MaxDB (SAP-Bibliothek - MaxDB)

 Anfang des Inhaltsbereichs

Komponentendokumentation MaxDB

Einsatzmöglichkeiten

MaxDB ist das SAP-eigene relationale Datenbanksystem, das Sie in SAP-Lösungen als kostengünstige Alternative zu den Datenbanken anderer Anbieter einsetzen können.

MaxDB ist Bestandteil der Standardauslieferung für die NetWeaver Full Use License.

Siehe auch:

Strukturlink Informationen zur Software

Strukturlink Download der Datenbanksoftware und Dokumentation

Dokumentation

Die folgende Tabelle enthält einen Überblick über alle Dokumentationen, die zum Datenbanksystem MaxDB verfügbar sind.

Installation

Strukturlink Installationshandbuch

Installation, Update und Deinstallation der Datenbanksoftware; Aktualisierung von Datenbankinstanzen inklusive Software

Installationsleitfaden MaxDB

NetWeaver-Installation <ABAP | Java> auf dem Betriebssystem <operating_system> mit der Datenbank MaxDB

nur für SAP-Kunden

nur auf Englisch

Sie finden diesen Leitfaden auf dem SAP Service Marktplatz unter der Adresse service.sap.com/installNW2004s. Weitere Informationen finden Sie im SAP-Hinweis 767598.

Upgrade-Leitfaden MaxDB

Upgrade von MaxDB auf die Version 7.6.00: <UNIX / Windows>

nur für SAP-Kunden

nur auf Englisch

Sie finden diesen Leitfaden auf dem SAP Service Marktplatz unter der Adresse service.sap.com/upgradeNW2004s. Weitere Informationen finden Sie im SAP-Hinweis 767598.

Grundwissen

Strukturlink Konzepte des Datenbanksystems

Informationen zum Datenbanksystem, Technische Systemlandschaft, Anlegen und Konfigurieren einer Datenbankinstanz, Verwaltung, Überwachung, Performance, Fehlersuche, Entwicklung von Datenbankanwendungen

Strukturlink Glossar

Begriffe des Datenbanksystems

Sie können dieses alphabetische sortierte Glossar als Einstiegspunkt in die Dokumentation verwenden.

Strukturlink SQL-Referenzhandbuch

SQL-Anweisungen und ihre Syntax, Systemtabellen, Besonderheiten im SQL-Modus ORACLE

Strukturlink Meldungen

Liste aller Fehlermeldungen und Rückmeldungen, sortiert nach Meldungsnummer

Strukturlink MaxDB-Sicherheitsleitfaden

Empfohlene Sicherheitsmaßnahmen für das Datenbanksystem

SAP Technical Operations Manual, Strukturlink Datenbankverwaltung für MaxDB

Überblick über die wichtigsten Verwaltungsaufgaben für MaxDB in SAP-Systemen

Strukturlink High Availability for the MaxDB Database

Bedingungen zur Gewährleistung hoher Verfügbarkeit einer MaxDB-Datenbankinstanz in einem SAP-System

Tutorials

Strukturlink Tutorial Datenbankverwaltung

Beschreibt ausgewählte Aufgaben zur Verwaltung von Datenbankinstanzen mit Hilfe des Werkzeugs Database Manager CLI.

Strukturlink SQL-Tutorial

Zeigt Beispiele für die vom Datenbanksystem MaxDB verwendete Structured Query Language (SQL).

Strukturlink Loader-Tutorial

Zeigt Beispiele für die Kommandos des Werkzeugs Loader zum Exportieren und Importieren von Daten.

Werkzeuge

Database Manager

● Strukturlink Database Manager GUI

● Strukturlink Database Manager CLI

Anlegen und Verwalten von Datenbankinstanzen

● grafische Benutzeroberfläche

● Kommandozeile

Strukturlink Database Analyzer

Analyse der Performance von Datenbankinstanzen

Strukturlink Loader

Exportieren und Importieren von Daten

Query Tools

● Strukturlink SQL Studio

● Strukturlink Web SQL Studio

● Strukturlink SQLCLI

Datenanfrage und Datenbearbeitung mit SQL

● grafische Benutzeroberfläche

● web-basierte Benutzeroberfläche

● Kommandozeile

Strukturlink Synchronization Manager

Synchronisieren von Tabelleninhalten von zwei oder mehr Datenbankinstanzen

Strukturlink Utilities

Event-Dispatcher

XCONS

XUSER

X-Server

Schnittstellen

Strukturlink ODBC-Handbuch

Grundlagen und Besonderheiten des MaxDB-ODBC-Treibers

Strukturlink SQLDBC-Handbuch

SQL Database Connectivity für die Entwicklung von Anwendungen und Schnittstellen für MaxDB

Strukturlink Java-Handbuch

Beschreibung des MaxDB JDBC-Treibers und der Programmierschnittstellen für Database Manager und Loader für die Entwicklung von Datenbankanwendungen mit Java

Strukturlink Perl-Handbuch

Beschreibung der Programmierschnittstellen für SQL, Database Manager und Loader für die Entwicklung von Datenbankanwendungen mit Perl

Strukturlink Python-Handbuch

Beschreibung der Programmierschnittstellen für SQL, Database Manager und Loader für die Entwicklung von Datenbankanwendungen mit Python

Strukturlink PHP-Handbuch

Beschreibung der MaxDB-PHP-Softwareerweiterung für die Entwicklung von Datenbankanwendungen mit PHP

Strukturlink WebDAV

Beschreibung des Zugriffs auf eine Dokumentenablage in einer MaxDB-Datenbankinstanz mit dem MaxDB-WebDAV-Servlet

Strukturlink Backint for MaxDB

Beschreibung der Backint for MaxDB-Schnittstelle für externe Sicherungswerkzeuge

Entwicklung

SAP Developer Guide, Strukturlink Developing on Database MaxDB

Entwickeln von Datenbankanwendungen für MaxDB

Strukturlink Entwicklungsumgebung

Verwendung der Entwicklungsumgebung zum Erstellen von MaxDB-Software aus dem Quelltext

Strukturlink Web Based Problem Tracking System

Web-Interface zum Problem Tracking System (PTS) für die Dokumentation von Problemmeldungen zur Datenbanksoftware

Datenbankverwaltung im CCMS

Strukturlink Datenbankverwaltung im CCMS: MaxDB

Analyse und Überwachung einer MaxDB-Datenbankinstanz über das SAP-System, Einplanung von Aktionen, Alert-Monitoring

Ende des Inhaltsbereichs


Installation (SAP-Bibliothek - Installation)

Komponentendokumentation Installation

Titel der Dokumentation

Inhalt

Installationshandbuch

Installation, Update und Deinstallation der Datenbanksoftware; Aktualisierung von Datenbankinstanzen inklusive Software

Installationsleitfaden MaxDB

NetWeaver-Installation <ABAP | Java> auf dem Betriebssystem <operating_system> mit der Datenbank MaxDB

nur für SAP-Kunden

nur auf Englisch

Sie finden diesen Leitfaden auf dem SAP Service Marktplatz unter der Adresse service.sap.com/installNW2004s . Weitere Informationen finden Sie im SAP-Hinweis 767598.

Upgrade-Leitfaden MaxDB

Upgrade von MaxDB auf die Version 7.6.00: <UNIX / Windows>

nur für SAP-Kunden

nur auf Englisch

Sie finden diesen Leitfaden auf dem SAP Service Marktplatz unter der Adresse service.sap.com/upgradeNW2004s . Weitere Informationen finden Sie im SAP-Hinweis 767598.


Installationshandbuch (SAP-Bibliothek - Installation)

Komponentendokumentation Installationshandbuch

Einsatzmöglichkeiten

Diese Dokumentation beschreibt die Grundlagen für die Installation und Deinstallation von MaxDB-Software, das Anlegen von Datenbankinstanzen sowie Updates der Datenbanksoftware und die Aktualisierung von Datenbankinstanzen auf den von MaxDB unterstützten Betriebssystemplattformen.

Insbesondere werden folgende Programme beschrieben:

● SDBSETUP: siehe Verwenden des Installation Manager

● SDBINST für die Installation/Update von Installationsprofilen sowie von einzelnen Softwarekomponenten unter Berücksichtigung der zwischen ihnen bestehenden Abhängigkeiten

● SDBUNINST für die Deinstallation von Softwarekomponenten unter Berücksichtigung der zwischen ihnen bestehenden Abhängigkeiten

● SDBUPD für die Aktualisierung von Datenbankinstanzen inklusive Server-Software

Die Beschreibung der Aktualisierung von Datenbankinstanzen inklusive Server-Software gilt auch für Datenbankinstanzen in SAP-Systemen.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems . Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Einschränkungen

Für die Installation/Deinstallation von MaxDB-Software in SAP-Systemen ist diese Dokumentation nicht relevant. Die Installation/Deinstallation der für SAP-Systeme erforderlichen MaxDB-Software ist in SAP-spezifischen Leitfäden beschrieben. Diese Leitfäden finden SAP-Kunden auf dem SAP-Service-Marktplatz unter service.sap.com/installNW2004s und service.sap.com/upgradeNW2004s . Weitere Informationen finden SAP-Kunden im SAP-Hinweis 767598.

Einführungshinweise

Die Programme SDBSETUP, SDBINST, SDBUNINST und SDBUPD sind Bestandteil des Datenbank-Softwarepakets.

Open-Source-Benutzer können die gesamte Datenbanksoftware von der MaxDB-Website unter dev.mysql.com/downloads/maxdb herunterladen.

SAP Kunden erhalten die MaxDB-Software mit der SAP-Installations-CD oder über den SAP-Service-Marktplatz unter service.sap.com.

Die nachfolgende Beschreibung basiert auf der Verwendung der online verfügbaren Software auf der MaxDB-Website und auf dem SAP-Service-Marktplatz.

Siehe auch:

Detailinformationen

Konzepte des Datenbanksystems, Strukturlink Unterstützte Betriebssysteme und Architekturen, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Glossar, Strukturlink Syntaxnotation


Verwenden des Installation Manager (SAP-Bibliothek - Installation)

Funktionsdokumentation Verwenden des Installation Manager

Verwendung

Der Installation Manager für die MaxDB-Software ist ein Werkzeug mit grafischer Oberfläche, mit dem Sie die gesamte MaxDB-Software oder einzelne Softwarekomponenten installieren und Datenbankinstanzen anlegen, aktualisieren und deinstallieren können.

Mit Hilfe des Installation Manager können Sie einfach und schnell eine vorkonfigurierte Desktop-Installation durchführen. Sie können aber auch den Expertenmodus wählen und die vorgeschlagenen Parameterwerte, z. B. für die Datenbankgröße, Memory-Größe, Anzahl der CPUs, Log-Einstellungen und das automatische Starten der Datenbankinstanz Ihren Erfordernissen anpassen.

Auch beim Aktualisieren ihrer vorhandenen MaxDB-Software und Datenbankinstanzen werden Sie vom Installation Manager geführt.

Sie können gleichzeitig mit der Installation der Software eine Datenbankinstanz anlegen. Sie können den Installation Manager aber auch verwenden, um Datenbankinstanzen für eine vorhandene Softwareversion zu einem späteren Zeitpunkt anzulegen.

Durch die Auswahl von Optionen können Sie zusammen mit der Softwareinstallation eine Demo-Datenbank anlegen und, wenn gewünscht mit den in der Dokumentation verwendeten Beispieldaten füllen. Sie schaffen sich so die Möglichkeit, die in der MaxDB-Dokumentation aufgeführten Beispiele Schritt für Schritt nachzuvollziehen und analoge Ergebnisse zu erhalten.

Für das Anlegen von Datenbankinstanzen wählen Sie Vorlagen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank, Strukturlink Vorlagen für Datenbankinstanzen.

Voraussetzungen

Voraussetzungen für die Verwendung des Installation Manager

Plattform | wxWidget-Software | weitere Software
MS Windows X86_32 | wxMSW | -
MS Windows X86_64, IA64 | noch nicht unterstützt | -
Linux X86_32 | wxGTK2 | Gtk+ >= 2.0 glibc ≥ 2.3.3 mit TLS-Unterstützung (Thread Local Storage) Wenn auf Ihrem System gcc 4.x installiert ist, benötigen Sie unter Umständen zusätzlich libstdc-Kompatibilitätsbibliotheken für gcc 3.2.x oder gcc 3.3.x.
*Linux X86_64 | wxGTK2 | glibc ≥ 2.3.3 Gtk+ >= 2.0
*Linux IA64 | wxGTK2 | glibc ≥ 2.3.3 Gtk+ >= 2.0
*Linux PPC_64 | wxGTK2 | glibc ≥ 2.3.3 Gtk+ >= 2.0
SUN Solaris SPARC | wxGTK | Gtk+ 1.2 (ab Solaris 9 enthalten)
IBM AIX PPC_64 | wxGTK (Gtk statisch gelinkt) | X11 Laufzeit
HP-UX HPPA | wxGTK (Gtk statisch gelinkt) | X11 Laufzeit
HP-UX IPF | wxGTK (Gtk statisch gelinkt) | X11 Laufzeit

*Auf Linux muss der root-Benutzer außerdem die Berechtigung haben, ein Display zu öffnen.

Funktionsumfang

● Installation von MaxDB-Software und Anlegen einer-Datenbankinstanz

● Anlegen einer Datenbankinstanz für eine vorhandene Softwareversion

● Update von MaxDB-Software

● Upgrade von MaxDB-Datenbankinstanzen einschließlich Software

● Deinstallation von MaxDB-Software und -Datenbankinstanzen

Aktivitäten

Installation/Upgrade auf Microsoft Windows

Installation/Upgrade auf UNIX/Linux

Datenbankinstanz nachträglich anlegen

Demo-Datenbankinstanz DEMODB anlegen

Deinstallation

Datenbankinstanz löschen


Installation/Upgrade auf UNIX/Linux (SAP-Bibliothek - Installation)

Vorgehensweisen Installation/Upgrade auf UNIX/Linux

Voraussetzungen

● Siehe Voraussetzungen im Abschnitt Verwenden des Installation Manager.

● Sie haben die Datenbanksoftware in ein lokales Verzeichnis entpackt (Siehe: Konzepte des Datenbanksystems, Strukturlink Download).

Installation Manager auf UNIX/Linux aufrufen

...

...

1. Öffnen Sie eine root-Shell.

Sie können auch kdesu verwenden, wenn es auf Ihrem System installiert ist.

2. Wechseln Sie in das lokale Verzeichnis, in das Sie die Datenbanksoftware entpackt haben.

3. Geben Sie folgendes Kommando ein:

./SDBSETUP

4. Wählen Sie Start installation/upgrade.

5. Folgen Sie den Anweisungen des Installation Manager.

6. Nach Abschluss der Installation verlassen Sie die root-Shell.

7. Aktualisieren Sie die Umgebungsvariable PATH für den Betriebssystembenutzer, der das MaxDB-Datenbanksystem betreiben wird, z.B.

export PATH=/opt/sdb/programs/bin:$PATH

Wenn erforderlich, fügen Sie sie auch dem Login-Profil des Betriebssystembenutzers hinzu (z. B. im Home-Verzeichnis des Benutzers):

.bash_profile

Siehe auch:

Verzeichnisse

Installierte Softwarekomponenten anzeigen


Installation/Upgrade auf Microsoft Windows (SAP-Bibliothek - Installation)

Vorgehensweisen Installation/Upgrade auf Microsoft Windows

Voraussetzungen

● Siehe Voraussetzungen im Abschnitt Verwenden des Installation Manager.

● Sie haben die Datenbanksoftware heruntergeladen und in ein lokales Verzeichnis entpackt (Siehe: Konzepte des Datenbanksystems, Strukturlink Download).

Installation mit dem Installation Manager

...

1. Wechseln Sie in das lokale Verzeichnis, in dem Sie die Datenbanksoftware entpackt haben.

2. Öffnen Sie das Programm SDBSETUP.exe, um den Installation Manager zu starten.

3. Wählen Sie Start installation/upgrade.

4. Folgen Sie den Anweisungen des Installation Manager.

5. Nach Abschluss der Installation starten Sie das System neu.

Siehe auch:

Verzeichnisse

Installierte Softwarekomponenten anzeigen


Datenbankinstanz nachträglich anlegen (SAP-Bibliothek - Installation)

Vorgehensweisen Datenbankinstanz nachträglich anlegen

Voraussetzungen

Sie haben die Datenbanksoftware installiert.

Vorgehensweise

...

1. Öffnen Sie das Programm SDBSETUP.exe, um den Installation Manager zu starten.

2. Wählen Sie Start installation/upgrade.

3. Folgen Sie den Anweisungen des Installation Manager.

4. Wählen Sie im Bild Choose installation type die Option Install Software and create database instance.

5. Folgen Sie weiter den Anweisungen des Installation Manager.

Ergebnis

Die Datenbankinstanz und die datenbankspezifischen Verzeichnisse wurden angelegt.

Siehe auch:

Verzeichnisse


Demo-Datenbankinstanz DEMODB anlegen (SAP-Bibliothek - Installation)

Vorgehensweisen Demo-Datenbankinstanz DEMODB anlegen

Verwendung

Für Demonstrationszwecke wurde eine Demo-Datenbankinstanz entwickelt. Diese Demo-Datenbankinstanz mit dem Namen DEMODB ist Grundlage für die Beispiele in der MaxDB-Dokumentation.

Wenn Sie die Demo-Datenbankinstanz nutzen wollen, müssen Sie diese zunächst anlegen und mit den Demo-Daten füllen. Verwenden Sie dazu den Installation Manager.

Einige Parameter der Demo-Datenbankinstanz wurden speziell für Übungszwecke eingestellt. Wir empfehlen deshalb, diese Demo-Datenbankinstanz nicht für ein Produktivsystem zu verwenden.

Vorgehensweise

Öffnen Sie den Installation Manager für das Anlegen einer Datenbankinstanz.

...

1. Wählen Sie die Option Start installation/upgrade.

2. Sie befinden sich im Bild Select component group to be installed.
Wählen Sie die Option Server + Client und anschließend Next.

3. Sie befinden sich im Bild Choose installation type.
Wählen Sie die Option Install software and create database und anschließend Next.

4. Sie befinden sich im Bild Select database configuration.
Wählen Sie die Option Desktop PC/Laptop und anschließend Next.

5. Sie befinden sich im Bild Database configuration.

○ Geben Sie für Database name DEMODB ein.

○ Wenn Sie die Demo-Daten laden wollen, lassen Sie die Option Load Tutorial Data markiert. Sie benötigen die Demo-Daten z.B. für die Arbeit mit dem Tutorial Datenbankverwaltung und dem Loader-Tutorial.
Wenn Sie die Demo-Daten nicht laden wollen, entfernen Sie die Markierung für die Option Load Tutorial Data. Sie erhalten sich so die Möglichkeit, die Demo-Daten manuell in die Datenbankinstanz einzufügen, wie im SQL-Tutorial beschrieben.

○ Übernehmen Sie für User name den Wert DBADMIN und definieren Sie für User password den Wert SECRET. Geben Sie diesen Wert im Feld Confirm password erneut ein.

6. Bestätigen Sie nachfolgend alle Vorschlagswerte des Installation Manager für das Anlegen der Datenbankinstanz.

Ergebnis

Sie verfügen nun über eine vollständige Datenbankinstanz, mit der sich die Übungen in der Dokumentation detailliert nachvollziehen lassen:

● Name der Demo-Datenbankinstanz: DEMODB

● Name/Kennwort des Datenbanksystemadministrators: DBADMIN/SECRET

● Name/Kennwort eines Datenbankbenutzers: MONA/RED

● Schema: HOTEL

● Weitere Demo-Daten: Strukturlink Objekte im Schema HOTEL

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank

Strukturlink Tutorial Datenbankverwaltung

Strukturlink Loader-Tutorial


Deinstallation (SAP-Bibliothek - Installation)

Vorgehensweisen Deinstallation

Vorgehensweise

...

1. Öffnen Sie das Programm SDBSETUP.exe, um den Installation Manager zu starten.

2. Wählen Sie Remove MaxDB components.

3. Folgen Sie den Anweisungen des Installation Manager.

4. Nach Abschluss der Deinstallation starten Sie das System neu.


Datenbankinstanz löschen (SAP-Bibliothek - Installation)

Vorgehensweisen Datenbankinstanz löschen

Verwendung

...

1. Öffnen Sie das Programm SDBSETUP.exe, um den Installation Manager zu starten.

2. Wählen Sie Remove MaxDB components.

3. Wählen Sie unter Base ® Server Utilities das Paket Database Kernel derjenigen Datenbankinstanz aus, die Sie löschen wollen und wählen Sie Next.

4. Folgen Sie weiter den Anweisungen des Installation Manager.


Installation, Upgrade und Deinstallation auf der Kommandozeile (SAP-Bibliothek - Installation)

Funktionsdokumentation Installation, Upgrade und Deinstallation auf der Kommandozeile

Verwendung

Sie können die gesamte MaxDB-Software oder einzelne Softwarekomponenten mit Kommandozeilenprogrammen installieren, Software und Datenbankinstanzen aktualisieren und deinstallieren.

Hierfür stehen Ihnen folgende Kommandozeilenprogramme zur Verfügung:

· SDBINST für die Installation/Update von Komponentengruppen, Installationsprofilen oder von einzelnen Softwarekomponenten unter Berücksichtigung der zwischen ihnen bestehenden Abhängigkeiten

· SDBUNINST für die Deinstallation von Softwarekomponenten unter Berücksichtigung der zwischen ihnen bestehenden Abhängigkeiten

· SDBUPD für die Aktualisierung von Datenbankinstanzen inklusive Server-Software

Die Beschreibung der Aktualisierung von Datenbankinstanzen inklusive Server-Software gilt auch für Datenbankinstanzen in SAP-Systemen.

Funktionsumfang

Installation und Update der Datenbanksoftware

Deinstallation der Datenbanksoftware

Aktualisierung von Datenbankinstanzen inklusive Server-Software


Installation und Update der Datenbanksoftware (SAP-Bibliothek - Installation)

Hintergrunddokumentation Installation und Update der Datenbanksoftware

Einführungshinweise

Die Installation/Update der Datenbanksoftware können Sie interaktiv oder im Hintergrund ausführen.

Sie können vollständige Komponentengruppen, Installationsprofile oder nur einzelne Softwarekomponenten installieren/aktualisieren. Das Installationsprogramm erkennt, ob es sich um eine Erstinstallation oder ein Update handelt.

Der Installationsvorgang wird vom System protokolliert.

Bevor Sie mit der Installation/Update der Datenbanksoftware beginnen,

● stellen Sie sicher, dass die häufigsten Fehlerursachen für einen Abbruch von Installation/Update ausgeschlossen sind (Fehlerbehandlung).

● informieren Sie sich im folgenden über die Vor- und Nachteile der interaktiven und der Hintergrundinstallation

● bedenken Sie, ob Sie eine oder mehrere Datenbankinstanzen benötigen werden.

Für den Fall, dass Sie mehrere Datenbankinstanzen planen, empfehlen wir Ihnen, für jede Datenbankinstanz eine gesonderte (parallele) Softwareinstallation. Sie erleichtern sich damit spätere Aktualisierungen, da im Falle eines Fehlers nur eine Datenbankinstanz davon betroffen wäre.

● wählen Sie die geeignete Komponentengruppe oder das geeignete Installationsprofil aus oder entscheiden Sie, ob es im Sonderfall angeraten ist, anstelle der üblichen Installation eines Installationsprofils nur eine oder mehrere einzelne Softwarekomponenten zu installieren/aktualisieren. Allerdings ist die Installation einzelner Komponenten nur im Hintergrund möglich.

Wir empfehlen Ihnen, der Installation/Update mit Hilfe von Komponentengruppen oder Installationsprofilen immer den Vorrang zu geben. Sie können damit auf einfache und sichere Weise Datenbanksoftware-Installationen für jeden Zweck erhalten.

Siehe auch:

Verzeichnisse

Strukturlink Unterstützte Betriebssysteme und Plattformen

Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)

Interaktive Installation/Update

Bei der interaktiven Installation/Update installieren Sie vollständige Komponentengruppen oder Installationsprofile. Das Installationsprogramm SDBINST erfragt alle notwendigen Informationen und bietet Ihnen für die zu installierenden Software und die Installationspfade Vorschlagswerte und Optionen zur Auswahl an. Anschließend installiert das Programm die Softwarepakete und registriert sie.

Installation/Update im Hintergrund

Bei der Installation/Update im Hintergrund geben Sie mit Hilfe der Optionen für das Programm SDBINST zunächst alle notwendigen Informationen an. Der eigentliche Installationsvorgang läuft dann im Hintergrund ab.

Vorteile der Installation im Hintergrund

● Eine Installation/Upgrade im Hintergrund nimmt weniger Zeit in Anspruch.

● Sie haben die Möglichkeit, einzelne Softwarekomponenten zu installieren oder zu aktualisieren.

● Sie können durch die Einbettung in ein Aufrufskript identische Datenbanksoftware-Installationen auf verschiedenen Rechnern erzeugen.

Nachteile der Installation im Hintergrund

● Sie müssen in dem Aufrufskript alle benötigten Optionen richtig und vollständig angeben.

● Einige Optionen werden vom System erst zur Laufzeit aus den Softwarepaketen ermittelt. Damit kann das System die Vollständigkeit der Angaben nicht zu Beginn einer Installation prüfen. Es beginnt mit der Installation und bricht den Vorgang erst dann ab, wenn die fehlende Angabe benötigt wird.

Installation/Update von Komponentengruppen oder Installationsprofilen

Sie haben die Wahl zwischen verschiedenen Zusammenstellungen von Softwarekomponenten, wie sie für unterschiedliche Zwecke benötigt werden. Sie wählen die für Ihre Zwecke geeignete Komponentengruppe oder ein geeignetes Installationsprofil aus und müssen keinerlei Rücksicht auf notwendige Installationsreihenfolgen oder einander bedingende Inhalte von Softwarekomponenten nehmen, um eine funktionierende Softwareinstallation zu erhalten.

Die Standard-Installation/-Update des gesamten Datenbanksoftware-Pakets erhalten Sie mit der Komponentengruppe Server+Client oder mit dem Installationsprofil all.

Installation/Update von Softwarekomponenten

Sie installieren einzelne Komponenten der Datenbanksoftware, um einzelne Teile Ihrer Datenbanksoftware-Installation zu aktualisieren. Diese Form der Installation empfiehlt sich nur im Sonderfall.

Sie müssen dabei die zwischen einzelnen Softwarekomponenten bestehenden Abhängigkeiten beachten. Andernfalls erhalten Sie eine entsprechende Fehlermeldung und der Installationsvorgang wird vom System abgebrochen.

Installation der Softwarekomponente Precompiler (CPC <version>) im Hintergrund

Sie wollen nur den C++-Precompiler Ihrer vorhandenen Softwareinstallation aktualisieren. Sie starten die Installation der Softwarekomponente CPC SDK <version>. Das System erkennt, dass diese Komponente eine neue Version der Softwarekomponente CPC Base voraussetzt. Sie werden deshalb darauf hingewiesen, dass das Paket CPC SDK <version> vom Paket CPC Base abhängig ist und zuvor installiert werden muss. Die Installation wird abgebrochen.

Bei umfangreichen Abhängigkeiten müssen sie den Installationsprozess also mehrfach (mit jeweils einem anderen Installationspaket) neu beginnen.

Sie umgehen diese Probleme, indem Sie für das Beispiel das Installationsprofil C Precompiler installieren.

Siehe:

Installation/Update der Software auf UNIX

Installation/Update der Software auf Linux

Installation/Update der Software auf Microsoft Windows


Installation/Update der Software auf UNIX (SAP-Bibliothek - Installation)

Hintergrunddokumentation Installation/Update der Software auf UNIX

Verwendung

Sie installieren oder aktualisieren eine Komponentengruppe, ein Installationsprofil oder einzelne Komponenten der Datenbanksoftware.

Die nachfolgend beschriebene Vorgehensweise ist für Updates nur dann anzuwenden, wenn Sie Komponenten aktualisieren wollen, deren Software nicht im <dependent_path> der MaxDB-Installation abgelegt ist, oder wenn keine Datenbankinstanzen die zu aktualisierende Softwareinstallation verwenden.

Siehe auch:

Verzeichnisse

Wenn Sie Komponenten aktualisieren wollen, deren Software im <dependent_path> der MaxDB-Installation abgelegt ist und Datenbankinstanzen diese Softwareinstallation verwenden, dann müssen Sie die Datenbankinstanzen zusammen mit der Software aktualisieren (siehe: Aktualisierung von Datenbankinstanzen inklusive Server-Software). Andernfalls riskieren Sie, dass die Datenbankinstanzen nicht mehr mit der Datenbanksoftware kompatibel sind und sich deshalb nicht mehr starten lassen.

Der Installationsvorgang wird vom System protokolliert (Protokollierung).

Vorgehensweise

...

1. Entpacken Sie zunächst die Datenbanksoftware in ein lokales Verzeichnis.

Entpacken der Software auf UNIX

2. Entscheiden Sie nun, ob Sie eine interaktive Installation (nur möglich für Installationsprofile) oder eine Installation im Hintergrund durchführen möchten.

○ Interaktive Installation/Update auf UNIX

○ Installation/Update im Hintergrund auf UNIX

Zu den Vor- und Nachteilen dieser Installationsverfahren siehe
Installation und Update der Datenbanksoftware


Entpacken der Software auf UNIX (SAP-Bibliothek - Installation)

Vorgehensweisen Entpacken der Software auf UNIX

Vorgehensweise

...

1. Wählen Sie das Ihrer Betriebssystemarchitektur und der gewünschten Software entsprechende Paket aus.

Wenn Sie nur eine einzelne Softwarekomponente installieren oder aktualisieren wollen, wählen Sie eine Komponentengruppe oder ein Installationsprofil aus, das diese Softwarekomponente enthält.

Installation vom Software Distribution Center auf dem SAP Service Marketplace (service.sap.com/swdc, nur für SAP-Kunden)

○ Für den Strukturlink Datenbankinstanztyp OLTP wählen Sie
Download ® Database Patches ® MaxDB and SAP DB ® MaxDB | MaxDB 64-bit ® MaxDB <version> ® <os> ®
MAXDB<version>_<build>-<GUID>.SAR

○ Für den Strukturlink Datenbankinstanztyp liveCache (SAP-System APO) wählen Sie
Download ® Support Packages and Patches ® Entry by Application Group ® SAP Application Components ® SAP APO ® SAP APO <apo_version> ® Entries by Component ® APO LC ® APO LC<version>/LCAPPS<apo_version> ® <os> ®
LC<version>A<apo_version>_<apo_build>-<GUID>.SAR

Installation von der MaxDB-Website dev.mysql.com/downloads/maxdb/7.6.00.html

○ Nur Datenbankinstanztyp OLTP:
Wählen Sie das gewünschte Softwarepaket für Ihr Betriebssystem:
maxdb-<inst_profile>-<os>-<32|64>bit-<arch>-<version>_<build>.tgz

2. Kopieren Sie das Softwarepaket in ein beliebiges lokales Verzeichnis.

3. Entpacken Sie die Software mit folgendem Kommando:

Bei Installation vom SAP Service Marketplace:

SAPCAR –xvf MAXDB<version>_<build>-<GUID>.SAR

Bei Installation von der MaxDB-Website:

tar xvzf maxdb-<inst_profile>-<os>-<32|64>bit-<arch>-<version>_<build>.tgz

Ergebnis

Das System legt in diesem lokalen Verzeichnis

· für OLTP-Software ein Unterverzeichnis
maxdb-<inst_profile>-<os>-<32|64>bit-<arch>-<version>

· für SAP liveCache-Software ein Unterverzeichnis
apo<apo_version>_livecache-<os>-<arch>-<version>

an und legt darin die Software ab.

Siehe auch:

Komponentengruppen, Installationsprofile, Verzeichnisse

Glossar, Strukturlink Variablen in der Dokumentation

Am einfachsten installieren Sie die Software nun mit Hilfe des Installation Manager (GUI) und rufen dazu das Programm SDBSETUP auf.
Siehe: Verwenden des Installation Manager

Sie können aber auch das Installationsprogramm SDBINST auf der Kommandozeile ausführen.
Siehe: Installation, Upgrade und Deinstallation auf der Kommandozeile


Interaktive Installation/Update auf UNIX (SAP-Bibliothek - Installation)

Vorgehensweisen Interaktive Installation/Update auf UNIX

Verwendung

Sie installieren/aktualisieren Komponentengruppen oder Installationsprofile der Datenbanksoftware unter Verwendung des Programms SDBINST auf dem Betriebssystem UNIX. Alle dafür notwendigen Informationen werden während des Installationsvorganges vom Programm abgefragt.

Wenn Sie eine vorhandene Datenbanksoftware-Installation aktualisieren wollen, ist die Vorgehensweise abhängig davon, ob die Startversion kleiner als 7.5.00 oder größer/gleich 7.5.00 ist.

Wenn die Startversion kleiner ist als 7.5.00, dann müssen Sie vor dem Installations-/Updatevorgang den Strukturlink X-Server und alle Datenbankinstanzen stoppen. Beachten Sie, dass Sie damit die Kommunikation von Clients zu allen lokalen Datenbankinstanzen unterbrechen. Wenn die Startversion größer oder gleich 7.5.00 ist, unterstützt die X-Server-Software ein Update bei laufendem Betrieb des X-Server. Das Stoppen des X-Server und aller Datenbankinstanzen ist deshalb nicht mehr notwendig. Sie müssen jedoch jene Datenbankinstanzen stoppen, die dem zu aktualisierenden Installationsverzeichnis zugeordnet sind.

Siehe auch:

Komponentengruppen

Installationsprofile

Voraussetzungen

● Sie befinden sich in einer root-Shell.

● Sie haben das Installationspaket heruntergeladen und in einem beliebigen lokalen Verzeichnis entpackt, siehe: Entpacken der Software auf UNIX.

Vorbereitende Schritte

Wenn die nachfolgend geschilderten Bedingungen für Ihr System zutreffen, müssen Sie vor einer Neuinstallation noch die genannten Schritte ausführen:

● Das Installationsprogramm wird die erforderlichen Services sql6 und sapdbni72 in die Datei /etc/services eintragen, wenn sie dort noch nicht vorhanden sind. Wenn für Ihr System die Services zentral im Netz verwaltet werden (NIS), müssen Sie diese wie folgt dort eintragen:
sql6 7210/tcp
sapdbni72 7269/tcp

● Bei der Installation muss die Datenbanksoftware einem speziellen Betriebssystembenutzer <sdb_user> als Eigentümer der Software sowie der Gruppe <sdba_group> zugeordnet werden.
(Siehe: Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -benutzergruppen (UNIX/Linux) für Software ab Version 7.5.00).

Wenn Benutzergruppen und Eigentümer auf Ihrem Rechner lokal verwaltet werden, dann empfehlen wir Ihnen, die Benutzergruppe und den Eigentümer vor Beginn des Installationsvorganges anzulegen. Sie können diese aber auch während des Installationsvorganges anlegen.
Wenn Benutzergruppen und Eigentümer für Ihr System zentral im Netz verwaltet werden, müssen Sie diese dort vor Beginn der Installation anlegen. Erläuterungen über das Anlegen von Betriebssystembenutzern und Benutzergruppen finden Sie in Ihrer Betriebssystemdokumentation.

Der spezielle Betriebssystembenutzer darf sich nicht an das Betriebssystem anmelden. Entziehen sie ihm deshalb diese Berechtigung. Hinweise dazu finden Sie in Ihrer Betriebssystemdokumentation (lock account).

Die primäre Gruppe (primary group) des Eigentümers der Datenbanksoftware ist die Administratorengruppe.

Für SAP-Systeme müssen Sie für den Eigentümer <sdb_user> und die Gruppe <sdba_group> die Namen sdb und sdba verwenden.

Aus Gründen der Übersichtlichkeit und für einen eventuellen Supportfall empfehlen wir, auch in anderen Systemen die Namen sdb und sdba für den Eigentümer und die Gruppe zu verwenden.

● Wenn der Pfad <independent_program_path>/bin noch nicht in Ihre Umgebungsvariable PATH eingetragen ist, fügen Sie ihn jetzt hinzu. (Hinweise zum Setzen von Umgebungsvariablen finden Sie in Ihrer Betriebssystemdokumentation.)

Vorgehensweise

...

1. Wenn Sie eine vorhandene Datenbanksoftware-Installation aktualisieren wollen,

○ stoppen Sie gegebenenfalls jede einzelne Datenbankinstanz, die dem zu aktualisierenden Installationsverzeichnis zugeordnet ist, mit dem Kommando
dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_offline

○ stoppen Sie gegebenenfalls das Programm X-Server (Prozess vserver) mit dem Kommando
x_server stop

Für eine Neuinstallation beginnen Sie mit Schritt 2.

2. Wechseln Sie in das Verzeichnis
maxdb-<inst_profile>-<os>-<32|64>bit-<arch>-<version>_<build>,
das die Installationssoftware enthält.

3. Geben Sie ./SDBINST ein, um das Installations-/Update-Programm zu starten.

4. Das System schlägt Ihnen Komponentengruppen vor. Geben Sie die ID der gewünschten Komponentengruppe ein. Bestätigen Sie Ihre Wahl.

5. Wenn Sie die Komponentengruppe Custom gewählt haben, dann schlägt das System Ihnen nun Installationsprofile vor. Geben Sie die entsprechende ID an. Bestätigen Sie ihre Wahl.

6. Bei einer Erstinstallation oder einem Update von einer Softwareversion < 7.5.00 werden Sie vom System aufgefordert, folgende Angaben zu machen:

○ den speziellen Betriebssystembenutzer <sdb_user>, also den Eigentümer der Datenbanksoftware

○ die Gruppe <sdba_group>

Bei Installation/Update älterer Softwareversionen werden Sie vom System aufgefordert, die Gruppe <group> und den Eigentümer <owner> der Datenbanksoftware anzugeben.

Wenn die Gruppe und der Eigentümer bereits angelegt sind, geben Sie die gültigen Werte an und bestätigen diese. Das System vergleicht Ihre Angaben mit den lokal oder im Netz vorhandenen Werten. Falls Ihre Angaben mit diesen Werten nicht übereinstimmen, bricht die Installation ab.

Wenn die Gruppe und der Eigentümer noch nicht angelegt sind, werden Sie vom System gefragt, ob Sie diese anlegen wollen. Geben Sie die gewünschten Werte an oder bestätigen Sie die Systemvorschläge. Ihre Eingabe legt die Gruppe und den Eigentümer lokal auf Ihrem Rechner an.

7. Das System prüft nun, ob es aktualisierbare Installationen der Datenbanksoftware auf Ihrem Rechner gibt.

Wenn dies der Fall ist, werden alle vorhandenen Installationen aufgelistet.

○ Wenn Sie eine vorhandene Installation aktualisieren wollen, geben Sie die ID der betreffenden Installation an.
Anschließend wird vom System die unter dem <independent_program_path> abgelegte Software aktualisiert. In Abhängigkeit von der gewählten Software wird auch die unter dem <dependent_path> abgelegte Software aktualisiert, wenn das Installationspaket neuere Versionen darin vorhandener Dateien enthält.

○ Wenn Sie eine Neuinstallation der Datenbanksoftware parallel zur vorhandenen Installation durchführen wollen, geben Sie none an. Sie erhalten dann die Möglichkeit, einen neuen Installationspfad anzugeben. Definieren Sie einen Installationspfad parallel zum vorhandenen Installationspfad.

Wenn es auf Ihrem Rechner noch keine Installation der Datenbanksoftware gibt, wird nun die Datenbanksoftware installiert. Gegebenenfalls werden Sie vom System aufgefordert, folgende Pfade anzugeben:

○ Pfad für die Ablage der Daten, Konfigurationen und Arbeitsverzeichnisse der Datenbankinstanzen und -anwendungen (Vorschlagswert des Systems ist /var/opt/sdb/data)

○ Pfad für die Ablage der von den Datenbankinstanzen und -anwendungen gemeinsam genutzten Programme und Bibliotheken (Vorschlagswert des Systems ist /opt/sdb/programs)

○ Pfad für die Ablage der von der Datenbankversion abhängigen Server-Software
Diese Pfadangabe muss eindeutig sein. Es können viele Verzeichnisse mit verschiedenen Versionen nebeneinander existieren (Vorschlagswert des Systems ist /opt/sdb/<version>).

Geben Sie die gewünschten Pfade an oder bestätigen Sie die Systemvorschläge.

8. Wenn es bislang auf Ihrem Rechner noch keine Installation der Datenbanksoftware gab, erweitern Sie für alle Benutzer, die das Datenbanksystem benutzen wollen, die Umgebungsvariable PATH um den Eintrag <independent_program_path>/bin.

Sie erhalten eine Meldung über den erfolgreichen Abschluss der Installation.

Ergebnis

Die Softwarepakete wurden installiert und registriert. Sie können das Ergebnis Ihrer Installation anhand des Protokolls überprüfen.

Sie können nun mit Hilfe des Installation Manager, Database Manager CLI oder Database Manager GUI Datenbankinstanzen anlegen.

Siehe auch:

Protokollierung

Datenbankinstanz nachträglich anlegen

Database Manager CLI, Strukturlink db_create

Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz


Installation/Update im Hintergrund auf UNIX (SAP-Bibliothek - Installation)

Vorgehensweisen Installation/Update im Hintergrund auf UNIX

Verwendung

Sie installieren/aktualisieren Komponentengruppen, Installationsprofile oder einzelne Komponenten der Datenbanksoftware unter Verwendung des Programms SDBINST auf dem Betriebssystem UNIX. Alle dafür notwendigen Informationen spezifizieren Sie auf der Kommandozeile zusammen mit dem Kommando zum Starten des Installationsprogramms.

Wenn Sie eine vorhandene Datenbanksoftware-Installation aktualisieren wollen, ist die Vorgehensweise abhängig davon, ob die Startversion kleiner als 7.5.00 oder größer/gleich 7.5.00 ist.

Wenn die Startversion kleiner ist als 7.5.00, dann müssen Sie vor dem Installations-/Updatevorgang den Strukturlink X-Server und alle Datenbankinstanzen stoppen. Beachten Sie, dass Sie damit die Kommunikation von Clients zu allen lokalen Datenbankinstanzen unterbrechen. Wenn die Startversion größer oder gleich 7.5.00 ist, unterstützt die X-Server-Software ein Update bei laufendem Betrieb des X-Server. Das Stoppen des X-Server und aller Datenbankinstanzen ist deshalb nicht mehr notwendig. Sie müssen jedoch jene Datenbankinstanzen stoppen, die dem zu aktualisierenden Installationsverzeichnis zugeordnet sind.

Voraussetzungen

· Sie sind auf Ihrem Rechner als Benutzer root angemeldet.

· Sie haben die erforderliche Software entpackt (Entpacken der Software auf UNIX).

Vorbereitende Schritte

Wenn die nachfolgend geschilderten Bedingungen für Ihr System zutreffen, müssen Sie vor einer Neuinstallation noch die genannten Schritte ausführen:

● Das Installationsprogramm wird die erforderlichen Services sql6, sql30 und sapdbni72 in die Datei /etc/services eintragen, wenn sie dort noch nicht vorhanden sind. Wenn für Ihr System die Services zentral im Netz verwaltet werden (NIS), müssen Sie diese dort wie folgt eintragen:
sql6 7210/tcp
sql30 7200/tcp
sapdbni72 7269/tcp

● Bei der Installation muss die Datenbanksoftware einem speziellen Betriebssystembenutzer (<sdb_user>) als Eigentümer der Software sowie der Gruppe (<sdba_group>) zugeordnet werden. Gruppe und Eigentümer sollten zuvor definiert worden sein. Nur Benutzer mit den entsprechenden Rechten können später Datenbankinstanzen erzeugen (siehe auch Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux) für Softwareversionen ab 7.5.00).

● Wenn der Pfad <independent_program_path>/bin noch nicht in Ihre Umgebungsvariable PATH eingetragen ist, fügen Sie ihn jetzt hinzu.

Vorgehensweise

...

1. Wenn Sie eine vorhandene Datenbanksoftware-Installation aktualisieren wollen,

○ stoppen Sie gegebenenfalls jede einzelne Datenbankinstanz, die dem zu aktualisierenden Installationsverzeichnis zugeordnet ist, mit dem Kommando
dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_offline

○ stoppen Sie gegebenenfalls das Programm X-Server (Prozess vserver) mit dem Kommando
x_server stop

Für eine Neuinstallation beginnen Sie mit Schritt 2.

2. Für die OLTP-Software starten Sie den Installations-/Updatevorgang mit folgendem Kommando:
./SDBINST [-b | --batch] -component_group <component_group> | -profile <inst profile>[,<inst_profile2>...] | -package <package_name>[,<package_name2...>] -indep_data <independent_data_path> - indep_prog <independent_program_path> -depend <dependent_path> [-archive_dir <directory>] [-o <sdb_user> -g <sdba_group>]

Für die SAP liveCache-Software (nur im SAP-System APO) starten Sie den Installations-/Updatevorgang mit folgendem Kommando:

○ Für das Installationsprofil APO liveCache
./SDBINST [-b] -profile "APO LiveCache" -indep_data <independent_data_path> -indep_prog <independent_program_path> -depend <dependent_path> [-o <sdb_user> -g <sdba_group>]

○ Für die Softwarekomponente APO LC APPS
./SDBINST [-b] -package "APO LC APPS" -depend <dependent_path>

Den speziellen Betriebssystembenutzer <sdb_user> und die Gruppe <sdba_group> müssen Sie nur bei der Erstinstallation oder dem Upgrade von einer Softwareversion < 7.5.00 angeben.

Zur Bedeutung der Optionen siehe auch Übersicht der Optionen für das Programm SDBINST.

Namen von Installationsprofilen und Softwarekomponenten, die Leerzeichen enthalten, müssen im Installationskommando in doppelte Anführungszeichen gesetzt werden.

Bei bestimmten Installationsprofilen oder Softwarekomponenten ist die Angabe der Optionen –indep_prog, -indep_data und –depend nicht notwendig. Wenn Sie diese Optionen dennoch angeben, werden sie vom System ignoriert. Informationen dazu finden Sie ebenfalls in der Übersicht der Optionen.

Sie erhalten eine Meldung über den erfolgreichen Abschluss der Installation.

Ergebnis

Die Softwarepakete wurden installiert und registriert. Sie können das Ergebnis Ihrer Installation anhand des Protokolls überprüfen.

Sie können nun mit Hilfe des Installation Manager, Database Manager CLI oder Database Manager GUI Datenbankinstanzen anlegen.

Siehe auch:

Protokollierung

Datenbankinstanz nachträglich anlegen

Database Manager CLI, Strukturlink db_create

Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz


Installation/Update der Software auf Linux (SAP-Bibliothek - Installation)

Vorgehensweisen Installation/Update der Software auf Linux

Verwendung

Sie installieren oder aktualisieren eine Komponentengruppe, ein Installationsprofil oder eine Komponente der Datenbanksoftware.

Die nachfolgend beschriebene Vorgehensweise ist für Updates nur dann anzuwenden, wenn Sie Komponenten aktualisieren wollen, deren Software nicht im <dependent_path> der MaxDB-Installation abgelegt ist, oder wenn keine Datenbankinstanzen die zu aktualisierende Softwareinstallation verwenden.

Siehe auch:

Verzeichnisse

Wenn Sie Komponenten aktualisieren wollen, deren Software im <dependent_path> der MaxDB-Installation abgelegt ist und Datenbankinstanzen diese Softwareinstallation verwenden, dann müssen Sie die Datenbankinstanzen zusammen mit der Software aktualisieren (Aktualisierung von Datenbankinstanzen inklusive Server-Software). Andernfalls riskieren Sie, dass die Datenbankinstanzen nicht mehr mit der Datenbanksoftware kompatibel sind und sich deshalb nicht mehr starten lassen.

Wenn Sie auf Ihrem Rechner bereits eine Installation der Datenbanksoftware haben, die mit Hilfe des Red Hat Package Manager (rpm-Paket) ausgeführt wurde, können Sie weitere Installationen oder Updates nur noch mit diesem Programm durchführen.
Weitere Installationen oder Updates mit Hilfe des Programms SDBINST (Installation mit tgz-Paket) sind nicht mehr möglich.

Für die Installation auf Linux stehen Ihnen folgende Möglichkeiten zur Verfügung:

● Das Programm Installation Manager (GUI)
Mit diesem Programm installieren sie die MaxDB-Software am einfachsten.
Siehe: Verwenden des Installation Manager

● Das Programm SDBSETUP zur Installation der Software auf der Kommandozeile
Siehe: Installation/Update mit dem Programm SDBINST

● Das Programm Red Hat Package Manager
Siehe: Installation/Update mit dem Red Hat Package Manager


Installation/Update mit dem Programm SDBINST (SAP-Bibliothek - Installation)

Vorgehensweisen Installation/Update mit dem Programm SDBINST

Verwendung

Sie installieren/aktualisieren Komponentengruppen oder Installationsprofile der Datenbanksoftware unter Verwendung des Programms SDBINST auf dem Betriebssystem Linux. Alle dafür notwendigen Informationen werden während des Installationsvorganges vom Programm abgefragt.

Wenn Sie auf Ihrem Rechner bereits eine Installation des Datenbanksystems haben, die mit Hilfe des Red Hat Package Manager (Installation mit rpm-Paket) ausgeführt wurde, können Sie weitere Installationen oder Updates nur noch mit diesem Programm durchführen.
Weitere Installationen oder Updates mit Hilfe des Programms SDBINST (Installation mit tgz-Paket) sind nicht mehr möglich.

Vorgehensweise

Verfahren Sie, wie im Abschnitt Installation/Update der Software auf UNIX beschrieben.


Installation/Update mit dem Red Hat Package Manager (SAP-Bibliothek - Installation)

Vorgehensweisen Installation/Update mit dem Red Hat Package Manager

Verwendung

Sie installieren/aktualisieren Komponenten der Datenbanksoftware auf dem Betriebssystem Linux. Alle dafür notwendigen Informationen und das Kommando zum Starten des Installationsprogramms spezifizieren Sie auf der Kommandozeile.

Sie müssen dabei die zwischen Softwarekomponenten bestehenden Abhängigkeiten berücksichtigen, um die Funktionsfähigkeit der Softwareinstallation zu gewährleisten.

Voraussetzungen

● Sie befinden sich in einer root-Shell.

● Die zu installierenden rpm-Pakete sind von Ihrem Rechner aus zugreifbar.

Vorgehensweise

Erstinstallation der Datenbanksoftware

...

1. Navigieren Sie in das Verzeichnis /usr und prüfen Sie, ob das Verzeichnis spool existiert.
Wenn es noch nicht existiert, fahren Sie fort mit Schritt 2. Wenn es bereits existiert, löschen Sie das Verzeichnis spool.

2. Bleiben Sie im Verzeichnis /usr und legen Sie folgenden symbolischen Link an:
ln -s ../var/spool spool

3. Führen Sie das Installationskommando aus:
rpm -Uhv maxdb<package_name>.rpm

4. Tragen Sie alle Benutzer, die das Datenbanksystem benutzen wollen, in die spezielle Betriebssystembenutzer-Gruppe (Systemvorschlag: sdba) ein.

5. Erweitern Sie für alle Benutzer, die das Datenbanksystem benutzen wollen, die Umgebungsvariable PATH um den Eintrag /opt/sdb/programs/bin.

Update der Datenbanksoftware

Stoppen Sie alle vorhandene Software des Datenbanksystems auf dem Rechner, auf dem eine Softwareversion aktualisiert werden soll.

Stoppen Sie das Programm Strukturlink X-Server (Prozess vserver). Beachten Sie, dass Sie damit die Kommunikation von Clients zu allen lokalen Datenbankinstanzen unterbrechen.

...

1. Stoppen Sie alle Datenbankinstanzen, die dem zu aktualisierenden Installationsverzeichnis zugeordnet sind, mit dem Kommando
dbmcli –d <database_name> -u <dbm_user_name>,<dbm_user_password> db_offline

2. Führen Sie das Installationskommando aus:
rpm -Uhv maxdb<package_name>.rpm

Ergebnis

Die im Installationsverzeichnis enthaltenen Softwarekomponenten wurden in der neuen Version installiert und registriert. Sie können das Ergebnis Ihrer Installation anhand des Protokolls überprüfen.

Sie können nun mit Hilfe des Installation Manager, Database Manager CLI oder Database Manager GUI Datenbankinstanzen anlegen.

Siehe auch:

Protokollierung

Datenbankinstanz nachträglich anlegen

Database Manager CLI, Strukturlink db_create

Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz


Installation/Update der Software auf Microsoft Windows (SAP-Bibliothek - Installation)

Hintergrunddokumentation Installation/Update der Software auf Microsoft Windows

Verwendung

Sie installieren oder aktualisieren eine Komponentengruppe, ein Installationsprofil oder einzelne Komponenten der Datenbanksoftware.

Die nachfolgend beschriebene Vorgehensweise ist für Updates nur dann anzuwenden, wenn Sie Komponenten aktualisieren wollen, deren Software nicht im <dependent_path> der MaxDB-Installation abgelegt ist, oder wenn keine Datenbankinstanzen die zu aktualisierende Softwareinstallation verwenden.

Siehe auch:

Verzeichnisse

Wenn Sie Komponenten aktualisieren wollen, deren Software im <dependent_path> der MaxDB-Installation abgelegt ist und Datenbankinstanzen diese Softwareinstallation verwenden, dann müssen Sie die Datenbankinstanzen zusammen mit der Software aktualisieren (Aktualisierung von Datenbankinstanzen inklusive Server-Software). Andernfalls riskieren Sie, dass die Datenbankinstanzen nicht mehr mit der Datenbanksoftware kompatibel sind und sich deshalb nicht mehr starten lassen.

Der Installationsvorgang wird vom System protokolliert (Protokollierung).

Vorgehensweise

...

1. Entpacken Sie zunächst die Datenbanksoftware in ein lokales Verzeichnis.

Entpacken der Software auf Microsoft Windows

2. Entscheiden Sie nun, ob Sie eine interaktive Installation (nur möglich für Komponentengruppen oder Installationsprofile) oder eine Installation im Hintergrund durchführen möchten.

○ Interaktive Installation/Update auf Microsoft Windows

○ Installation/Update im Hintergrund auf Microsoft Windows

Zu den Vor- und Nachteilen dieser Installationsverfahren siehe
Installation und Update der Datenbanksoftware.


Entpacken der Software auf Microsoft Windows (SAP-Bibliothek - Installation)

Vorgehensweisen Entpacken der Software auf Microsoft Windows

Vorgehensweise

...

...

1. Wählen Sie das Ihrer Betriebssystemarchitektur und der gewünschten Software entsprechende Paket aus.

Wenn Sie nur eine einzelne Softwarekomponente installieren oder aktualisieren wollen, wählen Sie eine Komponentengruppe oder ein Installationsprofil aus, das diese Softwarekomponente enthält.

Installation vom Software Distribution Center auf dem SAP Service Marketplace (service.sap.com/swdc, nur für SAP-Kunden)

○ Für den Strukturlink Datenbankinstanztyp OLTP wählen Sie
Download ®Database Patches ® MaxDB and SAP DB ® MaxDB | MaxDB 64-bit ® MaxDB <version> ® <os> ®
MAXDB<version>_<build>-<GUID>.SAR

○ Für den Strukturlink Datenbankinstanztyp liveCache (SAP-System APO) wählen Sie
Download ® Support Packages and Patches ® Entry by Application Group ® SAP Application Components ® SAP APO ® SAP APO <apo_version> ® Entries by Component ® APO LC ® APO LC<version>/LCAPPS<apo_version> ® <os> ®
LC<version>A<apo_version>_<apo_build>-<GUID>.SAR

Installation von der MaxDB-Website dev.mysql.com/downloads/maxdb/7.6.00.html

○ Nur Datenbankinstanztyp OLTP
Wählen Sie gewünschte Softwarepaket für Ihr Betriebssystem
maxdb-<inst_profile>-win-<32|64>bit-<arch>-<version>_<build>.zip

2. Kopieren Sie das Softwarepaket in ein beliebiges lokales Verzeichnis.

3. Entpacken Sie

○ ein sar-Paket mit Hilfe des Programms SAPCAR

○ ein zip-Paket mit Hilfe des Programms WinZip

in ein beliebiges lokales Verzeichnis.

Ergebnis

Das System legt in diesem lokalen Verzeichnis

● für OLTP-Software ein Unterverzeichnis
maxdb-<inst_profile>-win-<32|64>bit-<arch>-<version>

● für SAP liveCache-Software ein Unterverzeichnis
apo<apo_version>_livecache-win-<32|64>bit-<arch>-<version>

an und legt darin die Software ab.

Siehe auch:

Komponentengruppen, Installationsprofile, Verzeichnisse

Glossar, Strukturlink Variablen in der Dokumentation

Am einfachsten installieren Sie die Software nun mit Hilfe des Installation Manager (GUI) und rufen dazu das Programm SDBSETUP auf.
Siehe: Verwenden des Installation Manager

Sie können aber auch das Installationsprogramm SDBINST auf der Kommandozeile ausführen.
Siehe: Installation, Upgrade und Deinstallation auf der Kommandozeile


Interaktive Installation/Update auf Microsoft Windows (SAP-Bibliothek - Installation)

Vorgehensweisen Interaktive Installation/Update auf Microsoft Windows

Verwendung

Sie installieren/aktualisieren Komponentengruppen oder Installationsprofile der Datenbanksoftware unter Verwendung des Programms SDBINST auf dem Betriebssystem Microsoft Windows. Alle dafür notwendigen Informationen werden während des Installationsvorganges vom Programm abgefragt.

Vor einem Update der Datenbanksoftware müssen Sie das Programm Strukturlink X-Server stoppen. Beachten Sie, dass Sie damit die Kommunikation von Clients zu allen lokalen Datenbankinstanzen unterbrechen.

Siehe auch:

Komponentengruppen

Installationsprofile

Voraussetzungen

● Sie haben für Ihren Rechner Administrationsrechte.

● Sie haben das Installationspaket heruntergeladen und entpackt, siehe: Entpacken der Software auf Microsoft Windows.

Vorgehensweise

...

1. Wenn Sie eine vorhandene Installation des Datenbanksystems aktualisieren (Update) oder eine neuere Softwareversion parallel installieren wollen,

○ stoppen Sie jede einzelne Datenbankinstanz aller installierten Versionen des Datenbanksystems mit folgendem Kommando:

dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_offline

○ stoppen Sie das Programm X-Server (Service XServer) mit dem Kommando

x_server stop

Für eine Erstinstallation beginnen Sie mit Schritt 2.

2. Öffnen Sie das Command Prompt und navigieren Sie in das lokale Verzeichnis, das die Installationsdateien enthält:

○ Für OLTP-Software in das Verzeichnis

maxdb-<inst_profile>-win-<32|64>bit-<arch>-<version>

○ Für liveCache-Software in das Verzeichnis

apo<apo_version>_<livecache>-win-<32|64>bit-<arch>-<version>

3. Geben Sie sdbinst ein, um das Installations-/Update-Programm aufzurufen.

4. Das System schlägt Ihnen Komponentengruppen vor. Geben Sie die ID der gewünschten Komponentengruppe ein. Bestätigen Sie Ihre Wahl.

5. Wenn Sie die Komponentengruppe Custom gewählt haben, dann schlägt das System Ihnen nun Installationsprofile vor. Geben Sie die entsprechende ID an. Bestätigen Sie ihre Wahl.

6. Das System prüft nun, ob es aktualisierbare Installationen des Datenbanksystems auf Ihrem Rechner gibt.

Wenn dies der Fall ist, werden alle vorhandenen Installationen aufgelistet.

○ Wenn Sie eine vorhandene Installation aktualisieren wollen, geben Sie die ID der betreffenden Installation an.

Anschließend wird vom System die unter dem <independent_program_path> abgelegte Software aktualisiert. In Abhängigkeit von der gewählten Software wird auch die unter dem <dependent_path> abgelegte Software aktualisiert, wenn das Installationspaket neuere Versionen darin vorhandener Dateien enthält.

○ Wenn Sie eine Neuinstallation der Datenbanksoftware parallel zur vorhandenen Installation durchführen wollen, geben Sie none an. Sie erhalten dann die Möglichkeit, einen neuen Installationspfad anzugeben. Definieren Sie einen Installationspfad parallel zum vorhandenen Installationspfad.

Wenn es auf Ihrem Rechner noch keine Installation der Datenbanksoftware gibt, dann werden die Softwarekomponenten nun nacheinander installiert. Gegebenenfalls werden Sie vom System aufgefordert, folgende Pfade anzugeben:

○ Pfad für die Ablage der Daten, Konfigurationen und Arbeitsverzeichnisse von Datenbankinstanzen und -anwendungen (Vorschlagswert des Systems ist C:\Documents and Settings\All Users\Application Data\sdb\data)

○ Pfad für die Ablage der von den Datenbankinstanzen und -anwendungen gemeinsam genutzten Programme und Bibliotheken (Vorschlagswert des Systems ist C:\Program Files\sdb\programs)

○ Pfad für die Ablage der von der Datenbankversion abhängigen Server-Software

Diese Pfadangabe muss eindeutig sein. Es können viele Verzeichnisse mit verschiedenen Versionen nebeneinander existieren (Vorschlagswert des Systems ist C:\Program Files\sdb\<version>).

Geben Sie die gewünschten Pfade an oder bestätigen Sie die Systemvorschläge.

Sie erhalten eine Meldung über den erfolgreichen Abschluss der Installation.

7. Wenn es auf Ihrem Rechner bislang noch keine Installation der Datenbanksoftware gab, empfehlen wir Ihnen, nun Ihren Rechner herunterzufahren und neu zu starten, damit das System auf den <independent_program_path> zugreifen kann.

Bei einem Update der Datenbanksoftware ist dies nicht erforderlich.

Ergebnis

Die Softwarepakete wurden installiert und registriert. Sie können das Ergebnis Ihrer Installation anhand des Protokolls überprüfen.

Sie können nun mit Hilfe des Installation Manager, Database Manager CLI oder Database Manager GUI Datenbankinstanzen anlegen.

Siehe auch:

Protokollierung

Datenbankinstanz nachträglich anlegen

Database Manager CLI, Strukturlink db_create

Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz


Installation/Update im Hintergrund auf Microsoft Windows (SAP-Bibliothek - Installation)

Vorgehensweisen Installation/Update im Hintergrund auf Microsoft Windows

Verwendung

Sie installieren/aktualisieren Komponentengruppen, Installationsprofile oder einzelne Komponenten der Datenbanksoftware unter Verwendung des Programms SDBINST auf dem Betriebssystem Microsoft Windows. Alle dafür notwendigen Informationen spezifizieren Sie auf der Kommandozeile zusammen mit dem Kommando zum Starten des Installationsprogramms

Vor einem Update der Datenbanksoftware müssen Sie das Programm Strukturlink X-Server stoppen. Beachten Sie, dass Sie damit die Kommunikation von Clients zu allen lokalen Datenbankinstanzen unterbrechen.

Voraussetzungen

● Sie haben für Ihren Rechner Administrationsrechte.

● Sie haben das Installationspaket heruntergeladen und entpackt (Entpacken der Software auf Microsoft Windows).

Vorgehensweise

1. Wenn Sie eine vorhandene Installation des Datenbanksystems aktualisieren (Update) oder eine neuere Softwareversion parallel installieren wollen,

○ stoppen Sie jede einzelne Datenbankinstanz mit dem Kommando
dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_offline

○ stoppen Sie das Programm X-Server (Service XServer) mit dem Kommando
x_server stop

Für eine Erstinstallation beginnen Sie mit Schritt 2.

2. Für die OLTP-Software starten Sie den Installationsvorgang mit folgendem Kommando:
sdbinst [-b | --batch] -component_group <component_group> | -profile <inst profile>[,<inst_profile2>...] | -package <package_name>[,<package_name2...>] -indep_data <independent_data_path> - indep_prog <independent_program_path> -depend <dependent_path> [-archive_dir <directory>]

Für die liveCache-Software (nur im SAP-System APO) starten Sie den Installationsvorgang mit folgendem Kommando:

○ Für das Installationsprofil APO liveCache
sdbinst [-b] -profile "APO LiveCache" -indep_data <independent_data_path> -indep_prog <independent_program_path> -depend <dependent_path>

○ Für die Softwarekomponente APO LC APPS
sdbinst [-b] -package "APO LC APPS" -depend <dependent_path>

Zur Bedeutung der Optionen siehe Übersicht der Optionen für das Programm SDBINST.

Namen von Installationsprofilen und Softwarekomponenten, die Leerzeichen enthalten, müssen im Installationskommando in doppelte Anführungszeichen gesetzt werden.

Bei bestimmten Installationsprofilen oder Softwarekomponenten ist die Angabe der Optionen –indep_prog, -indep_data und –depend nicht notwendig. Wenn Sie diese Optionen dennoch angeben, werden sie vom System ignoriert. Informationen dazu finden Sie ebenfalls in der Übersicht der Optionen.

Sie erhalten eine Meldung über den erfolgreichen Abschluss der Installation.

Ergebnis

Die Softwarepakete wurden installiert und registriert. Sie können das Ergebnis Ihrer Installation anhand des Protokolls überprüfen.

Sie können nun mit Hilfe des Installation Manager, Database Manager CLI oder Database Manager GUI Datenbankinstanzen anlegen.

Siehe auch:

Protokollierung

Datenbankinstanz nachträglich anlegen

Database Manager CLI, Strukturlink db_create

Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz


Deinstallation der Datenbanksoftware (SAP-Bibliothek - Installation)

Hintergrunddokumentation Deinstallation der Datenbanksoftware

Einführungshinweise

In Abhängigkeit davon, mit welchem Verfahren die Datenbanksoftware installiert wurde, können Sie sie nun mit Hilfe des Programms SDBUNINST oder mit dem Red Hat Package Manager deinstallieren.

Sie haben in beiden Fällen die Möglichkeit, die gesamte Datenbanksoftware, einzelne Installationsprofile oder einzelne Softwarekomponenten zu deinstallieren.

Für eine Deinstallation im Anschluss an eine abgebrochene Installation müssen Sie zunächst Ihren Rechner neu starten. Erst danach kann das System auf das Deinstallationsprogramm zugreifen.

Wenn Sie auf dem Betriebssystem Linux arbeiten und die Installation der Datenbanksoftware auf Ihrem Rechner mit Hilfe des Red Hat Package Manager (rpm-Paket) ausgeführt wurde, können Sie die Deinstallation nur mit diesem Programm durchführen.

Konventionen

Verzeichnisse

Deinstallation mit SDBUNINST auf UNIX, Linux oder Microsoft Windows

Deinstallation mit Hilfe des Red Hat Package Manager


Deinstallation mit SDBUNINST auf UNIX, Linux und Microsoft Windows

Vorgehensweisen Deinstallation mit SDBUNINST auf UNIX, Linux und Microsoft Windows

Einführungshinweise

Sie verwenden das Deinstallationsprogramm SDBUNINST, um einzelne oder alle Softwarekomponenten unter Berücksichtigung der zwischen ihnen bestehenden Abhängigkeiten zu deinstallieren. Es ist in der Datenbanksoftware ab Version 7.3.00 Build 033 enthalten.

Sie können damit Software des Datenbanksystems ab Version 7.2 deinstallieren.

Übersicht der Optionen für das Programm SDBUNINST

Voraussetzungen

· Auf Ihrem Rechner sind eine oder mehrere Versionen der Datenbanksoftware installiert. Darunter ist mindestens eine Installation der Version 7.3.00, Build 033 oder größer, in der das Programm SDBUNINST enthalten ist.

· Sie haben für Ihren Rechner Administrationsrechte.

Vorgehensweise

...

1. Unter UNIX/Linux: Wechseln Sie in die root-Shell.

Unter Microsoft Windows: Öffnen Sie das Command Prompt auf Ihrem Rechner.

2. Stoppen Sie jede einzelne Datenbankinstanz auf Ihrem Rechner mit folgendem Kommando:
dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_offline

3. Löschen Sie jede einzelne Datenbankinstanz auf Ihrem Rechner mit folgendem Kommando:
dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_drop

4. Führen Sie das Deinstallationprogramm mit der gewünschten Option aus:
sdbuninst <option>

¡ Wenn Sie alle Softwarekomponenten deinstallieren wollen, geben Sie die Option –all an, andernfalls spezifizieren Sie die gewünschte Komponente mit Hilfe der Option –package.


Deinstallation mit dem Red Hat Package Manager (SAP-Bibliothek - Installation)

Vorgehensweisen Deinstallation mit dem Red Hat Package Manager

Verwendung

Sie installieren/aktualisieren Komponenten der Datenbanksoftware auf dem Betriebssystem Linux. Alle dafür notwendigen Informationen und das Kommando zum Starten des Installationsprogramms spezifizieren Sie auf der Kommandozeile.

Voraussetzungen

Sie befinden sich in einer root-Shell.

Vorgehensweise

1. Führen Sie jede einzelne Datenbankinstanz nacheinander das Kommando zum Stoppen und dann das Kommando zum Löschen einer Datenbankinstanz aus:
dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_offline

dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_drop

2. Führen Sie das Deinstallationskommando aus:
rpm -e maxdb<package_name|*>.rpm

Ergebnis

Die angegebene/n Softwarekomponenten wurde/n deinstalliert.


Aktualisierung von Datenbankinstanzen inklusive Server-Software (SAP-Bibliothek - Installation)

Hintergrunddokumentation Aktualisierung von Datenbankinstanzen inklusive Server-Software

Einführungshinweise

Sie überführen Strukturlink Datenbankinstanzen von einer Version in eine höhere Version und aktualisieren gleichzeitig deren Server-Software. Dieser Vorgang wird im Folgenden Upgrade genannt.

Die dabei zu verwendende Strategie ist vom Datenbankinstanztyp sowie der Start- und Zielversion abhängig. Für die Auswahl der geeigneten Upgrade-Strategie stehen Ihnen entsprechende Matrizen zur Verfügung.

Bei jeder Aktualisierung von Datenbankinstanzen empfiehlt es sich, für mögliche Fehler während des Vorganges vorzusorgen. Stellen Sie deshalb grundsätzlich sicher, dass Sie über vollständige Sicherungen aller Daten der betreffenden Datenbankinstanzen und über die Datenbanksoftware der Startversion verfügen. Nur dann können Sie gegebenenfalls umgehend auf die Startversion zurückgehen und einen längeren Systemstillstand vermeiden.

Stellen Sie vor Beginn des Vorganges sicher, dass die häufigsten Fehlerursachen für einen Abbruch des Upgrade ausgeschlossen sind.

Wann immer es möglich ist, führen Sie das Upgrade mit Hilfe des Programms SDBUPD aus. Sie erhalten von diesem Programm eine umfassende Unterstützung für ein problemloses Upgrade. Es kann jedoch nur unter bestimmten Voraussetzungen verwendet werden. Wenn diese Voraussetzungen nicht erfüllt sind, müssen Sie eine andere Upgrade-Strategie verwenden.

Siehe auch:

Auswahl der Upgrade-Strategie

Fehlerbehandlung

Verzeichnisse

Voraussetzungen für die Verwendung des Programms SDBUPD

SAP-Kunden steht für das Upgrade von Datenbankinstanzen in SAP-Systemen das Programm SDPUPD zu Verfügung. Das Programm SDBUPD nimmt dabei alle erforderlichen Prüfungen vor.

Sie können das Programm auch für das Upgrade von Datenbankinstanzen verwenden, wenn diese nicht in SAP-Systeme eingebunden sind. Dafür müssen jedoch folgende Voraussetzungen erfüllt sein:

● Die vorhandene Installation der Software erfolgte mit Hilfe des Programms SDBINST

● Jede der vorhandenen Datenbankinstanzen bezieht sich auf eine separate Softwareinstallation


Vorgehensweise Auswahl der Upgrade-Strategie

Wählen Sie die geeignete Upgrade-Strategie entsprechend des Instanztyps der zu aktualisierenden Datenbankinstanz sowie der Start- und Zielversion der Datenbanksoftware. Verfahren Sie dann weiter, wie für die gewählte Upgrade-Strategie beschrieben.

Empfehlung Empfehlung

Wenn die zu aktualisierende Datenbankinstanz die notwendigen Voraussetzungen erfüllt, empfehlen wir Ihnen, das Programm SDBUPD zu verwenden, da das Upgrade mit Hilfe des Programms nur eine geringe Interaktion des Benutzers erfordert, schneller und sicherer abläuft.

Ende der Empfehlung

Upgrade-Strategien für OLTP-Datenbankinstanzen

 | Zielversion 7.6.x
Startversion ab 7.3.00 Build 025 | In-Place-Migration mit SDBUPD oder* In-Place-Migration mit SDBINST Die Zielversion muss größer/gleich 7.6.00 Build 12 sein.
Startversion 7.4.03 | Patch-Installation mit SDBUPD oder* Patch-Installation mit SDBINST
Startversion 7.5.x | Patch-Installation mit SDBUPD oder* Patch-Installation mit SDBINST
Startversion 7.6.00 | Patch-Installation mit SDBUPD oder* Patch-Installation mit SDBINST

* Verwenden Sie das Programm SDBUPD, wenn die zu aktualisierende Datenbankinstanz Bestandteil eines SAP-Systems ist. In Sonderfällen können Sie SDBUPD auch dann verwenden, wenn die Datenbankinstanz nicht Bestandteil eines SAP-Systems ist. Siehe dazu den Abschnitt "Voraussetzungen für die Verwendung des Programms SDBUPD" unter HYPERLINK "../../KW/IWB_EXTHLP~68F3F63DEF83C452E10000000A114084/"Aktualisierung von Datenbankinstanzen inklusive Server-Software.

Upgrade-Strategien für liveCache-Datenbankinstanzen

 | Zielversion 7.6.00/500
Startversion 7.2.05/30A | Upgrade mittels APO Extract/Load
Startversion 7.4.02/30A | Upgrade mittels APO Extract/Load
Startversion 7.4.02/310 | Upgrade mittels APO Extract/Load
Startversion 7.4.03/400 | Upgrade mittels APO Extract/Load
Startversion 7.5.00/410 | Upgrade mittels APO Extract/Load
Startversion 7.6.00/500 | Patch-Installation mit SDBUPD


Patch-Installation mit SDBUPD (SAP-Bibliothek - Installation)

Vorgehensweisen Patch-Installation mit SDBUPD

Verwendung

Sie verwenden das Programms SDBUPD für das Upgrade der Datenbankinstanz. Dabei wird nur die Datenbanksoftware ausgetauscht.

Diese Vorgehensweise ist für Software der Version 7.6.x möglich, wenn sich zwischen Start- und Zielversion nur die Build-Nummer der Version geändert hat, aber auch für Upgrades von der Version 7.4.03 nach 7.6.x und von der Version 7.5.x nach 7.6.x (siehe auch Auswahl der Upgrade-Strategie).

Sie verwenden diese Upgrade-Strategie, wenn ihre Datenbankinstanz Bestandteil eines SAP-Systems ist.

Sie können diese Strategie auch verwenden, wenn die Datenbankinstanz nicht in ein SAP-System eingebunden ist. Dafür müssen jedoch folgende Voraussetzungen erfüllt sein:

● Die vorhandene Software wurde mit Hilfe des Installationsprogramms SDBINST installiert (also mittels tgz-Paket oder zip-Datei, nicht mittels rpm-Paket)

● Jede Datenbankinstanz bezieht sich auf eine separate Softwareinstallation

Die Vorgehensweise ist abhängig davon, ob die Startversion kleiner als 7.5.00 oder größer/gleich 7.5.00 ist und auf welchem Betriebssystem Sie arbeiten.

Wenn Sie unter UNIX oder Linux arbeiten und die Startversion kleiner ist als 7.5.00, dann müssen Sie vor dem Upgradevorgang den Strukturlink X-Server und alle Datenbankinstanzen stoppen. Beachten Sie, dass Sie damit die Kommunikation von Clients zu allen lokalen Datenbankinstanzen unterbrechen. Wenn die Startversion größer oder gleich 7.5.00 ist, unterstützt die X-Server-Software ein Update bei laufendem Betrieb des X-Server. Das Stoppen des X-Server ist nicht mehr notwendig. Die zu aktualisierende Datenbankinstanz wird von SDBUPD während des Upgrade gestoppt.

Wenn Sie unter Microsoft Windows arbeiten, müssen Sie in jedem Fall den X-Server und alle Datenbankinstanzen stoppen.

Voraussetzungen

Überzeugen Sie sich vor Beginn des Upgrade-Vorganges, dass Sie über aktuelle Strukturlink Log-Sicherungen und/oder Strukturlink Datensicherungen verfügen, die es ermöglichen, die zu aktualisierende Datenbankinstanz im Falle eines Fehlers wiederzustellen.

Die Parameter der zu aktualisierenden Datenbankinstanz sollten seit dem letzten Restart nicht mehr geändert worden sein.

● Die zu aktualisierende Datenbankinstanz bezieht sich als einzige auf den Installationspfad der zu aktualisierenden Software.

● Die Datenbankinstanz befindet sich in einem definierten Betriebszustand, d. h. es liegt keine Fehlersituation vor.

Vorgehensweise

...

1. Stoppen Sie gegebenenfalls jede einzelne Datenbankinstanz mit folgendem Kommando:

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_offline

2. Stoppen Sie gegebenenfalls jeden einzelnen Scheduler:

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> scheduler_stop

3. Stoppen Sie gegebenenfalls den X-Server:

>x_server stop

4. Starten Sie das Programm SDBUPD für die zu aktualisierende Datenbankinstanz durch die Eingabe des folgenden Kommandos:

UNIX, Linux: | Microsoft Windows:
>./SDBUPD –d <database_name> -u <dbm_user>,<password> [-o <sdb_user> -g <sdba_group>] | >sdbupd –d <database_name> -u <dbm_operator>,<dbm_operator_password>

Den speziellen Betriebssystembenutzer <sdb_user> und die Gruppe <sdba_group> müssen Sie nur dann angeben, wenn Sie ein Upgrade von einer Softwareversion < 7.5.00 durchführen (siehe Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)).

Das Programm SDBUPD führt das Upgrade durch, gibt eine Meldung über den erfolgreichen Abschluss des Upgrade aus und kennzeichnet die Installation als abgeschlossen.

Ergebnis

Die spezifizierte Datenbankinstanz und die Software, die zum Installationsprofil Server gehört, wurden aktualisiert.

Bei dieser Vorgehensweise wird die Software, die nicht zum Installationsprofil Server gehört, nicht aktualisiert. Um diese Software zu aktualisieren, verwenden Sie anschließend SDBINST wie im Abschnitt Installation und Update der Datenbanksoftware beschrieben.

Wenn Sie eine Datenbankinstanz des Strukturlink Instanztyps liveCache aktualisiert haben, befindet sie sich jetzt im Betriebszustand OFFLINE.

Wenn Sie eine Datenbankinstanz des Strukturlink Instanztyps OLTP aktualisiert haben, befindet sie sich jetzt im Betriebszustand ONLINE.


Patch-Installation mit SDBINST und Nachbereitung (SAP-Bibliothek - Installation)

Vorgehensweisen Patch-Installation mit SDBINST und Nachbereitung

Verwendung

Sie verwenden das Programms SDBINST für das Upgrade von Datenbankinstanzen. Dafür wird nur die Datenbanksoftware ausgetauscht. Anschließend müssen Sie die notwendigen Nachbereitungen mit Hilfe des Strukturlink Programms Database Manager CLI auf der Kommandozeile ausführen.

Diese Upgrade-Strategie ist nur für den Strukturlink Instanztyp OLTP von Bedeutung (Auswahl der Upgrade-Strategie). Sie gilt für alle Strukturlink unterstützten Betriebssystemplattformen.

Die Vorgehensweise ist abhängig davon, ob die Startversion kleiner als 7.5.00 oder größer/gleich 7.5.00 und auf welchem Betriebssystem Sie arbeiten.

Wenn Sie unter UNIX oder Linux arbeiten und die Startversion kleiner ist als 7.5.00, dann müssen Sie vor dem Upgradevorgang den Strukturlink X-Server und alle Datenbankinstanzen stoppen. Beachten Sie, dass Sie damit die Kommunikation von Clients zu allen lokalen Datenbankinstanzen unterbrechen. Wenn die Startversion größer oder gleich 7.5.00 ist, unterstützt die X-Server-Software ein Update bei laufendem Betrieb des X-Server. Das Stoppen des X-Server und aller Datenbankinstanzen ist deshalb nicht mehr notwendig. Sie müssen jedoch jene Datenbankinstanz stoppen, die dem zu aktualisierenden Installationsverzeichnis zugeordnet ist.

Wenn Sie unter Microsoft Windows arbeiten, müssen Sie in jedem Fall den X-Server und alle Datenbankinstanzen stoppen.

Voraussetzungen

Überzeugen Sie sich vor Beginn des Upgrade-Vorganges, dass Sie über aktuelle Strukturlink Log-Sicherungen und/oder Strukturlink Datensicherungen verfügen, die es ermöglichen, die zu aktualisierenden Datenbankinstanzen im Falle eines Fehlers wiederzustellen.

● Alle zu aktualisierenden Datenbankinstanzen beziehen sich auf die gleiche Softwareinstallation.

Vorgehensweise

...

1. Stoppen Sie gegebenenfalls jede einzelne Datenbankinstanz mit folgendem Kommando:

>dbmcli –d <database_name> -u <dbm_operator>, <dbm_operator_password> db_offline

2. Stoppen Sie gegebenenfalls jeden einzelnen Scheduler:

>dbmcli –d <database_name> -u <dbm_operator>, <dbm_operator_password> scheduler_stop

3. Stoppen Sie gegebenenfalls den X-Server.

>x_server stop

4. Rufen Sie das Programm SDBINST mit den Optionen für die Installation des Installationsprofils Server auf. Achten Sie darauf, für den <dependent_path> den korrekten Softwareinstallationspfad jener Datenbankinstanz/en anzugeben, die aktualisiert werden soll/en.

UNIX/Linux:

Microsoft Windows:

>./SDBINST [-b] -profile server -indep_data <independent_data_path> -indep_prog <independent_program_path> -depend <dependent_path>
[-o <sdb_user> -g <sdba_group>]

>sdbinst [-b] -profile server -indep_data <independent_data_path> -indep_prog <independent_program_path> -depend <dependent_path>

Den speziellen Betriebssystembenutzer <sdb_user> und die Gruppe <sdba_group> geben Sie beim Upgrade von einer Softwareversion < 7.5.00 entsprechend des Berechtigungskonzepts für UNIX an (siehe Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)).

5. Starten Sie den X-Server mit folgendem Kommando:

>x_server start

6. Melden Sie sich erneut als Strukturlink DBM-Benutzer nacheinander an jede der zu aktualisierenden Datenbankinstanzen an und führen Sie die angegebenen Nachbereitungsschritte aus:

Vorgehensweise

Kommando

...

1.

Melden Sie sich mit den Daten der zu aktualisierenden Datenbankinstanz an den Database Manager CLI an.

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password>

2.

Aktualisieren Sie die Softwareversion der Datenbankinstanz.

db_reg

3.

Aktualisieren Sie die Parameter der Datenbankinstanz.

param_checkall

4.

Wenn Sie ein Upgrade von einer Datenbankversion < 7.5.00 auf einem UNIX-Betriebssystem durchführen, dann nehmen Sie folgende Zwischenschritte vor:

a. Melden Sie sich vom Database Manager CLI ab.

b. Rufen Sie das Programm chvolperm auf, das Eigentümer, Gruppe sowie Zugriffsrechte auf die Volumes der Datenbankinstanz entsprechend dem Berechtigungskonzept für UNIX-Betriebssysteme ändert.

c. Melden Sie sich wieder am Database Manager CLI an.

exit | release | quit | bye

<dependent_path>/bin/chvolperm –d <database_name>

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password>

5.

Überführen Sie die Datenbankinstanz in den Betriebszustand WARM (bis Version 7.3) bzw. ONLINE (ab Version 7.4).

db_online | db_warm

6.

Laden Sie die Systemtabellen.

Sie erhalten eine Meldung über den erfolgreichen Abschluss.

load_systab

7.

Beenden Sie den Database Manager CLI

exit | release | quit | bye

Ergebnis

Die spezifizierte OLTP-Datenbankinstanz und die Software, die zum Installationsprofil Server gehört, wurden aktualisiert.

Bei dieser Vorgehensweise wird die Software, die nicht zum Installationsprofil Server gehört, nicht aktualisiert. Um diese Software zu aktualisieren, verwenden Sie anschließend SDBINST wie im Abschnitt Installation und Update der Datenbanksoftware beschrieben.

Sie befindet sich im Betriebszustand ONLINE.


In-Place-Migration mit SDBUPD (SAP-Bibliothek - Installation)

Vorgehensweisen In-Place-Migration mit SDBUPD

Verwendung

Sie verwenden das Programm SDBUPD für das Upgrade der Datenbankinstanz.

Sie verwenden diese Vorgehensweise, wenn die Datenbankinstanz in ein SAP-System eingebundenen ist.

Diese Upgrade-Strategie ist nur für den Strukturlink Instanztyp OLTP von Bedeutung. Sie gilt für alle Strukturlink unterstützten Betriebssystemplattformen.

Voraussetzungen

● Die zu aktualisierende Datenbankinstanz ist Bestandteil eines SAP-Systems.

● Die Datenbankinstanz ist im Betriebszustand ONLINE bzw. bei Version 7.3 im Zustand WARM.

● Die Datenbankinstanz bezieht sich als einzige auf den Installationspfad der zu aktualisierenden Softwareversion.

● Die Datenbankparameter der zu aktualisierenden Datenbankinstanz sind seit dem letzten Restart nicht geändert worden.

● Die Startversion der Datenbanksoftware ist 7.3 größer/gleich Build 025, die Zielversion ist größer gleich Version 7.5.00 (Siehe auch: Auswahl der Upgrade-Strategie).

Vorgehensweise

...

Beschreibung

Kommando

1.

Rufen Sie als DBM-Benutzer den Database Manager CLI auf und verbinden Sie sich mit der zu migrierenden Datenbankinstanz

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password>

2.

Melden Sie sich an den Database Manager CLI an und stoppen Sie die zu aktualisierende Datenbankinstanz.

Wenn der vorhandene X-Server kleiner ist als 7.5, dann stoppen Sie mit diesem Kommando nacheinander alle Datenbankinstanzen.

db_offline

3.

Überführen Sie die zu aktualisierende Datenbankinstanz in den Betriebszustand COLD (bis Version 7.3) bzw. ADMIN (ab Version 7.4)

db_cold | db_admin

4.

Falls Sie über eine jüngere Datensicherung verfügen, führen Sie eine inkrementelle Datensicherung und eine Log-Sicherung durch. Andernfalls führen Sie eine vollständige Datensicherung durch ( Strukturlink backup_start).

backup_start <medium> [<type>] [AUTOIGNORE]

5.

Beenden Sie den Database Manager CLI.

exit | release | quit | bye

6.

Wenn die Startversion kleiner ist als 7.5.00, stoppen Sie den X-Server

Wenn die Startversion größer/gleich 7.5.00 ist, unterstützt die X-Server-Software ein Update bei laufendem Betrieb. Das Stoppen des X-Server ist deshalb nicht mehr notwendig.

>x_server stop

7.

Starten Sie das Programm SDBUPD.

Das Programm SDBUPD führt das Upgrade durch, gibt eine Meldung über den erfolgreichen Abschluss aus und kennzeichnet die Installation als abgeschlossen.

Die Ausführung dieses Kommandos kann sehr lange dauern. Brechen Sie die Ausführung unter keinen Umständen ab. Andernfalls besteht das Risiko eines kompletten Datenverlusts. Sie haben dann nur die Möglichkeit, mit Hilfe der Datensicherung/en auf den darin gespeicherten Zustand der Datenbankinstanz zurückzugehen.

UNIX/Linux:

>./SDBUPD –d <database_name> -u <dbm_operator>,<dbm_operator_password>
[-o <sapdb_user>
-g <sapdb_admin>]

Den speziellen Betriebssystembenutzer <sdb_user> und die Gruppe <sdba_group> müssen Sie nur dann angeben, wenn Sie ein Upgrade zur Softwareversion 7.5.x durchführen (siehe Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)).

Microsoft Windows:

>sdbupd –d <database_name> -u <dbm_operator>,<dbm_operator_password>

Ergebnis

Die spezifizierte OLTP-Datenbankinstanz und die Software, die zum Installationsprofil Server gehört, wurden aktualisiert.

Bei dieser Vorgehensweise wird die Software, die nicht zum Installationsprofil Server gehört, nicht aktualisiert. Um diese Software zu aktualisieren, verwenden Sie anschließend SDBINST wie im Abschnitt Installation und Update der Datenbanksoftware beschrieben.

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.


In-Place-Migration mit SDBINST und Nachbereitung (SAP-Bibliothek - Installation)

Vorgehensweisen In-Place-Migration mit SDBINST und Nachbereitung

Verwendung

Sie verwenden das Programm SDBINST für das Upgrade von Datenbankinstanzen ab der Version 7.3. Dafür installieren Sie zunächst die neue Version der Datenbanksoftware. Anschließend migrieren Sie die Datenbankinstanz/en.

Die Startversion der Datenbanksoftware ist Version 7.3.00 Build größer/gleich 025, die Zielversion ist größer/gleich 7.5.00 (Auswahl der Upgrade-Strategie).

Wenn Sie ein Upgrade von der Version 7.3.00 auf eine Version 7.6.00 durchführen möchten, dann muss der Build der Version 7.6.00 größer/gleich 12 sein.

Sie verwenden diese Vorgehensweise für Datenbankinstanzen, die nicht in ein SAP-System eingebundenen sind, insbesondere dann, wenn sich mehrere Datenbankinstanzen auf den gleichen Installationspfad beziehen.

Diese Upgrade-Strategie ist nur für Datenbankinstanzen des Instanztyps OLTP von Bedeutung. Sie gilt für alle Strukturlink unterstützten Betriebssystemplattformen.

Voraussetzungen

● Die zu aktualisierende Datenbankinstanz ist nicht Bestandteil eines SAP-Systems.

● Sie verfügen über eine Sicherungsvorlage für eine vollständige Datensicherung.

Vorgehensweise

Zur Gewährleistung der Sicherheit Ihrer Daten im Falle eines eventuellen Fehlers während des Migrationsvorganges empfehlen wir Ihnen, als Schritt 6 der Migration eine vollständige Datensicherung der Instanz im Betriebszustand COLD durchzuführen. Wegen des notwendigen Stoppens der Datenbankinstanz führt dies zu einer gewissen Stillstandszeit. Die so entstehende Datensicherung kann jedoch in einem eventuellen Fehlerfall sowohl in eine Datenbankinstanz der Startversion als auch in eine Datenbankinstanz der Zielversion importiert werden.

Alternativ dazu können Sie auch vor dem Beginn der Migration eine vollständige Datensicherung im Betriebszustand WARM ausführen. Diese Sicherung könnte im Fehlerfall jedoch nur zum Wiederherstellen der Datenbankinstanz in der Startversion verwendet werden und ist deshalb keine vollständige Alternative zur Datensicherung im Betriebszustand COLD während des Migrationsvorganges.

...

1. Installieren Sie die Software der Zielversion mit Hilfe des Programms SDBINST (zip-Datei oder tgz-Paket) im Installationspfad <dependent_path_new> parallel zum Installationspfad der Version 7.3. (d. h. ohne die Software der alten Version zu überschreiben)

oder

installieren Sie die Software der Zielversion mit Hilfe des Red Hat Package Manager (rpm-Paket).

Wenn Sie auf Ihrem Rechner die Datenbanksoftware der Version 7.3 mit Hilfe des Red Hat Package Manager installiert haben, können Sie weitere Installationen nur noch mit diesem Programm durchführen. Weitere Installationen mittels SDBINST sind nicht mehr möglich.

2. Führen Sie die nachfolgenden Migrationsschritte für jede einzelne Ihrer Datenbankinstanzen der Startversion durch.

Vorgehensweise

Kommando

...

1.

Rufen Sie als DBM-Benutzer den Database Manager CLI auf und verbinden Sie sich mit der zu migrierenden Datenbankinstanz.

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password>

2.

Stoppen Sie die Datenbankinstanz ordnungsgemäß.

Verwenden Sie dazu das Kommando db_offline und nicht das Kommando db_stop. Nur so ist gewährleistet, dass die Datenbankinstanz in einem eventuellen Fehlerfall Restart-fähig bleibt.

db_offline

3.

Überführen Sie die Datenbankinstanz in den Betriebszustand COLD.

db_cold

4.

Eröffnen Sie eine Uitility-Sitzung

util_connect

5.

Führen Sie das Kommando zur Vorbereitung der Migration aus.

util_execute migrate

6.

Führen Sie im Betriebszustand COLD eine vollständige Datensicherung durch.

backup_start <medium>

7.

Beenden Sie die Utility-Sitzung

util_release

8.

Überführen Sie die Datenbankinstanz in den Betriebszustand OFFLINE.

db_offline

9.

UNIX:

Ordnen Sie die Datenbankinstanz der neuen Softwareversion zu.

Microsoft Windows:

Löschen Sie die Registrierung der Datenbankinstanz.

UNIX:

db_reg –R <dependent_path_new>

Microsoft Windows:

db_drop WITHOUTFILES

10.

Beenden Sie den Database Manager CLI.

nur für Microsoft Windows:

Geben Sie dem Database Manager den Installationspfad der neuen Datenbanksoftware bekannt und erzeugen Sie eine Datenbankinstanz dieser neuen Softwareversion.

exit | release | quit | bye

>dbmcli –R <dependent_path_new> db_create <database_name> <dbm_operator>,<dbm_operator_password>

11.

Melden Sie sich neu an den Database Manager CLI an.

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password>

12.

Starten Sie die Migration der Datenbankparameter.

param_checkall

13.

Wenn Sie ein Upgrade von einer Datenbankversion < 7.5.00 zu einer Datenbankversion größer/gleich 7.5.00 auf einem UNIX-Betriebssystem durchführen, dann nehmen Sie folgende Zwischenschritte vor. Andernfalls verfahren Sie weiter, wie unter Punkt 14. beschrieben.

a. Melden Sie sich vom Database Manager CLI ab.

b. Rufen Sie das Programm SDBINST jener Softwareversion auf, auf die Sie das Upgrade durchführen wollen. Dieses Programm ändert den Eigentümer, die Gruppe sowie die Zugriffsrechte auf die Volumes der Datenbankinstanz entsprechend dem Berechtigungskonzept für UNIX (siehe Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)).

c. Melden Sie sich wieder am Database Manager CLI an.

exit | release | quit | bye

>./SDBINST --main SAPDB::Install::Instance::ChVolPerm::main -d <database_name>

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password>

14.

Wenn Sie ein Upgrade von einer Datenbankversion 7.3.00 auf eine Datenbankversion 7.5.00 durchführen, dann nehmen Sie zusätzlich die folgenden Zwischenschritte vor. Andernfalls verfahren Sie weiter, wie unter Punkt 15 beschrieben.

a. Überführen Sie die Datenbankinstanz in den Betriebszustand ADMIN

b. Geben Sie das Migrationskommando ein.

c. Überführen Sie die Datenbankinstanz in den Betriebszustand OFFLINE.

db_admin

util_execute migrate database

db_offline

15.

Starten Sie die Datenbankinstanz neu. Der Datenbankkatalog wird von 7.3 in die Zielversion migriert.

db_online

16.

Laden Sie die Systemtabellen neu.

Sie erhalten eine Meldung über den erfolgreichen Abschluss.

load_systab

Ergebnis

Sie haben die spezifizierte Datenbankinstanz von der Softwareversion 7.3 in die gewünschte Zielversion migriert.

Sie befindet sich im Betriebszustand ONLINE.


Upgrade mittels APO Extract/Load (SAP-Bibliothek - Installation)

Vorgehensweisen Upgrade mittels APO Extract/Load

Verwendung

Sie verwenden das Programm SDBUPD für das Upgrade mittels APO Extract/Load. Dabei müssen Sie zunächst die Transaktionsdaten des Anwendungssystems aus der liveCache-Datenbankinstanz in der APO-Datenbank sichern und anschließend die Software austauschen (Auswahl der Upgrade-Strategie).

Diese Vorgehensweise ist derzeit nur für den Strukturlink Instanztyp liveCache im SAP-System APO von Bedeutung. Sie gilt für alle vom Datenbanksystem Strukturlink unterstützten Betriebsystemplattformen.

Die Vorgehensweise ist abhängig davon, ob die Startversion kleiner als 7.5.00 oder größer/gleich 7.5.00 ist und auf welchem Betriebssystem Sie arbeiten.

Wenn Sie unter UNIX oder Linux arbeiten und die Startversion kleiner ist als 7.5.00, dann müssen Sie vor dem Upgradevorgang den Strukturlink X-Server und alle Datenbankinstanzen stoppen. Beachten Sie, dass Sie damit die Kommunikation von Clients zu allen lokalen Datenbankinstanzen unterbrechen. Wenn die Startversion größer oder gleich 7.5.00 ist, unterstützt die X-Server-Software ein Update bei laufendem Betrieb des X-Server. Das Stoppen des X-Server und der Datenbankinstanzen ist deshalb nicht mehr notwendig.

Wenn Sie unter Microsoft Windows arbeiten, müssen Sie in jedem Fall den X-Server und alle Datenbankinstanzen stoppen.

Voraussetzungen

● Sie haben die liveCache-Transaktionsdaten in der APO-Datenbank gesichert.

Informationen dazu finden SAP-Kunden im Service Marktplatz unter service.sap.com/upgradeNW2004s

● Die Datenbankparameter der zu aktualisierenden Datenbankinstanz sind seit dem letzten Restart nicht geändert worden.

● Die Datenbankinstanz befindet sich in einem beliebigen Betriebszustand.

Vorgehensweise

...

1. Stoppen Sie gegebenenfalls jede einzelne Datenbankinstanz mit folgendem Kommando:

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> db_offline

2. Stoppen Sie gegebenenfalls jeden einzelnen Scheduler:

>dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password> scheduler_stop

3. Stoppen Sie gegebenenfalls den X-Server.

>x_server stop

4. Starten Sie das Programm SDBUPD durch die Eingabe des folgenden Kommandos:

UNIX, Linux: | Microsoft Windows:
>./SDBUPD –d <database_name> -u <dbm_operator>,<dbm_operator_password> [-o <sapdb_user> -g <sapdb_admin>] | >sdbupd –d <database_name> -u <dbm_operator>,<dbm_operator_password>

Den speziellen Betriebssystembenutzer <sdb_user> und die Gruppe <sdba_group> müssen Sie nur dann angeben, wenn Sie ein Upgrade von einer Softwareversion < 7.5.00 durchführen (siehe Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)).

5. Das Programm SDBUPD führt das Upgrade durch und gibt eine Meldung über den erfolgreichen Abschluss aus. Sie werden aufgefordert, den liveCache zu starten.

6. Starten Sie den liveCache ( Strukturlink liveCache starten).

7. Führen Sie das Wiederherstellen der Daten aus dem APO-System in den liveCache durch.

Informationen dazu finden SAP-Kunden im Service Marktplatz unter service.sap.com/upgradeNW2004s

Ergebnis

Die spezifizierte liveCache-Datenbankinstanz im SAP-System APO und ihre Software wurden aktualisiert.

Der liveCache befindet sich im Betriebszustand ONLINE.


Anschluss von Sicherungswerkzeugen anderer Anbieter (SAP-Bibliothek - Installation)

Komponentendokumentation Anschluss von Sicherungswerkzeugen anderer Anbieter

Einsatzmöglichkeiten

Sie können Sicherungswerkzeuge anderer Anbieter zusammen mit MaxDB- Strukturlink Datenbankwerkzeugen verwenden, um Daten zu sichern und wiederherzustellen oder zu exportieren und zu importieren.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sicherungswerkzeuge anderer Anbieter verwenden.

Funktionsumfang

MaxDB unterstützt den direkten Anschluss einer Reihe von Sicherungswerkzeugen anderer Anbieter. Sie müssen dazu die MaxDB-Software entsprechend konfigurieren.
Sie können auch Sicherungswerkzeuge anderer Anbieter verwenden, die nicht direkt von MaxDB unterstützt werden, wenn diese Werkzeuge Sicherungen aus Pipes verarbeiten können.

Wenn Sie beispielsweise den Datenbestand einer Datenbankinstanz sichern wollen oder Daten aus der Datenbankinstanz exportieren wollen, dann können diese Daten direkt in Dateien, Pipes oder mit Hilfe eines Bandgeräts auf ein Band gesichert werden.

Sie haben jedoch auch die Möglichkeit, die Daten mit Hilfe eines Sicherungswerkzeugs eines anderen Anbieters auf einen Datenträger zu sichern. Auch in diesem Falle steuern Sie die Aktionen mit den MaxDB-Datenbankwerkzeugen. Das Sicherungswerkzeug stellt die Bänder zur Verfügung, auf die die Daten gesichert oder exportiert werden können.

Bei folgenden Aktionen können Sie Sicherungswerkzeuge anderer Anbieter nutzen:

● Sichern auf Datenträger

○ vollständige Datensicherungen

○ inkrementelle Datensicherungen

○ Log-Sicherungen

○ Archivieren der Sicherungsdateien (bei Log-Sicherungen)

● Wiederherstellen von Datenträgern

○ Wiederherstellen der Datenbankinstanz mit Hilfe von Datensicherung(en), Log-Sicherungen und archivierten Log-Sicherungen

● Exportieren von Daten auf Datenträger

○ Exportieren der gesamten Datenbankinstanz

○ Exportieren des gesamten Datenbankkatalogs

● Importieren von Daten von Datenträgern

○ Importieren der gesamten Datenbankinstanz

○ Importieren des gesamten Datenbankkatalogs

Die Vorgehensweisen für das Sichern und Wiederherstellen mit Hilfe der von MaxDB unterstützten Sicherungswerkzeuge entnehmen Sie je nach verwendetem Werkzeug den folgenden Dokumentationen:

Database Manager CLI, Strukturlink Sichern und Wiederherstellen von Datenbankinstanzen
Database Manager GUI, Strukturlink Sichern mit Sicherungswerkzeugen anderer Anbieter und Strukturlink Wiederherstellen mit Sicherungswerkzeugen anderer Anbieter.

Die Vorgehensweisen für das Exportieren und Importieren von Daten nach der erfolgten Konfiguration sind in der Dokumentation Loader, Strukturlink Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter beschrieben.

Testen Sie nach Abschluss der Konfiguration alle geplanten Aktionen. Sie machen sich so mit der Handhabung des entsprechenden MaxDB-Datenbankwerkzeugs vertraut und testen die korrekte Konfiguration der MaxDB-Software für das Sicherungswerkzeug. Dies ist die Voraussetzung dafür, dass alle mit dem Sicherungswerkzeug durchgeführten Aktionen zum Sichern und Wiederherstellen bzw. Importieren und Exportieren von Daten im Produktivbetrieb fehlerlos ablaufen.

Einschränkungen

Beim Sichern und Wiederherstellen wird nur der Wechsel von Microsoft Windows nach Linux und umgekehrt unterstützt. D. h. eine auf dem Betriebssystem Microsoft Windows erstellte Sicherung kann nur auf dem gleichen Betriebssystem oder auf Linux wiederhergestellt werden. Eine auf Linux erstellte Sicherung kann nur auf dem gleichen Betriebssystem oder auf Microsoft Windows wiederhergestellt werden.

Wenn Sie eine Migration von Daten zwischen verschiedenen Betriebssystemen planen, empfiehlt es sich daher in den meisten Fällen, den Loader zu verwenden. Beim Exportieren und Importieren von Daten gibt es von Seiten dieses Datenbankwerkzeugs keine Einschränkungen für den Wechsel des Betriebssystems. Eingeschränkt wird ein Wechsel nur durch die begrenzte Betriebssystemunabhängigkeit der verschiedenen Speichergeräte, da beispielsweise ein Bandgerät oder ein Sicherungswerkzeug bei einem Wechsel von Microsoft Windows nach UNIX mit beiden Betriebssystemen gleichermaßen kompatibel sein müsste. Prüfen Sie dies vorab anhand der Dokumentation zu Ihrem Speichergerät.


Blockdiagramm Sichern und Wiederherstellen (SAP-Bibliothek - Installation)

Hintergrunddokumentation Blockdiagramm Sichern und Wiederherstellen

Das nachfolgende Blockdiagramm veranschaulicht die beim Sichern und Wiederherstellen beteiligten Softwarekomponenten und ihr Zusammenwirken mit einem Sicherungswerkzeug.

Diese Grafik wird im zugehörigen Text erklärt

Beschreibung des Sicherungsvorganges

Mit Hilfe des Database Manager Client geben Sie das Kommando zum Sichern der Daten und rufen damit das Programm DBM-Server auf. Unter einem UNIX-Betriebssystem legt der DBM-Server eine oder mehrere Pipes an, unter Microsoft Windows werden die Pipes vom Datenbankkern angelegt. Der DBM-Server übermittelt die Information zum Starten des Sicherungsvorganges an den Datenbankkern. Sobald Daten in die Pipes geschrieben werden, ruft das Programm DBM-Server das Sicherungswerkzeug auf. Dieses liest die Daten aus den Pipes und sichert sie auf einen Datenträger.

Beschreibung des Wiederherstellungsvorganges

Mit Hilfe des Database Manager Client geben Sie das Kommando zum Wiederherstellen der Daten und rufen damit das Programm DBM-Server auf.

Unter einem UNIX-Betriebssystem legt der DBM-Server eine oder mehrere Pipes an, unter Microsoft Windows werden die Pipes vom Datenbankkern angelegt.

Das Programm DBM-Server übermittelt die Information zum Starten des Wiederherstellungsvorganges an den Datenbankkern. Anschließend ruft es das Sicherungswerkzeug auf und übermittelt diesem die Information, welche Sicherung wiederhergestellt werden soll.

Der Client des Sicherungswerkzeugs fordert den angegebenen Datenträger beim Backup-Server an. Der Server beschafft sich den Datenträger, liest die Daten der Sicherung und überträgt sie an den Client des Sicherungswerkzeugs. Der Client schreibt die Daten in die Pipe/s. Dort werden sie vom Datenbankkern gelesen und in das Datenbanksystem übertragen.


Blockdiagramm Importieren und Exportieren von Daten (SAP-Bibliothek - Installation)

Hintergrunddokumentation Blockdiagramm Importieren und Exportieren von Daten

Das nachfolgende Blockdiagramm veranschaulicht die beim Importieren und Exportieren von Daten beteiligten Softwarekomponenten und ihr Zusammenwirken mit einem Sicherungswerkzeug.

Diese Grafik wird im zugehörigen Text erklärt

Beschreibung des Importvorganges

Mit Hilfe des Loader-Client geben Sie das Kommando zum Importieren der Daten und rufen damit das Programm Loader-Server auf. Daraufhin legt der Loader-Server die Pipes an. Parallel dazu ruft er das Sicherungswerkzeug auf und übermittelt diesem, von welchem Datenträger die Daten geladen werden sollen. Der Client des Sicherungswerkzeugs fordert den angegebenen Datenträger beim Backup-Server an. Der Backup-Server beschafft sich den Datenträger, liest die zu importierenden Daten vom Datenträger und überträgt sie an den Client des Sicherungswerkzeugs. Der Client schreibt die Daten sequentiell in die Pipes. Dort werden sie vom Loader-Server gelesen und in die Datenbankinstanz importiert.

Beschreibung des Exportvorganges

Mit Hilfe des Loader-Client geben Sie das Kommando zum Exportieren der Daten und rufen damit das Programm Loader-Server auf. Daraufhin legt der Loader-Server die Pipes an. Er beginnt, die Daten zu exportieren und sequentiell in die Pipes zu schreiben. Parallel dazu ruft er das Sicherungswerkzeug auf. Dieses liest die Daten sequentiell aus den Pipes und sichert sie auf einen Datenträger.


Anschluss an eine Backint for Oracle-Schnittstelle (SAP-Bibliothek - Installation)

Vorgehensweisen Anschluss an eine Backint for Oracle-Schnittstelle

Eine Vielzahl von Sicherungswerkzeugen anderer Anbieter verfügt über eine Backint for Oracle-Schnittstelle. Prinzipiell kann Backint for Oracle beliebige Dateien im Dateisystem sichern, unabhängig davon, ob auf dem Rechner das Datenbanksystem Oracle installiert ist oder nicht. Die nachfolgende Beschreibung für den Anschluss von MaxDB an eine Backint for Oracle-Schnittstelle setzt voraus, dass diese Eigenschaft vom Hersteller des mit der Backint for Oracle-Schnittstelle ausgestatteten Sicherungswerkzeugs garantiert wird.

Nach entsprechender Konfiguration der MaxDB-Software können die MaxDB-Datenbankwerkzeuge zum Sichern, Wiederherstellen, Importieren und Exportieren von Daten an die Backint for Oracle-Schnittstelle eines solches Sicherungswerkzeugs angeschlossen werden.

Der Anschluss erfolgt über ein Adapterprogramm, das zusammen mit dem Backint for Oracle-Programm des Sicherungswerkzeugs ein Strukturlink Backint for MaxDB-Programm implementiert. Dieses Adapterprogramm ist Bestandteil Ihrer MaxDB-Installation.

Nachdem Sie die gewünschte Aktion über das Datenbankwerkzeug angestoßen haben, kopiert das Adapterprogramm den Datenbestand stückweise in temporäre Dateien. Das Backint for Oracle-Programm wird vom Adapterprogramm mehrmals nacheinander aufgerufen, um diese temporären Dateien mit Hilfe des angeschlossenen externen Sicherungswerkzeugs zu sichern.

Siehe auch:

Einschränkungen für die Verwendung von Backint for Oracle

Funktionsweise des MaxDB-Adapterprogramms

Konfiguration des Backint for Oracle-Anschlusses


Einschränkungen für die Verwendung von Backint for Oracle für Versionen kleiner als 7.5

Hintergrunddokumentation Einschränkungen für die Verwendung von Backint for Oracle für Versionen kleiner als 7.5

Erst ab der Version 7.5 ist es uneingeschränkt möglich, MaxDB über eine Backint for Oracle-Schnittstelle an das Sicherungswerkzeug eines anderen Anbieters anzuschließen. Für frühere Versionen gelten die folgenden Einschränkungen.

Es stehen die jeweils angegebenen MaxDB-Datenbankwerkzeuge zur Verfügung.

MaxDB-Versionen und –Werkzeuge für das Sichern und Wiederherstellen über eine Backint for Oracle-Schnittstelle

Version | Build-Nr. | Verfügbare MaxDB-Werkzeuge
7.4.03 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 002 | auch Web DBM
7.4.02 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 011 | auch Web DBM
7.4.01 | ab 003 | Database Manager CLI, Database Manager GUI
7.3.32 | ab 000 | Database Manager CLI, Database Manager GUI
7.3.00 | ab 015 | Database Manager CLI, Database Manager GUI
 | ab 025 | auch Web DBM
7.2.05 | ab 008 | Database Manager CLI, Database Manager GUI (nur zum Sichern)*

* Mit dieser Version des Database Manager GUI können Sie nur sichern und nicht wiederherstellen. Wenn Sie jedoch eine neuere Version des Database Manager GUI installiert haben, die das Wiederherstellen unterstützt (z. B. 7.4.03), dann können Sie damit auch Datenbanken älterer Versionen (z. B. 7.2.05) wiederherstellen, da dieses Datenbankwerkzeug abwärts kompatibel ist.


Funktionsweise des MaxDB-Adapterprogramms (SAP-Bibliothek - Installation)

Hintergrunddokumentation Funktionsweise des MaxDB-Adapterprogramms

Zum Anschluss von Backint for Oracle an MaxDB wird mit der MaxDB-Software ein Adapterprogramm zur Verfügung gestellt, das im Zusammenwirken mit einem Backint for Oracle-Programm die Spezifikation von Backint for MaxDB erfüllt.

Funktionsweise beim Sichern

...

Die Sicherungsdaten des Datenbanksystems werden über eine oder mehrere Pipes in Empfang genommen und in temporären Dateien gesichert. Die Anzahl und Größe dieser Dateien können Sie in der Parameterdatei des MaxDB-Adapterprogramms definieren.

Das Adapterprogramm ruft das Sicherungswerkzeug auf und sichert die temporären Dateien unter Verwendung des Backint for Oracle-Programms. Anschließend werden die temporären Dateien gelöscht. Dieser Schritt wird so oft wiederholt, bis alle Daten gesichert sind.

Zur Beschleunigung des Vorganges beim Sichern müssen Sie das Adapterprogramm für das parallele Sichern konfigurieren. Dazu definieren Sie eine Gruppe paralleler Datenträger und für jede Pipe eine gesonderte Staging Area. Auf diese Weise werden neue temporäre Dateien erstellt und gleichzeitig bereits erstellte temporäre Dateien unter Verwendung von Backint for Oracle gesichert.

Verwaltungsinformationen werden in einer Sicherungshistorie gespeichert, die vom System nach jeder Sicherung ebenfalls über Backint for Oracle gesichert wird.

Funktionsweise beim Wiederherstellen

...

Die Informationen der Sicherungshistorie werden vom Adapterprogramm ausgewertet.

Mit Hilfe der Sicherungshistorie stellt das Adapterprogramm die erforderlichen temporären Dateien in der richtigen Reihenfolge unter Verwendung von Backint for Oracle wieder her. Die erstellten temporären Dateien werden vom Adapterprogramm über eine oder mehrere Pipes an das Datenbanksystem übergeben.

Wenn im Falle eines Fehlers die Sicherungshistorie nicht mehr vorhanden ist, müssen Sie die letzte Version der Sicherungshistorie manuell mit Backint for Oracle wiederherstellen. Machen Sie sich dafür zuvor mit den Möglichkeiten von Backint for Oracle und der Handhabung Ihres Sicherungswerkzeugs gut vertraut.


Konfiguration des Backint for Oracle-Anschlusses (SAP-Bibliothek - Installation)

Vorgehensweisen Konfiguration des Backint for Oracle-Anschlusses

Verwendung

Sie konfigurieren die MaxDB-Software mit dem Ziel, die MaxDB-Datenbankwerkzeuge zum Sichern, Wiederherstellen, Importieren oder Exportieren von Daten an die Backint for Oracle-Schnittstelle des Sicherungswerkzeugs eines anderen Anbieters anzuschließen.

Voraussetzungen

● Ihr Sicherungswerkzeug verfügt über eine Backint for Oracle-Schnittstelle.

● Die Version Ihres MaxDB-Datenbanksystems unterstützt den Anschluss einer Backint for Oracle-Schnittstelle (Siehe: Einschränkungen für die Verwendung von Backint for Oracle)

● Ihr Backint for Oracle-Programm ist in der Lage, beliebige Dateien in ein Dateisystem zu sichern, auch wenn kein Oracle-Datenbanksystem auf Ihrem Rechner installiert ist.

Vorgehensweise

Zum Anschluss der MaxDB an die Backint for Oracle-Schnittstelle führen Sie folgende Schritte aus:

...

1. Konfiguration der Backint for Oracle-Schnittstelle des Sicherungswerkzeugs entsprechend der Anweisungen des Herstellers. Wenn Sie dazu eine Konfigurationsdatei anlegen müssen, müssen Sie deren Namen in der Parameterdatei des Adapterprogramms (siehe Schritt 2) angeben.

2. Erstellen der Parameterdatei für das MaxDB-Adapterprogramm
Diese Datei verbindet MaxDB mit dem externem Sicherungswerkzeug. In dieser Datei ist gegebenenfalls auch der Name der Konfigurationsdatei des externen Sicherungswerkzeugs (siehe Schritt 1) anzugeben.

Beispiel

3. Erstellen der Konfigurationsdatei für Backint for MaxDB (Fall 1)
Diese Datei verbindet den Database Manager mit dem MaxDB-Adapterprogramm. In dieser Datei ist auch der Name der Parameterdatei des MaxDB-Adapterprogramms (siehe Schritt 1) anzugeben.

Beispiel

4. Exportieren von Umgebungsvariablen des Externen Sicherungswerkzeugs, falls dies vom Hersteller des externen Sicherungswerkzeugs verlangt wird

5. Setzen der Umgebungsvariablen BSI_ENV für das Programm Database Manager

6. Gegebenenfalls Setzen werkzeugunabhängiger Umgebungsvariablen für den Database Manager


Erstellen der Parameterdatei für das MaxDB-Adapterprogramm (SAP-Bibliothek - Installation)

Vorgehensweisen Erstellen der Parameterdatei für das MaxDB-Adapterprogramm

Verwendung

Wenn Sie für ein MaxDB-Datenbanksystem das Sicherungswerkzeug eines anderen Anbieters mit einer Backint for Oracle-Schnittstelle verwenden wollen, müssen Sie zunächst den Anschluss von MaxDB an das Backint for Oracle konfigurieren (Konfiguration des Backint for Oracle-Anschlusses). Das Erstellen der Parameterdatei für das MaxDB-Adapterprogramm ist dabei einer der notwendigen Schritte.

Mit der Parameterdatei legen Sie fest, wo das Adapterprogramm die erforderlichen temporären Dateien erzeugen soll und wo das Schnittstellenprogramm Backint for Oracle zu finden ist.

Den Namen dieser Parameterdatei hinterlegen Sie bei der Konfiguration von Backint for MaxDB in der Konfigurationsdatei des Backint for MaxDB (Schlüsselwort PARAMETERFILE).

Vorgehensweise

In jeder Zeile der Parameterdatei legen Sie einen Parameter des MaxDB-Adapterprogramms fest. Dazu müssen Sie am Anfang jeder Zeile das Schlüsselwort für den Parameter und anschließend den oder die gewünschten Wert/e angeben. Zeilen, die nicht durch Schlüsselwörter eingeleitet werden, werden vom System ignoriert.

Syntax

<key_string> <value_string>

<key_string> | Schlüsselwort für einen Parameter, kann aus einem oder mehreren Wörtern bestehen
<value_string> | Wert/e des Parameters

Für das MaxDB-Adapterprogramm definieren Sie folgende Parameter:

Parameter

Syntax

Beschreibung

Absoluter Pfad und Größe einer temporären Datei

STAGING AREA: <absolute_path>/<file_name> <size> [KB|MB|GB]

Sie können bis zu 256 temporäre Dateien definieren.
Wenn Sie keine Einheit für die Größe angeben, dann wird diese in Byte konfiguriert.
Das Programm verwendet genau eine temporäre Datei für jede Pipe.

Maximale Anzahl der temporären Dateien, die gleichzeitig durch Backint for Oracle verarbeitet werden sollen.

FILES PER BACKINT CALL: <number>

Vorschlagswert: 1.
Das Programm kann temporäre Dateien sichern und gleichzeitig andere temporäre Dateien erzeugen, vorausgesetzt, die hier definierte Anzahl <number> ist kleiner als die Zahl der bei der Sicherung/Wiederherstellung verwendeten Pipes.

Absoluter Pfad und Name des Backint for Oracle-Programms

BACKINT: <absolute_path>/<file_name>

Absoluter Pfad und Name der Konfigurationsdatei für das Backint for Oracle-Programm

PARAMETERFILE OF BACKINT: <absolute_path>/<file_name>h>

Definieren Sie diesen Parameter nur, wenn für das Sicherungswerkzeug eine Konfigurationsdatei zu erstellen ist. Andernfalls verwenden Sie dieses Schlüsselwort nicht.

Absoluter Pfad und Name der Sicherungshistorie

HISTORY FILE: <absolute_path>/<file_name>

Die Sicherungshistorie enthält die für das Wiederherstellen erforderlichen Informationen.

Absoluter Pfad und Name der Standard-Eingabedatei

INPUTFILE FOR BACKINT: <absolute_path>/<file_name>

Diese Dateien müssen von den für den Backint for MaxDB-Anschluss konfigurierten Dateien verschieden sein (siehe INPUT, OUTPUT, ERROROUTPUT in Erstellen der Konfigurationsdatei für Backint for MaxDB)

Absoluter Pfad und Name der Standard-Ausgabedatei

OUTPUTFILE FOR BACKINT: <absolute_path>/<file_name>

Absoluter Pfad und Name der Standard-Fehlerausgabedatei

ERRORFILE FOR BACKINT: <absolute_path>/<file_name>

Maximale Wartezeit in Sekunden zwischen der Erstellung einer temporären Datei und dem Beginn ihres Sicherns mit Backint for Oracle

MAXIMAL DELAY OF BACKINT CALL: <number>

Vorschlagswert: 10
Angabe zur Verhinderung von Deadlocks in Ausnahmesituationen beim parallelen Sichern oder Wiederherstellen

Wenn die temporären Dateien unterschiedlich schnell erzeugt werden und bereits eine temporäre Datei komplett vorliegt, wartet das Adapterprogramm maximal für die hier angegebene Zeitdauer auf die komplette Erstellung einer anderen temporären Datei. Wenn innerhalb der angegebenen Zeitdauer keine weitere Datei erstellt wird, wird die bereits erzeugte temporäre Datei gesichert.

Wählen Sie die Zeitdauer so groß, dass die konfigurierte Anzahl temporärer Dateien (FILES PER BACKINT CALL:) gleichzeitig gesichert werden kann.

Angabe, ob das Adapterprogramm den abschließenden Schrägstrich (/ oder \) eines absoluten Verzeichnisnamens für Backint for Oracle ignorieren soll.

OMIT LAST DIRECTORY DELIMITER ON RESTORE: <option>

<option> ::= YES | NO

NO: Vorschlagswert
der Schrägstrich wird nicht ignoriert.
YES: Der Schrägstrich wird ignoriert.
Verwenden Sie diese Option, um Probleme mit Backint for Oracle-Implementierungen zu vermeiden, die am Ende eines Verzeichnisnamens keinen abschließenden Schrägstrich (/ oder \) erwarten.
Dieser Parameter wird für die folgenden MaxDB-Versionen ab den angegebenen Build-Nummern unterstützt:
7.4.03 ab Build 000, 7.4.02 ab Build 002, 7.3.00 ab Build 021, 7.2.05 ab Build 016

Wert der Umgebungsvariablen BI_CALLER

BI_CALLER VALUE: <value>: <value>

Setzen Sie diesen Parameter nur, wenn das Sicherungswerkzeug das Setzen dieses Parameters verlangt. Gemäss Systemvorschlag wird die Variable BI_CALLER vor dem Aufrufen von Backint for Oracle aus der Umgebung entfernt. Bei den meisten Backint for Oracle-Implementierungen muss dieser Wert nicht gesetzt werden, da diese das Fehlern der Umgebungsvariablen BI_CALLER zulassen. Dieser Parameter wird für die folgenden MaxDB-Versionen ab den angegebenen Build-Nummern unterstützt:
alle Versionen ab 7.4.04 Build 000, 7.4.03 ab Build 006, 7.4.02 ab Build 016, 7.3.0 ab Build 029, 7.2.05 ab Build 025

Siehe auch:

Beispiel einer Parameterdatei für das MaxDB-Adapterprogramm


Beispiel einer Parameterdatei für das MaxDB-Adapterprogramm (SAP-Bibliothek - Installation)

Diese Grafik wird im zugehörigen Text erklärt Beispiel einer Parameterdatei für das MaxDB-Adapterprogramm

Verwendung

Sie können sich das Erstellen der Parameterdatei für das MaxDB-Adapterprogramm erleichtern, wenn Sie folgendes Beispiel verwenden und Ihren Erfordernissen anpassen. Wenn Sie dabei erreichen wollen, dass ein bestimmter Parameter nicht über die Parameterdatei gesetzt wird, müssen Sie das entsprechende Schlüsselwort ungültig machen oder löschen.

Im Beispiel einer Konfigurationdatei für Backint for MaxDB nennen wir die hier erstellte Parameterdatei backintmaxdbconfig.par.

Dateiinhalt

STAGING AREA: D:\TEMP\STAGE1 1 GB
STAGING AREA: E:\TEMP\STAGE2 1024 MB
STAGING AREA: F:\TEMP\STAGE3 1048576 KB
STAGING AREA: G:\TEMP\STAGE4 1073741824

FILES PER BACKINT CALL: 2

BACKINT: "C:\Program Files\BackupTool\BIN\backint.exe"
PARAMETERFILE OF BACKINT: C:\BackupTool\CONF\backintoraconfig.utl

HISTORY FILE: C:\SAPDB\BackintHistory

INPUTFILE FOR BACKINT: C:\TEMP\backint4Oracle.in
OUTPUTFILE FOR BACKINT: C:\TEMP\backint4Oracle.out
ERRORFILE FOR BACKINT: C:\TEMP\backint4Oracle.err

MAXIMAL DELAY OF BACKINT CALL: 30

Erläuterung

Schlüsselwort | Wert/e | Erläuterung
STAGING AREA: | D:\TEMP\STAGE1 1 GB E:\TEMP\STAGE2 1024 MB F:\TEMP\STAGE3 1048576 KB G:\TEMP\STAGE4 1073741824 | Das so konfigurierte Adapterprogramm kann maximal vier Pipes gleichzeitig sichern bzw. wiederherstellen. Die dabei erzeugten temporären Dateien erreichen eine Größe von einem Gigabyte, solange nicht das Ende der Pipe erreicht ist.
FILES PER BACKINT CALL: | 2 | Sobald zwei der vier temporären Dateien komplett erstellt wurden, werden diese durch den Aufruf des Backint for Oracle-Programms gesichert.
BACKINT: | "C:\Program Files\BackupTool\BIN\backint.exe" | Der absolute Pfad des Backint for Oracle-Programms lautet: "C:\Program Files\BackupTool\BIN\backint.exe" Wenn der Pfad Leerzeichen enthält, dann schließen Sie den Pfad mit doppelten Anführungszeichen ein.
PARAMETERFILE OF BACKINT: | C:\BackupTool\CONF\backint oraconfig.utl | Der absolute Pfad der Konfigurationsdatei des Backint for Oracle-Programms lautet: C:\BackupTool\CONF\backintoraconfig.utl.
HISTORY FILE: | C:\SAPDB\BackintHistory | Das Adapterprogramm hinterlegt die Sicherungshistorie am Ende jeder Sicherung unter dem Pfad C:\SAPDB\BackintHistory und sichert diese durch einen weiteren Aufruf des Backint for Oracle-Programms.
INPUTFILE FOR BACKINT: | C:\TEMP\backint4Oracle.in | Standardeingabe für Backint for Oracle: C:\TEMP\backint4Oracle.in
OUTPUTFILE FOR BACKINT: | C:\TEMP\backint4Oracle.out | Standardausgabe für Backint for Oracle: C:\TEMP\backint4Oracle.out
ERRORFILE FOR BACKINT: | C:\TEMP\backint4Oracle.err | Standard-Fehlerausgabe für Backint for Oracle: C:\TEMP\backint4Oracle.err
MAXIMAL DELAY OF BACKINT CALL: | 30 | Wenn die temporären Dateien unterschiedlich schnell erzeugt werden und bereits eine temporäre Datei komplett vorliegt, wartet das Adapterprogramm maximal 30 Sekunden auf die komplette Erstellung einer der anderen temporären Dateien. Wird keine dieser Dateien innerhalb von 30 Sekunden erstellt, wird die bereits erstellte temporäre Datei unter Verwendung von Backint for Oracle gesichert.


Erstellen der Konfigurationsdatei für Backint for MaxDB

Vorgehensweisen Erstellen der Konfigurationsdatei für Backint for MaxDB

Verwendung

Sie konfigurieren die MaxDB-Software mit dem Ziel, die MaxDB- Strukturlink Datenbankwerkzeuge zum Sichern, Wiederherstellen, Exportieren oder Importieren von Daten an das Sicherungswerkzeug eines anderen Anbieters anzuschließen.

Mit der Konfigurationsdatei für Backint for MaxDB teilen Sie dem Database Manager mit, wo das Backint for MaxDB-Programm abgelegt ist und wie es angesprochen werden soll.

Fall 1: Anschluss an Backint for Oracle über das MaxDB-Adapterprogramm

Wenn Sie für ein MaxDB-Datenbanksystem ein Sicherungswerkzeug mit einer Backint for Oracle-Schnittstelle verwenden wollen, müssen Sie zunächst den Anschluss von MaxDB an das Backint for Oracle-Programm konfigurieren (Konfiguration des Backint for Oracle-Anschlusses). Das Erstellen der Konfigurationsdatei für Backint for MaxDB ist dabei einer der notwendigen Schritte.

(Siehe auch: Funktionsweise des MaxDB-Adapterprogramms)

Fall 2 - Anschluss an die Backint for MaxDB-Schnittstelle des Sicherungswerkzeugs eines anderen Anbieters

Wenn Sie für ein MaxDB-Datenbanksystem ein Sicherungswerkzeug mit einer Backint for MaxDB-Schnittstelle verwenden wollen, müssen Sie eine Konfigurationsdatei erstellen. Diese entspricht im Wesentlichen der Konfigurationsdatei gemäß Fall 1. Unterschiede sind in der nachfolgenden Beschreibung berücksichtigt.

Es wird vorausgesetzt, dass die Backint for MaxDB-Schnittstelle des Herstellers des Sicherungswerkzeugs der Backint for MaxDB-Spezifikation entspricht (siehe auch: Dokumentation Strukturlink Backint for MaxDB).

Vorgehensweise

In jeder Zeile der Konfigurationsdatei legen Sie einen Parameter des Database Manager fest. Dazu müssen Sie am Anfang jeder Zeile das Schlüsselwort für den Parameter und anschließend den oder die gewünschten Wert/e angeben. Zeilen, die nicht durch Schlüsselwörter eingeleitet werden, werden vom System ignoriert.

Syntax

<key_string> <value_string>

<key_string> | Schlüsselwort für einen Parameter, kann aus einem oder mehreren Wörtern bestehen
<value_string> | Wert/e des Parameters

Für den Anschluss von Backint for MaxDB an den Database Manager definieren Sie folgende Parameter:

Parameter

Syntax

Beschreibung

Absoluter Pfad und Name des Backint-Programms

BACKINT <absolute_path>/<file_name>

Fall 1 - Anschluss an eine Backint for Oracle-Schnittstelle über das MaxDB-Adapterprogramm: Geben Sie den absoluten Pfad und Namen des mit MaxDB ausgelieferten Adapterprogramms an.

Fall 2 - Anschluss an die Backint for MaxDB-Schnittstelle des Sicherungswerkzeugs: Geben Sie den absoluten Pfad und Namen des Backint for MaxDB-Programms an.

Absoluter Pfad und Name der Standard-Eingabedatei

INPUT <absolute_path>/<file_name>

Diese Datei legt der Database Manager temporär an und verwendet sie als Standardeingabe von Backint for MaxDB.

Vorschlagswert ist die Datei bsi.in im Arbeitsverzeichnis der Datenbankinstanz.

Absoluter Pfad und Name der Standard-Ausgabedatei

OUTPUT <absolute_path>/<file_name>

Diese Datei legt der Database Manager temporär an und verwendet sie als Standardausgabe von Backint for MaxDB.

Vorschlagswert ist die Datei bsi.out im Arbeitsverzeichnis der Datenbankinstanz.

Absoluter Pfad und Name der Standard-Fehlerausgabedatei

ERROROUTPUT <absolute_path>/<file_name>

Diese Datei legt der Database Manager temporär an und verwendet sie als Standardfehlerausgabe von Backint for MaxDB.

Vorschlagswert ist die Datei bsi.err im Arbeitsverzeichnis der Datenbankinstanz.

Absoluter Pfad und Name der Konfigurationsdatei des Backint for MaxDB-Programms

PARAMETERFILE <absolute_path>/<file_name>

Fall 1 - Anschluss an eine Backint for Oracle-Schnittstelle über das MaxDB-Adapterprogramm: Geben Sie den absoluten Pfad und Namen der Parameterdatei des Adapterprogramms an.

Fall 2 - Anschluss an die Backint for MaxDB-Schnittstelle des Sicherungswerkzeugs: Geben Sie den absoluten Pfad und Namen einer eventuell zu definierenden Konfigurationsdatei des Backint for MaxDB-Programms an.

Zeitangabe in sec,

Zeit nach der sich das Sicherungswerkzeug selbst beendet, nachdem der Datenbankkern alle Daten erfolgreich übertragen hat

TIMEOUT_SUCCESS <number>

Vorschlagswert: 300

Fall 1 - Anschluss an eine Backint for Oracle-Schnittstelle über das MaxDB-Adapterprogramm: Wählen Sie den Wert groß genug, damit das Sicherungswerkzeug alle übertragenenen Daten in dieser Zeit auf Band sichern kann. Maßgeblich dafür sind die Anzahl der temporären Dateien und ihre konfigurierte Größe.

Fall 2 - Anschluss an die Backint for MaxDB-Schnittstelle des Sicherungswerkzeugs: Zeitspanne, nach der der Database Manager das externe Sicherungswerkzeug beenden soll, wenn alle Daten an die Pipes übergeben wurden.

Beachten Sie, dass sich das Sicherungswerkzeug nach der definierten Zeitspanne in jedem Fall beendet, unabhängig davon, ob bereits alle vom Datenbankkern übertragenen Daten tatsächlich vom Sicherungswerkzeug gesichert wurden.

Zeitangabe in sec,

Zeit nach der sich das Sicherungswerkzeug selbst beendet, wenn der Datenbankkern den Sicherungsvorgang aufgrund eines Fehler abgebrochen hat

TIMEOUT_FAILURE <number>

Vorschlagswert: 300

Definieren Sie einen ausreichend großen Wert, der dem Sicherungswerkzeug ermöglicht, alle vom Datenbankkern übertragenen Daten noch zu sichern, da das Sicherungswerkzeug sich nach dem festgelegten Time-out in jedem Fall beendet, auch wenn noch nicht alle übertragenen Daten gesichert wurden. Andererseits sollte der Wert nicht größer als notwendig sein. Nur so können Sie vermeiden, dass ein vom Datenbankkern abgebrochener Sicherungsvorgang das Starten weiterer Sicherungsvorgänge (beispielsweise bei automatischen Nachtläufen) blockiert.

Absoluter Pfad des Strukturlink Arbeitsverzeichnisses der Quelldatenbank

ORIGINAL_RUNDIRECTORY <absolute_path>

Vorschlagswert: Arbeitsverzeichnis der aktuell verwendeten Datenbankinstanz

Dieser Parameter ist nur bei einer Migration anzugeben.
Voraussetzung für eine Migration von einem Rechner auf einen anderen ist, dass das verwendete Backint for MaxDB Sicherungen des Quellrechners auf dem Zielrechner zur Verfügung stellen kann.

Beachten Sie bei der Angabe dieses Wertes Groß- und Kleinschreibung.

Siehe auch:

Beispiel einer Konfigurationsdatei für Backint for MaxDB


Beispiel einer Konfigurationsdatei für Backint for MaxDB

Diese Grafik wird im zugehörigen Text erklärt Beispiel einer Konfigurationsdatei für Backint for MaxDB

Verwendung

Sie können sich das Erstellen der Konfigurationsdatei für Backint for MaxDB erleichtern, wenn Sie folgendes Beispiel verwenden und Ihren Erfordernissen anpassen. Wenn Sie dabei erreichen wollen, dass ein bestimmter Parameter nicht über die Parameterdatei gesetzt wird, müssen Sie das entsprechende Schlüsselwort ungültig machen oder löschen.

Dateiinhalt

Fall 1: - Anschluss an eine Backint for Oracle-Schnittstelle über MaxDB-Adapterprogramm:

BACKINT C:\SAPDB\TST\db\bin\backint.exe
INPUT C:\TEMP\backint4MAXDB.in
OUTPUT C:\TEMP\backint4MAXDB.out
ERROROUTPUT C:\TEMP\backint4MAXDB.err
PARAMETERFILE C:\SAPDB\WRK\TST\backintmaxdbconfig.par
TIMEOUT_SUCCESS 600
TIMEOUT_FAILURE 300
ORIGINAL_RUNDIRECTORY C:\SAPDB\wrk\CUSTOMERDB

Fall 2: - Anschluss an die Backint for MaxDB-Schnittstelle eines externen Sicherungswerkzeugs (Fremdhersteller)

BACKINT C:\Backuptool\backint.exe
INPUT C:\TEMP\backint4MAXDB.in
OUTPUT C:\TEMP\backint4MAXDB.out
ERROROUTPUT C:\TEMP\backint4MAXDB.err
PARAMETERFILE C:\SAPDB\WRK\TST\backintmaxdbconfig.par
TIMEOUT_SUCCESS 600
TIMEOUT_FAILURE 300
ORIGINAL_RUNDIRECTORY C:\SAPDB\wrk\CUSTOMERDB

Erläuterung

Schlüsselwort | Wert | Erläuterung
BACKINT | C:\Backuptool\backint.exe | Der absolute Pfad des Backint for MaxDB-Programms ist C:\Backuptool\backintsapdb.exe.
INPUT | C:\TEMP\backint4MAXDB.in | Der absolute Pfad der Standardeingabe ist C:\TEMP\backint4MAXDB.in
OUTPUT | C:\TEMP\backint4MAXDB.out | Der absolute Pfad der Standardausgabe ist C:\TEMP\backint4MAXDB.out
ERROROUTPUT | C:\TEMP\backint4MAXDB.err | Der absolute Pfad der Standardfehlerausgabe ist C:\TEMP\backint4MAXDB.err
PARAMETERFILE | C:\SAPDB\WRK\TST\adaptprog.par | Der absolute Pfad der Parameterdatei des Adapterprogramms ist C:\SAPDB\WRK\TST\adaptprog.par.
TIMEOUT_SUCCESS | 600 | Im Erfolgsfall wartet der Database Manager maximal 10 Minuten, um Backint for MaxDB zu beenden.
TIMEOUT_FAILURE | 300 | Im Fehlerfall wartet der Database Manager maximal 5 Minuten, um Backint for MaxDB zu beenden.
ORIGINAL_RUNDIRECTORY | C:\SAPDB\wrk\ CUSTOMERDB | Das Arbeitsverzeichnis der Original-Datenbankinstanz ist C:\SAPDB\wrk\P1.


Exportieren von Umgebungsvariablen für das externe Sicherungswerkzeug

Vorgehensweisen Exportieren von Umgebungsvariablen für das externe Sicherungswerkzeug

Verwendung

Falls der Hersteller des externen Sicherungswerkzeugs den Export von Umgebungsvariablen vorschreibt, können Sie diese vor dem Aufrufen des externen Sicherungswerkzeugs vom Database Manager in die Umgebung exportieren lassen.

Das Exportieren von Umgebungsvariablen wird für die folgenden Datenbankversionen ab den angegebenen Build-Nummern unterstützt:
7.2.05 ab Build 016, 7.3.00 ab Build 021, 7.4.02 ab Build 002, 7.4.03 ab Build 000

Syntax

dbmcli -d <database_name> -n <database_server> -u <dbm_operator>,<dbm_operator_password> dbm_configset -raw set_variable_<number> <variable>=<value>

<number> | Frei wählbare Nummerierung für die zu setzenden Variablen (0<= number <=100)
<variable> | Umgebungsvariable
<value> | Wert der Umgebungsvariablen

Wenn Sie für eine Umgebungsvariable mehrere Werte hinterlegen, dann löst der Database Manager den Konflikt folgendermaßen auf.
Beispiel:
Sie haben folgende DBM-Kommandos eingegeben:

dbmcli ... dbm_configset -raw set_variable_<number1> <variable>=<value1>

dbmcli ... dbm_configset -raw set_variable_<number2> <variable>=<value2>

Wenn number1 < number2, dann exportiert der Database Manager nur den Wert <value1> für die Umgebungsvariable <variable>, andernfalls nur den Wert <value2>.

Wenn Sie eine der Umgebungsvariablen TEMP, TMP, ADINT, ADA_OPT, NSR_ENV, NSR_POOL, NSR_EXPIRE oder BSI_ENV sowohl mit
dbmcli ... dbm_configset -raw <variable> <value1>
bekannt machen als auch mit
dbmcli ... dbm_configset -raw set_variable_<number> <variable>=<value2>
exportieren, dann wird die Umgebungsvariable mit dem Wert <value1> exportiert, bevor ein externes Sicherungswerkzeug aufgerufen wird.


Setzen der Umgebungsvariablen BSI_ENV (SAP-Bibliothek - Installation)

Vorgehensweisen Setzen der Umgebungsvariablen BSI_ENV

Verwendung

Damit der Database Manager oder Loader auf dem Datenbankrechner auf die Konfigurationsdatei für Backint for MaxDB zugreifen können, müssen Sie deren absoluten Pfad in der Umgebungsvariablen BSI_ENV mit Hilfe des Database Manager CLI explizit hinterlegen.

Andernfalls verwendet das System die in der folgenden Tabelle angegebene Datei als Konfigurationsdatei:

Betriebssystem | Datei
UNIX | < Strukturlink run_directory>/bsi.env
Microsoft Windows | <run_directory>\bsi.env

Syntax

dbmcli -d <database_name> -n <database_computer> -u <dbm_operator>,<dbm_operator_password> dbm_configset -raw BSI_ENV <value>

<value>

Wert der Umgebungsvariablen BSI_ENV

Siehe auch:

Database Manager CLI, Abschnitt Strukturlink dbm_configset


Setzen werkzeugunabhängiger Umgebungsvariablen für den Database Manager

Hintergrunddokumentation Setzen werkzeugunabhängiger Umgebungsvariablen für den Database Manager

Verwendung

Damit der Database Manager auf dem Datenbankrechner auf von ihm benötigte Variablen zugreifen kann oder um zu erzwingen, dass der Database Manager vor dem Aufruf eines externen Sicherungswerkzeugs Umgebungsvariablen exportiert, müssen Sie diese Umgebungsvariablen mit Hilfe des Database Manager CLI explizit hinterlegen.

Sie können diese Umgebungsvariablen für jedes externe Sicherungswerkzeug setzen. Die so definierten Werte übersteuern die eventuell in der Umgebung oder in der Konfigurationsdatei des externen Sicherungswerkzeugs definierten Werte für diese Variablen.

¡ Wenn Sie die Umgebungsvariablen TEMP oder TMP übersteuern wollen, verfahren Sie weiter wie im Abschnitt Setzen vom TEMP oder TMP beschrieben.

¡ Wenn Sie für externe Sicherungswerkzeuge von Fremdherstellern Timeouts definieren wollen, verfahren Sie weiter wie im Abschnitt Setzen von DBM_TTO_SUCCESS und DBM_TTO_FAILURE beschrieben.

Sie können damit definieren, wie lange das externe Sicherungswerkzeug Zeit haben soll, um die Sicherung zu beenden, nachdem alle Daten an die Pipe/s übergeben wurden, oder nach welcher Zeitspanne im Falle eines Fehlers der Vorgang abgebrochen werden soll.

Die gleiche Vorgehensweise verwenden Sie für Backint for MaxDB, wenn Sie die in der Konfigurationsdatei definierten Werte für TIMEOUT_SUCCESS und/oder TIMEOUT_FAILURE übersteuern wollen.


Setzen von TEMP oder TMP (SAP-Bibliothek - Installation)

Vorgehensweisen Setzen von TEMP oder TMP

Verwendung

Sie setzen mit Hilfe des Database Manager CLI die Umgebungsvariablen TEMP oder TMP. Die so definierten Werte übersteuern die in der Konfigurationsdatei des Database Manager oder der Umgebung bereits hinterlegten Werte für TEMP oder TMP.

Syntax

dbmcli –d <database_name> -n <database_computer> -u <dbm_operator>,<dbm_operator_password> dbm_configset –raw <variable> <value>

<variable> | Name der Umgebungsvariablen TEMP | TMP
<value> | absoluter Pfad und Name des Verzeichnisses, in dem der Database Manager temporäre Dateien erzeugt


Setzen von DBM_TTO_SUCCESS und DBM_TTO_FAILURE (SAP-Bibliothek - Installation)

Vorgehensweisen Setzen von DBM_TTO_SUCCESS und DBM_TTO_FAILURE

Verwendung

Sie definieren mit Hilfe des Database Manager CLI die Werte für die Umgebungsvariablen DBM_TTO_SUCCESS und DBM_TTO_FAILURE.

Mit der Variablen DBM_TTO_SUCCESS definieren Sie den Zeitraum, nach dem der Database Manager das externe Sicherungswerkzeug beenden soll, wenn der Datenbankkern alle Daten an die Pipes oder Dateien übertragen hat. Es wird auch dann beendet, wenn noch nicht alle vom Datenbankkern übertragenen Daten in Pipes oder Dateien gesichert wurden, um den Sicherungsvorgang bei einem eventuellen Fehler des Sicherungswerkzeugs abzuschließen.

Für Backint for MaxDB übersteuern Sie damit den Wert des Parameters TIMEOUT_SUCCESS in der Konfigurationsdatei für Backint for MaxDB.

Mit der Variablen DBM_TTO_FAILURE definieren Sie den Zeitraum, nach dem der Database Manager das externe Sicherungswerkzeug beenden soll, wenn der Datenbankkern den Sicherungsvorgang aufgrund eines Fehlers abgebrochen hat. Es wird auch dann beendet, wenn der Datenbankkern noch nicht alle Daten an die Pipes oder Dateien übertragen hat, um beispielsweise bei automatischen Nachtläufen das Starten weiterer Sicherungsvorgänge zu ermöglichen.

Für Backint for MaxDB übersteuern Sie damit den Wert des Parameters TIMEOUT_FAILURE in der Konfigurationsdatei für Backint for MaxDB.

Syntax

dbmcli –d <database_name> -n <database_computer> -u <dbm_operator>,<dbm_operator_password> dbm_configset –raw <variable> <value>

<variable> | Name der Umgebungsvariablen DBM_TTO_SUCCESS | DBM_TTO_FAILURE
<value> | Wert des Time-outs in Sekunden


Anschluss an eine Backint for MaxDB-Schnittstelle (SAP-Bibliothek - Installation)

Vorgehensweisen Anschluss an eine Backint for MaxDB-Schnittstelle

Verwendung

Bislang sind externe Sicherungswerkzeuge, die über eine eigene Backint for MaxDB-Schnittstelle verfügen, noch in der Entwicklungsphase. Die Anforderungen an eine solche Schnittstelle sind in der Dokumentation Strukturlink Backint for MaxDB dokumentiert.

Die im Abschnitt Anschluss an eine Backint for Oracle-Schnittstelle dokumentierte Backint for MaxDB-Implementierung mit Hilfe eines Adapterprogramms verwendet ein von SAP entwickeltes und mit dem MaxDB-Softwarepaket ausgeliefertes Programm, das für den Anschluss an Backint for Oracle bestimmt ist. Die dafür zu erstellende Konfigurationsdatei entspricht jedoch der Konfigurationsdatei, die auch für ein externes Sicherungswerkzeug mit eigener Backint for MaxDB-Schnittstelle zu erstellen wäre, wenn vom Hersteller die in der Dokumentation Backint for MaxDB beschriebenen Anforderungen erfüllt werden.

Voraussetzungen

Die Version Ihres MaxDB-Datenbanksystems unterstützt den Anschluss einer Backint for MaxDB-Schnittstelle (Einschränkungen für die Verwendung von Backint for MaxDB).

Vorgehensweise

Für den Anschluss an eine Backint for MaxDB-Schnittstelle führen Sie folgende Schritte aus:

...

1. Erstellen der Konfigurationsdatei für Backint for MaxDB, Fall 2

2. Exportieren von Umgebungsvariablen des Externen Sicherungswerkzeugs, falls dies vom Hersteller des externen Sicherungswerkzeugs vorgesehen ist.

3. Setzen der Umgebungsvariablen BSI_ENV, für den Database Manager

4. Gegebenenfalls Setzen werkzeugunabhängiger Umgebungsvariablen für den Database Manager


Einschränkungen für die Verwendung von Backint for MaxDB für Versionen kleiner als 7.5

Hintergrunddokumentation Einschränkungen für die Verwendung von Backint for MaxDB für Versionen kleiner als 7.5

Erst ab der Version 7.5 ist es uneingeschränkt möglich, MaxDB über eine Backint for MaxDB-Schnittstelle an das Sicherungswerkzeug eines anderen Anbieters anzuschließen. Für frühere Versionen gelten die folgenden Einschränkungen.

Es stehen die jeweils angegebenen MaxDB-Datenbankwerkzeuge zur Verfügung.

MaxDB-Versionen und –Werkzeuge für das Sichern und Wiederherstellen über eine Backint for MaxDB-Schnittstelle

Version | Build-Nr. | Verfügbare MaxDB-Werkzeuge
7.4.03 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 002 | auch Web DBM
7.4.02 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 011 | auch Web DBM
7.4.01 | ab 003 | Database Manager CLI, Database Manager GUI
7.3.32 | ab 000 | Database Manager CLI, Database Manager GUI
7.3.00 | ab 015 | Database Manager CLI, Database Manager GUI
 | ab 025 | auch Web DBM
7.2.05 | ab 008 | Database Manager CLI, Database Manager GUI (nur zum Sichern)*

* Mit dieser Version des Database Manager GUI können Sie nur sichern und nicht wiederherstellen. Wenn Sie jedoch eine neuere Version des Database Manager GUI installiert haben, die das Wiederherstellen unterstützt (z. B. 7.4.03), dann können Sie damit auch Datenbanken älterer Versionen (z. B. 7.2.05) wiederherstellen, da dieses Datenbankwerkzeug abwärts kompatibel ist.


Anschluss an TSM (SAP-Bibliothek - Installation)

Hintergrunddokumentation Anschluss an TSM

MaxDB unterstützt den Anschluss an das externe Sicherungswerkzeug TSM der Firma IBM/Tivoli für das Sichern, Wiederherstellen, Importieren und Exportieren von Daten nach entsprechender Konfiguration der MaxDB-Software.

Beachten Sie die versionsspezifischen Einschränkungen für die Verwendung von TSM bzw. für die Möglichkeit, Daten parallel zu sichern oder wiederherzustellen.

Weitere Informationen finden Sie unter folgender Adresse: www.ibm.com

Siehe auch:

Einschränkungen für die Verwendung von TSM

Einschränkungen für das Parallele Sichern und Wiederherstellen mit TSM

Konfiguration des TSM-Anschlusses


Einschränkungen für die Verwendung von TSM für Versionen kleiner als 7.5

Hintergrunddokumentation Einschränkungen für die Verwendung von TSM für Versionen kleiner als 7.5

Erst ab der Version 7.5 ist es uneingeschränkt möglich, MaxDB-Datenbanksysteme mit Hilfe des Sicherungswerkzeugs TSM zu sichern und wiederherzustellen. Für frühere Versionen gelten die folgenden Einschränkungen.

Es stehen die jeweils angegebenen MaxDB-Datenbankwerkzeuge zur Verfügung.

MaxDB-Versionen und –Werkzeuge für das Sichern und Wiederherstellen mittels TSM

Version | Build-Nr. | Verfügbare MaxDB-Werkzeuge
7.4.03 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 002 | auch Web DBM
7.4.02 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 011 | auch Web DBM
7.3.32 | ab 000 | Database Manager CLI, Database Manager GUI (nur zum Sichern)*
7.3.00 | ab 000 | Database Manager CLI, Database Manager GUI (nur zum Sichern)*
 | ab 015 | Database Manager CLI, Database Manager GUI
 | ab 025 | auch Web DBM
7.2.05 | ab 000 | Database Manager CLI, Database Manager GUI (nur zum Sichern)*

* Mit dieser Version des Database Manager GUI können Sie nur sichern und nicht wiederherstellen. Wenn Sie jedoch eine neuere Version des Database Manager GUI installiert haben, die das Wiederherstellen unterstützt (z. B. 7.4.03), dann können Sie damit auch Datenbanken älterer Versionen (z. B. 7.2.05) wiederherstellen, da dieses Datenbankwerkzeug abwärts kompatibel ist.

Siehe auch:

Einschränkungen für das Parallele Sichern und Wiederherstellen mit TSM für Versionen kleiner als 7.5


Einschränkungen für das Parallele Sichern und Wiederherstellen mit TSM für Versionen kleiner als 7.5

Vorgehensweisen Einschränkungen für das Parallele Sichern und Wiederherstellen mit TSM für Versionen kleiner als 7.5

Erst ab der Version 7.5 ist es uneingeschränkt möglich, MaxDB-Datenbanksysteme mit Hilfe des Sicherungswerkzeugs TSM parallel zu sichern und wiederherzustellen . Für frühere Versionen gelten die folgenden Einschränkungen.

Es stehen die jeweils angegebenen MaxDB-Datenbankwerkzeuge zur Verfügung.

MaxDB-Versionen und –Werkzeuge für das parallele Sichern und Wiederherstellen mit TSM

Version | Build-Nr. | Verfügbare MaxDB-Werkzeuge
7.4.03 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 002 | auch Web DBM
7.4.02 | ab 003 | Database Manager CLI, Database Manager GUI
 | ab 011 | auch Web DBM
7.3.00 | ab 021 | Database Manager CLI, Database Manager GUI
 | ab 025 | auch Web DBM
7.2.05 | ab 017 | Database Manager CLI, Database Manager GUI


Konfiguration des TSM-Anschlusses (SAP-Bibliothek - Installation)

Vorgehensweisen Konfiguration des TSM-Anschlusses

Verwendung

Sie konfigurieren die MaxDB-Software mit dem Ziel, die MaxDB-Datenbankwerkzeuge zum Sichern, Wiederherstellen, Exportieren oder Importieren von Daten an das externe Sicherungswerkzeug TSM anzuschließen. Sie verwenden dazu den TSM-Client adint2. Sollte dieser auf der von Ihnen verwendeten Plattform nicht verfügbar sein, können Sie TSM auch über Backint for Oracle an MaxDB anschließen.

Siehe auch:

Anschluss an eine Backint for Oracle-Schnittstelle

Das Programm adint2 ist in einer Standardinstallation des TSM-Client nicht enthalten. Es wird von IBM separat bereitgestellt. Weitere Informationen dazu finden Sie unter der Adresse http://www.de.ibm.com.

Voraussetzungen

● Die Version Ihres MaxDB-Datenbanksystems unterstützt den Anschluss von TSM (Einschränkungen für die Verwendung von TSM).

● Sie verfügen über den TSM-Client adint2.

Vorgehensweise

...

1. Wenn Sie parallel sichern oder wiederherstellen wollen, prüfen Sie, ob die Version Ihres Datenbanksystems diese Aktion unterstützt (Einschränkungen für das Parallele Sichern und Wiederherstellen mit TSM).

2. Setzen der Umgebungsvariablen ADINT und ADA_OPT.

3. Gegebenenfalls Setzen werkzeugunabhängiger Umgebungsvariablen für den Database Manager


Setzen der Umgebungsvariablen ADINT und ADA_OPT (SAP-Bibliothek - Installation)

Vorgehensweisen Setzen der Umgebungsvariablen ADINT und ADA_OPT

Verwendung

Damit der Database Manager und der Loader auf dem Datenbankrechner auf die benötigten Umgebungsvariablen ADINT und ADA_OPT zugreifen können, müssen Sie diese mit Hilfe des Database Manager CLI explizit hinterlegen.

Umgebungsvariable | Beschreibung
ADINT | Angabe des Verzeichnisses, in dem sich das Programm adint2 (UNIX) bzw. adint2.exe (Microsoft Windows) befindet. Geben Sie dieses Verzeichnis als absoluten Pfad an, d. h. ohne abschließenden Schrägstrich (/) oder inversen Schrägstrich (\).
ADA_OPT | Absoluter Name der adint2-Konfigurationsdatei. Eine Beispielkonfigurationsdatei initSID.utl finden Sie im Verzeichnis des Programms adint2.

Syntax

dbmcli -d <database_name> -n <database_computer> -u <dbm_operator>,<dbm_operator_password> dbm_configset -raw <variable> <value>

<variable> | Umgebungsvariable ADINT | ADA_OPT
<value> | Wert der Umgebungsvariablen

Siehe auch:

Database Manager CLI , Abschnitt Strukturlink dbm_configset


Anschluss an NetWorker (SAP-Bibliothek - Installation)

Hintergrunddokumentation Anschluss an NetWorker

MaxDB unterstützt den Anschluss an das externe Sicherungswerkzeug NetWorker der Firma Legato für das Sichern, Wiederherstellen, Importieren und Exportieren von Daten nach entsprechender Konfiguration der MaxDB-Software.

Beachten Sie die versionsspezifischen Einschränkungen für die Verwendung von NetWorker bzw. für die Möglichkeit, Daten parallel zu sichern oder wiederherzustellen.

Siehe auch:

Einschränkungen für die Verwendung von NetWorker

Einschränkungen für das Parallele Sichern und Wiederherstellen mit NetWorker

Konfiguration des NetWorker-Anschlusses


Einschränkungen für die Verwendung von NetWorker für Versionen kleiner 7.5

Hintergrunddokumentation Einschränkungen für die Verwendung von NetWorker für Versionen kleiner 7.5

Erst ab der Version 7.5 ist es uneingeschränkt möglich, MaxDB-Datenbanksysteme mit Hilfe des Sicherungswerkzeugs Networker (Legato) zu sichern und wiederherzustellen. Für frühere Versionen gelten die folgenden Einschränkungen.

Es stehen die jeweils angegebenen MaxDB-Datenbankwerkzeuge zur Verfügung.

MaxDB-Versionen und –Werkzeuge für das Sichern und Wiederherstellen mittels NetWorker

Version | Build-Nr | Verfügbare MaxDB-Werkzeuge
7.4.03 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 002 | auch Web DBM
7.4.02 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 011 | auch Web DBM
7.3.32 | ab 000 | Database Manager CLI, Database Manager GUI
7.3.00 | ab 005 | Database Manager CLI, Database Manager GUI (nur zum Sichern)*
 | ab 015 | Database Manager CLI, Database Manager GUI
 | ab 025 | auch Web DBM
7.2.05 | ab 001 | Database Manager CLI, Database Manager GUI (nur zum Sichern)*

* Mit dieser Version des Database Manager GUI können Sie nur sichern und nicht wiederherstellen. Wenn Sie jedoch eine neuere Version des Database Manager GUI installiert haben, die das Wiederherstellen unterstützt (z. B. 7.4.03), dann können Sie damit auch Datenbanken älterer Versionen (z. B. 7.2.05) wiederherstellen, da dieses Datenbankwerkzeug abwärts kompatibel ist.

Folgende Networker-Versionen sind mindestens erforderlich:

Betriebssystem | NetWorker-Version
UNIX | 5.5
Microsoft Windows | 5.7

Siehe auch:

Einschränkungen für das Parallele Sichern und Wiederherstellen mit Networker für Versionen kleiner als 7.5


Einschränkungen für das Parallele Sichern und Wiederherstellen mit NetWorker für Versionen kleiner als 7.5

Vorgehensweisen Einschränkungen für das Parallele Sichern und Wiederherstellen mit NetWorker für Versionen kleiner als 7.5

Erst ab der Version 7.5 ist es uneingeschränkt möglich, MaxDB-Datenbanksysteme mit Hilfe des Sicherungswerkzeugs NetWorker parallel zu sichern und wiederherzustellen. Für frühere Versionen gelten die folgenden Einschränkungen.

Es stehen die jeweils angegebenen Datenbankwerkzeuge zur Verfügung.

Setzen Sie bei parallelen Sicherungen mit Datenbanken einer Version kleiner als 7.4.03 den NetWorker-Parameter Target Sessions für jedes Bandlaufwerk auf 1. (Siehe Dokumentation des Herstellers)

MaxDB-Versionen und –Werkzeuge für das parallele Sichern und Wiederherstellen mit NetWorker

Version | Build-Nr. | Verfügbare MaxDB-Werkzeuge
7.4.03 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 002 | auch Web DBM
7.4.02 | ab 000 | Database Manager CLI, Database Manager GUI
 | ab 011 | auch Web DBM
7.3.32 | ab 000 | Database Manager CLI, Database Manager GUI
7.3.00 | ab 009 | Database Manager CLI, Database Manager GUI (nur zum Sichern)*
 | ab 015 | Database Manager CLI, Database Manager GUI
 | ab 025 | auch Web DBM
7.2.05 | ab 004 | Database Manager CLI

* Mit dieser Version des Database Manager GUI können Sie nur sichern und nicht wiederherstellen. Wenn Sie jedoch eine neuere Version des Database Manager GUI installiert haben, die das Wiederherstellen unterstützt (z. B. 7.4.03), dann können Sie damit auch Datenbanken älterer Versionen (z. B. 7.2.05) wiederherstellen, da dieses Datenbankwerkzeug abwärts kompatibel ist.


Konfiguration des NetWorker-Anschlusses (SAP-Bibliothek - Installation)

Vorgehensweisen Konfiguration des NetWorker-Anschlusses

Verwendung

Sie konfigurieren die MaxDB-Software mit dem Ziel, die MaxDB-Datenbankwerkzeuge zum Sichern, Wiederherstellen, Importieren oder Exportieren von Daten an das externe Sicherungswerkzeug NetWorker anzuschließen.

Voraussetzungen

Die Version Ihres MaxDB-Datenbanksystems unterstützt den Anschluss von NetWorker (Siehe: Einschränkungen für die Verwendung von NetWorker).

Vorgehensweise

...

1. Wenn Sie parallel sichern oder wiederherstellen wollen, prüfen Sie, ob die Version Ihres Datenbanksystems diese Aktion unterstützt (Einschränkungen für das Parallele Sichern und Wiederherstellen mit NetWorker).

2. Setzen der Umgebungsvariablen NSR_ENV

3. Erstellen der Konfigurationsdatei für NetWorker

4. Gegebenenfalls Setzen werkzeugunabhängiger Umgebungsvariablen für den Database Manager


Setzen der Umgebungsvariablen NSR_ENV (SAP-Bibliothek - Installation)

Vorgehensweisen Setzen der Umgebungsvariablen NSR_ENV

Damit der Database Manager und der Loader auf dem Datenbankrechner auf die Konfigurationsdatei für NetWorker zugreifen können, müssen Sie deren absoluten Pfad in der Umgebungsvariablen NSR_ENV mit Hilfe des Database Manager CLI explizit hinterlegen.

Andernfalls verwendet das System die in der folgenden Tabelle angegebene Datei als Konfigurationsdatei:

Betriebssystem | Datei
UNIX | /nsr/sapdb/env
Microsoft Windows | C:\Program Files\nsr\sapdb\env

Syntax

dbmcli -d <database_name> -n <database_computer> -u <dbm_operator>,<dbm_operator_password> dbm_configset -raw NSR_ENV <value>

<value>

Wert der Umgebungsvariablen NSR_ENV

Siehe auch:

Database Manager CLI, Strukturlink dbm_configset


Erstellen der Konfigurationsdatei für NetWorker (SAP-Bibliothek - Installation)

Vorgehensweisen Erstellen der Konfigurationsdatei für NetWorker

Sie konfigurieren die MaxDB-Software mit dem Ziel, die MaxDB-Datenbankwerkzeuge zum Sichern, Wiederherstellen, Importieren oder Exportieren von Daten an das Sicherungswerkzeug NetWorker anzuschließen.

Vorgehensweise

In jeder Zeile der Konfigurationsdatei legen Sie einen Parameter des Database Manager fest. Dazu müssen Sie am Anfang jeder Zeile das Schlüsselwort für den Parameter und anschließend den oder die gewünschten Wert/e angeben. Zeilen, die nicht durch Schlüsselwörter eingeleitet werden, werden vom System ignoriert.

Syntax

<key_string> <value_string>

<key_string> | Schlüsselwort für einen Parameter, kann aus einem oder mehreren Wörtern bestehen
<value_string> | Wert/e des Parameters

Für den Anschluss von NetWorker and den Database Manager definieren Sie folgende Parameter:

Parameter

Syntax

Beschreibung

Absoluter Pfad des Verzeichnisses, in dem NetWorker installiert ist

NSR_HOME <absolute_path>

In diesem Verzeichnis befinden sich die NetWorker-Programme SAVE, MMINFO und RECOVER.

Name des NetWorker-Server

NSR_HOST <name>

Name des NetWorker-Band-Pool

NSR_POOL <name>

Angabe übersteuert den im NetWorker konfigurierten Vorschlagswert für das Band-Pool

Verfallsdatum oder Verfallszeitraum der Sicherung

NSR_EXPIRE <value>

Angabe wird an das NetWorker-Programm SAVE übergeben und übersteuert den im NetWorker konfigurierten Vorschlagswert für das Verfallsdatum oder den Verfallszeitraum

Die zulässigen Werte entnehmen Sie der NetWorker-Dokumentation.

Angabe, welches der NetWorker-Programme SAVE und RECOVER mit der Option -v gestartet werden soll

NSR_NOTVERBOSE <option>

<option> ::= NONE | SAVE | RECOVER | "SAVE AND RECOVER"

Angabe für den Fall dass NetWorker-Programme die Option –v nicht unterstützen.

NONE: Vorschlagswert
SAVE und RECOVER werden mit der Option -v gestartet.

SAVE: SAVE wird ohne und RECOVER mit der Option -v gestartet.

RECOVER: SAVE wird mit und RECOVER ohne die Option -v gestartet.

"SAVE AND RECOVER": SAVE und RECOVER werden ohne die Option -v gestartet.

Angabe, ob die Ausgabe des NetWorker-Programms SAVE bei Sicherungen analysiert werden soll

NSR_USEOUTPUT <option>

<option> ::= SAVE | NONE

SAVE: Vorschlagswert
Die Ausgabe von SAVE wird auf Fehlermeldungen überprüft.

NONE: Die Ausgabe von SAVE wird nicht auf Fehlermeldungen überprüft. Es wird nur der Rückgabewert von SAVE verwendet. Da SAVE bei einem Fehler auch den Rückgabewert 0 liefern kann, sollten Sie den Wert NONE nicht verwenden.

Fehlermeldungen des NetWorker-Programms SAVE, die ignoriert werden sollen

NSR_IGNOREERROR <error_text>

Alle Fehlermeldungen der Form <pipe_name>:<error_text> werden ignoriert.

Wiederholen Sie diese Parameterdefinition für jede einzelne Fehlermeldung, die ignoriert werden soll.

Angabe, ob der Database Manager für Wiederherstellungen die Sicherungszeiten oder die NetWorker-Save-Set-Identifier verwenden soll

NSR_EBIDTYPE <option>

<option> ::= NSAVETIME | SSID

NSAVETIME: Vorschlagswert
Sicherungen werden über ihre Sicherungszeit identifiziert
Empfohlener Wert, da vom NetWorker-Programm RECOVER keine Anforderungen an die Rechte des Betriebssystembenutzers gestellt werden

SSID: Sicherungen werden über NetWorker-Save-Set-Identifier identifiziert

Wartezeit zwischen zwei SAVE-Aufrufen bei parallelen Sicherungen in sec.

NSR_SAVEINTERVAL <time>

Vorschlagswert: 10

Name, unter dem die Sicherung in NetWorker abgelegt werden soll

NSR_BACKUPNAME <name>

Vorschlagswert: Name der Datenbankinstanz

Beliebige Zeichenkette, die die Platzhalter <database_name> und/oder <node> enthalten kann. Bei Sicherung/Wiederherstellung mit NetWorker werden die Platzhalter durch den Namen der Datenbankinstanz und/oder des Datenbankrechners ersetzt.

Umgehung eines NetWorker-Softwarefehlers

NSR_AVOIDPSSIDBUG <option>

<option> ::= YES | NO

Ab NetWorker 6.0 ist ein Softwarefehler im MMINFO-Programm bei Verwendung der Option -q pssid=0 (PSSID-Bug) bekannt. Sie können ihn durch Setzen dieses Parameters umgehen.
NO: Vorschlagswert
Aufruf des NetWorker-Programms MMINFO mit der Option -q pssid=0
YES: Umgehung des Softwarefehlers im MMINFO-Programms (nur für NetWorker-Versionen ab 6.0)

Datumsformat, das für die Analyse der Ausgabe des NetWorker-Programms MMINFO verwendet wird

NSR_SAVETIMEFORMAT <format>

<format>::=[<separator_definition><separator>]<datetime_format>[<separator><AM_definition>][<separator><PM_definition>]

<separator_definition>::= SEPARATOR=<new_separator>

<new_separator>::= Zeichen, das nicht in <date_time_format>, <AM_definition> und <PM_definition> vorkommt

<separator>::= Bei fehlender <separator_definition> das Kommazeichen (',') ansonsten <new_separator>

<datetime_format>::= { <year> | <month> | <day> | <hour> | <minute> | <second> | <AM> | <PM> [<datetime_separator>] }

<datetime_separator>::= ein beliebiges Zeichen außer y, m, d, H, M, S, a, A, p, P

<year>::= yy | yyyy

<month>::= mm

<day>::= dd

<hour>::= HH

<minute>::= MM

<second>::= SS

<AM>::= am | AM | a.m. | A.M.

<PM>::= pm | PM | p.m. | P.M.

<AM_definition>::=AM=<local_AM_string>

<local_AM_string>::= beliebige Zeichenfolge ohne das Zeichen <separator>

<PM_definition>::=PM=<local_PM_string>

<local_PM_string>::= beliebige Zeichenfolge ohne das Zeichen <separator>

Notwendig, falls aktueller Vorschlagswert nicht der NetWorker-Ausgabe entspricht,

Vorschlagswerte sind
mm/dd/yy HH:MM:SS AM: für Datumsausgaben von Networker, die 8 Zeichen lang sind, oder

mm/dd/yyyy HH:MM:SS AM: für Datumsausgaben von Networker, die 10 Zeichen lang sind

Sie können nur ein Format konfigurieren. Dies kann auch von den Vorschlagswerten verschieden sein, sofern die angegebenen Syntaxelemente verwendet werden.

yy|yyyy Jahr, mm Monat, dd Tag, HH Stunde, MM Minute, SS Sekunde, AM | PM vormittags oder nachmittags

Angabe, wie die durch das NetWorker-Programm SAVE übermittelte Größenangabe für Sicherungen verwendet werden soll.

NSR_SIZEROUNDUP <option>

<option> ::= NOROUNDUP | FIRSTDECIMAL | NORMAL | LASTINTEGER

Notwendig, falls die von SAVE übermittelte Größenangabe für die Sicherung abgerundet ist.

Dieser Parameter kann erst für die folgenden Datenbankversionen ab den angegebenen Build-Nummern verwendet werden: 7.2.05 ab Build 017, 7.3.00 ab Build 021, 7.4.03 ab Build 000.

NOROUNDUP: Vorschlagswert
Die Größenangabe soll unverändert übernommen werden.

FIRSTDECIMAL: Die Größenangabe soll um 0.1 erhöht übernommen werden (Beispiel: Sicherungsgröße 14 GB wird mit 14.1 GB weiterverwendet).

NORMAL: Die Größenangabe soll um 0.5 erhöht übernommen werden.

LASTINTEGER: Die Größenangabe soll um 1 erhöht übernommen werden.

Zeichenkette, die als Wert für die MMINFO-Option -t verwendet wird

NSR_AVOIDTIMEBUG <value>

Notwendig, falls MMINFO von NetWorker ohne die Option –t nicht funktioniert.

Dieser Parameter kann erst für die folgenden Datenbankversionen ab den angegebenen Build-Nummern verwendet werden: 7.2.05 ab Build 018, 7.3.00 ab Build 022, 7.4.02 ab Build 004, 7.4.03 ab Build 000.

Die Zeichenkette muss dem von MMINFO erwarteten Format entsprechen. Wenn die Zeichenkette aus mehreren Worten besteht, müssen Sie diese in Hochkomma setzen.
Beachten Sie, dass Sicherungen, die nicht in der durch die Zeichenkette angegebenen Zeitspanne liegen, von MaxDB nicht mehr als für eine Wiederherstellung verfügbar betrachtet werden.

Client-Name, den der Database Manager beim Aufruf des Networker-Programms MMINFO und gegebenenfalls des NetWorker-Programms SAVE anstelle des vom Betriebssystem gelieferten Rechnernamens verwenden soll.

NSR_CLIENT

Kann nur mit den Datenbankversionen 7.3.0 ab Build 032, 7.4.3 ab Build 010 oder Datenbankversionen größer/gleich 7.5. verwendet werden,
muss mit dem im NetWorker konfigurierten Client-Namen übereinstimmen

Wenn dieser Client-Name erstmalig spezifiziert oder geändert wird, dann kann auf Sicherungen die vor dieser Änderung durchgeführt wurden, nur noch wie auf Sicherungen von einem anderen Client zugegriffen werden. Sie werden in der Sicherungshistorie als UNAVAILABLE gekennzeichnet. Ihre Verfügbarkeit kann nur mit Hilfe des DBM-Kommandos zum Strukturlink backup_ext_ids_get bestimmt werden. Dabei ist der frühere Client-Name anstelle des Datenbankrechners als Parameter anzugeben. Beim Wiederherstellen gibt es keine Einschränkungen.

legt fest, wie der für NSR_CLIENT gewählte Wert verwendet wird

NSR_USECLIENTFOR <option>

<option> ::="SAVE and MMINFO" | MMINFO

MMINFO: Vorschlagswert. Der für NSR_CLIENT gewählte Wert wird nur für das NetWorker-Programm MMINFO verwendet.

SAVE and MMINFO: Der für NSR_CLIENT gewählte Wert wird für die NetWorker-Programme SAVE und MMINFO verwendet. Auf diese Weise können Sie bei Sicherungen einen logischen Rechnernamen oder gezielt eine zweite Netzwerkkarte verwenden.

Wenn Sie den Wert "SAVE and MMINFO" wählen, dann testen Sie, ob Sie mit der von Ihnen verwendeten NetWorker-Version und Ihrer Konfiguration eine Sicherung durchführen und diese auch wiederherstellen können. Wenn Sie die Sicherung nicht wiederherstellen können, dann wählen Sie für den Parameter NSR_USECLIENTFOR den Vorschlagswert MMINFO und wenden sich an Ihren NetWorker-Support.

Siehe auch:

Beispiel einer Konfigurationsdatei


Beispiel einer Konfigurationsdatei für NetWorker (SAP-Bibliothek - Installation)

Diese Grafik wird im zugehörigen Text erklärt Beispiel einer Konfigurationsdatei für NetWorker

Verwendung

Sie können sich das Erstellen der Konfigurationsdatei für NetWorker erleichtern, wenn Sie folgendes Beispiel verwenden und Ihren Erfordernissen anpassen. Wenn Sie dabei erreichen wollen, dass ein bestimmter Parameter nicht über die Parameterdatei gesetzt wird, müssen Sie das entsprechende Schlüsselwort ungültig machen oder löschen.

Dateiinhalt

NSR_HOST           p47579
NSR_HOME           "C:\Program Files\nsr\bin"
NSR_POOL           MAXDBPOOL
NSR_EXPIRE         year

NSR_NOTVERBOSE     RECOVER
NSR_EBIDTYPE       NSAVETIME

NSR_USEOUTPUT      SAVE
NSR_IGNOREERROR    " unknown error 109 (0x6d)"
NSR_IGNOREERROR    " using unlocked access"
NSR_IGNOREERROR    " The pipe has been ended.”

NSR_SAVEINTERVAL   60
NSR_BACKUPNAME     MAXDB:<database_name>_on_<node>

NSR_AVOIDPSSIDBUG  YES
NSR_SAVETIMEFORMAT "yyyy/mm/dd HH:MM:SS AM"

Erläuterung

Schlüsselwort

Wert

Erläuterung

NSR_HOST

p47579

Der NetWorker-Server läuft auf dem Rechner p47579.

NSR_HOME

"C:\Program Files\nsr\bin"

Der NetWorker-Client ist auf dem Datenbank-Server im Verzeichnis C:\Program Files\nsr\bin installiert.

NSR_POOL

MAXDBPOOL

Sicherungen werden im NetWorker-Pool MAXDBPOOL abgelegt.

NSR_EXPIRE

year

Die Sicherungen haben eine Verfallszeit von einem Jahr.

NSR_NOTVERBOSE

RECOVERY

Das NetWorker-Programm RECOVER wird ohne die Option -v aufgerufen.

NSR_EDITTYPE

NSAVETIME

Zur Identifikation der Sicherungen wird die Sicherungszeit verwendet.

NSR_USEOUTPUT

SAVE

Die Ausgabe des NetWorker-Programms SAVE wird bei jeder Sicherung nach Fehlern durchsucht.

NSR_IGNOREERROR

" unknown error 109 (0x6d)"
 " using unlocked access"
" The pipe has been ended."

Die Meldungen
<pipe_name>: unknown error 109 (0x6d),
<pipe_name>: using unlocked access und
 <pipe_name>: The pipe has been ended werden für die verwendeten Pipes ignoriert.

NSR_SAVEINTERVAL

60

Zwischen zwei SAVE-Aufrufen bei parallelen Sicherungen vergehen 60 Sekunden.

NSR_BACKUPNAME

MAXDB:<database_name>_on_<node>

Wenn die Datenbankinstanz den Namen DB73 und der Datenbankrechner den Namen p47579 hat, werden die Sicherungen mit dem Namen MAXDB:DB73_on_p47579 in NetWorker angelegt.

NSR_AVOIDPSSIDBUG

YES

Das PSSID-Bug des NetWorker-Programms MMINFO wird umgangen.

NSR_SAVETIMEFORMAT

"yyyy/mm/dd HH:MM:SS AM"

Das NetWorker-Programm MMINFO liefert Datumsangaben in der angegebenen Form.
Beispiel: 2001/12/31 11:59:58 AM


Anschluss an VERITAS NetBackup (SAP-Bibliothek - Installation)

Vorgehensweisen Anschluss an VERITAS NetBackup

Verwendung

Über seine Backint for Oracle-Schnittstelle unterstützt MaxDB den Anschluss an das externe Sicherungswerkzeug VERITAS NetBackup der Firma VERITAS für das Sichern, Wiederherstellen, Importieren und Exportieren von Daten nach entsprechender Konfiguration der MaxDB-Software. Es kann für Datenbankversionen ab 7.3 (mit aktuellem Patch-Level) verwendet werden.

Weitere Informationen, insbesondere zu den unterstützten Plattformen, sowie Konfigurationsbeispiele finden Sie unter support.veritas.com im VERITAS NetBackup for SAP System Administrator's Guide.


Synchronization Manager installieren (SAP-Bibliothek - Installation)

Vorgehensweisen Synchronization Manager installieren

Verwendung

Sie installieren den Synchronization Manager mit Hilfe des Installation Manager.

Um mehrere Datenbankinstanzen zu synchronisieren, installieren Sie die Software des Synchronization Manager auf allen beteiligten Rechnern. Weitere Informationen zum Synchronisieren von Datenbankinstanzen finden Sie in der Dokumentation Strukturlink Synchronization Manager.

Siehe auch:

Verwenden des Installation Manager

Voraussetzungen

● Java Runtime Environment 1.4, siehe java.sun.com/jre

● j2ee.jar aus dem Java 2 Enterprise SDK ≥ 1.4, siehe java.sun.com/j2ee

● Eclipse SDK, siehe www.eclipse.org

● Sie haben den Installation Manager aufgerufen.

Vorgehensweise

...

1. Wechseln Sie in das lokale Verzeichnis, in dem Sie die Datenbanksoftware entpackt haben.

2. Öffnen Sie das Programm SDBSETUP.exe, um den Installation Manager zu starten.

3. Im Installation Manager wählen Sie Start installation/upgrade.

4. Folgen Sie den Anweisungen des Installation Manager.

5. Wählen Sie im Bild Summary of Installation Settings unter Software ® Components das Installationspaket Synchronization Manager aus.

Der Installation Manager wählt alle weiteren benötigten Softwarekomponenten automatisch aus.

6. Folgen Sie weiter den Anweisungen des Installation Manager.

7. Nach Abschluss der Installation starten Sie das System neu.

Ergebnis

Die Software des Synchronization Manager wurde im Verzeichnis <independent_program_path>\app\syncman installiert (siehe Verzeichnisse).

Um Datenbankinstanzen synchronisieren zu können, müssen Sie weitere Konfigurationen durchführen (siehe Synchronization Manager, Strukturlink Konfiguration).


MaxDB-PHP-Erweiterung installieren (SAP-Bibliothek - Installation)

Hintergrunddokumentation MaxDB-PHP-Erweiterung installieren

Einführungshinweise

Über die MaxDB-PHP-Programmierschnittstelle können Sie mit PHP auf MaxDB-Datenbankinstanzen zugreifen.

Die Software für die MaxDB-PHP-Erweiterung wird über die PECL-Standard-Distribution veröffentlicht und kann unter pecl.php.net/package/maxdb kostenlos heruntergeladen werden. Sie benötigen außerdem die PHP Version 4.3.6 oder höher.

Die Dokumentation zur MaxDB-PHP-Erweiterung im html-Format finden Sie unter der Adresse www.php.net/manual/en/ref.maxdb.php. Diese Dokumentation ist auch im docbookxml-Format unter der Adresse cvs.php.net/phpdoc/en/reference/maxdb verfügbar.

Die Programmierschnittstelle kann auf Linux x86_32, Microsoft Windows 2000 und Microsoft Windows XP verwendet werden.

Siehe:

Erstellen und Installieren der MaxDB-PHP-Erweiterung auf Linux

Installieren der PHP-Bibliothek auf Microsoft Windows


Erstellen und Installieren der MaxDB-PHP-Erweiterung auf Linux (SAP-Bibliothek - Installation)

Vorgehensweisen Erstellen und Installieren der MaxDB-PHP-Erweiterung auf Linux

Verwendung

Sie erstellen die Software für die MaxDB-PHP-Erweiterung aus dem Quelltext und installieren diese Software auf Ihrem Rechner.

Voraussetzungen

● Sie haben folgende Programme installiert:

○ Compiler gcc Version 2.95 oder höher

○ autoconf Version 2.52 oder höher

○ libtool Version 1.5.6 oder höher

● Sie haben den Quelltext von PHP 4.3.x oder 5.0.x unter der Adresse php.net/downloads.php heruntergeladen und in ein lokales Verzeichnis <php_source> auf Ihrem Rechner entpackt.

● Sie haben mindestens die MaxDB SQLDBC-Software installiert (Softwarekomponenten Base und SQLDBC). Das Installationsverzeichnis wird nachfolgend als <independent_program_path> bezeichnet.

Um die im Weiteren beschriebenen Testbeispiele nachvollziehen zu können, benötigen Sie jedoch auch eine Datenbankinstanz. Aus diesem Grunde empfehlen wir Ihnen, zunächst die gesamte MaxDB-Software zu installieren, eine Datenbankinstanz anzulegen und die Tutorial-Daten in diese Datenbankinstanz zu laden. Ein sehr einfacher und sicherer Weg dafür ist die Verwendung des Installation Manager.

Vorgehensweise

...

1. Legen Sie das Verzeichnis <php_source>/ext/maxdb an.

2. Laden Sie das MaxDB-PHP-Paket maxdb-<version>.tgz von PECL unter der Adresse pecl.php.net/package/maxdb herunter und entpacken Sie es in ein temporäres Verzeichnis auf Ihrem Rechner.

tar –C <tmp_folder> –xvzf maxdb-<version>.tgz

3. Kopieren Sie den Inhalt des Verzeichnisses <maxdb_version> in das Verzeichnis <php_source>/ext/maxdb:

cp –r <tmp_folder>/<maxdb_version> <php_source>/ext/maxdb

4. Wechseln Sie in das Verzeichnis <php_source>:

cd /<php_source>

5. Erstellen Sie die neuen Skripte, mit denen der Quelltext kompiliert werden kann. Geben Sie dazu folgendes Kommando ein:

./buildconf --force

6. Geben Sie die Parameter an, mit denen die PHP-Software mit MaxDB-Erweiterung erstellt werden soll.

○ Definieren Sie dazu mit Hilfe der Option with-maxdb das Verzeichnis <independent_program_path>.

Geben Sie

■ das Installationsverzeichnis von SQLDBC an, wenn Sie nur die MaxDB SQLDBC-Software installiert haben oder

■ das Verzeichnis für die von den MaxDB-Datenbankinstanzen und -Anwendungen gemeinsam genutzten Programme und Bibliotheken an, wenn Sie die gesamte MaxDB-Software installiert haben.

○ Mit Hilfe der Option prefix können Sie das Verzeichnis <php_with_maxdb> angeben, in das MaxDB mit PHP-Erweiterung installiert werden soll. Beachten Sie, dass Sie Schreibrechte für dieses Verzeichnis haben müssen, um darin die Software erstellen zu können.

Wenn Sie diese Option nicht angeben, verwendet das System als Vorschlagswert das Verzeichnis /usr/local.

Um alle möglichen Optionen anzuzeigen, verwenden Sie folgendes Kommando:

./configure --help

./configure --with-maxdb=<independent_program_path> --prefix=<php_with_maxdb> [--<parameter>] [...]

<parameter> :: = <option>=<value> | <option>

7. Öffnen Sie eine root-Shell und erstellen und installieren Sie PHP mit MaxDB-Erweiterung mit folgendem Kommando:

make install

Ergebnis

PHP mit MaxDB-Unterstützung wurde im Verzeichnis <php_with_maxdb> erstellt und installiert.

Sie können als Test für die erfolgreiche Installation die Liste aller installierten PHP-Erweiterungen anzeigen. Geben Sie dazu folgendes Kommando ein:

<php_with_maxdb>/bin/php –m

Wenn keine Fehler aufgetreten sind, dann wird die PHP-Erweiterung maxdb in der Liste angezeigt.

Für weitere Test siehe: Testen der MaxDB-PHP-Erweiterung (Linux)

Beispiel

...

Der Quelltext für PHP 5.0.0 wurde in das Verzeichnis /home/anna/php-5.0.0 entpackt.

Mindestens die SQLDBC-Software wurde in das Verzeichnis /opt/sdb/programs installiert.

1. Legen Sie die Verzeichnisse /home/anna/php-5.0.0/ext und /home/anna/tmp an.

2. Entpacken Sie das MaxDB-PHP-Paket maxdb-7[1].5.00.24.tgz in das Verzeichnis /home/anna/tmp:

tar –C /home/anna/tmp –xvzf maxdb-7[1].5.00.24.tgz

Sie haben nun folgende Verzeichnisstruktur:

/home/anna/php-5.0.0/

ext/

/home/anna/tmp/

ext/

maxdb/

tests/

<independent_program_path>/

lib/

sdk/

incl/

lib/

3. Kopieren Sie den Inhalt des Verzeichnisses <maxdb_php>/ext/maxdb nach <php_source>/ext:

cp –r /home/anna/tmp/ext/maxdb /home/anna/php-5.0.0/ext

4. Wechseln Sie in das Verzeichnis, in das Sie den PHP-Quelltext entpackt haben:

cd /home/anna/php-5.0.0

5. Erstellen Sie die neuen Skripte, mit denen der Quelltext kompiliert werden kann.

./buildconf –force

6. Geben Sie mit Hilfe der notwendigen Optionen an, dass die von den MaxDB-Datenbankinstanzen und -Anwendungen gemeinsam genutzten Programme und Bibliotheken im Verzeichnis /opt/sdb/programs abgelegt sind, dass PHP mit MaxDB-Erweiterung in das Verzeichnis /usr installiert werden soll, und dass die Software sowohl ohne CGI- als auch ohne LIBXML-Unterstützung erstellt werden soll:

./configure --with-maxdb=/opt/sdb/programs --prefix=/usr --disable-cgi –-disable-libxml

7. Erstellen und installieren Sie die PHP-Software mit MaxDB-Erweiterung:

make install


Testen der MaxDB-PHP-Erweiterung (Linux) (SAP-Bibliothek - Installation)

Vorgehensweisen Testen der MaxDB-PHP-Erweiterung (Linux)

Verwendung

Sie testen die Funktionen der MaxDB-PHP-Erweiterung. Sie können dazu das im MaxDB-PHP-Paket mitgelieferte Testszenario verwenden oder eigene Tests entwickeln.

Voraussetzungen

· Sie haben die MaxDB-PHP-Erweiterung erstellt und installiert.

Siehe: Erstellen und Installieren der MaxDB-PHP-Erweiterung auf Linux

· Sie haben die MaxDB-Software installiert und eine Datenbankinstanz angelegt. Diese befindet sich auf dem gleichen Rechner wie die PHP-Installation. Wenn Sie das mitgelieferte MaxDB-Testszenario verwenden wollen, müssen Sie die Tutorialdaten in die Datenbankinstanz geladen haben.

Siehe: Verwenden des Installation Manager

Vorgehensweise

...

1. Öffnen Sie eine root-Shell und wechseln Sie in das Verzeichnis <php_source> mit dem PHP-Quelltext:

cd <php_source>

2. Kopieren Sie die Datei php.ini-recommended in das Verzeichnis <php_with_maxdb>/lib und benennen Sie diese Datei um in php.ini.

cp php.ini-recommended <php_with_maxdb>/lib/php.ini

3. Öffnen Sie die Datei <php_with_maxdb>/lib/php.ini in einem Editor und fügen Sie darin einen Eintrag [maxdb] sowie Werte für die folgenden Variablen ein:

Variable | Beschreibung
maxdb.default_db | Name der Datenbankinstanz
maxdb.default_user | Name eines gültigen Datenbankbenutzers
maxdb.default_pw | Kennwort des Datenbankbenutzers

4. Tragen Sie in die Umgebungsvariable TEST_PHP_EXECUTABLE den Pfad der PHP-Installation ein.

5. Wechseln Sie in das Verzeichnis <php_source> mit dem PHP-Quelltext. In diesem Verzeichnis ist das Skript run-tests.php zum Testen von PHP enthalten.

cd <php_source>

6. Um die Tests im Verzeichnis <test_program_folder> zu starten, geben Sie folgendes Kommando ein:

php run-tests.php <test_program_folder>

Ergebnis

Sie erhalten Informationen zu den erfolgreichen und den fehlgeschlagenen Tests angezeigt.

Beispiel

Sie haben den Quelltext für PHP 5.0.0 in das Verzeichnis /home/anna/php-5.0.0 entpackt.

Sie haben die MaxDB-PHP-Erweiterung erstellt und im Verzeichnis /usr installiert.

Sie haben die MaxDB-Software installiert und die Datenbankinstanz DEMODB sowie den Datenbankbenutzer MONA mit dem Kennwort RED angelegt.

Sie verwenden das mitgelieferte MaxDB-Testszenario.

...

1. Wechseln Sie in das Verzeichnis /home/anna/php-5.0.0:

cd /home/anna/php-5.0.0

2. Kopieren Sie die darin enthaltene Datei php.ini-recommended in das Verzeichnis /usr/lib und benennen Sie diese Datei um in php.ini.

copy php.ini-recommended /usr/lib/php.ini

3. Öffnen Sie die Datei /usr/lib/php.ini in einem Editor und fügen Sie den folgenden Abschnitt ein:

[maxdb]

maxdb.default_db=DEMODB

maxdb.default_user=MONA

maxdb.default_pw=RED

4. Tragen Sie in die Umgebungsvariable TEST_PHP_EXECUTABLE den Pfad der PHP-Installation ein.

Aktualisieren der Umgebungsvariablen in einer Bash-Shell:

export TEST_PHP_EXECUTABLE=<php_with_maxdb>/bin/php

5. Wechseln Sie in das Verzeichnis /home/anna/php-5.0.0 mit dem PHP-Quelltext. In diesem Verzeichnis ist das Skript run-tests.php zum Testen von PHP enthalten.

cd /home/anna/php-5.0.0

6. Um die Tests zu starten, geben Sie folgendes Kommando ein:

php run-tests.php /home/anna/tmp/ext/maxdb/tests


Installieren der MaxDB-PHP-Bibliothek (Microsoft Windows) (SAP-Bibliothek - Installation)

Vorgehensweisen Installieren der MaxDB-PHP-Bibliothek (Microsoft Windows)

Verwendung

Sie installieren die MaxDB-PHP-Bibliothek php_maxdb.dll. auf Microsoft Windows, um damit die MaxDB-PHP-Erweiterung nutzen zu können.

Sie verwenden dazu die der Version Ihrer PHP-Installation entsprechende Datei php_maxdb.dll.

Voraussetzungen

● Sie haben die Programme tar und gzip für Microsoft Windows installiert.

● Sie haben die PHP-Binär-Distribution für Microsoft Windows heruntergeladen. Sie finden diese unter der Adresse php.net/downloads.php.

● Sie haben sich die Ihrer PHP-Version entsprechende MaxDB-PHP-Bibliothek heruntergeladen.

Die Bibliotheken für PHP5 und PHP4 finden Sie unter der Adresse pecl4win.php.net.

● Sie haben mindestens die MaxDB SQLDBC-Software installiert (Softwarekomponenten Base und SQLDBC). Das Installationsverzeichnis wird nachfolgend als <independent_program_path> bezeichnet.

Um die im Weiteren beschriebenen Testbeispiele nachvollziehen zu können, benötigen Sie jedoch auch eine Datenbankinstanz. Aus diesem Grunde empfehlen wir Ihnen, zunächst die gesamte MaxDB-Software zu installieren, eine Datenbankinstanz anzulegen und die Tutorialdaten in diese Datenbankinstanz zu laden. Ein sehr einfacher und sicherer Weg dafür ist die Verwendung des Installation Manager.

Vorgehensweise

...

1. Entpacken Sie die PHP-Binär-Distribution in ein lokales Verzeichnis <php_binary> auf Ihrem Rechner.

2. Wählen Sie die für Ihre PHP-Version geeignete MaxDB-PHP-Bibliothek aus und entpacken Sie sie in das Verzeichnis, das die Erweiterungen der PHP-Binär-Distribution enthält:

Für PHP5 entpacken Sie das Paket nach <php_binary>\ext

Für PHP4 entpacken Sie das Paket nach <php_binary>\extensions

3. Kopieren Sie die Datei php.ini-recommended aus dem Verzeichnis <php_binary> in das Verzeichnis Ihrer Microsoft Windows-Installation <win_dir> und ändern Sie deren Namen auf php.ini:

copy <php_binary>\php.ini-recommended <win_dir>\php.ini

4. Öffnen Sie die Datei php.ini in einem Editor und fügen Sie im Abschnitt Dynamic Extensions die folgende Zeile ein:

extension=php_maxdb.dll

5. Suchen Sie in der Datei php.ini nach dem Eintrag extension_dir und tragen Sie dort das Verzeichnis ein, das die Erweiterungen der PHP-Binär-Distribution ihrer PHP-Version enthält.

Für PHP5 geben Sie ein:

extension_dir=″<php_binary>\ext″

Für PHP4 geben Sie ein:

extension_dir=″<php_binary>\extensions″

6. Speichern Sie Ihre Änderungen und schließen Sie die Datei php.ini.

7. Tragen Sie die notwendigen Pfade in die Umgebungsvariable PATH ein:

SET PATH=%PATH%;<php_binary>;<php_binary>\ext

Ergebnis

Die MaxDB-PHP-Bibliothek wurde installiert.

Sie können als Test für die erfolgreiche Installation die Liste aller installierten PHP-Erweiterungen anzeigen. Geben Sie dazu folgendes Kommando ein:

php –m

Wenn keine Fehler aufgetreten sind, dann wird die PHP-Erweiterung maxdb in der Liste angezeigt.

Für weitere Tests siehe: Testen der PHP-Bibliothek (Microsoft Windows).

Beispiel

Sie verwenden PHP5 und wollen die MaxDB-PHP-Erweiterung für Microsoft Windows (32 bit) installieren.

Ihr Betriebssystem ist Windows XP und wurde im Verzeichnis C:\WINDOWS installiert.

...

1. Entpacken Sie PHP 5.0.0 in das Verzeichnis C:\php-5.0.0-Win32

2. Entpacken Sie das Paket http://snaps.php.net/win32/PECL_5_0/php_maxdb.dll nach C:\php-5.0.0-Win32\ext.

3. Kopieren Sie die Datei php.ini-recommended aus dem Verzeichnis C:\php-5.0.0-Win32 in das Verzeichnis C:\WINDOWS und ändern Sie deren Namen auf php.ini:

copy C:\php-5.0.0-Win32\php.ini-recommended C:\WINDOWS\php.ini

4. Öffnen Sie die Datei php.ini in einem Editor und fügen Sie im Abschnitt Dynamic Extensions die folgende Zeile ein:

extension=php_maxdb.dll

5. Suchen Sie in der Datei php.ini nach dem Eintrag extension_dir und tragen Sie dort das Verzeichnis C:\php-5.0.0-Win32\ext ein.

extension_dir=″c:\php-5.0.0-Win32\ext″

6. Speichern Sie Ihre Änderungen und schließen Sie die Datei php.ini.

7. Tragen Sie die notwendigen Pfade in die Umgebungsvariable PATH ein:

SET PATH=%PATH%;C:\php-5.0.0-Win32;C:\php-5.0.0-Win32\ext


Testen der PHP-Bibliothek (Microsoft Windows) (SAP-Bibliothek - Installation)

Vorgehensweisen Testen der PHP-Bibliothek (Microsoft Windows)

Verwendung

Sie testen die Funktionen der MaxDB-PHP-Erweiterung. Sie können dazu das im MaxDB-PHP-Paket mitgelieferte Testszenario verwenden oder eigene Tests entwickeln.

Voraussetzungen

· Sie haben die MaxDB-PHP-Bibliothek installiert.

Siehe: Installieren der MaxDB-PHP-Bibliothek (Microsoft Windows)

· Sie haben die MaxDB-Software installiert und eine Datenbankinstanz angelegt. Diese befindet sich auf dem gleichen Rechner wie die PHP-Installation. Wenn Sie das mitgelieferte MaxDB-Testszenario verwenden wollen, müssen Sie die Tutorialdaten in die Datenbankinstanz geladen haben.

Siehe: Verwenden des Installation Manager

· Wenn das mitgelieferte MaxDB-Testszenario verwenden wollen, müssen Sie auch das MaxDB-Source-Paket unter der Adresse pecl.php.net/package/maxdb heruntergeladen und in das Verzeichnis <maxdb_php>entpackt haben. In diesem Paket befinden sich die Testprogramme.

Vorgehensweise

...

1. Öffnen Sie die Datei php.ini im Verzeichnis Ihrer Windows-Installation und fügen Sie darin einen Eintrag [maxdb] sowie Werte für die folgenden Variablen ein:

Variable | Beschreibung
maxdb.default_db | Name der Datenbankinstanz
maxdb.default_user | Name eines gültigen Datenbankbenutzers
maxdb.default_pw | Kennwort des Datenbankbenutzers

2. Wechseln Sie in das Verzeichnis <test_program_folder> mit den Testprogrammen:

cd <test_program_folder>

3. Führen Sie die einzelnen Testprogramme aus. Um das Testprogramm <test_program> auszuführen, geben Sie folgendes Kommando ein:

php <test_program>

Beispiel

Sie haben die PHP-Binärdistribution in das Verzeichnis C:\php-5.0.0-Win32 entpackt.

Sie haben die MaxDB-PHP-Bibliothek für Microsoft Windows im Verzeichnis C:\WINDOWS installiert.

Sie haben das MaxDB-Source-Paket in das Verzeichnis C:\php-5.0.0-Win32\ext\maxdb\tests entpackt.

Sie haben die MaxDB-Software installiert und die Datenbankinstanz DEMODB sowie den Datenbankbenutzer MONA mit dem Kennwort RED angelegt.

Sie verwenden das mitgelieferte MaxDB-Testszenario.

4. Öffnen Sie die Datei C:\WINDOWS\php.ini in einem Editor und fügen Sie den folgenden Abschnitt ein:

[maxdb]

maxdb.default_db=DEMODB

maxdb.default_user=MONA

maxdb.default_pw=RED

5. Wechseln Sie in das Verzeichnis, in dem sich die MaxDB-PHP-Testprogramme befinden:

cd C:\php-5.0.0-Win32\ext\maxdb\tests

6. Führen Sie das Testprogramm maxdb001.php aus.

php maxdb001.php

In der PHP-Binär-Distribution für Microsoft Windows ist kein Test-Frame enthalten. Sie müssen die Testprogramme für die MaxDB-PHP-Bibliothek deshalb einzeln ausführen.


Web SQL / WebDAV konfigurieren (SAP-Bibliothek - Installation)

Vorgehensweisen Web SQL / WebDAV konfigurieren

Verwendung

Sie konfigurieren folgende MaxDB-Software:

● Strukturlink Web SQL und/oder

● Strukturlink WebDAV-Servlet

Die Weiterentwicklung des Web DBM wurde eingestellt. Der Web DBM ist nur bis einschließlich Version 7.5 im MaxDB-Softwarepaket enthalten. Sie können mit dem Web DBM 7.5 jedoch auch Datenbankinstanzen der Version 7.6 verwalten.

Voraussetzungen

● Sie haben einen Servlet-Container, wie z. B. Apache Tomcat, SAP NetWeaver AS oder JBoss, installiert und gestartet.

● Sie haben die MaxDB-JDBC-Schnittstelle installiert.

● Sie haben die MaxDB-Softwarekomponente oder das entsprechende Installationsprofil für Web SQL oder WebDAV installiert:

Softwarekomponenten:

○ WebSQL

○ WebDAV Servlet

Installationsprofil:

○ WebJTools

Die Software wird im Verzeichnis <independent_program_path>\servlets\websql bzw. <independent_program_path>\servlets\webdav installiert. Weitere Informationen zu den Dateien finden Sie in der Readme-Datei in diesem Verzeichnis.

● Für das WebDAV-Servlet benötigen Sie zusätzlich eine MaxDB-Datenbankinstanz der Version ≥ 7.6.

Das WebDAV-Servlet ist eine Neuimplementierung der MaxDB-WebDAV-Schnittstelle. Wenn Sie bereits in MaxDB 7.5 WebDAV für den Zugriff auf eine MaxDB-Datenbankinstanz genutzt haben, dann passt das Installationsprogramm Ihre WebDAV-Dokumentenablagen automatisch für die Verwendung mit dem neuen WebDAV-Servlet an (es ordnet u. a. die Tabellen den notwendigen Schemas zu).

Vorgehensweise

...

1. Machen Sie den MaxDB-JDBC-Treiber in Ihrem Servlet-Container verfügbar.

2. Führen Sie das Deployment im Servlet-Container durch. Informationen zum Deployment eines Servlets in Ihrem Servlet-Container finden Sie in der Dokumentation des Herstellers des Servlet-Containers.

3. Nur für die Installation des WebDAV-Servlets:

Das MaxDB-WebDAV-Servlet wird mit Beispielkonfigurationsdateien für die Servlet-Container Apache Tomcat, SAP NetWeaver AS und JBoss ausgeliefert. Sie finden diese Dateien in folgendem Verzeichnis: <independent_program_path>\servlets\webdav.

Wenn Sie einen dieser Servlet-Container verwenden, dann passen Sie die entsprechende Beispielkonfigurationsdatei an Ihre Systemumgebung an:

○ Tragen Sie in die für Ihren Servlet-Container relevanten Konfigurationsdateien die MaxDB-Datenbankinstanz als Datenquelle und die Authentifizierungsdaten eines beliebigen Datenbankbenutzers der MaxDB-Datenbankinstanz ein.

Wir empfehlen, einen eigenen Datenbankbenutzer für das WebDAV-Servlet zu verwenden. Siehe Konzepte des Datenbanksystems, Strukturlink Datenbankbenutzer.

○ Konfigurieren Sie gegebenenfalls den Kontextpfad für WebDAV. Der Vorschlagswert für den Kontextpfad ist /sdbwebdav.

○ Nur für SAP NetWeaver AS:

Tragen Sie in den Deployment Descriptor die Authentifizierungsdaten SAP NetWeaver AS-Administratorbenutzers für die J2EE-Engine ein.

Ergebnis

Sie können WebSQL / WebDAV nun über den Kontextpfad aufrufen.

Software | Kontextpfad (Vorschlagswert)
Web SQL | /websql
WebDAV | /sdbwebdav

Siehe auch:

Web SQL, Strukturlink Web SQL Studio aufrufen

WebDAV, Strukturlink WebDAV-Servlet aufrufen


Fehlerbehandlung (SAP-Bibliothek - Installation)

Hintergrunddokumentation Fehlerbehandlung

Sollte es bei Installation/Update der Datenbanksoftware oder beim Aktualisieren von Datenbankinstanzen inklusive Software zu Fehlern und infolge dessen zu einem Abbruch des Programms kommen, können Sie mit Hilfe der zur Verfügung stehenden Programme, Ihren Datensicherungen und der Software der Startversion zunächst auf die ursprüngliche Version zurückgehen. Sie gewinnen so Zeit für die Problemanalyse und halten die Stillstandszeiten so gering wie möglich.

Löschen Sie bereits installierte Dateien unter keinen Umständen manuell aus dem Dateisystem. Verwenden Sie auch bei abgebrochenen Installationen zur Deinstallation ausschließlich das Programm SDBUNINST. Andernfalls kann es im Verlaufe weiterer Installationen oder Upgrades zu nicht vorhersehbaren Problemen kommen.

Fehler bei der Ausführung des Programms SDBINST

Fehler bei der Ausführung des Programms SDBUPD


Fehler bei der Ausführung des Programms SDBINST (SAP-Bibliothek - Installation)

Hintergrunddokumentation Fehler bei der Ausführung des Programms SDBINST

Wenn bei der Ausführung des Programms SDBINST Fehler auftreten, bricht das Programm mit einer Meldung über die Fehlerursache ab.

Die häufigsten Ursachen

...

1. Es sind noch Dateien der zu aktualisierenden Software in Benutzung.

¡ Es gibt noch laufende Administrationssitzungen, d.h. das Programm Database Manager CLI ist noch aktiv.

¡ Es laufen noch Anwendungen, die die Runtime oder Scripting-Interfaces des Datenbanksystems benutzen.

2. Der noch freie Plattenplatz reicht für die neu zu installierende Software nicht aus.

3. Sie versuchen, einen 64-bit-Datenbankkern mit Hilfe der Software für einen 32-bit-Datenbankkern zu aktualisieren. Das ist nicht möglich.

4. Sie versuchen, mit Hilfe des Programms SDBINST die Software zu aktualisieren. Dabei vernachlässigen Sie die Abhängigkeiten zwischen einzelnen Softwarekomponenten bezüglich der Installationsreihenfolge oder ihrer Versionen.

Benutzerreaktion

Beseitigen Sie die Fehlerursachen und starten Sie erneut die Ausführung des Programms wie beschrieben.


Fehler bei der Ausführung des Programms SDBUPD (SAP-Bibliothek - Installation)

Vorgehensweisen Fehler bei der Ausführung des Programms SDBUPD

Wenn bei der Ausführung des Programms SDBUPD Fehler auftreten, bricht das Programm mit einer Meldung über die Fehlerursache ab.

Die häufigsten Ursachen

...

1. Bei der Ausführung des Programms SDBUPD ist ein unerwarteter Fehler aufgetreten.

2. Sie versuchen, mit Hilfe des Programms SDBUPD auf eine Softwareversion zu wechseln, die niedriger ist, als die aktuelle (nachfolgend Downgrade genannt). Beispiele für derartige Situationen:

¡ Sie haben irrtümlich eine andere als die gewünschte Softwareversion ausgewählt.

¡ Das Upgrade der Datenbankinstanz ist mit einem Fehler abgebrochen. Sie haben deshalb versucht, mit Hilfe des Programms SDBUPD auf die ursprüngliche Softwareversion zurückzugehen.

¡ Das Upgrade der Datenbankinstanz war erfolgreich, aber sie wollen aus anderen Gründen auf eine niedrigere Softwareversion zurückgehen.

Ein Downgrade mit Hilfe des Programms SDBUPD ist nicht möglich. Für die Verwendung des Programms SDBUPD muss die neu zu installierende Software mindestens eine höhere Build-Nummer aufweisen ( Strukturlink Versionsnotierung).

Benutzerreaktion

Folgen Sie den für die verschiedenen Fälle beschriebenen Vorgehensweisen.

Fall 1:

Es gibt noch keine Datenbankinstanzen, die sich auf die höhere Softwareversion beziehen.

Fall 2:

Es gibt bereits Datenbankinstanzen, die sich auf die höhere Softwareinstallation beziehen. Sie wollen einen Downgrade für jene Software durchführen, die ausschließlich von der Datenbankinstanz benutzt wird (Dependent Software).

Fall 3:

Es gibt bereits Datenbankinstanzen, die sich auf die höhere Softwareinstallation beziehen. Sie wollen einen Downgrade für jene Software durchführen, die n i c h t von der Datenbankinstanz benutzt wird oder deren Version für die Datenbankinstanz unerheblich ist (Independent Software).


Fall 1: Es gibt noch keine Datenbankinstanzen (SAP-Bibliothek - Installation)

Vorgehensweisen Fall 1: Es gibt noch keine Datenbankinstanzen

Verwendung

Es gibt noch keine Datenbankinstanzen, die sich auf die höhere Softwareversion beziehen.

Vorgehensweise

Deinstallieren Sie entweder die gesamte Datenbanksoftware mit Hilfe des Programms SDBUNINST

oder

deinstallieren Sie nur jene Softwarekomponenten, die sie in einer niedrigeren Version installieren wollen. Berücksichtigen Sie dabei die zwischen den Komponenten bestehenden Abhängigkeiten.

Deinstallation der Datenbanksoftware


Fall 2: Downgrade für Dependent Software (SAP-Bibliothek - Installation)

Vorgehensweisen Fall 2: Downgrade für Dependent Software

Verwendung

Es gibt bereits Datenbankinstanzen, die sich auf die höhere Softwareinstallation beziehen. Sie wollen einen Downgrade für jene Software durchführen, die ausschließlich von der Datenbankinstanz benutzt wird (Dependent Software).

Vorgehensweise

Löschen Sie die Registrierung vorhandener Datenbankinstanzen vor einem Downgrade.

· Wenn das Downgrade nur auf Build-Ebene erfolgen soll, wird es keine Inkompatibilitäten zwischen den Datenbankinstanzen der höheren Version und der Software der zu installierenden niedrigeren Version geben. Verfahren Sie für jede einzelne Datenbankinstanz wie nachfolgend beschrieben:

Vorgehensweise

Kommando

...

1.

Rufen Sie als DBM-Benutzer den Database Manager CLI auf und verbinden Sie sich mit der Datenbankinstanz.

dbmcli –d <database_name> -u <dbm_operator>,<dbm_operator_password>

2.

Löschen Sie die Registrierung der Datenbankinstanz.

db_drop WITHOUTFILES

3.

Beenden Sie den Database Manager CLI.

exit | release | quit | bye

4.

Deinstallieren Sie mindestens den Datenbankkern sowie die gewünschte/n Softwarekomponente/n der höheren Version.

sdbuninst –package "Database Kernel" [, <package_name2>…]

5.

Installieren Sie das gewünschte Installationsprofil der niedrigeren Version (bei OLTP-Datenbankinstanzen mindestens Server, bei liveCache-Datenbankinstanzen APO liveCache).

Achtung Für die Installation in SAP-Systemen beachten Sie den unten stehenden wichtigen Hinweis.

sdbinst –profile Server | "APO LiveCache" [, <inst_profile2>…]

6.

Registrieren Sie die Datenbankinstanz neu. Geben Sie dafür den Namen und den DBM-Benutzer der alten Datenbankinstanz sowie den Pfad der neu installierten niedrigeren Softwareversion an.

Unix/Linux:

<dependent_path>\bin
\dbmcli –s –R <dependent_path> db_create <database_name> <dbm_operator>,<dbm_operator_password>

Microsoft Windows:

"<dependent_path>\pgm
\dbmcli" –s –R "<dependent_path>" db_create <database_name> <dbm_operator>,<dbm_operator_password>

· Wenn das Downgrade mit einem Versionswechsel (Minor- oder Major-Release, siehe auch Strukturlink Versionsnotierung) der Datenbanksoftware verbunden ist, verfahren Sie wie folgt:

 | Vorgehensweise | Kommando
 | Rufen Sie als DBM-Benutzer den Database Manager CLI auf und verbinden Sie sich mit der Datenbankinstanz. | dbmcli –d <database_name> -u <dbm_user>,<password>
1. | Löschen Sie die Datenbankinstanz. | db_drop
2. | Beenden Sie den Database Manager CLI. | exit | release | quit | bye
3. | Deinstallieren Sie mindestens den Datenbankkern sowie die gewünschte/n Softwarekomponente/n der höheren Version. | sdbuninst –package "Database Kernel" [, <package_name2>…]
4. | Installieren Sie das gewünschte Installationsprofil der niedrigeren Version (bei OLTP-Datenbankinstanzen mindestens Server, bei liveCache-Datenbankinstanzen APO liveCache). Achtung Für die Installation in SAP-Systemen beachten Sie den unten stehenden wichtigen Hinweis. | sdbinst –profile Server | "APO LiveCache" [, <inst_profile2>…]
5. | Rufen Sie den Database Manager GUI auf. Verwenden Sie den Installation Wizard zum Anlegen einer neuen Datenbankinstanz unter Verwendung der Parameterdatei aus einer Sicherung. | Wählen Sie Instance ® Install. Folgen Sie den Ausführungen zum Strukturlink Anlegen einer Datenbankinstanz. Geben Sie dabei für die neue Datenbankinstanz den Datenbanksystemadministrator an, der in der Parameterdatei der Sicherung gespeichert ist.
6. | Beenden Sie den Database Manager GUI. | Wählen Sie File ® Exit.

Wenn Sie diese Vorgehensweise in SAP-Systemen verwenden, akzeptieren Sie nicht die Vorschlagswerte des Systems. Machen Sie stattdessen folgende Angaben:

<group> | für Zielversionen größer/gleich 7.5.00: sdba für alle vorherigen Datenbankversionen: sapsys
<owner> | für Zielversionen größer/gleich 7.5.00 immer: sdb für alle vorherigen Datenbankversionen · bei OLTP-Datenbankinstanzen: sqdsid · bei liveCache-Datenbankinstanzen: sidadm
<independent_data_path> | UNIX/Linux: /sapdb/data Microsoft Windows: <drive>:\sapdb\data
<independent_program_path> | UNIX/Linux: /sapdb/programs Microsoft Windows: <drive>:\sapdb\programs
<dependent_path> | UNIX/Linux: /sapdb/<SID>/db Microsoft Windows: <drive>:\sapdb\<SID>\db


Fall 3: Downgrade für Independent Software (SAP-Bibliothek - Installation)

Vorgehensweisen Fall 3: Downgrade für Independent Software

Verwendung

Es gibt bereits Datenbankinstanzen, die sich auf die höhere Softwareinstallation beziehen. Sie wollen einen Downgrade für jene Software, die n i c h t von der Datenbankinstanz benutzt wird oder deren Version für die Datenbankinstanz unerheblich ist (Independent Software).

Vorgehensweise

 | Aktion | Kommando
... 1. | Deinstallieren Sie mindestens den Datenbankkern sowie die gewünschte/n Softwarekomponente/n der höheren Version. | sdbuninst –package "Database Kernel" [, <package_name2>…]
2. | Installieren Sie das gewünschte Installationsprofil der niedrigeren Version (bei OLTP-Datenbankinstanzen mindestens Server, bei liveCache-Datenbankinstanzen APO liveCache). Für die Installation in SAP-Systemen beachten Sie den unten stehenden wichtigen Hinweis. | sdbinst –profile Server | "APO LiveCache" [, <inst_profile2>…]

Sollten Sie diese Vorgehensweise in SAP-Systemen verwenden, akzeptieren Sie nicht die Vorschlagswerte des Systems. Machen Sie stattdessen folgende Angaben:

<group> | für Zielversionen größer/gleich 7.5.00: sdba für alle vorherigen Datenbankversionen: sapsys
<owner> | für Zielversionen größer/gleich 7.5.00 immer: sdb für alle vorherigen Datenbankversionen · bei OLTP-Datenbankinstanzen: sqdsid · bei liveCache-Datenbankinstanzen: sidadm
<independent_data_path> | UNIX/Linux: /sapdb/data Microsoft Windows: <drive>:\sapdb\data
<independent_program_path> | UNIX/Linux: /sapdb/programs Microsoft Windows: <drive>:\sapdb\programs
<dependent_path> | UNIX/Linux: /sapdb/<SIS>/db Microsoft Windows: <drive>:\sapdb\<SID>\db


Detailinformationen (SAP-Bibliothek - Installation)

Hintergrunddokumentation Detailinformationen

Verzeichnisse

Komponentengruppen

Installationsprofile

Softwarekomponenten

Protokollierung

Anzeigen der installierten Softwarekomponenten

Übersicht der Optionen für das Programm SDBINST

Übersicht der Optionen für das Programm SDBUNINST

Übersicht der Optionen für das Programm SDBUPD


Verzeichnisse (SAP-Bibliothek - Installation)

Hintergrunddokumentation Verzeichnisse

Das Datenbanksystems legt seine Programme und Bibliotheken in zwei verschiedenen Wurzelverzeichnissen ab.

Das erste Wurzelverzeichnis ist der Independent Program Path. Auf einem Rechner gibt es immer nur einen Independent Program Path. Dieser wird bei der Erstinstallation der MaxDB-Software festgelegt.

Das zweite Wurzelverzeichnis ist der Dependent Path. Dieses Verzeichnis wird nur auf dem Datenbankrechner angelegt. Darin werden die Programme und Bibliotheken des Databankkerns abgelegt. Auf einem Datenbankrechner können beliebig viele Wurzelverzeichnisse Dependent Path ausgeprägt werden. Damit kann jede Datenbankinstanz mit einem eigenen Datenbankkern betrieben werden.

Bei der Installation der MaxDB-Software erhalten Sie vom System Vorschlagswerte für die Wurzelverzeichnisse angeboten, die Sie Ihren Erfordernissen anpassen können. Die angebotenen Vorschlagswerte variieren, da das System bei der Erstellung der Vorschlagswerte die Gegebenheiten der Installationsumgebung berücksichtigt, d.h. ob bereits MaxDB-Softwareinstallationen vorhanden sind und unter welchen Pfaden diese abgelegt wurden, ob die Software innerhalb eines SAP-Systems oder beispielsweise für eine allein stehende Open-Source-Installation installiert werden soll etc.

Die in der Dokumentation dargestellten Verzeichnisstrukturen können deshalb nur als Orientierung dienen.

Für Übersichten der bei der Installation unter Microsoft Windows und UNIX/Linux angelegten Pfade siehe:

Verzeichnisstruktur innerhalb von SAP-Systemen

Verzeichnisstruktur außerhalb von SAP-Systemen

Wichtige Verzeichnisse des Datenbanksystems

Pfad

Inhalt des Verzeichnisses

<independent_program_path>

die von allen Datenbankinstanzen und Anwendungen gemeinsam genutzte Programme und Bibliotheken,

diese haben immer die neueste installierte Version der Datenbanksoftware

<independent_program_path>\runtime

Laufzeitumgebung der Clients, z. B. JDBC, Precompiler

<dependent_path>

Installationsverzeichnis der Datenbanksoftware,

Speicherort für die von der Softwareversion abhängige Server-Software

Es können beliebig viele Verzeichnisse verschiedener Versionen nebeneinander existieren.

Alle Programme in diesen versionsabhängigen Verzeichnissen werden nicht direkt von den Benutzern ausgeführt, sondern mit den in <independent_program_path> abgelegten Programmen aufgerufen.

<independent_data_path>

Daten, Konfiguration und Arbeitsverzeichnisse von Datenbankinstanzen und Anwendungen

<independent_data_path>\config

Konfigurationsdateien für Datenbankparameter, Daten für die Benutzerautorisierung usw.

<independent_data_path>\wrk\<database_name>

Strukturlink Arbeitsverzeichnis der Datenbankinstanz <database_name>

<independent_data_path>\wrk\<database_name>\DIAGHISTORY

Diagnosedateien (Sicherungen der wichtigsten Protokolldateien und Speicherauszüge), die das Datenbanksystem nach einem Datenbankfehler speichert

Sie können den Pfad dieses Verzeichnisses mit dem Strukturlink speziellen Datenbankparameter DIAG_HISTORY_PATH konfigurieren.

<tool_application_data>

Protokoll- und Konfigurationsdateien des Datenbankwerkzeugs <tool> u. a.

<tool_user_data>

Die vom angemeldeten Betriebssystembenutzer mit dem Datenbankwerkzeug <tool> erzeugten Daten


Verzeichnisstruktur innerhalb von SAP-Systemen (SAP-Bibliothek - Installation)

Hintergrunddokumentation Verzeichnisstruktur innerhalb von SAP-Systemen

Fall 1: Softwareinstallation mit Anlegen einer Datenbankinstanz (Server- und Client-Installation)

In SAP-Systemen wird für jede Datenbankinstanz ein gesondertes MaxDB-Softwarepaket installiert, das von nur einer Datenbankinstanz verwendet wird. Das bedeutet beispielsweise, dass für 2 Datenbankinstanzen der Version 7.6 zweimal die MaxDB-Software der Version 7.6 installiert wird.

Die komplette Softwareinstallation auf dem Datenbankrechner umfasst folgende Pfade:

● ein Independent Program Path

● ein Dependent Path

● ein Independent Data Path

● ein Arbeitsverzeichnis der Datenbankinstanz

● ein Pfad für die Ablage der Log-Volumes

● ein Pfad für die Ablage der Data-Volumes

Vorschlagswerte für die Verzeichnisstruktur

Pfad | Vorschlagswert unter Microsoft Windows | Vorschlagswert unter UNIX/Linux
Independent Program Path | <drive>:\sapdb\programs --bin --pgm --... --... | /sapdb/programs
Dependent Path | <drive>:\sapdb\<database_name>\db | /sapdb/<database_name>/db
Independent Data Path | <drive>:\sapdb\data | /sapdb/data
Arbeitsverzeichnis der Datenbankinstanz | <drive>:\sapdb\data\wrk\<database_name> | /var/opt/sdb/data/wrk/<database_name>
Ablage der Log-Volumes | <drive>:\sapdb\<database_name>\saplog | /var/opt/sdb/data/<database_name>/log
Ablage der Data-Volumes | <drive>:\sapdb\<database_name>\sapdata | /var/opt/sdb/data/<database_name>/data

Um die Abwärtskompatibilität der Datenbanksoftware zu gewährleisten, legt das Datenbanksystem auf UNIX/Linux auch die folgenden Verzeichnisse an:

Pfad | Inhalt des Verzeichnisses
/var/spool/sql | Links auf aktuelle Verzeichnisse und Dateien
/usr/spool/sql | Links auf aktuelle Verzeichnisse und Dateien

Fall 2: Softwareinstallation als Applikationsserver (Client-Installation)

Bei einer reinen Client-Installation werden folgende Pfade angelegt:

● ein Independent Program Path

● ein Independent Data Path

Vorschlagswerte für die Verzeichnisstruktur

Pfad | Vorschlagswert unter Microsoft Windows | Vorschlagswert unter UNIX/Linux
Independent Program Path | <drive>:\sapdb\programs --bin --pgm --... --... | /sapdb/programs
Independent Data Path | <drive>:\sapdb\data | /sapdb/data

Um die Abwärtskompatibilität der Datenbanksoftware zu gewährleisten, legt das Datenbanksystem auf UNIX/Linux auch die folgenden Verzeichnisse an:

Pfad | Inhalt des Verzeichnisses
/var/spool/sql | Links auf aktuelle Verzeichnisse und Dateien
/usr/spool/sql | Links auf aktuelle Verzeichnisse und Dateien


Verzeichnisstruktur außerhalb von SAP-Systemen (SAP-Bibliothek - Installation)

Hintergrunddokumentation Verzeichnisstruktur außerhalb von SAP-Systemen

Bei der Softwareinstallation außerhalb von SAP-Systemen haben Sie die Wahl, die Datenbanksoftware zu installieren und gleichzeitig eine Datenbankinstanz anzulegen oder zunächst ausschließlich die Datenbanksoftware zu installieren.

Des weiteren haben Sie die Möglichkeit, anschließend weitere Datenbankinstanzen anzulegen, die alle dieselbe Serversoftware verwenden (gleicher Dependant Path). Sie können aber auch für weitere Datenbankinstanzen weitere Softwareinstallationen vornehmen, so dass eine Installation der Serversoftware jeweils nur von einer Datenbankinstanz verwendet wird (mehrere Dependent Paths).

Je nachdem, was auf Ihrem System bereits installiert ist und ob Sie nur Software installieren, nur eine Datenbankinstanz anlegen oder beides zusammen, bietet Ihnen das System verschiedene Vorschlagswerte für die Verzeichnisse an, in die die Datenbanksoftware installiert und die Dateien des Datenbanksystems gespeichert werden.

Die nachfolgenddargestellten Verzeichnisstrukturen können deshalb nur als Orientierung dienen.

Fall 1: Erstinstallation der Datenbanksoftware mit Anlegen einer Datenbankinstanz

  • ein Independent Program Path
  • ein Dependent Path
  • ein Independent Data Path
  • ein Arbeitsverzeichnis der Datenbankinstanz
  • ein Pfad für die Ablage der Log-Volumes
  • ein Pfad für die Ablage der Data-Volumes

Pfad | Vorschlagswert Microsoft Windows | Vorschlagswert UNIX/Linux
Independent Program Path | <drive>:\Program Files\sdb\programs | /opt/sdb/programs
Dependent Path | <drive>:\Program Files\sdb\<database_name> | /opt/sdb/<database_name>/db
Independent Data Path | <drive>:\Documents and Settings\All Users\Application Data\sdb\data | /var/opt/sdb/data
Arbeitsverzeichnis der Datenbankinstanz | <drive>:\Documents and Settings\All Users\Application Data\sdb\data\wrk\<database_name> | /var/opt/sdb/data/wrk\<database_name>
Pfad für die Ablage der Log-Volumes | <drive>:\Documents and Settings\All Users\Application Data\sdb\<database_name>\log | /var/opt/sdb/data/<database_name>/log
Pfad für die Ablage der Data-Volumes | <drive>:\Documents and Settings\All Users\Application Data\sdb\<database_name>\data | /var/opt/sdb/data/<database_name>/data

Um die Abwärtskompatibilität der Datenbanksoftware zu gewährleisten, legt das Datenbanksystem auf UNIX/Linux auch die folgenden Verzeichnisse an:

Pfad | Inhalt des Verzeichnisses
/var/spool/sql | Links auf aktuelle Verzeichnisse und Dateien
/usr/spool/sql | Links auf aktuelle Verzeichnisse und Dateien

Fall 2: Anlegen weiterer Datenbankinstanzen, die diese Serversoftware verwenden

Independent Program Path und Independent Data Path sind bereits bei der Installation der verwendeten Serversoftware festgelegt worden.

Beim Anlegen weiterer Datenbankinstanzen wird pro Datenbankinstanz ein Pfad für den Dependent Path angelegt. Des weiteren werden unterhalb des vorhandenen Independent Data Path pro Datenbankinstanz der Pfad für das Arbeitsverzeichnis, der Pfad für die Ablage der Log-Volumes und der Pfad für die Ablage der Data-Volumes angelegt.

Pro Datenbankinstanz werden folgende neue Pfade angelegt:

  • ein Arbeitsverzeichnis der Datenbankinstanz
  • ein Pfad für die Ablage der Log-Volumes
  • ein Pfad für die Ablage der Data-Volumes

Pfad | Vorschlagswert Microsoft Windows | Vorschlagswert UNIX/Linux
Arbeitsverzeichnis der Datenbankinstanz | <drive>:\Documents and Settings\All Users\Application Data\sdb\data\wrk\<database_name> | /var/opt/sdb/data/wrk/<database_name>
Pfad für die Ablage der Log-Volumes | <drive>:\Documents and Settings\All Users\Application Data\sdb\<database_name>\log | /var/opt/sdb/data/<database_name>/log
Pfad für die Ablage der Data-Volumes | <drive>:\Documents and Settings\All Users\Application Data\sdb\<database_name>\data | /var/opt/sdb/data/<database_name>/data

Beipiel:

Die Datenbankinstanzen DEMODB, TESTDB und MAXDB werden alle mit der gleichen bereits vorhandenen Serversoftware angelegt. Daraus ergibt sich folgende Pfadstruktur unterhalb des Independent Data Path:

<drive>:\Documents and Settings

-All Users

--Application Data

---sdb

----data

-----wrk

------DEMODB

------TESTDB

------MAXDB

-----DEMODB

------log

------data

-----TESTDB

------log

------data

-----MAXDB

------log

------data

Fall 3: Erstinstallation der Datenbanksoftware mit dem Ziel, später die erste Datenbankinstanz anzulegen

  • ein Independent Program Path
  • ein Dependent Path
  • ein Independent Data Path

Pfad | Vorschlagswert Microsoft Windows | Vorschlagswert UNIX/Linux
Independent Program Path | <drive>:\Program Files\sdb\programs | /opt/sdb/programs
Dependent Path | <drive>:\Program Files\sdb\<version> | /opt/sdb/<version>
Independent Data Path | <drive>:\Documents and Settings\All Users\Application Data\sdb\data | /var/opt/sdb/data

Um die Abwärtskompatibilität der Datenbanksoftware zu gewährleisten, legt das Datenbanksystem auf UNIX/Linux auch die folgenden Verzeichnisse an:

Pfad | Inhalt des Verzeichnisses
/var/spool/sql | Links auf aktuelle Verzeichnisse und Dateien
/usr/spool/sql | Links auf aktuelle Verzeichnisse und Dateien


Komponentengruppen (SAP-Bibliothek - Installation)

Hintergrunddokumentation Komponentengruppen

Komponentengruppen sind Zusammenstellungen einzelner Softwarekomponenten, wie sie für verschiedene Zwecke benötigt werden.

Unabhängig davon, für welche Komponentengruppe Sie sich entscheiden, erhalten sie eine funktionierende Softwareinstallation. Wenn Sie im Gegensatz dazu einzelne Softwarekomponenten, also Teile von Installationsprofilen installieren wollen, müssen Sie die zwischen Komponenten bestehenden Abhängigkeiten berücksichtigen, um die Funktionsfähigkeit dieser Softwareinstallation zu gewährleisten.

Komponentengruppen

Name | enthaltene Softwarekomponenten | Installation/Update von
Server+Client | alle | gesamte MaxDB-Software
Client | alle Softwarekomponenten außer: · Server Utilities · Database Kernel · APO LC Apps | gesamte MaxDB-Software außer: · Werkzeuge zum Verwalten des Datenbankkerns (einschließlich XCONS) · Datenbankkern mit Laufzeitumgebung · Bibliotheken mit den APO liveCache-Routinen
Custom | Sie wählen aus, welche Installationsprofile Sie installieren möchten. | benutzerdefiniert
none | - | -


Installationsprofile (SAP-Bibliothek - Installation)

Hintergrunddokumentation Installationsprofile

Installationsprofile sind Zusammenstellungen einzelner Softwarekomponenten, wie sie für verschiedene Zwecke benötigt werden. Unabhängig davon, für welches Installationsprofil Sie sich entscheiden, erhalten sie eine funktionierende Softwareinstallation.

Wenn Sie sich einzelne Softwarekomponenten, also Teile von Installationsprofilen installieren wollen, müssen Sie die zwischen Komponenten bestehenden Abhängigkeiten berücksichtigen, um die Funktionsfähigkeit dieser Softwareinstallation zu gewährleisten.

Sie können zwischen folgenden Installationsprofilen wählen:

Name | Enthaltene Softwarekomponenten | Installation/Update von
all | alle Softwarekomponenten | gesamtes Datenbanksoftware-Paket
APO LiveCache | nur für liveCache im SAP-System APO Base, mehrere PCR <version>, Server Utilities, ODBC (nur für MS Windows), DB Analyzer, Database Kernel, APO LC APPS bzw. APO COM (bis APO Version 4.0) | Server- und –Client-Software des liveCache-Datenbanksystems
DB Analyzer | Base, ODBC (nur für MS Windows), DB Analyzer | Database Analyzer
JDBC | Base, JDBC | MaxDB-JDBC-Treiber
Loader | Base, Loader, Redist Python | Loader
Runtime for SAP AS | Base, mehrere PCR <version>, JDBC, Loader | Client-Software für den SAP-Applikationsserver
Script Interface | Base, Perl Interface, Python Interface | Bibliotheken für Anwendungen, die Programmierschnittstellen benutzen
Server | Base, Database Kernel, Server Utilities, ODBC, JDBC, Loader, DB Analyzer, | Server- und Client-Software des OLTP-Datenbanksystems
Web Tools | Base, ODBC, Web Tools, XML Indexing Engine | Web Tools

Namen von Softwarekomponenten, die Leerzeichen enthalten, müssen im Installationskommando in doppelte Anführungszeichen gesetzt werden.


Softwarekomponenten (SAP-Bibliothek - Installation)

Hintergrunddokumentation Softwarekomponenten

Verwendung

Sie installieren Installationspakete, die nur einzelne Komponenten der Datenbanksoftware enthalten. Auf diese Weise können Sie einzelne fehlende Komponenten nachträglich installieren ohne andere, für diese Komponente nicht erforderliche Komponenten, zu aktualisieren.

Verglichen mit der Installation von Komponentengruppen oder Installationsprofilen ist die Installation von Softwarekomponenten komplexer und verlangt vom Benutzer die Kenntnis und Berücksichtigung der bestehenden Abhängigkeiten, die durch den Inhalt und/oder die Version der Software bedingt sind.

Da die Installation nicht interaktiv sondern nur als Installation im Hintergrund ausgeführt werden kann, müssen Sie sich vor Beginn der Installation informieren, welche weiteren Komponenten für eine bestimmte Komponente erforderlich sind und in welcher Reihenfolge diese installiert werden müssen. Sobald das Installationsprogramm erkennt, dass Abhängigkeiten nicht berücksichtigt sind, bricht es den Installationsvorgang ab. Sie sollten diese Art der Installation deshalb nur im Sonderfall durchführen.

Die Datenbanksoftware ist in folgende Komponenten gegliedert:

Name | Beschreibung
APO LC APPS (ab APO Version 4.0) bzw. APO COM | nur für SAP liveCache im SAP-System APO: Bibliotheken mit den APO liveCache-Routinen
Base | Programme zum Registrieren der Installation, Deinstallationswerkzeug, InstallRegistryViewer und Programme, die vom SAP-Applikationsserver benötigt werden, um auf das Datenbanksystem zugreifen zu können (einschließlich Database Manager CLI, XUSER und SQLCLI)
Database Kernel | Datenbankkern mit Laufzeitumgebung.
DB Analyzer | Database Analyzer: Werkzeug zur Analyse der Datenbank-Performance
JDBC | MaxDB-JDBC-Treiber für den Zugriff auf das Datenbanksystem MaxDB
Loader | Loader: Werkzeug zum Importieren und Exportieren von Daten
ODBC | ODBC-Treiber für den Zugriff auf das Datenbanksystem MaxDB
PCR<version> | Precompiler-Runtime-Paket, enthält Laufzeitbibliotheken für Anwendungen, die mit dem C/C++-Precompiler für Embedded SQL erstellt wurden, kann in mehreren Versionen im lokalen Installationsverzeichnis vorliegen
Perl Interface | Perl-Schnittstelle
Python Interface | Python-Schnittstelle
Redist Python | Python Interface und Erweiterungen
Server Utilities | Werkzeuge zum Verwalten des Datenbankkerns (einschließlich XCONS)
SQLDBC | Objekt-orientierte C++-Schnittstelle für den Zugriff auf das Datenbanksystem MaxDB, enthält u. a. eine nicht-versionierte SQLDBC-Bibliothek
SQLDBC <version> | versionierte SQLDBC-Bibliothek
Web Tools | Web Server und Web-basierte Datenbankwerkzeuge (Web DBM)

Namen von Softwarekomponenten, die Leerzeichen enthalten, müssen im Installationskommando in doppelte Anführungszeichen gesetzt werden.

Abhängigkeiten

Zwischen den Softwarekomponenten bestehen folgende Abhängigkeiten:

Base ® Server Utilities ® Database Kernel ® APO LC APPS | APO COM
Base ® CPC Base ® CPC SDK <version>
Base ® ODBC ® Web Tools
Base [ ® ODBC]* ® DB Analyzer
Base ® SQLDBC
Base ® JDBC
Base ® Loader
Base ®Perl Interface
Base ®Python Interface
Base ® PCR <version>
Base ® Redist Python

* Komponente ist nur auf Microsoft Windows Voraussetzung für DB Analyzer

Erläuterung der Abhängigkeiten

● Die Softwarekomponente Base ist unabhängig von allen anderen Paketen.

● Die Softwarekomponente Server Utilities kann erst nach der Installation von Base installiert werden.

○ Die Softwarekomponente Database Kernel kann erst nach der Installation von Server Utilities installiert werden.

■ Die Softwarekomponente APO LC APPS bzw. APO COM kann erst nach Installation von Database Kernel installiert werden.

● Die Softwarekomponente CPC Base kann erst nach der Installation von Base installiert werden.

○ Die Softwarekomponente CPC SDK <version> kann erst nach der Installation von CPC Base installiert werden.

● Die Softwarekomponente ODBC kann erst nach der Installation von Base installiert werden.

○ Die Softwarekomponente Web Tools kann erst nach der Installation von ODBC installiert werden.

● Die Softwarekomponente DB Analyzer kann erst nach der Installation von Base (auf UNIX-Betriebssystemen) bzw. Base und ODBC (auf Windows-Betriebssystemen) installiert werden.

● Die Softwarekomponente SQLDBC kann erst nach der Installation von Base installiert werden.

● Die Softwarekomponente JDBC kann erst nach der Installation von Base installiert werden.

● Die Softwarekomponente Loader kann erst nach der Installation von Base installiert werden.

● Die Softwarekomponente Perl kann erst nach der Installation von Base installiert werden.

● Die Softwarekomponente Python kann erst nach der Installation von Base installiert werden.

● Die Softwarekomponente PCR <version> kann erst nach der Installation von Base installiert werden.


Protokollierung (SAP-Bibliothek - Installation)

Hintergrunddokumentation Protokollierung

Verwendung

Alle Schritte bei Installation/Update und der Aktualisierung von Datenbankinstanzen inklusive Server-Software werden in Protokolldateien gespeichert. Der Name der Protokolldatei enthält eine Angabe zum Produktnamen MaxDB oder SAP liveCache.

Konventionen

Verzeichnisse

Ablage der Protokolldatei für Installation/Update

● UNIX/Linux (tgz-Paket):
<independent_data_path>/wrk/MAXDB<profile>_install-<date>-<time>.log

oder

<independent_data_path>/wrk/SAPliveCache<profile>_install-<date>-<time>.log

● Microsoft Windows:
<independent_data_path>\wrk\MAXDB<profile>_install-<date>-<time>.log

oder

<independent_data_path>\wrk\SAPliveCache<profile>_install-<date>-<time>.log

Wenn das Verzeichnis <independent_data_path> zur Abbruchzeit noch nicht bekannt ist, wird das Protokoll im aktuellen Verzeichnis erstellt.

Falls Sie einzelne Softwarekomponenten installiert/aktualisiert haben, finden Sie die Protokollierung in der Datei
MAXDBSoftware_install-<date>-<time>.log

oder

SAPliveCacheSoftware_install-<date>-<time>.log

Ablage der Protokolldatei für die Aktualisierung von Datenbankinstanzen inklusive Software (Upgrade)

● UNIX/Linux (tgz-Paket):
<independent_data_path>/wrk/MAXDBUpgrade_install-<date>-<time>.log oder

<independent_data_path>/wrk/SAPliveCacheUpgrade_install-<date>-<time>.log

● Microsoft Windows:
<independent_data_path>\wrk\MAXDBUpgrade_install-<date>-<time>.log

oder

<independent_data_path>\wrk\SAPliveCacheUpgrade_install-<date>-<time>.log


Anzeigen der installierten Softwarekomponenten (SAP-Bibliothek - Installation)

Vorgehensweisen Anzeigen der installierten Softwarekomponenten

Verwendung

Sie können sich die installierten Softwarekomponenten der MaxDB-Software auf der Kommandozeile anzeigen lassen.

Vorgehensweise

Öffnen Sie ein Kommandozeilenfenster und machen Sie folgende Eingabe:

sdbregview –l

Beispiel

C:\>sdbregview -l

Server Utilities c:/program files/sdb/programs 7.6.00.16 32 bit valid

DB Analyzer c:/program files/sdb/programs 7.6.00.16 32 bit valid

PCR 7300 c:/program files/sdb/programs 7.3.00.54

valid

PCR 7301 c:/program files/sdb/programs 7.3.01.19

valid

PCR 7104 c:/program files/sdb/programs 7.1.04.45

valid

Webtools c:/program files/sdb/programs/web 7.6.00.16 32 bit valid

Synchronization Manager c:/program files/sdb/programs 7.6.00.16

valid

Base c:/program files/sdb/programs 7.6.00.16 32 bit valid

…

…


Übersicht der Optionen für das Programm SDBINST (SAP-Bibliothek - Installation)

Syntaxdokumentation Übersicht der Optionen für das Programm SDBINST

Bei der Installation/Update von Datenbanksoftware mit dem Programm SDBINST stehen Ihnen folgende Optionen zur Verfügung:

Option

Beschreibung

-b | -batch

Verwendung des Installationsprogramms im Hintergrund

Wenn Sie diese Option angeben, bricht das Installationsprogramm im Falle fehlender Angaben mit einem Fehler ab.

Wenn Sie diese Option nicht angeben, stoppt das Programm im Falle fehlender Angaben und fordert Sie zur Interaktion auf.

-component_group <component_group>

<component_group> = Server | Client

Komponentengruppe

Server entspricht der Komponentengruppe Server+Client

-profile <inst_profile>

Installationsprofil

Namen, die Leerzeichen enthalten, müssen im Installationskommando in doppelte Anführungszeichen gesetzt werden.

-package <package_name>

Logischer Name der Softwarekomponente (nicht Dateinamen)

Namen, die Leerzeichen enthalten, müssen im Installationskommando in doppelte Anführungszeichen gesetzt werden.

-indep_data <independent_data_path>

Kann nur bei einer Neuinstallation spezifiziert werden. In allen anderen Fällen wird die Angabe vom System ignoriert. Eine Änderung dieser Pfadangabe ist nur nach einer vollständigen Deinstallation der Datenbanksoftware möglich.

-indep_prog <independent-program_path>

Kann nur bei einer Neuinstallation spezifiziert werden. In allen anderen Fällen wird die Angabe vom System ignoriert. Eine Änderung dieser Pfadangabe ist nur nach einer vollständigen Deinstallation der Datenbanksoftware möglich.

-depend <dependent_path>

Muss nur bei einer Neuinstallation und nur für die Installationsprofile all, Server und APO LiveCache sowie die Softwarekomponenten Database Kernel und APO LC APPS (ab APO Version 4.) bzw.APO COM angegeben werden. In allen anderen Fällen wird die Angabe vom System ignoriert.

-a <archive_directory>

Verzeichnis, in dem sich die Installationspakete befinden

-o | -owner <sdb_user>

nur UNIX: Eigentümer der Software

-g | -group <sdba_group>

nur UNIX: Gruppe der Software (Administratorengruppe)

-h | -help

Liste der möglichen Optionen und Beschreibungen

-v | -version

Versionsnummer des Installationsprogramms SDBINST

-l | -list

Anzeigen aller möglichen Installationsprofile und Softwarekomponenten

Siehe auch:

Verzeichnisse


Übersicht der Optionen für das Programm SDBUNINST (SAP-Bibliothek - Installation)

Syntaxdokumentation Übersicht der Optionen für das Programm SDBUNINST

Bei der Deinstallation von Datenbanksoftware mit dem Programm SDBUNINST stehen Ihnen folgende Optionen zur Verfügung:

Option

Beschreibung

-all

Es wird die gesamte für MaxDB registrierte Software deinstalliert.

-package <package>

Logischer Name der Softwarekomponente, die deinstalliert werden soll (nicht Dateiname)

-package_dir <package_directory>

Verzeichnis der angegebenen Softwarekomponente
Diese Angabe ist nur erforderlich, wenn es mehrere Softwarepakete gleichen Namens gibt.

-autoresolve

Das System deinstalliert neben der angegebenen Softwarekomponente auch alle davon abhängigen Komponenten.

-package ODBC –autoresolve

Unter Microsoft Windows werden die Komponenten ODBC und die davon abhängige Komponente Web Tools deinstalliert.

-h | -help

Liste der möglichen Optionen und Beschreibungen

-v | -version

Versionsnummer des Deinstallationsprogramms SDBUNINST

-l | -list

Anzeigen aller möglichen Softwarekomponenten


Übersicht der Optionen für das Programm SDBUPD (SAP-Bibliothek - Installation)

Syntaxdokumentation Übersicht der Optionen für das Programm SDBUPD

Beim Upgrade von Datenbankinstanzen mit dem Programm SDBUPD stehen Ihnen folgende Optionen zur Verfügung:

Option

Beschreibung

-b | -batch

Verwendung des Programms SDBUPD im Hintergrund

Wenn Sie diese Option angeben, bricht das Installationsprogramm im Falle fehlender Angaben mit einem Fehler ab.

Wenn Sie diese Option nicht angeben, stoppt das Programm im Falle fehlender Angaben und fordert Sie zur Interaktion auf.

-d <database_name>

Strukturlink Name der Datenbankinstanz

-u <dbm_operator>,<dbm_operator_password>

Name und Kennwort des Strukturlink DBM-Benutzers

-h | -help

Liste der möglichen Optionen und Beschreibungen

-v | -version

Versionsnummer des Programms SDBUPD

-l | -list

Anzeigen aller möglichen Installationsprofile und Softwarekomponenten

-o <sdb_user>

Eigentümer der Software (nur UNIX/Linux) beim Upgrade zur Softwareversion 7.5.00 und höher (siehe Konzepte des Datenbanksystems, Strukturlink Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux))

-g <sdba_group>

Administratorengruppe (nur UNIX/Linux) beim Upgrade zur Softwareversion 7.5.00 und höher


Grundwissen (SAP-Bibliothek - Grundwissen)

Komponentendokumentation Grundwissen

Titel der Dokumentation | Inhalt
Konzepte des Datenbanksystems | Informationen zum Datenbanksystem, Technische Systemlandschaft, Anlegen und Konfigurieren einer Datenbankinstanz, Verwaltung, Überwachung, Performance, Fehlersuche, Entwicklung von Datenbankanwendungen
Glossar | Begriffe des Datenbanksystems
SQL-Referenzhandbuch | SQL-Anweisungen und ihre Syntax, Systemtabellenbeschreibung, Besonderheiten im SQL-Modus ORACLE
Meldungen | Liste aller Meldungen des Datenbanksystems: Rück- und Fehlermeldungen des Datenbankkerns, und der Datenbankwerkzeuge, mit kurzen Erläuterungen für die mögliche Fehlerursache und Hinweisen zu ihrer Behebung
MaxDB-Sicherheitsleitfaden | Empfohlene Sicherheitsmaßnahmen für das Datenbanksystem
SAP Technical Operations Manual, Strukturlink Datenbankverwaltung für MaxDB | Überblick über die wichtigsten Verwaltungsaufgaben für MaxDB in SAP-Systemen
Strukturlink High Availability for the MySQL MaxDB Database | Bedingungen zur Gewährleistung hoher Verfügbarkeit einer MaxDB-Datenbankinstanz in einem SAP-System, nur in Englisch verfügbar


Konzepte des Datenbanksystems (SAP-Bibliothek - Grundwissen)

Komponentendokumentation Konzepte des Datenbanksystems

Einsatzmöglichkeiten

Diese Dokumentation beschreibt die MaxDB-Software und die SAP liveCache-Technologie.

MaxDB ist ein relationales Datenbanksystem, mit dem Sie MaxDB-Datenbankinstanzen anlegen, nutzen und verwalten können.

Die SAP liveCache-Technologie ist eine objektbasierte Erweiterung des MaxDB-Datenbanksystems. Sie können die SAP liveCache-Technologie sowohl als normales relationales Datenbanksystem als auch als hauptspeicherzentriertes Spezialdatenbanksystem einsetzen.

Wenn nicht gesondert erwähnt, gilt die Beschreibung des MaxDB-Datenbanksystems in dieser Dokumentation auch für die SAP liveCache-Technologie.

Die MaxDB-Software und die SAP liveCache-Technologie können Sie auf mehreren Betriebssystemen verwenden (siehe Unterstützte Betriebssysteme und Plattformen).

Einführungshinweise

Informationen dazu, wo Sie die Datenbanksoftware erhalten und wie Sie sie installieren, finden Sie in den Abschnitten Informationen zur Software und Download und im Strukturlink Installationshandbuch.

Die vorliegende Dokumentation beschreibt die grundlegenden Konzepte des Datenbanksystems und verweist auf die Dokumentationen der Datenbankwerkzeuge und Schnittstellen, in denen die genauen Vorgehensweisen beschrieben sind. Das Strukturlink SQL-Tutorial bietet eine Einführung in die SQL-Syntax des Datenbanksystems.

Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Glossar.

Siehe auch:

Informationen zur Software

Das Datenbanksystem im Überblick

Datenbankwerkzeuge

Schnittstellen

Technische Systemlandschaft

Anlegen und Konfigurieren einer Datenbankinstanz

Verwaltung

Überwachung

Performance

Fehlersuche

Entwicklung von Datenbankanwendungen


Informationen zur Software (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Informationen zur Software

Mit der MaxDB-Software können Sie Datenbanken erstellen, nutzen und verwalten. Eine MaxDB-Datenbank können Sie unter anderem als Datenbank eines SAP-Systems einsetzen.

Vor der Version 7.5 wurde MaxDB unter dem Namen SAP DB ausgeliefert.

Sie können die MaxDB-Software, die MaxDB-Dokumentation und die Demo-Datenbank über die MaxDB-Website herunterladen, siehe Download und Versionsnotierung. MaxDB läuft auf einer Vielzahl von Plattformen, siehe Unterstützte Betriebssysteme und Plattformen.

Um kommerzielle Software basierend auf MaxDB zu entwickeln, benötigen Sie eine kommerzielle Lizenz. Kommerzielle Lizenzen für MaxDB sind von SAP und von MySQL erhältlich. Für Open-Source- und andere Softwareentwicklungsprojekte und für Test- oder Bildungszwecke ist MaxDB auch unter der GNU General Public Licence (GPL) erhältlich, siehe www.mysql.com/company/legal/licensing und Open-Source-Entwicklung der Datenbanksoftware.

Um Hilfe bei Fragen und Problemen zu erhalten, stehen Ihnen mehrere Optionen zur Verfügung, siehe Support und Problemmeldungen mit Web PTS verfolgen.

Siehe auch:

Datenbankwerkzeuge

Technische Systemlandschaft

Dokumentation Strukturlink Installationshandbuch


SAP DB und MaxDB (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SAP DB und MaxDB

Im Mai 2003 hat SAP einen Kooperationsvertrag mit MySQL AB geschlossen. Gemäß diesem Vertrag wird die Datenbank SAP DB seit der Datenbankversion 7.5 unter dem Namen MaxDB ausgeliefert.

MaxDB 7.5 ist Ergebnis der Weiterentwicklung des SAP DB Quelltexts. Die MaxDB-Software 7.5 können Sie als direktes Upgrade für die bisherigen SAP DB-Versionen ab 7.2.04 verwenden. Gemäß der Freigaben für SAP-Anwendungen gilt dies auch für SAP DB-Datenbanken in SAP-Installationen.

Für SAP-Kunden ändert sich durch diesen Kooperationsvertrag nichts. Open-Source-Benutzer können sich über die geänderten Lizenzbedingungen unter folgender Adresse informieren:

www.mysql.com/products/licensing/opensource-license.html

Siehe auch:

Informationen zur Software


Dokumentation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Dokumentation

Welche Dokumentation gibt es?

Eine Übersicht über die verfügbare Dokumentation zu MaxDB und zur SAP liveCache-Technologie finden Sie in den folgenden Abschnitten:

● Strukturlink MaxDB (nur für SAP-Kunden)

● Strukturlink SAP liveCache-Technologie (nur für SAP-Kunden)

● Strukturlink MaxDB-Bibliothek (für Open-Source-Benutzer)

Wo erhalte ich die Dokumentation?

Sie haben folgende Möglichkeiten:

● Sie können mit einem Web-Browser auf die Onlineversion der Dokumentation zugreifen.

● Sie können die gesamte Dokumentation im HTMLHelp-Format (eine .chm-Datei) für Microsoft Windows herunterladen.

Wenn Sie das Betriebssystem Microsoft Windows verwenden, dann empfehlen wir den Download im HTMLHelp-Format.

● Sie können die gesamte Dokumentation im HTML-Format (mehrere Plain-HTML-Dateien) herunterladen.

Weitere Informationen finden Sie im Abschnitt Download.

Wie benutze ich die Dokumentation?

Um schnell einen Begriff in der Dokumentation zu finden, verwenden Sie das alphabetisch sortierte Glossar.

Die MaxDB-Dokumentation ist in mehrere einzelne Dokumentationen unterteilt. Wenn auf einen Abschnitt in einer anderen Dokumentation verwiesen wird, dann ist der Titel der Dokumentation kursiv gesetzt.

siehe Database Manager GUI, Strukturlink Systemtabellen anzeigen

HTML-Format

Bereiche der Benutzungsoberfläche

Diese Grafik wird im zugehörigen Text erklärt

1 SAP-Benutzermenü (wird nur im SAP Help Portal angezeigt)

● Link zur Einstiegsseite des SAP Knowledge Warehouse

● Link zur Einstiegsseite der SAP-Bibliothek

● Einführung in das SAP System

● Hilfe zur Hilfe

● Navigation ausblenden/einblenden

● Kontext wechseln
(Anzeigen älterer Versionen („Kontexte“) und anderer Sprachen der Dokumentation)

● Suche

● Eigenschaften
(Eigenschaften des angezeigten Abschnitts)

2 Knowledge-Warehouse-Menü

● Synchronisieren
(markiert den angezeigten Abschnitt im Navigationsbaum; wenn sich der Abschnitt in einer anderen Dokumentation befindet als der zuletzt angezeigte Abschnitt, dann wird der entsprechende Navigationsbaum geöffnet)

● Zurück
(zeigt den im Navigationsbaum vorhergehenden Abschnitt an)

● Vorwärts
(zeigt den im Navigationsbaum folgenden Abschnitt an)

● Alle öffnen
(klappt alle Kapitel im Navigationsbaum auf)

● Alle schließen
(schließt alle Kapitel im Navigationsbaum)

3 Navigationsbaum

Im Navigationsbaum werden alle Kapitel und Abschnitte der ausgewählten Dokumentation angezeigt. Um die Kapitel aufzuklappen, wählen Sie das Dreieckssymbol.

4 Abschnitt

In diesem Bereich wird der im Navigationsbaum ausgewählte Abschnitt angezeigt. Um die URL des Abschnitts zu erhalten und ihn im Navigationsbaum zu lokalisieren, wählen Sie das Doppelpfeilsymbol neben dem Titel des Abschnitts.

Microsoft Windows HTMLHelp-Format

Die Dokumentation im HTMLHelp-Format ist analog zur Dokumentation im HTML-Format aufgebaut. Das HTMLHelp-Format bietet folgende Vorteile:

● kompiliertes und komprimiertes Format (eine einzelne .chm-Datei)

● benötigt weniger Speicherplatz als die Plain-HTML-Dateien

● Index

● Volltextsuche:

○ Verknüpfen von Suchbegriffen (AND, OR, NEAR, NOT)

○ Hervorheben der Suchbegriffe im gefundenen Abschnitt

○ Lokalisieren eines gefundenen Abschnitts im Navigationsbaum mit der Funktion Locate

○ iteratives Eingrenzen der Suche mit der Funktion Search Previous Results

● Speichern von Favoriten

● Drucken von einzelnen Kapiteln einschließlich aller dazugehörenden Kapitel und Abschnitte

Beispiele

In der Dokumentation werden Vorgehensweisen, Kommandos usw. mit Beispielen illustriert. Grundlage für diese Beispiele sind die Demo-Datenbank, die Variablen in der Dokumentation und die Syntaxnotation (siehe Glossar).

Siehe auch:

Informationen zur Software


Demo-Datenbank (SAP-Bibliothek - Grundwissen)

Objektdokumentation Demo-Datenbank

Definition

DEMODB ist eine für Demonstrationszwecke entwickelte Datenbankinstanz. Sie wird in der Dokumentation verwendet, um Vorgehensweisen, Kommandos usw. anhand von Beispielen zu erläutern.

Wenn Sie die Demo-Datenbankinstanz DEMODB verwenden wollen, um die Beispiele nachzuvollziehen, müssen Sie die Demo-Datenbankinstanz zunächst anlegen und die Demo-Daten in die Datenbankinstanz laden. Wir empfehlen Ihnen, dafür den Installation Manager zu verwenden.

Es ist auch möglich, nach dem Installieren der Software das Werkzeug Database Manager zu verwenden, um die Demo-Datenbankinstanz anzulegen und die Demo-Daten in die Datenbankinstanz zu laden.

Vorgehensweise

Sie können zum Anlegen der Demo-Datenbankinstanz DEMODB und Laden der vollständigen Demo-Daten den Installation Manager oder den Database Manager verwenden.

● Installationshandbuch, Strukturlink Demo-Datenbankinstanz DEMODB anlegen
Im Fenster Database configuration des Installation Manager markieren Sie Load Tutorial Data, um die vollständigen Demo-Daten zu laden.

● Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz: Desktop PC/Laptop
Markieren Sie Load Tutorial, um die vollständigen Demo-Daten zu laden.

● Tutorial Datenbankverwaltung, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz
Anschließend laden Sie die Demo-Daten in die neue Datenbankinstanz (Siehe: Strukturlink Demo-Daten in eine Datenbankinstanz laden).

Sie können die vollständigen Demo-Daten zu einem von Ihnen gewünschten Zeitpunkt in eine bereits vorhandene Datenbankinstanz laden, wenn Sie das Laden während des Anlegens der Datenbankinstanz nicht durchgeführt haben. Sie können zum Laden der vollständigen Demo-Daten den Database Manager verwenden.

● Database Manager GUI, Strukturlink Demo-Daten laden

● Database Manager CLI, Strukturlink load_tutorial

Um die Beispiele im SQL-Tutorial nachvollziehen zu können, ist ein vereinfachter Demo-Datensatz ausreichend. Laden Sie daher nicht die vollständigen Demo-Daten, sondern gehen Sie vor wie in SQL-Tutorial, Strukturlink Demo-Daten für das SQL-Tutorial beschrieben.

Die Demo-Datenbankinstanz wurde für Übungs- und Testzwecke entwickelt und enthält mehrere vordefinierte Demo-Benutzer mit Standardkennwörtern und Demo-Daten.

Verwenden Sie die Demo-Datenbankinstanz nicht in einem Produktivsystem.

Struktur

Vorschlagswerte für die Bezeichnungen der Datenbankinstanz, der Datenbankbenutzer u.a. sind die folgenden Bezeichnungen:

● Name der Datenbankinstanz: DEMODB

● Name/Kennwort des Datenbanksystemadministrators: DBADMIN/SECRET

● Name/Kennwort eines Datenbankbenutzers: MONA/RED

● Schema: HOTEL

● Datenbankobjekte: Objekte im Schema HOTEL bzw. SQL-Tutorial, Strukturlink Erläuterung der Tabellen im Demo-Schema HOTEL

Verwendung

Die Demo-Daten werden in folgenden Tutorials verwendet:

● Strukturlink Tutorial Datenbankverwaltung (vollständiger Demo-Datensatz)

● Strukturlink Loader-Tutorial (vollständiger Demo-Datensatz)

● Strukturlink SQL-Tutorial (vereinfachter Demo-Datensatz)


Objekte im Schema HOTEL (SAP-Bibliothek - Grundwissen)

Objektdokumentation Objekte im Schema HOTEL

Nach dem Laden der Demo-Daten in die Demo-Datenbank befinden sich die Tabellen CITY, CUSTOMER, HOTEL, ROOM, RESERVATION, EMPLOYEE und weitere Datenbankobjekte im Schema HOTEL. Eigentümer des Schemas HOTEL und seiner Objekte ist der Benutzer MONA. Die Tabellen sind mit Demo-Daten gefüllt.

Tabellen

CITY (Ortstabelle)

Jede Tabellenzeile enthält folgende Ortsinformationen: Postleitzahl, Name des Ortes, Abkürzung des Staatsnamens, in dem sich der Ort befindet.

CREATE TABLE city
(zip CHAR(5) PRIMARY KEY CONSTRAINT zip_cons CHECK
SUBSTR(zip,1,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,2,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,3,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,4,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,5,1) BETWEEN '0' AND '9',
name CHAR(30) NOT NULL,
state CHAR(2) NOT NULL)

Die Spalte zip ist die Primärschlüsselspalte.

Durch die Angabe des Constraints zip_cons wird gewährleistet, dass nur Zeichen zwischen 0 und 9 für die Angabe der Postleitzahl verwendet werden können.

In die Spalten Name des Ortes name und Abkürzung des Staatsnamens state dürfen keine NULL-Werte eingetragen werden.

CUSTOMER (Kundentabelle)

Jede Tabellenzeile enthält folgende Kundeninformationen: eine Nummer zur eindeutigen Identifizierung des Kunden, die Anrede zur Verwendung für Anschreiben, den Kundenvor- und Nachnamen, die Kundenadresse bestehend aus Postleitzahl, Straße und Hausnummer.

CREATE TABLE customer
(cno FIXED(4) PRIMARY KEY CONSTRAINT cno_cons CHECK cno > 0,
title CHAR(7) CONSTRAINT title_cons CHECK title IN ('Mr', 'Mrs', 'Company'),
firstname CHAR(20),
name CHAR(40) NOT NULL,
zip CHAR(5) CONSTRAINT zip_cons CHECK
SUBSTR(zip,1,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,2,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,3,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,4,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,5,1) BETWEEN '0' AND '9',
address CHAR(40) NOT NULL,
FOREIGN KEY customer_zip_in_city (zip) REFERENCES city ON DELETE RESTRICT)

Die Spalte cno ist die Primärschlüsselspalte.

Durch die Angabe des Constraint cno_cons wird gewährleistet, dass die Kundennummer größer als Null gewählt wird.

Durch die Angabe des Constraint title_cons wird gewährleistet, dass als Titel Mr, Mrs oder Company gewählt wird.

In die Spalten name und address dürfen keine NULL-Werte eingetragen werden.

Durch die Angabe des Constraint zip_cons wird gewährleistet, dass nur Zeichen zwischen 0 und 9 für die Angabe der Postleitzahlen verwendet werden können.

Die Spalte zip ist Fremdschlüsselspalte. Die Schlüsselwörter ON DELETE RESTRICT bewirken, dass Sie beim Löschen von Zeilen in der Ortstabelle CITY eine Warnung erhalten, wenn in der Tabelle CUSTOMER eine Zeile existiert, die mit der Postleitzahl der zu löschenden Zeile übereinstimmt.

HOTEL (Hoteltabelle)

Jede Tabellenzeile enthält folgende Hotelinformationen: eine Nummer zur eindeutigen Identifizierung des Hotels, den Hotelnamen und die Hoteladresse (Postleitzahl, Straße und Hausnummer) sowie Informationen zum Hotel.

CREATE TABLE hotel
(hno FIXED(4) PRIMARY KEY CONSTRAINT hno_cons CHECK hno > 0,
name CHAR(50) NOT NULL,
zip CHAR(5) CONSTRAINT zip_cons CHECK
SUBSTR(zip,1,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,2,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,3,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,4,1) BETWEEN '0' AND '9' AND
 SUBSTR(zip,5,1) BETWEEN '0' AND '9',
address CHAR(40) NOT NULL,
info LONG,
FOREIGN KEY hotel_zip_in_city (zip) REFERENCES city ON DELETE RESTRICT)

Die Spalte hno ist die Primärschlüsselspalte.

Durch die Angabe des Constraint hno_cons wird gewährleistet, dass die Hotelnummer größer als Null gewählt wird.

In die Spalten name und address dürfen keine NULL-Werte eingetragen werden.

Durch die Angabe des Constraint zip_cons wird gewährleistet, dass nur Zeichen zwischen 0 und 9 für die Angabe der Postleitzahlen verwendet werden können.

Die Spalte zip ist Fremdschlüsselspalte. Die Schlüsselwörter ON DELETE RESTRICT bewirken, dass Sie beim Löschen von Zeilen in der Ortstabelle CITY eine Warnung erhalten, wenn in der Tabelle HOTEL eine Zeile existiert, die mit der Postleitzahl der zu löschenden Zeile übereinstimmt. In diesem Fall wird die Zeile nicht gelöscht.

ROOM (Zimmertabelle)

Jede Tabellenzeile enthält folgende Zimmerinformationen: eine Nummer zur eindeutigen Identifizierung des Hotels, in dem sich das Zimmer befindet, eine Angabe zum Zimmertyp (Einzel, Doppel, Suite), die Anzahl der freien Zimmer und den Preis pro Zimmer.

CREATE TABLE room
(hno FIXED(4) CONSTRAINT hno_cons CHECK hno > 0,
type CHAR(6) CONSTRAINT type_cons CHECK type IN ('single','double','suite'), PRIMARY KEY (hno,type),
free FIXED(3,0) CONSTRAINT free_cons CHECK free >= 0,
price FIXED(6,2) CONSTRAINT price_cons CHECK price BETWEEN 0.00 AND 5000.00,
FOREIGN KEY room_hno_in_hotel (hno) REFERENCES hotel ON DELETE CASCADE)

Die Spalten hno und type bilden den Primärschlüssel.

Durch die Angabe des Constraint hno_cons wird gewährleistet, dass die Hotelnummer größer als Null gewählt wird.

Durch die Angabe des Constraint type_cons wird gewährleistet, dass als Zimmertyp single, double oder suite gewählt wird.

Durch die Angabe des Constraint free_cons wird gewährleistet, dass die Anzahl der freien Zimmer größer als Null gewählt wird.

Durch die Angabe des Constraint price_cons wird gewährleistet, dass der Zimmerpreis mit einem Wert zwischen 0 und 5000 gewählt wird.

Die Spalte hno ist Fremdschlüsselspalte. Die Schlüsselwörter ON DELETE CASCADE bewirken, dass beim Löschen von Zeilen in der Hoteltabelle HOTEL die Zeilen der Tabelle ROOM gelöscht werden, die eine mit der zu löschenden Zeile übereinstimmende Hotelnummer aufweisen.

RESERVATION (Buchungstabelle)

Jede Tabellenzeile enthält folgende Buchungsinformationen: eine Nummer zur eindeutigen Identifizierung der Buchung, eine Nummer zur eindeutigen Identifizierung des Kunden, eine Nummer zur eindeutigen Identifizierung des Hotels, eine Angabe zum Zimmertyp (Einzel, Doppel, Suite), das Datum der Ankunft und der Abreise.

CREATE TABLE reservation
(rno FIXED(4) PRIMARY KEY CONSTRAINT rno_cons CHECK rno > 0,
cno FIXED(4) CONSTRAINT cno_cons CHECK cno > 0,
hno FIXED(4) CONSTRAINT hno_cons CHECK hno > 0,
type CHAR(6) CONSTRAINT type_cons CHECK type IN ('single','double','suite'),
arrival DATE NOT NULL,
departure DATE NOT NULL, CONSTRAINT staying CHECK departure > arrival,
FOREIGN KEY reservation_cno_in_customer (cno) REFERENCES customer ON DELETE CASCADE
FOREIGN KEY reservation_info_in_room (hno,type) REFERENCES room ON DELETE CASCADE)

Die Spalte rno ist die Primärschlüsselspalte.

Durch die Angabe des Constraint rno_cons wird gewährleistet, dass die Buchungsnummer größer als Null gewählt wird.

Durch die Angabe des Constraint cno_cons wird gewährleistet, dass die Kundennummer größer als Null gewählt wird.

Durch die Angabe des Constraint hno_cons wird gewährleistet, dass die Hotelnummer größer als Null gewählt wird.

Durch die Angabe des Constraint type_cons wird gewährleistet, dass als Zimmertyp single, double oder suite gewählt wird.

In die Spalten arrival und departure dürfen keine NULL-Werte eingetragen werden.

Durch die Angabe des Constraint staying wird gewährleistet, dass als Abfahrtsdatum ein Datum nach dem Ankunftsdatum gewählt wird.

Die Spalte cno ist Fremdschlüsselspalte. Die Schlüsselwörter ON DELETE CASCADE bewirken, dass beim Löschen von Zeilen in der Kundentabelle CUSTOMER die Zeilen der Tabelle RESERVATION gelöscht werden, die eine mit der zu löschenden Zeile übereinstimmende Kundennummer aufweisen.

Die Spalten hno und type bilden einen Fremdschlüssel. Die Schlüsselwörter ON DELETE CASCADE bewirken, dass beim Löschen von Zeilen in der Zimmertabelle ROOM die Zeilen der Tabelle RESERVATION gelöscht werden, die mit der zu löschenden Zeile in Hotelnummer und Zimmertyp übereinstimmen.

EMPLOYEE (Angestelltentabelle)

Jede Tabellenzeile enthält folgende Angestellteninformationen: eine Nummer zur eindeutigen Identifizierung des Hotels, eine Nummer zur eindeutigen Identifizierung des Angestellten, die Anrede zur Verwendung für Anschreiben, den Angestelltenvor- und Nachnamen, eine Nummer zur Zuordnung des Vorgesetzten.

CREATE TABLE employee
(hno FIXED(4),
eno FIXED(4), PRIMARY KEY (hno,eno),
title CHAR(7) CONSTRAINT title_cons CHECK title IN ('Mr','Mrs'),
firstname CHAR(20),
name CHAR(20) NOT NULL,
manager_eno FIXED(4),
FOREIGN KEY employee_hno_in_hotel (hno) REFERENCES hotel ON DELETE CASCADE)

Die Spalten hno und eno bilden den Primärschlüssel.

Durch die Angabe des Constraint title_cons wird gewährleistet, dass als Titel Mr oder Mrs gewählt wird.

In die Spalten name dürfen keine NULL-Werte eingetragen werden.

Die Spalte hno ist Fremdschlüsselspalte. Die Schlüsselwörter ON DELETE CASCADE bewirken, dass beim Löschen von Zeilen in der Hoteltabelle HOTEL die Zeilen der Tabelle EMPLOYEE gelöscht werden, die eine mit der zu löschenden Zeile übereinstimmende Hotelnummer aufweisen.

View-Tabellen

CUSTOMER_ADDR (Kundenadressen)

Jede Zeile der View-Tabelle enthält folgende Kundeninformationen: eine Nummer zur eindeutigen Identifizierung des Kunden, die Anrede zur Verwendung für Anschreiben, den Kundennachnamen, die Kundenadresse bestehend aus Postleitzahl, Name des Ortes, Abkürzung des Staatsnamens, Straße und Hausnummer.

CREATE VIEW customer_addr (cno, title, name, zip, city, state, address)
AS SELECT customer.cno, customer.title, customer.name, customer.zip,
city.name, city.state, customer.address
FROM customer, city
WHERE customer.zip = city.zip WITH CHECK OPTION

Die erforderlichen Informationen werden den Tabellen customer und city entnommen.

Die Schlüsselwörter WITH CHECK OPTION bewirken, dass durch eine INSERT- oder UPDATE-Anweisung in der View-Tabelle keine Zeilen erzeugt werden können, die anschließend nicht mehr über die View-Tabelle selektierbar sind, d.h. resultierende Zeilen müssen die Suchbedingung der View-Tabelle erfüllen.

HOTEL_ADDR (Hoteladressen)

Jede Zeile der View-Tabelle enthält folgende Hotelinformationen: eine Nummer zur eindeutigen Identifizierung des Hotels, den Hotelnamen, die Hoteladresse bestehend aus Postleitzahl, Name des Ortes, Abkürzung des Staatsnamens, Straße und Hausnummer.

CREATE VIEW hotel_addr (hno, name, zip, city, state, address)
AS SELECT hotel.hno, hotel.name, hotel.zip,
city.name, city.state, hotel.address
FROM hotel, city
WHERE hotel.zip = city.zip WITH CHECK OPTION

Die erforderlichen Informationen werden den Tabellen hotel und city entnommen.

Die Schlüsselwörter WITH CHECK OPTION bewirken, dass durch eine INSERT- oder UPDATE-Anweisung in der View-Tabelle keine Zeilen erzeugt werden können, die anschließend nicht mehr über die View-Tabelle selektierbar sind, d.h. resultierende Zeilen müssen die Suchbedingung der View-Tabelle erfüllen.

CUSTOM_HOTEL (Hotelreservierungen)

Jede Zeile der View-Tabelle enthält folgende Informationen: den Kundennachnamen, Wohnort des Kunden, Name des Hotels, Ort des Hotels.

CREATE VIEW custom_hotel (customname, customcity, hotelname, hotelsity)
AS SELECT customer_addr.name, customer_addr.city,
hotel_addr.name, hotel_addr.city
FROM customer_addr, hotel_addr, reservation
WHERE customer_addr.cno = reservation.cno
AND hotel_addr.hno = reservation.hno

Die erforderlichen Informationen werden den View-Tabellen customer_addr und hotel_addr der Tabelle reservation entnommen.

Es werden die Kunden angezeigt, die in den Hotels gebucht haben.

Indizes

Einspaltiger Index

CREATE INDEX city_state ON city (state)

Auf die Spalte state der Tabelle city wird der Sekundärindex city_state gelegt.

Mehrspaltiger Index

CREATE INDEX full_name_index ON customer (name, firstname)

Auf die Spalten name und firstname der Tabelle customer wird der Sekundärindex full_name_index gelegt.


Download (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Download

SAP-Kunden erhalten die Datenbanksoftware über den SAP Service Marketplace, Open-Source-Benutzer können die Software über die MaxDB-Website herunterladen.

Zielgruppe SAP-Kunden

Produkt | Download/Bezugsquelle | online
Datenbanksoftware MaxDB/SAP liveCache-Technologie | SAP-Installations-CD | SAP Service Marketplace service.sap.com
Release Notes | - | siehe SAP-Hinweis 806690
Installations- und Upgrade-Leitfäden MaxDB | - | siehe SAP-Hinweis 767598 oder service.sap.com/installNW2004s ® Installation ® Installation - SAP NetWeaver 2004s ® MaxDB ® <os> service.sap.com/upgradeNW2004s ® Upgrade ® Upgrade - SAP NetWeaver 2004s ® MaxDB ® <os>
Installations- und Upgrade-Leitfäden SAP liveCache-Technologie | - | siehe SAP-Hinweis 767598 oder service.sap.com/installNW2004s ® Installation ® Installation Guide – SAP NetWeaver 2004s liveCache Technology service.sap.com/upgradeNW2004s ® Upgrade ® Upgrade Guide – SAP NetWeaver 2004s liveCache Technology
Sicherheitsleitfaden | - | Sicherheitsleitfaden Siehe auch SAP-Hinweis 767598 oder service.sap.com/securityguide ® SAP Security for MaxDB
Dokumentation zu MaxDB | SAP-Installations-CD | siehe SAP-Hinweis 767598 oder SAP Help Portal help.sap.com/NW2004sdoc ® SAP NetWeaver by Key Capability ® Databases ® MaxDB
High-Availability-Dokumentation zu MaxDB |  | SAP Help Portal help.sap.com/NW2004sdoc ® High Availability ® High Availability for the MaxDB Database
Dokumentation zur SAP liveCache-Technologie | SAP-Installations-CD | siehe SAP-Hinweis 767598 oder SAP Help Portal help.sap.com/NW2004sdoc ® SAP NetWeaver by Key Capability ® Databases ® SAP liveCache

Zielgruppe Open-Source-Benutzer

Produkt | Download | online
Datenbanksoftware MaxDB | dev.mysql.com/downloads/maxdb | -
Release Notes | - | dev.mysql.com/doc/maxdb/changes/
Installations-Dokumentation | in der Dokumentation enthalten | Strukturlink Installationshandbuch
Security Guide | in der Dokumentation enthalten | Sicherheitsleitfaden
Dokumentation | dev.mysql.com/downloads/maxdb | dev.mysql.com/doc/maxdb/index.html
Lizenzbedingungen |  | www.mysql.com/products/licensing/opensource-license.html

Siehe auch:

Informationen zur Software


Versionsnotierung (SAP-Bibliothek - Grundwissen)

Objektdokumentation Versionsnotierung

Definition

Die Versionsangaben für die Datenbanksoftware erfolgen gemäß der folgenden Versionsnotierung:

<major>.<minor>.<cl>.<build>

MaxDB 7.5.00.15

Bestandteile der Versionsnotierung

Name | Anzahl Stellen | Beschreibung
major | 1 | Versionsnummer
minor | 1 | Versionsnummer
cl | 2 | Nummer des Correction Level
build | 2 | Build-Nummer

Im technischen Bereich wird häufig auch die folgende Schreibweise mit dreistelliger Build-Nummer verwendet:

<major>.<minor>.<cl> Build <build>

MaxDB 7.5.00 Build 015

Siehe auch:

Informationen zur Software


Unterstützte Betriebssysteme und Architekturen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Unterstützte Betriebssysteme und Architekturen

SAP-Kunden finden Informationen zu den unterstützten Betriebssystemen und Architekturen (MaxDB und SAP liveCache-Technologie) in der Product Availability Matrix (PAM) unter service.sap.com/pam ® SAP NetWeaver.

Die folgenden Angaben gelten für Open-Source-Benutzer von MaxDB.

MaxDB 7.6: Unterstützte Betriebssysteme und Architekturen

Betriebssystemhersteller | Betriebssystemversionen | Architekturen
IBM | AIX 5.2 AIX 5.3 | 64bit 64bit
HP | HP-UX 11.11 HP-UX 11.23 | PA-RISC 64bit PA-RISC 64bit IA64 64bit
Red Hat | Red Hat EL 4 | IA32 32bit x86_64 64bit
Sun | Solaris 9 Solaris 10 | SPARC 64bit SPARC 64bit x64 64bit
Novell | SUSE SLES9 | IA32 32bit IA64 64bit x86_64 64bit Power 64bit
Microsoft | Windows 2000 Professional Windows XP Professional Windows Server 2003 | IA32 32bit IA32 32bit IA32 32bit IA64 64bit x64 64bit

Siehe auch:

Informationen zur Software


Open-Source-Entwicklung der Datenbanksoftware (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Open-Source-Entwicklung der Datenbanksoftware

Einsatzmöglichkeiten

Open-Source-Benutzer können den Quelltext der MaxDB-Datenbanksoftware ändern und übersetzen.

Beachten Sie die Lizenzbedingungen unter www.mysql.com/company/legal/licensing

Ablauf

...

1. Sie installieren die MaxDB-Entwicklungsumgebung.

Siehe Entwicklungsumgebung, Strukturlink Installieren der Entwicklungsumgebung.

2. Sie laden den Quelltext der MaxDB-Datenbanksoftware von der MaxDB-Website herunter.

Siehe Download.

3. Sie installieren den Quelltext.

Siehe Entwicklungsumgebung, Strukturlink Installieren des Quelltexts.

4. Sie initialisieren die Entwicklungsumgebung, ändern den Quelltext und übersetzen ihn mit dem Werkzeug VMAKE neu.

Ausführliche Informationen finden Sie in der Dokumentation Strukturlink Entwicklungsumgebung.

Siehe auch:

Problemmeldungen mit Web PTS verfolgen

Informationen zur Software

Entwicklung von Datenbankanwendungen


Support (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Support

Sie können auf folgenden Wegen Support für Ihr Datenbanksystem erhalten.

Supportangebote

Name | Beschreibung
Mailing-Liste | lists.mysql.com/maxdb Der Online-Support über die Mailing-Liste basiert auf der gegenseitigen Hilfestellung unter MaxDB-Benutzern und ist kostenlos. In einer E-Mail an diese Mailing-Liste beschreiben Sie Ihre Fragen und Probleme. Sowohl das Datenbankentwicklungsteam als auch Mitglieder der Open-Source-Community können Ihnen darauf antworten. Der Online-Support garantiert Ihnen keine festen Antwortzeiten. Das Entwicklungsteam beobachtet jedoch ständig die Korrespondenz in der Mailing-Liste und trägt dafür Sorge, dass auf jede Problemmeldung eine Reaktion erfolgt.
Support-Vertrag mit SAP | Wenn Sie das Datenbanksystem in einer SAP-Anwendung einsetzen, dann erhalten Sie über den Support-Vertrag mit SAP Zugriff auf die gesamte Support-Infrastruktur der SAP AG. Weitere Informationen finden Sie im SAP-Hinweis 826037.
Support-Vertrag mit MySQL | Wenn Sie das Datenbanksystem in anderen Anwendungen (nicht SAP-Anwendungen) einsetzen, dann können Sie einen Support-Vertrag mit MySQL abschließen.

Wenn Sie das Datenbanksystem sowohl in SAP-Anwendungen als auch in anderen Anwendungen einsetzen, dann erhalten Sie Support für die SAP-Anwendungen von der SAP AG und Support für die anderen Anwendungen von MySQL AB.

Siehe auch:

Problemmeldungen mit Web PTS verfolgen

Informationen zur Software


Problemmeldungen mit Web PTS verfolgen (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Problemmeldungen mit Web PTS verfolgen

Verwendung

Um sich über bekannte Probleme mit der MaxDB/SAP DB-Software zu informieren oder die Bearbeitung der von Ihnen gemeldeten Probleme zu verfolgen, verwenden Sie das Web-basierte Problem Tracking System (Web PTS).

Das Web PTS finden Sie unter folgender Adresse:

www.sapdb.org/webpts

Siehe auch:

Dokumentation zum Strukturlink Web Based Problem Tracking System

Informationen zur Software


Das Datenbanksystem im Überblick (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Das Datenbanksystem im Überblick

MaxDB ist das SAP-eigene relationale Datenbanksystem, das Sie in SAP-Lösungen als kostengünstige Alternative zu den Datenbanken anderer Anbieter einsetzen können.

Eine Datenbankinstanz umfasst eine Datenbank und die für den Betrieb der Datenbank notwendigen zusätzlichen Informationen. Eine Datenbank ist eine Menge von Daten mit einer regelmäßigen Struktur. Die Daten einer Datenbank setzen sich aus den Anwendungsdaten (Datensätze) und dem Datenbankkatalog (Metadaten) zusammen.

Jede Datenbankinstanz hat einen eindeutigen Namen. Eine Datenbankinstanz kann sich in verschiedenen Betriebszuständen befinden, wie z. B. ONLINE, ADMIN, OFFLINE. Im Betriebszustand ONLINE können Benutzer mit den Daten der Datenbankinstanz arbeiten, im Betriebszustand ADMIN können Datenbankadministratoren Verwaltungsaufgaben durchführen.

Um als Benutzer Daten in der Datenbank abzufragen oder zu ändern, verwenden Sie die Structured Query Language (SQL). Mit SQL können Sie die logischen Einheiten (Datenbankobjekte) der Datenbank wie z. B. Tabellen anzeigen, ändern und löschen. Zur logischen Gruppierung der Datenbankobjekte können Sie Schemas verwenden. Siehe SQL.

Das Datenbanksystem verwendet Transaktionen. Siehe Transaktionen.

Physikalisch umfasst eine Datenbankinstanz die Data- und Log-Volumes (permanenter Speicher), mehrere Caches, die Dateien im Arbeitsverzeichnis und eine Sammlung von Metadaten (u. a. Konfigurationsdateien, Datenbankparameter, Pfade der Volumes). Als logische Zugriffsstrukturen verwendet das Datenbanksystem Seitenketten und B*-Bäume. Siehe Datenspeicherung.

Siehe auch:

Informationen zur Software

Datenbankwerkzeuge

Technische Systemlandschaft

Anlegen und Konfigurieren einer Datenbankinstanz

Verwaltung


SQL (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation SQL

Verwendung

Mit der Structured Query Language (SQL) können Sie Daten in der Datenbank definieren, anzeigen, einfügen, ändern und löschen. Das Datenbanksystem führt SQL-Anweisungen innerhalb von Transaktionen aus.

Die SQL-Anweisungen sind in folgende Gruppen unterteilt:

● Datendefinition

● Autorisierung

● Datenmanipulation

● Datenanfrage

● Transaktionen

● Statistiken

Eine Einführung in die MaxDB-SQL-Syntax finden Sie im Strukturlink SQL-Tutorial, eine vollständige Beschreibung im SQL-Referenzhandbuch.

Aktivitäten

● Um eine Datenbankanwendung zu programmieren, können Sie SQL-Anweisungen in eine Programmiersprache Ihrer Wahl einbetten und über eine Schnittstelle an die Datenbankinstanz senden.

Benutzer der Datenbankanwendung geben SQL-Anweisungen dann nur noch implizit ein.

● Sie können SQL-Anweisungen explizit unter anderem mit den folgenden Datenbankwerkzeugen eingeben:

○ Strukturlink SQL Studio (GUI, nur für Microsoft Windows)

○ Strukturlink SQLCLI (Kommandozeile, für alle unterstützten Betriebssysteme)

○ Strukturlink Web SQL (Web-basiert, für alle unterstützten Betriebssysteme)

Funktionsumfang

Sie können unter anderem die folgenden Datentypen verwenden: BOOLEAN, CHAR[ACTER] (ASCII, BYTE, UNICODE), DATE, FIXED, FLOAT, INT[EGER], LONG (ASCII, BYTE,UNICODE) zur Speicherung von BLOBs und CLOBs, SMALLINT, TIME, TIMESTAMP, VARCHAR (ASCII, BYTE, UNICODE). Siehe SQL-Referenzhandbuch, Datentyp (data_type).

Sie können den SQL-Modus auswählen, in dem Sie mit dem Datenbanksystem arbeiten. Informationen zu den Unterschieden zwischen den SQL-Modi INTERNAL und ORACLE finden Sie in der Dokumentation SQL-Modus ORACLE.

Wichtige SQL-Eigenschaften von MaxDB

Eigenschaft | Weitere Informationen
Schema | SQL-Referenzhandbuch, CREATE SCHEMA-Anweisung (create_schema_statement)
Fremdschlüssel (referentielle Integrität) | SQL-Tutorial, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen SQL-Referenzhandbuch, Referentielle CONSTRAINT-Definition (referential_constraint_defi
explizite und implizite Sperren auf Zeilen, Tabellen und dem Datenbankkatalog | SQL-Referenzhandbuch, Transaktionen LOCK-Anweisung (lock_statement) LOCK-Option (lock_option)
aktualisierbare View-Tabelle | SQL-Tutorial, Strukturlink View-Tabellen SQL-Referenzhandbuch, CREATE VIEW-Anweisung (create_view_statement)
temporäre Tabelle | SQL-Referenzhandbuch, CREATE TABLE-Anweisung (create_table_statement)
Wertebereichsdefinition (Domain) | SQL-Tutorial, Strukturlink Wertebereiche SQL-Referenzhandbuch, CREATE DOMAIN-Anweisung (create_domain_statement)
Outer Join | SQL-Tutorial, Strukturlink Joins: Informationen aus mehreren Tabellen SQL-Referenzhandbuch, JOIN-Prädikat (join_predicate)
Sub-Query | SQL-Tutorial, Strukturlink Subquery: Innere Abfragen SQL-Referenzhandbuch, Subquery (subquery)
Subtransaktion | SQL-Referenzhandbuch, SUBTRANS-Anweisung (subtrans_statement)
Nummerngenerator (Autoinkrement-Spalte) | SQL-Tutorial, Strukturlink Nummerngeneratoren für Tabellen SQL-Referenzhandbuch, CREATE SEQUENCE-Anweisung (create_sequence_statement)
Datenbankprozedur (Stored Procedure) | SQL-Tutorial, Strukturlink Datenbankprozeduren SQL-Referenzhandbuch, CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement)
Datenbankfunktion (benutzerdefinierte Funktion) | SQL-Tutorial, Strukturlink Datenbankfunktionen SQL-Referenzhandbuch, CREATE FUNCTION-Anweisung (create_function_statement)
Trigger | SQL-Tutorial, Strukturlink Datenbanktrigger SQL-Referenzhandbuch, CREATE TRIGGER-Anweisung (create_trigger_statement) CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement
serverseitiger Cursor | SQL-Referenzhandbuch, DECLARE CURSOR-Anweisung (declare_cursor_statement)
Shared SQL (Wiederverwendung von Ausführungsplänen) | spezieller Datenbankparameter SHAREDSQL
Optimierung | SQL-Optimierer

Eine Übersicht aller SQL-Anweisungen finden Sie im SQL-Referenzhandbuch unter SQL-Anweisungen: Überblick.

Informationen zu Einschränkungen finden Sie im SQL-Referenzhandbuch unter Restriktionen für SQL-Anweisungen.

Siehe auch:

Transaktionen

Sperren für Datenbankobjekte

Entwicklung von Datenbankanwendungen

Das Datenbanksystem im Überblick


Transaktionen (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Transaktionen

Verwendung

Eine Transaktion ist eine Folge von SQL-Anweisungen, die das Datenbanksystem als Einheit behandelt. Eine Transaktion bringt die Datenbank von einem konsistenten Zustand in einen anderen konsistenten Zustand. Wenn es innerhalb der Transaktion zu einem Abbruch kommt, dann bringt das Datenbanksystem die Datenbank wieder in den Zustand, in dem sie bei Beginn der Transaktion war (ROLLBACK).

Dieser Abschnitt behandelt Datenbanktransaktionen. In SAP-Systemen hat der Begriff Transaktion eine andere Bedeutung.

Übergang der Datenbank von einem konsistenten Zustand über Zwischenzustände in einen anderen konsistenten Zustand

Diese Grafik wird im zugehörigen Text erklärt

Die Transaktionsverwaltung des Datenbanksystems sorgt unter anderem dafür, dass parallele Transaktionen aus mehreren Datenbanksitzungen korrekt abgearbeitet werden und die gleichen Ergebnisse liefern wie eine sequentielle Verarbeitung dieser Transaktionen.

Wenn Sie sich an die Datenbankinstanz anmelden, eröffnet das Datenbanksystem die erste Transaktion.

Abgeschlossen wird eine Transaktion durch ein COMMIT oder ROLLBACK:

● Wenn die Transaktion durch ein COMMIT erfolgreich beendet wird, dann sind alle Datenänderungen dauerhaft.

● Wenn die Transaktion durch ein ROLLBACK beendet oder anderweitig abgebrochen wird, dann macht das Datenbanksystem alle innerhalb der Transaktion durchgeführten Datenänderungen rückgängig.

Sowohl ein COMMIT als auch ein ROLLBACK eröffnen implizit eine neue Transaktion.

Weil das Datenbanksystem konkurrierende Transaktionen auf den gleichen Datenbankobjekten zulässt, sind zur Isolation einzelner Transaktionen Sperren nötig.

Transaktionen für OMS-Daten (nur in SAP liveCache-Datenbankinstanzen)

Transaktionen für OMS-Daten führt das Datenbanksystem unter Verwendung einer konsistenten Sicht aus. Für jede Transaktion kopiert das Datenbanksystem beim Lesen die Objekte in den OMS-Heap. Beim Beenden der Transaktion mit einem COMMIT kopiert das Datenbanksystem Änderungen an den Objekten aus dem OMS-Heap in den Data-Cache und entfernt dann alle Objekte der Transaktion aus dem OMS-Heap.

Aktivitäten

● Sie können Transaktionen unter anderem explizit eröffnen, abbrechen und beenden. Siehe

○ SQL-Referenzhandbuch, Transaktionen

○ Datenbankvewaltung im CCMS: MaxDB, Strukturlink Transaktionen

○ Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Transaktionen

● Das Datenbanksystem protokolliert alle Transaktionen, die Daten ändern, in Log-Einträgen. Siehe Protokollierung von Datenänderungen (Logging).

Siehe auch:

SQL

Sperren für Datenbankobjekte

Das Datenbanksystem im Überblick


Protokollierung von Datenänderungen (Logging) (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Protokollierung von Datenänderungen (Logging)

Verwendung

Das Datenbanksystem protokolliert alle Transaktionen, die Anwendungsdaten oder den Datenbankkatalog ändern, in Log-Einträgen. Das Datenbanksystem verwendet diese Log-Einträge, um SQL-Anweisungen gegebenenfalls rückgängig machen oder wiederholen zu können.

Es gab einen Stromausfall. Die Datenänderungen, die die letzten Transaktionen durchgeführt haben, hatte das Datenbanksystem nur im Data-Cache abgelegt und noch nicht mit einem Savepoint in den Datenbereich geschrieben. Durch den Stromausfall sind diese Datenänderungen im Data-Cache (Arbeitsspeicher) verloren gegangen und müssen deswegen vom Datenbanksystem wiederholt werden.

Arten von Log-Einträgen

Name | Verwendung
Undo-Log-Einträge (Before-Images) | - ermöglichen das Rückgängigmachen noch nicht abgeschlossener Transaktionen - ermöglichen konsistente Sichten (nur für SAP liveCache-Datenbankinstanzen)
Redo-Log-Einträge (After-Images) | - ermöglichen das Wiederholen bereits abgeschlossener Transaktionen

Um das Logging zu konfigurieren, verwenden Sie die Log-Einstellungen und Datenbankparameter.

Ablauf

...

1. Zu Beginn einer Transaktion, die Daten ändern wird, schreibt das Datenbanksystem Undo-Log-Einträge (Before-Images) für alle Datenbankobjekte, die von der Transaktion geändert werden sollen, in eine Undo-Log-Datei im Datenbereich.

Jeder Undo-Log-Eintrag in der Undo-Log-Datei erhält eine Undo-Sequenznummer, beginnend mit 0.

2. Während der Transaktion schreibt das System kontinuierlich Redo-Log-Einträge in eine Log-Warteschlange im Arbeitsspeicher.

Eine Transaktion schreibt immer in dieselbe Log-Warteschlange.

3. Wenn die Log-Warteschlange voll ist, schreibt der Log-Writer die Redo-Log-Einträge in den Log-Bereich.

Beim Schreiben der Redo-Log-Einträge in den Log-Bereich gibt das Datenbanksystem jeder Seite eine Sequenznummer und einen Zeitstempel. Anhand der Sequenznummern kann das Datenbanksystem später die eindeutige Reihenfolge der Seiten im Log-Bereich ermitteln. Den Zeitstempel benötigt das Datenbanksystem, um die Datenbankinstanz in den Zustand zu einem bestimmten Zeitpunkt wiederherstellen zu können.

Die Zeitintervalle zwischen den einzelnen Schreibvorgängen aus den Log-Warteschlangen in den Log-Bereich sind sehr viel kleiner als die Zeitintervalle zwischen Savepoints.

Wenn der Log-Bereich voll ist, dann sperrt das Datenbanksystem alle Log-Warteschlangen und hält alle Transaktionen an. Datenbankbenutzer können keine Datenänderungen in der Datenbank mehr durchführen. Sie müssen Redo-Log-Einträge aus dem Log-Bereich auf Datenträger sichern, damit das Datenbanksystem alte Redo-Log-Einträge im Log-Bereich wieder überschreiben kann (Ausnahmen: Überschreibmodus des Log-Bereichs ist eingeschaltet; automatische Log-Sicherung ist eingeschaltet).

4. Am Ende der Transaktion sind folgende Situationen möglich:

○ Die Transaktion wird mit COMMIT abgeschlossen.

Das Datenbanksystem schreibt die restlichen Redo-Log-Einträge (After-Images) aus der Log-Warteschlange in den Log-Bereich. Log-Seiten in der Log-Warteschlange, die noch nicht voll waren, verbleiben nach dem Schreiben in der Log-Warteschlange, werden weiter gefüllt und bei einem erneuten Schreibvorgang wieder in den Log-Bereich geschrieben.

Wenn die Undo-Log-Datei Aktionen für die Garbage-Collectors enthält oder wenn die Undo-Log-Datei größer als eine Seite ist, dann weist das Datenbanksystem sie der History-Verwaltung zu. Zu einem späteren Zeitpunkt löscht ein Garbage-Collector die Undo-Log-Datei aus dem Datenbereich, siehe History-Verwaltung. Ansonsten löscht die Transaktion die Undo-Log-Datei.

○ Die Transaktion wird mit ROLLBACK abgebrochen.

Das Datenbanksystem verwendet die Undo-Log-Einträge, um alle Datenänderungen rückgängig zu machen.

Bereits in den Log-Bereich und in die Log-Warteschlange geschriebene Redo-Log-Einträge verbleiben dort und werden vom Datenbanksystem ignoriert.

Protokollierung der Datenänderungen einer Transaktion, die mit COMMIT abgeschlossen wird

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Transaktionen

Log-Einträge sichern

Beispiel: Restart

Beispiel: Konsistente Sicht


History-Verwaltung (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation History-Verwaltung

Verwendung

Das Datenbanksystem bewahrt Undo-Log-Dateien zunächst auf. Diese Funktion wird als History-Verwaltung bezeichnet.

In regelmäßigen Abständen prüfen die Garbage-Collectors die Undo-Log-Einträge in den Undo-Log-Dateien und löschen nicht mehr benötigte Undo-Log-Dateien. Hierdurch werden die User-Tasks vom Löschen der Undo-Log-Einträge entlastet, und das Datenbanksystem kann COMMITs schneller durchführen.

SAP liveCache-Datenbankinstanzen verwenden die History-Verwaltung außerdem für konsistente Sichten. Für OLTP (MaxDB)-Datenbankinstanzen können Sie die Transaktionskonsistenz mit dem Isolation-Level konfigurieren (siehe Isolation-Level).

Beispiel

Beispiel: Konsistente Sicht

Protokollierung von Datenänderungen (Logging)


Beispiel: Restart (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Restart

Es gab einen Stromausfall, und Sie müssen die Datenbankinstanz neu starten (Restart). Während des Restarts stellt das Datenbanksystem die Datenbankinstanz beginnend ab dem Zeitpunkt des letzten Savepoint wieder her.

Die folgende Abbildung zeigt, wie das Datenbanksystem die Transaktionen bei einem Restart behandelt.

Zustand der Transaktionen zum Zeitpunkt des Systemausfalls

Diese Grafik wird im zugehörigen Text erklärt

Behandlung der Transaktionen beim Restart

Transaktion | Aktionen des Datenbanksystems
T1 | keine Die Änderungen der Transaktion T1 wurden vollständig durch den letzten Savepoint vor dem Systemausfall in den Datenbereich geschrieben.
T2, T3 | Das Datenbanksystem macht die vor dem Savepoint erfolgten Änderungen rückgängig. Hierfür wertet es die entsprechenden Undo-Log-Dateien aus.
T5 | keine Die Änderungen von T5 hat das Datenbanksystem bereits vor dem Systemausfall rückgängig gemacht (ROLLBACK). Diese Änderungen wurden nie durch einen Savepoint in den Datenbereich geschrieben.
T4, T6 | Das Datenbanksystem liest die erforderlichen Redo-Log-Einträge für diese Transaktionen ein und wiederholt die Transaktionen (ROLL FORWARD).

Siehe auch:

Protokollierung von Datenänderungen (Logging)

Savepoint

Transaktionen


Beispiel: Konsistente Sicht (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Konsistente Sicht

Konsistente Sichten gibt es nur für SAP liveCache-Datenbankinstanzen. Die Transaktionskonsistenz in OLTP (MaxDB)-Datenbankinstanzen konfigurieren Sie mit dem Isolation-Level.

liveCache-Datenbankinstanzen verwenden Undo-Log-Einträge, um für Transaktionen konsistente Sichten auf die Daten zu ermöglichen. Das folgende Beispiel zeigt, wie zwei Transaktionen gleichzeitig eine konsistente Sicht auf denselben Datensatz haben können.

...

1. Transaktion T1 greift in der Tabelle CUSTOMER zum ersten Mal auf den Datensatz 3600 zu und liest als Namen den Wert Smiht. Transaktion T1 sperrt den Datensatz jedoch nicht.

2. Transaktion T2 korrigiert im Datensatz 3600 den Namen von Smiht auf Smith. Transaktion T2 wird mit einem COMMIT beendet.

3. Transaktion T1 greift erneut auf den Datensatz 3600 zu und prüft zunächst in der History-Datei, ob seit dem ersten Lesen eine andere Transaktion den Datensatz 3600 geändert hat.

Weil der Datensatz inzwischen von Transaktion T2 geändert wurde, verwendet Transaktion T1 die Undo-Log-Einträge der Transaktion T2, um für das zweite Lesen dasselbe Ergebnis wie für das erste Lesen zu erhalten. Ohne Undo-Log-Einträge würde Transaktion T1 für das erste und zweite Lesen von Datensatz 3600 unterschiedliche Ergebnisse erhalten.

Diese Grafik wird im zugehörigen Text erklärt

4. Erst wenn Transaktion T1 mit einem COMMIT beendet wird, löschen die Garbage-Collectors die Undo-Log-Einträge von Transaktion T2.

Siehe auch:

History-Verwaltung

Protokollierung von Datenänderungen (Logging)


Sperren für Datenbankobjekte (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Sperren für Datenbankobjekte

Verwendung

Mehrere Transaktionen können gleichzeitig auf das gleiche Datenbankobjekt, z. B. eine Tabelle, zugreifen. Um die Transaktionen voneinander zu isolieren, setzt das Datenbanksystem Sperren für Datenbankobjekte.

Arten von Sperren

Name | Objekte, die gesperrt werden können
Lesesperre (SHARE LOCK) | Tabellen, Zeilen, Datenbankkatalog
Schreibsperre (EXCLUSIVE LOCK) | Tabellen, Zeilen, Datenbankkatalog
optimistische Sperre | Zeilen

Aktivitäten

Sperren anfordern

Sperren können folgendermaßen angefordert werden:

● Sperren für Zeilen oder Tabellen können implizit vom Datenbanksystem angefordert/freigeben oder explizit von einem Benutzer angefordert/freigegeben werden (siehe SQL-Referenzhandbuch, LOCK-Anweisung und LOCK-Option (lock_option)).

● Sperren auf dem Datenbankkatalog werden immer implizit vom Datenbanksystem angefordert und freigeben.

Mit dem Isolation-Level legen Sie fest, wann das Datenbanksystem welche Art von Sperre setzt. Damit bestimmen Sie den Grad der Parallelität von Transaktionen und die Phänomene, die auftreten können. Sie können das Isolation-Level beim Eröffnen einer Datenbanksitzung angeben. Wenn Sie kein Isolation-Level angeben, dann verwendet das Datenbanksystem den Vorschlagswert.

In Abhängigkeit vom Isolation-Level fordert das Datenbanksystem dann während der Abarbeitung der SQL-Anweisungen die erforderlichen Sperren an. Alle ändernden SQL-Anweisungen (z. B. INSERT, UPDATE, DELETE) fordern stets eine Schreibsperre an.

Um für eine Transaktion explizit Sperren anzufordern, können Sie die LOCK-Anweisung verwenden.

Um einzelne Zeilen einer Tabelle zu sperren, können Sie die LOCK-Option innerhalb einer SQL-Anweisung verwenden. Dies ist in jedem Isolation-Level möglich. Mit der LOCK-Option können Sie auch für einzelne SQL-Anweisungen den Isolation-Level zeitweilig übersteuern.

Wenn in einer Tabelle von einer Transaktion zu viele Zeilensperren angefordert werden, dann versucht das Datenbanksystem, dafür eine Tabellensperre zu setzen. Die Grenze, ab der das Datenbanksystem versucht, Zeilensperren in eine Tabellensperre zu verwandeln, konfigurieren Sie mit dem allgemeinen Datenbankparameter MAXLOCKS.

Sperren freigeben

Art der Sperre | Freigabe
explizit vom Benutzer mit der LOCK-Anweisung angefordert | Das Datenbanksystem gibt die Sperre nach dem Ende der Transaktion frei. Ausnahmen: Wenn die COMMIT-Anweisung oder die ROLLBACK-Anweisung eine LOCK-Anweisung enthalten, gibt das Datenbanksystem die Sperren am Ende der Transaktion nicht frei.
implizit gesetzte Lesesperre | abhängig vom Isolation-Level
implizit gesetzte Schreibsperre Schreibsperre für geänderte Zeilen Schreibsperren, die durch eine ändernde SQL-Anweisung angefordert wurden Tabellensperren | Das Datenbanksystem gibt die Sperre erst nach dem Ende der gesamten Transaktion frei.
Schreibsperre für noch nicht geänderte Zeilen Lesesperren für Zeilen | Sie können diese Sperren mit einer UNLOCK-Anweisung freigeben. Siehe SQL-Referenzhandbuch, UNLOCK-Anweisung (unlock_statement).

Mit dem speziellen Datenbankparameter REQUEST_TIMEOUT begrenzen Sie, wieviel Zeit maximal vergehen darf, bis das Datenbanksystem eine Sperre aufhebt (Timeout).

Anzeigen von Informationen zu Sperren

Sie können sich Informationen zu Sperren folgendermaßen anzeigen lassen:

● Database Manager GUI, Strukturlink Datenbankaktivitäten anzeigen

● In SAP-Systemen verwenden Sie das CCMS, siehe

○ Datenbankverwaltung im CCMS: MaxDB, Strukturlink SQL-Sperren

○ Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink SQL-Sperren

Die Systemtabelle LOCKS enthält Informationen zu Sperren, die Systemtabelle LOCK_WAITS Informationen zu den Sperranforderungen.

Siehe auch:

Transaktionen

Das Datenbanksystem im Überblick


Lesesperre (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Lesesperre

Verwendung

Wenn eine Transaktion eine Lesesperre auf ein Datenbankobjekt setzt, dann können andere Transaktionen weiterhin lesend auf das Datenbankobjekt zugreifen und Lesesperren auf dieses Datenbankobjekt setzen. Sie können jedoch keine Schreibsperre setzen und das Datenbankobjekt nicht ändern.

Lesesperren können für den Datenbankkatalog, eine Tabelle oder eine Tabellenzeile gesetzt werden.

Eine Lesesperre wird mit dem Ende der betreffenden Transaktion implizit vom Datenbanksystem oder explizit durch eine UNLOCK-Anweisung vom entsprechenden Benutzer freigegeben.

Die Lesesperre wird auch SHARE-Sperre genannt.

Siehe auch:

Schreibsperre

Optimistische Sperre

Sperren für Datenbankobjekte


Schreibsperre (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Schreibsperre

Verwendung

Wenn eine Transaktion eine Schreibsperre auf ein Datenbankobjekt setzt, dann steht das betreffende Datenbankobjekt nur dieser Transaktion zur Verfügung und kann nur durch diese Transaktion geändert werden. Andere Transaktionen, die das Vorhandensein von Schreibsperren prüfen oder Schreib- oder Lesesperren setzen wollen, kollidieren mit der bestehenden Schreibsperre dieser Transaktion (Sperrkollision). Sie erhalten weder lesenden noch schreibenden Zugriff auf das gesperrte Objekt.

Schreibsperren können für den Datenbankkatalog, Tabellen oder Tabellenzeilen gesetzt werden.

Eine Schreibsperre wird mit dem Ende der betreffenden Transaktion vom Datenbanksystem freigegeben. Sie kann auch mit der UNLOCK-Anweisung vom entsprechenden Benutzer freigegeben werden. Dies ist jedoch nur dann möglich, wenn das Datenbankobjekt nicht geändert wurde. Wenn das Datenbankobjekt mit einer SQL-Anweisung geändert wurde (z. B. mittels INSERT-, UPDATE-, oder DELETE-Anweisung), dann bleibt die Schreibsperre bis zum Ende der Transaktion erhalten.

Die Schreibsperre wird auch EXCLUSIVE-Sperre genannt.

Siehe auch:

Lesesperre

Optimistische Sperre

Sperren für Datenbankobjekte


Optimistische Sperre (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Optimistische Sperre

Verwendung

Eine Transaktion kann für eine Tabellenzeile (Datensatz) eine optimistische Sperre setzen. Das Datenbanksystem teilt der Transaktion die aktuelle Versionsnummer der Tabellenzeile mit.

Immer wenn die Tabellenzeile geändert wird, erhöht das Datenbanksystem die Versionsnummer. Durch einen Vergleich zwischen der ursprünglichen und der aktuellen Versionsnummer können Datenbankanwendungen ermitteln, ob die beim Setzen der Sperre gelesenen Daten noch aktuell sind oder neu eingelesen werden müssen.

Eine optimistische Sperre müssen Sie explizit mit einer LOCK-Anweisung anfordern. Wenn für ein Datenbankobjekt bereits eine Schreibsperre besteht, dann können Sie keine optimistische Sperre setzen (Sperrkollision). Bei einer bestehenden optimistischen Sperre für ein Datenbankobjekt können andere Benutzer weiterhin Schreib-, Lese- oder weitere optimistische Sperren setzen.

Bevor eine Transaktion eine von ihr optimistisch gesperrte Tabellenzeile ändern kann, prüft das Datenbanksystem, ob die Tabellenzeile seit dem Setzen der optimistischen Sperre von einem anderen Benutzer geändert wurde.

● Wenn die Tabellenzeile nicht geändert wurde, wandelt das Datenbanksystem zunächst die optimistische Sperre in eine Schreibsperre um und nimmt dann die Änderungen vor.

● Wenn eine andere Transaktion die Tabellenzeile inzwischen geändert hat, weist das Datenbanksystem die Änderungsoperation zurück und gibt die optimistische Sperre frei.

Eine optimistische Sperre ist nur dann sinnvoll, wenn Sie einen der folgenden Isolation-Level konfiguriert haben: 0, 1, 10 oder 15

Siehe auch:

Lesesperre

Schreibsperre

Sperren für Datenbankobjekte


Phänomene (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Phänomene

Wenn mehrere Transaktionen gleichzeitig auf dasselbe Datenbankobjekt, z. B. eine Tabelle, zugreifen, dann kann es zu Inkonsistenzen bei den Ergebnissen kommen. Folgende Phänomene können auftreten:

· Dirty Read

Transaktion T1 ändert eine Zeile. Transaktion T2 liest diese Zeile, bevor T1 die Transaktion mit COMMIT beendet. T1 führt dann ein ROLLBACK durch.

T2 hat in diesem Fall eine Zeile gelesen, die eigentlich nie existierte.

· Non Repeatable Read

Transaktion T1 liest eine Zeile. Transaktion T2 verändert oder löscht dann diese Zeile und schließt die Transaktion mit COMMIT ab. Wenn T1 anschließend die Zeile nochmals liest, dann erhält T1 entweder die geänderte Zeile oder die Meldung, dass die Zeile nicht mehr existiert.

· Phantom

Transaktion T1 führt eine SQL-Anweisung S mit einer Suchbedingung aus, die eine Ergebnismenge M von Zeilen liefert. Transaktion T2 erzeugt dann, z. B. durch das Einfügen oder Ändern von Daten, mindestens eine weitere Zeile, die diese Suchbedingung erfüllt. Wenn T1 anschließend nochmals S ausführt, dann unterscheidet sich die neue Ergebnismenge von M.

Mit dem Isolation-Level können Sie konfigurieren, welche Phänomene möglich sind.

Zusammenhang zwischen Isolation-Level und Phänomenen

Phänomen | Isolation Level
 | 0 | 1 oder 10 | 2 oder 20 | 3 oder 30
Dirty Read | ja | nein | nein | nein
Non Repeatable Read | ja | ja | nein | nein
Phantom | ja | ja | ja | nein

Siehe auch:

Sperren für Datenbankobjekte


Parallelität von Sperren (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Parallelität von Sperren

Die folgende Tabelle zeigt, welche Lesesperren (SHARE LOCKS) und Schreibsperren (EXCLUSIVE LOCKS) parallel existieren können.

 | Eine Transaktion hat..
 | auf einer Tabelle |  | auf einer Zeile |  | auf dem Datenbankkatalog
Eine andere Transaktion kann... | Schreibsperre | Lesesperre | Schreibsperre | Lesesperre | Schreibsperre | Lesesperre
für die Tabelle eine Schreibsperre anfordern | nein | nein | nein | nein | nein | ja
für die Tabelle eine Lesesperre anfordern | nein | ja | nein | ja | nein | ja
für irgendeine Zeile der Tabelle eine Schreibsperre anfordern | nein | nein | - | - | nein | ja
für die gesperrte Zeile eine Schreibsperre anfordern | - | - | nein | nein | - | -
für eine andere Zeile eine Schreibsperre anfordern | - | - | ja | ja | - | -
für irgendeine Zeile der Tabelle eine Lesesperre anfordern | nein | ja | - | - | nein | ja
für die gesperrte Zeile eine Lesesperre anfordern | - | - | nein | ja | - | -
für eine andere Zeile eine Lesesperre anfordern | - | - | ja | ja | - | -
die Definition der Tabelle im Datenbankkatalog ändern | nein | nein | nein | nein | nein | nein
die Definition der Tabelle im Datenbankkatalog lesen | ja | ja | ja | ja | nein | ja

In Fällen, die mit „nein“ gekennzeichnet sind, liegt eine Sperrkollision vor. Wenn eine Sperre innerhalb einer Transaktion angefordert wird, dann muss auf die Freigabe einer Sperre gewartet werden, bis eine der in der Matrix mit „ja“ gekennzeichneten Situationen vorliegt.

Außerdem gilt Folgendes:

· Wenn für ein Datenbankobjekt keine Sperre gesetzt ist, dann kann eine Transaktion eine Lese- oder eine Schreibsperre anfordern, und das Datenbanksystem setzt die Sperre sofort.

· Wenn eine Transaktion T1 eine Lesesperre für ein Datenbankobjekt hält und keine andere Transaktion eine Sperre für dieses Datenbankobjekt hält, dann kann Transaktion T1 eine Schreibsperre für dieses Datenbankobjekt anfordern und erhält diese sofort.

· Wenn eine Transaktion eine Schreibsperre für ein Datenbankobjekt hält, dann kann diese Transaktion eine Lesesperre anfordern (dies ist aber nicht notwendig).

Siehe auch:

Sperren für Datenbankobjekte


Isolation-Level (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Isolation-Level

Verwendung

Der Isolation-Level bestimmt, wann das Datenbanksystem welche Sperren setzt.

Je mehr Sperren gesetzt werden und je länger die Sperren erhalten bleiben, desto weniger Parallelität ist im Datenbankbetrieb möglich. Je weniger Sperren gesetzt werden, desto mehr Phänomene treten auf und desto niedriger ist der Grad der garantierten Konsistenz.

Isolation-Level

Nummer

Name

Beschreibung

0

Read Uncommitted

Das Datenbanksystem liest Zeilen, ohne Lesesperren anzufordern.

Es ist dabei nicht sichergestellt, dass eine Zeile beim nochmaligen Lesen innerhalb einer Transaktion noch den gleichen Zustand hat wie beim ersten Lesen, weil sie in der Zwischenzeit durch eine andere Transaktion geändert worden sein kann.

Außerdem ist nicht sichergestellt, dass das Datenbanksystem den Zustand einer gelesenen Zeile bereits mit einer COMMIT-Anweisung gespeichert hat. Es kann vorkommen, dass der gelesene Wert vom Datenbanksystem nicht gespeichert wird, sondern durch ein ROLLBACK wieder auf einen früheren Wert gesetzt wird.

Beim Einfügen, Ändern und Löschen von Zeilen setzt das Datenbanksystem für die entsprechende Transaktion implizit Schreibsperren für die betroffenen Zeilen. Diese Sperren gibt das Datenbanksystem erst am Ende der Transaktion wieder frei.

1 bzw. 10

Read Committed

Beim Lesen stellt das Datenbanksystem für jede gelesene Zeile sicher, dass zum Zeitpunkt des Lesens keine andere Transaktion eine Schreibsperre für diese Zeile hält.

Beim Einfügen, Ändern und Löschen von Zeilen setzt das Datenbanksystem für die entsprechende Transaktion implizit Schreibsperren für die betroffenen Zeilen, die es erst am Ende der Transaktion wieder freigegibt.

15

Zusätzlich zum unter Isolation-Level 1 beschriebenen Verhalten gilt, dass das Datenbanksystem für alle durch eine SQL-Anweisung angesprochenen Tabellen vor Beginn der Bearbeitung Lesesperren anfordert.

Wenn eine SQL-Anweisung eine Ergebnistabelle erzeugt, die nicht permanent gespeichert wird, dann gibt das Datenbanksystem diese Sperren erst am Ende der Transaktion oder beim Schließen der Ergebnistabelle frei. Andernfalls gibt es die Sperren unmittelbar nach der Bearbeitung der SQL-Anweisung frei.

2 bzw. 20

Repeatable Read

Zusätzlich zum unter Isolation-Level 1 beschriebenen Verhalten gilt, dass für alle durch eine SQL-Anweisung zur Datenanfrage angesprochenen Tabellen vor Beginn der Bearbeitung implizit Lesesperren angefordert werden.

Wenn eine SQL-Anweisung eine Ergebnistabelle erzeugt, die nicht permanent gespeichert wird, dann gibt das Datenbanksystem diese Sperren erst am Ende der Transaktion oder beim Schließen der Ergebnistabelle frei. Andernfalls gibt es die Sperren unmittelbar nach der Bearbeitung der SQL-Anweisung frei.

Bei folgenden SQL-Anweisungen ordnet das Datenbanksystem die Tabellen-Lesesperre der Transaktion nicht zu: SQL-Anweisungen, bei denen genau eine Zeile einer Tabelle bearbeitet wird, die durch Schlüsselspezifikationen oder durch CURRENT OF <result_table_name> bestimmt wird.

Darüber hinaus gilt, dass das Datenbanksystem der Transaktion für jede während der Bearbeitung einer SQL-Anweisung gelesene Zeile implizit eine Lesesperre zuordnet. Diese Sperren können nur durch eine UNLOCK-Anweisung oder durch Beendigung der Transaktion freigegeben werden.

Beim Einfügen, Ändern und Löschen von Zeilen ordnet das Datenbanksystem der Transaktion implizit Schreibsperren für die betroffenen Zeilen zu, die erst am Transaktionsende freigegeben werden. Es setzt jedoch keine Sperren für die gesamte Tabelle.

3 bzw. 30

Serializable

Zusätzlich zum unter Isolation-Level 2 beschriebenen Verhalten gilt, dass eine Transaktion für jede durch eine SQL-Anweisung angesprochene Tabelle implizit eine Tabellen-Lesesperre zugeordnet wird.

Diese Lesesperren können nur durch Beendigung der Transaktion freigegeben werden. Diese Tabellen-Lesesperre wird der Transaktion nicht zugeordnet bei SQL-Anweisungen, bei denen genau eine Zeile einer Tabelle bearbeitet wird, die durch Schlüsselspezifikationen oder durch CURRENT OF <result_table_name> bestimmt wird.

Beim Einfügen, Ändern und Löschen von Zeilen ordnet das Datenbanksystem der Transaktion implizit Schreibsperren für die betroffenen Zeilen zu, die erst am Transaktionsende freigegeben werden.

1 und 10 sind nur unterschiedliche Schreibweisen desselben Isolation-Level. Sie unterscheiden sich nicht in ihrer Bedeutung. Dasselbe gilt für 2 und 20 sowie 3 und 30.

Aktivitäten

Der Vorschlagswert für den Isolation-Level ist vom SQL-Modus abhängig:

● ANSI: 3

● alle anderen: 1

Sie können den Isolation-Level beim Eröffnen einer Datenbanksitzung mit der CONNECT-Anweisung oder für eine einzelne SQL-Anweisung übersteuern.

Siehe SQL-Referenzhandbuch,

● CONNECT-Anweisung (connect_statement)

● LOCK-Option (lock_option)

Sie können den Isolation-Level einer Loader-Sitzung mit dem SET-Kommando festlegen, für einzelne Benutzer diese Festlegung mit dem USE USER-Kommando übersteuern oder im EXPORT COLUMNS-Kommando mit der LOCK-Option in der SELECT-Anweisung den gewünschten Isolation-Level angeben.

Siehe Loader,

● Strukturlink SET-Kommando

● Strukturlink USE USER-Kommando

● Strukturlink EXPORT COLUMNS-Kommando


Datenspeicherung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenspeicherung

Wie speichert das Datenbanksystem Informationen physisch ab?

Wenn ein Datenbankbenutzer innerhalb einer Transaktion Daten in der Datenbank ändert, speichert das Datenbanksystem die geänderten Daten zunächst im Data-Cache (im Arbeitsspeicher) und protokolliert die Änderungen in Redo-Log-Einträgen in den Log-Warteschlangen (im Arbeitsspeicher).

Siehe Arbeitsspeicherbereiche.

In folgenden Situationen schreibt das Datenbanksystem (Pager-Tasks) die Datenänderungen vom Data-Cache in die Data-Volumes:

● Der Data-Cache wird zu voll (unter anderem abhängig vom Verhältnis der geänderten zu den gelesenen Seiten im Data-Cache)

● bei Savepoints

In folgenden Situationen schreibt das Datenbanksystem (Log-Writer-Task) die Redo-Log-Einträge aus einer Log-Warteschlange in die Log-Volumes:

● Die Log-Warteschlange ist voll.

● Die Transaktion wurde mit einem COMMIT abgeschlossen.

● bei Savepoints

Log-Seiten in Log-Warteschlangen, die beim Schreiben noch nicht voll waren, verbleiben nach dem Schreiben in der Log-Warteschlange, werden weiter gefüllt und bei einem erneuten Schreibvorgang wieder in die Log-Volumes geschrieben.

Siehe

● Savepoint

● Protokollierung von Datenänderungen (Logging)

● Volumes (permanenter Speicher)

Arbeitsspeicher und permanenter Speicher

Diese Grafik wird im zugehörigen Text erklärt

Welche logischen Organisationsstrukturen verwendet das Datenbanksystem?

Das Datenbanksystem verwendet folgende Organisationsstrukturen, um die Daten der Datenbank zu speichern:

● Seitenketten

● Seiten in B*-Bäumen

Siehe Logische Zugriffsstrukturen.

Logische Organisationsstrukturen

Diese Grafik wird im zugehörigen Text erklärt

Wie ordnet das Datenbanksystem logische Informationen zu physischen Seiten zu?

Die Zuordnung von logischen Datenseiten zu physischen Adressen speichert das Datenbanksystem im Converter. Siehe Converter.

Siehe auch:

Das Datenbanksystem im Überblick


Arbeitsspeicherbereiche (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Arbeitsspeicherbereiche

Um möglichst wenig Zugriffe auf den permanenten Speicher (Volumes) machen zu müssen, puffert das Datenbanksystem Lese- und Schreiboperationen im Arbeitsspeicher. Für Informationen dazu, wann das Datenbanksystem Informationen aus dem Arbeitsspeicher in den permanenten Speicher schreibt, siehe Datenspeicherung.

Die Einheit, in der das Datenbanksystem den Arbeitsspeicher nutzt, sind Seiten.

Das Datenbanksystem unterteilt den Arbeitsspeicher, den es verwendet, in folgende Bereiche:

● I/O-Buffer-Cache, besteht im Wesentlichen aus:

○ Data-Cache (größter Anteil)

○ Converter

○ internes Dateiverzeichnis

● Catalog-Cache

● Shared-SQL-Cache

● Sequence-Cache

● Log-Warteschlangen

● nur liveCache-Datenbankinstanzen: OMS-Heap

Arbeitsspeicherbereiche

Diese Grafik wird im zugehörigen Text erklärt Beispiel für Arbeitsspeichergrößen (Vorlage Desktop PC / Laptop für eine MaxDB-Datenbankinstanz)

Cache | Datenbankparameter | maximale Größe
I/O-Buffer-Cache | CACHE_SIZE = 2500 | 19,53 MB
Catalog-Cache | CAT_CACHE_SUPPLY = 1632 | 12,75 MB
Shared-SQL-Cache | SHAREDSQL_COMMANDCACHESIZE = 262144 | 256 MB (initial 16 MB)
Sequence-Cache | SEQUENCE_CACHE = 1 | 0,01 MB
Log-Warteschlangen | LOG_IO_QUEUE = 50 (Größe einer Log-Warteschlange) LOG_QUEUE_COUNT = 1 (Anzahl Log-Warteschlangen) | 0,4 MB
I/O-Buffer-Cache

Im I/O-Buffer-Cache verwaltet das Datenbanksystem den gesamten Arbeitsspeicher, der für I/O-Operationen zur Verfügung steht.

● Data-Cache

Im Data-Cache speichert das Datenbanksystem die Seiten, auf die es zuletzt im Datenbereich lesend oder schreibend zugegriffen hat. Hierzu gehören z. B. Tabellen, Indizes, Long-Werte und Undo-Log-Einträge

Das Datenbanksystem sucht Daten immer zuerst im Data-Cache, bevor es auf den Datenbereich zugreift.

Die Größe des Data-Cache wirkt sich folgendermaßen auf die Performance des Datenbanksystems aus:

○ Ein großer Data-Cache ermöglicht eine hohe Trefferrate. Wir empfehlen eine Trefferrate von mindestens 98%.

○ Ein zu großer Data-Cache kann auf einem Computer mit einem kleinen Arbeitsspeicher dazu führen, dass das Betriebssystem Seiten aus dem Arbeitsspeicher auf die Festplatte auslagert (Swapping), was die Performance stark verschlechtert.

● Converter-Cache

Im Converter speichert das Datenbanksystem die Informationen dazu, welche logische Seitennummer an welcher physikalischen Position (MaxDB-Blockadresse) gespeichert ist. Beim Starten der Datenbankinstanz liest das Datenbanksystem den ganzen Converter in den Arbeitsspeicher ein.

Siehe Converter.

Wenn der Converter im laufenden Datenbankbetrieb wächst und mehr Seiten benötigt, dann teilt das Datenbanksystem ihm mehr Seiten aus dem I/O-Buffer-Cache zu.

Sie können die Größe von Data-Cache und Converter nicht direkt konfigurieren, sondern nur indirekt über die Größe des I/O-Buffer-Cache.

Catalog-Cache

Im Catalog-Cache speichert das Datenbanksystem Folgendes:

● Informationen aus dem Datenbankkatalog

● Informationen zu bereits ausgeführten SQL-Anweisungen der einzelnen Datenbankbenutzer (benutzerspezifisch, nur wenn der Datenbankparameter SHAREDSQL den Wert NO hat). Wenn mehrere Datenbankbenutzer dieselbe SQL-Anweisung ausführen, wird, wird diese auch mehrmals im Catalog-Cache gespeichert.

Wenn der Catalog-Cache voll ist, verlagert das Datenbanksystem Informationen in den Data-Cache.

Jeder User-Task weist das Datenbanksystem zu Beginn der Datenbanksitzung einen Bereich des Catalog-Cache zu, den es nach Ende der Datenbanksitzung wieder freigibt.

Die Trefferrate für den Catalog-Cache sollte über 85 Prozent liegen. Die untere Grenze der Trefferrate hängt stark von der Anwendung ab.

Shared-SQL-Cache

Wenn der Datenbankparameter SHAREDSQL den Wert YES hat, dann verwendet das Datenbanksystem den Shared-SQL-Cache.

Im Shared-SQL-Cache speichert das Datenbanksystem bereits ausgeführte SQL-Anweisungen einschließlich ihrer Ausführungspläne. Der Shared-SQL-Cache wird von allen Datenbankbenutzern gemeinsam verwendet, dieselbe SQL-Anweisung wird also nur einmal gespeichert.

Wenn der Datenbankparameter SHAREDSQL den Wert NO hat, dann speichert das Datenbanksystem bereits ausgeführte SQL-Anweisungen für jeden Datenbankbenutzer einzeln im Catalog-Cache.

Sequence-Cache

Im Sequence-Cache speichert das Datenbanksystem Informationen zu Sequenzen.

Log-Warteschlangen

Das Datenbanksystem weist jeder Transaktion eine Log-Warteschlange zu, in die die Transaktion ihre Redo-Log-Einträge schreibt. Mehrere Transaktionen können in dieselbe Log-Warteschlange schreiben.

Siehe auch Protokollierung von Datenänderungen (Logging).

Arbeitsspeicher für das interne Dateiverzeichnis

Beim Starten der Datenbankinstanz liest das Datenbanksystem das gesamte interne Dateiverzeichnis in den Arbeitsspeicher ein. Im internen Dateiverzeichnis speichert das Datenbanksystem Informationen für den logischen Zugriff auf Datenbankobjekte, wie z. B. die Zuordnung der Wurzelseiten der B*-Bäume zu den Tabellen-IDs.

OMS-Heap (nur für SAP liveCache-Datenbankinstanzen)

Der OMS-Heap ist ein spezieller Arbeitsspeicherbereich, der nur von SAP liveCache-Datenbankinstanzen verwendet wird. Im OMS-Heap befinden sich folgende Daten:

● lokale Kopien der OMS-Daten

Beim ersten Zugriff auf ein Objekt innerhalb einer konsistenten Sicht schreibt das Datenbanksystem die entsprechenden Daten in den OMS-Heap.

● lokale Anwendungsdaten

Für jede OMS-Version kopiert das Datenbanksystem die Daten beim Lesen in den OMS-Heap.

Um auf ein persistentes Objekt zuzugreifen, sucht das Datenbanksystem es zuerst im OMS-Heap. Wenn es das Objekt dort nicht findet, sucht es im Data-Cache. Wenn es das Objekt auch dort nicht findet, kopiert das Datenbanksystem das Objekt vom Datenbereich in den Data-Cache und von dort in den OMS-Heap. Alle Änderungen an Objekten führt das Datenbanksystem dann im OMS-Heap durch. Objekte, die innerhalb einer konsistenten Sicht gelesen, aber nicht geändert wurden, löscht das Datenbanksystem aus dem OMS-Heap. Mit dem Beenden einer Transaktion (COMMIT) schreibt das Datenbanksystem die OMS-Daten aus dem OMS-Heap in den Data-Cache.

Der OMS-Heap wächst, wenn die Anwendung zusätzlichen Arbeitsspeicher anfordert. Die maximale Größe des OMS-Heap konfigurieren Sie mit dem liveCache-Datenbankparameter OMS_HEAP_LIMIT.

Siehe liveCache-Datenbankparameter.

Wie synchronisiert das Datenbanksystem Zugriffe auf kritische Abschnitte?

Ein kritischer Abschnitt ist ein Bereich des Arbeitsspeichers, für den das Datenbanksystem konkurrierende Zugriffe von Tasks über spezielle Synchronisationsmittel (Regionen, Reader-Writer-Locks) ermöglicht.

Spezielle Synchronisationsmittel

Name

verwendet für

Beschreibung

Region

Data-Cache

exklusive Sperre

Wenn eine Task auf einen kritischen Abschnitt zugreift, dann sperrt die zuständige Region diesen kritischen Abschnitt für alle anderen Tasks.

Reader-Writer-Lock

Catalog-Cache

Shared-SQL-Cache

exklusive oder shared

Wenn eine Task schreibend auf einen kritischen Abschnitt zugreift, dann sperrt das zuständige Reader-Writer-Lock diesen kritischen Abschnitt für weitere schreibende Zugriffe, lesende Zugriffe sind jedoch möglich.

Wenn eine Task lesend auf einen kritischen Abschnitt zugreift, dann sperrt das zuständige Reader-Writer-Lock diesen kritischen Abschnitt für schreibende Zugriffe, weitere lesende Zugriffe sind jedoch möglich.

Siehe auch:

Datenbankparameter

Savepoint

Überwachung

Performance


Volumes (permanenter Speicher) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Volumes (permanenter Speicher)

Das Datenbanksystem speichert die Daten und Log-Einträge einer Datenbankinstanz permanent in den Volumes.

Sie können für Volumes folgende Speicherarten verwenden:

● Datei (F)

Ein Volume kann ein Teil einer physischen Festplatte, eine gesamte physische Festplatte oder auch ein aus mehreren Speichereinheiten bestehendes Speichersystem sein.

● nur auf UNIX/Linux: Link (L)

● nur auf UNIX/Linux: Raw Device (R)

Die Einheit, in der das Datenbanksystem Informationen in den permanenten Speicher schreibt und daraus liest, sind Seiten mit einer Größe von 8 KB. Eine Seite entspricht einer bestimmten Anzahl von Betriebssystemblöcken. Seiten werden häufig als Einheit verwendet, wenn Speicher- und Plattengrößen angegeben werden.

Typen von Volumes

Das Datenbanksystem unterscheidet Data- und Log-Volumes.

Volumes einer Datenbankinstanz

Diese Grafik wird im zugehörigen Text erklärt

Beim Anlegen einer neuen Datenbankinstanz konfigurieren Sie mindestens ein Data- und ein Log-Volume.

Beispiel (Vorlage Desktop PC / Laptop für eine MaxDB-Datenbankinstanz)

Volume | Anzahl | Größe | Pfad und Dateiname
Data-Volume | 1 | 256 MB | <independent_data_path>\data\DISKD0001
Log-Volume | 1 | 50 MB | <independent_data_path>\log\DISKL0001

Die Größe eines bestehenden Volume können Sie nicht ändern. Bei Bedarf können Sie aber während des laufenden Datenbankbetriebs weitere Data- und Log-Volumes hinzufügen. Data-Volumes können Sie auch wieder löschen.

Siehe

Database Manager GUI, Strukturlink Volumes anlegen, anzeigen und löschen

Database Manager CLI, Strukturlink db_addvolume und Strukturlink db_deletevolume

Empfehlungen zur Konfiguration der Volumes finden Sie unter Datenbankinstanz planen, Informationen zu den technischen Restriktionen bei der Konfiguration der Volumes unter Technische Restriktionen.

Data-Volumes

In den Data-Volumes speichert das Datenbanksystem:

● Anwendungsdaten

● Datenbankkatalog

● den beim letzten Savepoint gespeicherten Converter

● Undo-Log-Dateien

● Sequenzen

● die Restart-Information

Alle Data-Volumes zusammen werden als Datenbereich bezeichnet.

Durch ein internes Striping verteilt das Datenbanksystem die zu einer Tabelle gehörenden Daten gleichmäßig auf alle Data-Volumes.

Datenbereich

Diese Grafik wird im zugehörigen Text erklärt

Die Größe des Datenbereichs darf 2000 Seiten nicht unterschreiten. Im Datenbereich muss außerdem stets genügend Platz vorhanden sein, um die im Datenbankbetrieb anfallenden Daten aufzunehmen. Sie können die Datenbankinstanz so konfigurieren, dass das Datenbanksystem automatisch Data-Volumes hinzufügt, wenn der im Datenbereich zur Verfügung stehende freie Speicherplatz zu klein wird.

Siehe

Database Manager GUI, Strukturlink Automatische Erweiterung des Datenbereichs ein-/ausschalten

Database Manager CLI, Strukturlink auto_extend

Bei großen Datenbankinstanzen erreichen Sie eine bessere Performance, wenn Sie mehrere Data-Volumes auf verschiedenen Festplatten konfigurieren. Die maximale Anzahl der Data-Volumes, die Sie für eine Datenbankinstanz definieren können, konfigurieren Sie mit dem allgemeinen Datenbankparameter MAXDATAVOLUMES.

Log-Volumes

In den Log-Volumes speichert das Datenbanksystem die Redo-Log-Einträge (After-Images).

Alle Log-Volumes zusammen werden als Log-Bereich bezeichnet. Die maximale Anzahl der Log-Volumes, die Sie für eine Datenbankinstanz definieren können, konfigurieren Sie mit dem allgemeinen Datenbankparameter MAXLOGVOLUMES.

Der Log-Bereich ist in logische Log-Segmente unterteilt. Die Größe der Log-Segmente konfigurieren Sie mit dem allgemeinen Datenbankparameter LOG_SEGMENT_SIZE. Sie ist unabhängig von der Größe der einzelnen Log-Volumes, darf allerdings nicht größer als die Summe aller Log-Volumes sein. Wählen Sie die Größe so, dass während der Sicherung eines Log-Segments noch genügend Platz im Log-Bereich bleibt, um die während der Sicherung neu geschriebenen Redo-Log-Einträge aufzunehmen.

Log-Bereich

Diese Grafik wird im zugehörigen Text erklärt

Das Datenbanksystem überschreibt den Log-Bereich zyklisch. Allerdings kann es Redo-Log-Einträge im Log-Bereich erst dann überschrieben werden, wenn diese gesichert wurden. Wenn Sie keine Log-Sicherungen durchführen, dann hat das Datenbanksystem irgendwann den ganzen Log-Bereich mit Redo-Log-Einträgen gefüllt. Wenn der Log-Bereich voll ist, kommt es zum Datenbankstillstand. Führen Sie deshalb regelmäßig Log-Sicherungen durch oder schalten Sie die automatische Log-Sicherung ein.

Siehe

Log-Einträge sichern

Database Manager GUI, Strukturlink Ein- und Ausschalten der automatischen Log-Sicherung

Database Manager CLI, Strukturlink autolog_on

Wenn der Log-Bereich voll ist, müssen Sie eine Log-Sicherung durchführen. Es nützt es nichts, wenn Sie ein neues Log-Volume hinzufügen: die aktuelle Schreibposition befindet sich in der Regel nicht am Ende des Log-Bereichs, wo das Datenbanksystem das neue Log-Volume anhängt.

Log-Bereich voll

Diese Grafik wird im zugehörigen Text erklärt

Sie können auch den Überschreibmodus für den Log-Bereich einschalten, dann überschreibt das Datenbanksystem den Log-Bereich, ohne vorher Log-Sicherungen durchzuführen. Beachten Sie jedoch, dass in diesem Fall die Sicherungshistorie unterbrochen wird und Sie die Datenbankinstanz nicht mehr bis zum letzten Stand wiederherstellen können.

Aus Sicherheitsgründen empfehlen wir, den Log-Bereich zu spiegeln. Wenn eine hardwarebasierte Spiegelung nicht möglich ist, dann kann das Datenbanksystem den Log-Bereich spiegeln.

Siehe Log-Einstellungen.

Siehe auch:

Datenspeicherung

Datenbankparameter

Anlegen und Konfigurieren einer Datenbankinstanz

Sichern und Wiederherstellen


Savepoint (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Savepoint

Einsatzmöglichkeiten

Das Datenbanksystem führt im Betriebszustand ONLINE und während eines Restarts automatisch Savepoints (Sicherungspunkte) durch. Bei einem Savepoint schreibt das Datenbanksystem alle Datenänderungen seit dem letzten Savepoint aus dem Data-Cache (Arbeitsspeicher) in den Datenbereich (permanenter Speicher).

Die Daten, die mit einem Savepoint in den Datenbereich geschrieben werden, repräsentieren immer einen konsistenten Zustand der Datenbank. Sie können die Datenbankinstanz immer, beispielsweise auch nach einem Stromausfall, in einem konsistenten Zustand starten, ohne dass Sie hierfür Log-Sicherungen einlesen müssen.

Wohin schreibt das Datenbanksystem die Datenänderungen?

Beim Savepoint überschreibt das Datenbanksystem nicht die beim vorherigen Savepoint geschriebenen Seiten im Datenbereich, sondern es schreibt die geänderten Daten auf neue freie Positionen. Der Grund hierfür ist, dass das Datenbanksystem diese Informationen des vorherigen Savepoints für den Restart benötigt, falls es während des neuen Savepoints zu einem Systemausfall kommt.

Erst nachdem das Datenbanksystem den neuen Savepoint erfolgreich abgeschlossen hat, gibt es die Seiten des vorherigen Savepoints im Datenbereich wieder zum Überschreiben frei.

Wann führt das Datenbanksystem Savepoints durch?

Das Datenbanksystem führt Savepoints in folgenden Situationen durch:

● Seit dem letzten Savepoint hat das Datenbanksystem 2/3 des Log-Bereichs mit Redo-Log-Einträgen gefüllt.

● Das Datenbanksystem hat 5000 Log-I/O-Operationen durchgeführt, und es ist seit dem letzten Savepoint mindestens die Zeit vergangen, die mit dem Support-Datenbankparameter _RESTART_TIME festgelegt ist.

Wenn Sie den Wert von _RESTART_TIME vergrößern, verringert sich zwar die Anzahl der Savepoints und damit die Systemlast, aber nach einem Systemausfall verlängert sich die für den Restart benötigte Zeitspanne.

● Verschiedene Datenbankaktivitäten, wie beispielsweise das Starten einer Datensicherung, fordern implizit einen Savepoint an. Alle Savepoints und die Aktionen, die durch sie ausgelöst wurden, protokolliert das Datenbanksystem im Kernprotokoll.

Ablauf

Der Savepoint wird vom Datenbanksystem über eine Server-Task (Savepoint Coordinator) gesteuert. Er läuft folgendermaßen ab:

...

1. Das System schreibt alle geänderten permanenten Datenseiten aus dem Data-Cache in den Datenbereich.

2. Das System wartet auf das Ende alle Operationen, die sich mit dem Savepoint synchronisieren müssen, beispielsweise das Einfügen eines Datensatzes in einen B*-Baum. Neue Operationen dieser Art lässt das Datenbanksystem nicht mehr zu.

3. Das System lässt kein Starten oder Beenden von Transaktionen mehr zu.

4. Bei einem Savepoint während des normalen Datenbankbetriebs:

Das System schreibt einen Redo-Log-Eintrag. Dieser markiert, ab wann das System noch Log-Einträge einlesen muss, wenn später ein Restart mit den Daten dieses Savepoint durchgeführt werden muss.

Bei einem Savepoint während eines Restarts:

Das System ermittelt die aktuelle Position des Log-Lesers und trägt diese in die Restart-Information ein.

5. Das System speichert Informationen über die offenen Transaktionen in Datenseiten, damit diese bei einem Restart für das Wiederholen oder Rückgängigmachen der Transaktionen zur Verfügung stehen.

6. Das System liest die History-Informationen in den Data-Cache ein.

7. Das System markiert alle seit Schritt 1 geänderten permanenten Datenseiten im Data-Cache.

8. Das System lässt alle in den Schritten 2 und 3 aufgeführten Operationen wieder zu.

Alle Änderungen, die Datenbankbenutzer ab diesem Zeitpunkt durchführen, haben keinen Einfluss mehr auf die im Schritt 7 markierten Daten. Diese Änderungen kann das System frühestens nach dem Ende des aktuellen Savepoint in den Datenbereich schreiben.

9. Das System schreibt die in Schritt 7 markierten Datenseiten in den Datenbereich. Neben den Änderungen, die bereits mit einem COMMIT abgeschlossen wurden, gehören hierzu auch die Undo-Log-Dateien nicht abgeschlossener Transaktionen, die das System im Falle eines Restarts benötigt.

10. Das System schreibt alle geänderten Seiten des internen Dateiverzeichnisses in den Datenbereich.

11. Das System schreibt alle geänderten Converter-Seiten in den Datenbereich.

12. Das System aktualisiert die Restart-Information, die unter anderem die Savepoint-Version (=Converter-Version) enthält.

Der eigentliche Savepoint ist damit abgeschlossen.

13. Nun gibt das System alle Seiten im Datenbereich, die nicht mehr benötigt werden, zum Überschreiben frei.

14. Das System weckt diejenigen Tasks auf, die den Savepoint angefordert oder auf einen Savepoint gewartet haben.

Wenn der Savepoint wegen des Übergangs in den Betriebszustand OFFLINE ausgelöst wurde, dann stoppt das System nun den Datenbankkern.

Siehe auch:

Datenspeicherung

Beispiel: Restart

Arbeitsspeicherbereiche

Volumes (permanenter Speicher)

Sichern und Wiederherstellen

Database Manager CLI, Strukturlink db_restartinfo


Logische Zugriffsstrukturen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Logische Zugriffsstrukturen

Das Datenbanksystem verwendet folgende Organisationsstrukturen, um die Daten der Datenbank zu speichern:

● Seitenketten

● Seiten in B*-Bäumen

Seitenketten

Um Undo-Log-Einträge und SAP liveCache-Daten (C++-Objekte) zu speichern und später darauf zuzugreifen, verwendet das Datenbanksystem Seitenketten.

Eine Seitenkette ist eine Folge von Seiten, die logisch zusammengehören. Jede Seite hat genau eine nachfolgende Seite. Die erste Seite der Seitenkette wird als Wurzelseite bezeichnet. Die Wurzelseite enthält interne Verwaltungsinformationen, wie z. B. die Identifikation der letzten Seite der Seitenkette.

Seitenkette

Diese Grafik wird im zugehörigen Text erklärt

B*-Bäume

B*-Bäume legt das Datenbanksystem für folgende Datenbankobjekte an:

● einen B*-Baum pro Tabelle für die Datensätze (Anwendungsdaten)

● einen oder mehrere zusätzliche B*-Bäume für die LONG-Werte einer Tabelle

Siehe B*-Bäume für Tabellen mit LONG-Spalten.

● einen zusätzlichen B*-Baum für jeden Index einer Tabelle

Siehe B*-Baum für jeden Index einer Tabelle

Ein B*-Baum besteht aus einer Wurzelebene, einer oder mehreren B*-Baum-Indexebenen und einer Blattebene. Jede Ebene besteht aus einer oder mehreren Seiten. Wenn das Datenbanksystem nach einem Datensatz sucht, schränkt es den Suchbereich schrittweise ein, ausgehend von der Wurzelseite des B*-Baums.

B*-Baum mit drei Ebenen

Diese Grafik wird im zugehörigen Text erklärt

Die Seiten der Wurzel- und B*-Baum-Indexebenen eines B*-Baums enthalten die Separatoren.

Ein Separator zeigt auf die logischen Adressen (Seitennummern) von Seiten auf der nächst tieferen Ebene. In einem Separator ist der signifikante Teil des Primärschlüssels enthalten, der zur Unterscheidung zum Folgeeintrag benötigt wird. Auf diese Weise wird der von diesen Seiten benötigte Speicherplatz minimiert. Die durchschnittliche Länge der Separatoren hängt von der Struktur und Selektivität des Schlüssels ab.

Der erste Separator in der äußersten linken Seite pro Ebene (einschließlich der Wurzelebene) enthält nur den Zeiger auf die äußerste linke Seite auf der nächst tiefer gelegenen Ebene.

Blattseite eines B*-Baums

Diese Grafik wird im zugehörigen Text erklärt

Die Seiten der Blattebene (Blattseiten) enthalten die eigentlichen Datensätze (Tabellenzeilen) und eine Positionsliste. Zu jedem Datensatz gehört ein Eintrag in der Positionsliste, der auf den physischen Speicherort des Datensatzes in der Seite zeigt. Das Datenbanksystem legt die Datensätze in einer Seite unsortiert ab, sortiert aber die Positionseinträge in der Positionsliste aufsteigend.

Die Anzahl der Datensätze auf einer Blattseite hängt von der Gesamtlänge der Datensätze ab.

Das Datenbanksystem führt einen automatischen Ausgleich zwischen den B*-Bäumen durch und macht dadurch eine manuelle Reorganisation der Daten überflüssig. Siehe Belegungsausgleich.

Siehe auch:

Beispiel: SELECT-Anweisung

Beispiel: INSERT-Anweisung

Beispiel: UPDATE-Anweisung

Beispiel: DELETE-Anweisung

Datenspeicherung


B*-Bäume für Tabellen mit LONG-Spalten (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation B*-Bäume für Tabellen mit LONG-Spalten

Verwendung

Das Datenbanksystem legt für LONG-Spalten (LOBs) folgende B*-Bäume an:

● einen B*-Baum für die Datensätze (Primärbaum), sortiert nach dem Primärschlüssel

● einen B*-Baum für die kurzen Werte in der LONG-Spalte

LONG-Werte, die kleiner als eine Seite sind, werden auch als short LONG-Werte oder short column file bezeichnet. LONG-Werte, die größer als eine Seite sind, werden auch als long LONG-Werte bezeichnet.

● jeweils einen weiteren B*-Baum für jeden langen LONG-Wert in der LONG-Spalte

Die Blattseiten des Primärbaums enthalten für die Werte der LONG-Spalte entweder Verweise auf das den B*-Baum für die kurzen LONG-Werte oder Verweise auf die Tabellen-ID eines der B*-Bäume für lange LONG-Werte.

Die folgende Abbildung zeigt die B*-Bäume für eine Basistabelle mit einer LONG-Spalte, die zwei kurze LONG-Werte und zwei lange LONG-Werte enthält.

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Logische Zugriffsstrukturen


B*-Bäume für Tabellen mit Indizes (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation B*-Bäume für Tabellen mit Indizes

Verwendung

Für jeden Index, der für eine Basistabelle definiert ist, legt das Datenbanksystem einen B*-Baum an.

Der Index einer Basistabelle wird explizit mit einer SQL-Anweisung definiert und hat nichts mit der B*-Baum-Indexebene zu tun.

Das Datenbanksystem legt die Invertierungslisten des Index folgendermaßen ab:

● 1:1-Beziehung zwischen Sekundärschlüssel (Indexeintrag) und Primärschlüssel:

Das Datenbanksystem legt die Invertierungsliste direkt in der entsprechenden Blattseite des B*-Baums des Index ab.

● 1:n-Beziehung zwischen Sekundärschlüssel und Primärschlüsseln:

Das Datenbanksystem legt die Invertierungsliste ebenfalls in der entsprechenden Blattseite des B*-Baums des Index ab (flache Liste).

Wenn die Invertierungsliste zu groß für die Blattseite wird, dann legt das Datenbanksystem einen zusätzlichen B*-Baum für diese Invertierungsliste an. In der Blattseite des B*-Baums des Index steht dann nur noch der Verweis auf den B*-Baum der Invertierungsliste.

Beispiel

Die Tabelle CUSTOMER enthält die Namen aller Kunden eines Hotels.

● Primärschlüssel: Kundennummer cno

● Index: Nachname name

Tabelle CUSTOMER

cno | name | firstname
2003 | Miller | Frank
2011 | Griffith | Mary
2078 | Miller | Jane
2104 | Miller | Susan
2295 | Miller | Sally

Der Index enthält die folgenden Invertierungslisten.

Invertierungslisten

Bezeichnung | Sekundärschlüssel | Primärschlüssel
Invertierungsliste 1 | Griffith | 2011
Invertierungsliste 2 | Miller | 2003, 2078, 2104, 2295

Das Datenbanksystem legt die Invertierungsliste 1 direkt in der Blattseite des B*-Baums des Index ab.

Für die Invertierungsliste 2 legt das Datenbanksystem einen zusätzlichen B*-Baum an, weil auf der Blattseite des B*-Baums des Index nicht genügend Platz vorhanden ist.

Siehe auch:

Logische Zugriffsstrukturen


Belegungsausgleich (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Belegungsausgleich

Verwendung

In folgenden Fällen ändert das Datenbanksystem die Struktur eines B*-Baums:

● Beim Ändern oder Einfügen eines Datensatzes ist in der der Blattseite nicht genügend Platz vorhanden.

Das Datenbanksystem fügt eine neue Blattseite ein und verteilt die Datensätze neu.

Die Größe einer Tabelle ist also nur durch den insgesamt verfügbaren Speicherplatz im Datenbereich begrenzt.

● Nach dem Löschen von Datensätzen ist eine Blattseite nicht mehr ausreichend gefüllt.

Das Datenbanksystem löscht die Blattseite und verschiebt die Datensätze auf andere Blattseiten.

● Das Ändern oder Einfügen eines Datensatzes hat zur Folge, dass die Separatoren auf der nächst höheren Ebene nicht mehr eindeutig sind.

Das Datenbanksystem verteilt die Separatoren neu.

Durch das Hinzufügen oder Löschen von Blattseiten kann es dazu kommen, dass einige Zweige des B*-Baums deutlich mehr Seiten als andere Zweige haben. Eine solche uneinheitliche Verteilung der Seiten verschlechtert die Performance des Datenbanksystems, weil bei der Suche nach Daten in Zweigen mit vielen Seiten mehr Zugriffe erforderlich sind als in Zweigen mit wenigen Seiten.

Das Datenbanksystem erkennt solche uneinheitlichen Verteilungen und führt automatisch einen Belegungsausgleich durch (Reorganisationsfreiheit).

Die folgende Abbildung zeigt, wie das Datenbanksystem bei einer INSERT-Anweisung die B*-Baumstruktur verändert.

Beispiel für die Aufteilung einer Seite auf der Blattebene

Diese Grafik wird im zugehörigen Text erklärt

In der Tabelle ADDRESS ist die Spalte CITY als Primärschlüssel definiert. Ein Benutzer fügt mit einer INSERT-Anweisung einen neuen Datensatz mit dem Wert Albas für die Spalte CITY ein. Der Datensatz ist jedoch zu groß für die entsprechende Blattseite im B*-Baum. Das Datenbanksystem führt deswegen folgende Aktionen durch:

...

1. Das Datenbanksystem legt eine neue Blattseite an und fügt den neuen Datensatz in die neue Blattseite ein. Die Sortierung der Einträge auf der neuen Blattseite beginnt also mit dem neuen Datensatz.

2. Wenn notwendig, kopiert es nun alle Datensätze, die zum Sortierbereich der neuen Blattseite gehören, aus der alten Blattseite auf die neue Blattseite und löscht sie dann aus der alten Blattseite. Dieser Vorgang wird als Seitensplit bezeichnet. Dann aktualisiert das Datenbanksystem die Positionslisten und die jeweiligen Zeiger auf die Folgeseiten innerhalb der Blattebene.

3. Das Datenbanksystem fügt die Adressen- und Separatorinformationen der neuen Blattseite in die entsprechende Wurzel- oder B*-Baum-Indexseite auf der nächsthöheren Ebene ein.

○ Wenn die B*-Baum-Indexseite zu klein ist, dann fügt das Datenbanksystem auf dieser Indexebene eine neue B*-Baum-Indexseite ein.

○ Wenn die Wurzelseite auf der obersten Ebene zu klein ist, dann legt das Datenbanksystem eine neue B*-Baum-Indexebene an.

Siehe auch:

Logische Zugriffsstrukturen

Beispiel: INSERT-Anweisung


Beispiel: SELECT-Anweisung (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: SELECT-Anweisung

In der Tabelle ADDRESS ist die Spalte CITY als Primärschlüssel definiert. Ein Benutzer hat die folgende SELECT-Anweisung eingegeben:

SELECT * FROM address WHERE city = 'Athens'

Das Datenbanksystem sucht in der Tabelle ADDRESS nach dem Datensatz, der den Wert Athens in der Spalte CITY hat.

...

1. Das Datenbanksystem beginnt die Suche auf der Wurzelebene des B*-Baums. Es vergleicht den gesuchten Wert Athens mit dem Wert des ersten Separators in der Wurzelseite, Baf.

Weil der Wert Athens niedriger ist als Baf, setzt das Datenbanksystem die Suche auf der ersten Indexseite der B*-Baum-Indexebene fort.

2. Der erste Separator An auf der ersten Indexseite der B*-Baum-Indexebene ist niedriger als der Wert Athens. Das Datenbanksystem wertet deshalb den nächsten Separator Au in der Indexseite aus.

Weil der Wert Au höher ist als der Wert Athens, wertet das Datenbanksystem die Adressinformationen nach dem Separator An aus, um auf die richtige Blattseite auf der Blattebene zu gelangen.

3. Um die Adressinformation des Datensatzes mit dem Schlüsselwert Athens zu finden, verwendet das Datenbanksystem einen binären Suchalgorithmus.

Das Datenbanksystem durchsucht die Datensätze in der Blattseite, bis es den gesuchten Datensatz gefunden hat. Die Suche ist hiermit abgeschlossen.

Siehe auch:

Logische Zugriffsstrukturen


Beispiel: INSERT-Anweisung (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: INSERT-Anweisung

In der Tabelle ADDRESS ist die Spalte CITY als Primärschlüssel definiert.

Ein Benutzer gibt eine INSERT-Anweisung ein, um in der Tabelle ADDRESS einen neuen Eintrag mit dem Wert Arbon für das Primärschlüsselfeld CITY einzufügen.

...

1. Das Datenbanksystem fügt den Datensatz hinter dem letzten Datensatz in der Blattseite ein.

Wenn in der entsprechenden Blattseite des B*-Baums nicht genügend Platz für den neuen Datensatz ist, dann muss das Datenbanksystem eine neue Blattseite einfügen und die Datensätze neu verteilen (siehe Belegungsausgleich).

2. Das Datenbanksystem aktualisiert die Positionsliste, indem es den Positionseintrag des neuen Dateneintrags an der richtigen Stelle in die Positionsliste einfügt.

Siehe auch:

Logische Zugriffsstrukturen


Beispiel: DELETE-Anweisung (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: DELETE-Anweisung

In der Tabelle ADDRESS ist die Spalte CITY als Primärschlüssel definiert.

Ein Benutzer gibt eine DELETE-Anweisung ein, um in der Tabelle den Eintrag mit dem Wert Apach für das Primärschlüsselfeld CITY zu löschen.

...

1. Das Datenbanksystem löscht den Datensatz und seinen Positionseintrag aus der entsprechenden Blattseite.

Hierdurch entstehen in der Blattseite Lücken.

2. Das Datenbanksystem schließt diese Lücken und aktualisiert anschließend die Adressinformationen in der Positionsliste der Blattseite.

Siehe auch:

Logische Zugriffsstrukturen


Beispiel: UPDATE-Anweisung (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: UPDATE-Anweisung

In der Tabelle ADDRESS ist die Spalte CITY als Primärschlüssel definiert. Ein Benutzer hat eine UPDATE-Anweisung eingegeben.

Das Datenbanksystem sucht bei einer UPDATE-Anweisung im B*-Baum auf die gleiche Weise wie bei einer SELECT-Anweisung nach den zu ändernden Daten.

● Wenn die UPDATE-Anweisung den Schlüsselwert des Datensatzes nicht ändert, dann ändert das Datenbanksystem nur den Inhalt des Datensatzes.

Wenn sich dabei die Länge des Datensatzes ändert, dann verschiebt das Datenbanksystem die nachfolgenden Datensätze in der Blattseite entsprechend und aktualisiert dann die Positionsliste der Blattseite.

● Wenn die UPDATE-Anweisung das Schlüsselfeld des Datensatzes ändert, dann führt das Datenbanksystem das UPDATE als DELETE mit einem nachfolgenden INSERT aus.

Siehe auch:

Logische Zugriffsstrukturen


Converter (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Converter

Verwendung

Der Converter ordnet logische Datenseiten zu physischen Speicherorten (Blockadressen, bestehend aus Volume-ID und Position) zu.

Converter-Eintrag

271397 P 1/0000271404

Die logische Seitennummer 271397 ist eine permanente (P) Datenseite. Sie ist auf dem ersten Data-Volume an der Position 271404 gespeichert.

Typen von Datenseiten

Typ | Beschreibung
P | permanente Datenseite
S | Datenseite einer SAP liveCache-Datenbankinstanz
T | temporäre Datenseite

Das Datenbanksystem liest den Converter beim Starten der Datenbankinstanz vollständig in den Converter-Cache ein.

Wenn das Datenbanksystem eine Seitennummer nicht im Data-Cache findet, dann sucht es die Seitennummer im Converter-Cache und ermittelt daraus die physische Position der Datenseite in den Data-Volumes.

Bei jedem Savepoint schreibt das Datenbanksystem den Inhalt des Converter-Caches in den Datenbereich und gibt dem gespeicherten Converter eine Versionsnummer. Der beim nächsten Savepoint gesicherte Converter erhält die nächst höhere Versionsnummer. Jede Converter-Version entspricht einem konsistenten Zustand der Datenbankinstanz.

Der Converter realisiert ein Schattenspeicherkonzept. Das Datenbanksystem bewahrt den letzten in den Datenbereich geschriebenen Datenbankzustand (letzte Converter-Version) bis zum nächsten Savepoint auf. Wenn Datenbankbenutzer Datenseiten ändern möchten, liest das Datenbanksystem die Datenseiten zunächst in den Arbeitsspeicher und nimmt die Änderungen dort vor. Die geänderten Datenseiten schreibt das Datenbanksystem dann beim nächsten Savepoint an neue Orte in den Data-Volumes. Erst nach dem Ende des Savepoint gibt das Datenbanksystem die alten Datenseiten in den Data-Volumes wieder zum Überschreiben frei.

Die gleiche logische Seite kann also zu verschiedenen Zeiten an verschiedenen physischen Orten gespeichert sein.

Siehe auch:

Datenspeicherung

Caches (Arbeitsspeicher)

Volumes (permanenter Speicher)

Savepoint

Datenbereich einfrieren (Snapshot)


Datenbankwerkzeuge (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Datenbankwerkzeuge

Verwendung

Zur MaxDB-Software gehören mehrere Datenbankwerkzeuge.

Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie diese installieren, finden Sie im Abschnitt Download und im Strukturlink Installationshandbuch. Das SAP Solution Life Cycle Management (CCMS) ist nur in SAP-Systemen verfügbar. Weitere Informationen hierzu entnehmen Sie den entsprechenden SAP-Installationsleitfäden.

Funktionsumfang

Die folgende Tabelle zeigt, welche Datenbankwerkzeuge Sie für welche Aufgaben verwenden können.

Datenbankwerkzeuge

Name | Aufgabe | Typische Benutzer | Abwärts- kompatibel
Strukturlink Database Analyzer (CLI) | Analyse der Performance von Datenbankinstanzen (Nachfolger des Programms XWIZARD) | Supportmitarbeiter Datenbankadministrator | ja
Database Manager: Strukturlink Database Manager GUI Strukturlink Database Manager CLI | Anlegen und Verwalten von Datenbankinstanzen, DBM-Benutzern und Datenbankbenutzern | Datenbankadministrator | ja, ≥ 7.2
Strukturlink Event-Dispatcher | Verwalten von Events zum Automatisieren von Verwaltungsaufgaben | Datenbankadministrator | nein
Strukturlink Loader (CLI) | Exportieren und Importieren von Daten | Datenbankadministrator Anwendungsentwickler | ja, ≥ 7.3
SQL Studio: Strukturlink SQL Studio (GUI) Strukturlink SQLCLI Strukturlink Web SQL Studio | Zugriff auf Daten und den Datenbankkatalog, SQL-Abfragen, Anlegen und Verwalten von Datenbankobjekten und Datenbankbenutzern | Datenbankbenutzer Anwendungsentwickler | SQL Studio: ja, ≥ 7.4.00 SQLCLI: ja, ≥ 7.2
Strukturlink Synchronization Manager | Synchronisieren von Tabelleninhalten von zwei oder mehr Datenbankinstanzen. | Datenbankbenutzer | nein
Strukturlink VMAKE (CLI) | Entwicklungsumgebung Erstellen von MaxDB-Software nach Änderung des Quelltexts. | Open-Source-Benutzer, die den MaxDB-Quelltext modifizieren | nein
Strukturlink XCONS (CLI) | Datenbankkonsole. Anzeige detaillierter Informationen über die vom Datenbanksystem belegten Betriebssystemressourcen | Supportmitarbeiter Datenbankadministrator | ja
Strukturlink XUSER (CLI) | Anlegen und Verwalten von XUSER-Einträgen für eine vereinfachte Anmeldung an Datenbankwerkzeuge und Schnittstellen mit Benutzerschlüsseln | Supportmitarbeiter Datenbankadministrator Anwendungsentwickler | ja

Nur für SAP-Systeme:

Solution Life Cycle Management:

Strukturlink CCMS MaxDB (GUI)

Strukturlink CCMS SAP liveCache-Technologie (GUI)

Verwalten von MaxDB- und liveCache-Datenbankinstanzen in SAP-Systemen

SAP-Administrator

ja

Einige der Datenbankwerkzeuge liegen in mehreren Varianten vor:

· GUI: grafische Benutzungsoberfläche
muss lokal installiert werden, kann nur unter Microsoft Windows verwendet werden

· CLI: Kommandozeile
alle Funktionen verfügbar, kann für die Hintergrundverarbeitung verwendet und in Skript-Sprachen (z. B. Python, Perl) eingebettet werden, kann auf allen unterstützten Betriebssystemen verwendet werden

· Web: Web-Oberfläche
nur die wichtigsten Funktionen verfügbar, wird zentral installiert, Bedienung über einen Web-Browser, plattformunabhängig

Die Weiterentwicklung der folgenden Web Tools wurde eingestellt: Web DBM, Web Server, Web Server Manager. Diese Web Tools sind nur bis einschließlich Version 7.5 im MaxDB-Softwarepaket enthalten. Weitere Informationen finden SAP-Kunden im SAP-Hinweis 856940 (Bestellung von Web-Tools).

Siehe auch:

Technische Systemlandschaft

Architektur der Datenbankwerkzeuge

Schnittstellen

Dokumentation Strukturlink X-Server


Schnittstellen (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Schnittstellen

Verwendung

Über Schnittstellen können Sie mit verschiedenen Programmiersprachen und Anwendungen auf Funktionen des Datenbanksystems zugreifen. Auf diese Weise können Sie beispielsweise zusätzliche Funktionen programmieren oder Datenbankanwendungen an eine MaxDB-Datenbankinstanz anbinden.

Die Schnittstellen sind Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Download und im Strukturlink Installationshandbuch.

Schnittstellen

Name | Treiber/Module | Funktionsumfang | Voraussetzungen
Strukturlink Java | com.sap.dbtech.jdbc.DriverSapDB com.sap.dbtech.powertoys.DBM com.sap.dbtech.powertoys.Loader (alle enthalten in sapdbc.jar) | SQL-Anweisungen ausführen (JDBC-Treiber) DBM-Kommandos ausführen Loader-Kommandos ausführen | JDBC 2.0: JRE 1.2 bzw. JDK 1.2 (für die Anwendungsentwicklung) JDBC 3.0: JRE 1.4, 1.5 bzw. JDK 1.4, 1.5 (für die Anwendungsentwicklung)
Strukturlink ODBC | sqlod32[w].dll (Microsoft Windows) libsqlod[w].so (UNIX/Linux) | SQL-Anweisungen ausführen | Microsoft Windows: ODBC Driver Manager 3.52 oder höher und MDAC 2.7 oder höher UNIX/Linux: direktes Linken an die Anwendung oder Verwenden eines Treiber-Managers (unixODBC 2.0.9 oder iODBC 3.0.5)
Strukturlink Perl | DBD::MaxDB SAP::DBTech::dbm SAP::DBTech::loader | SQL-Anweisungen ausführen DBM-Kommandos ausführen Loader-Kommandos ausführen | MaxDB SQLDBC SDK Perl 4 (5.6.1) Perl DBI (1.2.1)
Strukturlink PHP | php_maxdb.[dll|so] | SQL-Anweisungen ausführen | PHP 4.3.6 oder höher
Strukturlink Python | sdb.sql sdb.dbm sdb.loader | SQL-Anweisungen ausführen DBM-Kommandos ausführen Loader-Kommandos ausführen | Python 1.5 - 2.3
Strukturlink SQLDBC | libSQLDBC.[dll|so] | SQL-Anweisungen ausführen Anwendungen und Schnittstellen entwickeln |
Strukturlink WebDAV | webdavServletMaxDB-<version>.war | auf eine Dokumentenablage in einer MaxDB-Datenbankinstanz über das WebDAV-Protokoll zugreifen | Servlet-Container
Strukturlink Backint for MaxDB |  | Beschreibung der Backint for MaxDB-Schnittstelle für Sicherungswerkzeuge anderer Anbieter |

Siehe auch:

Architektur der Schnittstellen

Entwicklung von Datenbankanwendungen


Technische Systemlandschaft (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Technische Systemlandschaft

Verwendung

Für die Arbeit mit Datenbankinstanzen stehen Ihnen mehrere Datenbankwerkzeuge zur Verfügung. Um eine Datenbankinstanz in einer Datenbankanwendung zu nutzen, binden Sie die Datenbankinstanz über eine Schnittstelle in die Datenbankanwendung ein.

Datenbankanwendung, Datenbankwerkzeuge, Schnittstellen und Datenbankinstanz können sich auf unterschiedlichen Rechnern in einem Netzwerk befinden. Um auf eine Datenbankinstanz zuzugreifen, die auf einem entfernten Rechner läuft, benötigen die Datenbankwerkzeuge und Schnittstellen den MaxDB X-Server (Kommunikationsserver).

Zugriff auf eine MaxDB-Datenbankinstanz von entfernten Rechnern aus

Diese Grafik wird im zugehörigen Text erklärt

Integration

Sie können MaxDB-Datenbankinstanzen in SAP-Systemen einsetzen.

In SAP-Systemen steht Datenverschlüsselung zur Verfügung.

MaxDB in SAP-Systemen

SAP-System | SQL-Schnittstelle zu MaxDB
SAP NetWeaver AS | MaxDB SQLDBC
SAP NetWeaver BI | MaxDB SQLDBC
SAP NetWeaver EP | MaxDB JDBC
SAP NetWeaver MI (Clients) | MaxDB JDBC
SAP NetWeaver MDM | MaxDB JDBC
SAP NetWeaver XI | MaxDB JDBC

Integration von MaxDB in den SAP NetWeaver AS

Diese Grafik wird im zugehörigen Text erklärt

Beispiel

· Beispiel: Systemlandschaft mit MaxDB-Datenbankinstanz

· Beispiel: SAP-Systemlandschaft mit zwei MaxDB-Datenbankinstanzen

Siehe auch:

Netzwerkkommunikation

Architektur der Datenbankwerkzeuge

Prozessstruktur

Datenbankwerkzeuge

Schnittstellen

Dokumentation Strukturlink X-Server

Synchronization Manager, Strukturlink Technische Systemlandschaft


Netzwerkkommunikation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Netzwerkkommunikation

Um die Verbindung zu einer Datenbankinstanz auf einem entfernten Computer herzustellen, verwenden Datenbankanwendungen und Datenbankwerkzeuge den MaxDB X-Server, der auf dem entfernten Computer läuft (siehe Dokumentation Strukturlink X-Server). Der X-Server arbeitet instanzübergreifend: auch wenn auf einem Computer mehrere Datenbankinstanzen installiert sind, läuft immer nur ein X-Server.

Um die Verbindung zwischen Client und X-Server abzusichern, können SAP-Kunden SSL/TLS verwenden (siehe Datenverschlüsselung).

Verbindungen zu Datenbankinstanzen auf dem lokalen Computer verwenden Shared Memory. Um zu erzwingen, dass das Datenbanksystem die Verbindung trotzdem über den X-Server herstellt, geben Sie beim Anmelden an die Datenbankinstanz als Datenbankrechner localhost an.

Beispiel

Auf dem Computer ROME sind die beiden Datenbankinstanzen HOTELDB und SHOPDB installiert.

· Ein Benutzer greift mit dem Database Manager GUI (DBMGUI) vom Computer PARMA aus über den X-Server auf dem Computer ROME auf die Datenbankinstanz HOTELDB zu.

· Ein zweiter Benutzer greift mit SQL Studio vom Computer GENUA über denselben X-Server auf die Datenbankinstanz SHOPDB auf dem Computer ROME zu.

· Ein dritter, lokaler Benutzer greift mit dem Database Manager GUI auf die Datenbankinstanz HOTELDB zu, ohne den X-Server zu verwenden.

Beispiele für die Kommunikation zwischen Clients und Datenbankinstanz

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Technische Systemlandschaft

X-Server, Strukturlink Ports und Protokolle des X-Servers


Architektur der Datenbankwerkzeuge (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Architektur der Datenbankwerkzeuge

Die Datenbankwerkzeuge liegen teilweise in mehreren Varianten vor. Einige Datenbankwerkzeuge bestehen außerdem aus mehreren Komponenten.

Wenn sich das Datenbankwerkzeug auf einem anderen Rechner als die Datenbankinstanz befindet, dann benötigt das Datenbanksystem für die Kommunikation zusätzlich den MaxDB X-Server (Kommunikationsserver). Siehe Dokumentation zum Strukturlink X-Server.

Database Manager

Das Datenbankwerkzeug Database Manager besteht aus einem Client-Teil und einem Server-Teil. Der Client-Teil des Database Manager liegt in mehreren Varianten vor:

● Database Manager GUI (DBMGUI): grafische Benutzungsoberfläche

● Database Manager CLI (DBMCLI): Benutzung über die Kommandozeile

● Database Manager RFC (DBMRFC): nur in SAP-Systemen, Schnittstelle zum SAP-System

Um mit dem Kern zu kommunizieren und Kommandos auszuführen, benötigen alle Varianten den DBM-Server. Der DBM-Server ist der Server-Teil des Datenbankwerkzeugs Database Manager und befindet sich immer auf dem gleichen Rechner wie die Datenbankinstanz. Der Event-Dispatcher kommuniziert ebenfalls über den DBM-Server mit dem Kern.

Wenn sich der Client-Teil des Database Manager/der Event-Dispatcher und die Datenbankinstanz auf unterschiedlichen Rechnern befinden, dann benötigen sie für die Kommunikation mit dem DBM-Server zusätzlich den X-Server.

Database Manager und Event-Dispatcher

Diese Grafik wird im zugehörigen Text erklärt

Query Tools

Die Query Tools sind die Datenbankwerkzeuge, mit denen Sie SQL-Anweisungen ausführen können. Sie liegen in drei Varianten vor:

● Web SQL Studio: webbasierte Benutzungsoberfläche

● SQL Studio: grafische Benutzungsoberfläche

● SQLCLI: Benutzung über die Kommandozeile

Web SQL kommuniziert über den Servlet-Container (z. B. Apache Tomcat oder SAP NetWeaver AS) mit dem Kern, SQL Studio über die ODBC-Schnittstelle mit dem Kern und SQLCLI direkt mit dem Kern. Wenn sich die Datenbankwerkzeuge auf einem anderen Rechner als die Datenbankinstanz befinden, dann benötigen sie für die Kommunikation mit der Datenbankinstanz zusätzlich den X-Server.

Query Tools

Diese Grafik wird im zugehörigen Text erklärt

Loader

Das Datenbankwerkzeug Loader besteht aus einem Client-Teil und einem Server-Teil:

● Loader-Client

● Loader-Server

Der Loader-Client übermittelt die zu verarbeitenden Kommandos. Der Loader-Server stellt die Verbindung zwischen dem Loader-Client und der Datenbankinstanz her und verarbeitet die Kommandos. Loader-Client und Loader-Server sind immer auf demselben Rechner installiert (LoaderCLI).

Sie können über folgende Schnittstellen auf den Loader zugreifen:

● Python-Modul: sdb.loader

● Perl-Modul: SAP::DBTech::loader

● Java-Schnittstelle des Loader: com.sap.dbtech.powertoys.Loader

Wenn Sie Dateien als Datenträger für den Export oder Import der Daten verwenden, dann empfehlen wir Ihnen, den Loader-Server auf dem Rechner zu installieren, auf dem auch die Dateien liegen.

Wenn sich Loader und Datenbankinstanz auf unterschiedlichen Rechnern befinden, dann benötigt der Loader zur Kommunikation mit der Datenbankinstanz zusätzlich den X-Server.

Loader

Diese Grafik wird im zugehörigen Text erklärt

XUSER

Das Datenbankwerkzeug XUSER kommuniziert nicht direkt mit den anderen Datenbankwerkzeugen oder dem Kern, sondern schreibt nur XUSER-Informationen ins Dateisystem. Datenbankwerkzeuge, die XUSER verwenden, greifen direkt auf die XUSER-Informationen im Dateisystem zu.

XUSER

Diese Grafik wird im zugehörigen Text erklärt

Synchronization Manager

Siehe Synchronization Manager, Strukturlink Technische Systemlandschaft.

Weitere Datenbankwerkzeuge

Das Datenbankwerkzeug XCONS kommuniziert direkt mit dem Kern. Es muss auf demselben Rechner wie die Datenbankinstanz installiert sein.

Das Datenbankwerkzeug Database Analyzer kommuniziert über ODBC mit dem Kern. Wenn der Database Analyzer und die Datenbankinstanz auf unterschiedlichen Rechnern installiert sind, dann benötigt der Database Analyzer für die Kommunikation mit der Datenbankinstanz zusätzlich den X-Server.

Weitere Datenbankwerkzeuge

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Datenbankwerkzeuge

Schnittstellen

Technische Systemlandschaft


Architektur der Schnittstellen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Architektur der Schnittstellen

Datenbankanwendungen, wie z. B. SAP-Systeme, greifen über Schnittstellen auf MaxDB-Datenbankinstanzen zu.

Wenn sich die Datenbankanwendung und somit auch die MaxDB-Schnittstelle auf einem anderen Rechner als die Datenbankinstanz befindet, dann benötigt das Datenbanksystem für die Kommunikation zusätzlich den MaxDB X-Server (Kommunikationsserver). Die JDBC-Schnittstelle benötigt auch für die lokale Kommunikation den MaxDB X-Server. Siehe auch Dokumentation zum Strukturlink X-Server.

Zugriff von Datenbankanwendungen über MaxDB-Schnittstellen auf eine MaxDB-Datenbankinstanz

Diese Grafik wird im zugehörigen Text erklärt

Zugriff auf eine Dokumentenablage in einer MaxDB-Datenbankinstanz über das MaxDB-WebDAV-Servlet

Diese Grafik wird im zugehörigen Text erklärt


Datenverschlüsselung (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Datenverschlüsselung

Verwendung

Das Datenbanksystem kann die Daten, die zwischen Client (Datenbankwerkzeug oder Datenbankanwendung) und X-Server übertragen werden, mit SSL/TLS verschlüsseln.

Datenverschlüsselung steht nur in SAP-Systemen zur Verfügung.

Voraussetzungen

Sie haben Ihr SAP-System für die SSL/TLS-Verschlüsselung konfiguriert. Informationen hierzu finden Sie im Installationsleitfaden (siehe Download).

Aktivitäten

Um die in einer Datenbanksitzung übertragenen Daten zu verschlüsseln, wählen Sie beim Anmelden an die Datenbankinstanz die entsprechende Option.

Siehe auch:

Authentifizierung

Netzwerkkommunikation

Technische Systemlandschaft


Beispiel: Systemlandschaft mit MaxDB-Datenbankinstanz (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Systemlandschaft mit MaxDB-Datenbankinstanz

Im internen Netz (LAN) befindet sich eine MaxDB-Datenbankinstanz. Auf demselben Rechner läuft ein MaxDB X-Server. Über diesen X-Server greifen folgende Komponenten auf die MaxDB-Datenbankinstanz zu:

· eine Datenbankanwendung (über die MaxDB-JDBC-Schnittstelle)

· das Datenbankwerkzeug MaxDB SQLCLI (Datenabfragen mittels SQL)

· das Datenbankwerkzeug MaxDB Database Manager GUI (DBMGUI; Verwaltungsaktionen)

Beispiel für eine Systemlandschaft

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Beispiel: SAP-Systemlandschaft mit zwei MaxDB-Datenbankinstanzen

Technische Systemlandschaft


Beispiel: SAP-Systemlandschaft mit zwei MaxDB-Datenbankinstanzen

Diese Grafik wird im zugehörigen Text erklärt Beispiel: SAP-Systemlandschaft mit zwei MaxDB-Datenbankinstanzen

MaxDB-Datenbankinstanzen im Netz LAN 2

Im Netz LAN 2 befinden sich zwei MaxDB-Datenbankinstanzen auf zwei verschiedenen Rechnern. Auf jedem Rechner läuft ein MaxDB X-Server (Kommunikationsserver). Über diese X-Server greifen SAP-Systeme aus den Netzen LAN 1 und LAN 3 auf die MaxDB-Datenbankinstanzen in LAN 2 zu.

SAP NetWeaver AS-System im Netz LAN 1

Ein SAP NetWeaver AS-System greift aus LAN 1 über SAProuter auf eine MaxDB-Datenbankinstanz in LAN 2 zu:

· Für Datenabfragen mittels SQL verwendet das AS-System die MaxDB-SQLDBC-Schnittstelle.

· Für Verwaltungsaktionen mittels MaxDB Database Manager verwendet das AS-System die SAP RFC Library und den MaxDB DBM RFC Server.

Die Kommunikation kann auch ohne SAProuter erfolgen. Alle Verbindungen können mit SSL verschlüsselt werden (siehe Datenverschlüsselung).

SAP NetWeaver EP-System im Netz LAN 3

Ein SAP NetWeaver EP-System greift aus LAN 3 auf eine MaxDB-Datenbankinstanz in LAN 2 zu:

· Für Datenabfragen mittels SQL verwendet das EP-System die MaxDB-JDBC-Schnittstelle.

· Für Verwaltungsaktionen mittels MaxDB Database Manager verwendet das EP-System die SAP RFC Library und den MaxDB DBM RFC Server.

Die Kommunikation kann auch über einen SAProuter erfolgen. Alle Verbindungen können mit SSL verschlüsselt werden.

Beispiel für eine SAP-Systemlandschaft

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Beispiel: Systemlandschaft mit MaxDB-Datenbankinstanz

Technische Systemlandschaft


Prozessstruktur (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Prozessstruktur

Auf Microsoft Windows läuft der Kern der Datenbankinstanz als einzelner Betriebssystemprozess. Auf UNIX gehören zwei Betriebssystemprozesse zum Kern: beim Starten erzeugt das Datenbanksystem einen Watchdog-Prozess, der sich sofort verzweigt und den eigentlichen Kern als Prozess startet. Siehe Übersicht der Prozesse und Übersicht der Dienste.

Der Kern führt alle zentralen Datenbankaufgaben (Tasks) der Datenbankinstanz aus. Hierzu gehören z. B. das Aufbauen von Verbindungen, das Lesen und Schreiben von Daten (I/O), das Überwachen der Datenbankinstanz und das Bearbeiten von SQL-Anfragen (User-Tasks). Jedem an die Datenbank angemeldeten Benutzer ist eine User-Task zugeordnet. Die User-Tasks erzeugen die Hauptlast für den Prozessor. Siehe Übersicht der Tasks und Übersicht der Task-Zustände.

Für Tasks, die parallel ausgeführt werden sollen, erzeugt der Kern Betriebssystem-Threads.

Auf Linux-Systemen ohne NPTL (Native Posix Thread Library) wird jeder Thread durch einen Klonprozess simuliert.

Threads und Tasks einer Datenbankinstanz

Diese Grafik wird im zugehörigen Text erklärt

Das Datenbanksystem unterscheidet zwei Arten von Threads:

· User-Kernel-Threads (UKTs)

UKTs verarbeiten die Client-Anfragen. Sie sind diejenigen Threads, die am meisten Prozessorzeit verbrauchen. Eine Datenbankinstanz hat in der Regel mehrere UKTs.

In der Regel teilen sich mehrere Tasks einen UKT. Das Datenbanksystem steuert, in welcher Reihenfolge die Tasks in einem UKT laufen, und kann so Konflikte bei Zugriffen auf Ressourcen vermeiden (Task-Wechsel). Um die Tasks optimal auf die UKTs zu verteilen, führt das Datenbanksystem ein internes Load-Balancing durch.

· Spezial-Threads

Spezial-Threads stellen Dienste für die User-Kernel-Threads zur Verfügung. In Spezial-Threads führt das Datenbanksystem diejenigen Tasks aus, deren Dauer nicht vorhersehbar ist, wie z. B. Betriebssystemaufrufe zum Lesen und Schreiben auf Volumes und Verbindungsanfragen von Clients. Das Datenbanksystem arbeitet Spezial-Threads asynchron zu den User-Kernel-Threads ab. Siehe Übersicht der Spezial-Threads.

Siehe auch:

Technische Systemlandschaft


Übersicht der Prozesse (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Übersicht der Prozesse

Verwendung

MaxDB-Datenbankinstanz und -Datenbankwerkzeuge erzeugen eine Reihe von Betriebssystemprozessen.

Auf Linux-Systemen ohne NPTL (Native Posix Thread Library) wird jeder Thread durch einen Klonprozess simuliert. In der Prozessliste finden Sie deswegen unter Umständen mehrere gleichnamige MaxDB-Prozesse.

MaxDB-Prozesse

Prozess (Microsoft Windows) | Prozess (UNIX/Linux) | Funktion
- | niserver | Teil des X-Servers, der für die NI-Unterstützung in SAP-Systemen zuständig ist
dbanalyzer.exe | dbanalyzer | Database Analyzer
dbmcli.exe | dbmcli | Database Manager CLI
dbmevtdisp.exe | dbmevtdisp | Event-Dispatcher
DBMGui3.exe | - | Database Manager GUI
dbmsrv.exe | dbmsrv | DBM-Server
dbmsrvscd.exe | dbmsrvscd | Event-Scheduler
kernel.exe | kernel | Kern des Datenbanksystems Jede Datenbankinstanz hat ihren eigenen Kernprozess.
loadercli.exe | loadercli | Loader
serv.exe | vserver | MaxDB X-Server Auf UNIX/Linux wird für jede Datenbankverbindung ein neuer Kindprozess gestartet.
sqlcli.exe | sqlcli | SQLCLI
SQLSto.exe | - | SQL Studio
vmksrv.exe | vmksrv | VMAKE-Server
wahttp.exe | wahttp | MaxDB Web Server

Siehe auch:

Prozessstruktur


Übersicht der Dienste (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Übersicht der Dienste

Verwendung

Zum Datenbanksystem MaxDB gehören die folgenden Dienste (Services).

MaxDB-Dienste

Name

Beschreibung

Microsoft Windows:

· SAPDB: <database_name>

· SAPDB: <database_name> (slow)

· SAPDB: <database_name> (omststknl.exe)

UNIX/Linux:

· kernel

· quickknl

· slowknl

Kern der Datenbankinstanz <database_name>

Dieser Dienst liegt für jede Datenbankinstanz in mehreren Ausprägungen vor: jeweils ein Dienst für jede Kernvariante und ein Dienst für interne Testzwecke (omststknl.exe). Nur jeweils einer dieser Dienste kann laufen (Systemvorschlag: fast-Kernvariante).

Wenn dieser Dienst gestoppt ist, dann wurde entweder die Datenbankinstanz in den Betriebszustand OFFLINE gebracht, oder die Datenbankinstanz ist abgestürzt. Starten Sie diesen Dienst nicht manuell, sondern mit dem Datenbankwerkzeug Database Manager (Starten der Datenbankinstanz).

Auf Microsoft Windows können Sie beim Anlegen einer neuen Datenbankinstanz angeben, dass dieser Dienst beim Starten des Rechners automatisch gestartet wird.

SAPDB: .<generated_name>

SAPDB: .M760011

Service-Datenbankinstanz

Die Service-Datenbankinstanz wird vom Datenbanksystem ausschließlich für interne Verwaltungsaufgaben verwendet, z. B. für die Überprüfung von Sicherungen. Bei Bedarf startet das Datenbanksystem die Service-Datenbankinstanz.

Das Datenbanksystem legt die Service-Datenbankinstanz bei der Installation der Datenbanksoftware unter einem generierten Namen <generated_name> an.

Microsoft Windows:

· XServer

UNIX/Linux:

· vserver

X-Server

Der X-Server muss u. a. in den folgenden Fällen gestartet sein:

· Clients von anderen Rechnern greifen auf die lokale Datenbankinstanz zu

· Sie verwenden die JDBC-Schnittstelle

Beispiel

Sie zeigen auf Microsoft Windows die eingetragenen Dienste an. Folgende Dienste gehören zur Datenbankinstanz DEMODB:

SAP DB: DEMODB started

SAP DB: DEMODB (slow)

SAP DB: DEMODB (omststknl.exe)

Die Kernvariante fast (Systemvorschlag) der Datenbankinstanz DEMODB wurde gestartet.

Siehe auch:

Prozessstruktur

Automatischer Start


Übersicht der Tasks (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Übersicht der Tasks

Verwendung

Das Datenbanksystem führt Aufgaben, die von Benutzern oder dem Kern gestellt werden, in Tasks aus.

Übersicht wichtiger Tasks

Name

Beschreibung

Event-Task

Die Event-Task nimmt im Kern erzeugte Events entgegen und kommuniziert sie nach außen.

Log-Writer

Die Log-Writer schreiben die Log-Einträge aus der Log-Warteschlange in den Log-Bereich, z. B. bei einem COMMIT oder einem Savepoint.

Pager (Data-Writer)

Die Pager schreiben bei jedem Savepoint die Daten vom Data-Cache in die Data-Volumes. Bei einem großen Data-Cache kann die Durchführung eines Savepoints sehr lange dauern. Wenn notwendig, werden die Pager auch zwischen dem Ende eines Savepoints und dem Beginn des nächsten Savepoints aktiv, um asynchron die geänderten Daten zu sichern.

Beim Restart lesen die Pager die Converter-Seiten von den Data-Volumes in den Converter ein. Die Anzahl der benötigten Pager wird vom System berechnet. Sie ist in erster Linie von der Größe des Data-Cache und der Anzahl der Data-Volumes abhängig.

Server-Task

Die Server-Tasks parallelisieren Datenbankfunktionen. Sie werden z. B. für das Sichern von Daten und Log-Einträgen, das Anlegen von Indizes und das endgültige Löschen von Tabellen benötigt. Während eines Restarts lesen die Server-Tasks Log-Einträge ein und arbeiten parallel Transaktionen ab.

Die Anzahl der zur Verfügung stehenden Server-Tasks können Sie mit dem speziellen Datenbankparameter MAXSERVERTASKS konfigurieren.

Server-Tasks können je nach Verwendung einen speziellen Namen haben, beispielsweise Savepoint, BackupMedium, BackupVolume, AutosaveCoordinator, AutosaveMedium.

Timer-Task

Die Timer-Task ist für Timeouts von SQL-Sperranforderungen zuständig und überprüft, ob Log-Einträge gesichert werden können.

Trace-Writer-Task

Die Trace-Writer-Task schreibt bei eingeschaltetem Datenbank-Trace die Trace-Einträge in den Arbeitsspeicher.

User-Task

User-Tasks führen SQL-Anweisungen aus.

Wenn ein Datenbankbenutzer eine Datenbanksitzung eröffnet, ordnet das Datenbanksystem diesem Datenbankbenutzer eine User-Task fest zu.

Die Anzahl der zur Verfügung stehenden User-Tasks konfigurieren Sie mit dem allgemeinen Datenbankparameter MAXUSERTASKS.

Utility-Task

Die Utility-Task führt Verwaltungsaufgaben aus.

Aktivitäten

Um Informationen zu den Tasks anzuzeigen, verwenden Sie den Database Manager oder XCONS und in SAP-Systemen den Datenbank- bzw. liveCache-Assistenten. Siehe

● Database Manager GUI, Strukturlink Datenbanksitzungen anzeigen

● Database Manager CLI, Strukturlink show

● Dokumentation Strukturlink XCONS

● Datenbankverwaltung im CCMS, Strukturlink Task-Manager

Siehe auch:

Übersicht der Task-Zustände

Prozessstruktur


Übersicht der Task-Zustände (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Übersicht der Task-Zustände

Verwendung

Der Task-Zustand zeigt, ob eine Task aktiv ist und welche Aufgabe sie gerade ausführt.

Übersicht der Task-Zustände

Name

Beschreibung

AsynClose

Task schließt I/O-Ports nach dem Sichern oder Wiederherstellen

AsynCntl

Task ermittelt Parameter oder initialisiert ein Sicherungsgerät

AsynIO

Task führt asynchrone I/O-Operation aus (beim Sichern oder Wiederherstellen)

AsynOpen

Task öffnet I/O-Ports zum Sichern oder Wiederherstellen

AsynWaitRead/Write

Task wartet auf das Ende einer I/O-Operation beim Sichern oder Wiederherstellen

Command reply

Task übermittelt das Ergebnis eines Auftrags an die Anwendung

Command wait

Datenbanksitzung ohne Auftrag

Connect wait

freie Datenbanksitzung

DcomObjCalled

Task führt eine Datenbankprozedur oder ein COM-Objekt aus

Diaginit

Task initialisiert die datenbankinterne Trace-Datei

Inactive

Task ist in einem Initialzustand und verfügt über keine Ressourcen (z. B. Stack)

InsertEvent

Task generiert ein Event

IO wait (W/R)

Task wartet auf das Ergebnis einer I/O-Operation (W:Schreiben, R:Lesen)

Locked

Task wurde während des Herunterfahrens des Kerns gesperrt (zur Vermeidung eines Re-Scheduling dieser Task)

RescheduleMsec

kurzzeitige Wartesituation, Task läuft nach einer vorgegebenen Zeitspanne (in Mikrosekunden) automatisch weiter

Runnable

Task ist unmittelbar lauffähig, wurde aber wegen langer Laufzeit oder Bevorzugung einer anderen Task verdrängt

Running

Task läuft, nutzt CPU

sleep

kurzzeitige Wartesituation, Task läuft nach einer vorgegebenen Zeitspanne automatisch weiter

Stopped

Task wurde vom Kern suspendiert und wartet darauf weiterzulaufen

Terminated

Task oder Datenbanksitzung wurde beendet

UNKNOWN

Task-Zustand ist unbekannt

Vattach

Task öffnet I/O-Ports (Volumes, normaler Betrieb)

Vbegexcl

Task wartet darauf, einen geschützten Bereich zu betreten

Vdetach

Task schließt I/O-Ports (Volumes, normaler Betrieb)

Vdevsize

Task ermittelt die Größe eines Volumes oder formatiert ein Volume

Vdualvectorio

Task führt Vektor-I/O-Operation (Schreiben oder Lesen) auf zwei Volumes parallel aus

Vendexcl

Task verlässt einen geschützten Bereich

VenterRWRegion

Task wartet darauf, einen geschützten Bereich (Reader/Writer Region) zu betreten

Vfclose

Task schließt eine Datei

Vfopen

Task öffnet eine Datei

Vfwrite

Task schreibt in eine Datei

VleaveRWRegion

Task verlässt einen geschützten Bereich (Reader/Writer Region)

Vopmsg

Task schreibt eine Meldung in eine der folgenden Datenbankdateien: knldiag, knldiag.err, opmsg[n]

Vrelease

Task beendet die Datenbanksitzung

Vshutdown

Task ändert den Betriebszustand der Datenbankinstanz von ONLINE in ADMIN

Vsuspend

Task ist suspendiert und wartet darauf, von einer anderen Task explizit geweckt (Vresume) zu werden

Es gibt spezielle Vsuspend-Wartezustände, die jeweils unter einem eigenen Namen angezeigt werden. In der folgenden Liste sind die wichtigsten dieser Zustände aufgeführt.

TableRootExcl: kann beim Zugriff auf B*-Bäume auftreten, die permanente Daten repräsentieren
Eine Task versucht, eine Schreibsperre auf die Wurzelseite eines B*-Baums zu setzen, muss aber wegen einer Sperrkollision warten. Tasks fordern Schreibsperren auf B*-Bäumen unter anderem bei strukturverändernden Operationen wie z. B. einem Baumausgleich an.

TableRootShare:
kann beim Zugriff auf B*-Bäume auftreten, die permanente Daten repräsentieren
Eine Task versucht, eine Lesesperre auf die Wurzelseite eines B*-Baums zu setzen, muss aber wegen einer Sperrkollision warten. In der Regel beginnen alle Operationen auf einem B*-Baum mit einer Lesesperre, die dann beim Absteigen in den B*-Baum verfeinert wird, also in eine Schreib- oder Lesesperre auf Blattebene erweitert wird.

TableNodeExcl, TableNodeShare: analoge Wartezustände bei Sperrkollisionen auf Blattebene

Für B*-Bäumen, die einen Index oder temporäre Daten repräsentieren, gibt es ähnliche Zustande, wie z. B. InvRootExcl, InvRootShare, InvNodeExcl, TempRootExcl und TempRootExcl.

Für Seitenketten gibt es ähnliche Zustände, wie z. B. ObjRootExcl, ObjNodeExcl, ObjNodeShare, UndoRootExcl, UndoRootShare und UndoNodeExcl.

DC OvFlow: Der Data-Cache wird gerade stark genutzt und kann keine neuen Daten aufnehmen. Erst wenn wieder Seiten aus dem Data-Cache in die Volumes geschrieben wurden, kann der Data-Cache wieder neue Daten aufnehmen. Wenn Sie häufig DC OvFlow-Zustände beobachten, dann überprüfen Sie, ob Ihr Data-Cache groß genug ist oder das von Ihnen verwendete I/O-System zu langsam ist.

LogQ FULL: Die Log-Warteschlangen werden gerade stark genutzt und können keine neuen Redo-Log-Einträge aufnehmen. Erst wenn der Log-Writer Daten aus den Log-Warteschlangen in den Log-Bereich geschrieben hat, können die Log-Warteschlangen wieder Redo-Log-Einträge aufnehmen. Wenn Sie häufig LogQ Full-Zustände beobachten, dann überprüfen Sie, ob Ihre Log-Warteschlangen zu klein konfiguriert sind oder ob das von Ihnen verwendete I/O-System zu langsam ist.

DB FULL: Der Datenbereich ist voll und kann keine weiteren Seiten mehr aufnehmen. Fügen Sie ein neues Data-Volume hinzu.

Vvectorio

Task führt Vektor-I/O-Operation (Schreiben oder Lesen) aus

Vwait

Task wartet darauf, von einer anderen Task explizit (Vsignal) geweckt zu werden. Beispiel: Task wartet auf eine SQL-Sperre

WaitForEvent

Task wartet auf ein Event

Aktivitäten

Um Informationen zu den Tasks anzuzeigen, verwenden Sie den Database Manager oder XCONS und in SAP-Systemen den Datenbank- bzw. liveCache-Assistenten. Siehe

● Database Manager GUI, Strukturlink Datenbanksitzungen anzeigen

● Database Manager CLI, Strukturlink show

● Dokumentation Strukturlink XCONS

● Datenbankverwaltung im CCMS, Strukturlink Task-Manager

Siehe auch:

Übersicht der Tasks

Prozessstruktur


Task-Wechsel (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Task-Wechsel

Verwendung

In einem User-Kernel-Thread kann immer nur eine Task den Prozessor nutzen, also im Zustand running sein (laufen). Alle anderen Tasks sind entweder lauffähig, oder sie warten auf ein externes Ereignis wie z. B. das Ende einer I/O-Operation und eine entsprechende Meldung, um wieder lauffähig zu werden.

Wenn die laufende Task den Prozessor nicht mehr benötigt, löst sie einen Task-Wechsel aus (kooperativer Task-Wechsel), und die nächste Task im selben User-Kernel-Thread kann den Prozessor nutzen.

Beispiel

Die folgende Abbildung zeigt auf vereinfachte Weise, wie drei Tasks in einem User-Kernel-Thread abwechselnd laufen.

Diese Grafik wird im zugehörigen Text erklärt

Zunächst läuft Task 1. Task 2 und Task 3 sind lauffähig.

...

1. Task 1 schickt eine I/O-Anforderung und versetzt sich in einen wartenden Zustand.

Task 2 ist die nächste lauffähige Task; sie setzt ihre Ausführung fort.

2. Task 2 schickt eine I/O-Anforderung und versetzt sich in einen wartenden Zustand.

Task 3 ist die nächste lauffähige Task; sie setzt ihre Ausführung fort.

3. Die I/O-Operation von Task 1 ist beendet. Task 1 erhält eine entsprechende Meldung und ist wieder lauffähig.

4. Task 3 schickt eine I/O-Anforderung und versetzt sich in einen wartenden Zustand.

Task 1 ist die nächste lauffähige Task; sie setzt ihre Ausführung fort.

5. Die I/O-Operation von Task 2 ist beendet. Task 2 erhält eine entsprechende Meldung und ist wieder lauffähig.

6. Task 1 ist beendet.

Task 2 ist die nächste lauffähige Task; sie setzt ihre Ausführung fort.

Siehe auch:

Übersicht der Tasks

Übersicht der Task-Zustände

Prozessstruktur


Load-Balancing (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Load-Balancing

Verwendung

Das Betriebssystem hat keinen Einfluss darauf, wie das Datenbanksystem die Tasks einer Datenbankinstanz auf die zur Verfügung stehenden User-Kernel-Threads verteilt. Es kann daher nicht eingreifen, wenn z. B. ein User-Kernel-Thread einen Prozessor zu 100% auslastet, die anderen drei Prozessoren des Rechners jedoch überhaupt nicht genutzt werden.

Innerhalb eines User-Kernel-Threads verhalten Tasks sich kooperativ, das heißt sie entscheiden selbst, wann sie sich suspendieren und die nächste wartende Task weiterarbeiten lassen (siehe Task-Wechsel). Dieses Verhalten kann dazu führen, dass eine einzelne Task alle anderen Tasks im selben User-Kernel-Thread lange blockiert.

Um die Tasks optimal auf die User-Kernel-Threads zu verteilen, führt das Datenbanksystem deswegen ein internes Load-Balancing durch. So erreicht das Datenbanksystem insbesondere auf Rechnern mit mehreren Prozessoren eine bessere Ressourcenauslastung und für die einzelnen Benutzer kürzere Antwortzeiten.

Um die maximale Anzahl der parallel genutzten Prozessoren zu konfigurieren, verwenden Sie den allgemeinen Datenbankparameter MAXCPU.

Aktivitäten

Beim Load-Balancing verteilt der Timer (Spezial-Thread) die Tasks auf die einzelnen User-Kernel-Threads. Der Timer analysiert in regelmäßigen Abständen, wie lange die einzelnen Tasks in den User-Kernel-Threads bereits gewartet haben (siehe Übersicht der Task-Zustände) und summiert diese Wartezeiten für jeden User-Kernel-Thread auf.

Wenn die Summe der Wartezeiten in einem User-Kernel-Thread sehr viel größer ist als in einem anderen, dann veranlasst der Timer, dass diejenige Task, die im ersten User-Kernel-Thread am längsten gewartet hat, in den zweiten User-Kernel-Thread verschoben wird.

Um das Load-Balancing zu aktivieren, setzen Sie den speziellen Datenbankparameter LOAD_BALANCING_CHK auf einen Wert größer als Null.

Beispiel

User-Kernel-Thread UKT1 enthält die Tasks T1, T2, T3, UKT2 die Task T4. T1 befindet sich in einer langen Schleife, während T2 und T3 warten.

Die Summe der Wartezeiten in UKT1 beträgt 210 ms, in UKT 2 jedoch nur 10 ms. Deswegen wird T2, die in UKT1 am längsten gewartet hat, in UKT2 verschoben.

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Prozessstruktur


Übersicht der Spezial-Threads (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Übersicht der Spezial-Threads

Verwendung

Spezial-Threads stellen Dienste für die User-Kernel-Threads zur Verfügung.

Übersicht der Spezial-Threads

Name

Beschreibung

Coordinator

Der Coordinator-Thread überwacht alle Threads der Datenbankinstanz. Er ist der erste Thread, den das Datenbanksystem beim Starten der Datenbankinstanz erzeugt, und koordiniert die Startvorgänge der weiteren Threads. Wenn es zu einem Fehler kommt, kann der Coordinator-Thread andere Threads stoppen.

Requester

Der Requester-Thread nimmt Anmeldungen der Benutzer an die Datenbankinstanz entgegen und ordnet sie einer User-Task innerhalb eines User-Kernel-Threads zu.

Console

Der Console-Thread verarbeitet die Anfragen des Datenbankwerkzeugs XCONS (Datenbankkonsole).

Clock

nur auf Microsoft Windows

Der Clock-Thread setzt eine globale Zeitvariable, an der sich interne Zeitmessungen orientieren.

dev<n>

Dev-Threads sind dafür zuständig, Schreib- und Leseaufträge der Tasks in den Volumes durchzuführen.

Die Dev-Threads sind fortlaufend nummeriert (dev<n>). Der Dev-Thread dev0 spielt eine besondere Rolle: er koordiniert und überwacht die anderen Dev-Threads.

Die Anzahl der Dev-Threads ist in erster Linie von der Anzahl der Volumes in der Datenbankinstanz abhängig. Das Datenbanksystem aktiviert für jedes Data-Volume und jedes Log-Volume zwei Dev-Threads. Wenn der Datenbank-Trace eingeschaltet ist, dann aktiviert das Datenbanksystem für diesen ebenfalls einen Dev-Thread.

asdev<i>

Um Datensicherungen durchzuführen, aktiviert das Datenbanksystem temporäre Dev-Threads asdev<i> zum Lesen und Schreiben der Daten.

Timer

Timer-Threads sind für die Zeitüberwachung bei Timeouts, das interne Load-Balancing und für weitere zeitabhängige interne Steuerungen zuständig.

Worker

Der Worker-Thread ist für die Meldung abgeschlossener asynchroner I/O-Operationen zuständig.

Aktivitäten

Um Informationen zu den Threads anzuzeigen, verwenden Sie den Database Manager oder XCONS und in SAP-Systemen den Datenbank- bzw. liveCache-Assistenten. Siehe

● Database Manager GUI, Strukturlink Datenbanksitzungen anzeigen

● Database Manager CLI, Strukturlink show

● Dokumentation Strukturlink XCONS

● Datenbankverwaltung im CCMS, Strukturlink Kernel-Threads

Siehe auch:

Prozessstruktur


Anlegen und Konfigurieren einer Datenbankinstanz (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Anlegen und Konfigurieren einer Datenbankinstanz

Einsatzmöglichkeiten

Um eine Datenbankinstanz anzulegen und zu konfigurieren, können Sie den Installation Manager oder das Datenbankwerkzeug Database Manager verwenden.

Voraussetzungen

Wenn Sie den Database Manager zum Anlegen einer Datenbankinstanz verwenden, müssen Sie zunächst die Datenbanksoftware installieren (siehe Strukturlink Installationshandbuch).

Ablauf

...

1. Sie planen Ihre Datenbankinstanz.

Siehe

○ Datenbankinstanz planen

○ Technische Restriktionen

2. Sie legen die Datenbankinstanz an.

Siehe

○ Installationshandbuch, Strukturlink Verwenden des Installation Manager

○ Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz

○ Database Manager CLI, Strukturlink db_create

○ Tutorial Datenbankverwaltung, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Sie können Vorlagen verwenden (siehe Vorlagen für Datenbankinstanzen).

Beim Anlegen der Datenbankinstanz konfigurieren Sie unter anderem folgende Eigenschaften:

○ Datenbankname (siehe Konventionen für Datenbanknamen)

○ Data- und Log-Volumes (Größe, Verzeichnisse)

○ Werte wichtiger Datenbankparameter (siehe Datenbankparameter)

Mit dem speziellen Datenbankparameter _UNICODE legen Sie fest, ob die Namen von Datenbankobjekten im Datenbankkatalog, wie z. B. Tabellen- und Spaltennamen, in Unicode gespeichert werden. Diesen Datenbankparameter können Sie im späteren Betrieb nicht mehr ändern.

○ weitere Betriebseigenschaften (siehe z. B. Automatischer Start und Log-Einstellungen)

○ erste Benutzer (siehe Benutzer, Authentifizierung und Berechtigungen)

3. Das Datenbanksystem überführt die Datenbankinstanz in den Betriebszustand ONLINE

Ergebnis

Die Datenbankinstanz ist betriebsbereit. Sie können nun in der Datenbankinstanz Tabellen anlegen und Daten einfügen (siehe Datenbank-Design).

Siehe auch:

Konfigurationsdateien

MaxDB-Sicherheitsleitfaden

Installationshandbuch, Strukturlink Verzeichnisse


Datenbankinstanz planen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankinstanz planen

Bevor Sie eine Datenbankinstanz anlegen, planen Sie die Konfiguration. Beantworten Sie hierzu insbesondere die folgenden Fragen:

● Wie viele Anwendungsdaten erwarten Sie (Datenbankgröße)?

● Welche Hardware ist für Ihre Datenbankinstanz geeignet?

● Benötigen Sie Unicode-Unterstützung?

Die meisten Einstellungen, die Sie beim Anlegen der Datenbankinstanz wählen, können Sie später wieder ändern.

Allgemeine Hinweise

● Wenn Sie mehrere Datenbankinstanzen betreiben, dann legen Sie jede Datenbankinstanz auf einem separaten Rechner an.

Datenbankgröße und Konfiguration der Volumes

Beim Anlegen der Datenbankinstanz legen Sie Data-Volumes an, in denen das Datenbanksystem die Anwendungsdaten speichert. Die Größe der Datenbankinstanz wird im Wesentlichen durch die Größe des Datenbereichs (Menge aller Data-Volumes) bestimmt, siehe Datenspeicherung.

Sie können später Volumes hinzufügen oder löschen.

Die Geschwindigkeit, mit der das Datenbanksystem Daten aus den Volumes auslesen und in die Volumes schreiben kann, hat großen Einfluss auf die Performance der Datenbankinstanz. Um eine gute Performance im späteren Betrieb der Datenbankinstanz zu erreichen, beachten Sie beim Anlegen und Konfigurieren einer neuen Datenbankinstanz die folgenden Empfehlungen.

● Beachten Sie die Regeln für Größe und Anzahl der Volumes, siehe technische Restriktionen.

● Für SAP-Systeme empfehlen wir, Data-Volumes vom Typ Datei nach folgender Berechnungsformel zu konfigurieren: Berechnen Sie die Quadratwurzel aus der Größe, die für die Data-Volumes insgesamt in GB zur Verfügung steht, und runden Sie nach oben auf eine ganze Zahl.

Weitere Informationen finden SAP-Kunden im SAP-Hinweis 820824.

Für die Data-Volumes stehen 50 GB zur Verfügung.

√50=7,07 ergibt eine empfohlene Anzahl von 8 Data-Volumes.

● Verwenden Sie für Data-Volumes und für Log-Volumes verschiedene Platten. Weil das Datenbanksystem in den Log-Volumes alle Datenänderungen protokolliert, sind die Log-Volumes die Bereiche der Datenbankinstanz mit der höchsten Schreibaktivität.

● Verwenden Sie für Swap- und Paging-Bereiche andere Platten als für die Log-Volumes.

● Spiegeln Sie den Log-Bereich und den Datenbereich mit hardwarebasierten Mitteln, beispielsweise indem Sie RAID-5- oder RAID-1-Systeme einsetzen. Achten Sie bei der Auswahl des RAID-Systems darauf, dass der RAID-Controller eine gute Schreib-Performance aufweist und dass Caches auch bei einem Stromausfall noch auf Platte gesichert werden.

● Auch wenn Sie RAID-5-Systeme verwenden, legen Sie mehrere Data-Volumes für die Datenbankinstanz an. Weil einige Parallelisierungstechniken des Datenbanksystems von der Anzahl der Data-Volumes abhängen, erzielen Sie mit mehreren Data-Volumes eine bessere Performance als mit einem Data-Volume.

● Wenn Sie für die Volumes mehrere Platten verwenden, dann setzen Sie Platten mit einheitlichen Leistungsdaten, insbesondere einheitlichen Zugriffsgeschwindigkeiten, ein. Nur so erreichen Sie, dass die Platten gleichmäßig gefüllt werden.

● Wenn Sie fehlertolerante Hardware einsetzen, dann erweitern Sie die Kapazität nur mit gleichartiger Hardware. Erweitern Sie z. B. RAID-5-Systeme nur mit RAID-5-Systemen.

● Legen Sie Log-Volumes nicht auf RAID-5-Systemen an, sondern nur auf dedizierten Platten oder RAID-1-Systemen.

● Verwenden Sie auf UNIX Raw-Devices für Data- und Log-Volumes. Das Datenbanksystem kann auf Raw-Devices in der Regel schneller zugreifen als auf Dateien. Außerdem kann das Betriebssystem Raw Devices in der Regel schneller booten, weil es diese nicht die Konsistenz des Dateisystems überprüfen muss.

Beachten Sie folgende Hinweise:

○ Konfigurieren Sie Data-Volumes vom Typ Raw Device nicht größer als die tatsächliche Größe der Raw-Devices.

○ Wenn das Betriebssystem ein Ausschalten des eigenen Buffer-Cache unterstützt, dann konfigurieren Sie den Support-Datenbankparameter USE_OPEN_DIRECT entsprechend. Siehe Support-Datenbankparameter.

○ Stellen Sie sicher, dass nur jeweils eine Datenbankinstanz auf ein Raw-Device zugreift.

● Nur für UNIX/Linux: Verwenden Sie für die Volumes keine Festplatten mit einem Journal-Dateisystem. Journal-Dateisysteme führen unter anderem eine eigene Protokollierung von Datenänderungen durch, was für das Datenbanksystem überflüssig ist und zu Performance-Einbußen führt.

● Wählen Sie geeignete Einstellungen für die Protokollierung von Transaktionen, siehe Log-Einstellungen.

○ Wenn eine hardwarebasierte Spiegelung des Log-Bereichs nicht möglich ist, dann stellen Sie den Log-Modus so ein, dass das Datenbanksystem den Log-Bereich spiegelt.

○ Schalten Sie den Überschreibmodus für den Log-Bereich aus.

○ Lassen Sie die Redo-Log-Verwaltung immer eingeschaltet.

Unicode-Unterstützung

In einer MaxDB-Datenbankinstanz können Sie Unicode für den Datenbankkatalog und für Anwendungsdaten verwenden. Siehe Glossar, Unicode.

Die Unicode-Unterstützung des Datenbankkatalogs können Sie später nicht mehr ändern.

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Datenbank-Design

Verwaltung


Technische Restriktionen (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Technische Restriktionen

Die folgende Tabelle listet die wichtigsten technischen Restriktionen auf, die für MaxDB-Datenbankinstanzen gelten. Abhängig vom verwendeten Betriebssystem kann es zusätzliche Restriktionen geben.

Technische Restriktionen für eine Datenbankinstanz

Beschreibung | maximaler Wert
Anzahl der Data-Volumes | 4095 2 (VOLUMENO_BIT_COUNT) -1
Größe eines Data-Volume | 512 GB Seitengröße x (2 (32-VOLUMENO_BIT_COUNT) -1)
Anzahl der Log-Volumes | keine Einschränkung
Größe eines Log-Volume | 32 TB
Gesamtgröße der Datenbankinstanz (Datenbereich + Log-Bereich) | 64 TB

Das Datenbanksystem greift auf Datenseiten in den Data-Volumes über deren Converter-Blockadresse zu. Die Converter-Blockadresse ist 32 Bit lang und setzt sich aus der Volume-Nummer und dem Offset im Data-Volume zusammen. Je größer Sie den speziellen Datenbankparameter VOLUMENO_BIT_COUNT wählen, desto mehr Data-Volumes können Sie verwenden. Die maximal erlaubte Größe der einzelnen Data-Volumes verringert sich dabei entsprechend. Es gilt: 6 ≤ VOLUMENO_BIT_COUNT ≤ 12 und Seitengröße = 8 KB.

Das Datenbanksystem behandelt den Log-Bereich als Einheit. In der Regel konfigurieren Sie zunächst ein Log-Volume. Wenn dieses Log-Volume zu klein wird, dann können Sie dieses Log-Volume entweder vergrößern (erfordert Restart der Datenbankinstanz) oder ein weiteres Log-Volume hinzufügen (kann im Betriebszustand ONLINE erfolgen).

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

SQL-Referenzhandbuch, Restriktionen für SQL-Anweisungen


Vorlagen für Datenbankinstanzen (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Vorlagen für Datenbankinstanzen

Verwendung

Installation Manager und Database Manager GUI stellen Vorlagen für das Anlegen einer Datenbankinstanz zur Verfügung, in denen die wichtigsten Eigenschaften der Datenbankinstanz bereits konfiguriert sind.

Funktionsumfang

Für SAP-Installationen stehen Ihnen im Installation Manager zusätzliche Vorlagen zur Verfügung.

Desktop PC / Laptop

Mit dieser Vorlage legen Sie eine Datenbankinstanz an, die für einen Einzelbenutzer ausgelegt ist. Mit dieser Datenbankinstanz können Sie einfache Datenbankanwendungen entwickeln, Tests durchführen und die in den MaxDB-Tutorials beschriebenen Beispiele nachvollziehen.

Eigenschaft | Vorschlagswert (Microsoft Windows)*
Datenbankname | MAXDB1
Arbeitsverzeichnis | C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\MAXDB1\
Data-Volumes | ● Verzeichnis C:\Documents and Settings\All Users\Application Data\sdb\data\MAXDB1\data\ ● Größe des ersten Data-Volume 256 MB
Log-Volumes | ● Verzeichnis C:\Documents and Settings\All Users\Application Data\sdb\data\MAXDB1\log\ ● Größe des ersten Log-Volume 50 MB
Größe von Data-Cache und Converter (Datenbankparameter CACHE_SIZE) | 2500 Seiten (ca. 20 MB)
Anzahl CPUs (Datenbankparameter MAXCPU) | 1
parallele Datenbanksitzungen (Datenbankparameter MAXUSERTASKS) | 10
Unicode-Unterstützung (Datenbankparameter _UNICODE) | YES
automatischer Start | eingeschaltet
Log-Einstellungen | ● Log-Modus: nicht gespiegelt ● Überschreibmodus für den Log-Bereich: eingeschaltet ● Redo-Log-Verwaltung: eingeschaltet
automatische Log-Sicherung | ausgeschaltet
automatische Erweiterung des Datenbereichs | eingeschaltet
automatische Aktualisierung der Statistiken | eingeschaltet
Name des Datenbanksystemadministrators (SYSDBA-Benutzer) | DBADMIN
Name/Kennwort des ersten DBM-Benutzers | DBM/DBM
Namen/Kennwörter von Datenbankbenutzern | DBSERVICE/SECRET MONA/RED

* Auf UNIX/Linux werden dieselben Eigenschaften konfiguriert, mit folgenden Ausnahmen:

● Arbeitsverzeichnis: /var/opt/sdb/data/wrk/MAXDB1/

● Data-Volumes/Verzeichnis: /var/opt/sdb/data/MAXDB1/data/

● Log-Volumes/Verzeichnis: /var/opt/sdb/data/MAXDB1/log/

● automatischer Start: Funktion nicht verfügbar

Custom

Mit dieser Vorlage legen Sie eine Datenbankinstanz an, die für größere Anwendungen und mehrere Benutzer geeignet ist.

Eigenschaft | Vorschlagswert (Microsoft Windows)**
Datenbankname | MAXDB1
Arbeitsverzeichnis | C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\MAXDB1\
Data-Volumes | ● Verzeichnis C:\Documents and Settings\All Users\Application Data\sdb\data\MAXDB1\data\ ● Größe des ersten Data-Volume 1024 MB
Log-Volumes | ● Verzeichnis C:\Documents and Settings\All Users\Application Data\sdb\data\MAXDB1\log\ ● Größe des ersten Log-Volume 50 MB
Größe von Data-Cache und Converter (Datenbankparameter CACHE_SIZE) | 91648 Seiten (716 MB)
Anzahl CPUs (Datenbankparameter MAXCPU) | 1
parallele Datenbanksitzungen (Datenbankparameter MAXUSERTASKS) | 20
Unicode-Unterstützung (Datenbankparameter _UNICODE) | YES
automatischer Start | eingeschaltet
Log-Einstellungen | ● Log-Modus: nicht gespiegelt ● Überschreibmodus für den Log-Bereich: ausgeschaltet ● Redo-Log-Verwaltung: eingeschaltet
automatische Log-Sicherung | eingeschaltet
automatische Erweiterung des Datenbereichs | eingeschaltet
automatische Aktualisierung der Statistiken | ausgeschaltet
Name des Datenbanksystemadministrators (SYSDBA-Benutzer) | DBADMIN
Name des ersten DBM-Benutzers | DBM

** Auf UNIX/Linux werden dieselben Eigenschaften konfiguriert, mit folgenden Ausnahmen:

● Arbeitsverzeichnis: /var/opt/sdb/data/wrk/MAXDB1/

● Data-Volumes/Verzeichnis: /var/opt/sdb/data/MAXDB1/data/

● Log-Volumes/Verzeichnis: /var/opt/sdb/data/MAXDB1/log/

● automatischer Start: Funktion nicht verfügbar

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz


Konventionen für Datenbanknamen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Konventionen für Datenbanknamen

Beim Anlegen einer Datenbankinstanz definieren Sie den Namen der Datenbankinstanz (Datenbankname). Es gelten folgende Einschränkungen:

· Die maximale Länge eines Datenbanknamens beträgt 8 Zeichen.

· Der Datenbankname darf nur Zeichen aus dem Zeichensatz 7-bit ASCII enthalten.

· Der Datenbankname darf nicht mit einem Unterstrich oder einem Punkt beginnen.

· Beim Anlegen der Datenbankinstanz wandelt das Datenbanksystem alle Kleinbuchstaben im Datenbanknamen automatisch in Großbuchstaben um.

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Das Datenbanksystem im Überblick


Datenbankparameter (SAP-Bibliothek - Grundwissen)

Objektdokumentation Datenbankparameter

Definition

Datenbankparameter legen grundlegende Eigenschaften der Datenbankinstanz fest.

Es gibt folgende Typen von Datenbankparametern:

● allgemeine Datenbankparameter

● spezielle Datenbankparameter

● Support-Datenbankparameter

● liveCache-Datenbankparameter (nur für SAP liveCache-Datenbankinstanzen)

Datenbankparameter haben eine Reihe von Eigenschaften (siehe Eigenschaften von Datenbankparametern).

Vorschlagsparameterdatei

Die Vorschlagsparameterdatei cserv.pcf (siehe Konfigurationsdateien) enthält die Vorschlagswerte, Wertebereiche, Berechnungsvorschriften und Eigenschaften der Datenbankparameter. Die Vorschlagsparameterdatei und eine mit den Vorschlagswerten belegte Datenbankparameterdatei werden mit der Datenbankinstanz installiert. Wenn ein Benutzer einen Datenbankparameter ändert, speichert das Datenbanksystem den neuen Wert des Datenbankparameters in der Datenbankparameterdatei.

Verwendung

Beim Anlegen einer neuen Datenbankinstanz können Sie entweder den Systemvorschlag für die Datenbankparameter übernehmen, die Datenbank-Parameterdatei aus einer anderen Datenbankinstanz kopieren oder die Datenbank-Parameterdatei aus einer vollständigen Datensicherung einlesen. Sie können die Werte der meisten Datenbankparameter später ändern.

Änderungen von Datenbankparametern werden erst nach dem nächsten Restart der Datenbankinstanz wirksam.

Einige Datenbankparameter können Sie auch im laufenden Betrieb ändern (siehe Beschreibung der einzelnen Datenbankparameter). Für diese Datenbankparameter können Sie außerdem wählen, wie lange die Änderung wirksam ist:

■ nur bis zum nächsten Restart

■ erst nach dem nächsten Restart

■ sofort und dauerhaft

Das Datenbanksystem speichert die Werte der Datenbankparameter im Binärformat in der Datenbankparameterdatei der Datenbankinstanz. Um die Datenbankparameter anzuzeigen oder zu ändern, verwenden Sie den Database Manager und in SAP-Systemen das CCMS:

● Database Manager GUI, Strukturlink Datenbankparameter anzeigen und ändern

● Database Manager CLI, Strukturlink param_put

● Tutorial Datenbankverwaltung, Strukturlink Werte von Datenbankparametern ändern

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Parameter

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Parameter konfigurieren

Die Historie der Werte der Datenbankparameter können Sie ebenfalls mit diesen Werkzeugen anzeigen.

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz


Allgemeine Datenbankparameter (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Allgemeine Datenbankparameter

Verwendung

In der folgenden Übersicht sind die allgemeinen Datenbankparameter beschrieben. Für Informationen zu weiteren Datenbankparametern siehe Spezielle Datenbankparameter, Support-Datenbankparameter und liveCache-Datenbankparameter.

Änderungen von Datenbankparametern werden erst nach einem Restart der Datenbankinstanz wirksam.

Einige Datenbankparameter können Sie auch im laufenden Betrieb ändern. Für diese Datenbankparameter können Sie außerdem wählen, wie lange die Änderung wirksam ist:

■ nur bis zum nächsten Restart

■ erst nach dem nächsten Restart

■ sofort und dauerhaft

Allgemeine Datenbankparameter (General)

Parameter | Bedeutung | Wie kann der Parameter geändert werden?
CACHE_SIZE | Größe des I/O-Buffer-Cache (in Seiten) | Änderung erst nach Restart wirksam
INSTANCE_TYPE | Datenbankinstanztyp Sie definieren den Datenbankinstanztyp beim Anlegen der Datenbankinstanz und können ihn später nicht mehr ändern. | kann nicht geändert werden
KERNELVERSION | Version der Datenbanksoftware Wenn Sie eine neue Version der Datenbanksoftware installieren, dann aktualisiert das Datenbanksystem den Wert dieses Parameters. | kann nicht geändert werden
LOG_MIRRORED | gibt an, ob das Datenbanksystem den Log-Bereich spiegelt (siehe Log-Modus) Der Parameter ist nur für das Anlegen eines Spiegel-Volume mittels Database Manager CLI relevant. Der Database Manager GUI setzt diesen Parameter beim Anlegen eines Spiegel-Volume automatisch. | Änderung erst nach Restart wirksam
LOG_SEGMENT_SIZE | Log-Segmentgröße (in Seiten) Wenn die automatische Log-Sicherung aktiviert ist, dann führt das Datenbanksystem immer dann eine automatische Log-Sicherung durch, sobald ein Log-Segment voll ist. 0: System verwendet als Log-Segmentgröße 1/3 des Log-Bereichs ≤50% des Log-Bereichs: System verwendet den in LOG_SEGMENT-SIZE definierten Wert > 50% des Log-Bereichs: System verwendet als Log-Segmentgröße 50% des Log-Bereichs | Änderung erst nach Restart wirksam
MAXBACKUPDEVS | maximale Anzahl der Dateien oder Bandgeräte beim parallelen Sichern | Änderung erst nach Restart wirksam
MAXCPU | maximale Anzahl der Prozessoren, auf die das Datenbanksystem die User-Tasks verteilen kann Beachten Sie, dass die Betriebssystemressourcen Ihres Rechners außer für das Datenbanksystem auch für andere Prozesse zur Verfügung stehen müssen. | Änderung erst nach Restart wirksam
MAXDATAVOLUMES | maximale Anzahl der Data-Volumes | Änderung erst nach Restart wirksam
MAXLOCKS | maximale Anzahl von Einträgen in der Sperrliste | Änderung erst nach Restart wirksam
MAXLOGVOLUMES | maximale Anzahl der Log-Volumes | Änderung erst nach Restart wirksam
MAXUSERTASKS | maximale Anzahl gleichzeitig aktiver User-Tasks und damit die maximale Anzahl von Datenbanksitzungen Wenn diese Anzahl erreicht ist, dann kann sich kein weiterer Benutzer mehr an dieser Datenbankinstanz anmelden. Wenn Sie für MAXUSERTASKS einen sehr großen Wert wählen, dann benötigt das Datenbanksystem viel Adressraum, insbesondere bei lokaler Kommunikation über Shared Memory. | Änderung erst nach Restart wirksam
MCOD | MCOD = Multiple Components One Database zeigt bei SAP-Systemen an, ob mehrere Anwendungen die Datenbank nutzen | Änderung erst nach Restart wirksam
RUNDIRECTORY | Arbeitsverzeichnis der Datenbankinstanz | Änderung erst nach Restart wirksam

Siehe auch:

Arbeitsspeicherbereiche

Volumes (permanenter Speicher)


Spezielle Datenbankparameter (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Spezielle Datenbankparameter

Verwendung

In der folgenden Übersicht sind die speziellen Datenbankparameter beschrieben. Für Informationen zu weiteren Datenbankparametern siehe Allgemeine Datenbankparameter, Support-Datenbankparameter und liveCache-Datenbankparameter.

Änderungen von Datenbankparametern werden erst nach einem Restart der Datenbankinstanz wirksam.

Einige Datenbankparameter können Sie auch im laufenden Betrieb ändern. Für diese Datenbankparameter können Sie außerdem wählen, wie lange die Änderung wirksam ist:

■ nur bis zum nächsten Restart

■ erst nach dem nächsten Restart

■ sofort und dauerhaft

Spezielle Datenbankparameter (Extended)

Parameter

Bedeutung

Wie kann der Parameter geändert werden?

_COMMENT

Beschreibung der Datenbankinstanz

Änderung erst nach Restart wirksam

_DATA_CACHE_RGNS

Anzahl der kritischen Abschnitte, in die der Data-Cache unterteilt ist

Diese Unterteilung erlaubt ein paralleles Schreiben in den Data-Cache. Der Parameter wird vom Datenbanksystem berechnet und ist nicht änderbar. Sie können den Parameter jedoch für Testzwecke mit dem Support-Datenbankparameter XP_DATA_CACHE_RGNS übersteuern.

kann nicht geändert werden

_MAX_MESSAGE_FILES

maximale Anzahl von Trace-Dateien, die parallel geöffnet werden können

Änderung erst nach Restart wirksam

_MAXEVENTS

maximale Anzahl der vom Kern im Arbeitsspeicher abgelegten Events, die vom Database Manager verarbeitet werden sollen

Änderung erst nach Restart wirksam

_ROW_RGNS

Anzahl der kritischen Abschnitte, in die die Menge aller Zeilen in der Sperrliste unterteilt ist

Diese Unterteilung ermöglicht einen parallelen Zugriff auf die Sperrliste.

Änderung erst nach Restart wirksam

_TAB_RGNS

Anzahl der kritischen Abschnitte, in die die Menge aller Tabellen in der Sperrliste unterteilt ist

Diese Unterteilung ermöglicht einen parallelen Zugriff auf die Sperrliste.

Änderung erst nach Restart wirksam

_TRANS_RGNS

Anzahl der kritischen Abschnitte, in die die Menge aller Transaktionen in der Sperrliste unterteilt ist

Diese Unterteilung ermöglicht einen parallelen Zugriff auf die Sperrliste.

Änderung erst nach Restart wirksam

_UNICODE

legt fest, ob das Datenbanksystem für die Namen von Datenbankobjekten im Datenbankkatalog als Zeichensatz Unicode verwendet

Sie legen den Datenbankparameter beim Anlegen der Datenbankinstanz fest. Nachträglich können Sie den Datenbankparameter nur ändern, indem Sie die Datenbankinstanz neu initialisieren. Dabei gehen jedoch alle Anwendungsdaten verloren.

AUTO_RECREATE_BAD_INDEXES

als BAD markierte Indizes werden nach einem Wiederherstellen automatisch neu erzeugt

Änderung erst nach Restart wirksam

BACKUP_BLOCK_CNT

Blockgröße, die das Datenbanksystem beim Sichern für das Beschreiben der Datenträger verwendet

nur für Bänder sinnvoll, die über eine optimale Blockgröße verfügen

Änderung erst nach Restart wirksam

CAT_CACHE_SUPPLY

Speichergröße des Catalog-Cache für alle User-Tasks (in Seiten)

Änderung erst nach Restart wirksam

CLUSTERED_LOBS

gibt an, ob das Datenbanksystem LONG-Werte (LOBs) im Datenbereich als Cluster speichert

kann im laufenden Betrieb geändert werden

CLUSTER_WRITE_THRESHOLD

minimale Anzahl von Blöcken, die das Datenbanksystem noch als Cluster im Datenbereich speichert

kann im laufenden Betrieb geändert werden

CONVERTER_REGIONS

Anzahl der kritischen Abschnitte, in die der Converter unterteilt ist

Diese Unterteilung erlaubt ein paralleles Schreiben in den Converter.

Der Parameter wird vom Datenbanksystem berechnet und ist nicht änderbar. Sie können den Parameter jedoch für Testzwecke mit dem Support-Datenbankparameter XP_CONVERTER_REGIONS übersteuern.

Änderung erst nach Restart wirksam

DATE_TIME_FORMAT

Systemvorschlag für das Datums- und Zeitformat

Sie können das Datums- und Zeitformat mit Datenbankwerkzeugen (z. B. im Loader über standard_date_mask) oder durch entsprechende Angaben in SQL-Anweisungen (datetimeformat) übersteuern. Siehe Datums- und Zeitformat.

kann im laufenden Betrieb geändert werden

DEADLOCK_DETECTION

maximale Suchtiefe bei der Deadlock-Erkennung

Deadlocks, die das Datenbanksystem bis zur vorgegebenen Suchtiefe nicht entdeckt hat, werden nur durch einen Timeout aufgelöst (siehe REQUEST_TIMEOUT).

Änderung erst nach Restart wirksam

DEFAULT_CODE

Systemvorschlag für das Codeattribut, gilt nur für Spaltenwerte der Datentypen CHAR[ACTER], VARCHAR und LONG[VARCHAR]

kann im laufenden Betrieb geändert werden

DIAG_HISTORY_NUM

Anzahl der Historien im Verzeichnis <diag_history_path>

Änderung erst nach Restart wirksam

DIAG_HISTORY_PATH

Verzeichnis <diag_history_path>, in dem das Datenbanksystem nach einem Datenbankfehler Diagnosedateien (Sicherungen der wichtigsten Protokolldateien und Speicherauszüge) speichert

Änderung erst nach Restart wirksam

FILEDIR_SPINLOCKPOOL_SIZE

Anzahl der Spinlocks, die für Reader-Writer-Locks für das interne Dateiverzeichnis zur Verfügung stehen

Änderung erst nach Restart wirksam

FORMAT_DATAVOLUME

unterdrückt die Formatierung der Data-Volumes beim Anlegen einer neuen Datenbankinstanz; nur für Testzwecke sinnvoll

Änderung erst nach Restart wirksam

FORMATTING_MODE

Das Datenbanksystem formatiert beim Anlegen der Datenbankinstanz die Volumes. Mit diesem Parameter legen Sie die Art der Formatierung fest. Eine parallele Formatierung ist nur für solche Data-Volumes vom Typ Datei sinnvoll, die auf unterschiedlichen Festplatten liegen.

Änderung erst nach Restart wirksam

HASHED_RESULTSET

gibt an, ob das Datenbanksystem Ergebnismengen, die beim Ausführen von Joins entstehen, mit einem Hash-Verfahren optimiert

kann im laufenden Betrieb geändert werden

HASHED_RESULTSET_CACHESIZE

maximale Größe des Arbeitsspeichers, den das Datenbanksystem für Ergebnismengen verwenden kann, die mit einem Hash-Verfahren optimiert werden (in kB)

kann im laufenden Betrieb geändert werden

HIRES_TIMER_TYPE

Art der Zeitmessung, die vom Kern für interne Operationen verwendet wird; nur sinnvoll für Mehrprozessorenrechner, bei denen es zu Synchronisationsproblemen zwischen den CPUs kommt

Änderung erst nach Restart wirksam

HS_DELAY_TIME_<NNN>

nur für Hot-Standby-Systeme

Zeitverzögerung in Sekunden, mit der die Standby-Instanz NNN Datenänderungen der Master-Instanz nachvollzieht

Änderung erst nach Restart wirksam

HS_NODE_<NNN>

nur für Hot-Standby-Systeme

Rechnername / IP-Adresse der Hot Standby-Instanz NNN

Der Vorschlagswert für die Master-Instanz ist HSS_NODE_001.

Änderung erst nach Restart wirksam

HS_STORAGE_DLL

nur für Hot-Standby-Systeme

Name der Bibliothek, über die das das Hot-Standby-System das Speicherverwaltungssystem anspricht

Der Vorschlagswert ist libhsscopy.

Änderung erst nach Restart wirksam

HS_SYNC_INTERVAL

nur für Hot-Standby-Systeme

minimale Zeitspanne, die zwischen zwei Befehlen der Master-Instanz zum Synchronisieren der Standby-Instanzen liegt (in s)

Änderung erst nach Restart wirksam

JOIN_MAXTAB_LEVEL4

Parameter des SQL-Optimierers; siehe JOIN_SEARCH_LEVEL

kann im laufenden Betrieb geändert werden

JOIN_MAXTAB_LEVEL9

Parameter des SQL-Optimierers; siehe JOIN_SEARCH_LEVEL

kann im laufenden Betrieb geändert werden

JOIN_SEARCH_LEVEL

Algorithmus, den der SQL-Optimierer für die Join-Sequenz-Suche verwendet; siehe Datenbankparameter JOIN_SEARCH_LEVEL

kann im laufenden Betrieb geändert werden

JOIN_TABLEBUFFER

Größe des Puffers, den der SQL-Optimierer pro Join-Schritt für eine Leseoperation nutzen kann

Änderung erst nach Restart wirksam

KERNELDIAGSIZE

Größe der Protokolldatei knldiag (in KB)

Änderung erst nach Restart wirksam

LOAD_BALANCING_CHK

Zeitabstand, in dem das Datenbanksystem überprüft, ob ein Load-Balancing sinnvoll ist (in s)

Änderung erst nach Restart wirksam

LOG_BACKUP_TO_PIPE

NO: Nachdem eine Log-Sicherung in eine Pipe ausgelesen wurde, wird anschließend die Verbindung zur Pipe geschlossen, ohne dass das Datenbanksystem eine Information darüber hat, ob das die Log-Sicherung erfolgreich war. Der Log-Bereich wird deswegen nicht wieder freigegeben und kann nicht erneut beschrieben werden, so dass er unter Umständen voll wird und keine weiteren Datenänderungen mehr möglich sind.

YES: Das Datenbanksystem kann bereits in die Pipe geschriebene Log-Einträge im Log-Bereich wieder überschreiben. Beachten Sie, dass das System nicht prüft, ob die Log-Sicherung über die Pipe erfolgreich war.

Änderung erst nach Restart wirksam

LOG_IO_QUEUE

Größe der einzelnen Log-Warteschlangen (in Seiten)

Änderung erst nach Restart wirksam

LRU_FOR_SCAN

gibt an, ob der gesamte Data-Cache für Scans verwendet wird

kann im laufenden Betrieb geändert werden

MAX_HASHTABLE_MEMORY

maximale Größe des Arbeitsspeichers, den das Datenbanksystem für das Zwischenspeichern aller Tabellen beim Ausführen von Joins verwenden kann (in kB)

kann im laufenden Betrieb geändert werden

MAX_SINGLE_HASHTABLE_SIZE

maximale Größe des Arbeitsspeichers, den das Datenbanksystem für das Zwischenspeichern einer einzelnen Tabelle beim Ausführen eines Joins verwenden kann (in kB)

kann im laufenden Betrieb geändert werden

MAXRGN_REQUEST

maximale Anzahl von Zugriffsversuchen einer Task auf einen kritischen Abschnitt

Wenn diese Zahl überschritten wird, gibt die Task den Zugriff auf die CPU für eine andere Task des gleichen User-Kernel-Thread frei.

kann im laufenden Betrieb geändert werden

MAXSERVERTASKS

Anzahl von Server-Tasks

Änderung erst nach Restart wirksam

MEM_ENHANCE_LIMIT

maximal zusätzlich zu verwendender Speicher, der durch ein Memory Scalability Enhancement wie z. B. möglich wird (in MB)

Änderung erst nach Restart wirksam

MEMORY_ALLOCATION_LIMIT

maximal von der Datenbankinstanz zu verwendender Speicher (in KB)

Änderung erst nach Restart wirksam

MP_RGN_LOOP

maximale Anzahl von Zugriffsversuchen einer Task auf einen kritischen Abschnitt, der durch eine andere Task gesperrt ist

Wenn diese Zahl überschritten wird, ändert die zugreifende Task ihren Zustand in "wartend".

kann im laufenden Betrieb geändert werden

OFFICIAL_NODE

nur für Hot-Standby-Systeme

Virtual Server Name, über den der Cluster von außen angesprochen wird

Der Systemadministrator weist den Virtual Server Name initial dem Rechner zu, auf dem die Master-Instanz des Hot-Standby-Systems läuft. Wenn die Master-Instanz ausfällt, dann geht der Name auf jene Standby-Instanz über, die die Master-Rolle übernimmt.

Änderung erst nach Restart wirksam

OPTIM_INV_ONLY

legt fest, ob der SQL-Optimierer für Joins die Index-Only-Strategie verwendet

kann im laufenden Betrieb geändert werden

OPTIM_MAX_MERGE

beeinflusst die Entscheidung, ob der SQL-Optimierer eine Index-Merge-Strategie verwendet

Wenn die Anzahl der zusammenzuführenden Seiten eines Index den Wert von OPTIM_MAX_MERGE übersteigt, dann verwendet der SQL-Optimierer diesen Index nicht für eine Index-Merge-Strategie.

kann im laufenden Betrieb geändert werden

OPTIMIZE_QUERYREWRITE

Automatisches Umformen von SQL-Anweisungen

Vorschlagswert für Softwareversionen >= 7.6: OPERATOR (das Datenbanksystem formt SQL-Anweisungen um).

Um das alte Umformungsverhalten (Versionen < 7.6) zu aktivieren, wählen Sie STATEMENT.

kann im laufenden Betrieb geändert werden

REQUEST_TIMEOUT

maximale Wartezeit auf Freigabe einer Sperre (in s); begrenzt für alle Datenbanksitzungen das Warten auf die Freigabe einer Sperre durch andere Benutzer

Wenn eine Sperranforderung in der hier definierten Zeit nicht erfüllt werden kann, erfolgt eine Rückmeldung an die wartende Datenbanksitzung. Das Datenbanksystem macht die gegebenenfalls vorher durchgeführten Änderungen innerhalb der Transaktionen rückgängig (ROLLBACK).

Änderung erst nach Restart wirksam

SEQUENCE_CACHE

Größe des Sequence-Cache (in Seiten)

Änderung erst nach Restart wirksam

SESSION_TIMEOUT

Timeout-Wert für Datenbanksitzungen (in s)

kann im laufenden Betrieb geändert werden

SHAREDSQL

Aktivieren von Shared-SQL

kann im laufenden Betrieb geändert werden

SHAREDSQL_COMMANDCACHESIZE

maximale Größe des Shared-SQL-Cache (in KB)

Änderung erst nach Restart wirksam

SHAREDSQL_EXPECTEDSTATEMENTCOUNT

erwartete Anzahl der SQL-Anweisungen, die im Shared-SQL-Cache abgelegt werden

Änderung erst nach Restart wirksam

TRACE_PAGES_<task>

maximale Anzahl Seiten, die den einzelnen Task-Typen pro User-Kernel-Thread zur Verfügung stehen

Jeder User-Kernel-Thread hat einen eigenen Trace-Bereich im Arbeitsspeicher.

<task> kann folgende Werte haben: BUP (Backup-Task, noch nicht implementiert), EV (Event-Task), GC (Garbage-Collector), LW (Log-Writer), PG (Pager), SV (Server-Task), TI (Timer-Task), US (User-Task), UT (Utility-Task)

Änderung erst nach Restart wirksam

UPDATESTAT_SAMPLE_ALGO

legt den Algorithmus fest, den das Datenbanksystem für das Aktualisieren der SQL-Optimiererstatistiken verwendet

kann im laufenden Betrieb geändert werden

USED_LOG_QUEUE_COUNT

siehe LOG_QUEUE_COUNT

Änderung erst nach Restart wirksam

VOLUMENO_BIT_COUNT

Anzahl der Bits in der Converter-Blockadresse, die für die logische Volume-Nummer eines Data-Volume reserviert ist

Erlaubte Werte: 6 ≤ VOLUMENO_BIT_COUNT ≤ 12 (siehe Technische Restriktionen)

Wir empfehlen, den beim Anlegen der Datenbankinstanz gewählten Wert nicht mehr zu ändern. Wenn Sie den Datenbankparameter im laufenden Datenbankbetrieb ändern, dann müssen Sie anschließend eine Wiederherstellung der Datenbankinstanz durchführen, um die Nummerierung der Data-Volumes zu aktualisieren.

Änderung erst nach Restart wirksam

XP_CONVERTER_REGIONS

Übersteuern des Parameters CONVERTER_REGIONS

Änderung erst nach Restart wirksam

XP_DATA_CACHE_RGNS

Übersteuern des Parameters _DATA_CACHE_RGNS

Änderung erst nach Restart wirksam

XP_MAXPAGER

Übersteuern des Parameters MAXPAGER

Änderung erst nach Restart wirksam


Support-Datenbankparameter (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Support-Datenbankparameter

Verwendung

Die meisten Support-Datenbankparameter dienen zur Fehlersuche. Im normalen Betrieb müssen Sie die Support-Datenbankparameter nicht ändern. Das Ändern von Support-Datenbankparametern erfordert sehr detaillierte Kenntnisse des Datenbanksystems. Für Informationen zu weiteren Datenbankparametern siehe Allgemeine Datenbankparameter, Spezielle Datenbankparameter und liveCache-Datenbankparameter.

Änderungen von Datenbankparametern werden erst nach einem Restart der Datenbankinstanz wirksam.

Einige Datenbankparameter können Sie auch im laufenden Betrieb ändern. Für diese Datenbankparameter können Sie außerdem wählen, wie lange die Änderung wirksam ist:

■ nur bis zum nächsten Restart

■ erst nach dem nächsten Restart

■ sofort und dauerhaft

Support-Datenbankparameter

Parameter

Bedeutung

Wie kann der Parameter geändert werden?

_BACKUP_HISTFILE

Name der History-Datei für Daten- und Log-Sicherungen

kann nicht geändert werden

_BACKUP_MED_DEF

Name der Datei, in der die Definitionen der Sicherungsvorlagen gespeichert sind

kann nicht geändert werden

_EVENTFILE

Name der Datei, in der das Datenbanksystem interne Events protokolliert

Änderung erst nach Restart wirksam

_EVENTSIZE

Größe der Datei, in der das Datenbanksystem interne Events protokolliert

Änderung erst nach Restart wirksam

_IDXFILE_LIST_SIZE

Anzahl der temporären Zwischenergebnisdateien bei einer parallelen Indizierung

Große Tabellen indiziert das Datenbanksystem mit mehreren Server-Tasks. Diese Server-Tasks schreiben ihre Ergebnisse in temporäre Dateien. Wenn die Anzahl dieser Dateien den Wert dieses Parameters erreicht, dann muss das Datenbanksystem die Dateien abmischen (Merge), bevor es den eigentlichen Index erzeugen kann. Das hat zur Folge, dass die Performance sinkt.

kann im laufenden Betrieb geändert werden

_IOPROCS_PER_DEV

Anzahl Threads, die das Datenbanksystem für asynchrone I/O-Operationen verwenden kann (pro Data-Volume und System)

Änderung erst nach Restart wirksam

_KERNELDIAGFILE

Name der Protokolldatei des Kerns

Änderung erst nach Restart wirksam

_KERNELDUMPFILE

Name der Dump-Datei, die bei einem Systemabsturz vom Kern geschrieben wird

In diese Datei schreibt das Datenbanksystem u. a. den Inhalt des Data-Cache und des Converters. Dimensionieren Sie Ihr System so, dass genügend Speicherplatz für diese Datei zur Verfügung steht (ungefähr CACHE_SIZE + 10%). Beachten Sie hierbei auch den Parameter DIAG_HIST_NUM.

Änderung erst nach Restart wirksam

_KERNELTRACEFILE

Datei, in die der Kern die Trace-Einträge schreibt

Der Kern schreibt nur dann Trace-Einträge, wenn Sie zuvor den Datenbank-Trace eingeschaltet haben.

Änderung erst nach Restart wirksam

_MAXEVENTTASKS

maximale Anzahl von Event-Tasks

Das Datenbanksystem verwendet Event-Tasks sowohl für Event-Dispatcher als auch für die DBM-Kommandos event_wait, event_receive, event_available, auto_extend und auto_update_statistics, die für diese Datenbankinstanz gleichzeitig aktiv sein können.

Vorschlagswert des Database Manager für diesen Parameter ist 2.

Änderung erst nach Restart wirksam

_MAXTASK_STACK

Größe des Stacks, der von den User-Tasks verwendet wird

Änderung erst nach Restart wirksam

_MINREPLY_SIZE

minimale Größe des Speichers, der in einem Paket (Shared Memory-Segment) für die Antwort zur Verfügung steht

0: Sowohl der Anwendung als auch dem Kern steht das gesamte Paket für die Anfrage/die Antwort zur Verfügung.

Änderung erst nach Restart wirksam

_MULT_IO_BLOCK_CNT

siehe DATA_IO_BLOCK_COUNT und LOG_IO_BLOCK_COUNT

_PACKET_SIZE

Größe der Pakete (Shared Memory-Segmente), in denen SQL-Anweisungen und Daten übertragen werden

Ein Paket besteht aus einem Anfrage- und einem Antwortteil.

Änderung erst nach Restart wirksam

_READAHEAD_BLOBS

Anzahl Seiten, ab denen große LONG-Werte im Voraus von zusätzlichen Server-Tasks eingelesen werden

Wenn ein LONG-Wert zu groß ist, um in einem einzigen Auftragspaket an den Client übermittelt zu werden, dann verteilt das Datenbanksystem ihn auf mehrere Auftragspakete. Um die Performance zu steigern, können Server-Tasks bereits während des Sendens des ersten Auftragspakets weitere Teile des LONG-Werts einlesen.

kann im laufenden Betrieb geändert werden

_RESTART_TIME

minimale Zeit zwischen zwei Savepoints (in Sekunden), entspricht der Zeit, die für einen Restart nach einem Systemabsturz benötigt wird

Unabhängig hiervon schreibt das Datenbanksystem in folgenden Fällen immer einen Savepoint:

● nachdem Sie einen Index erstellt haben

● wenn die Anzahl der durch einen Savepoint freigegebenen Seiten größer als die Anzahl der freien Blöcke in den Data-Volumes ist

Änderung erst nach Restart wirksam

_RTEDUMPFILE

Datei, in die der Kern bei einem Systemabsturz Informationen zur Laufzeitumgebung schreibt

Änderung erst nach Restart wirksam

_SERVERDB_FOR_SAP

gibt an, ob die Datenbankinstanz in einem SAP-System verwendet wird

kann im laufenden Betrieb geändert werden

_TASKCLUSTER_01 bis _03

Diese Parameter beschreiben, wie das Datenbanksystem die User-Tasks auf die Threads verteilt. Ändern Sie diese Parameter nur nach Rücksprache mit dem Support.

Änderung erst nach Restart wirksam

_USE_ASYNC_IO

gibt an, ob für asynchrone I/O-Operationen Funktionen des Betriebssystems oder spezielle I/O-Threads verwendet werden

Änderung erst nach Restart wirksam

_USE_IOPROCS_ONLY

YES: I/O-Operationen werden ausschließlich von speziellen I/O-Threads durchgeführt

NO: der Kern entscheidet, ob eine Task eine I/O-Operation selbst ausführt oder ob sie die I/O-Operation an einen speziellen I/O-Thread übergibt

kann im laufenden Betrieb geändert werden

ALLOW_MULTIPLE_SERVERTASK_UKTS

gibt an, ob das Datenbanksystem die Server-Tasks auf die verfügbaren User-Kernel-Threads verteilt oder ob alle Server-Tasks im selben User-Kernel-Thread laufen

Änderung erst nach Restart wirksam

COLUMNCOMPRESSION

legt fest, ob die Spaltenwerte mit variabler Länge abgelegt werden können oder nicht

Vorschlagswert: YES (Spalten haben variable Länge, d.h. Werte können gegebenenfalls komprimiert werden)

nur für Spalten, die keine Primärschlüsselspalten sind

kann im laufenden Betrieb geändert werden

DATA_IO_BLOCK_COUNT

Blockgröße, die das Datenbanksystem beim Schreiben von Datenseiten aus dem Data-Cache in den Datenbereich verwendet

Die optimale Blockgröße ist abhängig von der verwendeten Hard- und Software.

Änderung erst nach Restart wirksam

ENABLE_SYSTEM_TRIGGERS

gibt an, ob beim Restart der Datenbankinstanz System-Trigger aufgerufen werden

Änderung erst nach Restart wirksam

EXPAND_COM_TRACE

gibt an, ob beim Erzeugen von COM-Trace-Dateien Plattenplatz reserviert wird

Änderung erst nach Restart wirksam

INIT_ALLOCATORSIZE

initiale Größe des Arbeitsspeichers, der am Anfang einer Datenbanksitzung reserviert wird

Änderung erst nach Restart wirksam

LOAD_BALANCING_DIF

nur für Load-Balancing; gibt an, um wieviel eine zu verschiebende Task in ihrem User-Kernel-Thread länger gewartet haben muss, als die Task, die im Ziel-User-Kernel-Thread am längsten gewartet hat (in Prozent)

Änderung erst nach Restart wirksam

LOAD_BALANCING_EQ

für Load-Balancing; gibt an, welche Zeitspanne beim Vergleich wartender Tasks noch als gleich anzusehen ist (in Prozent)

Änderung erst nach Restart wirksam

LOG_IO_BLOCK_COUNT

Blockgröße, die das Datenbanksystem beim Schreiben von Log-Seiten aus den Log-Warteschlangen in den Log-Bereich verwendet

Die optimale Blockgröße ist abhängig von der verwendeten Hard- und Software.

Änderung erst nach Restart wirksam

LOG_QUEUE_COUNT

Anzahl der Log-Warteschlangen

=0: Anzahl wird aus dem Parameter MAXCPU berechnet

>0: Wert des Parameters USED_LOG-QUEUE_COUNT wird übernommen

Änderung erst nach Restart wirksam

MAX_SERVERTASK_STACK

maximale Größe des Stack, der von den Server-Tasks verwendet wird

Änderung erst nach Restart wirksam

MAX_SPECIALTASK_STACK

maximale Größe des Stack, der von den Spezial-Tasks (alle außer User-Tasks und Server-Tasks) verwendet wird

Änderung erst nach Restart wirksam

MAXPAGER

maximale Anzahl der Pager, wird vom Datenbanksystem unter anderem aus MAXDATAVOLUMES berechnet

nicht änderbar

Sie können diesen Parameter mit XP_MAXPAGER übersteuern.

MAXVOLUMES

maximale Anzahl von Data- und Log-Volumes inklusive gespiegelter Volumes, wird vom System berechnet

Änderung erst nach Restart wirksam

MINI_DUMP

legt fest, ob das System die Speicherauszüge knlmini.dmp und srvmini.dmp (für das Postmortem-Debugging) schreibt, und wie viele Informationen diese Speicherauszüge enthalten

DISABLED: das System schreibt keine Speicherauszüge

NORMAL (Vorschlagswert): Das System schreibt alle Stacks und System-Handle-Informationen in den Speicherauszug

FULL: Das System schreibt alle Stacks und Datensegmente in den Speicherauszug

Änderung erst nach Restart wirksam

OMS_STREAM_TIMEOUT

maximale Wartezeit für alle Datenbanksitzungen, die bis zur Antwort einer OMS-Stream-Anfrage an einen Client vergehen darf (in Sekunden)

kann im laufenden Betrieb geändert werden

OPTIM_CACHE

gibt an, ob das Datenbanksystem die Suchstrategie nur einmal oder bei jeder Ausführung einer geparseten SQL-Anweisung ermittelt

Für Prepared Statements mit Parametern reicht es unter Umständen aus, die Suchstrategie nur einmal zu ermitteln.

kann im laufenden Betrieb geändert werden

OPTIMIZE_OPERATOR_JOIN

gibt an, ob das Datenbanksystem die verbesserte Join-Implementierung verwendet (spart Ressourcen)

kann im laufenden Betrieb geändert werden

SET_VOLUME_LOCK

gibt an, ob das Datenbanksystem beim Hinzufügen eines Volume eine Sperre setzt, die ein späteres erneutes Hinzufügen desselben Volume verhindert

In folgenden Fällen kann es sinnvoll sein, diesen Parameter auf NO zu setzen:

● NFS-gemountetes Volume

● Hot-Standby-System

Änderung erst nach Restart wirksam

SHOW_MAX_STACK_USE

protokolliert den maximalen Stack-Verbrauch jeder Task im Kernprotokoll

Setzen Sie den Parameter nur für Diagnosezwecke auf YES, weil er im Produktivbetrieb die Performance verschlechtert.

Änderung erst nach Restart wirksam

SUPPRESS_CORE

gibt an, ob das Datenbanksystem Core-Dumps des Kerns unterdrückt

Änderung erst nach Restart wirksam

SYMBOL_DEMANGLING

gibt an, ob das Datenbanksystem ein C/C++-Demangling durchführt

Änderung erst nach Restart wirksam

UPDATESTAT_PARALLEL_SERVERS

gibt an, wie viele parallele Server-Tasks das Datenbanksystem für das Aktualisieren der Statistiken des SQL-Optimierers verwendet

Wert -1: Aktualisieren der Statistiken erfolgt sequentiell
Wert 0: Datenbanksystem entscheidet, wie viele parallele Server-Tasks verwendet werden sollen

Wert n>0: Datenbanksystem verwendet maximal n parallele Server-Tasks

kann im laufenden Betrieb geändert werden

USE_OPEN_DIRECT

YES: Das Datenbanksystem verwendet beim Öffnen von Volumes das O_DIRECT-Flag (wenn dieses Flag vom Dateisystem unterstützt wird). Mit diesem Flag konfigurieren Sie, dass das Betriebssystem keinen eigenen Cache für I/O-Operationen verwendet.

Beachten Sie, dass dieses Flag für Linux-Kernel < 2.4.18 ignoriert wird.

Änderung erst nach Restart wirksam

USE_SYSTEM_PAGE_CACHE

gibt an, ob die Datenbankinstanz den System-Page-Cache für die Pufferung nicht mehr benötigter Speicherseiten verwendet

Änderung erst nach Restart wirksam


liveCache-Datenbankparameter (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation liveCache-Datenbankparameter

Verwendung

Die liveCache-Datenbankparameter verwendet das Datenbanksystem nur für SAP liveCache-Datenbankinstanzen.

Für Informationen zu weiteren Datenbankparametern siehe Allgemeine Datenbankparameter, Spezielle Datenbankparameter und Support-Datenbankparameter.

Änderungen von Datenbankparametern werden erst nach einem Restart der Datenbankinstanz wirksam.

Einige Datenbankparameter können Sie auch im laufenden Betrieb ändern. Für diese Datenbankparameter können Sie außerdem wählen, wie lange die Änderung wirksam ist:

■ nur bis zum nächsten Restart

■ erst nach dem nächsten Restart

■ sofort und dauerhaft

Voraussetzungen

Sie verwenden eine SAP liveCache-Datenbankinstanz.

Funktionsumfang

SAP-Kunden finden eine ausführliche Beschreibung der liveCache-Datenbankparameter im SAP-Hinweis 833216.

liveCache-Datenbankparameter

Parameter

Bedeutung

Wie kann der Parameter geändert werden?

MIN_RETENTION_TIME

MAX_RETENTION_TIME

legt fest, wann die Garbage-Collectors mit dem Löschen der History-Daten (Undo-Log-Einträge und Verweise darauf) beginnen (in Minuten)

Die Garbage-Collectors beginnen in folgenden Fällen mit dem Löschen der History-Daten:

● Wenn der Datenbereich zu mehr als 90% gefüllt ist, dann löschen die Garbage-Collectors alle History-Daten, die älter als MIN_RETENTION_TIME sind.

● Wenn der Datenbereich zu weniger als 90% gefüllt ist, dann löschen die Garbage-Collectors alle History-Daten, die älter als MAX_RETENTION_TIME sind.

Siehe History-Verwaltung.

kann im laufenden Betrieb geändert werden

OMS_HEAP_COUNT

legt fest, ob der OMS-Heap in Segmente unterteilt ist

Bei nicht unterteiltem OMS-Heap sperrt die interne Heap-Speicherverwaltung den gesamten OMS-Heap immer dann, wenn eine DB-Prozedur Speicher anfordert oder freigibt.

Änderung erst nach Restart wirksam

OMS_HEAP_LIMIT

legt die maximale Größe des OMS-Heap fest (in KB)

Änderung erst nach Restart wirksam

OMS_HEAP_THRESHOLD

legt den Speicherverbrauch durch den OMS-Heap fest (in %)

Änderung erst nach Restart wirksam

OMS_VERS_THRESHOLD

legt den Speicherverbrauch durch den OMS-Heap fest (in KB)

Änderung erst nach Restart wirksam

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Parameter konfigurieren


Eigenschaften von Datenbankparametern (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Eigenschaften von Datenbankparametern

Verwendung

Neben seinem aktuellen Wert hat jeder Datenbankparameter weitere Eigenschaften. Diese Eigenschaften sind in der Vorschlagsparameterdatei cserv.pcf (siehe Konfigurationsdateien) definiert.

Änderungen von Datenbankparametern werden erst nach einem Restart der Datenbankinstanz wirksam.

Einige Datenbankparameter können Sie auch im laufenden Betrieb ändern. Für diese Datenbankparameter können Sie außerdem wählen, wie lange die Änderung wirksam ist:

■ nur bis zum nächsten Restart

■ erst nach dem nächsten Restart

■ sofort und dauerhaft

Eigenschaften von Datenbankparametern

Eigenschaft | erlaubte Werte | Beschreibung
CASESENSITIVE | YES | NO | Das Datenbanksystem beachtet bei den Werten die Groß- und Kleinschreibung.
CHANGE | NO | RUNNING | OFFLINE | gibt an, ob und in welchem Betriebszustand der Parameter änderbar ist NO = nicht änderbar RUNNING = in den Betriebszuständen ONLINE und ADMIN änderbar; Sie können wählen, wann die Änderung wirksam wird OFFLINE = der neue Wert des Parameters wird erst nach einem Restart wirksam
CLEAR | YES | NO | gibt an, ob der Parameter in eine neue Datenbankinstanz übernommen werden darf (z. B. NO für den Parameter RUNDIRECTORY)
DEVSPACE | YES | NO | Art des Parameters: YES = Volume-Parameter NO = Kernparameter
DISPLAYNAME | Zeichenkette, darf Leerzeichen enthalten | Bezeichnung, die im Database Manager GUI für den Parameter angezeigt wird
DYNAMIC | YES | NO | gibt an, ob es in der Vorschlagsparameterdatei Platzhalter für den Parameter (z. B. DATAVOL_?) gibt
GROUP | GENERAL | EXTENDED | SUPPORT | NO | TRACE | Gruppe, zu der der Parameter gehört: GENERAL: allgemeine Datenbankparameter EXTENDED: spezielle Datenbankparameter SUPPORT: Support-Datenbankparameter NO: Parameter wird im Database Manager GUI nicht angezeigt TRACE: Parameter für den Datenbank-Trace, Datenbanküberprüfung und -überwachung
INSTANCES | LVC | OLTP | Datenbankinstanztyp, für den der Parameter relevant ist: LVC = SAP liveCache OLTP = OLTP (MaxDB) keine Angabe: für alle Datenbankinstanztypen gültig
INTERN | YES | NO | gibt an, ob der Wert für interne Berechnungen benötigt wird
LASTKNOWNGOOD |  | letzter gültiger Wert (Wert, den der Parameter beim letzten erfolgreichen Starten der Datenbankinstanz hatte)
MANDATORY | YES | NO | gibt an, ob der Parameter mit einem Wert belegt sein muss (ungleich Null bzw. nicht leer)
MAX |  | maximaler Wert
MIN |  | minimaler Wert
MODIFY | YES | NO | gibt an, ob Sie den Parameter nach dem Anlegen der Datenbankinstanz noch ändern können (z. B. NO für den Parameter RUNDIRECTORY)
VALUESET | Die einzelnen Werte müssen durch Leerzeichen oder Tabulatoren voneinander getrennt werden. Bei Zeichenkettenparametern müssen die zugelassenen Zeichenkettenkonstanten in Anführungszeichen gesetzt werden. | Wertemenge

Beispiel

Sie zeigen als Benutzer DBADMIN mit Kennwort SECRET mit dem Database Manager CLI die Eigenschaften des Datenbankparameters RUNDIRECTORY für die Datenbankinstanz DEMODB an:

dbmcli –d DEMODB –u DBADMIN,SECRET param_getproperties RUNDIRECTORY

OK

CHANGE OFFLINE

INTERN NO

MANDATORY YES

CLEAR YES

DYNAMIC NO

CASESENSITIVE YES

DEVSPACE NO

MODIFY YES

GROUP GENERAL

DISPLAYNAME

VALUESET

MAX

MIN

INSTANCES


Automatischer Start (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Automatischer Start

Verwendung

Sie können Betriebssystem und Datenbankinstanz auch so konfigurieren, dass die Datenbankinstanz beim Starten des Rechners automatisch in den Betriebszustand ONLINE überführt wird. Hierfür setzen Sie den Startup type für den Dienst des Kerns der Datenbankinstanz auf den Wert Automatic.

Funktionsumfang

Microsoft Windows

Beim Anlegen der Datenbankinstanz können Sie definieren, ob die Datenbankinstanz automatisch gestartet wird. Siehe

● Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz: Custom

● Database Manager CLI, Strukturlink db_create

Um das automatische Starten nachträglich zu konfigurieren, verwenden Sie den Database Manager CLI. Siehe

● Database Manager CLI, Strukturlink db_reg

Den X-Server, den Sie für die Netzwerkkommunikation benötigen, startet das Datenbanksystem automatisch.

UNIX/Linux

Auf UNIX/Linux erstellen Sie ein Startskript und erzeugen in den gewünschten Runlevel-Verzeichnissen symbolische Links auf dieses Startskript. Weitere Informationen zum automatischen Starten von Programmen finden Sie in Ihrer Betriebssystemdokumentation.

Beispiel

Beispiel: Startskript für eine Datenbankinstanz auf Linux

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Übersicht der Dienste


Beispiel: Startskript für eine Datenbankinstanz (Linux) (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Startskript für eine Datenbankinstanz (Linux)

Verwendung

Mit dem Startskript maxdb wird die Datenbankinstanz DEMODB beim Starten des Rechners automatisch in den Betriebszustand ONLINE überführt und beim Herunterfahren des Rechners automatisch in den Betriebszustand OFFLINE überführt.

Je nach verwendetem Betriebssystem müssen Sie das Startskript anpassen.

Voraussetzungen

· Sie haben die Datenbankinstanz DEMODB und den DBM-Benutzer OLEG mit Kennwort MONDAY angelegt.

· Sie befinden sich in einer root-Shell.

Vorgehensweise

...

1. Sichern Sie das Startskript maxdb im Verzeichnis /etc/init.d

2. Wechseln Sie in das Verzeichnis /etc/rc3.d

3. Erstellen Sie die folgenden symbolischen Links:

ln -s ../init.d/maxdb K05maxdb

ln -s ../init.d/maxdb S18maxdb

Startskript maxdb

#! /bin/sh

# Copyright (c) 2001-2004 SAP AG, Germany.

#

# Author: <maxdb@lists.mysql.com>

#

# init.d/maxdb

#

# and symbolic its link

#

#

### BEGIN INIT INFO

# Provides: MaxDB

# Required-Start: $remote_fs $syslog

# Required-Stop: $remote_fs $syslog

# Default-Start: 3 5

# Default-Stop: 0 1 2 6

# Description: Start MaxDB communication server.

### END INIT INFO

if [ -f /etc/rc.config ]; then

. /etc/rc.config

fi

# where to find x_server executable

IND_PROG_DBROOT=""

if [ -f /etc/opt/sdb ]; then

IND_PROG_DBROOT=`grep '^IndepPrograms=' /etc/opt/sdb | sed 's:IndepPrograms=::g'`

else

exit 5

fi

X_SERVER=$IND_PROG_DBROOT/bin/x_server

X_PATH=$IND_PROG_DBROOT/bin

MaxDB_BIN=$X_SERVER

test -x $MaxDB_BIN || exit 5

MaxDB_BIN=$X_PATH/dbmcli

test -x $MaxDB_BIN || exit 5

# find program fuser

FUSER=/bin/fuser

test -x $FUSER || FUSER=/sbin/fuser

test -x $FUSER || FUSER=/usr/sbin/fuser

# Shell functions sourced from /etc/rc.status:

# rc_check check and set local and overall rc status

# rc_status check and set local and overall rc status

# rc_status -v ditto but be verbose in local rc status

# rc_status -v -r ditto and clear the local rc status

# rc_failed set local and overall rc status to failed

# rc_reset clear local rc status (overall remains)

# rc_exit exit appropriate to overall rc status

#. /etc/rc.status

# First reset status of this service

#rc_reset

# Return values acc. to LSB for all commands but status:

# 0 - success

# 1 - misc error

# 2 - invalid or excess args

# 3 - unimplemented feature (e.g. reload)

# 4 - insufficient privilege

# 5 - program not installed

# 6 - program not configured

# 7 - program is not running

#

# Note that starting an already running service, stopping

# or restarting a not-running service as well as the restart

# with force-reload (in case signalling is not supported) are

# considered a success.

RETVAL=1

case "$1" in

start)

echo -n "Starting MaxDB services: "

if [ ! -z "$X_SERVER" ]; then

$X_SERVER start>/dev/null 2>&1

# to enable auto start/stop demodb remove following comments

DBMCLI=$X_PATH/dbmcli

if [ ! -x $DBMCLI ]; then

echo "dbmcli not found" >&2

exit 5

fi

$DBMCLI -d DEMODB << __EOD__ 2>&1 > /dev/null

user_logon OLEG,MONDAY

db_online

__EOD__

_test=`echo $_o | grep ERR`

if [ "$_test" = "" ]; then

echo -n " database DEMODB started"

else

echo "cannot start DEMODB: $_o" >&2

exit 7

fi

RETVAL=0

fi

touch /var/lock/subsys/maxdb

;;

stop)

echo -n "Shutting down MaxDB services: "

if [ ! -z "$X_SERVER" ]; then

# to enable auto start/stop demodb remove following comments

DBMCLI=$X_PATH/dbmcli

if [ ! -x $DBMCLI ]; then

echo "dbmcli not found" >&2

exit 5

fi

_o=`$DBMCLI -d DEMODB << __EOD__ 2>&1

user_logon OLEG,MONDAY

db_offline

__EOD__`

_test=`echo $_o | grep ERR`

if [ "$_test" = "" ]; then

echo -n "database DEMODB stopped"

else

echo "cannot stop DEMODB: $_o" >&2

exit 1

fi

$X_SERVER stop > /dev/null 2>&1

RETVAL=0

fi

rm -f /var/lock/subsys/maxdb

;;

status)

if [ ! -z "$X_PATH" ]; then

if [ -x $FUSER ]; then

_o=`$FUSER $IND_PROG_DBROOT/pgm/vserver`

if [ $? -eq 0 ]; then

echo "communication server is running"

# to enable auto start/stop demodb remove following comments

DBMCLI=$X_PATH/dbmcli

if [ ! -x $DBMCLI ]; then

echo "dbmcli not found" >&2

exit 5

fi

_o=`$DBMCLI -d DEMODB << __EOD__

user_logon OLEG,MONDAY

db_state

__EOD__`

_test=`echo $_o | grep ERR`

if [ "$_test" = "" ]; then

_state=`echo $_o | sed s/.*State\ *// | sed s/\ .*//`

echo "database DEMODB is $_state"

else

echo "cannot get state of DEMODB: $_o" >&2

fi

RETVAL=0

else

echo "communication server is not running"

RETVAL=0

fi

else

echo "status unkown - fuser not found" >&2

fi

else

echo "status unkown - x_server not found" >&2

fi

;;

restart)

$0 stop

$0 start

;;

reload)

$0 stop

$0 start

;;

*)

echo "Usage: maxdb {start|stop|status|reload|restart}"

exit 1

;;

esac

exit $RETVAL

Siehe auch:

Automatischer Start


Log-Einstellungen (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Log-Einstellungen

Verwendung

Das Datenbanksystem protokolliert alle Datenänderungen, die von Datenbankbenutzern durchgeführt werden, in Redo-Log-Einträgen. Mit den Log-Einstellungen konfigurieren Sie die wichtigsten Eigenschaften dieser Protokollierung (Logging).

Neben den Log-Einstellungen gibt es mehrere Datenbankparameter, die Einfluss auf das Logging haben.

Log-Einstellungen

Name

Beschreibung

Log-Modus

legt fest, ob das Datenbanksystem den Log-Bereich softwarebasiert spiegelt

● Log-Bereich wird nicht gespiegelt: Systemvorschlag

● Log-Bereich wird gespiegelt: Verwenden Sie diese Einstellung nur dann, wenn Sie den Log-Bereich nicht hardwarebasiert spiegeln können. Die softwarebasierte Spiegelung verschlechtert die Performance Ihres Datenbanksystems.

Bei der softwarebasierten Spiegelung beschreibt das Datenbanksystem zwei Log-Bereiche parallel (primären und sekundären Log-Bereich). Das Datenbanksystem kann die Log-Bereiche erst dann wieder überschreiben, wenn die Log-Einträge des primären Log-Bereichs gesichert wurden.

Bei Zugriffsproblemen auf ein Log-Volume im primären Log-Bereich markiert das Datenbanksystem das betroffene Log-Volume als BAD und überführt die Datenbankinstanz in den Betriebszustand OFFLINE. Um das defekte Log-Volume wiederherzustellen, ersetzen Sie die entsprechende Festplatte und kopieren Sie dann im Betriebszustand ADMIN den kompletten Inhalt des entsprechenden gespiegelten Log-Volume in das primäre Log-Volume.

Überschreibmodus für den Log-Bereich

legt fest, ob das Datenbanksystem Redo-Log-Einträge im Log-Bereich überschreiben darf, ohne dass sie zuvor gesichert wurden

● Überschreibmodus ist ausgeschaltet: Systemvorschlag

Das Datenbanksystem kann den Log-Bereich erst überschreiben, wenn die entsprechenden Redo-Log-Einträge gesichert wurden. Um über eine lückenlose Log-Sicherungshistorie zu verfügen, müssen Sie regelmäßig Log-Sicherungen durchführen oder die automatische Log-Sicherung einschalten.

● Überschreibmodus ist eingeschaltet:

Das Datenbanksystem überschreibt zyklisch den Log-Bereich, ohne zuvor die Redo-Log-Einträge zu sichern. Die Sicherungshistorie wird dadurch unterbrochen. Das bedeutet, dass Sie Ihre Datenbankinstanz nur bis zum Zeitpunkt der letzten Datensicherung wiederherstellen können.

Wenn der Überschreibmodus eingeschaltet war und Sie ihn ausschalten, dann müssen Sie anschließend eine vollständige Datensicherung durchführen.

Redo-Log-Verwaltung

legt fest, ob das Datenbanksystem Redo-Log-Einträge schreibt

● Redo-Log-Verwaltung ist eingeschaltet: Systemvorschlag

● Redo-Log-Verwaltung ist ausgeschaltet:

In seltenen Fällen kann es sinnvoll sein, die Redo-Log-Verwaltung auszuschalten, z. B. während eines großen Ladejobs. Beachten Sie, dass dadurch die Sicherungshistorie unterbrochen wird. Wenn Sie die Datenbankinstanz nach einem Fehler wiederherstellen müssen, dann stehen für diesen Zeitraum keine Redo-Log-Einträge zur Verfügung.

Wenn die Redo-Log-Verwaltung ausgeschaltet war und Sie sie erneut einschalten, dann müssen Sie anschließend eine vollständige Datensicherung durchführen.

Aktivitäten

Database Manager GUI, Strukturlink Log-Einstellungen ändern

Database Manager CLI, Strukturlink param_addvolume

Siehe auch:

Log-Einträge sichern

Protokollierung von Datenänderungen (Logging)


Konfigurationsdateien (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Konfigurationsdateien

Für Datenbankinstanzen und die Datenbanksoftware gibt es mehrere Konfigurationsdateien.

Die meisten Konfigurationsdateien können Sie direkt mit einem Text-Editor öffnen. Zum Anzeigen von Konfigurationsdateien, die eine Datei-ID haben, verwenden Sie das Datenbankwerkzeug Database Manager.

Beachten Sie bei der Datei-ID die Groß- und Kleinschreibung.

Siehe

● Database Manager CLI, Strukturlink file_getfirst

Konfigurationsdateien der Datenbankinstanz <database_name>

Dateiname | Datei-ID | Beschreibung | Verzeichnis
<database_name> | PARAM | binäre Parameterdatei mit den Werten der Datenbankparameter Ändern Sie Werte von Datenbankparametern nicht direkt in dieser Datei, sondern nur wie im Abschnitt Datenbankparameter beschrieben. Informationen zur Historie der Datenbankparameter finden Sie im Abschnitt Protokolldateien. | <independent_data_path>\config
cserv.pcf |  | Vorschlagsparameterdatei enthält die Vorschlagswerte, den Wertebereich, Berechnungsvorschriften und Eigenschaften der Datenbankparameter (siehe Eigenschaften von Datenbankparametern) | <dependent_path>\env
dbm.cfg | DBMCFG | Konfigurationsdatei des Database Manager für die Datenbankinstanz | Arbeitsverzeichnis der Datenbankinstanz: <independent_data_path>\wrk\<database_name> (siehe Arbeitsverzeichnis)
dbm.mmm | DBMMDF | Definitionen der Sicherungsvorlagen für die Datenbankinstanz | <independent_data_path>\wrk\<database_name>

Sonstige Konfigurationsdateien

Dateiname | Verzeichnis | Beschreibung
WebAgent<version>.ini | /usr/spool/sql/ini | nur auf UNIX/Linux Konfigurationsdatei des MaxDB Web Servers und Web Tools
sdb | /etc/opt | nur auf UNIX/Linux Konfigurationsdatei der MaxDB-Softwareinstallation Das Installationsprogramm erzeugt diese Datei bei der Installation der Datenbanksoftware. Diese Datei dürfen Sie nicht ändern.
loader.cfg | <loader_application_data>\config | Konfigurationsdatei des Loader (siehe Loader, Strukturlink Transportmodus)
dbanalyzer<version>.cfg | <independent_program_path>\env | Konfigurationsdatei des Datenbankwerkzeugs Database Analyzer

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Installationshandbuch, Strukturlink Verzeichnisse


Datenbankdesign (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Datenbankdesign

Einsatzmöglichkeiten

Datenbankdesign ist die Umsetzung Ihres logischen Datenmodells in Datenbankobjekte. Ein gut durchdachtes Datenbankdesign bringt Ihnen unter anderem folgende Vorteile:

● gute Performance

● parallele Datennutzung

● geringe Redundanz

● Datenintegrität

● Benutzerfreundlichkeit

Voraussetzungen

● Sie haben eine Datenbankinstanz angelegt und konfiguriert.

● Sie haben ein logisches Datenmodell erstellt.

Ablauf

Beachten Sie die Tipps zum Datenbankdesign.

...

1. Um die Datenbankobjekte zu definieren, verwenden Sie DDL (Data Definition Language)-Anweisungen. Sie können unter anderem folgende Datenbankobjekte anlegen:

○ Tabellen und View-Tabellen

○ Spalten (einschließlich geeigneter Datentypen)

○ Wertebereiche und Constraints

○ Primärschlüssel

○ Indizes

○ Datenbankprozeduren und -funktionen

○ Trigger

Siehe

○ SQL-Tutorial, Strukturlink Datendefinition

○ SQL-Referenzhandbuch, Datendefinition

2. Sie legen Datenbankbenutzer an und weisen diesen die gewünschten Berechtigungen zu. Siehe

○ SQL-Tutorial, Strukturlink Autorisierung

○ SQL-Referenzhandbuch, Autorisierung

Ergebnis

Sie können nun mit SQL-Anweisungen oder mit dem Datenbankwerkzeug Loader Daten in die Datenbank einfügen. Siehe

● SQL-Tutorial, Strukturlink Datenmanipulation

● SQL-Referenzhandbuch, Datenmanipulation

● Dokumentation zum Strukturlink Loader

Siehe auch:

Das Datenbanksystem im Überblick

Performance


Tipps zum Datenbank-Design (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Tipps zum Datenbank-Design

Das Datenbank-Design hat großen Einfluss auf die Performance im laufenden Betrieb. Viele Performance-Probleme lassen sich vermeiden, indem Sie die folgenden Tipps beim Design Ihrer Datenbank beachten:

● Bevor Sie Tabellen definieren, analysieren Sie die zu erwartenden Daten.

● Stellen Sie beim Definieren von Schlüsselspalten diejenigen Spalten an den Anfang des Schlüssels, die besonders selektiv sind und für die Benutzer besonders häufig Suchbedingungen angeben. In vielen Fällen muss das Datenbanksystem so beim Abarbeiten einer SELECT-Anweisung nur einen kleinen Teil der Tabelle durchsuchen.

● Invertieren Sie nur Spalten mit hoher Selektivität.

Wählen Sie nicht Spalten wie z. B. Geschlecht oder Familienstand als Index. Solche Spalten weisen in der Regel nur sehr wenige unterschiedliche Werte auf, weswegen das Datenbanksystem diese Spalten nur selten für eine nicht-sequentielle Suche verwenden kann.

● Bei relativ statischen Datenbeständen können Sie viele Spalten invertieren. Verwenden Sie wie bei der Definition der Schlüsselspalten am Anfang des Index möglichst selektive Spalten, die Benutzer häufig in Gleichheitsbedingungen verwenden.

● Invertieren Sie nicht alle Spalten, die Benutzer in Suchbedingungen verwenden. Der benötige Speicherplatz für die Indizes und der Aufwand für ihre Pflege ist groß.

Siehe auch:

Performance


Verwaltung (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Verwaltung

Verwendung

Im laufenden Betrieb müssen Sie eine Reihe regelmäßiger Verwaltungsaufgaben durchführen, wie z. B. Datensicherungen. Sie können viele dieser Verwaltungsaufgaben automatisieren.

Außerdem gibt es Verwaltungsaufgaben, die Sie bei bestimmten Ereignissen durchführen müssen, wie z. B. die Datenbankinstanz nach einem Systemausfall wiederherstellen.

Integration

Zur Verwaltung von Datenbankinstanzen stehen folgende Datenbankwerkzeuge zur Verfügung:

● Database Manager (Database Manager GUI und Database Manager CLI)

● CCMS (nur in SAP-Systemen)

Voraussetzungen

Anlegen und Konfigurieren einer Datenbankinstanz

Funktionsumfang

● Benutzer, Authentifizierung und Berechtigungen

● Sichern und Wiederherstellen

● Exportieren und Importieren

● Replikation und High-Availability

Siehe auch:

Dokumentation Strukturlink Database Manager GUI

Dokumentation Strukturlink Database Manager CLI

Dokumentation Strukturlink Datenbankverwaltung im CCMS: MaxDB

Dokumentation Strukturlink Datenbankverwaltung im CCMS: SAP liveCache-Technologie

MaxDB-Sicherheitsleitfaden


Regelmäßige Verwaltungsaufgaben (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Regelmäßige Verwaltungsaufgaben

Es gibt mehrere Verwaltungsaufgaben, die Sie im produktiven Betrieb regelmäßig ausführen müssen.

Wenn Sie die Datenbankinstanz in einem produktiven System verwenden, empfehlen wir, sie zu überwachen (siehe Überwachung).

Die folgende Tabelle ist ein Beispiel für die Einplanung von regelmäßigen Verwaltungsaufgaben. Je nachdem, wie großzügig Sie Ihre Datenbankinstanz dimensioniert haben und wie stark sie ausgelastet ist, sind diese Verwaltungsaufgaben häufiger oder weniger häufig als im angeführten Beispiel notwendig.

Beispiel: Einplanung regelmäßiger Verwaltungsaufgaben

Aktion

Häufigkeit

Anmerkungen

vollständige Datensicherung

(siehe Daten sichern)

an jedem produktiven Tag

Wenn Sie nicht täglich eine vollständige Datensicherung durchführen können oder wollen, dann führen Sie mindestens an jedem produktiven Tag eine inkrementelle Datensicherung durch.

Je aktueller die letzte Datensicherung ist, desto weniger Log-Einträge muss das Datenbanksystem bei einem Wiederherstellen der Datenbankinstanz einlesen.

Sicherungsdateien archivieren

einmal pro Woche

nur notwendig für Log-Sicherungen auf Datenträgern vom Typ Datei

Log-Sicherung

(siehe Log-Einträge sichern)

einmal pro Woche

nur notwendig, wenn die automatische Log-Sicherung ausgeschaltet ist

Wir empfehlen, die automatische Log-Sicherung einzuschalten. Log-Sicherungen sind die Voraussetzung für eine lückenlose Sicherungshistorie.

Datenbankstrukturen prüfen

einmal pro Woche

Wir empfehlen, die Datenbankstrukturen in lastarmen Zeiten oder auf einer Systemkopie zu prüfen.

Statistiken des SQL-Optimierers aktualisieren

einmal pro Woche

Siehe auch:

Sichern und Wiederherstellen

Verwaltung


Verwaltungsaufgaben automatisieren (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Verwaltungsaufgaben automatisieren

Verwendung

Sie können sowohl regelmäßige als auch nur bei Bedarf auszuführende Verwaltungsaufgaben automatisieren.

Aktivitäten

● Spezielle DBM-Kommandos

○ Automatische Log-Sicherung

Siehe

Database Manager GUI, Strukturlink Ein- und Ausschalten der automatischen Log-Sicherung

Database Manager CLI, Strukturlink autolog_on

○ Automatisches Erweitern des Datenbereichs

Siehe

Database Manager GUI, Strukturlink Automatische Erweiterung des Datenbereichs ein-/ausschalten

Database Manager CLI, Strukturlink auto_extend

○ Automatisches Aktualisieren der Statistiken des SQL-Optimierers

Siehe

Database Manager GUI, Strukturlink Statistikinformationen aktualisieren

Database Manager CLI, Strukturlink auto_update_statistics

● Automatischer Start

Sie können konfigurieren, dass die Datenbankinstanz beim Starten des Betriebssystems automatisch in den Betriebszustand ONLINE überführt wird. Siehe Automatischer Start.

● DBA-Einplanungskalender des CCMS

In SAP-Systemen können Sie regelmäßige Verwaltungsaufgaben mit dem Strukturlink DBA-Einplanungskalender automatisieren.

● Scheduler

Mit dem Scheduler können Sie einplanen, dass DBM-Kommandos zu definierten Zeitpunkten ausgeführt werden. Zu diesem Zweck legen Sie jedes auszuführende DBM-Kommando als Job im Scheduler an. Damit Jobs ausgeführt werden können, muss der Scheduler eingeschaltet sein

Siehe Database Manager CLI, Strukturlink Verwenden des Scheduler

● Datenbank-Events

Sie können Datenbank-Events für bestimmte Zustände der Datenbankinstanz definieren. Wenn einer dieser Zustände eintritt, führt der Event-Dispatcher eine bestimmte Aktion aus, wie z. B. ein DBM-Kommando oder ein Kommando eines anderen Programms.

Siehe Übersicht der Datenbank-Event-Kategorien , Dokumentation zum Strukturlink Event-Dispatcher und Database Manager CLI, Strukturlink Nutzen von Events der Datenbankinstanz

● Datenbank-Trigger

Um nach bestimmten Datenänderungen oder nach einem Restart Aktionen in der Datenbank auszulösen, können Sie Trigger verwenden. Siehe SQL-Referenzhandbuch, Triggername (trigger_name)

Siehe auch:

Verwaltung


Übersicht der Datenbank-Event-Kategorien (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Übersicht der Datenbank-Event-Kategorien

Verwendung

Es gibt folgende Event-Kategorien:

● Event-Kategorien, deren Events immer aktiv sind und nicht geändert werden können

● Event-Kategorien, für die Sie Events aktivieren/deaktivieren und ändern können. Sie können für jede dieser Event-Kategorien einen oder mehrere Events setzen, die bei erreichen der jeweils definierten Werte vom Datenbanksystem ausgelöst werden sollen (Siehe: Database Manager CLI, Strukturlink event_set).

Siehe auch:

Verwaltungsaufgaben automatisieren

Database Manager CLI, Strukturlink Nutzen von Events der Datenbankinstanz

Dokumentation zum Strukturlink Event-Dispatcher

Eventkategorien, für die immer Events aktiv sind

(Diese Events können nicht geändert oder deaktiviert werden)

Eventkategorie

Beschreibung

ADMIN

Das System löst ein Event dieser Kategorie aus, wenn die Datenbankinstanz in den Betriebszustand ADMIN überführt wurde.

Das Event hat die Priorität LOW.

AUTOSAVE

Das System löst ein Event dieser Kategorie aus, wenn sich der Zustand der automatischen Log-Sicherung ändert.

Das Event hat die Priorität LOW.

BACKUPRESULT

noch nicht implementiert

CHECKDATA

Das System löst ein Event dieser Kategorie aus, wenn es die Prüfung der Datenbankstruktur (CHECK DATA oder CHECK DATA WITH UPDATE) abgeschlossen hat.

Das Event hat die Priorität LOW.

DATABASEFULL

Das System löst in regelmäßigen Abständen ein Event dieser Kategorie aus, wenn der Datenbereich der Datenbankinstanz zu 100% gefüllt ist.

Beachten Sie, dass das System dieses Event nur im Betriebszustand ONLINE und während des Restarts der Datenbankinstanz auslöst

Das Event hat die Priorität HIGH.

Um den Betrieb fortsetzen zu können, fügen Sie ein Data-Volume hinzu.

ERROR

Das System löst ein Event dieser Kategorie aus, wenn es einen Fehler ins Kernprotokoll knldiag eingetragen hat.

Das Event hat die Priorität HIGH.

EVENT

Das System löst ein Event dieser Kategorie aus, wenn die Event-Konfiguration geändert wurde.

Das Event hat die Priorität LOW.

LOGFULL

Das System löst ein Event dieser Kategorie aus, wenn der Log-Bereich der Datenbankinstanz zu 100% gefüllt ist.

Das Event hat die Priorität HIGH.

Um den Betrieb fortsetzen zu können, führen Sie eine Log-Sicherung durch.

LOGSEGMENTFULL

Das System löst ein Event dieser Kategorie aus, wenn ein Log-Segment des Log-Bereichs voll ist.

Das Event hat die Priorität LOW.

ONLINE

Das System löst ein Event dieser Kategorie aus, wenn die Datenbankinstanz in den Betriebszustand ONLINE überführt wurde.

Das Event hat die Priorität LOW.

OUTOFSESSIONS

Das System löst ein Event dieser Kategorie aus, wenn alle vorhandenen User-Tasks belegt sind (es können sich keine weiteren Benutzer mehr an die Datenbankinstanz anmelden).

Das Event hat die Priorität HIGH.

SYSTEMERROR

Das System löst ein Event dieser Kategorie aus, wenn ein schwerer Systemfehler aufgetreten ist (Meldungsnummern -9000 bis -9999).

Das Event hat die Priorität HIGH.

STANDBY

Das System löst ein Event dieser Kategorie aus, wenn die Datenbankinstanz in den Betriebszustand STANDBY überführt wurde.

Das Event hat die Priorität LOW.

UPDSTATWANTED

Das System löst ein Event dieser Kategorie aus, wenn die Statistiken des SQL-Optimierers für mindestens eine Tabelle aktualisiert werden müssen.

Das Event hat die Priorität LOW.

Eventkategorien, für die Sie Events aktivieren/deaktivieren und ändern können

Eventkategorie

Beschreibung

DBFILLINGABOVELIMIT

Das System löst ein Event dieser Kategorie aus, wenn der Füllungsgrad des Datenbereichs einen der vordefinierten Werte überschreitet.

Events dieser Kategorie sind mit folgenden Vorschlagswerten aktiv:

HIGH (bei Füllungsgrad 90%, 95%, 96%, 97%, 98%, 99%) | MEDIUM | (bei Füllungsgrad 80%, 85%) | LOW (bei Füllungsgrad 70%)

Sie können zusätzlich für jedes Überschreiten des Füllungsgrads zwischen 0% und 99% ein eigenes Event mit einer eigenen Priorität definieren.

Außerdem können Sie die Prioritäten der vordefinierten Events übersteuern.

DBFILLINGBELOWLIMIT

Das System löst ein Event dieser Kategorie aus, wenn der Füllungsgrad des Datenbereichs einen der vordefinierten Werte unterschreitet.

Events dieser Kategorie sind mit folgenden Vorschlagswerten aktiv:

LOW (Vorschlagswert; bei Füllungsgrad 70%, 80%, 85%, 90%, 95%) | MEDIUM | HIGH

Sie können zusätzlich für jedes Unterschreiten des Füllungsgrads zwischen 1% und 100% ein eigenes Event mit einer eigenen Priorität definieren.

Außerdem können Sie die Prioritäten der vordefinierten Events übersteuern.

LOGABOVELIMIT

Das System löst ein Event dieser Kategorie aus, wenn der Füllungsgrad des Log-Bereichs einen der vordefinierten Werte überschreitet.

Events dieser Kategorie sind mit folgenden Vorschlagswerten aktiv:

HIGH (bei Füllungsgrad 96%,97%,98%,99%) | MEDIUM (bei Füllungsgrad 90%, 95%) | LOW (bei Füllungsgrad 50%, 75%)

Sie können zusätzlich für jedes Überschreiten des Füllungsgrads ein eigenes Event mit einer eigenen Priorität definieren.

Außerdem können Sie die Prioritäten der vordefinierten Events übersteuern.


Benutzer, Authentifizierung und Berechtigungen (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Benutzer, Authentifizierung und Berechtigungen

Verwendung

Um mit dem Datenbanksystem zu arbeiten, müssen Sie sich mit einem Datenbankwerkzeug oder über eine Schnittstelle an eine Datenbankinstanz anmelden. Bei der Anmeldung identifizieren Sie sich mit einem Benutzernamen und authentifizieren sich mit dem zugehörigen Kennwort.

Das Datenbanksystem MaxDB unterscheidet folgende Typen von Benutzern:

· Datenbanksystemadministrator (SYSDBA-Benutzer)

· Database Manager-Benutzer (DBM-Benutzer)

· Datenbankbenutzer

Übersicht der Benutzer des Datenbanksystems

Diese Grafik wird im zugehörigen Text erklärt

Um zu verhindern, dass unberechtigte Personen die Kennwörter von Standardbenutzern in Erfahrung bringen, sollten Sie die Kennwörter von Standardbenutzern ändern.

Nach der Authentifizierung können Sie im Rahmen der Berechtigungen, die dem angemeldeten Benutzer zugeordnet sind, auf Daten der Datenbankinstanz zugreifen und Datenbankwerkzeuge verwenden.

Um die Datenbankressourcen vor einem direkten Zugriff auf Betriebssystemebene zu schützen, verwendet das Datenbanksystem auf UNIX/Linux spezielle Betriebssystembenutzer und -gruppen.

Für eine vereinfachte Anmeldung an Datenbankinstanzen können Sie Anmeldedaten mit dem Programm Strukturlink XUSER speichern.

Siehe auch:

Datenbanksystemadministrator (SYSDBA-Benutzer)

Database Manager-Benutzer (DBM-Benutzer)

Datenbankbenutzer

Serverberechtigungen für den DBM-Server

Konventionen für Benutzernamen und Kennwörter

Verwaltung


Datenbanksystemadministrator (SYSDBA-Benutzer) (SAP-Bibliothek - Grundwissen)

Objektdokumentation Datenbanksystemadministrator (SYSDBA-Benutzer)

Definition

Der Datenbanksystemadministrator (SYSDBA-Benutzer) hat alle Rechte, die ein Datenbankbenutzer der Datenbankbenutzerklasse DBA haben kann, und zusätzlich folgende Eigenschaften:

● Der Datenbanksystemadministrator ist Eigentümer mehrerer Systemtabellen. Beim Laden der Systemtabellen meldet sich das Ladewerkzeug als Datenbanksystemadministrator an die Datenbankinstanz an.

● Der Datenbanksystemadministrator verfügt über alle Serverberechtigungen, die ein Database Manager-Benutzer haben kann. Der Datenbanksystemadministrator kann daher mit dem Datenbankwerkzeug Database Manager Datenbankinstanzen verwalten.

● Der Datenbanksystemadministrator hat Eigentümerrechte an allen Datenbankbenutzern. Er kann Datenbankbenutzer einer beliebigen Datenbankbenutzerklasse und auch Database Manager-Benutzer erzeugen.

Die Daten des Datenbanksystemadministrators werden sowohl im Database Manager als auch in der Datenbankinstanz gespeichert.

Struktur

Der Datenbanksystemadministrator verfügt über DBM-Benutzereigenschaften, Serverberechtigungen und SQL-Benutzereigenschaften.

DBM-Benutzereigenschaften

General | Beschreibung
Name | Name des Datenbanksystemadministrators
Password | Kennwort des Datenbanksystemadministrators
Comment | Beschreibung des Datenbanksystemadministrators
Disabled | gibt an, ob der Benutzer-Account des Datenbanksystemadministrators gesperrt ist
Enable Pwd | Für den Datenbanksystemadministrator können Sie ein zweites Kennwort definieren. So können Sie zeitweise anderen Personen eine Arbeit mit Datenbanksystemadministrator erlauben, ohne dass der Datenbanksystemadministrator das Originalkennwort weitergeben oder ändern muss (z. B. für Supportzwecke).

Serverberechtigungen

Serverberechtigungen (Server Rights) sind Berechtigungen für das Programm DBM-Server und damit für das Ausführen von Aktionen im Database Manager (Liste der Serverberechtigungen für den DBM-Server).

SQL-Benutzereigenschaften

General

Beschreibung

Name

Name des Datenbanksystemadministrators

Password

Kennwort des Datenbanksystemadministrators

User Class

Datenbankbenutzerklasse (SYSDBA)

Connection Mode

NOT EXCLUSIVE: Es ist möglich, gleichzeitig mehrere Datenbanksitzungen des Datenbanksystemadministrators zu öffnen.

EXCLUSIVE: Es ist nicht möglich, gleichzeitig zwei verschiedene Datenbanksitzungen des Datenbanksystemadministrators zu öffnen.

Extended

Beschreibung

Timeout

Angabe des Timeout-Wertes

Cost Warning

Dieser Wert gibt an, ab welchem SELECT-Kosten-Schätzwert der Benutzer eine Warnung erhält. Im Falle einer Warnung wird der Benutzer gefragt, ob die SQL-Anweisung wirklich ausgeführt wird.

Cost Limit

Dieser Wert gibt an, ab welchem SELECT-Kosten-Schätzwert die SQL-Anweisung nicht ausgeführt wird. Dieser Wert muss größer als der Cost Warning-Wert sein.

Default Code

DEFAULT: Der Vorschlagswert für das Codeattribut wird durch den Datenbankparameter DEFAULT_CODE bestimmt.

ASCII: Der Vorschlagswert für das Codeattribut ist ASCII.

UNICODE: Der Vorschlagswert für das Codeattribut ist UNICODE.

Datenbanksystemadministrator verwalten

Der Datenbanksystemadministrator (SYSDBA-Benutzer) ist der erste Datenbankbenutzer, den Sie beim Anlegen der Datenbankinstanz mit dem Database Manager oder dem Installation Manager anlegen.

Der Vorschlagswert für den Namen des Datenbanksystemadministrators ist ab der Datenbankversion MaxDB 7.6 DBADMIN.

Sie können den Database Manager oder ein geeignetes Query Tool verwenden, um die DBM-Benutzereigenschaften, Serverberechtigungen und SQL-Benutzereigenschaften des Datenbanksystemadministrators anzuzeigen oder zu ändern.

● Database Manager GUI
Strukturlink Ändern der DBM-Benutzereigenschaften des Datenbanksystemadministrators
Strukturlink Ändern des Kennworts des Datenbanksystemadministrators
Strukturlink Ändern der Serverberechtigungen des Datenbanksystemadministrators
Strukturlink Ändern der SQL-Benutzereigenschaften des Datenbanksystemadministrators

● Database Manager CLI
 Strukturlink user_get
 Strukturlink user_getrights
 Strukturlink user_put

● SQL-Referenzhandbuch
ALTER USER-Anweisung (alter_user_statement)
ALTER PASSWORD-Anweisung (alter_password_statement)

Siehe auch:

Benutzer, Authentifizierung und Berechtigungen

Konventionen für Benutzernamen und Kennwörter


Database Manager-Benutzer (DBM-Benutzer) (SAP-Bibliothek - Grundwissen)

Objektdokumentation Database Manager-Benutzer (DBM-Benutzer)

Definition

Database Manager-Benutzer (DBM-Benutzer) können sich am Datenbankwerkzeug Database Manager anmelden und die Verwaltungsfunktionen des Database Manager nutzen. Database Manager-Benutzer sind keine Datenbankbenutzer und können sich daher nicht an die Query Tools (z. B. SQL Studio) oder den Loader anmelden.

Struktur

Database Manger-Benutzer verfügen über DBM-Benutzereigenschaften und Serverberechtigungen.

DBM-Benutzereigenschaften

General | Beschreibung
Name | Name des Database Manager-Benutzers
Password | Kennwort des Database Manager-Benutzers
Comment | Beschreibung des Database Manager-Benutzers
Disabled | gibt an, ob der Benutzer-Account des Database Manager-Benutzers gesperrt ist
Enable Pwd | Für den Database Manager-Benutzer können Sie ein zweites Kennwort definieren. So können Sie zeitweise anderen Personen eine Arbeit mit dem Database Manager-Benutzer erlauben, ohne dass der Database Manager-Benutzer das Originalkennwort weitergeben oder ändern muss (z.B. für Supportzwecke).

Serverberechtigungen

Serverberechtigungen (Server Rights) sind Berechtigungen für das Programm DBM-Server und damit für das Ausführen von Aktionen im Database Manager (Liste der Serverberechtigungen für den DBM-Server).

Database Manager-Benutzer verwalten

Beim Anlegen einer Datenbankinstanz mit dem Database Manager oder dem Installation Manager wird ein erster Database Manager-Benutzer angelegt, der die erforderlichen DBM-Benutzereigenschaften hat und mit allen Serverberechtigungen ausgestattet ist.

Der Vorschlagswert für den Namen des Database Manager-Benutzers ist DBM.

Database Manager-Benutzer können weitere Database Manager-Benutzer anlegen, ändern oder löschen, wenn sie die entsprechenden Serverberechtigungen haben. Des Weiteren kann ein Database Manager-Benutzer bei entsprechender Serverberechtigung die DBM-Benutzereigenschaften und die Serverberechtigungen eines Benutzers anzeigen oder ändern.

Sie haben folgende Möglichkeiten, um Database Manager-Benutzer anzuzeigen und zu verwalten:

● Database Manager GUI
Strukturlink Anlegen/Ändern/Löschen eines Database Manager-Benutzers
Strukturlink Ändern der DBM-Benutzereigenschaften
Strukturlink Ändern des Kennworts eines Database Manager-Benutzers
Strukturlink Ändern der Serverberechtigungen

● Database Manager CLI
 Strukturlink user_create
Strukturlink user_get
Strukturlink user_getrights
Strukturlink user_put
Strukturlink user_delete

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Benutzerdaten

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Benutzerdaten

Siehe auch:

Benutzer, Authentifizierung und Berechtigungen

Konventionen für Benutzernamen und Kennwörter

Tutorial Datenbankverwaltung, Strukturlink DBM-Benutzer anlegen


Datenbankbenutzer (SAP-Bibliothek - Grundwissen)

Objektdokumentation Datenbankbenutzer

Definition

Datenbankbenutzer können SQL-Anweisungen verwenden, um mit den Daten in der Datenbankinstanz zu arbeiten. Sie können unter anderem Datenbankobjekte wie Tabellen, Views und Indizes erzeugen und ändern.

Datenbankbenutzer können sich an folgende Datenbankwerkzeuge und Programmierschnittstellen anmelden:

● SQL Studio, Web SQL Studio und SQLCLI (Query Tools)

● Loader

● ODBC-, JDBC-, SQLDBC-Schnittstelle

● Synchronization Manager

Datenbankbenutzer können keine Datenbankverwaltungsaufgaben mit dem Database Manager ausführen.

Struktur

Datenbankbenutzer verfügen über eine Reihe von SQL-Benutzereigenschaften.

SQL-Benutzereigenschaften

General | Beschreibung
Name | Name des Datenbankbenutzers
Password | Kennwort des Datenbankbenutzers
User Class | Datenbankbenutzerklasse (DBA | RESOURCE | STANDARD)
Connection Mode | NOT EXCLUSIVE: Der Datenbankbenutzer kann gleichzeitig mehrere Datenbanksitzungen des Benutzers öffnen. EXCLUSIVE: Der Datenbankbenutzer kann nur jeweils eine Datenbanksitzung öffnen. DISABLED: Der Datenbankbenutzer darf keine Datenbanksitzung öffnen.
Extended | Beschreibung
Timeout | Angabe des Timeout-Wertes
Cost Warning | Dieser Wert gibt an, ab welchem SELECT-Kosten-Schätzwert der Benutzer eine Warnung erhält. Im Falle einer Warnung wird der Benutzer gefragt, ob die SQL-Anweisung wirklich ausgeführt werden soll.
Cost Limit | Dieser Wert gibt an, ab welchem SELECT-Kosten-Schätzwert die SQL-Anweisung nicht ausgeführt wird. Dieser Wert muss größer als der Cost Warning-Wert sein.
Default Code | DEFAULT: Der Vorschlagswert für das Codeattribut wird durch den Datenbankparameter DEFAULT_CODE bestimmt. ASCII: Der Vorschlagswert für das Codeattribut ist ASCII. UNICODE: Der Vorschlagswert für das Codeattribut ist UNICODE.
Replication User | Wenn Replication User markiert ist, wird ein spezieller Datenbankbenutzer (Datenbankbenutzerklasse DBA, Connection Mode NOT EXCLUSIVE) angelegt bzw. verwaltet, der für die Synchronisation mit dem Programm Synchronization Manager benötigt wird (Synchronisationsbenutzer)

Jeder Datenbankbenutzer gehört einer Datenbankbenutzerklasse an. Die Benutzerklassen unterscheiden sich in den Berechtigungen, die ihre Mitglieder haben.

Datenbankbenutzerklassen

Name | Eigenschaften
STANDARD | Zugriff auf Daten und Datenbankprozeduren, die von anderen Datenbankbenutzern definiert wurden und für die der Benutzer die Privilegien erhalten hat Definition von View-Tabellen, Synonymen und temporären Tabellen
RESOURCE | Definition von Daten und Datenbankprozeduren Weitergabe der Privilegien für diese Datenbankobjekte an andere Datenbankbenutzer
DBA (Datenbankadministrator) | Anlegen von RESOURCE- und STANDARD-Datenbankbenutzern Definition von Datenbankobjekten Weitergabe aller oder eines Teils der Privilegien für diese Datenbankobjekte an andere Datenbankbenutzer

Datenbankbenutzer verwalten

Der Datenbanksystemadministrator (SYSDBA-Benutzer) kann Datenbankbenutzer einer beliebigen Datenbankbenutzerklasse anlegen, unter anderem auch Benutzer der Benutzerklasse DBA (Datenbankadministrator). Jeder Datenbankadministrator kann Benutzer der Benutzerklassen RESOURCE und STANDARD anlegen.

Um Datenbankbenutzer anzulegen, zu verwalten und zu löschen, verwenden Sie SQL-Anweisungen. Sie können folgende Möglichkeiten wählen, um Datenbankbenutzer zu verwalten:

● Verwenden Sie ein geeignetes Query Tool (z. B. SQL Studio) und geben Sie die SQL-Anweisungen direkt ein.
siehe dazu: SQL-Referenzhandbuch, Autorisierung

● Verwenden Sie den Database Manager GUI.
siehe dazu: Database Manager GUI, Strukturlink Verwalten von Datenbankbenutzern.

Der Sychronisationsbenutzer ist ein spezieller Datenbankbenutzer (SQL-Benutzereigenschaften: Datenbankbenutzerklasse DBA, Connection Mode NOT EXCLUSIVE, Replication User), der für die Synchronisation von Datenbankinstanzen mit dem Programm Synchronization Manager benötigt wird. Sie können den Database Manager GUI verwenden, um den Synchronisationsbenutzer zu verwalten: Strukturlink Anlegen/Ändern/Löschen des Synchronisationsbenutzers

Für Datenbankbenutzer im SAP-System können Sie besondere Rollen vergeben. Siehe

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Berechtigungskonzept

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Voraussetzungen

Datenbankbenutzer anlegen, ändern, löschen, SQL-Benutzereigenschaften verwalten

Ein Datenbankbenutzer der Datenbankbenutzerklasse DBA oder der Datenbanksystemadministrator (SYSDBA-Benutzer) kann weitere Datenbankbenutzer anlegen, ändern oder löschen und die SQL-Benutzereigenschaften anzeigen oder ändern.

Verfahren Sie dazu wie in folgenden Abschnitten beschrieben:

● Database Manager GUI
Strukturlink Anlegen/Ändern/Löschen eines Datenbankbenutzers
Strukturlink Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers
Strukturlink Ändern des Kennworts eines Datenbankbenutzers
Strukturlink Anlegen/Ändern/Löschen des Synchronisationsbenutzers

● SQL-Referenzhandbuch
CREATE USER-Anweisung (create_user_statement)
ALTER USER-Anweisung (alter_user_statement)
ALTER PASSWORD-Anweisung (alter_password_statement)
DROP USER-Anweisung (drop_user_statement)

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Benutzerdaten

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Benutzerdaten

Siehe auch:

Benutzer, Authentifizierung und Berechtigungen

Konventionen für Benutzernamen und Kennwörter


Serverberechtigungen für den DBM-Server (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Serverberechtigungen für den DBM-Server

Verwendung

Für das Ausführen von DBM-Kommandos im Database Manager benötigen Database Manager-Benutzer (DBM-Benutzer) und der Datenbanksystemadministrator (SYSDBA-Benutzer) entsprechende Berechtigungen für den DBM-Server. Diese Berechtigungen werden Serverberechtigungen genannt und als DBM-Benutzereigenschaft Server Rights im Database Manager gespeichert. Dabei kann eine Serverberechtigung mehrere DBM-Kommandos umfassen und ein DBM-Kommando mehreren Serverberechtigungen zugeordnet sein.

Serverberechtigungen

Berechtigung | Bezeichnung im Database Manager GUI | Bezeichnung im Database Manager CLI
Zugriff auf SQL-Sitzung | Access to SQL session | AccessSQL
Zugriff auf Utility-Sitzung | Access to utility session | AccessUtility
Durchführen von Sicherungen | Saving backups | Backup
Zugriff auf Datenbankdateien (nur lesend) | Database file access (read only) | DBFileRead
Anzeigen von Zustandsinformationen | Request status data | DBInfoRead
Starten der Datenbankinstanz | Start database instance | DBStart
Stoppen der Datenbankinstanz | Stop database instance | DBStop
Ausführen des Programms Loader | Execute the LOAD program | ExecLoad
Installationsverwaltung | Installation management | InstallMgm
Laden der Systemtabellen | Load the system tables | LoadSysTab
Zugriff auf Datenbankparameter (lesend und schreibend; es dürfen nur jene Kommandos zum Ändern von Parametern ausgeführt werden, deren Änderungen vom System anhand der Vorschlagsparameterdatei cserv.pcf überprüft werden) | Parameter access (checked write) | ParamCheckWrite
Zugriff auf Datenbankparameter (lesend und schreibend; es dürfen alle Kommandos zum Ändern von Parametern ausgeführt werden, auch jene für das direkte Ändern der Parameterdatei, ohne dass die Änderungen vom System geprüft werden) | Parameter access (read and write) | ParamFull
Zugriff auf Datenbankparameter (nur lesend) | Parameter access (read only) | ParamRead
Wiederherstellen von Sicherungen | Restoring backups | Recovery
Verwalten des Scheduler | - | SchedulerMgm
Einplanen von DBM-Kommandos | - | Scheduling
Verwalten des Shared Memory |  | SharedMemoryAdmin
Ausführen von Betriebssystemkommandos | Execute operating system commands | SystemCmd
Verwalten der DBM-Benutzer | User management | UserMgm

Siehe auch:

Benutzer, Authentifizierung und Berechtigungen

Database Manager GUI, Strukturlink Ändern der Serverberechtigungen, Strukturlink Ändern der Serverberechtigungen des Datenbanksystemadministrators


Konventionen für Benutzernamen und Kennwörter (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Konventionen für Benutzernamen und Kennwörter

Sie können Benutzernamen und Kennwörter frei wählen. Es gelten jedoch die folgenden Einschränkungen:

● Benutzernamen dürfen maximal 18 Zeichen lang sein.

● Kennwörter dürfen maximal 9 Zeichen lang sein.

Darüber hinaus gelten für die verschiedenen Benutzer von MaxDB die folgenden Einschränkungen.

Datenbanksystemadministrator

Für den Namen und das Kennwort des Datenbanksystemadministrators gelten die Regeln für DBM-Benutzer.

Wählen Sie als Benutzernamen nicht SYSDBA. SYSDBA ist ein reserviertes SQL-Schlüsselwort.

Siehe Datenbanksystemadministrator (SYSDBA-Benutzer).

Database Manager-Benutzer (DBM-Benutzer)

Benutzername und Kennwort werden vom Datenbanksystem automatisch in Großbuchstaben umgewandelt.

Folgende Zeichen sind erlaubt:

● Erstes Zeichen:

A...Z, a...z, $, #, @

● Restliche Zeichen:

A...Z, a...z, $, #, @, 0...9, _

Sprachspezifische Zeichen, wie z. B. ä, sind nicht erlaubt.

Beim Eingeben von Benutzernamen und Kennwörtern auf der Kommandozeile müssen Sie einzelne Sonderzeichen unter Umständen mit einem Escape-Zeichen maskieren. Weitere Informationen hierzu finden Sie in der Dokumentation zu Ihrer Shell.

In einer Linux-Bash-Shell meldet sich Benutzer OLEG mit Kennwort M$NDAY mit dem Database Manager CLI an die Datenbankinstanz DEMODB an:

dbmcli -d DEMODB –u OLEG,M\$NDAY

Im Sitzungsmodus des Database Manager CLI müssen Sie Sonderzeichen nicht maskieren.

Siehe Database Manager-Benutzer (DBM-Benutzer).

Datenbankbenutzer

Benutzername und Kennwort dürfen alle Zeichen enthalten, die in folgenden Abschnitten des SQL-Referenzhandbuchs beschrieben sind: Benutzername (user_name), Kennwort (password).

Benutzername und Kennwort werden vom Datenbanksystem automatisch in Großbuchstaben umgewandelt. Wenn der Benutzername oder das Kennwort Kleinbuchstaben enthalten und das Datenbanksystem diese nicht in Großbuchstaben umwandeln soll, dann müssen Sie den gesamten Benutzernamen oder das gesamte Kennwort in Anführungszeichen setzen.

Um sich als Benutzer MONA mit dem Kennwort Red mit SQL Studio an eine Datenbankinstanz anzumelden, geben Sie im Anmeldedialog von SQL Studio folgende Daten ein:

MONA

"Red"

Beim Eingeben von Benutzernahmen und Kennwörtern auf der Kommandozeile müssen Sie unter Umständen Sonderzeichen, wie z. B. $ oder das Anführungszeichen, mit einem Escape-Zeichen maskieren. Weitere Informationen hierzu finden Sie in der Dokumentation zu Ihrer Shell.

In einer Linux-Bash-Shell meldet sich Benutzer MONA mit Kennwort R$D mit dem SQLCLI an die Datenbankinstanz DEMODB an:

sqlcli -d DEMODB -u MONA,R\$D

Siehe Datenbankbenutzer.

Siehe auch:

Benutzer, Authentifizierung und Berechtigungen


Authentifizierung (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Authentifizierung

Verwendung

Das Datenbanksystem authentifiziert Benutzer anhand ihrer Kennwörter.

Für die Authentifizierung verwendet das Datenbanksystem ein Challenge-Response-Verfahren (SCRAM-MD5). Dieses Verfahren stellt sicher, dass keine Kennwörter unverschlüsselt zwischen Client (Datenbankwerkzeug oder Schnittstelle) und Datenbankinstanz ausgetauscht werden.

Dieses Verfahren verschlüsselt nur Kennwörter. Um die Datenübertragung zu verschlüsseln, können Sie SSL/TLS einsetzen (siehe Datenverschlüsselung).

Voraussetzungen

Client und Datenbankinstanz verwenden die Datenbanksoftware in Version 7.6 oder höher.

Wenn der Client oder die Datenbankinstanz eine niedrigere Version der Datenbanksoftware verwendet, dann wird das ältere, unverschlüsselte Verfahren zur Authentifizierung eingesetzt.

Siehe auch:

Benutzer, Authentifizierung und Berechtigungen


Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux) (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)

Verwendung

Um die Datenbankressourcen vor unberechtigten Zugriffen zu schützen, verwendet MaxDB auf UNIX/Linux spezielle Betriebssystembenutzer und -gruppen:

· <sdb_user>

· <sdba_group>

· Supportgruppe

Nur diese Betriebssystembenutzer bzw. Mitglieder dieser Betriebssystemgruppen haben auf Betriebssystemebene direkten Zugriff auf die Datenbankressourcen.

Der Betriebssystemadministrator root wird nur für die Installation der Datenbanksoftware benötigt, aber nicht für den produktiven Betrieb.

Nur für den Benutzerwechsel zu <sdb_user> wird ein SetUID-Root-Programm benötigt.

Übersicht spezieller Betriebssystembenutzer und -gruppen

Name

Systemvorschlag

Typ

Rechte der Benutzer

root

root

Benutzer

Installieren der Datenbanksoftware

Vergeben von Zugriffsrechten für Betriebssystembenutzer (über deren Gruppenzugehörigkeit)

<sdb_user>

sdb

Benutzer

Eigentümer aller Datenbankressourcen

<sdba_group>

sdba

Gruppe

Anlegen von Datenbankinstanzen

Starten, Stoppen und Aktualisieren des X-Servers

Analyse und Fehlerbehebung

Supportgruppe

sdb<database_name>

Gruppe

optional; Supportaufgaben

<os_user>

Benutzer

normaler Betriebssystembenutzer

Zugriff auf das Datenbankwerkzeug Database Manager (benötigt zur Anmeldung an den Database einen gültigen DBM-Benutzernamen und ein Kennwort)

Zugriff auf andere Datenbankwerkzeuge (z. B. Loader, SQLCLI), Schnittstellen (ODBC, JDBC, SQLDBC) und alle Datenbankwerkzeuge, die diese Schnittstellen verwenden (Database Analyzer, Web Tools); hierfür benötigt er einen Datenbankbenutzernamen und ein Kennwort

Starten des X-Servers

<sid>adm

Benutzer

SAP-Systemadministrator und Datenbankadministrator in SAP-Systemen

Mitglied der Gruppe <sdba_group>

sqd<sid>

Benutzer

veraltet, nicht für liveCache-Datenbankinstanzen

Eigentümer aller Datenbankressourcen

Aktivitäten

Das Installationsprogramm legt die speziellen Betriebssystembenutzer und -gruppen werden bei der Installation der Datenbanksoftware an. Weitere Informationen finden Sie im Installationshandbuch unter Strukturlink Installation/Update der Software auf UNIX und für SAP-Systeme im entsprechenden Installationsleitfaden.

Wir empfehlen, die speziellen Betriebssystembenutzer und -gruppen bereits vor der Installation anzulegen. Während der Installation erhalten diese dann die hier beschriebenen Berechtigungen zum Zugriff auf die Datenbankressourcen.

Wenn Sie die Betriebssystembenutzer und -gruppen für Ihr System zentral im Netz verwalten, dann müssen Sie diese dort vor Beginn der Installation anlegen. Erläuterungen zum Anlegen von Betriebssystembenutzern und -gruppen finden Sie in Ihrer Betriebssystemdokumentation.

Welche Berechtigungen einzelne Betriebssystembenutzer für das Datenbanksystem haben, hängt davon ab, zu welchen Betriebssystemgruppen sie gehören. Der Betriebssystemadministrator ist dafür zuständig, die Betriebssystembenutzer zu Betriebssystemgruppen zuzuordnen. Bei lokaler Benutzerverwaltung ist root der Betriebssystemadministrator, bei Benutzerverwaltung mit Network Information Services (NIS) der NIS-Administrator.

Siehe auch:

Benutzer, Authentifizierung und Berechtigungen


<sdb_user> (spezieller Betriebssystembenutzer) (SAP-Bibliothek - Grundwissen)

Objektdokumentation <sdb_user> (spezieller Betriebssystembenutzer)

Definition

Das Datenbanksystem verwendet unter UNIX den speziellen Betriebssystembenutzer <sdb_user>. Der Systemvorschlag für den Namen von <sdb_user> ist sdb.

Verwendung

<sdb_user> ist der Eigentümer der folgenden Datenbankressourcen:

● Dateien und Verzeichnisse der Datenbanksoftware

Siehe auch Installationshandbuch, Strukturlink Verzeichnisse

● Datenbankprozesse, z. B. der vserver-Prozess (MaxDB-X-Server)

● Volumes

● Sicherungen

<sdb_user> wurde eingeführt, damit es einen eindeutigen Eigentümer der Datenbankressourcen gibt und so andere Betriebssystembenutzer keinen direkten, ungeschützten Betriebssystemzugriff auf die Datenbankressourcen haben.

<sdb_user> ist nicht dafür gedacht, dass sich ein Administrator als dieser Betriebssystembenutzer am Betriebssystem anmeldet. Verwenden Sie für Administrationsaufgaben einen beliebigen anderen Betriebssystembenutzer.

Aus Sicherheitsgründen darf <sdb_user> kein interaktiver Benutzer sein. Sie können die Datenbanksoftware nur dann installieren, wenn der Benutzer-Account des <sdb_user> gesperrt ist. Entziehen Sie <sdb_user> gegebenenfalls die Berechtigung, sich am Betriebssystem interaktiv anzumelden. Hinweise hierzu finden Sie in der Dokumentation Ihres Betriebssystems.

<sdb_user> muss zu folgenden Betriebssystemgruppen gehören:

● <sdba_group> (primäre Gruppe)

● Supportgruppen aller Datenbankinstanzen

Siehe auch:

Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)


<sdba_group> (spezielle Betriebssystemgruppe) (SAP-Bibliothek - Grundwissen)

Objektdokumentation <sdba_group> (spezielle Betriebssystemgruppe)

Definition

Das Datenbanksystem verwendet unter UNIX die spezielle Betriebssystemgruppe <sdba_group>. Der Systemvorschlag für den Namen von <sdba_group> ist sdba.

Verwendung

Folgende Datenbankressourcen haben die Betriebssystemgruppen-ID (GID) von <sdba_group>:

· Dateien und Verzeichnisse der Datenbanksoftware (z. B. User Profile Container)

· Datenbankprozesse

· vserver-Prozess (MaxDB-X-Server)

· Volumes, wenn es für die Datenbankinstanz keine Supportgruppe gibt

· Sicherungen

Zur Betriebssystemgruppe <sdba_group> gehören diejenigen Betriebssystembenutzer, die Verwaltungsaufgaben für das Datenbanksystem ausführen. Sie können u. a. folgende Aktionen ausführen:

· Erzeugen neuer Datenbankinstanzen

· Starten, Stoppen und Aktualisieren des vserver

· Zugriff auf das Verzeichnis <independent_data>/wrk und seine Unterverzeichnisse

· Zugriff auf das Datenbankwerkzeug XCONS

· Zugriff auf die Volumes, wenn es für die Datenbankinstanz keine Supportgruppe gibt

<sdba_group> ist außerdem die primäre Gruppe des speziellen Betriebssystembenutzers <sdb_user>.

Siehe auch:

Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)


Supportgruppe (spezielle Betriebssystemgruppe) (SAP-Bibliothek - Grundwissen)

Objektdokumentation Supportgruppe (spezielle Betriebssystemgruppe)

Definition

Das Datenbanksystem verwendet unter UNIX spezielle Betriebssystemgruppen, die Supportgruppen. Die Definition einer Supportgruppe für eine Datenbankinstanz ist optional.

Wir empfehlen, für jede Datenbankinstanz eine eigene Supportgruppe zu definieren.

Der Systemvorschlag für den Namen der Supportgruppe für eine Datenbankinstanz ist <sdb<database_name>>, z. B. sdbdemodb für die Datenbankinstanz DEMODB. Wenn Sie eine Supportgruppe definieren, dann müssen Sie den speziellen Betriebssystembenutzer <sdb_user> in diese Gruppe aufnehmen.

Verwendung

Betriebssystembenutzer, die zur Supportgruppe gehören, können Supportaufgaben ausführen, ohne dass sie hierfür Mitglied der Betriebssystemgruppe <sdba_group> sein müssen.

Wenn es eine Supportgruppe für eine Datenbankinstanz gibt, dann erhalten die Volumes die Betriebssystemgruppen-ID (GID) der Supportgruppe. Betriebssystembenutzer, die zur Supportgruppe gehören, können dann z. B. für Diagnosezwecke direkt auf die Volumes zugreifen.

Wenn Sie eine Supportgruppe definiert haben, ihr aber keine Betriebssystembenutzer zugewiesen haben (leere Supportgruppe), dann kann kein Betriebssystembenutzer direkt auf die Volumes zugreifen.

Wenn es eine Supportgruppe für eine Datenbankinstanz gibt, dann erhält auch der User Profile Container die GID der Supportgruppe. Der User Profile Container ist die Datei, in der der DBM-Server seine Rechte verwaltet. Verzeichnis und Name des User Profile Containers: <independent_data>/config/<database_name>.upc.

Siehe auch:

Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)


Sichern und Wiederherstellen (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Sichern und Wiederherstellen

Einsatzmöglichkeiten

Sichern Sie regelmäßig die Daten und Redo-Log-Einträge vom Daten- und Log-Bereich Ihrer Datenbankinstanz auf Datenträger.

Wenn die Datenbankinstanz aufgrund eines Hardwareschadens oder eines logischen Fehlers ausfällt, können Sie die Datenbankinstanz wieder in einen konsistenten Zustand bringen (wiederherstellen), indem Sie die in den Sicherungen gespeicherten Daten und Redo-Log-Einträge einlesen.

Wenn Sie sehr viele Daten einlesen müssen, kann das Wiederherstellen der Datenbankinstanz lange dauern. Weil das Wiederherstellen im Betriebszustand ADMIN erfolgt, ist die Datenbankinstanz während dieser Zeit für die Benutzer nicht verfügbar. Informationen dazu, wie sie eine Datenbankinstanz schneller wieder für die Benutzer verfügbar machen können, finden Sie im Abschnitt Replikation und High-Availability.

Zum Sichern und Wiederherstellen können Sie den Database Manager verwenden. Der Database Manager unterstützt auch die Verwendung von Sicherungswerkzeugen anderer Anbieter.

Ablauf

...

1. Sie erstellen einen Plan, wann Sie welche Sicherungen ausführen wollen.

Siehe Regelmäßige Verwaltungsaufgaben.

Wir empfehlen, vor Inbetriebnahme Ihres produktiven Systems das Sichern und Wiederherstellen auf einem Testrechner zu testen.

2. Sie definieren Sicherungsvorlagen.

Siehe Sicherungsvorlagen und Datenträger.

3. Während des normalen Datenbankbetriebs sichern Sie in regelmäßigen Abständen die Daten und die Redo-Log-Einträge. Die Sicherungen können im Betriebszustand ONLINE erfolgen, die Datenbankinstanz ist also während des Sicherns für die Benutzer verfügbar.

Siehe

○ Daten sichern

○ Log-Einträge sichern

Sie können mit dem Database Manager auch Sicherungen auf Datenträgern auf einem entfernten Rechner anlegen und eine Datenbankinstanz mit Hilfe solcher Sicherungen wiederherstellen, siehe Sichern/Wiederherstellen mit entfernten Rechnern.

Sie können Sicherungen, die Sie auf dem Betriebssystem Microsoft Windows erstellt haben, auf den Betriebssystemen UNIX und Linux verwenden, und umgekehrt.

Mit dem Datenbankwerkzeug Loader exportierte Daten sind keine Datensicherungen. Sie sind unter Umständen nicht konsistent und eignen sich nicht zum Wiederherstellen einer Datenbankinstanz.

4. Überprüfen Sie, ob das Datenbanksystem die Sicherung erfolgreich durchführen konnte.

Siehe Überwachung.

5. Für Log-Sicherungen können Sie Datenträger vom Typ Datei verwenden. Die so bei Log-Sicherungen entstehenden Sicherungsdateien sollten Sie regelmäßig archivieren.

Siehe Sicherungsdateien archivieren.

6. Mit Daten- und Log-Sicherungen können Sie nach einem Systemausfall die Datenbankinstanz wiederherstellen.

Siehe Datenbankinstanz wiederherstellen.

Ablauf von Sicherungen

Diese Grafik wird im zugehörigen Text erklärt

Beispiel

Beispiel: Sichern und Wiederherstellen

Siehe auch:

Sicherungswerkzeuge anderer Anbieter verwenden

Datenbereich einfrieren (Snapshot)

Exportieren und Importieren

Verwaltung

Datenspeicherung


Sicherungsvorlagen und Datenträger (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Sicherungsvorlagen und Datenträger

Verwendung

Beim Sichern werden die Daten/die Log-Einträge auf einen Datenträger gespeichert, z. B. auf Bänder oder in Dateien im Dateisystem.

Bevor Sie Daten oder Log-Einträge auf einen Datenträger speichern können, müssen Sie eine Sicherungsvorlage definieren. In den Eigenschaften der Sicherungsvorlage legen Sie unter anderem die Sicherungsart und den Typ des zu verwendenden Datenträgers fest. Der Database Manager speichert Sicherungsvorlagen in der Datei dbm.mmm (siehe Konfigurationsdateien). Sie können die gleiche Sicherungsvorlage mehrfach verwenden.

Eigenschaften von Sicherungsvorlagen

● Name

Den Namen der Sicherungsvorlage können Sie frei wählen. Der Name der Sicherungsvorlage hat keinen Einfluss auf den Namen der später mit dieser Sicherungsvorlage erstellten Sicherungen.

● Sicherungsart (vollständige Datensicherung, inkrementelle Datensicherung, Log-Sicherung, automatische Log-Sicherung)

● Typ des Datenträgers

Typ | Für welche Sicherungsarten verwendbar? | Bemerkungen
Datei (FILE) | ● Datensicherung ● Log-Sicherung ● automatische Log-Sicherung |
Band (TAPE) | ● Datensicherung | Sie können einen Autoloader verwenden.
Pipe (PIPE) | ● Datensicherung ● Log-Sicherung | Automatische Log-Sicherungen können nicht in Pipes durchgeführt werden.

Beachten Sie weitere Empfehlungen und Einschränkungen, siehe Hinweise zu den verschiedenen Typen von Datenträgern.

● Datenträger (Device/File)

Sie geben die vom Betriebssystem vorgegebene Bezeichnung der Bandstation oder den Pfad und Dateinamen der Datei im Dateisystem oder den Pfad und Namen der Pipe an.

Bei Log-Sicherungen in Dateien fügt das System dem jeweiligen Dateinamen für jede neue Sicherungsdatei eine laufende Nummer hinzu. Das System vergibt die aufsteigenden Nummern fortlaufend, solange die Historie der Log-Sicherungen nicht unterbrochen wird. Nach einer Unterbrechung der Historie der Log-Sicherungen (z.B. durch das Initialisieren der Datenbankinstanz) beginnt das System die Nummerierung wieder bei 001.

Das System vergibt auch dann fortlaufende Nummern, wenn Sie Log-Sicherungen für dieselbe Datenbankinstanz nacheinander auf verschiedenen Datenträgern und damit in Dateien mit verschiedenen Dateinamen ausführen.

LogUri.001

LogKai.002

LogOleg.003

LogUri.004

LogUri.005

Bei eingeschalteter automatischer Log-Sicherung speichert das System alle Sicherungsdateien unter demselben Dateinamen mit einer angehängten laufenden Nummer.

autoLog.001

autoLog.002

autoLog.003

autoLog.004

autoLog.005

● Größe des Datenträgers

Für Datensicherungen können Sie die Größe des Datenträgers frei wählen. Wenn Sie keine Angabe machen, gibt es keine Größenbeschränkung.

Log-Sicherungen in Dateien haben immer die Größe eines Log-Segments (allgemeiner Datenbankparameter LOG_SEGMENT_SIZE) zuzüglich des Platzbedarfs für systeminterne Informationen.

● überschreibbar

Wenn Sie in eine Datei sichern und diese Datei mehrfach verwenden möchten, dann definieren Sie den Datenträger in der Sicherungsvorlage als überschreibbar. Wenn Sie eine solche Sicherungsvorlage für eine Sicherung verwenden, dann überschreibt das System den Inhalt der alten Sicherung (falls vorhanden) mit dem Inhalt der neuen Sicherung.

● Blockgröße

Sie können die Blockgröße festlegen, mit der das System die Sicherung auf den Datenträger schreibt.

Beispiel: Sicherungsvorlage

Eigenschaft | Wert
Name der Sicherungsvorlage | meine Datensicherung der DEMODB
Sicherungsart | vollständige Datensicherung (DATA)
Typ des Datenträgers | Datei (FILE)
Datenträger (Device/File) | backup 2005\data\complDataJan
Größe des Datenträgers | keine Beschränkung (leer)
Blockgröße | 6 Seiten
überschreibbar | nein

Aktivitäten

Sie verwenden den Database Manager oder das CCMS (in SAP-Systemen).

Sicherungsvorlage definieren

● Database Manager GUI, Strukturlink Sicherungsvorlage für einen einzelnen Datenträger, Strukturlink Sicherungsvorlage für eine Gruppe paralleler Datenträger

● Database Manager CLI, Strukturlink medium_put

● Tutorial Datenbankverwaltung, Strukturlink Sicherungsvorlagen definieren

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Sicherungsvorlagen

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Sicherungsvorlagen

Sie können auch Sicherungsvorlagen für das parallele Sichern definieren.

Sicherungsvorlagen verwalten

● Database Manager GUI, Strukturlink Verwalten der Sicherungsvorlagen

● Database Manager CLI, Strukturlink Sichern und Wiederherstellen der Datenbankinstanz

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Sicherungsvorlagen

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Sicherungsvorlagen

Sicherung auf einem Datenträger prüfen

Prüfen Sie regelmäßig, ob Ihre Sicherungen intakt sind. Siehe

● Database Manager GUI, Strukturlink Sicherung prüfen

● Database Manager CLI, Strukturlink recover_check

Siehe auch:

Sichern und Wiederherstellen

Sicherungswerkzeuge anderer Anbieter verwenden

Allgemeine Datenbankparameter

Tutorial Datenbankverwaltung, Strukturlink Sicherungsvorlagen definieren


Hinweise zu den verschiedenen Typen von Datenträgern (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Hinweise zu den verschiedenen Typen von Datenträgern

Alle Typen von Datenträgern

● Verwenden Sie für jede Datenbankinstanz gesonderte Datenträger.

● Überschreiben Sie eine Sicherung nicht gleich mit der nächsten Sicherung. Bewahren Sie immer mindestens eine ältere Version der Sicherung auf.

● Sie können mit dem Database Manager auch Sicherungen auf Datenträgern auf einem entfernten Rechner anlegen, prüfen und eine Datenbankinstanz mit Hilfe solcher Sicherungen wiederherstellen. Hierfür können einige vorbereitende Schritte notwendig sein, siehe Sichern/Wiederherstellen mit entfernten Rechnern.

Datenträger vom Typ Datei

● Legen Sie Sicherungen auf Datenträgern vom Typ Datei nicht auf derselben Festplatte wie die Volumes der Datenbankinstanz an, sondern auf einer separaten Festplatte.

● Kopieren Sie die Sicherungen regelmäßig mit Betriebssystemkommandos auf einen anderen Rechner oder einen anderen Datenträger, z. B. eine CD.

Datenträger vom Typ Band

● Verwenden Sie Bänder nicht öfter, als dies vom Hersteller empfohlen wird.

● UNIX

○ Achten Sie darauf, dass Sie den korrekten Gerätetreiber ansprechen.

○ Verwenden Sie für Datensicherungen ein Rewind-Band.

Datenträger vom Typ Pipe

● Auf Microsoft Windows werden die Pipes vom Datenbankkern angelegt.

Auf UNIX werden die Pipes nicht vom Datenbankkern angelegt:

○ Beim Sichern ohne Sicherungswerkzeug gilt:

Sie müssen die Pipe vor Beginn des Sicherungsvorgangs explizit anlegen.

○ Beim Sichern mit einem Sicherungswerkzeug eines anderer Anbieters, das nicht direkt von MaxDB unterstützt wird, gilt:

Sie müssen die Pipe vor Beginn des Sicherungsvorgangs explizit anlegen.

○ Beim Sichern mit einem Sicherungswerkzeug eines anderen Anbieters, das direkt von MaxDB unterstützt wird, gilt:

Die Pipe wird vom Database Manager während des Sicherungsvorgangs angelegt. Die Pipe darf vorher nicht vorhanden sein.

● Bevor Sie eine Log-Sicherung in eine Pipe ohne Sicherungswerkzeug oder mit einem Sicherungswerkzeug eines anderen Anbieters, das nicht direkt von MaxDB unterstützt wird, durchführen, setzen Sie den Wert des speziellen Datenbankparameters LOG_BACKUP_TO_PIPE auf YES.

Hiermit stellen Sie sicher, dass das System bereits in die Pipe geschriebene Log-Einträge im Log-Bereich wieder überschreiben kann. Beachten Sie, dass das System nicht prüft, ob die Log-Sicherung über die Pipe erfolgreich war.

Siehe auch:

Sicherungsvorlagen und Datenträger

Sicherungswerkzeuge anderer Anbieter verwenden

Spezielle Datenbankparameter


Daten sichern (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Daten sichern

Verwendung

Das Datenbanksystem speichert die Daten der Datenbank im Datenbereich. Sie benötigen Datensicherungen, um die Datenbankinstanz wiederherzustellen, wenn der Datenbereich beispielsweise durch einen Festplattenfehler beschädigt wurde. Sichern Sie deshalb regelmäßig die Daten auf Datenträger.

Eventuell benötigen Sie nach einem Schaden im Datenbereich zusätzlich zu den Datensicherungen auch gesicherte Log-Einträge, um den gewünschten Zustand der Datenbankinstanz wiederherzustellen (Siehe Log-Einträge sichern).

Sicherungsarten

Name | Beschreibung
vollständige Datensicherung | Sie sichern den gesamten Datenbereich.
inkrementelle Datensicherung | Sie sichern alle Daten aus dem Datenbereich, die seit der letzten vollständigen Datensicherung geändert wurden.

Voraussetzungen

Während einer vollständigen Datensicherung können Sie keine inkrementelle Datensicherung starten, und umgekehrt.

● Sie haben eine Sicherungsvorlage definiert (siehe Sicherungsvorlagen und Datenträger).

● Nur für Microsoft Windows: Wenn Sie auf einen Datenträger sichern wollen, der sich auf einem entfernten Rechner befindet, dann führen Sie die unter Sichern/Wiederherstellen mit entfernten Rechnern beschriebenen Schritte durch.

Aktivitäten

Um Daten zu sichern, verwenden Sie das Datenbankwerkzeug Database Manager oder in SAP-Systemen das CCMS. Siehe

...

● Database Manager GUI, Strukturlink Backup Wizard

● Database Manager CLI, Strukturlink backup_start

● Datenbankverwaltung im CCMS, Strukturlink Datensicherung einplanen

Diese Werkzeuge können verschiedene Typen von Datenträgern und verschiedene Sicherungsgeräte verwenden, darunter auch Sicherungswerkzeuge anderer Anbieter, siehe Sicherungswerkzeuge anderer Anbieter verwenden.

Siehe auch:

Sichern und Wiederherstellen

Tutorial Datenbankverwaltung

● Strukturlink Vollständige Datensicherung in eine Datei durchführen

● Strukturlink Vollständige Datensicherung auf ein Band durchführen

● Strukturlink Inkrementelle Datensicherung in eine Datei durchführen


Log-Einträge sichern (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Log-Einträge sichern

Verwendung

Nach bestimmten Systemausfällen benötigen Sie Sicherungen der Redo-Log-Einträge (Log-Sicherungen), um die Datenbankinstanz wiederherstellen zu können. In den Redo-Log-Einträgen protokolliert das Datenbanksystem alle Änderungen, die Datenbankbenutzer an Daten vornehmen.

Wenn z. B. bei einem Systemausfall der Log-Bereich beschädigt wurde, kann das Datenbanksystem die zuletzt durchgeführten Datenänderungen, die es nicht mehr in den Datenbereich schreiben konnte, nur mit Hilfe von Log-Sicherungen wiederholen.

Wenn das Datenbanksystem wegen eines Systemausfalls die zuletzt durchgeführten Datenänderungen nicht mehr in den Datenbereich schreiben konnte, der Log-Bereich beim Systemausfall jedoch unbeschädigt geblieben ist, dann benötigen Sie keine Log-Sicherungen.

In diesem Fall kann das Datenbanksystem die Datenänderungen beim Restart mit Hilfe der Redo-Log-Einträge aus dem Log-Bereich wiederholen (siehe Beispiel: Restart).

Regelmäßige Log-Sicherungen sind auch aus einem weiteren Grund wichtig: das Datenbanksystem kann nur bereits gesicherte Log-Segmente des Log-Bereichs wieder mit neuen Redo-Log-Einträgen überschreiben.

Wenn das Datenbanksystem keine neuen Redo-Log-Einträge mehr in den Log-Bereich schreiben kann (Log-Bereich ist voll), dann kommt es zum Datenbankstillstand.

Sie können erst dann weiterarbeiten, wenn Sie eine Log-Sicherung durchgeführt haben. Ausnahme: Sie haben den Überschreibmodus für den Log-Bereich eingeschaltet (siehe Log-Einstellungen).

Voraussetzungen

● Bevor Sie Redo-Log-Einträge sichern können, muss von der Datenbankinstanz mindestens einmal eine vollständige Datensicherung erstellt worden sein.

● Sie haben eine Sicherungsvorlage definiert, siehe Sicherungsvorlagen und Datenträger.

● Die Datenbankinstanz ist im Betriebszustand ONLINE oder ADMIN.

● Während eine Log-Sicherung läuft, können Sie keine andere Sicherung starten.

Ausnahme: während die automatische Log-Sicherung eingeschaltet ist, können Sie Datensicherungen durchführen.

● Nur für Microsoft Windows: Wenn Sie auf einen Datenträger sichern wollen, der sich auf einem entfernten Rechner befindet, dann führen Sie die unter Sichern/Wiederherstellen mit entfernten Rechnern beschriebenen Schritte durch.

Aktivitäten

Sichern Sie regelmäßig die Redo-Log-Einträge aus dem Log-Bereich auf Datenträger.

Sie können die Redo-Log-Einträge auch automatisch sichern lassen (siehe automatische Log-Sicherung ein-/ausschalten).

Log-Sicherung durchführen

Bei einer Log-Sicherung sichern Sie alle Redo-Log-Einträge, die das Datenbanksystem seit der letzten Log-Sicherung neu in den Log-Bereich geschrieben hat, auf einen Datenträger. Sie können das Datenbankwerkzeug Database Manager oder das CCMS (in SAP-Systemen) verwenden.

Sie können eine Sicherungsvorlage für das Sichern in eine Datei oder eine Sicherungsvorlage für das Sichern in eine Pipe verwenden:

● Beim Sichern in eine Datei legt das System nacheinander die notwendige Anzahl von Dateien an und sichert darin jeweils eine Datenmenge in der Größe eines Log-Segments. Die übrigen Daten werden in der letzten Datei gesichert.

● Für das Sichern in Pipes gelten einige Einschränkungen, siehe Hinweise zu den verschiedenen Typen von Datenträgern.

Zur Vorgehensweise siehe

● Database Manager GUI, Strukturlink Sicherungsverfahren

● Database Manager CLI, Strukturlink Sichern und Wiederherstellen von Datenbankinstanzen

● Datenbankverwaltung im CCMS, Strukturlink Interaktive Log-Sicherung einplanen

Automatische Log-Sicherung ein-/ausschalten

Um die Redo-Log-Einträge automatisch sichern zu lassen, schalten Sie die automatische Log-Sicherung ein. Wenn die automatische Log-Sicherung eingeschaltet ist, dann sichert das Datenbanksystem die Redo-Log-Einträge automatisch in Sicherungsdateien.

Das Datenbanksystem startet immer dann eine Log-Sicherung, wenn ein Log-Segment voll ist. Die Größe der Log-Segmente konfigurieren Sie mit dem allgemeinen Datenbankparameter LOG_SEGMENT_SIZE.

Wir empfehlen, die automatische Log-Sicherung insbesondere dann einzuschalten, wenn in der Datenbankinstanz viele Daten geändert werden und demzufolge mit vielen Redo-Log-Einträgen zu rechnen ist.

Siehe

● Database Manager GUI, Strukturlink Ein- und Ausschalten der automatischen Log-Sicherung

● Database Manager CLI, Strukturlink autolog_on

● Datenbankverwaltung im CCMS, Strukturlink Automatische Log-Sicherung aktivieren

Sicherungsdateien archivieren

Bei Log-Sicherungen auf Datenträger vom Typ Datei müssen Sie dabei erzeugten Sicherungsdateien regelmäßig archivieren, siehe Sicherungsdateien archivieren.

Siehe auch:

Sichern und Wiederherstellen

Tutorial Datenbankverwaltung

● Strukturlink Automatische Log-Sicherung einschalten

● Strukturlink Log-Sicherung in eine Pipe durchführen

● Strukturlink Sichern mit Sicherungswerkzeugen anderer Anbieter


Sicherungsdateien archivieren (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Sicherungsdateien archivieren

Verwendung

Wenn Sie Ihre Log-Einträge auf Datenträgern vom Typ Datei sichern, empfehlen wir, diese Sicherungsdateien regelmäßig zu archivieren. Das Archivieren der Sicherungsdateien ist notwendig, damit es nicht zu einem Datenbankstillstand wegen einer vollen Festplatte kommen kann.

Wenn die automatische Log-Sicherung eingeschaltet ist, schreibt das Datenbanksystem kontinuierlich Sicherungsdateien, die in chronologischer Reihenfolge die Redo-Log-Einträge enthalten. Die Zahl der Sicherungsdateien auf der Festplatte wächst also kontinuierlich an, bis unter Umständen kein Speicherplatz mehr verfügbar ist.

Wenn kein Speicherplatz mehr für Log-Sicherungen auf der Festplatte verfügbar ist, dann steht nach einer gewissen Zeit auch im Log-Bereich der Datenbankinstanz kein Speicherplatz mehr für Redo-Log-Einträge zur Verfügung (Ausnahme: der Überschreibmodus für den Log-Bereich ist eingeschaltet). Wenn das Datenbanksystem keine Redo-Log-Einträge mehr in den Log-Bereich schreiben kann, dann können auch keine Daten mehr geändert werden, und es kommt zu einem Datenbankstillstand.

Voraussetzungen

Sie sichern Ihre Log-Einträge auf Datenträgern vom Typ Datei, siehe Log-Einträge sichern.

Aktivitäten

● Um die Sicherungsdateien zu archivieren, kopieren Sie die ältesten Sicherungsdateien mit Betriebssystemkommandos auf eine andere Festplatte oder einen anderen Datenträger. Danach löschen Sie die Originale der Sicherungsdateien.

Wenn die automatische Log-Sicherung eingeschaltet ist, dann sichert das System auch während des Archivierens der Sicherungsdateien neue Log-Einträge in die neueste Sicherungsdatei.

Um sicherzustellen, dass Sie nur vollständige Sicherungsdateien archivieren, lassen Sie beim Archivieren jeweils die neueste Sicherungsdatei aus.

● Wenn Sie ein Sicherungswerkzeug anderer Anbieter verwenden, dann können Sie das Archivieren der Sicherungsdateien automatisieren.

Verwenden Sie dazu den Database Manager oder CCMS-Funktionalität:

Database Manager CLI, Strukturlink Weitere Kommandos zum Sichern

Datenbankverwaltung im CCMS, Strukturlink Sicherungsdateien archivieren

Siehe auch:

Regelmäßige Verwaltungsaufgaben

Sicherungswerkzeuge anderer Anbieter verwenden


Datenbankinstanz wiederherstellen (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Datenbankinstanz wiederherstellen

Einsatzmöglichkeiten

Nach einem Ausfall oder Fehler können Sie Ihre Datenbankinstanz wiederherstellen oder in einen früheren Zustand zurücksetzen, indem Sie Datensicherungen und Log-Sicherungen von Datenträgern einlesen.

Voraussetzungen

● Sie verfügen über Daten- und Log-Sicherungen für die Datenbankinstanz. Siehe Daten sichern und Log-Einträge sichern.

● Nur für Microsoft Windows: Wenn Sie die Datenbankinstanz mit Sicherungen von Datenträgern wiederherstellen wollen, die sich auf einem entfernten Rechner befinden, dann führen Sie die unter Sichern/Wiederherstellen mit entfernten Rechnern beschriebenen Schritte durch.

● Das Datenbanksystem versucht beim Wiederherstellen zunächst immer, noch im Log-Bereich vorhandene Redo-Log-Einträge einzulesen. Wenn Sie dies verhindern und erzwingen möchten, dass alle Redo-Log-Einträge im Log-Bereich gelöscht werden, dann initialisieren Sie vor dem Wiederherstellen den Log-Bereich.

Siehe Database Manager GUI, Strukturlink Wiederherstellen nach Initialisieren einer Datenbankinstanz und Database Manager CLI, Strukturlink db_activate RECOVER.

Ablauf

Sie verwenden zum Wiederherstellen den Database Manager.

...

1. Sie lesen eine vollständige Datensicherung ein.

Siehe

○ Database Manager GUI, Strukturlink Wiederherstellen

○ Database Manager CLI, Strukturlink Sichern und Wiederherstellen der Datenbankinstanz

2. Wenn notwendig, lesen Sie zusätzlich eine inkrementelle Datensicherung und Log-Sicherungen ein.

3. Wenn notwendig, stellen Sie beschädigte Indizes wieder her.

Siehe

○ Database Manager GUI, Strukturlink Wiederherstellen der Indizes nach Datenbankwiederherstellung

○ Database Manager CLI, Strukturlink sql_recreateindex

○ Datenbankverwaltung im CCMS: MaxDB, Strukturlink Indexanalyse

○ Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Bad Indexes

Siehe auch:

Sichern und Wiederherstellen

Beispiel: Sichern und Wiederherstellen

Tutorial Datenbankverwaltung, Strukturlink Wiederherstellen der Datenbankinstanz


Beispiel: Sichern und Wiederherstellen (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Sichern und Wiederherstellen

Die folgende Abbildung zeigt ein Beispiel dafür, wie Sie die Datenbankinstanz DEMODB im laufenden Betrieb sichern und nach einem Systemausfall aus Daten- und Log-Sicherungen wiederherstellen.

Diese Grafik wird im zugehörigen Text erklärt

Beispiel für das Sichern und Wiederherstellen

...

1. Sie erstellen eine vollständige Datensicherung der Datenbankinstanz DEMODB auf einen Datenträger.

2. Sie schalten die automatische Log-Sicherung ein. Das Datenbanksystem erstellt von diesem Zeitpunkt an kontinuierlich Log-Sicherungen in Sicherungsdateien.

3. Sie erstellen in regelmäßigen Zeitabständen inkrementelle Datensicherungen.

4. Es kommt zu einem Systemausfall, weil die Festplatte mit dem Datenbereich der Datenbankinstanz einen Hardwarefehler hat. Die Festplatte, auf der der Log-Bereich liegt, bleibt jedoch unbeschädigt.

5. Um die Datenbankinstanz wiederherzustellen, gehen Sie folgendermaßen vor:

a. Sie ersetzen die defekte Festplatte.

b. Sie lesen die letzte vollständige Datensicherung ein.

c. Sie lesen die letzte inkrementelle Datensicherung ein.

d. Sie lesen die Log-Sicherungen seit der letzten inkrementellen Datensicherung ein. Wenn noch Redo-Log-Einträge im unbeschädigten Log-Bereich existieren, dann verwendet das Datenbanksystem diese Redo-Log-Einträge anstelle der entsprechenden Log-Sicherungen.

6. Das Datenbanksystem bringt die Datenbankinstanz wieder in den Betriebszustand ONLINE.

Siehe auch:

Sichern und Wiederherstellen

Tutorial Datenbankverwaltung, Strukturlink Sichern


Sichern/Wiederherstellen mit entfernten Rechnern (SAP-Bibliothek - Grundwissen)

Vorgehensweisen Sichern/Wiederherstellen mit entfernten Rechnern

Verwendung

Sie können mit dem Database Manager auch Sicherungen auf Datenträgern auf einem entfernten Rechner anlegen, prüfen, oder eine Datenbankinstanz mit Hilfe solcher Sicherungen wiederherstellen. Hierfür starten Sie den Dienst der Datenbankinstanz unter dem Namen eines Betriebssystembenutzers, den es auf beiden Rechnern gibt.

Das Sichern auf einem entfernten Rechner ist anfällig für Übertragungsfehler. Außerdem ist es langsamer als das Sichern auf dem lokalen Rechner.

Voraussetzungen

● Beide Rechner verwenden ein Microsoft Windows-Betriebssystem.

● Es gibt einen Betriebssystembenutzer, der auf beiden Rechnern bekannt ist.

Auf UNIX/Linux läuft der Dienst der Datenbankinstanz immer unter einem speziellen Betriebssystembenutzer, siehe Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux).

● Dieser Betriebssystembenutzer hat auf beiden Rechnern die notwendigen Berechtigungen für die verwendeten Verzeichnisse, ist also z. B. berechtigt, auf dem entfernten Rechner die Sicherungen zu lesen.

● Sie haben eine Sicherungsvorlage angelegt, siehe Sicherungsvorlagen und Datenträger.

Vorgehensweise

...

1. Öffnen Sie die Services-Verwaltung in der Microsoft Management Console.

2. Stoppen Sie den Dienst der Datenbankinstanz, die Sie sichern/wiederherstellen möchten.

3. Öffnen Sie die Eigenschaften dieses Dienstes.

4. Tragen Sie auf der Registerkarte Log On den Betriebssystembenutzer ein, den es auf beiden Rechner gibt.

5. Starten Sie den Dienst der Datenbankinstanz wieder.

Ergebnis

Sie können nun Sicherungen auf dem entfernten Rechner durchführen/prüfen oder die Datenbankinstanz mit Sicherungen vom entfernten Rechner wiederherstellen.

Siehe auch:

Daten sichern

Log-Einträge sichern

Datenbankinstanz wiederherstellen

Tutorial Datenbankverwaltung, Strukturlink Sichern der Datenbankinstanz auf einen entfernten Rechner


Sicherungswerkzeuge anderer Anbieter verwenden (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Sicherungswerkzeuge anderer Anbieter verwenden

Verwendung

Um Daten und Log-Einträge zu sichern und wiederherzustellen oder um Daten zu exportieren und zu importieren, können Sie Sicherungswerkzeuge anderer Anbieter verwenden.

Einige dieser Sicherungswerkzeuge werden direkt vom Datenbanksystem unterstützt. Mit Betriebssystemskripten können Sie jedoch auch alle anderen Sicherungswerkzeuge verwenden, die Sicherungen aus Pipes verarbeiten können.

Wenn Sie ein nicht direkt von MaxDB unterstütztes Sicherungswerkzeug verwenden, dann beachten Sie Folgendes: Nachdem der Database Manager eine Sicherung in eine Pipe geschrieben hat, kann er nicht prüfen, ob diese Sicherung auch erfolgreich war (auch die Sicherungshistorie im Database Manager gibt in diesem Fall darüber keine verlässliche Auskunft). Prüfen Sie deshalb mit Ihrem Betriebssystemskript, ob die Sicherung erfolgreich war.

Für das Sichern in Pipes gelten außerdem weitere Einschränkungen, siehe Hinweise zu den verschiedenen Typen von Datenträgern.

Während des Sicherns oder des Exportierens von Daten mit einem Sicherungswerkzeugs, das direkt vom Datenbanksystem unterstützt wird, erhält jede Sicherung/jeder Datenstrom eine externe Sicherungskennung (External Backup ID).

Unterstützte Sicherungswerkzeuge anderer Anbieter

Name | Beschreibung
TSM (IBM/Tivoli) | TSM können Sie über den TSM-Client adint2 oder über die Strukturlink Backint for Oracle-Schnittstelle anbinden. Mit adint2 erreichen Sie eine bessere Performance; dieses Programm steht aber nicht auf allen Plattformen zur Verfügung. Siehe Installationshandbuch, Strukturlink Anschluss an TSM
NetWorker (Legato) | Siehe Installationshandbuch, Strukturlink Anschluss an NetWorker
NetBackup (Veritas) | Siehe Installationshandbuch, Strukturlink Anschluss an VERITAS NetBackup
alle Sicherungswerkzeuge, die Backint for MaxDB unterstützen | Informationen zu den Anforderungen an eine Backint for MaxDB-Schnittstelle finden Sie in der Dokumentation Strukturlink Backint for MaxDB.
alle Sicherungswerkzeuge, die Backint for Oracle unterstützen | Nähere Informationen finden Sie unter folgender Internetadresse: www.sap.com/softwarepartnerdir

Siehe auch:

Sichern und Wiederherstellen

Installationshandbuch, Strukturlink Anschluss von Sicherungswerkzeugen anderer Anbieter

Database Manager GUI, Strukturlink Sichern mit Sicherungswerkzeugen anderer Anbieter

Database Manager CLI, Strukturlink Sichern und Wiederherstellen von Datenbankinstanzen

Tutorial Datenbankverwaltung, Strukturlink Sichern mit Sicherungswerkzeugen anderer Anbieter

Loader, Strukturlink Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter


Datenbereich einfrieren (Snapshot) (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Datenbereich einfrieren (Snapshot)

Verwendung

Ein Snapshot friert den aktuellen Zustand des Datenbereichs ein. Nachdem Sie einen Snapshot gemacht haben, können Sie mit den Daten der Datenbankinstanz normal weiterarbeiten und Daten ändern, ohne damit den Snapshot zu beeinflussen.

Zu einem späteren Zeitpunkt haben Sie die folgenden Möglichkeiten:

● Sie kehren zum Zustand des Datenbereichs zum Zeitpunkt des Snapshot zurück und verwerfen damit alle Änderungen seit dem Snapshot. Der Snapshot enthält alle notwendigen Informationen, Sie benötigen hierfür keine vollständige Datensicherung.

Ein Snapshot ist keine Datensicherung. Um Ihre Daten nach einem Schaden im Datenbereich wiederherstellen zu können, müssen Sie regelmäßig Daten- und Logsicherungen durchführen.

● Sie löschen den Snapshot und übernehmen damit alle Änderungen im Datenbereich, die seit dem Snapshot erfolgt sind.

Es kann immer nur ein Snapshot existieren. Das Erzeugen eines neuen Snapshot überschreibt einen eventuell vorhandenen älteren Snapshot.

Aktivitäten

Um Snapshots zu verwalten, verwenden Sie den Database Manager GUI. Siehe Database Manager GUI, Strukturlink Einfrieren des Datenbereichs (Snapshots).

Für das Erstellen und Verwalten des Snapshot nutzt das Datenbanksystem ein Schattenspeicherkonzept: ein Snapshot speichert den aktuellen Converter.

Der Converter bildet die logischen Nummern der Seiten, die die Daten enthalten, auf die physischen Seiten (Blockadressen) in den Data-Volumes ab. Der Converter ist baumartig aufgebaut: vom Einstiegspunkt führen Verweise zu allen logischen Seiten des Datenbereichs und von dort zu den Blockadressen in den Data-Volumes.

Wenn Sie einen Snapshot erstellen, speichert das Datenbanksystem in der Restart-Information der Datenbankinstanz einen Verweis auf den aktuellen Einstiegspunkt in den Converter und markiert alle über den Converter adressierten physischen Seiten im Datenbereich. Diese Seiten kann das Datenbanksystem nicht überschreiben, solange der Snapshot existiert.

Datenänderungen, die Sie nach dem Snapshot machen, schreibt das Datenbanksystem auf andere physische Seiten im Datenbereich. Wenn Sie eine Tabelle löschen, dann löscht das Datenbanksystem diese Tabelle nicht physisch, sondern markiert sie nur als gelöscht (sie können nicht mehr mit SQL-Anweisungen auf diese Tabelle zugreifen). Auf diese Weise baut das Datenbanksystem nach und nach eine neue Version des Converters auf, die sich mit der Zeit immer mehr von der Version des Converters unterscheidet, die beim Snapshot gespeichert wurde.

Wenn Sie alle Änderungen nach dem Snapshot verwerfen, dann löscht das Datenbanksystem den Einstiegspunkt in die neue Version des Converters und ersetzt ihn durch den Einstiegspunkt, der im Snapshot gespeichert ist. Alle nach dem Snapshot geänderten Seiten werden hierdurch wieder zum Überschreiben freigegeben.

Wenn Sie den Snapshot löschen, dann gibt das Datenbanksystem die markierten Seiten im Datenbereich zum Überschreiben frei.

Beispiel

Einrichten eines Schulungsrechners:

...

1. Der Datenbankadministrator liest auf dem Schulungsrechner eine vollständige Datensicherung von der Original-Datenbankinstanz ein.

2. Der Datenbankadministrator macht im Betriebszustand ADMIN einen Snapshot und überführt die Datenbankinstanz dann in den Betriebszustand ONLINE.

3. Die Datenbankinstanz steht nun für den Schulungsbetrieb zur Verfügung. Der Schulungsteilnehmer kann beliebig Daten ändern und die Datenbankinstanz starten und stoppen.

4. Nach Ende der Schulung und vor Beginn der nächsten Schulung überführt der Datenbankadministrator die Datenbankinstanz in den Betriebszustand ADMIN und verwirft alle Änderungen seit dem Snapshot.

Sichern und Wiederherstellen


Exportieren und Importieren (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Exportieren und Importieren

Verwendung

Sie können Anwendungsdaten und den Datenbankkatalog aus einer MaxDB-Datenbankinstanz exportieren oder sie in eine MaxDB-Datenbankinstanz importieren.

Aktivitäten

Die folgende Tabelle zeigt, welche Datenbankwerkzeuge für welche Aufgaben geeignet sind.

Datentransfer

Aufgabe | Datenquelle | Datenziel | Datenbankwerkzeug
Anwendungsdaten exportieren: einschließlich LONG-Spalten in verschiedenen Formaten Konvertierung von Datums- und Zeitwerten Konvertierung von NULL-Werten Mapping von Zeichensätzen | MaxDB-Datenbankinstanz | MaxDB-Datenbankinstanz Datei Pipe externer Datenträger, z. B. ein Band | Loader, Strukturlink Exportieren: Kommandos Strukturlink Exportieren von LONG-Werten
Anwendungsdaten importieren: einschließlich LONG-Spalten in verschiedenen Formaten Konvertierung von Datums- und Zeitformaten Konvertierung von NULL-Werten Mapping von Zeichensätzen | MaxDB-Datenbankinstanz Datei Pipe externer Datenträger, z. B. ein Band | MaxDB-Datenbankinstanz | Loader, Strukturlink Importieren: Kommandos Strukturlink Importieren von LONG-Werten
Datenbankkatalog exportieren | MaxDB-Datenbankinstanz | MaxDB-Datenbankinstanz Datei Pipe externer Datenträger, z. B. ein Band | Loader,
Datenbankkatalog importieren | s. o. | MaxDB-Datenbankinstanz | Loader, Exportieren und Importieren: Kommandos (s. o.)
Anwendungsdaten exportieren: LONG-Werte eingeschränkt (nur einzeln bzw. nur bis zu einer bestimmten Länge) | MaxDB-Datenbankinstanz | Datei (Text- oder Tabellenformat) | SQL Studio, Strukturlink Exportieren und Importieren von LONG-Spalten
Anwendungsdaten importieren: LONG-Werte eingeschränkt (nur einzeln) aus einem Skript | Datei | MaxDB-Datenbankinstanz | SQL Studio, Importieren und Exportieren von LONG-Spalten (s. o.) Importieren und Exportieren von SQL-Anweisungen (s. u.)
Definitionen von Datenbankobjekten exportieren | MaxDB-Datenbankinstanz | Datei | SQL Studio, Strukturlink Exportieren der Definition eines Datenbankobjekts
Definitionen von Datenbankobjekten importieren | Datei | MaxDB-Datenbankinstanz | SQL Studio, Importieren und Exportieren von SQL-Anweisungen (s. u.)
SQL-Anweisungen exportieren | MaxDB-Datenbankinstanz | Datei | SQL Studio, Strukturlink Importieren und Exportieren von SQL-Anweisungen
SQL-Anweisungen importieren | Datei | MaxDB-Datenbankinstanz | SQL Studio, s. o.
gesamte Datenbankinstanz kopieren | MaxDB-Datenbankinstanz | MaxDB-Datenbankinstanz | Database Manager, siehe Datenbankkopie

Siehe auch:

Sichern und Wiederherstellen

Replikation und High-Availability

Verwaltung


Replikation und High-Availability (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Replikation und High-Availability

Verwendung

Eine Datenbankinstanz kann aufgrund von Hardwareschäden oder logischen Fehlern ausfallen.

Um die Datenbankinstanz wiederherzustellen, müssen Sie Daten- und Log-Sicherungen einlesen (siehe Sichern und Wiederherstellen). Wenn Sie sehr viele Daten neu einlesen müssen, kann das Wiederherstellen lange dauern. Die Datenbankinstanz ist während dieser Zeit für die Benutzer nicht verfügbar.

Um die Datenbankinstanz schneller wieder für die Benutzer verfügbar zu machen (High Availability), können Sie die Daten der aktiven Datenbankinstanz (Originalinstanz) replizieren. Replikation bedeutet, dass die aktive Datenbankinstanz zunächst dupliziert und das Duplikat in regelmäßigen Abständen aktualisiert wird.

Replikationsmechanismen

Name | Beschreibung | benötigte Datenbankwerkzeuge und zusätzliche Software
Datenbankkopie | Die aktive Datenbankinstanz wird einmalig kopiert, danach jedoch nicht mehr aktualisiert. Die Datenbankkopie ist kein Replikationsmechanismus, wird aber beim Einrichten einiger Replikationsmechanismen wie z. B. einer Schattendatenbank benötigt. | MaxDB Database Manager
Schattendatenbank | Sie aktualisieren asynchron ein Duplikat der aktiven Datenbankinstanz. Sie kopieren die Log-Sicherungen der Originalinstanz auf die Schatteninstanz und lesen Sie dort ein. Nach einem Ausfall der aktiven Datenbankinstanz können Sie nach dem Einlesen der letzten Redo-Log-Einträge die Schatteninstanz schnell in Betrieb nehmen. | MaxDB Database Manager
Hot-Standby | Mehrere Duplikate der aktiven Datenbankinstanz werden automatisch synchron aktualisiert. Alle Instanzen greifen auf denselben Log-Bereich zu. Nach einem Ausfall der aktiven Datenbankinstanz wird automatisch eine Standby-Instanz in Betrieb genommen. | MaxDB Database Manager Cluster-Software Speicherverwaltungssystem
Synchronisation | Der Synchronization Manager synchronisiert die Tabelleninhalte von Client-Datenbankinstanzen asynchron mit den Tabelleninhalten einer zentralen Datenbankinstanz. Die Clientrechner können zwischenzeitlich offline sein. Kollisionen werden automatisch behandelt. Optional können Sie Daten filtern. Voraussetzung: Das Verhältnis von geänderten Daten zu Bestandsdaten ist klein. | MaxDB Synchronization Manager MaxDB Database Manager

Siehe auch:

Strukturlink High Availability for the MaxDB Database

Sichern und Wiederherstellen

Verwaltung


Datenbankkopie (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Datenbankkopie

Einsatzmöglichkeiten

Eine Datenbankkopie können Sie beispielsweise dazu verwenden, um neue Anwendungen zu testen, die Datenbankstrukturen ohne Beeinträchtigungen des laufenden Betriebs zu prüfen oder eine Schattendatenbank einzurichten. Um eine Systemkopie eines SAP-Systems zu erstellen, benötigen Sie ebenfalls eine Datenbankkopie.

Um eine Datenbankkopie zu erstellen, verwenden Sie eine vollständige Datensicherung.

Originalinstanz und Kopie

Diese Grafik wird im zugehörigen Text erklärt

Voraussetzungen

● Original- und Zielrechner sind kompatibel, siehe Kompatible Prozessorarchitekturen für Datenbankkopien

Um eine Datenbankkopie auf eine nicht-kompatible Prozessorarchitektur durchzuführen, verwenden Sie das Datenbankwerkzeug Strukturlink Loader.

● Die Zielinstanz verwendet die gleiche Version der Datenbanksoftware wie die Originalinstanz.

Sie können jedoch eine Kopie von einer Quellinstanz einer älteren Version in eine Zielinstanz einer neueren Version machen, wenn sich die beiden Versionen nur in der Build-Nummer unterscheiden.

Version der Quellinstanz: 7.6.00.09

Version der Zielinstanz: 7.6.00.12

● Die Datenbankparameter der Zielinstanz wurden mit den gleichen Werten definiert, wie die der Originalinstanz, jede Instanz verfügt jedoch über ein eigenes Arbeitsverzeichnis.

Ablauf

Sie verwenden das Datenbankwerkzeug Database Manager.

...

1. Sie erstellen eine vollständige Datensicherung der Originalinstanz.

2. Sie legen entweder eine neue Zielinstanz an oder initialisieren eine vorhandene Datenbankinstanz. Definieren Sie die Datenbankparameter der Zielinstanz mit den gleichen Werten wie die Originalinstanz (Ausnahme: Arbeitsverzeichnis der Datenbankinstanz). Außerdem definieren Sie eine Sicherungsvorlage für eine Datensicherung, die auf den Datenträger verweist, auf dem Sie die Datensicherung der Originalinstanz erstellt haben.

3. Sie lesen die vollständige Datensicherung in die Zielinstanz ein, überführen sie in den Betriebszustand ONLINE und laden zum Abschluss die Systemtabellen. Dabei werden gegebenenfalls vorhandene Datenbankbenutzerdaten der Zielinstanz mit den Datenbankbenutzerdaten der Quellinstanz überschrieben.

Siehe auch:

Replikation und High-Availability

Tutorial Datenbankverwaltung, Strukturlink Datenbankkopie erstellen


Kompatible Prozessorarchitekturen für Datenbankkopien (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Kompatible Prozessorarchitekturen für Datenbankkopien

Verwendung

Bei der Datenbankkopie einer MaxDB (OLTP)-Datenbankinstanz muss die Prozessorarchitektur des Quellrechners mit der Prozessorarchitektur des Zielrechners kompatibel sein.

Datenbankinstanztyp SAP liveCache: Sowohl die Prozessorarchitekturen als auch die Betriebssysteme des Quell- und Zielrechners müssen identisch sein, und auf beiden Rechnern müssen die gleichen Datenbankprozeduren verwendet werden.

Die Datenträger, die Sie beim Erstellen einer Datenbankkopie verwenden, müssen ebenfalls kompatibel sein.

Kompatible Prozessorarchitekturen

 | IA32 32bit (alle Betriebssysteme) | IA64 64bit (alle Betriebssysteme außer HP-UX) | x64 64bit (alle Betriebssysteme) | AIX 64bit | Solaris on -SPARC 64bit | Linux on Power 64bit | HP-UX on IA64 64bit (HP_IPF) | HP-UX on PA-RISC 64bit
IA32 32bit (alle Betriebssysteme) | x | x | x |  |  |  |  |
IA64 64bit (alle Betriebssysteme außer HP-UX) | x | x | x |  |  |  |  |
x64 64bit (alle Betriebssysteme) | x | x | x |  |  |  |  |
AIX 64bit |  |  |  | x | x | x | x | x
Solaris on SPARC 64bit |  |  |  | x | x | x | x | x
Linux on Power 64bit |  |  |  | x | x | x | x | x
HP-UX on IA64 64bit (HP_IPF) |  |  |  | x | x | x | x | x
HP-UX on PA-RISC 64bit |  |  |  | x | x | x | x | x

Siehe auch:

Datenbankkopie

Unterstützte Betriebssysteme und Architekturen


Schattendatenbank (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Schattendatenbank

Verwendung

Eine Schattendatenbank ist eine Kopie der aktiven Datenbankinstanz, die Sie regelmäßig aktualisieren. Um die Schatteninstanz zu aktualisieren, lesen Sie die Log-Sicherungen der Originalinstanz ein. Die Schatteninstanz befindet sich dabei im Betriebszustand ADMIN.

Bei einem Ausfall der Originalinstanz können Sie die Schatteninstanz sofort in Betrieb nehmen und so ohne längere Ausfallzeiten weiterarbeiten. Sie können die Schatteninstanz auch in einem Zustand starten, der dem Zustand der Originalinstanz zu einem Zeitpunkt in der Vergangenheit entspricht.

Originalinstanz und Schatteninstanz

Diese Grafik wird im zugehörigen Text erklärt

Aktivitäten

Einrichten einer Schatteninstanz

Aktualisieren der Schatteninstanz

Inbetriebnahme der Schatteninstanz als aktive Instanz

Siehe auch:

Replikation und High-Availability

Tutorial Datenbankverwaltung, Strukturlink Schatteninstanz einrichten und aktualisieren


Einrichten einer Schatteninstanz (SAP-Bibliothek - Grundwissen)

Vorgehensweisen Einrichten einer Schatteninstanz

Verwendung

Sie richten eine Schatteninstanz für eine vorhandene Datenbankinstanz (Originalinstanz) ein.

Siehe auch:

Schattendatenbank

Tutorial Datenbankverwaltung, Strukturlink Schatteninstanz einrichten und aktualisieren

Vorgehensweise

Verwenden Sie für die folgenden Schritte den Database Manager:

...

1. Legen Sie die Schatteninstanz an, indem Sie eine Kopie Ihrer Originalinstanz erstellen. Verfahren Sie dabei wie im Abschnitt Datenbankkopie beschrieben, starten Sie die Schatteninstanz jedoch nicht in den Betriebszustand ONLINE, sondern lassen Sie sie im Betriebszustand ADMIN. Laden Sie noch nicht die Systemtabellen.

Beachten Sie beim Anlegen der Schatteninstanz folgende Punkte:

○ Wir empfehlen, die Originalinstanz und die Schatteninstanz auf unterschiedlichen Rechnern einzurichten.

○ Die Schatteninstanz muss die gleiche Version der Datenbanksoftware verwenden, wie die Originalinstanz.

○ Die Datenbankparameter der Zielinstanz wurden mit den gleichen Werten definiert, wie die der Originalinstanz, jede Instanz verfügt jedoch über ein eigenes Arbeitsverzeichnis.

2. Definieren Sie für die Schatteninstanz eine Sicherungsvorlage für die Sicherungsart Log-Sicherung. Die Eigenschaft Datenträger (device/file) muss auf die einzulesende Log-Sicherung der Originalinstanz verweisen. Mit Hilfe dieser Sicherungsvorlage aktualisieren Sie regelmäßig Ihre Schatteninstanz, indem Sie die Log-Einträge der Originalinstanz in die Schatteninstanz einlesen.

Siehe:

Database Manager GUI, Strukturlink Sicherungsvorlage für einen einzelnen Datenträger oder

Database Manager CLI, Strukturlink medium_put

Ergebnis

Die Schatteninstanz befindet sich im Betriebszustand ADMIN.

Sie können nun in regelmäßigen Zeitabständen die in der Originalinstanz erfolgten Datenänderungen in der Schatteninstanz nachvollziehen und verfügen so über eine geringfügig zeitversetzte Kopie der Originalinstanz und ihres Datenbestandes (siehe: Aktualisieren der Schatteninstanz).


Aktualisieren der Schatteninstanz (SAP-Bibliothek - Grundwissen)

Vorgehensweisen Aktualisieren der Schatteninstanz

Verwendung

Sie vollziehen in der Schatteninstanz (Schattendatenbank) in regelmäßigen Zeitabständen die Datenänderungen der Originalinstanz nach, indem Sie die Log-Sicherungen der Originalinstanz in die Schatteninstanz einlesen. Sie können diesen Vorgang über Skripte automatisieren.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Schatteninstanz einrichten und aktualisieren

Voraussetzungen

Sie haben eine Schatteninstanz eingerichtet.

Vorgehensweise

...

1. Erstellen Sie in Ihrer aktiven Originalinstanz in regelmäßigen Zeitabständen Log-Sicherungen.

Siehe:

○ Database Manager GUI, Strukturlink Sicherungsverfahren

○ Database Manager CLI, Strukturlink autolog_on oder Strukturlink backup_start

2. Lesen Sie diese Log-Sicherungen mit der gewünschten zeitlichen Verzögerung regelmäßig in die Schatteninstanz ein.

Siehe:

○ Database Manager GUI: Strukturlink Wiederherstellen ohne Sicherungshistorie.

○ Database Manager CLI: Strukturlink recover_start, und Strukturlink recover_replace

Ergebnis

Die Schatteninstanz enthält nun die gleichen Daten wie die Originalinstanz zu jenem Zeitpunkt, an dem die letzte eingelesene Log-Sicherung in der Originalinstanz erstellt wurde. Sie können die Schatteninstanz jederzeit als aktive Instanz in Betrieb nehmen.


Inbetriebnahme der Schatteninstanz als aktive Instanz (SAP-Bibliothek - Grundwissen)

Vorgehensweisen Inbetriebnahme der Schatteninstanz als aktive Instanz

Verwendung

Sie können die Schatteninstanz jederzeit zur neuen aktiven Instanz machen.

Sie sichern dafür abschließend den Log-Bereich Ihrer Originalinstanz und lesen diese Log-Sicherung in die Schatteninstanz ein. Wenn Sie Probleme mit der Originalinstanz haben und die abschließende Log-Sicherung der Originalinstanz nicht mehr ausführen können, gibt es noch andere Möglichkeiten, die letzten Log-Einträge der Originalinstanz in die Schatteninstanz zu kopieren (Siehe: Tutorial Datenbankverwaltung, Strukturlink Kopieren der Log-Volumes mit Betriebssystemmitteln)

Anschließend überführen Sie die bisherige Schatteninstanz in den Betriebszustand ONLINE und laden die Systemtabellen. Gegebenenfalls aktualisieren Sie jetzt oder zu einem späteren Zeitpunkt nicht mehr aktuelle Indizes (BAD INDEXES).

Abschließend führen Sie eine vollständige Datensicherung durch und haben damit die Voraussetzungen geschaffen, um die neuen Log-Einträge sichern zu können.

Siehe auch:

Schattendatenbank

Tutorial Datenbankverwaltung, Strukturlink Schatteninstanz als aktive Instanz in Betrieb nehmen

Voraussetzungen

● Sie haben eine Schatteninstanz eingerichtet.

● Die Schatteninstanz war seit ihrer letzten Initialisierung nicht im Betriebszustand ONLINE.

Vorgehensweise

Verwenden Sie für die folgenden Schritte den Database Manager:

...

1. Führen Sie eine abschließende Log-Sicherung in der Originalinstanz aus.

Siehe:

○ Database Manager GUI: Strukturlink Backup Wizard

○ Database Manager CLI: Strukturlink backup_start

2. Lesen Sie alle Log-Sicherungen der Originalinstanz, die noch nicht eingelesen wurden, in die Schatteninstanz ein.

Siehe:

○ Database Manager GUI: Strukturlink Recovery Wizard

○ Database Manager CLI: Strukturlink recover_start

3. Überführen Sie die Schatteninstanz in den Betriebszustand ONLINE.

Siehe:

○ Database Manager GUI: Strukturlink Starten der Datenbankinstanz

○ Database Manager CLI: Strukturlink db_online

4. Laden Sie die Systemtabellen.

Siehe:

○ Database Manager GUI: Strukturlink Aktualisieren der Systemtabellen

○ Database Manager CLI: Strukturlink load_systab

5. Aktualisieren Sie in der Schatteninstanz gegebenenfalls alle Indizes (BAD INDEXES).

Siehe:

○ Database Manager GUI: Strukturlink Wiederherstellen der Indizes nach Datenbankwiederherstellung

○ Database Manager CLI: Strukturlink sql_recreateindex .

6. Erstellen Sie eine vollständige Datensicherung der Schatteninstanz.

Siehe:

○ Database Manager GUI: Strukturlink Backup Wizard

○ Database Manager CLI: Strukturlink backup_start

Ergebnis

Sie können die bisherige Schatteninstanz jetzt als aktive Instanz betreiben und die Log-Einträge sichern.

Um die alte Originalinstanz zur neuen Schatteninstanz zu machen, initialisieren Sie die alte Originalinstanz und verfahren dann wieder wie in Einrichten einer Schatteninstanz beschrieben.


Hot-Standby (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Hot-Standby

Verwendung

Ein Hot-Standby-System besteht aus einer Master-Instanz und einer oder mehreren Standby-Instanzen, die in regelmäßigen Abständen die Änderungen der Master-Instanz nachvollziehen. Master- und Standby-Instanzen bilden einen Cluster (siehe Architektur eines Hot-Standby-Systems), der sich nach außen wie eine einzelne Datenbankinstanz verhält.

Die Standby-Instanzen befinden sich im Betriebszustand STANDBY, der einem Zustand zwischen den Betriebszuständen ADMIN und ONLINE entspricht. Sie sind in diesem Zustand keine vollwertigen Datenbankinstanzen (sie schreiben z. B. keine Log-Einträge).

Wenn die Master-Instanz aufgrund eines logischen oder physikalischen Fehlers ausfällt, wird automatisch eine der Standby-Instanzen zur neuen Master-Instanz (siehe Verhalten des Hot-Standby-Systems im Fehlerfall).

Vorteil eines Hot-Standby-Systems im Fehlerfall:

● sehr kurze Ausfallzeit (deutlich schneller als ein Restart der Master-Instanz)

Ein Hot-Standby-System sichert Sie nicht gegen vom Benutzer oder einer Anwendung verursachte Fehler und Inkonsistenzen. Um sich gegen derartige Fehler abzusichern, müssen Sie auch in einem Hot-Standby-System regelmäßig Daten- und Log-Sicherungen durchführen (siehe Sichern und Wiederherstellen).

Voraussetzungen

Systemanforderungen für ein Hot-Standby-System

Aktivitäten

...

1. Sie konfigurieren die Rechner, auf denen sich später die Master- und Standby-Instanzen des Hot-Standby-Systems befinden werden, als Cluster. Informationen zur Konfiguration des Clusters finden Sie in der Dokumentation des Herstellers der Cluster-Software.

2. Sie definieren mit der Cluster-Software einen Virtual Server Name, über den die Datenbankinstanz von außen angesprochen wird. Der Virtual Server Name darf nicht mit einem Namen eines Rechners im Cluster übereinstimmen.

3. Sie installieren ein Speicherverwaltungssystem. Hinweise zur Konfiguration des Speicherverwaltungssystems finden Sie in der Dokumentation des Herstellers.

4. Sie erstellen eine Datenbankinstanz auf dem Rechner, den Sie als Virtual Server definiert haben.

Die Volumes der Datenbankinstanz müssen sich im Speicherverwaltungssystem befinden.

5. Sie konfigurieren die Datenbankinstanz als Master-Instanz des Hot-Standby-Systems.

6. Sie fügen eine oder mehrere Standby-Instanzen hinzu.

Siehe

○ Database Manager CLI, Strukturlink Verwalten von Hot-Standby-Systemen

○ Database Manager GUI, Strukturlink Master-Instanz einrichten (Hot-Standby) und Strukturlink Standby-Instanz hinzufügen (Hot-Standby)

7. Das Datenbanksystem aktualisiert die Standby-Instanzen in regelmäßigen Abständen, indem es die Redo-Log-Einträge der Master-Instanz einliest (siehe Synchronisation von Master- und Standby-Instanzen).

Siehe auch:

Replikation und High-Availability

Tutorial Datenbankverwaltung, Strukturlink Hot-Standby-System einrichten


Systemanforderungen für ein Hot-Standby-System (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Systemanforderungen für ein Hot-Standby-System

Hardware

· Die Rechner, auf denen sich die Master- und Standby-Instanzen befinden, verwenden Hardware mit gleicher Speicherkapazität und gleicher Art und Anzahl von Prozessoren.

· Jeder Rechner hat einen eigenen, eindeutigen Namen.

· Alle Rechner sind eingeschaltet.

Betriebssystem

· Sie haben Administrationsrechte auf allen Rechnern.

Datenbanksoftware

· Auf allen Rechnern ist dieselbe Version der Datenbanksoftware installiert.

· Alle Pfade und Dateinamen sind für die Master- und Standby-Instanzen gleichlautend (Arbeitsverzeichnis, Volumes, Trace-Dateien usw.).

· Die MaxDB X-Server laufen auf allen Rechnern.

Cluster-Software

Die Rechner, auf denen sich die Master- und Standby-Instanzen des Hot-Standby-Systems befinden, sind Teil eines Clusters. Informationen zum Einrichten des Clusters finden Sie in der Dokumentation des Herstellers.

Anforderungen an die Cluster-Software:

· Fail-Over-Mechanismus, der im Fehlerfall den Rollentausch zwischen Master- und Standby-Instanz erlaubt

· IP-Switching

Master- und Standby-Instanzen haben jeweils eine eigene IP-Adresse

Für die folgende Cluster-Software wurde die Einrichtung eines Hot-Standby-Systems mit MaxDB getestet: IBM High Availability Cluster Multiprocessing for AIX clustering software.

Speicherverwaltungssystem

Daten- und Log-Bereich der Master- und Standby-Instanzen befinden sich in einem Speicherverwaltungssystem. Informationen zum Einrichten des Speicherverwaltungssystems finden Sie in der Dokumentation des Herstellers.

Anforderungen an das Speicherverwaltungssystem:

· Alle Instanzen können gleichzeitig auf den Log-Bereich zugreifen.

Optimal ist ein Speicherverwaltungssystem, bei dem zwei unterschiedliche Zugriffsberechtigungen auf den Log-Bereich möglich sind: nur lesend (read only) und lesend und schreibend (read and write).

· Jedes Data-Volume jeder beteiligten Datenbankinstanz hat einen eigenen physischen Speicherbereich im Speicherverwaltungssystem. Damit es nicht zu Kollisionen bei den I/O-Zugriffen kommt, empfehlen wir getrennte Festplatten im Speicherverwaltungssystem.

Die Data-Volumes jeder Instanz haben auf ihrem jeweiligen Rechner denselben Zugriffspfad, oder es kann ein entsprechender symbolischer Link eingerichtet werden.

Es lassen sich konsistente Kopien der Data-Volumes („Split“) erstellen, die nach dem Split unabhängig voneinander gelesen und beschrieben werden können. Während des Erstellens der Kopie kann die Master-Instanz weiter auf ihr Data-Volume schreiben, so dass Ausfallzeiten minimal bleiben. Nach dem Split sind die Data-Volumes der Master- und der Standby-Instanzen vollständig unabhängig voneinander.

· schnelles Kopieren von Daten innerhalb des Speicherverwaltungssystems

Bei der Initialisierung von Standby-Instanzen und im Fehlerfall müssen unter Umständen große Datenmengen kopiert werden.

· schnelle Datenübertragung zwischen dem Speicherverwaltungssystem und den Rechnern, auf denen sich Datenbankinstanzen befinden

Folgende Speicherverwaltungssysteme erfüllen diese Voraussetzungen und unterstützen die Einrichtung eines Hot-Standby-Systems mit MaxDB: EMC Symmetrix, IBM TotalStorage Enterprise Storage Server (ESS), IBM TotalStorage SAN Volume Controller (SVC).

Siehe auch:

Hot-Standby


Architektur eines Hot-Standby-Systems (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Architektur eines Hot-Standby-Systems

Ein Hot-Standby-System besteht aus einer Master- und einer oder mehreren Standby-Instanzen, die sich auf unterschiedlichen Rechnern befinden können. Master- und Standby-Instanzen haben jeweils einen eigenen Kern, eigene Caches, einen eigenen MaxDB X-Server, DBM-Server usw.

Die Rechner, auf denen sich die Datenbankinstanzen befinden, bilden einen Cluster. Die Kommunikation innerhalb des Clusters erfolgt mit den internen IP-Adressen der Rechner. Nach außen verhält sich das Hot-Standby-System wie eine einzelne Datenbankinstanz. Um von außen auf das Hot-Standby-System zuzugreifen, benötigen Sie folgende Informationen:

· Name der Datenbankinstanz

· Virtual Server Name (identifiziert den Rechner, der aktuell die Rolle der Master-Instanz hat)

Wenn die Master-Instanz ausfällt, dann geht der Virtual Server Name auf den Rechner mit der Standby-Instanz über, die die Master-Rolle übernimmt (siehe Verhalten des Hot-Standby-Systems im Fehlerfall).

Die Daten- und Log-Bereiche aller Instanzen befinden sich in einem Speicherverwaltungssystem.

Als Schutz vor Hardware-Fehlern empfehlen wir, dass Sie die Daten- und Log-Bereiche im Speicherverwaltungssystem spiegeln.

Master- und Standby-Instanzen verwenden denselben Log-Bereich, wobei die Standby-Instanzen jedoch nur nur lesenden Zugriff haben (siehe Synchronisation von Master- und Standby-Instanzen).

Im Gegensatz dazu haben Schattendatenbanken getrennte Log-Bereiche für alle Instanzen.

Master- und Standby-Instanzen verfügen jeweils über eigene, voneinander unabhängige Datenbereiche.

Beispiel

Die folgende Abbildung zeigt ein Hot-Standby-System, dass aus einer Master-Instanz auf dem Rechner GENUA und einer Standby-Instanz auf dem Rechner PARMA besteht. Die Rechner GENUA und PARMA sind Teil eines Clusters. Der Name der Datenbankinstanz lautet DEMODB, der Virtual Server Name VIRTUAL_SERVER. Die Daten- und Log-Bereiche der Instanzen befinden sich in einem Speicherverwaltungssystem, die Cluster-Software auf einem separaten Rechner.

Beispiel für den Aufbau eines Hot-Standby-Systems

Diese Grafik wird im zugehörigen Text erklärt

Von außen sieht das Hot-Standby-System wie eine einzelne Datenbankinstanz DEMODB auf dem Rechner VIRTUAL_SERVER aus:

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Hot-Standby


Synchronisation von Master- und Standby-Instanzen (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Synchronisation von Master- und Standby-Instanzen

Verwendung

Beim Initialisieren einer neuen Standby-Instanz kopiert das Speicherverwaltungssystem den kompletten Inhalt des Datenbereichs der Master-Instanz in einem konsistenten Zustand, also z. B. den Zustand beim letzten Savepoint, in den Datenbereich der Standby-Instanz.

Danach aktualisiert die Standby-Instanz regelmäßig ihren Datenbereich, indem sie die Redo-Log-Einträge der Master-Instanz bis zu einem bestimmten Zeitpunkt aus dem gemeinsamen Log-Bereich einliest und die entsprechenden Transaktionen nachvollzieht.

Im Gegensatz dazu werden bei einer Schattendatenbank Log-Sicherungen eingelesen.

Der Datenbereich einer Standby-Instanz entspricht also mit einer Zeitverzögerung immer dem Datenbereich der Master-Instanz.

Aktivitäten

Master- und Standby-Instanzen verwenden dieselben Datenbankparameter. Um einen Datenbankparameter zu ändern, ändern Sie ihn in der Master-Instanz. Das System überträgt die Änderungen dann automatisch an die Standby-Instanzen.

Die Master-Instanz informiert die Standby-Instanzen in regelmäßigen Zeitintervallen, bis zu welcher Position im Log-Bereich sie neue Redo-Log-Einträge in den gemeinsamen Log-Bereich geschrieben hat. Um diese Zeitintervalle zu konfigurieren, verwenden Sie den speziellen Datenbankparameter HS_SYNC_INTERVAL.

Um die Zeitverzögerung zu konfigurieren, mit der die Standby-Instanzen die Redo-Log-Einträge der Master-Instanz einlesen und die entsprechenden Transaktionen nachvollziehen, verwenden Sie den speziellen Datenbankparameter HS_DELAY_TIME.

Siehe auch:

Hot-Standby

Protokollierung von Datenänderungen (Logging)


Verhalten des Hot-Standby-Systems im Fehlerfall (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Verhalten des Hot-Standby-Systems im Fehlerfall

Einsatzmöglichkeiten

Wenn die Master-Instanz des Hot-Standby-Systems ausfällt, dann übernimmt eine Standby-Instanz automatisch die Rolle der Master-Instanz. Hierdurch entsteht nur eine sehr kurze Ausfallzeit (ein Restart der Master-Instanz dauert in der Regel sehr viel länger).

Ablauf

Die Cluster-Software überwacht ständig die Master-Instanz des Hot-Standby-Systems.

...

1. Wenn die Master-Instanz ausfällt, bestimmt die Cluster-Software eine der Standby-Instanzen zur neuen Master-Instanz und sendet eine entsprechende Information an die Standby-Instanz.

2. Die neue Standby-Instanz übernimmt von der alten Master-Instanz den Virtual Server Name, unter dem das Hot-Standby-System von außen angesprochen wird.

3. Das Speicherverwaltungssystem gibt der neuen Master-Instanz Schreibrechte für den gemeinsamen Log-Bereich.

4. Die neue Master-Instanz liest die letzten noch nicht eingelesenen Redo-Log-Einträge der alten Master-Instanz ein und vollzieht die entsprechenden Transaktionen nach.

5. Das Datenbanksystem bringt die neue Master-Instanz vom Betriebszustand STANDBY in den Betriebszustand ONLINE.

Nachdem Sie den Fehler in der alten Master-Instanz behoben haben, können Sie die alte Master-Instanz als Standby-Instanz wieder zum Hot-Standby-System hinzufügen.

Siehe auch:

Hot-Standby


Synchronisation (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Synchronisation

Verwendung

Bei der Synchronisation von Datenbankinstanzen werden die Daten mehrerer Datenbankinstanzen miteinander abgeglichen. Wenn in einer der Datenbankinstanzen Daten geändert werden, werden diese Änderungen in den anderen Datenbankinstanzen repliziert.

Wenn zwei Datenbankinstanzen gleichzeitig dieselben Daten ändern, findet eine automatische Konfliktbehandlung statt. Die Client-Datenbankinstanzen können zwischenzeitlich offline sein. Optional können Sie Filter für die Daten definieren.

Für die Synchronisation benötigen Sie einen Message-Server mit einer Message-Datenbankinstanz.

Schematischer Überblick: Synchronisation von einer Master- mit zwei Client-Datenbankinstanzen

Diese Grafik wird im zugehörigen Text erklärt

Voraussetzungen

· Sie haben die Software für den Synchronization Manager installiert.

· Das Verhältnis von geänderten Daten zu Bestandsdaten ist klein.

Aktivitäten

Um die Synchronisation mehrerer Datenbankinstanzen zu konfigurieren und zu verwalten, verwenden Sie den Synchronization Manager, siehe Dokumentation zum Strukturlink Synchronization Manager.

Siehe auch:

Replikation und High-Availability


Überwachung (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Überwachung

Verwendung

Wir empfehlen, dass Sie Ihre Datenbankinstanz im Produktivbetrieb überwachen. Auf diese Weise können Sie Probleme früh erkennen und Störungen oder Ausfälle vermeiden.

Aktivitäten

Um Ihre Datenbankinstanz zu überwachen, verwenden Sie Betriebssystemfunktionen, den Database Manager, den Event-Dispatcher, den Database Analyzer und in SAP-Systemen das CCMS (insbesondere den Strukturlink Datenbank-Alert-Monitor bzw. Strukturlink liveCache-Alert-Monitor).

Um bei kritischen Datenbankzuständen benachrichtigt zu werden, können Sie Events nutzen. Siehe Utilities, Strukturlink Event-Dispatcher.

Freien Speicherplatz im Datenbereich überwachen

Wenn der Speicherplatz im Datenbereich voll ist, dann hält das Datenbanksystem alle laufenden Transaktionen an, und die Datenbank ist für die Benutzer nicht mehr verfügbar. Um das zu vermeiden, überprüfen Sie regelmäßig, ob noch genügend freier Speicherplatz im Datenbereich vorhanden ist. Siehe

● Database Manager GUI, Strukturlink Datenbereichs-Informationen anzeigen

● Database Manager CLI, Strukturlink info

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Datenbereich überwachen

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Datenbereich überwachen

Freien Speicherplatz im Log-Bereich überwachen

Wenn der Speicherplatz im Log-Bereich voll ist, dann kann das Datenbanksystem keine Redo-Log-Einträge mehr schreiben und hält deswegen alle Transaktionen an. Die Datenbank ist für die Benutzer nicht mehr verfügbar. Um das zu vermeiden, überprüfen Sie regelmäßig, ob noch genügend freier Speicherplatz im Log-Bereich vorhanden ist. Siehe

● Database Manager GUI, Strukturlink Log-Bereichs-Informationen anzeigen

● Database Manager CLI, Strukturlink info

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Log-Bereich überwachen

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Log-Bereich überwachen

Trefferrate beim Zugriff auf die Caches überwachen

Je niedriger die Trefferrate beim Zugriff des Datenbanksystems auf die Caches ist, desto ineffizienter arbeitet Ihr Datenbanksystem. Siehe

● Database Manager GUI, Strukturlink Cache-Informationen anzeigen

● Database Manager CLI, Strukturlink info

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Caches

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Caches

CPU-Nutzung durch die Datenbankinstanz überwachen

Wenn die Datenbankinstanz sich mit zu vielen anderen Programmen den Prozessor/die Prozessoren eines Rechners teilen muss, kann die Performance schlecht sein. Überwachen Sie deshalb mit Betriebssystemmitteln die CPU-Nutzung durch die Prozesse der Datenbankinstanz. Siehe

● Übersicht der Prozesse

Sicherungen überwachen

Sicherungen können aus unterschiedlichen Gründen scheitern, beispielsweise wenn Sie in der Sicherungsvorlage eine Datei in einem Verzeichnis angegeben haben, das zum Zeitpunkt der Sicherung nicht mehr existiert. Die Sicherungshistorie zeigt an, welche Sicherungen durchgeführt wurden und ob sie erfolgreich waren. Überprüfen Sie deswegen regelmäßig die Sicherungshistorie, insbesondere wenn Sie die automatische Log-Sicherung verwenden oder die Sicherungen mit Skripten automatisiert haben. Siehe

● Database Manager GUI, Strukturlink Sicherungshistorie anzeigen

● Database Manager CLI, Strukturlink backup_history_list

● Datenbankverwaltung im CCMS, Strukturlink DBA-Historie

Überprüfen Sie regelmäßig, ob Ihre Sicherungen intakt sind. Siehe

● Database Manager GUI, Strukturlink Sicherung prüfen

● Database Manager CLI, Strukturlink recover_check

Datenbankstrukturen überwachen

Hardwaredefekte können zu Fehlern in den Datenbankstrukturen führen. Überprüfen Sie deshalb regelmäßig die Datenbankstrukturen. Siehe Datenbankstrukturen prüfen

Datenbankaktivitäten überwachen

Überwachen Sie folgende Datenbankaktivitäten:

● I/O-Aktivität

● Sperraktivität

● Logging-Aktivität

Siehe

● Database Manager GUI, Strukturlink Datenbankaktivitäten anzeigen

● Database Manager CLI, Strukturlink info

● Datenbankverwaltung im CCMS, Strukturlink Übersicht Aktivitäten

Anzahl der Datenbanksitzungen überwachen

Wenn maximale Anzahl der möglichen Datenbanksitzungen erreicht ist, dann können sich keine weiteren Benutzer mehr an die Datenbankinstanz anmelden. Überwachen Sie deswegen die Anzahl der Datenbanksitzungen.

Siehe

● Database Manager GUI, Strukturlink Datenbanksitzungen anzeigen

● Database Manager CLI, Strukturlink info

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink User Tasks

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink User Tasks

Sicherheitsrelevante Aktivitäten überwachen

Siehe

● MaxDB-Sicherheitsleitfaden, Protokolldateien auf fehlgeschlagene Anmeldeversuche überprüfen

Siehe auch:

Protokolldateien

Fehlersuche

Performance

Dokumentation zum Strukturlink Event-Dispatcher

Dokumentation zum Strukturlink Database Analyzer


Performance (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Performance

Die Performance einer Datenbankinstanz hängt wesentlich von der Konfiguration der Datenbankinstanz, vom Datenbankdesign und von der Formulierung der einzelnen SQL-Anweisungen ab.

Suchbedingungen

Suchbedingungen beschreiben den Suchbereich einer SQL-Anweisung. Suchbedingungen sind boolesche Ausdrücke (Terme), die mit AND oder OR verknüpft sein können. AND-Bedingungen verkleinern den Suchbereich, OR-Bedingungen vergrößern den Suchbereich.

SELECT firstname, name, zip FROM hotel.customer
WHERE (title ='Company') AND (name > 'Randolph')

Um eine Suchbedingung zu erfüllen, kann das Datenbanksystem immer die gesamte Tabelle durchsuchen (TABLE SCAN). Dies ist aber in den meisten Fällen nicht die effizienteste Methode. Je mehr Sie den Suchbereich einschränken können, desto schneller kann das Datenbanksystem die durch die Suchbedingung qualifizierten Datensätze finden.

Aus diesem Grund ist es auch immer vorteilhaft, wenn das Datenbanksystem über einen Tabellenbereich suchen kann, dessen Datensätze sortiert sind. Hierzu dienen die Schlüssel einer Tabelle. Jede Tabelle hat einen Primärschlüssel. Sie können zusätzlich Sekundärschlüssel (Indizes) definieren, die Sie über eine oder mehrere Spalten anlegen können.

Um SQL-Anweisungen möglichst schnell abzuarbeiten, verwendet das Datenbanksystem unter anderem die folgenden Vorgehensweisen:

● Es formt SQL-Anweisungen in die für die Suche am besten geeignete Form um.

Siehe Automatisches Umformen von SQL-Anweisungen

● Es berechnet die beste Suchstrategie für jede SQL-Anweisung.

Siehe SQL-Optimierer

Siehe auch:

Suchbedingungen, Suchstrategien

SQL-Referenzhandbuch, Suchbedingung (search_condition)

Empfehlungen

● Um eine gute I/O-Performance zu erreichen, beachten Sie die Hinweise im Abschnitt Datenbankinstanz planen.

● Beachten Sie bei der Datendefinition die Tipps zum Datenbankdesign.

● Aktualisieren Sie regelmäßig die Statistiken des SQL-Optimierers, insbesondere nachdem viele Daten geändert wurden.

● Nehmen Sie nur möglichst selektive Spalten in Indizes auf (Spalten, die möglichst viele unterschiedliche Werte enthalten).

● Formulieren Sie möglichst selektive Suchbedingungen.

Formulieren Sie nur solche Suchbedingungen, die nicht von allen Zeilen erfüllt werden: Wenn z. B. die Benutzer die Werte einer Suchbedingung frei wählen können, geben sie häufig gar keine Werte ein. Das Datenbanksystem muss dann diese wirkungslose Suchbedingung für jede zu untersuchende Zeile auswerten. Besser ist es, verschiedene SELECT-Anweisungen in Abhängigkeit von einer Benutzereingabe durchzuführen.

● Stellen Sie die selektivsten Suchbedingungen an den Anfang der Suchbedingung. So kann das Datenbanksystem die Suche unter Umständen abbrechen, bevor es alle Suchbedingungen ausgewertet hat.

● Die Suchbedingung

columnx IN (1,13,24,...)

kann vom SQL-Optimierer besser ausgewertet werden als semantisch gleiche Suchbedingung

columnx=1 OR columnx=13 OR columnx=24 OR ...

Siehe auch:

Performance-Engpässe analysieren

Überwachung

Fehlersuche

SAP-Hinweis 819641


Performance-Engpässe analysieren (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Performance-Engpässe analysieren

Verwendung

Um Performance-Engpässe zu analysieren, stehen Ihnen folgende Datenbankwerkzeuge zur Verfügung:

● Strukturlink Database Analyzer

● Strukturlink XCONS

In SAP-Systemen können Sie außerdem das CCMS verwenden.

Siehe Datenbankverwaltung im CCMS: MaxDB, Strukturlink Langsam laufende Transaktion


Automatisches Umformen von SQL-Anweisungen (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Automatisches Umformen von SQL-Anweisungen

Verwendung

Das Datenbanksystem versucht SQL-Anweisungen so umzuformen, dass die resultierende Anweisung semantisch identisch, jedoch schneller abzuarbeiten ist. Die Umformungen erfolgen rein regelbasiert und berücksichtigen keine Statistikinformationen. Hauptziel der Umformungen ist es, Zwischenergebnismengen zu vermeiden.

Die aus den Umformungen resultierende Anweisung kann unter Umständen nicht mehr als syntaktisch korrekte SQL-Anweisung dargestellt werden.

Integration

Nach dem Umformen einer SQL-Anweisung bestimmt der SQL-Optimierer für die resultierende Anweisung die kostengünstigste Suchstrategie, um auf die Daten zugreifen zu können.

Siehe auch:

SQL-Optimierer

Funktionsumfang

Das Datenbanksystem kann folgende Typen von SQL-Anweisungen umformen:

● SELECT

● CREATE CURSOR FOR SELECT

● EXPLAIN SELECT

Aktivitäten

Das automatische Umformen von SQL-Anweisungen konfigurieren Sie mit dem speziellen Datenbankparameter OPTIMIZE_QUERYREWRITE.

Wenn das Datenbanksystem eine SQL-Anweisung umgeformt hat, dann enthält das Ergebnis der EXPLAIN-Anweisung eine der folgenden Informationen:

● QUERY REWRITTEN ON SQLSTATEMENT LEVEL

● QUERY REWRITTEN ON OPERATOR LEVEL

Beispiel

Das Datenbanksystem formt folgende SQL-Anweisung um:

SELECT * FROM v WHERE a=1, wobei v als CREATE VIEW v (a) as SELECT b FROM t1 UNION ALL SELECT c FROM t2 definiert ist.

Das Ergebnis der ersten Umformung ist eine Anweisung, die eine kleinere Zwischenergebnismenge hat:

select b as a from (select b from t1 where b=1 union all select c from t2 where c=1)

Nach einer weiteren Umformung enthält die resultierende Anweisung kein äußeres SELECT mehr:

select b from t1 where b=1 union all select c from t2 where c=1

Siehe auch:

Performance


SQL-Optimierer (SAP-Bibliothek - Grundwissen)

Komponentendokumentation SQL-Optimierer

Einsatzmöglichkeiten

Der SQL-Optimierer analysiert SQL-Anfragen, die Benutzer oder Anwendungen an die Datenbank stellen. Wenn die SQL-Anfrage mit bestimmten Suchbedingungen angegeben ist, kann der SQL-Optimierer den Zugriff auf die Daten optimieren, d.h. er wählt anhand einer Kostenermittlung und der vorhandenen Statistiken des SQL-Optimierers die beste Suchstrategie für den Zugriff auf die Datensätze aus.

Integration

Der SQL-Optimierer ist Bestandteil des Datenbankkerns.

Siehe auch:

Konzepte des Datenbanksystems, Performance

In SAP-Systemen können Sie mit dem DBA-Einplanungskalender Informationen zum SQL-Optimierer anzeigen und Aktionen zur Statistikaktualisierung einplanen.

Siehe auch:

Datenbankverwaltung im CCMS: MaxDB, Strukturlink SQL-Optimierer im CCMS

Funktionsumfang

Der SQL-Optimierer wird implizit vom Datenbanksystem aufgerufen (siehe Arbeitsweise des SQL-Optimierers).

Mit der SQL-Anweisung EXPLAIN können Sie herausfinden, welche Suchstrategie der SQL-Optimierer für eine SQL-Anweisung auswählt (siehe Problemanalyse).

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Siehe auch:

Konzepte des Datenbanksystems, Demo-Datenbank, Objekte im Schema HOTEL


Arbeitsweise des SQL-Optimierers (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Arbeitsweise des SQL-Optimierers

SQL-Anweisungen spezifizieren nur, welche Resultate gewünscht sind. Sie enthalten keine Informationen darüber, wie das Datenbanksystem nach den Daten suchen soll. Um nach den in der SQL-Anweisung spezifizierten Daten zu suchen, hat das Datenbanksystem oft mehrere Möglichkeiten.

Der SQL-Optimierer hat die Aufgabe, die beste Suchstrategie für den Zugriff auf die Daten zu finden.

Ablauf

...

1. Ein Benutzer oder eine Datenbankanwendung schickt eine SQL-Anweisung mit einer Suchbedingung an die Datenbank.

2. Durch das Datenbanksystem erfolgt ein Automatisches Umformen der SQL-Anweisung.

3. Das Datenbanksystem startet den SQL-Optimierer.

4. Der SQL-Optimierer ermittelt alle Suchstrategien, mit denen das Datenbanksystem auf die in der SQL-Anweisung spezifizierten Daten zugreifen kann.

5. Der SQL-Optimierer ermittelt die Kosten für jede einzelne dieser Suchstrategien. Der SQL-Optimierer benötigt Statistiken, um die beste Strategie für das Abarbeiten komplexer SQL-Anweisungen zu bestimmen.

6. Der SQL-Optimierer wählt die Suchstrategie, die beim Ausführen der SQL-Anweisung die geringsten Kosten verursacht.

7. Das Datenbanksystem führt die SQL-Anweisung mit dieser Suchstrategie aus.

Siehe auch:

SQL-Optimierer


Suchbedingungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Suchbedingungen

Der SQL-Optimierer kann den Datenzugriff nur für SQL-Anweisungen optimieren, die eine Suchbedingung enthalten. Eine Suchbedingung wird mit einer WHERE-Klausel definiert.

SELECT name FROM customer
WHERE cno = 7020

Für folgende SQL-Anweisungsarten können Sie eine Suchbedingung angeben: SELECT, UPDATE, DELETE, INSERT.

Für UPDATE-Anweisungen gelten Einschränkungen für Suchbedingungen.

Die Form der Suchbedingung hat wesentlichen Einfluss auf die Kosten, die bei der Ausführung der SQL-Anweisung entstehen. Der SQL-Optimierer berücksichtigt bei der Kostenermittlung für eine SQL-Anweisung nur die folgenden Suchbedingungen:

● Gleichheitsbedingung

● Bereichsbedingung

● IN-Bedingung

● LIKE-Bedingung

Wenn sich die Suchbedingungen in einer SQL-Anweisung nicht in eine der oben aufgeführten Formen umformen lassen, dann kann der SQL-Optimierer für sie keine Suchstrategie ermitteln und verwendet deshalb die sequentielle Suche.

Wenn Suchbedingungen durch mehrere gleiche Boolsche Operatoren verknüpft sind, dann hat ihre Reihenfolge keinen Einfluss auf die Ermittlung der Suchstrategie durch den SQL-Optimierer.

Siehe auch:

Suchstrategien

Arbeitsweise des SQL-Optimierers

SQL-Referenzhandbuch, Tabellenausdruck (table_expression)


Gleichheitsbedingung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Gleichheitsbedingung

Gleichheitsbedingungen sind Suchbedingungen mit Vergleichsprädikat.

Für den SQL-Optimierer gelten folgende Einschränkungen für Gleichheitsbedingungen:

● Operator ist nur der Vergleichsoperator =

● Die Gleichheitsbedingungen haben eine der folgenden Formen:

<column_spec> = <extended_value_spec>

<column_spec> = <subquery>

Nur wenn eine Gleichheitsbedingung in dieser Form vorliegt, kann der SQL-Optimierer sie zum Ermitteln einer optimalen Suchstrategie auswerten. Wenn Gleichheitsbedingungen in einer anderen Form vorliegen, dann versucht der SQL-Optimierer sie umzuformen.

Ausdrücke der folgenden Formen formt der SQL-Optimierer in Bedingungen ohne NOT mit entsprechend negiertem Operator = um:

...NOT(<column_spec> <> <extended_value_spec>)

...NOT(<column_spec> <> <subquery>)

Der SQL-Optimierer verarbeitet dann die umgeformte Bedingung weiter.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

SELECT * FROM hotel.customer
WHERE name = 'Smith'

Qualifikation: name = 'Smith'
Primärschlüssel der Tabelle CUSTOMER: cno
Indizes über qualifizierte Spalten: FULL_NAME_INDEX (name, firstname)
genutzte Suchstrategie: RANGE CONDITION FOR INDEX

Der Index FULL_NAME_INDEX (name, firstname) kann genutzt werden, um alle Einträge mit dem Namen Smith zu finden.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CUSTOMER | FULL_NAME_INDEX | RANGE CONDITION FOR INDEX | 34
 | NAME | (USED INDEX COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 6

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

EXPLAIN-Anweisung

SQL-Referenzhandbuch, Vergleichsprädikat (comparison_predicate)


Bereichsbedingung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Bereichsbedingung

Bereichsbedingungen sind Suchbedingungen mit Vergleichsprädikat oder BETWEEN-Prädikat. Für den SQL-Optimierer gelten folgende Einschränkungen für Bereichsbedingungen:

● Operatoren sind nur die Vergleichsoperatoren < | <= | => | > und der Operator BETWEEN

● Bereichsbedingungen haben eine der folgenden Formen:
<column_spec> < < | <= | => | > > <extended_value_spec>

oder
<column_spec> BETWEEN <extended_value_spec> AND <extended_value_spec>

Nur Bereichsbedingungen, die diesen Festlegungen genügen, kann der SQL-Optimierer zum Ermitteln einer optimalen Suchstrategie auswerten.

Ob der Bereich durch einen BETWEEN-Operator oder durch Kombination der Vergleichsoperatoren <= und => begrenzt wird, ist für die Suchstratgie unerheblich.

Bedingungen der folgenden Form werden, wenn möglich, in einen Ausdruck ohne NOT mit entsprechend negiertem Operator überführt:

...NOT (<column_spec> < < | <= | => | > > <extended_value_spec>)

...NOT (<column_spec> NOT BETWEEN <extended_value_spec> AND <extended_value_spec>)

Die umgeformte Bedingung wird dann vom SQL-Optimierer weiterverarbeitet.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

SELECT * FROM hotel.customer
WHERE name BETWEEN 'B' AND 'P' AND firstname = 'Greg'

Qualifikation: name BETWEEN 'B' AND 'P' And firstname = 'Greg'
Primärschlüssel der Tabelle CUSTOMER: cno
Indizes über qualifizierte Spalten: FULL_NAME_INDEX (name, firstname)
genutzte Suchstrategie: TABLE SCAN

Der Index FULL_NAME_INDEX (name, firstname) könnte genutzt werden, da für die Spalten NAME und FIRSTNAME eine Bereichs- (BETWEEN) und eine Gleichheitsbedingung angegeben wurde. Ein TABLE SCAN wird hier gewählt, da bei einem Index-Zugriff anschließend auch auf die Basistabelle zugegriffen werden muss. Ab einer bestimmten Größe des Bereichs fallen dadurch zu viele Lesekosten an. Bei einem TABLE SCAN entfallen die Lesekosten des Index.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CUSTOMER | FULL_NAME_INDEX | RANGE CONDITION FOR INDEX | 40
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 40

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

EXPLAIN-Anweisung

SQL-Referenzhandbuch, Vergleichsprädikat (comparison_predicate), BETWEEN-Prädikat (between_predicate)


IN-Bedingung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation IN-Bedingung

IN-Bedingungen sind Suchbedingungen mit IN-Prädikat.

Für den SQL-Optimierer gelten die folgenden Einschränkungen für IN-Bedingungen:

● Operator ist der Operator IN

● IN-Bedingungen haben eine der folgenden Formen:

<column_spec> IN (<extended_value_spec>,...)
<column_spec> IN <subquery>

Nur wenn eine IN-Bedingung in dieser Form vorliegt, kann der SQL-Optimierer sie zum Ermitteln einer optimalen Suchstrategie auswerten.

Bedingungen der folgenden Form werden, wenn möglich, in einen Ausdruck ohne NOT mit entsprechend negiertem Operator überführt:

...NOT(<column_spec> NOT IN (<extended_value_spec>,...))

...NOT(<column_spec> NOT IN <subquery>)

Der SQL-Optimierer verarbeitet dann die umgeformte Bedingung weiter.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

SELECT * FROM hotel.customer
WHERE name IN ('Smith', 'Miller')

Qualifikation: name IN ('Smith', 'Miller')
Primärschlüssel der Tabelle CUSTOMER: cno
Indizes über qualifizierte Spalten: FULL_NAME_INDEX (name, firstname)
genutzte Suchstrategie: RANGE CONDITION FOR INDEX

Der Index FULL_NAME_INDEX (name, firstname) kann genutzt werden, um alle Einträge mit dem Namen Smith und Miller zu finden.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CUSTOMER | FULL_NAME_INDEX | RANGE CONDITION FOR INDEX | 34
 | NAME | (USED INDEX COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 21

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

EXPLAIN-Anweisung

SQL-Referenzhandbuch, IN-Prädikat (in_predicate)


LIKE-Bedingung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation LIKE-Bedingung

LIKE-Bedingungen sind Suchbedingungen mit LIKE-Prädikat.

Für den SQL-Optimierer gelten folgende Einschränkungen für LIKE-Bedingungen:

● Operator ist der Operator LIKE .

● LIKE-Bedingungen haben folgende Form:
<column_spec> LIKE <extended_value_spec>

● Die verwendete Wertespezifikation (extended_value_spec) darf nicht mit den SQL-Syntaxelementen match_string bzw. match_set eines LIKE-Prädikats beginnen.

Nur wenn eine LIKE-Bedingungen in dieser Form vorliegt, kann der SQL-Optimierer sie zum Ermitteln einer optimalen Suchstrategie auswerten.

Bedingungen der Form ...NOT (<column_spec> NOT LIKE<extended_value_spec>) werden, wenn möglich, in einen Ausdruck <column_spec> LIKE <extended_value_spec> überführt.

Der SQL-Optimierer verarbeitet dann die umgeformte Bedingung weiter.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützten sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

SELECT * FROM hotel.customer
WHERE name LIKE 'Wa%'

Qualifikation: name LIKE 'Wa%'
Primärschlüssel der Tabelle CUSTOMER: cno
Indizes über qualifizierte Spalten: FULL_NAME_INDEX (name, firstname)
genutzte Suchstrategie: RANGE CONDITION FOR INDEX

Der Index FULL_NAME_INDEX (name, firstname) kann genutzt werden. Der Startschlüssel wird beim ersten Satz gesetzt, der die LIKE-Bedingung in den ersten beiden Zeichenwerten erfüllt (Wade, Francisco). Der Stoppschlüssel liegt bei dem ersten Satz, der der Bedingung nicht mehr entspricht (Weaver, Alfredo).

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CUSTOMER | FULL_NAME_INDEX | RANGE CONDITION FOR INDEX | 34
 | NAME | (USED INDEX COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 4

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

EXPLAIN-Anweisung

SQL-Referenzhandbuch, LIKE-Prädikat (like_predicate)


Einschränkungen für UPDATE-Anweisungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Einschränkungen für UPDATE-Anweisungen

Für UPDATE-Anweisungen und SELECT-Anweisungen, die eine UPDATE-Klausel enthalten, gilt die folgende Einschränkung für die Verwendung von Suchbedingungen:

Wenn der neue Wert einer Spalte in einem arithmetischen Ausdruck errechnet wird, dann kann der SQL-Optimierer eine Invertierung dieser Spalte, d. h. den entsprechenden Index, nicht für die Ermittlung der Suchstrategie auswerten.

UPDATE <table_name>
  SET columnx = columnx + 3
    WHERE columnx IN (100, 103, 106, 109, 112)

Diese SQL-Anweisung könnte zu fehlerhaften Ergebnissen führen, wenn schrittweise die Invertierungslisten mit den Werten 100, 103, 106, 109, 112 abgearbeitet werden würden.

Siehe auch:

SQL-Referenzhandbuch, UPDATE-Anweisung (update_statement), UPDATE-Klausel (update_clause)


Kostenermittlung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kostenermittlung

Der SQL-Optimierer ermittelt die Kosten für jede mögliche Suchstrategie.

Um die Kosten für eine Suchstrategie zu ermitteln, schätzt der SQL-Optimierer, wie viele I/O-Vorgänge das Datenbanksystem für diese Suchstrategie voraussichtlich durchführen muss. Für diese Schätzung führt der SQL-Optimierer Stichproben durch und nutzt statistische Informationen, die vom Datenbanksystem geliefert werden (siehe Statistiken des SQL-Optimierers).

Der SQL-Optimierer berücksichtigt keine Kosten für Ressourcen wie CPU-Zeit oder Speicherauslastung.

Die Kosten einer Suchstrategie hängen im Wesentlichen von der Form der in der SQL-Anweisung angegebenen Suchbedingung ab. Formulieren Sie SQL-Anweisungen so, dass das Datenbanksystem in den Tabellen nur die Zeilen durchsuchen muss, die tatsächlich benötigt werden und Ergebnis- und Zwischenergebnistabellen so klein wie möglich halten kann.

Um anzuzeigen, welche Suchstrategie und welche Kosten der SQL-Optimierer für eine bestimmte SQL-Anweisung ermittelt hat, können Sie die EXPLAIN-Anweisung verwenden.

Siehe auch:

Arbeitsweise des SQL-Optimierers


Statistiken des SQL-Optimierers (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Statistiken des SQL-Optimierers

Das Datenbanksystem speichert automatisch grundlegende Statistiken mit Informationen zur Größe von Tabellen und Indizes im internen Dateiverzeichnis. Auf Anfrage ermittelt das Datenbanksystem darüber hinaus im laufenden Betrieb eine Reihe zusätzlicher statistischer Informationen, die es im Datenbankkatalog speichert (dieser Vorgang wird als "Aktualisieren der Statistiken" bezeichnet).

Der SQL-Optimierer benötigt die Statistiken, um für das Abarbeiten von komplexen SQL-Anweisungen mit bestimmten Suchbedingungen die optimale Suchstrategie für den Zugriff auf die Daten zu bestimmen.

Aktivitäten

Wir empfehlen, die Statistiken einmal pro Woche zu aktualisieren. Aktualisieren Sie die Statistiken unabhängig davon immer dann, wenn sich die Größenverhältnisse oder Werte in der Datenbankinstanz wesentlich geändert haben.

Um die Statistiken für eine Tabelle zu aktualisieren, setzt das System kurzfristig eine Lesesperre auf den Eintrag für diese Tabelle im Datenbankkatalog. So lange eine Lesesperre für den Eintrag der Tabelle im Datenbankkatalog existiert, können Sie diesen Eintrag nicht ändern und können deswegen keine DDL-Operationen auf der Tabelle durchführen. Außerdem ist es nicht möglich, während dem Aktualisieren der Statistiken einer Tabelle für diese Tabelle eine Schreibsperre zu setzen.

Um die Statistiken zu aktualisieren, verwenden Sie den Database Manager oder in SAP-Systemen das CCMS.

● Database Manager GUI, Strukturlink Statistikinformationen aktualisieren

● Database Manager CLI,

○ Strukturlink sql_updatestat

○ Strukturlink auto_update_statistics

● Datenbankverwaltung im CCMS, Strukturlink Aktualisierung der SQL-Optimiererstatistiken einplanen

Um eine Tabelle vom Aktualisieren der Statistiken auszuschließen, wählen Sie als Stichprobengröße für diese Tabelle den Wert 0.

Siehe auch:

Arbeitsweise des SQL-Optimierers

SQL-Referenzhandbuch, UPDATE STATISTICS-Anweisung (update_statistics_statement)


Suchstrategien (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Suchstrategien

Um auf Daten zuzugreifen, kann der SQL-Optimierer des Datenbanksystems in der Regel mehrere unterschiedliche Strategien (Suchstrategien) anwenden.

Diese Suchstrategien unterscheiden sich u. a. in den Kosten, die bei ihrer Ausführung entstehen.

Funktionsumfang

Die einfachste Suchstrategie ist die sequentielle Suche, bei der die gesamte Tabelle Zeile für Zeile durchsucht wird. Bei großen Datenmengen ist die sequentielle Suche aber auch häufig die aufwendigste Suchstrategie. Deshalb analysiert der SQL-Optimierer andere Suchstrategien, bei denen der zu durchsuchende Bereich der Tabelle kleiner ist.

Welche anderen Suchstrategien möglich sind, hängt von der Suchbedingung und dem Aufbau der jeweiligen SQL-Anweisung und vom Design der Datenbank (Primärschlüssel usw.) ab.

In dieser Dokumentation werden die folgenden Suchbedingungen und die sich daraus ergebenden Suchstrategien beschrieben:

● Suchbedingungen für Schlüsselspalten

● Suchbedingungen für indizierte Spalten

● Suchbedingungen für UPDATE-Anweisungen

● Mit OR verknüpfte Suchbedingungen

● Verlagerung der Suche auf den FETCH-Zeitpunkt

● Joins

Aktivitäten

Um herauszufinden, welche Suchstrategie der SQL-Optimierer für eine SQL-Anweisung auswählt, verwenden Sie die EXPLAIN-Anweisung.

Siehe auch:

Liste aller Suchstrategien

Arbeitsweise des SQL-Optimierers

Konzepte des Datenbanksystems, Tipps zum Datenbankdesign


Sequentielle Suche (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sequentielle Suche

Grundsätzlich kann jede Suche sequentiell, also Zeile für Zeile, durch die gesamte Tabelle erfolgen, d.h. die einfachste Suchstragie des SQL-Optimierers ist die sequentielle Suche. Diese Suchstrategie wird in folgenden Fällen gewählt:

● Es ist keine Suchbedingung angegeben.

● Weder für Schlüsselspalten noch für indizierte Spalten ist eine Suchbedingung angegeben.

Falls die möglichen nicht-sequentiellen Suchstrategien des SQL-Optimierers aufwändiger wären als die sequentielle Suche, wird die Tabelle sequentiell abgearbeitet.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

SELECT * FROM hotel.city

Qualifikation: keine
Primärschlüssel der Tabelle CITY: zip
Indizes über qualifizierte Spalten: keine
genutzte Suchstrategie: TABLE SCAN

Es ist keine Suchbedingung (Qualifikation) angegeben.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CITY |  | TABLE SCAN | 11
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 11

SELECT * FROM hotel.city
WHERE name = 'Oxford'

Qualifikation: WHERE name = 'Oxford'
Primärschlüssel der Tabelle CITY: zip
Indizes über qualifizierte Spalten: keine
genutzte Suchstrategie: TABLE SCAN

Die Suchbedingung ist nicht über die Primärschlüsselspalte angegeben.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CITY |  | TABLE SCAN | 11
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 11

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

EXPLAIN-Anweisung

Suchbedingungen für Schlüsselspalten

Suchbedingungen für indizierte Spalten

Liste aller Suchstrategien


Suchbedingungen für Schlüsselspalten (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Suchbedingungen für Schlüsselspalten

Wenn die SQL-Anweisung Suchbedingungen für Schlüsselspalten enthält, kann der SQL-Optimierer folgende Suchstrategien verwenden:

Suchbedingung | Suchstrategie des SQL-Optimierers
Gleichheitsbedingung für jede Schlüsselspalte | Es wird direkt auf die entsprechende(n) Zeile(n) zugegriffen.
IN-Bedingung für eine Schlüsselspalte, und auf allen anderen Schlüsselspalten eine Gleichheitsbedingung (alle Spalten, die vor der Spalte mit der IN-Bedingung im Schlüssel liegen) | Es wird direkt auf die entsprechende(n) Zeile(n) zugegriffen.
Bereichsbedingungen | Für die Schlüsselspalten wird eine Unter- und Obergrenze für den zulässigen Schlüsselbereich gebildet. Alle Suchstrategien, auch die Strategien für Invertierungen, nutzen das Wissen über diesen zulässigen Schlüsselbereich aus.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

Gleichheitsbedingung

SELECT name FROM hotel.customer
WHERE cno = 7020

Qualifikation: cno = 7020
Primärschlüssel der Tabelle CUSTOMER: cno
Indizes über qualifizierte Spalten: keine
genutzte Suchstrategie: EQUAL CONDITION FOR KEY

Da der Primärschlüssel durch die Suchbedingung voll qualifiziert wurde, erfolgt ein direkter Zugriff auf den Satz.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CUSTOMER |  | EQUAL CONDITION FOR KEY | 40
 | CNO | (USED KEY COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 1

IN-Bedingung

SELECT * FROM hotel.city
WHERE zip IN ('04270', '04570', '04770')

Qualifikation: zip IN ('04270', '04570', '04770')
Primärschlüssel der Tabelle CUSTOMER: zip
Indizes über qualifizierte Spalten: keine
genutzte Suchstrategie: RANGE CONDITION FOR KEY

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CITY | FULL_NAME_INDEX | RANGE CONDITION FOR KEY | 11
 | ZIP | (USED KEY COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 1

Bereichsbedingung

SELECT zip, name FROM hotel.city
WHERE zip BETWEEN '10000' AND '20000'

Qualifikation: BETWEEN '10000' AND '20000'
Primärschlüssel der Tabelle CUSTOMER: zip
Indizes über qualifizierte Spalten: keine
genutzte Suchstrategie: RANGE CONDITION FOR KEY

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CITY |  | RANGE CONDITION FOR KEY | 11
 | ZIP | (USED KEY COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 1

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

EXPLAIN-Anweisung

Suchbedingungen für indizierte Spalten

Liste aller Suchstrategien


Suchbedingungen für indizierte Spalten (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Suchbedingungen für indizierte Spalten

Wenn die SQL-Anweisung Suchbedingungen für indizierte Spalten enthält, kann der SQL-Optimierer folgende Suchstrategien verwenden:

Suchbedingung | Suchstrategie des SQL-Optimierers
Gleichheitsbedingung für die indizierten Spalten | Es wird auf die Zeilen zugegriffen, deren Schlüssel in der zugehörigen Invertierungsliste enthalten sind.
IN-Bedingung für indizierte Spalten | Es wird auf die Zeilen zugegriffen, deren Schlüssel in den Invertierungslisten enthalten sind.
Bereichsbedingungen mit nur einer Bedingung ( <, <=, >, >= ) für eine der beiden Bereichsgrenzen (Unter- bzw. Obergrenze). | Es wird auf die Zeilen zugegriffen, deren Schlüssel in den Invertierungslisten enthalten sind, die durch den Bereich bestimmt wurden.
Bereichsbedingungen, bei denen beide Bereichsgrenzen angegeben sind. Für die Auswahl der Suchstrategie ist es unerheblich, ob diese Angabe durch einen BETWEEN-Operator oder durch zwei durch AND verknüpfte Bedingungen ( <= bzw. >= ) für dieselbe Spalte erfolgt. | Es wird auf die Zeilen zugegriffen, deren Schlüssel in den Invertierungslisten enthalten sind, die durch den Bereich bestimmt wurden.

Im Fall der Gleichheit/IN-Bedingungen und der Bereichsbedingungen gibt es auch Anfragen, bei denen darauf verzichtet werden kann, auf die Zeilen zuzugreifen, da alle notwendigen Werte bereits in der/den Invertierungsliste(n) enthalten sind.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

Gleichheitsbedingung

SELECT * FROM hotel.customer
WHERE name = 'Wagner'

Qualifikation: name = 'Wagner'
Primärschlüssel der Tabelle CUSTOMER: cno
Indizes über qualifizierte Spalten: FULL_NAME_INDEX (name, firstname)
genutzte Suchstrategie: RANGE CONDITION FOR INDEX

Da die Gleichheitsbedingung nur über die erste Indexspalte angegeben ist, muss diese SQL-Anweisung mit einer RANGE CONDITION abgearbeitet werden – es kann im Index mehrere Einträge mit dem Wert Wagner geben.

Der Startschlüssel wird beim ersten Satz gesetzt, der die Gleichheitsbedingung in der ersten Indexspalte erfüllt (Wagner). Der Stoppschlüssel liegt bei dem ersten Satz, der der Bedingung nicht mehr genügt (Walker).

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CUSTOMER | FULL_NAME_INDEX | RANGE CONDITION FOR INDEX | 34
 | NAME | (USED INDEX COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 2

IN-Bedingung

SELECT * FROM hotel.customer
WHERE name IN ('Smith', 'Miller')

Qualifikation: name = IN ('Smith', 'Miller')
Primärschlüssel der Tabelle CUSTOMER: cno
Indizes über qualifizierte Spalten: FULL_NAME_INDEX (name, firstname)
genutzte Suchstrategie: IN CONDITION FOR INDEX

Die SQL-Anweisung wird mit einer IN-Bedingung abgearbeitet. Der SQL-Optimierer hat auch die entsprechende RANGE-Bedingung bewertet, diese wäre bei den gegebenen Werten jedoch teurer.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CUSTOMER | FULL_NAME_INDEX | IN CONDITION FOR INDEX | 34
 | NAME | (USED INDEX COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 21

Bereichsbedingung

Legen Sie einen einspaltigen Index EMPLOYEE_ENO über die Spalte ENO an.

Siehe auch:

SQL-Referenzhandbuch, CREATE INDEX-Anweisung (create_index_statement)

SELECT eno, hno FROM hotel.employee
WHERE eno >= 8

Qualifikation: eno >= 8
Primärschlüssel der Tabelle EMPLOYEE: hno, eno
Indizes über qualifizierte Spalten: EMPLOYEE_ENO (eno)
genutzte Suchstrategie: RANGE CONDITION FOR INDEX

Diese SQL-Anweisung kann mit einer INDEX ONLY-Strategie abgearbeitet werden, weil nur Spalten aus dem Index und dem Primärschlüssel in der SELECT-Liste angegeben sind und im Indexbaum die Primärschlüsselspalten mit abgelegt sind.

Der Zugriff erfolgt über den Index EMPLOYEE_ENO. Der Startschlüssel wird beim ersten Satz gesetzt, der die Größer-Bedingung erfüllt – also beim Wert 8. Der Stoppschlüssel wird auf den letzten Satz des Index gesetzt.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
EMPLOYEE | EMPLOYEE_ENO | RANGE CONDITION FOR INDEX | 45
 |  | ONLY INDEX ACCESSED |
 | ENO | (USED INDEX COLUMN) |
 |  | RESULT IS NOT COPIED, COSTVALUE IS | 45

Bei einer BETWEEN-Bedingung wird der Stoppschlüssel nicht auf das Ende des Index gesetzt, sondern auf den letzten Eintrag, der der RANGE-Bedingung entspricht.

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

EXPLAIN-Anweisung

Suchbedingungen für Schlüsselspalten

Liste aller Suchstrategien


Mit OR verknüpfte Suchbedingungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Mit OR verknüpfte Suchbedingungen

Bei SQL-Anweisungen, die mit OR verknüpfte Suchbedingungen enthalten, analysiert der SQL-Optimierer zunächst jede Suchbedingung einzeln.

b1 AND b2 AND (b3 OR (b4 AND b5))

Die Ausdrücke b1, b2 und (b3 OR (b4 AND b5)) werden zunächst einzeln analysiert. Wenn der Optimierer bei b1 oder b2 eine Gleichheitsbedingung auf Schlüsselspalten findet, dann muss er (b3 OR (b4 AND b5)) bei der Auswahl der Suchstrategie nicht berücksichtigen, weil der Suchbereich nicht sinnvoll weiter eingegrenzt werden kann.

Wenn keine Gleichheitsbedingung für Schlüsselspalten gefunden wird, werden die bis dahin nicht betrachteten, mit OR verknüpften Suchbedingungen weiter analysiert. Dabei geht der SQL-Optimierer folgendermaßen vor:

..

1. Umformen in die disjunktive Normalform

b1 AND b2 AND (b3 OR (b4 AND b5))

ergibt in der disjunktiven Normalform

(b1 AND b2 AND b3) OR (b1 AND b2 AND b4 AND b5)

2. Analyse des neuen Ausdrucks
Die neu gebildeten Klammerausdrücke werden separat analysiert.

3. Kostenermittlung
Die Kosten der verschiedenen Suchstrategien für die Klammerausdrücke der disjunktiven Normalform werden summiert. Wenn diese Summe kleiner als die anfangs ermittelten Kosten für die Suchstrategie ohne Betrachtung der mit OR verknüpften Suchbedingungen ist, werden diese verschiedenen Suchstrategien verwendet.

Wenn die Summe der Kosten von (b1 AND b2 AND b3) und (b1 AND b2 AND b4 AND b5) kleiner ist als die Kosten für die Suchstrategie für b1 und b2, dann werden Strategien für (b1 AND b2 AND b3) und (b1 AND b2 AND b4 AND b5) angewendet.

4. Die kostengünstigste Suchstrategie wird verwendet, um die SQL-Anweisung auszuführen.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzeptes des Datenbanksystems, Objekte im Schema HOTEL

SELECT * FROM hotel.customer
WHERE name = 'Smith' AND firstname = 'Sally'
OR name = 'Miller' AND firstname = 'Sally'

Qualifikation: name = 'Smith' AND firstname = 'Sally'
OR name = 'Miller' AND firstname = 'Sally'
Primärschlüssel der Tabelle CUSTOMER: cno
Indizes über qualifizierte Spalten: FULL_NAME_INDEX (name, firstname)
genutzte Suchstrategie 1. Prädikat: EQUAL CONDITION FOR INDEX
genutzte Suchstrategie 2. Prädikat: EQUAL CONDITION FOR INDEX

Mehrere AND-Terme sind mit einer OR-Bedingung verknüpft. Die AND-Bedingung hat eine höhere Priorität als die OR-Bedingung. Für jeden AND-Term wird die beste Zugriffstrategie bestimmt. Beide AND-Terme qualifizieren die beiden Index-Spalten mit einer Gleichheitsbedingung. Daher können sie jeweils mit einer EQUAL CONDITION FOR INDEX abgearbeitet werden. Die ADDL. QUALIFICATION ON INDEX wird ausgegeben, da die OR-verknüpften Spalten auch im Index überprüft werden.

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CUSTOMER |  | DIFFERENT STRATEGIES FOR OR TERMS | 34
 | FULL_NAME_INDEX | EQUAL CONDITION FOR INDEX |
 |  | ADDNL. QUALIFICATION ON INDEX |
 | NAME | (USED INDEX COLUMN)) |
 | FIRSTNAME | (USED INDEX COLUMN)) |
 | FULL_NAME_INDEX | EQUAL CONDITION FOR INDEX |
 |  | ADDNL. QUALIFICATION ON INDEX |
 | NAME | (USED INDEX COLUMN)) |
 | FIRSTNAME | (USED INDEX COLUMN)) |
 |  | RESULT IS COPIED, COSTVALUE IS | 14

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

EXPLAIN-Anweisung

Liste aller Suchstrategien


Verlagerung der Suche auf den FETCH-Zeitpunkt (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Verlagerung der Suche auf den FETCH-Zeitpunkt

Der SQL-Optimierer versucht, nur dann Ergebnistabellen zu bilden, wenn es unbedingt notwendig ist.

Wenn keine Ergebnistabelle aufgebaut werden muss, kann die Suche auf den FETCH-Zeitpunkt verlagert werden. Dadurch wird kein Speicher für Ergebnisse belegt, und auf die ersten Ergebnisse kann schnell zugegriffen werden.

Ergebnistabelle wird erzeugt

Die Suche kann jedoch nicht immer auf den FETCH-Zeitpunkt verlagert werden, da in einigen Fällen immer eine Ergebnistabelle aufgebaut werden muss:

● SELECT auf mehrere Tabellen (Join)

● SELECT ... FOR REUSE

In den folgenden Fällen muss meistens eine Ergebnistabelle aufgebaut werden:

● SELECT DISTINCT ...

● SELECT ... ORDER BY ...

Ergebnistabelle wird nicht erzeugt

Wenn alle folgenden Bedingungen zutreffen, muss keine Ergebnistabelle aufgebaut werden:

● Weder eine DISTINCT-Spezifikation (bis auf einige Ausnahmen) noch das Syntaxelement FOR REUSE sind angegeben.

● Die Spalten, nach denen sortiert werden soll, bilden zusammen in der angegebenen Reihenfolge und Sortierung (aufsteigend oder absteigend) einen Index.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

Mit Hilfe der EXPLAIN-Anweisung können Sie herausfinden, ob eine Ergebnistabelle erstellt wird (Eintrag in Spalte STRATEGY: RESULT IS COPIED) oder nicht (Eintrag in Spalte STRATEGY: RESULT IS NOT COPIED).

SELECT zip, name FROM hotel.city
WHERE ROWNO < 5
ORDER BY name, zip DESC

Qualifikation: ROWNO < 5 ORDER BY name, zip DESC
Primärschlüssel der Tabelle CITY: zip
Indizes über qualifizierte Spalten: keine
genutzte Suchstrategie: TABLE SCAN

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLMUN_OR_INDEX | STRATEGY | PAGECOUNT
CITY |  | TABLE SCAN | 11
 |  | RESULT IS COPIED COSTVALUE IS | 3

Es wird eine Ergebnistabelle erstellt (RESULT IS COPIED).

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

Suchstrategien

Suchstrategien für Joins

Liste aller Suchstrategien

SQL-Referenzhandbuch, FETCH-Anweisung (fetch_statement), DISTINCT-Spezifikation (distinct_spec), SELECT-Anweisung (select_statement)


Joins (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Joins

Ein Join ist eine SQL-Anweisung, die mehrere Tabellen miteinander verknüpft und als Ergebnis eine Join-Tabelle liefert.

Siehe auch:

SQL-Tutorial, Strukturlink Joins: Informationen aus mehreren Tabellen

SQL-Referenzhandbuch, JOIN-Prädikat (join_predicate)

Funktionsumfang

Aufgabe des SQL-Optimierers ist es, die optimale Reihenfolge bei der Abarbeitung der Tabellen zu finden. Der SQL-Optimierer versucht, auf die Zeilen der zu verknüpfenden neuen Tabellen möglichst direkt zuzugreifen und die Zwischenergebnistabellen möglichst klein zu halten. Er beginnt die Abarbeitung von Joins deswegen mit den kleinsten Tabellen mit den restriktivsten Suchbedingungen, um zunächst kleine Zwischenergebnistabellen zu erhalten.

Die Reihenfolge, in der die Tabellen in der FROM-Klausel der SELECT-Anweisung spezifiziert sind, hat keinen Einfluss auf die Reihenfolge ihrer Abarbeitung.

Suchstrategien für Joins

Der SQL-Optimierer kann eine der folgenden Suchstrategien wählen, um ausgehend von den Join-Spaltenwerten der alten Zwischenergebnistabelle auf Zeilen der neuen Tabelle zuzugreifen:

JOIN VIA INDEXED COLUMN

JOIN VIA KEY COLUMN

JOIN VIA KEY RANGE

JOIN VIA MULTIPLE INDEXED COLUMNS

JOIN VIA MULTIPLE KEY COLUMNS

JOIN VIA RANGE OF MULTIPLE INDEXED COL.

JOIN VIA RANGE OF MULTIPLE KEY COLUMNS

Wenn die Spaltenlängen der in einem Join-Schritt jeweils zu vergleichenden beiden Spalten nicht gleich sind, dann kann der SQL-Optimierer die oben aufgeführten Suchstrategien nicht anwenden. Um diese Einschränkung zu umgehen, definieren Sie deshalb für alle Spalten, die über einen Join verbunden werden sollen, denselben Wertebereich (Domäne).

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

SELECT customer.cno, customer.title, customer.name,
customer.zip, city.name, city.state, customer.address
FROM hotel.customer, hotel.city
WHERE customer.zip = city.zip

Join-Tabellen: CUSTOMER und CITY
Qualifikation: customer.zip = city.zip
genutzte Suchstrategie für CITY: TABLE SCAN
genutzte Suchstrategie für CUSTOMER: JOIN VIA KEY RANGE

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CITY |  | TABLE SCAN | 1
CUSTOMER |  | JOIN VIA KEY RANGE | 1
 |  | TABLE TEMPORARY SORTED |
 | ZIP | (USED SORT COLUMN) |
 |  | RESULT IS COPIED COSTVALUE IS | 13

Die Join-Abarbeitung beginnt mit dem Zugriff auf die Tabelle CITY. Diese wird mit der Suchstrategie TABLE SCAN abgearbeitet.

Für den Join-Übergang auf die Tabelle CUSTOMER mit der Strategie JOIN VIA KEY RANGE wird die Spalte ZIP genutzt.

Beim Join wird immer eine Ergebnismenge aufgebaut (RESULT IS COPIED).

Siehe auch:

Datenbankparameter JOIN_SEARCH_LEVEL

EXPLAIN-Anweisung für Joins

SQL-Referenzhandbuch, Domänenname (domain_name)


Datenbankparameter JOIN_SEARCH_LEVEL (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankparameter JOIN_SEARCH_LEVEL

Der spezielle Datenbankparameter JOIN_SEARCH_LEVEL wird vom SQL-Optimierer bei der Abarbeitung von Joins verwendet.

Er legt den Algorithmus für die Join-Sequenz-Suche fest und bestimmt damit Aufwand und Zeit der Join-Sequenz-Suche. Welcher Algorithmus verwendet werden soll, können Sie entweder direkt festlegen oder aus den Parametern JOIN_MAXTAB_LEVEL4, JOIN_MAXTAB_LEVEL9 sowie der Anzahl der Tabellen im Join berechnen lassen.

Um den Algorithmus direkt festzulegen, geben Sie für JOIN_SEARCH_LEVEL einen der folgenden Werte an:

· 9: Alle möglichen Join-Sequenzen werden berechnet (Permutierender Algorithmus).

· 4: Es werden diverse Join-Sequenzen in Abhängigkeit von der Anfragestruktur berechnet (Transformierender Algorithmus).

· 1: Der einfachste Algorithmus für die Join-Sequenz-Suche wird verwendet (Greedy-Algorithmus).

Wenn Sie als JOIN_SEARCH_LEVEL den Wert 0 angeben, wird der Algorithmus für die Join-Sequenz-Suche folgendermaßen bestimmt:

Tabellenanzahl n des Joins | Algorithmus für die Join-Sequenz-Suche
n ≤ JOIN_MAXTAB_LEVEL9 | 9
JOIN_MAXTAB_LEVEL9 <n ≤ JOIN_MAXTAB_LEVEL4 | 4
JOIN_MAXTAB_LEVEL4 < n | 1

JOIN_SEARCH_LEVEL ist auf 0 gesetzt.

JOIN_MAXTAB_LEVEL4 ist auf 16 gesetzt.

JOIN_MAXTAB_LEVEL9 ist auf 4 gesetzt.

Für einen Join werden 5 Tabellen verwendet.

Für diesen Join wird die Join-Sequenz-Suche Level 4 (Transformierender Algorithmus) verwendet, da für den Join JOIN_MAXTAB_LEVEL9 < 5 ≤ JOIN_MAXTAB_LEVEL4 zutrifft.


Liste aller Suchstrategien (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Liste aller Suchstrategien

Im Folgenden sind alle Suchstrategien aufgelistet, die der SQL-Optimierer kennt. Die Bezeichnungen entsprechen den Rückgabewerten der EXPLAIN-Anweisung, mit deren Hilfe Sie erfragen können, welche Suchstrategie der SQL-Optimierer für eine bestimmte SQL-Anweisung ausgewählt hat.

CATALOG KEY ACCESS

CATALOG SCAN

CATALOG SCAN USING USER EQUAL CONDITION

DIFFERENT STRATEGIES FOR OR-TERMS

EQUAL CONDITION FOR INDEX

EQUAL CONDITION FOR KEY

IN CONDITION FOR INDEX

IN CONDITION FOR KEY

INDEX SCAN

JOIN VIA INDEXED COLUMN

JOIN VIA KEY COLUMN

JOIN VIA KEY RANGE

JOIN VIA MULTIPLE INDEXED COLUMNS

JOIN VIA MULTIPLE KEY COLUMNS

JOIN VIA RANGE OF MULTIPLE INDEXED COL.

JOIN VIA RANGE OF MULTIPLE KEY COLUMNS

NO RESULT SET POSSIBLE

NO STRATEGY NOW (ONLY AT EXECUTION TIME)

RANGE CONDITION FOR KEY

RANGE CONDITION FOR INDEX

SUBQ CONDITION FOR INDEX

SUBQ CONDITION FOR KEY

TABLE SCAN

Siehe auch:

Suchstrategien


CATALOG KEY ACCESS (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation CATALOG KEY ACCESS

CATALOG KEY ACCESS ist eine Suchstrategie des SQL-Optimierers.

Diese Suchstrategie kann für Suchbedingungen angewendet werden, die Gleichheitsbedingungen enthalten. Solche Suchbedingungen können durch einen Zugriff auf Schlüsselspalten im Datenbankkatalog abgearbeitet werden.

Siehe auch:

Liste aller Suchstrategien


CATALOG SCAN (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation CATALOG SCAN

CATALOG SCAN ist eine Suchstrategie des SQL-Optimierers.

Es wird eine sequentielle Suche auf dem Datenbankkatalog durchgeführt.

Siehe auch:

Liste aller Suchstrategien


CATALOG SCAN USING USER EQUAL CONDITION (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation CATALOG SCAN USING USER EQUAL CONDITION

CATALOG SCAN USING USER EQUAL CONDITION ist eine Suchstrategie des SQL-Optimierers. Es wird eine sequentielle Suche über diejenigen Einträge im Datenbankkatalog durchgeführt, die Objekte des angegebenen Benutzers beschreiben.

Siehe auch:

Liste aller Suchstrategien


DIFFERENT STRATEGIES FOR OR-TERMS (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DIFFERENT STRATEGIES FOR OR-TERMS

DIFFERENT STRATEGIES FOR OR-TERMS ist eine Suchstrategie des SQL-Optimierers.

Mit OR verknüpfte Suchbedingungen werden umgeformt und analysiert und für die einzelnen Teilbedingungen, die durch OR-Bedingung verknüpft sind, werden verschiedene Suchstrategien gewählt.

Siehe auch:

Mit OR verknüpfte Suchbedingungen

Liste aller Suchstrategien


EQUAL CONDITION FOR INDEX (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation EQUAL CONDITION FOR INDEX

EQUAL CONDITION FOR INDEX ist eine Suchstrategie des SQL-Optimierers.

Diese Suchstrategie kann für Suchbedingungen ausgewählt werden, die eine Gleichheitsbedingung für alle Spalten eines Index enthalten.

Mit Hilfe der Invertierungsliste wird direkt auf die entsprechenden Tabellenzeilen zugegriffen.

Siehe auch:

Gleichheitsbedingung

Suchbedingungen für indizierte Spalten

Liste aller Suchstrategien


EQUAL CONDITION FOR KEY (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation EQUAL CONDITION FOR KEY

EQUAL CONDITION FOR KEY ist eine Suchstrategie des SQL-Optimierers.

Diese Suchstrategie kann angewendet werden, wenn die beiden folgenden Bedingungen erfüllt sind:

● Die Tabelle hat nur eine Schlüsselspalte.

● In der Suchbedingung ist eine Gleichheitsbedingung für diese Schlüsselspalte angegeben.

Bei dieser Suchstrategie wird direkt auf die betreffende Tabellenzeile zugegriffen.

Siehe auch:

Gleichheitsbedingung

Suchbedingungen für Schlüsselspalten

Liste aller Suchstrategien


IN CONDITION FOR INDEX (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation IN CONDITION FOR INDEX

IN CONDITION FOR INDEX ist eine Suchstrategie des SQL-Optimierers.

Diese Suchstrategie kann in der folgenden Situation gewählt werden: Für die ersten k-1 Spalten des Index sind Gleichheitsbedingungen angegeben und für die k-te Indexspalte wurde eine IN-Bedingung definiert (1 <= k < n, n ist die Anzahl der Indexspalten).

Insbesondere wird diese Suchstrategie auch gewählt, wenn die erste Indexspalte mit einer IN-Bedingung angegeben wird.

Die einzelnen Werte einer IN-Bedingung werden bei dieser Suchstrategie als Gleichheitsbedingung abgearbeitet.

Mit Hilfe der Invertierungslisten wird direkt auf die entsprechenden Tabellenzeilen zugegriffen.

Es wird eine Zwischenergebnismenge aufgebaut.

Liegen die Werte in der IN-Bedingung dicht beieinander oder sind sehr viele Werte angegeben, kann es günstiger sein, anstelle der Gleichheitsbedingung eine Bereichsbedingung zu nutzen.

Es können mehrere IN-Bedingungen auf einem Index berücksichtigt werden. Hierbei ist zu beachten, dass die zweite IN-Bedingung nur mit einem Bereich abgearbeitet wird.

Siehe auch:

Gleichheitsbedingung

IN-Bedingung

Bereichsbedingung

Suchbedingungen für indizierte Spalten

Liste aller Suchstrategien


IN CONDITION FOR KEY (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation IN CONDITION FOR KEY

IN CONDITION FOR KEY ist eine Suchstrategie des SQL-Optimierers.

Diese Suchstrategie wird in folgender Situation gewählt: Die ersten k-1 Spalten des Primärschlüssels wurden mit Gleichheitsbedingungen qualifiziert und für die k-te Schlüsselspalte wurde eine IN-Bedingung definiert (1 <= k <= n, n ist die Anzahl der Schlüsselspalten).

Insbesondere wird diese Suchstrategie auch gewählt, wenn die erste Schlüsselspalte mit einer IN-Bedingung angegeben wurde.

Die einzelnen Werte in der IN-Bedingung werden bei dieser Strategie als Gleichheitsbedingung abgearbeitet. Es wird direkt auf die betreffenden Tabellenzeilen zugegriffen. Es wird eine Zwischenergebnismenge aufgebaut.

Liegen die Werte einer IN-Bedingung dicht beieinander oder sind sehr viele Werte angegeben, kann es günstiger sein, anstelle der Gleichheitsbedingung eine Bereichsbedingung zu nutzen. Diese wird im Ausführungsplan entsprechend angezeigt.

Siehe auch:

Gleichheitsbedingung

IN-Bedingung

Suchbedingungen für Schlüsselspalten

Liste aller Suchstrategien


INDEX SCAN (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation INDEX SCAN

INDEX SCAN ist eine Suchstrategie des SQL-Optimierers.

Es wird eine sequentielle Suche im gesamten angegebenen Index durchgeführt.

Siehe auch:

Liste aller Suchstrategien


JOIN VIA INDEXED COLUMN (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation JOIN VIA INDEXED COLUMN

JOIN VIA INDEXED COLUMN ist eine Suchstrategie des SQL-Optimierers für Joins.

Diese Suchstrategie kann angewendet werden, wenn für die Join-Spalte ein Index erzeugt wurde, der nur diese eine Spalte enthält.

Der Zugriff auf die Zeilen der zu verknüpfenden Tabellen erfolgt über den Index der Join-Spalte.

Siehe auch:

Suchstrategien für Joins

Liste aller Suchstrategien


JOIN VIA KEY COLUMN (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation JOIN VIA KEY COLUMN

JOIN VIA KEY COLUMN ist eine Suchstrategie des SQL-Optimierers für Joins.

Diese Suchstrategie kann ausgewählt werden, wenn die erste Join-Spalte die einzige Spalte des Primärschlüssels, die zweite Spalte eine normale Spalte ist.

Der Zugriff auf die zweite Tabelle kann direkt über den Primärschlüssel erfolgen.

Siehe auch:

Suchstrategien für Joins

Liste aller Suchstrategien


JOIN VIA KEY RANGE (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation JOIN VIA KEY RANGE

JOIN VIA KEY RANGE ist eine Suchstrategie des SQL-Optimierers für Joins.

Diese Suchstrategie kann gewählt werden, wenn die erste Join-Spalte die erste Spalte des multiplen Primärschlüssels, die zweite Spalte eine normale Spalte ist.

In der zweiten Tabelle werden die Daten sequentiell innerhalb des Primärschlüsselbereichs gelesen.

Siehe auch:

Suchstrategien für Joins

Liste aller Suchstrategien


JOIN VIA MULTIPLE INDEXED COLUMNS (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation JOIN VIA MULTIPLE INDEXED COLUMNS

JOIN VIA MULTIPLE INDEXED COLUMNS ist eine Suchstrategie des SQL-Optimieres für Joins.

Diese Suchstrategie kann angewendet werden, wenn die Joinspalten sich zu einem vollständigen, mehrere Spalten umfassenden Index zusammensetzen lassen.

Der Zugriff auf die Zeilen der zu verknüpfenden Tabellen erfolgt über diesen Index.

Siehe auch:

Suchstrategien für Joins

Liste aller Suchstrategien


JOIN VIA MULTIPLE KEY COLUMNS (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation JOIN VIA MULTIPLE KEY COLUMNS

JOIN VIA MULTIPLE KEY COLUMNS ist eine Suchstrategie des SQL-Optimieres für Joins.

Diese Suchstrategie kann angewendet werden, wenn sich die Join-Spalten zu dem aus mehreren Spalten bestehenden Schlüssel der neuen Tabelle zusammensetzen lassen.

Es wird direkt auf die Tabellenzeilen in der neuen Tabelle zugegriffen.

Siehe auch:

Suchstrategien für Joins

Liste aller Suchstrategien


JOIN VIA RANGE OF MULTIPLE INDEXED COL.

Hintergrunddokumentation JOIN VIA RANGE OF MULTIPLE INDEXED COL.

JOIN VIA RANGE OF MULTIPLE INDEXED COL. ist eine Suchstrategie des SQL-Optimierers für Joins.

Diese Suchstrategie kann angewendet werden, wenn die Join-Spalten sich zum Anfangsstück eines mehrere Spalten umfassenden Index zusammensetzen lassen.

Innerhalb des Indexbereichs wird auf die Zeilen der Tabelle zugegriffen.

Siehe auch:

Suchstrategien für Joins

Liste aller Suchstrategien


JOIN VIA RANGE OF MULTIPLE KEY COLUMNS

Hintergrunddokumentation JOIN VIA RANGE OF MULTIPLE KEY COLUMNS

JOIN VIA RANGE OF MULTIPLE KEY COLUMNS ist eine Suchstrategie des SQL-Optimierers für Joins.

Diese Suchstrategie kann angewendet werden, wenn die Join-Spalten sich zum Anfangsstück des aus mehreren Spalten bestehenden Schlüssels der neuen Tabelle zusammensetzen lassen.

Innerhalb des Schlüsselbereiches wird sequentiell auf Tabellenzeilen der neuen Tabelle zugegriffen.

Siehe auch:

Suchstrategien für Joins

Liste aller Suchstrategien


NO RESULT SET POSSIBLE (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation NO RESULT SET POSSIBLE

Der SQL-Optimierer erkennt Suchbedingungen, die logisch kein Ergebnis haben können. In diesem Fall findet keine Suche statt.

Siehe auch:

Liste aller Suchstrategien


NO STRATEGY NOW (ONLY AT EXECUTION TIME) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation NO STRATEGY NOW (ONLY AT EXECUTION TIME)

NO STRATEGY NOW (ONLY AT EXECUTION TIME) ist eine Suchstrategie des SQL-Optimierers.

Wenn die Spaltenwerte einer Unterabfrage erst zum Ausführungszeitpunkt der Unterabfrage bekannt sind, dann wird die Suchstrategie für den effektivsten Zugriff auf die entsprechende Tabelle der Unterabfrage erst bestimmt, wenn diese Werte vorliegen.

Siehe auch:

Liste aller Suchstrategien

EXPLAIN-Anweisung für SELECT-Anweisungen mit Unterabfragen


RANGE CONDITION FOR INDEX (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation RANGE CONDITION FOR INDEX

RANGE CONDITION FOR INDEX ist eine Suchstrategie des SQL-Optimierers.

Diese Suchstrategie kann gewählt werden, wenn eine der folgenden Bedingungen erfüllt ist:

● Die Suchbedingung enthält für die ersten k Spalten eines Index (1 <= k < n, n ist die Anzahl der Indexspalten) Gleichheitsbedingungen.

● Die erste Indexspalte wurde mit einer Bereichsbedingung angegeben.

● Die Werte einer IN-Bedingung liegen sehr dicht beieinander.

Mit Hilfe der in diesem Bereich liegenden Invertierungslisten wird direkt auf die entsprechenden Tabellenzeilen zugegriffen. Es wird also nur ein Teil des Index durchsucht und dieser Teil sequentiell gelesen.

Siehe auch:

Gleichheitsbedingung

Bereichsbedingung

IN-Bedingung

Suchbedingungen für indizierte Spalten

Liste aller Suchstrategien


RANGE CONDITION FOR KEY (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation RANGE CONDITION FOR KEY

RANGE CONDITION FOR KEY ist eine Suchstrategie des SQL-Optimierers.

Es wird nur ein Teil der Basistabelle durchsucht. Es wird ein sogenannter Start- und Stoppschlüssel gebildet, der den Range-Bereich einschränkt.

Diese Suchstrategie wird gewählt, wenn eine der folgenden Bedingungen erfüllt ist:

● Für die ersten k Spalten des Primärschlüssels sind Gleichheitsbedingungen angegeben (1 <= k <n, n ist die Anzahl der Schlüsselspalten). Alle weiteren Schlüsselspalten können entweder gar nicht oder mit einer Bereichsbedingung angegeben sein.

● Die erste Schlüsselspalte ist mit einer Bereichsbedingung angegeben.

● Die Werte einer IN-Bedingung liegen sehr dicht beieinander.

Es wird eine sequentielle Suche im angegebenen Bereich der Tabelle durchgeführt.

Siehe auch:

Gleichheitsbedingung

Bereichsbedingung

IN-Bedingung

Suchbedingungen für Schlüsselspalten

Liste aller Suchstrategien


SUBQ CONDITION FOR INDEX (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SUBQ CONDITION FOR INDEX

SUBQ CONDITION FOR INDEX ist eine Suchstrategie des SQL-Optimierers.

Diese Suchstrategie kann in folgenden Fällen gewählt werden:

● Die Suchbedingung enthält Gleichheits- oder Bereichsbedingungen für die ersten k Spalten eines Index (1 <= k <n, n ist die Anzahl der indizierten Spalten).

● Die Suchbedingung enthält eine Gleichheitsbedingung für alle Spalten eines Index.

Die Werte für die Invertierungsliste bzw. die Indexspalten stammen aus einer Unterabfrage (Subquery).

Siehe auch:

Gleichheitsbedingung

Bereichsbedingung

Suchbedingungen für indizierte Spalten

Liste aller Suchstrategien


SUBQ CONDITION FOR KEY (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SUBQ CONDITION FOR KEY

SUBQ CONDITION FOR KEY ist eine Suchstrategie des SQL-Optimierers.

Diese Suchstrategie wird gewählt, wenn die folgenden Bedingungen erfüllt sind:

● Die Tabelle hat nur eine Primärschlüsselspalte.

● Die Werte für die Schlüsselspalte stammen aus einer Unterabfrage (Subquery).

oder

● Die Tabelle hat einen Primärschlüssel über mehrere Spalten.

● Auf allen Primärschlüsselspalten, die vor der Spalte mit der Subquery im Primärschlüssel liegen, sind Gleichheitsbedingungen definiert.

● Auf eine Spalte des Primärschlüssels ist eine IN-Bedingung in Form einer Subquery definiert.

Für jede Ergebniszeile der Subquery wird ein Teil des Primärschlüssels sequentiell durchsucht.

Siehe auch:

Gleichheitsbedingung

IN-Bedingung

Suchbedingungen für Schlüsselspalten

Liste aller Suchstrategien


TABLE SCAN (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation TABLE SCAN

TABLE SCAN ist eine Suchstrategie des SQL-Optimierers.

Es wird eine sequentielle Suche in der gesamten Tabelle durchgeführt.

Siehe auch:

Liste aller Suchstrategien


Problemanalyse (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Problemanalyse

Wenn das Datenbanksystem unverhältnismäßig lange braucht, um eine SQL-Anweisung abzuarbeiten, analysieren Sie Ihre Datenbank und gegebenenfalls die Arbeitsweise des SQL-Optimierers.

Ablauf

..

1. Beachten Sie die allgemeinen Hinweise zur Fehlersuche.

Konzepte des Datenbanksystems, Fehlersuche

2. Sie können die SQL-Anweisungen gezielt analysieren. Dazu können Sie unter anderem mit der EXPLAIN-Anweisung ermitteln, welche Suchstrategie der SQL-Optimierer für die SQL-Anweisungen verwendet.

EXPLAIN-Anweisung

3. Überprüfen Sie Ihr Datenbankdesign.

Konzepte des Datenbanksystems, Tipps zum Datenbankdesign

Siehe auch:

SQL-Optimierer

SQL-Referenzhandbuch, EXPLAIN-Anweisung (explain_statement)


EXPLAIN-Anweisung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation EXPLAIN-Anweisung

Mit Hilfe der EXPLAIN-Anweisung können Sie für eine SQL-Anweisung mit bestimmten Suchbedingungen herausfinden, welche Suchstrategie der SQL-Optimierer für diese SQL-Anweisung auswählt und welche Kosten diese Suchstrategie verursacht.

Syntax

EXPLAIN <query_statement>

Als Ergebnis einer EXPLAIN-Anweisung wird eine Tabelle zurückgegeben.

● In der Spalte STRATEGY wird angezeigt, welche Suchstrategie der SQL-Optimierer für diese SQL-Anweisung auswählt und ob eine Ergebnistabelle erstellt wurde oder nicht.

● In der Spalte PAGECOUNT wird das Ergebnis der Kostenermittlung für die gewählte Suchstrategie angezeigt.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

EXPLAIN
  SELECT * FROM hotel.city
    WHERE zip > '99000'

Ergebnis der EXPLAIN-Anweisung

OWNER | TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
HOTEL | CITY |  | RANGE CONDITION FOR KEY | 11
 |  | ZIP | (USED KEY COLUMN) |
 |  |  | RESULT IS NOT COPIED, COSTVALUE IS | 1

Das bedeutet, dass die Tabelle CITY 11 Seiten umfasst und die I/O-Kosten für die Ausführung der SQL-Anweisung 1 Seite beträgt.

Einige Besonderheiten der EXPLAIN-Anweisung werden in den folgenden Abschnitten erläutert:

● EXPLAIN-Anweisung für Joins

● EXPLAIN-Anweisung für komplizierte SELECT-Anweisungen

● EXPLAIN-Anweisung für SELECT-Anweisungen mit Unterabfragen

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial.

Siehe auch:

Liste aller Suchstrategien

Verlagerung der Suche auf den FETCH-Zeitpunkt

Problemanalyse

SQL-Referenzhandbuch, EXPLAIN-Anweisung (explain_statement)


EXPLAIN-Anweisung für Joins (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation EXPLAIN-Anweisung für Joins

Wenn die EXPLAIN-Anweisung auf Joins angewendet wird, werden folgende Informationen angezeigt:

● Reihenfolge, in der die Tabellen abgearbeitet werden, wenn die SELECT-Anweisung ausgeführt wird

● Ob ausgehend von den Werten in den Join-Spalten der alten Zwischenergebnistabelle direkt oder über eine Invertierung auf die Zeilen einer neuen Tabelle zugegriffen werden kann

● Suchstrategie, nach der in der jeweils neuen Tabelle gesucht wird, wenn auf die Zeilen dieser Tabelle nicht direkt oder über eine Invertierung zugegriffen werden kann

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

EXPLAIN
SELECT customer.cno, customer.title, customer.name,
customer.zip, city.name, city.state, customer.address
FROM hotel.customer, hotel.city
WHERE customer.zip = city.zip

Join-Tabellen: CUSTOMER und CITY
Qualifikation: customer.zip = city.zip
genutzte Suchstrategie für CITY: TABLE SCAN
genutzte Suchstrategie für CUSTOMER: JOIN VIA KEY RANGE

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
CITY |  | TABLE SCAN | 1
CUSTOMER |  | JOIN VIA KEY RANGE | 1
 |  | TABLE TEMPORARY SORTED |
 | ZIP | (USED SORT COLUMN) |
 |  | RESULT IS COPIED COSTVALUE IS | 13

Die Join-Abarbeitung beginnt mit dem Zugriff auf die Tabelle CITY. Diese wird mit der Suchstrategie TABLE SCAN abgearbeitet.

Für den Join-Übergang auf die Tabelle CUSTOMER mit der Strategie JOIN VIA KEY RANGE wird die Spalte ZIP genutzt.

Beim Join wird immer eine Ergebnismenge aufgebaut (RESULT IS COPIED).

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im SQL-Tutorial, Strukturlink Joins: Informationen aus mehreren Tabellen.

Siehe auch:

Suchstrategien für Joins

Liste aller Suchstrategien

SQL-Referenzhandbuch, EXPLAIN-Anweisung (explain_statement), JOIN-Prädikat (join_predicate)


EXPLAIN-Anweisung für komplizierte SELECT-Anweisungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation EXPLAIN-Anweisung für komplizierte SELECT-Anweisungen

Der SQL-Optimierer zerlegt komplizierte SELECT-Anweisungen in mehrere interne SELECT-Schritte, die temporäre Ergebnisse erzeugen.

Die EXPLAIN-Anweisung für solche SELECT-Anweisungen liefert als Ausgabe mehrere Suchstrategien. Als Tabellenname wird dabei INTERNAL TEMPORARY RESULT angegeben. Die Suche über solche internen Zwischenergebnisse kann immer nur sequentiell erfolgen.


EXPLAIN-Anweisung für SELECT-Anweisungen mit Unterabfragen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation EXPLAIN-Anweisung für SELECT-Anweisungen mit Unterabfragen

Um die Kosten für Suchstrategien zu ermitteln, bei denen der Wert einer Spalte mit den Trefferzeilen einer Unterabfrage (Subquery) verglichen wird, muss der SQL-Optimierer die Anzahl der Trefferzeilen kennen. Die Anzahl der Trefferzeilen ist jedoch erst nach der Abarbeitung der Unterabfrage bekannt.

Die EXPLAIN-Anweisung für eine SELECT-Anweisung mit Unterabfragen ermittelt die möglichen Suchstrategien, ohne die enthaltenen Unterabfragen auszuführen. Daher wird in der Regel für die äußere SQL-Anweisung die Suchstrategie NO STRATEGY NOW (ONLY AT EXECUTION TIME) angezeigt.

Beispiele

Die bei den Erläuterungen zum SQL-Optimierer verwendeten Beispiele stützen sich auf die Demo-Datenbank DEMODB und ihre vollständigen Demo-Daten im Schema HOTEL.

Konzepte des Datenbanksystems, Objekte im Schema HOTEL

EXPLAIN
SELECT name FROM hotel.city
WHERE name IN (SELECT name FROM hotel.hotel)

Qualifikation: name IN (SELECT name FROM hotel.hotel)
Primärschlüssel der Tabelle CITY: zip
Primärschlüssel der Tabelle HOTEL: cno
Indizes über qualifizierte Spalten: keine
genutzte Suchstrategie äußeres SELECT: TABLE SCAN
genutzte Suchstrategie Subquery: TABLE SCAN

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
HOTEL |  | TABLE SCAN | 8
CITY |  | TABLE SCAN | 11
 |  | RESULT IS COPIED COSTVALUE IS | 101

Es werden alle Städtenamen selektiert, nach denen ein Hotel benannt ist. Da für beide Tabellen kein passender Index existiert und nicht auf die Primärschlüsselspalten eingeschränkt wird, werden beide SELECT-Anweisungen mit einem TABLE SCAN abgearbeitet.

EXPLAIN
SELECT cno, name FROM hotel.customer
WHERE cno = ANY(SELECT cno FROM hotel.reservation WHERE arrival > '2005-01-01')

Qualifikation: cno = ANY(SELECT cno FROM hotel.reservation WHERE arrival > '2005-01-01')
Primärschlüssel der Tabelle CUSTOMER: cno
Primärschlüssel der Tabelle RESERVATION: rno
Indizes über qualifizierte Spalten: keine
genutzte Suchstrategie äußeres SELECT: NO STRATEGY NOW (ONLY AT EXECUTION TIME)
genutzte Suchstrategie Subquery: TABLE SCAN

Ergebnis der EXPLAIN-Anweisung

TABLENAME | COLUMN_OR_INDEX | STRATEGY | PAGECOUNT
RESERVATION |  | TABLE SCAN | 24
CUSTOMER |  | NO STRATEGY NOW (ONLY AT EXECUTION TIME) |
 |  | RESULT IS COPIED COSTVALUE IS |

Es werden alle Kunden angezeigt, die alle Buchungen ab einem vorgegebenen Datum getätigt haben. Für die Tabelle RESERVATION wird ein TABLE SCAN durchgeführt. Für die äußere SELECT-Anweisung wird die Suchstrategie NO STRATEGY NOW (ONLY AT EXECUTION TIME) angezeigt.

Weitere einfache Beispiel-SQL-Anweisungen finden Sie im SQL-Tutorial, Strukturlink Subquery: Innere Abfragen.

Siehe auch:

SUBQ CONDITION FOR KEY

SUBQ CONDITION FOR INDEX

Liste aller Suchstrategien

SQL-Referenzhandbuch, Subquery (subquery)


Spalte STRATEGY (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Spalte STRATEGY

Die EXPLAIN-Anweisung liefert als Ergebnis eine Tabelle zurück, die aus mehreren Spalten besteht. In der Spalte STRATEGY finden Sie folgende Angaben:

● Suchstrategie, die vom SQL-Optimierer für die untersuchte SQL-Anweisung verwendet wird
siehe dazu: Liste aller Suchstrategien

● Eintrag, ob eine Ergebnistabelle erstellt wird (RESULT IS COPIED) oder nicht (RESULT IS NOT COPIED)
siehe dazu: Verlagerung der Suche auf den FETCH-Zeitpunkt

● Hinweise des SQL-Optimierers:

Hinweis des SQL-Optimierers | Bedeutung
ONLY INDEX ACCESSED | Es wird nur der angegebene Index zur Abarbeitung der SQL-Anweisung benutzt; auf die Daten der Basistabelle wird nicht zugegriffen. Dies ist nur möglich, wenn in der SQL-Anweisung nur solche Spalten angesprochen werden, die in der Indexstruktur enthalten sind.
DISTINCT OPTIMIZATION (A) | Der komplette Schlüssel steht in der SELECT-Liste/den Ausgabespalten. Das Ergebnis ist deshalb automatisch duplikatfrei.
DISTINCT OPTIMIZATION (C) | Complete Secondary Key Nach dem Schlüsselwort DISTINCT sind alle Spalten eines Index (und nur diese) in beliebiger Reihenfolge angegeben (DISTICNK-Spezifikation). Es wird nur jeweils einmal auf die Werte der entsprechenden Indexspalten zugegriffen. Eine Ergebnistabelle wird nicht aufgebaut. SELECT DISTINCT <alle_Spalten_des_Index> FROM ...
DISTINCT OPTIMIZATION (P) | Partial Secondary Key Nach dem Schlüsselwort DISTINCT sind die ersten k (k < Gesamtanzahl der Spalten des Index) Spalten eines Index in beliebiger Reihenfolge angegeben. Es wird nur jeweils einmal auf die Werte der entsprechenden Indexspalten zugegriffen. Eine Ergebnistabelle wird nicht aufgebaut. SELECT DISTINCT <ersten_k_Spalten_des_Index> FROM ...
DISTINCT OPTIMIZATION (K) | Primary Key Nach dem Schlüsselwort DISTINCT sind alle Spalten eines Index sowie die ersten k (k <= Gesamtzahl der Spalten des Schlüssels) Spalten des Schlüssels in beliebiger Reihenfolge angegeben. Es wird nur jeweils einmal auf die Werte der entsprechenden Index- und Schlüsselspalten zugegriffen. Eine Ergebnistabelle wird nicht aufgebaut. SELECT DISTINCT <alle_Spalten_des_Index_+_ersten_k_Spalten_des_Schlüssels> FROM ...
TEMPORARY INDEX CREATED | Es wird intern ein temporärer Index aufgebaut, in dem die Schlüssel der über die entsprechenden Indexspalten ermittelten Trefferzeilen in aufsteigender Reihenfolge sortiert vorliegen. Auf die Basistabelle wird über diesen temporären Index zugegriffen.
ADDNL. QUALIFICATION ON INDEX | Es gibt Suchbedingungen für Index- oder Schlüsselspalten, die nicht für die direkte Eingrenzung des Bereichs für einen Indexzugriff verwendet werden können. Diese Suchbedingungen fließen in die entsprechende Indexstrategie mit ein, indem sie für die Einschränkung der Zugriffe auf die Basistabelle benutzt werden.

Siehe auch:

Suchstrategien

SQL-Referenzhandbuch, EXPLAIN-Anweisung (explain_statement), DISTINCT-Spezifikation (distinct_spec)


Fehlersuche (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Fehlersuche

Verwendung

Einen Überblick über häufig auftretende Fehler finden Sie im Abschnitt Typische Fehlersituationen.

Für die Fehlersuche stehen Ihnen unter anderem die folgenden Hilfsmittel zur Verfügung:

· Meldungshandbuch

Diese Dokumentation erläutert Meldungen (Fehler und Informationen) des Datenbanksystems und gibt Empfehlungen, wie Sie darauf reagieren können. Die Meldungen sind nach Fehlernummern sortiert.

· Datenbankwerkzeuge:

¡ Database Manager GUI, Strukturlink Diagnosemöglichkeiten

¡ Database Manager CLI, Strukturlink Analysieren der Datenbankinstanz

¡ Strukturlink Database Analyzer (Performance analysieren)

¡ Strukturlink XCONS(Informationen zur Datenbankinstanz anzeigen)

· Protokolldateien

· Traces

· Datenbankstrukturen prüfen

In SAP-Systemen verwenden Sie das CCMS, siehe

· Datenbankverwaltung im CCMS: MaxDB, Strukturlink Problemanalyse

· Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Problemanalyse

Open-Source-Benutzer haben zusätzlich folgende Möglichkeiten:

· Suche im Archiv der MaxDB-Mailing-Liste: lists.mysql.com/search.php

· Problemmeldungen mit WebPTS verfolgen

Siehe auch:

Überwachung

Performance

Support


Typische Fehlersituationen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Typische Fehlersituationen

Wir empfehlen, die Datenbankinstanz laufend zu überwachen. Weitere Informationen finden Sie im Abschnitt Überwachung.

Typische Fehlersituationen

Problem | Typische Symptome | Lösungen
Fehler bei der Installation oder beim Upgrade der Datenbanksoftware. | Die Installation oder Upgrade der Datenbanksoftware schlägt fehl. | Überprüfen Sie das Installationsprotokoll, siehe Protokolldateien. Weitere Informationen finden Sie im Installationshandbuch, Strukturlink Fehlerbehandlung. SAP-Kunden finden weitere Informationen in den folgenden SAP-Hinweisen: 851169 (Installation von MaxDB auf UNIX/Linux), 848437 (Installation von MaxDB auf Microsoft Windows), 851229 (Upgrade MaxDB/Java), 817463 (Upgrade MaxDB/ABAP)
Fehler beim Wiederherstellen der Datenbankinstanz. | Eine Datensicherung oder eine Log-Sicherung ist defekt. | Überprüfen Sie die Sicherung, siehe Database Manager GUI, Strukturlink Sicherung prüfen Database Manager CLI, Strukturlink recover_check
Der Datenbereich ist voll. | Alle Tasks sind suspendiert, das System „hängt“. | Fügen Sie ein Data-Volume hinzu. Siehe: Database Manager GUI, Strukturlink Volumes anlegen, anzeigen und löschen Database Manager CLI, Strukturlink db_addvolume Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Volumes konfigurieren
Der Log-Bereich ist voll. | Alle Tasks sind suspendiert, das System „hängt“. Es ist kein Upgrade möglich (Laden der Systemtabellen scheitert). | Sichern Sie die Log-Einträge. Fügen Sie danach gegebenfalls ein neues Log-Volume hinzu (siehe oben). Das neue Log-Volume wird erst dann vom Datenbanksystem verwendet, wenn die Redo-Log-Einträge auf dem alten Log-Volume gesichert wurden.
Die Datenbankinstanz ist nicht im Betriebszustand ONLINE. | Benutzer können sich nicht an die Datenbankinstanz anmelden. | Starten Sie die Datenbankinstanz. Siehe: Database Manager GUI, Strukturlink Starten der Datenbankinstanz (Restart) Database Manager CLI, Strukturlink db_online Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink liveCache starten
Die maximale Zahl der Datenbanksitzungen ist erreicht. | Keine weiteren Benutzer können sich an die Datenbankinstanz anmelden. | Erhöhen Sie den Wert des allgemeinen Datenbankparameters MAXUSERTASKS.
Der Kern der Datenbankinstanz ist abgestürzt. | Die Datenbankinstanz ist im Betriebszustand OFFLINE. | Überprüfen Sie das Kernprotokoll knldiag, siehe Protokolldateien.
Eine Firewall verhindert die Verbindung mit dem X-Server auf einem entfernten Rechner. | Sie können sich mit dem Database Manager nicht mit einer Datenbankinstanz auf einem entfernten Rechner verbinden. | Stellen Sie sicher, dass der Strukturlink Port des X-Servers auf dem entfernten Rechner nicht durch eine Firewall gesperrt wird.
Der X-Server auf einem entfernten Rechner läuft nicht. | Sie können sich nicht an eine Datenbankinstanz auf einem entfernten Rechner anmelden. | Strukturlink Starten Sie den X-Server.

Siehe auch:

Fehlersuche

Installationshandbuch, Strukturlink Fehlerbehandlung


Protokolldateien (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Protokolldateien

Verwendung

Datenbanksystem, Datenbankwerkzeuge und Schnittstellen schreiben Informationen und Fehlermeldungen in Protokolldateien. Die meisten Protokolldateien sind Textdateien, die Sie direkt mit einem Text-Editor lesen können.

Ausnahmen:

● binäre Protokolldateien

● Protokolldateien, die vom Datenbanksystem erst dann erzeugt werden, wenn ein Benutzer sie anfordert

Um den Inhalt solcher Protokolldateien anzuzeigen, verwenden Sie das Datenbankwerkzeug Database Manager oder in SAP-Systemen das CCMS. Sie benötigen die Datei-ID der Protokolldatei.

Beachten Sie bei der Datei-ID die Groß- und Kleinschreibung.

Siehe

● Database Manager GUI, Strukturlink Protokolldateien lesen

● Database Manager CLI, Strukturlink file_getfirst

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Protokolle und Strukturlink Meldungen

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Protokolle und Strukturlink Meldungen

Kernprotokolle

Dateiname | Verzeichnis | Datei-ID | Beschreibung
knldiag | Arbeitsverzeichnis der Datenbankinstanz: <independent_data_path>\wrk\<database_name> (siehe Glossar, Arbeitsverzeichnis) | KNLDIAG | aktuelles Kernprotokoll der Datenbankinstanz enthält alle Meldungen des Kerns (Fehlermeldungen, Warnungen und Informationen) siehe auch den speziellen Datenbankparameter KNLDIAGSIZE
knlmsg | Arbeitsverzeichnis der Datenbankinstanz | KNLMSG | ausführliches aktuelles Kernprotokoll der Datenbankinstanz enthält alle Meldungen des Kerns (Fehlermeldungen, Warnungen und Informationen) Mit dem Database Manager können Sie sich zusätzliche Informationen zu den Meldungen anzeigen lassen. Pseudo-XML-Datei
knldiag.err | Arbeitsverzeichnis der Datenbankinstanz | KNLDIAGERR | Fehlermeldungen und Startmeldungen des Kerns seit der Installation
knldiag.old | Arbeitsverzeichnis der Datenbankinstanz | KNLDIAGOLD | letztes Kernprotokoll (vor dem letzten Restart)

Allgemeine Protokolldateien

Dateiname | Verzeichnis | Datei-ID | Inhalt
<database_name>.pah | <independent_data_path>\config | DBMPAHI | Historie der Datenbankparameter
<database_name>.prt | Arbeitsverzeichnis der Datenbankinstanz: <independent_data_path>\wrk\<database_name> | KNLTRCPRT | Textversion des Datenbank-Trace
knldump | Arbeitsverzeichnis der Datenbankinstanz | KNLDUMP | Speicherauszug nach einem Datenbankabsturz
knlmini.dmp | Arbeitsverzeichnis der Datenbankinstanz | - | nur auf Microsoft Windows Speicherauszug nach einem Absturz des Datenbankkerns (für das Postmortem-Debugging) siehe Support-Datenbankparameter MINI_DUMP
knltrace | Arbeitsverzeichnis der Datenbankinstanz | KNLTRC | binäre Protokolldatei des Datenbank-Trace, kann außerdem Informationen zu Absturzursachen enthalten. Das Datenbanksystem initialisiert diese Datei bei jedem Starten der Datenbankinstanz.
MaxDBInstanceCreation_install-<date-ID>.log | <independent_data_path>\wrk |  | Protokoll der Softwareinstallation siehe Installationshandbuch, Strukturlink Protokollierung
rtedump | Arbeitsverzeichnis der Datenbankinstanz | RTEDUMP | letzte Werte der Laufzeitumgebung der Datenbankinstanz

liveCache-spezifische Protokolldateien

Dateiname | Datei-ID | Inhalt | Verzeichnis
lcinit.his | LCINITHIS | Historie aller Start-, Stopp- und Initialisierungsaktionen im liveCache. Die Informationen des Protokolls lcinit.log werden angehängt. | Arbeitsverzeichnis der Datenbankinstanz: <independent_data_path>\wrk\<database_name>
lcinit.log | LCINIT | Informationen zum Starten, Stoppen und Initialisieren des SAP liveCache mit der CCMS-Funktionalität des SAP-Systems | Arbeitsverzeichnis der Datenbankinstanz

Database Manager-Protokolldateien

Dateiname

Verzeichnis

Datei-ID

Inhalt

dbahist.prt

<independent_data_path>\wrk\<database_name>\dbahist

DBAHIST

nur für SAP-Systeme

Protokoll der Datenbankadministrationsaktivitäten

dbm.ebf

Arbeitsverzeichnis der Datenbankinstanz: <independent_data_path>\wrk\<database_name>

BACKEBF

nur für Sicherungswerkzeuge anderer Anbieter

Sicherungshistorie, enthält u. a. die Sicherungskennungen, externe Sicherungskennungen und Fehlermeldungen

Wenn ein Sicherungswerkzeug eine Sicherung erfolgreich durchführen, jedoch die externe Sicherungskennung nicht ermitteln konnte, dann trägt es die Sicherung als fehlgeschlagen in die Sicherungshistorie ein.

dbm.ebp

Arbeitsverzeichnis der Datenbankinstanz

BACKEBP

nur für Sicherungswerkzeuge anderer Anbieter

Protokoll der letzten Sicherung

dbm.ins

Arbeitsverzeichnis der Datenbankinstanz

INSTPRT

Protokoll des Ladens/Aktualisierens der Systemtabellen

dbm.knl

Arbeitsverzeichnis der Datenbankinstanz

BACKHIST

Sicherungshistorie

Enthält alle Sicherungen und Wiederherstellungsaktionen. Wenn noch keine Sicherungen durchgeführt wurden, oder die Sicherungshistorie unterbrochen wurde, dann wird HISTLOST angezeigt.

Für Informationen zu den Protokolldateien von Sicherungswerkzeugen anderer Anbieter siehe die entsprechende Dokumentation.

dbm.mdf

Arbeitsverzeichnis der Datenbankinstanz

BACKMDF

Historie der bei den Sicherungen verwendeten Sicherungsvorlagen

dbm.prt

Arbeitsverzeichnis der Datenbankinstanz

DBMPRT

Protokoll des DBM-Servers

enthält alle administrativen Kommandos, die an den DBM-Server geschickt wurden

dbm.utl

Arbeitsverzeichnis der Datenbankinstanz

UTLPRT

enthält administrative Kommandos, die vom DBM-Server an den Datenbankkern geschickt wurden

dbmsrv_<database_computer>

<independent_data_path>\wrk

DBMSRV

instanzunabhängiges Protokoll des DBM-Servers

dbmsrv_<database_computer>.dmp

<independent_data_path>\wrk

DBMSRVMINIDUMP

Speicherauszug, den der DBM-Server bei einem Absturz speichert

enthält Stack- und Speichersegmente

kann für ein Post-Mortem-Debugging verwendet werden

Loader-Protokolldateien

Dateiname | Verzeichnis | Datei-ID | Inhalt
loader.log | <loader_appplication_data>\log |  | Protokoll des Loader
loader.log | <independent_data_path>\wrk | LOADER | Protokoll des Loader-Server
loader_<timestamp>.log | <loader_user_data>\packages |  | Protokoll des Loader im Transportmodus
transport.log | <loader_application_data>\packages |  | Transformationshistorie

Siehe auch:

Loader, Strukturlink Protokolldatei, Strukturlink Transformationshistorie

X-Server-Protokolldateien

Dateiname | Verzeichnis | Datei-ID | Inhalt
xserver_<computer_name>.prt | <independent_data_path>\wrk | XSRVPROT | Protokoll des X-Servers
xserver_<computer_name>.old | <independent_data_path>\wrk | XSRVPROTOLD | letztes Protokoll des X-Servers

Database Analyzer-Protokolldateien

Dateiname | Verzeichnis | Datei-ID | Inhalt
DBAN.prt | <independent_data_path>\wrk\analyzer | ANALYZER#\DBAN.prt | Protokoll des Database Analyzer
DBAN.inf | <independent_data_path>\wrk\analyzer | ANALYZER#\DBAN.inf | Status des Database Analyzer
DBAN.err | <independent_data_path>\wrk\analyzer | ANALYZER#\DBAN.err | Fehler des Database Analyzer
weitere Strukturlink Protokolldateien |  | ANALYZER#\<date> |

Event-Dispatcher-Protokolldateien

Dateiname | Verzeichnis | Datei-ID | Inhalt
dbmevtdisp.prt | Arbeitsverzeichnis der Datenbankinstanz: <independent_data_path>\wrk\<database_name> | EVTDISPPRT | Protokoll des Event-Dispatcher

Synchronization Manager-Protokolldateien

Dateiname | Verzeichnis | Datei-ID | Inhalt
frei wählbar wird in der Datei MSGSERVER.XML festgelegt | frei wählbar wird in der Datei MSGSERVER.XML festgelegt | - | Protokoll des Message-Servers

Siehe auch:

Traces

Überwachung

Fehlersuche

Installationshandbuch, Strukturlink Verzeichnisse


Traces (SAP-Bibliothek - Grundwissen)

Funktionsdokumentation Traces

Verwendung

Um Aktionen des Datenbanksystems detailliert zu protokollieren, können Sie verschiedene Traces einschalten.

Während ein Trace geschrieben wird, kann sich die Performance verschlechtern. Schalten Sie deswegen den Trace wieder aus, sobald die für die Fehleranalyse wichtigen Aktionen im Trace protokolliert wurden.

Solange ein Trace eingeschaltet ist, betreiben Sie die Datenbankinstanz mit möglichst geringer Last und führen Sie nur solche Aktionen aus, die zur Reproduktion des Fehlers notwendig sind.

Traces

Dateiname
(Vorschlagswert)

Verzeichnis
(Vorschlagswert)

Beschreibung

Trace aktivieren

knltrace

Arbeitsverzeichnis der Datenbankinstanz:

<independent_data_path>\wrk\<database_name>

Datenbank-Trace

Das System protokolliert alle Meldungen des Kerns.

Anhand der Protokolldatei können Sie z. B. Fehler bei der Abarbeitung von SQL-Anweisungen identifizieren.

Das Einschalten des Datenbank-Trace wirkt sich nur bei liveCache-Datenbankinstanzen negativ auf die Performance aus, bei MaxDB-Datenbankinstanzen ist dies nicht der Fall.

Verwenden Sie das Datenbankwerkzeug Database Manager oder in SAP-Systemen das CCMS.

Siehe

- Database Manager GUI, Strukturlink Datenbank-Trace verwenden

- Database Manager CLI, Strukturlink trace_on

- Datenbankverwaltung im CCMS, Strukturlink Datenbank-Trace

sqltrace.pct

frei wählbar

ODBC-Trace

Der MaxDB-ODBC-Treiber protokolliert alle SQL-Anweisungen, die die Anwendung an das Datenbanksystem übermittelt.

Dieser ODBC-Trace ist nicht identisch mit dem Trace SQL.LOG, den Sie im ODBC Data Source Administrator (Microsoft Windows) im Register Tracing ein- und ausschalten können.

Geben Sie die entsprechende Option für die Datenquelle an.

Siehe ODBC-Handbuch, Strukturlink Eigenschaften von Datenquellen

frei wählbar

frei wählbar

JDBC-Trace

Der MaxDB-JDBC-Treiber protokolliert alle JDBC-API-Aufrufe mit ihren Eingabeparametern, Rückgabewerten und zugehörigem Thread.

Geben Sie die entsprechende Option für den Verbindungsaufbau an.

Siehe Java-Handbuch, Strukturlink Methode java.sql.DriverManager.getConnection und Strukturlink Klasse com.sap.dbtech.jdbcext.DataSourceSapDB

sqldbctrace-<pid>.prt

<user_home>\Application Data\sdb
(Microsoft Windows)

<user_home>/.sdb
(UNIX/Linux)

SQLDBC-Traces

Das System kann SQL-Anweisungen, Kommunikationspakete, Methodenaufrufe und Aufrufparameter protokollieren.

<pid>= Prozess-ID

Verwenden Sie das Datenbankwerkzeug sqldbc_cons oder in SAP-Systemen das CCMS.

Siehe

- SQLDBC-Handbuch, Strukturlink SQLDBC-Traces

- Datenbankverwaltung im CCMS, Strukturlink SQLDBC-Trace

Siehe auch:

Fehlersuche

Installationshandbuch, Strukturlink Verzeichnisse


Datenbankstrukturen prüfen (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Datenbankstrukturen prüfen

Einsatzmöglichkeiten

Bei einer Datenbankstrukturprüfung überprüft das Datenbanksystem, ob die Datenbankstrukturen konsistent sind (z. B. die Konsistenz der B*-Bäume, siehe Logische Zugriffsstrukturen), nicht aber die Semantik des Datenmodells. Mit einer Datenbankstrukturprüfung können Sie deswegen keine logischen Fehler finden.

Wir empfehlen, die Datenbankstruktur einmal pro Woche zu prüfen. Um den laufenden Betrieb nicht zu stören, können Sie die Datenbankstrukturprüfung auf einer Datenbankkopie durchführen.

Wenn Sie eine der folgenden Fehlermeldungen erhalten, dann führen Sie auch außerplanmäßig eine Datenbankstrukturprüfung durch: -9053: Data page corrupted, -9023: Illegal entrypos, -9003: Illegal entrylength, -9006: Illegal keylength, -9041: Index not accessible

Ablauf

Um die Datenbankstrukturprüfung zu starten, verwenden Sie das Datenbankwerkzeug Database Manager GUI oder in SAP-Systemen das CCMS:

● Database Manager GUI, Strukturlink Datenbankstrukturen prüfen

● Datenbankverwaltung im CCMS,

○ Strukturlink Datenbankstrukturprüfung einplanen

○ Strukturlink Tabellen/Views/Synonyme (Prüfen einer einzelnen Tabelle)

Sie wählen eine der folgenden Funktionen aus:

Funktionen zum Prüfen der Datenbankstrukturen

Funktion

Beschreibung

Prüfen des gesamten Datenbestands im Betriebszustand ONLINE

Das Datenbanksystem prüft im Betriebszustand ONLINE im Cache und im Datenbereich alle Tabellen, Indizes, LONG-Spalten usw. auf ihre strukturelle Konsistenz.

Immer wenn das Datenbanksystem Datenseiten aus dem Datenbereich liest, berechnet es eine Prüfsumme, die mit der auf der Seite gespeicherten Prüfsumme übereinstimmen muss.

Das Datenbanksystem durchläuft alle B*-Bäume und Seitenketten einmal komplett. Es überprüft, ob alle Seiten der B*-Bäume bzw. Seitenketten erreicht werden können und ob die Verwaltungsstrukturen auf den Seiten intakt sind (z. B. die Separatoren auf der B*-Baum-Indexebene).

Zusätzlich prüft es u. a. die Länge und aufsteigende Reihenfolge der Schlüssel.

Prüfen des gesamten Datenbestands und Bereinigen des Converters im Betriebszustand ADMIN

Im Betriebszustand ADMIN führt das Datenbanksystem zunächst die gleichen Überprüfungen wie im Betriebszustand ONLINE durch.

Danach bereinigt das Datenbanksystem anhand der Ergebnisse der Überprüfungen den Converter: es löscht alle Seiten, die es während der Überprüfungen nicht gelesen hat, die also im Datenbestand nicht mehr existieren.

Prüfen einer ausgewählten Tabelle im Betriebszustand ONLINE

Im Betriebszustand ONLINE können Sie auch gezielt eine einzelne Tabelle untersuchen.

Dabei führt das Datenbanksystem dieselben Überprüfungen wie beim Prüfen des gesamten Datenbestands im Betriebszustand ONLINE durch. Sie können für einzelne Tabellen auch alle LONG-Werte und den Datenbankkatalog überprüfen.

Ergebnis

Das Datenbanksystem listet alle bei der Datenbankstrukturprüfung verwendeten Kommandos in den Protokolldateien DBM.UTL und DBM.PRT auf und protokolliert in diesen Dateien auch die Fehler- und Return-Codes.

Der Return-Code 0 bedeutet, dass das Datenbanksystem bei der Datenbankstrukturprüfung keine Fehler gefunden hat. Wenn bei der Datenbankstrukturprüfung ein anderer Return-Code zurückgeliefert wurde, dann gehen Sie vor wie im Abschnitt Fehler in der Datenstruktur beheben beschrieben.

Beispiel

Beispiel: Fehler in der Datenstruktur

Siehe auch:

Fehlersuche

Protokolldateien


Fehler in der Datenstruktur beheben (SAP-Bibliothek - Grundwissen)

Vorgehensweisen Fehler in der Datenstruktur beheben

Verwendung

Nach einer Datenbankstrukturprüfung analysieren Sie die Fehler und versuchen sie zu beheben.

Voraussetzungen

Sie haben die Datenbankstrukturen geprüft.

Vorgehensweise

...

1. Zeigen Sie das Kernprotokoll an (siehe Protokolldateien).

Im Kernprotokoll ist der Beginn der Datenbankstrukturprüfung mit dem Schlüsselwort CHECKgekennzeichnet, nach diesem Schlüsselwort folgen die Ergebnisse der Datenbankstrukturprüfung und gegebenenfalls die Fehler.

Typische Fehlermeldung:

2005-04-08 09:40:30 0x37C ERR 53019 CHECK Base error: bad_datapage

2005-04-08 09:40:30 0x37C ERR 53019 CHECK Root pageNo: 104236

2. Identifizieren Sie für jeden Fehler die Nummer der Wurzelseite (ROOT) des betroffenen B*-Baums bzw. bei SAP liveCache-Daten die Wurzelseite der betroffenen Seitenkette.

3. Verwenden Sie die Systemtabelle ROOTSbzw. bei SAP liveCache-Daten die Systemtabelle CLASSCONTAINER_ROOTS, um von der Nummer der Wurzelseite auf die betroffene Basistabelle oder den betroffenen Index zu schließen (siehe Referenzhandbuch, Systemtabellen auswerten).

4. Wenn der Fehler einen Index betrifft, dann stellen Sie den beschädigten Index wieder her. Siehe

¡ Database Manager GUI, Strukturlink Wiederherstellen der Indizes nach Datenbankwiederherstellung

¡ Database Manager CLI, Strukturlink sql_recreateindex

¡ Datenbankverwaltung im CCMS: MaxDB, Strukturlink Indexanalyse

5. Wenn der Fehler eine Basistabelle betrifft, dann haben Sie folgende Möglichkeiten:

¡ Sie löschen die Basistabelle. Sie können versuchen, die Basistabelle aus anderen Tabellen zu rekonstruieren.

¡ Sie stellen die Datenbankinstanz mit dem Database Manager wieder her. Sie verwenden hierbei diejenige Sicherung, die Sie vor dem letzten erfolgreichen Prüfen der Datenbankstrukturen erstellt haben.

6. Wenn Sie zuvor noch keine Datenbankstrukturprüfung für die Datenbankinstanz durchgeführt haben, dann führen Sie nach dem Einlesen der Sicherung erneut eine Datenbankstrukturprüfung für die Tabelle durch, die beschädigt war. Wenn das Datenbanksystem wieder Fehler findet, dann lesen Sie eine ältere Sicherung ein. Siehe

¡ Database Manager GUI, Strukturlink Wiederherstellen aus einer früheren Sicherung

¡ Database Manager CLI, Strukturlink recover_start

Beispiel

Beispiel: Fehler in der Datenstruktur


Beispiel: Fehler in der Datenstruktur (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Fehler in der Datenstruktur

Eine Basistabelle enthält eine defekte Datenseite, die sich im B*-Baum der Basistabelle auf der Blattebene befindet: Blattnummer 44690 mit Blockadresse 1/564.

Beim Prüfen der Datenbankstrukturen stellt das Datenbanksystem fest, dass die Prüfsumme für diese Datenseite nicht stimmt. Das Datenbanksystem schreibt folgende Informationen ins Kernprotokoll (siehe Protokolldateien):

● Fehler in der Prüfsumme

● Seitennummer mit Angabe zum Data-Volume und Blockadresse

● Blattnummer im B*-Baum

● Typ des Datenbankobjekts, das durch den B*-Baum repräsentiert wird

● Wurzelseite des B*-Baums

● Fehlermeldung

Anschließend markiert das Datenbanksystem das Datenbankobjekt intern als BAD.

Ausschnitt aus dem Kernprotokoll

2005-04-08 09:40:28 0xCEC ERR 4 Data Data_BasePage.cpp:124

2005-04-08 09:40:28 0xCEC ERR 4 Data 2005-04-08 09:40:28 Data Error 4

2005-04-08 09:40:28 0xCEC ERR 4 Data Checksum mismatch; calculated: 5468846 found: 22246062

2005-04-08 09:40:28 0xCEC ERR 25 IOMan IOMan_Volume.cpp:500

2005-04-08 09:40:28 0xCEC ERR 25 IOMan 2005-04-08 09:40:28 IOMan Error 25

2005-04-08 09:40:28 0xCEC ERR 25 IOMan Bad page on Data volume 1 blockno 564

2005-04-08 09:40:30 0xCEC ERR 36 IOMan IOMan_Manager.cpp:1007

2005-04-08 09:40:30 0xCEC ERR 36 IOMan 2005-04-08 09:40:30 IOMan Error 36

2005-04-08 09:40:30 0xCEC ERR 36 IOMan Bad data page 44690

2005-04-08 09:40:30 0xCEC ERR 18 Data vbd13.cpp:2426

2005-04-08 09:40:30 0xCEC ERR 18 Data 2005-04-08 09:40:30 Data Error 18

2005-04-08 09:40:30 0xCEC ERR 18 Data Bad data page 44690 of filetype 'Table' identified by root 104236

2005-04-08 09:40:30 0xCEC ERR 53021 B*TREE Bad File: 104236 (Root)

2005-04-08 09:40:30 0xCEC ERR 53000 B*TREE 0D000000000000000388000000000000

2005-04-08 09:40:30 0xCEC ERR 53000 B*TREE Table Root 104236

2005-04-08 09:40:30 0x37C ERR 53019 CHECK Base error: bad_datapage

2005-04-08 09:40:30 0x37C ERR 53019 CHECK Root pageNo: 104236

Siehe auch:

Datenbankstrukturen prüfen

Logische Zugriffsstrukturen


Entwicklung von Datenbankanwendungen (SAP-Bibliothek - Grundwissen)

Prozessdokumentation Entwicklung von Datenbankanwendungen

Einsatzmöglichkeiten

Um Daten abzulegen und zu verwalten, nutzen die meisten Anwendungen eine Datenbank. Es gibt mehrere MaxDB-Schnittstellen für unterschiedliche Programmiersprachen, über die Sie eine Datenbankanwendung an eine MaxDB-Datenbankinstanz anbinden und SQL-Anweisungen ausführen können. Über einige dieser Schnittstellen können Sie auch Funktionen des Database Manager und des Loader nutzen.

Siehe Schnittstellen.

Voraussetzungen

Sie haben eine Datenbankinstanz angelegt (siehe Anlegen und Konfigurieren einer Datenbankinstanz).

Ablauf

...

1. Sie konzipieren Ihr Datenmodell.

2. Sie definieren mit SQL die entsprechenden Tabellen, Indizes usw. in der Datenbank.

Um die Daten physisch abzulegen und wieder darauf zuzugreifen, verwendet das Datenbanksystem spezielle interne Strukturen. Siehe Logische Zugriffsstrukturen.

3. Sie wählen die Schnittstelle aus, über die Ihre Datenbankanwendung auf die Datenbankinstanz zugreifen soll.

4. Sie binden die Datenbankanwendung über die ausgewählte Schnittstelle an die Datenbankinstanz an.

Ergebnis

Benutzer der Datenbankanwendung können Daten abfragen und ändern.

Siehe auch:

Das Datenbanksystem im Überblick

SQL

Technische Systemlandschaft

Datenbankwerkzeuge

Informationen zur Weiterentwicklung der MaxDB-Software finden Sie im Abschnitt Open-Source-Entwicklung der Datenbanksoftware und in der Dokumentation Strukturlink Entwicklungsumgebung.


Glossar (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt Glossar

Einsatzmöglichkeiten

In diesem Glossar werden die wichtigsten Begriffe erklärt, die Sie bei der Arbeit mit dem Datenbanksystem MySQL MaxDB benötigen.

Einführungshinweise

Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Download und im Strukturlink Installationshandbuch.

Für einen schnellen Einstieg in die SQL-Syntax des Datenbanksystems verwenden Sie das Strukturlink SQL-Tutorial. Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Konzepte des Datenbanksystems.


A (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation A


After-Image (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation After-Image

siehe Redo-Log-Eintrag


Anwendungsdaten (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Anwendungsdaten

Die Datensätze einer Datenbankinstanz einschließlich ihrer Indexeinträge werden als Anwendungsdaten bezeichnet.

Die Anwendungsdaten einer Tabelle oder eines Index belegen mindestens eine Seite in einem Data-Volume. Bei großen Tabellen verteilt das Datenbanksystem die Anwendungsdaten unter Umständen auf mehrere Data-Volumes. Sie können nicht beeinflussen oder herausfinden, welche Anwendungsdaten in welchen Data-Volumes gespeichert sind.

Siehe auch:

Konzepte des Datenbanksystems, Datenspeicherung


Arbeitsspeicher (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Arbeitsspeicher

siehe Cache


Arbeitsverzeichnis (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Arbeitsverzeichnis

Das Arbeitsverzeichnis einer Datenbankinstanz ist das Verzeichnis, in dem das Datenbanksystem Konfigurations- und Protokolldateien speichert. Wenn Sie bei der Arbeit mit einer Datenbankinstanz einen relativen Pfad angeben, dann interpretiert das Datenbanksystem diesen Pfad immer relativ zum Arbeitsverzeichnis.

Wenn Sie eine neue Datenbankinstanz anlegen, konfigurieren Sie den <independent_data_path> und damit implizit den Pfad des Arbeitsverzeichnisses. Der Vorschlagswert für den Pfad des Arbeitsverzeichnisses ist <independent_data_path>\wrk\<database_name>. Das Datenbanksystem legt den Pfad des Arbeitsverzeichnisses im allgemeinen Datenbankparameter RUNDIRECTORY ab.

Arbeitsverzeichnis der Datenbankinstanz DEMODB

Microsoft Windows:

C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB

UNIX/Linux:

/var/opt/sdb/data/wrk/DEMODB

Bei einem Restart nach einem Systemausfall verschiebt das Datenbanksystem die alten Protokolldateien ins Verzeichnis <diag_history_path> (Vorschlagswert: <independent_data_path>\wrk\<database_name>\DIAGHISTORY).

Siehe auch:

Installationshandbuch, Strukturlink Verzeichnisse


Architektur (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Architektur

MaxDB-Datenbankinstanzen, -Werkzeuge und -Schnittstellen können auf unterschiedlichen Rechnern in einem Netzwerk installiert sein.

Siehe auch:

Konzepte des Datenbanksystems, Technische Systemlandschaft


ASCII (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation ASCII

ASCII (American Standard Code for Information Interchange) ist ein Zeichensatz, der ursprünglich 128 Zeichenkombinationen (7 Bit) zur Verfügung stellte.

Das Datenbanksystem MaxDB verwendet einen 8-Bit-ASCII-Zeichensatz (ISO 8859/1.2), der 256 Zeichen umfasst:

Diese Grafik wird im zugehörigen Text erklärt

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Referenzhandbuch, Codeattribut

Loader, Strukturlink Code-Spezifikation


Ausführungsplan (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Ausführungsplan

siehe Suchstrategie


Authentifizierung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Authentifizierung

Das Datenbanksystem authentifiziert Benutzer anhand ihrer Kennwörter. Es verwendet dabei ein Challenge-Response-Verfahren in Kombination mit einem Einmalschlüssel.

Siehe auch:

Konzepte des Datenbanksystems, Authentifizierung

SQL-Referenzhandbuch, Autorisierung


AUTOCOMMIT-Modus (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation AUTOCOMMIT-Modus

Der AUTOCOMMIT-Modus legt fest, ob das Datenbanksystem SQL-Anweisungen automatisch mit einem COMMIT abschließt oder ob Datenbankbenutzer nach einer SQL-Anweisung explizit ein COMMIT eingeben müssen.

Siehe auch:

SQL Studio, Strukturlink Benutzereinstellungen

SQLCLI, Strukturlink Übersicht der SQLCLI-Kommandos

Loader, Strukturlink AUTOCOMMIT-Kommando


Automatische Log-Sicherung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Automatische Log-Sicherung

Wenn die automatische Log-Sicherung eingeschaltet ist, dann sichert das Datenbanksystem die Redo-Log-Einträge der Datenbankinstanz automatisch aus dem Log-Bereich in Dateien.

Siehe auch:

Konzepte des Datenbanksystems, Log-Einträge sichern

Database Manager GUI, Strukturlink Ein- und Ausschalten der automatischen Log-Sicherung

Database Manager CLI, Strukturlink autolog_on

Datenbankverwaltung im CCMS, Strukturlink Automatische Log-Sicherung aktivieren


Automatischer Start (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Automatischer Start

Sie können Betriebssystem und Datenbankinstanz so konfigurieren, dass das Datenbanksystem die Datenbankinstanz beim Starten des Betriebssystems automatisch in den Betriebszustand ONLINE überführt (automatischer Start).

Siehe auch:

Konzepte des Datenbanksystems, Automatischer Start


Automatisierung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Automatisierung

Sie können sowohl regelmäßig als auch nur bei Bedarf auszuführende Verwaltungsaufgaben automatisieren.

Siehe auch:

Konzepte des Datenbanksystems, Verwaltungsaufgaben automatisieren


B (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation B


B*-Baum (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation B*-Baum

Ein B*-Baum ist eine interne Zugriffstruktur, über die das Datenbanksystem auf Anwendungsdaten zugreift.

Siehe auch:

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


Backint for MaxDB (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Backint for MaxDB

Backint for MaxDB ist eine Schnittstelle, über die Sie MaxDB-Datenbankinstanzen mit externen Sicherungswerkzeugen sichern und wiederherstellen können.

Siehe auch:

Dokumentation zu Strukturlink Backint for MaxDB


Before-Image (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Before-Image

siehe Undo-Log-Eintrag


Beispiel (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Beispiel

Um Befehle und Aktionen zu illustrieren, verwendet die Dokumentation die Demo-Datenbankinstanz DEMODB und die darin enthaltenen Demo-Daten des Schemas HOTEL.

dbmcli –d DEMODB –u DBADMIN,SECRET db_online

loadercli –d DEMODB –u MONA,RED –s HOTEL

Siehe auch:

Variablen in der Dokumentation

Konzepte des Datenbanksystems, Demo-Datenbank


Benutzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Benutzer

Das Datenbanksystem unterscheidet zwischen folgenden Typen von Benutzern:

· Datenbankbenutzer

· Database Manager-Benutzer (DBM-Benutzer)

· Datenbanksystemadministrator (SYSDBA-Benutzer)

Siehe auch:

Konzepte des Datenbanksystems, Benutzer, Authentifizierung und Berechtigungen


Benutzerdefinierte Funktion (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Benutzerdefinierte Funktion

siehe Datenbankfunktion


Benutzergruppe (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Benutzergruppe

Auf UNIX/Linux verwendet MaxDB eine spezielle Betriebssystembenutzergruppe <sdba_group>. Die Mitglieder dieser Benutzergruppe haben auf Betriebssystemebene umfassende Berechtigungen für den Zugriff auf die Datenbankressourcen.

Siehe auch:

Konzepte des Datenbanksystems, <sdba_group> (spezielle Betriebssystemgruppe)


Benutzerschlüssel (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Benutzerschlüssel

Sie können Ihre Anmeldedaten für die Anmeldung an eine Datenbankinstanz unter einem Benutzerschlüssel ablegen. Um sich an die Datenbankinstanz anzumelden, müssen Sie dann nur noch den Benutzerschlüssel angeben.

Um Benutzerschlüssel anzulegen und zu verwalten, verwenden Sie das Datenbankwerkzeug XUSER.

Siehe auch:

XUSER, Strukturlink Anlegen oder Ändern von XUSER-Einträgen


Berechtigung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Berechtigung

MaxDB unterscheidet zwischen folgenden Berechtigungen, die Benutzer des Datenbanksystems haben können:

· Berechtigungen von Datenbankbenutzern für den Zugriff auf Datenbankobjekte mit SQL-Anweisungen (u.a. abhängig von der Benutzerklasse des Datenbankbenutzers)

· Berechtigungen von DBM-Benutzern für das Ausführen von Verwaltungsaufgaben mit dem Datenbankwerkzeug Database Manager (Serverberechtigungen).

Siehe auch:

Konzepte des Datenbanksystems, Benutzer, Authentifizierung und Berechtigungen


Betriebsmodus (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Betriebsmodus

Wenn Sie ein Kommandozeilenprogramm aufrufen, wählen Sie einen Betriebsmodus. Folgende Kommandozeilenprogramme können Sie in verschiedenen Betriebsmodi aufrufen:

● Database Manager CLI

● SQLCLI

Auch der Loader hat verschiedene Betriebsmodi. Sie unterscheiden sich jedoch von den unten beschriebenen Betriebsmodi.

Betriebsmodi

Name | Beschreibung
Kommandomodus | Sie geben Sie zusammen mit dem Aufruf des Programms gegebenenfalls Optionen und anschließend genau ein Kommando an. Das System führt dieses Kommando aus und beendet danach das Programm.
Sitzungsmodus | Sie rufen zunächst nur das Programm auf. Sie können nun Kommandos nacheinander eingeben und ausführen, ohne dass das Programm beendet wird. Um den Sitzungsmodus zu beenden, beenden Sie das Programm.
Skriptmodus | Sie geben beim Aufrufen des Programms den Namen einer Skriptdatei an, die die auszuführenden Kommandos enthält. Das Programm führt das Skript im Hintergrund aus.

Siehe auch:

Database Manager CLI, Strukturlink Aufrufen des Database Manager CLI

Tutorial Datenbankverwaltung, Strukturlink Betriebsmodi im Database Manager CLI

SQLCLI, Strukturlink Kommando ausführen

Loader, Strukturlink Aufrufen des Loader


Betriebssystembenutzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Betriebssystembenutzer

Betriebssystembenutzer können mit Betriebssystemkommandos auf die Datenbankressourcen zugreifen. Um die Datenbankressourcen vor unberechtigen Zugriff zu schützen, gibt es für MaxDB auf UNIX und Linux spezielle Betriebssystembenutzer und -benutzergruppen.

Siehe auch:

Konzepte des Datenbanksystems, Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)


Betriebszustand (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Betriebszustand

Eine Datenbankinstanz kann sich in folgenden Betriebszuständen befinden.

Betriebszustand | Beschreibung
ONLINE | Die Datenbankinstanz ist gestartet. Datenbankbenutzer mit den entsprechenden Berechtigungen können sich anmelden und SQL-Anweisungen ausführen. Datenbankadministratoren führen in diesem Betriebszustand die Mehrzahl der Verwaltungsaufgaben aus.
STANDBY | nur für Standby-Instanzen in Hot Standby-Systemen; Zu einer Standby-Instanz können Sie keine Verbindung herstellen. Sie befindet sich ständig im Restart-Zustand.
ADMIN | Die Datenbankinstanz steht nur für Verwaltungsaufgaben zur Verfügung.
OFFLINE | Die Datenbankinstanz ist nicht in Betrieb.

Wenn die Datenbankinstanz von einem Betriebszustand in einen anderen Betriebszustand überführt wird, kann sie sich kurzzeitig in einem Zwischenzustand befinden.

Um den Betriebszustand der Datenbankinstanz zu überwachen oder zu ändern, verwenden Sie den Database Manager oder in SAP-Systemen den Datenbankassistenten des CCMS.

Siehe auch:

● Database Manager GUI, Strukturlink Betriebszustand überwachen

● Database Manager CLI, Strukturlink Steuern von Datenbankinstanzen

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Betriebszustand

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink liveCache-Zustand, Strukturlink Operating


Blattseite (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Blattseite

Eine Blattseite ist eine Seite auf der unterste Ebene (Blattebene) eines B*-Baums. Blattseiten enthalten die Datensätze.

Siehe auch:

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


BLOB (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation BLOB

siehe LONG-Wert


C (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation C


Cache (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Cache

Ein Cache ist ein Arbeitsspeicherbereich. Um Zugriffe auf die Festplatten zu sparen, puffert das Datenbanksystem Lese- und Schreiboperationen im Arbeitsspeicher. Sie können die Arbeitsspeicherbereiche über Datenbankparameter konfigurieren.

Siehe auch:

Konzepte des Datenbanksystems, Arbeitsspeicherbereiche

Database Manager GUI, Strukturlink Cache-Informationen anzeigen

Database Manager CLI, Strukturlink show

In SAP-Systemen verwenden Sie zum Anzeigen von Datenbankinformationen den Strukturlink Datenbankassistenten bzw. den Strukturlink liveCache-Assistenten.


Catalog-Cache (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Catalog-Cache

Der Catalog-Cache ist ein Arbeitsspeicherbereich, in dem das Datenbanksystem Informationen aus dem Datenbankkatalog ablegt.

Siehe auch:

Konzepte des Datenbanksystems, Arbeitsspeicherbereiche


Checkpoint (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Checkpoint

siehe Savepoint


CLOB (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation CLOB

siehe LONG-Wert


Codeattribut (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Codeattribut

Mit dem Codeattribut legen Sie fest, in welchem Zeichensatz die Werte in einer Tabellenspalte abgelegt werden. Hiervon ist unter anderem die Sortierreihenfolge abhängig.

Siehe auch:

Referenzhandbuch, Codeattribut

Loader, Strukturlink Code-Spezifikation


COMMIT (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation COMMIT

Ein COMMIT schließt eine Transaktion ab. Bei einem COMMIT speichert das Datenbanksystem alle von der Transaktion durchgeführten Änderungen. Änderungen, die durch ein COMMIT abgeschlossen wurden, kann das Datenbanksystem nicht mehr durch ein ROLLBACK rückgängig machen.

Nach einem COMMIT gibt das Datenbanksystem alle Sperren frei, die der Transaktion zugeordnet waren, und eröffnet implizit eine neue Transaktion.

Systemvorschlag: Das Datenbanksystem führt alle erforderlichen COMMIT-Aktionen automatisch durch (AUTOCOMMIT-Modus ist eingeschaltet). Sie können den AUTOCOMMIT-Modus ausschalten; dann müssen Sie explizit COMMIT-Anweisungen eingeben.

Siehe auch:

SQL-Referenzhandbuch, COMMIT-Anweisung


Constraint (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Constraint

Ein Constraint ist eine weitere Einschränkung für den Wertebereich des Datentyps einer Spalte.

Siehe auch:

SQL-Tutorial, Strukturlink Constraints

SQL-Referenzhandbuch, CONSTRAINT-Definition (constraint_definition)


Converter (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Converter

Der Converter enthält die Informationen, welche logischen Seitennummern an welchen physikalischen Positionen (Blockadressen) gespeichert sind.

Siehe auch:

Konzepte des Datenbanksystems, Converter


Cursor (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Cursor

Ein Cursor ist ein Datenbankobjekt, mit dem Sie in der benannten Ergebnistabelle einer SQL-Anweisung navigieren können.

Siehe auch:

SQL-Referenzhandbuch, DECLARE CURSOR-Anweisung (declare_cursor_statement)


D (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation D


Data-Cache (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Data-Cache

Der Data-Cache ist ein Arbeitsspeicherbereich, in dem das Datenbanksystem die Datenseiten ablegt, auf die es zuletzt im Datenbereich lesend oder schreibend zugegriffen hat.

Siehe auch:

Konzepte des Datenbanksystems, Arbeitsspeicherbereiche

Database Manager GUI, Strukturlink Cache-Informationen anzeigen

Database Manager CLI, Strukturlink show

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Caches

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Caches


Data-Volume (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Data-Volume

Die Data-Volumes sind der permanente Speicher, in denen das Datenbanksystem die Daten der Datenbank speichert. Alle Data-Volumes einer Datenbankinstanz zusammen werden als Datenbereich bezeichnet.

Siehe auch:

Konzepte des Datenbanksystems, Volumes (permanenter Speicher)

Database Manager GUI, Strukturlink Volumes anlegen, anzeigen und löschen, Strukturlink Volume-Eigenschaften ändern

Database Manager CLI, Strukturlink db_addvolume

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Volumes

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Volumes


Data-Writer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Data-Writer

siehe Pager


Database Analyzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Database Analyzer

Der Database Analyzer ist ein Datenbankwerkzeug, mit dem Sie die Performance von Datenbankinstanzen analysieren können. Es löst die früheren Werkzeuge XWIZARD und XWIZTRC ab.

Siehe auch:

Dokumentation zum Strukturlink Database Analyzer

Konzepte des Datenbanksystems, Datenbankwerkzeuge

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Database Analyzer

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Database Analyzer

Database Manager GUI, Strukturlink Database Analyzer-Informationen anzeigen und löschen


Database Manager (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Database Manager

Der Database Manager ist ein Datenbankwerkzeug für das Anlegen und Verwalten von Datenbankinstanzen, Datenbankbenutzern und Database Manager-Benutzern.

Es stehen folgende Ausprägungen des Database Manager zur Verfügung:

· Strukturlink Database Manager GUI

· Strukturlink Database Manager CLI

Siehe auch:

Konzepte des Datenbanksystems, Datenbankwerkzeuge


Database Manager-Benutzer (DBM-Benutzer) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Database Manager-Benutzer (DBM-Benutzer)

Ein Database Manager-Benutzer (DBM-Benutzer) kann mit dem Datenbankwerkzeug Database Manager arbeiten, um Datenbankinstanzen zu verwalten.

Siehe auch:

Konzepte des Datenbanksystems

· Database Manager-Benutzer (DBM-Benutzer)

· Konventionen für Benutzernamen und Kennwörter

Database Manager GUI, Strukturlink Verwalten der Database Manager-Benutzer

Database Manager CLI, Strukturlink Verwalten der Database Manager-Benutzer


Datei-ID (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datei-ID

Einige Protokoll- und Konfigurationsdateien haben eine Datei-ID. Sie benötigen die Datei-ID, um sich die jeweilige Datei mit dem Datenbankwerkzeug Database Manager anzeigen zu lassen.

Siehe auch:

Konzepte des Datenbanksystems,

● Protokolldateien

● Konfigurationsdateien


Dateiklasse (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Dateiklasse

Die Konfigurations- und Protokolldateien des Datenbanksystems sind unterschiedlichen Dateiklassen zugeordnet:

backup | Protokolldateien vom Sichern und Wiederherstellen
config | Konfigurationsdateien
dump | Speicherauszüge
hist | Diagnosedateien
lvc | Protokolldateien für den Datenbankinstanztyp SAP liveCache
protocol | allgemeine Protokolldateien

Die Dateiklassen werden beim Packen von Datenbankdateien für den Support benötigt.

Siehe auch:

Konzepte des Datenbanksystems

· Konfigurationsdateien

· Protokolldateien

Database Manager CLI, Strukturlink diag_pack


Dateiverzeichnis (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Dateiverzeichnis

Das Dateiverzeichnis ist eine interne Verwaltungsstruktur des Datenbanksystems. Im Datei-Verzeichnis ist unter anderem Folgendes gespeichert:

● Zuordnung der Wurzelseiten der B*-Bäume zu Tabellen-IDs

● Zuordnung der Einstiegsseiten von Seitenketten zu Tabellen-IDs

● Typkennzeichen (gibt an, ob eine Tabelle Primärdaten, Sekundärschlüssel oder LONG-Werte enthält)

● statistische Informationen zur Anzahl der Datensätze und zur Größe der Tabellen

Jede interne Datei im Dateiverzeichnis hat eine eindeutige Dateinummer (8 Byte lang).

Informationen zum Dateiverzeichnis sind unter anderem in den Systemtabellen FILES und FILEDIRECTORIES enthalten.

Siehe auch:

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen

Referenzhandbuch, Systemtabellen


Datenbank (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbank

Eine Datenbank ist eine Menge von Daten mit einer regelmäßigen Struktur. Mit der Datenbanksoftware können Sie Datenbanken anlegen und verwalten. Um auf die Daten in der Datenbank zuzugreifen, verwenden Sie SQL-Anweisungen.

Siehe auch:

Konzepte des Datenbanksystems, Das Datenbanksystem im Überblick

Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz

Database Manager CLI, Strukturlink db_create

SQL-Referenzhandbuch, SQL-Anweisungen: Überblick

SQL-Tutorial, Strukturlink SQL-Tutorial


Datenbank-ID (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbank-ID

Die Datenbank-ID identifiziert den Datenbereich einer Datenbankinstanz eindeutig. Die Datenbank-ID wird beim Anlegen einer neuen Datenbankinstanz vom Datenbanksystem nach folgendem Muster erzeugt:

<computer_name>:<database_name>_<date>_<time>

Datenbank-ID des Datenbereichs der Datenbankinstanz DEMODB auf dem Rechner PARMA, die am 30.01.2006 um 11:26:33 Uhr angelegt wurde:

PARMA:DEMODB_20060130_112633

Das Datenbanksystem benötigt die Datenbank-ID unter anderem dazu, um beim Wiederherstellen der Datenbankinstanz zu überprüfen, ob die verwendeten Sicherungen auch wirklich zu dieser Datenbankinstanz gehören.

Die Datenbank-ID des Datenbereichs ändert sich in folgenden Situationen:

● Sie haben die Datenbankinstanz initialisiert und dann aus einer Datensicherung wiederhergestellt.

Der Datenbereich der Datenbankinstanz erhält die Datenbank-ID, die in der Datensicherung gespeichert war.

Wenn Sie die Datensicherung einer anderen Datenbankinstanz eingelesen haben (z. B. beim Erstellen einer Datenbankkopie), dann enthält die Datenbank-ID nun zunächst den Namen dieser anderen Datenbankinstanz.

Wenn Sie die erste Datensicherung in der wiederhergestellten Datenbankinstanz durchführen, erhält der Datenbereich wiederum eine neue Datenbank-ID, die den Namen der aktuellen Datenbankinstanz und den aktuellen Zeitstempel enthält.

● Sie haben eine Datensicherung durchgeführt, nachdem die Sicherungshistorie unterbrochen war (z. B. nach dem Restart der Datenbankinstanz bis zu einem bestimmten Zeitpunkt oder nach dem Einschalten des Überschreibmodus für den Log-Bereich).

Der Datenbereich der Datenbankinstanz erhält eine neue Datenbank-ID mit dem aktuellen Zeitstempel.

Das Datenbanksystem speichert die Datenbank-ID an folgenden Stellen:

● in der Restart-Information im Datenbereich (identifiziert den Datenbereich der Datenbankinstanz)

● in der Informationsseite des Log-Bereichs (identifiziert den Log-Bereich der Datenbankinstanz)

● in der Informationsseite jeder Sicherung (identifiziert die Sicherung)

In folgenden Fällen stimmt die Datenbank-ID von Datenbereich und Log-Bereich nicht über:

● Sie haben eine Datensicherung aus einer anderen Datenbankinstanz eingelesen, ohne die Datenbankinstanz zu initialisieren (und damit den Log-Bereich zu leeren).

● In Hot-Standby-Systemen (mehrere Datenbankinstanzen verwenden denselben Log-Bereich).

Siehe auch:

Database Manager CLI,

● Strukturlink db_restartinfo

● Strukturlink medium_label


Datenbank-Trace (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbank-Trace

Sie können das Schreiben eines Datenbank-Trace einschalten. Der Datenbank-Trace protokolliert alle Reaktionen des Kerns auf Datenbankanweisungen.

Der Datenbank-Trace wird auch als Kernel-Trace oder vtrace bezeichnet.

Siehe auch:

Konzepte des Datenbanksystems, Traces

Datenbankverwaltung im CCMS, Strukturlink Datenbank-Trace

Database Manager GUI, Strukturlink Datenbank-Trace verwenden

Database Manager CLI, Strukturlink trace_on


Datenbankadministrator (DBA-Benutzer) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankadministrator (DBA-Benutzer)

Ein Datenbankadministrator (DBA-Benutzer) ist ein Datenbankbenutzer, der Benutzer und Objekte in der Datenbank verwalten kann.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankbenutzer


Datenbankanwendung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankanwendung

Datenbankanwendungen sind Anwendungen, die eine Datenbank zur Ablage ihrer Daten verwenden. Datenbankanwendungen greifen über Schnittstellen auf eine Datenbank zu.

Siehe auch:

Konzepte des Datenbanksystems,

· Entwicklung von Datenbankanwendungen

· Schnittstellen


Datenbankbenutzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankbenutzer

Datenbankbenutzer können mit SQL-Anweisungen Daten in der Datenbankinstanz bearbeiten. Dazu können sie z. B. die Datenbankwerkzeuge SQL Studio, Web SQL Studio, SQLCLI und den Loader verwenden.

Datenbankbenutzer können sich nicht am Database Manager anmelden. Sie können Datenbankbenutzer aber mit dem Database Manager anlegen und verwalten.

Siehe auch:

Konzepte des Datenbanksystems

● Datenbankbenutzer

● Konventionen für Benutzernamen und Kennwörter

Database Manager GUI, Strukturlink Verwalten von Datenbankbenutzern

SQL-Referenzhandbuch, Autorisierung


Datenbankdatei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankdatei

Das Datenbanksystem legt eine Reihe von Datenbankdateien an, u. a. Konfigurationsdateien und Protokolldateien.

Siehe auch:

Konzepte des Datenbanksystems

· Konfigurationsdateien

· Protokolldateien


Datenbankdesign (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankdesign

Datenbankdesign ist die Umsetzung Ihres logischen Datenmodells in Datenbankobjekte. Hierzu gehören u. a. die Definition der Tabellen, der Schlüssel und der Indizes. Das Datenbankdesign hat großen Einfluss auf die Performance im laufenden Betrieb.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankdesign

SQL-Referenzhandbuch, Datendefinition


Datenbankfunktion (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankfunktion

Eine Datenbankfunktion ist eine spezielle Datenbankprozedur. Eine Datenbankfunktion kann nur einen Ausgabeparameter haben. Sie rufen einen Datenbankfunktion auf die gleiche Weise wie eine vordefinierte Funktion auf.

Siehe auch:

SQL-Referenzhandbuch

● Name einer Datenbankfunktion

● CREATE FUNCTION-Anweisung (create_function_statement)

● Datenbankfunktionsaufruf (dbfunction_call)


Datenbankinstanz (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankinstanz

Eine Datenbank einschließlich der für ihren Betrieb notwendigen zusätzlichen Informationen wird als Datenbankinstanz bezeichnet. Jede Datenbankinstanz hat einen Datenbanknamen und besteht aus Volumes, allen Dateien im Arbeitsverzeichnis und einer Sammlung von Metadaten (u. a. Konfigurationsdateien, Datenbankparameter, Pfade der Volumes).

Sie legen Datenbankinstanzen mit dem Installation Manager oder dem Datenbankwerkzeug Database Manager an.

Siehe auch:

Konzepte des Datenbanksystems, Das Datenbanksystem im Überblick

Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz

Database Manager CLI, Strukturlink db_create


Datenbankinterne Datei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankinterne Datei

Jedes Datenbankobjekt wird vom Datenbanksystem intern als eine oder mehrere datenbankinterne Dateien abgelegt. Für alle datenbankinternen Dateien gibt es einen Eintrag im datenbankinternen Dateiverzeichnis.


Datenbankkatalog (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankkatalog

Der Datenbankkatalog einer Datenbank enthält die Metadaten aller Datenbankobjekte. Der Datenbankkatalog setzt sich aus folgenden Teilen zusammen:

· Informationen über die Installation des Datenbanksystems

· Metadaten der Benutzer und Benutzergruppen

· Metadaten der Datenbankobjekte. Hierzu gehören unter anderem die Metadaten der Basistabellen und View-Tabellen.

Der Zugriff eines Benutzers auf Metadaten eines anderen Benutzers oder einer anderen Benutzergruppe ist nur mit den entsprechenden Privilegien möglich.


Datenbankkopie (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankkopie

Bei einer Datenbankkopie duplizieren Sie die Daten einer Datenbankinstanz.

Eine Datenbankkopie können Sie zum Beispiel für Tests, für die Entwicklung von Datenbankanwendungen oder beim Einrichten einer Schattendatenbank verwenden. Eine Systemkopie eines SAP-Systems benötigt ebenfalls eine Datenbankkopie.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankkopie

Tutorial Datenbankverwaltung, Strukturlink Datenbankkopie erstellen (Datensicherung in eine andere Datenbankinstanz einlesen)


Datenbankname (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankname

Der Datenbankname ist der Name einer Datenbankinstanz.

Siehe auch:

Konzepte des Datenbanksystems, Konventionen für Datenbanknamen


Datenbankobjekt (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankobjekt

Datenbankobjekte sind die logischen Einheiten, mit denen das Datenbanksystem arbeitet. Hierzu gehören unter anderem:

● Basistabellen

● View-Tabellen

● Synonyme

● Indizes

● Benutzer

● Schemas

● Trigger

● Datenbankprozeduren

● Datenbankfunktionen

Die Metadaten der Datenbankobjekte werden vom Datenbanksystem im Datenbankkatalog abgelegt.

Um Datenbankobjekte anzulegen und zu verwalten, verwenden Sie SQL-Anweisungen.

Siehe auch:

SQL-Referenzhandbuch

● Datendefinition

● Autorisierung


Datenbankparameter (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankparameter

Datenbankparameter legen die Eigenschaften einer Datenbankinstanz fest. Sie können die Werte der meisten Datenbankparameter ändern.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankparameter


Datenbankprozedur (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankprozedur

Eine Datenbankprozedur ist ein Datenbankobjekt, das eine Folge von Anweisungen beinhaltet und somit einen in sich geschlossenen Programmteil bildet.

Datenbankprozeduren werden in der Datenbank angelegt und gespeichert. Sie können beliebig viele Datenbankprozeduren definieren. Um eine Datenbankprozedur auszuführen, müssen Sie diese von einem Anwendungsprogramm aus mit der entsprechenden SQL-Anweisung aufrufen.

Siehe auch:

SQL-Referenzhandbuch

● Name einer Datenbankprozedur

● CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement)

● CALL-Anweisung (call_statement)

Datenbankverwaltung im CCMS: MaxDB, Strukturlink DB-Prozeduren

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink DB-Prozeduren


Datenbanksitzung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbanksitzung

Um SQL-Anweisungen in einer Datenbankinstanz ausführen zu können, müssen Sie eine Datenbanksitzung eröffnet haben.

Um eine Datenbanksitzung zu eröffnen, melden Sie sich mit einem Datenbankwerkzeug oder über eine Schnittstelle als Datenbankbenutzer mit Benutzername und Kennwort an eine Datenbankinstanz an. Beim Eröffnen einer Datenbanksitzung können Sie unter anderem die folgenden Eigenschaften der Datenbankinstanz übersteuern:

● SQL-Modus

● Cache-Limit

● Timeout-Wert

● Isolation-Level

Später beenden Sie die Datenbanksitzung mit einem entsprechenden Kommando, oder das Datenbanksystem beendet die Datenbanksitzung nach dem Überschreiten des Timeout-Werts.

Pro Datenbanksitzung startet das Datenbanksystem eine User-Task. Die maximale Anzahl der User-Tasks und damit der Datenbanksitzungen konfigurieren Sie mit dem allgemeinen Datenbankparameter MAXUSERTASKS.

Beachten Sie beim Konfigurieren dieses Datenbankparameters, dass Datenbankwerkzeuge für bestimmte Aktionen implizit Datenbanksitzungen eröffnen und schließen.

Siehe auch:

SQL Studio, Strukturlink Eröffnen einer Datenbanksitzung

SQLCLI, Strukturlink An eine Datenbankinstanz anmelden

Web SQL Studio, Strukturlink An eine Datenbankinstanz anmelden

Database Manager GUI, Strukturlink Datenbanksitzungen anzeigen

Database Manager CLI, Strukturlink SQL-Zugriffe auf die Datenbankinstanz

In SAP-Systemen verwenden Sie zum Anzeigen von Datenbankinformationen den Strukturlink Datenbankassistenten oder für liveCache-Instanzen den Strukturlink liveCache-Assistenten.

Konzepte des Datenbanksystems, Allgemeine Datenbankparameter


Datenbankstruktur (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankstruktur

Das Datenbanksystem legt die Daten in internen Datenbankstrukturen ab, z. B. in B*-Bäumen. Hardwarefehler können zu inkonsistenten Datenbankstrukturen führen.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankstrukturen prüfen


Datenbanksystem (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbanksystem

Das Datenbanksystem ist die Gesamtheit der Software, mit der Sie Datenbankinstanzen anlegen und verwalten und Daten dieser Datenbankinstanzen bearbeiten können.

Siehe auch:

Konzepte des Datenbanksystems

· Das Datenbanksystem im Überblick

· Datenbankwerkzeuge

· Schnittstellen


Datenbanksystemadministrator (SYSDBA-Benutzer) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbanksystemadministrator (SYSDBA-Benutzer)

Der Datenbanksystemadministrator (SYSDBA-Benutzer) ist der erste Datenbankbenutzer. Dieser Benutzer wird beim Anlegen einer Datenbankinstanz angelegt. Vorschlagswert für den Namen des Datenbanksystemadministrators ist DBADMIN.

Der Datenbanksystemadministrator hat von allen Datenbankbenutzern die umfassendsten Rechte. Der Datenbanksystemadministrator ist ein Datenbankadministrator, der zusätzlich über alle möglichen Rechte eines Database Manager-Benutzers (DBM-Benutzer) verfügt.

Siehe auch:

Konzepte des Datenbanksystems

● Datenbanksystemadministrator (SYSDBA-Benutzer)

● Konventionen für Benutzernamen und Kennwörter

Database Manager GUI, Strukturlink Verwalten des Datenbanksystemadministrators

Database Manager CLI, Strukturlink Verwalten der Database Manager-Benutzer

Sicherheitsleitfaden, Kennwörter von Standardbenutzern ändern


Datenbankverbindung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankverbindung

Die Verbindung zwischen einem Datenbankwerkzeug oder einer Schnittstelle und der Datenbankinstanz ist die Voraussetzung für jede Arbeit mit der Datenbankinstanz.

Um eine Verbindung zu einer Datenbankinstanz herzustellen, benötigen Sie unter anderem folgende Informationen:

● Datenbankname

● Name des Datenbankrechners (wenn die Datenbankinstanz sich auf einem entfernten Rechner befindet)

Siehe auch:

Database Manager GUI, Strukturlink Verbindung zum DBM-Server

Database Manager CLI, Strukturlink Aufrufen des Database Manager CLI

Loader, Strukturlink Aufbau einer Datenbanksitzung: Kommandos

Datenbankverwaltung im CCMS, Strukturlink Name der Datenbankverbindung


Datenbankwerkzeug (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankwerkzeug

Datenbankwerkzeuge sind Programme, die Sie für das Verwalten und Überwachen von Datenbankinstanzen, das Bearbeiten von Daten und die Fehlersuche verwenden können.

Für MaxDB stehen mehrere Datenbankwerkzeuge zur Verfügung.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankwerkzeuge


Datenbereich (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbereich

Alle Data-Volumes einer Datenbankinstanz zusammen werden als Datenbereich bezeichnet. Der Datenbereich enthält unter anderem die Anwendungsdaten, den Datenbankkatalog und die Undo-Log-Einträge der Datenbankinstanz.

Siehe auch:

Konzepte des Datenbanksystems, Volumes (permanenter Speicher)

Database Manager GUI, Strukturlink Datenbereichs-Informationen anzeigen

Database Manager CLI, Strukturlink show

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Datenbereich überwachen

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Datenbereich überwachen


Datenintegrität (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenintegrität

Datenintegrität bedeutet, dass die Daten in einer Datenbank dauerhaft unverfälscht bleiben. Das Datenbanksystem erreicht Datenintegrität, indem es die Daten vor dem absichtlichen unautorisierten oder dem versehentlichen autorisierten Einfügen, Ändern oder Löschen schützt.

Siehe auch:

SQL-Referenzhandbuch, Datenintegrität absichern


Datensatz (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datensatz

Ein Datensatz entspricht einer Zeile in einer Basistabelle der Datenbank.


Datensicherung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datensicherung

Bei einer Datensicherung sichern Sie die Inhalte des Datenbereichs und die für eine Wiederherstellung notwendigen Datenbankparameter auf einen Datenträger.

Siehe auch:

Konzepte des Datenbanksystems, Daten sichern

Database Manager GUI, Strukturlink Backup Wizard

Database Manager CLI, Strukturlink backup_start

Datenbankverwaltung im CCMS, Strukturlink Datensicherung einplanen


Datenträger (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenträger

Bei Daten- und Log-Sicherungen werden die Daten/die Log-Einträge auf einen Datenträger gespeichert, z. B. auf Bänder oder in Dateien im Dateisystem.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungsvorlagen und Datenträger


Datentyp (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datentyp

Der Datentyp legt fest, welche Art von Werten eine Tabellenspalte enthalten darf.

Siehe auch:

SQL-Referenzhandbuch, Datentyp (data_type)

Loader, Strukturlink Datentypen


Datenzugriff (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenzugriff

Um Daten abzulegen und darauf zuzugreifen, verwendet das Datenbanksystem B*-Bäume und Seitenketten.

Siehe auch:

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


DBA (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBA

siehe

Datenbanksystemadministrator (SYSDBA-Benutzer)

Datenbankbenutzer


DBA-Einplanungskalender (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBA-Einplanungskalender

nur in SAP-Systemen verfügbar

Mit dem DBA-Einplanungskalender können Sie die Datenbankverwaltung automatisieren. Sie können Datenbankverwaltungsaktionen einplanen, ausführen und überprüfen.

Siehe auch:

Datenbankverwaltung im CCMS, Strukturlink DBA-Einplanungskalender


DBADMIN (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBADMIN

Vorschlagswert für den Namen des Datenbanksystemadministrators (SYSDBA-Benutzer).

Siehe auch:

Konzepte des Datenbanksystems, Datenbanksystemadministrator (SYSDBA-Benutzer)


DBM-Benutzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBM-Benutzer

siehe Database Manager-Benutzer


DBM-Benutzereigenschaften (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBM-Benutzereigenschaften

Eigenschaften eines Database Manager-Benutzers

Siehe auch:

Konzepte des Datenbanksystems, Database Manager-Benutzer (DBM-Benutzer)

Database Manager GUI, Strukturlink Ändern der DBM-Benutzereigenschaften

Database Manager CLI, Strukturlink user_put


DBM-Kommando (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBM-Kommando

DBM-Kommandos sind Kommandos im Database Manager CLI, mit denen Sie Datenbankinstanzen verwalten können.

Siehe auch:

Database Manager CLI, Strukturlink Übersicht aller DBM-Kommandos


DBM-Option (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBM-Option

Sie können das Datenbankwerkzeug Database Manager CLI mit verschiedenen Optionen (DBM-Optionen) aufrufen.

Siehe auch:

Database Manager CLI, Strukturlink DBM-Optionen


DBM-Server (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBM-Server

Der DBM-Server ist der Server-Teil des Datenbankwerkzeugs Database Manager. Der DBM-Server stellt die Verbindung zwischen dem Client-Teil des Database Manager und der Datenbankinstanz her.

Siehe auch:

Konzepte des Datenbanksystems

· Datenbankwerkzeuge

· Architektur der Datenbankwerkzeuge


DBMCLI (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBMCLI

Abkürzung für Database Manager CLI

Kommandozeilen-Variante des Datenbankwerkzeugs Database Manager.

Siehe auch:

Dokumentation zum Strukturlink Database Manager CLI


DBMGUI (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DBMGUI

Abkürzung für Database Manager GUI

GUI-Variante des Datenbankwerkzeugs Database Manager.

Siehe auch:

Dokumentation zum Strukturlink Database Manager GUI


DDL-Anweisung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation DDL-Anweisung

DDL-Anweisungen sind SQL-Anweisungen, die Sie zur Definition der Datenstruktur in einer Datenbank verwenden (DDL = Data Definition Language).

Im Datenbanksystem MaxDB unterliegen DDL-Anweisungen dem Transaktionskonzept. Nachdem eine DDL-Anweisung mit einem COMMIT abgeschlossen wurde, kann sie nicht mehr rückgängig gemacht werden.

Siehe auch:

SQL-Referenzhandbuch, Datendefinition


Demo-Datenbank (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Demo-Datenbank

Um einzelne Werkzeuge des MaxDB-Datenbanksystems und Datenbankverwaltungsabläufe zu testen, können Sie eine Demo-Datenbankinstanz DEMODB einrichten.

Sie können die vollständigen Demo-Daten des Schemas HOTEL laden, um z.B. die Loader-Syntax zu testen.

Sie können die vereinfachten Demo-Daten des Schemas HOTEL erzeugen, um z.B. die SQL-Syntax zu testen.

Siehe auch:

Konzepte des Datenbanksystems, Demo-Datenbank, Objekte im Schema HOTEL

Database Manager GUI, Strukturlink Demo-Daten laden

Tutorial Datenbankverwaltung, Strukturlink Demo-Daten in eine Datenbankinstanz laden

Loader-Tutorial, Strukturlink Demo-Datenbanken DEMODB und TESTDB

SQL-Tutorial, Strukturlink Demo-Daten für das SQL-Tutorial


Dienst (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Dienst

Datenbankinstanzen, den X-Server und einige andere MaxDB-Komponenten können Sie als Dienste starten und stoppen.

Siehe auch:

Konzepte des Datenbanksystems,

· Übersicht der Dienste

· Automatischer Start


Dokumentation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Dokumentation

Das Datenbanksystem MaxDB, die Datenbankwerkzeuge und die Schnittstellen sind in der MaxDB-Bibliothek dokumentiert.

Um auf die MaxDB-Bibliothek zuzugreifen, haben Sie folgende Möglichkeiten:

· Onlinezugriff auf die HTML-Version

· Download als HTMLHelp-Version (eine .chm-Datei) für Microsoft Windows

· Download als HTML-Version (mehrere Plain-HTML-Dateien)

Siehe auch:

Konzepte des Datenbanksystems

· Dokumentation

· Download

Dokumentation für Strukturlink MaxDB

Dokumentation für Strukturlink MaxDB in SAP-Systemen

Dokumentation für Strukturlink SAP liveCache-Technologie in SAP-Systemen


E (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation E


Eigentümer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Eigentümer

Eigentümer eines Datenbankobjekts ist zunächst derjenige Datenbankbenutzer, der das Datenbankobjekt angelegt hat. Der Eigentümer besitzt besondere Privilegien für das Datenbankobjekt.

Mit der GRANT-Anweisung kann der Eigentümer eines Datenbankobjekts anderen Datenbankbenutzern Privilegien für das Datenbankobjekt gewähren.

Siehe auch:

SQL-Referenzhandbuch,

● Privilegien: Überblick

● GRANT-Anweisung (grant_statement)


Entladen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Entladen

siehe Exportieren


Entwicklung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Entwicklung

Für Entwickler bietet MaxDB folgende Möglichkeiten:

· Sie können eine Datenbankanwendung für MaxDB entwickeln und über eine Schnittstelle an eine MaxDB-Datenbankinstanz anbinden.

· Sie können die MaxDB-Software weiterentwickeln. Hierzu verwenden Sie die MaxDB-Entwicklunsgumgebung.

Siehe auch:

Konzepte des Datenbanksystems, Entwicklung von Datenbankanwendungen

Dokumentation Strukturlink Entwicklungsumgebung


Event (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Event

Ein Event ist eine Information des Datenbanksystems über das Eintreten einer definierten Situation.

Siehe auch:

Konzepte des Datenbanksystems,

● Übersicht der Datenbank-Event-Kategorien

● Verwaltungsaufgaben automatisieren

Database Manager CLI, Strukturlink Nutzen von Events der Datenbankinstanz

Dokumentation zum Strukturlink Event-Dispatcher


Event-Dispatcher (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Event-Dispatcher

Der Event-Dispatcher nimmt die von der Datenbankinstanz ausgegebenen Events entgegen und reagiert darauf.

Siehe auch:

Utilities, Strukturlink Event-Dispatcher


EXPLAIN-Anweisung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation EXPLAIN-Anweisung

Mit der EXPLAIN-Anweisung können Sie herausfinden, welche Suchstrategie der SQL-Optimierer für eine SQL-Anweisung auswählt.

Siehe auch:

SQL-Optimierer, Explain-Anweisung

Datenbankverwaltung im CCMS, Strukturlink Kommandomonitor

SQL-Referenzhandbuch, EXPLAIN-Anweisung (explain_statement)


Exportieren (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Exportieren

Zum Exportieren („Entladen“) von Daten steht das Datenbankwerkzeug Loader zur Verfügung.

Mit dem Loader exportierte Daten können Sie nicht zum Wiederherstellen einer Datenbankinstanz verwenden, weil Sie unter Umständen keinen konsistenten Datenbankzustand repräsentieren. Exportierte Daten können daher Datensicherungen nicht ersetzen.

Siehe auch:

Dokumentation zum Strukturlink Loader

Konzepte des Datenbanksystems, Exportieren und Importieren


Externes Sicherungswerkzeug (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Externes Sicherungswerkzeug

siehe Sicherungswerkzeug


F (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation F


FBM (Free Block Management) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation FBM (Free Block Management)

Im FBM im Arbeitsspeicher verwaltet das Datenbanksystem die physischen Datenseiten in den Data-Volumes.

Siehe auch:

Konzepte des Datenbanksystems, Arbeitsspeicherbereiche


Fehlermeldung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Fehlermeldung

Wenn das Datenbanksystem ein Kommando nicht ausführen konnte, gibt es eine Fehlermeldung zurück.

Siehe auch:

Dokumentation Meldungen (Erklärung der wichtigsten Informations- und Fehlermeldungen, nach Meldungsnummern sortiert)

Konzepte des Datenbanksystems, Fehlersuche


Fehlersuche (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Fehlersuche

Das Datenbanksystem stellt eine Reihe von Hilfsmittel zur Fehlersuche zur Verfügung, wie z. B. Fehlermeldungen, Protokolldateien und Traces.

Siehe auch:

Konzepte des Datenbanksystems, Fehlersuche


Fremdschlüssel (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Fremdschlüssel

Wenn die Werte einer Spalte (oder einer Kombination von Spalten) einer Tabelle immer mit den Werten der Primärschlüsselspalte einer anderen Tabelle übereinstimmen, dann wird diese Spalte (bzw. die Kombination der Spalten) als Fremdschlüssel bezeichnet.

Siehe auch:

SQL-Referenzhandbuch, Referentielle CONSTRAINT-Definition

SQL-Tutorial, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen


G (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation G


Garbage-Collector (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Garbage-Collector

Die Garbage-Collectors sind Tasks, die in User-Kernel-Threads laufen.

Aufgabe der Garbage-Collectors ist es, nicht mehr benötigte Undo-Log-Dateien und die dazugehörigen Datenbankobjekte endgültig zu löschen. Die Garbage-Collectors ermöglichen konsistente Sichten auf die Daten.

Siehe auch:

Konzepte des Datenbanksystems, History-Verwaltung


H (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation H


High-Availability (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation High-Availability

High-Availability bedeutet hohe Verfügbarkeit, also dass ein IT-System kontinuierlich ohne Ausfälle im Einsatz ist.

Siehe auch:

Konzepte des Datenbanksystems, High-Availability

SAP High Availability, Strukturlink High Availability for the MaxDB Database


History-Datei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation History-Datei

History-Dateien sind datenbankinterne Dateien, die Verweise auf die Undo-Log-Dateien beendeter Transaktionen enthalten. In den History-Dateien steht, welche Undo-Log-Datei zu welcher beendeten Transaktion gehört.

Bei jedem Savepoint schreibt das Datenbanksystem die aktualisierten History-Dateien in den Datenbereich.

Aus Performance-Gründen sind immer mehrere History-Dateien parallel geöffnet. Das Datenbanksystem berechnet die Anzahl der History-Dateien aus dem allgemeinen Datenbankparameter MAXUSERTASKS.

Siehe auch:

Konzepte des Datenbanksystems

· History-Verwaltung

· Allgemeine Datenbankparameter


Homogene Systemkopie (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Homogene Systemkopie

siehe Systemkopie


Hot-Standby (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Hot-Standby

Hot-Standby ist eine High-Availability-Strategie für Cluster-Systeme. Wenn die Master-Instanz ausfällt, dann wird eine parallel laufende Standby-Instanz aktiviert.

Siehe auch:

Konzepte des Datenbanksystems, Hot-Standby


I (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation I


I/O-Buffer-Cache (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation I/O-Buffer-Cache

Der I/O-Buffer-Cache ist der Arbeitsspeicherbereich, den das Datenbanksystem für I/O-Operationen verwendet.

Siehe auch:

Konzepte des Datenbanksystems, Arbeitsspeicherbereiche


Importieren (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Importieren

Zum Importieren („Laden“) von Daten steht das Datenbankwerkzeug Loader zur Verfügung.

Mit dem Loader exportierte Daten können Sie nicht zum Wiederherstellen einer Datenbankinstanz verwenden, weil Sie unter Umständen keinen konsistenten Datenbankzustand repräsentieren. Ein Importieren von Daten kann ein Wiederherstellen der Datenbankinstanz mit einer Datensicherung daher nicht ersetzen.

Siehe auch:

Dokumentation zum Strukturlink Loader

Konzepte des Datenbanksystems, Exportieren und Importieren


Index (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Index

Um die Suche nach Datensätzen in einer Tabelle zu beschleunigen, können Sie einen Index (auch Sekundärschlüssel genannt) anlegen. Ein Index ist ein Datenbankobjekt, das für eine einzelne Spalte oder eine Folge von Spalten einer Datenbanktabelle definiert werden kann. Ein Index besteht aus einer oder mehreren Invertierungslisten.

Ein Indexname muss zusammen mit dem Tabellennamen eindeutig sein. Bei der Definition eines Index legen Sie fest, ob die Spaltenwerte verschiedener Zeilen in den indizierten Spalten eindeutig sein müssen oder nicht.

Weil Indizes vollständig aus bereits in der Datenbank vorhandenen Daten abgeleitet sind, können Sie diese löschen, ohne dass dabei Daten verloren gehen.

Beachten Sie, dass das Datenbanksystem nach einer Datenänderung unter Umständen auch den entsprechenden Index aktualisieren muss, was Zeit kostet.

Ein Index kann folgende Zustände haben:

Zustand | Beschreibung
OK | Der Index ist intakt.
BAD | Der Index ist beschädigt. Der B*-Baum für den Index ist beschädigt und kann vom Datenbanksystem nicht mehr benutzt werden. Das Datenbanksystem ignoriert beschädigte Indizes. Sie können keine Fehler verursachen, beeinträchtigen jedoch die Performance.
MISSING | Der Index ist im Datenbankkatalog vorhanden, fehlt aber im internen Dateiverzeichnis.

Sie können beschädigte Indizes mit dem Database Manager wiederherstellen. Wenn Sie den speziellen Datenbankparameter AUTO_RECREATE_BAD_INDEXES auf YES setzen, dann stellt das Datenbanksystem beschädigte Indizes automatisch wieder her.

Sie können mit Hilfe der EXPLAIN-Anweisung überprüfen, ob der Index tatsächlich genutzt wird, wenn das Datenbanksystem nach Datensätzen sucht.

Siehe auch:

SQL-Referenzhandbuch, CREATE INDEX-Anweisung (create_index_statement), EXPLAIN-Anweisung (explain_statement)

Database Manager GUI, Strukturlink Wiederherstellen der Indizes nach Datenbankwiederherstellung

Database Manager CLI, Strukturlink sql_recreateindex

Konzepte des Datenbanksystems, B*-Bäume für Tabellen mit Indizes

Datenbankverwaltung im CCMS: Strukturlink Indizes


Indizierte Spalte (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Indizierte Spalte

Eine indizierte Spalte ist eine Spalte, die Bestandteil eines Index ist. Indizierte Spalten werden auch als invertierte Spalten bezeichnet.


Initialisieren (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Initialisieren

Wenn Sie eine Datenbankinstanz initialisieren, löscht das Datenbanksystem alle Daten (die Anwendungsdaten und den Datenbankkatalog) und alle Log-Einträge aus den Volumes. Die Konfiguration der Datenbankinstanz (Werte der Datenbankparameter, Definitionen der Volumes usw.) bleibt jedoch erhalten.

Siehe auch:

Database Manager GUI,

● Strukturlink Initialisieren einer vorhandenen Datenbankinstanz

● Strukturlink Wiederherstellen nach Initialisieren einer Datenbankinstanz

Database Manager CLI,

● Strukturlink db_activate

● Strukturlink db_activate RECOVER

Konzepte des Datenbanksystems, Datenbankinstanz wiederherstellen


Inkrementelle Datensicherung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Inkrementelle Datensicherung

Bei einer inkrementellen Datensicherung sichern Sie alle seit der letzten vollständigen Datensicherung geänderten Daten aus dem Datenbereich auf einen Datenträger.

Siehe auch:

Konzepte des Datenbanksystems, Daten sichern

Database Manager GUI, Strukturlink Sichern

Database Manger CLI, Strukturlink Sichern und Wiederherstellen von Datenbankinstanzen

Datenbankverwaltung im CCMS, Strukturlink Datensicherung einplanen


Installation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Installation

Je nach Umgebung, in der Sie MaxDB installieren, verwenden Sie unterschiedliche Installationswerkzeuge.

Siehe auch:

Installation außerhalb von SAP-Systemen (Open-Source-Projekte):

· Strukturlink Installationshandbuch

Installation innerhalb von SAP-Systemen:

· Strukturlink Installation


Installation Manager (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Installation Manager

Der Installation Manager ist ein Werkzeuge mit grafischer Oberfläche, mit dem Sie die gesamte MaxDB-Software oder einzelne Softwarekomponenten installieren und gleichzeitig eine Datenbankinstanz anlegen, aktualisieren und deinstallieren können.

Siehe auch:

Installationshandbuch, Strukturlink Verwenden des Installation Manager


Installationsprofil (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Installationsprofil

Ein Installationsprofil umfasst mehrere Softwarekomponenten der MaxDB-Datenbanksoftware. Bei der Installation können Sie auswählen, welches Installationsprofil und damit welche Softwarekomponenten Sie installieren möchten.

Siehe auch:

Installationshandbuch, Strukturlink Installationsprofile


Interaktive Log-Sicherung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Interaktive Log-Sicherung

siehe Log-Sicherung


Invertierte Spalte (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Invertierte Spalte

siehe Indizierte Spalte


Invertierungsliste (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Invertierungsliste

Eine Invertierungsliste ist Teil eines Index. Eine Invertierungsliste besteht aus einem Sekundärschlüssel und dem/den zugehörigen Primärschlüssel(n).

Eine Tabelle enthält die Namen aller Kunden eines Hotels. Als Primärschlüssel für diese Tabelle haben Sie die Kundennummer cno definiert.

cno | name | firstname
2003 | Miller | Frank
2011 | Griffith | Mary
2078 | Miller | Jane
2104 | Miller | Susan
2295 | Miller | Sally

Nun definieren Sie einen Index für die Spalte name. Die Spalte name wird so zu einer indizierten Spalte (auch invertierte Spalte genannt).

Der Index enthält folgende Invertierungslisten:

¡ eine Invertierungsliste mit dem Sekundärschlüssel Griffith und dem Primärschlüssel 2011 (der Nachname Griffith kommt in der Tabelle nur einmal vor)

¡ eine weitere Invertierungsliste mit dem Sekundärschlüssel Miller und den Primärschlüsseln 2003, 2078, 2104 und 2295 (der Nachname Miller kommt in der Tabelle viermal vor)


Isolation-Level (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Isolation-Level

Der Isolation-Level legt fest, ob und wie das Datenbanksystem Sperren für Datenbankobjekte implizit setzt und freigibt.

Siehe auch:

Konzepte des Datenbanksystems

· Isolation-Level

· Sperren für Datenbankobjekte


J (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation J


Java (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Java

Mit dem MaxDB JDBC-Treiber und den MaxDB Java-Klassen können Sie MaxDB-Datenbankinstanzen in Java-Anwendungen einbinden.

Siehe auch:

Strukturlink Java-Handbuch

Konzepte des Datenbanksystems, Schnittstellen


JDBC (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation JDBC

Um aus einer Java-Anwendung mit SQL-Anweisungen über JDBC auf eine MaxDB-Datenbankinstanz zuzugreifen, können Sie den MaxDB JDBC-Treiber verwenden.

Siehe auch:

Java-Handbuch, Strukturlink JDBC-Treiber


Join (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Join

Ein Join ist eine SQL-Anweisung, die mehrere Tabellen miteinander verknüpft. Als Ergebnis entsteht eine Join-Tabelle.

Siehe auch:

Konzepte des Datenbanksystems, Joins

SQL-Tutorial, Strukturlink Joins: Informationen aus mehreren Tabellen

SQL-Referenzhandbuch, Join-Prädikat


K (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation K


Kern (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kern

Der Kern ist der zentrale Teil des Datenbanksystems. Der Kern verwaltet den Zugriff auf die dauerhaft abgelegten Daten einer Datenbankinstanz und bearbeitet die SQL-Anfragen bzw. bei liveCache-Datenbankinstanzen die OMS-Prozeduren.

Um eine Datenbankinstanz zu starten, wird der Kern des Datenbanksystems unter Angabe des Datenbanknamens gestartet. Im laufenden Betrieb gehören mehrere Betriebssystem-Threads zum Kern.

Das Datenbanksystem wird mit mehreren unterschiedlichen Kernvarianten ausgeliefert.

Siehe auch:

Konzepte des Datenbanksystems,

· Prozessstruktur

· Architektur der Datenbankwerkzeuge


Kernprotokoll (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kernprotokoll

Das Kernprotokoll enthält alle Meldungen des Kerns.

Siehe auch:

Konzepte des Datenbanksystems, Protokolldateien


Kernvariante (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kernvariante

Kernvarianten sind unterschiedliche Varianten des Kerns des Datenbanksystems. Sie unterscheiden sich darin, welche Protokollierungen und Laufzeitüberprüfungen das Datenbanksystem im Betrieb durchführt.

Sie können beim Starten, Restart, Überführen in den Betriebszustand ADMIN und Überführen in den Betriebszustand ONLINE explizit angeben, welche Kernvariante die Datenbankinstanz verwenden soll.

Folgende Kernvarianten sind verfügbar:

Kernvariante | Eigenschaften
fast | Systemvorschlag Schnellste Variante des Kerns, es erfolgen nur minimale Protokollierungen und Laufzeitprüfungen.
slow | Variante des Kerns, bei der sehr umfangreiche Protokollierungen und Laufzeitprüfungen erfolgen.

Verwenden Sie die Kernvariante slow nicht im Produktivbetrieb. Diese Kernvariante ist wegen der zusätzlichen Protokollierungen und Laufzeitüberprüfungen sehr viel langsamer als die Kernvariante fast und sollte nur vom Support eingesetzt werden.

Siehe auch:

Database Manager CLI, Strukturlink db_speed


KNLDIAG (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation KNLDIAG

siehe Kernprotokoll


Kommandomodus (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kommandomodus

Der Kommandomodus ist ein Betriebsmodus von Kommandozeilenprogrammen.


Kommandomonitor (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kommandomonitor

nur in SAP-Systemen verfügbar

Mit dem Kommandomonitor können Sie langlaufende SQL-Anweisungen analysieren und Engpässe identifizieren.

Siehe auch:

Datenbankverwaltung im CCMS, Strukturlink Kommandomonitor


Kommunikationsserver (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kommunikationsserver

siehe X-Server


Komponentengruppe (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Komponentengruppe

Sie können bei der Installation der Datenbanksoftware Komponentengruppen auswählen. Komponentengruppen sind Zusammenstellungen einzelner Softwarekomponenten.

Siehe auch:

Installationshandbuch, Strukturlink Komponentengruppen


Konfiguration (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Konfiguration

Beim Anlegen einer neuen Datenbankinstanz legen Sie die Eigenschaften der Datenbankinstanz (Konfiguration) fest. Später können Sie die Konfiguration anpassen, indem Sie die Werte von Datenbankparametern ändern.

Siehe auch:

Konzepte des Datenbanksystems,

● Anlegen und Konfigurieren einer Datenbankinstanz

● Datenbankparameter


Konfigurationsdatei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Konfigurationsdatei

Datenbanksystem und Datenbankwerkzeuge haben mehrere Konfigurationsdateien, in denen grundlegende Eigenschaften festgelegt sind.

Siehe auch:

Konzepte des Datenbanksystems, Konfigurationsdateien


Konfigurationsverzeichnis (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Konfigurationsverzeichnis

Im Konfigurationsverzeichnis einer Datenbankinstanz legt das Datenbanksystem Konfigurationsdateien für Datenbankparameter und Datenbankwerkzeuge und Dateien für die Benutzerautorisierung ab.

Das Konfigurationsverzeichnis wird bei der Installation der Datenbanksoftware angelegt. Der Vorschlagswert ist <independent_data_path>\config.

Siehe auch:

Konzepte des Datenbanksystems

· Konfigurationsdateien


Konsistente Sicht (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Konsistente Sicht

Konsistente Sichten werden nur von SAP liveCache-Datenbankinstanzen verwendet.

Das Datenbanksystem verwendet konsistente Sichten, um Lesezugriffe auf ein Objekt unabhängig von Änderungen an den Daten durch andere Transaktionen zu gewährleisten. Eine konsistente Sicht kann sich über eine Transaktion oder mehrere Transaktionen (OMS-Version) erstrecken.

Wenn ein Benutzer eine Transaktion eröffnet, dann behält er bis zum Ende der Transaktion seine Sicht auf die Daten. Zwischenzeitliche Änderungen an den Daten durch andere Transaktionen ändern die Sicht des ersten Benutzers auf die Daten nicht.

Beim ersten Zugriff auf ein Objekt innerhalb einer konsistenten Sicht kopiert das Datenbanksystem diese Objektdaten in den OMS-Heap. Wenn verschiedene konsistente Sichten auf die gleichen Daten zugreifen, dann kopiert das Datenbanksystem für jede konsistente Sicht die entsprechenden Daten in einen eigenen Bereich des OMS-Heap. Wenn eine konsistente Sicht beendet wird, löscht das Datenbanksystem die entsprechenden Daten im OMS-Heap.

Siehe auch:

Konzepte des Datenbanksystems,

· History-Verwaltung

· Beispiel: Konsistente Sicht

Datenbankverwaltung im CCMS, SAP liveCache-Technologie

· Strukturlink OMS-Versionen

· Strukturlink OMS-Versionen überwachen


Kontrollstruktur (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kontrollstruktur

In Datenbankprozeduren, Datenbankfunktionen und Datenbanktriggern können Sie verschiedene Kontrollstrukturen verwenden, wie z. B. Schleifen oder Verzweigungen.

Siehe auch:

SQL-Referenzhandbuch, Routine (routine)

SQL-Tutorial,

● Strukturlink Datenbankprozeduren

● Strukturlink Datenbankfunktionen

● Strukturlink Datenbanktrigger


Kosten (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kosten

Die Kosten einer SQL-Anweisung sind die Ressourcen für I/O-Vorgänge, die das System für das Aufbereiten und Lesen des Ergebnisses der SQL-Anweisung benötigt.

Siehe auch:

SQL-Optimierer, Kostenermittlung


Kritischer Abschnitt (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kritischer Abschnitt

Ein kritischer Abschnitt ist ein Abschnitt des Arbeitsspeichers, für den das Datenbanksystem konkurrierende Zugriffe von Tasks über spezielle Semaphoren (Regionen, Reader-Writer-Locks) synchronisiert.

Siehe auch:

Konzepte des Datenbanksystems, Arbeitsspeicherbereiche

Datenbankverwaltung im CCMS: Strukturlink Kritische Abschnitte


L (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation L


Laden (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Laden

siehe Importieren


Lesesperre (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Lesesperre

Eine Lesesperre erlaubt anderen Transaktionen das Lesen, jedoch nicht das Ändern eines Datenbankobjekts.

Siehe auch:

Konzepte des Datenbanksystems, Lesesperre


liveCache (SAP liveCache-Technologie) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation liveCache (SAP liveCache-Technologie)

Die liveCache-Technologie können Sie nur in SAP-Anwendungen einsetzen.

Die SAP liveCache-Technologie ist eine objektbasierte Erweiterung des MaxDB-Datenbanksystems, die für das Verwalten komplexer Objekte entwickelt wurde (z. B. in logistischen Lösungen wie SAP SCM/APO).

Für solche Lösungen müssen große Mengen von Daten ständig erreichbar und änderbar sein. Mit der SAP liveCache-Technologie können Datenstrukturen und Datenströme (wie Netzwerke und Beziehungen) leichter und effektiver abgebildet werden.

Im Gegensatz zu MaxDB befinden sich bei einer SAP liveCache-Datenbankinstanz bei optimaler Konfiguration alle Daten, auf die das Datenbanksystem zugreifen muss, im Arbeitsspeicher.

Siehe auch:

Dokumentation Strukturlink Datenbankverwaltung im CCMS: SAP liveCache-Technologie


Load-Balancing (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Load-Balancing

Das Datenbanksystem führt intern ein Load-Balancing durch, um die Tasks optimal auf die zur Verfügung stehenden User-Kernel-Threads zu verteilen.

Siehe auch:

Konzepte des Datenbanksystems, Load-Balancing


Loader (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Loader

Der Loader ist ein Datenbankwerkzeug zum Exportieren und Importieren von Daten (Entladen und Laden).

Mit dem Loader exportierte Daten können Sie nicht zum Wiederherstellen einer Datenbankinstanz verwenden, weil sie unter Umständen einen inkonsistenten Datenbankzustand repräsentierte. Exportierte Daten können Datensicherungen daher nicht ersetzen.

Siehe auch:

Dokumentation zum Strukturlink Loader

Konzepte des Datenbanksystems, Datenbankwerkzeuge


Loader-Server (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Loader-Server

Der Loader-Server ist der Server-Teil des Datenbankwerkzeugs Loader. Er stellt die Verbindung zwischen dem Client-Teil des Loaders und der Datenbankinstanz her.

Siehe auch:

Dokumentation zum Strukturlink Loader

Konzepte des Datenbanksystems, Architektur der Datenbankwerkzeuge


LOB (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation LOB

siehe LONG-Wert


Log-Bereich (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Bereich

Alle Log-Volumes einer Datenbankinstanz zusammen werden als Log-Bereich bezeichnet. In den Log-Bereich schreibt das Datenbanksystem die Redo-Log-Einträge von Transaktionen.

Siehe auch:

Konzepte des Datenbanksystems,

● Volumes (permanenter Speicher)

● Protokollierung von Datenänderungen (Logging)

Database Manager GUI, Strukturlink Log-Bereichs-Informationen anzeigen

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Log-Bereich überwachen

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Log-Bereich überwachen


Log-Einstellung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Einstellung

Mit den Log-Einstellungen konfigurieren Sie die wichtigsten Eigenschaften des Loggings von Transaktionen.

Es gibt folgende Log-Einstellungen:

● Log-Modus

● Überschreibmodus für den Log-Bereich

● Ausschalten der Redo-Log-Verwaltung

Siehe auch:

Konzepte des Datenbanksystems,

● Log-Einstellungen

● Protokollierung von Datenänderungen (Logging)

Database Manager GUI, Strukturlink Log-Einstellungen ändern


Log-Eintrag (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Eintrag

Das Datenbanksystem protokolliert alle Transaktionen, die Daten in der Datenbank ändern, in Log-Einträgen. Dabei unterscheidet es Undo-Log-Einträge (Before-Images) und Redo-Log-Einträge (After-Images).

Das Datenbanksystem benötigt die Log-Einträge, wenn es SQL-Anweisungen rückgängig machen oder nach einem Systemausfall wiederholen muss (Transaktionskonsistenz).

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Log-Leser (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Leser

Der Log-Leser ermittelt alle Informationen, die das Datenbanksystem für einen Restart oder ein Wiederherstellen der Datenbankinstanz benötigt, und erstellt die notwendigen Dateien und Listen zum Wiederholen der Transaktionen. Der Log-Leser ist eine Server-Task und läuft im User-Kernel-Thread.

Siehe auch:

Konzepte des Datenbanksystems,

● Protokollierung von Datenänderungen (Logging)

● Übersicht der Tasks


Log-Modus (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Modus

Der Log-Modus ist eine Log-Einstellung. Mit dem Log-Modus konfigurieren Sie, ob das Datenbanksystem den Log-Bereich spiegelt.

Wir empfehlen, diese Einstellung nur zu verwenden, wenn Sie den Log-Bereich nicht hardwarebasiert spiegeln können.

Siehe auch:

Konzepte des Datenbanksystems, Log-Einstellungen

Database Manager GUI, Strukturlink Log-Einstellungen ändern

Database Manager CLI, Strukturlink param_addvolume


Log-Segment (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Segment

Der Log-Bereich einer Datenbankinstanz ist in logische Log-Segmente unterteilt.

Siehe auch:

Konzepte des Datenbanksystems

● Volumes (permanenter Speicher)

● Log-Einträge sichern


Log-Seite (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Seite

Log-Seiten sind die Speichereinheiten in den Log-Warteschlangen (im Arbeitsspeicher) und im Log-Bereich (permanenter Speicher), in die das Datenbanksystem die Log-Einträge schreibt.

Eine Log-Seite ist 8 KB groß.

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Log-Sicherung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Sicherung

Bei einer Log-Sicherung sichern Sie mit dem Datenbankwerkzeug Database Manager alle Redo-Log-Einträge, die das Datenbanksystem seit der letzten Log-Sicherung neu in den Log-Bereich geschrieben hat, auf einen Datenträger. Nachdem Sie die Redo-Log-Einträge gesichert haben, kann das Datenbanksystem sie im Log-Bereich wieder überschreiben.

Sie können die Redo-Log-Einträge auch automatisch sichern lassen (automatische Log-Sicherung ein-/ausschalten).

Siehe auch:

Konzepte des Datenbanksystems, Log-Einträge sichern

Database Manager GUI, Strukturlink Backup Wizard

Database Manager CLI, Strukturlink Sichern und Wiederherstellen von Datenbankinstanzen

Datenbankverwaltung im CCMS, Strukturlink Log-Sicherungen einplanen


Log-Volume (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Volume

Die Log-Volumes sind der permanente Speicher, in denen das Datenbanksystem die Redo-Log-Einträge speichert. Alle Log-Volumes zusammen bilden den Log-Bereich.

Siehe auch:

Konzepte des Datenbanksystems, Volumes (permanenter Speicher)

Database Manager GUI, Strukturlink Volumes anlegen, anzeigen und löschen, Strukturlink Volume-Eigenschaften ändern

Database Manager CLI, Strukturlink db_addvolume

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Volumes

Datenbankverwaltung im CCMS, SAP liveCache-Technologie, Strukturlink Volumes


Log-Warteschlange (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Warteschlange

Die Log-Warteschlangen sind Arbeitsspeicherbereiche, die das Datenbanksystem für Redo-Log-Einträge verwendet. Aus den Log-Warteschlangen schreibt das Datenbanksystem die Redo-Log-Einträge später in den Log-Bereich.

Sie können die Anzahl der Log-Warteschlangen mit dem speziellen Datenbankparameter LOG_QUEUE_COUNT, die Größe einer Log-Warteschlange mit LOG_IO_QUEUE konfigurieren.

Siehe auch:

Konzepte des Datenbanksystems,

● Arbeitsspeicherbereiche

● Spezielle Datenbankparameter


Log-Writer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Log-Writer

Der Log-Writer schreibt die Redo-Log-Einträge aus den Log-Warteschlangen in den Log-Bereich. Der Log-Writer ist eine Task im User-Kernel-Thread.

Siehe auch:

Konzepte des Datenbanksystems

● Protokollierung von Datenänderungen (Logging)

● Datenspeicherung

● Übersicht der Tasks


Logging (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Logging

Das Datenbanksystem protokolliert alle Transaktionen, die Daten ändern, indem es Log-Einträge schreibt.

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


LONG-Wert (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation LONG-Wert

LONG ist ein spezieller Datentyp, mit dem eine alphanumerische Spalte beliebiger Länge definiert wird. In LONG-Spalten können sehr lange Zeichenketten und binäre Informationen gespeichert werden: ein LONG-Wert kann entweder ein BLOB (Binary Large Object) oder ein CLOB (Character Large Object) sein.

Siehe auch:

SQL-Referenzhandbuch, LONG [VARCHAR]

Loader, Strukturlink Exportieren und Importieren von LONG-Werten


M (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation M


Mailing-Liste (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Mailing-Liste

Open-Source-Benutzer können über die MaxDB-Mailing-Liste Hilfe zum Datenbanksystem erhalten. Sie finden die Mailing-Liste unter folgender Adresse:

lists.mysql.com/maxdb

Siehe auch:

Konzepte des Datenbanksystems, Support


Mapchar-Set (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Mapchar-Set

siehe Sprachunterstützung


Master-Instanz (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Master-Instanz

...

a. In einem Hot-Standby-System:

Die Master-Instanz ist diejenige Datenbankinstanz im Cluster, die im Betriebszustand ONLINE ist und mit der die Benutzer arbeiten. Wenn die Master-Instanz ausfällt, wird eine der Standby-Instanzen im Cluster zur neuen Master-Instanz.

Siehe auch:

Konzepte des Datenbanksystems, Hot-Standby

Database Manager GUI, Strukturlink Master-Instanz einrichten (Hot-Standby)

Database Manager CLI, Strukturlink hss_enable

b. Bei der Synchronisierung mehrerer Datenbankinstanzen mit dem MaxDB Synchronization Manager:

Die Master-Datenbankinstanz ist die Datenbankinstanz, mit der die Client-Datenbankinstanz ihre Daten synchronisieren. Die Daten der Client-Datenbankinstanzen sind in der Regel eine Teilmenge der Daten der Master-Datenbankinstanz.

Siehe auch: Dokumentation zum Strukturlink Synchronization Manager


MaxDB (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation MaxDB

siehe OLTP (MaxDB)


Merge (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Merge

Bei einem Merge vereinigt das System die Primärschlüssellisten eines Index zu einer einzigen Primärschlüsselliste, um diese Liste danach sortiert lesen zu können.

Siehe auch:

Dokumentation zum SQL-Optimierer


Message-Server (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Message-Server

Den Message-Server benötigen Sie, um mehrere Datenbankinstanzen mit Hilfe des Synchronization Managers zu synchronisieren.

Siehe auch:

Synchronization Manager, Strukturlink Message-Server


Migration (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Migration

siehe Upgrade


Multi-Prozessor-Konfiguration (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Multi-Prozessor-Konfiguration

Um Rechner mit mehreren Prozessoren optimal ausnutzen zu können, unterstützt das Datenbanksystem ein konfigurierbares Tasking. Das Ziel dieses Tasking ist es, eine möglichst große Anzahl von Datenbanksitzungen mit einer minimalen Anzahl von Betriebssystem-Threads zu unterstützen.

Sie können das Tasking mit den beiden allgemeinen Datenbankparametern MAXUSERTASKS und MAXCPU konfigurieren.

Siehe auch:

Konzepte des Datenbanksystems, Allgemeine Datenbankparameter


N (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation N


Namenskonventionen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Namenskonventionen

Einige Namen im Datenbanksystem können Sie nicht frei wählen, sondern müssen sich an die entsprechenden Namenskonventionen halten.

Siehe auch:

Konzepte des Datenbanksystems,

· Konventionen für Datenbanknamen

· Konventionen für Benutzernamen und Kennwörter


Netzwerk (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Netzwerk

MaxDB-Datenbankinstanzen, -Werkzeuge und -Schnittstellen können auf unterschiedlichen Rechnern in einem Netzwerk installiert sein.

Siehe auch:

Konzepte des Datenbanksystems,

· Netzwerkkommunikation

· Technische Systemlandschaft


O (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation O


ODBC (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation ODBC

Um über ODBC auf das Datenbanksystem MaxDB zuzugreifen, verwenden Sie den MaxDB-ODBC-Treiber.

Siehe auch:

Strukturlink ODBC-Handbuch


OLTP (MaxDB) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation OLTP (MaxDB)

MaxDB ist ein relationales Datenbanksystem, das für den OLTP-Betrieb (Online Transaction Processing) entwickelt wurde.

Der Datenbankinstanztyp OLTP ist für die schnelle Bearbeitung einzelner Transaktionen mit einer hohen Anzahl von Benutzern und großen Datenbanken optimiert.


OMS (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation OMS

OMS (Object Management System) ist eine Art der Datenverwaltung.

Nur SAP liveCache-Datenbankinstanzen verwenden OMS.

Ein großer Teil der Daten einer SAP liveCache-Datenbankinstanz wird in Objekten verwaltet. Diese Objektdaten werden als OMS-Daten bezeichnet. OMS-Daten werden in Containern verwaltet, die als Objektspeicher exakt einer persistenten C++-Klasse des Objekttyps zugeordnet sind.

Die Bearbeitung der OMS-Daten erfolgt in der OMS-Zwischenschicht. Anwendungslogik können Sie mit DB-Prozeduren in den liveCache-Kern einbinden. Dadurch entfällt ein erheblicher Teil des Aufwands für die Kommunikation und den Datentransfer.

Die OMS-Datenseiten befinden sich im Data-Cache.

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Klassencontainer


OMS-Heap (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation OMS-Heap

Der OMS-Heap wird nur von SAP liveCache-Datenbankinstanzen verwendet.

SAP liveCache-Datenbankinstanzen verwenden neben dem Data-Cache und dem Converter im Betrieb zusätzlich einen privaten OMS-Cache im Arbeitsspeicher, den OMS-Heap. Im OMS-Heap befinden sich lokale Kopien der OMS-Daten und lokale Anwendungsdaten.

Siehe auch:

Konzepte des Datenbanksystems,

● Arbeitsspeicherbereiche

● liveCache-Datenbankparameter

Datenbankverwaltung im CCMS: SAP liveCache-Technologie

● Strukturlink Heap-Verbrauch

● Strukturlink Hauptspeicherbereiche überwachen


OMS-Version (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation OMS-Version

OMS-Versionen werden nur von SAP liveCache-Datenbankinstanzen verwendet.

Eine OMS-Version basiert auf einer konsistenten Sicht, repräsentiert also den zu ihrem Startzeitpunkt gültigen konsistenten Zustand der SAP liveCache-Datenbankinstanz. Eine OMS-Version wird durch die Anwendung erzeugt und kann sich über mehrere Transaktionen erstrecken. Sie definiert einen Datenraum, in dem unabhängig von konkurrierenden Anwendungen Transaktionen mit Objektänderungen durchgeführt werden können. Zu einem bestimmten Zeitpunkt kann eine OMS-Version stets nur innerhalb einer Datenbanksitzung bearbeitet werden.

Eine OMS-Version kann jederzeit im Object Management System (OMS) aktiviert werden. Alle darauffolgenden OMS-Operationen beziehen sich auf die aktivierte OMS-Version. Insbesondere können auch Änderungen vorgenommen werden, die jedoch nur innerhalb der OMS-Version sichtbar sind.

Für jede OMS-Version werden die Daten beim Lesen in den OMS-Heap kopiert. Die Anwendung entscheidet, ob Änderungen an Objekten innerhalb der OMS-Version in den Ist-Stand der Anwendung übernommen werden. Änderungen an den Daten einer OMS-Version werden ohne Aufforderung der Anwendung in keiner Form im Data-Cache gespeichert. Alle nicht von der Anwendung in den Ist-Stand übernommenen Daten gehen daher beim Löschen einer OMS-Version verloren.

Nach einem Restart sind die vorher existierenden OMS-Versionen nicht mehr verfügbar. Sie wurden implizit gelöscht.

Nach Schließen einer OMS-Version (Beenden der Datenbanksitzung) können die Daten im Fall von Speicherengpässen aus dem OMS-Heap in den Data-Cache verdrängt werden.

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie,

· Strukturlink OMS-Versionen

· Strukturlink OMS-Versionen überwachen


Open-Source-Entwicklung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Open-Source-Entwicklung

Open-Source-Benutzer können den Quelltext der Datenbanksoftware selbst übersetzen.

Beachten Sie die Lizenzbedingungen unter www.mysql.com/company/legal/licensing

Siehe auch:

Konzepte des Datenbanksystems, Open-Source-Entwicklung der Datenbanksoftware

Dokumentation Strukturlink Entwicklungsumgebung


Optimierer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Optimierer

siehe SQL-Optimierer


Optimistische Sperre (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Optimistische Sperre

Das Datenbanksystem protokolliert, ob das Datenbankobjekt, für das Sie die optimistische Sperre gesetzt haben, seitdem geändert wurde.

Siehe auch:

Konzepte des Datenbanksystems, Optimistische Sperre

SQL-Referenzhandbuch, LOCK-Anweisung (lock_statement)


P (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation P


Pager (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Pager

Pager schreiben bei jedem Savepoint die Daten vom Data-Cache in den Datenbereich. Wenn sehr viele Daten geändert wurden, also die Pager beim nächsten Savepoint sehr viele Seiten schreiben müssten, dann schreiben sie bereits vor dem nächsten Savepoint Daten vom Data-Cache in den Datenbereich.

Bei Starten der Datenbankinstanz lesen die Pager den Converter in den Arbeitsspeicher ein.

Wenn Sie ein Data-Volume entfernen, lesen die Pager die Daten von dem zu entfernenden Data-Volume und schreiben sie anschließend auf die verbleibenden Data-Volumes.

Pager sind Tasks im User-Kernel-Thread.

Siehe auch:

Konzepte des Datenbanksystems,

● Datenspeicherung

● Übersicht der Tasks


Parallele Sicherung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Parallele Sicherung

Um das Sichern zu beschleunigen, können Sie parallel auf mehrere Datenträger sichern.

Siehe auch:

Database Manager GUI, Strukturlink Sichern auf eine Gruppe paralleler Datenträger

Database Manager CLI, Strukturlink medium_put

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Sicherungsvorlagen

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Sicherungsvorlagen


Parameter (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Parameter

siehe

· Datenbankparameter

· Parameter in SQL-Anweisungen


Parameter in SQL-Anweisungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Parameter in SQL-Anweisungen

Host-Variablen

SQL-Anweisungen für das Datenbanksystem können Sie in Programmiersprachen einbetten. Werte, die die Programme abfragen oder speichern sollen, können Sie innerhalb der SQL-Anweisungen mit Hilfe von Parametern übergeben. Die Parameter deklarieren Sie innerhalb des einbettenden Programms als Variablen (Host-Variablen).

In der Programmiersprache wird bei der Deklaration von Host-Variablen deren Datentyp festgelegt. Werte von Host-Variablen werden (falls möglich) implizit vom Programmiersprachen-Datentyp in den Datenbanksystem-Datentyp konvertiert und umgekehrt.

Jeder Parameter kann mit einer Indikatorvariablen kombiniert sein, die Auskunft über Unregelmäßigkeiten gibt, die bei der Zuweisung aufgetreten sind, z. B. unterschiedliche Länge von Wert und Parameter, NULL-Wert, Spezial-NULL-Wert usw. Zur Übergabe von NULL-Werten und Spezial-NULL-Werten sind Indikatorvariablen zwingend erforderlich. Indikatorvariablen werden innerhalb des einbettenden Programms als Variablen definiert.

Siehe

SQL-Referenzhandbuch, Parametername

Konzepte des Datenbanksystems, Schnittstellen

Parameter in SQL Studio

Parameter in SQL-Anweisungen sind Platzhalter für variable Werte. Beim Ausführen einer SQL-Anweisung, die Parameter enthält, fordert das System den Benutzer auf, Werte für die Parameter einzugeben.

Siehe SQL Studio, Strukturlink Parametrisieren von SQL-Anweisungen


Parameterdatei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Parameterdatei

Die Parameterdatei ist eine Binärdatei, die die Werte der Datenbankparameter für die Datenbankinstanz enthält.

Siehe auch:

Konzepte des Datenbanksystems, Konfigurationsdateien


Performance (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Performance

Um SQL-Anweisungen möglichst schnell abzuarbeiten, formt das Datenbanksystem sie intern um. Der SQL-Optimierer wählt dann die beste Zugriffstrategie aus.

Die Performance Ihrer Datenbankinstanz wird wesentlich davon beeinflusst, wie Sie die Datenbankinstanz konfigurieren.

Siehe auch:

Konzepte des Datenbanksystems, Performance

SAP-Hinweis 819641


Perl (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Perl

Die Module SAP::DBTech::dbm und SAP::DBTech::loader dienen dazu, mit Perl-Skripten auf die Datenbankwerkzeuge Database Manager und Loader zuzugreifen.

Siehe auch:

Strukturlink Perl-Handbuch


PHP (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation PHP

Mit der MaxDB PHP-Erweiterung können Sie können Sie mit PHP auf MaxDB-Datenbankinstanzen zugreifen.

Siehe auch:

Strukturlink PHP-Handbuch


Port (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Port

Ein Port ist der Endpunkt einer logischen Verbindung. Diensten und Serverprogrammen können Portnummern zugeordnet werden. MaxDB verwendet Portnummern für den MaxDB X-Server und den Synchronization Manager.

Siehe auch:

X-Server, Strukturlink Ports und Protokolle des X-Servers

Synchronization Manager, Strukturlink Synchronisierungs-Ports


Prädikat (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Prädikat

Ein Prädikat ist eine Vergleichsoperation, deren Ergebnis wahr oder falsch ist. Sie können Prädikate in einer SQL-Anweisung in der WHERE-Bedingung verwenden.

Siehe auch:

SQL-Referenzhandbuch, Prädikat (predicate)

SQL-Optimierer, Suchbedingungen


Precompiler (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Precompiler

siehe SQLDBC

Bis einschließlich Datenbankversion 7.5 diente der Precompiler als Schnittstelle zwischen MaxDB-Datenbankinstanzen und C/C++-Anwendungsprogrammen. Ab Datenbankversion 7.6 ersetzt die SQLDBC-Schnittstelle den Precompiler.


Prepared Statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Prepared Statement

Prepared Statements werden bei der Entwicklung von Datenbankanwendungen verwendet. Sie ermöglichen es, in Methoden der für die Datenbankanwendung gewählten Programmiersprache SQL-Anweisungen mit Platzhaltern zu verwenden.

Platzhalter können nur für Werte stehen, nicht jedoch für Namen von Datenbankobjekten wie beispielsweise den Namen einer Tabelle. Als Platzhalter können Sie ein Fragezeichen ? oder einen Variablennamen :input verwenden. Wenn Sie mehrmals denselben Variablennamen verwenden, dann entspricht dieser mehreren Parametern.

Prepared Statements bieten gegenüber einfachen SQL-Anweisungen unter anderem die folgenden Vorteile:

· Sie sind effizienter, weil das Datenbanksystem sie nur einmal parsen muss, auch wenn sie mehrfach verwendet werden (siehe hared SQL).

· Sie sind sicherer, weil sie die SQL-Logik und die vom Benutzer eingegebenen Daten trennen und so die Gefahr verringern, dass ein Benutzer absichtlich ungültige Werte eingibt (SQL Injection). Siehe MaxDB Sicherheitsleitfaden, Benutzereingaben in SQL-Anweisungen überprüfen

Für die folgenden MaxDB-Schnittstellen können Sie Prepared Statements verwenden:

MaxDB-Schnittstellen: PreparedStatements

Schnittstelle | Implementierung
JDBC | Klasse PreparedStatement
ODBC | Methode SQLPrepare
SQLDBC | Klasse SQLDBC_PrepareStatement
PHP | maxdb_prepare
Perl | prepare
Python | Strukturlink Methode prepare, Strukturlink Klasse SAPDB_Prepared

Beispiel

Prepared Statement für die MaxDB SQLDBC-Schnittstelle:

SQLDBC_PrepareStatement *stmt = conn->createPreparedStatement();

SQLDBC_Retcode rc = stmt->prepare("SELECT * FROM CUSTOMER");

if (rc != SQLDBC_OK) {

// Handle error ...

}

rc = stmt->execute();

if (rc != SQLDBC_OK) {

// Handle error ...

}


Primärschlüssel (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Primärschlüssel

Jede Datenbanktabelle hat einen Primärschlüssel (Primärindex). Der Primärschlüssel wird entweder vom Benutzer definiert oder vom System generiert. Ein benutzerdefinierter Primärschlüssel kann aus einer oder mehreren Spalten bestehen. Der Primärschlüssel muss für jede Zeile der Tabelle einen eindeutigen Wert haben.

Siehe auch:

SQL-Referenzhandbuch, Schlüsseldefinition (key_definition)

SQL-Tutorial, Strukturlink Primärschlüssel


Privileg (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Privileg

Ein Privileg legt die für ein Datenbankobjekt erlaubten SQL-Anweisungen fest.

Benutzer dürfen nur SQL-Anweisungen auf Datenbankobjekten ausführen, für die sie Privilegien erhalten haben. Wenn ein Benutzer ein Datenbankobjekt erzeugt, wird er dadurch automatisch Eigentümer des Datenbankobjekts und erhält für dieses Datenbankobjekt alle Privilegien.

Der Eigentümer eines Objektes kann Privilegien für dieses Datenbankobjekt an andere Benutzer vergeben; implizit vergibt das Datenbanksystem keine Privilegien. Andere Benutzer können Privilegien für ein Datenbankobjekt nur dann vergeben, wenn sie selbst diese Privilegien erhalten haben und die Erlaubnis besitzen, diese Privilegien weiterzuvergeben.

Siehe auch:

SQL-Referenzhandbuch:

● Privilegien: Überblick

● GRANT-Anweisung (grant_statement)

● REVOKE-Anweisung (revoke_statement)


Programmierschnittstelle (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Programmierschnittstelle

siehe Schnittstelle


Protokolldatei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Protokolldatei

Das Datenbanksystem schreibt Informationen zu Aktionen und Fehlern in Protokolldateien.

Siehe auch:

Konzepte des Datenbanksystems, Protokolldateien


Prozess (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Prozess

Zum Datenbanksystem MaxDB gehören mehrere Prozesse.

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Prozesse


PTS (Problem Tracking System) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation PTS (Problem Tracking System)

Fehler- und Problemmeldungen für MaxDB werden intern im PTS (Problem Tracking System) erfasst. Benutzer können die Bearbeitung von Meldungen über die Webschnittstelle Web PTS verfolgen.

Siehe auch:

Konzepte des Datenbanksystems, Problemmeldungen mit Web PTS verfolgen


Python (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Python

Die Module sdb.dbm, sdb.loader und sdb.sql dienen dazu, mit Python-Skripten auf MaxDB-Datenbankinstanzen und die Datenbankwerkzeuge Database Manager und Loader zuzugreifen.

Siehe auch:

Strukturlink Python-Handbuch


Q (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Q


Query Tool (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Query Tool

Als Query Tools werden diejenigen Datenbankwerkzeuge bezeichnet, mit denen Sie auf Daten und den Datenbankkatalog zugreifen, SQL-Anfragen erstellen und ausführen und Datenbankobjekte und Datenbankbenutzer anlegen und verwalten können.

Folgende Query Tools sind verfügbar:

· Strukturlink SQL Studio

· Strukturlink SQLCLI

· Strukturlink Web SQL Studio

Siehe auch:

Konzepte des Datenbanksystems, Datenbankwerkzeuge


R (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation R


Raw-Device (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Raw-Device

Ein Raw-Device ist eine Festplatte/Teil einer Festplatte, die nicht vom Betriebssystem verwaltet wird. Auf UNIX/Linux können Sie für Datenbankinstanzen Volumes vom Typ Raw Device konfigurieren.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankinstanz planen

Database Manager GUI, Strukturlink Volumes anlegen, anzeigen und löschen

Database Manager CLI, Strukturlink db_addvolume


Reader-Writer-Lock (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Reader-Writer-Lock

Reader-Writer-Locks sind spezielle Semaphoren, mit denen das Datenbanksystem exklusive und nicht-exklusive Task-Zugriffe auf kritische Abschnitte im Arbeitsspeicher synchronisiert.

Siehe auch:

Konzepte des Datenbanksystems, Arbeitsspeicherbereiche


Redo-Liste (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Redo-Liste

Die Redo-Liste ist eine datenbankinterne Liste von Transaktionen, die vom Redo-Log-Manager angelegt wird. Sie befindet sich im Arbeitsspeicher.

Die Redo-Liste ergänzt die Transaktionsliste. In der Redo-Liste sind diejenigen Transaktionen und die Reihenfolge ihrer Ausführung aufgeführt, die das Datenbanksystem nach dem letzten Savepoint gestartet hat und die es bei einem Restart oder einem Wiederherstellen der Datenbankinstanz wiederholen muss.

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Redo-Log-Datei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Redo-Log-Datei

Bei einem Restart oder einem Wiederherstellen der Datenbankinstanz schreibt das Datenbanksystem alle Redo-Log-Einträge von Transaktionen, die beim letzten Savepoint noch nicht beendet waren und die das Datenbanksystem wiederholen muss, in eine Redo-Log-Datei.

Redo-Log-Dateien sind datenbankinterne Dateien und befinden sich im Datenbereich.

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Redo-Log-Eintrag (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Redo-Log-Eintrag

In Redo-Log-Einträgen (After-Images) protokolliert das Datenbanksystem Datenänderungen. Das Datenbanksystem verwendet die Redo-Log-Einträge, wenn es eine abgeschlossene Transaktion wiederholen muss (z. B. nach einem Systemausfall).

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Redo-Log-Manager (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Redo-Log-Manager

Der Redo-Log-Manager sorgt bei einem Restart oder beim Wiederherstellen dafür, dass die erforderlichen Redo-Log-Einträge zur Verfügung gestellt und in der zeitlich korrekten Reihenfolge abgearbeitet werden. Er startet den Log-Leser und die Redo-Tasks.

Der Redo-Log-Manager ist eine Server-Task und läuft im User-Kernel-Thread.

Siehe auch:

Konzepte des Datenbanksystems,

● Protokollierung von Datenänderungen (Logging)

● Übersicht der Tasks


Redo-Log-Verwaltung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Redo-Log-Verwaltung

Die Redo-Log-Verwaltung verwaltet die Redo-Log-Einträge. Sie können die Redo-Log-Verwaltung ausschalten.

Schalten Sie die Redo-Log-Verwaltung nur in speziellen Situationen wie z. B. für Tests aus.

Siehe auch:

Konzepte des Datenbanksystems,

● Log-Einstellungen

● Protokollierung von Datenänderungen (Logging)

Database Manager GUI, Strukturlink Log-Einstellungen ändern


Redo-Task (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Redo-Task

Redo-Tasks sind Server-Tasks. Die Redo-Tasks führen bei einem Restart oder einem Wiederherstellen der Datenbankinstanz diejenigen Transaktionen aus, die wiederholt werden müssen.

Siehe auch:

Konzepte des Datenbanksystems,

● Beispiel: Restart

● Übersicht der Tasks


Region (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Region

Eine Region ist eine spezielle Semaphore, mit der das Datenbanksystem exklusive Task-Zugriffe auf einen kritischen Abschnitt im Arbeitsspeicher synchronisiert.

Siehe auch:

Konzepte des Datenbanksystems, Arbeitsspeicherbereiche


Reorganisation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Reorganisation

Eine Reorganisation der Daten ist im Datenbanksystem MaxDB nicht notwendig.

Siehe auch:

Konzepte des Datenbanksystems, Datenspeicherung


Replikation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Replikation

Replikation bedeutet, dass Sie mehrere Duplikate einer Datenbankinstanz anlegen, die in regelmäßigen Abständen aktualisiert werden.

Siehe auch:

Konzepte des Datenbanksystems, Replikation und High-Availability


Replikationseinheit (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Replikationseinheit

Replikationseinheiten benötigen Sie bei der Synchronisation der Daten mehrerer Datenbankinstanzen mit dem Synchronization Manager. In den Replikationseinheiten definieren Sie, welche Tabellen auf welche Weise miteinander synchronisiert werden.

Siehe auch:

Synchronization Manager, Strukturlink Datenmodell


Replikationstabelle (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Replikationstabelle

Replikationstabellen benötigen Sie für bei der Synchronisation mehrerer Datenbankinstanzen mit dem Synchronization Manager. Für jede Master-Tabelle, deren Daten mit Client-Tabellen synchronisiert werden soll, definieren Sie eine Replikationstabelle.

Siehe auch:

Synchronization Manager, Strukturlink Datenmodell


Reserviertes Wort (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Reserviertes Wort

siehe Schlüsselwort


RESOURCE-Benutzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation RESOURCE-Benutzer

RESOURCE-Benutzer sind Datenbankbenutzer, die im Vergleich zu STANDARD-Datenbankbenutzern einige zusätzliche Rechte besitzen. RESOURCE-Benutzer können beispielsweise bestimmte Privilegien an andere Benutzer weitergeben.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankbenutzer


Ressourcenmonitor (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Ressourcenmonitor

nur in SAP-Systemen verfügbar

Mit dem Ressourcenmonitor können Sie den Ressourcenverbrauch der Datenbankinstanz überwachen und teure SQL-Anweisungen identifizieren.

Siehe auch:

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Ressourcenmonitor


Restart (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Restart

Bei einem Restart startet das Datenbanksystem die Datenbankinstanz neu, bringt sie also aus dem Betriebszustand ADMIN oder ONLINE zunächst in den Betriebszustand OFFLINE und von dort in den Betriebszustand ONLINE.

Ein Restart ist beispielsweise in folgenden Situationen notwendig:

● Sie haben einen Datenbankparameter geändert, dessen Änderung erst nach einem Restart wirksam wird.

● Die Datenbankinstanz wurde nicht korrekt gestoppt, weil der Computer durch einen Stromausfall abgeschaltet wurde.

Bei einem Restart verwendet das Datenbanksystem Informationen aus dem letzten Savepoint (letzter in den Volumes gespeicherter konsistenter Zustand der Datenbankinstanz) und die noch in den Volumes gespeicherten Log-Einträge, um die Datenbankinstanz wieder möglichst nahe an den Zustand zu bringen, den Sie zum Zeitpunkt des Überführens in den Betriebszustand OFFLINE hatte.

Ein erfolgreicher Restart setzt voraus, dass die Volumes der Datenbankinstanz unbeschädigt sind. Wenn ein Festplattenschaden vorliegt, dann müssen Sie die Datenbankinstanz wiederherstellen.

Sie können bei einem Restart die Datenbankinstanz auch in einem Zustand starten, den sie zu einem Zeitpunkt in der Vergangenheit hatte.

Bei jedem Starten der Datenbankinstanz wird eine Kopie des Kernprotokolls unter dem Namen erstellt, und das alte Kernprotokoll mit neuen Informationen überschrieben.

Siehe auch:

Konzepte des Datenbanksystems, Beispiel: Restart, Savepoint

Database Manager GUI, Strukturlink Starten der Datenbankinstanz (Restart)

Database Manager CLI, Strukturlink db_restart


Restart-Information (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Restart-Information

Die Restart-Information befindet sich auf der ersten Seite des ersten Data-Volume. Sie enthält alle Informationen, die das Datenbanksystem für einen Restart der Datenbankinstanz benötigt, unter anderem:

● Informationen zum Log-Bereich

● Einstiegspunkt in den Converter, den das Datenbanksystem beim letzten Savepoint gesichert hat

● Einstiegspunkt in das History-Directory, das das Datenbanksystem beim letzten Savepoint gesichert hat

● Einstiegspunkt in das interne Dateiverzeichnis

Das Datenbanksystem aktualisiert die Restart-Information bei jedem Savepoint.

Siehe auch:

Konzepte des Datenbanksystems, Volumes (permanenter Speicher), Savepoint

Database Manager CLI, Strukturlink db_restartinfo


Restriktion (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Restriktion

Für MaxDB-Datenbankinstanzen gelten einige Restriktionen, wie z. B. wie viele Data-Volumes eine Datenbankinstanz maximal haben kann oder wie viele Spalten ein Index maximal umfassen darf.

Siehe auch:

Konzepte des Datenbanksystems, Technische Restriktionen

SQL-Referenzhandbuch, Restriktionen für SQL-Anweisungen


ROLL FORWARD (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation ROLL FORWARD

Das Datenbanksystem wiederholt die Effekte bereits abgeschlossener Transaktionen, z. B. beim Restart nach einem Stromausfall.

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging), Beispiel: Restart


ROLLBACK (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation ROLLBACK

Bei einem ROLLBACK macht das Datenbanksystem alle Änderungen rückgängig, die von einer Transaktion in der Datenbank durchgeführt wurden. Hierfür verwendet das Datenbanksystem die Undo-Log-Einträge der Transaktion.

Danach gibt das Datenbanksystem alle Sperren frei, die der Transaktion zugeordnet sind, löscht implizit alle Ergebnistabellen, die die Transaktion angelegt hat, und eröffnet eine neue Transaktion.

Durch ein COMMIT abgeschlossene Änderungen können nicht mehr durch ein ROLLBACK rückgängig gemacht werden.

Im normalen Datenbankbetrieb führt das Datenbanksystem die erforderlichen ROLLBACK-Aktionen selbständig durch. Ein ROLLBACK kann aber auch explizit durch entsprechende SQL-Anweisungen angefordert werden.

Siehe auch:

SQL-Referenzhandbuch, ROLLBACK-Anweisung

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Rolle (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Rolle

Eine Rolle ist eine Zusammenfassung von Privilegien, die Datenbankbenutzern, Benutzergruppen oder anderen Rollen zugewiesen werden können.

Während Privilegien immer gelten, sind Rollen zunächst inaktiv, d. h. die darin enthaltenen Privilegien gelten nicht. Rollen können Sie für einzelne Datenbanksitzungen aktivieren. Jeder Benutzer, an den Rollen vergeben wurden, kann auch festlegen, welche der Rollen in jeder seiner Datenbanksitzungen aktiv sein soll. Diese Festlegung kann der Benutzer ändern, nachdem er eine Datenbanksitzung eröffnet hat.

Siehe auch:

SQL-Referenzhandbuch, Rollenname (role_name)


S (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation S


SAP DB (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SAP DB

Die Datenbanksoftware SAP DB wird seit der Datenbankversion 7.5 unter dem Namen MaxDB ausgeliefert.

Siehe auch:

Konzepte des Datenbanksystems, SAP DB und MaxDB


Savepoint (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Savepoint

In Savepoints schreibt das Datenbanksystem Datenänderungen aus den verschiedenen Caches (Arbeitsspeicher) in die Volumes (permanenter Speicher).

Siehe auch:

Konzepte des Datenbanksystems, Savepoint


Schattendatenbank (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Schattendatenbank

Eine Schattendatenbank (englisch: Standby Database) ist einer Kopie der aktiven Datenbankinstanz, die Sie in regelmäßigen Abständen mit den Log-Sicherungen der aktiven Datenbankinstanz auf dem aktuellen Stand bringen.

Siehe auch:

Konzepte des Datenbanksystems, Schattendatenbank


Scheduler (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Scheduler

Mit dem Scheduler können Sie einplanen, dass DBM-Kommandos zu definierten Zeitpunkten ausgeführt werden.

Siehe auch:

Database Manager CLI, Strukturlink Verwenden des Scheduler


Schema (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Schema

Mit Schemas können Sie logisch zusammengehörende Datenbankobjekte gruppieren. Ein Datenbankobjekt kann zu genau einem Schema gehören.

Schemas werden in folgenden Situationen angelegt:

● Wenn Sie einen neuen Datenbankbenutzer anlegen, legt das Datenbanksystem ein Schema mit dem Namen des Datenbankbenutzers an.

Wenn Sie eine neue Datenbankinstanz anlegen, legt das Datenbanksystem den Datenbanksystemadministrator (SYSDBA-Benutzer) an und damit implizit ein Schema gleichen Namens. Das Datenbanksystem legt für den Datenbanksystemadministrator außerdem folgende Schemas an: SYS, DOMAIN, SYSINFO.

● Datenbankadministratoren können explizit Schemas erzeugen.

Neue Datenbankobjekte werden folgendermaßen einem Schema zugeordnet:

● Der Datenbankbenutzer, der das Datenbankobjekt anlegt, kann das Datenbankobjekt explizit einem Schema zuordnen.

Der Datenbankbenutzer BORIS legt die Tabelle person an und ordnet sie dem Schema OFFICE zu.

CREATE TABLE OFFICE.person
(pno FIXED(6),
name CHAR(20),
city CHAR(20))

● Wenn der Datenbankbenutzer beim Anlegen des Datenbankobjekts kein Schema angibt, dann ordnet das Datenbanksystem das Datenbankobjekt automatisch dem Schema des aktuell angemeldeten Datenbankbenutzers zu.

Der Datenbankbenutzer BORIS legt die Tabelle person an. Das Datenbanksystem ordnet die Tabelle dem Schema BORIS zu.

CREATE TABLE person
(pno FIXED(6),
name CHAR(20),
city CHAR(20))

Siehe auch:

SQL-Referenzhandbuch, Schemaname (schema_name)


Schlüsselwort (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Schlüsselwort

Das Datenbanksystem verwendet eine Reihe von Wörtern als Schlüsselwörter, z. B. als Syntaxelemente in SQL-Anweisungen oder als Kommandonamen.

Es gibt reservierte und nicht-reservierte Schlüsselwörter:

● Reservierte Schlüsselwörter können Sie in speziellen Bezeichnern für Datenbankobjekte verwenden, nicht jedoch in einfachen Bezeichnern.

Beispiel: SELECT

● Nicht-reservierte Schlüsselwörtern können Sie uneingeschränkt in Bezeichnern für Datenbankobjekte verwenden.

Beispiel: COMMIT

Wir empfehlen, weder nicht-reservierte noch reservierte Schlüsselwörter in Bezeichnern für Datenbankobjekte zu verwenden.

Siehe auch:

SQL-Referenzhandbuch, Schlüsselwort (key_word)


Schnittstelle (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Schnittstelle

Das Datenbanksystem MaxDB bietet Schnittstellen für die Programmierung von Datenbankanwendungen in mehreren Programmiersprachen.

Siehe auch:

Konzepte des Datenbanksystems, Schnittstellen


Schreibsperre (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Schreibsperre

Eine Schreibsperre sperrt ein Datenbankobjekt exklusiv. Andere Transaktionen können weder lesend noch schreibend auf das Datenbankobjekt zugreifen.

Siehe auch:

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


sdb (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation sdb

sdb ist der Vorschlagswert für den Namen des speziellen Betriebssystembenutzers für MaxDB (nur auf UNIX/Linux).

Siehe auch:

Konzepte des Datenbanksystems, <sdb_user> (spezieller Betriebssystembenutzer)


sdba (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation sdba

sdba ist der Vorschlagswert für den Namen der speziellen Betriebssystembenutzergruppe für MaxDB (nur auf UNIX/Linux). Die Mitglieder dieser Benutzergruppe haben auf Betriebssystemebene umfassende Berechtigungen beim Zugriff auf Datenbankressourcen.

Siehe auch:

Konzepte des Datenbanksystems, <sdba_group> (spezielle Betriebssystemgruppe)


Seite (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Seite

Eine Seite (Page) ist die Grundeinheit, in der das Datenbanksystem Daten auf Festplatten schreibt und von Festplatten liest. Eine Seite entspricht einer bestimmten Anzahl von Betriebssystemblöcken. Seiten werden häufig als Einheit verwendet, wenn Speicher- und Plattengrößen angegeben werden.

Die Seitengröße für das Datenbanksystem MaxDB beträgt 8 KB.

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Konzepte des Datenbanksystems, Datenspeicherung


Seitenkette (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Seitenkette

Eine Seitenkette ist eine Folge von Seiten, die logisch zusammengehören.

Siehe auch:

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


Sekundärschlüssel (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sekundärschlüssel

siehe Index


Selektivität (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Selektivität

Verhältnis zwischen gelesenen und tatsächlich benötigten Datensätzen beim Datenzugriff.


Separator (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Separator

Die Einträge in Wurzel- und Indexseiten eines B*-Baums werden als Separatoren bezeichnet. Ein Separator dient als Wegweiser zur zugehörigen Seite auf der nächsttiefergelegenen Ebene des B*-Baums. Ein Separator besteht aus dem signifikanten Teil des Primärschlüssels eines Datensatzes, der zur Unterscheidung zum Folgeeintrag benötigt wird, einer Längenangabe und einem Zeiger.

Siehe auch:

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


Sequence-Cache (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sequence-Cache

Der Sequence-Cache ist ein Arbeitsspeicherbereich, in dem das Datenbanksystem Informationen zu Sequenzen ablegt.

Die Größe des Sequence-Cache können Sie über den speziellen Datenbankparameter SEQUENCE_CACHE konfigurieren.

Siehe auch:

Konzepte des Datenbanksystems,

● Arbeitsspeicherbereiche

● Spezielle Datenbankparameter


Sequenz (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sequenz

Eine Sequenz ist ein Datenbankobjekt, dessen Wert das Datenbanksystem bei jedem Zugriff automatisch vergrößert oder verkleinert. Um einen schnellen Zugriff zu gewährleisten, hält das Datenbanksystem die Werte und Verwaltungsinformationen für Sequenzen im Sequence-Cache.

Siehe auch:

SQL-Referenzhandbuch,

● Sequenzname (sequence_name)

● CREATE SEQUENCE-Anweisung (create_sequence_statement)

SQL-Tutorial, Strukturlink Nummerngeneratoren für Tabellen


Server-Task (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Server-Task

Server-Tasks sind Tasks im User-Kernel-Thread. Server-Tasks parallelisieren Datenbankfunktionen und werden z. B. für das Sichern von Daten verwendet.

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Tasks


Serverberechtigung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Serverberechtigung

Serverberechtigungen regeln die Berechtigungen von Database Manager-Benutzern (DBM-Benutzern) beim Zugriff auf den DBM-Server.

Siehe auch:

Konzepte des Datenbanksystems, Serverberechtigungen für den DBM-Server

Database Manager GUI, Strukturlink Ändern der Serverberechtigungen

Database Manager CLI, Strukturlink user_getrights, Strukturlink user_put


Service-Datenbankinstanz (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Service-Datenbankinstanz

Die Service-Datenbankinstanz ist eine speziell konfigurierte zusätzliche Datenbankinstanz ohne eigenen Datenbestand, die das Datenbanksystem u. a. für das Prüfen einer Sicherung oder das Wiederherstellen der Parameterdatei aus einer Datensicherung benötigt.

Das Datenbanksystem legt die Service-Datenbankinstanz bei der Installation der Datenbanksoftware unter einem generierten Namen <generated_name> an.

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Dienste

Database Manager CLI, Strukturlink Eröffnen einer Service-Sitzung: : -uSRV


Service-Sitzung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Service-Sitzung

Eine Service-Sitzung ist eine spezielle Datenbanksitzung, bei der Sie mit der Service-Datenbankinstanz verbunden sind.

Siehe auch:

Database Manager CLI, Strukturlink Eröffnen einer Service-Sitzung: -uSRV


Shared-Memory (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Shared-Memory

Shared-Memory ist Arbeitsspeicher, den mehrere Prozesse einer Datenbankinstanz gemeinsam nutzen.

Der DBM-Server einer Datenbankinstanz kann aus mehreren Prozessen bestehen. Diese Prozesse kommunizieren über Shared-Memory miteinander. Diese Kommunikation ist aus den folgenden Gründen notwendig:

○ um den Zugriff auf gemeinsame Ressourcen wie z.B. die Parameterdatei oder die Protokolldatei des DBM-Servers zu koordinieren

○ um Datenbankparameter zu übergeben

○ um die Ergebnisse spezieller DBM-Server-Prozesse wie z. B. des Command Scheduler abzuholen

Das Datenbanksystem speichert den Inhalt des Shared-Memory des DBM-Servers zusätzlich im Dateisystem in den Dateien dbmsrv_<database_name>.shi und dbmsrv_<database_name>.shm im Verzeichnis <independent_data_path>\wrk. So bleibt der Inhalt des Shared-Memory auch dann erhalten, wenn gerade kein DBM-Server-Prozess aktiv ist.

DBM-Server-Prozesse unterschiedlicher Datenbankinstanzen können nicht über Shared-Memory miteinander kommunizieren.

Siehe auch:

Database Manager CLI, Strukturlink Weitere Kommandos zu den Einstellungen des Database Manager


Shared-SQL (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Shared-SQL

Das Datenbanksystem kann Shared-SQL verwenden, um ein mehrfaches Parsen und eine mehrfache Speicherung von Parse-Informationen (z. B. Ausführungspläne, Ergebnismengenbeschreibungen) zu vermeiden.

Wenn Shared-SQL aktiviert ist, dann speichert das Datenbanksystem alle geparsten SQL-Anweisungen und insbesondere Prepared Statements mit den zugehörigen Informationen in einem globalen, von allen Benutzern gemeinsam verwendeten Cache. Es kann diese Informationen später gegebenenfalls wieder verwenden.

Shared-SQL können Sie mit dem speziellen Datenbankparameter SHARED_SQL aktivieren.

Siehe auch:

Konzepte des Datenbanksystems, Spezielle Datenbankparameter


Sichern (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sichern

Beim Sichern speichert das Datenbanksystem die Inhalte der Volumes auf Datenträger.

Siehe auch:

Konzepte des Datenbanksystems, Sichern und Wiederherstellen


Sicherungsart (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sicherungsart

Es gibt folgende Sicherungsarten:

● vollständige Datensicherung

● inkrementelle Datensicherung

● Log-Sicherung

Sie können die Log-Sicherung automatisieren (automatische Log-Sicherung).

Siehe auch:

Konzepte des Datenbanksystems, Sichern und Wiederherstellen


Sicherungsdatei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sicherungsdatei

Sie können sowohl Daten als auch Log-Einträge auf Datenträger vom Typ Datei sichern. Solche Dateien werden auch als Sicherungsdateien bezeichnet.

Besonderheiten bei Log-Sicherungen

Bei Log-Sicherungen auf einen Datenträger vom Typ Datei sichert das Datenbanksystem jedes Log-Segment des Log-Bereichs in eine Sicherungsdatei.

Der Name einer solchen Sicherungsdatei setzt sich aus dem bei der Definition der Sicherungsvorlage angegebenen Dateinamen und einer vom Datenbanksystem vergebenen fortlaufenden Nummer zusammen (z. B. logfile.001).

Wir empfehlen, diese Sicherungsdateien regelmäßig archivieren.

Siehe auch:

Konzepte des Datenbanksystems,

● Sicherungsvorlagen und Datenträger

● Log-Einträge sichern

● Sicherungsdateien archivieren

Database Manager CLI, Strukturlink Weitere Kommandos zum Sichern

Datenbankverwaltung im CCMS, Strukturlink Sicherungsdateien archivieren


Sicherungshistorie (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sicherungshistorie

In der Sicherungshistorie protokolliert das Datenbanksystem chronologisch die Informationen zu allen Aktionen, die es beim Sichern und Wiederherstellen der Datenbankinstanz durchgeführt hat.

Das Datenbanksystem schreibt die Sicherungshistorie in folgende Protokolldateien:

· bei Sicherungen ohne externe Sicherungswerkzeuge in die Protokolldatei dbm.knl

· bei Sicherungen mit externen Sicherungswerkzeugen in die Protokolldatei dbm.ebf

Verwenden Sie zum Anzeigen der Sicherungshistorie den Database Manager oder in SAP-Systemen den Datenbankassistenten.

Siehe auch:

Database Manager GUI, Strukturlink Sicherungshistorie anzeigen

Database Manager CLI, Strukturlink Sichern und Wiederherstellen der Datenbankinstanz

Datenbankverwaltung im CCMS, Strukturlink DBA-Historie

Konzepte des Datenbanksystems, Protokolldateien


Sicherungskennung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sicherungskennung

Das Datenbanksystem vergibt für jede Sicherung eine Sicherungskennung (IBID), bestehend aus einem vom System vergebenen Schlüssel (<key>) und dem Label (<label>). Diese Kombination aus Schlüssel und Label ermöglicht die eindeutige Identifizierung der Sicherung seit dem Anlegen oder dem letzten Initialisieren der Datenbankinstanz.

Wenn Sie externe Sicherungswerkzeuge verwenden, dann erhält die Sicherung außerdem eine externe Sicherungskennung (EBID oder External Backup ID).

Das Label besteht aus einer Zeichenkette für die Sicherungsart <backup_type> (vollständige oder inkrementelle Datensicherung oder Log-Sicherung) und einer Sequenznummer <sequence_no>. Datensicherungen werden unabhängig davon, ob sie vollständig oder inkrementell sind, fortlaufend nummeriert. Log-Sicherungen zählt das Datenbanksystem separat.

Der Database Manager schreibt die Sicherungskennung nach dem Sicherungsvorgang in die Protokolldatei dbm.knl des Database Manager. Der Inhalt dieser Datei wird in der Sicherungshistorie vollständig angezeigt. Beim Wiederherstellen können Sie die Sicherungshistorie mit dem Database Manager anzeigen und die gewünschte Sicherung anhand ihrer Sicherungskennung auswählen.

Der Loader schreibt die externe Sicherungskennung in die Protokolldatei des Loader und in die Loader-relevanten Systemtabellen.

Wenn der verwendete Datenträger ein Band ist, empfehlen wir, nach Beenden des Sicherungsvorganges die Sicherungskennung auf das Etikett des Bandes zu schreiben.

Formale Beschreibung der Sicherungskennung

<IBID> ::= <key><label>

<label> ::= <backup_type>_<sequence_no>

<backup_type> ::= DAT | PAG | LOG

Siehe auch:

Konzepte des Datenbanksystems

● Protokolldateien

● Sichern und Wiederherstellen


Sicherungsmedium (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sicherungsmedium

siehe

● Datenträger

● Sicherungsvorlage


Sicherungsvorlage (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sicherungsvorlage

Bevor Sie Daten oder Log-Einträge auf einen Datenträger sichern können, müssen Sie eine Sicherungsvorlage definieren. In den Eigenschaften der Sicherungsvorlage legen Sie unter anderem die Sicherungsart und den Typ des zu verwendenden Datenträgers fest.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungsvorlagen und Datenträger

Database Manager GUI, Strukturlink Verwalten der Sicherungsvorlagen

Database Manager CLI, Strukturlink medium_put

Tutorial Datenbankverwaltung, Strukturlink Sicherungsvorlagen definieren

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Sicherungsvorlagen

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Sicherungsvorlagen


Sicherungswerkzeug (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sicherungswerkzeug

MaxDB unterstützt die Verwendung einer Reihe von Sicherungswerkzeugen anderer Anbieter.

Darüber hinaus können Sie über Skripte im Database Manager auch alle anderen Sicherungswerkzeuge verwenden, die Sicherungen aus Pipes verarbeiten können.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungswerkzeuge anderer Anbieter verwenden


Sitzungsmodus (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sitzungsmodus

Der Sitzungsmodus ist ein Betriebsmodus von Kommandozeilenprogrammen.


Skriptmodus (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Skriptmodus

Der Skriptmodus ist ein Betriebsmodus von Kommandozeilenprogrammen.


Snapshot (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Snapshot

Ein Snapshot friert den aktuellen Zustand des Datenbereichs ein. Nachdem Sie einen Snapshot gemacht haben, können Sie mit den Daten der Datenbankinstanz normal weiterarbeiten und Änderungen der Daten vornehmen. Zu einem späteren Zeitpunkt können Sie zum eingefrorenen Zustand des Datenbereichs zurückkehren oder alle Änderungen seit dem Snapshot übernehmen.

Siehe auch:

Konzepte des Datenbanksystems, Datenbereich einfrieren (Snapshot)

Database Manager GUI, Strukturlink Einfrieren des Datenbereichs (Snapshot)


Softwarekomponente (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Softwarekomponente

Die MaxDB-Datenbanksoftware besteht aus mehreren Softwarekomponenten. Eine Softwarekomponente kann beispielsweise ein Datenbankwerkzeug oder eine Schnittstelle sein. Bei der Installation können Sie auswählen, welche Softwarekomponenten Sie installieren möchten.

Siehe auch:

Installationshandbuch, Strukturlink Softwarekomponenten


Spalte (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Spalte

Alle Werte einer Spalte in einer Datenbanktabelle sind von demselben Datentyp. Ein Wert einer Spalte in einer Zeile ist die kleinste Einheit von Daten, die aus einer Tabelle selektiert werden kann, auf die Funktionen angewendet werden kann oder die modifiziert werden kann. Jede Spalte einer Basistabelle hat einen innerhalb der Tabelle eindeutigen Namen.

Spaltentypen

alphanumerisch | Zeichenkettenspalte alle Zeichenketten in einer alphanumerischen Spalte haben dieselbe Länge
numerisch | Gleit- oder Festkommaspalte alle Zahlen in einer Gleitkommaspalte haben diesselbe Mantissenlänge alle Zahlen in einer Festkommaspalte haben dasselbe Format, d. h. dieselbe Anzahl von Vorkomma- und Nachkommastellen

Siehe auch:

SQL-Referenzhandbuch

● Spaltenname

● Spalten mit einer SQL-Anweisung definieren: column_definition


Sperre (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sperre

Das Datenbanksystem lässt konkurrierende Transaktionen auf den gleichen Datenbankobjekten zu. Um dabei eine Synchronisation der parallelen Prozesse und eine Isolation einzelner Transaktionen zu gewährleisten, sind Sperren (Locks) erforderlich.

Siehe auch:

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


Sperrliste (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sperrliste

In der Sperrliste hält das Datenbanksystem die Sperren und Sperranforderungen sämtlicher Benutzer.

Siehe auch:

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


Spezial-Thread (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Spezial-Thread

Spezial-Threads sind Betriebssystem-Threads. Sie stellen Dienste für die User-Kernel-Threads zur Verfügung, die die User-Kernel-Threads asynchron abarbeiten müssen, wie z. B. Verbindungsanfragen, das Lesen oder Schreiben auf Data-Volumes oder Sicherungen.

Siehe auch:

Konzepte des Datenbanksystems, Spezial-Threads


Sprachunterstützung (Mapchar-Sets) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sprachunterstützung (Mapchar-Sets)

Das Datenbanksystem verwendet Mapchar-Set, um sprachspezifische Zeichen auf alternative Schreibweisen abzubilden, wie z. B. ü auf ue. Die umzusetzenden Zeichen und das Mapchar-Set müssen den gleichen Zeichensatz verwenden. Wenn z. B. ein Mapchar-Set als Unicode definiert wurde, dann kann dieses Mapchar-Set nur für Unicode-Werte verwendet werden.

Beim Anlegen einer Datenbankinstanz legt das Datenbanksystem das Mapchar-Set DEFAULTMAP an. Sie können das Mapchar-Set DEFAULTMAP ändern und zusätzliche Mapchar-Sets definieren.

Mapchar-Sets gelten nur für systeminterne Funktionen.

Die Funktion MAPCHAR(x,n,i) verwendet Mapchar-Sets, um Felder zu sortieren, die Umlaute enthalten.

Siehe auch:

Database Manager GUI, Strukturlink Mapchar-Sets anlegen, anzeigen, ändern und löschen

SQL-Referenzhandbuch, Mapchar-Set-Name (mapchar_set_name), MAPCHAR(x,n,i)


SQL (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL

Mit Anweisungen in der Structured Query Language (SQL-Anweisungen) können Sie Daten in der Datenbank definieren, anzeigen, einfügen, ändern und löschen.

Siehe auch:

Konzepte des Datenbanksystems, SQL

SQL-Referenzhandbuch

Strukturlink SQL-Tutorial


SQL Studio (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL Studio

SQL Studio ist ein Datenbankwerkzeug für den Zugriff auf Daten und den Datenbankkatalog, SQL-Abfragen und das Anlegen und Verwalten von Datenbankobjekten und Datenbankbenutzern. SQL Studio hat eine grafische Benutzungsoberfläche.

Siehe auch:

Dokumentation zu Strukturlink SQL Studio

Konzepte des Datenbanksystems, Datenbankwerkzeuge


SQL-Anweisung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL-Anweisung

Mit SQL-Anweisungen können Sie Daten in der Datenbank anzeigen, einfügen, ändern oder löschen.

Siehe auch:

SQL-Referenzhandbuch, SQL-Anweisungen: Überblick

SQL-Tutorial, Strukturlink SQL-Tutorial

Konzepte des Datenbanksystems, SQL


SQL-Modus (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL-Modus

Das Datenbanksystem MaxDB unterstützt mehrere SQL-Sprachvarianten (SQL-Modi)

SQL-Modi

Name | Beschreibung
INTERNAL | MaxDB-eigene Definition
ANSI | ANSI-Standard gemäß ANSI X3.135-1992, Entry SQL
DB2 | Definition DB2 Version 4
ORACLE | Definition ORACLE 7

Wenn Sie eine Datenbanksitzung eröffnen, können Sie den gewünschten SQL-Modus angeben. Der Vorschlagswert ist INTERNAL.

Bei Data Definition Language (DDL)-Anweisungen unterstützt das Datenbanksystem andere SQL-Modi als INTERNAL nur eingeschränkt.

Wenn nicht anders angegeben, dann beschreibt die Dokumentation zum Datenbanksystem diejenige Funktionalität, die im SQL-Modus INTERNAL zur Verfügung steht.

Siehe auch:

SQL-Referenzhandbuch:

● Angeben des SQL-Modus mit der CONNECT-Anweisung

● SQL-Modus ORACLE

Loader, Strukturlink SQLMODE-Kommando


SQL-Optimierer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL-Optimierer

Der SQL-Optimierer ist Bestandteil des Kerns des Datenbanksystems. Er analysiert SQL-Anfragen, die an die Datenbankinstanz gestellt werden, und wählt die beste Suchstrategie für den Zugriff auf die Datenbanktabellen aus.

Siehe auch:

Dokumentation zum SQL-Optimierer


SQL-Sitzung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL-Sitzung

siehe Datenbanksitzung


SQL-Tutorial (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL-Tutorial

Für das Datenbanksystem MaxDB steht ein SQL-Tutorial zur Verfügung. Das SQL-Tutorial erklärt die wichtigsten SQL-Anweisungen mit Daten des Beispielschemas HOTEL.

Siehe auch:

Strukturlink SQL-Tutorial


SQLCLI (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQLCLI

SQLCLI ist ein Kommandozeilen-Datenbankwerkzeug für den Zugriff auf Daten und den Datenbankkatalog, SQL-Abfragen und das Anlegen und Verwalten von Datenbankobjekten und Datenbankbenutzern.

Siehe auch:

Dokumentation zu Strukturlink SQLCLI

Konzepte des Datenbanksystems, Datenbankwerkzeuge


SQLDBC (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQLDBC

SQL Database Connectivity (SQLDBC) ist eine Laufzeitbibliothek für die Entwicklung von Datenbankanwendungen und Datenbankschnittstellen für MaxDB. Über SQLDBC können Anwendungen auf MaxDB-Datenbankinstanzen zugreifen, SQL-Anweisungen ausführen und Daten bearbeiten. Es besteht aus der Laufzeitbibliothek libSQLDBC, dem Software Development Kit SQLDBC SDK und dem Werkzeug sqldbc_cons.

Siehe auch:

Dokumentation zu Strukturlink SQLDBC

Konzepte des Datenbanksystems, Schnittstellen

Datenbankverwaltung im CCMS, Strukturlink SQLDBC-Trace


SSL/TLS (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SSL/TLS

Die Kommunikation zwischen Clients (z. B. Database Manager CLI) und X-Server können Sie mit SSL/TLS verschlüsseln.

Siehe auch:

Konzepte des Datenbanksystems, Datenverschlüsselung


STANDARD-Benutzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation STANDARD-Benutzer

STANDARD-Benutzer sind Datenbankbenutzer, die nur über eingeschränkte Rechte zur Verwaltung von Datenbankobjekten und über keine Rechte zur Benutzerverwaltung verfügen.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankbenutzer


Standby-Instanz (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Standby-Instanz

In einem Hot-Standby-System gibt es eine oder mehrere Standby-Instanzen, die in regelmäßigen Abständen alle Datenänderungen in der Master-Instanz nachvollziehen. Wenn die Master-Instanz ausfällt, dann wird eine der Standby-Instanzen zur neuen Master-Instanz. Standby-Instanzen befinden sich im Betriebszustand STANDBY.

Siehe auch:

Konzepte des Datenbanksystems, Hot-Standby

Database Manager GUI, Strukturlink Standby-Instanz hinzufügen (Hot-Standby)

Database Manager CLI, Strukturlink hss_addstandby


Starten (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Starten

Um eine Datenbankinstanz manuell zu starten, überführen Sie sie mit dem Datenbankwerkzeug Database Manager in den Betriebszustand ONLINE.

Sie können Betriebssystem und Datenbankinstanz auch so konfigurieren, dass die Datenbankinstanz beim Starten des Rechners automatisch in den Betriebszustand ONLINE überführt wird.

Siehe auch:

Konzepte des Datenbanksystems, Automatischer Start

Database Manager GUI, Strukturlink Starten der Datenbankinstanz (Restart)

Database Manager CLI, Strukturlink db_online


Statistiken (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Statistiken

Das Datenbanksystem ermittelt im laufenden Betrieb eine Reihe von statistischen Informationen, die u. a. vom SQL-Optimierer verwendet werden.

Siehe auch:

Konzepte des Datenbanksystems, Statistiken des SQL-Optimierers

SQL-Referenzhandbuch, Statistiken

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Statistiken

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Statistiken


Stored Procedure (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Stored Procedure

siehe Datenbankprozedur


Strategie (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Strategie

Um auf Daten zuzugreifen, kann das Datenbanksystem in der Regel mehrere unterschiedliche Strategien (Suchstrategien) anwenden. Diese Suchstrategien unterscheiden sich u. a. in den Kosten, die bei ihrer Ausführung entstehen.

Siehe auch:

Konzepte des Datenbanksystems,

● Suchstrategien

● Liste aller Suchstrategien


Subtransaktion (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Subtransaktion

Sie können eine Transaktion in weitere in sich geschlossene Einheiten (Subtransaktionen) unterteilen.

Siehe auch:

SQL-Referenzhandbuch, SUBTRANS-Anweisung (subtrans_statement)


Suchstrategie (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Suchstrategie

siehe Strategie


Support (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Support

Für MaxDB können Sie auf mehreren Wegen Support erhalten.

SAP-Kunden finden weitere Informationen im SAP-Hinweis 826037.

Siehe auch:

Konzepte des Datenbanksystems, Support


Synchronisation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Synchronisation

Bei der Synchronisation von Datenbankinstanzen werden die Daten mehrerer Datenbankinstanzen miteinander abgeglichen.

Um Datenbankinstanzen zu synchronisieren, können Sie den Synchronization Manager verwenden. Der Synchronization Manager stellt unter anderem Folgendes sicher:

  • Wenn in einer der Datenbankinstanzen Daten geändert werden, werden diese Änderungen in den anderen Datenbankinstanzen repliziert.
  • Wenn zwei Datenbankinstanzen gleichzeitig dieselben Daten ändern, findet eine automatische Konfliktbehandlung statt.

Siehe auch:

Dokumentation Strukturlink Synchronization Manager

Konzepte des Datenbanksystems, Synchronisation


Synchronisationsbenutzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Synchronisationsbenutzer

Der Synchronisationsbenutzer ist ein spezieller Datenbankbenutzer, der für die Synchronisation von Datenbankinstanzen mit dem Programm Synchronization Manager benötigt wird.

Der Synchronisationsbenutzer zeichnet sich durch folgende SQL-Benutzereigenschaften aus: Datenbankbenutzerklasse DBA, Connection Mode NOT EXCLUSIVE, Replication User.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankbenutzer

Database Manager GUI, Strukturlink Anlegen/Ändern/Löschen des Synchronisationsbenutzers

Dokumentation zum Strukturlink Synchronization Manager


Synchronization Manager (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Synchronization Manager

Der Synchronization Manager ist ein Werkzeug zum Synchronisieren von Tabelleninhalten von zwei oder mehr Datenbankinstanzen.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankwerkzeuge

Dokumentation zum Strukturlink Sychronization Manager


Synonym (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Synonym

Ein Synonym ist ein alternativer Name für eine Datenbanktabelle. Jedes Synonym hat einen innerhalb eines Datenbankschemas eindeutigen und von allen anderen Tabellennamen verschiedenen Namen.

Siehe auch:

SQL-Referenzhandbuch, Synonymname


Syntaxnotation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Syntaxnotation

Die in der Dokumentation verwendete Syntaxnotation ist von der Backus Naur Form (BNF) abgeleitet. Es gelten unter anderem folgende Konventionen:

Syntaxelement | Beschreibung
SCHLÜSSELWORT | Schlüsselwort Schlüsselwörter werden zur Hervorhebung in Großbuchstaben geschrieben. Wenn in der Dokumentation kein besonderer Hinweis zur Groß- und Kleinschreibung steht, dann können Sie Schlüsselwörter in Groß- oder in Kleinbuchstaben eingeben.
<variable> | Platzhalter für Syntaxelement, wie z. B. eine Variable. Wenn Sie die Variable eingeben, dann geben Sie die spitzen Klammern nicht mit ein.
[syntax_element] | optionales Syntaxelement
syntax_element1 | syntax_element1 | alternative Syntaxelemente (oder)
syntax_element, ... | Syntaxelement kann beliebig oft wiederholt werden.

Um die Dokumentation übersichtlicher zu gestalten, ist die Syntax folgendermaßen formatiert:

Beispiel | Beschreibung
>dbmcli db_enum | Kommandos und SQL-Anweisungen, die Benutzer eingeben sollen
OK DEMODB C:\Program Files\sdb\DEMODB 7.6.00.00 fast online | Ausgaben des Datenbanksystem, der Datenbankwerkzeuge oder anderer Programme
Das Kommando db_enum listet alle Datenbankinstanzen auf. Die Dokumentation verwendet die Demo-Datenbankinstanz DEMODB. | Syntaxelemente und Beispiele im Fließtext

Beispiel

>sqlcli –d <database_name> –u <database_user>,<database_user_password> <sql_statement>

Um Befehle und Aktionen zu illustrieren, verwendet die Dokumentation die Demo-Datenbankinstanz DEMODB und die darin enthaltenen Beispieldaten des Schemas HOTEL:

>sqlcli –d demodb -u mona,red SELECT * FROM hotel.city

| ZIP | NAME | STATE |

| ----- | -------------------- | ----- |

| 10019 | New York | NY |

| 10580 | New York | NY |

| 11788 | Long Island | NY |

| 12203 | Albany | NY |

| 20005 | Washington | DC |

| 20019 | Washington | DC |

Siehe auch:

SQL-Referenzhandbuch, Syntaxnotation

Loader, Strukturlink Syntaxregeln: Übersicht


SYSDBA-Benutzer (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SYSDBA-Benutzer

siehe Datenbanksystemadministrator (SYSDBA-Benutzer)


System-Trigger (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation System-Trigger

Ein System-Trigger ist eine spezielle Datenbankprozedur, die im Verlauf eines Restarts implizit ausgeführt wird. Die Ausführung erfolgt zu einem Zeitpunkt, zu dem die Datenbankinstanz zwar bereits vollständig gestartet ist, jedoch noch keine Verbindungen zur Datenbankinstanz möglich sind.

Siehe auch:

SQL-Referenzhandbuch, CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement)


Systemausfall (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Systemausfall

Wenn die Datenbankinstanz aufgrund eines Hardwareschadens oder eines logischen Fehlers ausfällt, können Sie die Datenbankinstanz wieder in einen konsistenten Zustand bringen (wiederherstellen), indem Sie Ihre Daten- und Log-Sicherungen einlesen.

Für eine erhöhte Ausfallsicherheit stehen darüber hinaus mehrere Replikations- und High-Availability-Mechanismen zur Verfügung.

Siehe auch:

Konzepte des Datenbanksystems,

· Sichern und Wiederherstellen

· Replikation und High-Availability

· Fehlersuche


Systemkopie (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Systemkopie

Bei einer Systemkopie duplizieren Sie ein SAP-System. Sie installieren alle Instanzen des SAP-Systems neu, legen die Zieldatenbank aber als Kopie der Quelldatenbank an (Datenbankkopie). Einige Einstellungen im Zielsystem können sich von denen im Quellsystem unterscheiden.

Sie können folgende Arten von Systemkopien erstellen:

· homogene Systemkopie

Das Zielsystem läuft auf demselben Betriebssystem und mit demselben Datenbanksystem wie das Quellsystem.

· heterogene Systemkopie

Das Zielsystem läuft auf einem anderen Betriebssystem oder mit einem anderen Datenbanksystem als das Quellsystem.

Um eine Systemkopie zu erstellen, benötigen Sie unter anderem eine Datenbankkopie.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankkopie

SAP-Hinweis 129352


Systemtabelle (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Systemtabelle

In den Systemtabellen einer Datenbankinstanz speichert das Datenbanksystem unter anderem Informationen über Datenbankobjekte und ihre Beziehungen zueinander, Datenbankzustände, Statistiken, Betrieb und Einstellungen.

Siehe auch:

Referenzhandbuch, Systemtabellen

Database Manager GUI, Strukturlink Aktualisieren der Systemtabellen

Database Manager CLI, Strukturlink load_systab


Systemvoraussetzungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Systemvoraussetzungen

MaxDB-Software können Sie auf mehreren Betriebssystemen verwenden, u. a. auf Microsoft Windows und auf verschiedenen UNIX- und Linux-Varianten.

Siehe auch:

Konzepte des Datenbanksystems, Unterstützte Betriebssysteme und Plattformen

Strukturlink Installationshandbuch


T (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation T


Tabelle (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Tabelle

Eine Tabelle ist eine Menge von Zeilen. Jede Zeile einer Tabelle hat dieselbe Anzahl von Spalten und enthält für jede Spalte einen Wert.

Tabellen-Typen

Basistabelle | Alle Tabellen, die Anwendungsdaten enthalten, und die Systemtabellen sind Basistabellen. Basistabellen werden permanent gespeichert.
Ergebnistabelle | Das Datenbanksystem legt unbenannte Ergebnistabellen beim Ausführen einer SELECT-Anweisung an und löscht diese bei Sitzungsende wieder. Das Datenbanksystem legt benannte Ergebnistabellen beim Ausführen einer DECLARE CURSOR-Anweisung an.
Join-Tabelle | Eine Join-Tabelle ist eine spezielle Ergebnistabelle, die das Datenbanksystem beim Verknüpfen von zwei oder mehreren Tabellen anlegt.
Systemtabelle | Eine Systemtabelle ist eine Basistabelle, die Systeminformationen enthält (Informationen zu Datenbankobjekten, -zuständen, -statistik, -monitordaten; Loader-Systemtabellen).
temporäre Tabelle | Eine temporäre Tabelle ist eine spezielle Basistabelle, die das Datenbanksystem bei Sitzungsende wieder löscht. Temporäre Tabellen gehören zum Schema TEMP.
View-Tabelle | Eine View-Tabelle ist eine Basistabellen abgeleitete Tabelle, deren Definition permanent gespeichert wird. View-Tabellen enthalten selbst keine Daten, sondern repräsentieren nur eine Sicht auf die Daten.

Das Datenbanksystem vergrößert und verkleinert Tabellen automatisch, ohne dass Sie als Administrator eingreifen müssen. Durch ein datenbankinternes Striping verteilt das Datenbanksystem die zu einer Tabelle gehörenden Daten gleichmäßig auf alle Data-Volumes. Sie können nicht beeinflussen, wie die Daten auf die Data-Volumes verteilt werden, und Sie können auch nicht herausfinden, welche Tabellen in welchen Data-Volumes gespeichert sind.

Siehe auch:

SQL-Referenzhandbuch, Datendefinition, QUERY-Anweisung (query_statement), Definitionen der Systemtabellen

SQL-Tutorial, Strukturlink Tabellen, Strukturlink View-Tabellen, Strukturlink Joins: Informationen aus mehreren Tabellen, Strukturlink Datenanfrage


Tabellen-ID (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Tabellen-ID

Jede Tabelle der Datenbank hat eine Tabellen-ID fester Länge, die die Tabelle eindeutig kennzeichnet. Das Datenbanksystem verwendet die Tabellen-ID für den Zugriff auf die Tabelle. Wenn Sie mit einer SQL-Anweisung auf eine Tabelle zugreifen, geben Sie den Tabellennamen an.

Die Zuordnung des Tabellennamens zur Tabellen-ID ist im Datenbankkatalog, die Zuordnung der Tabellen-ID zu den B*-Bäumen im internen Dateiverzeichnis gespeichert.

Siehe auch:

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


Tabellenname (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Tabellenname

Jede Tabelle einer Datenbankinstanz hat einen eindeutigen Namen.

Wenn Sie in einer SQL-Anweisung einen Tabellennamen angeben, ohne einen Eigentümer oder ein Schema zu spezifizieren, dann durchsucht das Datenbanksystem den Datenbankkatalog in folgender Reihenfolge nach dem Tabellennamen:

...

1. Katalogteil des aktuellen Benutzers

2. Menge der PUBLIC-Synonyme

3. Katalogteil des Datenbankadministrators, der den aktuell angemeldeten Benutzer angelegt hat

4. Katalogteil des Datenbanksystemadministrators

5. Katalogteil des Eigentümers der Systemtabellen

Sie können auf Tabellen anderer Eigentümer/Schemas nur dann zugreifen, wenn Sie zuvor die entsprechenden Privilegien erhalten haben.

Siehe auch:

SQL-Referenzhandbuch,

● Tabellenname (table_name)

● QUERY-Anweisung (query_statement)


Task (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Task

Tasks führen Aufträge aus, die Benutzer oder der Kern an die Datenbankinstanz gestellt haben. Tasks laufen in User-Kernel-Threads. Für bestimmte Aufgaben gibt es spezielle Tasks, wie z. B. User-Tasks für das Ausführen von SQL-Anweisungen.

Siehe auch:

Konzepte des Datenbanksystems

· Übersicht der Tasks

· Übersicht der Taskzustände


Task-Zustand (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Task-Zustand

Der Task-Zustand gibt Auskunft darüber, ob eine Task gerade aktiv ist und welche Aufgabe sie gerade ausführt. Um die aktuellen Task-Zustände anzuzeigen, können Sie z. B. das Werkzeug XCONS (Datenbankkonsole) verwenden.

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Task-Zustände

Utilities, Strukturlink XCONS


Thread (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Thread

Zu einer Datenbankinstanz gehören mehrere Betriebssystem-Threads, die unter anderem für das Ausführen von Tasks zuständig sind.

Es wird zwischen User-Kernel-Threads (UKTs) und Spezial-Threads unterschieden. Die Anzahl der User-Kernel-Threads und Spezial-Threads ist abhängig von der Hardwarekonfiguration, der Anzahl der verwendeten Volumes und den eingestellten Datenbankparametern.

Siehe auch:

Konzepte des Datenbanksystems,

· Prozessstruktur

· Übersicht der Spezial-Threads

· Datenbankparameter


Timeout (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Timeout

Der Timeout-Wert legt die maximale Inaktivitätsdauer einer Datenbanksitzung fest. Die Inaktivitätsdauer ist das Zeitintervall zwischen dem Beenden einer SQL-Anweisung und dem Senden der nächsten SQL-Anweisung. Sobald der angegebene Timeout-Wert überschritten wird, schließt das Datenbanksystem die Datenbanksitzung mit einem ROLLBACK ab.

Sie können den Timeout-Wert folgendermaßen konfigurieren:

● Mit dem speziellen Datenbankparameter SESSION_TIMEOUT konfigurieren Sie den Vorschlagswert des Timeout-Werts für alle Benutzer der Datenbankinstanz.

● Beim Eingeben einer CREATE USER-Anweisung oder einer ALTER USER-Anweisung können Sie für einen Benutzer einen speziellen Timeout-Wert festlegen.

Beim Eingeben einer CREATE USERGROUP-Anweisung oder einer ALTER USERGROUP-Anweisung können Sie für eine Benutzergruppe einen speziellen Timeout-Wert festlegen.

Das Datenbanksystem verwendet für eine Datenbanksitzung immer den kleinsten dieser Timeout-Werte. Wenn Sie sich an die Datenbankinstanz anmelden, können Sie für die Dauer der Datenbanksitzung auch einen noch kleineren Timeout-Werte wählen.

Timeout-Werte geben Sie in Sekunden an.

Siehe auch:

Konzepte des Datenbanksystems, Spezielle Datenbankparameter

SQL-Referenzhandbuch, Autorisierung


Timer-Task (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Timer-Task

Die Timer-Task ist für Timeouts zuständig. Sie ist eine Task im User-Kernel-Thread.

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Tasks


Trace (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Trace

Um Meldungen des Datenbanksystems für die Fehlersuche detailliert zu protokollieren, können Sie verschiedene Traces einschalten.

Siehe auch:

Konzepte des Datenbanksystems, Traces


Trace-Writer-Task (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Trace-Writer-Task

Die Trace-Writer-Task schreibt bei einem Datenbank-Trace die entsprechende Protokolldatei. Sie ist eine Task im User-Kernel-Thread.

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Tasks


Transaktion (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Transaktion

Eine Transaktion ist eine Folge von SQL-Anweisungen, die vom Datenbanksystem als Einheit behandelt wird. Eine Transaktion bringt die Datenbank von einem konsistenten Zustand in einen anderen konsistenten Zustand. Wenn es innerhalb der Transaktion zu einem Abbruch kommt, dann bringt das Datenbanksystem die Datenbank wieder in den Zustand, in dem sie bei Beginn der Transaktion war (ROLLBACK).

Siehe auch:

Konzepte des Datenbanksystems, Transaktionen

SQL-Referenzhandbuch, Transaktionen

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Transaktionen

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Transaktionen


Transaktionsdatei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Transaktionsdatei

Die Transaktionsdatei ist eine datenbankinterne Datei im Datenbereich, in die das Datenbanksystem bei einem Savepoint die Daten aller offenen Transaktionen schreibt.

Der Log-Leser verwendet die Transaktionsdatei bei einem Restart oder einem Wiederherstellen der Datenbankinstanz, um die Transaktionsliste neu zu erzeugen.

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Transaktionsliste (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Transaktionsliste

Die Transaktionsliste ist eine datenbankinterne Liste aller offenen Transaktionen. Die Transaktionsliste befindet sich im Arbeitsspeicher. Der Transaktionseintrag einer offenen Transaktion in der Transaktionsliste enthält unter anderem Verweise auf eventuell vorhandene Redo-Log-Einträge und Undo-Log-Einträge.

Um die Transaktionsliste bei einem Restart oder einem Wiederherstellen der Datenbankinstanz neu zu erzeugen, verwendet der Log-Leser die Transaktionsdatei.

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Trefferquote (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Trefferquote

Die Trefferquote ist der Anteil erfolgreicher Zugriffe an der Gesamtzahl aller Zugriffe auf einen Cache. Ein erfolgreicher Zugriff bedeutet, dass die benötigten Daten zum Zugriffszeitpunkt bereits im Cache vorliegen.

Siehe auch:

Database Manager GUI, Strukturlink Cache-Informationen anzeigen

Database Manager CLI, Strukturlink info


Trigger (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Trigger

Ein Trigger ist eine spezielle Datenbankprozedur (Folge von Anweisungen), die das Datenbanksystem nach dem Eintreten eines bestimmten Ereignisses ausführt.

Sie können folgende Typen von Triggern definieren:

● Trigger, die ausgeführt werden, nachdem Daten in einer Basistabelle (oder in einer auf dieser Basistabelle basierenden View-Tabelle) mit einer SQL-Anweisung geändert wurden.

● System-Trigger, die das Datenbanksystem bei einem Restart der Datenbankinstanz ausführt.

Sie können beliebig viele Trigger definieren.

Siehe auch:

SQL-Referenzhandbuch

● Triggername

● CREATE TRIGGER-Anweisung (create_trigger_statement)

● CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement)


Tutorial (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Tutorial

siehe

SQL-Tutorial


U (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation U


Überschreibmodus für den Log-Bereich (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Überschreibmodus für den Log-Bereich

Mit dieser Log-Einstellung können Sie konfigurieren, ob das Datenbanksystem den Log-Bereich zyklisch überschreiben soll, ohne die Log-Einträge zuvor zu sichern.

Schalten Sie den Überschreibmodus nur dann ein, wenn es für Sie ausreichend ist, dass Sie das System gegebenenfalls nur auf dem Stand der letzten vorhandenen Datensicherung wiederherstellen können.

Siehe auch:

Konzepte des Datenbanksystems, Log-Einstellungen

Database Manager GUI, Strukturlink Log-Einstellungen ändern


Überwachung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Überwachung

Wir empfehlen, dass Sie Ihre Datenbankinstanz im Produktivbetrieb überwachen. Auf diese Weise können Sie Probleme früh erkennen und Störungen oder Ausfälle vermeiden.

Es stehen mehrere Werkzeuge zur Verfügung, mit denen Sie Datenbankinstanzen überwachen können.

Siehe auch:

Konzepte des Datenbanksystems, Überwachung


Umgebungsvariable (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Umgebungsvariable

Umgebungsvariablen enthalten Informationen über die Softwareumgebung eines Benutzers. Das Datenbanksystem, die Datenbankwerkzeuge und die Schnittstellen verwenden mehrere Umgebungsvariablen.

MaxDB-Umgebungsvariablen

Name | Beispiel | Beschreibung | System
SERVERDB | DEMODB | Name der Datenbankinstanz |
PATH | /opt/sdb/bin siehe auch Variable in der Dokumentation | Pfad zu den ausführbaren MaxDB-Dateien |
LD_ASSUME_KERNEL | 2.2.5 | Deaktivieren der neuen Threading-Bibliothek von Red Hat | Red Hat, Fedora Linux-Kernel > 2.4 MaxDB-Version < 7.6
SQLOPT |  | Optionen für die Verbindung zur Datenbankinstanz | MaxDB-Version < 7.5

Siehe auch:

Entwicklungsumgebung, Strukturlink Umgebungsvariablen


Undo-Log-Datei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Undo-Log-Datei

Das Datenbanksystem schreibt Undo-Log-Einträge (Before-Images) für Transaktionen, die Daten in der Datenbank ändern werden, in Undo-Log-Dateien im Datenbereich.

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


Undo-Log-Eintrag (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Undo-Log-Eintrag

Für jede Transaktion, die Daten in der Datenbank ändert, schreibt das Datenbanksystem Undo-Log-Einträge (Before-Images). In den Undo-Log-Einträgen speichert das Datenbanksystem die ursprünglichen Werte aller Datenbankobjekte, die die Transaktion ändern wird.

Das Datenbanksystem verwendet die Undo-Log-Einträge, wenn es nicht abgeschlossene Transaktionen rückgängig machen muss (ROLLBACK).

Siehe auch:

Konzepte des Datenbanksystems

● Protokollierung von Datenänderungen (Logging)

● Beispiel: Konsistente Sicht


Unicode (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Unicode

Unicode ist ein internationaler Standard-Zeichensatz. Im Unicode-Zeichensatz können alle in Alphabeten verwendeten Zeichen eindeutig ausdrückt werden. Der Zeichensatz ASCII ist dagegen nur für den amerikanischen und zentraleuropäischen Sprachraum gut geeignet.

Das Datenbanksystem MaxDB unterstützt Unicode gemäß ISO 10646. Intern legt das Datenbanksystem Unicode-Daten im UTF-16/UCS-2-Format ab. Hierfür benötigt es doppelt so viel Speicherplatz wie für eine Ablage von Daten im Format ASCII, weil die Kodierung mit 16 anstatt mit 8 Bit erfolgt.

Sie können Unicode in einer MaxDB-Datenbankinstanz für den Datenbankkatalog und für Anwendungsdaten verwenden.

● Datenbankkatalog:

Um die Namen von Datenbankobjekten, wie z. B. Tabellen- und Spaltennamen, in Unicode zu speichern, setzen Sie beim Anlegen der Datenbankinstanz den speziellen Datenbankparameter _UNICODE auf YES.

Sie können diesen Datenbankparameter später nicht mehr ändern.

● Anwendungsdaten:

Um die Anwendungsdaten in einer Spalte des Typs CHAR, VARCHAR oder LONG in Unicode zu speichern, wählen Sie für das Codeattribut der Spalte den Wert UNICODE.

Um UNICODE als Vorschlagswert für das Codeattribut aller Spalten der Datentypen CHAR, VARCHAR und LONG zu konfigurieren, wählen Sie für den speziellen Datenbankparameter DEFAULT_CODE den Wert UNICODE.

Um das Codeattribut einer bereits mit Daten gefüllten Spalte nachträglich zu ändern, müssen folgende Bedingungen erfüllt sein:

○ ASCII -> Unicode: Alle Werte in der Spalte passen auch nach der Konvertierung noch in diese Spalte (Unicode-Daten benötigen doppelt so viel Platz wie ASCII-Daten).

○ Unicode -> ASCII: Alle Werte der Spalte enthalten nur solche Zeichen, die es auch im ASCII-Zeichensatz gibt.

Welche Datenbankwerkzeuge unterstützen Unicode?

Datenbankwerkzeug | unterstützt Unicode *
Database Manager | ja
Loader | ja
SQL Studio | eingeschränkt (siehe SQL Studio, Strukturlink Unicode-Unterstützung)
SQLCLI | nein
Synchronization Manager | ja
Web SQL | ja
XUSER | eingeschränkt (Sie können Benutzernamen und Kennwörter in Unicode nur mit der Option -b aus einer Datei in XUSER einlesen, aber nicht direkt auf der Kommandozeile angeben)

* Beachten Sie bei Kommandozeilenprogrammen, dass die Kommandozeilenumgebung ebenfalls Unicode unterstützen muss.

Welche Schnittstellen unterstützen Unicode?

Schnittstelle | unterstützt Unicode
JDBC | ja
ODBC | ja
Perl | ja
PHP | nein
Python | eingeschränkt (die Module sdb.dbm und sdb.loader unterstützen Unicode momentan noch nicht)
SQLDBC | ja
WebDAV | ja

Siehe auch:

Konzepte des Datenbanksystems,

● Datenbankinstanz planen

● Spezielle Datenbankparameter

Referenzhandbuch, Codeattribut


Update (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Update

Bei einem Update überführen Sie die Datenbanksoftware in eine höhere Version. Sie verwenden das Programm SDBINST oder den Installation Manager.

Wenn Datenbankinstanzen die zu aktualisierende Datenbanksoftware verwenden, dann führen Sie ein Upgrade durch.

Siehe auch:

Installationshandbuch, Strukturlink Installation und Update der Datenbanksoftware


Upgrade (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Upgrade

Bei einem Upgrade überführen Sie Datenbankinstanzen und Datenbanksoftware in eine höhere Version. Sie verwenden das Programm SDBUPD.

Wenn keine Datenbankinstanz die zu aktualisierende Datenbanksoftware verwendet, dann führen Sie ein Update durch.

Siehe auch:

Installationshandbuch, Strukturlink Aktualisierung von Datenbankinstanzen inklusive Server-Software


User-Kernel-Thread (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation User-Kernel-Thread

Ein User-Kernel-Thread (UKT) bündelt mehrere Tasks, die Client-Anfragen ausführen. Eine Datenbankinstanz hat in der Regel mehrere User-Kernel-Threads. Die Anzahl der User-Kernel-Threads und die Anzahl und Typen von Tasks, die in einem User-Kernel-Thread laufen können, konfigurieren Sie mit Datenbankparametern.

Siehe auch:

Konzepte des Datenbanksystems

· Prozessstruktur

· Datenbankparameter


User-Task (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation User-Task

User-Tasks sind Tasks im User-Kernel-Thread. User-Tasks führen SQL-Anweisungen aus.

Wenn ein Datenbankbenutzer eine Datenbanksitzung eröffnet, ordnet das Datenbanksystem diesem Datenbankbenutzer eine User-Task fest zu.

Die Anzahl der zur Verfügung stehenden User-Tasks konfigurieren Sie mit dem allgemeinen Datenbankparameter MAXUSERTASKS.

Siehe auch:

Konzepte des Datenbanksystems,

● Übersicht der Tasks

● Allgemeine Datenbankparameter


Utility-Task (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Utility-Task

Die Utility-Task ist eine Task im User-Kernel-Thread, die Verwaltungsaufgaben durchführt.

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Tasks


V (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation V


Variable (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Variable

siehe

● Variablen in der Dokumentation

● Parameter in SQL-Anweisungen (Host-Variablen)


Variablen in der Dokumentation (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Variablen in der Dokumentation

In der Dokumentation wird die Syntax von Kommandos mit Hilfe von Variablen beschrieben. Variablen in der Dokumentation sind durch spitze Klammern gekennzeichnet: <variable>.

Die Syntax des DBM-Kommandos db_create ist in der Dokumentation wie folgt beschrieben:

dbmcli db_create <database_name> <dbm_operator>,<dbm_operator_password>

Um das DBM-Kommando auszuführen, geben Sie Werte für die Variablen <database_name>, <dbm_operator>, <dbm_operator_password> an, zum Beispiel:

dbmcli db_create DEMODB DBM,DBM

Die folgende Tabelle zeigt die am häufigsten verwendeten Variablen und Beispielwerte für diese Variablen.

Variable | Beispielwerte | Beschreibung
<arch> | ia64 | Architektur (Prozessor)
<build> | 24 | Build-Nummer der Datenbanksoftware (Teil der Versionsnummer)
<computer_name> | GENUA PARMA SIENA COMO | Name des Rechners
<database_computer> | GENUA PARMA SIENA COMO | Name des Rechners, auf dem die Datenbankinstanz installiert ist
<database_name> | DEMODB TESTDB SAMPLEDB | Name der Datenbankinstanz (Datenbankname)
<database_server> |  | siehe <database_computer>
<database_user> | MONA DAVID BORIS NINA | Datenbankbenutzer
<database_user_password> | RED BLUE PINK BLACK | Kennwort des Datenbankbenutzers
<dbm_operator> | DBADMIN DBM OLEG ELENA JULIE | Name des Database Manager-Benutzers (DBM-Benutzers)
<dbm_operator_password> | SECRET DBM MONDAY SUNDAY TUESDAY | Kennwort des Database Manager-Benutzers (DBM-Benutzers)
<dependent_path> | Nur Software-Installation: Microsoft Windows*: C:\Program Files\sdb\<version> UNIX/Linux: /opt/sdb/<version> Installation von Software und Datenbankinstanz: Microsoft Windows*: C:\Program Files\sdb\<database_name> UNIX/Linux: /opt/sdb/<database_name> | Verzeichnis, in dem sich die von der Datenbankversion abhängige Server-Software befindet siehe Installationshandbuch, Strukturlink Verzeichnisse
<file_name> | sample.txt | Dateiname
<independent_data_path> | Microsoft Windows*: c:\Documents and Settings\All Users\Application Data\sdb\data UNIX/Linux: /var/opt/sdb/data | Verzeichnis, in dem sich die Daten, Konfigurationsinformationen und Arbeitsverzeichnisse von Datenbankinstanzen und Anwendungen befinden Um den Pfad dieses Verzeichnisses anzuzeigen, können Sie das DBM-Kommando dbm_getpath verwenden: dbmcli dbm_getpath IndepDataPath siehe Installationshandbuch, Strukturlink Verzeichnisse
<independent_program_path> | Microsoft Windows*: C:\Program Files\sdb\programs UNIX/Linux: /opt/sdb/programs | Verzeichnis, in dem sich die von den Datenbankinstanzen und Anwendungen gemeinsam genutzten Programme und Bibliotheken befinden Um den Pfad dieses Verzeichnisses anzuzeigen, können Sie das DBM-Kommando dbm_getpath verwenden: dbmcli dbm_getpath IndepProgPath siehe Installationshandbuch, Strukturlink Verzeichnisse
<inst_profile> | JDBC | Installationsprofil
<os> | Microsoft Windows | Betriebssystem
<os_user> | ANNA | Name des Betriebssystembenutzers
<os_user_password> | MAY | Kennwort des Betriebssystembenutzers
<package_name> | a) APO LC APPS b) 20050512183812.prt | a) Name des Softwarepakets bei der Installation b) Name der Kommandodatei des Loader (siehe Loader, Strukturlink Kommandodatei)
<password> | SECRET | Kennwort
<path> | C:\test | Pfad
<sdb_user> | sdb | UNIX/Linux: spezieller Betriebssystembenutzer für MaxDB siehe Konzepte des Datenbanksystems, <sdb_user> (spezieller Betriebssystembenutzer)
<sdba_group> | sdba | UNIX/Linux: spezielle Betriebssystembenutzergruppe für MaxDB siehe Konzepte des Datenbanksystems, <sdba_group> (spezielle Betriebssystembenutzergruppe)
<sysdba_user> | DBADMIN | Name des Datenbanksystemadministrators (SYSDBA-Benutzers)
<sysdba_user_password> | SECRET | Kennwort des Datenbanksystemadministrators (SYSDBA-Benutzers)
<tool> | Loader | Datenbankwerkzeug
<user_home> | Microsoft Windows: C:\Documents and Settings\anna UNIX/Linux: /home/anna | Home-Verzeichnis des Betriebssystembenutzers
<user_key> | SAMPLEKEY | Benutzerschlüssel
<user_name> |  | siehe <database_user>
<version> | 7.6.00.12 | Versionsnummer der Datenbanksoftware
<virtual_server_name> | VIRTUAL_SERVER HOTEL_VIRTUAL | Name des virtuellen Rechners in einem Hot-Standby-System siehe Konzepte des Datenbanksystems, Hot-Standby

* Systemvorschlag, wenn noch keine MaxDB-Software installiert wurde. Wenn bereits eine ältere MaxDB-Version vorhanden ist, dann schlägt das Installationsprogramm die Pfade dieser Version für die neue Installation vor.


Verschlüsselung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Verschlüsselung

siehe SSL/TLS


Version (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Version

Die Datenbanksoftware hat eine Versionsnummer. Die Versionsnummer widerspiegelt die Version des Datenbankkerns.

Die Versionen von MaxDB und SAP liveCache verwenden dieselben Versionsnummern.

Die Versionsnummer der Datenbanksoftware ist identisch mit der Version des Werkzeugs Database Manager CLI. Die Software für das Programm Database Manager CLI ist Bestandteil des Basis-Pakets der Datenbanksoftware und kann nur mit ihr zusammen installiert werden.

Um die Version Ihrer Datenbanksoftware anzuzeigen verwenden Sie das DBM-Kommando Strukturlink dbm_version. Wenn Sie bereits Datenbankinstanzen angelegt haben, können Sie auch das DBM-Kommando Strukturlink db_enum verwenden.

Siehe auch:

Konzepte des Datenbanksystems, Versionsnotierung

Installationshandbuch,

· Strukturlink Installation und Update der Datenbanksoftware

· Strukturlink Aktualisierung von Datenbankinstanzen inklusive Server-Software


Verwaltung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Verwaltung

Admistratoren müssen im produktiven Betrieb regelmäßig eine Reihe von Verwaltungsaufgaben durchführen, wie z. B. Datensicherungen.

Wenn ein bestimmtes Ereignis, wie z. B. ein Systemausfall, eintritt, müssen Administratoren spezielle Verwaltungsaufgaben durchführen, wie z. B. ein Wiederherstellen der Datenbankinstanz.

Zur Verwaltung von Datenbankinstanzen stehen mehrere Datenbankwerkzeuge zur Verfügung.

Siehe auch:

Konzepte des Datenbanksystems, Verwaltung


Verzeichnisstruktur (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Verzeichnisstruktur

Das Installationsprogramm legt bei der Installation eine Reihe von Verzeichnissen für die MaxDB-Software an.

Siehe auch:

Installationshandbuch, Strukturlink Verzeichnisse


View (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation View

siehe View-Tabelle


View-Tabelle (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation View-Tabelle

Eine View-Tabelle ist eine Sicht auf eine existierende Tabelle. Eine View-Tabelle ist nie physisch vorhanden, sondern wird vom Datenbanksystem aus den Zeilen der zugrundeliegenden Basistabelle(n) gebildet, wenn ein Benutzer in einer SQL-Anweisung diese View-Tabelle angegeben hat.

Siehe auch:

SQL-Referenzhandbuch, CREATE VIEW-Anweisung (create_view_statement)

SQL-Tutorial, Strukturlink View-Tabellen


Virtueller Rechner (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Virtueller Rechner

in Hot-Standby-Systemen

Der virtuelle Rechner ist der Rechner im Cluster, auf dem aktuell die Master-Instanz des Hot-Standby-Systems läuft.

Siehe auch:

Konzepte des Datenbanksystems, Architektur eines Hot-Standby-Systems


VMAKE (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation VMAKE

VMAKE ist das MaxDB-eigene make-Programm, mit dem Sie MaxDB-Software aus dem MaxDB-Quelltext erstellen können.

Siehe auch:

Dokumentation zur Strukturlink Entwicklungsumgebung

Konzepte des Datenbanksystems, Datenbankwerkzeuge


Vollständige Datensicherung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Vollständige Datensicherung

Bei einer vollständigen Datensicherung sichern Sie den gesamten Inhalt des Datenbereichs auf einen Datenträger.

Siehe auch:

Konzepte des Datenbanksystems, Daten sichern

Database Manager GUI, Strukturlink Sichern

Database Manager CLI, Strukturlink Sichern und Wiederherstellen von Datenbankinstanzen

Datenbankverwaltung im CCMS, Strukturlink Datensicherung einplanen


Volume (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Volume

Das Datenbanksystem speichert die Daten und Log-Einträge einer Datenbankinstanz permanent in den Volumes (Data- und Log-Volumes).

Siehe auch:

Konzepte des Datenbanksystems, Volumes (permanenter Speicher)

Database Manager GUI, Strukturlink Verwalten von Datenbankinstanzen

Database Manager CLI, Strukturlink Konfigurieren von Datenbankinstanzen

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Volumes

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Volumes


Vorlage für eine Datenbankinstanz (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Vorlage für eine Datenbankinstanz

Installation Manager und Database Manager GUI stellen Vorlagen für das Anlegen einer Datenbankinstanz zur Verfügung, in denen die wichtigsten Eigenschaften der Datenbankinstanz bereits konfiguriert sind.

Siehe auch:

Konzepte des Datenbanksystems, Vorlagen für Datenbankinstanzen


Vorschlagsparameterdatei (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Vorschlagsparameterdatei

Die Vorschlagsparameterdatei cserv.pcf enthält die Vorschlagswerte für die Datenbankparameter und eine Beschreibung der erlaubten Werte.

Siehe auch:

Konzepte des Datenbanksystems,

· Konfigurationsdateien

· Datenbankparameter


vserver (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation vserver

siehe X-Server


vtrace (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation vtrace

siehe Datenbank-Trace


W (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation W


Web DBM (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Web DBM

Web-basiertes Datenbankwerkzeug zum Anlegen und Verwalten von Datenbankinstanzen und DBM-Benutzern.

Die Weiterentwicklung des Web DBM wurde eingestellt. Der Web DBM ist nur bis einschließlich Version 7.5 im MaxDB-Softwarepaket enthalten.

Sie können mit dem Web DBM 7.5 jedoch auch Datenbankinstanzen der Version 7.6 verwalten.

Siehe auch:

SAP-Hinweis 856940 (Bestellung von Web-Tools)


Web Server (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Web Server

Der MaxDB Web Server ist ein Programm, das Web-Seiten über HTTP (Hypertext Transfer Protocol) an Browser und andere Anwendungen ausliefert.

Die Weiterentwicklung des MaxDB Web Servers wurde eingestellt. Der Web Server ist nur bis einschließlich Version 7.5 im MaxDB-Softwarepaket enthalten.

Siehe auch:

SAP-Hinweis 856940 (Bestellung von Web-Tools)


Web Server Manager (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Web Server Manager

Der Web Server Manager bietet eine web-basierte Oberfläche, über die Sie die Konfiguration des Web Server und der Web Tools ändern können.

Die Weiterentwicklung des Web Server Manager wurde eingestellt. Der Web Server Manager ist nur bis einschließlich Version 7.5 im MaxDB-Softwarepaket enthalten.

Siehe auch:

SAP-Hinweis 856940 (Bestellung von Web-Tools)


Web SQL (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Web SQL

Web-basiertes Datenbankwerkzeug für den Zugriff auf Daten und den Datenbankkatalog, SQL-Abfragen und das Anlegen und Verwalten von Datenbankobjekten und Datenbankbenutzern.

Siehe auch:

Dokumentation zum Strukturlink Web SQL Studio

Konzepte des Datenbanksystems, Datenbankwerkzeuge


Web Tool (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Web Tool

Unter dem Begriff „Web Tools“ sind diejenigen Datenbankwerkzeuge zusammengefasst, die über eine Web-Oberfläche verfügen und die Sie mit einem Web-Browser bedienen können.

Es stehen folgende Web Tools zur Verfügung:

· Strukturlink Web SQL

· Strukturlink WebDAV

Die Weiterentwicklung der folgenden Web Tools wurde eingestellt: Web DBM, Web Server, Web Server Manager. Diese Web Tools sind nur bis einschließlich Version 7.5 im MaxDB-Softwarepaket enthalten.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankwerkzeuge

SAP-Hinweis 856940 (Bestellung von Web-Tools)


WebDAV (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation WebDAV

Das MaxDB WebDAV-Servlet ist eine Implementierung des im RFC2518 definierten WebDAV Protokolls. Mit dem MaxDB WebDAV-Servlet können Sie eine MaxDB-Datenbankinstanz als Ablage für Dokumente nutzen. Benutzer können auf Dokumente in dieser Dokumentenablage mit dem WebDAV-Protokoll zugreifen.

Siehe auch:

Dokumentation zu Strukturlink WebDAV


Werkzeug (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Werkzeug

siehe Datenbankwerkzeug


Wertebereich (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Wertebereich

Wertebereichsdefinitionen (auch Domänendefinition genannt) erlauben die Festlegung und Benennung von Wertebereichen für Tabellenspalten.

Jede Wertebereichsdefinition hat einen innerhalb des gesamten Datenbanksystems eindeutigen Namen. Wenn ein Wertebereich ohne Angabe eines Eigentümers definiert wurde, dann durchsucht das Datenbanksystem die Katalogteile in folgender Reihenfolge nach dem Wertebereich:

...

1. Katalogteil des aktuellen Benutzers

2. Katalogteil des Datenbankadministrators, der den aktuellen Benutzer erzeugt hat

3. Katalogteil des Datenbanksystemadministrators

Siehe auch:

SQL-Referenzhandbuch, Domänenname

SQL-Tutorial, Strukturlink Wertebereiche


Wiederherstellen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Wiederherstellen

Beim Wiederherstellen bringen Sie eine Datenbankinstanz in den letzten konsistenten Zustand, den sie vor einem Systemausfall (z. B. einem Festplattenschaden) hatte. Hierfür benötigen Sie lückenlose Daten- und Log-Sicherungen.

Sie können eine Datenbankinstanz auch in einem Zustand wiederherstellen, den sie zu einem anderen Zeitpunkt in der Vergangenheit hatte.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankinstanz wiederherstellen

Database Manager GUI, Strukturlink Wiederherstellen von Daten

Database Manager CLI, Strukturlink recover_start


X (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation X


X-Server (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation X-Server

Der X-Server ist der Kommunikationsserver des Datenbanksystems. Er lauscht auf einem Service-Port auf Verbindungsanfragen von Datenbankanwendungen und Datenbankwerkzeugen.

Unter UNIX und Linux heißt der X-Server-Prozess vserver.

Siehe auch:

Dokumentation Utilities, Strukturlink X-Server


XCONS (Datenbankkonsole) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation XCONS (Datenbankkonsole)

XCONS (Datenbankkonsole) ist ein Datenbankwerkzeug, mit dem Sie einen schnellen Überblick über die vom Datenbanksystem belegten Betriebssystemressourcen, die Aufteilung der Datenbanksitzungen auf Threads sowie den Status der aktiven Datenbanksitzungen erhalten.

Siehe auch:

Dokumentation Utilities, Strukturlink XCONS

Konzepte des Datenbanksystems, Datenbankwerkzeuge


XUSER (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation XUSER

XUSER ist ein Datenbankwerkzeug, mit dem Sie XUSER-Einträge für beliebige Benutzer definieren und unter einem Schlüsselnamen ablegen können. XUSER-Einträge erleichtern Datenbankwerkzeugen die Verbindungsaufnahme zur Datenbankinstanz. Auch SAP-Systeme unterstützen die Verwendung von XUSER.

Siehe auch:

Dokumentation Utilities, Strukturlink XUSER

Konzepte des Datenbanksystems, Datenbankwerkzeuge


Y (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Y


Z (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Z


Zeile (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Zeile

Eine Zeile ist eine geordnete Folge von Werten. Die Zeile ist die kleinste Einheit von Daten, die in eine Tabelle eingefügt oder aus einer Tabelle gelöscht werden kann. Jede Zeile einer Tabelle hat dieselbe Anzahl von Spalten und enthält für jede Spalte einen Wert.


SQL-Referenzhandbuch (SAP-Bibliothek - Grundwissen)

SQL-Referenzhandbuch

In dieser Dokumentation wird die Syntax und Semantik der SQL-Anweisungen des Datenbanksystems MaxDB vorgestellt.

Eine SQL-Anweisung führt eine Operation auf der Datenbankinstanz aus. Die SQL-Anweisungen wurden nach der Art der Operation in folgenden Gruppen eingeteilt:

● Datendefinition

● Autorisierung

● Datenmanipulation

● Datenanfrage

● Transaktionen

● Statistiken

Überblicksinformationen

● SQL-Anweisungen: Überblick

● Häufig verwendete Syntaxelemente: Überblick

● Funktionen: Überblick

● Namen: Überblick

● Privilegien: Überblick

● Syntaxverzeichnis

● Systemtabellen

SQL-Anweisungen in Beispielen

Die Beispiele im SQL-Referenzhandbuch basieren auf dem im SQL-Tutorial vorgestellten Datenbankschema HOTEL.

● Strukturlink SQL-Tutorial

Informationen zum Datenbanksystem

● Konzepte des Datenbanksystems

● Glossar

● Technische Restriktionen

● Restriktionen für SQL-Anweisungen

● SQL-Modus ORACLE


Datendefinition (SAP-Bibliothek - Grundwissen)

Datendefinition

In den folgenden Abschnitten wird die vom Datenbanksystem verwendete Sprache zur Datendefinition (Data Definition Language, DDL) vorgestellt.

SQL-Anweisungen zur Datendefinition

CREATE TABLE-Anweisung | DROP TABLE-Anweisung | ALTER TABLE-Anweisung RENAME TABLE-Anweisung RENAME COLUMN-Anweisung EXISTS TABLE-Anweisung
CREATE SCHEMA-Anweisung | RENAME SCHEMA-Anweisung | DROP SCHEMA-Anweisung
CREATE DOMAIN-Anweisung | DROP DOMAIN-Anweisung |
CREATE SEQUENCE-Anweisung | DROP SEQUENCE-Anweisung |
CREATE SYNONYM-Anweisung | DROP SYNONYM-Anweisung | RENAME SYNONYM-Anweisung
CREATE VIEW-Anweisung | DROP VIEW-Anweisung | RENAME VIEW-Anweisung
CREATE INDEX-Anweisung | DROP INDEX-Anweisung | ALTER INDEX-Anweisung RENAME INDEX-Anweisung
CREATE DBPROC[EDURE]-Anweisung | DROP DBPROC[EDURE]-Anweisung |
CREATE SYSTEM TRIGGER-Anweisung | DROP SYSTEM TRIGGER-Anweisung |
CREATE FUNCTION-Anweisung | DROP FUNCTION-Anweisung |
CREATE TRIGGER-Anweisung | DROP TRIGGER-Anweisung |
COMMENT ON-Anweisung |  |

Beispiele

SQL-Tutorial, Strukturlink Datendefinition


Datenintegrität absichern (SAP-Bibliothek - Grundwissen)

Datenintegrität absichern

Das Datenbanksystem bietet Ihnen folgende Hilfsmittel, um die Datenintegrität sicherzustellen:

· Integritätsregeln: Die Angabe von Integritätsregeln, die sich auf eine Tabelle beziehen, ist möglich (siehe CONSTRAINT-Definition).

· Schlüssel: Für jede Tabelle kann ein aus einer oder mehreren Spalte(n) bestehender Schlüssel definiert werden, dessen Eindeutigkeit das Datenbanksystem sicherstellt. Dieser Schlüssel kann sich auch aus Spalten unterschiedlichen Datentyps zusammensetzen (siehe Schlüsseldefinition).

· UNIQUE-Definition: Über den Schlüssel hinaus kann für weitere Spalten bzw. Spaltenkombinationen die Eindeutigkeit ihrer Wertebelegung erzwungen werden (siehe UNIQUE-Definition für "alternate keys").

· NOT NULL: Für einzelne Spalten kann durch die Angabe von NOT NULL eine Wertebelegung ungleich des NULL-Wertes erzwungen werden (siehe Spaltendefinition).

· DEFAULT-Definition: Pro Spalte kann eine Wertebelegung vordefiniert werden (siehe DEFAULT-Spezifikation).

· Referentielle Integritätsbedingungen: Durch referentielle Integritätsbedingungen können Lösch- und Existenzabhängigkeiten zwischen Zeilen zweier Tabellen deklarativ festgelegt werden (siehe Referentielle CONSTRAINT-Definition).

· Datenbankprozeduren und Trigger: Komplexe Integritätsregeln, die Zugriffe auf weitere Tabellen erfordern, lassen sich durch Datenbankprozeduren oder Trigger formulieren.


CREATE TABLE-Anweisung (create_table_statement) (SAP-Bibliothek - Grundwissen)

CREATE TABLE-Anweisung (create_table_statement)

Eine CREATE TABLE-Anweisung (create_table_statement) definiert eine Basistabelle. Es gibt drei syntaktische Möglichkeiten, eine Tabelle anzulegen.

Syntax

<create_table_statement> ::=
CREATE TABLE <table_name> (<column_definition>[,<table_description_element>,...])
[IGNORE ROLLBACK] [<sample_definition>]
| CREATE TABLE <table_name> [(<table_description_element>,...)]
[IGNORE ROLLBACK] [<sample_definition>] AS <query_expression> [<duplicates_clause> ]
| CREATE TABLE <table_name> LIKE <table_name> [IGNORE ROLLBACK]

<table_description_element> ::=
<column_definition>
| <constraint_definition>
| <key_definition>
| <referential_constraint_definition>
| <unique_definition>

Beispiele

SQL-Tutorial, Strukturlink Tabellen, Strukturlink Primärschlüssel, Strukturlink Constraints, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen, Strukturlink Indizes, Strukturlink Wertebereiche

Erläuterung

Die Ausführung einer CREATE TABLE-Anweisung führt zur Ablage von Daten im Datenbankkatalog, die die Tabelle (genannt Basistabelle) beschreiben. Diese Daten heißen Metadaten.

Eine CREATE TABLE-Anweisung darf höchstens eine Schlüsseldefinition (key_definition) enthalten.

Wenn im Tabellennamen (table_name) kein Schemaname angegeben ist, wird implizit das aktuelle Schema angenommen. Der Tabellenname darf nicht mit dem Namen einer bereits existierenden Tabelle des Schemas übereinstimmen.

Der aktuelle Benutzer muss das CREATEIN-Privileg für das implizit oder explizit im Tabellennamen angegebene Schema besitzen. Der aktuelle Benutzer wird zum Eigentümer der erzeugten Tabelle. Der Eigentümer erhält das INSERT-, UPDATE-, DELETE- und SELECT-Privileg für diese Tabelle. Wenn es sich nicht um eine temporäre Tabelle handelt, erhält der Eigentümer zusätzlich das INDEX-, REFERENCES- und ALTER-Privileg.

Siehe auch:

Restriktionen für SQL-Anweisungen

Schemazugehörigkeit einer Tabelle

· Der Schemaname ist vor dem Tabellennamen angegeben: Temporäre Tabellen werden durch die Angabe des Schemas TEMP vor ihren Namen gekennzeichnet.
Wenn eine Tabelle zu einem von TEMP verschiedenen Schema gehört, muss der aktuelle Benutzer das CREATEIN-Privileg für das angegebene Schema besitzen.

· Der Schemaname ist nicht angegeben: Die Tabelle gehört zum aktuellen Schema. Dieses ist entweder das Schema, das den Namen des aktuellen Benutzers trägt, oder das in der SET CURRENT SCHEMA-Anweisung angegebene Schema.

CREATE TABLE … AS <query_expression> …

· Wenn kein QUERY-Ausdruck (query_expression) angegeben ist, muss die CREATE TABLE-Anweisung mindestens eine Spaltendefinition (column_definition) enthalten.

· Bei Angabe eines QUERY-Ausdrucks wird eine Basistabelle definiert, die die gleiche Struktur wie die durch den QUERY-Ausdruck definierte Ergebnistabelle besitzt.
Wenn Spaltendefinitionen angegeben sind, darf die Spaltendefinition nur aus einem Spaltennamen bestehen und die Anzahl der Spaltendefinitionen muss der Anzahl der Spalten der durch den QUERY-Ausdruck erzeugten Ergebnistabelle entsprechen.
Der Datentyp (data_type) der i-ten Spalte der Basistabelle entspricht dem der i-ten Spalte der durch den QUERY-Ausdruck erzeugten Ergebnistabelle.
Die Ergebnistabelle darf auch LONG-Spalten enthalten.
Wenn keine Spaltendefinitionen angegeben sind, werden die Spaltennamen der Ergebnistabelle übernommen.
Die Zeilen der Ergebnistabelle werden implizit in die erzeugte Basistabelle eingefügt. Durch die DUPLICATES-Klausel kann das Verhalten beim Auftreten von Schlüsselkollisionen gesteuert werden.
Für den QUERY-Ausdruck gelten einige Einschränkungen, die auch für die INSERT-Anweisung gelten.

LIKE <table_name>

Die Angabe von LIKE <table_name> bewirkt das Anlegen einer leeren Basistabelle, die die gleiche Struktur wie diese Tabelle aus Sicht des aktuellen Benutzers besitzt, d.h. sie besitzt alle Spalten mit den gleichen Spaltennamen und -definitionen wie diese Tabelle, die dem Benutzer bekannt sind. Diese Sicht muss nicht mit der tatsächlichen Struktur der angegebenen Tabelle übereinstimmen, da dem Benutzer durch eingeschränkte Privilegierung nicht alle Spalten bekannt sein müssen.

Die angegebene Tabelle muss eine Basistabelle, eine View-Tabelle oder ein Synonym bezeichnen. Der Benutzer muss mindestens ein Privileg für diese Tabelle besitzen.

Der aktuelle Benutzer ist der Eigentümer der Basistabelle.

Wenn alle Schlüsselspalten der nach LIKE angegebenen Tabelle in der Basistabelle enthalten sind, bilden diese die Schlüsselspalten dieser Tabelle. Ist dies nicht der Fall, wird vom Datenbanksystem implizit eine Schlüsselspalte SYSKEY CHAR(8) BYTE angelegt, die den Schlüssel der Basistabelle bildet.

DEFAULT-Spezifikation en der Spalten oder CONSTRAINT-Definition en für Spalten, die in die Basistabelle übernommen werden, gelten auch für die neu erzeugte Basistabelle.

IGNORE ROLLBACK

Die Angabe von IGNORE ROLLBACK ist optional und nur für temporäre Tabellen zulässig. Eine temporäre Tabelle mit diesem Merkmal unterliegt nicht dem Transaktionsmechanismus, d.h. durch Zurücksetzen einer Transaktion werden die diese Tabelle betreffenden Änderungen nicht rückgängig gemacht.

SQL-Anweisungen, um Tabelleneigenschaften zu verändern

· Hinzufügen, Löschen von Spalten, Verändern von Datentypen, Verändern der CONSTRAINT-Definition: ALTER TABLE-Anweisung

· Umbenennen von Spalten: RENAME COLUMN-Anweisung

· Umbenennen der Tabelle: RENAME TABLE-Anweisung


Spaltendefinition (column_definition) (SAP-Bibliothek - Grundwissen)

Spaltendefinition (column_definition)

Eine Spaltendefinition (column_definition) definiert eine Spalte einer Tabelle. Name und Datentyp jeder Spalte werden durch Spaltenname column_name und Datentyp data_type bestimmt. Die Spaltennamen müssen innerhalb einer Basistabelle eindeutig sein.

Syntax

<column_definition> ::= <column_name> <data_type> [<column_attributes>]
| <column_name> <domain_name> [<column_attributes>]

Erläuterung

Wenn das Spaltenattribut column_attributes [PRIMARY] KEY angegeben ist, darf die CREATE TABLE-Anweisung keine Schlüsseldefinition enthalten.

Eine Spaltendefinition darf nur aus einem Spaltennamen column_name bestehen, wenn in der CREATE TABLE-Anweisung ein QUERY-Ausdruck query_expression verwendet wird.

<domain_name>

Wenn Spaltenname und Domänenname domain_name, also der Name eines Wertebereiches, angegeben werden, muss durch den Domänennamen ein existierender Wertebereich identifiziert werden. Der angegebenen Spalte wird der Datentyp und die Länge des Wertebereichs zugewiesen. Falls der Wertebereich eine CONSTRAINT-Definition besitzt, hat dies die gleiche Wirkung wie die Angabe der entsprechenden CONSTRAINT-Definition im Spaltenattribut der Spaltendefinition.

NOT NULL-Spalten

Spalten, die Bestandteil des Schlüssels sind, oder für die NOT NULL definiert wurde, heißen NOT NULL-Spalten. In diese kann kein NULL-Wert eingefügt werden.

· Pflichtspalten: NOT NULL-Spalten, für die keine DEFAULT-Spezifikation als Spaltenattribut vereinbart wurde, heißen Pflichtspalten. Beim Einfügen einer Zeile muss für diese Spalte immer ein Wert angegeben werden.

· Optionale Spalten: Spalten, die keine Pflichtspalten sind, heißen optionale Spalten. Für diese Spalten braucht beim Einfügen einer Zeile kein Wert angegeben zu werden. Wenn für die Spalte eine DEFAULT-Spezifikation existiert, wird der Vorschlagswert (DEFAULT-Wert) in die Spalte eingetragen. Existiert keine DEFAULT-Spezifikation, wird ein NULL-Wert in die Spalte eingetragen.

Siehe auch:

Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp

Restriktionen für SQL-Anweisungen


Datentyp (data_type) (SAP-Bibliothek - Grundwissen)

Datentyp (data_type)

Bei einer Spaltendefinition (column_definition) können neben den Spaltennamen column_name die Datentypen angegeben werden.

Grundsätzlich werden folgende Datentypen unterschieden:

● NULL-Wert

● Spezial-NULL-Wert

● Nicht-NULL-Werte

Zeichenkette, LONG-Spalte, Zahl, Datumswert, Zeitwert, Zeitstempelwert, BOOLEAN

Die Nicht-NULL-Werte können mit Hilfe des Syntaxelements data_type angegeben werden.

Syntax

<data_type> ::=
CHAR[ACTER] [(<unsigned_integer>)] [ASCII | BYTE | UNICODE]
| VARCHAR [(<unsigned_integer>)] [ASCII | BYTE | UNICODE]
| LONG [VARCHAR] [ASCII | BYTE | UNICODE]
| BOOLEAN
| FIXED (<unsigned_integer> [,<unsigned_integer>])
| FLOAT (<unsigned_integer>)
| INT[EGER]
| SMALLINT
| DATE | TIME | TIMESTAMP

Für folgende Zeichenketten kann gegebenenfalls bei einer Spaltendefinition column_definition zusätzlich ein Codeattribut (ASCII, BYTE oder UNICODE) angegeben werden: CHAR[ACTER], VARCHAR, LONG[VARCHAR]

Beispiele

SQL-Tutorial, Strukturlink Tabellen, Strukturlink Nummerngenerator für eine einzelne Spalte einer Tabelle

Erläuterung

Neben den oben definierten Datentypen werden in einer Spaltendefinition auch die folgenden Datentypen zugelassen und wie folgt auf die zuerst genannten Datentypen abgebildet:

Datentyp | wird abgebildet auf
BINARY(p) | FIXED(p)
DEC[IMAL](p,s) | FIXED(p,s)
DEC[IMAL](p) | FIXED(p)
DEC[IMAL] | FIXED(5)
DOUBLE PRECISION | FLOAT(38)
FLOAT | FLOAT(16)
FLOAT(39..64) | FLOAT(38)
LONG VARCHAR | LONG
NUMERIC(p,s) | FIXED(p,s)
NUMERIC(p) | FIXED(p)
NUMERIC | FIXED(5)
REAL(p) | FLOAT(p)
REAL | FLOAT(16)
SERIAL | FIXED(10) DEFAULT SERIAL
SERIAL(p) | FIXED(10) DEFAULT SERIAL(p)

Siehe auch:

Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp

SQL-Tutorial, Strukturlink Umwandeln von Werten


CHAR[ACTER] (SAP-Bibliothek - Grundwissen)

CHAR[ACTER]

Mit dem Datentyp (data_type) CHAR[ACTER] wird eine alphanumerische Spalte definiert. Die Angabe eines Längenattributs n ist optional. Ist kein Längenattribut angegeben, wird n=1 angenommen.

CHAR[ACTER] [(n)]: 0<n<=8000
CHAR[ACTER] [(n)] UNICODE: 0<n<=4000

Das Datenbanksystem entscheidet in Abhängigkeit von n, ob die Werte der Spalte mit fester oder variabler Länge abgelegt werden. Wenn die Ablage unabhängig von n in variabler Länge erwünscht ist, muss VARCHAR angegeben werden.

Der Datentyp CHAR[ACTER] wird bei der Spaltendefinition angegeben, gegebenenfalls mit Codeattribut.


VARCHAR (SAP-Bibliothek - Grundwissen)

VARCHAR

Der Datentyp (data_type) VARCHAR definiert eine alphanumerische Spalte. Die Angabe eines Längenattributs n ist optional. Ist kein Längenattribut angegeben, wird n=1 angenommen.

VARCHAR [(n)]: 0<n<=8000
VARCHAR [(n)] UNICODE: 0<n<=4000

Verwenden Sie VARCHAR (n), wenn die Werte der Spalte unabhängig von n mit variabler Länge abgelegt werden sollen.

Der Datentyp VARCHAR wird bei der Spaltendefinition angegeben, gegebenenfalls mit Codeattribut


LONG [VARCHAR] (SAP-Bibliothek - Grundwissen)

LONG [VARCHAR]

Mit dem Datentyp (data_type) LONG [VARCHAR] wird eine alphanumerische Spalte beliebiger Länge (nicht für temporäre Tabellen) definiert. Der Datentyp LONG (siehe auch: Glossar, LONG-Wert) wird bei der Spaltendefinition angegeben, gegebenenfalls mit Codeattribut.

● LONG [VARCHAR] [ASCII | BYTE]: Es können maximal 2 GB Zeichen in einer LONG-Spalte geschrieben werden.

● LONG [VARCHAR] UNICODE: Es können maximal 2 GB Bytes in einer LONG-Spalte geschrieben werden.

Erläuterung

Auf eine LONG-Spalte können nur wenige Funktionen angewendet werden: DECODE, LENGTH und SUBSTR.

LONG-Spalten sind nicht untereinander vergleichbar. Inhalte von LONG-Spalten sind auch nicht mit Zeichenketten oder mit anderen Datentypen vergleichbar.

LONG-Spalten dürfen als Spaltenattribut nur NOT NULL oder eine DEFAULT-Spezifikation erhalten.

LONG-Spalten können beispielsweise in folgenden SQL-Anweisungen und Syntaxelementen verwendet werden:

● INSERT-Anweisung

● UPDATE-Anweisung

● NULL-Prädikat

● Selektierte Spalten


Codeattribut (SAP-Bibliothek - Grundwissen)

Codeattribut

Für Spaltenwerte mit folgenden Datentypen kann gegebenenfalls zusätzlich ein Codeattribut angegeben werden: CHAR[ACTER], VARCHAR, LONG[VARCHAR]

Ein Codeattribut definiert die beim Vergleich von Werten zu verwendende Sortierreihenfolge.

Codeattribut | Spaltenwerte
Kein Codeattribut | Die Spaltenwerte haben das im Datenbanksystem festgelegte Codeattribut.
ASCII | Die Spaltenwerte werden in ASCII-Code abgelegt.
BYTE | Die Spaltenwerte werden codeneutral abgelegt, d. h. die Spaltenwerte werden nicht vom Datenbanksystem konvertiert.
UNICODE | Die Anwendungsdaten in einer Tabellenspalte werden in UNICODE abgelegt.

Codeattribut festlegen

● Für Spaltenwerte mit den Datentypen CHAR[ACTER], VARCHAR und LONG[VARCHAR] kann gegebenenfalls zusätzlich ein Codeattribut in der Spaltendefinition (column_definition) angegeben werden

● Wenn kein Codeattribut angegeben ist, dann wird der im Datenbanksystem definierte Code verwendet. Der Code kann durch folgende Möglichkeiten benutzerspezifisch oder global festgelegt werden:

○ Der Code kann durch entsprechende SQL-Anweisungen für bestimmte Datenbankbenutzer definiert werden (siehe dazu: CREATE/ALTER USER-Anweisung bzw. CREATE/ALTER USERGROUP-Anweisung).

○ Der Code kann global bei der Installation des Datenbanksystems durch den speziellen Datenbankparameter DEFAULT_CODE definiert werden.

Der für einen Datenbankbenutzer definierte Code übersteuert den global im Datenbanksystem angegebenen Code.

Codeattribut ändern

Sie können ein Codeattribut ändern.

Wenn Sie das Codeattribut von ASCII nach UNICODE ändern, sollten Sie beachten, dass der Spaltenwert die Länge der Spalte nicht überschreiten darf.

Sie können das Codeattribut von UNICODE nach ASCII nur dann ändern, wenn sämtliche Daten in ASCII-Werte konvertierbar sind.

Siehe auch:

Datentyp (data_type)

ALTER TABLE-Anweisung (alter_table_statement)


BOOLEAN (SAP-Bibliothek - Grundwissen)

BOOLEAN

Es wird für die Spalte als Datentyp (data_type) BOOLEAN definiert. Ein BOOLEAN-Wert kann nur die beiden Zustände TRUE und FALSE und den NULL-Wert annehmen. Ein Wert vom Datentyp BOOLEAN ist nur mit anderen Werten vom Datentyp BOOLEAN vergleichbar.

Der Datentyp BOOLEAN wird bei der Spaltendefinition angegeben.


FIXED (SAP-Bibliothek - Grundwissen)

FIXED

Der Datentyp (data_type) FIXED (p,s) definiert eine Festkommazahl (fixed_point_literal). Es wird eine Spalte mit der Festkommazahl der Genauigkeit p und mit s Nachkommastellen (0<p<=38, s<=p) definiert. Wird kein s angegeben, werden 0 Nachkommastellen angenommen.

Die Angabe des Datentyps FIXED erfolgt bei der Spaltendefinition.


FLOAT (SAP-Bibliothek - Grundwissen)

FLOAT

Der Datentyp (data_type) FLOAT (p) definiert eine Gleitkommazahl (floating_point_literal). Es wird eine Spalte mit der Gleitkommazahl der Genauigkeit p (0<p<=38) definiert.

Die Angabe des Datentyps FLOAT erfolgt bei der Spaltendefinition.


INT[EGER] (SAP-Bibliothek - Grundwissen)

INT[EGER]

Der Datentyp (data_type) INT[EGER] entspricht dem Datentyp FIXED(10,0). Für den Datentyp INT[EGER] sind im Gegensatz zum Datentyp FIXED(10,0) jedoch nur Werte zwischen -2147483648 und 2147483647 zulässig.

Die Angabe des Datentyps INT[EGER] erfolgt bei der Spaltendefinition.


SMALLINT (SAP-Bibliothek - Grundwissen)

SMALLINT

Der Datentyp (data_type) SMALLINT entspricht FIXED(5,0) mit zulässigen Werten zwischen -32768 und 32767.

Die Angabe des Datentyps SMALLINT erfolgt bei der Spaltendefinition.


DATE (Datumswert) (SAP-Bibliothek - Grundwissen)

DATE (Datumswert)

Mit dem Datentyp DATE wird eine alphanumerische Spalte definiert, in der Datumswerte abgelegt werden können.

Ein Datumswert ist eine spezielle Zeichenkette. Ein Datumswert ist mit anderen Datumswerten und mit Zeichenketten der Codeattribute ASCII und UNICODE vergleichbar.

Die Angabe des Datentyps DATE erfolgt bei der Spaltendefinition.

Siehe auch:

Datums- und Zeitformat (datetimeformat)


TIME (Zeitwert) (SAP-Bibliothek - Grundwissen)

TIME (Zeitwert)

Mit dem Datentyp (data_type) TIME wird eine alphanumerische Spalte, in der Zeitwerte abgelegt werden können, definiert.

Ein Zeitwert ist eine spezielle Zeichenkette. Ein Zeitwert ist mit anderen Zeitwerten und mit Zeichenketten der Codeattribute ASCII und UNICODE vergleichbar.

Die Angabe des Datentyps TIME erfolgt bei der Spaltendefinition.

Siehe auch:

Datums- und Zeitformat (datetimeformat)


TIMESTAMP (Zeitstempelwert) (SAP-Bibliothek - Grundwissen)

TIMESTAMP (Zeitstempelwert)

Mit dem Datentyp (data_type) TIMESTAMP wird eine alphanumerische Spalte definiert, in der Zeitstempel abgelegt werden können.

Ein Zeitstempelwert ist eine spezielle Zeichenkette. Ein Zeitstempel setzt sich aus einem Datums- und einem Zeitwert und der Angabe von Mikrosekunden zusammen.

Ein Zeitstempelwert ist mit anderen Zeitstempelwerten und mit Zeichenketten der Codeattribute ASCII und UNICODE vergleichbar.

Die Angabe des Datentyps TIMESTAMP erfolgt bei der Spaltendefinition

Siehe auch:

Datums- und Zeitformat (datetimeformat)


NULL-Wert (SAP-Bibliothek - Grundwissen)

NULL-Wert

Der Datentyp (data_type) NULL-Wert (undefinierter Wert) ist ein spezieller Wert, dessen Vergleich mit einem beliebigen Wert immer undefiniert ist.


Spezial-NULL-Wert (SAP-Bibliothek - Grundwissen)

Spezial-NULL-Wert

Ein Spezial-NULL-Wert ist ein spezieller Datentyp (data_type) und entsteht bei arithmetischen Operationen, wenn diese zu einem Überlauf oder zu einer Division durch Null führen.

Der Spezial-NULL-Wert ist nur für die Ausgabespalten und für Spalten in der ORDER-Klausel zulässig. Tritt ein Überlauf bei einer arithmetischen Operation oder eine Division durch Null an einer anderen Stelle auf, führt das zum Abbruch der SQL-Anweisung.

Der Vergleich eines Spezial-NULL-Wertes mit einem beliebigen Wert ist immer undefiniert.

Bei der Sortierung ist der Spezial-NULL-Wert größer als alle Nicht-NULL-Werte, aber kleiner als der NULL-Wert.


Zahl (SAP-Bibliothek - Grundwissen)

Zahl

Eine Zahl ist ein spezieller Datentyp (data_type). Es gibt Festkomma- und Gleitkommazahlen:

● Festkommazahl

wird durch die Anzahl signifikanter Stellen und die Anzahl der Nachkommastellen beschrieben. Die Anzahl signifikanter Stellen beträgt maximal 38 Ziffern.

Beispiele: FIXED, INT[EGER], SMALLINT

● Gleitkommazahl

besteht aus einer Mantisse und einem Exponenten. Die Mantisse darf höchstens 38 signifikante Stellen haben. Der zulässige Wertebereich von Gleitkommazahlen besteht aus den Intervallen von ‑9.9999999999999999999999999999999999999E+62 bis -1E-64 und von +1E-64 bis +9.9999999999999999999999999999999999999E+62 sowie dem Wert 0.0.

Beispiel: FLOAT

Alle Zahlen sind miteinander vergleichbar.

Siehe auch:

Literal (literal)


Zeichenkette (SAP-Bibliothek - Grundwissen)

Zeichenkette

Eine Zeichenkette ist ein Datentyp (data_type), der eine Folge von alphanumerischen Zeichen ist.

Beispiele: CHAR[ACTER], VARCHAR, DATE, TIME, TIMESTAMP

Bei einer Spaltendefinition kann für die Datentypen CHAR[ACTER] und VARCHAR ein Codeattribut angegeben werden.

Für die Datentypen CHAR[ACTER] und VARCHAR gelten folgende Vergleichsmöglichkeiten:

Zeichenketten mit gleichem Codeattribut | Diese Zeichenketten sind untereinander vergleichbar.
Zeichenketten mit den Codeattributen ASCII oder UNICODE | Diese Zeichenketten sind mit Zeichenketten der Codeattribute ASCII oder UNICODE und mit Datums-, Zeit- und Zeitstempelwerten vergleichbar.

Siehe auch:

Literal (literal)


Spaltenattribute (column_attributes) (SAP-Bibliothek - Grundwissen)

Spaltenattribute (column_attributes)

Bei einer Spaltendefinition können neben den Spaltennamen (column_name) Spaltenattribute (column_attributes) angegeben werden.

Syntax

<column_attributes> ::= [<key_or_not_null_spec>] [<default_spec>] [UNIQUE] [<constraint_definition>]
[REFERENCES <referenced_table> [(<referenced_column>)] [<delete_rule>]]

<key_or_not_null_spec> ::= [PRIMARY] KEY | NOT NULL [WITH DEFAULT]

<referenced_table> ::= <table_name>

<referenced_column> ::= <column_name>

Erläuterung

Eine CONSTRAINT-Definition constraint_definition definiert eine Bedingung, die alle Spaltenwerte der durch die Spaltendefinition column_definition definierten Spalte erfüllen müssen.

Die Angabe von [REFERENCES <referenced_table> [(<referenced_column>)] [<delete_rule>] hat die gleiche Wirkung wie die Angabe der referentiellen CONSTRAINT-Definition FOREIGN KEY [<referential_constraint_name>] (<referencing_column>) REFERENCES <referenced_table> [(<referenced_column>,...)] [<delete_rule>]

referenced_table

referenced_column

referenzierte Tabelle

referenzierte Spalte

Datentyp LONG: Für Spalten vom Datentyp LONG darf als Spaltenattribut nur NOT NULL oder eine DEFAULT-Spezifikation angegeben werden.

UNIQUE

Wenn das Spaltenattribut UNIQUE angegeben ist, wird dadurch die Eindeutigkeit von Spaltenwerten festgelegt (siehe auch CREATE INDEX-Anweisung).

[PRIMARY] KEY

Bei einer Spaltendefinition dürfen die Spaltenattribute [PRIMARY] KEY und UNIQUE nicht gemeinsam verwendet werden.

Wenn das Spaltenattribut [PRIMARY] KEY angegeben ist, darf die CREATE TABLE-Anweisung keine Schlüsseldefinition enthalten.

Wenn das Spaltenattribut KEY angegeben ist, ist diese Spalte Bestandteil des Schlüssels einer Tabelle und heißt Schlüsselspalte. Das Datenbanksystem garantiert die Eindeutigkeit der Schlüsselwerte in einer Tabelle. Aus Gründen der Ausführungsgeschwindigkeit ist es zweckmäßig, den Schlüssel mit Schlüsselspalten, die viele verschiedene Werte annehmen können und häufig in Bedingungen mit dem Operator "=" verwendet werden sollen, beginnen zu lassen.

Siehe auch:

Restriktionen für SQL-Anweisungen

Wenn eine Tabelle ohne Schlüsselspalte definiert wird, legt das Datenbanksystem implizit eine Schlüsselspalte SYSKEY CHAR(8) BYTE an. Diese Spalte ist bei einem SELECT * nicht sichtbar. Sie kann jedoch explizit angegeben werden und hat dann dieselbe Funktion wie eine Schlüsselspalte. Die SYSKEY-Spalte kann dazu verwendet werden, eindeutige Schlüssel vom Datenbanksystem erzeugen zu lassen. Die Schlüssel sind aufsteigend, so dass die Einfügereihenfolge in die Tabelle widergespiegelt wird. Die Schlüsselwerte in der Spalte SYSKEY sind jedoch nur innerhalb einer Tabelle eindeutig, d.h. in zwei voneinander verschiedenen Tabellen können gleiche Werte in der SYSKEY-Spalte existieren. Wenn eindeutige Schlüssel innerhalb des gesamten Datenbanksystems erwünscht sind, kann eine Schlüsselspalte vom Datentyp CHAR(8) BYTE mit der DEFAULT-Spezifikation STAMP definiert werden.

NOT NULL

· NOT NULL darf nicht zusammen mit der DEFAULT-Spezifikation NULL verwendet werden.

· NOT NULL WITH DEFAULT definiert einen Vorschlagswert (DEFAULT-Wert), der abhängig vom Datentyp der Spalte ist. NOT NULL WITH DEFAULT darf nicht zusammen mit irgendeiner der DEFAULT-Spezifikationen verwendet werden.

Datentyp der Spalte | DEFAULT-Wert
CHAR (n); VARCHAR(n) | ' '
CHAR(n) BYTE; VARCHAR(n) BYTE | X'00'
FIXED(p,s), INT, SMALLINT, FLOAT(p) | 0
DATE | DATE
TIME | TIME
TIMESTAMP | TIMESTAMP
BOOLEAN | FALSE


Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp (SAP-Bibliothek - Grundwissen)

Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp

Bei der Spaltendefinition (column_definition) sollten Sie den Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp beachten. Eine ungefähre Einschätzung des Platzbedarfs können Sie anhand der folgenden Tabelle vornehmen. Beachten Sie, dass diese Angaben Richtwerte sind, die in den meisten Fällen stimmen, die jedoch je nach Konfiguration Ihres Systems variieren können.

Wenn der Datenbankparameter COLUMNCOMPRESSION=YES gesetzt ist, ist der tatsächlich benötigte Platz in vielen Fällen kleiner als der maximale Platzbedarf. Diese Differenz ist von der tatsächlichen Größe der gespeicherten Spaltenwerte abhängig.
Siehe auch: Konzepte des Datenbanksystems, Support-Datenbankparameter

Wenn die Spalte Schlüsselspalte jedoch nicht die letzte Schlüsselspalte ist, entspricht der tatsächlich benötigte Platz dem maximalen Platzbedarf.

Wenn die Spalte die letzte Schlüsselspalte ist, ist der tatsächlich benötigte Platz kleiner als der maximale Platzbedarf.

Datentyp | Maximaler Platzbedarf innerhalb der Datenbank (Bytes) COLUMNCOMPRESSION=YES | Maximaler Platzbedarf innerhalb der Datenbank (Bytes) COLUMNCOMPRESSION=NO | Platzbedarf innerhalb der Kommunikation (Bytes) bei Verwendung eines ASCII-Clients | Platzbedarf innerhalb der Kommunikation (Bytes) bei Verwendung eines UNICODE-Clients
FIXED(p,s) | (p+1) DIV 2 + 3 | (p+1) DIV 2 + 2 | (p+1) DIV 2 + 2 | (p+1) DIV 2 + 2
FLOAT(p) | (p+1) DIV 2 + 3 | (p+1) DIV 2 + 2 | (p+1) DIV 2 + 2 | (p+1) DIV 2 + 2
BOOLEAN | 3 | 2 | 2 | 2
DATE | 10 | 9 | 11 | 21
TIME | 10 | 9 | 9 | 19
TIMESTAMP | 22 | 21 | 27 | 53
LONG | 9 | 9 | 41 | 41
CHAR(n) ASCII 0<n<=1023 Schlüsselspalte | n+1 | n+1 | n+1 | 2*n+1
CHAR(n) ASCII n<=30 keine Schlüsselspalte | n+2 | n+1 | n+1 | 2*n+1
CHAR(n) ASCII 30<n<=254 keine Schlüsselspalte | n+2 | n+2 | n+1 | 2*n+1
CHAR(n) ASCII 254<n keine Schlüsselspalte | n+3 | n+3 | n+1 | 2*n+1
CHAR(n) BYTE 0<n<=1023 Schlüsselspalte | n+1 | n+1 | n+1 | n+1
CHAR(n) BYTE n<=30 keine Schlüsselspalte | n+2 | n+1 | n+1 | n+1
CHAR(n) BYTE 30<n<=254 keine Schlüsselspalte | n+2 | n+2 | n+1 | n+1
CHAR(n) BYTE 254<n keine Schlüsselspalte | n+3 | n+3 | n+1 | n+1
CHAR(n) UNICODE 0<n<=511 Schlüsselspalte | 2*n+1 | 2*n+1 | 2*n+1 | 2*n+1
CHAR(n) UNICODE n<=15 keine Schlüsselspalte | 2*n+2 | 2*n+1 | 2*n+1 | 2*n+1
CHAR(n) UNICODE 15<n<=127 keine Schlüsselspalte | 2*n+2 | 2*n+2 | 2*n+1 | 2*n+1
CHAR(n) UNICODE 127<n keine Schlüsselspalte | 2*n+3 | 2*n+3 | 2*n+1 | 2*n+1
VARCHAR(n) ASCII 0<n<=1023 Schlüsselspalte | n+1 | n+1 | n+1 | 2*n+1
VARCHAR(n) ASCII n<=30 keine Schlüsselspalte | n+2 | n+2 | n+1 | 2*n+1
VARCHAR(n) ASCII 30<n<=254 keine Schlüsselspalte | n+2 | n+2 | n+1 | 2*n+1
VARCHAR(n) ASCII 254<n keine Schlüsselspalte | n+3 | n+3 | n+1 | 2*n+1
VARCHAR(n) BYTE 0<n<=1023 Schlüsselspalte | n+1 | n+1 | n+1 | n+1
VARCHAR(n) BYTE n<=30 keine Schlüsselspalte | n+2 | n+2 | n+1 | n+1
VARCHAR(n) BYTE 30<n<=254 keine Schlüsselspalte | n+2 | n+2 | n+1 | n+1
VARCHAR(n) BYTE 254<n keine Schlüsselspalte | n+3 | n+3 | n+1 | n+1
VARCHAR(n) UNICODE 0<n<=511 Schlüsselspalte | 2*n+1 | 2*n+1 | 2*n+1 | 2*n+1
VARCHAR(n) UNICODE n<=15 keine Schlüsselspalte | 2*n+2 | 2*n+2 | 2*n+1 | 2*n+1
VARCHAR(n) UNICODE 15<n<=127 keine Schlüsselspalte | 2*n+2 | 2*n+2 | 2*n+1 | 2*n+1
VARCHAR(n) UNICODE 127<n keine Schlüsselspalte | 2*n+3 | 2*n+3 | 2*n+1 | 2*n+1


CONSTRAINT-Definition (constraint_definition) (SAP-Bibliothek - Grundwissen)

CONSTRAINT-Definition (constraint_definition)

Eine CONSTRAINT-Definition (constraint_definition) definiert eine Integritätsbedingung, der alle Zeilen einer Tabelle genügen müssen.

Syntax

<constraint_definition> ::= CHECK <search_condition>
| CONSTRAINT <search_condition>
| CONSTRAINT <constraint_name> CHECK <search_condition>

Beispiele

SQL-Tutorial, Strukturlink Constraints

Erläuterung

Eine CONSTRAINT-Definition definiert eine Integritätsbedingung, die alle Spaltenwerte der durch die Spaltendefinition mit CONSTRAINT-Definition definierten Spalte erfüllen müssen.

Die CONSTRAINT-Definition einer Spalte wird beim Einfügen einer Zeile und beim Ändern einer Spalte, die in der CONSTRAINT-Definition auftritt, überprüft. Wird die CONSTRAINT-Definition verletzt, scheitert die INSERT- bzw. UPDATE-Anweisung.

Die Suchbedingung search_condition der CONSTRAINT-Definition darf keine Subquery enthalten und sie darf Spaltennamen nur in der Form column_name enthalten.

<constraint_name>

· Kein Constraint-Name angegeben:
Vom Datenbanksystem wird ein für die Tabelle eindeutiger Constraint-Name vergeben.

· Constraint-Name angegeben:
Der Constraint-Name muss sich von allen anderen Constraint-Namen der Tabelle unterscheiden.

<search_condition>

Die Anzahl der Spalten in einer Suchbedingung spielt eine Rolle.

· Die Suchbedingung enthält nur einen Spaltennamen der Tabelle:
Beim Erzeugen der Tabelle (CREATE TABLE-Anweisung) kann geprüft werden, ob ein zusätzlich als Spaltenattribut angegebener DEFAULT-Wert die Suchbedingung erfüllt. Ist dies nicht der Fall, scheitert die CREATE TABLE-Anweisung.

· Die Suchebedingung enthält mehr als einen Spaltennamen der Tabelle:
Zum Zeitpunkt der Tabellenerzeugung (CREATE TABLE-Anweisung) kann nicht entschieden werden, ob DEFAULT-Werte der Tabellenspalten die Suchbedingung erfüllen. In diesem Fall kann der Versuch, DEFAULT-Werte in die Tabelle einzufügen, bei Ausführung einer INSERT- oder UPDATE-Anweisung scheitern.

Siehe auch:

Datenintegrität absichern


Referentielle CONSTRAINT-Definition (referential_constraint_definition)

Eine referentielle CONSTRAINT-Definition (referential_constraint_definition) definiert eine Integritätsbedingung, der alle Zeilen zweier Tabellen genügen müssen. Die dadurch definierte Abhängigkeit zwischen zwei Tabellen hat Auswirkungen auf Veränderungen, die an deren Zeilen gewünscht werden.

Syntax

<referential_constraint_definition> ::=
FOREIGN KEY [<referential_constraint_name>] (<referencing_column>,...)
REFERENCES <referenced_table> [(<referenced_column>,...)] [<delete_rule>]

<referencing_column>
::= <column_name>
<referenced_table> ::= <table_name>
<referenced_column> ::= <column_name>

referenced_table referenced_column | referenzierte Tabelle, referenzierte Spalte (Tabelle/Spalte, die angesprochen werden soll)
referencing_column | referenzierende Spalte (Spalte, die die Verbindung zu der anzusprechenden Spalte herstellt)

Beispiele

SQL-Tutorial, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen

Erläuterung

Eine referentielle CONSTRAINT-Definition kann in einer CREATE TABLE-Anweisung oder ALTER TABLE-Anweisung (ADD-Definition) verwendet werden. Die in der entsprechenden Anweisung angegebene Tabelle table_name wird im folgenden als referenzierende Tabelle bezeichnet.

Name eines referentiellen Constraint (referential_constraint_name)

Der Name eines referentiellen Constraint kann nach den Schlüsselworten FOREIGN KEY angegeben werden.

· Wenn der Name eines referentiellen Constraints angegeben ist, muss dieser sich von allen anderen Namen referentieller Constraints der referenzierenden Tabelle unterscheiden.

· Wenn kein Name eines referentiellen Constraints angegeben ist, wird vom Datenbanksystem ein eindeutiger Name (bezogen auf die referenzierende Tabelle) vergeben.

Referenzierende Spalten (referencing_column)

Die referenzierenden Spalten referencing_column werden in der referentiellen CONSTRAINT-Definition angegeben. Die referenzierenden Spalten müssen Spalten der referenzierenden Tabelle bezeichnen und alle voneinander verschieden sein. Sie werden auch als Fremdschlüsselspalten bezeichnet.

Referenzierte Spalten (referenced_column)

· Wenn keine referenzierten Spalten angegeben werden, hat das die Wirkung wie die Angabe der Schlüsselspalten der referenzierten Tabelle referenced_table in der definierten Reihenfolge.

· Wenn referenzierte Spalten angegeben werden, die nicht der Schlüssel der referenzierten Tabelle sind, dann muss die referenzierte Tabelle eine UNIQUE-Definition besitzen, deren Spaltennamen und Reihenfolge der Spalten mit den referenzierten Spalten übereinstimmen.

Beziehung zwischen referenzierten und referenzierenden Spalten:

· Die Anzahl der referenzierten und der referenzierenden Spalten muss übereinstimmen.

· Die n-te referenzierende Spalte korrespondiert mit der n-ten referenzierten Spalte.

· Datentyp und Länge jeder referenzierenden Spalte muss mit dem Datentyp und der Länge der korrespondierenden referenzierten Spalte übereinstimmen.

Referenzierende und referenzierte Tabelle müssen Basistabellen, dürfen jedoch keine temporären Tabellen sein.

Der aktuelle Benutzer muss das ALTER-Privileg für die referenzierende Tabelle und das REFERENCE-Privileg für die referenzierte Tabelle haben.

Einfügen und Ändern von Zeilen der referenzierten Tabelle

Das Einfügen und Ändern von Zeilen der referenzierenden Tabelle unterliegt folgenden Einschränkungen:

Sei Z eine einzufügende oder geänderte Zeile. Das Einfügen und Ändern ist nur dann möglich, wenn für jede zugehörige referenzierte Tabelle referenced_table eine der folgenden Bedingungen erfüllt ist:

· Z ist eine Trefferzeile

· Z enthält in einer der referenzierenden Spalten referencing_column einen NULL-Wert.

· Die referentielle CONSTRAINT-Definition definiert die DELETE-Regel ON DELETE SET DEFAULT, und Z enthält in jeder referenzierenden Spalte den DEFAULT-Wert.

Bei Anwendung einer INSERT- oder einer UPDATE-Anweisung auf eine referenzierende Tabelle verwendet das Datenbanksystem unabhängig vom für die aktuelle Sitzung aktuellen Isolation-Level ein Sperrverhalten für die referenzierte Tabelle, das dem Isolation-Level 1 entspricht.
Bei Anwendung einer DELETE-Anweisung auf eine referenzierte Tabelle verwendet das Datenbanksystem ein Sperrverhalten, das dem Isolation-Level 3 entspricht.

Trefferzeile

Eine Zeile der referenzierenden Tabelle heißt Trefferzeile einer Zeile der referenzierten Tabelle referenced_table, wenn die Werte der korrespondierenden referenzierenden Spalten referencing_column und referenzierten Spalten referenced_column gleich sind.

Eine referentielle CONSTRAINT-Definition definiert eine 1:n-Beziehung zwischen zwei Tabellen. Das bedeutet, dass zu jeder Zeile der referenzierten Tabelle mehrere Trefferzeilen existieren können.

Eine Änderung einer Zeile der referenzierten Tabelle in einer referenzierten Spalte scheitert, wenn mindestens eine Trefferzeile existiert.

CASCADE-Abhängigkeit

Eine Tabelle T* heißt CASCADE-abhängig von einer Tabelle T, wenn es eine Folge von referentiellen CONSTRAINT-Definitionen R1, R2, ..., Rn (n>=1) gibt, so dass gilt:

· T* ist referenzierende Tabelle von R1

· T ist referenzierte Tabelle referenced_table von Rn

· Alle referentiellen CONSTRAINT-Definitionen verwenden CASCADE.

· Für i=1,...,n-1, n>1 ist die referenzierte Tabelle von Ri referenzierende Tabelle von Ri+1

Seien R1 und R2 zwei verschiedene referentielle CONSTRAINT-Definitionen mit derselben referenzierenden Tabelle S. Die referenzierte Tabelle von R1 sei T1, die von R2 sei T2.

Wenn die Tabellen T1 und T2 gleich sind, oder wenn es eine Tabelle T gibt, so dass T1 und T2 CASCADE-abhängig von T sind, dann müssen R1 und R2 entweder beide CASCADE oder beide RESTRICT spezifizieren.

Es gibt zwei verschiedene Folgen von referentiellen CONSTRAINT-Definitionen, die die Tabellen S und T verbinden. Eine DELETE-Anweisung auf die Tabelle T hat eine Aktion in der Tabelle S zur Folge. Damit das Ergebnis der DELETE-Anweisung nicht abhängig davon ist, welche der beiden verschiedenen Folgen von referentiellen CONSTRAINT-Definitionen abgearbeitet wird, wurde die obige Einschränkung für R1 und R2 gewählt.

Referenz-Zyklus

Ein Referenz-Zyklus ist eine Folge von referentiellen CONSTRAINT-Definitionen R1, R2,...,Rn mit n>1, für die folgenden Bedingungen gelten:

· Für i=1,...,n-1 ist die referenzierte Tabelle referenced_table von Ri die referenzierende Tabelle von Ri+1.

· Die referenzierte Tabelle von Rn ist die referenzierende Tabelle von R1.

Ein Referenz-Zyklus, in dem alle referentiellen CONSTRAINT-Definitionen CASCADE spezifizieren, ist nicht erlaubt.

Ein Referenz-Zyklus, in dem eine referentielle CONSTRAINT-Definition nicht CASCADE spezifiziert und alle übrigen referentiellen CONSTRAINT-Definitionen CASCADE spezifizieren, ist nicht erlaubt.

Selbst-referenzierende CONSTRAINT-Definition

Eine referentielle CONSTRAINT-Definition heißt selbst-referenzierend, wenn die referenzierte Tabelle referenced_table und die referenzierende Tabelle übereinstimmen.

Bei selbst-referenzierenden referentiellen CONSTRAINT-Definitionen kann die Abarbeitungsfolge einer DELETE-Anweisung von Bedeutung sein.

Angabe von CASCADE: Zunächst werden alle von der DELETE-Anweisung betroffenen Zeilen unter Nichtbeachtung der referentiellen CONSTRAINT-Bedingungen gelöscht. Anschließend werden alle Trefferzeilen der soeben gelöschten Zeilen gelöscht. Sodann werden alle Trefferzeilen des eben vorangegangenen Löschvorgangs gelöscht, usw.

Angabe von SET NULL oder SET DEFAULT: Zunächst werden alle von der DELETE-Anweisung betroffenen Zeilen unter Nichtbeachtung der referentiellen CONSTRAINT-Bedingungen gelöscht. Anschließend wird auf die Trefferzeile SET NULL bzw. SET DEFAULT angewandt.

Siehe auch:

Datenintegrität absichern


Schlüsseldefinition (key_definition) (SAP-Bibliothek - Grundwissen)

Schlüsseldefinition (key_definition)

Eine Schlüsseldefinition (key_definition) in einer CREATE TABLE-Anweisung oder einer ALTER TABLE-Anweisung definiert den Schlüssel einer Basistabelle. Eingeleitet wird die Schlüsseldefinition durch die Schlüsselworte PRIMARY KEY (Primärschlüssel).

Syntax

<key_definition> ::= PRIMARY KEY (<column_name>,...)

Beispiele

SQL-Tutorial, Strukturlink Primärschlüssel

Erläuterung

Der Spaltenname column_name muss eine Spalte der Basistabelle identifizieren. Die angegebenen Spaltennamen sind die Schlüsselspalten der Tabelle.

Eine Schlüsselspalte darf keine Spalte des Datentyps LONG identifizieren und ist immer eine NOT NULL-Spalte. Vom Datenbanksystem wird sichergestellt, dass keine Schlüsselspalte einen NULL-Wert besitzt und dass zwei Zeilen der Tabelle nicht in allen Schlüsselspalten die gleichen Werte besitzen.

Siehe auch:

Restriktionen für SQL-Anweisungen


UNIQUE-Definition (unique_definition) (SAP-Bibliothek - Grundwissen)

UNIQUE-Definition (unique_definition)

Eine UNIQUE-Definition (unique_definition) in der CREATE TABLE-Anweisung definiert die Eindeutigkeit von Spaltenwertkombinationen.

Syntax

<unique_definition> ::= [CONSTRAINT <index_name>] UNIQUE (<column_name>,...)

Beispiele

SQL-Tutorial, Strukturlink Indizes

Erläuterung

Die Angabe einer UNIQUE-Definition in einer CREATE TABLE-Anweisung hat die gleiche Wirkung wie die Angabe der CREATE TABLE-Anweisung ohne UNIQUE-Definition, jedoch mit einer CREATE INDEX-Anweisung mit Angabe von UNIQUE.

· Indexname angegeben: Der erzeugte Index wird unter diesem Namen im Datenbankkatalog abgelegt.

· Kein Indexname: Dem Index wird vom Datenbanksystem ein eindeutiger Indexname zugeordnet.


DROP TABLE-Anweisung (drop_table_statement) (SAP-Bibliothek - Grundwissen)

DROP TABLE-Anweisung (drop_table_statement)

Eine DROP TABLE-Anweisung (drop_table_statement) löscht eine Basistabelle.

Syntax

<drop_table_statement> ::= DROP TABLE <table_name> [<cascade_option>]

Beispiele

SQL-Tutorial, Strukturlink Tabellen

Erläuterung

Wenn kein Schemaname im Tabellennamen angegeben ist, wird das aktuelle Schema angenommen. Der Tabellenname muss der Name einer existierenden Basistabelle sein. Der aktuelle Benutzer muss Eigentümer der Basistabelle sein oder das DROPIN-Privileg für das Schema besitzen, dem die zu löschende Tabelle angehört.

Alle Metadaten und Zeilen der Basistabelle sowie alle von dieser Basistabelle abgeleiteten View-Tabellen, Indizes, Privilegien, Synonyme und referentiellen CONSTRAINT-Definitionen werden gelöscht.

Sollen alle Daten, die über eine referentielle CONSTRAINT-Definition mit einer DELETE-Regel mit dieser Basistabelle verknüpft sind, gemäß angegebener DELETE-Regel bearbeitet werden, so muss erst eine DELETE-Anweisung für diese Basistabelle und dann die DROP TABLE-Anweisung dafür ausgeführt werden.

<cascade_option>

Wenn keine CASCADE-Option angegeben wird, wird die DROP TABLE-Anweisung unabhängig von den Abhängigkeiten durchgeführt.

· RESTRICT: Die DROP TABLE-Anweisung scheitert, wenn auf der angegebenen Tabelle View-Tabellen oder Synonyme basieren.

· CASCADE: Die DROP TABLE-Anweisung wird unabhängig von den Abhängigkeiten durchgeführt.


ALTER TABLE-Anweisung (alter_table_statement) (SAP-Bibliothek - Grundwissen)

ALTER TABLE-Anweisung (alter_table_statement)

Eine ALTER TABLE-Anweisung (alter_table_statement) ändert Eigenschaften einer Basistabelle.

Syntax

<alter_table_statement> ::=
ALTER TABLE <table_name> <add_definition>
| ALTER TABLE <table_name> <alter_definition>
| ALTER TABLE <table_name> <column_change_definition>
| ALTER TABLE <table_name> <drop_definition>
| ALTER TABLE <table_name> <modify_definition>
| ALTER TABLE <table_name> <referential_constraint_definition>
| ALTER TABLE <table_name> <sample_definition>

Beispiele

SQL-Tutorial, Strukturlink Tabellen, Strukturlink Primärschlüssel, Strukturlink Constraints, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen

Erläuterung

Wenn kein Schemaname im Tabellennamen angegeben ist, wird das aktuelle Schema angenommen. Der Tabellenname muss der Name einer existierenden Basistabelle sein. Die Tabelle darf keine temporäre Basistabelle sein. Der aktuelle Benutzer muss das ALTER-Privileg für die angegebene Tabelle besitzen.

ADD-Definition

Definieren zusätzlicher Tabelleneigenschaften.

ALTER-Definition

Ändern einer CONSTRAINT- oder Schlüsseldefinition.

COLUMN-Change-Definition

Ändern der Spalteneigenschaften.

DROP-Definition

Löschen von Tabelleneigenschaften.

MODIFY-Definition

Ändern von Datentypen und Spaltenattributen.

Referentielle CONSTRAINT-Definition

Definieren eines neuen referentiellen Constraints.

SAMPLE-Definition

Definieren einer Anzahl von Zeilen, die das Datenbanksystem bei der Bestimmung der Tabellenstatistiken berücksichtigen soll (Stichprobengröße).

Sie können einzelne Tabellen von einem UPDATE STATISTICS-Lauf ausschließen, indem Sie für diese Tabellen die Stichprobengröße auf 0 setzen.


ADD-Definition (add_definition) (SAP-Bibliothek - Grundwissen)

ADD-Definition (add_definition)

Durch Angabe einer ADD-Definition (add_definition) in der ALTER TABLE-Anweisung können Sie zusätzliche Tabelleneigenschaften definieren.

Syntax

<add_definition> ::= ADD <column_definition>,...
| ADD (<column_definition>,...)
| ADD <constraint_definition>
| ADD <key_definition>
| ADD <referential_constraint_definition>

Beispiele

SQL-Tutorial, Strukturlink Tabellen, Strukturlink Primärschlüssel, Strukturlink Constraints, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen

Hinzufügen einer Spaltendefinition: ADD <column_definition>

Durch die Angabe von Spaltendefinitionen column_definition können Sie die in der ALTER TABLE-Anweisung angegebene Tabelle um diese Spalten erweitern. Die maximal zulässige Anzahl von Spalten sowie die maximale Länge einer Zeile darf hierdurch nicht überschritten werden.

Jede Spalte hat einen um ein Zeichen erhöhten Platzbedarf (normaler Platzbedarf siehe Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp), falls die dort beschriebene Länge kleiner als 31 Zeichen ist und die Spalte nicht den Datentyp VARCHAR besitzt.

Die neu definierten Spalten enthalten in allen Zeilen den NULL-Wert, wenn für diese Spalten kein Vorschlagswert durch eine DEFAULT-Spezifikation festgelegt wurde. Falls der NULL-Wert eine CONSTRAINT-Definition der Tabelle verletzt, scheitert die ALTER TABLE-Anweisung.

Wenn Sie LONG-Spalten hinzufügen, können Sie keine DEFAULT-Spezifikation angeben. Wenn Sie für eine LONG-Spalte einen Vorschlagswert festlegen wollen, können Sie die LONG-Spalte mittels der ADD-Definition definieren und dann für die Definition eines Vorschlagswertes die MODIFY-Definition verwenden.

In jeder anderen Hinsicht hat die Angabe einer Spaltendefinition dieselbe Wirkung wie die Angabe einer Spaltendefinition in einer CREATE TABLE-Anweisung.

· Wenn für die angegebene Tabelle View-Tabellen definiert sind, für eine dieser View-Tabellen Alias-Namen definiert sind und die View-Tabellen die Spalten der Tabelle mit * referenzieren, so scheitert die ALTER TABLE-Anweisung.

· Wenn für die angegebene Tabelle View-Tabellen definiert sind, keine Alias-Namen definiert sind und die View-Tabellen die Spalten der Tabelle mit * referenzieren, so enthält diese View-Tabelle die durch die ADD-Definition zur Basistabelle hinzugefügten Spalten.

Hinzufügen einer CONSTRAINT-Definition: ADD <constraint_definition>

Alle Zeilen der Tabelle müssen die durch die Suchbedingung der CONSTRAINT-Definition definierte Bedingung erfüllen.

Hinzufügen einer Schlüsseldefinition: ADD <key_definition>

Für die in der ALTER TABLE-Anweisung angegebene Tabelle wird ein Schlüssel definiert. Die Tabelle darf zum Zeitpunkt der Ausführung nur die vom Datenbanksystem vergebene Schlüsselspalte SYSKEY besitzen. Die in der Schlüsseldefinition angegebenen Spalten müssen Spalten der Tabelle sein und die Schlüsseleigenschaften erfüllen (keine der Spalten darf NULL-Werte enthalten, keine zwei Zeilen dürfen in allen in der Schlüsseldefinition definierten Spalten die gleiche Werte besitzen). Der neue Schlüssel wird in den Metadaten der Tabelle vermerkt. Die Schlüsselspalte SYSKEY entfällt. Dieser Vorgang dauert für Tabellen mit vielen Zeilen recht lange, da umfangreiche Kopiervorgänge durchgeführt werden.

Wenn für die in der ALTER TABLE-Anweisung angegebene Tabelle ein Primärschlüssel definiert wird, dessen Struktur mit der eines vorhandenen Index vollständig übereinstimmt, wird dieser Index gelöscht.

Hinzufügen einer referentiellen CONSTRAINT-Definition: ADD <referential_constraint_definition>

Für die in der ALTER TABLE-Anweisung angegebene Tabelle wird eine Integritätsbedingung definiert. Die in der referentiellen CONSTRAINT-Definition angegebenen Spalten müssen Spalten der Tabelle sein. Alle Zeilen der Tabelle müssen die durch die referentielle CONSTRAINT-Definition definierte Integritätsbedingung erfüllen.


ALTER-Definition (alter_definition) (SAP-Bibliothek - Grundwissen)

ALTER-Definition (alter_definition)

Durch Angabe einer ALTER-Definition (alter_definition) in der ALTER TABLE-Anweisung können Sie eine CONSTRAINT- oder eine Schlüsseldefinition ändern.

Syntax

<alter_definition> ::=
ALTER CONSTRAINT <constraint_name> CHECK <search_condition>
| ALTER <key_definition>

Beispiele

SQL-Tutorial, Strukturlink Primärschlüssel, Strukturlink Constraints

Erläuterung

CONSTRAINT-Definition ändern: ALTER CONSTRAINT <constraint_name>

Der Constraint-Name muss eine CONSTRAINT-Definition der Tabelle identifizieren. Wenn keine Zeile der Tabelle der angegebenen Suchbedingung widerspricht, ersetzt diese die bestehende Suchbedingung der CONSTRAINT-Definition. Andernfalls scheitert die ALTER TABLE-Anweisung.

Schlüsseldefinition ändern: ALTER <key_definition>

Der durch die Schlüsseldefinition festgelegte Schlüssel ersetzt den bisherigen Schlüssel der Tabelle. Die in der Schlüsseldefinition angegebenen Spalten müssen Spalten der Tabelle identifizieren und die Schlüsseleigenschaft besitzen, d.h. keine Schlüsselspalte besitzt einen NULL-Wert und zwei Zeilen der Tabelle besitzen nicht in allen Schlüsselspalten die gleichen Werte.

Wenn eine Spalte des zu ersetzenden Schlüssels referenzierte Spalte referenced_column einer referentiellen CONSTRAINT-Definition ist, scheitert die ALTER TABLE-Anweisung.

Insbesondere bei Tabellen mit vielen Zeilen ist ein hoher Zeitbedarf zu erwarten, da umfangreiche Kopiervorgänge durchgeführt werden müssen.


COLUMN-Change-Definition (column_change_definition) (SAP-Bibliothek - Grundwissen)

COLUMN-Change-Definition (column_change_definition)

Durch Angabe einer COLUMN-Change-Definition (column_change_definition) in der ALTER TABLE-Anweisung können Sie die Eigenschaften einer Spalte ändern.

Syntax

<column_change_definition> ::=
COLUMN <column_name> ADD <default_spec>
| COLUMN <column_name> ALTER <default_spec>
| COLUMN <column_name> DEFAULT NULL
| COLUMN <column_name> DROP DEFAULT
| COLUMN <column_name> NOT NULL

Erläuterung

ADD <default_spec>

Die Spalte darf vor Ausführung der ALTER TABLE-Anweisung mit ADD <default_spec> keine DEFAULT-Spezifikation default_spec besitzen. Durch ADD <default_spec> erhält die Spalte einen Vorschlagswert (DEFAULT-Wert).

ALTER <default_spec>

Durch ALTER <default_spec> wird der Vorschlagswert (DEFAULT-Wert) der Spalte geändert. Alle Zeilen, die in der Spalte den alten Vorschlagswert besitzen, bleiben unverändert.

DEFAULT NULL

DEFAULT NULL läßt einen NULL-Wert für die Spalte zu. Es wird nicht geprüft, ob ein NULL-Wert existierende CONSTRAINT-Definitionen der Tabelle verletzt. Daher kann das Einfügen des NULL-Wertes bei Ausführung einer INSERT- oder UPDATE-Anweisung scheitern.

DROP DEFAULT

Durch DROP DEFAULT wird die DEFAULT-Spezifikation der Spalte gelöscht. Wenn die Spalte Fremdschlüsselspalte einer referentiellen CONSTRAINT-Definition mit der DELETE-REGEL ON DELETE SET DEFAULT ist, scheitert die ALTER TABLE-Anweisung.

NOT NULL

NOT NULL kann nur angegeben werden, wenn die Spalte keine NULL-Werte enthält. Nach erfolgreicher Ausführung der ALTER TABLE-Anweisung ist es nicht mehr möglich, einen NULL-Wert in die Spalte einzufügen.


DROP-Definition (drop_definition) (SAP-Bibliothek - Grundwissen)

DROP-Definition (drop_definition)

Durch Angabe einer DROP-Definition (drop_definition) in der ALTER TABLE-Anweisung können Sie Tabelleneigenschaften löschen.

Syntax

<drop_definition> ::= DROP <column_name>,... [<cascade_option>] [RELEASE SPACE]
| DROP (<column_name>,...) [<cascade_option>] [RELEASE SPACE]
| DROP CONSTRAINT <constraint_name>
| DROP FOREIGN KEY <referential_constraint_name>
| DROP PRIMARY KEY

Beispiele

SQL-Tutorial, Strukturlink Tabellen, Strukturlink Constraints, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen, Strukturlink Primärschlüssel

Erläuterung

DROP <column_name>

Mit DROP <column_name> bzw. DROP (<column_name>,.. .) löschen Sie Spalten.

Jeder Spaltenname muss eine Spalte der durch die ALTER TABLE-Anweisung identifizierten Tabelle sein. Die Spalte darf keine Schlüsselspalte und keine Fremdschlüsselspalte einer referentiellen CONSTRAINT-Definition der Tabelle sein.

In den Metadaten der Tabelle werden die Spalten als gelöscht markiert. Der Platzbedarf der zugrundeliegenden Tabelle verringert sich durch eine DROP-Definition nicht automatisch. Durch RELEASE SPACE wird das Löschen der Spaltenwerte der gelöschten Spalten in allen Zeilen der Tabelle erzwungen. Insbesondere bei Tabellen mit vielen Zeilen ist ein hoher Zeitbedarf zu erwarten, da umfangreiche Kopiervorgänge durchgeführt werden müssen.

Privilegien und Kommentare der zu löschenden Spalte werden gelöscht.

Wenn eine der zu löschenden Spalten als selektierte Spalte in einer View-Definition auftritt, dann wird die angegebene Spalte der View-Tabelle gelöscht.
Wenn diese View-Tabelle in der FROM-Klausel einer weiteren View-Tabelle verwendet wird, so wird das beschriebene Verfahren rekursiv auf diese View-Tabelle angewandt.

Existierende Indizes, die sich auf die zu löschenden Spalten beziehen, werden gelöscht. Der Speicherplatz für die gelöschten Indizes wird frei.

Alle CONSTRAINT-Definitionen, die eine der gelöschten Spalten enthalten, werden gelöscht.

<cascade_option>

· Wenn eine der zu löschenden Spalten in der QUERY-Spezifikation einer View-Definition auftritt und keine CASCADE-Option oder die CASCADE-Option CASCADE in der DROP-Definition angegeben ist, dann wird die View-Definition mit allen von ihr abhängigen View-Tabellen, Privilegien und Synonymen gelöscht

· Wenn eine der zu löschenden Spalten in der QUERY-Spezifikation einer View-Definition auftritt und die CASCADE-Bedingung RESTRICT in der DROP-Definition angegeben ist, dann scheitert die ALTER TABLE-Anweisung.

DROP CONSTRAINT <constraint_name>

Mit DROP CONSTRAINT <constraint_name> löschen Sie ein Constraint.

Der Constraintname muss eine CONSTRAINT-Definition der Tabelle identifizieren. Diese wird aus den Metadaten der Tabelle entfernt.

DROP FOREIGN KEY <referential_constraint_name>

Mit DROP FOREIGN KEY <referential_constraint_name> löschen Sie einen Frendschlüssel.

Wenn DROP FOREIGN KEY angegeben wurde, wird die durch den Namen des referentiellen Constraints referential_constraint_name identifizierte referentielle CONSTRAINT-Definition gelöscht.

DROP PRIMARY KEY

Mit DROP PRIMARY KEY löschen Sie einen Schlüssel.

· Die Tabelle muss einen vom Benutzer definierten Schlüssel besitzen.

· Die Tabelle darf nicht mehr als 1023 Spalten besitzen.

· Die maximal zulässige Länge einer Zeile darf 8088 Bytes nicht überschreiten.

· Keine Schlüsselspalte darf referenzierte Spalte (referenced_column) einer referentiellen CONSTRAINT-Definition sein.

Der Schlüssel wird durch die vom Datenbanksystem vergebene Schlüsselspalte SYSKEY ersetzt. Insbesondere bei Tabellen mit vielen Zeilen ist ein hoher Zeitbedarf zu erwarten, da umfangreiche Kopiervorgänge durchgeführt werden müssen.


MODIFY-Definition (modify_definition) (SAP-Bibliothek - Grundwissen)

MODIFY-Definition (modify_definition)

Durch Angabe einer MODIFY-Definition (modify_definition) in der ALTER TABLE-Anweisung können Sie Datentypen und Spaltenattribute ändern.

Syntax

<modify_definition> ::= MODIFY (<modify_column_definition>,...)

<modify_column_definition> ::=
<column_name> <data_type> <column_attributes>
| <column_name> <data_type>
| <column_name> <column_attributes>

Beispiele

SQL-Tutorial, Strukturlink Tabellen

Erläuterung

Die Klammern können entfallen, wenn die MODIFY-Definition nur einen Spaltennamen column_name enthält.

Jeder Spaltenname muss eine Spalte der in der ALTER TABLE-Anweisung angegebenen Basistabelle bezeichnen.

Wenn eine der durch column_name spezifizierten Spalten in einer CONSTRAINT-Definition der Tabelle enthalten ist, dann muss diese Spalte auch nach einer Datentypänderung eine legale Suchbedingung definieren.

<data_type>

Wenn keine DEFAULT-Spezifikation angegeben wird und für die entsprechende Spalte eine DEFAULT-Spezifikation definiert ist, dann muss diese zum Datentyp data_type kompatibel sein.

● Codeattribut ASCII: Die entsprechende Spalte muss vor der Modifikation den Datentyp DATE, TIME oder TIMESTAMP oder das Codeattribut ASCII oder UNICODE besitzen.

● Codeattribut UNICODE: Für die entsprechende Spalte muss eine Transformation von UNICODE nach ASCII möglich sein.

● Codeattribut BYTE: Die entsprechende Spalte muss vor der Modifikation den Datentyp DATE, TIME oder TIMESTAMP oder das Codeattribut ASCII oder BYTE besitzen.

Datentyp CHAR(n), VARCHAR(n): Die entsprechende Spalte muss den Datentyp CHAR(n), VARCHAR(n), DATE, TIME oder TIMESTAMP besitzen. Die Tabelle darf in diesem Fall keine Zeile enthalten, die in der Spalte einen Wert einer Länge größer als n besitzt.
Falls eine Spalte vor der Ausführung der ALTER TABLE-Anweisung das Codeattribut UNICODE besaß und das neue Codeattribut von UNICODE verschieden ist, muss eine Transformation in das neue Codeattribut möglich sein.

Datentyp DATE: Die entsprechende Spalte muss den Datentyp CHAR(n), VARCHAR(n) oder DATE besitzen. Alle Zeilen der Tabelle müssen in der Spalte einen Wert enthalten, der einem Datum in einem beliebigen vom Datenbanksystem unterstützten Datumsformat entspricht.

Datentyp FIXED(n,m): Die entsprechende Spalte muss den Datentyp FIXED(n,m), FLOAT, INT oder SMALLINT besitzen. Die Tabelle darf in diesem Fall keine Zeile enthalten, die in der Spalte einen Wert mit mehr als (n-m) Vorkomma- oder m Nachkommastellen besitzt.

Datentyp FLOAT(n): Die entsprechende Spalte muss den Datentyp FIXED(n,m), FLOAT(n), INT oder SMALLINT besitzen.

Datentyp INT: Die entsprechende Spalte muss den Datentyp FIXED(n,m), FLOAT(n), INT oder SMALLINT besitzen. Die Tabelle darf in diesem Fall nur Zeilen enthalten, die in der Spalte ganzzahlige Werte im Bereich von –2147483648 bis 2147483647 enthalten.

Datentyp SMALLINT: Die entsprechende Spalte muss den Datentyp FIXED(n,m), FLOAT(n), INT oder SMALLINT besitzen. Die Tabelle darf in diesem Fall nur Zeilen enthalten, die in der Spalte ganzzahlige Werte im Bereich von –32768 bis 32767 enthalten.

Datentyp TIME: Die entsprechende Spalte muss den Datentyp CHAR(n), VARCHAR(n) oder TIME besitzen. Alle Zeilen der Tabelle müssen in der Spalte einen Wert enthalten, der einem Zeitwert in einem beliebigen vom Datenbanksystem unterstützten Zeitformat entspricht.

Datentyp TIMESTAMP: Die entsprechende Spalte muss den Datentyp CHAR(n), VARCHAR(n) oder TIMESTAMP besitzen. Alle Zeilen der Tabelle müssen in der Spalte einen Wert enthalten, der einem Zeitstempelwert in einem beliebigen vom Datenbanksystem unterstützten Zeitstempelformat entspricht.

Spaltenattribut NULL: In die entsprechende Spalte kann durch nachfolgende INSERT- oder UPDATE-Anweisungen ein NULL-Wert eingetragen werden.

<column_attributes>

Es sind nur folgende Spaltenattribute erlaubt:

● NULL
NULL-Wert

● NOT NULL
Wenn NOT NULL angegeben wird, darf die Tabelle keine Zeile besitzen, die in der entsprechenden Spalte einen NULL-Wert enthält. Ein NULL-Wert kann anschließend nicht mehr in die Spalte eingefügt werden.

● DEFAULT-Spezifikation
Die DEFAULT-Spezifikation DEFAULT SERIAL ist nicht zulässig.
Wenn eine DEFAULT-Spezifikation angegeben wird, dann ersetzt diese eine gegebenenfalls existierende DEFAULT-Spezifikation der entsprechenden Spalte. Die neue DEFAULT-Spezifikation hat keine Auswirkungen auf bereits existierende Zeilen der Tabelle, sondern wird erst bei nachfolgenden INSERT-Anweisungen wirksam.

Weitere Informationen

Die Angabe einer MODIFY-Definition kann abhängig von der Art der Änderung dazu führen, dass die Tabelle umkopiert werden muss und/oder dass Indizes neu aufgebaut werden müssen. In diesen Fällen ist mit einer entsprechend langen Laufzeit zu rechnen.

Wenn die Tabelle umkopiert wird und die Tabelle als gelöscht markierte Spalten besitzt, dann werden diese aus dem Datenbankkatalog und den Zeilen der Tabelle entfernt und der Platzbedarf der Tabelle wird entsprechend reduziert.


RENAME TABLE-Anweisung (rename_table_statement) (SAP-Bibliothek - Grundwissen)

RENAME TABLE-Anweisung (rename_table_statement)

Eine RENAME TABLE-Anweisung (rename_table_statement) ändert den Namen einer Basistabelle.

Syntax

<rename_table_statement> ::=
RENAME TABLE <old_table_name> TO <new_table_name>

<old_table_name> ::= <table_name>
<new_table_name> ::= <table_name>

Beispiele

SQL-Tutorial, Strukturlink Tabellen

Erläuterung

Wenn kein Schemaname im Tabellennamen angegeben ist, wird das aktuelle Schema angenommen. Der alte Tabellenname muss eine Basistabelle identifizieren, die keine temporäre Tabelle sein darf.

Der aktuelle Benutzer muss das CREATEIN-Privileg im durch new_table_name identifizierten Schema besitzen.

Der neue Tabellenname darf noch nicht für eine Basis- oder View-Tabelle oder ein privates Synonym im durch new_table_name identifizierten Schema vergeben sein.

Die alte Tabelle old_table_name erhält den in new_table_name angegebenen Namen. Sämtliche Eigenschaften der Tabelle (z.B. Privilegien, Indizes) bleiben erhalten. Die Definitionen von View-Tabellen, die auf dem alten Tabellennamen basieren, werden an den neuen Namen angepaßt.


RENAME COLUMN-Anweisung (rename_column_statement) (SAP-Bibliothek - Grundwissen)

RENAME COLUMN-Anweisung (rename_column_statement)

Eine RENAME COLUMN-Anweisung (rename_column_statement) ändert den Namen einer Tabellenspalte.

Syntax

<rename_column_statement> ::=
RENAME COLUMN <table_name>.<column_name> TO <column_name>

Erläuterung

Die angegebene Tabelle muss eine Basis- oder View-Tabelle sein.

Wenn im Tabellennamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Die angegebene Tabellenspalte erhält einen neuen Namen. Wurde der Spaltenname einer View-Tabelle (die mit dieser Tabelle definiert wurde) aus dem Spaltennamen der Basistabelle abgeleitet, so wird in der View-Tabelle der alte Spaltenname durch den neuen ersetzt. Falls der neue Spaltenname bereits als Spaltenname der View-Tabelle existiert, scheitert die RENAME COLUMN-Anweisung.


EXISTS TABLE-Anweisung (exists_table_statement) (SAP-Bibliothek - Grundwissen)

EXISTS TABLE-Anweisung (exists_table_statement)

Eine EXISTS TABLE-Anweisung (exists_table_statement) zeigt die Existenz oder Nichtexistenz einer Tabelle an.

Syntax

<exists_table_statement> ::= EXISTS TABLE <table_name>

Erläuterung

Die angegebene Tabelle muss eine Basis- oder View-Tabelle oder ein Synonym sein.

Die Existenz oder Nichtexistenz der angegebenen Tabelle wird durch die Rückmeldung 0 bzw. die Fehlermeldung –4004 Unknown table name signalisiert.

Eine Tabelle existiert für einen Benutzer nur dann, wenn er ein Privileg auf dieser Tabelle besitzt.


CREATE SCHEMA-Anweisung (create_schema_statement) (SAP-Bibliothek - Grundwissen)

CREATE SCHEMA-Anweisung (create_schema_statement)

Die CREATE SCHEMA-Anweisung (create_schema_statement) definiert ein Schema.

Syntax

<create_schema_statement> ::= CREATE SCHEMA <schema_name_clause> [<schema_element> ...]

<schema_name_clause> ::= <schema_name>
| <schema_name> AUTHORIZATION <schema_authorization_identifier>

<schema_authorization_identifier> ::= <identifier>

<schema_element> ::= <create_table_statement>
| <create_view_statement>
| <create_dbproc_statement>
| <create_function_statement>
| <create_sequence_statement>

Erläuterung

Der aktuelle Benutzer muss ein Datenbankadministrator sein.

Der angegebene Schemaname (schema_name) muss sich von den Namen aller bereits existierenden Schemas, Datenbankbenutzer und Rollen unterscheiden.

CREATE SCHEMA <schema_name>

Ein Schema mit dem Namen schema_name wird angelegt. Der aktuelle Benutzer (ein Datenbankadministrator) wird der Eigentümer dieses Schemas.

CREATE SCHEMA <schema_name> AUTHORIZATION <schema_authorization_identifier>

Ein Schema mit dem Namen schema_name wird angelegt. Der durch schema_authorization_identifier angegebene Benutzer muss existieren und ein Datenbankadministrator sein. Dieser Datenbankadministrator wird Eigentümer des Schemas. Der Eigentümer besitzt die Privilegien CREATEIN und DROPIN für das erzeugte Schema und kann somit jederzeit Datenbankobjekte dem Schema hinzufügen oder Objekte löschen.


RENAME SCHEMA-Anweisung (rename_schema_statement) (SAP-Bibliothek - Grundwissen)

RENAME SCHEMA-Anweisung (rename_schema_statement)

Die RENAME SCHEMA-Anweisung (rename_schema_statement) ändert den Namen eines Schemas.

Syntax

<rename_schema_statement> ::= RENAME SCHEMA <schema_name> TO <new_schema_name>

<new_schema_name> ::= <schema_name>

Erläuterung

Das zu ändernde Schema muss existieren und darf keinen Benutzer identifizieren. Der Schemaname muss ein Schema identifizieren, dessen Eigentümer der aktuelle Datenbankbenutzer ist.

Der neue Schemaname new_schema_name darf nicht mit dem Namen eines existierenden Datenbankbenutzers, einer existierenden Benutzergruppe, eines existierenden Schemas oder einer existierenden Rolle übereinstimmen.

Alle vom zu ändernden Schema abhängigen Objekte werden vom Datenbanksystem an den neuen Schemanamen angepasst.


DROP SCHEMA-Anweisung (drop_schema_statement) (SAP-Bibliothek - Grundwissen)

DROP SCHEMA-Anweisung (drop_schema_statement)

Die DROP SCHEMA-Anweisung (drop_schema_statement) löscht ein Schema.

Syntax

<drop_schema_statement> ::= DROP SCHEMA <schema_name> [<cascade_option>]

Erläuterung

Der aktuelle Benutzer muss Eigentümer des zu löschenden Schemas sein.

Die Metadaten des angegebenen Schemas werden aus dem Datenbankkatalog gelöscht.

Wenn keine CASCADE-Option oder die CASCADE-Option CASCADE angegeben wurde, werden alle Datenbankobjekte gelöscht, die dem zu löschenden Schema angehören.

Wenn die CASCADE-Option RESTRICT angegeben wurde und noch Objekte existieren, die dem Schema angehören, so scheitert die DROP SCHEMA-Anweisung.


CREATE DOMAIN-Anweisung (create_domain_statement) (SAP-Bibliothek - Grundwissen)

CREATE DOMAIN-Anweisung (create_domain_statement)

Eine CREATE DOMAIN-Anweisung (create_domain_statement) definiert einen Wertebereich.

Syntax

<create_domain_statement> ::= CREATE DOMAIN <domain_name> <data_type> [<default_spec>] [<constraint_definition>]

Beispiele

SQL-Tutorial, Strukturlink Wertebereiche

Erläuterung

Die CONSTRAINT-Definition constraint_definition darf keinen Constraint-Namen enthalten.

Die CREATE DOMAIN-Anweisung kann von allen Datenbankadministratoren ausgeführt werden.

Wenn der Domänenname ohne Schemaname angegeben wird, wird dem Wertebereich das Schema mit dem Namen des aktuellen Benutzers zugeordnet. Wenn Sie den Domänennamen mit einem Schema angeben, muss der Schemaname mit dem Namen des aktuellen Benutzers übereinstimmen. Der aktuelle Benutzer wird also in jedem Fall zum Eigentümer des Wertebereichs.

Der Domänenname muss sich von allen existierenden Domänennamen des aktuellen Benutzers unterscheiden.

Wenn ein Wertebereich mit einer CONSTRAINT-Definition erzeugt wird, so wird der Domänenname in der Suchbedingung als Spaltenname angenommen.


DROP DOMAIN-Anweisung (drop_domain_statement) (SAP-Bibliothek - Grundwissen)

DROP DOMAIN-Anweisung (drop_domain_statement)

Die DROP DOMAIN-Anweisung (drop_domain_statement) löscht die Definition eines Wertebereichs.

Syntax

<drop_domain_statement> ::= DROP DOMAIN <domain_name>

Beispiele

SQL-Tutorial, Strukturlink Wertebereiche

Erläuterung

Der Domänenname muss einen existierenden Wertebereich identifizieren. Der Wertebereich muss sich im Schema des aktuellen Benutzers befinden.

Die Metadaten des Wertebereichs werden aus dem Katalog gelöscht. Das Löschen eines Wertebereichs hat keine Auswirkungen auf Tabellen, in denen der Wertebereich zur Spaltendefinition benutzt wurde.


CREATE SEQUENCE-Anweisung (create_sequence_statement) (SAP-Bibliothek - Grundwissen)

CREATE SEQUENCE-Anweisung (create_sequence_statement)

Die CREATE SEQUENCE-Anweisung (create_sequence_statement) definiert ein Datenbankobjekt, das ganzzahlige Werte liefert (Nummerngenerator). Dieses Objekt wird im folgenden Sequenz genannt.

Syntax

<create_sequence_statement> ::= CREATE SEQUENCE [<schema_name>.]<sequence_name>
[INCREMENT BY <integer>] [START WITH <integer>]
[MAXVALUE <integer> | NOMAXVALUE] [MINVALUE <integer> | NOMINVALUE]
[CYCLE | NOCYCLE]
[CACHE <unsigned_integer> | NOCACHE]
[ORDER | NOORDER]

Beispiele

SQL-Tutorial, Strukturlink Nummerngeneratoren für Tabellen

Erläuterung

Die optionalen Angaben nach dem Sequenznamen sequence_name können in beliebiger Reihenfolge erfolgen.

Der aktuelle Benutzer muss ein RESOURCE-Benutzer oder Datenbankadministrator (DBA-Benutzer) sein und wird Eigentümer der Sequenz. Wenn kein Schema schema_name angegeben ist, wird das aktuelle Schema angenommen.

Die Sequenz wird dem implizit ermittelten oder dem explizit angegebenen Schema zugeordnet. Der aktuelle Benutzer muss das CREATEIN-Privileg für dieses Schema besitzen. Der Sequenzname muss sich von den Namen aller bereits in dem Schema existierenden Sequenzen unterscheiden.

Die von der Sequenz erzeugten ganzzahligen Werte können zur Vergabe von Schlüsselwerten benutzt werden.

INCREMENT BY

Definiert die Differenz des nächsten Sequenzwertes vom zuletzt vergebenen Wert. Ein negativer Wert von INCREMENT BY erzeugt eine fallende Sequenz. Wenn kein Wert angegeben wird, wird der Wert 1 verwendet.

START WITH

Definiert den ersten Sequenzwert. Wenn kein Wert angegeben wird, wird der für MAXVALUE angegebene Wert bzw. -1 bei fallenden und der für MINVALUE angegebene Wert bzw. 1 bei aufsteigenden Sequenzen benutzt.

MINVALUE | MAXVALUE

· MINVALUE: Definiert den kleinsten Wert, der durch die Sequenz erzeugt wird. Ist kein Wert für MINVALUE angegeben, wird bei negativem Wert für INCREMENT BY der kleinste mit 38 Ziffern darstellbare ganzzahlige Wert benutzt, bei positivem Wert für INCREMENT BY der Wert 1.

· MAXVALUE: Definiert den größten Wert, der durch die Sequenz erzeugt wird. Ist kein Wert für MAXVALUE angegeben, wird bei negativem Wert für INCREMENT BY der Wert -1 benutzt, bei positivem Wert für INCREMENT BY der größte mit 38 Ziffern darstellbare ganzzahlige Wert.

CYCLE | NOCYCLE

Ist weder CYCLE noch NOCYCLE angegeben, wird NOCYCLE angenommen.

· CYCLE: Bei aufsteigenden Sequenzen wird nach der Vergabe von MAXVALUE der Wert MINVALUE geliefert. Bei fallenden Sequenzen wird nach der Vergabe von MINVALUE der Wert MAXVALUE geliefert.

· NOCYCLE: Die Anforderung eines Sequenzwertes scheitert, wenn bereits das Ende der Sequenz erreicht wurde, d.h. wenn MAXVALUE bei aufsteigenden bzw. MINVALUE bei fallenden Sequenzen vergeben wurde

CACHE | NOCACHE

Ist weder CACHE noch NOCACHE angegeben, wird CACHE 20 angenommen.

· CACHE: Der Zugriff auf die Sequenz kann beschleunigt werden, weil die definierte Anzahl von Sequenzwerten bereits voraus im Speicher gehalten wird.

· NOCACHE: Es werden keine Sequenzwerte im voraus bestimmt.

ORDER | NOORDER

Die Angabe von ORDER bzw. NOORDER hat keinerlei Auswirkungen.

Die Spezifikation der Sequenzwerte kann mittels CURRVAL und NEXTVAL (Spezifikation von Werten) erfolgen. So können Sie den aktuellen Zählerstand erfragen oder erhöhen.


DROP SEQUENCE-Anweisung (drop_sequence_statement) (SAP-Bibliothek - Grundwissen)

DROP SEQUENCE-Anweisung (drop_sequence_statement)

Die DROP SEQUENCE-Anweisung (drop_sequence_statement) löscht einen Zahlengenerator (Sequenz).

Syntax

<drop_sequence_statement> ::= DROP SEQUENCE [<schema_name>.]<sequence_name>

Beispiele

SQL-Tutorial, Strukturlink Nummerngeneratoren für Tabellen

Erläuterung

Der aktuelle Benutzer muss Eigentümer der Sequenz sein oder das DROPIN-Privileg für das Schema besitzen, dem die zu löschende Sequenz zugeordnet ist.

Die Metadaten der Sequenz werden aus dem Datenbankkatalog entfernt.


CREATE SYNONYM-Anweisung (create_synonym_statement) (SAP-Bibliothek - Grundwissen)

CREATE SYNONYM-Anweisung (create_synonym_statement)

Die CREATE SYNONYM-Anweisung (create_synonym_statement) definiert ein Synonym (alternativer Name) für einen Tabellennamen.

Syntax

<create_synonym_statement> ::=
CREATE [PUBLIC] SYNONYM [<schema_name>.]<synonym_name> FOR <table_name>

Erläuterung

Der Tabellenname table_name darf keine temporäre Basistabelle bezeichnen. Der Benutzer muss ein Privileg auf der angegebenen Tabelle besitzen.

Als Schemaname schema_name vor dem Synonymnamen ist nur der Name des aktuellen Benutzers zulässig.

Der Synonymname kann überall an Stelle des Tabellennamens angegeben werden. Dies hat die gleiche Wirkung wie die Angabe des Tabellennamens, für den das Synonym definiert wurde.

PUBLIC

Wenn PUBLIC angegeben ist, darf der Synonymname nicht mit dem Namen eines in PUBLIC definierten Synonyms übereinstimmen. Es wird ein Synonym erzeugt, das für alle Benutzer zugreifbar ist.

Wenn PUBLIC nicht angegeben ist, wird ein privates Synonym erzeugt, das nur dem aktuellen Benutzer bekannt ist. In diesem Fall darf der Synonymname nicht mit dem Namen einer bereits existierenden Basis- oder View-Tabelle oder eines privaten Synonyms des aktuellen Benutzers übereinstimmen. Falls ein Synonym gleichen Namens mit dem PUBLIC-Attribut existiert, kann mit diesem vom aktuellen Benutzer nicht mehr zugegriffen werden, bis das private Synonym gelöscht wird.


DROP SYNONYM-Anweisung (drop_synonym_statement) (SAP-Bibliothek - Grundwissen)

DROP SYNONYM-Anweisung (drop_synonym_statement)

Die DROP SYNONYM-Anweisung (drop_synonym_statement) löscht ein Synonym (alternativer Name) für einen Tabellennamen.

Syntax

<drop_synonym_statement> ::=
DROP [PUBLIC] SYNONYM [<schema_name>.]<synonym_name>

Erläuterung

Der angegebene Synonymname muss ein existierendes Synonym des aktuellen Benutzers identifizieren. Als Schemaname ist nur der Name des aktuellen Benutzers zulässig.

Wenn PUBLIC angegeben ist, muss das durch den Synonymnamen identifizierte Synonym als PUBLIC definiert sein.

Die Synonymdefinition wird aus der Menge der dem Benutzer zur Verfügung stehenden Synonyme für Tabellennamen entfernt.


RENAME SYNONYM-Anweisung (rename_synonym_statement) (SAP-Bibliothek - Grundwissen)

RENAME SYNONYM-Anweisung (rename_synonym_statement)

Die RENAME SYNONYM-Anweisung (rename_synonym_statement) ändert den Namen eines Synonyms.

Syntax

<rename_synonym_statement> ::=
RENAME [PUBLIC] SYNONYM <old_synonym_name> TO <new_synonym_name>

<old_synonym_name> ::= <synonym_name>
<new_synonym_name> ::= <synonym_name>

Erläuterung

Der alte Synonymname old_synonym_name muss vom aktuellen Benutzer erzeugt worden sein.

Wenn PUBLIC angegeben ist, dann muss das alte Synonym als PUBLIC definiert sein.

Es darf keine Tabelle des aktuellen Benutzers mit dem neuen Synonymnamen new_synonym_name existieren.


CREATE VIEW-Anweisung (create_view_statement) (SAP-Bibliothek - Grundwissen)

CREATE VIEW-Anweisung (create_view_statement)

Die CREATE VIEW-Anweisung (create_view_statement) definiert eine View-Tabelle.

View-Tabelle

Eine View-Tabelle ist eine Sicht auf eine existierende Tabelle: Teile der Tabelle werden verdeckt und andere Teile bleiben sichtbar. Sie können View-Tabellen verwenden, um längere SELECT-Anweisungen abzukürzen. Sie können mit Hilfe von View-Tabellen unwichtige oder vertrauliche Daten verbergen.

Eine View-Tabelle ist nie physisch vorhanden, sondern wird erst aus den Zeilen der zugrundeliegenden Basistabelle(n) gebildet, wenn in einer SQL-Anweisung diese View-Tabelle angegeben wird.

Syntax

<create_view_statement> ::=
CREATE [OR REPLACE] VIEW <table_name> [(<alias_name>,...)] AS <query_expression> [WITH CHECK OPTION]

Beispiele

SQL-Tutorial, Strukturlink View-Tabellen, Konzepte des Datenbanksystems, Objekte im Schema HOTEL

Erläuterung

Wenn im View-Tabellennamen table_name kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen. Der View-Tabellenname darf nicht mit dem Namen einer bereits existierenden Tabelle des Schemas übereinstimmen.

Die Ausführung der CREATE VIEW-Anweisung führt zur Ablage von Metadaten im Datenbankkatalog, die die View-Tabelle beschreiben.

Die View-Tabelle ist jederzeit identisch mit der Tabelle, die Sie als Ergebnis des QUERY-Ausdrucks query_expression erhalten würden. Der QUERY-Ausdruck darf keine Parameterspezifikation enthalten. Der QUERY-Ausdruck darf keine temporäre Tabelle und keinen Ergebnistabellennamen referenzieren.

Jeder Tabellenausdruck der QUERY-Spezifikation im QUERY-Ausdruck der CREATE VIEW-Anweisung darf keinen QUERY-Ausdruck enthalten.

Wenn eine durch den QUERY-Ausdruck selektierte Spalte vom Datentyp LONG ist, dann muss die FROM-Klausel genau einen Tabellennamen enthalten, dem genau eine Basistabelle zugrundeliegt.

Join-View-Tabelle

Eine Join-View-Tabelle ist eine View-Tabelle, deren FROM-Klausel mehr als eine Tabelle oder eine Join-Tabelle enthält.

Komplexe View-Tabelle

Eine View-Tabelle ist eine komplexe View-Tabelle, wenn sie eine der folgenden Bedingungen erfüllt:

● Die Definition der View-Tabelle enthält DISTINCT oder GROUP BY oder HAVING.

● Die CREATE VIEW-Anweisung enthält EXCEPT, INTERSECT oder UNION.

● Die im QUERY-Ausdruck der CREATE VIEW-Anweisung enthaltene Suchbedingung enthält eine Subquery.

● Die CREATE VIEW-Anweisung enthält einen Outer Join, also einen OUTER JOIN-Indikator outer_join_indicator in einem JOIN-Prädikat der Suchbedingung.

Änderbare View-Tabelle

Eine View-Tabelle heißt änderbar, wenn sie keine komplexe View-Tabelle ist und auf keiner komplexen View-Tabelle basiert.

Änderbare Join-View-Tabelle

Eine änderbare Join-View-Tabelle ist eine änderbare View-Tabelle, für die zusätzlich folgende Bedingungen erfüllt sein müssen:

● Jede der View-Tabelle zugrundeliegende Basistabelle besitzt einen vom Benutzer definierten Schlüssel.

● Zwischen den der View-Tabelle zugrundeliegenden Basistabellen müssen referentielle CONSTRAINT-Definitionen festgelegt sein.

● Es gibt genau eine der View-Tabelle zugrundeliegende Basistabelle, die nicht referenzierte Tabelle referenced_table einer referentiellen CONSTRAINT-Definition zu einer anderen der View-Tabelle zugrundeliegenden Basistabelle ist. Diese Tabelle ist die Schlüsseltabelle der View-Tabelle.

● Für jede der View-Tabelle zugrundeliegende Basistabelle gibt es eine Folge von referentiellen CONSTRAINT-Definitionen, so dass die jeweilige Basistabelle von der Schlüsseltabelle aus erreichbar ist.

● Die referentiellen CONSTRAINT-Definitionen müssen sich in der Suchbedingung der CREATE VIEW-Anweisung als JOIN-Prädikat widerspiegeln, d. h. die Bedingung "Schlüsselspalte = Fremdschlüsselspalte" muss für jede Spalte jeder referentiellen CONSTRAINT-Definition vorhanden sein.

● In der CREATE VIEW-Anweisung muss von jeder referentiellen CONSTRAINT-Definition entweder die Primärschlüssel- oder die Fremdschlüsselspalte als selektierte Spalte enthalten sein, jedoch nicht beide.

● Die View-Tabelle muss mit WITH CHECK OPTION definiert sein.

Weitere Detailinformationen dazu finden Sie in Änderbare Join-View-Tabelle.

Privilegien

Der Benutzer muss das SELECT-Privileg für alle Spalten besitzen, die in der View-Definition vorkommen. Der Benutzer ist Eigentümer der View-Tabelle und besitzt mindestens das SELECT-Privileg dafür. Er darf das SELECT-Privileg für alle Spalten der View-Tabelle, die sich aus Spalten ableiten, für die er das Recht zur Weitergabe des SELECT-Privilegs besitzt, vergeben.

Das INSERT-, UPDATE- und DELETE-Privileg besitzt der Benutzer nur dann, wenn er die entsprechenden Privilegien für die der View-Tabelle bzw. Join-View-Tabelle zugrundeliegenden Tabellen besitzt, und wenn es sich um eine änderbare View-Tabelle bzw. Join-View-Tabelle handelt. Diese Privilegien darf er nur dann weitergeben, wenn er für alle der View-Tabelle bzw- Join-View-Tabelle zugrundeliegenden Tabellen das Recht besitzt, das jeweilige Privileg weiterzugeben.

Siehe auch:

INSERT-/UPDATE/DELETE-Privileg für Eigentümer der View-Tabelle

Privilegienspezifikation (priv_spec)

OR REPLACE

Wenn OR REPLACE nicht angegeben wird, darf der Tabellenname table_name nicht mit dem Namen einer existierenden View-Tabelle übereinstimmen.

Wenn OR REPLACE angegeben ist, darf der Tabellenname mit dem Namen einer existierenden View-Tabelle übereinstimmen. Die Definition der existierenden View-Tabelle wird in diesem Fall durch die neue Definition ersetzt. Das Datenbanksystem versucht dabei, vergebene Privilegien der existierenden View-Tabelle an die neue View-Definition anzupassen, so dass die Privilegierung der View-Tabelle normalerweise erhalten bleibt. Bei Konflikten, die das Datenbanksystem nicht entscheiden kann, erfolgt ein impliziter Entzug von Privilegien. Bei großen Unterschieden zwischen den beiden View-Definitionen kann die CREATE VIEW-Anweisung in folgendem Fall scheitern: Die CREATE VIEW-Anweisung einer auf der existierenden View-Tabelle basierenden View-Tabelle ist auf der neuen View-Definition nicht mehr fehlerfrei ausführbar.

Alias-Namen (alias_name)

Die Spaltennamen der View-Tabelle müssen eindeutig sein. Ist das in der durch den QUERY-Ausdruck erzeugten Ergebnistabelle nicht der Fall, müssen Alias-Namen vergeben werden, die die Spaltennamen der View-Tabelle definieren. Die Anzahl der Alias-Namen muss gleich der Anzahl der Spalten der durch den QUERY-Ausdruck erzeugten Ergebnistabelle sein. Wenn keine Alias-Namen angegeben sind, dann werden die Spaltennamen der durch den QUERY-Ausdruck erzeugten Ergebnistabelle für die View-Tabelle übernommen. Die Spaltenbeschreibungen der View-Tabelle werden von den entsprechenden Spalten des QUERY-Ausdrucks übernommen. Die FROM-Klausel des QUERY-Ausdrucks kann eine oder mehrere Tabellen enthalten.

WITH CHECK OPTION

Wenn die CREATE VIEW-Anweisung eine WITH CHECK OPTION enthält, dann muss der Eigentümer der View-Tabelle das INSERT-, UPDATE- oder DELETE-Privileg für die View-Tabelle besitzen.

Die Angabe von WITH CHECK OPTION bewirkt, dass durch die INSERT- oder UPDATE-Anweisung auf der View-Tabelle keine Zeilen erzeugt werden können, die anschließend nicht mehr über die View-Tabelle selektierbar sind, d.h. resultierende Zeilen müssen die Suchbedingung der View-Tabelle erfüllen.

Die CHECK OPTION wird vererbt, d.h. wenn eine View-Tabelle V mit WITH CHECK OPTION definiert wurde und V in der FROM-Bedingung einer änderbaren View-Tabelle V1 vorkommt, dann lassen sich über V1 nur Zeilen einfügen oder ändern, die über V selektiert werden können.


INSERT-/UPDATE-/DELETE-Privileg für Eigentümer der View-Tabelle (SAP-Bibliothek - Grundwissen)

INSERT-/UPDATE-/DELETE-Privileg für Eigentümer der View-Tabelle

Da View-Tabellen nur Sichten auf die in Basistabellen vorhandenen Daten darstellen, soll an dieser Stelle auf Besonderheiten der Vergabe der Privilegiene für View-Tabellen eingegangen werden.

INSERT-Privileg für Eigentümer der View-Tabelle

Der Eigentümer einer View-Tabelle besitzt das INSERT-Privileg, d.h. er darf die View-Tabelle als Tabelle, in die einzufügen ist, in der INSERT-Anweisung angeben, wenn folgende Bedingungen erfüllt sind:

· Es handelt sich um eine änderbare View-Tabelle.

· Der Eigentümer der View-Tabelle besitzt das INSERT-Privileg für alle Tabellen in der FROM-Klausel der CREATE VIEW-Anweisung.

· Die selektierten Spalten der CREATE VIEW-Anweisung bestehen nur aus Tabellenspalten table_columns oder Spaltennamen column_name, jedoch nicht aus Ausdrücken (expression) mit mehr als einem Spaltennamen.

· Die CREATE VIEW-Anweisung enthält jede Pflichtspalte aller Tabellen der FROM-Klausel als selektierte Spalte.

UPDATE-Privileg für Eigentümer der View-Tabelle

Der Eigentümer der View-Tabelle besitzt das UPDATE-Privileg für eine Spalte der View-Tabelle, d.h. er darf die Spalte als zu ändernde Spalte in einer UPDATE-Anweisung angeben, wenn folgende Bedingungen erfüllt sind:

· Es handelt sich um eine änderbare View-Tabelle.

· Der Eigentümer der View-Tabelle besitzt das UPDATE-Privileg für die Tabellenspalten table_columns bzw. den Spaltennamen column_name, durch den die Spalte definiert ist.

· Die Spalte ist durch die Angabe von Tabellenspalten oder durch einen Spaltennamen definiert, jedoch nicht durch einen Ausdruck expression mit mehr als einem Spaltennamen.

DELETE-Privileg für Eigentümer der View-Tabelle

Der Eigentümer der View-Tabelle besitzt das DELETE-Privileg für die View-Tabelle, d.h. er darf die View-Tabelle als Tabelle, aus der zu löschen ist, in der DELETE-Anweisung angeben, wenn folgende Bedingungen erfüllt sind:

· Es handelt sich um eine änderbare View-Tabelle.

· Der Eigentümer der View-Tabelle besitzt das DELETE-Privileg für alle Tabellen in der FROM-Klausel der CREATE VIEW-Anweisung.

Siehe auch:

Privilegienspezifikation (priv_spec)


Änderbare Join-View-Tabelle (SAP-Bibliothek - Grundwissen)

Änderbare Join-View-Tabelle

Der Begriff der änderbaren Join-View-Tabelle spielt eine wichtige Rolle. Daher soll an dieser Stelle neben der bereits bekannten allgemeinen Definition einer änderbaren Join-View-Tabelle eventuell notwendiges Detailwissen dargestellt werden.

Siehe auch:

CREATE VIEW-Anweisung (create_view_statement)

Erläuterung

Es wird ohne Beschränkung der Allgemeinheit davon ausgegangen, dass die Definition der Join-View-Tabelle V in der FROM-Klausel die Basistabellen T1,...,Tn (n>1) enthält.

● Seien Ti und Tj zwei von V selektierte Basistabellen.
Rij sei eine referentielle CONSTRAINT-Definition von Ti und Tj, in der Ti die referenzierende Tabelle und Tj die referenzierte Tabelle (referenced_table) ist.
PKj1,...,PKjm seien die Schlüsselspalten von Tj.
FKi1,...,FKim seien die korrespondierenden Fremdschlüsselspalten von Ti.
Die referentielle CONSTRAINT-Definition ist für V relevant, wenn das JOIN-Prädikat (PKj1=FKi1 AND ... AND PKjm=FKjm) Teil der Suchbedingung von V ist.

● Seien Ti und Tj zwei von V selektierte Basistabellen und Rij eine für V relevante referentielle CONSTRAINT-Definition von Ti und Tj.
Ti ist Vorgänger von Tj (Ti<Tj), wenn Rij die einzige für V relevante referentielle CONSTRAINT-Definition von Ti und Tj ist.

● Sei Rij eine für V relevante referentielle CONSTRAINT-Definition.
Rij definiert eine 1:1 Beziehung zwischen Ti und Tj, wenn die Fremdschlüsselspalten von Rij die Schlüsselspalten von Ti bilden.

● Sei Rij eine für V relevante referentielle CONSTRAINT-Definition und s eine Schlüsselspalte von Tj oder eine Fremdschlüsselspalte dieser referentiellen CONSTRAINT-Definition von Ti. Die Spalte s lässt sich aus V ableiten, wenn genau eine der folgenden Bedingungen zutrifft:
- s ist eine selektierte Spalte von V.
- Es existiert eine Schlüsselspalte oder eine Fremdschlüsselspalte s' einer für V relevanten referentiellen CONSTRAINT-Definition, die sich aus V ableiten lässt, und das JOIN-Prädikat s=s' ist Teil der Suchbedingung von V.

● Eine Spalte v von V korrespondiert mit einer Spalte s einer zugrundeliegenden Basistabelle T, wenn eine der folgenden Bedingungen erfüllt ist
- v ist i-te Spalte von V und s ist i-te selektierte Spalte von V
- v korrespondiert mit einer Schlüsselspalte PK von Tj einer für V relevanten referentiellen CONSTRAINT-Definition Rij und s ist die PK zugeordnete Fremdschlüsselspalte von Ti
- v korrespondiert mit einer Fremdschlüsselspalte FK von Ti einer für V relevanten referentiellen CONSTRAINT-Bedingung Rij und s ist die FK zugeordnete Schlüsselspalte von Tj.

Eine Join-View-Tabelle V ist änderbar, wenn die folgenden Bedingungen erfüllt sind:

● Jede Basistabelle Ti (1 <= i <= n) besitzt einen vom Benutzer definierten Schlüssel.

● Das Datenbanksystem muss in der Lage sein, eine Abarbeitungsreihenfolge der zugrundeliegenden Basistabellen zu bestimmen, d.h., es muss eine Anordnung Ti1,...,Tin der Tabellen T1,...,Tn existieren, so dass aus Tij<Tik folgt, dass j < k ist. Die Spalten von V, aus denen sich die Schlüsselspalten von Ti1 ableiten lassen, bilden den Schlüssel von V. Ti1 heißt Schlüsseltabelle von V. Die Anordnung der Tabellen muss nicht eindeutig sein.

● Ausgehend von einer Zeile der Schlüsseltabelle von V, muss es möglich sein, genau eine Zeile jeder zugrundeliegenden Basistabelle zuzuordnen, d.h. für jede Tabelle Tij (1 <= j <= n) gibt es eine Folge von Tabellen Ti1,...,Tij, so dass Ti1 < .. < Tij gilt.
Diese Folge ist für jede von V referenzierte Basistabelle eindeutig.

● Die Schlüsselspalten und Fremdschlüsselspalten aller für V relevanten referentiellen CONSTRAINT-Definitionen müssen aus den Spalten von V ableitbar sein.

● Die für die Erkennung der Relevanz einer referentiellen CONSTRAINT-Definition wichtigen JOIN-Prädikate müssen in Teilen der Suchbedingung liegen, die mit WITH CHECK OPTION definiert sind. Wenn die View-Definition nur Basistabellen enthält, so heißt das, dass die View-Tabelle mit WITH CHECK OPTION definiert sein muss. Ist eine View-Tabelle V aus einer View-Tabelle V' abgeleitet und wurde V' mit WITH CHECK OPTION definiert, so erbt V die CHECK OPTION für den Teil der Qualifikation, der durch V' vererbt wird.


DROP VIEW-Anweisung (drop_view_statement) (SAP-Bibliothek - Grundwissen)

DROP VIEW-Anweisung (drop_view_statement)

Die DROP VIEW-Anweisung (drop_view_statement) löscht eine View-Tabelle.

Syntax

<drop_view_statement> ::= DROP VIEW <table_name> [<cascade_option>]

Beispiele

SQL-Tutorial, Strukturlink View-Tabellen

Erläuterung

Der Tabellenname muss eine existierende View-Tabelle bezeichnen.

Der Benutzer muss der Eigentümer der angegebenen View-Tabelle sein oder das DROPIN-Privileg für das Schema besitzen, dem die View-Tabelle zugeordnet ist.

Die Metadaten der View-Tabelle und alle von dieser View-Tabelle abhängigen Synonyme, View-Tabellen und Privilegien werden gelöscht. Die der View-Tabelle zugrundeliegenden Tabellen bleiben unberührt.

<cascade_option>

Wenn keine CASCADE-Option angegeben ist, wird die View-Tabelle mit allen von ihr abhängigen View-Tabellen, Privilegien und Synonymen gelöscht.

· Wenn die CASCADE-Option RESTRICT angegeben ist und wenn auf der View-Tabelle basierende View-Tabellen oder Synonyme existieren, dann scheitert die DROP VIEW-Anweisung.

· Wenn die CASCADE-Option CASCADE angegeben ist, wird die View-Tabelle mit allen von ihr abhängigen View-Tabellen, Privilegien und Synonymen gelöscht.


RENAME VIEW-Anweisung (rename_view_statement) (SAP-Bibliothek - Grundwissen)

RENAME VIEW-Anweisung (rename_view_statement)

Die RENAME VIEW-Anweisung (rename_view_statement) ändert den Namen einer View-Tabelle.

Syntax

<rename_view_statement> ::= RENAME VIEW <old_table_name> TO <new_table_name>

<old_table_name> ::= <table_name>
<new_table_name> ::= <table_name

Erläuterung

Wenn kein Schemaname im Tabellennamen angegeben ist, wird das aktuelle Schema angenommen. Die Tabelle old_table_name muss eine View-Tabelle sein. Der aktuelle Benutzer muss Eigentümer der View-Tabelle sein und das CREATIN-Privileg im durch new_table_name identifizierten Schema besitzen.

Der neue Tabellenname darf noch nicht für eine Basis- oder View-Tabelle oder ein privates Synonym im durch new_table_name identifizierten Schema vergeben sein.

Die CREATE VIEW-Anweisung der View-Tabelle old_table_name wird an den neuen Namen angepaßt. Das Ergebnis dieser Anpassung kann der Tabelle DOMAIN.VIEWDEFS entnommen werden.

Die Definitionen von View-Tabellen, die auf der View-Tabelle old_table_name basieren, werden an den neuen Namen angepaßt.


CREATE INDEX-Anweisung (create_index_statement) (SAP-Bibliothek - Grundwissen)

CREATE INDEX-Anweisung (create_index_statement)

Die CREATE INDEX-Anweisung (create_index_statement) definiert einen Index einer Basistabelle.

Syntax

<create_index_statement> ::=
CREATE [UNIQUE] INDEX <index_name> ON <table_name> (<index_spec>)

<index_spec> ::=
<index_column_name>,...
| <dbfunction_name>(<column_name>,...) [ASC|DESC]

<index_column_name> ::=
<column_name> [ASC|DESC]

Beispiele

SQL-Tutorial, Strukturlink Indizes

Erläuterung

Indizes unterstützen den Zugriff auf die Tabellendaten über Nicht-Schlüsselspalten. Ihre Pflege bedeutet jedoch erhöhten Aufwand bei einer INSERT-, UPDATE oder DELETE-Anweisung.

Die Angabe eines Datenbankfunktionsnamens definiert einen Funktionsindex. Diese Indizes können Anfragen beschleunigen, die die Datenbankfunktion in ihrer Suchbedingung enthalten, oder die nach der Datenbankfunktion sortieren.

Ist kein Datenbankfunktionsname angegeben, wird der Index über die angegebenen Spalten der Tabelle erzeugt. Der Sekundärschlüssel setzt sich in diesem Fall aus den angegebenen Spalten der Tabelle zusammen, und zwar in der angegebenen Reihenfolge.

● Wenn im Tabellennamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

● Die angegebene Tabelle muss eine existierende Basistabelle sein, darf jedoch keine temporäre Tabelle sein. Der Indexname darf nicht mit einem bereits existierenden Indexnamen der Tabelle übereinstimmen.

● Die durch column_name definierte Spalte muss eine Spalte der angegebenen Tabelle sein. Diese Spalte darf keine LONG-Spalte sein. Alle Spaltennamen müssen paarweise verschieden sein.

● Der aktuelle Benutzer muss das INDEX-Privileg für die Spalten besitzen.

● Die durch den Datenbankfunktionsnamen identifizierte Datenbankfunktion muss folgende Bedingungen erfüllen:
Der aktuelle Benutzer muss das Privileg EXECUTE für die Datenbankfunktion besitzen.
Die Datenbankfunktion darf keine SQL-Anweisung enthalten.
Die angegebenen Spaltennamen müssen mit den Parametern der Funktion typverträglich sein.
Das Ergebnis der Datenbankfunktion muss deterministisch sein, d.h. die mehrmalige Ausführung der Funktion mit gleichen Parametern liefert immer das gleiche Resultat.

● Restriktionen für SQL-Anweisungen

UNIQUE

Durch diese Angabe wird sichergestellt, dass keine zwei Zeilen der angegebenen Tabelle in den indizierten Spalten dieselben Werte besitzen. Enthalten zwei Zeilen für alle Spalten eines Index jeweils den NULL-Wert, so gelten diese beiden Indexwerte nicht als identisch. Enthält mindestens eine Spalte nicht den NULL-Wert, so gelten zwei Zeilen, die in allen Nicht-NULL-Spalten den gleichen Wert besitzen, als identisch.

ASC | DESC

Die Indexwerte werden in aufsteigender oder absteigender Reihenfolge abgelegt. Fehlt die Angabe von ASC oder DESC, dann wird implizit ASC angenommen.

Siehe auch:

UNIQUE-Definition (unique_definition)


DROP INDEX-Anweisung (drop_index_statement) (SAP-Bibliothek - Grundwissen)

DROP INDEX-Anweisung (drop_index_statement)

Die DROP INDEX-Anweisung (drop_index_statement) löscht einen Index einer Basistabelle. Die Metadaten des Index werden aus dem Datenbankkatalog gelöscht. Der durch den Index belegte Speicherplatz wird freigegeben.

Syntax

<drop_index_statement> ::= DROP INDEX <index_name> [ON <table_name>]

Beispiele

SQL-Tutorial, Strukturlink Indizes

Erläuterung

Wenn im Tabellennamen kein Schemaname angegeben ist, wird das aktuelle Schema angenommen.

Der angegebene Index muss existieren und der angegebene Tabellenname muss der Name einer existierenden Basistabelle sein.

Wenn der Indexname eindeutig einen Index bezeichnet, kann die Angabe ON <table_name> entfallen.

Der aktuelle Benutzer muss Eigentümer der angegebenen Tabelle sein oder das INDEX-Privileg für sie besitzen.


ALTER INDEX-Anweisung (alter_index_statement) (SAP-Bibliothek - Grundwissen)

ALTER INDEX-Anweisung (alter_index_statement)

Die ALTER INDEX-Anweisung (alter_index_statement) steuert die Verwendung eines Index bei Datenanfragen.

Syntax

<alter_index_statement> ::= ALTER INDEX <index_name> [ON <table_name>] ENABLE
| ALTER INDEX <index_name> [ON <table_name>] DISABLE
| ALTER INDEX <index_name> [ON <table_name>] INIT USAGE

Erläuterung

Wenn im Tabellennamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Die Ausführung einer CREATE INDEX-Anweisung führt zur Erzeugung eines Index über den angegebenen Spalten. Bei allen folgenden SQL-Anweisungen zur Datenmanipulation (INSERT-Anweisung, UPDATE-Anweisung, DELETE-Anweisung) wird dieser Index der SQL-Anweisung entsprechend verändert. Bei allen anderen SQL-Anweisungen, in denen einzelne Zeilen einer Tabelle angegeben werden, kann das Datenbanksystem diesen Index zur Beschleunigung der Suche nach diesen Zeilen verwenden.

ALTER INDEX … DISABLE

Der Index kann nicht mehr für diese Suche verwendet werden, wird jedoch weiterhin bei Verwendung der SQL-Anweisungen INSERT, UPDATE oder DELETE verändert.

ALTER INDEX … ENABLE

Der Index kann wieder für die Suche verwendet werden.

ALTER INDEX … INIT USAGE

Die Spalte INDEX_USED in der Systemtabelle DOMAIN.INDEXES wird mit 0 initialisiert, d.h die Zählung, wie häufig ein Index genutzt wird, wird neu gestartet.


RENAME INDEX-Anweisung (rename_index_statement) (SAP-Bibliothek - Grundwissen)

RENAME INDEX-Anweisung (rename_index_statement)

Die RENAME INDEX-Anweisung (rename_index_statement) ändert den Namen eines Index.

Syntax

<rename_index_statement> ::= RENAME INDEX <old_index_name> [ON <table_name>] TO <new_index_name>

<old_index_name> ::= <index_name>
<new_index_name> ::= <index_name>

Erläuterung

Wenn im Tabellennamen kein Schemaname angegeben ist, wird das aktuelle Schema angenommen.

Der angegebene Tabellenname muss der Name einer existierenden Basistabelle sein.

Der durch old_index_name identifizierte Index muss existieren. Wenn dieser Index eindeutig ist, kann die Angabe ON <table_name> entfallen.

Der aktuelle Benutzer muss Eigentümer der angegebenen Tabelle sein oder das INDEX-Privileg für diese Tabelle besitzen.

Der neue Indexname darf nicht mit einem bereits existierenden Indexnamen eines Index der Tabelle übereinstimmen.


CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement) (SAP-Bibliothek - Grundwissen)

CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement)

Die CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement) definiert eine Datenbankprozedur.

Syntax

<create_dbproc_statement> ::= CREATE DBPROC[EDURE] <dbproc_name> [(<formal_parameter>,...)] [RETURNS CURSOR] AS <routine>

<formal_parameter> ::=
IN <argument> <data_type>
| OUT <argument> <data_type>
| INOUT <argument> <data_type>

<argument> ::= <identifier>

Beispiele

SQL-Tutorial, Strukturlink Datenbankprozeduren

Erläuterung

Wenn im Datenbankprozedurnamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Die Datenbankprozedur wird dem implizit ermittelten oder dem explizit angegebenen Schema zugeordnet. Der aktuelle Benutzer muss das CREATEIN-Privileg für dieses Schema besitzen. Der Prozedurname muss sich von den Namen aller bereits im Schema existierenden Datenbankprozeduren unterscheiden.

Der aktuelle Benutzer ist der Eigentümer einer Datenbankprozedur. Er besitzt das EXECUTE-Privileg zur Ausführung der Datenbankprozedur.

Parameter

Eine Anwendung tauscht beim Aufruf der Datenbankprozedur durch die CALL-Anweisung Daten über Parameter aus, die durch die formalen Parameter formal_parameter definiert werden. Einem formalen Parameter der Datenbankprozedur entspricht normalerweise eine Variable der Anwendung.

IN | OUT | INOUT

Der Modus des Parameters (IN | OUT | INOUT) legt fest, in welche Richtung die Daten beim Aufruf der Prozedur übergeben werden.

● IN: Durch IN wird ein Eingabeparameter definiert, d.h. beim Aufruf der Datenbankprozedur wird der Wert der Variablen an die Datenbankprozedur übertragen.

● OUT: Durch OUT wird ein Ausgabeparameter definiert, d.h. nach Beendigung der Prozedur wird der Wert des formalen Parameters aus der Datenbankprozedur an die Variable übertragen.

● INOUT: Durch INOUT wird ein Ein-/Ausgabeparameter definiert, der die Möglichkeiten von IN und OUT kombiniert.

Argument

Durch die Angabe eines Arguments argument wird einem formalen Parameter der Datenbankprozedur ein Name zugeordnet. Innerhalb der Datenbankprozedur kann der Parameter dann mit diesem Namen als Variable in Ausdrücken und Zuweisungen benutzt werden.

Datentyp

Als Datentyp data_type des formalen Parameters einer Datenbankprozedur sind nur die Datentypen BOOLEAN, CHAR[ACTER], DATE, FIXED, FLOAT, INT[EGER], NUMBER, REAL, SMALLINT, TIME, TIMESTAMP und VARCHAR zulässig.

RETURNS CURSOR

Bei Angabe von RETURNS CURSOR wird eine Datenbankprozedur definiert, deren Aufruf eine Ergebnistabelle liefert.

Der Name dieser Tabelle wird durch die Systemvariable $CURSOR definiert. In der Datenbankprozedur muss deshalb eine Anweisung enthalten sein, die eine Ergebnistabelle mit dem Ergebnismengennamen $CURSOR erzeugt.

Der Wert von $CURSOR wird von den meisten Programmierspracheneinbettungen bereits vorgegeben, kann jedoch auch in der Datenbankprozedur explizit vergeben werden.

CREATE DBPROC hotels_of_town (IN zip CHAR(5))
RETURNS CURSOR AS
$CURSOR = 'HOTEL_CURSOR';
DECLARE :$CURSOR CURSOR FOR
SELECT * FROM hotel.hotel WHERE zip = :zip;

Siehe auch:

CREATE SYSTEM TRIGGER-Anweisung

CREATE TRIGGER-Anweisung


Routine (routine) (SAP-Bibliothek - Grundwissen)

Routine (routine)

Der als Routine (routine) bezeichnete Teil der CREATE DBPROC[EDURE]-Anweisung, CREATE TRIGGER-Anweisung, CREATE SYSTEM TRIGGER-Anweisung oder CREATE FUNCTION-Anweisung ist die Implementierung der Datenbankprozedur, des Triggers oder der Datenbankfunktion. Sie besteht aus optionalen Variablendeklarationen und Anweisungen.

Syntax

<routine> ::= [<local_variables>] <statement_list>;

<local_variables> ::= VAR <local_variable_list>;
<local_variable_list> ::= <local_variable>
| <local_variable_list>; <local_variable>
<local_variable> ::= <variable_name> <data_type>
<variable_name> ::= <identifier>

<statement_list> ::= <statement> | <statement_list> ; <statement>

Kontrollstrukturen, Anweisungen und SQL-Anweisungen (statement)

<statement> ::= BEGIN <statement_list> END
| BREAK | CONTINUE | CONTINUE EXECUTE
| <if_statement>
| <while_statement>
| <assignment_statement>
| <case_statement>
| RETURN [<expression>]
| STOP (<expression> [,<expression>] )
| TRY <statement_list>; CATCH <statement>
| <routine_sql_statement>

<if_statement> ::= IF <search_condition> THEN <statement> [ELSE <statement>]
<while_statement> ::= WHILE <search_condition> DO <statement>
<assignment_statement> ::= [SET] <variable_name> = <expression>
<case_statement> ::= <simple_case_statement> | <searched_case_statement>

<routine_sql_statement> ::=
<call_statement>
| <close_statement>
| <create_table_temp>
| <declare_cursor_statement>
| <delete_statement>
| <drop_table_temp>
| <fetch_statement>
| <insert_statement>
| <lock_statement>
| <recursive_declare_cursor_statement>
| <select_statement>
| <single_select_statement>
| <subtrans_statement>
| <update_statement>

<create_table_temp> ::= <! <create_table_statement> für das Anlegen temporärer Tabellen, d.h. der Tabellenname table_name in der CREATE TABLE-Anweisung muss die Form TEMP.<identifier> haben !>

<drop_table_temp> ::= DROP TABLE TEMP.<identifier>

Beispiele

SQL-Tutorial

● Strukturlink Datenbankprozeduren

● Strukturlink Datenbankfunktionen

● Strukturlink Datenbanktrigger

Erläuterung

Die im Folgenden getroffenen Aussagen für Datenbankprozeduren gelten ebenfalls für Trigger bzw. Datenbankfunktionen.

Variablen

Die lokalen Variablen der Datenbankprozedur müssen vor der ersten Benutzung explizit unter Angabe eines Datentyps deklariert werden. Es sind nur die Datentypen BOOLEAN, CHAR[ACTER], DATE, FIXED, FLOAT, INT[EGER], NUMBER, REAL, SMALLINT, TIME, TIMESTAMP und VARCHAR zulässig. Die Variablen können nach ihrer Deklaration beliebig in SQL-Anweisungen und Anweisungen benutzt werden.

Jede Datenbankprozedur besitzt implizit die Variablen $RC, $ERRMSG und $COUNT.

Die $RC-Variable liefert nach der Ausführung einer SQL-Anweisung einen numerischen Fehlercode zurück. Der Wert 0 bedeutet, dass die SQL-Anweisung erfolgreich ausgeführt wurde.

Parallel zu $RC liefert die $ERRMSG-Variable eine maximal 80 Zeichen lange Erläuterung des Fehlers.

Die Anzahl der in einer SQL-Anweisung bearbeiteten Zeilen kann der $COUNT-Variablen entnommen werden. Im Fall einer QUERY-Anweisung kann diese Variable den Wert -1 haben, der bedeutet, dass eine unbekannte Anzahl von Sätzen, aber mindestens einer, das Ergebnis der QUERY-Anweisung bildet. Im Fall einer DELETE-Anweisung kann diese Variable den Wert -1 haben, der bedeutet, dass eine unbekannt große Anzahl von Sätzen gelöscht wurde, gegebenenfalls auch 0 Sätze.

Variablen kann mit Hilfe der Anweisung assignment_statement ein Wert zugewiesen werden.

Kontrollstrukturen

Die IF-Anweisung if_statement wertet zunächst die Suchbedingung aus. Ist diese erfüllt, so wird die im THEN-Zweig definierte Anweisung ausgeführt, andernfalls wird - wenn vorhanden - die Anweisung im ELSE-Zweig ausgeführt.

Die WHILE-Anweisung while_statement ermöglicht die bedingte Wiederholung von Anweisungen. Solange die angegebene Suchbedingung zutrifft, wird die Anweisung ausgeführt. Insbesondere wird die Bedingung vor der ersten Ausführung der Anweisung geprüft. Gegebenenfalls wird die Anweisung also gar nicht ausgeführt. Durch Angabe von BREAK kann die Schleife sofort ohne Überprüfung der Bedingung verlassen werden. Die Angabe von CONTINUE innerhalb der Schleife bewirkt, dass die Bedingung sofort neu bewertet und die Schleife abhängig vom Resultat erneut durchlaufen oder verlassen wird.

Die CASE-Anweisung case_statement erlaubt die bedingt Anweisungsausführung abhängig von Suchbedingungen oder der Gleichheit von Operanden. Es werden einfache und allgemeine CASE-Anweisungen unterschieden.

RETURN

CREATE DBPROC- und CREATE TRIGGER-Anweisung: Die Angabe von RETURN ermöglicht das sofortige fehlerfreie Verlassen der umgebenden Datenbankprozedur.

CREATE FUNCTION-Anweisung: Die Angabe von RETURN <expression> ermöglicht das Verlassen der Datenbankfunktion bei gleichzeitiger Übergabe des Funktionswertes <expression>.

Fehlerbehandlung

Wenn in der Anweisungsfolge zwischen TRY und CATCH ein SQL-Fehler auftritt, wird unverzüglich in die auf das CATCH folgende Anweisung verzweigt. In dieser Anweisung kann die eigentliche Fehlerbehandlung programmiert werden. Wird hier CONTINUE EXECUTE ausgeführt, erfolgt ein Sprung unmittelbar hinter die Anweisung, die den Fehler ausgelöst hat.

Durch Aufruf der STOP-Funktion wird die Ausführung der Datenbankprozedur sofort unterbrochen. Der Wert des ersten Parameters der STOP-Funktion ist die Rück- oder Fehlermeldung, die die Anwendung als Resultat des Aufrufs der Datenbankprozedur erhält. Zusätzlich kann ein Fehlertext geliefert werden.

SQL-Anweisungen (routine_sql_statement)

In den SQL-Anweisungen routine_sql_statement der Datenbankprozedur müssen Tabellen immer vollständig, d.h. unter Angabe des Schemas angegeben werden. Im Falle von SELECT-Anweisungen reicht die vollständige Angabe des Tabellennamens in der FROM-Klausel.

Restriktionen

Die Anweisungsfolge statement_list darf nicht mehr als 255 SQL-Anweisungen enthalten.

Die Länge einer SQL-Anweisung routine_sql_statement darf ca. 8 KB nicht überschreiten.


Allgemeine CASE-Anweisung (searched_case_statement) (SAP-Bibliothek - Grundwissen)

Allgemeine CASE-Anweisung (searched_case_statement)

Die allgemeine CASE-Anweisung (searched_case_statement) ist ein Syntaxelement, das in einer Routine zur Definition einer Datenbankprozedur (siehe CREATE DBPROC[EDURE]-Anweisung), einer Datenbankfunktion (siehe CREATE FUNCTION-Anweisung) oder eines Triggers (siehe CREATE TRIGGER-Anweisung) verwendet werden kann.

Syntax

<searched_case_statement> ::=
CASE
<searched_case_when_clause>...
[<case_else_clause>]
END [CASE]

<searched_case_when_clause> ::=
WHEN <search_condition> THEN <statement>;
<case_else_clause> ::= ELSE <statement>;

Erläuterung

Eine CASE-Anweisung case_statement erlaubt die bedingte Anweisungsausführung abhängig von Suchbedingungen oder der Gleichheit von Operanden.

Im Fall einer allgemeinen CASE-Anweisung searched_case_statement wird die erste erfüllte Suchbedingung bestimmt, die zugehörige Anweisung ausgeführt und die CASE-Anweisung beendet.

CASE
WHEN digit = 0 THEN toCHAR = 'zero';
WHEN digit = 1 THEN toCHAR = 'one';
WHEN digit = 2 THEN toCHAR = 'two';
WHEN digit = 3 THEN toCHAR = 'three';
WHEN digit = 4 THEN toCHAR = 'four';
WHEN digit = 5 THEN toCHAR = 'five';
WHEN digit = 6 THEN toCHAR = 'six';
WHEN digit = 7 THEN toCHAR = 'seven';
WHEN digit = 8 THEN toCHAR = 'eight';
WHEN digit = 9 THEN toCHAR = 'nine';
ELSE STOP(-29000, 'no digit');
END CASE

Ist in einer CASE-Anweisung kein passendes Literal bzw. keine erfüllte Suchbedingung vorhanden, wird die im ELSE-Zweig definierte Anweisung ausgeführt.

Ist auch kein ELSE-Zweig vorhanden, wird der Laufzeitfehler -28901 geliefert.

Siehe auch:

Einfache CASE-Anweisung (simple_case_statement)


Einfache CASE-Anweisung (simple_case_statement) (SAP-Bibliothek - Grundwissen)

Einfache CASE-Anweisung (simple_case_statement)

Die einfache CASE-Anweisung (simple_case_statement) ist ein Syntaxelement, das in einer Routine zur Definition einer Datenbankprozedur (siehe CREATE DBPROC[EDURE]-Anweisung), einer Datenbankfunktion (CREATE FUNCTION-Anweisung) oder eines Triggers (siehe CREATE TRIGGER-Anweisung) verwendet werden kann.

Syntax

<simple_case_statement> ::= CASE <expression>
<simple_case_when_clause>...
[<case_else_clause>]
END [CASE]

<simple_case_when_clause>
::= WHEN <literal>[, ...]
THEN <statement>;
<case_else_clause> ::= ELSE <statement>;

Erläuterung

Eine CASE-Anweisung case_statement erlaubt die bedingte Anweisungsausführung abhängig von Suchbedingungen oder der Gleichheit von Operanden.

Im Fall einer einfachen CASE-Anweisung simple_case_statement wird der Ausdruck mit den Literalen verglichen. Stimmt der Ausdruck mit einem Literal überein, wird die zugehörige Anweisung ausgeführt und die CASE-Anweisung beendet.

CASE digit
WHEN 0 THEN toCHAR = 'zero';
WHEN 1 THEN toCHAR = 'one';
WHEN 2 THEN toCHAR = 'two';
WHEN 3 THEN toCHAR = 'three';
WHEN 4 THEN toCHAR = 'four';
WHEN 5 THEN toCHAR = 'five';
WHEN 6 THEN toCHAR = 'six';
WHEN 7 THEN toCHAR = 'seven';
WHEN 8 THEN toCHAR = 'eight';
WHEN 9 THEN toCHAR = 'nine';
ELSE STOP(-29000, 'no digit');
END CASE

Ist in einer CASE-Anweisung kein passendes Literal bzw. keine erfüllte Suchbedingung vorhanden, wird die im ELSE-Zweig definierte Anweisung ausgeführt.

Ist auch kein ELSE-Zweig vorhanden, wird der Laufzeitfehler -28901 geliefert.

Siehe auch:

Allgemeine CASE-Anweisung (searched_case_statement)


DROP DBPROC[EDURE]-Anweisung (drop_dbproc_statement) (SAP-Bibliothek - Grundwissen)

DROP DBPROC[EDURE]-Anweisung (drop_dbproc_statement)

Die DROP DBPROC[EDURE]-Anweisung (drop_dbproc_statement) löscht eine Datenbankprozedur.

Syntax

<drop_dbproc_statement> ::= DROP DBPROC[EDURE] <dbproc_name>

Beispiele

SQL-Tutorial, Strukturlink Datenbankprozeduren

Erläuterung

Wenn im Datenbankprozedurnamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Der aktuelle Benutzer muss Eigentümer der Datenbankprozedur sein oder das DROPIN-Privileg für das Schema besitzen, dem die Datenbankprozedur zugeordnet ist.

Die Metadaten der Datenbankprozedur werden gelöscht.


CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement)

Die CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement) definiert einen Trigger für den Restart.

Syntax

<create_system_trigger_statement> ::=
CREATE SYSTEM TRIGGER [<schema_name>.]<trigger_name> AFTER RESTART EXECUTE (<routine>)

Erläuterung

Ein System-Trigger ist eine spezielle Datenbankprozedur, die im Verlauf eines Restarts implizit ausgeführt wird. Die Ausführung erfolgt zu einem Zeitpunkt, zu dem die Datenbankinstanz zwar bereits vollständig gestartet ist, jedoch noch keine Verbindungen an die Datenbankinstanz möglich sind.

Wenn vor dem Triggernamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen. Der Trigger wird dem implizit ermittelten oder dem explizit angegebenen Schema zugeordnet.

Der aktuelle Benutzer muss ein Datenbankadministrator sein. Er wird Eigentümer des System-Triggers.

Der aktuelle Benutzer muss das CREATEIN-Privileg für dieses Schema besitzen. Der Triggername muss sich von den Namen aller bereits im Schema existierenden Triggernamen unterscheiden.

Wenn in der Datenbank mehr als ein System-Trigger definiert ist, so werden diese in einer beliebigen Reihenfolge ausgeführt.

<routine>

Wird der Trigger durch STOP mit einer Fehlernummer ungleich Null beendet, scheitert der Restart. Ein Restart der Datenbankinstanz ist in diesem Fall nur möglich, indem die System-Trigger deaktiviert werden (Datenbankparameter ENABLE_SYSTEM_TRIGGERS).


DROP SYSTEM TRIGGER-Anweisung (drop_system_trigger_statement) (SAP-Bibliothek - Grundwissen)

DROP SYSTEM TRIGGER-Anweisung (drop_system_trigger_statement)

Die DROP SYSTEM TRIGGER-Anweisung (drop_system_trigger_statement) löscht einen System-Trigger.

Syntax

<drop_system_trigger_statement> ::= DROP SYSTEM TRIGGER [<schema_name>.]<trigger_name>

Erläuterung

Wenn vor dem Triggernamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Der aktuelle Benutzer muss Eigentümer des System-Triggers sein.

Die Metadaten des System-Triggers werden gelöscht.


CREATE FUNCTION-Anweisung (create_function_statement) (SAP-Bibliothek - Grundwissen)

CREATE FUNCTION-Anweisung (create_function_statement)

Die CREATE FUNCTION-Anweisung (create_function_statement) definiert eine Datenbankfunktion.

Syntax

<create_function_statement> ::= CREATE [PUBLIC] FUNCTION <dbfunction_name> [(<formal_parameter1>,..)] RETURNS <data_type> [DETERMINISTIC] AS <routine>

<formal_parameter1> ::= <argument1> <data_type>
<argument1> ::= <identifier>

Beispiele

SQL-Tutorial, Strukturlink Datenbankfunktionen

Erläuterung

Wenn im Datenbankfunktionsnamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Die Datenbankfunktion wird dem implizit ermittelten oder dem explizit angegebenen Schema zugeordnet. Der aktuelle Benutzer muss das CREATEIN-Privileg für dieses Schema besitzen. Der Funktionsname muss sich von den Namen aller bereits im Schema existierenden Datenbankfunktionen unterscheiden.

Der aktuelle Benutzer ist der Eigentümer einer Datenbankfunktion. Er besitzt das EXECUTE-Privileg zur Ausführung der Datenbankfunktion und zur Weitergabe des Ausführungsrechtes.

Wenn in der Datenbankfunktion eine Ergebnistabelle erzeugt wird, dann muss sich deren Name vom Ergebnistabellennamen der aufrufenden SQL-Anweisung unterscheiden.

Argument

Durch die Angabe eines Arguments argument1 wird einem formalen Parameter der Datenbankfunktion ein Name zugeordnet. Innerhalb der Datenbankfunktion kann der Parameter dann mit diesem Namen als Variable in Ausdrücken und Zuweisungen benutzt werden.

Datentyp

Als Datentyp data_type des formalen Parameters einer Datenbankfunktion sind nur die Datentypen BOOLEAN, CHAR[ACTER], DATE, FIXED, FLOAT, INT[EGER], NUMBER, REAL, SMALLINT, TIME, TIMESTAMP und VARCHAR zulässig.

Datentypen werden nomalerweise mit Länge und Genauigkeit definiert. Bei Verwenden von VARCHAR bzw. NUMBER werden Länge bzw. Genauigkeit nicht angegeben. In diesen Fällen leitet das Datenbanksystem Länge bzw. Genauigkeit automatisch abhängig vom Kontext des Funktionsaufrufs ab.

PUBLIC

Bei Angabe von PUBLIC wird eine globale Datenbankfunktion erzeugt, die ohne Angabe eines Schemanamens aufgerufen werden kann. Der Funktionsname darf in diesem Fall keinen Schemanamen enthalten und er darf nicht mit dem Namen einer weiteren globalen Datenbankfunktion übereinstimmen.

RETURNS

Als Datentyp des Rückgabewertes sind nur die Typen BOOLEAN, CHAR[ACTER], DATE, DEC[IMAL], DOUBLE, FLOAT, INT[EGER], NUMBER, NUMERIC, REAL, SMALLINT,TIME, TIMESTAMP und VARCHAR zulässig.

DETERMINISTIC

Bei Angabe von DETERMINISTIC wird zugesichert, dass die Funktion ein deterministisches Verhalten besitzt. Dies bedeutet, dass bei gleichen Eingabewerten immer der gleiche Rückgabewert geliefert wird.

Die Angabe von DETERMINISTIC ist zwingend erforderlich, wenn Sie die Funktion zur Erzeugung eines Funktionsindex nutzen wollen.


DROP FUNCTION-Anweisung (drop_function_statement) (SAP-Bibliothek - Grundwissen)

DROP FUNCTION-Anweisung (drop_function_statement)

Die DROP-FUNCTION-Anweisung (drop_function_statement) löscht eine Datenbankfunktion.

Syntax

<drop_function_statement> ::= DROP [PUBLIC] FUNCTION <dbfunction_name>

Beispiele

SQL-Tutorial, Strukturlink Datenbankfunktionen

Erläuterung

Wenn im Datenbankfunktionsnamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Der aktuelle Benutzer muss Eigentümer der Datenbankfunktion sein oder das DROPIN-Privileg für das Schema besitzen, dem die Datenbankfunktion zugeordnet ist.

Die Metadaten der Datenbankfunktion werden gelöscht.

PUBLIC

Wenn Sie eine Datenbankfunktion löschen wollen, die mit der Eigenschaft PUBLIC angelegt wurde, müssen Sie die DROP PUBLIC FUNCTION-Anweisung für diese Funktion verwenden.


CREATE TRIGGER-Anweisung (create_trigger_statement) (SAP-Bibliothek - Grundwissen)

CREATE TRIGGER-Anweisung (create_trigger_statement)

Die CREATE TRIGGER-Anweisung (create_trigger_statement) definiert einen Trigger für eine Basistabelle.

Syntax

<create_trigger_statement> ::= CREATE TRIGGER <trigger_name> FOR <table_name>
AFTER <trigger_event>,... EXECUTE (<routine>) [WHENEVER <search_condition>]

<trigger_event> ::= INSERT
| UPDATE [(<column_list>)]
| DELETE
<column_list> ::= <column_name> | <column_list>,<column_name>

Beispiele

SQL-Tutorial, Strukturlink Datenbanktrigger

Erläuterung

Ein Trigger ist eine spezielle Datenbankprozedur, die einer Basistabelle zugeordnet ist. Ein Trigger kann nicht explizit ausgeführt werden, sondern wird vom Datenbanksystem automatisch ausgeführt, wenn definierte Ereignisse trigger_event auf der Tabelle eintreten.

Wenn im Tabellennamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Der Tabellenname muss eine existierende Tabelle des Schemas identifizieren. Der aktuelle Benutzer muss Eigentümer der angegebenen Tabelle sein.

<trigger_event>

Das Trigger-Ereignis trigger_event definiert, wodurch der Trigger ausgelöst wird. Der Aufruf des Triggers erfolgt immer nach der fehlerfreien Bearbeitung des auslösenden Ereignisses.

INSERT: Das Trigger-Ereignis INSERT bewirkt für jede Zeile, die in die Tabelle eingefügt wird, eine Ausführung des Triggers.

UPDATE: Das Trigger-Ereignis UPDATE bewirkt für jede Änderung einer Zeile der Tabelle eine Ausführung des Triggers. Wenn eine Spaltenliste column_list angegeben ist, erfolgt der Aufruf nur, wenn eine der in der Spaltenliste enthaltenen Spalten verändert wurde.

DELETE: Das Trigger-Ereignis DELETE bewirkt für jede gelöschte Zeile der Tabelle einen Aufruf des Triggers.

Zu jedem Trigger-Ereignis darf pro Tabelle maximal ein Trigger definiert werden.

Sie können bei einer INSERT-, UPDATE- bzw. DELETE-Anweisung durch Angabe von IGNORE TRIGGER erreichen, dass das Trigger-Ereignis INSERT, UPDATE bzw. DELETE ignoriert wird.

<routine>

Beachten Sie folgende Informationen zur Trigger-Routine routine.

Jeder INSERT-Trigger besitzt implizit für jede Spalte der Tabelle eine korrespondierende Variable NEW.<column_name>. Bei der Ausführung des Triggers besitzt diese Variable den Wert der korrespondierenden Spalte der eingefügten Zeile. Die Angabe von NEW ist nur für in routine_sql_statements genannte SQL-Anweisungen erlaubt. Für die anderen Anweisungen führt die Angabe von NEW zu einem Fehler.

Jeder UPDATE-Trigger besitzt implizit für jede Spalte der Tabelle die korrespondierenden Variablen NEW.<column_name> und OLD.<column_name>. Bei der Ausführung des Triggers besitzt die Variable OLD.<column_name> den Wert der korrespondierenden Spalte vor und NEW.<column_name> den Wert der Spalte nach der Änderung der Zeile. Die Angabe von NEW und OLD sind optional.

Jeder DELETE-Trigger besitzt implizit für jede Spalte der Tabelle eine korrespondierende Variable OLD.<column_name>. Bei der Ausführung des Triggers besitzt diese Variable den Wert der korrespondierenden Spalte der gelöschten Zeile. Die Angabe von OLD ist nur für in routine_sql_statements genannte SQL-Anweisungen erlaubt. Für die anderen Anweisungen führt die Angabe von OLD zu einem Fehler.

In SQL-Anweisungen statement, die in Triggern verwendet werden und zu den in routine_sql_statements genannten Anweisungen gehören, müssen :NEW und :OLD immer mit Doppelpunkt verwendet werden (Beispielzeile UPDATE hotel.room SET hno = :NEW.hno WHERE hno = :OLD.hno).

In SQL-Anweisungen, die in Triggern verwendet werden und nicht zu den in routine_sql_statements genannten Anweisungen gehören, müssen NEW und OLD immer ohne Doppelpunkt verwendet werden (Beispielzeile IF NEW.hno <> OLD.hno).

Wird der Trigger durch STOP mit einer Fehlernummer ungleich Null beendet, scheitert die gesamte SQL-Anweisung, die den Trigger ausgelöst hat.

Die SUBTRANS-Anweisung ist innerhalb eines Triggers nicht zulässig.

Bei Angabe einer WHENEVER-Bedingung wird der Trigger nur ausgeführt, wenn die Suchbedingung erfüllt ist. Die Bedingung darf keine Subquery und keine Set-Funktionen enthalten.

Siehe auch:

CREATE SYSTEM TRIGGER-Anweisung

CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement)


DROP TRIGGER-Anweisung (drop_trigger_statement) (SAP-Bibliothek - Grundwissen)

DROP TRIGGER-Anweisung (drop_trigger_statement)

Die DROP TRIGGER-Anweisung (drop_trigger_statement) löscht einen Trigger einer Tabelle.

Syntax

<drop_trigger_statement> ::= DROP TRIGGER <trigger_name> OF <table_name>

Beispiele

SQL-Tutorial, Strukturlink Datenbanktrigger

Erläuterung

Wenn im Tabellennamen kein Schema angegeben ist, wird implizit das aktuelle Schema angenommen.

Der Tabellenname muss eine existierende Tabelle des Schemas identifizieren. Der aktuelle Benutzer muss Eigentümer der angegebenen Tabelle sein.

Der angegebene Triggername muss einen existierenden Trigger der Tabelle bezeichnen.

Die Metadaten des Triggers werden gelöscht.


COMMENT ON-Anweisung (comment_on_statement) (SAP-Bibliothek - Grundwissen)

COMMENT ON-Anweisung (comment_on_statement)

Die COMMENT ON-Anweisung (comment_on_statement) erzeugt, ändert oder löscht einen Kommentar zu einem Datenbankobjekt, das im Datenbankkatalog abgelegt wird.

Syntax

<comment_on_statement> ::= COMMENT ON <object_spec> IS <comment>

<object_spec> ::= siehe Erläuterung
<comment> ::= <string_literal> | <parameter_name>

Erläuterung

Für folgende Datenbankobjekte können Kommentare angegeben werden:

<object_spec> ::= | Erläuterung
COLUMN <table_name>.<column_name> | Die Spalte muss in der angegebenen Tabelle existieren. Der aktuelle Benutzer muss Eigentümer der Tabelle sein. Der Kommentar zu dieser Spalte kann durch Selektieren der Systemtabelle DOMAIN.COLUMNS abgefragt werden.
DBPROC[EDURE] <dbproc_name> | Durch dbproc_name muss eine existierende Datenbankprozedur identifiziert sein, deren Eigentümer der aktuelle Benutzer ist. Es wird ein Kommentar zu dieser Datenbankprozedur abgelegt, der durch Selektieren der Systemtabelle DOMAIN.DBPROCEDURES abgefragt werden kann.
DOMAIN <domain_name> | Durch domain_name muss ein Wertebereich des aktuellen Benutzers angegeben sein. Der Kommentar zu diesem Wertebereich kann durch Selektieren der Systemtabelle DOMAIN.DOMAINS abgefragt werden.
FOREIGN KEY <table_name>.<referential_constraint_name> | Durch referential_constraint_name muss eine referentielle CONSTRAINT-Definition der angegebenen Tabelle angegeben sein. Der aktuelle Benutzer muss Eigentümer der Tabelle sein. Der Kommentar zu dieser referentiellen CONSTRAINT-Definition kann durch Selektieren der Systemtabelle DOMAIN.FOREIGNKEYS abgefragt werden.
INDEX <index_name> ON <table_name> | Durch index_name muss ein Index der angegebenen Tabelle angegeben sein. Der aktuelle Benutzer muss Eigentümer der Tabelle sein. Der Kommentar zu diesem Index kann durch Selektieren der Systemtabelle DOMAIN.INDEXES abgefragt werden.
SEQUENCE <sequence_name> | Durch sequence_name muss eine existierende Sequenz angegeben sein. Der aktuelle Benutzer muss Eigentümer der Sequenz sein. Der Kommentar zu dieser Sequenz kann durch Selektieren der Systemtabelle DOMAIN.SEQUENCES abgefragt werden.
[PUBLIC] SYNONYM <synonym_name> | Durch synonym_name muss ein Synonym des aktuellen Benutzers angegeben sein. Wenn PUBLIC angegeben ist, muss dieses Synonym das PUBLIC-Attribut besitzen. Der Kommentar zu diesem Synonym kann durch Selektieren der Systemtabelle DOMAIN.SYNONYMS abgefragt werden.
TABLE <table_name> | Die angegebene Tabelle muss eine nicht-temporäre Basis- oder View-Tabelle identifizieren. Der aktuelle Benutzer muss Eigentümer der Tabelle sein. Der Kommentar zu dieser Tabelle kann durch Selektieren der Systemtabelle DOMAIN.TABLES abgefragt werden.
TRIGGER <table_name>.<trigger_name> | Der angegebene Triggername muss einen Trigger der angegebenen Tabelle identifizieren. Der aktuelle Benutzer muss Eigentümer der Tabelle sein. Es wird ein Kommentar zu dem Trigger abgelegt, der durch Selektieren der Systemtabelle DOMAIN.TRIGGERS abgefragt werden kann.
USER <user_name> | Der angegebene Benutzer muss einen existierenden Benutzer identifizieren, dessen Eigentümer der aktuelle Benutzer ist. Der Kommentar zu diesem Benutzer kann durch Selektieren der Systemtabelle DOMAIN.USERS abgefragt werden.
USERGROUP <usergroup_name> | Die angegebene Benutzergruppe muss eine existierende Benutzergruppe identifizieren, deren Eigentümer der aktuelle Benutzer ist. Der Kommentar zu dieser Benutzergruppe kann durch Selektieren der Systemtabelle DOMAIN.USERS abgefragt werden.
<parameter_name> | Die korrespondierende Variable muss einen der in der Tabelle aufgelisteten Werte enthalten. Die Werte müssen in Hochkommas eingeschlossen sein. Beispiel für Angabe der korrespondierenden Variablen: 'COLUMN <table_name>.<column_name>'


Autorisierung (SAP-Bibliothek - Grundwissen)

Autorisierung

SQL-Anweisungen für die Autorisierung

CREATE USER-Anweisung | DROP USER-Anweisung | ALTER USER-Anweisung RENAME USER-Anweisung GRANT USER-Anweisung
CREATE USERGROUP-Anweisung | DROP USERGROUP-Anweisung | ALTER USERGROUP-Anweisung RENAME USERGROUP-Anweisung GRANT USERGROUP-Anweisung
CREATE ROLE-Anweisung | DROP ROLE-Anweisung |
ALTER PASSWORD-Anweisung | GRANT-Anweisung | REVOKE-Anweisung

Beispiele

SQL-Tutorial, Strukturlink Autorisierung


CREATE USER-Anweisung (create_user_statement) (SAP-Bibliothek - Grundwissen)

CREATE USER-Anweisung (create_user_statement)

Die CREATE USER-Anweisung (create_user_statement) definiert einen Datenbankbenutzer. Die Existenz und die Eigenschaften des Datenbankbenutzers werden in Form von Metadaten im Datenbankkatalog abgelegt.

Syntax

<create_user_statement> ::=
CREATE USER <user_name> PASSWORD <password>
[<user_mode>]
[TIMEOUT <unsigned_integer>]
[COSTWARNING <unsigned_integer>]
[COSTLIMIT <unsigned_integer>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE <ASCII_or_UNICODE>]
[<connect_mode>]
| CREATE USER <user_name> PASSWORD <password> LIKE <source_user>
| CREATE USER <user_name> PASSWORD <password> USERGROUP <usergroup_name>

<user_mode> ::= DBA | RESOURCE | STANDARD
<ASCII_or_UNICODE> ::= ASCII | UNICODE
<connect_mode> ::= ENABLE CONNECT | DISABLE CONNECT
<source_user> ::= <user_name>

Beispiele

SQL-Tutorial, Strukturlink Datenbankbenutzer und ihre Privilegien

Erläuterung

Der aktuelle Benutzer muss ein Datenbankadministrator (DBA-Benutzer) sein. Er wird Eigentümer des erzeugten Benutzers.

Der angegebene Benutzername darf nicht mit dem Namen eines existierenden Benutzers einer Benutzergruppe, einer Rolle oder eines Schemas übereinstimmen.

Das Kennwort password muss bei der Eröffnung einer Datenbanksitzung angegeben werden. Es stellt sicher, dass nur berechtigte Benutzer Zugang zum Datenbanksystem erhalten.

Die gegebenenfalls angegebenen ganzen Zahlen ohne Vorzeichen unsigned_integer müssen stets größer als 0 sein.

Dem Benutzer steht für die Ablage seiner privaten und temporären Tabellen unbegrenzt viel Plattenplatz zur Verfügung (im Rahmen der bei der Installation angegebenen Größen der Data-Volumes).

Datenbankbenutzerklasse

Mittels user_mode wird beim Anlegen eines Datenbankbenutzers die Datenbankbenutzerklasse DBA, RESOURCE oder STANDARD des definierten Benutzers festgelegt. Die Datenbankbenutzerklasse gibt an, welche Operationen der definierte Benutzer ausführen darf.

Wenn bei Definition eines Benutzers keine Datenbankbenutzerklasse angegeben wird, wird implizit STANDARD angenommen.

Die Datenbankbenutzerklassen sind wie folgt ineinander enthalten:

● Die Benutzerklasse RESOURCE schließt alle Rechte ein, die ein STANDARD-Benutzer hat.

● Die Benutzerklasse DBA schließt alle Rechte ein, die ein RESOURCE-Benutzer hat.

● Der Datenbanksystemadministrator (SYSDBA-Benutzer) kann Datenbankbenutzer der Datenbankbenutzerklassen DBA, RESOURCE und STANDARD erzeugen. Er hat Eigentümerrechte an allen Benutzern. Der Datenbanksystemadministrator die gleiche Funktion und die gleichen Rechte wie ein DBA-Benutzer.

TIMEOUT

Die Angabe des Timeout -Werts erfolgt in Sekunden und muss im Bereich von 30 und 32400 liegen.

Nur der Datenbanksystemadministrator (SYSDBA-Benutzer) darf Benutzer mit dem Timeout-Wert 0 definieren.

COSTWARNING/COSTLIMIT

Mit diesen Angaben kann verhindert werden, dass ein Benutzer beliebig komplizierte und damit kostenintensive QUERY-Anweisungen oder INSERT-Anweisungen der Form INSERT...SELECT... ausführen kann.

Vor Ausführung einer dieser SQL-Anweisungen werden die durch die Ausführung zu erwartenden Kosten geschätzt. Dieser SELECT-Kosten-Schätzwert kann mit der EXPLAIN-Anweisung ausgegeben werden. Der SELECT-Kosten-Schätzwert wird im interaktiven Betrieb mit den für den Benutzer angegebenen Werten für COSTWARNING und COSTLIMIT verglichen.

Für QUERY-Anweisungen oder INSERT-Anweisungen der Form INSERT...SELECT..., die in eine Programmiersprache eingebettet sind, werden die Werte COSTWARNING und COSTLIMIT nicht beachtet.

● COSTWARNING: Dieser Wert gibt an, ab welchem SELECT-Kosten-Schätzwert der Benutzer eine Warnung erhält. Im Falle einer Warnung wird der Benutzer gefragt, ob die SQL-Anweisung wirklich ausgeführt werden soll.

● COSTLIMIT: Dieser Wert gibt an, ab welchem SELECT-Kosten-Schätzwert die SQL-Anweisung nicht ausgeführt wird.

Der COSTLIMIT-Wert muss größer als der COSTWARNING-Wert sein.

EXCLUSIVE

Wenn die EXCLUSIVE-Bedingung nicht angegeben wird, dann wird implizit NOT EXCLUSIVE angenommen.

● EXCLUSIVE: Es ist nicht möglich, gleichzeitig zwei verschiedene Datenbanksitzungen des Benutzers zu eröffnen.

● NOT EXCLUSIVE: Es ist möglich, gleichzeitig mehrere Datenbanksitzungen des Benutzers zu eröffnen.

DEFAULTCODE ASCII, DEFAULTCODE UNICODE

Für die Objekte des angegebenen Benutzers wird der Wert des speziellen Datenbankparameters DEFAULT_CODE mit dem in DEFAULTCODE angegebenen Codeattribut übersteuert.

LIKE

Der aktuelle Benutzer muss das Eigentümerrecht an dem Quellbenutzer source_user besitzen.

Wenn der Quellbenutzer nicht Mitglied einer Benutzergruppe ist, dann erhält der neu definierte Benutzer die gleiche Benutzerklasse und die gleichen Werte für TIMEOUT, COSTWARNING, COSTLIMIT und für die EXCLUSIVE-Angabe wie der Quellbenutzer. Der neu definierte Benutzer erhält alle Privilegien, die der Quellbenutzer von anderen Benutzern verliehen bekommen hat.

Wenn der Quellbenutzer Mitglied einer Benutzergruppe ist, dann wird ein neues Mitglied dieser Benutzergruppe mit dem neu definierten Benutzernamen definiert.

USERGROUP

Der die SQL-Anweisung absetzende Benutzer muss Eigentümer der angegebenen Benutzergruppe sein. Der neu definierte Benutzer wird Mitglied dieser Benutzergruppe.

Siehe auch:

CREATE USERGROUP-Anweisung (create_usergroup_statement)

ENABLE CONNECT, DISABLE CONNECT

Mittels connect_mode definieren Sie, ob ein Benutzer Datenbanksitzungen eröffnen kann.

Wenn kein CONNECT-Modus angegeben ist, wird implizit ENABLE CONNECT angenommen. ENABLE und DISABLE dürfen nicht gleichzeitig angeben sein.

● ENABLE CONNECT: Der Benutzer kann Datenbanksitzungen eröffnen.

● DISABLE CONNECT: Der Benutzer kann keine Datenbanksitzungen eröffnen.

Siehe auch:

Konzepte des Datenbanksystems, Authentifizierung


CREATE USERGROUP-Anweisung (create_usergroup_statement) (SAP-Bibliothek - Grundwissen)

CREATE USERGROUP-Anweisung (create_usergroup_statement)

Die CREATE USERGROUP-Anweisung (create_usergroup_statement) definiert eine Benutzergruppe.

Syntax

<create_usergroup_statement>
::=
CREATE USERGROUP <usergroup_name>
[<usergroup_mode>]
[TIMEOUT <unsigned_integer>]
[COSTWARNING <unsigned_integer>]
[COSTLIMIT <unsigned_integer>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE <ASCII_or_UNICODE>]
[<connect_mode>]

<usergroup_mode>
::= RESOURCE | STANDARD
<ASCII_or_UNICODE> ::= ASCII | UNICODE
<connect_mode> ::= ENABLE CONNECT | DISABLE CONNECT

Erläuterung

Der aktuelle Datenbankbenutzer muss ein Datenbankadministrator (DBA-Benutzer) sein.

Der angegebene Benutzergruppenname darf nicht mit dem Namen eines existierenden Datenbankbenutzers einer Benutzergruppe oder einer Rolle übereinstimmen.

Mit Hilfe der CREATE USER-Anweisung können mehrere Datenbankbenutzer definiert werden, die zu dieser Benutzergruppe gehören sollen. Alle privaten Objekte, die durch Mitglieder der Benutzergruppe erzeugt werden, werden durch den Benutzergruppennamen identifiziert. Der Eigentümer eines privaten Objekts ist die Benutzergruppe, nicht der Benutzer, der das Objekt erzeugt hat. Jeder Benutzer kann mit allen privaten Objekten der Benutzergruppe so arbeiten, als wäre er der Eigentümer des Objekts. Privilegien können nur der Benutzergruppe gegeben bzw. entzogen werden. Es ist nicht möglich, einem einzelnen Mitglied der Benutzergruppe ein Privileg zu geben bzw. zu entziehen.

Die gegebenenfalls angegebenen ganzen Zahlen ohne Vorzeichen unsigned_integer müssen stets größer als 0 sein.

Dem Benutzer steht für die Ablage seiner privaten und temporären Tabellen unbegrenzt viel Plattenplatz zur Verfügung (im Rahmen der bei der Installation angegebenen Größen der Data-Volumes).

Datenbankbenutzerklasse

Mittels usergroup_mode wird beim Anlegen einer Benutzergruppe die Datenbankbenutzerklasse RESOURCE oder STANDARD für diese Benutzergruppe festgelegt.

Wenn bei Definition einer Benutzergruppe keine Datenbankbenutzerklasse angegeben wird, wird implizit STANDARD angenommen.

Die Datenbankbenutzerklasse RESOURCE schließt alle Rechte ein, die ein STANDARD-Benutzer hat.

TIMEOUT

Die Angabe des Timeout-Werts erfolgt in Sekunden und muss im Bereich von 30 und 32400 liegen.

Nur der Datenbanksystemadministrator (SYSDBA-Benutzer) darf Benutzer mit dem Timeout-Wert 0 definieren.

COSTWARNING/COSTLIMIT

Mit diesen Angaben kann verhindert werden, dass ein Benutzer dieser Benutzergruppe beliebig komplizierte und damit kostenintensive QUERY-Anweisungen oder INSERT-Anweisungen der Form INSERT...SELECT... ausführen kann.

Vor Ausführung einer dieser SQL-Anweisungen werden die durch die Ausführung zu erwartenden Kosten geschätzt. Dieser SELECT-Kosten-Schätzwert kann mit der EXPLAIN-Anweisung ausgegeben werden. Der SELECT-Kosten-Schätzwert wird im interaktiven Betrieb mit den für den Benutzer angegebenen Werten für COSTWARNING und COSTLIMIT verglichen.

Für QUERY-Anweisungen oder INSERT-Anweisungen der Form INSERT...SELECT..., die in eine Programmiersprache eingebettet sind, werden die Werte COSTWARNING und COSTLIMIT nicht beachtet.

● COSTWARNING: Dieser Wert gibt an, ab welchem SELECT-Kosten-Schätzwert der Benutzer eine Warnung erhält. Im Falle einer Warnung wird der Benutzer gefragt, ob die SQL-Anweisung wirklich ausgeführt werden soll.

● COSTLIMIT: Dieser Wert gibt an, ab welchem SELECT-Kosten-Schätzwert die SQL-Anweisung nicht ausgeführt wird.

Der COSTLIMIT-Wert muss größer als der COSTWARNING-Wert sein.

EXCLUSIVE

Wenn die EXCLUSIVE-Bedingung nicht angegeben wird, dann wird implizit NOT EXCLUSIVE angenommen.

● EXCLUSIVE: Es ist nicht möglich, gleichzeitig zwei verschiedene Datenbanksitzungen eines Benutzers dieser Benutzergruppe zu eröffnen.

● NOT EXCLUSIVE: Es ist möglich, gleichzeitig mehrere Datenbanksitzungen des Benutzers zu eröffnen.

DEFAULTCODE ASCII, DEFAULTCODE UNICODE

Für die Objekte des angegebenen Benutzers wird der Wert des speziellen Datenbankparameters DEFAULT_CODE mit dem in DEFAULTCODE angegebenen Codeattribut übersteuert.

ENABLE CONNECT, DISABLE CONNECT

Mittels connect_mode definieren Sie, ob später definierte Mitglieder der Benutzergruppe Datenbanksitzungen eröffnen können. Dies gilt jedoch nur, wenn in der CREATE USER-Anweisung des jeweiligen Gruppenmitgliedes kein CONNECT-Modus angegeben ist.

Wenn kein CONNECT-Modus angegeben ist, wird implizit ENABLE CONNECT angenommen. ENABLE und DISABLE dürfen nicht gleichzeitig angeben sein.

● ENABLE CONNECT : Mitglieder der Benutzergruppe können Datenbanksitzungen eröffnen.

● DISABLE CONNECT: Mitglieder der Benutzergruppe können keine Datenbanksitzungen eröffnen.


DROP USER-Anweisung (drop_user_statement) (SAP-Bibliothek - Grundwissen)

DROP USER-Anweisung (drop_user_statement)

Die DROP USER-Anweisung (drop_user_statement) löscht die Definition eines Datenbankbenutzers. Die Metadaten des zu löschenden Datenbankbenutzers werden aus dem Datenbankkatalog gelöscht.

Syntax

<drop_user_statement> ::= DROP USER <user_name> [<cascade_option>]

Beispiele

SQL-Tutorial, Strukturlink Datenbankbenutzer und ihre Privilegien

Erläuterung

Der aktuelle Datenbankbenutzer muss Eigentümerrecht an dem zu löschenden Datenbankbenutzer besitzen.

Der angegebene Datenbankbenutzer darf zum Zeitpunkt der Ausführung der DROP USER-Anweisung nicht beim Datenbanksystem angemeldet sein.

Wenn ein Datenbankbenutzer der Datenbankbenutzerklasse DBA gelöscht wird, bleiben die von ihm erzeugten Datenbankbenutzer erhalten. Neuer Eigentümer dieser Datenbankbenutzer wird der Datenbanksystemadministrator (SYSDBA-Benutzer).

<cascade_option>

· Wenn keine CASCADE-Option oder die CASCADE-Option CASCADE angegeben wurde, werden zusammen mit dem Datenbankbenutzer alle Schemas, Synonyme und Tabellen des zu löschenden Datenbankbenutzers, sowie alle darauf basierenden Indizes, Privilegien, View-Tabellen usw. gelöscht.

· Wenn die CASCADE-Option RESTRICT angegeben wurde und der zu löschende Datenbankbenutzer keiner Benutzergruppe angehört, aber Eigentümer von Synonymen oder Tabellen ist , scheitert die DROP USER-Anweisung.

Alle Datenbankobjekte, die der zu löschende Datenbankbenutzer in Schemas erzeugt hat, deren Eigentümer er nicht ist, bleiben erhalten. Neuer Eigentümer dieser Objekte wird der Eigentümer des entsprechenden Schemas.


DROP USERGROUP-Anweisung (drop_usergroup_statement) (SAP-Bibliothek - Grundwissen)

DROP USERGROUP-Anweisung (drop_usergroup_statement)

Die DROP USERGROUP-Anweisung (drop_usergroup_statement) löscht die Definition einer Benutzergruppe. Die Metadaten der zu löschenden Benutzergruppe werden aus dem Datenbankkatalog gelöscht.

Syntax

<drop_usergroup_statement> ::= DROP USERGROUP <usergroup_name> [<cascade_option>]

Erläuterung

Der aktuelle Datenbankbenutzer muss Eigentümerrecht an der zu löschenden Benutzergruppe besitzen.

Kein Datenbankbenutzer der Benutzergruppe darf zum Zeitpunkt der Ausführung der DROP USERGROUP-Anweisung beim Datenbanksystem angemeldet sein.

<cascade_option>

· Wenn die zu löschende Benutzergruppe Eigentümer von Synonymen oder Tabellen ist und die CASCADE-Option RESTRICT angegeben wurde, scheitert die DROP USERGROUP-Anweisung.

· Wenn keine CASCADE-Option oder die CASCADE-Option CASCADE angegeben wurde, werden zusammen mit der Benutzergruppe alle Synonyme und Tabellen der zu löschenden Benutzergruppe, sowie alle darauf basierenden Indizes, Privilegien, View-Tabellen usw. gelöscht.


ALTER USER-Anweisung (alter_user_statement) (SAP-Bibliothek - Grundwissen)

ALTER USER-Anweisung (alter_user_statement)

Die ALTER USER-Anweisung (alter_user_statement) ändert die einem Datenbankbenutzer zugeordneten Eigenschaften.

Syntax

<alter_user_statement> ::= ALTER USER <user_name> [<user_mode>]
[TIMEOUT <unsigned_integer> | TIMEOUT NULL]
[COSTWARNING <unsigned_integer> | COSTWARNING NULL]
[COSTLIMIT <unsigned_integer> | COSTLIMIT NULL]
[DEFAULT ROLE ALL [EXCEPT <role_name>] | DEFAULT ROLE NONE | DEFAULT ROLE <role_name>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE ASCII]
[DEFAULTCODE UNICODE]
[<connect_mode>]

<user_mode> ::= DBA | RESOURCE | STANDARD
<connect_mode> ::= ENABLE CONNECT | DISABLE CONNECT

Beispiele

SQL-Tutorial, Strukturlink Datenbankbenutzer und ihre Privilegien, Strukturlink Rollen

Erläuterung

Sie müssen mindestens eine der optionalen Angaben verwenden.

Der angegebene Benutzername muss einen definierten Benutzer bezeichnen, der kein Mitglied einer Benutzergruppe ist.

Der aktuelle Benutzer muss das Eigentümerrecht an dem Benutzer besitzen, dessen Eigenschaften geändert werden sollen.

Zum Zeitpunkt der Ausführung der ALTER USER-Anweisung darf der angegebene Benutzer nicht beim Datenbanksystem angemeldet sein.

Datenbankbenutzerklasse

Mittels user_mode können Sie die Datenbankbenutzerklasse des Datenbankbenutzers festlegen. Die Datenbankbenutzerklasse gibt an, welche Operationen der definierte Benutzer ausführen darf.

· DBA: Diese Angabe bedeutet, dass dem angegebenen Datenbankbenutzer die Datenbankbenutzerklasse DBA verliehen werden soll. Diese Datenbankbenutzerklasse kann nur der Datenbanksystemadministrator (SYSDBA-Benutzer) verleihen.

· RESOURCE: Diese Angabe bedeutet, dass dem angegebenen Datenbankbenutzer die Datenbankbenutzerklasse RESOURCE verliehen werden soll. Falls der Benutzer zuvor die Datenbankbenutzerklasse DBA besaß, wird dem Benutzer das Eigentümerrecht für alle Benutzer entzogen, die er erzeugt hat. Neuer Eigentümer wird der Datenbanksystemadministrator (SYSDBA-Benutzer).

· STANDARD: Diese Angabe bedeutet, dass dem Datenbankbenutzer seine aktuelle Datenbankbenutzerklasse entzogen wird und er das Recht verliert, eigene Basistabellen zu erzeugen. Alle bereits existierenden Basistabellen des Benutzers werden gelöscht.

· Keine Datenbankbenutzerklasse: Wenn keine Datenbankbenutzerklasse angegeben wurde, bleibt die Benutzerklasse des Datenbankbenutzers unverändert.

NULL

Wenn der Wert NULL spezifiziert wird, dann wird der zuvor definierte Wert aufgehoben.

DEFAULT ROLE

Durch DEFAULT ROLE wird festgelegt, welche der an den Benutzer vergebenen Rollen automatisch beim Eröffnen einer Datenbanksitzung aktiviert werden.

· ALL: Alle Rollen, die dem Benutzer vergeben wurden, sind nach dem Eröffnen einer Sitzung aktiv. Durch EXCEPT können einzelne namentlich aufgeführte Rollen hiervon ausgenommen werden.

· NONE: Keine Rolle wird beim Eröffnen einer Datenbanksitzung des Benutzers aktiv.

· Angabe von Rollennamen: Die hierdurch identifizierten Rollen müssen existieren und an den Benutzer vergeben sein. Sie werden beim Eröffnen einer Datenbanksitzung des Benutzers automatisch aktiv.

TIMEOUT, COSTWARNING, COSTLIMIT, [NOT] EXCLUSIVE, DEFAULTCODE, ENABLE | DISABLE CONNECT

Eine Erläuterung dieser Möglichkeiten finden Sie in der Beschreibung der CREATE USER-Anweisung (create_user_statement).


ALTER USERGROUP-Anweisung (alter_usergroup_statement) (SAP-Bibliothek - Grundwissen)

ALTER USERGROUP-Anweisung (alter_usergroup_statement)

Die ALTER USERGROUP-Anweisung (alter_usergroup_statement) ändert die einer Benutzergruppe zugeordneten Eigenschaften.

Syntax

<alter_usergroup_statement> ::= ALTER USERGROUP <usergroup_name> [<usergroup_mode>]
[TIMEOUT <unsigned_integer> | TIMEOUT NULL]
[COSTWARNING <unsigned_integer> | COSTWARNING NULL]
[COSTLIMIT <unsigned_integer> | COSTLIMIT NULL]
[DEFAULT ROLE ALL [EXCEPT <role_name>] | DEFAULT ROLE NONE | DEFAULT ROLE <role_name>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE ASCII]
[DEFAULTCODE UNICODE]
[<connect_mode>]

<usergroup_mode> ::= RESOURCE | STANDARD
<connect_mode> ::= ENABLE CONNECT | DISABLE CONNECT

Erläuterung

Sie müssen mindestens eine der optionalen Angaben verwenden.

Die angegebene Benutzergruppe muss eine definierte Benutzergruppe bezeichnen.

Der aktuelle Datenbankbenutzer muss das Eigentümerrecht an der Benutzergruppe besitzen, deren Eigenschaften geändert werden sollen.

Zum Zeitpunkt der Ausführung der ALTER USERGROUP-Anweisung darf kein Mitglied der angegebenen Benutzergruppe beim Datenbanksystem angemeldet sein.

Datenbankbenutzerklasse der Benutzergruppe

Mittels usergroup_mode können Sie Datenbankbenutzerklasse für diese Benutzergruppe festgelegen.

· RESOURCE: Diese Angabe bedeutet, dass der angegebenen Benutzergruppe die Datenbankbenutzerklasse RESOURCE verliehen wird.

· STANDARD: Diese Angabe bedeutet, dass der Benutzergruppe ihre aktuelle Datenbankbenutzerklasse entzogen wird und sie das Recht verliert, eigene Daten zu halten. Alle bereits existierenden Basistabellen der Benutzergruppe werden gelöscht.

· Keine Datenbankbenutzerklasse: Wenn keine Datenbankbenutzerklasse angegeben wurde, bleibt die Datenbankbenutzerklasse der Benutzergruppe unverändert.

NULL

Wenn der Wert NULL spezifiziert wird, dann wird der zuvor definierte Wert aufgehoben.

DEFAULT ROLE

Durch DEFAULT ROLE wird festgelegt, welche der an die Benutzergruppe vergebenen Rollen automatisch beim Eröffnen einer Sitzung eines Gruppenmitglieds aktiviert werden.

· ALL: Alle Rollen, die der Benutzergruppe vergeben wurden, sind nach dem Eröffnen einer Sitzung aktiv. Durch EXCEPT können einzelne namentlich aufgeführte Rollen hiervon ausgenommen werden.

· NONE: Keine Rolle wird beim Eröffnen einer Sitzung eines Mitglieds der Benutzergruppe aktiv.

· Angabe von Rollennamen: Die hierdurch identifizierten Rollen müssen existieren und an die Benutzergruppe vergeben sein. Sie werden beim Eröffnen einer Sitzung eines Gruppenmitglieds automatisch aktiv.

ENABLE CONNECT, DISABLE CONNECT

Mittels connect_mode definieren Sie, ob alle Mitglieder der Benutzergruppe Datenbanksitzungen eröffnen können.

Wenn kein CONNECT-Modus angegeben ist, wird implizit ENABLE CONNECT angenommen. ENABLE und DISABLE dürfen nicht gleichzeitig angeben sein.

· ENABLE CONNECT: Alle Mitglieder der Benutzergruppe können Datenbanksitzungen eröffnen.

· DISABLE CONNECT: Kein Mitglied der Benutzergruppe kann eine Datenbanksitzungen eröffnen. Durch die ALTER USER-Anweisung kann es einzelnen Mitgliedern wieder ermöglicht werden, Datenbanksitzungen zu eröffnen.

TIMEOUT, COSTWARNING, COSTLIMIT, [NOT] EXCLUSIVE, DEFAULTCODE

Eine Erläuterung dieser Möglichkeiten finden Sie in der Beschreibung der CREATE USERGROUP-Anweisung.


RENAME USER-Anweisung (rename_user_statement) (SAP-Bibliothek - Grundwissen)

RENAME USER-Anweisung (rename_user_statement)

Die RENAME USER-Anweisung (rename_user_statement) ändert den Namen eines Datenbankbenutzers.

Syntax

<rename_user_statement> ::= RENAME USER <user_name> TO <new_user_name>

<new_user_name> ::= <user_name>

Erläuterung

Der zu ändernde Datenbankbenutzer muss existieren. Der Benutzername muss einen Datenbankbenutzer identifizieren, dessen Eigentümer der aktuelle Datenbankbenutzer ist.

Der neue Benutzername new_user_name darf nicht mit dem Namen eines existierenden Datenbankbenutzers, einer existierenden Benutzergruppe, eines existierenden Schemas oder einer existierenden Rolle übereinstimmen.

Der Datenbankbenutzer, der geändert werden soll, darf zum Zeitpunkt der Ausführung der RENAME USER-Anweisung nicht am Datenbanksystem angemeldet sein. Dies gilt nicht, wenn sich der Datenbanksystemadministrator (SYSDBA-Benutzer) umbenennt.

Wenn sich der Datenbanksystemadministrator umbenennt, so wird implizit die aktuelle Transaktion durch eine COMMIT-Anweisung beendet. Nach erfolgreicher Umbenennung des Datenbanksystemadministrators erfolgt wiederum implizit die Ausführung einer COMMIT-Anweisung.

Alle vom zu ändernden Datenbankbenutzer abhängigen Objekte werden vom Datenbanksystem an den neuen Benutzernamen angepasst.


RENAME USERGROUP-Anweisung (rename_usergroup_statement) (SAP-Bibliothek - Grundwissen)

RENAME USERGROUP-Anweisung (rename_usergroup_statement)

Die RENAME USERGROUP-Anweisung (rename_usergroup_statement) ändert den Namen einer Benutzergruppe.

Syntax

<rename_usergroup_statement> ::= RENAME USERGROUP <usergroup_name> TO <new_usergroup_name>

<new_usergroup_name> ::= <usergroup_name>

Erläuterung

Die zu ändernde Benutzergruppe muss existieren. Der Name der Benutzergruppe muss eine Benutzergruppe identifizieren, für die der aktuelle Datenbankbenutzer das Eigentümerrecht besitzt.

Der neue Benutzergruppenname new_usergroup_name darf nicht mit dem Namen eines existierenden Datenbankbenutzers, einer existierenden Benutzergruppe oder einer existierenden Rolle übereinstimmen.

Kein Mitglied der zu ändernden Benutzergruppe darf zum Zeitpunkt, an dem die RENAME USERGROUP-Anweisung abgesetzt wird, beim Datenbanksystem angemeldet sein.

Alle von der zu ändernden Benutzergruppe abhängigen Objekte werden vom Datenbanksystem an den neuen Benutzergruppennamen angepasst.


GRANT USER-Anweisung (grant_user_statement) (SAP-Bibliothek - Grundwissen)

GRANT USER-Anweisung (grant_user_statement)

Die GRANT USER-Anweisung (grant_user_statement) verleiht das Eigentümerrecht, das der Datenbanksystemadministrator (SYSDBA-Benutzer) oder ein Datenbankadministrator (DBA-Benutzer) für einen Datenbankbenutzer besitzt, an einen anderen Datenbankbenutzer.

Syntax

<grant_user_statement> ::= GRANT USER <granted_users> [FROM <user_name>] TO <user_name>

<granted_users> ::= <user_name>,...| *

Erläuterung

Der aktuelle Benutzer muss ein Datenbankadministrator (DBA-Benutzer) sein.

Die hinter den Schlüsselwörtern FROM und TO angegebenen Benutzernamen müssen verschieden sein, und sie müssen DBA-Benutzer kennzeichnen. Wenn FROM <user_name> nicht angegeben ist, wird implizit der aktuelle Datenbankbenutzer angenommen.

Die nach den Schlüsselwörtern GRANT USER angegebenen Datenbankbenutzer müssen existieren, dürfen keine Mitglieder einer Benutzergruppe sein und müssen RESOURCE-Benutzer oder STANDARD-Benutzer sein. Der FROM-Benutzer muss das Eigentümerrecht für diese Datenbankbenutzer haben. Die Angabe * bedeutet, dass die GRANT USER-Anweisung alle Datenbankbenutzer betrifft, für die der FROM-Benutzer das Eigentümerrecht besitzt.

Der TO-Benutzer erhält vom FROM-Benutzer die Eigentümerrechte, die der FROM-Benutzer an den angegebenen Datenbankbenutzern besitzt. Dem FROM-Benutzer werden diese Rechte entzogen. Insbesondere erhält der TO-Benutzer für jeden angegebenen Datenbankbenutzer das Recht, diesen zu löschen sowie dessen Benutzerklasse und dessen andere Eigenschaften zu ändern.


GRANT USERGROUP-Anweisung (grant_usergroup_statement) (SAP-Bibliothek - Grundwissen)

GRANT USERGROUP-Anweisung (grant_usergroup_statement)

Die GRANT USERGROUP-Anweisung (grant_usergroup_statement) verleiht das Eigentümerrecht, das der Datenbanksystemadministrator (SYSDBA-Benutzer) oder ein Datenbankadministrator (DBA-Benutzer) für eine Benutzergruppe besitzt, an einen anderen Benutzer.

Syntax

<grant_usergroup_statement> ::= GRANT USERGROUP <granted_usergroups> [FROM <user_name>] TO <user_name>

<granted_usergroups> ::= <usergroup_name>,...| *

Erläuterung

Der aktuelle Benutzer muss ein DBA-Benutzer sein.

Die hinter den Schlüsselwörtern FROM und TO angegebenen Benutzernamen müssen verschieden sein, und sie müssen DBA-Benutzer kennzeichnen. Wenn FROM <user_name> nicht angegeben ist, wird implizit der aktuelle Benutzer angenommen.

Die Benutzergruppennamen müssen Benutzergruppen identifzieren, für die der FROM-Benutzer das Eigentümerrecht besitzt. Die Angabe * steht für alle Benutzergruppen, für die der FROM-Benutzer das Eigentümerrecht besitzt.

Der TO-Benutzer erhält vom FROM-Benutzer die Eigentümerrechte, die der FROM-Benutzer an den angegebenen Benutzergruppen besitzt. Dem FROM-Benutzer werden diese Rechte entzogen. Insbesondere erhält der TO-Benutzer für jede Benutzergruppe das Recht, diese zu löschen, deren Benutzerklasse und deren Eigenschaften zu ändern sowie Mitglieder der Benutzergruppe zu löschen oder neu einzurichten.


ALTER PASSWORD-Anweisung (alter_password_statement) (SAP-Bibliothek - Grundwissen)

ALTER PASSWORD-Anweisung (alter_password_statement)

Die ALTER PASSWORD-Anweisung (alter_password_statement) wird benötigt, um das Kennwort eines Benutzers zu ändern.

Syntax

<alter_password_statement> ::= ALTER PASSWORD <old_password> TO <new_password>
| ALTER PASSWORD <user_name> <new_password>

<old_password> ::= <password>
<new_password> ::= <password>

Beispiele

SQL-Tutorial, Strukturlink Datenbankbenutzer und ihre Privilegien

Erläuterung

Mit ALTER PASSWORD <old_password> TO <new_password> können Sie das Kennwort des aktuellen Benutzers ändern. Das alte Kennwort muss mit dem im Datenbankkatalog für den aktuellen Benutzer abgelegten Kennwort übereinstimmen.

Wenn Sie das Kennwort für einen Benutzer mit dem Namen user_name ändern wollen, muss der aktuelle Benutzer der Datenbanksystemadministrator (SYSDBA) sein.

Das neue Kennwort muss beim Eröffnen der nächsten Datenbanksitzung des Benutzers in der CONNECT-Anweisung angegeben werden.

Siehe auch:

Konzepte des Datenbanksystems, Konventionen für Benutzernamen und Kennwörter


CREATE ROLE-Anweisung (create_role_statement) (SAP-Bibliothek - Grundwissen)

CREATE ROLE-Anweisung (create_role_statement)

Die CREATE ROLE-Anweisung (create_role_statement) definiert eine Rolle.

Syntax

<create_role_statement> ::= CREATE ROLE <role_name> [IDENTIFIED BY <password>]

Beispiele

SQL-Tutorial, Strukturlink Rollen

Erläuterung

Der aktuelle Datenbankbenutzer muss ein Datenbankadministrator (DBA-Benutzer) sein.

Der Rollenname darf nicht mit dem Namen einer bereits existierenden Rolle, eines Datenbankbenutzers oder einer Benutzergruppe übereinstimmen.


DROP ROLE-Anweisung (drop_role_statement) (SAP-Bibliothek - Grundwissen)

DROP ROLE-Anweisung (drop_role_statement)

Die DROP ROLE-Anweisung (drop_role_statement) löscht eine Rolle.

Syntax

<drop_role_statement> ::= DROP ROLE <role_name>

Beispiele

SQL-Tutorial, Strukturlink Rollen

Erläuterung

Der aktuelle Datenbankbenutzer muss Eigentümer der Rolle sein.

Die Metadaten der zu löschenden Rolle werden aus dem Datenbankkatalog gelöscht.


GRANT-Anweisung (grant_statement) (SAP-Bibliothek - Grundwissen)

GRANT-Anweisung (grant_statement)

Die GRANT-Anweisung (grant_statement) vergibt Privilegien für Tabellen, einzelne Spalten, Rollen und Schemas, das SELECT-Privileg für Sequenzen und das Ausführungsprivileg (EXECUTE-Privileg) für Datenbankprozeduren oder Datenbankfunktionen.

Syntax

<grant_statement> ::= GRANT <priv_spec>,... TO <grantee>,... [WITH GRANT OPTION]
| GRANT <schema_priv_spec> TO <grantee>,...
| GRANT EXECUTE ON <dbproc_name> TO <grantee>,...
| GRANT EXECUTE ON <dbfunction_name> TO <grantee>,...
| GRANT SELECT ON <sequence_name> TO <grantee>,... [WITH GRANT OPTION]

<grantee> ::= <user_name> | <usergroup_name> | <role_name> | PUBLIC

Beispiele

SQL-Tutorial, Strukturlink Datenbankbenutzer und ihre Privilegien, Strukturlink Rollen

Erläuterung

Die in der Privilegienspezifikation (priv_spec bzw. schema_priv_spec) aufgezählten Privilegien werden an die in der grantee-Liste genannten Datenbankbenutzer, Benutzergruppen und Rollen vergeben.

<grantee>

Der Eigentümer eines Objekts, für das Privilegien vergeben werden, darf nicht in der grantee-Liste enthalten sein. Ein Datenbankbenutzer, der in der grantee-Liste erscheint, darf kein Mitglied einer Benutzergruppe bezeichnen.

<role_name>

Wenn eine Rolle an einen Datenbankbenutzer oder eine Benutzergruppe vergeben wird, erweitert sie die Menge der für diesen Datenbankbenutzer bzw. diese Benutzergruppe aktivierbaren Rollen. Die Aktivierung durch den Datenbankbenutzer erfolgt entweder mit Hilfe der SET-Anweisung oder durch Aufnahme der Rolle in die Menge der beim Eröffnen einer Sitzung automatisch aktivierten Rollen durch die ALTER USER-Anweisung oder ALTER USERGROUP-Anweisung.

Wenn eine Rolle an eine Rolle vergeben wird, dann darf hierdurch kein Zyklus entstehen, d.h.

● eine Rolle darf nicht an sich selbst vergeben werden.

● wenn eine Rolle R1 an eine Rolle R2 vergeben wurde, dann darf R2 nicht an R1 vergeben werden.

● wenn eine Rolle R1 an R2 und R2 an eine Rolle R3 vergeben wurde, dann darf R3 weder an R2 noch an R1 vergeben werden.

● usw.

PUBLIC

Die aufgeführten Privilegien werden an alle zu diesem und zu einem späteren Zeitpunkt existierenden Datenbankbenutzer vergeben.

Eine Rolle kann nicht an PUBLIC vergeben werden.

WITH GRANT OPTION

Dem durch grantee identifizierten Benutzer bzw. der durch grantee identifizierten Benutzergruppe wird erlaubt, die erhaltenen Privilegien an andere Benutzer weiterzugeben. Der aktuelle Benutzer muss die Berechtigung besitzen, die Privilegien zur Weitergabe zu vergeben.

Die Angabe von WITH GRANT OPTION ist nicht zulässig, wenn durch grantee eine Rolle angegeben ist.

GRANT <schema_priv_spec>

Durch GRANT CREATEIN ON wird dem durch grantee identifizierten Benutzer die Berechtigung gegeben, Datenbankobjekte im angegebenen Schema zu erzeugen.

Durch GRANT DROPIN ON wird dem durch grantee identifizierten Benutzer die Berechtigung gegeben, Datenbankobjekte im angegebenen Schema zu löschen.

GRANT EXECUTE ON

GRANT EXECUTE ON erlaubt dem durch grantee identifizierten Benutzer die Ausführung der angegebenen Datenbankprozedur oder Datenbankfunktion. Der aktuelle Benutzer muss Eigentümer der Datenbankprozedur oder Datenbankfunktion sein.

GRANT SELECT ON

GRANT SELECT ON erlaubt dem durch grantee identifizierten Benutzer die Verwendung der angegebenen Sequenz.

Siehe auch:

Privilegien: Überblick


REVOKE-Anweisung (revoke_statement) (SAP-Bibliothek - Grundwissen)

REVOKE-Anweisung (revoke_statement)

Die REVOKE-Anweisung (revoke_statement) widerruft Privilegien.

Syntax

<revoke_statement> ::= REVOKE <priv_spec>,... FROM <grantee>,... [<cascade_option>]
| REVOKE <schema_priv_spec> FROM <grantee>,...
| REVOKE EXECUTE ON <dbproc_name> FROM <grantee>,...
| REVOKE EXECUTE ON <dbfunction_name> FROM <grantee>,...
| REVOKE SELECT ON <sequence_name> FROM <grantee>,... [<cascade_option>]

<grantee> ::= <user_name> | <usergroup_name> | <role_name> | PUBLIC

Beispiele

SQL-Tutorial, Strukturlink Datenbankbenutzer und ihre Privilegien, Strukturlink Rollen

Erläuterung

Der Eigentümer einer Tabelle oder eines Schemas kann jedem Datenbankbenutzer die für diese Tabelle bzw. dieses Schema vergebenen Privilegien entziehen.

Ist ein Datenbankbenutzer nicht Eigentümer der Tabelle oder des Schemas, kann er nur die Privilegien entziehen, die er selbst vergeben hat.

Wenn für eine Tabelle das SELECT-Privielg ohne Angabe von Spaltennamen vergeben wurde, dann wird durch REVOKE SELECT (<column_name>,...) das SELECT-Privileg für die angegebenen Spalten entzogen, das SELECT-Privileg für die nicht vorkommenden Spalten der Tabelle besteht anschließend weiter. Entsprechendes gilt für das UPDATE-, REFERENCES- und SELUPD-Privileg.

<grantee>

Der Eigentümer eines Objekts, für das Privilegien vergeben werden, darf nicht in der grantee-Liste enthalten sein. Ein Datenbankbenutzer, der in der grantee-Liste erscheint, darf kein Mitglied einer Benutzergruppe bezeichnen.

PUBLIC

Die aufgeführten Privilegien werden allen zu diesem und zu einem späteren Zeitpunkt existierenden Datenbankbenutzern entzogen.

Die REVOKE-Anweisung kann kaskadieren, d.h. wird einem Benutzer ein Privileg entzogen, so kann das dazu führen, dass dieses Privileg weiteren Benutzern entzogen wird, die dieses Privileg von dem angegebenen Benutzer erhalten haben.

Seien U1, U2 und U3 Benutzer.
U1 vergibt an U2 die Privilegienmenge P WITH GRANT OPTION.
U2 vergibt an U3 die Privilegienmenge P' (P'<=P).

Wenn U1 dem Benutzer U2 die Privilegienmenge P'' (P''<=P) entzieht, so wird dem Benutzer U3 implizit die Privilegienmenge (P'*P'') entzogen.

● Wenn dem Eigentümer einer View-Tabelle das SELECT-Privileg für eine Spalte entzogen wird, die als selektierte Spalte, jedoch nicht in der table_expression der View-Definition auftritt (CREATE VIEW-Anweisung), dann wird die durch select_column definierte Spalte aus der View-Tabelle gelöscht.
Wenn diese View-Tabelle in der FROM-Klausel einer weiteren View-Tabelle verwendet wird, so wird das beschriebene Verfahren rekursiv auf diese View-Tabelle angewendet.

● Wenn dem Eigentümer einer View-Tabelle das SELECT-Privileg für eine Spalte oder Tabelle entzogen wird, die in der table_expression der View-Definition auftritt, dann wird die View-Tabelle mit allen von ihr abhängigen View-Tabellen, Privilegien und Synonymen gelöscht, wenn keine CASCADE-Option oder die CASCADE-Option CASCADE angegeben ist. Bei Angabe der CASCADE-Option RESTRICT scheitert die REVOKE-Anweisung.

REVOKE <schema_priv_spec>

Durch REVOKE CREATEIN ON wird dem durch grantee identifizierten Benutzer die Berechtigung entzogen, Datenbankobjekte im angegebenen Schema zu erzeugen. Datenbankobjekte, die der in grantee angegebene Benutzer bereits im angegebenen Schema erzeugt hat, bleiben bestehen.

Durch REVOKE DROPIN ON wird dem durch grantee identifizierten Benutzer die Berechtigung entzogen, Datenbankobjekte im angegebenen Schema zu löschen.

REVOKE EXECUTE ON

Durch REVOKE EXECUTE wird dem durch grantee identifizierten Benutzer die Berechtigung entzogen, die angegebene Datenbankprozedur oder Datenbankfunktion auszuführen. Die Berechtigung zur Ausführung kann nur vom Eigentümer der Datenbankprozedur oder Datenbankfunktion entzogen werden.

REVOKE SELECT ON

Durch REVOKE SELECT wird dem durch grantee identifizierten Benutzer die Berechtigung entzogen, die angegebene Sequenz zu verwenden. Auch diese REVOKE-Anweisung kann kaskadieren.

Siehe auch:

Privilegien: Überblick


Datenmanipulation (SAP-Bibliothek - Grundwissen)

Datenmanipulation

In den folgenden Abschnitten wird die vom Datenbanksystem verwendete Sprache zur Datenmanipulation (Data Manipulation Language, DML) vorgestellt.

Bei jeder SQL-Anweisung zur Datenmanipulation wird für jede eingefügte, geänderte oder gelöschte Zeile implizit eine Schreibsperre gesetzt.

SQL-Anweisungen zur Datenmanipulation

INSERT-Anweisung | UPDATE-Anweisung | DELETE-Anweisung
NEXT STAMP-Anweisung | CALL-Anweisung |

Beispiele

SQL-Tutorial, Strukturlink Datenmanipulation

Siehe auch:

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


INSERT-Anweisung (insert_statement) (SAP-Bibliothek - Grundwissen)

INSERT-Anweisung (insert_statement)

Die INSERT-Anweisung (insert_statement) erzeugt neue Zeilen einer Tabelle.

Syntax

<insert_statement> ::=
INSERT [INTO] <table_name> [(<column_name>,...)]
VALUES (<insert_expression>,...) [<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]
| INSERT [INTO] <table_name> [(<column_name>,...)] <query_expression>
[<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]
| INSERT [INTO] <table_name> SET <set_insert_clause>,...
[<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]

<insert_expression> ::= <extended_expression> | <subquery>
<extended_expression> ::= <expression> | DEFAULT | STAMP

<set_insert_clause> ::= <column_name> = <extended_value_spec>

Beispiele

SQL-Tutorial, Strukturlink Einfügen, Ändern, Löschen von Zeilen

Erläuterung

Der Tabellenname muss eine existierende Basistabelle oder View-Tabelle oder ein Synonym bezeichnen.

Der Benutzer muss das INSERT-Privileg für die durch den Tabellennamen identifizierte Tabelle besitzen. Wenn durch den Tabellennamen eine View-Tabelle identifiziert wird, ist es möglich, dass selbst der Eigentümer der View-Tabelle das INSERT-Privileg nicht besitzt, weil die View-Tabelle nicht änderbar ist.

<column_name>, <set_insert_clause>

Wenn Spaltennamen column_name oder eine SET INSERT-Klausel set_insert_clause angegeben sind, müssen alle angegebenen Spaltennamen Spalten der angegebenen Tabelle sein. Wenn die Tabelle ohne Schlüssel definiert wurde (d.h. vom Datenbanksystem wird intern die Spalte SYSKEY erzeugt), darf die Spalte SYSKEY nicht in der Folge der genannten Spalten oder in einer SET INSERT-Klausel vorkommen. Eine Spalte darf nicht mehrmals in einer Folge von Spaltennamen oder in mehr als einer SET INSERT-Klausel enthalten sein.

Eine angegebene Spalte (optional durch column_name oder Spaltenname in der set_insert_clause) ist eine Zielspalte. Die Zielspalten können in beliebiger Reihenfolge angegeben werden.

● Wenn kein Spaltenname und keine SET INSERT-Klausel angegeben ist, so hat das die gleiche Wirkung wie die Angabe einer Folge von Spalten, die alle Spalten der Tabelle in der bei der CREATE TABLE-Anweisung bzw. CREATE VIEW-Anweisung angegebenen Reihenfolge enthält. In diesem Fall sind alle vom Benutzer definierten Spalten der Tabelle Zielspalten.

● Die Anzahl der Ausdrücke insert_expression muss der Anzahl der Zielspalten entsprechen. Dem i-ten Spaltennamen ist der i-te Ausdruck zugeordnet.

● Ausdrücke extended_expression und Subqueries subquery können gleichzeitig angegeben werden.

● Es können eine oder mehrere Subqueries angegeben werden.

● Die angegebenen Subqueries dürfen nur genau eine Ergebniszeile liefern.

● Die Anzahl der im QUERY-Ausdruck query_expression angegebenen selektierten Spalten muss der Anzahl der Zielspalten entsprechen.

● Alle Pflichtspalten der durch den Tabellennamen identifizierten Tabelle müssen Zielspalten sein.

● Wenn der Tabellenname eine View-Tabelle identifiziert, werden Zeilen in die der View-Tabelle zugrundeliegende(n) Basistabelle(n) eingefügt. Die Zielspalten des angegebenen Tabellennamens korrespondieren in diesem Fall mit Spalten von Basistabellen, die der View-Tabelle zugrundeliegen. Im folgenden identifiziert der Begriff Zielspalte immer die korrespondierende Spalte der Basistabelle.

<extended_expression>

Die Angabe eines erweiterten Ausdrucks extended_expression kann durch die Angabe eines Ausdrucks oder eines der Schlüsselwörter DEFAULT bzw. STAMP erfolgen.

● Ausdruck expression
Ein Ausdruck in einer INSERT-Anweisung darf keine Spaltenspezifikation enthalten.
Der durch eine Parameterspezifikation in einem Ausdruck angegebene Wert ist der Wert des dadurch identifizierten Parameters. Wenn ein Indikatorparameter angegeben wurde und dieser einen negativen Wert hat, ist der durch die Parameterspezifikation angegebene Wert der NULL-Wert.

● Schlüsselwort DEFAULT
DEFAULT bezeichnet den für die Spalte als Vorschlagswert (DEFAULT) verwendeten Wert.

● Schlüsselwort STAMP
Das Datenbanksystem ist in der Lage, eindeutige Werte zu generieren. Es handelt sich dabei um eine fortlaufende Nummer, die bei X'000000000001' beginnt. Die Werte werden aufsteigend vergeben, wobei nicht sichergestellt werden kann, dass eine Folge von Werten lückenlos ist. Das Schlüsselwort STAMP liefert den nächsten vom Datenbanksystem generierten Wert.
Das Schlüsselwort STAMP kann in der INSERT-Anweisung oder in der UPDATE-Anweisung verwendet werden, allerdings nur auf Spalten vom Datentyp CHAR(n) BYTE mit n>=8.
Wenn der Anwender den generierten Wert erfahren möchte, bevor er auf eine Spalte angewandt wird, muss die SQL-Anweisung NEXT STAMP-Anweisung verwendet werden.

IGNORE TRIGGER

Sie können durch Angabe von IGNORE TRIGGER steuern, dass durch die INSERT-Anweisung kein INSERT-Trigger ausgeführt wird.

NOWAIT

Wenn Sie NOWAIT angeben, dann wird im Fall einer Sperrkollision nicht auf die Freigabe einer Sperre gewartet, sondern sofort mit einem Fehler zurückgekehrt.

Weitere Informationen

● Datentyp der Zielspalte und Datentyp des einzufügenden Wertes

● Join-View-Tabelle, QUERY-Ausdruck, CONSTRAINT-Definition, Trigger in INSERT-Anweisung


Datentyp der Zielspalte und Datentyp des einzufügenden Wertes (SAP-Bibliothek - Grundwissen)

Datentyp der Zielspalte und Datentyp des einzufügenden Wertes

Sei C eine Zielspalte und v ein vom NULL-Wert verschiedener Wert.

v soll in C durch eine INSERT-Anweisung eingefügt werden.
v soll zur Modifikation von C durch eine UPDATE-Anweisung verwendet werden.

Zielspalte C

geforderter Wert für v

numerische Spalte

Zahl, die im zulässigen Bereich von C liegt.

INSERT-Anweisung: Wenn v das Ergebnis eines QUERY-Ausdrucks ist, werden gegebenenfalls Nachkommastellen gerundet.

UPDATE-Anweisung: Wenn v das Ergebnis eines Ausdrucks (expression) ist, der nicht aus einem einzigen numerischen Literal besteht, werden gegebenenfalls Nachkommastellen gerundet.

alphanumerische Spalte mit dem Codeattribut ASCII, UNICODE

Zeichenkette, deren Länge nicht größer ist als das Längenattribut von C. Bei der Bestimmung der Länge von v werden nachfolgende Leerzeichen nicht berücksichtigt. Wenn die Länge von v kleiner ist als das Längenattribut von C, wird v um die entsprechende Anhalt von Leerzeichen verlängert.

alphanumerische Spalte mit dem Codeattribut BYTE

Hexadezimale Zeichenkette, deren Länge nicht größer ist als das Längenattribut von C. Bei der Bestimmung der Länge von v werden nachfolgende binäre Nullen nicht berücksichtigt. Wenn die Länge von v kleiner ist als das Längenattribut von C, wird v um die entsprechende Anzahl von binären Nullen verlängert.

Datentyp DATE

Datumswert im derzeit gültigen Datumsformat.

Datentyp TIME

Zeitwert im derzeit gültigen Zeitformat.

Datentyp TIMESTAMP

Zeitstempelwert im derzeit gültigen Zeitstempelformat.

Datentyp BOOLEAN

Einer der Werte TRUE oder FALSE (BOOLEAN)


Join-View-Tabelle, QUERY-Ausdruck, CONSTRAINT-Definition, Trigger in INSERT-Anweisung

Hintergrunddokumentation Join-View-Tabelle, QUERY-Ausdruck, CONSTRAINT-Definition, Trigger in INSERT-Anweisung

Im Folgenden werden einige Besonderheiten für INSERT-Anweisungen erläutert.

Join-View-Tabelle in einer INSERT-Anweisung

● Wenn durch den Tabellennamen in einer INSERT-Anweisung keine Join-View-Tabelle identifiziert wird und eine Zeile mit dem Schlüssel der einzufügenden Zeile bereits existiert, hängt das Ergebnis von der Angabe der DUPLICATES-Klausel ab. Ist keine DUPLICATES-Klausel angegeben, scheitert die INSERT-Anweisung.

● Wenn der Tabellenname eine Join-View-Tabelle identifiziert, wird in jede Basistabelle, die der View-Tabelle zugrundeliegt, eine Zeile eingefügt. Wenn eine Zeile mit dem Schlüssel der einzufügenden Zeile in der Schlüsseltabelle der View-Tabelle bereits existiert, scheitert die INSERT-Anweisung. Wenn eine Zeile mit dem Schlüssel der einzufügenden Zeile in einer Basistabelle, die nicht Schlüsseltabelle oder View-Tabelle ist, bereits existiert, scheitert die INSERT-Anweisung, wenn die einzufügende Zeile nicht mit der existierenden übereinstimmt.

Siehe auch:

CREATE VIEW-Anweisung (create_view_statement)

QUERY-Ausdruck in einer INSERT-Anweisung

· Wenn in der INSERT-Anweisung ein QUERY-Ausdruck angegeben ist, darf die angegebene Tabelle keine Join-View-Tabelle sein.
Der QUERY-Ausdruck definiert eine Ergebnistabelle, deren i-te Spalte der i-ten Zielspalte zugeordnet wird. Aus jeder Zeile der Ergebnistabelle wird eine Zeile der angegebenen Tabelle gebildet und in die Basistabelle eingefügt. Jede dieser Zeilen setzt sich wie folgt zusammen:
Alle Spalten der Basistabelle, die Zielspalten der INSERT-Anweisung sind, enthalten den Spaltenwert der Spalte der aktuellen Zeile der Ergebnistabelle, die ihr zugeordnet ist.

· Wenn in der INSERT-Anweisung kein QUERY-Ausdruck angegeben ist, wird genau eine Zeile in die angegebene Tabelle eingefügt. Die eingefügte Zeile setzt sich wie folgt zusammen: Alle Spalten der Basistabelle, die Zielspalten der INSERT-Anweisung sind, enthalten den der jeweiligen Zielspalte zugeordneten Wert.

Weiterhin gilt für die Zeile bzw. Zeilen, die eingefügt werden, folgendes:

· Alle Spalten der Basistabelle, die keine Zielspalten der INSERT-Anweisung sind und für die eine DEFAULT-Spezifikation existiert, enthalten den Vorschlagswert (DEFAULT-Wert).

· Alle Spalten der Basistabelle, die keine Zielspalten der INSERT-Anweisung sind und für die keine DEFAULT-Spezifikation existiert, enthalten den NULL-Wert.

CONSTRAINT-Definition in einer INSERT-Anweisung

Wenn für Basistabellen, in die durch die INSERT-Anweisung Zeilen eingefügt werden, CONSTRAINT-Definitionen existieren, wird für jede einzufügende Zeile geprüft, ob sie die CONSTRAINT-Definition erfüllt. Wenn dies für mindestens eine Zeile nicht der Fall ist, scheitert die INSERT-Anweisung.

Wenn mindestens eine der Basistabellen, in die durch die INSERT-Anweisung Zeilen eingefügt werden, referenzierende Tabelle einer referentiellen CONSTRAINT-Definition ist, wird für jede einzufügende Zeile geprüft, ob der aus der Zeile resultierende Fremdschlüssel als Schlüssel bzw. als Wert eines mit UNIQUE definierten Index in der korrespondierenden referenzierten Tabelle (referenced_table) existiert. Wenn dies für mindestens eine Zeile nicht der Fall ist, scheitert die INSERT-Anweisung.

Trigger in einer INSERT-Anweisung

Wenn für Basistabellen, in die durch die INSERT-Anweisung Zeilen eingefügt werden, Trigger definiert wurden, die nach einer INSERT-Anweisung auszuführen sind, so werden diese ausgeführt. Scheitert einer dieser Trigger, scheitert die INSERT-Anweisung.


UPDATE-Anweisung (update_statement) (SAP-Bibliothek - Grundwissen)

UPDATE-Anweisung (update_statement)

Die UPDATE-Anweisung (update_statement) ändert Spaltenwerte in Tabellenzeilen.

Syntax

<update_statement> ::=
UPDATE [OF] <table_name> [<reference_name>] SET <set_update_clause>,... [KEY <key_spec>,...] [WHERE <search_condition>] [IGNORE TRIGGER] [NOWAIT]
| UPDATE [OF] <table_name> [<reference_name>] (<column_name>,...) VALUES (<extended_value_spec>,...) [KEY <key_spec>,...] [WHERE <search_condition>] [IGNORE TRIGGER] [NOWAIT]
| UPDATE [OF] <table_name> [<reference_name>] SET <set_update_clause>,... WHERE CURRENT OF <result_table_name> [NOWAIT]
| UPDATE [OF] <table_name> [<reference_name>] (<column_name>,...) VALUES (<extended_value_spec>,...) WHERE CURRENT OF <result_table_name> [NOWAIT]

<set_update_clause> ::= <column_name> = <extended_expression>
| <column_name>,... = (<extended_expression>,...)
| (<column_name>,...) = (<extended_expression>,...)
| <column_name> = <subquery>
| (<column_name>,...) = <subquery>

Beispiele

SQL-Tutorial, Strukturlink Einfügen, Ändern, Löschen von Zeilen

Erläuterung

Der Tabellenname muss eine existierende Basistabelle, View-Tabelle oder ein Synonym identifizieren.

Die Spalten, deren Werte geändert werden sollen, heißen Zielspalten. Nach Angabe des Tabellennamens und gegebenenfalls des Referenznamens werden eine oder mehrere Zielspalten und neue Werte für diese Spalten angegeben.

· Alle Zielspalten müssen Spalten der angegebenen Tabelle identifizieren, und jede Zielspalte darf nur einmal aufgeführt werden.

· Die Anzahl der angegebenen Spezifikationen von Werten extended_value_spec muss der Anzahl der Zielspalten entsprechen. Der i-ten Zielspalte ist die i-te Spezifikation eines Wertes zugeordnet.

· Der aktuelle Benutzer muss das UPDATE-Privileg für jede Zielspalte der angegebenen Tabelle besitzen.
Falls der Tabellenname eine View-Tabelle identifiziert, ist es möglich, dass selbst der Eigentümer der View-Tabelle keine Spaltenwerte ändern kann, weil die View-Tabelle nicht änderbar ist.

· Wenn die angegebene Tabelle eine View-Tabelle ist, werden nur Spaltenwerte von Zeilen von Basistabellen geändert, die der View-Tabelle zugrundeliegen. Die Zielspalten der angegebenen Tabelle korrespondieren in diesem Fall mit Spalten der Basistabellen, die der View-Tabelle zugrundeliegen. Im folgenden identifiziert der Begriff Zielspalte immer die korrespondierende Spalte der Basistabelle.

Siehe auch:

Datentyp der Zielspalte und Datentyp des einzufügenden Wertes

Welche Zeilen werden geändert

Welche Zeilen der angegebenen Tabelle geändert werden, wird durch eine der folgende Angaben festgelegt:

· Optionale Folge von Schlüsselspezifikation und optionale Suchbedingung
Schlüsselspezifikation und keine Suchbedingung: Es existiert eine Zeile mit den angegebenen Schlüsselwerten. Den Zielspalten dieser Zeile werden die korrespondierenden Werte zugewiesen. Wenn keine Zeile mit den angegebenen Schlüsselwerten existiert, wird keine Zeile geändert.
Schlüsselspezifikation und eine Suchbedingung: Es existiert eine Zeile mit den angegebenen Schlüsselwerten. Die Suchbedingung wird auf diese Zeile angewendet. Wenn die Suchbedingung erfüllt ist, werden den Zielspalten dieser Zeile die korrespondierenden Werte zugewiesen. Wenn keine Zeile mit den angegebenen Schlüsselwerten existiert oder eine auf eine Zeile angewandte Suchbedingung nicht erfüllt ist, wird keine Zeile geändert.
Keine Schlüsselspezifikation und eine Suchbedingung: Die Suchbedingung wird auf jede Zeile der angegebenen Tabelle angewendet. In allen Zeilen, die die Suchbedingung erfüllen, werden den Zielspalten die korrespondierenden Werte zugewiesen.

· Bei Verwendung von CURRENT OF, d.h. bei Angabe der Cursorposition innerhalb der Ergebnistabelle result_table_name: Wenn der Cursor nicht auf einer Zeile der Ergebnistabelle steht, wird keine Zeile geändert.

· Wurde keine der oben genannten möglichen Angaben vorgenommen, werden alle Zeilen der angegebenen Tabelle geändert.

· Wenn keine Zeile gefunden wird, die die durch die optionalen Klauseln definierten Bedingungen erfüllt, erscheint folgende Rückmeldung: 100 Zeile nicht gefunden

Auch Werte von Schlüsselspalten, die von einem Benutzer bei einer CREATE TABLE-Anweisung oder einer ALTER TABLE-Anweisung definiert wurden, können verändert werden. Die gegebenenfalls implizit angelegte Schlüsselspalte SYSKEY kann nicht verändert werden.

Wenn der Tabellenname eine Join-View-Tabelle angibt, können Spalten existieren, die nur in Kombination mit anderen Spalten geändert werden können.

Ermitteln der Spaltenkombination für eine Spalte einer Join-View-Tabelle

Um die Kombination von Spalten für eine gegebene Spalte v einer Join-View-Tabelle zu ermitteln, gehen Sie wie folgt vor:

...

1. Bestimmen Sie die Basistabelle Tj, in der die Spalte liegt, mit der v korrespondiert.

2. Bestimmen Sie die eindeutige Tabellenfolge Ti1...Tik, in der Tj liegt.

3. Bestimmen Sie die letzte Tabelle Ti1 dieser Folge, die zur Schlüsseltabelle in einer 1:1-Beziehung steht.

4. Die Spalten der Join-View-Tabelle, die mit den Fremdschlüsselspalten von Ti1 der für die Join-View-Tabelle relevanten referentiellen CONSTRAINT-Definition zwischen Ti1 und Ti1+1 korrespondieren, sind Elemente der Spaltenkombination.

5. Alle Spalten der Join-View-Tabelle, die mit Spalten der Tabellen Ti1+1...Tik korrespondieren, sind Element der Spaltenkombination.

Um den Spaltenwert der entsprechenden Spalte zu ändern, muss für alle Spalten der Spaltenkombination ein Wert angegeben werden. Dies gilt für alle Zielspalten, für die eine der folgenden Bedingungen gilt:

· Die Zielspalten liegen in einer Basistabelle, die nicht Schlüsseltabelle der Join-View-Tabelle ist und die nicht in einer 1:1-Beziehung zur Schlüsseltabelle der Join-View-Tabelle steht.

· Die Zielspalten sind Fremdschlüsselspalten einer für die Join-View-Tabelle relevanten referentiellen CONSTRAINT-Definition.

SET <set_update_clause>

Der Ausdruck in einer SET UPDATE-Klausel set_update_clause darf keine Set-Funktion enthalten.

Die Subquery muss eine Ergebnistabelle liefern, die höchstens eine Zeile enthält, und aus so vielen Spalten besteht wie Zielspalten angegeben sind.

IGNORE TRIGGER

Sie können durch Angabe von IGNORE TRIGGER steuern, dass durch die UPDATE-Anweisung kein UPDATE-Trigger ausgeführt wird. So können Sie Endlosrekursionen vermeiden, falls geänderte Zeilen im Trigger nochmal geändert werden.

CURRENT OF

Wenn CURRENT OF angegeben ist, muss der Tabellenname in der FROM-Klausel der QUERY-Anweisung, mit der die Ergebnistabelle result_table_name aufgebaut wurde, mit dem Tabellennamen in der UPDATE-Anweisung übereinstimmen.

Wenn CURRENT OF angegeben ist, und der Cursor auf einer Zeile der Ergebnistabelle steht, werden den Zielspalten der korrespondierenden Zeile die korrespondierenden Werte zugewiesen. Korrespondierend ist die Zeile aus der in der FROM-Klausel der QUERY-Anweisung angegebenen Tabelle, aus der die Zeile der Ergebnistabelle gebildet wurde. Voraussetzung dafür ist jedoch, dass die Ergebnistabelle mit FOR UPDATE spezifiziert wurde. Es kann keine Aussage darüber getroffen werden, ob die Änderung in der korrespondierenden Zeile beim nächsten Zugriff auf die gleiche Zeile der Ergebnistabelle sichtbar ist oder nicht.

NOWAIT

Wenn Sie NOWAIT angeben, dann wird im Fall einer Sperrkollision nicht auf die Freigabe einer Sperre gewartet, sondern sofort mit einem Fehler zurückgekehrt.

Gründe für das Scheitern der UPDATE-Anweisung

Wenn für Basistabellen, in denen durch die UPDATE-Anweisung Zeilen geändert wurden, CONSTRAINT-Definition en existieren, wird für jede geänderte Zeile geprüft, ob sie die CONSTRAINT-Definitionen erfüllt. Ist dies für mindestens eine geänderte Zeile nicht der Fall, scheitert die UPDATE-Anweisung.

Für jede Zeile, in der durch die UPDATE-Anweisung der Wert von Fremdschlüsselspalten geändert wurde, wird geprüft, ob der jeweils resultierende Fremdschlüssel als Schlüssel bzw. als Wert eines mit UNIQUE definierten Index in der korrespondierenden referenzierten Tabelle referenced_table existiert. Ist dies für mindestens eine geänderte Zeile der Fall, scheitert die UPDATE-Anweisung.

Für jede Zeile, in der durch die UPDATE-Anweisung der Wert einer referenzierten Spalte referenced_column einer referentiellen CONSTRAINT-Definition geändert werden soll, wird geprüft, ob Zeilen in der korrespondierenden Fremdschlüsseltabelle existieren, die die noch unveränderten Spaltenwerte als Fremdschlüssel enthalten. Ist dies für mindestens eine Zeile der Fall, scheitert die UPDATE-Anweisung.

Wenn für Basistabellen, in denen durch die UPDATE-Anweisung Zeilen geändert werden, Trigger definiert wurden, die nach einer UPDATE -Anweisung auszuführen sind, so werden diese ausgeführt. Scheitert einer dieser Trigger, scheitert die UPDATE -Anweisung.

Weitere Informationen

Spalten mit dem Datentyp LONG kann durch die UPDATE-Anweisung nur über einen Parameter oder durch Angabe von NULL ein Wert zugewiesen werden. Deshalb ist die Zuweisung von Werten an LONG-Spalten nur mit einigen Datenbankwerkzeugen möglich.


DELETE-Anweisung (delete_statement) (SAP-Bibliothek - Grundwissen)

DELETE-Anweisung (delete_statement)

Die DELETE-Anweisung (delete_statement) löscht Zeilen einer Tabelle.

Syntax

<delete_statement> ::=
DELETE [FROM] <table_name> [<reference_name>] [KEY <key_spec>,...]
[WHERE <search_condition>] [IGNORE TRIGGER] [NOWAIT]
| DELETE [FROM] <table_name> [<reference_name>] WHERE CURRENT OF <result_table_name> [NOWAIT]

Beispiele

SQL-Tutorial, Strukturlink Einfügen, Ändern, Löschen von Zeilen

Erläuterung

Der Tabellenname muss eine existierende Basistabelle, View-Tabelle oder ein Synonym identifizieren.

Der aktuelle Benutzer muss das DELETE-Privileg für die angegebene Tabelle besitzen. Falls der angegebene Tabellenname eine View-Tabelle identifiziert, ist es möglich, dass selbst der Eigentümer der View-Tabelle das DELETE-Privileg nicht besitzt, weil die View-Tabelle nicht änderbar ist.

<table_name>

Tabellenname identifiziert eine View-Tabelle: Die Zeilen der Basistabellen werden gelöscht, die der View-Tabelle zugrundeliegen.

Tabellenname identifiziert eine Join-View-Tabelle: Es werden nur folgende Zeilen gelöscht:

● Zeilen in der Schlüsseltabelle der Join-View-Tabelle

● Zeilen in Basistabellen, die der View-Tabelle zugrundeliegen und in einer 1:1-Beziehung zur Schlüsseltabelle stehen.

<key_spec>, search_condition>

Welche Zeilen der angegebenen Tabelle gelöscht werden, wird durch eine der folgende Angaben festgelegt:

● Optionale Folge von Schlüsselspezifikationen und optionale Suchbedingung
Schlüsselspezifikation und keine Suchbedingung: Es existiert eine Zeile mit den angegebenen Schlüsselwerten. Diese Zeile wird gelöscht. Wenn keine Zeile mit den angegebenen Schlüsselwerten existiert, wird keine Zeile gelöscht.
Schlüsselspezifikation und eine Suchbedingung: Es existiert eine Zeile mit den angegebenen Schlüsselwerten. Die Suchbedingung wird auf diese Zeile angewendet. Wenn die Suchbedingung erfüllt ist, wird die Zeile gelöscht. Wenn keine Zeile mit den angegebenen Schlüsselwerten existiert oder eine auf eine Zeile angewandte Suchbedingung nicht erfüllt ist, wird keine Zeile gelöscht.
Keine Schlüsselspezifikation und eine Suchbedingung: Die Suchbedingung wird auf jede Zeile der angegebenen Tabelle angewendet. Alle Zeilen, die die Suchbedingung erfüllen, werden gelöscht.

● Bei Verwendung von CURRENT OF, d.h. bei Angabe der Cursorposition innerhalb der Ergebnistabelle result_table_name: Wenn der Cursor nicht auf einer Zeile der Ergebnistabelle steht, wird keine Zeile gelöscht.

● Wurde keine der oben genannten möglichen Angaben vorgenommen, werden alle Zeilen der angegebenen Tabelle gelöscht.

● Wenn keine Zeile gefunden wird, die die durch die optionalen Klauseln definierten Bedingungen erfüllt, erscheint folgende Rückmeldung: 100 Zeile nicht gefunden

CURRENT OF

Wenn CURRENT OF angegeben ist, muss der Tabellenname in der FROM-Klausel der QUERY-Anweisung, mit der die Ergebnistabelle result_table_name aufgebaut wurde, mit dem Tabellennamen in der DELETE-Anweisung übereinstimmen.

Wenn CURRENT OF angegeben ist, und der Cursor auf einer Zeile der Ergebnistabelle steht, wird die korrespondierende Zeile gelöscht. Korrespondierend ist die Zeile aus der in der FROM-Klausel der QUERY-Anweisung angegebenen Tabelle, aus der die Zeile der Ergebnistabelle gebildet wurde. Voraussetzung dafür ist jedoch, dass die Ergebnistabelle mit FOR UPDATE spezifiziert wurde. Der Cursor steht anschließend hinter der Zeile der Ergebnistabelle. Es kann keine Aussage darüber getroffen werden, ob die Änderung in der korrespondierenden Zeile beim nächsten Zugriff auf die gleiche Zeile der Ergebnistabelle sichtbar ist oder nicht.

IGNORE TRIGGER

Wenn für Basistabellen, aus denen durch die DELETE-Anweisung Zeilen gelöscht werden, Trigger definiert wurden, die nach einer DELETE-Anweisung auszuführen sind, so werden diese ausgeführt. Scheitert einer dieser Trigger, scheitert die DELETE-Anweisung.

Sie können durch Angabe von IGNORE TRIGGER steuern, dass durch die DELETE-Anweisung kein DELETE-Trigger ausgeführt wird.

NOWAIT

Wenn Sie NOWAIT angeben, dann wird im Fall einer Sperrkollision nicht auf die Freigabe einer Sperre gewartet, sondern sofort mit einem Fehler zurückgekehrt.

DELETE-Regel

Für jede im Verlauf der DELETE-Anweisung gelöschte Zeile, die aus einer referenzierten Tabelle referenced_table mindestens einer referentiellen CONSTRAINT-Definition stammt, wird in Abhängigkeit von der DELETE-Regel der referentiellen CONSTRAINT-Definition eine der folgenden Aktionen durchgeführt:

● DELETE CASCADE: Alle Trefferzeilen in der korrespondierenden Fremdschlüsseltabelle werden gelöscht.

● DELETE RESTRICT: Falls es Trefferzeilen in der korrespondierenden Fremdschlüsseltabelle gibt, scheitert die DELETE-Anweisung.

● DELETE SET NULL: In allen Trefferzeilen der korrespondierenden Fremdschlüsseltabelle werden die entsprechenden Fremdschlüsselspalten mit dem NULL-Wert belegt.

● DELETE SET DEFAULT: In allen Trefferzeilen der korrespondierenden Fremdschlüsseltabelle werden die entsprechenden Fremdschlüsselspalten mit dem DEFAULT-Wert, der durch Angabe einer DEFAULT-Spezifikation gesetzt wurde, belegt.


NEXT STAMP-Anweisung (next_stamp_statement) (SAP-Bibliothek - Grundwissen)

NEXT STAMP-Anweisung (next_stamp_statement)

Die NEXT STAMP-Anweisung (next_stamp_statement) liefert einen vom Datenbanksystem generierten eindeutigen Schlüssel.

Syntax

<next_stamp_statement> ::= NEXT STAMP [INTO] <parameter_name>

Erläuterung

Das Datenbanksystem ist in der Lage, eindeutige Werte zu generieren. Es handelt sich dabei um eine fortlaufende Nummer, die bei X'0000000000001' beginnt. Die Werte werden aufsteigend vergeben, wobei nicht sichergestellt werden kann, dass eine Folge von Werten lückenlos ist. Diese Werte können in einer Spalte vom Datentyp CHAR(n) BYTE mit n>=8 abgelegt werden.

Die NEXT STAMP-Anweisung weist den nächsten vom Datenbanksystem generierten Wert der mit parameter_name bezeichneten Variablen zu.

Die NEXT STAMP-Anweisung kann nur in eine Programmiersprache eingebettet werden, sie kann nicht im interaktiven Betrieb verwendet werden.

In einer INSERT-Anweisung oder einer UPDATE-Anweisung kann ebenfalls das Schlüsselwort STAMP verwendet werden, wenn der nächste Wert durch das Datenbanksystem generiert und in einer Spalte abgelegt werden soll, ohne dass der Anwender diesen Wert kennt.


CALL-Anweisung (call_statement) (SAP-Bibliothek - Grundwissen)

CALL-Anweisung (call_statement)

Die CALL-Anweisung (call_statement) bewirkt die Ausführung einer Datenbankprozedur.

Syntax

<call_statement> ::= CALL <dbproc_name> [(<expression>,...)] [WITH COMMIT]

Beispiele

SQL-Tutorial, Strukturlink Datenbankprozeduren

Erläuterung

Der angegebene Name der Datenbankprozedur muss eine existierende Datenbankprozedur identifizieren.

Der aktuelle Benutzer muss das EXECUTE-Privileg für die Datenbankprozedur besitzen.

Die Anzahl der Ausdrücke expression muss der Anzahl der formalen Parameter der Datenbankprozedur entsprechen.

Der Datentyp des i-ten Ausdrucks muss mit dem Datentyp des i-ten formalen Parameters der Datenbankprozedur verträglich sein.

Wenn der i-te formale Parameter der Datenbankprozedur den Modus OUT oder INOUT besitzt (siehe CREATE DBPROC-Anweisung), muss der korrespondierende Ausdruck einer Parameterspezifikation entsprechen.

WITH COMMIT

Bei Angabe von WITH COMMIT wird nach der fehlerfreien Ausführung der Datenbankprozedur die aktuelle Transaktionen mit COMMIT abgeschlossen. Wenn die Ausführung der Datenbankprozedur scheitert, wird die aktuelle Transaktion mit ROLLBACK abgebrochen.


Datenanfrage (SAP-Bibliothek - Grundwissen)

Datenanfrage

In den folgenden Abschnitten wird die vom Datenbanksystem verwendete Anfragesprache (auch als Abfragesprache oder Sprache zum Datenretrieval bezeichnet) vorgestellt.

SQL-Anweisungen zur Datenanfrage

QUERY-Anweisung | SINGLE SELECT-Anweisung | EXPLAIN-Anweisung
FETCH-Anweisung | CLOSE-Anweisung |

Beispiele

SQL-Tutorial, Strukturlink Datenanfrage


QUERY-Anweisung (query_statement) (SAP-Bibliothek - Grundwissen)

QUERY-Anweisung (query_statement)

Eine QUERY-Anweisung (query_statement) spezifiziert eine gegebenenfalls geordnete Ergebnistabelle. Es gibt verschiedene Grundtypen für die Formulierung einer QUERY-Anweisung.

Syntax

<query_statement> ::= <declare_cursor_statement>
| <recursive_declare_cursor_statement>
| <select_statement>

Beispiele

SQL-Tutorial, Strukturlink Datenanfrage

Erläuterung

Durch eine QUERY-Anweisung wird eine benannte oder unbenannte Ergebnistabelle erzeugt. Eine unbenannte Ergebnistabelle kann im Gegensatz zu einer benannten Ergebnistabelle nicht in einer FROM-Klausel oder im CURRENT OF <result_table_name> einer nachfolgenden SQL-Anweisung angegeben werden.

Folgende QUERY-Anweisungen werden unterschieden:

Grundtypen einer QUERY-Anweisung |
DECLARE CURSOR-Anweisung | Eine benannte Ergebnistabelle wird definiert und erzeugt.
SELECT-Anweisung select_statement | Eine unbenannte Ergebnistabelle wird definiert und erzeugt.
Rekursive DECLARE CURSOR-Anweisung | Mit dieser Anweisung können Stücklisten erzeugt werden.

Für die SELECT-Anweisung select_statement gelten die Regeln, die für die DECLARE CURSOR-Anweisung declare_cursor_statement angegeben werden.

Die Reihenfolge der Zeilen in der Ergebnistabelle hängt von der systeminternen Suchstrategie ab und ist nicht vorhersehbar. Der einzig sichere Weg, eine Sortierung der Ergebniszeilen zu erhalten, besteht in der Angabe einer ORDER-Klausel.

Änderbare Ergebnistabelle

Eine Ergebnistabelle bzw. die ihr zugrundeliegenden Basistabellen sind änderbar, wenn die QUERY-Anweisung folgende Bedingungen erfüllt:

● Die QUERY-Anweisung besteht aus einer DECLARE CURSOR-Anweisung.

● Der QUERY-Ausdruck (query_expression) darf nur aus einer QUERY-Spezifikation (query_spec) bestehen.

● In der FROM-Klausel der QUERY-Spezifikation darf nur eine Basistabelle oder eine änderbare View-Tabelle angegeben worden sein.

● Es darf nicht das Schlüsselwort DISTINCT, eine GROUP- oder HAVING-Klausel angegeben werden.

● Ausdrücke dürfen keine Set-Funktion enthalten.

● Die Ergebnistabelle ist eine benannte Ergebnistabelle, d.h. sie darf nicht durch eine SELECT-Anweisung erzeugt worden sein.

Siehe auch:

Ergebnistabellenname

Glossar, Tabelle


DECLARE CURSOR-Anweisung (declare_cursor_statement) (SAP-Bibliothek - Grundwissen)

DECLARE CURSOR-Anweisung (declare_cursor_statement)

Durch die DECLARE CURSOR-Anweisung (declare_cursor_statement) wird eine benannte Ergebnistabelle mit dem Namen result_table_name definiert und erzeugt.

Syntax

<declare_cursor_statement> ::= DECLARE <result_table_name> CURSOR FOR <select_statement>

Erläuterung

Existierende Ergebnistabellen werden implizit durch das Erzeugen einer Ergebnistabelle gleichen Namens gelöscht.

Alle Ergebnistabellen, die in der aktuellen Transaktion erzeugt wurden, werden implizit bei Beendigung der Transaktion mittels der ROLLBACK-Anweisung gelöscht.

Alle Ergebnistabellen werden implizit bei Beendigung der Sitzung mittels der RELEASE-Anweisung gelöscht. Sie können zuvor explizit durch eine CLOSE-Anweisung gelöscht werden.

Wenn der Name einer Ergebnistabelle identisch ist mit dem Namen einer Basistabelle, View-Tabelle oder eines Synonyms, kann auf diese Tabellen während der Lebensdauer der Ergebnistabelle nicht lesend zugegriffen werden. Wenn eine INSERT-, UPDATE-, DELETE- oder LOCK-Anweisung auf eine Ergebnistabelle erfolgt, deren Name mit dem Namen einer Basistabelle, View-Tabelle oder eines Synonyms identisch ist, erfolgt der Zugriff auf die entsprechende Nicht-Ergebnistabelle.

Zu jedem Zeitpunkt der Abarbeitung einer Ergebnistabelle existiert ein Standpunkt (Cursor), der sich vor der ersten Zeile, auf einer Zeile, hinter der letzten Zeile oder zwischen zwei Zeilen befinden kann. Nach dem Erzeugen der Ergebnistabelle befindet sich der Standpunkt (Cursor) vor der ersten Zeile der Ergebnistabelle.

Je nach Suchstrategie wird die Suche nach allen Zeilen der Ergebnistabelle durchgeführt und die Ergebnistabelle physisch erzeugt oder jeweils die nächste Zeile der Ergebnistabelle bei der Ausführung einer FETCH-Anweisung gesucht und nicht physisch gespeichert.

Ist die Ergebnistabelle leer, erhalten Sie die Rückmeldung 100 – Zeile nicht gefunden .


Rekursive DECLARE CURSOR-Anweisung (recursive_declare_cursor_statement)

Mit Hilfe der rekursiven DECLARE CURSOR-Anweisung (recursive_declare_cursor_statement) ist es möglich, Stücklisten mittels eines Befehls zu erhalten.

Syntax

<recursive_declare_cursor_statement> ::=
DECLARE <result_table_name> CURSOR FOR WITH RECURSIVE <reference_name> (<alias_name>,...) AS
(<initial_select> UNION ALL <recursive_select>) <final_select>

<initial_select>
::= <query_spec>
<recursive_select> ::= <query_spec>
<final_select> ::= <select_statement>

DECLARE C CURSOR FOR
WITH RECURSIVE PX (MAJOR, MINOR, NUMBER, MAINMAJOR) AS
(SELECT W,X,Y,W FROM T WHERE W = 'aaa' UNION ALL
SELECT W,X,Y,MAINMAJOR FROM T, PX WHERE MINOR = T.W)
SELECT MAINMAJOR,MINOR,NUMBER FROM PX ORDER BY NUMBER

Erläuterung

Wenn vor der Ausführung der rekursiven DECLARE CURSOR-Anweisung ein Ergebnistabellenname mit dem angegebenen Referenznamen existierte, so wird der entsprechende Cursor implizit geschlossen.

<initial_select>

Die QUERY-Spezifikation initial_select wird ausgeführt und das Ergebnis in eine temporäre Ergebnistabelle eingetragen, deren Name durch die Angabe des Referenznamens reference_name festgelegt ist. Die darin enthaltenen Spaltennamen erhalten die Namen aus der Liste der Alias-Namen. Die Anzahl von Ausgabespalten in der QUERY-Spezifikation muss mit der Anzahl von Alias-Namen übereinstimmen.

<recursive_select>

Die QUERY-Spezifikation recursive_select sollte aus einer SELECT-Anweisung bestehen, die mindestens einmal den Referenznamen in der FROM-Klausel und mindestens ein JOIN-Prädikat zwischen dieser und einer anderen Tabelle aus der FROM-Klausel enthält.

Die QUERY-Spezifikation recursive_select wird so lange wiederholt, bis diese kein Ergebnis mehr liefert. Die jeweiligen Ergebnisse werden (logisch) in die temporäre Ergebnistabelle eingetragen, deren Name durch den Referenznamen definiert ist. Diese Tabelle wird immer mehr erweitert. Es ist aber sichergestellt, dass beim n+1-ten Ausführen nur noch die Ergebnisse der n-ten Ausführung verwendet werden, um eine Endlosschleife zu vermeiden.

<final_select>

Die SELECT-Anweisung final_select darf nur einen QUERY-Ausdruck enthalten, der aus einer QUERY-Spezifikation besteht.

Es handelt sich um eine SELECT-Anweisung über die Tabelle mit dem angegebenen Referenznamen, in der folgende Elemente verwendet werden können: Set-Funktionen, GROUP-Klausel, HAVING-Klausel, ORDER-Klausel, LOCK-Option


SELECT-Anweisung (select_statement) (SAP-Bibliothek - Grundwissen)

SELECT-Anweisung (select_statement)

Durch eine SELECT-Anweisung (select_statement) wird eine unbenannte Ergebnistabelle definiert und gleichzeitig erzeugt.

Syntax

<select_statement> ::= <query_expression> [<order_clause>] [<limit_clause>]
[<update_clause>] [<lock_option>] [FOR REUSE]

<limit_clause> ::= LIMIT <row_count>
| LIMIT <offset>,<row_count>
<row_count> ::= <unsigned_integer>
| <parameter_name>
<offset> ::= <unsigned_integer>
| <parameter_name>

Beispiele

SQL-Tutorial, Strukturlink Datenanfrage

Erläuterung

Für die SELECT-Anweisung select_statement gelten die Regeln, die für die DECLARE CURSOR-Anweisung angegeben werden.

Je nach Suchstrategie wird die Suche nach allen Zeilen der Ergebnistabelle bei der Ausführung der SELECT-Anweisung durchgeführt und die Ergebnistabelle physisch erzeugt oder jeweils die nächste Zeile der Ergebnistabelle bei der Ausführung einer FETCH-Anweisung gesucht und nicht physisch gespeichert. Dies ist beim Zeitverhalten von FETCH-Anweisungen zu berücksichtigen.

Änderbare Ergebnistabelle

Eine Ergebnistabelle bzw. die ihr zugrundeliegenden Basistabellen sind änderbar, wenn die QUERY-Anweisung folgende Bedingungen erfüllt:

● Die QUERY-Anweisung besteht aus einer DECLARE CURSOR-Anweisung.

● Der QUERY-Ausdruck query_expression darf nur aus einer QUERY-Spezifikation query_spec bestehen.

● In der FROM-Klausel der QUERY-Spezifikation darf nur eine Basistabelle oder eine änderbare View-Tabelle angegeben worden sein.

● Es darf nicht das Schlüsselwort DISTINCT, eine GROUP- oder HAVING-Klausel angegeben werden.

● Ausdrücke dürfen keine Set-Funktion (set_function_spec) enthalten.

ORDER-Klausel

Die ORDER-Klausel order_clause spezifiziert eine Sortierreihenfolge für eine Ergebnistabelle.

LIMIT-Klausel

Die LIMIT-Klausel limit_clause können Sie verwenden, um die maximale Zeilenanzahl der Ergebnistabelle einzuschränken. Sie geben entweder nur die gewünschte maximale Zeilenanzahl an oder noch zusätzlich die Information, ab welcher Zeile die Ausgabe erfolgen soll (Offset-Wert). Der Offset der initialen Zeile ist 0. Ohne Angabe eines Offset werden die Zeilen ab Beginn der Ergebnistabelle ausgegeben.

Wenn Sie ein ROWNO-Prädikat oder ein TOP-Syntaxelement verwenden, dürfen Sie die LIMIT-Klausel nicht verwenden.

Wird eine LIMIT-Klausel und eine ORDER-Klausel angegeben, so werden alle Ergebniszeilen sortiert und dann die entsprechende Anzahl von Zeilen ausgegeben. Das Ergebnis unterscheidet sich im Normalfall von dem, das man erhalten hätte, wäre keine ORDER-Klausel angegeben gewesen.

UPDATE-Klausel

Die Angabe einer UPDATE-Klausel update_clause ist nur bei änderbaren Ergebnistabellen erlaubt. Bei änderbaren Ergebnistabellen entspricht ein Standpunkt in der Ergebnistabelle immer einem Standpunkt in den zugrundeliegenden Tabellen und damit letzlich einem Standpunkt in einer oder mehreren Basistabellen.

Wenn eine UPDATE-Klausel angegeben wurde, können die Basistabellen mit Hilfe des Standpunktes in der Ergebnistabelle (Angabe von CURRENT OF <result_table_name>) durch eine UPDATE-Anweisung oder eine DELETE-Anweisung geändert werden. Es kann mit Hilfe einer LOCK-Anweisung eine Sperre für die betroffene Zeile jeder betroffenen Basistabelle angefordert werden.

LOCK-Option

Die LOCK-Option lock_option bestimmt, welche Sperren auf die gelesenen Zeilen gesetzt werden.

FOR REUSE

Soll die Ergebnistabelle in einer nachfolgenden QUERY-Anweisung in der FROM-Klausel angegeben werden, so sollte diese Ergebnistabelle mit den Schlüsselwörtern FOR REUSE angegeben werden. Wenn FOR REUSE nicht angegeben ist, hängt die Wiederverwendbarkeit der Ergebnistabelle von systeminternen Strategien ab.

Da die Angabe von FOR REUSE die Antwortzeiten einiger QUERY-Anweisungen verschlechtert, sollte FOR REUSE nur angegeben werden, wenn es für die Wiederverwendbarkeit der Ergebnistabelle notwendig ist.


QUERY-Ausdruck (query_expression) (SAP-Bibliothek - Grundwissen)

QUERY-Ausdruck (query_expression)

Um eine ungeordnete Ergebnistabelle in einer SELECT-Anweisung (select_statement) zu erzeugen, ist die Angabe eines QUERY-Ausdrucks (query_expression) erforderlich.

Syntax

<query_expression> ::= <query_term>
| <query_expression> UNION [ALL] <query_term>
| <query_expression> EXCEPT [ALL] <query_term>

<query_term> ::= <query_primary>
| <query_term> INTERSECT [ALL] <query_primary>

<query_primary> ::= <query_spec>
| (<query_expression>)

<query_spec> ::= SELECT [<distinct_spec>] [<top_spec>] <select_column>,... <table_expression>

<top_spec> ::= TOP <unsigned_integer>
| TOP <parameter_name>

Beispiele

SQL-Tutorial, Strukturlink Auswählen, Anordnen und Umbenennen von Spalten, Strukturlink Mengenoperationen: UNION, INTERSECT, EXCEPT

Erläuterung

Eine QUERY-Spezifikation spezifiziert eine Ergebnistabelle. Diese wird aus einer Zwischenergebnistabelle erzeugt. Die Zwischenergebnistabelle ist das Ergebnis des Tabellenausdrucks.

Besteht der QUERY-Ausdruck nur aus einer QUERY-Spezifikation query_spec, so ist das Ergebnis des QUERY-Ausdrucks das unveränderte Ergebnis der QUERY-Spezifikation.

Besteht der QUERY-Ausdruck aus mehr als einer QUERY-Spezifikation, muss die Anzahl der selektierten Spalten in allen QUERY-Spezifikationen des QUERY-Ausdrucks gleich sein. Die jeweils i-ten selektierten Spalten der QUERY-Spezfikationen müssen vergleichbar sein.

Spaltenart (select_column) |
Numerische Spalten | Sind untereinander vergleichbar. Sind alle i-ten selektierten Spalten numerische Spalten, so ist die i-te Spalte der Ergebnistabelle eine numerische Spalte.
Alphanumerische Spalten, Codeattribut BYTE | Sind untereinander vergleichbar.
Alphanumerische Spalten, Codeattribut ASCII, UNICODE | Sind untereinander vergleichbar. Sind auch vergleichbar mit Datums-, Zeit- und Zeitstempelwerten.
Alle i-ten Spalten sind Datumswerte | i-te Spalte der Ergebnistabelle ist Datumswert
Alle i-ten Spalten sind Zeitwerte | i-te Spalte der Ergebnistabelle ist Zeitwert
Alle i-ten Spalten sind Zeitstempelwerte | i-te Spalte der Ergebnistabelle ist Zeitstempelwert
Spalten vom Typ BOOLEAN | Sind untereinander vergleichbar.
Alle i-ten Spalten sind vom Typ BOOLEAN | i-te Spalte der Ergebnistabelle ist vom Typ BOOLEAN
Spalten von beliebigem anderen Datentyp (nicht weiter oben genannt) | i-te Spalte der Ergebnistabelle ist eine alphanumerische Spalte. Vergleichbare Spalten mit unterschiedlichen Code-Attributen werden konvertiert.

Sind Spalten vergleichbar, haben aber unterschiedliche Längen, so hat die korrespondierende Spalte der Ergebnistabelle die maximale Länge der zugrundeliegenden Spalten.

Namen der Spalten in der Ergebnistabelle

Die Namen der Spalten der Ergebnistabelle werden durch die Namen der selektierten Spalten der ersten QUERY-Spezifikation gebildet.

Sei T1 der linke Operand von UNION, EXCEPT oder INTERSECT (definiert in query_term). T2 sei der rechte Operand. R sei das Ergebnis der Operation T1 und T2.

● Eine Zeile ist ein Duplikat einer anderen Zeile, wenn beide in jeder Spalte identische Werte aufweisen. NULL-Wert e gelten dabei als identisch. Spezial-NULL-Wert e gelten als identisch.

● UNION: R enthält alle Zeilen aus T1 und T2.

● EXCEPT: R enthält alle Zeilen aus T1, die keine Duplikatzeile in T2 besitzen.

● INTERSECT: R enthält alle Zeilen aus T1, die eine Duplikatzeile in T2 besitzen. Eine Zeile aus T2 kann nur Duplikatzeile genau einer Zeile aus T1 sein. Mehrere Zeilen aus T1 können nicht dieselbe Duplikatzeile in T2 besitzen.

● Ist ALL nicht spezifiziert, so wird für die zu T1 und T2 gehörenden QUERY-Ausdrücke jeweils implizit DISTINCT angenommen. Aus R werden alle Duplikatzeilen entfernt.

Bei fehlender Klammerung wird INTERSECT vor UNION und EXCEPT ausgewertet. UNION und EXCEPT haben gleiche Priorität und werden bei fehlender Klammerung von links nach rechts ausgewertet.

TOP

Mit Hilfe des TOP-Syntaxelements können Sie angeben, dass nur die ersten n Zeilen des Ergebnisses ausgegeben werden sollen. Erlaubt sind ganze Zahlen zwischen 0 und 2147483647.

Wenn Sie in einer SELECT-Anweisung ein TOP-Syntaxelement und eine ORDER-Klausel verwenden, werden die ersten n Zeilen aller durch die ORDER-Klausel sortierten Zeilen ausgegeben. Wenn in der SELECT-Anweisung keine ORDER-Klausel verwendet wird, werden beliebige n Zeilen ausgegeben.

Wenn ein QUERY-Ausdruck query_expression aus mehreren QUERY-Spezifikationen query_spec besteht, darf das TOP-Syntaxelement nur in der ersten QUERY-Spezifikation enthalten sein.

Wenn Sie ein ROWNO-Prädikat oder eine LIMIT-Klausel verwenden, dürfen Sie das TOP-Syntaxelement nicht verwenden.


Tabellenausdruck (table_expression) (SAP-Bibliothek - Grundwissen)

Tabellenausdruck (table_expression)

Ein Tabellenausdruck (table_expression) spezifiziert eine einfache oder eine gruppierte Ergebnistabelle.

Syntax

<table_expression> ::= <from_clause> [<where_clause>] [<group_clause>] [<having_clause>]

<from_clause> ::= FROM <from_table_spec>,...
<where_clause> ::= WHERE <search_condition>
<group_clause> ::= GROUP BY <expression>,...
<having_clause> ::= HAVING <search_condition>

<from_table_spec> ::= <table_name> [AS] [<reference_name>]
| <result_table_name> [AS] [<reference_name>]
| (<query_expression>) [AS] [<reference_name>]
| <joined_table>

Beispiele

SQL-Tutorial, Strukturlink Auswählen und Anordnen von Zeilen, Strukturlink Bilden von Gruppen: GROUP BY, HAVING

Erläuterung

Ein Tabellenausdruck liefert eine Zwischenergebnistabelle. Wenn alle optionalen Klauseln fehlen, ist diese Zwischenergebnistabelle die von der FROM-Klausel gelieferte Ergebnistabelle. Sonst wird jede angegebene Klausel auf das Ergebnis der vorherigen Bedingung angewendet, und die Tabelle ist das Ergebnis der Anwendung der letzten spezifizierten Klausel. Die Zwischenergebnistabelle enthält alle Spalten aller in der FROM-Klausel aufgeführten Tabellen.

Die Reihenfolge der GROUP-Klausel und der HAVING-Klausel ist beliebig.

FROM-Klausel (from_clause)

Die FROM-Klausel from_clause spezifiziert eine Tabelle. Diese Tabelle kann aus mehreren Basis-, View-und Ergebnistabellen abgeleitet werden. Die Anzahl der zugrundeliegenden Tabellen einer FROM-Klausel ist die Summe der zugrundeliegenden Tabellen jeder FROM TABLE-Spezifikation from_table_spec. Die Anzahl der zugrundeliegenden Tabellen einer FROM-Klausel darf höchstens 64 sein.

Der Datenbankbenutzer muss das SELECT-Privileg für jede angegebene Tabelle oder für wenigstens eine Spalte der angegebenen Tabelle besitzen.

Das Ergebnis einer FROM-Klausel ist eine Tabelle, die aus den angegebenen Tabellen im Prinzip wie folgt erzeugt wird:

● Wenn die FROM-Klausel aus einer einzigen FROM TABLE-Spezifikation besteht, ist das Ergebnis die angegebene Tabelle.

● Wenn die FROM-Klausel mehr als eine FROM TABLE-Spezifikation enthält, wird eine Ergebnistabelle gebildet, die aus allen möglichen Kombinationen aller Zeilen der ersten Tabelle mit allen Zeilen der zweiten Tabelle usw. besteht. Im mathematischen Sinn wird also das kartesische Produkt sämtlicher Tabellen gebildet.

Diese Regel beschreibt die Wirkung der FROM-Klausel, nicht deren tatsächliche Implementierung.

WHERE-Klausel (where_clause)

Die WHERE-Klausel where_clause gibt die Bedingungen für das Bilden einer Ergebnistabelle an.

Die Suchbedingung search_condition wird auf jede Zeile der durch die FROM-Klausel gebildeten Zwischenergebnistabelle angewendet. Das Ergebnis der WHERE-Klausel ist eine Tabelle, die nur noch diejenigen Zeilen der Ergebnistabelle enthält, für die die Suchbedingung wahr ist.

Die Suchbedingung darf nur Spaltenspezifikationen enthalten, auf die der Benutzer das SELECT-Privileg hat.

Jede direkt in der Suchbedingung enthaltene Spaltenspezifikation muss eindeutig eine Spalte aus den in der FROM-Klausel des Tabellenausdrucks angegebenen Tabellen bezeichnen. Gegebenenfalls ist der Spaltenname durch den Tabellenbezeichner zu qualifizieren. Wenn in der FROM-Klausel für Tabellennamen Referenznamen reference_name definiert wurden, sind die Referenznamen als Tabellenbezeichner in der Suchbedingung zu verwenden.

Ein in der Suchbedingung enthaltener Ausdruck expression darf bis auf folgende Ausnahme keine Set-Funktion enthalten:

SELECT ... FROM uppertab,...
HAVING ... (SELECT ...
WHERE MIN(uppertab, ...)...
)

Die SELECT-Anweisung in der angegebenen Form ist erlaubt.

In der in einer HAVING-Klausel verwendeten Subquery ist es möglich, WHERE-Klauseln zu verwenden, die Set-Funktionen für die Spalten der in der SELECT … HAVING-Anweisung angegebenen Tabelle enthalten.

Im Fall einer Correlated Subquery kann eine Spaltenspezifikation eine Spalte einer Tabelle bezeichnen, die in einer FROM-Klausel eines anderen Tabellenausdrucks der QUERY-Spezifikation angegeben wurde.

Jede Subquery in der Suchbedingung wird in der Regel nur einmal ausgewertet. Im Fall einer Correlated Subquery wird die Subquery für jede Zeile der durch die FROM-Klausel gebildeten Ergebnistabelle ausgeführt.

GROUP-Klausel (group_clause)

Die GROUP-Klausel group_clause gibt eine Gruppierung einer Ergebnistabelle an.

Jeder in der GROUP-Klausel angegebene Spaltenname muss einen result_column_name in den selektiertem Spalten der QUERY-Spezifikation bezeichnen oder eindeutig eine Spalte aus den der QUERY-Spezifikation zugrundeliegenden Tabellen bezeichnen. Gegebenenfalls ist der Spaltenname mit dem Tabellenbezeichner zu qualifizieren.

Die GROUP-Klausel erlaubt die Anwendung der Set-Funktionen AVG, COUNT, MAX/MIN, STDDEV, SUM und VARIANCE nicht nur für ganze Ergebnistabellen, sondern für Gruppen von Zeilen innerhalb einer Ergebnistabelle. Dabei wird eine Gruppe durch die in GROUP BY angegebenen Gruppierspalten definiert. Alle Zeilen einer Gruppe haben in den Gruppierspalten dieselben Werte. Zeilen, die in einer Gruppierspalte den NULL-Wert enthalten, werden zu einer Gruppe zusammengefasst. Dasselbe gilt für den Spezial-NULL-Wert.

Die Verwendung von GROUP BY führt dazu, dass für jede Gruppe eine Zeile in der Ergebnistabelle gebildet wird. Die selektierten Spalten in der QUERY-Spezifikation dürfen deshalb nur die Gruppierspalten, Operationen auf den Gruppierspalten und Ausdrücke (expression) enthalten, in denen die Funktionen SUM, AVG, MAX/MIN, COUNT, STDDEV und VARIANCE verwendet werden.

Wenn es keine Zeile gibt, die die in der WHERE-Klausel angegebenen Bedingungen erfüllt, und eine GROUP-Klausel angegeben wurde, ist die Ergebnistabelle leer.

In einer GROUP-Klausel ist die Angabe skalarer Subqueries nicht erlaubt.

HAVING-Klausel (having_clause)

Die HAVING-Klausel having_clause spezifiziert die Eigenschaften einer Gruppe.

Jeder in der Suchbedingung search_condition auftretende Ausdruck, der nicht im Argument einer Set-Funktion auftritt, muss eine Gruppierspalte bezeichnen.

Wenn die HAVING-Klausel ohne GROUP-Klausel angewendet wird, wird die bisher gebildete Ergebnistablle als eine Gruppe betrachtet.

Die Suchbedingung wird auf jede Gruppe der Ergebnistabelle angewendet. Das Ergebnis der HAVING-Klausel ist eine Tabelle, die nur noch die Gruppen enthält, für die die Suchbedingung wahr ist.

FROM TABLE-Spezifikation (from_table_spec)

Jede FROM TABLE-Spezifikation from_table_spec in einer FROM-Klausel spezifiziert keinen, einen oder beliebig viele Tabellenbezeichner.

Referenzname (reference_name)

Wenn eine FROM TABLE-Spezifikation keinen Referenznamen enthält, ist der Tabellenname table_name bzw. der Ergebnistabellenname result_table_name der Tabellenbezeichner.

Wenn eine FROM TABLE-Spezifikation einen Referenznamen enthält, ist der Referenzname der Tabellenbezeichner.

Jeder Referenzname muss sich von jedem Bezeichner, der einen Tabellennamen angibt, unterscheiden. Wenn ein Ergebnistabellenname ein Tabellenbezeichner ist, darf es keinen Tabellenbezeichner table_name der Form [<schema_name>.]<result_table_name> geben. Jeder Tabellenbezeichner muss sich von jedem anderen Tabellenbezeichner unterscheiden.

Der Gültigkeitsbereich der Tabellenbezeichner ist die ganze QUERY-Spezifikation, innerhalb der die FROM TABLE-Spezifikation verwendet wird. Wenn innerhalb der QUERY-Spezifikation Spaltennamen qualifiziert werden sollen, muss das mit den Tabellenbezeichnern geschehen.

Referenznamen sind unbedingt nötig für die Formulierung von JOIN-Bedingungen einer Tabelle mit sich selbst. Zum Beispiel wird durch FROM HOTEL, HOTEL X ein Referenzname X für das zweite Auftreten der Tabelle HOTEL definiert. Darüber hinaus sind Referenznamen manchmal nötig für die Formulierung von Correlated Subqueries. Außerdem ist ein Referenzname notwendig, wenn nur durch die Angabe des Referenznamens eine Spalte des Ergebnisses des QUERY-Ausdrucks eindeutig bezeichnet werden kann.

Anzahl der zugrundeliegenden Tabellen

Wenn eine FROM TABLE-Spezifikation eine Basistabelle, eine Ergebnistabelle oder das Ergebnis eines QUERY-Ausdrucks bezeichnet, ist die Anzahl der zugrundeliegenden Tabellen dieser FROM TABLE-Spezifikation gleich 1.

Wenn eine FROM TABLE-Spezifikation eine komplexe View-Tabelle bezeichnet, ist die Anzahl der zugrundeliegenden Tabellen dieser FROM TABLE-Spezifikation gleich 1.

Wenn eine FROM TABLE-Spezifikation eine View-Tabelle bezeichnet, die keine komplexe View-Tabelle ist, ist die Anzahl der zugrundeliegenden Tabellen gleich der Anzahl der zugrundeliegenden Tabellen der FROM-Klausel der View-Tabelle.

Wenn eine FROM TABLE-Spezifikation eine Join-Tabelle joined_table bezeichnet, ist die Anzahl der zugrundeliegenden Tabellen dieser FROM TABLE-Spezifikation die Summe der zugrundeliegenden Tabellen der in ihr enthaltenen FROM TABLE-Spezifikationen.

QUERY-Ausdruck (query_expression)

Eine FROM TABLE-Spezifikation, in der ein QUERY-Ausdruck query_expression enthalten ist, spezifiziert nur dann einen Tabellenbezeichner, wenn ein Referenzname reference_name angegeben ist.

Enthält eine FROM TABLE-Spezifikation einen QUERY-Ausdruck, so wird eine Ergebnistabelle gebildet, die diesem QUERY-Ausdruck entspricht. Diese Ergebnistabelle erhält einen systeminternen Namen, der weder mit einer unbenannten noch einer benannten Ergebnistabelle kollidiert. Während der Bearbeitung der FROM-Bedingung wird das Ergebnis des QUERY-Ausdrucks wie eine benannte Ergebnistabelle verwendet und nach der Bearbeitung implizit gelöscht.

Ein Tabellenausdruck, in dem mindestens ein OUTER JOIN-Indikator oder OUTER JOIN TYPE (LEFT | RIGHT | FULL) angegeben wird, ist strengen Restriktionen unterworfen, wenn mehr als zwei Tabellen zugrundeliegen sollen. Daher ist die Verwendung eines QUERY-Ausdrucks häufig notwendig für die Formulierung einer QUERY-Spezifikation, der mindestens drei Tabellen zugrundeliegen sollen und in der mindestens ein OUTER JOIN-Indikator in einem JOIN-Prädikat verwendet wird.

JOINED TABLE (joined_table)

Eine FROM TABLE-Spezifikation, in der eine Join-Tabelle joined_table enthalten ist, spezifiziert so viele Tabellenbezeichner wie durch die in ihr enthaltenen FROM TABLE-Spezifikationen angegeben sind.

Siehe auch:

Restriktionen für SQL-Anweisungen


Subquery (subquery) (SAP-Bibliothek - Grundwissen)

Subquery (subquery)

Eine Subquery (subquery) spezifiziert eine Ergebnistabelle, die in bestimmten Prädikaten und beim Ändern von Spaltenwerten verwendet werden kann.

Eine skalare Subquery (scalar_subquery) ist eine spezielle Subquery.

Syntax

<subquery> ::= (<query_expression>)

<scalar_subquery> ::= <subquery>

Beispiele

SQL-Tutorial, Strukturlink Subquery: Innere Abfragen

Erläuterung

Subqueries können in einer SET UPDATE-Klausel einer UPDATE-Anweisung verwendet werden. In diesem Fall darf die Subquery nur eine Ergebnistabelle, die höchstens eine Zeile enthält, bilden.

Subqueries können in einer INSERT-Anweisung verwendet werden (INSERT-Anweisung).

In folgenden Prädikaten können Subqueries verwendet werden:

· Vergleichsprädikat

· EXISTS-Prädikat

· IN-Prädikat

· Mengenvergleichsprädikat

Correlated Subqueries

Gewisse Prädikate können Subqueries enthalten. Diese Subqueries können wiederum Subqueries enthalten, usw. Eine Subquery, die Subqueries enthält, ist von höherer Stufe als die in ihr enthaltenen Subqueries.

· In der Suchbedingung einer Subquery dürfen Spaltennamen auftreten, die zu Tabellen gehören, die in höheren Stufen in der FROM-Klausel enthalten sind. Eine Subquery dieser Art heißt Correlated Subquery.

· Tabellen, die in dieser Weise in Subqueries verwendet werden, werden als Correlated Tables bezeichnet. Mehr als 16 Correlated Tables sind in einer SQL-Anweisung nicht zulässig.

· Spalten, die derart in Subqueries verwendet werden, heißen Correlated Columns. Ihre Anzahl in einer SQL-Anweisung ist auf 64 beschränkt.

Wenn der qualifizierende Tabellen- oder Referenzname nicht eindeutig eine Tabelle höherer Stufe bezeichnet, wird unter diesen nicht eindeutigen Tabellen die Tabelle niedrigster Stufe genommen.

Wird der Spaltenname nicht durch den Tabellennamen oder den Referenznamen qualifiziert, wird in den Tabellen höherer Stufen gesucht. Der Spaltenname muss dann in allen Tabellen der FROM-Klausel, zu der die gefundene Tabelle gehört, eindeutig sein.

Wird eine Correlated Subquery verwendet, gehen die Werte einer oder mehrerer Spalten einer Zwischenergebniszeile einer höheren Stufe in die Suchbedingung einer Subquery niederer Stufe ein, wobei das Ergebnis der Subquery für die endgültige Qualifikation der Zwischenergebniszeile der höheren Stufe verwendet wird.

Skalare Subquery (scalar_subquery)

Skalare Subqueries entstehen durch Einschränkung der Ergebnismenge einer Ergebnistabelle auf höchstens einen Wert.

Skalare Subqueries können als Ausdruck (expression)verwendet werden.

Skalare Subqueries sind nicht in einer GROUP- oder ORDER-Klausel erlaubt.

Skalare Subquery in der Liste der einzufügenden Werte in einer INSERT-Anweisung:

INSERT INTO hotel.hotel VALUES((SELECT MAX(hno)+10 FROM hotel), 'Three Seasons', 90014, 'Los Angeles', '247 Broad Street')

Skalare Subquery in einer selektierten Spalte:

SELECT hno, price, (SELECT MIN(price) FROM hotel.room) FROM hotel.room


ORDER-Klausel (order_clause) (SAP-Bibliothek - Grundwissen)

ORDER-Klausel (order_clause)

Die ORDER-Klausel (order_clause) spezifiziert eine Sortierreihenfolge für eine Ergebnistabelle.

Syntax

<order_clause> ::= ORDER BY <sort_spec>,...

<sort_spec> ::= <unsigned_integer> [ASC | DESC]
| <expression> [ASC | DESC]

Beispiele

SQL-Tutorial, Strukturlink Auswählen und Anordnen von Zeilen

Erläuterung

Die in der ORDER-Klausel angegebenen Sortierspalten legen die Reihenfolge der Sortierkriterien fest.

Eine in der Sortierspezifikation sort_spec angegebene Zahl n identifiziert die n-te Spalte der Ergebnistabelle. n muss kleiner oder gleich der Anzahl der Spalten der Ergebnistabelle sein.

Besteht ein QUERY-Ausdruck aus mehr als einer QUERY-Spezifikation, so ist die Angabe einer Sortierspezifikation nur in einer der folgenden Formen zulässig:

<sort_spec> ::= <unsigned_integer> [ASC | DESC]
 | <column_spec> [ASC | DESC]

Als Spaltenspezifikation column_spec können Sie in diesem Fall entweder einen Referenznamen reference_name oder einen Spaltenamen column_name aus der Liste der selektierten Spalten der ersten QUERY-Spezifikation wählen.

In einer ORDER-Klausel sind skalare Subqueries nicht erlaubt.

ASC/DESC

Wenn Sie keine Angaben machen, wird ASC angenommen.

● ASC: Die Sortierung erfolgt nach aufsteigenden Werten.

● DESC: Die Sortierung erfolgt nach absteigenden Werten.

Weitere Informationen

Wenn eine QUERY-Spezifikation mit DISTINCT spezifiziert wurde, darf die Summe der internen Längen aller Sortierspalten 1016 Zeichen nicht überschreiten, andernfalls 1020 Zeichen.

Spaltennamen in den Sortierspezifikationen müssen Spalten der Tabellen der FROM-Klausel sein oder einen result_column_name in den selektierten Spalten der QUERY-Spezifikation bezeichnen.

Wenn DISTINCT oder eine Set-Funktion in einer selektierten Spalte verwendet wurde, muss die Sortierspezifikation eine Spalte der Ergebnistabelle bezeichnen.

Der Vergleich von Werten erfolgt nach den Regeln des Vergleichsprädikats. Bei Sortierungen sind NULL-Wert e größer als Nicht-NULL-Werte und Spezial-NULL-Wert e größer als Nicht-NULL-Werte aber kleiner als NULL-Werte.

Siehe auch:

Restriktionen für SQL-Anweisungen

SELECT-Anweisung (select_statement)


UPDATE-Klausel (update_clause) (SAP-Bibliothek - Grundwissen)

UPDATE-Klausel (update_clause)

Die UPDATE-Klausel (update_clause) gibt an, dass eine Ergebnistabelle änderbar werden soll. Für alle Zeilen, die diese Ergebnistabelle bilden, werden Schreibsperren gesetzt.

Syntax

<update_clause> ::= FOR UPDATE [OF <column_name>,...] [NOWAIT]

Erläuterung

Die angegebenen Spaltennamen müssen Spalten in den der QUERY-Spezifikation zu Grunde liegenden Tabellen bezeichnen. Es ist nicht erforderlich, dass sie in einer selektierten Spalte auftreten.

Die QUERY-Anweisung, die die UPDATE-Klausel enthält, muss eine änderbare Ergebnistabelle erzeugen.

Die UPDATE-Klausel ist Voraussetzung für die Verwendung der Ergebnistabelle mittels CURRENT OF <result_table_name> in der UPDATE-Anweisung, in der DELETE-Anweisung und in der LOCK-Anweisung. Für andere Formen der oben genannten SQL-Anweisungen sowie im interaktiven Betrieb hat die UPDATE-Klausel keine Bedeutung.

Es sind alle Spalten der zugrundeliegenden Basistabellen änderbar, sofern der Benutzer die entsprechenden Privilegien besitzt, unabhängig davon, ob sie als Spaltenname angegeben wurden oder nicht.

Es wird aus Performancegründen geraten, nur dann Spaltennamen anzugeben, wenn der Cursor in einer UPDATE-Anweisung verwendet werden soll.

Seien für eine Spalte x folgende Bedingungen erfüllt:

● x ist im Primärschlüssel oder einem Index enthalten

● x ist in der Suchbedingung der QUERY-Anweisung enthalten

● x ist in einer SET UPDATE-Klausel der UPDATE-Anweisung in der Art x = <expression> enthalten, wobei der Ausdruck (expression) die Spalte x enthält

Sind alle Bedingungen erfüllt, sollten Sie unbedingt die Spalte x als Spaltenname in der UPDATE-Klausel angeben.

Trifft mindestens eine der Bedingungen nicht zu, sollte auf die Angabe des Spaltennamens verzichtet werden.

NOWAIT

Wenn NOWAIT nicht angegeben wird, wird im Falle einer Sperrkollision auf die Freigabe des gesperrten Datenobjekts gewartet (jedoch maximal so lange wie der spezielle Datenbankparameter REQUEST_TIMEOUT angibt).

Wenn NOWAIT angegeben wird, wird nicht auf die Freigabe eines von einem anderen Benutzer gesperrten Datenobjekts gewartet, sondern im Fall einer Kollision eine Rückmeldung ausgegeben. Liegt keine Kollision vor, wird die gewünschte Sperre gesetzt.

Siehe auch:

SELECT-Anweisung (select_statement)

Konzepte des Datenbanksystems, Einschränkungen für UPDATE-Anweisungen


LOCK-Option (lock_option) (SAP-Bibliothek - Grundwissen)

LOCK-Option (lock_option)

Die LOCK-Option (lock_option) fordert eine Sperre für jede selektierte Zeile an.

Syntax

<lock_option> ::=
WITH LOCK [(IGNORE)|(NOWAIT)] [EXCLUSIVE|OPTIMISTIC] [ISOLATION LEVEL <unsigned_integer>]

unsigned_integer darf nur die Werte 0, 1, 2, 3, 10, 15, 20 oder 30 annehmen

Erläuterung

(IGNORE)

Wenn (IGNORE)nicht angegeben wird, wird im Falle einer Sperrkollision auf die Freigabe einer Zeilensperre gewartet (jedoch maximal so lange wie der spezielle Datenbankparameter REQUEST_TIMEOUT angibt).

Wenn (IGNORE)spezifiziert wird, wird nicht auf die Freigabe einer Zeilensperre durch eine andere Transaktion gewartet, sondern im Fall einer Sperrkollision diese Zeile ignoriert. Liegt keine Kollision vor, wird die gewünschte Sperre gesetzt. (IGNORE) kann nur im Isolation-Level 1 angegeben werden.

(NOWAIT)

Wenn (NOWAIT)nicht angegeben wird, wird im Falle einer Sperrkollision auf die Freigabe des gesperrten Datenobjekts gewartet (jedoch maximal so lange wie der Datenbankparameter REQUEST_TIMEOUT angibt).

Wenn (NOWAIT)angegeben wird, wird nicht auf die Freigabe eines von einem anderen Benutzer gesperrten Datenobjekts gewartet, sondern im Fall einer Kollision eine Rückmeldung ausgegeben. Liegt keine Kollision vor, wird die gewünschte Sperre gesetzt.

EXCLUSIVE

Es wird eine Schreibsperre definiert. Solange die gesperrte Zeile noch nicht geändert oder gelöscht wurde, kann die Schreibsperre mit der UNLOCK-Anweisung zurückgenommen werden.

OPTIMISTIC

Es wird eine optimistische Sperre auf Zeilen definiert. Diese ist nur in Zusammenhang mit den Isolation-Levels 0, 1, 10 und 15 sinnvoll.

Lesesperre

Wenn weder EXCLUSIVE noch OPTIMISTIC angegeben wird, dann wird eine Lesesperre auf die entsprechenden Zeilen gesetzt.

ISOLATION LEVEL

Das Setzen der Sperren geschieht unabhängig von der ISOLATION-Spezifikation isolation_spec der CONNECT-Anweisung. Das Isolation-Level der LOCK-Option kann einen höheren oder niedrigeren Wert als den der CONNECT-Anweisung haben.

Wenn durch die LOCK-Option ein Isolation-Level angegeben wird, gilt dieses nur für die Dauer der SQL-Anweisung, in der die LOCK-Option angegeben ist. Anschließend gilt wieder das Isolation-Level, das in der CONNECT-Anweisung angegeben wurde. Im Fall einer SELECT-Anweisung (select_statement), bei der die Ergebnistabelle nicht physisch erzeugt wird, gilt das spezifizierte Isolation-Level für diese SQL-Anweisung und alle FETCH-Anweisungen, die sich auf diese Ergebnistabelle beziehen. Für zwischenzeitlich durchgeführte, andere SQL-Anweisungen gilt das Isolation-Level, das in der CONNECT-Anweisung angegeben wurde.

Siehe auch:

LOCK-Anweisung (lock_statement)

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


FETCH-Anweisung (fetch_statement) (SAP-Bibliothek - Grundwissen)

FETCH-Anweisung (fetch_statement)

Die FETCH-Anweisung (fetch_statement) weist Parametern die Werte der aktuellen Zeile einer Ergebnistabelle zu.

Syntax

<fetch_statement> ::=
FETCH [FIRST | LAST | NEXT | PREV | <position> | SAME] [<result_table_name>] INTO <parameter_spec>,...

<position> ::=
POS (<unsigned_integer>)
| POS (<parameter_spec>)
| ABSOLUTE <integer>
| ABSOLUTE <parameter_spec>
| RELATIVE <integer>
| RELATIVE <parameter_spec>

Erläuterung

Wenn kein Name einer Ergebnistabelle angegeben wurde, bezieht sich die FETCH-Anweisung auf die zuletzt erzeugte unbenannte Ergebnistabelle.

Je nach Suchstrategie wird die Suche nach allen Zeilen der Ergebnistabelle bei der Ausführung der SELECT-Anweisung (select_statement) durchgeführt und die Ergebnistabelle physisch erzeugt oder jeweils die nächste Zeile der Ergebnistabelle bei der Ausführung einer FETCH-Anweisung gesucht und nicht physisch gespeichert. Dies ist beim Zeitverhalten von FETCH-Anweisungen zu berücksichtigen. Außerdem kann das je nach gewähltem Isolation-Level auch dazu führen, dass bei einem FETCH Sperrprobleme auftreten, z. B. Rückmeldung 500 – Lock request timeout.

Zeile nicht gefunden

Sei C der Standpunkt in der Ergebnistabelle. Es wird die Rückmeldung 100 – Row not found ausgegeben, und es erfolgt keine Zuweisung von Werten an die Parameter, wenn eine der folgenden Bedingungen erfüllt ist:

· Die Ergebnistabelle ist leer.

· C steht auf oder hinter der letzten Zeile der Ergebnistabelle, und es wird FETCH oder FETCH NEXT angegeben.

· C steht auf oder vor der ersten Zeile der Ergebnistabelle, und es wird FETCH PREV angegeben.

· Es wird FETCH mit einer Position angegeben, die nicht innerhalb der Ergebnistabelle liegt.

FIRST | LAST | NEXT | PREV

· FETCH FIRST oder FETCH LAST: Die Ergebnistabelle ist nicht leer. Der Standpunkt in der Ergebnistabelle C wird auf die erste bzw. letzte Zeile der Ergebnistabelle gesetzt, und die Werte dieser Zeile werden den Parametern zugewiesen.

· FETCH oder FETCH NEXT: C steht vor einer Zeile der Ergebnistabelle. C wird auf diese Zeile gesetzt, und die Werte dieser Zeile werden den Parametern zugewiesen.

· FETCH oder FETCH NEXT: C steht auf einer Zeile und diese ist nicht die letzte Zeile der Ergebnistabelle. C wird auf die unmittelbar folgende Zeile gesetzt, und die Werte in dieser Folgezeile werden den Parametern zugewiesen.

· FETCH PREV: C steht hinter einer Zeile der Ergebnistabelle. C wird auf diese Zeile gesetzt, und die Werte dieser Zeile werden den Parametern zugewiesen.

· FETCH PREV: C steht auf einer Zeile und diese ist nicht die erste Zeile der Ergebnistabelle. C wird auf die unmittelbar vorangehende Zeile gesetzt, und die Werte in dieser Vorgängerzeile werden den Parametern zugewiesen.

<position>

Es gibt eine Reihe von Möglichkeiten zur Positionsangabe unter Verwendung der Schlüsselworte POS, ABSOLUTE und RELATIVE.

POS

Unabhängig von der Angabe einer ORDER-Klausel existiert implizit eine Ordnung der Zeilen einer Ergebnistabelle, so dass eine interne Nummerierung möglich ist. Diese kann durch Angabe einer ROWNO-Spalte als selektierte Spalte sichtbar gemacht werden. Die Angabe einer Position bezieht sich auf diese interne Numerierung.

· POS (<unsigned_integer>): Wenn mittels POS eine Position angegeben wurde, die kleiner oder gleich der Anzahl der Zeilen der Ergebnistabelle ist, wird C auf die entsprechende Zeile gesetzt, und die Werte dieser Zeile werden den Parametern zugewiesen. Wenn eine Position angegeben wurde, die größer als die Anzahl der Zeilen der Ergebnistabelle ist, erfolgt die Rückmeldung 100 – Zeile nicht gefunden.

· POS (<parameter_spec>)Bei der Angabe einer Position mittels POS muss die Parameterspezifikation eine positive ganze Zahl bezeichnen.

ABSOLUTE

ABSOLUTE (<integer>)/ABSOLUTE (<parameter_spec>): Sei x der Wert der ganzen Zahl integer bzw. der Parameterspezifikation, die bei der Positionsangabe angegeben werden. Sei abs_x der Absolutbetrag von x.

· FETCH ABSOLUTE und x ist positiv: FETCH ABSOLUTE entspricht einem FETCH POS.

· FETCH ABSOLUTE und x=0: Es erfolgt die Rückmeldung 100 – Zeile nicht gefunden.

· FETCH ABSOLUTE und x ist negativ: Der Standpunkt in der Ergebnistabelle C wird hinter die letzte Zeile der Ergebnistabelle gesetzt und von dort abs_x-mal FETCH PREV durchgeführt. Die dabei zuletzt gefundene Zeile bildet das Ergebnis der SQL-Anweisung. Diese Beschreibung stellt nicht den Ablauf, sondern die Logik der Anweisung dar. Ist abs_x größer als die Anzahl der Zeilen der Ergebnistabelle, erfolgt die Rückmeldung 100 – Zeile nicht gefunden.

RELATIVE

RELATIVE (<integer>)/RELATIVE (<parameter_spec>): Sei x der Wert der ganzen Zahl integer bzw. der Parameterspezifikation, die bei der Positionsangabe angegeben werden. Sei abs_x der Absolutbetrag von x.

· FETCH RELATIVE und x ist positiv: Ausgehend vom aktuellen Standpunkt in der Ergebnistabelle C wird FETCH NEXT x-mal ausgeführt.

· FETCH RELATIVE und x=0: Entspricht einem FETCH SAME.

· FETCH RELATIVE und x ist negativ: Ausgehend von C wird FETCH PREV abs_x-mal ausgeführt. Diese Beschreibung stellt nicht den Ablauf, sondern die Logik der Anweisung dar. Die Rückmeldung 100 – Zeile nicht gefunden wird ausgegeben, wenn eine der im Abschnitt "Zeile nicht gefunden" angeführten Bedingungen erfüllt ist.

SAME

Die zuletzt ermittelte Zeile der Ergebnistabelle wird nochmals ausgegeben.

<parameter_spec>

Die in einer Positionsangabe position angegebene Parameterspezifikation muss eine ganze Zahl bezeichnen. Die übrigen durch die Parameterspezifikationen angegebenen Parameter sind Ausgabeparameter. Der durch die n-te Parameterspezifikation identifizierte Parameter korrespondiert mit dem n-ten Wert der aktuellen Zeile der Ergebnistabelle. Wenn diese Zeile mehr Spalten hat, als Parameter spezifiziert wurden, werden Werte der Spalten ignoriert, für die keine korrespondierenden Parameter existieren. Wenn die Zeile weniger Spalten hat, als Parameter spezifiziert wurden, werden den überzähligen Parametern keine Werte zugewiesen. Für die Zuweisung von NULL-Werten oder Spezial-NULL-Werten muss ein Indikatorname angegeben werden.

Zahlen werden umgewandelt und Zeichenketten abgeschnitten oder verlängert, wenn das zur Anpassung an die korrespondierenden Parameter erforderlich ist. Wenn während der Zuweisung eines Wertes an einen Parameter ein Fehler auftritt, wird diese Zuweisung nicht ausgeführt, und es erfolgen auch keine weiteren Zuweisungen an korrespondierende Parameter aufgrund dieser FETCH-Anweisung. Schon erfolgte Zuweisungen von Werten an Parameter bleiben erhalten.

Sei p ein Parameter und v der entsprechende Wert in der aktuellen Zeile der Ergebnistabelle.

· v ist eine Zahl: p muss ein numerischer Parameter sein, und v muss innerhalb des zulässigen Wertebereichs von p liegen.

· v ist eine Zeichenkette: p muss ein alphanumerischer Parameter sein.

Weitere Informationen

Wurde in der QUERY-Anweisung kein FOR REUSE angegeben, können nachfolgende INSERT-, UPDATE- oder DELETE-Anweisungen, die sich auf die zugrundeliegende Basistabelle beziehen und von dem Benutzer selber oder von anderen Benutzern abgesetzt werden, dazu führen, dass das mehrmalige Absetzen einer FETCH-Anweisung trotz gleicher Angabe der Position unterschiedliche Zeilen der Ergebnistabelle bezeichnet.

Änderungen durch andere Benutzer können durch eine LOCK-Anweisung für die gesamte Tabelle oder die Verwendung des Isolation-Levels 2, 3, 15, 20 oder 30 bei der CONNECT-Anweisung oder der LOCK-Option der QUERY-Anweisung verhindert werden.
Ist das nicht möglich oder ändert der Benutzer selber in dieser Tabelle, ist die Angabe von FOR REUSE notwendig. Zwischenzeitlich durchgeführte Änderungen sind dann nicht sichtbar.

Enthält die Ergebnistabelle LONG-Spalten und wurde die Ergebnistabelle physisch erzeugt, ist bei Verwendung der Isolation-Levels 0, 1 und 15 nicht sichergestellt, dass Konsistenz zwischen dem Inhalt der LONG-Spalten und dem der übrigen Spalten herrscht. Wurde die Ergebnistabelle nicht physisch erzeugt, ist die Konsistenz nur im Isolation-Level 0 nicht sichergestellt. Es wird deshalb empfohlen, durch Verwendung einer LOCK-Anweisung oder der Isolation-Levels 2, 3, 20 oder 30 die Konsistenz sicherzustellen.


CLOSE-Anweisung (close_statement) (SAP-Bibliothek - Grundwissen)

CLOSE-Anweisung (close_statement)

Die CLOSE-Anweisung (close_statement) löscht eine Ergebnistabelle.

Syntax

<close_statement> ::= CLOSE [<result_table_name>]

Erläuterung

· Name einer Ergebnistabelle angegeben: Diese Ergebnistabelle wird gelöscht. Ihr Name kann zur Benennung einer anderen Ergebnistabelle verwendet werden.

· Kein Name einer Ergebnistabelle angegeben: Eine eventuell existierende unbenannte Ergebnistabelle wird gelöscht.

Eine unbenannte Ergebnistabelle wird implizit durch die nächste SELECT-Anweisung gelöscht.

Ergebnistabellen werden implizit durch das Erzeugen einer Ergebnistabelle gleichen Namens gelöscht.

Alle Ergebnistabellen, die in der aktuellen Transaktion erzeugt wurden, werden implizit bei Beendigung der Transaktion mittels der ROLLBACK-Anweisung gelöscht.

Alle Ergebnistabellen werden implizit bei Beendigung der Sitzung mittels der RELEASE-Anweisung gelöscht.


SINGLE SELECT-Anweisung (single_select_statement) (SAP-Bibliothek - Grundwissen)

SINGLE SELECT-Anweisung (single_select_statement)

Eine SINGLE SELECT-Anweisung (single_select_statement) spezifiziert eine einzeilige Ergebnistabelle und weist deren Werte Parametern zu.

Syntax

<single_select_statement> ::=
SELECT [<distinct_spec>] <select_column>,...
INTO <parameter_spec>,... FROM <from_table_spec>,...
[<where_clause>] [<group_clause>] [<having_clause>] [<lock_option>]

Erläuterung

Die Anzahl der Zeilen in der Ergebnistabelle darf nicht größer als eins sein. Wenn die Ergebnistabelle leer ist oder mehr als eine Zeile enthält, werden entsprechende Fehler- oder Rückmeldungen ausgegeben und den in den Parameterspezifikationen angegebenen Parametern keine Werte zugewiesen. Bei einer leeren Ergebnistabelle erhalten Sie die Rückmeldung 100 – Zeile nicht gefunden.

Wenn die Ergebnistabelle genau eine Zeile enthält, werden deren Werte den korrespondierenden Parametern zugewiesen. Für die Wertzuweisungen an die Parameter gelten die Regeln der FETCH-Anweisung.

Die Reihenfolge der GROUP- und HAVING-Klausel ist beliebig.

Die Angabe einer LONG-Spalte in einer selektierten Spalte select_column ist nur in der obersten Folge von selektierten Spalten in einer SINGLE SELECT-Anweisung zulässig, wenn dort nicht die DISTINCT-Spezifikation distinct_spec DISTINCT verwendet wurde.


EXPLAIN-Anweisung (explain_statement) (SAP-Bibliothek - Grundwissen)

EXPLAIN-Anweisung (explain_statement)

Die EXPLAIN-Anweisung (explain_statement) beschreibt die bei einer QUERY-Anweisung oder einer SINGLE SELECT-Anweisung (Anweisungen zur Suche nach bestimmten Zeilen vorgegebener Tabellen) intern vom Datenbanksystem angewandte Suchstrategie. Insbesondere wird gezeigt, ob und in welcher Form Schlüsselspalten oder Indizes bei der Suche ausgenutzt werden.

Syntax

<explain_statement> ::=
EXPLAIN [(<result_table_name>)] <query_statement>
| EXPLAIN [(<result_table_name>)] <single_select_statement>

Beispiele

Konzepte des Datenbanksystems, EXPLAIN-Anweisung

Erläuterung

Durch die EXPLAIN-Anweisung kann geprüft werden, welche Auswirkungen das Erzeugen oder Löschen von Indizes auf die Wahl der Suchstrategie für die angegebene SQL-Anweisung hat. Außerdem wird es möglich abzuschätzen, welche Zeit das Datenbanksystem für die Abarbeitung der angegebenen SQL-Anweisung benötigen würde. Während der Ausführung der EXPLAIN-Anweisung wird die angegebene QUERY- bzw. SINGLE SELECT-Anweisung nicht ausgeführt.

Als Ergebnis der EXPLAIN-Anweisung wird eine Ergebnistabelle aufgebaut. Die Ergebnistabelle kann benannt werden. Wenn die optionale Benennung fehlt, erhält die Ergebnistabelle den Namen SHOW.

Struktur der EXPLAIN-Ergebnistabelle

SCHEMANAME | CHAR(64)
TABLENAME | CHAR(64)
COLUMN_OR_INDEX | CHAR(64)
STRATEGY | CHAR(40)
PAGECOUNT | CHAR(10)

Die Reihenfolge der SELECT-Abarbeitung ist durch die Reihenfolge der Zeilen der Ergebnistabelle beschrieben.

COLUMN_OR_INDEX

Die Spalte COLUMN_OR_INDEX zeigt, welche Schlüsselspalte oder invertierte Spalte oder welcher Index für die Strategie ausgenutzt wird.

STRATEGY

Die Spalte STRATEGY zeigt, welche Suchstrategie(n) benutzt wird/werden und ob eine Ergebnistabelle aufgebaut wird. Eine Ergebnistabelle wird physisch aufgebaut, wenn RESULT IS COPIED in der Spalte STRATEGY der letzten Ergebniszeile steht.

Siehe auch:

Konzepte des Datenbanksystems, Spalte STRATEGY, Liste aller Suchstrategien

PAGECOUNT

Die Spalte PAGECOUNT zeigt, welche Größen für die Tabellen bzw. bei bestimmten Strategien, welche Größen für die Indizes angenommen werden. Diese Größen beeinflussen die Wahl der Suchstrategie.

Die angenommenen Größen werden mit der UPDATE STATISTICS-Anweisung aktualisiert und können durch Selektieren der Systemtabelle OPTIMIZERINFORMATION abgefragt werden. Die aktuellen Größen von Tabellen oder Indizes können durch Selektieren der Systemtabellen TABLESTATISTICS und INDEXSTATISTICS ermittelt werden. Werden dabei größere Differenzen zwischen den in OPTIMIZERINFORMATION und den in TABLESTATISTICS enthaltenen Werten festgestellt, so sollte die UPDATE STATISTICS-Anweisung für diese Tabelle durchgeführt werden.

Wenn während einer Suche in einer Tabelle festgestellt wurde, dass die durch die letzte UPDATE STATISTICS-Anweisung ermittelten Werte erheblich zu klein sind, so wird eine Zeile in die Systemtabelle SYSUPDSTATWANTED eingetragen, die den Tabellennamen enthält. In anderen Fällen werden Zeilen in diese Systemtabelle eingetragen, die Spalten von Tabellen beschreiben. Für Tabellen bzw. Spalten von Tabellen, die in der Systemtabelle SYSUPDSTATWANTED beschrieben sind, sollte die UPDATE STATISTICS-Anweisung durchgeführt werden.

In der letzten Zeile steht in der Spalte PAGECOUNT der SELECT-Kostenschätzwert. Auf diesen SELECT-Kostenschätzwert beziehen sich die Angaben für COSTLIMIT und COSTWARNING in den SQL-Anweisungen zum Anlegen und Ändern von Benutzern (z.B. CREATE USER-Anweisung, ALTER USER-Anweisung).

Siehe auch:

Konzepte des Datenbanksystems, SQL-Optimierer

Datenbankverwaltung im CCMS, Strukturlink SQL-Optimierer im CCMS


Transaktionen (SAP-Bibliothek - Grundwissen)

Transaktionen

Durch Eröffnen einer Datenbanksitzung mit Hilfe einer CONNECT-Anweisung wird die erste Transaktion eröffnet. Die Eigenschaften einer Datenbanksitzung können Sie mit einer SET-Anweisung ändern. Abgeschlossen wird eine Transaktion durch die COMMIT-, die ROLLBACK- oder eine RELEASE-Anweisung. Durch die RELEASE-Anweisung wird außerdem die Datenbanksitzung geschlossen.

Subtransaktionen

Eine Transaktion kann in weitere atomare Einheiten unterteilt werden, nämlich in Subtransaktionen. Um Subtransaktionen zu öffnen oder zu schließen können Sie eines der beiden folgenden Verfahren verwenden:

● Verwenden der SUBTRANS-Anweisungen
Eine Subtransaktion wird durch die SUBTRANS BEGIN-Anweisung eingeleitet und mit der SUBTRANS END- oder SUBTRANS ROLLBACK-Anweisung abgeschlossen.

● Verwenden eines SQL-Savepoints
Eine Subtransaktion wird durch Setzen eines SQL-Savepoints mit Hilfe der SAVEPOINT-Anweisung eingeleitet. Ein SQL-Savepoint kann mit Hilfe der RELEASE SAVEPOINT-Anweisung oder der ROLLBACK TO-Anweisung deaktiviert werden.

Entscheiden Sie sich für eines der beiden Verfahren und behalten Sie dieses Verfahren bei.

Subtransaktionen haben keinen Einfluß auf Sperren. Diese werden erst durch COMMIT oder ROLLBACK freigegeben. COMMIT oder ROLLBACK schließen implizit alle Subtransaktionen.

Innere Transaktionen

Sie können mit Hilfe der INNER TRANSACTION-Anweisung eine Transaktion in eine Transaktion einbetten. Die eingebettete Transaktion kann beliebig beendet werden, die sie umgebende Transaktion wird unabhängig davon fortgesetzt.

Sperren

Da das Datenbanksystem konkurrierende Transaktionen auf den gleichen Datenbankobjekten zulässt, sind zur Isolation einzelner Transaktionen Sperren auf Zeilen, Tabellen und dem Datenbankkatalog nötig.

● Die Vergabe von impliziten Sperren kann durch die Einstellung des Isolation-Levels über die CONNECT-Anweisung beeinflusst werden.

● Sperren können explizit durch die LOCK-Anweisung oder durch die Angabe einer LOCK-Option vergeben werden.

● Schreibsperren für Zeilen, die noch nicht geändert wurden, und Lesesperren auf Zeilen können durch die UNLOCK-Anweisung vor Transaktionsende freigegeben werden.

Die einer Transaktion zugeordneten Sperren werden am Transaktionsende freigegeben, so dass die entsprechenden Datenbankobjekte wieder für andere Transaktionen zugänglich sind.

SQL-Anweisungen zur Verwaltung der Transaktionen

CONNECT-Anweisung | SET-Anweisung
COMMIT-Anweisung | ROLLBACK-Anweisung
SUBTRANS-Anweisung | SQL SAVEPOINT-Anweisungen
INNER TRANSACTION-Anweisung | LOCK-Anweisung
UNLOCK-Anweisung | RELEASE-Anweisung


CONNECT-Anweisung (connect_statement) (SAP-Bibliothek - Grundwissen)

CONNECT-Anweisung (connect_statement)

Eine CONNECT-Anweisung (connect_statement) eröffnet eine Datenbanksitzung und eine Transaktion eines Datenbankbenutzers.

Syntax

<connect_statement> ::=
CONNECT <parameter_name> IDENTIFIED BY <parameter_name> [<connect_option> ...]
| CONNECT <parameter_name> IDENTIFIED BY <password> [<connect_option> ...]
| CONNECT <user_name> IDENTIFIED BY <parameter_name> [<connect_option> ...]
| CONNECT <user_name> IDENTIFIED BY <password> [<connect_option> ...]

<connect_option> ::=
SQLMODE <INTERNAL_ANSI_DB2_ORACLE>
| ISOLATION LEVEL <unsigned_integer>
| TIMEOUT <unsigned_integer>

<INTERNAL_ANSI_DB2_ORACLE> ::= INTERNAL | ANSI | DB2 | ORACLE

Erläuterung

Bei zulässiger Kombination der Werte von Parametername/Benutzername und Parametername/Kennwort eröffnet der Benutzer eine Datenbanksitzung und erhält Zugang zur Datenbankinstanz. Er ist damit der aktuelle Benutzer in dieser Datenbanksitzung.

Es wird implizit eine Transaktion eröffnet.

Jede CONNECT-Option connect_option darf nur einmal angegeben werden.

SQLMODE

Mit der Angabe SQLMODE <INTERNAL|ANSI|DB2|ORACLE> kann der SQL-Modus ausgewählt werden. Vorschlagswert ist der SQL-Modus INTERNAL.

ISOLATION LEVEL

Für jede neu eröffnete Transaktion gilt der in der CONNECT-Anweisung angegebene Isolation-Level, der die Sperrbetriebsart festlegt.

Der Isolation-Level wird durch eine Integer-Zahl ohne Vorzeichen nach den Schlüsselwörtern ISOLATION LEVEL festgelegt. Folgende Werte sind zulässig: 0, 1, 2, 3, 10, 15, 20 und 30. Fehlt die Angabe eines Isolation-Levels, wird der Isolation-Level 1 angenommen.

Siehe auch:

Konzepte des Datenbanksystems, Isolation-Level

TIMEOUT

Der angegebene Timeout-Wert muss kleiner oder gleich dem Datenbankparameter SESSION_TIMEOUT sowie dem benutzerspezifischen Timeout-Wert des Benutzers oder der Benutzergruppe sein. Anderenfalls wird beim Anmelden ein Fehler geliefert.

Wenn kein Timeout-Wert angegeben wird, dann wird der kleinere der beiden anderen Werte als Timeout-Wert angenommen.

Wird für den TIMEOUT-Wert 0 angegeben, so erfolgt keine Überprüfung der Inaktivitätsdauer. Das kann dazu führen, dass Datenbankressourcen nicht wieder zur Verfügung stehen, obwohl die zugehörige Anwendung schon, ggf. durch einen Abbruch, ohne eine RELEASE-Anweisung beendet wurde.

Benutzer mit dem Attribut NOT EXCLUSIVE

Wenn ein Benutzer mit dem Attribut NOT EXCLUSIVE definiert wurde, kann er mehrere Sitzungen zur gleichen Zeit eröffnen. Wenn dies der Fall ist oder zwei Benutzer derselben Benutzergruppe zur gleichen Zeit eine Sitzung eröffnet haben, gelten die Sitzungen als verschieden, d. h. Sperranforderungen der beteiligten Sitzungen können kollidieren.

Siehe auch:

CREATE USER-Anweisung (create_user_statement)


SET-Anweisung (set_statement) (SAP-Bibliothek - Grundwissen)

SET-Anweisung (set_statement)

Die SET-Anweisung (set_statement) ändert die Eigenschaften einer Datenbanksitzung.

Syntax

<set_statement> ::= SET ROLE ALL [EXCEPT <role_name>,...]
| SET ROLE NONE
| SET ROLE <role_name>,... [IDENTIFIED BY <password>]
| SET ISOLATION LEVEL <unsigned_integer>
| SET CURRENT_SCHEMA = <schema_name>

Beispiele

SQL-Tutorial, Strukturlink Rollen

Erläuterung

SET ROLE

Mittels DEFAULT ROLE wird in der ALTER USER-Anweisung bzw. in der ALTER USERGROUP-Anweisung festgelegt, welche der an den aktuellen Benutzer bzw. die Benutzergruppe vergebenen Rollen in der Benutzersitzung bzw. Gruppenmitgliedssitzung aktiv sind. Wenn eine Rolle aktiv ist, besitzt der aktuelle Benutzer alle Privilegien, die durch die Rolle zusammengefasst sind.

Falls dem aktuellen Benutzer mit Hilfe der ALTER USER-Anweisung bzw. der ALTER USERGROUP-Anweisung eine Rolle zugeordnet ist, die automatisch beim Eröffnen der Sitzung aktiviert wird, so wird sie mit Ausführung der SET-Anweisung deaktiviert, falls sie nicht auch durch die SET ROLE-Angabe der SET-Anweisung identifiziert wird.

· ALL: Alle Rollen, die dem aktuellen Benutzer vergeben wurden, sind aktiv. Durch EXCEPT können einzelne namentlich aufgeführte Rollen hiervon ausgenommen werden.

· NONE: Es ist keine Rolle aktiv.

· Angabe von Rollennamen: Die hierdurch identifizierten Rollen müssen existieren und an den aktuellen Benutzer vergeben sein. Falls für die Rolle ein Kennwort existiert, muss es außer vom Eigentümer der Rolle in der SET-Anweisung angegeben werden.
Die durch den angegebenen Rollennamen identifizierte Rolle wird aktiviert.

SET ISOLATION LEVEL

Die Angabe eines Isolation-Levels verändert das Sperrverhalten für alle folgenden SQL-Anweisungen der aktuellen Datenbanksitzung. Der Isolation-Level wird durch eine Integer-Zahl ohne Vorzeichen nach den Schlüsselwörtern ISOLATION LEVEL festgelegt. Folgende Werte sind zulässig: 0, 1, 2, 3, 10, 15, 20 und 30.

Siehe auch:

Konzepte des Datenbanksystems, Isolation-Level

SET CURRENT_SCHEMA

Die Angabe eines Schemanamens definiert das angegebene Schema als aktuelles Schema der Datenbanksitzung. Dies bedeutet, dass bei nachfolgenden SQL-Anweisungen bei fehlender Angabe eines Schemanamens implizit immer dieses Schema angenommen wird. Der Schemaname muss ein existierendes Schema identifizieren.


COMMIT-Anweisung (commit_statement) (SAP-Bibliothek - Grundwissen)

COMMIT-Anweisung (commit_statement)

Eine COMMIT-Anweisung (commit_statement) beendet die aktuelle Transaktion und startet eine neue Transaktion.

Syntax

<commit_statement> ::= COMMIT [WORK]

Erläuterung

Die COMMIT-Anweisung dient zur Beendigung der aktuellen Transaktion (COMMIT).

Die COMMIT-Anweisung eröffnet implizit eine neue Transaktion. Alle innerhalb dieser neuen Transaktion gesetzten Sperren werden dieser Transaktion zugeordnet. Für das Setzen von Sperren in der neuen Transaktion gilt der in der CONNECT-Anweisung vereinbarte Isolation-Level.


ROLLBACK-Anweisung (rollback_statement) (SAP-Bibliothek - Grundwissen)

ROLLBACK-Anweisung (rollback_statement)

Die ROLLBACK-Anweisung (rollback_statement) bricht die aktuelle Transaktion ab (ROLLBACK) und startet eine neue Transaktion.

Syntax

<rollback_statement> ::= ROLLBACK [WORK]

Erläuterung

Die ROLLBACK-Anweisung eröffnet implizit eine neue Transaktion. Alle innerhalb dieser neuen Transaktion gesetzten Sperren werden dieser Transaktion zugeordnet. Für das Setzen von Sperren in der neuen Transaktion gilt das in der CONNECT-Anweisung vereinbarte Isolation-Level.


SUBTRANS-Anweisung (subtrans_statement) (SAP-Bibliothek - Grundwissen)

SUBTRANS-Anweisung (subtrans_statement)

Die SUBTRANS-Anweisung (subtrans_statement) unterteilt eine Transaktion in Teileinheiten, die Subtransaktionen genannt werden.

Syntax

<subtrans_statement> ::= SUBTRANS BEGIN | SUBTRANS END | SUBTRANS ROLLBACK

Erläuterung

SUBTRANS BEGIN

Eine Subtransaktion wird eröffnet, d. h. es wird vom Datenbanksystem der aktuelle Standpunkt innerhalb der Transaktion festgehalten. Anschließend kann eine beliebige Folge von SQL-Anweisungen folgen. Wenn diese Folge kein weiteres SUBTRANS BEGIN enthält, können durch SUBTRANS ROLLBACK alle Datenbankänderungen, die nach dem SUBTRANS BEGIN erfolgten, rückgängig gemacht werden.

Die Folge kann jedoch auch weitere SUBTRANS BEGIN-Anweisungen enthalten, die dann weitere Subtransaktionen eröffnen. Zu einem Zeitpunkt kann es daher mehrere offene, geschachtelte Subtransaktionen geben.

SUBTRANS END

Wird eine Subtransaktion mit SUBTRANS END abgeschlossen, bleiben die durchgeführten Änderungen erhalten. Die Subtransaktion wird geschlossen, d. h. das Datenbanksystem vergisst den bei SUBTRANS BEGIN bestimmten Standpunkt innerhalb der Transaktion. Voraussetzung dafür ist, dass eine offene Subtransaktion existiert. Wenn mehr als eine offene Subtransaktion existiert, wird die zuletzt geöffnete Subtransaktion geschlossen, d. h. sie gilt nicht mehr als offene Subtransaktion.

SUBTRANS ROLLBACK

Wenn eine Subtransaktion mit SUBTRANS ROLLBACK abgeschlossen wird, werden alle innerhalb einer Subtransaktion durchgeführten Datenbankänderungen rückgängig gemacht, und die Subtransaktion wird geschlossen. Auch alle Datenbankänderungen von innerhalb der Subtransaktion liegenden Subtransaktionen werden rückgängig gemacht, unabhängig davon, ob diese mit SUBTRANS END oder SUBTRANS ROLLBACK beendet wurden. Alle innerhalb der Subtransaktion erzeugten Ergebnistabellen werden geschlossen.

Voraussetzung dafür ist, dass eine offene Subtransaktion existiert. Wenn mehr als eine offene Subtransaktion existiert, wird die zuletzt geöffnete Subtransaktion zurückgesetzt. Die betroffene Subtransaktion gilt anschließend nicht mehr als offen.

Weitere Informationen

Die SUBTRANS-Anweisung hat keinen Einfluß auf Sperren, die der Transaktion zugeordnet sind. Insbesondere werden bei SUBTRANS END und SUBTRANS ROLLBACK keine Sperren freigegeben.

Die SUBTRANS-Anweisung eignet sich besonders dafür, die Auswirkungen von Unterprogrammen oder Datenbankprozeduren atomar zu machen, d. h. sie so zu gestalten, dass sie entweder alle ihre Aufgaben erfüllen oder andernfalls keine Wirkung haben. Dazu wird am Beginn ein SUBTRANS BEGIN abgesetzt. Wenn das Unterprogramm seine Aufgabe erfolgreich erfüllen konnte, wird am Ende SUBTRANS END benutzt, während im Fehlerfall durch SUBTRANS ROLLBACK alle vom Unterprogramm durchgeführten Änderungen rückgängig gemacht werden.

Durch die COMMIT-Anweisung und die ROLLBACK-Anweisung werden alle noch offenen Subtransaktionen implizit geschlossen.

Siehe auch:

Transaktionen

SQL SAVEPOINT-Anweisungen


INNER TRANSACTION-Anweisung (inner_transaction_statement) (SAP-Bibliothek - Grundwissen)

INNER TRANSACTION-Anweisung (inner_transaction_statement)

Die INNER TRANSACTION-Anweisung (inner_transaction_statement) ermöglicht die Einbettung einer Transaktion in eine Transaktion. Die eingebettete Transaktion kann beliebig beendet werden, die sie umgebende Transaktion wird unabhängig davon fortgesetzt.

Syntax

<inner_transaction_statement> ::= INNER TRANSACTION BEGIN
| INNER TRANSACTION COMMIT
| INNER TRANSACTION ROLLBACK

Erläuterung

INNER TRANSACTION BEGIN

Es wird eine Transaktion eröffnet ohne die bereits bestehende Transaktion zu beenden. Anschließend kann eine beliebige Folge von SQL-Anweisungen folgen. Die Folge der SQL-Anweisungen darf keine weiteren INNER TRANSACTION-Anweisungen enthalten. Zu einem Zeitpunkt kann es daher höchstens eine offene innere Transaktion geben.

Nach Beendigung der inneren Transaktion wird die bestehende Transaktion unverändert fortgesetzt.

INNER TRANSACTION COMMIT

Wird eine innere Transaktion mit COMMIT abgeschlossen, bleiben die durchgeführten Änderungen erhalten auch wenn die umgebende Transaktion rückgängig gemacht wird. Voraussetzung dafür ist, dass eine offene innere Transaktion existiert.

INNER TRANSACTION ROLLBACK

Wird eine innere Transaktion mit ROLLBACK abgeschlossen wird, werden alle seit dem INNER TRANSACTION BEGIN durchgeführten Datenbankänderungen rückgängig gemacht. Voraussetzung dafür ist, dass eine offene innere Transaktion existiert.

Weitere Informationen

Sperranforderungen der inneren Transaktion können mit gehaltenen Sperren der umgebenden Transaktion kollidieren.

Wenn die umgebende Transaktion beendet wird und noch eine offene innere Transaktion existiert, so wird diese zuvor genauso mit COMMIT oder ROLLBACK beendet wie die umgebende Transaktion.

Die INNER TRANSACTION-Anweisung eignet sich besonders für Anwendungen, die Informationen unabhängig vom Ausgang einer Transaktion in der Datenbank festschreiben wollen, z.B. bei Protokollierungen.

Siehe auch:

Transaktionen


SQL SAVEPOINT-Anweisungen (savepoint/rollback_to_/release_savepoint_statement)

Innerhalb einer Transaktion können Subtransaktionen definiert werden, die dazu dienen, eine Folge von Datenbankoperationen innerhalb einer Transaktion bezüglich der Änderungen in der Datenbank als Einheit erscheinen zu lassen.

Durch die SAVEPOINT-Anweisung wird ein SQL-Savepoint und damit der Beginn einer Subtransaktion innerhalb einer Transaktion definiert und diesem SQL-Savepoint ein Name zugeordnet. Durch eine spätere ROLLBACK TO-Anweisung mit Angabe des SQL-Savepoint-Namens können alle zwischenzeitlich durchgeführten Änderungen rückgängig gemacht werden, ohne solche Datenbankoperationen zu beeinflussen, die innerhalb der Transaktion vor dem Beginn dieser Subtransaktion durchgeführt wurden. Dabei wird auch der SQL-Savepoint gelöscht. Das Löschen von SQL-Savepoints kann ebenfalls mit Hilfe der RELEASE SAVEPOINT-Anweisung erfolgen.

Ein durch eine SAVEPOINT-Anweisung definierter SQL-Savepoint ist kein Savepoint.

Syntax

<savepoint_statement> ::= SAVEPOINT <sql_savepoint_name>

<rollback_to_statement> ::= ROLLBACK TO [SAVEPOINT] <sql_savepoint_name>

<release_savepoint_statement> ::= RELEASE SAVEPOINT <sql_savepoint_name>

<sql_savepoint_name> ::= <identifier>

Erläuterung

SAVEPOINT-Anweisung

Durch die SAVEPOINT-Anweisung wird eine Subtransaktion eröffnet, d.h. vom Datenbanksystem wird der aktuelle Standpunkt (SQL-Savepoint) innerhalb der Transaktion festgehalten und dem Namen sql_savepoint_name zugeordnet. Der SQL-Savepoint wird als aktiv gekennzeichnet. Anschließend kann eine beliebige Folge von SQL-Anweisungen innerhalb einer Transaktion folgen. Die Folge von SQL-Anweisungen kann weitere SAVEPOINT-Anweisungen enthalten, höchstens können jedoch 50 SQL-Savepoints in einer Transaktion aktiv sein.

Die Namen der SQL-Savepoints einer Transaktion müssen voneinander verschieden sein. Wenn ein SQL-Savepoint-Name innerhalb einer Transaktion zweimal vergeben wird, wird der SQL-Savepoint der Transaktion inaktiv, der durch die erste SAVEPOINT-Anweisung definiert wurde.

ROLLBACK TO-Anweisung

Durch eine ROLLBACK TO-Anweisung können alle Datenbankänderungen, die innerhalb der aktiven Transaktion nach der SAVEPOINT-Anweisung erfolgten, rückgängig gemacht werden.

Der in der ROLLBACK TO-Anweisung angegebene SQL-Savepoint muss ein innerhalb der Transaktion aktiver SQL-Savepoint sein. Alle SQL-Savepoints, die nach diesem SQL-Savepoint erzeugt wurden, werden inaktiv. Alle SQL-Savepoints, die vor diesem SQL-Savepoint erzeugt wurden, bleiben in ihrem Zustand.

Der angegebene SQL-Savepoint bleibt auch nach Ausführung der ROLLBACK TO-Anweisung aktiv, d.h. es ist möglich, die ROLLBACK TO-Anweisung innerhalb der gleichen Transaktion mehrfach unter Angabe des gleichen SQL-Savepoint-Namens auszuführen.

RELEASE SAVEPOINT-Anweisung

Durch eine RELEASE SAVEPOINT-Anweisung kann eine SQL-Savepoint deaktiviert werden. Der in der RELEASE SAVEPOINT-Anwesiung angegebene SQL-Savepoint muss ein innerhalb der Transaktion aktiver SQL-Savepoint sein.

Alle SQL-Savepoints, die nach diesem SQL-Savepoint aktiviert wurden, werden ebenfalls inaktiv. Alle SQL-Savepoints, die vor diesem SQL-Savepoint erzeugt wurden, bleiben in ihrem Zustand.

Weitere Informationen

Die SQL SAVEPOINT-Anweisungen haben keinen Einfluss auf Sperren, die der Transaktion zugeordnet sind. Insbesondere werden bei diesen SQL-Anweisungen keine Sperren freigegeben. Diese werden erst durch COMMIT oder ROLLBACK freigegeben

Subtransaktionen eignen sich besonders dafür, die Auswirkungen von Datenbankprozeduren atomar zu machen, d. h. sie so zu gestalten, dass sie entweder alle ihre Aufgaben erfüllen oder andernfalls keine Wirkung haben. Dazu wird am Beginn ein SAVEPOINT-Anweisung angegeben. Wenn das Unterprogramm seine Aufgabe nicht erfolgreich erfüllen konnte, können alle von der Datenbankprozedur durchgeführten Änderungen durch eine ROLLBACK TO-Anweisung rückgängig gemacht werden.

Durch die COMMIT-Anweisung und die ROLLBACK-Anweisung werden alle noch offenen Subtransaktionen implizit geschlossen.

Siehe auch:

Transaktionen

SUBTRANS-Anweisung (subtrans_statement)


LOCK-Anweisung (lock_statement) (SAP-Bibliothek - Grundwissen)

LOCK-Anweisung (lock_statement)

Die LOCK-Anweisung (lock_statement) ordnet Objekten der aktuellen Transaktion eine Sperre zu.

Syntax

<lock_statement> ::=
LOCK [(WAIT)|(NOWAIT)] <lock_spec> IN SHARE MODE
LOCK [(WAIT)|(NOWAIT)] <lock_spec> IN EXCLUSIVE MODE
LOCK [(WAIT)|(NOWAIT)] <lock_spec> IN SHARE MODE <lock_spec> IN EXCLUSIVE MODE
LOCK [(WAIT)|(NOWAIT)] <row_spec> ... OPTIMISTIC

<lock_spec> ::= TABLE <table_name>,...
| <row_spec> ...
| TABLE <table_name>,... <row_spec> ...

<row_spec> ::= ROW <table_name> KEY <key_spec>,...
| ROW <table_name> CURRENT OF <result_table_name>

Erläuterung

Die angegebene Tabelle darf keine temporäre Basistabelle, keine View-Tabelle und kein Synonym sein. Wenn der Tabellenname eine View-Tabelle identifiziert, werden Sperren auf die Basistabellen gesetzt, die der View-Tabelle zugrundeliegen.

(WAIT)/(NOWAIT)

● Wenn (NOWAIT) spezifiziert wird, wird nicht auf die Freigabe einer Sperre durch eine andere Transaktion gewartet, sondern im Fall einer Sperrkollision ein Fehler gemeldet. Wenn keine Kollision vorliegt, wird die gewünschte Sperre gesetzt.

● Wenn keine WAIT-Option oder (WAIT) angegeben ist, wird bei einer Sperrkollision auf die Freigabe von Sperren maximal so lange gewartet, wie der spezielle Datenbankparameter REQUEST_TIMEOUT angibt.

<lock_spec>

TABLE <table_name>,...

Bei Angabe von TABLE <table_name>,... wird eine Sperre für die genannte Tabelle angelegt.

Wenn der Tabellenname eine nicht änderbare View-Tabelle identifiziert, ist nur das Setzen einer Lesesperre für diese View-Tabelle möglich. Als Folge dieser SQL-Anweisung sind anschließend für alle Basistabellen die der View-Tabelle zugrundeliegen Lesesperren gesetzt.

<row_spec> ...

Bei Angabe von <row_spec> ... wird eine Sperre für die durch die Schlüsselwerte oder durch einen Standpunkt in einer Ergebnistabelle bezeichnete Zeile einer Tabelle angelegt.

Die Angabe einer row_spec erfordert, dass die angegebene Tabelle eine Schlüsselspalte besitzt, d. h. falls durch den Tabellennamen eine View-Tabelle angegeben ist, muss diese änderbar sein.

Bei Tabellen, die ohne Schlüsselspalten definiert wurden, kann die implizit existierende Schlüsselspalte SYSKEY CHAR(8) BYTE in einer Schlüsselspezifikation key_spec verwendet werden.

Wenn CURRENT OF <result_table_name> angegeben wird, muss die Ergebnistabelle mit FOR UPDATE spezifiziert worden sein.

SHARE

SHARE definiert eine Lesesperre für die aufgeführten Objekte. Zum Setzen von Lesesperren muss der aktuelle Benutzer das SELECT-Privileg besitzen.

EXCLUSIVE

EXCLUSIVE definiert eine Schreibsperre für die aufgeführten Objekte. Zum Setzen von Schreibsperren muss der aktuelle Benutzer das UPDATE-, DELETE- oder INSERT-Privileg besitzen.

OPTIMISTIC

OPTIMISTIC definiert eine optimistische Sperre auf Zeilen. Diese ist nur in Zusammenhang mit den Isolation-Leveln 0, 1, 10 und 15 sinnvoll.

Weitere Informationen

Deadlock

Wenn das Datenbanksystem einen durch Sperren verursachten Deadlock erkennt, dann wird die Transaktion durch ein implizites ROLLBACK WORK beendet.

Reproduzierbarkeit

Werden für das Lesen von Zeilen mittels einer SELECT-Anweisung reproduzierbare Ergebnisse gewünscht, müssen die gelesenen Objekte gesperrt werden, und die Sperren müssen bis zur Reproduktion gehalten werden. Für die Reproduzierbarkeit ist es im allgemeinen erforderlich, die betroffenen Tabellen explizit mittels eines oder mehrerer LOCK-Anweisungen oder implizit durch Verwendung des Isolation-Level 3 lesend zu sperren. Dadurch wird gewährleistet, dass kein anderer Benutzer die Tabelle ändern kann.

Siehe auch:

LOCK-Option (lock_option)

UNLOCK-Anweisung (unlock_statement)

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


UNLOCK-Anweisung (unlock_statement) (SAP-Bibliothek - Grundwissen)

UNLOCK-Anweisung (unlock_statement)

Die UNLOCK-Anweisung (unlock_statement) gibt Sperren auf Zeilen frei.

Syntax

<unlock_statement> ::= UNLOCK <row_spec>... IN SHARE MODE
| UNLOCK <row_spec> ... IN EXCLUSIVE MODE
| UNLOCK <row_spec> ... IN SHARE MODE <row_spec> ... IN EXCLUSIVE MODE
| UNLOCK <row_spec> ... OPTIMISTIC

<row_spec> ::= ROW <table_name> KEY <key_spec>,...
| ROW <table_name> CURRENT OF <result_table_name>

Erläuterung

Mit der UNLOCK-Anweisung können innerhalb einer Transaktion Lesesperren, optimistische Sperren und Schreibsperren für einzelne, noch nicht geänderte Zeilen von Tabellen freigegeben werden.

Wurde eine Zeile eingefügt, geändert oder gelöscht, kann ihre Schreibsperre nicht durch die UNLOCK-Anweisung freigegeben werden.

Die UNLOCK-Anweisung scheitert nicht, wenn die angegebene Sperre gar nicht existiert oder nicht freigegeben werden kann.

Bei Tabellen, die ohne Schlüsselspalten definiert wurden, kann die implizit existierende Schlüsselspalte SYSKEY CHAR(8) BYTE in einer Schlüsselspezifikation key_spec verwendet werden.

Wenn CURRENT OF <result_table_name> angegeben wird, muss die Ergebnistabelle mit FOR UPDATE spezifiziert worden sein.

Siehe auch:

LOCK-Anweisung (lock_statement)

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


RELEASE-Anweisung (release_statement) (SAP-Bibliothek - Grundwissen)

RELEASE-Anweisung (release_statement)

Die RELEASE-Anweisung (release_statement) beendet die Transaktion und die Datenbanksitzung eines Benutzers.

Syntax

<release_statement> ::= COMMIT [WORK] RELEASE | ROLLBACK [WORK] RELEASE

Erläuterung

Alle Ergebnistabellen und sowohl die in temporären Basistabellen gespeicherten Daten als auch die Metadaten dieser Tabellen werden implizit bei Beendigung der Sitzung mittels der RELEASE-Anweisung gelöscht.

COMMIT WORK RELEASE

Die aktuelle Transaktion wird abgeschlossen, jedoch keine neue Transaktion eröffnet. Die Sitzung des Benutzers wird beendet.

Wenn die aktuelle Transaktion vom Datenbanksystem implizit rückgängig gemacht werden muss, scheitert COMMIT WORK RELEASE und es wird eine neue Transaktion eröffnet. Die Sitzung des Benutzers wird in diesem Fall nicht beendet.

ROLLBACK WORK RELEASE

Die aktuelle Transaktion wird abgebrochen, jedoch keine neue Transaktion eröffnet. Alle innerhalb der Transaktion durchgeführten Datenbankänderungen werden rückgängig gemacht. Die Sitzung des Benutzers wird beendet. ROLLBACK WORK RELEASE hat die gleiche Wirkung wie die ROLLBACK-Anweisung gefolgt von COMMIT WORK RELEASE.


Statistiken (SAP-Bibliothek - Grundwissen)

Statistiken

Die UPDATE STATISTICS-Anweisung bestimmt den Platzbedarf von Tabellen und Indizes und die Werteverteilung von Spalten und legt diese Informationen in Statistik-Systemtabellen ab. der SQL-Optimierer verwendet diese Informationen, um die beste Strategie zur Ausführung einer SQL-Anweisung zu bestimmen.

Mit der MONITOR-Anweisung können Sie die beim Datenbankmonitoring geführten Zähler initialisieren.

SQL-Anweisungen zur Verwaltung der Statistiken

UPDATE STATISTICS-Anweisung

MONITOR-Anweisung

Siehe auch:

Definitionen der Systemtabellen


UPDATE STATISTICS-Anweisung (update_statistics_statement) (SAP-Bibliothek - Grundwissen)

UPDATE STATISTICS-Anweisung (update_statistics_statement)

Die UPDATE STATISTICS-Anweisung (update_statistics_statement) bestimmt den Platzbedarf von Tabellen und Indizes und die Werteverteilung von Spalten und legt die Informationen im Datenbankkatalog ab.

Syntax

<update_statistics_statement> ::=
UPDATE STAT[ISTICS] COLUMN <table_name>.<column_name> [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] COLUMN (<column_name>,...) FOR <table_name> [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] COLUMN (*) FOR <table_name> [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] <table_name> [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] [<schema_name>.][<identifier>]* [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] AS PER SYSTEM TABLE

Erläuterung

Die Ausführung der UPDATE STATISTICS-Anweisung bewirkt, dass Informationen über die Tabelle wie die Anzahl der Zeilen, Anzahl belegter Seiten, Größe von Indizes, Werteverteilung innerhalb von Spalten oder Indizes usw. im Datenbankkatalog abgelegt werden. Diese Werte werden vom SQL-Optimierer zur Bestimmung der besten Suchstrategie zur Ausführung von komplexen SQL-Anweisungen benutzt.

Bei der Bestimmung von Werteverteilungen werden maximal 1022 Bytes eines Spaltenwertes betrachtet, unabhängig davon wie viel Bytes der Spaltenwert gemäß Definition tatsächlich belegen kann. Dadurch können die ermittelten Werteverteilungen von den tatsächlichen Werteverteilungen abweichen, wenn es Spaltenwerte gibt, die in den ersten 1022 Bytes übereinstimmen und sich erst danach unterscheiden.

Die UPDATE STATISTICS-Anweisung führt implizit pro Basistabelle eine COMMIT-Anweisung aus, d. h. die Transaktion, in der die UPDATE STATISTICS-Anweisung ausgeführt wird, ist anschließend beendet.

Die im Datenbankkatalog abgelegten Statistikwerte können durch Selektieren der Systemtabelle OPTIMIZERINFORMATION abgefragt werden. Jede Zeile der Tabelle beschreibt Statistikwerte über Indizes, Spalten oder Größe einer Tabelle.

<table_name>

Wenn ein Tabellenname angegeben ist, dann muss die Tabelle eine Basistabelle, darf jedoch keine temporäre Tabelle sein. Der aktuelle Datenbankbenutzer muss ein Privileg für sie besitzen.

<column_name>

Wenn ein Spaltenname angegeben ist, dann muss die Spalte der angegebenen Tabelle existieren.

Wenn * angegeben ist, werden alle Spalten der Tabelle angenommen.

<identifier>*

Wenn <identifier>* angegeben ist, dann hat das den gleichen Effekt wie die Angabe der UPDATE STATISTICS-Anweisung für alle Basistabellen, für die der aktuelle Datenbankbenutzer ein Privileg besitzt und deren Tabellenname mit dem Bezeichner identifier beginnt.

UPDATE STATISTICS *

Der Datenbanksystemadministrator (SYSDBA-Benutzer) kann durch UPDATE STATISTICS * erreichen, dass die UPDATE STATISTICS-Anweisung für alle Basistabellen ausgeführt wird, auch wenn dem Datenbanksystemadministrator kein Privileg für die Tabelle vergeben wurde.

ESTIMATE

● Bei Angabe von ESTIMATE und einer sample_definition schätzt das Datenbanksystem die Statistikwerte durch Auswahl von Stichproben aus dem Datenbestand. Die Anzahl der Stichproben kann in Anzahl Zeilen oder in Prozent erfolgen. Durch die Angabe von ESTIMATE kann die Laufzeit der UPDATE STATISTICS-Anweisung stark reduziert werden. Die Genauigkeit der ermittelten Statistikwerte ist in den meisten Fällen dennoch ausreichend.

● Bei Angabe von ESTIMATE ohne eine sample_definition schätzt das Datenbanksystem die Statistikwerte durch Auswahl von Stichproben aus dem Datenbestand. Die Anzahl der Stichproben wurde bei der CREATE TABLE-Anweisung oder einer ALTER TABLE-Anweisung durch eine sample_definition für die angegebene Tabelle festgelegt. Durch die Angabe von ESTIMATE kann die Laufzeit der UPDATE STATISTICS-Anweisung stark reduziert werden. Die Genauigkeit der ermittelten Statistikwerte ist in den meisten Fällen dennoch ausreichend.

● Wenn ESTIMATE nicht angegeben ist, bestimmt das Datenbanksystem exakte Statistikwerte, indem der gesamte Datenbestand der Tabelle betrachtet wird. Bei großen Tabellen kann die Laufzeit hierfür beträchtlich sein.

UPDATE STATISTICS AS PER SYSTEM TABLE

Der Datenbankkern trägt in die Systemtabelle SYSUPDSTATWANTED (befindet sich im Schema des Datenbanksystemadministrators) die Tabellen(spalten) ein, für die ein UPDATE STATISTICS-Lauf zweckmäßig erscheint.

Wenn Sie die SQL-Anweisung UPDATE STATISTICS AS PER SYSTEM TABLE verwenden, wird für alle in der Tabelle SYSUPDSTATWANTED enthaltenen Tabellen(spalten) ein UPDATE STATISTICS-Lauf ausgelöst. Wenn der Datenbankparameter UPDATESTAT_PARALLEL_SERVERS auf einen Wert >= 0 gesetzt ist, wird versucht, die Statistikläufe parallel durchzuführen. Anschließend werden die Einträge in der Tabelle SYSUPDSTATWANTED gelöscht.

Die Systemtabelle SYSUPDSTATWANTED kann ebenfalls durch Datenbankadministratoren geändert werden. Allerdings kann ein Datenbankadministrator nur solche Einträge einfügen, die sich auf Tabellen beziehen, dessen Eigentümer dieser Datenbankadministrator ist.

Stichprobengröße 0

Sie können einzelne Tabellen von einem UPDATE STATISTICS-Lauf ausschließen, indem Sie mittels einer ALTER TABLE-Anweisung für diese Tabellen die Stichprobengröße auf 0 setzen (SAMPLE-Definition).

Siehe auch:

EXPLAIN-Anweisung (explain_statement)

Konzepte des Datenbanksystems, SQL-Optimierer, Statistiken des SQL-Optimierers, EXPLAIN-Anweisung

Datenbankverwaltung im CCMS, Strukturlink SQL-Optimierer im CCMS, Strukturlink Aktualisierung der SQL-Optimiererstatistiken einplanen


MONITOR-Anweisung (monitor_statement) (SAP-Bibliothek - Grundwissen)

MONITOR-Anweisung (monitor_statement)

Mit der MONITOR-Anweisung (monitor_statement) können Sie die beim Datenbankmonitoring geführten Zähler mit 0 initialisieren.

Syntax

<monitor_statement> ::= MONITOR INIT

Erläuterung

Das Datenbanksystem führt immer Ereigniszähler. Diese werden beim Start des Datenbanksystems mit 0 initialisiert. Durch die MONITOR-Anweisung werden sie wieder auf 0 gesetzt.

Die vom Datenbanksystem geführten Ereigniszähler können durch Selektieren von Monitor-Systemtabellen abgefragt werden.

Eine Definition der Monitor-Systemtabellen finden Sie im Abschnitt Definition der Systemtabellen, Monitor-Systemtabellen.


SQL-Anweisungen: Überblick (SAP-Bibliothek - Grundwissen)

SQL-Anweisungen: Überblick

Alle SQL-Anweisungen (sql_statement) können in Programmiersprachen eingebettet und außer der NEXT STAMP-Anweisung interaktiv angegeben werden.

Für jede SQL-Anweisung können Kommentare angegeben werden.

Für viele SQL-Anweisungen werden Beispiel-Anweisungen anhand der Strukturlink Demo-Daten für das SQL-Tutorial formuliert.

SQL-Anweisungen zur Datendefinition

CREATE TABLE-Anweisung | DROP TABLE-Anweisung | ALTER TABLE-Anweisung RENAME TABLE-Anweisung RENAME COLUMN-Anweisung EXISTS TABLE-Anweisung
CREATE SCHEMA-Anweisung | RENAME SCHEMA-Anweisung | DROP SCHEMA-Anweisung
CREATE DOMAIN-Anweisung | DROP DOMAIN-Anweisung |
CREATE SEQUENCE-Anweisung | DROP SEQUENCE-Anweisung |
CREATE SYNONYM-Anweisung | DROP SYNONYM-Anweisung | RENAME SYNONYM-Anweisung
CREATE VIEW-Anweisung | DROP VIEW-Anweisung | RENAME VIEW-Anweisung
CREATE INDEX-Anweisung | DROP INDEX-Anweisung | ALTER INDEX-Anweisung RENAME INDEX-Anweisung
CREATE DBPROC-Anweisung | DROP DBPROC-Anweisung |
CREATE SYSTEM TRIGGER-Anweisung | DROP SYSTEM TRIGGER-Anweisung |
CREATE FUNCTION-Anweisung | DROP FUNCTION-Anweisung |
CREATE TRIGGER-Anweisung | DROP TRIGGER-Anweisung |
COMMENT ON-Anweisung |  |

SQL-Anweisungen zur Autorisierung

CREATE USER-Anweisung | DROP USER-Anweisung | ALTER USER-Anweisung RENAME USER-Anweisung GRANT USER-Anweisung
CREATE USERGROUP-Anweisung | DROP USERGROUP-Anweisung | ALTER USERGROUP-Anweisung RENAME USERGROUP-Anweisung GRANT USERGROUP-Anweisung
CREATE ROLE-Anweisung | DROP ROLE-Anweisung |
ALTER PASSWORD-Anweisung | GRANT-Anweisung | REVOKE-Anweisung

SQL-Anweisungen zur Datenmanipulation

INSERT-Anweisung | UPDATE-Anweisung | DELETE-Anweisung
NEXT STAMP-Anweisung | CALL-Anweisung |

SQL-Anweisungen zur Datenanfrage

QUERY-Anweisung | SINGLE SELECT-Anweisung | EXPLAIN-Anweisung
OPEN CURSOR-Anweisung | FETCH-Anweisung | CLOSE-Anweisung

SQL-Anweisungen zur Verwaltung der Transaktionen

CONNECT-Anweisung | SET-Anweisung | COMMIT-Anweisung
ROLLBACK-Anweisung | INNER TRANSACTION-Anweisung | SUBTRANS-Anweisung
SAVEPOINT-Anweisung | ROLLBACK TO-Anweisung | RELEASE SAVEPOINT-Anweisung
LOCK-Anweisung | UNLOCK-Anweisung | RELEASE-Anweisung

SQL-Anweisungen zur Verwaltung der Statistiken

UPDATE STATISTICS-Anweisung

MONITOR-Anweisung


Kommentar (sql_comment) (SAP-Bibliothek - Grundwissen)

Kommentar (sql_comment)

Jede SQL-Anweisung kann mit einem Kommentar (sql_comment) versehen werden.

Syntax

<sql_comment> ::= /*<sql_comment_text>*/ | --<sql_comment_text>

<sql_comment_text> ::= <! <Kommentartext> !>

Erläuterung

Sie können einen beliebigen Kommentartext eingeben.

Bei Verwenden der Syntaxregel --<sql_comment_text> in einer Zeile werden alle nach -- eingegebenen Zeichen dieser Zeile als Kommentar gewertet.

CREATE TABLE person (knr FIXED(4), vorname CHAR(7), nachname CHAR(7), konto FIXED(7,2)) /*Anlegen der Tabelle person*/


Häufig verwendete Syntaxelemente: Überblick (SAP-Bibliothek - Grundwissen)

Häufig verwendete Syntaxelemente: Überblick

Syntax | Erläuterung
arithmetic_function | Arithmetische Funktion (arithmetic_function)
between_predicate | BETWEEN-Prädikat (between_predicate)
bool_predicate | Boolesches Prädikat (bool_predicate)
cascade_option | CASCADE-Option (cascade_option)
character | Zeichen (character)
column_spec | Spaltenspezifikation (column_spec)
comparison_predicate | Vergleichsprädikat (comparison_predicate)
conversion_function | Konversionsfunktion (conversion_function)
data_type | Datentyp (data_type)
date_function | Datumsfunktion (date_function)
dbfunction_call | Datenbankfunktionsaufruf (dbfunction_call)
default_predicate | DEFAULT-Prädikat (default_predicate)
default_spec | DEFAULT-Spezifikation (default_spec)
delete_rule | DELETE-Regel (delete_rule)
distinct_spec | DISTINCT-Spezifikation (distinct_spec)
duplicates_clause | DUPLICATES-Klausel (duplicates_clause)
exists_predicate | EXISTS-Prädikat (exists_predicate)
expression | Ausdruck (expression)
extended_value_spec | Spezifikation von Werten (extended_value_spec)
extraction_function | Extraktion (extraction_function)
fixed_point_literal | Festkommazahl (fixed_point_literal)
floating_point_literal | Gleitkommazahl (floating_point_literal)
function_spec | Funktion (function_spec)
identifier | Bezeichner (identifier)
in_predicate | IN-Prädikat (in_predicate)
integer | Ganze Zahl (integer)
joined_table | Join-Tabelle (joined_table)
join_predicate | JOIN-Prädikat (join_predicate)
key_word | Schlüsselwort (key_word)
key_spec | Schlüsselspezifikation (key_spec)
like_predicate | LIKE-Prädikat (like_predicate)
literal | Literal (literal)
null_predicate | NULL-Prädikat (null_predicate)
parameter_spec | Parameterspezifikation (parameter_spec)
predicate | Prädikat (predicate)
quantified_predicate | Mengenvergleichsprädikat (quantified_predicate)
rowno_predicate | ROWNO-Prädikat (rowno_predicate)
sample_definition | SAMPLE-Definition (sample_definition)
search_condition | Suchbedingung (search_condition)
select_column | Selektierte Spalte (select_column)
set_function_spec | Set-Funktion (set_function_spec)
sounds_predicate | SOUNDS-Prädikat (sounds_predicate)
special_function | Spezialfunktion (special_function)
string_function | Stringfunktion (string_function)
time_function | Zeitfunktion (time_function)
token | Zeichensatz (token)
trigonometric_function | Trigonometrische Funktion (trigonometric_function)
unsigned_integer | Ganze Zahl ohne Vorzeichen (unsigned_integer)

Siehe auch:

Syntaxverzeichnis


CASCADE-Option (cascade_option) (SAP-Bibliothek - Grundwissen)

CASCADE-Option (cascade_option)

Eine CASCADE-Option (cascade_option) bestimmt das Löschverhalten für Objekte (z.B. Tabellen, Benutzer), d.h. es wird bestimmt, ob gewisse Abhängigkeiten beim Löschen von Objekten berücksichtigt werden sollen oder nicht.

Syntax

<cascade_option> ::= CASCADE | RESTRICT

Erläuterung

CASCADE: Abhängigkeiten sollen nicht berücksichtigt werden

RESTRICT: Abhängigkeiten sollen berücksichtigt werden

SQL-Anweisungen

DROP-Definition

DROP SCHEMA-Anweisung

DROP TABLE-Anweisung

DROP USER-Anweisung

DROP USERGROUP-Anweisung

DROP VIEW-Anweisung

REVOKE-Anweisung

Referentielle CONSTRAINT-Definition


Zeichen (character) (SAP-Bibliothek - Grundwissen)

Zeichen (character)

Zeichen (character) sind die Elemente von Zeichenketten und Schlüsselwörtern.

Syntax

<character> ::= <digit>
| <letter>
| <extended_letter>
| <hex_digit>
| <language_specific_character>
| <special_character>

Ziffern

<digit> ::= 0 | 1 | 2 | | 3 | 4 | 5 | 6 | 7 | 8 | 9

Buchstaben

<letter> ::= A | B | C | D | E | F | G | H | I | J | K | L | M
| N | O | P | Q | R | S | T | U | V | W | X | Y | Z
| a | b | c | d | e | f | g | h | i | j | k | l | m
| n | o | p | q | r | s | t | u | v | w | x | y | z

Weitere Buchstaben

<extended_letter> ::= # | @ | $

Hexadezimale Zeichen

<hex_digit> ::= 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
| A | B | C | D | E | F
| a | b | c | d | e | f

Sprachenspezfische Zeichen

Ein sprachenspezifisches Zeichen language_specific_character ist jeder Buchstabe, der in einer nord-, mittel- oder südeuropäischen Sprache vorkommt und nicht in der Auflistung der Buchstaben enthalten ist.

Deutsche Umlaute: ä, ö, ü

Französische Buchstaben mit accent grave: à

Wenn eine UNICODE-fähige Datenbankinstanz installiert wurde, ist ein sprachenspezifisches Zeichen jedes Zeichen, das nicht in der Liste der Zeichen im ASCII-Code von 0 bis 127 enthalten ist.

Sonderzeichen

Ein Sonderzeichen special_character ist jedes Zeichen, dass nicht in der folgenden Liste zu finden ist:

● Ziffern

● Buchstaben

● Weitere Buchstaben

● Hexadezimale Zeichen

● Sprachenspezifische Zeichen

● Zeichen für Zeilenende in einer Datei

Siehe auch:

Zeichensatz (token)

Literal (literal)


Spaltenspezifikation (column_spec) (SAP-Bibliothek - Grundwissen)

Spaltenspezifikation (column_spec)

Eine Spaltenspezifikation (column_spec) spezifiziert die Spalte einer Tabelle.

Syntax

<column_spec> ::= <column_name>
| <table_name>.<column_name>
| <reference_name>.<column_name>
| <result_table_name>.<column_name>

Erläuterung

Bei allen Namen, die sich aus mehreren, durch "." getrennten Bezeichnern zusammensetzen, können jeweils vor und hinter dem "." beliebig viele Leerzeichen angegeben werden.

Eine Spaltenspezifikation wird in folgenden SQL-Syntaxelementen verwendet:

Ausdruck (expression)

Boolesches Prädikat (bool_predicate)

DEFAULT-Prädikat (default_predicate)


DEFAULT-Spezifikation (default_spec) (SAP-Bibliothek - Grundwissen)

DEFAULT-Spezifikation (default_spec)

Eine DEFAULT-Spezifikation (default_spec) wird durch die Angabe des Schlüsselwortes DEFAULT und eines Vorschlagswerts (DEFAULT-Wert) gebildet. Die maximale Länge eines Vorschlagswerts beträgt 254 Zeichen.

Syntax

<default_spec> ::= DEFAULT <literal>
| DEFAULT NULL
| DEFAULT USER
| DEFAULT USERGROUP
| DEFAULT SYSDBA
| DEFAULT DATE
| DEFAULT TIME
| DEFAULT TIMESTAMP
| DEFAULT UTCDATE
| DEFAULT UTCDIFF
| DEFAULT TIMEZONE
| DEFAULT TRUE
| DEFAULT FALSE
| DEFAULT TRANSACTION
| DEFAULT STAMP
| DEFAULT SERIAL[(<unsigned_integer>)]

Beispiele

SQL-Tutorial, Strukturlink Nummerngenerator für eine einzelne Spalte einer Tabelle

Erläuterung

Wenn für eine Spalte eine DEFAULT-Spezifikation angegeben wurde, muss der Vorschlagswert (<literal>, NULL, USER,...) ein Wert sein, der in die Spalte eingefügt werden kann.

DEFAULT-Spezifikation

Erläuterung

DEFAULT <literal>

Das Literal muss mit dem Datentyp der Spalte vergleichbar sein.

DEFAULT USER

Liefert den Benutzernamen des aktuellen Benutzers und kann nur für Spalten vom Datentyp [VAR]CHAR(n) bzw. CHAR(n) (n>=32) angegeben werden.

DEFAULT USERGROUP

Liefert für Mitglieder einer Benutzergruppe den Benutzergruppennamen bzw. den Benutzernamen für Benutzer, die keiner Benutzergruppe angehören. Diese DEFAULT-Spezifikation kann nur für Spalten vom Datentyp [VAR]CHAR(n) (n>=32) angegeben werden.

DEFAULT SYSDBA

Liefert den Namen des Datenbanksystemadministrators (SYSDBA-Benutzers) und kann nur für Spalten vom Datentyp [VAR]CHAR(n) (n>=32) angegeben werden.

DEFAULT DATE

Liefert das aktuelle Datum und kann nur für Spalten vom Datentyp DATE angegeben werden.

DEFAULT TIME

Liefert die aktuelle Zeit und kann nur für Spalten vom Datentyp TIME angegeben werden.

DEFAULT TIMESTAMP

Liefert den aktuellen Zeitstempel und kann nur für Spalten vom Datentyp TIMESTAMP angegeben werden.

DEFAULT UTCDATE

Liefert den aktuellen UTC-Zeitstempel (Greenwich Mean Time) und kann nur für Spalten vom Datentyp TIMESTAMP angegeben werden.

DEFAULT UTCDIFF

Liefert die Zeitdifferenz in Stunden zwischen Ihrer lokalen Zeitangabe und der UTC-Zeitangabe und kann nur für Spalten vom Datentyp FLOAT(p) (p>=4) oder FIXED(p,s) (s>=2, p>=s+2) angegeben werden (ab Version 7.4.04.02).

DEFAULT TIMEZONE

Liefert die Zeitdifferenz in der Form hhmmss zwischen Ihrer lokalen Zeitangabe und der UTC-Zeitangabe und kann nur für Spalten vom Datentyp FLOAT(p) (p>=6) oder FIXED(p,s) (s>=0, p>=s+6) angegeben werden.

DEFAULT TRUE/DEFAULT FALSE

Können nur für Spalten vom Datentyp BOOLEAN angegeben werden.

DEFAULT TRANSACTION

Liefert die Identifikation der aktuellen Transaktion und kann nur für Spalten vom Datentyp CHAR(n) BYTE (n>=8) angegeben werden.

DEFAULT STAMP

Liefert einen innerhalb des Datenbanksystems eindeutigen acht Zeichen langen Wert und kann nur für Spalten vom Datentyp CHAR(n) BYTE (n>=8) angegeben werden.

Wenn eine Tabelle ohne Schlüsselspalte definiert wird, legt das Datenbanksystem implizit eine Schlüsselspalte SYSKEY CHAR(8) BYTE an. Die Schlüsselwerte in der Spalte SYSKEY sind jedoch nur innerhalb einer Tabelle eindeutig, d.h. in zwei voneinander verschiedenen Tabellen können gleiche Werte in der SYSKEY-Spalte existieren. Wenn eindeutige Schlüssel innerhalb des gesamten Datenbanksystems erwünscht sind, kann eine Schlüsselspalte mit der DEFAULT-Spezifikation STAMP definiert werden.

DEFAULT SERIAL [(<unsigned_integer)]

Liefert einen Nummerngenerator für positive ganze Zahlen und kann nur für Spalten vom Datentyp INTEGER, SMALLINT und FIXED ohne Nachkommastellen angegeben werden (siehe weiter unten: Nummerngenerator).

Durch Angabe einer Integer-Zahl ohne Vorzeichen (unsigned_integer) (muss größer als 0 sein) kann der erste vom Generator erzeugte Wert definiert werden. Fehlt diese Angabe, wird als erster Wert 1 geliefert.

Wenn der Wert 0 in diese Spalte durch eine INSERT-Anweisung eingefügt wird, wird der aktuelle Zahlengeneratorwert geliefert, nicht der Wert 0.

In jeder Tabelle darf es höchstens eine Spalte mit der DEFAULT-Spezifikation DEFAULT SERIAL geben.

Siehe auch:

DEFAULT-Prädikat (default_predicate)

Nummerngenerator

Durch Angabe der DEFAULT-Spezifikation DEFAULT SERIAL(n) bzw. des Datentyps SERIAL(n) kann ein Nummerngenerator erzeugt werden, der implizit von 1 oder einem vorgegebenen Wert n beginnend positive, ganze Zahlen erzeugt.

Der Datentyp SERIAL(n) kann als DEFAULT-Spezifikation für Spalten verwendet werden, die nur Festkommazahlen ohne Nachkommastellen enthalten können, da SERIAL(n) auf FIXED(10) DEFAULT SERIAL(n) abgebildet wird.

Der maximal vom Nummerngenerator erzeugte Wert ist (10**m)-1, wenn die Defaultspezifikation DEFAULT SERIAL für eine Spalte des Datentyps FIXED(m) definiert wird.

SERIAL-Spalten kann nur beim Einfügen einer Zeile ein Wert zugewiesen werden. Die Werte einer SERIAL-Spalte können nicht mit Hilfe einer UPDATE-Anweisung verändert werden. Eine SERIAL-Spalte kann deshalb zur eindeutigen Bestimmung der Einfügereihenfolge und zur eindeutigen Identifikation einer Zeile in einer Tabelle verwendet werden.


DELETE-Regel (delete_rule) (SAP-Bibliothek - Grundwissen)

DELETE-Regel (delete_rule)

Die DELETE-Regel (delete_rule) definiert die Auswirkungen, die das Löschen einer Zeile der referenzierten Tabelle referenced_table auf die referenzierende Tabelle hat

Syntax

<delete_rule> ::= ON DELETE CASCADE
| ON DELETE RESTRICT
| ON DELETE SET DEFAULT
| ON DELETE SET NULL

Erläuterung

· Keine DELETE-Regel: Das Löschen einer Zeile der referenzierten Tabelle scheitert, wenn es Trefferzeile gibt.

· ON DELETE CASCADE: Wenn eine Zeile der referenzierten Tabelle gelöscht wird, dann werden alle Trefferzeilen gelöscht.

· ON DELETE RESTRICT: Das Löschen einer Zeile der referenzierten Tabelle scheitert, wenn es Trefferzeilen gibt.

· ON DELETE SET DEFAULT: Wenn eine Zeile der referenzierten Tabelle gelöscht wird, dann wird für jede Trefferzeile jeder referenzierenden Spalte der zugehörige Vorschlagswert (DEFAULT-Wert) zugewiesen.
Für jede referenzierende Spalte muß eine DEFAULT-Spezifikation existieren.

· ON DELETE SET NULL: Wenn eine Zeile der referenzierten Tabelle gelöscht wird, dann wird jeder referenzierenden Spalte referencing_column jeder Trefferzeile ein NULL-Wert zugewiesen.
Keine referenzierende Spalte darf eine NOT NULL-Spalte sein.

Siehe auch:

Referentielle CONSTRAINT-Definition (referential_constraint_definition)

Spaltenattribute (column_attributes)


DISTINCT-Spezifikation (distinct_spec) (SAP-Bibliothek - Grundwissen)

DISTINCT-Spezifikation (distinct_spec)

Die DISTINCT-Spezifikation (distinct_spec) wird in einer QUERY-Spezifikation oder in einer SINGLE SELECT-Anweisung angegeben, um Duplikatzeilen zu entfernen.

Syntax

<distinct_spec> ::= DISTINCT | ALL

Beispiele

SQL-Tutorial, Strukturlink Auswählen und Anordnen von Zeilen

Erläuterung

Eine Zeile ist ein Duplikat einer anderen Zeile, wenn beide in jeder Spalte identische Werte aufweisen. NULL-Werte gelten dabei als identisch, ebenso Spezial-NULL-Werte.

Wird keine DISTINCT-Spezifikation angegeben, werden keine Duplikatzeilen aus der Ergebnistabelle entfernt.

· DISTINCT: Aus der Ergebnistabelle werden alle Duplikatzeilen entfernt.

· ALL: Aus der Ergebnistabelle werden keine Duplikatzeilen entfernt.


DUPLICATES-Klausel (duplicates_clause) (SAP-Bibliothek - Grundwissen)

DUPLICATES-Klausel (duplicates_clause)

Durch die DUPLICATES-Klausel (duplicates_clause) kann das Verhalten beim Auftreten von Schlüsselkollisionen gesteuert werden.

Syntax

<duplicates_clause> ::= REJECT DUPLICATES | IGNORE DUPLICATES | UPDATE DUPLICATES

Erläuterung

SQL-Anweisungen, in denen die DUPLICATES-Klausel verwendet wird, sind die CREATE-TABLE-Anweisung und die INSERT-Anweisung.

CREATE TABLE-Anweisung

REJECT DUPLICATES oder keine DUPLICATES-Klausel | Die CREATE TABLE-Anweisung scheitert, wenn Schlüsselkollisionen auftreten.
IGNORE DUPLICATES | Alle Zeilen, die beim Einfügen eine Schlüsselkollision hervorrufen, werden ignoriert.
UPDATE DUPLICATES | Alle Zeilen, die beim Einfügen eine Schlüsselkollision hervorrufen, überschreiben die Zeilen, mit denen sie kollidieren.

INSERT-Anweisung

Wenn eine Zeile mit dem Schlüssel der einzufügenden Zeile in der Basistabelle bereits existiert, sind folgende Fälle zu unterscheiden:

REJECT DUPLICATES oder keine DUPLICATES-Klausel | Die INSERT-Anweisung scheitert.
IGNORE DUPLICATES | Die neue Zeile wird nicht eingefügt und die Bearbeitung der INSERT-Anweisung fortgesetzt.
UPDATE DUPLICATES | Die existierende Zeile wird durch die neue Zeile überschrieben und die Bearbeitung der INSERT-Anweisung wird fortgesetzt.

Wenn bei einer INSERT-Anweisung mit Angabe von UPDATE DUPLICATES und Angabe eines QUERY-Ausdrucks mehr als eine Schlüsselkollision für den gleichen Schlüssel auftritt, kann nicht vorausgesagt werden, welchen Inhalt die entsprechende Zeile der Basistabelle nach Beendigung der INSERT-Anweisung besitzt.

Wenn bei einer INSERT-Anweisung mit Angabe von IGNORE DUPLICATES und Angabe eines QUERY-Ausdrucks mehr als eine Zeile der Ergebnistabelle den gleichen Schlüssel der Basistabelle liefert und wenn dieser zuvor in der Basistabelle noch nicht existierte, kann nicht vorausgesagt werden, welche Zeile in die Tabelle eingefügt wird.

Wenn durch den in der INSERT-Anweisung angegebenen Tabellennamen eine Tabelle ohne vom Benutzer definierten Schlüssel identifiziert wird, hat die Angabe einer DUPLICATES-Klausel keine Wirkung.


Ausdruck (expression) (SAP-Bibliothek - Grundwissen)

Ausdruck (expression)

Ein Ausdruck (expression) spezifiziert einen Wert, der gegebenenfalls durch Anwendung von arithmetischen Operatoren auf Werte erzeugt wird. Oftmals wird in einer SQL-Anweisung auch eine Liste von Ausdrücken (expression_list) verwendet.

Es werden folgende arithmetische Operatoren unterschieden:

● Additive Operatoren
+ Addition
- Subtraktion

● Multiplikative Operatoren
* Multiplikation
/ Division
DIV ganzzahlige Division
MOD Rest nach ganzzahliger Division

Syntax

<expression> ::= <term>
| <expression> + <term>
| <expression> - <term>

<expression_list> ::= (<expression>,...)

<term> ::= <factor>
| <term> * <factor>
| <term> / <factor>
| <term> DIV <factor>
| <term> MOD <factor>

<factor> ::= [<sign>] <value_spec>
                    | [<sign>] <column_spec>
                    | [<sign>] <function_spec>
                    | [<sign>] <set_function_spec>
                    | <scalar_subquery>
                    | <expression>

<sign> ::= + | -

Beispiele

SQL-Tutorial, Strukturlink Arithmetische Operationen

Erläuterung

Die arithmetischen Operatoren können nur auf numerische Datentypen angewandt werden.

 | Ergebnis eines Ausdrucks
expression | Wert eines beliebigen Datentyps
factor liefert einen NULL-Wert | NULL-Wert
factor liefert einen Spezial-NULL-Wert | Spezial-NULL-Wert
expression führt zu einer Division durch 0 | Spezial-NULL-Wert
expression führt zu einem Überlauf des internen Zwischenergebnisses | Spezial-NULL-Wert

Bei fehlender Klammerung haben die Operatoren folgende Priorität:

...

1. Das Vorzeichen (+ | -) bindet stärker als die additiven und multiplikativen Operatoren.

2. Die multiplikativen Operatoren binden stärker als die additiven Operatoren.

3. Die multiplikativen Operatoren haben untereinander gleiche Priorität.

4. Die additiven Operatoren haben untereinander gleiche Priorität.

5. Bei gleicher Priorität erfolgt die Auswertung von links nach rechts.

Operanden sind Festkommazahlen

Operand1 (a) | Operand2 (b) | Ergebnis
Festkommazahl (p Genauigkeit s Anzahl der Nachkommastellen) | Festkommazahl (p' Genauigkeit s' Anzahl der Nachkommastellen) | Festkommazahl (p'' Genauigkeit s'' Anzahl der Nachkommastellen) oder Gleitkommazahl

Der Datentyp des Ergebnisses ist abhängig von der Operation sowie von der Genauigkeit und der Anzahl der Nachkommastellen der Operanden.

Beachten Sie, dass bei der Angabe eines Spaltennamens der Datentyp der Spalte zugrunde gelegt wird, nicht die Genauigkeit und die Anzahl der Nachkommastellen des aktuellen Wertes der Spalte.

Operanden sind Festkommazahlen, Operatoren sind +, - , * oder /

Das Ergebnis von Addition, Subtraktion und Multiplikation wird aus einem Zwischenergebnis erzeugt, das mehr als 38 gültige Ziffern haben kann. Wenn das Zwischenergebnis nicht mehr als 38 gültige Ziffern hat, ist das endgültige Ergebnis gleich diesem Zwischenergebnis. Andernfalls wird ein Ergebnis als Gleitkommazahl mit 38 Stellen Genauigkeit erzeugt. Nachkommastellen werden gegebenenfalls abgeschnitten.

Bedingung

Operator

Ergebnis

max(p-s,p'-s')

+, -

Festkommazahl
p''=max(p-s,p'-s')+max(s,s')+1
s''=max(s,s')

(p+p')<=38

*

Festkommazahl
p''=p+p'
s''=s+s'

(p-s+s')<=38

/

Festkommazahl
p''=38
s''=38-(p-s+s')
Spezial-NULL-Wert, wenn b=0

Operanden sind ganze Zahlen, Operatoren sind DIV, MOD

Bedingung | Operator | Ergebnis
ABS(a)<1E38 und ABS(b)<1E38 und b<>0 | DIV | TRUNC(a/b)
b=0 | DIV | Spezial-NULL-Wert
ABS(a)>=1E38 und b<>0 oder ABS(b)>=1E38 | DIV | Fehlermeldung
ABS(a)<1E38 und ABS(b)<1E38 und b<>0 | MOD | a-b*(a DIV b)
b=0 | MOD | A
ABS(a)>=1E38 und b<>0 oder ABS(b)>=1E38 | MOD | Fehlermeldung

Ein Operand ist Gleitkommzahl

Wenn einer der Operanden eine Gleitkommazahl ist, so ist das Ergebnis der arithmetischen Operation eine Gleitkommazahl.


Spezifikation von Werten (extended_value_spec) (SAP-Bibliothek - Grundwissen)

Spezifikation von Werten (extended_value_spec)

Die Spezifikation von Werten (extended_value_spec) kann durch Angabe eines der Schlüsselwörter DEFAULT bzw. STAMP oder durch Angabe von Werten (value_spec: Literale, Parameterspezifikationen, Schlüsselworten usw.) erfolgen.

Syntax

<extended_value_spec> ::= DEFAULT | STAMP | <value_spec>

<value_spec> ::= <literal>
| <parameter_spec>
| NULL
| USER | USERGROUP
| SYSDBA | CURRENT_SCHEMA | UID
| [<schema_name>.]<sequence_name>.NEXTVAL
| [<schema_name>.]<sequence_name>.CURRVAL
| <table_name>.CURRVAL
| DATE | TIME | TIMESTAMP
| UTCDATE | TIMEZONE | UTCDIFF
| TRUE | FALSE
| TRANSACTION

Beispiele

SQL-Tutorial, Strukturlink Nummerngeneratoren für Tabellen

Erläuterung

DEFAULT

DEFAULT bezeichnet den in einer CREATE TABLE-Anweisung oder ALTER TABLE-Anweisung für die Spalte als Vorschlagswert (Default) definierten Wert. Ist ein solcher Wert nicht definiert, kann DEFAULT zur Spezifikation von Werten nicht verwendet werden.

Das Schlüsselwort DEFAULT kann in folgenden SQL-Anweisungen verwendet werden: INSERT-Anweisung, UPDATE-Anweisung

Das Schlüsselwort DEFAULT kann in einem DEFAULT-Prädikat verwendet werden.

STAMP

Das Datenbanksystem ist in der Lage, eindeutige Werte zu generieren. Es handelt sich dabei um eine fortlaufende Nummer, die bei X'000000000001' beginnt. Die Werte werden aufsteigend vergeben, wobei nicht sichergestellt werden kann, daß eine Folge von Werten lückenlos ist. Das Schlüsselwort STAMP liefert den nächsten vom Datenbanksystem generierten Wert.

Das Schlüsselwort STAMP kann in folgenden SQL-Anweisungen verwendet werden (nur auf Spalten vom Datentyp CHAR(n) BYTE mit n>=8, siehe DEFAULT-Spezifikation): INSERT-Anweisung, UPDATE-Anweisung

Wenn der Anwender den generierten Wert erfahren möchte, bevor er auf eine Spalte angewandt wird, muß folgende SQL-Anweisung verwendet werden: NEXT STAMP-Anweisung

<value_spec>

NULL

Angabe des NULL-Werts

USER | USERGROUP

Aktueller Benutzername bzw. Name der Benutzergruppe, zu der der Benutzer gehört, der die SQL-Anweisung aufruft. Gehört der Benutzer keiner Benutzergruppe an, wird der Benutzername angezeigt.

SYSDBA

Angabe des Datenbanksystemadministrators

CURRENT_SCHEMA

Angabe des aktuellen Schemas.

UID

Identifikation des aktuellen Benutzers. Diese DEFAULT-Spezifikation kann nur für Spalten mit numerischem Datentyp und mindestens 10 Vorkommastellen angegeben werden.

[<schema_name>.]<sequence_name>.NEXTVAL | [<schema_name>.]<sequence_name>.CURRVAL

NEXTVAL gibt den nächsten verfügbaren Wert an, der durch den impliziten Nummerngenerator, der durch die Sequenz [<schema_name>.]<sequence_name> definiert wurde, erzeugt wird.

CURRVAL gibt den gerade verwendeten Wert an, der innerhalb der Datenbanksitzung durch den Nummerngenerator [<schema_name>.]<sequence_name> erzeugt wurde.

Siehe auch:

CREATE SEQUENCE-Anweisung (create_sequence_statement)

<table_name>.CURRVAL

Letzer in der aktuellen Datenbanksitzung vergebener Wert der Serial-Spalte der Tabelle table_name.

DATE | TIME | TIMESTAMP

Aktuelles Datum, Zeit, Zeitstempel

UTCDATE

Aktueller UTC-Zeitstempel (Greenwich Mean Time)

TIMEZONE

Angabe der Zeitdifferenz in der Form hhmmss (im Datentyp FIXED(6)) zwischen Ihrer lokalen Zeitangabe und der UTC-Zeitangabe.

UTCDIFF

Angabe der Zeitdifferenz in Stunden (im Datentyp FIXED(4,2)) zwischen Ihrer lokalen Zeitangabe und der UTC-Zeitangabe.

TRUE | FALSE

Entsprechender Wert einer Spalte vom Datentyp BOOLEAN

TRANSACTION

Identifikation der aktuellen Transaktion. Es handelt sich um einen Wert mit dem Datentyp CHAR(6) BYTE.


Funktion (function_spec) (SAP-Bibliothek - Grundwissen)

Funktion (function_spec)

Es gibt eine Reihe von Funktionen (function_spec), die auf einen Wert (Zeile) als Argument angewendet werden können und ein Ergebnis liefern. Diese Funktionen (vorgegebene und selbst definierte) und ihre Aufrufe werden in den folgenden Abschnitten vorgestellt.

Syntax

<function_spec> ::=
<arithmetic_function>
| <trigonometric_function>
| <string_function>
| <date_function>
| <time_function>
| <extraction_function>
| <special_function>
| <conversion_function>
| <dbfunction_call>

Beispiele

SQL-Tutorial, Strukturlink Funktionen

Erläuterung

Die Argumente und Ergebnisse der Funktionen sind numerische, alphanumerische oder boolesche Werte, die gewissen Einschränkungen unterliegen. LONG-Spalten sind als Argumente nicht zulässig bis auf wenige Ausnahmen, auf die explizit hingewiesen wird.

Siehe auch:

Funktionen: Überblick


Arithmetische Funktion (arithmetic_function) (SAP-Bibliothek - Grundwissen)

Arithmetische Funktion (arithmetic_function)

Eine arithmetische Funktion (arithmetic_function) ist eine Funktion, die als Ergebnis einen numerischen Wert liefert.

Syntax

<arithmetic_function> ::=
ABS ( <expression> )
| CEIL ( <expression> )
| EXP ( <expression> )
| FIXED ( <expression>[, <unsigned_integer> [, <unsigned_integer>] ] )
| FLOAT ( <expression>[, <unsigned_integer> ] )
| FLOOR ( <expression> )
| INDEX ( <string_spec>, <string_spec> [,<expression>[, <expression>] ] )
| LENGTH ( <expression> )
| LN ( <expression> )
| LOG ( <expression>, <expression> )
| NOROUND ( <expression> )
| PI
| POWER ( <expression>, <expression> )
| ROUND ( <expression>[, <expression>] )
| SIGN ( <expression> )
| SQRT ( <expression> )
| TRUNC ( <expression>[, <expression>] )

<string_spec> ::= <expression>

Erläuterung

Als Stringspezifikation string_spec sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert haben.

Siehe auch:

Funktionen: Überblick


ABS(a) (SAP-Bibliothek - Grundwissen)

ABS(a)

ABS(a) ist eine arithmetische Funktion, die den vorzeichenlosen Wert (Absolutbetrag) für den Ausdruck a (eine Zahl) ermittelt.

 | Ergebnis der Funktion ABS(a)
a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


CEIL(a) (SAP-Bibliothek - Grundwissen)

CEIL(a)

CEIL(a) ist eine arithmetische Funktion, die den kleinsten ganzzahligen Wert bildet, der größer oder gleich dem Ausdruck a (einer Zahl) ist.

Das Ergebnis ist eine Festkommazahl mit 0 Nachkommastellen.

Wenn es nicht möglich ist, das Ergebnis von CEIL(a) in einer Festkommazahl darzustellen, wird eine Fehlermeldung ausgegeben.

 | Ergebnis der Funktion CEIL(a)
a ist der NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


EXP(a) (SAP-Bibliothek - Grundwissen)

EXP(a)

EXP(a) ist eine arithmetische Funktion, die die Potenz aus der Basis e (2.71828183) und dem Ausdruck a als Exponent ("e hoch a") bildet.

 | Ergebnis der Funktion EXP(a)
a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-Null-Wert


FIXED(a,p,s) (SAP-Bibliothek - Grundwissen)

FIXED(a,p,s)

FIXED(a,p,s) ist eine arithmetische Funktion, die zur Ausgabe des Ausdrucks a (einer Zahl) in einem Format vom Datentyp FIXED(p,s) (p, s sind ganze Zahlen ohne Vorzeichen) dient.

Die Nachkommastellen werden gegebenenfalls auf s Stellen nach dem Komma gerundet.

 | Ergebnis der Funktion FIXED(a,p,s)
Keine Angabe für s | Ergebnis wie für s=0
Keine Angabe für p | Ergebnis wie für p=38
ABS(a)>10exp(p-s) | Spezial-NULL-Wert
a ist der NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


FLOAT(a,s) (SAP-Bibliothek - Grundwissen)

FLOAT(a,s)

FLOAT(a,s) ist eine arithmetische Funktion, die den Ausdruck a (eine Zahl) in einem Format vom Datentyp FLOAT(s) (s ist eine ganze Zahl ohne Vorzeichen) ausgibt. Dabei wird gegebenenfalls auf s Stellen gerundet.

 | Ergebnis der Funktion FLOAT(a,s)
a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


FLOOR(a) (SAP-Bibliothek - Grundwissen)

FLOOR(a)

FLOOR(a) ist eine arithmetische Funktion, die den größten ganzzahligen Wert bildet, der kleiner oder gleich dem Ausdruck a (einer Zahl) ist.

Das Ergebnis ist eine Festkommazahl mit 0 Nachkommastellen.

Wenn es nicht möglich ist, das Ergebnis von FLOOR(a) in einer Festkommazahl darzustellen, wird eine Fehlermeldung ausgegeben.

 | Ergebnis der Funktion FLOOR(a)
a ist der NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


INDEX(a,b,p,s) (SAP-Bibliothek - Grundwissen)

INDEX(a,b,p,s)

INDEX(a,b,p,s) ist eine arithmetische Funktion, die die Position des in b angegebenen Substrings innerhalb der Zeichenkette a bestimmt. a und b sind Stringspezifikationen. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert haben.

Der Parameter p (ein Ausdruck) ist optional. Wenn p angegeben ist (p>=1), gibt er die Startposition für die Suche nach dem Substring b an. Wenn p nicht angegeben ist, so wird ab der Startposition 1 gesucht.

Der Parameter s (ein Ausdruck) ist optional. Wenn s angegeben ist, gibt er an, nach dem wievielten Auftreten des Substrings b gesucht werden soll. Wenn s nicht angegeben ist, so wird nach dem ersten Auftreten gesucht.

 | Ergebnis der Funktion INDEX(a,b,p,s)
a, b Zeichenketten und b nicht mindestens s-mal Substring von a | 0
a Zeichenkette und b leere Zeichenkette | p
a, b, p oder s ist NULL-Wert | NULL-Wert
p oder s ist Spezial-NULL-Wert | Fehlermeldung

Beispiele

SQL-Tutorial, Strukturlink Informationen über Zeichenketten


LENGTH(a) (SAP-Bibliothek - Grundwissen)

LENGTH(a)

LENGTH(a) ist eine arithmetische Funktion, die die Anzahl von Zeichen bzw. Bytes angibt, die zur internen Darstellung des Ausdrucks a notwendig sind. Die Funktion kann auf alle Datentypen (auch LONG) angewandt werden.

 | Ergebnis der Funktion LENGTH(a)
a ist ein Wert vom Datentyp CHAR|VARCHAR <ASCII|UNICODE> mit n Zeichen | Anzahl der Zeichen n
a ist ein Wert von einem der anderen Datentypen der Länge n | Länge n in Bytes
a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert

Die Bestimmung der Anzahl der Zeichen bzw. der Länge in Bytes erfolgt ohne Berücksichtigung von nachfolgenden Leerzeichen (Codeattribut ASCII, UNICODE) bzw. binären Nullen (Codeattribut BYTE).

Beispiele

SQL-Tutorial, Strukturlink Informationen über Zeichenketten


LN(a) (SAP-Bibliothek - Grundwissen)

LN(a)

LN(a) ist eine arithmetische Funktion, die den natürliche Logarithmus des Ausdrucks a (einer Zahl) bildet.

 | Ergebnis der Funktion LN(a)
a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


LOG(a,b) (SAP-Bibliothek - Grundwissen)

LOG(a,b)

LOG(a,b) ist eine arithmetische Funktion, die den Logarithmus des Ausdrucks b (einer Zahl) zum Ausdruck a als Basis bildet.

 | Ergebnis der Funktion LOG(a,b)
a oder b ist NULL-Wert | NULL-Wert
b ist Spezial-NULL-Wert | Spezial-NULL-Wert


NOROUND(a) (SAP-Bibliothek - Grundwissen)

NOROUND(a)

NOROUND(a) ist eine arithmetische Funktion, die verhindert, dass bei einer UPDATE- oder INSERT-Anweisung der Ausdruck a gerundet wird, um es dem Datentyp der Zielspalte anzupassen.

Wenn die nicht gerundete Zahl nicht zum Datentyp der Zielspalte paßt, wird eine Fehlermeldung ausgegeben.

 | Ergebnis der Funktion NOROUND(a)
a ist der NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


PI (SAP-Bibliothek - Grundwissen)

PI

PI ist eine arithmetische Funktion , die den Wert p ausgibt.


POWER(a,n) (SAP-Bibliothek - Grundwissen)

POWER(a,n)

POWER(a,n) ist eine arithmetische Funktion, die die n-te Potenz der Zahl a (a und n sind Ausdrücke) bildet.

Wenn n kein ganzzahliger Wert ist, dann wird eine Fehlermeldung ausgegeben.

 | Ergebnis der Funktion POWER(a,n)
a oder n ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


ROUND(a,n) (SAP-Bibliothek - Grundwissen)

ROUND(a,n)

ROUND(a,n) ist eine arithmetische Funktion mit folgendem Ergebnis (für die Ausdrücke a und n, die Zahlen sind):

ROUND(a) - Auf- und Abrunden von Dezimalstellen
ROUND(a,n) - Auf- und Abrunden auf die n-te Stelle rechts vom Dezimalpunkt
ROUND(a,-n) - Auf- und Abrunden auf die n-te Stelle links vom Dezimalpunkt

 | Ergebnis der Funktion ROUND(a,n)
a>=0 | TRUNC(a+0.5*10E-n,n)
a<0 | TRUNC(a-0.5*10E-n,n)
Keine Angabe für n | Ergebnis wie für n=0
n ist nicht ganzzahlig | Der ganzzahlige Teil von n wird verwendet und das Ergebnis ist entsprechend wie bei a>=0 bzw. a<0
a ist Gleitkommazahl | Gleitkommazahl
a ist Festkommazahl | Festkommazahl
a ist der NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


SIGN(a) (SAP-Bibliothek - Grundwissen)

SIGN(a)

SIGN(a) ist eine arithmetische Funktion, die Auskunft über das Vorzeichen den Ausdruck a (einer Zahl) gibt.

 | Ergebnis der Funktion SIGN(a)
a<0 | -1
a=0 | 0
a>0 | 1
a ist der NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


SQRT(a) (SAP-Bibliothek - Grundwissen)

SQRT(a)

SQRT(a) ist eine arithmetische Funktion, die die Quadratwurzel des Ausdrucks a (einer Zahl) errechnet.

 | Ergebnis der Funktion SQRT(a)
a>0 | Quadratwurzel von a
a=0 | 0
a<0 oder a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


TRUNC(a,n) (SAP-Bibliothek - Grundwissen)

TRUNC(a,n)

TRUNC(a,n) ist eine arithmetische Funktion mit folgendem Ergebnis (für die Ausdrücke a und n, die Zahlen sind):

TRUNC(a) - Abschneiden der Dezimalstellen von a
TRUNC(a,n) - Abschneiden der Zahl a nach n Stellen hinter dem Komma
TRUNC(a,-n) - Setzen von n Stellen der Zahl a vor dem Dezimalpunkt auf 0

 | Ergebnis der Funktion TRUNC(a,n)
n>0 | Zahl a, die n Stellen nach dem Komma abgeschnitten wird
n=0 | Ganzzahliger Teil von a
n<0 | Zahl a, die s Stellen vor dem Komma abgeschnitten wird
Keine Angabe für n | Wie bei n=0
n ist nicht ganzzahlig | Der ganzzahlige Teil von n wird verwendet und das Ergebnis ist entsprechend wie bei n>0, n=0 bzw. n<0
a ist Gleitkommazahl | Gleitkommazahl
a ist Festkommazahl | Festkommazahl
a ist der NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert


Konversionsfunktion (conversion_function) (SAP-Bibliothek - Grundwissen)

Konversionsfunktion (conversion_function)

Eine Konversionsfunktion (conversion_function) ist eine Funktion, die einen Wert von einem Datentyp in einen anderen konvertiert.

Syntax

<conversion_function> ::=
CHAR ( <expression>[, <datetimeformat> ] )
| CHR ( <expression>[, <unsigned_integer> ] )
| HEX ( <expression> )
| HEXTORAW ( <expression> )
| NUM ( <expression> )

Siehe auch:

Funktionen: Überblick


CHAR(a,t) (SAP-Bibliothek - Grundwissen)

CHAR(a,t)

CHAR(a,t) ist eine Funktion (Konversionsfunktion), die Datums-, Zeit- oder Zeitstempelwerte in eine Zeichenkette (Ausdruck a) mit dem in t angegebenen Format für Datumswerte, Zeitwerte oder Zeitstempelwerte konvertiert.

 | Ergebnis der Funktion CHAR(a,t)
CHAR(a) | Als Format für den Wert a wird das aktuell eingestellte Datums- und Zeitformat angenommen.
a ist der NULL-Wert | NULL-Wert


CHR(a,n) (SAP-Bibliothek - Grundwissen)

CHR(a,n)

CHR(a,n) ist eine Konversionsfunktion, die den Ausdruck a in eine Zeichenkette konvertiert.

Wert a: Der Ausdruck a muss ein numerischer Wert, eine Zeichenkette oder ein boolescher Wert (BOOLEAN) sein.

Wert n: n ist eine ganze Zahl ohne Vorzeichen.

 | Ergebnis der Funktion CHR(a,n)
a ist numerischer Wert | Zeichenkette, die der CHAR-Darstellung des numerischen Wertes a entspricht. Das Codeattribut der Zeichenkette entspricht dem Codetyp des Rechners.
a ist Zeichenkette | Unveränderte Zeichenkette
a ist boolescher Wert | T, wenn a=TRUE F, wenn a=FALSE
a ist weder numerischer Wert, noch Zeichenkette, noch boolescher Wert | Fehlermeldung
CHR(a,n), n>=1 | Ausgabe mit dem Längenattribut n
CHR(a) | Das Längenattribut n wird in Abhängigkeit vom Datentyp und der Länge von a bestimmt.
CHR(a) und a ist vom Datentyp FLOAT(p) | Wenn p=1, dann n=6 Wenn p>1, dann n=p+6
CHR(a) und a ist vom Datentyp FIXED(p,s) | Wenn p=s, dann n=p+s Wenn s=0, dann n=p+1
a ist der NULL-Wert | NULL-Wert
a ist der Spezial-NULL-Wert | Fehlermeldung

Beispiele

SQL-Tutorial, Strukturlink Umwandeln von Werten


HEX(a) (SAP-Bibliothek - Grundwissen)

HEX(a)

HEX(a) ist eine Konversionsfunktion, die den Ausdruck a in eine hexadezimale Darstellung konvertiert. Die Funktion kann auf jeden Datentyp angewandt werden.

 | Ergebnis der Funktion HEX(a)
a ist der NULL-Wert | NULL-Wert
a ist der Spezial-NULL-Wert | Fehlermeldung


HEXTORAW(a) (SAP-Bibliothek - Grundwissen)

HEXTORAW(a)

HEXTORAW(a) ist eine Konversionsfunktion.

Ein Argument a der Funktion muss ein Ausdruck sein, der aus hexadezimalen Zeichen besteht. Der Ausdruck a wird in eine Zeichenkette mit dem Codeattribut BYTE konvertiert, die die entsprechenden Zeichen enthält. Dabei werden zwei hexadezimale Zeichen in ein Zeichen umgewandelt.

 | Ergebnis der Funktion HEXTORAW(a)
a ist der NULL-Wert | NULL-Wert
A ist der Spezial-NULL-Wert | Fehlermeldung


NUM(a) (SAP-Bibliothek - Grundwissen)

NUM(a)

NUM(a) ist eine Konversionsfunktion, die den Ausdruck a in einen numerischen Wert umwandelt.

NUM kann auf Zeichenketten (Datentyp CHAR bzw. VARCHAR) mit dem Codeattribut ASCII, UNICODE oder BYTE, auf Datums-, Zeit-, Zeitstempelwerte, auf numerische und boolesche Werte (BOOLEAN) angewandt werden.

 | Ergebnis der Funktion NUM(a)
a ist Zeichenkette mit dem Codeattribut ASCII oder UNICODE und kann als numerischer Wert interpretiert werden | Entsprechender numerischer Wert
a ist Zeichenkette mit dem Codeattribut BYTE | Wert zwischen 0 und 255, der wie folgt bestimmt wird: das erste Byte dieser Zeichenkette wird aus seiner hexadezimalen Darstellung in die dezimale Darstellung überführt
a ist numerischer Wert | Unveränderter numerischer Wert
a ist boolescher Wert | 1, wenn a=TRUE 0, wenn a=FALSE
a ist eine Zeichenkette, die nicht als numerischer Wert interpretiert werden kann, a ist eine Zeichenkette, die nicht das Codeattribute ASCII hat, a ist kein numerischer und kein boolescher Wert | Fehlermeldung
a ist Zeichenkette, die als numerischer Wert außerhalb des Intervalls –9.9999999999999999999999999999999999999E+62, 9.9999999999999999999999999999999999999E+62 interpretiert werden kann | Spezial-NULL-Wert
a ist der NULL-Wert | NULL-Wert
a ist der Spezial-NULL-Wert | Spezial-NULL-Wert


Datums- und Zeitformat (datetimeformat) (SAP-Bibliothek - Grundwissen)

Datums- und Zeitformat (datetimeformat)

Das Datums- und Zeitformat (datetimeformat) spezifiziert die Darstellungsform für Datums-, Zeit- und Zeitstempelwerte.

In SQL-Anweisungen legt es fest, in welcher Darstellung Datums-, Zeit- und Zeitstempelwerte in diesen SQL-Anweisungen enthalten sein können und wie Ergebnisse dargestellt werden sollen.

Syntax

<datetimeformat> ::= EUR | INTERNAL | ISO | JIS | USA

Das Datums- und Zeitformat ISO wird von ODBC- und JDBC-Anwendungen genutzt und kann nicht durch ein anderes Datums- und Zeitformat ersetzt werden.

Datumswert

'YYYY' | Vierstellige Jahresbezeichnung (0001-9999)
'MM' | Zweistellige Monatsbezeichnung (01-12)
'DD' | Zweistellige Tagesbezeichnung (01-31)

Format | Allgemeine Form | Beispiel
EUR | 'DD.MM.YYYY' | '23.01.2005'
INTERNAL | 'YYYYMMDD' | '20050123'
ISO/JIS | 'YYYY-MM-DD' | '2005-01-23'
USA | 'MM/DD/YYYY' | '01/23/2005'

Bei allen Formaten außer INTERNAL können die führenden Nullen bei Monats- und Tagesbezeichnungen entfallen.

Zeitwert

'HHHH' | Vierstellige Stundenbezeichnung
'HH' | Zweistellige Stundenbezeichnung
'MM' | Zweistellige Minutenbezeichnung (00-59)
'SS' | Zweistellige Sekundenbezeichnung (00-59)

Format | Allgemeine Form | Beispiel
EUR | 'HH.MM.SS' | '14.30.08'
INTERNAL | 'HHHHMMSS' | '00143008'
JIS/ISO | 'HH:MM:SS' | '14:30:08'
USA | 'HH:MM AM (PM)' | '2:30 PM'

In allen Zeitformaten muss die Stundenbezeichnung mindestens einstellig sein. Im Zeitformat USA kann die Minutenbezeichnung ganz entfallen, in den anderen Formaten außer INTERNAL muss die Minuten- und Sekundenbezeichnung mindestens einstellig sein.

In den Formaten ISO und USA werden die Stunden modulo 24 ausgegeben.
In den Formaten EUR und JIS führen Stundenangaben >99 zu einem Fehler.
Im Format INTERNAL können Stundenangaben bis 9999 verwendet werden.

Zeitstempelwert

'YYYY' | Vierstellige Jahresbezeichnung (0001-9999)
'MM' | Zweistellige Monatsbezeichnung (01-12)
'DD' | Zweistellige Tagesbezeichnung (01-31)
'HH' | Zweistellige Stundenbezeichnung (0-24)
'MM' | Zweistellige Minutenbezeichnung (00-59)
'SS' | Zweistellige Sekundenbezeichnung (00-59)
'MMMMMM' | Sechstellige Mikrosekundenbezeichnung

Format | Allgemeine Form | Beispiel
EUR/JIS/USA | 'YYYY-MM-DD-HH.MM.SS.MMMMMM' | '2005-01-23-14.30.08.456234'
ISO | 'YYYY-MM-DD HH:MM:SS.MMMMMM' | '2005-01-23 14:30:08.456234'
INTERNAL | 'YYYYMMDDHHMMSSMMMMMM' | '20050123143008456234'

In allen Zeitstempelformaten kann die Mikrosekundenbezeichnung entfallen. In allen Formaten außer INTERNAL muss die Monats- und Tagesbezeichnung mindestens einstellig sein.

Siehe auch:

Spezieller Datenbankparameter DATE_TIME_FORMAT


Datumsfunktion (date_function) (SAP-Bibliothek - Grundwissen)

Datumsfunktion (date_function)

Eine Datumsfunktion (date_function) ist eine Funktion, die auf Datums- oder Zeitstempelwerten angewandt wird bzw. als Ergebnis einen Datums- oder Zeitstempelwert liefert.

Syntax

<date_function> ::=
ADDDATE ( <date_or_timestamp_expression>, <expression> )
| DATEDIFF ( <date_or_timestamp_expression>, <date_or_timestamp_expression> )
| DAYNAME ( <date_or_timestamp_expression> )
| DAYOFMONTH ( <date_or_timestamp_expression> )
| DAYOFWEEK ( <date_or_timestamp_expression> )
| DAYOFYEAR ( <date_or_timestamp_expression> )
| MAKEDATE ( <expression>, <expression> )
| MONTHNAME ( <date_or_timestamp_expression> )
| SUBDATE ( <date_or_timestamp_expression>, <expression> )
| WEEKOFYEAR ( <date_or_timestamp_expression> )

<date_or_timestamp_expression> ::= <expression>

Beispiele

SQL-Tutorial, Strukturlink Datums- und Zeitberechnungen

Erläuterung

Das Argument date_or_timestamp_expression in einer Funktion muss als Ergebnis ein Datum, einen Zeitstempel oder einen alphanumerischen Wert liefern, der dem aktuellen Datums- oder Zeitstempelformat entspricht.

Datums- und Zeitwerte können in verschiedenen Datums- und Zeitformaten angegeben sein (ISO, USA, EUR, JIS, INTERNAL)

Obwohl der Gregorianische Kalender erst im Jahr 1582 eingeführt wurde, wird bei den Funktionen auch bei früheren Datumswerten so gerechnet, als hätte es den Gregorisnischen Kalender schon gegeben. Jedes Jahr hat also 365 oder 366 Tage.

Siehe auch:

Funktionen: Überblick


ADDDATE/SUBDATE(t,a) (SAP-Bibliothek - Grundwissen)

ADDDATE/SUBDATE(t,a)

ADDDATE(t,a) und SUBDATE(t,a) sind Datumsfunktionen, die ein Datum der Zukunft bzw. ein Datum der Vergangenheit ermitteln.

Wert t: Der Ausdruck t (date_or_timestamp_expression) in einer Funktion muss als Ergebnis ein Datum, einen Zeitstempel oder einen alphanumerischen Wert liefern, der dem aktuellen Datums- oder Zeitstempelformat entspricht.

Wert a: Der Ausdruck a (expression) liefert einen numerischen Wert, der eine Anzahl von Tagen darstellt. Nachkommastellen von a werden gegebenenfalls abgeschnitten.

 | Ergebnis der Funktion ADDDATE(t,a)/SUBDATE(t,a)
Addition von a zu t/ Subtraktion von a von t | Datumswert bzw. Zeitstempelwert
t oder a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Fehlermeldung

SELECT arrival, ADDDATE(arrival,2) arrival2, rno
FROM reservation WHERE rno = 130

Buchungsdatum um zwei Tage erhöhen

ARRIVAL | ARRIVAL2 | RNO
2005-02-01 | 2005-02-03 | 130


DATEDIFF(t,s) (SAP-Bibliothek - Grundwissen)

DATEDIFF(t,s)

DATEDIFF(t,s) ist eine Datumsfunktion, die die Anzahl der Tage zwischen Anfangs- und Enddatum ermittelt.

Werte t und s: Die Ausdrücke t und s (date_or_timestamp_expression) in einer Funktion müssen jeweils als Ergebnis ein Datum, einen Zeitstempel oder einen alphanumerischen Wert liefern, der dem aktuellen Datums- oder Zeitstempelformat entspricht.

 | Ergebnis der Funktion DATEDIFF(t,s)
Positive Differenz zwischen t und s | Numerischer Wert (Anzahl der Tage)
t oder s sind Zeitstempelwerte | Nur die im Zeitstempelwert enthaltenen Datumsangaben werden berücksichtigt, um DATEDIFF(t,s) zu berechnen.
t oder s ist NULL-Wert | NULL-Wert

SELECT arrival, departure, DATEDIFF(departure,arrival) difference, rno
FROM reservation
WHERE rno = 130

ARRIVAL | DEPARTURE | DIFFERENCE | RNO
2005-02-01 | 2005-02-03 | 2 | 130


DAYNAME/MONTHNAME(t) (SAP-Bibliothek - Grundwissen)

DAYNAME/MONTHNAME(t)

DAYNAME(t) bzw. MONTHNAME(t) sind Datumsfunktionen, die den Wochentagsnamen bzw. den Monatsnamen des angegebenen Tages liefern.

Wert t: Der Ausdruck t (date_or_timestamp_expression) in einer Funktion muss als Ergebnis ein Datum, einen Zeitstempel oder einen alphanumerischen Wert liefern, der dem aktuellen Datums- oder Zeitstempelformat entspricht.

 | Ergebnis der entsprechenden Funktion
DAYNAME(t) bzw. MONTHNAME(t) | Zeichenkette, die einen Wochentagsnamen (Sonntag bis Samstag) bzw. einen Monatsnamen (Januar bis Dezember) liefert
t ist NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Funktionen


DAYOFWEEK/WEEKOFYEAR/DAYOFMONTH/DAYOFYEAR(t) (SAP-Bibliothek - Grundwissen)

DAYOFWEEK/WEEKOFYEAR/DAYOFMONTH/DAYOFYEAR(t)

DAYOFWEEK(t)/WEEKOFYEAR(t)/DAYOFMONTH(t)/DAYOFYEAR(t) sind Datumsfunktionen, die folgende Angaben ermitteln:

Wert t: Der Ausdruck t (date_or_timestamp_expression) in einer Funktion muss als Ergebnis ein Datum, einen Zeitstempel oder einen alphanumerischen Wert liefern, der dem aktuellen Datums- oder Zeitstempelformat entspricht.

 | Ergebnis der entsprechenden Funktion
DAYOFWEEK(t) | Numerischer Wert zwischen 1 und 7 (Wochentag) Der erste Tag ist Montag, der zweite Dienstag, usw.
WEEKOFYEAR(t) | Numerischer Wert zwischen 1 und 53 (Woche des Jahres, in der der angegebene Tag liegt)
DAYOFMONTH(t) | Numerischer Wert zwischen 1 und 31 (Tag des Monats, in dem der angegebene Tag liegt)
DAYOFYEAR(t) | Numerischer Wert zwischen 1 und 366 (Tag des Jahres, in dem der angegebene Tag liegt)
t ist NULL-Wert | NULL-Wert


MAKEDATE(a,b) (SAP-Bibliothek - Grundwissen)

MAKEDATE(a,b)

MAKEDATE(a,b) ist eine Datumsfunktion, die aus einer Jahreszahl und einem Tag einen Datumswert liefert.

Die Ausdrücke a und b (expression ) in MAKEDATE müssen numerische Werte liefern.
Weiter gelten folgende Bedingungen: a>=0 (a stellt eine Jahreszahl dar)
b>0 (b stellt einen Tag dar)
Nachkommastellen von a und b werden gegebenenfalls angeschnitten.

 | Ergebnis der Funktion MAKEDATE(a,b)
a oder b ist NULL-Wert | NULL-Wert
a oder b ist Spezial-NULL-Wert | Fehlermeldung

MAKEDATE(2004,49) im Datumsformat INTERNAL ergibt 2004-02-18


Datenbankfunktionsaufruf (dbfunction_call) (SAP-Bibliothek - Grundwissen)

Datenbankfunktionsaufruf (dbfunction_call)

Der Aufruf einer Datenbankfunktion (dbfunction_call) erfolgt wie der Aufruf einer Funktion. Die Datenbankfunktion wurde durch Ausführung einer CREATE FUNCTION-Anweisung erzeugt.

Syntax

<dbfunction_call> ::= <dbfunction_name> ( [<expression>,...] )

Beispiele

SQL-Tutorial, Strukturlink Datenbankfunktionen, Strukturlink Funktionen

Erläuterung

Der aktuelle Benutzer muss das Recht zur Ausführung der Datenbankfunktion (EXECUTE-Privileg) besitzen.

Siehe auch:

Funktionen: Überblick


Extraktion (extraction_function) (SAP-Bibliothek - Grundwissen)

Extraktion (extraction_function)

Eine Extraktion (extraction_function) ist eine Funktion, die aus einem Datums-, Zeit- oder Zeitstempelwert Teile extrahiert oder einen Datums-, Zeit- oder Zeitstempelwert bildet.

Syntax

<extraction_function> ::=
DATE ( <expression> )
| DAY ( <date_or_timestamp_expression> )
| HOUR ( <time_or_timestamp_expression> )
| MICROSECOND ( <expression> )
| MINUTE ( <time_or_timestamp_expression> )
| MONTH ( <date_or_timestamp_expression> )
| SECOND ( <time_or_timestamp_expression> )
| TIME ( <expression> )
| TIMESTAMP ( <expression>[, <expression> ] )
| YEAR ( <date_or_timestamp_expression> )

<date_or_timestamp_expression> ::= <expression>

<time_or_timestamp_expression> ::= <expression>

Beispiele

SQL-Tutorial, Strukturlink Datums- und Zeitberechnungen

Erläuterung

Das Argument date_or_timestamp_expression in einer Funktion muss als Ergebnis ein Datum, einen Zeitstempel oder einen alphanumerischen Wert liefern, der dem aktuellen Datums- oder Zeitstempelformat entspricht.

Das Argument time_or_timestamp_expression in einer Funktion muss als Ergebnis einen Zeit-, einen Zeitstempelwert oder einen alphanumerischen Wert liefern, der dem aktuellen Zeit- oder Zeitstempelformat entspricht.

Datums- und Zeitwerte stehen in verschiedenen Datums- und Zeitformaten zur Verfügung (ISO, USA, EUR, JIS, INTERNAL).

Siehe auch:

Funktionen: Überblick


DATE(a) (SAP-Bibliothek - Grundwissen)

DATE(a)

DATE(a) ist eine Funktion (Extraktion), die für den Ausdruck a einen Datumswert bildet.

 | Ergebnis Funktion DATE(a)
a ist Datumswert oder ein alphanumerischer Wert, der dem aktuellen Datumsformat entspricht | dieser Datumswert
a ist alphanumerischer Wert, der nicht dem aktuellen Datumsformat entspricht | Fehlermeldung
a ist Zeitstempelwert oder ein alphanumerischer Wert, der dem aktuellen Zeitstempelformat entspricht | der Datumswert, der Teil des Zeitstempels ist
a ist Festkomma- oder Gleitkommazahl | Datumswert, der dem x-ten Tag nach dem 31.12.0000 entspricht (x=TRUNC(a) )
a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Fehlermeldung

Beispiele

SQL-Tutorial, Funktionen


HOUR/MINUTE/SECOND(t) (SAP-Bibliothek - Grundwissen)

HOUR/MINUTE/SECOND(t)

HOUR(t), MINUTE(t) bzw. SECOND(t) sind Funktionen (Extraktion), die Stundenangabe, Minutenangabe bzw. Sekundenangabe aus dem angegebenen Zeit- oder Zeitstempelwert extrahieren.

Wert t: Der Ausdruck t in einer Funktion muss als Ergebnis einen Zeitwert, einen Zeitstempelwert oder einen alphanumerischen Wert liefern, der dem aktuellen Zeit- oder Zeitstempelformat entspricht.

 | Ergebnis der entsprechenden Funktion
HOUR(t), MINUTE(t) bzw. SECOND(t) | Numerischer Wert (Stunden, Minuten bzw. Sekunden)
t ist NULL-Wert | NULL-Wert


MICROSECOND(a) (SAP-Bibliothek - Grundwissen)

MICROSECOND(a)

MICROSECOND(a) ist eine Funktion (Extraktion), die die Mikrosekundenangabe aus dem Ausdruck a extrahiert.

Wert a: Der Ausdruck a muss ein Zeitstempelwert sein oder einen alphanumerischen Wert liefern, der dem aktuellen Zeitstempelformat entspricht.

 | Ergebnis Funktion MICROSECOND(a)
MICROSECOND(a) | Numerischer Wert (Mikrosekunden)
a ist NULL-Wert | NULL-Wert


TIME(a) (SAP-Bibliothek - Grundwissen)

TIME(a)

TIME(a) ist eine Funktion (Extraktion), die aus dem Ausdruck a einen Zeitwert bildet.

 | Ergebnis Funktion TIME(a)
a ist Zeitwert oder ein alphanumerischer Wert, der dem aktuellen Zeitformat entspricht | dieser Zeitwert
a ist alphanumerischer Wert, der nicht dem aktuellen Zeitformat entspricht | Fehlermeldung
a ist Zeitstempelwert oder ein alphanumerischer Wert, der dem aktuellen Zeitstempelformat entspricht | der Zeitwert, der Teil des Zeitstempels ist
a ist NULL-Wert | NULL-Wert


TIMESTAMP(a,b) (SAP-Bibliothek - Grundwissen)

TIMESTAMP(a,b)

TIMESTAMP(a,b) ist eine Funktion (Extraktion), die aus den Ausdrücken a und b einen Zeitstempelwert bestehend aus Datums-, Zeitwert und 0 Mikrosekunden bildet.

 | Ergebnis Funktion TIMESTAMP(a,b)
TIMESTAMP(a) | a muss Zeitstempelwert oder ein alphanumerischer Wert sein, der dem aktuellen Zeitstempelformat entspricht. Ergebnis ist dieser Zeitstempelwert.
TIMESTAMP(a,b) | a muss Datumswert, b muss Zeitwert sein (bzw. alphanumerischer Wert, der dem aktuellen Format für Datums- bzw. Zeitwerte entspricht). Ergebnis ist ein Zeitstempelwert, der aus Datumswert, Zeitwert und 0 Mikrosekunden gebildet wird.
a oder b ist NULL-Wert | NULL-Wert


YEAR/MONTH/DAY(t) (SAP-Bibliothek - Grundwissen)

YEAR/MONTH/DAY(t)

YEAR(t), MONTH(t) bzw. DAY(t) sind Funktionen (Extraktion), die Jahresangabe, Monatsangabe bzw. Tagesangabe aus dem angegebenen Datums- oder Zeitstempelwert extrahieren.

Wert t: Der Ausdruck t in einer Funktion muss als Ergebnis ein Datum, einen Zeitstempel oder einen alphanumerischen Wert liefern, der dem aktuellen Datums- oder Zeitstempelformat entspricht.

 | Ergebnis der entsprechenden Funktion
YEAR(t), MONTH(t) bzw. DAY(t) | Numerischer Wert (Jahr, Monat bzw. Tag)
t ist NULL-Wert | NULL-Wert


Spezialfunktion (special_function) (SAP-Bibliothek - Grundwissen)

Spezialfunktion (special_function)

Spezialfunktionen (special_function) sind spezielle Funktionen, die nicht auf bestimmte Datentypen beschränkt sind.

Syntax

<special_function> ::=
<case_function>
| DECODE (<check_expression>,<search_and_result_spec>,...[,<default_expression>])
| GREATEST (<expression>,<expression>,...)
| LEAST (<expression>,<expression>,...)
| VALUE (<expression>,<expression>,...)

<case_function> ::= <simple_case_function>|<searched_case_function>

<check_expression> ::= <expression>

<search_and_result_spec> ::= <search_expression>,<result_expression>

<default_expression> ::= <expression>

<result_expression> ::= <expression>

Erläuterung

Bei den CASE-Funktionen werden einfache und allgemeine CASE-Funktionen unterschieden.

Siehe auch:

Funktionen: Überblick


DECODE(x,y(i),...,z) (SAP-Bibliothek - Grundwissen)

DECODE(x,y(i),...,z)

DECODE(x,y(i),...,z) ist eine Spezialfunktion, die Ausdrücke (expression) in Abhängigkeit von ihren Werten umcodiert.

x

check_expression

Ausdruck (expression), für den ein Vergleich mit den Vergleichswerten in y(i) durchgeführt werden soll

y(i)

search_and_result_spec

<search_and_result_spec> ::= <search_expression>, <result_expression> (Kurzschreibweise: y(i)=u(i),v(i), i=1,...)

Kombination aus Vergleichswert u(i) und Wert v(i), der diesen Vergleichswert gegebenenfalls ersetzen soll

z

default_expression

Optionaler Vorschlagswert (LONG-Wert ist zulässig)

u(i)

search_expression

Vergleichswert, der bei Übereinstimmung mit x durch v(i) ersetzt werden soll

v(i)

result_expression

Wert, der den Wert u(i) gegebenenfalls ersetzen soll (LONG-Wert ist zulässig)

Beispiele

SQL-Tutorial, Strukturlink Umwandeln von Werten

Erläuterung

Die Datentypen von x und u(i) müssen vergleichbar sein. Die Datentypen von v(i) und z müssen vergleichbar sein. Die Datentypen von u(i) und v(i) müssen nicht vergleichbar sein.

DECODE vergleicht nacheinander die Werte von x mit den Werten u(i). Wird eine Übereinstimmung festgestellt, dann ist das Ergebnis von DECODE der Wert v(i), der sich in der Kombination y(i)=u(i),v(i) befunden hat.

Sind x und u(i) NULL-Werte, so wird die Übereinstimmung festgestellt. Der Vergleich zwischen dem Spezial-NULL-Wert und einem beliebigen Wert führt nie zu einer Übereinstimmung.

Wird keine Übereinstimmung festgestellt, so liefert DECODE das Ergebnis von z. Ist z nicht angegeben, dann ist der NULL-Wert das Ergebnis von DECODE.


GREATEST/LEAST(x,y,...) (SAP-Bibliothek - Grundwissen)

GREATEST/LEAST(x,y,...)

GREATEST(x,y,...) bzw. LEAST(x,y) ist eine Spezialfunktion, die den größten bzw. den kleinsten Wert aller Argumente (Ausdrücke) ermittelt.

Die Funktionen können auf beliebige Datentypen angewandt werden. Die Datentypen der einzelnen Ausdrücke müssen vergleichbar sein.

 | Ergebnis der entsprechenden Funktion
Mindestens ein Argument ist der NULL-Wert | NULL-Wert
Mindestens ein Argument ist der Spezial-NULL-Wert | Spezial-NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Informationen über Zeichenketten


VALUE(x,y,...) (SAP-Bibliothek - Grundwissen)

VALUE(x,y,...)

VALUE(x,y,...) ist eine Spezialfunktion, die verwendet werden kann, um NULL-Werte durch einen Nicht-NULL-Wert zu ersetzen.

Die Argumente (Ausdrücke) der VALUE-Funktion müssen vergleichbar sein. Die Ausdrücke werden nacheinander in der angegebenen Reihenfolge ausgewertet.

 | Ergebnis der Funktion VALUE(x,y,...)
Eines der Argumente ist ein Nicht-NULL-Wert | der erste auftretende Nicht-NULL-Wert
Jedes Argument ist Spezial-NULL-Wert | Spezial-NULL-Wert
Jedes Argument ist NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Umwandeln von Werten


Allgemeine CASE-Funktion (searched_case_function) (SAP-Bibliothek - Grundwissen)

Allgemeine CASE-Funktion (searched_case_function)

Die allgemeine CASE-Funktion (searched_case_function) ist eine Spezialfunktion, die eine Menge von Suchbedingungen untersucht, um einen Ergebnisausdruck zu bestimmen.

Syntax

<searched_case_function> ::=
CASE
WHEN <search_condition> THEN <result_expression>
    [...]
  [ELSE <default_expression>])
END

<result_expression> ::= <expression>
<default_expression> ::= <expression>

Beispiele

SQL-Tutorial, Strukturlink Funktionen

Erläuterung

CASE überprüft nacheinander die Suchbedingungen search_condition. Sowie eine Suchbedingung gefunden wird, die wahr ist, ist das Ergebnis der allgemeinen CASE-Funktion der Wert des Ausdrucks result_expression, der zur Suchbedingung gehört.

Wird keine Suchbedingung gefunden, die wahr ist, so liefert CASE das Ergebnis des Ausdrucks default_expression. Ist default_expression nicht angegeben, dann ist der NULL-Wert das Ergebnis von CASE.

Alle Suchbedingungen ohne ROWNO-Prädikat sind zulässig. Die Datentypen der Ausdrücke result_expression und default_expression müssen vergleichbar sein.

Siehe auch:

Einfache CASE-Funktion (simple_case_function)


Einfache CASE-Funktion (simple_case_function) (SAP-Bibliothek - Grundwissen)

Einfache CASE-Funktion (simple_case_function)

Die einfache CASE-Funktion (simple_case_function) ist eine Spezialfunktion, die einen Ausdruck mit einer Menge einfacher Ausdrücke vergleicht, um einen Ergebnisausdruck zu bestimmen.

Syntax

<simple_case_function> ::=
CASE <check_expression>
WHEN <search_expression> THEN <result_expression>
[...]
[ELSE <default_expression>])
END

<check_expression> ::= <expression>
<search_expression> ::= <expression>
<result_expression> ::= <expression>
<default_expression> ::= <expression>

Beispiele

SQL-Tutorial, Strukturlink Funktionen

Erläuterung

CASE vergleicht nacheinander den Wert des Vergleichsausdrucks check_expression mit den Werten der Ausdrücke search_expression. Wird eine Übereinstimmung festgestellt, dann ist das Ergebnis der einfachen CASE-Funktion der Wert des Ausdrucks result_expression, der zum Ausdruck search_expression gehört.

Wird keine Übereinstimmung festgestellt, so liefert CASE das Ergebnis des Ausdrucks default_expression. Ist default_expression nicht angegeben, dann ist der NULL-Wert das Ergebnis von CASE.

Die Datentypen von check_expression und search_expression müssen vergleichbar sein. Die Datentypen von result_expression und default_expression müssen vergleichbar sein. Die Datentypen von search_expression und result_expression müssen nicht vergleichbar sein.

Sind die Werte der Ausdrücke check_expression und search_expression NULL-Werte, so wird die Übereinstimmung festgestellt. Der Vergleich zwischen dem Spezial-NULL-Wert und einem beliebigen Wert führt nie zu einer Übereinstimmung.

Siehe auch:

Allgemeine CASE-Funktion (searched_case_function)


Stringfunktion (string_function) (SAP-Bibliothek - Grundwissen)

Stringfunktion (string_function)

Eine Stringfunktion (string_function) ist eine Funktion, die als Ergebnis einen alphanumerischen Wert liefert.

Syntax

<string_function> ::=
<string_spec> || <string_spec>
| <string_spec> & <string_spec>
| ALPHA     (<string_spec>[,<unsigned_integer>])
| ASCII     (<string_spec>)
| EXPAND    (<string_spec>,<unsigned_integer>)
| GET_OBJECTNAME (<string_literal>)
| GET_SCHEMA     (<string_literal>)
| INITCAP   (<string_spec>)
| LFILL     (<string_spec>,<string_literal>[,<unsigned_integer>])
| LOWER     (<string_spec>)
| LPAD      (<string_spec>,<expression>,<string_literal>[,<unsigned_integer>])
| LTRIM     (<string_spec>[,<string_spec>])
| MAPCHAR   (<string_spec>[,<unsigned_integer>][,<mapchar_set_name>])
| REPLACE   (<string_spec>,<string_spec>[,<string_spec>])
| RFILL     (<string_spec>,<string_literal>[,<unsigned_integer>])
| RPAD      (<string_spec>,<expression>,<string_literal>[,<unsigned_integer>])
| RTRIM     (<string_spec>[,<string_spec>])
| SOUNDEX   (<string_spec>)
| SUBSTR    (<string_spec>,<expression>[,<expression>])
| TRANSLATE (<string_spec>,<string_spec>,<string_spec>)
| TRIM      (<string_spec>[,<string_spec>])
| UPPER     (<string_spec>)

<string_spec> ::= <expression>

Erläuterung

Mit Hilfe von <string_spec> || <string_spec> oder <string_spec> & <string_spec> wird eine Verkettung (x||y bzw x&y) dargestellt.

Als Stringspezifikation (string_spec) sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert haben.

Siehe auch:

Funktionen: Überblick


ALPHA(x,n) (SAP-Bibliothek - Grundwissen)

ALPHA(x,n)

ALPHA(x,n) ist eine Stringfunktion, die das Umsetzen eines Zeichens x (Stringspezifikation), das in ASCII verschlüsselt ist, in eine andere in der DEFAULTMAP (mapchar_set_name) festgelegte Ein- oder Zwei-Zeichendarstellung ermöglicht. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

ALPHA(x,n) wird verwendet, um die Sortierreihenfolge zu beeinflussen.

Die Funktion ALPHA(x,n) greift intern auf die Funktion MAPCHAR(x,n,i) zurück (wobei i die DEFAULTMAP ist) und nimmt zusätzlich eine Umwandlung in Großbuchstaben vor (UPPER(x)).

Die Angabe von n, einer ganzen Zahl ohne Vorzeichen, ist optional. n gibt die maximale Länge des Ergebnisses an.

 | Ergebnis der Funktion ALPHA(x,n)
ALPHA(x,n) | UPPER(MAPCHAR(x,n,DEFAULTMAP))

Die Funktion ALPHA ermöglicht eine sinnvolle Sortierung, z.B. wenn "ü" als "UE" einsortiert werden soll. Es wird das Mapchar-Set mit dem Namen DEFAULTMAP verwendet.

SELECT...,ALPHA(<column_name>) sort,...FROM...ORDER BY sort


ASCII(x) (SAP-Bibliothek - Grundwissen)

ASCII(x)

ASCII(x) ist eine Stringfunktion, die eine Zeichenkette x (Stringspezifikation) mit dem Codeattribut ASCII, UNICODE (falls diese ASCII-Daten sind) oder BYTE in ASCII-Daten umwandelt. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

 | Ergebnis der Funktion ASCII(x)
x ist vom Datentyp CHAR oder VARCHAR, Codeattribut für x ist ASCII, UNICODE oder BYTE | ASCII(x) ist eine Zeichenkette in ASCII-Darstellung
x ist NULL-Wert | NULL-Wert

Die Anwendung der Funktionen ASCII ist dann sinnvoll, wenn eine Sortierung oder ein Vergleich im ASCII-Code durchgeführt werden soll.

Ausgabe einer sortierten Ergebnistabelle in ASCII-Reihenfolge:

SELECT ASCII(name) FROM...WHERE...ORDER BY 1


EXPAND(x,n) (SAP-Bibliothek - Grundwissen)

EXPAND(x,n)

EXPAND(x,n) ist eine Stringfunktion, die am Ende der Zeichenkette x (Stringspezifiaktion) so viele Leerzeichen (Codedeattribut ASCII, UNICODE) bzw. binäre Nullen (Codeattribut BYTE) anfügt, bis eine Länge erreicht ist, die durch n, eine ganze Zahl ohne Vorzeichen, festgelegt ist. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

 | Ergebnis der Funktion EXPAND(x,n)
x ist NULL-Wert | NULL-Wert

Siehe auch:

LFILL(x,a,n)

RFILL(x,a,n)


GET_OBJECTNAME(x,o) (SAP-Bibliothek - Grundwissen)

GET_OBJECTNAME(x,o)

Die Stringfunktion GET_OBJECTNAME(x,o) liefert den Namen des Datenbankobjekts.

Bezeichnung des Objekts: x

Das Argument x ist ein Stringliteral der Form [<schema_name>.]<identifier> bzw. ein Character-Parameter dieser Art. Schema schema_name bzw. Bezeichner identifier können spezielle Bezeichner sein.

Objekttyp: o

Sie können eines der folgenden Schlüsselworte verwenden:

· DBPROC[EDURE]: Datenbankprozedur

· DOMAIN: Wertebereich

· SEQUENCE: Sequenz

· SYNONYM: Synonym

· VIEW: View-Tabelle

· TABLE: Tabelle

 | Ergebnis der Funktion GET_OBJECTNAME(x,o)
x bezeichnet ein Objekt, das nicht vom Objekttyp o ist | NULL-Wert
Das Objekt x existiert nicht | NULL-Wert
Das Objekt x existiert, jedoch besitzt der aktuelle Benutzer keinerlei Privilegien für dieses Objekt | NULL-Wert
Das Objekt x existiert für das unter schema_name angegebenen Schema und der aktuelle Benutzer besitzt irgendein Privileg für dieses Objekt | identifier
Das Objekt x existiert und der aktuelle Benutzer besitzt irgendein Privileg für dieses Objekt | In der Suchhierarchie zuerst gefundener Objektname

Für einige Objekttypen gibt es keine Suchhierarchie. In diesem Fall wird das Objekt nur im Schema des aktuellen Benutzers gesucht.


GET_SCHEMA(x,o) (SAP-Bibliothek - Grundwissen)

GET_SCHEMA(x,o)

Die Stringfunktion GET_SCHEMA(x,o) liefert den Namen des Schemas des angegebenen Datenbankobjekts.

Bezeichnung des Objekts: x

Das Argument x ist ein Stringliteral der Form [<schema_name>.]<identifier> bzw. ein Character-Parameter dieser Art. Schema schema_name bzw. Bezeichner identifier können spezielle Bezeichner sein.

Objekttyp: o

Sie können eines der folgenden Schlüsselworte verwenden:

· DBPROC[EDURE]: Datenbankprozedur

· DOMAIN: Wertebereich

· SEQUENCE: Sequenz

· SYNONYM: Synonym

· VIEW: View-Tabelle

· TABLE: Tabelle

 | Ergebnis der Funktion GET_SCHEMA(x,o)
x bezeichnet ein Objekt, das nicht vom Objekttyp o ist | NULL-Wert
Das Objekt x existiert nicht | NULL-Wert
Das Objekt x existiert, jedoch besitzt der aktuelle Benutzer keinerlei Privilegien für dieses Objekt | NULL-Wert
Das Objekt x existiert für das unter schema_name angegebene Schema und der aktuelle Benutzer besitzt irgendein Privileg für dieses Objekt | schema_name
Das Objekt x existiert und der aktuelle Benutzer besitzt irgendein Privileg für dieses Objekt | In der Suchhierarchie zuerst gefundenes Schema dieses Objekts

Für einige Objekttypen gibt es keine Suchhierarchie. In diesem Fall wird das Objekt nur im Schema des aktuellen Benutzers gesucht.


INITCAP(x) (SAP-Bibliothek - Grundwissen)

INITCAP(x)

INITCAP(x) ist eine Stringfunktion, die eine Zeichenkette x (Stringspezifikation) so ändert, dass jeweils der erste Buchstabe eines Wortes ein Grossbuchstabe ist, der Rest Kleinbuchstaben. Wörter werden dabei durch ein oder mehrere Zeichen getrennt, die zur Zeichenmenge des 7-Bit-ASCII gehören und weder Buchstaben noch Ziffern sind (z.B. Komma, Leerzeichen, Doppelpunkt; eine Liste der Buchstaben und Ziffern finden Sie in Zeichen (character)). Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

 | Ergebnis der Funktion INITCAP(x)
x ist NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Informationen über Zeichenketten


LFILL(x,a,n) (SAP-Bibliothek - Grundwissen)

LFILL(x,a,n)

LFILL(x,a,n) ist eine Stringfunktion, die an den Anfang der Zeichenkette x (Stringspezifikation) die Zeichenkette a (Stringliteral) so oft einfügt, bis die Zeichenkette die Länge n (ganze Zahl ohne Vorzeichen) erreicht. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

Kann die Zeichenkette a nicht vollständig eingefügt werden, ohne die angegebene Gesamtlänge zu überschreiten, so wird von ihr nur der Teil eingefügt, der zum Erreichen der Gesamtlänge notwendig ist.

 | Ergebnis der Funktion LFILL(x,a,n)
LFILL(x,a) x muss eine CHAR- oder VARCHAR-Spalte bezeichnen. | Die Spalte x wird bis zu ihrer Maximallänge mit den Zeichen von a aufgefüllt.
x ist NULL-Wert | NULL-Wert
a oder n ist NULL-Wert | Fehlermeldung

Beispiele

SQL-Tutorial, Strukturlink Verändern von Zeichenketten

Siehe auch:

RFILL(x,a,n)

EXPAND(x,n)


LPAD(x,a,y,n) (SAP-Bibliothek - Grundwissen)

LPAD(x,a,y,n)

LPAD(x,a,y,n) ist eine Stringfunktion, die an den Anfang der Zeichenkette x (Stringspezifikation) die Zeichenkette y (Stringliteral) so oft einfügt, wie es der Ausdruck a angibt. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern. Das Ergebnis des Ausdrucks a muss eine nicht-negative ganze Zahl sein.

In der Zeichenkette x werden führende und nachfolgende Leerzeichen abgeschnitten.

Der optionale Parameter n (ganze Zahl ohne Vorzeichen) definiert die maximale Gesamtlänge der entstehenden Zeichenkette. n muss größer oder gleich der Summe LENGTH(x)+a*LENGTH(y) sein.

 | Ergebnis der Funktion LPAD(x,a,y,n)
LPAD(x,a,y) x muss eine CHAR- oder VARCHAR-Spalte bezeichnen. | Die Zeichenkette erhält als Maximallänge die Länge der Zeichenkette x.
x oder a ist NULL-Wert | NULL-Wert
a ist der Spezial-NULL-Wert | Fehlermeldung

SELECT hno, LPAD(' ',TRUNC(price/10),'*',70) graph
FROM room WHERE price > 150 ORDER BY price DESC

Erzeugen von Balkendiagrammen: LPAD fügt vor dem ersten Parameter (hier ein Leerzeichen) Sternchen ein. Dies geschieht in der Anzahl des durch 10 dividierten Preises.

HNO | GRAPH
130 | **********************************************************************
140 | ************************************************************
50 | **************************************************
60 | **************************************************
150 | *********************************************
80 | ****************************************
120 | ***********************************
90 | ******************************
130 | ***************************
10 | ********************
60 | ********************
140 | ********************
150 | *******************
50 | ******************
70 | ******************
130 | ****************

Siehe auch:

RPAD(x,a,y,n)


LTRIM(x,y) (SAP-Bibliothek - Grundwissen)

LTRIM(x,y)

LTRIM(x,y) ist eine Stringfunktion, die am Anfang der Zeichenkette x (Stringspezifikation) alle in der Zeichenkette y (Stringspezifikation) angegebenen Zeichen entfernt.

Das Ergebnis von LTRIM(x,y) beginnt daher mit dem ersten Zeichen, das nicht in y angegeben wurde. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

 | Ergebnis der Funktion LTRIM(x,y)
LTRIM(x) | Es werden nur die Leerzeichen (Codeattribut ASCII, UNICODE) aus x entfernt.
x ist NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Verändern von Zeichenketten

Siehe auch:

TRIM(x,y)

RTRIM(x,y)


MAPCHAR(x,n,i) (SAP-Bibliothek - Grundwissen)

MAPCHAR(x,n,i)

MAPCHAR(x,n,i) ist eine Stringfunktion, die das Umsetzen von länderspezifischen Buchstaben in eine andere Repräsentation ermöglicht (z.B. die deutschen Umlaute, französische Buchstaben mit Accent grave).

MAPCHAR(x,n,i) setzt die Zeichenkette x (Stringspezifikation) unter Zuhilfenahme des Mapchar-Sets mit dem Namen i (mapchar_set_name) um. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern. Wenn kein Mapchar-Set-Name angegeben wird, wird das Mapchar-Set mit dem Namen DEFAULTMAP (definiert für ASCII-Code) verwendet.

Der der Zeichenkette x und dem verwendeten Mapchar-Set zugrundeliegende Code muss übereinstimmen.

Der Parameter n (ganze Zahl ohne Vorzeichen) ist optional und gibt die maximale Länge des Ergebnisses an.

 | Ergebnis der Funktion MAPCHAR(x,n,i)
MAPCHAR(x,i) | MAPCHAR(x,n,i), wobei n die Länge der Zeichenkette x ist
MAPCHAR(x,i) x ist CHAR- oder VARCHAR-Spalte | MAPCHAR(x,n,i), wobei n die Länge der Spalte x ist
MAPCHAR(x) | MAPCHAR(x,DEFAULTMAP)
x ist NULL-Wert | NULL-Wert

Die Funktion MAPCHAR ermöglicht eine sinnvolle Sortierung, z.B. wenn "ü" als "ue" einsortiert werden soll. Es wird das Mapchar-Set mit dem Namen DEFAULTMAP verwendet.

SELECT...,MAPCHAR(<column_name>) sort,...FROM...ORDER BY sort


REPLACE(x,y,z) (SAP-Bibliothek - Grundwissen)

REPLACE(x,y,z)

REPLACE(x,y,z) ist eine Stringfunktion, die in der Zeichenkette x die Zeichenkette y durch die Zeichenkette z ersetzt. Alle Zeichenketten sind Stringspezifikationen. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

 | Ergebnis der Funktion REPLACE(x,y,z)
REPLACE(x,y) | Die Zeichenkette y wird in x gelöscht
x ist NULL-Wert | NULL-Wert
y ist NULL-Wert | x bleibt unverändert
z ist NULL-Wert | Die Zeichenkette y wird in x gelöscht

Beispiele

SQL-Tutorial, Strukturlink Verändern von Zeichenketten

Siehe auch:

TRANSLATE(x,y,z)


RFILL(x,a,n) (SAP-Bibliothek - Grundwissen)

RFILL(x,a,n)

RFILL(x,a,n) ist eine Stringfunktion, die an das Ende der Zeichenkette x (Stringspezifikation) die Zeichenkette a (Stringliteral) so oft einfügt, bis die Zeichenkette die Länge n (ganze Zahl ohne Vorzeichen) erreicht. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

Kann die Zeichenkette a nicht vollständig eingefügt werden, ohne die angegebene Gesamtlänge zu überschreiten, so wird von ihr nur der Teil eingefügt, der zum Erreichen der Gesamtlänge notwendig ist.

 | Ergebnis der Funktion RFILL(x,a,n)
RFILL(x,a) x muss eine CHAR- oder VARCHAR-Spalte bezeichnen. | Die Spalte x wird bis zu ihrer Maximallänge mit den Zeichen von a aufgefüllt.
x ist NULL-Wert | NULL-Wert
a oder n ist NULL-Wert | Fehlermeldung

Beispiele

SQL-Tutorial, Strukturlink Verändern von Zeichenketten

Siehe auch:

LFILL(x,a,n)

EXPAND(x,n)


RPAD(x,a,y,n) (SAP-Bibliothek - Grundwissen)

RPAD(x,a,y,n)

RPAD(x,a,y,n) ist eine Stringfunktion, die an das Ende der Zeichenkette x (Stringspezifikation) die Zeichenkette y (Stringliteral) so oft einfügt, wie es der Ausdruck a angibt. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern. Das Ergebnis des Ausdrucks a muss eine nicht-negative ganze Zahl sein.

In der Zeichenkette x werden führende und nachfolgende Leerzeichen abgeschnitten.

Der optionale Parameter n (ganze Zahl ohne Vorzeichen) definiert die maximale Gesamtlänge der dabei entstehenden Zeichenkette. n muss größer oder gleich der Summe LENGTH(x)+a*LENGTH(y) sein.

 | Ergebnis der Funktion RPAD(x,a,y,n)
RPAD(x,a,y) x muss eine CHAR- oder VARCHAR-Spalte bezeichnen. | Die Zeichenkette erhält als Maximallänge die Länge der Zeichenkette x.
x oder a ist NULL-Wert | NULL-Wert
a ist der Spezial-NULL-Wert | Fehlermeldung

Siehe auch:

LPAD(x,a,y,n)


RTRIM(x,y) (SAP-Bibliothek - Grundwissen)

RTRIM(x,y)

RTRIM(x,y) ist eine Stringfunktion, die am Ende der Zeichenkette x (Stringspezifikation) die Leerzeichen (Codeattribut ASCII, UNICODE) und anschließend alle in der Zeichenkette y (Stringspezifikation) angegebenen Zeichen entfernt.

Das Ergebnis von RTRIM(x,y) endet daher mit dem letzten Zeichen, das nicht in y angegeben wurde. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

 | Ergebnis der Funktion RTRIM(x,y)
RTRIM(x) | Es werden nur die Leerzeichen (Codeattribut ASCII, UNICODE) aus x entfernt.
x ist NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Verändern von Zeichenketten

Siehe auch:

TRIM(x,y)

LTRIM(x,y)


SOUNDEX(x) (SAP-Bibliothek - Grundwissen)

SOUNDEX(x)

SOUNDEX(x) ist eine Stringfunktion, die eine Zeichenkette x (Stringspezifikation) in eine Repräsentation umsetzt, die der sogenannte Soundex-Algorithmus erzeugt. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

Diese Darstellung kann verwendet werden, wenn der Anwender die Schreibweise eines Suchbegriffs nicht genau kennt.

 | Ergebnis der Funktion SOUNDEX(x)
SOUNDEX(x) | Anwendung des Soundex-Algorithmus, Ergebnis ist ein Wert vom Datentyp CHAR(4)
x ist NULL-Wert | NULL-Wert

Das SOUNDS-Prädikat wird häufig auf eine Spalte x angewandt.

Da dabei Invertierungen nicht ausgenutzt werden können, empfiehlt es sich aus Performancegründen zusätzlich eine Tabellenspalte x1 vom Datentyp CHAR(4) zu definieren, in die das Ergebnis von SOUNDEX(x) eingefügt wird.

Eine SQL-Anweisung sollte sich dann auf die Spalte x1 beziehen:
verwenden Sie nicht x SOUNDS LIKE <string_literal>,
sondern x1= SOUNDEX(<string_literal>)


SUBSTR(x,a,b) (SAP-Bibliothek - Grundwissen)

SUBSTR(x,a,b)

SUBSTR(x,a,b) ist eine Stringfunktion, die einen Teilbereich der Zeichenkette x (Stringspezifikation der Länge n) ausgibt. Als Stringspezifikation x sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern. LONG-Werte sind zulässig. Wenn x ein LONG-Wert ist, müssen Sie die Länge b des gewünschten Teilbereiches angeben.

a und b sind Ausdrücke. Der Wert b darf nicht größer als die Spaltendefinition für eine CHAR-Spalte sein.

 | Ergebnis der Funktion SUBSTR(x,a,b)
SUBSTR(x,a,b) | Teil der Zeichenkette x, der an dem a-ten Zeichen beginnt und b Zeichen lang ist.
SUBSTR(x,a) | SUBSTR(x,a,n-a+1) – liefert alle Zeichen der Zeichenkette x vom a-ten Zeichen bis zum letzten (n-ten) Zeichen.
b ist einer ganze Zahl ohne Vorzeichen | SUBSTR(x,a,b) Für b ist auch ein Wert zulässig, der größer als (n-a+1) ist.
b ist keine ganze Zahl ohne Vorzeichen | SUBSTR(x,a,b) b darf den Wert (n-a+1) nicht übersteigen.
b>(n-a+1) | SUBSTR(x,a) An dieses Ergebnis werden am Ende so viele Leerzeichen (Codeattribut ASCII, UNICODE) bzw. binäre Nullen (Codeattribut BYTE) angefügt, bis das Ergebnis die Länge b hat.
x, a oder b sind NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Funktionen, Strukturlink Verändern von Zeichenketten


TRANSLATE(x,y,z) (SAP-Bibliothek - Grundwissen)

TRANSLATE(x,y,z)

TRANSLATE(x,y,z) ist eine Stringfunktion, die in der Zeichenkette x das i-te Zeichen der Zeichenkette y durch das i-te Zeichen der Zeichenkette z ersetzt. Die Länge der Zeichenkette y muss mit der Länge der Zeichenkette z übereinstimmen. x, y und z sind Stringspezifikationen. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

 | Ergebnis der Funktion TRANSLATE(x,y,z)
x ist NULL-Wert | NULL-Wert
y ist NULL-Wert | x bleibt unverändert

Beispiele

SQL-Tutorial, Strukturlink Verändern von Zeichenketten

Siehe auch:

REPLACE(x,y,z)


TRIM(x,y) (SAP-Bibliothek - Grundwissen)

TRIM(x,y)

TRIM(x,y) ist eine Stringfunktion, die am Anfang der Zeichenkette x alle in der Zeichenkette y angegebenen Zeichen entfernt. Das Ergebnis von TRIM(x,y) beginnt daher mit dem ersten Zeichen, das nicht in y angegeben wurde.

Zusätzlich entfernt TRIM(x,y) am Ende der Zeichenkette x die Leerzeichen (Codeattribut ASCII, UNICODE) und anschließend alle in der Zeichenkette y angegebenen Zeichen. Das Ergebnis von TRIM(x,y) endet daher mit dem letzten Zeichen, das nicht in y angegeben wurde.

 | Ergebnis der Funktion TRIM(x,y)
TRIM(x) | Es werden nur die Leerzeichen (Codeattribut ASCII, UNICODE) aus x entfernt.
x ist NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Verändern von Zeichenketten

Siehe auch:

LTRIM(x,y)

RTRIM(x,y)


UPPER/LOWER(x) (SAP-Bibliothek - Grundwissen)

UPPER/LOWER(x)

UPPER(x) bzw. LOWER(x) sind Stringfunktionen, die eine Zeichenkette x (Stringspezifiaktion) in Großbuchstaben bzw. Kleinbuchstaben verwandelt. Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

 | Ergebnis der Funktion UPPER(x) bzw. LOWER(x)
x ist NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Umwandeln von Werten


Verkettung (concatenation) (SAP-Bibliothek - Grundwissen)

Verkettung (concatenation)

Eine Verkettung (concatenation) x||y bzw. x&y ist eine Stringfunktion, die folgende Ergebnisse für die Zeichenkette x (Stringspezifikation der Länge n) und die Zeichenkette y (Stringspezifikation der Länge m) liefert:

 | Ergebnis der Verkettung
x||y bzw. x&y | Verkettung von x und y zu einer Zeichenkette der Länge n+m Wenn eine Zeichenkette aus einer Spalte hervorgeht, dann erfolgt die Längenbestimmung dieser Zeichenkette ohne Berücksichtigung von nachfolgenden Leerzeichen (Codeattribut ASCII, UNICODE) bzw. binären Nullen (Codeattribut BYTE).
x oder y ist NULL-Wert | NULL-Wert

Beispiele

SQL-Tutorial, Strukturlink Funktionen, Strukturlink Verändern von Zeichenketten

Erläuterung

Als Stringspezifikation sind nur Ausdrücke erlaubt, die als Ergebnis einen alphanumerischen Wert liefern.

Spalten mit gleichem Codeattribut können miteinander verkettet werden.

Spalten mit unterschiedlichen Codeattributen ASCII und UNICODE können miteinander und mit Datums-, Zeit- und Zeitstempelwerten verkettet werden.


Zeitfunktion (time_function) (SAP-Bibliothek - Grundwissen)

Zeitfunktion (time_function)

Eine Zeitfunktion (time_function) ist eine Funktion, die auf Zeit- oder Zeitstempelwerten angewandt wird bzw. als Ergebnis einen Zeit- oder Zeitstempelwert liefert.

Syntax

<time_function> ::=
ADDTIME ( <time_or_timestamp_expression>, <time_expression> )
| MAKETIME ( <hours>, <minutes>, <seconds> )
| SUBTIME ( <time_or_timestamp_expression>, <time_expression> )
| TIMEDIFF ( <time_or_timestamp_expression>, <time_or_timestamp_expression> )

<time_or_timestamp_expression> ::= <expression>
<time_expression> ::= <expression>

<hours> ::= <expression>
<minutes> ::= <expression>
<seconds> ::= <expression>

Beispiele

SQL-Tutorial, Strukturlink Datums- und Zeitberechnungen

Erläuterung

Das Argument time_or_timestamp_expression in einer Funktion muss als Ergebnis einen Zeitwert, einen Zeitstempelwert oder einen alphanumerischen Wert liefern, der dem aktuellen Zeit- oder Zeitstempelformat entspricht.

Das Argument time_expression in einer Funktion muss als Ergebnis einen Zeitwert oder einen alphanumerischen Wert liefern, der dem aktuellen Zeitformat entspricht.

Jedes der Argumente hours, minutes oder seconds in einer Funktion muss ganzzahlig und größer oder gleich 0 sein. Wenn ein Argument nicht ganzzahlig ist, werden die Nachkommastellen abgeschnitten.

Datums- und Zeitwerte stehen in verschiedenen Datums- und Zeitformaten zur Verfügung (ISO, USA, EUR, JIS, INTERNAL).

In den Formaten ISO und USA werden die Stunden modulo 24 ausgegeben.
In den Formaten EUR und JIS führen Stundenangaben >99 zu einem Fehler.
Im Format INTERNAL können Stundenangaben bis 9999 verwendet werden.

Siehe auch:

Funktionen: Überblick


ADDTIME/SUBTIME(t,a) (SAP-Bibliothek - Grundwissen)

ADDTIME/SUBTIME(t,a)

ADDTIME(t,a) bzw. SUBTIME(t,a) sind Zeitfunktionen, die einen Zeit-/Zeitstempelwert der Zukunft bzw. der Vergangenheit ermitteln.

Wert t: Der Ausdruck t (time_or_timestamp_expression) in einer Funktion muss als Ergebnis einen Zeit-, einen Zeitstempelwert oder einen alphanumerischen Wert liefern, der dem aktuellen Zeit- oder Zeitstempelformat entspricht.

Wert a: Der Ausdruck a (time_expression) in einer Funktion muss als Ergebnis einen Zeitwert oder einen alphanumerischen Wert liefern, der dem aktuellen Zeitformat entspricht.

 | Ergebnis der Funktion ADDTIME(t,a)/SUBTIME(t,a)
Addition von a zu t/ Subtraktion von a von t | Zeit- bzw. Zeitstempelwert
SUBTIME(t,a) und t und a sind Zeitwerte | a muss kleiner sein als t, andernfalls wird ein Fehler gemeldet
t oder a ist NULL-Wert | NULL-Wert


MAKETIME(h,m,s) (SAP-Bibliothek - Grundwissen)

MAKETIME(h,m,s)

MAKETIME(h,m,s) ist eine Zeitfunktion, die aus der Summe von Stunden, Minuten und Sekunden einen Zeitwert bildet.

Werte h, m und s: Jeder der Ausdrücke h, m oder s in der Funktion muss ganzzahlig und größer oder gleich 0 sein. Wenn ein Ausdruck nicht ganzzahlig ist, werden die Nachkommastellen abgeschnitten.

 | Ergebnis der Funktion MAKETIME(h,m,s)
h,m,s ist NULL-Wert | NULL-Wert
h,m,s ist Spezial-NULL-Wert | Fehlermeldung


TIMEDIFF(t,s) (SAP-Bibliothek - Grundwissen)

TIMEDIFF(t,s)

TIMEDIFF(t,s) ist eine Zeitfunktion, die den Zeitwert zwischen Anfangs- und Endzeit ermittelt.

Werte t und s: Die Ausdrücke t und s in der Funktion müssen als Ergebnis einen Zeitwert, einen Zeitstempelwert oder einen alphanumerischen Wert liefern, der dem aktuellen Zeit- oder Zeitstempelformat entspricht. Beide Argumente müssen vom gleichen Datentyp sein, also entweder einen Zeit- oder einen Zeitstempelwert darstellen.

 | Ergebnis der Funktion TIMEDIFF(t,s)
Positive Differenz zwischen t und s | Zeitwert
t oder s sind Zeitstempelwerte bzw. alphanumerische Werte, die dem aktuellen Zeitstempelformat entsprechen | Die im Zeitstempelwert enthaltenen Datumsangaben werden berücksichtigt, um TIMEDIFF(t,s) zu berechnen.
Differenz von mehr als 9999 Stunden | Anzahl der Stunden modulo 10000
t oder s ist NULL-Wert | NULL-Wert


Trigonometrische Funktion (trigonometric_function) (SAP-Bibliothek - Grundwissen)

Trigonometrische Funktion (trigonometric_function)

Eine trigonometrische Funktion (trigonometric_function) ist eine Funktion, die als Ergebnis einen numerischen Wert liefert.

Syntax

<trigonometric_function> ::=
COS ( <expression> )
| SIN ( <expression> )
| TAN ( <expression> )
| COT ( <expression> )
| COSH ( <expression> )
| SINH ( <expression> )
| TANH ( <expression> )
| ACOS ( <expression> )
| ASIN ( <expression> )
| ATAN ( <expression> )
| ATAN2 ( <expression>, <expression> )
| RADIANS ( <expression> )
| DEGREES ( <expression> )

Erläuterung

Alle Ausdrücke (expression), im folgenden bezeichnet mit a und b, in allen trigonometrischen Funktionen bezeichnen eine Angabe in Bogenmaß. Einzige Ausnahme ist die Funktion RADIANS.

 | Ergebnis der trigonometrischen Funktion
a ist NULL-Wert | NULL-Wert
a ist Spezial-NULL-Wert | Spezial-NULL-Wert
COS(a) | Kosinus der Zahl a
SIN(a) | Sinus der Zahl a
TAN(a) | Tangens der Zahl a
COT(a) | Kotangens der Zahl a
COSH(a) | Kosinus hyperbolicus der Zahl a
SINH(a) | Sinus hyperbolicus der Zahl a
TANH(a) | Tangens hyperbolicus der Zahl a
ACOS(a) | Arcus Kosinus der Zahl a
ASIN(a) | Arcus Sinus der Zahl a
ATAN(a) | Arcus Tangens der Zahl a
ATAN2(a,b) | Arcus Tangens des Wertes a/b, wenn -p<=a<=+p und -p<=b<=+p
ASIN(a) | Arcus Sinus der Zahl a
RADIANS(a) | Bogenmaß der Zahl a
DEGREES(a) | Gradmaß der Zahl a

Siehe auch:

Funktionen: Überblick


Join-Tabelle (joined_table) (SAP-Bibliothek - Grundwissen)

Join-Tabelle (joined_table)

Die Angabe einer Join-Tabelle (joined_table) ist ein möglicher Bestandteil einer FROM TABLE-Spezifikation from_table_spec.

Syntax

<joined_table> ::=
<from_table_spec> CROSS JOIN <from_table_spec>
| <from_table_spec> [INNER] JOIN <from_table_spec> <join_spec>
| <from_table_spec> [LEFT [OUTER] | RIGHT [OUTER] | FULL [OUTER]] JOIN <from_table_spec> <join_spec>

<join_spec> ::= ON <search_condition>

Erläuterung

Besteht eine FROM TABLE-Spezifikation aus einer Join-Tabelle, so wird das Ergebnis wie folgt erzeugt:

Sei FT1 die Menge aller Zeilen der Tabelle, die durch die erste FROM TABLE-Spezifikation angegeben wird. FT2 sei die Menge aller Zeilen der Tabelle, die durch die zweite FROM TABLE-Spezifikation angegeben wird.

● Wenn die Join-Tabelle als CROSS JOIN angegeben ist, wird eine Tabelle erzeugt, die aus allen möglichen Kombinationen von FT1 und FT2 besteht. Es wird also im mathematischen Sinn das kartesische Produkt beider Tabellen gebildet.

● Wenn die Join-Tabelle mit dem Schlüsselwort JOIN ohne Angabe der optionalen Schlüsselwörter INNER, LEFT, RIGHT, FULL oder OUTER angegeben wird, so wird als Join-Typ INNER angenommen.

Sei T die Menge von Ergebniszeilen, die aus allen möglichen Kombinationen von FT1 und FT2 besteht und für die gilt, dass jede Ergebniszeile die JOIN-Spezifikation join_spec erfüllt.

● Wenn die Join-Tabelle mit dem Join-Typ INNER angegeben wird, ist das Ergebnis die Menge T.

● Wenn die Join-Tabelle mit dem Join-Typ LEFT angegeben wird, ist das Ergebnis die Menge T ergänzt um jene Zeilen aus FT1, die nicht in T eingegangen sind. Die nicht aus FT1 gebildeten Ergebnisspalten erhalten den NULL-Wert.

● Wenn die Join-Tabelle mit dem Join-Typ RIGHT angegeben wird, ist das Ergebnis die Menge T ergänzt um jene Zeilen aus FT2, die nicht in T eingegangen sind. Die nicht aus FT2 gebildeten Ergebnisspalten erhalten den NULL-Wert.

● Wenn Join-Tabelle mit dem Join-Typ FULL angegeben wird, ist das Ergebnis die Menge T ergänzt um jene Zeilen, die durch die Join-Typen LEFT und RIGHT hinzugefügt werden.

Für die JOIN-Spezifikation ON <search_condition> gelten die für die WHERE-Bedingung angegebenen Regeln mit der Einschränkung, dass keine Verknüpfungen mit dem booleschen Operator OR zugelassen sind.

Siehe auch:

JOIN-Prädikat (join_predicate)

Änderbare Join-View-Tabelle (CREATE VIEW-Anweisung)

Join-View-Tabelle in INSERT-Anweisungen


Schlüsselspezifikation (key_spec) (SAP-Bibliothek - Grundwissen)

Schlüsselspezifikation (key_spec)

Eine Schlüsselspezifikation (key_spec) ermöglicht das Finden einer bestimmten Tabellenzeile, deren Schlüsselspaltenwerte den in den Schlüsselspezifikationen angegebenen Werten entsprechen. Eine Zeile mit den angegebenen Schlüsselwerten muss nicht existieren.

Syntax

<key_spec> ::= <column_name> = <value_spec>

Erläuterung

Die Spezifikation von Werten value_spec darf nicht NULL sein.

Der Spaltenname column_name muss eine Schlüsselspalte der Tabelle bezeichnen.

Die Angabe eines Schlüssels muss alle Schlüsselspalten einer Tabelle enthalten. Dabei werden die einzelnen Schlüsselspezifikationen key_spec durch Kommas getrennt angegeben.

Für Tabellen, die ohne Schlüsselspalten definiert wurden, gibt es eine implizit angelegte Spalte SYSKEY CHAR(8) BYTE, die einen vom Datenbanksystem integrierten Schlüssel enthält. Diese Spalte kann in einer Schlüsselspezifikation verwendet werden.

Eine Schlüsselspezifikation wird in folgenden SQL-Anweisungen verwendet:

UPDATE-Anweisung (update_statement), DELETE-Anweisung (delete_statement), LOCK-Anweisung (lock_statement), UNLOCK-Anweisung (unlock_statement)


Literal (literal) (SAP-Bibliothek - Grundwissen)

Literal (literal)

Ein Literal (literal) ist ein unbenanntes Datenobjekt, das durch seinen Wert vollständig bestimmt ist (spezifiziert einen Nicht-NULL-Wert). Der Wert von Literalen ist unveränderbar. Es werden Stringliterale und numerische Literale unterschieden.

Syntax

<literal> ::= <numeric_literal>
| <string_literal>

<numeric_literal> ::= <fixed_point_literal>
| <floating_point_literal>

<string_literal> ::= ''
| '<character>...'
| <hex_literal>

<hex_literal> ::= x''
| X''
| x'<hex_digit_seq>'
| X'<hex_digit_seq>'

<hex_digit_seq> ::= <hex_digit><hex_digit>
| <hex_digit_seq><hex_digit><hex_digit>

<hex_digit> ::= 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
| A | B | C | D | E | F
| a | b | c | d | e | f

Stringliterale
'69190 Walldorf'
'Anton Schmitt'
X'12ab'

Numerische Literale
+0.58498
1E160
-765E-04

Erläuterung

Ein numerisches Literal numeric_literal ist ein Literal, das eine Zahl in Festkomma- oder Gleitkommadarstellung angibt.

Ein Stringliteral string_literal ist ein Literal, das aus einer Folge von Zeichen besteht, die in Apostrophe eingeschlossen sind. Gegebenenfalls kann ein Stringliteral durch ein vorangestelltes x oder X als hexadezimal gekennzeichnet werden.

Ein Apostroph innerhalb einer Zeichenkette wird durch zwei aufeinanderfolgende Apostrophs dargestellt.

Ein Stringliteral der Art '<character>...' oder '' ist nur für einen Wert zulässig, der eine alphanumerische Spalte mit dem Codeattribut ASCII betrifft.

Ein hexadezimaler Wert hex_literal ist nur für einen Wert zulässig, der eine Spalte mit dem Codeattribut BYTE betrifft.

Ein Stringliteral der Art '', x''und X'' und Stringliterale, die nur Leerzeichen enthalten, entsprechen nicht dem NULL-Wert.

Siehe auch:

Zeichensatz (token)

Datentyp (data_type)


Festkommazahl (fixed_point_literal) (SAP-Bibliothek - Grundwissen)

Festkommazahl (fixed_point_literal)

Eine Festkommazahl (fixed_point_literal) ist ein numerisches Literal, das eine Zahl in Festkommadarstellung angibt.

Syntax

<fixed_point_literal> ::=
[<sign>]<digit_sequence>[.<digit_sequence>]
| [<sign>]<digit_sequence>.
| [<sign>].<digit_sequence>

<sign> ::= + | -
<digit_sequence> ::= <digit>...
<digit> ::= 0 | 1 | 2 | | 3 | 4 | 5 | 6 | 7 | 8 | 9

+123.12
1234.


Gleitkommazahl (floating_point_literal) (SAP-Bibliothek - Grundwissen)

Gleitkommazahl (floating_point_literal)

Eine Gleitkommazahl (floating_point_literal) ist ein numerisches Literal, das eine Zahl in Gleitkommadarstellung angibt.

Syntax

<floating_point_literal> ::= <mantissa>E<exponent>
| <mantissa>e<exponent>

<mantissa> ::= <fixed_point_literal>

<exponent> ::= [<sign>][[<digit>]<digit>]<digit>
<sign> ::= + | -
<digit> ::= 0 | 1 | 2 | | 3 | 4 | 5 | 6 | 7 | 8 | 9

1e160
-765E-04


Ganze Zahl ohne Vorzeichen (unsigned_integer) (SAP-Bibliothek - Grundwissen)

Ganze Zahl ohne Vorzeichen (unsigned_integer)

Eine ganze Zahl ohne Vorzeichen (unsigned_integer) ist ein spezielles numerisches Literal.

Syntax

<unsigned_integer> ::= <numeric_literal>

<numeric_literal> ::= <fixed_point_literal> | <floating_point_literal>

Erläuterung

Eine ganze Zahl ohne Vorzeichen kann beliebig dargestellt sein, muss aber positiv sein.


Ganze Zahl (integer) (SAP-Bibliothek - Grundwissen)

Ganze Zahl (integer)

Eine ganze Zahl (integer) ist ein spezielles numerisches Literal. Eine ganze Zahl kann beliebig dargestellt sein.

Syntax

<integer> ::= [<sign>]<unsigned_integer>

<sign> ::= + | -


Parameterspezifikation (parameter_spec) (SAP-Bibliothek - Grundwissen)

Parameterspezifikation (parameter_spec)

Als Parameterspezifikation (parameter_spec) wird der Parametername und gegebenenfalls der Indikatorname bezeichnet, die erforderlich sind, um einen Parameter zu spezifizieren.

Syntax

<parameter_spec> ::= <parameter_name> [<indicator_name>]

Erläuterung

Der Indikator muss in der einbettenden Programmiersprache als Variable deklariert werden, der mindestens vierstellige ganze Zahlen zugewiesen werden können.

Es werden Ausgabeparameter und Eingabeparameter unterschieden:

· Ausgabeparameter: Parameter, die Werte aufnehmen sollen, die aus dem Datenbanksystem abgerufen werden.

- Ein Indikator mit dem Wert Null zeigt, dass der übergebene Wert kein NULL-Wert ist, und dass der Parameterwert der übergebene Wert ist.

- Ein Indikator mit dem Wert –1 zeigt, dass der Parameterwert der NULL-Wert ist.

- Alphanumerische Ausgabeparameter: Ein Indikator mit einem Wert größer Null zeigt, dass die zugewiesene Zeichenkette zu lang war und abgeschnitten wurde. Der Indikator gibt die Länge der Ausgabespalte an, aus der die Zeichenkette stammt.

- Numerische Ausgabeparameter: Ein Indikator mit einem Wert größer Null zeigt, dass der zugewiesene Wert zu viele signifikante Stellen hat und Nachkommastellen abgeschnitten wurden. Der Indikator gibt die Anzahl der Stellen des Originalwertes an.

- Bei numerischen Ausgabeparametern zeigt ein Indikator mit dem Wert –2, dass der Parameterwert der Spezial-NULL-Wert ist.

· Eingabeparameter: Parameter, die Werte enthalten, die an das Datenbanksystem übergeben werden sollen.

- Ein Indikator mit einem Wert größer oder gleich Null zeigt, dass der angegebene Parameterwert der Wert ist, der an das Datenbanksystem zu übergeben ist.

- Ein Indikator mit einem Wert kleiner Null zeigt, dass der angegebene Parameterwert der NULL-Wert ist.


Prädikat (predicate) (SAP-Bibliothek - Grundwissen)

Prädikat (predicate)

Ein Prädikat (predicate) wird in einer WHERE-Klausel in einer Anweisung, deren Aussage "wahr", "falsch" oder "undefiniert" ist, angegeben. Das Ergebnis ergibt sich aus der Anwendung des Prädikats auf eine gegebene Zeile einer Ergebnistabelle oder auf eine Gruppe von Zeilen einer Tabelle, die mit Hilfe der GROUP-Klausel gebildet wurde.

Syntax

<predicate> ::=
<between_predicate>
| <bool_predicate>
| <comparison_predicate>
| <default_predicate>
| <exists_predicate>
| <in_predicate>
| <join_predicate>
| <like_predicate>
| <null_predicate>
| <quantified_predicate>
| <rowno_predicate>
| <sounds_predicate>

Beispiele

SQL-Tutorial, Strukturlink Bedingungen: Vergleich, AND, OR, BETWEEN, IN, Strukturlink Negative Bedingungen: NOT, Strukturlink Suchen nach Zeichenketten: LIKE, Strukturlink Joins: Informationen aus mehreren Tabellen

Erläuterung

· Spalten einer Tabelle mit gleichem Codeattribut sind vergleichbar.

· Spalten mit den unterschiedlichen Codeattributen ASCII und UNICODE sind vergleichbar.

· Spalten mit dem Codeattribut ASCII oder UNICODE sind mit Datums-, Zeit- oder Zeitstempelwerten vergleichbar.

· LONG-Spalten können nur im NULL-Prädikat (null_predicate) verwendet werden.


BETWEEN-Prädikat (between_predicate) (SAP-Bibliothek - Grundwissen)

BETWEEN-Prädikat (between_predicate)

Das BETWEEN-Prädikat (between_predicate) ist ein Prädikat, das prüft, ob ein Wert in einem vorgegebenen Intervall liegt.

Syntax

<between_predicate> ::= <expression> [NOT] BETWEEN <expression> AND <expression>

Beispiele

SQL-Tutorial, Strukturlink Bedingungen: Vergleich, AND, OR, BETWEEN, IN, Strukturlink Negative Bedingungen: NOT

Erläuterung

Seien x,y und z die Ergebnisse des ersten, zweiten und dritten Ausdrucks (expression). Die Werte x,y,z müssen miteinander vergleichbar sein.

 | Ergebnis des angegebenen Prädikats
x BETWEEN y AND z | x>=y AND x<=z
x NOT BETWEEN y AND z | NOT(x BETWEEN y AND z)
x, y, oder z sind NULL-Werte | x [NOT] BETWEEN y AND z ist undefiniert


Boolesches Prädikat (bool_predicate) (SAP-Bibliothek - Grundwissen)

Boolesches Prädikat (bool_predicate)

In einem booleschen Prädikat (bool_predicate) werden boolesche Werte (BOOLEAN) verglichen.

Syntax

<bool_predicate> ::= <column_spec> [IS [NOT] TRUE | IS [NOT] FALSE]

Erläuterung

Wenn nur eine Spaltenspezifikation column_spec angegeben wird, entspricht das der Syntax <column_spec> IS TRUE.

Die Spaltenspezifikation muss eine Spalte vom Datentyp BOOLEAN bezeichnen.

Für das Ergebnis eines booleschen Prädikats gelten folgende Regeln:

Spaltenwert | IS TRUE | IS NOT TRUE | IS FALSE | IS NOT FALSE
falsch | falsch | wahr | wahr | falsch
undefiniert | undefiniert | undefiniert | undefiniert | undefiniert
wahr | wahr | falsch | falsch | wahr


Vergleichsprädikat (comparison_predicate) (SAP-Bibliothek - Grundwissen)

Vergleichsprädikat (comparison_predicate)

Ein Vergleichsprädikat (comparison_predicate) ist eine Prädikat, das einen Vergleich zweier Werte bzw. Wertelisten spezifiziert.

Syntax

<comparison_predicate> ::=
<expression> <comp_op> <expression>
| <expression> <comp_op> <subquery>
| <expression_list> <equal_or_not> (<expression_list>)
| <expression_list> <equal_or_not> <subquery>

Für den Vergleich zweier Werte stehen folgende Vergleichsoperatoren zur Verfügung:
<comp_op> ::= < | > | <> | != | = | <= | >=
| ~= <! für Rechner mit ASCII-Code !>
| ~< <! für Rechner mit ASCII-Code !>
| ~> <! für Rechner mit ASCII-Code !>

Für den Vergleich zweier Wertelisten stehen nur die folgenden Vergleichsoperatoren zur Verfügung:
<equal_or_not> ::= <> | =
| ~= <! für Rechner mit ASCII-Code !>

Beispiele

SQL-Tutorial, Strukturlink Bedingungen: Vergleich, AND, OR, BETWEEN, IN, Strukturlink Subquery: Innere Abfragen

Erläuterung

Die Subquery subquery muss eine Ergebnistabelle liefern, die so viele Spalten enthält wie Werte auf der linken Seite des Operators angegeben sind. Diese Ergebnistabelle darf höchstens eine Zeile enthalten.

Die auf der rechten Seite des Vergleichsoperators equal_or_not angegebene Werteliste expression_list muss so viele Werte enthalten, wie in der Werteliste vor dem Vergleichsoperator equal_or_not angegeben sind.

Ein Spezialfall des Vergleichsprädikats ist das JOIN-Prädikat.

Vergleich zweier Werte

Sei x das Ergebnis des ersten Ausdrucks expression und y das Ergebnis des zweiten Ausdrucks oder der Subquery.

● Die Werte x und y müssen miteinander vergleichbar sein.

● Zahlen werden nach ihrem algebraischen Wert verglichen.

● Der Vergleich von Zeichenketten erfolgt Zeichen für Zeichen.
Wenn eine oder beide Zeichenketten am Ende Leerzeichen (Codeattribut ASCII, UNICODE) oder binären Nullen (Codeattribut BYTE) enthalten, so werden diese entfernt.
Wenn die Zeichenketten die unterschiedlichen Codeattribute ASCII und UNICDODE besitzen, wird die Zeichenkette mit dem Codeattribut ASCII implizit in eine Zeichenkette mit dem Codeattribut UNICODE umgewandelt.
Zwei Zeichenketten sind gleich, wenn sie an allen Positionen die jeweils gleichen Zeichen enthalten.
Wenn zwei Zeichenketten nicht gleich sind, wird ihre Beziehung vom ersten sich unterscheidenden Zeichen bestimmt, welches beim Vergleich von links nach rechts gefunden wird. Dieser Vergleich wird gemäß dem für diese Spalte gewählten Codeattribut (ASCII, UNICODE oder BYTE) ausgeführt.

● Wenn x oder y NULL-Werte sind, oder wenn das Ergebnis der Subquery leer ist, dann ist (x <comp_op> y) undefiniert.

Vergleich zweier Wertelisten

Wenn auf der linken Seite der Vergleichsoperators equal_or_not eine Werteliste expression_list angegeben ist, dann sei x die Werteliste, die sich aus den Ergebnissen der Werte x1, x2, ..., xn dieser Werteliste zusammensetzt. y sei das Ergebnis der Subquery oder das Ergebnis der zweiten Werteliste. Eine Werteliste y setzt sich aus den Ergebnissen der Werte y1, y2, ..., yn zusammen.

● Ein Wert xm muss mit dem zugehörigen Wert ym vergleichbar sein.

● x=y ist wahr, wenn für alle m=1, ..., n gilt xm=ym

● x<>y ist wahr, wenn es mindestens ein m gibt, für das gilt xm<>ym.

● (x <equal_or_not> y) ist undefiniert, wenn es kein m gibt, für das (xm <equal_or_not> ym) falsch ist und es mindestens ein m gibt, für das (xm <equal_or_not> ym) undefiniert ist.

● Wenn ein xm oder ein ym NULL-Werte sind, oder wenn das Ergebnis der Subquery leer ist, dann ist (x <equal_or_not> y) undefiniert.

Siehe auch:

Mengenvergleichsprädikat

DEFAULT-Prädikat


DEFAULT-Prädikat (default_predicate) (SAP-Bibliothek - Grundwissen)

DEFAULT-Prädikat (default_predicate)

Durch die Angabe eines DEFAULT-Prädikats (default_predicate) können Sie überprüfen, ob eine Spalte den für diese Spalte definierten Vorschlagswert (DEFAULT-Wert) enthält.

Syntax

<default_predicate> ::= <column_spec> <comp_op> DEFAULT

<comp_op> ::= < | > | <> | != | = | <= | >=
| ~= | ~< | ~> (für Computer mit ASCII-Code)

Erläuterung

Für die angegebene Spalte muss eine DEFAULT-Spezifikation erfolgt sein. Das kann in folgenden SQL-Anweisungen erfolgen:

· CREATE TABLE-Anweisung

· ALTER TABLE-Anweisung

Wenn die Spalte den NULL-Wert enthält, dann ist <column_spec> <comp_op> DEFAULT undefiniert.

Es gelten die Regeln für Vergleiche von Werten bzw. Wertelisten, wie für Vergleichsprädikate beschrieben.


EXISTS-Prädikat (exists_predicate) (SAP-Bibliothek - Grundwissen)

EXISTS-Prädikat (exists_predicate)

Das EXISTS-Prädikat (exists_predicate) ist ein Prädikat, das prüft, ob eine Ergebnistabelle (siehe Ergebnistabellenname) mindestens eine Zeile enthält.

Syntax

<exists_predicate> ::= EXISTS <subquery>

Beispiele

SQL-Tutorial, Strukturlink Subquery: Innere Abfragen

Erläuterung

Der Wahrheitsgehalt eines EXISTS-Prädikats ist entweder wahr oder falsch.

Durch die Subquery wird eine Ergebnistabelle erzeugt. Wenn diese Ergebnistabelle wenigstens eine Zeile enthält, ist EXISTS <subquery> wahr.


IN-Prädikat (in_predicate) (SAP-Bibliothek - Grundwissen)

IN-Prädikat (in_predicate)

Das IN-Prädikat (in_predicate) ist ein Prädikat, das prüft, ob ein Wert bzw. eine Werteliste in einer vorgegebenen Wertemenge bzw. Menge von Wertelisten enthalten ist.

Syntax

<in_predicate> ::=
<expression> [NOT] IN <subquery>
| <expression> [NOT] IN <expression_list>
| <expression_list> [NOT] IN <subquery>
| <expression_list> [NOT] IN (<expression_list>,...)

Beispiele

SQL-Tutorial, Strukturlink Bedingungen: Vergleich, AND, OR, BETWEEN, IN, Strukturlink Negative Bedingungen: NOT, Strukturlink Subquery: Innere Abfragen

Erläuterung

Die Subquery (subquery) muss eine Ergebnistabelle (siehe Ergebnistabellenname) liefern, die so viele Spalten enthält wie Werte durch den Ausdruck (expression) auf der linken Seite des Operators IN angegeben sind.

Jede auf der rechten Seite des Operators IN angegebene Werteliste muss so viele Werte enthalten, wie in der Werteliste auf der linken Seite des Operators IN angegeben sind.

· x [NOT] IN S, wobei x <expression> und S <subquery> oder <expression_list>
Der Wert x und die Werte in S müssen miteinander vergleichbar sein.

· x [NOT] IN S, wobei x <expression_list> mit den Werten x1, x2, ..., xn und S <subquery>(Menge von Wertelisten s) oder (<expression_list>,...) (Folge von Wertelisten s) mit den Wertelisten s: s1, s2, ..., sn
Ein Wert xm muss mit allen Werten sm vergleichbar sein.
x=s ist wahr, wenn xm=sm, m=1,...,n
x=s ist falsch, wenn es mindestens ein m gibt, für das xm=sm falsch ist
x=s ist undefiniert, wenn es kein m gibt, für das xm=sm falsch ist, und es mindestens ein m gibt, für das xm=sm undefiniert ist.

In der folgenden Aufstellung bedeutet ‘------‘, daß keine Aussage getroffen werden kann, wenn nur das Ergebnis des Vergleichs mit einem s bekannt ist.

 | Ergebnis der Funktion x IN S
x=s ist wahr für mindestens ein s | wahr
x=s ist wahr für alle s | wahr
S enthält NULL-Werte und x=s ist wahr für die übrigen s | wahr
S ist leer | falsch
x=s ist falsch für mindestens ein s | ------
x=s ist falsch für alle s | falsch
S enthält NULL-Werte und x=s ist falsch für die übrigen s | undefiniert
x=s ist für kein s wahr und ist für wenigstens einen Wert s undefiniert | undefiniert

x NOT IN S hat das gleiche Ergebnis wie NOT(x IN S)


JOIN-Prädikat (join_predicate) (SAP-Bibliothek - Grundwissen)

JOIN-Prädikat (join_predicate)

Ein JOIN-Prädikat (join_predicate) ist ein Prädikat, das einen Join spezifiziert.

Ein Join ist eine SQL-Anweisung, die mehrere Tabellen miteinander verknüpft und als Ergebnis eine Join-Tabelle liefert.

Ein JOIN-Prädikat kann ohne, mit einem oder mit zwei OUTER JOIN-Indikatoren angegeben werden.

Syntax

<join_predicate> ::=
<expression> [<outer_join_indicator>] <comp_op> <expression> [<outer_join_indicator>]

<outer_join_indicator> ::= (+)

<comp_op> ::= < | > | <> | != | = | <= | >=
| ~= | ~< | ~> (für Computer mit ASCII-Code)

Beispiele

SQL-Tutorial, Strukturlink Joins: Informationen aus mehreren Tabellen

Erläuterung

Jeder Ausdruck expression muss eine Spaltenspezifikation enthalten. Es muss eine Spaltenspezifikation des ersten Ausdrucks und eine Spaltenspezifikation des zweiten Ausdrucks geben, so dass sich die beiden Spaltenspezifikationen auf verschiedene Tabellennamen oder Referenznamen beziehen.

Sei x der Wert des ersten Ausdrucks und y der Wert des zweiten Ausdrucks. Die Werte x und y müssen vergleichbar sein.

Das JOIN-Prädikat ist ein Spezialfall des Vergleichsprädikats. Es gelten die für ein Vergleichsprädikat angegebenen Regeln.

Wenn mindestens ein OUTER JOIN-Indikator outer_join_indicator in einem JOIN-Prädikat einer Suchbedingung angegeben wird, dürfen dem entsprechenden Tabellenausdruck nur genau zwei Tabellen zugrundeliegen oder es muss folgendes gelten:

● Nur für eine der in der FROM-Klausel angegebenen Tabellen werden OUTER JOIN-Indikatoren angegeben.

● Alle JOIN-Prädikate dieser Tabelle zu genau einer anderen Tabelle enthalten jeweils den OUTER JOIN-Indikator.

● Alle anderen JOIN-Prädikate enthalten keinen OUTER JOIN-Indikator.

Wenn für einen JOIN mehr als zwei Tabellen für die QUERY-Spezifikation notwendig sind und kann eine der oben genannten Regeln nicht eingehalten werden, kann auch ein QUERY-Ausdruck in der FROM-Klausel verwendet werden.

Es werden nur solche Zeilen einer Tabelle in die Ergebnistabelle übertragen, die ein dem Vergleichsoperator comp_op entsprechendes Gegenstück in der anderen im JOIN-Prädikat angegebenen Tabelle haben.

Wenn sichergestellt werden soll, dass jede Zeile einer Tabelle mindestens einmal in der Ergebnistabelle enthalten ist, muss der OUTER JOIN-Indikator auf der Seite des Vergleichsoperators angegeben werden, auf der die andere Tabelle spezifiziert ist.

Es wird dann (wenn für eine Zeile einer Tabelle nicht mindestens ein Gegenstück in der anderen Tabelle gefunden werden kann) aus der Tabelle trotzdem eine Zeile für die Ergebnistabelle gebildet. Dabei wird für die Ausgabespalten, die aus Spalten der anderen Tabelle gebildet werden, der NULL-Wert verwendet.

Da der OUTER JOIN-Indikator auf beiden Seiten des Vergleichsoperators angegeben werden kann, wenn dem Tabellenausdruck nur genau zwei Tabellen zugrundeliegen, kann für beide Tabellen sichergestellt werden, dass jede Zeile mindestens einmal in der Ergebnistabelle enthalten ist.

Siehe auch:

Join-Tabelle (joined_table)

Join-View-Tabelle in einer INSERT-Anweisung

Änderbare Join-View-Tabelle (CREATE VIEW-Anweisung)

Restriktionen für SQL-Anweisungen

Konzepte des Datenbanksystems, Suchstrategien für Joins, EXPLAIN-Anweisung für Joins


LIKE-Prädikat (like_predicate) (SAP-Bibliothek - Grundwissen)

LIKE-Prädikat (like_predicate)

Ein LIKE-Prädikat (like_predicate) ist eine Prädikat, das zur Suche nach Zeichenketten dient, die ein bestimmtes Muster haben. Dieses Muster kann eine bestimmte Zeichenkette sein, eine Folge von Zeichen mit unbekannter Anzahl oder eine Menge von Zeichen mit bestimmter Anzahl.

Syntax

<like_predicate> ::= <expression> [NOT] LIKE <like_expression> [ESCAPE <expression>]

<like_expression> ::= <expression> | '<pattern_element>...'
<pattern_element> ::= <match_string> | <match_set>

<match_string> ::= % | X'1F'
<match_set> ::= <underscore> | X'1E' | <match_char>

<underscore> ::= _ (Unterstrich)
<match_char> ::= <! Jedes Zeichen außer % | X'1F' | <underscore> | X'1E' !>

Beispiele

SQL-Tutorial, Strukturlink Suchen nach Zeichenketten: LIKE, Strukturlink Negative Bedingungen: NOT

Erläuterung

x NOT LIKE y hat das gleiche Ergebnis wie NOT(x LIKE y).

Ergebnis von x LIKE y

x oder y sind NULL-Werte

x LIKE y ist undefiniert

x und y sind Nicht-NULL-Werte

x LIKE y ist entweder wahr oder falsch

x lässt sich in Teilzeichenketten zerlegen, so dass gilt:

Eine Teilzeichenkette von x ist eine Folge von 0,1, oder eine Folge von mehreren benachbarten Zeichen und jedes Zeichen von x gehört genau zu einer Teilzeichenkette.

Die Anzahl der Teilzeichenketten von x und y ist gleich.

Das n-te Vergleichsmuster (pattern_element) von y ist eine Folge von Zeichen und die n-te Teilzeichenkette von x ist eine Folge von 0 oder mehr Zeichen.

x LIKE y ist wahr

<expression>

Der Ausdruck expression im LIKE-Ausdruck like_expression muss einen alphanumerischen Wert oder einen Datums- oder Zeitwert liefern.

<pattern_element>

Wenn ein match_string angegeben wird, bedeutet das, dass diese Stelle im Suchmuster durch eine beliebige Anzahl von Zeichen ersetzt werden kann.

Wenn ein match_set angegeben wird, bedeutet das, dass diese Stelle im Suchmuster durch die durch das match_set vorgegebene Anzahl von Zeichen ersetzt werden kann.

Die Verwendung eines Unterstrichs oder X'1E' bedeutet, dass diese Stelle im Muster durch genau ein beliebiges Zeichen ersetzt werden kann.

Die Verwendung von match_char bedeutet, dass diese Stelle im Muster durch das angegebene Zeichen selbst ersetzt werden kann.

ESCAPE

Die Verwendung eines Escape-Zeichens ESCAPE <expression> ist dann notwendig, wenn nach einem Unterstrich oder % oder dem hexadezimalen Wert X'1E' oder X'1F' im LIKE-Prädikat gesucht werden soll.

Wenn ESCAPE <expression> angegeben wird, muss der zugehörige Ausdruck expression einen alphanumerischen Wert liefern, der aus genau einem Zeichen besteht. Ist dieses Escape-Zeichen im LIKE-Ausdruck like_expression enthalten, so muss das darauffolgende Zeichen eines der Sonderzeichen <underscore>, %, X’1E’ oder X’1F’ sein. Dieses Sonderzeichen wird dann als für sich selbst stehendes Zeichen angesehen.


NULL-Prädikat (null_predicate) (SAP-Bibliothek - Grundwissen)

NULL-Prädikat (null_predicate)

Durch Angabe eines NULL-Prädikats (null_predicate) wird getestet, ob es sich um einen NULL-Wert handelt oder nicht.

Syntax

<null_predicate> ::= <expression> IS [NOT] NULL

Beispiele

SQL-Tutorial, Strukturlink Negative Bedingungen: NOT

Erläuterung

Der Wahrheitswert eines NULL-Prädikats ist entweder wahr oder falsch.

 | Ergebnis der Funktion x IS NULL
x ist NULL-Wert | wahr
x ist Spezial-NULL-Wert | falsch

x IS NOT NULL hat das gleiche Ergebnis wie NOT(x IS NULL).


Mengenvergleichsprädikat (quantified_predicate) (SAP-Bibliothek - Grundwissen)

Mengenvergleichsprädikat (quantified_predicate)

Durch die Angabe eines Mengenvergleichsprädikats (quantified_predicate) wird ein Vergleich eines Wertes bzw. einer Werteliste mit einer Menge von Werten bzw. Wertelisten durchgeführt.

Syntax

<quantified_predicate> ::=
<expression> <comp_op> <quantifier> <expression_list>
| <expression> <comp_op> <quantifier> <subquery>
| <expression_list> <equal_or_not> <quantifier> (<expression_list>,...)
| <expression_list> <equal_or_not> <quantifier> <subquery>

Für den Vergleich von Werten stehen folgende Vergleichsoperatoren zur Verfügung:
<comp_op> ::= < | > | <> | != | = | <= | >=
| ~= | ~< | ~> (für Computer mit ASCII-Code)

Für den Vergleich von Wertelisten stehen nur die folgenden Vergleichsoperatoren zur Verfügung:

<equal_or_not> ::= <> |=
| ~= (für Computer mit ASCII-Code)

Zur Qualifizierung des Mengenvergleichs stehen ALL bzw. SOME oder ANY zur Verfügung.

<quantifier> ::= ALL | SOME | ANY

Beispiele

SQL-Tutorial, Strukturlink Subquery: Innere Abfragen

Erläuterung

Die Subquery subquery muss eine Ergebnistabelle liefern, die so viele Spalten enthält wie Werte durch den Ausdruck (expression bzw. expression_list) auf der linken Seite des Operators erzeugt sind.

Jede auf der rechten Seite des Vergleichsoperators equal_or_not angegebene Werteliste expression_list muss so viele Werte enthalten, wie in der Werteliste vor dem Vergleichsoperator equal_or_not angegeben sind.

· Sei x das Ergebnis des ersten Wertes expression und S das Ergebnis der Subquery oder der Folge von Werten. S ist eine Menge von Werten s. Der Wert x und die Werte in S müssen miteinander vergleichbar sein.

· Wenn auf der linken Seite der Vergleichsopertors equal_or_not eine Werteliste expression_list angegeben ist, dann sei x die Werteliste, die sich aus den Ergebnissen der Werte x1, x2, ..., xn dieser Werteliste zusammensetzt. S sei das Ergebnis der Subquery, die sich aus einer Menge von Wertelisten s zusammensetzt. oder eine Folge von Wertelisten s. Eine Werteliste s setzt sich aus den Ergebnissen der Werte s1, s2, ..., sn zusammen. Ein Wert xm muss mit allen Werten sm vergleichbar sein.
x=s ist wahr, wenn xm=sm, m=1,...,n
x<>s ist wahr, wenn es mindestens ein m gibt, für das gilt xm<>sm.
x <equal_or_not> s ist undefiniert, wenn es kein m gibt, für das xm <equal_or_not> sm falsch ist und es mindestens ein m gibt, für das xm <equal_or_not> sm undefiniert ist.
Wenn ein xm oder ein ym NULL-Werte sind, oder wenn das Ergebnis der Subquery leer ist, dann ist x <equal_or_not> y undefiniert.

In der folgenden Aufstellung bedeutet ‘------‘, dass keine Aussage getroffen werden kann, wenn nur das Ergebnis des Vergleichs mit einem s bekannt ist.

x <compare> <quantifier> S, wobei compare ::= comp_op | equal_or_not

 | quantifier ::= ALL | quantifier ::= ANY | SOME
S ist leer | Wahr | falsch
x <compare> S ist wahr für mindestens ein s aus S | ------ | wahr
x <compare> S ist wahr für alle s aus S | Wahr | wahr
x <compare> S ist für keinen Wert s aus S falsch und ist wenigstens für einen Wert s undefiniert | undefiniert |
S enthält NULL-Werte und x <compare> S ist wahr für alle anderen s | undefiniert | wahr
x <compare> S ist für wenigstens einen Wert s aus S falsch | Falsch | ------
x <compare> S ist falsch für alle s aus S | Falsch | falsch
x <compare> S ist für keinen Wert aus aus S wahr und für wenigstens einen Wert s undefiniert |  | undefiniert
S enthält NULL-Werte und x <compare> S ist falsch für alle anderen s | falsch | undefiniert

Siehe auch:

Vergleichsprädikat (comparison_predicate)


ROWNO-Prädikat (rowno_predicate) (SAP-Bibliothek - Grundwissen)

ROWNO-Prädikat (rowno_predicate)

Das ROWNO-Prädikat (rowno_predicate) ist ein Prädikat, das die Anzahl der Zeilen einer Ergebnistabelle bzw. die Anzahl zu ändernder oder zu löschender Zeilen beschränkt.

Syntax

<rowno_predicate> ::= ROWNO < <unsigned_integer>
| ROWNO < <parameter_spec>
| ROWNO <= <unsigned_integer>
| ROWNO <= <parameter_spec>

Beispiele

SQL-Tutorial, Strukturlink Auswählen und Anordnen von Zeilen

Erläuterung

Ein ROWNO-Prädikat darf in einer WHERE-Klausel verwendet werden, die zu einer QUERY-, DELETE- oder UPDATE-Anweisung gehört. Das ROWNO-Prädikat kann innerhalb der WHERE-Klausel wie jedes andere Prädikat verwendet werden, wenn folgende Einschränkungen beachtet werden:

● ROWNO-Prädikat muss mit den anderen Prädikaten logisch durch AND verknüpft sein

● ROWNO-Prädikat darf nicht negiert werden

● ROWNO-Prädikat darf höchstens einmal in der WHERE-Klausel verwendet werden

Durch die Angabe einer ganzen Zahl ohne Vorzeichen (unsigned_integer) oder eine Parameterspezifikation (parameter_spec) wird die maximale Anzahl der Zeilen angegeben, die die Ergebnistabelle aufweisen soll. Wurden mehr Zeilen gefunden, werden diese nicht betrachtet und führen auch nicht zu einer Fehlermeldung. Die Angabe eines ROWNO-Prädikats der Art ROWNO <= 0 führt zu einer leeren Ergebnistabelle bzw. keiner geänderten oder gelöschten Zeile.

Wird ein ROWNO-Prädikat und eine ORDER-Klausel in einer QUERY-Anweisung angegeben, so werden nur die ersten n Ergebniszeilen gesucht und sortiert. Das Ergebnis unterscheidet sich im Normalfall von dem, das man erhalten hätte, wäre kein ROWNO-Prädikat angegeben gewesen, und hätte man dann die ersten n Ergebniszeilen betrachtet.

Wenn ein ROWNO-Prädikat und eine Set-Funktion in einer QUERY-Anweisung angegeben werden, dann wird die Set-Funktion nur auf die durch das ROWNO-Prädikat beschränkte Anzahl der Ergebniszeilen angewandt.

Die Angabe eines ROWNO-Prädikats in einer UPDATE- oder DELETE-Anweisung ist sinnvoll, wenn eine so große Anzahl von Zeilen zu bearbeiten ist, dass deren Log-Informationen den zur Verfügung stehenden Platz überschreiten würden. Die gewünschten Änderungsanweisung können Sie somit in mehreren Teilschritten durchführen, so lange bis die Anzahl der geänderten bzw. gelöschten Zeilen kleiner ist als die im ROWNO-Prädikat angegebenen Anzahl.

Wenn Sie eine LIMIT-Klausel oder ein TOP-Syntaxelement verwenden, dürfen Sie das ROWNO-Prädikat nicht verwenden.


SOUNDS-Prädikat (sounds_predicate) (SAP-Bibliothek - Grundwissen)

SOUNDS-Prädikat (sounds_predicate)

Durch die Angabe eines SOUNDS-Prädikats (sounds_predicate) wird ein phonetischen Vergleich durchgeführt.

Syntax

<sound_predicate> ::= <expression> [NOT] SOUNDS [LIKE] <expression>

Erläuterung

Die Angabe von LIKE im SOUNDS-Prädikat hat keine Wirkung.

Die Werte der Ausdrücke (expression) müssen alphanumerisch sein (Codeattribut ASCII).

Ein phonetischer Vergleich zwischen Werten erfolgt nach dem SOUNDEX-Algorithmus. Dabei werden alle Vokale und einige Konsonanten eliminiert und alle ähnlich klingenden Konsonanten aufeinander abgebildet.

x [NOT] SOUNDS [LIKE] y

 | Ergebnis des Prädikats
x oder y ist NULL-Wert | x SOUNDS y ist undefiniert
x und y sind Nicht-NULL-Werte | x SOUNDS y ist wahr oder falsch
x und y sind phonetisch gleich | x SOUNDS y ist wahr

x NOT SOUNDS y hat das gleiche Ergebnis wie NOT (x SOUNDS y).

Siehe auch:

Stringfunktion SOUNDEX(x)


SAMPLE-Definition (sample_definition) (SAP-Bibliothek - Grundwissen)

SAMPLE-Definition (sample_definition)

Die Angabe einer SAMPLE-Definition (sample_definition) definiert die Stichprobengröße, d.h. wie viele Zeilen einer Tabelle beim Aktualisieren von Statistiken herangezogen werden sollen.

Syntax

<sample_definition> ::=
SAMPLE <unsigned_integer> ROWS
| SAMPLE <unsigned_integer> PERCENT

Erläuterung

Das Datenbanksystem führt für jede Basistabelle Statistikwerte, die zur Bestimmung der besten Strategie zur Ausführung einer SQL-Anweisung herangezogen werden. Diese Statistikwerte werden durch die UPDATE STATISTICS-Anweisung im Datenbankkatalog abgelegt.

Wenn in einer UPDATE STATISTICS-Anweisung eine SAMPLE-Definition angegeben wird, legt die SAMPLE-Definition fest, wieviele Zeilen der Tabelle zur Bestimmung der Statistikwerte herangezogen werden sollen (Stichprobengröße).

Wenn in einer UPDATE STATISTICS-Anweisung keine SAMPLE-Definition angegeben wird und auch nicht erzwungen wird, dass alle Zeilen der Tabelle zur Bestimmung der Statistikwerte herangezogen werden sollen, so verwendet das Datenbanksystem die entsprechende SAMPLE-Definition der CREATE TABLE-Anweisung oder der ALTER TABLE-Anweisung.

Die Definition der Anzahl der Zeilen, für die die UPDATE STATISTCS-Anweisung durchgeführt werden soll, kann durch Angabe der Anzahl der Zeilen (ROWS) oder durch Angabe in Prozent (PERCENT) erfolgen.

● Bei Angabe einer SAMPLE-Definition mittels PERCENT muss die Ganze Zahl ohne Vorzeichen im Bereich zwischen 0 und 100 liegen.

● Wenn keine SAMPLE-Definition definiert ist, verwendet das Datenbanksystem den Wert 20000 ROWS.

Stichprobengröße 0

Sie können einzelne Tabellen von einem UPDATE STATISTICS-Lauf ausschließen, indem Sie mittels einer ALTER TABLE-Anweisung für diese Tabellen die Stichprobengröße auf 0 setzen.

SQL-Anweisungen, in denen die SAMPLE-Definition verwendet werden kann

CREATE TABLE-Anweisung

ALTER TABLE-Anweisung

UPDATE STATISTICS-Anweisung


Suchbedingung (search_condition) (SAP-Bibliothek - Grundwissen)

Suchbedingung (search_condition)

Eine Suchbedingung (search_condition) verknüpft Aussagen, die wahr, falsch oder undefiniert sein können. Es können Zeilen in einer Tabelle gefunden werden, die mehrere Bedingungen erfüllen, die durch AND oder OR verknüpft werden.

Syntax

<search_condition> ::= <boolean_term> | <search_condition> OR <boolean_term>

<boolean_term> ::= <boolean_factor> | <boolean_term> AND <boolean_factor>
<boolean_factor> ::= [NOT] <predicate> | [NOT] (<search_condition>)

Im Syntaxelement boolean_factor werden die zu verknüpfenden booleschen Werte (BOOLEAN) bzw. deren Negation (NOT) ermittelt.

Beispiele

SQL-Tutorial, Strukturlink Bedingungen: Vergleich, AND, OR, BETWEEN, IN, Strukturlink Arithmetische Operationen, Strukturlink Negative Bedingungen: NOT

Erläuterung

In einer WHERE-Klausel werden Prädikate auf eine gegebene Zeile oder auf eine Gruppe von Zeilen einer Tabelle angewendet, die mit Hilfe der GROUP-Klausel gebildet wurden (siehe dazu: Tabellenausdruck (table_expression)). Diese Resultate werden mit den angegebenen booleschen Operatoren (AND, OR, NOT) verknüpft.

Bei fehlender Klammerung ist die Priorität der Operatoren folgendermaßen festgelegt: NOT bindet stärker als AND und OR, AND bindet stärker als OR. Bei gleicher Priorität erfolgt die Auswertung von links nach rechts.

NOT

X | NOT(x)
Wahr | Falsch
Falsch | Wahr
Undefiniert | Undefiniert

x AND y

x y | Falsch | undefiniert | wahr
Falsch | Falsch | falsch | falsch
Undefiniert | Falsch | undefiniert | undefiniert
Wahr | Falsch | undefiniert | wahr

x OR y

x y | Falsch | undefiniert | wahr
Falsch | Falsch | undefiniert | wahr
Undefiniert | Undefiniert | undefiniert | wahr
Wahr | Wahr | wahr | wahr

Damit der SQL-Optimierer die effizienteste Suchstrategie bestimmen kann, ist eine bestimmte Form der Suchbedingung erforderlich. Weitere Informationen dazu finden Sie in Konzepte des Datenbanksystems, Suchbedingungen.


Selektierte Spalte (select_column) (SAP-Bibliothek - Grundwissen)

Selektierte Spalte (select_column)

Selektierte Spalten (select_column) müssen in einer QUERY-Spezifikation angegeben werden, um eine Ergebnistabelle zu spezifizieren.

Die Folge von selektierten Spalten definiert die Spalten der Ergebnistabelle. Die Spalten der Ergebnistabelle ergeben sich aus den Spalten der Zwischenergebnistabelle, gegebenenfalls ergänzt durch ROWNO-Spalten (rowno_column) bzw. STAMP-Spalten (stamp_column). Die Spalten der Zwischenergebnistabelle werden durch die FROM-Klausel des Tabellenausdrucks bestimmt. Die Reihenfolge der Spaltennamen der Zwischenergebnistabelle wird durch die Reihenfolge der Tabellennamen in der FROM-Klausel bestimmt.

Syntax

<select_column> ::= <table_columns> | <derived_column> | <rowno_column> | <stamp_column>

<table_columns> ::= * | <table_name>.* | <reference_name>.*
<derived_column> ::= <expression> [ [AS] <result_column_name>]
<rowno_column> ::= ROWNO [ [AS] <result_column_name>]
<stamp_column> ::= STAMP [ [AS] <result_column_name>]

<result_column_name> ::= <identifier>

Beispiele

SQL-Tutorial, Strukturlink Auswählen und Anordnen von Zeilen, Strukturlink Auswählen, Anordnen und Umbenennen von Spalten

Erläuterung

Jeder als selektierte Spalte select_column angegebene Spaltenname muss eindeutig eine Spalte einer der QUERY-Spezifikation zugrundeliegenden Tabellen bezeichnen. Gegebenenfalls ist der Spaltenname durch den Tabellennamen zu qualifizieren.

Die Angabe einer Spalte des Datentyps LONG in einer selektierten Spalte ist nur in der obersten Folge von selektierten Spalten in einer QUERY-Anweisung oder SINGLE SELECT-Anweisung zulässig, wenn dort nicht die DISTINCT-Spezifikation verwendet wurde.

Die Angabe einer Spalte des Datentyps LONG in einer selektierten Spalte ist nur in der obersten Folge von selektierten Spalten in einer CREATE VIEW-Anweisung, der genau eine Basistabelle zugrundeliegt, zulässig.

Wenn eine selektierte Spalte eine Set-Funktion enthält, darf die Folge der selektierten Spalten, zu der sie gehört, keine Tabellenspalten table_columns enthalten, und jeder in einem Ausdruck expression auftretende Spaltenname muss eine Gruppierspalte bezeichnen, oder der Ausdruck muss sich aus Gruppierspalten zusammensetzen.

Die Angabe skalarer Subqueries ist möglich.

<table_columns>

Die Angabe von Tabellenspalten table_columns in einer selektierten Spalte ist eine Abkürzung für die Angabe der Spalten der Ergebnistabelle.

· Wird nur eine selektierte Spalte der Art * angegeben, so ist das eine Abkürzung für die Angabe aller Spalten der Zwischenergebnistabelle in unveränderter Reihenfolge.
Spalten, für die der Benutzer nicht das SELECT-Privileg hat, und die implizit angelegte Spalte SYSKEY werden nicht übernommen.

· Die Angabe von <table_name>.* oder <reference_name>.* ist eine Abkürzung für die Angabe aller Spalten der zugrundeliegenden Tabelle. Der erste Spaltenname der Ergebnistabelle wird vom ersten Spaltennamen der zugrundeliegenden Tabelle übernommen, der zweite Spaltenname der Ergebnistabelle entspricht dem zweiten Spaltennamen der zugrundeliegenden Tabelle, usw. Die Reihenfolge der Spaltennamen der zugrundeliegenden Tabelle entspricht der bei der Definition der zugrundeliegenden Tabelle festgelegten Reihenfolge.
Spalten, für die der Benutzer nicht das SELECT-Privileg hat, und die implizit angelegte Spalte SYSKEY werden nicht übernommen.

<derived_column>

Die Angabe einer Ergebnistabellenspalte derived_column in einer selektierten Spalte definiert eine Spalte der Ergebnistabelle.

· Wenn eine Spalte der Ergebnistabelle die Form <expression> [AS] <result_column_name> hat, erhält diese Ergebnisspalte den Namen result_column_name.

· Wenn kein result_column_name angegeben ist und der Ausdruck expression eine Spaltenspezifikation ist, die eine Spalte der Zwischenergebnistabelle bezeichnet, erhält die Spalte der Ergebnistabelle den Spaltennamen der Zwischenergebnistabelle.

· Wenn kein result_column_name angegeben ist und der Ausdruck keine Spaltenspezifikation ist, erhält die Spalte den Namen EXPRESSION_, wobei "_" eine maximal vierstellige Zahl bedeutet, beginnend mit EXPRESSION1, EXPRESSION2, usw.

<rowno_column>

Eine ROWNO-Spalte rowno_column darf nur in einer selektierten Spalte spezifiziert werden, die zu einer QUERY-Anweisung gehört.

Bei Angabe einer ROWNO-Spalte wird eine Spalte vom Datentyp FIXED(10) mit dem Namen ROWNO erzeugt. Sie enthält die Werte 1, 2, 3,..., welche eine Numerierung der Zeilen der Ergebnistabelle darstellen.

Wenn die ROWNO-Spalte in der Form ROWNO [AS] <result_column_name> angegeben wurde, erhält diese Ergebnisspalte den Namen result_column_name.

Über eine ROWNO-Spalte darf nicht mittels ORDER BY sortiert werden.

<stamp_column>

Eine STAMP-Spalte stamp_column darf nur in einer selektierten Spalte spezifiziert werden, die zu einem QUERY-Ausdruck (query_expression) einer INSERT-Anweisung gehört.

Das Datenbanksystem ist in der Lage, eindeutige Werte zu generieren. Dabei handelt es sich um eine fortlaufende Nummer, die bei X'000000000001' beginnt. Die Werte werden aufsteigend vergeben, wobei nicht sichergestellt werden kann, dass eine Folge von Werten lückenlos ist.

Die Angabe einer STAMP-Spalte liefert pro Zeile der Zwischenergebnistabelle den nächsten vom Datenbanksystem generierten Wert vom Datentyp CHAR(8) BYTE.

Weitere Informationen

Jede Spalte einer Ergebnistabelle hat den gleichen Datentyp, die gleiche Länge, die gleiche Genauigkeit und die gleiche Anzahl von Nachkommastellen wie die derived_column oder die zugrundeliegende Spalte der Tabellenspalten table_columns.

Für die Datentypen DATE und TIMESTAMP trifft dies nicht zu. Um die Darstellung jedes Datums- und Zeitformats zu ermöglichen, wird die Länge der Spalte der Ergebnistabelle auf die maximal notwendige Länge zur Darstellung eines Datumswertes (Länge 10) bzw. eines Zeitstempelwertes (Länge 26) gesetzt.


Set-Funktion (set_function_spec) (SAP-Bibliothek - Grundwissen)

Set-Funktion (set_function_spec)

Es gibt eine Reihe von Funktionen, die auf eine Menge von Werten (Zeilen) als Argument angewandt werden und ein Ergebnis liefern. Als Bezeichnung für derartige Funktionen wird der Begriff Set-Funktion (set_function_spec) verwendet.

Syntax

<set_function_spec> ::= COUNT(*)
| <all_function>
| <distinct_function>

<all_function> ::= <set_function_name>([ALL] <expression>)
<distinct_function> ::= <set_function_name>(DISTINCT <expression>)

<set_function_name> ::= AVG | COUNT | MAX | MIN | STDDEV | SUM | VARIANCE

Beispiele

SQL-Tutorial, Strukturlink Set-Funktionen, Strukturlink Bilden von Gruppen: GROUP BY, HAVING, Strukturlink Informationen über Zeichenketten

Erläuterung

Set-Funktionen arbeiten über Gruppen von Werten, aber sie geben nur einen Wert zurück. Das Ergebnis besteht aus einer Zeile. Wenn eine Set-Funktion in einer Anweisung verwendet wird, muss auch auf jede andere Spalte der Anfrage eine solche Funktion angewandt werden. Dies gilt jedoch nicht für eine Spalte, über die mittels GROUP BY eine Gruppierung vorgenommen wurde. Es wird dann für jede Gruppe der Wert der Set-Funktion bestimmt.

Das Argument einer DISTINCT-Funktion oder einer ALL-Funktion ist eine Ergebnistabelle oder eine Gruppe (die Ergebnistabelle kann durch eine GROUP-Bedingung gruppiert werden).

NULL-Werte werden, mit Ausnahme der Funktion COUNT(*), nicht in die Berechnung einbezogen.

Bei einigen Set-Funktionen wird unabhängig von dem bei der Anmeldung festgelegten Isolation-Level kein Sperrverfahren durchgeführt.

<set_function_name>

Die Set-Funktionen werden durch folgende Set-Funktionsnamen klassifiziert:

AVG

Das Ergebnis von AVG ist das arithmetische Mittel der Werte des Arguments. AVG kann nur auf numerische Werte angewandt werden. Das Ergebnis ist vom Datentyp FLOAT(38).

COUNT

- COUNT(*) liefert die Anzahl aller Werte (Zeilen der Ergebnistabelle oder einer Gruppe).

- COUNT(DISTINCT <expression>) liefert die Anzahl der voneinander verschiedenen Werte (Anzahl der Werte des Arguments der DISTINCT-Funktion).

- COUNT(ALL <expression>) liefert die Anzahl der Werte, die vom NULL-Wert verschieden sind (Anzahl der Werte des Arguments der ALL-Funktion).

Das Ergebnis ist vom Datentyp FIXED(10).

MAX

Das Ergebnis von MAX ist der größte Wert des Arguments.

MIN

Das Ergebnis von MIN ist der kleinste Wert des Arguments.

STDDEV

Das Ergebnis von STDDEV ist die Standardabweichung der Werte des Arguments. STDDEV kann nur auf numerische Werte angewandt werden. Das Ergebnis ist vom Datentyp FLOAT(38).

SUM

Das Ergebnis von SUM ist die Summe der Werte des Arguments. SUM kann nur auf numerische Werte angewandt werden. Das Ergebnis ist vom Datentyp FLOAT(38).

VARIANCE

Das Ergebnis von VARIANCE ist die Varianz der Werte des Arguments. VARIANCE kann nur auf numerische Werte angewandt werden. Das Ergebnis ist vom Datentyp FLOAT(38).

ALL/DISTINCT-Funktion

 | Ergebnis der ALL/DISTINCT-Funktion
Die Menge von Werten ist leer und die ALL-/DISTINCT-Funktion wird auf die gesamte Ergebnistabelle angewandt | Die Set-Funktionen AVG, MAX, MIN, STDDEV, SUM, VARIANCE liefern als Ergebnis den NULL-Wert. Die Set-Funktion COUNT liefert den Wert 0.
Es gibt keine Gruppe, auf die die ALL-/DISTINCT-Funktion angewandt werden kann. | Im Ergebnis erhält man eine leere Tabelle.
Die Menge von Werten enthält mindestens einen Spezial-NULL-Wert | Spezial-NULL-Wert
<all_function>

Die ALL-Funktion all_function ist eine Set-Funktion, die alle NULL-Werte entfernt.

Das Argument einer ALL-Funktion ist eine Menge von Werten, die wie folgt gebildet wird:

1. Eine Ergebnistabelle oder eine Gruppe (die Ergebnistabelle kann durch eine GROUP-Bedingung gruppiert werden) wird gebildet.

2. Auf jede Zeile dieser Ergebnistabelle oder Gruppe wird der Ausdruck expression angewandt.
Der Ausdruck darf keine Set-Funktion enthalten.

3. Alle NULL-Werte werden entfernt. Spezial-NULL-Werte werden nicht entfernt, zwei Spezial-NULL-Werte gelten als gleich.

Die ALL-Funktion wird unter Berücksichtigung des entsprechenden Set-Funktionsnamens set_function_name für die Menge von Werten durchgeführt.

Das Ergebnis einer ALL-Funktion ist unabhängig davon, ob das Schlüsselwort ALL angegeben wird oder nicht.

<distinct_function>

Die DISTINCT-Funktion distinct_function ist eine Set-Funktion, die doppelt vorkommende Werte und alle NULL-Werte entfernt.

Das Argument einer DISTINCT-Funktion ist eine Menge von Werten, die wie folgt gebildet wird:

...

1. Eine Ergebnistabelle oder eine Gruppe (die Ergebnistabelle kann durch eine GROUP-Bedingung gruppiert werden) wird gebildet.

2. Auf jede Zeile dieser Ergebnistabelle oder Gruppe wird der Ausdruck expression angewandt.
Der Ausdruck darf keine Set-Funktion erhalten.

3. Alle NULL-Werte und doppelt vorkommenden Werte werden entfernt (DISTINCT). Spezial-NULL-Werte werden nicht entfernt, zwei Spezial-NULL-Werte gelten als gleich.

Die DISTINCT-Funktion wird unter Berücksichtigung des entsprechenden Set-Funktionsnamens set_function_name für diese Menge von Werten durchgeführt.


Zeichensatz (token) (SAP-Bibliothek - Grundwissen)

Zeichensatz (token)

Ein Zeichensatz (token) besteht aus Zeichen, die zu einer lexikalischen Einheit zusammengefasst werden. Es werden reguläre und Sonderzeichensätze unterschieden.

Syntax

<token> ::= <regular_token> | <delimiter_token>

<regular_token> ::= <literal> | <key_word> | <identifier> | <parameter_name>

<delimiter_token> ::= <vertical_slash> | , | . | + | - | * | /
| < | > | <> | != | = | <= | >=
| ~= <! für Maschinen mit ASCII-Code !>
| ~< <! für Maschinen mit ASCII-Code !>
| ~> <! für Maschinen mit ASCII-Code !>

<vertical_slash> ::= |

SELECT * FROM reservation
ALTER TABLE reservation DROP FOREIGN KEY customer_reservation
'Reisen10'

Erläuterung

Nach jedem Zeichensatz können beliebig viele Leerzeichen folgen. Jeder reguläre Zeichensatz regular_token muss von einem Sonderzeichensatz delimiter_token oder einem Leerzeichen abgeschlossen werden.

Anführungszeichen innerhalb eines speziellen Bezeichners werden durch zwei direkt aufeinanderfolgende Anführungszeichen dargestellt.


Bezeichner (identifier) (SAP-Bibliothek - Grundwissen)

Bezeichner (identifier)

Bezeichner (identifier). Es werden einfache Bezeichner simple_identifier und spezielle Bezeichner special_identifier unterschieden.

Syntax

<identifier> ::= <simple_identifier>
| <double_quotes><special_identifier><double_quotes>

Einfache Bezeichner

<simple_identifier> ::= <first_character>[<identifier_tail_character>...]

<first_character> ::= <letter>
| <extended_letter>
| <language_specific_character>

<letter> ::= A | B | C | D | E | F | G | H | I | J | K
| L | M | N | O | P | Q | R | S | T | U | V
| W | X | Y | Z
| a | b | c | d | e | f | g | h | i | j | k
| l | m | n | o | p | q | r | s | t | u | v
| w | x | y | z

<extended_letter> ::= # | @ | $

<identifier_tail_character> ::= <digit>
| <letter>
| <extended_letter>
| <language_specific_character>
| <underscore>

<digit> ::= 0 | 1 | 2 | | 3 | 4 | 5 | 6 | 7 | 8 | 9

<underscore> ::= _

Spezielle Bezeichner

<special_identifier> ::= <special_identifier_character>...

<special_identifier_character> ::= <! Beliebige Zeichen, die in beliebiger Reihenfolge aneinandergereiht werden können !>

<double_quotes> ::= "

einfacher Bezeichner: reservation

spezieller Bezeichner: "ADD", "Example_1"

Erläuterung

Bezeichner können in Groß-/Kleinschreibung angegeben werden.

Einfache Bezeichner

Bei der Angabe von einfachen Bezeichnern simple_identifier spielt die Groß-/Kleinschreibung keine Rolle, da die Bezeichner immer vom Datenbanksystem in Großbuchstaben konvertiert werden.

Als erstes Zeichen darf in einem einfachen Bezeichner keine Ziffer und kein durchgehender Unterstrich underscore erscheinen. In einfachen Bezeichnern dürfen keine reservierten Schlüsselwörter verwendet werden.

Spezielle Bezeichner

Spezielle Bezeichner special_identifier werden innerhalb der Datenbank immer so verwendet wie angegeben, d.h. die Groß- und Kleinschreibung spielt eine Rolle. Spezielle Bezeichner sind case-sensitiv.

Soll der Name eines Datenbankobjekts Kleinbuchstaben, Sonderzeichen, reservierte Schlüsselwörter oder Leerzeichen enthalten, so ist das nur möglich, wenn Sie einen Bezeichner als speziellen Bezeichner angeben, der in doppelte Anführungszeichen double_quotes eingeschlossen ist.

Anführungszeichen innerhalb eines speziellen Bezeichners werden durch zwei direkt aufeinanderfolgende Anführungszeichen dargestellt.

Sprachenspezifische Zeichen

Ein sprachenspezifisches Zeichen language_specific_character ist jeder Buchstabe, der in einer nord-, mittel- oder südeuropäischen Sprache vorkommt und nicht in der Auflistung der Buchstaben enthalten ist.

Deutsche Umlaute: ä, ö, ü

Französische Buchstaben mit accent grave: à

Wenn eine UNICODE-fähige Datenbankinstanz installiert wurde, ist ein sprachenspezifisches Zeichen jedes Zeichen, das nicht in der Liste der Zeichen im ASCII-Code von 0 bis 127 enthalten ist.

Siehe auch:

Literal (literal)

Zeichensatz (token)


Schlüsselwort (key_word) (SAP-Bibliothek - Grundwissen)

Schlüsselwort (key_word)

Schlüsselwort (key_word). Es werden "normale" Schlüsselwörter (not_reserved_key_word) und reservierte Schlüsselwörter (reserved_key_word) unterschieden.

Syntax

<key_word> ::= <not_reserved_key_word> | <reserved_key_word>

Erläuterung

Schlüsselwörter können in Groß-/Kleinschreibung angegeben werden. Generell sollten Schlüsselwörter nicht zur Benennung von Objekten verwendet werden.

Eine Liste aller „normalen“ Schlüsselwörter not_reserved_key_word finden Sie im Syntaxverzeichnis unter not_reserved_key_word.

Eine Liste aller reservierten Schlüsselwörter reserved_key_word finden Sie im Syntaxverzeichnis unter reserved_key_word.
Reservierte Schlüsselwörter dürfen Sie nicht als einfachen Bezeichner verwenden. Allerdings können Sie reservierte Schlüsselwörter in Form von speziellen Bezeichnern als Bezeichner verwenden.

Siehe auch:

Bezeichner (identifier)

Zeichensatz (token)


Funktionen: Überblick (SAP-Bibliothek - Grundwissen)

Funktionen: Überblick

Liste aller Funktionsbezeichnungen

ABS | ACOS | ADDDATE
ADDTIME | ALL | ALPHA
ASCII | ASIN | ATAN
ATAN2 | AVG |
CASE | CEIL | CHAR
CHR | COS | COSH
COT | COUNT |
DATE | DATEDIFF | DAY
DAYNAME | DAYOFMONTH | DAYOFWEEK
DAYOFYEAR | DECODE | DEGREES
DISTINCT |  |
EXCEPT | EXP | EXPAND
FIXED | FLOAT | FLOOR
GET_OBJECTNAME | GET_SCHEMA | GREATEST
HEX | HEXTORAW | HOUR
INDEX | INITCAP | INTERSECT
LEAST | LENGTH | LFILL
LN | LOG | LOWER
LPAD | LTRIM |
MAKEDATE | MAKETIME | MAX
MAPCHAR | MICROSECOND | MIN
MINUTE | MONTH | MONTHNAME
NOROUND | NUM |
PI | POWER |
RADIANS | REPLACE | RFILL
ROUND | RPAD | RTRIM
SECOND | SIGN | SIN
SINH | SOUNDEX |
SQRT | SUBDATE | SUBSTR
SUBTIME | STDDEV | SUM
TAN | TANH | TIME
TIMEDIFF | TIMESTAMP | TRANSLATE
TRIM | TRUNC |
UNION | UPPER |
VALUE | VARIANCE |
WEEKOFYEAR |  |
YEAR |  |
|| | & |

Siehe auch:

Funktion (function_spec)

Set-Funktion (set_function_spec)

Name einer Datenbankfunktion (dbfunction_name)

Syntaxverzeichnis


Namen: Überblick (SAP-Bibliothek - Grundwissen)

Namen: Überblick

Namen identifizieren Objekte und Funktionen. In der folgenden Liste finden Sie einige Namen, die in der Syntaxbeschreibung der SQL-Anweisungen häufig verwendet werden.

Name |
Alias-Name | alias_name
Spaltenname | column_name
Constraint-Name | constraint_name
Name einer Datenbankfunktion | dbfunction_name
Name einer Datenbankprozedur | dbproc_name
Domänenname | domain_name
Funktionen | function_spec
Indexname | index_name
Indikatorname | indicator_name
Mapchar-Set-Name | mapchar_set_name
Parametername | parameter_name
Kennwort | password
Referenzname | reference_name
Name eines referentiellen Constraints | referential_constraint_name
Ergebnistabellenname | result_table_name
Rollenname | role_name
Schemaname | schema_name
Sequenzname | sequence_name
Set-Funktionsname | set_function_name
Synonymname | synonym_name
Tabellenname | table_name
Triggername | trigger_name
Benutzername | user_name

Erläuterung

Bei allen Namen, die sich aus mehreren, durch "." getrennten Bezeichnern zusammensetzen, können jeweils vor und hinter dem "." beliebig viele Leerzeichen angegeben werden.

Siehe auch:

Funktionen: Überblick

Syntaxverzeichnis


Alias-Name (alias_name) (SAP-Bibliothek - Grundwissen)

Alias-Name (alias_name)

Ein Alias-Name (alias_name) ist ein neuer Spaltenname, der den Namen einer Spalte in folgenden Arten von Tabellen angibt:

· View-Tabelle

· Tabelle, die mit einer rekursiven DECLARE CURSOR-Anweisung definiert wurde

Syntax

<alias_name> ::= <identifier>

Erläuterung

Es wird eine Fehlermeldung ausgegeben, wenn der Name aus mehr als 32 Zeichen besteht.

SQL-Anweisung, um einen Alias-Namen zu definieren

CREATE VIEW-Anweisung

Rekursive DECLARE CURSOR-Anweisung


Spaltenname (column_name) (SAP-Bibliothek - Grundwissen)

Spaltenname (column_name)

Ein Spaltenname (column_name) identifiziert eine Spalte.

Syntax

<column_name> ::= <identifier>

Erläuterung

Es wird eine Fehlermeldung ausgegeben, wenn der Name aus mehr als 32 Zeichen besteht.

SQL-Anweisungen

Spaltendefinition, Spaltenspezifikation

CREATE TABLE-Anweisung

CREATE INDEX-Anweisung

UNIQUE-Definition

RENAME COLUMN-Anweisung

COLUMN-Change-Definition

INSERT-Anweisung

UPDATE-Anweisung

MODIFY-Definition

UPDATE-Klausel

DROP-Definition


Constraint-Name (constraint_name) (SAP-Bibliothek - Grundwissen)

Constraint-Name (constraint_name)

Ein Constraint-Name (constraint_name) bezeichnet eine Integritätsbedingung für Zeilen einer Tabelle.

Syntax

<constraint_name> ::= <identifier>

Erläuterung

Es wird eine Fehlermeldung ausgegeben, wenn der Name aus mehr als 32 Zeichen besteht.

SQL-Anweisungen

CONSTRAINT-Definition

ALTER-Definition

CREATE DOMAIN-Definition

DROP-Definition

Siehe auch:

Datenintegrität absichern


Name einer Datenbankfunktion (dbfunction_name) (SAP-Bibliothek - Grundwissen)

Name einer Datenbankfunktion (dbfunction_name)

Ein Datenbankfunktionsname (dbfunction_name) bezeichnet eine Datenbankfunktion. Datenbankfunktionen sind spezialisierte Datenbankprozeduren. Es handelt sich um Unterprogramme, die beliebig viele Eingabe-, aber genau einen Ausgabeparamter besitzen. Dieser liefert das Ergebnis der Funktion.

Syntax

<dbfunction_name> ::= [<schema_name>.]<identifier>

Der Schemaname und der Bezeichner dürfen jeweils nicht länger als 32 Zeichen lang sein.

Erläuterung

Sie können benutzerspezifische Funktionen definieren, um Anwendungslogik auf den Server des Datenbanksystems zu verlagern. Diese Datenbankfunktionen können Sie wie die vordefinierten Funktionen verwenden. Bei der Namensgebung ist zu beachten, dass Sie nicht die Namen von vordefinierten Funktionen verwenden (Funktionen: Überblick).

Das Datenbanksystem stellt eine Sprache (spezielle SQL-Syntax, die um Variablen, Kontrollstrukturen und Möglichkeiten zur Fehlerbehandlung erweitert wurde) bereit, in der die Formulierung einer SQL-Zugriffsschicht auf der Server-Seite ermöglicht wird. Diese spezielle SQL-Syntax kann verwendet werden, um Datenbankfunktionen zu definieren. Diese Datenbankfunktionen können dann als Funktionsaufruf einer SQL-Anweisung ausgeführt werden (Datenbankfunktionsaufruf).

SQL-Anweisungen, um eine Datenbankfunktion anzulegen, aufzurufen und zu löschen

CREATE FUNCTION-Anweisung

Datenbankfunktionsaufruf (dbfunction_call)

DROP FUNCTION-Anweisung


Name einer Datenbankprozedur (dbproc_name) (SAP-Bibliothek - Grundwissen)

Name einer Datenbankprozedur (dbproc_name)

Der Name einer Datenbankprozedur (dbproc_name) bezeichnet eine Datenbankprozedur.

Syntax

<dbproc_name> ::= [<schema_name>.]<identifier>

Die Angabe von TEMP als Schema in einer Datenbankprozedur ist nicht zulässig.

Der Schemaname und der Bezeichner dürfen jeweils nicht länger als 32 Zeichen lang sein.

Erläuterung

In einer gut strukturierten Datenbankanwendung sind die SQL-Anweisungen typischerweise nicht über die gesamte Anwendung verteilt, sondern werden in einer Zugriffsschicht konzentriert. Diese Zugriffsschicht hat zur restlichen Anwendung eine prozedurale Schnittstelle, an der die Operationen auf Anwendungsobjekten in Form abstrakter Datentypen bereitgestellt werden.

In Client-Server-Konfigurationen erfolgt bei der Ausführung einer jeden SQL-Anweisung in der Zugriffsschicht eine Interaktion zwischen dem Client und dem Server. Die Anzahl dieser Interaktionen kann drastisch reduziert werden, wenn die SQL-Zugriffsschicht nicht mehr im Client, sondern im Server abläuft.

Dazu stellt das Datenbanksystem eine Sprache (spezielle SQL-Syntax, die um Variablen, Kontrollstrukturen und Möglichkeiten zur Fehlerbehandlung erweitert wurde) bereit, in der die Formulierung einer SQL-Zugriffsschicht auf der Server-Seite ermöglicht wird. Diese spezielle SQL-Syntax kann verwendet werden, um Datenbankprozeduren zu definieren.

Das hat drei wesentliche Vorteile:

· Die Anzahl der Interaktionen zwischen Client und Server wird um Faktoren reduziert. Nur noch pro Operation auf einem Anwendungsobjekt ist eine Client-Server-Kommunikation erforderlich, nicht mehr pro SQL-Anweisung. Das erhöht die Performance von Client-Server-Konfigurationen erheblich.

· Die SQL-Zugriffsschicht enthält prozedural formulierte Integritätsregeln und "business rules". Die Konzentration dieser Regeln auf der Server-Seite und ihre Elimination aus den Datenbankanwendungen führt dazu, dass jetzt an zentraler Stelle Änderungen dieser Regeln erfolgen können, die sofort in allen Datenbankanwendungen wirksam werden. Damit werden auch diese Integritäts- und Entscheidungsregeln Bestandteil des Katalogs im Datenbanksystem.

· Eine auf die Server-Seite verlagerte SQL-Zugriffsschicht in der Form von Datenbankprozeduren erlaubt es auch, kundenspezifische Datenbankfunktionalität bereitzustellen und ist daher ein wesentliches Customizing-Werkzeug.

Um eine Datenbankprozedur ausführen zu können, muss ein Benutzer das Aufrufprivileg dafür besitzen. Dieses Aufrufprivileg ist unabhängig davon, welche Privilegien der Benutzer auf den Tabellen und Spalten besitzt, die in der Datenbankprozedur benutzt werden. Es ist deshalb möglich, dass ein Benutzer über eine Datenbankprozedur SQL-Anweisungen ausführen kann, die für ihn außerhalb dieser Datenbankprozedur nicht zulässig sind.

Datenbankprozeduren werden aus der Anwendungsprogrammiersprache heraus explizit aufgerufen. Sie können Parameter enthalten, wobei nur LONG-Spalten ausgeschlossen sind. In wieweit LONG-Spalten innerhalb von Datenbankprozeduren verwendet werden können, hängt von deren Länge und dem zur Verfügung stehenden Speicherplatz ab.

Wie bei jeder SQL-Anweisung muss auch bei einem Aufruf einer Datenbankprozedur sichergestellt sein, dass dieser Aufruf im Erfolgsfall die gewünschten Wirkungen hat, im Fehlerfall aber keinerlei Effekte im Datenbanksystem hinterlässt. Damit dieses Verhalten auch für Datenbankprozeduren erreicht wird, stellt MaxDB geschachtelte Transaktionen bereit. Jeder Aufruf einer Datenbankprozedur kann innerhalb einer Subtransaktion ablaufen, die zurückgesetzt werden kann, ohne die Transaktionssteuerung der Datenbankanwendung zu beeinträchtigen.

SQL-Anweisungen, um eine Datenbankprozedur anzulegen, aufzurufen und zu löschen

CREATE DBPROC[EDURE]-Anweisung

CALL-Anweisung

DROP DBPROC[EDURE]-Anweisung

Siehe auch:

Triggername (trigger_name)

Name einer Datenbankfunktion (dbfunction_name)

Datenintegrität absichern


Domänenname (domain_name) (SAP-Bibliothek - Grundwissen)

Domänenname (domain_name)

Ein Domänenname (domain_name) identifiziert einen Wertebereich einer Tabellenspalte.

Syntax

<domain_name> ::= [<schema_name>.]<identifier>

Der Schemaname und der Bezeichner dürfen jeweils nicht länger als 32 Zeichen lang sein.

Erläuterung

Als Schemaname ist nur der Name des aktuellen Benutzers zulässig.

SQL-Anweisungen

CREATE DOMAIN-Anweisung

DROP DOMAIN-Anweisung


Indexname (index_name) (SAP-Bibliothek - Grundwissen)

Indexname (index_name)

Ein Indexname (index_name) identifiziert einen Index.

Syntax

<index_name> ::= <identifier>

Erläuterung

Es wird eine Fehlermeldung ausgegeben, wenn der Name aus mehr als 32 Zeichen besteht.

SQL-Anweisungen

CREATE INDEX-Anweisung

ALTER INDEX-Anweisung

RENAME INDEX-Anweisung

DROP INDEX-Anweisung


Indikatorname (indicator_name) (SAP-Bibliothek - Grundwissen)

Indikatorname (indicator_name)

Ein Indikatorname (indicator_name) bezeichnet eine Indikatorvariable in einer Anwendung, die zusammen mit einem Parameternamen angegeben werden kann.

Syntax

<indicator_name> ::= <parameter_name>

Erläuterung

Die Indikatorvariable einer Parameterspezifikation gibt Auskunft über aufgetretene Unregelmäßigkeiten (z.B. NULL-Wert, unterschiedliche Länge von Wert und Parameter).

Siehe auch:

Parameterspezifikation (parameter_spec)

Glossar, Parameter in SQL-Anweisungen


Mapchar-Set-Name (mapchar_set_name) (SAP-Bibliothek - Grundwissen)

Mapchar-Set-Name (mapchar_set_name)

Ein Mapchar-Set-Name (mapchar_set_name) identifiziert ein Mapchar-Set.

Syntax

<mapchar_set_name> ::= <identifier>

Der Bezeichner darf nicht länger als 32 Zeichen lang sein.

Erläuterung

Funktion, in der Mapchar-Sets verwendet werden

MAPCHAR

Anlegen und Löschen von Mapchar-Sets

Verwenden Sie den Database Manager GUI, um Mapchar-Sets zu verwalten.

Siehe auch:

Database Manager GUI, Strukturlink Mapchar-Sets anlegen, anzeigen, ändern und löschen


Kennwort (password) (SAP-Bibliothek - Grundwissen)

Kennwort (password)

Ein Kennwort (password) wird benötigt, um für einen Benutzer die Verbindung mit der Datenbankinstanz herzustellen (Datenbanksitzung aufbauen).

Syntax

<password> ::= <identifier>
| <first_password_character>[<identifier_tail_character>...]

<first_password_character> ::= <digit>
| <letter>
| <extended_letter>
| <language_specific_character>

<digit> ::= 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9

<letter> ::= A | B | C | D | E | F | G | H | I | J
| K | L | M | N | O | P | Q | R | S | T
| U | V | W | X | Y | Z
| a | b | c | d | e | f | g | h | i | j
| k | l | m | n | o | p | q | r | s | t
| u | v | w | x | y | z

<extended_letter> ::= # | @ | $

<identifier_tail_character> ::= <digit>
| <letter>
| <extended_letter>
| <language_specific_character>
| <underscore>

<underscore> ::= _

Erläuterung

Kennwörter werden nach dem 18. Zeichen abgeschnitten.

Sprachenspezfische Zeichen

Ein sprachenspezifisches Zeichen language_specific_character ist jeder Buchstabe, der in einer nord-, mittel- oder südeuropäischen Sprache vorkommt und nicht in der Auflistung der Buchstaben enthalten ist.

Deutsche Umlaute: ä, ö, ü

Französische Buchstaben mit accent grave: à

Wenn eine UNICODE-fähige Datenbankinstanz installiert wurde, ist ein sprachenspezifisches Zeichen jedes Zeichen, das nicht in der Liste der Zeichen im ASCII-Code von 0 bis 127 enthalten ist.

Siehe auch:

CREATE USER-Anweisung (create_user_statement)

ALTER PASSWORD-Anweisung (alter_password_statement)

Konzepte des Datenbanksystems, Konventionen für Benutzernamen und Kennwörter


Parametername (parameter_name) (SAP-Bibliothek - Grundwissen)

Parametername (parameter_name)

Ein Parametername (parameter_name) bezeichnet einen Parameter (Host-Variable) in einer Anwendung, die SQL-Anweisungen des Datenbanksystems enthält.

Syntax

<parameter_name> ::=
:<identifier>
| ?

Der Bezeichner darf nicht länger als 32 Zeichen lang sein.

Sie können auch den Platzhalter ? als Parameternamen verwenden.

Erläuterung

Vor den Bezeichner wird ein Doppelpunkt gesetzt.

Die Konventionen der Programmiersprache, in die die SQL-Anweisungen des Datenbanksystems eingebettet sind, bestimmen die Anzahl der signifikanten Zeichen eines Parameternamens.

Die Bezeichner für Parameternamen dürfen mit Ausnahme des ersten Zeichens die Zeichen "." und "_" enthalten.

Wenn Sie den Platzhalter ? als Parameternamen verwenden, muss in der Anwendung dafür gesorgt werden, dass vor Ausführung der SQL-Anweisung der Platzhalter durch den Parameterwert ersetzt wird.

Siehe auch:

Parameterspezifikation (parameter_spec)


Referenzname (reference_name) (SAP-Bibliothek - Grundwissen)

Referenzname (reference_name)

Ein Referenzname (reference_name) ist ein Bezeichner, der für einen bestimmten Gültigkeitsbereich deklariert und mit genau einer Tabelle assoziiert wird. Der Gültigkeitsbereich dieser Deklaration ist die gesamte SQL-Anweisung.

Syntax

<reference_name> ::= <identifier>

Der Bezeichner darf nicht länger als 32 Zeichen lang sein.

Erläuterung

In verschiedenen Gültigkeitsbereichen kann derselbe Referenzname mit verschiedenen Tabellen oder mit derselben Tabelle assoziiert werden.

Siehe auch:

Spaltenspezifikation

Selektierte Spalte

Tabellenausdruck

Rekursive DECLARE CURSOR-Anweisung

UPDATE-Anweisung

DELETE-Anweisung


Name eines Referentiellen Constraints (referential_constraint_name)

Der Name eines referentiellen Constraints (referential_constraint_name) bezeichnet ein referentielles Constraint (referentielle Integritätsbedingung). Diese Integritätsbedingung legt Lösch- und Existenzabhängigkeiten zwischen zwei Tabellen fest.

Syntax

<referential_constraint_name> ::= <identifier>

Erläuterung

Es wird eine Fehlermeldung ausgegeben, wenn der Name aus mehr als 32 Zeichen besteht.

SQL-Anweisungen

Referentielle CONSTRAINT-Definition

ALTER TABLE-Anweisung

Siehe auch:

Datenintegrität absichern


Ergebnistabellenname (result_table_name) (SAP-Bibliothek - Grundwissen)

Ergebnistabellenname (result_table_name)

Ein Ergebnistabellenname (result_table_name) identifiziert eine Ergebnistabelle.

Syntax

<result_table_name> ::= <identifier>

Erläuterung

Es wird eine Fehlermeldung ausgegeben, wenn der Name aus mehr als 32 Zeichen besteht.

Siehe auch:

QUERY-Anweisung

UPDATE-Klausel


Rollenname (role_name) (SAP-Bibliothek - Grundwissen)

Rollenname (role_name)

Ein Rollenname (role_name) identifiziert eine Rolle.

Syntax

<role_name> ::= <identifier>

Der Bezeichner darf nicht länger als 32 Zeichen lang sein.

Erläuterung

1. Mit der CREATE ROLE-Anweisung wird eine Rolle angelegt. Diese Rolle ist zunächst leer. Nur ein Datenbankadministrator kann Rollen anlegen. Der Name einer neuen Rolle darf nicht mit dem Namen einer vorhandenen Rolle, eines Benutzers oder einer Benutzergruppe identisch sein.

2. Mit Hilfe der GRANT-Anweisung werden einer Rolle Privilegien zugewiesen. Mit Hilfe der REVOKE-Anweisung können einer Rolle Privilegien entzogen werden.

3. Eine Rolle kann mit Hilfe der GRANT-Anweisung unter Angabe des Rollennamens Datenbankbenutzern, Benutzergruppen oder Rollen zugewiesen werden.

4. Mit Hilfe der ALTER USER- bzw. ALTER USERGROUP-Anweisung legen Sie fest, welche der Rollen, die einem Benutzer bzw. einer Benutzergruppe zugeordnet wurden, beim Eröffnen einer Datenbanksitzung verwendet werden sollen.

5. Während einer Datenbanksitzung können Sie mit Hilfe der SET-Anweisung andere dem Benutzer bzw. der Benutzergruppe zugeordnete Rollen aktivieren
Wenn eine Rolle während einer Sitzung aktiviert wird, dann hat der aktuelle Benutzer der Sitzung alle Privilegien, die einer Rolle zugeordnet sind.
Wenn für eine Rolle ein Kennwort definiert wurde, können Benutzer, die dieser Rolle zugeordnet wurden, die Rolle nur durch die Angabe des Kennwortes in der SET-Anweisung aktivieren.

Das Vorhandensein und die Eigenschaften einer Rolle werden in Form von Metadaten im Datenbankkatalog registriert. Ein Benutzer, der eine Rolle anlegt, wird zum Eigentümer dieser Rolle.

Die durch die ALTER USER- bzw. ALTER-USERGROUP-Anweisungen dem Benutzer bzw. der Benutzergruppe zugeordneten Rollen werden aktiviert, sobald eine Datenbanksitzung eröffnet wird.

Während der Ausführung von Datendefinitionsanweisungen sind für die ausführende Datenbanksitzung alle Rollen inaktiv.

SQL-Anweisung, um eine Rolle zu definieren

CREATE ROLE-Anweisung

SQL-Anweisung, um einer Rolle Privilegien zuzuordnen

GRANT-Anweisung

SQL-Anweisung, um eine Rolle zu vergeben

GRANT-Anweisung

SQL-Anweisungen, um eine Rolle zu aktivieren

ALTER USER-Anweisung

ALTER USERGROUP-Anweisung

SET-Anweisung

SQL-Anweisung, um eine Rolle zu löschen

DROP ROLE-Anweisung


Schemaname (schema_name) (SAP-Bibliothek - Grundwissen)

Schemaname (schema_name)

Die Zugehörigkeit eines Objektes zu einem Schema kann durch die Angabe des Namens des Schemas festgelegt werden.

Syntax

<schema_name> ::= <identifier>

Der Bezeichner darf nicht länger als 32 Zeichen lang sein.

Erläuterung

Schemas schaffen Namensräume für Datenbankobjekte.

Beim Anlegen eines Benutzers mit der CREATE USER-Anweisung wird implizit ein Schema erzeugt, dessen Name mit dem Benutzernamen übereinstimmt.

Beim Anlegen eines Schemas mit der CREATE SCHEMA-Anweisung können Schemaname und Eigentümer des Schemas explizit angegeben werden. Wird kein Eigentümer angegeben, wird der aktuelle Benutzer Eigentümer des Schemas.

Jedes Schema hat genau einen Eigentümer. Der Eigentümer des Schemas kann Objekte in seinem eigenen Schema anlegen, ändern oder löschen, da er implizit die entsprechenden Privilegien erhält. Er kann diese Privilegien an andere Benutzer weitergeben.

Es ist möglich, Schemas zu erzeugen, die nicht mit einem Benutzernamen korrespondieren. Der Datenbankbenutzer DAVID kann die Schemas A, B und C erzeugen, deren Eigentümer er dann ist, ohne dass es zugehörige Datenbankbenutzer A, B oder C gäbe.

Siehe auch:

CREATE SCHEMA-Anweisung (create_schema_statement)

GRANT-Anweisung (grant_statement)

RENAME SCHEMA-Anweisung (rename_schema_statement)

SET-Anweisung (set_statement)

DROP SCHEMA-Anweisung (drop_schema_statement)


Sequenzname (sequence_name) (SAP-Bibliothek - Grundwissen)

Sequenzname (sequence_name)

Ein Sequenzname (sequence_name) identifiziert eine Folge von Werten.

Syntax

<sequence_name> ::= <identifier>

Der Bezeichner darf nicht länger als 32 Zeichen lang sein.

Erläuterung

Sequenzen sind Folgen von Werten, die nach bestimmten Regeln erzeugt werden. Unter anderem kann die Schrittweite zwischen den Werten festgelegt werden.

Mit Sequenzen können eindeutige Werte erzeugt werden. Diese sind allerdings nicht lückenlos, da Werte, die in einer zurückgerollten Transaktion erzeugt wurden, nicht wieder verwendbar sind.

Siehe auch:

CREATE SEQUENCE-Anweisung

DROP SEQUENCE-Anweisung


Synonymname (synonym_name) (SAP-Bibliothek - Grundwissen)

Synonymname (synonym_name)

Ein Synonymname (synonym_name) bezeichnet ein Synonym für einen Tabellennamen. Synonyme sind gut geeignet, um lange oder komplizierte Tabellennamen abzukürzen.

Syntax

<synonym_name> ::= <identifier>

Der Bezeichner darf nicht länger als 32 Zeichen lang sein.

Erläuterung

Ein Synonym kann überall anstelle des alten Namens geschrieben werden. Da ein Synonym benutzerspezifisch ist, muss bei seiner Angabe keine Benutzeridentifikation mitgegeben werden. Bei Zugriff auf Tabellen, die einem anderen Benutzer gehören, müssen Sie also nicht den Benutzernamen vor dem Tabellennamen angeben, wenn Sie das Synonym verwenden.

Für eine Tabelle können mehrere Synonyme vergeben werden. Sie sind nicht an andere Benutzer verleihbar. Handelt es sich nicht um ein PUBLIC-Synonym, ist dieses Synonym nur für einen Benutzer oder eine Benutzergruppe bekannt. Ein PUBLIC-Synonym ist jedem Benutzer und jeder Benutzergruppe bekannt.

Siehe auch:

CREATE SYNONYM-Anweisung

RENAME SYNONYM-Anweisung

DROP SYNONYM-Anweisung


Tabellenname (table_name) (SAP-Bibliothek - Grundwissen)

Tabellenname (table_name)

Ein Tabellenname (table_name) identifiziert eine Tabelle.

Syntax

<table_name> ::= [<schema_name>.]<identifier>

Der Schemaname und der Bezeichner dürfen jeweils nicht länger als 32 Zeichen lang sein.

Erläuterung

Tabellen und View-Tabellen werden durch Tabellennamen identifiziert. Ein Tabellenname besteht aus einem Schemanamen (schema_name) und einem Bezeichner (identifier).

Alle Tabellenbezeichner, die einem Schema angehören, müssen voneinander verschieden sein.

Das Datenbanksystem verwendet für interne Zwecke einige Tabellennamen, bei denen der Bezeichner mit SYS beginnt. Um Namenskollisionen zu vermeiden, sollten Sie daher keine mit SYS beginnenden Tabellennamen verwenden.

Siehe auch:

CREATE TABLE-Anweisung

CREATE VIEW-Anweisung

CREATE SYNONYM-Anweisung

CREATE SCHEMA-Anweisung

und weitere SQL-Anweisungen zur Datendefinition


Triggername (trigger_name) (SAP-Bibliothek - Grundwissen)

Triggername (trigger_name)

Ein Triggername (trigger_name) bezeichnet einen Trigger, der für eine Tabelle definiert wird.

Syntax

<trigger_name> ::= <identifier>

Ein Triggername darf nicht länger als 32 Zeichen lang sein.

Erläuterung

Trigger sind spezialisierte Datenbankprozeduren, die implizit nach der Ausführung einer Datenmanipulationsanweisung auf einer Basistabelle oder einer View-Tabelle, der diese Basistabelle zugrundeliegt, ablaufen. Ein System-Trigger ist eine spezielle Datenbankprozedur, die im Verlauf eines Restarts implizit ausgeführt wird. Die Bedingungen, unter denen ein Trigger ausgeführt werden soll, können weiter eingeschränkt werden. Ein Trigger kann implizit weitere Trigger aufrufen.

Der Trigger wird für jede Zeile, auf die sich die SQL-Anweisung bezieht, ausgeführt. Der Trigger kann dabei auf die alten Werte in dieser Zeile (Werte vor der Veränderung bzw. dem Löschen) und auf die neuen Werte (Werte nach der Veränderung bzw. dem Einfügen) zugreifen.

Trigger können dazu verwendet werden, um komplizierte Integritätsregeln zu prüfen, abgeleitete Datenbankmodifikationen für diese Zeile oder andere anzustoßen oder um komplizierte Regeln zum Zugriffsschutz zu implementieren.

Das Datenbanksystem stellt eine Sprache (spezielle SQL-Syntax, die um Variablen, Kontrollstrukturen und Möglichkeiten zur Fehlerbehandlung erweitert wurde) bereit, in der die Formulierung einer SQL-Zugriffsschicht auf der Server-Seite ermöglicht wird. Diese spezielle SQL-Syntax kann verwendet werden, um Trigger zu definieren.

SQL-Anweisungen, um einen Trigger anzulegen und zu löschen

CREATE TRIGGER-Anweisung

DROP TRIGGER-Anweisung

SQL-Anweisungen, um einen System-Trigger anzulegen und zu löschen

CREATE SYSTEM TRIGGER-Anweisung

DROP SYSTEM TRIGGER-Anweisung

Siehe auch:

Name einer Datenbankprozedur

Datenintegrität absichern


Benutzergruppenname (usergroup_name) (SAP-Bibliothek - Grundwissen)

Benutzergruppenname (usergroup_name)

Ein Benutzergruppenname (usergroup_name) identifiziert eine Benutzergruppe.

Syntax

<usergroup_name> ::= <identifier>

Erläuterung

Es wird eine Fehlermeldung ausgegeben, wenn der Name aus mehr als 32 Zeichen besteht.

Siehe auch:

CREATE USERGROUP-Anweisung

ALTER USERGROUP-Anweisung)

RENAME USERGROUP-Anweisung

DROP USERGROUP-Anweisung

GRANT USERGROUP-Anweisung


Benutzername (user_name) (SAP-Bibliothek - Grundwissen)

Benutzername (user_name)

Ein Benutzername (user_name) identifiziert einen Datenbankbenutzer.

Syntax

<user_name> ::= <identifier>

Erläuterung

Es wird eine Fehlermeldung ausgegeben, wenn der Name aus mehr als 32 Zeichen besteht.

SQL-Anweisungen

CREATE USER-Anweisung

ALTER USER-Anweisung

ALTER PASSWORD-Anweisung

RENAME USER-Anweisung

DROP USER-Anweisung

GRANT USER-Anweisung

Siehe auch:

Konzepte des Datenbanksystems, Datenbankbenutzer


Privilegien: Überblick (SAP-Bibliothek - Grundwissen)

Privilegien: Überblick

Es gibt eine Reihe von Privilegien, über die einem Datenbankbenutzer die Berechtigungen für Datenmanipulationen oder Datenanfragen auf Datenbankobjekten vergeben werden können.

Privileg | Objekt | Dieses Privileg erlaubt dem Benutzer, ...
ALTER | Tabelle | die ALTER TABLE-Anweisung zu verwenden Siehe dazu: Privilegienspezifikation (priv_spec)
CREATEIN | Schema | Datenbankobjekte im angegebenen Schema zu erzeugen Siehe dazu: Privilegienspezifikation für ein Schema (schema_priv_spec)
DELETE | Tabelle | Zeilen in den angegebenen Tabellen zu löschen. Siehe dazu: Privilegienspezifikation (priv_spec)
DROPIN | Schema | Datenbankobjekte im angegebenen Schema zu löschen Siehe dazu: Privilegienspezifikation für ein Schema (schema_priv_spec)
EXECUTE | Datenbankprozedur Datenbankfunktion | die Datenbankprozedur oder die Datenbankfunktion auszuführen Siehe dazu: GRANT-Anweisung (grant_statement)
INDEX | Tabelle | die CREATE INDEX- und DROP INDEX-Anweisung zu verwenden Siehe dazu: Privilegienspezifikation (priv_spec)
INSERT | Tabelle | Zeilen in die angegebenen Tabellen einzufügen Siehe dazu: Privilegienspezifikation (priv_spec)
REFERENCES | Tabelle | die angegebene Tabelle als referenzierte Tabelle in einer Spaltendefinition oder referentiellen CONSTRAINT-Definition anzugeben Siehe dazu: Privilegienspezifikation (priv_spec)
SELECT | Sequenz | die angegebenen Sequenzen zu verwenden Siehe dazu: GRANT-Anweisung (grant_statement)
SELECT | Tabelle oder Teile einer Tabelle | Zeilen ganz oder teilweise in den angegebenen Tabellen zu selektieren Siehe dazu: Privilegienspezifikation (priv_spec)
SELUPD | Tabelle oder Teile einer Tabelle | Es werden die Privilegien SELECT und UPDATE vergeben Siehe dazu: Privilegienspezifikation (priv_spec)
UPDATE | Tabelle oder Teile einer Tabelle | Zeilen ganz oder teilweise in den angegebenen Tabellen zu ändern Siehe dazu: Privilegienspezifikation (priv_spec)

Siehe auch:

INSERT-/UPDATE-/DELETE-Privileg für Eigentümer der View-Tabelle

GRANT-Anweisung

REVOKE-Anweisung

Definitionen der Systemtabellen, ROLEPRIVILEGES, SCHEMAPRIVILEGES, SEQUENCEPRIVILEGES, TABLEPRIVILEGES


Privilegienspezifikation (priv_spec) (SAP-Bibliothek - Grundwissen)

Privilegienspezifikation (priv_spec)

Eine Privilegienspezifikation (priv_spec) definiert eine Rolle bzw. eine Menge von Privilegien für entsprechend angegebene Tabellen oder Teile von Tabellen.

Syntax

<priv_spec> ::= ALL [PRIV[ILEGES]] ON [TABLE] <table_name>,...
| <privilege>,... ON [TABLE] <table_name>,...
| <role_name>

<privilege> ::=
ALTER
| DELETE
| INDEX
| INSERT
| REFERENCES [(<column_name>,...)]
| SELECT [(<column_name>,...)]
| SELUPD [(<column_name>,...)]
| UPDATE [(<column_name>,...)]

Erläuterung

Keine der angegebenen Tabellen darf eine temporäre Basistabelle sein.

Der Benutzer muss die Berechtigung besitzen, die Privilegien auf den angegebenen Tabellen zu vergeben (GRANT-Anweisung) bzw. zu widerrufen (REVOKE-Anweisung). Für Basistabellen besitzt der Eigentümer der Tabelle diese Berechtigung.

Bei View-Tabellen besitzt auch der Eigentümer nicht immer die Berechtigung, alle Privilegien zu vergeben bzw. zu widerrufen. Welche Privilegien er für eine View-Tabelle vergeben bzw. widerrufen darf, wird vom Datenbanksystem beim Erzeugen der Tabelle festgestellt. Das Resultat hängt vom Typ der Tabelle sowie den Privilegien ab, die der Benutzer auf den in der View-Tabelle selektierten Tabellen besitzt. Der Eigentümer einer Tabelle kann die Privilegien, die er vergeben bzw. widerrufen darf, durch Selektieren der Systemtabelle DOMAIN.PRIVILEGES erfragen.

ALL [PRIV[ILEGES]]

Alle Privilegien, die der Benutzer auf Tabellen vergeben darf, werden an die angegebenen Benutzer, Benutzergruppen und Rollen vergeben (GRANT-Anweisung) bzw. widerrufen (REVOKE-Anweisung).

Wenn ein Benutzer, der nicht Eigentümer der Tabelle ist, in einer REVOKE-Anweisung ALL spezifiziert, entzieht er dem angegebenen Benutzer alle von ihm für diese Tabelle vergebenen Privilegien.

Wenn als Privilegienspezifikation eine Rolle angegeben ist, muss sie existieren und der aktuelle Benutzer muss Eigentümer der Rolle sein.

ALTER

Erlaubt dem identifizierten Benutzer, die ALTER TABLE-Anweisung für die angegebenen Tabellen auszuführen. Das ALTER-Privileg kann nur für Basistabellen vergeben werden. Der aktuelle Benutzer muss die Berechtigung besitzen, das ALTER-Privileg zu vergeben.

DELETE

Erlaubt dem identifizierten Benutzer, Zeilen in den angegebenen Tabellen zu löschen. Der aktuelle Benutzer muss die Berechtigung besitzen, das DELETE-Privileg zu vergeben.

INDEX

Erlaubt dem identifizierten Benutzer, die CREATE INDEX- und DROP INDEX-Anweisung für die angegebenen Tabellen auszuführen. Das INDEX-Privileg kann nur für Basistabellen vergeben werden. Der aktuelle Benutzer muss die Berechtigung besitzen, das INDEX-Privileg zu vergeben.

INSERT

Erlaubt dem identifizierten Benutzer, Zeilen in den angegebenen Tabellen einzufügen. Der aktuelle Benutzer muss die Berechtigung besitzen, das INSERT-Privileg zu vergeben.

REFERENCES

Erlaubt dem identifizierten Benutzer, die angegebene Tabelle als referenzierte Tabelle referenced_table in einer Spaltendefinition oder referentiellen CONSTRAINT-Definition anzugeben.

SELECT

Erlaubt dem identifizierten Benutzer, Zeilen in den angegebenen Tabellen zu selektieren. Wenn Spaltennamen angegeben sind, dürfen die Zeilen nur in den dadurch identifizierten Spalten selektiert werden. Der aktuelle Benutzer muss die Berechtigung besitzen, das SELECT-Privileg zu vergeben.

SELUPD

Es werden die Privilegien SELECT und UPDATE vergeben. Wenn Spaltennamen angegeben sind, dürfen die Zeilen nur in den dadurch identifizierten Spalten selektiert oder geändert werden. Der aktuelle Benutzer muss die Berechtigung besitzen, das SELECT- und das UPDATE-Privileg zu vergeben.

UPDATE

Erlaubt dem identifizierten Benutzer, Zeilen in den angegebenen Tabellen zu ändern. Wenn Spaltennamen angegeben sind, dürfen die Zeilen nur in den dadurch identifizierten Spalten geändert werden. Der aktuelle Benutzer muss die Berechtigung besitzen, das UPDATE-Privileg zu vergeben.

Siehe auch:

INSERT-/UPDATE-/DELETE-Privileg für Eigentümer der View-Tabelle

Privilegien: Überblick


Privilegienspezifikation für ein Schema (schema_priv_spec) (SAP-Bibliothek - Grundwissen)

Privilegienspezifikation für ein Schema (schema_priv_spec)

Eine Privilegienspezifikation für ein Schema (schema_priv_spec) definiert eine Menge von Privilegien in einem Schema.

Syntax

<schema_priv_spec> ::= <schema_privilege> ON <schema_name>,...

<schema_privilege> ::= CREATEIN | DROPIN

Erläuterung

Der Schemaname muss ein existierendes Schema identifizieren, darf jedoch nicht mit dem Namen eines Datenbankbenutzers übereinstimmen.

Der aktuelle Datenbankbenutzer muss Eigentümer jedes durch den Schemanamen identifizierten Schemas sein.

CREATEIN

Das CREATEIN-Privileg erlaubt das Erzeugen von Datenbankobjekten in dem angegebenen Schema.

DROPIN

Das DROPIN-Privileg erlaubt das Löschen von Datenbankobjekten in dem angegebenen Schema. Jeder Datenbankbenutzer, der dieses Privileg für ein Schema besitzt, kann beliebige Objekte des Schemas löschen. Dies ist unabhängig davon, ob er diese Objekte auch selbst erzeugt hat.

Siehe auch:

GRANT-Anweisung (grant_statement)

REVOKE-Anweisung (revoke_statement)

Privilegien: Überblick


Syntaxverzeichnis (SAP-Bibliothek - Grundwissen)

Komponentendokumentation Syntaxverzeichnis

Die in diesem Dokument verwendete Syntaxnotation ist die BNF.

Wesentliche Änderungen der Syntax im Vergleich zur Datenbankversion 7.5 werden im Abschnitt Syntaxänderungen vorgestellt.

A

<add_definition> ::=
 ADD <column_definition>,...
| ADD (<column_definition>,...)
| ADD <constraint_definition>
| ADD <key_definition>
| ADD <referential_constraint_definition>

<alias_name> ::=
<identifier>

<all_function> ::=
<set_function_name>([ALL] <expression>)

<alter_definition> ::=
ALTER CONSTRAINT <constraint_name> CHECK <search_condition>
| ALTER <key_definition>

<alter_index_statement> ::=
 ALTER INDEX <index_name> [ON <table_name>] ENABLE
| ALTER INDEX <index_name> [ON <table_name>] DISABLE
| ALTER INDEX <index_name> [ON <table_name>] INIT USAGE

<alter_password_statement>::=
 ALTER PASSWORD <old_password> TO <new_password>
| ALTER PASSWORD <user_name> <new_password>

<alter_table_statement> ::=
ALTER TABLE <table_name> <add_definition>
| ALTER TABLE <table_name> <alter_definition>
| ALTER TABLE <table_name> <column_change_definition>
| ALTER TABLE <table_name> <drop_definition>
| ALTER TABLE <table_name> <modify_definition>
| ALTER TABLE <table_name> <referential_constraint_definition>
| ALTER TABLE <table_name> <sample_definition>

<alter_user_statement> ::=
ALTER USER <user_name> [<user_mode>]
[TIMEOUT <unsigned_integer> | TIMEOUT NULL]
[COSTWARNING <unsigned_integer> | COSTWARNING NULL]
[COSTLIMIT <unsigned_integer> | COSTLIMIT NULL]
[DEFAULT ROLE ALL [EXCEPT <role_name>] | DEFAULT ROLE NONE | DEFAULT ROLE <role_name>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE ASCII]
[DEFAULTCODE UNICODE]
[<connect_mode>]

<alter_usergroup_statement> ::=
 ALTER USERGROUP <usergroup_name> [<usergroup_mode>]
[TIMEOUT <unsigned_integer> | TIMEOUT NULL]
[COSTWARNING <unsigned_integer> | COSTWARNING NULL]
[COSTLIMIT <unsigned_integer> | COSTLIMIT NULL]
[DEFAULT ROLE ALL [EXCEPT <role_name>] | DEFAULT ROLE NONE | DEFAULT ROLE <role_name>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE ASCII]
[DEFAULTCODE UNICODE]
[<connect_mode>]

<argument> ::=
<identifier>

<argument1> ::=
<identifier>

<arithmetic_function> ::=
ABS (<expression> )
| CEIL ( <expression> )
| EXP ( <expression> )
| FIXED ( <expression>[, <unsigned_integer> [, <unsigned_integer>] ] )
| FLOAT ( <expression>[, <unsigned_integer> ] )
| FLOOR ( <expression> )
| INDEX ( <string_spec>, <string_spec> [,<expression>[, <expression>] ] )
| LENGTH ( <expression> )
| LN ( <expression> )
| LOG ( <expression>, <expression> )
| NOROUND ( <expression> )
| PI
| POWER ( <expression>, <expression> )
| ROUND ( <expression>[, <expression>] )
| SIGN ( <expression> )
| SQRT ( <expression> )
| TRUNC ( <expression>[, <expression>] )

<ASCII_or_UNICODE> ::=
ASCII
| UNICODE

<assignment_statement> ::=
SET <variable_name> = <expression>

B

<between_predicate> ::=
 <expression> [NOT] BETWEEN <expression> AND <expression>

<bool_predicate> ::=
<column_spec> [IS [NOT] TRUE | IS [NOT] FALSE]

<boolean_factor> ::=
[NOT] <predicate>
| [NOT] (<search_condition>)

<boolean_term> ::=
 <boolean_factor>
| <boolean_term> AND <boolean_factor>

C

<call_statement> ::=
 CALL <dbproc_name> [(<expression>,...)] [WITH COMMIT]

<cascade_option> ::=
CASCADE
| RESTRICT

<case_else_clause> ::=
 ELSE <statement>;

<case_function> ::=
 <simple_case_function>
| <searched_case_function>

<case_statement> ::=
<simple_case_statement>
| <searched_case_statement>

<character> ::=
 <digit>
| <letter>
| <extended_letter>
| <hex_digit>
| <language_specific_character>
| <special_character>

<check_expression> ::=
<expression>

<close_statement> ::=
CLOSE [<result_table_name>]

<column_attributes> ::=
[<key_or_not_null_spec>] [<default_spec>] [UNIQUE] [<constraint_definition>]
[REFERENCES <referenced_table> [(<referenced_column>)] [<delete_rule>]]

<column_change_definition> ::=
  COLUMN <column_name> ADD <default_spec>
| COLUMN <column_name> ALTER <default_spec>
| COLUMN <column_name> DEFAULT NULL
| COLUMN <column_name> DROP DEFAULT
| COLUMN <column_name> NOT NULL

<column_definition> ::=
<column_name> <data_type> [<column_attributes>]
| <column_name> <domain_name> [<column_attributes>]

<column_list> ::=
<column_name>
| <column_list>, <column_name>

<column_name> ::=
<identifier>

<column_spec> ::=
<column_name>
| <table_name>.<column_name>
| <reference_name>.<column_name>
| <result_table_name>.<column_name>

<comment> ::=
<string_literal>
| <parameter_name>

<comment_on_statement> ::=
COMMENT ON <object_spec> IS <comment>

<commit_statement> ::=
COMMIT [WORK]

<comp_op> ::=
<
| >
| <>
| !=
| =
| <=
| >=
| ~= <! für Maschinen mit ASCII-Code !>
| ~< <! für Maschinen mit ASCII-Code !>
| ~> <! für Maschinen mit ASCII-Code !>

<comparison_predicate> ::=
<expression> <comp_op> <expression>
| <expression> <comp_op> <subquery>
| <expression_list> <equal_or_not> (<expression_list>)
| <expression_list> <equal_or_not> <subquery>

<connect_mode> ::=
ENABLE CONNECT
| DISABLE CONNECT

<connect_option> ::=
SQLMODE <INTERNAL_ANSI_DB2_ORACLE>
| ISOLATION LEVEL <unsigned_integer>
| TIMEOUT <unsigned_integer>

<connect_statement> ::=
CONNECT <parameter_name> IDENTIFIED BY <parameter_name> [<connect_option> ...]
| CONNECT <parameter_name> IDENTIFIED BY <password> [<connect_option> ...]
| CONNECT <user_name> IDENTIFIED BY <parameter_name> [<connect_option> ...]
| CONNECT <user_name> IDENTIFIED BY <password> [<connect_option> ...]

<constraint_definition> ::=
CHECK <search_condition>
| CONSTRAINT <search_condition>
| CONSTRAINT <constraint_name> CHECK <search_condition>

<constraint_name> ::=
 <identifier>

<conversion_function> ::=
  CHAR (<expression>[,<datetimeformat>])
| CHR (<expression>[,<unsigned_integer>])
| HEX (<expression>)
| HEXTORAW (<expression>)
| NUM (<expression>)

<create_dbproc_statement> ::=
CREATE DBPROC[EDURE] <dbproc_name> [(<formal_parameter>,...)] [RETURNS CURSOR] AS <routine>

<create_domain_statement> ::=
  CREATE DOMAIN <domain_name> <data_type> [<default_spec>] [<constraint_definition>]

<create_function_statement> ::=
 CREATE [PUBLIC] FUNCTION <dbfunction_name>
[(<formal_parameter1>,...)] RETURNS <data_type> [DETERMINISTIC] AS <routine>

<create_index_statement> ::=
CREATE [UNIQUE] INDEX <index_name> ON <table_name> (<index_spec>)

<create_role_statement> ::=
CREATE ROLE <role_name> [IDENTIFIED BY <password>]

<create_schema_statement> ::=
CREATE SCHEMA <schema_name_clause> [<schema_element> ...]

<create_sequence_statement>
::=
CREATE
SEQUENCE [<schema_name>.]<sequence_name>
[INCREMENT BY <integer>]
[START WITH <integer>]
[MAXVALUE <integer> | NOMAXVALUE]
[MINVALUE <integer> | NOMINVALUE]
[CYCLE | NOCYCLE]
[CACHE <unsigned_integer> | NOCACHE]
[ORDER | NOORDER]

<create_synonym_statement> ::=
  CREATE [PUBLIC] SYNONYM [<schema_name>.]<synonym_name> FOR <table_name>

<create_system_trigger_statement> ::=
CREATE SYSTEM TRIGGER [<schema_name>.]<trigger_name> AFTER RESTART EXECUTE (<routine>)

<create_table_statement> ::=
CREATE TABLE <table_name> (<column_definition> [,<table_description_element>,...])
[IGNORE ROLLBACK] [<sample_definition>]
| CREATE TABLE <table_name> [(<table_description_element>,...)]
[IGNORE ROLLBACK] [<sample_definition>]
AS <query_expression> [<duplicates_clause>]
| CREATE TABLE <table_name> LIKE <table_name> [IGNORE ROLLBACK]

<create_table_temp> ::=
<! <create_table_statement> für das Anlegen temporärer Tabellen,
d.h. der Tabellenname table_name in der CREATE TABLE-Anweisung
muss die Form TEMP.<identifier> haben. !>

<create_trigger_statement> ::=
CREATE TRIGGER <trigger_name> FOR <table_name> AFTER <trigger_event>,...
EXECUTE (<routine>) [WHENEVER <search_condition>]

<create_user_statement> ::=
CREATE USER <user_name> PASSWORD <password>
[<user_mode>]
[TIMEOUT <unsigned_integer>]
[COSTWARNING <unsigned_integer>]
[COSTLIMIT <unsigned_integer>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE <ASCII_or_UNICODE>]
[<connect_mode>]
| CREATE USER <user_name> PASSWORD <password> LIKE <source_user>
| CREATE USER <user_name> PASSWORD <password> USERGROUP <usergroup_name>

<create_usergroup_statement>
::=
CREATE
USERGROUP <usergroup_name>
[<usergroup_mode>]
[TIMEOUT <unsigned_integer>]
[COSTWARNING <unsigned_integer>]
[COSTLIMIT <unsigned_integer>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE ASCII_or_UNICODE]
[<connect_mode>]

<create_view_statement> ::=
CREATE [OR REPLACE] VIEW <table_name> [(<alias_name>,...)]
AS <query_expression> [WITH CHECK OPTION]

D

<data_type> ::=
CHAR[ACTER] [(<unsigned_integer>)] [ASCII | BYTE | UNICODE]
| VARCHAR [(<unsigned_integer>)] [ASCII | BYTE | UNICODE]
| LONG [VARCHAR] [ASCII | BYTE | UNICODE]
| BOOLEAN
| FIXED (<unsigned_integer> [,<unsigned_integer>])
| FLOAT (<unsigned_integer>)
| INT[EGER]
| SMALLINT
| DATE
| TIME
| TIMESTAMP

<date_function> ::=
ADDDATE (<date_or_timestamp_expression>, <expression>)
| DATEDIFF ( <date_or_timestamp_expression>, <date_or_timestamp_expression> )
| DAYNAME ( <date_or_timestamp_expression> )
| DAYOFMONTH ( <date_or_timestamp_expression> )
| DAYOFWEEK ( <date_or_timestamp_expression> )
| DAYOFYEAR ( <date_or_timestamp_expression> )
| MAKEDATE ( <expression>, <expression> )
| MONTHNAME ( <date_or_timestamp_expression> )
| SUBDATE ( <date_or_timestamp_expression>, <expression> )
| WEEKOFYEAR ( <date_or_timestamp_expression> )

<date_or_timestamp_expression> ::=
<expression>

<datetimeformat> ::=
EUR
| INTERNAL
| ISO
| JIS
| USA

<dbfunction_call> ::=
 <dbfunction_name> ( [<expression>,...] )

<dbfunction_name> ::=
 [<schema_name>.]<identifier>

<dbproc_name> ::=
[<schema_name>.]<identifier>

<declare_cursor_statement> ::=
DECLARE <result_table_name> CURSOR FOR <select_statement>

<default_expression> ::=
<expression>

<default_predicate> ::=
<column_spec> <comp_op> DEFAULT

<default_spec> ::=
DEFAULT <literal>
| DEFAULT NULL
| DEFAULT USER
| DEFAULT USERGROUP
| DEFAULT SYSDBA
| DEFAULT DATE
| DEFAULT TIME
| DEFAULT TIMESTAMP
| DEFAULT UTCDATE
| DEFAULT UTCDIFF
| DEFAULT TIMEZONE
| DEFAULT TRUE
| DEFAULT FALSE
| DEFAULT TRANSACTION
| DEFAULT STAMP
| DEFAULT SERIAL[(<unsigned_integer>)]

<delete_rule> ::=
ON DELETE CASCADE
| ON DELETE RESTRICT
| ON DELETE SET DEFAULT
| ON DELETE SET NULL

<delete_statement> ::=
DELETE [FROM] <table_name> [<reference_name>]
[KEY <key_spec>,...] [WHERE <search_condition>] [IGNORE TRIGGER] [NOWAIT]
| DELETE [FROM] <table_name> [<reference_name>]
WHERE CURRENT OF <result_table_name> [NOWAIT]

<delimiter_token> ::=
<vertical_slash> | , | . | + | - | * | / | < | > | <> | != | = | <= | >=
| ~= <! für Maschinen mit ASCII-Code !>
| ~< <! für Maschinen mit ASCII-Code !>
| ~> <! für Maschinen mit ASCII-Code !>

<derived_column> ::=
<expression> [ [AS] <result_column_name>]

<digit> ::=
0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9

<digit_sequence> ::=
<digit>...

<distinct_function> ::=
<set_function_name>(DISTINCT <expression>)

<distinct_spec> ::=
DISTINCT
| ALL

<domain_name> ::=
[<schema_name>.]<identifier>

<double_quotes> ::=
"

<drop_dbproc_statement> ::=
DROP DBPROC[EDURE] <dbproc_name>

<drop_definition> ::=
DROP <column_name>,... [<cascade_option>] [RELEASE SPACE]
| DROP (<column_name>,...) [<cascade_option>] [RELEASE SPACE]
| DROP CONSTRAINT <constraint_name>
| DROP FOREIGN KEY <referential_constraint_name>
| DROP PRIMARY KEY

<drop_domain_statement> ::=
DROP DOMAIN <domain_name>

<drop_function_statement> ::=
 DROP [PUBLIC] FUNCTION <dbfunction_name>

<drop_index_statement> ::=
DROP INDEX <index_name> [ON <table_name>]

<drop_role_statement> ::=
DROP ROLE <role_name>

<drop_schema_statement> ::=
DROP SCHEMA <schema_name> [<cascade_option>]

<drop_sequence_statement> ::=
DROP SEQUENCE [<schema_name>.]<sequence_name>

<drop_synonym_statement> ::=
DROP [PUBLIC] SYNONYM [<schema_name>.]<synonym_name>

<drop_system_trigger_statement> ::=
DROP SYSTEM TRIGGER [<schema_name>.]<trigger_name>

<drop_table_statement> ::=
DROP TABLE <table_name> [<cascade_option>]

<drop_table_temp> ::=
DROP TABLE TEMP.<identifier>

<drop_trigger_statement> ::=
DROP TRIGGER <trigger_name> OF <table_name>

<drop_user_statement> ::=
DROP USER <user_name> [<cascade_option>]

<drop_usergroup_statement> ::=
DROP USERGROUP <usergroup_name> [<cascade_option>]

<drop_view_statement> ::=
DROP VIEW <table_name> [<cascade_option>]

<duplicates_clause> ::=
REJECT DUPLICATES
| IGNORE DUPLICATES
| UPDATE DUPLICATES

E

<equal_or_not> ::=
<>
| =
| ~= <! für Maschinen mit ASCII-Code !>

<exists_predicate> ::=
EXISTS <subquery>

<exists_table_statement> ::=
EXISTS TABLE <table_name>

<explain_statement> ::=
EXPLAIN [(<result_table_name>)] <query_statement>
| EXPLAIN [(<result_table_name>)] <single_select_statement>

<exponent> ::=
[<sign>][[<digit>]<digit>]<digit>

<expression> ::=
<term>
| <expression> + <term>
| <expression> - <term>

<expression_list> ::=
(<expression>,...)

<extended_expression> ::=
<expression>
| DEFAULT
| STAMP

<extended_letter> ::=
#
| @
| $

<extended_value_spec> ::=
DEFAULT
| STAMP
| <value_spec>

<extraction_function> ::=
DATE ( <expression> )
| DAY ( <date_or_timestamp_expression> )
| HOUR ( <time_or_timestamp_expression> )
| MICROSECOND ( <expression> )
| MINUTE ( <time_or_timestamp_expression> )
| MONTH ( <date_or_timestamp_expression> )
| SECOND ( <time_or_timestamp_expression> )
| TIME ( <expression> )
| TIMESTAMP ( <expression>[, <expression> ] )
| YEAR ( <date_or_timestamp_expression> )

F

<factor> ::=
[<sign>] <value_spec>
| [<sign>] <column_spec>
| [<sign>] <function_spec>
| [<sign>] <set_function_spec>
| <scalar_subquery>
| <expression>

<fetch_statement> ::=
 FETCH [FIRST | LAST | NEXT | PREV | <position> | SAME] [<result_table_name>]
INTO <parameter_spec>,...

<final_select> ::=
<select_statement>

<first_character> ::=
<letter>
| <extended_letter>
| <language_specific_character>

<first_password_character> ::=
<letter>
| <extended_letter>
| <language_specific_character>
| <digit>

<fixed_point_literal> ::=
[<sign>]<digit_sequence>[.<digit_sequence>]
| [<sign>]<digit_sequence>.
| [<sign>].<digit_sequence>

<floating_point_literal> ::=
<mantissa>E<exponent>
| <mantissa>e<exponent>

<formal_parameter> ::=
IN <argument> <data_type>
| OUT <argument> <data_type>
| INOUT <argument> <data_type>

<formal_parameter1> ::=
<argument1> <data_type>

<from_clause> ::=
FROM <from_table_spec>,...

<from_table_spec> ::=
<table_name> [AS][<reference_name>]
| <result_table_name> [AS][<reference_name>]
| (<query_expression>) [AS][<reference_name>]
| <joined_table>

<function_spec> ::=
  <arithmetic_function>
| <conversion_function>
| <date_function>
| <dbfunction_call>
| <extraction_function>
| <special_function>
| <string_function>
| <time_function>
| <trigonometric_function>

G

<grant_statement> ::=
  GRANT <priv_spec>,... TO <grantee>,... [WITH GRANT OPTION]
| GRANT <schema_priv_spec> TO <grantee>,...
| GRANT EXECUTE ON <dbproc_name> TO <grantee>,...
| GRANT EXECUTE ON <dbfunction_name> TO <grantee>,...
| GRANT SELECT ON <sequence_name> TO <grantee>,... [WITH GRANT OPTION]

<grant_user_statement> ::=
  GRANT USER <granted_users> [FROM <user_name>] TO <user_name>

<grant_usergroup_statement> ::=
  GRANT USERGROUP <granted_usergroups> [FROM <user_name>] TO <user_name>

<granted_usergroups> ::=
  <usergroup_name>,...
| *

<granted_users> ::=
<user_name>,...
| *

<grantee> ::=
<user_name>
| <usergroup_name>
| <role_name>
| PUBLIC

<group_clause> ::=
GROUP BY <expression>,...

H

<having_clause> ::=
HAVING <search_condition>

<hex_digit> ::=
0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
| A | B | C | D | E | F
| a | b | c | d | e | f

<hex_digit_seq> ::=
<hex_digit><hex_digit>
| <hex_digit_seq><hex_digit><hex_digit>

<hex_literal> ::=
x''
| X''
| x'<hex_digit_seq>'
| X'<hex_digit_seq>'

<hours> ::=
<expression>

I

<identifier> ::=
<simple_identifier>
| <double_quotes><special_identifier><double_quotes>

<identifier_tail_character> ::=
<digit>
| <letter>
| <extended_letter>
| <language_specific_character>
| <underscore>

<if_statement> ::=
IF <search_condition> THEN <statement> [ELSE <statement>]

<in_predicate> ::=
<expression> [NOT] IN <subquery>
| <expression> [NOT] IN <expression_list>
| <expression_list> [NOT] IN <subquery>
| <expression_list> [NOT] IN (<expression_list>,...)

<index_column_name> ::=
<column_name> [ASC|DESC]

<index_name> ::=
<identifier>

<index_spec> ::=
<index_column_name>,...
| <dbfunction_name> (<column_name>,...) [ASC|DESC]

<indicator_name> ::=
  <parameter_name>

<initial_select> ::=
  <query_spec>

<inner_transaction_statement> ::=
  INNER TRANSACTION BEGIN
| INNER TRANSACTION COMMIT
| INNER TRANSACTION ROLLBACK

<insert_expression> ::=
  <extended_expression>
| <subquery>

<insert_statement> ::=
  INSERT [INTO] <table_name> [(<column_name>,...)]
    VALUES (<insert_expression>,...) [<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]
| INSERT [INTO] <table_name> [(<column_name>,...)]
    <query_expression> [<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]
| INSERT [INTO] <table_name> SET <set_insert_clause>,...
    [<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]

<integer> ::=
  [<sign>]<unsigned_integer>

<INTERNAL_ANSI_DB2_ORACLE> ::=
  INTERNAL
| ANSI
| DB2
| ORACLE

J

<join_predicate> ::=
  <expression> [<outer_join_indicator>] <comp_op> <expression> [<outer_join_indicator>]

<join_spec> ::=
  ON <search_condition>

<joined_table> ::=
  <from_table_spec> CROSS JOIN <from_table_spec>
| <from_table_spec> [INNER] JOIN <from_table_spec> <join_spec>
| <from_table_spec> [LEFT [OUTER] | RIGHT [OUTER] | FULL [OUTER]] JOIN
    <from_table_spec> <join_spec>

K

<key_definition> ::
  PRIMARY KEY (<column_name>,...)

<key_or_not_null_spec> ::=
  [PRIMARY] KEY
| NOT NULL [WITH DEFAULT]

<key_spec> ::=
  <column_name> = <value_spec>

<key_word> ::=
  <not_reserved_key_word>
| <reserved_key_word>

L

<language_specific_character> ::=
 <! <jeder Buchstabe, der in einer nord-, mittel- oder südeuropäischen Sprache
 vorkommt und nicht in der Auflistung <letter> enthalten ist>
| <für UNICODE-fähige Datenbanken: jedes Zeichen, das nicht in der
ASCII-Code-Liste von 0 bis 127 enthalten ist> !>

<letter> ::=
  A | B | C | D | E | F | G | H | I | J | K | L | M
| N | O | P | Q | R | S | T | U | V | W | X | Y | Z
| a | b | c | d | e | f | g | h | i | j | k | l | m
| n | o | p | q | r | s | t | u | v | w | x | y | z

<like_expression> ::=
  <expression>
| '<pattern_element>...'

<like_predicate> ::=
  <expression> [NOT] LIKE <like_expression> [ESCAPE <expression>]

<limit_clause> ::=
  LIMIT <row_count>
| LIMIT <offset>,<row_count>

<literal> ::=
  <string_literal>
| <numeric_literal>

<local_variable> ::=
  <variable_name> <data_type>

<local_variable_list> ::=
  <local_variable>
| <local_variable_list>;<local_variable>

<local_variables> ::=
  VAR <local_variable_list>;

<lock_option> ::=
  WITH LOCK [(IGNORE)|(NOWAIT)] [EXCLUSIVE | OPTIMISTIC] [ISOLATION LEVEL <unsigned_integer>]

<lock_spec> ::=
  TABLE <table_name>,...
| <row_spec> ...
| TABLE <table_name>,... <row_spec> ...

<lock_statement> ::=
LOCK [(WAIT)|(NOWAIT)] <lock_spec> IN SHARE MODE
| LOCK [(WAIT)|(NOWAIT)] <lock_spec> IN EXCLUSIVE MODE
| LOCK [(WAIT)|(NOWAIT)] <row_spec> ... OPTIMISTIC
| LOCK [(WAIT)|(NOWAIT)] <lock_spec> IN SHARE MODE <lock_spec> IN EXCLUSIVE MODE

M

<mantissa> ::=
<fixed_point_literal>

<mapchar_set_name> ::=
<identifier>

<match_char> ::=
<! Jedes Zeichen außer
%
| X'1F'
| <underscore>
| X'1E' !>

<match_set> ::=
<underscore>
| X'1E'
| <match_char>

<match_string> ::=
%
| X'1F'

<minutes> ::=
<expression>

<modify_column_definition> ::=
<column_name> <data_type> <column_attributes>
| <column_name> <data_type>
| <column_name> <column_attributes>

<modify_definition> ::=
  MODIFY (<modify_column_definition>,...)

<monitor_statement> ::=
  MONITOR INIT

N

<new_index_name> ::=
<index_name>

<new_password> ::=
<password>

<new_schema_name> ::=
<schema_name>

<new_synonym_name> ::=
<synonym_name>

<new_table_name> ::=
<table_name>

<new_user_name> ::=
<user_name>

<new_usergroup_name> ::=
<usergroup_name>

<next_stamp_statement> ::=
NEXT STAMP [INTO] <parameter_name>

<not_reserved_key_word> ::=

ADD | ADDRESS | ADD_MONTHS | AFTER
ALTERIN | ANALYZE | AND | ANSI
APPEND | ARCHIVE | AS | ASC
AT | AUTHORIZATION | AUTO | AUTOSAVE
BACKUP_PAGES | BAD | BEFORE | BEGIN
BEGINLOAD | BEGINPROC | BETWEEN | BLOCK
BLOCKSIZE | BOTH | BREAK | BUFFER
BUFFERPOOL | BWHIERARCHY | BY |
CACHE | CACHELIMIT | CACHES | CALL
CANCEL | CASCADE | CATALOG | CATCH
CHECKPOINT | CLEAR | CLOSE | CLUSTER
COMMENT | COMMIT | COMPUTE | CONFIG
CONNECT | CONSTRAINTS | CONTAINER | CONTINUE
COSTLIMIT | COSTWARNING | CREATE | CREATEIN
CURRENT_DATE | CURRENT_SCHEMA | CURRENT_TIME | CURRENT_TIMESTAMP
CURRVAL | CURSOR | CYCLE |
DATA | DAYS | DB2 | DBA
DBPROC | DBPROCEDURE | DB_ABOVE_LIMIT | DB_BELOW_LIMIT
DEBUG | DECLARE | DEFAULTCODE | DEGREE
DESC | DESCRIBE | DEVICE | DIAGNOSE
DIMENSION | DISABLE | DIV | DO
DOMAIN | DROP | DROPIN | DSETPASS
DUPLICATES | DYNAMIC |  |
EDITPROC | ELSE | ENABLE | END
ENDLOAD | ENDPROC | ERROR | ESCAPE
ESTIMATE | EUR | EVENT | EXCLUSIVE
EXECUTE | EXPLAIN | EXPLICIT | EXTENDED
FACT | FALSE | FETCH | FILE
FLUSH | FORCE | FOREIGN | FORMAT
FREEPAGE | FUNCTION | FVERSION |
GET | GRANT |  |
HIGH | HOLD | HOURS |
IDENTIFIED | IF | IMPLICIT | IN
INCREMENT | INDEXNAME | INDICATOR | INFO
INIT | INITRANS | INOUT | INPROC
INSTANCE | INSTR | IS | ISO
ISOLATION |  |  |
JAVA | JIS |  |
LABEL | LANGUAGE | LAST_DAY | LEVEL
LIKE | LOAD | LOCAL | LOCK
LOGFULL | LOGWRITER | LOG_ABOVE_LIMIT | LOW
MAXTRANS | MAXVALUE | MEDIANAME | MEDIUM
MICROSECONDS | MIGRATE | MINUS | MINUTES
MINVALUE | MODE | MODIFY | MONITOR
MONTHS | MONTHS_BETWEEN |  |
NAME | NEW | NEW_TIME | NEXTVAL
NEXT_DAY | NLSSORT | NLS_DATE_FORMAT | NLS_DATE_LANGUAGE
NLS_LANGUAGE | NLS_SORT | NOCACHE | NOCYCLE
NOLOG | NOMAXVALUE | NOMINVALUE | NONE
NOORDER | NOREWIND | NORMAL | NOSORT
NOWAIT | NUMBER | NVL |
OBID | OFF | ONLY | OPEN
OPTIMISTIC | OPTIMIZE | OPTION | OR
ORACLE | OUT | OUTER | OVERWRITE
PACKAGE | PAGE | PAGES | PARAM
PARSE | PARSEID | PASSWORD | PCTFREE
PCTUSED | PERCENT | PING | PIPE
POS | PRECISION | PREPARE | PRIV
PRIVILEGES | PROC | PROCEDURE | PSM
PUBLIC |  |  |
QUICK |  |  |
RANGE | RAW | RAWTOHEX | READ
RECURSIVE | REFERENCES | REGISTER | RELEASE
REMOTE | REMOVE | RENAME | REPLICATION
RESOURCE | RESTART | RESTORE | RESTRICT
RESUME | RETURN | RETURNS | REUSE
REVOKE | ROLE | ROLLBACK | ROW
ROWNUM | ROWS |  |
SAME | SAMPLE | SAPR3 | SAVE
SAVEPOINT | SCHEMA | SECONDS | SELECTIVITY
SEQUENCE | SERVERDB | SESSION | SHARE
SHUTDOWN | SNAPSHOT | SOUNDS | SQLID
SQLMODE | STANDARD | STANDBY | START
STARTPOS | STAT | STATE | STATIC
STOP | STORAGE | SUBPAGES | SUBTRANS
SUSPEND | SWITCH | SYNCHRONIZE | SYNONYM
SYSDATE |  |  |
TABID | TABLESPACE | TAKEOVER | TAPE
TEMP | THEN | TIMEOUT | TOPIC
TO_CHAR | TO_DATE | TO_NUMBER | TRACE
TRIGGER | TRUE | TRY | TYPE
UNIQUE | UNKNOWN | UNLOAD | UNLOCK
UNTIL | UNUSED | USA | USAGE
USERID |  |  |
VALIDPROC | VARCHAR2 | VERIFY | VERSION
VIEW | VOLUME | VSIZE | VTRACE
WAIT | WHENEVER | WHILE | WORK
WRITE | WRITER |  |
YEARS |  |  |

<null_predicate> ::=
<expression> IS [NOT] NULL

<numeric_literal> ::=
<fixed_point_literal>
| <floating_point_literal>

O

<object_spec> ::=
  COLUMN <table_name>.<column_name>
| DBPROC[EDURE] <dbproc_name>
| DOMAIN <domain_name>
| FOREIGN KEY <table_name>.<referential_constraint_name>
| INDEX <index_name> ON <table_name>
| SEQUENCE <sequence_name>
| [PUBLIC] SYNONYM <synonym_name>
| TABLE <table_name>
| TRIGGER <trigger_name>.<table_name>
| USER <user_name>
| USERGROUP <usergroup_name>
| <parameter_name>

<offset> ::=
  <unsigend_integer>
| <parameter_name>

<old_index_name> ::=
  <index_name>

<old_password> ::=
  <password>

<old_synonym_name> ::=
  <synonym_name>

<old_table_name> ::=
  <table_name>

<order_clause> ::=
  ORDER BY <sort_spec>,...

<outer_join_indicator> ::=
  (+)

P

<parameter_name> ::=
  :<identifier>
| ?

<parameter_spec> ::=
  <parameter_name> [<indicator_name>]

<password> ::=
<identifier>
| <first_password_character>[<identifier_tail_character>...]

<pattern_element> ::=
<match_string>
| <match_set>

<position> ::=
  POS (<unsigned_integer>)
| POS (<parameter_spec>)
| ABSOLUTE <integer>
| ABSOLUTE <parameter_spec>
| RELATIVE <integer>
| RELATIVE <parameter_spec>

<predicate> ::=
  <between_predicate>
| <bool_predicate>
| <comparison_predicate>
| <default_predicate>
| <exists_predicate>
| <in_predicate>
| <join_predicate>
| <like_predicate>
| <null_predicate>
| <quantified_predicate>
| <rowno_predicate>
| <sound_predicate>

<priv_spec> ::=
  ALL [PRIV[ILEGES]] ON [TABLE] <table_name>,...
| <privilege>,...  ON [TABLE] <table_name>,...
| <role_name>

<privilege> ::=
  ALTER
| DELETE
| INDEX
| INSERT
| REFERENCES [(<column_name>,...)]
| SELECT [(<column_name>,...)]
| SELUPD [(<column_name>,...)]
| UPDATE [(<column_name>,...)]

Q

<quantified_predicate> ::=
<expression> <comp_op> <quantifier> <expression_list>
| <expression> <comp_op> <quantifier> <subquery>
| <expression_list> <equal_or_not> <quantifier> (<expression_list>,...)
| <expression_list> <equal_or_not> <quantifier> <subquery>

<quantifier> ::=
ALL
| SOME
| ANY

<query_expression> ::=
<query_term>
| <query_expression> UNION [ALL] <query_term>
| <query_expression> EXCEPT [ALL] <query_term>

<query_primary> ::=
<query_spec>
| (<query_expression>)

<query_spec> ::=
SELECT [<distinct_spec>] [<top_spec>] <select_column>,... <table_expression>

<query_statement> ::=
<declare_cursor_statement>
| <recursive_declare_cursor_statement>
| <select_statement>

<query_term> ::=
<query_primary>
| <query_term> INTERSECT [ALL] <query_primary>

R

<recursive_declare_cursor_statement> ::=
DECLARE <result_table_name> CURSOR FOR WITH RECURSIVE <reference_name> (<alias_name>,...) AS (<initial_select> UNION ALL <recursive_select>) <final_select>

<recursive_select> ::=
  <query_spec>

<reference_name> ::=
  <identifier>

<referenced_column> ::=
  <column_name>

<referenced_table> ::=
  <table_name>

<referencing_column> ::=
  <column_name>

<referential_constraint_definition> ::=
FOREIGN KEY [<referential_constraint_name>] (<referencing_column>,...)
REFERENCES <referenced_table> [(<referenced_column>,...)] [<delete_rule>]

<referential_constraint_name> ::=
<identifier>

<regular_token> ::=
<literal>
| <key_word>
| <identifier>
| <parameter_name>

<release_savepoint_statement> ::=
RELEASE SAVEPOINT <sql_savepoint_name>

<release_statement> ::=
COMMIT [WORK] RELEASE
| ROLLBACK [WORK] RELEASE

<rename_column_statement> ::=
  RENAME COLUMN <table_name>.<column_name> TO <column_name>

<rename_index_statement> ::=
  RENAME INDEX <old_index_name> [ON <table_name>] TO <new_index_name>

<rename_schema_statement> ::=
  RENAME SCHEMA <schema_name> TO <new_schema_name>

<rename_synonym_statement> ::=
  RENAME [PUBLIC] SYNONYM <old_synonym_name> TO <new_synonym_name>

<rename_table_statement> ::=
RENAME TABLE <old_table_name> TO <new_table_name>

<rename_user_statement> ::=
RENAME USER <user_name> TO <new_user_name>

<rename_usergroup_statement> ::=
RENAME USERGROUP <usergroup_name> TO <new_usergroup_name>

<rename_view_statement> ::=
RENAME VIEW <old_table_name> TO <new_table_name>

<reserved_key_word> ::=

ABS | ABSOLUTE | ACOS | ADDDATE
ADDTIME | ALL | ALPHA | ALTER
ANY | ASCII | ASIN | ATAN
ATAN2 | AVG |  |
BINARY | BIT | BOOLEAN | BYTE
CASE | CEIL | CEILING | CHAR
CHARACTER | CHECK | CHR | COLUMN
CONCAT | CONSTRAINT | COS | COSH
COT | COUNT | CROSS | CURDATE
CURRENT | CURTIME |  |
DATABASE | DATE | DATEDIFF | DAY
DAYNAME | DAYOFMONTH | DAYOFWEEK | DAYOFYEAR
DEC | DECIMAL | DECODE | DEFAULT
DEGREES | DELETE | DIGITS | DISTINCT
DOUBLE |  |  |
EXCEPT | EXISTS | EXP | EXPAND
FIRST | FIXED | FLOAT | FLOOR
FOR | FROM | FULL |
GET_OBJECTNAME | GET_SCHEMA | GRAPHIC | GREATEST
GROUP |  |  |
HAVING | HEX | HEXTORAW | HOUR
IFNULL | IGNORE | INDEX | INITCAP
INNER | INSERT | INT | INTEGER
INTERNAL | INTERSECT | INTO |
JOIN |  |  |
KEY |  |  |
LAST | LCASE | LEAST | LEFT
LENGTH | LFILL | LIST | LN
LOCATE | LOG | LOG10 | LONG
LONGFILE | LOWER | LPAD | LTRIM
MAKEDATE | MAKETIME | MAPCHAR | MAX
MBCS | MICROSECOND | MIN | MINUTE
MOD | MONTH | MONTHNAME |
NATURAL | NCHAR | NEXT | NO
NOROUND | NOT | NOW | NULL
NUM | NUMERIC |  |
OBJECT | OF | ON | ORDER
PACKED | PI | POWER | PREV
PRIMARY |  |  |
RADIANS | REAL | REJECT | RELATIVE
REPLACE | RFILL | RIGHT | ROUND
ROWID | ROWNO | RPAD | RTRIM
SECOND | SELECT | SELUPD | SERIAL
SET | SHOW | SIGN | SIN
SINH | SMALLINT | SOME | SOUNDEX
SPACE | SQRT | STAMP | STATISTICS
STDDEV | SUBDATE | SUBSTR | SUBSTRING
SUBTIME | SUM | SYSDBA |
TABLE | TAN | TANH | TIME
TIMEDIFF | TIMESTAMP | TIMEZONE | TO
TOIDENTIFIER | TRANSACTION | TRANSLATE | TRIM
TRUNC | TRUNCATE |  |
UCASE | UID | UNICODE | UNION
UPDATE | UPPER | USER | USERGROUP
USING | UTCDATE | UTCDIFF |
VALUE | VALUES | VARCHAR | VARGRAPHIC
VARIANCE |  |  |
WEEK | WEEKOFYEAR | WHEN | WHERE
WITH |  |  |
YEAR |  |  |
ZONED |  |  |

<result_column_name> ::=
<identifier>

<result_expression> ::=
<expression>

<result_table_name> ::=
<identifier>

<revoke_statement> ::=
REVOKE <priv_spec>,... FROM <grantee>,... [<cascade_option>]
| REVOKE <schema_priv_spec> FROM <grantee>,...
| REVOKE EXECUTE ON <dbproc_name> FROM <grantee>,...
| REVOKE EXECUTE ON <dbfunction_name> FROM <grantee>,...
| REVOKE SELECT ON <sequence_name> FROM <grantee>,... [<cascade_option>]

<role_name> ::=
<identifier>

<rollback_statement> ::=
ROLLBACK [WORK]

<rollback_to_statement> ::=
ROLLBACK TO [SAVEPOINT] <sql_savepoint_name>

<routine>
::=
[<local_variables>]
<statement_list>;

<routine_sql_statement> ::=
<call_statement>
| <close_statement>
| <create_table_temp>
| <declare_cursor_statement>
| <delete_statement>
| <drop_table_temp>
| <fetch_statement>
| <insert_statement>
| <lock_statement>
| <recursive_declare_cursor_statement>
| <select_statement>
| <single_select_statement>
| <subtrans_statement>
| <update_statement>

<row_count> ::=
<unsigned_integer>
| <parameter_name>

<row_spec> ::=
ROW <table_name> KEY <key_spec>,...
| ROW <table_name> CURRENT OF <result_table_name>

<rowno_column> ::=
ROWNO [ [AS] <result_column_name>]

<rowno_predicate> ::=
ROWNO < <unsigned_integer>
| ROWNO < <parameter_spec>
| ROWNO <= <unsigned_integer>
| ROWNO <= <parameter_spec>

S

<sample_definition> ::=
SAMPLE <unsigned_integer> ROWS
| SAMPLE <unsigned_integer> PERCENT

<savepoint_statement> ::=
SAVEPOINT <sql_savepoint_name>

<scalar_subquery> ::=
<subquery>

<schema_authorization_identifier> ::=
<identifier>

<schema_element> ::=
<create_table_statement>
| <create_view_statement>
| <create_dbproc_statement>
| <create_function_statement>
| <create_sequence_statement>

<schema_name> ::=
<identifier>

<schema_name_clause> ::=
<schema_name>
| <schema_name> AUTHORIZATION <schema_authorization_identifier>

<schema_priv_spec> ::=
<schema_privilege> ON <schema_name>,...

<schema_privilege> ::=
CREATEIN
| DROPIN

<search_and_result_spec> ::=
<search_expression>, <result_expression>

<search_condition> ::=
<boolean_term>
| <search_condition> OR <boolean_term>

<search_expression> ::=
<expression>

<searched_case_function> ::=
WHEN <search_condition> THEN <result_expression>
[...]
[ELSE <default_expression>]
END

<searched_case_statement> ::=
CASE
<searched_case_when_clause> ...
[<case_else_clause>]
END [CASE]

<searched_case_when_clause> ::=
WHEN <search_condition> THEN <statement>;

<seconds> ::=
<expression>

<select_column> ::=
  <table_columns>
| <derived_column>
| <rowno_column>
| <stamp_column>

<select_statement> ::=
  <query_expression> [<order_clause>] [<limit_clause>] [<update_clause>]
    [<lock_option>] [FOR REUSE]

<sequence_name> ::=
<identifier>

<set_function_name> ::=
AVG
| COUNT
| MAX
| MIN
| STDDEV
| SUM
| VARIANCE

<set_function_spec> ::=
COUNT (*)
| <all_function>
| <distinct_function>

<set_insert_clause> ::=
<column_name> = <extended_value_spec>

<set_statement> ::=
SET ROLE ALL [EXCEPT <role_name>,...]
| SET ROLE NONE
| SET ROLE <role_name>,... [IDENTIFIED BY <password>]
| SET ISOLATION LEVEL <unsigned_integer>
| SET CURRENT_SCHEMA = <schema_name>

<set_update_clause> ::=
<column_name> = <extended_expression>
| <column_name>,... = (<extended_expression>,...)
| (<column_name>,...) = (<extended_expression>,...)
| <column_name> = <subquery>
| (<column_name>,...) = <subquery>

<sign> ::=
  +
| -

<simple_case_function> ::=
  CASE <check_expression>
    WHEN <search_expression> THEN <result_expression>
      [...]
    [ELSE <default_expression>]
  END

<simple_case_statement> ::=
  CASE <expression>
    <simple_case_when_clause> ...
    [<case_else_clause>]
  END [CASE]

<simple_case_when_clause> ::=
WHEN <literal>[, ...] THEN <statement>;

<simple_identifier> ::=
<first_character>[<identifier_tail_character>...]

<single_select_statement> ::=
  SELECT [<distinct_spec>] <select_column>,... INTO <parameter_spec>,...
    FROM <from_table_spec>,...[<where_clause>] [<group_clause>]
    [<having_clause>] [<lock_option>]

<sort_spec> ::=
  <unsigned_integer> [ASC | DESC]
| <expression> [ASC | DESC]

<sound_predicate> ::=
  <expression> [NOT] SOUNDS [LIKE] <expression>

<source_user> ::=
  <user_name>

<special_character> ::=
  <! Jedes Zeichen außer
    <digit>
  | <letter>
  | <extended_letter>
  | <hex_digit>
  | <language_specific_character >
  | <Zeichen für das Zeilenende in einer Datei> !>

<special_function> ::=
<case_function>
| DECODE (<check_expression>,<search_and_result_spec>,...[,<default_expression>])
| GREATEST (<expression>,<expression>,...)
| LEAST (<expression>,<expression>,...)
| VALUE (<expression>,<expression>,...)

<special_identifier> ::=
<special_identifier_character>...

<special_identifier_character> ::=
<! <Jedes beliebige Zeichen> !>

<sql_comment> ::=
/*<sql_comment_text>*/
| --<sql_comment_text>

<sql_comment_text> ::=
<! <Kommentartext> !>

<sql_savepoint_name> ::=
<identifier>

<sql_statement> ::=
<alter_index_statement>
| <alter_password_statement>
| <alter_table_statement>
| <alter_user_statement>
| <alter_usergroup_statement>
| <call_statement>
| <close_statement>
| <comment_on_statement>
| <commit_statement>
| <connect_statement>
| <create_dbproc_statement>
| <create_domain_statement>
| <create_function_statement>
| <create_index_statement>
| <create_role_statement>
| <create_schema_statement>
| <create_sequence_statement>
| <create_synonym_statement>
| <create_system_trigger_statement>
| <create_table_statement>
| <create_trigger_statement>
| <create_user_statement>
| <create_usergroup_statement>
| <create_view_statement>
| <delete_statement>
| <drop_dbproc_statement>
| <drop_domain_statement>
| <drop_function_statement>
| <drop_index_statement>
| <drop_role_statement>
| <drop_schema_statement>
| <drop_sequence_statement>
| <drop_synonym_statement>
| <drop_system_trigger_statement>
| <drop_table_statement>
| <drop_trigger_statement>
| <drop_user_statement>
| <drop_usergroup_statement>
| <drop_view_statement>
| <exists_table_statement>
| <explain_statement>
| <fetch_statement>
| <grant_statement>
| <grant_user_statement>
| <grant_usergroup_statement>
| <inner_transaction_statement>
| <insert_statement>
| <lock_statement>
| <monitor_statement>
| <next_stamp_statement>
| <query_statement>
| <release_statement>
| <rename_column_statement>
| <rename_index_statement>
| <rename_schema_statement>
| <rename_synonym_statement>
| <rename_table_statement>
| <rename_user_statement>
| <rename_usergroup_statement>
| <rename_view_statement>
| <revoke_statement>
| <rollback_statement>
| <rollback_to_statement>
| <savepoint_statement>
| <set_statement>
| <single_select_statement>
| <subtrans_statement>
| <unlock_statement>
| <update_statement>
| <update_statistics_statement>

<stamp_column> ::=
STAMP [ [AS] <result_column_name>]

<statement> ::=
BEGIN <statement_list> END
| BREAK
| CONTINUE
| CONTINUE EXECUTE
| <if_statement>
| <while_statement>
| <assignment_statement>
| <case_statement>
| RETURN [<expression>]
| STOP (<expression> [,<expression>] )
| TRY <statement_list>; CATCH <statement>
| <routine_sql_statement>

<statement_list> ::=
<statement>
| <statement_list> ; <statement>

<string_function> ::=
<string_spec> || <string_spec>
| <string_spec> & <string_spec>
| ALPHA (<string_spec>[,<unsigned_integer>])
| ASCII (<string_spec>)
| EXPAND (<string_spec>,<unsigned_integer>)
| GET_OBJECTNAME (<string_literal>)
| GET_SCHEMA (<string_literal>)
| INITCAP (<string_spec>)
| LFILL (<string_spec>,<string_literal>[,<unsigned_integer>])
| LOWER (<string_spec>)
| LPAD (<string_spec>,<expression>,<string_literal>[,<unsigned_integer>])
| LTRIM (<string_spec>[,<string_spec>])
| MAPCHAR (<string_spec>[,<unsigned_integer>][,<mapchar_set_name>])
| REPLACE (<string_spec>,<string_spec>[,<string_spec>])
| RFILL (<string_spec>,<string_literal>[,<unsigned_integer>])
| RPAD (<string_spec>,<expression>,<string_literal>[,<unsigned_integer>])
| RTRIM (<string_spec>[,<string_spec>])
| SOUNDEX (<string_spec>)
| SUBSTR (<string_spec>,<expression>[,<expression>])
| TRANSLATE (<string_spec>,<string_spec>,<string_spec>)
| TRIM (<string_spec>[,<string_spec>])
| UPPER (<string_spec>)

<string_literal> ::=
''
| '<character>...'
| <hex_literal>

<string_spec> ::=
<expression>

<subquery> ::=
(<query_expression>)

<subtrans_statement> ::=
SUBTRANS BEGIN
| SUBTRANS END
| SUBTRANS ROLLBACK

<synonym_name> ::=
<identifier>

T

<table_columns> ::=
  *
| <table_name>.*
| <reference_name>.*

<table_description_element> ::=
  <column_definition>
| <constraint_definition>
| <referential_constraint_definition>
| <key_definition>
| <unique_definition>

<table_expression> ::=
  <from_clause> [<where_clause>] [<group_clause>] [<having_clause>]

<table_name> ::=
  [<schema_name>.]<identifier>

<term> ::=
<factor>
| <term> * <factor>
| <term> / <factor>
| <term> DIV <factor>
| <term> MOD <factor>

<time_expression> ::=
<expression>

<time_or_timestamp_expression> ::=
<expression>

<time_function> ::=
ADDTIME (<time_or_timestamp_expression>, <time_expression> )
| MAKETIME (<hours>, <minutes>, <seconds> )
| SUBTIME ( <time_or_timestamp_expression>, <time_expression> )
| TIMEDIFF ( <time_or_timestamp_expression>, <time_or_timestamp_expression> )

<token> ::=
<regular_token>
| <delimiter_token>

<top_spec> ::=
TOP <unsigned_integer>
| TOP <parameter_name>

<trigger_event> ::=
  INSERT
| UPDATE [(<column_list>)]
| DELETE

<trigger_name> ::=
  <identifier>

<trigonometric_function> ::=
  COS ( <expression> )
| SIN ( <expression> )
| TAN ( <expression> )
| COT ( <expression> )
| COSH ( <expression> )
| SINH ( <expression> )
| TANH ( <expression> )
| ACOS ( <expression> )
| ASIN ( <expression> )
| ATAN ( <expression> )
| ATAN2 ( <expression>, <expression> )
| RADIANS ( <expression> )
| DEGREES ( <expression> )

U

<underscore> ::=
_

<unique_definition> ::=
  [CONSTRAINT <index_name>] UNIQUE (<column_name>,...)

<unlock_statement> ::=
  UNLOCK <row_spec> ... IN SHARE MODE
| UNLOCK <row_spec> ... IN EXCLUSIVE MODE
| UNLOCK <row_spec> ... IN SHARE MODE <row_spec> ... IN EXCLUSIVE MODE
| UNLOCK <row_spec> ... OPTIMISTIC

<unsigned_integer> ::=
  <numeric_literal>

<update_clause> ::=
  FOR UPDATE [OF <column_name>,...] [NOWAIT]

<update_statement> ::=
  UPDATE [OF] <table_name> [<reference_name>] SET <set_update_clause>,...
    [KEY <key_spec>,...] [WHERE <search_condition>] [NOWAIT] [IGNORE TRIGGER]
| UPDATE [OF] <table_name> [<reference_name>] (<column_name>,...)
    VALUES (<extended_value_spec>,...) [KEY <key_spec>,...]
    [WHERE <search_condition>] [NOWAIT] [IGNORE TRIGGER]
| UPDATE [OF] <table_name> [<reference_name>] SET <set_update_clause>,...
    WHERE CURRENT OF <result_table_name> [NOWAIT]
| UPDATE [OF] <table_name> [<reference_name>] (<column_name>,...)
    VALUES (<extended_value_spec>,...) WHERE CURRENT OF <result_table_name> [NOWAIT]

<update_statistics_statement> ::=
UPDATE STAT[ISTICS] COLUMN <table_name>.<column_name>
[ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] COLUMN (<column_name>,...) FOR <table_name>
[ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] COLUMN (*) FOR <table_name>
[ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] <table_name> [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] [<schema_name>.][<identifier>]* [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] AS PER SYSTEM TABLE

<user_mode> ::=
DBA
| RESOURCE
| STANDARD

<user_name> ::=
<identifier>

<usergroup_mode> ::=
RESOURCE
| STANDARD

<usergroup_name> ::=
  <identifier>

V

<value_spec> ::=
<literal>
| <parameter_spec>
| NULL
| USER
| USERGROUP
| SYSDBA
| CURRENT_SCHEMA
| UID
| [<schema_name>.]<sequence_name>.NEXTVAL
| [<schema_name>.]<sequence_name>.CURRVAL
| <table_name>.CURRVAL
| DATE
| TIME
| TIMESTAMP
| UTCDATE
| TIMEZONE
| UTCDIFF
| TRUE
| FALSE
| TRANSACTION

<variable_name> ::=
<identifier>

<vertical_slash> ::=
|

W

<where_clause> ::=
WHERE <search_condition>

<while_statement> ::=
 WHILE <search_condition> DO <statement>


add_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation add_definition

<add_definition> ::=
ADD <column_definition>,...
| ADD (<column_definition>,...)
| ADD <constraint_definition>
| ADD <key_definition>
| ADD <referential_constraint_definition>


alias_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation alias_name

< alias_name > ::=
  < identifier >


all_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation all_function

<all_function> ::=
<set_function_name>([ALL] <expression>)


alter_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation alter_definition

< alter_definition > ::=
  ALTER CONSTRAINT < constraint_name > CHECK < search_condition >
| ALTER < key_definition >


alter_index_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation alter_index_statement

< alter_index_statement > ::=
  ALTER INDEX < index_name > [ON < table_name >] ENABLE
| ALTER INDEX <index_name> [ON <table_name>] DISABLE
| ALTER INDEX <index_name> [ON <table_name>] INIT USAGE


alter_password_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation alter_password_statement

<alter_password_statement>::=
ALTER PASSWORD <old_password> TO <new_password>
| ALTER PASSWORD <user_name> <new_password>


alter_table_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation alter_table_statement

<alter_table_statement> ::=
ALTER TABLE <table_name> <add_definition>
| ALTER TABLE <table_name> <alter_definition>
| ALTER TABLE <table_name> <column_change_definition>
| ALTER TABLE <table_name> <drop_definition>
| ALTER TABLE <table_name> <modify_definition>
| ALTER TABLE <table_name> <referential_constraint_definition>
| ALTER TABLE <table_name> <sample_definition>


alter_user_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation alter_user_statement

<alter_user_statement> ::=
ALTER USER <user_name> [<user_mode>]
[TIMEOUT <unsigned_integer> | TIMEOUT NULL]
[COSTWARNING <unsigned_integer> | COSTWARNING NULL]
[COSTLIMIT <unsigned_integer> | COSTLIMIT NULL]
[DEFAULT ROLE ALL [EXCEPT <role_name>] | DEFAULT ROLE NONE | DEFAULT ROLE <role_name>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE ASCII]
[DEFAULTCODE UNICODE]
[<connect_mode>]


alter_usergroup_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation alter_usergroup_statement

<alter_usergroup_statement> ::=
ALTER USERGROUP <usergroup_name> [<usergroup_mode>]
[TIMEOUT <unsigned_integer> | TIMEOUT NULL]
[COSTWARNING <unsigned_integer> | COSTWARNING NULL]
[COSTLIMIT <unsigned_integer> | COSTLIMIT NULL]
[DEFAULT ROLE ALL [EXCEPT <role_name>] | DEFAULT ROLE NONE | DEFAULT ROLE <role_name>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE ASCII]
[DEFAULTCODE UNICODE]
[<connect_mode>]


argument (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation argument

<argument> ::=
<identifier>


argument1 (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation argument1

<argument1> ::=
  <identifier>


arithmetic_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation arithmetic_function

<arithmetic_function> ::=
TRUNC ( <expression>[, <expression>] )
| ROUND ( <expression>[, <expression>] )
| NOROUND ( <expression> )
| FIXED ( <expression>[, <unsigned_integer> [, <unsigned_integer>] ] )
| FLOAT ( <expression>[, <unsigned_integer> ] )
| CEIL ( <expression> )
| FLOOR ( <expression> )
| SIGN ( <expression> )
| ABS ( <expression> )
| POWER ( <expression>, <expression> )
| EXP ( <expression> )
| SQRT ( <expression> )
| LN ( <expression> )
| LOG ( <expression>, <expression> )
| PI
| LENGTH ( <expression> )
| INDEX ( <string_spec>, <string_spec> [,<expression>[, <expression>] ] )


ASCII_or_UNICODE (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation ASCII_or_UNICODE

<ASCII_or_UNICODE> ::=
 ASCII
| UNICODE


assignment_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation assignment_statement

<assignment_statement> ::=
SET <variable_name> = <expression>


between_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation between_predicate

< between_predicate > ::=
  < expression > [NOT] BETWEEN <expression> AND <expression>


bool_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation bool_predicate

<bool_predicate> ::=
<column_spec> [IS [NOT] TRUE | IS [NOT] FALSE]


boolean_factor (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation boolean_factor

<boolean_factor> ::=
[NOT] <predicate>
| [NOT] (<search_condition>)


boolean_term (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation boolean_term

<boolean_term> ::=
<boolean_factor>
| <boolean_term> AND <boolean_factor>


call_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation call_statement

< call_statement > ::=
  CALL < dbproc_name > [(< expression >,...)] [WITH COMMIT]


cascade_option (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation cascade_option

< cascade_option > ::=
  CASCADE
| RESTRICT


case_else_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation case_else_clause

<case_else_clause> ::=
  ELSE <statement>;


case_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation case_function

<case_function> ::=
<simple_case_function>
| <searched_case_function>


case_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation case_statement

<case_statement> ::=
<simple_case_statement>
| <searched_case_statement>


character (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation character

< character > ::=
  < digit >
| < letter >
| < extended_letter >
| < hex_digit >
| < language_specific_character >
| < special_character >


check_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation check_expression

<check_expression> ::=
<expression>


close_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation close_statement

< close_statement > ::=
  CLOSE [< result_table_name >]


column_attributes (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation column_attributes

< column_attributes > ::=
  [< key_or_not_null_spec >] [< default_spec >] [UNIQUE] [< constraint_definition >]
    [REFERENCES < referenced_table > [(< referenced_column >)] [< delete_rule >]]


column_change_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation column_change_definition

<column_change_definition> ::=
COLUMN <column_name> ADD <default_spec>
| COLUMN <column_name> ALTER <default_spec>
| COLUMN <column_name> DEFAULT NULL
| COLUMN <column_name> DROP DEFAULT
| COLUMN <column_name> NOT NULL


column_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation column_definition

< column_definition > ::=
  < column_name > < data_type > [< column_attributes >]
| <column_name> < domain_name > [<column_attributes>]


column_list (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation column_list

<column_list> ::=
<column_name>
| <column_list>, <column_name>


column_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation column_name

< column_name > ::=
  < identifier >


column_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation column_spec

< column_spec > ::=
  < column_name >
| < table_name >.<column_name>
| < reference_name >.<column_name>
| < result_table_name >.<column_name>


comment (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation comment

< comment > ::=
  < string_literal >
| < parameter_name >


comment_on_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation comment_on_statement

< comment_on_statement > ::=
  COMMENT ON < object_spec > IS < comment >


commit_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation commit_statement

<commit_statement > ::=
  COMMIT [WORK]


comp_op (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation comp_op

<comp_op> ::=
<
| >
| <>
| !=
| =
| <=
| >=
| ~= <! für Maschinen mit ASCII-Code !>
| ~< <! für Maschinen mit ASCII-Code !>
| ~> <! für Maschinen mit ASCII-Code !>


comparison_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation comparison_predicate

< comparison_predicate > ::=
  < expression > < comp_op > <expression>
| <expression> <comp_op> < subquery >
| < expression_list > < equal_or_not > (<expression_list>)
| <expression_list> <equal_or_not> <subquery>


connect_mode (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation connect_mode

<connect_mode> ::=
ENABLE CONNECT
| DISABLE CONNECT


connect_option (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation connect_option

<connect_option> ::=
SQLMODE <INTERNAL_ANSI_DB2_ORACLE>
| ISOLATION LEVEL <unsigned_integer>
| TIMEOUT <unsigned_integer>


connect_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation connect_statement

<connect_statement> ::=
CONNECT <parameter_name> IDENTIFIED BY <parameter_name> [<connect_option> ...]
| CONNECT <parameter_name> IDENTIFIED BY <password> [<connect_option> ...]
| CONNECT <user_name> IDENTIFIED BY <parameter_name> [<connect_option> ...]
| CONNECT <user_name> IDENTIFIED BY <password> [<connect_option> ...]


constraint_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation constraint_definition

< constraint_definition > ::=
  CHECK < search_condition >
| CONSTRAINT <search_condition>
| CONSTRAINT < constraint_name > CHECK <search_condition>


constraint_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation constraint_name

< constraint_name > ::=
  < identifier >


conversion_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation conversion_function

< conversion_function > ::=
  NUM (< expression >)
| CHR (<expression>[,< unsigned_integer >])
| HEX (<expression>)
| HEXTORAW (<expression>)
| CHAR (<expression>[,< datetimeformat >])


create_dbproc_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_dbproc_statement

<create_dbproc_statement> ::=
CREATE DBPROC[EDURE] <dbproc_name> [(<formal_parameter>,...)] [RETURNS CURSOR] AS <routine>


create_domain_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_domain_statement

< create_domain_statement > ::=
  CREATE DOMAIN < domain_name > < data_type > [< default_spec >] [< constraint_definition >]


create_function_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_function_statement

<create_function_statement> ::=
  CREATE [PUBLIC] FUNCTION <dbfunction_name>
    [(<formal_parameter1>,...)] RETURNS <data_type> [DETERMINISTIC] AS <routine>


create_index_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_index_statement

<create_index_statement > ::=
CREATE [UNIQUE] INDEX <index_name > ON <table_name > (<index_spec>)


create_role_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_role_statement

< create_role_statement > ::=
  CREATE ROLE < role_name > [IDENTIFIED BY < password >]


create_schema_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_schema_statement

<create_schema_statement> ::=
CREATE SCHEMA <schema_name_clause> [<schema_element> ...]


create_sequence_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_sequence_statement

<create_sequence_statement> ::=
CREATE SEQUENCE [<schema_name>.]<sequence_name>
[INCREMENT BY <integer>]
[START WITH <integer>]
[MAXVALUE <integer> | NOMAXVALUE]
[MINVALUE <integer> | NOMINVALUE]
[CYCLE | NOCYCLE]
[CACHE <unsigned_integer> | NOCACHE]
[ORDER|NOORDER]


create_synonym_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_synonym_statement

<create_synonym_statement> ::=
  CREATE [PUBLIC] SYNONYM [<schema_name>.]<synonym_name> FOR <table_name>


create_system_trigger_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_system_trigger_statement

<create_system_trigger_statement> ::=
CREATE SYSTEM TRIGGER [<schema_name>.]<trigger_name> AFTER RESTART EXECUTE (<routine>)


create_table_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_table_statement

<create_table_statement> ::=
CREATE TABLE <table_name> (<column_definition> [,<table_description_element>,...])
[IGNORE ROLLBACK] [<sample_definition>]
| CREATE TABLE <table_name> [(<table_description_element>,...)]
[IGNORE ROLLBACK] [<sample_definition>]
AS <query_expression> [<duplicates_clause>]
| CREATE TABLE <table_name> LIKE <table_name> [IGNORE ROLLBACK]


create_table_temp (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_table_temp

<create_table_temp> ::=
<! <create_table_statement> für das Anlegen temporärer Tabellen,
d.h. der Tabellenname table_name in der CREATE TABLE-Anweisung
muss die Form TEMP.<identifier> haben. !>


create_trigger_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_trigger_statement

<create_trigger_statement> ::=
CREATE TRIGGER <trigger_name> FOR <table_name> AFTER <trigger_event>,...
EXECUTE (<routine>) [WHENEVER <search_condition>]


create_user_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_user_statement

<create_user_statement> ::=
CREATE USER <user_name> PASSWORD <password>
[<user_mode>]
[TIMEOUT <unsigned_integer>]
[COSTWARNING <unsigned_integer>]
[COSTLIMIT <unsigned_integer>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE <ASCII_or_UNICODE>]
[<connect_mode>]
| CREATE USER <user_name> PASSWORD <password> LIKE <source_user>
| CREATE USER <user_name> PASSWORD <password> USERGROUP <usergroup_name>


create_usergroup_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_usergroup_statement

<create_usergroup_statement> ::=
CREATE USERGROUP <usergroup_name>
[<usergroup_mode>]
[TIMEOUT <unsigned_integer>]
[COSTWARNING <unsigned_integer>]
[COSTLIMIT <unsigned_integer>]
[[NOT] EXCLUSIVE]
[DEFAULTCODE <ASCII_or_UNICODE>]
[<connect_mode>]


create_view_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation create_view_statement

< create_view_statement > ::=
  CREATE [OR REPLACE] VIEW < table_name > [(< alias_name >,...)]
    AS < query_expression > [WITH CHECK OPTION]


data_type (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation data_type

<data_type> ::=
CHAR[ACTER] [(<unsigned_integer>)] [ASCII | BYTE | UNICODE]
| VARCHAR [(<unsigned_integer>)] [ASCII | BYTE | UNICODE]
| LONG [VARCHAR] [ASCII | BYTE | UNICODE]
| BOOLEAN
| FIXED (<unsigned_integer> [,<unsigned_integer>])
| FLOAT (<unsigned_integer>)
| INT[EGER]
| SMALLINT
| DATE
| TIME
| TIMESTAMP


date_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation date_function

< date_function > ::=
  ADDDATE ( < date_or_timestamp_expression >, < expression > )
| SUBDATE ( <date_or_timestamp_expression>, <expression> )
| DATEDIFF ( <date_or_timestamp_expression>, <date_or_timestamp_expression> )
| DAYOFWEEK ( <date_or_timestamp_expression> )
| WEEKOFYEAR ( <date_or_timestamp_expression> )
| DAYOFMONTH ( <date_or_timestamp_expression> )
| DAYOFYEAR ( <date_or_timestamp_expression> )
| MAKEDATE ( <expression>, <expression> )
| DAYNAME ( <date_or_timestamp_expression> )
| MONTHNAME ( <date_or_timestamp_expression> )


date_or_timestamp_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation date_or_timestamp_expression

<date_or_timestamp_expression> ::=
<expression>


datetimeformat (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation datetimeformat

< datetimeformat > ::=
  EUR
| INTERNAL
| ISO
| JIS
| USA


dbfunction_call (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation dbfunction_call

<dbfunction_call> ::=
  <dbfunction_name> ( [<expression>,...) )


dbfunction_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation dbfunction_name

<dbfunction_name> ::=
  [<schema_name>.]<identifier>


dbproc_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation dbproc_name

<dbproc_name> ::=
[<schema_name>.]<identifier>


declare_cursor_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation declare_cursor_statement

< declare_cursor_statement > ::=
  DECLARE < result_table_name > CURSOR FOR < select_statement >


default_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation default_expression

<default_expression> ::=
<expression>


default_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation default_predicate

< default_predicate > ::=
  < column_spec > < comp_op > DEFAULT


default_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation default_spec

<default_spec> ::=
  DEFAULT <literal>
| DEFAULT NULL
| DEFAULT USER
| DEFAULT USERGROUP
| DEFAULT SYSDBA
| DEFAULT DATE
| DEFAULT TIME
| DEFAULT TIMESTAMP
| DEFAULT UTCDATE
| DEFAULT UTCDIFF
| DEFAULT TIMEZONE
| DEFAULT TRUE
| DEFAULT FALSE
| DEFAULT TRANSACTION
| DEFAULT STAMP
| DEFAULT SERIAL[(<unsigned_integer>)]


delete_rule (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation delete_rule

< delete_rule > ::=
  ON DELETE CASCADE
| ON DELETE RESTRICT
| ON DELETE SET DEFAULT
| ON DELETE SET NULL


delete_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation delete_statement

<delete_statement> ::=
DELETE [FROM] <table_name> [<reference_name>]
[KEY <key_spec>,...] [WHERE <search_condition>] [IGNORE TRIGGER] [NOWAIT]
| DELETE [FROM] <table_name> [<reference_name>]
WHERE CURRENT OF <result_table_name> [NOWAIT]


delimiter_token (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation delimiter_token

<delimiter_token> ::=
<vertical_slash> | , | . | + | - | * | / | < | > | <> | != | = | <= | >=
| ~= <! für Maschinen mit ASCII-Code !>
| ~< <! für Maschinen mit ASCII-Code !>
| ~> <! für Maschinen mit ASCII-Code !>


derived_column (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation derived_column

<derived_column> ::=
<expression> [ [AS] <result_column_name>]


digit (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation digit

<digit> ::=
0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9


digit_sequence (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation digit_sequence

<digit_sequence> ::=
  <digit>...


distinct_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation distinct_function

<distinct_function> ::=
<set_function_name>(DISTINCT <expression>)


distinct_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation distinct_spec

< distinct_spec > ::=
  DISTINCT
| ALL


domain_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation domain_name

<domain_name> ::=
[<schema_name>.]<identifier>


double_quotes (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation double_quotes

<double_quotes> ::=
"


drop_dbproc_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_dbproc_statement

<drop_dbproc_statement> ::=
DROP DBPROC[EDURE] <dbproc_name>


drop_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_definition

< drop_definition > ::=
  DROP < column_name >,... [< cascade_option >] [RELEASE SPACE]
| DROP (<column_name>,...) [<cascade_option>] [RELEASE SPACE]
| DROP CONSTRAINT < constraint_name >
| DROP PRIMARY KEY


drop_domain_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_domain_statement

< drop_domain_statement > ::=
  DROP DOMAIN < domain_name >


drop_function_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_function_statement

<drop_function_statement> ::=
  DROP [PUBLIC] FUNCTION <dbfunction_name>


drop_index_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_index_statement

< drop_index_statement > ::=
  DROP INDEX < index_name > [ON < table_name >]


drop_role_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_role_statement

< drop_role_statement > ::=
  DROP ROLE < role_name >


drop_schema_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_schema_statement

<drop_schema_statement> ::=
DROP SCHEMA <schema_name> [<cascade_option>]


drop_sequence_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_sequence_statement

<drop_sequence_statement> ::=
DROP SEQUENCE [<schema_name>.]<sequence_name>


drop_synonym_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_synonym_statement

<drop_synonym_statement> ::=
DROP [PUBLIC] SYNONYM [<schema_name>.]<synonym_name>


drop_system_trigger_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_system_trigger_statement

<drop_system_trigger_statement> ::=
DROP SYSTEM TRIGGER [<schema_name>.]<trigger_name>


drop_table_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_table_statement

< drop_table_statement > ::=
  DROP TABLE < table_name > [< cascade_option >]


drop_table_temp (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_table_temp

<drop_table_temp> ::=
DROP TABLE TEMP.<identifier>


drop_trigger_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_trigger_statement

<drop_trigger_statement> ::=
DROP TRIGGER <trigger_name> OF <table_name>


drop_user_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_user_statement

< drop_user_statement > ::=
  DROP USER < user_name > [< cascade_option >]


drop_usergroup_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_usergroup_statement

< drop_usergroup_statement > ::=
  DROP USERGROUP < usergroup_name > [< cascade_option >]


drop_view_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation drop_view_statement

< drop_view_statement > ::=
  DROP VIEW < table_name > [< cascade_option >]


duplicates_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation duplicates_clause

< duplicates_clause > ::=
  REJECT DUPLICATES
| IGNORE DUPLICATES
| UPDATE DUPLICATES


equal_or_not (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation equal_or_not

<equal_or_not> ::=
<>
| =
| ~= <! für Maschinen mit ASCII-Code !>


exists_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation exists_predicate

< exists_predicate > ::=
  EXISTS < subquery >


exists_table_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation exists_table_statement

< exists_table_statement > ::=
  EXISTS TABLE < table_name >


explain_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation explain_statement

< explain_statement > ::=
  EXPLAIN [(< result_table_name >)] < query_statement >
| EXPLAIN [(<result_table_name>)] < single_select_statement >


exponent (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation exponent

<exponent> ::=
[<sign>][[<digit>]<digit>]<digit>


expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation expression

< expression > ::=
  < term >
| <expression> + <term>
| <expression> - <term>


expression_list (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation expression_list

< expression_list > ::=
  (< expression >,...)


extended_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation extended_expression

<extended_expression> ::=
<expression>
| DEFAULT
| STAMP


extended_letter (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation extended_letter

<extended_letter> ::=
#
| @
| $


extended_value_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation extended_value_spec

<extended_value_spec> ::=
DEFAULT
| STAMP
| <value_spec>


extraction_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation extraction_function

<extraction_function> ::=
YEAR ( <date_or_timestamp_expression> )
| MONTH ( <date_or_timestamp_expression> )
| DAY ( <date_or_timestamp_expression> )
| HOUR ( <time_or_timestamp_expression> )
| MINUTE ( <time_or_timestamp_expression> )
| SECOND ( <time_or_timestamp_expression> )
| MICROSECOND ( <expression> )
| TIMESTAMP ( <expression>[, <expression> ] )
| DATE ( <expression> )
| TIME ( <expression> )


factor (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation factor

<factor> ::=
[<sign>] <value_spec>
| [<sign>] <column_spec>
| [<sign>] <function_spec>
| [<sign>] <set_function_spec>
| <scalar_subquery>
| <expression>


fetch_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation fetch_statement

< fetch_statement > ::=
  FETCH [FIRST | LAST | NEXT | PREV | < position > | SAME] [< result_table_name >]
    INTO < parameter_spec >,...


final_select (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation final_select

< final_select > ::=
  < select_statement >


first_character (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation first_character

<first_character> ::=
<letter>
| <extended_letter>
| <language_specific_character>


first_password_character (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation first_password_character

<first_password_character> ::=
<letter>
| <extended_letter>
| <language_specific_character>
| <digit>


fixed_point_literal (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation fixed_point_literal

<fixed_point_literal> ::=
[<sign>]<digit_sequence>[.<digit_sequence>]
| [<sign>]<digit_sequence>.
| [<sign>].<digit_sequence>


floating_point_literal (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation floating_point_literal

< floating_point_literal > ::=
  < mantissa >E< exponent >
| <mantissa>e<exponent>


formal_parameter (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation formal_parameter

< formal_parameter > ::=
  IN < argument > < data_type >
| OUT <argument> <data_type>
| INOUT <argument> <data_type>


formal_parameter1 (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation formal_parameter1

<formal_parameter1> ::=
  <argument1> <data_type>


from_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation from_clause

<from_clause> ::=
FROM <from_table_spec>,...


from_table_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation from_table_spec

<from_table_spec> ::=
<table_name> [AS] [<reference_name>]
| <result_table_name> [AS] [<reference_name>]
| (<query_expression>) [AS] [<reference_name>]
| <joined_table>


function_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation function_spec

<function_spec > ::=
  <arithmetic_function >
| <trigonometric_function >
| <string_function >
| <date_function >
| <time_function >
| <extraction_function >
| <special_function >
| <conversion_function >
| <dbfunction_call>


grant_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation grant_statement

<grant_statement> ::=
GRANT <priv_spec>,... TO <grantee>,... [WITH GRANT OPTION]
| GRANT <schema_priv_spec> TO <grantee>,...
| GRANT EXECUTE ON <dbproc_name> TO <grantee>,...
| GRANT EXECUTE ON <dbfunction_name> TO <grantee>,...
| GRANT SELECT ON <sequence_name> TO <grantee>,... [WITH GRANT OPTION]


grant_user_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation grant_user_statement

< grant_user_statement > ::=
  GRANT USER < granted_users > [FROM < user_name >] TO <user_name>


grant_usergroup_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation grant_usergroup_statement

< grant_usergroup_statement > ::=
  GRANT USERGROUP < granted_usergroups > [FROM < user_name >] TO <user_name>


granted_usergroups (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation granted_usergroups

< granted_usergroups > ::=
  < usergroup_name >,...
| *


granted_users (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation granted_users

< granted_users > ::=
  < user_name >,...
| *


grantee (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation grantee

<grantee> ::=
<user_name>
| <usergroup_name>
| <role_name>
| PUBLIC


group_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation group_clause

<group_clause> ::=
GROUP BY <expression>,...


having_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation having_clause

<having_clause> ::=
HAVING <search_condition>


hex_digit (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation hex_digit

<hex_digit> ::=
0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
| A | B | C | D | E | F
| a | b | c | d | e | f


hex_digit_seq (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation hex_digit_seq

<hex_digit_seq> ::=
<hex_digit><hex_digit>
| <hex_digit_seq><hex_digit><hex_digit>


hex_literal (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation hex_literal

<hex_literal> ::=
x''
| X''
| x'<hex_digit_seq>'
| X'<hex_digit_seq>'


hours (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation hours

<hours> ::=
<expression>


identifier (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation identifier

< identifier > ::=
  < simple_identifier >
| < double quotes >< special_identifier ><double_quotes>


identifier_tail_character (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation identifier_tail_character

<identifier_tail_character> ::=
| <digit>
| <letter>
| <extended_letter>
| <language_specific_character>
| <underscore>


if_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation if_statement

<if_statement> ::=
IF <search_condition> THEN <statement> [ELSE <statement>]


in_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation in_predicate

< in_predicate > ::=
  < expression > [NOT] IN < subquery >
| <expression> [NOT] IN < expression_list >
| <expression_list> [NOT] IN <subquery>
| <expression_list> [NOT] IN (<expression_list>,...)


index_column_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation index_column_name

<index_column_name> ::=
<column_name> [ASC|DESC]


index_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation index_name

< index_name > ::=
  < identifier >


index_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation index_spec

<index_spec> ::=
  <index_column_name>,...
| <dbfunction_name> (<column_name>,...) [ASC|DESC]


indicator_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation indicator_name

< indicator_name > ::=
  < parameter_name >


initial_select (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation initial_select

< initial_select > ::=
  < query_spec >


inner_transaction_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation inner_transaction_statement

<inner_transaction_statement> ::=
INNER TRANSACTION BEGIN
| INNER TRANSACTION COMMIT
| INNER TRANSACTION ROLLBACK


insert_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation insert_expression

< insert_expression > ::=
  < extended_expression >
| < subquery >


insert_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation insert_statement

<insert_statement> ::=
INSERT [INTO] <table_name> [(<column_name>,...)]
VALUES (<insert_expression>,...) [<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]
| INSERT [INTO] <table_name> [(<column_name>,...)]
<query_expression> [<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]
| INSERT [INTO] <table_name> SET <set_insert_clause>,...
[<duplicates_clause>] [IGNORE TRIGGER] [NOWAIT]


integer (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation integer

<integer> ::=
[<sign>]<unsigned_integer>


INTERNAL_ANSI_DB2_ORACLE (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation INTERNAL_ANSI_DB2_ORACLE

<INTERNAL_ANSI_DB2_ORACLE> ::=
INTERNAL
| ANSI
| DB2
| ORACLE


join_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation join_predicate

< join_predicate > ::=
  < expression > [< outer_join_indicator >] < comp_op > <expression> [<outer_join_indicator>]


join_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation join_spec

<join_spec> ::=
  ON <search_condition>


joined_table (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation joined_table

<joined_table> ::=
<from_table_spec> CROSS JOIN <from_table_spec>
| <from_table_spec> [INNER] JOIN <from_table_spec> <join_spec>
| <from_table_spec> [LEFT [OUTER] | RIGHT [OUTER] | FULL [OUTER]] JOIN
<from_table_spec> <join_spec>


key_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation key_definition

<key_definition> ::=
PRIMARY KEY (<column_name>,...)


key_or_not_null_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation key_or_not_null_spec

< key_or_not_null_spec > ::=
  [PRIMARY] KEY
| NOT NULL [WITH DEFAULT]


key_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation key_spec

< key_spec > ::=
  < column_name > = < value_spec >


key_word (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation key_word

<key_word> ::=
<not_reserved_key_word>
| <reserved_key_word>


language_specific_character (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation language_specific_character

<language_specific_character> ::=
<! <jeder Buchstabe, der in einer nord-, mittel- oder südeuropäischen Sprache vorkommt
und nicht in der Auflistung <letter> enthalten ist>
| <für UNICODE-fähige Datenbanken: jedes Zeichen, das nicht in der ASCII-Code-Liste von 0 bis 127 enthalten ist>  !>


letter (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation letter

<letter> ::=
A | B | C | D | E | F | G | H | I | J | K | L | M
| N | O | P | Q | R | S | T | U | V | W | X | Y | Z
| a | b | c | d | e | f | g | h | i | j | k | l | m
| n | o | p | q | r | s | t | u | v | w | x | y | z


like_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation like_expression

< like_expression > ::=
  < expression >
| '< pattern_element >...'


like_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation like_predicate

< like_predicate > ::=
  < expression > [NOT] LIKE < like_expression > [ESCAPE <expression>]


limit_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation limit_clause

<limit_clause> ::=
LIMIT <row_count>
| LIMIT <offset>,<row_count>


literal (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation literal

< literal > ::=
  < string_literal >
| < numeric_literal >


local_variable (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation local_variable

< local_variable > ::=
  < variable_name > < data_type >


local_variable_list (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation local_variable_list

< local_variable_list > ::=
  < local_variable >
| <local_variable_list>;<local_variable>


local_variables (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation local_variables

< local_variables > ::=
  VAR < local_variable_list >;


lock_option (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation lock_option

< lock_option > ::=
  WITH LOCK [(IGNORE)|(NOWAIT)] [EXCLUSIVE | OPTIMISTIC] [ISOLATION LEVEL < unsigned_integer >]


lock_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation lock_spec

<lock_spec> ::=
TABLE <table_name>,...
| <row_spec> ...
| TABLE <table_name>,... <row_spec> ...


lock_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation lock_statement

< lock_statement > ::=
  LOCK [(WAIT)|(NOWAIT)] < lock_spec > IN SHARE MODE
| LOCK [(WAIT)|(NOWAIT)] <lock_spec> IN EXCLUSIVE MODE
| LOCK [(WAIT)|(NOWAIT)] < row_spec >... OPTIMISTIC
| LOCK [(WAIT)|(NOWAIT)] <lock_spec> IN SHARE MODE <lock_spec> IN EXCLUSIVE MODE


mantissa (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation mantissa

<mantissa> ::=
<fixed_point_literal>


mapchar_set_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation mapchar_set_name

< mapchar_set_name > ::=
  < identifier >


match_char (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation match_char

<match_char> ::=
<! Jedes Zeichen außer
%
| X'1F'
| <underscore>
| X'1E' !>


match_set (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation match_set

<match_set> ::=
<underscore>
| X'1E'
| <match_char>


match_string (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation match_string

<match_string> ::=
  %
| X'1F'


minutes (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation minutes

<minutes> ::=
<expression>


modify_column_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation modify_column_definition

<modify_column_definition> ::=
<column_name> <data_type> <column_attributes>
| <column_name> <data_type>
| <column_name> <column_attributes>


modify_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation modify_definition

<modify_definition> ::=
MODIFY (<modify_column_definition>,...)


monitor_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation monitor_statement

< monitor_statement > ::=
  MONITOR INIT


new_index_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation new_index_name

< new_index_name > ::=
  < index_name >


new_password (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation new_password

<new_password> ::=
<password>


new_schema_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation new_schema_name

<new_schema_name> ::=
<schema_name>


new_synonym_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation new_synonym_name

<new_synonym_name> ::=
<synonym_name>


new_table_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation new_table_name

<new_table_name> ::=
<table_name>


new_user_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation new_user_name

<new_user_name> ::=
 <user_name>


new_usergroup_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation new_usergroup_name

<new_usergroup_name> ::=
<usergroup_name>


next_stamp_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation next_stamp_statement

< next_stamp_statement > ::=
  NEXT STAMP [INTO] < parameter_name >


not_reserved_key_word (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation not_reserved_key_word

<not_reserved_key_word> ::=

ADD | ADDRESS | ADD_MONTHS | AFTER | ALTERIN
ANALYZE | AND | ANSI | APPEND | ARCHIVE
AS | ASC | AT | AUTHORIZATION | AUTO
AUTOSAVE |  |  |  |
BACKUP_PAGES | BAD | BEFORE | BEGIN | BEGINLOAD
BEGINPROC | BETWEEN | BLOCK | BLOCKSIZE | BOTH
BREAK | BUFFER | BUFFERPOOL | BWHIERARCHY | BY
CACHE | CACHELIMIT | CACHES | CALL | CANCEL
CASCADE | CATALOG | CATCH | CHECKPOINT | CLEAR
CLOSE | CLUSTER | COMMENT | COMMIT | COMPUTE
CONFIG | CONNECT | CONSTRAINTS | CONTAINER | CONTINUE
COSTLIMIT | COSTWARNING | CREATE | CREATEIN | CURRENT_DATE
CURRENT_SCHEMA | CURRENT_TIME | CURRENT_TIMESTAMP | CURRVAL | CURSOR
CYCLE |  |  |  |
DATA | DAYS | DB2 | DBA | DBPROC
DBPROCEDURE | DB_ABOVE_LIMIT | DB_BELOW_LIMIT | DEBUG | DECLARE
DEFAULTCODE | DEGREE | DESC | DESCRIBE | DEVICE
DIAGNOSE | DIMENSION | DISABLE | DIV | DO
DOMAIN | DROP | DROPIN | DSETPASS | DUPLICATES
DYNAMIC |  |  |  |
EDITPROC | ELSE | ENABLE | END | ENDLOAD
ENDPROC | ERROR | ESCAPE | ESTIMATE | EUR
EVENT | EXCLUSIVE | EXECUTE | EXPLAIN | EXPLICIT
EXTENDED |  |  |  |
FACT | FALSE | FETCH | FILE | FLUSH
FORCE | FOREIGN | FORMAT | FREEPAGE | FUNCTION
FVERSION |  |  |  |
GET | GRANT |  |  |
HIGH | HOLD | HOURS |  |
IDENTIFIED | IF | IMPLICIT | IN | INCREMENT
INDEXNAME | INDICATOR | INFO | INIT | INITRANS
INOUT | INPROC | INSTANCE | INSTR | IS
ISO | ISOLATION |  |  |
JAVA | JIS |  |  |
LABEL | LANGUAGE | LAST_DAY | LEVEL | LIKE
LOAD | LOCAL | LOCK | LOGFULL | LOGWRITER
LOG_ABOVE_LIMIT | LOW |  |  |
MAXTRANS | MAXVALUE | MEDIANAME | MEDIUM | MICROSECONDS
MIGRATE | MINUS | MINUTES | MINVALUE | MODE
MODIFY | MONITOR | MONTHS | MONTHS_BETWEEN |
NAME | NEW | NEW_TIME | NEXTVAL | NEXT_DAY
NLSSORT | NLS_DATE_FORMAT | NLS_DATE_LANGUAGE | NLS_LANGUAGE | NLS_SORT
NOCACHE | NOCYCLE | NOLOG | NOMAXVALUE | NOMINVALUE
NONE | NOORDER | NOREWIND | NORMAL | NOSORT
NOWAIT | NUMBER | NVL |  |
OBID | OFF | ONLY | OPEN | OPTIMISTIC
OPTIMIZE | OPTION | OR | ORACLE | OUT
OUTER | OVERWRITE |  |  |
PACKAGE | PAGE | PAGES | PARAM | PARSE
PARSEID | PASSWORD | PCTFREE | PCTUSED | PERCENT
PING | PIPE | POS | PRECISION | PREPARE
PRIV | PRIVILEGES | PROC | PROCEDURE | PSM
PUBLIC |  |  |  |
QUICK |  |  |  |
RANGE | RAW | RAWTOHEX | READ | RECURSIVE
REFERENCES | REGISTER | RELEASE | REMOTE | REMOVE
RENAME | REPLICATION | RESOURCE | RESTART | RESTORE
RESTRICT | RESUME | RETURN | RETURNS | REUSE
REVOKE | ROLE | ROLLBACK | ROW | ROWNUM
ROWS |  |  |  |
SAME | SAMPLE | SAPR3 | SAVE | SAVEPOINT
SCHEMA | SECONDS | SELECTIVITY | SEQUENCE | SERVERDB
SESSION | SHARE | SHUTDOWN | SNAPSHOT | SOUNDS
SQLID | SQLMODE | STANDARD | STANDBY | START
STARTPOS | STAT | STATE | STATIC | STOP
STORAGE | SUBPAGES | SUBTRANS | SUSPEND | SWITCH
SYNCHRONIZE | SYNONYM | SYSDATE |  |
TABID | TABLESPACE | TAKEOVER | TAPE | TEMP
THEN | TIMEOUT | TOPIC | TO_CHAR | TO_DATE
TO_NUMBER | TRACE | TRIGGER | TRUE | TRY
TYPE |  |  |  |
UNIQUE | UNKNOWN | UNLOAD | UNLOCK | UNTIL
UNUSED | USA | USAGE | USERID |
VALIDPROC | VARCHAR2 | VERIFY | VERSION | VIEW
VOLUME | VSIZE | VTRACE |  |
WAIT | WHENEVER | WHILE | WORK | WRITE
WRITER |  |  |  |
YEARS |  |  |  |


null_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation null_predicate

< null_predicate > ::=
  < expression > IS [NOT] NULL


numeric_literal (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation numeric_literal

<numeric_literal> ::=
<fixed_point_literal>
| <floating_point_literal>


object_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation object_spec

< object_spec > ::=
  COLUMN < table_name >.< column_name >
| DBPROC[EDURE] < dbproc_name >
| DOMAIN < domain_name >
| FOREIGN KEY <table_name>.< referential_constraint_name >
| INDEX < index_name > ON <table_name>
| SEQUENCE < sequence_name >
| [PUBLIC] SYNONYM < synonym_name >
| TABLE <table_name>
| TRIGGER < trigger_name >.<table_name>
| USER < user_name >
| USERGROUP < usergroup_name >
| < parameter_name >


offset (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation offset

<offset> ::=
<unsigned_integer>
| <parameter_name>


old_index_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation old_index_name

< old_index_name > ::=
  < index_name >


old_password (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation old_password

<old_password> ::=
<password>


old_synonym_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation old_synonym_name

<old_synonym_name> ::=
<synonym_name>


old_table_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation old_table_name

< old_table_name > ::=
  < table_name >


order_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation order_clause

< order_clause > ::=
  ORDER BY < sort_spec >,...


outer_join_indicator (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation outer_join_indicator

<outer_join_indicator> ::=
(+)


parameter_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation parameter_name

<parameter_name> ::=
:<identifier>
| ?


parameter_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation parameter_spec

< parameter_spec > ::=
  < parameter_name > [< indicator_name >]


password (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation password

< password > ::=
  < identifier >
| < first_password_character >[< identifier_tail_character >...]


pattern_element (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation pattern_element

<pattern_element> ::=
<match_string>
| <match_set>


position (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation position

< position > ::=
  POS (< unsigned_integer >)
| POS (< parameter_spec >)
| ABSOLUTE < integer >
| ABSOLUTE <parameter_spec>
| RELATIVE <integer>
| RELATIVE <parameter_spec>


predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation predicate

< predicate > ::=
  < between_predicate >
| < bool_predicate >
| < comparison_predicate >
| < default_predicate >
| < exists_predicate >
| < in_predicate >
| < join_predicate >
| < like_predicate >
| < null_predicate >
| < quantified_predicate >
| < rowno_predicate >
| < sound_predicate >


priv_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation priv_spec

< priv_spec > ::=
  ALL [PRIV[ILEGES]] ON [TABLE] < table_name >,...
| < privilege >,... ON [TABLE] <table_name>,...
| < role_name >


privilege (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation privilege

<privilege> ::=
INSERT
| UPDATE [(<column_name>,...)]
| SELECT [(<column_name>,...)]
| SELUPD [(<column_name>,...)]
| DELETE
| INDEX
| ALTER
| REFERENCES [(<column_name>,...)]


quantified_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation quantified_predicate

< quantified_predicate > ::=
  < expression > < comp_op > < quantifier > < expression_list >
| <expression> <comp_op> <quantifier> < subquery >
| <expression_list> < equal_or_not > <quantifier> (<expression_list>,...)
| <expression_list> <equal_or_not> <quantifier> <subquery>


quantifier (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation quantifier

<quantifier> ::=
ALL
| SOME
| ANY


query_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation query_expression

< query_expression > ::=
  < query_term >
| <query_expression> UNION [ALL] <query_term>
| <query_expression> EXCEPT [ALL] <query_term>


query_primary (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation query_primary

<query_primary> ::=
<query_spec>
| (<query_expression>)


query_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation query_spec

<query_spec> ::=
SELECT [<distinct_spec>] [<top_spec>] <select_column>,... <table_expression>


query_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation query_statement

<query_statement> ::=
<declare_cursor_statement>
| <recursive_declare_cursor_statement>
| <select_statement>


query_term (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation query_term

<query_term> ::=
<query_primary>
| <query_term> INTERSECT [ALL] <query_primary>


recursive_declare_cursor_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation recursive_declare_cursor_statement

< recursive_declare_cursor_statement > ::=
  DECLARE < result_table_name > CURSOR FOR WITH RECURSIVE < reference_name >
    (< alias_name >,...) AS (< initial_select > UNION ALL < recursive_select >) < final_select >


recursive_select (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation recursive_select

< recursive_select > ::=
  < query_spec >


reference_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation reference_name

< reference_name > ::=
  < identifier >


referenced_column (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation referenced_column

< referenced_column > ::=
  < column_name >


referenced_table (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation referenced_table

< referenced_table > ::=
  < table_name >


referencing_column (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation referencing_column

< referencing_column > ::=
  < column_name >


referential_constraint_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation referential_constraint_definition

< referential_constraint_definition > ::=
  FOREIGN KEY [< referential_constraint_name >] (< referencing_column >,...)
    REFERENCES < referenced_table > [(< referenced_column >,...)] [< delete_rule >]


referential_constraint_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation referential_constraint_name

< referential_constraint_name > ::=
  < identifier >


regular_token (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation regular_token

<regular_token> ::=
<literal>
| <key_word>
| <identifier>
| <parameter_name>


release_savepoint_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation release_savepoint_statement

<release_savepoint_statement> ::=
RELEASE SAVEPOINT <sql_savepoint_name>


release_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation release_statement

< release_statement > ::=
  COMMIT [WORK] RELEASE
| ROLLBACK [WORK] RELEASE


rename_column_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rename_column_statement

< rename_column_statement > ::=
  RENAME COLUMN < table_name >.< column_name > TO <column_name>


rename_index_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rename_index_statement

< rename_index_statement > ::=
  RENAME INDEX < old_index_name > [ON < table_name >] TO < new_index_name >


rename_schema_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rename_schema_statement

<rename_schema_statement> ::=
RENAME SCHEMA <schema_name> TO <new_schema_name>


rename_synonym_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rename_synonym_statement

<rename_synonym_statement> ::=
RENAME [PUBLIC] SYNONYM <old_synonym_name> TO <new_synonym_name>


rename_table_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rename_table_statement

< rename_table_statement > ::=
  RENAME TABLE < old_table_name > TO < new_table_name >


rename_user_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rename_user_statement

<rename_user_statement> ::=
RENAME USER <user_name> TO <new_user_name>


rename_usergroup_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rename_usergroup_statement

<rename_usergroup_statement> ::=
RENAME USERGROUP <usergroup_name> TO <new_usergroup_name>


rename_view_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rename_view_statement

< rename_view_statement > ::=
  RENAME VIEW < old_table_name > TO < new_table_name >


reserved_key_word (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation reserved_key_word

<reserved_key_word> ::=

ABS | ABSOLUTE | ACOS | ADDDATE | ADDTIME
ALL | ALPHA | ALTER | ANY | ASCII
ASIN | ATAN | ATAN2 | AVG |
BINARY | BIT | BOOLEAN | BYTE |
CASE | CEIL | CEILING | CHAR | CHARACTER
CHECK | CHR | COLUMN | CONCAT | CONSTRAINT
COS | COSH | COT | COUNT | CROSS
CURDATE | CURRENT | CURTIME |  |
DATABASE | DATE | DATEDIFF | DAY | DAYNAME
DAYOFMONTH | DAYOFWEEK | DAYOFYEAR | DEC | DECIMAL
DECODE | DEFAULT | DEGREES | DELETE | DIGITS
DISTINCT | DOUBLE |  |  |
EXCEPT | EXISTS | EXP | EXPAND |
FIRST | FIXED | FLOAT | FLOOR | FOR
FROM | FULL |  |  |
GET_OBJECTNAME | GET_SCHEMA | GRAPHIC | GREATEST | GROUP
HAVING | HEX | HEXTORAW | HOUR |
IFNULL | IGNORE | INDEX | INITCAP | INNER
INSERT | INT | INTEGER | INTERNAL | INTERSECT
INTO |  |  |  |
JOIN |  |  |  |
KEY |  |  |  |
LAST | LCASE | LEAST | LEFT | LENGTH
LFILL | LIST | LN | LOCATE | LOG
LOG10 | LONG | LONGFILE | LOWER | LPAD
LTRIM |  |  |  |
MAKEDATE | MAKETIME | MAPCHAR | MAX | MBCS
MICROSECOND | MIN | MINUTE | MOD | MONTH
MONTHNAME |  |  |  |
NATURAL | NCHAR | NEXT | NO | NOROUND
NOT | NOW | NULL | NUM | NUMERIC
OBJECT | OF | ON | ORDER |
PACKED | PI | POWER | PREV | PRIMARY
RADIANS | REAL | REJECT | RELATIVE | REPLACE
RFILL | RIGHT | ROUND | ROWID | ROWNO
RPAD | RTRIM |  |  |
SECOND | SELECT | SELUPD | SERIAL | SET
SHOW | SIGN | SIN | SINH | SMALLINT
SOME | SOUNDEX | SPACE | SQRT | STAMP
STATISTICS | STDDEV | SUBDATE | SUBSTR | SUBSTRING
SUBTIME | SUM | SYSDBA |  |
TABLE | TAN | TANH | TIME | TIMEDIFF
TIMESTAMP | TIMEZONE | TO | TOIDENTIFIER | TRANSACTION
TRANSLATE | TRIM | TRUNC | TRUNCATE |
UCASE | UID | UNICODE | UNION | UPDATE
UPPER | USER | USERGROUP | USING | UTCDATE
UTCDIFF |  |  |  |
VALUE | VALUES | VARCHAR | VARGRAPHIC | VARIANCE
WEEK | WEEKOFYEAR | WHEN | WHERE | WITH
YEAR |  |  |  |
ZONED |  |  |  |


result_column_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation result_column_name

< result_column_name > ::=
  < identifier >


result_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation result_expression

<result_expression> ::=
<expression>


result_table_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation result_table_name

< result_table_name > ::=
  < identifier >


revoke_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation revoke_statement

<revoke_statement> ::=
REVOKE <priv_spec>,... FROM <grantee>,... [<cascade_option>]
| REVOKE <schema_priv_spec> FROM <grantee>,...
| REVOKE EXECUTE ON <dbproc_name> FROM <grantee>,...
| REVOKE EXECUTE ON <dbfunction_name> FROM <grantee>,...
| REVOKE SELECT ON <sequence_name> FROM <grantee>,... [<cascade_option>]


role_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation role_name

< role_name > ::=
  < identifier >


rollback_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rollback_statement

<rollback_statement > ::=
  ROLLBACK [WORK]


rollback_to_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rollback_to_statement

<rollback_to_statement> ::=
ROLLBACK TO [SAVEPOINT] <sql_savepoint_name>


routine (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation routine

< routine > ::=
  [< local_variables >] < statement_list >;


routine_sql_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation routine_sql_statement

<routine_sql_statement> ::=
<call_statement>
| <close_statement>
| <create_table_temp>
| <declare_cursor_statement>
| <delete_statement>
| <drop_table_temp>
| <fetch_statement>
| <insert_statement>
| <lock_statement>
| <recursive_declare_cursor_statement>
| <select_statement>
| <single_select_statement>
| <subtrans_statement>
| <update_statement>


row_count (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation row_count

<row_count> ::=
<unsigned_integer>
| <parameter_name>


row_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation row_spec

<row_spec> ::=
ROW <table_name> KEY <key_spec>,...
| ROW <table_name> CURRENT OF <result_table_name>


rowno_column (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rowno_column

<rowno_column> ::=
ROWNO [ [AS] <result_column_name>]


rowno_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation rowno_predicate

< rowno_predicate > ::=
  ROWNO < < unsigned_integer >
| ROWNO < < parameter_spec >
| ROWNO <= < unsigned_integer >
| ROWNO <= < parameter_spec >


sample_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sample_definition

< sample_definition > ::=
  SAMPLE < unsigned_integer > ROWS
| SAMPLE <unsigned_integer> PERCENT


savepoint_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation savepoint_statement

<savepoint_statement> ::=
SAVEPOINT <sql_savepoint_name>


scalar_subquery (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation scalar_subquery

<scalar_subquery> ::=
<subquery>


schema_authorization_identifier (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation schema_authorization_identifier

<schema_authorization_identifier> ::=
<identifier>


schema_element (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation schema_element

<schema_element> ::=
<create_table_statement>
| <create_view_statement>
| <create_dbproc_statement>
| <create_function_statement>
| <create_sequence_statement>


schema_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation schema_name

<schema_name> ::=
<identifier>


schema_name_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation schema_name_clause

<schema_name_clause> ::=
<schema_name>
| <schema_name> AUTHORIZATION <schema_authorization_identifier>


schema_priv_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation schema_priv_spec

<schema_priv_spec> ::=
<schema_privilege> ON <schema_name>,...


schema_privilege (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation schema_privilege

<schema_privilege> ::=
CREATEIN
| DROPIN


search_and_result_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation search_and_result_spec

< search_and_result_spec > ::=
  <search_ expression >, <result_expression>


search_condition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation search_condition

< search_condition > ::=
  < boolean_term >
| <search_condition> OR <boolean_term>


search_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation search_expression

<search_expression> ::=
<expression>


searched_case_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation searched_case_function

< searched_case_function > ::=
  WHEN < search_condition > THEN <result_ expression >
    [...]
  [ELSE <default_expression>]
END


searched_case_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation searched_case_statement

< searched_case_statement > ::=
  CASE
    < searched_case_when_clause >…
    [< case_else_clause >]
  END [CASE]


searched_case_when_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation searched_case_when_clause

<searched_case_when_clause> ::=
WHEN <search_condition> THEN <statement>;


seconds (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation seconds

<seconds> ::=
<expression>


select_column (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation select_column

< select_column > ::=
  < table_columns >
| < derived_column >
| < rowno_column >
| < stamp_column >


select_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation select_statement

<select_statement> ::=
<query_expression>
[<order_clause>] [<limit_clause>]
[<update_clause>]
[<lock_option>]
[FOR REUSE]


sequence_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sequence_name

< sequence_name > ::=
  < identifier >


set_function_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation set_function_name

<set_function_name> ::=
AVG
| COUNT
| MAX
| MIN
| STDDEV
| SUM
| VARIANCE


set_function_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation set_function_spec

<set_function_spec> ::=
COUNT (*)
| <all_function>
| <distinct_function>


set_insert_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation set_insert_clause

<set_insert_clause> ::=
<column_name> = <extended_value_spec>


set_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation set_statement

<set_statement> ::=
SET ROLE ALL [EXCEPT <role_name>,...]
| SET ROLE NONE
| SET ROLE <role_name>,... [IDENTIFIED BY <password>]
| SET ISOLATION LEVEL <unsigned_integer>
| SET CURRENT_SCHEMA = <schema_name>


set_update_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation set_update_clause

<set_update_clause> ::=
<column_name> = <extended_expression>
| <column_name>,... = (<extended_expression>,...)
| (<column_name>,...) = (<extended_expression>,...)
| <column_name> = <subquery>
| (<column_name>,...) = <subquery>


sign (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sign

<sign> ::=
+
| -


simple_case_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation simple_case_function

<simple_case_function> ::=
  CASE <check_expression>
    WHEN <search_expression> THEN <result_expression>
      [...]
    [ELSE <default_expression>]
  END


simple_case_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation simple_case_statement

< simple_case_statement > ::=
  CASE < expression >
    < simple_case_when_clause >...
    [< case_else_clause >]
  END [CASE]


simple_case_when_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation simple_case_when_clause

<simple_case_when_clause> ::=
  WHEN <literal>[, ...] THEN <statement>;


simple_identifier (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation simple_identifier

<simple_identifier> ::=
<first_character>[<identifier_tail_character>...]


single_select_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation single_select_statement

< single_select_statement > ::=
  SELECT [< distinct_spec >] < select_column >,... INTO < parameter_spec >,...
    FROM < from_table_spec >,...[< where_clause >] [< group_clause >]
    [< having_clause >] [< lock_option >]


sort_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sort_spec

< sort_spec > ::=
  < unsigned_integer > [ASC | DESC]
| < expression > [ASC | DESC]


sound_predicate (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sound_predicate

< sound_predicate > ::=
  < expression > [NOT] SOUNDS [LIKE] <expression>


source_user (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation source_user

< source_user > ::=
  < user_name >


special_character (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation special_character

<special_character> ::=
  <!  Jedes Zeichen außer
    <digit>
  | <letter>
  | <extended_letter>
  | <hex_digit>
  | <language_specific_character>
  | <Zeichen für das Zeilenende in einer Datei> !>


special_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation special_function

<special_function> ::=
<case_function>
| DECODE (<check_expression>,<search_and_result_spec>,...[,<default_expression>])
| GREATEST (<expression>,<expression>,...)
| LEAST (<expression>,<expression>,...)
| VALUE (<expression>,<expression>,...)


special_identifier (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation special_identifier

<spezial_identifier> ::=
<special_identifier_character>...


special_identifier_character (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation special_identifier_character

<special_identifier_character> ::=
<! <Jedes beliebige Zeichen> !>


sql_comment (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sql_comment

<sql_comment> ::=
/*<sql_comment_text>*/
| --<sql_comment_text>


sql_comment_text (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sql_comment_text

<sql_comment_text> ::=
 <! <Kommentartext> !>


sql_savepoint_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sql_savepoint_name

<sql_savepoint_name> ::=
 <identifier>


sql_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation sql_statement

<sql_statement> ::=
<alter_index_statement>
| <alter_password_statement>
| <alter_table_statement>
| <alter_user_statement>
| <alter_usergroup_statement>
| <call_statement>
| <close_statement>
| <comment_on_statement>
| <commit_statement>
| <connect_statement>
| <create_dbproc_statement>
| <create_domain_statement>
| <create_function_statement>
| <create_index_statement>
| <create_role_statement>
| <create_schema_statement>
| <create_sequence_statement>
| <create_synonym_statement>
| <create_table_statement>
| <create_trigger_statement>
| <create_user_statement>
| <create_usergroup_statement>
| <create_view_statement>
| <delete_statement>
| <drop_dbproc_statement>
| <drop_domain_statement>
| <drop_function_statement>
| <drop_index_statement>
| <drop_role_statement>
| <drop_schema_statement>
| <drop_sequence_statement>
| <drop_synonym_statement>
| <drop_table_statement>
| <drop_trigger_statement>
| <drop_user_statement>
| <drop_usergroup_statement>
| <drop_view_statement>
| <exists_table_statement>
| <explain_statement>
| <fetch_statement>
| <grant_statement>
| <grant_user_statement>
| <grant_usergroup_statement>
| <inner_transaction_statment>
| <insert_statement>
| <lock_statement>
| <monitor_statement>
| <next_stamp_statement>
| <query_statement>
| <release_statement>
| <rename_column_statement>
| <rename_index_statement>
| <rename_schema_statement>
| <rename_synonym_statement>
| <rename_table_statement>
| <rename_user_statement>
| <rename_usergroup_statement>
| <rename_view_statement>
| <revoke_statement>
| <rollback_statement>
| <rollback_to_statement>
| <savepoint_statement>
| <set_statement>
| <single_select_statement>
| <subtrans_statement>
| <unlock_statement>
| <update_statement>
| <update_statistics_statement>


stamp_column (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation stamp_column

<stamp_column> ::=
STAMP [ [AS] <result_column_name>]


statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation statement

<statement> ::=
BEGIN <statement_list> END
| BREAK
| CONTINUE
| CONTINUE EXECUTE
| <if_statement>
| <while_statement>
| <assignment_statement>
| <case_statement>
| <RETURN> [<expression>]
| STOP (<expression> [,<expression>] )
| TRY <statement_list>; CATCH <statement>
| <routine_sql_statement>


statement_list (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation statement_list

<statement_list> ::=
<statement>
| <statement_list> ; <statement>


string_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation string_function

<string_function> ::=
  <string_spec> || <string_spec>
| <string_spec> & <string_spec>
| ALPHA (<string_spec>[,<unsigned_integer>])
| ASCII (<string_spec>)
| EXPAND (<string_spec>,<unsigned_integer>)
| GET_OBJECTNAME (<string_literal>)
| GET_SCHEMA (<string_literal>)
| INITCAP (<string_spec>)
| LFILL (<string_spec>,<string_literal>[,<unsigned_integer>])
| LOWER (<string_spec>)
| LPAD (<string_spec>,<expression>,<string_literal>[,<unsigned_integer>])
| LTRIM (<string_spec>[,<string_spec>])
| MAPCHAR (<string_spec>[,<unsigned_integer>][,<mapchar_set_name>])
| REPLACE (<string_spec>,<string_spec>[,<string_spec>])
| RFILL (<string_spec>,<string_literal>[,<unsigned_integer>])
| RPAD (<string_spec>,<expression>,<string_literal>[,<unsigned_integer>])
| RTRIM (<string_spec>[,<string_spec>])
| SOUNDEX (<string_spec>)
| SUBSTR (<string_spec>,<expression>[,<expression>])
| TRANSLATE (<string_spec>,<string_spec>,<string_spec>)
| TRIM (<string_spec>[,<string_spec>])
| UPPER (<string_spec>)


string_literal (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation string_literal

<string_literal> ::=
''
| '<character>...'
| <hex_literal>


string_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation string_spec

<string_spec> ::=
  <expression>


subquery (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation subquery

< subquery > ::=
  (< query_expression >)


subtrans_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation subtrans_statement

< subtrans_statement > ::=
  SUBTRANS BEGIN
| SUBTRANS END
| SUBTRANS ROLLBACK


synonym_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation synonym_name

< synonym_name > ::=
  < identifier >


table_columns (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation table_columns

< table_columns > ::=
  *
| < table_name >.*
| < reference_name >.*


table_description_element (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation table_description_element

< table_description_element > ::=
  < column_definition >
| < constraint_definition >
| < referential_constraint_definition >
| < key_definition >
| < unique_definition >


table_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation table_expression

< table_expression > ::=
  < from_clause > [< where_clause >] [< group_clause >] [< having_clause >]


table_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation table_name

<table_name> ::=
[<schema_name>.]<identifier>


term (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation term

< term > ::=
  < factor >
| <term> * <factor>
| <term> / <factor>
| <term> DIV <factor>
| <term> MOD <factor>


time_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation time_expression

<time_expression> ::=
<expression>


time_or_timestamp_expression (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation time_or_timestamp_expression

<time_or_timestamp_expression> ::=
<expression>


time_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation time_function

< time_function > ::=
  ADDTIME ( < time_or_timestamp_expression >, < time_expression > )
| SUBTIME ( <time_or_timestamp_expression>, <time_expression> )
| TIMEDIFF ( <time_or_timestamp_expression>, <time_or_timestamp_expression> )
| MAKETIME ( < hours >, < minutes >, < seconds > )


token (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation token

<token> ::=
<regular_token>
| <delimiter_token>


top_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation top_spec

<top_spec> ::=
TOP <unsigend_integer>
| TOP <parameter_name>


trigger_event (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation trigger_event

<trigger_event> ::=
INSERT
| UPDATE [(<column_list>)]
| DELETE


trigger_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation trigger_name

< trigger_name > ::=
  < identifier >


trigonometric_function (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation trigonometric_function

< trigonometric_function > ::=
  COS ( < expression > )
| SIN ( <expression> )
| TAN ( <expression> )
| COT ( <expression> )
| COSH ( <expression> )
| SINH ( <expression> )
| TANH ( <expression> )
| ACOS ( <expression> )
| ASIN ( <expression> )
| ATAN ( <expression> )
| ATAN2 ( <expression>, <expression> )
| RADIANS ( <expression> )
| DEGREES ( <expression> )


underscore (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation underscore

<underscore> ::=
_


unique_definition (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation unique_definition

< unique_definition > ::=
  [CONSTRAINT < index_name >] UNIQUE (< column_name >,...)


unlock_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation unlock_statement

<unlock_statement> ::=
UNLOCK <row_spec> ... IN SHARE MODE
| UNLOCK <row_spec> ... IN EXCLUSIVE MODE
| UNLOCK <row_spec> ... IN SHARE MODE <row_spec> ... IN EXCLUSIVE MODE
| UNLOCK <row_spec> ... OPTIMISTIC


unsigned_integer (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation unsigned_integer

< unsigned_integer > ::=
  < numeric_literal >


update_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation update_clause

<update_clause > ::=
  FOR UPDATE [OF <column_name >,...] [NOWAIT]


update_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation update_statement

<update_statement> ::=
UPDATE [OF] <table_name> [<reference_name>] SET <set_update_clause>,...
[KEY <key_spec>,...] [WHERE <search_condition>] [NOWAIT] [IGNORE TRIGGER]
| UPDATE [OF] <table_name> [<reference_name>] (<column_name>,...)
VALUES (<extended_value_spec>,...) [KEY <key_spec>,...]
[WHERE <search_condition>] [NOWAIT] [IGNORE TRIGGER]
| UPDATE [OF] <table_name> [<reference_name>] SET <set_update_clause>,...
WHERE CURRENT OF <result_table_name> [NOWAIT]
| UPDATE [OF] <table_name> [<reference_name>] (<column_name>,...)
VALUES (<extended_value_spec>,...) WHERE CURRENT OF <result_table_name> [NOWAIT]


update_statistics_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation update_statistics_statement

<update_statistics_statement> ::=
UPDATE STAT[ISTICS] COLUMN <table_name>.<column_name>
[ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] COLUMN (<column_name>,...) FOR <table_name>
[ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] COLUMN (*) FOR <table_name>
[ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] <table_name> [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] [<schema_name>.][<identifier>]* [ESTIMATE [<sample_definition>]]
| UPDATE STAT[ISTICS] AS PER SYSTEM TABLE


user_mode (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation user_mode

<user_mode> ::=
DBA
| RESOURCE
| STANDARD


user_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation user_name

< user_name > ::=
  < identifier >


usergroup_mode (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation usergroup_mode

<usergroup_mode> ::=
RESOURCE
| STANDARD


usergroup_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation usergroup_name

< usergroup_name > ::=
  < identifier >


value_spec (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation value_spec

<value_spec> ::=
<literal>
| <parameter_spec>
| NULL
| USER
| USERGROUP
| SYSDBA
| CURRENT_SCHEMA
| UID
| [<schema_name>.]<sequence_name>.NEXTVAL
| [<schema_name>.]<sequence_name>.CURRVAL
| <table_name>.CURRVAL
| DATE
| TIME
| TIMESTAMP
| UTCDATE
| TIMEZONE
| UTCDIFF
| TRUE
| FALSE
| TRANSACTION


variable_name (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation variable_name

<variable_name> ::=
<identifier>


vertical_slash (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation vertical_slash

<vertical_slash> ::=
|


where_clause (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation where_clause

<where_clause> ::=
WHERE <search_condition>


while_statement (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation while_statement

<while_statement> ::=
WHILE <search_condition> DO <statement>


Syntaxnotation (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation Syntaxnotation

Die in dieser Dokumentation verwendete Syntaxnotation ist die BNF mit folgenden Konventionen:

 | Erläuterung
SCHLÜSSELWÖRTER | Schlüsselwörter sind zur Verdeutlichung in Großbuchstaben geschrieben. Sie können in Groß- und in Kleinbuchstaben angegeben werden.
<xyz> | In spitze Klammern eingefaßte Begriffe sind Platzhalter für syntaktische Einheiten, die erläutert werden. Verwenden Sie die spitzen Klammern bei der Angabe einer SQL-Anweisung nicht mit.
<! Text !> | In spitze Klammern und Ausrufezeichen eingefasste Texte geben an, dass die syntaktische Einheit durch einen Text erläutert wird. Verwenden Sie die spitzen Klammern und Ausrufezeichen bei der Angabe einer SQL-Anweisung nicht mit.
Klausel ::= Regel | Klauseln sind die Bausteine der SQL-Anweisungen. Die Regeln beschreiben die Bildung zusammengesetzter Bausteine aus einfacheren Bausteinen und ihre Notation.
Klausel1 Klausel2 | Die beiden Klauseln werden hintereinander notiert und durch wenigstens ein Leerzeichen voneinander getrennt.
[Klausel] | Optionale Klausel. Diese Klausel kann ersatzlos entfallen. Verwenden Sie die eckigen Klammern bei der Angabe einer SQL-Anweisung nicht mit.
Klausel1 | Klausel2 | ... | Klauseln | Alternative Klauseln. Sie können jeweils genau eine der Klauseln verwenden.
Klausel,... | Die Klausel kann beliebig oft wiederholt werden. Die einzelnen Wiederholungen sind hintereinander zu notieren und durch ein Komma und beliebig viele Leerzeichen voneinander zu trennen.
Klausel ... | Die Klausel kann beliebig oft wiederholt werden. Die einzelnen Wiederholungen sind hintereinander zu notieren und durch Leerzeichen voneinander zu trennen.
Klausel... | Die Klausel kann beliebig oft wiederholt werden. Die einzelnen Wiederholungen sind direkt hintereinander zu notieren.

Siehe auch:

Syntaxverzeichnis

Syntaxänderungen

Glossar, Syntaxnotation


Syntaxänderungen (SAP-Bibliothek - Grundwissen)

Syntaxdokumentation Syntaxänderungen

Beim Übergang von der Datenbankversion 7.5 zur Version 7.6 gab es Syntaxänderungen. Die wesentlichen Veränderungen werden in der folgenden Liste genannt.

SQL-Anweisung in Version 7.6

Änderung in Version 7.6 im Vergleich zu Version 7.5

create_user_statement
alter_user_statement

Das optionale Syntaxelement connect_mode wird unterstützt.

create_dbproc_statement
drop_dbproc_statement

Die Verwendung des Schlüsselworts DBPROC oder DBPROCEDURE ist erlaubt.

create_function_statement
drop_function_statement

Das optionale Syntaxelement PUBLIC und/oder DETERMINISTIC wird unterstützt.

create_schema_statement
drop_schema_statement
rename_schema_statement

Die Verwendung von Schemas wird unterstützt.

In Zusammenhang mit der Einführung des Schemakonzeptes gab es Syntaxanpassungen in einigen weiteren SQL-Anweisungen, die hier jetzt nicht alle einzeln aufgeführt werden. Die bisherige Angabe eines Eigentümers wurde für viele Objektbezeichnungen durch die Angabe des Schemas ersetzt.

create_system_trigger_statement
drop_system_trigger_statement

Die Verwendung von System-Triggern wird unterstützt.

create_table_statement

Das optionale Syntaxelement NO FIXED LENGTH COLUMN wird nicht mehr unterstützt.

grant_statement
revoke_statement

Die Syntaxvariante, die bei Verwendung von Schemas erforderlich ist, wurde jeweils hinzugefügt.

parameter_name

Bei der Angaben eines Parameternamens wird nur noch eine der Varianten :<identifier> oder ? unterstützt, die weiteren Möglichkeiten sind entfallen.

sample_definition

Die Angabe der Stichprobengröße 0 bewirkt, dass die Tabellen vom UPDATE STATISTICS-Lauf ausgeschlossen werden.

inner_transaction_statement

Das Anlegen und Verwenden von inneren Transaktionen wird unterstützt.

savepoint_statement
release_savepoint_statement
rollback_to_statement

Das Setzen und Verwenden von SQL-Savepoints wird unterstützt.

select_column

Die Syntaxvarianten <result_column_name> = <expression>, <result_column_name> = ROWNO und <result_column_name> = STAMP werden nicht mehr unterstützt.

set_statement

Die Syntaxvariante, die bei Verwendung von Schemas erforderlich ist, wurde hinzugefügt.

top_spec

limit_clause

In einer SELECT-Anweisung können Sie die LIMIT-Klausel oder das TOP-Syntaxelement verwenden, um die Anzahl der Zeilen einer Ergebnistabelle einzuschränken.

insert_statement
update_statement
delete_statement

Die optionalen Syntaxelemente NOWAIT und/oder IGNORE TRIGGER werden unterstützt.

update_statistics

Die Syntaxvariante UPDATE STATISTICS AS PER SYSTEM TABLE wird unterstützt.

GET_OWNER(x,o)
GET_SCHEMA(x,o)

Die Stringfunktion GET_OWNER(x,o) wurde in GET_SCHEMA(x,o) umbenannt.

named_query_expression
named_query_primary
named_query_spec
named_query_term

Alle SQL-Anweisungen und Syntaxelemente in diesem Bereich werden nicht mehr unterstützt.

open_cursor_statement

Die SQL-Anweisung open_cursor_statement wird nicht mehr unterstützt.

Siehe auch:

Syntaxverzeichnis


Systemtabellen (SAP-Bibliothek - Grundwissen)

Komponentendokumentation Systemtabellen

Im Datenbanksystem gibt es eine Reihe von Systemtabellen, die Informationen über die Datenbankobjekte und deren Verbindungen untereinander enthalten, Statistiksystemtabellen, Monitor-Systemtabellen und Loader-Systemtabellen.

Sie finden im Folgenden eine Reihe von Informationen, wie Sie die Systemtabellen auswerten können.

● Beachten Sie bei der Angabe von SELECT-Anweisungen auf die Systemtabellen die allgemeinen Hinweise.

● Um zu erfahren, in welcher Systemtabelle Sie Informationen zu einem bestimmten Datenbankbegriff finden, verwenden Sie die Liste der Datenbankbegriffe.

● Um zu erfahren, welche Informationen eine bestimmte Systemtabelle liefern kann, finden Sie im Abschnitt Systemtabellen auswerten eine Reihe von Beispiel-SELECT-Anweisungen.

Für die Beispiele werden gegebenenfalls die Strukturlink Demo-Daten für das SQL-Tutorial zugrunde gelegt.

● Die vollständige Definition einiger wichtiger Systemtabellen finden Sie unter Definition der Systemtabellen.


Allgemeine Hinweise (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Allgemeine Hinweise

Wenn Sie Systemtabellen auswerten wollen, beachten Sie folgende Hinweise:

· Beim Auswerten von Systemtabellen werden nur Informationen über solche Objekte ausgegeben, für die der aktuelle Benutzer Eigentümer ist oder zumindest ein Privileg erhalten hat (der Benutzer kennt also das Objekt). Dieses Berechtigungskonzept kann dazu führen, dass die für den aktuellen Benutzer sichtbare Tabellendefinition von der tatsächlichen Definition abweicht.
Die Definition einer View-Tabelle ist nur für den Eigentümer der View-Tabelle sichtbar.

· Die Bedingungen bei der Abfrage der Systemtabelle(n) sollten möglichst genau das gewünschte Objekt beschreiben. Die Angabe des Eigentümers des Objektes beschleunigt die Suche nach den entsprechenden Informationen erheblich.

· Bei der Angabe der Suchanweisungen sollten möglichst Gleichheitsbedingungen angegeben werden. Die Angabe von LIKE-Bedingungen ist ungünstiger.

· Aus Performance-Gründen sollte bei der Abfrage von Informationen aus Systemtabellen nicht nur die SQL-Anweisung SELECT * verwendet werden, sondern die Anzahl der Ausgabespalten auf die gewünschten Spalten eingeschränkt werden.
Gerade bei Abfrage von Statistikinformationen aus Systemtabellen werden bei Anforderung bestimmter Ausgabespalten zusätzliche Aktionen zur Ermittlung dieser Spaltenwerte im Datenbanksystem durchgeführt. Daher sollte Sie diese Spalteninformation nur dann ermitteln lassen, wenn diese auch wirklich benötigt werden.

· Einfache Bezeichner werden immer in Großbuchstaben in der Datenbankinstanz abgelegt, unabhängig davon wie sie bei der Datendefinition angegeben werden.
Wenn Sie einfache Bezeichner in einer Suchbedingung verwenden, müssen die für die Angabe von Literalen üblichen einfachen Hochkomma angegeben werden.
Aus Performance-Gründen sollte die Umwandlung eines einfachen Bezeichners in Großbuchstaben nicht erst beim Ausführen der SQL-Anweisung durch das Datenbanksystem erfolgen, sondern Sie sollten einfache Bezeichner sofort in Großbuchstaben in der Suchbedingung angeben.

CREATE TABLE mytab (…)
SELECT … FROM … WHERE … = 'MYTAB'

· Spezielle Bezeichner werden bei der Datendefinition in doppelten Hochkomma angegeben. Sie werden in der Datenbankinstanz so abgelegt, wie sie angegeben wurden, also nicht in Großbuchstaben umgewandelt.
Wenn Sie spezielle Bezeichner in einer Suchbedingung verwenden, müssen Sie die für die Angabe von Literalen üblichen einfachen Hochkomma angegeben.

CREATE TABLE "this is mytab" (…)
SELECT … FROM … WHERE … = 'this is mytab'

Siehe auch:

Bezeichner (identifier)


Datenbankbegriffe (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankbegriffe

Um Informationen über Ihr Datenbanksystem, dessen Objekte, Strukturen, Statusinformationen u.ä. zu ermitteln, müssen Sie die entsprechenden Systemtabellen auswerten.

Sie finden im folgenden eine Liste von Datenbankbegriffen mit Verweisen auf die Systemtabellen, die Informationen zu dem gewünschten Begriff liefern können. Die Begriffe sind alphabetisch geordnet.

 | Begriff | Erläuterung | Systemtabelle
B | Benutzer | definierter aktueller | USERS SESSIONS
 | Betriebssystem | der Datenbankinstanz | VERSION
C | Char-Set (Zeichensatz) | Mapchar-Set | MAPCHARSETS
 | Column (Spalte) | Definition, Wertebereich, Vorschlagswert Primärschlüssel Privileg indizierte im referentiellen Constraint einer Tabelle in View-Tabelle | COLUMNS INDEXCOLUMNS FOREIGNKEYCOLUMNS VIEWCOLUMNS
 | Constraint | NOT NULL-Spalten Primärschlüssel einer Spalte oder Tabelle eines Wertebereichs referentielles UNIQUE | COLUMNS CONSTRAINTS DOMAINCONSTRAINTS FOREIGNKEYS INDEXES
D | Datenbankinstanz | der aktuellen Datenbanksitzung Informationen | USERS INSTANCE
 | Datenbankparameter | aktuell gültige | ACTIVECONFIGURATION
 | Datenbankprozedur | Name und weitere Informationen Parameter | DBPROCEDURES DBPROCPARAMS
 | Datenbanksitzung | eigene und alle aktiven in der Datenbanksitzung aktive Rollen | SESSIONS SESSION_ROLES
 | Default (Vorschlagswert) | für eine Spalte für einen Wertebereich für eine Rolle | COLUMNS DOMAINS ROLES
 | Domain (Wertebereich) | Name und weitere Informationen Constraint bei Spaltendefinition | DOMAINS DOMAINCONSTRAINTS COLUMNS
E | Ergebnistabelle | Existenz | TABLES
F | Fremdschlüssel (Foreign Key, referentielles Constraint) | Name und weitere Informationen Spalten | FOREIGNKEYS FOREIGNKEYCOLUMNS
I | Identifikation | interne Identifikation einer Tabelle interne Identifikation eines Benutzers | TABLES USERS
 | Isolation-Level | der aktuellen Datenbanksitzung | SESSIONS
L | Lock (Sperre) | aktuelle angeforderte | LOCKS LOCK_WAITS
 | Log-Bereich | Auslastung | LOGSTATISTICS
 | Log-Warteschlange | Identifikation und weitere Informationen | LOGQUEUESTATISTICS
M | Mapchar-Set | Name und weitere Informationen | MAPCHARSETS
 | Migration (Upgrade) | Protokoll | POSTUPGRADECHECKLIST
P | Parameter | einer Datenbankprozedur Datenbankparameter | DBPROCPARAMS ACTIVECONFIGURATION
 | Privileg | einer Rolle einer Spalte eines Schemas einer Tabelle | ROLEPRIVILEGES COLUMNS SCHEMAPRIVILEGES TABLES TABLEPRIVILEGES
R | Rechner | Name Auslastung | USERS MACHINEUTILIZATION
 | Referentielles Constraint | Name und weitere Informationen Spalten | FOREIGNKEYS FOREIGNKEYCOLUMNS
 | Release (Version) | Datenbanksoftware | VERSION
 | Rolle | Name und weitere Informationen Privileg aktive in der Datenbanksitzung | ROLES ROLEPRIVILEGES SESSION_ROLES
S | Schema | Name und weitere Informationen Privileg | SCHEMAS SCHEMAPRIVILEGES
 | Schlüssel | Primärschlüssel Sekundärschlüssel Fremdschlüssel (referentielles Constraint) | COLUMNS FOREIGNKEYCOLUMNS FOREIGNKEYS
 | Sequenz | Aktueller Wert | SEQUENCES
 | Server-Node (Rechner) | Name Auslastung | USERS MACHINEUTILIZATION
 | Session (Datenbanksitzung) | eigene und alle aktiven in der Datenbanksitzung aktive Rollen | SESSIONS SESSION_ROLES
 | Spalte | Definition, Wertebereich, Vorschlagswert Primärschlüssel Privileg indizierte im referentiellen Constraint einer Tabelle in View-Tabelle | COLUMNS INDEXCOLUMNS FOREIGNKEYCOLUMNS VIEWCOLUMNS
 | Sperre | aktuelle angeforderte | LOCKS LOCK_WAITS
 | SQL-Modus | der aktuellen Datenbanksitzung | SESSIONS
 | Statistik | Zeitpunkt und Sample-Werte des letzten UPDATE STATISTICS-Laufs einer Tabelle | TABLES
 | Synonym | Synonyme Existenz | SYNONYMS TABLES
T | Tabelle | Name und weitere Informationen Definition Synonym Privileg View-Definition Constraint referentielles Constraint Index View-Tabelle Primärschlüssel Sekundärschlüssel Trigger | TABLES COLUMNS SYNONYMS TABLEPRIVILEGES VIEWCOLUMNS CONSTRAINTS FOREIGNKEYS INDEXES VIEWS COLUMNS FOREIGNKEYCOLUMNS TRIGGERS
 | Timeout | der aktuellen Datenbanksitzung | SESSIONS
 | Trigger | Name und weitere Informationen | TRIGGERS
U | UNIQUE | Index | INDEXES
 | Upgrade | Protokolle | POSTUPGRADECHECKLIST
 | User (Benutzer) | definierter aktueller | USERS SESSIONS
V | Version | Datenbanksoftware u. Betriebssystem | VERSION
 | View-Tabelle | Name und weitere Informationen Definition Existenz Synonym Tabellen und Spalten | VIEWS VIEWDEFS TABLES SYNONYMS VIEWCOLUMNS
 | Vorschlagswert | für eine Spalte für einen Wertebereich für eine Rolle | COLUMNS DOMAINS ROLES
W | Wertebereich | Name und weitere Informationen Constraint bei Spaltendefinition | DOMAINS DOMAINCONSTRAINTS COLUMNS
Z | Zeichensatz | Mapchar-Set | MAPCHARSETS


Systemtabellen auswerten (Beispiele) (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Systemtabellen auswerten (Beispiele)

Voraussetzungen

Sie haben die Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Beispiele

Für folgende Systemtabellen werden Beispiele für deren Auswertung gegeben:

Strukturlink ACTIVECONFIGURATION

Strukturlink CACHESTATISTICS

Strukturlink COLUMNS

Strukturlink CONSTRAINTS

Strukturlink DATASTATISTICS

Strukturlink DATAVOLUMES

Strukturlink DBPROCEDURES

Strukturlink DBPROCPARAMS

Strukturlink DOMAINCONSTRAINTS

Strukturlink DOMAINS

Strukturlink FOREIGNKEYCOLUMNS

Strukturlink FOREIGNKEYS

Strukturlink FUNCTIONS

Strukturlink INDEXCOLUMNS

Strukturlink INDEXES

Strukturlink INSTANCE

Strukturlink LOCKS

Strukturlink LOGQUEUESTATISTICS

Strukturlink LOGSTATISTICS

Strukturlink MAPCHARSETS

Strukturlink ROLEPRIVILEGES

Strukturlink ROLES

Strukturlink SEQUENCES

Strukturlink SESSION_ROLES

Strukturlink SESSIONS

Strukturlink SYNONYMS

Strukturlink TABLEPRIVILEGES

Strukturlink TABLES

Strukturlink TRIGGERS

Strukturlink USERS

Strukturlink VERSION

Strukturlink VIEWCOLUMNS

Strukturlink VIEWDEFS

Strukturlink VIEWS

Siehe auch:

Strukturlink Datenbankbegriffe

Strukturlink Definitionen der Systemtabellen


ACTIVECONFIGURATION (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt ACTIVECONFIGURATION

Voraussetzungen

Melden Sie sich an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle ACTIVECONFIGURATION können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Name und Wert des Datenbankparameters RUNDIRECTORY

SELECT parametername, value
FROM SYSINFO.ACTIVECONFIGURATION
WHERE parametername = 'RUNDIRECTORY'

· Anzeige, ob der Paramater MAXBACKUPDEVS im Betriebszustand ONLINE änderbar ist und nach seiner Änderung sofort wirksam wird

SELECT parametername, changeable
FROM activeconfiguration
WHERE parametername = 'MAXBACKUPDEVS'


CACHESTATISTICS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt CACHESTATISTICS

Voraussetzungen

Melden Sie sich an der Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle CACHESTATISTICS können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Anzeige aller Caches, deren Trefferrate unter 90 % liegt

SELECT name, accesscount, hitrate
FROM SYSINFO.CACHESTATISTICS
WHERE hitrate < '90'

· Anzeige der Caches, die weniger erfolgreiche als fehlgeschlagene Zugriffe aufweisen

SELECT *
FROM SYSINFO.CACHESTATISTICS
WHERE successfulaccesscount < unsuccessfulaccesscount


COLUMNS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt COLUMNS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle COLUMNS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Spalten der Tabelle RESERVATION in der Reihenfolge ihrer Definition, zusammen mit den zugehörigen Kommentaren

SELECT columnname, comment
FROM DOMAIN.COLUMNS
WHERE tablename = 'RESERVATION' ORDER BY pos

● Datentypen aller Spalten der Tabelle CUSTOMER

SELECT columnname, datatype, len, dec, codetype
FROM DOMAIN.COLUMNS
WHERE tablename = 'CUSTOMER'

● Alle Spalten der Basistabellen des Schemas HOTEL, die den Datentyp DATE besitzen

SELECT tablename,columnname
FROM DOMAIN.COLUMNS
WHERE schemaname = 'HOTEL'
AND tabletype = 'TABLE'
AND datatype = 'DATE'

● Alle Spalten der eigenen Tabelle HOTEL, für die ein Vorschlagswert definiert wurde, sowie dieser Vorschlagswert

SELECT columnname, "DEFAULT"
FROM DOMAIN.COLUMNS
WHERE schemaname = 'HOTEL'
AND tablename = 'HOTEL'
AND "DEFAULT" IS NOT NULL

Beachten Sie, dass die Spalte DEFAULT als spezieller Bezeichner (Bezeichner eingeschlossen in doppelte Anführungszeichen) angegeben werden muss, da DEFAULT ein reserviertes Schlüsselwort ist.

● Alle Primärschlüsselspalten der Tabelle ROOM, sortiert nach ihrer Reihenfolge im Primärschlüssel

SELECT columnname
FROM DOMAIN.COLUMNS
WHERE tablename = 'ROOM' AND mode = 'KEY' ORDER BY keypos

● Alle mit NOT NULL definierten Spalten der Tabelle CUSTOMER

SELECT columnname
FROM DOMAIN.COLUMNS
WHERE tablename = 'CUSTOMER' AND mode = 'MAN'

● Alle für den Benutzer MONA änderbaren Spalten der Tabelle RESERVATION

SELECT columnname
FROM DOMAIN.COLUMNS
WHERE tablename = 'RESERVATION' AND columnprivileges LIKE '%UPD%'

● Alle für den Benutzer MONA änderbaren Spalten der Tabelle RESERVATION, für die er dieses Privileg weitervergeben darf

SELECT columnname
FROM DOMAIN.COLUMNS
WHERE tablename = 'RESERVATION' AND columnprivileges LIKE '%UPD+%'

Voraussetzung für das folgende Beispiel ist die Definition von Wertebereichen und deren Verwendung in Tabellen. Verfahren Sie dazu z.B. wie im SQL-Tutorial, Strukturlink Wertebereiche beschrieben.

● Alle Tabellenspalten, für die bei der Definition der Wertebereich name_domain oder birthday_domain angegeben wurden

SELECT schemaname, tablename, columnname
FROM DOMAIN.COLUMNS
WHERE domainname = 'NAME_DOMAIN' OR domainname = 'BIRTHDAY_DOMAIN'

Spalten im Index: siehe INDEXCOLUMNS

Spalten im referentiellen Constraint: siehe FOREIGNKEYCOLUMNS

Primärtabellen- oder View-Tabellen-Spalten in View-Tabelle: siehe VIEWCOLUMNS


CONSTRAINTS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt CONSTRAINTS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren und verwenden Sie Constraints. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Constraints beschrieben.

Beispiele

Anhand der Systemtabelle CONSTRAINTS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Bedingungen der Spalten der Tabellen des Schemas HOTEL, die explizite Werteüberprüfungen darstellen

SELECT tablename, constraintname, definition
FROM DOMAIN.CONSTRAINTS
WHERE schemaname = 'HOTEL'

● Alle Bedingungen der Spalten der TabelleCUSTOMER, die explizite Werteüberprüfungen darstellen

SELECT tablename, constraintname
FROM DOMAIN.CONSTRAINTS
WHERE tablename = 'CUSTOMER'

Constraints (Integritätsbedingungen), die NOT NULL-Definitionen, Primärschlüssel, UNIQUE-Definitionen oder referentielle Constraints betreffen, werden mit dieser SELECT-Anweisung nicht gefunden.

NOT-NULL-Spalten: siehe COLUMNS

Primärschlüssel: siehe COLUMNS

UNIQUE-Spalten: siehe INDEXES

Referentielles Constraint: siehe FOREIGNKEYS

Spalten in einem referentiellen Constraint: siehe FOREIGNKEYCOLUMNS

Constraint eines Wertebereichs: siehe DOMAINCONSTRAINTS


DATASTATISTICS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt DATASTATISTICS

Voraussetzungen

Melden Sie sich an der Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle DATASTATISTICS können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Anzeige des Füllungsgrades der Datenbankinstanz

SELECT usablesize, usedsize, usedsizepercentage, datafull
FROM SYSINFO.DATASTATISTICS

· Anzeige, welcher Teil der Datenbankinstanz mit permanenten und welcher Teil mit temporären Daten belegt ist

SELECT usedpermanentsize, usedtemporarysize
FROM SYSINFO.DATASTATISTICS


DATAVOLUMES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt DATAVOLUMES

Voraussetzungen

Melden Sie sich an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle DATAVOLUMES können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Anzeige der Bezeichnung und der Größe der Volumes

SELECT path, configuredsize
FROM SYSINFO.DATAVOLUMES

· Anzeige des für Daten nutzbaren und des für Daten genutzten Bereiches des Volume mit der Identifikation 1

SELECT usablesize, usedsize, usedsizepercentage
FROM SYSINFO.DATAVOLUMES
WHERE ID = 1


DBPROCEDURES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt DBPROCEDURES

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie Datenbankprozeduren an. Verfahren Sie dazu wie z.B. in SQL-Tutorial, Strukturlink Datenbankprozeduren angegeben.

Beispiele

Anhand der Systemtabelle DBPROCEDURES können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Datenbankprozeduren des Schemas HOTEL und ihre Kommentare, die in den letzten 10 Tagen erzeugt wurden

SELECT schemaname, dbprocname, comment
FROM DOMAIN.DBPROCEDURES
WHERE schemaname = 'HOTEL' AND createdate >= subdate(date,10)

● Alle Datenbankprozeduren des Schemas SYSLOADER und ihre Definition

SELECT schemaname, dbprocname, definition
FROM DOMAIN.DBPROCEDURES
WHERE schemaname = 'SYSLOADER'

Parameter einer Datenbankprozedur: siehe DBPROCPARAMS


DBPROCPARAMS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt DBPROCPARAMS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie Datenbankprozeduren und Datenbankfunktionen an und verwenden Sie diese. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Datenbankprozeduren und Strukturlink Datenbankfunktionen angegeben.

Beispiele

Anhand der Systemtabelle DBPROCPARAMS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Input-Parameter der Datenbankfunktion AVGPRICE im Schema HOTEL und folgende Parameterinformationen: Datentyp, Länge und Angabe, um den wievielten Parameter innerhalb der Datenbankfunktion es sich handelt

SELECT parametername, datatype, len, dec, pos
FROM DOMAIN.DBPROCPARAMS
WHERE schemaname = 'HOTEL'
AND dbprocname = 'AVGPRICE'
AND "IN/OUT-TYPE" = 'IN'

● Alle Output-Parameter der Datenbankprozedur AVG_PRICE im Schema HOTEL und folgende Parameterinformationen: Datentyp, Länge und Angabe, um den wievielten Parameter innerhalb der Datenbankprozedur es sich handelt

SELECT parametername, datatype, len, dec, pos
FROM DOMAIN.DBPROCPARAMS
WHERE schemaname = 'HOTEL'
AND dbprocname = 'AVG_PRICE'
AND "IN/OUT-TYPE" = 'OUT'

● Gesamtanzahl der Parameter der Datenbankprozedur AVG_PRICE im Schema HOTEL

SELECT COUNT(*)
FROM DOMAIN.DBPROCPARAMS
WHERE schemaname = 'HOTEL'
AND dbprocname = 'AVG_PRICE'

Datenbankprozeduren: siehe DBPROCEDURES

Datenbankfunktionen: siehe FUNCTIONS


DOMAINCONSTRAINTS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt DOMAINCONSTRAINTS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie Wertebereiche an. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Wertebereiche angegeben.

Beispiele

Anhand der Systemtabelle DOMAINCONSTRAINTS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Wertebereiche, für die eine Einschränkung der zulässigen Werte definiert wurde und die Definition dieses Wertebereichs

SELECT domainname, definition
FROM DOMAIN.DOMAINCONSTRAINTS

● Alle Wertebereiche des Benutzers MONA, für die eine Einschränkung der zulässigen Werte definiert wurde

SELECT owner, domainname
FROM DOMAIN.DOMAINCONSTRAINTS
WHERE owner = 'MONA'

Alle Wertebereiche: siehe DOMAINS


DOMAINS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt DOMAINS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie Wertebereiche an. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Wertebereiche angegeben.

Beispiele

Anhand der Systemtabelle DOMAINS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Wertebereiche, die für den Datentyp DATE definiert wurden

SELECT owner, domainname
FROM DOMAIN.DOMAINS
WHERE datatype = 'DATE'

● Alle eigenen Wertebereiche, in denen ein Vorschlagswert vereinbart wurde

SELECT domainname, datatype, len, dec, "DEFAULT"
FROM DOMAIN.DOMAINS
WHERE owner = 'MONA'
AND "DEFAULT" IS NOT NULL

Beachten Sie, dass die Spalte DEFAULT als spezieller Bezeichner (Bezeichner eingeschlossen in doppelte Anführungszeichen) angegeben werden muss, da DEFAULT ein reserviertes Schlüsselwort ist.

Constraint eines Wertebereichs: siehe DOMAINCONSTRAINTS

Wertebereich bei Spaltendefinition: siehe COLUMNS


FOREIGNKEYCOLUMNS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt FOREIGNKEYCOLUMNS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie referentielle Constraints an. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen angegeben.

Beispiele

Anhand der Systemtabelle FOREIGNKEYCOLUMNS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle referentiellen Constraints, in denen die Spalte CNO der Tabelle CUSTOMER referenzierte Spalte ist

SELECT schemaname, tablename, columnname, fkeyname, rule
FROM DOMAIN.FOREIGNKEYCOLUMNS
WHERE reftablename = 'CUSTOMER'
AND refcolumnname = 'CNO'

● Alle referentiellen Constraints, in denen die Spalte HNO der Tabelle RESERVATION referenzierende Spalte ist

SELECT fkeyname, rule
FROM DOMAIN.FOREIGNKEYCOLUMNS
WHERE tablename = 'RESERVATION'
AND columnname = 'HNO'

● Alle referentiellen Constraints, in denen die referenzierenden Spalten aus der Tabelle RESERVATION stammen

SELECT DISTINCT fkeyname, rule, refschemaname, reftablename
FROM DOMAIN.FOREIGNKEYCOLUMNS
WHERE tablename = 'RESERVATION'

Alle referentiellen Constraints: siehe FOREIGNKEYS


FOREIGNKEYS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt FOREIGNKEYS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie referentielle Constraints an. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Fremdschlüsselbeziehungen zwischen Tabellen angegeben.

Beispiele

Anhand der Systemtabelle FOREIGNKEYS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle referentiellen Constraints, in denen die Tabelle RESERVATION referenzierende Tabelle ist

SELECT fkeyname, tablename
FROM DOMAIN.FOREIGNKEYS
WHERE tablename = 'RESERVATION'

● Alle referentiellen Constraints, die mit der Regel DELETE CASCADE gebildet wurden

SELECT schemaname, fkeyname
FROM DOMAIN.FOREIGNKEYS
WHERE rule = 'DELETE CASCADE'

Spalten in referentiellen Constraints: siehe FOREIGNKEYCOLUMNS


FUNCTIONS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt FUNCTIONS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie Datenbankfunktionen an. Verfahren Sie dazu wie z.B. in SQL-Tutorial, Strukturlink Datenbankfunktionen angegeben.

Beispiele

Anhand der Systemtabelle FUNCTIONS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Datenbankfunktionen des Schemas HOTEL, die in den letzten 10 Tagen erzeugt wurden

SELECT schemaname, functionname
FROM DOMAIN.FUNCTIONS
WHERE schemaname = 'HOTEL' AND createdate >= SUBDATE(DATE,10)

● Parameter der Datenbankfunktion AVGPRICE

SELECT schemaname, functionname, parameter
FROM DOMAIN.FUNCTIONS
WHERE functionname = 'AVGPRICE'

Parameter einer Datenbankfunktion: siehe DBPROCPARAMS


INDEXCOLUMNS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt INDEXCOLUMNS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie Indizes an. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Indizes angegeben.

Beispiele

Anhand der Systemtabelle INDEXCOLUMNS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle indizierten Spalten der Tabelle CUSTOMER

SELECT DISTINCT columnname
FROM DOMAIN.INDEXCOLUMNS
WHERE tablename = 'CUSTOMER'

● Alle Invertierungen für die Tabelle CUSTOMER, sortiert nach dem Indexnamen und darin jeweils nach der Reihenfolge der Spalten, die bei der Indexdefinition angegeben wurden

SELECT indexname, type, columnname, sort
FROM DOMAIN.INDEXCOLUMNS
WHERE tablename = 'CUSTOMER' ORDER BY indexname, columnno

● Informationen über die Spalten, aus denen der Index ADDRESS_INDEX der Tabelle CUSTOMER zusammengesetzt ist

SELECT columnname, sort, datatype, len
FROM DOMAIN.INDEXCOLUMNS
WHERE tablename = 'CUSTOMER'
AND indexname = 'ADDRESS_INDEX' ORDER BY columnno

Alle Indizes: siehe INDEXES


INDEXES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt INDEXES

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie Indizes an. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Indizes angegeben.

Beispiele

Anhand der Systemtabelle INDEXES können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Indizes der Tabelle CUSTOMER und Angabe, welche Indizes zur Zeit für Suchvorgänge nicht genutzt werden (sich also im Zustand DISABLED befinden)

SELECT indexname, disabled
FROM DOMAIN.INDEXES
WHERE tablename = 'CUSTOMER'

● Alle UNIQUE-Indizes (unabhängig davon, mit welcher der möglichen SQL-Anweisungen diese Indizes erzeugt wurden: CREATE INDEX-Anweisung oder UNIQUE-Definition)

SELECT schemaname, tablename, indexname
FROM DOMAIN.INDEXES
WHERE type = 'UNIQUE'

Spalten eines Index: siehe INDEXCOLUMNS


INSTANCE (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt INSTANCE

Voraussetzungen

Melden Sie sich an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle INSTANCE können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Name, unter dem die Datenbankinstanz von Anwendungen angesprochen werden kann

SELECT node
FROM SYSINFO.INSTANCE

· Zeitpunkt des Erreichens des Betriebszustandes ONLINE

SELECT onlinestatedate
FROM SYSINFO.INSTANCE


LOCKS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt LOCKS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle LOCKS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Sperren, die aktuell auf der Tabelle ROOM gehalten werden

SELECT lockmode, lockstate, rowidlength, rowidhex, rowid
FROM DOMAIN.LOCKS
WHERE tablename = 'ROOM'

● Alle Sperren, die der aktuelle Benutzer in seiner Datenbanksitzung auf der Tabelle ROOM hält

SELECT lockmode, lockstate, rowidlength, rowidhex, rowid
FROM DOMAIN.LOCKS, SYSINFO.SESSIONS
WHERE tablename = 'ROOM'
AND locks.session = sessions.sessionid

● Alle Sperren, die aktuell auf der Tabelle mit der hexadezimalen internen Identifikation 000000000000035D gehalten werden

SELECT lockmode, lockstate, rowidlength, rowidhex, rowid
FROM DOMAIN.LOCKS
WHERE tableid = X'000000000000035D'

Wenn der aktuelle Benutzer Datenbankadministrator (DBA-Benutzer) oder Datenbanksystemadministrator (SYSDBA-Benutzer) ist, werden alle Sperren angezeigt, die gehalten werden.

Benutzer anderer Benutzerklassen sehen nur die Sperren, die von diesem Benutzer gehalten werden.


LOGQUEUESTATISTICS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt LOGQUEUESTATISTICS

Voraussetzungen

Melden Sie sich an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle LOGQUEUESTATISTICS können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Identifikation der Log-Warteschlange

SELECT QUEUEID
FROM SYSINFO.LOGQUEUESTATISTICS

· Anzahl der Wartesituationen, die aufgrund einer zu vollen Log-Warteschlange notwendig waren

SELECT QUEUEOVERFLOWCOUNT
FROM SYSINFO.LOGQUEUESTATISTICS


LOGSTATISTICS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt LOGSTATISTICS

Voraussetzungen

Melden Sie sich an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle LOGSTATISTICS können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Größe des Log-Bereichs und belegter Log-Bereich

SELECT usablesize, usedsize, usedsizepercentage
FROM SYSINFO.LOGSTATISTICS

· Anzahl der Log-Warteschlangen und deren Größe

SELECT queuecount, queuesize
FROM SYSINFO.LOGSTATISTICS

· Größe des noch nicht gesicherten Log-Bereichs

SELECT notsavedsize, notsavedpercentage
FROM SYSINFO.LOGSTATISTICS


MAPCHARSETS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt MAPCHARSETS

Voraussetzungen

Melden Sie sich an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle MAPCHARSETS können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Namen aller Mapchar-Sets

SELECT DISTINCT mapcharsetname
FROM DOMAIN.MAPCHARSETS

· Umsetzung des hexadezimalen Wertes D6 im Mapchar-Set DEFAULTMAP

SELECT map_code, map_character
FROM DOMAIN.MAPCHARSETS
WHERE mapcharsetname = 'DEFAULTMAP'
AND intern = X'D6'


ROLEPRIVILEGES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt ROLEPRIVILEGES

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren und verwenden Sie Rollen. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Rollen beschrieben.

Beispiele

Anhand der Systemtabelle ROLEPRIVILEGES können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Privilegien, die der Rolle ROLE_1 direkt für die Tabelle CITY verliehen wurden. Indirekt, d. h. durch eine andere Rolle für die Tabelle CITY vergebene Privilegien werden nicht angezeigt.

SELECT privileges
FROM DOMAIN.ROLEPRIVILEGES
WHERE grantee = 'ROLE_1'
AND schemaname = 'HOTEL'
AND tablename = 'CITY'

● Alle Rollen, die der Rolle ROLE_4 verliehen wurden. Angabe, wer die Rollen verliehen hat.

SELECT role, grantor
FROM DOMAIN.ROLEPRIVILEGES
WHERE grantee = 'ROLE_4'
AND role IS NOT NULL

Alle Rollen: siehe ROLES

Rolle eines Benutzers, die automatisch beim Eröffnen einer Datenbanksitzung aktiviert wird: siehe ROLES

Alle in der aktuellen Datenbanksitzung aktiven Rollen: siehe SESSION_ROLES


ROLES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt ROLES

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODEB an.

Definieren und verwenden Sie Rollen. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Rollen beschrieben.

Beispiele

Anhand der Systemtabelle ROLES können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Rollen, für deren Aktivierung die Angabe eines Kennworts notwendig ist

SELECT owner, role
  FROM DOMAIN.ROLES
    WHERE password_required = 'YES'

● Rolle des aktuellen Benutzers, die automatisch beim Eröffnen einer Datenbanksitzung aktiviert wird

SELECT role
  FROM DOMAIN.ROLES
    WHERE defaultrole = 'YES'

Alle in der aktuellen Datenbanksitzung aktiven Rollen: siehe SESSION_ROLES

Rollenprivileg: siehe ROLEPRIVILEGES


SEQUENCES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt SEQUENCES

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren und verwenden Sie Sequenzen. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Nummerngeneratoren für Tabellen beschrieben.

Beispiele

Anhand der Systemtabelle SEQUENCES können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Sequenzen, deren inkrementeller Wert nicht +1 beträgt und die Grenzwerte der Sequenzen

SELECT owner, sequence_name, increment_by, min_value, max_value
FROM DOMAIN.SEQUENCES
WHERE increment_by <> 1

● Alle Sequenzen mit positivem inkrementellen Wert. Die Werte werden nicht zyklisch vergeben und es gibt nur noch maximal 1000 freie Werte.

SELECT owner, sequence_name, last_number, max_value
FROM DOMAIN.SEQUENCES
WHERE increment_by > 0
AND cycle_flag = 'N'
AND max_value - last_number <= 1000

● Aktueller Wert der Sequenz SEQU

SELECT last_number
FROM DOMAIN.SEQUENCES
WHERE schemaname = 'HOTEL'
AND sequence_name = 'SEQU'

● Zuletzt in der aktuellen Datenbanksitzung vergebener Wert der Sequenz SEQU

SELECT hotel.sequ.currval
FROM DUAL


SESSION_ROLES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt SESSION_ROLES

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren und verwenden Sie Rollen. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Rollen beschrieben.

Beispiele

Anhand der Systemtabelle SESSION_ROLES können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Rollen, die in der aktuellen Datenbanksitzung aktiv sind

SELECT role
FROM DOMAIN.SESSION_ROLES

Alle Rollen: siehe ROLES

Rolle eines Benutzers, die automatisch beim Eröffnen einer Datenbanksitzung aktiviert wird: siehe ROLES

Rollenprivileg: siehe ROLEPRIVILEGES


SESSIONS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt SESSIONS

Voraussetzungen

Melden Sie sich an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle SESSIONS können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Alle aktuell angemeldeten Benutzer und Name des Rechners, auf dem die Anwendung läuft

SELECT username, applicationnode
FROM SYSINFO.SESSIONS
WHERE own = 'YES'

· Parameter der eigenen Datenbanksitzung

SELECT sqlmode, isolationlevel, timeout, sessionid
FROM SYSINFO.SESSIONS
WHERE own = 'YES'

Alle definierten Benutzer: siehe USERS


SYNONYMS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt SYNONYMS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren Sie Synonyme. Verwenden Sie dazu die CREATE SYNONYM-Anweisung (create_synonym_statement).

Beispiele

Anhand der Systemtabelle SYNONYMS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Die Tabelle (Basistabelle, View-Tabelle), für die das PUBLIC-Synonym SHORT_TAB definiert wurde

SELECT tableowner, tablename
  FROM DOMAIN.SYNONYMS
    WHERE public = 'YES'
      AND synonymname = 'SHORT_TAB'

● Privates Synonym für die Tabelle CITY des Benutzers MONA

SELECT synonymname
  FROM DOMAIN.SYNONYMS
    WHERE tableschemaname = 'HOTEL'
      AND tableowner = 'MONA'
      AND tablename = 'CITY'

Existenz eines Synonyms: siehe TABLES


TABLEPRIVILEGES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt TABLEPRIVILEGES

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren Sie Privilegien. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink Datenbankbenutzer und ihre Privilegien beschrieben.

Beispiele

Anhand der Systemtabelle TABLEPRIVILEGES können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Tabellen, für die der aktuelle Benutzer ein Privileg erhalten hat. Eigene Tabellen werden nicht ausgegeben.

SELECT schemaname, tablename, privilege
  FROM DOMAIN.TABLEPRIVILEGES
    WHERE grantee = 'MONA'

● Alle Tabellen, für die der aktuelle Benutzer das SELECT-Privileg erhalten hat und dieses auch weitergeben darf. Eigene Tabellen werden nicht ausgegeben.

SELECT schemaname, owner, tablename
  FROM DOMAIN.TABLEPRIVILEGES
    WHERE grantee = 'MONA'
      AND privilege LIKE '%SEL%'
      AND is_grantable = 'YES'

● Alle Privilegien, die der aktuelle Benutzer an den Benutzer DAVID vergeben hat

SELECT schemaname, tablename, privilege
  FROM DOMAIN.TABLEPRIVILEGES
    WHERE grantor = 'MONA'
      AND grantee = 'DAVID'

Alle Tabellen: siehe TABLES

Existenz einer Tabelle: siehe TABLES

Tabellendefinition: siehe COLUMNS

Synonym für eine Tabelle: siehe SYNONYMS

Tabellenprivileg: siehe TABLES

Tabelle in einer View-Definition: siehe VIEWCOLUMNS


TABLES (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt TABLES

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle TABLES können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Tabellen, View-Tabellen und Synonyme, die der aktuelle Benutzer im Schema HOTEL selektieren kann

SELECT tablename, type
FROM DOMAIN.TABLES
WHERE schemaname = 'HOTEL'
AND privileges LIKE '%SEL%'

● Alle Ergebnistabellen des aktuellen Benutzers

SELECT tablename
FROM DOMAIN.TABLES
WHERE type = 'RESULT'

● Alle eigenen Tabellen, für die der letzte Update-Statistics-Lauf mehr als 30 Tage zurückliegt

SELECT tablename, updstatdate
FROM DOMAIN.TABLES
WHERE updstatdate <= subdate(DATE,30)

● Informationen, mit welchen Sample-Werten ein Update-Statistics-Lauf auf die Tabelle CUSTOMER durchgeführt wird

SELECT sample_percent, sample_rows
FROM DOMAIN.TABLES
WHERE tablename = 'CUSTOMER'

● Interne Identifikation der Tabelle HOTEL

SELECT tableid
FROM DOMAIN.TABLES
WHERE tablename = 'HOTEL'

Wenn es sich um eine Basistabelle handelt, kann die interne Identifikation einer Tabelle z.B. bei der Abfrage auf Sperren (siehe LOCKS) eingesetzt werden.

Tabellendefinition: siehe COLUMNS

Primärschlüssel: COLUMNS

Synonym für eine Tabelle: siehe SYNONYMS

Tabellenprivileg: siehe TABLEPRIVILEGES

Tabelle in einer View-Definition: siehe VIEWCOLUMNS

Constraint einer Spalte oder Tabelle: siehe CONSTRAINTS

Referentieller Constraint: siehe FOREIGNKEYS

Index: siehe INDEXES

View-Tabelle: VIEWS

Sekundärschlüssel: siehe FOREIGNKEYCOLUMNS

Trigger: siehe TRIGGERS


TRIGGERS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt TRIGGERS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren Sie Trigger. Verfahren Sie dazu wie z.B. in SQL-Tutorial, Strukturlink Datenbanktrigger beschrieben.

Beispiele

Anhand der Systemtabelle TRIGGERS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Update-Trigger für die Tabelle HOTEL

SELECT triggername, definition
FROM DOMAIN.TRIGGERS
WHERE tablename = 'HOTEL'
AND UPDATE = 'YES'

● Tabelle und Aktion, für die der Trigger HOTEL_UPDATE definiert wurde

SELECT owner, triggername, insert, update, delete
FROM DOMAIN.TRIGGERS
WHERE triggername = 'HOTEL_UPDATE'


USERS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt USERS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren Sie weitere Datenbankbenutzer. Verfahren Sie dazu z.B: wie in SQL-Tutorial, Strukturlink Datenbankbenutzer und ihre Privilegien beschrieben.

Beispiele

Anhand der Systemtabelle USERS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle definierten Datenbankbenutzer der Datenbankbenutzerklasse STANDARD

SELECT owner, username
FROM DOMAIN.USERS
WHERE usermode = 'STANDARD'

● Alle Benutzer, die mehr als 6 Monate ihr Kennwort nicht verändert haben

SELECT username, pwcreadate, pwcreatime
FROM DOMAIN.USERS
WHERE pwcreadate <= subdate(date,183)

● Alle Benutzer, die sich mehrfach an der Datenbankinstanz anmelden dürfen

SELECT username, usermode
FROM DOMAIN.USERS
WHERE connectmode = 'MULTIPLE'

● Name der Datenbankinstanz, auf der die aktuelle Datenbanksitzung eröffnet wurde. Name des Rechners, auf der diese Datenbankinstanz läuft.

SELECT DISTINCT serverdb, servernode
FROM DOMAIN.USERS

Aktuell aktiver Benutzer: siehe SESSIONS


VERSION (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt VERSION

Voraussetzungen

Melden Sie sich an die Datenbankinstanz DEMODB an.

Beispiele

Anhand der Systemtabelle VERSION können Sie unter anderem folgende Datenbankinformationen ermitteln:

· Version der Software, mit der die aktuell genutzte Datenbankinstanz läuft

SELECT MAJORVERSION, MINORVERSION, CORRECTIONLEVEL, BUILD
FROM SYSINFO.VERSION

· Version des Betriebssystems

SELECT OPERATINGSYSTEM
FROM SYSINFO.VERSION

· Kernvariante

SELECT KERNELVARIANT
FROM SYSINFO.VERSION


VIEWCOLUMNS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt VIEWCOLUMNS

Vorausetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren Sie View-Tabellen. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink View-Tabellen beschrieben.

Beispiele

Anhand der Systemtabelle VIEWCOLUMNS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● Alle Tabellen, die der View-Tabelle CUSTOMER_ADDR zugrunde liegen

SELECT tablename, viewcolumnname, columnname
FROM DOMAIN.VIEWCOLUMNS
WHERE schemaname = 'HOTEL'
AND viewname = 'CUSTOMER_ADDR'

● Spalte der Tabelle, die der Spalte CITY der View-Tabelle CUSTOMER_ADDR zugrunde liegt

SELECT tablename, columnname
FROM DOMAIN.VIEWCOLUMNS
WHERE schemaname = 'HOTEL'
AND viewname = 'CUSTOMER_ADDR'
AND viewcolumnname = 'CITY'

● Ermitteln, ob die Spalte TITLE der Tabelle CUSTOMER in einer View-Tabelle verwendet wird

SELECT schemaname, viewname, viewcolumnname
FROM DOMAIN.VIEWCOLUMNS
WHERE tablename = 'CUSTOMER'
AND columnname = 'TITLE'

Alle View-Tabellen: siehe VIEWS

Definition einer View-Tabelle: siehe VIEWDEFS

Existenz einer View-Tabelle: siehe TABLES


VIEWDEFS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt VIEWDEFS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Legen Sie View-Tabellen an. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink View-Tabellen angegeben.

Beispiele

Anhand der Systemtabelle VIEWDEFS können Sie unter anderem folgende Datenbankinformationen ermitteln:

● SQL-Anweisungstext, der bei der Definition der View-Tabelle verwendet wurde

SELECT definition
FROM DOMAIN.VIEWDEFS
WHERE schemaname = 'HOTEL'
AND viewname = 'CUSTOMER_ADDR'

● Länge der Definition der View-Tabelle

SELECT len
FROM DOMAIN.VIEWDEFS
WHERE schemaname = 'HOTEL'
AND viewname = 'CUSTOMER_ADDR'

Nur der Eigentümer einer View-Tabelle kann die Definition selektieren. Alle anderen Benutzer erhalten keine Ausgabe.

Alle View-Tabellen: siehe VIEWS

Existenz einer View-Tabelle: siehe TABLES

Einer View-Tabelle zugrunde liegende Tabellen und Spalten: siehe VIEWCOLUMNS


VIEWS (SAP-Bibliothek - Grundwissen)

Diese Grafik wird im zugehörigen Text erklärt VIEWS

Voraussetzungen

Sie haben die Strukturlink Demo-Daten für das SQL-Tutorial erzeugt.

Melden Sie sich als Benutzer MONA an die Demo-Datenbankinstanz DEMODB an.

Definieren Sie View-Tabellen. Verfahren Sie dazu z.B. wie in SQL-Tutorial, Strukturlink View-Tabellen beschrieben.

Beispiele

Anhand der Systemtabelle VIEWS können Sie anderem folgende Datenbankinformationen ermitteln:

● Alle Privilegien der View-Tabelle CUSTOMER_ADDR

SELECT privileges
FROM DOMAIN.VIEWS
WHERE schemaname = 'HOTEL'
AND viewname = 'CUSTOMER_ADDR'

● Alle View-Tabellen mit ihren Kommentaren, die der aktuelle Benutzer sehen kann, ohne Eigentümer zu sein

SELECT schemaname, viewname, comment
FROM DOMAIN.VIEWS
WHERE owner <> 'MONA'

Definitionstext einer View-Tabelle: siehe VIEWDEFS

Existenz einer View-Tabelle: siehe TABLES

Synonym für eine View-Tabelle: siehe SYNONYMS

Einer View-Tabelle zugrunde liegende Tabellen und Spalten: siehe VIEWCOLUMNS


Definitionen der Systemtabellen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Definitionen der Systemtabellen

Systemtabellen mit Informationen zu Datenbankobjekten

Im Datenbanksystem gibt es eine Reihe von Systemtabellen, die Informationen über die Datenbankobjekte und deren Verbindungen untereinander enthalten. Diese Systemtabellen stehen in jedem SQL-Modus im Schema DOMAIN zur Verfügung. Die Angabe des Schemas ist beim Zugriff auf diese Tabellen in jedem von INTERNAL verschiedenen SQL-Modus erforderlich.

Definitionen der wichtigsten DOMAIN-Systemtabellen:

COLUMNS | CONNECTEDUSERS | CONNECTPARAMETERS
CONSTRAINTCOLUMNS | CONSTRAINTS | DBPROCEDURES
DBPROCPARAMS | DOMAINCONSTRAINTS | DOMAINS
FOREIGNKEYCOLUMNS | FOREIGNKEYS | FUNCTIONS
INDEXCOLUMNS | INDEXES | LOCKS
LOCK_WAITS | MAPCHARSETS | PACKAGES
ROLEPRIVILEGES | ROLES | SCHEMAPRIVILEGES
SCHEMAS | SEQUENCEPRIVILEGES | SEQUENCES
SESSION_ROLES | SYNONYMS | SYSTEMTRIGGERS
TABLEPRIVILEGES | TABLES | TRIGGERS
USERS | VERSIONS | VIEWCOLUMNS
VIEWDEFS | VIEWS | VIEWTABLES

Systemtabellen mit Informationen zu Datenbankzuständen

Im Datenbanksystem gibt es eine Reihe von Systemtabellen, die Informationen über die Systemkonfiguration und -auslastung enthalten. Diese Systemtabellen stehen in jedem SQL-Modus im Schema SYSINFO zur Verfügung. Die Angabe des Schemas ist beim Zugriff auf diese Tabellen nicht erforderlich.

Definitionen der wichtigsten SYSINFO-Systemtabellen:

ACTIVECONFIGURATION | BACKUPTHREADS | CACHESTATISTICS
CATALOGCACHESTATISTICS | COMMANDCACHESTATISTICS | COMMANDCACHESTATISTICSRESET
COMMANDSTATISTICS | COMMANDSTATISTICSRESET | CONSISTENTVIEWS
DATACACHE | DATASTATISTICS | DATASTATISTICSRESET
DATAVOLUMES | DATASTATISTICSRESET | FILEDIRECTORIES
FILES | HOTSTANDBYCOMPONENT | HOTSTANDBYGROUP
INSTANCE | IOBUFFERCACHES | IOTHREADSTATISTICS
IOTHREADSTATISTICSRESET | INDEXSIZE | INDEXSTORAGEDETAILS
LOGINFORMATION | LOGQUEUESTATISTICS | LOGQUEUESTATISTICSRESET
LOGSTATISTICS | LOGSTATISTICSRESET | LOGVOLUMES
MACHINECONFIGURATION | MACHINEUTILIZATION | MEMORYALLOCATORSTATISTICS
OPTIMIZERINFORMATION | READERWRITERLOCKINFORMATION | READERWRITERLOCKSTATISTICS
READERWRITERLOCKSTATISTICSRESET | READERWRITERLOCKWAITINGTASKS | REGIONINFORMATION
REGIONSTATISTICS | REGIONSTATISTICSRESET | RESTARTINFORMATION
SCHEMASIZE | SERVERTASKS | SESSIONS
SNAPSHOTS | SPINLOCKPOOLSTATISTICS | SPINLOCKPOOLSTATISTICSRESET
SPINLOCKSTATISTICS | SPINLOCKSTATISTICSRESET | TABLESIZE
TABLESTORAGEDETAILS | TASKGROUPSTATISTICS | TASKGROUPSTATISTICSRESET
TASKLOADBALANCINGINFORMATION | TASKLOADBALANCINGTASKGROUPSTATES | TASKLOADBALANCINGTASKMOVES
TRANSACTIONHISTORY | TRANSACTIONS | UNLOADEDSTATEMENTS
VERSION |  |

Statistik-Systemtabellen

Im Datenbanksystem gibt es eine Reihe von Systemtabellen, mit deren Hilfe sich Informationen über die Konfiguration, Strukturen und Größen von Datenbankobjekten selektieren lassen. Diese Statistik-Systemtabellen stehen im Schema des Datenbanksystemadministrators (SYSDBA-Benutzer) zur Verfügung. Die Angabe des Schemas ist beim Zugriff auf diese Tabellen nicht erforderlich.

Statistik-Systemtabellen

DBPARAMETERS | INDEXSTATISTICS | LOCKLISTSTATISTICS
OPTIMIZERSTATISTICS | SERVERDBSTATISTICS | SYSUPDATECOUNTERWANTED
SYSUPDSTATWANTED | TABLESTATISTICS | TRANSACTIONS
USERSTATISTICS |  |

Monitor-Systemtabellen

Im Datenbanksystem gibt es eine Reihe von Systemtabellen, mit deren Hilfe sich Monitor-Informationen abrufen lassen. Diese Monitor-Systemtabellen stehen im Schema des Datenbanksystemadministrators (SYSDBA-Benutzer) zur Verfügung. Die Angabe des Schemas ist beim Zugriff auf diese Tabellen nicht erforderlich.

Die Monitor-Systemtabellen liefern für den Datenbanksystemadministrator (SYSDBA-Benutzer) und für alle Benutzer der Datenbankbenutzerklasse Datenbankadministrator (DBA-Benutzer) Ergebnisse. Nicht berechtigte Benutzer erhalten die Fehlermeldung 100 – Zeile nicht gefunden.

Die Monitor-Systemtabellen besitzen folgende Struktur:

DESCRIPTION | CHAR(40)
VALUE | FIXED(20)

Jede Zeile enthält einen Zählerwert, dessen Bedeutung jeweils dem Spaltenwert von DESCRIPTION entnommen werden kann.

Monitor-Systemtabellen

MONITOR | MONITOR_CACHES | MONITOR_LOAD
MONITOR_LOCK | MONITOR_LOG | MONITOR_LONG
MONITOR_PAGES | MONITOR_REWRITE | MONITOR_ROW
MONITOR_TRANS |  |

Loader-Systemtabellen

Im Datenbanksystem gibt es eine Reihe von Strukturlink Systemtabellen, die vom Strukturlink Loader verwendet werden. Diese Loader-Systemtabellen stehen im SYSLOADER-Schema zur Verfügung. Die Angabe des Schemas SYSLOADER ist beim Zugriff auf diese Tabellen erforderlich.

Loader-Systemtabellen

CODEPAGE | Strukturlink MAPSCHEMANAMES | TRANSFORMATIONMODEL
TRANSFORMATIONMONITOR | TRANSFORMATIONPACKAGES | TRANSFORMATIONRESOURCES
TRANSFORMATIONSTATISTICS | TRANSFORMATIONSTEPS |

Upgrade-Systemtabellen

Die Upgrade-Systemtabellen stehen im Schema des Datenbanksystemadministrators (SYSDBA-Benutzer) zur Verfügung.

Die Upgrade-Systemtabellen sind nur für den Datenbanksystemadministrator (SYSDBA-Benutzer) sichtbar.

Upgrade-Systemtabellen

POSTUPGRADECHECKLIST | POSTUPGRADECHECKLIST<version> | POSTUPGRADECHECKLISTUNICODE
SYSUPGRADEHISTORY |  |


ACTIVECONFIGURATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation ACTIVECONFIGURATION

Definition

Die Systemtabelle ACTIVECONFIGURATION enthält die Namen und Werte der aktuell gültigen Datenbankparameter.

Struktur

ACTIVECONFIGURATION

PARAMETERNAME | CHAR(32) | Name des Datenbankparameters
PERMANENT | CHAR(3) | Angabe, ob der Wert des Datenbankparameters nach einem Wechsel in den Betriebszustand OFFLINE weiterhin gilt (YES | NO)
CHANGEABLE | CHAR(10) | Angabe, ob der Wert des Datenbankparameters im Betriebszustand ONLINE änderbar ist und nach seiner Änderung sofort wirksam wird (YES | NO)
VALUE | CHAR(256) | Wert des Datenbankparameters

Siehe auch:

Systemtabellen auswerten, ACTIVECONFIGURATION

Konzepte des Datenbanksystems, Datenbankparameter


BACKUPTHREADS (SAP-Bibliothek - Grundwissen)

Objektdokumentation BACKUPTHREADS

Definition

Die Systemtabelle BACKUPTHREADS enthält Informationen über I/O-Vorgänge der zuletzt oder aktuell durchgeführten Sicherung.

Struktur

BACKUPTHREADS

THREADID | FIXED(10) | Identifikation des Thread im Betriebssystem
THREADNAME | CHAR(16) | Name des Thread
IODIRECTION | CHAR(6) | I/O-Typ (READ | WRITE)
IOCOUNT | FIXED(20) | Anzahl der I/O-Vorgänge
IOPAGECOUNT | FIXED(20) | Anzahl der Seiten, die während des I/O-Vorgangs gelesen/geschrieben wurden
IOTIME | FIXED(20) | Gesamtzeit der I/O-Vorgänge mit aktiver Zeitmessung (µs)
IOTIMEMEASUREMENTCOUNT | FIXED(20) | Anzahl der vermessenen I/O-Vorgänge
PENDINGIOCOUNT | FIXED(5) | Anzahl der nicht unmittelbar ausführbaren (pending) I/O-Aufrufe
MAXPENDINGIOCOUNT | FIXED(5) | Maximale Anzahl I/O-Aufrufe, die nicht unmittelbar ausführbar waren
PATH | CHAR(256) | Name des Datenträgers, auf dem die I/O-Aufrufe durchgeführt werden


CACHESTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CACHESTATISTICS

Definition

Die Systemtabelle CACHESTATISTICS enthält Angaben über Zugriffe auf Caches seit dem letzten Start der Datenbankinstanz.

Struktur

CACHESTATISTICS

SESSIONID | FIXED(10) | Identifikation der Datenbanksitzung, falls der entsprechende Cache sitzungsspezifisch ist, andernfalls NULL-Wert
NAME | CHAR(20) | Name des Cache
ACCESSCOUNT | FIXED(20) | Anzahl der Zugriffe auf den Cache
SUCCESSFULACCESSCOUNT | FIXED(20) | Anzahl erfolgreicher Zugriffe auf den Cache
UNSUCCESSFULACCESSCOUNT | FIXED(20) | Anzahl erfolgloser Zugriffe auf den Cache
HITRATE | FIXED(3) | Prozentsatz erfolgreicher Zugriffe auf den Cache (%)

Siehe auch:

Systemtabellen auswerten, CACHESTATISTICS


CATALOGCACHESTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CATALOGCACHESTATISTICS

Definition

Die Systemtabelle CATALOGCACHESTATISTICS enthält Angaben über Aktionen und den aktuellen Zustand des Catalog-Cache seit dem Start des Datenbanksystems.

Struktur

CATALOGCACHESTATISTICS

RELEASEMEMORYCOUNT | FIXED(20) | Anzahl der wegen Speichermangels aus dem Catalog-Cache entfernten Objekte
ENTRYCOUNT | FIXED(10) | Anzahl der Objekte, die sich momentan im Catalog-Cache befinden
MAXENTRYCOUNT | FIXED(10) | Anzahl der Objekte, die sich maximal im Catalog-Cache befanden
ENTERLRU | FIXED(20) | Anzahl der Einfügeoperationen in die LRU-Liste
REMOVELRU | FIXED(20) | Anzahl der Löschoperationen aus der LRU-Liste
INVALIDATECOUNT | FIXED(10) | Anzahl der Objekte, die als ungültig markiert wurden
LRUENTRYCOUNT | FIXED(10) | Anzahl der momentan in der LRU-Liste gespeicherten Einträge
INVALIDHANDLECOUNT | FIXED(10) | Anzahl der momentan im Catalog-Cache befindlichen Objekte, die als ungültig markiert sind

Siehe auch:

Glossar, Catalog-Cache


CLASSCONTAINER_CHAINS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CLASSCONTAINER_CHAINS

Definition

Die Systemtabelle CLASSCONTAINER_CHAINS liefert Statistiken pro Datei bzw. Container, in denen OMS-Objekte gespeichert werden.

Struktur

CLASSCONTAINER_CHAINS

CLASS_ID | CHAR(8) BYTE | Identifikation der Container-Datei
SEQUELCONTAINER | FIXED(10) | Index der Fortsetzungscontainer-Datei für Objekte variabler Länge (0 sonst)
CHAIN_ID | FIXED(10) | Nicht mehr genutzt (immer 1)
SUBROOT | FIXED(10) | Nicht mehr genutzt (immer Root der Datei)
OBJECTCOUNT | FIXED(10) | Anzahl der belegten Objektrahmen
PAGECOUNT | FIXED(10) | Anzahl der Seiten
ACTIVE_GC_TASKID | FIXED(10) | Nicht mehr genutzt (immer 0)
RELEASEEMPTYPAGES | CHAR(3) | Nicht mehr genutzt (immer NULL)

Siehe auch:

Datenbankverwaltung im CCMS, Strukturlink Klassencontainer


CLASSCONTAINER_KEYS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CLASSCONTAINER_KEYS

Definition

Die Systemtabelle CLASSCONTAINER_KEYSliefert die Wurzel (Root) der Invertierungsdateien für OMS-Objekte mit Schlüssel.

Struktur

CLASSCONTAINER_KEYS

CLASS_ID | CHAR(8) BYTE | Identifikation der Container-Datei
KEY_PARTITION | FIXED(10) | Index der Schlüsselinvertierung
KEY_ROOT | FIXED(10) | Root der Invertierungsdatei

Siehe auch:

Datenbankverwaltung im CCMS, Strukturlink Klassencontainer


CLASSCONTAINER_ROOTS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CLASSCONTAINER_ROOTS

Definition

Die Systemtabelle CLASSCONTAINER_ROOTSbeschreibt die Dateien bzw. Container, in denen OMS-Objekte gespeichert werden.

Struktur

CLASSCONTAINER_ROOTS

CLASS_ID | CHAR(8) BYTE | Identifikation der Container-Datei
SEQUELCONTAINER | FIXED(10) | Index der Fortsetzungscontainer-Datei für Objekte variabler Länge (0 sonst )
ROOT | FIXED(10) | Root der Container-Datei
KEY_PARTITIONCOUNT | FIXED(10) | Anzahl der Invertierungen für persistente Objekte mit Schlüssel (0 sonst )
VAROBJ_CONTAINER | CHAR(3) | Container enthält variabel lange Objekte (YES | NO)
DELETED | CHAR(3) | Anwendung hat den Container gelöscht, aber das physikalische Löschen durch die Garbage-Collectors steht noch aus
MAX_OBJBODYSIZE | FIXED(10) | Maximale Objektgrösse für Objekte, die in diesem Container gespeichert werden können
MAX_OBJPERPAGE | FIXED(10) | Maximale Anzahl von persistenten Objekten, die in eine Seite passen
MAX_CHAINS | FIXED(10) | nicht mehr genutzt (immer 1)
UNUSED_BYTEPERPAGE | FIXED(10) | Anzahl der Bytes Verschnitt auf jeder Seite der Container-Datei

Siehe auch:

Datenbankverwaltung im CCMS, Strukturlink Klassencontainer


CLASSCONTAINERS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CLASSCONTAINERS

Definition

Die Systemtabelle CLASSCONTAINERS beschreibt die Dateien bzw. Container, in denen OMS-Objekte gespeichert werden.

Struktur

CLASSCONTAINERS

GUID | CHAR(16) BYTE | Identifikation der C++ Klasse, deren Objekte im Container abgelegt sind
CLASS_NAME | CHAR(64) | Name der C++ Klasse, deren Objekte im Container abgelegt sind
SCHEMANAME | CHAR(32) | Name des Schemas, dem der Container angehört
CONTAINERNO | FIXED(10) | Benutzerdefinierte Nummer des Containers
CLASS_ID | CHAR(8) BYTE | Identifikation des Containers
SIZE | FIXED(5) | Definitionslänge der in diesem Container gespeicherten Objekte, wenn sie nicht variabel lang sind (Bytes)
PAGECOUNT | FIXED(10) | Größe des Containers (Seiten)
FREE_PAGES | FIXED(10) | Anzahl nicht komplett gefüllter Seiten
EMPTY_PAGES | FIXED(10) | Ohne Bedeutung
KEY_LEAF_PAGES | FIXED(10) | Anzahl der Blätter des Indexbaumes bei Containern, die Schlüsselzugriffe unterstützten
OBJECTS_PER_PAGES | FIXED(10) | NULL (ohne Bedeutung)
GARBAGEOBJCHECKED | FIXED(10) | NULL (ohne Bedeutung)
GARBAGEOBJRELEASED | FIXED(10) | NULL (ohne Bedeutung)
OCCUPANCY | FIXED(10) | Füllgrad des Containers (%)
FREE_EOT_PAGES | FIXED(10) | NULL (ohne Bedeutung)

Siehe auch:

Datenbankverwaltung im CCMS, Strukturlink Klassencontainer


CODEPAGE (SAP-Bibliothek - Werkzeuge)

Objektdokumentation CODEPAGE

Definition

Die Systemtabelle CODEPAGE enthält die vom Loader für die Konvertierung genutzten Konvertierungstabellen.

Struktur

CODEPAGE

CODEPAGEID | CHAR(32) | Name der Code-Page (z.B. ISO-8859-2)
CODEPAGETABLE | CHAR(512) BYTE | Konvertierungstabelle von ASCII nach UCS2 für die jeweilige Code-Page

Die Systemtabelle CODEPAGE wird vorkonfiguriert. Die Spalte CODEPAGE enthält 27 Einträge bei Ihrer Auslieferung:

ISO-8859-2, ISO-8859-3, ISO-8859-4, ISO-8859-5, ISO-8859-6, ISO-8859-7, ISO-8859-8, ISO-8859-9, ISO-8859-10, ISO-8859-11, ISO-8859-13, ISO-8859-14, ISO-8859-15, ISO-8859-16, WINDOWS-874, WINDOWS-932, WINDOWS-936, WINDOWS-949, WINDOWS-950, WINDOWS-1250, WINDOWS-1251, WINDOWS-1252, WINDOWS-1253, WINDOWS-1254, WINDOWS-1255, WINDOWS-1256, WINDOWS-1257.

Der Vorschlagswert des Loader, die Code-Page ISO-8859-1, ist nicht in der Tabelle enthalten.

Erläuterung

Die Systemtabelle CODEPAGE kann nur vom Datenbanksystemadministrator geändert werden. Wenn ein anderer Datenbankbenutzer versucht, die Tabelle zu verändern, wird der Vorgang vom Loader mit folgendem Fehler abgebrochen: -25251: Code page to set (<code_page_name>) not found in system table SYSLOADER.CODEPAGE. The privilege to change the content of this table is restricted to SYSDBA.

Alle Datenbankbenutzer können lesend auf die Einträge der Tabelle CODEPAGE zugreifen.

Siehe auch:

Loader, SET-Kommando

weitere Systemtabellen

Konzepte des Datenbanksystems, Strukturlink Benutzer, Authentifizierung und Berechtigungen


COLUMNS (SAP-Bibliothek - Grundwissen)

Objektdokumentation COLUMNS

Definition

Die Systemtabelle COLUMNS enthält die Spalten aller Tabellen, View-Tabellen, Ergebnistabellen und Synonyme, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

COLUMNS

SCHEMANAME | CHAR(32) | Name des Schemas des Datenbankobjekts
OWNER | CHAR(32) | Name des Eigentümers des Datenbankobjekts
TABLENAME | CHAR(32) | Name des Datenbankobjekts
COLUMNNAME | CHAR(32) | Name der Spalte
MODE | CHAR(3) | Art der Spalte (KEY | MAN | OPT)
DATATYPE | CHAR(10) | Datentyp der Spalte (BOOLEAN | CHAR | DATE | FIXED | FLOAT | INTEGER | LONG | SMALLINT | TIME | TIMESTAMP)
CODETYPE | CHAR(8) | Codeattribut der Spalte (ASCII | BYTE | UNICODE)
LEN | FIXED(4) | Länge bzw. Genauigkeit der Spalte
DEC | FIXED(3) | Anzahl der Nachkommastellen bei den Spalten vom Datentyp FIXED
NULLABLE | CHAR(3) | Spalte kann NULL-Wert annehmen (YES | NO)
COLUMNPRIVILEGES | CHAR(8) | Privilegien des aktuellen Benutzers für die Spalte
DEFAULT | CHAR(254) | Vorschlagswert (DEFAULT) für die Spalte
DEFAULTFUNCTION | CHAR(12) | Name, wenn der DEFAULT-Wert eine der folgenden Spezifikationen von Werten ist: NULL | USER | USERGROUP | SYSDBA | UID | DATE | TIME | TIMESTAMP | UTCDATE | TIMEZONE | UTCDIFF | TRUE | FALSE | TRANSACTION andernfalls NULL-Wert
DOMAINOWNER | CHAR(32) | Name des Eigentümers des Wertebereichs, der für die Spaltendefinition verwendet wurde
DOMAINNAME | CHAR(32) | Name des Wertebereichs, der für die Spaltendefinition verwendet wurde
POS | FIXED(4) | Originalposition der Spalte in der Tabelle
KEYPOS | FIXED(4) | Originalposition der Schlüsselspalte in der Tabelle
PHYSICALPOS | FIXED(4) | Position der Spalte auf Platte
CREATEDATE | DATE(10) | Erzeugungsdatum der Spalte
CREATETIME | TIME(8) | Erzeugungszeit der Spalte
ALTERDATE | DATE(10) | Änderungsdatum der Spalte
ALTERTIME | TIME(8) | Änderungszeit der Spalte
TABLETYPE | CHAR(8) | Typ der Tabelle (TABLE | VIEW | SYNONYM | RESULT | SYSTEM)
COMMENT | LONG | Kommentar zu der Spalte

Siehe auch:

Systemtabellen auswerten, COLUMNS

SQL-Referenzhandbuch, Datentyp (data_type)


COMMANDCACHESTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation COMMANDCACHESTATISTICS

Definition

Die Systemtabelle COMMANDCACHESTATISTICS enthält die seit dem letzten Start der Datenbankinstanz gesammelten statistischen Angaben über Aktivitäten des Kommando-Cache. Der Kommando-Cache enthält die von verschiedenen Datenbanksitzungen gemeinsam genutzten SQL-Anweisungen und deren Ausführungspläne (SQL-Anweisung und Ausführungsplan gemeinsam werden im folgenden kurz Kommando genannt).

Struktur

COMMANDCACHESTATISTICS

USABLESIZE | FIXED(10) | Größe des Kommando-Cache (KB)
USEDSIZE | FIXED(10) | Tatsächlich belegter Bereich des Kommando-Cache (KB)
USEDSIZEPERCENTAGE | FIXED(3) | Tatsächlich belegter Bereich des Kommando-Cache (%)
MAXUSEDSIZE | FIXED(10) | Maximal belegter Bereich des Kommando-Cache (KB)
MAXUSEDSIZEPERCENTAGE | FIXED(3) | Maximal belegter Bereich des Kommando-Cache (%)
COMMANDCOUNT | FIXED(10) | Anzahl der gespeicherten Kommandos
MAXCOMMANDCOUNT | FIXED(10) | Maximale Anzahl gespeicherter Kommandos
INSERTCOMMANDCOUNT | FIXED(10) | Anzahl der Einfügungen
DELETECOMMANDCOUNT | FIXED(10) | Anzahl der Löschungen
FAILEDALLOCATECOUNT | FIXED(10) | Anzahl nicht erfüllbarer Speicheranforderungen
CLEANUPCOUNT | FIXED(10) | Anzahl der Operationen, die auf Platzmangel im Hauptspeicher stießen
CLEANUPCOMMANDCOUNT | FIXED(10) | Anzahl geänderter Kommandos aufgrund des Platzmangels im Hauptspeicher
INVALIDATECOUNT | FIXED(10) | Anzahl der Anweisungen zur Datendefinition, die zur Ungültigkeit von Ausführungsplänen führten
CURRENTUNLOADSTATEMENTCOUNT | FIXED(10) | Anzahl der zur Zeit auf Platte verdrängten SQL-Anweisungen
UNLOADSTATEMENTCOUNT | FIXED(10) | Anzahl der auf Platte verdrängten SQL-Anweisungen
RELOADSTATEMENTCOUNT | FIXED(10) | Anzahl der in den Hauptspeicher zurückgeladenen SQL-Anweisungen
DELETEPLANCOUNT | FIXED(10) | Anzahl gelöschter Ausführungspläne aufgrund des Platzmangels im Hauptspeicher
HASHTABLESLOTCOUNT | FIXED(5) | Anzahl der Slots in der Hash-Tabelle
USEDHASHTABLESLOTCOUNT | FIXED(5) | Anzahl genutzter Slots in der Hash-Tabelle
MAXUSEDHASHTABLESLOTCOUNT | FIXED(5) | Maximale Anzahl genutzter Slots in der Hash-Tabelle
AVGHASHTABLECHAINENTRYCOUNT | FIXED(5) | Durchschnittliche Länge der Überlaufketten
MAXHASHTABLECHAINENTRYCOUNT | FIXED(5) | Maximale Länge der Überlaufketten

Siehe auch:

COMMANDCACHESTATISTICSRESET


COMMANDCACHESTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation COMMANDCACHESTATISTICSRESET

Definition

Die Systemtabelle COMMANDCACHESTATISTICSRESET enthält die seit dem letzten RESET COMMANDCACHESTATISTICS oder RESET ALL gesammelten statistischen Angaben über Aktivitäten des Kommando-Cache. Der Kommando-Cache enthält die von verschiedenen Datenbanksitzungen gemeinsam genutzten SQL-Anweisungen und deren Ausführungspläne (SQL-Anweisung und Ausführungsplan gemeinsam werden im folgenden kurz Kommando genannt).

Struktur

COMMANDCACHESTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzen RESET für diese Angaben
USABLESIZE | FIXED(10) | Größe des Kommando-Cache (KB)
MAXUSEDSIZE | FIXED(10) | Maximal belegter Bereich des Kommando-Cache (KB)
MAXUSEDSIZEPERCENTAGE | FIXED(3) | Maximal belegter Bereich des Kommando-Cache (%)
MAXCOMMANDCOUNT | FIXED(10) | Maximale Anzahl gespeicherter Kommandos
INSERTCOMMANDCOUNT | FIXED(10) | Anzahl der Einfügungen
DELETECOMMANDCOUNT | FIXED(10) | Anzahl der Löschungen
FAILEDALLOCATECOUNT | FIXED(10) | Anzahl nicht erfüllbarer Speicheranforderungen
CLEANUPCOUNT | FIXED(10) | Anzahl der Operationen, die auf Platzmangel im Hauptspeicher stießen
CLEANUPCOMMANDCOUNT | FIXED(10) | Anzahl geänderter Kommandos aufgrund des Platzmangels im Hauptspeicher
INVALIDATECOUNT | FIXED(10) | Anzahl der Anweisungen zur Datendefinition, die zur Ungültigkeit von Ausführungsplänen führten
UNLOADSTATEMENTCOUNT | FIXED(10) | Anzahl der auf Platte verdrängten SQL-Anweisungen
RELOADSTATEMENTCOUNT | FIXED(10) | Anzahl der in den Hauptspeicher zurückgeladenen SQL-Anweisungen
DELETEPLANCOUNT | FIXED(10) | Anzahl gelöschter Ausführungspläne aufgrund des Platzmangels im Hauptspeicher
MAXUSEDHASHTABLESLOTCOUNT | FIXED(5) | Maximale Anzahl genutzter Slots in der Hash-Tabelle
MAXHASHTABLECHAINENTRYCOUNT | FIXED(5) | Maximale Länge der Überlaufketten

Siehe auch:

COMMANDCACHESTATISTICS


COMMANDSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation COMMANDSTATISTICS

Definition

Die Systemtabelle COMMANDSTATISTICS beschreibt SQL-Anweisungen, die im Kommando-Cache gespeichert sind und enthält die seit dem letzten Start der Datenbankinstanz gesammelten statistischen Angaben über Aktivitäten dieser SQL-Anweisungen. Der Kommando-Cache enthält die von verschiedenen Datenbanksitzungen gemeinsam genutzten SQL-Anweisungen und deren Ausführungspläne.

Struktur

COMMANDSTATISTICS

COMMANDID | CHAR(8) BYTE | Identifikation der SQL-Anweisung
INTERNAL | CHAR(3) | SQL-Anweisung wurde implizit erzeugt (YES | NO)
HASHVALUE | FIXED(10) | Hash-Wert
HASHTABLESLOT | FIXED(5) | Slot in der Hash-Tabelle
STATUS | CHAR(10) | Status (PREPARING | PREPARED | INVALID)
USERNAME | CHAR(32) | Name des Datenbankbenutzers
SCHEMANAME | CHAR(32) | Aktuelles Schema zum Zeitpunkt der Erstellung des Ausführungsplanes
SQLMODE | CHAR(8) | SQL-Modus zum Zeitpunkt der Erstellung des Ausführungsplanes
ISOLATIONLEVEL | FIXED(3) | Isolation-Level zum Zeitpunkt der Erstellung des Ausführungsplanes
DATEFORMAT | CHAR(50) | Datums- und Zeitformat zum Zeitpunkt der Erstellung des Ausführungsplanes
MASSCOMMAND | CHAR(3) | Datums- und Zeitformat zum Zeitpunkt der Erstellung des Ausführungsplanes
STATEMENTCODETYPE | CHAR(15) | Codeattribut der SQL-Anweisung (ASCII | UNICODE | UNICODE SWAP)
QUERYREWRITE | CHAR(10) | Angabe, ob und welche Art des Query-Rewrites stattgefunden hat (NO | STATEMENT | OPERATOR)
STATEMENTSIZE | FIXED(10) | Länge der SQL-Anweisung (Bytes)
STATEMENT | LONG | SQL-Anweisung
PLANSIZE | FIXED(10) | Speicherbedarf des Ausführungsplans (Bytes)
DBPROCEDURESCHEMANAME | CHAR(32) | Schemaname der aufrufenden Datenbankprozedur
DBPROCEDURENAME | CHAR(32) | Name der aufrufenden Datenbankprozedur
PREPARECOUNT | FIXED(10) | Anzahl der Ausführungsvorbereitungen
REFERENCECOUNT | FIXED(5) | Anzahl der Datenbanksitzungen, für die die SQL-Anweisung zur Ausführung vorbereitet ist
CURRENTEXECUTECOUNT | FIXED(5) | Aktuelle Anzahl der Ausführungen
EXECUTECOUNT | FIXED(10) | Anzahl der Ausführungen
PREPARETIME | FIXED(20) | Zeit zum Parsen (ms)
EXECUTETIME | FIXED(20) | Gesamtzeit der Ausführungen (ms)
AVGEXECUTETIME | FIXED(20) | Durchschnittliche Ausführungszeit (ms)
MINEXECUTETIME | FIXED(20) | Minimale Ausführungszeit (ms)
MAXEXECUTETIME | FIXED(20) | Maximale Ausführungszeit (ms)
READROWCOUNT | FIXED(20) | Anzahl gelesener Zeilen
QUALIFIEDROWCOUNT | FIXED(20) | Anzahl qualifizierter Zeilen
VIRTUALREADCOUNT | FIXED(20) | Anzahl der Lesevorgänge im Data-Cache
PHYSICALREADCOUNT | FIXED(20) | Anzahl der Lesevorgänge im Data-Cache, die Lesevorgänge auf der Platte auslösten
FETCHROWCOUNT | FIXED(20) | Anzahl der Zeilen der durch die SQL-Anweisung erzeugten Ergebnistabellen, die an die Anwendung geliefert wurden
SUSPENDCOUNT | FIXED(20) | Anzahl der Suspends
WAITCOUNT | FIXED(20) | Anzahl der Wartevorgänge aufgrund von Sperrkollisionen

Siehe auch:

COMMANDSTATISTICSRESET


COMMANDSTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation COMMANDSTATISTICSRESET

Definition

Die Systemtabelle COMMANDSTATISTICSRESET beschreibt SQL-Anweisungen, die im Kommando-Cache gespeichert sind und enthält die seit dem letzten RESET COMMANDSTATISTICS oder RESET ALL gesammelten statistischen Angaben über Aktivitäten dieser SQL-Anweisungen. Der Kommando-Cache enthält die von verschiedenen Datenbanksitzungen gemeinsam genutzten SQL-Anweisungen und deren Ausführungspläne.

Struktur

COMMANDSTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
COMMANDID | CHAR(8) BYTE | Identifikation der SQL-Anweisung
PREPARECOUNT | FIXED(10) | Anzahl der Ausführungsvorbereitungen
EXECUTECOUNT | FIXED(10) | Anzahl der Ausführungen
EXECUTETIME | FIXED(20) | Gesamtzeit der Ausführungen (ms)
AVGEXECUTETIME | FIXED(20) | Durchschnittliche Ausführungszeit (ms)
MINEXECUTETIME | FIXED(20) | Minimale Ausführungszeit (ms)
MAXEXECUTETIME | FIXED(20) | Maximale Ausführungszeit (ms)
READROWCOUNT | FIXED(20) | Anzahl gelesener Zeilen
QUALIFIEDROWCOUNT | FIXED(20) | Anzahl qualifizierter Zeilen
VIRTUALREADCOUNT | FIXED(20) | Anzahl der Lesevorgänge im Data-Cache
PHYSICALREADCOUNT | FIXED(20) | Anzahl der Lesevorgänge im Data-Cache, die Lesevorgänge auf der Platte auslösten
FETCHROWCOUNT | FIXED(20) | Anzahl der Zeilen der durch die SQL-Anweisung erzeugten Ergebnistabellen, die an die Anwendung geliefert wurden
SUSPENDCOUNT | FIXED(20) | Anzahl der Suspends
WAITCOUNT | FIXED(20) | Anzahl der Wartevorgänge aufgrund von Sperrkollisionen

Siehe auch:

COMMANDSTATISTICS


CONNECTEDUSERS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CONNECTEDUSERS

Definition

Die Systemtabelle CONNECTEDUSERS enthält alle angemeldeten Datenbankbenutzer.

Struktur

CONNECTEDUSERS

USERNAME | CHAR(32) | Name des Benutzers
TERMID | CHAR(18) | Terminal-Identifikation
SESSION | FIXED(10) | Datenbanksitzung
CATALOG_CACHE_SIZE | FIXED(10) | Größe des Cache für Kataloginformationen dieser Datenbanksitzung (in Seiten)

Die Systemtabelle CONNECTEDUSERS existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle der Systemtabelle CONNECTEDUSERS die Systemtabelle SESSIONS.

Siehe auch:

Systemtabellen auswerten, SESSIONS

Konzepte des Datenbanksystems, Datenbankbenutzer


CONNECTPARAMETERS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CONNECTPARAMETERS

Definition

Die Systemtabelle CONNECTPARAMETERS enthält Informationen über sitzungsspezifische Parameter.

Struktur

CONNECTPARAMETERS

SQLMODE | CHAR(8) | SQL-Modus (ANSI | DB2 | ORACLE | INTERNAL)
ISOLEVEL | FIXED(10) | Isolation-Level (0-3)
TIMEOUT | FIXED(10) | Wert für Sitzungs-Timeout
SESSION | FIXED(10) | Datenbanksitzung

Die Systemtabelle CONNECTPARAMETERS existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle der Systemtabelle CONNECTPARAMETERS die Systemtabelle SESSIONS.

Siehe auch:

Systemtabellen auswerten, SESSIONS


CONSISTENTVIEWS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CONSISTENTVIEWS

Definition

Die Systemtabelle CONSISTENTVIEWS beschreibt die aktuell genutzten konsistenten Sichten.

Struktur

CONSISTENTVIEWS

CONSISTENTVIEW | CHAR(6) BYTE | Identifikation der konsistenten Sicht
CREATORTRANSCOUNT | CHAR(20) | Identifikation der Transaktion, die die konsistente Sicht erzeugt hat
OPENTRANS | CHAR(6) BYTE | Identifikation der Transaktion, die zur Zeit der Erzeugung der konsistenten Sicht konkurrierend aktiv war
OPENDATE | TIMESTAMP | Zeitpunkt der Erzeugung der konsistenten Sicht
LASTUSED | FIXED(10) | Zeit seit der letzten Nutzung der konsistenten Sicht (s)
CANCELED | CHAR(3) | Konsistente Sicht wurde implizit aufgrund Speichermangels geschlossen (YES | NO)

Siehe auch:

Konzepte des Datenbanksystems, Beispiel: Konsistente Sicht


CONSTRAINTCOLUMNS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CONSTRAINTCOLUMNS

Definition

Die Systemtabelle CONSTRAINTCOLUMNS enthält für alle CONSTRAINT-Definitionen der Tabellen, für die der aktuelle Benutzer Privilegien besitzt, die in der CONSTRAINT-Definition angegebenen Spalten.

Struktur

CONSTRAINTCOLUMNS

SCHEMANAME | CHAR(32) | Name des Schemas
OWNER | CHAR(32) | Name des Eigentümers
TABLENAME | CHAR(32) | Name der Tabelle mit der CONSTRAINT-Definition
CONSTRAINTNAME | CHAR(32) | Name der CONSTRAINT-Definition
CONSTRAINTTYPE | CHAR(12) | Typ der CONSTRAINT-Definition (CHECK | FOREIGN KEY | KEY | UNIQUE_CONST)
COLUMNNAME | CHAR(32) | Name der Spalte
COLUMNNO | FIXED(4) | Nummer der Spalte innerhalb der Tabelle bzw. des Constraints

Siehe auch:

SQL-Referenzhandbuch, CONSTRAINT-Definition (constraint_definition)


CONSTRAINTS (SAP-Bibliothek - Grundwissen)

Objektdokumentation CONSTRAINTS

Definition

Die Systemtabelle CONSTRAINTS enthält die CONSTRAINT-Definitionen für alle Tabellen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

CONSTRAINTS

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle mit der CONSTRAINT-Definition
CONSTRAINTNAME | CHAR(32) | Name der CONSTRAINT-Definition
DEFINITION | LONG | Text der CONSTRAINT-Definition

Siehe auch:

Systemtabellen auswerten, CONSTRAINTS

SQL-Referenzhandbuch, CONSTRAINT-Definition (constraint_definition)


DATACACHE (SAP-Bibliothek - Grundwissen)

Objektdokumentation DATACACHE

Definition

Die Systemtabelle DATACACHE beschreibt die Teilbereiche des Data-Cache.

Struktur

DATACACHE

USABLESIZE | FIXED(20) | Größe des Data-Cache (KB)
USEDSIZE | FIXED(20) | Belegter Bereich des Data-Cache (KB)
MAXUSEDSIZE | FIXED(20) | Maximal belegter Bereich des Data-Cache (KB)
OMSDATASIZE | FIXED(20) | Größe des Bereichs des Data-Cache, der zur Speicherung der OMS-Daten genutzt wird (KB)
OMSUNLOADEDVERSIONSIZE | FIXED(20) | Größe der OMS-Versionen, die aus Platzgründen aus dem Hauptspeicher verdrängt wurden (KB)
HISTORYDATASIZE | FIXED(20) | Größe des Bereichs des Data-Cache, der für das konsistente Lesen und Transaktionsmanagement benötigt wird (KB)
SQLDATASIZE | FIXED(20) | Größe des Bereichs des Data-Cache, der weder für OMS noch für konsistentes Lesen oder Transaktionsmanagement benötigt wird (KB)
CHANGEDDATASIZE | FIXED(20) | Menge geänderter Daten seit dem letzten Savepoint, die beim nächsten Savepoint in den Datenbereich geschrieben werden müssen (KB)
PENDINGOPERATIONCOUNT | FIXED(10) | Anzahl strukturverändernder Operationen, die beim nächsten Savepoint berücksichtgit werden müssen


DATASTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation DATASTATISTICS

Definition

Die Systemtabelle DATASTATISTICS beschreibt den aktuellen Füllungsgrad der Datenbankinstanz sowie den maximalen Füllungsgrad seit dem letzten Start der Datenbankinstanz.

Struktur

DATASTATISTICS

USABLESIZE | FIXED(20) | Für Daten zur Verfügung stehender Datenbereich (KB)
USEDSIZE | FIXED(20) | Für Daten tatsächlich genutzter Speicherplatz des Datenbereichs (KB)
USEDSIZEPERCENTAGE | FIXED(3) | Für Daten tatsächlich genutzter Speicherplatz des Datenbereichs (%)
DATAFULL | CHAR(3) | Datenbereich ist voll (YES | NO)
USEDSIZEONVOLUMES | FIXED(20) | In den Datenbereich geschriebene Menge von Daten (KB)
USEDSIZENOTONVOLUMES | FIXED(20) | Menge permanenter Daten, die beim nächsten Savepoint in den Datenbereich geschrieben werden müssen (KB)
USEDPERMANENTSIZE | FIXED(20) | Für permanente Daten genutzter Datenbereich (KB)
USEDTEMPORARYSIZE | FIXED(20) | Für temporäre Daten genutzter Datenbereich (KB)
MAXUSEDSIZE | FIXED(20) | Maximal für Daten genutzter Datenbereich zum Zeitpunkt eines Savepoint (KB)
MAXUSEDPERMANENTSIZE | FIXED(20) | Maximal für permanente Daten genutzter Datenbereich zum Zeitpunkt eines Savepoint (KB)
MAXUSEDTEMPORARYSIZE | FIXED(20) | Maximal für temporäre Daten genutzter Datenbereich zum Zeitpunkt eines Savepoint (KB)
INCREMENTALBACKUPSIZE | FIXED(20) | Bei der nächsten inkrementellen Sicherung zu sichernde Menge von Daten (KB)
LASTEMERGENCYHISTORYCLEANUP | TIMESTAMP | Zeitpunkt des letzten Löschens von Undo-Log-Dateien anhand der History-Datei aufgrund von Platzmangel im Datenbereich
CONVERTERVERSION | FIXED(10) | Die beim letzten Savepoint in den Datenbereich gesicherten Converter-Daten erhalten eine eindeutige Nummer (Converter-Version), die in der Restart-Information abgelegt wird
MAXTEMPORARYDATAPAGENUMBER | FIXED(10) | Höchste für temporäre Seiten zur Verfügung stehende Seitennummer
MAXPERMANENTDATAPAGENUMBER | FIXED(10) | Höchste für permanente Seiten zur Verfügung stehende Seitennummer
MAXPERMANENTSTATICDATAPAGENUMBER | FIXED(10) | Höchste für permanente, statische Seiten zur Verfügung stehende Seitennummer

Siehe auch:

Systemtabellen auswerten, DATASTATISTICS

DATASTATISTICSRESET


DATASTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation DATASTATISTICSRESET

Definition

Die Systemtabelle DATASTATISTICS beschreibt den aktuellen Füllungsgrad der Datenbankinstanz sowie den maximalen Füllungsgrad seit dem letzten RESET ALL STATISTICS bzw. RESET DATASTATISTICS.

Struktur

DATASTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzen RESET für diese Angaben
USABLESIZE | FIXED(20) | Für Daten zur Verfügung stehender Datenbereich (KB)
MAXUSEDSIZE | FIXED(20) | Maximal für Daten genutzter Datenbereich zum Zeitpunkt eines Savepoint (KB)
MAXUSEDPERMANENTSIZE | FIXED(20) | Maximal für permanente Daten genutzter Datenbereich zum Zeitpunkt eines Savepoint (KB)
MAXUSEDTEMPORARYSIZE | FIXED(20) | Maximal für temporäre Daten genutzter Datenbereich zum Zeitpunkt eines Savepoint (KB)

Siehe auch:

DATASTATISTICS


DATAVOLUMES (SAP-Bibliothek - Grundwissen)

Objektdokumentation DATAVOLUMES

Definition

Die Systemtabelle DATAVOLUMES beschreibt die Data-Volumes, auf denen Daten gespeichert sind.

Struktur

DATAVOLUMES

ID | FIXED(5) | Nummer des Volume
MODE | CHAR(10) | Modus des Volume (NORMAL | SEQUENTIAL)
CONFIGUREDSIZE | FIXED(20) | Konfigurierte Größe des Volume (KB)
USABLESIZE | FIXED(20) | Für Daten nutzbarer Bereich des Volume (KB)
USEDSIZE | FIXED(20) | Für Daten genutzter Bereich des Volume (KB)
USEDSIZEPERCENTAGE | FIXED(3) | Anteil des genutzten Bereichs vom insgesamt nutzbaren Bereich des Volume (%)
DROPVOLUME | CHAR(3) | Volume wird zur Zeit aus der Datenbank entfernt (YES | NO)
TOTALCLUSTERAREASIZE | FIXED(20) | Reservierter Bereich (Cluster-Bereich) am Ende des Volume für die in Clustern abgelegten Daten (KB)
RESERVEDCLUSTERAREASIZE | FIXED(20) | Durch Cluster genutzter Bereich innerhalb des Cluster-Bereichs
USEDCLUSTERAREASIZE | FIXED(20) | Durch Daten genutzter Bereich innerhalb des Cluster-Bereichs
PATH | CHAR(256) | Bezeichnung des Volume


DBPARAMETERS (SAP-Bibliothek - Grundwissen)

Objektdokumentation DBPARAMETERS

Definition

Die Statistik-Systemtabelle DBPARAMETERS enthält die Parameter, die mit dem Datenbankwerkzeug Database Manager für die Datenbankinstanz definiert wurden.

Struktur

DBPARAMETERS

DESCRIPTION | CHAR(32) | Beschreibung, wie die Spalte VALUE zu interpretieren ist
VALUE | CHAR(256) | Wert

Die Systemtabelle DBPARAMETERS existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle der Systemtabelle DBPARAMETERS die Systemtabelle ACTIVECONFIGURATION.


DBPROCEDURES (SAP-Bibliothek - Grundwissen)

Objektdokumentation DBPROCEDURES

Definition

Die Systemtabelle DBPROCEDURES enthält alle Datenbankprozeduren, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

DBPROCEDURES

SCHEMANAME | CHAR(32) | Name des Schemas der Datenbankprozedur
DBPROCNAME | CHAR(32) | Name der Datenbankprozedur
OWNER | CHAR(32) | Name des Eigentümers der Datenbankprozedur
PACKAGE | CHAR(32) | Paket, in dem die Datenbankprozedur enthalten ist
PARAMETER | FIXED(4) | Anzahl der Parameter der Datenbankprozedur
CREATEDATE | DATE(10) | Erzeugungsdatum der Datenbankprozedur
CREATETIME | TIME(8) | Erzeugungszeit der Datenbankprozedur
EXECUTION_KIND | CHAR(6) | Ausführungsort der Datenbankprozedur (INPROC | LOCAL)
LANGUAGE | CHAR(32) | Implementierungssprache der Datenbankprozedur (SPL | C++ | JAVA | ...)
SQL_SUPPORT | CHAR(3) | Datenbankprozedur darf SQL-Anweisungen enthalten (YES | NO)
CURSOR_SUPPORT | CHAR(3) | Das Datenbanksystem schickt einen Cursor zurück (YES | NO)
WAIT_FOR_CHCKPT | CHAR(3) | NO
REMOTE_LOCATION | CHAR(132) | NULL
DEFINITION | LONG | SQL-Anweisung zur Definition der Datenbankprozedur
COMMENT | LONG | Kommentar zu der Datenbankprozedur

Siehe auch:

Systemtabellen auswerten, DBPROCEDURES

SQL-Referenzhandbuch, Name einer Datenbankprozedur (dbproc_name)


DBPROCPARAMS (SAP-Bibliothek - Grundwissen)

Objektdokumentation DBPROCPARAMS

Definition

Die Systemtabelle DBPROCPARAMS enthält alle Parameter einer Datenbankprozedur, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

DBPROCPARAMS

SCHEMANAME | CHAR(32) | Name des Schemas der Datenbankprozedur
DBPROCNAME | CHAR(32) | Name der Datenbankprozedur
OWNER | CHAR(32) | Name des Eigentümers der Datenbankprozedur
PARAMETERNAME | CHAR(32) | Name des Parameters
POS | FIXED(4) | Originalposition des Parameters in der Datenbankprozedur
IN/OUT-TYPE | CHAR(6) | Art des Parameters (IN | OUT)
DATATYPE | CHAR(10) | Datentyp des Parameters (BOOLEAN | CHAR | DATE | FIXED | FLOAT | TIME | TIMESTAMP)
CODETYPE | CHAR(8) | Codeattribut der Spalte (ASCII | BYTE | UNICODE)
LEN | FIXED(4) | Länge oder Genauigkeit des Parameters
DEC | FIXED(3) | Anzahl der Nachkommastellen des Parameters bei Datentyp FIXED
CREATEDATE | DATE(10) | Erzeugungsdatum der Datenbankprozedur
CREATETIME | TIME(8) | Erzeugungszeit der Datenbankprozedur

Siehe auch:

Systemtabellen auswerten, DBPROCPARAMS

SQL-Referenzhandbuch, Name einer Datenbankprozedur (dbproc_name), Datentyp (data_type)


DOMAINCONSTRAINTS (SAP-Bibliothek - Grundwissen)

Objektdokumentation DOMAINCONSTRAINTS

Definition

Die Systemtabelle DOMAINCONSTRAINTS beschreibt Wertebereiche und ihre Definition.

Struktur

DOMAINCONSTRAINTS

OWNER | CHAR(32) | Name des Eigentümers des Wertebereichs
DOMAINNAME | CHAR(32) | Name des Wertebereichs
CONSTRAINTNAME | CHAR(32) | Name der CONSTRAINT-Definition
DEFINITION | LONG | Text der CONSTRAINT-Definition

Siehe auch:

Systemtabellen auswerten, DOMAINCONSTRAINTS

SQL-Referenzhandbuch, CONSTRAINT-Definition (constraint_definition)


DOMAINS (SAP-Bibliothek - Grundwissen)

Objektdokumentation DOMAINS

Definition

Die Systemtabelle DOMAINS enthält Informationen zu allen Wertebereichen.

Struktur

DOMAINS

OWNER | CHAR(32) | Name des Eigentümers des Wertebereichs
DOMAINNAME | CHAR(32) | Name des Wertebereichs
DATATYPE | CHAR(10) | Datentyp des Wertebereichs (BOOLEAN | CHAR | DATE | FIXED | FLOAT | INTEGER | LONG | SMALLINT | TIME | TIMESTAMP)
CODETYPE | CHAR(8) | Codeattribut des Wertebereichs (ASCII | BYTE | UNICODE)
LEN | FIXED(4) | Länge oder Genauigkeit des Wertebereichs
DEC | FIXED(3) | Anzahl der Nachkommastellen bei den Wertebereichen vom Datentyp FIXED
DEFAULT | CHAR(254) | Vorschlagswert (Default) für den Wertebereich
DEFAULTFUNCTION | CHAR(12) | Name, wenn der DEFAULT-Wert eine der folgenden Spezifikationen von Werten ist: NULL | USER | USERGROUP | SYSDBA | UID | DATE | TIME | TIMESTAMP | UTCDATE | TIMEZONE | UTCDIFF | TRUE | FALSE | TRANSACTION andernfalls NULL-Wert
DEFINITION | LONG | Text der Wertebereichsdefinition
CREATEDATE | DATE(10) | Erzeugungsdatum des Wertebereichs
CREATETIME | TIME(8) | Erzeugungszeit des Wertebereichs
COMMENT | LONG | Kommentar zu dem Wertebereich

Siehe auch:

Systemtabellen auswerten, DOMAINS

SQL-Referenzhandbuch, Datentyp (data_type), Spezifikation von Werten (extended_value_spec)


FILEDIRECTORIES (SAP-Bibliothek - Grundwissen)

Objektdokumentation FILEDIRECTORIES

Definition

Die Systemtabelle FILEDIRECTORIES beschreibt alle internen Dateiverzeichnisse, sowohl das allgemeine als auch die lokalen Dateiverzeichnisse aller Datenbanksitzungen.

Struktur

FILEDIRECTORIES

SESSIONID | FIXED(10) | Identifikation der Datenbanksitzung, zu der das lokale Dateiverzeichnis gehört NULL für das allgemeine Dateiverzeichnis
TASKID | FIXED(10) | Identifikation der Task, zu der das lokale Dateiverzeichnis gehört NULL für das allgemeine Dateiverzeichnis
MAXUSEDFILEID | CHAR(8) BYTE | Größte vergebene Dateinummer - bei lokalem Dateiverzeichnis Dateinummer für temporäre Dateien - bei allgemeinem Dateiverzeichnis Dateinummer für persistente Dateien
ENTRYCOUNT | FIXED(10) | Anzahl der Einträge in diesem Dateiverzeichnis
CACHEENTRYCOUNT | FIXED(10) | Anzahl der Einträge, die im Cache des lokalen Dateiverzeichnisses gepuffert sind NULL für das allgemeine Dateiverzeichnis
HASHTABLESLOTCOUNT | FIXED(10) | Anzahl der Slots in der Hash-Tabelle des Dateiverzeichnisses
USEDHASHTABLESLOTCOUNT | FIXED(10) | Anzahl der belegten Slots in der Hash-Tabelle des Dateiverzeichnisses
MAXHASHTABLECHAINENTRYCOUNT | FIXED(10) | Längste Hash-Kette innerhalb der Hash-Tabelle des Dateiverzeichnisses seit der letzten Vergrößerung der Hash-Kette
RESIZEHASHTABLECOUNT | FIXED(10) | Zahl der notwendigen Größenanpassungen der Hash-Tabelle
USEDPAGECOUNT | FIXED(10) | Anzahl der belegten Datenseiten für das allgemeine Dateiverzeichnis NULL für die lokalen Dateiverzeichnisse
STATISTICSDELTACOUNT | FIXED(10) | Anzahl der Dateiverzeichnis-Einträge, die nach einem Savepoint geändert wurden
CURRENTSTATISTICSDELTACOUNT | FIXED(10) | Anzahl der Dateiverzeichnis-Einträge, die nach dem aktuellen Savepoint geändert wurden

Siehe auch:

Glossar, Dateiverzeichnis


FILES (SAP-Bibliothek - Grundwissen)

Objektdokumentation FILES

Definition

Die Systemtabelle FILES beschreibt alle datenbankinternen Dateien, bis auf die LONG-Dateien.

Struktur

FILES

FILEID | CHAR(8) BYTE | Identifikation der Datei
SESSIONID | FIXED(10) | Identifikation der Datenbanksitzung, in der temporäre Dateien angelegt wurden NULL für persistente Dateien
ROOT | FIXED(10) | Seitennummer der Wurzel der Datei
TYPE | CHAR(20) | Typ der Datei (TABLE | INDEX | FIXED OBJECT | VARIABLE OBJECT | KEYED OBJECT | KEYED OBJECT INDEX | SHORT COLUMN FILE | interner Dateityp für temporäre Dateien | UNKNOWN)
PRIMARYFILEID | CHAR(8) BYTE | Identifikation der zugehörigen Tabelle, wenn es sich um eine Datei vom Typ SHORT COLUMN FILE oder INDEX handelt oder Identifikation des zugehörigen KEYED OBJECT, wenn es sich um eine Datei vom Typ KEYED OBJECT INDEX handelt oder NULL, wenn es sich um eine Datei eines anderen Typs handelt
FILESTATE | CHAR(20) | Status der Datei (OK | DELETED | BAD | READONLY | UNKNOWN)
ENTRYCOUNT | FIXED(20) | Anzahl der Einträge in der Datei NULL wenn keine Einträge vorhanden sind oder ENTRYCOUNT noch nicht ermittelt wurde
TREEINDEXSIZE | FIXED(20) | Platz, der durch Indexseiten der Datei belegt ist (KB) NULL, falls die Datei keine Indexseiten hat oder TREEINDEXSIZE noch nicht ermittelt wurde
TREELEAVESSIZE | FIXED(20) | Platz, der durch die Blattseiten der Datei belegt ist (KB) NULL, falls TREELEAVESIZE noch nicht ermittelt wurde
LOBSIZE | FIXED(20) | Platz, der durch LONG-Werte der Tabelle belegt ist (KB) NULL, falls die Datei keine Tabelle ist oder LOBSIZE noch nicht ermittelt wurde
CLUSTERED | CHAR(3) | Angabe, ob Datenseiten der Datei für die Ablage in Clustern berücksichtigt werden (YES | NO) Dies bedeutet nicht, dass die Datei vollständig in Clustern abgelegt wird.
DYNAMIC | CHAR(3) | Angabe, ob eine vereinfachte Über-/Unterlaufbehandlung auf B*-Baum-Seiten angewendet wird (YES | NO)
PACKED | CHAR(3) | Angabe, ob Datensätze der Datei in einem platzsparenden Format abgelegt werden (YES | NO)

Siehe auch:

SYSUPDATECOUNTERWANTED

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


FOREIGNKEYCOLUMNS (SAP-Bibliothek - Grundwissen)

Objektdokumentation FOREIGNKEYCOLUMNS

Definition

Die Systemtabelle FOREIGNKEYCOLUMNS enthält die Spalten aller referentiellen CONSTRAINT-Definitionen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

FOREIGNKEYCOLUMNS

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle
COLUMNNAME | CHAR(32) | Name der Spalte
FKEYNAME | CHAR(32) | Name der referentiellen CONSTRAINT-Definition
REFSCHEMANAME | CHAR(32) | Name des Schemas der referenzierten Tabelle
REFOWNER | CHAR(32) | Name des Eigentümers der referenzierten Tabelle
REFTABLENAME | CHAR(32) | Name der referenzierten Tabelle
REFCOLUMNNAME | CHAR(32) | Name der Spalte der referenzierten Tabelle
RULE | CHAR(18) | Regeln beim Löschen der Tabelle
CREATEDATE | DATE(10) | Erzeugungsdatum der referentiellen CONSTRAINT-Definition
CREATETIME | TIME(8) | Erzeugungszeit der referentiellen CONSTRAINT-Definition
COMMENT | LONG | Kommentar zur referentiellen CONSTRAINT-Definition

Siehe auch:

Systemtabellen auswerten, FOREIGNKEYCOLUMNS

SQL-Referenzhandbuch, Name eines Referentiellen Constraints (referential_constraint_name)


FOREIGNKEYS (SAP-Bibliothek - Grundwissen)

Objektdokumentation FOREIGNKEYS

Definition

Die Systemtabelle FOREIGNKEYS enthält alle referentiellen CONSTRAINT-Definitionen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

FOREIGNKEYS

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle
FKEYNAME | CHAR(32) | Name der referentiellen CONSTRAINT-Definition
RULE | CHAR(18) | Regeln beim Löschen der Tabelle
CREATEDATE | DATE(10) | Erzeugungsdatum der referentiellen CONSTRAINT-Definition
CREATETIME | TIME(8) | Erzeugungszeit der referentiellen CONSTRAINT-Definition
COMMENT | LONG | Kommentar zur referentiellen CONSTRAINT-Definition

Siehe auch:

Systemtabellen auswerten, FOREIGNKEYS

SQL-Referenzhandbuch, Name eines Referentiellen Constraints (referential_constraint_name)


FUNCTIONS (SAP-Bibliothek - Grundwissen)

Objektdokumentation FUNCTIONS

Definition

Die Systemtabelle FUNCTIONS enthält alle Datenbankfunktionen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

FUNCTIONS

SCHEMANAME | CHAR(32) | Name des Schemas der Datenbankfunktion
FUNCTIONNAME | CHAR(32) | Name der Datenbankfunktion
OWNER | CHAR(32) | Name des Eigentümers der Datenbankfunktion
PARAMETER | FIXED(4) | Anzahl der Parameter der Datenbankfunktion
CREATEDATE | DATE(10) | Erzeugungsdatum der Datenbankfunktion
CREATETIME | TIME(8) | Erzeugungszeit der Datenbankfunktion
SQL_SUPPORT | CHAR(3) | Datenbankfunktion darf SQL-Anweisungen enthalten (YES | NO)
DETERMINISTIC | CHAR(3) | Datenbankfunktion kann deterministisch sein (YES | NO)
DEFINITION | LONG | SQL-Anweisung zur Definition der Datenbankfunktion
COMMENT | LONG | Kommentar zur Datenbankfunktion

Siehe auch:

Systemtabellen auswerten, FUNCTIONS

SQL-Referenzhandbuch, Name einer Datenbankfunktion (dbfunction_name)


GARBAGECOLLECTOR_STATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation GARBAGECOLLECTOR_STATISTICS

Definition

Die Systemtabelle GARBAGECOLLECTOR_STATISTICS beschreibt die Aktivität der Garbage-Collectors.

Struktur

GARBAGECOLLECTOR_STATISTICS

TASKID | FIXED(10) | Identifikation der Task, die als Garbage-Collector läuft
ACTIVE | CHAR(3) | Task ist aktiv (YES | NO)
ACTIVE_COUNT | FIXED(20) | Anzahl, wie oft die Task aktiviert wurde
DELETE_OBJ | FIXED(20) | Anzahl der persistenten Objekten, die von den Garbage-Collectors freigegeben wurden
RELHIST_NORMAL | FIXED(20) | Anzahl der History-Einträgen, die von den Garbage-Collectors freigegeben wurden
RELHIST_SENSITIVE | FIXED(20) | NULL-Wert (wird nicht mehr genutzt)
RELHIST_TRUNCATE | FIXED(20) | NULL-Wert (wird nicht mehr genutzt)
HIST_CREATE_FILE | FIXED(20) | Anzahl der ‚Create Container’-History-Einträge, die von den Garbage-Collectors freigegeben wurden
HIST_DELETE_OBJ | FIXED(20) | Anzahl der ‚Delete Object’-History-Einträge, die von den Garbage-Collectors freigegeben wurden
HIST_DROP_FILE | FIXED(20) | Anzahl der ‚Drop Container’-History-Einträge, die von den Garbage-Collectors freigegeben wurden
HIST_LOCK_OBJ | FIXED(20) | Anzahl der ‚Lock Object’-History-Einträge, die von den Garbage-Collectors freigegeben wurden
HIST_INSERT_OBJ | FIXED(20) | Anzahl der ‚Insert Object’-History-Einträge, die von den Garbage-Collectors freigegeben wurden
HIST_NEW_OBJ | FIXED(20) | Anzahl der ‚New Object’-History-Einträge, die von den Garbage-Collectors freigegeben wurden
HIST_UPDATE_OBJ | FIXED(20) | Anzahl der ‚Update Object’-History-Einträge, die von den Garbage-Collectors freigegeben wurden
RELPAGE_EMPTY | FIXED(20) | Anzahl der Seiten, die von den Garbage-Collectors freigegeben wurden, weil sie leer waren
RELPAGE_DROPFILE | FIXED(20) | Anzahl der Seiten, die auf Grund einer ‚Drop Container’-Anweisung freigegeben wurden
DROP_FILE | FIXED(20) | Anzahl der ‚Drop Container’-Befehle, die von den Garbage-Collectors ausgeführt wurden

Siehe auch:

Konzepte des Datenbanksystems, History-Verwaltung


HISTORYINFO (SAP-Bibliothek - Grundwissen)

Objektdokumentation HISTORYINFO

Definition

Die Systemtabelle HISTORYINFO liefert Informationen zur Datenhistorie. Diese Historie wird benötigt, um Daten für eine konsistente Sicht liefern zu können.

Struktur

HISTORYINFO

FILENO | FIXED(10) | Nummer der History-Datei
FIRSTTRANS | CHAR(20) | Älteste Transaktion, die durch den Garbage-Collector noch nicht bearbeitet wurde
LASTTRANS | CHAR(20) | Jüngste Transaktion, die durch den Garbage-Collector noch nicht bearbeitet wurde
PAGECOUNT | FIXED(10) | Anzahl der Seiten, die durch die History-Datei und alle durch die History-Datei referenzierten Undo-Log-Dateien verwendet werden


HOTSTANDBYCOMPONENT (SAP-Bibliothek - Grundwissen)

Objektdokumentation HOTSTANDBYCOMPONENT

Definition

Die Systemtabelle HOTSTANDBYCOMPONENT beschreibt einige Details der Hot-Standby-Instanz, auf der die Informationen dieser Systemtabelle abgefragt werden.

Struktur

HOTSTANDBYCOMPONENT

LOCALNODE | CHAR(64) | Name, unter dem die Hot-Standby-Instanz angesprochen werden kann
MASTERLOCALNODE | CHAR(64) | Name, unter dem die zugehörige Master-Instanz angesprochen werden kann
STANDBYROLE | CHAR(8) | Rolle innerhalb der Hot-Standby-Konfiguration (MASTER | STANDBY | UNKNOWN)
TAKEOVERDATE | TIMESTAMP | Zeitpunkt, an dem eine TAKEOVER-Anweisung empfangen wurde
DELAYTIME | FIXED(10) | Zeitverzögerung in Sekunden, mit der die Standby-Instanz die Änderungen der Master-Instanz nachfährt
STANDBYSTATEDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz den Betriebszustand STANDBY erreicht hat
SYNCHRONIZERECEIVECOUNT | FIXED(10) | Anzahl der SYNCHRONIZE-Anweisungen, die die Instanz erhalten hat
FIRSTNEEDEDLOGOFFSET | FIXED(10) | Älteste Position im Log-Bereich, ab der die Log-Einträge nachgefahren werden müssen
LASTVALIDLOGOFFSETRECEIVED | FIXED(10) | Position im Log-Bereich, bis zu der die Instanz Log-Einträge lesen darf; diese Position wurde mit der letzten SYNCHRONIZE-Anweisung übermittelt
INITSTANDBYDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz die letzte INIT STANDBY-Anweisung erhalten hat
RESTARTSTANDBYDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz die letzte RESTART STANDBY-Anweisung abgeschickt hat
LASTSYNCHRONIZEDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz die letzte SYNCHRONIZE-Anweisung erhalten hat
PREPARESTANDBYDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz die letzte PREPARE STANDBY-Anweisung abgeschickt hat
REGISTERSTANDBYDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz die letzte REGISTER STANDBY-Anweisung abgeschickt hat

Siehe auch:

Konzepte des Datenbanksystems, Architektur eines Hot-Standby-Systems


HOTSTANDBYGROUP (SAP-Bibliothek - Grundwissen)

Objektdokumentation HOTSTANDBYGROUP

Definition

Die Systemtabelle HOTSTANDBYGROUP beschreibt, welche Informationen die Hot-Standby-Instanz, auf der die Informationen dieser Systemtabelle abgefragt werden, über die anderen Standby-Instanzen hat.

Struktur

HOTSTANDBYGROUP

LOCALNODE | CHAR(64) | Name, unter dem die Instanz angesprochen werden kann
ADDNODEDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz zur Hot-Standby-Konfiguration hinzugefügt wurde
REMOVENODEDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz aus der Hot-Standby-Konfiguration entfernt wurde
STATE | CHAR(20) | Status der Instanz (UNKNOWN, PREPARE STANDBY, WAIT FOR SYNCHRONIZE, DEACTIVATED, REGISTER STANDBY, REMOVED, ADDED)
PREPARESTANDBYDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz die letzte PREPARE STANDBY-Anweisung erhalten hat
REGISTERSTANDBYDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz die letzte REGISTER STANDBY-Anweisung erhalten hat
SYNCHRONIZEDATE | TIMESTAMP | Zeitpunkt, an dem die Instanz die letzte SYNCHRONIZE-Anweisung abgeschickt hat
SUCCESSFULSYNCHRONIZEDATE | TIMESTAMP | Zeitpunkt, an dem die SYNCHRONIZE-Anweisung zum letzten Mal erfolgreich ausgeführt wurde
LASTVALIDLOGOFFSETSENT | FIXED(10) | Letzte von der Master-Instanz verschickte Position im Log-Bereich, bis zu der die Standby-Instanzen die Log-Einträge nachfahren können
FIRSTNEEDELOGOFFSET | FIXED(10) | Älteste Position im Log-Bereich, bis zu der die Master-Instanz schreiben kann, ohne damit von den Standby-Instanzen benötigte Log-Seiten zu überschreiben
SYNCHRONIZESENDCOUNT | FIXED(10) | Anzahl der abgeschickten SYNCHRONIZE-Anweisungen
SYNCHRONIZERETRYCOUNT | FIXED(10) | Anzahl der SYNCHRONIZE-Anweisungen, die seit der letzten erfolgreichen SYNCHRONIZE-Anweisung fehlgeschlagen sind

Siehe auch:

Konzepte des Datenbanksystems, Architektur eines Hot-Standby-Systems


INDEXCOLUMNS (SAP-Bibliothek - Grundwissen)

Objektdokumentation INDEXCOLUMNS

Definition

Die Systemtabelle INDEXCOLUMNS enthält detaillierte Informationen zu den Indizes, für die der aktuelle Datenbankbenutzer Privilegien besitzt.

Struktur

INDEXCOLUMNS

SCHEMANAME | CHAR(32) | Name des Schemas des Index
OWNER | CHAR(32) | Name des Eigentümers des Index
TABLENAME | CHAR(32) | Name der Tabelle
INDEXNAME | CHAR(32) | Name des Index
FILEID | CHAR(8) BYTE | Identifikation der Indexdatei
TYPE | CHAR(6) | Typ des Index (UNIQUE | NULL)
COLUMNNAME | CHAR(32) | Name der Spalte
SORT | CHAR(4) | Sortierreihenfolge für die Spalte (ASC | DESC)
COLUMNNO | FIXED(4) | Nummer der Spalte im Index
DATATYPE | CHAR(10) | Datentyp des Wertebereichs (BOOLEAN | CHAR | DATE | FIXED | FLOAT | INTEGER | SMALLINT | TIME | TIMESTAMP)
LEN | FIXED(4) | Länge oder Genauigkeit der Definition der Spalte
CREATEDATE | DATE(10) | Erzeugungsdatum des Index
CREATETIME | TIME(8) | Erzeugungszeit des Index
INDEX_USED | FIXED(10) | Verwendungshäufigkeit des Index bei Suchvorgängen
FILESTATE | CHAR(20) | Zustand des Index (OK | BAD | MISSING)
DISABLED | CHAR(3) | Index für Suchvorgänge nicht aktiv (YES | NO)
COMMENT | LONG | Kommentar zum Index

Siehe auch:

Systemtabellen auswerten, INDEXCOLUMNS

SQL-Referenzhandbuch, Indexname (index_name)


INDEXES (SAP-Bibliothek - Grundwissen)

Objektdokumentation INDEXES

Definition

Die Systemtabelle INDEXES enthält alle Indizes, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

INDEXES

SCHEMANAME | CHAR(32) | Name des Schemas des Index
OWNER | CHAR(32) | Name des Eigentümers des Index
TABLENAME | CHAR(32) | Name der Tabelle
INDEXNAME | CHAR(32) | Name des Index
FILEID | CHAR(8) BYTE | Identifikation der Indexdatei
TYPE | CHAR(6) | Typ des Index (UNIQUE | NULL)
CREATEDATE | DATE(10) | Erzeugungsdatum des Index
CREATETIME | TIME(8) | Erzeugungszeit des Index
INDEX_USED | FIXED(10) | Verwendungshäufigkeit des Index bei Suchvorgängen
INDEXUSEDRESETDATE | DATE | Datum, an dem zuletzt ALTER INDEX INIT USAGE ausgeführt wurde
INDEXUSEDRESETTIME | TIME | Zeit, zu der zuletzt ALTER INDEX INIT USAGE ausgeführt wurde
FILESTATE | CHAR(20) | Zustand des Index (OK | DELETED | BAD | READONLY | UNKNOWN)
DISABLED | CHAR(3) | Index für Suchvorgänge nicht aktiv (YES | NO)
COMMENT | LONG | Kommentar zum Index

Wenn die Systemtabelle INDEXES vom Datenbanksystemadministrator aufgerufen wird, so werden Informationen zu den Indizes aller Datenbankbenutzer angezeigt.

Siehe auch:

Systemtabellen auswerten, INDEXES

SQL-Referenzhandbuch, Indexname (index_name)


INDEXSIZE (SAP-Bibliothek - Grundwissen)

Objektdokumentation INDEXSIZE

Definition

Die Systemtabelle INDEXSIZE enthält Größeninformationen über Indizes.

Struktur

INDEXSIZE

SCHEMANAME | CHAR(32) | Name des Schemas
TABLENAME | CHAR(32) | Name der Tabelle
INDEXNAME | CHAR(32) | Name des Index
USEDSIZE | FIXED(20) | Platzbedarf für den Index (KB)
SECONDARYKEYCOUNT | FIXED(20) | Anzahl der verschiedenen Sekundärschlüsselwerte

Siehe auch:

FILES


INDEXSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation INDEXSTATISTICS

Definition

Die Statistik-Systemtabelle INDEXSTATISTICS enthält Struktur- und Größeninformationen über Indizes.

Struktur

INDEXSTATISTICS

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle
INDEXNAME | CHAR(32) | Name des Index (NULL bei nicht benannten Indizes)
COLUMNNAME | CHAR(32) | Name einer invertierten Spalte
DESCRIPTION | CHAR(40) | Beschreibung (siehe Tabelle Spalte DESCRIPTION), wie die folgenden Spalten zu interpretieren sind
CHAR_VALUE | CHAR(12) | Alphanumerischer Wert
NUMERIC_VALUE | FIXED(10) | Numerischer Wert

Spalte DESCRIPTION

Wert | Erläuterung
Root pno | NUMERIC_VALUE enthält die Seitennummer der Wurzel des B*-Baums
File type | CHAR_VALUE enthält den Typ des B*-Baums
Used pages | NUMERIC_VALUE enthält die Anzahl der durch den Index belegten Seiten
Index pages | NUMERIC_VALUE enthält die Anzahl der durch den Index belegten Seiten im B*-Baumindex
Leaf pages | NUMERIC_VALUE enthält die Anzahl der durch den Index belegten Blattseiten
Index levels | NUMERIC_VALUE enthält die Anzahl der Indexstufen des B*-Baums
Space used in all pages(%) | NUMERIC_VALUE enthält die prozentuale Belegung aller Seiten des B*-Baums
Space used in root page(%) | NUMERIC_VALUE enthält die prozentuale Belegung der Wurzelseite des B*-Baums
Space used in index pages(%) | NUMERIC_VALUE enthält die prozentuale Belegung der Indexseiten des B*-Baums
Space used in index pages(%) min | NUMERIC_VALUE enthält die minimale prozentuale Belegung der Indexseiten des B*-Baums
Space used in index pages(%) max | NUMERIC_VALUE enthält die maximale prozentuale Belegung der Indexseiten des B*-Baums
Space used in leaf pages(%) | NUMERIC_VALUE enthält die prozentuale Belegung der Blattseiten des B*-Baums
Space used in leaf pages(%) min | NUMERIC_VALUE enthält die minimale prozentuale Belegung der Blattseiten des B*-Baums
Space used in leaf pages(%) max | NUMERIC_VALUE enthält die maximale prozentuale Belegung der Blattseiten des B*-Baums
Secondary keys (index lists) | NUMERIC_VALUE enthält die Anzahl verschiedener Werte der indizierten Spalten
Avg secondary key length | NUMERIC_VALUE enthält die durchschnittliche Indexwertlänge
Min secondary key length | NUMERIC_VALUE enthält die minimale Indexwertlänge
Max secondary key length | NUMERIC_VALUE enthält die maximale Indexwertlänge
Avg separator length | NUMERIC_VALUE enthält die durchschnittliche Länge eines Separators des B*-Baums
Min separator length | NUMERIC_VALUE enthält die minimale Separatorlänge
Max separator length | NUMERIC_VALUE enthält die maximale Separatorlänge
Primary keys | NUMERIC_VALUE enthält die Anzahl der Zeilen der durch OWNER und TABLENAME identifizierten Tabelle
Avg primary keys per list | NUMERIC_VALUE enthält die durchschnittliche Anzahl von Schlüsseln pro Invertierungsliste
Min primary keys per list | NUMERIC_VALUE enthält die minimale Anzahl von Schlüsseln pro Invertierungsliste
Max primary keys per list | NUMERIC_VALUE enthält die maximale Anzahl von Schlüsseln pro Invertierungsliste
Values with selectivity <= 1% | NUMERIC_VALUE enthält die Anzahl von Invertierungslisten mit einer Selektivität <= 1%
Values with selectivity <= 5% | NUMERIC_VALUE enthält die Anzahl von Invertierungslisten mit einer Selektivität zwischen 1% und 5%
Values with selectivity <= 10% | NUMERIC_VALUE enthält die Anzahl von Invertierungslisten mit einer Selektivität zwischen 5% und 10%
Values with selectivity <= 25% | NUMERIC_VALUE enthält die Anzahl von Invertierungslisten mit einer Selektivität zwischen 10% und 25%.
Values with selectivity > 25% | NUMERIC_VALUE enthält die Anzahl von Invertierungslisten mit einer Selektivität > 25%

Siehe auch:

FILES

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


INDEXSTORAGEDETAILS (SAP-Bibliothek - Grundwissen)

Objektdokumentation INDEXSTORAGEDETAILS

Definition

Die Systemtabelle INDEXSTORAGEDETAILS enthält Struktur- und Größeninformationen über Indizes.

Struktur

INDEXSTORAGEDETAILS

SCHEMANAME | CHAR(32) | Name des Schemas
TABLENAME | CHAR(32) | Name der Tabelle
INDEXNAME | CHAR(32) | Name des Index
TREELEVELCOUNT | FIXED(3) | Anzahl der B*-Baum-Indexebenen
AVGSEPARATORLENGTH | FIXED(4) | Durchschnittliche Separatorlänge
MINSEPARATORLENGTH | FIXED(4) | Minimale Separatorlänge
MAXSEPARATORLENGTH | FIXED(4) | Maximale Separatorlänge
AVGUSEDSIZEPERCENTAGEINLEAVES | FIXED(3) | Durchschnittlicher Füllungsgrad der Seiten, die Daten enthalten
MINUSEDSIZEPERCENTAGEINLEAVES | FIXED(3) | Minimaler Füllungsgrad einer Seite, die Daten enthält
MAXUSEDSIZEPERCENTAGEINLEAVES | FIXED(3) | Maximaler Füllungsgrad einer Seite, die Daten enthält
AVGSECONDARYKEYLENGTH | FIXED(4) | Durchschnittliche Länge der Sekundärschlüsselwerte
MINSECONDARYKEYLENGTH | FIXED(4) | Minimale Länge eines Sekundärschlüsselwertes
MAXSECONDARYKEYLENGTH | FIXED(4) | Maximale Länge eines Sekundärschlüsselwertes
AVGROWCOUNTPERSECONDARYKEY | FIXED(10) | Durchschnittliche Anzahl der Tabellenzeilen pro Sekundärschlüssel
MINROWCOUNTPERSECONDARYKEY | FIXED(10) | Minimale Anzahl der Tabellenzeilen zu einem Sekundärschlüssel
MAXROWCOUNTPERSECONDARYKEY | FIXED(10) | Maximale Anzahl der Tabellenzeilen zu einem Sekundärschlüssel
CLUSTERCOUNT | FIXED(10) | Anzahl der Datenseiten, die in Clustern abgelegt wurden

Siehe auch:

FILES

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


INSTANCE (SAP-Bibliothek - Grundwissen)

Objektdokumentation INSTANCE

Definition

Die Systemtabelle INSTANCE beschreibt einige Details einer Datenbankinstanz.

Struktur

INSTANCE

NODE | CHAR(64) | Name, unter dem die Datenbankinstanz von Anwendungen angesprochen werden kann
LOCALNODE | CHAR(64) | Name, unter dem im Fall einer Hot-Standby-Konfiguration diese Hot-Standby-Instanz angesprochen werden kann
ADMINSTATEDATE | TIMESTAMP | Zeitpunkt des Erreichens des Betriebszustandes ADMIN
ONLINESTATEDATE | TIMESTAMP | Zeitpunkt des Erreichens des Betriebszustandes ONLINE
KERNELPROCESSID | FIXED(20) | Identifikation des Kernprozesses

Siehe auch:

Systemtabellen auswerten, INSTANCE

Konzepte des Datenbanksystems, Das Datenbanksystem im Überblick, Architektur eines Hot-Standby-Systems


IOBUFFERCACHES (SAP-Bibliothek - Grundwissen)

Objektdokumentation IOBUFFERCACHES

Definition

Die Systemtabelle IOBUFFERCACHES enthält Informationen über die Verwendung des I/O-Buffer-Cache, der durch den Datenbankparameter CACHE_SIZE dimensioniert wird.

Struktur

IOBUFFERCACHES

TOTALSIZE | FIXED(20) | Konfigurierte Größe des I/O-Buffer-Cache gemäß dem Datenbankparameter CACHE_SIZE (KB)
DATACACHEUSEDSIZE | FIXED(20) | Durch den Data-Cache genutzte Seiten (KB)
CONVERTERUSEDSIZE | FIXED(20) | Durch den Converter genutzte Seiten (KB)
LOGQUEUEUSEDSIZE | FIXED(20) | Durch die Log-Warteschlange genutzte Seiten (KB)
IOMANAGEMENTUSEDSIZE | FIXED(20) | Durch das I/O-Management genutzte Seiten (KB)
FILEDIRECTORYUSEDSIZE | FIXED(20) | Durch das interne Dateiverzeichnis genutzte Seiten (KB)
RESTARTRECORDUSEDSIZE | FIXED(20) | Restart-Seiten, die für Snapshots genutzt werden (KB)
BLOCKALLOCATORUSEDSIZE | FIXED(20) | Durch Blockallokatoren genutzter Speicherplatz (KB)
UNUSEDSIZE | FIXED(20) | Ungenutzte Seiten (KB)
INDEXCREATIONUSEDSIZE | FIXED(20) | Für den parallelen Indexaufbau benutzte Seiten (KB)

Siehe auch:

MEMORYALLOCATORSTATISTICS

Konzepte des Datenbanksystems, Allgemeine Datenbankparameter


IOTHREADSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation IOTHREADSTATISTICS

Definition

Die Systemtabelle IOTHREADSTATISTICS enthält Informationen über alle I/O-Vorgänge pro Volume seit dem letzten Start der Datenbankinstanz.

Struktur

IOTHREADSTATISTICS

VOLUMEID | FIXED(10) | Identifikation des Volume in der Laufzeitumgebung
READCOUNT | FIXED(20) | Anzahl der Lesevorgänge
READPAGECOUNT | FIXED(20) | Anzahl der Seiten, die während des Lesevorgangs gelesen wurden
READTIME | FIXED(20) | Gesamtzeit der Lesevorgänge mit aktiver Zeitmessung (µs)
READTIMEMEASUREMENTCOUNT | FIXED(20) | Anzahl der vermessenen Lesevorgänge
WRITECOUNT | FIXED(20) | Anzahl der Schreibvorgänge
WRITEPAGECOUNT | FIXED(20) | Anzahl der Seiten, die während des Schreibvorgangs geschrieben wurden
WRITETIME | FIXED(20) | Gesamtzeit der Schreibvorgänge mit aktiver Zeitmessung (µs)
WRITETIMEMEASUREMENTCOUNT | FIXED(20) | Anzahl der vermessenen Schreibvorgänge
PENDINGIOCOUNT | FIXED(5) | Anzahl der nicht unmittelbar ausführbaren (pending) I/O-Aufrufe
MAXPENDINGIOCOUNT | FIXED(5) | Maximale Anzahl I/O-Aufrufe, die nicht unmittelbar ausführbar waren
PATH | CHAR (256) | Name des Festplattenspeicherbereichs, auf dem die I/O-Aufrufe durchgeführt werden

Siehe auch:

IOTHREADSTATISTICSRESET


IOTHREADSTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation IOTHREADSTATISTICSRESET

Definition

Die Systemtabelle IOTHREADSTATISTICSRESET enthält Informationen über alle I/O-Vorgänge pro Volume seit dem letzten RESET IOTHREADSTATISTICS oder RESET ALL.

Struktur

IOTHREADSTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
VOLUMEID | FIXED(10) | Identifikation des Volume in der Laufzeitumgebung
READCOUNT | FIXED(20) | Anzahl der Lesevorgänge
READPAGECOUNT | FIXED(20) | Anzahl der Seiten, die während des Lesevorgangs gelesen wurden
READTIME | FIXED(20) | Gesamtzeit der Lesevorgänge mit aktiver Zeitmessung (µs)
READTIMEMEASUREMENTCOUNT | FIXED(20) | Anzahl der vermessenen Lesevorgänge
WRITECOUNT | FIXED(20) | Anzahl der Schreibvorgänge
WRITEPAGECOUNT | FIXED(20) | Anzahl der Seiten, die während des Schreibvorgangs geschrieben wurden
WRITETIME | FIXED(20) | Gesamtzeit der Schreibvorgänge mit aktiver Zeitmessung (µs)
WRITETIMEMEASUREMENTCOUNT | FIXED(20) | Anzahl der vermessenen Schreibvorgänge
PENDINGIOCOUNT | FIXED(5) | Anzahl der nicht unmittelbar ausführbaren (pending) I/O-Aufrufe
MAXPENDINGIOCOUNT | FIXED(5) | Maximale Anzahl I/O-Aufrufe, die nicht unmittelbar ausführbar waren
PATH | CHAR (256) | Name des Festplattenspeicherbereichs, auf dem die I/O-Aufrufe durchgeführt werden

Siehe auch:

IOTHREADSTATISTICS


LOCKLISTSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOCKLISTSTATISTICS

Definition

Die Statistik-Systemtabelle LOCKLISTSTATISTICS enthält Angaben über die Belegung der Sperrliste.

Struktur

LOCKLISTSTATISTICS

DESCRIPTION | CHAR(40) | Beschreibung (siehe Tabelle Spalte DESCRIPTION), wie der Inhalt der Spalte VALUE zu interpretieren ist
VALUE | CHAR(12) | Wert

Spalte DESCRIPTION

Wert | Erläuterung
MAX LOCKS | VALUE enthält die Anzahl der verfügbaren Sperren in der Sperrliste
TRANS LIST REGIONS | VALUE enthält die Anzahl der Semaphore für Transaktionen
TABLE LIST REGIONS | VALUE enthält die Anzahl der Semaphore für Tabellen
ROW LIST REGIONS | VALUE enthält die Anzahl der Semaphore für Zeilen
ENTRIES | VALUE enthält ein datenbankinternes Maß (Einträge) für die Größe der Sperrliste
USED ENTRIES | VALUE enthält die momentan benutzte Anzahl von Einträgen für gesetzte und angeforderte Sperren
USED ENTRIES (%) | VALUE enthält die momentan benutzte Anzahl von Einträgen für gesetzte und angeforderte Sperren in Prozent
AVG USED ENTRIES | VALUE enthält die durchschnittliche Anzahl von Einträgen für gesetzte und angeforderte Sperren
AVG USED ENTRIES (%) | VALUE enthält die durchschnittliche Anzahl von Einträgen für gesetzte und angeforderte Sperren in Prozent
MAX USED ENTRIES | VALUE enthält die maximale Anzahl von Einträgen für gesetzte und angeforderte Sperren
MAX USED ENTRIES (%) | VALUE enthält die maximale Anzahl von Einträgen für gesetzte und angeforderte Sperren in Prozent
LOCK ESCALATION VALUE | VALUE enthält die Anzahl von Tabellenzeilen, ab der Zeilensperren in eine Tabellensperre umgewandelt werden (Sperr-Eskalation)
LOCK ESCALATIONS | VALUE enthält die Anzahl von Sperr-Eskalationen
LOCK COLLISIONS | VALUE enthält die Anzahl von Sperranforderungen, die nicht (sofort) erfüllt werden konnten
DEADLOCKS | VALUE enthält die Anzahl von Situationen, in denen mindestens zwei Transaktionen aufgrund gehaltener und angeforderter Sperren so miteinander kollidiert sind, dass diese Kollision nur durch implizites Beenden einer Transaktion gelöst werden konnte
SQL REQUEST TIMEOUTS | VALUE enthält die Anzahl von Sperranforderungen, die nicht gesetzt werden konnten, weil sie die maximale Wartezeit überschritten hatten
TRANSACTIONS HOLDING LOCKS | VALUE enthält die Anzahl von Transaktionen, denen Sperren zugeordnet sind
TRANSACTIONS REQUESTING LOCKS | VALUE enthält die Anzahl von Transaktionen, die Sperren anfordern
CHECKPOINT WANTED | Wenn die Spalte VALUE den Wert TRUE besitzt, dann ist die Sperrliste geschlossen, d. h. einer Transaktion, die noch keine exklusive Sperre besitzt, kann keine exklusive Sperre zugeordnet werden, weil ein Checkpoint angefordert wurde
SHUTDOWN WANTED | Wenn die Spalte VALUE den Wert TRUE besitzt, dann ist die Sperrliste geschlossen, weil ein Shutdown angefordert wurde

Siehe auch:

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


LOCKS (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOCKS

Definition

Die Systemtabelle LOCKS beschreibt die aktuellen Sperreinträge und Einträge für Sperranforderungen.

Struktur

LOCKS

SESSION | FIXED(10) | Identifikation der Datenbanksitzung
TRANSCOUNT | CHAR(20) | Identifikation der Transaktion in der Datenbanksitzung
PROCESS | FIXED(10) | Identifikation des Prozesses in der Datenbankinstanz
USERNAME | CHAR(32) | Name des Benutzers
DATE | DATE(10) | Erzeugungsdatum der Sperre
TIME | TIME(8) | Erzeugungszeit der Sperre
TERMID | CHAR(18) | Identifikation des Benutzer-Terminals
LASTWRITE | CHAR(10) | Zeit, die seit der letzten SQL-Anweisung zur Datenmanipulation vergangen ist
LOCKMODE | CHAR(14) | Art der Sperre (NULL-Wert | SHARE | EXCLUSIVE)
LOCKSTATE | CHAR(10) | Status der Sperre
APPLPROCESS | FIXED(10) | Identifikation des Prozesses auf der Client-Hardware
APPLNODE | CHAR(64) | Identifikation der Client-Hardware
SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle
TABLEID | CHAR(8) BYTE | Identifikation der Tabelle
ROWIDLENGTH | FIXED(4) | Länge des Schlüssels der gesperrten Zeile
ROWIDHEX | CHAR(64) BYTE | Anfang des Schlüssels der gesperrten Zeile in hexadezimaler Darstellung
ROWID | CHAR(128) | Anfang des Schlüssels der gesperrten Zeile

Siehe auch:

Systemtabellen auswerten, LOCKS

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


LOCK_WAITS (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOCK_WAITS

Definition

Die Systemtabelle LOCK_WAITS beschreibt die Sperranforderungen.

Struktur

LOCK_WAITS

TABLENAME | CHAR(32) | Name der Tabelle
TABLEID | CHAR(8) BYTE | Identifikation der Tabelle
H_TERMID | CHAR(18) | Identifikation des Benutzer-Terminals, der die Sperre hält
H_PROCESS | FIXED(10) | Identifikation des Benutzer-Prozesses, der die Sperre hält
H_APPLPROCESS | FIXED(10) | Identifikation des Prozesses auf der Client-Hardware, der die Sperre hält
H_APPLNODE | CHAR(64) | Identifikation der Client-Hardware, auf der der Anwendungsprozess läuft, der die Sperre hält
H_ROWIDHEX | CHAR(64) BYTE | Anfang des Schlüssels der gesperrten Zeile in hexadezimaler Darstellung
H_ROWID | CHAR(128) | Anfang des Schlüssels der gesperrten Zeile
H_LOCKMODE | CHAR(14) | Art der Sperre (NULL-Wert | SHARE | EXCLUSIVE)
H_DATE | DATE(10) | Erzeugungsdatum der Sperre
H_TIME | TIME(8) | Erzeugungszeit der Sperre
H_LOCKTIMEOUT | CHAR(10) | Enthält immer den NULL-Wert
R_TERMID | CHAR(18) | Identifikation des Benutzer-Terminals, der die Sperre anfordert
R_PROCESS | FIXED(10) | Identifikation des Benutzer-Prozesses, der die Sperre anfordert
R_APPLPROCESS | FIXED(10) | Identifikation des Prozesses auf der Client-Hardware, der die Sperre anfordert
R_APPLNODE | CHAR(64) | Identifikation der Client-Hardware, auf der der Anwendungsprozess läuft, der die Sperre anfordert
R_ROWIDHEX | CHAR(64) BYTE | Anfang des Schlüssels der angeforderten Zeile in hexadezimaler Darstellung
R_ROWID | CHAR(128) | Anfang des Schlüssels der angeforderten Zeile
R_REQMODE | CHAR(14) | Art der Sperranforderung (NULL-Wert | SHARE | EXCLUSIVE)
R_DATE | DATE(10) | Erzeugungsdatum der Sperranforderung
R_TIME | TIME(8) | Erzeugungszeit der Sperranforderung
R_REQTIMEOUT | CHAR(10) | Zeit, die bis Ablauf des REQUEST_TIMEOUT verbleibt

Siehe auch:

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


LOGINFORMATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOGINFORMATION

Definition

Die Systemtabelle LOGINFORMATION beschreibt den Zustand der Log-Verwaltung.

Struktur

LOGINFORMATION

LOGVOLUMEENABLED | CHAR(3) | Log-Einträge werden in den Log-Bereich geschrieben (YES | NO)
AUTOMATICOVERWRITE | CHAR(3) | Überschreibmodus für den Log-Bereich ist eingeschaltet (YES | NO)
LOGWRITERSUSPENDED | CHAR(3) | Log-Schreiben auf Platte ist verhindert, um physikalische Plattensicherung zu ermöglichen (YES | NO)
FLUSHMODE | CHAR(20) | Kriterium, ob eine Seite mehrfach auf denselben Offset geschrieben werden darf oder nicht (MINIMIZE SPACE | MAXIMIZE SPACE)
DEVICESTATE | CHAR(20) | Zustand des Logs (OK | HISTROY LOST | CLEARED | CLEARING | PARTIALLY CLEARED | PARTIALLY CLEARING)
LOGFULL | CHAR(3) | Log-Bereich ist vollständig gefüllt (YES | NO)
PENDINGLOGSIZE | FIXED(20) | Größenangabe für den Log-Bereich, der neu definiert wurde, aber noch nicht aktiv ist

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


LOGQUEUESTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOGQUEUESTATISTICS

Definition

Die Systemtabelle LOGQUEUESTATISTICS gibt die Anzahl bestimmter Ereignisse in Zusammenhang mit dem Logging wieder, die pro Log-Warteschlange seit dem letzten Start der Datenbankinstanz gezählt wurden.

Struktur

LOGQUEUESTATISTICS

QUEUEID | FIXED(5) | Identifikation der Log-Warteschlange
QUEUEMAXUSED | FIXED(5) | Anzahl der Schreibtransaktionen
QUEUEINSERTCOUNT | FIXED(20) | Anzahl der Log-Einträge, die in die Log-Warteschlange eingefügt wurden
QUEUEOVERFLOWCOUNT | FIXED(10) | Anzahl der Wartesituationen, die aufgrund einer zu vollen Log-Warteschlange notwendig waren
GROUPCOMMITCOUNT | FIXED(10) | Anzahl der Log-Seiten, auf deren Schreiben mehr als eine Transaktion gewartet hat
WAITCOUNT | FIXED(10) | Anzahl von COMMIT-/ROLLBACK-Einträgen
MAXWAITCOUNTPERPAGE | FIXED(10) | Maximale Anzahl von Transaktionen, die gleichzeitig auf das Schreiben derselben Log-Seite gewartet haben
PHYSICALWRITECOUNT | FIXED(10) | Anzahl der Schreibvorgänge

Siehe auch:

Systemtabellen auswerten, LOGQUEUESTATISTICS

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


LOGQUEUESTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOGQUEUESTATISTICSRESET

Definition

Die Systemtabelle LOGQUEUESTATISTICSRESET gibt die Anzahl bestimmter Ereignisse in Zusammenhang mit dem Logging wieder, die pro Log-Warteschlange seit dem letzten RESET LOGQUEUESTATISTICS oder RESET ALL gezählt wurden.

Struktur

LOGQUEUESTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
QUEUEID | FIXED(5) | Identifikation der Log-Warteschlange
QUEUEMAXUSED | FIXED(5) | Anzahl der Schreibtransaktionen
QUEUEINSERTCOUNT | FIXED(20) | Anzahl der Log-Einträge, die in die Log-Warteschlange eingefügt wurden
QUEUEOVERFLOWCOUNT | FIXED(10) | Anzahl der Wartesituationen, die aufgrund einer zu vollen Log-Warteschlange notwendig waren
GROUPCOMMITCOUNT | FIXED(10) | Anzahl der Log-Seiten, auf deren Schreiben mehr als eine Transaktion gewartet hat
WAITCOUNT | FIXED(10) | Anzahl von COMMIT-/ROLLBACK-Einträgen
MAXWAITCOUNTPERPAGE | FIXED(10) | Maximale Anzahl von Transaktionen, die gleichzeitig auf das Schreiben derselben Log-Seite gewartet haben
PHYSICALWRITECOUNT | FIXED(10) | Anzahl der Schreibvorgänge

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


LOGSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOGSTATISTICS

Definition

Die Systemtabelle LOGSTATISTICS beschreibt den Nutzungsgrad der Log-Verwaltung und die Anzahl besonderer Ereignisse beim Logging seit dem letzten Start der Datenbankinstanz.

Struktur

LOGSTATISTICS

USABLESIZE | FIXED(20) | Größe des Log-Bereichs (KB)
USEDSIZE | FIXED(20) | Belegter Log-Bereich (KB)
USEDSIZEPERCENTAGE | FIXED(3) | Belegter Log-Bereich (%)
NOTSAVEDSIZE | FIXED(20) | Größe des noch nicht gesicherten Log-Bereichs (KB)
NOTSAVEDPERCENTAGE | FIXED(3) | Größe des noch nicht gesicherten Log-Bereichs (%)
SAVEPOINTCOUNT | FIXED(10) | Anzahl der Savepoints
TRANSACTIONCOUNT | FIXED(10) | Anzahl der Transaktionen
WRITETRANSACTIONCOUNT | FIXED(10) | Anzahl der Schreibtransaktionen
MAXUSEDSESSIONID | FIXED(10) | Höchste vergebene Identifikation einer Datenbanksitzung
MAXUSEDTRANSACTIONNUMBER | FIXED(15) | Höchste vergebene Identifikation einer Transaktion
QUEUECOUNT | FIXED(5) | Anzahl der Log-Warteschlangen
QUEUESIZE | FIXED(5) | Größe der Log-Warteschlange (KB)

Siehe auch:

Systemtabellen auswerten, LOGSTATISTICS

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


LOGSTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOGSTATISTICSRESET

Definition

Die Systemtabelle LOGSTATISTICSRESET beschreibt den Nutzungsgrad der Log-Verwaltung und die Anzahl besonderer Ereignisse beim Logging seit dem letzten RESET LOGSTATISTICS oder RESET ALL.

Struktur

LOGSTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
SAVEPOINTCOUNT | FIXED(10) | Anzahl der Savepoints
TRANSACTIONCOUNT | FIXED(10) | Anzahl der Transaktionen
WRITETRANSACTIONCOUNT | FIXED(10) | Anzahl der Schreibtransaktionen

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


LOGVOLUMES (SAP-Bibliothek - Grundwissen)

Objektdokumentation LOGVOLUMES

Definition

Die Systemtabelle LOGVOLUMES beschreibt die Log-Volumes, auf denen Log-Einträge gespeichert sind.

Struktur

LOGVOLUMES

ID | FIXED(5) | Nummer des Volume
CONFIGUREDSIZE | FIXED(20) | Konfigurierte Größe des Volume (KB)
USABLESIZE | FIXED(20) | Bereich des Volume, der für die Log-Einträge genutzt werden kann (KB)
PATH | CHAR(256) | Bezeichnung des Volume
MIRRORPATH | CHAR(256) | Bezeichnung des gespiegelten Volume NULL, wenn keine Spieglung erfolgt

Siehe auch:

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


MACHINECONFIGURATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation MACHINECONFIGURATION

Definition

Die Systemtabelle MACHINECONFIGURATION enthält Informationen zur Konfiguration des Rechners, auf dem der Datenbankkern installiert ist.

Struktur

MACHINECONFIGURATION

CPUNUMBER | FIXED(5) | Anzahl der CPUs
PHYSICALCPUNUMBER | FIXED(5) | Anzahl der vom Betriebssystem vergebenen Identifikation der physisch vorhandenen CPUs
PHYSICALMEMORYSIZE | FIXED(10) | Größe des physischen Speichers (MB)
VIRTUALMEMORYSIZE | FIXED(10) | Größe des virtuellen Speichers (MB)


MACHINEUTILIZATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation MACHINEUTILIZATION

Definition

Die Systemtabelle MACHINEUTILIZATION enthält Angaben zur Auslastung des Rechners, auf dem der Datenbankkern installiert ist.

Struktur

MACHINEUTILIZATION

PHYSICALMEMORYUSABLE | FIXED(10) | Größe des frei zur Verfügung stehenden physikalischen Speicherplatzes (MB)
VIRTUALMEMORYUSABLE | FIXED(10) | Größe des frei zur Verfügung stehenden virtuellen Speicherplatzes (MB)
PROCESSUSEDUSERTIME | FIXED(10) | Zeit, die der Prozess des Datenbankkerns seit dem Start der Datenbankinstanz im Benutzermodus verbracht hat (s)
PROCESSUSEDSYSTEMTIME | FIXED(10) | Zeit, die der Prozess des Datenbankkerns seit dem Start der Datenbankinstanz im Systemmodus verbracht hat (s)
MACHINEUSEDUSERTIME | FIXED(10) | Zeit, die der Rechner seit dem Start der Datenbankinstanz im Benutzermodus verbracht hat (s)
MACHINEUSEDSYSTEMTIME | FIXED(10) | Zeit, die der Rechner seit dem Start der Datenbankinstanz im Systemmodus verbracht hat (s)
MACHINEUSEDIDLETIME | FIXED(10) | Zeit, die der Rechner seit dem Start der Datenbankinstanz im Idle-Modus verbracht hat (s)
CPULOAD | CHAR(12) | CPU-Last auf dem Rechner


MAPCHARSETS (SAP-Bibliothek - Grundwissen)

Objektdokumentation MAPCHARSETS

Definition

Die Systemtabelle MAPCHARSETS enthält alle Mapchar-Sets.

Struktur

MAPCHARSETS

MAPCHARSETNAME | CHAR(32) | Name des Mapchar-Set
CODE | CHAR(8) | Codeattribut, für das das Mapchar-Set definiert wurde (ASCII | UNICODE)
INTERN | CHAR(2) BYTE | Originalform in hexadezimaler Darstellung
MAP_CODE | CHAR(4) BYTE | Zielform in hexadezimaler Darstellung
MAP_CHARACTER | CHAR(2) | Zielform in Klarschriftdarstellung

Siehe auch:

Systemtabellen auswerten, MAPCHARSETS

SQL-Referenzhandbuch, Mapchar-Set-Name (mapchar_set_name)


MEMORYALLOCATORSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation MEMORYALLOCATORSTATISTICS

Definition

Die Systemtabelle MEMORYALLOCATORSTATISTICS enthält Angaben über Zugriffe auf Allokatoren seit dem letzten Start der Datenbankinstanz.

Struktur

MEMORYALLOCATORSTATISTICS

ALLOCATORNAME | CHAR(40) | Name des Allokators
USEDSIZE | FIXED(20) | Vom Allokator zur Benutzung vergebene Menge an Speicher (Bytes)
MAXUSEDSIZE | FIXED(20) | Maximale vom Allokator zur Benutzung vergebene Menge an Speicher (Bytes)
ALLOCATEDSIZE | FIXED(20) | Vom Allokator reservierte Menge an Speicher (Bytes)
ALLOCATECOUNT | FIXED(20) | Anzahl von Speicherzuteilungen
DEALLOCATECOUNT | FIXED(20) | Anzahl von Speicherfreigaben
FAILEDALLOCATECOUNT | FIXED(20) | Anzahl nicht erfüllbarer Speicheranforderungen
FOUNDERRORCOUNT | FIXED(10) | Anzahl der im Allokator gefundenen und intern korrigierten Fehler
BASEALLOCATORNAME | CHAR(40) | Name des Allokators, der diesem Allokator Speicher zur Verfügung stellt
BASEALLOCATECOUNT | FIXED(20) | Anzahl von Speicherreservierungen beim Allokator BASEALLOCATORNAME
BASEDEALLOCATECOUNT | FIXED(20) | Anzahl von Speicherrückgaben an den Allokator BASEALLOCATORNAME


MONITOR (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR

Definition

Die Tabelle MONITOR ist die Vereinigung der Monitor-Systemtabellen MONITOR_CACHES, MONITOR_LOAD, MONITOR_LOCK, MONITOR_LOG, MONITOR_LONG, MONITOR_PAGES, MONITOR_REWRITE, MONITOR_ROW und MONITOR_TRANS.

Struktur

MONITOR

TYPE | CHAR(8)
DESCRIPTION | CHAR(40)
VALUE | FIXED(20)


MONITOR_CACHES (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_CACHES

Definition

Die Monitor-Systemtabelle MONITOR_CACHES enthält Informationen über durchgeführte Operationen auf den verschiedenen Caches.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
Data cache accesses | Anzahl von Zugriffen auf Seiten im Data-Cache (Summe der Zugriffe auf Datenseiten und Seiten mit Rollback-Informationen)
Data cache accesses successful | Anzahl erfolgreicher Zugriffe auf Seiten im Data-Cache
Data cache accesses unsuccessful | Anzahl erfolgloser Zugriffe auf Seiten im Data-Cache
Data cache hit rate (%) | Prozentsatz erfolgreicher Zugriffe auf Datenseiten im Data-Cache
Catalog cache accesses | Anzahl von Zugriffen auf den sitzungsspezifischen Catalog-Cache
Catalog cache accesses successful | Anzahl erfolgreicher Zugriffe auf den sitzungsspezifischen Catalog-Cache
Catalog cache accesses unsuccessful | Anzahl erfolgloser Zugriffe auf den sitzungsspezifischen Catalog-Cache
Catalog cache hit rate (%) | Prozentsatz erfolgreicher Zugriffe auf den sitzungsspezifischen Catalog-Cache
Sequence cache accesses | Anzahl von Zugriffen auf den Sequence-Cache
Sequence cache accesses successful | Anzahl erfolgreicher Zugriffe auf den Sequence-Cache
Sequence cache accesses unsuccessful | Anzahl erfolgloser Zugriffe auf den Sequence-Cache
Sequence cache hit rate (%) | Prozentsatz erfolgreicher Zugriff auf den Sequence-Cache
Data cache sqlpage accesses | Anzahl von Zugriffen auf Datenseiten im Data-Cache
Data cache sqlpage accesses successful | Anzahl erfolgreicher Zugriffe auf Datenseiten im Data-Cache
Data cache sqlpage accesses unsuccessful | Anzahl erfolgloser Zugriffe auf Datenseiten im Data-Cache
Data cache sqlpage hit rate(%) | Prozentsatz erfolgreicher Zugriffe auf Datenseiten im Data-Cache
Data history/undo accesses | Anzahl von Zugriffen auf Seiten mit Rollback-Informationen bzw. Informationen zum konsistenten Lesen im Data-Cache
Data history/undo accesses successful | Anzahl erfolgreicher Zugriffe auf Seiten mit Rollback-Informationen bzw. Informationen zum konsistenten Lesen im Data-Cache
Data history/undo accesses unsuccessful | Anzahl erfolgloser Zugriffe auf Seiten mit Rollback-Informationen bzw. Informationen zum konsistenten Lesen im Data-Cache
Data history/undo hit rate (%) | Prozentsatz erfolgreicher Zugriffe auf Seiten mit Rollback-Informationen bzw. Informationen zum konsistenten Lesen im Data-Cache

Die Systemtabelle MONITOR_CACHES existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle der Systemtabelle MONITOR_CACHES die Systemtabelle CACHESTATISTICS.

Siehe auch:

MONITOR


MONITOR_LOAD (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_LOAD

Definition

Die Monitor-Systemtabelle MONITOR_LOAD enthält Informationen über ausgeführte SQL-Anweisungen und Zugriffsmethoden.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
SQL commands | Anzahl ausgeführter SQL-Anweisungen
PREPAREs | Anzahl der geparsten SQL-Anweisungen
PREPAREs repeated | Anzahl der SQL-Anweisungen, die nach Änderung von Metadaten erneut geparst wurden
EXECUTEs | Anzahl der Ausführungen zuvor geparster SQL-Anweisungen
COMMITs | Anzahl ausgeführter COMMIT-Anweisungen
ROLLBACKs | Anzahl ausgeführter ROLLBACK-Anweisungen
LOCKs and UNLOCKs | Anzahl ausgeführter LOCK-Anweisungen und UNLOCK-Anweisungen
SUBTRANS BEGINs | Anzahl der SQL-Anweisungen zum Öffnen einer Subtransaktion
SUBTRANS ENDs | Anzahl der SQL-Anweisungen zum Schließen einer Subtransaktion
SUBTRANS ROLLBACKs | Anzahl der SQL-Anweisungen zum Zurücksetzen einer Subtransaktion
CREATEs | Anzahl ausgeführter SQL-Anweisungen zur Erzeugung von Datenbankobjekten
ALTERs | Anzahl ausgeführter SQL-Anweisungen zur Änderung von Datenbankobjekten
DROPs | Anzahl ausgeführter SQL-Anweisungen zum Löschen von Datenbankobjekten
SELECTs and FETCHes | Anzahl ausgeführter SQL-Anweisungen zum Zugriff auf Daten
SELECTs and FETCHes, rows read | Anzahl der Zeilen, die beim Zugriff auf Daten gelesen wurden
SELECTs and FETCHes, rows qual | Anzahl der Zeilen, die beim Zugriff auf Daten gelesen wurden und die Bedingungen erfüllten
INSERTs | Anzahl ausgeführter SQL-Anweisungen zum Einfügen von Zeilen
INSERTs, rows inserted | Anzahl eingefügter Zeilen
UPDATEs | Anzahl ausgeführter SQL-Anweisungen zum Ändern von Zeilen
UPDATEs, rows read | Anzahl der Zeilen, die bei Änderung von Daten gelesen wurden
UPDATEs, rows updated | Anzahl geänderter Zeilen
DELETEs | Anzahl ausgeführter SQL-Anweisungen zum Löschen von Zeilen
DELETEs, rows read | Anzahl der Zeilen, die beim Löschen von Daten gelesen wurden
DELETEs, rows deleted | Anzahl gelöschter Zeilen
Internal DBPROC calls | Anzahl der Ausführungen von Datenbankprozeduren
External DBPROC calls | Anzahl der externen Datenbankprozeduraufrufe
Internal trigger calls | Anzahl der Ausführungen von Triggern
External trigger calls | Anzahl der externen Triggeraufrufe
Primary key accesses | Anzahl der Suchvorgänge mit direktem Zugriff über den Schlüssel
Primary key accesses (IN strategy) | Anzahl der Suchvorgänge mit Zugriff über den Schlüssel und IN-Suchbedingung
Primary key accesses (SUBQ strategy) | Anzahl der Suchvorgänge mit Zugriff über den Schlüssel und Unterabfragen
Primary key accesses, rows read | Anzahl der Zeilen, die durch direkten Schlüsselzugriff gelesen wurden
Primary key accesses, rows qual | Anzahl der Zeilen, die durch direkten Schlüsselzugriff gelesen wurden und die Bedingung erfüllten
Primary key range accesses | Anzahl der Suchvorgänge mit Zugriffen innerhalb eines Schlüsselbereichs
Primary key range accesses, rows read | Anzahl gelesener Zeilen innerhalb eines Schlüsselbereichs
Primary key range accesses, rows qual | Anzahl gelesener Zeilen innerhalb eines Schlüsselbereichs, die die Bedingung erfüllten
Index accesses | Anzahl der Suchvorgänge mit Zugriffen auf einen Index
Index accesses (IN strategy) | Anzahl der Suchvorgänge mit Zugriffen auf einen Index und IN-Suchbedingungen
Index accesses (SUBQ strategy) | Anzahl der Suchvorgänge mit Zugriffen auf einen Index und Unterabfragen
Index scan | Anzahl der Indexdurchsuchungen
Index accesses, rows read | Anzahl der Zeilen, auf die indirekt über einen Index zugegriffen wurde
Index accesses, rows qual | Anzahl der Zeilen, auf die indirekt über einen Index zugegriffen wurde und die die Bedingung erfüllten
Index range accesses | Anzahl der Suchvorgänge unter Ausnutzung eines Indexbereichs
Index range accesses, rows read | Anzahl der Zeilen, auf die indirekt über einen Index unter Ausnutzung eines Indexbereichs zugegriffen wurde
Index range accesses, rows qual | Anzahl der Zeilen, die die Bedingung erfüllten, auf die indirekt über einen Index unter Ausnutzung eines Indexbereichs zugegriffen wurde
Isolated index accesses | Anzahl der Suchvorgänge, die ganz oder teilweise durch einen Index befriedigt werden konnten, ohne auf die Zeilen der Basistabelle zuzugreifen
Isolated index accesses (IN strategy) | Anzahl der Suchvorgänge gemäß IN-Suchstrategie, die ganz oder teilweise durch einen Index befriedigt werden konnten, ohne auf die Zeilen der Basistabelle zuzugreifen
Isolated index accesses (SUBQU strategy) | Anzahl der Suchvorgänge gemäß Unterabfrage-Strategie, die ganz oder teilweise durch einen Index befriedigt werden konnten, ohne auf die Zeilen der Basistabelle zuzugreifen
Isolated index accesses, rows read | Anzahl von Schlüsseln, auf die innerhalb der in ISOLATED INDEX ACCESSES bezeichneten Suchvorgänge zugegriffen wurde
Isolated index accesses, rows qual | Anzahl von Schlüsseln, auf die innerhalb der in ISOLATED INDEX ACCESSES bezeichneten Suchvorgänge zugegriffen wurde und die die Bedingung erfüllten
Isolated index range accesses | Anzahl von Suchvorgängen, in denen ein Teil eines Indexes mit Werten innerhalb eines Bereichs ausgenutzt wurde, ohne auf die Zeilen der Basistabelle zuzugreifen
Isolated index range accesses, rows read | Anzahl von Primär-/Sekundärschlüsseln, auf die innerhalb der durch ISOLATED INDEX RANGE ACCESSES bezeichneten Suchvorgänge zugegriffen wurde
Isolated index range accesses, rows qual | Anzahl von Primär-/Sekundärschlüsseln, auf die innerhalb der durch ISOLATED INDEX RANGE ACCESSES bezeichneten Suchvorgänge zugegriffen wurde und die die Bedingung erfüllten
Table scans | Anzahl von Suchvorgängen über die gesamte Basistabelle
Table scans, rows read | Anzahl von Zeilen, auf die innerhalb von Suchvorgängen über die gesamte Basistabelle zugegriffen wurde
Table scans, rows qual | Anzahl von Zeilen, auf die innerhalb von Suchvorgängen über die gesamte Basistabelle zugegriffen wurde und die die Bedingung erfüllten
Isolated index scans | Anzahl von Suchvorgängen, bei denen auf einen kompletten Index zugegriffen wurde, ohne auf Zeilen der Basistabelle zuzugreifen
Isolated index scans, rows read | Anzahl von Indexzeilen, auf die innerhalb der unter ISOLATED INDEX SCANS beschriebenen Suchvorgänge zugegriffen wurde
Isolated index scans, rows qual | Anzahl von Indexzeilen, auf die innerhalb der unter ISOLATED INDEX SCANS beschriebenen Suchvorgänge zugegriffen wurde und die die Bedingung erfüllten
Memory sorts / sort&merge | Anzahl von Sortiervorgängen im Hauptspeicher zum Aufbau von temporären Invertierungen
Memory sorts / sort&merge, rows read | Anzahl gelesener Zeilen zum Aufbau von temporären Invertierungen
Sorts by insertion | Anzahl von Sortiervorgängen durch Einfügen
Sorts by insertion, rows inserted | Anzahl von Zeilen, die im Verlauf des Sortiervorganges eingefügt wurden

Siehe auch:

MONITOR

Konzepte des Datenbanksystems, SQL-Optimierer

Suchbedingungen für Schlüsselspalten, Suchbedingungen für indizierte Spalten

SUBQ CONDITION FOR KEY, SUBQ CONDITION FOR INDEX


MONITOR_LOCK (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_LOCK

Definition

Die Monitor-Systemtabelle MONITOR_LOCK enthält Informationen über durchgeführte Operationen der Sperrverwaltung des Datenbanksystems.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
Lock list avg used entries | Durchschnittliche Anzahl von Einträgen der Sperrliste
Lock list max used entries | Maximale Anzahl von Einträgen der Sperrliste
Lock list collisions | Anzahl von Sperrkollisionen
Lock list escalations | Anzahl von Sperreskalationen
Lock list inserted row entries | Anzahl eingefügter Zeilensperren
Lock list inserted table entries | Anzahl eingefügter Tabellensperren
Detected deadlocks | Anzahl von Situationen, in denen mindestens zwei Transaktionen aufgrund gehaltener und angeforderter Sperren so miteinander kollidiert sind, dass diese Kollision nur durch implizites Beenden einer Transaktion gelöst werden konnte
Request timeouts | Anzahl von Sperranforderungen, die nicht gesetzt werden konnten, weil diese die maximale Wartezeit überschritten hatten

Siehe auch:

MONITOR

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte


MONITOR_LOG (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_LOG

Definition

Die Monitor-Systemtabelle MONITOR_LOG enthält Informationen über durchgeführte Operationen des Loggings des Datenbanksystems.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
Log page physical reads | Anzahl physisch gelesener Log-Seiten
Log page physical writes | Anzahl physisch geschriebener Log-Seiten
Log queue pages | Größe der Log-Warteschlange in Seiten
Log queue max used pages | Maximal genutzte Anzahl von Seiten der Log-Warteschlange
Log queue inserts | Anzahl von Einfügeoperationen in die Log-Warteschlange
Log queue overflows | Anzahl von Überläufen der Log-Warteschlange
Log queue group commits | Anzahl von Group-COMMITs
Log queue waits for log page write | Anzahl von Wartezuständen auf Log-Schreiboperationen
Log queue max waits per log page | Maximale Anzahl von Wartezuständen pro Log-Seite
Log queue avg waits per log page | Durchschnittliche Anzahl von Wartezuständen pro Log-Seite

Die Systemtabelle MONITOR_LOG existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle der Systemtabelle MONITOR_LOG die Systemtabelle LOGSTATISTICS.

Siehe auch:

MONITOR

Konzepte des Datenbanksystems, Protokollierung von Datenänderungen (Logging)


MONITOR_LONG (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_LONG

Definition

Die Monitor-Systemtabelle MONITOR_LONG enthält Informationen über Lese- und Schreibvorgänge für LONG-Spalten.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
BD read long | Anzahl von Lesevorgängen für LONG-Spalten
BD write long | Anzahl von Schreibvorgängen für LONG-Spalten

Siehe auch:

MONITOR


MONITOR_OMS (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_OMS

Definition

Die Systemtabelle MONITOR_OMS beschreibt die Aktivitäten der DB-Prozeduren (OMS-Prozeduren) seit dem letzten Restart.

Struktur

MONITOR_OMS

IID | CHAR(40) | Interface-Identifikation der Komponente, der die DB-Prozedur angehört
Methodname | CHAR(32) | Name der DB-Prozedur = Name der C++ Methode, die die DB-Prozedur implementiert
CallCnt | FIXED(10) | Anzahl der DB-Prozeduraufrufe
MinRuntime | FIXED(10) | Minimale Laufzeit pro DB-Prozeduraufruf (ms)
MaxRuntime | FIXED(10) | Maximale Laufzeit pro DB-Prozeduraufruf (ms)
AvgRuntime | FIXED(38,28) | Durchschnittliche Laufzeit pro DB-Prozeduraufruf (ms)
SumRuntime | FIXED(10) | Gesamtlaufzeit aller DB-Prozeduraufrufe
OMS_Deref | FIXED(20) | Anzahl der Objekt-Lesezugriffe, die über den OMS-Cache durchgeführt wurden
LC_Deref | FIXED(20) | Anzahl der Objekt-Lesezugriffe, die nicht durch den OMS-Cache befriedigt werden konnten
KeyDeref | FIXED(20) | Anzahl der Objekt-Schlüsselzugriffe
KeyDerefInVersion | FIXED(20) | Anzahl der Schlüsselzugriffe innerhalb einer OMS-Version
OMS_Store | FIXED(20) | Anzahl der Objekt-Änderungsmitteilungen im OMS-Cache
Lc_Store | FIXED(20) | Anzahl geänderter Objekte
OMS_Delete | FIXED(20) | Anzahl der Objekt-Löschmitteilungen im OMS-Cache
LC_Delete | FIXED(20) | Anzahl gelöschter Objekte
LC_Lock | FIXED(20) | Anzahl der Objekt-Sperranforderungen
DerefIter | FIXED(20) | Anzahl der Container-Scans
OMS_Release | FIXED(20) | Anzahl explizit freigegebener Objekte im OMS-Cache
OMS_ReleaseExecuted | FIXED(20) | Anzahl tatsächlich durchgeführter Objektfreigaben im OMS-Cache
LC_LogHops | FIXED(20) | Anzahl von History-Zugriffen, die durch Objekt-Lesezugriffe ausgelöst wurden
LC_LogHopsIter | FIXED(20) | Anzahl von History-Zugriffen, die durch Container-Scans ausgelöst wurden
Exceptions | FIXED(20) | Anzahl ausgegebener C++ Exceptions
OutOfDateExceptions | FIXED(20) | Anzahl der Exceptions, die durch Sperranforderungen auf nicht aktuelle Objekte ausgelöst wurden
Timeouts | FIXED(20) | Anzahl aufgetretener Zeitüberschreitungen bei Sperranforderungen
OutOfMemoryExceptions | FIXED(20) | Anzahl aufgetretener Speichermangelzustände
SubtransRollbacks | FIXED(20) | Anzahl rückgängig gemachter Subtransaktionen
SubtransCommits | FIXED(20) | Anzahl erfolgreich beendeter Subtransaktionen
MaxSubtransLevel | FIXED(20) | Maximale Subtransaktionstiefe
VarObjectLoad | FIXED(20) | Anzahl gelesener variabel langer Objekte
VarObjectStore | FIXED(20) | Anzahl geänderter variabel langer Objekte
AvgVarObjectSize | FIXED(20) | Durchschnittliche Länge eines variabel langen Objektes
OmsCacheSize | FIXED(20) | Speicherverbrauch der Komponenteninstanz
MaxWaitForNewConsView | FIXED(20) | Maximale Wartezeit auf Gewährung einer neuen konsistenten Sicht (s)
MinWaitForNewConsView | FIXED(20) | Minimale Wartezeit auf Gewährung einer neuen konsistenten Sicht (s)
AvgWaitForNewConsView | FIXED(20) | Durchschnittliche Wartezeit auf Gewährung einer neuen konsistenten Sicht (s)
MallocCnt | FIXED(20) | Anzahl der Speicheranforderungen
MallocMin | FIXED(20) | Kleinster angeforderter Speicherblock (Bytes)
MallocMax | FIXED(20) | Größter angeforderter Speicherblock (Bytes)
MallocAvg | FIXED(20) | Durchschnittliche Größe eines angeforderten Speicherblocks (Bytes)
FreeCnt | FIXED(20) | Anzahl der Speicherfreigaben
FreeMin | FIXED(20) | Kleinster freigegebener Speicherblock (Bytes)
FreeMax | FIXED(20) | Größter freigegebener Speicherblock (Bytes)
FreeAvg | FIXED(20) | Durchschnittliche Größe eines freigegebenen Speicherblocks (Bytes)
DeltaAllocMin | FIXED(20) | Minimale Speicherbedarfsveränderung eines Prozeduraufrufs
DeltaAllocMax | FIXED(20) | Maximale Speicherbedarfsveränderung eines Prozeduraufrufs
DeltaAllocAvg | FIXED(20) | Durchschnittliche Speicherbedarfsveränderung pro Prozeduraufruf
OMS_Terminate | FIXED(20) | Anzahl von Transaktionsabbrüchen aufgrund unvorhergesehener Fehler
MinStreamBufferReadReq | FIXED(20) | Minimale Anzahl von Kommunikationen zum Lesen von ABAP-Tabellen
MaxStreamBufferReadReq | FIXED(20) | Maximale Anzahl von Kommunikationen zum Lesen von ABAP-Tabellen
AvgStreamBufferReadReq | FIXED(20) | Durchschnittliche Anzahl von Kommunikationen zum Lesen von ABAP-Tabellen
MinStreamRowReads | FIXED(20) | Minimale Anzahl gelesener Zeilen von ABAP-Tabellen
MaxStreamRowReads | FIXED(20) | Maximale Anzahl gelesener Zeilen von ABAP-Tabellen
AvgStreamRowReads | FIXED(20) | Durchschnittliche Anzahl gelesener Zeilen von ABAP-Tabellen
MinStreamBufferWriteReq | FIXED(20) | Minimale Anzahl von Kommunikationen zum Schreiben von ABAP-Tabellen
MaxStreamBufferWriteReq | FIXED(20) | Maximale Anzahl von Kommunikationen zum Schreiben von ABAP-Tabellen
AvgStreamBufferWriteReq | FIXED(20) | Durchschnittliche Anzahl von Kommunikationen zum Schreiben von ABAP-Tabellen
MinStreamRowWrites | FIXED(20) | Minimale Anzahl geschriebener Zeilen von ABAP-Tabellen
MaxStreamRowWrites | FIXED(20) | Maximale Anzahl geschriebener Zeilen von ABAP-Tabellen
AvgStreamRowWrites | FIXED(20) | Durchschnittliche Anzahl geschriebener Zeilen von ABAP-Tabellen
OmsKeyCacheHit | FIXED(20) | Anzahl von Schlüsselzugriffen, die durch den Key-Cache befriedigt werden konnten
OmsKeyCacheMiss | FIXED(20) | Anzahl von Schlüsselzugriffen, die nicht durch den Key-Cache befriedigt werden konnten
OmsKeyVersion | FIXED(20) | Anzahl von Schlüsselobjekten, die innerhalb einer OMS-Version erzeugt wurden
OmsMaxChainLen | FIXED(20) | Maximale Listenlänge der OMS-Cache-Datenstruktur
OmsAvgChainLenSearched | FIXED(10,2) | Durchschnittliche Anzahl aufgesuchter Listenelemente der OMS-Cache-Datenstruktur zur Dereferenzierung eines Objektes
OmsRehash | FIXED(20) | Anzahl der Größenanpassungen der OMS-Cache-Datenstruktur
OmsLockObjWaits | FIXED(20) | Anzahl der Sperrkollisionen
OmsLockObjAvgWaitDelay | FIXED(20) | Durchschnittliche Wartezeit auf die Freigabe von Sperren (µs)

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink DB-Prozeduren, Strukturlink OMS-Monitor, Strukturlink Klassencontainer


MONITOR_PAGES (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_PAGES

Definition

Die Monitor-Systemtabelle MONITOR_PAGES enthält Informationen über Zugriffe auf die Seiten.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
Virtual reads | Anzahl virtueller Leseoperationen
Virtual writes | Anzahl virtueller Schreiboperationen
Physical reads | Anzahl physischer Leseoperationen
Physical writes | Anzahl physischer Schreiboperationen
Catalog virtual read | Anzahl virtueller Katalog-Leseoperationen
Catalog virtual writes | Anzahl virtueller Katalog-Schreiboperationen
Catalog physical reads | Anzahl physischer Katalog-Leseoperationen
Catalog physical writes | Anzahl physischer Katalog-Schreiboperationen
Perm page virtual reads | Anzahl virtuell gelesener permanenter Seiten
Perm page virtual writes | Anzahl virtuell geschriebener permanenter Seiten
Perm page physical reads | Anzahl physisch gelesener permanenter Seiten
Perm page physical writes | Anzahl physisch geschriebener permanenter Seiten
Temp page virtual reads | Anzahl virtuell gelesener temporärer Seiten
Temp page virtual writes | Anzahl virtuell geschriebener temporärer Seiten
Temp page physical reads | Anzahl physisch gelesener temporärer Seiten
Temp page physical writes | Anzahl physisch geschriebener temporärer Seiten
LONG page virtual reads | Anzahl virtuell gelesener Seiten für LONG-Spalten
LONG page virtual writes | Anzahl virtuell geschriebener Seiten für LONG-Spalten
LONG page physical reads | Anzahl physisch gelesener Seiten für LONG-Spalten
LONG page physical writes | Anzahl physisch geschriebener Seiten für LONG-Spalten
Leaf page virtual reads | Anzahl virtuell gelesener Blattseiten
Leaf page virtual writes | Anzahl virtuell geschriebener Blattseiten
Leaf page physical reads | Anzahl physisch gelesener Blattseiten
Leaf page physical writes | Anzahl physisch geschriebener Blattseiten
Level1 page virtual reads | Anzahl virtuell gelesener Indexseiten auf Stufe 1
Level1 page virtual writes | Anzahl virtuell geschriebener Indexseiten auf Stufe 1
Level1 page physical reads | Anzahl physisch gelesener Indexseiten auf Stufe 1
Level1 page physical writes | Anzahl physisch geschriebener Indexseiten auf Stufe 1
Level2 page virtual reads | Anzahl virtuell gelesener Indexseiten auf Stufe 2
Level2 page virtual writes | Anzahl virtuell geschriebener Indexseiten auf Stufe 2
Level2 page physical reads | Anzahl physisch gelesener Indexseiten auf Stufe 2
Level2 page physical writes | Anzahl physisch geschriebener Indexseiten auf Stufe 2
Level3 page virtual reads | Anzahl virtuell gelesener Indexseiten auf Stufe 3
Level3 page virtual writes | Anzahl virtuell geschriebener Indexseiten auf Stufe 3
Level3 page physical reads | Anzahl physisch gelesener Indexseiten auf Stufe 3
Level3 page physical writes | Anzahl physisch geschriebener Indexseiten auf Stufe 3
Level4 page virtual reads | Anzahl virtuell gelesener Indexseiten auf Stufe 4
Level4 page virtual writes | Anzahl virtuell geschriebener Indexseiten auf Stufe 4
Level4 page physical reads | Anzahl physisch gelesener Indexseiten auf Stufe 4
Level4 page physical writes | Anzahl physisch geschriebener Indexseiten auf Stufe 4
Level5 page virtual reads | Anzahl virtuell gelesener Indexseiten auf Stufe 5
Level5 page virtual writes | Anzahl virtuell geschriebener Indexseiten auf Stufe 5
Level5 page physical reads | Anzahl physisch gelesener Indexseiten auf Stufe 5
Level5 page physical writes | Anzahl physisch geschriebener Indexseiten auf Stufe 5
Converter page virtual reads | Immer 0
Converter page virtual writes | Immer 0
Converter page physical reads | Anzahl physisch gelesener Converter-Seiten
Converter page physical writes | Anzahl physisch geschriebener Converter-Seiten

Siehe auch:

MONITOR


MONITOR_REWRITE (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_REWRITE

Definition

Die Monitor-Systemtabelle MONITOR_REWRITE enthält Informationen darüber, welche Regeln des Query-Rewrite wie häufig angewendet wurden, um eine SQL-Anweisung zu vereinfachen.

Damit die Regeln von der Anwendung genutzt werden, muss der Datenbankparameter OPTIMIZE_QUERYREWRITE den Wert OPERATOR haben.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
EliminateOrderBy | Anzahl Verwendungen der Regel 'EliminateOrderBy'
MergeFromSelectOrView | Anzahl Verwendungen der Regel 'MergeFromSelectOrView'
MergeExistentialSubquery | Anzahl Verwendungen der Regel 'MergeExistentialSubquery'
ConvertExistentialSubquery | Anzahl Verwendungen der Regel 'ConvertExistentialSubquery'
ConvertToExistentialSubquery | Anzahl Verwendungen der Regel 'ConvertToExistentialSubquery'
DistinctPullUp | Anzahl Verwendungen der Regel 'DistinctPullUp'
DistinctPushDownTo | Anzahl Verwendungen der Regel 'DistinctPushDownTo'
DistinctPushDownFrom | Anzahl Verwendungen der Regel 'DistinctPushDownFrom'
DistinctForSubqueries | Anzahl Verwendungen der Regel 'DistinctForSubqueries'
SimplifyPredicates | Anzahl Verwendungen der Regel 'SimplifyPredicates'
EliminateGroupByOrDistinct | Anzahl Verwendungen der Regel 'EliminateGroupByOrDistinct'
PushDownPredicates | Anzahl Verwendungen der Regel 'PushDownPredicates'
PushDownProjection | Anzahl Verwendungen der Regel 'PushDownProjection'
PushDownQuantifier | Anzahl Verwendungen der Regel 'PushDownQuantifier'

Die Reihenfolge der Angaben in der Spalte DESCRIPTION kann sich verändern.

Siehe auch:

MONITOR

Konzepte des Datenbanksystems, Spezielle Datenbankparameter


MONITOR_ROW (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_ROW

Definition

Die Monitor-Systemtabelle MONITOR_ROW enthält Informationen über Operationen auf Zeilenniveau.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
BD add record perm | Anzahl eingefügter Zeilen in permanente Tabellen
BD add record temp | Anzahl eingefügter Zeilen in temporäre Tabellen
BD repl record perm | Anzahl geänderter Zeilen in permanenten Tabellen
BD repl record temp | Anzahl geänderter Zeilen in temporären Tabellen
BD del record perm | Anzahl gelöschter Zeilen aus permanenten Tabellen
BD del record temp | Anzahl gelöschter Zeilen aus temporären Tabellen
BD get record perm | Anzahl gelesener Zeilen aus permanenten Tabellen unter Angabe des Schlüssels
BD get record temp | Anzahl gelesener Zeilen aus temporären Tabellen unter Angabe des Schlüssels
BD next record perm | Anzahl gelesener Zeilen aus permanenten Tabellen unter Angabe des Vorgängerschlüssels
BD next record temp | Anzahl gelesener Zeilen aus temporären Tabellen unter Angabe des Vorgängerschlüssels
BD prev record perm | Anzahl gelesener Zeilen aus permanenten Tabellen unter Angabe des Nachfolgerschlüssels
BD prev record temp | Anzahl gelesener Zeilen aus temporären Tabellen unter Angabe des Nachfolgerschlüssels
BD select direct record | Anzahl von selektierten Zeilen unter Angabe des Schlüssels
BD select next record | Anzahl von selektierten Zeilen unter Angabe des Vorgängerschlüssels
BD select prev record | Anzahl von selektierten Zeilen unter Angabe des Nachfolgerschlüssels
BD add to index list perm | Anzahl von Einfügeoperationen in permanente Indizes
BD add to index list temp | Anzahl von Einfügeoperationen in temporäre Indizes
BD del from index list perm | Anzahl von Löschoperationen aus permanenten Indizes
BD del from index list temp | Anzahl von Löschoperationen aus temporären Indizes
BD get index list perm | Anzahl von Zugriffen auf permanente Indizes
BD get index list perm parallel | Anzahl von parallelen Zugriffen auf permanente Indizes
BD get index list temp | Anzahl von Zugriffen auf temporäre Indizes

Siehe auch:

MONITOR


MONITOR_TRANS (SAP-Bibliothek - Grundwissen)

Objektdokumentation MONITOR_TRANS

Definition

Die Monitor-Systemtabelle MONITOR_TRANS enthält Informationen über Transaktionen.

Struktur

Spalte DESCRIPTION

Wert | Erläuterung
SQL commands | Anzahl von SQL-Anweisungen
Write transactions | Anzahl von Transaktionen mit Änderungsoperationen
KB calls | Anzahl der Aufträgen über die interne Kommunikationsbasisschnittstelle

Siehe auch:

MONITOR


OBJECTLOCKS (SAP-Bibliothek - Grundwissen)

Objektdokumentation OBJECTLOCKS

Definition

Die Systemtabelle OBJECTLOCKS enthält Objektsperren und -sperranforderungen

Struktur

OBJECTLOCKS

OBJECTID | CHAR(25) | Identifikation des Objektes
HOLDERTASKID | FIXED(10) | Identifikation der Task, die die Sperre hält oder NULL, falls eine Anforderung beschrieben wird
REQUESTORTASKID | FIXED(10) | Task, die auf die Sperre wartet oder NULL, falls ein Sperrhalter beschrieben wird
LOCKMODE | CHAR(10) | Art der Sperre ( SHARE | EXCLUSIVE )
FILEID | FIXED(20) | Identifikation des Containers, der das durch OBJECTID identifizierte Objekt enthält


OMS_HEAP_STATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation OMS_HEAP_STATISTICS

Definition

Die Systemtabelle OMS_HEAP_STATISTICS beschreibt Zustände der in der SAP liveCache-Technologie benutzten Allokatoren.

Struktur

OMS_HEAP_STATISTICS

DESCRIPTION | CHAR(40) | Name des Allokators
TOTAL_HEAP_USAGE | FIXED(20) | Aktuell benutzter Speicher (Bytes)
MAXTOTAL_HEAP_USAGE | FIXED(20) | Maximal benutzter Speicher (Bytes)
RESERVED | FIXED(20) | Vom Allokator verwalteter Speicher (Bytes)
ALLOC_CNT | FIXED(20) | Anzahl der Speicherzuteilungen
FREE_CNT | FIXED(20) | Anzahl der Speicherfreigaben
SYSTEM_ALLOC_CNT | FIXED(20) | Anzahl der Speicherreservierungen beim zugrunde liegenden Allokator
SYSTEM_FREE_CNT | FIXED(20) | Anzahl der Speicherfreigaben beim zugrunde liegenden Allokator
TOTAL_SPINLOCKS | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten
COLLISIONS | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten
TOTAL_SPINLOOPS | FIXED(10) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten
TOTAL_YIELDLOOPS | FIXED(10) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten
MAX_SPINLOOPS | FIXED(10) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten
MAX_YIELDLOOPS | FIXED(10) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten
ERROR_CNT | FIXED(10) | Anzahl von Fehlern, die der Allokator festgestellt und selbständig korrigiert hat

Die Systemtabelle OMS_HEAP_STATISTICS ersetzt die Tabelle OMS_MEMORY_USAGE, die nicht mehr benutzt werden sollte.

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Heap-Verbrauch, Strukturlink Memory


OMS_LOCKOBJ_INFO (SAP-Bibliothek - Grundwissen)

Objektdokumentation OMS_LOCKOBJ_INFO

Definition

Die Systemtabelle OMS_LOCKOBJ_INFO enthält Informationen über Sperren, die über das OmsLockObject explizit gehalten oder angefordert werden.

Struktur

OMS_LOCKOBJ_INFO

PROCESS | FIXED(10) | Identifikation der Task, die die Sperre hält bzw. anfordert
SESSION | FIXED(10) | Identifikation der Sitzung, die die Sperre hält bzw. anfordert
USERNAME | CHAR(32) | Name des Benutzers, der die Sperre hält oder anfordert
TERMID | CHAR(18) | Identifikation des Terminals, das die verbundene Applikation nutzt
APPLPROCESS | FIXED(10) | Betriebssystem-Identifikation der verbundenen Applikation
APPLNODEID | CHAR(64) | Name des Rechners der remote verbundenen Applikation
LOCK_HANDLE | CHAR(8) BYTE | Benutzerdefinierte Identifikation der Sperre
LOCK_MODE | CHAR(14) | Art der Sperre (NULL | SHARE | EXCLUSIVE)
REQ_MODE | CHAR(14) | Art der Sperre im Falle einer Kollision mit Timeout-Wartesituationen (NULL | SHARE | EXCLUSIVE)
REQ_TIMEOUT | CHAR(10) | Verbleibende Zeit bis zum Timeout (s)

Siehe auch:

Konzepte des Datenbanksystems, Sperren für Datenbankobjekte

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink OMS-Sperren, Strukturlink OMS-Monitor


OMSLOCKS (SAP-Bibliothek - Grundwissen)

Objektdokumentation OMSLOCKS

Definition

Die Systemtabelle OMSLOCKS enthält vom Anwender explizit angeforderte Sperren.

Struktur

OMSLOCKS

ID | CHAR(8) BYTE | Identifikation des Sperrobjektes
TASKID | FIXED(10) | Identifikation der Task
LOCKREQUESTTIMEOUT | FIXED(10) | Timeout der Sperranforderung (s)
LOCKMODE | CHAR(18) | Art der Sperre (NULL-Wert | SHARE | EXCLUSIVE)
REQUESTMODE | CHAR(18) | Art der Sperranforderung (NULL-Wert | SHARE | EXCLUSIVE)


OMS_VERSIONS (SAP-Bibliothek - Grundwissen)

Objektdokumentation OMS_VERSIONS

Definition

Die Systemtabellen OMS_VERSIONS enthält Informationen über die aktuell vorhandenen OMS-Versionen.

Struktur

OMS_VERSIONS

OMS_VERSION_ID | CHAR(22) | Eindeutiger Name der Version
CREATE_DATE | DATE(10) | Erstellungsdatum der Version
CREATE_TIME | TIME(8) | Erstellungszeit der Version
TRANSVERSION | CHAR(6) BYTE | Konsistente Sicht, die der Version zugeordnet ist
MARKED | CHAR(1) | Flag, das von der Anwendung genutzt werden kann
AGE_IN_HOURS | FIXED(4) | Alter der Version in Stunden
UNLOADED | CHAR(3) | Angabe, ob die Version aus dem Speicher entladen ist
HEAP_USAGE | FIXED(20) | Größe des durch die Version belegten Speichers (Bytes)
PAGECOUNT | FIXED(20) | Anzahl der durch die Version belegten Seiten, falls diese entladen ist
VERSION_DESC | CHAR(512) | Beschreibung, die durch den Anwendung angegeben werden kann

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink OMS-Versionen


OPTIMIZERINFORMATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation OPTIMIZERINFORMATION

Definition

Die Systemtabelle OPTIMIZERINFORMATION enthält die durch die UPDATE STATISTICS-Anweisung bestimmten und vom SQL-Optimierer genutzten Angaben über Werteverteilungen.

Struktur

OPTIMIZERINFORMATION

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle
COLUMNNAME | CHAR(32) | Name einer einzelnen, nicht indizierten Spalte
INDEXNAME | CHAR(32) | Name des Index
DISTINCTVALUECOUNT | FIXED(10) | Anzahl verschiedener Werte in der Spalte, dem Index oder Primärschlüssel
CALCULATEDSIZE | FIXED(10) | Beim letzten UPDATE STATISTICS ermittelter Platzbedarf des (Primärschlüssel-) Index (KB)

Siehe auch:

SQL-Referenzhandbuch, UPDATE STATISTICS-Anweisung (update_statistics_statement), EXPLAIN-Anweisung (explain_statement)

Konzepte des Datenbanksystems, SQL-Optimierer

Datenbankverwaltung im CCMS, Strukturlink SQL-Optimierer im CCMS, Strukturlink Aktualisierung der SQL-Optimiererstatistiken einplanen


OPTIMIZERSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation OPTIMIZERSTATISTICS

Definition

Die im Datenbankkatalog abgelegten Statistikwerte, die durch eine UPDATE STATISTICS-Anweisung erzeugt wurden, können durch Selektieren der Systemtabelle OPTIMIZERSTATISTICS abgefragt werden. Jede Zeile der Tabelle beschreibt Statistikwerte über Indizes, Spalten oder Größe einer Tabelle.

Struktur

OPTIMIZERSTATISTICS

SCHEMANAME

CHAR(32)

Name des Schemas der Tabelle, über die Statistikinformationen vorliegen

OWNER

CHAR(32)

Name des Eigentümers der Tabelle, über die Statistikinformationen vorliegen

TABLENAME

CHAR(32)

Tabellenname der Tabelle, über die Statistikinformationen vorliegen

INDEXNAME

CHAR(32)

Indexname des Index, über den Statistikinformationen vorliegen

COLUMNNAME

CHAR(32)

Name einer Spalte, über die Statistikinformationen vorliegen

DISTINCTVALUES

FIXED(10)

Anzahl verschiedener Werte, falls die aktuelle Zeile eine Spalte oder einen einspaltigen Index beschreibt;
sonst die Anzahl der Zeilen einer Tabelle

PAGECOUNT

FIXED(10)

Anzahl der durch einen Index belegten Seiten, falls die aktuelle Zeile einen Index beschreibt;
Anzahl der Seiten einer Basistabelle, falls die aktuelle Zeile eine Tabelle beschreibt;
NULL-Wert sonst

Die Systemtabelle OPTIMIZERSTATISTICS existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle der Systemtabelle OPTIMIZERSTATISTICS die Systemtabelle OPTIMIZERINFORMATION.


PACKAGES (SAP-Bibliothek - Grundwissen)

Objektdokumentation PACKAGES

Definition

Die Systemtabelle PACKAGES beschreibt alle Pakete, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

PACKAGES

OWNER | CHAR(32) | Name des Eigentümers des Pakets
PACKAGE | CHAR(32) | Name des Pakets
CREATEDATE | DATE | Erzeugungsdatum des Pakets
CREATETIME | TIME | Erzeugungszeit des Pakets
EXCECUTION_KIND | CHAR(6) | Ausführungsort der Datenbankprozedur (INPROC | LOCAL)
SQL_SUPPORT | CHAR(3) | Datenbankprozedur darf SQL-Anweisungen enthalten (YES | NO)
REMOTE_LOCATION | CHAR(132) | Ausführungsort
FILE | CHAR(256) | Dateiname der Bibliothek, die die Implementierung dieses Pakets enthält
COMMENT | LONG | Kommentar zu dem Paket


POSTUPGRADECHECKLIST (SAP-Bibliothek - Grundwissen)

Objektdokumentation POSTUPGRADECHECKLIST

Definition

Die Systemtabelle POSTUPGRADECHECKLIST beschreibt Fehler, die während eines Upgrade aufgetreten sind, bei denen SQL-Anweisungen neu ausgeführt werden mussten (z.B. beim Versuch, eine View-Tabelle, einen Trigger oder eine Datenbankprozedur wieder anzulegen). Diese Fehler wurden während des Upgrade ignoriert.

Struktur

POSTUPGRADECHECKLIST

UPGRADETYPE | CHAR(40) | Typ des Upgrade (ImplicitUpgrade | CatalogToUnicode)
SCHEMANAME | CHAR(32) | Name des Schemas, dem das Objekt zugeordnet war, das nicht wiederhergestellt werden konnte
OWNER | CHAR(32) | Name des Eigentümers des Objekts, das nicht wiederhergestellt werden konnte
UPGRADEDATE | TIMESTAMP | Zeitpunkt, zu dem das Wiederherstellen des Objektes fehl schlug
ERRORNUMBER | INTEGER | Fehlercode, der beim Wiederherstellen auftrat
ERRORPOSITION | INTEGER | Fehlerposition in der Anweisung
STATEMENT | LONG | Text der fehlgeschlagenen SQL-Anweisung

Die Systemtabelle POSTUPGRADECHECKLIST ist nur für den Datenbanksystemadministrator sichtbar.

Nach einem Upgrade wird die bestehende Tabelle POSTUPGRADECHECKLIST in POSTUPGRADECHECKLIST<version> umbenannt und eine neue Tabelle POSTUPGRADECHECKLIST erzeugt.

Wenn ein Upgrade für eine UNICODE-Datenbankinstanz gemacht wird, werden die Upgrade-Informationen in der Tabelle POSTUPGRADECHECKLISTUNICODE abgelegt.

Siehe auch:

Upgrade


READERWRITERLOCKINFORMATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation READERWRITERLOCKINFORMATION

Definition

Die Systemtabelle READERWRITERLOCKINFORMATION beschreibt Reader-Writer-Locks.

Struktur

READERWRITERLOCKINFORMATION

READERWRITERLOCKADDRESS | CHAR(20) | Adresse im Speicher
SPINLOCKPOOLNAME | CHAR(40) | Name des verwendeten Spinlock-Pools
READERWRITERLOCKINDEX | FIXED(20) | Index innerhalb einer Gruppe von Reader-Writer-Locks, die den Spinlock-Pool nutzen
LASTENTEREDTASKID | FIXED(10) | Identifikation der Task, die als letzte Zugriff auf das Reader-Writer-Lock bekam


READERWRITERLOCKSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation READERWRITERLOCKSTATISTICS

Definition

Diese Systemtabelle READERWRITERLOCKSTATISTICS beschreibt kritische Abschnitte und deren Nutzung seit dem letzten Start der Datenbankinstanz.

Struktur

READERWRITERLOCKSTATISTICS

READERWRITERLOCKADDRESS | CHAR(20) | Adresse im Speicher
EXCLUSIVEACCESSCOUNT | FIXED(20) | Anzahl der exklusiven Zugriffe auf diesen kritischen Abschnitt
NONEXCLUSIVEACCESSCOUNT | FIXED(20) | Anzahl der nicht-exklusiven Zugriffe auf diesen kritischen Abschnitt
COLLISIONCOUNT | FIXED(20) | Anzahl der Kollisionen zwischen einer Task, die den kritischen Abschnitt belegt und einer anderen Task, die den kritischen Abschnitt anfordert
WAITCOUNT | FIXED(20) | Anzahl der Tasks, die auf Zugriff für diesen kritischen Abschnitt warten
SPINLOCKCOLLISIONCOUNT | FIXED(20) | Anzahl der Task-Kollisionen bei der Verwaltung des kritischen Abschnitts

Siehe auch:

READERWRITERLOCKSTATISTICSRESET


READERWRITERLOCKSTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation READERWRITERLOCKSTATISTICSRESET

Definition

Die Systemtabelle READERWRITERLOCKSTATISTICSRESET beschreibt die kritischen Abschnitte und deren Nutzung seit dem letzten RESET READERWRITERLOCKSTATISTICS oder RESET ALL.

Struktur

READERWRITERLOCKSTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
READERWRITERLOCKADDRESS | CHAR(20) | Adresse im Speicher
EXCLUSIVEACCESSCOUNT | FIXED(20) | Anzahl der exklusiven Zugriffe auf diesen kritischen Abschnitt
NONEXCLUSIVEACCESSCOUNT | FIXED(20) | Anzahl der nicht-exklusiven Zugriffe auf diesen kritischen Abschnitt
COLLISIONCOUNT | FIXED(20) | Anzahl der Kollisionen zwischen einer Task, die den kritischen Abschnitt belegt und einer anderen Task, die den kritischen Abschnitt anfordert
WAITCOUNT | FIXED(20) | Anzahl der Tasks, die auf Zugriff für diesen kritischen Abschnitt warten
SPINLOCKCOLLISIONCOUNT | FIXED(20) | Anzahl der Task-Kollisionen bei der Verwaltung des kritischen Abschnitts

Siehe auch:

READERWRITERLOCKSTATISTICS


READERWRITERLOCKWAITINGTASKS (SAP-Bibliothek - Grundwissen)

Objektdokumentation READERWRITERLOCKWAITINGTASKS

Definition

Die Systemtabelle READERWRITERLOCKWAITINGTASKS beschreibt Wartezustände auf Reader-Writer-Locks.

Struktur

READERWRITERLOCKWAITINGTASKS

READERWRITERLOCKADDRESS | CHAR(20) | Adresse im Speicher
WAITINGTASKID | FIXED(10) | Identifikation der Task, die auf den Reader-Writer-Lock wartet


REGIONINFORMATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation REGIONINFORMATION

Definition

Die Systemtabelle REGIONINFORMATION beschreibt zu einer Region die Tasks, die diese besitzen bzw. auf sie warten.

Struktur

REGIONINFORMATION

REGIONNAME | CHAR(16) | Name der Region
STATE | CHAR(10) | LOCKED: Task besitzt die Region REQUESTED: Task wartet auf die Region
TASKID | FIXED(10) | Identifikation der Task, die die Region besitzt oder auf diese wartet

Siehe auch:

Glossar, Kritischer Abschnitt


REGIONSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation REGIONSTATISTICS

Definition

Die Systemtabelle REGIONSTATISTICS enthält Angaben über Regionen und deren Nutzung seit dem Start des Datenbanksystems.

Struktur

REGIONSTATISTICS

REGIONNAME | CHAR(16) | Name der Region
REGIONID | FIXED(10) | Identifikation der Region
HOLDERTASKID | FIXED(10) | Identifikation der Task, die diese Region besitzt
REQUESTORCOUNT | FIXED(10) | Anzahl der Tasks, die auf die Region warten
ACCESSCOUNT | FIXED(20) | Anzahl der Zugriffe auf diese Region
SPINLOCKCOLLISIONCOUNT | FIXED(20) | Anzahl der Kollisionen mit einem internen Mechanismus während der Nutzung dieser Region
WAITCOUNT | FIXED(20) | Anzahl der Kollisionen, die dazu führen, dass die Warteschlange für diese Region verwendet wird
COLLISIONCOUNT | FIXED(20) | Anzahl der Kollisionen zwischen der Task, die die Region besitzt und einer anderen Task, die auf diese Region wartet
COLLISIONRATE | FIXED(10) | Anzahl der Zugriffe, die zu Kollisionen führten

Siehe auch:

Glossar, Kritischer Abschnitt

REGIONSTATISTICSRESET


REGIONSTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation REGIONSTATISTICSRESET

Definition

Die Systemtabelle REGIONSTATISTICSRESET enthält Angaben über Regionen und deren Nutzung seit dem letzten RESET REGIONSTATISTICS oder RESET ALL.

Struktur

REGIONSTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
REGIONNAME | CHAR(16) | Name der Region
ACCESSCOUNT | FIXED(20) | Anzahl der Zugriffe auf diese Region
SPINLOCKCOLLISIONCOUNT | FIXED(20) | Anzahl der Kollisionen mit einem internen Mechanismus während der Nutzung dieser Region
WAITCOUNT | FIXED(20) | Anzahl der Kollisionen, die dazu führen, dass die Warteschlange für diese Region verwendet wird
COLLISIONCOUNT | FIXED(20) | Anzahl der Kollisionen zwischen der Task, die die Region besitzt und einer anderen Task, die auf diese Region wartet
COLLISIONRATE | FIXED(10) | Anzahl der Zugriffe, die zu Kollisionen führten

Siehe auch:

Glossar, Kritischer Abschnitt

REGIONSTATISTICS


RESTARTINFORMATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation RESTARTINFORMATION

Definition

Die Systemtabelle RESTARTINFORMATION enthält alle für den Restart relevanten Informationen.

Struktur

RESTARTINFORMATION

BADINDEXCOUNT | FIXED(5) | Anzahl der Indizes, die erst nach einem Wiederanlegen zur Verfügung stehen
RESTARTCONVERTERVERSION | FIXED(10) | Für den Restart gültige Converter-Version
LASTSAVEPOINTID | FIXED(10) | Nummer des letzten Savepoints
LASTSAVEPOINTREASON | CHAR(20) | Grund für den Savepoint
LASTSAVEPOINTDATE | TIMESTAMP | Zeitpunkt des letzten Savepoints
OPENTRANSACTIONCOUNT | FIXED(10) | Anzahl der offenen Transkationen
OPENTRANSACTIONFILEROOT | FIXED(10) | Wurzel der Datei, die die offenen Transaktionen hält
HISTORYDIRECTORYROOT | FIXED(10) | Wurzel des History-Directory
FILEDIRECTORYROOT | FIXED(10) | Wurzel des Dateiverzeichnisses
LOBDIRECTORYROOT | FIXED(10) | Wurzel des Dateiverzeichnisses für LONG-Dateien
RESTARTIOSEQUENCE | FIXED(10) | Aufsetzpunkt für den Restart (Teil 1)
RESTARTOFFSETOFPAGEONVOLUME | FIXED(10) | Aufsetzpunkt für den Restart (Teil 2)
RESTARTOFFSETOFENTRYINPAGE | FIXED(10) | Aufsetzpunkt für den Restart (Teil 3)
RESTARTENTRYTYPE | CHAR(20) | Aufsetzpunkt für den Restart (Teil 4)
RESTARTENTRYDATE | TIMESTAMP | Zeitpunkt/Aufsetzpunkt für den Restart
CYCLERELATEDENDOFFSET | FIXED(10) | Letzte gültige Position im Log-Bereich, die beschrieben werden kann
LASTKNOWNSEQUENCE | FIXED(10) | Position der letzten bekannten Schreibposition im Log-Bereich (Teil 1)
LASTKNOWNOFFSET | FIXED(10) | Position der letzten bekannten Schreibposition im Log-Bereich (Teil 2)
DATABASEIDENTIFIER | CHAR(100) | Identifikation der Datenbankinstanz
LASTSAVEPOINTRELEASEVERSION | CHAR(40) | Version zum Zeitpunkt des letzten Savepoint
INSTALLSERVERDBVERSION | CHAR(40) | Version zum Zeitpunkt der Datenbankinstallation

Siehe auch:

Konzepte des Datenbanksystems, Beispiel: Restart


ROLEPRIVILEGES (SAP-Bibliothek - Grundwissen)

Objektdokumentation ROLEPRIVILEGES

Definition

Die Systemtabelle ROLEPRIVILEGES beschreibt die Privilegien und Rollen, die an Rollen vergeben wurden, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

ROLEPRIVILEGES

SCHEMANAME | CHAR(32) | Name des Schemas des Objekts, das an die Rolle vergeben wurde
OWNER | CHAR(32) | Name des Eigentümers des Objekts, das an die Rolle vergeben wurde
TABLENAME | CHAR(32) | Name der Tabelle, für die Privilegien an die Rolle vergeben wurden
ROLE | CHAR(32) | Name der Rolle, die vergeben wurde
GRANTEE | CHAR(32) | Name der Rolle, an die vergeben wurde
PRIVILEGES | CHAR(30) | Privilegien, die vergeben wurden
GRANTOR | CHAR(32) | Name des Benutzers, der die Privilegien oder die Rolle vergeben hat
CREATEDATE | DATE(10) | Datum der Privilegienvergabe
CREATETIME | TIME(8) | Zeit der Privilegienvergabe

Siehe auch:

Systemtabellen auswerten, ROLEPRIVILEGES

SQL-Referenzhandbuch, Rollenname (role_name), Privilegien: Überblick


ROLES (SAP-Bibliothek - Grundwissen)

Objektdokumentation ROLES

Definition

Die Systemtabelle ROLES beschreibt die Rollen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

ROLES

OWNER | CHAR(32) | Name des Eigentümers der Rolle
ROLE | CHAR(32) | Name der Rolle
PASSWORD_REQUIRED | CHAR(3) | Kennwort zur Aktivierung der Rolle erforderlich (YES | NO)
GRANTED | CHAR(3) | Rolle wurde an aktuellen Benutzer vergeben (YES | NO)
DEFAULTROLE | CHAR(3) | Rolle ist die vorgeschlagene Rolle für den aktuellen Benutzer (YES | NO)
CREATEDATE | DATE(10) | Erzeugungsdatum der Rolle
CREATETIME | TIME(8) | Erzeugungszeit der Rolle

Siehe auch:

Systemtabellen auswerten, ROLES

SQL-Referenzhandbuch, Rollenname (role_name), Privilegien: Überblick


SCHEMAPRIVILEGES (SAP-Bibliothek - Grundwissen)

Objektdokumentation SCHEMAPRIVILEGES

Definition

Die Systemtabelle SCHEMAPRIVILEGES beschreibt die Privilegien, die der aktuelle Benutzer für Schemas hat.

Struktur

SCHEMAPRIVILEGES

SCHEMANAME | CHAR(32) | Name des Schemas
GRANTEE | CHAR(32) | Name des Benutzers oder der Rolle, an die das Privileg vergeben wurde
GRANTOR | CHAR(32) | Name des Benutzers, der die Privilegien vergeben hat
CREATEIN | CHAR(3) | Privileg, Objekte in diesem Schema anzulegen (CREATEIN), wurde vergeben (YES | NO)
DROPIN | CHAR(3) | Privileg, Objekte in diesem Schema zu löschen (DROPIN), wurde vergeben (YES | NO)
ALTERIN | CHAR(3) | Privileg, Objekte in diesem Schema zu ändern (ALTERIN), wurde vergeben (YES | NO)
GRANTOPTION | CHAR(3) | Privileg, die erhaltenen Privilegien an andere Benutzer oder Rollen weiterzugeben, wurde vergeben (YES | NO)
GRANTDATE | DATE(10) | Datum der Privilegienvergabe
GRANTTIME | TIME(8) | Zeit der Privilegienvergabe

Siehe auch:

SQL-Referenzhandbuch, Schemaname (schema_name), Privilegien: Überblick


SCHEMAS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SCHEMAS

Definition

Die Systemtabelle SCHEMAS beschreibt die in der Datenbankinstanz bekannten Schemas.

Struktur

SCHEMAS

OWNER | CHAR(32) | Eigentümer des Schemas
SCHEMANAME | CHAR(32) | Name des Schemas
SCHEMAHANDLE | FIXED(10) | Identifikation des Schemas
CREATEDATE | DATE | Erzeugungsdatum des Schemas
CREATETIME | TIME | Erzeugungszeit des Schemas

Siehe auch:

SQL-Referenzhandbuch, Schemaname (schema_name)


SCHEMASIZE (SAP-Bibliothek - Grundwissen)

Objektdokumentation SCHEMASIZE

Definition

Die Systemtabelle SCHEMASIZE enthält Größeninformationen über Schemas.

Struktur

SCHEMASIZE

SCHEMANAME | CHAR(32) | Name des Schemas
USEDSIZE | FIXED(20) | Platzbedarf für Tabellen und Indizes, die zum Schema gehören (KB)

Siehe auch:

SCHEMAS

INDEXSIZE

TABLESIZE


SEQUENCEPRIVILEGES (SAP-Bibliothek - Grundwissen)

Objektdokumentation SEQUENCEPRIVILEGES

Definition

Die Systemtabelle SEQUENCEPRIVILEGES beschreibt die Privilegien, die der aktuelle Benutzer für Sequenzen besitzt oder die er vergeben hat.

Struktur

SEQUENCEPRIVILEGES

SCHEMANAME | CHAR(32) | Name des Schemas der Sequenz
OWNER | CHAR(32) | Name des Eigentümers der Sequenz
SEQUENCENAME | CHAR(32) | Name der Sequenz
GRANTOR | CHAR(32) | Name des Benutzers, der die Privilegien vergeben hat
GRANTEE | CHAR(32) | Name des Benutzers oder der Rolle, an die das Privileg vergeben wurde
PRIVILEGE | CHAR(30) | Privilegien, die vergeben wurden
IS_GRANTABLE | CHAR(3) | Privileg, das erhaltene Privileg weiterzugeben (YES | NO)

Siehe auch:

SQL-Referenzhandbuch, Sequenzname (sequence_name), Privilegien: Überblick


SEQUENCES (SAP-Bibliothek - Grundwissen)

Objektdokumentation SEQUENCES

Definition

Die Systemtabelle SEQUENCES enthält alle Sequenzen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

SEQUENCES

SCHEMANAME | CHAR(32) | Name des Schemas der Sequenz
OWNER | CHAR(32) | Name des Eigentümers der Sequenz
SEQUENCE_NAME | CHAR(32) | Name der Sequenz
MIN_VALUE | FIXED(38) | Minimalwert der Sequenz
MAX_VALUE | FIXED(38) | Maximalwert der Sequenz
INCREMENT_BY | FIXED(38) | Wert, um den die Sequenz erhöht wird
CYCLE_FLAG | CHAR(1) | Angabe. ob die Sequenz erneut beim Minimalwert beginnt, nachdem der Maximalwert erreicht wurde (N | Y)
ORDER_FLAG | CHAR(1) | Angabe, ob die Sequenzwerte in der Reihenfolge der Anforderung vergeben werden (Y | N)
CACHE_SIZE | FIXED(38) | Anzahl der Sequenzwerte, die gleichzeitig in den Cache geladen werden
LAST_NUMBER | FIXED(38) | Letzter Sequenzwert, der gespeichert wurde
CREATEDATE | DATE(10) | Erzeugungsdatum der Sequenz
CREATETIME | TIME(8) | Erzeugungszeit der Sequenz
COMMENT | LONG | Kommentar zur Sequenz

Siehe auch:

Systemtabellen auswerten, SEQUENCES

SQL-Referenzhandbuch, Sequenzname (sequence_name)


SERVERDBSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SERVERDBSTATISTICS

Definition

Die Statistik-Systemtabelle SERVERDBSTATISTICS enthält Angaben über die Belegung der Datenbankinstanz.

Struktur

SERVERDBSTATISTICS

SERVERDBSIZE | FIXED(10) | Größe der Datenbankinstanz in Seiten
MAXDATAPAGENO | FIXED(10) | Höchste Seitennummer der Datenbankinstanz
MAXPERM | FIXED(10) | Anzahl von Seiten der Datenbankinstanz, die für nicht temporäre Objekte nutzbar sind
MAXUSEDPAGES | FIXED(10) | Maximale Anzahl benutzter Seiten zu einem Synchronisationszeitpunkt (Restart bzw. Savepoint)
USEDPERM | FIXED(10) | Anzahl der Seiten der Datenbankinstanz, die für nicht temporäre Objekte belegt sind
PCTUSEDPERM | FIXED(10) | Prozentualer Anteil der Seiten für nicht temporäre Objekte
USEDTMP | FIXED(10) | Anzahl der Seiten der Datenbankinstanz, die für temporäre Objekte belegt sind
PCTUSEDTMP | FIXED(10) | Prozentualer Anteil der Seiten für temporäre Objekte
UNUSED | FIXED(10) | Anzahl nicht belegter Seiten
PCTUNUSED | FIXED(10) | Prozentualer Anteil nicht belegter Seiten
UPDATEDPERM | FIXED(10) | Anzahl geänderter Seiten für permanente Objekte
SERVERDBFULL | CHAR(3) | YES: maximaler Füllungsgrad der Datenbankinstanz ist erreicht NO: maximaler Füllungsgrad der Datenbankinstanz ist nicht erreicht
USEDBLOCKS | FIXED(10) | Anzahl von Blöcken auf Data-Volumes, die mit Seiten belegt sind
LOGSIZE | FIXED(10) | Größe des Log-Bereichs in Seiten
USEDLOG | FIXED(10) | Anzahl benutzter Log-Seiten
PCTUSEDLOG | FIXED(10) | Prozentualer Anteil benutzter Log-Seiten
LOGNOTSAVED | FIXED(10) | Anzahl noch nicht gesicherter Log-Seiten
PCTLOGNOTSAVED | FIXED(10) | Prozentualer Anteil noch nicht gesicherter Log-Seiten
LOGSINCEBACKUP | FIXED(10) | Anzahl geschriebener Log-Seiten seit der letzten vollständigen oder inkrementellen Datensicherung
LOGSEGMENTSIZE | FIXED(10) | Größe eines Log-Segments in Seiten
SAVEPOINTS | FIXED(10) | Anzahl durchgeführter Savepoints
CHECKPOINTS | FIXED(10) | 0 (Die Anzahl der Checkpoints ist immer auf 0 gesetzt.)

Die Systemtabelle SERVERDBSTATISTICS existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle der Systemtabelle SERVERDBSTATISTICS die Systemtabellen DATASTATISTICS und LOGSTATISTICS.


SERVERTASKS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SERVERTASKS

Definition

Die Systemtabelle SERVERTASKS beschreibt die Tasks, die für die parallele Bearbeitung von SQL-Anweisungen intern genutzt werden.

Struktur

SERVERTASKS

TASKID | FIXED(10) | Identifikation der Server-Task
ISASSIGNED | CHAR(3) | Angabe, ob eine Server-Task registriert ist (YES | NO)
ISRESERVED | CHAR(3) | Angabe, ob eine Server-Task für eine Aufgabe reserviert wurde (YES | NO)
LASTJOBDESCRIPTION | CHAR(32) | Beschreibung, wofür eine reservierte Server-Task verwendet wird

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Tasks


SESSION_ROLES (SAP-Bibliothek - Grundwissen)

Objektdokumentation SESSION_ROLES

Definition

Die Systemtabelle SESSION_ROLES enthält die Rollen, die in der aktuellen Datenbanksitzung aktiv sind.

Struktur

SESSION_ROLES

ROLE

CHAR(32)

Name der Rolle

Siehe auch:

Systemtabellen auswerten, SESSION_ROLES

SQL-Referenzhandbuch, Rollenname (role_name)


SESSIONS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SESSIONS

Definition

Die Systemtabelle SESSIONS beschreibt die Verbindung zwischen einer Anwendung und einer Datenbank-Task.

Struktur

SESSIONS

SESSIONID | FIXED(10) | Identifikation der Datenbanksitzung
OWN | CHAR(3) | Aktuelle Datenbanksitzung (YES | NO)
SESSIONTYPE | CHAR(4) | Angabe des Datenbankinstanztyps (OLTP | LVC) OLTP: Datenbankinstanztyp OLTP LVC: SAP liveCache-Technologie
ENCRYPTION | CHAR(3) | Angabe, ob zur Datenverschlüsselung SSL verwendet wird (SSL | NO) SSL: Datenverschlüsselung mittels SSL NO: keine Datenverschlüsselung mittels SSL
STARTDATE | TIMESTAMP | Startzeitpunkt der Datenbanksitzung
APPLICATIONNODE | CHAR(64) | Name des Rechners, auf dem die Anwendung läuft
APPLICATIONPROCESS | FIXED(10) | Betriebssystem-Identifikation der Anwendung
APPLICATIONTYPE | CHAR(3) | Identifikation des Werkzeugs oder Interface, das die Anwendung verwendet
USERNAME | CHAR(32) | Name des Datenbankbenutzers
PEERPROCESSID | FIXED(10) | Identifikation des Kommunikationspartners der Datenbank-Task
CONNECTSTATE | CHAR(32) | Status der Verbindung
TASKID | FIXED(10) | Identifikation der Datenbank-Task
OMSHEAPUSEDSIZE | FIXED(20) | Speicherverbrauch im OMS-Heap (KB)
TRACE | CHAR(3) | Ein Datenbank-Trace wird für diese Datenbanksitzung/alle Datenbanksitzungen geschrieben (YES | NO)
CATALOGCACHEUSEDSIZE | FIXED(10) | Platzverbrauch des der Datenbanksitzung zugeordneten Catalog-Cache (KB)
USEDTEMPORARYSIZE | FIXED(10) | Platzverbrauch für temporäre Informationen der eigenen Datenbanksitzung (KB)
PAGINGFILEUSEDSIZE | FIXED(10) | Größe der Auslagerungsdatei, in die die Informationen geschrieben werden, die aus dem Catalog-Cache verdrängt werden (KB)
SQLMODE | CHAR(8) | SQL-Modus der eigenen Datenbanksitzung (ANSI | DB2 | ORACLE | INTERNAL)
ISOLATIONLEVEL | FIXED(3) | Isolation-Level der eigenen Datenbanksitzung (0-3)
TIMEOUT | FIXED(10) | Timeout-Wert der eigenen Datenbanksitzung
DATEFORMAT | CHAR(50) | Datums- und Zeitformat der eigenen Datenbanksitzung
DEFAULTCODE | CHAR(8) | Vorschlagswert für Codeattribut der Datenbanksitzung

Siehe auch:

Systemtabellen auswerten, SESSIONS

Dokumentation Konzepte des Datenbanksystems

Glossar, OMS-Heap, SSL/TLS


SNAPSHOTS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SNAPSHOTS

Definition

Die Systemtabelle SNAPSHOTS enthält Angaben über eine definierte Sicht (Snapshot) auf den Datenbestand.

Struktur

SNAPSHOTS

ID | FIXED(10) | Aktuelle Converter-Version zum Zeitpunkt der Definition des Snapshot
CREATEDATE | TIMESTAMP | Zeitpunkt der Definition des Snapshot
USEDSIZE | FIXED(20) | Für den Snapshot genutzte Menge von Daten (KB)

Siehe auch:

Konzepte des Datenbanksystems, Datenbereich einfrieren (Snapshot)


SPINLOCKPOOLSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SPINLOCKPOOLSTATISTICS

Definition

Die Systemtabelle SPINLOCKPOOLSTATISTICS beschreibt zu Pools zusammengefaßte interne Sperrmechanismen und darauf ausgeführte Aktionen seit dem letzten Start der Datenbankinstanz.

Struktur

SPINLOCKPOOLSTATISTICS

SPINLOCKPOOLNAME | CHAR(40) | Name des Spinlock-Pool
MAXLOCKCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten – Maximalwert innerhalb des Pool
MINLOCKCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten – Minimalwert innerhalb des Pool
AVGLOCKCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten – Durchschnittswert innerhalb des Pool
MAXCOLLISIONCOUNT | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten – Maximalwert innerhalb des Pool
MINCOLLISIONCOUNT | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten – Minimalwert innerhalb des Pool
AVGCOLLISIONCOUNT | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten – Durchschnittswert innerhalb des Pool
MAXTOTALSPINLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Maximalwert innerhalb des Pool
MINTOTALSPINLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Minimalwert innerhalb des Pool
AVGTOTALSPINLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Durchschnittswert innerhalb des Pool
MAXTOTALYIELDLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Maximalwert innerhalb des Pool
MINTOTALYIELDLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Minimalwert innerhalb des Pool
AVGTOTALYIELDLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Durchschnittswert innerhalb des Pool
MAXMAXSPINLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Maximalwert innerhalb des Pool
MINMAXSPINLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Minimalwert innerhalb des Pool
AVGMAXSPINLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Durchschnittswert innerhalb des Pool
MAXMAXYIELDLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Maximalwert innerhalb des Pool
MINMAXYIELDLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Minimalwert innerhalb des Pool
AVGMAXYIELDLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Durchschnittswert innerhalb des Pool

Siehe auch:

SPINLOCKPOOLSTATISTICSRESET


SPINLOCKPOOLSTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation SPINLOCKPOOLSTATISTICSRESET

Definition

Die Systemtabelle SPINLOCKPOOLSTATISTICSRESET beschreibt zu Pools zusammengefasste interne Sperrmechanismen und darauf ausgeführte Aktionen seit dem letzten RESET SPINLOCKPOOLSTATISTICS oder RESET ALL.

Struktur

SPINLOCKPOOLSTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
SPINLOCKPOOLNAME | CHAR(40) | Name des Spinlock-Pool
MAXLOCKCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten – Maximalwert innerhalb des Pool
MINLOCKCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten – Minimalwert innerhalb des Pool
AVGLOCKCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten – Durchschnittswert innerhalb des Pool
MAXCOLLISIONCOUNT | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten – Maximalwert innerhalb des Pool
MINCOLLISIONCOUNT | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten – Minimalwert innerhalb des Pool
AVGCOLLISIONCOUNT | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten – Durchschnittswert innerhalb des Pool
MAXTOTALSPINLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Maximalwert innerhalb des Pool
MINTOTALSPINLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Minimalwert innerhalb des Pool
AVGTOTALSPINLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Durchschnittswert innerhalb des Pool
MAXTOTALYIELDLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Maximalwert innerhalb des Pool
MINTOTALYIELDLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Minimalwert innerhalb des Pool
AVGTOTALYIELDLOOPCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Durchschnittswert innerhalb des Pool
MAXMAXSPINLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Maximalwert innerhalb des Pool
MINMAXSPINLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Minimalwert innerhalb des Pool
AVGMAXSPINLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten – Durchschnittswert innerhalb des Pool
MAXMAXYIELDLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Maximalwert innerhalb des Pool
MINMAXYIELDLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Minimalwert innerhalb des Pool
AVGMAXYIELDLOOPCOUNT | FIXED(20) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten – Durchschnittswert innerhalb des Pool

Siehe auch:

SPINLOCKPOOLSTATISTICS


SPINLOCKSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SPINLOCKSTATISTICS

Definition

Die Systemtabelle SPINLOCKSTATISTICS enthält Angaben über interne Sperrmechanismen seit dem letzten Start des Datenbanksystems.

Struktur

SPINLOCKSTATISTICS

NAME | CHAR(40) | Name des Spinlock
LOCKCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten
COLLISIONCOUNT | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten
SPINLOOPCOUNT | FIXED(10) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten
YIELDLOOPCOUNT | FIXED(10) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten
MAXSPINLOOPCOUNT | FIXED(10) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten
MAXYIELDLOOPCOUNT | FIXED(10) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten

Siehe auch:

SPINLOCKSTATISTICSRESET


SPINLOCKSTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation SPINLOCKSTATISTICSRESET

Definition

Die Systemtabelle SPINLOCKSTATISTICSRESET enthält Angaben über interne Sperrmechanismen seit dem letzten RESET SPINLOCKSTATISTICS oder RESET ALL.

Struktur

SPINLOCKSTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
NAME | CHAR(40) | Name des Spinlock
LOCKCOUNT | FIXED(20) | Anzahl der Versuche, den Spinlock zu erhalten
COLLISIONCOUNT | FIXED(20) | Anzahl fehlgeschlagener Versuche, den Spinlock zu erhalten
SPINLOOPCOUNT | FIXED(10) | Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten
YIELDLOOPCOUNT | FIXED(10) | Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten
MAXSPINLOOPCOUNT | FIXED(10) | Maximale Anzahl der Versuche, den Spinlock ohne vorherige Freigabe der CPU zu erhalten
MAXYIELDLOOPCOUNT | FIXED(10) | Maximale Anzahl der Versuche, den Spinlock nach vorheriger Freigabe der CPU zu erhalten

Siehe auch:

SPINLOCKSTATISTICS


SYNONYMS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SYNONYMS

Definition

Die Systemtabelle SYNONYMS enthält alle Synonyme, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

SYNONYMS

OWNER | CHAR(32) | Name des Eigentümers des Synonyms
SYNONYMNAME | CHAR(32) | Name des Synonyms
PUBLIC | CHAR(3) | Synonym ist PUBLIC (YES | NO)
TABLESCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
TABLEOWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle
CREATEDATE | DATE(10) | Erzeugungsdatum des Synonyms
CREATETIME | TIME(8) | Erzeugungszeit des Synonyms
COMMENT | LONG | Kommentar zu dem Synonym

Siehe auch:

Systemtabellen auswerten, SYNONYMS

SQL-Referenzhandbuch, Synonymname (synonym_name)


SYSTEMTRIGGERS (SAP-Bibliothek - Grundwissen)

Objektdokumentation SYSTEMTRIGGERS

Definition

Die Systemtabelle SYSTEMTRIGGERS enthält alle System-Trigger, die der aktuelle Benutzer angelegt hat.

Struktur

SYSTEMTRIGGERS

SCHEMANAME | CHAR(32) | Name des Schemas des System-Trigger
TRIGGERNAME | CHAR(32) | Name des System-Trigger
OWNER | CHAR(32) | Name des Eigentümers des System-Trigger
CREATEDATE | DATE(10) | Anlegedatum des System-Trigger
CREATETIME | TIME(8) | Anlegezeit des System-Trigger
DEFINITION | LONG | SQL-Anweisung, um den System-Trigger anzulegen
COMMENT | LONG | Kommentar zum System-Trigger

Siehe auch:

SQL-Referenzhandbuch, CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement


SYSUPDATECOUNTERWANTED (SAP-Bibliothek - Grundwissen)

Objektdokumentation SYSUPDATECOUNTERWANTED

Definition

Die Systemtabelle SYSUPDATECOUNTERWANTED zeigt die Tabellen und Indizes an, für die die Statistikzähler im Dateiverzeichnis initialisiert werden sollen.

Struktur

SYSUPDATECOUNTERWANTED

SCHEMANAME | CHAR(32) | Name des Schemas
TABLENAME | CHAR(32) | Name der Tabelle
INDEXNAME | CHAR(32) | Name des Index
CANCELCOUNT | FIXED(5) | Zähler, wie oft der Versuch, die Statistiken dieses Objektes zu aktualisieren, abgebrochen wurde

Siehe auch:

FILES

Glossar, Dateiverzeichnis


SYSUPDSTATWANTED (SAP-Bibliothek - Grundwissen)

Objektdokumentation SYSUPDSTATWANTED

Definition

Die Systemtabelle SYSUPDSTATWANTED enthält Einträge zu den Tabellen, für die ein UPDATE STATISTICS-Lauf sinnvoll ist.

Struktur

SYSUPDSTATWANTED

SCHEMANAME | CHAR(32) | Name des Schemas
OWNER | CHAR(32) | Name des Eigentümers
TABLENAME | CHAR(32) | Name der Tabelle
COLUMNNAME | CHAR(32) | Name der Spalte

Der Datenbankkern trägt in die Systemtabelle SYSUPDSTATWANTED die Tabellen(spalten) ein, für die ein UPDATE STATISTICS-Lauf zweckmäßig erscheint.

Wenn Sie die SQL-Anweisung UPDATE STATISTICS AS PER SYSTEM TABLE verwenden, wird für alle in der Tabelle SYSUPDSTATWANTED enthaltenen Tabellen(spalten) ein UPDATE STATISTICS-Lauf ausgelöst. Anschließend werden die Einträge aus der Tabelle SYSUPDSTATWANTED gelöscht.

Die Systemtabelle SYSUPDSTATWANTED kann ebenfalls durch Datenbankadministratoren geändert werden. Allerdings kann ein Datenbankadministrator nur solche Einträge einfügen, die sich auf Tabellen beziehen, dessen Eigentümer dieser Datenbankadministrator ist.

Siehe auch:

SQL-Referenzhandbuch, UPDATE STATISTICS-Anweisung (update_statistics_statement)


SYSUPGRADEHISTORY (SAP-Bibliothek - Grundwissen)

Objektdokumentation SYSUPGRADEHISTORY

Definition

Die Systemtabelle SYSUPGRADEHISTORY zeigt an, mit welcher Version der Datenbanksoftware welche Komponente wann einen impliziten Upgrade durchführen musste bzw. wann ein erfolgreiches Laden der Systemtabellen unter Verwendung welcher Systemtabellenversion durchgeführt wurde.

Struktur

SYSUPGRADEHISTORY

KERNELVERSION | CHAR(40) | Version der Datenbanksoftware
EXECUTEDATE | TIMESTAMP | Zeitpunkt des impliziten Upgrade bzw. des Ladens der Systemtabellen
COMPONENT | CHAR(18) | Teil des Datenbankkerns, für die der implizite Upgrade durchgeführt wurde (z.B. CATALOG, CONVERTER, LOGGING)
DESCRIPTION | CHAR(2000) | Zusatzinformationen über den Upgrade bzw. Version der beim Laden der Systemtabellen verwendeten Skripte

Siehe auch:

Upgrade


TABLEPRIVILEGES (SAP-Bibliothek - Grundwissen)

Objektdokumentation TABLEPRIVILEGES

Definition

Die Systemtabelle TABLEPRIVILEGES beschreibt die Privilegien, die der aktuelle Benutzer für Tabellen besitzt.

Struktur

TABLEPRIVILEGES

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle
GRANTOR | CHAR(32) | Name des Benutzers, der die Privilegien vergeben hat
GRANTEE | CHAR(32) | Name des Benutzers oder der Rolle, an den/die vergeben wurde
PRIVILEGES | CHAR(30) | Privilegien, die vergeben wurden
IS_GRANTABLE | CHAR(3) | Privileg, das erhaltene Privileg weiterzugeben (YES | NO)

Siehe auch:

Systemtabellen auswerten, TABLEPRIVILEGES

SQL-Referenzhandbuch, Privilegien: Überblick


TABLES (SAP-Bibliothek - Grundwissen)

Objektdokumentation TABLES

Definition

Die Systemtabelle TABLES enthält alle Tabellen (Basistabellen, View-Tabellen, Synonyme, Ergebnistabellen), für die der aktuelle Benutzer Privilegien besitzt.

Struktur

TABLES

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle
PRIVILEGES | CHAR(30) | Privilegien des aktuellen Benutzers für die Tabelle
TYPE | CHAR(8) | Typ der Tabelle (SYNONYM | SYSTEMS | TABLES)
TABLETYPE | CHAR(8) | Typ der Tabelle (TABLE | VIEW | SYNONYM | RESULT)
CREATEDATE | DATE(10) | Erzeugungsdatum der Tabelle
CREATETIME | TIME(8) | Erzeugungszeit der Tabelle
UPDSTATDATE | DATE(10) | Datum der zuletzt durchgeführten UPDATE STATISTICS-Anweisung für die Tabelle
UPDSTATTIME | TIME(8) | Zeit der zuletzt durchgeführten UPDATE STATISTICS-Anweisung für die Tabelle
ALTERDATE | DATE(10) | Änderungsdatum der Tabelle
ALTERTIME | TIME(8) | Änderungszeit der Tabelle
UNLOADED | CHAR(3) | Tabelle ist entladen (YES | NO)
SAMPLE_PERCENT | FIXED(3) | Angabe, wieviel Prozent des Tabelleninhalts für das Aktualisieren von Statistiken herangezogen werden sollen
SAMPLE_ROWS | FIXED(10) | Angabe, wieviele Zeilen der Tabelle für das Aktualisieren von Statistiken herangezogen werden sollen
COMMENT | LONG | Kommentar zu der Tabelle
TABLEID | CHAR(8) BYTE | Identifikation der Tabelle in hexadezimaler Darstellung
DYNAMIC | CHAR(3) | Die Tabelle wurde mit der Angabe DYNAMIC definiert (YES | NO)
ARCHIVE | CHAR(3) | Die Tabelle wurde mit der Angabe FOR ARCHIVE definiert (YES | NO)
VARIABLE_COLUMNS | CHAR(3) | Die Spalten werden mit variabler Länge abgelegt (YES | NO)
VIRTUALKEY | CHAR(3) | Die Tabelle wurde mit der Angabe CLUSTER definiert (YES | NO)

Wenn die Systemtabelle TABLES vom Datenbanksystemadministrator aufgerufen wird, so werden Informationen zu den Tabellen aller Datenbankbenutzer angezeigt.

Siehe auch:

Systemtabellen auswerten, TABLES

SQL-Referenzhandbuch, Tabellenname (table_name)


TABLESIZE (SAP-Bibliothek - Grundwissen)

Objektdokumentation TABLESIZE

Definition

Die Systemtabelle TABLESIZE enthält Größeninformationen über Tabellen.

Struktur

TABLESIZE

SCHEMANAME | CHAR(32) | Name des Schemas
TABLENAME | CHAR(32) | Name der Tabelle
USEDSIZE | FIXED(22) | Platzbedarf der Tabelle (KB)
ROWCOUNT | FIXED(20) | Anzahl der Zeilen in der Tabelle

Siehe auch:

FILES


TABLESTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation TABLESTATISTICS

Definition

Die Statistik-Systemtabelle TABLESTATISTICS enthält Struktur- und Größeninformationen von Basistabellen.

Struktur

TABLESTATISTICS

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Tabellenname
DESCRIPTION | CHAR(40) | Beschreibung (siehe Tabelle Spalte DESCRIPTION), wie die folgenden Spalten zu interpretieren sind
CHAR_VALUE | CHAR(12) | Alphanumerischer Wert
NUMERIC_VALUE | FIXED(10) | Numerischer Wert

Spalte DESCRIPTION

Wert | Erläuterung
Root pno | NUMERIC_VALUE enthält die Seitennummer der Wurzel des B*-Baums
File type | CHAR_VALUE enthält den Typ des B*-Baums
Used pages | NUMERIC_VALUE enthält die Anzahl der durch die Tabelle belegten Seiten
Index pages | NUMERIC_VALUE enthält die Anzahl der durch die Tabelle belegten Seiten im B*-Baumindex
Leaf pages | NUMERIC_VALUE enthält die Anzahl der durch die Tabelle belegten Blattseiten
Index levels | NUMERIC_VALUE enthält die Anzahl der Indexstufen des B*-Baums
Space used in all pages(%) | NUMERIC_VALUE enthält die prozentuale Belegung aller Seiten des B*-Baums
Space used in root page(%) | NUMERIC_VALUE enthält die prozentuale Belegung der Wurzelseite des B*-Baums
Space used in index pages(%) | NUMERIC_VALUE enthält die prozentuale Belegung der Indexseiten des B*-Baums
Space used in index pages(%) min | NUMERIC_VALUE enthält die minimale prozentuale Belegung der Indexseiten des B*-Baums
Space used in index pages(%) max | NUMERIC_VALUE enthält die maximale prozentuale Belegung der Indexseiten des B*-Baums
Space used in leaf pages(%) | NUMERIC_VALUE enthält die prozentuale Belegung der Blattseiten des B*-Baums
Space used in leaf pages(%) min | NUMERIC_VALUE enthält die minimale prozentuale Belegung der Blattseiten des B*-Baums
Space used in leaf pages(%) max | NUMERIC_VALUE enthält die maximale prozentuale Belegung der Blattseiten des B*-Baums
Rows | NUMERIC_VALUE enthält die Anzahl der Zeilen der Tabelle
Avg rows per page | NUMERIC_VALUE enthält die durchschnittliche Anzahl von Zeilen pro Seite
Min rows per page | NUMERIC_VALUE enthält die minimale Anzahl von Zeilen pro Seite
Max rows per page | NUMERIC_VALUE enthält die maximale Anzahl von Zeilen pro Seite
Avg row length | NUMERIC_VALUE enthält die durchschnittliche Zeilenlänge
Min row length | NUMERIC_VALUE enthält die minimale Zeilenlänge
Max row length | NUMERIC_VALUE enthält die maximale Zeilenlänge
Avg key length | NUMERIC_VALUE enthält die durchschnittliche Schlüssellänge
Min key length | NUMERIC_VALUE enthält die minimale Schlüssellänge
Max key length | NUMERIC_VALUE enthält die maximale Schlüssellänge
Avg separator length | NUMERIC_VALUE enthält die durchschnittliche Separatorlänge
Min separator length | NUMERIC_VALUE enthält die minimale Separatorlänge
Max separator length | NUMERIC_VALUE enthält die maximale Separatorlänge
Defined LONG columns | NUMERIC_VALUE enthält die Anzahl definierter LONG-Spalten
Avg LONG column length | NUMERIC_VALUE enthält die durchschnittliche LONG-Spaltenlänge
Min LONG column length | NUMERIC_VALUE enthält die minimale LONG-Spaltenlänge
Max LONG column length | NUMERIC_VALUE enthält die maximale LONG-Spaltenlänge
LONG column pages | NUMERIC_VALUE enthält die Anzahl von Seiten aller LONG-Spalten der Tabelle
Avg pages per LONG column | NUMERIC_VALUE enthält die durchschnittliche Anzahl von Seiten der Tabelle pro LONG-Spalte
Min pages per LONG column | NUMERIC_VALUE enthält die kleinste LONG-Spalte der Tabelle in Seiten
Max pages per LONG column | NUMERIC_VALUE enthält die größte LONG-Spalte der Tabelle in Seiten

Siehe auch:

FILES

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


TABLESTORAGEDETAILS (SAP-Bibliothek - Grundwissen)

Objektdokumentation TABLESTORAGEDETAILS

Definition

Die Systemtabelle TABLESTORAGEDETAILS enthält Struktur- und Größeninformationen über Tabellen.

Struktur

TABLESTORAGEDETAILS

SCHEMANAME | CHAR(32) | Name des Schemas
TABLENAME | CHAR(32) | Name der Tabelle
TREELEVELCOUNT | FIXED(3) | Anzahl der B*-Baum-Indexebenen
AVGSEPARATORLENGTH | FIXED(4) | Durchschnittliche Separatorlänge
MINSEPARATORLENGTH | FIXED(4) | Minimale Separatorlänge
MAXSEPARATORLENGTH | FIXED(4) | Maximale Separatorlänge
AVGUSEDSIZEPERCENTAGEINLEAVES | FIXED(3) | Durchschnittlicher Füllungsgrad der Seiten, die Daten enthalten
MINUSEDSIZEPERCENTAGEINLEAVES | FIXED(3) | Minimaler Füllungsgrad einer Seite, die Daten enthält
MAXUSEDSIZEPERCENTAGEINLEAVES | FIXED(3) | Maximaler Füllungsgrad einer Seite, die Daten enthält
AVGROWCOUNTPERLEAF | FIXED(5) | Durchschnittliche Anzahl der Tabellenzeilen pro Seite
MINROWCOUNTPERLEAF | FIXED(5) | Minimale Anzahl der Tabellenzeilen auf einer Seite
MAXROWCOUNTPERLEAF | FIXED(5) | Maximale Anzahl der Tabellenzeilen auf einer Seite
AVGROWLENGTH | FIXED(5) | Durchschnittliche Länge der Tabellenzeilen
MINROWLENGTH | FIXED(5) | Länge der kürzesten Tabellenzeile
MAXROWLENGTH | FIXED(5) | Länge der längsten Tabellenzeilen
DEFINEDLOBCOLUMNCOUNT | FIXED(10) | Anzahl der LONG-Spaltenwerte, die nicht NULL sind
AVGLOBCOLUMNLENGTH | FIXED(10) | Durchschnittliche Länge aller potentiell existierenden LONG-Spaltenwerte
MINLOBCOLUMNLENGTH | FIXED(10) | Minimale Länge eines existierenden LONG-Spaltenwertes
MAXLOBCOLUMNLENGTH | FIXED(10) | Maximale Länge eines existierenden LONG-Spaltenwertes
CLUSTERCOUNT | FIXED(10) | Anzahl der Datenseiten, die in Clustern abgelegt wurden

Siehe auch:

FILES

Konzepte des Datenbanksystems, Logische Zugriffsstrukturen


TASKGROUPSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation TASKGROUPSTATISTICS

Definition

Die Systemtabelle TASKGROUPSTATISTICS enthält Angaben über Task-Gruppen und deren Ressourcenverbrauch seit dem letzten Start der Datenbankinstanz.

Struktur

TASKGROUPSTATISTICS

TASKGROUPID | FIXED(10) | Identifikation der Task-Gruppe
TASKCLUSTER | CHAR(20) | Task-Cluster, zu dem diese Task-Gruppe gehört
TASKCOUNT | FIXED(10) | Anzahl der Tasks in dieser Taskgruppe
USEDRUNQUEUELENGTH | FIXED(10) | Anzahl der Tasks, die für die Zuteilung der CPU eingereiht wurden
MAXUSEDRUNQUEUELENGTH | FIXED(10) | Maximale Anzahl der Tasks, die für die Zuteilung der CPU eingereiht wurden
IDLECOUNT | FIXED(20) | Anzahl der Zeitintervalle, in denen die CPU freigegeben wurde
IDLETIME | FIXED(20) | Gesamtzeit, für die die CPU freigegeben wurde (µs)
IOWAITCOUNT | FIXED(20) | Anzahl der Zeitintervalle, in denen auf ausstehende I/O-Vorgänge gewartet wurde
IOWAITTIME | FIXED(20) | Gesamtzeit, in der auf ausstehende I/O-Vorgänge gewartet wurde (µs)
USEDSYSTEMTIME | FIXED(20) | Insgesamt verbrauchte CPU-Zeit im System-Modus (µs)
USEDUSERTIME | FIXED(20) | Insgesamt verbrauchte CPU-Zeit im Benutzermodus (µs)

Siehe auch:

TASKGROUPSTATISTICSRESET

Konzepte des Datenbanksystems, Übersicht der Tasks, Task-Wechsel


TASKGROUPSTATISTICSRESET (SAP-Bibliothek - Grundwissen)

Objektdokumentation TASKGROUPSTATISTICSRESET

Definition

Die Systemtabelle TASKGROUPSTATISTICSRESET enthält Angaben über Task-Gruppen und deren Ressourcenverbrauch seit dem letzten RESET TASKGROUPSTATISTICS oder RESET ALL.

Struktur

TASKGROUPSTATISTICSRESET

RESETDATE | TIMESTAMP | Zeitpunkt des letzten RESET für diese Angaben
TASKGROUPID | FIXED(10) | Identifkation der Task-Gruppe
MAXUSEDRUNQUEUELENGTH | FIXED(10) | Maximale Anzahl der Tasks, die für die Zuteilung der CPU eingereiht wurden
IDLECOUNT | FIXED(20) | Anzahl der Zeitintervalle, in denen die CPU freigegeben wurde
IDLETIME | FIXED(20) | Gesamtzeit, für die die CPU freigegeben wurde (µs)
IOWAITCOUNT | FIXED(20) | Anzahl der Zeitintervalle, in denen auf ausstehende I/O-Vorgänge gewartet wurde
IOWAITTIME | FIXED(20) | Gesamtzeit, in der auf ausstehende I/O-Vorgänge gewartet wurde (µs)
USEDSYSTEMTIME | FIXED(20) | Insgesamt verbrauchte CPU-Zeit im Systemmodus (µs)
USEDUSERTIME | FIXED(20) | Insgesamt verbrauchte CPU-Zeit im Benutzermodus (µs)

Siehe auch:

TASKGROUPSTATISTICS

Konzepte des Datenbanksystems, Übersicht der Tasks, Task-Wechsel


TASKLOADBALANCINGINFORMATION (SAP-Bibliothek - Grundwissen)

Objektdokumentation TASKLOADBALANCINGINFORMATION

Definition

Die Systemtabelle TASKLOADBALANCINGINFORMATION beschreibt die aktuellen Parameter des Task-Load-Balancing bzw. gibt Auskunft über das laufende Task-Load-Balancing-Messintervall.

Struktur

TASKLOADBALANCINGINFORMATION

MEASUREMENTINTERVALTIME | FIXED(10) | Messintervallzeit (s), die zwischen Task-Lastverteilungsoperationen bzw. –bewertungen vergeht
INTERVALSTARTTIME | TIMESTAMP | Startzeitpunkt der aktuell laufenden Messintervallzeit
MEASUREMENTINTERVALS | FIXED(10) | Anzahl der Messintervalle seit dem Start des Datenbankkerns
VALUEQUALITY | FIXED(3) | Angabe (%), welcher Toleranzbereich beim Vergleich von Zeitwerten maximal erlaubt sein soll. Befindet sich die Zeitdifferenz zweier laufwilliger Tasks innerhalb dieses Toleranzbereichs, gelten die Task-Zeiten als gleich
MINDIFFERENCE | FIXED(3) | Angabe (%), um wieviel eine zu verschiebende Task in ihrer Task-Gruppe länger laufwillig gewesen sein muss, als die am längsten laufwillige Task der Ziel-Task-Gruppe

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Tasks, Task-Wechsel


TASKLOADBALANCINGTASKGROUPSTATES (SAP-Bibliothek - Grundwissen)

Objektdokumentation TASKLOADBALANCINGTASKGROUPSTATES

Definition

Die Systemtabelle TASKLOADBALANCINGTASKGROUPSTATES enthält Angaben über die Task-Load-Balancing-Werte der einzelnen Task-Gruppen des aktuell laufenden Messintervalls.

Struktur

TASKLOADBALANCINGTASKGROUPSTATES

TASKGROUPID | FIXED(10) | Identifikation der Task-Gruppe
MOVETASKTOTASKGROUPID | FIXED(10) | Identifikation der Ziel-Task-Gruppe, in die eine Task der Task-Gruppe (TASKGROUPID) zu verschieben ist
MOVEABLETASKCOUNT | FIXED(10) | Anzahl der Tasks der Task-Gruppe, die einen Task-Gruppenwechsel erlauben
INTERVALSTARTTIME | TIMESTAMP | Startzeitpunkt der aktuell laufenden Messintervallzeit
TASKGROUPSLEEPTIME | FIXED(20) | Zeit (µs) innerhalb der Messintervallzeit, die sich die Task-Gruppe im Schlafzustand (sleep on semaphore) befunden hat
TOTALTASKRUNNABLETIME | FIXED(20) | Gesamtzeit (µs) innerhalb der Messintervallzeit, in der sich die Tasks der Task-Gruppe im Zustand laufwillig befunden haben
MAXTASKRUNNABLETIME | FIXED(20) | Maximum der Zeiten (µs) innerhalb der Messintervallzeit, in der sich eine Task der Task-Gruppe im Zustand laufwillig befunden hat

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Tasks, Task-Wechsel


TASKLOADBALANCINGTASKMOVES (SAP-Bibliothek - Grundwissen)

Objektdokumentation TASKLOADBALANCINGTASKMOVES

Definition

Die Systemtabelle TASKLOADBALANCINGTASKMOVES beschreibt die Historie der Task-Gruppenwechsel.

Struktur

TASKLOADBALANCINGTASKMOVES

MOVETIME | TIMESTAMP | Zeitpunkt des Task-Gruppenwechsels
TASKID | FIXED(10) | Identifikation der Task, die zwischen zwei Task-Gruppen gewechselt hat
MAXTASKRUNNABLETIME | FIXED(20) | Maximum der Zeiten innerhalb der Messintervallzeit (µs), in der sich die Task im Zustand laufwillig befunden hat
SOURCETASKGROUP | FIXED(10) | Identifikation der Quell-Task-Gruppe
SOURCEMAXTASKRUNNABLETIME | FIXED(20) | Maximum der Zeiten innerhalb der Messintervallzeit (µs), in der sich eine Task der Quell-Taskgruppe im Zustand laufwillig befunden hat
DESTINATIONTASKGROUP | FIXED(10) | Identifikation der Ziel-Task-Gruppe
DESTINATIONMAXTASKRUNNABLETIME | FIXED(20) | Maximum der Zeiten innerhalb der Messintervallzeit (µs), in der sich eine Task der Ziel-Task-Gruppe im Zustand laufwillig befunden hat

Siehe auch:

Konzepte des Datenbanksystems, Übersicht der Tasks, Task-Wechsel


TRANSACTIONHISTORY (SAP-Bibliothek - Grundwissen)

Objektdokumentation TRANSACTIONHISTORY

Definition

Die Systemtabelle TRANSACTIONHISTORY enthält Angaben über aktive und beendete Transaktionen einer Datenbankinstanz.

Struktur

TRANSACTIONHISTORY

TRANSACTIONID | FIXED(15) | Identifikation der Transaktion
TASKID | FIXED(10) | Identifikation der Datenbank-Task
WRITETRANSACTIONID | FIXED(15) | Identifikation einer Schreibtransaktion
STARTDATE | TIMESTAMP | Startzeitpunkt der Transaktion
ENDDATE | TIMESTAMP | Endzeitpunkt der Transaktion
STATE | CHAR(10) | Status der Transaktion (ACTIVE | COMMITTED | ROLLBACKED)
COMMENT | CHAR(2048) | Kommentar zur Transaktion

Die Anzahl der maximal möglichen Einträge wird über den Datenbankparameter TRANS_HISTORY_SIZE gesteuert.

Siehe auch:

Konzepte des Datenbanksystems, Transaktionen


TRANSACTIONS (SAP-Bibliothek - Grundwissen)

Objektdokumentation TRANSACTIONS

Definition

Die Statistik-Systemtabelle TRANSACTIONS enthält Angaben über aktive Transaktionen einer Datenbankinstanz.

Struktur

TRANSACTIONS

SESSION | FIXED(10) | Identifikation der Datenbanksitzung
TRANSCOUNT | CHAR(20) | Identifikation der Transaktion
SUB_TRANS | FIXED(10) | Nummer der aktuellen Subtransaktion
WRITE_TRANS | CHAR(6) BYTE | Identifikation der aktuellen Schreibtransaktion, wenn diese eine Änderung durchgeführt hat
PROCESS | FIXED(10) | Identifikation des Benutzerprozesses
USERNAME | CHAR(32) | Benutzername
CONNECTDATE | DATE | Datum des Sitzungsbeginns
CONNECTTIME | TIME | Zeit des Sitzungsbeginns
TERMID | CHAR(18) | Identifikation des Terminals
REQTIMEOUT | CHAR(10) | Verbleibende Sekunden bis zum Erreichen der im speziellen Datenbankparameter REQUEST_TIMEOUT angegebenen Zeit
LASTWRITE | CHAR(10) | Vergangene Zeit seit dem letzten Schreibauftrag in Timeout-Intervallen
LOCKMODE | CHAR(14) | Art der Sperre (NULL-Wert | SHARE | EXCLUSIVE)
LOCKSTATE | CHAR(10) | Status der Sperre
REQMODE | CHAR(14) | Art der Sperranforderung (NULL-Wert | SHARE | EXCLUSIVE)
REQSTATE | CHAR(10) | Status der Sperranforderung
CONSISTENTVIEW | CHAR(6) BYTE | für zukünftige Zwecke
APPLPROCESS | FIXED(10) | Identifikation des Applikationsprozesses
APPLNODEID | CHAR(64) | Identifikation des Client-Rechners des Applikationsprozesses

Diese Statistik-Systemtabelle TRANSACTIONS existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle dieser Statistik-Systemtabelle TRANSACTIONS die Systemtabelle TRANSACTIONS.


TRANSACTIONS (SAP-Bibliothek - Grundwissen)

Objektdokumentation TRANSACTIONS

Definition

Die Systemtabelle TRANSACTIONS beschreibt den Zustand aller aktuellen Transaktionen.

Struktur

TRANSACTIONS

TASKID | FIXED(10) | Identifikation der Task
TRANSACTIONID | FIXED(15) | Identifikation der Transaktion
STARTDATE | TIMESTAMP | Startzeitpunkt der Transaktion
WRITETRANSACTIONID | FIXED(15) | Identifikation einer Schreibtransaktion
SQLLOCKREQUESTTIMEOUT | FIXED(10) | Timeout für SQL-Sperranforderungen für Datenbankobjekte (s) Gegebenenfalls ist dieser Wert gegenüber dem Datenbankparameter verändert.
OMSLOCKREQUESTTIMEOUT | FIXED(10) | Timeout für Sperranforderungen für OMS-Objekte (s) Gegebenenfalls ist dieser Wert gegenüber dem Datenbankparameter verändert.
LASTWRITE | FIXED(10) | Dauer einer Transaktion, die Änderungen in der Datenbank vorgenommen hat (s)
SQLLOCKMODE | CHAR(14) | Art der Sperre für SQL-Datenbankobjekte (NULL-Wert | SHARE | EXCLUSIVE)
OMSLOCKMODE | CHAR(14) | Art der Sperre für OMS-Objekte (NULL-Wert | SHARE | EXCLUSIVE)
REQUESTMODE | CHAR(14) | Art der Sperre im Falle einer Kollision mit Timeout-Wartesituationen (NULL-Wert | SHARE | EXCLUSIVE)
HISTORYROOT | FIXED(10) | Erste Seite in der Kette der History-Seiten
HISTORYLAST | FIXED(10) | Letzte Seite in der Kette der History-Seiten
HISTORYPAGECOUNT | FIXED(10) | Anzahl verwendeter History-Seiten
LASTHISTORYSEQUENCE | FIXED(10) | Letzte vergebene Nummer für einen History-Eintrag
CONSISTENTVIEWID | FIXED(15) | Identifikation der aktuell gültigen konistenten Sicht
TASKTYPE | CHAR(32) | Task-Typ

Siehe auch:

Konzepte des Datenbanksystems, Transaktionen, Sperren für Datenbankobjekte


TRANSFORMATIONMODEL (SAP-Bibliothek - Werkzeuge)

Objektdokumentation TRANSFORMATIONMODEL

Definition

Die Systemtabelle TRANSFORMATIONMODEL enthält alle Einträge über Transformationen des Loader.

Wenn eine Transformation erfolgreich verlief, dann werden die Einträge der Tabelle TRANSFORMATIONMODEL gelöscht. Wenn eine Transformation nicht erfolgreich beendet werden konnte, bleiben die Daten in dieser Systemtabelle erhalten und werden bei einem eventuellen Wiederausetzen der Transformation verwendet.

Sie können den Inhalt der Systemtabelle TRANSFORMATIONMODEL auch im Falle einer erfolgreichen Transformation sichern, indem Sie die Werte exportieren. Geben Sie dazu einen PACKAGE-Datenstrom in dem entsprechenden Loader-Kommando an.

Siehe auch:

Loader, Transformation, Wiederaufsetzen, Zusätzliche Protokollfunktionalität (package_spec)

Struktur

TRANSFORMATIONMODEL

PACKAGEGUID | CHAR(24) BYTE | Eindeutige Kennung des Transformationspakets
TASKID | FIXED(6,0) | Kennung der Transformationstask
SERVERNODE | CHAR(32) | Rechnerknoten, auf dem sich die zu transformierende Datenbankinstanz befindet
SERVERDB | CHAR(32) | Name der Datenbankinstanz, die transformiert werden soll
USERNAME | CHAR(32) | Benutzername
CODETYPE | CHAR(32) | Codetyp der Datenbankinstanz (ASCII | UNICODE)
CODEPAGEID | CHAR(32) | Bezeichnung der ASCII-Codepage, die verwendet werden soll
STORAGEDEVICE | CHAR(32) | Externe Datenträger, der verwendet werden soll
TRANSACTIONSIZE | FIXED(6,0) | Mindestanzahl von Zeilen, die transformiert werden sollen, bevor der Status des Transformationsschritts protokolliert wird
TRANSFORMATION | CHAR(32) | Transformationstyp (EXPORT | IMPORT | UPDATE)
PART | CHAR(32) | Teile des Datenbankkatalogs (ALL | USER | SCHEMA | TABLE)
STEPID | FIXED(6,0) | Kennung des Transformationsschritts
OWNER | CHAR(32) | Eigentümer der Tabelle
SCHEMANAME | CHAR(32) | Schemaname
TABLENAME | CHAR(32) | Tabellenname
TABLETYPE | CHAR(8) | Tabellentyp (TABLE | VIEW | SYNONYM)
CATALOGSTREAMNAME | CHAR(254) | Bezeichnung des CATALOG-Datenstroms
CATALOGSTREAMTYPE | CHAR(32) | Datenträger des CATALOG-Datenstroms (FILE | PIPE | TAPE)
CATALOGSTREAMEBID | CHAR(32) | Externe Sicherungskennung des CATALOG-Datenstroms
CATALOGSTREAMFORMAT | CHAR(32) | Format des CATALOG-Datenstroms (DDL | XML)
DATASTREAMNAME | CHAR(254) | Bezeichnung des DATA-Datenstroms
DATASTREAMTYPE | CHAR(32) | Datenträger des DATA-Datenstroms (FILE | PIPE | TAPE)
DATASTREAMEBID | CHAR(32) | Externe Sicherungskennung des DATA-Datenstroms
DATASTREAMFORMAT | CHAR(32) | Format des DATA-Datenstroms (CSV | DDL | FWV | PAGES | RECORDS)
DATASTREAMHEADERBLOCK | FIXED(6,0) | Startposition des Header des DATA-Datenstroms (in 2 GB-Blöcken)
DATASTREAMHEADERPOS | FIXED(10,0) | Startposition des Header des DATA-Datenstroms (in Bytes, weniger als 2 GB)
DATASTREAMDATABLOCK | FIXED(6,0) | Startposition der Daten des DATA-Datenstroms (in 2 GB-Blöcken)
DATASTREAMDATAPOS | FIXED(10,0) | Startposition der Daten des DATA-Datenstroms (in Bytes, weniger als 2 GB)
DATASTREAMTRAILEBLOCK | FIXED(6,0) | Startposition des Trailer des DATA-Datenstroms (in 2 GB-Blöcken)
DATASTREAMTRAILERPOS | FIXED(10,0) | Startposition des Trailer des DATA-Datenstroms (in Bytes, weniger als 2 GB)
EXCLUDE | BOOLEAN | Transformationsschritt wurde ausgeschlossen (TRUE) oder nicht (FALSE)
RESTART | BOOLEAN | Transformationsschritt wurde durchgeführt (TRUE) oder nicht (FALSE)
RESTORE | BOOLEAN | Transformationskommando wurde erzeugt (TRUE) oder nicht (FALSE)
PAGECOUNT | FIXED(10,0) | Anzahl der Seiten, die bei einem Transformationsschritt transformiert wurden
ROWCOUNT | FIXED(10,0) | Anzahl der Zeilen, die bei einem Transformationsschritt transformiert wurden
STARTTIME | TIMESTAMP | Beginn des Transformationsschritts
ENDTIME | TIMESTAMP | Ende des Transformationsschritts
REQUESTTIME | FIXED(15,10) | Gesamte Ausführungszeit einer Kern-Anforderung innerhalb eines Transformationsschritts
RECEIVETIME | FIXED(15,10) | Gesamte Ausführungszeit einer Kern-Antwort innerhalb eines Transformationsschritts
IOTIME | FIXED(15,10) | Gesamte I/O-Zeit innerhalb eines Transformationsschritts
LOGTIME | FIXED(15,10) | Gesamte Zeit, die für die Verwaltung der Aktionen innerhalb eines Transformationsschritts erforderlich ist
SEQ_NO | FIXED(6,0) | Sequenznummer, über die gesplittete GRANT-Anweisungen einander zugeordnet werden können
CMD | CHAR(254) | Autorisierungsanweisung

Siehe auch:

weitere Systemtabellen


TRANSFORMATIONMONITOR (SAP-Bibliothek - Werkzeuge)

Objektdokumentation TRANSFORMATIONMONITOR

Definition

Die Systemtabelle TRANSFORMATIONMONITOR beschreibt den Ressourcenverbrauch einer Loader-Transformation.

Struktur

TRANSFORMATIONMONITOR

PACKAGEGUID | CHAR(24) | Eindeutige Kennung des Transformationspaketes
ROWCOUNT | FLOAT(38) | Anzahl der transformierten Zeilen
TRANSACTIONSIZE | FIXED(6,0) | Mindestanzahl von Zeilen, die transformiert werden sollen, bevor der Status des Transformationsschritts protokolliert wird
SYSTEMDURATION | FLOAT(38) | System-Performance
KERNELDURATION | FLOAT(38) | Kern-Performance
LOADERDURATION | FLOAT(38) | Loader-Performance
DATADURATION | FLOAT(38) | Pager-Performance
LOGDURATION | FLOAT(38) | Gesamte Zeit, die für die Verwaltung der Aktionen innerhalb eines Transformationsschritts erforderlich ist
IODURATION | FLOAT(38) | Gesamte I/O-Zeit innerhalb eines Transformationsschritts

Siehe auch:

weitere Systemtabellen


TRANSFORMATIONPACKAGES (SAP-Bibliothek - Werkzeuge)

Objektdokumentation TRANSFORMATIONPACKAGES

Definition

Die Systemtabelle TRANSFORMATIONPACKAGES enthält alle Schritte einer Loader-Transformation für ein Transformationspaket.

Struktur

TRANSFORMATIONPACKAGES

PACKAGEGUID | CHAR(24) BYTE | Eindeutige Kennung des Transformationspakets
TASKID | FIXED(6,0) | Kennung der Transformationstask
STEPID | FIXED(6,0) | Kennung des Transformationsschritts
OWNER | CHAR(32) | Eigentümer der Tabelle
SCHEMANAME | CHAR(32) | Schemaname
TABLENAME | CHAR(32) | Tabellenname
EXCLUDE | BOOLEAN | Transformationsschritt wurde ausgeschlossen (TRUE) oder nicht (FALSE)
RESTART | BOOLEAN | Transformationsschritt wurde durchgeführt (TRUE) oder nicht (FALSE)

Siehe auch:

weitere Systemtabellen


TRANSFORMATIONRESOURCES (SAP-Bibliothek - Werkzeuge)

Objektdokumentation TRANSFORMATIONRESOURCES

Definition

Die Systemtabelle TRANSFORMATIONRESOURCES beschreibt die an einer Loader-Transformation beteiligten Datenquellen und Datenziele.

Struktur

TRANSFORMATIONRESOURCES

PACKAGEGUID | CHAR(24) BYTE | Eindeutige Kennung des Transformationspakets
SERVERNODE | CHAR(32) | Rechnerknoten, auf dem sich die zu transformierende Datenbankinstanz befindet
SERVERDB | CHAR(32) | Name der Datenbankinstanz, die transformiert werden soll
USERNAME | CHAR(32) | Benutzername
CODEPAGEID | CHAR(32) | Bezeichnung der ASCII-Codepage, die verwendet werden soll
STORAGEDEVICE | CHAR(32) | Externer Datenträger, der verwendet werden soll
CATALOGSTREAMNAME | CHAR(254) | Bezeichnung des CATALOG-Datenstroms
CATALOGSTREAMTYPE | CHAR(32) | Datenträger des CATALOG-Datenstroms (FILE | PIPE | TAPE)
CATALOGSTREAMEBID | CHAR(32) | Externe Sicherungskennung des CATALOG-Datenstroms
DATASTREAMNAME | CHAR(254) | Bezeichnung des DATA-Datenstroms
DATASTREAMTYPE | CHAR(32) | Datenträger des DATA-Datenstroms (FILE | PIPE | TAPE)
DATASTREAMEBID | CHAR(32) | Externe Sicherungskennung des DATA-Datenstroms

Siehe auch:

weitere Systemtabellen


TRANSFORMATIONSTATISTICS (SAP-Bibliothek - Werkzeuge)

Objektdokumentation TRANSFORMATIONSTATISTICS

Definition

Die Systemtabelle TRANSFORMATIONSTATISTICS beschreibt den Ressourcenverbrauch eines Schritts einer Loader-Transformation.

Struktur

TRANSFORMATIONSTATISTICS

PACKAGEGUID | CHAR(24) BYTE | Eindeutige Kennung des Transformationspakets
STEPID | FIXED(6,0) | Aufsteigende Nummer für jedes Transformationspaket
OWNER | CHAR(32) | Eigentümer der Tabelle
SCHEMANAME | CHAR(32) | Schemaname
TABLENAME | CHAR(32) | Tabellenname
BYTECOUNT | FIXED(11,0) | Größe des DATA-Datenstroms in Bytes
ROWCOUNT | FIXED(10,0) | Anzahl der Tabellenzeilen des DATA-Datenstroms
TRANSACTIONSSIZE | FIXED(6,0) | Mindestanzahl von Zeilen, die transformiert werden sollen, bevor der Status des Transformationsschritts protokolliert wird
SYSTEMTIME | FLOAT(38) | Transformationsperformance
KERNELTIME | FIXED(20,10) | Kern-Performance
LOADERTIME | FLOAT(38) | Loader-Performance
DATATIME | FLOAT(38) | Pager-Performance
LOGTIME | FIXED(15,10) | Gesamte Zeit, die für die Verwaltung der Aktionen innerhalb eines Transformationsschritts erforderlich ist
IOTIME | FIXED(15,10) | Gesamte I/O-Zeit innerhalb eines Transformationsschritts

Siehe auch:

weitere Systemtabellen


TRANSFORMATIONSTEPS (SAP-Bibliothek - Werkzeuge)

Objektdokumentation TRANSFORMATIONSTEPS

Definition

Die Systemtabelle TRANSFORMATIONSTEPS beschreibt eine Loader-Transformation auf Tabellenebene.

Struktur

TRANSFORMATIONSTEPS

PACKAGEGUID | CHAR(24) BYTE | Eindeutige Kennung des Transformationspakets
TRANSFORMATION | FIXED(6,0) | Transformationstyp (EXPORT | IMPORT | UPDATE)
OWNER | CHAR(32) | Eigentümer der Tabelle
SCHEMANAME | CHAR(32) | Schemaname
TABLENAME | CHAR(32) | Tabellenname
CATALOGSTREAMNAME | CHAR(254) | Bezeichnung des CATALOG-Datenstroms
CATALOGSTREAMFORMAT | CHAR(32) | Format des CATALOG-Datenstroms (DDL | XML)
DATASTREAMNAME | CHAR(254) | Bezeichnung des DATA-Datenstroms
DATASTREAMFORMAT | CHAR(32) | Format des DATA-Datenstroms (CSV | DDL | FWV | PAGES | RECORDS)
DATASTREAMHEADERBLOCK | FIXED(6,0) | Startposition des Header des DATA-Datenstroms (in 2 GB-Blöcken)
DATASTREAMHEADERPOS | FIXED(10,0) | Startposition des Header des DATA-Datenstroms (in Bytes, weniger als 2 GB)
DATASTREAMDATABLOCK | FIXED(6,0) | Startposition der Daten des DATA-Datenstroms (in 2 GB-Blöcken)
DATASTREAMDATAPOS | FIXED(10,0) | Startposition der Daten des DATA-Datenstroms (in Bytes, weniger als 2 GB)
DATASTREAMTRAILERBLOCK | FIXED(6,0) | Startposition des Trailer des DATA-Datenstroms (in 2 GB-Blöcken)
DATASTREAMTRAILERPOS | FIXED(10,0) | Startposition des Trailer des DATA-Datenstroms (in Bytes, weniger als 2 GB)
RESTART | BOOLEAN | Transformationsschritt wurde durchgeführt (TRUE) oder nicht (FALSE)
START | FIXED(10,0) | Anzahl der transformierten Zeilen

Siehe auch:

weitere Systemtabellen


TRIGGERS (SAP-Bibliothek - Grundwissen)

Objektdokumentation TRIGGERS

Definition

Die Systemtabelle TRIGGERS enthält alle Trigger, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

TRIGGERS

SCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
OWNER | CHAR(32) | Name des Eigentümers der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle, für die der Trigger definiert wurde
TRIGGERNAME | CHAR(32) | Name des Trigger
INSERT | CHAR(3) | Trigger wird nach einer INSERT-Anweisung aufgeführt (YES | NO)
UPDATE | CHAR(3) | Trigger wird nach einer UPDATE-Anweisung aufgeführt (YES | NO)
DELETE | CHAR(3) | Trigger wird nach einer DELETE-Anweisung aufgeführt (YES | NO)
CREATEDATE | DATE(10) | Erzeugungsdatum des Trigger
CREATETIME | TIME(8) | Erzeugungszeit des Trigger
DEFINITION | LONG | Text der Triggerdefinition
COMMENT | LONG | Kommentar zu dem Trigger

Siehe auch:

Systemtabellen auswerten, TRIGGERS

SQL-Referenzhandbuch, Triggername (trigger_name)


UNLOADEDSTATEMENTS (SAP-Bibliothek - Grundwissen)

Objektdokumentation UNLOADEDSTATEMENTS

Definition

Die Systemtabelle UNLOADEDSTATEMENTS enthält die SQL-Anweisungen, die aus Platzgründen aus dem Kommando-Cache in eine datenbankinterne Datei verdrängt wurden.

Struktur

UNLOADEDSTATEMENTS

COMMANDID | CHAR(8) BYTE | Identifikation der SQL-Anweisung
STATEMENT | LONG | SQL-Anweisung


USERS (SAP-Bibliothek - Grundwissen)

Objektdokumentation USERS

Definition

Die Systemtabelle USERS enthält alle Datenbankbenutzer.

Struktur

USERS

OWNER | CHAR(32) | Name des Eigentümers des Datenbankbenutzers
GROUPNAME | CHAR(32) | Name der Gruppe
USERNAME | CHAR(32) | Name des Datenbankbenutzers
USERMODE | CHAR(8) | Klasse des Datenbankbenutzers (SYSDBA | DBA | RESOURCE | STANDARD)
CONNECTMODE | CHAR(8) | Art der Verbindung (MULTIPLE | SINGLE)
MAXTIMEOUT | FIXED(10) | Timeout-Wert
COSTWARNING | FIXED(10) | Wert des COSTWARNING
COSTLIMIT | FIXED(10) | Wert des COSTLIMIT
DEFAULTCODE | CHAR(7) | Vorschlagswert für Codeattribut
CREATEDATE | DATE(10) | Erzeugungsdatum des Datenbankbenutzers
CREATETIME | TIME(8) | Erzeugungszeit des Datenbankbenutzers
ALTERDATE | DATE(10) | Änderungsdatum des Datenbankbenutzers
ALTERTIME | TIME(8) | Änderungszeit des Datenbankbenutzers
PWCREADATE | DATE(10) | Erzeugungsdatum des Kennworts
PWCREATIME | TIME(8) | Erzeugungszeit des Kennworts
SERVERDB | CHAR(18) | Name der Datenbankinstanz
SERVERNODE | CHAR(64) | Rechnername der Datenbankinstanz
USER_ID | FIXED(10) | Identifikation des Datenbankbenutzers
ISREPLICATIONUSER | CHAR(3) | Angabe, ob der Datenbankbenutzer die Datenbankreplikation steuern und überwachen kann oder nicht (YES | NO)
COMMENT | LONG BYTE | Kommentar zum Datenbankbenutzer

Siehe auch:

Systemtabellen auswerten, USERS

Konzepte des Datenbanksystems, Datenbankbenutzer

SQL-Referenzhandbuch, Benutzername (user_name)


USERSTATISTICS (SAP-Bibliothek - Grundwissen)

Objektdokumentation USERSTATISTICS

Definition

Die Statistik-Systemtabelle USERSTATISTICS enthält Angaben über den Ressourcenverbrauch von Datenbankbenutzern.

Struktur

USERSTATISTICS

USERNAME | CHAR(32) | Name des Datenbankbenutzers
USERMODE | CHAR(8) | Datenbankbenutzerklasse
PERMCOUNT | FIXED(10) | Aktueller Seitenverbrauch für permanente Objekte
TEMPCOUNT | FIXED(10) | Aktueller Seitenverbrauch für temporäre Objekte

Siehe auch:

Konzepte des Datenbanksystems, Datenbankbenutzer


VERSION (SAP-Bibliothek - Grundwissen)

Objektdokumentation VERSION

Definition

Die Systemtabelle VERSION beschreibt die Version der Datenbanksoftware.

Struktur

VERSION

OPERATINGSYSTEM | CHAR(64) | Name des Betriebssystems
PROCESSORTYPE | CHAR(64) | Name des Prozessorherstellers
ADDRESSINGMODE | FIXED(2) | Angabe, ob eine 32bit- oder 64bit-Plattform verwendet wird
ID | CHAR(40) | Aktuelle Version incl. Build-Level
MAJORVERSION | FIXED(2) | Nummer der Major-Version
MINORVERSION | FIXED(2) | Nummer der Minor-Version
CORRECTIONLEVEL | FIXED(2) | Nummer des Correction-Levels
BUILD | FIXED(2) | Build-Level
KERNELVARIANT | CHAR(8) | Variante des Kerns (SLOW | FAST)

Siehe auch:

Systemtabellen auswerten, VERSION

Konzepte des Datenbanksystems, Versionsnotierung


VERSIONS (SAP-Bibliothek - Grundwissen)

Objektdokumentation VERSIONS

Definition

Die Systemtabelle VERSIONS beschreibt die Versionen der Datenbanksoftware.

Struktur

VERSIONS

KERNEL | CHAR(40) | Version der Datenbanksoftware
RUNTIMEENVIRONMENT | CHAR(40) | Version der Laufzeitumgebung

Die Systemtabelle VERSIONS existiert nur noch, um zu älteren Datenbankversionen kompatibel zu sein. Verwenden Sie anstelle der Systemtabelle VERSIONS die Systemtabelle VERSION.

Siehe auch:

Systemtabellen auswerten, VERSION


VIEWCOLUMNS (SAP-Bibliothek - Grundwissen)

Objektdokumentation VIEWCOLUMNS

Definition

Die Systemtabelle VIEWCOLUMNS enthält alle Spalten der View-Tabellen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

VIEWCOLUMNS

SCHEMANAME | CHAR(32) | Name des Schemas der View-Tabelle
OWNER | CHAR(32) | Name des Eigentümers der View-Tabelle
VIEWNAME | CHAR(32) | Name der View-Tabelle
VIEWCOLUMNNAME | CHAR(32) | Name der Spalte in der View-Tabelle
TABLESCHEMANAME | CHAR(32) | Name des Schemas der Tabelle, zu der die verwendete Spalte gehört
TABLEOWNER | CHAR(32) | Name des Eigentümers der Tabelle, zu der die verwendete Spalte gehört
TABLENAME | CHAR(32) | Name der Tabelle, zu der die verwendete Spalte gehört
COLUMNNAME | CHAR(32) | Name der Spalte, den sie ursprünglich in der Tabelle hat
CREATEDATE | DATE(10) | Erzeugungsdatum der View-Tabelle
CREATETIME | TIME(8) | Erzeugungszeit der View-Tabelle

Siehe auch:

Systemtabellen auswerten, VIEWCOLUMNS

VIEWDEFS, VIEWS, VIEWTABLES

SQL-Referenzhandbuch, CREATE VIEW-Anweisung (create_view_statement)


VIEWDEFS (SAP-Bibliothek - Grundwissen)

Objektdokumentation VIEWDEFS

Definition

Die Systemtabelle VIEWDEFS enthält die Definitionen der View-Tabellen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

VIEWDEFS

SCHEMANAME | CHAR(32) | Name des Schemas der View-Tabelle
OWNER | CHAR(32) | Name des Eigentümers der View-Tabelle
VIEWNAME | CHAR(32) | Name der View-Tabelle
LEN | FIXED(5) | Länge der Definition der View-Tabelle
DEFINITION | LONG | SQL-Anweisungstext der Definition der View-Tabelle

Siehe auch:

Systemtabellen auswerten, VIEWDEFS

VIEWCOLUMNS, VIEWS, VIEWTABLES

SQL-Referenzhandbuch, CREATE VIEW-Anweisung (create_view_statement)


VIEWS (SAP-Bibliothek - Grundwissen)

Objektdokumentation VIEWS

Definition

Die Systemtabelle VIEWS enthält alle View-Tabellen, für die der aktuelle Benutzer Privilegien besitzt.

Struktur

VIEWS

SCHEMANAME | CHAR(32) | Name des Schemas der View-Tabelle
OWNER | CHAR(32) | Name des Eigentümers der View-Tabelle
VIEWNAME | CHAR(32) | Name der View-Tabelle
PRIVILEGES | CHAR(30) | Privilegien des Benutzers für die View-Tabelle
TYPE | CHAR(8) | Typ der Tabelle
CREATEDATE | DATE(10) | Erzeugungsdatum der View-Tabelle
CREATETIME | TIME(8) | Erzeugungszeit der View-Tabelle
UPDSTATDATE | DATE(10) | Datum der zuletzt durchgeführten UPDATE STATISTICS-Anweisung für die View-Tabelle
UPDSTATTIME | TIME(8) | Zeit der zuletzt durchgeführten UPDATE STATISTICS-Anweisung für die View-Tabelle
ALTERDATE | DATE(10) | Änderungsdatum der View-Tabelle
ALTERTIME | TIME(8) | Änderungszeit der View-Tabelle
UNLOADED | CHAR(3) | View-Tabelle ist entladen (YES | NO)
WITHCHECKOPTION | CHAR(3) | Angabe, ob die View-Tabelle mit WITH CHECK OPTION angelegt wurde oder nicht (YES | NO)
COMPLEX | CHAR(3) | Angabe, ob es sich um eine komplexe View-Tabelle handelt oder nicht (YES | NO)
COMMENT | LONG | Kommentar zu der View-Tabelle

Siehe auch:

Systemtabellen auswerten, VIEWS

VIEWDEFS, VIEWCOLUMNS, VIEWTABLES

SQL-Referenzhandbuch, CREATE VIEW-Anweisung (create_view_statement)


VIEWTABLES (SAP-Bibliothek - Grundwissen)

Objektdokumentation VIEWTABLES

Definition

Die Systemtabelle VIEWTABLES enthält für alle View-Tabellen, für die der aktuelle Benutzer Privilegien besitzt, die Namen der zugrunde liegenden Tabellen.

Struktur

VIEWTABLES

SCHEMANAME | CHAR(32) | Name des Schemas der View-Tabelle
OWNER | CHAR(32) | Name des Eigentümers der View-Tabelle
VIEWNAME | CHAR(32) | Name der View-Tabelle
TABLESCHEMANAME | CHAR(32) | Name des Schemas der Tabelle
TABLENAME | CHAR(32) | Name der Tabelle

Siehe auch:

VIEWDEFS, VIEWCOLUMNS, VIEWS

SQL-Referenzhandbuch, CREATE VIEW-Anweisung (create_view_statement)


Restriktionen für SQL-Anweisungen (SAP-Bibliothek - Grundwissen)

Komponentendokumentation Restriktionen für SQL-Anweisungen

Maximale Länge einer SQL-Anweisung | ≥ 16 KB (Voreinstellung 64 KB), definiert durch einen Support-Datenbankparameter
Länge eines Bezeichners | 32 Zeichen
Genauigkeit numerischer Werte | 38 Stellen
Anzahl der Tabellen | unbegrenzt
Anzahl der Spalten pro Tabelle (mit KEY) | 1024
Anzahl der Spalten pro Tabelle (ohne KEY) | 1023
Anzahl der Primärschlüsselspalten pro Tabelle | 512
Anzahl der Spalten in einem Index | 16
Anzahl der Fremdschlüsselspalten pro Tabelle | 16
Anzahl der Spalten in einer ORDER- oder GROUP-Klausel | 128
Anzahl der Spalten in einer SELECT-Anweisung | 1023
Anzahl der Spalten in einer INSERT-Anweisung | 1024
Anzahl der Spalten in einer Ergebnistabelle | 1023
Anzahl der Join-Tabellen in einer SELECT-Anweisung | 254
Anzahl der JOIN-Prädikate in einer Suchbedingung | 128
Anzahl der Trigger pro Basistabelle | 3
Anzahl der Indizes pro Tabelle | 255
Anzahl der referentiellen CONSTRAINT-Definitionen (Fremdschlüsselbeziehungen) pro Tabelle | unbegrenzt
Anzahl der Referenzierungen pro Tabelle | unbegrenzt
Anzahl der Zeilen pro Tabelle | begrenzt durch die Datenbankgröße
Interne Länge einer Tabellenzeile | 8088 Bytes
Summe der internen Längen aller Schlüsselspalten | 1024 Bytes
Summe der internen Längen aller Fremdschlüsselspalten | 1024 Bytes
Summe der internen Längen aller zu einem Index gehörenden Spalten | 1024 Bytes
Interne Länge einer LONG-Spalte | 2 GB
Länge der Spalten in einer ORDER- oder GROUP-Klausel | 4016 Bytes
Anzahl der Schachtelungen bei Triggern | unbegrenzt
Anzahl der Schachtelungen bei Subqueries | 127
Anzahl der Join-Bedingungen in einer WHERE-Klausel einer SELECT-Anweisung | 128
Anzahl der Correlated Columns in einer SQL-Anweisung | 64
Anzahl der Correlated Tables in einer SQL-Anweisung | 16
Anzahl der Parameter in einer SQL-Anweisung | 2000

Siehe auch:

Konzepte des Datenbanksystems, Technische Restriktionen


SQL-Modus ORACLE (SAP-Bibliothek - Grundwissen)

Komponentendokumentation SQL-Modus ORACLE

Sie können das Datenbanksystem MaxDB im SQL-Modus ORACLE betreiben. In den folgenden Abschnitten sind die Unterschiede zwischen einem Datenbanksystem Oracle Version 7 und einem Datenbanksystem MaxDB (im SQL-Modus ORACLE) beschrieben.

Logische Datenbankstruktur

Die logische Datenbankstruktur der Datenbanksystem Oracle Version 7 und MaxDB unterscheidet sich grundlegend.

· Eine Oracle-Datenbank besteht aus logischer Sicht aus Tablespaces, Segmenten, Extents, Blöcken, Tabellen und Datensätzen.

· MaxDB besteht aus logischer Sicht im wesentlichen aus den Tabellen im Datenbankkatalog und den Anwendungsdaten in Form von Datensätzen.

Für MaxDB haben deshalb alle Oracle-SQL-Anweisungen, die mit der Verwaltung von Tablespaces, Segmenten, Extents oder Blöcken zu tun haben, keine Bedeutung.

Konsistentes Lesen/Sperren

Das von Oracle angebotene konsistente Lesen kann von MaxDB durch Sperren im Isolation-Level >= 2 erreicht werden.

Oracle erlaubt eine unbegrenzte Anzahl von exklusiven Zeilensperren. Bei MaxDB tritt ab einer gewissen Anzahl von Zeilensperren eine Eskalation in Kraft, d. h. die gesamte Tabelle wird gesperrt. Der Zeitpunkt der Eskalation ist abhängig von der definierten Größe der Sperrliste.

Datenbankprozeduren/Trigger

· In Oracle werden DB-Prozeduren, DB-Funktionen und Trigger in der ADA-ähnlichen Sprache PL/SQL definiert.

· In MaxDB werden Datenbankprozeduren, Datenbankfunktionen und Trigger in einer C-ähnlichen Sprache definiert.

DBA-Benutzer und Privilegien

Im Gegensatz zu Oracle unterliegen in MaxDB auch Datenbankadministratoren (DBA-Benutzer) dem Privilegienkonzept und können nicht beliebige DDL-Anweisungen (z. B. CREATE INDEX) oder DML-Anweisungen (z. B. DELETE) ausführen, wenn ihnen keine entsprechenden Privilegien zugeordnet sind.

Weitere Unterschiede

· SQL-Syntaxelemente

· SQL-Anweisungen

· Systemtabellen

· Fehlermeldungen


SQL-Syntaxelemente (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL-Syntaxelemente

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich in folgenden Bereichen:

· Datenbankobjekt

· Name

· Namensraum

· Zugriff auf Objekte

· Ganze Zahl

· Zahl

· Datentyp

· Pseudospalte

· Operator

· Funktion

· Format


Datenbankobjekt (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datenbankobjekt

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition der möglichen Datenbankobjekte.

Folgende Datenbankobjekte werden von MaxDB nicht unterstützt:

· Cluster

· Database-Link

· Package

· Profile

· Rollback-Segment

· Snapshot

· Snapshot-Log

· Tablespace

Folgendes Datenbankobjekt wird von MaxDB unterstützt, nutzt aber eine andere Syntax als Oracle:

Procedure (Objekt in MaxDB: Datenbankprozedur)


Name (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Name

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition der Namen für Objekte.

Wenn von MaxDB Namen für Objekte vergeben werden, dann unterschieden sich diese von Namen, die von Oracle erzeugt werden.

Folgende Schlüsselwörter sind in Oracle 7 reserviert, nicht jedoch in MaxDB:

ACCESS | COMPRESS | ELSE | FILE
IMMEDIATE | INCREMENT | INITIAL | MAXEXTENTS
NOAUDIT | NOCOMPRESS | OFFLINE | ONLINE
PRIOR | SIZE | START | SUCCESSFUL
THEN | VALIDATE |  |

Diese Schlüsselwörter sollten in MaxDB wenn möglich nicht zur Benennung von Objekten verwendet werden.

Eine Liste aller in MaxDB reservierten Schlüsselwörter finden Sie im Referenzhandbuch in reserved_key_word.

Eine Liste aller in MaxDB nicht reservierten Schlüsselwörter finden Sie im Referenzhandbuch in not_reserved_key_word.


Namensraum (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Namensraum

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition der Namensräume.

Unterschiede im Namensraum

Oracle 7 | MaxDB
Alle Indizes einer Datenbankinstanz bilden einen Namensraum. | Alle Indizes einer Tabelle bilden einen Namensraum.
Alle Constraints einer Datenbankinstanz bilden einen Namensraum. | Alle Constraints einer Tabelle bilden einen Namensraum.
Alle Trigger einer Datenbankinstanz bilden einen Namensraum. | Alle Trigger einer Tabelle bilden einen Namensraum.
Alle Sequenzen bilden gemeinsam mit den Tabellen, Views, Synonymen, Prozeduren und weiteren Objekten einen Namensraum. | Alle Sequenzen einer Datenbankinstanz bilden einen eigenen Namensraum.
Alle Prozeduren bilden gemeinsam mit den Tabellen, Views, Sequenzen, Synonymen und weiteren Objekten einen Namensraum. | Alle Datenbankprozeduren einer Datenbankinstanz bilden einen eigenen Namensraum.


Zugriff auf Objekte (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Zugriff auf Objekte

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem beim Zugriff auf die Objekte.

Wenn kein Schema beim Zugriff auf ein Datenbankobjekt angegeben wird und kein Objekt des aktuellen Benutzers mit diesem Namen existiert, dann gilt im Gegensatz zu Oracle für MaxDB folgende Vorgehensweise, um auf das Datenbankobjekt zuzugreifen:

...

1. MaxDB durchsucht die PUBLIC-Synonyme nach diesem Objekt.

2. Wenn das Objekt nicht gefunden wurde, durchsucht MaxDB den Datenbankkatalogteil des DBA-Benutzers, der den aktuellen Benutzer erzeugt hat, nach diesem Objekt.

3. Wenn das Objekt nicht gefunden wurde, durchsucht MaxDB den Datenbankkatalogteil des Datenbanksystemadministrators (SYSDBA-Benutzers) nach diesem Objekt.


Ganze Zahl (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Ganze Zahl

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition der ganzen Zahlen.

Eine ganze Zahl (integer) hat im Unterschied zu Oracle in MaxDB 20 signifikante Zeichen.


Zahl (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Zahl

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition der Zahlen.

· Der zulässige Wertebereich für Zahlen umfasst für Oracle Werte von 0.999E-128 bis 0.999E126.

· Der zulässige Wertebereich von Gleitkommazahlen (Zahl) besteht für MaxDB aus dem Intervall von -9.9999999999999999999999999999999999999E+62 bis -1E-64, dem Wert 0.0 sowie aus dem Intervall von +1E-64 bis +9.9999999999999999999999999999999999999E+62.


Datentyp (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Datentyp

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition der Datentypen.

· Spalten vom Datentyp CHAR[ACTER] werden im Gegensatz zu Oracle von MaxDB nur bis zu einer Länge von 30 Zeichen mit fester Länge abgelegt.

· Der Oracle-Datentyp VARCHAR2 unterscheidet sich in MaxDB nicht von VARCHAR.

· Die Datentypen INT[EGER] und SMALLINT haben in MaxDB 20 signifikante Zeichen.

· Der Datentyp FLOAT wird von MaxDB immer mit 20 signifikanten Stellen dargestellt.

· In MaxDB ist es bei numerischen Datentypen nicht möglich, eine negative Anzahl von Nachkommastellen zu definieren. Ferner darf die Anzahl von Nachkommastellen nicht größer als die Anzahl der signifikanten Stellen gewählt werden.

· In MaxDB findet keine implizite Konvertierung von Zahlen in Datumswerte oder umgekehrt statt.

· Datumswerte in Oracle reichen vom 1.1.4712 v. Chr. bis zum 31.12.9999 n.Chr.
Datumswerte in MaxDB reichen vom 1.1.0001 bis zum 31.12.9999.

· Der von Oracle als "non padded comparison" bezeichnete Vergleich von Zeichenketten wird von MaxDB nicht unterstützt.

· Die von Oracle unterstützten Datentypen NCHAR, NVARCHAR2, MLSLABEL, BLOB, CLOB, NCLOB, BFILE und UROWID werden von MaxDB nicht unterstützt.


Pseudospalte (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Pseudospalte

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition der Pseudospalten.

· Die Pseudospalte LEVEL wird von MaxDB nicht unterstützt.

· Die Pseudospalte ROWID kann nur verwandt werden, wenn in der CREATE TABLE-Anweisung <create_table_statement> die Option ROWID angegeben wurde. Im Gegensatz zu Oracle liefert MaxDB eine logische Spaltenidentifikation vom Datentyp RAW(8).

· Die Pseudospalte ROWNUM kann in MaxDB nicht in der UPDATE-Anweisung <update_statement> verwendet werden.

· Die Pseudospalte ROWNUM wird in eine selektierte Spalte (select_column) eingetragen, nachdem die Ergebnistabelle sortiert wurde.


Operator (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Operator

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition von Operatoren.

Der Oracle-Operator PRIOR steht in MaxDB nicht zur Verfügung.


Funktion (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Funktion

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition der Funktionen.

· Folgende Oracle-Funktionen stehen in MaxDB nicht als Funktionen zur Verfügung:

- CHARTOROWID

- ROWIDTOCHAR

- CONVERT

- DUMP

- USERENV

- NLS_INITCAP

- NLS_LOWER

- NLS_UPPER

- TO_MULTI_BYTE

- TO_SINGLE_BYTE

- INSTRB

- LENGTHB

- SUBSTRB

· Bei Angabe der Stringfunktionen LPAD und RPAD in MaxDB darf die Zeichenkette x nicht länger als n sein.

· Bei Angabe der Stringfunktion SUBSTR in MaxDB darf a nicht kleiner als 1 sein.

· Bei Angabe der Funktion INSTR in MaxDB darf der Parameter "n" nicht kleiner als 1 sein.

· Bei Angabe der Funktionen TO_CHAR, TO_DATE und TO_NUMBER in MaxDB steht der Parameter "nlsparams" nicht zur Verfügung.


Format (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Format

Die SQL-Syntaxelemente für Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheiden sich unter anderem bei der Definition des Datumsformats.

Wenn nicht anders in der ALTER SESSION-Anweisung angegeben, wird das Datumsformat DD-MON-YY, die Sprache Englisch und die Sortierung BINARY für eine Datenbanksitzung angenommen.


SQL-Anweisungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation SQL-Anweisungen

In diesem Abschnitt werden alle Oracle-SQL-Anweisungen aufgeführt, bei denen sich das Verhalten von Oracle Version 7 und MaxDB im SQL-Modus ORACLE unterscheidet.

Eine genaue Syntaxbeschreibung der Oracle-SQL-Anweisungen finden Sie nicht in den folgenden Abschnitten, sondern nur im Handbuch ORACLE7 Server SQL Reference Manual. Die Oracle-SQL-Anweisungen werden in der gleichen Reihenfolge wie im Handbuch ORACLE7 Server SQL Reference Manual aufgeführt.

Um die Syntaxerläuterungen besser verstehen zu können, wurde gegebenenfalls direkt auf die Syntaxbeschreibung der entsprechenden MaxDB-SQL-Anweisung im SQL-Referenzhandbuch verwiesen

Bei SQL-Anweisungen, die hier nicht beschrieben werden, können Sie davon ausgehen, dass außer den allgemeinen Unterschieden keine Unterschiede vorliegen.


alter_cluster_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_cluster_statement

Das Schema-Objekt Cluster wird von MaxDB nicht unterstützt. Die SQL-Anweisung ALTER CLUSTER (alter_cluster_statement) wird daher von MaxDB nicht akzeptiert.


alter_database_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_database_statement

Die SQL-Anweisung ALTER DATABASE (alter_database_statement) wird von MaxDB nicht akzeptiert.


alter_function_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_function_statement

Die SQL-Anweisung ALTER FUNCTION (alter_function_statement) wird von MaxDB abgelehnt.


alter_index_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_index_statement

Die Änderung von Speichercharakteristika für Indizes ist in MaxDB wegen der Reorganisationsfreiheit unnötig. Die SQL-Anweisung ALTER INDEX (alter_index_statement) ist in MaxDB bekannt, jedoch mit einer von Oracle verschiedenen Syntax und Semantik (ALTER INDEX-Anweisung (alter_index_statement)).


alter_package_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_package_statement

Die SQL-Anweisung ALTER PACKAGE (alter_package_statement) wird von MaxDB nicht akzeptiert.


alter_procedure_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_procedure_statement

Die SQL-Anweisung ALTER PROCEDURE (alter_procedure_statement) wird von MaxDB nicht akzeptiert.


alter_profile_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_profile_statement

Das Schema-Objekt Profile wird von MaxDB nicht unterstützt. Die SQL-Anweisung ALTER PROFILE (alter_profile_statement) wird daher von MaxDB nicht akzeptiert


alter_resource_cost_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_resource_cost_statement

Die SQL-Anweisung ALTER RESOURCE COST (alter_resource_cost_statement) wird von MaxDB nicht akzeptiert.


alter_role_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_role_statement

Die SQL-Anweisung ALTER ROLE (alter_role_statement) wird von MaxDB nicht akzeptiert.


alter_rollback_segment_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_rollback_segment_statement

Das Schema-Objekt Rollback-Segment wird von MaxDB nicht unterstützt. Die SQL-Anweisung ALTER ROLLBACK SEGMENT (alter_rollback_segment_statement) wird daher von MaxDB nicht akzeptiert.


alter_sequence_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_sequence_statement

Die SQL-Anweisung ALTER SEQUENCE (alter_sequence_statement) wird von MaxDB nicht akzeptiert.


alter_snapshot_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_snapshot_statement

Das Schema-Objekt Snapshot wird von MaxDB nicht unterstützt. Die SQL-Anweisung ALTER SNAPSHOT (alter_snapshot_statement) wird daher von MaxDB nicht akzeptiert


alter_snapshot_log_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_snapshot_log_statement

Das Schema-Objekt Snapshot-Log wird von MaxDB nicht unterstützt. Die SQL-Anweisung ALTER SNAPSHOT LOG (alter_snapshot_log_statement) wird daher von MaxDB nicht akzeptiert.


alter_system_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_system_statement

Die SQL-Anweisung ALTER SYSTEM (alter_system_statement) wird von MaxDB nicht akzeptiert.


alter_table_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_table_statement

Die SQL-Anweisung ALTER TABLE (alter_table_statement) ist in MaxDB bekannt, jedoch mit einer von Oracle verschiedenen Syntax und Semantik (ALTER TABLE-Anweisung (alter_table_statement)).

· Die Varianten PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, DROP und ALLOCATE besitzen für MaxDB keine Bedeutung und werden nicht akzeptiert.

· Constraints können von MaxDB nicht deaktiviert werden. Die Angabe von DISABLE wird daher von MaxDB ignoriert.

· Mit Hilfe der DROP-Klausel (drop_clause) können von MaxDB keine UNIQUE-Constraints gelöscht werden. Statt dessen muss die DROP INDEX-Anweisung (drop_index_statement) benutzt werden.

· Beim Hinzufügen von Spalten werden von MaxDB diese Spalten automatisch allen View-Tabellen hinzugefügt, die den "*" in der <select_list> benutzen, um alle Spalten der Tabelle zu identifizieren.


alter_tablespace_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_tablespace_statement

Das Schema-Objekt Tablespace wird von MaxDB nicht unterstützt. Die SQL-Anweisung ALTER TABLESPACE (alter_tablespace_statement) wird daher von MaxDB nicht akzeptiert.


alter_trigger_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_trigger_statement

Trigger können von MaxDB nicht deaktiviert werden. Die SQL-Anweisung ALTER TRIGGER (alter_trigger_statement) wird daher von MaxDB nicht akzeptiert.


alter_user_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_user_statement

Die SQL-Anweisung ALTER USER (alter_user_statement) wird in MaxDB mit eingeschränkter Syntax unterstützt. Mit Hilfe der ALTER USER-Anweisung (alter_user_statement) kann in MaxDB ausschließlich das Kennwort des Benutzers verändert werden. Die Angabe von EXTERNALLY wird von MaxDB nicht akzeptiert.

Alle anderen Varianten der ALTER USER-Anweisung werden von MaxDB nicht akzeptiert.


alter_view_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation alter_view_statement

View-Tabellen werden von MaxDB immer in einem ausführbaren Zustand gehalten. Die SQL-Anweisung ALTER VIEW (alter_view_statement) ist daher nicht nötig und wird nicht akzeptiert.


analyze_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation analyze_statement

Für die SQL-Anweisung ANALYZE (analyze_statement) wird in MaxDB ausschließlich die Variante ANALYZE TABLE unterstützt. Die Optionen DELETE, VALIDATE STRUCTURE und LIST CHAINED ROWS sind in MaxDB nicht zulässig.


audit_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation audit_statement

Die SQL-Anweisung AUDIT (audit_statement) wird von MaxDB nicht akzeptiert.


commit_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation commit_statement

Für die SQL-Anweisung COMMIT (commit_statement) wird die Angabe von FORCE oder COMMENT von MaxDB nicht akzeptiert.


constraint_clause (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation constraint_clause

Für das in SQL-Anweisungen verwendete Syntaxelement CONSTRAINT-Klausel (constraint_clause) gibt es bei Verwendung in MaxDB folgende Einschränkungen:

· Ein Constraint-Name (constraint_name) für einen Schlüssel oder [NOT] NULL wird nicht im Datenbankkatalog abgelegt.

· USING INDEX ist syntaktisch zulässig, hat jedoch für MaxDB keine Bedeutung.

· Die Option DISABLE wird von MaxDB ignoriert.


create_cluster_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_cluster_statement

Das Schema-Objekt Cluster wird von MaxDB nicht unterstützt. Die SQL-Anweisung CREATE CLUSTER (create_cluster_statement) wird daher von MaxDB nicht akzeptiert.


create_controlfile_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_controlfile_statement

Die SQL-Anweisung CREATE CONTROLFILE (create_controlfile_statement) wird von MaxDB nicht akzeptiert.


create_database_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_database_statement

Die SQL-Anweisung CREATE DATABASE (create_database_statement) wird von MaxDB nicht akzeptiert.


create_database_link_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_database_link_statement

Das Schema-Objekt Database-Link wird von MaxDB nicht unterstützt. Die SQL-Anweisung CREATE DATABASE LINK (create_database_link_statement) wird daher von MaxDB nicht akzeptiert.


create_index_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_index_statement

Die SQL-Anweisung CREATE INDEX (create_index_statement) ist in MaxDB bekannt, jedoch mit einer von Oracle verschiedenen Syntax und Semantik (CREATE INDEX-Anweisung (create_index_statement)).

· Die Angabe von CLUSTER <cluster>, INITRANS <integer>, MAXTRANS <integer>, TABLESPACE <tablespace>, STORAGE <storage_clause>, PCTFREE <integer> und NOSORT hat für MaxDB keine Bedeutung, wird jedoch syntaktisch akzeptiert.

· In MaxDB wird der Index bei Angabe von DESC in absteigender Ordnung erzeugt.


create_package_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_package_statement

Die SQL-Anweisung CREATE PACKAGE (create_package_statement) wird von MaxDB nicht akzeptiert.


create_package_body_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_package_body_statement

Die SQL-Anweisung CREATE PACKAGE BODY (create_package_body_statement) wird von MaxDB nicht akzeptiert.


create_procedure_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_procedure_statement

Die SQL-Anweisung CREATE PROCEDURE (create_procedure_statement) wird von MaxDB nicht akzeptiert.

Im Datenbanksystem MaxDB verwenden Sie zum Anlegen einer Datenbankprozedur die CREATE DBPROC-Anweisung (create_dbproc_statement).


create_profile_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_profile_statement

Das Schema-Objekt Profile wird von MaxDB nicht unterstützt. Die SQL-Anweisung CREATE PROFILE (create_profile_statement) wird daher von MaxDB nicht akzeptiert


create_rollback_segment_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_rollback_segment_statement

Das Schema-Objekt Rollback-Segment wird von MaxDB nicht unterstützt. Die SQL-Anweisung CREATE ROLLBACK SEGMENT (create_rollback_segment_statement) wird daher von MaxDB nicht akzeptiert.


create_sequence_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_sequence_statement

Die SQL-Anweisung CREATE SEQUENCE (create_sequence_statement) wird von MaxDB mit folgender syntaktischer Einschränkung akzeptiert: die Option ORDER hat für MaxDB keine Bedeutung (CREATE SEQUENCE-Anweisung (create_sequence_statement)).


create_snapshot_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_snapshot_statement

Das Schema-Objekt Snapshot wird von MaxDB nicht unterstützt. Die SQL-Anweisung CREATE SNAPSHOT (create_snapshot_statement) wird daher von MaxDB nicht akzeptiert.


create_snapshot_log_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_snapshot_log_statement

Das Schema-Objekt Snapshot-Log wird von MaxDB nicht unterstützt. Die SQL-Anweisung CREATE SNAPSHOT LOG (create_snapshot_log_statement) wird daher von MaxDB nicht akzeptiert.


create_synonym_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_synonym_statement

MaxDB erlaubt keine Synonyme für Datenbankprozeduren, Synonyme und Sequenzen.

Zum Zeitpunkt der Ausführung der SQL-Anweisung CREATE SYNONYM (create_synonym_statement) muss das Objekt, für das das Synonym in MaxDB definiert wird, existieren. Der aktuelle Benutzer muss ein Privileg für dieses Objekt besitzen.


create_table_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_table_statement

Die SQL-Anweisung CREATE TABLE (create_table_statement) ist in MaxDB bekannt, jedoch mit einer von Oracle verschiedenen Syntax und Semantik (CREATE TABLE-Anweisung (create_table_statement)).

· Die Angabe von PCTFREE <integer>, PCTUSED <integer>, INITRANS <integer>, MAXTRANS <integer>, TABLESPACE <tablespace> STORAGE <storage clause> und CLUSTER <cluster> besitzt für MaxDB keine Bedeutung, wird jedoch syntaktisch akzeptiert.

· Die Angabe von DISABLE wird von MaxDB ignoriert.

· Bei Angabe einer Subquery (subquery) werden von MaxDB keine NOT NULL-Constraints generiert.

· Jede Zeile einer Tabelle besitzt in Oracle eine eindeutige Adresse, die als ROWID zugreifbar ist und über die die Zeile direkt adressiert werden kann. Diese ROWID existiert auch dann, wenn die Tabelle einen Schlüssel besitzt. MaxDB besitzt eine Adresse dieser Art nicht, da die Zeilen immer über den Schlüssel adressiert werden.
Um das Oracle-Verhalten besser nachbilden zu können, gibt es die Tabellenoption ROWID, die folgendes bewirkt:
- Die Tabelle erhält implizit die Schlüsselspalte ROWID vom Datentyp RAW(8). Diese Spalte ist normalerweise unsichtbar und kann nur durch die Funktion ROWID selektiert werden.
-Falls die CREATE TABLE-Anweisung eine Schlüsseldefinition (key_definition) enthält, wird implizit ein Index mit dem UNIQUE-Attribut erzeugt, der der Schlüsseldefinition entspricht.

Eine Zeile besitzt auf diese Weise eine ROWID und kann sowohl über diese als auch über den Schlüssel schnell selektiert werden.


create_tablespace_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_tablespace_statement

Das Schema-Objekt Tablespace wird von MaxDB nicht unterstützt. Die SQL-Anweisung CREATE TABLESPACE (create_tablespace_statement) wird dennoch von MaxDB syntaktisch akzeptiert, hat jedoch keine Auswirkungen.


create_trigger_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_trigger_statement

Mit der SQL-Anweisung CREATE TRIGGER (create_trigger_statement) können in MaxDB ausschließlich die von Oracle als „after row trigger“ bezeichneten Trigger definiert werden.

Im Datenbanksystem MaxDB verwenden Sie zum Anlegen eines Triggers die CREATE TRIGGER-Anweisung (create_trigger_statement).


create_user_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_user_statement

Die SQL-Anweisung CREATE USER (create_user_statement) wird in MaxDB mit eingeschränkter Syntax unterstützt. In der CREATE USER-Anweisung (create_user_statement) akzeptiert MaxDB nicht die Angabe von IDENTIFIED EXTERNALLY, GLOBALLY AS <external_name>, DEFAULT TABLESPACE <tablespace>, TEMPORARY TABLESPACE <tablespace>, QUOTA und PROFILE <profile>.

Der erzeugte Benutzer besitzt den Status RESOURCE.


create_view_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation create_view_statement

Die SQL-Anweisung CREATE VIEW (create_view_statement) wird in MaxDB mit eingeschränkter Syntax unterstützt. Für die Syntax der CREATE VIEW-Anweisung (create_view_statement) gibt es in MaxDB folgende Einschränkungen:

· Die Angabe von FORCE oder NOFORCE wird von MaxDB nicht akzeptiert.

· Ein für die CHECK OPTION vergebener Constraint-Name (constraint_name) wird nicht im Datenbankkatalog abgelegt. Wenn kein Constraint-Name angegeben ist, wird von MaxDB kein Name erzeugt.

· View-Tabellen, die von Oracle als änderbar erkannt werden, sind nicht notwendigerweise auch in MaxDB änderbar. Dies gilt insbesondere für View-Tabellen, die in ihrer Definition Subqueries enthalten.


declare_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation declare_statement

Die Angabe der SQL-Anweisung DECLARE (declare_statement) ist für MaxDB mit folgender syntaktischer Einschränkung möglich: die Angabe eines PL/SQL-Blocks wird nicht akzeptiert.


declare_table_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation declare_table_statement

Die SQL-Anweisung DECLARE TABLE (declare_table_statement) wird von MaxDB akzeptiert, hat jedoch für MaxDB keine Bedeutung.


delete_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation delete_statement

Die SQL-Anweisung DELETE (delete_statement) wird in MaxDB mit eingeschränkter Syntax unterstützt (DELETE-Anweisung (delete_statement)).

· Bei Angabe von CURRENT OF <cursor> in MaxDB muss der Ergebnistabelle eine änderbare Tabelle zugrundeliegen.

· Ein Cursor, der durch einen Join oder eine Join-View-Tabelle gebildet wurde, wird in MaxDB nicht akzeptiert.


describe_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation describe_statement

Die Angabe der SQL-Anweisung DESCRIBE (describe_statement) ist für MaxDB mit folgender syntaktischer Einschränkung möglich: die Angabe eines PL/SQL-Blocks wird nicht akzeptiert.


drop_cluster_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_cluster_statement

Das Schema-Objekt Cluster wird von MaxDB nicht unterstützt. Die SQL-Anweisung DROP CLUSTER (drop_cluster_statement) wird daher von MaxDB nicht akzeptiert.


drop_database_link_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_database_link_statement

Das Schema-Objekt Database-Link wird von MaxDB nicht unterstützt. Die SQL-Anweisung DROP DATABASE LINK (drop_database_link_statement) wird daher von MaxDB nicht akzeptiert.


drop_index_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_index_statement

Die SQL-Anweisung DROP INDEX (drop_index_statement) wird mit folgender Einschränkung von MaxDB akzeptiert: aufgrund der unterschiedlichen Namensräume für Indizes wird in MaxDB durch Angabe eines Indexnamens nicht immer eindeutig ein Index identifiziert. In diesem Fall muss explizit die Tabelle angegeben werden, auf die sich der Index bezieht.


drop_procedure_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_procedure_statement

Die SQL-Anweisung DROP PROCEDURE (drop_procedure_statement) wird von MaxDB nicht akzeptiert.

Im Datenbanksystem MaxDB verwenden Sie zum Löschen einer Datenbankprozedur die DROP DBPROC-Anweisung (drop_dbproc_statement).


drop_profile_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_profile_statement

Das Schema-Objekt Profile wird von MaxDB nicht unterstützt. Die SQL-Anweisung DROP PROFILE (drop_profile_statement) wird daher von MaxDB nicht akzeptiert


drop_rollback_segment_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_rollback_segment_statement

Das Schema-Objekt Rollback-Segment wird von MaxDB nicht unterstützt. Die SQL-Anweisung DROP ROLLBACK SEGMENT (drop_rollback_segment_statement) wird daher von MaxDB nicht akzeptiert.


drop_snapshot_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_snapshot_statement

Das Schema-Objekt Snapshot wird von MaxDB nicht unterstützt. Die SQL-Anweisung DROP SNAPSHOT (drop_snapshot_statement) wird daher von MaxDB nicht akzeptiert


drop_snapshot_log_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_snapshot_log_statement

Das Schema-Objekt Snapshot-Log wird von MaxDB nicht unterstützt. Die SQL-Anweisung DROP SNAPSHOT LOG (drop_snapshot_log_statement) wird daher von MaxDB nicht akzeptiert.


drop_table_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_table_statement

Die SQL-Anweisung DROP TABLE (alter_table_statement) ist in MaxDB bekannt, jedoch mit folgenden syntaktischen Einschränkungen:

· Alle auf der Tabelle basierenden Synonyme und View-Tabellen werden in MaxDB gelöscht.

· Die Angabe von CASCADE CONSTRAINTS hat in MaxDB keine Wirkung.


drop_tablespace_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_tablespace_statement

Das Schema-Objekt Tablespace wird von MaxDB nicht unterstützt. Die SQL-Anweisung DROP TABLESPACE (drop_tablespace_statement) wird daher von MaxDB nicht akzeptiert.


drop_trigger_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_trigger_statement

Aufgrund der unterschiedlichen Namensräume für Trigger wird in MaxDB durch Angabe eines Triggernamens der Trigger nicht eindeutig identifiziert.

Die SQL-Anweisung DROP TRIGGER (drop_trigger_statement) wird von MaxDB daher nur mit folgender Einschränkung akzeptiert: es muss explizit die Tabelle angegeben werden, auf die sich der Trigger bezieht (siehe dazu DROP TRIGGER-Anweisung (drop_trigger_statement)).


drop_view_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation drop_view_statement

Mit der SQL-Anweisung DROP VIEW (drop_view_statement) werden in MaxDB alle auf der View-Tabelle basierenden Synonyme und View-Tabellen gelöscht.


execute_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation execute_statement

Die Angabe der SQL-Anweisung EXECUTE (execute_statement) ist für MaxDB mit folgender syntaktischer Einschränkung möglich: die Angabe eines PL/SQL-Blocks wird nicht akzeptiert.


explain_plan_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation explain_plan_statement

Die SQL-Anweisung EXPLAIN PLAN (explain_plan_statement) wird von MaxDB nicht akzeptiert.

Allerdings gibt es eine ähnliche SQL-Anweisung in MaxDB: EXPLAIN-Anweisung (explain_statement).


grant_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation grant_statement

Die SQL-Anweisung GRANT (grant_statement) ist in MaxDB bekannt, jedoch mit einem von Oracle verschiedenen Verhalten in folgenden Bereichen (GRANT-Anweisung (grant_statement)).

· Die Vergabe von System-Privilegien wird von MaxDB nicht akzeptiert.

· Bei Vergabe von Objekt-Privilegien kann in MaxDB das Schema-Objekt Package nicht angegeben werden.


insert_statement (embedded SQL) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation insert_statement (embedded SQL)

Die SQL-Anweisung INSERT (insert_statement) wird in MaxDB mit folgender Einschränkung akzeptiert (INSERT-Anweisung (insert_statement)): die Angabe von Array-Hostvariablen in der WHERE-Klausel wird von MaxDB nicht akzeptiert.


lock_table_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation lock_table_statement

Die SQL-Anweisung LOCK TABLE (lock_table_statement) wird von MaxDB mit folgenden syntaktischen Einschränkungen akzeptiert: bei Angabe von ROW EXCLUSIVE, SHARE ROW EXCLUSIVE oder EXCLUSIVE wird von MaxDB eine Tabellen-Schreibsperre vergeben. Konkurrierende Anfragen auf der Tabelle sind somit nicht möglich.


noaudit_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation noaudit_statement

Die SQL-Anweisung NOAUDIT (noaudit_statement) wird von MaxDB nicht akzeptiert.


rename_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation rename_statement

Die SQL-Anweisung RENAME (rename_statement) ist in MaxDB bekannt, jedoch mit einem von Oracle verschiedenen Verhalten: in MaxDB können ausschließlich Basistabellen umbenannt werden.


revoke_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation revoke_statement

Die SQL-Anweisung REVOKE (revoke_statement) ist in MaxDB bekannt, jedoch mit einem von Oracle verschiedenen Verhalten in folgenden Bereichen (REVOKE-Anweisung (revoke_statement)).

· Der Entzug von System-Privilegien wird von MaxDB nicht akzeptiert.

· Bei Entzug von Objekt-Privilegien kann in MaxDB das Schema-Objekt Package nicht angegeben werden.


rollback_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation rollback_statement

Die SQL-Anweisung ROLLBACK (rollback_statement) wird in MaxDB mit eingeschränkter Syntax unterstützt (ROLLBACK-Anweisung (rollback_statement)).

· Die Angabe von FORCE wird von MaxDB nicht akzeptiert.

· Bei Angabe von ROLLBACK TO [SAVEPOINT] <savepoint> werden von MaxDB keine Sperren freigegeben.


select_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation select_statement

Die SQL-Anweisung SELECT (select_statement) wird in MaxDB mit eingeschränkter Syntax unterstützt (SELECT-Anweisung (select_statement)).

· Die Angabe von START WITH <condition> oder CONNECT BY <condition> wird von MaxDB nicht unterstützt.

· In Oracle zulässige Outer-Joins mit mehr als zwei Tabellen in der FROM-Klausel werden von MaxDB teilweise abgelehnt.

· Sollen durch eine SELECT-Anweisung gewonnene Ergebnismengen einer Tabelle änderbar sein, muss das Syntaxelement FOR UPDATE angegeben werden.


set_transaction_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation set_transaction_statement

Die SQL-Anweisung SET TRANSACTION (set_transaction_statement) wird von MaxDB nicht akzeptiert.


truncate_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation truncate_statement

Die SQL-Anweisung TRUNCATE (truncate_statement) wird von MaxDB nur mit eingeschränkter Syntax unterstützt:

  • Die Anweisung TRUNCATE CLUSTER [<schema>.]<cluster> wird von MaxDB nicht akzeptiert.
  • Die Syntaxelemente DROP/REUSE STORAGE werden von MaxDB akzeptiert. Semantisch sind sie jedoch ohne Bedeutung, da sie ein Verhalten fordern, das bei MaxDB Standard ist.


update_statement (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation update_statement

Die SQL-Anweisung UPDATE (update_statement) wird in MaxDB mit eingeschränkter Syntax unterstützt (UPDATE-Anweisung (update_statement)).

· Eine Correlated Subquery ist als Subquery (subquery) einer SET UPDATE-Klausel in MaxDB nicht zulässig.

· Bei Angabe von CURRENT OF <cursor> muss in MaxDB der Ergebnistabelle eine änderbare Tabelle zugrunde liegen. Ein Cursor, der durch einen Join oder eine Join-View-Tabelle gebildet wurde, wird nicht akzeptiert.


Systemtabellen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Systemtabellen

Folgende Systemtabellen sind in MaxDB zwar bekannt, enthalten aber keine Einträge, da die entsprechenden Objekte oder Informationen in MaxDB nicht existieren:

ALL_ERRORS
ALL_SOURCE
ALL_SNAPSHOTS
ALL_TRIGGER_COLS

DBA_2PC_NEIGHBORS
DBA_2PC_PENDING
DBA_AUDIT_EXISTS
DBA_AUDIT_OBJECT
DBA_AUDIT_SESSION
DBA_AUDIT_STATEMENT
DBA_AUDIT_TRAIL
DBA_BLOCKERS
DBA_CLUSTERS
DBA_CLU_COLUMNS
DBA_DATA_FILES
DBA_DDL_LOCKS
DBA_DML_LOCKS
DBA_ERRORS
DBA_EXP_FILES
DBA_EXP_OBJECTS
DBA_EXTENTS
DBA_LOCKS
DBA_OBJECT_SIZE
DBA_PRIV_AUDIT_OPTS
DBA_PROFILES
DBA_ROLLBACK_SEGS
DBA_SNAPSHOTS
DBA_SNAPSHOT_LOGS
DBA_SOURCE
DBA_STMT_AUDIT_OPTS
DBA_SYS_PRIVS
DBA_TABLESPACES
DBA_TRIGGER_COLS
DBA_TS_QUOTAS

RESOURCE_COST
ROLE_SYS_PRIVS
ROLE_TAB_PRIVS

USER_AUDIT_OBJECT
USER_AUDIT_SESSION
USER_AUDIT_TRAIL
USER_CLUSTERS
USER_CLU_COLUMNS
USER_ERRORS
USER_EXTENTS
USER_OBJECT_SIZE
USER_SNAPSHOTS
USER_SNAPSHOT_LOGS
USER_SOURCE
USER_SYS_PRIVS
USER_TABLESPACES
USER_TRIGGER_COLS
USER_TS_QUOTAS

Folgende Spalten von Systemtabellen enthalten immer einen NULL-Wert, weil MaxDB die Informationen nicht in der notwendigen Form vorliegen:

Systemtabelle(n) | Spalte(n)
ALL_CONSTRAINT, USER_CONSTRAINTS, DBA_CONSTRAINTS | R_CONSTRAINT_NAME
ALL_DEPENDENCIES, USER_DEPENDENCIES, DBA_DEPENDENCIES | REFERENCED_LINK_NAME
ALL_INDEXES, USER_INDEXES, DBA_INDEXES | PREFIX_LENGTH INI_TRANS MAX_TRANS INITIAL_EXTENT NEXT_EXTENT MIN_EXTENT MAX_EXTENTS PCT_INCREASE PCT_FREE BLEVEL LEAF_BLOCKS AVG_LEAF_BLOCKS_PER_KEY AVG_DATA_BLOCKS_PER_KEY CLUSTERING_FACTOR NUM_ROWS SAMPLE_SIZE LAST_ANALYZED DEGREE INSTANCES BUFFER_POOL DUARTION PCT_DIRECT_ACCESS ITYP_OWNER ITYP_NAME PARAMETERS GLOBAL_STATS
ALL_OBJECTS, USER_OBJECTS, DBA_OBJECTS | SUBOBJECT_NAME DATA_OBJECT_ID
ALL_SYNONYMS, USER_SYNONYMS, DBA_SYNONYMS | DB_LINK
ALL_TABLES, USER_TABLES, DBA_TABLES | CLUSTER_NAME IOT_NAME PCT_FREE PCT_USED INI_TRANS MAX_TRANS INITIAL_EXTENT NEXT_EXTENT MIN_EXTENT MAX_EXTENTS PCT_INCREASE FREELISTS FREELIST_GROUPS BLOCKS EMPTY_BLOCKS AVG_SPACE CHAIN_CNT AVG_ROW_LEN AVG_SPACE_FREELIST_BLOCKS NUM_FREELIST_BLOCKS DEGREE INSTANCES IOT_TYPE BUFFER_POOL ROW_MOVEMENT GLOBAL_STATS DUARTION SKIP_CORRUPT MONITORING
ALL_TAB_COLUMNS, USER_TAB_COLUMNS, DBA_TAB_COLUMNS | DATA_TYPE_MOD DATA_TYPE_OWNER LOW_VALUE HIGH_VALUE DENSITY NUM_NULLS NUM_BUCKETS LAST_ANALYZED SAMPLE_SIZE GLOBAL_STATS AVG_COL_LENGTH
ALL_TRIGGERS, USER_TRIGGERS, DBA_TRIGGERS | COLUMN_NAME REFERENCING_NAME WHEN_CLAUSE ACTION_TYPE
ALL_VIEWS, USER_VIEWS, DBA_VIEWS | TYPE_TEXT_LENGTH TYPE_TEXT OID_TEXT_LENGTH OID_TEXT VIEW_TYPE_OWNER VIEW_TYPE
DBA_IND_COLUMNS | COLUMN_EXPRESSION
USER_FREE_SPACE, DBA_FREE_SPACE | RELATIVE_FNO
USER_RESOURCE_LIMITS | RESOURCE_NAME LIMIT
USER_SEGMENTS, DBA_SEGMENTS | BYTES BLOCKS EXTENTS INITIAL_EXTENT NEXT_EXTENT IN_EXTENT MAX_EXTENTS PCT_INCREASE FREELISTS FREELIST_GROUPS BUFFER_POOL RESOURCE_NAME
USER_SYS_PRIVS | PRIVILEGE
USER_USERS, DBA_USERS | ACCOUNT_STATUS LOCK_DATE EXPIRY_DATE PROFILE INITIAL_RSRC_CONSUMER_GROUP EXTERNAL_NAME


Fehlermeldungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Fehlermeldungen

Beim Auftreten einiger Fehler liefert MaxDB die gleiche Fehlernummer wie Oracle Version 7:

Meldungsnummer | Meldungstext
1403 | Row not found
-1 | Duplicate key in index
-51 | Lock request timeout
-54 | Lock collision
-602 | System error
-942 | Unknown table name
-955 | Duplicate name
-1007 | Parameter is too long
-1008 | Too many or too few host variables for output
-1034 | Serverdb must be restarted
-1400 | Input parameter cannot be NULL value
-1402 | Integrity violation
-1405 | Missing indicator variable
-1452 | Duplicate secondary key
-1556 | Data space full (emergency shutdown)

Bei allen anderen Fehlern liefert MaxDB die im Handbuch Meldungen beschriebenen Fehlernummern. Diese unterscheiden sich von der Nummer für den entsprechenden Oracle-Fehler.


Meldungen (SAP-Bibliothek - Grundwissen)

Komponentendokumentation Meldungen

Einsatzmöglichkeiten

Diese Dokumentation erklärt die wichtigsten Fehlermeldungen und Rückmeldungen, die das Datenbanksystem MaxDB anzeigt, und gibt Ihnen Empfehlungen, wie Sie auf diese Meldungen reagieren können („Benutzerreaktion“).

Jede Meldung hat eine eindeutige Meldungsnummer, die einem Nummernkreis zugeordnet ist. Über den Nummerkreis können Sie herausfinden, welche Komponente des Datenbanksystems die Meldung verursacht hat.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Glossar.


Nummernkreise (SAP-Bibliothek - Grundwissen)

Nummernkreise

Komponente | Nummernkreis
Datenbankkern | 0 bis 1999 –1 bis –699 –900 bis –999 –1000 bis –1999 –2000 bis –2999 –3000 bis –3999 –4000 bis –4999 –5000 bis –5999 –6000 bis –6999 –7000 bis –7999 –8000 bis -9799
SQLDBC | -10000 bis -10999
Perl DBD | -11000 bis -11099
PHP | -11100 bis -11199
ODBC | –22000 bis –22999
SQL Studio | -23000 bis -23999
Database Manager | -24000 bis -24999
Loader | 25000 bis 25999 -25000 bis -25999
liveCache | -27000 bis -28999


Von -1 bis -699 (SAP-Bibliothek - Grundwissen)

Von -1 bis -699

Fehlermeldungen aus dem Datenbankkern

-1 | Duplicate key in index
-8 | Execution failed, parse again
-20 | Duplicate key
-25 | Duplicate secondary key
-30 | Integrity violation
-32 | View violation
-35 | Referential integrity violated
-36 | Foreign key integrity violation
-40 | Lock collision
-50 | Lock request timeout
-51 | Lock request timeout
-54 | Lock collision
-60 | Work rolled back
-65 | Work rolled back
-70 | Session inactivity timeout (Work rolled back)
-71 | Session terminated by shutdown (Work rolled back)
-75 | Too many SQL statements (Work rolled back)
-101 | SQL statement not available in this DB mode
-102 | SQL statement canceled
-103 | SQL statement not available for this application
-104 | DBM command impossible at this time
-106 | Table unloaded or content deleted
-107 | SQL statement not allowed for this instance
-108 | Table or index dropped or content deleted
-111 | Incompatible incremental backup
-115 | Table is read only
-123 | No more log to save
-126 | Data backup missing (backup history lost)
-127 | Log backup is not possible because log writing has been switched off
-128 | Log backup is not possible because the log overwrite mode has been enabled
-530 | Referential integrity violated
-602 | System error


-1: Duplicate key in index (SAP-Bibliothek - Grundwissen)

-1: Duplicate key in index

Erläuterung:

Es gibt bereits eine Tabellenzeile mit dem angegebenen Sekundärschlüssel. Für den Sekundärschlüssel ist UNIQUE spezifiziert.

Benutzerreaktion:

Damit keine Schlüsselkollision auftritt, müssen Sie den Wert des einzufügenden Sekundärschlüssels in der SQL-Anweisung ändern.

Der Fehlertext enthält die Angabe, für welche Spalte oder welchen mehrspaltigen Index die angegebenen Werte bereits existieren.


-8: Execution failed, parse again (SAP-Bibliothek - Grundwissen)

-8: Execution failed, parse again

Erläuterung:

Zwischen Parsen und Ausführen einer Anweisung wurde die Parseidentifikation (parsid) durch Veränderungen im Datenbankkatalog ungültig.

Benutzerreaktion:

Parsen Sie die Anweisung neu.


-20: Duplicate key (SAP-Bibliothek - Grundwissen)

-20: Duplicate key

Erläuterung:

Es gibt bereits eine Tabellenzeile mit dem einzufügenden Schlüssel.

Benutzerreaktion:

Prüfen Sie, ob die bereits existierende Tabellenzeile die gewünschten Werte enthält. Ist das nicht der Fall, prüfen Sie, ob Werte in der bestehenden Tabellenzeile durch die gewünschten ersetzt werden können. Muss eine neue Tabellenzeile eingefügt werden, müssen Sie den Wert des einzufügenden Schlüssels in der SQL-Anweisung ändern, damit keine Schlüsselkollision auftritt.


-25: Duplicate secondary key (SAP-Bibliothek - Grundwissen)

-25: Duplicate secondary key

Erläuterung:

Es gibt bereits eine Tabellenzeile mit dem angegebenen Sekundärschlüssel. Für den Sekundärschlüssel ist UNIQUE spezifiziert.

Benutzerreaktion:

Damit keine Schlüsselkollision auftritt, müssen Sie den Wert des einzufügenden Sekundärschlüssels in der SQL-Anweisung ändern.

Der Fehlertext enthält die Angabe, für welche Spalte oder welchen mehrspaltigen Index die angegebenen Werte bereits existieren.


-30: Integrity violation (SAP-Bibliothek - Grundwissen)

-30: Integrity violation

Erläuterung:

Beim Einfügen oder Ändern würden Integritätsbedingungen (siehe Hilfsmittel für die Datenintegrität) verletzt, die bei der Definition der Basistabelle bzw. der View-Tabelle spezifiziert wurden.

Benutzerreaktion:

Der Fehlertext enthält die Angabe, für welche Spalte die Integritätsbedingungen verletzt würden.

Korrigieren Sie den Eingabewert für die entsprechende Spalte.


-32: View violation (SAP-Bibliothek - Grundwissen)

-32: View violation

Erläuterung:

Es wurde eine INSERT- oder UPDATE-Anweisung für eine View-Tabelle eingegeben. Mindestens eine in der SQL-Anweisung angegebene Zeile erfüllt nicht die Bedingungen der Suchbedingungen aller mit WITH CHECK OPTION definierten, zugrundeliegenden View-Tabellen.

Benutzerreaktion:

Lassen Sie sich die Definition der View-Tabelle durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.VIEWDEFS, anzeigen. Die INSERT- oder UPDATE-Anweisung müssen Sie dieser Definition entsprechend ändern.


-35: Referential integrity violated (SAP-Bibliothek - Grundwissen)

-35: Referential integrity violated

Erläuterung:

Eine der folgenden Ursachen kann vorliegen:

1. Bei der INSERT- oder UPDATE-Anweisung in eine Tabelle, die referenzierende Tabelle in einer referentiellen CONSTRAINT-Definition ist, entsteht eine Zeile, die nicht Trefferzeile der CONSTRAINT-Definition ist.

2. Beim Löschen von Zeilen einer referenzierten Tabelle (referenced_table) einer referentiellen CONSTRAINT-Definition mit ON DELETE RESTRICT in der DELETE RULE existiert eine Trefferzeile.

3. Bei der Ausführung einer referentiellen CONSTRAINT-Definition enthält die referenzierte Tabelle (referenced_table) oder referenzierende Tabelle Zeilen, die der CONSTRAINT-Definition widersprechen.

Benutzerreaktion:

...

1. Sie können sich die bei der referentiellen CONSTRAINT-Definition verwendete Definition durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.FOREIGNKEYCOLUMNS, anzeigen lassen. Die INSERT- oder UPDATE-Anweisung müssen Sie dieser Definition entsprechend ändern.

2. Mit Hilfe einer geeigneten QUERY-Anweisung müssen Sie ermitteln, welche Zeile der referenzierenden Tabelle verhindert, dass die gewünschten Zeilen der referenzierten Tabelle (referenced_table) gelöscht werden können.

3. Mit Hilfe einer geeigneten QUERY-Anweisung müssen Sie ermitteln, welche Zeile der referenzierten Tabelle (referenced_table) oder referenzierenden Tabelle der referentiellen CONSTRAINT-Definition widerspricht. Ändern oder löschen Sie diese Zeile, oder korrigieren Sie die CONSTRAINT-Definition.


-36: Foreign key integrity violation (SAP-Bibliothek - Grundwissen)

-36: Foreign key integrity violation

Erläuterung:

Bei der INSERT- oder UPDATE-Anweisung für eine Join-View-Tabelle widersprechen die von den Spalten (referencing column) der referenzierenden Tabelle funktional abhängigen Spaltenwerte den bereits existierenden Spaltenwerten dieser Spalten.

Benutzerreaktion:

Diesen Widerspruch können Sie auflösen, indem Sie die Spaltenwerte bei der INSERT- bzw. UPDATE-Anweisung oder die bereits existierenden Werte ändern.


-40: Lock collision (SAP-Bibliothek - Grundwissen)

-40: Lock collision

Erläuterung:

Bei der Angabe der Option (NOWAIT) in der LOCK-Anweisung oder in der LOCK-Option signalisiert diese Fehlermeldung, dass die Sperranforderung mit den Sperren eines anderen Benutzers kollidiert.

Benutzerreaktion:

Im Dialog können Sie in dieser Situation einen anderen Verarbeitungsvorgang anstoßen, der die gewünschte Sperre nicht voraussetzt.

Alternativ dazu können Sie mit derselben SQL-Anweisung ohne Angabe der Option (NOWAIT) auf die Sperrfreigabe warten.


-50: Lock request timeout (SAP-Bibliothek - Grundwissen)

-50: Lock request timeout

Erläuterung:

Die Sperranforderung oder eine implizit angeforderte Sperre kollidiert mit Sperren eines anderen Benutzers. Die maximale Wartezeit auf die Zuteilung der Sperre (spezieller Datenbankparameter REQUEST_TIMEOUT) ist abgelaufen.

Benutzerreaktion:

In einigen Fällen enthält der Fehlertext noch eine genauere Beschreibung des Fehlers.

Sie können die Sperranforderung noch einmal absetzen. Es empfiehlt sich jedoch, die Transaktion mit einer ROLLBACK-Anweisung zurückzusetzen, um eventuelle Deadlock-Situationen aufzulösen.


-51: Lock request timeout (SAP-Bibliothek - Grundwissen)

-51: Lock request timeout

Erläuterung:

Die Sperranforderung oder eine implizit angeforderte Sperre kollidiert mit Sperren eines anderen Benutzers. Die maximale Wartezeit auf die Zuteilung der Sperre (spezieller Datenbankparameter REQUEST_TIMEOUT) ist abgelaufen.

Benutzerreaktion:

In einigen Fällen enthält der Fehlertext noch eine genauere Beschreibung des Fehlers.

Sie können die Sperranforderung noch einmal absetzen. Es empfiehlt sich jedoch, die Transaktion mit einer ROLLBACK-Anweisung zurückzusetzen, um eventuelle Deadlock-Situationen aufzulösen.


-54: Lock collision (SAP-Bibliothek - Grundwissen)

-54: Lock collision

Erläuterung:

Bei der Angabe der Option (NOWAIT) in der LOCK-Anweisung oder in der LOCK-Option signalisiert diese Fehlermeldung, dass die Sperranforderung mit den Sperren eines anderen Benutzers kollidiert.

Benutzerreaktion:

...

1. Im Dialog können Sie in dieser Situation einen anderen Verarbeitungsvorgang anstoßen, der die gewünschte Sperre nicht voraussetzt.

2. Alternativ dazu können Sie mit derselben SQL-Anweisung ohne Angabe der Option (NOWAIT) auf die Sperrfreigabe warten.


-60: Work rolled back (SAP-Bibliothek - Grundwissen)

-60: Work rolled back

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine ROLLBACK-Anweisung zurückgesetzt. Dafür kann es folgende Ursachen geben:

1. Der Benutzer hat innerhalb eines bestimmten Zeitintervalls im Datenbanksystem keine Operationen durchgeführt, jedoch Sperren gehalten, auf deren Zuteilung andere Benutzer warten.

2. Die Datenbankinstanz befand sich in einer Deadlock-Situation. Eine Deadlock-Situation ist eine Situation, in der zwei oder mehr Benutzer jeweils Sperren halten und weitere Sperren anfordern, die von den jeweils anderen Benutzern gehalten werden. Im einfachsten Fall mit zwei Benutzern hält der eine Benutzer mindestens eine Sperre und fordert eine andere an. Diese wird aber von einem anderen Benutzer gehalten, der wiederum auf die Sperre wartet, die der erste Benutzer hält. Diese Situation kann nur aufgelöst werden, wenn einer der Benutzer die schon erhaltene Sperre wieder freigibt.

Benutzerreaktion:

In einigen Fällen enthält der Fehlertext noch eine genauere Beschreibung des Fehlers.

In beiden Fällen müssen Sie die Sperranforderungen überprüfen und ggf. ändern. Die letzte Transaktion müssen Sie wiederholen.


-65: Work rolled back (SAP-Bibliothek - Grundwissen)

-65: Work rolled back

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine ROLLBACK-Anweisung zurückgesetzt, weil der Log-Bereich voll ist.

Benutzerreaktion:

Der Fehlertext enthält eine genauere Beschreibung des Fehlers.

Sichern Sie den Log-Bereich (Log-Sicherung).


-70: Session inactivity timeout (Work rolled back) (SAP-Bibliothek - Grundwissen)

-70: Session inactivity timeout (Work rolled back)

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine ROLLBACK-Anweisung zurückgesetzt. Die Datenbanksitzung wurde implizit beendet, weil der Benutzer während des durch den Timeout-Wert bestimmten Zeitintervalls keine Operationen im Datenbanksystem durchgeführt hatte.

Benutzerreaktion:

Wiederholen Sie die CONNECT-Anweisung, eventuell unter Angabe eines größeren Timeout-Wertes.

Überprüfen Sie gegebenenfalls ebenfalls den Wert des speziellen Datenbankparameters SESSION_TIMEOUT, und ändern Sie diesen.


-71: Session terminated by shutdown (Work rolled back) (SAP-Bibliothek - Grundwissen)

-71: Session terminated by shutdown (Work rolled back)

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine ROLLBACK-Anweisung zurückgesetzt. Die Datenbanksitzung wurde implizit beendet, weil parallel durch das Datenbankverwaltungssystem ein Shutdown der Datenbankinstanz erzwungen wurde. Um den später durchzuführenden Restart zu beschleunigen, wird durch das Datenbanksystem versucht, offene Transaktionen innerhalb eines kurzen zur Verfügung stehenden Zeitraumes zurückzusetzen und nicht nur abzubrechen.

Benutzerreaktion:

Nachdem die Datenbankinstanz wieder betriebsbereit ist, müssen Sie die CONNECT-Anweisung und die Transaktion wiederholen.


-75: Too many SQL statements (Work rolled back) (SAP-Bibliothek - Grundwissen)

-75: Too many SQL statements (Work rolled back)

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine ROLLBACK-Anweisung zurückgesetzt. Die Datenbanksitzung wurde implizit beendet, weil der Benutzer innerhalb einer Sitzung zu viele SQL-Anweisungen abgesetzt oder zu viele Transaktionen betrieben hat.

Benutzerrreaktion:

Nach einer erneuten CONNECT-Anweisung können Sie die Transaktion wiederholen.


-101: SQL statement not available in this DB mode (SAP-Bibliothek - Grundwissen)

-101: SQL statement not available in this DB mode

Erläuterung

Die auszuführende SQL-Anweisung setzt entweder den Betriebszustand OFFLINE oder ONLINE voraus.

Benutzerreaktion

Stellen Sie den erforderlichen Betriebszustand der Datenbankinstanz her.

Wurde nach einem Systemfehler implizit ein SHUTDOWN durchgeführt, beseitigen Sie den Fehler und starten dann den Datenbankinstanz.


-102: SQL statement canceled (SAP-Bibliothek - Grundwissen)

-102: SQL statement canceled

Erläuterung:

Die aktuelle Ausführung einer SQL-Anweisung wurde durch einen Benutzer abgebrochen.

Benutzerreaktion:

Im Dialogbetrieb ist keine Benutzerreaktion erforderlich. In anderen Fällen sollte die Transaktion durch eine ROLLBACK-Anweisung zurückgesetzt werden.


-103: SQL statement not available for this application (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -103: SQL statement not available for this application

Erläuterung:

Sie haben versucht, eine SQL-Anweisung mit Hilfe einer Anwendung auszuführen, die für diese Anweisung nicht privilegiert ist.

Benutzerreaktion:

Verwenden Sie die korrekte Anwendung bzw. überprüfen Sie die Schreibweise der Anweisung.


-104: DBM command impossible at this time (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -104: DBM command impossible at this time

Erläuterung:

Sie haben versucht, eine Anweisung zur Datenbankverwaltung auszuführen.

Diese Anweisung darf nicht parallel zu einer bereits laufenden Anweisung zur Datenbankverwaltung ausgeführt werden.

Benutzerreaktion:

Führen Sie die Anweisung zu einem späteren Zeitpunkt erneut aus.


-106: Table unloaded or content deleted (SAP-Bibliothek - Grundwissen)

-106: Table unloaded or content deleted

Erläuterung:

Ein Zugriff auf die Tabelle ist zur Zeit nicht möglich. Folgende Ursachen sind möglich:

...

1. Die Tabelle wurde mit Hilfe eines Strukturlink EXPORT TABLE-Kommandos aus der Datenbankinstanz ausgelagert.

2. Ein anderer Benutzer hat gleichzeitig eine DELETE-Anweisung für den größten Teil der Tabelle oder die gesamte Tabelle ausgeführt. Auf die angegebene Tabelle kann daher für eine kurze Zeitspanne nicht zugegriffen werden. Diese Fehlermeldung kann nur auftreten, wenn der aktuelle Benutzer den Isolation-Level 0 verwendet.

Benutzerreaktion:

...

1. Nehmen Sie die Tabelle mit Hilfe des IMPORT TABLE-Kommandos wieder in den Datenbestand auf.

2. Warten Sie die Abarbeitung der DELETE-Anweisung ab.

Führen Sie nun die SQL-Anweisung aus.


-107: SQL statement not allowed for this instance (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -107: SQL statement not allowed for this instance

Erläuterung:

Die Datenbankinstanz kann diese SQL-Anweisung nicht ausführen.

Benutzerreaktion:

Auf diese SQL-Anweisung muss für diese Datenbankinstanz verzichtet werden.


-108: Table or index dropped or content deleted (SAP-Bibliothek - Grundwissen)

-108: Table or index dropped or content deleted

Erläuterung:

Für die Datenbankinstanz wurde der Isolation-Level 0 (keine Lesesperren) konfiguriert.

Sie haben eine SQL-Anweisung ausgeführt, die sich auf eine nicht vorhandene Tabelle oder einen nicht vorhandenen Index bezieht. Die Tabelle bzw. der Index wurde während des Ausführens Ihrer SQL-Anweisung von einem anderen Datenbankbenutzer gelöscht.

Das Datenbanksystem hat die Ausführung Ihrer SQL-Anweisung deswegen abgebrochen.

Benutzerreaktion:

Überprüfen Sie, ob der Isolation-Level 0 für Ihre Datenbankanwendung geeignet ist.

Siehe auch:

Konzepte des Datenbanksystems, Isolation-Level


-111: Incompatible incremental backup (SAP-Bibliothek - Grundwissen)

-111: Incompatible incremental backup

Erläuterung:

Die zurückzuladende Datenversion ist nicht die Nachfolgeversion des aktuellen Datenzustandes.

Benutzerreaktion:

Wählen Sie die richtige Datenversion.


-115: Table is read only (SAP-Bibliothek - Grundwissen)

-115: Table is read only

Erläuterung:

Es wurde versucht, eine INSERT-, UPDATE- oder DELETE-Anweisung auszuführen. Für die angegebene Tabelle sind jedoch nur SQL-Anweisungen zum Lesen möglich, weil sie zuvor mit der NOLOG-Option geladen wurde.

Benutzerreaktion:

Den Nur-Lese-Zustand können Sie aufheben. Starten Sie eine Datensicherung mit dem entsprechenden Werkzeug zur Datenbankverwaltung.


-123: No more log to save (SAP-Bibliothek - Grundwissen)

-123: No more log to save

Erläuterung:

Sie haben versucht, den Log-Bereich zu sichern. Das ist nicht möglich und nicht notwendig, da das Datenbanksystem seit der letzten Sicherung des Log-Bereichs keine oder nur sehr wenige Einträge in den Log-Bereich geschrieben hat.

Benutzerreaktion:

Es ist keine Benutzerreaktion notwendig.


-126: Data backup missing (backup history lost) (SAP-Bibliothek - Grundwissen)

-126: Data backup missing (backup history lost)

Erläuterung:

Sie haben versucht, den Log-Bereich durch Starten einer Log-Sicherung zu sichern (interaktive Log-Sicherung oder Aktivieren der automatischen Log-Sicherung). Dies ist im augenblicklichen Betriebszustand nicht erlaubt, da es keine vorausgegangene Datensicherung gibt, auf der ein späteres Wiederherstellen des gesicherten Log-Bereichs aufsetzen kann.

Benutzerreaktion:

Erstellen Sie eine vollständige Datensicherung, um die Sicherungshistorie zu beginnen. Wiederholen Sie dann die gewünschte Log-Sicherung.


-127: Log backup is not possible because log writing has been switched off

Erläuterung:

Sie haben versucht, den Log-Bereich zu sichern, indem sie entweder eine interaktive Log-Sicherung gestartet haben oder versucht haben, die automatische Log-Sicherung einzuschalten. Dies ist im augenblicklichen Datenbankzustand nicht erlaubt, weil die Redo-Log-Verwaltung ausgeschaltet ist. Durch das Ausschalten der Redo-Log-Verwaltung wurde die Sicherungshistorie unterbrochen, und die letzte Datensicherung kann nicht mehr für ein vollständiges Wiederherstellen der Datenbankinstanz verwendet werden. Eine Log-Sicherung ist deshalb momentan nicht sinnvoll.

Benutzerreaktion:

...

1. Schalten sie die Redo-Log-Verwaltung wieder an.

2. Erstellen Sie eine vollständige Datensicherung, um die Sicherungshistorie neu zu beginnen.

3. Wiederholen sie das fehlgeschlagene Kommando.


-128: Log backup is not possible because the log overwrite mode has been enabled

Erläuterung:

Sie haben versucht, den Log-Bereich zu sichern, indem sie entweder eine interaktive Log-Sicherung gestartet haben oder versucht haben, die automatische Log-Sicherung einzuschalten. Dies ist im augenblicklichen Datenbankzustand nicht erlaubt, weil das automatische Überschreiben des Log-Bereichs eingeschaltet ist. Durch das Einschalten des automatischen Überschreibens wurde die Sicherungshistorie unterbrochen, und die letzte Datensicherung kann nicht mehr für ein vollständiges Wiederherstellen der Datenbankinstanz verwendet werden. Eine Log-Sicherung ist deshalb momentan nicht sinnvoll.

Benutzerreaktion:

...

1. Schalten sie das automatische Überschreiben des Log-Bereichs aus.

2. Erstellen Sie eine vollständige Datensicherung, um die Sicherungshistorie neu zu beginnen.

3. Wiederholen Sie das fehlgeschlagene Kommando.


-530: Referential integrity violated (SAP-Bibliothek - Grundwissen)

-530: Referential integrity violated

Erläuterung:

Folgende Ursachen sind möglich:

...

1. Bei der INSERT- oder UPDATE-Anweisung in eine Tabelle, die referenzierende Tabelle in einer referentiellen CONSTRAINT-Definition ist, entsteht eine Zeile, die nicht Trefferzeile der CONSTRAINT-Definition ist.

2. Beim Löschen von Zeilen einer referenzierten Tabelle (referenced_table) einer referentiellen CONSTRAINT-Definition mit ON DELETE RESTRICT in der DELETE RULE existiert eine Trefferzeile.

Benutzerreaktion:

...

1. Lassen Sie sich die bei der referentiellen CONSTRAINT-Definition verwendete Definition durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.FOREIGNKEYCOLUMNS, anzeigen. Ändern Sie die INSERT- oder UPDATE-Anweisung entsprechend dieser Definition.

2. Ermitteln Sie mit Hilfe einer geeigneten QUERY-Anweisung, welche Zeile der referenzierenden Tabelle verhindert, dass die gewünschten Zeilen der referenzierten Tabelle (referenced_table) gelöscht werden können.


-602: System error (SAP-Bibliothek - Grundwissen)

-602: System error

Erläuterung:

Der normale Datenbankbetrieb wurde gestört. Möglicherweise ist die Datenbankinstanz nicht mehr konsistent. Eventuell wurde ein implizites SHUTDOWN durchgeführt.

Benutzerreaktion:

Stellen Sie den Betrieb auf der Datenbankinstanz ein, und benachrichtigen Sie den Support.

Stellen Sie den Datenbank-Trace und weitere Porotokolldateien dem Support zur Fehlerverfolgung und -behebung zur Verfügung.


Von -900 bis -999 (SAP-Bibliothek - Grundwissen)

Von -900 bis -999

Fehlermeldungen aus dem Datenbankkern

-900 | Data area full
-901 | Log full
-902 | I/O error
-903 | Hostfile I/O error
-904 | Space for result tables exhausted
-907 | Space for user session exhausted
-910 | COSTLIMIT for this user exhausted
-911 | Work rolled back
-913 | Lock request timeout
-914 | New volume not accessible
-915 | No more memory
-917 | Save/Restore write process crash - I/O error
-918 | Stack overflow
-942 | Unknown table name
-955 | Duplicate name


-900: Data area full (SAP-Bibliothek - Grundwissen)

-900: Data area full

Erläuterung:

Der Datenbereich der Datenbankinstanz ist voll.

Benutzerreaktion:

Sie müssen die Datenbankinstanz durch Zuweisung weiterer Volumes vergrößern. Die begonnenen SQL-Anweisungen werden anschließend weiter durchgeführt.


-901: Log full (SAP-Bibliothek - Grundwissen)

-901: Log full

Erläuterung:

Der Log-Bereich ist voll. Folgende Ursachen sind möglich:

...

1. Es ist keine Log-Sicherung aktiv. Der Database Manager führt Änderungsoperationen durch, die zusammen mit Änderungsoperationen anderer Transaktionen zu einem Überlauf des Log-Bereichs führen.

2. Es werden Log-Sicherungen durchgeführt. Diese erfolgen aber nicht schnell genug, oder es gibt eine sehr lange Transaktion, deren Änderungsoperationen zusammen mit den Änderungsoperationen parallel laufender Transaktionen zu einem Überlauf des Log-Bereichs führen. Der Database Manager führt Änderungsoperationen durch.

Die Durchführung der SQL-Anweisung scheitert.

Benutzerreaktion:

...

1. Sichern Sie den Log-Bereich.
Wiederholen Sie anschließend die SQL-Anweisung.

2. Das Datenbanksystem sichert den von der sehr langen Transaktion benötigten Log-Bereich in andere Bereiche der Datenbankinstanz. Anschließend kann der Befehl wiederholt werden.

Prüfen Sie, ob dieser Zustand häufig auftritt, d.h. der Log-Bereich für die Anzahl von Benutzern und durchschnittliche Länge von Transaktionen zu klein ist. Dann sollte der Log-Bereich vergrößert werden.

Prüfen Sie, ob ein Fehler in der Anwendungsprogrammierung vorliegt, der zu der sehr langen oder endlosen Transaktion führt. Beseitigen Sie gegebenenfalls diesen Fehler.


-902: I/O error (SAP-Bibliothek - Grundwissen)

-902: I/O error

Erläuterung:

Während der Bearbeitung einer SQL-Anweisung mußte auf dem Datenbereich oder Log-Bereich eine Lese- oder Schreiboperation ausgeführt werden. Diese Operation konnte nicht erfolgreich durchgeführt werden. Folgende Ursachen sind möglich:

...

1. Zwischenzeitlich ist ein SHUTDOWN erfolgt.

2. Eine Platte ist defekt.

Benutzerreaktion:

Der Fehlertext enthält in einigen Fällen zusätzlich eine betriebssystemspezifisch zu interpretierende Fehlerbeschreibung.

...

1. Starten Sie die Datenbankinstanz mit Hilfe des Database Manager.

2. Nach Behebung des Plattendefekts muss die Datenbankinstanz wiederhergestellt werden.


-903: Hostfile I/O error (SAP-Bibliothek - Grundwissen)

-903: Hostfile I/O error

Erläuterung:

Beim Betrieb einer Steuer- oder Sicherungsdatei oder eines Datensicherungsgerätes ist ein Fehler aufgetreten.

Benutzerreaktion:

Der Fehlertext enthält zusätzlich eine betriebssystemspezifisch zu interpretierende Fehlerbeschreibung.

Ermitteln Sie die Ursache für den Fehler, und beseitigen Sie den Fehler anhand der Betriebssystemdokumentation.

Prüfen Sie, ob ein Schreibfehler oder die Angabe eines Verzeichnisses statt einer Datei die Fehlerursache sein könnte.


-904: Space for result tables exhausted (SAP-Bibliothek - Grundwissen)

-904: Space for result tables exhausted

Erläuterung:

Der Speicherplatz für Ergebnistabellen ist erschöpft.

Folgende Ursachen sind möglich:

...

1. Der für die Ergebnistabellen zur Verfügung stehende Speicherplatz ist zu klein.

2. Durch die Datenbankanwendung wurden zu viele temporäre Informationen erzeugt.

In beiden Fällen wurde die Ausführung der SQL-Anweisung abgebrochen und der Benutzer mit einer impliziten RELEASE-Anweisung der Form ROLLBACK WORK RELEASE vom Datenbanksystem abgemeldet.

Benutzerreaktion:

...

1. Wiederholen Sie die Ausführung der SQL-Anweisung nach einer erneuten CONNECT-Anweisung. Möglicherweise hat zu diesem Zeitpunkt ein anderer Benutzer weniger Ergebnistabellen definiert bzw. temporäre Informationen erzeugt.

2. Definieren Sie einen größeren Plattenplatz mit Hilfe des Database Manager.

3. Verwenden Sie ein Strukturlink EXPORT TABLE-Kommando, um Tabellen auszulagern und somit Platz zu schaffen.


-907: Space for user session exhausted (SAP-Bibliothek - Grundwissen)

-907: Space for user session exhausted

Erläuterung:

Der Benutzer wurde beim Datenbanksystem nicht angemeldet, weil nicht mehr genügend freier temporärer Plattenplatz für die Anmeldung einer normalen Datenbanksitzung zur Verfügung steht.

Benutzerreaktion:

...

1. Der Benutzer kann sich anmelden, wenn sich ein anderer Benutzer abgemeldet hat oder durch Löschen von Ergebnistabellen anderer Benutzer wieder genügend freier Speicherplatz zur Verfügung steht.

2. Mit dem Database Manager können Sie sich anmelden und die Datenbankinstanz umkonfigurieren.


-910: COSTLIMIT for this user exhausted (SAP-Bibliothek - Grundwissen)

-910: COSTLIMIT for this user exhausted

Erläuterung:

Die Ausführung der SQL-Anweisung würde infolge des notwendigen Selektierens von Zeilen den maximal zulässigen Aufwand für die Abarbeitung der SQL-Anweisung (COSTLIMIT-Wert des Benutzers) übersteigen. Der COSTLIMIT-Wert wird in der Anweisung CREATE USER, CREATE USERGROUP, ALTER USER oder ALTER USERGROUP festgelegt.

Benutzerreaktion:

Prüfen Sie, ob die SQL-Anweisung in der angegebenen Form notwendig ist. Prüfen Sie, ob z. B. durch weitere Bedingungen in der Suchbedingung die Menge der zu bearbeitenden Daten verkleinert und damit die Kosten verringert werden können.

Ist das nicht möglich, können Sie versuchen, den Effekt der SQL-Anweisung mit mehreren weniger aufwendigen SQL-Anweisungen zu erzielen.

Sie können sich den COSTLIMIT-Wert durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.USERS, anzeigen lassen.

Durch eine ALTER USER oder ALTER USERGROUP-Anweisung kann der Datenbankadministrator, der Eigentümer der Benutzergruppe oder des Benutzers ist, den COSTLIMIT-Wert erhöhen.


-911: Work rolled back (SAP-Bibliothek - Grundwissen)

-911: Work rolled back

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine implizite ROLLBACK-Anweisung zurückgesetzt. Dafür kann es folgende Ursachen geben:

...

1. Der Benutzer hat innerhalb eines bestimmten Zeitintervalls keine Datenbankoperationen durchgeführt, jedoch Sperren gehalten, auf deren Zuteilung andere Benutzer warteten.

2. Die Datenbankinstanz befand sich in einer Deadlock-Situation.

Deadlock-Situation: zwei oder mehr Benutzer halten jeweils Sperren und fordern weitere Sperren an, die von den jeweils anderen Benutzern gehalten werden. Im einfachsten Fall mit zwei Benutzern hält der eine Benutzer mindestens eine Sperre und fordert eine andere an. Diese wird aber von einem anderen Benutzer gehalten, der wiederum auf die Sperre wartet, die der erste Benutzer hält. Diese Situation kann nur aufgelöst werden, wenn einer der Benutzer die schon erhaltene Sperre wieder freigibt.

Benutzerreaktion:

In einigen Fällen enthält der Fehlertext noch eine genauere Beschreibung des Fehlers.

In beiden Fällen müssen Sie die Sperranforderungen überprüfen und gegebenenfalls ändern. Wiederholen Sie die letzte Transaktion.


-913: Lock request timeout (SAP-Bibliothek - Grundwissen)

-913: Lock request timeout

Erläuterung:

Die Sperranforderung oder eine implizit angeforderte Sperre kollidiert mit Sperren eines anderen Benutzers. Die maximale Wartezeit auf die Zuteilung der Sperre (spezieller Datenbankparameter REQUEST_TIMEOUT) ist abgelaufen.

Benutzerreaktion:

In einigen Fällen enthält der Fehlertext noch eine genauere Beschreibung des Fehlers.

Die Sperranforderung kann noch einmal abgesetzt werden. Es empfiehlt sich jedoch, die Transaktion mit einem ROLLBACK zurückzusetzen, um eventuelle Deadlock-Situationen aufzulösen.


-914: New volume not accessible (SAP-Bibliothek - Grundwissen)

-914: New volume not accessible

Erläuterung:

Es wurde versucht, eine zusätzliche Platte für den Datenbereich zu definieren. Das ist nicht möglich, da auf eine Platte unter dem angegebenen Namen mit der angegebenen Größe nicht zugegriffen werden kann.

Benutzerreaktion:

Der Fehlertext enthält zusätzlich eine betriebssystemspezifisch zu interpretierende Fehlerbeschreibung.

Prüfen Sie den Namen und die Größe der Platte sowie deren Installation. Wiederholen Sie das Kommando mit veränderten Angaben.


-915: No more memory (SAP-Bibliothek - Grundwissen)

-915: No more memory

Erläuterung:

...

1. Es ist nicht mehr genügend Hauptspeicher zur Eröffnung einer Datenbanksitzung verfügbar. Der maximal verfügbare Hauptspeicher wird durch den speziellen Datenbankparameter CAT_CACHE_SUPPLY bei der Installation der Datenbankinstanz festgelegt.

2. Es ist nicht mehr genügend Hauptspeicherbereich zur Ausführung der gewünschten Datenbankprozedur verfügbar.

Benutzerreaktion:

...

1. Sie können erst eine Sitzung eröffnen, wenn mindestens ein anderer Benutzer seine Sitzung beendet hat. Prüfen Sie, ob der Datenbankparameter CAT_CACHE_SUPPLY groß genug gewählt ist.

2. Versuchen Sie, die Datenbankprozedur zu einem späteren Zeitpunkt auszuführen.


-917: Save/restore write process crash - I/O error (SAP-Bibliothek - Grundwissen)

-917: Save/restore write process crash - I/O error

Erläuterung:

  1. Bei einer Anweisung zur Datensicherung ist ein I/O-Fehler beim Versuch, auf ein Datensicherungsgerät zu schreiben, aufgetreten.
  2. Bei einer Anweisung zur Wiederherstellung ist ein I/O-Fehler beim Versuch, auf ein Volume zu schreiben, aufgetreten.

Die Anweisung zur Datensicherung bzw. Wiederherstellung wurde abgebrochen.

Benutzerreaktion:

Der Fehlertext enthält zusätzlich eine betriebssystemspezifisch zu interpretierende Fehlerbeschreibung.

Ermitteln Sie die Ursache für den Fehler anhand der Betriebssystemdokumentation und beseitigen Sie diesen.


-918: Stack overflow (SAP-Bibliothek - Grundwissen)

-918: Stack overflow

Erläuterung:

Durch geschachtelte Aufrufe von Datenbankprozeduren, Triggern oder Subqueries oder durch einen sehr komplizierte Spezifikation von Werten wurde der maximal mögliche Stack-Verbrauch einer Task erreicht. Eine weitere Schachtelung ist nicht möglich. Die Ausführung des Befehls wurde abgebrochen.

Benutzerreaktion:

...

1. Durch geeignete Abfragen in den Datenbankprozeduren und Triggern können Sie die Schachtelungstiefe der Aufrufe stärker beschränken.

2. Die Schachtelungstiefe können Sie beschränken, indem die SQL-Anweisung in mehrere aufgeteilt wird.


-942: Unknown table name (SAP-Bibliothek - Grundwissen)

-942: Unknown table name

Erläuterung:

Dem aktuellen Benutzer ist eine Tabelle mit dem angegebenen Namen nicht bekannt. Es ist möglich, dass eine solche Tabelle nicht existiert, oder dass sie existiert, der aktuelle Benutzer aber keine Privilegien für sie bekommen hat.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TABLES, ist es möglich, die Namen der Tabellen zu ermitteln, für die der aktuelle Benutzer Privilegien besitzt. Korrigieren Sie den Tabellennamen. (Gegebenenfalls reicht es, den fehlenden Eigentümer dem Namen voranzustellen.) Ist eine Korrektur nicht möglich, legen Sie eine Tabelle mit diesem Namen an. Klären Sie, warum der aktuelle Benutzer kein Privileg für die existierende Tabelle erhalten hat.


-955: Duplicate name (SAP-Bibliothek - Grundwissen)

-955: Duplicate name

Erläuterung:

Es existiert bereits ein Datenobjekt mit dem angegebenen Namen.

Benutzerreaktion:

Wiederholen Sie die SQL-Anweisung mit einem anderen Namen.


Von -1000 bis -1999 (SAP-Bibliothek - Grundwissen)

Von -1000 bis -1999

Fehlermeldungen aus dem Datenbankkern

-1000 | Too many lock requests
-1001 | Too many lock objects specified
-1002 | Too many columns
-1003 | Too many buffers requested
-1004 | Too many correlated columns
-1005 | Too many monadic operators
-1006 | Too many variables
-1007 | Parameter list too long
-1008 | Too many or too few host variables for output
-1009 | Too many named indexes for this table
-1010 | Too many volumes
-1011 | Too many correlated tables
-1012 | Too many referential constraint definitions for this table
-1013 | Too many order columns
-1014 | Too many source tables
-1015 | Too many values
-1017 | Too many joins
-1023 | Too many nested subtransactions
-1025 | Too many asynchron requests
-1026 | Too many differences between old and new view definition
-1102 | Too complicated SQL statement (Too many Subqueries)
-1103 | Too complicated SQL statement
-1104 | Too complicated SQL statement (KB-stack overflow)
-1105 | Too complicated SQL statement (Too much data)
-1106 | Too complicated SQL statement (Too much strategy data)
-1107 | Too complicated SQL statement (Too many internal commands)
-1108 | Too complicated SQL statement (Correlated row too long)
-1110 | View definition too long
-1111 | Too many savepoints
-1112 | Constraint too complicated
-1113 | Too many nested function calls
-1114 | Communication packet too small
-1115 | Too many intern columns
-1116 | Too long trigger parameters
-1117 | Too complicated trigger qualification
-1119 | Too many constraints for this table
-1120 | Too many statements in definition
-1200 | Too few values
-1201 | Too few columns
-1400 | Input parameter cannot be NULL value
-1402 | Integrity violation
-1403 | Row not found
-1405 | Missing indicator variable, output parameter
-1406 | Output value truncated
-1452 | Duplicate secondary key
-1556 | Data space full
-1755 | SQL statement will drop further objects (use CASCADE)


-1000: Too many lock requests (SAP-Bibliothek - Grundwissen)

-1000: Too many lock requests

Erläuterung:

Es existieren zu viele Sperren bzw. Sperranforderungen.

Benutzerreaktion:

Sie können versuchen, die SQL-Anweisung zu einem späteren Zeitpunkt zu wiederholen bzw. die Transaktion abzubrechen. Wenn dieser Fehler häufiger auftritt, ist der allgemeine Datenbankparameter MAXLOCKS zu klein gewählt und sollte vergrößert werden.


-1001: Too many lock objects specified (SAP-Bibliothek - Grundwissen)

-1001: Too many lock objects specified

Erläuterung:

Die LOCK-Anweisung enthält zu viele zu sperrende Tabellen oder Tabellenzeilen.

Benutzerreaktion:

Die SQL-Anweisung muss mit Hilfe zweier aufeinanderfolgender LOCK-Anweisungen dargestellt werden.


-1002: Too many columns (SAP-Bibliothek - Grundwissen)

-1002: Too many columns

Erläuterung:

1. Die in den Restriktionen für SQL-Anweisungen angegebene maximale Anzahl für Spalten wurde überschritten.

2. Ein benannter Index kann über maximal 16 Spalten einer Tabelle angelegt werden.

3. In einer referentiellen CONSTRAINT-Definition wurden mehr referenzierende Spalten (referencing_column) angegeben als referenzierte Spalten (referenced_column). Die Anzahl der angegebenen Spalten der referenzierenden Tabelle muss der Anzahl der angegebenen referenzierten Spalten der referenzierten Tabelle (referenced_table) entsprechen.

Benutzerreaktion:

1. Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die aktuelle Definition der Tabelle ermitteln. Sie dürfen keine weiteren Spalten definieren.

2. Korrigieren Sie die Anzahl der Spalten bei der Definition des Index.

3. Sie können die vollständige Definition und die Schlüsselspalten der referenzierten Tabelle (referenced_table) durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, ermitteln.

...

Wenn keine Schlüsselspalte definiert wurde, beträgt die maximale Anzahl der Spalten 254, da das System automatisch eine interne Schlüsselspalte SYSKEY einfügt. Ansonsten beträgt die Anzahl 255.

n


-1003: Too many buffers requested (SAP-Bibliothek - Grundwissen)

-1003: Too many buffers requested

Erläuterung:

Der Speicherplatzbedarf für die durch die Datenbankparameter definierten Puffer und Bereiche ist größer als der dem Datenbanksystem maximal zur Verfügung stehende virtuelle Speicherplatz. Die Ausführung der SQL-Anweisung wurde abgebrochen.

Benutzerreaktion:

Verringern Sie die Größe bzw. Anzahl der Puffer und Bereiche, oder vergrößern Sie den dem Datenbanksystem zur Verfügung gestellten virtuellen Speicherplatz. Starten Sie die Datenbankinstanz neu.


-1004: Too many correlated columns (SAP-Bibliothek - Grundwissen)

-1004: Too many correlated columns

Erläuterung:

Die SQL-Anweisung enthält mindestens eine Correlated Subquery. Dabei wurde versucht, mehr als 64 korrespondierende Spalten (correlated columns) zu verwenden. Es können höchstens 64 korrespondierende Spalten verwendet werden. Dabei zählt jede einzelne Benutzung einer korrespondierenden Spalte.

Benutzerreaktion:

Stellen Sie die SQL-Anweisung so um, dass 64 korrespondierende Spalten genügen. Sie können auch versuchen, den Effekt dieser SQL-Anweisung mit Hilfe mehrerer SQL-Anweisungen zu erzielen.


-1005: Too many monadic operators (SAP-Bibliothek - Grundwissen)

-1005: Too many monadic operators

Erläuterung:

In der SQL-Anweisung stehen mindestens zwei monadische Operatoren in unzulässiger Weise hintereinander.

Benutzerreaktion:

Korrigieren Sie in der SQL-Anweisung die monadischen Operatoren.


-1006: Too many variables (SAP-Bibliothek - Grundwissen)

-1006: Too many variables

Erläuterung:

Pro SQL-Anweisung dürfen höchstens 2000 Parameter angegeben werden (siehe Restriktionen für SQL-Anweisungen).

Benutzerreaktion:

Verringern Sie die Anzahl der Parameter in der SQL-Anweisung. Einige Parameter sind durch konstante Werte zu ersetzen. Ist das nicht möglich, müssen Sie die SQL-Anweisung in mehrere SQL-Anweisungen aufteilen.


-1007: Parameter list too long (SAP-Bibliothek - Grundwissen)

-1007: Parameter list too long

Erläuterung:

In einer Anweisung sind mehr Parameter angegeben worden, als in einer zugehörigen EXECUTE-Anweisung erlaubt.

Benutzerreaktion:

Verändern Sie die Anzahl der Parameter, so dass diese den Angaben in der Spaltenliste entspricht.


-1008: Too many or too few host variables for output (SAP-Bibliothek - Grundwissen)

-1008: Too many or too few host variables for output

Erklärung:

In der SQL-Anweisung sind Variablen für selektierte Spalten enthalten.

Ihre Anzahl entspricht nicht der Anzahl der selektierten Spalten.

Benutzerreaktion:

Überprüfen Sie die Anzahl und die Datentypen der Variablen und korrigieren Sie diese.

Ändern Sie in der SELECT-Anweisung die Angabe ’*’ in eine Folge von Spaltennamen.


-1009: Too many named indexes for this table (SAP-Bibliothek - Grundwissen)

-1009: Too many named indexes for this table

Erläuterung:

Pro Tabelle können maximal 255 benannte Indizes angelegt werden (siehe Restriktionen für SQL-Anweisungen).

Benutzerreaktion:

Prüfen Sie, ob eine derart große Anzahl von Indizes benötigt wird.

Der Aufwand für die Pflege der Indizes bei Änderungsoperationen und der für die Indizes benötigte Speicherplatz ist bei einer solchen Anzahl von Indizes meist unverhältnismäßig groß.


-1010: Too many volumes (SAP-Bibliothek - Grundwissen)

-1010: Too many volumes

Erläuterung

Bei der Installation ist die Anzahl der Data-Volumes begrenzt (siehe Technische Restriktionen). Diese Grenze wurde überschritten.

Benutzerreaktion

Verringern Sie die Anzahl der Data-Volumes.


-1011: Too many correlated tables (SAP-Bibliothek - Grundwissen)

-1011: Too many correlated tables

Erläuterung:

Die Anzahl der in den Correlated Subqueries verwendeten korrespondierenden Tabellen (Correlated Tables) darf 16 nicht überschreiten (siehe Restriktionen für SQL-Anweisungen).

Benutzerreaktion:

Versuchen Sie, die SQL-Anweisung so umzuformulieren, dass 16 korrespondierende Tabellen ausreichen. Wenn dies nicht möglich ist, müssen Sie mehrere SQL-Anweisungen verwenden, um den gewünschten Effekt zu erzielen.


-1012: Too many referential constraint definitions for this table

Erläuterung:

Es wurde versucht, eine referentielle CONSTRAINT-Definition zu erzeugen, durch die die Summe der Längen aller referenzierenden oder aller referenzierten Spalten die maximale Zeilenlänge übersteigt.

Benutzerreaktion:

Die SQL-Anweisung kann erst aufgerufen werden, wenn eine bestehende CONSTRAINT-Definition gelöscht wurde. Andernfalls müssen Sie auf die neue CONSTRAINT-Definition verzichten.


-1013: Too many order columns (SAP-Bibliothek - Grundwissen)

-1013: Too many order columns

Erläuterung:

Folgenden Fehlerursachen sind möglich:

...

1. Es wurden mehr als 128 Spalten als Sortierkriterium oder als Gruppierspalten angegeben (siehe Restriktionen für SQL-Anweisungen).

2. Die Spalten, nach denen sortiert oder gruppiert werden soll, sind insgesamt länger als 1020 Bytes.

3. Die Länge des längsten Ergebnisdatentyps einer DISTINCT-Funktion zusammen mit den Längen der Gruppierspalten ist größer als 254. Dabei ist der Ergebnisdatentyp der Datentyp, der dem Ergebnis eines Ausdrucks zugeordnet wird.

Benutzerreaktion:

Sie müssen in der SQL-Anweisung auf eine oder mehrere Spalten verzichten, die in der ORDER-Klausel bzw. GROUP-Klausel angegeben sind.


-1014: Too many source tables (SAP-Bibliothek - Grundwissen)

-1014: Too many source tables

Erläuterung:

Die Anzahl der einer FROM-Klausel zugrundeliegenden Tabellen ist größer als 16. Wurde eine Join-View-Tabelle in der FROM-Klausel angegeben, so geht die Anzahl der dieser Join-View-Tabelle zugrundeliegenden Basistabellen in die Berechnung ein.

Benutzerreaktion:

Sie können die SQL-Anweisung in zwei aufeinanderfolgende SQL-Anweisungen aufteilen.

Es ist auch möglich, durch Verwendung eines QUERY-Ausdrucks in der FROM-Klausel diese Beschränkung zu umgehen.


-1015: Too many values (SAP-Bibliothek - Grundwissen)

-1015: Too many values

Erläuterung:

Bei einer INSERT- oder UPDATE-Anweisung übersteigt die Anzahl der angegebenen Werte die Anzahl der implizit angegebenen Spaltennamen.

Benutzerreaktion:

Passen Sie in der SQL-Anweisung die Anzahl der angegebenen Werte der Anzahl der angegebenen Spaltennamen an. Für eine INSERT-Anweisung ohne Angabe der Spaltennamen kann mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, die Definition der verwendeten Tabelle ermittelt werden.


-1017: Too many joins (SAP-Bibliothek - Grundwissen)

-1017: Too many joins

Erläuterung:

Die Anzahl der JOIN-Prädikate in einer Suchbedingung darf 64 nicht übersteigen (siehe Restriktionen für SQL-Anweisungen).

Benutzerreaktion:

Sie können das erwartete Ergebnis erzielen, indem mehrere QUERY-Anweisungen ausgeführt und entsprechende Ergebnistabellen als Zwischenergebnisse aufgebaut werden. Sie können die SQL-Anweisung auch derart verändern, dass durch Verwendung eines QUERY-Ausdrucks in einer FROM-Klausel implizit Zwischenergebnisse aufgebaut werden.


-1023: Too many nested subtransactions (SAP-Bibliothek - Grundwissen)

-1023: Too many nested subtransactions

Erläuterung:

Die maximale Schachtelungstiefe von Subtransaktionen liegt bei 32767. Diese Anzahl wurde überschritten.

Benutzerreaktion:

Prüfen Sie, durch welchen Fehler in der Anwendungsprogrammierung diese Schachtelungstiefe von Subtransaktionen erzeugt wurde, und korrigieren Sie diesen.


-1025: Too many asynchron requests (SAP-Bibliothek - Grundwissen)

-1025: Too many asynchron requests

Erläuterung

Die angegebene SQL-Anweisung würde asynchron bearbeitet werden. Dafür stehen zur Zeit nicht genügend Ressourcen zur Verfügung.

Benutzerreaktion

Führen Sie die SQL-Anweisung zu einem späteren Zeitpunkt erneut aus.


-1026: Too many differences between old and new view definition (SAP-Bibliothek - Grundwissen)

-1026: Too many differences between old and new view definition

Erläuterung:

Es wurde eine CREATE VIEW-Anweisung mit der REPLACE-Option angegeben. Eine View-Tabelle mit dem angegebenen Namen existiert bereits. Die bestehende View-Definition und die angegebene unterscheiden sich so stark, dass nicht mehr alle von dieser View-Tabelle abhängigen Definitionen konsistent gepflegt werden können. Die CREATE VIEW-Anweisung scheitert deshalb.

Benutzerreaktion:

Verzichten Sie auf die Änderung der angegebenen View-Tabelle oder prüfen Sie, welche abhängigen Definitionen, z. B. View-Tabellen, Privilegien usw., nicht mehr zu der neuen View-Definition passen. Diese sind gegebenenfalls vor der erneuten Ausführung der CREATE VIEW-Anweisung zu löschen und anschließend in geeigneter abgeänderter Form wieder zu erzeugen.


-1102: Too complicated SQL statement (Too many subqueries) (SAP-Bibliothek - Grundwissen)

-1102: Too complicated SQL statement (Too many subqueries)

Erläuterung:

1. Die SQL-Anweisung enthält zu viele Subqueries. Die Anzahl der zulässigen Subqueries hängt von der Art der SQL-Anweisung ab.

2. Es wurden in einer SQL-Anweisung, die mindestens eine korrespondierende Subquery enthält, in einem Tabellenausdruck sowohl in der WHERE-Klausel als auch in der HAVING-Klausel Subqueries angegeben. Das ist nicht zulässig.

Benutzerreaktion:

Vereinfachen Sie die SQL-Anweisung, oder teilen Sie die Anweisung in mehrere SQL-Anweisungen auf.


-1103: Too complicated SQL statement (SAP-Bibliothek - Grundwissen)

-1103: Too complicated SQL statement

Erläuterung:

Die Anzahl der Operationen, Funktionen und Bedingungen ist zu hoch.

Benutzerreaktion:

Vereinfachen Sie die SQL-Anweisung, oder teilen Sie die Anweisung in mehrere SQL-Anweisungen auf.


-1104: Too complicated SQL statement (KB-stack overflow) (SAP-Bibliothek - Grundwissen)

-1104: Too complicated SQL statement (KB-stack overflow)

Erläuterung:

Innerhalb des Systems werden für die Darstellung der SQL-Anweisung mehr Elemente einer internen Struktur benötigt als vorhanden sind.

Benutzerreaktion:

Vereinfachen Sie die SQL-Anweisung, oder teilen Sie die Anweisung in mehrere SQL-Anweisungen auf.

Ist das nicht möglich, sollten Sie überprüfen, ob der Datenbankparameter PACKET_SIZE erhöht werden kann, von dessen Größe die Größe dieser internen Struktur abhängt. Die Anpassung erfolgt dabei jeweils ab einem bestimmten Grenzwert der PACKET_SIZE.


-1105: Too complicated SQL statement (Too much data) (SAP-Bibliothek - Grundwissen)

-1105: Too complicated SQL statement (Too much data)

Erläuterung:

Innerhalb des Systems wird für die Darstellung der Daten der SQL-Anweisung mehr Platz benötigt als vorhanden ist.

Benutzerreaktion:

Vereinfachen Sie die SQL-Anweisung, oder teilen Sie die Anweisung in mehrere SQL-Anweisungen auf. Ist das nicht möglich, sollten Sie überprüfen, ob der Datenbankparameter PACKET_SIZE erhöht werden kann, von dessen Größe die Menge des zur Verfügung stehenden Platzes abhängt. Eine Erhöhung über 32 KB hinaus vergrößert nicht mehr die Menge des zur Verfügung stehenden Platzes.


-1106: Too complicated SQL statement (Too much strategy data) (SAP-Bibliothek - Grundwissen)

-1106: Too complicated SQL statement (Too much strategy data)

Erläuterung

Die ermittelte Suchstrategie für die Abarbeitung der SQL-Anweisung ist länger als Speicherplatz zur Verfügung steht.

Benutzerreaktion

Verzichten Sie auf einige mit OR verknüpfte Bedingungen.


-1107: Too complicated SQL statement (Too many internal commands)

Erläuterung:

Die SQL-Anweisung ist so kompliziert, dass mehr interne Anweisungen dafür erzeugt werden müssen, als für eine SQL-Anweisung verwaltet werden können.

Benutzerreaktion:

Vereinfachen Sie die SQL-Anweisung, oder teilen Sie die Anweisung in mehrere SQL-Anweisungen auf.


-1108: Too complicated SQL statement (correlated row too long) (SAP-Bibliothek - Grundwissen)

-1108: Too complicated SQL statement (correlated row too long)

Erläuterung:

Während der Bearbeitung einer SQL-Anweisung, die mindestens eine Correlated Subquery enthält, müsste ein internes Ergebnis erzeugt werden, dessen Zeilen länger wären als zulässig ist.

Benutzerreaktion:

Prüfen Sie, ob auf Spalten innerhalb der SELECT-Anweisung verzichtet werden kann oder ob die SQL-Anweisung so umformuliert werden kann, dass weniger oder keine korrespondierenden Spalten (Correlated Columns) verwendet werden.


-1110: View definition too long (SAP-Bibliothek - Grundwissen)

-1110: View definition too long

Erläuterung:

Die Definition einer View-Tabelle ist länger als der dafür zur Verfügung stehende Platz. Dieser Fehler kann z.B. auch bei einer RENAME COLUMN-Anweisung auftreten, wenn durch eine Verlängerung des Namens die intern vorhandene View-Tabelle die Maximallänge überschreitet.

Benutzerreaktion:

Verkürzen Sie die View-Tabelle, z. B. indem kurze Referenznamen statt langer Tabellennamen in der SELECT-Anweisung oder der Suchbedingung verwendet werden.


-1111: Too many savepoints (SAP-Bibliothek - Grundwissen)

-1111: Too many savepoints

Erläuterung:

Es wurden zu viele Savepoints innerhalb einer Transaktion definiert.

Benutzerreaktion:

Prüfen Sie, wie diese ungewöhnlich hohe Anzahl von Savepoints zustande kam. Nehmen Sie die fehlenden COMMIT- bzw. ROLLBACK-Anweisungen in die Anwendung auf.


-1112: Constraint too complicated (SAP-Bibliothek - Grundwissen)

-1112: Constraint too complicated

Erläuterung:

Die interne Darstellung des Constraint ist länger als der dafür zur Verfügung stehende Platz.

Benutzerreaktion:

Vereinfachen Sie das Constraint oder teilen Sie es in mehrere Constraints auf.


-1113: Too many nested function calls (SAP-Bibliothek - Grundwissen)

-1113: Too many nested function calls

Erläuterung:

Die SQL-Anweisung enthält mehr geschachtelte Funktionsaufrufe als bearbeitet werden können.

Benutzerreaktion:

Prüfen Sie, ob nicht auf einige Funktionen innerhalb der Schachtelung verzichtet werden kann. Ist das nicht der Fall, sollten Sie prüfen, ob durch die Verwendung eines QUERY-Ausdrucks in der FROM-Klausel oder durch die Erzeugung und Wiederverwendung einer benannten Ergebnistabelle, die einen Teil der Funktionen enthält, der gewünschte Effekt erreicht werden kann.


-1114: Communication packet too small (SAP-Bibliothek - Grundwissen)

-1114: Communication packet too small

Erläuterung:

Die SQL-Anweisung ist so lang, dass nicht alle Informationen, die zwischen Client und Server ausgetauscht werden müssen, gleichzeitig in dem dafür vorgesehenen Kommunikationspaket Platz finden.

Benutzerreaktion:

Vereinfachen Sie die SQL-Anweisung, oder teilen Sie diese in mehrere SQL-Anweisungen auf. Ist das nicht möglich, sollten Sie überprüfen, ob der Datenbankparameter PACKET_SIZE erhöht werden kann, der die Größe dieses Kommunikationspakets angibt.


-1115: Too many intern columns (SAP-Bibliothek - Grundwissen)

-1115: Too many intern columns

Erläuterung:

Durch eine ALTER TABLE-Anweisung oder während einer CREATE VIEW-Anweisung wird eine Tabellenbeschreibung erzeugt, die mehr Spalten enthält als zulässig sind oder deren Zeilenlänge die Maximallänge überschreitet. Dieser Zustand kann unter Umständen durch Spalten erreicht werden, die für den Anwender nicht sichtbar sind.

Benutzerreaktion:

Prüfen Sie, ob bei einer CREATE VIEW-Anweisung auf einige Ausgabespalten verzichtet werden kann. Bei einer ALTER TABLE-Anweisung sollten Sie prüfen, ob die angegebene Spaltenbreite verringert werden kann. Prüfen Sie auch, ob durch vorangegangene ALTER TABLE-Anweisungen so viele unsichtbare Spalten erzeugt wurden, dass statt einer ALTER-Definition die MODIFY-Definition verwendet werden sollte, um diese unsichtbaren Spalten zu löschen. Das führt allerdings dazu, dass die Tabelle kopiert wird, was mit einem erheblichen Speicherplatz- und Zeitbedarf verbunden ist.


-1116: Too long trigger parameters (SAP-Bibliothek - Grundwissen)

-1116: Too long trigger parameters

Erläuterung:

Es wurde ein Trigger definiert, dessen Parameter insgesamt länger sind als möglich ist.

Benutzerreaktion:

Versuchen Sie, auf einen oder mehrere Parameter zu verzichten.


-1117: Too complicated trigger qualification (SAP-Bibliothek - Grundwissen)

-1117: Too complicated trigger qualification

Erläuterung:

Die interne Darstellung der Trigger-Bedingung ist länger als der dafür zur Verfügung stehende Platz.

Benutzerreaktion:

Vereinfachen Sie die Trigger-Bedingung.


-1119: Too many constraints for this table (SAP-Bibliothek - Grundwissen)

-1119: Too many constraints for this table

Erläuterung:

Sie haben implizit durch Verwendung eines Wertebereichs oder durch explizite Angabe von Constraints mehr Bedingungen für diese Tabelle definiert als zulässig sind.

Benutzerreaktion:

Überprüfen Sie, ob alle Constraints notwendig sind, und verzichten Sie auf einen oder mehrere, oder fassen Sie mehrere Constraints zu einem zusammen. Wiederholen Sie den Befehl mit den veränderten Constraint-Definitionen.


-1120: Too many statements in definition (SAP-Bibliothek - Grundwissen)

-1120: Too many statements in definition

Erläuterung:

Es wurden mehr als 255 SQL-Anweisungen innerhalb einer CREATE TRIGGER- oder CREATE DBPROC-Anweisung angegeben.

Benutzerreaktion:

Verzichten Sie auf einige SQL-Anweisungen, und versuchen Sie, den gewünschten Effekt mit nicht mehr als 255 SQL-Anweisungen zu erzielen.


-1200: Too few values (SAP-Bibliothek - Grundwissen)

-1200: Too few values

Erläuterung:

Bei der INSERT- oder UPDATE-Anweisung ist die Anzahl der angegebenen Werte geringer als die Anzahl der gegebenenfalls implizit angegebenen Spaltennamen.

Benutzerreaktion:

Passen Sie in der SQL-Anweisung die Anzahl der angegebenen Werte der Anzahl der angegebenen Spaltennamen an. Für eine INSERT-Anweisung ohne Angabe der Spaltennamen können Sie durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, die Definition der verwendeten Tabelle ermitteln.


-1201: Too few columns (SAP-Bibliothek - Grundwissen)

-1201: Too few columns

Erläuterung:

Bei einer referentiellen CONSTRAINT-Definition wurden weniger referenzierende Spalten (referencing_column) angegeben als referenzierte Spalten (referenced_column). Die Anzahl der angegebenen Spalten der referenzierenden Tabelle muss der Anzahl der implizit oder explizit angegebenen referenzierten Spalten der referenzierten Tabelle (referenced_table) entsprechen.

Benutzerreaktion:

Mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die Definition der Schlüsselspalten der referenzierten Tabelle ermitteln. Mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.IND_USES_COL, können Sie die Indizes der referenzierten Tabelle ermitteln. Die Angabe der Spalten für die referenzierende Tabelle müssen Sie entsprechend anpassen.


-1400: Input parameter cannot be NULL value (SAP-Bibliothek - Grundwissen)

-1400: Input parameter cannot be NULL value

Erläuterung:

Der Wert eines Eingabeparameters darf kein NULL-Wert sein, denn die Spalte darf keine NULL-Werte erhalten.

Benutzerreaktion:

Ändern Sie entweder die Anwendung oder die Spaltendefinition in der CREATE TABLE-Anweisung.


-1402: Integrity violation (SAP-Bibliothek - Grundwissen)

-1402: Integrity violation

Erläuterung:

Beim Einfügen oder Ändern würden Integritätsbedingungen (siehe Hilfsmittel für die Datenintegrität) verletzt, die bei der Definition der Basistabelle bzw. der View-Tabelle spezifiziert wurden.

Benutzerreaktion:

Der Fehlertext enthält die Angabe, für welche Spalte die Integritätsbedingungen verletzt würden. Korrigieren Sie den Eingabewert für die entsprechende Spalte.


-1403: Row not found (SAP-Bibliothek - Grundwissen)

-1403: Row not found

Erläuterung

Es gibt keine (weitere) Tabellenzeile, die die Qualifikation erfüllt.

Benutzerreaktion

Eine Benutzerreaktion ist nicht erforderlich.


-1405: Missing indicator variable, output parameter with NULL value

-1405: Missing indicator variable, output parameter with NULL value

Erläuterung:

Die zur Rückgabe eines NULL-Werts an die SQL-Variable notwendige Indikatorvariable fehlt.

Benutzerreaktion:

Geben Sie bei dem Parameter die Indikatorvariable an.


-1406: Output value truncated (SAP-Bibliothek - Grundwissen)

-1406: Output value truncated

Erläuterung:

Der Wertebereich der Spalte ist größer als der Wertebereich der SQL-Variablen. Beim Einfügen des Wertes in die SQL-Variable wurde dieser abgeschnitten.

Benutzerreaktion:

Passen Sie den Wertebereich der SQL-Variablen dem Wertebereich der Spalte an.


-1452: Duplicate secondary key (SAP-Bibliothek - Grundwissen)

-1452: Duplicate secondary key

Erläuterung:

Bei der Angabe einer UNIQUE-Definition, bei der Verwendung des Spaltenattributes UNIQUE oder bei der Angabe von UNIQUE in der CREATE INDEX-Anweisung existieren mehrere Tabellenzeilen mit gleichen Werten in den angegebenen Spalten.

Benutzerreaktion:

Sie können UNIQUE nicht verwenden, oder sorgen Sie dafür, dass nur jeweils eine Tabellenzeile eine bestimmte Wertekombination in den angegebenen Spalten enthält. Der Fehlertext enthält die Angabe, für welche Spalte oder welchen mehrspaltigen Index die angegebenen Werte bereits existieren.


-1556: Data space full (SAP-Bibliothek - Grundwissen)

-1556: Data space full

Erläuterung

Der Datenbereich der Datenbankinstanz ist voll.

Benutzerreaktion

Sie müssen den Datenbereich der Datenbankinstanz durch Hinzufügen weiterer Data-Volumes vergrößern. Die begonnenen SQL-Anweisungen werden anschließend weiter ausgeführt.


-1755: SQL statement will drop further objects (use CASCADE) (SAP-Bibliothek - Grundwissen)

-1755: SQL statement will drop further objects (use CASCADE)

Erläuterung:

Es wurde eine DROP USER-, DROP TABLE-, DROP VIEW- oder REVOKE-Anweisung angegeben, für das weder implizit noch explizit die CASCADE-Option angegeben war. Es existieren aber von dem zu löschenden Objekt abhängige Objekte, die ebenfalls zu löschen wären. Das ist nur bei impliziter oder expliziter Angabe der CASCADE-Option zulässig.

Benutzerreaktion:

Prüfen Sie, welche abhängigen Objekte existieren, bevor diese SQL-Anweisung mit der CASCADE-Option angegeben wird.


Von -2000 bis -2999 (SAP-Bibliothek - Grundwissen)

Von -2000 bis -2999

Fehlermeldungen aus dem Datenbankkern

-2000 | Row too long
-2001 | Key too long
-2002 | One output column too long
-2003 | Output columns too long
-2004 | Numeric constant too long
-2008 | Data area too small
-2009 | Join columns too long
-2010 | Assignment impossible, char value too long
-2012 | View column list too long
-2013 | Select column list too long
-2014 | Identifier too long
-2020 | Data buffer too small
-2025 | Invalid number of backup devices
-2027 | Space for converted value too small
-2028 | Sequence <sequence name> exhausted
-2029 | <sequence name>.CURRVAL is not yet defined in this session


-2000: Row too long (SAP-Bibliothek - Grundwissen)

-2000: Row too long

Erläuterung:

Beim (Um-)Definieren einer Tabelle wird die Länge einer Tabellenzeile größer als 8088 Bytes (siehe Restriktionen für SQL-Anweisungen).

Benutzerreaktion:

1. Bei einer CREATE TABLE-Anweisung müssen Sie auf eine oder mehrere Spalten verzichten oder die Spaltenlängen verkürzen.

2. Bei einer ALTER TABLE-Anweisung müssen Sie auf eine oder mehrere Spalten verzichten oder die Spaltenlängen verkürzen. Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die aktuelle Definition der Tabelle ermitteln.


-2001: Key too long (SAP-Bibliothek - Grundwissen)

-2001: Key too long

Erläuterung

1. Bei einer CREATE TABLE- oder ALTER TABLE-Anweisung darf die Summe der Längen der Schlüsselspalten maximal 1024 Bytes betragen (siehe Restriktionen für SQL-Anweisungen).

2. Bei der Definition eines benannten Index darf die Summe der Längen der Spalten, über die der Index angelegt werden soll, nicht größer als 1024 Bytes sein.

Benutzerreaktion

1. Korrigieren Sie die Definition der Längen, oder versuchen Sie, mit weniger Spalten als Schlüssel auszukommen.

3. Versuchen Sie, den benannten Index aus weniger Spalten zu bilden.


-2002: One output column too long (SAP-Bibliothek - Grundwissen)

-2002: One output column too long

Erläuterung:

Infolge einer Verkettung von Werten wurde ein zu langer alphanumerischer Wert erzeugt.

Benutzerrreaktion:

Verzichten Sie auf diese Art der Ausgabe. Wenn davon auszugehen ist, dass die Werte in einer Spalte alle kürzer sind als die für diese Spalte definierte Maximallänge, dann können Sie versuchen, durch die Funktion SUBSTR eine Verkürzung des Ergebnisses auf weniger Zeichen zu erzielen. In jedem Fall können die an der Verkettung beteiligten Spalten oder Ausdrücke einzeln ausgegeben werden.


-2003: Output columns too long (SAP-Bibliothek - Grundwissen)

-2003: Output columns too long

Erläuterung:

Folgende Ursachen sind möglich:

...

1. Die Summe der Längen der Ausgabespalten ist größer als 8084 Bytes.

2. Die Länge der Ausgabespalten zusammen mit den in der ORDER- oder GROUP-Klausel angegebenen Spalten ist größer als 8084 Bytes.

3. In einer SQL-Anweisung mit korrespondierenden Subqueries (Correlated Subqueries) ist die Länge der Ausgabespalten zusammen mit den korrespondierenden Spalten und den Spalten aus Prädikaten, die eine Subquery enthalten, größer als 8084 Bytes.

Benutzerreaktion:

...

1. Verringern Sie die Anzahl der Ausgabespalten.

2. Versuchen Sie, ohne Sortierung bzw. Gruppierung auszukommen oder die Sortierung bzw. Gruppierung über kürzere bzw. weniger Spalten zu verlangen.

3. Versuchen Sie, mit weniger Ausgabespalten oder korrespondierenden Spalten auszukommen, oder den gewünschten Effekt durch mehrere SQL-Anweisungen zu erreichen.


-2004: Numeric constant too long (SAP-Bibliothek - Grundwissen)

-2004: Numeric constant too long

Erläuterung:

...

1. Die Zahl enthält mehr als 38 Ziffern (siehe Restriktionen für SQL-Anweisungen).

2. Die Zahl entspricht nicht der Definition des Wertebereichs.

Benutzerreaktion:

Aus der Positonsangabe in der Fehlermeldung ist ersichtlich, welche Zahl fehlerhaft eingegeben wurde.

...

1. Sie müssen die Zahl auf 38 signifikante Ziffern verkürzen und gegebenenfalls als Floating-Point-Literal angeben.

2. Überprüfen Sie die Definition des Wertebereichs. Korrigieren Sie die Zahlenangabe entsprechend.


-2008: Data area too small (SAP-Bibliothek - Grundwissen)

-2008: Data area too small

Erläuterung:

· Die Wiederherstellung einer Datenbankinstanz ist nicht möglich, da die Datenbankinstanz, die wiederhergestellt werden soll, größer ist als die Zieldatenbankinstanz, die für die Wiederherstellung angegeben wurde.

· Die Installation einer Datenbankinstanz ist nicht möglich, da für sie zu wenig Platz für die Ablage von Daten definiert wurde.

Benutzerreaktion:

· Erhöhen Sie die Volume-Größe der Zieldatenbankinstanz.

· Erhöhen Sie die Volume-Größe auf einen Wert größer 2000 Seiten.


-2009: Join columns too long (SAP-Bibliothek - Grundwissen)

-2009: Join columns too long

Erläuterung:

Die interne Länge der Join-Spalten einer Tabelle darf 1020 Bytes nicht übersteigen. Join-Spalten sind die Spalten, die in einem JOIN-Prädikat enthalten sind.

WHERE (S.A = T.V AND S.B < T.W)

Die Join-Spalten der Tabelle S sind die Spalten S.A und S.B. Die interne Länge der Join-Spalten von S ist die interne Länge der Spalte S.A plus der internen Länge der Spalte S.B. Die interne Länge der Join-Spalten von S darf 1020 Bytes nicht übersteigen.

Benutzerreaktion:

Versuchen Sie, das erwartete Ergebnis zu erzielen, indem Sie mehrere QUERY-Anweisungen angeben und Ergebnistabellen als Zwischenergebnisse erzeugen.


-2010: Assignment impossible, char value too long (SAP-Bibliothek - Grundwissen)

-2010: Assignment impossible, char value too long

Erläuterung:

Bei einer INSERT-Anweisung mit einem QUERY-Ausdruck oder bei einer UPDATE-Anweisung wurde versucht, einer Spalte vom Datentyp CHAR eine zu lange Zeichenkette zuzuweisen. Die Fehlermeldung tritt bei dem ersten zu langen Wert auf und nicht bei der Analyse der maximalen Spaltenlängen.

Benutzerreaktion:

Sie können die Zeilen mit einem zu langen Wert durch ein SELECT... WHERE LENGTH (<column name>) > <unsigned_integer> ermitteln. Die Länge der entsprechenden Spalte kann mit einer ALTER TABLE-Anweisung vergrößert werden.


-2012: View column list too long (SAP-Bibliothek - Grundwissen)

-2012: View column list too long

Erläuterung:

In der CREATE VIEW-Anweisung muss die Anzahl der zu definierenden Spalten der View-Tabelle gleich der Anzahl der Spalten sein, die als Ergebnis des QUERY-Ausdrucks geliefert werden. Im vorliegenden Fall wurde versucht, mehr View-Tabellenspalten zu definieren, als im Ergebnis der QUERY-Anforderung vorhanden sind.

Benutzerreaktion:

Verringern Sie die Anzahl der in der SQL-Anweisung angegebenen View-Tabellenspalten.


-2013: Select column list too long (SAP-Bibliothek - Grundwissen)

-2013: Select column list too long

Erläuterung:

Folgende Ursachen sind möglich:

1. In der CREATE VIEW-Anweisung muss die Anzahl der zu definierenden Spalten der View-Tabelle gleich der Anzahl der Spalten sein, die als Ergebnis des QUERY-Ausdrucks geliefert werden. Im vorliegenden Fall gibt es mehr Spalten im Ergebnis der QUERY-Anforderung als definierte View-Tabellenspalten.

2. Die Anzahl der Ausgabespalten einer Subquery, die in einer SET UPDATE-Klausel angegeben wurde, muss genau eins sein. In einigen SQL-Modi gilt diese Restriktion auch im Vergleichprädikat, Mengenvergleichsprädikat und IN-Prädikat. Im vorliegenden Fall lieferte die Subquery mehr als eine Ausgabespalte.

3. Es wurde eine SQL-Anweisung zur Datenanfrage angegeben. Die Anzahl der Ausgabespalten muss kleiner oder gleich 254 sein. Diese Anzahl wurde im vorliegenden Fall überschritten.

Benutzerreaktion

1. Erhöhen Sie die Anzahl der in der CREATE VIEW-Anweisung angegebenen View-Tabellenspalten oder verringern Sie die Anzahl von Ausgabespalten des QUERY Ausdrucks.

2. Beschränken Sie die Anzahl von Ausgabespalten der Subquery auf eine.

3. Korrigieren Sie die SQL-Anweisung zur Datenanfrage, indem Sie auf eine oder mehrere Ausgabespalten verzichten.


-2014: Identifier too long (SAP-Bibliothek - Grundwissen)

-2014: Identifier too long

Erläuterung:

Der angegebene Bezeichner ist für den verwendeten SQL-Modus zu lang.

Benutzerreaktion:

Achten Sie bei Angabe des Bezeichners auf die in der Tabelle angegebenen Beschränkungen:

SQL-Modus | Länge des Bezeichners
ANSI | Maximal 18 Zeichen
DB2 | Maximal 18 Zeichen
ORACLE | Maximal 30 Zeichen
INTERNAL | Maximal 32 Zeichen


-2020: Data buffer too small (SAP-Bibliothek - Grundwissen)

-2020: Data buffer too small

Erläuterung:

Momentan ist im Data-Cache kein Speicherplatz verfügbar. Die Ausführung der SQL-Anweisung wurde abgebrochen. Das Datenbanksystem führt ein implizites SHUTDOWN durch.

Benutzerreaktion:

Führen Sie ein Restart der Datenbankinstanz mit vergrößertem Data-Cache durch.


-2025: Invalid number of backup devices (SAP-Bibliothek - Grundwissen)

-2025: Invalid number of backup devices

Erläuterung:

Die Anzahl der Sicherungsgeräte, die bei der Sicherung bzw. Wiederherstellung angegeben wurde, entspricht nicht dem allgemeinen Datenbankparameter MAXBACKUPDEVS.

Benutzerreaktion:

Mit Hilfe des Werkzeugs zur Datenbankverwaltung ist der Parameter zu überprüfen und gegebenenfalls zu korrigieren.


-2027: Space for converted value too small (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -2027: Space for converted value too small

Erläuterung

Es wurde versucht, Daten aus einer ASCII- oder UCS-2-Darstellung in eine andere Darstellung zu konvertieren. Das ist gescheitert.

Benutzerreaktion

Prüfen Sie, ob die Zielspalte genügend groß definiert wurde. Wenn Sie die Zielspalte nicht vergrößern können, müssen Sie auf eine explizite Konvertierung verzichten. Sie können versuchen, durch explizite Konvertierung der z. B. zum Vergleich verwendeten Daten den Fehler zu vermeiden.


-2028: Sequence <sequence name> exhausted (SAP-Bibliothek - Grundwissen)

-2028: Sequence <sequence name> exhausted

Erläuterung:

Es wurde versucht, mit <sequence name>.NEXTVAL den nächsten Wert der angegebenen Sequenz zu ermitteln. Das ist aus einem der folgenden Gründe nicht möglich:

...

1. Der nächste Wert würde nicht in den für Sequenzen zur Verfügung stehenden Datentyp passen.

2. Der nächste Wert wäre größer als der durch MAXVALUE bei der CREATE SEQUENCE-Anweisung angegebene Wert, und es wurde implizit oder explizit NOCYCLE angegeben.

3. Der nächste Wert wäre kleiner als der durch MINVALUE bei der CREATE SEQUENCE-Anweisung angegebene Wert, und es wurde implizit oder explizit NOCYCLE angegeben.

Benutzerreaktion:

...

1. Geben Sie den gewünschten Wert explizit an.

2. Löschen und erzeugen Sie die Sequenz erneut. Dadurch wird gewährleistet, dass die Werte der Sequenz zyklisch erzeugt werden bzw. ein größerer MAXVALUE bzw. kleinerer MINVALUE verwendet wird. Geben Sie gegebenenfalls START WITH mit dem zuletzt vergebenen Wert an. Danach können Sie SQL-Anweisung erneut verwenden.


-2029: <sequence_name>.CURRVAL is not yet defined in this session

Erläuterung:

Sie haben versucht, <sequence_name>.CURRVAL (Spezifikation von Werten (extended_value_spec)) auszuführen, bevor Sie innerhalb dieser Datenbanksitzung <sequence_name>.NEXTVAL verwendet haben.

Benutzerreaktion:

Führen Sie zuerst <sequence_name>.NEXTVAL und danach <sequence_name>.CURRVAL aus.


Von -3000 bis -3999 (SAP-Bibliothek - Grundwissen)

Von -3000 bis -3999

Fehlermeldungen aus dem Datenbankkern

-3000 | Invalid host file content
-3002 | Invalid data type
-3003 | Invalid user name
-3004 | Invalid host file sequence
-3005 | Invalid SQL statement
-3007 | Invalid sequence for DML and DDL statements
-3008 | Invalid key word or missing delimiter
-3009 | Invalid table name
-3011 | Invalid column name
-3014 | Invalid end of SQL statement
-3016 | Invalid numeric constant
-3017 | Invalid unsigned integer
-3018 | Invalid numeric parameter
-3019 | Invalid exponent
-3020 | Invalid length for this data type
-3021 | Invalid mixture of functions and columns
-3022 | Invalid number of tables for outer join
-3024 | Invalid numeric expression
-3030 | Invalid SESSION TIMEOUT
-3035 | Invalid date time format
-3037 | Invalid volume name
-3038 | Invalid volume size
-3046 | Invalid char position in string function
-3047 | Invalid table for RESTORE CATALOG
-3048 | Invalid date format
-3049 | Invalid time format
-3050 | Invalid timestamp format
-3054 | Invalid block size
-3059 | Invalid day of week
-3060 | Invalid escape sequence
-3061 | Invalid escape value
-3062 | Invalid month
-3063 | Invalid format code
-3064 | Date input value out of range
-3065 | Invalid date input value
-3066 | Date input value inconsistent
-3067 | Invalid time zone
-3068 | Mismatch of parameter configuration between backup and instance
-3069 | Bad xparam page in backup
-3102 | Invalid subtrans structure
-3103 | Invalid sequence definition
-3995 | Invalid pattern
-3998 | Wrong password
-3999 | Invalid parameter


-3000: Invalid host file content (SAP-Bibliothek - Grundwissen)

-3000: Invalid host file content

Erläuterung:

Auf dem verwendeten Datenträger gibt es keinen Inhalt, der zum angegebenen Kommando passt.

Benutzerreaktion:

● Geben Sie den passenden Datenträger oder das passende Sicherungswerkzeug an.

● Wenn Sie bereits Teile der Sicherung von anderen Datenträgern eingelesen haben, müssen Sie die das Einlesen der Sicherung neu starten.

Siehe auch:

Konzepte des Datenbanksystems, Sichern und Wiederherstellen


-3002: Invalid datatype (SAP-Bibliothek - Grundwissen)

-3002: Invalid datatype

Erläuterung:

Der angegebene Datentyp ist in dem aktuell gültigen SQL-Modus unbekannt.

Benutzerreaktion:

Verwenden Sie einen der zulässigen Datentypen.


-3003: Invalid user name (SAP-Bibliothek - Grundwissen)

-3003: Invalid user name

Erläuterung:

Der angegebene Benutzername entspricht nicht der Syntax für den Benutzer.

Benutzerreaktion:

Korrigieren Sie den in der SQL-Anweisung angegebenen Benutzernamen.


-3004: Invalid host file sequence (SAP-Bibliothek - Grundwissen)

-3004: Invalid host file sequence

Erläuterung:

Dieser Fehler kann auftreten, wenn Sie eine Sicherung von mehreren Datenträgern hintereinander einlesen.

Auf dem angegebenen Datenträger befindet sich kein Inhalt, der zum angegebenen Kommando passt.

Der Fehlertext enthält zusätzlich eine betriebssystemspezifisch zu interpretierende Fehlerbeschreibung.

Benutzerreaktion:

Geben Sie den zur Fortsetzung der Aktion passenden Datenträger oder das passende Sicherungswerkzeug an.

Siehe auch:

Konzepte des Datenbanksystems, Sichern und Wiederherstellen


-3005: Invalid SQL statement (SAP-Bibliothek - Grundwissen)

-3005: Invalid SQL statement

Erläuterung:

Die SQL-Anweisung enthält entweder einen Schreibfehler in den ersten beiden Schlüsselwörtern, ist in diesem SQL-Modus unbekannt oder in dieser Datenbankversion nicht erlaubt.

Benutzerreaktion:

Korrigieren Sie die Schreibfehler, oder geben Sie eine andere SQL-Anweisung an.


-3007: Invalid sequence for DML and DDL statements (SAP-Bibliothek - Grundwissen)

-3007: Invalid sequence for DML and DDL statements

Erläuterung:

Zwischen einer QUERY-Anweisung, die keine Ergebnistabelle aufbaut, und den dazugehörigen FETCH-Anweisungen wurden Änderungen im Datenbankkatalog vorgenommen, die die der QUERY-Anweisung zugrundeliegende Tabelle betrafen.

Benutzerreaktion:

Führen Sie die QUERY- und die FETCH-Anweisung nochmals aus.


-3008: Invalid keyword or missing delimiter (SAP-Bibliothek - Grundwissen)

-3008: Invalid keyword or missing delimiter

Erläuterung:

Die SQL-Anweisung enthält ein falsches Schlüsselwort oder ein Schlüsselwort, das in dem aktuell gültigen SQL-Modus unbekannt ist, oder es fehlt ein Schlüsselwort oder Trennzeichen.

Benutzerreaktion:

Korrigieren Sie die SQL-Anweisung entsprechend der Syntaxbeschreibung und dem aktuell gültigen SQL-Modus.


-3009: Invalid table name (SAP-Bibliothek - Grundwissen)

-3009: Invalid table name

Erläuterung:

Der angegebene Tabellenname entspricht nicht der Syntax.

Benutzerreaktion:

Korrigieren Sie den in der SQL-Anweisung angegebenen Tabellennamen.


-3011: Invalid column name (SAP-Bibliothek - Grundwissen)

-3011: Invalid column name

Erläuterung:

Der angegebene Spaltenname entspricht nicht der Syntax.

Benutzerreaktion:

Korrigieren Sie den in der SQL-Anweisung angegebenen Spaltennamen.


-3014: Invalid end of SQL statement (SAP-Bibliothek - Grundwissen)

-3014: Invalid end of SQL statement

Erläuterung:

Die angegebene SQL-Anweisung ist laut Syntax in dem aktuell gültigen SQL-Modus nicht zulässig.

Benutzerreaktion:

Aus der Fehlerposition ist ersichtlich, an welcher Stelle die eingegebene SQL-Anweisung von der zulässigen Syntax abweicht.


-3016: Invalid numeric constant (SAP-Bibliothek - Grundwissen)

-3016: Invalid numeric constant

Erläuterung:

...

1. Die angegebene Zahl stimmt nicht mit dem Datentyp der Spalte überein.

2. Die angegebene Länge des Ergebnisses einer Funktion, z. B. LPAD, CHR etc., ist nicht zulässig. Sie muss zwischen 1 und der maximal zulässigen Länge einer Spalte vom Datentyp CHAR liegen.

Benutzerreaktion:

...

1. Ermitteln Sie den Datentyp der Spalte durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS.

2. Korrigieren Sie die angegebene Länge des Ergebnisses der Funktion.


-3017: Invalid unsigned integer (SAP-Bibliothek - Grundwissen)

-3017: Invalid unsigned integer

Erläuterung:

Es wurde keine zulässige Zahl angegeben.

Benutzerreaktion:

Korrigieren Sie die SQL-Anweisung.


-3018: Invalid numeric parameter (SAP-Bibliothek - Grundwissen)

-3018: Invalid numeric parameter

Erläuterung:

Der angegebene Wert ist keine zulässige Zahl.

Benutzerreaktion:

Überprüfen Sie den als Parameter übergebenen numerischen Wert.


-3019: Invalid exponent (SAP-Bibliothek - Grundwissen)

-3019: Invalid exponent

Erläuterung:

Folgende Ursachen sind möglich:

...

1. Ein numerisches Endergebnis oder ein Zwischenergebnis ist größer oder kleiner als die durch eine Gleitkommazahl darstellbaren Werte.

2. Ein numerischer Wert ist größer oder kleiner, als es der Datentyp einer angegebenen Spalte zuläßt.

Benutzerreaktion:

...

1. Ist ein numerisches Zwischenergebnis zu groß oder zu klein, dann können Sie versuchen, durch Umstellung der Rechenschritte einen Überlauf bzw. Unterlauf zu verhindern.

2. Sie können den Datentyp der Spalte durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, ermitteln. Korrigieren Sie die Werte entsprechend.


-3020: Invalid length for this data type (SAP-Bibliothek - Grundwissen)

-3020: Invalid length for this data type

Erläuterung:

Die für den Datentyp angegebene Länge ist nicht zulässig.

Benutzerreaktion:

...

1. Wählen Sie für das Längenattribut einer Spalte mit dem Datentyp CHAR einen Wert aus dem Bereich 1 bis 254 (SQL-Modus ANSI) bzw. 1 bis 8000 (SQL-Modus INTERNAL und ORACLE) bzw. 1 bis 4000 (SQL-Modus DB2).

2. Wählen Sie für die Genauigkeit einer Spalte mit dem Datentyp FIXED oder FLOAT einen Wert aus dem Bereich 1 bis 38.


-3021: Invalid mixture of functions and columns (SAP-Bibliothek - Grundwissen)

-3021: Invalid mixture of functions and columns

Erläuterung:

...

1. Wenn in einer SELECT-Anweisung eine Set-Funktion (AVG, COUNT, MAX, MIN, STDDEV, SUM, VARIANCE) vorkommt, dann dürfen keine Nicht-Gruppierspalten in der Folge von ausgewählten Spalten (select_column) auftreten.

2. Es ist unzulässig, Mengenfunktionen zu schachteln, z. B. AVG (SUM...).

3. Eine korrespondierende Subquery S, die in der WHERE-Klausel der QUERY-Spezifikation Q enthalten ist, darf keine Mengenfunktionen auf Spalten von Tabellen enthalten, die in der FROM-Klausel der QUERY-Spezifikation Q angegeben sind.

Benutzerreaktion:

Korrigieren Sie die SQL-Anweisung je nach Fehlerfall.

Sie können versuchen, den gewünschten Effekt ohne Schachtelung von Mengenfunktionen zu erreichen, indem Sie mehrere QUERY-Anweisungen verwenden, die jeweils eine Mengenfunktion enthalten.

Innerhalb einer QUERY-Anweisung kann der Effekt durch die Angabe eines QUERY-Ausdrucks in der FROM-Klausel erreicht werden.


-3022: Invalid number of tables for outer join (SAP-Bibliothek - Grundwissen)

-3022: Invalid number of tables for outer join

Erläuterung:

Wurde in mindestens einem Join-Prädikat der QUERY-Spezifikation ein OUTER JOIN-Indikator angegeben, dann muss die Anzahl der Tabellen, die der FROM-Klausel der QUERY-Spezifikation zugrunde liegen, genau zwei sein oder es muss folgendes gelten:

...

1. Nur für eine der in der FROM-Klausel angegebenen Tabellen werden OUTER JOIN-Indikatoren angegeben.

2. Alle Joins dieser Tabelle zu genau einer anderen Tabelle enthalten jeweils den OUTER JOIN INDICATOR.

3. Alle anderen Joins enthalten keinen OUTER JOIN INDICATOR.

Benutzerreaktion:

Versuchen Sie, die gegebenenfalls fehlenden OUTER JOIN-Indikatoren hinzuzufügen oder die SQL-Anweisung in mehrere SQL-Anweisungen aufzuteilen oder den gewünschten Effekt durch QUERY-Ausdrücke in der FROM-Klausel zu erzielen.


-3024: Invalid numeric expression (SAP-Bibliothek - Grundwissen)

-3024: Invalid numeric expression

Erläuterung:

Die Division durch 0 gehört nicht zu einer gewählten Spalte der äußersten QUERY-Spezifikation.

Benutzerreaktion:

Prüfen Sie, ob dieser Fehler durch geeignete Angaben (Prädikate) verhindert werden kann.


-3030: Invalid SESSION TIMEOUT (SAP-Bibliothek - Grundwissen)

-3030: Invalid SESSION TIMEOUT

Erläuterung:

...

1. Der bei der CREATE USER- oder CREATE USERGROUP-Anweisung angegebene Timeout-Wert ist ungültig.

2. Wird bei der CONNECT-Anweisung ein Timeout-Wert angegeben, muss dieser Wert kleiner oder gleich dem für diesen Benutzer maximal möglichen Timeout-Wert sein.

Benutzerreaktion:

...

1. Für den spezielle Datenbankparameter SESSION_TIMEOUT ist ein Wert zwischen 30 und 32400 Sekunden zu wählen.

2. Wurde für diesen Benutzer kein eigener Timeout-Wert bei der CREATE USER- oder CREATE USERGROUP-Anweisung definiert, ist dieser Maximalwert gleich dem Datenbankparameter SESSION_TIMEOUT.

Wurde ein benutzerspezifischer Timeout-Wert bei der CREATE USER- oder CREATE USERGROUP-Anweisung definiert, ist das der Maximalwert.

3. Wird bei der CONNECT-Anweisung der Wert 0 für den Timeout-Wert angegeben, dann findet keine Überprüfung der Inaktivitätsdauer der Sitzung statt.


-3035: Invalid date time format (SAP-Bibliothek - Grundwissen)

-3035: Invalid date time format

Erläuterung:

Das bei der Installation angegebene Datums- und Zeitformat (spezieller Datenbankparameter DATE_TIME_FORMAT) ist nicht zulässig.

Benutzerreaktion:

Geben Sie für das Datums- und Zeitformat EUR, INTERNAL, ISO, JIS oder USA an.


-3037: Invalid volume name (SAP-Bibliothek - Grundwissen)

-3037: Invalid volume name

Erläuterung

Der bei der Installation angegebene Volume-Name ist unzulässig. Dieser Name ist von der Umgebung abhängig, in der das Datenbanksystem läuft. Im allgemeinen handelt es sich dabei um einen Betriebssystemdateinamen.

Benutzerreaktion

Der Fehlertext enthält den fehlerhaften Volume-Namen. Geben Sie den Namen entsprechend den Konventionen der Umgebung, in der das Datenbanksystem läuft, an.


-3038: Invalid volume size (SAP-Bibliothek - Grundwissen)

-3038: Invalid volume size

Erläuterung

Der bei der Installation für die Größe eines Volume angegebene Wert ist keine gültige Zahl.

Benutzerreaktion

Geben Sie eine gültige Zahl an.


-3046: Invalid char position in string function (SAP-Bibliothek - Grundwissen)

-3046: Invalid char position in string function

Erläuterung:

In einer Stringfunktion wurde für eine Position ein unzulässiger Wert angegeben.

Benutzerreaktion:

Geben Sie in der SQL-Anweisung als Position einen Wert an, der größer als 0 und kleiner oder gleich der definierten Spaltenbreite ist.


-3047: Invalid table for RESTORE CATALOG (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -3047: Invalid table for RESTORE CATALOG

Erläuterung:

In der RESTORE CATALOG-Anweisung wurde eine Tabelle angegeben, die keine mit der SAVE CATALOG-Anweisung erzeugten Daten enthält.

Benutzerreaktion:

Geben sie eine Tabelle an, deren Daten durch die SAVE CATALOG-Anweisung erzeugt wurden.


-3048: Invalid date format (SAP-Bibliothek - Grundwissen)

-3048: Invalid date format

Erläuterung:

Der angegebene Wert ist als Datumswert nicht zulässig oder entspricht nicht dem bei der Installation oder der aktuellen Sitzung gewählten Datums- und Zeitformat.

Benutzerreaktion:

Korrigieren Sie den Datumswert.


-3049: Invalid time format (SAP-Bibliothek - Grundwissen)

-3049: Invalid time format

Erläuterung:

Der angegebene Wert ist als Zeitwert nicht zulässig oder entspricht nicht dem bei der Installation oder der aktuellen Sitzung gewählten Datums- und Zeitformat.

Benutzerreaktion:

Korrigieren Sie den Zeitwert.


-3050: Invalid timestamp format (SAP-Bibliothek - Grundwissen)

-3050: Invalid timestamp format

Erläuterung:

Der angegebene Wert ist als Zeitstempelwert nicht zulässig oder entspricht nicht dem bei der Installation oder der aktuellen Sitzung gewählten Datums- und Zeitformat.

Benutzerreaktion:

Korrigieren Sie den Zeitstempelwert.


-3054: Invalid block size (SAP-Bibliothek - Grundwissen)

-3054: Invalid block size

Erläuterung

· Die bei der Datensicherung oder bei der Wiederherstellung angegebene Blockungsgröße ist nicht zulässig.

· (liveCache) Bei der Registrierung eines bereits existierenden Containers stimmt die angegebene Länge eines Objektes nicht mit der im Datenbankkatalog abgelegten Länge überein.

Benutzerreaktion

· Setzen Sie die Blockungsgröße auf einen Wert >= 1.

· Registrieren Sie den Container mit der im Datenbankkatalog abgelegten Länge.


-3059: Invalid day of week (SAP-Bibliothek - Grundwissen)

-3059: Invalid day of week

Erläuterung:

Im Datumswert wurde ein in der gewählten Sprache oder in dem gewählten Format unzulässiger Wochentag angegeben.

Benutzerreaktion:

Überprüfen Sie die gewählte Sprache und das Format. Wiederholen Sie die SQL-Anweisung mit einer korrekten Angabe eines Wochentages. Bei Angabe des Formatelementes DAY sind die Wochentage auszuschreiben, bei DY durch ihre dreibuchstabigen Kürzel anzugeben.


-3060: Invalid escape sequence (SAP-Bibliothek - Grundwissen)

-3060: Invalid escape sequence

Erläuterung:

Das Escape-Zeichen darf nur vor einem Zeichen match_char stehen, das gleich dem Escape-Zeichen ist, vor einem match_string oder vor einem match_set, das kein match_char-Zeichen ist. Eine Erläuterung der Syntaxelemente finden Sie in LIKE-Prädikat (like_predicate).

Benutzerreaktion:

Entfernen Sie das überflüssige Escape-Zeichen.


-3061: Invalid escape value (SAP-Bibliothek - Grundwissen)

-3061: Invalid escape value

Erläuterung:

Als Escape-Zeichen ist nur genau ein Zeichen zulässig.

Benutzerreaktion:

Verkürzen Sie das Escape-Zeichen auf ein Zeichen.


-3062: Invalid month (SAP-Bibliothek - Grundwissen)

-3062: Invalid month

Erläuterung:

Im Datumswert wurde ein in der gewählten Sprache oder in dem gewählten Format unzulässiger Monat angegeben.

Benutzerreaktion:

Überprüfen Sie die gewählte Sprache und das Format. Wiederholen Sie die SQL-Anweisung mit einer korrekten Angabe eines Monats. Bei Angabe des Formatelementes MONTH sind die Monate auszuschreiben, bei MON durch ihre dreibuchstabigen Kürzel anzugeben.


-3063: Invalid format code (SAP-Bibliothek - Grundwissen)

-3063: Invalid format code

Erläuterung:

Die Formatangabe in einer Funktion zur Umwandlung von Datums- oder Zahlenangaben enthält ein unzulässiges Formatelement.

Benutzerreaktion:

Entfernen Sie das unzulässige Formatelement.


-3064: Date input value out of range (SAP-Bibliothek - Grundwissen)

-3064: Date input value out of range

Erläuterung:

In einer Funktion zur Umwandlung eines Wertes in einen Datumswert wurde für ein Formatelement ein unzulässiger Wert angegeben.

Grenzen für Formatelemente

Jahr | YYYY | 1-4713
Tag des Monats | DD | 1-28/29/30/31
Tag des Jahres | DDD | 1-365/366
Wochentag | D | 1-7
Stunden | HH,HH12 | 1-12
Stunden | HH24 | 0-23
Minuten | MI | 0-59
Sekunden | SS | 0-59
Sekunden des Tages | SSSSS | 0-86399
Julianischer Tag | J | 1-3442447

Benutzerreaktion:

Korrigieren Sie den Wert.


-3065: Invalid date input value (SAP-Bibliothek - Grundwissen)

-3065: Invalid date input value

Erläuterung:

Der in einen Datumswert umzuwandelnde Wert enthält entweder ein ungültiges, zu viele oder zu wenige Elemente.

Benutzerreaktion:

Korrigieren Sie den Wert entsprechend dem Format.


-3066: Date input value inconsistent (SAP-Bibliothek - Grundwissen)

-3066: Date input value inconsistent

Erläuterung:

Es wurden die Daten von zwei Formatelementen umgewandelt, deren Werte sich widersprechen. Das kann z.B. daran liegen, dass ein julianischer Tag angegeben wurde, dieser aber nicht im angegebenen Jahr oder Monat liegt oder einen anderen Tag im Monat bezeichnet. Es kann auch daran liegen, dass die Sekunden des Tages angegeben wurden, diese aber nicht den angegebenen Stunden oder Minuten oder Sekunden der Minute entsprechen.

Benutzerreaktion:

...

1. Verzichten Sie auf eins der Formatelemente, deren Werte sich widersprechen.

2. Passen Sie die Werte der beiden Formatelemente einander an.


-3067: Invalid timezone (SAP-Bibliothek - Grundwissen)

-3067: Invalid timezone

Erläuterung:

In der Funktion NEW_TIME wurde ein unzulässiger Wert für die Zeitzone angegeben.

Benutzerreaktion:

Wiederholen Sie die SQL-Anweisung mit einer zulässigen Zeitzone.


-3068: Mismatch of parameter configuration between backup and instance

Erläuterung:

Bei einer Datensicherung werden auch die Datenbankparameter gesichert. Wenn Daten wiederhergestellt werden, wird vorher überprüft, ob die Datenbankparameter aus der Datensicherung mit den aktuellen Datenbankparametern der Zieldatenbankinstanz kompatibel sind.

Die Sicherung einer UNICODE-Datenbankinstanz darf nicht in eine nicht-UNICODE-Datenbankinstanz eingespielt werden.

Benutzerreaktion:

Die Datenbankparamter der Zieldatenbank müssen mit den in der Datensicherung gespeicherten Datenbankparametern übereinstimmen. Zur Zeit betrifft das nur den speziellen Datenbankparameter _UNICODE.


-3069: Bad xparam page in backup (SAP-Bibliothek - Grundwissen)

-3069: Bad xparam page in backup

Erläuterung:

Die Datensicherung enthält eine korrupte Seite, in der xparam-Parameter abgelegt sind. Da diese Seite nur in der Sicherung vorkommt, ist dieser Fall nicht so kritisch wie der Fall einer korrupten Daten- oder Log-Seite. Allerdings bricht die Datensicherung ab.

Benutzerreaktion:

Wenden Sie sich an den Support.


-3102: Invalid subtrans structure (SAP-Bibliothek - Grundwissen)

-3102: Invalid subtrans structure

Erläuterung:

Innerhalb einer Datenbankprozedur wurden dynamisch mehr oder weniger Subtransaktionen geöffnet als geschlossen. Die innerhalb der Datenbankprozedur geöffneten, aber bis zum Ende der Datenbankprozedur nicht wieder geschlossenen Subtransaktionen wurden zurückgerollt.

Benutzerreaktion:

Prüfen Sie, durch welchen Fehler in der Datenbankprozedur diese Schachtelung von Subtransaktionen erzeugt wurde. Korrigieren Sie die Datenbankprozedur.


-3103: Invalid sequence definition (SAP-Bibliothek - Grundwissen)

-3103: Invalid sequence definition

Erläuterung:

Folgende Ursachen sind möglich:

...

1. Beim CREATE SEQUENCE wurde der Wert 0 für die Schrittweite zwischen zwei Zahlen angegeben, die durch die Sequenz zu erzeugen sind. Das ist nicht zulässig.

2. Beim CREATE SEQUENCE wurde ein Startwert angegeben, der außerhalb des Bereiches liegt, der durch den Minimal- und den Maximalwert angegeben wurde, oder es wurde ein Minimalwert angegeben, der größer als der Maximalwert ist.

Benutzerreaktion:

...

1. Wiederholen Sie das Kommando mit einer ganzzahligen, positiven oder negativen Zahl.

2. Wiederholen Sie das Kommando, wobei der Startwert und/oder die Minimal- und Maximalwerte zu verändern sind.


-3995: Invalid pattern (SAP-Bibliothek - Grundwissen)

-3995: Invalid pattern

Erläuterung:

Der angegebene Wert in einem LIKE-Prädikat entspricht nicht der Syntax für LIKE-Ausdrücke (like_expression).

Benutzerreaktion:

Korrigieren Sie den Wert gemäß den Syntaxregeln für LIKE-Ausdrücke eines LIKE-Prädikats.


-3998: Wrong password (SAP-Bibliothek - Grundwissen)

-3998: Wrong password

Erläuterung:

Eine Rolle sollte aktiviert werden. Das angegebene Kennwort entspricht nicht dem bei der Definition der Rolle angegebenen.

Benutzerreaktion:

Korrigieren Sie das Kennwort.


-3999: Invalid parameter (SAP-Bibliothek - Grundwissen)

-3999: Invalid parameter

Erläuterung:

...

1. Es wurde ein unzulässiger Datenbankparameter angegeben.

2. Es wurde ein unzulässiger Parameter in der Folge von Parametern einer CREATE TRIGGER-Anweisung angegeben. In einem INSERT-Trigger ist die Verwendung von OLD, in einem DELETE-Trigger die Verwendung von NEW unzulässig.

Benutzerreaktion:

...

1. Der Fehlertext enthält eine genauere Fehlerbeschreibung. Korrigieren Sie die Parameterwerte entsprechend.

2. Korrigieren Sie die Parameter entsprechend.


Von -4000 bis -4999 (SAP-Bibliothek - Grundwissen)

Von -4000 bis -4999

Fehlermeldungen aus dem Datenbankkern

-4000 | Unknown result table
-4002 | Unknown password
-4003 | Unknown user name
-4004 | Unknown table name
-4005 | Unknown column name
-4006 | Unknown domain name
-4007 | Unknown synonym name
-4008 | Unknown user name/password combination
-4009 | Unknown referential constraint name
-4010 | Unknown MAPCHARSET name
-4011 | Unknown index name
-4013 | Unknown usergroup name
-4014 | Unknown SERVERDB name
-4016 | Unknown procedure name
-4017 | Unknown constraint
-4018 | Unknown default
-4019 | Unknown trigger name
-4020 | Unknown sequence name
-4023 | Unknown function name
-4024 | Unknown name
-4025 | Unknown or not loaded character set
-4027 | Unknown session
-4030 | Unknown schema


-4000: Unknown result table (SAP-Bibliothek - Grundwissen)

-4000: Unknown result table

Erläuterung:

Es gibt keine Ergebnistabelle mit dem angegebenen Namen.

Benutzerreaktion:

Mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TABLES, können Sie die Namen der existierenden Ergebnistabellen ermitteln. Korrigieren Sie den Namen der Ergebnistabelle, oder prüfen Sie, warum die Ergebnistabelle mit dem angegebenen Namen schon gelöscht wurde.

Bei einer COMMIT-Anweisung werden im SQL-Modus ANSI und DB2 implizit alle Ergebnistabellen geschlossen. Im SQL-Modus DB2 kann dieses Verhalten durch die Angabe von WITH HOLD verhindert werden.

Bei einer ROLLBACK-Anweisung werden außer im SQL-Modus ORACLE implizit alle Ergebnistabellen geschlossen, die innerhalb dieser Transaktion erzeugt wurden.


-4001: Unknown user name/password combination in operational state ADMIN

Hintergrunddokumentation -4001: Unknown user name/password combination in operational state ADMIN

Erläuterung:

Im Betriebszustand ADMIN kann sich nur der erste DBM-Benutzer an das Datenbanksystem anmelden.

Benutzerreaktion:

Geben Sie den Benutzernamen und das Kennwort des ersten DBM-Benutzers an.

Siehe auch:

Konzepte des Datenbanksystems, Database Manager-Benutzer (DBM-Benutzer)


-4002: Unknown password (SAP-Bibliothek - Grundwissen)

-4002: Unknown password

Erläuterung:

Das angegebene Kennwort ist nicht bekannt.

Benutzerreaktion:

Wiederholen Sie die ALTER PASSWORD-Anweisung mit dem richtigen Kennwort.


-4003: Unknown user name (SAP-Bibliothek - Grundwissen)

-4003: Unknown user name

Erläuterung:

Es gibt keinen Benutzer mit diesem Namen.

Benutzerreaktion:

Wiederholen Sie die SQL-Anweisung mit einem gültigen Benutzernamen.

Die Systemtabelle USERS enthält alle für die Datenbankinstanz definierten Benutzernamen.

Siehe auch:

Konzepte des Datenbanksystems, Benutzer, Authentifizierung und Berechtigungen

Systemtabellen, USERS


-4004: Unknown table name (SAP-Bibliothek - Grundwissen)

-4004: Unknown table name

Erläuterung:

Dem aktuellen Benutzer ist eine Tabelle mit dem angegebenen Namen nicht bekannt. Es ist möglich, dass eine solche Tabelle nicht existiert, oder dass sie existiert, der aktuelle Benutzer aber keine Privilegien für sie bekommen hat.

Benutzerreaktion:

Mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TABLES, können Sie die Namen der Tabellen ermitteln, für die der aktuelle Benutzer Privilegien besitzt. Korrigieren Sie den Tabellennamen, wobei es gegebenenfalls reicht, das fehlende Schema voranzustellen. Ist durch diese Aktion der Fehler noch nicht behoben, legen Sie eine Tabelle mit diesem Namen an, oder klären Sie, warum der aktuelle Benutzer kein Privileg für die existierende Tabelle erhalten hat.


-4005: Unknown column name (SAP-Bibliothek - Grundwissen)

-4005: Unknown column name

Erläuterung:

Es gibt keine Spalte mit diesem Namen in einer der angegebenen Tabellen.

Benutzerreaktion:

Mit QUERY-Anweisungen, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die Namen der in den Tabellen bekannten Spalten ermitteln. Korrigieren Sie den Spaltennamen.


-4006: Unknown domain name (SAP-Bibliothek - Grundwissen)

-4006: Unknown domain name

Erläuterung:

Es gibt keinen Wertebereich mit dem angegebenen Namen.

Benutzerreaktion:

Mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.DOMAINS, können Sie sich eine Liste der bekannten Wertebereiche anzeigen lassen. Ändern Sie den Namen des Wertebereichs in der SQL-Anweisung entsprechend. Dabei kann es ausreichen, den fehlenden Eigentümer voranzustellen.

Ein DBA kann einen Wertebereich mit dem gewünschten Namen und den gewünschten Eigenschaften erzeugen.


-4007: Unknown synonym name (SAP-Bibliothek - Grundwissen)

-4007: Unknown synonym name

Erläuterung:

Es gibt kein Synonym mit diesem Namen.

Benutzerreaktion:

Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TABLES, anzeigen lassen, welche Synonymnamen existieren. Ändern Sie den Synonymnamen in der SQL-Anweisung entsprechend.


-4008: Unknown user name/password combination (SAP-Bibliothek - Grundwissen)

-4008: Unknown user name/password combination

Erläuterung:

Die angegebene Kombination von Benutzername und Kennwort ist unbekannt. Der Zugang zum Datenbanksystem ist nur mit einer der Datenbankinstanz bekannten Kombination möglich.

Benutzerreaktion:

Ändern Sie die Benutzer- bzw. Kennwortangabe in der SQL-Anweisung.


-4009: Unknown referential constraint name (SAP-Bibliothek - Grundwissen)

-4009: Unknown referential constraint name

Erläuterung:

Es gibt keine referentielle CONSTRAINT-Definition mit dem angegebenen Namen.

Benutzerreaktion:

Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.FOREIGNKEYS, anzeigen lassen, welche CONSTRAINT-Definitionen existieren. Ändern Sie den Namen der referentiellen CONSTRAINT-Anweisung in der SQL-Anweisung entsprechend.


-4010: Unknown MAPCHAR SET name (SAP-Bibliothek - Grundwissen)

-4010: Unknown MAPCHAR SET name

Erläuterung:

Es gibt kein Mapchar-Set mit dem angegebenen Namen.

Benutzerreaktion:

Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.MAPCHARSETS, anzeigen lassen, welche Mapchar-Sets existieren. Ändern Sie den Namen in der SQL-Anweisung entsprechend.


-4011: Unknown index name (SAP-Bibliothek - Grundwissen)

-4011: Unknown index name

Erläuterung:

Es existiert kein benannter Index mit dem angegebenen Namen für die verwendete Tabelle.

Benutzerreaktion:

Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.INDEXES, anzeigen lassen, welche Indizes existieren. Ändern Sie den Indexnamen in der SQL-Anweisung entsprechend.


-4013: Unknown usergroup name (SAP-Bibliothek - Grundwissen)

-4013: Unknown usergroup name

Erläuterung:

Es gibt keine Benutzergruppe mit dem angegebenen Namen.

Benutzerreaktion:

Der Benutzer kann sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.USERS, anzeigen lassen, welche Benutzergruppennamen existieren. Ändern Sie den Benutzergruppennamen in der SQL-Anweisung entsprechend.


-4014: Unknown SERVERDB name (SAP-Bibliothek - Grundwissen)

-4014: Unknown SERVERDB name

Erläuterung:

Es gibt keine Datenbankinstanz mit dem angegebenen Namen.

Benutzerreaktion:

Korrigieren Sie den Datenbanknamen.


-4016: Unknown procedure name (SAP-Bibliothek - Grundwissen)

-4016: Unknown procedure name

Erläuterung:

Es gibt keine Datenbankprozedur mit dem angegebenen Namen.

Benutzerreaktion:

Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.DBPROCEDURES, anzeigen lassen, welche Datenbankprozeduren existieren. Ändern Sie den Prozedurnamen in der SQL-Anweisung entsprechend.


-4017: Unknown constraint (SAP-Bibliothek - Grundwissen)

-4017: Unknown constraint

Erläuterung:

Für die angegebene Spalte existiert keine CONSTRAINT-Definition.

Benutzerreaktion:

Es ist keine Benutzerreaktion erforderlich.


-4018: Unknown default (SAP-Bibliothek - Grundwissen)

-4018: Unknown default

Erläuterung:

Für die angegebene Spalte existiert keine DEFAULT-Spezifikation.

Benutzerreaktion:

Fügen Sie eine Defaultspezifikation hinzu.


-4019: Unknown trigger name (SAP-Bibliothek - Grundwissen)

-4019: Unknown trigger name

Erläuterung:

Es gibt keinen Trigger mit dem angegebenen Namen.

Benutzerreaktion:

Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TRIGGERS, anzeigen lassen, welche Trigger existieren.


-4020: Unknown sequence name (SAP-Bibliothek - Grundwissen)

-4020: Unknown sequence name

Erläuterung:

Es existiert keine Sequenz mit dem angegebenen Namen.

Benutzerreaktion:

Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.SEQUENCES, anzeigen lassen, welche Sequenzen existieren.


-4023: Unknown function name (SAP-Bibliothek - Grundwissen)

-4023: Unknown function name

Erläuterung:

...

Eine Funktion mit dem angegebenen Namen existiert nicht.

Benutzerreaktion:

Verfahren Sie nach einer der folgenden Möglichkeiten:

· Verzichten Sie auf die angegebene Funktion.

· Prüfen Sie, ob die angegebene Funktion nur in dem verwendeten SQL-Modus nicht zur Verfügung steht. Eröffnen Sie eine Datenbanksitzung mit dem SQL-Modus, in dem die Funktion zur Verfügung steht.

· Erzeugen Sie eine Datenbankfunktion mit dem angegebenen Namen und der gewünschten Funktionalität.

..


-4024: Unknown name (SAP-Bibliothek - Grundwissen)

-4024: Unknown name

Erläuterung:

Es existiert kein Datenbankobjekt mit dem angegebenen Namen.

Benutzerreaktion:

Durch QUERY-Anweisungen, angewandt auf Systemtabellen, können Sie ermitteln, welche Objekte für den Anwender aufgrund seiner Privilegierung sichtbar sind.


-4025: Unknown or not loaded character set (SAP-Bibliothek - Grundwissen)

-4025: Unknown or not loaded character set

Erläuterung:

Der angegebene CHARACTER SET ist nicht bekannt.

Benutzerreaktion:

Prüfen Sie die Schreibweise des Character Sets. Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.CHARSET, können Sie außerdem ermitteln, ob der angegebene Character Set geladen ist. Ersetzen Sie die Angabe durch einen der geladenen Character Sets, oder sorgen Sie dafür, daß dieser Character Set geladen wird.


-4027: Unknown session (SAP-Bibliothek - Grundwissen)

-4027: Unknown session

Erläuterung:

Es sollte für die spezielle Datenbanksitzung der Datenbank-Trace eingeschaltet werden. Die angegebene Sitzungsnummer existiert nicht.

Benutzerreaktion:

Korrigieren Sie die Sitzungsnummer.


-4030: Unknown schema (SAP-Bibliothek - Grundwissen)

-4030: Unknown schema

Erläuterung:

Ein Schema mit dem angegebenen Namen ist nicht bekannt.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.SCHEMAS, können Sie die Namen aller bekannten Schemas ermitteln.


Von -5000 bis -5999 (SAP-Bibliothek - Grundwissen)

Von -5000 bis -5999

Fehlermeldungen aus dem Datenbankkern

-5001 | Missing privilege
-5003 | Missing key specification
-5004 | Missing constant
-5005 | Missing non-NULL value
-5006 | Missing identifier
-5007 | Missing numeric constant
-5008 | Missing string constant
-5009 | Missing integer
-5010 | Missing value specification
-5012 | Missing definite table name
-5013 | Missing update column
-5014 | Missing definite column name
-5015 | Missing keyword
-5016 | Missing delimiter


-5001: Missing privilege (SAP-Bibliothek - Grundwissen)

-5001: Missing privilege

Erläuterung:

...

1. Der Benutzer hat nicht die Berechtigung, die SQL-Anweisung auszuführen.

2. Der Benutzer hat nicht die Berechtigung, diese SQL-Anweisung zur Datendefinition auszuführen. Das für diese SQL-Anweisung notwendige Privileg besitzt er nur innerhalb einer Rolle. Derart eingeschränkt gültige Privilegien reichen für andere SQL-Anweisungen aus, nicht aber für solche zur Datendefinition.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TABLEPRIVILEGES oder DOMAIN.COLUMNS können Sie ermitteln, welche Privilegien Sie für die angegebene Tabelle bzw. deren Spalten besitzen. Die Ausführung der gewünschten SQL-Anweisung ist nicht möglich.


-5003: Missing key specification (SAP-Bibliothek - Grundwissen)

-5003: Missing key specification

Erläuterung:

Die SQL-Anweisung setzt die Angabe eines Schlüssels voraus. Dieser ist nicht oder nicht vollständig angegeben.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die Schlüsselspalten der Tabelle ermitteln. Korrigieren Sie den in der SQL-Anweisung angegebenen Schlüssel, oder fügen Sie eine Schlüsselangabe in die SQL-Anweisung ein.


-5004: Missing constant (SAP-Bibliothek - Grundwissen)

-5004: Missing constant

Erläuterung:

In der SQL-Anweisung fehlt eine Konstante.

Benutzerreaktion:

Fügen Sie in die SQL-Anweisung eine Konstante ein.


-5005: Missing non-NULL value (SAP-Bibliothek - Grundwissen)

-5005: Missing non-NULL value

Erläuterung:

Bei der INSERT- oder UPDATE-Anweisung müssen Nicht-NULL-Werte für alle Pflichtspalten angegeben werden. Bei der Angabe einer Schlüsselspezifikation müssen Nicht-NULL-Werte für alle Schlüsselspalten angegeben werden.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die Pflichtspalten und Schlüsselspalten der Tabelle ermitteln.


-5006: Missing identifier (SAP-Bibliothek - Grundwissen)

-5006: Missing identifier

Erläuterung:

Es fehlt ein Bezeichner.

Benutzerreaktion:

Die Fehlerposition gibt an, an welcher Stelle ein Bezeichner erwartet wurde. Fügen Sie einen Bezeichner in die SQL-Anweisung ein.


-5007: Missing numeric constant (SAP-Bibliothek - Grundwissen)

-5007: Missing numeric constant

Erläuterung:

Es fehlt eine Zahl.

Benutzerreaktion:

Die Fehlerposition gibt an, an welcher Stelle eine Zahl erwartet wurde. Fügen Sie eine Zahl in die SQL-Anweisung ein.


-5008: Missing string constant (SAP-Bibliothek - Grundwissen)

-5008: Missing string constant

Erläuterung:

In der SQL-Anweisung fehlt eine Zeichenkette.

Benutzerreaktion:

Fügen Sie in die SQL-Anweisung ein Stringliteral ein.


-5009: Missing integer (SAP-Bibliothek - Grundwissen)

-5009: Missing integer

Erläuterung:

Es fehlt eine ganze Zahl.

Benutzerreaktion:

Fügen Sie eine ganze Zahl in die SQL-Anweisung ein.


-5010: Missing value specification (SAP-Bibliothek - Grundwissen)

-5010: Missing value specification

Erläuterung:

Es fehlt eine Wertangabe, oder der angegebene Wert ist nicht zulässig.

Benutzerreaktion:

Korrigieren Sie den in der SQL-Anweisung angegebenen Wert, oder fügen Sie einen Wert in die SQL-Anweisung ein.


-5012: Missing definite table name (SAP-Bibliothek - Grundwissen)

-5012: Missing definite table name

Erläuterung:

Wird in einer FROM-Klausel derselbe Tabellenname mehrmals verwendet, muss der Tabellenname innerhalb dieser SQL-Anweisung immer mit dem entsprechenden Schemanamen angegeben werden.

Benutzerreaktion:

Ergänzen Sie die Tabellennamen um den Schemanamen.


-5013: Missing update column (SAP-Bibliothek - Grundwissen)

-5013: Missing update column

Erläuterung:

Es wurde versucht, mindestens einen Spaltenwert einer Spalte einer änderbaren Join-View-Tabelle durch eine UPDATE-Anweisung zu ändern, der nur in Kombination mit anderen Spaltenwerten geändert werden kann. Mindestens einer dieser benötigten Spaltenwerte fehlt im UPDATE-Statement.

Benutzerreaktion:

Nehmen Sie die fehlenden Spaltenwerte in der UPDATE-Anweisung auf, oder führen Sie UPDATE-Anweisungen für die der änderbaren Join-View-Tabelle zugrundeliegende(n) Tabelle(n) aus.


-5014: Missing definite column name (SAP-Bibliothek - Grundwissen)

-5014: Missing definite column name

Erläuterung:

Die Anzahl der in einer FROM-Klausel der SQL-Anweisung angegebenen Tabellen ist größer als eins. Es wurde ein Spaltenname ohne vorangestellten Tabellennamen verwendet, und dieser Spaltenname ist in mehr als einer der in der FROM-Klausel angegebenen Tabellen enthalten.

Benutzerreaktion:

Stellen Sie die Eindeutigkeit des Spaltennamens durch Voranstellen des gewünschten Tabellennamens her.


-5015: Missing keyword (SAP-Bibliothek - Grundwissen)

-5015: Missing keyword

Erläuterung:

Die SQL-Anweisung enthält ein falsches Schlüsselwort oder ein Schlüsselwort, das in dem aktuell gültigen SQL-Modus unbekannt ist, oder es fehlt ein Schlüsselwort.

Benutzerreaktion:

Korrigieren Sie die SQL-Anweisung entsprechend der Syntaxbeschreibung und dem aktuell gültigen SQL-Modus, indem Sie eines der angegebenen Schlüsselwörter verwenden.


-5016: Missing delimiter (SAP-Bibliothek - Grundwissen)

-5016: Missing delimiter

Erläuterung:

Die SQL-Anweisung enthält ein falsches Trennzeichen, oder es fehlt ein Trennzeichen.

Benutzerreaktion:

Korrigieren Sie die SQL-Anweisung entsprechend der Syntaxbeschreibung und dem aktuell gültigen SQL-Modus, indem Sie das angegebene Trennzeichen verwenden.


Von -6000 bis -6999 (SAP-Bibliothek - Grundwissen)

Von -6000 bis -6999

Fehlermeldungen aus dem Datenbankkern

-6000 | Duplicate table name
-6001 | Duplicate column name
-6002 | Duplicate privilege
-6003 | Duplicate result table name
-6006 | Duplicate name
-6008 | Duplicate index name
-6009 | Duplicate reference name
-6011 | Duplicate constraint
-6012 | Duplicate default
-6013 | Duplicate trigger definition
-6014 | Duplicate value
-6016 | Duplicate format code


-6000: Duplicate table name (SAP-Bibliothek - Grundwissen)

-6000: Duplicate table name

Erläuterung:

Es gibt schon eine Tabelle mit dem angegebenen Namen.

Benutzerreaktion:

Wählen Sie für die anzulegende Tabelle einen anderen Namen.


-6001: Duplicate column name (SAP-Bibliothek - Grundwissen)

-6001: Duplicate column name

Erläuterung:

...

1. Die Spaltennamen einer Tabelle müssen verschieden sein. Basistabellen ohne benutzerdefinierte Schlüsselspalten und benannte Ergebnistabellen enthalten die implizit angelegte Spalte SYSKEY.

2. Ergebnistabellen, die Spalten enthalten, die nicht explizit benannt wurden und die nicht einen Spaltennamen der zugrundeliegenden Tabelle erben, erhalten implizit die Spaltennamen EXPRESSION_, wobei _ für eine positive ganze Zahl steht.

3. In einer INSERT- oder UPDATE-Anweisung oder in einer Folge von Schlüsselspezifikationen darf eine Spalte nicht mehrfach angegeben werden.

Benutzerreaktion:

...

1. Wählen Sie verschiedene Spaltennamen.

2. Bei einer CREATE VIEW- oder einer QUERY-Anweisung können Sie durch Angabe von Referenznamen in den ausgewählten Spalten die Eindeutigkeit der Spaltennamen herstellen. Bei einem CREATE VIEW ist das auch durch die Angabe einer Folge von Alias-Namen möglich.

3. Korrigieren Sie die mehrfache Angabe derselben Spalte.


-6002: Duplicate privilege (SAP-Bibliothek - Grundwissen)

-6002: Duplicate privilege

Erläuterung:

Ein zu vergebendes Privileg wurde in der SQL-Anweisung doppelt aufgeführt.

Benutzerreaktion:

Entfernen Sie eines dieser Privilegien aus der SQL-Anweisung.


-6003: Duplicate result table name (SAP-Bibliothek - Grundwissen)

-6003: Duplicate result table name

Erläuterung:

Eine mit DECLARE CURSOR erzeugte Ergebnistabelle muss im SQL-Modus ANSI und DB2 durch eine CLOSE-Anweisung geschlossen werden, bevor dieser Ergebnistabellenname zum Öffnen einer neuen Ergebnistabelle in derselben Transaktion verwendet werden kann.

Benutzerreaktion:

Fügen Sie in die Anwendung eine CLOSE-Anweisung ein.


-6006: Duplicate name (SAP-Bibliothek - Grundwissen)

-6006: Duplicate name

Erläuterung:

Es existiert bereits ein Datenobjekt mit dem angegebenen Namen.

Benutzerreaktion:

Wiederholen Sie die SQL-Anweisung mit einem anderen Namen.


-6008: Duplicate index name (SAP-Bibliothek - Grundwissen)

-6008: Duplicate index name

Erläuterung:

Es gibt schon einen Index mit dem gewählten Namen.

Benutzerreaktion:

Wählen Sie einen anderen Indexnamen, oder löschen Sie den existierenden Index.


-6009: Duplicate reference name (SAP-Bibliothek - Grundwissen)

-6009: Duplicate reference name

Erläuterung:

In der FROM-Klausel einer QUERY-Spezifikation wurde ein Referenzname doppelt gewählt. Dadurch wird die Eindeutigkeit der Zuordnung des Referenznamens zu einer Tabelle verletzt.

Benutzerreaktion:

Ändern Sie einen der Referenznamen.


-6011: Duplicate constraint (SAP-Bibliothek - Grundwissen)

-6011: Duplicate constraint

Erläuterung:

Für die angegebene Spalte existiert schon eine CONSTRAINT-Definition.

Benutzerreaktion:

Verzichten Sie auf das Hinzufügen einer CONSTRAINT-Definition oder ändern Sie die bestehenden CONSTRAINT-Definition, um den gewünschten Effekt erreichen.

Die Definition der bestehenden CONSTRAINT-Definition können Sie durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.CONSTRAINTS, ermitteln.


-6012: Duplicate default (SAP-Bibliothek - Grundwissen)

-6012: Duplicate default

Erläuterung:

Für die angegebene Spalte existiert schon eine DEFAULT-Spezifikation.

Benutzerreaktion:

Verzichten Sie auf das Hinzufügen eines Vorschlagswertes, oder ändern Sie den bestehenden Vorschlagswert, um den gewünschten Effekt erreichen.

Die Definition des bestehenden Vorschlagswerts können Sie durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, ermitteln.


-6013: Duplicate trigger definition (SAP-Bibliothek - Grundwissen)

-6013: Duplicate trigger definition

Erläuterung:

Ein Trigger mit dem angegebenen Namen existiert bereits.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TRIGGERS, können Sie ermitteln, welche Triggernamen bereits vergeben wurden. Verwenden Sie einen anderen Namen.

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TRIGGERS, können Sie feststellen, ob der existierende Trigger die gewünschte Definition aufweist und deshalb auf die Definition eines weiteren Triggers verzichtet werden kann.


-6014: Duplicate value (SAP-Bibliothek - Grundwissen)

-6014: Duplicate value

Erläuterung:

...

Bei der Definition eines Mapchar-Set wurde ein interner Wert mehrfach angegeben.

Benutzerreaktion:

...

Ändern Sie die Definition des Mapchar-Set so, dass für einen internen Wert nicht mehrere Umsetzungen angegeben werden.


-6016: Duplicate format code (SAP-Bibliothek - Grundwissen)

-6016: Duplicate format code

Erläuterung:

  1. In der Funktion TO_DATE wurde ein Formatelement mehrfach angegeben.
  2. Es wurden in der Formatangabe der Funktion TO_DATE Formatelemente angegeben, die sich nicht zusammen in einer Formatangabe befinden dürfen. Nicht zusammen in einer Formatangabe auftreten dürfen z. B. Tag des Jahres (DDD) und der julianische Tag. Es dürfen nicht mehrere Angaben das Jahr, z. B. YYYY und YY, oder den Monat, z. B. MM und MONTH, bezeichnen.

Benutzerreaktion:

  1. Entfernen Sie die zu oft angegebenen Formatelemente.
  2. Entfernen Sie eines der sich ausschließenden Formatelemente.


Von -7000 bis -7999 (SAP-Bibliothek - Grundwissen)

Von -7000 bis -7999

Fehlermeldungen aus dem Datenbankkern

-7002 | KEY not allowed
-7003 | NOT NULL not allowed
-7004 | DEFAULT not allowed
-7005 | Lower bound greater than upper bound not allowed
-7006 | Reserved identifier not allowed
-7007 | Key column not allowed
-7008 | Updates of this table not allowed
-7009 | NULL value in key column not allowed
-7011 | Correlated subquery not allowed
-7012 | More than one update row not allowed
-7015 | More than one result row not allowed
-7016 | Parameter spec not allowed in this context
-7017 | User not allowed
-7018 | Variable not allowed in view definition
-7019 | Feature not allowed in view definition
-7021 | View column derived from function not allowed
-7022 | Columns from more than one table not allowed
-7023 | Dropping of all columns not allowed
-7024 | Alter column not allowed, constraint violation
-7026 | SQL statement not allowed without previous FETCH
-7029 | Function not allowed for this data type
-7032 | SQL statement not allowed for column of data type LONG
-7035 | DEFAULT specification not allowed for this column
-7036 | ROWNO specification not allowed in this context
-7037 | NULL value for NOT NULL column not allowed
-7038 | Foreign key column not allowed
-7039 | Cycle in referential constraint definition not allowed
-7040 | Referential constraint not allowed
-7041 | Result table name not allowed
-7042 | Key update not allowed
-7043 | Group member not allowed
-7045 | Parameter spec not allowed
-7046 | Column with length greater than 254 not allowed
-7048 | DROP/ALTER USER not allowed while user is connected
-7050 | Fastload with indexed table not allowed
-7051 | Read only view WITH CHECK OPTION not allowed
-7055 | Column(s) already indexed
-7056 | Subquery not allowed
-7057 | View definition contradicts new table definition
-7058 | Correlated subquery with select in from clause not allowed
-7061 | LOCK ROW for this table not allowed
-7063 | Temp table not allowed
-7064 | Feature not allowed in temp table definition
-7065 | SUBTRANS COMMIT/ROLLBACK not allowed without SUBTRANS BEGIN
-7066 | Unique index referenced by foreign key not allowed
-7067 | Update without repeated read not allowed
-7068 | Outer join not allowed in this context
-7071 | AUTOSAVE LOG must be stopped
-7072 | More than one column with default SERIAL not allowed
-7074 | Cycle in granted roles not allowed
-7075 | Current save skipped, next is ready to take on this tape
-7076 | No more data to read from tape
-7077 | Synonym not allowed
-7078 | No backup is running
-7079 | A backup is already running
-7080 | Query in statement not allowed
-7082 | SQL statement not allowed for this table type
-7084 | Parameter change not allowed
-7085 | Function not allowed for this cursor
-7086 | Schema not allowed
-7500 | DCOM HRESULT
-7900 | Different block sizes


-7002: KEY not allowed (SAP-Bibliothek - Grundwissen)

-7002: KEY not allowed

Erläuterung:

...

1. In der CREATE TABLE-Anweisung müssen die Schlüsselspalten als erste aufgeführt werden, wenn sie durch die Angabe von KEY in einer key_or_not_null_spec definiert werden.

2. Es ist unzulässig, in einer CREATE TABLE-Anweisung sowohl KEY in einer key_or_not_null_spec als auch eine Schlüssel-Definition anzugeben.

Benutzerreaktion:

Geben Sie die Schlüsselspalten in der SQL-Anweisung richtig an.


-7003: NOT NULL not allowed (SAP-Bibliothek - Grundwissen)

-7003: NOT NULL not allowed

Erläuterung:

Spalten mit der Angabe NOT NULL können einer Tabelle nicht mit der ALTER TABLE-Anweisung hinzugefügt werden.

Benutzerreaktion:

Entfernen Sie die Angabe NOT NULL aus der SQL-Anweisung, und führen Sie diese noch einmal durch.


-7004: DEFAULT not allowed (SAP-Bibliothek - Grundwissen)

-7004: DEFAULT not allowed

Erläuterung:

...

1. Spalten mit der Angabe DEFAULT können einer Tabelle nicht mit der ALTER TABLE-Anweisung hinzugefügt werden.

2. Die Angabe von NOT NULL DEFAULT NULL ist unzulässig.

Benutzerreaktion:

...

1. Bei einer ALTER TABLE-Anweisung können Sie erst die Spalte ohne Angabe von DEFAULT hinzufügen und in einer weiteren ALTER TABLE-Anweisung den DEFAULT hinzudefinieren. So erhält diese Spalte in allen Tabellenzeilen den DEFAULT-Wert.

2. Entfernen Sie die Angabe von DEFAULT aus der SQL-Anweisung, und führen Sie diese noch einmal durch.


-7005: Lower bound greater than upper bound not allowed (SAP-Bibliothek - Grundwissen)

-7005: Lower bound greater than upper bound not allowed

Erläuterung:

Bei der Angabe der Unter- und Obergrenze eines Wertebereichs ist die Untergrenze größer als die Obergrenze.

Benutzerreaktion:

Korrigieren Sie die Werte.


-7006: Reserved identifier not allowed (SAP-Bibliothek - Grundwissen)

-7006: Reserved identifier not allowed

Erläuterung:

Der angegebene Name ist in dem aktuellen SQL-Modus ein reserviertes Schlüsselwort und darf nicht zur Bezeichnung von Datenbankobjekten verwendet werden.

Benutzerreaktion:

Wählen Sie in der SQL-Anweisung einen anderen Bezeichner.


-7007: Key column not allowed (SAP-Bibliothek - Grundwissen)

-7007: Key column not allowed

Erläuterung:

Die Angabe einer Schlüsselspalte ist hier unzulässig.

Benutzerreaktion:

Entfernen Sie die Angabe der Schlüsselspalte aus der SQL-Anweisung.


-7008: Updates of this table not allowed (SAP-Bibliothek - Grundwissen)

-7008: Updates of this table not allowed

Erläuterung:

Die angegebene Tabelle kann nicht geändert werden. Dafür kann es folgende Ursachen geben:

...

1. Im Falle einer SQL-Anweisung mit der Angabe von CURRENT OF und Ergebnistabellenname ist die angegebene Tabelle nicht die, die in der FROM-Klausel der QUERY-Anweisung stand, die die angegebene Ergebnistabelle erzeugte.

2. Die SQL-Anweisung enthält eine korrespondierende Subquery (Correlated Subquery), die die zu ändernde Tabelle verwendet.

3. Der QUERY-Ausdruck wurde mit FOR UPDATE spezifiziert. Der QUERY-Ausdruck enthält aber Anweisungsteile, die zusammen mit der Angabe von FOR UPDATE nicht zulässig sind (DISTINCT, GROUP CLAUSE, UNION, INTERSECT, EXCEPT, SUBQUERY).

4. Im SQL-Modus DB2 enthält der QUERY-Ausdruck einer SQL-Anweisung mit der Angabe von CURRENT OF <result_table_name> die Anweisung FOR FETCH ONLY.

Benutzerreaktion:

...

1. Ersetzen Sie den Tabellennamen durch den in der FROM-Klausel der QUERY-Anweisung verwendeten, oder führen Sie eine neue QUERY-Anweisung durch, die den erforderlichen Tabellennamen benutzt.

2. Im Fall der korrespondierenden Subquery können Sie den gewünschten Effekt erreichen, indem eine benannte Ergebnistabelle erzeugt wird, die dann in der Subquery verwendet wird.

3. Sie müssen auf die Angabe von FOR UPDATE oder die Angabe von DISTINCT o.ä. verzichten.

4. Wiederholen Sie den QUERY-Ausdruck ohne FOR FETCH ONLY, oder verzichten Sie auf die Angabe von CURRENT OF <result_table_name> in der SQL-Anweisung.


-7009: NULL value in key column not allowed (SAP-Bibliothek - Grundwissen)

-7009: NULL value in key column not allowed

Erläuterung:

Schlüsselspalten dürfen nicht mit dem NULL-Wert belegt werden.

Benutzerreaktion:

Verwenden Sie für Schlüsselspalten einen Nicht-NULL-Wert.


-7011: Correlated subquery not allowed (SAP-Bibliothek - Grundwissen)

-7011: Correlated subquery not allowed

Erläuterung:

...

1. In einem QUERY-Ausdruck (QUERY EXPRESSION), der mindestens ein UNION, INTERSECT oder EXCEPT enthält, wurde eine korrespondierende Subquery verwendet. Das ist z. Z. noch nicht zulässig.

2. In einer skalaren Subquery wurde in einer selektierten Spalte ein Spaltenname verwendet, der in keiner Tabelle der FROM-Klausel bekannt ist.

Benutzerreaktion:

...

1. Sie können den gewünschten Effekt dadurch erreichen, dass Sie die QUERY-Anweisung in mehrere SQL-Anweisungen aufteilen.

2. Korrigieren Sie den Spaltennamen.


-7012: More than one update row not allowed (SAP-Bibliothek - Grundwissen)

-7012: More than one update row not allowed

Erläuterung:

Es wurde versucht, mit einer UPDATE-Anweisung mehrere Zeilen zu ändern, wobei für eine LONG-Spalte ein neuer Wert angegeben wurde. Das ist nicht zulässig.

Benutzerreaktion:

Verändern Sie die UPDATE-Anweisung so, dass jeweils nur eine Zeile geändert wird, oder verzichten Sie auf die Änderung des Wertes für die LONG-Spalte.


-7015: More than one result row not allowed (SAP-Bibliothek - Grundwissen)

-7015: More than one result row not allowed

Erläuterung:

...

1. Dieser Fehler kann bei der Ausführung einer SINGLE SELECT-Anweisung auftreten, wenn mehr als eine Zeile die Suchbedingung erfüllt.

2. Der Fehler kann auftreten, wenn bei der Ausführung einer Subquery, die in einem Vergleichsprädikat oder einer SET UPDATE-Klausel einer UPDATE-Anweisung angegeben wurde, mehr als eine Zeile die Suchbedingung erfüllt.

Benutzerreaktion:

...

1. Sie können die SINGLE SELECT-Anweisung durch eine QUERY-Anweisung und eine Folge von FETCH-Anweisungen ersetzen, oder Sie können durch die Erweiterung der Suchbedingung sicherstellen, dass maximal eine Zeile die Bedingungen erfüllt.

2. Sie können das Vergleichsprädikat durch ein Mengenvergleichsprädikat ersetzen. Sie können versuchen, durch Angabe von DISTINCT oder die Erweiterung der Suchbedingung die Subquery so zu verändern, dass die Subquery maximal eine Zeile als Ergebnis enthält.


-7016: Parameter spec not allowed in this context (SAP-Bibliothek - Grundwissen)

-7016: Parameter spec not allowed in this context

Erläuterung:

...

1. Es wurde versucht, in einer selektierten Spalte einen Parameter anzugeben.

2. Innerhalb der Suchbedingung tritt ein Vergleichsprädikat der Form <parameter_spec> <comp_op> <parameter_spec> auf.

3. Ein Vergleichsprädikat, IN-Prädikat oder Mengenvergleichsprädikat spezifiziert einen Vergleich zwischen einem Parameter und einer Subquery.

Benutzerreaktion:

...

1. Ersetzen Sie den Parameter durch eine Konstante.

2. Lassen Sie eine solche Bedingung in der Anwendung prüfen. Ist das nicht möglich, muss einer der beiden Parameter durch eine Konstante, einen Spaltennamen oder einen Ausdruck ersetzt werden, der nicht nur Parameter enthält.

3. Ersetzen Sie den Parameter durch eine Konstante, oder fügen Sie diesen in eine Funktion (z.B. SUBSTR) ein, so dass dadurch der Datentyp des Parameters eindeutig wird.


-7017: User not allowed (SAP-Bibliothek - Grundwissen)

-7017: User not allowed

Erläuterung:

...

1. Ein Benutzer kann sich nicht selbst Privilegien verleihen.

2. Bei einer GRANT USER-Anweisung dürfen die angegebenen Namen nicht gleich sein.

Benutzerreaktion:

Korrigieren Sie den Benutzernamen.


-7018: Variable not allowed in view definition (SAP-Bibliothek - Grundwissen)

-7018: Variable not allowed in view definition

Erläuterung:

In der CREATE VIEW-Anweisung dürfen keine Parameter angegeben werden.

Benutzerreaktion:

Verwenden Sie Variablen statt der Konstanten.


-7019: Feature not allowed in view definition (SAP-Bibliothek - Grundwissen)

-7019: Feature not allowed in view definition

Erläuterung:

In einer View-Definition ist die Angabe von ROWNO nicht erlaubt.

Benutzerreaktion:

Entfernen Sie die Angabe von ROWNO aus der SQL-Anweisung.


-7021: View column derived from function not allowed (SAP-Bibliothek - Grundwissen)

-7021: View column derived from function not allowed

Erläuterung:

Es wurde eine View-Tabellenspalte angegeben, die das Ergebnis eines arithmetischen Ausdrucks oder einer Mengenfunktion ist. Im vorliegenden Fall ist die Angabe einer solchen Spalte nicht erlaubt.

Benutzerreaktion:

Versuchen Sie, den gewünschten Effekt durch eine oder mehrere andere SQL-Anweisungen zu erreichen.


-7022: Columns from more than one table not allowed (SAP-Bibliothek - Grundwissen)

-7022: Columns from more than one table not allowed

Erläuterung:

In bestimmten Fällen ist es unzulässig, in einem Ausdruck Spalten von mehr als einer Tabelle anzusprechen.

Benutzerreaktion:

Überlegen Sie, ob der gewünschte Effekt durch Absetzen anderer SQL-Anweisungen erzielt werden kann.


-7023: Dropping of all columns not allowed (SAP-Bibliothek - Grundwissen)

-7023: Dropping of all columns not allowed

Erläuterung:

Es wurde versucht, alle Spalten einer Tabelle zu löschen. Das ist nicht erlaubt.

Benutzerreaktion:

...

1. Löschen Sie die Tabelle mit der DROP TABLE-Anweisung. Dadurch werden alle von der Tabelle abhängigen View-Tabellen, Privilegien, Indizes, referentielle CONSTRAINT-Definitionen usw. gelöscht.

2. Definieren Sie anschließend mit der CREATE TABLE-Anweisung eine neue gleichnamige Tabelle.


-7024: Alter column not allowed, constraint violation (SAP-Bibliothek - Grundwissen)

-7024: Alter column not allowed, constraint violation

Erläuterung:

Es wurde versucht, für eine Spalte einen neuen Wertebereich zu definieren. Die SQL-Anweisung scheitert, wenn die Tabelle Zeilen enthält, die die CONSTRAINT-Definition verletzen.

Benutzerreaktion:

...

1. Wählen Sie eine andere CONSTRAINT-Definition, oder verzichten Sie auf die Änderung der CONSTRAINT-Definition.

2. Sie können durch eine QUERY-Anweisung die Zeilen ermitteln, die die CONSTRAINT-Definition verletzen. Diese können Sie dann ändern oder löschen.


-7026: SQL statement not allowed without previous FETCH (SAP-Bibliothek - Grundwissen)

-7026: SQL statement not allowed without previous FETCH

Erläuterung:

Es wurde versucht, eine SQL-Anweisung mit CURRENT OF für die Ergebnistabelle durchzuführen, ohne dass zuvor eine erfolgreiche FETCH-Anweisung für die angegebene Ergebnistabelle durchgeführt wurde.

Benutzerreaktion:

Führen Sie eine FETCH-Anweisung für diese Ergebnistabelle durch, und wiederholen Sie die SQL-Anweisung.


-7029: Function not allowed for this data type (SAP-Bibliothek - Grundwissen)

-7029: Function not allowed for this data type

Erläuterung:

...

1. Eine der Angaben DATE, TIME, TIMESTAMP, USER, USERGROUP, TRUE, FALSE oder STAMP wurde für eine Default-Spezifikation einer Spalte verwendet, deren Datentyp nicht mit dieser Angabe verträglich ist.

2. Eine Set-Funktion mit DISTINCT wurde für einen Wert aufgerufen, dessen maximale Länge 1024 Bytes überschreitet.

3. Eine Funktion wurde für einen Wert aufgerufen, der die Anwendung dieser Funktion nicht erlaubt.

4. Ein Ausdruck date_or_timestamp_expression wurde zusammen mit einem Wert gebildet, dessen Datentyp dafür nicht zulässig ist.

Benutzerreaktion:

...

1. Im Fall der Default-Angabe müssen Sie eine andere Default-Angabe wählen oder ganz auf diese verzichten.

2. Verwenden Sie die Funktion SUBSTR, um den Wert zu verkürzen.

3. Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die Datentypen der angegebenen Spalten ermitteln. Sie können prüfen, ob durch eine Funktion zur Umwandlung von Zahlen in Zeichenketten oder umgekehrt der gewünschte Effekt erreicht werden kann.


-7032: SQL statement not allowed for column of data type LONG (SAP-Bibliothek - Grundwissen)

-7032: SQL statement not allowed for column of data type LONG

Erläuterung:

Die SQL-Anweisung kann auf Spalten vom Datentyp LONG nicht angewendet werden.

Benutzerreaktion:

Verwenden Sie eine der Operationen, die auf Spalten vom Datentyp LONG durchgeführt werden können.


-7035: DEFAULT specification not allowed for this column (SAP-Bibliothek - Grundwissen)

-7035: DEFAULT specification not allowed for this column

Erläuterung:

Es wurde eine INSERT- oder UPDATE-Anweisung oder ein DEFAULT-Prädikat abgesetzt, wobei für eine Spalte DEFAULT angegeben wurde, für die weder in der CREATE TABLE- noch in einer nachfolgenden ALTER TABLE-Anweisung eine DEFAULT-Spezifikation definiert worden ist.

Benutzerreaktion:

Geben Sie statt DEFAULT den gewünschten Wert an.


-7036: ROWNO- specification not allowed in this context (SAP-Bibliothek - Grundwissen)

-7036: ROWNO- specification not allowed in this context

Erläuterung:

Eine der folgenden Bedingungen wurde verletzt:

...

1. Die Spezifikation von ROWNO darf nur in QUERY-Anweisungen verwendet werden. In der QUERY-Anweisung darf kein UNION, EXCEPT oder INTERSECT enthalten sein.

2. Das ROWNO-Prädikat kann innerhalb der Suchbedingung verwendet werden, und zwar in der Form ROWNO < <rowno_spec> oder ROWNO <= <rowno_spec>, d. h. ROWNO steht links vom Operator.

3. In einer Suchbedingung darf das ROWNO-Prädikat nur einmal auftreten und muss mit anderen Prädikaten mit logischem AND verbunden werden.

Benutzerreaktion:

...

1. Im Fall von UNION, EXCEPT oder INTERSECT können Sie den Effekt durch zwei aufeinanderfolgende QUERY-Anweisungen erzielen.

2. Korrigieren Sie die Suchbedingung der SQL-Anweisung entsprechend.


-7037: NULL value for NOT NULL column not allowed (SAP-Bibliothek - Grundwissen)

-7037: NULL value for NOT NULL column not allowed

Erläuterung:

Die Fehlermeldung tritt bei der Ausführung einer referentiellen CONSTRAINT-Definition mit Angabe von ON DELETE SET NULL in der DELETE-Regel auf, wenn eine Spalte (referencing_column) den NULL-Wert nicht zuläßt.

Benutzerreaktion:

Sie müssen eine andere Aktion in der DELETE-Regel wählen oder in der referenzierenden Tabelle für die entsprechende(n) Spalte(n) den NULL-Wert zulassen.


-7038: Foreign key column not allowed (SAP-Bibliothek - Grundwissen)

-7038: Foreign key column not allowed

Erläuterung:

Unter Fremdschlüsselspalte versteht man eine Spalte, die als referencing_column einer referentiellen CONSTRAINT-Definition angegeben wurde.

...

1. Es wurde versucht, eine Spalte einer Tabelle zu löschen, die als referencing_column einer CONSTRAINT-Definition angegeben wurde.

2. Es wurde versucht, den Schlüssel einer Tabelle zu löschen. Dessen Spalten wurden implizit oder explizit als referencing_column einer CONSTRAINT-Definition angegeben.

Benutzerreaktion:

Löschen Sie die referentielle CONSTRAINT-Definition und dann die Spalte oder den Schlüssel.


-7039: Cycle in referential constraint definition not allowed (SAP-Bibliothek - Grundwissen)

-7039: Cycle in referential constraint definition not allowed

Erläuterung:

Es wurde versucht, eine referentielle CONSTRAINT-Definition zu erzeugen, durch die ein unzulässiger Referenzzyklus entstehen würde. Die CONSTRAINT-Definition würde zu prinzipiellen Widersprüchen führen und wird deshalb vom Datenbanksystem abgelehnt.

Benutzerreaktion:

Lösen Sie die zyklische Abhängigkeit auf.


-7040: Referential constraint not allowed (SAP-Bibliothek - Grundwissen)

-7040: Referential constraint not allowed

Erläuterung:

Es gibt bereits eine referentielle CONSTRAINT-Definition mit der angegebenen referenzierenden Tabelle. Zusätzlich entsteht eine CASCADE-Abhängigkeit. Unter diesen Bedingungen müssen alle CONSTRAINT-Definitionen mit der angegebenen referenzierenden Tabelle entweder CASCADE oder RESTRICT spezifizieren.

Benutzerreaktion:

Der gewünschte Effekt muss überdacht werden, da er zu prinzipiellen Widersprüchen führt. Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.FOREIGNKEYCOLUMNS, Informationen über bestehende referentielle CONSTRAINT-Definitionen anzeigen lassen.


-7041: Result table name not allowed (SAP-Bibliothek - Grundwissen)

-7041: Result table name not allowed

Erläuterung:

Bei der CREATE VIEW-Anweisung wurde in einer FROM-Klausel des QUERY-Ausdrucks eine benannte Ergebnistabelle angegeben. Es dürfen jedoch nur Basis- oder View-Tabellen angegeben werden.

Benutzerreaktion:

Geben Sie in der SQL-Anweisung eine Basis- oder View-Tabelle an, und erweitern Sie die Suchbedingung um die Bedingungen, die bei der Erstellung der Ergebnistabelle verwendet wurden.


-7042: Key update not allowed (SAP-Bibliothek - Grundwissen)

-7042: Key update not allowed

Erläuterung:

Es wurde versucht, den Wert einer Schlüsselspalte einer temporären Tabelle in einen neuen Wert zu ändern. Das ist nicht möglich. Schlüsselspalten permanenter Tabellen können verändert werden.

Benutzerreaktion:

Ist ein anderer Schlüsselwert erwünscht, müssen Sie die Zeile mit dem alten Schlüsselwert löschen und mit dem neuen wieder einfügen.


-7043: Group member not allowed (SAP-Bibliothek - Grundwissen)

-7043: Group member not allowed

Erläuterung:

Folgende Ursachen sind möglich:

...

1. Es wurde versucht, einem Benutzer, der zu einer Benutzergruppe gehört, Privilegien zu verleihen.

2. Es wurde versucht, die Eigenschaften eines Benutzers, der Mitglied einer Benutzergruppe ist, mittels einer ALTER USER-Anweisung zu ändern.

Eigenschaften des Benutzers und Privilegien können für Mitglieder einer Benutzergruppe nicht geändert werden. Das ist nur für die Benutzergruppe möglich.

Benutzerreaktion:

Mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.USERS, ist es für einen Datenbankadministrator möglich, sich anzeigen zu lassen, zu welcher Benutzergruppe der betreffende Benutzer gehört. Bei anderen Benutzern ist die Anzeige auf Benutzer und Benutzergruppen eingeschränkt, die zu dem gleichen Datenbankadministrator gehören wie sie selbst.

...

1. Die Privilegien müssen an die Benutzergruppe vergeben werden, zu der der Benutzer gehört.

2. Ersetzen Sie die ALTER USER- durch eine ALTER USERGROUP-Anweisung.


-7045: Parameter spec not allowed (SAP-Bibliothek - Grundwissen)

-7045: Parameter spec not allowed

Erläuterung:

Es wurde ein Parameter angegeben, obwohl diese Datenbankkomponente bzw. diese Art der Anwendungsprogrammierung nur die Verwendung von Konstanten zuläßt.

Benutzerreaktion:

Ersetzen Sie den Parameter durch eine Konstante.


-7046: Column with length greater than 254 not allowed (SAP-Bibliothek - Grundwissen)

-7046: Column with length greater than 254 not allowed

Erläuterung:

Es wurde versucht, eine Spalte vom Datentyp CHAR mit einer Länge größer als 254 in einem Anweisungsteil zu verwenden, in dem sie nicht zulässig ist. Das kann u. a. der Fall sein, wenn versucht wurde, eine Spalte mit einer Definitionslänge kleiner als 254 in eine mit einer Definitionslänge größer als 254 zu ändern.

Benutzerreaktion:

Verzichten Sie auf die Verwendung dieser Spalte im Anweisungsteil. Versuchen Sie, den gewünschten Effekt durch Anwendungsprogrammierung zu erzielen. Bei der Änderung der Definitionslänge könnte durch eine MODIFY-Definition statt einer ALTER-Definition der gewünschte Effekt erreicht werden. Es ist allerdings mit einem erheblich höheren Zeitbedarf zu rechnen. Dieser Zeitbedarf richtet sich nach der Anzahl von Datensätzen in der angesprochenen Tabelle und nach der für diese Tabelle definierten Indizes.


-7048: DROP/ALTER USER not allowed while user is connected (SAP-Bibliothek - Grundwissen)

-7048: DROP/ALTER USER not allowed while user is connected

Erläuterung:

Es wurde versucht, einen zur Zeit angemeldeten Benutzer zu löschen oder dessen Eigenschaften zu ändern. Das ist nur erlaubt, wenn der Benutzer nicht angemeldet ist.

Benutzerreaktion:

Führen Sie die SQL-Anweisung zu einem Zeitpunkt durch, an dem der zu löschende oder zu ändernde Benutzer nicht angemeldet ist.


-7050: Fastload with indexed table not allowed (SAP-Bibliothek - Grundwissen)

-7050: Fastload with indexed table not allowed

Erläuterung:

Auf der zu importierenden Tabelle ist ein Index angelegt. In diesem Fall ist ein schneller Import unter Verwendung des Loader-Kommandos Strukturlink IMPORT TABLE <table_spec> nicht möglich.

Benutzerreaktion:

Löschen Sie den Index, oder verzichten Sie auf den schnellen Import.


-7051: Read only view WITH CHECK OPTION not allowed (SAP-Bibliothek - Grundwissen)

-7051: Read only view WITH CHECK OPTION not allowed

Erläuterung:

Die zu definierende View-Tabelle ist nicht änderbar. Für nicht änderbare View-Tabellen ist die Angabe von WITH CHECK OPTION nicht erlaubt.

Benutzerreaktion:

Führen Sie die gleiche SQL-Anweisung ohne Angabe von WITH CHECK OPTION durch.


-7055: Column(s) already indexed (SAP-Bibliothek - Grundwissen)

-7055: Column(s) already indexed

Erläuterung:

Es existiert bereits ein Index für die angegebene(n) Spalte(n).

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.INDEXCOLUMNS, können Sie überprüfen, ob die Ablage der Indexwerte in auf- oder absteigender Reihenfolge vorgenommen wird. Eine Benutzerreaktion ist nicht erforderlich.


-7056: Subquery not allowed (SAP-Bibliothek - Grundwissen)

-7056: Subquery not allowed

Erläuterung:

In einer CONSTRAINT-Definition ist die Angabe einer Subquery nicht zulässig.

Benutzerreaktion:

...

1. Versuchen Sie, die Suchbedingung so umzuformulieren, dass auf die Subquery verzichtet werden kann.

2. Versuchen Sie, den gewünschten Effekt durch Definition eines Triggers, der die Bedingung überprüft, zu erzielen.


-7057: View definition contradicts new table definition (SAP-Bibliothek - Grundwissen)

-7057: View definition contradicts new table definition

Erläuterung:

...

1. Es wurde versucht, einer Tabelle eine Spalte hinzuzufügen oder aus einer Tabelle eine Spalte zu löschen. Bei der Definition der angegebenen View-Tabelle wurde SELECT * verwendet, und den View-Tabellenspalten wurden neue Namen zugewiesen. Die Anzahl der View-Tabellenspalten würde nach der Tabellenänderung nicht mehr mit der Anzahl der Tabellenspalten übereinstimmen.

2. Es wurde versucht, eine referentielle CONSTRAINT-Definition zu löschen, die Voraussetzung für eine änderbare Join-View-Tabelle ist.

Benutzerreaktion:

...

1. Löschen Sie die View-Tabelle, und definieren Sie diese anschließend neu. Die gewünschten Spalten sollten Sie einzeln in den selektierten Spalten des QUERY-Ausdrucks angeben.

2. Die referentielle CONSTRAINT-Definition können Sie nur löschen, wenn zuvor die änderbare View-Tabelle gelöscht worden ist.


-7058: Correlated subquery with select in from clause not allowed

Erläuterung:

Es ist nicht möglich, in einer korrespondierenden Subquery (Correlated Subquery) einen QUERY-Ausdruck in der FROM-Klausel anzugeben.

Benutzerreaktion:

Formulieren Sie die korrespondierende Subquery so um, dass auf den QUERY-Ausdruck verzichtet werden kann. Ist das nicht möglich, müssen Sie die SQL-Anweisung in mindestens zwei SQL-Anweisungen aufteilen und eine benannte Ergebnistabelle erzeugen, die in der FROM-Klausel verwendet werden kann.


-7061: LOCK ROW for this table not allowed (SAP-Bibliothek - Grundwissen)

-7061: LOCK ROW for this table not allowed

Erläuterung:

Für eine Join-View-Tabelle darf eine LOCK-Anweisung mit Angabe einer ROW-Spezifikation nur ausgeführt werden, wenn es sich um eine änderbare Join-Viewtabelle handelt. Selbst für änderbare Join-View-Tabellen ist die Angabe einer ROW-Spezifikation mit Angabe von OPTIMISTIC nicht zulässig.

Benutzerreaktion:

Sie können durch Angabe von mehreren ROW-Spezifikationen auf die zugrundeliegenden Basistabellen diesen Effekt erreichen.


-7063: Temp table not allowed (SAP-Bibliothek - Grundwissen)

-7063: Temp table not allowed

Erläuterung:

Für temporäre Tabellen ist nur eine eingeschränkte Menge von SQL-Anweisungen zur Datendefinition zulässig. Dazu gehören das Erzeugen und Löschen der Tabellen und die Existenzabfrage.

Benutzerreaktion:

Entscheiden Sie, ob auf die SQL-Anweisung zur Datendefinition verzichtet werden kann oder statt der temporären Tabelle eine permanente zu erzeugen ist.


-7064: Feature not allowed in temp table definition (SAP-Bibliothek - Grundwissen)

-7064: Feature not allowed in temp table definition

Erläuterung:

Es ist nicht möglich, für eine temporäre Tabelle eine referentielle CONSTRAINT-Definition anzugeben.

Benutzerreaktion:

Wiederholen Sie die SQL-Anweisung ohne die unzulässigen Angaben, oder erzeugen Sie statt der temporären eine permanente Tabelle.


-7065: SUBTRANS COMMIT/ROLLBACK not allowed without SUBTRANS BEGIN

Erläuterung:

Für jede Subtransaktion, die geschlossen werden soll, muss eine SUBTRANS BEGIN-Anweisung aufgerufen worden sein.

Benutzerreaktion:

Überprüfen Sie die Datenbankanwendung auf das dynamische Verhalten der SUBTRANS-Anweisungen hin.


-7066: Unique index referenced by foreign key not allowed (SAP-Bibliothek - Grundwissen)

-7066: Unique index referenced by foreign key not allowed

Erläuterung:

Der angegebene Index kann nicht gelöscht werden, da die in ihm enthaltenen Spalten in einer referentiellen CONSTRAINT-Definition als referenzierte Spalten der referenzierten Tabelle (referenced_table) angegeben wurden.

Benutzerreaktion:

Sie können den Index nur löschen, nachdem die entsprechende referentielle CONSTRAINT-Definition gelöscht wurde. Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.FOREIGNKEYCOLUMNS, anzeigen lassen, welche CONSTRAINT-Definitionen erzeugt wurden.


-7067: Update without repeated read not allowed (SAP-Bibliothek - Grundwissen)

-7067: Update without repeated read not allowed

Erläuterung:

Durch eine vorangegangene SQL-Anweisung wurde eine optimistische Sperre auf mindestens eine Zeile einer Tabelle gesetzt. Ein anderer Datenbankbenutzer veränderte danach mindestens eine dieser Zeilen. Der Datenbankbenutzer, der die optimistische Sperre gesetzt hatte, kann erst wieder Änderungen an dieser Zeile vornehmen, nachdem er sie wieder mit einer (optimistischen) Sperre gelesen hat.

Benutzerreaktion:

Die zu ändernde Zeile muss erneut mit (optimistischer) Sperre gelesen werden.


-7068: Outer Join not allowed in this context (SAP-Bibliothek - Grundwissen)

-7068: Outer Join not allowed in this context

Erläuterung:

Es wurde ein OUTER JOIN-Indikator in einem Vergleichsprädikat verwendet, in dem in einem der beiden Ausdrücke keine Spalte einer Tabelle angegeben ist. Ein OUTER JOIN-Indikator ist nur in einem JOIN-Prädikat zulässig.

Benutzerreaktion:

Sie können die SQL-Anweisung ohne den OUTER JOIN-Indikator wiederholen.


-7071: AUTOSAVE LOG must be stopped (SAP-Bibliothek - Grundwissen)

-7071: AUTOSAVE LOG must be stopped

Erläuterung:

Es sollte ein SHUTDOWN durchgeführt werden. Das ist nicht möglich, solange die automatische Log-Sicherung noch aktiv ist.

Benutzerreaktion:

Stoppen Sie die automatische Log-Sicherung, und führen Sie dann den SHUTDOWN durch.


-7072: More than one column with default SERIAL not allowed (SAP-Bibliothek - Grundwissen)

-7072: More than one column with default SERIAL not allowed

Erläuterung:

Es wurde versucht, bei der Definition einer Basistabelle die DEFAULT-Spezifikation DEFAULT SERIAL mehrfach zu vergeben. In jeder Basistabelle darf maximal eine Spalte mit der DEFAULT-Spezifikation DEFAULT SERIAL existieren.

Benutzerreaktion:

Entscheiden Sie, in welcher der Spalten auf diese Angabe verzichtet werden kann. Wiederholen Sie anschließend die geänderte SQL-Anweisung.


-7074: Cycle in granted roles not allowed (SAP-Bibliothek - Grundwissen)

-7074: Cycle in granted roles not allowed

Erläuterung:

Folgende Ursachen sind möglich:

...

1. Es wurde versucht, eine Rolle an sich selbst zu vergeben.

2. Es wurde versucht, Rollendefinitionen zyklisch zu vergeben.

Benutzerreaktion:

Prüfen Sie, ob eventuell ein Schreibfehler vorliegt. Ist das nicht der Fall, prüfen Sie, ob die Rollen, die den Zyklus ergeben würden, zu einer zusammengefasst werden können.


-7075: Current save skipped, next is ready to take on this tape (SAP-Bibliothek - Grundwissen)

-7075: Current save skipped, next is ready to take on this tape

Erläuterung:

Es wurde versucht, eine Log-Sicherung von einem No-Rewind-Band zurückzuladen. Die angegebene Sicherung ist älter als die benötigte. Diese könnte noch auf diesem Band gespeichert sein.

Benutzerreaktion:

Sie müssen versuchen, das Zurückladen der nächsten Sicherung durchzuführen, die sich auf diesem Band befindet.


-7076: No more data to read from tape (SAP-Bibliothek - Grundwissen)

-7076: No more data to read from tape

Erläuterung:

Es wurde versucht, eine Log-Sicherung von einem No-Rewind-Band zurückzuladen. Die angegebene Sicherung ist älter als die benötigte. Es befindet sich keine weitere Sicherung auf diesem Band.

Benutzerreaktion:

Das aktuelle Band wird nicht mehr benötigt. Statt dessen legen Sie das Band mit der benötigten Sicherung ein, und wiederholen Sie den Befehl.


-7077: Synonym not allowed (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -7077: Synonym not allowed

Erläuterung:

Sie haben einen Synonymnamen innerhalb einer CREATE TRIGGER- oder CREATE DBPROC-Anweisung verwendet. Das ist nicht zulässig.

Benutzerreaktion:

Verwenden Sie anstatt des Synonymnamens den Namen, für den der Synonymname definiert wurde.


-7078: No backup is running (SAP-Bibliothek - Grundwissen)

-7078: No backup is running

Erläuterung:

Es wurde versucht eine Sicherung abzubrechen, obwohl zur Zeit keine Sicherung aktiv ist.

Benutzerreaktion:

Es ist keine Benutzerreaktion erforderlich.


-7079: A backup is already running (SAP-Bibliothek - Grundwissen)

-7079: A backup is already running

Erläuterung:

Es wurde versucht, eine Sicherung zu starten, während eine Sicherung durchgeführt wird. Zu einer Zeit ist nur eine Sicherung möglich.

Benutzerreaktion:

Es ist keine Benutzerreaktion möglich.


-7080: Query in statement not allowed (SAP-Bibliothek - Grundwissen)

-7080: Query in statement not allowed

Erläuterung :

Die Suchbedingung einer IF- oder WHILE-Anweisung enthält eine QUERY-Anweisung. Dies ist nicht zulässig.

Benutzerreaktion :

Führen Sie die QUERY-Anweisung außerhalb der IF- bzw. WHILE-Anweisung aus und speichern Sie die benötigten Ergebnisse in Programmvariablen. Benutzen Sie diese anschließend in der IF- bzw. WHILE-Anweisung.


-7082: SQL statement not allowed for this table type (SAP-Bibliothek - Grundwissen)

-7082: SQL statement not allowed for this table type

Erläuterung:

SQL-Anweisungen zum Löschen oder Ändern von Tabellenzeilen oder zum Ändern von Tabellendefinitionen sind für diesen Tabellentyp nicht zulässig.

Benutzerreaktion:

Sie können diese SQL-Anweisung nicht verwenden.


-7084: Parameter change not allowed (SAP-Bibliothek - Grundwissen)

-7084: Parameter change not allowed

Erläuterung:

Es wurde versucht, mit Hilfe einer SET-Anweisung den Wert eines Installationsparameters zu ändern. Das Datenbanksystem konnte den Wert jedoch aus einem der folgenden Gründe nicht ändern:

· Der Installationsparameter ist grundsätzlich nicht änderbar.

· Der Installationsparameter ist in den Betriebszuständen ONLINE und ADMIN nicht änderbar.

Benutzerreaktion:

Sie haben folgende Möglichkeiten:

· Verzichten Sie auf die Änderung.

· Wenn der Installationsparameter in den Betriebszuständen ONLINE oder ADMIN nicht änderbar ist, dann überführen Sie die Datenbankinstanz in den Betriebszustand OFFLINE, nehmen die Änderung vor und überführen die Datenbankinstanz anschließend wieder in den gewünschten Betriebszustand.


-7085: Function not allowed for this cursor (SAP-Bibliothek - Grundwissen)

-7085: Function not allowed for this cursor

Erläuterung:

Sie haben versucht, für einen Cursor, der als nicht scrollable angelegt wurde, eine FETCH-Anweisung mit einer der optionalen Angaben FIRST, LAST, PREV, <position> oder SAME durchzuführen. Das ist nur für scrollable Cursor zulässig.

Benutzerreaktion:

Verwenden Sie für diesen Cursor keine der genannten optionalen Angaben oder verwenden Sie NEXT oder erzeugen Sie den Cursor neu als scrollable Cursor


-7086: Schema not allowed (SAP-Bibliothek - Grundwissen)

-7086: Schema not allowed

Erläuterung:

Das Schema mit dem angegebenen Namen darf nicht verwendet werden. Dies ist der Fall, wenn in der CREATE SYNONYM-Anweisung oder der CREATE DOMAIN-Anweisung ein Schemaname angegeben wird, der sich vom Namen des aktuellen Benutzers unterscheidet.

Benutzerreaktion:

Korrigieren Sie den Schemanamen.


-7500: DCOM HRESULT (SAP-Bibliothek - Grundwissen)

-7500: DCOM HRESULT

Erläuterung

Bei der CREATE PACKAGE-Anweisung ist ein unerwarteter Fehler aufgetreten. Die genaue Fehlerursache wird durch einen numerischen Wert (HRESULT) in der Fehlermeldung identifiziert.

Benutzerreaktion

Das Auftreten dieses Fehlers deutet auf falsche oder fehlende Einträge in der Registrierungsdatenbank hin.

Stellen Sie sicher, dass unter der angegebenen Programatic-ID der korrekte Verweis auf die entsprechende Bibliothek existiert. Stellen Sie sicher, dass die Bibliothek an der angegebenen Stelle existiert und dass sie ausreichend privilegiert ist.

Sollte durch dieses Vorgehen das Problem nicht behoben sein, übermitteln Sie den numerischen Wert (HRESULT) dem Support zur Fehleranalyse.


-7900: Different block sizes (SAP-Bibliothek - Grundwissen)

-7900: Different block sizes

Erläuterung:

Die bei der Wiederherstellung angegebene Blockungsgröße und die bei der Sicherung verwendete unterscheiden sich. Die Wiederherstellung kann nicht erfolgreich beendet werden.

Benutzerreaktion:

Sie müssen die Wiederherstellung mit der Blockungsgröße durchführen, die bei der zugehörigen Sicherung verwendet wurde.


Von -8000 bis -9799 (SAP-Bibliothek - Grundwissen)

Von -8000 bis -9799

Fehlermeldungen aus dem Datenbankkern

-8000 | SERVERDB must be restarted
-8001 | User must be connected
-8002 | User already connected to this user task
-8003 | Log and data must be compatible
-8004 | Constant must be compatible with column type and length
-8005 | Value expression must be parameter name
-8006 | Data types must be compatible
-8007 | Column must be key column
-8009 | DEFAULT value must be in constraint specification
-8010 | Table name must be in from list
-8013 | Order column must be output column
-8014 | Result table must be FOR REUSE
-8015 | Table must be a base table
-8016 | Table must be a view table
-8017 | Column must be group column
-8018 | Index name must be unique
-8020 | Next volume required
-8021 | Column must have DEFAULT specification
-8022 | User already connected
-8023 | COSTLIMIT must be greater than COSTWARNING
-8024 | RESTORE CATALOG failed
-8025 | Table must be temp table
-8026 | Connect disabled for this user
-8028 | UNION columns must be compatible
-8030 | Column must be indexed
-8031 | Owner must be specified
-8033 | Incomplete log segment
-8034 | Order column must be number
-8035 | Foreign key must exist
-8037 | DB procedure must be recompiled
-8040 | Key does not exist
-8044 | Conversion for character set value impossible
-8045 | Conversion to UNICODE impossible
-8046 | Conversion from UNICODE impossible
-8047 | Password required
-8048 | Version of component must be compatible with kernel version
-8050 | Migration error
-8051 | No snapshot available
-8052 | Trigger dropped during migration; check view migrationerrorprotocol
-8053 | Software version is too old for version of persistent data
-8888 | SERVERDB not accessible
-9000 | System error: Not yet implemented
-9001 bis -9799 | System error


-8000: SERVERDB must be restarted (SAP-Bibliothek - Grundwissen)

-8000: SERVERDB must be restarted

Erläuterung:

Ein Arbeiten auf der Datenbankinstanz ist nicht möglich, da die Datenbankinstanz gestoppt wurde.

Benutzerreaktion:

Starten Sie die Datenbankinstanz in den Betriebszustand ONLINE.


-8001: User must be connected (SAP-Bibliothek - Grundwissen)

-8001: User must be connected

Erläuterung:

Eine Datenbanksitzung kann nur mit einer CONNECT-Anweisung eröffnet werden.

Benutzerreaktion:

Geben Sie eine CONNECT-Anweisung ein.


-8002: User already connected to this user task (SAP-Bibliothek - Grundwissen)

-8002: User already connected to this user task

Erläuterung:

Ein Benutzer, der bereits mit der Datenbankinstanz verbunden ist, hat eine weitere CONNECT-Anweisung eingegeben.

Benutzerreaktion:

Soll unter einem anderen Benutzernamen weitergearbeitet werden, so müssen Sie zuerst eine RELEASE- und dann ein CONNECT-Anweisung eingeben.


-8003: Log and data must be compatible (SAP-Bibliothek - Grundwissen)

-8003: Log and data must be compatible

Erläuterung:

Sie haben entweder eine Datensicherung eingelesen, die nicht zum Log-Bereich der Datenbankinstanz passt, oder eine Log-Sicherung eingelesen, die nicht zum Datenbereich der Datenbank passt.

Benutzerreaktion:

● Überprüfen Sie, ob die Datenbank-ID von Sicherung und Datenbankinstanz übereinstimmen.

● Verwenden Sie die Sicherung, die zu Ihrer Datenbankinstanz gehört.

Siehe auch:

Database Manager CLI, Strukturlink db_restartinfo, Strukturlink medium_label

Konzepte des Datenbanksystems, Sichern und Wiederherstellen


-8004: Constant must be compatible with column type and length (SAP-Bibliothek - Grundwissen)

-8004: Constant must be compatible with column type and length

Erläuterung:

Die angegebene Konstante passt nicht zum Datentyp dieser Spalte.

Benutzerreaktion:

Ermitteln Sie durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, die Definition der betroffenen Spalte. Geben Sie eine Konstante mit dem richtigen Datentyp an.


-8005: Value expression must be parameter name (SAP-Bibliothek - Grundwissen)

-8005: Value expression must be parameter name

Erläuterung:

Beim Aufruf einer Datenbankprozedur wurde für einen OUT- oder IN/OUT-Parameter kein Parameter, sondern ein konstanter Wert angegeben.

Benutzerreaktion:

Ersetzen Sie die Angabe der Konstanten durch einen Parameter.


-8006: Data types must be compatible (SAP-Bibliothek - Grundwissen)

-8006: Data types must be compatible

Erläuterung:

...

1. Eine Funktion wurde auf ein nicht zulässiges Argument angewendet.

2. Eine zweistellige Operation wurde auf nicht vergleichbare Werte angewendet.

3. Ein Prädikat enthält nicht vergleichbare Datentypen.

Jeder Datentyp ist mit sich selbst vergleichbar. Spalten des Datentyps CHAR mit den unterschiedlichen Codeattributen ASCII und UNICODE sind vergleichbar, wobei eine implizite Anpassung erfolgt. Spalten der Codeattribute ASCII sind mit Datumsangaben, Zeitangaben und Zeitstempelangaben vergleichbar.

Alle Zahlen sind untereinander vergleichbar.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die Definition der beteiligten Spalten ermitteln. Gegebenenfalls können Sie versuchen, durch Anwendung einer Konversionsfunktion die Vergleichbarkeit zu erreichen.


-8007: Column must be key column (SAP-Bibliothek - Grundwissen)

-8007: Column must be key column

Erläuterung:

Die Angabe einer Nicht-Schlüsselspalte ist hier unzulässig.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie ermitteln, welche Spalten zum Schlüssel der Tabelle gehören. Nur solche Spalten sind an dieser Stelle der SQL-Anweisung anzugeben.


-8009: DEFAULT value must be in constraint specification (SAP-Bibliothek - Grundwissen)

-8009: DEFAULT value must be in constraint specification

Erläuterung:

Der angegebene DEFAULT-Wert würde die CONSTRAINT-Definition verletzen.

Benutzerreaktion:

...

1. Überdenken Sie die Definition der entsprechenden CONSTRAINT-Definition und ändern Sie diese gegebenenfalls.

2. Wählen Sie einen anderen DEFAULT-Wert, oder verzichten Sie auf die Angabe eines DEFAULT-Wertes.


-8010: Table name must be in from list (SAP-Bibliothek - Grundwissen)

-8010: Table name must be in from list

Erläuterung:

In einer selektierten Spalte, Suchbedingung oder ORDER-Klausel wurde ein Tabellenname angegeben, der nicht in der FROM-Klausel aufgeführt wurde.

Benutzerreaktion:

...

1. Wurde für einen Tabellennamen ein Referenzname angegeben, müssen Sie den Referenznamen in der SQL-Anweisung verwenden.

2. Ist in der FROM-Klausel eine Tabelle angegeben, die nicht im Schema des aktuellen Datenbankbenutzers liegt und auch keine Systemtabelle ist, so müssen Sie in der gesamten SQL-Anweisung den Schemanamen der Tabelle mit angeben.


-8013: Order column must be output column (SAP-Bibliothek - Grundwissen)

-8013: Order column must be output column

Erläuterung:

...

1. Bei einer QUERY-Anweisung mit DISTINCT-Spezifikation können in der ORDER-Klausel nur Spaltennamen angegeben werden, die auch als selektierte Spalte angegeben wurden.

2. Wurden Spaltennummern angegeben, ist darauf zu achten, dass die Nummer nicht größer ist als die Anzahl der angegebenen Ausgabespalten.

3. Bei einem SELECT * kann sich die Anzahl der Ausgabespalten infolge einer ALTER TABLE-Anweisung mit Angabe einer DROP-Definition verringert haben.

Benutzerreaktion:

...

1. Verzichten Sie auf die Angabe von DISTINCT oder geben Sie die Spalte der ORDER-Klausel in einer selektierten Spalte an.

2. Verändern Sie die Nummer in der ORDER-Klausel entsprechend.


-8014: Result table must be FOR REUSE (SAP-Bibliothek - Grundwissen)

-8014: Result table must be FOR REUSE

Erläuterung:

In der FROM-Klausel einer QUERY- oder SINGLE SELECT-Anweisung wurde eine benannte Ergebnistabelle verwendet, die nicht mit FOR REUSE erzeugt wurde.

Benutzerreaktion:

Erzeugen Sie die benannte Ergebnistabelle mit der Angabe FOR REUSE, und führen Sie die SQL-Anweisung erneut durch.


-8015: Table must be a base table (SAP-Bibliothek - Grundwissen)

-8015: Table must be a base table

Erläuterung:

Es wird die Angabe einer Basistabelle erwartet. Diese Angabe fehlt, oder die angegebene Tabelle ist keine Basistabelle.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.TABLES, können Sie ermitteln, ob es sich bei der angegebenen Tabelle um eine View-Tabelle oder eine Ergebnistabelle handelt. Im Fall einer View-Tabelle können Sie durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.VIEWDEFS, die zugehörige Basistabelle feststellen. Für diese können Sie dann bei entsprechender Privilegierung die gewünschte SQL-Anweisung durchführen.


-8016: Table must be a view table (SAP-Bibliothek - Grundwissen)

-8016: Table must be a view table

Erläuterung:

Bei der RENAME VIEW- oder DROP VIEW-Anweisung wurde eine Tabelle angegeben, die keine View-Tabelle ist.

Benutzerreaktion:

Geben Sie in der SQL-Anweisung eine View-Tabelle an, oder ersetzen Sie die SQL-Anweisung durch eine RENAME TABLE- oder DROP TABLE- Anweisung.


-8017: Column must be group column (SAP-Bibliothek - Grundwissen)

-8017: Column must be group column

Erläuterung:

Es wurde eine Spalte in einer selektierten Spalte oder in der HAVING-Klausel angegeben, die keine Gruppierspalte ist, d. h. sie ist nicht in der GROUP-Klausel enthalten. Spalten, die keine Gruppierspalten sind, dürfen nur in den Argumenten der Set-Funktionen AVG, COUNT, MAX, MIN, STDDEV, SUM und VARIANCE auftreten.

Benutzerreaktion:

Fügen Sie die angegebene Spalte als weitere Gruppierspalte in die Gruppierbedingung ein, oder entfernen Sie diese aus der selektierten Spalte bzw. der HAVING-Klausel.


-8018: Index name must be unique (SAP-Bibliothek - Grundwissen)

-8018: Index name must be unique

Erläuterung:

...

1. Diese Fehlermeldung kann bei der DROP INDEX- Anweisung auftreten. Zu verschiedenen Tabellen wurden Indizes mit gleichem Namen definiert. Daher ist der zu löschende Indexname nicht eindeutig.

2. Es existiert nur ein benannter einspaltiger Index für diese Spalte. Es wurde versucht, den Index für diese Spalte ohne Angabe des Namens zu löschen.

Benutzerreaktion:

...

1. Geben Sie beim DROP INDEX zusätzlich den Tabellennamen an, auf den sich der zu löschende Index bezieht.

2. Löschen Sie den Index mit Angabe seines Namens.


-8020: Next volume required (SAP-Bibliothek - Grundwissen)

-8020: Next volume required

Erläuterung:

Dieser Fehler kann unter anderem in folgenden Fällen auftreten:

...

a. Beim Sichern: auf dem aktuell verwendeten Datenträger ist kein Platz mehr.

b. Beim Einlesen einer Datensicherung: es wurden nicht alle Datenträger angegeben, die zu dieser Datensicherung gehören.

c. Beim Einlesen einer Log-Sicherung: das Datenbanksystem benötigt den nächsten Datenträger der Log-Sicherung.

Benutzerreaktion:

...

a. Geben Sie einen weiteren Datenträger an.

b. Vervollständigen Sie die Liste der Datenträger.

c. Geben Sie, sofern vorhanden, den nächsten Datenträger der Log-Sicherung an oder beenden Sie das Einlesen der Log-Sicherung manuell.

Siehe auch:

Konzepte des Datenbanksystems, Sichern und Wiederherstellen


-8021: Column must have DEFAULT specification (SAP-Bibliothek - Grundwissen)

-8021: Column must have DEFAULT specification

Erläuterung:

Es wurde versucht, in einer referentiellen CONSTRAINT-Definition die Aktion SET DEFAULT als DELETE-Regel anzugeben, obwohl für mindestens eine Spalte (referencing_column) kein DEFAULT-Wert definiert ist.

Benutzerreaktion:

...

1. Falls der Fehler bei der Bearbeitung einer CREATE TABLE- Anweisung auftrat, müssen Sie für die Spalte(n) einen DEFAULT-Wert definieren oder eine andere Aktion wählen.

2. Falls der Fehler bei der Bearbeitung einer ALTER TABLE- Anweisung auftrat, müssen Sie vor der erneuten Ausführung allen Spalten (referencing_column), die keinen DEFAULT-Wert besitzen, durch eine ALTER TABLE- Anweisung einen DEFAULT-Wert zuordnen. Als Alternative dazu können Sie eine andere Aktion wählen.


-8022: User already connected (SAP-Bibliothek - Grundwissen)

-8022: User already connected

Erläuterung:

Ein Benutzer versucht, sich unter einem Benutzernamen am Datenbanksystem anzumelden, für den in der CREATE USER-, CREATE USERGROUP-, ALTER USER- oder ALTER USERGROUP- Anweisung EXCLUSIVE definiert wurde und mit dem sich schon ein anderer Benutzer angemeldet hat.

Benutzerreaktion:

Warten Sie, bis sich der andere Benutzer mittels einer RELEASE-Anweisung vom Datenbanksystem abgemeldet hat.

Soll eine gleichzeitige mehrmalige Anmeldung eines Benutzers möglich sein, muss mit Hilfe einer ALTER USER- oder ALTER USERGROUP-Anweisung für den Benutzer NOT EXCLUSIVE spezifiziert werden. Diese SQL-Anweisungen dürfen nur vom Eigentümer des Benutzers oder der Benutzergruppe ausgeführt werden.


-8023: COSTLIMIT must be greater than COSTWARNING (SAP-Bibliothek - Grundwissen)

-8023: COSTLIMIT must be greater than COSTWARNING

Erläuterung:

Es wurde ein COSTLIMIT-Wert angegeben, der kleiner oder gleich dem angegebenen COSTWARNING-Wert ist. Der COSTLIMIT-Wert muss jedoch größer sein als der COSTWARNING-Wert.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.USERS, können Sie für bestehende Benutzer den COSTWARNING-Wert ermitteln.


-8024: RESTORE CATALOG failed (SAP-Bibliothek - Grundwissen)

-8024: RESTORE CATALOG failed

Erläuterung

Bei einigen Datendefinitionsanweisungen werden Teile des Datenbankkatalogs zunächst gelöscht und dann wieder aufgebaut.

Wenn es dabei zu einem nicht erwarteten Fehler kommt, wird der Fehler -8024 ausgegeben.

Benutzerreaktion

Erstellen Sie einen Datenbank-Trace der letzten Datenbankaktivitäten, und sichern Sie diesen.

Übermitteln Sie den Datenbank-Trace dem Support zur Fehlerverfolgung und -behebung.


-8025: Table must be temp table (SAP-Bibliothek - Grundwissen)

-8025: Table must be temp table

Erläuterung:

Bei einer CREATE TABLE- Anweisung wurde die Option IGNORE ROLLBACK für eine permanente Tabelle angegeben. Das ist unzulässig.

Benutzerreaktion:

Sie können die SQL-Anweisung wiederholen, wobei entweder auf die Option IGNORE ROLLBACK verzichtet werden muss oder eine temporäre Tabelle erzeugt werden muss, indem als Schema der zu erzeugenden Tabelle TEMP anzugeben ist.


-8026: Connect disabled for this user (SAP-Bibliothek - Grundwissen)

-8026: Connect disabled for this user

Erläuterung:

Ein Benutzer versucht sich am Datenbanksystem anzumelden, obwohl ihm das Recht dazu von seinem Datenbankadministrator entzogen wurde.

Benutzerreaktion:

Der Benutzer kann sich erst dann wieder am Datenbanksystem anmelden, wenn der entsprechende Datenbankadministrator das Recht dazu vergibt.


-8028: UNION columns must be compatible (SAP-Bibliothek - Grundwissen)

-8028: UNION columns must be compatible

Erläuterung:

In einem QUERY-Ausdruck, in der mindestens ein UNION, INTERSECT oder EXCEPT angegeben wurde, müssen alle Folgen von selektierten Spalten die gleiche Anzahl von Spalten bezeichnen. Dabei müssen die Datentypen der jeweils korrespondierenden Spalten dieselben Bedingungen erfüllen, die auch für die Vergleichbarkeit gelten.

Jeder Datentyp ist mit sich selbst vergleichbar. Spalten des Datentyps CHAR mit den unterschiedlichen Codeattributen ASCII und UNICODE sind vergleichbar, wobei eine implizite Anpassung erfolgt. Spalten des Codeattributs ASCII sind mit Datumsangaben, Zeitangaben und Zeitstempelangaben vergleichbar.

Alle Zahlen sind untereinander vergleichbar.

Im SQL-Modus ANSI müssen die Datentypen und Längen der angegebenen Spalten nicht nur kompatibel, sondern gleich sein. Dazu gehört auch, dass in den selektierten Spalten der mit UNION verknüpften QUERY-Spezifikationen nur Spaltenspezifikationen oder * angegeben werden dürfen. Die Angabe von Literalen ist nicht zulässig.

Benutzerreaktion:

Durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.COLUMNS, können Sie die Definition der beteiligten Spalten ermitteln. Gegebenenfalls können Sie versuchen, durch Anwendung einer Konversionsfunktion die Vergleichbarkeit zu erreichen.

Im SQL-Modus ANSI müssen Sie auf diese Abfrage verzichten.


-8030: Column must be indexed (SAP-Bibliothek - Grundwissen)

-8030: Column must be indexed

Erläuterung:

Über der angegebenen Spalte wurde kein Index angelegt.

In einer referentiellen CONSTRAINT-Definition müssen die Spalten (referenced_column) entweder den Schlüssel der Tabelle bezeichnen oder Spalten, die zusammen einen mit UNIQUE definierten Index bilden.

Benutzerreaktion:

Sie können sich mit einer QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.INDEXES, anzeigen lassen, welche Indizes existieren. Erzeugen Sie den gewünschten Index, oder verwenden Sie keinen Index.


-8031: Schema must be specified (SAP-Bibliothek - Grundwissen)

-8031: Schema must be specified

Erläuterung:

In einer Datenbankprozedur muss zu jedem Tabellennamen das Schema angegeben werden.

Benutzerreaktion:

Korrigieren Sie die Datenbankprozedur entsprechend.


-8033: Incomplete log segment (SAP-Bibliothek - Grundwissen)

-8033: Incomplete log segment

Erläuterung:

Es wurde versucht, den Log-Bereich zu sichern. Es sind weniger Log-Einträge zu sichern, als durch den allgemeinen Datenbankparameter LOG_SEGMENT_SIZE definiert wurde.

Benutzerreaktion:

Keine Benutzerreaktion erforderlich.


-8034: Order column must be number (SAP-Bibliothek - Grundwissen)

-8034: Order column must be number

Erläuterung:

In einer QUERY-Anweisung, in dessen äußerem QUERY-Ausdruck mindestens ein UNION, INTERSECT oder EXCEPT enthalten ist, darf die ORDER-Klausel keine Spaltenspezifikationen enthalten.

Benutzerreaktion:

Ersetzen Sie die Spaltenspezifikationen durch die entsprechenden Nummern der Ausgabespalten oder die in der ersten QUERY-Spezifikation des äußeren QUERY-Ausdrucks verwendeten Ergebnisspaltennamen (result_column_name).


-8035: Foreign key must exist (SAP-Bibliothek - Grundwissen)

-8035: Foreign key must exist

Erläuterung:

Es wurde eine UPDATE-Anweisung für eine änderbare Join-View-Tabelle durchgeführt. Diese UPDATE-Anweisung führt intern zu einem Einfügen in eine der zugrundeliegenden Basistabellen. Aus den Angaben innerhalb der UPDATE-Anweisung können nicht alle Pflichtspalten, die für die implizite INSERT-Anweisung notwendig sind, gebildet werden.

Benutzerreaktion:

Durch eine INSERT-Anweisung in die zugrundeliegende Basistabelle können Sie die Notwendigkeit des Einfügens während der UPDATE-Anweisung auf die Join-View-Tabelle verhindern.


-8037: DB procedure must be recompiled (SAP-Bibliothek - Grundwissen)

-8037: DB procedure must be recompiled

Erläuterung:

Es wurden SQL-Anweisungen zur Datendefinition ausgeführt, die Tabellen betreffen, die in der Datenbankprozedur verwendet werden. Durch Kompilation der Datenbankprozedur ist zu überprüfen, ob diese noch ausführbar ist.

Benutzerreaktion:

Der Eigentümer der Datenbankprozedur muss diese Überprüfung vornehmen, indem er die Datenbankprozedur erneut speichert.


-8040: Key does not exist (SAP-Bibliothek - Grundwissen)

-8040: Key does not exist

Erläuterung:

Es wurde versucht, für die angegebene Tabelle den Schlüssel zu löschen. Die angegebene Tabelle besitzt keinen benutzerdefinierten Schlüssel. Der implizit angelegte Schlüssel mit der Spalte SYSKEY kann nicht gelöscht werden.

Benutzerreaktion:

Verzichten Sie auf die SQL-Anweisung, da die gewünschte Definition der Tabelle schon besteht.


-8044: Conversion for character set value impossible (SAP-Bibliothek - Grundwissen)

-8044: Conversion for character set value impossible

Erläuterung:

Es wurde versucht, Daten aus einer ASCII- oder UCS-2-Darstellung (siehe Überblick: UNICODE) in eine andere Darstellung zu konvertieren. Das ist gescheitert.

Benutzerreaktion:

Eine explizite Konvertierung können Sie nicht durchführen. Sie können versuchen, durch explizite Konvertierung der z.B. zum Vergleich verwendeten Daten den Fehler zu vermeiden.


-8045: Conversion to UNICODE impossible (SAP-Bibliothek - Grundwissen)

-8045: Conversion to UNICODE impossible

Erläuterung:

Es wurde versucht, Daten aus einer ASCII-Darstellung in eine UCS-2-Darstellung (siehe Überblick: UNICODE) zu konvertieren. Das ist gescheitert.

Benutzerreaktion:

Eine explizite Konvertierung können Sie nicht durchführen. Sie können versuchen, durch explizite Konvertierung der z.B. zum Vergleich verwendeten UCS-2-Daten den Fehler zu vermeiden.


-8046: Conversion from UNICODE impossible (SAP-Bibliothek - Grundwissen)

-8046: Conversion from UNICODE impossible

Erläuterung:

Es wurde versucht, Daten aus einer UNICODE-Darstellung (UCS-2) in eine ASCII-Darstellung zu konvertieren. Das ist aufgrund des Dateninhalts nicht möglich, da dieser nicht nur aus Zeichen, die Bestandteil von Latin1 sind, besteht.

Benutzerreaktion:

Klären Sie, ob die Daten korrekt sind.

Eine explizite Konvertierung können Sie nicht durchführen. Sie können versuchen, durch explizite Konvertierung der z.B. zum Vergleich verwendeten ASCII-Daten den Fehler zu vermeiden.


-8047: Password required (SAP-Bibliothek - Grundwissen)

-8047: Password required

Erläuterung:

Es wurde versucht, durch eine SET-Anweisung eine Rolle zu aktivieren, die die Angabe eines Kennworts erfordert.

Benutzerreaktion:

Wiederholen Sie die SQL-Anweisung, und geben Sie das Kennwort mit an.


-8048: Version of component must be compatible with kernel version

Erläuterung:

Es wurde versucht, eine Komponente zu benutzen, deren Versionsnummer sehr viel kleiner als die des benutzten Datenbankkerns ist. Da sich die Schnittstelle zwischen den Komponenten und dem Datenbankkern erheblich verändert hat, ist das nicht möglich.

Benutzerreaktion:

Verwenden Sie eine Komponente, deren Versionsnummer der des verwendeten Datenbankkerns entspricht.


-8049: Prepare migration required (SAP-Bibliothek - Grundwissen)

-8049: Prepare migration required

Erläuterung:

Das Starten der Strukturlink INPLACE-Migration nach dem Einspielen der Version 7.4 ist nicht möglich, weil in der ursprünglichen Datenbankversion keine Migrationsvorbereitung durchgeführt wurde.

Benutzerreaktion:

...

1. Spielen Sie die ursprüngliche Datenbankversion wieder ein.

2. Bringen Sie die Datenbankinstanz in den Betriebszustand ONLINE.

3. Stoppen Sie die Datenbankinstanz.

4. Führen Sie im Betriebszustand ADMIN folgendes Database Manager CLI-Kommando in einer Utility-Sitzung aus: migrate

Dadurch werden bei der Migration die Daten gelöscht, die in der Version 7.4 nicht mehr unterstützt werden.

5. Spielen Sie die Version 7.4 ein und starten Sie die INPLACE-Migration erneut.


-8050: Migration error (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -8050: Migration error

Erläuterung

Bei der Migration einer Datenbankinstanz mit einem in ASCII gespeicherten Datenbankkatalog (spezieller Datenbankparameter _UNICODE = NO) zu einer UNICODE-Datenbankinstanz (Datenbankparameter _UNICODE = YES) ist ein Fehler aufgetreten. Die Fehlerursache ist in der Datei knldiag bzw. knldiag.err protokolliert.

Benutzerreaktion

In Abhängigkeit von der angegebenen Fehlerursache sind unterschiedliche Maßnahmen zu ergreifen:

● "RESTART REQUIRED BEFORE MIGRATION"
Sie müssen die Datenbankinstanz mit dem aktuellen Stand der Datenbanksoftware mindestens einmal in den Betriebszustand ONLINE gebracht haben, bevor eine Migration gestartet werden kann.

● "UNHANDLED ENTRY TYPE: " + Record-Typ-Nummer
Es wurde im Datenbankkatalog ein Record-Typ gefunden, der in der Migration nicht berücksichtigt wird. In diesem Fall werden sämtliche nicht behandelte Records gesammelt und für jedes ein Eintrag geschrieben. Informieren Sie den Support.

● "ERROR HANDLING TYPE " + Record-Typ-Nummer
Bei der Behandlung eines Datenbankkatalog-Records vom Typ Record-Typ-Nummer ist ein Fehler aufgetreten. Die Migration wird abgebrochen. Das Record, bei dessen Behandlung der Fehler auftrat, wird im Arbeitsverzeichnis unter dem Namen MIGERRORREC.BIN gespeichert . Informieren Sie den Support.

● "ERROR WHEN RECREATING VIEW" + Anfang des Textes der View-Definition
Beim Wiederaufbau einer View-Tabelle ist ein Fehler aufgetreten.
Je nach Fehler ist die entsprechende View-Tabelle ggf. zu löschen und bei Bedarf nach der Migration neu zu erzeugen.

● "MIGRATION FAILED FOR TRIGGER:" bzw. "MIGRATION FAILED FOR DBPROC:"
Es wurden Datenbankprozeduren oder Trigger auf Tabellen definiert, bei denen inzwischen verwendete Tabellen, Spalten oder Benutzer umbenannt wurden. Diese können nicht rekonstruiert werden. Die Namen sämtlicher Datenbankprozeduren und Trigger, die nicht rekonstruiert werden können, werden aufgelistet. Anschließend wird die Migration abgebrochen.
Die Datenbankprozeduren/Trigger waren zum Zeitpunkt der Migration bereits nicht mehr einsatzfähig und müssen gelöscht werden.

● "CONSTRAINTTEXT IS TOO LONG:" + Constraint-Name
Bei der Migration würde die Konversion des Definitionstextes eines Constraint nach UNICODE zur Überschreitung der maximalen Länge von Constraints führen. Das Constraint ist zu löschen bzw. zu modifizieren.

● "CATALOG IS UNICODE ALREADY"
Die Datenbankinstanz scheint bereits eine UNICODE-fähige Datenbankinstanz zu sein.

● "_UNICODE has to be YES for migration"
Die Migration wurde gestartet, obwohl der Datenbankparameter _UNICODE den Wert NO hat.


-8051: No snapshot available (SAP-Bibliothek - Grundwissen)

-8051: No snapshot available

Erläuterung:

Sie haben versucht, den Datenbereich auf einen früheren Zustand (Snapshot) zurückzusetzen, ohne dass vorher ein Snapshot erzeugt wurde.

Benutzerreaktion:

Sie können dieses Kommando nur dann anwenden, wenn bereits ein Snapshot existiert.

Siehe auch:

Konzepte des Datenbanksystems, Abschnitt Datenbereich einfrieren (Snapshot)


-8052: Trigger dropped during migration; check view migrationerrorprotocol

Erläuterung:

Bei der Migration des Datenbankkatalogs nach UNICODE konnten einige Trigger nicht neu angelegt werden. Das Datenbanksystem hat für diese Trigger Ersatz-Trigger angelegt.

Benutzerreaktion:

Überprüfen Sie in der Systemtabelle MIGRATIONERRORPROTOCOL die CREATE-Anweisungen für die Trigger, die nicht neu angelegt werden konnten.

Die CREATE-Anweisung für einen Trigger kann z. B. aus folgenden Gründen falsch sein:

· Eine Tabelle oder View, die der Trigger referenziert, existiert nicht mehr oder wurde umbenannt.

· Die Syntax innerhalb des Triggers hat sich geändert.

Nachdem Sie den Original-Trigger korrigiert haben, können Sie den Ersatz-Trigger löschen.

Siehe auch:

Dokumentation zu den Systemtabellen


-8053: Software version is too old for version of persistent data

Erläuterung:

Bei einem Restart wurde festgestellt, dass die Version der Datenbanksoftware, mit der die Daten erstellt wurden, nicht mit der Version der Datenbanksoftware der aktuellen Datenbankinstanz übereinstimmt.

Ursache für diesen Zustand könnte z.B. sein, dass Sie eine Wiederherstellung mit einer Datensicherung durchgeführt haben, die von einer Datenbankinstanz mit einer aktuelleren Version der Datenbanksoftware stammt.

Der Restart bricht ab.

Benutzerreaktion:

Sorgen Sie dafür, dass die Version der Datenbanksoftware Ihrer Datenbankinstanz mit der Version der Datenbanksoftware, die bei der Erstellung der Daten vorlag, übereinstimmt.


-8888: SERVERDB not accessible (SAP-Bibliothek - Grundwissen)

-8888: SERVERDB not accessible

Erläuterung:

Es wurde versucht, eine Datenbanksitzung zu starten. Das ist aus einem der folgenden Gründe nicht möglich:

...

1. Der Datenbankname wurde fehlerhaft angegeben

2. Die Datenbankinstanz wurde noch nicht gestartet.

Benutzerreaktion:

...

1. Überprüfen Sie den angegebenen Datenbanknamen.

2. Starten Sie die Datenbankinstanz. Achten Sie auf eventuell auftretende Fehler.


-9000: System error: Not yet implemented (SAP-Bibliothek - Grundwissen)

-9000: System error: Not yet implemented

Erläuterung:

Die SQL-Anweisung ist zur Zeit noch nicht implementiert. Sie wird in noch folgenden Versionen zur Verfügung gestellt.

Benutzerreaktion:

Sie können versuchen, durch eine oder mehrere andere SQL-Anweisungen den gewünschten Effekt zu erreichen.


-9001 bis -9799: System error (SAP-Bibliothek - Grundwissen)

-9001 bis -9799: System error

Erläuterung:

Diese Fehlermeldungen dürften im normalen Betrieb mit einer konsistenten Datenbankinstanz nicht auftreten. Bei manchen Fehlern wird ein implizites SHUTDOWN durchgeführt.

Benutzerreaktion:

In der Regel sollten Sie den Betrieb auf der Datenbankinstanz einstellen und den Support benachrichtigen. Erstellen Sie einen Trace der letzten Datenbankaktivitäten, und sichern Sie diesen. Übermitteln Sie den Trace dem Support zur Fehlerverfolgung und -behebung.


Von -10000 bis -10999 (SAP-Bibliothek - Grundwissen)

Von -10000 bis -10999

Fehlermeldungen der Schnittstelle SQLDBC

-10001 | System error: <description>
-10003 | Feature not supported for kernel version <version>
-10100 | Invalid value for option <option> of SQLDBC_ConnectProperties
-10101 | Invalid value for ISOLATIONLEVEL (<description>)
-10102 | Invalid value for PACKETCOUNT (<description>)
-10103 | Invalid value for STATEMENTCACHESIZE (<description>)
-10104 | Invalid value for KEY
-10200 | Function sequence error (data for execution expected)
-10201 | Function sequence error (no data for execution expected)
-10202 | Function sequence error (operation was aborted by disconnect)
-10210 | Invalid command state (no prepared SQL command)
-10220 | Calling addBatch is not allowed for PreparedStatement / Calling clearBatch is not allowed for PreparedStatement
-10221 | Command info too long
-10300 | Invalid parameter index [<number>]
-10301 | Invalid host type (<name>) for parameter (<number>)
-10304 | Parameter/Column (<number>) not bound
-10305 | Parameter <number> contains null pointer
-10306 | Negative buffer length for parameter (<number>) used
-10307 | Invalid length or indicator value for parameter (<number>)
-10308 | Non-character and non-binary data for parameter (<number>) for piecewise insert not allowed
-10310 | Invalid column index (<number>)
-10312 | Attempt to concatenate to a NULL or DEFAULT value for parameter (<number>)
-10313 | Requested parameter (<number>) was already processed
-10314 | Invalid parameter processing sequence, process non-LONG data before parameter (<number>)
-10315 | Invalid start position (<number>)
-10316 | DATA AT EXECUTE for parameter (<number>) not allowed (conflicts with use of LOB parameter)
-10317 | LOB type for parameter (<number>) not allowed (conflicts with use of DATA AT EXECUTE parameter)
-10318 | Invalid LOB object
-10319 | Could not read/write LOB for parameter/column (<number>)
-10320 | LOB already closed for parameter/column (<number>)
-10321 | LOB invalidated by a previous error for parameter/column (<number>)
-10322 | Could not insert LOB. Parameter/column (<number>) has a NULL/DEFAULT value
-10323 | Non-character and non-binary data for parameter/column (<number>) was tried to read piecewise
-10324 | Stream with id (<number>) not found
-10325 | Stream parameter (<number>) is not an input|output parameter
-10326 | No data found for stream (<number>)
-10327 | Invalid use of null pointer in stream parameter field of stream descriptor for parameter (<number>)
-10328 | Mismatch of number of stream members for parameter (<number>) (application <count1>, database <count2>)
-10329 | Invalid serial value requested, must be first or last value
-10330 | Multiple stream output sequence error
-10331 | Input stream callback buffer overflow for table id (<number>) , allowed <count1> bytes, written <count2> bytes
-10332 | No callback function supplied for stream parameter (<number>)
-10400 | Conversion looses significant digits for parameter/column (<number>)
-10401 | Conversion of parameter/column (<number>) would truncate data
-10404 | Conversion not supported for parameter/column (<number>)
-10405 | Cannot convert UCS2 data to ASCII
-10406 | Invalid data length for UCS2 data for parameter/column (<number>)
-10407 | Corrupted UTF8 data for parameter/column (<number>)
-10408 | Character conversion failed
-10410 | Date/Time format is not supported for parameter/column (<number>)
-10411 | Illegal DATE value for parameter/column (<number>)
-10412 | Illegal TIME value for parameter/column (<number>)
-10413 | Illegal TIMESTAMP value for parameter/column (<number>)
-10414 | Conversion from binary value to string is not supported for parameter/column (<number>)
-10500 | Result set is closed
-10501 | Invalid position in result set: before first row
-10502 | Invalid position in result set: after last row
-10503 | The operation is not allowed for result set type FORWARD_ONLY
-10504 | Invalid position (<row_number>) for row set
-10505 | Result set type is UPDATABLE but row set type is READ_ONLY
-10506 | Result set type is READ_ONLY but row set type is UPDATABLE
-10507 | Internal error: No metadata available for row set operation
-10508 | Invalid encoding of column name for column (<number>) for row set operation
-10509 | The statement was not executed with updatable cursor concurrency
-10601 | SQL command is the empty string
-10602 | SQL command contains UNICODE character
-10603 | SQL command would generate a result set
-10604 | SQL command contains output parameters
-10605 | Illegal schema modification, parameters/columns have changed type/number incompatibly
-10706 | Statement too long
-10709 | Connection failed (<description>)
-10715 | Missing user name for connection | Missing password for connection
-10757 | XUSER error (<description>)
-10802 | Invalid numeric value for parameter/column (<number>)
-10803 | Allocation of shared memory failed (<description>)
-10807 | Connection down: [<description>]
-10808 | Feature <feature> not implemented yet in module: <module> line: <line_number>
-10810 | Session already in use
-10811 | Numeric overflow for parameter/column (<number>)
-10821 | Session not connected
-10856 | Invalid row array size 0
-10857 | Missing database name for connection
-10861 | Invalid use of null pointer for stream handle in parameter (<number>)
-10862 | Stream parameter (<number>) error in read|write procedure
-10899 | Unknown error
-10901 | No space left in request packet
-10902 | Invalid request packet structure
-10903 | Internal Error: LONGDATA part expected
-10904 | Internal error: Expected result count
-10905 | Invalid reply packet structure
-10906 | Internal Error: Entry for valindex (<number>) not found
-10907 | Internal Error: Long descriptor has error flag set


-10001: System error: <description> (SAP-Bibliothek - Grundwissen)

-10001: System error: <description>

Erläuterung:

Beim Aufrufen einer Systemfunktion ist ein Fehler aufgetreten, der nicht behandelt werden konnte. <description> enthält nähere Angaben zum Fehler.

Benutzerreaktion:

· Überprüfen Sie, ob Sie die Betriebssystemressourcen ausreichend dimensioniert haben.

· Überprüfen Sie, ob der angemeldete Betriebssystembenutzer über die notwendigen Lese-, Schreib- und Ausführungsrechte verfügt.

Siehe auch:

Glossar, SQLDBC


-10003: Feature not supported for kernel version <version>

Erläuterung:

Die verwendete Version <version> der Datenbanksoftware ist zu alt.

Benutzerreaktion:

Installieren Sie eine neuere Version der Datenbanksoftware.

Siehe auch:

Glossar, SQLDBC


-10100: Invalid value for option <option> of SQLDBC_ConnectProperties

Erläuterung:

Sie haben für die Option <option> der Eigenschaft SQLDBC_ConnectProperties der Methode SQLDBC_Connection::connect einen unerlaubten Wert angegeben.

Benutzerreaktion:

Überprüfen Sie die Werte, die Sie angegeben haben.

Siehe auch:

Glossar, SQLDBC


-10101: Invalid value for ISOLATIONLEVEL (<description>) (SAP-Bibliothek - Grundwissen)

-10101: Invalid value for ISOLATIONLEVEL (<description>)

Erläuterung:

Sie haben für die Option ISOLATIONLEVEL der Eigenschaft SQLDBC_ConnectProperties der Methode SQLDBC_Connection::connect einen unerlaubten Wert angegeben.

<description> enthält weitere Angaben zum Fehler.

Benutzerreaktion:

Überprüfen Sie den Wert, den Sie für die Option ISOLATIONLEVEL angegeben haben.

Siehe auch:

Glossar, SQLDBC


-10102: Invalid value for PACKETCOUNT (<description>) (SAP-Bibliothek - Grundwissen)

-10102: Invalid value for PACKETCOUNT (<description>)

Erläuterung:

Sie haben für die Option PACKETCOUNT der Eigenschaft SQLDBC_ConnectProperties der Methode SQLDBC_Connection::connect einen unerlaubten Wert angegeben.

<description> enthält weitere Angaben zum Fehler.

Benutzerreaktion:

Überprüfen Sie den Wert, den Sie für die Option PACKETCOUNT angegeben haben.

Siehe auch:

Glossar, SQLDBC


-10103: Invalid value for STATEMENTCACHESIZE (<description>)

Erläuterung:

Sie haben für die Option STATEMENTCACHESIZE der Eigenschaft SQLDBC_ConnectProperties der Methode SQLDBC_Connection::connect einen unerlaubten Wert angegeben.

<description> enthält weitere Angaben zum Fehler.

Benutzerreaktion:

Überprüfen Sie den Wert, den Sie für die Option STATEMENTCACHESIZE angegeben haben.

Siehe auch:

Glossar, SQLDBC


-10104: Invalid value for KEY (SAP-Bibliothek - Grundwissen)

-10104: Invalid value for KEY

Erläuterung:

Sie haben für die Option KEY der Eigenschaft SQLDBC_ConnectProperties der Methode SQLDBC_Connection::connect einen unerlaubten Wert angegeben.

Benutzerreaktion:

· Überprüfen Sie mit dem Kommando XUSER list, ob der angegebene XUSER-Eintrag für die Datenbankinstanz vorhanden ist und ob er zulässig ist.

· Wenn Sie KEY=SQLOPT angegeben haben, dann überprüfen Sie, ob in der Umgebungsvariablen SQLOPT die Option -U <user_key> gesetzt wurde.

Siehe auch:

Glossar, SQLDBC


-10200: Function sequence error (data for execution expected) (SAP-Bibliothek - Grundwissen)

-10200: Function sequence error (data for execution expected)

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil der vorhergehende Aufruf der Methode SQLDBC_PreparedStatement::execute oder SQLDBC_PreparedStatement::nextParameter Daten zum stückweisen Einfügen mit SQLDBC_PreparedStatement::putData erwartet.

Benutzerreaktion:

Schließen Sie die vorhergehende Aktion mit SQLDBC_PreparedStatement::putData oder SQLDBC_PreparedStatement::nextParameter ab.


-10201: Function sequence error (no data for execution expected)

Erläuterung:

Die aufgerufene Methode SQLDBC_PreparedStatement::putData oder SQLDBC_PreparedStatement::nextParameter konnte nicht ausgeführt werden, weil keine Daten zum stückweisen Einfügen angefordert wurden.

Benutzerreaktion:

Um Daten stückweise einzufügen, verwenden Sie die Methode SQLDBC_PreparedStatement::bindParameter und wählen Sie für das Argument LengthIndicator den Wert SQLDBC_DATA_AT_EXEC.


-10202: Function sequence error (operation was aborted by disconnect)

Erläuterung:

Die aufgerufene Methode SQLDBC_PreparedStatement::putData konnte nicht ausgeführt werden, weil die Verbindung zur Datenbankinstanz beendet wurde.

Benutzerreaktion:

Melden Sie sich erneut an der Datenbankinstanz an.


-10210: Invalid command state (no prepared SQL command) (SAP-Bibliothek - Grundwissen)

-10210: Invalid command state (no prepared SQL command)

Erläuterung:

Die aufgerufene Methode SQLDBC_PreparedStatement::execute konnte nicht ausgeführt werden, weil die Anweisung nicht mit der Methode SQLDBC_PreparedStatement::prepare vorbereitet wurde.

Benutzerreaktion:

Verwenden Sie die Methode SQLDBC_PreparedStatement::prepare, um SQL-Anweisungen vorzubereiten (Parsen).


-10220: Calling addBatch is not allowed for PreparedStatement / Calling clearBatch is not allowed for PreparedStatement

Erläuterung:

Die aufgerufene Methode SQLDBC_PreparedStatement::addBatch oder SQLDBC_PreparedStatement::clearBatch kann nicht auf Objekte des Types SQLDBC_PreparedStatement angewendet werden.

Benutzerreaktion:

Verwenden Sie die Methoden addBatch und clearBatch nur für Objekte des Typs SQLDBC_Statement.


-10221: Command info too long (SAP-Bibliothek - Grundwissen)

-10221: Command info too long

Erläuterung:

Der Aufruf der Methode SQLDBC_PreparedStatement::setCommandInfo ist gescheitert, weil eine zu lange Zeichenkette übergeben wurde. Die maximal erlaubte Länge ist 40 Zeichen.

Benutzerreaktion:

Überprüfen Sie die Länge der Zeichenkette, die als erster Parameter an die Methode SQLDBC_PreparedStatement::setCommandInfo() übergeben wurde.


-10300: Invalid parameter index [<number>] (SAP-Bibliothek - Grundwissen)

-10300: Invalid parameter index [<number>]

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil ein ungültiger Wert <number> für die Parameternummer angegeben wurde.

Benutzerreaktion:

Wählen Sie einen zulässigen Wert für die Parameternummer im Argument Index der Methode SQLDBC_PreparedStament::bindParameter bzw. SQLDBC_ResultSet::bindColumn.


-10301: Invalid host type (<name>) for parameter (<number>)

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil der in der Methode SQLDBC_PreparedStatement::bindParameter angegebene Datentyp <name> ungültig ist.

Benutzerreaktion:

· Verwenden Sie nur Werte für den Datentyp (SQLDBC_Hosttype), die in der Datei SQLDBC_Types.h spezifiziert wurden.

· Überprüfen Sie, ob Ihre Version der SQLDBC-Schnittstelle den angegebenen Datentyp unterstützt.


-10304: Parameter/Column (<number>) not bound (SAP-Bibliothek - Grundwissen)

-10304: Parameter/Column (<number>) not bound

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil für den Parameter oder die Spalte mit der angegebenen Nummer <number> keine Programmvariable gebunden war.

Benutzerreaktion:

Binden Sie mit der Methode SQLDBC_PreparedStatement::bindParameter bzw. SQLDBC_ResultSet::bindColumn eine Programmvariable.


-10305: Parameter <number> contains null pointer (SAP-Bibliothek - Grundwissen)

-10305: Parameter <number> contains null pointer

Erläuterung:

Die aufgerufene Methode konnte keine Parameter oder Spalten aus der Datenbank lesen oder schreiben, weil die an den Parameter <number> gebundene Programmvariable und der dazugehörige Indikatorparameter ein NULL-Zeiger ist.

Benutzerreaktion:

Binden Sie mit der Methode SQLDBC_PreparedStatement::bindParameter bzw. SQLDBC_ResultSet::bindColumn eine Programmvariable. Geben Sie eine gültige Programvariablenadresse an oder setzen Sie den Indikatorparameter.


-10306: Negative buffer length for parameter (<number>) used

Erläuterung:

Die aufgerufene Methode konnte keine Parameter an die Datenbankinstanz übertragen, weil die Längenangabe (LengthIndicator) der Programmvariablen, die an den Parameter <number> gebunden wurde, einen negativen Wert enthält.

Benutzerreaktion:

Geben Sie für die Längenangabe (LengthIndicator) einen positiven Wert ein, der der Länge des Werts der Programmvariablen entspricht.


-10307: Invalid length or indicator value for parameter (<number>)

Erläuterung:

Sie haben für den Parameter <number> einen Wert angegeben, der entweder eine ungültige Länge hat oder ein ungültiger Indikatorwert ist.

Benutzerreaktion:

Überprüfen Sie den angegebenen Wert. Der Wert muss >= 0, SQLDBC_NULL_DATA oder SQLDBC_DEFAULT_PARAM sein.


-10308: Non-character and non-binary data for parameter (<number>) for piecewise insert not allowed

Erläuterung:

Numerische Datentypen können nicht stückweise verarbeitet werden. Der gebundene Parameter <number> hat nicht den Datentyp character oder binary und kann deshalb nicht stückweise verarbeitet werden.

Benutzerreaktion:

Geben Sie für den Parameter, der stückweise verarbeitet werden soll, als Datentyp (SQLDBC_HostType) character oder binary an. Definieren Sie hierfür eine Programmvariable.


-10310: Invalid column index (<number>) (SAP-Bibliothek - Grundwissen)

-10310: Invalid column index (<number>)

Erläuterung:

Sie haben einen ungültigen Index für die Datenbankspalte angegeben.

Benutzerreaktion:

Geben Sie einen gültigen Wert für den Index der Datenbankspalte an. Sie können nur Spalten auswählen, die in der Ergebnismenge enthalten sind.


-10312: Attempt to concatenate to a NULL or DEFAULT value for parameter (<number>)

Erläuterung:

Beim stückweisen Schreiben von Daten wurde versucht, dem Parameter <number>, dem schon der NULL-Wert oder der DEFAULT-Wert zugewiesen wurde, weitere Daten zuzuweisen.

Benutzerreaktion:

Weisen Sie einem Parameter, dem Sie den NULL- oder DEFAULT-Wert zugewiesen haben, keine weiteren Daten zu.


-10313: Requested parameter (<number>) was already processed

Erläuterung:

Einem schon verarbeiteten Parameter können keine weitere Werte zugewiesen werden. Nach dem Aufruf von SQLDBC_PreparedStatment::nextParameter können dem vorherigen Parameter keine Werte mehr zugewiesen werden.

Beim stückweisen Schreiben von Daten wurde versucht, dem Parameter <number>, der schon verarbeitet wurde, weitere Daten zuzuweisen.

Benutzerreaktion:

Weisen Sie einem bereits verarbeiteten Parameter keine weiteren Werte zu.


-10314: Invalid parameter processing sequence, process non-LONG data before parameter (<number>)

Erläuterung:

Der an die Methode SQLDBC_PreparedStatement::nextParameter übergebene Parameterindex kann nicht als nächster Parameter verarbeitet werden.

Benutzerreaktion:

· Ändern Sie die Reihenfolge der Abarbeitung der Parameter.

· Verarbeiten Sie die Parameter, die LONG-Spalten beschreiben, nach den Parametern für andere Spalten.


-10315: Invalid start position (<number>) (SAP-Bibliothek - Grundwissen)

-10315: Invalid start position (<number>)

Erläuterung:

Beim positionierten Lesen von Daten aus einem LONG-Wert wurde eine ungültige Position übergeben.

Benutzerreaktion:

Überprüfen Sie die angegebene Position.


-10316: DATA AT EXECUTE for parameter (<number>) not allowed (conflicts with use of LOB parameter)

Erläuterung:

Es wurde mit DATA AT EXECUTE ein Parameter gebunden, wobei ein anderer Parameter an eine SQLDBC_LOB-Struktur gebunden ist.

Benutzerreaktion:

Verwenden Sie DATA AT EXECUTE und SQLDBC_LOB-Parameter nicht gleichzeitig.


-10317: LOB type for parameter (<number>) not allowed (conflicts with use of DATA AT EXECUTE parameter)

Erläuterung:

Es wurde ein Parameter an eine SQLDBC_LOB-Struktur gebunden, wobei ein anderer Parameter mit der Option DATA AT EXECUTE gebunden ist.

Benutzerreaktion:

Verwenden Sie DATA AT EXECUTE und SQLDBC_LOB-Parameter nicht gleichzeitig.


-10318: Invalid LOB object (SAP-Bibliothek - Grundwissen)

-10318: Invalid LOB object

Erläuterung:

Einer der folgenden Fälle ist eingetreten:

· für den Aufruf der LOB-Methode wurde eine ungültige Klassenreferenz verwendet

· das zur LOB-Methode gehörende SQLDBC_PreparedStatement existiert nicht mehr

· das zur LOB-Methode gehörende SQLDBC_PreparedStatement hat keine LOB-Objekte

Benutzerreaktion:

Verwenden Sie die LOB-Objekt-Methode nur solange, wie das dazugehörige SQLDBC_PreparedStatment gültig ist.


-10319: Could not read/write LOB for parameter/column (<number>)

Erläuterung:

Einer der beiden folgenden Fehler ist für den Parameter/für die Spalte <number> aufgetreten:

· Mit der Methode SQLDBC_LOB::getVal wurde versucht, ein LOB-Objekt zu lesen, obwohl dieses nur für den schreibenden Zugriff (Input-Parameter) geöffnet war.

· Mit der Methode SQLDBC_LOB::putVal wurde versucht, ein LOB-Objekt zu schreiben, obwohl dieses nur für den lesenden Zugriff (Output-Parameter) geöffnet war.

Benutzerreaktion:

Verwenden Sie die Methode SQLDBC_LOB::getVal nur für Output-Parameter und die Methode SQLDBC_LOB::putVal nur für Input-Parameter.


-10320: LOB already closed for parameter/column (<number>)

Erläuterung:

Die aufgerufene Methode SQLDBC_LOB::putData oder SQLDBC_LOB::getData konnte nicht ausgeführt werden, weil das zum Parameter/zur Spalte <number> gehörende LOB-Objekt bereits mit der SQLDBC_LOB::close Methode geschlossen wurde.

hode geschlossen wurde.

Benutzerreaktion:

Um das LOB-Objekt zu öffnen, führen Sie die Methode SQLDBC_PreparedStatement::execute erneut aus.


-10321: LOB invalidated by a previous error for parameter/column (<number>)

Erläuterung:

Die aufgerufene Methode SQLDBC_LOB konnte nicht ausgeführt werden, weil der vorherige Aufruf der Methode gescheitert ist und dadurch das LOB-Objekt für den Parameter/die Spalte <number> ungültig geworden ist.

Benutzerreaktion:

Überprüfen Sie den vorherigen Aufruf der Methode.


-10322: Could not insert LOB. Parameter/column (<number>) has a NULL/DEFAULT value

Erläuterung:

Die aufgerufene Methode SQLDBC_LOB::putData oder SQLDBC_LOB::getData konnte nicht ausgeführt werden, weil das zum Parameter/zur Spalte <number> gehörende LOB-Objekt den NULL-Wert oder den DEFAULT- Wert enthält.

Benutzerreaktion:

Sie können ein LOB-Objekt, das den NULL-Wert oder den DEFAULT-Wert enthält, nicht in diesen Methoden verwenden.


-10323: Non-character and non-binary data for parameter/column (<number>) was tried to read piecewise

Erläuterung:

Es wurde versucht, einen Parameter oder eine Spalte, die nicht an einen Zeichen- oder Binärtyp gebunden ist, stückweise auszulesen.

Benutzerreaktion:

Verwenden Sie stückweises Lesen nur für Zeichen- oder Binärtypen.


-10324: Stream with id (<number>) not found (SAP-Bibliothek - Grundwissen)

-10324: Stream with id (<number>) not found

Erläuterung:

Die Datenbankprozedur referenziert einen liveCache-Stream, den die Anwendung nicht kennt.

Benutzerreaktion:

Überprüfen Sie die Datenbankprozedur.


-10325: Stream parameter (<number>) is not an input|output parameter

Erläuterung:

Die Datenbankprozedur referenziert einen liveCache-Stream als Eingabe, während die Anwendung den Stream als Ausgabe behandelt, oder umgekehrt.

Benutzerreaktion:

Überprüfen Sie die Datenbankprozedur und/oder die Anwendung.


-10326: No data found for stream (<number>) (SAP-Bibliothek - Grundwissen)

-10326: No data found for stream (<number>)

Erläuterung:

Es wurden keine Daten für einen liveCache-Stream (Ausgabe) übermittelt.

Benutzerreaktion:

Überprüfen Sie die Datenbankprozedur.


-10327: Invalid use of null pointer in stream parameter field of stream descriptor for parameter (<number>)

Erläuterung:

Die Beschreibung der liveCache-Stream-Parameter enthält einen Nullpointer.

Benutzerreaktion:

Überprüfen Sie den gebundenen Parameter.


-10328: Mismatch of number of stream members for parameter (<number>) (application <count1>, database <count2>)

Erläuterung:

Die Beschreibung der Struktur eines liveCache-Streams hat in der Datenbank eine andere Anzahl Elemente als im Anwendungsprogramm.

Benutzerreaktion:

Überprüfen Sie die Datenbankprozedur und das Anwendungsprogramm, ob eine inkonsistente Installation oder ein Versionskonflikt vorliegt.


-10329: Invalid serial value requested, must be first or last value

Erläuterung:

SQLDBC_Statement::getLastInsertedKey wurde falsch parametrisiert.

Benutzerreaktion:

Überprüfen Sie den Aufruf im Anwendungsprogramm.


-10330: Multiple stream output sequence error (SAP-Bibliothek - Grundwissen)

-10330: Multiple stream output sequence error

Erläuterung:

Es wurde ein interner Protokollfehler beim Abarbeiten von liveCache-Streams (Ausgabe) festgestellt.

Benutzerreaktion:

Benachrichtigen Sie den Support.


-10331: Input stream callback buffer overflow for table id (<number>) , allowed <count1> bytes, written <count2> bytes

Erläuterung:

Nach dem Aufruf der Callback-Prozedur zur Verarbeitung von liveCache-Streams (Eingabe) wurde ein Überschreiben des Speichers (Buffer Overflow) festgestellt.

Benutzerreaktion:

Überprüfen Sie die Callback-Prozedur.


-10332: No callback function supplied for stream parameter (<number>)

Erläuterung:

Es wurde keine Callback-Prozedur für einen liveCache-Stream gebunden.

Benutzerreaktion:

Überprüfen Sie die gebundenen Parameter.


-10400: Conversion looses significant digits for parameter/column (<number>)

Erläuterung:

Der numerische (floatingpoint oder fixed) Wert des Parameters/der Spalte <number> konnte nicht gelesen oder eingefügt werden, weil die Länge des Parameters oder der Spalte zu klein ist.

Benutzerreaktion:

Führen Sie eine der folgenden Aktionen durch:

· vergrössern Sie die Länge der Host-Variablen, die mit der Methode SQLDBC_PreparedStatement::bindParameter an den Parameter oder mit der Methode SQLDBC_ResultSet::bindColumn an die Spalte gebunden ist

· wählen Sie einen anderen Datentyp für die Host-Variable

· passen Sie Ihre SQL-Anweisung an

· passen Sie Ihre Tabellendefinition an


-10401: Conversion of parameter/column (<number>) would truncate data

Erläuterung:

Die Daten (character oder binary) des Parameters/der Spalte <number> konnten nicht gelesen oder eingefügt werden, weil die Länge des Parameters oder der Spalte zu klein ist.

Benutzerreaktion:

Führen Sie eine der folgenden Aktionen aus:

· Vergrössern Sie die Länge der Host-Variablen, die mit der Methode SQLDBC_PreparedStatement::bindParameter an den Parameter oder mit der Methode SQLDBC_ResultSet::bindColumn an die Spalte gebunden ist.

· Ändern Sie die SQL-Anweisung.

· Ändern Sie die Tabellendefinition.


-10404: Conversion not supported for parameter/column (<number>)

Erläuterung:

Der Wert des Parameters/der Spalte <number> konnte nicht gelesen oder eingefügt werden, weil es keine Konvertierungsmöglichkeit in das gewünschte Datentypformat gibt.

Benutzerreaktion:

Überprüfen Sie, ob die ausgewählte Konvertierung für die installierte Version der SQLDBC-Schnittstelle erlaubt ist.

Falls die Konvertierung erlaubt ist, ändern Sie den Datentyp der Host-Variablen oder des Parameters/der Spalte in einen in der Konvertierungsmatrix enthaltenen Datentyp.


-10405: Cannot convert UCS2 data to ASCII (SAP-Bibliothek - Grundwissen)

-10405: Cannot convert UCS2 data to ASCII

Erläuterung:

Der UNICODE-Wert (UCS2) des Parameters/der Spalte konnte nicht gelesen oder eingefügt werden, weil der Wert Zeichen enthält, die nicht in ASCII darstellbar sind.

Benutzerreaktion:

Geben Sie nur solche UNICODE-Werte (UCS2) an, die im ASCII-7-Bit-Zeichensatz enthalten sind.


-10406: Invalid data length for UCS2 data for parameter/column (<number>)

Erläuterung:

Der UNICODE-Wert (UCS2) des Parameters/der Spalte <number> konnte nicht gelesen oder eingefügt werden, weil die Anzahl der Zeichen ungerade ist. UNICODE-Werte (UCS2) können nur dann in ASCII konvertiert werden, wenn die Anzahl der Zeichen, die konvertiert werden sollen, geradzahlig ist.

Benutzerreaktion:

· Überprufen Sie die Längenangabe des Arguments LengthIndicator der Methode SQLDBC_PreparedStatement::bindParameter.

· Stellen Sie sicher, dass nicht das abschliessende 0-Byte der Zeichenkette mitgezählt wird.


-10407: Corrupted UTF8 data for parameter/column (<number>)

Erläuterung:

Der UNICODE-Wert (UTF8) des Parameters/der Spalte konnte nicht gelesen oder eingefügt werden, weil der Wert Zeichen enthält, die nicht in ASCII darstellbar sind.

Benutzerreaktion:

Geben Sie nur solche UNICODE-Werte (UTF8) an, die im ASCII-7-Bit-Zeichensatz enthalten sind.


-10408: Character conversion failed (SAP-Bibliothek - Grundwissen)

-10408: Character conversion failed

Erläuterung:

Die übergebenen LOB-Daten konnten nicht konvertiert werden, weil die Daten ungültige Zeichen enthalten oder nicht zum Datenformat der Spalte passen. UNICODE-Daten (UCS2 und UTF8) können nur in UNICODE-Datenbankeninstanzen eingefügt werden.

Benutzerreaktion:

· Überprüfen Sie, ob die Datenbankinstanz das angegebene Datenformat unterstützt.

· Überprüfen Sie, ob der spezielle Datenbankparameter _UNICODE den Wert YES hat.


-10410: Date/time format is not supported for parameter/column (<number>)

Erläuterung:

Die SQLDBC-Schnittstelle unterstützt das für den Parameter/dieSpalte <number> konfigurierte Datums- oder Zeitformat nicht.

Benutzerreaktion:

Verwenden Sie eines der zulässigen Datums- oder Zeitformate für den Datentyp des Parameters oder der Host-Variablen.

Siehe auch:

Referenzhandbuch, datetimeformat


-10411: Illegal DATE value for parameter/column (<number>)

Erläuterung:

Der Wert des Parameters/der Spalte <number> konnte nicht gelesen oder eingefügt werden, weil es sich um einen ungültigen Datumswert handelt.

Benutzerreaktion:

Geben Sie einen gültigen Datumswert an.

Siehe auch:

Referenzhandbuch, datetimeformat


-10412: Illegal TIME value for parameter/column (<number>)

Erläuterung:

Der Wert des Parameters/der Spalte <number> konnte nicht gelesen oder eingefügt werden, weil es sich um einen ungültigen Zeitwert handelt.

Benutzerreaktion:

Geben Sie einen gültigen Zeitwert an.

Siehe auch:

Referenzhandbuch, datetimeformat


-10413: Illegal TIMESTAMP value for parameter/column (<number>)

Erläuterung:

Der Wert des Parameters/der Spalte <number> konnte nicht gelesen oder eingefügt werden, weil es sich um einen ungültigen Zeitstempelwert handelt.

Benutzerreaktion:

Geben Sie einen gültigen Zeitstempelwert an.

Siehe auch:

Referenzhandbuch, TIMESTAMP (Zeitstempelwert)


-10414: Conversion from binary value to string is not supported for parameter/column (<number>)

Erläuterung:

Es wurde ein CHAR BYTE-Parameteran eine ASCII/UNICODE-Variable gebunden, oder ein CHAR ASCII/CHAR UNICODE-Parameter wurde an eine Binärvariable gebunden.

Benutzerreaktion:

Überprüfen Sie die gebundenen Parameter.


-10500: Result set is closed (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10500: Result set is closed

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil es keine Ergebnismenge gibt oder weil die Ergebnismenge mit der Methode SQLDBC_ResultSet::close geschlossen wurde.

Benutzerreaktion:

Rufen Sie die folgenden Methoden nur dann auf, wenn es eine Ergebnismenge gibt:

absolute
bindColumn
clearColumns
close
first
GetResultSetMetaData
getRowSet
getUpdatableRowSet
last
next
relative
setFetchSize
setRowSetSize


-10501: Invalid position in result set: before first row (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10501: Invalid position in result set: before first row

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil die aktuelle Cursor-Position der Ergebnismenge vor der ersten Zeile der Ergebnissmenge liegt.

Benutzerreaktion:

Positionieren Sie den Cursor mit einer der folgenden SQLDBC_ResultSet-Methoden (first, last, next, relative, absolute) oder der SQLDBC_RowSet::setPos-Methode innerhalb der Ergebnismenge.


-10502: Invalid position in result set: after last row (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10502: Invalid position in result set: after last row

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil die aktuelle Cursor-Position der Ergebnismenge hinter der letzten Zeile der Ergebnismenge liegt.

Benutzerreaktion:

Positionieren Sie den Cursor mit einer der folgenden SQLDBC_ResultSet-Methoden (first, last, next, relative, absolute) oder mit der SQLDBC_RowSet::setPos-Methode innerhalb der Ergebnismenge.


-10503: The operation is not allowed for result set type FORWARD_ONLY

Hintergrunddokumentation -10503: The operation is not allowed for result set type FORWARD_ONLY

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil die Ergebnistabelle vom Typ FORWARD_ONLY ist. Positionsangaben für Ergebnistabellen sind nur für Ergebnistabellen vom Typ SCROLL_SENSITIVE und SCROLL_INSENSITIVE zugelassen.

Benutzerreaktion:

Ändern Sie den Typ der Ergebnistabelle mit der Methode SQLDBC_PreparedStatement::setResultSetType auf SCROLL_SENSITIVE oder SCROLL_INSENSITIVE.


-10504: Invalid position (<row_number>) for row set (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10504: Invalid position (<row_number>) for row set

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil die angegebene Position <row_number> außerhalb von SQLDBC_RowsSet liegt.

Benutzerreaktion:

Geben Sie in der Methode SQLDBC_RowSet::setPos nur Werte an, die folgende Bedingungen erfüllen:

· > 0

· < RowSetSize der Ergebnismenge


-10505: Result set type is UPDATABLE but row set type is READ_ONLY

Hintergrunddokumentation -10505: Result set type is UPDATABLE but row set type is READ_ONLY

Erläuterung:

Es konnte kein RowSet erzeugt werden, weil die die dazugehörige SQL-Anweisung oder der Typ der Ergebnismenge keine Updates (Änderungen) erlaubt.

Benutzerreaktion:

Änderbare Ergebnismengen können nur von speziellen SELECT-Anweisungen erzeugt werden.

Sie haben folgende Möglichkeiten:

· Ändern Sie die SQL-Anweisung.

· Setzen Sie den Typ der Ergebnismenge mit der Methode SQLDBC_Statement::ConcurrencyType SQLDBC_PreparedStatement::ConcurrencyType auf CONCUR_UPDATABLE.


-10506: Result set type is READ_ONLY but row set type is UPDATABLE

Hintergrunddokumentation -10506: Result set type is READ_ONLY but row set type is UPDATABLE

Erläuterung:

Es konnte kein RowSet erzeugt werden, weil die die dazugehörige SQL-Anweisung Updates (Änderungen) erlaubt, der Typ der Ergebnismenge jedoch nicht.

Benutzerreaktion:

Nicht änderbare Ergebnismengen können nur von speziellen SELECT-Anweisungen erzeugt werden.

Sie haben folgende Möglichkeiten:

· Ändern Sie die SQL-Anweisung

· Setzen Sie den Typ der Ergebnismenge mit der Methode SQLDBC_Statement::ConcurrencyType SQLDBC_PreparedStatement::ConcurrencyType auf CONCUR_READONLY. Hiermit wird eine Ergebnismenge erzeugt, die nur gelesen werden kann (read-only).


-10507: Internal error: No metadata available for row set operation

Hintergrunddokumentation -10507: Internal error: No metadata available for row set operation

Erläuterung:

Es ist ein interner Fehler aufgetreten. Dieser Fehler hat zur Folge, dass keine Informationen über die Struktur der Ergebnismenge vorliegen, die für UPDATE-Operationen geöffnet werden sollte.

Benutzerreaktion:

Vereinfachen Sie Ihre SQL-Anweisung.


-10508: Invalid encoding of column name for column (<number>) for row set operation

Hintergrunddokumentation -10508: Invalid encoding of column name for column (<number>) for row set operation

Erläuterung:

Die aufgerufene Methode konnte nicht ausgeführt werden, weil der Spaltenname UNICODE-Zeichen enthält, für die SQL-Anweisung aber der Zeichensatz ASCII 7 Bit definiert wurde.

Benutzerreaktion:

Setzen Sie den Zeichensatz (Encoding) für die SQL-Anweisung in der Methode SQLDBC_Statement::execute oder SQLDBC_PreparedStatement::prepare auf SQLDBC_StringEncodingType_Encoding_UCS2 oder SQLDBC_StringEncodingType_Encoding_UTF8 und führen Sie die Methode erneut aus.


-10509: The statement was not executed with updatable cursor concurrency

Hintergrunddokumentation -10509: The statement was not executed with updatable cursor concurrency

Erläuterung:

Die aufgerufene Methode (insertOneRow, updateRow oder deleteRow) aus SQLDBC_UpdatableRowSet konnte nicht ausgeführt werden, weil die Ergebnismenge nicht änderbar war.

Benutzerreaktion:

Änderbare Ergebnismengen können nur von speziellen SELECT-Anweisungen erzeugt werden.

Sie haben folgende Möglichkeiten:

· Ändern Sie die SQL-Anweisung.

· Setzen Sie den Typ der Ergebnismenge mit der Methode SQLDBC_Statement::ConcurrencyType SQLDBC_PreparedStatement::ConcurrencyType auf CONCUR_UPDATABLE.


-10601: SQL command is the empty string (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10601: SQL command is the empty string

Erläuterung:

Die aufgerufene Methode SQLDBC_Statement::execute oder SQLDBC_PreparedStatement::prepare konnte nicht ausgeführt werden, weil keine SQL-Anweisung angegeben wurde oder weil die Längenangabe 0 war.

Benutzerreaktion:

Sie haben folgenden Möglichkeiten:

· Übergeben Sie die SQL-Anweisung als Zeichenkette im Parameter sql der Methode SQLDBC_Statement::execute oder SQLDBC_PreparedStatement::prepare.

· Setzen Sie die die korrekte Länge im Parameter sqlLength.

· Wenn Sie UNICODE-Daten verwenden, dann konfigurieren Sie den korrekten Zeichensatz (Encoding) für die SQL-Anweisung.


-10602: SQL command contains UNICODE character (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10602: SQL command contains UNICODE character

Erläuterung:

Die aufgerufene Methode SQLDBC_Statement::execute oder SQLDBC_PreparedStatement::prepare konnte nicht ausgeführt werden, weil die SQL-Anweisung UNICODE-Zeichen enthält, die Datenbankinstanz aber nicht für UNICODE-Zeichen konfiguriert wurde.

Benutzerreaktion:

Verwenden Sie für ASCII-Datenbankinstanzen nur SQL-Anweisungen mit dem Zeichensatz (Encoding) ASCII 7 Bit.


-10603: SQL command would generate a result set (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10603: SQL command would generate a result set

Erläuterung:

Die aufgerufene Methode SQLDBC_Statement::addBatch oder SQLDBC_Statement::executeBatch konnte nicht ausgeführt werden, weil die übergebenen SQL-Anweisungen eine Ergebnismenge erzeugen würden.

Benutzerreaktion:

Verwenden Sie für diese Methoden keine SQL-Anweisungen (SELECT oder Datenbankprozedur), für die eine Ergebnismenge erzeugt wird.


-10604: SQL command contains output parameters (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10604: SQL command contains output parameters

Erläuterung:

Die übergebene SQL-Anweisung konnte nicht ausgeführt werden, weil sie Ausgabeparameter enthält.

Benutzerreaktion:

Mit den Methoden der SQLDBC_Statement-Klassen können keine Ausgabeparameter verarbeitet werden

Verwenden Sie für SQL-Anweisungen mit Ausgabeparametern (SELECT INTO oder Datenbankprozedur) SQLDBC_PreparedStatement-Objekte.


-10605: Illegal schema modification, parameters/columns have changed type/number incompatibly

Hintergrunddokumentation -10605: Illegal schema modification, parameters/columns have changed type/number incompatibly

Erläuterung:

Die Methode konnte nicht ausgeführt werden, weil sich nach dem Parsen der SQL-Anweisung die Tabllendefinition inkompatibel geändert hat. Vermutlich wurde die Tabellendefinition nach dem Parsen der SQL-Anweisung durch eine andere Anwendung mit einer DDL-Anweisung geändert.

Benutzerreaktion:

Parsen Sie die SQL-Anweisung erneut. Binden Sie gegebenenfalls die Parameter neu.


-10706: Statement too long (SAP-Bibliothek - Grundwissen)

-10706: Statement too long

Erläuterung:

Die SQL-Anweisung, die Sie angegeben haben, ist zu lang.

Benutzerreaktion:

· Verkürzen Sie die SQL-Anweisung.

· Überprüfen Sie den Wert des Datenbankparameters _PACKET_SIZE und vergrößern Sie ihn gegebenenfalls.

Siehe auch:

Glossar, SQLDBC


-10709: Connection failed (<description>) (SAP-Bibliothek - Grundwissen)

-10709: Connection failed (<description>)

Erläuterung:

Es konnte keine Verbindung zur Datenbankinstanz aufgebaut werden.

<description> enthält die interne Fehlermeldung.

Benutzerreaktion:

· Überprüfen Sie, ob Sie die richtigen Verbindungsdaten angegeben haben (Name der Datenbankinstanz, Name des Computers).

· Überprüfen Sie, ob die Datenbankinstanz im Betriebszustand ONLINE ist.

· Wenn Sie eine Verbindung zu einer Datenbankinstanz auf einem anderen Computer aufbauen möchten, dann überprüfen Sie, ob der X-Server auf dem anderen Computer läuft.

Siehe auch:

Glossar, SQLDBC


-10715: Missing user name for connection | Missing password for connection

Erläuterung:

Es wurde versucht, mit der Methode SQLDBC_Connection::connect eine Verbindung zur Datenbankinstanz aufzubauen.

Eines der beiden folgenden Probleme ist aufgetreten:

· Sie haben keinen Datenbankbenutzer angegeben.

· Sie haben kein Kennwort für den Datenbankbenutzer angegeben.

Benutzerreaktion:

Geben Sie den Datenbankbenutzer bzw. dessen Kennwort in den Eigenschaften der Methode SQLDBC_Connection::connect an.

· Wenn Sie die Verbindung über die Eigenschaft KEY herstellen möchten, dann überprüfen Sie mit dem Kommando XUSER list, ob ein XUSER-Eintrag für den Datenbankbenutzer vorhanden bzw. das Kennwort des Datenbankbenutzers im XUSER-Eintrag enthalten ist.

· Wenn Sie die Verbindung über die Eigenschaft KEY=SQLOPT herstellen möchten, dann überprüfen Sie, ob in der Umgebungsvariablen SQLOPT die Option -u <database_user>,<database_user_password> gesetzt wurde.

Siehe auch:

Glossar, SQLDBC


-10757: XUSER error (<description>) (SAP-Bibliothek - Grundwissen)

-10757: XUSER error (<description>)

Erläuterung:

Sie haben die Eigenschaft KEY für die Methode CONNECT angegeben. Beim Ermitteln des zugehörigen XUSER-Eintrags ist ein Fehler aufgetreten.

Benutzerreaktion:

Überprüfen Sie mit dem Kommando XUSER list, ob der XUSER-Eintrag existiert, den Sie für die Eigenschaft KEY angegeben haben. Wenn der XUSER-Eintrag nicht existiert, dann legen Sie ihn mit dem Kommando XUSER set an (siehe Strukturlink Anlegen oder Ändern von XUSER-Einträgen).

Siehe auch:

Glossar, SQLDBC


-10802: Invalid numeric value for parameter/column (<number>)

Erläuterung:

Der numerische Wert des Parameters/der Spalte konnte nicht gelesen oder eingefügt werden, weil es sich um einen ungültigen numerischen Wert handelt.

Benutzerreaktion:

Überprüfen Sie, ob der Wert des Parameters/der Spalte einen gültigen Wert beinhaltet.

Für floatingpoint-Werte gelten folgende Regeln:

· Die Werte müssen der IEEE-Spezifikation entsprechen.

· Die Werte dürfen keine NaN-Werte (NaN=Not a Number) sein.


-10803: Allocation of shared memory failed (<description>)

Erläuterung:

Das Datenbanksystem konnte keinen Speicherbereich (Shared Memory) anlegen, oder der Zugriff auf den Speicherbereich wurde verweigert. Dieser Fehler kann auftreten, wenn Betriebssystemberechtigungen falsch vergeben wurden.

<description> enthält zusätzliche Informationen zum Fehler.

Benutzerreaktion:

· Wenn Sie UNIX oder Linux verwenden, dann überprüfen Sie, ob das Verzeichnis $HOME/.sdb existiert und ob der angemeldete Betriebssystembenutzer Zugriff auf das Verzeichnis hat (siehe Konzepte des Datenbanksystems, Spezielle Betriebssystembenutzer und -benutzergruppen (UNIX/Linux)).

· Wenn in <description> eine Datei angegeben ist, dann überprüfen Sie, ob diese Datei existiert und ob der angemeldete Betriebssystembenutzer Schreib- und Leserechte für diese Datei hat.

· Wenn in <description> eine Speichergröße angegeben ist, dann überprüfen Sie, ob genügend Platz auf der Festplatte vorhanden ist.

Siehe auch:

Glossar, SQLDBC


-10807: Connection down: [<description>] (SAP-Bibliothek - Grundwissen)

-10807: Connection down: [<description>]

Erläuterung:

Die Verbindung zur Datenbankinstanz wurde unterbrochen. Dieser Fehler kann z. B. dann auftreten, wenn die Datenbankinstanz heruntergefahren wurde oder wenn es Netzwerkprobleme gibt.

<description> enthält die interne Fehlernummer und weitere Hinweise zum aufgetretenen Fehler.

Benutzerreaktion:

· Überprüfen Sie die Verbindungsdaten.

· Überprüfen Sie, ob die Datenbankinstanz sich im Betriebszustand ONLINE befindet. Falls ja, melden Sie sich mit der Methode SQLDBC_Connection::connect erneut an die Datenbankinstanz an.

Siehe auch:

Glossar, SQLDBC


-10808: Feature <feature> not implemented yet in module: <module> line: <line_number>

Erläuterung:

Das Feature <feature> wurde noch nicht im Modul <module>, Zeile <line_number>, implementiert.

Benutzerreaktion:

Installieren Sie die aktuelle Version der Software.

Siehe auch:

Glossar, SQLDBC


-10810: Session already in use (SAP-Bibliothek - Grundwissen)

-10810: Session already in use

Erläuterung:

In der Datenbanksitzung wird in diesem Thread bereits eine SQL-Anweisung ausgeführt.

Benutzerreaktion:

Vermeiden Sie den Aufruf von SQLDBC-Methoden aus Signal-Handlern, wenn Sie nicht sicherstellen können, dass im Anwendungsprogramm zum Zeitpunkt der Auslösung des Signals keine SQL-Anweisung ausgeführt wird.


-10811: Numeric overflow for parameter/column (<number>) (SAP-Bibliothek - Grundwissen)

-10811: Numeric overflow for parameter/column (<number>)

Erläuterung:

Der numerische Wert des Parameters/der Spalte <number> konnte nicht gelesen oder eingefügt werden, weil er zu gross ist.

Benutzerreaktion:

Führen Sie eine der folgenden Aktionen aus:

· Ändern Sie den Datentyp der Host-Variablen, die mit der Methode SQLDBC_PreparedStatement::bindParameter an den Parameter oder mit der Methode SQLDBC_ResultSet::bindColumn an die Spalte gebunden ist.

· Ändern Sie die SQL-Anweisung.

· Ändern Sie die Tabellendefinition.


-10821: Session not connected (SAP-Bibliothek - Grundwissen)

-10821: Session not connected

Erläuterung:

Es besteht keine Verbindung zur Datenbankinstanz. Die Verbindung zur Datenbankinstanz wurde unterbrochen.

Benutzerreaktion:

Melden Sie sich mit der Methode CONNECT erneut an die Datenbankinstanz an.

Siehe auch:

Glossar, SQLDBC


-10856: Invalid row array size 0 (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10856: Invalid row array size 0

Erläuterung:

Die aufgerufene Methode SQLDBC_PrepareStatement::setRowArraySize konnte nicht ausgeführt werden, weil die angegebene Grösse des Input-Arrays 0 war.

Massenkommandos, die Parameter haben, müssen immer mit Parameter-Arrays gebunden werden. Alle gebundenen Parameter-Arrays müssen die gleiche Dimension haben und größer als 0 sein.

Benutzerreaktion:

Definieren Sie Ihre Parameter als Arrays und setzen Sie die Dimension dieser Arrays als RowArraySize.


-10857: Missing database name for connection (SAP-Bibliothek - Grundwissen)

-10857: Missing database name for connection

Erläuterung:

Es wurde versucht, mit der Methode SQLDBC_Connection::connect eine Verbindung zur Datenbankinstanz aufzubauen, aber der Name der Datenbankinstanz wurde nicht angegeben.

Benutzerreaktion:

Geben Sie den Namen der Datenbankinstanz in den Eigenschaften der Methode SQLDBC_Connection::connect an:

· Wenn Sie die Verbindung über die Eigenschaft KEY herstellen möchten, dann überprüfen Sie mit dem Kommando XUSER list, ob ein XUSER-Eintrag für diese Datenbankinstanz vorhanden ist.

· Wenn Sie die Verbindung über die Eigenschaft KEY=SQLOPT herstellen möchten, dann überprüfen Sie, ob in der Umgebungsvariablen SQLOPT die Option -d <database_name> gesetzt wurde.

Siehe auch:

Glossar, SQLDBC


-10861: Invalid use of null pointer for stream handle in parameter (<number>)

Erläuterung:

Beim Binden einer Struktur für einen liveCache-Stream-Parameter wurde ein Nullpointer angegeben.

Benutzerreaktion:

Überprüfen Sie den angegebenen Wert im Anwendungsprogramm.


-10862: Stream parameter (<number>) error in read|write procedure

Erläuterung:

Der Aufruf der Callback-Prozedur bei der Verarbeitung eines liveCache-Streams hat einen Fehler gemeldet.

Benutzerreaktion:

Überprüfen Sie die Callback-Prozedur.


-10899: Unknown error (SAP-Bibliothek - Grundwissen)

-10899: Unknown error

Erläuterung:

Der Fehler konnte keiner Meldung zugeordnet werden. Dieser Fehler kann auftreten, wenn Sie eine Beta-Version der Software verwenden oder wenn interne Datenstrukturen inkonsistent geworden sind.

Benutzerreaktion:

Benachrichtigen Sie den Support.


-10901: No space left in request packet (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10901: No space left in request packet

Erläuterung:

Die aufgerufene Methode ist fehlgeschlagen, weil der Puffer für die Verbindung zur Datenbankinstanz zu klein für die Ausführung der SQL-Anweisung ist.

Vermutlich ist die SQL-Anweisung zu lang oder zu kompliziert, oder es wurde Zusatzfunktionalität wie die Methode SQLDBC_Prepared_Statement::setCommandInfo verwendet.

Benutzerreaktion:

Sie haben folgende Möglichkeiten:

· Vergrößern Sie den Puffer, indem Sie den Datenbankparameter _PACKET_SIZE ändern.

· Kürzen Sie die SQL-Anweisung.

· Verwenden Sie weniger Parameter/Spalten in der SQL-Anweisung.

Siehe auch:

Konzepte des Datenbanksystems, Datenbankparameter


-10902: Invalid request packet structure (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10902: Invalid request packet structure

Erläuterung:

Die interne Struktur des Puffers für die Verbindung vom Client zur Datenbankinstanz ist inkonsistent.

Benutzerreaktion:

Überprüfen Sie die Protokolldatei knldiag für weitere Hinweise auf den Fehler.

Siehe auch:

Konzepte des Datenbanksystems, Protokolldateien


-10903: Internal Error: LONGDATA part expected (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10903: Internal Error: LONGDATA part expected

Erläuterung:

Die aufgerufene Methode ist beim Übertragen von LONG-Werten fehlgeschlagen, weil der Datenbankkern nicht die notwendigen Daten zur Verfügung gestellt hat oder die interne Struktur des Puffers für die Verbindung zur Datenbankinstanz inkonsistent ist.

Benutzerreaktion:

Überprüfen Sie die Protokolldatei knldiag für weitere Hinweise auf den Fehler.

Siehe auch:

Konzepte des Datenbanksystems, Protokolldateien


-10904: Internal error: Expected result count (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10904: Internal error: Expected result count

Erläuterung:

Die aufgerufene Methode ist beim Übertragen von Ergebnissen gescheitert, weil der Datenbankkern nicht die notwendigen Daten zur Verfügung gestellt hat oder weil die interne Struktur des Puffers für die Verbindung zur Datenbankinstanz inkonsistent ist.

Benutzerreaktion:

Überprüfen Sie die Protokolldatei knldiag für weitere Hinweise auf den Fehler.

Siehe auch:

Konzepte des Datenbanksystems, Protokolldateien


-10905: Invalid reply packet structure (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10905: Invalid reply packet structure

Erläuterung:

Die interne Struktur des Puffers für die Verbindung von der Datenbankinstanz zum Client ist inkonsistent.

Benutzerreaktion:

Überprüfen Sie die Protokolldatei knldiag für weitere Hinweise auf den Fehler.

Siehe auch:

Konzepte des Datenbanksystems, Protokolldateien


-10906: Internal Error: Entry for valindex (<number>) not found

Hintergrunddokumentation -10906: Internal Error: Entry for valindex (<number>) not found

Erläuterung:

Die aufgerufene Methode ist beim Übertragen von LONG-Werten gescheitert, weil die interne Struktur der LONG-Spalte <number> inkonsistent ist.

Benutzerreaktion:

Überprüfen Sie die Protokolldatei knldiag für weitere Hinweise auf den Fehler.

Siehe auch:

Konzepte des Datenbanksystems, Protokolldateien


-10907: Internal Error: Long descriptor has error flag set (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -10907: Internal Error: Long descriptor has error flag set

Erläuterung:

Die aufgerufene Methode ist beim Übertragen von LONG-Werten gescheitert, weil der Datenbankkern einen Fehler gemeldet hat.

Benutzerreaktion:

Überprüfen Sie die Protokolldatei knldiag für weitere Hinweise auf den Fehler.

Siehe auch:

Konzepte des Datenbanksystems, Protokolldateien


Von -11000 bis -11099 (SAP-Bibliothek - Grundwissen)

Von -11000 bis -11099

Meldungen der Perl-Schnittstelle

-11000 bis -11099

Perl DBD-Meldungen


Von -11100 bis -11199 (SAP-Bibliothek - Grundwissen)

Von -11100 bis -11199

Meldungen der PHP-Schnittstelle

-11100 | Unknown error
-11101 | Initialization failed [<description>].
-11104 | Session not connected.
-11105 | Cannot get column name for column <number>.
-11106 | No result set found.
-11107 | Statement not prepared.
-11108 | Invalid parameter index <number>.
-11109 | Column/Parameter <number> truncated.
-11111 | Parameter/Column (<number>) not bound.
-11113 | Number of parameters does not match number of result columns.
-11115 | Syntax error. Expected: <description>.
-11116 | Wrong parameter type. Expected: <description>.


-11100: Unknown error (SAP-Bibliothek - Grundwissen)

-11100: Unknown error

Erläuterung:

Ein Fehler ist aufgetreten, den das System nicht genauer beschreiben kann.

Benutzerreaktion:

Schicken Sie das PHP-Skript, das den Fehler verursacht hat, an die MaxDB Mailing-Liste.

Siehe auch:

Strukturlink PHP-Handbuch


-11101: Initialization failed [<description>]. (SAP-Bibliothek - Grundwissen)

-11101: Initialization failed [<description>].

Erläuterung:

Das System konnte eine Initialisierung nicht durchführen.

Beispiele:

· Das System konnte die Variable einer internen Datenstruktur wegen Problemen bei der Speicherallozierung nicht anlegen.

· Der Pointer einer internen Variablen hat den Wert 0, obwohl das System einen Wert ungleich 0 erwartet.

Weitere Informationen finden Sie in der Beschreibung <description>.

Benutzerreaktion:

Versuchen sie, den Fehler mit den Informationen aus der Beschreibung <description> zu beheben. Wenn das das nicht möglich ist, dann wenden Sie sich an die MaxDB Mailing-Liste.

Siehe auch:

Strukturlink PHP-Handbuch


-11104: Session not connected. (SAP-Bibliothek - Grundwissen)

-11104: Session not connected.

Erläuterung:

Das System hat versucht, mit dem Datenbankkern zu kommunizieren. Dabei hat es festgestellt, dass es keine Verbindung mehr zum Datenbankkern gibt.

Benutzerreaktion:

Verbinden Sie sich erneut mit der Funktion maxdb_connect() mit dem Datenbankkern.

Siehe auch:

Strukturlink PHP-Handbuch


-11105: Cannot get column name for column <number>. (SAP-Bibliothek - Grundwissen)

-11105: Cannot get column name for column <number>.

Erläuterung:

In den Metadaten der Spalte mit der Nummer <number> fehlt der Spaltenname.

Benutzerreaktion:

Prüfen Sie, ob Sie beim Aufrufen einer MaxDB PHP-Funktion, die einen Spaltenindex als Parameter erwartet, den korrekten Spaltenindex übergeben haben.

Siehe auch:

Strukturlink PHP-Handbuch


-11106: No result set found. (SAP-Bibliothek - Grundwissen)

-11106: No result set found.

Erläuterung:

Sie haben eine MaxDB PHP-Funktion aufgerufen, die eine Ergebnismenge voraussetzt. Das System konnte jedoch keine Ergebnismenge finden.

Benutzerreaktion:

Prüfen Sie, ob eine Ergebnismenge existiert. Wenn nicht, dann ändern Sie Ihr PHP-Skript entsprechend.

Siehe auch:

Strukturlink PHP-Handbuch


-11107: Statement not prepared. (SAP-Bibliothek - Grundwissen)

-11107: Statement not prepared.

Erläuterung:

Sie haben eine MaxDB PHP-Funktion aufgerufen, die nur für Prepared Statements verwendet werden kann.

Benutzerreaktion:

Verwenden Sie Prepared Statements oder eine andere Funktion.

Siehe auch:

Strukturlink PHP-Handbuch


-11108: Invalid parameter index <number>. (SAP-Bibliothek - Grundwissen)

-11108: Invalid parameter index <number>.

Erläuterung:

Sie haben an eine MaxDB PHP-Funktion einen falschen Parameterindex <number> übergeben.

Benutzerreaktion:

Korrigieren Sie den Parameterindex.

Siehe auch:

Strukturlink PHP-Handbuch


-11109: Column/Parameter <number> truncated. (SAP-Bibliothek - Grundwissen)

-11109: Column/Parameter <number> truncated.

Erläuterung:

Das System hat beim Lesen von Daten aus der gebundenen LONG-Spalte <number> oder aus dem gebundenen Parameter <number> festgestellt, dass die Daten die maximal erlaubte Länge überschreiten.

Benutzerreaktion:

Vergrößern Sie den Wert der Eigenschaft maxdb.long_readlen in der Konfigurationsdatei PHP.ini.

Siehe auch:

Strukturlink PHP-Handbuch


-11111: Parameter/Column (<number>) not bound. (SAP-Bibliothek - Grundwissen)

-11111: Parameter/Column (<number>) not bound.

Erläuterung:

Das System hat beim Aufrufen der MaxDB PHP-Funktion maxdb_execute() oder maxdb_stmt_execute() festgestellt, dass Sie zum Spalten- oder Parameternamen <number> der SQL-Anweisung keine PHP-Variable gebunden haben.

Das System nummeriert Spalten- und Parameternamen in der SQL-Anweisung von links nach rechts durch, beginnend bei 1.

Benutzerreaktion:

Binden Sie zu jedem Parameter in einer SQL-Anweisung eine PHP-Variable mit der Funktion maxdb_bind_param() oder der Funktion maxdb_stmt_bind_param().

Siehe auch:

Strukturlink PHP-Handbuch


-11113: Number of parameters does not match number of result columns.

Erläuterung:

Das System hat beim Aufrufen der MaxDB PHP-Funktion maxdb_bind_param() oder der Funktion maxdb_stmt_bind_param() festgestellt, dass die Anzahl der zu bindenden PHP-Variablen nicht mit der Anzahl der Parameter in der zugehörigen SQL-Anweisung übereinstimmt.

Benutzerreaktion:

Stellen Sie sicher, dass die Anzahl der zu bindenden PHP-Variablen mit der Anzahl der Parameter übereinstimmt.

Siehe auch:

Strukturlink PHP-Handbuch


-11115: Syntax error. Expected: <description>. (SAP-Bibliothek - Grundwissen)

-11115: Syntax error. Expected: <description>.

Erläuterung:

Sie haben beim Aufrufen einer MaxDB PHP-Funktion eine Zeichenkette übergeben, deren Syntax falsch ist. Weitere Informationen finden Sie in der Beschreibung <description>.

Benutzerreaktion:

Korrigieren Sie die Syntax mit Hilfe der Information in der Beschreibung <description>.

Siehe auch:

Strukturlink PHP-Handbuch


-11116: Wrong parameter type. Expected: <description>. (SAP-Bibliothek - Grundwissen)

-11116: Wrong parameter type. Expected: <description>.

Erläuterung:

Der Typ der PHP-Variablen, die Sie mit der MaxDB PHP-Funktion maxdb_bind_param() oder der Funktion maxdb_stmt_bind_param() gebunden haben, stimmt nicht mit der Typkennung von maxdb_bind_param() überein.

Benutzerreaktion:

Ändern Sie die Typkennung von maxdb_bind_param() oder maxdb_stmt_bind_param() so, dass sie mit dem Typ in der Beschreibung <description> übereinstimmt.

Siehe auch:

Strukturlink PHP-Handbuch


Von -22000 bis -22999 (SAP-Bibliothek - Grundwissen)

Von -22000 bis -22999

Fehlermeldungen des Programms ODBC

-22000 | Null values not allowed on more than one long column
-22005 | Connection timeout occured. Session reconnected


-22000: Null values not allowed on more than one long column (SAP-Bibliothek - Grundwissen)

-22000: Null values not allowed on more than one long column

Erläuterung:

Bei einer INSERT- oder UPDATE-Anweisung darf maximal eine LONG-Spalte den NULL-Wert erhalten, wenn LONG-Spalten mittels SQLParamData und SQLPutData eingefügt werden.

Benutzerreaktion:

Nehmen Sie nur eine LONG-Spalte in die Anweisung auf, oder verwenden Sie leere Strings anstelle von NULL-Werten.


-22005: Connection timeout occurred. Session reconnected (SAP-Bibliothek - Grundwissen)

-22005: Connection timeout occurred. Session reconnected

Erläuterung:

Die Transaktion des Benutzers wurde abgebrochen und durch eine ROLLBACK-Anweisung zurückgesetzt. Die Datenbanksitzung wurde beendet, weil der Benutzer während eines bestimmten Zeitintervalls (spezieller Datenbankparameter SESSION_TIMEOUT oder bei der CONNECT-Anweisung angegebener Timeout-Wert) keine Operationen durchgeführt hatte.

Der ODBC-Treiber erkennt einen solchen Timeout und meldet den Benutzer automatisch wieder an die Datenbankinstanz an mit den ursprünglichen Parametern (Benutzername, Kennwort, Datenbankname, Datenbankrechner, ...). Jede Anweisung der betroffenen Sitzung signalisiert dies mit dem Returncode SQL_SUCCESS_WITH_INFO und der Meldung -22005.

Benutzerreaktion:

Alle Anweisungen, die eine Ergebnismenge (CURSOR) besitzen, müssen erneut ausgeführt werden, um zu gewährleisten, dass die Ergebnismengen erneut aufgebaut werden. Ist die Verbindung auf SQL_AUTOCOMMIT_OFF eingestellt, so müssen auch alle anderen Anweisungen, die in einer offenen Transaktion waren, erneut ausgeführt werden.


Von -23000 bis -23999 (SAP-Bibliothek - Grundwissen)

Von -23000 bis -23999

Fehlermeldungen des Programms SQL Studio

-23050 | Unknown error
-23051 | Could not load system tables for SQL Studio
-23052 | Could not save object data
-23053 | Cannot load suppose list
-23054 | Maximum numbers of windows reached
-23055 | Connection failed
-23056 | User is exclusive
-23057 | Reconnect failed
-23058 | No database connection
-23059 | You do not have the permission to modify this object
-23060 | You do not have the permission to delete this object
-23061 | Cannot analyze error
-23062 | Could not open connection
-23063 | Could not create Global Com Object
-23064 | Import failed
-23070 | Cannot open object created by newer SQL Studio Version
-23071 | Convert object created by older SQL Studio Version
-23072 | Representation of null value too long.
-23100 | OLE Error Please restart SQL Studio
-23101 | Data in clipboard truncated
-23102 | Failed to create DBC Pool
-23103 | Failed to create DBC Handle
-23104 | Could not load table definition
-23200 | No data sources
-23201 | No ODBC driver
-23202 | Could not load object description
-23203 | Cannot show tables of users, wrong database version


-23050: Unknown error (SAP-Bibliothek - Grundwissen)

-23050: Unknown error

Erläuterung:

Es trat ein unbekannter Fehler auf.

Benutzerreaktion:

Verständigen Sie den Support.


-23051: Could not load system tables for SQL Studio (SAP-Bibliothek - Grundwissen)

-23051: Could not load system tables for SQL Studio

Erläuterung:

Die Datenbankinstanz enthält nicht die für das Strukturlink SQL Studio benötigten Systemtabellen.

Benutzerreaktion:

Laden Sie die Systemtabellen mit dem Database Manager.

Falls die Fehlermeldung danach nochmals auftritt, verständigen Sie den Support.


-23052: Could not save object data (SAP-Bibliothek - Grundwissen)

-23052: Could not save object data

Erläuterung:

Ein Objekt des Strukturlink SQL Studio konnte nicht gespeichert werden.

Benutzerreaktion:

Laden Sie die Systemtabellen mit dem Database Manager.

Falls die Fehlermeldung danach nochmals auftritt, verständigen Sie den Support.


-23053: Cannot load suppose list (SAP-Bibliothek - Grundwissen)

-23053: Cannot load suppose list

Erläuterung:

Die SQL-Unterstützung konnte nicht geladen werden.

Benutzerreaktion:

Laden Sie die Systemtabellen mit dem Database Manager.

Falls die Fehlermeldung danach nochmals auftritt, verständigen Sie den Support.


-23054: Maximum numbers of windows reached (SAP-Bibliothek - Grundwissen)

-23054: Maximum numbers of windows reached

Erläuterung:

Die maximale Anzahl von Fenstern wurde geöffnet.

Benutzerreaktion:

Schließen Sie geöffnete Fenster.


-23055: Connection failed (SAP-Bibliothek - Grundwissen)

-23055: Connection failed

Erläuterung:

Die Verbindung zur Datenbankinstanz konnte nicht hergestellt werden.

Benutzerreaktion:

Überprüfen Sie den Zustand der Datenbankinstanz mit dem Database Manager.


-23056: User is exclusive (SAP-Bibliothek - Grundwissen)

-23056: User is exclusive

Erläuterung:

Es wurde versucht, mit einem exclusive-Benutzer mehrere Verbindungen zur Datenbankinstanz aufzubauen.

Benutzerreaktion:

Der Benutzer muss mit dem Strukturlink SQL Studio, falls mehrere Verbindungen nötig sind, zu einem not-exclusive-Benutzer verändert werden.


-23057: Reconnect failed (SAP-Bibliothek - Grundwissen)

-23057: Reconnect failed

Erläuterung:

Der Versuch, eine unterbrochene Verbindung zur Datenbankinstanz wieder aufzubauen, schlug fehl.

Benutzerreaktion:

Überprüfen Sie den Zustand der Datenbankinstanz mit dem Database Manager.

Beenden Sie die Datenbanksitzung, und melden Sie sich erneut an die Datenbankinstanz an.


-23058: No database connection (SAP-Bibliothek - Grundwissen)

-23058: No database connection

Erläuterung:

Die Verbindung zur Datenbankinstanz besteht nicht mehr.

Benutzerreaktion:

Überprüfen Sie den Zustand der Datenbankinstanz mit dem Database Manager.

Beenden Sie die Datenbanksitzung, und melden Sie sich erneut an die Datenbankinstanz an.


-23059: You do not have the permission to modify this object (SAP-Bibliothek - Grundwissen)

-23059: You do not have the permission to modify this object

Erläuterung:

Ein von einem anderen Benutzer freigegebenes Objekt des Strukturlink SQL Studio darf nicht verändert werden.

Benutzerreaktion:

Wenden Sie sich an den Besitzer des Objekts.


-23060: You do not have the permission to delete this object (SAP-Bibliothek - Grundwissen)

-23060: You do not have the permission to delete this object

Erläuterung:

Ein von einem anderen Benutzer freigegebenes Objekt des Strukturlink SQL Studio darf nicht gelöscht werden.

Benutzerreaktion:

Wenden Sie sich an den Besitzer des Objekts.


-23061: Cannot analyze error (SAP-Bibliothek - Grundwissen)

-23061: Cannot analyze error

Erläuterung:

Es trat ein ODBC-Fehler auf, der nicht analysiert werden konnte.

Benutzerreaktion:

Überprüfen Sie die Version des benutzten ODBC-Treibers, und installieren Sie gegebenenfalls eine neuere Version.


-23062: Could not open connection (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23062: Could not open connection

Erläuterung:

Der Versuch eine Verbindung zur Datenbankinstanz aufzubauen schlug fehl.

Benutzerreaktion:

Überprüfen Sie den Zustand der Datenbankinstanz mit dem Database Manager.

Beenden Sie die Strukturlink SQL-Studio-Sitzung, und verbinden Sie sich erneut mit der Datenbankinstanz.


-23063: Could not create Global Com Object (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23063: Could not create Global Com Object

Erläuterung:

Ein SQL-Studio-Objekt konnte nicht erzeugt werden.

Benutzerreaktion:

Beenden Sie das Strukturlink SQL Studio.

Überprüfen Sie, ob das System genügend Arbeitsspeicher zur Verfügung hat.

Starten Sie SQL Studio neu.


-23064: Import failed (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23064: Import failed

Erläuterung:

Das Importieren exportierter Objekte des Strukturlink SQL Studio schlug fehl.

Benutzerreaktion:

Verständigen Sie den Support.


-23070: Cannot open object created by newer SQL Studio Version (SAP-Bibliothek - Grundwissen)

-23070: Cannot open object created by newer SQL Studio Version

Erläuterung:

Sie haben versucht, ein Objekt des Strukturlink SQL Studio zu öffnen, das mit einer aktuelleren Programmversion erstellt wurde.

Benutzerreaktion:

Sie können dieses Objekt nur mit der aktuelleren Programmversion bearbeiten. Installieren Sie die aktuelle Version des SQL Studio.


-23071: Convert object created by older SQL Studio Version (SAP-Bibliothek - Grundwissen)

-23071: Convert object created by older SQL Studio Version

Erläuterung:

Das Objekt des Strukturlink SQL Studio kann in das Format einer neueren Programmversion konvertiert werden.

Benutzerreaktion:

Wählen Sie Yes, wenn Sie die Konvertierung des Objektes durchführen möchten. Nach der Sicherung des Objektes hat dieses Objekt dann das Format der neueren Version des SQL Studio. Ein konvertiertes Objekt kann mit einer älteren Version nicht mehr bearbeitet werden.

Wählen Sie No, wenn Sie die Konvertierung des Objektes nicht durchführen möchten.


-23072: Representation of null value too long (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23072: Representation of null value too long

Erläuterung:

Die Darstellung des NULL-Wertes ist länger als 16 Zeichen.

Benutzerreaktion:

Wählen Sie eine Darstellung des NULL-Wertes kleiner als 16 Zeichen.


-23100: OLE Error! Please restart SQL Studio (SAP-Bibliothek - Grundwissen)

-23100: OLE Error! Please restart SQL Studio

Erläuterung:

Bei einer OLE-Operation trat ein Automatisierungsfehler im Windows-Betriebssystem auf.

Benutzerreaktion:

Beenden Sie Strukturlink SQL Studio, und starten Sie es neu.


-23101: Data in clipboard truncated (SAP-Bibliothek - Grundwissen)

-23101: Data in clipboard truncated

Erläuterung:

Beim Export des Inhalts einer LONG-Spalte in die Zwischenablage werden maximal 1048576 Byte exportiert. Sind mehr Daten in der Ergebniszeile vorhanden, werden diese ignoriert.

Benutzerreaktion:

Um den Inhalt einer LONG-Spalte größer als 1048576 Byte komplett zu exportieren, verwenden Sie das Exportieren in eine Datei.


-23102: Failed to create DBC Pool (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23102: Failed to create DBC Pool

Erläuterung:

Das Anlegen eines Datenbank-Connection-Pool schlug fehl.

Benutzerreaktion:

Verständigen Sie den Support.


-23103: Failed to create DBC Handle (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23103: Failed to create DBC Handle

Erläuterung:

Das Anlegen eines Datenbank-Connection-Pool schlug fehl.

Benutzerreaktion:

Verständigen Sie den Support.


-23104: Could not load table definition (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23104: Could not load table definition

Erläuterung:

Die Definition einer Tabelle konnte nicht geladen werden.

Benutzerreaktion:

Verständigen Sie den Support.


-23200: No data sources (SAP-Bibliothek - Grundwissen)

-23200: No data sources

Erläuterung:

Auf dem Betriebssystem sind keine ODBC-Datenquellen mit dem ODBC-Treiber der Datenbank installiert.

Benutzerreaktion:

Installieren Sie mit dem ODBC-Administrator eine Datenquelle.


-23201: No ODBC driver (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23201: No ODBC driver

Erläuterung:

Im Verzeichnis von Strukturlink SQL Studio befindet sich kein ODBC-Treiber (sqlod32.dll, sqlsp32.dll).

Benutzerreaktion:

Deinstallieren Sie SQL Studio und installieren Sie SQL Studio anschließend neu.

Falls die Fehlermeldung danach nochmals auftritt, verständigen Sie den Support.


-23202: Could not load object description (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation -23202: Could not load object description

Erläuterung:

Die Strukturlink SQL Studio-Objekte konnten nicht geladen werden.

Benutzerreaktion:

Laden Sie die Systemtabellen mit dem Database Manager.

Falls die Fehlermeldung danach nochmals auftritt, verständigen Sie den Support.


-23203: Cannot show tables of users, wrong database version (SAP-Bibliothek - Grundwissen)

-23203: Cannot show tables of users, wrong database version

Erläuterung:

Die Systemtabelle DOMAIN.TABLES enthält nicht alle notwendigen Spalten zum Anzeigen der Tabellen im Katalogbaum.

Benutzerreaktion:

Benutzen Sie eine frühere Version von Strukturlink SQL Studio.


Von -24000 bis -24999 (SAP-Bibliothek - Grundwissen)

Von -24000 bis -24999

Fehlermeldungen des Programms Database Manager

-24905 | ERR_NOEBIDLIST: no information on external backup IDs available
-24906 | ERR_EBFDIRTY: invalid format of external backup history
-24907 | ERR_DBAWRONG - wrong SYSDBA
-24909 | ERR_DBAUNKNOWN - DOMAIN password unknown
-24910 | ERR_PARAMVER - wrong version of param help file (cserv.pcf) <version>
-24911 | ERR_INVDBNAME - database name <dbname> is reserved
-24912 | ERR_WRONGINST - DBM Server instroot is <instroot>
-24913 | ERR_SERVICEDB - cannot register service kernel for <instroot>
-24914 | ERR_KEYEXISTS - installation key <key> exists
-24915 | ERR_NOADDD - configuration update not allowed (param file is inactive)
-24916 | ERR_MAXVOLCNT - max volume count exceeded
-24917 | ERR_MAXDATA - max data size exceeded
-24918 | ERR_MISSMIRR - missing data for mirror devspace
-24919 | ERR_CLEANUP: cannot free all operational resources after backup operation
-24920 | ERR_BACKUPOP: backup operation was unsuccessful
-24921 | ERR_POSTOP: error while finishing backup operation
-24922 | ERR_OPCHK: cannot check state of backup operation
-24923 | ERR_TOOLREQ: error while starting external backup tool
-24924 | ERR_DBREQ: cannot start database kernel request
-24925 | ERR_PREPARE: preparation of backup operation failed
-24926 | ERR_MEDIUMCHK: medium cannot be used with this external backup tool
-24927 | ERR_TOOLCHK: external backup tool not found
-24928 | ERR_NOREPLY - no reply available
-24929 | ERR_USRFRM - invalid user record format
-24930 | ERR_XPVALUESET - parameter value not in valueset
-24931 | ERR_XPMAX - parameter value higher than maximum allowed
-24932 | ERR_XPMIN - parameter value smaller than minimum allowed
-24933 | ERR_NOSERVICESESSION - no service kernel session available
-24934 | ERR_VERSION - incompatible versions (param and kernel)
-24935 | ERR_NOUSERS - no users found
-24936 | ERR_DBNORUN - database is not running
-24937 | ERR_MISSRIGHT - no server rights for this command
-24938 | ERR_NOENTRY - no entry found
-24939 | ERR_LASTREG - cannot delete last registration of instance
-24940 | ERR_NEEDSYSLOGON - system logon required
-24941 | ERR_NEEDLOGON - DBM Server logon required
-24942 | ERR_USRDELSDBA - cannot delete sysdba
-24943 | ERR_USRDELDBM - cannot delete DBM user
-24944 | ERR_USRDELSELF - cannot delete current user
-24945 | ERR_TOFEWPARAM - to few parameters
-24946 | ERR_TOMANYPARAM - to many parameters
-24947 | ERR_DBNAME - do not use dbname
-24948 | ERR_NODBNAME - database name required
-24949 | ERR_USREXISTS - user entry already exists
-24950 | ERR_USRFAIL - user authorization failed
-24951 | ERR_USRREAD - could not read user data
-24952 | ERR_USRSAVE - could not save user data
-24953 | ERR_DBEXIST - database instance already exists
-24954 | ERR_BANOAUTOMED – no autolog medium found in media list
-24955 | ERR_BANOSAVETYPE – backup type not defined
-24956 | ERR_BASAVETYPECON – backup type conflicts with media definition
-24957 | ERR_NOUSER – required user not set
-24958 | ERR_BAOVERWRITE – file already exists, cannot overwrite
-24959 | ERR_XPOVERFLOW – value out of margin
-24960 | ERR_DBRUN – database is running
-24961 | ERR_STATE – cannot determine current db state
-24962 | ERR_VOLTYPE – wrong volume type
-24963 | ERR_VOLCHECK – error while checking volume
-24964 | ERR_EXECUTE – error in program execution
-24965 | ERR_SYSLOGON – logon to system failed
-24966 | ERR_LOGON – logon to DBM Server failed
-24967 | ERR_SYSTEM – system call error
-24968 | ERR_XPREADONLY – parameter is read only
-24969 | ERR_XPDIRTY – param file is dirty
-24970 | ERR_XPNOMODIFY –parameter must not be modified
-24971 | ERR_XPNOCHECK – no running parameter check
-24972 | ERR_XPINVCONF – invalid value
-24973 | ERR_XPCHECK – param check failure/request
-24974 | ERR_XPSESSION – param session active
-24975 | ERR_NOXPSESSION – param session inactive
-24976 | ERR_PARAMEXIST – param file of database already exists
-24977 | ERR_COMMAND – unknown command <command>
-24978 | ERR_XPSYNTAX – xparam syntax error
-24979 | ERR_XPNOTFOUND – parameter not found
-24980 | ERR_NOHELP – xparam help file not found
-24981 | ERR_HIENTRYNOTFOUND – backup history entry not found
-24982 | ERR_ERR_NOHISTORY – backup history file not found
-24983 | ERR_BANOVALIDTYPE – invalid backup type
-24984 | ERR_MENOVALID – invalid medium definition
-24985 | ERR_MENOTFOUND – medium not found
-24986 | ERR_NOMEDIA –media file not found
-24987 | ERR_TOSMALL – packet size too small for answer
-24988 | ERR_SQL – sql error
-24989 | ERR_NOHISTORYSESSION – no backup history session available
-24990 | ERR_ NOBACKUPSESSION – no backup session available
-24993 | ERR_RTEEXT – runtime environment error
-24994 | ERR_RTE – runtime environment error
-24995 | ERR_MEM – memory allocation error
-24996 | ERR_PARAM – wrong parameters
-24997 | ERR_FILE – file handling error
-24998 | ERR_NOTIMPL – sorry, command not yet implemented
-24999 | ERR – common error


-24905: ERR_NOEBIDLIST: no information on external backup IDs available

Erläuterung:

Es sind keine Informationen zu externen Sicherungskennungen (External Backup IDs) vorhanden, da diese nicht abgefragt wurden.

Benutzerreaktion:

Führen Sie die das DBM-Kommando Strukturlink backup_ext_ids_get zum Holen der externen Sicherungskennungen aus.


-24906: ERR_EBFDIRTY: invalid format of external backup history (SAP-Bibliothek - Grundwissen)

-24906: ERR_EBFDIRTY: invalid format of external backup history

Erläuterung:

Die Datei External Backup History entspricht nicht dem erwarteten Format.

Benutzerreaktion:

Je nachdem, ob Sie die Informationen aus dieser Datei benötigen oder nicht benötigen, verständigen Sie entweder den Support oder erstellen eine Sicherungskopie dieser Datei und ersetzen diese Datei mit einer leeren Datei gleichen Namens.


-24907: ERR_DBAWRONG - wrong SYSDBA (SAP-Bibliothek - Grundwissen)

-24907: ERR_DBAWRONG - wrong SYSDBA

Erläuterung:

Der dem DBM-Server als SYSDBA (Datenbanksystemadministrator) bekannte Benutzer besitzt nicht die erforderlichen Rechte.

Benutzerreaktion:

Geben Sie den tatsächlichen Datenbanksystemadministrator an.


-24909: ERR_DBAUNKNOWN - SYSDBA unknown (SAP-Bibliothek - Grundwissen)

-24909: ERR_DBAUNKNOWN - SYSDBA unknown

Erläuterung:

Der für das Laden der Systemtabellen erforderliche SYSDBA (Datenbanksystemadministrator) ist dem DBM-Server nicht bekannt.

Benutzerreaktion:

Geben Sie den Datenbanksystemadministrator an.


-24910: ERR_PARAMVER - wrong version of param help file (cserv.pcf) <version>

Erläuterung:

Die Versionen von DBM-Server und der Parameter-Beschreibungsdatei (cserv.pcf) passen nicht zueinander.

Benutzerreaktion:

Korrigieren Sie die Dateien Ihrer Installation. Beachten Sie, dass vor einer Installation oder einer Aktualisierung der Installation alle Programme des Datenbanksystems beendet werden müssen.


-24911: ERR_INVDBNAME - database name <database_name> is reserved

Erläuterung:

Sie haben einen unzulässigen Namen für Ihre Datenbankinstanz gewählt.

Benutzerreaktion:

Benutzen Sie einen anderen Namen für Ihre Datenbankinstanz.


-24912: ERR_WRONGINST – DBM server instroot is <inst_path>

Erläuterung:

Sie haben versucht, eine Installation mit einem DBM-Server aus einer anderen Installation zu registrieren. Dies ist nicht möglich.

Benutzerreaktion:

Benutzen Sie den korrekten DBM-Server. Bei der Benutzung des Strukturlink Database Manager CLI können Sie mit der Strukturlink Option -R die Verwendung eines bestimmten DBM-Server erzwingen.


-24913: ERR_SERVICEDB - can not register service kernel for <inst_path>

Erläuterung:

Die Servicedatenbankinstanz konnte nicht registriert werden. Ursache dafür können eine fehlerhafte Installation der Dateien oder fehlende Rechte des Betriebsystembenutzers sein.

Benutzerreaktion:

Korrigieren oder wiederholen Sie die Installation, bzw. statten Sie Ihren Betriebssystembenutzer mit den erforderlichen Rechten aus.


-24914: ERR_KEYEXISTS - installation key <key> exists (SAP-Bibliothek - Grundwissen)

-24914: ERR_KEYEXISTS - installation key <key> exists

Erläuterung:

Sie haben im DBM-Kommando Strukturlink inst_reg einen Schlüssel verwendet, der bereits vergeben ist. Hatten Sie keinen Schlüssel spezifiziert, so ist der leere Schlüssel bereits vergeben.

Benutzerreaktion:

Verwenden Sie im DBM-Kommando inst_reg hinter der Option -k einen eindeutigen Schlüssel inst_reg -k <key>.


-24915: ERR_NOADDD - configuration update not allowed (param file is inactive)

Erläuterung:

Das Ändern der Datenbankkonfiguration ist nicht erlaubt, da an der Parameterdatei Änderungen vorgenommen wurden, die noch nicht aktiviert wurden.

Benutzerreaktion:

Um die Änderungen in der Parameterdatei zu aktivieren, überführen Sie die Datenbank zunächst in den Betriebszustand OFFLINE und dann in den Zustand ONLINE.

Um die Änderungen in der Parameterdatei rückgängig zu machen, benutzen Sie das DBM-Kommando Strukturlink param_restore.


-24916: ERR_MAXVOLCNT - max volume count exceeded (SAP-Bibliothek - Grundwissen)

-24916: ERR_MAXVOLCNT - max volume count exceeded

Erläuterung:

Die Anzahl der Volumes des verwendeten Typs übersteigt den aktuell eingestellten Maximalwert.

Benutzerreaktion:

Erhöhen Sie den Wert des allgemeinen Datenbankparameters MAXLOGVOLUMES für die Log-Volumes oder den Wert von MAXDATAVOLUMES für die Data-Volumes. Zur Aktivierung des neuen Wertes müssen Sie die Datenbankinstanz neu starten.


-24917: ERR_MAXDATA - max data size exceeded (SAP-Bibliothek - Grundwissen)

-24917: ERR_MAXDATA - max data size exceeded

Erläuterung:

Die Gesamtgröße der Data-Volumes übersteigt den aktuell eingestellten Maximalwert.

Benutzerreaktion:

Verringern Sie die Größe des hinzuzufügenden Volume.


-24918: ERR_MISSMIRR - missing data for mirror volume (SAP-Bibliothek - Grundwissen)

-24918: ERR_MISSMIRR - missing data for mirror volume

Erläuterung:

Die Angaben zu einem gespiegelten Volume sind nicht vorhanden.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe mit den Daten für das gespiegelte Volume. Führen Sie die Anweisung erneut aus.


-24919: ERR_CLEANUP: cannot free all operational ressources after backup operation

Erläuterung:

Es war nach der eigentlich erfolgreichen Sicherung, Überprüfung oder Wiederherstellung nicht möglich, alle in Anspruch genommenen temporären Systemressourcen wieder freizugeben.

Benutzerreaktion:

Überprüfen Sie anhand des Sicherungsprotokolls, welche Ressourcen nicht freigegeben wurden. Handelt es sich um temporäre Dateien oder Pipes, versuchen Sie, diese manuell zu entfernen. Versuchen Sie außerdem, die in der erweiterten Fehlerbeschreibung genannte Ursache des Problems zu beseitigen. Falls Sie das Problem nicht lösen können, verständigen Sie den Support.


-24920: ERR_BACKUPOP: backup operation was unsuccessful (SAP-Bibliothek - Grundwissen)

-24920: ERR_BACKUPOP: backup operation was unsuccessful

Erläuterung:

Die Sicherung, Überprüfung oder Wiederherstellung ist aufgrund eines Datenbankproblems oder aufgrund eines Problems des Sicherungswerkzeuges fehlgeschlagen. Im Falle einer Überprüfung ist es auch möglich, dass die überprüfte Sicherung fehlerhaft war.

Benutzerreaktion:

Versuchen Sie, die in der erweiterten Fehlerbeschreibung genannte Ursache des Problems zu beseitigen. Falls Sie das Problem nicht lösen können, verständigen Sie den Support.


-24921: ERR_POSTOP: error while finishing backup operation (SAP-Bibliothek - Grundwissen)

-24921: ERR_POSTOP: error while finishing backup operation

Erläuterung:

Es war nach eigentlich erfolgreicher Sicherung, Überprüfung oder Wiederherstellung nicht möglich, die notwendigen Schritte zur Nachbearbeitung durchzuführen.

Benutzerreaktion:

Versuchen Sie, die in der erweiterten Fehlerbeschreibung genannte Ursache des Problems zu beseitigen, und wiederholen Sie die Sicherung, Überprüfung oder Wiederherstellung. Falls Sie das Problem nicht lösen können, verständigen Sie den Support.


-24922: ERR_OPCHK: cannot check state of backup operation (SAP-Bibliothek - Grundwissen)

-24922: ERR_OPCHK: cannot check state of backup operation

Erläuterung:

Es war nicht möglich, den Zustand der Datenbankinstanz oder den Zustand des Sicherungswerkzeuges zu überprüfen.

Benutzerreaktion:

Versuchen Sie, die in der erweiterten Fehlerbeschreibung genannte Ursache des Problems zu beseitigen. Falls Sie das Problem nicht lösen können, verständigen Sie den Support.


-24923: ERR_TOOLREQ: error while starting external backup tool (SAP-Bibliothek - Grundwissen)

-24923: ERR_TOOLREQ: error while starting external backup tool

Erläuterung:

Es war nicht möglich das Sicherungswerkzeug korrekt zu starten.

Benutzerreaktion:

Versuchen Sie, die in der erweiterten Fehlerbeschreibung genannte Ursache des Problems zu beseitigen. Falls Sie das Problem nicht lösen können, verständigen Sie den Support.


-24924: ERR_DBREQ: cannot start database kernel request (SAP-Bibliothek - Grundwissen)

-24924: ERR_DBREQ: cannot start database kernel request

Erläuterung:

Die Datenbankinstanz konnte die Sicherung, Überprüfung oder Wiederherstellung nicht starten.

Benutzerreaktion:

Versuchen Sie, die in der erweiterten Fehlerbeschreibung genannte Ursache des Problems zu beseitigen. Falls Sie das Problem nicht lösen können, verständigen Sie den Support.


-24925: ERR_PREPARE: preparation of backup operation failed (SAP-Bibliothek - Grundwissen)

-24925: ERR_PREPARE: preparation of backup operation failed

Erläuterung:

Die nötigen Vorbereitungen zum Einsatz des Sicherungswerkzeuges konnten nicht erfolgreich abgeschlossen werden.

Benutzerreaktion:

Versuchen Sie, die in der erweiterten Fehlerbeschreibung genannte Ursache des Problems zu beseitigen. Falls Sie das Problem nicht lösen können, verständigen Sie den Support.


-24926: ERR_MEDIUMCHK: medium cannot be used with this external backup tool

Erläuterung:

Die angegebene Sicherungsvorlage kann mit diesem Sicherungswerkzeug nicht verwendet werden.

Benutzerreaktion:

● Überprüfen Sie die Definition Ihrer Sicherungsvorlage.

● Wenn Sie das Problem nicht lösen können, dann verständigen Sie den Support.

Siehe Support.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungsvorlagen und Datenträger


-24927: ERR_TOOLCHK: external backup tool not found (SAP-Bibliothek - Grundwissen)

-24927: ERR_TOOLCHK: external backup tool not found

Erläuterung:

Das Sicherungswerkzeug wurde nicht gefunden oder ist nicht korrekt installiert.

Benutzerreaktion:

● Versuchen Sie, die in der erweiterten Fehlerbeschreibung genannte Ursache des Problems zu beseitigen.

● Wenn Sie kein Sicherungswerkzeug eines anderen Anbieters einsetzen wollten, dann ändern Sie die Definition der Sicherungsvorlage entsprechend.

● Wenn Sie das Problem nicht lösen können, dann verständigen Sie den Support.

Siehe Support.

Siehe auch:

Konzepte des Datenbanksystems,

● Sicherungswerkzeuge anderer Anbieter verwenden

● Sicherungsvorlagen und Datenträger


-24928: ERR_NOREPLY - no reply available (SAP-Bibliothek - Grundwissen)

-24928: ERR_NOREPLY - no reply available

Erläuterung:

Für eine asynchrone Anforderung an die Datenbankinstanz liegt noch keine Antwort vor.

Benutzerreaktion:

Wiederholen Sie die Anweisung bis ein Vorliegen der Anwort angezeigt wird, und verwenden Sie dann die zur Anforderung korrespondierende Anweisung zum Abholen der Antwort. Alternativ können Sie sofort die Anweisung zum Abholen der Antwort verwenden. Diese wartet, bis die Anwort bereitgestellt ist.


-24929: ERR_USRFRM - invalid user record format (SAP-Bibliothek - Grundwissen)

-24929: ERR_USRFRM - invalid user record format

Erläuterung:

Die Daten der DBM-Benutzer sind inkonsistent.

Benutzerreaktion:

Überprüfen Sie bei einer Migration die korrekte Ausführung der Migrationsschritte. Wenden Sie sich bei weiterem Bestehen des Fehlers an den Support.


-24930: ERR_XPVALUESET - parameter value not in value set (SAP-Bibliothek - Grundwissen)

-24930: ERR_XPVALUESET - parameter value not in value set

Erläuterung:

Der eingegebene Wert des Datenbankparameters ist nicht in der zulässigen Wertemenge enthalten.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe, und führen Sie die DBM-Kommando erneut durch.


-24931: ERR_XPMAX - parameter value higher than maximum allowed (SAP-Bibliothek - Grundwissen)

-24931: ERR_XPMAX - parameter value higher than maximum allowed

Erläuterung:

Der eingegebene Wert des Datenbankparameters liegt über dem maximal zulässigen Wert.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe, und führen Sie das DBM-Kommando erneut durch.


-24932: ERR_XPMIN - parameter value smaller than minimum allowed

Erläuterung:

Der eingegebene Wert des Datenbankparameters liegt unter dem notwendigen Minimum.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe und führen Sie das DBM-Kommando erneut durch.


-24933: ERR_NOSERVICESESSION - no service kernel available (SAP-Bibliothek - Grundwissen)

-24933: ERR_NOSERVICESESSION - no service kernel available

Erläuterung:

Das verwendete DBM-Kommando erfordert eine Service-Sitzung.

Benutzerreaktion:

Aktivieren Sie die Service-Sitzung vor Ausführung des DBM-Kommandos mit dem DBM-Kommando Strukturlink service_connect oder der Option Strukturlink -uSRV.


-24934: ERR_VERSION - incompatible versions (param and kernel) (SAP-Bibliothek - Grundwissen)

-24934: ERR_VERSION - incompatible versions (param and kernel)

Erläuterung:

Die Version der Parameterdatei der Datenbankinstanz passt nicht zum ausführbaren Datenbankprogramm.

Benutzerreaktion:

Aktualisieren Sie die Einträge in der Parameterdatei durch eine Parameterprüfung. Verwenden Sie dazu das DBM-Kommando Strukturlink param_checkall.


-24935: ERR_NOUSERS - no users found (SAP-Bibliothek - Grundwissen)

-24935: ERR_NOUSERS - no users found

Erläuterung:

Es wurden keine Benutzereinträge gefunden.

Benutzerreaktion:

Erzeugen Sie die benötigten Benutzereinträge mit dem DBM-Kommando Strukturlink db_create.


-24936: ERR_DBNORUN - database is not running (SAP-Bibliothek - Grundwissen)

-24936: ERR_DBNORUN - database is not running

Erläuterung:

Die Datenbankinstanz befindet sich nicht im Betriebszustand ADMIN oder ONLINE.

Benutzerreaktion:

Überführen Sie vor Anwendung des DBM-Kommandos die Datenbankinstanz in den gewünschten Betriebszustand. Verwenden Sie dazu das DBM-Kommando Strukturlink db_admin oder Strukturlink db_online.


-24937: ERR_MISSRIGHT - no server rights for this command (SAP-Bibliothek - Grundwissen)

-24937: ERR_MISSRIGHT - no server rights for this command

Erläuterung:

Der aktuelle Database Manager-Benutzer ist nicht berechtigt dieses Kommando auszuführen.

Benutzerreaktion:

Verwenden Sie einen anderen Database Manager-Benutzer, oder passen Sie die Serverberechtigungen des aktuellen Database Manager-Benutzers entsprechend an. Benutzen Sie dazu das DBM-Kommando Strukturlink user_put.


-24938: ERR_NOENTRY - no entry found (SAP-Bibliothek - Grundwissen)

-24938: ERR_NOENTRY - no entry found

Erläuterung:

Die angeforderte Registrierung der Datenbankinstanz wurde nicht gefunden.

Benutzerreaktion:

Verwenden zur Ausführung des DBM-Kommandos eine vorhandene Registrierung.


-24939: ERR_LASTREG - cannot delete last registration of instance

Erläuterung:

Die letzte Registrierung einer Datenbankinstanz darf mit dem verwendeten DBM-Kommando nicht gelöscht werden.

Benutzerreaktion:

Zum Löschen der Datenbankinstanz verwenden Sie das DBM-Kommando Strukturlink db_drop. Alle gespeicherten Daten und die Konfiguration der Datenbankinstanz gehen dabei verloren.


-24940: ERR_NEEDSYSLOGON - system logon required (SAP-Bibliothek - Grundwissen)

-24940: ERR_NEEDSYSLOGON - system logon required

Erläuterung:

Das verwendete DBM-Kommando erfordert eine Anmeldung am Betriebssystem.

Benutzerreaktion:

Hinterlegen Sie zu dem verwendeten Database Manager-Benutzer einen Betriebssystembenutzer. Verwenden Sie dazu das DBM-Kommando Strukturlink user_put.

Zur Aktivierung des Betriebssystembenutzers melden Sie sich erneut am DBM-Server an. Verwenden Sie dazu das DBM-Kommando Strukturlink user_logon, und achten Sie auf Warnungen, die auf Probleme mit der Betriebssystemanmeldung hinweisen.


-24941: ERR_NEEDLOGON - DBM server logon required (SAP-Bibliothek - Grundwissen)

-24941: ERR_NEEDLOGON - DBM server logon required

Erläuterung:

Das verwendete DBM-Kommando erfordert eine Anmeldung am DBM-Server.

Benutzerreaktion:

Melden Sie sich korrekt am DBM-Server an. Verwenden Sie dazu das DBM-Kommando Strukturlink user_logon oder die Option -u.


-24942: ERR_USRDELSDBA - cannot delete sysdba (SAP-Bibliothek - Grundwissen)

-24942: ERR_USRDELSDBA - cannot delete sysdba

Erläuterung:

Der verwendete Datenbanksystemadministrator (SYSDBA-Benutzer) hat besondere Eigenschaften und darf nicht gelöscht werden.

Benutzerreaktion:

Sie dürfen diesen Benutzer nicht löschen. Sollte die Kombination Benutzername/Kennwort Unbefugten bekannt geworden sein, ändern Sie das Kennwort des Datenbanksystemadministrators. Verwenden Sie dazu z.B. das DBM-Kommando Strukturlink user_put.


-24943: ERR_USRDELDBM - cannot delete DBM operator (SAP-Bibliothek - Grundwissen)

-24943: ERR_USRDELDBM - cannot delete DBM operator

Erläuterung:

Der verwendete Database Manager-Benutzer hat besondere Eigenschaften und darf nicht gelöscht werden.

Benutzerreaktion:

Sie dürfen diesen Benutzer nicht löschen. Sollte die Kombination Benutzername/Kennwort Unbefugten bekannt geworden sein, ändern Sie das Kennwort dieses Database Manager-Benutzers. Verwenden Sie dazu das DBM-Kommando Strukturlink user_put.


-24944: ERR_USRDELSELF - cannot delete current user (SAP-Bibliothek - Grundwissen)

-24944: ERR_USRDELSELF - cannot delete current user

Erläuterung:

Der aktuell angemeldete Benutzer darf nicht gelöscht werden.

Benutzerreaktion:

Melden Sie sich mit einem anderen Benutzer am DBM-Server an, und führen Sie das DBM-Kommando erneut aus.


-24945: ERR_TOFEWPARAM - to few parameters (SAP-Bibliothek - Grundwissen)

-24945: ERR_TOFEWPARAM - to few parameters

Erläuterung:

Das DBM-Kommando wurde mit zu wenig Parametern versehen.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe entsprechend der Dokumentation der Strukturlink DBM-Kommandos und führen Sie diese erneut aus.


-24946: ERR_TOMANYPARAM - to many parameters (SAP-Bibliothek - Grundwissen)

-24946: ERR_TOMANYPARAM - to many parameters

Erläuterung:

Das DBM-Kommando wurde mit zu vielen Parametern versehen.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe entsprechend der Dokumentation der Strukturlink DBM-Kommandos und führen Sie diese erneut aus.


-24947: ERR_DBNAME - do not use dbname (SAP-Bibliothek - Grundwissen)

-24947: ERR_DBNAME - do not use dbname

Erläuterung:

Das DBM-Kommando lässt sich nicht auf eine Datenbankinstanz anwenden.

Benutzerreaktion:

Verzichten Sie bei der Ausführung des DBM-Kommandos auf die Angabe eines Datenbanknamens.


-24948: ERR_NODBNAME - database name required (SAP-Bibliothek - Grundwissen)

-24948: ERR_NODBNAME - database name required

Erläuterung:

Das DBM-Kommando lässt sich nur auf eine Datenbankinstanz anwenden.

Benutzerreaktion:

Geben Sie mit der Strukturlink Option -d dem DBM-Server den Namen der zu verwendenden Datenbankinstanz bekannt.


-24949: ERR_USREXISTS - user entry already exists (SAP-Bibliothek - Grundwissen)

-24949: ERR_USREXISTS - user entry already exists

Erläuterung:

Das verwendete DBM-Kommando ist nicht möglich, da der Benutzername bereits existiert.

Benutzerreaktion:

Verwenden Sie einen Namen, der noch nicht für einen Benutzer vergeben wurde oder löschen Sie den vorhandenen Benutzer. Einen Benutzer sollten Sie nur löschen, wenn er nicht mehr benötigt wird. Alle gespeicherten Einstellungen zu diesem Benutzer gehen dabei verloren. Verwenden Sie zum Löschen des Benutzers das DBM-Kommando Strukturlink user_delete.


-24950: ERR_USRFAIL - user authorization failed (SAP-Bibliothek - Grundwissen)

-24950: ERR_USRFAIL - user authorization failed

Erläuterung:

Die Autorisierung am DBM-Server ist fehlgeschlagen. Der Benutzername und/oder das verwendete Kennwort sind nicht korrekt.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe und melden Sie sich erneut am DBM-Server an. Im Database Manager GUI können Sie die für die Datenbankinstanz hinterlegten Benutzerdaten korrigieren.


-24951: ERR_USRREAD - could not read user data (SAP-Bibliothek - Grundwissen)

-24951: ERR_USRREAD - could not read user data

Erläuterung:

Die Daten der/des Database Manager-Benutzer(s) (DBM-Benutzer) konnten nicht gelesen werden.

Benutzerreaktion:

Überprüfen Sie die Dateisystemattribute und die Betriebssystem-Benutzerrechte des User Profile Containers. Diese Datei trägt den Namen <database_name>.upc. Unter Windows finden Sie diese Datei im Verzeichnis config der Datenbankinstallation. Auf UNIX-Systemen ist diese Datei unter <independent_data>/config abgelegt. Überprüfen Sie mit dem DBM-Kommando Strukturlink user_getall das Vorhandensein des betreffenden Benutzers.


-24952: ERR_USRSAVE - could not save user data (SAP-Bibliothek - Grundwissen)

-24952: ERR_USRSAVE - could not save user data

Erläuterung:

Die Daten des DBM-Benutzers konnten nicht gespeichert werden.

Benutzerreaktion:

Überprüfen Sie die Dateisystemattribute und die Betriebssystem-Benutzerrechte des User Profile Containers. Diese Datei trägt den Namen <database_name>.upc. Unter Windows finden Sie diese Datei im Verzeichnis config der Datenbankinstallation. Auf UNIX-Systemen ist diese Datei unter <independent_data>/config abgelegt. Überprüfen Sie die Verfügbarkeit von ausreichendem Speicherplatz auf der betroffenen Festplatte.


-24953: ERR_DBEXIST - database instance already exists (SAP-Bibliothek - Grundwissen)

-24953: ERR_DBEXIST - database instance already exists

Erläuterung:

Das verwendete DBM-Kommando ist nicht möglich, da die Datenbankinstanz bereits existiert.

Benutzerreaktion:

Verwenden Sie einen Namen, der noch nicht für eine Datenbankinstanz vergeben wurde, oder löschen Sie die vorhandene Datenbankinstanz. Eine Datenbankinstanz sollten Sie nur löschen, wenn sie nicht mehr benötigt wird. Alle gespeicherten Daten und die Konfiguration der Datenbankinstanz gehen dabei verloren. Verwenden Sie zum Löschen der Datenbankinstanz das DBM-Kommando Strukturlink db_drop.


-24954: ERR_BANOAUTOMED - no autolog medium found in media list (SAP-Bibliothek - Grundwissen)

-24954: ERR_BANOAUTOMED - no autolog medium found in media list

Erläuterung:

Das Datenbanksystem konnte keine Sicherungsvorlage finden, die für die automatische Log-Sicherung verwendet werden kann.

Benutzerreaktion:

Überprüfen Sie die Definition Ihrer Sicherungsvorlagen.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungsvorlagen und Datenträger


-24955: ERR_BANOSAVETYPE - backup type not defined (SAP-Bibliothek - Grundwissen)

-24955: ERR_BANOSAVETYPE - backup type not defined

Erläuterung:

Die Sicherungsmediendefinition enthält keinen Backup-Type (LOG, DATA oder PAGES).

Benutzerreaktion:

Korrigieren Sie die Mediendefinition, oder geben Sie den Backup-Type bei dem fehlgeschlagenen Kommando explizit an.


-24956: ERR_BASAVETYPECON - backup type conflicts with medium definition

Erläuterung:

Dieser Fehler kann beim Sichern oder Wiederherstellen auftreten.

Die in der Sicherungsvorlage definierte Sicherungsart (LOG, DATAoder PAGES) und die beim Sichern oder Wiederherstellen angegebene Sicherungsart stimmen nicht überein.

Benutzerreaktion:

Ändern Sie die Sicherungsart in der Definition der Sicherungsvorlage oder geben Sie beim Sichern oder Wiederherstellen die zur Sicherungsvorlage passende Sicherungsart an.

Um ältere Sicherungen wiederherzustellen, müssen Sie die Definition der Sicherungsvorlage unter Umständen wieder ändern.


-24957: ERR_NOUSER - required user not set (SAP-Bibliothek - Grundwissen)

-24957: ERR_NOUSER - required user not set

Erläuterung:

Es wurde versucht ein DBM-Kommando auszuführen, das implizit die Daten eines Benutzers der SAP-Anwendung verwendet, die auf dem DBM-Server für diese Datenbankinstanz hinterlegt sind. Diese Benutzerdaten fehlen jedoch auf dem DBM-Server.

Benutzerreaktion:

Hinterlegen Sie zunächst die erforderlichen Benutzerdaten (siehe: Strukturlink user_sap) und führen Sie das DBM-Kommando erneut aus. Alternativ dazu können Sie zusammen mit dem DBM-Kommando auch explizit den Namen und das Kennwort des Benutzers angeben.

Im Database Manager GUI verwenden Sie den Kommandozeilendialog für die Eingabe dieses DBM-Kommandos (siehe: Strukturlink Database Manager CLI verwenden).


-24958: ERR_BAOVERWRITE - file already exists, cannot overwrite (SAP-Bibliothek - Grundwissen)

-24958: ERR_BAOVERWRITE - file already exists, cannot overwrite

Erläuterung:

Dieser Fehler kann beim Sichern auftreten.

Sie haben eine Sicherungsvorlage angegeben, die bereits für eine Sicherung verwendet wurde und die mit der Eigenschaft nicht überschreibbar definiert wurde.

Benutzerreaktion:

Verwenden Sie eine andere Sicherungsvorlage, ändern Sie die Definition der Sicherungsvorlage oder löschen Sie die bereits erstellte Sicherung mit Betriebssystemmitteln.

Wenn Sie die Sicherung auf einem Datenträger löschen oder überschreiben, gehen alle dort gespeicherten Daten verloren.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungsvorlagen und Datenträger


-24959: ERR_XPOVERFLOW - value out of margin (SAP-Bibliothek - Grundwissen)

-24959: ERR_XPOVERFLOW - value out of margin

Erläuterung:

Der verwendete Wert für einen Datenbankparameter ist unzulässig. Es wurde ein unzulässiger Datentyp gewählt (z.B. Text für einen numerischen Parameter) oder die Grenzen des Datentyps überschritten (z.B. zu große Zahl oder zu langer Text).

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24960: ERR_DBRUN - database is running (SAP-Bibliothek - Grundwissen)

-24960: ERR_DBRUN - database is running

Erläuterung:

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE oder ADMIN. Das verwendete DBM-Kommando ist in diesem Betriebszustand unzulässig.

Benutzerreaktion:

Bringen Sie zunächst die Datenbankinstanz in den Betriebszustand OFFLINE und wiederholen Sie das Kommando.

Ein Stoppen der Datenbankinstanz in den Betriebszustand OFFLINE beendet die Verbindungen aller angemeldeten Benutzer bzw. Programme zur Datenbankinstanz.


-24961: ERR_STATE - cannot determine current db state (SAP-Bibliothek - Grundwissen)

-24961: ERR_STATE - cannot determine current db state

Erläuterung:

Der Betriebszustand der Datenbankinstanz konnte nicht korrekt ermittelt werden. Damit kann die Zulässigkeit von DBM-Kommandos nicht mehr bestimmt werden.

Benutzerreaktion:

Prüfen Sie die Datenbankprozesse mit Betriebssystemmitteln. Versuchen Sie mit einer Datenbankanwendung (z.B. Strukturlink SQL Studio) eine Verbindung zur Datenbankinstanz herzustellen. Gelingt dies, ist die Datenbankinstanz im Betriebszustand ONLINE und (evtl. mit Einschränkungen) betriebsbereit.

Nutzen Sie weitere vorhandene Möglichkeiten (z.B. Protokolldateien), um den Zustand der Datenbankinstanz zu überprüfen. Wenden Sie sich ggf. an den Support.

Sind Ihre Anwendungen bzw. Benutzer nicht mehr in der Lage, eine Verbindung zur Datenbankinstanz aufzubauen, sollte die Datenbankinstanz neu gestartet und so in einen definierten Zustand gebracht werden.


-24962: ERR_VOLTYPE - wrong volume type (SAP-Bibliothek - Grundwissen)

-24962: ERR_VOLTYPE - wrong volume type

Erläuterung:

Es wurde ein unbekannter oder unzulässiger Typ für ein Volume verwendet.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe.


-24963: ERR_VOLCHECK - error while checking volume (SAP-Bibliothek - Grundwissen)

-24963: ERR_VOLCHECK - error while checking volume

Erläuterung:

Es wurde versucht, ein ungültiges Volume zu konfigurieren. Das Volume konnte mit den verwendeten Parametern nicht gefunden bzw. angelegt werden.

Benutzerreaktion:

Überprüfen Sie Ihre Eingabe und Ihre Betriebssystemkonfiguration. Nehmen Sie entsprechende Korrekturen vor, und wiederholen Sie die Konfiguration des Volume.


-24964: ERR_EXECUTE - error in program execution (SAP-Bibliothek - Grundwissen)

-24964: ERR_EXECUTE - error in program execution

Erläuterung:

Beim Aufruf eines Programms oder einer Betriebssystemanweisung durch den DBM-Server ist ein Fehler aufgetreten. Das Programm bzw. die Anweisung selbst wurde nicht gefunden oder stellte bei seiner Ausführung einen Fehler fest.

Benutzerreaktion:

Achten Sie auf den gelieferten Exit-Code und die ebenfalls gelieferte Ausgabe des Programms bzw. der Anweisung. Überprüfen Sie das Vorhandensein des Programms bzw. der Anweisung auf dem Server, und beziehen Sie die Dokumentation des Programms bzw. der Anweisung in die Fehlersuche ein.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24965: ERR_SYSLOGON - logon to system failed (SAP-Bibliothek - Grundwissen)

-24965: ERR_SYSLOGON - logon to system failed

Erläuterung:

Die Anmeldung des DBM-Server am Betriebssystem konnte nicht durchgeführt werden, oder die verwendete Anweisung erfordert eine vorherige Anmeldung am Betriebssystem.

Benutzerreaktion:

Prüfen Sie Ihre Eingabe sowie die Rechte des verwendeten Benutzers. Unter Windows muss der Benutzer das Recht logon as batch job haben. Ebenfalls muss der aktuelle Benutzer des DBM-Servers das Recht haben, sich unter einem anderen Benutzerkonto anzumelden.


-24966: ERR_LOGON - logon to DBM server failed (SAP-Bibliothek - Grundwissen)

-24966: ERR_LOGON - logon to DBM server failed

Erläuterung:

Es wurde eine ungültige Benutzer/Kennwort-Kombination verwendet, oder die verwendete Anweisung erfordert eine vorherige Anmeldung.

Benutzerreaktion:

Korrigieren Sie Ihre Benutzer/Kennwort-Eingabe, oder melden Sie sich zunächst am DBM-Server an.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24967: ERR_SYSTEM - system call error (SAP-Bibliothek - Grundwissen)

-24967: ERR_SYSTEM - system call error

Erläuterung:

Die Verwendung einer Funktion des Betriebssystems ist fehlgeschlagen.

Benutzerreaktion:

Achten Sie auf den erweiterten Fehlertext, der die Meldung des Betriebssystems näher beschreibt.


-24968: ERR_XPREADONLY - parameter is read only (SAP-Bibliothek - Grundwissen)

-24968: ERR_XPREADONLY - parameter is read only

Erläuterung:

Der verwendete Datenbankparameter darf nicht geändert werden.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, ist der Support zu benachrichtigen.


-24969: ERR_XPDIRTY - param file is dirty (SAP-Bibliothek - Grundwissen)

-24969: ERR_XPDIRTY - param file is dirty

Erläuterung:

Es wurde versucht, eine Änderung an den Datenbankparameter vorzunehmen, ohne eine bereits vorher getätigte Änderung durch einen Neustart der Datenbankinstanz auf Lauffähigkeit zu prüfen.

Benutzerreaktion:

Starten Sie die Datenbankinstanz, und wiederholen Sie die Änderung des Datenbankparameters.

Ein erneutes Starten der Datenbankinstanz beendet die Verbindungen aller angemeldeten Benutzer bzw. Programme zur Datenbankinstanz.


-24970: ERR_XPNOMODIFY - parameter must not be modified (SAP-Bibliothek - Grundwissen)

-24970: ERR_XPNOMODIFY - parameter must not be modified

Erläuterung:

Der verwendete Datenbankparameter darf nicht verändert werden.

Benutzerreaktion:

Korrigieren Sie den Datenbankparameter auf seinen Ausgangswert.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24971: ERR_XPNOCHECK - no running parameter check (SAP-Bibliothek - Grundwissen)

-24971: ERR_XPNOCHECK - no running parameter check

Erläuterung:

Das Wiederaufsetzen beim Prüfen der Datenbankparameter nach der Korrektur eines einzelnen Parameters war nicht möglich, da kein Checklauf aktiv war.

Benutzerreaktion:

Starten Sie das Prüfen der Datenbankparameter erneut.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24972: ERR_XPINVCONF - invalid value (SAP-Bibliothek - Grundwissen)

-24972: ERR_XPINVCONF - invalid value

Erläuterung:

Es wurde versucht einen Datenbankparameter zu bestätigen. Dabei wurde ein ungültiger Wert verwendet oder ein Parameter verwendet, für den kein Request vorlag.

Benutzerreaktion:

Korrigieren Sie Ihre Eingabe oder prüfen Sie nochmals die Datenbankparameter (z.B. mit dem DBM-Kommando Strukturlink param_checkall).

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24973: ERR_XPCHECK - param check failure/request (SAP-Bibliothek - Grundwissen)

-24973: ERR_XPCHECK - param check failure/request

Erläuterung:

Das Überprüfen der Datenbankparameter anhand der in der Parameterhilfedatei hinterlegten Regeln und Eigenschaften war nicht erfolgreich. Im erweiterten Meldungstext finden Sie nähere Information.

Benutzerreaktion:

Korrigieren Sie den Wert des Datenbankparameters entsprechend der Dokumentation.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24974: ERR_XPSESSION - param session active (SAP-Bibliothek - Grundwissen)

-24974: ERR_XPSESSION - param session active

Erläuterung:

Bei einer aktiven Parametersitzung wird der Start einer weiteren Sitzung abgelehnt.

Benutzerreaktion:

Überprüfen Sie die Reihenfolge Ihrer DBM-Kommandos. Beenden Sie ggf. eine existierende Parametersitzung mit Strukturlink param_commitsession oder Strukturlink param_abortsession. Alternativ können Sie auch die aktive Parametersitzung für Ihr Kommando benutzen.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24975: ERR_NOXPSESSION - param session inactive (SAP-Bibliothek - Grundwissen)

-24975: ERR_NOXPSESSION - param session inactive

Erläuterung:

Einige DBM-Kommandos aus dem Themenkreis setzen eine Parametersitzung voraus. Diese Sitzung war im vorliegenden Fall jedoch nicht aktiv.

Benutzerreaktion:

Überprüfen Sie die Reihenfolge Ihrer Kommandos. Starten Sie zur Bearbeitung der Datenbankparameter zunächst eine Parametersitzung mit dem DBM-Kommando Strukturlink param_startsession.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24976: ERR_PARAMEXIST - param file of database already exists (SAP-Bibliothek - Grundwissen)

-24976: ERR_PARAMEXIST - param file of database already exists

Erläuterung:

Für die angegebene Datenbankinstanz existiert bereits eine Parameterdatei. Die Initialisierung der Parameterdatei ist nur möglich, wenn keine Parameterdatei existiert. Damit wird der Verlust einer Konfiguration verhindert.

Benutzerreaktion:

Löschen Sie die Parameterdatei explizit mit dem DBM-Kommando Strukturlink param_rmfile oder auf Dateisystemebene. Dabei verlieren Sie die aktuelle Konfiguration der Datenbankinstanz.


-24977: ERR_COMMAND - unknown command <command> (SAP-Bibliothek - Grundwissen)

-24977: ERR_COMMAND - unknown command <command>

Erläuterung:

Das spezifizierte DBM-Kommando ist unbekannt.

Benutzerreaktion:

Geben Sie ein korrektes Kommando an. Achten Sie dabei auf Groß- und Kleinschreibung.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24978: ERR_XPSYNTAX - xparam syntax error (SAP-Bibliothek - Grundwissen)

-24978: ERR_XPSYNTAX - xparam syntax error

Erläuterung:

Die Beschreibung der Datenbankparameter in der Parameterhilfedatei ist fehlerhaft.

Benutzerreaktion:

Achten Sie auf den erweiterten Fehlertext, und korrigieren Sie den Fehler in der Datei cserv.pcf in Verzeichnis env der Datenbankinstallation.


-24979: ERR_XPNOTFOUND - parameter not found (SAP-Bibliothek - Grundwissen)

-24979: ERR_XPNOTFOUND - parameter not found

Erläuterung:

Der angebene Datenbankparameter existiert nicht in der Parameterhilfedatei.

Benutzerreaktion:

Überprüfen Sie die Korrektheit des Parameternamens. Achten Sie auch auf Groß- und Kleinschreibung.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24980: ERR_NOHELP - xparam help file not found (SAP-Bibliothek - Grundwissen)

-24980: ERR_NOHELP - xparam help file not found

Erläuterung:

Die Parameterhilfedatei, die die Datenbankparameter beschreibt, konnte nicht geöffnet werden.

Benutzerreaktion:

Überprüfen Sie das Vorhandensein und die Korrektheit der Datei cserv.pcf im Verzeichnis env Ihrer Datenbankinstallation. Überprüfen Sie ebenfalls die Zugriffsrechte des DBM-Server auf diese Datei.


-24981: ERR_HIENTRYNOTFOUND - backup history entry not found (SAP-Bibliothek - Grundwissen)

-24981: ERR_HIENTRYNOTFOUND - backup history entry not found

Erläuterung:

Der angeforderte Eintrag existiert nicht in der Sicherungshistorie.

Benutzerreaktion:

Korrigieren Sie die Parameter Ihres DBM-Kommandos zum Lesen der Sicherungshistorie.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24982: ERR_ERR_NOHISTORY - backup history file not found (SAP-Bibliothek - Grundwissen)

-24982: ERR_ERR_NOHISTORY - backup history file not found

Erläuterung:

Es ist keine Sicherungshistorie vorhanden.

Benutzerreaktion:

Eine Sicherungshistorie ist nur vorhanden, wenn bereits Sicherungsoperationen durchgeführt wurden. Vorher kann die Funktionalität zur Sicherungshistorie nicht benutzt werden.


-24983: ERR_BANOVALIDTYPE - invalid backup type (SAP-Bibliothek - Grundwissen)

-24983: ERR_BANOVALIDTYPE - invalid backup type

Erläuterung:

Der angegebene Backup-Type ist ungültig.

Benutzerreaktion:

Geben Sie in Ihrem DBM-Kommando einen gültigen Backup-Type an.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24984: ERR_MENOVALID - invalid medium definition (SAP-Bibliothek - Grundwissen)

-24984: ERR_MENOVALID - invalid medium definition

Erläuterung:

Die Definition der Sicherungsvorlage ist ungültig.

Benutzerreaktion:

● Überprüfen Sie Ihre Eingaben.

● Wenn Sie den Fehler nicht beheben können, dann wenden Sie sich an den Support.

Siehe Support.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungsvorlagen und Datenträger


-24985: ERR_MENOTFOUND - medium not found (SAP-Bibliothek - Grundwissen)

-24985: ERR_MENOTFOUND - medium not found

Erläuterung:

Sie haben eine Sicherungsvorlage angegeben, für die keine Definition gibt.

Benutzerreaktion:

● Prüfen Sie, ob Sie den Namen der Sicherungsvorlage korrekt angegeben haben.

● Verwenden Sie eine andere Sicherungsvorlage.

● Legen Sie eine neue Sicherungsvorlage mit diesem Namen an.

● Wenn Sie den Fehler nicht beheben können, dann wenden Sie sich an den Support.

Siehe Support.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungsvorlagen und Datenträger


-24986: ERR_NOMEDIA - media file not found (SAP-Bibliothek - Grundwissen)

-24986: ERR_NOMEDIA - media file not found

Erläuterung:

Für die Datenbankinstanz wurden noch keine Sicherungsvorlagen definiert.

Benutzerreaktion:

● Definieren Sie eine geeignete Sicherungsvorlage.

● Prüfen Sie, ob der DBM-Server auf seine Konfigurationsdateien zugreifen kann. Prüfen Sie die Zugriffsrechte.

Siehe auch:

Konzepte des Datenbanksystems, Sicherungsvorlagen und Datenträger


-24987: ERR_TOSMALL - packet size too small for answer (SAP-Bibliothek - Grundwissen)

-24987: ERR_TOSMALL - packet size too small for answer

Erläuterung:

Der von der Anwendung zur Verfügung gestellte Speicherplatz für die Antwort des DBM-Servers ist nicht ausreichend.

Benutzerreaktion:

Verändern Sie Ihr DBM-Kommando, so dass die Größe der Antwort verringert wird.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24988: ERR_SQL - sql error (SAP-Bibliothek - Grundwissen)

-24988: ERR_SQL - sql error

Erläuterung:

Bei Übergabe einer SQL-Anweisung an den Datenbankkern ist ein Fehler aufgetreten.

Benutzerreaktion:

Beachten Sie ggf. die zusätzlich vorhandene Fehlermeldung des Datenbankkerns, und korrigieren Sie Ihre Eingabe entsprechend.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24989: ERR_NOHISTORYSESSION - no backup history session available

Erläuterung:

Das DBM-Kommando ist nur bei geöffneter Sicherungshistorie möglich.

Benutzerreaktion:

Öffnen Sie zunächst die Sicherungshistorie mit Strukturlink backup_history_open, und beachten Sie ggf. auftretende Fehler.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24990: ERR_ NOBACKUPSESSION - no backup session available (SAP-Bibliothek - Grundwissen)

-24990: ERR_ NOBACKUPSESSION - no backup session available

Erläuterung:

Das DBM-Kommando ist nur bei aktiver Sicherung oder Wiederherstellung zulässig.

Benutzerreaktion:

Starten Sie zunächst die erforderliche Sicherungssitzung mit den DBM-Kommandos Strukturlink backup_start oder Strukturlink recover_start, und führen Sie dann entsprechend dem Verlauf der Sicherung/Wiederherstellung weitere Kommandos aus.

Prüfen Sie, ob das Starten der Sicherung/Wiederherstellung erfolgreich war.

Beachten Sie, dass das Einlesen einer Datenbanksicherung den aktuellen Zustand Ihrer Datenbankinstanz überschreibt.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24993: ERR_RTEEXT - runtime environment error (SAP-Bibliothek - Grundwissen)

-24993: ERR_RTEEXT - runtime environment error

Erläuterung:

Die Datenbanklaufzeitumgebung konnte eine Funktion nicht korrekt ausführen.

Benutzerreaktion:

Beachten Sie die zusätzlich ausgegebene Fehlermeldung der Laufzeitumgebung.


-24994: ERR_RTE - runtime environment error (SAP-Bibliothek - Grundwissen)

-24994: ERR_RTE - runtime environment error

Erläuterung:

Die Datenbanklaufzeitumgebung konnte eine Funktion nicht korrekt ausführen.

Benutzerreaktion:

Beachten Sie die zusätzlich ausgegebene Fehlermeldung der Laufzeitumgebung.


-24995: ERR_MEM - memory allocation error (SAP-Bibliothek - Grundwissen)

-24995: ERR_MEM - memory allocation error

Erläuterung:

Das Betriebssystem konnte dem DBM-Server nicht ausreichend Hauptspeicher zur Verfügung stellen.

Benutzerreaktion:

Korrigieren Sie ein ggf. vorhandenes Limit bei den Nutzerrechten des DBM-Server.

Prüfen Sie den allgemeinen Zustand Ihres Betriebssystems auf Probleme bei der Verwaltung des Hauptspeichers.


-24996: ERR_PARAM - wrong parameters (SAP-Bibliothek - Grundwissen)

-24996: ERR_PARAM - wrong parameters

Erläuterung:

Ihr DBM-Kommando wurde mit falschen Parametern ausgeführt.

Benutzerreaktion:

Überprüfen Sie die Eingabe. Prüfen Sie ebenfalls, ob das Kommando einen Datenbanknamen oder eine spezielle Sitzung voraussetzt.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24997: ERR_FILE - file handling error (SAP-Bibliothek - Grundwissen)

-24997: ERR_FILE - file handling error

Erläuterung:

Der Zugriff auf eine Datei war fehlerhaft.

Benutzerreaktion:

Möglicherweise fehlen die erforderlichen Nutzerrechte. Prüfen Sie daher die Installation des DBM-Server und dessen aktuelle Rechte.

Prüfen Sie auch, ob die Datei beschädigt ist.


-24998: ERR_NOTIMPL - sorry, command not yet implemented (SAP-Bibliothek - Grundwissen)

-24998: ERR_NOTIMPL - sorry, command not yet implemented

Erläuterung:

Ihr DBM-Kommando steht in dieser Version nicht zur Verfügung.

Benutzerreaktion:

Wählen Sie ein alternatives Kommando.

Tritt der Fehler im Database Manager GUI auf, und Sie haben keine Möglichkeit zur Korrektur, wenden Sie sich an den Support.


-24999: ERR - common error (SAP-Bibliothek - Grundwissen)

-24999: ERR - common error

Erläuterung:

Es ist ein Fehler aufgetreten, den der Database Manager nicht näher analysieren konnte.

Benutzerreaktion:

Wenden Sie sich an den Support.


Von -25000 bis -25999 (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Von -25000 bis -25999

Fehlermeldungen des Loader

-25002 | No database connection possible - missing database name; specify the database name in the USE USER command
-25003 | Getting hostname of database host failed: <error_code> = <error_text>
-25004 | A connection to the database could not be established: <error_code> = <error_text>
-25005 | User (<user_name>) logon to database failed: <error_text>
-25006 | Connect with userkey '<user_key>' failed: <error_text>
-25007 | No connection to server db '<database_name>' established
-25008 | Logon failure; previous user's (<user_name>) connection was restored
-25009 | Failure in db communication (<type>): <return_code> = <error_text>
-25010 | <SQL_error_text>
-25011 | Error executing internal SQL statement '<statement>' : '<error_text>'
-25012 | No user connection to server db established
-25018 | Error changing log file owner to current user '<user_name>' (Error: '<error_text>')
-25019 | Error opening server log file '<log_file_name>' (<error_text>). Opened temporary log file '<temp_log_file_name>'
-25020 | No more memory available
-25021 | Error switching connected user to <user_name> : <error_text>
-25022 | Received cancel request; stopping execution
-25024 | Error switching current schema to <schema_name> ; <error_text>
-25109 | Command not implemented
-25201 | Column '<column_name>' - INTEGER field: 1, 2 or 4 bytes long (double if HEX)
-25202 | Column '<column_name>' - REALfield: 4 or 8 bytes long (double if HEX)
-25203 | Column '<column_name>' - DECIMALfield: 20 bytes maximum (double if HEX)
-25204 | Column '<column_name>' - ZONEDfield: 20 bytes maximum (double if HEX)
-25205 | Declare USAGE between 50% and 100%
-25206 | USAGE value of '0 rows' not allowed
-25207 | USAGE value of row(s) too high; maximum number of records possible on a single db page: <number>
-25208 | Invalid position specification (negative values not allowed)
-25209 | Invalid FRACTION specification (negative values not allowed)
-25210 | Invalid SCALE specification. Scale range: -127 <= SCALE <= 127
-25211 | Invalid ROUND specification (0 <= ROUND_value <= 18)
-25212 | Invalid TRUNC specification (0 <= TRUNC_value <= 18)
-25213 | Invalid file format specification: given formats rule each other out
-25214 | The specification of a separator/delimiter is not allowed together with FWV
-25216 | File option FWV required
-25217 | End position for column <column_name> lower than start position
-25218 | No column specified but file format is FWV
-25219 | Columns have to be specified in left-to-right order (positions in ascending order)
-25220 | Wrong separator/delimiter specification
-25221 | Wrong decimal specification
-25222 | Wrong Boolean specification
-25223 | Wrong null specification
-25225 | Wrong number specification
-25226 | A maximum of 1024 columns can be specified for one table
-25227 | Specification of conditions exceeds allowed count of conditions
-25228 | Incorrect date-time format, all patterns accepted in the SET menu are valid
-25229 | Incorrect comparison operator in condition
-25230 | Cannot execute command DATAEXTRACT FOR <load_type>; specify an output file for commands
-25231 | ROUND or TRUNC specification not allowed for this column
-25232 | Wrong keyword
-25233 | Some column descriptions with end position but file format is CSV
-25234 | Some column descriptions without end position but file format is FWV
-25235 | Some positions specified more than once
-25236 | Some positions overlap
-25237 | Cannot execute DATAUPDATE command; specify set columns
-25238 | Cannot execute DATAUPDATE command; specify access columns
-25239 | Specified value '<value>'is not a valid integer
-25240 | Incomplete logon parameters; password missing
-25242 | Database identifier too long
-25243 | Error parsing <time> mask: <error_text>
-25244 | Loader CONSTRAINT violation: <error_text>
-25245 | Error: specify CATALOG, DATA, and PACKAGE stream
-25247 | Error: specify CATALOG or DATA stream
-25249 | Invalid Isolation Level specification: possible values are: 0, 1, 10, 15, 2, 20, 3, 30
-25250 | Error building URI for encrypted connection: <error_text>
-25251 | Code page to set (<code_page_name>) not found in system table SYSLOADER.CODEPAGE. The privilege to change the content of this table is restricted to SYSDBA
-25281 | Syntax error at position <position> (<error_text>). Check for typing errors
-25301 | Invalid input for date or time column: <input_value>
-25302 | This value is not a valid number: '<input_value>'
-25303 | Input value does not match key order or range specification
-25304 | Columns for key (KEY) or search condition missing
-25305 | Data for key columns exceeds allowed key length
-25306 | The value is not a valid HEX constant: <input_value>
-25308 | CONSTRAINT condition violated
-25309 | Invalid input for BOOLEAN column: <input_value>
-25310 | Column '<column_name>' must not contain NULL values
-25311 | No Data for NOT NULL - column without default (<column_name>). You have either not specified this column in the command or there is no data in the data file for this column
-25313 | Overflow occurred, execution aborted
-25314 | Fractional part too small for column '<column_name>', minimum length: <length>
-25315 | Column data type of column '<column_name>' and external data type are not compatible
-25316 | Table contains at least one column defined as LONG; IMPORT in PAGE format rejected
-25317 | Constant must be compatible with column type and length (column: '<column_name>')
-25318 | Syskey violation (the computed value exceeds the highest possible syskey value)
-25319 | Missing data for specified column '<column_name>'
-25320 | The LONG value could not be loaded into column
-25321 | This condition value is not a valid number: '<value>'
-25322 | This condition value was truncated and cannot be used: '<value>'
-25323 | Data type of null value representation for column '<column_name>' is incompatible with the column data type
-25324 | Errors checking length of column specifications. See loader server log file for more information
-25325 | Errors checking compatibility of external and db data types. See loader server log file for more information
-25326 | The exported number (column '<column_name>') was truncated
-25327 | Error(s) exporting record <record_no>; start position of incorrect record in data file:<position>
-25328 | Some error(s) while extracting data. See loader server log file for more information
-25329 | The given data file '<file_name>' was not generated using EXPORT in PAGE Format (<error_text>)
-25330 | The page sizes of the source system and the target system do not match (source:<page_size>, target:<page_size>)
-25331 | This is a restricted statement, user must be SYSDBA
-25332 | Error getting schema definition of table <table_name> (<SQL_error_text>)
-25333 | Error getting index definitions for table <table_name> (<SQL_error_text>)
-25334 | File counter for data file exceeded maximum value of 9999
-25335 | Error restoring single table using data file with multiple table data; specify single table data file
-25336 | Error restoring multiple tables using data file with single table data; specify data file created using EXPORT DB or EXPORT USER
-25337 | Error restoring table <table_name>; no table data found in data file <file_name>
-25338 | Error during restart IMPORT; restart entry <position> not found in mapping file <file_name>
-25339 | Error during restart IMPORT; file <file_name> could not be opened/read
-25340 | UCS2 conversion error; character string contains invalid characters or character sequences
-25341 | Error generating 'create table/index statements': <error_text>
-25342 | Error restoring table <table_name>; table exists but source table schema and target table schema are different
-25343 | Column name(s) or number(s) do not match column names/numbers in select list: (<column_names>)
-25344 | Incorrect field length for column '<column_name>', minimum length <length_value>
-25345 | Definition of source and target table <table_name> do not match: <description>
-25346 | Communication packet size too small to run IMPORT for PAGES of <N>kb. Increase value of parameter _PACKET_SIZE and restart the database
-25347 | Encoding type of source and target database do not match: source = <type>, target = <type>
-25348 | Different byte swap of source and target computer. The Loader must run on the same processor memory architecture for EXPORT and IMPORT in PAGE format
-25349 | Error exporting <type> data of table <table_name>. See loader server log file for more information
-25350 | Conversion from UNICODE data to ASCII data is not supported. This conversion may cause information loss
-25351 | No long file info given for LONG column '<column_name>'
-25352 | Errors analyzing long file information. See loader server log file for more information
-25353 | Specified maximum number of LONG data files for column '<column_name>' exceeded
-25354 | LONGFILE specification missing or incorrect
-25355 | Error processing LONG value (column '<column_name>'): <error_code>
-25356 | Error processing LONG value(s): <error_text>
-25364 | Name of table to import <table_name> and the table currently being processed in data file <file_name> do not match
-25365 | Data file corrupted: trailer not found
-25366 | Data file corrupted: header not found
-25371 | Error converting data from <source_encoding> to <target_encoding>. Source contains invalid characters or character sequences
-25390 | Error generating CREATE TABLE/INDEX statements. Table name is ambiguous (different users have a table with this name)
-25391 | SQL statement is too long
-25392 | [MySQL MaxDB][SQLOD32 DLL][MaxDB] <error_text>
-25393 | Error during check if table <table_name> exists <error_text>
-25394 | Catalog of table <table_name> changed while processing <import> command; reparse failed; To restart the command append <record_no> to the infile specification
-25401 | Error reading system table SYSLOADER.CODEPAGE
-25402 | Error creating/granting system table SYSLOADER.CODEPAGE <code_page>; using codepage file
-25403 | Error opening/reading code page file <code_page>. Can't use code page conversion
-25404 | Invalid HEX constant <hex_value> found in code page file. The file might be corrupted
-25405 | Invalid ASCII values read or values not sorted in ascending order; The file might be corrupted
-25451 | Integrity violation (SQL_Error)
-25498 | Errors processing data for table <table_name>; No data imported/updated
-25499 | Errors processing data for table <table_name>. Data not completely imported/updated
-25500 | Errors processing command exceed maximum number of errors to ignore; processing stopped
-25501 | Error opening file <file_name> : <error_text>
-25502 | Error closing file <file_name> : <error_text>
-25503 | Error reading file <file_name> : <error_text>
-25504 | Error writing file <file_name> : <error_text>
-25505 | Error erasing file <file_name> : <error_text>
-25507 | Error truncating file <file_name> : <error_text>
-25508 | File <file_name> is not encoded as <encoding>
-25551 | Error importing statistics: <error_text>
-25552 | Error exporting statistics: <error_text>
-25601 | Error restoring table <table_name>. Table does not exist – table must be created before import
-25602 | Error restoring table <table_name>. Table is not empty
-25603 | Error processing IMPORT in PAGE Format. Loader versions used for EXPORT and IMPORT differ (EXPORT <version>, IMPORT <version>)
-25801 | Internal error [<file_name>,<line_no>,<error_code>]. Contact support


-25002: No database connection possible - missing database name; specify the database name in the USE USER command

Erläuterung:

Im Kommando zum Anmelden eines Datenbankbenutzers haben Sie keinen Datenbanknamen angegeben. Daher konnte sich der Datenbankbenutzer nicht an der Datenbank anmelden.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25003: Getting hostname of database host failed: <error_code> = <error_text>

Erläuterung:

Im Kommando zum Aufbau einer Verbindung wurde kein Name für den Datenbankrechner angegeben. Der Datenbankrechner konnte nicht ermittelt werden.

Benutzerreaktion:

Geben Sie im Strukturlink Loader-Kommando zum Aufbau der Datenbanksitzung den Namen des Rechners an, auf dem die Datenbankinstanz läuft, für die eine Verbindung aufgebaut werden soll. Starten Sie den Loader erneut.


-25004: A connection to the database could not be established: <error_code> = <error_text>

Erläuterung:

Die Verbindung zur Datenbankinstanz konnte nicht aufgebaut werden.

Benutzerreaktion:

Überprüfen Sie anhand des SQL-Fehlertextes, warum die Verbindung fehlgeschlagen ist. Beseitigen Sie die Ursache, und starten Sie den Loader erneut.


-25005: User (<user_name>) logon to database failed: <error_text>

Erläuterung:

Der angegebene Datenbankbenutzer konnte nicht an der angegebenen Datenbankinstanz angemeldet werden.

Benutzerreaktion:

Überprüfen Sie anhand des SQL-Fehlertextes, warum das Anmelden fehlgeschlagen ist. Beseitigen Sie die Ursache und starten Sie den Loader erneut.


-25006: Connect with userkey '<user_key>' failed: <error_text>

Erläuterung:

Die Verbindung zur Datenbankinstanz mit den angegeben Daten für einen Datenbankbenutzer konnte nicht aufgebaut werden.

Benutzerreaktion:

Überprüfen Sie anhand des SQL-Fehlertextes, warum die Verbindung fehlgeschlagen ist. Beseitigen Sie die Ursache und starten Sie den Loader erneut.


-25007: No connection to server db '<database_name>' established

Erläuterung:

Während der Ausführung eines Loader-Kommandos zum Exportieren oder Importieren bzw. einer SQL-Anweisung wird festgestellt, dass keine Verbindung zur angegebenen Datenbankinstanz besteht. Grund dafür kann sein, dass Sie nicht an der gewünschten Datenbankinstanz angemeldet sind.

Benutzerreaktion:

Melden Sie sich mit dem Strukturlink USE USER-Kommando an der Datenbankinstanz an, bevor Sie das Kommando oder die SQL-Anweisung ausführen.


-25008: Logon failure; previous user's (<user_name>) connection was restored

Erläuterung:

Beim Anmelden eines Datenbankbenutzers an die Datenbankinstanz ist ein Fehler aufgetreten. Der vorher bereits erfolgreich angemeldete Datenbankbenutzer ist wieder angemeldet worden.

Diese Fehlermeldung tritt nur dann auf, wenn nach dem erfolgreichen Anmelden eines Datenbankbenutzers und dem Bearbeiten von Export – und Importkommandos ein neuer Datenbankbenutzer nicht an der gleichen Datenbankinstanz angemeldet werden kann. Dieser Meldung geht die Fehlermeldung –25005 voraus.

Benutzerreaktion:

Da es sich hier lediglich um die Information handelt, dass eine alte Verbindung wiederhergestellt wurde, gehen Sie bitte vor, wie es in der Fehlermeldung -25005 angegeben ist.


-25009: Failure in db communication (<type>): <return_code> = <error_text>

Erläuterung:

Die Kommunikation zwischen dem Loader und der Datenbankinstanz erfolgt über den synchronen Austausch sogenannter Kommunikationspakete. Dabei schickt der Loader ein Paket mit dem zu bearbeitenden Kommando an die Datenbankinstanz (Request). Während die Datenbankinstanz das empfangene Kommando verarbeitet, wartet der Loader auf das Antwortpaket der Datenbankinstanz mit dem Resultat (Receive).

Während dieses Prozesses des Paketaustausches kann ein Fehler auftreten, wenn die Verbindung des Loader zur Datenbankinstanz abbricht oder die Datenbankinstanz nicht mehr verfügbar ist.

Benutzerreaktion:

Prüfen Sie anhand des Fehlertextes, warum die Kommunikation fehlgeschlagen ist. Beseitigen Sie die Ursache und starten Sie den Loader erneut.


-25010: <SQL_error_text> (SAP-Bibliothek - Grundwissen)

-25010: <SQL_error_text>

Erläuterung:

Mit dieser Fehlernummer werden SQL-Fehler ausgegeben, die von der Datenbankinstanz während der Bearbeitung von SQL-Anweisungen des Datenbankbenutzers gemeldet werden.

Benutzerreaktion:

Beseitigen Sie die Ursache des Fehlers und starten Sie den Loader erneut.


-25011: Error executing internal SQL statement '<statement>' : '<error_text>'

Erläuterung:

Eine zur Bearbeitung eines Export- oder Importkommandos vom Loader intern erzeugte SQL–Anweisung konnte nicht ausgeführt werden. Die Meldung gibt die Ursache des Fehlers mit aus.

Benutzerreaktion:

Beseitigen Sie die Ursache des Fehlers und starten Sie den Loader erneut.


-25012: No user connection to server db established (SAP-Bibliothek - Grundwissen)

-25012: No user connection to server db established

Erläuterung:

Sie haben ein Loader-Kommando oder eine SQL-Anweisung ausgeführt. Das Kommando bzw. die Anweisung wurde abgebrochen, da kein Datenbankbenutzer an der Datenbank angemeldet ist.

Benutzerreaktion:

Melden Sie einen Benutzer an der Datenbank an und führen Sie das Kommando erneut aus.


-25018: Error changing log file owner to current user '<user_name>' (Error: '<error_text>')

Erläuterung:

Dieser Fehler kann nur unter den Betriebssystemen UNIX oder Linux auftreten, wenn der Befehl SET LOGOWNER <user_name> ausgeführt wird.

Benutzerreaktion:

Prüfen Sie anhand des Fehlertextes, warum die Änderung fehlgeschlagen ist. Beseitigen Sie die Ursache und führen Sie die Anweisung erneut aus.


-25019: Error opening server log file '<log_file_name>' (<error_text>). Opened temporary log file '<temp_log_file_name>'

Erläuterung:

Das Öffnen der Protokolldatei des Loader ist fehlgeschlagen. Grund hierfür kann ein bereits laufender Loader auf dem gleichen Rechner sein. Da die Protokolldatei exklusiv geöffnet wird, können mehrere gleichzeitig auf einem Rechner gestartete Loader nicht auch gleichzeitig auf die Protokolldatei zugreifen.

Damit der gestartete Loader die Anweisungen trotzdem bearbeiten kann, öffnet er eine temporäre Protokolldatei mit dem in der Meldung angegebenen Namen.

Benutzerreaktion:

Es ist keine Benutzeraktion notwendig.


-25020: No more memory available (SAP-Bibliothek - Grundwissen)

-25020: No more memory available

Erläuterung:

Ein Kommando oder eine Anweisung kann aufgrund von Hauptspeicherbeschränkungen nicht ausgeführt werden.

Benutzerreaktion:

Es ist keine Benutzeraktion möglich.


-25021: Error switching connected user to <user_name> : <error_text>

Erläuterung:

Es ist ein Fehler beim Loader-Kommando EXPORT DB bzw. IMPORT DB aufgetreten.

Beim Export oder Import von Daten mit einem entsprechenden Kommando muss der Loader intern den Datenbankbenutzer wechseln, um benutzerspezifischen Daten bearbeiten zu können. Dieser interne Benutzerwechsel ist fehlgeschlagen.

Benutzerreaktion:

Beseitigen Sie die Ursache des Fehlers und führen Sie das Kommando erneut aus.


-25022: Received cancel request; stopping execution (SAP-Bibliothek - Grundwissen)

-25022: Received cancel request; stopping execution

Erläuterung:

Der Loader hat vom Datenbankbenutzer mittels der Tastenkombination STRG+C die Aufforderung erhalten, die weitere Bearbeitung der Kommandos und Anweisungen abzubrechen.

Benutzerreaktion:

Es ist keine Benutzeraktion notwendig.


-25024: Error switching current schema to <schema_name> ; <error_text>

Erläuterung:

Sie haben entweder ein Kommando zum Anmelden eines Datenbankbenutzers an einer Datenbank für ein bestimmtes Schema oder ein Kommando zum Wechseln des aktuellen Schemas ausgeführt. Das Kommando ist abgebrochen. Der Fehlertext beschreibt die Ursache des Fehlers.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25109: Command not implemented (SAP-Bibliothek - Grundwissen)

-25109: Command not implemented

Erläuterung:

Die angegebene Anweisung kann nicht ausgeführt werden, da im Loader die erforderliche Funktionalität nicht implementiert ist.

Benutzerreaktion:

Es ist keine Benutzereaktion möglich.


-25201: Column '<column_name>' - INTEGER field: 1, 2 or 4 bytes long (double if HEX)

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

In einer expliziten Spaltenbeschreibung ist ein Dateifeld vom Typ INTEGER angegeben, dessen Länge nicht der hier genannten entspricht.

Benutzerreaktion:

Korrigieren Sie die Positionsangabe und führen Sie das Kommando erneut aus.


-25202: Column '<column_name>' - REAL field: 4 or 8 bytes long (double if HEX)

-25202: Column '<column_name>' - REALfield: 4 or 8 bytes long (double if HEX)

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

In einer expliziten Spaltenbeschreibung ist ein Dateifeld vom Typ REAL angegeben, dessen Länge nicht der in der Fehlermeldung genannten entspricht.

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25203: Column '<column_name>' - DECIMAL field: 20 bytes maximum (double if HEX)

-25203: Column '<column_name>' - DECIMALfield: 20 bytes maximum (double if HEX)

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

In einer expliziten Spaltenbeschreibung ist ein Dateifeld vom Typ DECIMAL angegeben, dessen Länge nicht der in der Fehlermeldung genannten entspricht.

Benutzerreaktion:

Korrigieren Sie die Angabe, und führen Sie das Kommando erneut aus.


-25204: Column '<column_name>' - ZONED field: 20 bytes maximum (double if HEX)

-25204: Column '<column_name>' - ZONEDfield: 20 bytes maximum (double if HEX)

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

In einer expliziten Spaltenbeschreibung ist ein Dateifeld vom Typ ZONED angegeben, dessen Länge nicht der in der Fehlermeldung genannten entspricht.

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25205: Declare USAGE between 50% and 100% (SAP-Bibliothek - Grundwissen)

-25205: Declare USAGE between 50% and 100%

Erläuterung:

Fehler in einem Loader-Kommando zum Importieren: Strukturlink IMPORT TABLE <table_spec>.

Der im Kommando für USAGE angegebene Wert entspricht nicht den zulässigen Werten zwischen 50% und 100%.

Benutzerreaktion:

Korrigieren Sie die Prozentangabe für USAGE im Kommando und führen Sie es erneut aus.


-25206: USAGE value of '0 rows' not allowed (SAP-Bibliothek - Grundwissen)

-25206: USAGE value of '0 rows' not allowed

Erläuterung:

Fehler in einem Loader-Kommando zum Import von Daten: Strukturlink IMPORT TABLE <table_spec>.

Der für USAGE angegebene Wert von 0 Zeilen ist nicht zulässig.

Benutzerreaktion:

Korrigieren Sie die Angabe der Zeilenanzahl für USAGE im Kommando und führen Sie es erneut aus.


-25207: USAGE value of row(s) too high; maximum number of records possible on a single db page: <number>

Erläuterung:

Fehler in einem Loader-Kommando zum Importieren: Strukturlink IMPORT TABLE <table_spec>.

Die angegebene Zeilenzahl für USAGE (Zeilen pro Datenbankseite) ist zu groß. Die maximal zulässige Zeilenanzahl kann aus der Größe einer Datenbankseite und der Größe eines Satzes der zu importierenden Tabelle bestimmt werden.

Benutzerreaktion:

Korrigieren Sie die Angabe im Kommando und führen Sie es erneut aus.


-25208: Invalid position specification (negative values not allowed)

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

Positionsangaben können nicht negativ sein.

Benutzerreaktion:

Korrigieren Sie die Positionsangabe und führen Sie das Kommando erneut aus.


-25209: Invalid FRACTION specification (negative values not allowed)

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

Angaben für FRACTION können nicht negativ sein.

Benutzerreaktion:

Korrigieren Sie die Angabe für FRACTION und führen Sie das Kommando erneut aus.


-25210: Invalid SCALE specification. Scale range: -127 <= SCALE <= 127

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

Eine für SCALE angegebene Zahl kann nur einen Wertebereich zwischen -127 und +127 haben.

Benutzerreaktion:

Korrigieren Sie die Angabe für SCALE und führen Sie das Kommando erneut aus.


-25211: Invalid ROUND specification (0 <= ROUND_value <= 18)

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

Eine für ROUND angegebene Zahl kann nur einen Wertebereich zwischen 0 und 18 haben.

Benutzerreaktion:

Korrigieren Sie die Angabe der Zeilenanzahl für ROUND und führen Sie das Kommando erneut aus.


-25212: Invalid TRUNC specification (0 <= TRUNC_value <= 18)

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

Eine für TRUNC angegebene Zahl kann nur einen Wertebereich zwischen 0 und 18 haben.

Benutzerreaktion:

Korrigieren Sie die Angabe der Zeilenanzahl für TRUNC und führen Sie das Kommando erneut aus.


-25213: Invalid file format specification: given formats rule each other out

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Es ist nicht möglich, für einen Datenstrom als Strukturlink Format sowohl CSV als auch FWV anzugeben. Die beiden Formate schließen einander aus.

Benutzerreaktion:

Korrigieren Sie die Formatangabe und führen Sie das Kommando erneut aus.


-25214: The specification of a separator/delimiter is not allowed together with FWV

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Wenn in einem Kommando für einen Datenstrom das Strukturlink Format FWV angegeben ist, können weder Separatoren noch Delimiter zusätzlich in dieser Anweisung spezifiziert werden.

Benutzerreaktion:

Korrigieren Sie die Angaben und führen Sie das Kommando erneut aus.


-25216: File option FWV required (SAP-Bibliothek - Grundwissen)

-25216: File option FWV required

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Die Formatangaben INTEGER, REAL, DECIMAL und ZONED für einzelne zu exportierende oder zu importierende Spalten sind nur zulässig, wenn für den Datenstrom das Format Strukturlink FWV gewählt wurde.

Benutzerreaktion:

Korrigieren Sie die Formatangabe und führen Sie das Kommando erneut aus.


-25217: End position for column <column_name> lower than start position

Erläuterung:

Sie haben ein Kommando zum Exportieren, Importieren oder Aktualisieren von Daten einer einzelnen Tabelle im Strukturlink Format FWV ausgeführt. Das Kommando wurde abgebrochen, da für die angegebene Spalte eine Endposition angegeben wurde, die kleiner ist als die Startposition für diese Spalte.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25218: No column specified but file format is FWV (SAP-Bibliothek - Grundwissen)

-25218: No column specified but file format is FWV

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

In einem Kommando wurde für den Datenstrom das Strukturlink Format FWV angegeben, aber es sind keine Spalten spezifiziert. Die Formatangabe FWV verlangt, dass jede zu exportierende oder zu importierende Spalte im Kommando spezifiziert wird.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25219: Columns have to be specified in left-to-right order (positions in ascending order)

Erläuterung:

Fehler im Kommando zum Importieren von Daten.

Im Kommando wurde für den Datenstrom das Strukturlink Format CSV angegeben. In diesem Fall müssen die im Kommando angegebenen Spalten nach Positionen aufsteigend sortiert angegeben werden.

Benutzerreaktion:

Korrigieren Sie die Angaben und führen Sie das Kommando erneut aus.


-25220: Wrong separator/delimiter specification (SAP-Bibliothek - Grundwissen)

-25220: Wrong separator/delimiter specification

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Separatoren und Delimiter können nur jeweils ein Zeichen lang sein.

Benutzerreaktion:

Korrigieren Sie die Formatangabe und führen Sie das Kommando erneut aus.


-25221: Wrong decimal specification (SAP-Bibliothek - Grundwissen)

-25221: Wrong decimal specification

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Im Kommando entspricht in der Strukturlink Formatangabe für den Datenstrom die Spezifikation der Zeichen, die bei Dezimalzahlen zu verwenden sind, um Tausender zu gliedern und ganze Zahlen von Dezimalstellen zu trennen, nicht der Syntax.

Benutzerreaktion:

Korrigieren Sie die Angaben und führen Sie das Kommando erneut aus.


-25222: Wrong Boolean specification (SAP-Bibliothek - Grundwissen)

-25222: Wrong Boolean specification

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Im Kommando entspricht in der Strukturlink Formatangabe für den Datenstrom die Spezifikation der Zeichenkette, mit der aus der Datenbankinstanz zu exportierende bzw. in eine Datenbankinstanz zu importierende BOOLEAN-Werte repräsentiert werden, nicht der Syntax.

Benutzerreaktion:

Korrigieren Sie die Angaben und führen Sie das Kommando erneut aus.


-25223: Wrong null specification (SAP-Bibliothek - Grundwissen)

-25223: Wrong null specification

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Die Spezifikation der Zeichenkette, mit der NULL-Werte extern in einem Datenstrom dargestellt sind oder dargestellt werden sollen, entspricht nicht der Syntax. NULL-Werte können als Zeichenketten maximal 20 Zeichen lang sein.

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25225: Wrong number specification (SAP-Bibliothek - Grundwissen)

-25225: Wrong number specification

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Die Spezifikation des Tausendertrennzeichens und des Dezimalzeichens, die beim Exportieren oder Importieren numerischer Werte vom Loader genutzt werden sollen, entspricht nicht der Syntax ( Strukturlink Datenformat).

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25226: A maximum of 1024 columns can be specified for one table

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

In einem Kommando zum Export oder Import von Daten können nicht mehr Spalten angegeben werden, als die Datenbankinstanz pro Tabelle erlaubt. Dieser Wert von 1024 Spalten wurde im auszuführenden Kommando überschritten.

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25227: Specification of conditions exceeds allowed count of conditions

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

In einem Kommando zum Export oder Import von Daten können nicht mehr als 254 Bedingungen für alle Spalten zusammen spezifiziert werden. Dieser Wert wurde im auszuführenden Kommando überschritten.

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25228: Incorrect date-time format, all patterns accepted in the SET menu are valid

Erläuterung:

Fehler im Kommando zum Export oder Import von Daten.

Die Angabe für die Darstellung der Datums- oder Zeitwerte (angegebene Maske) ist unzulässig.

Benutzerreaktion:

Korrigieren Sie die Angabe so, dass die Darstellung der Strukturlink Datums- bzw. Strukturlink Zeitangabe entspricht und führen Sie das Kommando erneut aus.


-25229: Incorrect comparison operator in condition (SAP-Bibliothek - Grundwissen)

-25229: Incorrect comparison operator in condition

Erläuterung:

Fehler im Loader-Kommando zum Exportieren oder Importieren von Daten.

Der in einer Bedingung angegeben Vergleichsoperator wird nicht unterstützt. Mögliche Vergleichsoperatoren sind in der Syntaxregel Strukturlink compare_operator angegeben.

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25230: Cannot execute command DATAEXTRACT FOR <load_type>; specify an output file for commands

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Das angegebene Kommando muss mindestens Angaben für 2 Ausgabedatenströme enthalten - einen Datenstrom für Daten und einen Datenstrom für die zu erzeugenden Kommandos. Der Datenstrom für die Kommandos fehlt im Kommando.

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25231: ROUND or TRUNC specification not allowed for this column

Erläuterung:

Fehler beim Export oder Import von Daten.

Die Angabe von ROUND, TRUNC oder SCALE ist nur möglich für numerische Tabellenspalten, d. h. für Tabellenspalten vom Typ INTEGER, SMALLINT, FLOAT oder FIXED.

Benutzerreaktion:

Korrigieren Sie die Angabe und führen Sie das Kommando erneut aus.


-25232: Wrong keyword (SAP-Bibliothek - Grundwissen)

-25232: Wrong keyword

Erläuterung:

Fehler im Kommando zum Exportieren oder Importieren von Daten.

Das angegebene Kommando enthält ein unbekanntes Schlüsselwort.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25233: Some column descriptions with end position but file format is CSV

Erläuterung:

Fehler im Loader-Kommando zum Importieren oder zum Aktualisieren von Daten.

Für den Datenstrom ist im Kommando das Format Strukturlink CSV angegeben. Bei diesem Format geben die Positionen in den Spaltenbeschreibungen die laufende Nummer des Feldes in einer Datenzeile des Datenstroms an, das importiert werden soll. Endpositionen sind für dieses Format nicht erlaubt.

Benutzerreaktion:

Korrigieren Sie die Positionsangaben und führen Sie das Kommando erneut aus.


-25234: Some column descriptions without end position but file format is FWV

Erläuterung:

Fehler im Loader-Kommando zum Importieren oder zum Aktualisieren von Daten.

Für die Datenströme ist im Kommando das Format Strukturlink FWV angegeben. Bei diesem Format sind Positionsangaben in der Form Anfangsposition - Endposition erforderlich.

Benutzerreaktion:

Korrigieren Sie die Positionsangaben und führen Sie das Kommando erneut aus.


-25235: Some positions specified more than once (SAP-Bibliothek - Grundwissen)

-25235: Some positions specified more than once

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Für den Datenstrom ist im Kommando das Format Strukturlink CSV angegeben. Alle zu exportierenden Werte müssen durch unterschiedliche Positionsangaben im Kommando angegeben sein, da sonst exportierte Werte überschrieben werden.

Benutzerreaktion:

Korrigieren Sie die Positionsangabe und führen Sie das Kommando erneut aus.


-25236: Some positions overlap (SAP-Bibliothek - Grundwissen)

-25236: Some positions overlap

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Für den Datenstrom ist im Kommando das Format Strukturlink FWV angegeben. Alle zu exportierenden Werte müssen durch nicht überschneidende Positionsangaben im Kommando spezifiziert sein, da sonst bereits exportierte Werte überschrieben werden.

Benutzerreaktion:

Korrigieren Sie die Positionsangabe und führen Sie das Kommando erneut aus.


-25237: Cannot execute DATAUPDATE command; specify set columns (SAP-Bibliothek - Grundwissen)

-25237: Cannot execute DATAUPDATE command; specify set columns

Erläuterung:

Fehler beim Aktualisieren von Daten mit dem Strukturlink UPDATE COLUMNS-Kommando.

Die für die Ausführung notwendigen Angaben zu den zu aktualisierenden Spalten fehlen im Kommando. Diese Spaltenangaben müssen mit dem Schlüsselwort SET eingeleitet werden.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25238: Cannot execute DATAUPDATE command; specify access columns

Erläuterung:

Fehler beim Aktualisieren von Daten mit dem Strukturlink UPDATE COLUMNS-Kommando.

Die für die Ausführung notwendigen Angaben zu den Qualifikationsspalten fehlen im Kommando. Die Werte der Qualifikationsspalten identifizieren eine Zeile der Zieltabelle, die aktualisiert werden soll.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25239: Specified value '<value>' is not a valid integer (SAP-Bibliothek - Grundwissen)

-25239: Specified value '<value>'is not a valid integer

Erläuterung:

Fehler im Loader-Kommando zum Importieren oder Aktualisieren von Daten.

Der im Kommando angegeben Zahlenwert kann nicht als ganze Zahl interpretiert werden (Wertebereich für ganze Zahlen: 0 <= Zahl <= 2147483647).

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25240: Incomplete logon parameters; password missing (SAP-Bibliothek - Grundwissen)

-25240: Incomplete logon parameters; password missing

Erläuterung:

Im Kommando zum Anmelden eines Datenbankbenutzers haben Sie vergessen, ein Kennwort anzugeben.

Benutzerreaktion:

Geben Sie das Kennwort des anzumeldenden Datenbankbenutzers im Kommando an und führen Sie es erneut aus.


-25242: Database identifier too long (SAP-Bibliothek - Grundwissen)

-25242: Database identifier too long

Erläuterung:

Sie haben ein Kommando zum Exportieren, Importieren oder Aktualisieren von Daten einer einzelnen Tabelle ausgeführt. Das Kommando wurde abgebrochen, da der angegebene Tabellenname zu lang ist.

Benutzerreaktion:

Korrigieren Sie den Tabellennamen und führen Sie das Kommando erneut aus.


-25243: Error parsing <time> mask: <error_text> (SAP-Bibliothek - Grundwissen)

-25243: Error parsing <time> mask: <error_text>

Erläuterung:

Sie haben ein Kommando zum Exportieren, Importieren oder Aktualisieren von Daten ausgeführt. Im Kommando wurde ein Datums-, Zeit- oder Zeitstempelformat angegeben. Dieses Format ist fehlerhaft. Der Fehlertext beschreibt die Ursache des Fehlers.

Benutzerreaktion:

Korrigieren Sie die Zeitangabe im Kommando und führen Sie es erneut aus.


-25244: Loader CONSTRAINT violation: <error_text> (SAP-Bibliothek - Grundwissen)

-25244: Loader CONSTRAINT violation: <error_text>

Erläuterung:

Sie haben ein Kommando zum Exportieren oder Importieren von Daten einer Datenbank, eines Benutzers oder eines Schemas ausgeführt. Dieses Kommando wurde abgebrochen, da Sie für die Datendatei ein Format angegeben haben, das für diese Kommandos nicht unterstützt wird. Der Fehlertext beschreibt die Ursache des Fehlers.

Benutzerreaktion:

Korrigieren Sie die Formatangabe im Kommando und führen Sie es erneut aus.


-25245: Error: specify CATALOG, DATA, and PACKAGE stream (SAP-Bibliothek - Grundwissen)

-25245: Error: specify CATALOG, DATA, and PACKAGE stream

Erläuterung:

Sie haben ein Kommando zum Exportieren von Daten einer Tabelle ausgeführt. Dieses Kommando wurde abgebrochen, da im Kommando keine Datei angegeben wurde.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25247: Error: specify CATALOG or DATA stream (SAP-Bibliothek - Grundwissen)

-25247: Error: specify CATALOG or DATA stream

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT), Aktualisieren (UPDATE) oder Exportieren (EXPORT) von Daten ausgeführt. Das Kommando wurde abgebrochen, da Sie weder eine Katalogdatei noch eine Datendatei im Kommando angegeben haben.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25249: Invalid Isolation Level specification: possible values are: 0, 1, 10, 15, 2, 20, 3, 30

Erläuterung:

Sie haben im Kommando zum Anmelden eines Datenbankbenutzers an die Datenbank einen Isolation Level angegeben, der nicht zulässig ist. Die Anmeldung wurde nicht ausgeführt.

Benutzerreaktion:

Korrigieren Sie die Angabe des Isolation Level im Kommando und führen Sie es erneut aus.


-25250: Error building URI for encrypted connection: <error_text>

Erläuterung:

Sie haben versucht, mit dem Loader eine verschlüsselte Verbindung zu einer Datenbank herzustellen. Dieser Versuch brach mit einem Fehler ab. Die Fehlermeldung enthält einen zusätzlichen Fehlertext, in dem die Ursache für den Fehler angegeben wird.

Benutzerreaktion:

Beseitigen Sie die Ursache des Fehlers und führen Sie das Kommando erneut aus.


-25251: Code page to set (<code_page_name>) not found in system table SYSLOADER.CODEPAGE. The privilege to change the content of this table is restricted to SYSDBA.

Erläuterung:

Sie haben das Kommando SET CODEPAGE <code_page_name> ausgeführt. Der Loader konnte die im Kommando angegebene Codepage in der Systemtabelle SYSLOADER.CODEPAGE nicht finden.

Um mit dem Kommando SET CODEPAGE <code_page_name> Codepages in diese Systemtabelle einfügen zu können, ist es notwendig, sich als Datenbanksystemadministrator (SYSDBA-Benutzer) mit dem Loader an der Datenbank anzumelden.

Benutzerreaktion:

Melden Sie sich mit dem Loader als Datenbanksystemadministrator an der Datenbank an und führen Sie das Kommando erneut aus.


-25281: Syntax error at position <position> (<error_text>). Check for typing errors

Erläuterung:

Beim Parsen des auszuführenden Kommandos hat der Loader einen Syntaxfehler im Kommando festgestellt.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25301: Invalid input for date or time column: <input_value>

Erläuterung:

Fehler im Kommando zum Importieren oder Aktualisieren von Daten.

Für die Angabe von Werten für Spalten vom Datentyp DATE oder TIME stehen verschiedene Formate zur Verfügung: INTERNAL, EUR, ISO, USA, JIS. Der Loader nutzt diese Angaben, um beim Einfügen der Werte diese in das interne Datenbankformat für die jeweiligen Datentypen umzuwandeln.

Ein angegebener Datenwert, der in eine Spalte vom Datentyp DATE oder TIME eingefügt werden soll, kann nicht in das entsprechende interne Datenbankformat umgewandelt werden.

Benutzerreaktion:

Korrigieren Sie die Werte und führen Sie das Kommando erneut aus.


-25302: This value is not a valid number: '<input_value>' (SAP-Bibliothek - Grundwissen)

-25302: This value is not a valid number: '<input_value>'

Erläuterung:

Fehler im Kommando zum Exportieren/Importieren oder Aktualisieren von Daten.

Dieser Fehler kann verschiedene Ursachen haben abhängig vom Kontext, in dem er auftritt.

  • Beim Importieren von Daten kann ein Wert, der in eine Spalte mit numerischem Datentyp (INTEGER, FIXED (n, m), ...) importiert werden soll, nicht in das interne Format umgewandelt werden. Der Wert ist entweder zu groß oder kann nicht als Zahl interpretiert werden.
  • Beim Exportieren von Daten kann ein Wert, der aus einer Spalte mit numerischem Datentyp (INTEGER; FIXED (n, m), ...) extrahiert werden soll, nicht in die externe Darstellung umgewandelt werden. Der Wert ist entweder zu groß oder die Datentypen korrelieren nicht miteinander (z.B. beim Versuch, einen Wert aus einer Spalte vom Datentyp FLOAT in eine externe Darstellung vom Datentyp INTEGER BINARY zu extrahieren).
  • Ein Kommando zum Exportieren oder Importieren von Daten enthält Bedingungen, z.B. für das Exportieren oder Importieren von NULL-Werten. Wenn Bedingungen für Spalten mit numerischem Datentyp definiert werden, müssen die Werte in den Bedingungen auch als Zahl interpretierbar sein.

Benutzerreaktion:

Korrigieren Sie die Werte und führen Sie das Kommando erneut aus.


-25303: Input value does not match key order or range specification

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Alle zu Importierenden Werte müssen in Schlüsselreihenfolge sortiert im Datenstrom vorliegen. Diese Reihenfolge ist durch den Datensatz in der angegebenen Zeile (Datenformat Strukturlink CSV oder FWV ohne binäre Daten) oder an der angegebenen Position (Format des Datenstroms: FWV BINARY) verletzt.

Benutzerreaktion:

Korrigieren Sie die Daten und führen Sie das Kommando erneut aus.


-25304: Columns for key (KEY) or search condition missing (SAP-Bibliothek - Grundwissen)

-25304: Columns for key (KEY) or search condition missing

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Für ein oder mehrere Schlüsselfelder einer zu importierenden Tabelle wurden keine Daten angegeben. Der betroffene Datensatz ist in der nachfolgenden Meldung angegeben.

Benutzerreaktion:

Korrigieren Sie die Daten und führen Sie das Kommando erneut aus.


-25305: Data for key columns exceeds allowed key length (SAP-Bibliothek - Grundwissen)

-25305: Data for key columns exceeds allowed key length

Erläuterung:

Fehler beim Importieren von Daten.

Benutzerreaktion:

Korrigieren Sie die Daten und führen Sie das Kommando erneut aus.


-25306: The value is not a valid HEX constant: <input_value>

Erläuterung:

Fehler im Kommando zum Importieren oder Aktualisieren von Daten. Im Kommando wurde für eine oder mehrere Spalten definiert, dass die Werte zum Importieren in Klarschrift in hexadezimaler Kodierung vorliegen. Die angegebenen Werte entsprechen nicht der hexadezimalen Darstellung.

Benutzerreaktion:

Korrigieren Sie die Werte und führen Sie das Kommando erneut aus.


-25308: CONSTRAINT condition violated (SAP-Bibliothek - Grundwissen)

-25308: CONSTRAINT condition violated

Erläuterung:

Fehler beim Importieren von Daten.

Der angegebene Datensatz erfüllt nicht die auf dieser Tabelle definierte CONSTRAINT-Bedingung.

Benutzerreaktion:

Korrigieren Sie die Daten und führen Sie das Kommando erneut aus.


-25309: Invalid input for BOOLEAN column: <input_value> (SAP-Bibliothek - Grundwissen)

-25309: Invalid input for BOOLEAN column: <input_value>

Erläuterung:

Fehler im Loader-Kommando zum Importieren oder Aktualisieren von Daten. Die externe Darstellung von Eingabewerten vom Datentyp BOOLEAN kann in einzelnen Kommandos oder für alle Kommandos einer Kommandodatei definiert werden. Der zu importierende Wert entspricht nicht dieser Darstellung.

Benutzerreaktion:

Korrigieren Sie die Daten und führen Sie das Kommando erneut aus.


-25310: Column '<column_name>' must not contain NULL values

Erläuterung:

Fehler im Loader-Kommando zum Importieren oder Aktualisieren von Daten. Es ist nicht möglich, NULL-Werte in Spalten zu importieren, die NOT NULL ohne Vorschlagswert des Systems definiert wurden.

Benutzerreaktion:

Korrigieren Sie die Daten und führen Sie das Kommando erneut aus.


-25311: No Data for NOT NULL - column without default (<column_name>). You have either not specified this column in the command or there is no data in the data file for this column

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten. Dieser Fehler tritt auf, wenn für eine Spalte, die als NOT NULL ohne Vorschlagswert des Systems definiert wurde, keine Daten im Datenstrom gefunden werden, oder wenn die Spalte im Kommando nicht angegeben ist.

Benutzerreaktion:

Korrigieren Sie die Werte oder das Kommando und führen Sie das Kommando erneut aus.


-25313: Overflow occurred, execution aborted (SAP-Bibliothek - Grundwissen)

-25313: Overflow occurred, execution aborted

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten. Ein zu exportierender numerischer Wert kann in die im Kommando angegebenen externen Darstellung nicht exportiert werden. Dieser Fehler tritt z.B. auf, wenn versucht wird, den Wert 2147483647 vom Datentyp INTEGER in einen externen 2 Byte langen binären INTEGER-Wert zu exportieren. Bei diesem Fehler wird allerdings nur eine Fehlermeldung ausgegeben und anstelle der numerischen Daten wird eine entsprechende Anzahl von * im Datenstrom eingetragen. Das Exportieren der Daten wird von diesem Fehler nicht unterbrochen.

Benutzerreaktion:

Überprüfen Sie nach Beendigung des Exports die exportierten Daten.


-25314: Fractional part too small for column '<column_name>', minimum length: <length>

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten. Die Definition der externen Darstellung der Werte der angegebenen Spalte (externes Format DECIMAL oder ZONED) enthält zu wenig Nachkommastellen. Die erforderliche Anzahl ergibt sich aus der Definition der Spalte in der Datenbankinstanz und/oder durch die beim Export auszuführenden Operationen auf den Werten der Spalte.

Benutzerreaktion:

Korrigieren Sie die Angaben zur externen Darstellung der Werte dieser Spalte und führen Sie das Kommando erneut aus.


-25315: Column data type of column '<column_name>' and external data type are not compatible

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Benutzerreaktion:

Wählen Sie einen anderen externen Datentyp und führen Sie das Kommando erneut aus.


-25316: Table contains at least one column defined as LONG; IMPORT in PAGE format rejected

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten. Die zu importierende Tabelle darf keine Spalten vom Datentyp LONG enthalten. Das gilt selbst dann, wenn die betreffende Spalte in diesem Fall nicht importiert werden soll, d.h. das Kommando selbst diese Spalte in der Spaltenbeschreibung nicht aufführt.

Benutzerreaktion:

Importieren Sie die Tabelle mit einem anderen IMPORT-Kommando.


-25317: Constant must be compatible with column type and length (column: '<column_name>')

Erläuterung:

Fehler im Loader-Kommando zum Importieren oder Aktualisieren von Daten.

Der zu importierende Wert kann nicht in die Spalte importiert werden, da er entweder zu lang ist oder der externe Datentyp und der Datentyp der Spalte nicht kompatibel sind.

Benutzerreaktion:

Korrigieren Sie die Daten und führen Sie das Kommando erneut aus.


-25318: Syskey violation (the computed value exceeds the highest possible syskey value)

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Es werden Daten in eine Tabelle importiert, die keinen benutzerdefinierten Schlüssel besitzt. In diesem Fall wird ein datenbankinterner Schlüssel erzeugt.

Der beim Import erzeugte Wert übersteigt den maximal möglichen Wert. Dieser Fehler tritt allerdings erst auf, wenn die Anzahl der Datensätze in dieser Tabelle den Wert 2E48 überschreitet.

Benutzerreaktion:

Benachrichtigen Sie den Support.


-25319: Missing data for specified column '<column_name>' (SAP-Bibliothek - Grundwissen)

-25319: Missing data for specified column '<column_name>'

Erläuterung:

Fehler im Kommando zum Importieren von Daten. Beim Importieren von Daten müssen für alle im Kommando aufgeführten Spalten Daten im Strukturlink Datenstrom angegeben werden. Eine Ausnahme bilden Spalten, die einen Systemsvorschlagswert oder den NULL-Wert erlauben.

Für die angegebene Spalte hat der Loader keine Daten im Datenstrom gefunden. Zusätzlich zu dieser Fehlermeldung protokolliert der Loader, in welcher Zeile (Textdatenstrom) oder an welcher Position im Datenstrom (binärer Datenstrom) der Fehler aufgetreten ist.

Benutzerreaktion:

Überprüfen Sie die Daten im Datenstrom und führen Sie das Kommando erneut aus.


-25320: The LONG value could not be loaded into column (SAP-Bibliothek - Grundwissen)

-25320: The LONG value could not be loaded into column

Erläuterung:

Fehler beim Loader-Kommando zum Importieren oder Aktualisieren von Daten.

Beim Importieren eines Wertes in eine Spalte vom Datentyp LONG ist ein Fehler aufgetreten. Die Fehlermeldung erhält einen zusätzlichen Fehlertext, in dem die Ursache für das Fehlschlagen angegeben wird.

Benutzerreaktion:

Beheben Sie die Fehlerursache und führen Sie das Kommando erneut aus.


-25321: This condition value is not a valid number: '<value>'

Erläuterung:

Fehler beim Loader-Kommando zum Importieren oder Aktualisieren von Daten.

Im Kommando können für einzelne Spalten Bedingungen definiert werden, die das Importieren/Aktualisieren der Werte steuern. Die Vergleichskonstanten in Bedingungen für numerische Spalten müssen auch als Zahlen interpretierbar sein.

Bei diesem Fehler ist die angegebene Vergleichskonstante nicht als Zahl interpretierbar.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25322: This condition value was truncated and cannot be used: '<value>'

Erläuterung:

Fehler beim Loader-Kommando zum Importieren oder Aktualisieren von Daten.

Im Kommando können für einzelne Spalten Bedingungen definiert werden, die das Importieren/Aktualisieren der Werte steuern. Die Vergleichskonstanten in Bedingungen für numerische Spalten müssen auch als Zahlen interpretierbar sein.

Bei diesem Fehler ist die angegebene Vergleichskonstante als Zahl interpretierbar. Sie wurde aber bei der Konvertierung um Nachkommastellen gekürzt und kann deshalb für Vergleiche nicht mehr herangezogen werden.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25323: Data type of null value representation for column '<column_name>' is incompatible with the column data type

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten. Im Kommando kann für einzelne Spalten eine NULL-Wert-Repräsentation spezifiziert werden. Damit wird im Fall eines exportierten NULL-Wertes die im Kommando angegebene Konstante in den Datenstrom eingetragen. Der Datentyp der angegebenen Konstante muss kompatibel sein zum externen Datentyp der zu exportierenden Spalte. Wird kein Datentyp im Kommando angegeben, dann wird als Vorgabewert der Datentyp CHAR angenommen.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25324: Errors checking length of column specifications. See loader server log file for more information

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten. Im Kommando kann für einzelne Spalten die Länge der Werte im Datenstrom angegeben werden. Einige der angegebenen Längen sind kürzer als die definierten Längen der Spalten in der Datenbank. Diese Werte könnten somit nur fehlerhaft exportiert werden. Bei dieser Fehlermeldung handelt es sich um eine zusammenfassende Meldung. Die Fehlermeldungen –25203, -25204 und -25315, welche die fehlerhaften Spaltenbeschreibungen angeben, sind nur in der Protokolldatei aufgeführt.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25325: Errors checking compatibility of external and db data types. See loader server log file for more information

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten. Im Kommando kann für einzelne Spalten der externe Datentyp der Werte im Datenstrom angegeben werden. Bei dieser Fehlermeldung handelt es sich um eine zusammenfassende Meldung. Die Fehlermeldungen -25315 und -25323, welche die fehlerhaften Spaltenbeschreibungen angeben, sind nur in der Protokolldatei aufgeführt.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25326: The exported number (column '<column_name>') was truncated

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Die exportierte Zahl wurde bei der Konvertierung in den externen Datentyp um Nachkommastellen gekürzt.

Dieser Fehler hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion erforderlich.


-25327: Error(s) exporting record <record_no>; start position of incorrect record in data file:<position>

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Der in der Fehlermeldung aufgeführte Datensatz konnte nur fehlerhaft exportiert werden.

Die angegebene Position ist nur für binäre Datenströme interessant, da sie die genaue Position des fehlerhaften Datensatzes im Datenstrom angibt. Im Fall von Textdatenströmen ist die Position immer 1.

Dieser Fehlermeldung sind bereits Fehlermeldungen vorausgegangen, welche die aufgetretenen Fehler und die fehlerhaften Werte im Datensatz genauer beschreiben.

Dieser Fehler hat keinen Abbruch des Kommandos zur Folge, wenn das Kommando mit einer Fehlertoleranz größer als 1 ausgeführt wird.

Benutzerreaktion:

Überprüfen Sie die fehlerhaften Datensätze.

Korrigieren Sie im Fall eines Abbruchs das Kommando und führen Sie es erneut aus.


-25328: Some error(s) while extracting data. See loader server log file for more information

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Diese Fehlermeldung wird nur vom Client (z.B. LOADERCLI) ausgegeben.

Benutzerreaktion:

Überprüfen Sie die aufgetretenen Probleme anhand der Einträge in der Strukturlink Protokolldatei des Loader.

Korrigieren Sie gegebenenfalls das Kommando und führen Sie es erneut aus.


-25329: The given data file '<file_name>' was not generated using EXPORT in PAGE Format (<error_text>)

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Datenströme für dieses Kommando müssen binär sein und die Datenbankstrukturen und spezielle Informationen zum Ausführen eines anschließenden IMPORT-Kommandos enthalten. Diese Datenströme werden durch das korrespondierende EXPORT-Kommando erzeugt und dürfen nicht verändert werden.

Der im Kommando angegebene Datenstrom ist nach Ausführung vom Export verändert worden oder wurde nicht mit dem korrespondierenden EXPORT-Kommando erstellt. In der Fehlerursache wird angegeben, welche Information im Datenstrom nicht ausgewertet werden kann.

Benutzerreaktion:

Erstellen Sie den Datenstrom mit dem korrespondierenden EXPORT-Kommando und führen das Kommando erneut aus.


-25330: The page sizes of the source system and the target system do not match (source:<page_size>, target:<page_size>)

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Die mit dem EXPORT-Kommando erzeugten Daten sind Binärstrukturen der exportierten Datenbank. Damit diese Daten in eine andere Datenbank importiert werden können, müssen beide Datenbankinstanzen die gleiche Seitengröße haben.

Dieser Fehler tritt auf, wenn die Seitengröße der Datenbankinstanz, aus der die Tabellen exportiert wurden und die Seitengröße der Datenbankinstanz, in die sie importiert werden sollen, nicht übereinstimmen.

Benutzerreaktion:

Verwenden Sie eine Zieldatenbankinstanz, die die gleiche Seitengröße wie die Quelldatenbankinstanz hat.


-25331: This is a restricted statement, user must be SYSDBA (SAP-Bibliothek - Grundwissen)

-25331: This is a restricted statement, user must be SYSDBA

Erläuterung:

Die Loader-Kommandos TABLEEXTRACT ALL, TABLELOAD ALL, CATALOGEXTRACT ALL und CATALOGLOAD ALL sind Kommandos, die den gesamten Datenbankkatalog betreffen und deshalb nur vom Datenbanksystemadministrator ausgeführt werden dürfen

Benutzerreaktion:

Rufen Sie den Loader mit der entsprechenden Benutzerkennung auf oder führen Sie vor dem Kommando ein Strukturlink USE USER-Kommando mit der entsprechenden Benutzerkennung aus.


-25332: Error getting schema definition of table <table_name> (<SQL_error_text>)

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Beim Ausführen eines EXPORT-Kommandos wird für jede zu exportierende Tabelle neben den Daten auch die Schemadefinition der Tabelle exportiert. Das ermöglicht es, die exportierte Tabelle bei Aufruf des entsprechenden IMPORT-Kommandos vollständig wiederherzustellen.

Beim Export der Schemadefinition der Tabelle ist ein Fehler aufgetreten. Dem SQL-Fehlertext können Sie die Ursache des Fehlers entnehmen.

Benutzerreaktion:

Analysieren Sie die Ursache des Fehlers und führen Sie das Kommando erneut aus.


-25333: Error getting index definitions for table <table_name> (<SQL_error_text>)

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Beim Ausführen eines EXPORT-Kommandos wird für jede zu exportierende Tabelle neben den Daten auch die Indexdefinition der Tabelle exportiert. Das ermöglicht es, die exportierte Tabelle bei Aufruf des entsprechenden IMPORT-Kommandos vollständig wiederherzustellen.

Beim Export der Indexdefinition der Tabelle ist ein Fehler aufgetreten. Dem SQL-Fehlertext können Sie die Ursache des Fehlers entnehmen.

Benutzerreaktion:

Analysieren Sie die Ursache des Fehlers und führen Sie das Kommando erneut aus.


-25334: File counter for data file exceeded maximum value of 9999

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Um die vorgegebene Größe der bei Ausführung eines EXPORT TABLE-Kommandos zu erzeugenden Datenströme einzuhalten, wird implizit aus dem im Kommando angegebenen Namen des Datenstroms eine Folge von Dateien erzeugt.

Die maximal zu erzeugende Anzahl von Dateien ist auf 9999 Dateien begrenzt.

Benutzerreaktion:

Korrigieren Sie die im EXPORT TABLE-Kommando angegebene Größe für einen einzelnen Datenstrom und führen Sie das Kommando erneut aus.


-25335: Error restoring single table using data file with multiple table data; specify single table data file

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Die Daten wurden entweder mit dem Kommando EXPORT USER oder EXPORT DB exportiert. Die so exportierten Daten können nur mit dem entsprechenden IMPORT USER- oder IMPORT DB-Kommando importiert werden. Der Import einer einzelnen Tabelle aus diesen Daten ist nicht möglich.

Benutzerreaktion:

Wenn Sie eine einzelne Tabelle importieren wollen, müssen Sie diese zuerst mit dem EXPORT TABLE-Kommando exportieren.

Wenn Sie die gesamten Daten des Datenstroms importieren wollen, korrigieren Sie das Kommando und führen Sie es erneut aus.


-25336: Error restoring multiple tables using data file with single table data; specify data file created using EXPORT DB or EXPORT USER

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Die Daten wurden mit dem Kommando EXPORT TABLE exportiert. Mit diesem Kommando wird eine einzelne Tabelle exportiert. Diese kann nur mit einem entsprechenden IMPORT TABLE-Kommando importiert werden.

Das Importieren mehrerer Tabellen aus diesen Daten ist nicht möglich.

Benutzerreaktion:

Wenn Sie alle Tabellen oder die eines bestimmten Datenbankbenutzers importieren wollen, müssen Sie diese zuerst mit dem entsprechenden EXPORT DB bzw. EXPORT USER-Kommando exportieren:


-25337: Error restoring table <table_name>; no table data found in data file <file_name>

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Der angegebene Datenstrom enthält keine Daten, mit der die Tabelle importiert werden könnte. Bevor eine Tabelle importiert werden kann, muss sie mit einem EXPORT TABLE-Kommando exportiert werden.

Benutzerreaktion:

Exportieren Sie die Tabelle bevor Sie diese wiederherstellen.


-25338: Error during restart IMPORT; restart entry <position> not found in mapping file <file_name>

Erläuterung:

Fehler beim Wiederaufsetzen des Imports von Daten.

Mit den IMPORT-Kommando haben Sie die Möglichkeit, abgebrochene Importe wiederaufzusetzen. Um das zu ermöglichen, schreibt der Loader beim Ausführen des Kommandos eine Restart-Datei, die den Namen der letzten erfolgreich importierten Tabelle enthält.

Der angegebene Fehler tritt auf, wenn der Loader den Namen der Tabelle aus der Restart-Datei nicht in der Zuordnungsdatei finden kann. Die mögliche Ursache ist eine Modifikation der Zuordnungsdatei nach Abbruch des Imports.

Benutzerreaktion:

Wenn möglich, stellen Sie die Zuordnungsdatei in ihrer ursprünglichen Version wieder her. Ist das nicht möglich, sollte für einen konsistenten Datenbestand der Export und der Import der Daten komplett wiederholt werden.


-25339: Error during restart IMPORT; file <file_name> could not be opened/read

Erläuterung:

Fehler beim Wiederaufsetzen des Import von Daten mit einem IMPORT-Kommando.

Die Restart-Datei konnte nicht geöffnet werden.

Benutzerreaktion:

Analysieren und beseitigen Sie die Fehlerursache. Führen Sie das Kommando erneut aus.


-25340: UCS2 conversion error; character string contains invalid characters or character sequences

Erläuterung:

Fehler beim Loader-Kommando zum Importieren oder Aktualisieren von Daten in eine Datenbankinstanz, die UNICODE verwendet.

Wenn Daten in Spalten mit einem zeichenbasierten Datentyp (CHAR) importiert werden, konvertiert der Loader die Daten in die datenbankinterne Darstellung (UCS2). Dabei ist ein Fehler aufgetreten. Die zu importierenden Daten enthalten Zeichen, die nicht in UCS2 konvertiert werden können.

Benutzerreaktion:

Korrigieren Sie die abgewiesenen Daten und führen Sie das Kommando erneut aus.


-25341: Error generating 'create table/index statements': <error_text>

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Beim Ausführen des EXPORT-Kommandos werden neben den exportierten Daten auch die Kommandos zum Anlegen der Tabelle (CREATE TABLE) und zum Anlegen der Indizes (CREATE INDEX) erzeugt.

Dabei ist ein Fehler aufgetreten. Der Fehler wird in der im Fehlermeldungstext angegebenen Fehlermeldung näher beschrieben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


-25342: Error restoring table <table_name>; table exists but source table schema and target table schema are different

Erläuterung:

Fehler beim Loader-Kommando zum Importieren von Daten.

Die angegebene Tabelle existiert bereits in der Datenbankinstanz. Der Loader hat festgestellt, dass das Schema der Quelltabelle nicht mit dem Schema der Zieltabelle übereinstimmt. Deshalb können die Daten nicht importiert werden.

Benutzerreaktion:

Verändern Sie die Zieltabelle so, dass die Schemas übereinstimmen. Führen Sie das Kommando erneut aus.


-25343: Column name(s) or number(s) do not match column names/numbers in select list: (<column_names>)

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

In der Spaltenliste sind die angeführten Spaltennamen enthalten, die jedoch in der SELECT-Anweisung fehlen. Diese werden nicht exportiert und können deswegen nicht in den Datenstrom gesichert werden.

Benutzerreaktion:

Wenn Sie die angegebenen Spalten ebenfalls exportieren wollen, nehmen Sie diese zusätzlich in die SELECT-Anweisung mit auf. Andernfalls löschen Sie die Spaltennamen aus der Spaltenliste.

Führen Sie das Kommando erneut aus.


-25344: Incorrect field length for column '<column_name>', minimum length <length_value>

Erläuterung:

Fehler beim Loader-Kommando zum Export von Daten.

Die für die Spalte definierte Ausgabelänge ist zu klein, um die Werte auszugeben, die gemäß Definition der Spalte in der Datenbankinstanz möglich sind.

Benutzerreaktion:

Korrigieren Sie die Ausgabelänge der angegebenen Spalte und führen Sie das Kommando erneut aus.


-25345: Definition of source and target table <table_name> do not match: <description>

Erläuterung:

Sie haben ein Kommando zum Importieren von Daten im Format PAGES ausgeführt. Das Kommando wurde abgebrochen, da sich die Definitionen der Tabelle, aus der exportiert wurde und die Definition der Tabelle, in die importiert werden soll, unterscheiden. Die Angabe <description> beschreibt, worin sich die beiden Tabellen unterscheiden.

Benutzerreaktion:

Stellen Sie sicher, dass sich die Definition der Zieltabelle nicht von der der Quelltabelle unterscheidet. Führen Sie das Kommando erneut aus.


-25346: Communication packet size too small to run IMPORT for PAGES of <N>kb. Increase value of parameter _PACKET_SIZE and restart the database

Erläuterung:

Sie haben ein Kommando zum Importieren von Daten im Format PAGES ausgeführt. Das Kommando wurde abgebrochen, da der Parameter _PACKET_SIZE der Datenbank, in die importiert werden soll, zu klein ist für den Import im Format PAGES.

Benutzerreaktion:

Erhöhen Sie den Wert des Datenbankparameter _PACKET_SIZE, stoppen und starten Sie die Datenbank und führen Sie das Kommando erneut aus.


-25347: Encoding type of source and target database do not match: source = <type>, target = <type>

Erläuterung:

Sie haben ein Kommando zum Importieren von Daten im Format Strukturlink PAGES ausgeführt. Das Kommando wurde abgebrochen, da die Datenbank, aus der exportiert wurde, einen andern Codetyp hatte als die Datenbank, in die importiert werden soll.

Dieser Typ einer Migration wird nicht unterstützt.

Benutzerreaktion:

Stellen Sie sicher, dass der Codetyp der Zieldatenbank dem Codetyp der Quelldatenbank entspricht und führen Sie das Kommando erneut aus.


-25348: Different byte swap of source and target computer. The Loader must run on the same processor memory architecture for EXPORT and IMPORT in PAGE format

Erläuterung:

Sie haben ein Kommando zum Importieren von Daten im Format PAGES ausgeführt. Das Kommando wurde aufgrund unterschiedlicher Speicherarchitekturen der Quell- und Zieldatenbankrechner abgebrochen. Dieser Typ eines Transports wird nicht unterstützt.

Benutzerreaktion:

Importieren Sie die Daten auf einen Rechner gleicher Architektur.


-25349: Error exporting <type> data of table <table_name>. See loader server log file for more information

Erläuterung:

Sie haben ein Kommando zum Exportieren von Daten im Format PAGES ausgeführt. Das Kommando wurde abgebrochen, da Daten des angegebenen Typs (mögliche Typen: Primärdaten, LONG-Daten) nicht exportiert werden konnten. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache für den Fehler beschreiben.

Benutzerreaktion:

Beseitigen Sie die Ursache des Fehlers und führen Sie das Kommando erneut aus.


-25350: Conversion from UNICODE data to ASCII data is not supported. This conversion may cause information loss

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT), Aktualisieren (UPDATE) oder Exportieren (EXPORT) von Daten ausgeführt. Das Kommando wurde abgebrochen, da Sie versucht haben, Daten in UCS2- oder UTF8-Kodierung in eine Datenbank zu importieren, deren Parameter _UNICODE=NO gesetzt ist oder Daten aus einer Datenbank in ASCII-Dateien zu exportieren, deren Parameter _UNICODE=YES gesetzt ist.

Benutzerreaktion:

Wenn der Fehler beim Importieren oder Aktualisieren von Daten aufgetreten ist, stellen Sie sicher, dass der Datenbankparameter _UNICODE=YES gesetzt ist, und importieren Sie die Daten erneut. Ist der Fehler beim Export aufgetreten, setzen Sie zusätzlich das Datendateiattribut UCS2 im Export-Kommando und führen Sie es erneut aus.


-25351: No long file info given for LONG column '<column_name>'

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Die in der SELECT-Anweisung des auszuführenden EXPORT-Kommandos angegebene Spalte ist vom Datentyp LONG. Um sie zu exportieren, muss im Kommando für diese Spalte ein Strukturlink Syntaxelement zum Exportieren und Importieren von LONG-Werten angegeben werden.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25352: Errors analyzing long file information. See loader server log file for more information

Erläuterung:

Fehler beim Loader-Kommando zum Export von Daten.

Bei dieser Fehlermeldung handelt es sich um eine zusammenfassende Meldung. Die dieser Meldung vorausgegangenen Fehlermeldungen sind in der Protokolldatei aufgeführt.

Benutzerreaktion:

Überprüfen Sie die Fehlermeldungen. Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25353: Specified maximum number of LONG data files for column '<column_name>' exceeded

Erläuterung:

Fehler beim Loader-Kommando zum Exportieren von Daten.

Im Kommando kann für Spalten vom Datentyp LONG im Syntaxelement export_lobcolumn_spec angegeben werden, dass jeder exportierte Werte in einen einzelnen Datenstrom geschrieben werden soll ( Strukturlink Exportieren von LONG-Werten). Dabei wird mit Platzhaltern im Namen des Datenstroms (‚#’) definiert, wie viele Datenströme maximal erzeugt werden können, z. B. würde eine Definition des Namens <name>### es ermöglichen, 1000 Datenströme zu erzeugen.

Der Fehler tritt auf, wenn die Tabelle mehr Datensätze enthält als Datenströme erzeugt werden können.

Benutzerreaktion:

Korrigieren Sie das Kommando und führen Sie es erneut aus.


-25354: LONGFILE specification missing or incorrect (SAP-Bibliothek - Grundwissen)

-25354: LONGFILE specification missing or incorrect

Erläuterung:

Fehler im Loader-Kommando zum Importieren oder Aktualisieren von Daten, wenn alle einzufügenden LONG-Werte einer Spalte in einem LONG-Datenstrom stehen.

Der Loader hat im Quelldatenstrom keine Positionsangaben für die Werte im LONG-Datenstrom gefunden.

Benutzerreaktion:

Korrigieren Sie den Datenstrom und führen Sie das Kommando erneut aus.


-25355: Error processing LONG value (column '<column_name>'): <error_code>

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) oder Aktualisieren (UPDATE) von Daten einer Tabelle mit LONG-Spalten ausgeführt. Das Kommando ist beim Lesen der LONG-Daten aus dem Datenstrom bzw. bei der Konvertierung der LONG-Daten der angegebenen Spalte abgebrochen. Der <error_code> gibt die Fehlerursache an.

In der Protokolldatei finden Sie weitere Meldungen, die die Ursache für den Fehler beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


-25356: Error processing LONG value(s): <error_text> (SAP-Bibliothek - Grundwissen)

-25356: Error processing LONG value(s): <error_text>

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) oder Aktualisieren (UPDATE) von Daten einer Tabelle mit LONG-Spalten ausgeführt. Das Kommando ist bei der Verarbeitung der LONG-Werte abgebrochen. Die Fehlermeldung enthält einen zusätzlichen Fehlertext, in dem die Ursache für den Fehler angegeben wird.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


-25364: Name of table to import <table_name> and the table currently being processed in data file <file_name> do not match

Erläuterung:

Sie versuchen die Daten der Tabellen einer gesamten Datenbank, eines Datenbankbenutzers oder eines Schemas im Format PAGES oder RECORDS zu importieren. Die Tabellennamen der Einträge in den Loader Systemtabellen und der Datendatei sind unterschiedlich. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache des Fehlers beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und stellen Sie die Ausgangssituation auf dem Zielsystem wieder her. Führen Sie daraufhin das Kommando zum Importieren (IMPORT) erneut aus.


-25365: Data file corrupted: trailer not found (SAP-Bibliothek - Grundwissen)

-25365: Data file corrupted: trailer not found

Erläuterung:

Sie versuchen Daten im Format PAGES oder RECORDS zu importieren .
Bei der Überprüfung des Datenformats wurde festgestellt, daß die Daten nicht zu den
angegebenen Formaten konform sind.

Benutzerreaktion:
Führen Sie das Kommando zum Exportieren (EXPORT) erneut aus und stellen Sie die Ausgangssituation auf dem Zielsystem wieder her. Führen Sie daraufhin das Kommando zum Importieren (IMPORT) erneut aus.


-25366: Data file corrupted: header not found (SAP-Bibliothek - Grundwissen)

-25366: Data file corrupted: header not found

Erläuterung:

Sie versuchen Daten im Format PAGES oder RECORDS zu importieren. Bei der Überprüfung des Datenformats wurde festgestellt, daß die Daten nicht zu den angegebenen Formaten konform sind.

Benutzerreaktion:
Führen Sie das Kommando zum Exportieren (EXPORT) erneut aus und stellen Sie die Ausgangssituation auf dem Zielsystem wieder her. Führen Sie daraufhin das Kommando zum Importieren (IMPORT) erneut aus.


-25371: Error converting data from <source_encoding> to <target_encoding>. Source contains invalid characters or character sequences

Erläuterung:

Die Konvertierung von Daten mit der Kodierung <source_encoding> in Daten der Kodierung <target_encoding> kann nicht vorgenommen werden. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache des Fehlers beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


-25390: Error generating CREATE TABLE/INDEX statements. Table name is ambiguous (different users have a table with this name)

Erläuterung:

Eine Tabelle oder ein Index mit demselben Name existiert bereits.

Benutzerreaktion:

Lösen Sie den Namenskonflikt, indem Sie die existierende Tabelle umbenennen oder löschen.


-25391: SQL statement is too long (SAP-Bibliothek - Grundwissen)

-25391: SQL statement is too long

Erläuterung:

Die Länge einer SQL-Anweisung überschreitet die Paketgröße der Auftragsschnittstelle.

Benutzerreaktion:

Vergrößern Sie die Paketgröße der Auftragsschnittstelle und führen Sie die SQL-Anweisung erneut aus.


-25392: [SAP AG][SQLOD32 DLL][MaxDB] <error_text> (SAP-Bibliothek - Grundwissen)

-25392: [SAP AG][SQLOD32 DLL][MaxDB] <error_text>

Erläuterung:

Es trat ein Fehler bei der Verarbeitung einer SQL-Anweisung auf. Die Fehlerursache ist in <error_text> näher beschrieben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie die SQL-Anweisung erneut aus.


-25393: Error during check if table <table_name> exists <error_text>

Erläuterung:

Bei der Prüfung der Existenz der Tabelle <table_name> trat ein Fehler auf.
Die Fehlerursache ist in <error_text> näher beschrieben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


-25394: Catalog of table <table_name> changed while processing <import> command; reparse failed; To restart the command append <record_no> to the infile specification.

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) von Daten in eine Tabelle ausgeführt. Während des Imports wurde die Definition der Tabelle geändert. Der Datenbankkern meldet beim Parsen der neuen Tabellendefinition eine Fehler. Der Import wird abgebrochen.

Benutzerreaktion:

Wiederholen Sie das Import Kommando, nachdem Sie den Ausgangszustand der Tabelle wiederhergestellt haben oder ändern Sie das ursprüngliche Import Kommando ab. Hierfür fügen Sie an das ursprüngliche Import Kommando die Klausel START <recordnumber> MAXROWS an, die Ihnen im Fehlertext vorgeschlagen wird.


-25401: Error reading system table SYSLOADER.CODEPAGE (SAP-Bibliothek - Grundwissen)

-25401: Error reading system table SYSLOADER.CODEPAGE

Erläuterung:

Sie haben das Kommando SET CODEPAGE ausgeführt. Die Systemtabelle SYSLOADER.CODEPAGE konnte nicht gelesen werden.

Benutzerreaktion:

Der Loader liest die CODEPAGE Information direkt aus der CODEPAGE Datei. Es ist daher keine weitere Benutzerreaktion notwendig.


-25402: Error creating/granting system table SYSLOADER.CODEPAGE <code_page>; using codepage file

Erläuterung:

Sie haben das Kommando SET CODEPAGE ausgeführt. Die Systemtabelle SYSLOADER.CODEPAGE konnte nicht angelegt oder das Recht zum Lesen aus der Tabelle nicht an vergeben werden.

Benutzerreaktion:

Der Loader liest die CODEPAGE Information direkt aus der CODEPAGE Datei. Es ist daher keine weitere Benutzerreaktion notwendig.


-25403: Error opening/reading code page file <code_page>. Can't use code page conversion

Erläuterung:

Sie haben versucht mit dem SET CODEPAGE Kommando die Codepage Datei <code_page>.txt in die SYSLOADER.CODEPAGE Tabelle zu importieren. Die Datei befindet sich nicht im CODEPAGE Verzeichnis oder kann nicht geöffnet werden.

Benutzerreaktion:

Importieren Sie die gewünschte CODEPAGE-Datei von der Internetseite http://www.unicode.org/ in das CODEPAGE-Verzeichnis des Loader und führen Sie das Kommando SET CODEPAGE erneut aus.


-25404: Invalid HEX constant <hex_value> found in code page file. The file might be corrupted

Erläuterung:

Sie haben versucht mit dem SET CODEPAGE Kommando eine Codepage Datei in die SYSLOADER.CODEPAGE Tabelle zu importieren. Eine Überprüfung der CODEPAGE-Datei ergab, daß diese nicht konform zur Formatierung von CODEPAGE-Dateien ist.

Benutzerreaktion:

Importieren Sie die gewünschte CODEPAGE-Datei von der Internetseite http://www.unicode.org/ in das CODEPAGE-Verzeichnis des Loader und führen Sie das Kommando SET CODEPAGE erneut aus.


-25405: Invalid ASCII values read or values not sorted in ascending order; The file might be corrupted

Erläuterung:

Sie haben versucht mit dem SET CODEPAGE Kommando eine Codepage Datei in die SYSLOADER.CODEPAGE Tabelle zu importieren. Eine Überprüfung der CODEPAGE-Datei ergab, daß diese nicht konform zur Formatierung von CODEPAGE-Dateien ist.

Benutzerreaktion:

Importieren Sie die gewünschte CODEPAGE-Datei von der Internetseite http://www.unicode.org/ in das CODEPAGE-Verzeichnis des Loader und führen Sie das Kommando SET CODEPAGE erneut aus.


-25451: Integrity violation (SQL_Error) (SAP-Bibliothek - Grundwissen)

-25451: Integrity violation (SQL_Error)

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) von Daten im PAGE Format ausgeführt. Die Daten genügen nicht den Integritätsbedingungen der Katalogbeschreibung der Datenbanktabelle.

Benutzerreaktion:

Passen Sie die zu importierenden Daten an die Integritätsbedingung der Katalogbeschreibung der Datenbanktabelle an, oder passen Sie die Integritätsbedingung der Katalogbeschreibung der Datenbanktabelle an die zu importierenden Daten an. Führen Sie das Kommando daraufhin erneut aus.


-25498: Errors processing data for table <table_name>; No data imported/updated.

Erläuterung:

Sie haben ein Kommando zum Importieren von Daten einer Tabelle (IMPORT) oder Aktualisieren von Spaltenwerten einer Tabelle (UPDATE) ausgeführt. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache des Fehlers beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


-25499: Errors processing data for table <table_name>. Data not completely imported/updated

Erläuterung:

Sie haben ein Kommando zum Importieren von Daten einer Tabelle (IMPORT) oder Aktualisieren von Spaltenwerten einer Tabelle (UPDATE) ausgeführt. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache für den Fehler beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


-25500: Errors processing command exceed maximum number of errors to ignore; processing stopped

Erläuterung:

Sie haben mit dem Kommando SET MAXERRORCOUNT die Anzahl während der Verarbeitung zu ignorierender Fehler angegeben. Diese Schranke wurde während der Verarbeitung des Loader Kommandos überschritten.

Benutzerreaktion:

Erhöhen Sie mit dem Kommando SET MAXERRORCOUNT die Anzahl während der Verarbeitung zu ignorierender Fehler oder beheben Sie die in der Loader Protokolldatei protokollierten Fehler : Führen Sie daraufhin das Kommando erneut aus.


-25501: Error opening file <file_name> : <error_text>

Erläuterung:

Im Fehlertext des Betriebssystems erscheint ein betriebssystemabhängiger Text, der den aufgetretenen Fehler benennt. Ursachen können sein, dass es keine Datei mit diesem Namen gibt, dass die angegebene Platte schreibgeschützt ist usw.

Benutzerreaktion:

Geben Sie einen anderen Dateiname an oder beseitigen Sie die Fehlerursache (auf Betriebssystemebene).


-25502: Error closing file <file_name> : <error_text>

Erläuterung:

Im Fehlertext des Betriebssystems erscheint ein betriebssystemabhängiger Text, der den aufgetretenen Fehler benennt.

Benutzerreaktion:

Eine Benutzerreaktion ist nicht erforderlich.


-25503: Error reading file <file_name> : <error_text>

Erläuterung:

Im Fehlertext des Betriebssystems erscheint ein betriebssystemabhängiger Text, der den aufgetretenen Fehler benennt.

Benutzerreaktion:

Beseitigen Sie die Ursache für diesen Fehler und starten Sie den Loader zur Bearbeitung des abgebrochenen Kommandos erneut.


-25504: Error writing file <file_name> : <error_text>

Erläuterung:

Im Fehlertext des Betriebssystems erscheint ein betriebssystemabhängiger Text, der den aufgetretenen Fehler benennt.

Benutzerreaktion:

Beseitigen Sie die Ursache für diesen Fehler und starten Sie den Loader zur Bearbeitung des abgebrochenen Kommandos erneut.


-25505: Error erasing file <file_name> : <error_text>

Erläuterung:

Im Fehlertext des Betriebssystems erscheint ein betriebssystemabhängiger Text, der den aufgetretenen Fehler benennt.

Benutzerreaktion:

Eine Benutzerreaktion ist nicht erforderlich.


-25507: Error truncating file <file_name> : <error_text>

Erläuterung:

In Fehlertext des Betriebssystems erscheint ein betriebssystemabhängiger Text, der den aufgetretenen Fehler benennt. Ursachen können sein, dass es keine Datei mit diesem Namen gibt, dass die angegebene Platte schreibgeschützt ist, usw.

Benutzerreaktion:

Geben Sie einen anderen Dateiname an oder beseitigen Sie die Fehlerursache auf Betriebssystemebene.


-25508: File <file_name> is not encoded as <encoding>

Erläuterung:

Die im Loader Kommando angegebene Kodierung der Datei und die tatsächliche Kodierung der Datei sind unterschiedlich.

Benutzerreaktion:

Geben Sie die korrekte oder aber keine Kodierung der Datei im Loader Kommando an.
Falls Sie keine Kodierung angeben, ermittelt der Loader die korrekte Kodierung anhand
des Dateiinhalts.


-25551: Error importing statistics: <error_text> (SAP-Bibliothek - Grundwissen)

-25551: Error importing statistics: <error_text>

Erläuterung:

Sie haben versucht, Statistiken einer Tabelle, eines Schemas, eines Datenbankbenutzers oder einer gesamten Datenbank zu importieren. Dabei ist ein Fehler aufgetreten, der in <error_text> näher beschrieben ist.

Benutzerreaktion:

Beheben Sie den Fehler und führen Sie das Kommando erneut aus.


-25552: Error exporting statistics: <error_text> (SAP-Bibliothek - Grundwissen)

-25552: Error exporting statistics: <error_text>

Erläuterung:

Sie haben versucht, Statistiken einer Tabelle, eines Schemas, eines Datenbankbenutzers oder einer gesamten Datenbank zu exportieren. Dabei ist ein Fehler aufgetreten, der in <error_text> näher beschrieben ist.

Benutzerreaktion:

Beheben Sie den Fehler und führen Sie das Kommando erneut aus.


-25601: Error restoring table <table_name>. Table does not exist – table must be created before import.

Erläuterung:

Sie haben versucht, Daten im datenbankeigenen Format PAGES in eine Tabelle zu importieren, die der Loader im Datenbankkatalog nicht findet.

Benutzerreaktion:

Wenn eine Tabelle mit dem angegebenen Namen in der Datenbank existiert, stellen Sie sicher, dass die Tabelle voll qualifiziert im Kommando angegeben wird. Wenn die Tabelle nicht existiert, legen Sie die Tabelle an. Führen Sie das Kommando erneut aus.


-25602: Error restoring table <table_name>. Table is not empty.

Erläuterung:

Sie haben versucht, Daten im datenbankeigenen Format PAGES zu Importieren. Die zu importierende Tabelle <table_name> war nicht leer.

Benutzerreaktion:

Löschen Sie den Inhalt der Tabelle und führen Sie das Kommando erneut aus.


-25603: Error processing IMPORT in PAGE Format. Loader versions used for EXPORT and IMPORT differ (EXPORT <version>, IMPORT <version>)

Erläuterung:

Sie haben versucht, Daten, die im datenbankeigenen Format PAGES exportiert wurden, wieder zu importieren. Dabei hat der Loader festgestellt, dass sich die Version des Loader, der zum Importieren der Daten genutzt wird, von der Version des Loader unterscheidet, mit der die Daten exportiert wurden. Um sicherzustellen, dass die Daten korrekt wieder importiert werden, muss zum Import wie zum Export der Daten im Format PAGES ein Loader der gleichen Version genutzt werden.

Benutzerreaktion:

Starten Sie den Import mit einem Loader der Version, wie er auch zum Export genutzt wurde.


-25801: Internal error [<file_name>,<line_no>,<error_code>]. Contact support.

Erläuterung:

Es ist ein interner Programmfehler aufgetreten.

Benutzerreaktion:

Verständigen Sie den Support und übermitteln Sie die Ausgaben der Fehlermeldung.


Von -27000 bis -28999 (SAP-Bibliothek - Grundwissen)

Von -27000 bis -28999

Fehlermeldungen des liveCache

-27000 | Unknown error
-27003 | Numeric input parameter overflow
-27006 | Incompatible data types
-27009 | Command too long
-27014 | Connect not ok
-27015 | Connection down
-27016 | DB shut down
-27017 | Too many users
-27018 | Connection error
-27019 | Conversion UNICODE to ASCII not possible
-28001 | Access via NIL OID
-28002 | Invalid OID
-28003 | Unknown GUID
-28005 | Duplicate object
-28006 | Object not locked
-28007 | OID not compatible with given class
-28501 | Error reading OMS input stream
-28502 | Error writing OMS output stream
-28503 | Crash in DB-Procedure
-28505 | No component object found
-28508 | Unsupported parameter type
-28514 | Unknown OMS version
-28515 | OMS Version already open
-28516 | Commit or Rollback required
-28517 | Already in Critical Section
-28518 | Not in Critical Section
-28521 | Already in version
-28522 | Missing before image
-28523 | Unknown schema
-28524 | Duplicate schema
-28525 | Procedure Address not found
-28527 | Directory not found
-28529 | Too small name buffer
-28530 | omsTerminate called
-28531 | OMS read only
-28532 | Version bound by transaction
-28533 | Integer out of packed range
-28534 | Package must be recreated
-28600 | Invalid request code in package
-28601 | Object data packet for read missing
-28602 | Packet size does not match object size
-28603 | Requested packet size to transfer an object is too big
-28604 | Trying to queue too many data packets when sending object data
-28605 | Invalid operation in UDE Server-Kernel communication
-28606 | Communication error
-28607 | Missing object data packet
-28608 | Invalid reply for stored procedure
-28609 | Stored procedure not found
-28801 | Wrong class id
-28802 | Wrong object version
-28803 | Wrong object state
-28804 | Too old OID
-28806 | Nil page pointer
-28808 | Hash not found
-28810 | Duplicate hash key
-28813 | Unknown consistent version
-28814 | Object not found
-28815 | Object history not found
-28817 | Wrong object length
-28818 | Wrong object position
-28819 | Object has been updated by other transactions
-28823 | Page already in use
-28826 | Pagecounter inconsistent
-28828 | Inconsistent information concerning “is container dropped”
-28902 | Too many nested try/catch statements
-28903 | DBFunction $1 must return a value
-28822 bis -28999 | Internal Error


-27000: Unknown error (SAP-Bibliothek - Grundwissen)

-27000: Unknown error

Erklärung:

Es ist ein Systemfehler aufgetreten.

Benutzerreaktion:

Verständigen Sie den Support.


-27003: Numeric input parameter overflow (SAP-Bibliothek - Grundwissen)

-27003: Numeric input parameter overflow

Erklärung:

Es trat ein Überlauf auf entweder

· bei einer lesenden SQL-Anweisung:
beim Übertragen eines numerischen Wertes aus der Datenbankinstanz in eine Host-Variable

oder

· bei einer schreibenden SQL-Anweisung:
beim Übertragen eines numerischen Wertes einer Host-Variable in die Datenbankinstanz

Benutzerreaktion:

Verständigen Sie den Support.


-27006: Incompatible data types (SAP-Bibliothek - Grundwissen)

-27006: Incompatible data types

Erklärung:

Es wurde entweder versucht

· bei einer lesenden SQL-Anweisung einen Wert aus der Datenbankinstanz in eine inkompatible Host-Variable zu lesen

oder

· bei einer schreibenden SQL-Anweisung den Wert einer inkompatiblen Host-Variable in die Datenbankinstanz zu schreiben.

Benutzerreaktion:

Verständigen Sie den Support.


-27009: Command too long (SAP-Bibliothek - Grundwissen)

-27009: Command too long

Erklärung:

Es wurde versucht eine zu lange SQL-Anweisung zu preparieren oder auszuführen.

Benutzerreaktion:

Verständigen Sie den Support.


-27014: Connect not ok (SAP-Bibliothek - Grundwissen)

-27014: Connect not ok

Erklärung:

Es trat ein nicht näher spezifizierter Fehler beim Verbindungsaufbau auf.

Benutzerreaktion:

Verständigen Sie den Support.


-27015: Connection down (SAP-Bibliothek - Grundwissen)

-27015: Connection down

Erklärung:

Die Verbindung zum liveCache ist abgebrochen.

Benutzerreaktion:

Verständigen Sie den Support.


-27016: DB shut down (SAP-Bibliothek - Grundwissen)

-27016: DB shut down

Erklärung:

Es wurde versucht über die externe SQL-Klasse eine Verbindung zu einer Datenbankinstanz im Betriebszustand OFFLINE aufzubauen.

Benutzerreaktion:

Verständigen Sie den Support.


-27017: Too many users (SAP-Bibliothek - Grundwissen)

-27017: Too many users

Erklärung:

Die Anzahl der maximal möglichen Verbindungen zur Datenbankinstanz wurde überschritten.

Benutzerreaktion:

Verständigen Sie den Support.


-27018: Connection error (SAP-Bibliothek - Grundwissen)

-27018: Connection error

Erklärung:

Bei der Ausführung einer SQL-Anweisung im liveCache trat ein nicht näher spezifizierter Verbindungsfehler auf.

Benutzerreaktion:

Verständigen Sie den Support.


-27019: Conversion UNICODE to ASCII not possible (SAP-Bibliothek - Grundwissen)

-27019: Conversion UNICODE to ASCII not possible

Erklärung:

Es sollte eine UNICODE-Zeichenkette aus der Datenbankinstanz in eine ASCII-Variable gelesen werden. Mindestens ein Zeichen ist jedoch ein UNICODE-Zeichen, das somit nicht nach ASCII konvertiert werden kann.

Dieser Fehler kann nur dann auftreten, wenn im liveCache Unicode-Spalten mittels nativer SQL gefüllt wurden oder sowohl Unicode- als auch ASCII-Anwendungen dieselbe liveCache-Instanz verwenden.

Benutzerreaktion:

Falls Sie im liveCache Unicode-Spalten mittels nativer SQL geändert haben, überprüfen Sie, ob diese Änderungen ASCII-kompatibel sind.

Falls Sie keine Änderungen mittels nativer SQL vorgenommen haben, verständigen Sie Ihren lokalen Support.


-28001: Access via NIL OID (SAP-Bibliothek - Grundwissen)

-28001: Access via NIL OID

Erklärung:

Es wurde eine OMS-Operation, z.B. Dereferenzierung (omsDeref) unter Angabe der NIL Oid versucht. Dies ist nicht zulässig.

Benutzerreaktion:

Verständigen Sie den Support.


-28002: Invalid OID (SAP-Bibliothek - Grundwissen)

-28002: Invalid OID

Erklärung:

Bei einer OMS-Operation wurde eine nicht zulässige OID angegeben.

Dies ist der Fall, wenn der Seitennummer- oder Positionsanteil der OID ausserhalb der zulässigen Grenzen liegt.

Benutzerreaktion:

Verständigen Sie den Support.


-28003: Unknown GUID (SAP-Bibliothek - Grundwissen)

-28003: Unknown GUID

Erklärung:

Es wurde eine nicht registrierte Klasse angesprochen.

Vor dem ersten Zugriff auf eine persistente Klasse muss sie durch Aufruf vom omsRegClass registriert werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28005: Duplicate object (SAP-Bibliothek - Grundwissen)

-28005: Duplicate object

Erklärung:

Es wird versucht eine Kopie eines variabel langen Objekts zu erzeugen (omsLoadVarObject), obwohl der Aufrufer bereits eine Kopie davon besitzt.

Diese muss zuvor mit omsReleaseVarObject freigegeben werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28006: Object not locked (SAP-Bibliothek - Grundwissen)

-28006: Object not locked

Erklärung:

Beim Ändern oder Löschen einer Instanz einer persistenten Klasse hat der liveCache festgestellt, dass die aktuelle Transaktion keine Sperre für die Instanz besitzt.

Dies ist nicht zulässig.

Benutzerreaktion:

Verständigen Sie den Support.


-28007: OID not compatible with given class (SAP-Bibliothek - Grundwissen)

-28007: OID not compatible with given class

Erklärung:

Es wird versucht ein Objekt zu derefenzieren, dessen OID nicht zu der vorgegebenen Klassen passt.

OID und Objekt nicht typverträglich.

Benutzerreaktion:

Verständigen Sie den Support.


-28501: Error reading OMS input stream (SAP-Bibliothek - Grundwissen)

-28501: Error reading OMS input stream

Erklärung:

Beim Lesen aus einer internen ABAP-Tabelle oder in einem Stream ist ein Fehler aufgetreten.

Nähere Informationen können der Datei knldiag des liveCache entnommen werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28502: Error writing OMS output stream (SAP-Bibliothek - Grundwissen)

-28502: Error writing OMS output stream

Erklärung:

Beim Schreiben in eine interne ABAP-Tabelle oder in einen Stream ist ein Fehler aufgetreten. Nähere Informationen können der Datei knldiag des liveCache entnommen werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28503: Crash in DB-Procedure (SAP-Bibliothek - Grundwissen)

-28503: Crash in DB-Procedure

Erklärung:

Beim Aufruf einer DB-Prozedur ist im Code der Methode der entsprechenden Komponenteninstanz eine unbehandelte Exception aufgetreten.

Nähere Informationen können der Datei knldiag des liveCache entnommen werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28505: No Component Object found (SAP-Bibliothek - Grundwissen)

-28505: No Component Object found

Erklärung:

Die OMS-Bibliothek konnte beim Starten des liveCache nicht geladen werden.

Ein Betrieb des liveCache ist somit nicht möglich.

Benutzerreaktion:

Verständigen Sie den Support.


-28508: Unsupported parameter type (SAP-Bibliothek - Grundwissen)

-28508: Unsupported parameter type

Erklärung:

Einem Parameter einer Methode einer Komponentenklasse kann vom liveCache kein SQL Datentyp zugeordnet werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28514: Unknown OMS Version (SAP-Bibliothek - Grundwissen)

-28514: Unknown OMS Version

Erklärung:

Beim Aufruf von omsOpenVersion, OmsCloseVersion, omsDropVersion oder omsRenameVersion wurde vom liveCache festgestellt, dass die angegebene OMS-Version nicht existiert.

Benutzerreaktion:

Verständigen Sie den Support.


-28515: OMS Version already open (SAP-Bibliothek - Grundwissen)

-28515: OMS Version already open

Erklärung:

Beim Aufruf von omsOpenVersion wurde vom liveCache festgestellt, dass die angesprochene OMS-Version bereits durch eine konkurrierende Task geöffnet worden ist.

Die OMS-Version kann erst geöffnet werden, wenn diese Task die Version geschlossen und die Transaktion beendet hat.

Benutzerreaktion:

Verständigen Sie den Support.


-28516: Commit or Rollback required (SAP-Bibliothek - Grundwissen)

-28516: Commit or Rollback required

Erklärung:

Bei Aufruf von omsCreateVersion, omsOpenVersion oder omsDropVersion wurde vom liveCache festgestellt, dass in der aktuellen Transaktion zuvor bereits Änderungen an Instanzen persistenter Klassen vorgenommen worden sind.

Dies ist nicht zulässig, die aktuelle Transaktion muss zuvor beendet werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28517: Already in Critical Section (SAP-Bibliothek - Grundwissen)

-28517: Already in Critical Section

Erklärung:

Es wurde die Funktion omsEnter für eine Instanz von OmsCriticalSection aufgerufen, obwohl sich diese Instanz bereits im kritischen Abschnitt befindet.

Dies ist nicht zulässig.

Benutzerreaktion:

Verständigen Sie den Support.


-28518: Not in Critical Section (SAP-Bibliothek - Grundwissen)

-28518: Not in Critical Section

Erklärung:

Es wurde die Funktion omsLeave für eine Instanz von OmsCriticalSection aufgerufen, obwohl sich die Instanz nicht im kritischen Abschnitt befindet.

Dies ist nicht zulässig.

Benutzerreaktion:

Verständigen Sie den Support.


-28521: Already in version (SAP-Bibliothek - Grundwissen)

-28521: Already in version

Erklärung:

Beim Aufruf der Funktion omsOpenVersion wurde vom liveCache festgestellt, dass sich der Aufrufer bereits in einer OMS-Version befindet.

Dies ist nicht zulässig.

Benutzerreaktion:

Verständigen Sie den Support.


-28522: Missing before image (SAP-Bibliothek - Grundwissen)

-28522: Missing before image

Erklärung:

Beim Aufruf der Funktion omsStore wurde festgestellt, dass für das zu ändernde Objekt kein Before-Image existiert.

Im diesem Fall wurde für das Objekt kein ForUpd-Zeiger angefordert.

Änderungen an dem Objekt sind somit nicht zulässig.

Benutzerreaktion:

Verständigen Sie den Support.


-28523: Unknown schema (SAP-Bibliothek - Grundwissen)

-28523: Unknown schema

Erklärung:

Es wird versucht auf ein nicht existierendes Strukturlink liveCache-Schema zuzugreifen.

Dies kann beim Registrieren oder Löschen eines Containers oder beim Lösen eines liveCache-Schemas der Fall sein.

Benutzerreaktion:

Verständigen Sie den Support.


-28524: Duplicate schema (SAP-Bibliothek - Grundwissen)

-28524: Duplicate schema

Erklärung:

Beim Aufruf der Funktion omsCreateSchema wird vom liveCache festgestellt, dass ein Strukturlink liveCache-Schema des angegebenen Namens bereits existiert.

Dies ist nicht zulässig.

Benutzerreaktion:

Verständigen Sie den Support.


-28525: Procedure Address not found (SAP-Bibliothek - Grundwissen)

-28525: Procedure Address not found

Erklärung:

Die beim Aufruf von dbpGetProcAddress angegebene Funktion konnte nicht lokalisiert werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28527: Directory not found (SAP-Bibliothek - Grundwissen)

-28527: Directory not found

Erklärung:

Beim Aufruf von dbpGetDbrootSapPath oder dbpGetWorkingDirectory konnte der Pfadname nicht geliefert werden.

Der Puffer zur Aufnahme des Namens ist zu klein.

Benutzerreaktion:

Verständigen Sie den Support.


-28529: Too small name buffer (SAP-Bibliothek - Grundwissen)

-28529: Too small name buffer

Erklärung:

Beim Aufruf von omsGetLiveCacheVersion, omsGetLocalDateTime, omsGetLocalDateTime oder omsGetSchemaName ist der Puffer für den Rückgabewerte zu klein.

Benutzerreaktion:

Verständigen Sie den Support.


-28530: omsTerminate called (SAP-Bibliothek - Grundwissen)

-28530: omsTerminate called

Erklärung:

Die Methode omsTerminate wurde gerufen.

Hierdurch wurden alle Komponenteninstanzen der betroffenen Sitzung aufgelöst und die aktuelle Transaktion zurückgesetzt.

Benutzerreaktion:

Verständigen Sie den Support.


-28531: OMS read only (SAP-Bibliothek - Grundwissen)

-28531: OMS read only

Erklärung:

Es wurde versucht ein Objekt zu sperren, obwohl sich die aufrufende Sitzung im Nur-Lese-Betrieb befindet. Dies ist nicht zulässig.

Benutzerreaktion:

Verständigen Sie den Support.


-28532: Version bound by transaction (SAP-Bibliothek - Grundwissen)

-28532: Version bound by transaction

Erklärung:

Beim Aufruf von omsOpenVersion wurde vom liveCache festgestellt, dass die angesprochene OMS-Version noch durch eine konkurrierende Task gebunden, jedoch nicht geöffnet ist.

Die Version kann erst geöffnet werden, wenn diese Task ihre Transaktion beendet hat.

Benutzerreaktion:

Verständigen Sie den Support.


-28533: Integer out of packed range (SAP-Bibliothek - Grundwissen)

-28533: Integer out of packed range

Erklärung:

Es soll ein Integer-Wert von 8 Byte in einen Wert vom Typ OmsTypePacked_8_3 umgewandelt werden, der außerhalb des zulässigen Bereichs liegt.

Benutzerreaktion:

Verständigen Sie den Support.


-28534: Package must be recreated (SAP-Bibliothek - Grundwissen)

-28534: Package must be recreated

Erklärung:

Die dem Package zugeordnete Bibliothek wurde nach dem Erzeugen des Package verändert.

Benutzerreaktion:

Löschen Sie das Package und erzeugen Sie es neu.


-28600: Invalid request code in packet (SAP-Bibliothek - Grundwissen)

-28600: Invalid request code in packet

Erklärung:

Das Paket enthält ungültigen Anfrage-Code.

Benutzerreaktion:

Wenden Sie sich an Ihren lokalen Support.


-28601: Object data packet for read missing (SAP-Bibliothek - Grundwissen)

-28601: Object data packet for read missing

Erklärung:

Ein Datenpaket fehlt, weil ein Endpunkt zu wenig Pakete gesendet hat.

Dieser Fehler tritt nur auf, wenn Socket-Kommunikation verwendet wird. Bei einer Shared-Memory-Kommunikation werden Daten direkt über Shared Memory ausgetauscht. Im Unterschied hierzu werden Daten bei einer Socket-Kommunikation in Extra-Paketen vor dem Anfrage- bzw. nach dem Antwort-Paket gesendet.

Benutzerreaktion:

Wenden Sie sich an Ihren lokalen Support.


-28602: Packet size does not match object size (SAP-Bibliothek - Grundwissen)

-28602: Packet size does not match object size

Erklärung:

Dieser Fehler tritt nur auf, wenn Nicht-Shared-Memory-Kommunikation verwendet wird.

Die angegebene Objektgröße stimmt nicht mit der empfangenen Paketgröße überein.

Benutzerreaktion:

Wenden Sie sich an Ihren lokalen Support.


-28603: Requested packet size to transfer an object is too big (SAP-Bibliothek - Grundwissen)

-28603: Requested packet size to transfer an object is too big

Erklärung:

Die Paketgröße, die im Kommunikationskanals erlaubt ist, ist zu klein, um das Objekt aufzunehmen.

Benutzerreaktion:

Vergrößern Sie die Paketgröße für den Kommunikationskanal.


-28604: Trying to queue too many data packets when sending object data

Erklärung:

Die Obergrenze für die Größe der Warteschlange für die Nicht-Shared-Memory-Kommunikation wurde erreicht. Dieser Fehler tritt oft bei Massen-Operationen auf, wenn zu viele Objekte in der Warteschlange sind.

Benutzerreaktion:

Ändern Sie den Code, der die Warteschlange für Pakete steuert, so dass weniger Pakete in die Warteschlange gelangen. Massen-Operationen sollten maximal 100 Pakete in die Warteschlange schicken.


-28605: Invalid operation in UDE Server-Kernel communication (SAP-Bibliothek - Grundwissen)

-28605: Invalid operation in UDE Server-Kernel communication

Erklärung:

Es wurde versucht, in einer Shared-Memory-Kommunikation Objektdaten über einen Kommunikationskanal zu senden. In einer Shared-Memory-Kommunikation werden Objektdaten immer über Adressen im Shared Memory ausgetauscht, das Senden über einen Kommunikationskanal ist nicht möglich.

Benutzerreaktion:

Wenden Sie sich an Ihren lokalen Support.


-28606: Communication error (SAP-Bibliothek - Grundwissen)

-28606: Communication error

Erklärung:

Dieser Fehler tritt nur auf, wenn Socket-Kommunikation verwendet wird.

Ein unerwartetes Datenpaket wurde empfangen oder die Größe des Datenpakets stimmt nicht mit der im Anfragepaket angegebenen Größe des Objekts überein.

Benutzerreaktion:

Wenden Sie sich an Ihren lokalen Support.


-28607: Missing object data packet (SAP-Bibliothek - Grundwissen)

-28607: Missing object data packet

Erklärung:

Ein Datenpaket fehlt, weil ein Endpunkt zu wenig Pakete gesendet hat.

Dieser Fehler tritt nur auf, wenn Socket-Kommunikation verwendet wird. Bei einer Shared-Memory-Kommunikation werden Daten direkt über Shared Memory ausgetauscht. Im Unterschied hierzu werden Daten bei einer Socket-Kommunikation in Extra-Paketen vor dem Anfrage- bzw. nach dem Antwort-Paket gesendet.

Benutzerreaktion:

Wenden Sie sich an Ihren lokalen Support.


-28608: Invalid reply for stored procedure (SAP-Bibliothek - Grundwissen)

-28608: Invalid reply for stored procedure

Erklärung:

Das Antwort-Paket passt nicht zur Anfrage.

Benutzerreaktion:

Wenden Sie sich an Ihren lokalen Support.


-28609: Stored procedure not found (SAP-Bibliothek - Grundwissen)

-28609: Stored procedure not found

Erklärung:

Der Benutzer hat versucht, eine gespeicherte Prozedur aufzurufen. Diese Prozedur konnte jedoch nicht in der zugeordneten DB-Prozedur gefunden werden.

Benutzerreaktion:

Überprüfen Sie, ob die Prozedur mit ihrer DB-Prozedur-Definition im Datenbankkatalog übereinstimmt.


-28801: Wrong class id (SAP-Bibliothek - Grundwissen)

-28801: Wrong class id

Erklärung:

Beim Zugriff auf ein Objekt wurde eine fehlerhafte Container-Identifikation verwendet.

Es handelt sich um einen liveCache-internen Fehler, der nicht durch fehlerhafte Handhabung des OMS API hervorgerufen werden kann.

Benutzerreaktion:

Verständigen Sie den Support.


-28802: Wrong object version (SAP-Bibliothek - Grundwissen)

-28802: Wrong object version

Erklärung:

Beim Sperren eines Objektes wurde festgestellt, dass das Objekt zwischenzeitlich bereits gelöscht und wiederverwendet wurde.

Dieser Fehler wird in eine OmsOutOfDate Exceptionübersetzt, kann aber als Fehler in der knldiag-Datei protokolliert werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28803: Wrong object version (SAP-Bibliothek - Grundwissen)

-28803: Wrong object version

Erklärung:

Beim Zugriff auf ein Objektes wurde festgestellt, dass es zwischenzeitlich bereits gelöscht wurde. Dieser Fehler wird in eine OmsOutOfDate Exceptionübersetzt, kann aber als Fehler in der knldiag-Datei protokolliert werden.

Benutzerreaktion:

Verständigen Sie den Support.


-28804: Too old OID (SAP-Bibliothek - Grundwissen)

-28804: Too old OID

Erklärung:

Beim Dereferenzieren einer OID kann vom liveCache nicht entschieden werden, ob die OID jemals existierte.

Siehe auch Fehlermeldung –28815.

Dieser Fehler wird in eine OmsOutOfDate Exception übersetzt.

Benutzerreaktion:

Verständigen Sie den Support.


-28806: Nil page pointer (SAP-Bibliothek - Grundwissen)

-28806: Nil page pointer

Erklärung:

Das Container-Verzeichnis ist inkonsistent.

Es handelt sich um einen liveCache-internen Fehler, der nicht durch fehlerhafte Handhabung des OMS API hervorgerufen werden kann.

Benutzerreaktion:

Verständigen Sie den Support.


-28808: Hash not found (SAP-Bibliothek - Grundwissen)

-28808: Hash not found

Erklärung:

Ein B*Baum eines Keyed-Object-Containers konnte nicht gefunden werden.

Es handelt sich um einen liveCache-internen Fehler, der nicht durch fehlerhafte Handhabung des OMS API hervorgerufen werden kann.

Benutzerreaktion:

Verständigen Sie den Support.


-28810: Duplicate hash key (SAP-Bibliothek - Grundwissen)

-28810: Duplicate hash key

Erklärung:

Beim Einfügen in das globale Container-Verzeichnis wurde ein doppelter Eintrag festgestellt.

Es handelt sich um einen liveCache-internen Fehler, der nicht durch fehlerhafte Handhabung des OMS API hervorgerufen werden kann.

Benutzerreaktion:

Verständigen Sie den Support.


-28813: Unknown consistent version (SAP-Bibliothek - Grundwissen)

-28813: Unknown consistent version

Erklärung:

Es wird ein Zugriff auf ein Objekt in einer konsistenten Sicht versucht, die dem liveCache nicht mehr bekannt ist.

Es handelt sich um einen liveCache-internen Fehler, der nicht durch fehlerhafte Handhabung des OMS API hervorgerufen werden kann.

Benutzerreaktion:

Verständigen Sie den Support.


-28814: Object not found (SAP-Bibliothek - Grundwissen)

-28814: Object not found

Erklärung:

Es wurde eine nicht existierende OID dereferenziert.

Benutzerreaktion:

Verständigen Sie den Support.


-28815: Object history not found (SAP-Bibliothek - Grundwissen)

-28815: Object history not found

Erklärung:

Beim Dereferenzieren eines Objektes muss die konsistente Sicht der Instanz aus dem Datenbereich des liveCache befriedigt werden, der die Before-Images von persistenten Objekten enthält.

Before-Images sind entsprechend ihrer Vergangenheit von alt nach neu sortiert.

Im Normalfall werden nur diejenigen Before-Images gelöscht, auf die keine konsistente Sicht mehr zugreifen wird.

In Ausnahmefällen müssen aufgrund von Speicherplatzproblemen auch Before-Images gelöscht werden, auf die prinzipell konsistente Sichten noch zugreifen können.

In diesen Fällen kann der liveCache die angeforderte Sicht der Instanz nicht mehr liefern.

Je älter die konsistente Sicht desto eher tritt in den genannten Ausnahmesituationen dieses Phänomen auf.

Benutzerreaktion:

Verständigen Sie den Support.


-28817: Wrong object length (SAP-Bibliothek - Grundwissen)

-28817: Wrong object length

Erklärung:

Ein Objekt passt nicht in den bereitgestellten Speicherplatz.

Es handelt sich um einen liveCache-internen Fehler, der nicht durch fehlerhafte Handhabung des OMS API hervorgerufen werden kann.

Benutzerreaktion:

Verständigen Sie den Support.


-28818: Wrong object position (SAP-Bibliothek - Grundwissen)

-28818: Wrong object position

Erklärung:

Eine OID enthält eine unzulässige Positionsangabe.

Benutzerreaktion:

Verständigen Sie den Support.


-28819: Object has been updated by other transactions (SAP-Bibliothek - Grundwissen)

-28819: Object has been updated by other transactions

Erklärung:

Eine Instanz vom Typ OmsOutOfDate wurde als DbpError aufgefangen.

Benutzerreaktion:

Verständigen Sie den Support.


-28823: Page already in use (SAP-Bibliothek - Grundwissen)

-28823: Page already in use

Erklärung:

Es wurde versucht, eine Seite zu benutzen, die bereits als belegt markiert ist.

Benutzerreaktion:

Benachrichtigen Sie Ihren lokalen Support.


-28826: Pagecounter inconsistent (SAP-Bibliothek - Grundwissen)

-28826: Pagecounter inconsistent

Erklärung:

Die Angaben für den Pagecounter auf der Rootpage des Object-Containerfile und im Object-Filedirectory sind nicht konsistent.

Dieser Fehler kann auftreten, wenn CHECK DATA ausgeführt wird.

Benutzerreaktion:

Benachrichtigen Sie Ihren lokalen Support.


-28828: Inconsistent information concerning “is container dropped”

Erklärung:

Die Angaben zu „is container dropped“ auf der Rootpage des Object-Containerfile und im Object-Filedirectory sind nicht konsistent.

Dieser Fehler kann auftreten, wenn CHECK DATA ausgeführt wird.

Benutzerreaktion:

Benachrichtigen Sie Ihren lokalen Support.


-28902: Too many nested try/catch statements (SAP-Bibliothek - Grundwissen)

-28902: Too many nested try/catch statements

Erläuterung:

In einer Datenbankprozedur sind maximal 16 ineinander geschachtelte TRY/CATCH-Blöcke erlaubt.

Benutzerreaktion:

Kodieren Sie die Datenbankprozedur so, dass die Obergrenze von 16 ineinander geschachtelten TRY/CATCH-Blöcken nicht überschritten wird.


-28903: DBFunction$1 must return a value (SAP-Bibliothek - Grundwissen)

-28903: DBFunction$1 must return a value

Erklärung:

Eine Datenbankfunktion enthält keine RETURN-Anweisung und liefert somit kein Ergebnis. Dies ist nicht zulässig.

Benutzerreaktion:

Erweitern Sie die Datenbankfunktion um eine RETURN-Anweisung.


-28822 bis -28999: Internal Error (SAP-Bibliothek - Grundwissen)

-28822 bis -28999: Internal Error

Erklärung:

Es handelt sich um liveCache-interne Systemfehler.

Benutzerreaktion:

Verständigen Sie den Support.


Von 0 bis 1999 (SAP-Bibliothek - Grundwissen)

Von 0 bis 1999

Rückmeldungen aus dem Datenbankkern

0 | Success
100 | Row not found
200 | Duplicate key
250 | Duplicate secondary key
300 | Integrity violation
320 | View violation
350 | Referential integrity violated
360 | Foreign key integrity violation
400 | Lock collision
500 | Lock request timeout
600 | Work rolled back
650 | Work rolled back
700 | Session inactivity timeout (work rolled back)
710 | Session terminated by shutdown (work rolled back)
750 | Too many SQL statements (work rolled back)
1403 | Row not found


0: Success (SAP-Bibliothek - Grundwissen)

0: Success

Erläuterung:

Die SQL-Anweisung wurde erfolgreich ausgeführt. Der gewünschte Effekt wurde hergestellt.

Benutzerreaktion:

Eine Benutzerreaktion ist nicht erforderlich.


100: Row not found (SAP-Bibliothek - Grundwissen)

100: Row not found

Erläuterung:

Es gibt keine (weitere) Tabellenzeile, die die Qualifikation erfüllt.

Benutzerreaktion:

Eine Benutzerreaktion ist nicht erforderlich.


200: Duplicate key (SAP-Bibliothek - Grundwissen)

200: Duplicate key

Erläuterung:

Es gibt bereits eine Tabellenzeile mit dem einzufügenden Schlüssel.

Benutzerreaktion:

Prüfen Sie, ob die bereits existierende Tabellenzeile die gewünschten Werte enthält. Ist das nicht der Fall, prüfen Sie, ob Werte in der bestehenden Tabellenzeile durch die gewünschten ersetzt werden können. Muss eine neue Tabellenzeile eingefügt werden, ist der Wert des einzufügenden Schlüssels in der SQL-Anweisung zu ändern, damit keine Schlüsselkollision auftritt.


250: Duplicate secondary key (SAP-Bibliothek - Grundwissen)

250: Duplicate secondary key

Erläuterung:

Es gibt bereits eine Tabellenzeile mit dem angegebenen Sekundärschlüssel. Für den Sekundärschlüssel ist UNIQUE spezifiziert.

Benutzerreaktion:

Damit keine Schlüsselkollision auftritt, ist der Wert des einzufügenden Sekundärschlüssels in der SQL-Anweisung zu ändern.

Der Fehlertext enthält die Angabe, für welche Spalte oder welchen mehrspaltigen Index die angegebenen Werte bereits existieren.


300: Integrity violation (SAP-Bibliothek - Grundwissen)

300: Integrity violation

Erläuterung:

Beim Einfügen oder Ändern wurden Integritätsbedingungen (siehe Hilfsmittel für die Datenintegrität), die bei der Definition der Basistabelle bzw. der View-Tabelle spezifiziert wurden, verletzt.

Benutzerreaktion:

Der Fehlertext enthält die Angabe, für welche Spalte die Integritätsbedingungen verletzt wurden.

Der Eingabewert ist für die entsprechende Spalte zu korrigieren.


320: View violation (SAP-Bibliothek - Grundwissen)

320: View violation

Erläuterung:

Es wurde eine INSERT- oder UPDATE-Anweisung für eine View-Tabelle angegeben. Mindestens eine in der SQL-Anweisung angegebene Zeile erfüllt nicht die Suchbedingungen aller mit WITH CHECK OPTION definierten, zugrundeliegenden View-Tabellen.

Benutzerreaktion:

Sie können sich die Definition der View-Tabelle durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.VIEWDEFS, anzeigen lassen. Ändern Sie die INSERT- oder UPDATE-Anweisung dieser Definition entsprechend.


350: Referential integrity violated (SAP-Bibliothek - Grundwissen)

350: Referential integrity violated

Erläuterung:

Eine der folgenden Ursachen ist möglich:

...

1. Bei der Einfügen in eine oder Ändern einer Tabelle, die referenzierende Tabelle in einer referentiellen CONSTRAINT-Definition ist, entsteht eine Zeile, die nicht Trefferzeile der CONSTRAINT-Definition ist.

2. Beim Löschen von Zeilen einer referenzierten Tabelle (referenced_table) einer referentiellen CONSTRAINT-Definition mit ON DELETE RESTRICT in der DELETE-Regel existiert eine Trefferzeile.

3. Bei der Ausführung einer referentiellen CONSTRAINT-Definition enthält die referenzierte Tabelle (referenced_table) oder referenzierende Tabelle Zeilen, die der CONSTRAINT-Definition widersprechen.

Benutzerreaktion:

...

1. Sie können sich die bei der referentiellen CONSTRAINT-Definition verwendete Definition durch eine QUERY-Anweisung, angewandt auf die Systemtabelle DOMAIN.FOREIGNKEYCOLUMNS, anzeigen lassen. Ändern Sie die INSERT- oder UPDATE-Anweisung dieser Definition entsprechend.

2. Sie können mit Hilfe einer geeigneten QUERY-Anweisung ermitteln, welche Zeile der referenzierenden Tabelle verhindert, dass die gewünschten Zeilen der referenzierten Tabelle (referenced_table) gelöscht werden können.

3. Sie können mit Hilfe einer geeigneten QUERY-Anweisung ermitteln, welche Zeile der referenzierten Tabelle (referenced_table) oder referenzierenden Tabelle der referentiellen CONSTRAINT-Definition widerspricht. Ändern oder löschen Sie diese, oder korrigieren Sie die CONSTRAINT-Definition.


360: Foreign key integrity violation (SAP-Bibliothek - Grundwissen)

360: Foreign key integrity violation

Erläuterung:

Bei der INSERT- oder UPDATE-Anweisung für eine Join-View-Tabelle widersprechen die von den referenzierenden Spalten (referencing_column) der referenzierenden Tabelle funktional abhängigen Spaltenwerte den bereits existierenden Spaltenwerten dieser Spalten.

Benutzerreaktion:

Ändern Sie die Spaltenwerte der Anweisung oder die bereits existierenden Werte, und lösen Sie so diesen Widerspruch auf.


400: Lock collision (SAP-Bibliothek - Grundwissen)

400: Lock collision

Erläuterung:

Bei der Angabe der Option (NOWAIT) in der LOCK-Anweisung oder in der LOCK-Option signalisiert diese Rückmeldung, dass die Sperranforderung mit den Sperren eines anderen Benutzers kollidiert.

Benutzerreaktion:

1. Im Dialog kann in dieser Situation ein anderer Verarbeitungsvorgang angestoßen werden, der die gewünschte Sperre nicht voraussetzt.

2. Alternativ dazu kann mit derselben SQL-Anweisung ohne Angabe der Option (NOWAIT) auf die Sperrfreigabe gewartet werden.


500: Lock request timeout (SAP-Bibliothek - Grundwissen)

500: Lock request timeout

Erläuterung:

...

a. Die Sperranforderung oder eine implizit angeforderte Sperre kollidiert mit Sperren eines anderen Benutzers. Die maximale Wartezeit auf die Zuteilung der Sperre (spezieller Datenbankparameter REQUEST_TIMEOUT) ist abgelaufen.

b. Die Datenbankinstanz konnte in einem bestimmten Zeitintervall nicht gestoppt werden, weil noch Transaktionen mit SQL-Anweisungen zum Ändern von Daten offen sind.

Benutzerreaktion:

...

a. In einigen Fällen enthält der Fehlertext noch eine genauere Beschreibung des Fehlers. Die Sperranforderung kann noch einmal abgesetzt werden. Es empfiehlt sich jedoch, die Transaktion mit einer ROLLBACK-Anweisung zurückzusetzen, um eventuelle Deadlock-Situationen aufzulösen.

b. Sie verzichten auf das Stoppen der Datenbankinstanz.


600: Work rolled back (SAP-Bibliothek - Grundwissen)

600: Work rolled back

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine implizite ROLLBACK-Anweisung zurückgesetzt, weil

1. der Benutzer innerhalb eines bestimmten Zeitintervalls keine Operationen durchführte, jedoch Sperren hielt, auf deren Zuteilung andere Benutzer warteten, oder

2. sich die Datenbankinstanz in einer Deadlock-Situation befand. Eine Deadlock-Situation ist eine Situation, in der zwei oder mehr Benutzer jeweils Sperren halten und weitere Sperren anfordern, die von den jeweils anderen Benutzern gehalten werden. Im einfachsten Fall mit zwei Benutzern hält der eine Benutzer mindestens eine Sperre und fordert eine andere an. Diese wird aber von einem anderen Benutzer gehalten, der wiederum auf die Sperre wartet, die der erste Benutzer hält. Diese Situation kann nur aufgelöst werden, wenn einer der Benutzer die schon erhaltene Sperre wieder freigibt.

Benutzerreaktion:

In einigen Fällen enthält der Fehlertext noch eine genauere Beschreibung des Fehlers.

In beiden Fällen sind die Sperranforderungen zu überprüfen und ggf. zu ändern. Die letzte Transaktion ist zu wiederholen.


650: Work rolled back (SAP-Bibliothek - Grundwissen)

650: Work rolled back

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine implizite ROLLBACK-Anweisung zurückgesetzt, weil der Log-Bereich voll ist.

Benutzerreaktion:

Der Fehlertext enthält eine genauere Beschreibung des Fehlers.

Sichern Sie den Log-Bereich (Log-Sicherung).


700: Session inactivity timeout (work rolled back) (SAP-Bibliothek - Grundwissen)

700: Session inactivity timeout (work rolled back)

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine implizite ROLLBACK-Anweisung zurückgesetzt. Die Datenbanksitzung wurde implizit beendet, weil der Benutzer während eines bestimmten Zeitintervalls (spezieller Datenbankparameter SESSION_TIMEOUT oder bei der CONNECT-Anweisung angegebener Timeout-Wert) keine Operationen durchgeführt hatte.

Benutzerreaktion:

Wiederholen Sie die CONNECT-Anweisung, wobei evtl. ein größerer Timeout-Wert angegeben werden sollte.

Überprüfen und ändern Sie gegebenenfalls auch den Wert des Datenbankparameters SESSION_TIMEOUT.


710: Session terminated by shutdown (work rolled back) (SAP-Bibliothek - Grundwissen)

710: Session terminated by shutdown (work rolled back)

Erläuterung:

Die Transaktion des Benutzers wurde implizit abgebrochen und durch eine implizite ROLLBACK-Anweisung zurückgesetzt. Die Datenbanksitzung wurde implizit beendet, weil parallel durch den Database Manager ein Shutdown der Datenbankinstanz erzwungen wurde. Um den später durchzuführenden Restart zu beschleunigen, wird durch das Datenbanksystem versucht, offene Transaktionen innerhalb eines kurzen zur Verfügung stehenden Zeitraumes zurückzusetzen und nicht nur abzubrechen.

Benutzerreaktion:

Nachdem die Datenbankinstanz wieder betriebsbereit ist, wiederholen Sie die CONNECT-Anweisung sowie die Transaktion.


750: Too many SQL statements (work rolled back) (SAP-Bibliothek - Grundwissen)

750: Too many SQL statements (work rolled back)

Erläuterung:

Die Transaktion des Benutzers wurde abgebrochen und durch eine implizite ROLLBACK-Anweisung zurückgesetzt. Die Datenbanksitzung wurde beendet, weil der Benutzer innerhalb einer Sitzung zu viele SQL-Anweisungen abgesetzt oder zu viele Transaktionen betrieben hat.

Benutzerreaktion:

Nach einer erneuten CONNECT-Anweisung können Sie die Transaktion wiederholen.


1403: Row not found (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation 1403: Row not found

Erläuterung:

Es gibt keine (weitere) Tabellenzeile, die die Qualifikation erfüllt.

Benutzerreaktion:

Eine Benutzerreaktion ist nicht erforderlich.


Von 25000 bis 25999 (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Von 25000 bis 25999

Rückmeldungen des Loader

25599 | Value for usage <number> rows too high to fit into one database page. Ignoring value
25600 | CONFIGURATION stream is not supported for this Loader command
25601 | Output of NULL values for column <column_name> will be truncated
25602 | Possible overflow of integer values for column '<column_name>'
25603 | Output of literal '<literal>' will be truncated
25604 | Surplus long file info (column name/id '<column_name>') ignored
25605 | No header in binary data file and no record length in command (using computed value of <number> bytes for record length)
25606 | Different byte swap of source and target machine; long values may be corrupted after import
25607 | Value for usage <value>% too less to fit one row into one database page. Ignoring value.
25608 | Restart file <file_name> not found; starting import from the beginning
25913 | Table <schema_name>. <table_name> not imported
25921 | Range of SEQUENCE is exhausted
25940 | Error at record <record_count> in input file for table <table_name>
25965 | No data to import in datastream <file_name> ; either the stream is empty or a specified condition does not match any data
25966 | Error at record <record_count> in input file <file_name>
25967 | Error at position <file_position> in input file <file_name>
25968 | Number of NULL values inserted: <null_count> (NULL representation in data file is <null_representation>)


25599: Value for usage <number> rows too high to fit into one database page. Ignoring value

Erläuterung:

Sie haben ein IMPORT-Kommando ausgeführt und im Kommando angegeben, wie viele Datensätze dabei auf einer Datenbankseite gespeichert werden sollen. Der angegebene Wert ist allerdings zu hoch und wird deshalb vom Loader ignoriert. Der Loader speichert in diesem Fall die maximal mögliche Anzahl von Datensätzen auf einer einzelnen Datenbankseite.

Benutzerreaktion:

Diese Meldung ist eine Information und eine Benutzerreaktion nicht notwendig.


25600: CONFIGURATION stream is not supported for this Loader command

Erläuterung:

Sie haben ein Kommando zum Exportieren oder Importieren von Daten einer einzelnen Tabelle ausgeführt und im Kommando eine Konfigurationsdatei angegeben. Eine Konfigurationsdatei wird bei der Bearbeitung einzelner Tabellen mit dem Loader nicht unterstützt.

Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion notwendig.


25601: Output of NULL values for column <column_name> will be truncated

Erläuterung:

Warnung beim Loader-Kommando zum Exportieren von Daten. Die Länge der Zeichenkette für den NULL-Wert übersteigt die definierte Ausgabelänge einer Spalte. Die Zeichenkette wird nicht vollständig ausgegeben. Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion notwendig.


25602: Possible overflow of integer values for column '<column_name>'

Erläuterung:

Warnung beim Loader-Kommando zum Exportieren von Daten. Die für die Spalte definierte Ausgabelänge ist zu klein, um alle Werte vom Datentyp ganze Zahl auszugeben, die gemäß Definition der Spalte in der Datenbankinstanz möglich sind. Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion notwendig.


25603: Output of literal '<literal>' will be truncated (SAP-Bibliothek - Grundwissen)

25603: Output of literal '<literal>' will be truncated

Erläuterung:

Warnung beim Loader-Kommando zum Exportieren von Daten. Die Länge des Literals übersteigt die definierte Ausgabelänge für dieses Literal. Das Literal wird nicht vollständig ausgegeben. Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion notwendig.


25604: Surplus long file info (column name/id '<column_name>') ignored

Erläuterung:

Warnung beim Loader-Kommando zum Exportieren von Daten, wenn LONG-Spalten exportiert werden sollen. Im Kommando wurden LONG-Datenströme angegeben, die keiner Spalte in der Spaltenliste des Kommandos zugeordnet werden können. Die überzähligen LONG-Datenströme werden beim Export der Daten ignoriert. Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion notwendig.


25605: No header in binary data file and no record length in command (using computed value of <number> bytes for record length)

Erläuterung:

Warnung beim Loader-Kommando zum Importieren oder Aktualisieren von Daten aus binären Datenströmen. Wenn die zu importierenden Daten mit dem Loader exportiert wurden, enthält der binäre Datenstrom einen Header mit der Länge eines einzelnen Datensatzes im Datenstrom. Dieser Header wurde nicht gefunden. Auch im Kommando wurde die Länge eines einzelnen Datensatzes nicht definiert. Deshalb berechnet der Loader die Satzlänge aus den im Kommando definiert Spaltenlängen. Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion notwendig.


25606: Different byte swap of source and target machine; long values may be corrupted after import

Erläuterung:

Warnung beim Loader-Kommando zum Importieren von Daten. Die zu importierende Tabelle enthält LONG-Werte. Der Byte-Swap von Quell- und Zielrechner ist unterschiedlich. Deshalb können die LONG-Werte nach dem Import falsch oder korrumpiert sein. Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Überprüfen Sie die LONG-Werte in der Datenbankinstanz nach dem Import:

  • Wenn sie fehlerfrei importiert wurden, ist keine weitere Benutzerreaktion notwendig.
  • Wenn die LONG-Werte fehlerhaft sind, müssen sie erneut importiert werden.


25607: Value for usage <value>% too less to fit one row into one database page. Ignoring value.

Erläuterung:

Warnung beim Loader-Kommando zum Importieren von Daten. Die zu importierende Tabelle ist in der Datenbank so definiert, dass ein einzelner Datensatz größer ist als der für USAGE angegebene Wert. Der Wert für USAGE wird deshalb vom Loader ignoriert. Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion erforderlich.


25608: Restart file <file_name> not found; starting import from the beginning

Erläuterung:

Warnung beim Loader-Kommando zum Importieren von Daten. Im Kommando wurde das Syntaxelement RESTART angegeben. Der Loader findet die erforderlichen Restart-Informationen nicht. Er beginnt den Import noch einmal von vorn. Diese Warnung hat keinen Abbruch des Kommandos zur Folge.

Benutzerreaktion:

Es ist keine Benutzerreaktion erforderlich.


25913: Table <schema_name>. <table_name> not imported

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) oder Aktualisieren (UPDATE) von Daten einer Tabelle ausgeführt. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache des Fehlers beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


25921: Range of SEQUENCE is exhausted (SAP-Bibliothek - Grundwissen)

25921: Range of SEQUENCE is exhausted

Erläuterung:

Sie führen ein Kommando zum Exportieren (EXPORT) von Datenbankkataloginformationen aus. Beim Exportieren eines Sequenz-Objekts fällt während der Überprüfung des Wertebereiches der Sequenz auf, dass dieser ausgeschöpft ist.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


25940: Error at record <record_count> in input file for table <table_name>

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) oder Aktualisieren (UPDATE) von Daten einer Tabelle ausgeführt. Dabei trat ein Fehler im Datensatz <record_count> auf. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache des Fehlers beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


25965: No data to import in datastream <file_name>; either the stream is empty or a specified condition does not match any data

25965: No data to import in datastream <file_name>;
either the stream is empty or a specified condition does not match any data

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) oder Aktualisieren (UPDATE) von Daten einer Menge von Tabellenspalten ausgeführt. Es wurde jedoch keine Tabellenspalten importiert oder aktualisiert.

Benutzerreaktion:

Überprüfen Sie Datei <file_name> auf deren Größe und Inhalt. Falls die Datei leer ist konnten keine Tabellenspalten importiert oder aktualisiert werden. Falls die Datei nicht leer ist, überprüfen Sie die Bedingungen Ihres Kommandos zum Importieren (IMPORT) oder Aktualisieren der Daten und ändern Sie diese gegebenenfalls ab.


25966: Error at record <record_count> in input file <file_name>

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) von Daten einer Tabelle im PAGE-Format ausgeführt. Dabei trat ein Fehler im Datensatz <record_count> auf. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache für den Fehler beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


25967: Error at position <file_position> in input file <file_name>

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) von Daten einer Tabelle im PAGE-Format ausgeführt. Dabei trat ein Fehler an der Datenposition <file_postion> in der Datei <file_name> auf. In der Protokolldatei finden Sie weitere Meldungen, die die Ursache für den Fehler beschreiben.

Benutzerreaktion:

Beseitigen Sie die Fehlerursache und führen Sie das Kommando erneut aus.


25968: Number of NULL values inserted: <null_count> (NULL representation in data file is <null_representation>)

Erläuterung:

Sie haben ein Kommando zum Importieren (IMPORT) oder Aktualisieren (UPDATE) von Daten einer Menge von Tabellenspalten ausgeführt. Dabei wurden <null_count> NULL-Werte eingefügt.

Benutzerreaktion:

Falls Ihnen die Anzahl <null_count> der eingefügten NULL-Werte zu klein oder zu groß ist, überprüfen Sie die NULL-Wert-Darstellung <null_representation> in Ihrem Kommando und Ihrer Datendatei. Falls Datenfelder der Datendatei mit der NULL-Wert-Darstellung <null_representation> übereinstimmen, jedoch nicht als NULL-Werte importiert oder aktualisiert werden sollen, ändern Sie die NULL-Wert-Darstellung im Kommando. Führen Sie den Ausgangszustand wieder her und führen Sie das Kommando erneut aus.


MaxDB-Sicherheitsleitfaden (SAP-Bibliothek - Grundwissen)

Komponentendokumentation MaxDB-Sicherheitsleitfaden

Einsatzmöglichkeiten

Um Sie bei der Absicherung Ihres MaxDB-Datenbanksystems zu unterstützen, bieten wir diesen Sicherheitsleitfaden an.

Funktionsumfang

· Einführung

· Bevor Sie anfangen

· Technische Systemlandschaft

· Benutzerverwaltung und -authentifizierung

· Berechtigungen

· Netzwerk- und Kommunikationssicherheit

· Sicherheit der Datenablage

· Überflüssige Funktionen mit Auswirkungen auf die Sicherheit

· Weitere sicherheitsrelevante Informationen

· Trace- und Protokolldateien

· Anhang


Einführung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Einführung

Dieser Leitfaden ersetzt nicht das Handbuch für den Tagesbetrieb, das die Kunden auf unsere Empfehlung hin für ihren spezifischen Produktionsbetrieb anlegen sollen.

Dieser Leitfaden entspricht dem aktuellen Stand der Entwicklung. Die Inhalte können ohne vorherige Ankündigung geändert werden und sind keinesfalls bindend für die SAP.

Zielgruppe

· Technologieberater

· Systemadministratoren

Dieses Dokument ist nicht Teil von Installationsleitfäden, Konfigurationsleitfäden, Technischen Handbüchern oder Upgrade-Leitfäden. Diese Leitfäden sind nur für eine bestimmte Phase des Software-Lebenszyklus relevant, während die Sicherheitsleitfäden Informationen liefern, die alle Phasen des Lebenszyklus betreffen.

Warum ist Sicherheit notwendig?

Der zunehmende Einsatz verteilter Systeme und des Internets zur Verwaltung von Geschäftsdaten führt auch zu steigenden Anforderungen an die Sicherheit. Bei einem verteilten System müssen Sie sicher sein, dass Ihre Daten und Prozesse die Bedürfnisse Ihres Unternehmens unterstützen, ohne unberechtigten Zugriff auf kritische Informationen zu ermöglichen. Fehler der Anwender, Nachlässigkeit oder Manipulationsversuche an Ihrem System dürfen nicht Informations- oder Verarbeitungsverluste nach sich ziehen. Diese Sicherheitsanforderungen gelten entsprechend auch für MaxDB. Um Sie bei der Absicherung von MaxDB zu unterstützen, bieten wir diesen Sicherheitsleitfaden an.

Über dieses Dokument

Der Sicherheitsleitfaden bietet einen Überblick über die sicherheitsrelevanten Informationen, die MaxDB betreffen.

Überblick über die Hauptabschnitte

Der Sicherheitsleitfaden besteht aus folgenden Hauptabschnitten:

· Bevor Sie anfangen

Dieser Abschnitt enthält Informationen darüber, warum Sicherheit erforderlich ist, wie das Dokument verwendet wird und Verweise auf andere Sicherheitsleitfäden, die die Grundlage für diesen Sicherheitsleitfaden bilden.

· Technische Systemlandschaft

Dieser Abschnitt bietet einen Überblick über die technischen Komponenten und Kommunikationspfade, die MaxDB verwendet.

· Benutzerverwaltung und -authentifizierung

Dieser Abschnitt bietet einen Überblick über folgende Aspekte der Benutzerverwaltung und ‑authentifizierung:

¡ Für die Benutzerverwaltung empfohlene Werkzeuge

¡ Für MaxDB erforderliche Benutzertypen

¡ Mit MaxDB ausgelieferte Standardbenutzer

· Berechtigungen

Dieser Abschnitt bietet einen Überblick über das Berechtigungskonzept, das für MaxDB gilt.

· Netzwerk- und Kommunikationssicherheit

Dieser Abschnitt bietet einen Überblick über die Kommunikationspfade, die MaxDB verwendet, sowie über die anzuwendenden Sicherheitsmechanismen.

· Sicherheit der Datenablage

Dieser Abschnitt bietet einen Überblick über kritische Daten, die MaxDB verwendet, sowie über die anzuwendenden Sicherheitsmechanismen.

· Überflüssige Funktionen mit Auswirkungen auf die Sicherheit

Dieser Abschnitt bietet einen Überblick über Funktionen, die Auswirkungen auf die Sicherheit haben und deaktiviert oder aus dem System entfernt werden können.

· Weitere sicherheitsrelevante Informationen

Dieser Abschnitt enthält Informationen zu

¡ Benutzereingaben in SQL-Anweisungen

· Trace- und Protokolldateien

Dieser Abschnitt bietet einen Überblick über die Trace- und Protokolldateien, die sicherheitsrelevante Informationen enthalten, so dass Sie z. B. Aktivitäten reproduzieren können, falls ein Sicherheitsverstoß auftritt.

· Anhang

Übersicht der verwendeten Variablen und Beispiele


Bevor Sie anfangen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Bevor Sie anfangen

Zu Grunde liegende Sicherheitsleitfäden

Weitere Informationen zu Sicherheitsmaßnahmen für MaxDB in SAP-Systemen finden Sie im SAP NetWeaver Security Guide.

Eine vollständige Liste aller verfügbaren SAP-Sicherheitsleitfäden finden Sie auf dem SAP Service Marketplace unter der Adresse service.sap.com/securityguide

Wichtige SAP-Hinweise

Aktuelle SAP-Hinweise, die sicherheitsrelevante Informationen zu MaxDB enthalten, finden Sie auf dem SAP Service Marketplace unter service.sap.com/security ® Security ® SAP Security Notes unter der Komponente BC-DB-SDB SAP DB.

Zusatzinformationen

Weitere Informationen zu Spezialthemen erhalten Sie in nachfolgender Tabelle unter den Quick Links.

Quick Links zu weiterführenden Informationen

Inhalt | Quick Link zum SAP Service Marketplace
Sicherheit | service.sap.com/security
Sicherheitsleitfäden | service.sap.com/securityguide
Verwandte SAP-Hinweise | service.sap.com/notes
Zulässige Plattformen | service.sap.com/platforms
Netzwerksicherheit | service.sap.com/securityguide
SAP Solution Manager | service.sap.com/solutionmanager


Technische Systemlandschaft (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Technische Systemlandschaft

Nachfolgende Grafik zeigt einen Überblick der technischen Systemlandschaft von MaxDB.

Schematischer Überblick über die technische Systemlandschaft

Diese Grafik wird im zugehörigen Text erklärt

Weitere Informationen zur technischen Systemlandschaft

Thema | Dokument | Quick Link zum SAP Service Marketplace
Technische Systemlandschaft von MaxDB | Konzepte des Datenbanksystems, Technische Systemlandschaft |
Technische Beschreibung von SAP NetWeaver | Master Guide | service.sap.com/instguides
Sicherheit |  | service.sap.com/security


Benutzerverwaltung und -authentifizierung (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Benutzerverwaltung und -authentifizierung

Um mit dem Datenbanksystem zu arbeiten, müssen Sie sich mit einem Datenbankwerkzeug oder über eine Schnittstelle an die Datenbankinstanz anmelden. Bei der Anmeldung identifizieren Sie sich mit Ihrem Benutzernamen. Das Datenbanksystem authentifiziert Ihre Identität anhand des Kennworts, das Sie angegeben haben.

Gefahren

· Unberechtiger Zugriff auf die Datenbankinstanz mit fremden Benutzerdaten

Eine Person ohne Zugriffsberechtigung auf die Datenbankinstanz bringt den Benutzernamen und das Kennwort eines berechtigten Benutzers in Erfahrung. Besonders gefährdet sind Standardbenutzer mit Standardkennwörtern, die allgemein bekannt sind.

Die Person meldet sich mit der Identität des berechtigten Benutzers an die Datenbankinstanz an.

Aktivitäten

· Kennwörter von Standardbenutzern ändern

· Protokolldateien auf fehlgeschlagene Anmeldeversuche überprüfen

Siehe auch:

Konzepte des Datenbanksystems, Benutzer, Authentifizierung und Berechtigungen


Kennwörter von Standardbenutzern ändern (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kennwörter von Standardbenutzern ändern

Verwendung

Bei der Installation des Datenbanksystems MaxDB werden die folgenden Standardbenutzer angelegt.

MaxDB-Standardbenutzer

Name (Vorschlagswert) | Kennwort (Vorschlagswert) | Beschreibung
DBADMIN DBA (bis einschließlich Version 7.5) | SECRET DBA (bis einschließlich Version 7.5) | Datenbanksystemadministrator (SYSDBA-Benutzer)
DBM | SECRET DBM | Database Manager-Benutzer (DBM-Benutzer) mit allen DBM-Serverberechtigungen
DBSERVICE | SECRET | nur für Version 7.6.10 bis 7.6.25: Synchronisationsbenutzer für den Strukturlink Synchronization Manager Wenn Sie den Synchronization Manager nicht verwenden, dann können Sie diesen Benutzer und alle ihm zugeordneten Datenbankobjekte löschen.

Bei der Installation in SAP-Systemen werden in der Regel folgende Standardbenutzer angelegt.

SAP-Standardbenutzer für Datenbanken

Name | Kennwort | Beschreibung
SUPERDBA | benutzerdefiniert, wird bei der Installation festgelegt | Datenbanksystemadministrator (SYSDBA-Benutzer)
CONTROL | benutzerdefiniert, wird bei der Installation festgelegt | Database Manager-Benutzer (DBM-Benutzer) mit allen Serverberechtigungen
SAPR3 | benutzerdefiniert, wird bei der Installation festgelegt | in älteren SAP-Systemen: Datenbankadministrator (Datenbankbenutzer der Klasse DBA)
SAP<SAPSID> | benutzerdefiniert, wird bei der Installation festgelegt | in neueren SAP-Systemen, insbesondere in MCOD-Systemen (Multiple Components, One Database): Datenbankadministrator für das SAP-System mit der ID <SAPSID> (Datenbankbenutzer der Klasse DBA)
SAP<SAPSID>DB | benutzerdefiniert, wird bei der Installation festgelegt | in J2EE-Systemen: Datenbankadministrator für das SAP-System mit der ID <SAPSID> (Datenbankbenutzer der Klasse DBA)

Diese Benutzer haben umfassende Berechtigungen bei der Arbeit mit dem Datenbanksystem MaxDB.

Vorgehensweise

Um zu verhindern, dass unberechtigte Personen die Kennwörter von Standardbenutzern in Erfahrung bringen, empfehlen wir folgende Maßnahmen:

● Übernehmen Sie nicht die Vorschlagswerte für die Kennwörter.

● Verwenden Sie sichere Kennwörter.

● Ändern Sie die Kennwörter regelmäßig.

● Um einem anderen Benutzer zeitweilig die Arbeit mit dem Konto des Datenbanksystemadministrators (SYSDBA-Benutzer) zu erlauben, können Sie dem Datenbanksystemadministrator zeitweilig ein zweites Kennwort zuweisen. Auf diese Weise müssen Sie das Kennwort des Datenbanksystemadministrators nicht weitergeben.

Kennwörter von MaxDB-Standardbenutzern ändern

Verwenden Sie das Datenbankwerkzeug Database Manager oder in SAP-Systemen das CCMS. Siehe:

● Database Manager GUI
Strukturlink Ändern des Kennworts des Datenbanksystemadministrators
Strukturlink Ändern des Kennworts eines Database Manager-Benutzers
Strukturlink Ändern des Kennworts eines Datenbankbenutzers

● Database Manager CLI
Strukturlink user_put

● Datenbankverwaltung im CCMS: MaxDB, Strukturlink Benutzerdaten

● Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Benutzerdaten

Für Sicherheitsmaßnahmen für Standard-Betriebssystembenutzer siehe Kennwörter von SAP-Standard-Betriebssystembenutzern ändern.

MaxDB-Standardbenutzern ein temporäres zweites Kennwort zuweisen

Verwenden Sie das Datenbankwerkzeug Database Manager. Siehe:

● Database Manager GUI
Strukturlink Ändern der DBM-Benutzereigenschaften des Datenbanksystemadministrators
Strukturlink Ändern der DBM-Benutzereigenschaften

● Database Manager CLI
Strukturlink user_put


Protokolldateien auf fehlgeschlagene Anmeldeversuche überprüfen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Protokolldateien auf fehlgeschlagene Anmeldeversuche überprüfen

Verwendung

Das Datenbanksystem protokolliert Fehler und wichtige Meldungen in mehreren Protokolldateien. Informationen zu Namen, Pfad und Funktion der Protokolldateien finden Sie in der Dokumentation Konzepte des Datenbanksystems, Protokolldateien.

Durch eine Überwachung der Protokolldateien können Sie ungewöhnliche Vorgänge rechtzeitig erkennen.

Vorgehensweise

Überprüfen Sie regelmäßig die folgenden Protokolldateien auf fehlgeschlagene Anmeldeversuche:

· Protokolldatei des Database Manager

· Protokolldatei des Loader

Beispiel

In der Protokolldatei c:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\dbm.prt werden die Meldungen des Database Manager für die Datenbankinstanz DEMODB protokolliert. Wenn ein Anmeldeversuch fehlgeschlagen ist, dann schreibt der Database Manager folgende Meldung in diese Protokolldatei:

command user_logon
ERR_USRFAIL: user authorization failed


Berechtigungen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Berechtigungen

Nach der Authentifizierung können Benutzer im Rahmen ihrer Berechtigungen auf Daten der Datenbankinstanz zugreifen und Datenbankwerkzeuge verwenden.

Für das Datenbanksystem MaxDB gibt es folgende Typen von Benutzern:

· Datenbanksystemadministrator (SYSDBA-Benutzer)

Der Datenbanksystemadministrator hat umfassende Berechtigungen beim Zugriff auf die Datenbankinstanz und die Datenbankwerkzeuge.

· Datenbankbenutzer

Datenbankbenutzer greifen mit SQL-Anweisungen auf die Daten in der Datenbankinstanz zu. Die Berechtigungen eines Datenbankbenutzers werden durch seine Benutzerklasse bestimmt.

· DBM-Benutzer (Database Manager-Benutzer)

DBM-Benutzer verwalten Datenbankinstanzen mit dem Datenbankwerkzeug Database Manager. Die Berechtigungen eines DBM-Benutzers werden durch seine Serverberechtigungen bestimmt.

Gefahren

· Lesen von Daten durch einen unberechtigten Benutzer

Ein Benutzer liest vertrauliche Daten, die nur für einen beschränkten Benutzerkreis sichtbar sein sollten.

· Ändern von Daten durch einen unberechtigten Benutzer

Ein Benutzer ändert Daten, die nur von einem beschränkten Benutzerkreis geändert werden sollten.

Aktivitäten

· Klare Berechtigungen für Benutzer definieren

Siehe auch:

Konzepte des Datenbanksystems, Datenbankbenutzer und Serverberechtigungen für den DBM-Server


Klare Berechtigungen für Benutzer definieren (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Klare Berechtigungen für Benutzer definieren

Um sicherzustellen, dass Benutzer nur die Berechtigungen haben, die sie für ihre Arbeit benötigen, empfehlen wir folgende Maßnahmen:

● Erstellen Sie ein Berechtigungskonzept, in dem sie klare Berechtigungen für die einzelnen Benutzer festlegen:

○ Definieren Sie, welche Datenbankbenutzer Zugang zu welchen Daten haben sollen.

○ Definieren Sie, welche Database Manager-Benutzer welche Verwaltungsaufgaben ausführen sollen.

● Legen Sie für jede Person, die mit der Datenbankinstanz arbeitet, einen eigenen Datenbankbenutzer an. Verwenden Sie dabei möglichst die Benutzerklassen STANDARD und RESOURCE.

● Teilen Sie die Verwaltungsaufgaben auf. Definieren Sie hierzu zusätzlich zum Datenbanksystemadministrator Datenbankbenutzer der Benutzerklasse DBA und Database Manager-Benutzer.

● Weisen Sie Database Manager-Benutzern nur die Serverberechtigungen zu, die sie wirklich benötigen.

In manchen Situationen kann es sinnvoll sein, einen Database Manager-Benutzer anzulegen, der nur den Betriebszustand der Datenbankinstanz überprüfen, jedoch keine Verwaltungsaufgaben durchführen kann.

Datenbankbenutzer anlegen und Benutzerklasse definieren

Verwenden Sie auf Microsoft Windows das Datenbankwerkzeug Database Manager GUI:

● Database Manager GUI, Strukturlink Anlegen/Ändern/Löschen eines Datenbankbenutzers

Auf anderen Betriebssystemen verwenden Sie das Datenbankwerkzeug SQLCLI und die SQL-Anweisungen zur Autorisierung von Benutzern:

● SQLCLI, Strukturlink Ausführen einer SQL-Anweisung

● SQL-Referenzhandbuch, Autorisierung

Database Manager-Benutzer anlegen und Serverberechtigungen anpassen

Um Database Manager-Benutzer anzulegen, verwenden Sie das Datenbankwerkzeug Database Manager:

● Database Manager GUI, Strukturlink Anlegen/Ändern/Löschen eines Database Manager-Benutzers

● Database Manager CLI, Strukturlink user_create

Um Serverberechtigungen von Database Manager-Benutzern anzupassen, verwenden Sie das Datenbankwerkzeug Database Manager:

● Database Manager GUI: Strukturlink Ändern der Serverberechtigungen

● Database Manager CLI: Strukturlink user_put


Netzwerk- und Kommunikationssicherheit (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Netzwerk- und Kommunikationssicherheit

Das Datenbanksystem besteht aus mehreren Komponenten, die sich auf verschiedenen Rechnern und in verschiedenen Netzen befinden können. Zwischen diesen Komponenten werden Daten übertragen, ebenso zwischen Datenbanksystem und Datenbankanwendung (beispielsweise einem SAP-System).

Gefahren

· Abhören von Daten

Unberechtigte Personen hören Daten ab, die zwischen Rechnern übertragen werden.

· Unberechtigter Zugriff auf den Datenbankrechner über das Netzwerk

Unberechtigte Personen nutzen Sicherheitslücken in anderen Programmen aus, um sich über eine Netzwerkverbindung Zugang zum Datenbankrechner zu verschaffen.

Aktivitäten

· Kommunikationskanäle absichern

· MaxDB X-Server hinter einer Firewall verwenden

· Web Tools hinter einer Firewall verwenden

Siehe auch:

Technische Systemlandschaft


Kommunikationskanäle absichern (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kommunikationskanäle absichern

Verwendung

Es gibt unter anderem die folgenden Kommunikationskanäle, über die Daten übertragen werden.

Kommunikationskanäle

von | nach | Protokoll
MaxDB X-Server | MaxDB Client (Datenbankwerkzeug, Schnittstelle) | TCP/IP optional: SSL (nur in SAP-Systemen)
MaxDB X-Server | SAProuter | NI (SAP-eigenes Protokoll) optional: NISSL (nur in SAP-Systemen)

Vorgehensweise

Um sicherzustellen, dass keine Daten bei der Übertragung zwischen verschiedenen Rechnern abgehört werden, können Sie in SAP-Systemen die Datenübertragung verschlüsseln.

Weitere Informationen finden Sie im Installationsleitfaden für Ihr SAP-System, siehe SAP-Hinweis 767598.

Das Kennwort eines Benutzers wird bei der Anmeldung an eine Datenbankinstanz nicht im Klartext übertragen, sondern verschlüsselt. Siehe Konzepte des Datenbanksystems, Authentifizierung

Siehe auch:

Dokumentation zu SAProuter finden Sie unter SAP NetWeaver ® SAP NetWeaver Configuration ® SAP Web Application Server ® SAPRouter


MaxDB X-Server hinter einer Firewall verwenden (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation MaxDB X-Server hinter einer Firewall verwenden

Verwendung

Sie können den MaxDB X-Server hinter einer Firewall verwenden, beispielsweise in einem Firmen-LAN (Local Area Network).

Beispiel für ein Netzwerk mit einer Firewall

Diese Grafik wird im zugehörigen Text erklärt

Vorgehensweise

Um mit einem MaxDB Client, beispielsweise einem MaxDB Datenbankwerkzeug, auf einen MaxDB X-Server hinter einer Firewall zuzugreifen, schalten Sie in Ihrer Firewall die erforderlichen Ports frei. Hinweise zum Freischalten von Ports finden Sie in der Dokumentation zu Ihrer Firewall.

Ports und Protokolle des MaxDB X-Servers

Portnummer | Protokoll | Bemerkungen
7210 | TCP/IP |
7269 | NI | nur in SAP-Systemen
7270 | SSL NISSL | nur in SAP-Systemen

Siehe auch:

X-Server, Strukturlink Ports und Protokolle des X-Servers

Konzepte des Datenbanksystems, Netzwerkkommunikation

Dokumentation zu SAProuter unter SAP NetWeaver ® SAP NetWeaver Configuration ® SAP Web Application Server ® SAPRouter


Web Tools hinter einer Firewall verwenden (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Web Tools hinter einer Firewall verwenden

Die Weiterentwicklung des MaxDB Web DBM, des MaxDB Web Server und des MaxDB Web Server Manager wurde eingestellt. Diese Programme sind nur bis einschließlich Version 7.5 im MaxDB-Softwarepaket enthalten.

Die Vorschlagswerte der Softwareinstallation gehen von der Annahme aus, dass die MaxDB Web Tools in einer sicheren Umgebung hinter einer Firewall betrieben werden.

Wenn Sie erhöhte Anforderungen an die Sicherheit Ihrer Systeme stellen, dann ändern Sie gegebenenfalls die Vorschlagskonfiguration, sobald Sie die Software des Web Server und der Web Tools als Teil der Standard-Softwareinstallation installiert haben.


Sicherheit der Datenablage (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Sicherheit der Datenablage

Die Daten der Datenbankinstanz liegen im Dateisystem. Es gibt mehrere Betriebssystembenutzer, die umfassende Berechtigungen für den Zugriff auf Datenbankressourcen mit Betriebssystemmitteln haben.

Zugriff auf Datenbankressourcen durch Betriebssystembenutzer

Datenbankressource | zugriffsberechtigt (UNIX/Linux) | zugriffsberechtigt (Microsoft Windows)
Volumes | <sdb_user> (Eigentümer) Mitglieder der Gruppe <sdba_group>, falls es keine Supportgruppe gibt Mitglieder der Supportgruppe | Mitglieder der Gruppen Administrators, System, Creator/Owner
Sicherungen | <sdb_user> (Eigentümer) Mitglieder der Gruppe <sdba_group> | Mitglieder der Gruppen Administrators, System, Creator/Owner
Dateien und Verzeichnisse der Datenbanksoftware | <sdb_user> (Eigentümer) Mitglieder der Gruppe <sdba_group> | alle
Datenbankprozesse | <sdb_user> (Eigentümer) | Local System Account
X-Server | <sdb_user> (Eigentümer) | Local System Account

In SAP-Systemen kann es zusätzliche Betriebssystembenutzer geben, die Zugriff auf Datenbankressourcen haben und den Betriebssystembenutzer <sdb_user> ersetzen können.

Zugriff auf Datenbankressourcen durch SAP-Standard-Betriebssystembenutzer

Datenbankressource | zugriffsberechtigt (UNIX/Linux) | zugriffsberechtigt (Microsoft Windows)
alle | <sid>adm (SAP-Systemadministrator und Datenbankadministrator in SAP-Systemen) Mitglied der Gruppe <sdba_group> bei liveCache-Datenbankinstanzen zusätzlich Eigentümer | <SID>ADM
alle | <sqd>sid veraltet, nicht für liveCache-Datenbankinstanzen Eigentümer | <SQD>SID

<sid> = System-ID des SAP-Systems

Gefahren

· Zugriff auf ungeschützte Datenbankressourcen

Ein normaler Betriebssystembenutzer greift mit Betriebssystemkommandos auf Datenbankressourcen zu, die nicht durch entsprechende Einschränkungen auf Betriebssystemebene geschützt sind.

· Unberechtigter Zugriff auf geschützte Datenbankressourcen mit fremden Benutzerdaten

Ein normaler Betriebssystembenutzer bringt das Kennwort eines privilegierten Betriebssystembenutzers in Erfahrung und greift mit Betriebssystemkommandos auf geschützte Datenbankressourcen zu.

Aktivitäten

· Zugriffsrechte auf Datenbankressourcen einschränken (UNIX/Linux bis inkl. Datenbankversion 7.4.03)

· Zugriff auf Datenbankressourcen einschränken (Microsoft Windows)

· Kennwörter von SAP Standard-Betriebssystembenutzern ändern

Siehe auch:

Anhang

Konzepte des Datenbanksystems, Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)


Zugriffsrechte auf Datenbankressourcen einschränken (UNIX/Linux bis inkl. Datenbankversion 7.4.03)

Hintergrunddokumentation Zugriffsrechte auf Datenbankressourcen einschränken (UNIX/Linux bis inkl. Datenbankversion 7.4.03)

Ab Datenbankversion 7.5 gilt ein neues Berechtigungskonzept. Siehe Konzepte des Datenbanksystems, Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux). Die im Folgenden beschriebenen Maßnahmen sind nur für ältere Datenbankversionen relevant.

Bis einschließlich Datenbankversion 7.4.03 werden die Zugriffsrechte in SAP-Systemen auf UNIX/Linux bei der Installation automatisch folgendermaßen konfiguriert.

Zugriffsrechte in SAP-Systemen bis Datenbankversion 7.4.03: Verzeichnisse

Verzeichnis | Privileg | Eigentümer | Gruppe | Kommentar
/sapdb/<SID>/sapdata | 750 | sqd<sid> | sapsys |
/sapdb/<SID>/saplog | 750 | sqd<sid> | sapsys |
/sapdb/<SID>/sapsys | 750 | sqd<sid> | sapsys |
/sapdb/<SID>/dbsys | 750 | sqd<sid> | sapsys | entfällt ab Version 7.4
/sapdb/<SID>/db | 750 | sqd<sid> | sapsys | Wenn eine Datenbankversion 7.5 oder höher gemeinsam mit einer älteren Version auf einem Rechner installiert ist, dann ändern Sie das Zugriffsprivileg für das Verzeichnis /sapdb/<SID>/db der älteren Datenbankinstanz auf 755, damit die Datenbankprozesse der neueren Versionen auf dieses Verzeichnis uneingeschränkt Zugriff haben.

Zugriffsrechte in SAP-Systemen bis Datenbankversion 7.4.03: Dateien

Datei | Privileg | Eigentümer | Gruppe | Kommentar
/sapdb/<SID>/sapdata/* | 660 | sqd<sid> | sapsys |
/sapdb/<SID>/saplog/* | 660 | sqd<sid> | sapsys |
/sapdb/<SID>/sapsys/* | 660 | sqd<sid> | sapsys |
/sapdb/<SID>/dbsys/sys | 660 | sqd<sid> | sapsys | entfällt ab Version 7.4

Zugriffsrechte in SAP-Systemen bis Datenbankversion 7.4.03: Raw Devices

Raw-Device | Privileg | Eigentümer | Gruppe | Kommentar
Raw-Devices des Datenbanksystems | 660 | sqd<sid> |  | Link auf die als Data- oder Log-Volumes verwendeten Raw-Devices

Vorgehensweise

Um die Zugriffsrechte einzuschränken, gehen Sie folgendermaßen vor:

...

1. Sichern Sie die ursprünglichen Einstellungen. Geben Sie hierfür folgende Kommandos ein:

cd /usr/sap
ls -lR > sap_perm.txt

cd /sapmnt
ls -lR > sap_sw.txt

cd /sapdb/<SID>
ls -lR > sapdb_perm.txt

2. Vergeben Sie die gewünschten Zugriffsprivilegien für Dateien und Verzeichnisse mit dem Kommando chmod:

chmod <Zugriffsprivilegien_in_Oktalform> <Datei_oder_Verzeichnis>

chmod 750 /sapdb/<SID>/sap*

chmod 750 /sapdb/<SID>/sapdata/*

chmod 750 /sapdb/<SID>/saplog/*

...

Verwenden Sie chmod nicht rekursiv, weil dies leicht zu unbeabsichtigten Änderungen an Berechtigungen führen kann.


Zugriff auf Datenbankressourcen einschränken (Microsoft Windows)

Hintergrunddokumentation Zugriff auf Datenbankressourcen einschränken (Microsoft Windows)

Auf Microsoft Windows können nur Betriebssystembenutzer, die den Gruppen Administrators, System oder Creator/Owner angehören, mit Betriebssystemkommandos auf die Volumes und Sicherungen der Datenbankinstanz zugreifen. Alle anderen Datenbankressourcen sind für alle Betriebssystembenutzer zugänglich.

Vorgehensweise

Um weitere Datenbankressourcen zu schützen, können Sie den Zugriff auf das Verzeichnis <independent_data_path>\config einschränken.

...

1. Melden Sie sich als Betriebssystembenutzer der Gruppe Administrators oder der Gruppe Creator/Owner am Betriebssystem an.

2. Vergeben Sie folgende Zugriffsprivilegien für das Verzeichnis <independent_data_path>\config und alle darin enthaltenen Dateien:

¡ Zugriffsprivileg Full Control für die Gruppen Administrators, System und Creator/Owner

¡ kein Zugriff für alle anderen Gruppen und Benutzer

Hinweise zum Vergeben von Zugriffsprivilegien finden Sie in Ihrer Betriebssystemdokumentation.

Siehe auch:

Anhang

Konzepte des Datenbanksystems, Konfigurationsdateien


Kennwörter von SAP Standard-Betriebssystembenutzern ändern (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Kennwörter von SAP Standard-Betriebssystembenutzern ändern

Viele SAP-Systeme verwenden Standard-Betriebssystembenutzer, die auf Betriebssystemebene umfassende Zugriffsrechte auf die Datenbankressourcen haben.

Standard-Betriebssystembenutzer in SAP-Systemen

Betriebssystembenutzer | Verwendung
<sid>adm | SAP-Systemadministrator und Datenbankadministrator in SAP-Systemen
sqd<sid> | Eigentümer der Datenbankressourcen

<sid> = System-ID des SAP-Systems

Vorgehensweise

Um zu verhindern, dass unberechtigte Personen die Kennwörter von Standard-Betriebssystembenutzern in Erfahrung bringen, empfehlen wir folgende Maßnahmen:

· Übernehmen Sie nicht die Vorschlagswerte für die Kennwörter.

· Verwenden Sie sichere Kennwörter.

· Ändern Sie die Kennwörter regelmäßig

Kennwort eines Betriebssystembenutzers ändern (UNIX/Linux)

...

1. Melden Sie sich als Benutzer <sid>adm am Betriebssystem an.

2. Öffnen Sie eine Shell.

3. Geben Sie das Kommando passwd ein.

4. Geben Sie das alte und das neue Kennwort ein.

Wiederholen Sie die Vorgehensweise für den Benutzer sqd<sid>.

Wenn Sie den Network Information Service (NIS) verwenden, dann lesen Sie im NIS-Leitfaden nach, wie Sie Kennwörter von Betriebssystembenutzern ändern.

Kennwort eines Betriebssystembenutzers ändern (Microsoft Windows)

...

1. Melden Sie sich als ein Benutzer der Gruppe Administrators am Betriebssystem an.

2. Ändern Sie das Kennwort des Betriebssystembenutzers <SID>ADM.


Überflüssige Funktionen mit Auswirkungen auf die Sicherheit (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Überflüssige Funktionen mit Auswirkungen auf die Sicherheit

Unter Umständen benötigen Sie nicht alle Funktionen des MaxDB-Datenbanksystems.

Gefahren

Je mehr Funktionen Sie aktiviert haben, desto mehr potentielle Gefahrenquellen existieren.

Aktivitäten

· Installieren Sie nur diejenigen Softwarekomponenten, die Sie wirklich benötigen.

· MaxDB X-Server bei lokaler Kommunikation ausschalten

· MaxDB X-Server ohne NI-Unterstützung starten (UNIX/Linux)

· Demo-Daten entfernen

Siehe auch:

Installationshandbuch, Abschnitt Strukturlink Softwarekomponenten


MaxDB X-Server bei lokaler Kommunikation ausschalten (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation MaxDB X-Server bei lokaler Kommunikation ausschalten

Verwendung

Der MaxDB X-Server wird nur für die Netzwerkkommunikation benötigt. Siehe Konzepte des Datenbanksystems, Netzwerkkommunikation.

Bei lokaler Kommunikation, also wenn sich die Datenbankinstanz und die Datenbankanwendung (oder das Datenbankwerkzeug bzw. die Schnittstelle) auf demselben Rechner befinden, verwendet MaxDB Shared Memory. Ausnahmen sind der Event-Dispatcher und die JDBC-Schnittstelle, die auch bei lokaler Kommunikation den X-Server benötigen.

Voraussetzungen

Sie verwenden weder den Event-Dispatcher noch die JDBC-Schnittstelle.

Vorgehensweise

Stoppen Sie den X-Server mit folgendem Kommando:

x_server stop

Siehe auch:

X-Server, Strukturlink Stoppen des X-Server


MaxDB X-Server ohne NI-Unterstützung starten (UNIX/Linux) (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation MaxDB X-Server ohne NI-Unterstützung starten (UNIX/Linux)

Verwendung

Auf UNIX/Linux wird beim Starten des MaxDB X-Servers automatisch auch der MaxDB NI-Server für die Unterstützung des SAP-eigenen NI-Netzwerkprotokolls als separater Prozess gestartet.

Wenn Sie MaxDB außerhalb von SAP-Systemen verwenden, dann benötigen Sie keine NI-Unterstützung.

Vorgehensweise

Verwenden Sie die Option –Y beim Starten des X-Servers:

x_server –Y start

Siehe auch:

X-Server, Strukturlink Starten des X-Servers


Demo-Daten entfernen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Demo-Daten entfernen

Verwendung

MaxDB wird mit einer Demo-Datenbank ausgeliefert. Diese Datenbank wurde für Übungs- und Testzwecke entwickelt und enthält mehrere vordefinierte Demo-Benutzer und Demo-Daten.

Vorgehensweise

Um zu verhindern, dass unberechtigte Personen sich mit den Daten eines Demo-Benutzers an ein Produktivsystem anmelden, empfehlen wir Folgendes:

· Verwenden Sie die Demo-Datenbank nur für Übungs- und Testzwecke.

· Wenn Sie Ihr Produktivsystem auf der Demo-Datenbank aufbauen, dann entfernen Sie alle Demo-Benutzer und deren Datenbankobjekte.

Siehe auch:

Konzepte des Datenbanksystems, Abschnitt Demo-Datenbank


Weitere sicherheitsrelevante Informationen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Weitere sicherheitsrelevante Informationen

Gefahren

· SQL Injection

Benutzer geben in SQL-Anweisungen ungültige Werte ein und verursachen dadurch Fehler in der Datenbank, führen einen Systemausfall herbei oder versuchen in andere Systeme einzudringen.

Aktivitäten

· Benutzereingaben in SQL-Anweisungen überprüfen


Benutzereingaben in SQL-Anweisungen überprüfen (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Benutzereingaben in SQL-Anweisungen überprüfen

Um zu verhindern, dass Benutzer ungültige Werte in SQL-Anweisungen eingeben und dadurch den Datenbestand unkontrolliert verändern oder das Verhalten der Datenbankanwendung ändern (SQL Injection), empfehlen wir die Verwendung von Prepared Statements.

Die folgende Tabelle zeigt, für welche MaxDB-Schnittstellen Sie welche Prepared Statements verwenden können.

MaxDB-Schnittstellen: PreparedStatements

Schnittstelle | Prepared Statements
JDBC | Klasse PreparedStatement
ODBC | Methode SQLPrepare
SQLDBC | Klasse SQLDBC_PrepareStatement
PHP | maxdb_prepare
Perl | prepare
Python | Methode prepare, Klasse SAPDB_Prepared

Weitere Informationen zu den MaxDB-Schnittstellen finden Sie in Konzepte des Datenbanksystems, Schnittstellen.

Beispiel

Die Tabelle APPLICATION_USER enthält die Benutzer und Kennwörter einer Datenbankanwendung, die über die MaxDB-JDBC-Schnittstelle auf die Datenbankinstanz DEMODB zugreift.

Unsichere Anweisung

Die folgende Implementierung der Benutzeranmeldung ist unsicher, weil sie von einer Person dazu missbraucht werden kann, durch die Eingabe eines ungültigen Werts Zugriff auf die Datenbankinstanz zu erhalten, ohne ein gültiges Kennwort anzugeben.

Statement s = connection.createStatement();

ResultSet rs = s.executeQuery("SELECT * FROM APPLICATION_USERS WHERE username = '" + username + "' and password = '" + password + "'");

if(rs.next()) {

// ... continue with successful logon

} else {

// ... unsuccessful logon

}

Wenn eine Person einen gültigen Benutzernamen für die Datenbankanwendung kennt, dann kann sie sich anmelden, ohne ein gültiges Kennwort anzugegeben. Es genügt, für password beispielsweise den Wert abcdefg′ or 1=1 anzugeben.

Das Kennwort wird dann folgendermaßen zusammengesetzt:

password='abcdefg' or 1=1'

Weil 1=1 immer wahr ist, wird auch der gesamte Ausdruck für das Kennwort vom Datenbanksystem immer als wahr ausgewertet, unabhängig davon, ob abcdefg ein gültiges Kennwort ist oder nicht.

Verbesserte Anweisung

Die folgende Implementierung der Benutzeranmeldung verwendet Prepared Statements und schützt vor der oben beschriebenen SQL-Injection, weil als Kennwort keine Sonderzeichen wie beispielsweise ' mehr eingegeben werden können.

PreparedStatement ps = connection.prepare("SELECT * FROM APPLICATION_USERS WHERE username=? and password=?");

ps.setString(1, username);

ps.setString(2, password);

ResultSet rs = ps.executeQuery();

if(rs.next()) {

// ... continue with successful logon

} else {

// ... unsuccessful logon

}


Trace- und Protokolldateien (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Trace- und Protokolldateien

Im laufenden Betrieb schreiben das Datenbanksystem und die Datenbankwerkzeuge Protokolldateien. Um Fehler zu finden, können Sie außerdem unterschiedliche Traces einschalten, die zusätzliche Aktionen protokollieren. Traces können unter anderem Auszüge aus eingefügten Daten enthalten.

Trace- und Protokolldateien können Sie entweder mit einem Texteditor oder mit Hilfe des Datenbankwerkzeugs Database Manager lesen.

Gefahren

· Unberechtigtes Lesen von Daten

Ein unprivilegierter Betriebssystembenutzer liest eine Trace- oder Protokolldatei und erhält dadurch Informationen über den Datenbankbetrieb und unter Umständen Daten der Datenbankinstanz.

Aktivitäten

· Schalten Sie Traces nur zur Fehlersuche ein. Löschen Sie die Trace-Dateien danach wieder.

· Zugriff auf Protokolldateien einschränken

Siehe auch:

Protokolldateien auf fehlgeschlagene Anmeldeversuche überprüfen

Konzepte des Datenbanksystems, Protokolldateien und Traces


Zugriff auf Protokolldateien einschränken (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Zugriff auf Protokolldateien einschränken

Verwendung

Benutzer können sowohl mit Betriebssystemmitteln als auch mit dem Datenbankwerkzeug Database Manager auf Protokolldateien zugreifen.

Vorgehensweise

Zugriff mit Betriebssystemmitteln einschränken

Auf UNIX/Linux können keine unprivilegierten Betriebssystembenutzer auf die Protokolldateien zugreifen, sondern nur Mitglieder der speziellen Betriebssystembenutzergruppe <sdba_group>.

Auf Microsoft Windows können grundsätzlich alle Betriebssystembenutzer auf die Protokolldateien zugreifen. Um den Zugriff einzuschränken, verfahren Sie wie im Abschnitt Zugriff auf Datenbankressourcen einschränken (Microsoft Windows) beschrieben.

Zugriff mit dem Database Manager einschränken

Entziehen Sie allen Database Manager-Benutzern, die nicht auf die Protokolldateien zugreifen sollen, die Serverberechtigung zum Lesen der Datenbankdateien.

● Database Manager GUI: Entziehen Sie die Serverberechtigung Database File Access. Verfahren Sie wie in Strukturlink Ändern der Serverberechtigungen beschrieben.

● Database Manager CLI: Entziehen Sie die Serverberechtigung DBFileRead. Verfahren Sie wie in Strukturlink user_put beschrieben.

Siehe auch:

Klare Berechtigungen für Benutzer definieren

Konzepte des Datenbanksystems,

● Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)

● Serverberechtigungen für den DBM-Server


Anhang (SAP-Bibliothek - Grundwissen)

Hintergrunddokumentation Anhang

In der Dokumentation wird die Syntax von Befehlen mit Hilfe von Variablen beschrieben, die durch spitze Klammern gekennzeichnet sind. Die folgende Tabelle zeigt die am häufigsten verwendeten Variablen und Beispiele.

Variable | Beispiele | Beschreibung
<dependent_path> | Nur Software-Installation: Microsoft Windows*: C:\Program Files\sdb\<version> UNIX/Linux: /opt/sdb/<version> Installation von Software und Datenbankinstanz: Microsoft Windows*: C:\Program Files\sdb\<database_name> UNIX/Linux: /opt/sdb/<database_name> | Verzeichnis, in dem sich die von der Datenbankversion abhängige Server-Software befindet
<independent_data_path> | Microsoft Windows*: c:\Documents and Settings\All Users\Application Data\sdb\data UNIX/Linux: /var/opt/sdb/data | Verzeichnis, in dem sich die Daten, Konfigurationsinformationen und Arbeitsverzeichnisse von Datenbankinstanzen und Anwendungen befinden Um den Pfad dieses Verzeichnisses anzuzeigen, können Sie das DBM-Kommando dbm_getpath verwenden: dbmcli dbm_getpath IndepDataPath
<independent_program_path> | Microsoft Windows*: C:\Program Files\sdb\programs UNIX/Linux: /opt/sdb/programs | Verzeichnis, in dem sich die von den Datenbankinstanzen und Anwendungen gemeinsam genutzten Programme und Bibliotheken befinden Um den Pfad dieses Verzeichnisses anzuzeigen, können Sie das DBM-Kommando dbm_getpath verwenden: dbmcli dbm_getpath IndepProgPath
<sdb_user> | sdb | UNIX/Linux: spezieller Betriebssystembenutzer für MaxDB, Eigentümer der Datenbanksoftware
<sdba_group> | sdba | UNIX/Linux: spezielle Betriebssystembenutzergruppe für MaxDB
<sysdba_user> | DBADMIN | Name des SYSDBA-Benutzers (Datenbanksystemadministrator)
<sysdba_user_password> | SECRET | Kennwort des SYSDBA-Benutzers

* Systemvorschlag, wenn noch keine MaxDB-Software installiert wurde. Wenn bereits eine ältere MaxDB-Version vorhanden ist, dann schlägt das Installationsprogramm die Pfade dieser Version für die neue Installation vor.

Siehe auch:

Konzepte des Datenbanksystems, Benutzer, Authentifizierung und Berechtigungen

Installationshandbuch, Strukturlink Verzeichnisse

Database Manager CLI, Strukturlink dbm_getpath


Tutorials (SAP-Bibliothek - Tutorials)

Komponentendokumentation Tutorials

Titel der Dokumentation | Beschreibung
Tutorial Datenbankverwaltung | Beschreibt ausgewählte Aufgaben zur Verwaltung von Datenbankinstanzen mit Hilfe des Werkzeugs Database Manager CLI.
SQL-Tutorial | Zeigt Beispiele für die vom Datenbanksystem MaxDB verwendete Structured Query Language (SQL).
Loader-Tutorial | Zeigt Beispiele für die Kommandos des Werkzeugs Loader zum Exportieren und Importieren von Daten.


Tutorial Datenbankverwaltung (SAP-Bibliothek - Tutorials)

Komponentendokumentation Tutorial Datenbankverwaltung

Einsatzmöglichkeiten

Dieses Tutorial beschreibt ausgewählte Aufgaben zur Verwaltung von Datenbankinstanzen mit Hilfe des Werkzeugs Strukturlink Database Manager CLI im Betriebssystem Microsoft Windows.

Alle Beispiele basieren auf der Demo-Datenbank, die für Übungs- und Testzwecke entwickelt und konfiguriert wurde. Verwenden Sie die Demo-Datenbank nicht in einem Produktivsystem.

Einführungshinweise

In der Dokumentation Database Manager CLI sind die DBM-Optionen und DBM-Kommandos mit allen erforderlichen Voraussetzungen einzeln erläutert. Im Gegensatz dazu liegt der Focus in diesem Tutorial darauf, welche Abfolge von DBM-Kommandos auszuführen ist, um beispielsweise eine Datenbankinstanz anzulegen, einen Datenbankparameter zu ändern oder eine Sicherung durchzuführen.

Das Tutorial ist eine Sammlung von einzelnen Beispielen für typische Verwaltungsaufgaben.

Der Inhalt der Beispiele gliedert sich in folgende Abschnitte:

Verwendung | Allgemeiner Überblick über die für die Aktion notwendigen Schritte
Szenario | Angenommene Ausgangssituation für das Beispiel
Vorgehensweise | Genaue Ein- und Ausgabetexte, wo notwendig, sind diese kommentiert
Ergebnis | Kurze Zusammenfassung des Zustands der Datenbankinstanz nach der ausgeführten Aktion mit Hinweisen, welche weiteren Aktionen nun ausgeführt werden können

Detaillierte Informationen darüber, welche Voraussetzungen für die Ausführung einzelner DBM-Kommandos erfüllt sein müssen, finden Sie in der jeweiligen Kommandobeschreibung in der Dokumentation Database Manager CLI. Die darin enthaltene Strukturlink Übersicht aller DBM-Kommandos erleichtert Ihnen das Auffinden des DBM-Kommandos.

Weiterführende Informationen zum Datenbanksystem finden Sie in den Dokumentationen Strukturlink Konzepte des Datenbanksystems und Strukturlink Glossar.

Funktionsumfang

Diese Dokumentation erhebt keinen Anspruch auf Vollständigkeit. Sie wird jedoch auf der Basis häufig auftauchender Fragen und Probleme, insbesondere auf der MaxDB-Mailingliste, Schritt für Schritt erweitert. Bei Fragen zu hier noch nicht beschriebenen Verwaltungsaufgaben haben Sie auch die Möglichkeit, im Archiv der Mailingliste unter der Adresse http://lists.mysql.com/maxdb nach Lösungsvorschlägen zu suchen.

Einschränkungen

Diese Dokumentation versteht sich nicht als alleinige Arbeitsgrundlage eines Datenbankadministrators. Sie setzt voraus, dass Sie sich mit dem Datenbanksystem, seinen Bestandteilen und insbesondere mit der Beschreibung des Werkzeugs Database Manager CLI eingehend vertraut gemacht haben.


Anlegen und Konfigurieren einer Datenbankinstanz (SAP-Bibliothek - Tutorials)

Vorgehensweisen Anlegen und Konfigurieren einer Datenbankinstanz

Verwendung

Sie haben verschiedene Möglichkeiten, eine neue Datenbankinstanz anzulegen.

Am einfachsten legen Sie eine neue Datenbankinstanz mit Hilfe des Installation Manager an.

Sie können jedoch auch das Programm Database Manager CLI verwenden. Hiermit können Sie eine neue Datenbankinstanz anlegen, indem Sie entweder den Systemvorschlag für die Datenbank-Parameterdatei verwenden oder die Parameterdatei einer anderen Datenbankinstanz einlesen.

Dieses Beispiel beschreibt, wie Sie eine neue Datenbankinstanz auf der Basis des Systemvorschlags für die Parameterdatei anlegen und anschließend einzelne Werte Ihren Erfordernissen anpassen. Die dafür notwendige Folge von DBM-Kommandos können Sie im Database Manager CLI entweder einzeln nacheinander oder mit Hilfe eines Skripts ausführen.

Im Folgenden sind die einzeln nacheinander auszuführenden DBM-Kommandos beschrieben. Wenn Sie ein Skript verwenden wollen, verfahren Sie wie in Skriptdatei verwenden beschrieben.

Sie können eine Datenbankinstanz auf dem lokalen Rechner anlegen oder mit Hilfe der Option –n auf einem entfernten Rechner. Um auf einem entfernten Rechner eine Datenbankinstanz anlegen zu können, benötigen Sie einen Betriebssystembenutzer für diesen Rechner. Dieser muss unter Microsoft Windows das Recht "logon as batch job" haben. Informationen, wie Sie einem Benutzer dieses Recht zuweisen, finden Sie in Ihrer Betriebssystem-Benutzerdokumentation.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink db_create, Strukturlink param_put, Strukturlink param_addvolume, Strukturlink db_activate, Strukturlink load_systab

Siehe auch:

Parameterdatei einer anderen Datenbankinstanz verwenden

Installationshandbuch, Strukturlink Verwenden des Installation Manager

Konzepte des Datenbanksystems, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Szenario

Sie wollen eine neue Datenbankinstanz mit dem Namen DEMODB auf dem lokalen Rechner anlegen.

Der Benutzer DBM mit dem Kennwort DBM soll als erster DBM-Benutzer für diese Datenbankinstanz definiert werden.

Der Benutzer DBADMIN mit dem Kennwort SECRET soll als Datenbanksystemadministrator für diese Datenbankinstanz definiert werden.

Sie wollen die Werte für die Datenbankparameter SESSION_TIMEOUT, _UNICODE, CACHE_SIZE, _SERVERDB_FOR_SAP, MAXDATAVOLUMES und MAXUSERTASKS ändern. (Achtung: Den Datenbankparameter _UNICODE können Sie nach dem Anlegen der Datenbankinstanz nicht mehr ändern, siehe: Strukturlink Unicode.)

Sie wollen ein Data-Volume mit dem Namen DISKD0001 vom Typ Datei mit einer Größe von 32768 Seiten und ein Log-Volume mit dem Namen DISKL0001 vom Typ Datei mit einer Größe von 6400 Seiten anlegen.

Es sollen weiterhin

● die Statistiken der Datenbankinstanz automatisch aktualisiert werden

● der Datenbereich bei einem Füllungsgrad von 90 % (Vorschlagswert) automatisch erweitert werden

● die Systemtabellen geladen

● die Demo-Daten geladen

● der Überschreibmodus für den Log-Bereich eingeschaltet werden

Vorgehensweise

...

1. Aufrufen des Database Manager CLI und Anlegen der neuen Datenbankinstanz mit dem Namen DEMODB, definieren des ersten DBM-Benutzers mit dem Benutzernamen DBM und dem Kennwort DBM:

>dbmcli db_create DEMODB DBM,DBM

OK

Alternativen zu dieser Kommandozeile:

○ Wenn auf Ihrem Rechner mehrere Versionen der Datenbanksoftware installiert sind, müssen Sie die Eingabe erweitern und mit Hilfe der Option -R <dependent_path> angeben, für welche Version die Datenbankinstanz angelegt werden soll:

>dbmcli -R "C:\Program Files\SDB\7.6.00" db_create DEMODB DBM,DBM

2. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u DBM,DBM -d DEMODB

dbmcli on DEMODB>

3. Eröffnen einer Parametersitzung:

>param_startsession

OK

dbmcli on DEMODB>

4. Initialisieren der Datenbankparameter und Definition des Datenbanktyps OLTP (Vorschlagswert).

>param_init

OK

dbmcli on DEMODB>

5. Ändern des Datenbankparameters SESSION_TIMEOUT auf den Wert 0.

dbmcli on DEMODB>param_put SESSION_TIMEOUT 0

OK

6. Ändern des Datenbankparameters _UNICODE auf den Wert YES

dbmcli on DEMODB>param_put _UNICODE YES

OK

7. Ändern des Datenbankparameters _SERVERDB_FOR_SAP auf den Wert NO:

dbmcli on DEMODB>param_put _SERVERDB_FOR_SAP NO

OK

8. Ändern des Datenbankparameters MAXDATAVOLUMES auf den Wert 64:

dbmcli on DEMODB>param_put MAXDATAVOLUMES 64

OK

9. Ändern des Datenbankparameters MAXUSERTASKS auf den Wert 10:

dbmcli on DEMODB>param_put MAXUSERTASKS 10

OK

10. Prüfen aller Datenbankparameter:

dbmcli on DEMODB>param_checkall

OK

11. Bestätigen der Änderungen der Datenbank-Parameterdatei:

dbmcli on DEMODB>param_commitsession

OK

12. Anlegen von Data- und Log-Volumes

a. Anlegen des Data-Volume Nr. 1 mit dem Namen DISKD0001 vom Typ FILE mit einer Größe von 32768 Seiten:

dbmcli on DEMODB>param_addvolume 1 DATA DISKD0001 F 32768

OK

b. Anlegen des Log-Volume Nr. 1 mit dem Namen DISKL0001 vom Typ FILE mit einer Größe von 6400 Seiten

dbmcli on DEMODB>param_addvolume 1 LOG DISKL0001 F 6400

OK

13. Überführen der Datenbankinstanz in den Betriebszustand ADMIN:

dbmcli on DEMODB>db_admin

OK

14. Initialisieren der neuen Datenbankinstanz und Anlegen des Datenbanksystemadministrators mit dem Benutzernamen DBADMIN und dem Kennwort SECRET:

dbmcli on DEMODB>db_activate DBADMIN,SECRET

OK

15. Laden der Systemtabellen:

dbmcli on DEMODB>load_systab

OK

0,OK: everything works fine

0,""c:\program files\sdb\maxdb1\bin\x_python" "c:\program files\sdb\maxdb1\env

\lsystab.py" -R "c:\program files\sdb\maxdb1" -d DEMODB -u dbadmin,*"

Removing obsolete objects

Installing Loader tables

...

...

==================================

Installation successfully finished

==================================

16. Einschalten der Funktion zum automatischen Aktualisieren der Optimiererstatistiken:

dbmcli on DEMODB>auto_update_statistics ON

OK

17. Einschalten der Funktion zum automatischen Erweitern des Datenbereichs:

dbmcli on DEMODB>auto_extend ON

OK

18. Laden der Demo-Daten:

dbmcli on DEMODB>load_tutorial

OK

0,OK: everything works fine

0,""c:\program files\sdb\maxdb1\bin\x_python" "c:\program files\sdb\maxdb1\env

\../demo/ltutorial.py" -R "c:\program files\sdb\maXdb1" -d DEMODB -u dbadmin,*"

HOTEL

==================================

Installation successfully finished

==================================

19. Überschreibmodus für den Log-Bereich einschalten:

dbmcli on DEMODB>db_execute SET LOG AUTO OVERWRITE ON

OK

Ergebnis

Die Datenbankinstanz DEMODB wurde angelegt. Sie befindet sich im Betriebszustand ONLINE. Gegenwärtig gibt es für diese Datenbankinstanz nur den ersten DBM-Benutzer mit dem Benutzernamen DBM und dem Kennwort DBM sowie den Datenbanksystemadministrator mit dem Benutzernamen DBADMIN und dem Kennwort SECRET.

Wir empfehlen Ihnen nun, zunächst einen weiteren DBM-Benutzer mit dem Namen OLEG und dem Kennwort MONDAY anzulegen, mit dessen Benutzerdaten alle weiteren Beispiele in diesem Tutorial Datenbankverwaltung erstellt wurden (Siehe: DBM-Benutzer anlegen).

Weiterführende Hinweise

In Abhängigkeit davon, was Sie mit Hilfe der Datenbankinstanz DEMODB testen wollen, verfahren Sie anschließend wie folgt:

● Wenn Sie Schritt für Schritt weitere Datenbankbenutzer und Schemas sowie Tabellen anlegen, diese mit Daten füllen und weitere SQL-Anweisungen ausführen wollen, folgen Sie den Erläuterungen in der Dokumentation SQL-Tutorial.

● Wenn Sie die Verwaltung von Datenbankinstanzen am Beispiel von DEMODB erlernen wollen, können Sie die Sie interessierenden Beispiele in diesem Tutorial Datenbankverwaltung nachvollziehen.

Für die detaillierte Beschreibung der DBM-Kommandos und DBM-Optionen siehe:

Database Manager CLI, Strukturlink Übersicht aller DBM-Kommandos und Strukturlink DBM-Optionen


Skriptdatei verwenden (SAP-Bibliothek - Tutorials)

Vorgehensweisen Skriptdatei verwenden

Verwendung

Sie erstellen eine Skriptdatei, die alle auszuführenden DBM-Kommandos enthält und speichern diese.

Anschließend rufen Sie den Database Manager unter Angabe dieser Skriptdatei auf.

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Database Manager CLI, Strukturlink -i, -ic, -is, -ics: Name des Eingabeskripts

Szenario

Sie wollen mit Hilfe einer Skriptdatei eine neue Datenbankinstanz anlegen.

Die neue Datenbankinstanz soll den Namen DEMODB haben und auf dem lokalen Rechner angelegt werden.

Der Benutzer DBM mit dem Kennwort DBM soll als erster DBM-Benutzer für diese Datenbankinstanz definiert werden.

Der Benutzer DBADMIN mit dem Kennwort SECRET soll als Datenbanksystemadministrator für diese Datenbankinstanz definiert werden.

Sie wollen die Werte für die Datenbankparameter SESSION_TIMEOUT, _UNICODE, CACHE_SIZE, _SERVERDB_FOR_SAP, MAXDATAVOLUMES und MAXUSERTASKS ändern. (Beachten Sie: Den Datenbankparameter _UNICODE können Sie nach dem Anlegen der Datenbankinstanz nicht mehr ändern, siehe: Strukturlink Unicode.)

Sie wollen ein Data-Volume mit dem Namen DISKD0001 vom Typ Datei mit einer Größe von 32768 Seiten an und ein Log-Volume mit dem Namen DISKL0001 vom Typ Datei mit einer Größe von 6400 Seiten anlegen.

Es sollen weiterhin

● die Statistiken der Datenbankinstanz automatisch aktualisiert werden

● der Datenbereich bei einem Füllungsgrad von 90 % (Vorschlagswert) automatisch erweitert werden

● die Systemtabellen geladen

● die Demo-Daten geladen

● der Überschreibmodus für den Log-Bereich eingeschaltet werden

Vorgehensweise

...

1. Legen Sie die Skriptdatei demoscript.txt an und speichern Sie sie unter folgendem Pfad:

C:\test\DBM

2. Kopieren Sie folgende Vorlage in die Skriptdatei und sichern Sie Ihre Eingaben:

db_create DEMODB DBM,DBM

param_startsession

param_init OLTP

param_put SESSION_TIMEOUT 0

param_put _UNICODE YES

param_put CACHE_SIZE 2500

param_put _SERVERDB_FOR_SAP NO

param_put MAXDATAVOLUMES 64

param_put MAXUSERTASKS 10

param_checkall

param_commitsession

param_addvolume 1 DATA DISKD0001 F 32768

param_addvolume 1 LOG DISKL0001 F 6400

db_admin

db_activate DBADMIN,SECRET

load_systab

auto_update_statistics ON

auto_extend ON

load_tutorial

db_execute SET LOG AUTO OVERWRITE ON

3. Rufen Sie den Database Manager CLI mit der Option zum Ausführen der Skriptdatei auf:

...

>dbmcli -i "C:\test\DBM\demoscript.txt"

>db_create DEMODB DBM,DBM

OK

---

>param_startsession

OK

---

>param_init OLTP

OK

---

>param_put SESSION_TIMEOUT 0

OK

---

>param_put _UNICODE YES

OK

---

>param_put CACHE_SIZE 2500

OK

---

>param_put _SERVERDB_FOR_SAP NO

OK

---

>param_put MAXDATAVOLUMES 64

OK

---

>param_put MAXUSERTASKS 10

OK

---

>param_checkall

OK

---

>param_commitsession

OK

---

>param_addvolume 1 DATA DISKD0001 F 32768

OK

---

>param_addvolume 1 LOG DISKL0001 F 6400

OK

---

>db_admin

OK

---

>db_activate DBADMIN,SECRET

OK

---

>auto_update_statistics ON

OK

---

>auto_extend ON

OK

---

>load_systab

OK

0,OK: everything works fine

0,""c:\program files\sdb\maxdb1\bin\x_python" "c:\program files\sdb\maxdb1\env\lsystab.py" -R "c:\program files\sdb\maxdb1" -d DEMODB -u DBADMIN,*"

Removing obsolete objects

Installing Loader tables

Installing messages and help

Installing SYSDBA tables

Installing comments for SYSDBA tables

Installing precompiler tables

Installing system tables for R3 backup information

Installing ODBC tables

Installing system tables for ORACLE (V7) mode

Installing data dictionary tables and views

Installing synonyms for oracle system tables

Installing comments on oracle sytem tables

Installing tables for WebAgent

Installing tables for Repository

Installing DOMAIN tables

Installing comments for DOMAIN tables

Installing Views as replacement for SHOWs

Installing Database Manager tables

Installing SYSINFO tables

Installing comments for SYSINFO tables

Installing support for UDE (User Defined Extensions)

Installing tables for JDBC Database Metadata

Installing tables for SQLDBC Database Metadata

Installing additional triggers

==================================

Installation successfully finished

==================================

---

>load_tutorial

OK

0,OK: everything works fine

0,""c:\program files\sdb\maxdb1\bin\x_python" "c:\program files\sdb\maxdb1\env\../demo/ltutorial.py" -R "c:\program files\sdb\maxdb1" -d DEMODB -u DBADMIN,*

"

HOTEL

==================================

Installation successfully finished

==================================

---

>db_execute SET LOG AUTO OVERWRITE ON

OK

---


Parameterdatei einer anderen Datenbankinstanz verwenden (SAP-Bibliothek - Tutorials)

Funktionsdokumentation Parameterdatei einer anderen Datenbankinstanz verwenden

Verwendung

Beim Anlegen einer Datenbankinstanz definieren Sie die Datenbankparameterdatei.

Sie können dazu den Systemvorschlag für die Parameterdatei verwenden und Ihren Erfordernissen anpassen.

Sie haben aber auch die Möglichkeit, die Parameterdatei einer anderen Datenbankinstanz zu verwenden. Dazu können Sie entweder die Kopie der Parameterdatei einer Datenbankinstanz auf dem gleichen Rechner verwenden oder die Parameterdatei aus einer vollständigen Datensicherung einer anderen Datenbankinstanz kopieren.

Die Kopie der Parameterdatei einer vorhandenen Datenbankinstanz zu verwenden empfiehlt sich beispielsweise dann, wenn Sie anschließend auch die Daten dieser Datenbankinstanz in die neue Datenbankinstanz einlesen wollen, wie z. B. bei der Datenbankkopie oder dem Einrichten einer Schatteninstanz. So können Sie sicherstellen, dass sich die Daten problemlos einlesen lassen und dass sich die Instanz mit der Datenbankkopie bzw. die Schatteninstanz genau so verhält wie die Quelldatenbank.

Auch wenn die neue Datenbankinstanz beispielsweise nur weniger Ressourcen verbrauchen soll, können Sie die neue Datenbankinstanz mit der Kopie der Parameterdatei der Quelldatenbank anlegen und anschließend nur die entsprechenden Parameter ändern.

Parameterdatei aus einer anderen Datenbankinstanz kopieren

Parameterdatei aus einer Datensicherung kopieren


Parameterdatei aus einer anderen Datenbankinstanz kopieren (SAP-Bibliothek - Tutorials)

Vorgehensweisen Parameterdatei aus einer anderen Datenbankinstanz kopieren

Verwendung

Sie können beim Anlegen einer Datenbankinstanz (Zieldatenbank) die Kopie der Parameterdatei einer vorhandenen Datenbankinstanz (Quelldatenbank) verwenden. Quelldatenbank und Zieldatenbank müssen sich auf dem gleichen Rechner befinden.

Sie müssen in jedem Fall den Parameterwert für das Arbeitsverzeichnis der neuen Datenbankinstanz ändern. Andernfalls würden die Quelldatenbank und die Zieldatenbank sich ihre Daten im Arbeitsverzeichnis gegenseitig überschreiben.

Außerdem müssen Sie die Pfade der Data- und Log-Volumes für die neue Datenbankinstanz definieren.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink param_copy

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Werte von Datenbankparametern ändern

Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien, Strukturlink Datenbankparameter

Glossar, Strukturlink Arbeitsverzeichnis, Strukturlink Volume

Szenario

Sie wollen eine Datenbankinstanz TESTDB auf dem lokalen Rechner anlegen. Diese soll fast die gleiche Konfiguration haben wie die Datenbankinstanz DEMODB auf dem gleichen Rechner. Sie wollen jedoch den Parameterwert CACHE_SIZE auf 1000 ändern.

Das Arbeitsverzeichnis von TESTDB soll unter dem Pfad C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\TESTDB angelegt werden.

Sie wollen ein Data-Volume (Typ: Datei, Name: DISKD0001, Größe: 32768 Seiten) und ein Log-Volume (Typ: Datei, Name DISKL0001, Größe: 6400 Seiten) definieren.

Der Datenbanksystemadministrator soll den Benutzernamen DBADMIN und das Kennwort SECRET haben.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI und Anlegen der neuen Datenbankinstanz mit dem Namen TESTDB, definieren des ersten DBM-Benutzers mit dem Benutzernamen DBM und dem Kennwort DBM:

>dbmcli db_create TESTDB DBM,DBM

OK

2. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz TESTDB:

>dbmcli -u DBM,DBM -d TESTDB

dbmcli on TESTDB>

3. Eröffnen einer Parametersitzung:

dbmcli on TESTDB>param_startsession

OK

4. Kopieren der Parameterdatei von DEMODB:

dbmcli on TESTDB>param_copy DEMODB

OK

5. Ändern des Datenbankparameters CACHE_SIZE auf den Wert 1000:

dbmcli on TESTDB>param_put CACHE_SIZE 1000

OK

6. Ändern des Datenbankparameters RUNDIRECTORY auf den Wert C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\TESTDB:

dbmcli on TESTDB>param_put RUNDIRECTORY "C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\TESTDB"

OK

7. Prüfen aller Datenbankparameter:

dbmcli on TESTDB>param_checkall

OK

8. Bestätigen der Änderungen der Datenbank-Parameterdatei:

dbmcli on TESTDB>param_commitsession

OK

9. Anlegen des Data-Volume Nr. 1 mit dem Namen DISKD0001 vom Typ FILE mit einer Größe von 32768 Seiten:

dbmcli on TESTDB>param_addvolume 1 DATA DISKD0001 F 32768

OK

10. Anlegen des Log-Volume Nr. 1 mit dem Namen DISKL0001 vom Typ FILE mit einer Größe von 6400 Seiten:

dbmcli on TESTDB>param_addvolume 1 LOG DISKL0001 F 6400

OK

11. Überführen der Datenbankinstanz in den Betriebszustand ADMIN:

dbmcli on TESTDB>db_admin

OK

12. Initialisieren der neuen Datenbankinstanz und Anlegen des Datenbanksystemadministrators mit dem Benutzernamen DBADMIN und dem Kennwort SECRET:

dbmcli on TESTDB>db_activate DBADMIN,SECRET

OK

Laden der Systemtabellen:

dbmcli on TESTDB>load_systab

OK

0,OK: everything works fine

0,""c:\program files\sdb\maxdb1\bin\x_python" "c:\program files\sdb\maxdb1\env\lsystab.py" -R "c:\program files\sdb\maxdb1" -d DEMODB -u DBADMIN,*"

Removing obsolete objects

Installing Loader tables

Installing messages and help

…

…

…

==================================

Installation successfully finished

==================================

Ergebnis

Die Datenbankinstanz TESTDB wurde auf der Basis der Parameterdatei von DEMODB angelegt und die im Szenario beschriebenen Parameter wurden geändert.

TESTDB befindet sich im Betriebszustand ONLINE.


Parameterdatei aus einer Datensicherung kopieren (SAP-Bibliothek - Tutorials)

Vorgehensweisen Parameterdatei aus einer Datensicherung kopieren

Verwendung

Sie können beim Anlegen einer neuen Datenbankinstanz (Zieldatenbank) die Kopie der Parameterdatei einer anderen Datenbankinstanz (Quelldatenbank) verwenden. Sie kopieren dazu die Parameterdatei aus einer vollständigen Datensicherung der Quelldatenbank in die neu anzulegende Datenbankinstanz. Wenn erforderlich, können Sie anschließend auch noch einzelne der auf diese Weise kopierten Parameterwerte ändern.

Sie benötigen dazu eine aktuelle vollständige Datensicherung der Quelldatenbank.

In der Zieldatenbank definieren Sie eine Sicherungsvorlage für eine vollständige Datensicherung. Dabei müssen die für die Eigenschaften Typ, Sicherungsart, Größenbeschränkung, Blockgröße undüberschreibbar definierten Werte mit den Werten derjenigen Sicherungsvorlage identisch sein, die für das Erstellen der Sicherung der Quelldatenbank verwendet wurde. Der Name der Sicherungsvorlage ist frei wählbar, die Eigenschaft Datenträger (device/file) muss auf den Ort verweisen, an dem die vollständige Datensicherung der Quelldatenbank gespeichert wurde.

Anschließend lesen Sie mit dem Kommando recover_config unter Angabe der neu definierten Sicherungsvorlage die Datensicherung aus der Quelldatenbank in die Zieldatenbank ein.

Nun ändern Sie gegebenenfalls einzelne Datenbankparameter.

Wenn sich die Quelldatenbank auf dem gleichen Rechner befindet wie die Zieldatenbank, müssen Sie in jedem Fall den Parameterwert RUNDIRECTORY für das Arbeitsverzeichnis und den Parameterwert DIAGHISTORY für das Verzeichnis der Diagnosehistorie ändern. Wenn die Pfade für die Data- und Log-Volumes in der Qelldatenbank als absolute Pfade definiert sind, müssen Sie sie ebenfalls in der Zieldatenbank ändern. Andernfalls würden sich die Quelldatenbank und die Zieldatenbank die Daten im Arbeitsverzeichnis, der Diagnosehistorie sowie im Daten- und Log-Bereich gegenseitig überschreiben.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink service_connect, Strukturlink recover_config, Strukturlink service_release

Siehe auch:

Sichern

Anlegen und Konfigurieren einer Datenbankinstanz

Werte von Datenbankparametern ändern

Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien, Strukturlink Datenbankparameter

Szenario

Sie haben eine vollständige Datensicherung von DEMODB auf dem Rechner GENUA angefertigt und unter dem Pfad \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\completeDataJan gespeichert.

Auf dem lokalen Rechner PARMA wollen Sie die neue Datenbankinstanz TESTDB mit einer nahezu identischen Konfiguration wie DEMODB anlegen. Sie wollen dazu die Kopie der Parameterdatei von DEMODB verwenden. Sie wollen für TESTDB den Parameter RUNDIRECTORY auf den Wert C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\TESTDB und den Parameter CACHE_SIZE auf den Wert 1000 ändern.

Die zu definierende Sicherungsvorlage für TESTDB soll folgende Eigenschaften aufweisen:

Name der Sicherungsvorlage: DataComplete

Datenträger (device/file): \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\completeDataJan

Typ: Datei (File)

Sicherungsart: vollständige Datensicherung (DATA)

Größenbeschränkung: keine (0)

Blockgröße: 6

überschreibbar: nein (NO)

Vorgehensweise

...

1. Aufrufen des Database Manager CLI und Anlegen der neuen Datenbankinstanz mit dem Namen TESTDB, definieren des ersten DBM-Benutzers mit dem Benutzernamen DBM und dem Kennwort DBM auf dem lokalen Rechner:

>dbmcli db_create TESTDB DBM,DBM

OK

2. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz TESTDB.

>dbmcli -u DBM,DBM -d DEMODB

dbmcli on TESTDB>

3. Sicherungsvorlage für eine vollständige Datensicherung in eine Datei mit den im Szenario genannten Eigenschaften definieren:

dbmcli on TESTDB>medium_put DataComplete "\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\completeDataJan" FILE DATA 0 6 NO

OK

4. Eröffnen einer Servicesitzung:

dbmcli on TESTDB>service_connect

OK

5. Einlesen der Parameterdatei von DEMODB aus der vollständigen Datensicherung DemoDataCompl und damit Übernehmen der Datenbankparameter von DEMODB nach TESTDB:

dbmcli on TESTDB>recover_config DataComplete

OK

Returncode 0

Date 20060328

Time 00162218

Server BERD00146827A.ber.sap.corp

Database DEMODB

…

…

6. Schließen der Service-Sitzung:

dbmcli on TESTDB>service_release

OK

7. Ändern des Parameters RUNDIRECTORY auf den im Szenario genannten Wert:

dbmcli on TESTDB>param_put RUNDIRECTORY "C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\TESTDB"

OK

8. Ändern des Parameters CACHE_SIZE auf den Wert 1000:

dbmcli on TESTDB>param_put CACHE_SIZE 1000

OK

9. Überführen der Datenbankinstanz in den Betriebszustand ADMIN:

dbmcli on TESTDB>db_admin

OK

10. Initialisieren der neuen Datenbankinstanz und Anlegen des Datenbanksystemadministrators mit dem Benutzernamen DBADMIN und dem Kennwort SECRET:

dbmcli on TESTDB>db_activate DBADMIN,SECRET

OK

11. Laden der Systemtabellen:

dbmcli on TESTDB>load_systab

OK

0,OK: everything works fine

0,""c:\program files\sdb\DEMODB\bin\x_python" "c:\program files\sdb\DEMODB\env\lsystab.py" -R "c:\program files\sdb\DEMODB" -d TESTDB -u dbadmin,*"

Removing obsolete objects

Installing Loader tables

...

...

Installing tables for JDBC Database Metadata

Installing tables for SQLDBC Database Metadata

Installing additional triggers

==================================

Installation successfully finished

==================================

Ergebnis

Die Datenbankinstanz TESTDB wurde auf der Basis der Parameterdatei von DEMODB angelegt und die Werte der Parameter RUNDIRECTORY und CACHE_SIZE wurden geändert.

TESTDB befindet sich im Betriebszustand ONLINE.

Gegenwärtig gibt es für diese Datenbankinstanz nur den ersten DBM-Benutzer mit dem Benutzernamen DBM und dem Kennwort DBM sowie den Datenbanksystemadministrator mit dem Benutzernamen DBADMIN und dem Kennwort SECRET.


Informationen über installierte Software und Datenbankinstanzen anzeigen

Vorgehensweisen Informationen über installierte Software und Datenbankinstanzen anzeigen

Verwendung

Sie können mit Hilfe von DBM-Kommandos Informationen über die installierten Versionen der Datenbanksoftware, Installationspfade sowie die registrierten Datenbankinstanzen auf einem bestimmten Rechner anzeigen.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink dbm_version, Strukturlink dbm_getpath, Strukturlink db_enum, Strukturlink info

Vorgehensweise

Versionsnummer des Database Manager anzeigen

>dbmcli dbm_version VERSION

OK

7.6.00

Installationsverzeichnis der versionsabhängigen Datenbanksoftware (Dependent Path) anzeigen

>dbmcli dbm_version INSTROOT

OK

c:\program files\sdb\DEMODB

Installationsverzeichnisse der versionsunabhängigen Datenbanksoftware anzeigen

● Independent Program Path anzeigen:

>dbmcli dbm_getpath IndepProgramPath

OK

c:\program files\sdb\programs

● Independent Data Path anzeigen:

>dbmcli dbm_getpath IndepDataPath

OK

c:\documents and settings\all users\application data\sdb\data

Registrierte Datenbankinstanzen und deren Softwareversion anzeigen

>dbmcli db_enum

OK

DEMODB C:\Program Files\sdb\DEMODB 7.6.00.16 slow offline

DEMODB C:\Program Files\sdb\DEMODB 7.6.00.16 fast running

TESTDB C:\Program Files\sdb\TESTDB 7.6.00.16 slow offline

TESTDB C:\Program Files\sdb\TESTDB 7.6.00.16 fast running

Softwareversion der aktuellen Datenbankinstanz anzeigen

>dbmcli –u DBM,DBM –d DEMODB info VERSIONS

OK

END

Name | Value

Kernel = Kernel 7.6.00 Build 016-123-109-428

Runtime Environment = W32/INTEL 7.6.00 Build 016-123-109-428


Starten und Stoppen einer Datenbankinstanz (SAP-Bibliothek - Tutorials)

Vorgehensweisen Starten und Stoppen einer Datenbankinstanz

Verwendung

Wenn die Datenbankinstanz sich im Betriebszustand ONLINE befindet, können Datenbankbenutzer mit den entsprechenden Berechtigungen Operationen in der Datenbankinstanz ausführen, d. h. Daten definieren, ändern und anzeigen sowie weitere Datenbankbenutzer anlegen, ändern, löschen usw.

Die Verwaltungsaufgaben für eine Datenbankinstanz werden von DBM-Benutzern mit Hilfe des Database Manager ausgeführt. Sie führen dazu DBM-Kommandos aus. Die Mehrzahl dieser DBM-Kommandos muss im Betriebszustand ONLINE der Datenbankinstanz ausgeführt werden. Bei denjenigen DBM-Kommandos, die den Betriebszustand OFFLINE oder ADMIN voraussetzen, ist dies in der Kommandobeschreibung unter dem Abschnitt "Voraussetzungen" explizit vermerkt.

Zu den Voraussetzungen für das Starten und Stoppen der Datenbankinstanz siehe Database Manager CLI, Strukturlink db_online, Strukturlink db_offline

Vorgehensweise

Starten der Datenbankinstanz (Überführen in den Betriebszustand ONLINE)

Aufrufen des Database Manager CLI, Anmelden als Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Überführen in den Betriebszustand ONLINE:

>dbmcli –u DBM,DBM –d DEMODB db_online

OK

Stoppen der Datenbankinstanz (Überführen in den Betriebszustand OFFLINE)

Aufrufen des Database Manager CLI, Anmelden als Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Überführen in den Betriebszustand OFFLINE:

>dbmcli –u DBM,DBM –d DEMODB db_offline

OK

Anzeigen des aktuellen Betriebszustands der Datenbankinstanz

Aufrufen des Database Manager CLI, Anmelden als Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen des Betriebszustands der Datenbankinstanz:

>dbmcli –u DBM,DBM –d DEMODB db_state

OK

OFFLINE


Löschen einer Datenbankinstanz (SAP-Bibliothek - Tutorials)

Vorgehensweisen Löschen einer Datenbankinstanz

Verwendung

Am einfachsten löschen Sie eine Datenbankinstanz mit Hilfe des Installation Manager.

Sie können aber auch den Database Manager CLI verwenden.

Um eine Datenbankinstanz löschen zu können, überführen Sie sie zunächst in den Betriebszustand OFFLINE. Wenn Sie die Datenbankdateien behalten wollen, können Sie dies im Kommando zum Löschen der Datenbankinstanz mit Hilfe einer Option angeben.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink db_offline, Strukturlink db_drop

Siehe auch:

Installationshandbuch, Strukturlink Verwenden des Installation Manager

Szenario

Sie wollen die Datenbankinstanz DEMODB einschließlich aller Datenbankdateien (Vorschlagswert des Systems) löschen.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u DBM,DBM –d DEMODB

dbmcli on DEMODB>

2. Überführen der Datenbankinstanz in Betriebszustand OFFLINE:

dbmcli on DEMODB>db_offline

OK

3. Löschen der Datenbankinstanz:

dbmcli on DEMODB>db_drop

OK

Ergebnis

Die Datenbankinstanz DEMODB wurde gelöscht.

Sie können dies überprüfen, indem Sie sich eine Liste aller vorhandenen Datenbankinstanzen anzeigen lassen (Siehe: Database Manager CLI, Strukturlink db_enum)


Demo-Daten in eine Datenbankinstanz laden (SAP-Bibliothek - Tutorials)

Vorgehensweisen Demo-Daten in eine Datenbankinstanz laden

Verwendung

Sie laden mit Hilfe des DBM-Kommandos Strukturlink load_tutorial die Demo-Daten in eine beliebige Datenbankinstanz.

Wenn Sie die in diesem Tutorial Datenbankverwaltung oder im Loader-Tutorial aufgeführten Beispiele ausführen wollen, empfehlen wir Ihnen, mit Hilfe des Installation Manager die Datenbankinstanz DEMODB anzulegen und mit der angebotenen Option die Demo-Daten in diese Datenbankinstanz zu laden. Sie erhalten so die den Beispielen zugrunde liegende Datenbankinstanz und damit auch die in den Beispielen ausgewiesenen Ergebnisse.

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Installationshandbuch, Strukturlink Demo-Datenbankinstanz DEMODB anlegen

Vorgehensweise

Aufrufen des Database Manager CLI, Anmelden als Benutzer DBADMIN mit dem Kennwort SECRET, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Laden der Demo-Daten:

>dbmcli –u DBADMIN,SECRET –d DEMODB load_tutorial

OK


DBM-Benutzer anlegen (SAP-Bibliothek - Tutorials)

Vorgehensweisen DBM-Benutzer anlegen

Verwendung

Sie können einen DBM-Benutzer auf der Basis eines vorhandenen DBM-Benutzers anlegen, von dem dann alle Serverberechtigungen und DBM-Benutzereigenschaften, jedoch nicht Name und Kennwort, kopiert werden. Anschließend können Sie diese Serverberechtigungen und DBM-Benutzeigenschaften ändern und so Ihren Erfordernissen anpassen.

Sie haben aber auch die Möglichkeit, beim Anlegen des neuen Benutzers nur Name und Kennwort zu definieren. Er wird dann nur mit diesen beiden DBM-Benutzereigenschaften angelegt. Anschließend müssen Sie ihm alle weiteren DBM-Benutzereigenschaften und Serverberechtigungen explizit zuweisen.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink user_create

Siehe auch:

Database Manager CLI, Strukturlink Serverberechtigungen

Konzepte des Datenbanksystems, Strukturlink Database Manager-Benutzer

Szenario 1

Sie wollen den neuen DBM-Benutzer OLEG mit dem Kennwort MONDAY anlegen. Sie verwenden als Vorlage dafür die Konfiguration des Datenbanksystemadministrators und entziehen ihm dann die Serverberechtigungen für das Starten und Stoppen von Datenbankinstanzen, für das Ausführen von Betriebssystemkommandos, für die Installationsverwaltung und für das Verwalten der DBM-Benutzer.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Datenbanksystemadministrator DBADMIN mit dem Kennwort SECRET, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli -u DBADMIN,SECRET -d DEMODB

dbmcli on DEMODB>

2. Anlegen des Database Manager-Benutzers OLEG mit dem Kennwort MONDAY und den Serverberechtigungen des Datenbanksystemadministrators DBADMIN:

dbmcli on DEMODB>user_create OLEG,MONDAY DBADMIN

OK

3. Ändern der DBM-Benutzereigenschaften gemäß obigem Szenario:

dbmcli on DEMODB>user_put OLEG SERVERRIGHTS=-DBStart,-DBStop,-SystemCmd,-InstallMgm,-UserMgm

OK

Ergebnis

Es wurde der DBM-Benutzer OLEG mit dem Kennwort MONDAY für die Datenbankinstanz DEMODB angelegt. Er hat folgende Serverberechtigungen: DBInfoRead, Backup, LoadSystab, Recovery, DBFileRead, ParamCheckWrite, ParamFull, ParamRead, AccessSQL, AccessUtility, SchedulerMgm und Scheduling.

Szenario 2

Sie wollen den neuen DBM-Benutzer ELENA mit dem Kennwort SUNDAY anlegen und ihm folgende Serverberechtigungen zuweisen:

● Anzeigen von Zustandsinformationen

● Sichern und Wiederherstellen von Datenbankinstanzen

● Zugriff auf Datenbankparameter (geprüftes Schreiben)

● Laden der Systemtabellen

● Einplanen von DBM-Kommandos

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Datenbanksystemadministrator DBADMIN mit dem Kennwort SECRET, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u DBADMIN,SECRET –d DEMODB

dbmcli on DEMODB>

2. Anlegen des DBM-Benutzers ELENA mit dem Kennwort SUNDAY:

dbmcli on DEMODB>user_create ELENA,SUNDAY

OK

3. Zuweisen der Serverberechtigungen gemäß obigem Szenario:

dbmcli on DEMODB>user_put ELENA SERVERRIGHTS=+Backup,+Recovery,+ParamCheckWrite,+Scheduling

OK

Ergebnis

Es wurde der DBM-Benutzer ELENA mit dem Kennwort SUNDAY für die Datenbankinstanz DEMODB angelegt. Er hat folgende Serverberechtigungen: Backup, Recovery, ParamCheckwrite und Scheduling.


Werte von Datenbankparametern ändern (SAP-Bibliothek - Tutorials)

Funktionsdokumentation Werte von Datenbankparametern ändern

Die Werte von Datenbankparametern können geändert werden. Um die Lauffähigkeit des Datenbanksystems und die Sicherheit der Daten zu gewährleisten, sollten Änderungen an den Datenbankparametern jedoch ausschließlich von geschulten und erfahrenen Administratoren vorgenommen werden.

Wählen Sie das geeignete Beispiel:

Wert eines einzelnen Datenbankparameters ändern

Werte mehrerer Datenbankparameter ändern

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien


Wert eines einzelnen Datenbankparameters ändern (SAP-Bibliothek - Tutorials)

Vorgehensweisen Wert eines einzelnen Datenbankparameters ändern

Verwendung

Sie ändern den Wert eines einzelnen Datenbankparameters. Die dafür benötigte Parametersitzung wird vom Database Manager beim Ausführen des DBM-Kommandos implizit eröffnet und wieder geschlossen.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink param_put

Vorgehensweise

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ändern des Parameterwertes für DATE_TIME_FORMAT auf den Wert EUR. Die Änderung soll sofort aktiv werden, jedoch nur für die laufende Datenbanksitzung gelten:

>dbmcli -u OLEG,MONDAY -d DEMODB param_put –running DATE_TIME_FORMAT EUR

OK


Werte mehrerer Datenbankparameter ändern (SAP-Bibliothek - Tutorials)

Vorgehensweisen Werte mehrerer Datenbankparameter ändern

Verwendung

Bevor Sie die Werte mehrerer Datenbankparameter ändern, eröffnen Sie explizit eine Parametersitzung. Anschließend weisen Sie jedem der Parameter den neuen Wert zu, lassen dann alle neuen Parameterwerte gleichzeitig vom System prüfen und bestätigen dann alle Änderungen der Parameterdatei.

Durch die Angabe einer Option können Sie definieren, ob die Parametersitzung nach dem Bestätigen der Änderungen erhalten bleiben oder geschlossen werden soll.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink param_startsession, Strukturlink param_put, Strukturlink param_checkall, Strukturlink param_commitsession

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Eröffnen einer Parametersitzung

dbmcli on DEMODB>param_startsession

OK

3. Ändern der Parameterwerte für MAXUSERTASKS auf 5, für MAXLOCKS auf 2000 und für CACHE_SIZE auf 8000.

Die neuen Werte für die Parameter sollen erst nach einem Restart wirksam werden. (Die entsprechende Option –permanent muss nicht angegeben werden, da sie Vorschlagswert des Systems ist.):

dbmcli on DEMODB>param_put MAXUSERTASKS 5

OK

dbmcli on DEMODB>param_put MAXLOCKS 2000

OK

dbmcli on DEMODB>param_put CACHE_SIZE 8000

OK

4. Prüfen der Datenbankparameter durch das System starten:

dbmcli on DEMODB>param_checkall

OK

5. Bestätigen der durchgeführten Änderungen in der Parameterdatei:

dbmcli on DEMODB>param_commitsession

OK


Vergrößern einer Datenbankinstanz (SAP-Bibliothek - Tutorials)

Vorgehensweisen Vergrößern einer Datenbankinstanz

Verwendung

Wenn Sie feststellen, dass Sie beim Anlegen Ihrer Datenbankinstanz den Datenbereich potentiell zu klein bemessen haben und ein Überlaufen des Datenbereichs befürchten müssen, können Sie während des laufenden Datenbankbetriebs den Datenbereich vergrößern.

Der permanente Speicherplatz muss dafür ausreichend groß sein, da Sie mit dem Anlegen eines Data-Volume auch den entsprechenden Speicherplatz für das Datenbanksystem reservieren.

Während des laufenden Datenbankbetriebs können Sie Data-Volmes nur dann hinzufügen, wenn Sie den Wert des Datenbankparameters MAXDATAVOLUMES ausreichend groß definiert haben.

Wenn dieser Wert nicht groß genug konfiguriert ist, müssen Sie zunächst den Wert für MAXDATAVOLUMES erhöhen und das Datenbanksystem neu starten. Anschließend können Data-Volumes bei laufendem Datenbankbetrieb hinzugefügt werden.

Sie können die Funktion zum automatischen Erweitern des Datenbereichs nutzen, mit der Data-Volumes angelegt werden, sobald das Datenbanksystem den definierten Füllungsgrad erreicht. Sie können aber auch manuell Data-Volumes hinzufügen.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink auto_extend, Strukturlink db_addvolume

Siehe auch:

Wert eines einzelnen Datenbankparameters ändern

Konzepte des Datenbanksystems, Strukturlink Volumes (permanenter Speicher), Abschnitt "Data-Volumes" sowie Strukturlink Datenbankdesign

Szenario 1

Sie wollen, dass das System immer dann selbständig den Datenbereich um ein Data-Volume vergrößert, wenn ein Füllungsgrad von 66 % erreicht wird. Es soll dafür im gleichen Verzeichnis, in dem auch das zuletzt definierte Data-Volume gespeichert ist, weitere Data-Volumes anlegen.

Das zuletzt angelegt Data-Volume ist vom Typ Datei.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Einschalten der Funktion zur automatischen Vergrößerung des Datenbereichs bei einem Füllungsgrad von 66 %:

dbmcli on DEMODB>auto_extend ON 66

OK

Ergebnis

Die Funktion für das automatische Vergrößern des Datenbereichs ist eingeschaltet.

Sie können dies mit auto_extend SHOW überprüfen und auch anzeigen, welcher Wert aktuell als Schwellenwert definiert ist.

Szenario 2

Sie haben festgestellt, dass sich der Füllungsgrad des Datenbereichs von DEMODB dem Wert von 95% nähert. Sie streben jedoch im Datenbereich einen Füllungsgrad von 50 % an.

Aus diesem Grunde soll das System so viele Data-Volumes hinzufügen, wie notwendig sind, um einen Füllungsgrad des Datenbereichs von 50 % zu erzielen.

Vorgehensweise

...

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB,

Erweitern des Datenbereichs zum Erreichen eines Füllungsgrades von 50 %:

>dbmcli –u OLEG,MONDAY –d DEMODB db_addvolume DATA –fd 50

OK

1

Ergebnis

Zum Erreichen des Füllungsgrades von 50 % wurde vom System ein weiteres Data-Volume angelegt.

Szenario 3

Sie wollen vorsorglich ein zweites Data-Volume vom Typ Datei für DEMODB anlegen. Es soll genauso groß sein, wie das erste Data-Volume (32768 Seiten) und unter dem Namen DISKD0002 im gleichen Verzeichnis angelegt werden (C:\Documents and Settings\All Users\Application Data\sdb\data\DEMODB\data).

Vorgehensweise

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

OK

dbmcli on DEMODB>

2. Anlegen des zweiten Data-Volume mit den im Szenario genannten Eigenschaften:

dbmcli on demodb>db_addvolume DATA "C:\Documents and Settings\All Users\Application Data\sdb\data\DEMODB\data\DISKD0002" F 32768

OK

Ergebnis

Das Data-Volume DISKD0002 wurde für die Datenbankinstanz DEMODB angelegt.

Sie können alle Data- und Log-Volumes und die Pfade, unter denen sie gespeichert sind, mit Hilfe des DBM-Kommandos Strukturlink param_getvolsall anzeigen.


Ausführen von Datenbankanweisungen (SAP-Bibliothek - Tutorials)

Funktionsdokumentation Ausführen von Datenbankanweisungen

Sie können mit Hilfe von DBM-Kommandos Datenbankanweisungen an die Datenbankinstanz übermitteln sowie die Ergebnismengen der Datenbankanweisungen und deren Struktur anzeigen.

Wählen Sie das geeignete Beispiel:

Einzelne Datenbankanweisung ausführen

Folge von Datenbankanweisungen ausführen


Einzelne Datenbankanweisung ausführen (SAP-Bibliothek - Tutorials)

Vorgehensweisen Einzelne Datenbankanweisung ausführen

Verwendung

Sie verwenden das DBM-Kommando db_execute zum Ausführen der Datenbankanweisung. Die dafür benötigte Datenbanksitzung wird vom Database Manager beim Ausführen der Datenbankanweisung implizit eröffnet und wieder geschlossen. Für das implizite Eröffnen einer Datenbanksitzung verwendet der Database Manager die Daten des ersten DBM-Benutzers. Deshalb können auf diese Weise nur Datenbankanweisungen ausgeführt werden, zu denen der erste DBM-Benutzer berechtigt ist.

Die Datenbanksitzung wird immer im AUTOCOMMIT-Modus eröffnet. Das bedeutet, dass eingegebene SQL-Anweisungen automatisch mit einer COMMIT-Anweisung abgeschlossen und damit nicht mehr mit Hilfe einer ROLLBACK-Anweisung zurückgerollt werden können.

Wenn Sie db_execute verwenden, dann kann die erzeugte Ergebnismenge die Größe des vom DBM-Server übertragenen Antwortpakets (ca. 16 KB) überschreiten. Wenn am Ende der Ausgabe das Schlüsselwort CONTINUE angezeigt wird, dann ist dies ein Zeichen dafür, dass noch weitere Datensätze ermittelt wurden und abgerufen werden können. Sie müssen in diesem Falle so verfahren, wie unter Folge von Datenbankanweisungen ausführen erläutert, da Sie innerhalb derselben Datenbanksitzung weitere Datenbankanweisungen ausführen müssen, um die übrige Ergebnismenge anzuzeigen.

Neben der sofortigen Ausgabe der gesamten Ergebnismenge haben Sie auch die Möglichkeit, sich die Ergebnismenge datensatzweise anzeigen zu lassen. Da Sie dazu innerhalb derselben Datenbanksitzung weitere Datenbankanweisungen ausführen müssen, verfahren Sie auch in diesem Falle so, wie in Folge von Datenbankanweisungen ausführen erläutert.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink db_execute

Siehe auch:

Glossar, Strukturlink AUTOCOMMIT-Modus , Strukturlink ROLLBACK

Szenario

Sie wollen die SQL-Anweisung zum Anzeigen von Inhalten der Tabelle users ausführen und sich in der Antwort die größtmögliche Anzahl von Datensätzen anzeigen lassen.

Vorgehensweise

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ausführen der SQL-Anweisung zum Anzeigen von Inhalten der Tabelle users (Benutzername, Verbindungsmodus und Benutzer-ID):

>dbmcli -u OLEG,MONDAY -d DEMODB db_execute SELECT username,connectmode,user_id from users

OK

END

'DBM';'MULTIPLE';22

'OLEG';'MULTIPLE';0

'DBADMIN';'MULTIPLE';10

'MONA';'MULTIPLE';24


Folge von Datenbankanweisungen ausführen (SAP-Bibliothek - Tutorials)

Vorgehensweisen Folge von Datenbankanweisungen ausführen

Verwendung

Bevor Sie eine Folge von Datenbankanweisungen ausführen, eröffnen Sie explizit eine Datenbanksitzung. Sie können in diesem Kommando angeben, mit welchem Benutzer diese Datenbanksitzung eröffnet werden soll. Wenn Sie keinen Benutzer angeben, verwendet das System die Daten des ersten DBM-Benutzers. Beachten Sie deshalb, dass Sie innerhalb der Datenbanksitzung nur Datenbankanweisungen ausführen können, zu denen der Benutzer, mit welchem die Datenbanksitzung eröffnet wurde, berechtigt ist.

Die Datenbanksitzung wird immer im AUTOCOMMIT-Modus eröffnet. Das bedeutet, dass eingegebene SQL-Anweisungen automatisch mit einer COMMIT-Anweisung abgeschlossen und damit nicht mehr mit Hilfe einer ROLLBACK-Anweisung zurückgerollt werden können.

Innerhalb der Datenbanksitzung verwenden Sie dann das DBM-Kommando db_execute oder db_executenice, um eine Datenbankanweisung an eine Datenbankinstanz zu übermitteln.

Welches dieser beiden DBM-Kommandos Sie wählen, hängt davon ab, ob Sie die größtmögliche Ergebnismenge der Datenbankanweisung oder das Ergebnis datensatzweise anzeigen wollen.

Wenn Sie db_execute verwendet haben, dann kann die erzeugte Ergebnismenge die Größe des vom DBM-Server übertragenen Antwortpakets (ca. 16 KB) überschreiten. In diesem Fall weist Sie der Database Manager mit dem Schlüsselwort CONTINUE in der Ausgabe darauf hin, dass noch weitere Daten angezeigt werden können. Zum Anzeigen dieser weiteren Daten verwenden Sie das DBM-Kommando db_fetch.

Wenn Sie db_executenice verwendet haben und sich den jeweils nächsten Datensatz anzeigen lassen wollen, verwenden Sie dazu das DBM-Kommando db_fetchnice.

Wenn alle Ergebnisdaten angezeigt wurden, schließen Sie die Datenbanksitzung oder beenden gegebenenfalls den Database Manager CLI.

Sie müssen auch für die Ausführung einer einzelnen Datenbankanweisung explizit eine Datenbanksitzung eröffnen, wenn Sie für diese Anweisung eine Ergebnismenge erwarten, die die Größe eines Antwortpakets übersteigt, oder wenn Sie sich die Ergebnismenge datensatzweise anzeigen lassen wollen. Dies ist notwendig, da Sie in diesen Fällen mehrere Datenbankanweisungen zum Anzeigen der Ergebnisse innerhalb derselben Datenbanksitzung ausführen müssen.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink db_connect, Strukturlink db_execute, Strukturlink db_executenice, Strukturlink db_fetch, Strukturlink db_fetchnice, Strukturlink db_release

Siehe auch:

Glossar, Strukturlink AUTOCOMMIT-Modus , Strukturlink ROLLBACK

Szenario 1

Sie wollen drei neue Datenbankbenutzer anlegen und die dazu notwendigen SQL-Anweisungen unmittelbar nacheinander ausführen. Sie müssen dazu eine Datenbanksitzung eröffnen.

Nur ein Datenbanksystemadministrator hat die Berechtigung, neue Datenbankbenutzer anzulegen. Sie müssen deshalb die Datenbanksitzung mit den Daten des Datenbanksystemadministrators eröffnen. Wenn Sie bei diesem DBM-Kommando keinen Benutzer angeben, verwendet das System die Daten des ersten DBM-Benutzers.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Benutzer, Authentifizierung und Berechtigungen

Referenzhandbuch, Strukturlink CREATE USER-Anweisung

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on demodb>

2. Aufbau einer Datenbanksitzung als Datenbankadministrator DBADMIN mit dem Kennwort SECRET:

dbmcli on demodb>db_connect DBADMIN,SECRET

OK

3. Ausführen der SQL-Anweisung zum Anlegen des Benutzers MONA mit dem Kennwort RED und den Eigenschaften DBA und NOT EXCLUSIVE:

dbmcli on demodb>db_execute CREATE USER mona PASSWORD red DBA NOT EXCLUSIVE

OK

4. Ausführen der SQL-Anweisung zum Anlegen des Benutzers DAVID mit dem Kennwort BLUE und der Eigenschaft RESOURCE:

dbmcli on demodb>db_execute CREATE USER david PASSWORD blue RESOURCE

OK

5. Ausführen der SQL-Anweisung zum Anlegen des Benutzers BORIS mit dem Kennwort PINK und der Eigenschaft STANDARD:

dbmcli on demodb>db_execute CREATE USER boris PASSWORD pink STANDARD

OK

6. Schließen der Datenbanksitzung:

dbmcli on demodb>db_release

OK

Ergebnis

Die Datenbankbenutzer MONA, DAVID und BORIS wurden mit den angegebenen Eigenschaften angelegt und können sich nun an die Datenbankinstanz anmelden.

Szenario 2

Sie wollen eine SQL-Anweisung ausführen, um sich Inhalte der Tabelle users anzeigen zu lassen. Die Anzeige soll datensatzweise erfolgen.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on demodb>

2. Aufbau einer Datenbanksitzung (ohne Angabe eines Benutzers, es werden die Daten des ersten DBM-Benutzers verwendet):

dbmcli on demodb>db_connect

OK

3. Ausführen der SQL-Anweisung zum datensatzweisen Anzeigen von Inhalten der Tabelle users (Benutzername, Verbindungsmodus und Benutzer-ID):

dbmcli on demodb>db_executenice SELECT username,connectmode,user_id FROM users

OK

CONTINUE

USERNAME = 'DBM'

CONNECTMODE = 'MULTIPLE'

USER_ID = 0

---

4. Anzeigen des nächsten Datensatzes:

dbmcli on demodb>db_fetchnice

OK

CONTINUE

USERNAME = 'DBADMIN'

CONNECTMODE = 'MULTIPLE'

USER_ID = 10

---

5. Anzeigen des nächsten Datensatzes:

dbmcli on demodb>db_fetchnice

OK

USERNAME = 'MONA'

CONNECTMODE = 'MULTIPLE'

USER_ID = 27

Ergebnis

Nach jeder Ausführung des DBM-Kommandos db_fetchnice erhalten Sie den nächsten Datensatz der Ergebnismenge angezeigt.


Sicherungsvorlagen definieren (SAP-Bibliothek - Tutorials)

Funktionsdokumentation Sicherungsvorlagen definieren

Wählen Sie das geeignete Beispiel für das Definieren der gewünschten Sicherungsvorlage:

Sicherungsvorlage für die vollständige Datensicherung in eine Datei definieren

Sicherungsvorlage für die inkrementelle Datensicherung in eine Datei definieren

Sicherungsvorlage für die Log-Sicherung in eine Datei definieren

Sicherungsvorlage für die interaktive Log-Sicherung in eine Pipe definieren

Sicherungsvorlage für die vollständige Datensicherung auf ein Band definieren


Sicherungsvorlage für die vollständige Datensicherung in eine Datei definieren

Vorgehensweisen Sicherungsvorlage für die vollständige Datensicherung in eine Datei definieren

Verwendung

Sie melden sich als DBM-Benutzer an den Database Manager CLI an, stellen die Verbindung zu jener Datenbankinstanz her, für die die Sicherungsvorlage angelegt werden soll, und definieren eine Sicherungsvorlage vom Typ Datei für eine vollständige Datensicherung.

Sie können frei wählen, wo diese Datei im System abgelegt werden soll. Wenn Sie einen relativen Pfad angeben, dann wird dieser relativ zum Arbeitsverzeichnis der Datenbankinstanz interpretiert. Das angegebene Verzeichnis muss bereits existieren. Wenn Sie einen Pfad oder Namen angeben, der Leerzeichen enthält, dann sind diese im DBM-Kommando in doppelte Anführungszeichen zu setzen. Die einführenden Anführungszeichen müssen Sie mit Hilfe eines inversen Schrägstrichs (\) markieren.

Der Database Manager speichert die Sicherungsvorlage intern. Erst wenn die Sicherungsvorlage für eine Sicherung verwendet wird, wird die Datei, welche die Sicherung enthält, im Dateisystem sichtbar.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink medium_put

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen

Szenario

Sie wollen eine Sicherungsvorlage für die vollständige Datensicherung mit folgenden Eigenschaften definieren:

Name der Sicherungsvorlage: DemoDataCompl
Datenträger (device/file): Backups 2005\Data\completeDataJan
Typ: Datei (FILE)
Sicherungsart: vollständige Datensicherung (DATA)
Größenbeschränkung: keine (0)
Blockgröße: 6
überschreibbar: nein (NO)

Vorgehensweise

Aufrufen des Database Manager CLI und Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB und Anlegen einer Sicherungsvorlage mit den im Szenario genannten Eigenschaften:

>dbmcli -u OLEG,MONDAY -d DEMODB medium_put DemoDataCompl \"Backups 2005\Data\completeDataJan" FILE DATA 0 6 NO

OK

Ergebnis

Die Sicherungsvorlage DemoDataCompl wurde für die Datenbankinstanz DEMODB angelegt.

Sie können nun eine vollständige Datensicherung unter Verwendung dieser Sicherungsvorlage starten.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Database Manager CLI, Strukturlink backup_start


Sicherungsvorlage für die inkrementelle Datensicherung in eine Datei definieren

Vorgehensweisen Sicherungsvorlage für die inkrementelle Datensicherung in eine Datei definieren

Verwendung

Sie melden sich als DBM-Benutzer an den Database Manager CLI an, stellen die Verbindung zu jener Datenbankinstanz her, für die die Sicherungsvorlage angelegt werden soll, und definieren eine Sicherungsvorlage vom Typ Datei für eine inkrementelle Datensicherung.

Sie können frei wählen, wo diese Datei im System abgelegt werden soll. Wenn Sie einen relativen Pfad angeben, dann wird dieser relativ zum Arbeitsverzeichnis der Datenbankinstanz interpretiert. Das angegebene Verzeichnis muss bereits existieren. Wenn Sie einen Pfad oder Namen angeben, der Leerzeichen enthält, dann sind diese im DBM-Kommando in doppelte Anführungszeichen zu setzen. Die einführenden Anführungszeichen müssen Sie mit Hilfe eines inversen Schrägstrichs (\) markieren.

Der Database Manager speichert die Sicherungsvorlage intern. Erst wenn die Sicherungsvorlage für eine Sicherung verwendet wird, wird die Datei, welche die Sicherung enthält, im Dateisystem sichtbar.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink medium_put

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen

Szenario

Sie wollen eine Sicherungsvorlage für die inkrementelle Datensicherung mit folgenden Eigenschaften definieren:

Name der Sicherungsvorlage: DemoDataInc
Datenträger (device/file): Backups 2005\Data\incDataJan01
Typ: Datei (FILE)
Sicherungsart: inkrementelle Datensicherung (PAGES)
Größenbeschränkung: keine (0)
Blockgröße: 6
überschreibbar: nein (NO)

Vorgehensweise

Aufrufen des Database Manager CLI und Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB und Anlegen einer Sicherungsvorlage mit den im Szenario genannten Eigenschaften:

>dbmcli -u OLEG,MONDAY -d DEMODB medium_put DemoDataInc "Backups 2005\Data\incDataJan" FILE PAGES 0 6 NO

OK

Ergebnis

Die Sicherungsvorlage DemoDataInc wurde für die Datenbankinstanz DEMODB angelegt.

Sie können nun eine inkrementelle Datensicherung unter Verwendung dieser Sicherungsvorlage starten.

Siehe auch:

Inkrementelle Datensicherung in eine Datei durchführen

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Database Manager CLI, Strukturlink backup_start


Sicherungsvorlage für die Log-Sicherung in eine Datei definieren

Vorgehensweisen Sicherungsvorlage für die Log-Sicherung in eine Datei definieren

Verwendung

Sie melden sich als DBM-Benutzer an den Database Manager CLI an, stellen die Verbindung zu jener Datenbankinstanz her, für die die Sicherungsvorlage angelegt werden soll, und definieren eine Sicherungsvorlage vom Typ Datei für die Log-Sicherung.

Sie können die Sicherungsvorlage sowohl für die automatische als auch für die interaktive Log-Sicherung verwenden. Dabei ist es unerheblich, ob sie für den Sicherungstyp LOG oder AUTO definiert wurde. Das Datenbanksystem verarbeitet automatische und interaktive Log-Sicherungen sowohl beim Sichern als auch beim Wiederherstellen auf die gleiche Art und Weise.

Sie können frei wählen, wo diese Datei im System abgelegt werden soll. Wenn Sie einen relativen Pfad angeben, dann wird dieser relativ zum Arbeitsverzeichnis der Datenbankinstanz interpretiert. Das angegebene Verzeichnis muss bereits existieren. Wenn Sie einen Pfad angeben, der Leerzeichen enthält, dann sind diese im DBM-Kommando in doppelte Anführungszeichen zu setzen. Die einführenden Anführungszeichen müssen Sie mit Hilfe eines inversen Schrägstrichs (\) markieren.

Der Database Manager speichert die Sicherungsvorlage intern. Erst wenn die Sicherungsvorlage für eine Sicherung verwendet wird, wird die Datei, welche die Sicherung enthält, im Dateisystem sichtbar.

Das System nummeriert die Dateien fortlaufend, sobald sie für eine Log-Sicherung verwendet werden. Sie werden also nach dem Sichern des Log-Bereichs mit Hilfe der Sicherungsvorlage <file_name> nur eine oder mehrere Datei/en mit dem Dateinamen <file_name>.<running_number> auf Ihrer Festplatte finden.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink medium_put

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen

Szenario

Sie wollen eine Sicherungsvorlage für die Log-Sicherung in eine Datei mit folgenden Eigenschaften definieren:

Name der Sicherungsvorlage: DemoFileLog
Datenträger (device/file): Backups 2005\Data\logBackup
Typ: Datei (FILE)
Sicherungsart: automatische Log-Sicherung (AUTO)
Größenbeschränkung: keine (0)

Vorgehensweise

Aufrufen des Database Manager CLI und Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB und Anlegen einer Sicherungsvorlage mit den im Szenario genannten Eigenschaften:

>dbmcli -u OLEG,MONDAY -d DEMODB medium_put DemoFileLog "Backups 2005\Data\logBackup" FILE AUTO 0

OK

Ergebnis

Die Sicherungsvorlage DemoFileLog wurde für die Datenbankinstanz DEMODB angelegt.

Wenn Sie bereits eine vollständige Datensicherung von DEMODB angefertigt haben, können Sie nun eine Log-Sicherung in eine Datei durchführen oder die automatische Log-Sicherung einschalten.

Siehe auch:

Automatische Log-Sicherung einschalten

Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern

Database Manager CLI, Strukturlink backup_start, Strukturlink autolog_on


Sicherungsvorlage für die Log-Sicherung in eine Pipe definieren (SAP-Bibliothek - Tutorials)

Vorgehensweisen Sicherungsvorlage für die Log-Sicherung in eine Pipe definieren

Verwendung

Sie verwenden eine Sicherungsvorlage vom Typ PIPE, wenn Sie Daten an andere Programme übergeben oder über Rechnergrenzen hinaus übertragen wollen. Neben den von der MaxDB-Datenbanksoftware direkt unterstützten Sicherungswerkzeugen haben Sie damit auch die Möglichkeit, weitere Sicherungswerkzeuge anderer Anbieter anzuschließen, sofern diese in der Lage sind, Daten aus Pipes zu lesen.

Sie melden sich als DBM-Benutzer an den Database Manager CLI an, stellen die Verbindung zu jener Datenbankinstanz her, für die die Sicherungsvorlage angelegt werden soll, und definieren eine Sicherungsvorlage vom Typ Pipe für eine Log-Sicherung.

Eine Sicherungsvorlage vom Typ Pipe können Sie nur für eine interaktive Log-Sicherung, jedoch nicht für die automatische Log-Sicherung verwenden.

In Abhängigkeit von Ihrem Betriebssystem können Sie wählen, wo diese Pipe im System abgelegt werden soll. Wenn Sie einen relativen Pfad angeben, dann wird dieser relativ zum Arbeitsverzeichnis der Datenbankinstanz interpretiert. Das angegebene Verzeichnis muss bereits existieren. Wenn Sie einen Pfad angeben, der Leerzeichen enthält, dann müssen Sie den Pfad im DBM-Kommando in doppelte Anführungszeichen setzen. Beachten Sie auch die Regeln Ihres Betriebssystems für die Namensgebung bei Pipes.

Der Database Manager speichert die Sicherungsvorlage intern. Erst dann, wenn die Sicherungsvorlage für eine Sicherung verwendet wird, wird die Pipe angelegt und geöffnet und die Daten werden in die Pipe geschrieben.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink medium_put

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen

Szenario

Sie wollen eine Sicherungsvorlage für die Log-Sicherung in eine Pipe mit folgenden Eigenschaften definieren:

Name der Sicherungsvorlage: DemoPipeLog
Datenträger (device/file): \\.\pipe\testpipe
Typ: Pipe (PIPE)
Sicherungsart: interaktive Log-Sicherung (LOG)
Vorgehensweise

Aufrufen des Database Manager CLI und Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB und Definieren einer Sicherungsvorlage mit den im Szenario genannten Eigenschaften:

>dbmcli -u OLEG,MONDAY -d DEMODB medium_put DemoPipeLog \\.\pipe\testpipe PIPE LOG

OK

Ergebnis

Die Sicherungsvorlage DemoPipeLog wurde für die Datenbankinstanz DEMODB angelegt.

Wenn Sie bereits eine vollständige Datensicherung von DEMODB angefertigt haben, können Sie nun eine interaktive Log-Sicherung unter Verwendung dieser Sicherungsvorlage starten.

Siehe auch:

Log-Sicherung in eine Pipe durchführen

Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern

Installationshandbuch, Strukturlink Anschluss von Sicherungswerkzeugen anderer Anbieter

Database Manager CLI, Strukturlink backup_start


Sicherungsvorlage für die vollständige Datensicherung auf ein Band definieren

Vorgehensweisen Sicherungsvorlage für die vollständige Datensicherung auf ein Band definieren

Verwendung

Sie melden sich als DBM-Benutzer an den Database Manager CLI an, stellen die Verbindung zu jener Datenbankinstanz her, für die die Sicherungsvorlage angelegt werden soll, und definieren eine Sicherungsvorlage vom Typ Band für eine vollständige Datensicherung. Dabei verwenden Sie die von der Bandstation vorgegebene Bezeichnung für den Datenträger (location/device).

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink medium_put

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen

Szenario

Sie wollen eine Sicherungsvorlage für die vollständige Datensicherung auf ein Band mit folgenden Eigenschaften definieren:

Name der Sicherungsvorlage: DemoTapeCompl
Datenträger (device/file): \\.\tape0
Typ: Band (TAPE)
Sicherungsart: vollständige Datensicherung (DATA)

Vorgehensweise

Aufrufen des Database Manager CLI und Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB und Definieren einer Sicherungsvorlage mit den im Szenario genannten Eigenschaften:

>dbmcli –u OLEG,MONDAY –d DEMODB medium_put DemoTapeCompl \\.\tape0 TAPE DATA

OK

Ergebnis

Die Sicherungsvorlage DemoTapeCompl wurde für die Datenbankinstanz DEMODB angelegt.

Sie können nun eine vollständige Datensicherung unter Verwendung dieser Sicherungsvorlage starten.

Siehe auch:

Vollständige Datensicherung auf ein Band durchführen

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Database Manager CLI, Strukturlink backup_start


Sichern (SAP-Bibliothek - Tutorials)

Funktionsdokumentation Sichern

Wählen Sie das geeignete Beispiel für das Sichern von Daten:

Vollständige Datensicherung in eine Datei durchführen

Vollständige Datensicherung auf ein Band durchführen

Inkrementelle Datensicherung in eine Datei durchführen

Log-Sicherung in eine Pipe durchführen

Anzeigen des Sicherungsfortschritts

Automatische Log-Sicherung einschalten

Sichern mit Sicherungswerkzeugen anderer Anbieter


Vollständige Datensicherung in eine Datei durchführen (SAP-Bibliothek - Tutorials)

Vorgehensweisen Vollständige Datensicherung in eine Datei durchführen

Verwendung

Sie sichern alle im Datenbereich der Datenbankinstanz gespeicherten Daten in eine Datei.

Den Fortschritt des Sicherungsvorganges können Sie sich mit Hilfe des DBM-Kommandos backup_state anzeigen lassen. Jedes Mal, wenn Sie dieses DBM-Kommando ausführen, erhalten Sie den jeweils erreichten Fortschritt angezeigt.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink backup_start, Strukturlink backup_state

Siehe auch:

Sicherungsvorlage für die vollständige Datensicherung in eine Datei definieren

Anzeigen des Sicherungsfortschritts

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Szenario

Sie wollen eine vollständige Datensicherung in eine Datei durchführen.

Sie haben eine Sicherungsvorlage vom Typ FILE mit dem Namen DemoDataCompl für die vollständige Datensicherung definiert.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus und Anmelden als DBM-Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>

2. Eröffnen einer Datenbanksitzung

dbmcli on DEMODB>db_connect

OK

3. Starten des Sicherungsvorganges unter Verwendung der Sicherungsvorlage mit dem Namen DemoDataCompl

dbmcli on DEMODB>backup_start DemoDataCompl

OK

Returncode 0

Date 20051103

Time 00083316

Server GENUA

Database DB7.6

Kernel Version Kernel 7.6.00 Build 018-003-000-000

Pages Transferred 3800

Pages Left 0

Volumes 1

Medianame DemoDataCompl

Location Backups 2005\Data\completeDataJan

Errortext

Label DAT_000000010

Is Consistent true

First LOG Page 11934

Last LOG Page

DB Stamp 1 Date 20051103

DB Stamp 1 Time 00083316

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 5667

Devices Used 1

Database ID GENUA:DEMODB_20051014_142158

Max Used Data Page 0

Converter Page Count 11

---

dbmcli on DEMODB>

Ergebnis

Nach der Ausführung des DBM-Kommandos werden die Informationen über die Sicherung ausgegeben. Dies erfolgt erst dann, wenn die Sicherung beendet ist oder unterbrochen wurde. Die Antwort auf dieses DBM-Kommando kann deshalb sehr lange dauern.


Vollständige Datensicherung auf ein Band durchführen (SAP-Bibliothek - Tutorials)

Vorgehensweisen Vollständige Datensicherung auf ein Band durchführen

Verwendung

Sie sichern alle im Datenbereich der Datenbankinstanz gespeicherten Daten auf ein Band.

Den Fortschritt des Sicherungsvorganges können Sie sich mit Hilfe des DBM-Kommandos backup_state anzeigen lassen. Jedes Mal, wenn Sie dieses DBM-Kommando ausführen, erhalten Sie den jeweils erreichten Fortschritt angezeigt.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink backup_start, Strukturlink backup_state

Siehe auch:

Sicherungsvorlage für die vollständige Datensicherung auf ein Band definieren

Anzeigen des Sicherungsfortschritts

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Szenario

Sie wollen eine vollständige Datensicherung auf ein Band durchführen.

Sie haben eine Sicherungsvorlage vom Typ TAPE mit dem Namen DemoTapeCompl für die vollständige Datensicherung definiert.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus und Anmelden als DBM-Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Eröffnen einer Datenbanksitzung:

dbmcli on DEMODB>db_connect

OK

3. Starten des Sicherungsvorganges unter Verwendung der Sicherungsvorlage mit dem Namen DemoTapeCompl:

dbmcli on DEMODB>backup_start DemoTapeCompl

OK

Returncode 0

Date 20051101

Time 00113310

Server GENUA

Database DB7.6

Kernel Version Kernel 7.6.00 Build 018-003-000-000

Pages Transferred 3800

Pages Left 0

Volumes 1

Medianame DemoTapeCompl

Location \\.\tape0

Errortext

Label DAT_000000010

Is Consistent true

First LOG Page 10615

Last LOG Page

DB Stamp 1 Date 20051101

DB Stamp 1 Time 00113309

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 3775

Devices Used 1

Database ID GENUA:DB7.6_20051014_142158

Max Used Data Page 0

Converter Page Count 11

---

dbmcli on DEMODB>

Ergebnis

Nach der Ausführung des DBM-Kommandos werden die Informationen über die Sicherung ausgegeben. Dies erfolgt erst dann, wenn die Sicherung beendet ist oder unterbrochen wurde. Die Antwort auf dieses DBM-Kommando kann deshalb sehr lange dauern.


Anzeigen des Sicherungsfortschritts (SAP-Bibliothek - Tutorials)

Vorgehensweisen Anzeigen des Sicherungsfortschritts

Verwendung

Nachdem Sie eine Sicherung gestartet haben, können Sie sich den Sicherungsfortschritt mit Hilfe des Database Manager anzeigen lassen.

Neben dem bereits geöffneten Kommandozeilenfenster, in dem der Sicherungsvorgang gestartet wurde, öffnen Sie dazu noch ein zweites Kommandozeilenfenster, in dem Sie sich an dieselbe Datenbankinstanz anmelden.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink backup_state

Szenario

Sie haben eine vollständige Datensicherung auf ein Band gestartet. Sie wollen sich nun den Sicherungsfortschritt anzeigen lassen.

Vorgehensweise

Im folgenden Beispiel sind die relevanten Interpretationen in die Ausgabe eingefügt, fett formatiert und als Kommentare gekennzeichnet (#).

...

1. Öffnen eines neuen Kommandozeilenfensters.

2. Aufrufen des Database Manager CLI im Sitzungsmodus und Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

3. Ausführen des DBM-Kommandos zum Anzeigen des Sicherungsfortschritts:

dbmcli on DEMODB>backup_state

OK

Returncode 0

Date 20051101

Time 00113310

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 018-003-000-000

Pages Transferred 0

Pages Left 0

# Diesen Ausgabewerten entnehmen Sie, dass das Datenbanksystem mit dem Sichern begonnen hat und versucht, auf das Band zuzugreifen.

Volumes

Medianame

Location

Errortext

Label

Is Consistent

First LOG Page

Last LOG Page

DB Stamp 1 Date

DB Stamp 1 Time

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 0

Devices Used 1

Database ID GENUA:DEMODB_20051014_142158

Max Used Data Page 0

Converter Page Count

Redo Transactions Read 0

Redo Transactions Done 0

4. Erneutes Ausführen des DBM-Kommandos zum Anzeigen des Sicherungsfortschritts:

dbmcli on DEMODB>backup_state

OK

Returncode 0

Date 20051101

Time 00113310

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 018-003-000-000

Pages Transferred 216

Pages Left 3559

# Diesen Ausgabewerten entnehmen Sie, dass das Datenbanksystem die Daten auf das Band schreibt.

Volumes

Medianame

Location

Errortext

Label

Is Consistent

First LOG Page

Last LOG Page

DB Stamp 1 Date

DB Stamp 1 Time

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 3775

Devices Used 1

Database ID GENUA:DEMODB_20051014_142158

Max Used Data Page 0

Converter Page Count 11

Redo Transactions Read 0

Redo Transactions Done 0

5. Erneutes Ausführen des DBM-Kommandos zum Anzeigen des Sicherungsfortschritts:

dbmcli on DEMODB>backup_state

OK

Returncode 0

Date 20051101

Time 00113310

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 018-003-000-000

Pages Transferred 3800

Pages Left 0

# Diesen Ausgabewerten entnehmen Sie, dass das Datenbanksystem keine Daten mehr auf das Band schreibt und nun das Band zurückspult.

Volumes 1

Medianame

Location

Errortext

Label

Is Consistent

First LOG Page

Last LOG Page

DB Stamp 1 Date

DB Stamp 1 Time

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 3800

Devices Used 1

Database ID GENUA:DEMODB_20051014_142158

Max Used Data Page 0

Converter Page Count 11

Redo Transactions Read 0

Redo Transactions Done 0

6. Erneutes Ausführen des DBM-Kommandos zum Anzeigen des Sicherungsfortschritts:

dbmcli on DEMODB>backup_state

OK

Returncode 0

Date

Time

Server

Database

Kernel Version

Pages Transferred 0

Pages Left 0

# Diesen Ausgabewerten entnehmen Sie, dass der Sicherungsvorgang beendet ist.

Volumes

Medianame

Location

Errortext

Label

Is Consistent

First LOG Page

Last LOG Page

DB Stamp 1 Date

DB Stamp 1 Time

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 0

Devices Used

Database ID

Max Used Data Page

Converter Page Count

Redo Transactions Read 0

Redo Transactions Done 0


Inkrementelle Datensicherung in eine Datei durchführen (SAP-Bibliothek - Tutorials)

Vorgehensweisen Inkrementelle Datensicherung in eine Datei durchführen

Verwendung

Sie sichern alle Daten, die seit der letzten vollständigen Datensicherung im Datenbereich der Datenbankinstanz gespeichert wurden.

Den Fortschritt des Sicherungsvorganges können Sie sich mit Hilfe des DBM-Kommandos backup_state anzeigen lassen. Jedes Mal, wenn Sie dieses DBM-Kommando ausführen, erhalten Sie den jeweils erreichten Fortschritt angezeigt.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink backup_start, Strukturlink backup_state

Siehe auch:

Sicherungsvorlage für die inkrementelle Datensicherung in eine Datei definieren

Anzeigen des Sicherungsfortschritts

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Szenario

Sie wollen eine inkrementelle Datensicherung in eine Datei durchführen.

Sie haben bereits eine vollständige Datensicherung durchgeführt. Sie haben eine Sicherungsvorlage vom Typ FILE mit dem Namen DemoDataInc für die inkrementelle Datensicherung definiert.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus und Anmelden als DBM-Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Eröffnen einer Datenbanksitzung:

dbmcli on DEMODB>db_connect

OK

3. Starten des Sicherungsvorganges unter Verwendung der Sicherungsvorlage mit dem Namen DemoDataInc:

dbmcli on DEMODB>backup_start DemoDataInc

OK

Returncode 0

Date 20051229

Time 00111343

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 312

Pages Left 0

Volumes 1

Medianame DemoDataInc

Location Backups 2005\Data\incDataJan

Errortext

Label PAG_000000005

Is Consistent true

First LOG Page 18648

Last LOG Page

DB Stamp 1 Date 20051229

DB Stamp 1 Time 00111343

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 285

Devices Used 1

Database ID GENUA:DEMODB_20051201_111620

Max Used Data Page 0

---

dbmcli on DEMODB>

Ergebnis

Nach der Ausführung des DBM-Kommandos werden die Informationen über die Sicherung ausgegeben. Dies erfolgt erst dann, wenn die Sicherung beendet ist oder unterbrochen wurde. Die Antwort auf dieses DBM-Kommando kann deshalb sehr lange dauern.


Log-Sicherung in eine Pipe durchführen (SAP-Bibliothek - Tutorials)

Vorgehensweisen Log-Sicherung in eine Pipe durchführen

Verwendung

Sie sichern die Daten im Log-Bereich des Datenbanksystems in eine Pipe.

Das Sichern der Daten des Log-Bereichs in eine Pipe ist nicht mit der automatischen Log-Sicherung möglich.

Den Fortschritt des Sicherungsvorganges können Sie sich mit Hilfe des DBM-Kommandos backup_state anzeigen lassen. Jedes Mal, wenn Sie dieses DBM-Kommando ausführen, erhalten Sie den jeweils erreichten Fortschritt angezeigt.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink backup_start, Strukturlink backup_state

Siehe auch:

Sicherungsvorlage für die Log-Sicherung in eine Pipe definieren

Anzeigen des Sicherungsfortschritts

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Szenario

Sie wollen den Inhalt des Log-Bereichs in eine Pipe sichern. Sie haben bereits eine Datensicherung durchgeführt und eine Sicherungsvorlage vom Typ PIPE mit dem Namen DemoPipeLog für die Log-Sicherung definiert.

DEMODB wurde für Testzwecke so konfiguriert, dass der Log-Bereich, sobald er voll ist, überschrieben wird. Um den Log-Bereich sichern zu können, müssen Sie zunächst den Überschreib-Modus ausschalten.

Die Datenbankinstanz ist im Betriebszustand ONLINE oder ADMIN.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus und Anmelden als DBM-Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Ausschalten des Überschreibmodus für den Log-Bereich:

dbmcli on DEMODB>db_execute SET LOG AUTO OVERWRITE OFF

3. Eröffnen einer Datenbanksitzung:

dbmcli on DEMODB>db_connect

OK

4. Starten des Sicherungsvorganges unter Verwendung der Sicherungsvorlage mit dem Namen DemoPipeLog.

dbmcli on DEMODB>backup_start DemoPipeLog

Ergebnis

Die Daten werden vom Database Manager in die Pipe geschrieben. Sie müssen nun das Sicherungswerkzeug starten, um die Daten aus der Pipe auf den Datenträger des Sicherungswerkzeugs zu übertragen.

Nach der Ausführung des DBM-Kommandos werden die Informationen über die Sicherung ausgegeben. Dies erfolgt erst dann, wenn die Sicherung beendet ist oder unterbrochen wurde. Die Antwort auf dieses DBM-Kommando kann deshalb sehr lange dauern.


Automatische Log-Sicherung einschalten (SAP-Bibliothek - Tutorials)

Vorgehensweisen Automatische Log-Sicherung einschalten

Verwendung

Wenn die automatische Log-Sicherung eingeschaltet ist, sichert das System kontinuierlich den Inhalt des Log-Bereichs in Dateien.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink autolog_on

Siehe auch:

Sicherungsvorlage für die Log-Sicherung in eine Datei definieren

Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern

Szenario

Sie wollen den Log-Bereich in regelmäßigen Abständen automatisch sichern lassen.

Sie haben bereits eine Datensicherung durchgeführt. Sie haben eine Sicherungsvorlage vom Typ FILE für mit dem Namen DemoFileLog für die Sicherungsart LOG oder AUTO definiert.

Vorgehensweise

Aufrufen des Database Manager CLI und Anmelden als DBM-Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Einschalten der automatischen Log-Sicherung unter Verwendung der Sicherungsvorlage DemoFileLog:

>dbmcli –u OLEG,MONDAY –d DEMODB autolog_on DemoFileLog

OK

Ergebnis

Die automatische Log-Sicherung ist eingeschaltet.

Wir empfehlen Ihnen, die bei der automatischen Log-Sicherung entstehenden Sicherungsdateien regelmäßig zu archivieren.

Um die Dateien im Dateisystem eines anderen Rechners zu archivieren, verwenden Sie Betriebssystemkommandos.

Um die Dateien mit Hilfe von Sicherungswerkzeugen andere Anbieter zu archivieren, stehen Ihnen DBM-Kommandos zur Verfügung, mit deren Hilfe Sie den Inhalt der Sicherungsdateien in Pipes schreiben können, die dann von den Sicherungswerkzeugen ausgelesen werden können.

Siehe auch:

Database Manager CLI, Strukturlink archive_stage, Strukturlink archive_stage_repeat

Konzepte des Datenbanksystems, Strukturlink Sicherungsdateien archivieren


Sichern mit Sicherungswerkzeugen anderer Anbieter (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Sichern mit Sicherungswerkzeugen anderer Anbieter

Verwendung

Sie starten den Sicherungsvorgang direkt aus dem Database Manager CLI. In Abhängigkeit vom Sicherungswerkzeug und dem Typ der verwendeten Sicherungsvorlage werden die Daten im Sicherungswerkzeug gesichert oder zur Abholung durch das Sicherungswerkzeug in eine Pipe gestellt.

Sie haben dafür die notwendige Sicherungsvorlage definiert, die MaxDB-Softwareinstallation für das verwendete Sicherungswerkzeug konfiguriert und die Datenbankinstanz in den Betriebszustand ADMIN oder ONLINE überführt. Sie haben den Datenträger in das Sicherungswerkzeug eingelegt.

Zu den Voraussetzunge siehe Database Manager CLI, Strukturlink backup_start

Siehe auch:

Sichern

Konzepte des Datenbanksystems, Strukturlink Daten sichern, Strukturlink Log-Einträge sichern, Strukturlink Sicherungswerkzeuge anderer Anbieter verwenden

Installationshandbuch, Strukturlink Anschluss von Sicherungswerkzeugen anderer Anbieter


Sichern der Datenbankinstanz auf einem entfernten Rechner (SAP-Bibliothek - Tutorials)

Vorgehensweisen Sichern der Datenbankinstanz auf einem entfernten Rechner

Verwendung

Sie können die Daten und Log-Einträge einer lokalen Datenbankinstanz auf einem entfernten Rechner sichern.

Wenn Sie in Dateien sichern wollen, muss dafür die Eigenschaft Datenträger (device/file) in der jeweiligen Sicherungsvorlage auf einen Ordner verweisen, der auf dem entfernten Rechner existiert und mit entsprechenden Lese- und Schreibrechten definiert wurde. Außerdem können Sie derartige Sicherungen nur als ein Benutzer ausführen, der auf beiden Rechnern Betriebssystem-Benutzerrechte hat.

Auf Microsoft Windows können Sie Log-Sicherungen auch in Pipes ausführen, die auf einem entfernten Rechner liegen.

Szenario

Sie wollen eine vollständige Datensicherung der Datenbankinstanz DEMODB auf dem lokalen Rechner GENUA anfertigen und auf dem entfernten Rechner PARMA im Verzeichnis C:\Backups 2006\Data ablegen. Sie haben dazu eine Sicherungsvorlage für eine vollständige Datensicherung in eine Datei mit folgenden Eigenschaften definiert:

Name der Sicherungsvorlage: DemoDataCompl_remote
Datenträger (device/file):\\PARMA\Backups 2006\Data\completeDataFe
Typ: Datei (FILE)
Sicherungsart: vollständige Datensicherung (DATA)
Größenbeschränkung: keine (0)
Blockgröße: 6
überschreibbar: nein (NO)

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink backup_start

Siehe auch:

Sicherungsvorlage für die vollständige Datensicherung in eine Datei definieren

Konzepte des Datenbanksystems, Strukturlink Sichern/Wiederherstellen mit entfernten Rechnern

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur lokalen Datenbankinstanz DEMODB.

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Überführen der Datenbankinstanz in den Betriebszustand OFFLINE:

dbmcli on DEMODB>db_offline

OK

3. Wechseln Sie in den Bereich Administrative Tools Ihres Betriebssystems. Ändern Sie im Serviceeintrag der aktuellen Datenbankinstanz (hat den Status STARTED) die Anmeldung Log on as local system account auf einen für GENUA gültigen Betriebssystembenutzer. Dieser muss auch auf dem entfernten Rechner PARMA gültig sein.

4. Überführen der Datenbankinstanz in den Betriebszustand ONLINE (nun unter dem zuvor eingetragenen Betriebssystembenutzer)

dbmcli on DEMODB>db_online

OK

5. Eröffnen einer Datenbanksitzung:

dbmcli on DEMODB>db_connect

OK

6. Starten der vollständigen Datensicherung mit Hilfe der Sicherungsvorlage DemoDataCompl_remote:

dbmcli on DEMODB>backup_start DemoDataCompl_remote

OK

Returncode 0

Date 20061901

Time 00093116

Server GENUA

Database DB7.6

Kernel Version Kernel 7.6.00 Build 018-003-000-000

Pages Transferred 6200

Pages Left 0

Volumes 1

Medianame DemoDataCompl_remote

Location \\PARMA\Backups 2006\Data\completeDataFeb

Errortext

Label DAT_000000003

Is Consistent true

First LOG Page 16212

Last LOG Page

DB Stamp 1 Date 20061901

DB Stamp 1 Time 00093116

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 16667

Devices Used 1

Database ID GENUA:DEMODB_20051014_142158

Max Used Data Page 0

Converter Page Count 13

Ergebnis

Die Daten der lokalen Datenbankinstanz DEMODB wurden auf den entfernten Rechner PARMA im Verzeichnis Backups 2006\Data unter dem Dateinamen completeDataFeb gesichert.


Log automatisch sichern nach Event LOGABOVELIMIT (SAP-Bibliothek - Tutorials)

Vorgehensweisen Log automatisch sichern nach Event LOGABOVELIMIT

Verwendung

Sie können den Event-Mechanismus des Datenbanksystems nutzen, um den Füllungsgrad des Log-Bereichs der Datenbankinstanz zu überwachen.

Mit Hilfe des Database Manager CLI aktivieren Sie zunächst das Event LOGABOVELIMIT, damit es bei einem zu definierenden Füllungsgrad vom Datenbanksystem ausgelöst werden kann. Den Event-Dispatcher konfigurieren Sie so, dass er nach dem Auslösen des Events LOGABOVELIMIT die automatische Log-Sicherung einschaltet. Sie müssen dafür eine Definition für dieses Event in die Konfigurationsdatei des Event-Dispatcher eintragen.

Wenn Sie in dieser Event-Definition Platzhalter verwenden, dann können Sie diese Konfigurationsdatei des Event-Dispatcher für beliebige Datenbankinstanzen, Datenbankrechner und Benutzer verwenden. Wenn Sie den Event-Dispatcher mit einer so definierten Konfigurationsdatei starten, werden die Platzhalter in der Konfigurationsdatei zur Laufzeit vom System durch die entsprechenden Daten ersetzt, die Sie im Start-Kommando eines Event-Dispatcher angeben.

Damit die automatische Log-Sicherung eingeschaltet werden kann, muss eine entsprechende Sicherungsvorlage verfügbar sein, die das Sichern des Log-Bereichs ermöglicht.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink event_set

Siehe auch:

Sicherungsvorlagen definieren

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Utilities, Strukturlink Event-Dispatcher

Szenario

Wenn der Log-Bereich der Datenbankinstanz DEMODB auf dem entfernten Datenbankrechner PARMA den Füllungsgrad von 80% überschreitet, dann soll die Datenbankinstanz das Event LOGABOVELIMIT auslösen. Ein Event-Dispatcher soll daraufhin im Database Manager das DBM-Kommando zum Einschalten der automatischen Log-Sicherung ausführen.

Sie legen für diesen Event-Dispatcher lokal eine Konfigurationsdatei unter dem Pfad C:\test\testconfig.cfg an und tragen darin die entsprechende Event-Definition ein.

Anschließend starten Sie den Event-Dispatcher auf dem Datenbankrechner PARMA.

Sie verfügen über die Sicherungsvorlage DemoFileLog für die Log-Sicherung in eine Datei.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem Rechner PARMA,

Aktivieren des Events LOGABOVELIMIT mit der Priorität HIGH und einem Wert, bei dem die Datenbankinstanz das Event auslösen soll, von 80 %:

>dbmcli -u OLEG,MONDAY -d DEMODB -n PARMA event_set LOGABOVELIMIT HIGH 80

OK

2. Eintragen der Event-Definition in die Konfigurationsdatei testconfig.cfg im lokalen Verzeichnis C:\test unter Verwendung von Platzhaltern:

>dbmevtdisp add C:\test\testconfig.cfg Name == LOGABOVELIMIT Priority == HIGH Value1 == 80 Command == "dbmcli -u $DBMUSERPW$ -d $DBNAME$ –n $SERVERNAME$ autolog_on DemoFileLog"

OK

0

3. Starten des Event-Dispatcher mit den aktuellen Daten für den DBM-Benutzernamen und das Kennwort, den Namen der Datenbankinstanz und den Datenbankrechner:

>dbmevtdisp start C:\test\testconfig.cfg –l C:\test\test.log –u OLEG,MONDAY –d DEMODB –n PARMA

Event Dispatcher instance 1 running

using configuration file C:\test\testconfig.cfg

event with name DISPINFO:DISPSTART not dispatched (count 0)

Ergebnis

Ein Event-Dispatcher mit der ID 1 (instance 1) wurde gestartet.

Er verwendet die Konfigurationsdatei C:\test\testconfig.cfg. In der Event-Definition werden anstelle der Platzhalter $DBMUSERPW$, $DBNAME$ und $SERVERNAME$ die Werte OLEG,MONDAY, DEMODB und PARMA verwendet.

Der Event-Dispatcher überwacht die Datenbankinstanz und protokolliert seine Aktionen in der Protokolldatei C:\test\test.log.

Der Event-Dispatcher löst bei jedem Starten das spezielle Events DISPINFO:DISPSTART aus (Systemvorschlag). Weil Sie dafür keine Event-Definition in die Konfigurationsdatei eingetragen haben, erhalten Sie die Meldung not dispatched.

Um den Event-Dispatcher zu stoppen, öffnen Sie ein neues Fenster für das Command Prompt und führen des Kommando dbmevtdisp stop aus.

Siehe auch:

Utilities, Strukturlink Übersicht der Event-Dispatcher-Kommandos


Event DATABASEFULL über Microsoft Windows Event Viewer anzeigen (SAP-Bibliothek - Tutorials)

Vorgehensweisen Event DATABASEFULL über Microsoft Windows Event Viewer anzeigen

Verwendung

Das Event DATABASEFULL gehört einer Event-Kategorie an, die immer aktiv ist. Das bedeutet, dass es vom Datenbanksystem ausgelöst wird, sobald der Datenbereich voll ist.

Sie müssen nun definieren, wie es vom Event-Dispatcher behandelt werden soll. Dazu tragen Sie eine Event-Definition in die Konfigurationsdatei eines Event-Dispatcher ein und starten den Event-Dispatcher. Sobald das Datenbanksystem das entsprechende Event auslöst, wird es gemäß dieser Event-Definition behandelt.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink event_set

Siehe auch:

Dokumentation des Event-Dispatcher, Strukturlink add

Konzepte des Datenbanksystems, Strukturlink Datenbank-Event-Kategorien

Szenario

Wenn der Datenbereich von DEMODB auf dem lokalen Datenbankrechner voll ist, dann soll ein Event-Dispatcher dafür sorgen, dass das Event DATABASEFULL im Microsoft Windows Event Viewer mit einem MaxDB-Eintrag als Fehler angezeigt wird.

Die Konfigurationsdatei für den Event-Dispatcher soll unter dem Namen testconfig.txt im Verzeichnis C:\test gespeichert werden.

Die Protokolldatei des Event Dispatcher soll im gleichen Verzeichnis unter dem Dateinamen testlog.txt gespeichert werden.

Vorgehensweise

...

1. Konfigurationsdatei für den Event-Dispatcher erstellen und Event-Definition eintragen.

>dbmevtdisp add c:\test\testconfig.txt Name == DATABASEFULL Priority == HIGH Command == "EVENTCREATE /T ERROR /id 100 /L APPLICATION /D \"Database Full\" /SO "MaxDB""

OK

0

2. Starten des Event-Dispatcher

>dbmevtdisp start c:\test\testconfig.txt -l testlog.txt -u DBADMIN,SECRET –d DEMODB

Event Dispatcher instance 1 running

using configuration file c:\test\testconfig.txt

event with name DISPINFO:DISPSTART not dispatched (count 0)

...

Ergebnis

Sobald der Datenbereich von DEMODB voll ist, löst das Datenbanksystem das Event DATABASEFULL aus.

Der Event-Dispatcher ist eingeschaltet und wird das Event gemäß Event-Definition im Microsoft Windows Event Viewer mit dem Type Error, der Source MaxDB und der Description Database Full anzeigen lassen.

Die Ausgabe auf das Kommando dbmevtdisp start wird vom Event-Dispatcher fortlaufend ergänzt:

....

event with name DBFILLINGABOVELIMIT not dispatched (count 3)

event with name DBFILLINGABOVELIMIT not dispatched (count 4)

event with name LOGSEGMENTFULL not dispatched (count 5)

event with name AUTOSAVE not dispatched (count 6)

event with name AUTOSAVE not dispatched (count 7)

event with name DBFILLINGABOVELIMIT not dispatched (count 8)

Event with name DATABASEFULL dispatched (count 9)

…

…


Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Vorgehensweisen Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Verwendung

Um eine Datenbankinstanz wiederherzustellen oder eine Schatteninstanz einzurichten, lesen Sie Sicherungen in eine Datenbankinstanz ein. Bevor Sie Daten- und Log-Sicherungen einlesen können, müssen Sie zunächst ermitteln

● mit welcher Seite Sie das Einlesen beginnen müssen

● in welcher Sicherung diese Seite enthalten ist

● welche Sicherung jeweils als nächste eingelesen werden muss

Sie lassen sich dazu die Restart-Information derjenigen Datenbankinstanz anzeigen, in die die Sicherungen eingelesen werden. Die Restart-Information enthält unter anderem Informationen darüber, welche Log-Seiten im Log-Bereich stehen, d. h. von welcher Seitennummer (First Log Page) bis zu welcher Seitennummer (Used Log Page).

Außerdem lassen Sie sich die Sicherungshistorie derjenigen Datenbankinstanz anzeigen, von der die Sicherungen erstellt wurden.

Der Sicherungshistorie entnehmen Sie unter anderem

● für Datensicherungen die Information, welche Seite beim Wiederherstellen nach dieser Sicherung als nächste eingelesen werden muss

● für Log-Sicherungen die Information, welche Log-Seiten in der jeweiligen Sicherung enthalten sind, d. h. von welcher Seitennummer bis zu welcher Seitennummer

Wie Sie diese Informationen nutzen ist davon abhängig, ob Sie eine Datenbankinstanz wiederherstellen oder eine Schatteninstanz einrichten.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink db_restartinfo, Strukturlink backup_history_open, Strukturlink backup_history_list

Siehe auch:

Wiederherstellen der Datenbankinstanz, Abschnitt "Sicherungsinformationen anzeigen"

Schatteninstanz einrichten und aktualisieren


Wiederherstellen der Datenbankinstanz (SAP-Bibliothek - Tutorials)

Vorgehensweisen Wiederherstellen der Datenbankinstanz

Verwendung

Nach einem Hardware- oder Datenbankfehler stellen Sie die Daten in der betreffenden Datenbankinstanz wieder her, indem Sie die Daten- und gegebenenfalls Log-Sicherungen dieser Datenbankinstanz wieder einlesen.

Sie zeigen zunächst die Sicherungshistorie an und ermitteln, welches die neueste vollständige Datensicherung ist (Siehe: Strukturlink backup_history_open, Strukturlink backup_history_list) und welche inkrementellen Datensicherungen noch danach angefertigt wurden. Werten Sie dazu die Angaben in den Zeilen der Sicherungen aus, aus denen hervorgeht, wann und von welcher bis zu welcher Seite die jeweilige Sicherung angefertigt wurde. Die neuesten Einträge stehen am Ende der Datei.

Als Nächstes lesen Sie die vollständige und danach die inkrementellen Datensicherungen ein (Siehe: Strukturlink recover_start). Nach jeder eingelesenen Datensicherung erhalten Sie angezeigt, welche Seite nach dieser Datensicherung als nächste einzulesen ist.

Nach dem Einlesen der Datensicherungen zeigen Sie die Restart-Information an und ermitteln, ob die Datenbankinstanz restartfähig ist und ab welcher Seite die Log-Einträge im Log-Bereich noch vorhanden sind (Siehe Strukturlink db_restartinfo).

Wenn sich die nach einer Datensicherung als nächste einzulesende Seite noch im Log-Bereich der Datenbankinstanz befindet, müssen Sie nun nur noch die Datenbankinstanz neu starten (Siehe: Strukturlink db_restart). Das System liest die Log-Einträge aus dem Log-Bereich und stellt so den letzten konsistenten Datenbankzustand wieder her. Wenn Sie die Datenbankinstanz nicht vollständig bis zum letzten konsistenten Zustand sondern nur bis zu einem bestimmten früheren Zeitpunkt wiederherstellen wollen, geben Sie diesen Zeitpunkt als Option beim Restart an.

Wenn die nach einer Datensicherung einzulesende Seite kleiner ist, als die kleinste Seitennummer im Log-Bereich, dann ermitteln Sie in der Sicherungshistorie, in welcher Sicherung diese Seite enthalten ist. Lesen Sie die entsprechende Daten- oder Log-Sicherung und fortlaufend chronologisch alle nachfolgend erstellten Sicherungen bis einschließlich jener ein, die mindestens den Vorgänger der kleinsten Seitennummer im Log-Bereich enthält (Siehe: Strukturlink recover_replace). Sobald diese Seite eingelesen wurde, beendet das System das Einlesen der Sicherung und startet die Datenbankinstanz unter Verwendung der noch im Log-Bereich stehenden Einträge (Restart).

Siehe auch:

Einlesen der Log-Sicherungen bis zu einem bestimmten Zeitpunkt

Sie lesen die erste Sicherung mit Hilfe des DBM-Kommandos recover_start ein. Alle folgenden Sicherungen lesen Sie mit dem DBM-Kommando recover_replace ein.

Falls Sie aus irgendeinem Grunde das Einlesen der Sicherungen unterbrechen oder Ihnen bei der Angabe des Folgekommandos ein Fehler unterlaufen sollte, überführt das System die Datenbankinstanz sofort in den Betriebszustand OFFLINE.

Sie müssen dann die Datenbankinstanz erneut in den Betriebszustand ADMIN überführen und die Datenbanksitzung wieder eröffnen. Anschließend führen Sie erneut db_restartinfo aus, um sich davon zu überzeugen, welche der eingelesenen Seiten bereits persistent im Datenbereich abgelegt wurden und welche gegebenenfalls noch einmal eingelesen werden müssen. Fahren Sie in diesem Fall mit dem Einlesen der Sicherungen fort, indem Sie erneut mit recover_start die gemäß Restart-Information vom System erwartete erste Seite und mit recover_replace alle folgenden Sicherungen einlesen.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink recover_start, Strukturlink recover_replace

Siehe auch:

Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen, Strukturlink Datenbankinstanz wiederherstellen

Glossar, Strukturlink Sicherungshistorie

Szenario

Sie wollen die Datenbankinstanz nach einem Hardwarefehler im Datenbereich wiederherstellen.

Für die Simulation dieses Beispiels, muss die Datenbankinstanz über mindestens 2 Data-Volumes verfügen. Sie können alle vorhandenen Volumes mit dem DBM-Kommando Strukturlink param_getvolsall anzeigen. Legen Sie gegebenenfalls ein weiteres Data-Volume mit dem Namen DISKD0002 unter dem Pfad c:\documents and settings\all users\application data\sdb\data\demodb\data an (Siehe: Vergrößern einer Datenbankinstanz, Abschnitt Szenario 3).

Überführen Sie nun DEMODB in den Betriebszustand ADMIN. Simulieren Sie einen Hardwarefehler, indem Sie mittels Betriebssystemkommando das Data-Volume DISKD0002 löschen.

Die Datenbankinstanz befindet sich weiterhin im Betriebszustand ADMIN, alle vorher im Datenbereich vorhandenen Daten sind jedoch verloren. Die Datenbankinstanz muss wiederhergestellt werden.

Vorgehensweise

Im folgenden Beispiel sind die relevanten Werte der Ausgabe fett formatiert, die Interpretation dieser Werte ist als Kommentar gekennzeichnet (#).

Sicherungsinformationen anzeigen

Zeigen Sie zunächst die notwendigen Informationen über die vorhandenen Sicherungen an und werten Sie diese aus.

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als BenutzerOLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>

2. Holen der Sicherungshistorie:

dbmcli on demodb>backup_history_open

OK

3. Anzeigen der Sicherungshistorie :

dbmcli on demodb>backup_history_list

OK

END

…

# Die neuste vollständige Datensicherung ist jene mit dem Label DAT_000000002. Diese muss zuerst eingelesen werden.

# Die nächste Seite muss 9531 sein:

| |

43C7BBD1000B|DAT_000000002|SAVE WARM|2006-01-13 15:40:17|2006-01-13 15:40:17|200

6-01-13 15:40:17|2006-01-13 15:40:17| 9531| |NO |DemoDataCompl

| 384| 1| 0

# Die Seite 9531 ist in dieser Log-Sicherung mit dem Label LOG_000000007 enthalten, damit ist diese unmittelbar nach der vollständigen Datensicherung einzulesen.

# Dabei werden die Seiten 9531 -11828 eingelesen, nächste einzulesende Seite ist die 11829:

| |

43C7BBE5000C|LOG_000000007|SAVE WARM|2006-01-13 15:40:23|2006-01-13 15:40:37|200

6-01-13 15:40:37|2006-01-13 15:40:38| 9531| 11828| |DemoFileLog

| 2096| 1| 0

# Die Seite 11829 ist in dieser Log-Sicherung mit dem Label LOG_000000008 enthalten, damit ist diese unmittelbar nach der Log-Sicherung mit dem Label LOG_000000007 einzulesen.

# Dabei werden die Seiten 11829 - 14182 eingelesen, nächste einzulesende Seite ist die 14183:

| |

43C7BC01000D|LOG_000000008|SAVE WARM|2006-01-13 15:40:42|2006-01-13 15:40:46|200

6-01-13 15:41:05|2006-01-13 15:41:06| 11829| 14182| |DemoFileLog

| 2152| 1| 0

# Die Seite 14183 ist in dieser Log-Sicherung mit dem Label LOG_000000009 enthalten, damit ist diese unmittelbar nach der Log-Sicherung mit dem Label LOG_000000008 einzulesen.

# Dabei werden die Seiten 14183 – 14358 eingelesen, nächste einzulesende Seite ist die 14359:

| |

43C7BC01000D|LOG_000000009|SAVE WARM|2006-01-13 15:40:46|2006-01-13 15:41:05|200

6-01-13 15:41:06|2006-01-13 15:41:07| 14183| 14358| |DemoFileLog

| 176| 1| 0

# Die Seite 14359 ist in dieser Log-Sicherung mit dem Label LOG_000000010 enthalten, damit ist diese unmittelbar nach der Log-Sicherung mit dem Label LOG_000000009 einzulesen.

# Dabei werden die Seiten 14359 - 16712 eingelesen, nächste einzulesende Seite ist die 16713.

| |

43C7BC24000E|LOG_000000010|SAVE WARM|2006-01-13 15:41:17|2006-01-13 15:41:21|200

6-01-13 15:41:40|2006-01-13 15:41:42| 14359| 16712| |DemoFileLog

| 2152| 1| 0

# Nachfolgend müssen chronologisch alle Log-Sicherungen einschließlich der mit dem Label LOG_000000013 eingelesen werden.

| |

43C7BC24000E|LOG_000000011|SAVE WARM|2006-01-13 15:41:21|2006-01-13 15:41:25|200

6-01-13 15:41:42|2006-01-13 15:41:43| 16713| 19065| |DemoFileLog

| 2152| 1| 0

| |

43C7BC24000E|LOG_000000012|SAVE WARM|2006-01-13 15:41:25|2006-01-13 15:41:40|200

6-01-13 15:41:43|2006-01-13 15:41:43| 19066| 19770| |DemoFileLog

| 656| 1| 0

# Die Log-Sicherung mit dem Label LOG_000000013 enthält die Seiten 19771 bis 22124 und damit den Vorgänger der in der Restart-Information ausgewiesen ersten Seite im Log-Bereich (21452).

# Das System wird beim Wiederherstellen diese Log-Sicherung vollständig einlesen. Die nachfolgenden Log-Sicherungen brauchen nicht mehr eingelesen zu werden, da die darin enthaltenen Seiten noch im Log-Bereich stehen und vom System aus dem Log-Bereich wiederhergestellt werden können.

| |

43C7C497000F|LOG_000000013|SAVE WARM|2006-01-13 16:17:14|2006-01-13 16:17:17|200

6-01-13 16:17:43|2006-01-13 16:17:45| 19771| 22124| |DemoFileLog

| 2152| 1| 0

| |

43C7C497000F|LOG_000000014|SAVE WARM|2006-01-13 16:17:17|2006-01-13 16:17:22|200

6-01-13 16:17:45|2006-01-13 16:17:46| 22125| 24478| |DemoFileLog

| 2152| 1| 0

| |

43C7C497000F|LOG_000000015|SAVE WARM|2006-01-13 16:17:22|2006-01-13 16:17:43|200

6-01-13 16:17:46|2006-01-13 16:17:48| 24479| 26748| |DemoFileLog

| 2080| 1| 0

| |

43C7C5240010|LOG_000000016|SAVE WARM|2006-01-13 16:17:45|2006-01-13 16:20:04|200

6-01-13 16:20:04|2006-01-13 16:20:05| 26749| 28510| |DemoFileLog

| 1616| 1| 0

| |

Daten und Log-Einträge wiederherstellen

Sie verfügen nun über die Informationen zu den Sicherungen und können DEMODB wiederherstellen.

...

1. Überführen der Datenbankinstanz in den Betriebszustand ADMIN:

dbmcli on demodb>db_admin

OK

2. Aufbau einer Datenbanksitzung:

dbmcli on demodb>db_connect

OK

3. Einlesen der letzten vollständigen Datensicherung:

dbmcli on demodb>recover_start DemoDataCompl

OK

Returncode 0

Date 20060117

Time 00114627

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 384

Pages Left 0

Volumes 1

Medianame DemoDataCompl

Location Backups 2005\data\completeDataJan

Errortext

Label DAT_000000002

Is Consistent true

First LOG Page 9531

# Nach der vollständigen Datensicherung erwartet das System die Log-Seite mit der Nummer 9531.

Last LOG Page

DB Stamp 1 Date 20060113

DB Stamp 1 Time 00154017

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 362

Devices Used 1

Database ID GENUA:DEMODB_20060113_153806

Max Used Data Page 0

4. Anzeigen der Restart-Information:

dbmcli on demodb>db_restartinfo

OK

Used LOG Page 28513

First LOG Page 21452

# Der Log-Bereich enthält noch alle Seiten der Nummern 21452 bis 28513. Für einen Restart der Datenbankinstanz müssen somit noch die Seiten 9531 bis 21451 aus Sicherungen eingelesen werden.

Restartable 1

# Die Datenbankinstanz ist restartfähig, d.h. der Log-Bereich ist unbeschädigt.

Id Restart Record GENUA:DEMODB_20060113_153806

Id LOG Info GENUA:DEMODB_20060113_153806

Consistent 1

5. Einlesen der Log-Sicherungen

a. Einlesen der Log-Sicherung mit dem Label LOG_000000007:

dbmcli on demodb>recover_start DemoFileLog LOG 007

OK

Returncode -8020

# Der Rückgabewert -8020 weist aus, dass die chronologisch nächste Sicherung mit Hilfe des Folgekommandos recover_replace eingelesen werden muss.

Date 20060117

Time 00143406

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 2096

Pages Left 0

Volumes 1

Medianame DemoFileLog

Location Backups 2005\data\logBackup.007

Errortext

Label LOG_000000007

Is Consistent

First LOG Page 9531

Last LOG Page 11828

DB Stamp 1 Date 20060113

DB Stamp 1 Time 00154023

DB Stamp 2 Date 20060113

DB Stamp 2 Time 00154037

Page Count 2297

Devices Used 1

Database ID GENUA:DEMODB_20060113_153806

Max Used Data Page

b. Einlesen der Log-Sicherung mit dem Label LOG_000000008 mit Hilfe des Folgekommandos recover_replace:

dbmcli on demodb>recover_replace DemoFileLog "C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup" 008

OK

Returncode -8020

Date 20060117

Time 00143406

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 2152

Pages Left 0

Volumes 1

Medianame DemoFileLog

Location C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.008

Errortext

Label LOG_000000008

Is Consistent

First LOG Page 11829

Last LOG Page 14182

DB Stamp 1 Date 20060113

DB Stamp 1 Time 00154042

DB Stamp 2 Date 20060113

DB Stamp 2 Time 00154046

Page Count 2353

Devices Used 1

Database ID GENUA:DEMODB_20060113_153806

Max Used Data Page

c. Einlesen der Log-Sicherung mit dem Label LOG_000000009 mit Hilfe des Folgekommandos recover_replace:

dbmcli on demodb>recover_replace DemoFileLog "C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup" 009

OK

Returncode -8020

Date 20060117

Time 00143406

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 176

Pages Left 0

Volumes 1

Medianame DemoFileLog

Location C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.009

Errortext

Label LOG_000000009

Is Consistent

First LOG Page 14183

Last LOG Page 14358

DB Stamp 1 Date 20060113

DB Stamp 1 Time 00154046

DB Stamp 2 Date 20060113

DB Stamp 2 Time 00154105

Page Count 175

Devices Used 1

Database ID GENUA:DEMODB_20060113_153806

Max Used Data Page

d. bis g: Einlesen der übrigen Log-Sicherungen mit den Labels LOG_000000010 - LOG_000000013 mit Hilfe des Folgekommandos recover_replace (siehe Abschnitte a – c).

# Wenn die letzte notwendige Log-Sicherung eingelesen ist und das Datenbanksystem damit über alle Seiten verfügt, deren Nummer kleiner als die erste Seite im Log-Bereich ist, dann liest es die übrigen Seiten selbsttätig aus dem Log-Bereich ein und überführt die Datenbankinstanz am Schluss in den Betriebszustand ONLINE.

Ergebnis

Die Datenbankinstanz DEMODB wurde wiederhergestellt, das manuell gelöschte Data-Volume wurde entsprechend der Informationen in der Datenbankparameterdatei wiederhergestellt und befindet sich an der ursprünglichen Stelle auf Ihrer Festplatte.

Alle vor dem Hardwarefehler im Daten- und Log-Bereich vorhandenen Seiten sind wieder in der Datenbankinstanz und Sie können darauf zugreifen.

Die Datenbankinstanz ist betriebsbereit und befindet sich im Betriebszustand ONLINE.


Einlesen der Log-Sicherungen bis zu einem bestimmten Zeitpunkt (Wiederherstellen)

Vorgehensweisen Einlesen der Log-Sicherungen bis zu einem bestimmten Zeitpunkt (Wiederherstellen)

Verwendung

Wenn Sie die Datenbankinstanz nicht vollständig bis zum letzten konsistenten Zustand, sondern nur bis zu einem bestimmten früheren Zeitpunkt wiederherstellen wollen, geben Sie diesen Zeitpunkt als Option beim Einlesen der Log-Sicherungen an.

Das System liest die Sicherung ein und fordert sie auf, den nächsten Datenträger anzugeben. Dieser Vorgang wiederholt sich so oft, bis jene Seite eingelesen wurde, die dem angegebenen Zeitpunkt entspricht. Dann beendet das System das Einlesen der Sicherung und startet die Datenbankinstanz (Restart).

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink recover_start, Strukturlink recover_replace

Siehe auch:

Wiederherstellen der Datenbankinstanz

Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Konzepte des Datenbanksystems, Strukturlink Datenbankinstanz wiederherstellen

Szenario

Sie wollen die Datenbankinstanz DEMODB in einem konsistenten Zustand bis zu jenen Daten wiederherstellen, die am 02.02.2006 bis um 16:36:00 Uhr in der Datenbankinstanz gespeichert waren. Anhand der Sicherungshistorie haben Sie ermittelt, dass dieser Zeitpunkt innerhalb der Log-Sicherung logBackup.011 gespeichert sein muss.

Sie haben die aktuellste vollständige Datensicherung eingelesen. Sie befinden sich noch in derselben Datenbanksitzung.

Die nächste einzulesende Seite ist gemäß Sicherungshistorie in der Log-Sicherung logBackup.009 enthalten.

Vorgehensweise

Im folgenden Beispiel sind die relevanten Werte der Ausgabe fett formatiert, die Interpretation dieser Werte ist als Kommentar gekennzeichnet (#).

1. Starten des Einlesens der Log-Sicherungen mit dem Datenträger logBackup.009. Es sollen die Log-Einträge bis zum 02.02.2006 bis um 16:36:00 eingelesen werden:

dbmcli on DEMODB>recover_start DemoFileLog LOG 009 UNTIL 20060202 163600

OK

Returncode -8020

# Der angegebene Datenträger wurde eingelesen. Der Rückgabewert -8020 fordert Sie auf, den nächstfolgenden Datenträger anzugeben.

Date 20060203

Time 00134353

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 1168

Pages Left 0

Volumes 1

Medianame LogBackupFile

Location C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.009

Errortext

Label LOG_000000009

Is Consistent

First LOG Page 17187

Last LOG Page 18452

DB Stamp 1 Date 20060202

DB Stamp 1 Time 00093758

DB Stamp 2 Date 20060202

DB Stamp 2 Time 00093819

Page Count 1265

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

--

1. Einlesens der Log-Sicherungen mit dem nächsten Datenträger fortsetzen:

dbmcli on DEMODB>recover_replace LogBackupFile "C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup" 010

OK

Returncode -8020

# Der angegebene Datenträger wurde eingelesen. Der Rückgabewert -8020 fordert Sie auf, den nächstfolgenden Datenträger anzugeben.

Date 20060203

Time 00134353

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 2032

Pages Left 0

Volumes 1

Medianame LogBackupFile

Location C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.010

Errortext

Label LOG_000000010

Is Consistent

First LOG Page 18453

Last LOG Page 20670

DB Stamp 1 Date 20060202

DB Stamp 1 Time 00163233

DB Stamp 2 Date 20060202

DB Stamp 2 Time 00163447

Page Count 2217

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

---

2. Einlesens der Log-Sicherungen mit dem nächsten Datenträger fortsetzen:

dbmcli on DEMODB>recover_replace LogBackupFile "\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup" 011

OK

Returncode 0

# Der angegebene Datenträger wurde eingelesen. Der Rückgabewert 0 weist aus, dass alle Log-Einträge, die bis zum angegebenen Zeitpunkt geschrieben worden waren, eingelesen wurden.

Date 20060203

Time 00134353

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 1280

Pages Left 0

Volumes 1

Medianame LogBackupFile

Location C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups.011

Errortext

Label LOG_000000011

Is Consistent

First LOG Page 20671

Last LOG Page 23024

DB Stamp 1 Date 20060202

DB Stamp 1 Time 00163601

DB Stamp 2 Date 20060202

DB Stamp 2 Time 00163604

Page Count 2353

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

---

dbmcli on DEMODB>

Ergebnis

Das System hat die Log-Sicherungen bis zum angegebenen Zeitpunkt eingelesen und anschließend die Datenbankinstanz in den Betriebszustand ONLINE überführt.


Datenbankkopie erstellen (Datensicherung in eine andere Datenbankinstanz einlesen)

Vorgehensweisen Datenbankkopie erstellen (Datensicherung in eine andere Datenbankinstanz einlesen)

Verwendung

Sie legen eine Kopie einer Datenbankinstanz an, indem Sie eine vollständige Datensicherung dieser Datenbankinstanz (Quelldatenbank) in eine andere Datenbankinstanz (Zieldatenbank) einlesen. Die Zieldatenbank kann bereits existieren. Sie können auch eine neue Datenbankinstanz als Zieldatenbank anlegen.

Die Datenbankparameter der Zieldatenbank müssen nicht zwingend mit denen der Quelldatenbank übereinstimmen. Wir empfehlen es Ihnen jedoch für den Fall, dass Sie die Datenbankkopie für eine Schatteninstanz erstellen. Unabdingbar ist es jedoch, dass der Datenbereich der Zieldatenbank ausreichend groß konfiguriert wurde, damit die Datensicherung der Quelldatenbank eingelesen werden kann.

Da die Datenbank-IDs von Datensicherung und Zieldatenbank verschieden sind, müssen Sie die Zieldatenbank beim Einlesen der Sicherung initialisieren. Dabei werden alle Kataloginformationen und Anwendungsdaten sowie die Einträge im Log-Bereich der Zieldatenbank gelöscht.

Sie erstellen zunächst eine vollständige Datensicherung der Quelldatenbank. Anschließend melden Sie sich als DBM-Benutzer an die Zieldatenbank an und definieren eine Sicherungsvorlage für eine vollständige Datensicherung für die Zieldatenbank. Dabei müssen die für die Eigenschaften Typ, Sicherungsart, Größenbeschränkung, Blockgröße und überschreibbar definierten Werte mit den Werten derjenigen Sicherungsvorlage identisch sein, die für das Erstellen der Sicherung der Quelldatenbank verwendet wurde. Der Name der Sicherungsvorlage ist frei wählbar, die Eigenschaft Datenträger (device/file) muss auf den Ort verweisen, an dem die vollständige Datensicherung der Quelldatenbank gespeichert wurde.

Sie überführen nun die Zieldatenbank in den Betriebszustand ADMIN und eröffnen mit dieser Datenbankinstanz eine Datenbanksitzung. Anschließend lesen Sie mit Hilfe der neu definierten Sicherungsvorlage die Datensicherung aus der Quelldatenbank in die Zieldatenbank ein und initialisieren dabei die Zieldatenbank. Sie verwenden dazu das DBM-Kommando db_activate RECOVER.

Zum Abschluss überführen Sie die Zieldatenbank in den Betriebszustand ONLINE und laden die Systemtabellen. Dazu müssen Sie die Daten des Datenbanksystemadministrators der Quelldatenbank angeben.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink medium_put, Strukturlink backup_start, Strukturlink db_activate RECOVER

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Parameterdatei einer anderen Datenbankinstanz verwenden

Sicherungsvorlage für die vollständige Datensicherung in eine Datei definieren

Sichern

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen, Strukturlink Datenbankkopie

Szenario

Sie haben eine Datenbankinstanz DEMODB und wollen von dieser eine Datenbankkopie in der Datenbankinstanz TESTDB erzeugen. Die Datenbankinstanzen liegen auf verschiedenen, aber kompatiblen Rechnern. Sie wurden mit der gleichen Version der Datenbanksoftware erzeugt. Die Datenbankparameter von TESTDB wurden mit den gleichen Werten definiert wie die von DEMODB.

Informationen zu DEMODB:

Datenbankrechner: GENUA

DBM-Benutzer: Benutzername OLEG, Kennwort MONDAY

Datenbanksystemadministrator: Benutzername DBADMIN, Kennwort SECRET

Informationen zu TESTDB:

Datenbankrechner: lokal, Name PARMA

DBM-Benutzer: Benutzername ELENA, Kennwort SUNDAY

Datenbanksystemadministrator: Benutzername SUPER, Kennwort MAX

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Sicherungsvorlage für eine vollständige Datensicherung in eine Datei mit folgenden Eigenschaften definieren:

Name der Sicherungsvorlage: DemoDataCompl
Datenträger (device/file): Backups 2005\Data\completeDataJan
Typ: Datei (File)
Sicherungsart: vollständige Datensicherung (DATA)
Größenbeschränkung: keine (0)
Blockgröße: 6
überschreibbar: nein (NO)

dbmcli on DEMODB>medium_put DemoDataCompl "Backups 2005\Data\completeDataJan" FILE DATA 0 6 NO

OK

3. Vollständige Datensicherung von DEMODB unter Verwendung der Sicherungsvorlage DemoDataCompl durchführen:

dbmcli on DEMODB>db_connect

OK

dbmcli on DEMODB>backup_start DemoDataCompl

OK

...

...

4. Database Manager CLI beenden:

dbmcli on DEMODB>exit

5. Aufrufen des Database Manager CLI, Anmelden als Benutzer ELENA mit dem Kennwort SUNDAY, Herstellen der Verbindung zur Datenbankinstanz TESTDB:

>dbmcli –u ELENA,SUNDAY –d TESTDB

dbmcli on TESTDB>

6. Sicherungsvorlage für eine vollständige Datensicherung in eine Datei mit folgenden Eigenschaften definieren:

Name der Sicherungsvorlage: DemoDataCompl_recover

Datenträger (device/file): \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\completeDataJan

Typ: Datei (File)

Sicherungsart: vollständige Datensicherung (DATA)

Größenbeschränkung: keine (0)

Blockgröße: 6

überschreibbar: nein (NO)

dbmcli on TESTDB>medium_put DemoDataCompl_recover "\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\completeDataJan" FILE DATA 0 6 NO

OK

7. Überführen der Datenbankinstanz in den Betriebszustand ADMIN:

dbmcli on TESTDB>db_admin

OK

8. Eröffnen einer Datenbanksitzung:

dbmcli on TESTDB>db_connect

OK

9. Einlesen der vollständigen Datensicherung von DEMODB in TESTDB (mit Initialisierung von TESTDB) unter Verwendung der für TESTDB erstellten Sicherungsvorlage DemoDataCompl_recover:

dbmcli on TESTDB>db_activate RECOVER DemoDataCompl_recover

OK

Returncode 0

Date 20060126

Time 00142843

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 6376

Pages Left 0

Volumes 1

Medianame DemoDataCompl_recover

Location C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\completeDataJan

Errortext

Label DAT_000000008

Is Consistent true

First LOG Page 3146

Last LOG Page

DB Stamp 1 Date 20060126

DB Stamp 1 Time 00113848

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 6354

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page 0

10. Überführen der Datenbankinstanz in den Betriebszustand ONLINE.

dbmcli on TESTDB>db_online

OK

11. Laden der Systemtabellen unter Angabe des Datenbanksystemadministrators von DEMODB:

dbmcli on TESTDB>load_systab –u DBADMIN,SECRET

OK

0,OK: everything works fine

0,""C:\Program Files\sdb\TESTDB\bin\x_python" "C:\Program Files\sdb\TESTDB\env\systab.py" -R "C:\Program Files\sdb\TESTDB" -d TESTDB -u dbadmin,*"

Removing obsolete objects

Installing Loader tables

Installing messages and help

Installing SYSDBA tables

Installing comments for SYSDBA tables

Installing precompiler tables

Installing system tables for R3 backup information

Installing ODBC tables

Installing system tables for ORACLE (V7) mode

Installing data dictionary tables and views

Installing synonyms for oracle system tables

Installing comments on oracle sytem tables

Installing tables for WebAgent

Installing tables for Repository

Installing DOMAIN tables

Installing comments for DOMAIN tables

Installing Views as replacement for SHOWs

Installing Database Manager tables

Installing SYSINFO tables

Installing comments for SYSINFO tables

Installing support for UDE (User Defined Extensions)

Installing tables for JDBC Database Metadata

Installing tables for SQLDBC Database Metadata

Installing additional triggers

==================================

Installation successfully finished

==================================

---

dbmcli on TESTDB>

12. Beenden des Database Manager CLI:

dbmcli on testdb>exit

OK

Ergebnis

Die Datenbankinstanz TESTDB auf dem Rechner PARMA enthält nun die Daten aus der vollständigen Datensicherung von DEMODB auf dem Rechner GENUA.

TESTDB befindet sich im Betriebszustand ONLINE.

Der ursprüngliche Datenbanksystemadministrator sowie die übrigen Datenbankbenutzer von TESTDB wurden mit den Daten des für DEMODB gültigen Datenbanksystemadministrators sowie der übrigen Datenbankbenutzer von DEMODB überschrieben. Nur diese Benutzer haben noch Zugriff auf die Datenbankinstanz.

Die ursprünglichen DBM-Benutzer von TESTDB sind weiterhin gültig und können mittels Database Manager die Datenbankinstanz TESTDB verwalten.


Schatteninstanz einrichten und aktualisieren (SAP-Bibliothek - Tutorials)

Vorgehensweisen Schatteninstanz einrichten und aktualisieren

Verwendung

Um eine Schatteninstanz zu erzeugen, lesen Sie zunächst eine vollständige Datensicherung und dann fortlaufend alle Log-Sicherungen einer Datenbankinstanz (Originalinstanz) in eine andere Datenbankinstanz (Schatteninstanz) ein. Die Originalinstanz muss für das Einrichten der Schatteninstanz nicht gestoppt werden. Sie kann ohne Unterbrechung weiterbetrieben werden. Aus Sicherheitsgründen liegen Original- und Schatteninstanz auf verschiedenen Datenbankrechnern.

Zunächst legen Sie eine neue Datenbankinstanz an, die als Schatteninstanz eingerichtet werden soll.

Für diese Schatteninstanz definieren Sie eine Sicherungsvorlage für eine vollständige Datensicherung und eine Sicherungsvorlage für eine Log-Sicherung. Bei beiden Vorlagen müssen die für die Eigenschaften Typ, Sicherungsart, Größenbeschränkung, Blockgröße und überschreibbar definierten Werte identisch sein mit den Werten der Sicherungsvorlage, die für das Erstellen der Sicherungen der Originalinstanz verwendet werden. Der Name der Sicherungsvorlage ist frei wählbar, die Eigenschaft Datenträger (device/file) muss auf den Ort verweisen, an dem die vollständige Datensicherung bzw. die Log-Sicherungen der Originalinstanz gespeichert sind.

Nun lesen Sie die vollständige Datensicherung in die Schatteninstanz ein und initialisieren sie dabei.

Anschließend kann das regelmäßige Einlesen der Log-Sicherungen erfolgen. Wir empfehlen Ihnen, diesen Vorgang mit Hilfe von Skripten zur automatisieren. Sie können die Log-Sicherungen aber auch manuell einlesen.

Welche Sicherung als nächste einzulesen ist, entnehmen Sie den Daten der Restart-Information und der Sicherungshistorie.

Wenn Sie die Datenbankinstanz irgendwann nach dem Initialisieren beim Einlesen der Datensicherung versehentlich in den Betriebszustand ONLINE überführt haben, müssen Sie das Einlesen der vollständigen Datensicherung mit Initialisierung wiederholen.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink db_activate RECOVER, Strukturlink recover_start, Strukturlink recover_replace

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Sicherungsvorlagen definieren

Datenbankkopie erstellen (Datensicherung in einer andere Datenbankinstanz einlesen)

Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Konzepte des Datenbanksystems, Strukturlink Schattendatenbank

Szenario

Sie wollen eine Schatteninstanz TESTDB zu Ihrer Datenbankinstanz DEMODB erzeugen. Sie haben eine vollständige Datensicherung von DEMODB unter Verwendung einer Sicherungsvorlage mit folgenden Eigenschaften erstellt:
Namen: DemoDataCompl
Datenträger (device/file): Backups 2005\Data\completeDataJan
Typ: Datei
Sicherungsart: vollständige Datensicherung (DATA)
Größenbeschränkung: keine (0)
Blockgröße: 6
überschreibbar: nein (NO)

Sie sichern kontinuierlich die Log-Einträge von DEMODB unter Verwendung der Sicherungsvorlage DemoFileLog mit folgenden Eigenschaften:
Datenträger (device/file):Backups 2005\Data\logBackup
Typ: Datei
Sicherungsart: automatische Log-Sicherung (AUTO)
keine Größenbeschränkung

Der Sicherungshistorie entnehmen Sie, dass nach der Datensicherung die Log-Seite mit der Nummer 37746 einzulesen ist und dass diese Log-Seite in der Log-Sicherung mit der Versionsnummer 018 enthalten sein muss.

DEMODB liegt auf dem Rechner GENUA. TESTDB soll auf dem lokalen Rechner angelegt werden. GENUA und der lokale Rechner sind kompatibel.

Vorgehensweise

...

1. Anlegen der neuen Datenbankinstanz TESTDB:

Verwenden Sie die gleiche Version der Datenbanksoftware, die Sie für das Anlegen von DEMODB verwendet haben. Konfigurieren Sie TESTDB mit den gleichen Parameterwerten wie DEMODB.

Siehe: Anlegen und Konfigurieren einer Datenbankinstanz

2. Aufrufen des Database Manager CLI im Sitzungsmodus, anmelden als DBM-Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz TESTDB.

>dbmcli –u DBM,DBM –d TESTDB

dbmcli on TESTDB>

3. Definieren einer Sicherungsvorlage für eine vollständige Datensicherung:

Definieren Sie für diese Sicherungsvorlage die gleichen Eigenschaften wie für die Sicherungsvorlage, mit der die vollständige Datensicherung von DEMODB erstellt wurde. Eine Ausnahme ist die Eigenschaft Datenträger (device/file). Hier muss der Pfad auf den Ort verweisen, an dem die vollständige Datensicherung von DEMODB gespeichert ist:

Name der Sicherungsvorlage: DataSave
Datenträger (device/file): \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\completeDataJan
Typ: Datei (File)
Sicherungsart: vollständige Datensicherung (DATA)
Größenbeschränkung: keine (0)
Blockgröße: 6
überschreibbar: nein (NO)

dbmcli on TESTDB>medium_put DataSave "\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\completeDataJan" FILE DATA 0 6 NO

4. Definieren einer Sicherungsvorlage für eine Log-Sicherung:

Definieren Sie für diese Sicherungsvorlage die gleichen Eigenschaften, wie für die Sicherungsvorlage, mit der die Log-Sicherungen von DEMODB erstellt werden. Eine Ausnahme ist die Eigenschaft Datenträger (device/file). Hier muss der Pfad auf den Ort verweisen, an dem die Dateien der Log-Sicherungen gespeichert sind:

Name der Sicherungsvorlage: LogSave
Datenträger (device/file):\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup
Typ: Datei (File)
Sicherungsart: Log-Sicherung (LOG)
Größenbeschränkung: keine (0)
Blockgröße: 6
überschreibbar: nein (NO)

dbmcli on TESTDB>medium_put LogSave "\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup" FILE LOG 0

5. Überführen von TESTDB in den Betriebszustand ADMIN:

dbmcli on TESTDB>db_admin

OK

6. Eröffnen einer Datenbanksitzung:

dbmcli on TESTDB>db_connect

OK

7. Einlesen der vollständigen Datensicherung von DEMODB mit Initialisierung von TESTDB:

dbmcli on TESTDB>db_activate RECOVER DataSave

OK

Returncode 0

Date 20060309

Time 00100407

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 13632

Pages Left 0

Volumes 1

Medianame datasave

Location \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\completeDataMay

Errortext

Label DAT_000000017

Is Consistent true

First LOG Page 37746

Last LOG Page

DB Stamp 1 Date 20060308

DB Stamp 1 Time 00160527

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 13610

Devices Used 1

Database ID PARMA:DEMODB_20060125_165646

Max Used Data Page 0

8. Einlesen der Log-Sicherungen starten.

dbmcli on TESTDB>recover_start LogSave 018

OK

Returncode -8020

Date 20060309

Time 00100728

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 1000

Pages Left 0

Volumes 1

Medianame logsave

Location \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.018

Errortext

Label LOG_000000018

Is Consistent

First LOG Page 35382

Last LOG Page 37747

DB Stamp 1 Date 20060208

DB Stamp 1 Time 00110215

DB Stamp 2 Date 20060308

DB Stamp 2 Time 00160655

Page Count 2365

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

9. Einlesen der nächsten Log-Sicherung starten:

dbmcli on TESTDB>recover_replace LogSave "\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.019"

OK

Returncode -8020

Date 20060309

Time 00100728

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 2152

Pages Left 0

Volumes 1

Medianame logsave

Location \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.019

Errortext

Label LOG_000000019

Is Consistent

First LOG Page 37748

Last LOG Page 40013

DB Stamp 1 Date 20060308

DB Stamp 1 Time 00160725

DB Stamp 2 Date 20060308

DB Stamp 2 Time 00160758

Page Count 2265

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

10. Einlesen der nächsten Log-Sicherung starten:

dbmcli on testdb1>recover_replace LogSave "\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.020"

OK

Returncode -8020

Date 20060309

Time 00100728

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 704

Pages Left 0

Volumes 1

Medianame logsave

Location \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackup.020

Errortext

Label LOG_000000020

Is Consistent

First LOG Page 40014

Last LOG Page 40772

DB Stamp 1 Date 20060308

DB Stamp 1 Time 00160758

DB Stamp 2 Date 20060308

DB Stamp 2 Time 00163132

Page Count 758

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

...

...

Ergebnis

Die Schatteninstanz TESTDB für die Originalinstanz DEMODB wurde eingerichtet.

Der erste DBM-Benutzer für TESTDB hat den Benutzernamen DBM und das Kennwort DBM. Der Datenbanksystemadministrator von TESTDB hat den Benutzernamen DBADMIN und das Kennwort SECRET.

DEMODB befindet sich weiterhin im Betriebszustand ONLINE.

TESTDB muss bis zur Inbetriebnahme als aktive Instanz im Betriebszustand ADMIN bleiben.

Der Datenbestand von DEMODB wurde in TESTDB kopiert. Um TESTDB als Schatteninstanz von DEMODB zu betreiben, müssen Sie nun kontinuierlich alle weiteren Log-Sicherungen von DEMODB in TESTDB einlesen. Sie können die weiteren Log-Sicherungen wie oben beschrieben einlesen oder das Einlesen mit Hilfe eines Skripts automatisieren.

Im Bedarfsfall kann TESTDB jederzeit als aktive Instanz in Betrieb genommen werden.

Siehe auch:

Schatteninstanz als aktive Instanz in Betrieb nehmen


Schatteninstanz als aktive Instanz in Betrieb nehmen (SAP-Bibliothek - Tutorials)

Vorgehensweisen Schatteninstanz als aktive Instanz in Betrieb nehmen

Verwendung

Sie können die Schatteninstanz sowohl mit dem aktuellen Datenbestand der Originalinstanz in Betrieb nehmen als auch mit dem Datenbestand der Originalinstanz zu einem bestimmten Zeitpunkt in der Vergangenheit.

Um die Schatteninstanz mit dem aktuellen Datenbestand der Originalinstanz in Betrieb zu nehmen, stoppen Sie die Originalinstanz, führen eine letzte Log-Sicherung in der Originalinstanz durch, lesen diese Log-Sicherung in die Schatteninstanz ein und starten anschließend die Schatteninstanz.

Sie können die Schatteninstanz mit dem Datenbestand der Originalinstanz nur dann zu einem bestimmten Zeitpunkt in der Vergangenheit in Betrieb nehmen, wenn bisher nur Log-Sicherungen in die Schatteninstanz eingelesen wurden, deren Inhalt vor diesem gewünschten Zeitpunkt liegt.

Sie geben dazu beim Einlesen der Log-Sicherungen den gewünschten Zeitpunkt an, bis zu dem das System die Log-Einträge einlesen soll. Wenn Sie die Log-Sicherungen aus der Originalinstanz automatisch in die Schatteninstanz einlesen lassen, brechen Sie zunächst das automatische Einlesen ab. Anschließend starten Sie das Einlesen der Log-Sicherungen erneut und geben dabei den gewünschten Zeitpunkt an, bis zu dem das System die Log-Einträge einlesen soll.

Das System liest die Log-Einträge ein und fordert Sie auf, den jeweils nächsten Datenträger anzugeben, bis es zu jenen Log-Einträgen gelangt, die zum angegeben Zeitpunkt geschrieben wurden. Hier bricht es das Einlesen der Log-Einträge endgültig ab und überführt die Datenbankinstanz in den Betriebszustand ONLINE.

Wenn es nach einem Problem mit der Originalinstanz nicht mehr möglich ist, eine letzte Log-Sicherung der Originalinstanz durchzuführen, die Log-Volumes der Originalinstanz jedoch unbeschädigt sind, dann können Sie deren Inhalt auch mit Betriebssystemkommandos in die Log-Volumes der Schatteninstanz kopieren.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink recover_cancel, Strukturlink recover_start, Strukturlink recover_replace

Siehe auch:

Schatteninstanz einrichten und aktualisieren

Log-Volumes mit Betriebssystemmitteln kopieren

Konzepte des Datenbanksystems, Strukturlink Schattendatenbank

Szenario

Sie verfügen auf Ihrem lokalen Rechner über eine Schatteninstanz mit dem Namen TESTDB für die Datenbankinstanz DEMODB auf dem Rechner GENUA. Über ein Skript werden die von DEMODB erstellten Log-Sicherungen mit einer definierten Zeitverzögerung automatisch in TESTDB eingelesen.

Am 02. Februar 2006 um 16:36:10 gab es in DEMODB einen Hardwarefehler im Datenbereich. Sie beschließen deshalb, die Schatteninstanz TESTDB bis zum Zeitpunkt 02. Februar 2006 um 16:36:00 Uhr wiederherzustellen und in Betrieb zu nehmen.

Vorgehensweise

In den nachfolgenden Erläuterungen sind die relevanten Interpretationen in die Ausgabe eingefügt, fett formatiert und als Kommentare gekennzeichnet (#)

...

1. Der erste Schritt hängt davon ab, ob Sie die Log-Sicherungen bisher automatisch oder manuell in TESTDB einlesen.

○ Wenn Sie die Log-Sicherungen aus der Originalinstanz DEMODB automatisch in die Schatteninstanz TESTDB einlesen lassen, dann brechen Sie diesen Vorgang jetzt ab:
dbmcli on TESTDB>recover_cancel

OK

Returncode 0

Date

Time

Server

Database

Kernel Version

Pages Transferred 0

Pages Left 0

Volumes

Medianame

Location

Errortext

Label

Is Consistent

First LOG Page

Last LOG Page

DB Stamp 1 Date

DB Stamp 1 Time

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 0

Devices Used

Database ID

Max Used Data Page

----

dbmcli on TESTDB>

Anschließend überführen Sie TESTDB in den Betriebszustand ADMIN:

dbmcli on TESTDB>db_admin

OK

○ Wenn Sie die Log-Sicherungen von DEMODB manuell in TESTDB eingelesen haben, rufen Sie zunächst den Database Manager CLI im Sitzungsmodus auf, melden sich als Benutzer DBM mit dem Kennwort DBM an und stellen die Verbindung zur Schattensinstanz TESTDB her:

>dbmcli –u DBM,DBM –d TESTDB

dbmcli on TESTDB>

2. Eröffnen Sie eine Datenbanksitzung:

dbmcli on TESTDB>db_connect

OK

3. Starten Sie das Einlesen der noch fehlenden Log-Sicherungen bis zu dem gewünschten Zeitpunkt:

dbmcli on TESTDB>recover_start LogSave LOG 009 UNTIL 20060202 163600

OK

Returncode -8020

# Der angegebene Datenträger wurde eingelesen. Der Rückgabewert -8020 fordert sie auf, den nächstfolgenden Datenträger anzugeben.

Date 20060203

Time 00134353

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 1168

Pages Left 0

Volumes 1

Medianame LogBackupFile

Location \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackupFeb.009

Errortext

Label LOG_000000009

Is Consistent

First LOG Page 17187

Last LOG Page 18452

DB Stamp 1 Date 20060202

DB Stamp 1 Time 00093758

DB Stamp 2 Date 20060202

DB Stamp 2 Time 00093819

Page Count 1265

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

--

dbmcli on TESTDB>recover_replace LogBackupFile "C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackupFeb" 010

OK

Returncode -8020

# Der angegebene Datenträger wurde eingelesen. Der Rückgabewert -8020 fordert sie auf, den nächstfolgenden Datenträger anzugeben.

Date 20060203

Time 00134353

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 2032

Pages Left 0

Volumes 1

Medianame LogBackupFile

Location \\GENUA\\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackupFeb.010

Errortext

Label LOG_000000010

Is Consistent

First LOG Page 18453

Last LOG Page 20670

DB Stamp 1 Date 20060202

DB Stamp 1 Time 00163233

DB Stamp 2 Date 20060202

DB Stamp 2 Time 00163447

Page Count 2217

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

---

dbmcli on TESTDB>recover_replace LogBackupFile "\\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups 2005\Data\logBackupFeb" 011

OK

Returncode 0

# Der angegebene Datenträger wurde eingelesen. Der Rückgabewert 0 weist aus, dass alle Log-Einträge, die bis zum angegebenen Zeitpunkt geschrieben worden waren, eingelesen wurden.

Date 20060203

Time 00134353

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 1280

Pages Left 0

Volumes 1

Medianame LogBackupFile

Location \\GENUA\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\Backups.011

Errortext

Label LOG_000000011

Is Consistent

First LOG Page 20671

Last LOG Page 23024

DB Stamp 1 Date 20060202

DB Stamp 1 Time 00163601

DB Stamp 2 Date 20060202

DB Stamp 2 Time 00163604

Page Count 2353

Devices Used 1

Database ID GENUA:DEMODB_20060125_165646

Max Used Data Page

---

dbmcli on TESTDB>

Ergebnis

Das System hat die Log-Sicherungen bis zum angegebenen Zeitpunkt eingelesen und anschließend die Datenbankinstanz in den Betriebszustand ONLINE überführt.

Sie können die Schatteninstanz nun als aktive Instanz verwenden.


Log-Volumes mit Betriebssystemmitteln kopieren und Schatteninstanz in Betrieb nehmen

Vorgehensweisen Log-Volumes mit Betriebssystemmitteln kopieren und Schatteninstanz in Betrieb nehmen

Verwendung

Wenn Sie ihre Schatteninstanz als aktive Instanz in Betrieb nehmen wollen, stellen Sie zunächst den aktuellsten Zustand der Originalinstanz in der Schatteninstanz her. Dazu sichern Sie den Log-Bereich der Originalinstanz und lesen diese Log-Sicherung in die Schatteninstanz ein. Wenn es nach einem Problem mit der Originalinstanz aber nicht mehr möglich ist, eine letzte Log-Sicherung der Originalinstanz durchzuführen, die Log-Volumes der Originalinstanz jedoch unbeschädigt sind, dann können Sie deren Inhalt auch mit Betriebssystemkommandos in die Log-Volumes der Schatteninstanz kopieren.

Wenn Sie die Log-Sicherungen aus der Originalinstanz jeweils automatisch in die Schatteninstanz einlesen lassen, dann brechen Sie zunächst diesen Vorgang in der Schatteninstanz ab (recover_cancel). Anschließend überführen Sie die Schatteninstanz in den Betriebszustand OFFLINE. Nun kopieren Sie das Log-Volume der Originalinstanz in die Schatteninstanz.

Anschließend können Sie die Schatteninstanz mit allen Daten der Originalinstanz oder auch in einem Zustand, der dem Zustand der Originalinstanz zu einem bestimmten Zeitpunkt in der Vergangenheit entspricht, in Betrieb nehmen.

Database Manager CLI, Strukturlink recover_cancel , Strukturlink db_restart

Konzepte des Datenbanksystems, Strukturlink Schattendatenbank

Szenario

Sie verfügen über die Datenbankinstanz DEMODB und deren Schatteninstanz TESTDB. Das Data-Volume von DEMODB ist ausgefallen. Das Log-Volume von DEMODB ist noch intakt. Die Log-Sicherungen von DEMODB werden automatisch in TESTDB eingelesen. Sie wollen nun TESTDB mit allen in DEMODB vorhandenen Daten zur aktiven Instanz machen.

Voraussetzungen

● Sie haben eine Schatteninstanz eingerichtet.

● Die Schatteninstanz war noch nicht im Betriebszustand ONLINE.

● Die Log-Volumes der Originalinstanz sind unbeschädigt.

● Die Originalinstanz ist im Betriebszustand OFFLINE.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Schatteninstanz TESTDB:

>dbmcli –u OLEG,MONDAY –d TESTDB

dbmcli on TESTDB>

2. Wenn Sie die Log-Sicherungen aus der Originalinstanz jeweils automatisch in die Schatteninstanz einlesen lassen, dann brechen Sie diesen Vorgang jetzt ab, andernfalls fahren Sie mit Schritt 3 fort:

dbmcli on TESTDB>recover_cancel

OK

3. Überführen der Schatteninstanz in den Betriebszustand OFFLINE:

dbmcli on TESTDB>db_offline

OK

4. Mit Hilfe von Betriebssystemkommandos kopieren Sie nun die Dateien des Log-Volume von DEMODB in das Log-Volume von TESTDB.

5. Restart der Schatteninstanz:

dbmcli on TESTDB>db_restart

OK

Ergebnis

Die Datenbankinstanz TESTDB enthält den vollständigen Datenbestand von DEMODB. Sie befindet sich im Betriebszustand ONLINE und kann als aktive Instanz verwendet werden.

Um die Ausfallsicherheit des Systems zu erhalten, empfehlen wir Ihnen, nunmehr DEMODB als Schatteninstanz von TESTDB einzurichten und zu aktualisieren.

Siehe auch:

Schatteninstanz einrichten und aktualisieren


Hot-Standby-System einrichten (SAP-Bibliothek - Tutorials)

Vorgehensweisen Hot-Standby-System einrichten

Verwendung

Ein für den produktiven Einsatz geeignetes Hot-Standby-System lässt sich nur einrichten, wenn die erforderliche Cluster-Software installiert ist und Sie über eine für MaxDB freigegebene Speicherlösung verfügen. Für entsprechende Informationen wenden Sie sich an den MaxDB-Support.

Das folgende Beispiel basiert lediglich auf der Verwendung von zwei kompatiblen Windows-Rechnern. Es soll nur veranschaulichen, welche Aktionen für das Einrichten eines Hot-Standby-Systems für Entwicklungs- und Testzwecke erforderlich sind. Dabei wird mit Netzwerk-Freigaben durch das Windows-Programm gearbeitet, die für das Log-Volume in der Beispiel-Simulation manuell angepasst werden müssen.

Ein produktives Hot-Standby-System muss von einem erfahrenen Administrator eingerichtet werden, der auch über die notwendigen Kenntnisse für die Verwendung von Cluster-Software verfügt.

Zu den Voraussetzungen siehe Database Manager CLI, Strukturlink hss_enable, Strukturlink hss_addstandby, Strukturlink db_standby

Siehe auch:

Anlegen und Konfigurieren einer Datenbankinstanz

Konzepte des Datenbanksystems, Strukturlink Hot-Standby

Szenario

Sie wollen ein Hot-Standby-System bestehend aus der Master-Instanz und einer Standby-Instanz mit folgenden Eigenschaften einrichten:

Eigenschaft | Beispiel
Name des Hot-Standby-Systems | HOTSTANDBY
Rechner der Master-Instanz | GENUA (lokaler Rechner)
Rechner der Standby-Instanz | PARMA
Name des Virtual Server | VIRTUAL_SERVER
Betriebssystembenutzer, der auf dem lokalen Rechner und dem Rechner PARMA gültig ist | Benutzername ANNA, Kennwort MAY
Name der Bibliothek, über die auf das Speicherverwaltungssystem zugegriffen wird, (Bestandteil der Speichersoftware) | libhsscopy

Vorgehensweise

Schritte, die nur für die Beispielsimulation unter Microsoft Windows ausgeführt werden müssen, sind kursiv formatiert.

...

1. Aufrufen des Database Manager CLI, Anlegen der Datenbankinstanz mit dem Namen HOTSTANDBY und Definieren des ersten DBM-Benutzers mit dem Benutzernamen DBM und dem Kennwort DBM.

Für die Simulation des Beispiels unter Microsoft Windows müssen Sie hier zusätzlich die Option –u angeben, damit der Service zum Starten des Datenbankkerns unter dem am Schluss des DBM-Kommandos angegebenen Betriebssystembenutzer ANNA mit dem Kennwort MAY läuft.

>dbmcli db_create -u HOTSTANDBY DBM,DBM ANNA,MAY

OK

dbmcli on HOTSTANDBY>

2. Eröffnen einer Parametersitzung:

dbmcli on HOTSTANDBY>param_startsession

OK

dbmcli on HOTSTANDBY>

3. Initialisieren der Datenbankparameter und Definition des Datenbanktyps OLTP (Vorschlagswert).
dbmcli on HOTSTANDBY>param_init

OK

4. Ändern des Datenbankparameters RUNDIRECTORY auf einen Pfad, der keine Leerzeichen enthält:

dbmcli on HOTSTANDBY>param_put RUNDIRECTORY C:\test\wrk

OK

5. Prüfen aller Datenbankparameter:

dbmcli on HOTSTANDBY>param_checkall

OK

6. Bestätigen der Änderungen der Datenbank-Parameterdatei:

dbmcli on HOTSTANDBY>param_commitsession

OK

7. Anlegen von Data- und Log-Volumes

a. Anlegen des Data-Volume Nr. 1 mit dem Namen DISKD0001 vom Typ FILE mit einer Größe von 32768 Seiten:

dbmcli on HOTSTANDBY>param_addvolume 1 DATA DISKD0001 F 32768

OK

b. Anlegen des Log-Volume Nr. 1 mit dem Namen DISKL0001 vom Typ FILE mit einer Größe von 6400 Seiten

dbmcli on HOTSTANDBY>param_addvolume 1 LOG DISKL0001 F 6400

OK

8. Definieren des Namens des Virtual Server.

Damit wird die Datenbankinstanz zum Bestandteil eines Hot-Standby-Systems und gemäß Vorschlagswert des Database Manager gleichzeitig zur Master-Instanz des Hot-Standby-Systems:

dbmcli on HOTSTANDBY>hss_enable node=VIRTUAL_SERVER lib=libhsscopy

OK

9. Überführen der Master-Instanz in den Betriebszustand ADMIN:

dbmcli on DEMODB>db_admin

OK

10. Initialisieren der Master-Instanz und Anlegen des Datenbanksystemadministrators mit dem Benutzernamen DBADMIN und dem Kennwort SECRET:

dbmcli on DEMODB>db_activate DBADMIN,SECRET

OK

11. Laden der Systemtabellen:

dbmcli on DEMODB>load_systab

OK

0,OK: everything works fine

0,""c:\program files\sdb\maxdb1\bin\x_python" "c:\program files\sdb\maxdb1\env

\lsystab.py" -R "c:\program files\sdb\maxdb1" -d HOTSTANDBY -u dbadmin,*"

Removing obsolete objects

Installing Loader tables

...

...

==================================

Installation successfully finished

==================================

12. Anpassen der Log-Volume-Pfade für die Beispielsimulation:

a. Überführen der Master-Instanz in den Betriebszustand OFFLINE:

dbmcli on HOTSTANDBY>db_offline

b. Setzen des Pfades für das von der Master- und der Standby-Instanz gemeinsam genutzten Log-Volume:

dbmcli on HOTSTANDBY>param_addvolume 1 LOG \\GENUA\HSS_HOTSTANDBY\DISKLO001 F 6400

c. Überführen der Master-Instanz in den Betriebszustand ONLINE:

dbmcli on HOTSTANDBY>db_online

13. Hinzufügen der Standby-Instanz:

dbmcli on HOTSTANDBY>hss_addstandby PARMAlogin=ANNA,MAY

OK

14. Überführen Standby-Instanz in den Betriebszustand STANDBY:

dbmcli on HOTSTANDBY>db_standby node=PARMA

OK

Ergebnis

Das Hot-Standby-System ist eingerichtet.

Die Master-Instanz ist im Betriebszustand ONLINE. Die Standby-Instanz ist im Betriebszustand STANDBY.


Betriebsmodi im Database Manager CLI (SAP-Bibliothek - Tutorials)

Funktionsdokumentation Betriebsmodi im Database Manager CLI

Im Programm Database Manager CLI können Sie in Abhängigkeit von der auszuführenden Aktion zwischen drei Betriebsmodi wählen:

Kommandomodus verwenden

Sitzungsmodus verwenden

Skriptmodus verwenden


Kommandomodus verwenden (SAP-Bibliothek - Tutorials)

Vorgehensweisen Kommandomodus verwenden

Verwendung

Wir empfehlen Ihnen, mit dem Database Manager im Kommandomodus zu arbeiten, wenn Sie Aktionen im Database Manager CLI ausführen wollen, die nur ein einzelnes DBM-Kommando erfordern.

Vorgehensweise

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen des Betriebszustandes der Datenbankinstanz:

>dbmcli –u OLEG,MONDAY –d DEMODB db_online

OK

oder:

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Einschalten der automatischen Log-Sicherung:

>dbmcli –u OLEG,MONDAY –d DEMODB autolog_on

OK


Sitzungsmodus verwenden (SAP-Bibliothek - Tutorials)

Vorgehensweisen Sitzungsmodus verwenden

Verwendung

Sie müssen mit dem Database Manager im Sitzungsmodus oder Skriptmodus arbeiten, wenn Sie DBM-Kommandos ausführen wollen, die eine Datenbanksitzung oder Servicesitzung zur Voraussetzung haben.

Darüber hinaus empfehlen wir Ihnen auch dann im Sitzungsmodus zu arbeiten, wenn Sie Aktionen ausführen wollen, die eine Folge von mehreren DBM-Kommandos erfordern.

Wenn Sie eine vollständige Datensicherung der Datenbankinstanz erstellen wollen, müssen Sie zunächst eine Datenbanksitzung eröffnen. Sie benötigen für den Sicherungsvorgang eine geeignete Sicherungsvorlage.

Siehe auch:

Sicherungsvorlage für die vollständige Datensicherung in eine Datei erstellen

Skriptmodus verwenden

Szenario

Sie wollen Ihre Datenbankinstanz DEMODB unter Verwendung der Sicherungsvorlage DemoDataCompl sichern.

Vorgehensweise

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als BenutzerOLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Aufbau einer Datenbanksitzung:

dbmcli on DEMODB>db_connect

OK

3. Starten einer Datensicherung unter Verwendung der Sicherungsvorlage DemoDataCompl:

dbmcli on DEMODB>backup_start DemoDataCompl

OK

Returncode 0

Date 20051229

Time 00104810

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

Pages Transferred 384

Pages Left 0

Volumes 1

Medianame DemoDataCompl

Location Backups 2005\Data\completeDataJan

Errortext

Label DAT_000000003

Is Consistent true

First LOG Page 15939

Last LOG Page

DB Stamp 1 Date 20051229

DB Stamp 1 Time 00104809

DB Stamp 2 Date

DB Stamp 2 Time

Page Count 365

Devices Used 1

Database ID GENUA:DEMODB_20051201_111620

Max Used Data Page 0

---

dbmcli on DEMODB>

Weitere Beispiele:

Anlegen und Konfigurieren einer Datenbankinstanz

Wiederherstellen der Datenbankinstanz


Skriptmodus verwenden (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Skriptmodus verwenden

Verwendung

Wenn Sie im Skriptmodus arbeiten, können Sie eine in einer Skriptdatei gespeicherte Folge von DBM-Kommandos an den Database Manager übergeben und ausführen. Dazu rufen Sie den Database Manager CLI mit der DBM-Option -i <file_name> auf.

Sie müssen mit dem Database Manager im Skriptmodus oder im Sitzungsmodus arbeiten, wenn Sie DBM-Kommandos ausführen wollen, die eine Datenbanksitzung oder Servicesitzung zur Voraussetzung haben. Außerdem empfehlen wir Ihnen, im Skriptmodus zu arbeiten, wenn Sie Aktionen im Database Manager CLI ausführen wollen, die eine Folge von mehreren DBM-Kommandos erfordern und im Hintergrund abgearbeitet werden sollen.

Siehe auch:

Sitzungsmodus verwenden

Beispiel

Skriptdatei verwenden


SQL-Tutorial (SAP-Bibliothek - Tutorials)

Komponentendokumentation SQL-Tutorial

Einsatzmöglichkeiten

MaxDB ist ein relationales Datenbanksystem mit einer SQL-Sprachschnittstelle. Die Daten von MaxDB sind in Form von Tabellen organisiert. Mit einem Satz von einfachen, an die englische Sprache angelehnten Anweisungen der Sprache SQL (Structured Query Language) lassen sich vielfältige Operationen mit den Daten und Tabellen ausführen.

Dieses SQL-Tutorial dient dazu, Ihnen die Sprache SQL anhand des Datenbanksystems MaxDB nahe zu bringen.

Einführungshinweise

Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie diese installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Eine ausführliche detaillierte Beschreibung der SQL-Syntax finden Sie im Strukturlink SQL-Referenzhandbuch.

Funktionsumfang

Demo-Daten

Um die Beispiele des SQL-Tutorials selbst nachvollziehen zu können, benötigen Sie die Demo-Daten für das SQL-Tutorial.

Die Demo-Daten wurde für Übungs- und Testzwecke entwickelt und enthalten mehrere vordefinierte Demo-Benutzer und Demo-Daten im Demo-Schema HOTEL.

Verwenden Sie diese Demo-Daten nicht in einem Produktivsystem.

Beispiel-SQL-Anweisungen

Die SQL-Anweisungen, die in diesem SQL-Tutorial anhand von Beispielen erläutert werden sollen, lassen sich in folgende Bereiche einteilen:

● Die SELECT-Anweisung ermöglicht die zeilen- oder spaltenweise Auswahl von Daten aus einer Tabelle. Zeilen mehrerer Tabellen können miteinander verbunden werden. Sortierungen, Gruppierungen und Berechnungen können ausgeführt werden.
Beispiele dazu finden Sie im Abschnitt Datenanfrage.

● Eine weitere Gruppe von Anweisungen dient zur Definition und Re-Definition der Tabellenstruktur und weiterer Datenbankobjekte.
Beispiele dazu finden Sie im Abschnitt Datendefinition.

● Mit der Anweisung INSERT lassen sich Zeilen einfügen und mit DELETE wieder entfernen. Mit UPDATE können Änderungen vorgenommen werden.
Beispiele dazu finden Sie im Anschnitt Datenmanipulation.

● Eine weitere Gruppe von Anweisungen dient der Kontrolle der Zugriffsrechte von Benutzern und Benutzergruppen auf die Daten.
Beispiele dazu finden Sie im Abschnitt Autorisierung.

● Oftmals ist für Kontrollzwecke ein Auswerten der Systemtabellen hilfreich.
Beispiele dazu finden Sie im Abschnitt Systemtabellen auswerten (Beispiele).

Um die SQL-Anweisungen gut lesbar darzustellen, werden die Schlüsselwörter in Großbuchstaben geschrieben und die SQL-Anweisungen strukturiert. Für die Ausführung einer SQL-Anweisung spielt die Groß- und Kleinschreibung der Syntaxelemente und das Setzen von Leerzeichen oder Zeilenumbrüchen keine Rolle.

Bei der Wahl der Strukturlink Bezeichner der Datenbankobjekte und der Eingabe von Werten in Form von Strukturlink Literalen kann die Groß- und Kleinschreibung von Bedeutung sein.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank


Demo-Daten für das SQL-Tutorial (SAP-Bibliothek - Tutorials)

Vorgehensweisen Demo-Daten für das SQL-Tutorial

Die Demo-Daten für das SQL-Tutorial widerspiegeln ein sehr vereinfachtes Modell einer Hotelverwaltung mit Informationen zu den Besuchern der Hotels, der Lage der Hotels, ihrer Auslastung, Preise der Zimmer usw. .

Diese einfachen Demo-Daten sind ausreichend, um alle Beispiele dieses SQL-Tutorials nachvollziehen zu können.

Es steht Ihnen frei, die Demo-Daten Ihren Anforderungen entsprechend zu verändern. Allerdings stimmen dann gegebenfalls die im SQL-Tutorial angegebenen Beispielergebnisse nicht mehr ganz mit Ihren Ergebnissen überein.

Voraussetzungen

...

1. Installieren Sie die Datenbanksoftware und die Datenbankwerkzeuge.
Verfahren Sie dazu wie im Strukturlink Installationshandbuch beschrieben.

2. Legen Sie die Demo-Datenbankinstanz DEMODB an. Sie können dazu den Installation Manager oder den Database Manager verwenden.
Laden Sie NICHT die Demo-Daten.
Installationshandbuch, Strukturlink Demo-Datenbankinstanz DEMODB anlegen
Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz: Desktop PC/Laptop
Tutorial Datenbankverwaltung, Anlegen und Konfigurieren einer Datenbankinstanz

Vorgehensweise

Anlegen des Datenbankbenutzers MONA

Sie können verschiedene Werkzeuge verwenden, um Datenbankbenutzer anzulegen (Loader, Database Manager, z.B. Database Manager GUI oder Database Manager CLI, Query Tools, z.B. SQL Studio, SQLCLI). Die Eingabe der SQL-Anweisungen für das Anlegen des Datenbankbenutzers MONA wird im Folgenden anhand des Werkzeugs Strukturlink SQL Studio demonstriert.

...

1. Melden Sie sich mit Hilfe des SQL Studio als Datenbanksystemadministrator an die Demo-Datenbankinstanz DEMODB an.
Wenn Sie die Vorschlagswerte beim Anlegen der Demo-Datenbankinstanz DEMODB übernommen haben, hat der Datenbanksystemadministrator folgende Benutzerdaten:
Benutzername: DBADMIN, Kennwort: SECRET

2. Legen Sie den Datenbankbenutzer MONA mit folgender SQL-Anweisung an.
CREATE USER mona PASSWORD red DBA NOT EXCLUSIVE

3. Melden Sie sich vom SQL Studio ab.

Anlegen des Demo-Schemas HOTEL

Sie können verschiedene Werkzeuge verwenden, um die Objekte in der Demo-Datenbankinstanz DEMODB im Demo-Schema HOTEL anzulegen und mit Demo-Daten zu füllen (Loader, Database Manager CLI, Query Tools, z.B. SQL Studio, SQLCLI).

Das Ausführen der SQL-Anweisungen für das Anlegen der Datenbankobjekte und ihrer Inhalte wird im Folgenden anhand des Werkzeugs SQL Studio mit den für das Schema HOTEL angegebenen SQL-Anweisungen demonstriert.

1. Melden Sie sich mit Hilfe des SQL Studio als Benutzer MONA mit dem Kennwort RED an die Demo-Datenbankinstanz DEMODB an.

2. Legen Sie das Schema HOTEL und die erforderlichen Tabellen an und füllen Sie diese mit Werten.
Verwenden Sie dazu die entsprechenden SQL-Anweisungen wie in SQL-Anweisungen für das Demo-Schema HOTEL angegeben.

Ergebnis

In der Demo-Datenbankinstanz DEMODB wurde der Datenbankbenutzer MONA mit dem Kennwort RED als Datenbankadministrator (DBA) angelegt. Der Datenbankadministrator MONA kann mehrere Datenbanksitzungen gleichzeitig öffnen (NOT EXCLUSIVE).

Es wurde das Demo-Schema HOTEL erzeugt. Dem Schema HOTEL wurden eine Reihe von einfach aufgebauten Tabellen zugeordnet. Die Tabellen sind mit Demo-Daten gefüllt.

Siehe auch:

Erläuterung der Tabellen im Demo-Schema HOTEL

Wenn Sie die Verwaltung von Datenbankinstanzen am Beispiel von DEMODB erlernen, SQL-Anweisungen oder Loader-Kommandos auf der Basis vorhandener Daten testen wollen, haben Sie die Möglichkeit, einen umfassenderen Satz von Demo-Daten durch Ausführen vorgegebener Skripte in die Datenbankinstanz DEMODB zu laden.

Markieren Sie in diesem Fall beim Anlegen einer Datenbankinstanz im Installation Manager und im Database Manager GUI die entsprechende Load Tutorial-Option, um die vollständigen Demo-Daten zu laden.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank, Strukturlink Objekte im Schema HOTEL


SQL-Anweisungen für das Demo-Schema HOTEL (SAP-Bibliothek - Tutorials)

Hintergrunddokumentation SQL-Anweisungen für das Demo-Schema HOTEL

Mit den folgenden SQL-Anweisungen können Sie eine Reihe von Tabellen und ihre Inhalte im Demo-Schema HOTEL erzeugen. Anhand dieses Schemas können Sie alle Beispiele des SQL-Tutorials nachvollziehen.

Siehe auch:

Erläuterung der Tabellen im Demo-Schema HOTEL

Ablauf

Erzeugen Sie den Datenbankadministrator MONA und melden Sie sich als MONA an die Demo-Datenbankinstanz DEMODB mit einem geeigneten Werkzeug an (siehe dazu: Demo-Daten für das SQL-Tutorial). Geben Sie die folgenden SQL-Anweisungen ein:

//

CREATE SCHEMA hotel

//

SET CURRENT_SCHEMA = hotel

//

CREATE TABLE city

(zip                CHAR(5)     PRIMARY KEY,

 name               CHAR(30)    NOT NULL,

 state              CHAR(2)    NOT NULL)

//

CREATE TABLE customer

(cno                FIXED(4)    PRIMARY KEY,

 title              CHAR(7),

 firstname          CHAR(20),

 name               CHAR(40)    NOT NULL,

 zip                CHAR(5),

 address            CHAR(40)    NOT NULL)

//

CREATE TABLE hotel

(hno                FIXED(4)    PRIMARY KEY,

 name               CHAR(50)    NOT NULL,

 zip                CHAR(5),

 address            CHAR(40)    NOT NULL)

//

CREATE TABLE room

(hno                FIXED(4),

 type               CHAR(6),    PRIMARY KEY (hno,type),

 free               FIXED(3,0),

 price              FIXED(6,2))

//

CREATE TABLE reservation

(rno                FIXED(4)    PRIMARY KEY,

 cno                FIXED(4),

 hno                FIXED(4),

 type               CHAR(6),

 arrival            DATE        NOT NULL,

 departure          DATE        NOT NULL)

//

//------------------------------------------------------------------

//TABLE city (25 Rows)

//------------------------------------------------------------------

//

INSERT INTO city VALUES ('12203','Albany','NY')

//

INSERT INTO city VALUES ('60601','Chicago','IL')

//

INSERT INTO city VALUES ('60615','Chicago','IL')

//

INSERT INTO city VALUES ('45211','Cincinnati','OH')

//

INSERT INTO city VALUES ('33575','Clearwater','FL')

//

INSERT INTO city VALUES ('75243','Dallas','TX')

//

INSERT INTO city VALUES ('32018','Daytona Beach','FL')

//

INSERT INTO city VALUES ('33441','Deerfield Beach','FL')

//

INSERT INTO city VALUES ('48226','Detroit','MI')

//

INSERT INTO city VALUES ('90029','Hollywood','CA')

//

INSERT INTO city VALUES ('92714','Irvine','CA')

//

INSERT INTO city VALUES ('90804','Long Beach','CA')

//

INSERT INTO city VALUES ('11788','Long Island','NY')

//

INSERT INTO city VALUES ('90018','Los Angeles','CA')

//

INSERT INTO city VALUES ('70112','New Orleans','LA')

//

INSERT INTO city VALUES ('10580','New York','NY')

//

INSERT INTO city VALUES ('10019','New York','NY')

//

INSERT INTO city VALUES ('92262','Palm Springs','CA')

//

INSERT INTO city VALUES ('97213','Portland','OR')

//

INSERT INTO city VALUES ('60018','Rosemont','IL')

//

INSERT INTO city VALUES ('95054','Santa Clara','CA')

//

INSERT INTO city VALUES ('20903','Silver Spring','MD')

//

INSERT INTO city VALUES ('20037','Seattle','WA')

//

INSERT INTO city VALUES ('20005','Seattle','WA')

//

INSERT INTO city VALUES ('20019','Seattle','WA')

//------------------------------------------------------------------

//TABLE customer (15 Rows)

//------------------------------------------------------------------

//

INSERT INTO customer VALUES (3000,'Mrs','Jenny','Porter','10580','1340 N. Ash Street, #3')

//

INSERT INTO customer VALUES (3100,'Mr','Peter','Brown','48226','1001 34th St., APT.3')

//

INSERT INTO customer VALUES (3200,'Company',NULL,'Datasoft','90018','486 Maple St.')

//

INSERT INTO customer VALUES (3300,'Mrs','Rose','Brian','75243','500 Yellowstone Drive, #2')

//

INSERT INTO customer VALUES (3400,'Mrs','Mary','Griffith','20005','3401 Elder Lane')

//

INSERT INTO customer VALUES (3500,'Mr','Martin','Randolph','60615','340 MAIN STREET, #7')

//

INSERT INTO customer VALUES (3600,'Mrs','Sally','Smith','75243','250 Curtis Street')

//

INSERT INTO customer VALUES (3700,'Mr','Mike','Jackson','45211','133 BROADWAY APT. 1')

//

INSERT INTO customer VALUES (3800,'Mrs','Rita','Doe','97213','2000 Humboldt St., #6')

//

INSERT INTO customer VALUES (3900,'Mr','George','Howe','75243','111 B Parkway, #23')

//

INSERT INTO customer VALUES (4000,'Mr','Frank','Miller','95054','27 5th St., 76')

//

INSERT INTO customer VALUES (4100,'Mrs','Susan','Baker','90018','200 MAIN STREET, #94')

//

INSERT INTO customer VALUES (4200,'Mr','Joseph','Peters','92714','700 S. Ash St., APT.12')

//

INSERT INTO customer VALUES (4300,'Company',NULL,'TOOLware','20019','410 Mariposa St., #10')

//

INSERT INTO customer VALUES (4400,'Mr','Antony','Jenkins','20903','55 A Parkway, #15')

//

//------------------------------------------------------------------

//TABLE hotel (15 Rows)

//------------------------------------------------------------------

//

//

INSERT INTO hotel VALUES (10,'Congress','20005','155 Beechwood St.')

//

INSERT INTO hotel VALUES (30,'Regency','20037','477 17th Avenue')

//

INSERT INTO hotel VALUES (20,'Long Island','11788','1499 Grove Street')

//

INSERT INTO hotel VALUES (70,'Empire State','12203','65 Yellowstone Dr.')

//

INSERT INTO hotel VALUES (80,'Midtown','10019','12 Barnard St.')

//

INSERT INTO hotel VALUES (40,'Eighth Avenue','10019','112 8th Avenue')

//

INSERT INTO hotel VALUES (50,'Lake Michigan','60601','354 OAK Terrace')

//

INSERT INTO hotel VALUES (60,'Airport','60018','650 C Parkway')

//

INSERT INTO hotel VALUES (90,'Sunshine','33575','200 Yellowstone Dr.')

//

INSERT INTO hotel VALUES (100,'Beach','32018','1980 34th St.')

//

INSERT INTO hotel VALUES (110,'Atlantic','33441','111 78th St.')

//

INSERT INTO hotel VALUES (120,'Long Beach','90804','35 Broadway')

//

INSERT INTO hotel VALUES (150,'Indian Horse','92262','16 MAIN STREET')

//

INSERT INTO hotel VALUES (130,'Star','90029','13 Beechwood Place')

//

INSERT INTO hotel VALUES (140,'River Boat','70112','788 MAIN STREET')

//

//------------------------------------------------------------------

//TABLE room (38 Rows)

//------------------------------------------------------------------

//

//

INSERT INTO room VALUES (10,'single',20,135.00)

//

INSERT INTO room VALUES (10,'double',45,200.00)

//

INSERT INTO room VALUES (30,'single',12,45.00)

//

INSERT INTO room VALUES (30,'double',15,80.00)

//

INSERT INTO room VALUES (20,'single',10,70.00)

//

INSERT INTO room VALUES (20,'double',13,100.00)

//

INSERT INTO room VALUES (70,'single',4,115.00)

//

INSERT INTO room VALUES (70,'double',11,180.00)

//

INSERT INTO room VALUES (80,'single',15,90.00)

//

INSERT INTO room VALUES (80,'double',19,150.00)

//

INSERT INTO room VALUES (80,'suite',5,400.00)

//

INSERT INTO room VALUES (40,'single',20,85.00)

//

INSERT INTO room VALUES (40,'double',35,140.00)

//

INSERT INTO room VALUES (50,'single',50,105.00)

//

INSERT INTO room VALUES (50,'double',230,180.00)

//

INSERT INTO room VALUES (50,'suite',12,500.00)

//

INSERT INTO room VALUES (60,'single',10,120.00)

//

INSERT INTO room VALUES (60,'double',39,200.00)

//

INSERT INTO room VALUES (60,'suite',20,500.00)

//

INSERT INTO room VALUES (90,'single',45,90.00)

//

INSERT INTO room VALUES (90,'double',145,150.00)

//

INSERT INTO room VALUES (90,'suite',60,300.00)

//

INSERT INTO room VALUES (100,'single',11,60.00)

//

INSERT INTO room VALUES (100,'double',24,100.00)

//

INSERT INTO room VALUES (110,'single',2,70.00)

//

INSERT INTO room VALUES (110,'double',10,130.00)

//

INSERT INTO room VALUES (120,'single',34,80.00)

//

INSERT INTO room VALUES (120,'double',78,140.00)

//

INSERT INTO room VALUES (120,'suite',55,350.00)

//

INSERT INTO room VALUES (150,'single',44,100.00)

//

INSERT INTO room VALUES (150,'double',115,190.00)

//

INSERT INTO room VALUES (150,'suite',6,450.00)

//

INSERT INTO room VALUES (130,'single',89,160.00)

//

INSERT INTO room VALUES (130,'double',300,270.00)

//

INSERT INTO room VALUES (130,'suite',100,700.00)

//

INSERT INTO room VALUES (140,'single',10,125.00)

//

INSERT INTO room VALUES (140,'double',9,200.00)

//

INSERT INTO room VALUES (140,'suite',78,600.00)

//

//------------------------------------------------------------------

//TABLE reservation (10 Rows)

//------------------------------------------------------------------

//

//

INSERT INTO reservation VALUES (100,3000,80,'single','2004-11-13','2004-11-15')

//

INSERT INTO reservation VALUES (110,3000,100,'double','2004-12-24','2005-01-06')

//

INSERT INTO reservation VALUES (120,3200,50,'suite','2004-11-14','2004-11-18')

//

INSERT INTO reservation VALUES (130,3900,110,'single','2005-02-01','2005-02-03')

//

INSERT INTO reservation VALUES (150,3600,70,'double','2005-03-14','2005-03-24')

//

INSERT INTO reservation VALUES (140,4300,80,'double','2004-04-12','2004-04-30')

//

INSERT INTO reservation VALUES (160,4100,70,'single','2004-04-12','2004-04-15')

//

INSERT INTO reservation VALUES (170,4400,150,'suite','2004-09-01','2004-09-03')

//

INSERT INTO reservation VALUES (180,3100,120,'double','2004-12-23','2005-01-08')

//

INSERT INTO reservation VALUES (190,4300,140,'double','2004-11-14','2004-11-17')

//

// THE END

Wenn Sie alle Demo-Daten mit dem Installation Manager oder dem Database Manager geladen haben, wurden die Tabellen mit weitaus umfangreicheren Definitionen angelegt und weitere Objekte (z.B. Views, Indizes u.ä.) erzeugt.

Sie können auch diese Demo-Daten verwenden. Allerdings unterscheidet sich dann gegebenfalls die in diesem SQL-Tutorial für eine Beispielanweisung angegebene Ergebnismenge von der Ergebnismenge, die Sie für die erweiterten Demo-Daten erhalten.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank, Strukturlink Objekte im Schema HOTEL


Erläuterung der Tabellen im Demo-Schema HOTEL (SAP-Bibliothek - Tutorials)

Hintergrunddokumentation Erläuterung der Tabellen im Demo-Schema HOTEL

Nach Ausführen der SQL-Anweisungen für das Demo-Schema HOTEL befinden sich die Tabellen CITY, CUSTOMER, HOTEL, ROOM und RESERVATION im Demo-Schema HOTEL. Durch die INSERT-Anweisungen wurden die Tabellen mit Demo-Daten gefüllt.

CITY (Ortstabelle)

Jede Tabellenzeile enthält folgende Ortsinformationen: Postleitzahl, Name des Ortes, Abkürzung des Staatsnamens, in dem sich der Ort befindet.

Definition

CREATE TABLE city
(zip CHAR(5) PRIMARY KEY,
name CHAR(30) NOT NULL,
state CHAR(2) NOT NULL)

Daten

ZIP | NAME | STATE
12203 | Albany | NY
60601 | Chicago | IL
60615 | Chicago | IL
45211 | Cincinnati | OH
33575 | Clearwater | FL
75243 | Dallas | TX
32018 | Daytona Beach | FL
33441 | Deerfield Beach | FL
48226 | Detroit | MI
90029 | Hollywood | CA
92714 | Irvine | CA
90804 | Long Beach | CA
11788 | Long Island | NY
90018 | Los Angeles | CA
70112 | New Orleans | LA
10580 | New York | NY
10019 | New York | NY
92262 | Palm Springs | CA
97213 | Portland | OR
60018 | Rosemont | IL
95054 | Santa Clara | CA
20903 | Silver Spring | MD
20037 | Seattle | WA
20005 | Seattle | WA
20019 | Seattle | WA

CUSTOMER (Kundentabelle)

Jede Tabellenzeile enthält folgende Kundeninformationen: eine Nummer zur eindeutigen Identifizierung des Kunden, die Anrede zur Verwendung für Anschreiben, den Kundenvor- und Nachnamen, die Kundenadresse bestehend aus Postleitzahl, Straße und Hausnummer.

Definition

CREATE TABLE
customer
(cno        FIXED(4) PRIMARY
KEY,
title      CHAR(7),
firstname  CHAR(20),
name       CHAR(40) NOT
NULL,
zip        CHAR(5),
address    CHAR(40) NOT NULL)

Daten

CNO | TITLE | FIRSTNAME | NAME | ZIP | ADDRESS
3000 | Mrs | Jenny | Porter | 10580 | 1340 N. Ash Street, #3
3100 | Mr | Peter | Brown | 48226 | 1001 34th St., APT.3
3200 | Company | ? | Datasoft | 90018 | 486 Maple St.
3300 | Mrs | Rose | Brian | 75243 | 500 Yellowstone Drive, #2
3400 | Mrs | Mary | Griffith | 20005 | 3401 Elder Lane
3500 | Mr | Martin | Randolph | 60615 | 340 MAIN STREET, #7
3600 | Mrs | Sally | Smith | 75243 | 250 Curtis Street
3700 | Mr | Mike | Jackson | 45211 | 133 BROADWAY APT. 1
3800 | Mrs | Rita | Doe | 97213 | 2000 Humboldt St., #6
3900 | Mr | George | Howe | 75243 | 111 B Parkway, #23
4000 | Mr | Frank | Miller | 95054 | 27 5th St., 76
4100 | Mrs | Susan | Baker | 90018 | 200 MAIN STREET, #94
4200 | Mr | Joseph | Peters | 92714 | 700 S. Ash St., APT.12
4300 | Company | ? | TOOLware | 20019 | 410 Mariposa St., #10
4400 | Mr | Antony | Jenkins | 20903 | 55 A Parkway, #15

HOTEL (Hoteltabelle)

Jede Tabellenzeile enthält folgende Hotelinformationen: eine Nummer zur eindeutigen Identifizierung des Hotels, den Hotelnamen und die Hoteladresse bestehend aus Postleitzahl, Straße und Hausnummer.

Definition

CREATE TABLE
hotel
(hno     FIXED(4) PRIMARY KEY,
name    CHAR(50) NOT NULL,
zip     CHAR(5),
address CHAR(40) NOT NULL)

Daten

HNO | NAME | ZIP | ADDRESS
10 | Congress | 20005 | 155 Beechwood St.
20 | Long Island | 11788 | 1499 Grove Street
30 | Regency | 20037 | 477 17th Avenue
40 | Eighth Avenue | 10019 | 112 8th Avenue
50 | Lake Michigan | 60601 | 354 OAK Terrace
60 | Airport | 60018 | 650 C Parkway
70 | Empire State | 12203 | 65 Yellowstone Dr.
80 | Midtown | 10019 | 12 Barnard St.
90 | Sunshine | 33575 | 200 Yellowstone Dr.
100 | Beach | 32018 | 1980 34th St.
110 | Atlantic | 33441 | 111 78th Street
120 | Long Beach | 90804 | 35 Broadway
130 | Star | 90029 | 13 Beechwood Place
140 | River Boat | 70112 | 788 MAIN STREET
150 | Indian Horse | 92262 | 16 MAIN STREET

ROOM (Zimmertabelle)

Jede Tabellenzeile enthält folgende Zimmerinformationen: eine Nummer zur eindeutigen Identifizierung des Hotels, in dem sich das Zimmer befindet, eine Angabe zum Zimmertyp (Einzel, Doppel, Suite), die Anzahl der freien Zimmer und den Preis pro Zimmer.

Definition

CREATE TABLE room
(hno FIXED(4),
type CHAR(6) PRIMARY KEY (hno, type),
free FIXED(3,0),
price FIXED(6,2))

Daten

HNO | TYPE | FREE | PRICE
10 | double | 45 | 200.00
10 | single | 20 | 135.00
20 | double | 13 | 100.00
20 | single | 10 | 70.00
30 | double | 15 | 80.00
30 | single | 12 | 45.00
40 | double | 35 | 140.00
40 | single | 20 | 85.00
50 | double | 230 | 180.00
50 | single | 50 | 105.00
50 | suite | 12 | 500.00
60 | double | 39 | 200.00
60 | single | 10 | 120.00
60 | suite | 20 | 500.00
70 | double | 11 | 180.00
70 | single | 4 | 115.00
80 | double | 19 | 150.00
80 | single | 15 | 90.00
80 | suite | 5 | 400.00
90 | double | 145 | 150.00
90 | single | 45 | 90.00
90 | suite | 60 | 300.00
100 | double | 24 | 100.00
100 | single | 11 | 60.00
110 | double | 10 | 130.00
110 | single | 2 | 70.00
120 | double | 78 | 140.00
120 | single | 34 | 80.00
120 | suite | 55 | 350.00
130 | double | 300 | 270.00
130 | single | 89 | 160.00
130 | suite | 100 | 700.00
140 | double | 9 | 200.00
140 | single | 10 | 125.00
140 | suite | 78 | 600.00
150 | double | 115 | 190.00
150 | single | 44 | 100.00
150 | suite | 6 | 450.00

RESERVATION (Buchungstabelle)

Jede Tabellenzeile enthält folgende Buchungsinformationen: eine Nummer zur eindeutigen Identifizierung der Buchung, eine Nummer zur eindeutigen Identifizierung des Kunden, eine Nummer zur eindeutigen Identifizierung des Hotels, eine Angabe zum Zimmertyp (Einzel, Doppel, Suite), Datum der Ankunft und der Abreise.

Definition

CREATE TABLE reservation
(rno FIXED(4) PRIMARY KEY,
cno FIXED(4),
hno FIXED(4),
type CHAR(6),
arrival DATE NOT NULL,
departure DATE NOT NULL)

Daten

RNO | CNO | HNO | TYPE | ARRIVAL | DEPARTURE
100 | 3000 | 80 | Single | 2004-11-13 | 2004-11-15
110 | 3000 | 100 | Double | 2004-12-24 | 2005-01-06
120 | 3200 | 50 | Suite | 2004-11-14 | 2004-11-18
130 | 3900 | 110 | Single | 2005-02-01 | 2005-02-03
140 | 4300 | 80 | Double | 2005-03-14 | 2005-03-24
150 | 3600 | 70 | Double | 2004-04-12 | 2004-04-30
160 | 4100 | 70 | Single | 2004-04-12 | 2004-04-15
170 | 4400 | 150 | Suite | 2004-09-01 | 2004-09-03
180 | 3100 | 120 | Double | 2004-12-23 | 2005-01-08
190 | 4300 | 140 | Double | 2004-11-14 | 2004-11-17

Wenn Sie alle Demo-Daten mit dem Installation Manager oder dem Database Manager geladen haben, wurden die Tabellen mit weitaus umfangreicheren Definitionen und Inhalten angelegt und weitere Objekte (z.B. Views, Indizes u.ä.) erzeugt.

Sie können auch diese Demo-Daten verwenden. Allerdings unterscheidet sich dann gegebenfalls die in diesem SQL-Tutorial für eine Beispielanweisung angegebene Ergebnismenge von der Ergebnismenge, die Sie für die erweiterten Demo-Daten erhalten.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank, Strukturlink Objekte im Schema HOTEL


Datenanfrage (SAP-Bibliothek - Tutorials)

Hintergrunddokumentation Datenanfrage

Eine vollständige Syntaxbeschreibung der SQL-Anweisungen zur Datenanfrage erhalten Sie im SQL-Referenzhandbuch im Abschnitt Strukturlink Datenanfrage.

Im Folgenden sollen einige wesentliche SQL-Anweisungen zur Datenanfrage anhand von Beispielen vorgestellt werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool Strukturlink SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiel einer Datenanfrage

SELECT zip, name, state
FROM hotel.city
WHERE name = 'Seattle'

Das bedeutet:

· Suche (SELECT)

· die Spalten zip, name, state

· aus der Tabelle city des Schemas hotel (FROM)

· für die Zeilen mit dem Stadtnamen Seattle (WHERE)

Die Form einer einfachen SELECT-Anweisung ist also:

SELECT..... WAS
FROM....... WOHER
WHERE...... WOBEI

Ergebnis

ZIP | NAME | STATE
20005 | Seattle | WA
20019 | Seattle | WA
20037 | Seattle | WA

Beispiele

· Auswählen, Anordnen und Umbenennen von Spalten

· Auswählen und Anordnen von Zeilen

· Bedingungen: Vergleich, AND, OR, BETWEEN, IN

· Suchen nach Zeichenketten: LIKE

· Negative Bedingungen: NOT

· Bilden von Gruppen: GROUP BY, HAVING

· Arithmetische Operationen

· Funktionen

· Set-Funktionen

· Datums- und Zeitberechnungen

· Umwandeln von Werten

· Verändern von Zeichenketten

· Informationen über Zeichenketten

· Subquery: Innere Abfragen

· Joins: Informationen aus mehreren Tabellen

· Mengenoperationen: UNION, INTERSECT, EXCEPT


Auswählen, Anordnen und Umbenennen von Spalten (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Auswählen, Anordnen und Umbenennen von Spalten

Bei der Datenanfrage ist eine Auswahl bestimmter Spalten, deren Anordnung und Umbenennung in der Ergebnistabelle möglich.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Auswählen bestimmter Spalten

Um Spalten aus einer Tabelle auszuwählen, geben Sie nach dem Schlüsselwort SELECT die gewünschten Spaltennamen an. Die Spaltennamen in dieser Liste sind durch Kommata voneinander zu trennen. Leerzeichen sind möglich, aber nicht notwendig.

SELECT firstname, name
FROM hotel.customer

Anzeige des Vor- und Nachnamens aller Kunden

Ergebnis

FIRSTNAME | NAME
Jenny | Porter
Peter | Brown
? | Datasoft
Rose | Brian
Mary | Griffith
Martin | Randolph
Sally | Smith
Mike | Jackson
Rita | Doe
George | Howe
Frank | Miller
Susan | Baker
Joseph | Peters
? | TOOLware
Antony | Jankins

Auswählen aller Spalten

Anstelle der Liste der Spaltennamen kann auch ein * angegeben werden.

SELECT *
FROM hotel.customer

Sie erhalten den Inhalt der gesamten Tabelle customer, wobei die Spalten in der beim Anlegen der Tabelle festgelegten Reihenfolge ausgegeben werden.

Anordnen von Spalten

Sie können die Spalten für die Ausgabe in einer von Ihnen gewünschten Reihenfolge anordnen. Geben Sie dazu nach dem Schlüsselwort SELECT die Spaltennamen in der gewünschten Reihenfolge an.

SELECT name, firstname
FROM hotel.customer

Anzeige des Namens und des Vornamens aller Kunden

Ergebnis

NAME | FIRSTNAME
Porter | Jenny
Brown | Peter
Datasoft | ?
Brian | Rose
Griffith | Mary
Randolph | Martin
Smith | Sally
Jackson | Mike
Doe | Rita
Howe | George
Miller | Frank
Baker | Susan
Peters | Joseph
TOOLware | ?
Jankins | Antony

Umbenennen von Spalten

Sie können die Spalten für die Ausgabe umbenennen.

SELECT zip, name city_name
FROM hotel.city
WHERE state = 'NY'

Anzeige der Postleitzahl und des Ortsnamens aller Orte im Staat NY

Ergebnis

ZIP | CITY_NAME
10019 | New York
10580 | New York
11788 | Long Island
12203 | Albany

Siehe auch:

SQL-Referenzhandbuch, Strukturlink QUERY-Ausdruck (query_expression), Strukturlink Selektierte Spalte (select_column), Strukturlink Tabellenausdruck (table_expression)

Weitere Beispiele zur Datenanfrage


Auswählen und Anordnen von Zeilen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Auswählen und Anordnen von Zeilen

Bei der Datenanfrage ist eine Auswahl bestimmter Zeilen und deren Anordnung möglich.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Auswählen bestimmter Zeilen

Für die Auswahl bestimmter Zeilen verwenden Sie die WHERE-Klausel.

SELECT zip, name
FROM hotel.city
WHERE name = 'Seattle'

Auswahl der Zeilen mit dem Ortsnamen Seattle

Ergebnis

ZIP | NAME
20005 | Seattle
20019 | Seattle
20037 | Seattle

Siehe auch:

SQL-Referenzhandbuch, Strukturlink WHERE-Klausel

SELECT ROWNO, cno, title, firstname, name
FROM hotel.customer
WHERE ROWNO <= 5

Auswahl der ersten fünf Zeilen und Nummerieren der Zeilen

Ergebnis

ROWNO | CNO | TITLE | FIRSTNAME | NAME
1 | 3000 | Mrs | Jenny | Porter
2 | 3100 | Mr | Peter | Brown
3 | 3200 | Company | ? | Datasoft
4 | 3300 | Mrs | Rose | Brian
5 | 3400 | Mrs | Mary | Griffith

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ROWNO-Prädikat (rowno_predicate)

Anordnen von Zeilen

Für die Anordnung von Zeilen verwenden Sie die ORDER-Klausel, die die Reihenfolge angibt, in der die Zeilen erscheinen sollen.

SELECT name, firstname
FROM hotel.customer
WHERE ROWNO <= 5
ORDER BY name

Sortieren der ersten 5 Zeilen in alphabetischer Reihenfolge nach dem Namen des Kunden

Ergebnis

NAME | FIRSTNAME
Brian | Rose
Brown | Peter
Datasoft | ?
Griffith | Mary
Porter | Jenny

SELECT name, firstname
FROM hotel.customer
WHERE ROWNO <= 5
ORDER BY name DESC

Sortieren der ersten 5 Zeilen in absteigender alphabetischer Reihenfolge nach dem Namen des Kunden

Ergebnis

NAME | FIRSTNAME
Porter | Jenny
Griffith | Mary
Datasoft | ?
Brown | Peter
Brian | Rose

Statt des Sortierspaltennamens kann auch die Posititionsnummer in der Ausgabeliste angegeben werden (anstelle von ORDER BY name DESC also ORDER BY 1 DESC).

Ist über eine Sortierspalte nichts weiter ausgesagt, bedeutet das immer eine aufsteigende Folge. Eine Sortierspalte muss nicht gleichzeitig eine Ausgabespalte sein.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ORDER-Klausel (order_clause)

Anordnen nach mehr als einer Spalte

Soll die Sortierreihenfolge mehrfach gestaffelt sein, geben Sie die Sortierspaltennamen in der Reihenfolge ihrer Wichtigkeit an. Jeder Name kann dabei den Zusatz ASC oder DESC erhalten. Dies ist auch gemischt möglich.

SELECT zip, name
FROM hotel.city
WHERE ROWNO < 5
ORDER BY name, zip DESC

Anzeige der Ortsdaten, sortiert nach dem Namen und absteigend nach den Postleitzahlen

Ergebnis

ZIP | NAME
12203 | Albany
11788 | Long Island
10580 | New York
10019 | New York

Anzeigen ohne doppelte Zeilen

Sie können bei einer Datenanfrage vermeiden, dass redundante Informationen angezeigt werden. Verwenden Sie dazu nach dem Schlüsselwort SELECT das Schlüsselwort DISTINCT.

SELECT DISTINCT name, state
FROM hotel.city
ORDER BY name

Anzeige der Ortsangaben, bestehend aus Name und Staat, die verschieden sind

Ergebnis

NAME | STATE
Albany | NY
Chicago | IL
Cincinnati | OH
Clearwater | FL
Dallas | TX
Daytona Beach | FL
Deerfield Beach | FL
Detroit | MI
Hollywood | CA
Irvine | CA
Long Beach | CA
Long Island | NY
Los Angeles | CA
New York | NY
Palm Spring | CA
Portland | OR
Rosemont | IL
Santa Clara | CA
Seattle | WA
Silver Spring | MD

Führen Sie zum Vergleich die SQL-Anweisung ohne das Schlüsselwort DISTINCT aus.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DISTINCT-Spezifikation (distinct_spec)

Siehe auch:

SQL-Referenzhandbuch, Strukturlink QUERY-Ausdruck (query_expression), Strukturlink Selektierte Spalte (select_column), Strukturlink Tabellenausdruck (table_expression)

Weitere Beispiele zur Datenanfrage


Bedingungen: Vergleich, AND, OR, BETWEEN, IN (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Bedingungen: Vergleich, AND, OR, BETWEEN, IN

Für die Auswahl von bestimmten Zeilen kann die WHERE-Klausel verwendet werden. In WHERE-Klauseln können Suchbedingungen angegeben werden. Einige dieser Bedingungen sollen hier vorgestellt werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

SQL-Referenzhandbuch, Strukturlink Prädikat (predicate)

Vergleichsbedingungen

SELECT title, name
FROM hotel.customer
WHERE title ='Company'

Auswahl der Kunden, die Firmen sind

Ergebnis

TITLE | NAME
Company | Datasoft
Company | TOOLware

SELECT firstname, name, zip
FROM hotel.customer
WHERE name > 'Randolph'

Auswahl der Kunden, die in alphabetischer Folge nach Randolph stehen

Ergebnis

FIRSTNAME | NAME | ZIP
Sally | Smith | 75243
? | TOOLware | 20019

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Vergleichsprädikat (comparison_predicate)

Mehrfachbedingungen: AND, OR

Wenn AND und OR gemischt werden, beachten Sie, dass AND eine höhere Priorität als OR hat. Sie sollten Klammern zur Verdeutlichung der gewünschten Mehrfachbedingungen setzen. Eine Mehrfachklammerung ist möglich. Die Auswertung erfolgt dann von der innersten zur äußersten Klammerung.

SELECT firstname, name, zip
FROM hotel.customer
WHERE (title ='Company') AND (name > 'Randolph')

Auswahl der Kunden, die in alphabetischer Folge nach Randolph stehen und eine Firma sind

Ergebnis

FIRSTNAME | NAME | ZIP
? | TOOLware | 20019

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Suchbedingung (search_condition)

Werte in einem Bereich: BETWEEN x AND y

SELECT title, name, zip
FROM hotel.customer
WHERE zip BETWEEN '10000' AND '30000'

Auswahl der Kunden, die in Städten mit einer Postleitzahl zwischen 10000 und 30000 wohnen

Ergebnis

TITLE | NAME | ZIP
Mrs | Porter | 10580
Mrs | Griffith | 20005
Company | TOOLware | 20019
Mr | Jenkins | 20903

Siehe auch:

SQL-Referenzhandbuch, Strukturlink BETWEEN-Prädikat (between_predicate)

Werte in einer Menge: IN (x,...)

Die Werte in der Klammer können in beliebiger Reihenfolge angegeben werden, da es sich um eine Menge von Werten handelt, aus der durch das IN-Prädikat ein Wert ausgewählt werden soll.

SELECT title, firstname, name
FROM hotel.customer
WHERE title IN ('Mr', 'Mrs')

Auswahl aller Kunden, die natürliche Personen (keine Firmen) sind

Ergebnis

TITLE | FIRSTNAME | NAME
Mrs | Jenny | Porter
Mr | Peter | Brown
Mrs | Rose | Brian
Mrs | Mary | Griffith
Mr | Martin | Randolph
Mrs | Sally | Smith
Mr | Mike | Jackson
Mrs | Rita | Doe
Mr | George | Howe
Mr | Frank | Miller
Mrs | Susan | Baker
Mr | Joseph | Peters
Mr | Antony | Jenkins

Siehe auch:

SQL-Referenzhandbuch, Strukturlink IN-Prädikat (in_predicate)

Weitere Beispiele zur Datenanfrage


Suchen nach Zeichenketten: LIKE (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Suchen nach Zeichenketten: LIKE

Für die Auswahl von bestimmten Zeilen kann die WHERE-Klausel verwendet werden. Sind nicht alle Zeichen eines Spaltenwertes bekannt, können auch unvollständige Suchwerte angegeben werden. Für diese Zwecke wird das LIKE-Prädikat angeboten.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele

SELECT firstname, name
FROM hotel.customer
WHERE name LIKE 'P%'

Auswahl der Kunden, deren Nachname mit P beginnt

Ergebnis

FIRSTNAME | NAME
Jenny | Porter
Joseph | Peters

SELECT firstname, name
FROM hotel.customer
WHERE name LIKE '%er'

Auswahl der Kunden, deren Nachname auf er endet

Ergebnis

FIRSTNAME | NAME
Jenny | Porter
Frank | Miller
Susan | Baker

SELECT firstname, name
FROM hotel.customer
WHERE firstname LIKE '_i__'

Auswahl der Kunden, deren Vorname 4 Zeichen lang ist und ein i an zweiter Stelle enthält

Ergebnis

FIRSTNAME | NAME
Mike | Jackson
Rita | Doe

SELECT firstname, name
FROM hotel.customer
WHERE name LIKE '_%an%'

Auswahl der Kunden mit einem an ab der zweiten Stelle im Nachnamen

Ergebnis

FIRSTNAME | NAME
Rose | Brian
Martin | Randolph

Siehe auch:

SQL-Referenzhandbuch, Strukturlink LIKE-Prädikat (like_predicate)

Weitere Beispiele zur Datenanfrage


Negative Bedingungen: NOT (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Negative Bedingungen: NOT

Um das Gegenteil einer Bedingung zu erreichen, müssen Sie das Schlüsselwort NOT vor den entsprechenden Ausdruck stellen. Wollen Sie einen zusammengesetzten Ausdruck negieren, so müssen Sie diesen in Klammern setzen.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Negieren eines Ausdrucks

SELECT name, state
FROM hotel.city
WHERE NOT (state = 'CA' OR state = 'WA' OR state = 'IL' OR state = 'NY')

Auswahl der Orte, die nicht in den Staaten CA, WA, IL und NY liegen

Ergebnis

NAME | STATE
Silver Spring | MD
Daytona Beach | FL
Deerfield Beach | FL
Clearwater | FL
Cincinnati | OH
Detroit | MI
New Orleans | LA
Dallas | TX
Portland | OR

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Suchbedingung (search_condition)

Bei Verwenden der Prädikate BETWEEN, IN, LIKE und NULL kann das NOT vor dem Prädikat oder unmittelbar vor dem entsprechenden Schlüsselwort (BETWEEN, IN, LIKE, NULL) stehen.

NOT BETWEEN

SELECT name, state
FROM hotel.city
WHERE NOT (state BETWEEN 'CA' AND 'NY')
oder
SELECT name, state
FROM hotel.city
WHERE state NOT BETWEEN 'CA' AND 'NY'

Auswahl der Orte, die nicht in den Staaten CA, FL, IL, LA, MD, MI und NY liegen

Ergebnis

NAME | STATE
Seattle | WA
Seattle | WA
Seattle | WA
Cincinnati | OH
Dallas | TX
Portland | OR

Siehe auch:

SQL-Referenzhandbuch, Strukturlink BETWEEN-Prädikat (between_predicate)

NOT IN

SELECT name, state
FROM hotel.city
WHERE NOT (state IN ('CA', 'IL', 'NY'))
oder
SELECT name, state
FROM hotel.city
WHERE state NOT IN ('CA', 'IL', 'NY')

Auswahl der Orte, die nicht in den Staaten CA, IL und NY liegen

Ergebnis

NAME | STATE
Seattle | WA
Seattle | WA
Seattle | WA
Silver Spring | MD
Daytona Beach | FL
Deerfield Beach | FL
Clearwater | FL
Cincinnati | OH
Detroit | MI
New Orleans | LA
Dallas | TX
Portland | OR

Siehe auch:

SQL-Referenzhandbuch, Strukturlink IN-Prädikat (in_predicate)

NOT LIKE

SELECT firstname, name
FROM hotel.customer
WHERE NOT (firstname LIKE '%e%')
oder
SELECT firstname, name
FROM hotel.customer
WHERE firstname NOT LIKE '%e%'

Auswahl der Kunden, deren Vorname kein e enthält

Ergebnis

FIRSTNAME | NAME
Mary | Griffith
Martin | Randolph
Sally | Smith
Rita | Doe
Frank | Miller
Susan | Baker
Antony | Jenkins

Siehe auch:

SQL-Referenzhandbuch, Strukturlink LIKE-Prädikat (like_predicate)

NOT NULL

SELECT firstname, name
FROM hotel.customer
WHERE NOT (firstname IS NULL)
oder
SELECT firstname, name
FROM hotel.customer
WHERE firstname IS NOT NULL

Auswahl der Kunden, die einen Vornamen haben, also keine Firmen sind

Ergebnis

FIRSTNAME | NAME
Jenny | Porter
Peter | Brown
Rose | Brian
Mary | Griffith
Martin | Randolph
Sally | Smith
Mike | Jackson
Rita | Doe
George | Howe
Frank | Miller
Susan | Baker
Joseph | Peters
Antony | Jenkins

Siehe auch:

SQL-Referenzhandbuch, Strukturlink NULL-Prädikat (null_predicate)

SQL-Referenzhandbuch, Strukturlink Prädikat (predicate)

Weitere Beispiele zur Datenanfrage


Bilden von Gruppen: GROUP BY, HAVING (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Bilden von Gruppen: GROUP BY, HAVING

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Gruppieren von Werten: GROUP BY

Mit Hilfe der GROUP-Klausel können Sie die Werte einer Spalte gruppieren und für jede dieser Gruppen gegebenenfalls weitere Berechnungen anhand der anderen Spaltenwerte durchführen. Außer für die zu gruppierende Spalte müssen Sie für jede andere Spalte eine Strukturlink Set-Funktion angeben. Die GROUP-Klausel müssen Sie nach der FROM- und WHERE-Klausel angeben.

SELECT type, SUM(free)
FROM hotel.room
GROUP BY type

Anzahl der freien Zimmer, gruppiert nach Zimmertyp

Die hier verwendete Set-Funktion ist die Funktion SUM, die die Summe der Werte bildet.

Ergebnis

Da die zweite Spalte der Ergebnistabelle keine vordefinierte Bezeichung erhält, wird vom Datenbanksystem die Spaltenbezeichnung EXPRESSION1 gewählt.

TYPE | EXPRESSION1
Double | 1088
Single | 376
Suite | 336

SELECT type, MIN(price) min_price, FIXED (AVG(price),5,2) avg_price, MAX(price) max_price
FROM hotel.room
GROUP BY type

Berechnen der Preiskategorien der Zimmer, gruppiert nach Zimmertyp

Die hier verwendeten Set-Funktionen sind MIN (minimaler Wert), AVG (Durchschnittswert) und MAX (Maximalwert).

Ergebnis

Die Spalten der Ergebnistabelle erhalten die Bezeichungen MIN_PRICE, AVG_PRICE und MAX_PRICE.

TYPE | MIN_PRICE | AVG_PRICE | MAX_PRICE
Double | 80 | 160.67 | 270
Single | 45 | 96.67 | 160
Suite | 300 | 475 | 700

Siehe auch:

Weitere Beispiele für die Angabe von Set-Funktionen

SQL-Referenzhandbuch, Strukturlink GROUP-Klausel

Gruppen mit Bedingungen: HAVING

Mit Hilfe der GROUP-Klausel können Sie die Werte einer Spalte gruppieren. Mit Hilfe der HAVING-Klausel können Sie anschließend Gruppen aus der Zwischenergebnistabelle ausschließen. Im Unterschied zum Verwenden der WHERE-Klausel für das Ausschließen von Werten, geht dem Gebrauch der HAVING-Klausel im Normalfall die Verwendung einer Set-Funktion, die sich auf eine gesamte Spalte einer Zwischenergebnistabelle bezieht, voraus.

SELECT type, MIN(price) min_price, FIXED(AVG(price),5,2) avg_price, MAX(price) max_price
FROM hotel.room
GROUP BY type
HAVING MIN(price) >= 70

Berechnen der Preiskategorien der Zimmer, gruppiert nach Zimmertyp, Anzeige nur der Zimmertypen, die Zimmer zum Preis von mindestens 80 Euro haben

Ergebnis

TYPE | MIN_PRICE | AVG_PRICE | MAX_PRICE
Double | 80 | 160.67 | 270
Suite | 300 | 475 | 700

Siehe auch:

SQL-Referenzhandbuch, Strukturlink HAVING-Klausel

Weitere Beispiele zur Datenanfrage


Arithmetische Operationen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Arithmetische Operationen

Sie können Ausdrücke mit arithmetischen Operationen (z.B. + für die Addition, - für die Subtraktion usw.) verwenden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Arithmetik in der Ergebnistabelle

Sie können mit Hilfe einer Datenanfrage nicht nur Daten ermitteln, die bereits in einer Tabelle vorhanden sind, sondern Sie können auch Werte anhand dieser Daten berechnen.

SELECT hno, price*7 weekly_price, type
FROM hotel.room
WHERE type = 'single' AND hno <50

Anzeige des Wochenpreises eines Einzelzimmers, die Anzeige wurde auf die Hotels mit einer Hotelnummer kleiner 50 beschränkt

Ergebnis

HNO | WEEKLY_PRICE | TYPE
10 | 945 | Single
20 | 490 | Single
30 | 315 | Single
40 | 595 | Single

Arithmetik in Suchbedingungen

In Suchbedingungen können Sie ebenfalls Ausdrücke mit arithmetischen Operationen verwenden.

SELECT hno, type, price
FROM hotel.room
WHERE price*7 < 500 AND type = 'single'

Auswahl der Hotels, deren Wochenpreis für ein Einzelzimmer unter 500,00 Euro liegt

Ergebnis

HNO | TYPE | PRICE
20 | Single | 70
30 | Single | 45
100 | Single | 60
110 | Single | 70

SELECT hno, type, price
FROM hotel.room
WHERE (price*1.05)*7 < 500 AND type = 'single'

Auswahl der Hotels, deren Wochenpreis für ein Einzelzimmer auch nach einer Preissteigerung um 5 Prozent unter 500,00 Euro liegt

Ergebnis

HNO | TYPE | PRICE
30 | Single | 45
100 | Single | 60

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Ausdruck (expression)

Weitere Beispiele zur Datenanfrage


Funktionen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Funktionen

Sie können Ausdrücke mit Funktionen verwenden. Dabei können die Funktionen auf die Daten der Ergebnistabelle angewendet oder in Suchbedingungen angegeben werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Erläuterungen

Funktionsbeschreibungen im Referenzhandbuch | Beispiele für diese Funktionsgruppe
Strukturlink Arithmetische Funktion (arithmetic_function) | TRUNC, SIGN, ABS
Strukturlink Trigonometrische Funktion (trigonometric_function) | SIN, ATAN, DEGREES
Strukturlink Stringfunktion (string_function) | SUBSTR, UPPER, MAPCHAR
Strukturlink Datumsfunktion (date_function) | SUBDATE, DAYOFMONTH, DAYNAME
Strukturlink Zeitfunktion (time_function) | ADDTIME, TIMEDIFF, MAKETIME
Strukturlink Extraktion (extraction_function) | DAY, TIMESTAMP, DATE
Strukturlink Spezialfunktion (special_function) | VALUE, LEAST, CASE-Funktion
Strukturlink Konversionsfunktion (conversion_function) | NUM, HEXTOROW, CHAR
Strukturlink Datenbankfunktionsaufruf (dbfunction_call) | Aufruf einer mit CREATE FUNCTION definierten Datenbankfunktion

Die Verwendung der meisten Funktionen ist selbsterklärend. Daher werden hier nur einige wenige ausgewählte Funktionen anhand von Beispielen vorgestellt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Ausdruck (expression)

SQL-Referenzhandbuch, Strukturlink Funktion (function_spec)

Stringfunktionen

Mit Hilfe der Stringfunktionen können Sie die Darstellung von Zeichenketten verändern.

SELECT cno, name & ', ' & firstname name
FROM hotel.customer WHERE cno = 3000

Vor- und Nachname werden miteinander verbunden.

Ergebnis

CNO | NAME
3000 | Porter, Jenny

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Verkettung (concatenation)

SELECT cno, SUBSTR(firstname,1,1) & '. ' & name name
FROM hotel.customer WHERE cno = 3000

Vor- und Nachname werden miteinander verbunden, wobei der Vorname nur verkürzt dargestellt wird.

Ergebnis

CNO | NAME
3000 | J. Porter

Siehe auch:

SQL-Referenzhandbuch, Strukturlink SUBSTR(x,a,b)

Datumsfunktionen

Datumsfunktionen werden auf Datums- oder Zeitstempelwerte angewendet bzw. liefern als Ergebnis einen Datums- oder Zeitstempelwert.

SELECT rno, arrival, DAYNAME(arrival) arrival_day FROM hotel.reservation WHERE rno < 150

Anzeige des Wochentages der Ankunft

Ergebnis

RNO | ARRIVAL | ARRIVAL_DAY
100 | 2004-11-13 | Saturday
110 | 2004-12-24 | Friday
120 | 2004-11-14 | Sunday
130 | 2005-02-01 | Tuesday
140 | 2004-04-12 | Monday

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DAYNAME/MONTHNAME(t)

Extraktionen

Mit Extraktionsfunktionen können Sie Teile von Datums-, Zeit- oder Zeitstempelwerten anzeigen lassen oder Datums-, Zeit- oder Zeitstempelwerte bilden.

SELECT name, 675456 number_of_days, DATE(675456) counted_date FROM hotel.city WHERE zip = '12203'

Anzeige, wann 675456 Tage nach dem 31.12.0000 vergangen sind

Ergebnis

NAME | NUMBER_OF_DAYS | COUNTED_DATE
Albany | 675456 | 1850-05-03

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DATE(a)

Allgemeine CASE-Funktion

Die allgemeine CASE-Funktion untersucht eine Reihe von Suchbedingungen und liefert für jede Suchbedingung ein Ergebnis.

SELECT hno,
CASE
WHEN price IS NULL THEN 'Not yet priced'
WHEN price < 70 THEN 'Very cheap'
WHEN price >= 70 AND price < 100 THEN 'Normal price'
ELSE 'Expensive hotel'
END price_range
FROM hotel.room WHERE hno < 100 AND type = 'single'

Einschätzung der Preisklassen einiger Hotels für Einzelzimmer

Ergebnis

HNO | PRICE_RANGE
10 | Expensive hotel
20 | Normal price
30 | Very cheap
40 | Normal price
50 | Expensive hotel
60 | Expensive hotel
70 | Expensive hotel
80 | Normal price
90 | Normal price

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Allgemeine CASE-Funktion (searched_case_function)

Einfache CASE-Funktion

Die einfache CASE-Funktion vergleicht einen Ausdruck mit einer Reihe von einfachen Ausdrücken, um jeweils einen Ergebnisausdruck zu bestimmen.

SELECT hno,
CASE price
WHEN NULL THEN 'Not yet priced'
WHEN 70 THEN 'Very cheap'
WHEN 90 THEN 'Cheap'
WHEN 100 THEN 'Normal hotel'
WHEN 115 THEN 'Expensive hotel'
WHEN 135 THEN 'Very expensive hotel'
ELSE 'Not yet in price_range list'
END price_range
FROM hotel.room WHERE hno < 100 AND type = 'single'

Vergleich der Preise einiger Hotels mit einer Bewertungsskala für Einzelzimmerpreise

Ergebnis

HNO | PRICE_RANGE
10 | Very expensive hotel
20 | Very cheap
30 | Not yet in price_range list
40 | Not yet in price_range list
50 | Not yet in price_range list
60 | Not yet in price_range list
70 | Expensive hotel
80 | Cheap
90 | Cheap

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Einfache CASE-Funktion (simple_case_function)

Datenbankfunktion

Voraussetzung für die Ausführung dieses Beispiels ist das Anlegen der Datenbankfunktion avgprice(zip), wie im Abschnitt Datendefinition ® Datenbankfunktionen beschrieben.

SELECT hno, avgprice(zip) avgprice FROM hotel.hotel WHERE hno = 40

Ergebnis

HNO | AVGPRICE
40 | 87.5

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Datenbankfunktionsaufruf (dbfunction_call)

Weitere Beispiele zur Datenanfrage


Set-Funktionen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Set-Funktionen

Das Datenbanksystem verfügt über Funktionen, die spaltenweise über mehrere Zeilen arbeiten, die Set-Funktionen. Im Einzelnen sind folgende Set-Funktionen möglich: AVG, COUNT, MAX, MIN, STDDEV, SUM und VARIANCE.

Set-Funktionen arbeiten über Gruppen von Zahlen, aber sie geben nur einen Wert zurück. Das Ergebnis besteht also aus einer Zeile. Wenn eine Set-Funktion in einer Datenanfrage verwendet wird, muss auch auf jede andere Spalte der Anfrage eine solche Funktion angewandt werden. Dies gilt jedoch nicht für eine Spalte, über die mittels GROUP BY eine Gruppierung vorgenommen wurde. Es wird dann für jede Gruppe der Wert der Set-Funktion bestimmt (siehe dazu: Bilden von Gruppen: GROUP BY, HAVING).

NULL-Werte werden, mit Ausnahme bei COUNT(*), nicht in die Berechnung einer Set-Funktion einbezogen.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele

SELECT COUNT(*) number
FROM hotel.customer

Anzahl der Kunden

Ergebnis

NUMBER

15

SELECT COUNT(DISTINCT name) number_city
FROM hotel.city

Anzahl der verschiedenen Orte

Ergebnis

NUMBER_CITY

21

SELECT SUM(price) sum_price, MIN(price) min_price, FIXED(AVG(price),5,2) avg_price, MAX(price) max_price, COUNT(*) number_room
FROM hotel.room
WHERE type = 'single'

Auswertungen der Preise der Einzelzimmer: Summe aller Preise, minimaler Preis, Durchschnittspreis, maximaler Preis, Anzahl der Einzelzimmer

Ergebnis

SUM_PRICE | MIN_PRICE | AVG_PRICE | MAX_PRICE | NUMBER_ROOM
1450 | 45 | 96.67 | 160 | 15

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Ausdruck (expression)

SQL-Referenzhandbuch, Strukturlink Set-Funktion (set_function_spec)

Weitere Beispiele zur Datenanfrage


Datums- und Zeitberechnungen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Datums- und Zeitberechnungen

Um den Umgang mit Datums- und Zeitberechnungen zu erleichtern, sind eine Reihe von Funktionen verfügbar, die mit Werten dieser Datentypen Berechnungen durchführen können.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele

SELECT arrival, ADDDATE (arrival,2) new_arrival, rno
FROM hotel.reservation
WHERE rno = 130

Erhöhen des Buchungsdatums um zwei Tage

Ergebnis

ARRIVAL | NEW_ARRIVAL | RNO
2005-02-01 | 2005-02-03 | 130

SELECT arrival, departure, DATEDIFF(departure, arrival) overnight_stays, rno
FROM hotel.reservation
WHERE rno = 130

Anzahl der Übernachtungen

Ergebnis

ARRIVAL | DEPARTURE | OVERNIGHT_STAYS | RNO
2005-02-01 | 2005-02-03 | 2 | 130

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Datumsfunktion (date_function), Strukturlink Zeitfunktion (time_function), Strukturlink Extraktion (extraction_function)

Zur Bearbeitung von Datumswerten stehen verschiedene Datumsformate zur Verfügung: EUR, INTERNAL, ISO, JIS und USA.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Datums- und Zeitformat (datetimeformat)

Weitere Beispiele zur Datenanfrage


Umwandeln von Werten (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Umwandeln von Werten

Für verschiedene Anwendungsfälle kann es nötig sein, Werte in eine andere Darstellung umzuwandeln, weil der verwendete Operator nur mit einer bestimmten Darstellung der Werte umgehen kann.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Im SQL-Referenzhandbuch werden folgende Funktionen für diese Zwecke beschrieben: Strukturlink CHR(a,n), Strukturlink NUM(a), Strukturlink UPPER/LOWER(x), Strukturlink ASCII(x), Strukturlink MAPCHAR(x,n,i), Strukturlink ALPHA(x,n), Strukturlink HEX(a), Strukturlink CHAR(a,t), Strukturlink SOUNDEX(x), Strukturlink VALUE(x,y,...), Strukturlink DECODE(x,y(i),...,z)

Beispiele

SELECT * FROM hotel.hotel
WHERE CHR(hno) LIKE '1__'

Anzeige der Hotelangaben, deren Nummer dreistellig ist und mit 1 beginnt. Die Hotelnummer wird für diese Zwecke in Zeichenwerte umgewandelt.

Ergebnis

HNO | NAME | ZIP | ADDRESS
100 | Beach | 32018 | 1980 34th St.
110 | Atlantik | 33441 | 111 78th St.
120 | Long Beach | 90804 | 35 Broadway
130 | Star | 90029 | 13 Beechwood Place
140 | River Boat | 70112 | 788 MAIN STREET
150 | Indian Horse | 92262 | 16 MAIN STREET

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CHR(a,n)

SELECT * FROM hotel.hotel
WHERE UPPER(name) = 'STAR'

Anzeige des Hotelnamens unabhängig von der Groß-/Kleinschreibung

Ergebnis

HNO | NAME | ZIP | ADDRESS
130 | Star | 90029 | 13 Beechwood Place

Siehe auch:

SQL-Referenzhandbuch, Strukturlink UPPER/LOWER(x)

SELECT VALUE(firstname, 'Company') firstname, name
FROM hotel.customer
WHERE firstname IS NULL

Anzeige der Firmennamen, wobei der NULL-Wert durch die Bezeichnung Company ersetzt werden soll

Ergebnis

FIRSTNAME | NAME
Company | Datasoft
Company | Toolware

Siehe auch:

SQL-Referenzhandbuch, Strukturlink VALUE(x,y,...)

SELECT hno, price, DECODE(type, 'single', 1, 'double', 2, 'suite', 3) code
FROM hotel.room
WHERE hno < 60

Anzeige der Hotelzimmer mit anderer Bezeichnung für die Zimmertypen

Ergebnis

HNO | PRICE | CODE
10 | 200 | 2
10 | 135 | 1
20 | 100 | 2
20 | 70 | 1
30 | 80 | 2
30 | 45 | 1
40 | 140 | 2
40 | 85 | 1
50 | 180 | 2
50 | 105 | 1
50 | 500 | 3

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DECODE(x,y(i),...,z)

Weitere Beispiele zur Datenanfrage


Verändern von Zeichenketten (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Verändern von Zeichenketten

Es gibt eine Reihe von Operationen mit Zeichenketten.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Verkettung

CHAR-Spalten können mit dem Operator & verkettet werden.

SELECT name & ', ' & firstname name, zip
FROM hotel.customer
WHERE cno < 3500

Nachname und Vorname sollen gemeinsam ausgegeben werden.

Ergebnis

NAME | ZIP
Porter, Jenny | 10580
Brown, Peter | 48226
? | 90019
Brian, Rose | 75243
Griffith, Mary | 20005

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Verkettung (concatenation)

Entfernen und Einfügen von Zeichen

Für das Entfernen und Einfügen von Zeichen stehen die Funktionen TRIM, LTRIM und RTRIM zur Verfügung.

SELECT RTRIM(title,'any') title, name
FROM hotel.customer
WHERE title = 'Company'

Angabe eines verkürzten Firmentitels

Ergebnis

TITLE | NAME
Comp | Datasoft
Comp | TOOLware

Siehe auch:

SQL-Referenzhandbuch, Strukturlink TRIM(x,y), Strukturlink LTRIM(x,y), Strukturlink RTRIM(x,y)

Verkürzung von Werten

SELECT title, SUBSTR(firstname,1,1)& '. '&name name
FROM hotel.customer
WHERE firstname IS NOT NULL

Angabe eines verkürzten Vornamens, der mit dem Nachnamen verkettet wird

Ergebnis

TITLE | NAME
Mrs | J. Porter
Mr | P. Brown
Mrs | R. Brian
Mrs | M. Griffith
Mr | M. Randolph
Mrs | S. Smith
Mr | M. Jackson
Mrs | R. Doe
Mr | G. Howe
Mr | F. Miller
Mrs | S. Baker
Mr | J. Peters
Mr | A. Jenkins

Siehe auch:

SQL-Referenzhandbuch, Strukturlink SUBSTR(x,a,b)

Verschieben von Werten

Mit den Funktionen LFILL bzw. RFILL können Werte vom Typ CHAR auf eine vorgegebene Länge mit einem beliebig wählbaren Zeichen aufgefüllt werden.

SELECT LFILL(firstname,' ',10) firstname, name
FROM hotel.customer
WHERE firstname IS NOT NULL AND title = 'Mrs'

Angabe eines nach Rechts verschobenen Vornamens, insgesamt sollen Vorname und Leerzeichen eine Zeichenkette der Länge 10 ergeben

Ergebnis

FIRSTNAME | NAME
Jenny | Porter
Rose | Brian
Mary | Griffith
Sally | Smith
Rita | Doe
Susan | Baker

Siehe auch:

SQL-Referenzhandbuch, Strukturlink LFILL(x,a,n), Strukturlink RFILL(x,a,n)

Strukturlink EXPAND(x,n)erweitert eine Zeichenkette um eine angegebene Zahl von Leerzeichen.

Ersetzungen in Zeichenketten

Die Funktion REPLACE ersetzt in der angegebenen Spalte einer Zeichenkette durch eine andere.

SELECT hno, zip, REPLACE(address,'St.','Street') address
FROM hotel.hotel
WHERE zip < '40000'

Angabe der Adresse nicht mit der Abkürzung Str., sondern mit Street

Ergebnis

HNO | ZIP | ADDRESS
10 | 20005 | 155 Beechwood Street
20 | 11788 | 1499 Grove Street
30 | 20037 | 477 17th Avenue
40 | 10019 | 112 8th Avenue
70 | 12203 | 65 Yellowstone Dr.
80 | 10019 | 12 Barnard Street
90 | 33575 | 200 Yellowstone Dr.
100 | 32018 | 1980 34th Street
110 | 33441 | 111 78th Street

Die Funktion TRANSLATE ersetzt in der angegebenen Spalte einzelne Buchstaben durch andere Buchstaben. Dabei wird bei jedem Auftreten der i-te Buchstabe der ersten Zeichenkette durch den i-ten Buchstaben der zweiten Zeichenkette ersetzt.

SELECT name, TRANSLATE(name,'ae','xy') name_new
FROM hotel.customer
WHERE cno > 4000

Die Buchstaben a und e sollen durch x und y ersetzt werden.

Ergebnis

NAME | NAME_NEW
Baker | Bxkyr
Peters | Pytyrs
TOOLware | TOOLwxry
Jenkins | Jynkins

Siehe auch:

SQL-Referenzhandbuch, Strukturlink REPLACE(x,y,z), Strukturlink TRANSLATE(x,y,z)

Weitere Beispiele zur Datenanfrage


Informationen über Zeichenketten (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Informationen über Zeichenketten

Sie können eine Reihe von Informationen über eine Zeichenkette erhalten.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Bestimmen der Zeichenzahl

SELECT name, LENGTH(name) len
FROM hotel.customer
WHERE title = 'Mrs' ORDER BY len, name

Ein Teil der Kundentabelle wird nach der Länge der Nachnamen sortiert, bei gleicher Namenslänge alphabetisch aufsteigend

Ergebnis

NAME | LEN
Doe | 3
Baker | 5
Brian | 5
Smith | 5
Porter | 6
Griffith | 8

Siehe auch:

SQL-Referenzhandbuch, Strukturlink LENGTH(a)

Vereinheitlichen der Schreibweisen

Die Funktion INITCAP liefert, wenn sie auf eine Zeichenkette angewendet wird, eine Zeichenkette, in der jeweils der erste Buchstabe eines Wortes in Groß- und alle weiteren in Kleinbuchstaben erschienen. Dies kann beispielsweise zur Vereinheitlichung der Schreibweisen von Namen verwendet werden.

SELECT name, INITCAP(name) name_new
FROM hotel.customer
WHERE firstname IS NULL

Ergebnis

NAME | NAME_NEW
Datasoft | Datasoft
TOOLware | Toolware

Siehe auch:

SQL-Referenzhandbuch, Strukturlink INITCAP(x)

Suchen der Postition von Zeichenketten

Die Funktion INDEX liefert die Position einer vorgegebenen Teilzeichenkette in der Zeichenkette. Optional kann über einen dritten Parameter in der Funktion INDEX die Anfangsposition für die Suche und über eine vierten Parameter angegeben werden, nach dem wievielten Auftreten der Teilzeichenkette gesucht werden soll.

SELECT name, INDEX(name,'er') position_er
FROM hotel.customer
WHERE title = 'Mrs'

Für einen Teil der Kundentabelle soll im Nachnamen die Position der Zeichenkette ‘er’ bestimmt werden.

Ergebnis

NAME | POSITION_ER
Porter | 5
Brian | 0
Griffith | 0
Smith | 0
Doe | 0
Baker | 4

Siehe auch:

SQL-Referenzhandbuch, Strukturlink INDEX(a,b,p,s)

Bestimmen von Minimum und Maximum in Zeichenketten

Die Funktionen MAX und MIN können auch auf Zeichenketten angewendet werden.

SELECT title, MIN(name) min_name
FROM hotel.customer
GROUP BY title

Es wird derjenige Kunde (männlich, weiblich oder Firma) gesucht, dessen Nachname mit dem, bezogen auf den gewählten Code, „kleinsten“ Buchstaben beginnt. Stimmen die Anfangsbuchstaben überein, wird der Vergleich auf die nachfolgenden Zeichen ausgedehnt.

Ergebnis

TITLE | MIN_NAME
Company | Datasoft
Mr | Brown
Mrs | Baker

Siehe auch:

SQL-Referenzhandbuch, Strukturlink MAX/MIN

Um eine sinnvolle alphabetische Sortierung insbesondere von Umlauten zu erreichen, sollte jedoch die Funktion Strukturlink MAPCHAR(x,n,i) verwendet werden.

Die Funktionen Strukturlink GREATEST/LEAST(x,y,...) erlauben es, aus einer Liste von angegebenen Werten den größten bzw. kleinsten Wert herauszusuchen. Sie können auch auf Zeichenketten angewendet werden. GREATEST ('Mary', 'Mike', 'Martin') würde Mike als Ergebnis liefern.

Siehe auch:

Weitere Beispiele zur Datenanfrage


Subquery: Innere Abfragen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Subquery: Innere Abfragen

In eine SELECT-Anweisung kann eine zweite SELECT-Anweisung ( Strukturlink Subquery (subquery)) eingeschlossen werden. Durch die Subquery wird ein Wert oder eine Menge von Werten als Teil der Hauptanweisung erzeugt.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele

SELECT name, zip
FROM hotel.customer
WHERE zip = (SELECT MAX(zip) FROM hotel.customer)

Anzeige des Kunden mit der grössten Postleitzahl

Ergebnis

NAME | ZIP
Doe | 97213

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Vergleichsprädikat (comparison_predicate)

SELECT hno, name, zip
FROM hotel.hotel
WHERE zip IN(SELECT zip FROM hotel.customer WHERE title = 'Mrs')

Anzeige der Hotels, die in Orten liegen, in denen auch weibliche Kunden wohnen

Ergebnis

HNO | NAME | ZIP
10 | Congress | 20005

Siehe auch:

SQL-Referenzhandbuch, Strukturlink IN-Prädikat (in_predicate)

SELECT hno, name
FROM hotel.hotel
WHERE name = ANY(SELECT name FROM hotel.city)

Anzeige der Hotels, die dieselben Namen haben wie irgendwelche Orte in der Ortstabelle. Die innere Abfrage ermittelt die Ortsnamenliste, mit der die Hotelnamen verglichen werden.

Ergebnis

HNO | NAME
20 | Long Island
120 | Long Beach

SELECT cno, name
FROM hotel.customer
WHERE cno = ANY(SELECT cno FROM hotel.reservation WHERE arrival > '2005-01-01')

Anzeige der Kunden, die alle Buchungen ab einem vorgegebenen Datum getätigt haben

Ergebnis

CNO | NAME
3600 | Smith
3900 | Howe

Verwenden Sie ANY, wenn die Subquery mehr als einen Wert ergibt und das in der Bedingung der WHERE-Klausel berücksichtigt werden soll, die normalerweise genau einen Wert verlangt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Mengenvergleichsprädikat (quantified_predicate)

Correlated Subquery

Mit Hilfe von Correlated Subqueries lassen sich Bedingungen zur Zeilenauswahl formulieren, die nicht für alle Zeilen einer Tabelle, sondern nur für Gruppen von Zeilen gelten sollen.

Subqueries werden nur einmal ausgewertet. Correlated Subqueries hingegen werden für jede Zeile der äußeren Tabelle ausgewertet, bei geschachtelten Subqueries von innen nach außen.

SELECT hno, type, price
FROM hotel.room room_table
WHERE price =
(SELECT MAX(price) FROM hotel.room WHERE type = room_table.type)

Anzeige der Hotels (in Form der Hotelnummer), deren Zimmer in den einzelnen Typen (Einzel, Doppel, Suite) den höchsten Preis haben

Da in diesem Beispiel in der äußeren SELECT-Anweisung und in der Subquery die gleiche Tabelle angesprochen wird, muss ein Referenzname (room_table) vergeben werden. Eine Zeile aus dem Ergebnis der äußeren SELECT-Anweisung wird mit einem Wert in der Subquery verknüpft (korreliert).

Erläuterung

● SELECT hno, type, price FROM hotel.room room_table
Suche Hotelnummer, Zimmertyp, Preis aus der Tabelle room und benenne diese Tabelle in room_table um.

● WHERE price=
Behalte die Zeile, in der der Preis gleich dem Ergebnis der folgenden Subquery ist:

● (SELECT MAX(price) FROM hotel.room
(Beginn der Subquery) Suche den maximalen Preis aus der Tabelle room

● WHERE type = room_table.type)
wobei die Zimmertypen gleich den Zimmertypen der oben gefundenen Zeilen sein soll

Ergebnis

HNO | TYPE | PRICE
130 | double | 270
130 | single | 160
130 | suite | 700

SELECT cno, title, name FROM hotel.customer
WHERE EXISTS
(SELECT * FROM hotel.reservation
WHERE hotel.customer.cno = hotel.reservation.cno)

Anzeige nur der Kunden aus der Kundentabelle, für die eine oder mehrere Buchungen vorliegen

Ergebnis

CNO | TITLE | NAME
3000 | Mrs | Porter
3100 | Mr | Brown
3200 | Company | Datasoft
3600 | Mrs | Smith
3900 | Mr | Howe
4100 | Mrs | Baker
4300 | Company | TOOLware
4400 | Mr | Jenkins

Verwenden Sie EXISTS, wenn die Subquery nur herausfinden soll, ob eine Zeile existiert, die eine bestimmte Bedingung erfüllt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink EXISTS-Prädikat (exists_predicate)

Weitere Beispiele zur Datenanfrage


Joins: Informationen aus mehreren Tabellen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Joins: Informationen aus mehreren Tabellen

Zur Beantwortung mancher Anfragen müssen mehrere Tabellen durchsucht werden. Die Verbindung zwischen diesen Tabellen wird über Spalten hergestellt, die in mehreren Tabellen erscheinen. Eine solche Anweisung wird als Join bezeichnet.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele

SELECT reservation.rno, customer.name, reservation.arrival, reservation.departure
FROM hotel.customer, hotel.reservation
WHERE customer.name = 'Porter'
AND customer.cno = reservation.cno

Anzeige, ob und wann für den Kunden Porter eine Buchung vorliegt.

Ergebnis

RNO | NAME | ARRIVAL | DEPARTURE
100 | Porter | 2004-11-13 | 2004-11-15
110 | Porter | 2004-12-24 | 2005-01-06

Die Verknüpfung der beiden Tabellen erfolgt über die Kundennummer, d.h. es werden nur die Zeilen ausgewählt, die den Name Porter enthalten und für die die Kundennummern übereinstimmen. Als Operatoren in der WHERE-Klausel sind =, <, <=, >, >= und <> möglich.

Die Gesamtergebniszeile wird aus den gewünschten Spalten der jeweiligen Tabelle zusammengesetzt. Wenn Spalten in zwei verschiedenen Tabellen denselben Namen haben, muss in der Anweisung vor dem Spaltennamen der Tabellenname angegeben werden, wobei beide durch einen Punkt verbunden werden.

SELECT customer.name, reservation.rno, hotel.name hotel_name
FROM hotel.customer, hotel.reservation, hotel.hotel
WHERE customer.name = 'Porter'
AND customer.cno=reservation.cno
AND reservation.hno = hotel.hno

Anzeige aller Hotels, die der Kunder Porter gebucht hat. Dazu müssen die Tabellen customer, reservation und hotel verkettet werden.

Ergebnis

NAME | RNO | HOTEL_NAME
Porter | 100 | Midtown
Porter | 110 | Beach

Outer-Join

Zunächst noch einmal ein Join-Beispiel:

SELECT hotel.name hotel_name, city.zip, city.name city_name
FROM hotel.hotel, hotel.city
WHERE city.state = 'CA' AND city.zip=hotel.zip

Anzeige der Städte des Staates CA, für die Hotels in der Hoteltabelle angegeben sind

Ergebnis

HOTEL_NAME | ZIP | CITY_NAME
Long Beach | 90804 | Long Beach
Star | 90029 | Hollywood
Indian Horse | 92262 | Palm Springs

Wenn Sie jetzt alle Städtenamen angezeigt bekommen wollen, unabhängig davon ob für diese Stadt ein Hotel angegeben ist, so können Sie einen Outer-Join verwenden.

Ein Outer-Join wird durch den Operator (+) gekennzeichnet.

SELECT hotel.name hotel_name, city.zip, city.name city_name
FROM hotel.hotel, hotel.city
WHERE city.state = 'CA' AND city.zip=hotel.zip (+)

Anzeige der Städte des Staates CA, für die Hotels in der Hoteltabelle angegeben sind

Ergebnis

HOTEL_NAME | ZIP | CITY_NAME
Long Beach | 90804 | Long Beach
Star | 90029 | Hollywood
Indian Horse | 92262 | Palm Springs
? | 90018 | Los Angeles
? | 92714 | Irvine
? | 95054 | Santa Clara

Es wird eine Liste aller Städte des Staates CA angezeigt. Für die Städte, für die es keine Hoteleinträge gibt, wird der Hotelname mit einem NULL-Wert belegt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink JOIN-Prädikat (join_predicate)

Weitere Beispiele zur Datenanfrage


Mengenoperationen: UNION, INTERSECT, EXCEPT (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Mengenoperationen: UNION, INTERSECT, EXCEPT

Es gibt eine Reihe von Möglichkeiten, Ergebnisse aus mehreren Ergebnistabellen miteinander in Beziehung zu setzen und daraus eine neue Ergebnistabelle zu erzeugen.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

UNION

Die UNION-Anweisung erlaubt es Ihnen, aus mehreren SELECT-Anweisungen eine Vereinigungsmenge der einzelnen Ergebnistabellen zu erzeugen.

Im einfachsten Fall können Sie zwei Ergebnistabellen, die aus der gleichen Basistabelle gebildet wurden, miteinander verknüpfen.

Mit Hilfe der UNION-Anweisung können Sie auch Ergebnistabellen kombinieren, die aus unterschiedlichen Tabellen gebildet wurden. Es muss dabei jedoch gewährleistet sein, dass die Datentypen der jeweiligen i-ten Ausgabespalten vergleichbar sind. Eine Gleichheit ist nicht erforderlich, da gegebenenfalls die maximale Länge genutzt wird.

SELECT zip customer_zip FROM hotel.customer WHERE zip > '90000'

SELECT zip hotel_zip FROM hotel.hotel WHERE zip> '90000'

Anzeige der Postleitzahlen größer 90000.

Ergebnistabellen

CUSTOMER_ZIP | HOTEL_ZIP
90018 | 90804
97213 | 90029
95054 | 92262
90018 |
92714 |

SELECT zip FROM hotel.customer WHERE zip > '90000'
UNION
SELECT zip FROM hotel.hotel WHERE zip > '90000'

Anzeige aller Postleitzahlen aus der Kunden- und der Hoteltabelle, die größer als 90000 sind.

Ergebnis

ZIP

90018

90029

92262

90804

97213

92714

95054

Mehrmals auftauchende Postleitzahlen werden nur einmal angezeigt, da das Datenbanksystem implizit ein DISTINCT durchführt.

Sollen alle Postleitzahlen in der Häufigkeit ihres Auftretens angezeigt werden, so verwenden Sie UNION ALL.

SELECT hno hno_or_cno, name hotel_or_customer_name, zip
FROM hotel.hotel WHERE zip < '30000'
UNION
SELECT cno, name, zip
FROM hotel.customer WHERE zip < '30000'

Anzeige aller Orte, in denen sich entweder ein Hotel befindet oder einer der Kunde wohnt

Ergebnis

HNO_OR_CNO | HOTEL_OR_CUSTOMER_NAME | ZIP
3000 | Porter | 10580
30 | Regency | 20037
4300 | TOOLware | 20019
4400 | Jenkins | 20903
10 | Congress | 20005
3400 | Griffith | 20005
80 | Midtown | 10019
20 | Long Island | 11788
70 | Empire State | 12203
40 | Eighth Avenue | 10019

INTERSECT

Mittels INTERSECT können Sie eine Schnittmenge erzeugen.

SELECT zip FROM hotel.customer WHERE zip < '30000'

INTERSECT

SELECT zip FROM hotel.hotel WHERE zip < '30000'

Anzeige der Postleitzahlen, die in beiden Tabellen verwendet werden.

Ergebnis

ZIP

20005

Ohne zusätzliche Angabe von ALL wird auch hier ein implizites DISTINCT durchgeführt.

EXCEPT

Mittels EXCEPT können Sie Ergebnisse aus einer Ergebnistabelle von einer anderen abziehen. Dabei ist die Angabe der Reihenfolge der SELECT-Anweisungen wichtig.

SELECT zip FROM hotel.hotel WHERE zip < '30000'

EXCEPT

SELECT zip FROM hotel.customer WHERE zip < '30000'

Anzeige nur der Postleitzahlen aus der Hoteltabelle, die nicht in der Kundentabelle vorkommen.

Ergebnis

ZIP

12203

10019

20037

11788

Bevor das EXCEPT wirksam wird, wird implizit ein DISTINCT durchgeführt.

Möchten Sie erreichen, dass auch die Anzahl der in den einzelnen Ergebnistabellen gefundenen Zeilen in Betracht gezogen wird, verwenden Sie jeweils <UNION|INTERSECT|EXCEPT> ALL.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink QUERY-Ausdruck (query_expression)

Weitere Beispiele zur Datenanfrage


Datendefinition (SAP-Bibliothek - Tutorials)

Hintergrunddokumentation Datendefinition

Eine vollständige Syntaxbeschreibung der SQL-Anweisungen zur Datendefinition erhalten Sie im SQL-Referenzhandbuch im Abschnitt Strukturlink Datendefinition.

Im folgenden sollen einige wesentliche SQL-Anweisungen zur Datendefinition anhand von Beispielen vorgestellt werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool Strukturlink SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele

● Tabellen

● Constraints

● Primärschlüssel

● Fremdschlüsselbeziehungen zwischen Tabellen

● View-Tabellen

● Indizes

● Wertebereiche

● Datenbankprozeduren

● Datenbankfunktionen

● Datenbanktrigger

● Nummerngeneratoren für Tabellen

● Nummerngenerator für eine einzelne Spalte einer Tabelle


Tabellen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Tabellen

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen einer Tabelle

Zum Anlegen einer Tabelle verwenden Sie die CREATE TABLE-Anweisung.

CREATE TABLE
hotel.person
(pno       FIXED(6),
name      CHAR(20),
city      CHAR(20))

Der Name der Tabelle, person, wird nach den Schlüsselworten CREATE TABLE angegeben. Die Tabelle person soll im Schema hotel angelegt werden.

In der Liste der Spaltendefinitionen müssen für jede Spalte deren Name und Datentyp angegeben werden. Die Liste der Spaltendefinitionen wird in Klammern eingeschlossen.

● Die Tabelle person enthält Spalten mit den folgenden Namen: pno, name, city

● Die Spalten haben folgende Datentypen: pno FIXED(6), name und city jeweils CHAR(20)

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE TABLE-Anweisung (create_table_statement)

SQL-Referenzhandbuch, Strukturlink Spaltenname (column_name)

SQL-Referenzhandbuch, Strukturlink Datentyp (data_type)

Datenintegrität

Die Tabelle person ist eine sehr einfache Tabelle. Eingabebeschränkungen für Werte in die Spalten der Tabelle person gibt es nur insofern, dass die Datentypen vorgegeben sind. In der Realität sind weitere Angaben, Beschränkungen und Objekte zur Wahrung der Datenintegrität üblich, z.B. Constraints, Primärschlüssel, Wertebereiche, Datenbankprozeduren, Datenbanktrigger.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Datenintegrität absichern

Ändern einer Tabelle

Die Definition einer Tabelle kann während des Datenbankbetriebs mit Hilfe der ALTER TABLE-Anweisung verändert werden.

ALTER TABLE hotel.person
 ADD (code FIXED(5), fon FIXED(8))

Der Personentabelle werden Spalten für die Telefonvorwahl und -nummer hinzugefügt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ADD-Definition (add_definition)

ALTER TABLE hotel.person
 DROP (code)

In der Kundentabelle wird die Spalte für die Telefonvorwahl wieder gelöscht.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP-Definition (drop_definition)

ALTER TABLE hotel.person
 MODIFY fon FIXED(10)

In der Kundentabelle wird die Spaltendefinition geändert. Die Neudefinition wird nur dann durchgeführt, wenn ihr die bereits gespeicherten Werte entsprechen.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink MODIFY-Definition (modify_definition)

Weitere Änderungen an bereits vorhandenen Tabellen sind möglich.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER TABLE-Anweisung (alter_table_statement)

Umbenennen einer Tabelle

Zum Umbenennen einer Tabelle verwenden Sie die RENAME TABLE-Anweisung.

RENAME TABLE hotel.person TO member

Umbenennen der Tabelle person in member

Siehe auch:

SQL-Referenzhandbuch, Strukturlink RENAME TABLE-Anweisung (rename_table_statement)

Löschen einer Tabelle

Zum Löschen einer Tabelle verwenden Sie die DROP TABLE-Anweisung.

DROP TABLE hotel.member

Mit Hilfe dieser SQL-Anweisung löschen Sie die Tabellendefinition, den Inhalt der Tabelle und alle abhängigen Objekte (z.B. View-Tabellen, Indizes). Das Löschen der Tabelle kann nur durch den Eigentümer der Tabelle erfolgen.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP TABLE-Anweisung (drop_table_statement)

Weitere Beispiele zur Datendefinition


Constraints (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Constraints

Der Wertebereich des Datentyps einer Spalte kann mit Hilfe von sogenannten Constraints zusätzlich eingegrenzt werden.

In einer CONSTRAINT-Definition kann bis auf wenige Einschränkungen alles formuliert werden, was auch als Suchbedingung gilt. Mehrere Bedingungen können durch die Operatoren AND, OR und NOT verknüpft werden. Es können beliebig viele Spalten angesprochen werden. Dabei ist jedoch zu beachten, dass Constraints die Geschwindigkeit des Datenbanksystems bei Änderungen an Einträgen der Tabelle herabsetzen.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

SQL-Referenzhandbuch, Strukturlink CONSTRAINT-Definition (constraint_definition)

Anlegen eines Constraint

Sie können ein Constraint direkt bei der Tabellendefinition angeben oder nachträglich zu einer vorhandenen Tabelle hinzufügen.

Einfache Constraints

Sie können Constraints formulieren, die sich nur auf eine Spalte der Tabelle beziehen.

Sie können die CREATE TABLE-Anweisung verwenden, um Constraints beim Anlegen einer Tabelle zu definieren.

...

1. Löschen Sie gegebenenfalls die Tabelle city.
DROP TABLE hotel.city

2. Legen Sie die Tabelle city wie folgt an:
CREATE TABLE hotel.city
(zip CHAR(5) PRIMARY KEY CONSTRAINT zip_cons CHECK
SUBSTR(zip,1,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,2,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,3,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,4,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,5,1) BETWEEN '0' AND '9',
name CHAR(30) NOT NULL,
state CHAR(2) NOT NULL)

Die Tabelle city wurde mit einem einfachen Constraint auf der Postleitzahlenspalte angelegt. Dieses Constraint bewirkt, dass für die Postleitzahl nur Ziffern von 0 bis 9 eingegeben werden können. Andere Zeichen werden bei der Dateneingabe abgewiesen.

Die Spezifizierung von NOT NULL bewirkt, dass einer Spalte ein Wert zugewiesen werden muss. Sie wird dann als Pflichtspalte (mandatory) bezeichnet.

Durch die Definition eines Constraints wird implizit festgelegt, dass der NULL-Wert nicht als Eingabe zugelassen ist.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE TABLE-Anweisung (create_table_statement)

Sie können die ALTER TABLE-Anweisung verwenden, um Constraints zu bereits vorhandenen Tabellen hinzuzufügen.

ALTER TABLE hotel.customer ADD CONSTRAINT zip_cons CHECK
SUBSTR(zip,1,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,2,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,3,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,4,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,5,1) BETWEEN '0' AND '9'

Für die Tabelle customer wurde ein einfaches Constraint auf der Postleitzahlenspalte hinzugefügt. Dieses Constraint bewirkt, dass für die Postleitzahl nur Ziffern von 0 bis 9 eingegeben werden können. Andere Zeichen werden bei der Dateneingabe abgewiesen.

ALTER TABLE hotel.customer ADD CONSTRAINT cno_cons CHECK cno > 10

//

ALTER TABLE hotel.customer ADD CONSTRAINT title_cons CHECK title IN ('Mr', 'Mrs', 'Company')

Für die Tabelle customer wurden weitere einfache Constraints definiert. Die Kundennummer soll größer als 10 sein, in die Spalte title darf nur einer der Zeichensätze Mr, Mrs oder Company eingetragen werden.

Komplizierte Constraints

In einem komplizierten Constraint werden Bedingungen formuliert, die sich auf mehrere Spalten der Tabelle beziehen.

ALTER TABLE hotel.reservation ADD CONSTRAINT staying CHECK
departure > arrival

In der Tabelle reservation soll überprüft werden, ob das Ankunfts- vor dem Abreisedatum liegt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER TABLE-Anweisung (alter_table_statement)

SQL-Referenzhandbuch, Strukturlink ADD-Definition (add_definition)

Ändern eines Constraint

Sie können die ALTER TABLE-Anweisung verwenden, um vorhandene Constraints zu ändern.

ALTER TABLE hotel.customer ALTER CONSTRAINT cno_cons CHECK cno > 0

Für die Tabelle customer wurde das Constraint cno_cons geändert. Die Kundennummer soll größer als 0 sein

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER-Definition (alter_definition)

Systemtabellen auswerten, Strukturlink CONSTRAINTS

Löschen eines Constraint

Sie können die ALTER TABLE-Anweisung verwenden, um ein Constraint zu löschen.

ALTER TABLE hotel.reservation DROP CONSTRAINT staying

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP-Definition (drop_definition)

Weitere Beispiele zur Datendefinition


Primärschlüssel (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Primärschlüssel

Für manche Anwendungen ist es sinnvoll, die Zeilen einer Tabelle durch eine oder mehrere Spalten eindeutig zu kennzeichnen, um sie z.B. in einer festen Reihenfolge abarbeiten zu können. Dies erfolgt über die Vergabe eines sogenannten Primärschlüssels. Durch die Schlüsselworte PRIMARY KEY werden die Spaltennamen gekennzeichnet, die den Schlüssel der Tabelle bilden sollen. Die Eingabewerte der so definierten Schlüsselspalten dürfen kein NULL-Wert sein.

Das Einfügen von Zeilen in eine Tabelle mit Primärschlüssel geschieht wie in eine Basistabelle ohne Primärschlüsseldefinition. Allerdings führt der Versuch, einen bereits vorhandenen Wert ein zweites Mal in die Primärschlüsselspalte einzufügen, zu einer Fehlermeldung, da die Eindeutigkeit der Spalte durch die Definition des Primärschlüssels gewährleistet wird.

Ein Primärschlüssel kann aus mehreren Spalten bestehen. Es ist jedoch unüblich, einen Schlüssel aus mehr als 5 Spalten zu konstruieren, da es für den Benutzer nicht mehr überschaubar ist, die Werte eindeutig einzugeben. Die Anordnung der Spalten hinter den Schlüsselworten PRIMARY KEY legt die Schlüsselreihenfolge fest.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

SQL-Referenzhandbuch, Strukturlink Schlüsseldefinition (key_definition)

Anlegen eines Primärschlüssels

Sie können einen Primärschlüssel direkt bei der Tabellendefinition angeben oder nachträglich zu einer vorhandenen Tabelle hinzufügen.

Einfache Primärschlüssel

Sie können Primärschlüssel definieren, die sich nur auf eine Spalte der Tabelle beziehen.

Sie können die CREATE TABLE-Anweisung verwenden, um Primärschlüssel beim Anlegen einer Tabelle zu definieren.

CREATE TABLE hotel.person
(pno FIXED(6) PRIMARY KEY,
name CHAR(20),
city CHAR(20))

oder

CREATE TABLE hotel.person
(pno FIXED(6),
name CHAR(20),
city CHAR(20),
PRIMARY KEY (pno))

Beide Anweisungen bewirken folgendes: Die Zeilen der Tabelle person sollen eindeutig über die Personennummer identifiziert werden können.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE TABLE-Anweisung (create_table_statement)

Sie können die ALTER TABLE-Anweisung verwenden, um Primärschlüssel zu bereits vorhanden Tabellen hinzuzufügen.

...

1. Löschen Sie die Tabelle person.
DROP TABLE hotel.person

2. Legen Sie die Tabelle person wie folgt an:
CREATE TABLE hotel.person
(pno FIXED(6),
name CHAR(20),
city CHAR(20))

3. Fügen Sie einen Primärschlüssel hinzu:
ALTER TABLE hotel.person ADD PRIMARY KEY (pno)

Die Zeilen der Tabelle person sollen eindeutig über die Personennummer identifiziert werden können.

Primärschlüssel über mehrere Spalten

Sie können einen Primärschlüssel über mehrere Spalten der Tabelle definieren.

1. Löschen Sie die Tabelle person.
DROP TABLE hotel.person

2. Legen Sie die Tabelle person wie folgt an:
CREATE TABLE hotel.person
(pno FIXED(6),
name CHAR(20),
city CHAR(20))

3. Fügen Sie einen Primärschlüssel hinzu:
ALTER TABLE hotel.person ADD PRIMARY KEY (pno,name)

Die Zeilen der Tabelle person sollen eindeutig über Personennummer und Namen identifiziert werden können.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER TABLE-Anweisung (alter_table_statement)

SQL-Referenzhandbuch, Strukturlink ADD-Definition (add_definition)

Ändern eines Primärschlüssels

Sie können die ALTER TABLE-Anweisung verwenden, um vorhandene Primärschlüssel zu ändern.

ALTER TABLE hotel.person ALTER PRIMARY KEY (pno)

Die Zeilen der Tabelle person sollen eindeutig über die Personennummer identifiziert werden können.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER-Definition (alter_definition)

Löschen eines Primärschlüssels

Sie können die ALTER TABLE-Anweisung verwenden, um Primärschlüssel zu löschen.

ALTER TABLE hotel.person DROP PRIMARY KEY

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP-Definition (drop_definition)

Weitere Beispiele zur Datendefinition


Fremdschlüsselbeziehungen zwischen Tabellen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Fremdschlüsselbeziehungen zwischen Tabellen

Zwischen zwei Tabellen lässt sich eine Abhängigkeit definieren, die Auswirkungen bei der Veränderung von Zeilen hat. Dieser Zusammenhang wird als referentielles Constraint (oder auch Fremdschlüsselbeziehung) bezeichnet.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

SQL-Referenzhandbuch, Strukturlink Referentielle CONSTRAINT-Definition (referential_constraint_definition)

Anlegen eines Fremdschlüssels

Sie können einen Fremdschlüssel (referentielles Constraint) direkt bei der Tabellendefinition angeben oder nachträglich zu einer vorhandenen Tabelle hinzufügen.

Einfache Fremdschlüssel

Sie können Fremdschlüsselbeziehungen definieren, die sich nur auf eine Primärschlüsselspalte einer Tabelle beziehen.

Sie können die CREATE TABLE-Anweisung verwenden, um Fremdschlüssel beim Anlegen einer Tabelle zu definieren.

...

1. Löschen Sie die Tabelle hotel.
DROP TABLE hotel.hotel

2. Legen Sie die Tabelle hotel wie folgt an:
CREATE TABLE hotel.hotel
(hno FIXED(4) PRIMARY KEY CONSTRAINT hno_cons CHECK hno > 0,
name CHAR(50) NOT NULL,
zip CHAR(5) CONSTRAINT zip_cons CHECK
SUBSTR(zip,1,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,2,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,3,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,4,1) BETWEEN '0' AND '9' AND
SUBSTR(zip,5,1) BETWEEN '0' AND '9',
address CHAR(40) NOT NULL,
FOREIGN KEY hotel_zip_in_city (zip) REFERENCES hotel.city ON DELETE RESTRICT)

Die Tabellen city und hotel lassen sich über die Postleitzahl miteinander verknüpfen, da die Postleitzahlenspalte in der Tabelle city die Primärschlüsselspalte ist. Die Tabelle hotel bekommt durch die Syntaxregel FOREIGN KEY den Fremdschlüssel (referentielles Constraint) hotel_zip_in_city für die Spalte zip zugewiesen

Tabelle CITY

ZIP

NAME

STATE

Tabelle HOTEL

HNO

NAME

ZIP

....

Der Name des Fremdschlüssels (referentiellen Constraint) hotel_zip_in_city wurde nach den Schlüsselworten FOREIGN KEY angegeben. Wird der Name nicht angegeben, so vergibt das Datenbanksystem selbst folgenden Namen: city_hotel, d.h. die Namen der beteiligten Tabellen werden mit einem Unterstrich verbunden.

Über ein hinter dem Schlüsselwort DELETE anzugebendes Schlüsselwort kann festgelegt werden, was mit abhängigen Werten bei Löschung von Zeilen geschehen soll.

Zeilen der Ortstabelle sollten z.B. nur dann gelöscht werden, wenn keine Hoteleinträge mehr für diese Orte vorhanden sind. Ist das doch der Fall, können Sie z.B. unter folgenden Möglichkeiten wählen:

● ON DELETE RESTRICT: Sie erhalten eine Warnung, die Zeilen werden in der Tabelle city nicht gelöscht.

● ON DELETE CASCADE: Entsprechende Zeilen werden in der Orts- und in der Hoteltabelle gelöscht.

● ON DELETE SET NULL: In der Hoteltabelle sinnlos gewordene Einträge werden auf den NULL-Wert gesetzt.

● ON DELETE SET DEFAULT: In der Hoteltabelle sinnlos gewordene Einträge werden auf den Default-Wert gesetzt.

Wenn Sie in die Tabelle hotel eine Zeile einfügen oder ändern, zu der kein Ort vorhanden ist, wird dies durch den Fremdschlüssel hotel_zip_in_city verhindert.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE TABLE-Anweisung (create_table_statement)

Sie können die ALTER TABLE-Anweisung verwenden, um Fremdschlüssel zu bereits vorhandenen Tabellen hinzuzufügen.

ALTER TABLE hotel.reservation ADD FOREIGN KEY reservation_cno_in_customer (cno) REFERENCES hotel.customer ON DELETE CASCADE

Für die Tabelle reservation wurde ein Fremdschlüssel auf der Kundennummerspalte hinzugefügt. Diese Spalte ist in der Tabelle customer Primärschlüsselspalte.

Fremdschlüssel über mehrere Spalten

Sie können einen Fremdschlüssel auf mehrere Primärschlüsselspalten definieren.

ALTER TABLE hotel.reservation ADD FOREIGN KEY reservation_info_in_room (hno,type) REFERENCES hotel.room ON DELETE CASCADE

Für die Tabelle reservation wurde ein Fremdschlüssel auf die Spalten hno und type hinzugefügt. Diese Spalten sind in der Tabelle room Primärschlüsselspalten.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER TABLE-Anweisung (alter_table_statement)

SQL-Referenzhandbuch, Strukturlink ADD-Definition (add_definition)

Systemtabellen auswerten, Strukturlink FOREIGNKEYS, Strukturlink FOREIGNKEYCOLUMNS

Löschen eines Fremdschlüssels

Sie können die ALTER TABLE-Anweisung verwenden, um Fremdschlüssel zu löschen.

ALTER TABLE hotel.reservation DROP FOREIGN KEY reservation_info_in_room

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP-Definition (drop_definition)

Weitere Beispiele zur Datendefinition


View-Tabellen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt View-Tabellen

Eine View-Tabelle ist eine Sicht auf eine oder mehrere existierende Tabellen. Dabei werden Teile der Tabellen verdeckt, andere Teile bleiben sichtbar.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen einer View-Tabelle

Zum Anlegen einer View-Tabelle verwenden Sie die CREATE VIEW-Anweisung.

CREATE VIEW hotel.customer_addr (cno, title, name, zip, city, state, address)
AS SELECT customer.cno, customer.title, customer.name, customer.zip,
city.name, city.state, customer.address
FROM hotel.customer, hotel.city
WHERE customer.zip = city.zip
Die View-Tabelle customer_addr setzt sich aus Informationen aus den Tabellen customer und city zusammen.

Wenn die Tabellen mit den für das SQL-Tutorial vorgegebenen Daten (SQL-Anweisungen für das Schema HOTEL) gefüllt sind, können über die View-Tabelle customer_addr folgende Daten gefunden werden:

SELECT * FROM hotel.customer_addr ORDER BY cno

Ergebnis

CNO | TITLE | NAME | ZIP | CITY | STATE | ADDRESS
3000 | Mrs | Porter | 10580 | New York | NY | 1340 N.Ash Street, #3
3100 | Mr | Brown | 48226 | Detroit | MI | 1001 34th Str., APT.3
3200 | Company | Datasoft | 90018 | Los Angeles | CA | 486 Maple Str.
3300 | Mrs | Brian | 75243 | Dallas | TX | 500 Yellowstone Drive, #2
3400 | Mrs | Griffith | 20005 | Washington | DC | 3401 Elder Lane
3500 | Mr | Randolph | 60615 | Chicago | IL | 340 MAIN STREET, #7
3600 | Mrs | Smith | 75243 | Dallas | TX | 250 Curtis Street
3700 | Mr | Jackson | 45211 | Cincinnati | OH | 133 BROADWAY APT. 1
3800 | Mrs | Doe | 97213 | Portland | OR | 2000 Humboldt Str., #6
3900 | Mr | Howe | 75243 | Dallas | TX | 111 B Parkway, #23
4000 | Mr | Miller | 95054 | Santa Clara | CA | 27 5th Str., 76
4100 | Mrs | Baker | 90018 | Los Angeles | CA | 200 MAIN STREET, #94
4200 | Mr | Peters | 92714 | Irvine | CA | 700 S. Ash Str., APT.12
4300 | Company | TOOLware | 20019 | Washington | DC | 410 Mariposa Str., # 10
4400 | Mr | Jenkins | 20903 | Silver Spring | MD | 55 A Parkway, #15

Beim Anlegen einer View-Tabelle können Sie Spalten umbenennen und umstellen. Sie können mehrere Tabellen verknüpfen. Jede SELECT-Anweisung, die nicht ORDER BY enthält, können Sie zur Definition einer View-Tabelle verwenden.

Einen View-Tabellennamen können Sie immer in SELECT-Anweisungen und in speziellen Fällen auch in INSERT-, UPDATE- und DELETE-Anweisungen verwenden.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE VIEW-Anweisung (create_view_statement)

Systemtabellen auswerten, Strukturlink VIEWS, Strukturlink VIEWDEFS, Strukturlink VIEWCOLUMNS

Weitere CREATE View-Anweisungsbeispiele: Konzepte des Datenbanksystems, Strukturlink Objekte im Schema HOTEL

Löschen einer View-Tabelle

Zum Löschen einer View-Tabelle verwenden Sie die DROP VIEW-Anweisung.

DROP VIEW hotel.customer_addr

Mit Hilfe dieser SQL-Anweisung löschen Sie die View-Definition. Die Tabelleninhalte werden dabei nicht berührt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP VIEW-Anweisung (drop_view_statement)

Weitere Beispiele zur Datendefinition


Indizes (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Indizes

Da in einer Tabelle alle Spalten gleich behandelt werden, ist jede Spalte als Suchkriterium verwendbar. Das bedeutet aber nicht, dass die Suchvorgänge gleich effizient sind.

Wenn eine Spalte bevorzugt für die Abarbeitung von Suchbedingungen verwendet wird, sollten Sie für diese Spalte einen Index erzeugen. Dadurch können Sie die gewünschten Zeilen schneller finden, da das Datenbanksystem versucht, Indizes für die Suche von Einträgen zu verwenden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen eines Index

Zum Anlegen eines Index verwenden Sie die CREATE INDEX-Anweisung.

CREATE INDEX hotel.name_index ON hotel.customer (name)

Mit dieser Anweisung legen Sie einen einspaltigen Index mit dem Namen name_index im Schema hotel an.

CREATE INDEX hotel.city_state ON hotel.city (state)

Mit dieser Anweisung legen Sie einen einspaltigen Index mit dem Namen city_state an.

CREATE INDEX hotel.full_name_index ON hotel.customer (name,firstname)

Mit dieser Anweisung legen Sie einen zweispaltigen Index mit dem Namen full_name_index an.

Wenn Sie einen Index erzeugen wollen, der ähnlich dem Schlüssel eine Eindeutigkeit gewährleistet, müssen Sie das Schlüsselwort UNIQUE verwenden.

CREATE UNIQUE INDEX address_index ON hotel.customer (firstname,name,address)

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE INDEX-Anweisung (create_index_statement)

Die Definition eines UNIQUE-Index kann gleichzeitig mit der Tabellendefinition mit Hilfe der CREATE TABLE-Anweisung erfolgen.

...

1. Löschen Sie gegebenenfalls die Tabelle person.
DROP TABLE hotel.person

2. Legen Sie die Tabelle person an.
CREATE TABLE hotel.person
(pno FIXED(6) PRIMARY KEY,
name CHAR(20) CONSTRAINT name_index UNIQUE,
city CHAR(20))

Mit dieser Anweisung legen Sie einen einspaltigen UNIQUE-Index mit dem Namen name_index an.

1. Löschen Sie die Tabelle person.
DROP TABLE hotel.person

2. Legen Sie die Tabelle person an.
CREATE TABLE hotel.person
(pno FIXED(6) PRIMARY KEY,
name CHAR(20),
city CHAR(20),
CONSTRAINT address_index UNIQUE (name,city))

Mit dieser Anweisung legen Sie einen zweispaltigen UNIQUE-Index mit dem Namen address_index an.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE TABLE-Anweisung (create_table_statement)

SQL-Referenzhandbuch, Strukturlink UNIQUE-Definition (unique_definition)

Löschen eines Index

Zum Löschen eines Index verwenden Sie die DROP INDEX-Anweisung:

DROP INDEX hotel.full_name_index ON hotel.customer

Mit Hilfe dieser SQL-Anweisung löschen Sie die Indexdefinition und damit die Daten, die im Index gehalten wurden. Die Tabelleninhalte werden dabei nicht berührt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP INDEX-Anweisung (drop_index_statement)

Weitere Beispiele zur Datendefinition


Wertebereiche (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Wertebereiche

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele

Beim Anlegen einer Tabelle können Sie für jede Spalte einen Wertebereich definieren.

CREATE TABLE hotel.customer
(cno FIXED(4) PRIMARY KEY CONSTRAINT cno_cons CHECK cno > 0,
title CHAR(7) CONSTRAINT title_cons CHECK title IN ('Mr','Mrs','Company'),
firstname CHAR(20),
name CHAR(40) NOT NULL,
...)

Die Kundennummer ist maximal vierstellig, der Title 7 Zeichen lang, der Vorname 20 Zeichen lang und der Name 40 Zeichen lang.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE TABLE-Anweisung (create_table_statement)

Diese Wertebereiche können Sie vorab in einer Wertebereichsdefinition festlegen.

Anlegen eines Wertebereichs

Zum Anlegen eines Wertebereichs verwenden Sie die CREATE DOMAIN-Anweisung.

CREATE DOMAIN name_domain CHAR(20)

Namen sollen 20 Zeichen lang sein.

CREATE DOMAIN birthday_domain DATE DEFAULT DATE
CONSTRAINT birthday_domain > '1880-01-01'AND birthday_domain <= DATE

In der Wertebereichsdefinition birthday_domain für den Geburtstag wird als DEFAULT-Wert das aktuelle Tagesdatum gewählt. Das Geburtsdatum soll nicht vor dem 01.01.1880 liegen.

In einer Wertebereichsdefinition können ein DEFAULT-Wert und/oder eine CONSTRAINT-Definition angegeben werden.

● Die DEFAULT-Werte müssen den eventuell vorhandenen einschränkenden Bedingungen genügen.

● In der CONSTRAINT-Definition darf kein Constraint-Name vergeben werden und als Spaltenname wird der Wertebereichsname verwendet.

Verwenden des Wertebereichs

...

1. Löschen Sie gegebenenfalls die Tabelle person.
DROP TABLE hotel.person

2. Legen Sie die Tabelle person an.
CREATE TABLE hotel.person
(pno FIXED(6) PRIMARY KEY,
name name_domain,
city CHAR(20))

3. Fügen Sie eine neue Spalte birthday mit dem Wertebereich birthday_domain hinzu.
ALTER TABLE hotel.person ADD birthday birthday_domain

Der Tabelle person wurde unter Berücksichtigung des Wertebereichs name_domain für Namen und mit der Spalte birthday mit der Wertebereichsdefinition birthday_domain angelegt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE DOMAIN-Anweisung (create_domain_statement)

Systemtabellen auswerten, Strukturlink COLUMNS, Strukturlink DOMAINS, Strukturlink DOMAINCONSTRAINTS

Löschen eines Wertebereichs

Zum Löschen eines Wertebereichs verwenden Sie DROP DOMAIN-Anweisung:

DROP DOMAIN name_domain

Mit Hilfe dieser SQL-Anweisung löschen Sie die Wertebereichsdefinition. Tabellendefinitionen, die diese Wertebereichsdefinition verwendet haben, bleiben bestehen.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP DOMAIN-Anweisung (drop_domain_statement)

Weitere Beispiele zur Datendefinition


Datenbankprozeduren (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Datenbankprozeduren

Datenbankprozeduren sind Programme, die aus einem Anwendungsprogramm heraus wie eine SQL-Anweisung aufgerufen werden können. Eine Datenbankprozedur kann mehrere SQL-Anweisungen enthalten und dem Anwendungsentwickler stehen eine Reihe von Kontrollstrukturen zur Verfügung. Sie können z.B. Schleifen oder Verzweigungen innerhalb einer Datenbankprozedur programmieren.

Sie können sowohl Eingabe- als auch Ausgabeparameter definieren, um einer Datenbankprozedur eigene Werte zu übermitteln bzw. Ergebnisse zu erhalten.

Mögliche Anwendungsgebiete sind z.B. die Formulierung von komplexen Integritätsregeln, die die Zulässigkeit von Werten prüfen. Mit Datenbankprozeduren können Operationen auf Anwendungsobjekten bereitgestellt werden. Änderungen an diesen Regeln bzw. Operationen können dann an zentraler Stelle, nämlich in der Datenbankprozedur erfolgen und müssen nicht mehr in jeder Anwendung einzeln gemacht werden. Die Programme werden übersichtlicher und daher einfacher zu handhaben.

Desweiteren ist die Privilegienvergabe bei Einsatz von Datenbankstrukturen sehr einfach. Sie müssen nur das Aufrufprivileg vergeben, Privilegien für die angesprochenen Datenbankobjekte müssen Sie nicht vergeben.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen einer Datenbankprozedur

Zum Anlegen einer Datenbankprozedur verwenden Sie die CREATE DBPROC-Anweisung.

CREATE DBPROC
hotel.avg_price (IN zip CHAR(5), OUT avg_price FIXED(6,2)) AS
VAR sum FIXED(10,2); price FIXED(6,2); hotels
INTEGER;
TRY
SET sum = 0; SET hotels = 0;
DECLARE dbproccursor CURSOR FOR
SELECT price FROM hotel.room,hotel.hotel WHERE zip = :zip AND
room.hno = hotel.hno AND type = 'single';
WHILE $rc = 0 DO BEGIN
FETCH dbproccursor INTO :price;
SET sum = sum + price;
SET hotels = hotels + 1;
END;
CATCH
IF $rc <> 100 THEN STOP ($rc, 'unexpected error');
CLOSE dbproccursor;
IF hotels > 0 THEN SET avg_price = sum / hotels
ELSE STOP (100, 'no hotel found');

Die Datenbankprozedur avg_price bestimmt den durchschnittlichen Preis für Einzelzimmer in Hotels, die im angegebenen Postleitzahlenbereich liegen.

Erläuterung

● IN zip CHAR(5), OUT avg_price FIXED(6,2) : Eingabeparameter ist die Postleitzahl zip, Ausgabeparameter ist der durchschnittliche Preis avg_price.

● Nach dem Schlüsselwort AS werden die SQL-Anweisungen (in diesem Beispiel eine SELECT-Anweisung) und Kontrollstrukturen (in diesem Beispiel eine WHILE- und eine IF-Anweisung) definiert, die zum Ausführen der gewünschten Prozedur erforderlich sind.

● Nach dem Schlüsselwort VAR werden die innerhalb der Datenbankprozedur erforderlichen Variablen definiert.

● Fehlerbehandlung: Wenn in der Anweisungsfolge zwischen TRY und CATCH ein SQL-Fehler auftritt, wird unverzüglich in die auf das CATCH folgende Anweisung verzweigt. In dieser Anweisung kann die eigentliche Fehlerbehandlung programmiert werden.

● Mittels SET werden den Variablen sum und hotels Werte zugewiesen.

● Durch die DECLARE CURSOR-Anweisung wird die benannte Ergebnistabelle dbproccursor definiert.

● In der SELECT-Anweisung müssen die Tabellen vollständig, d.h. unter Angabe des Eigentümers angegeben werden. Beachten Sie, dass die Übergabe der Postleitzahl als Parameter erfolgt: :zip.

● Die WHILE-Anweisung ermöglicht die bedingte Wiederholung von Anweisungen. Solange die angegebene Suchbedingung zutrifft, wird die Anweisung ausgeführt.

● Die FETCH-Anweisung weist Parametern die Werte der aktuellen Zeile der Ergebnistabelle dbproccursor zu.

● Die $rc-Variable liefert nach der Ausführung der SELECT-Anweisung einen numerischen Fehlercode zurück. Der Wert 0 bedeutet, dass die SELECT-Anweisung erfolgreich ausgeführt wurde.

● Eine IF-Anweisung wertet zunächst die Suchbedingung aus. Ist diese erfüllt, so wird die im THEN-Zweig definierte Anweisung ausgeführt, andernfalls wird - wenn vorhanden - die Anweisung im ELSE-Zweig ausgeführt.

● Die CLOSE-Anweisung löscht die Ergebnistabelle dbproccursor.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement)

SQL-Referenzhandbuch, Strukturlink Routine (routine)

Systemtabellen auswerten, Strukturlink DBPROCEDURES

Aufrufen einer Datenbankprozedur

Zum Aufrufen einer Datenbankprozedur verwenden Sie die CALL-Anweisung.

Wenn die Tabelle hotel mit den SQL-Anweisungen für das Schema HOTEL erzeugt und mit Daten gefüllt wurde, können Sie folgende CALL-Anweisung ausprobieren:

CALL hotel.avg_price (20005, :avg_price)

Ergebnis

Out(1)

135

Wenn ein formaler Parameter der Datenbankprozedur den Modus OUT besitzt, muss der korrespondierende Ausdruck einer Parameterspezifikation entsprechen. In der CALL-Anweisung finden Sie die Parameterspezifikation :avg_price.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CALL-Anweisung (call_statement)

Löschen einer Datenbankprozedur

Zum Löschen einer Datenbankprozedur verwenden Sie die DROP DBPROC-Anweisung.

DROP DBPROC hotel.avg_price

Mit Hilfe dieser SQL-Anweisung löschen Sie die Definition der Datenbankprozedur.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP DBPROC[EDURE]-Anweisung (drop_dbproc_statement)

Weitere Beispiele zur Datendefinition


Datenbankfunktionen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Datenbankfunktionen

Sie können benutzerspezifische Datenbankfunktionen definieren. In einer SQL-Anweisung kann diese benutzerdefinierte Datenbankfunktion dann wie jede andere festdefinierte Funktion verwendet werden.

Eine Datenbankfunktion kann mehrere SQL-Anweisungen enthalten und dem Anwendungsentwickler stehen eine Reihe von Kontrollstrukturen zur Verfügung. Sie können z.B. Schleifen oder Verzweigungen innerhalb einer Datenbankfunktion programmieren.

Datenbankfunktionen sind spezialisierte Datenbankprozeduren, die beliebig viele Eingabe-, aber nur genau einen Ausgabeparameter besitzen. Der Ausgabeparameter stellt das Ergebnis der Datenbankfunktion dar.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen einer Datenbankfunktion

Zum Anlegen einer Datenbankfunktion verwenden Sie die CREATE FUNCTION-Anweisung.

CREATE FUNCTION
hotel.avgprice (zip CHAR(5)) RETURNS FIXED(6,2) AS
VAR sum FIXED(10,2); price FIXED(6,2);
hotels INTEGER; avg_price FIXED(6,2);
TRY
SET sum = 0; SET hotels = 0;
DECLARE functionresult CURSOR FOR
SELECT price FROM hotel.room,hotel.hotel WHERE zip = :zip AND
room.hno = hotel.hno AND type = 'single';
WHILE $rc = 0 DO BEGIN
FETCH functionresult INTO :price;
SET sum = sum + price;
SET hotels = hotels + 1;
END;
CATCH
IF $rc <> 100 THEN STOP ($rc, 'unexpected error');
CLOSE functionresult;
IF hotels > 0 THEN RETURN sum/hotels
ELSE RETURN NULL;

Die Datenbankfunktion avgprice bestimmt den durchschnittlichen Preis für Einzelzimmer in Hotels, die im angegebenen Postleitzahlenbereich liegen.

Erläuterung

● Eingabeparameter ist die Postleitzahl zip, Nach dem Schlüsselwort RETURNS wird der Datentyp des Ausgabewerts festgelegt.

● Nach dem Schlüsselwort AS werden die SQL-Anweisungen (z.B. SELECT-Anweisung) und Kontrollstrukturen (z.B. WHILE- und eine IF-Anweisung) definiert, die zum Ausführen der gewünschten Funktion erforderlich sind.

● Nach dem Schlüsselwort VAR werden die innerhalb der Datenbankfunktion erforderlichen Variablen definiert.

● Fehlerbehandlung: Wenn in der Anweisungsfolge zwischen TRY und CATCH ein SQL-Fehler auftritt, wird unverzüglich in die auf das CATCH folgende Anweisung verzweigt. In dieser Anweisung kann die eigentliche Fehlerbehandlung programmiert werden.

● Mittels SET werden den Variablen sum und hotels Werte zugewiesen.

● Durch die DECLARE CURSOR-Anweisung wird die benannte Ergebnistabelle functionresult definiert.

● In der SELECT-Anweisung müssen die Tabellen vollständig, d.h. unter Angabe des Eigentümers angegeben werden. Beachten Sie, dass die Übergabe der Postleitzahl als Parameter erfolgt: :zip.

● Die WHILE-Anweisung ermöglicht die bedingte Wiederholung von Anweisungen. Solange die angegebene Suchbedingung zutrifft, wird die Anweisung ausgeführt.

● Die FETCH-Anweisung weist Parametern die Werte der aktuellen Zeile der Ergebnistabelle functionresult zu.

● Die $rc-Variable liefert nach der Ausführung der SELECT-Anweisung einen numerischen Fehlercode zurück. Der Wert 0 bedeutet, dass die SELECT-Anweisung erfolgreich ausgeführt wurde.

● Eine IF-Anweisung wertet zunächst die Suchbedingung aus. Ist diese erfüllt, so wird die im THEN-Zweig definierte Anweisung ausgeführt, andernfalls wird - wenn vorhanden - die Anweisung im ELSE-Zweig ausgeführt.

● Die CLOSE-Anweisung löscht die Ergebnistabelle functionresult.

● Nach dem Schlüsselwort RETURN wird der Ausgabeparameter definiert.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE FUNCTION-Anweisung (create_function_statement)

SQL-Referenzhandbuch, Strukturlink Routine (routine)

Systemtabellen auswerten, Strukturlink FUNCTIONS

Aufrufen einer Datenbankfunktion

Zum Aufrufen einer Datenbankfunktion verfahren Sie wie beim Aufruf einer fest definierten Funktion.

Wenn die Tabelle hotel mit den SQL-Anweisungen für das Schema HOTEL erzeugt und mit Daten gefüllt wurde, können Sie folgende SELECT-Anweisung ausprobieren:

SELECT hno, hotel.avgprice(zip) avgprice FROM hotel.hotel WHERE hno < 100

Ergebnis

HNO | AVGPRICE
10 | 135
20 | 70
30 | 45
40 | 87.5
50 | 105
60 | 120
70 | 115
80 | 87.5
90 | 90

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Datenbankfunktionsaufruf (dbfunction_call)

Löschen einer Datenbankfunktion

Zum Löschen einer Datenbankfunktion verwenden Sie DROP FUNCTION-Anweisung.

DROP FUNCTION hotel.avgprice

Mit Hilfe dieser SQL-Anweisung löschen Sie die Definition der Datenbankfunktion.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP FUNCTION-Anweisung (drop_function_statement)

Weitere Beispiele zur Datendefinition


Datenbanktrigger (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Datenbanktrigger

Datenbanktrigger sind Programme, die implizit nach Ausführung einer INSERT-, UPDATE- oder DELETE-Anweisung auf einer Basistabelle starten. Ein Trigger kann mehrere SQL-Anweisungen enthalten und dem Anwendungsentwickler stehen eine Reihe von Kontrollstrukturen zur Verfügung. Sie können z.B. Schleifen oder Verzweigungen innerhalb eines Triggers programmieren.

Wenn Sie z.B. für eine Basistabelle einen Trigger definieren, der bei jedem INSERT angestoßen wird, so werden automatisch nach jedem neuen Eintrag in diese Tabelle die innerhalb des Triggers definierten Aktionen ausgeführt. Sie können die Ausführung eines Triggers von bestimmten Vorbedingungen abhängig machen. UPDATE-Trigger können Sie auch nur für die Änderung einzelner Spalten formulieren.

Trigger können Sie z.B. verwenden, um Werte vor ihrem Eintrag auf ihre Eignung zu überprüfen oder Werte vor ihrem Ändern zu sichern. Bei der Programmierung eines Triggers können Sie daher sowohl auf den neuen als auch auf den alten Spaltenwert zugreifen.

Nach der Definition eines Triggers müssen Sie diesen einer Basistabelle oder einzelnen Spalten sowie einer Aktion wie INSERT, UPDATE, DELETE zuordnen.

Um einen Trigger für Tabellen definieren zu können, müssen Sie Eigentümer der Tabelle sein und das Recht besitzen, die innerhalb des Triggers definierten Aktionen auszuführen.

Schlägt die Ausführung eines Triggers fehl, wird die dazugehörige INSERT-, UPDATE- oder DELETE-Anweisung durch ein ROLLBACK zurückgesetzt.

Ein Trigger kann implizit weitere Trigger und explizit auch Datenbankprozeduren aufrufen.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen eines Datenbanktriggers

Zum Anlegen eines Datenbanktriggers verwenden Sie die CREATE TRIGGER-Anweisung.

CREATE TRIGGER hotel_update FOR hotel.hotel AFTER UPDATE EXECUTE
(TRY
IF NEW.hno <> OLD.hno
THEN UPDATE hotel.room SET hno = :NEW.hno WHERE hno = :OLD.hno;
CATCH
IF $rc <> 100
THEN STOP ($rc, 'unexpected error');)

Der Trigger sorgt dafür, dass beim Ändern einer Hotelnummer in der Tabelle hotel die Änderung der Hotelnummer in der Tabelle room ebenfalls durchgeführt wird.

Erläuterung

● Nach dem Schlüsselwort AFTER wird das Trigger-Ereignis UPDATE angegeben. Das Trigger-Ereignis UPDATE bewirkt für jede Änderung einer Zeile der Tabelle hotel eine Ausführung des Triggers.

● Nach dem Schlüsselwort EXECUTE werden die SQL-Anweisungen und Kontrollstrukturen (in diesem Beispiel IF-Anweisungen) definiert, die zum Ausführen des gewünschten Triggers erforderlich sind.

● Fehlerbehandlung: Wenn in der Anweisungsfolge zwischen TRY und CATCH ein SQL-Fehler auftritt, wird unverzüglich in die auf das CATCH folgende Anweisung verzweigt. In dieser Anweisung kann die eigentliche Fehlerbehandlung programmiert werden.

● Sie können die neue Hotelnummer NEW.hno und die alte Hotelnummer OLD.hno verwenden.

● Die $rc-Variable liefert nach der Ausführung der UPDATE-Anweisung einen numerischen Fehlercode zurück. Der Wert 0 bedeutet, dass die Anweisung erfolgreich ausgeführt wurde.

● Eine IF-Anweisung wertet zunächst die Suchbedingung aus. Ist diese erfüllt, so wird die im THEN-Zweig definierte Anweisung ausgeführt, andernfalls wird - wenn vorhanden - die Anweisung im ELSE-Zweig ausgeführt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE TRIGGER-Anweisung (create_trigger_statement)

SQL-Referenzhandbuch, Strukturlink Routine (routine)

Systemtabellen auswerten, Strukturlink TRIGGERS

Ausführen eines Datenbanktriggers

Der Datenbanktrigger hotel_update wird automatisch gestartet, sobald Änderungen der Hotelnummer in der Tabelle hotel mittels einer UPDATE-Anweisung durchgeführt werden.

Löschen eines Datenbanktriggers

Zum Löschen eines Datenbanktriggers verwenden Sie die DROP TRIGGER-Anweisung.

DROP TRIGGER hotel_update OF hotel

Mit Hilfe dieser SQL-Anweisung löschen Sie die Triggerdefinition. Die Tabelleninhalte werden dabei nicht berührt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP TRIGGER-Anweisung (drop_trigger_statement)

Weitere Beispiele zur Datendefinition


Nummerngeneratoren für Tabellen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Nummerngeneratoren für Tabellen

Mit Hilfe der CREATE SEQUENCE-Anweisung können Sie eine Sequenz und dadurch einen impliziten Nummerngenerator (automatisch generierte Abfolge von Zahlen) erzeugen.

Eine typische Anwendung ist die Erzeugung eines Primärschlüssels.

Bei jedem Zugriff auf eine Sequenz können Sie den nächsten verfügbaren Wert des Nummerngenerators ermitteln und weiterverwenden. Die Werte des Nummerngenerators können aus den Pseudospalten NEXTVAL und CURRVAL abgerufen werden. Diese Werte sind immer ganze Zahlen.

● NEXTVAL gibt den nächsten verfügbaren Wert an, der durch den Nummergenerator erzeugt wurde

● CURRVAL gibt den gerade verwendeten Wert an, der innerhalb der Datenbanksitzung durch den Nummerngenerator erzeugt wurde.

In INSERT- und UPDATE-Anweisungen können der nächste verfügbare und der gerade verwendete Sequenzwert in einer beliebigen Spalte einer Tabelle angegeben werden, wenn das der Datentyp dieser Spalte erlaubt. Jedoch ist es nicht möglich, den nächsten verfügbaren und den gerade verwendeten Wert als DEFAULT-Wert einer Spalte zu definieren. Beide Werte müssen immer explizit angegeben werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen einer Sequenz

...

...

Legen Sie die Sequenz sequ mit Hilfe der CREATE SEQUENCE-Anweisung an.

Geben Sie den Sequenznamen und den ersten Sequenzwert an (START WITH <integer>, Vorschlagswert ist 1). Geben Sie an, wie der nächste Wert in der Sequenz erzeugt werden soll (INCREMENT BY <integer>, Vorschlagswert ist 1)

CREATE SEQUENCE hotel.sequ
START WITH 1
INCREMENT BY 1

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE SEQUENCE-Anweisung (create_sequence_statement)

Verwenden einer Sequenz

Legen Sie für die folgenden Beispiele die Tabellen pers1 und pers2 an.

CREATE TABLE hotel.pers1
(pno FIXED(6),
firstname CHAR(20),
name CHAR(20))
//
CREATE TABLE hotel.pers2
(pno FIXED(6),
firstname CHAR(20),
name CHAR(20))

Ein Nummerngenerator für verschiedenen Tabellen

Sie können den durch die Sequenz sequ erzeugten Nummerngenerator in Ihren SQL-Anweisungen verwenden. Geben Sie dazu nach dem Sequenznamen das Schlüsselwort NEXTVAL an.

Wenn Sie den Nummerngenerator in verschiedenen Tabellen verwenden wollen, geben Sie diesen in der Form <sequence_name>.NEXTVAL in den gewünschten Tabellen an.

INSERT INTO hotel.pers1 VALUES (hotel.sequ.NEXTVAL,'Mary','Jackson')

//

INSERT INTO hotel.pers2 VALUES (hotel.sequ.NEXTVAL,'Billy','Jackson')

//

INSERT INTO hotel.pers1 VALUES (hotel.sequ.NEXTVAL,'Lucy','Baker')

//

INSERT INTO hotel.pers2 VALUES (hotel.sequ.NEXTVAL,'Henry','Baker')

//

INSERT INTO hotel.pers1 VALUES (hotel.sequ.NEXTVAL,'Anna','Miller')

//

INSERT INTO hotel.pers2 VALUES (hotel.sequ.NEXTVAL,'Mike','Miller')

//

INSERT INTO hotel.pers1 VALUES (hotel.sequ.NEXTVAL,'Peggy','Miller')

//

SELECT * FROM hotel.pers1

Ergebnis

PNO | FIRSTNAME | NAME
1 | Mary | Jackson
3 | Lucy | Baker
5 | Anna | Miller
7 | Peggy | Miller

SELECT * FROM hotel.pers2

Ergebnis

PNO | FIRSTNAME | NAME
2 | Billy | Jackson
4 | Henry | Baker
6 | Mike | Miller

Anzeige des gerade verwendeten Wertes des Nummerngenerators

Zur Anzeige des gerade verwendeten Wertes des Nummerngenerator können Sie die automatisch durch das Datenbanksystem erzeugte Tabelle DUAL verwenden. Die Tabelle DUAL kann durch alle Datenbankbenutzer verwendet werden. Da die Tabelle DUAL nur eine Zeile hat, können Sie diese Tabelle dazu verwenden, den Wert des Nummerngenerators mit Hilfe einer SELECT-Anweisung anzeigen zu lassen.

SELECT hotel.sequ.CURRVAL FROM dual

Ergebnis

 | EXPRESSION1
1 | 7

Wenn <sequence_name>.NEXTVAL innerhalb der aktuellen Datenbanksitzung noch nicht verwendet wurde, ist die Verwendung von <sequence_name>.CURRVAL nicht möglich.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Spezifikation von Werten (extended_value_spec)

Wert eines Nummerngenerators mehrmals verwenden

Sie haben unter anderem folgende Möglichkeit, wenn Sie einen Wert des Nummerngenerators mehrmals verwenden wollen:

Geben Sie den gerade verwendeten Wert des Nummerngenerators <sequence_name>.CURRVAL in Ihrer SQL-Anweisung an.

INSERT INTO hotel.pers1 VALUES (hotel.sequ.NEXTVAL,'Mary','Ford')

//

INSERT INTO hotel.pers2 VALUES (hotel.sequ.CURRVAL,'Mary','Ford')

//

SELECT * FROM hotel.pers1

Ergebnis

PNO | FIRSTNAME | NAME
1 | Mary | Jackson
3 | Lucy | Baker
5 | Anna | Miller
7 | Peggy | Miller
8 | Mary | Ford

SELECT * FROM hotel.pers2

Ergebnis

PNO | FIRSTNAME | NAME
2 | Billy | Jackson
4 | Henry | Baker
6 | Mike | Miller
8 | Mary | Ford

Siehe auch:

Nummerngenerator für eine einzelne Spalte einer Tabelle

Löschen des Nummerngenerators

Zum Löschen des Nummerngenerators müssen Sie die Sequenz mit Hilfe der DROP SEQUENCE-Anweisung löschen.

DROP SEQUENCE hotel.sequ

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP SEQUENCE-Anweisung (drop_sequence_statement)

Weitere Beispiele zur Datendefinition


Nummerngenerator für eine einzelne Spalte einer Tabelle (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Nummerngenerator für eine einzelne Spalte einer Tabelle

Mit Hilfe der DEFAULT-Spezifikation SERIAL(n) können Sie einen Nummerngenerator (automatisch generierte Abfolge von Zahlen) für eine Spalte einer Tabelle erzeugen.

Eine typische Anwendung ist die Erzeugung eines Primärschlüssels.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen eines Nummerngenerators

...

Legen Sie die Tabelle pers3 mit der DEFAULT-Spezifikation SERIAL(n) an.

Bei Verwenden des Schlüsselworts SERIAL ohne Angabe einer Zahl ist der Vorschlagswert für den Start des Nummerngenerators die Zahl 1. Wollen Sie den Nummerngenerator mit der Zahl n starten, müssen Sie die Zahl n explizit nach dem Schlüsselwort SERIAL angeben: SERIAL(n).

CREATE TABLE hotel.pers3
(pno FIXED(10) DEFAULT SERIAL PRIMARY KEY,
name CHAR (20))

oder

CREATE TABLE hotel.pers3
(pno SERIAL PRIMARY KEY,
name CHAR (20))

Da der Datentyp SERIAL auf FIXED(10) DEFAULT SERIAL abgebildet wird, liefern beide CREATE TABLE-Anweisungen die gleiche Definition der Tabelle pers3. Als erster Wert des Nummerngenerators wird die Zahl 1 erzeugt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DEFAULT-Spezifikation (default_spec)

SQL-Referenzhandbuch, Strukturlink Datentyp (data_type)

Verwenden des Nummerngenerators

Sie können den Nummerngenerator in der Spalte pno in Ihrer Anwendung verwenden.

In INSERT-Anweisungen müssen Sie für die SERIAL-Spalte keinen Wert angeben, da dieser durch den impliziten Nummerngenerator erzeugt wird.

Der erste Wert des Nummergenerators in dem oben genannten Beispiel ist eine 1. Mit jedem weiteren Einfügen eines Wertes in die Tabelle wird der Wert der SERIAL-Spalte um 1 erhöht.

INSERT hotel.pers3 (name) VALUES ('Baker')
//
INSERT hotel.pers3 (name) VALUES ('Miller')
//
SELECT * FROM hotel.pers3

Ergebnis

PNO | NAME
1 | Baker
2 | Miller

Eine Spalte mit der DEFAULT-Spezifikation SERIAL kann nicht geändert werden.

Eine Spalte mit der DEFAULT-Spezifikation SERIAL kann auch Fremdschlüsselspalte sein. Eine solche Spalte eignet sich sogar hervorrragend für diese Zwecke, da die Werte nicht geändert werden können und in den Anwendungen nur für die Zwecke genutzt werden, die durch die auf der Spalte liegende Anwendungslogik vorgegeben sind.

Anzeige des gerade verwendeten Wertes des Nummerngenerators

Zur Anzeige des gerade verwendeten Wertes des Nummerngenerator können Sie die automatisch durch das Datenbanksystem erzeugte Tabelle DUAL verwenden. Die Tabelle DUAL kann durch alle Datenbankbenutzer verwendet werden. Da die Tabelle DUAL nur eine Zeile hat, können Sie diese Tabelle dazu verwenden, den Wert des Nummerngenerators mit Hilfe einer SELECT-Anweisung anzeigen zu lassen.

Der aktuelle Wert des Nummerngenerators kann durch <table_name>.CURRVAL erfragt werden, wobei <table_name> der Name der Tabelle ist, die die DEFAULT-Spezifikation SERIAL enthält.

SELECT hotel.pers3.CURRVAL FROM dual

Ergebnis

 | EXPRESSION1
1 | 2

Siehe auch:

Nummerngeneratoren für Tabellen

Weitere Beispiele zur Datendefinition


Datenmanipulation (SAP-Bibliothek - Tutorials)

Hintergrunddokumentation Datenmanipulation

Eine vollständige Syntaxbeschreibung der SQL-Anweisungen zur Datenanfrage erhalten Sie im SQL-Referenzhandbuch im Abschnitt Strukturlink Datenmanipulation.

Im Folgenden sollen einige wesentliche SQL-Anweisungen zur Datenmanipulation anhand von Beispielen vorgestellt werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool Strukturlink SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele

Einfügen, Ändern, Löschen von Zeilen


Einfügen, Ändern, Löschen von Zeilen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Einfügen, Ändern, Löschen von Zeilen

Im Folgenden sollen SQL-Anweisungen zur Datenmanipulation (Einfügen, Ändern, Löschen von Zeilen) vorgestellt werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Einfügen von Zeilen

Zum Einfügen von Zeilen verwenden Sie die INSERT-Anweisung.

INSERT INTO hotel.city VALUES ('10018','New York','NY')

oder

INSERT INTO hotel.city (zip,name,state) VALUES ('10017','New York','NY')

In die Tabelle hotel werden Zeilen eingefügt (INSERT). Die Werte, die eingefügt werden sollen, werden nach dem Schlüsselwort VALUES in Klammern angegeben.

Wenn keine Spaltennamen angegeben sind, muss die Reihenfolge der Werte der Definitionsreihenfolge der Spalten entsprechen. Beide Folgen müssen in Länge und Datentypen übereinstimmen. Undefinierte Werte können als NULL geschrieben werden.

Die Angaben einer anderen Tabelle lassen sich auch durch eine SELECT-Anweisung in eine Tabelle aufnehmen.

...

1. Löschen Sie gegebenenfalls die Tabelle person.
DROP TABLE hotel.person

2. Legen Sie die Tabelle person an:
CREATE TABLE hotel.person
(pno FIXED(6,0) PRIMARY KEY,
name CHAR(20),
city CHAR(20))

3. Füllen Sie die Tabelle mit Werten aus der Tabelle city.
INSERT INTO hotel.person
SELECT zip, state, name FROM hotel.city WHERE zip < '20000'

Die Tabelle person wird mit Informationen aus der Tabelle city gefüllt. Das können Sie z.B. mit Hilfe folgender SELECT-Anweisung überprüfen:

SELECT pno, name state, city FROM hotel.person

Ergebnis

PNO | STATE | CITY
10017 | NY | New York
10018 | NY | New York
10019 | NY | New York
10580 | NY | New York
11788 | NY | Long Island
12203 | NY | Albany

Siehe auch:

SQL-Referenzhandbuch, Strukturlink INSERT-Anweisung (insert_statement)

Ändern von Zeilen

Zum Ändern von Zeilen verwenden Sie die UPDATE-Anweisung. Beachten Sie, dass alle Zeilen der Tabelle geändert werden, wenn die WHERE-Klausel in der UPDATE-Anweisung fehlt.

UPDATE hotel.person
SET name = 'CITY'
WHERE pno = '10019'

In der Tabelle person wird der Spaltenwert für name geändert (UPDATE...SET...), und zwar nur für die in der WHERE-Klausel spezifizierte Zeile. Das können Sie z.B. mit Hilfe folgender SELECT-Anweisung überprüfen:

SELECT pno, name, city FROM hotel.person

Ergebnis

PNO | NAME | CITY
10017 | NY | New York
10018 | NY | New York
10019 | CITY | New York
10580 | NY | New York
11788 | NY | Long Island
12203 | NY | Albany

Siehe auch:

SQL-Referenzhandbuch, Strukturlink UPDATE-Anweisung (update_statement)

Löschen von Zeilen

Zum Löschen von Zeilen verwenden Sie die DELETE-Anweisung.

DELETE FROM hotel.person
WHERE name = 'NY'

In der Tabelle person werden Zeilen gelöscht (DELETE FROM...), und zwar alle Zeilen mit dem Eintrag NY als Name (WHERE...). Das können Sie z.B. mit Hilfe folgender SELECT-Anweisung überprüfen:

SELECT pno, name, city FROM hotel.person

Ergebnis

PNO | NAME | CITY
10019 | CITY | New York

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DELETE-Anweisung (delete_statement)

Datenmanipulation


Autorisierung (SAP-Bibliothek - Tutorials)

Hintergrunddokumentation Autorisierung

Eine vollständige Syntaxbeschreibung der SQL-Anweisungen zur Autorisierung erhalten Sie im SQL-Referenzhandbuch im Abschnitt Strukturlink Autorisierung. Informieren Sie sich über das Benutzerkonzept des Datenbanksystems ( Strukturlink Benutzer, Authentifizierung und Berechtigungen).

Der Datenbanksystemadministrator (SYSDBA-Benutzer) wird beim Anlegen einer Datenbankinstanz erzeugt. Der Datenbanksystemadministrator kann weitere Datenbankbenutzer erzeugen, unter anderem auch Datenbankadministratoren. Alle Datenbankadministratoren können Datenbankbenutzer erzeugen oder Privilegien vergeben. So können Sie den Zugang zu den Daten benutzerspezifisch steuern.

Im Folgenden sollen einige wesentliche SQL-Anweisungen zur Autorisierung anhand von Beispielen vorgestellt werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool Strukturlink SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Beispiele für Datenbankbenutzer

Wenn die Vorschlagswerte beim Anlegen der Datenbankinstanz DEMODB übernommen wurden, hat der Datenbanksystemadministrator den Namen DBADMIN und das Kennwort SECRET.

Der Datenbankbenutzer MONA wurde mit der folgenden CREATE USER-Anweisung angelegt:

CREATE USER mona PASSWORD red DBA NOT EXCLUSIVE

● Nach den Schlüsselworten CREATE USER werden der Name des Datenbankbenutzers (MONA) und nach dem Schlüsselwort PASSWORD das Kennwort (RED) angegeben.

● Für den Datenbankbenutzer MONA wird die Benutzerklasse DBA (Datenbankadministrator) festgelegt.

● Durch die Angabe von NOT EXCLUSIVE wird gesteuert, dass der Datenbankadministrator MONA gleichzeitig mehrere Datenbanksitzungen öffnen darf.

In der Datenbankinstanz DEMODB gehört dem Datenbankadministrator MONA das Schema HOTEL. Im Schema HOTEL befinden sich die Tabellen CITY, CUSTOMER, HOTEL, ROOM, RESERVATION sowie eventuell weitere Datenbankobjekte, die der Datenbankadministrator MONA angelegt hat: Indizes, Datenbankprozeduren, View-Tabellen usw.

Beispiele

● Datenbankbenutzer und ihre Privilegien

● Rollen


Datenbankbenutzer und ihre Privilegien (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Datenbankbenutzer und ihre Privilegien

Datenbankadministratoren können weitere Datenbankbenutzer anlegen und Privilegien vergeben.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen von Datenbankbenutzern

Verwenden Sie die CREATE USER-Anweisung für das Anlegen weiterer Datenbankbenutzer.

CREATE USER david PASSWORD blue RESOURCE

Der Datenbankadministrator MONA hat den Datenbankbenutzer DAVID mit dem Kennwort BLUE erzeugt. Für diesen Datenbankbenutzer wurde die Datenbankbenutzerklasse RESOURCE festgelegt.

CREATE USER boris PASSWORD pink STANDARD

Der Datenbankadministrator MONA hat den Datenbankbenutzer BORIS mit dem Kennwort PINK erzeugt. Für diesen Datenbankbenutzer wurde die Datenbankbenutzerklasse STANDARD festgelegt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE USER-Anweisung (create_user_statement)

Ändern der Datenbankbenutzerklasse

Verwenden Sie die ALTER USER-Anweisung für das Ändern der Datenbankbenutzerklasse.

ALTER USER boris RESOURCE

Für den Datenbankbenutzer BORIS wird die Datenbankbenutzerklasse RESOURCE festgelegt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER USER-Anweisung (alter_user_statement)

Ändern des Kennwortes

Verwenden Sie die ALTER PASSWORD-Anweisung, um das Kennwort eines Datenbankbenutzers zu ändern.

● Melden Sie sich als Datenbanksystemadministrator (Vorschlagswerte: DBADMIN/SECRET) an.
ALTER PASSWORD boris red
Das Kennwort des Datenbankbenutzer BORIS wird in RED verändert.

Sie können auch folgende Möglichkeit der ALTER PASSWORD-Anweisung verwenden:

● Melden Sie sich als Datenbankbenutzer BORIS (BORIS/RED) an.
ALTER PASSWORD red TO pink
Das Kennwort des Datenbankbenutzer BORIS wird in PINK verändert.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER PASSWORD-Anweisung (alter_password_statement)

Vergeben von Privilegien

Eröffnen Sie eine Datenbanksitzung für den Datenbankadministrator MONA und verwenden Sie die GRANT-Anweisung für die Vergabe von Privilegien.

GRANT SELECT, UPDATE, DELETE, INSERT ON hotel.customer TO david

Der Datenbankadministrator MONA verwaltet die Kundentabelle im Schema HOTEL. Er entscheidet, dass der RESOURCE-Benutzer DAVID das Recht besitzen soll, die Kundendaten zu pflegen, jedoch keine Änderung an der Struktur der Tabelle vornehmen kann.

GRANT SELECT ON hotel.customer TO PUBLIC

Alle im System befindlichen Datenbankbenutzer sollen die Möglichkeit besitzen, lesend auf die Daten der Kundentabelle zuzugreifen. Die Privilegienvergabe für alle Datenbankbenutzer kann mit Hilfe des Schlüsselwortes PUBLIC erfolgen.

Überprüfen Sie die Vergabe der Privilegien z.B. anhand der Informationen in der Systemtabelle TABLEPRIVILEGES. Melden Sie sich dazu als Benutzer DAVID an die Datenbankinstanz DEMODB an.

SELECT * FROM DOMAIN.TABLEPRIVILEGES
WHERE schemaname = 'HOTEL' AND tablename = 'CUSTOMER'

Ergebnis

SCHEMANAME | OWNER | TABLENAME | GRANTOR | GRANTEE | PRIVILEGE | IS_GRANTABLE
HOTEL | MONA | CUSTOMER | MONA | DAVID | SELECT | NO
HOTEL | MONA | CUSTOMER | MONA | DAVID | UPDATE | NO
HOTEL | MONA | CUSTOMER | MONA | DAVID | INSERT | NO
HOTEL | MONA | CUSTOMER | MONA | DAVID | DELETE | NO
HOTEL | MONA | CUSTOMER | MONA | PUBLIC | SELECT | NO

Siehe auch:

SQL-Referenzhandbuch, Strukturlink GRANT-Anweisung (grant_statement)

Systemtabellen auswerten, Strukturlink TABLEPRIVILEGES

Entziehen von Privilegien

Eröffnen Sie eine Datenbanksitzung für den Datenbankadministrator MONA und verwenden Sie die REVOKE-Anweisung für das Entziehen von Privilegien.

REVOKE DELETE ON customer FROM david

Der RESOURCE-Benutzer DAVID soll Zeilen der Kundentabelle nicht löschen dürfen.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink REVOKE-Anweisung (revoke_statement)

Löschen von Datenbankbenutzern

Verwenden Sie die DROP USER-Anweisung, um Datenbankbenutzer zu löschen.

DROP USER boris

Wenn keine CASCADE-Option oder die Option CASCADE angegeben wird, werden zusammen mit dem Datenbankbenutzer alle Synonyme und Tabellen des zu löschenden Benutzers, sowie alle darauf basierenden Indizes, Privilegien, View-Tabellen usw. gelöscht.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP USER-Anweisung (drop_user_statement)

Weitere Beispiele zur Autorisierung


Rollen (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Rollen

Eine Rolle ist eine Zusammenfassung von Privilegien, die Datenbankbenutzern, Benutzergruppen oder anderen Rollen zugewiesen werden können.

Während Privilegien immer gelten, müssen Rollen für einzelne Datenbanksitzungen explizit aktiviert werden. Jeder Benutzer, an den Rollen vergeben wurden, kann auch festlegen, welche der Rollen in jeder seiner Datenbanksitzungen aktiv sein soll. Diese Festlegung kann nach Eröffnen einer Datenbanksitzung geändert werden.

Voraussetzungen

Sie benötigen die Demo-Daten für das SQL-Tutorial.

Starten Sie das Query Tool SQL Studio als Datenbankadministrator MONA mit dem Kennwort RED und melden Sie sich an die Demo-Datenbankinstanz DEMODB an.

Anlegen einer Rolle

Eröffnen Sie eine Datenbanksitzung für den Datenbankadministrator MONA und verwenden Sie die CREATE ROLE-Anweisung für das Anlegen einer Rolle.

CREATE ROLE role_1

//

CREATE ROLE role_2

//

CREATE ROLE role_3

Die Rollen ROLE_1, ROLE_2 und ROLE_3 werden angelegt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink CREATE ROLE-Anweisung (create_role_statement)

Vergeben von Privilegien

Eröffnen Sie eine Datenbanksitzung für den Datenbankadministrator MONA und verwenden Sie die GRANT-Anweisung für die Vergabe von Privilegien.

GRANT SELECT, UPDATE, INSERT ON hotel.city TO role_1

Der Datenbankadministrator MONA verwaltet die Ortstabelle. Er entscheidet, dass der Rolle ROLE_1 die Rechte SELECT, UPDATE und INSERT für die Tabelle city zugeordnet werden.

GRANT DELETE ON hotel.city TO role_2

Der Rolle ROLE_2 wird das Recht DELETE für die Tabelle city zugeordnet.

GRANT DELETE, ALTER ON hotel.city TO role_3

Der Rolle ROLE_3 werden die Rechte DELETE und ALTER für die Tabelle city zugeordnet.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink GRANT-Anweisung (grant_statement)

Zuweisen einer Rolle

Legen Sie gegebenenfalls die Datenbankbenutzer DAVID und BORIS an, wie in Datenbankbenutzer und ihre Privilegien beschrieben.

Eröffnen Sie eine Datenbanksitzung für den Datenbankadministrator MONA und verwenden Sie die GRANT-Anweisung, um einem anderen Datenbankbenutzer die gewünschten Rollen zuzuweisen.

GRANT role_1 TO david

//

GRANT role_2 TO david

//

GRANT role_3 to boris

Die Rollen ROLE_1 und ROLE_2 werden dem Datenbankbenutzer DAVID zugewiesen.

Die Rolle ROLE_3 wird dem Datenbankbenutzer BORIS zugewiesen.

Festlegen, welche Rolle verwendet werden soll

Eröffnen Sie eine Datenbanksitzung für den Datenbankadministrator MONA. Verwenden Sie die ALTER USER-Anweisung, um festzulegen, welche der Rollen, die einem Datenbankbenutzer zugeordnet wurden, beim Eröffnen einer Datenbanksitzung verwendet werden sollen.

ALTER USER david DEFAULT ROLE role_1

ALTER USER boris DEFAULT ROLE role_3

Für den Datenbankbenutzer DAVID soll die Rolle ROLE_1, für BORIS die Rolle ROLE_3 beim Eröffnen seiner Datenbanksitzung aktiviert werden.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink ALTER USER-Anweisung (alter_user_statement)

Während einer Datenbanksitzung können Sie mit Hilfe der SET-Anweisung weitere einem Datenbankbenutzer zugeordnete Rollen aktivieren.

Eröffnen Sie eine Datenbanksitzung für den Datenbankbenutzer DAVID.

SET ROLE ALL

Alle Rollen (ROLE_1 und ROLE_2) sollen aktiviert werden.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink SET-Anweisung (set_statement)

Entziehen von Privilegien

Eröffnen Sie eine Datenbanksitzung für den Datenbankadministrator MONA und verwenden Sie die REVOKE-Anweisung für das Entziehen von Privilegien.

REVOKE DELETE ON hotel.city FROM ROLE_3

Der Rolle ROLE_3 wird das Privileg DELETE entzogen.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink REVOKE-Anweisung (revoke_statement)

Systemtabellen auswerten, Strukturlink ROLES, Strukturlink SESSION_ROLES, Strukturlink ROLEPRIVILEGES

Löschen von Rollen

Eröffnen Sie eine Datenbanksitzung für den Datenbankadministrator MONA und verwenden Sie die DROP ROLE-Anweisung, um Rollen zu löschen.

DROP ROLE ROLE_3

Die Rolle ROLE_3 wird gelöscht.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink DROP ROLE-Anweisung (drop_role_statement)

Weitere Beispiele zur Autorisierung


Loader-Tutorial (SAP-Bibliothek - Tutorials)

Komponentendokumentation Loader-Tutorial

Einsatzmöglichkeiten

Dieses Loader-Tutorial dient dazu, Ihnen die Kommandos des Loader zum Exportieren und Importieren anhand von Beispielen zu erläutern.

Einführungshinweise

Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie diese installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Eine ausführliche detaillierte Beschreibung der Loader-Kommandos finden Sie in der Dokumentation Strukturlink Loader.

Funktionsumfang

Demo-Datenbanken

Um die Beispiele des Loader-Tutorials selbst nachvollziehen zu können, benötigen Sie die Demo-Datenbanken DEMODB und TESTDB.

Beispiel-Kommandos

Die Loader-Kommandos, die in diesem Loader-Tutorial anhand von Beispielen erläutert werden sollen, lassen sich in folgende Bereiche einteilen:

● Exportieren

● Importieren

● UPDATE COLUMNS-Kommando zum Aktualisieren von Spaltenwerten

Um die Kommandos gut lesbar darzustellen, werden die Schlüsselwörter in Großbuchstaben geschrieben und die Kommandos strukturiert. Für die Ausführung eines Loader-Kommandos spielt die Groß- und Kleinschreibung der Syntaxelemente und das Setzen von Leerzeichen oder Zeilenumbrüchen keine Rolle.

Bei der Wahl der Strukturlink Bezeichner der Datenbankobjekte und der Eingabe von Werten in Form von Strukturlink Literalen kann die Groß- und Kleinschreibung von Bedeutung sein.

Betriebsmodi

Die Eingabe an den Loader kann über drei Betriebsmodi erfolgen: den interaktiven Transportmodus, den Kommandodateimodus und den Sitzungsmodus.

Die Verwendung der drei Betriebsmodi soll anhand von Beispielen erläutert werden:

● Transportmodus

● Kommandodateimodus

● Sitzungsmodus

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank, Strukturlink Objekte im Schema HOTEL


Demo-Datenbanken DEMODB und TESTDB (SAP-Bibliothek - Tutorials)

Vorgehensweisen Demo-Datenbanken DEMODB und TESTDB

Um die Beispiele des Loader-Tutorials selbst nachvollziehen zu können, benötigen Sie die Demo-Datenbankinstanzen DEMODB und TESTDB und die vollständigen Demo-Daten in der Datenbankinstanz DEMODB.

Die Datenbankinstanz DEMODB soll hauptsächlich für die Demonstration der EXPORT-Kommandos verwendet werden, die Datenbankinstanz TESTDB für die Demonstration der IMPORT-Kommandos.

Voraussetzungen

Installieren Sie die Datenbanksoftware und die Datenbankwerkzeuge.

Verfahren Sie dazu wie im Strukturlink Installationshandbuch beschrieben.

Vorgehensweise

Legen Sie eine Demo-Datenbankinstanz mit dem Namen DEMODB und eine mit dem Namen TESTDB an.

Laden Sie beim Anlegen der Datenbankinstanz DEMODB die vollständigen Demo-Daten in diese Datenbankinstanz. Laden Sie beim Anlegen der Datenbankinstanz TESTDB die Demo-Daten nicht in diese Datenbankinstanz.

Sie können zum Anlegen einer Datenbankinstanz und gegebenenfalls Laden der vollständigen Demo-Daten den Installation Manager oder den Database Manager verwenden.

● Installationshandbuch, Strukturlink Demo-Datenbankinstanz DEMODB anlegen

Im Fenster Database configuration des Installation Manager muss Load Tutorial Data markiert sein, wenn Sie die vollständigen Demo-Daten laden wollen.

● Database Manager GUI, Strukturlink Anlegen einer Datenbankinstanz: Desktop PC/Laptop

Markieren Sie Load Tutorial, um die vollständigen Demo-Daten zu laden.

● Tutorial Datenbankverwaltung, Anlegen und Konfigurieren einer Datenbankinstanz (unter Verwendung des Database Manager CLI)

Führen Sie nach dem Anlegen der Datenbankinstanz DEMODB das Kommando Strukturlink load_tutorial aus, um die vollständigen Demo-Daten zu laden.

Sie können die vollständigen Demo-Daten zu einem von Ihnen gewünschten Zeitpunkt in die bereits vorhandene Datenbankinstanz DEMODB laden, wenn Sie das Laden während des Anlegens der Datenbankinstanz nicht durchgeführt haben. Sie können zum Laden der vollständigen Demo-Daten den Database Manager verwenden.

● Database Manager GUI, Strukturlink Demo-Daten laden

● Database Manager CLI, Strukturlink load_tutorial

Ergebnis

Die Demo-Datenbanken DEMODB und TESTDB wurden angelegt.

In der Datenbank DEMODB wurde der Datenbankbenutzer MONA mit dem Kennwort RED als Datenbankadministrator (DBA) angelegt. Der Datenbankadministrator MONA kann mehrere Datenbanksitzungen gleichzeitig öffnen (NOT EXCLUSIVE).

Desweiteren wurde das Demo-Schema HOTEL erzeugt. Das Demo-Schema HOTEL widerspiegelt ein sehr vereinfachtes Modell einer Hotelverwaltung mit Informationen zu den Besuchern der Hotels, der Lage der Hotels, ihrer Auslastung, Preise der Zimmer usw. . Diese Informationen wurden in einer Reihe von einfach aufgebauten Tabellen abgelegt. Diese Tabellen sind mit Demo-Daten gefüllt und weitere Objekte, wie z.B. View-Tabellen und Indizes wurden angelegt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank, Strukturlink Objekte im Schema HOTEL

Es steht Ihnen frei, die Demo-Daten Ihren Anforderungen entsprechend zu verändern. Allerdings stimmen dann gegebenfalls die im Loader-Tutorial angegebenen Beispielergebnisse nicht mehr ganz mit Ihren Ergebnissen überein.

Das Demo-Schema HOTEL wurde für Übungs- und Testzwecke entwickelt und enthält vordefinierte Demo-Daten. Verwenden Sie die Demo-Daten nicht in einem Produktivsystem.

Die Datenbank TESTDB enthält keine Demo-Daten. Für einige Beispiele wird das Vorhandensein des Datenbankbenutzers MONA vorausgesetzt. Legen Sie in diesen Fällen den Datenbankbenutzer MONA wie folgt an:

1. Melden Sie sich mit Hilfe eines geeigneten Werkzeugs (z.B. SQL Studio) als Datenbanksystemadministrator an die Datenbankinstanz TESTDB an.

Wenn Sie die Vorschlagswerte beim Anlegen der Datenbankinstanz TESTDB übernommen haben, hat der Datenbanksystemadministrator folgende Benutzerdaten:
Benutzername: DBADMIN, Kennwort: SECRET

2. Legen Sie den Datenbankbenutzer MONA mit folgender SQL-Anweisung an.

CREATE USER mona PASSWORD red DBA NOT EXCLUSIVE

Für einige Beispiele wird das Vorhandensein des Demo-Schemas HOTEL vorausgesetzt. Legen Sie in diesen Fällen das Schema HOTEL wie folgt an:

1. Melden Sie sich mit Hilfe eines geeigneten Werkzeugs (z.B. SQL Studio) als Benutzer MONA an die Datenbankinstanz TESTDB an.

2. Legen Sie das Schema HOTEL mit folgender SQL-Anweisung an.

CREATE SCHEMA hotel


Exportieren (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Exportieren

Eine vollständige Syntaxbeschreibung der Loader-Kommandos zum Exportieren erhalten Sie im Loader-Handbuch im Abschnitt Strukturlink Exportieren: Kommandos.

Im Folgenden sollen einige wesentliche Export-Kommandos anhand von Beispielen vorgestellt werden.

Voraussetzungen

Sie benötigen die Demo-Datenbank DEMODB.

Starten Sie den Loader und melden Sie sich an die Datenbank DEMODB als Datenbankadministrator MONA mit dem Kennwort RED an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli -d demodb –u mona,red

Beispiel eines Export-Kommandos

Geben Sie das gewünschte Export-Kommando ein:

EXPORT TABLE hotel.city
  CATALOG OUTSTREAM 'city_ddl.catalog'

Das bedeutet:

...

1. Exportiere (EXPORT)

2. eine Tabelle (TABLE)

3. aus dem Schema HOTEL mit dem Namen CITY (hotel.city)

4. Exportiere die Datenbankkatalogdaten (CATALOG)

5. in die Ausgabedatei (OUTSTREAM)

6. mit dem Namen city_ddl.catalog

Alle von der Tabelle CITY abhängigen Objektdefinitionen (z.B. View-Tabellen) werden ebenfalls in die Datei city_ddl.catalog exportiert.

Beispiele

EXPORT DB

EXPORT USER

EXPORT SCHEMA

EXPORT TABLE

EXPORT COLUMNS

Die so erzeugten Export-Datenströme können Sie für einen Import der Daten in eine von Ihnen gewünschte Datenbankinstanz verwenden.


EXPORT DB (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt EXPORT DB

Mit dem EXPORT DB-Kommando können Sie die Daten, die zur Anwendung einer Datenbank gehören, exportieren.

Voraussetzungen

Sie benötigen die Demo-Datenbank DEMODB.

Das EXPORT DB-Kommando kann nur vom Datenbanksystemadministrator (SYSDBA-Benutzer) ausgeführt werden. Starten Sie daher den Loader als Datenbanksystemadministrator und melden Sie sich an die Datenbank DEMODB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli -d demodb –u dbadmin,secret

Beispiele

Die Daten der Datenbank DEMODB sollen exportiert werden.

Durch die Angaben nach dem Schlüsselwort CATALOG und/oder DATA können Sie steuern, ob Sie den Datenbankkatalog und/oder die Daten, die zur Anwendung gehören, exportieren wollen.

Export des Datenbankkatalogs

Sie können die Datenbankkataloginformationen aller Datenbankbenutzer exportieren, die zur Anwendung der Datenbank gehören.

EXPORT DB
CATALOG OUTSTREAM 'demodb_ddl.catalog'

Der Datenbankkatalog (CATALOG) wird im Format DDL (Vorschlagswert) exportiert.

Siehe auch:

Loader, Strukturlink Datenstrom

Export der Anwendungsdaten

Sie können die Anwendungsdaten aller Datenbankbenutzer exportieren.

EXPORT DB
DATA OUTSTREAM 'demodb_pages.data'

Die Anwendungsdaten (DATA) werden im Format PAGES (Vorschlagswert) exportiert.

EXPORT DB
DATA OUTSTREAM 'demodb_records.data' RECORDS

Die Anwendungsdaten (DATA) werden im Format RECORDS exportiert.

Da im Falle der Verwendung von PAGES ein datenbankeigenes Format (auf Basis einer Seite) verwendet wird, ist dieser Export schneller als ein Export über das Loader-eigene Format RECORDS.

Die Datendateien dürfen in beiden Fällen nicht verändert werden, da es sich um ein Loader-eigenes Binärformat handelt.

Siehe auch:

Loader, Strukturlink PAGES, RECORDS

Export des Datenbankkatalogs und der Anwendungsdaten

Sie können die Daten, die zur Anwendung einer Datenbank gehören, exportieren.

EXPORT DB
CATALOG OUTSTREAM 'demodb_ddl.catalog'
DATA OUTSTREAM 'demodb_pages.data'

Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie stets zuerst das Syntaxelement zum Export des Datenbankkatalogs und dann das Syntaxelement zum Export der Anwendungsdaten an.

Tabellen vom Export ausschließen

Durch die Angabe eines Datenstroms nach dem Schlüsselwort CONFIGURATION können die Anwendungsdaten der Tabellen, die in diesem Datenstrom angegeben sind, vom Export ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens spezifiziert sein.

Die Tabellen CITY und HOTEL sollen vom Export ausgeschlossen werden. Legen Sie die Datei hotel_table.configuration mit folgendem Inhalt an:

HOTEL,CITY

HOTEL,HOTEL

Geben Sie folgendes Export-Kommando im Loader-Sitzungsmodus an. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst das Syntaxelement an, das die Tabellen vom Export ausschließt.

EXPORT DB
CONFIGURATION INSTREAM 'hotel_table.configuration'
CATALOG OUTSTREAM 'demodb_ddl.catalog'
DATA OUTSTREAM 'demodb_pages.data'

Die Datenbankkatalogeinträge aller Tabellen werden unabhängig von den in hotel_table.configuration gemachten Einschränkungen immer exportiert.

Zusätzliche Protokollfunktionalität

Durch die Angabe eines Datenstroms nach dem Schlüsselwort PACKAGE werden die Kommando-Einträge in der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den angegebenen Datenstrom exportiert. Damit haben Sie eine weitere Möglichkeit der Protokollierung. Geben Sie das PACKAGE-Syntaxelement stets als letztes Syntaxelement an.

EXPORT DB
CATALOG OUTSTREAM 'demodb_ddl.catalog'
PACKAGE OUTSTREAM 'demodb_csv.package'

Siehe auch:

Loader, Strukturlink Zusätzliche Protokollfunktionalität (package_spec)

Vollständige Syntax des EXPORT DB-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

EXPORT DB
CONFIGURATION INSTREAM FILE 'hotel_table.configuration' CSV ASCII
 CATALOG OUTSTREAM FILE 'demodb_ddl.catalog' DDL
DATA OUTSTREAM FILE 'demodb_pages.data' PAGES
PACKAGE OUTSTREAM FILE 'demodb_csv.package' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink EXPORT DB-Kommando.

Siehe auch:

Weitere Beispiel-Kommandos zum Exportieren

Korrespondierendes Import-Kommando IMPORT DB


EXPORT USER (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt EXPORT USER

Mit dem EXPORT USER-Kommando können Sie die Daten, die zur Anwendung des an die Datenbank angemeldeten Datenbankbenutzers gehören, exportieren.

Voraussetzungen

Sie benötigen die Beispiel-Datenbank DEMODB.

Mit dem EXPORT USER-Kommando können die Objekte exportiert werden, dessen Eigentümer der an die Datenbankinstanz angemeldete Datenbankbenutzer ist. Starten Sie den Loader als Datenbankadministrator MONA und melden Sie sich an die Datenbank DEMODB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d demodb –u mona,red

Beispiele

Die Daten des Benutzers MONA sollen exportiert werden.

Durch die Angaben nach dem Schlüsselwort CATALOG und/oder DATA können Sie steuern, ob Sie den Datenbankkatalog und/oder die Daten, die zur Anwendung gehören, exportieren wollen.

Export des Datenbankkatalogs des angemeldeten Datenbankbenutzers

Sie können die Datenbankkataloginformationen des Datenbankbenutzers exportieren, die zur Anwendung gehören.

EXPORT USER
CATALOG OUTSTREAM 'mona_ddl.catalog'

Der Datenbankkatalog (CATALOG) wird im Format DDL (Vorschlagswert) exportiert.

Siehe auch:

Loader, Strukturlink Datenstrom

Export der Anwendungsdaten des angemeldeten Datenbankbenutzers

Sie können die Anwendungsdaten des Datenbankbenutzers exportieren.

EXPORT USER
DATA OUTSTREAM 'mona_pages.data'

Die Anwendungsdaten (DATA) werden im Format PAGES (Vorschlagswert) exportiert.

EXPORT DB
DATA OUTSTREAM 'mona_records.data' RECORDS

Die Anwendungsdaten (DATA) werden im Format RECORDS exportiert.

Da im Falle der Verwendung von PAGES ein datenbankeigenes Format (auf Basis einer Seite) verwendet wird, ist dieser Export schneller als ein Export über das Loader-eigene Format RECORDS.

Die Datendateien dürfen in beiden Fällen nicht verändert werden, da es sich um ein Loader-eigenes Binärformat handelt.

Siehe auch:

Loader, Strukturlink PAGES, RECORDS

Export des Datenbankkatalogs und der Anwendungsdaten des angemeldeten Datenbankbenutzers

Sie können die Daten, die zur Anwendung des an die Datenbank angemeldeten Datenbankbenutzers gehören, exportieren.

EXPORT USER
CATALOG OUTSTREAM 'mona_ddl.catalog'
DATA OUTSTREAM 'mona_pages.data'

Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie stets zuerst das Syntaxelement zum Export des Datenbankkatalogs und dann das Syntaxelement zum Export der Anwendungsdaten an.

Tabellen vom Export ausschließen

Durch die Angabe eines Datenstroms nach dem Schlüsselwort CONFIGURATION können die Anwendungsdaten der Tabellen, die in diesem Datenstrom angegeben sind, vom Export ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.

Die Tabellen CITY und HOTEL sollen vom Export ausgeschlossen werden. Legen Sie die Datei hotel_table.configuration mit folgendem Inhalt an:

HOTEL,CITY

HOTEL,HOTEL

Geben Sie folgendes Export-Kommando im Loader-Sitzungsmodus an. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst das Syntaxelement an, das die Tabellen vom Export ausschließt.

EXPORT USER
CONFIGURATION INSTREAM 'hotel_table.configuration'
 CATALOG OUTSTREAM 'mona_ddl.catalog'
DATA OUTSTREAM 'mona_pages.data'

Die Datenbankkatalogeinträge aller Tabellen werden unabhängig von den in hotel_table.configuration gemachten Einschränkungen immer exportiert.

Zusätzliche Protokollfunktionalität

Durch die Angabe eines Datenstroms nach dem Schlüsselwort PACKAGE werden die Kommando-Einträge in der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den angegebenen Datenstrom exportiert. Damit haben Sie eine weitere Möglichkeit der Protokollierung. Geben Sie das PACKAGE-Syntaxelement stets als letztes Syntaxelement an.

EXPORT USER
CATALOG OUTSTREAM 'mona_ddl.catalog'
 PACKAGE OUTSTREAM 'mona_csv.package'

Siehe auch:

Loader, Strukturlink Zusätzliche Protokollfunktionalität (package_spec)

Vollständige Syntax des EXPORT USER-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihefolge der Syntaxelemente.

EXPORT USER
CONFIGURATION INSTREAM FILE 'hotel_table.configuration' CSV ASCII
 CATALOG OUTSTREAM FILE 'mona_ddl.catalog' DDL
DATA OUTSTREAM FILE 'mona_pages.data' PAGES
 PACKAGE OUTSTREAM FILE 'mona_csv.package' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink EXPORT USER-Kommando.

Siehe auch:

Weitere Beispiel-Kommandos zum Exportieren

Korrespondierendes Import-Kommando IMPORT USER


EXPORT SCHEMA (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt EXPORT SCHEMA

Mit dem EXPORT SCHEMA-Kommando können Sie die Daten, die zur Anwendung des angegebenen Schemas gehören, exportieren.

Voraussetzungen

Sie benötigen die Beispiel-Datenbank DEMODB.

Das EXPORT SCHEMA-Kommando kann nur vom Eigentümer des Schemas ausgeführt werden. Starten Sie den Loader als Datenbankadministrator MONA und melden Sie sich an die Datenbank DEMODB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d demodb –u mona,red

Beispiele

Die Daten des Schemas HOTEL sollen exportiert werden.

Durch die Angaben nach dem Schlüsselwort CATALOG und/oder DATA können Sie steuern, ob Sie den Datenbankkatalog und/oder die Daten, die zur Anwendung gehören, exportieren wollen.

Export des Datenbankkatalogs eines Schemas

Sie können die Datenbankkataloginformationen exportieren, die zur Anwendung des Schemas gehören.

EXPORT SCHEMA hotel
CATALOG OUTSTREAM 'hotel_ddl.catalog'

Der Datenbankkatalog (CATALOG) wird im Format DDL (Vorschlagswert) exportiert.

Siehe auch:

Loader, Strukturlink Datenstrom

Export der Anwendungsdaten eines Schemas

Sie können die Anwendungsdaten des Schemas exportieren.

EXPORT SCHEMA hotel
DATA OUTSTREAM 'hotel_pages.data'

Die Anwendungsdaten (DATA) werden im Format PAGES (Vorschlagswert) exportiert.

EXPORT SCHEMA hotel
DATA OUTSTREAM 'hotel_records.data' RECORDS

Die Anwendungsdaten (DATA) werden im Format RECORDS exportiert.

Da im Falle der Verwendung von PAGES ein datenbankeigenes Format (auf Basis einer Seite) verwendet wird, ist dieser Export schneller als ein Export über das Loader-eigene Format RECORDS.

Die Datendateien dürfen in beiden Fällen nicht verändert werden, da es sich um ein Loader-eigenes Binärformat handelt.

Siehe auch:

Loader, Strukturlink PAGES, RECORDS

Export des Datenbankkatalogs und der Anwendungsdaten eines Schemas

Sie können die Daten, die zur Anwendung des angegebenen Schemas gehören, exportieren.

EXPORT SCHEMA hotel
CATALOG OUTSTREAM 'hotel_ddl.catalog'
DATA OUTSTREAM 'hotel_pages.data'

Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie stets zuerst das Syntaxelement zum Export des Datenbankkatalogs und dann das Syntaxelement zum Export der Anwendungsdaten an.

Tabellen vom Export ausschließen

Durch die Angabe eines Datenstroms nach dem Schlüsselwort CONFIGURATION können die Anwendungsdaten der Tabellen, die in diesem Datenstrom angegeben sind, vom Export ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.

Die Tabellen CITY und HOTEL sollen vom Export ausgeschlossen werden.

Legen Sie die Datei hotel_table.configuration mit folgendem Inhalt an:

HOTEL,CITY

HOTEL,HOTEL

Geben Sie folgendes Export-Kommando im Loader-Sitzungsmodus an. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst das Syntaxelement an, das die Tabellen vom Export ausschließt.

EXPORT SCHEMA hotel
CONFIGURATION INSTREAM 'hotel_table.configuration'
 CATALOG OUTSTREAM 'hotel_ddl.catalog'
DATA OUTSTREAM 'hotel_records.data'

Die Datenbankkatalogeinträge aller Tabellen werden unabhängig von den in hotel_table.configuration gemachten Einschränkungen immer exportiert.

Zusätzliche Protokollfunktionalität

Durch die Angabe eines Datenstroms nach dem Schlüsselwort PACKAGE werden die Kommando-Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den angegebenen Datenstrom exportiert. Damit haben Sie eine weitere Möglichkeit der Protokollierung. Geben Sie das PACKAGE-Syntaxelement stets als letztes Syntaxelement an.

EXPORT SCHEMA hotel
CATALOG OUTSTREAM 'hotel_ddl.catalog'
 PACKAGE OUTSTREAM 'hotel_csv.package'

Siehe auch:

Loader, Strukturlink Zusätzliche Protokollfunktionalität (package_spec)

Vollständige Syntax des EXPORT SCHEMA-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

EXPORT SCHEMA hotel
CONFIGURATION INSTREAM FILE 'hotel_table.configuration' CSV ASCII
CATALOG OUTSTREAM FILE 'hotel_ddl.catalog' DDL
DATA OUTSTREAM FILE 'hotel_pages.data' PAGES
PACKAGE OUSTREAM FILE 'hotel_csv.package' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink EXPORT SCHEMA-Kommando.

Siehe auch:

Weitere Kommandos zum Exportieren

Korrespondierendes Import-Kommando IMPORT SCHEMA


EXPORT TABLE (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt EXPORT TABLE

Mit dem EXPORT TABLE-Kommando können Sie die gesamten Daten einer angegebenen Tabelle exportieren.

Voraussetzungen

Sie benötigen die Beispiel-Datenbank DEMODB.

Die gewünschten Tabellen müssen in der Datenbankinstanz vorhanden sein. Das Kommando EXPORT TABLE ...PAGES kann nur vom Eigentümer der Tabelle ausgeführt werden. In allen anderen Fällen müssen Sie die Zugriffsberechtigung für die zu exportierende Tabelle haben.

Starten Sie den Loader als Datenbankadministrator MONA und melden Sie sich an die Datenbank DEMODB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d demodb –u mona,red

Beispiele

Die gesamten Daten der Tabelle ROOM des Schemas HOTEL sollen exportiert werden. Eine Auswahl bestimmter Spaltenwerte ist mit dem EXPORT TABLE-Kommando nicht möglich, sondern nur mit dem EXPORT COLUMNS-Kommando.

Durch die Angaben nach dem Schlüsselwort CATALOG und/oder DATA können Sie steuern, ob Sie den Datenbankkatalog und/oder die Anwendungsdaten exportieren wollen.

Export des Datenbankkatalogs einer Tabelle

Sie können alle Datenbankkataloginformationen einer Tabelle exportieren.

EXPORT TABLE hotel.room
CATALOG OUTSTREAM 'room_ddl.catalog'

Der Datenbankkatalog (CATALOG) wird im Format DDL exportiert.

Siehe auch:

Loader, Strukturlink Datenstrom

Export der Anwendungsdaten einer Tabelle

Sie können alle Anwendungsdaten einer Tabelle exportieren.

EXPORT TABLE hotel.room
DATA OUTSTREAM 'room_csv.data'

Die Anwendungsdaten (DATA) werden im Format CSV (Vorschlagswert) exportiert.

EXPORT TABLE hotel.room
DATA OUTSTREAM 'room_fwv.data' FWV

Die Anwendungsdaten (DATA) werden im Format FWV exportiert.

EXPORT TABLE hotel.room
DATA OUTSTREAM 'room_fwvbinary.data' FWV BINARY

Die Anwendungsdaten (DATA) werden im Format FWV BINARY exportiert.

Siehe auch:

Loader, Strukturlink CSV, FWV, FWV BINARY

EXPORT TABLE hotel.room
DATA OUTSTREAM 'room_pages.data' PAGES

Die Anwendungsdaten (DATA) werden im Format PAGES exportiert.

EXPORT TABLE hotel.room
DATA OUTSTREAM 'room_records.data' RECORDS

Die Anwendungsdaten (DATA) werden im Format RECORDS exportiert.

Da im Falle der Verwendung von PAGES ein datenbankeigenes Format (auf Basis einer Seite) verwendet wird, ist dieser Export schneller als z.B. ein Export über das Loader-eigene Format RECORDS.

Die Datendateien im Format PAGES, RECORDS und FWV BINARY dürfen nicht verändert werden, da es sich jeweils um ein Loader-eigenes Binärformat handelt.

Siehe auch:

Loader, Strukturlink PAGES, RECORDS

Export des Datenbankkatalogs und der Anwendungsdaten einer Tabelle

Sie können die gesamten Daten der angegebenen Tabelle exportieren.

EXPORT TABLE hotel.room
CATALOG OUTSTREAM 'room_ddl.catalog'
DATA OUTSTREAM 'room_csv.data'

Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie stets zuerst das Syntaxelement zum Export des Datenbankkatalogs und dann das Syntaxelement zum Export der Anwendungsdaten an.

Reihenfolge der Tabellenzeilen

Um die Tabellenzeilen im Datenstrom in einer bestimmten Reihenfolge anzuordnen, können Sie die ORDER-Klausel verwenden. Die in der ORDER-Klausel angegebenen Spalten legen die Sortierreihenfolge fest. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst die ORDER-Klausel an.

EXPORT TABLE hotel.room
ORDER BY price
 CATALOG OUTSTREAM 'room_ddl.catalog'
DATA OUTSTREAM 'room_csv.data'

Die Zeilen der Tabelle ROOM werden nach den Werten in der Spalte PRICE sortiert in den Datenstrom exportiert.

Zusätzliche Protokollfunktionalität

Durch die Angabe eines Datenstroms nach dem Schlüsselwort PACKAGE werden die Kommando-Einträge in der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den angegebenen Datenstrom exportiert. Damit haben Sie eine weitere Möglichkeit der Protokollierung. Geben Sie das PACKAGE-Syntaxelement stets als letztes Syntaxelement an.

EXPORT TABLE hotel.room
CATALOG OUTSTREAM 'room_ddl.catalog'
 PACKAGE OUTSTREAM 'room_csv.package'

Siehe auch:

Loader, Strukturlink Zusätzliche Protokollfunktionalität (package_spec)

Behandlung von LONG-Werten

Wenn Sie die Formate CSV und FWV [BINARY] verwenden, werden für die LONG-Daten extra Datenströme angelegt.

Die Daten der Tabelle HOTEL des Schemas HOTEL sollen in einen CSV-Datenstrom exportiert werden. DieTabelle HOTEL besitzt die LONG-Spalte INFO. Geben Sie das LOB-Syntaxelement nach dem DATA-Syntaxelement an.

EXPORT TABLE hotel.hotel
DATA OUTSTREAM 'hotel_csv.data'
 LOB OUTSTREAM INFO 'hotel_info_csv.long'

Alle Spalten der Tabelle HOTEL werden exportiert. Die LONG-Werte befinden sich in der Datei hotel_info_csv.long.

Wenn Sie die Formate PAGES und RECORDS verwenden, werden sämtliche Tabellendaten in einem Datenstrom abgelegt, also auch die LONG-Daten. Ein LOB-Syntaxelement ist daher nicht erforderlich.

EXPORT TABLE hotel.hotel.
DATA OUTSTREAM 'hotel_records.data' RECORDS

Alle Spalten der Tabelle HOTEL einschließlich der LONG-Spalte INFO werden in den Datenstrom hotel_records.data exportiert.

Siehe auch:

Loader, Strukturlink Exportieren und Importieren von LONG-Werten

Vollständige Syntax des EXPORT TABLE-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

EXPORT TABLE hotel.room
ORDER BY price
CATALOG OUTSTREAM FILE 'room_ddl.catalog' DDL
DATA OUTSTREAM FILE 'room_csv.data' CSV
PACKAGE OUTSTREAM FILE 'room_csv.package' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink EXPORT TABLE-Kommando.

Wenn Sie nicht die gesamten Daten einer Tabelle, sondern nur ausgewählte Spaltenwerte exportieren wollen, wählen Sie das Strukturlink EXPORT COLUMNS-Kommando.

Siehe auch:

Weitere Kommandos zum Exportieren

Korrespondierendes Import-Kommando IMPORT TABLE


EXPORT COLUMNS (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt EXPORT COLUMNS

Mit dem EXPORT COLUMNS-Kommando können Sie einzelne Spaltenwerte einer Tabelle exportieren.

Voraussetzungen

Sie benötigen die Beispiel-Datenbank DEMODB.

Die gewünschten Tabellen müssen in der Datenbankinstanz vorhanden sein. Das Kommando EXPORT COLUMNS können Sie nur ausführen, wenn Sie die Zugriffsberechtigung für die zu exportierende/n Tabelle/n haben.

Starten Sie den Loader als Datenbankadministrator MONA und melden Sie sich an die Datenbank DEMODB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d demodb –u mona,red

Beispiele

Die Daten der Tabelle CUSTOMER des Schemas HOTEL sollen exportiert werden.

Nach den Schlüsselwörtern EXPORT COLUMNS können Sie die gewünschten Tabellenspalten und ihre Reihenfolge wie in einer SELECT-Anweisung angeben.

Durch die Angaben nach dem Schlüsselwort DATA können Sie steuern, wohin die Anwendungsdaten exportiert werden sollen.

Export aller Anwendungsdaten einer Tabelle

Sie können die Anwendungsdaten einer Tabelle exportieren.

EXPORT COLUMNS * FROM hotel.customer
DATA OUTSTREAM 'customer_csv.data'

Die Anwendungsdaten (DATA) werden im Format CSV (Vorschlagswert) exportiert.

EXPORT COLUMNS * FROM hotel.customer
DATA OUTSTREAM 'customer_fwv.data' FWV

Die Anwendungsdaten (DATA) werden im Format FWV exportiert.

EXPORT COLUMNS * FROM hotel.customer
DATA OUTSTREAM 'customer_fwvbinary.data' FWV BINARY

Die Anwendungsdaten (DATA) werden im Format FWV BINARY exportiert.

Eine Datendatei im Format FWV BINARY darf nicht verändert werden, da es ich um ein Loader-eigenes Binärformat handelt.

Siehe auch:

Loader, Strukturlink Datenstrom, Strukturlink CSV, FWV, FWV BINARY

Sie können das Kommando EXPORT COLUMNS * ... DATA ... oder auch das Kommando EXPORT TABLE ... DATA ... verwenden, um alle Anwendungsdaten einer Tabelle zu exportieren. In beiden Fällen werden alle Daten in der durch die Anordnung der Tabellenspalten vorgegebenen Reihenfolge exportiert.

Export der Anwendungsdaten bestimmter Spalten einer Tabelle

Sie können einzelne Spaltenwerte einer Tabelle exportieren.

EXPORT COLUMNS cno, title, name, zip, address FROM hotel.customer
DATA OUTSTREAM 'customer_csv.data'

Die Spalten CNO, TITLE, NAME, ZIP und ADDRESS der Tabelle CUSTOMER werden in der angegebenen Reihenfolge exportiert.

EXPORT COLUMNS title, name, cno, zip, address FROM hotel.customer
DATA OUTSTREAM 'customer_csv.data'

Die Spalten TITLE, NAME, CNO, ZIP und ADDRESS der Tabelle CUSTOMER werden in der angegebenen Reihenfolge exportiert.

Reihenfolge der Tabellenzeilen

Um die Tabellenzeilen im Datenstrom in einer bestimmten Reihenfolge anzuordnen, können Sie die ORDER-Klausel verwenden. Die in der ORDER-Klausel angegebenen Spalten legen die Sortierreihenfolge fest. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst die ORDER-Klausel an.

EXPORT COLUMNS name, title, cno, zip, address
FROM hotel.customer
ORDER BY name, zip
 DATA OUTSTREAM 'customer_csv.data'

Die Zeilen der Tabelle CUSTOMER werden nach den Werten in den Spalten NAME und ZIP sortiert in den Datenstrom exportiert.

Lock-Option und Isolation-Level festlegen

Häufig verwendet werden die Syntaxelemente zum Setzen einer Sperre und zum Festlegen des Isolation-Levels. Beachten Sie die Reihenfolge der Syntaxelemente, die durch die Syntaxregeln für eine SELECT-Anweisung festgelegt wird.

EXPORT COLUMNS cno, title, name, zip, address
FROM hotel.customer
WITH LOCK
ISOLATION LEVEL 0
DATA OUTSTREAM 'customer_csv.data'

Die angegebenen Spalten der Tabelle CUSTOMER werden exportiert. Dabei werden die LOCK-Option und der Isolation-Level 0 gesetzt.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink SELECT-Anweisung (select_statement)

Reihenfolge der Tabellenspalten im Datenstrom

Nach den Schlüsselwörtern MAP COLUMNS können Sie die Reihenfolge der Tabellenspalten im Datenstrom festlegen. Beachten Sie die Reihenfolge der Syntaxelemente.

EXPORT COLUMNS * FROM hotel.customer
 MAP COLUMNS
cno 1-5
title 6-13
name 14-54
firstname 55-75
zip 76-81
address 82-122
 DATA OUTSTREAM 'customer_fwv.data' FWV

Alle Spaltenwerte werden exportiert und im Datenstrom in der Reihenfolge CNO, TITLE, NAME, FIRSTNAME, ZIP, ADDRESS abgelegt.

Diese Möglichkeit besteht auch, wenn sie nur ausgewählte Spalten exportieren.

EXPORT COLUMNS cno, title, name, zip, address
FROM hotel.customer
 MAP COLUMNS
name 1
title 2
cno 3
zip 4
address 5
 DATA OUTSTREAM 'customer_csv.data'

Die Spaltenwerte CNO, TITLE, NAME, ZIP, ADDRESS werden exportiert und im Datenstrom in der Reihenfolge NAME, TITLE, CNO, ZIP, ADDRESS abgelegt.

Behandlung von LONG-Werten

Wenn Sie die Formate CSV und FWV [BINARY] verwenden, werden für die LONG-Daten extra Datenströme angelegt.

Die Daten der Tabelle HOTEL des Schemas HOTEL sollen in einen CSV-Datenstrom exportiert werden. Die Tabelle HOTEL besitzt die LONG-Spalte INFO. Geben Sie das LOB-Syntaxelement nach dem DATA-Syntaxelement an.

EXPORT COLUMNS * FROM hotel.hotel
  DATA OUTSTREAM 'hotel_csv.data'
  LOB OUTSTREAM INFO 'hotel_info_csv.long'

Alle Spalten der Tabelle HOTEL werden exportiert. Die LONG-Werte befinden sich im Datenstrom hotel_info_csv.long.

Siehe auch:

Loader, Strukturlink Exportieren und Importieren von LONG-Werten

Vollständige Syntax des EXPORT COLUMNS-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

EXPORT COLUMNS cno, title, name, zip, address
FROM hotel.customer
ORDER BY name, zip
WITH LOCK
ISOLATION LEVEL 0
MAP COLUMNS
cno 1-4 INTEGER
title 5-12
name 13-53
zip 54-59
address 60-100
DATA OUTSTREAM 'customer_fwvbinary.data' FWV BINARY

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink EXPORT COLUMNS-Kommando.

Siehe auch:

Weitere Kommandos zum Exportieren

Korrespondierendes Import-Kommando IMPORT COLUMNS


Importieren (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Importieren

Eine vollständige Syntaxbeschreibung der Loader-Kommandos zum Importieren erhalten Sie im Loader-Handbuch im Abschnitt Strukturlink Importieren: Kommandos.

Im Folgenden sollen einige wesentliche Import-Kommandos anhand von Beispielen vorgestellt werden.

Voraussetzungen

Sie benötigen die Demo-Datenbank TESTDB. Sie haben die erforderlichen Daten exportiert.

Beispiel eines Import-Kommandos

Starten Sie den Loader als Datenbankadministrator MONA mit dem Kennwort RED für die Datenbank TESTDB ( Strukturlink Aufrufen des Loader). Legen Sie das Schema HOTEL an.

Importieren Sie die Datenbankkatalogdaten, die Sie exportiert haben, in das Schema HOTEL der Testdatenbank TESTDB.

IMPORT TABLE hotel.city
CATALOG INSTREAM 'city_ddl.catalog'

Das bedeutet:

...

1. Importiere (IMPORT)

2. eine Tabelle (TABLE)

3. mit dem Namen CITY (hotel.city)

4. Importiere die Datenbankkatalogdaten (CATALOG)

5. aus der Eingabedatei (INSTREAM)

6. mit dem Namen city_ddl.catalog

Alle von der Tabelle CITY abhängigen Objekte (z.B. View-Tabellen, Indizes), die in city_ddl.catalog verzeichnet sind, werden importiert. Wenn für das Anlegen eines abhängigen Objektes weitere Objekte erforderlich sind (z.B. weitere Tabellen für das Anlegen einer View-Tabelle), werden die abhängigen Objekte nur dann importiert, wenn die weiteren Objekte vorhanden sind.

Beispiele

IMPORT DB

IMPORT USER

IMPORT SCHEMA

IMPORT TABLE

IMPORT COLUMNS


IMPORT DB (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt IMPORT DB

Mit dem IMPORT DB-Kommando können Sie alle Daten, die zur Anwendung einer Datenbank gehören, importieren.

Voraussetzungen

Sie benötigen die Beispiel-Datenbank TESTDB.

Sie haben die erforderlichen Daten mit dem EXPORT DB-Kommando exportiert.

Das IMPORT DB-Kommando kann nur vom Datenbanksystemadministrator (SYSDBA-Benutzer) ausgeführt werden. Starten Sie daher den Loader als Datenbanksystemadministrator und melden Sie sich an die Datenbank TESTDB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d testdb –dbadmin,secret

Beispiele

In die Datenbank TESTDB sollen Daten importiert werden.

Durch die Angaben nach dem Schlüsselwort CATALOG und/oder DATA können Sie steuern, ob Sie den Datenbankkatalog und/oder die Daten, die zur Anwendung gehören, importieren wollen.

Wenn Sie Tabellen importieren, legt der Loader auch alle für die Tabelle definierten Objekte und Verknüpfungen (Views, Fremdschlüsselbeziehungen zu anderen Tabellen...) an. Gegebenenfalls meldet der Loader, wenn die dafür erforderlichen Objekte nicht vorhanden sind und daher der Import nicht ausgeführt werden kann. Typische Fehlermeldungen sind z.B. die Fehlermeldungen Strukturlink -25451 und Strukturlink -25392. Wenn solche Fehler auftreten, wird der Import an dieser Stelle abgebrochen.

Import des Datenbankkatalogs

Sie können die Datenbankkataloginformationen aller Datenbankbenutzer importieren, die zur Anwendung einer Datenbank gehören.

IMPORT DB
CATALOG INSTREAM 'demodb_ddl.catalog'

Der Datenbankkatalog (CATALOG) wird im Format DDL (Vorschlagswert) importiert.

Siehe auch:

Loader, Strukturlink Datenstrom

Import der Anwendungsdaten

Sie können die Anwendungsdaten aller Datenbankbenutzer importieren.

IMPORT DB
DATA INSTREAM 'demodb_pages.data'

Die Anwendungsdaten (DATA) werden im Format PAGES (Vorschlagswert) importiert.

IMPORT DB
DATA INSTREAM 'demodb_records.data' RECORDS

Die Anwendungsdaten (DATA) werden im Format RECORDS importiert.

Da im Falle der Verwendung von PAGES ein datenbankeigenes Format (auf Basis einer Seite) verwendet wird und keine Log-Einträge geschrieben werden, ist dieser Import schneller als ein Import über das Loader-eigene Format RECORDS. Allerdings sind die im Format PAGES importierten Tabellen so lange schreibgeschützt, bis Sie eine Datensicherung durchgeführt haben.

Siehe auch:

Loader, Strukturlink PAGES, RECORDS

Import des Datenbankkatalogs und der Anwendungsdaten

Sie können die Daten, die zur Anwendung einer Datenbank gehören, importieren.

IMPORT DB
CATALOG INSTREAM 'demodb_ddl.catalog'
DATA INSTREAM 'demodb_pages.data'

Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie stets zuerst das Syntaxelement zum Import des Datenbankkatalogs und dann das Syntaxelement zum Import der Anwendungsdaten an.

Tabellen vom Import ausschließen

Durch die Angabe eines Datenstroms nach dem Schlüsselwort CONFIGURATION können die Anwendungsdaten der Tabellen, die in diesem Datenstrom angegeben sind, vom Import ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.

Testen Sie das Loader-Verhalten für verschiedene Tabellen. Durch den Ausschluss von Tabellen dürfen keine Abhängigkeiten verletzt werden, wie das z.B. bei Ausschluss der Tabelle CITY oder HOTEL der Fall wäre.

Die Tabelle EMPLOYEE soll vom Import ausgeschlossen werden. Legen Sie die Datei employee.configuration mit folgendem Inhalt an:

HOTEL,EMPLOYEE

Geben Sie folgendes Import-Kommando im Loader-Sitzungsmodus an. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst das Syntaxelement an, das die Tabellen vom Import ausschließt.

IMPORT DB
CONFIGURATION INSTREAM 'employee.configuration'
CATALOG INSTREAM 'demodb_ddl.catalog'
DATA INSTREAM 'demodb_pages.data'

Die Datenbankkatalogeinträge aller Tabellen werden unabhängig von den in employee.configuration gemachten Einschränkungen immer importiert.

Zusätzliche Protokollfunktionalität

Durch die Angabe eines Datenstroms nach dem Schlüsselwort PACKAGE werden die Kommando-Einträge in der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den angegebenen Datenstrom exportiert. Damit haben Sie eine weitere Möglichkeit der Protokollierung. Geben Sie das PACKAGE-Syntaxelement stets als letztes Syntaxelement an.

IMPORT DB
CATALOG INSTREAM 'demodb_ddl.catalog'
 PACKAGE OUTSTREAM 'demodb_csv.package'

Siehe auch:

Loader, Strukturlink Zusätzliche Protokollfunktionalität (package_spec)

Vollständige Syntax des IMPORT DB-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

IMPORT DB
CONFIGURATION INSTREAM FILE 'employee.configuration' CSV ASCII
CATALOG INSTREAM FILE 'demodb_ddl.catalog' DDL
DATA INSTREAM FILE 'demodb_pages.data' PAGES
PACKAGE OUTSTREAM FILE 'demodb_import.package' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink IMPORT DB-Kommando.

Siehe auch:

Weitere Kommandos zum Importieren


IMPORT USER (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt IMPORT USER

Mit dem IMPORT USER-Kommando können Sie Daten importieren, die benutzerspezifisch exportiert wurden. Diese importierten Daten gehören dann dem Datenbankbenutzer, der zum Zeitpunkt des Imports an die Datenbank angemeldet ist.

Voraussetzungen

Sie benötigen die Beispiel-Datenbank TESTDB. Legen Sie den Datenbankbenutzer MONA an, falls dieser noch nicht vorhanden ist.

Sie haben die erforderlichen Daten mit dem EXPORT USER-Kommando exportiert.

Starten Sie den Loader als Datenbankadministrator MONA und melden Sie sich an die Datenbank TESTDB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d testdb –u mona,red

Beispiele

In die Datenbank TESTDB sollen Daten importiert werden, die dann dem Datenbankbenutzer MONA gehören.

Durch die Angaben nach dem Schlüsselwort CATALOG und/oder DATA können Sie steuern, ob Sie den Datenbankkatalog und/oder die Anwendungsdaten importieren wollen.

Wenn Sie Tabellen importieren, legt der Loader auch alle für die Tabelle definierten Objekte und Verknüpfungen (Views, Fremdschlüsselbeziehungen zu anderen Tabellen...) an. Gegebenenfalls meldet der Loader, wenn die dafür erforderlichen Objekte nicht vorhanden sind und daher der Import nicht ausgeführt werden kann. Typische Fehlermeldungen sind z.B. die Fehlermeldungen Strukturlink -25451 und Strukturlink -25392. Wenn solche Fehler auftreten, wird der Import an dieser Stelle abgebrochen.

Import des Datenbankkatalogs für den angemeldeten Datenbankbenutzer

Sie können die benutzerspezifischen Datenbankkataloginformationen importieren, die zur Anwendung gehören.

IMPORT USER
CATALOG INSTREAM 'mona_ddl.catalog'

Der Datenbankkatalog (CATALOG) wird im Format DDL (Vorschlagswert) importiert.

Siehe auch:

Loader, Strukturlink Datenstrom

Import der Anwendungsdaten für den angemeldeten Datenbankbenutzer

Sie können die benutzerspezifischen Anwendungsdaten importieren.

IMPORT USER
DATA INSTREAM 'mona_pages.data'

Die Anwendungsdaten (DATA) werden im Format PAGES (Vorschlagswert) importiert.

IMPORT USER
DATA INSTREAM 'mona_records.data' RECORDS

Die Anwendungsdaten (DATA) werden im Format RECORDS importiert.

Da im Falle der Verwendung von PAGES ein datenbankeigenes Format (auf Basis einer Seite) verwendet wird und keine Log-Einträge geschrieben werden, ist dieser Import schneller als ein Import über das Loader-eigene Format RECORDS. Allerdings sind die im Format PAGES importierten Tabellen so lange schreibgeschützt, bis Sie eine Datensicherung durchgeführt haben.

Siehe auch:

Loader, Strukturlink PAGES, RECORDS

Import des Datenbankkatalogs und der Anwendungsdaten für den angemeldeten Datenbankbenutzer

Sie können die Daten importieren, die benutzerspezifisch exportiert wurden

IMPORT USER
CATALOG INSTREAM 'mona_ddl.catalog'
DATA INSTREAM 'mona_pages.data'

Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie stets zuerst das Syntaxelement zum Import des Datenbankkatalogs und dann das Syntaxelement zum Import der Anwendungsdaten an.

Tabellen vom Import ausschließen

Durch die Angabe eines Datenstroms nach dem Schlüsselwort CONFIGURATION können die Anwendungsdaten ausgewählter Tabellen, die in diesem Datenstrom angegeben sind, vom Import ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.

Testen Sie das Loader-Verhalten für verschiedene Tabellen. Durch den Ausschluss von Tabellen dürfen keine Abhängigkeiten verletzt werden, wie das z.B. bei Ausschluss der Tabelle CITY oder HOTEL der Fall wäre.

Die Tabelle EMPLOYEE soll vom Import ausgeschlossen werden. Legen Sie die Datei employee.configuration mit folgendem Inhalt an:

HOTEL,EMPLOYEE

Geben Sie folgendes Import-Kommando im Loader-Sitzungsmodus an. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst das Syntaxelement an, das die Tabellen vom Import ausschließt.

IMPORT USER
CONFIGURATION INSTREAM 'employee.configuration'
CATALOG INSTREAM 'mona_ddl.catalog'
DATA INSTREAM 'mona_pages.data'

Die Datenbankkatalogeinträge aller Tabellen werden unabhängig von den in hotel_table.configuration gemachten Einschränkungen immer importiert.

Zusätzliche Protokollfunktionalität

Durch die Angabe eines Datenstroms nach dem Schlüsselwort PACKAGE werden die Kommando-Einträge in der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den angegebenen Datenstrom exportiert. Damit haben Sie eine weitere Möglichkeit der Protokollierung. Geben Sie das PACKAGE-Syntaxelement stets als letztes Syntaxelement an.

IMPORT USER
CATALOG INSTREAM 'mona_ddl.catalog'
 PACKAGE OUTSTREAM 'mona_csv.package'

Siehe auch:

Loader, Strukturlink Zusätzliche Protokollfunktionalität (package_spec)

Vollständige Syntax des IMPORT USER-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

IMPORT USER
CONFIGURATION INSTREAM FILE 'employee.configuration' CSV ASCII
CATALOG INSTREAM FILE 'mona_ddl.catalog' DDL
DATA INSTREAM FILE 'mona_pages.data' PAGES
PACKAGE OUTSTREAM FILE 'mona_csv.package' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink IMPORT USER-Kommando.

Siehe auch:

Weitere Kommandos zum Importieren


IMPORT SCHEMA (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt IMPORT SCHEMA

Mit dem IMPORT SCHEMA-Kommando können Sie die Daten, die zur Anwendung des angegebenen Schemas gehören, importieren.

Voraussetzungen

Sie benötigen die Beispiel-Datenbank TESTDB. Legen Sie den Datenbankbenutzer MONA an, falls dieser noch nicht vorhanden ist. Legen Sie als Benutzer MONA das Schema HOTEL an, falls dieses noch nicht vorhanden ist.

Sie haben die erforderlichen Daten mit dem EXPORT SCHEMA-Kommando exportiert.

Das IMPORT SCHEMA-Kommando kann nur vom Eigentümer des Schemas ausgeführt werden. Starten Sie daher den Loader als Datenbankadministrator MONA und melden Sie sich an die Datenbank TESTDB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli – d testdb –u mona,red –s hotel

Beispiele

In die Datenbank TESTDB sollen die Daten des Schemas HOTEL importiert werden.

Durch die Angaben nach dem Schlüsselwort CATALOG und/oder DATA können Sie steuern, ob Sie den Datenbankkatalog und/oder die Daten, die zur Anwendung gehören, importieren wollen.

Wenn Sie Tabellen importieren, legt der Loader auch alle für die Tabelle definierten Objekte und Verknüpfungen (Views, Fremdschlüsselbeziehungen zu anderen Tabellen...) an. Gegebenenfalls meldet der Loader, wenn die dafür erforderlichen Objekte nicht vorhanden sind und daher der Import nicht ausgeführt werden kann. Typische Fehlermeldungen sind z.B. die Fehlermeldungen Strukturlink -25451 und Strukturlink -25392. Wenn solche Fehler auftreten, wird der Import an dieser Stelle abgebrochen.

Import des Datenbankkatalogs eines Schemas

Sie können die Datenbankkataloginformationen importieren, die zur Anwendung des Schemas gehören.

IMPORT SCHEMA hotel
CATALOG INSTREAM 'hotel_ddl.catalog'

Der Datenbankkatalog (CATALOG) wird im Format DDL (Vorschlagswert) importiert.

Siehe auch:

Loader, Strukturlink Datenstrom

Import der Anwendungsdaten eines Schemas

Sie können die Anwendungsdaten des Schemas importieren.

IMPORT SCHEMA hotel
DATA INSTREAM 'hotel_pages.data'

Die Anwendungsdaten (DATA) werden im Format PAGES (Vorschlagswert) importiert.

IMPORT SCHEMA hotel
DATA INSTREAM 'hotel_records.data' RECORDS

Die Anwendungsdaten (DATA) werden im Format RECORDS importiert.

Da im Falle der Verwendung von PAGES ein datenbankeigenes Format (auf Basis einer Seite) verwendet wird und keine Log-Einträge geschrieben werden, ist dieser Import schneller als ein Import über das Loader-eigene Format RECORDS. Allerdings sind die im Format PAGES importierten Tabellen so lange schreibgeschützt, bis Sie eine Datensicherung durchgeführt haben.

Siehe auch:

Loader, Strukturlink PAGES, RECORDS

Import des Datenbankkatalogs und der Anwendungsdaten eines Schemas

Sie können die Daten, die zur Anwendung eines Schemas gehören, importieren.

IMPORT SCHEMA hotel
CATALOG INSTREAM 'hotel_ddl.catalog'
DATA INSTREAM 'hotel_pages.data'

Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie stets zuerst das Syntaxelement zum Import des Datenbankkatalogs und dann das Syntaxelement zum Import der Anwendungsdaten an.

Tabellen vom Import ausschließen

Durch die Angabe eines Datenstroms nach dem Schlüsselwort CONFIGURATION können die Anwendungsdaten ausgewählter Tabellen, die in diesem Datenstrom angegeben sind, vom Import ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.

Testen Sie das Loader-Verhalten für verschiedene Tabellen. Durch den Ausschluss von Tabellen dürfen keine Abhängigkeiten verletzt werden, wie das z.B. bei Ausschluss der Tabelle CITY oder HOTEL der Fall wäre.

Die Tabelle EMPLOYEE soll vom Import ausgeschlossen werden. Legen Sie die Datei employee.configuration mit folgendem Inhalt an:

HOTEL,EMPLOYEE

Geben Sie folgendes Import-Kommando im Loader-Sitzungsmodus an. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst das Syntaxelement an, das die Tabellen vom Import ausschließt.

IMPORT SCHEMA hotel
CONFIGURATION INSTREAM'employee.configuration'
 CATALOG INSTREAM 'hotel_ddl.catalog'
DATA INSTREAM 'hotel_pages.data'

Die Datenbankkatalogeinträge aller Tabellen werden unabhängig von den in employee.configuration gemachten Einschränkungen immer importiert.

Zusätzliche Protokollfunktionalität

Durch die Angabe eines Datenstroms nach dem Schlüsselwort PACKAGE werden die Kommando-Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den angegebenen Datenstrom exportiert. Damit haben Sie eine weitere Möglichkeit der Protokollierung. Geben Sie das PACKAGE-Syntaxelement stets als letztes Syntaxelement an.

IMPORT SCHEMA hotel
CATALOG INSTREAM 'hotel_ddl.catalog'
 PACKAGE OUTSTREAM 'hotel_csv.package'

Siehe auch:

Loader, Strukturlink Zusätzliche Protokollfunktionalität (package_spec)

Vollständige Syntax des IMPORT SCHEMA-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

IMPORT SCHEMA hotel
CONFIGURATION INSTREAM FILE 'employee.configuration' CSV ASCII
CATALOG INSTREAM FILE 'hotel_ddl.catalog' DDL
DATA INSTREAM FILE 'hotel_pages.data' PAGES
PACKAGE OUTSTREAM FILE 'hotel_csv.package' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink IMPORT SCHEMA-Kommando.

Siehe auch:

Weitere Kommandos zum Importieren


IMPORT TABLE (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt IMPORT TABLE

Mit dem IMPORT TABLE-Kommando können Sie die gesamten Daten einer Tabelle importieren.

Voraussetzungen

Sie benötigen die Demo-Datenbank TESTDB. Legen Sie den Datenbankbenutzer MONA an, falls dieser noch nicht vorhanden ist. Legen Sie als Benutzer MONA das Schema HOTEL an, falls dieses noch nicht vorhanden ist.

Sie haben die erforderlichen Daten mit dem EXPORT TABLE-Kommando exportiert.

Eine Auswahl bestimmter Spaltenwerte ist mit dem IMPORT TABLE-Kommando nicht möglich, sondern nur mit dem IMPORT COLUMNS-Kommando.

Die Kommandos IMPORT TABLE ... PAGE und IMPORT TABLE ... PAGES WITH ... können nur vom Eigentümer der Tabelle ausgeführt werden. In allen anderen Fällen müssen Sie die Zugriffsberechtigung für die Tabelle haben, in die die Daten importiert werden sollen.

Starten Sie den Loader als Datenbankadministrator MONA und melden Sie sich an die Datenbank TESTDB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d testdb –u mona,red –s hotel

Beispiele

In die Datenbank TESTDB sollen die Daten der gewünschten Tabelle importiert werden.

Durch die Angaben nach dem Schlüsselwort CATALOG und/oder DATA können Sie steuern, ob Sie den Datenbankkatalog und/oder die Anwendungsdaten importieren wollen.

Wenn Sie Tabellen importieren, legt der Loader auch alle für die Tabelle definierten Objekte und Verknüpfungen (Views, Fremdschlüsselbeziehungen zu anderen Tabellen...) an. Gegebenenfalls meldet der Loader, wenn die dafür erforderlichen Objekte nicht vorhanden sind und daher der Import nicht ausgeführt werden kann. Typische Fehlermeldungen sind z.B. die Fehlermeldungen Strukturlink -25451 und Strukturlink -25392. Wenn solche Fehler auftreten, wird der Import an dieser Stelle abgebrochen.

Testen Sie das Loader-Verhalten für verschiedene Tabellen. Legen Sie gegebenenfalls die erforderlichen abhängigen Objekte in der Datenbank TESTDB an. Für die Tabelle ROOM z.B. bestehen Abhängigkeiten zu den Tabellen CITY und HOTEL.

Import des Datenbankkatalogs einer Tabelle

Sie können alle Datenbankkataloginformationen einer Tabelle importieren.

IMPORT TABLE hotel.room
CATALOG INSTREAM 'room_ddl.catalog'

Der Datenbankkatalog (CATALOG) wird im Format DDL importiert.

Siehe auch:

Loader, Strukturlink Datenstrom

Import der Anwendungsdaten einer Tabelle

Sie können alle Anwendungsdaten einer Tabelle importieren.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data'

Die Anwendungsdaten (DATA) werden im Format CSV (Vorschlagswert) importiert.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_fwv.data' FWV
 hno 1-5
type 6-11
free 12-31
price 32-51

Die Anwendungsdaten (DATA) werden im Format FWV importiert.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_fwvbinary.data' FWV BINARY
 hno 1-5
type 06-11
free 12-31
price 32-51

Die Anwendungsdaten (DATA) werden im Format FWV BINARY importiert.

Siehe auch:

Loader, Strukturlink CSV, FWV, FWV BINARY

IMPORT TABLE hotel.room
DATA INSTREAM 'room_pages.data' PAGES

Die Anwendungsdaten (DATA) werden im Format PAGES importiert.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_records.data' RECORDS

Die Anwendungsdaten (DATA) werden im Format RECORDS importiert.

Da im Falle der Verwendung von PAGES ein datenbankeigenes Format (auf Basis einer Seite) verwendet wird und keine Log-Einträge geschrieben werden, ist dieser Import schneller als ein Import über eines der anderen Formate. Allerdings sind die im Format PAGES importierten Tabellen so lange schreibgeschützt, bis Sie eine Datensicherung durchgeführt haben.

Siehe auch:

Loader, Strukturlink PAGES, RECORDS

Performance-Steigerung

Durch das seitenweise Importieren von Anwendungsdaten können Sie einen IMPORT TABLE-Vorgang auch im Falle der Verwendung eines der Formate CSV, FWV [BINARY] wesentlich beschleunigen. Verwenden Sie in diesem Fall für den Datenstrom DATA INSTREAM die Möglichkeit PAGE WITH ... der Syntaxregel usage_spec, um einen seitenweisen Import der Daten in die Tabelle festzulegen.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data'
PAGE WITH 80 % USAGE

Die Anwendungsdaten werden in die leere Tabelle ROOM importiert. Die Anwendungsdaten werden als Datensätze im Datenformat CSV aus dem Datenstrom gelesen und seitenweise mit dem Füllgrad 80 % in die Tabelle ROOM importiert.

Siehe auch:

Loader, Strukturlink Performance-Steigerung beim IMPORT TABLE

Import des Datenbankkatalogs und der Anwendungsdaten einer Tabelle

Sie können die gesamten Daten der angegebenen Tabelle importieren.

IMPORT TABLE hotel.room
CATALOG INSTREAM 'room_ddl.catalog'
DATA INSTREAM 'room_csv.data'

Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie stets zuerst das Syntaxelement zum Import des Datenbankkatalogs und dann das Syntaxelement zum Import der Anwendungsdaten an.

if_condition

Sie können einzelne Datensätze aus einem DATA-Datenstrom des Formats CSV, FWV oder RECORDS selektieren und nur diese in die angegebene Tabelle importieren. Im Falle eines Datenstroms im Format PAGES wird die IF-Bedingung ignoriert, da immer die gesamte Seite importiert wird. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst die IF-Bedingung an.

IMPORT TABLE hotel.room
IF POS 4 < '200'
CATALOG INSTREAM 'room_ddl.catalog'
DATA INSTREAM 'room_csv.data'

In die Tabelle ROOM werden die Zeilen importiert, die in der Spalte PRICE einen Wert unter 200 haben.

Siehe auch:

Loader, Strukturlink Selektieren von Datensätzen

DUPLICATES-Klausel

Für die Steuerung des Verhaltens bei Auftreten von gleichen Tabellenzeilen verwenden Sie die DUPLICATES-Klausel. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie die DUPLICATES-Klausel gegebenenfalls nach der IF-Bedingung an.

IMPORT TABLE hotel.room
UPDATE DUPLICATES
CATALOG INSTREAM 'room_ddl.catalog'
DATA INSTREAM 'room_csv.data'

Die Anwendungsdaten der Tabelle ROOM werden importiert und eine existierende Zeile mit dem importierten Datensatz überschrieben.

Siehe auch:

Loader, Duplicates-Klausel ( Strukturlink IMPORT TABLE-Kommando)

Zusätzliche Protokollfunktionalität

Durch die Angabe eines Datenstroms nach dem Schlüsselwort PACKAGE werden die Kommando-Einträge in der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den angegebenen Datenstrom exportiert. Damit haben Sie eine weitere Möglichkeit der Protokollierung. Geben Sie das PACKAGE-Syntaxelement stets als letztes Syntaxelement an.

IMPORT TABLE hotel.room
CATALOG INSTREAM 'room_ddl.catalog'
PACKAGE OUTSTREAM 'room_csv.package'

Loader, Strukturlink Zusätzliche Protokollfunktionalität (package_spec)

Behandlung von LONG-Werten

Wenn Sie die Formate CSV und FWV [BINARY] verwenden, werden für die LONG-Daten beim Export extra Datenströme angelegt.

Die Daten der Tabelle HOTEL des Schemas HOTEL sollen importiert werden. Die Tabelle HOTEL besitzt die LONG-Spalte INFO, deren Inhalt in einen eigenen Datenstrom exportiert wurde. Geben Sie das LOB-Syntaxelement nach dem DATA-Syntaxelement an.

IMPORT TABLE hotel.hotel
DATA INSTREAM 'hotel_csv.data'
LOB INSTREAM INFO 'hotel_info_csv.long'

Alle Spalten der Tabelle HOTEL werden importiert. Die LONG-Werte befinden sich im Datenstrom hotel_info_csv.long.

Wenn Sie die Formate PAGES und RECORDS verwenden, werden sämtliche Tabellendaten beim Export in einen Datenstrom exportiert, also auch die LONG-Daten. Ein LOB-Syntaxelement ist daher beim Import nicht erforderlich.

IMPORT TABLE hotel.hotel.
  DATA INSTREAM 'hotel_records.data' RECORDS

Alle Spalten der Tabelle HOTEL einschließlich der LONG-Spalte INFO werden vom Datenstrom hotel_records.data importiert.

Siehe auch:

Loader, Strukturlink Exportieren und Importieren von LONG-Werten

Vollständige Syntax des IMPORT TABLE-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

IMPORT TABLE hotel.room
IF POS 4 < '200'
UPDATE DUPLICATES
CATALOG INSTREAM FILE 'room_ddl.catalog' DDL
DATA INSTREAM FILE 'room_csv.data' CSV
PAGE WITH 80 % USAGE
PACKAGE OUTSTREAM FILE 'room_csv.package' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink IMPORT TABLE-Kommando.

Wenn Sie nicht die gesamten Daten einer Tabelle, sondern nur ausgewählte Spaltenwerte importieren wollen, wählen Sie das Strukturlink IMPORT COLUMNS-Kommando.

Siehe auch:

Weitere Kommandos zum Importieren


IMPORT COLUMNS (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt IMPORT COLUMNS

Mit dem IMPORT COLUMNS-Kommando können Sie einzelne Spaltenwerte einer Tabelle importieren.

Voraussetzungen

Sie benötigen die Demo-Datenbank TESTDB. Legen Sie den Datenbankbenutzer MONA an, falls dieser noch nicht vorhanden ist. Legen Sie als Datenbankbenutzer MONA das Schema HOTEL an, falls dieses noch nicht vorhanden ist. Legen Sie im Schema HOTEL die gewünschte Tabelle an, falls diese noch nicht vorhanden ist.

Sie haben die erforderlichen Daten mit dem EXPORT COLUMNS-Kommando exportiert.

Starten Sie den Loader als Datenbankbenutzer MONA und melden Sie sich an die Datenbank TESTDB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d testdb –u mona,red –s hotel

Beispiele

Die Daten sollen in die Tabelle CUSTOMER des Schemas HOTEL importiert werden.

Durch die Angaben nach dem Schlüsselwort DATA können Sie steuern, welche Anwendungsdaten Sie importiert wollen.

Wenn Sie Tabellen importieren, legt der Loader auch alle für die Tabelle definierten Objekte und Verknüpfungen (Views, Fremdschlüsselbeziehungen zu anderen Tabellen...) an. Gegebenenfalls meldet der Loader, wenn die dafür erforderlichen Objekte nicht vorhanden sind und daher der Import nicht ausgeführt werden kann. Typische Fehlermeldungen sind z.B. die Fehlermeldungen Strukturlink -25451 und Strukturlink -25392. Wenn solche Fehler auftreten, wird der Import an dieser Stelle abgebrochen.

Testen Sie das Loader-Verhalten für verschiedene Tabellen. Legen Sie gegebenenfalls die erforderlichen abhängigen Objekte in der Datenbank TESTDB an. Für die Tabelle CUSTOMER z.B. besteht die Abhängigkeit zur Tabelle CITY.

Import aller Anwendungsdaten einer Tabelle

Sie können alle Anwendungsdaten einer Tabelle importieren.

IMPORT COLUMNS TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'

Die Anwendungsdaten (DATA) werden im Format CSV (Vorschlagswert) importiert.

IMPORT COLUMNS TABLE hotel.customer
cno 1-5
title 6-25
firstname 26-45
name 46-85
zip 86-105
address 106-145
DATA INSTREAM 'customer_fwv.data' FWV

Die Anwendungsdaten (DATA) werden im Format FWV importiert.

IMPORT COLUMNS TABLE hotel.customer
cno 1-5
title 6-25
firstname 26-45
name 46-85
zip 86-105
address 106-145
DATA INSTREAM 'customer_fwvbinary.data' FWV BINARY

Alle (TABLE) Anwendungsdaten (DATA) werden im Format FWV BINARY importiert.

Zu allen Spalten der Tabelle müssen Daten in dem entsprechenden Datenstrom vorhanden sein. Andernfalls meldet der Loader einen Fehler.

Siehe auch:

Loader, Strukturlink Datenstrom, Strukturlink CSV, FWV, FWV BINARY

Ein Import aller Spaltenwerte einer Tabelle ist auch mit dem Kommando IMPORT TABLE ... DATA ... möglich.

if_condition

Sie können einzelne Datensätze aus dem DATA-Datenstrom selektieren und nur diese in die angegebene Tabelle importieren. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst die IF-Bedingung an.

IMPORT COLUMNS TABLE hotel.customer
IF POS 1 > '4000'
 DATA INSTREAM 'hotel_csv.data'

In die Tabelle CUSTOMER werden die Zeilen importiert, die in der Spalte CNO einen Wert über 4000 haben.

Siehe auch:

Loader, Strukturlink Selektieren von Datensätzen

DUPLICATES-Klausel

Für die Steuerung des Verhaltens bei Auftreten von gleichen Tabellenzeilen verwenden Sie die DUPLICATES-Klausel. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie die DUPLICATES-Klausel gegebenenfalls nach der IF-Bedingung an.

IMPORT COLUMNS TABLE hotel.customer
 UPDATE DUPLICATES
 DATA INSTREAM 'customer_csv.data'

Die Anwendungsdaten der Tabelle CUSTOMER werden importiert und eine existierende Zeile mit dem importierten Datensatz überschrieben.

Siehe auch:

Loader, Duplicates-Klausel ( Strukturlink IMPORT COLUMNS-Kommando)

Import der Anwendungsdaten bestimmter Spalten einer Tabelle

Sie können einzelne Spaltenwerte einer Tabelle importieren.

IMPORT COLUMNS TABLE hotel.customer
cno 1
title 2
name 3
zip 4
address 5
 DATA INSTREAM 'customer_csv.data'

Die Spalten der Tabelle CUSTOMER werden in der angegebenen Reihenfolge importiert.

Der Loader erwartet nur für die angegebenen Spalten Daten im Datenstrom, die in der beim Import gewünschten Reihenfolge vorliegen müssen. Die anderen Spalten werden mit ihrem DEFAULT-Wert oder dem NULL-Wert importiert, je nachdem, wie die Spalten definiert wurden.

Sie müssen in all diejenigen Spalten Daten importieren, für die kein DEFAULT- oder NULL-Wert bei der Definition der Tabelle definiert wurde und für die die Eingabe von bestimmten Werten durch eine Integritätsbedingung erforderlich ist. Wird eine der notwendigen Spalten nicht angegeben, bricht der Loader die Verarbeitung mit einem Fehler ab.

Behandlung von LONG-Werten

Wenn Sie die Formate CSV und FWV [BINARY] verwenden, werden für die LONG-Daten beim Export extra Datenströme angelegt.

Die Daten der Tabelle HOTEL des Schemas HOTEL sollen importiert werden. Die Tabelle HOTEL besitzt die LONG-Spalte INFO, deren Inhalt in einen eigenen Datenstrom exportiert wurde. Geben Sie das LOB-Syntaxelement nach dem DATA-Syntaxelement an.

IMPORT COLUMNS TABLE hotel.hotel
DATA INSTREAM 'hotel_csv.data'
 LOB INSTREAM INFO 'hotel_info_csv.long'

Alle Spalten der Tabelle HOTEL werden importiert. Die LONG-Werte befinden sich im Datenstrom hotel_info_csv.long.

Siehe auch:

Loader, Strukturlink Exportieren und Importieren von LONG-Werten

Vollständige Syntax des IMPORT COLUMNS-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen. Beachten Sie die Reihenfolge der Syntaxelemente.

IMPORT COLUMNS TABLE hotel.customer
IF POS 1 >= '4000'
UPDATE DUPLICATES
cno 1
title 2
name 3
zip 4
address 5
DATA INSTREAM FILE 'customer_csv.data' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink IMPORT COLUMNS-Kommando.

Siehe auch:

Weitere Kommandos zum Importieren


UPDATE COLUMNS (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt UPDATE COLUMNS

Mit dem UPDATE COLUMNS-Kommando können Sie einzelne Spaltenwerte einer Tabelle ändern.

Voraussetzungen

Sie benötigen die Beispiel-Datenbank DEMODB.

Die gewünschte Tabelle muss in der Datenbank vorhanden sein. Starten Sie den Loader als Datenbankadministrator MONA und melden Sie sich an die Datenbank DEMODB an. Verwenden Sie den Strukturlink Sitzungsmodus.

loadercli –d demodb –u mona,red

Beispiele

Die Daten der Tabelle CUSTOMER des Schemas HOTEL sollen geändert werden.

Nach dem Schlüsselwort TABLE können Sie die gewünschte Tabellen- und Spaltenbeschreibung angeben. Die Spaltendefinition der Zielspalten erfolgt nach dem Schlüsselwort SET.

Durch die Angaben nach dem Schlüsselwort DATA können Sie steuern, welche neuen Spaltenwerte gesetzt werden sollen.

Aktualisieren von Werten einer Spalte einer Tabelle

Sie können Werte einer Spalte einer Tabelle aktualisieren.

UPDATE COLUMNS TABLE hotel.customer
cno 1
SET address 5
DATA INSTREAM 'customer_csv.data'

Die Anwendungsdaten (DATA) werden im Format CSV (Vorschlagswert) geändert.

Qualifikationsspalte ist die Spalte CNO. In der Tabelle CUSTOMER werden die Zeilen zur Aktualisierung eines Spaltenwertes ausgewählt, die durch die in customer_csv.dataangegebenen CNO-Werte qualifiziert sind. Die ADDRESS-Werte jeder dieser Zeilen werden durch die in customer_csv.datavorgegebenen Werte für ADDRESS ersetzt.

UPDATE COLUMNS TABLE hotel.customer
 cno 1-5
 SET address 76-116
DATA INSTREAM 'customer_fwv.data' FWV

Die Anwendungsdaten (DATA) werden im Format FWV geändert.

UPDATE COLUMNS TABLE hotel.customer
 cno 1-5
SET address 76-116
 DATA INSTREAM 'customer_fwvbinary.data' FWV BIMARY

Die Anwendungsdaten (DATA) werden im Format FWV BINARY geändert.

Siehe auch:

Loader, Strukturlink Datenstrom, Strukturlink CSV, FWV, FWV BINARY

Aktualisieren von Werten mehrerer Spalten einer Tabelle

Sie können mehrere Spaltenwerte einer Tabelle aktualisieren.

UPDATE COLUMNS TABLE hotel.customer
 cno 1
SET firstname 'Secret'
 SET address 5
DATA INSTREAM 'customer_csv.data'

Qualifikationsspalte ist die Spalte CNO. In der Tabelle CUSTOMER werden die Zeilen zur Aktualisierung von Spaltenwerten ausgewählt, die durch die in customer_csv.dataangegebenen CNO-Werte qualifiziert sind. Die FIRSTNAME-Werte jeder dieser Zeilen werden durch den Wert Secret ersetzt. Die ADDRESS-Werte jeder dieser Zeilen werden durch die in customer_csv.datavorgegebenen Werte für ADDRESS ersetzt.

if_condition

Sie können einzelne Datensätze aus dem DATA-Datenstrom selektieren und nur diese in der angegebenen Tabelle aktualisieren. Beachten Sie die Reihenfolge der Syntaxelemente. Geben Sie zuerst die IF-Bedingung an.

UPDATE COLUMNS TABLE hotel.customer
IF POS 1 > '4000'
 cno 1
SET address 5
 DATA INSTREAM 'customer_csv.data'

In die Tabelle CUSTOMER werden die Zeilen aktualisiert, die in der Spalte CNO einen Wert über 4000 haben.

Behandlung von LONG-Werten

Die Daten der Tabelle HOTEL des Schemas HOTEL sollen aktualisiert werden. Die Tabelle HOTEL besitzt die LONG-Spalte INFO. Geben Sie das LOB-Syntaxelement nach dem DATA-Syntaxelement an.

UPDATE COLUMNS TABLE hotel.hotel
hno 1
SET name 2
SET info 5
DATA INSTREAM 'hotel_csv.data'
LOB INSTREAM INFO 'hotel_info_csv.long'

Die Spalten NAME und INFO der Tabelle HOTEL werden aktualisiert. Die LONG-Werte befinden sich im Datenstrom hotel_info_csv.long.

Siehe auch:

Loader, Strukturlink Exportieren und Importieren von LONG-Werten

Vollständige Syntax des UPDATE COLUMNS-Kommandos

Die Kombination der Syntaxmöglichkeiten kann zu entsprechend komplexen Kommandos führen.

UPDATE COLUMNS TABLE hotel.customer
IF POS 1 > '4000'
cno 1
SET firstname 'Secret'
SET address 5
DATA INSTREAM FILE 'customer_csv.data' CSV

Eine vollständige Syntaxbeschreibung finden Sie in der Dokumentation Loader, Strukturlink UPDATE COLUMNS-Kommandos.

Siehe auch:

Kommandos zum Exportieren

Kommandos zum Importieren


Transportmodus (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Transportmodus

Im Transportmodus werden vom Benutzer interaktiv Eingaben abgefragt, um Anwendungsdaten aus einer Datenbank zu exportieren und gegebenenfalls in eine andere Datenbank zu importieren. Anhand der Eingabeparameter und der Loader-Konfigurationsdatei kann die Syntax der Loader-Kommandos generiert und die gewünschte Transformation (Transport, Export, Import) ausgeführt werden.

Voraussetzungen

Sie benötigen die Demo-Datenbanken DEMODB und TESTDB.

Starten Sie den Loader im Transportmodus: loadercli -p

Im Transportmodus selbst ist kein Wissen über die Loader-Syntax erforderlich. Die generierten Loader-Kommandos werden jedoch an der Konsole und in Dateien des Loader ausgegeben und können somit dem Benutzer als Vorlage für selbst verfasste Loader-Kommandos dienen.

Siehe auch:

Loader, Strukturlink Transportmodus, Strukturlink Transformation

Beispiele

Im Folgenden sollen einige Varianten der Nutzung des Loader CLI im Transportmodus anhand von Beispielen vorgestellt werden.

● Beispiele für den Transport

● Beispiele für den Export

● Beispiele für den Import

Siehe auch:

Kommandodateimodus

Sitzungsmodus


Transport (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Transport

Im Folgenden sollen einige Beispiele des Transports von Daten (Export mit anschließendem Import) mit dem Loader CLI im Transportmodus vorgestellt werden.

Voraussetzungen

Eine Beschreibung der Voraussetzungen finden Sie im Abschnitt Transportmodus.

Transport ausführen

Sie wollen den Datenbankkatalog und die Anwendungsdaten des Schemas HOTEL des Benutzers MONA zwischen den Datenbanken DEMODB und TESTDB transportieren.

loadercli -p

Package history: C:\Documents and Settings\anna\Application Data\sdb\loader\log\transport.log
Package path: c:\transport
Package name: 20060302090909

Step 1: Enter a package path
Package path: c:\transport

Step 2: Enter a package comment
Package comment: transport

Step 3: What do you want to do
[1] Transport from a source database into a target database
[2] Export from a source database
[3] Import into a target database

Step 3: 1

Step 4: What do you want to do
[1] Choose a transport package
[2] Create a transport package

Step 4: 2

Step 5: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Step 6: Enter the target database connection
Database computer : genua
Database name : testdb
Database user : mona
Password : red

Step 7: Choose what you want include into the package

[1] Complete user
[2] Complete user, excluding some tables
[3] Complete schema
[4] Complete schema, excluding some tables
[5] Schema tables

Step 7: 1

Step 8: Choose the transformation streams
[1] Catalog and data
[2] Catalog
[3] Data

Step 8: 1

Step 9: The package can be executed or generated now.
[1] Execute package to transport data now
[2] Generate package to execute it later

Step 9: 1
Transport package name : 20060302090909
Transport package comment : transport
Transport package creation : 20060302090909
Transport package execution : 20060302090909
Transport package path : c:\transport
Transport package status [-T]: EXECUTE
Transport direction [-t]: TRANSPORT
Transport package [-p]: USER
Transport part [-P]: USER
Transport streams [-s]: CATALOG,DATA,PACKAGE
Transport format [-f]: RECORDS
Transport format [-F]: ROW
Transport encoding [-c]:
Transport lobcolumn [-l]: TABLE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Target database computer [-nTRC]: GENUA
Target database name [-dTRC]: TESTDB
Target database user [-uTRC]: MONA

Step 10: Continue
[1] OK
[2] CANCEL

Step 10: 1

EXPORT USER
CATALOG OUTSTREAM PIPE 'MONA.CATALOG' DDL
DATA OUTSTREAM PIPE 'MONA.DATA' RECORDS
;

IMPORT USER UPDATE DUPLICATES
CATALOG INSTREAM PIPE 'MONA.CATALOG' DDL
DATA INSTREAM PIPE 'MONA.DATA' RECORDS
;

Package execution time: 11.625s
Package execution log : loader_20060302090909
Package name : 20060302090909

Die Loader-Kommandos, die während der Ausführung des Transportpakets 20060302090909 abgearbeitet werden, können Sie in der Protokolldatei loader_20060302090909.log einsehen.

Transport erneut ausführen

Wenn Sie den soeben ausgeführten Transport im Transportmodus erneut ausführen möchten, geben Sie beim Aufruf des Loader CLI den Namen des Transportpakets an:

loadercli –p 20060302090909

Step 1: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Step 2: Enter the target database connection
Database computer : genua
Database name : testdb
Database user : mona
Password : red

Transport package name : 20060302090909
Transport package comment : transport
Transport package creation : 20060302090909
Transport package execution : 20060302101010
Transport package path : c:\transport
Transport package status [-T]: EXECUTE
Transport direction [-t]: TRANSPORT
Transport package [-p]: USER
Transport part [-P]: USER
Transport streams [-s]: CATALOG,DATA,PACKAGE
Transport format [-f]: RECORDS
Transport format [-F]: ROW
Transport encoding [-c]:
Transport lobcolumn [-l]: TABLE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Target database computer [-nTRC]: GENUA
Target database name [-dTRC]: TESTDB
Target database user [-uTRC]: MONA

EXPORT USER
CATALOG OUTSTREAM PIPE 'MONA.CATALOG' DDL
DATA OUTSTREAM PIPE 'MONA.DATA' RECORDS
;

IMPORT USER UPDATE DUPLICATES
CATALOG INSTREAM PIPE 'MONA.CATALOG' DDL
DATA INSTREAM PIPE 'MONA.DATA' RECORDS
;

Package execution time: 6.953s
Package execution log : loader_20060302101010
Package name : 20060302090909

Die Loader-Kommandos, die während der Ausführung des Transportpakets 20060302090909abgearbeitet werden, können Sie in der aktuellen Protokolldatei loader_20060302101010.log einsehen.

Transportpaket generieren

Wenn Sie ein Transportpaket nur generieren, jedoch noch nicht ausführen wollen, verfahren Sie wie folgt:

loadercli -p

Package history: C:\Documents and Settings\anna\Application Data\sdb\loader\log\transport.log
Package path: c:\transport
Package name: 20060302141414

Step 1: Enter a package path
Package path: c:\transport

Step 2: Enter a package comment
Package comment: transport_generate

Step 3: What do you want to do
[1] Transport from a source database into a target database
[2] Export from a source database
[3] Import into a target database

Step 3: 1

Step 4: What do you want to do
[1] Choose a transport package
[2] Create a transport package

Step 4: 2

Step 5: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Step 6: Enter the target database connection
Database computer : genua
Database name : testdb
Database user : mona
Password : red

Step 7: Choose what you want include into the package

[1] Complete user
[2] Complete user, excluding some tables
[3] Complete schema
[4] Complete schema, excluding some tables
[5] Schema tables

Step 7: 1

Step 8: Choose the transformation streams
[1] Catalog and data
[2] Catalog
[3] Data

Step 8: 1

Step 9: The package can be generated or executed now.
[1] Execute package to transport data now
[2] Generate package to execute it later

Step 9: 2
Transport package name : 20060302141414
Transport package comment : transport_generate
Transport package creation : 20060302141414
Transport package execution : 20060302141414
Transport package path : c:\transport
Transport package status [-T]: GENERATE
Transport direction [-t]: TRANSPORT
Transport package [-p]: USER
Transport part [-P]: USER
Transport streams [-s]: CATALOG,DATA,PACKAGE
Transport format [-f]: RECORDS
Transport format [-F]: ROW
Transport encoding [-c]:
Transport lobcolumn [-l]: TABLE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Target database computer [-nTRC]: GENUA
Target database name [-dTRC]: TESTDB
Target database user [-uTRC]: MONA

Step 9: Continue
[1] OK
[2] CANCEL

Step 9: 1

EXPORT USER
CATALOG OUTSTREAM PIPE 'MONA.CATALOG' DDL
DATA OUTSTREAM PIPE 'MONA.DATA' RECORDS
;

IMPORT USER UPDATE DUPLICATES
CATALOG INSTREAM PIPE 'MONA.CATALOG' DDL
DATA INSTREAM PIPE 'MONA.DATA' RECORDS
;

Package execution time: 8.484s
Package name : 20060302141414

Generiertes Transportpaket ausführen

Wenn Sie die generierten Transportinformationen im Transportmodus ausführen möchten, geben Sie beim Aufruf des Loader CLI den Namen des Transportpakets an:

loadercli –p 20060302141414

Step 1: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Step 2: Enter the target database connection
Database computer : genua
Database name : testdb
Database user : mona
Password : red

Transport package name : 20060302141414
Transport package comment : transport_generate
Transport package creation : 20060302141414
Transport package execution : 20060302151515
Transport package path : c:\transport
Transport package status [-T]: EXECUTE
Transport direction [-t]: TRANSPORT
Transport package [-p]: USER
Transport part [-P]: USER
Transport streams [-s]: CATALOG,DATA,PACKAGE
Transport format [-f]: RECORDS
Transport format [-F]: ROW
Transport encoding [-c]:
Transport lobcolumn [-l]: TABLE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Target database computer [-nTRC]: GENUA
Target database name [-dTRC]: TESTDB
Target database user [-uTRC]: MONA

EXPORT USER
CATALOG OUTSTREAM PIPE 'MONA.CATALOG' DDL
DATA OUTSTREAM PIPE 'MONA.DATA' RECORDS
;

IMPORT USER UPDATE DUPLICATES
CATALOG INSTREAM PIPE 'MONA.CATALOG' DDL
DATA INSTREAM PIPE 'MONA.DATA' RECORDS
;

Package execution time: 6.781s
Package execution log : loader_20060302151515
Package name : 20060302141414

Die Loader-Kommandos, die während der Ausführung des Transportpakets 20060302141414abgearbeitet werden, können Sie in der aktuellen Protokolldatei loader_20060302151515.log einsehen.

Siehe auch:

Export

Import

Kommandodateimodus

Sitzungsmodus

Loader, Strukturlink Protokolldatei


Export (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Export

Im Folgenden sollen einige Beispiele des Exports von Daten mit dem Loader CLI im Transportmodus vorgestellt werden.

Voraussetzungen

Eine Beschreibung der Voraussetzungen finden Sie im Abschnitt Transportmodus.

Export ausführen

Sie wollen aus der Datenbank DEMODB die Tabelle HOTEL des Schemas HOTEL des Benutzers MONA exportieren. Die Anwendungsdaten sollen dabei als Dateien im CSV-Format exportiert werden. Die Werte der Spalte INFO vom Datentyp LONG der Tabelle HOTEL sollen pro Datensatz in eine separate Datei exportiert werden.

loadercli -p

Package history: C:\Documents and Settings\anna\Application Data\sdb\loader\log\transport.log
Package path: c:\transport
Package name: 20060312161616

Step 1: Enter a package path
Package path: c:\transport

Step 2: Enter a package comment
Package comment: export

Step 3: What do you want to do
[1] Transport from a source database into a target database
[2] Export from a source database
[3] Import into a target database

Step 3: 2

Step 4: What do you want to do
[1] Choose an export package
[2] Create an export package

Step 4: 2

Step 5: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Step 6: Choose what you want include into the package
[1] Complete user; one file per user
[2] Complete user; one file per user, excluding some tables
[3] Complete user; one file per table
[4] Complete user; one file per table, excluding some tables
[5] Complete schema; one file per schema
[6] Complete schema; one file per schema, excluding some tables
[7] Complete schema; one file per table
[8] Complete schema; one file per table, excluding some tables
[9] Schema tables ; one file per table

Step 6: 9

Step 7: Enter the source database connection
Database schema : hotel

Step 8: Enter the table names you want include into the package

[1] hotel

[2]

Step 9: Choose the transformation streams
[1] Catalog and data
[2] Catalog
[3] Data

Step 9: 1

Step 10: Do you want to specify the data streamformat
[1] Yes
[2] No

Step 10: 1

Step 11: How do you want to export the datastream
[1] Comma separated values; one file per lob column
[2] Comma separated values; one file per lob value
[3] Fixed width values; one file per lob column
[4] Fixed width values; one file per lob value
[5] Platform independent loader records format (with logging)
[6] Platform independent database page format(without logging, backup necessary)

Step 11: 2

Step 12: How do you want to import the data
[1] Row by row (with logging)
[2] Row by page (without logging, backup necessary)

Step 12: 1

Step 13: The package can be executed or generated now.
[1] Execute package to transport data now
[2] Generate package to transport data later

Step 13: 1

Export package name : 20060312161616
Export package comment : export
Export package creation : 20060312161616
Export package execution : 20060312161616
Export package path : c:\transport
Export package status [-T]: EXECUTE
Export direction [-t]: EXPORT
Export package [-p]: TABLE
Export part [-P]: TABLE
Export streams [-s]: CATALOG,DATA,PACKAGE
Export format [-f]: CSV
Export format [-F]: ROW
Export encoding [-c]:
Export lobcolumn [-l]: COLUMNVALUE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Source database table : "HOTEL"."HOTEL"

Step 14: Continue
[1] OK
[2] CANCEL

Step 14: 1

EXPORT TABLE "HOTEL"
CATALOG OUTSTREAM FILE 'HOTEL.CATALOG' DDL
  DATA    OUTSTREAM FILE 'HOTEL.DATA'    CSV
           Start 1 MAXROWS
  LOB OUTSTREAM FILE "INFO" 'HOTEL_INFO.DATA###'
  ;

Package execution time : 10.039s
Package execution log : loader_20060312161616.log
Package name : 20060312161616

Die Loader-Kommandos, die während der Ausführung des Exportpakets 20060312161616 abgearbeitet werden, können Sie in der Protokolldatei loader_20060312161616.logeinsehen.

Export erneut ausführen

Wenn Sie den soeben ausgeführten Export erneut ausführen möchten, geben Sie beim Aufruf des Loader CLI den Namen des Exportpakets an:

loadercli –p 20060312161616

Step 1: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Export package name : 20060312161616
Export package comment : export
Export package creation : 20060312161616
Export package execution : 20060312171717
Export package path : c:\transport
Export package status [-T]: EXECUTE
Export direction [-t]: EXPORT
Export package [-p]: 20060312161616
Export part [-P]: TABLE
Export streams [-s]: CATALOG,DATA,PACKAGE
Export format [-f]: CSV
Export format [-F]: ROW
Export encoding [-c]:
Export lobcolumn [-l]: COLUMNVALUE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Source database table : "HOTEL"."HOTEL"

EXPORT TABLE "HOTEL"
CATALOG OUTSTREAM FILE 'HOTEL.CATALOG' DDL
  DATA    OUTSTREAM FILE 'HOTEL.DATA'    CSV
           Start 1 MAXROWS
  LOB OUTSTREAM FILE "INFO" 'HOTEL_INFO.DATA###'
  ;

Package execution time : 2.152s
Package execution log : loader_20060312171717.log
Package name : 20060312161616

Die Loader-Kommandos, die während der Ausführung des Exportpakets 20060312161616 abgearbeitet werden, können Sie in der Protokolldatei loader_20060312171717.logeinsehen.

Exportpaket generieren

Wenn Sie ein Exportpaket nur generieren, jedoch noch nicht ausführen wollen, verfahren Sie wie folgt:

loadercli –p

Package history: C:\Documents and Settings\anna\Application Data\sdb\loader\log\transport.log
Package path: c:\transport
Package name: 20060322101010

Step 1: Enter a package path
Package path: c:\transport

Step 2: Enter a package comment
Package comment: export_generate

Step 3: What do you want to do
[1] Transport from a source database into a target database
[2] Export from a source database
[3] Import into a target database

Step 3: 2

Step 4: What do you want to do
[1] Choose an export package (updates data)
[2] Create an export package

Step 4: 2

Step 5: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Step 6: Choose what you want include into the package
[1] Complete user; one file per user
[2] Complete user; one file per user, excluding some tables
[3] Complete user; one file per table
[4] Complete user; one file per table, excluding some tables
[5] Complete schema; one file per schema
[6] Complete schema; one file per schema, excluding some tables
[7] Complete schema; one file per table
[8] Complete schema; one file per table, excluding some tables
[9] Schema tables ; one file per table

Step 6: 9

Step 7: Enter the source database connection
Database schema : hotel

Step 8: Enter the table names you want include into the package

[1] hotel

[2]

Step 9: Choose the transformation streams
[1] Catalog and data
[2] Catalog
[3] Data

Step 9: 1

Step 10: Do you want to specify the data streamformat
[1] Yes
[2] No

Step 10: 1

Step 11: How do you want to export the datastream
[1] Comma separated values; one file per lob column
[2] Comma separated values; one file per lob value
[3] Fixed width values; one file per lob column
[4] Fixed width values; one file per lob value
[5] Platform independent loader records format (with logging)
[6] Platform independent database page format(without logging, backup necessary)

Step 11: 2

Step 12: How do you want to import the data
[1] Row by row (with logging)
[2] Row by page (without logging, backup necessary)

Step 12: 1

Step 13: The package can be executed or generated now.
[1] Execute package to transport data now
[2] Generate package to transport data later

Step 13: 2

Export package name : 20060322101010
Export package comment : export_generate
Export package creation : 20060322101010
Export package execution : 20060322101010
Export package path : c:\transport
Export package status [-T]: EXECUTE
Export direction [-t]: GENERATE
Export package [-p]: TABLE
Export part [-P]: TABLE
Export streams [-s]: CATALOG,DATA,PACKAGE
Export format [-f]: CSV
Export format [-F]: ROW
Export encoding [-c]:
Export lobcolumn [-l]: COLUMNVALUE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Source database table : "HOTEL"."HOTEL"

Step 14: Continue
[1] OK
[2] CANCEL

Step 14: 1

EXPORT TABLE "HOTEL"
CATALOG OUTSTREAM FILE 'HOTEL.CATALOG' DDL
  DATA    OUTSTREAM FILE 'HOTEL.DATA'    CSV
           Start 1 MAXROWS
  LOB OUTSTREAM FILE "INFO" 'HOTEL_INFO.DATA###'
  ;

Package execution time : 11.195s
Package name : 20060322101010

Generiertes Exportpaket ausführen

Wenn Sie ein generiertes Exportpaket ausführen möchten, geben Sie beim Aufruf des Loader CLI den Namen des Exportpakets an:

loadercli –p 20060322101010

Step 1: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Export package name : 20060322101010
Export package comment : export_generate
Export package creation : 20060322101010
Export package execution : 20060322121212
Export package path : c:\transport
Export package status [-T]: EXECUTE
Export direction [-t]: EXPORT
Export package [-p]: 20060322101010
Export part [-P]: TABLE
Export streams [-s]: CATALOG,DATA,PACKAGE
Export format [-f]: CSV
Export format [-F]: ROW
Export encoding [-c]:
Export lobcolumn [-l]: COLUMNVALUE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Source database table : "HOTEL"."HOTEL"

EXPORT TABLE "HOTEL"
CATALOG OUTSTREAM FILE 'HOTEL.CATALOG' DDL
  DATA    OUTSTREAM FILE 'HOTEL.DATA'    CSV
           Start 1 MAXROWS
  LOB OUTSTREAM FILE "INFO" 'HOTEL_INFO.DATA###'
  ;

Package execution time : 2.058s
Package execution log : loader_20060322121212.log
Package name : 20060322101010

Die Loader-Kommandos, die während der Ausführung des Exportpakets 20060322101010 abgearbeitet werden, können Sie in der Protokolldatei loader_20060322121212.log einsehen.

Siehe auch:

Import

Transport

Kommandodateimodus

Sitzungsmodus

Loader, Strukturlink Protokolldatei


Import (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Import

Im Folgenden sollen einige Beispiele des Imports von Daten mit dem Loader CLI im Transportmodus vorgestellt werden.

Voraussetzungen

Eine Beschreibung der Voraussetzungen finden Sie im Abschnitt Transportmodus.

Import ausführen

Sie wollen in die Datenbank TESTDB die Tabelle HOTEL des Schemas HOTEL des Benutzers MONA importieren. Die Anwendungsdaten sollen dabei als Dateien im CSV-Format importiert werden. Die Werte der Spalte INFO vom Datentyp LONG der Tabelle HOTEL sollen pro Datensatz aus einer separaten Datei importiert werden.

loadercli -p

Package history: C:\Documents and Settings\anna\Application Data\sdb\loader\log\transport.log
Package path: c:\transport
Package name: 20060322131313

Step 1: Enter a package path
Package path: c:\transport

Step 2: Enter a package comment
Package comment: import

Step 3: What do you want to do
[1] Transport from a source database into a target database
[2] Export from a source database
[3] Import into a target database

Step 3: 3

Step 4: Enter the source database of the export package
Database computer : genua
Database name : demodb

Step 5: Choose an export package

Export package path : c:\transport
Source database computer [-nSRC]: genua
Source database name [-dSRC]: demodb

[1]:

Export package name : 20060322101010
Export package comment : export_generate

[2]:

Export package name : 20060312161616
Export package comment : export

Step 5: 2

Step 6: Enter the target database of the export package
Database computer : genua
Database name : testdb
Database user : mona
Password : red

Step 7: Enter the target database schema
Database schema: hotel

Import package name : 20060322131313
Import package comment : import
Import package creation : 20060322131313
Import package execution : 20060322131313
Import package path : c:\transport
Import package status [-T]: EXECUTE
Import direction [-t]: IMPORT
Import package [-p]: 20060312161616
Import part [-P]: TABLE
Import streams [-s]: CATALOG,DATA,PACKAGE
Import format [-f]: CSV
Import format [-F]: ROW
Import encoding [-c]:
Import lobcolumn [-l]: COLUMNVALUE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Target database computer [-nTRG]: GENUA
Target database name [-dTRG]: TESTDB
Target database user [-uTRG]: MONA
Source database table : "HOTEL"."HOTEL"

Step 10: Continue
[1] OK
[2] CANCEL

Step 10: 1

IMPORT TABLE "HOTEL" UPDATE DUPLICATES
CATALOG INSTREAM FILE 'HOTEL.CATALOG' DDL
DATA INSTREAM FILE 'HOTEL.DATA' CSV
Start 1 MAXROWS
"HNO" 1 CHAR
"NAME" 1 CHAR
"ZIP" 1 CHAR DEFAULT NULL
"ADDRESS" 1 CHAR
"INFO" 1 CHAR DEFAULT NULL
RECORDS USAGE
;

Package execution time : 25.817s
Package execution log : loader_20060322131313.log
Package name : 20060322131313

Die Loader-Kommandos, die während der Ausführung des Importpakets 20060322131313abgearbeitet werden, können Sie in der Protokolldatei loader_20060322131313.log einsehen.

Import erneut ausführen

Wenn Sie den soeben ausgeführten Import erneut ausführen möchten, geben Sie beim Aufruf des Loader CLI den Namen des Importpakets an:

loadercli –p 20060322131313

Step 1: Enter the source database connection
Database computer : genua
Database name : demodb
Database user : mona
Password : red

Import package name : 20060322131313
Import package comment : import
Import package creation : 20060322131313
Import package execution : 20060322151515
Import package path : c:\transport
Import package status [-T]: EXECUTE
Import direction [-t]: IMPORT
Import package [-p]: 20060312161616
Import part [-P]: TABLE
Import streams [-s]: CATALOG,DATA,PACKAGE
Import format [-f]: CSV
Import format [-F]: ROW
Import encoding [-c]:
Import lobcolumn [-l]: COLUMNVALUE
Source database computer [-nSRC]: GENUA
Source database name [-dSRC]: DEMODB
Source database user [-uSRC]: MONA
Target database computer [-nTRG]: GENUA
Target database name [-dTRG]: TESTDB
Target database user [-uTRG]: MONA
Source database table : "HOTEL"."HOTEL"

IMPORT TABLE "HOTEL" UPDATE DUPLICATES
CATALOG INSTREAM FILE 'HOTEL.CATALOG' DDL
DATA INSTREAM FILE 'HOTEL.DATA' CSV
Start 1 MAXROWS
"HNO" 1 CHAR
"NAME" 1 CHAR
"ZIP" 1 CHAR DEFAULT NULL
"ADDRESS" 1 CHAR
"INFO" 1 CHAR DEFAULT NULL
RECORDS USAGE
;

Package execution time : 8.025s
Package execution log : loader_20060322151515.log
Package name : 20060322131313

Die Loader-Kommandos, die während der Ausführung des Importpakets 20060322131313abgearbeitet werden, können Sie in der Protokolldatei loader_20060322151515.log einsehen.

Siehe auch:

Export

Transport

Kommandodateimodus

Sitzungsmodus

Loader, Strukturlink Protokolldatei


Kommandodateimodus (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Kommandodateimodus

Im Folgenden soll vorgestellt werden, wie Sie den Transport, Export oder Import von Daten mit dem Loader CLI im Kommandomodus durchführen können.

Voraussetzungen

Sie benötigen die Demo-Datenbanken DEMODB und TESTDB.

Starten Sie den Loader im Kommandodateimodus: loadercli –b <command.dat>

Die Kommandodatei command_file enthält die für die gewünschte Transformation erforderlichen Loader-Kommandos.

Eine Kommandodatei kann z.B. bei Durchführen einer Transformation mit dem Loader im Transportmodus erzeugt werden. Diese Datei können Sie dann Ihren Wünschen entsprechend modifizieren und im Kommandodateimodus des Loader zur Ausführung bringen.

Siehe auch:

Loader, Strukturlink Kommandodateimodus, Strukturlink Kommandodatei, Strukturlink Transportmodus, Strukturlink Transformation

Beispiele

Loader CLI-Aufruf im Kommandodateimodus

loadercli -b command.dat -d demodb -u mona,red –n genua –E 20

Der Loader stellt eine Verbindung zur Datenbankinstanz DEMODB auf dem Rechner GENUA für den Benutzer MONA her. Der Loader arbeitet die in der Kommandodatei command.dat enthaltenen Kommandos und SQL-Anweisungen ab. Wenn dabei Fehler (Returncode <> 0) auftreten, wird die Abarbeitung abgebrochen, sobald 20 Kommandos mit einem Fehler abgebrochen wurden.

Die Kommandodatei command.dat könnte folgenden Inhalt haben:

//IMPORT TABLE DATA
IMPORT TABLE hotel.customer
CATALOG INSTREAM 'customer_ddl.catalog'
DATA INSTREAM 'customer_csv.data'
PAGE WITH 25 ROWS USAGE
//CREATE INDEX
CREATE INDEX customer_index ON hotel.customer(name ASC,firstname ASC)
//
EXPORT COLUMNS cno, title, name, firstname
FROM hotel.customer WITH LOCK
DATA OUTSTREAM 'newcustomer_csv.data'

In dieser Kommandodatei finden Sie folgende Loader-Kommandos und SQL-Anweisungen: IMPORT TABLE, CREATE INDEX und EXPORT COLUMNS. Angaben zur Datenbanksitzung (Datenbankbenutzer, Name der Datenbankinstanz, Name des Datenbankrechners) müssen Sie über den Loader-Aufruf als Kommandozeilenoption übergeben.

Loader CLI-Aufruf im Kommandodateimodus mit explizit angegebenem Kommandotrenner

loadercli -b command.dat -d demodb -u mona,red –n genua –E 20 –cs ;

Der Loader stellt eine Verbindung zur Datenbankinstanz DEMODB auf dem Rechner GENUA für den Benutzer MONA her. Der Loader arbeitet die in der Kommandodatei command.dat enthaltenen Kommandos und SQL-Anweisungen ab. Wenn dabei Fehler (Returncode <> 0) auftreten, wird die Abarbeitung abgebrochen, sobald 20 Kommandos mit einem Fehler abgebrochen wurden.

Die Kommandodatei command.dat könnte folgenden Inhalt haben:

//IMPORT TABLE DATA
IMPORT TABLE hotel.customer
CATALOG INSTREAM 'customer_ddl.catalog'
DATA INSTREAM 'customer_csv.data'
PAGE WITH 25 ROWS USAGE;
//CREATE INDEX
CREATE INDEX customer_index ON hotel.customer(name ASC,firstname ASC);
EXPORT COLUMNS cno, title, name, firstname
FROM hotel.customer WITH LOCK
DATA OUTSTREAM 'newcustomer_csv.data';

In dieser Kommandodatei finden Sie folgende Loader-Kommandos und SQL-Anweisungen: IMPORT TABLE, CREATE INDEX und EXPORT COLUMNS, die jeweils mit einem Semikolon abgeschlossen werden. Angaben zur Datenbanksitzung (Datenbankbenutzer, Name der Datenbankinstanz, Name des Datenbankrechners) müssen Sie über den Loader-Aufruf als Kommandozeilenoption übergeben.

Kommandodatei im Transportmodus erzeugen und im Kommandodateimodus ausführen

Sie haben einen Export mit dem Loader im Transportmodus durchgeführt. Im Paketverzeichnis befindet sich die Kommandodatei 20060322101010.EXPORT.

Sie können die in der Kommandodatei enthaltenen Kommandos im Kommandodateimodus ausführen.

Verfahren Sie dazu wie folgt:

...

1. Wechseln Sie in das Paketverzeichnis:
<loader_user_data>\packages\export\GENUA\DEMODB\20060322101010

2. Starten Sie den Export:
loadercli –b 20060322101010.EXPORT –d demodb –u mona,red –s hotel –E 10

Siehe auch:

Transportmodus

Sitzungsmodus

Loader, Strukturlink Protokolldatei


Sitzungsmodus (SAP-Bibliothek - Tutorials)

Diese Grafik wird im zugehörigen Text erklärt Sitzungsmodus

Im Folgenden soll vorgestellt werden, wie Sie den Transport, Export oder Import von Daten mit dem Loader CLI im Sitzungsmodus durchführen können.

Voraussetzungen

Sie benötigen die Demo-Datenbanken DEMODB und TESTDB.

Starten Sie den Loader im Sitzungsmodus: loadercli [<options>]

Geben Sie die erforderlichen Loader-Kommandos und SQL-Anweisungen ein. Um den Sitzungsmodus zu beenden, geben Sie release oder exit ein.

Siehe auch:

Loader, Strukturlink Sitzungsmodus

Beispiele

Loader CLI-Aufruf im Sitzungsmodus

loadercli -d demodb -u mona,red -s hotel

Der Loader stellt eine Verbindung zur Datenbankinstanz DEMODB für den Benutzer MONA im Schema HOTEL her. Danach erwartet der Loader die Kommandos und SQL-Anweisungen auf der Kommandozeile und arbeitet diese ab.

loadercli -d demodb -u mona,red -cs ;

Der Loader stellt eine Verbindung zur Datenbankinstanz DEMODB für den Benutzer MONA her. Der Loader erwartet die Kommandos und SQL-Anweisungen auf der Kommandozeile. Diese müssen jeweils mit einem Semikolon abgeschlossen werden, damit der Loader sie verarbeitet.

Kommandos im Transportmodus erzeugen und im Sitzungsmodus ausführen

Sie haben einen Export mit dem Loader im Transportmodus durchgeführt. Im Paketverzeichnis <loader_user_data>\packages\export\GENUA\DEMODB\20060322101010 befindet sich die Kommandodatei 20060322101010.EXPORT.

Sie können die in der Kommandodatei enthaltenen Kommandos im Sitzungsmodus ausführen.

Verfahren Sie dazu wie folgt:

...

1. Starten Sie den Loader im Sitzungsmodus:
loadercli -d demodb –u mona,red –s hotel –E 10 –cs //

2. Kopieren die gewünschten Kommandos aus der Kommandodatei 20060322101010.EXPORT in die Konsoleneingabe, um den Export zu beschreiben. Beachten Sie, dass Sie gegebenenfalls Angaben zu den Benutzern streichen oder anpassen müssen. Jede Kommandozeile muss jeweils mit // abgeschlossen werden, damit der Loader sie verarbeitet.

3. Beenden Sie den Sitzungsmodus.

Siehe auch:

Transportmodus

Kommandodateimodus

Loader, Strukturlink Protokolldatei


Werkzeuge (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Werkzeuge

Titel der Dokumentation | Erläuterung
Database Manager · Database Manager GUI · Database Manager CLI | Anlegen und Verwalten von Datenbankinstanzen · grafische Benutzeroberfläche · Kommandozeilenwerkzeug
Database Analyzer | Analyse der Performance von Datenbankinstanzen
Loader | Exportieren und Importieren von Daten
Query Tools · SQL Studio · Web SQL Studio · SQLCLI | Datenanfrage und Datenbearbeitung mit SQL · grafische Benutzeroberfläche · web-basierte Benutzeroberfläche · Kommandozeilenwerkzeug
Synchronization Manager | Synchronisieren von Tabelleninhalten von zwei oder mehr Datenbankinstanzen
Utilities · Event-Dispatcher · XCONS · XUSER · X-Server |


Database Manager GUI (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Database Manager GUI

Einsatzmöglichkeiten

Das Datenbankwerkzeug Database Manager GUI dient dazu, Datenbankinstanzen zu verwalten. Sie können hiermit unter anderem Datenbankinstanzen anlegen, überwachen, sichern und wiederherstellen.

Der Database Manager GUI hat eine grafische Benutzeroberfläche und kann nur unter Microsoft Windows eingesetzt werden. Sie können mit dem Database Manager GUI aber auch Datenbankinstanzen verwalten, die auf einem entfernten Computer mit einem anderen Betriebssystem laufen.

Einführungshinweise

Der Database Manager GUI ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

Der Database Manager GUI bietet unter anderem die folgenden Funktionen und Anzeigemöglichkeiten:

· Aufrufen des Database Manager GUI

· Bildschirmbereiche des Database Manager GUI

· Anlegen einer Datenbankinstanz

· Initialisieren einer vorhandenen Datenbankinstanz

· Verwalten von Datenbankinstanzen

· Löschen einer Datenbankinstanz

· Verwalten des Datenbanksystemadministrators

· Verwalten der Database Manager-Benutzer

· Verwalten von Datenbankbenutzern

· Sichern

· Wiederherstellen

· Einfrieren des Datenbereichs (Snapshots)

· Anzeigen von Informationen

· Diagnosemöglichkeiten

· Update der Datenbanksoftware

· SQL Studio verwenden

· Database Manager CLI verwenden

Das Datenbankwerkzeug Database Manager CLI hat einen ähnlichen Funktionsumfang wie der Database Manager GUI, ist aber ein Kommandozeilenprogramm.


Aufrufen des Database Manager GUI (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Aufrufen des Database Manager GUI

Um das Programm Database Manager GUI aufzurufen, verwenden Sie das Startmenü von Microsoft Windows oder den entsprechenden Shortcut.

In Ausnahmefällen können Sie den Database Manager GUI auch von der Kommandozeile aus aufrufen. Wechseln Sie dazu in das Verzeichnis des Programms dbmgui<n>.exe (n ist ein Programmversionszähler) und geben Sie folgendes Kommando ein:

dbmgui<n> [<options>]

<option> | Beschreibung
-? | alle Kommandozeilen-Optionen anzeigen
-d <database_name> | Datenbankname
-e | verschlüsselte Verbindung verwenden (nur für SAP-Kunden)
-f <file_name> | Konfigurationsdatei öffnen
-n <database_computer> | Name des Datenbankrechners
-nologo | Database Manager GUI ohne Anzeige des Splash Screen starten
-prompt | Dialog zum Herstellen einer Verbindung zur Datenbankinstanz öffnen
-u <dbm_operator>,[<dbm_operator_password>] | Verbindung zur Datenbankinstanz herstellen (Angabe von Name und Kennwort des Database Manager-Benutzers)
-version | Version des Database Manager GUI anzeigen

Siehe auch:

Glossar, Strukturlink Variablen in der Dokumentation


Bildschirmbereiche des Database Manager GUI (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Bildschirmbereiche des Database Manager GUI

Der Bildschirm des Database Manager GUI gliedert sich in acht Bereiche. Sie können die Größe der einzelnen Bildschirmbereiche ändern.

Diese Grafik wird im zugehörigen Text erklärt

Inhalt der Bildschirmbereiche

Nr. | Name des Bereichs | Beschreibung
1 | Menüleiste | Auswahl der Funktionen und Anzeigen zur aktuellen Datenbankinstanz Die Menüleiste passt sich dynamisch an ausgewählte Funktionen an.
2 | Symbolleiste | Symbole, mit denen Sie Funktionen der Menüleiste zur aktuellen Datenbankinstanz aufrufen
3 | Verzeichnisstruktur der Datenbankinstanzen | Organisation der Datenbankinstanzen, die in die Liste der Datenbankinstanzen im Database Manager GUI aufgenommen wurden, wie im Windows Explorer Sie können die Verzeichnisstruktur ein- oder ausblenden. Wählen Sie dazu View ® Tree und markieren oder entmarkieren Sie Tree.
4 | Liste der Datenbankinstanzen | In die Liste der Datenbankinstanzen des Database Manager GUI aufgenommenen Datenbankinstanzen, deren Anmeldestatus bzw. Betriebszustand Wenn für eine Datenbankinstanz der Betriebszustand ONLINE angezeigt wird, erhalten Sie zusätzlich eine Übersicht der Statistiken und wichtiger Betriebswerte Siehe auch: Liste der Datenbankinstanzen verwalten
5 | Menüliste der aktuellen Datenbankinstanz | Der Name der gewählten Datenbankinstanz wird angezeigt. Sie können die Menüliste ein- oder ausblenden. Wählen Sie dazu View ® Menu und markieren oder entmarkieren Sie Menu.
6 | Ausgabe | Zentraler Bildschirmbereich Darin erscheinen die Eingabemasken für Funktionen und die Ausgabewerte der Anzeigen.
7 | Meldungsausgabe | Anzeige allgemeiner Meldungen und Fehler
8 | Anzeige des Datenbanknamens | Name der aktuellen Datenbankinstanz, gegebenenfalls Name des Datenbankrechners und Anzeige des Betriebszustandes


Anlegen einer Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen einer Datenbankinstanz

Sie können mit dem Database Manager GUI eine Datenbankinstanz auf einem lokalen oder entfernten Rechner anlegen.

Voraussetzungen

● Datenbankinstanz auf einem lokalen Rechner
 Sie besitzen als Betriebssystembenutzer Administrationsrechte für den Rechner.

● Datenbankinstanz auf einem entfernten Rechner
Microsoft Windows: Sie benötigen einen Betriebssystembenutzer für den entfernten Rechner, der dort Administrationsrechte und zusätzlich das Recht log on as batch job oder ein vergleichbares Recht besitzt
UNIX: Sie benötigen einen Betriebssystembenutzer für den entfernten Rechner, der Mitglied der Gruppe sdba ist (siehe dazu Strukturlink <sdba_group> (spezielle Betriebssystemgruppe)).
Hinweise zur Verwaltung von Betriebssystembenutzern finden Sie in Ihrer Betriebssystemdokumentation.

Vorgehensweise

...

Wählen Sie Instance ® Create... .

Starten Sie die gewünschten Schritte jeweils mit Next. Wählen Sie eine der folgenden Möglichkeiten:

● Desktop PC / Laptop

● Custom

● My Templates

Siehe auch:

Konzepte des Datenbanksystems

● Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

● Strukturlink Benutzer, Authentifizierung und Berechtigungen

● Strukturlink Demo-Datenbank


Anlegen einer Datenbankinstanz: Desktop PC/Laptop (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen einer Datenbankinstanz: Desktop PC/Laptop

Sie können mit dem Database Manager GUI mittels Desktop PC /Laptop eine Datenbankinstanz anlegen. Diese Datenbankinstanz ist eine für die Verwendung durch einen Datenbankbenutzer vorkonfigurierte Datenbankinstanz, die sich sehr gut für Tests kleinerer Anwendungen und für das Nachvollziehen der Beispiele der Tutorials anhand der vollständigen Demo-Daten eignet.

Voraussetzungen

Beachten Sie die beim Anlegen einer Datenbankinstanz üblichen Voraussetzungen.

Vorgehensweise

Wählen Sie Instance ® Create... .

Starten Sie die gewünschten Schritte jeweils mit Next. Wählen Sie Desktop PC / Laptop.

1. Machen Sie folgende Angaben:

○ Database Name: Name der Datenbankinstanz (siehe auch: Konzepte des Datenbanksystems, Strukturlink Konventionen für Datenbanknamen). In der Demo-Welt wird als Name der Datenbankinstanz DEMODB verwendet.

○ Database Size (MB): Größe der Datenbankinstanz

○ Markieren Sie Load Tutorial Data, wenn Sie die vollständigen Demo-Daten laden wollen (siehe auch: Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank).
Wenn Sie Load Tutorial nicht markieren, werden die Demo-Daten beim Anlegen der Datenbankinstanz nicht geladen. Sie können die Demo-Daten allerdings zu einem späteren Zeitpunkt laden. Verfahren Sie in diesem Fall z.B. wie in Demo-Daten laden beschrieben.

○ Database System Administrator: Geben Sie den Namen und das Kennwort für den Strukturlink Datenbanksystemadministrator (SYSDBA-Benutzer) an. Verwenden Sie keine Sonderzeichen und wählen Sie nicht den Namen SYSDBA. Wir empfehlen, Großbuchstaben zu verwenden (siehe auch: Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter). In der Demo-Welt werden als Name und Kennwort des Datenbanksystemadministrators DBADMIN und SECRET verwendet.

2. Bestätigen oder ändern Sie die Lage der Volumes für den Daten- und den Log-Bereich.

3. Wenn Sie Ihre Konfiguration als Vorlage zum Anlegen einer Datenbankinstanz speichern wollen, wählen Sie Save Template as... (siehe auch: Konzepte des Datenbanksystems, Strukturlink Vorlagen für Datenbankinstanzen).

4. Wählen Sie Start. Wenn Fehler auftreten, wird der Vorgang sofort abgebrochen, der bis zum Fehler erreichte Stand bleibt jedoch erhalten.

5. Wählen Sie Close, um den Wizard zu beenden.

Ergebnis

Die Datenbankinstanz wird angelegt und in den Betriebszustand ONLINE überführt.

Siehe auch:

Konzepte des Datenbanksystems

● Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

● Strukturlink Benutzer, Authentifizierung und Berechtigungen

Verwendung der Demo-Datenbank

● Strukturlink Tutorial Datenbankverwaltung

● Strukturlink Loader-Tutorial


Anlegen einer Datenbankinstanz: Custom (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen einer Datenbankinstanz: Custom

Sie können mit dem Database Manager GUI mittels Custom eine Datenbankinstanz auf einem lokalen oder entfernten Rechner anlegen. Für diese Datenbankinstanz können Sie alle Voreinstellungen der Datenbankparameter, Volumes usw. individuell ändern.

Voraussetzungen

Beachten Sie die beim Anlegen einer Datenbankinstanz üblichen Voraussetzungen.

Vorgehensweise

Wählen Sie Instance ® Create... .

Starten Sie die gewünschten Schritte jeweils mit Next. Wählen Sie Custom.

1. Um eine Datenbankinstanz auf Ihrem lokalen Rechner anzulegen, machen Sie folgende Angaben:

○ Database Server: <local>: Lassen Sie diesen Eintrag unverändert.

○ Database Name: Name der Datenbankinstanz (siehe auch: Konzepte des Datenbanksystems, Strukturlink Konventionen für Datenbanknamen). In der Demo-Welt wird als Name der Datenbankinstanz DEMODB verwendet.

Um eine Datenbankinstanz auf einem entfernten Rechner anzulegen, machen Sie zusätzlich folgende Angaben:

○ Database Server: Name des entfernten Rechners

○ Port: Port, über den der X-Server angesprochen wird; wenn Sie keine Angabe machen, dann wird der Vorschlagswert verwendet (siehe auch X-Server, Ports und Protokolle des X-Servers).

○ Login Name: Betriebssystembenutzer für den entfernten Rechner

○ Password: Kennwort für den Betriebssystembenutzer auf dem entfernten Rechner

2. Auf einem Rechner kann es mehrere Installationen der Datenbanksoftware geben. Wählen Sie aus den vorhandenen Installationen die gewünschte Installation aus.

3. Sie können weitere Optionen angeben, wenn Sie ein Microsoft Windows-Betriebssystem verwenden:

○ Set the startup type for the database service to automatic: Die Datenbankinstanz wird bei jedem Start des Rechners automatisch gestartet (siehe auch: Konzepte des Datenbanksystems, Strukturlink Automatischer Start).

○ Use the login information as account for the database service: nur für entfernte Rechner; der Service für die Datenbankinstanz läuft auf entfernten Rechner unter dem Namen des dort angemeldeten Betriebssystembenutzers und nicht unter SYSTEM.

○ Automatic extension of data areas: Der Datenbereich wird bei Speicherplatzmangel automatisch erweitert (siehe auch: Automatische Erweiterung des Datenbereichs ein-/ausschalten).

○ Automatic update of statistics: Die Statistiken für den SQL-Optimierer werden automatisch aktualisiert (siehe auch: Statistikinformationen aktualisieren).

4. Geben Sie den Strukturlink Database Manager-Benutzer (DBM-Benutzer) an. In der Demo-Welt werden als Name und Kennwort des Database Manager-Benutzers DBM und DBM verwendet.

Markieren Sie Use Encryption , wenn Sie die Kommunikation zwischen Client und X-Server verschlüsseln wollen (siehe auch: Konzepte des Datenbanksystems, Strukturlink Datenverschlüsselung).

Name und Kennwort des DBM-Benutzers werden vom Datenbanksystem in Großbuchstaben umgewandelt (siehe auch: Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter).

5. Entscheiden Sie, auf welche Art die Datenbankparameter mit initialen Werten belegt werden sollen:

○ Initialize parameters with default values
Für die initiale Belegung der Datenbankparameter werden die Standardwerte der Datenbanksoftware verwendet.

○ Copy parameters from existing database
Für die initiale Belegung der Datenbankparameter werden die Parameterwerte einer bereits vorhandenen Datenbankinstanz verwendet. Wählen Sie die Datenbankinstanz aus, deren Parameterwerte übernommen werden soll.

○ Restore parameters from a backup medium
Für die initiale Belegung der Datenbankparameter werden die Parameterwerte verwendet, die in einer vollständigen Datensicherung gespeichert sind. Wählen Sie die gewünschte vollständige Datensicherung aus.

6. Wählen Sie einen Datenbankinstanztyp aus.

7. Passen Sie die Datenbankparameter (General/Extended) Ihren Erfordernissen an. Um einen Datenbankparameter zu ändern, wählen Sie den Datenbankparameter aus und wählen Sie New Value. Geben Sie den neuen Wert des Datenbankparameters ein und bestätigen Sie Ihre Eingabe. Die Datenbankparameter werden beim Verlassen der Eingabemaske geprüft. Sie werden gegebenenfalls aufgefordert, Änderungen durchzuführen und zu bestätigen, bevor Sie die Eingabemaske verlassen können (siehe auch: Konzepte des Datenbanksystems, Strukturlink Datenbankparameter).

8. Definieren Sie die gewünschten Data- und Log-Volumes.

Sie können die Vorschlagswerte übernehmen oder diese ändern.
Um neue Volumes zu definieren, wählen Sie jeweils New Volume, tragen die Größe sowie die Bezeichnung oder den absoluten Pfad des Volume ein.

9. Wählen Sie zwischen folgenden Optionen:

○ Create and start instance
Geben Sie den Strukturlink Datenbanksystemadministrator (SYSDBA-Benutzer) an. Verwenden Sie dabei keine Sonderzeichen und wählen Sie nicht den Namen SYSDBA. Wir empfehlen, Großbuchstaben zu verwenden (siehe auch: Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter). In der Demo-Welt werden als Name und Kennwort des Datenbanksystemadministrators DBADMIN und SECRET verwendet.

○ Create instance for recovery
Die Datenbankinstanz wird angelegt und in den Betriebszustand ADMIN überführt. Diese Datenbankinstanz kann nur für eine Strukturlink Wiederherstellung verwendet werden. Die Angaben zum Datenbanksystemadministrator (SYSDBA-Benutzer) werden aus der Datensicherung übernommen.

...

10. Sie können weitere Einstellungen vornehmen:

○ Markieren Sie Load Tutorial, wenn Sie die vollständigen Demo-Daten sofort laden wollen (siehe auch: Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank).
Wenn Sie Load Tutorial nicht markieren, werden die Demo-Daten beim Anlegen der Datenbankinstanz nicht geladen. Sie können die Demo-Daten allerdings zu einem späteren Zeitpunkt laden. Verfahren Sie in diesem Fall z.B. wie in Demo-Daten laden beschrieben.

○ Markieren Sie Activate overwrite mode for the log area, wenn Sie den Überschreibmodus für den Log-Bereich aktivieren wollen (Konzepte des Datenbanksystems, Strukturlink Log-Einstellungen).
Wenn Sie Activate overwrite mode for the log area nicht markieren, ist der Überschreibmodus deaktiviert, d.h. ein gefüllter Log-Bereich kann erst nach Sicherung der Log-Einträge überschrieben werden. Sie sollten daher die Automatische Log-Sicherung aktivieren. Sie können den Überschreibmodus zu einem späteren Zeitpunkt aktivieren. Verfahren Sie in diesem Fall z.B. wie in Log-Einstellungen ändern beschrieben.

○ Markieren Sie Automatic log backup, wenn Sie die Automatische Log-Sicherung aktivieren wollen (Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern).
Wenn Sie Automatic log backup nicht markieren, wird die Automatische Log-Sicherung nach Anlegen der Datenbankinstanz nicht aktiviert. Sie können diese allerdings zu einem späteren Zeitpunkt aktivieren. Verfahren Sie in diesem Fall z.B. wie in Ein- und Ausschalten der automatischen Log-Sicherung beschrieben.

11. Wenn Sie Ihre Konfiguration als Vorlage zum Anlegen einer Datenbankinstanz speichern wollen, wählen Sie Save Template as... (siehe auch: Konzepte des Datenbanksystems, Strukturlink Vorlagen für Datenbankinstanzen).

12. Wählen Sie Start. Wenn Fehler auftreten, wird der Vorgang sofort abgebrochen, der bis zum Fehler erreichte Stand bleibt jedoch erhalten.

13. Wählen Sie Close, um den Wizard zu beenden.

Ergebnis

Die Datenbankinstanz wird Ihren Angaben entsprechend angelegt und in den Betriebszustand ONLINE überführt.

Neben den erforderlichen Benutzern, Volumes usw. wurde eine erste Sicherungsvorlage mit dem Namen INITIALBACKUP erzeugt und eine Datensicherung auf INITIALBACKUP durchgeführt. Wenn Sie weitere Sicherungsvorlagen erzeugen wollen, verfahren Sie wie in Verwalten der Sicherungsvorlagen beschrieben. Wenn Sie weitere Sicherungen durchführen wollen, verfahren Sie wie in Sicherungsverfahren beschrieben.

Siehe auch:

Konzepte des Datenbanksystems

● Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

● Strukturlink Benutzer, Authentifizierung und Berechtigungen

● Strukturlink Sicherungsvorlagen und Datenträger


Anlegen einer Datenbankinstanz: My Templates (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen einer Datenbankinstanz: My Templates

Sie können mit dem Database Manager GUI mittels My Templates eine Datenbankinstanz mit den vorhandenen Daten einer Vorlage für Datenbankinstanzen anlegen. Für diese Datenbankinstanz können Sie alle Voreinstellungen der Datenbankparameter, Volumes usw. individuell ändern.

Voraussetzungen

Beachten Sie die beim Anlegen einer Datenbankinstanz üblichen Voraussetzungen.

Sie haben Vorlagen für das Anlegen einer Datenbankinstanz erzeugt (siehe auch: Konzepte des Datenbanksystems, Strukturlink Vorlagen für Datenbankinstanzen).

Vorgehensweise

Wählen Sie Instance ® Create... .

Starten Sie die gewünschten Schritte jeweils mit Next. Wählen Sie My Templates.

  1. Wählen Sie die gewünschte Vorlage für das Anlegen einer Datenbankinstanz mit Open Template aus.
  2. Sie können mit Properties die Vorlage für das Anlegen einer Datenbankinstanz ändern.
  3. Verfahren Sie weiter wie in Anlegen einer Datenbankinstanz: Custom beschrieben, um eine Datenbankinstanz anzulegen.

Ergebnis

Die Datenbankinstanz wird Ihren Angaben entsprechend angelegt und in den Betriebszustand ONLINE überführt.

Neben den erforderlichen Benutzern, Volumes usw. wurde eine erste Sicherungsvorlage mit dem Namen INITIALBACKUP erzeugt und eine Datensicherung auf INITIALBACKUP durchgeführt. Wenn Sie weitere Sicherungsvorlagen erzeugen wollen, verfahren Sie wie in Verwalten der Sicherungsvorlagen beschrieben. Wenn Sie weitere Sicherungen durchführen wollen, verfahren Sie wie in Sicherungsverfahren beschrieben.

Siehe auch:

Konzepte des Datenbanksystems

● Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

● Strukturlink Benutzer, Authentifizierung und Berechtigungen

● Strukturlink Sicherungsvorlagen und Datenträger


Initialisieren einer vorhandenen Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Initialisieren einer vorhandenen Datenbankinstanz

Sie können mit dem Database Manager GUI eine vorhandene Datenbankinstanz auf einem lokalen oder entfernten Rechner initialisieren.

Beim Initialisieren werden alle Daten gelöscht.

Sie können jedoch Ihre Datenbankparameter und die Konfiguration Ihrer Volumes und Sicherungsvorlagen übernehmen.

Voraussetzungen

● Sie besitzen Administrationsrechte für die Datenbankinstanz. Das ist in jedem Fall gesichert, wenn Sie sich als erster Strukturlink DBM-Benutzer anmelden.

● Datenbankinstanz auf einem lokalen Rechner: Sie besitzen als Betriebssystembenutzer Administrationsrechte für den Rechner.

● Datenbankinstanz auf einem entfernten Rechner: Sie verfügen über einen Betriebssystembenutzer für den entfernten Rechner, der Administrationsrechte und zusätzlich das Recht log on as batch job (für Microsoft Windows-Betriebssysteme) oder ein vergleichbares Recht besitzt (Hinweise zur Verwaltung von Betriebssystembenutzern finden Sie in Ihrer Betriebssystemdokumentation).

Vorgehensweise

...

Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.

Wählen Sie Instance ® Initialize... .

Starten Sie die gewünschten Schritte jeweils mit Next.

1. Wählen Sie Initialize the database instance <database_name>.
Unter dem bereits existierenden Namen wird eine leere Datenbankinstanz angelegt (die Datenbankinstanz wird initialisiert, alle Daten der alten Version gehen verloren).

2. Überführen Sie die Datenbankinstanz gegebenenfalls in den Betriebszustand OFFLINE.

3. Wählen Sie Use current parameters.

4. Die von Ihnen für die Datenbankinstanz konfigurierten Datenbankparameter werden vorgeschlagen, Sie müssen diese also nicht ändern.

5. Die von Ihnen für die Datenbankinstanz konfigurierten Volumes werden vorgeschlagen, Sie müssen diese also nicht ändern.

6. Die von Ihnen für die Datenbankinstanz konfigurierten Sicherungsvorlagen werden vorgeschlagen, Sie müssen diese also nicht ändern.

7. Wählen Sie zwischen den folgenden Optionen:

○ Create and start instance
Geben Sie den Strukturlink Datenbanksystemadministrator (SYSDBA-Benutzer) an. Die Datenbankinstanz wird initialisiert und in den Betriebszustand ONLINE überführt.

○ Create instance for recovery
Die Datenbankinstanz wird initialisiert und in den Betriebszustand ADMIN überführt. Diese Datenbankinstanz kann nur für eine Wiederherstellung verwendet werden. Die Angaben zum Datenbanksystemadministrator werden aus der Datensicherung übernommen.

8. Wählen Sie Start.

9. Wählen Sie Close.


Verwalten von Datenbankinstanzen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Verwalten von Datenbankinstanzen

Folgende Datenbankverwaltungsaufgaben werden beschrieben:

Datenbankinstanz anlegen, initialisieren oder löschen | Anlegen einer Datenbankinstanz Initialisieren einer vorhandenen Datenbankinstanz Löschen einer Datenbankinstanz
Liste der Datenbankinstanzen anzeigen, anlegen, ändern oder löschen | Bildschirmbereiche des Database Manager GUI Liste der Datenbankinstanzen verwalten
Datenbankinstanzverbindung zum DBM-Server herstellen | Verbindung zum DBM-Server
Datenbankinstanz starten oder stoppen | Starten der Datenbankinstanz (Restart) Stoppen der Datenbankinstanz (Shutdown)
Datenbankinstanz sichern oder wiederherstellen | Sichern Wiederherstellen
Datenbanksitzungen überwachen | Betriebszustand überwachen Datenbanksitzungen anzeigen Datenbanksitzung manuell beenden
Benutzer anlegen, anzeigen, ändern, löschen | Verwalten des Datenbanksystemadministrators Verwalten der Database Manager-Benutzer Verwalten von Datenbankbenutzern
Volumes anlegen, anzeigen, ändern, löschen | Volumes anlegen, anzeigen und löschen Volume-Eigenschaften ändern Datenbereichs-Informationen anzeigen Log-Bereichs-Informationen anzeigen Automatische Erweiterung des Datenbereichs ein-/ausschalten
Datenbankparameter anzeigen, ändern | Datenbankparameter anzeigen und ändern Volume-Datenbankparameter ändern
Log-Einstellungen anzeigen und ändern | Log-Bereichs-Informationen anzeigen Log-Einstellungen ändern
Hot Standby-System einrichten | Master-Instanz einrichten (Hot Standby) Standby-Instanz hinzufügen (Hot Standby)
Indizes aktivieren, deaktivieren, löschen | Indizes de-/aktivieren oder löschen
Sprachunterstützung (Mapchar-Set) | Mapchar-Sets anlegen, anzeigen, ändern und löschen
Statistiken aktualisieren | Statistikinformationen aktualisieren
Demo-Daten laden | Anlegen einer Datenbankinstanz: Desktop PC/Laptop Demo-Daten laden

Siehe auch:

Anzeigen von Informationen

Diagnosemöglichkeiten


Liste der Datenbankinstanzen verwalten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Liste der Datenbankinstanzen verwalten

Um mit dem Database Manager GUI Datenbankinstanzen verwalten zu können, müssen diese in die Liste der Datenbankinstanzen (siehe dazu Bildschirmbereiche) aufgenommen sein. Die Art der Anzeige der Datenbankinstanzen in dieser Liste können Sie über View ® ... Ihren Wünschen entsprechend einstellen.

Voraussetzung

Wenn Sie mit dem Database Manager auf eine entfernte Datenbankinstanz (remote) zugreifen wollen, muss auf dem entsprechenden Datenbankrechner der X-Server gestartet sein.

Eintrag in die Liste der Datenbankinstanzen hinzufügen

...

1. Wählen Sie Instance ® Add.

2. Wählen Sie als Database Server den gewünschten Rechnernamen aus.
Bestätigen Sie Ihre Wahl mit Add.

3. Markieren Sie die Datenbankinstanzen, die in die Liste aufgenommen werden sollen und bestätigen Sie Ihre Wahl.

Die Datenbankinstanz wird in die Liste der Datenbankinstanzen aufgenommen.

Um eine Datenbankinstanz verwalten zu können, müssen Sie für die gewünschte Datenbankinstanz die Verbindung zum DBM-Server herstellen.

Eintrag aus der Liste der Datenbankinstanzen löschen

...

1. Markieren Sie die gewünschte Datenbankinstanz in der Liste der Datenbankinstanzen.

2. Wählen Sie File ® Delete.

3. Bestätigen Sie, dass Sie die Datenbankinstanz aus der Liste löschen wollen.

Die Datenbankinstanz wird aus der Liste der Datenbankinstanzen im Database Manager gelöscht.

Wenn Sie eine Datenbankinstanz löschen wollen, verfahren Sie wie in Löschen einer Datenbankinstanz beschrieben.

Datenbankinstanzliste im Database Manager mit den vorhandenen Datenbankinstanzen synchronisieren

Sie können dafür sorgen, dass die Liste der Datenbankinstanzen mit den auf dem Rechner tatsächlich vorhandenen Datenbankinstanzen übereinstimmt.

1. Markieren Sie den gewünschten Rechner in der Verzeichnisstruktur der Datenbankinstanzen.

2. Wählen Sie File ® Sync Server.

Alle auf dem Rechner vorhandenen Datenbankinstanzen werden in die Liste der Datenbankinstanzen aufgenommen. Einträge von Datenbankinstanzen, die auf dem Rechner nicht mehr vorhanden sind, werden aus der Liste gelöscht.


Verbindung zum DBM-Server (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Verbindung zum DBM-Server

Das Verwalten von Datenbankinstanzen mit Hilfe des Programms Database Manager GUI setzt voraus, dass eine Verbindung zwischen der zu verwaltenden Datenbankinstanz und ihrem DBM-Server besteht.

Sie können die Verbindung zum DBM-Server unter Berücksichtigung der Performance Ihres Systems für eine, mehrere oder alle in der Liste angezeigten Datenbankinstanzen gezielt herstellen. Ebenso können Sie die Verbindung einzelner Datenbankinstanzen zum DBM-Server beenden, um die Systemlast zu reduzieren.

Voraussetzungen

Die gewünschte Datenbankinstanz muss in die Liste der Datenbankinstanzen aufgenommen sein. Verfahren Sie dazu wie in Liste der Datenbankinstanzen verwalten beschrieben.

Vorgehensweise

Aufbau der Verbindung einer Datenbankinstanz zum DBM-Server

Der Eintrag zum Zustand der Datenbankinstanz State ist Not connected.

1. Markieren Sie die gewünschte Datenbankinstanz in der Liste der Datenbankinstanzen.

2. Wählen Sie Instance ® Connect.

3. Geben Sie gegebenenfalls Name und Kennwort des Database Manager-Benutzers ein. Sie können diese Angaben speichern.

Der Database Manager kann unter anderem den aktuellen Betriebszustand der ausgewählten Datenbankinstanz ermitteln.

Beenden der Verbindung einer Datenbankinstanz zum DBM-Server

1. Markieren Sie die gewünschte Datenbankinstanz in der Liste der Datenbankinstanzen.

2. Wählen Sie Instance ® Disconnect.

Der Eintrag zum Zustand dieser Datenbankinstanz State ist nun Not connected.

Die Verbindung zum DBM-Server wurde beendet. Der Database Manager kann den aktuellen Betriebszustand der Datenbankinstanz nicht mehr ermitteln und daher Analysen der Datenbankinstanz nicht durchführen.


Starten der Datenbankinstanz (Restart) (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Starten der Datenbankinstanz (Restart)

Sie können mit dem Database Manager GUI eine Datenbankinstanz starten.

Voraussetzungen

1. Sorgen Sie dafür, dass die Datenbankinstanz in die Liste der Datenbankinstanzen aufgenommen ist (siehe dazu Liste der Datenbankinstanzen verwalten).

2. Stellen Sie die Verbindung zum DBM-Server her.

3. Ermitteln Sie den Betriebszustand der Datenbankinstanz: Betriebszustand überwachen.

Vorgehensweise

Wählen Sie die gewünschte Datenbankinstanz aus der Liste der Datenbankinstanzen mittels Doppelklick aus.

Die Datenbankinstanz befindet sich im Betriebszustand OFFLINE.

· Überführen in den Betriebszustand ONLINE
Wählen Sie Actions ® Online.
Die Datenbankinstanz wird gestartet.

· Überführen in den Betriebszustand ADMIN
Wählen Sie Actions ® Admin.
Die Datenbankinstanz wird in den Betriebszustand ADMIN überführt.

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

· Überführen in den Betriebszustand ONLINE
Wählen Sie Actions ® Online.
Die Datenbankinstanz wird gestartet.

Bei jedem Starten der Datenbankinstanz wird eine Kopie der Strukturlink Protokolldatei knldiag unter dem Namen knldiag.old erstellt und die Datei knldiagüberschrieben. Nutzen Sie diese Protokolldatei, um Fehler beim Starten oder Stoppen der Datenbankinstanz zu analysieren.

Siehe auch:

Stoppen der Datenbankinstanz (Shutdown)

Konzepte des Datenbanksystems, Strukturlink Automatischer Start


Stoppen der Datenbankinstanz (Shutdown) (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Stoppen der Datenbankinstanz (Shutdown)

Sie können mit dem Database Manager GUI eine Datenbankinstanz stoppen.

Voraussetzungen

1. Sorgen Sie dafür, dass die Datenbankinstanz in die Liste der Datenbankinstanzen aufgenommen ist (siehe dazu Liste der Datenbankinstanzen verwalten).

2. Stellen Sie die Verbindung zum DBM-Server her.

3. Die Datenbankinstanz befindet sich im Betriebszustand ONLINE: Betriebszustand überwachen.

Vorgehensweise

Wählen Sie die gewünschte Datenbankinstanz aus der Liste der Datenbankinstanzen mittels Doppelklick aus.

· Überführen in den Betriebszustand ADMIN
Wählen Sie Actions ® Admin.
Die Datenbankinstanz wird in den Betriebszustand OFFLINE und anschließend in den Betriebszustand ADMIN überführt. Eventuelle Änderungen an den Datenbankparametern werden wirksam.

· Überführen in den Betriebszustand OFFLINE
Wählen Sie Actions ® Offline.
Die Datenbankinstanz wird gestoppt

Wenn gerade eine Strukturlink Sicherung durchgeführt wird, wartet der Database Manager mit dem Stoppen der Datenbankinstanz solange, bis die Sicherung beendet ist.

Nutzen Sie die Strukturlink Protokolldatei knldiag, um Fehler beim Starten oder Stoppen der Datenbankinstanz zu analysieren.

Siehe auch:

Starten der Datenbankinstanz (Restart)


Betriebszustand überwachen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Betriebszustand überwachen

Sie können mit dem Database Manager GUI den Betriebszustand jeder Datenbankinstanz überwachen.

Voraussetzung

1. Sorgen Sie dafür, dass die Datenbankinstanz in die Liste der Datenbankinstanzen aufgenommen ist (siehe dazu: Liste der Datenbankinstanzen verwalten).

2. Stellen Sie die Verbindung zum DBM-Server her.

Betriebszustand anzeigen

Prüfen Sie, mit welchem Kennzeichen das allgemeine Symbol für die Datenbankinstanz in der Liste der Datenbankinstanzen versehen ist.

Sie können die Anzeigen View ® Large Icons / Small Icons / List für diese Zwecke verwenden.

Diese Grafik wird im zugehörigen Text erklärt | Allgemeines Symbol für eine Datenbankinstanz
Diese Grafik wird im zugehörigen Text erklärt | Datenbankinstanz ist im Betriebszustand OFFLINE
Diese Grafik wird im zugehörigen Text erklärt | Datenbankinstanz ist im Betriebszustand ADMIN
Diese Grafik wird im zugehörigen Text erklärt | Datenbankinstanz ist im Betriebszustand ONLINE

Strukturlink Hot-Standby-Datenbankinstanzen werden mit folgenden Symbolen versehen:

Diese Grafik wird im zugehörigen Text erklärt | Master-Instanz oder Standby-Instanz im Betriebszustand OFFLINE.
Diese Grafik wird im zugehörigen Text erklärt | Master-Instanz im Betriebszustand ADMIN oder Standby-Instanz im Betriebszustand STANDBY.
Diese Grafik wird im zugehörigen Text erklärt | Master-Instanz im Betriebszustand ONLINE.

Betriebszustand ändern

Wählen Sie die gewünschte Datenbankinstanz in der Liste der Datenbankinstanzen mittels Doppelklick aus.

Wählen Sie Actions ® OFFLINE / ADMIN / ONLINE, um in den gewünschten Betriebszustand zu wechseln.

Den Betriebszustand von Standby-Instanzen in einem Hot-Standby-System können Sie nicht direkt ändern. Standby-Instanzen werden von der Master-Instanz gesteuert.

Siehe auch:

Starten der Datenbankinstanz (Restart)

Stoppen der Datenbankinstanz (Shutdown)


Datenbanksitzung manuell beenden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbanksitzung manuell beenden

Verwendung

In Sonderfällen kann es notwendig sein, eine einzelne Datenbanksitzung manuell zu beenden.

Voraussetzung

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.

2. Wählen Sie Instance ® Sessions.

3. Markieren Sie die gewünschte Datenbanksitzung.

4. Wählen Sie Actions ® Kill Selected Sessions, um die Datenbanksitzung zu beenden.

Siehe auch:

Datenbanksitzungen anzeigen


Volumes anlegen, anzeigen und löschen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Volumes anlegen, anzeigen und löschen

Sie können mit Hilfe des Database Manager GUI die Speicherkapazität Ihres Daten- oder Log-Bereichs erweitern oder verringern.

● Sie können so viele Data-Volumes anlegen wie im Strukturlink allgemeinen Datenbankparameter MAXDATAVOLUMES angegeben.

● Es können so viele Log-Volumes anlegen wie im allgemeinen Datenbankparameter MAXLOGVOLUMES angegeben.

● Sie können Data-Volumes löschen.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Wenn Sie Volumes neu anlegen möchten, muss der Wert des Datenbankparameters MAXDATAVOLUMES bzw. MAXLOGVOLUMES mindestens so groß sein wie die Summe der vorhandenen und der neu zu definierenden Volumes.

Das System prüft vor jedem Start der Datenbankinstanz, ob noch genügend Speicherplatz für mindestens ein Volume jeden Typs frei ist. Wenn nicht, vergrößert es den entsprechenden Datenbankparameter automatisch um 1.

Falls erforderlich, verändern Sie die Datenbankparameter MAXDATAVOLUMES und/oder MAXLOGVOLUMES entsprechend (Volume-Datenbankparameter ändern). Damit können Sie nachfolgend im Betriebszustand ONLINE der Datenbankinstanz mehrmals hintereinander ein Volume eines Typs hinzufügen, ohne zwischendurch die Datenbankinstanz stoppen zu müssen.

Vorgehensweise

...

Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.

Wählen Sie Instance ® Configuration ® Volumes.

Sie erhalten alle bisher vorhandenen Volumes der gewählten Art mit ihren Daten sowie die entsprechend des eingestellten Parameterwertes noch mögliche Anzahl Volumes angezeigt.

Name | Name des Volume
Size | Größe des Volume
Type | Datei, Raw Device oder symbolischer Link
Device/File | Device/Pfad und Dateiname des Volume
M. Type | Datei, Raw Device oder symbolischer Link (gespiegeltes Volume)
M. Location | Pfad des gespiegelten Log-Volume

Anlegen eines Volume

1. Im Bereich Configuration – Volumes wählen Sie Actions ® New Volume.

2. Definieren Sie das neue Volume, indem Sie unter Size die Größe und unter Device/File das Device bzw. den Pfad und Dateinamen des Volume angeben.

3. Wählen Sie OK.

Löschen eines Data-Volume

1. Markieren Sie das zu löschende Data-Volume.

2. Wählen Sie Actions ® Delete.

3. Bestätigen Sie, dass Sie das Data-Volume löschen wollen.

Siehe auch:

Volume-Eigenschaften ändern

Automatische Erweiterung des Datenbereichs ein-/ausschalten

Konzepte des Datenbanksystems, Strukturlink Datenbankinstanz planen


Volume-Eigenschaften ändern (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Volume-Eigenschaften ändern

Sie können mit dem Database Manager GUI Volume-Eigenschaften ändern.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand OFFLINE.

Sie haben das Log- oder Data-Volume, dessen geänderten Pfad Sie dem Database Manager GUI bekanntgeben wollen, in den neuen Pfad kopiert.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.

2. Wählen Sie Instance ® Configuration ® Volumes.
Sie erhalten alle vorhandenen Volumes der gewählten Art angezeigt.

Name | Name des Volume
Size | Größe des Volume
Type | Datei, Raw Device oder symbolischer Link
Device/File | Device/Pfad und Dateiname des Volume
M. Type | Datei, Raw Device oder symbolischer Link (gespiegeltes Volume)
M. Location | Pfad des gespiegelten Log-Volume

3. Markieren Sie das zu ändernde Volume.

4. Wählen Sie Action ® Properties.

5. Geben Sie unter Device/File das Device bzw. den Pfad und Dateinamen des Volume an.

6. Wählen Sie OK.

Wenn Sie nun die Datenbankinstanz neu starten, ist der neue Pfad dem Datenbanksystem bekannt.

Siehe auch:

Volumes anlegen, anzeigen und löschen


Datenbankparameter anzeigen und ändern (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbankparameter anzeigen und ändern

Sie können mit dem Database Manager GUI die Datenbankparameter der aktuellen Datenbankinstanz anzeigen und ändern. Dies ist in jedem Betriebszustand der Datenbankinstanz möglich.

Die Änderungen von Datenbankparametern werden erst nach dem erneuten Starten der Datenbankinstanz (Restart) wirksam.

Einige Datenbankparameter können Sie auch im laufenden Betrieb ändern. Für diese Datenbankparameter können Sie außerdem wählen, wie lange die Änderung wirksam ist.

Weitere Informationen zu den einzelnen Datenbankparametern und ihren Eigenschaften finden Sie unter Konzepte des Datenbanksystems, Strukturlink Datenbankparameter.

Vorgehensweise

...

1. Wählen Sie Instance ® Configuration ® Parameters.

Die Datenbankparameter werden angezeigt. Sie sind in drei Gruppen unterteilt:

○ Allgemeine Datenbankparameter (General)

○ Spezielle Datenbankparameter (Extended)

○ Support-Datenbankparameter (Support)

2. Wählen Sie den gewünschten Datenbankparameter aus.

3. Wählen Sie Action ® Properties.

4. Geben Sie den neuen Wert des Datenbankparameters im Feld New Value ein.

Name | Name des Datenbankparameters
Value | Wert des Datenbankparameters, der aktuell verwendet wird
New Value | neuer Wert des Datenbankparameters
Comment | benutzerdefinierter Kommentar Dieser Kommentar wird in der Historie der Datenbankparameter angezeigt. Siehe Datenbankparameter anzeigen
Durability | ● Permanent: Änderung ist dauerhaft ● Running: Änderung wird sofort wirksam
Description | Hilfetext zum gewählten Parameter

5. Bestätigen Sie Ihre Eingabe.


Volume-Datenbankparameter ändern (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Volume-Datenbankparameter ändern

Mit dem Database Manager GUI können Sie Datenbankparameter definieren, unter anderem auch diejenigen, die die maximal mögliche Anzahl Volumes einer Datenbankinstanz festlegen: die Strukturlink allgemeinen Datenbankparameter MAXDATAVOLUMES und MAXLOGVOLUMES.

Sie können die Werte beider Datenbankparameter nachträglich in jedem Betriebszustand der Datenbankinstanz verändern. Wie alle Datenbankparameteränderungen werden diese jedoch erst mit dem nächsten Starten der Datenbankinstanz wirksam.

Vorgehensweise

...

1. Verfahren Sie für die Datenbankparameter MAXDATAVOLUMES und/oder MAXLOGVOLUMES wie unter Datenbankparameter anzeigen und ändern beschrieben.

2. Starten Sie die Datenbankinstanz neu.

Der Database Manager GUI überführt die Datenbankinstanz nacheinander in die Betriebszustände OFFLINE und ONLINE und sichert den neuen Wert des Datenbankparameters in der Parameterdatei.

Der für diese Anzahl von Volumes erforderlichen Speicherplatz zuzüglich einer Reserve von der Größe des größten Volume dieses Typs wird reserviert. Diese Reserve ermöglicht Ihnen, bei laufendem Datenbankbetrieb ein zusätzliches Volume anzulegen, wenn die anfangs geplante Anzahl von Volumes nicht ausreicht.

Siehe auch:

Volumes anlegen, anzeigen und löschen


Automatische Erweiterung des Datenbereichs ein-/ausschalten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Automatische Erweiterung des Datenbereichs ein-/ausschalten

Sie können Ihr Datenbanksystem so konfigurieren, dass das System jeweils ein neues Data-Volume hinzufügt, sobald der Datenbereich zu einem bestimmten Prozentsatz gefüllt ist. Dazu können Sie mit dem Database Manager GUI das automatische Erweitern des Datenbereichs einschalten.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Für diese Funktion wird eine eigene Event-Task benötigt. Stellen Sie deshalb sicher, dass der Datenbankparameter _MAXEVENTTASKS groß genug eingestellt ist.

Wenn Sie die automatische Erweiterung des Datenbereichs einschalten, muss das letzte Data-Volume, das Sie hinzugefügt haben, vom Typ Datei sein.

Sie können die automatische Erweiterung des Datenbereichs bereits beim Anlegen einer Datenbankinstanz aktivieren (Anlegen einer Datenbankinstanz: Custom).

Automatische Erweiterung des Datenbereichs einschalten

...

1. Wählen Sie Instance ® Data Area Extension.

2. Geben Sie den Füllungsgrad in Prozent an, bei dem das Datenbanksystem ein neues Data-Volume zum Datenbereich hinzufügen soll.

3. Wählen Sie On.

Ergebnis

Beim Einschalten dieser Funktion können Sie den Prozentsatz definieren, bei dessen Erreichen ein Data-Volume hinzugefügt werden soll. Wenn Sie keinen Prozentsatz angeben, wird als Systemvorschlag bei einem Füllungsgrad von 90 % ein Data-Volume hinzugefügt. Den definierten Wert können Sie durch erneutes Ausführen der Funktion mit einem anderen Wert überschreiben.

Die Anzahl der Data-Volumes, die während des laufenden Datenbankbetriebs hinzugefügt werden können, ist durch den Wert des Datenbankparameters MAXDATAVOLUMES begrenzt.

Auf der Basis der vorhandenen Volume-Definitionen wird ein Systemvorschlag für den Namen des neuen Data-Volume ermittelt und verwendet.

Automatische Erweiterung des Datenbereichs ausschalten

...

1. Wählen Sie Instance ® Data Area Extension.

2. Wählen Sie Off.

Ergebnis

Überwachen Sie regelmäßig den Datenbereich: Datenbereichs-Informationen anzeigen.

Erweitern Sie rechtzeitig den Datenbereich (Volumes anlegen, anzeigen und löschen) bzw. aktivieren Sie die automatische Erweiterung des Datenbereichs erneut.

Siehe auch:

Datenbankparameter anzeigen und ändern

Volume-Datenbankparameter ändern


Log-Einstellungen ändern (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Log-Einstellungen ändern

Sie können mit dem Database Manager GUI die Log-Einstellungen ändern.

Voraussetzungen

Stellen Sie fest, welche Sicherheitsbedürfnisse Sie haben und informieren Sie sich über die möglichen Log-Einstellungen. Informationen dazu finden Sie in der Dokumentation Konzepte des Datenbanksystems in den Abschnitten Strukturlink Protokollierung von Datenänderungen (Logging) und Strukturlink Sichern und Wiederherstellen.

Sie können einige Log-Einstellungen bereits beim Anlegen einer Datenbankinstanz einstellen (Anlegen einer Datenbankinstanz: Custom).

Überprüfen Sie im Database Manager GUI regelmäßig die Log-Bereichs-Informationen.

Vorgehensweise

...

Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz. Wählen Sie Instance ® Configuration ® Log Settings.

Starten Sie die gewünschten Schritte jeweils mit Next.

1. Markieren Sie die Log-Einstellung, die Sie ändern möchten:

○ Log Mode: Log-Bereich spiegeln

○ Overwrite Mode for the Log Area: Überschreibmodus für Log-Bereich ein- oder ausschalten

○ Activating or Deactivating the Redo Log Management: Redo-Log-Verwaltung aus- oder einschalten

2. Sie können nacheinander mehrere Log-Einstellungen ändern. Wählen Sie dazu nach Abschluss einer Log-Einstellung Back.

Log-Bereich spiegeln

Wenn Sie den Log-Bereich spiegeln wollen (siehe dazu: Strukturlink Log-Modus), dann markieren Sie die Log-Einstellung Log Mode.

Die Datenbankinstanz kann in einem beliebigen Betriebszustand sein. Beachten Sie jedoch, dass die Datenbankinstanz nach Beendigung der Einstellung des Log-Modus in jedem Fall in den Betriebszustand OFFLINE überführt wird und anschließend in den Betriebszustand ONLINE.

Sie werden vom Database Manager aufgefordert, die erforderlichen Spiegel der Log-Volumes anzulegen.

...

1. Wählen Sie Properties.

2. Geben Sie unter Location die Lage der Spiegel an.

3. Starten Sie den Vorgang.

Die Datenbankinstanz wird nach Abschluss dieser Operation in den Betriebszustand OFFLINE und anschließend ONLINE überführt.

Wenn Sie den Spiegel nicht mehr verwenden wollen, markieren Sie die Log-Einstellung Log Mode und folgen Sie den weiteren Anweisungen.

Überschreibmodus für Log-Bereich

Wenn Ihr Sicherheitskonzept es erlaubt, dass Sie den Log-Bereich ohne vorherige Sicherung der Log-Einträge überschreiben können (siehe dazu: Strukturlink Überschreibmodus für Log-Bereich), markieren Sie die Log-Einstellung Overwrite Mode for the Log Area und folgen Sie den weiteren Anweisungen.

Nach einer Standardinstallation ist der normale Log-Sicherungsbetrieb eingeschaltet, d.h. der Überschreibmodus ist deaktiviert. Damit Sie den Überschreibmodus ändern können, muss die Datenbankinstanz im Betriebszustand ADMIN oder ONLINE sein.

Wenn der Überschreibmodus aktiviert wurde, bleibt diese Einstellung auch nach einem erneuten Start der Datenbankinstanz erhalten.

Um erneut auf den normalen Log-Sicherungsbetrieb umzuschalten (d.h. Deaktivieren des Überschreibmodus), markieren Sie Overwrite Mode for the Log Area und folgen Sie den weiteren Anweisungen. Sie werden aufgefordert, eine vollständige Datensicherung durchzuführen, um die Sicherheit Ihres Datenbestandes zu gewährleisten.

Redo-Log-Verwaltung aus- und einschalten

Für Ausnahmesituationen besteht die Möglichkeit, die Redo-Log-Verwaltung auszuschalten. Markieren Sie dazu die Log-Einstellung Activating or Deactivating the Redo Log Management (siehe dazu: Strukturlink Redo-Log-Verwaltung ein- oder ausschalten) und folgen Sie den weiteren Anweisungen.

Nach einer Standardinstallation ist die Redo-Log-Verwaltung eingeschaltet. Damit Sie diese Log-Einstellung ändern können, muss die Datenbankinstanz im Betriebszustand ADMIN sein.

Wenn die Redo-Log-Verwaltung ausgeschaltet wurde, bleibt diese Einstellung auch nach einem erneuten Start der Datenbankinstanz erhalten.

Sie sollten möglichst bald die Redo-Log-Verwaltung wieder einschalten, um die Sicherheit Ihres Datenbanksystems zu gewährleisten. Markieren Sie dazu Activating or Deactivating the Redo Log Management und folgen Sie den weiteren Anweisungen. Sie werden aufgefordert, eine vollständige Datensicherung durchzuführen, um die Sicherheit Ihres Datenbestandes zu gewährleisten.


Master-Instanz einrichten (Hot-Standby) (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Master-Instanz einrichten (Hot-Standby)

Sie können mit dem Database Manager GUI die Master-Instanz eines Strukturlink Hot-Standby-Systems einrichten.

Voraussetzungen

· Siehe Konzepte des Datenbanksystems, Strukturlink Systemanforderungen für ein Hot-Standby-System

· Sie sind an die Datenbankinstanz des Hot-Standby-Systems auf dem Virtual Server angemeldet.

Vorgehensweise

Wählen Sie im Database Manager GUI Instance ® Configuration ® Hot Standby.

Starten Sie die gewünschten Schritte jeweils mit Next.

...

1. Wählen Sie Enable or Disable the Hot Standby System.

2. Wählen Sie Enable Hot Standby System.

3. Geben Sie als Virtual Server Name den Namen an, den der Systemadministrator für den Rechner definiert hat, auf dem sich die Master-Instanz befindet. Siehe Konzepte des Datenbanksystems, Strukturlink Architektur eines Hot-Standby-Systems.

4. Geben Sie unter Storage DLL den Namen der Bibliothek an, über die das Speicherverwaltungssystem angesteuert wird.

5. Wählen Sie Start.

Siehe auch:

Standby-Instanz hinzufügen (Hot-Standby)


Standby-Instanz hinzufügen (Hot-Standby) (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Standby-Instanz hinzufügen (Hot-Standby)

Sie können mit dem Database Manager GUI einem Strukturlink Hot-Standby-System eine Standby-Instanz hinzufügen.

Voraussetzungen

· Siehe Konzepte des Datenbanksystems, Strukturlink Systemanforderungen für ein Hot-Standby-System

· Die Master-Instanz des Hot-Standby-Systems wurde bereits eingerichtet.

· Sie sind an die Datenbankinstanz des Hot-Standby-Systems auf dem Virtual Server angemeldet.

Vorgehensweise

Wählen Sie im Database Manager GUI Instance ® Configuration ® Hot Standby.

Starten Sie die gewünschten Schritte jeweils mit Next.

...

1. Wählen Sie Add or Remove Standby Instances.

2. Klicken Sie auf den Add Standby Instance-Button. Machen Sie folgende Angaben:

Node | Name des Standby-Rechners
Login Name | Betriebssystembenutzer auf dem Standby-Rechner
Password | Kennwort des Betriebssystembenutzers auf dem Standby-Rechner
Installation | Installationspfad der Datenbanksoftware auf dem Standby-Rechner
Delay | Zeitverzögerung in Sekunden, mit der die Standby-Instanz die Änderungen in der Master-Instanz nachvollzieht.

3. Wählen Sie Start.

Die Standby-Instanz wurde hinzugefügt und in den Betriebszustand STANDBY gebracht.

Siehe auch:

Master-Instanz einrichten (Hot-Standby)


Indizes de-/aktivieren oder löschen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Indizes de-/aktivieren oder löschen

Sie können mit Hilfe des Database Manager GUI ermitteln, welche der vorhandenen Indizes in einer Datenbankinstanz genutzt wurden.

Sie können außerdem ausgewählte Indizes aktivieren, deaktivieren oder löschen.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.

2. Wählen Sie Instance ® Tuning ® Index Use.

3. Sie haben die Möglichkeit auszuwählen, welche Indizes angezeigt werden sollen. Geben Sie dazu geeignete Suchargumente ein:

Owner | Eigentümer
Table Name | Name der Tabelle
Index Name | Name des Index

Sie können weiterhin zwischen folgenden Optionen wählen:

Disabled indexes only | Nur deaktivierte Indizes
Unused indexes only | Nur ungenutzte Indizes

4. Wählen Sie Actions ® Search. Sie erhalten eine Liste der Indizes, die Ihren Angaben entsprechen.

5. Markieren Sie die Indizes, die Sie aktivieren wollen.
Wenn Sie alle ausgegebenen Indizes aktivieren wollen, wählen Sie Actions ® Mark All.
Entmarkieren Sie die Indizes der Liste, die Sie deaktivieren wollen.

6. Wählen Sie Actions und die gewünschte Aktion.

Siehe auch:

Wiederherstellen der Indizes nach Datenbankwiederherstellung

Datenbankverwaltung im CCMS, Strukturlink Indizes


Mapchar-Sets anlegen, anzeigen, ändern und löschen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Mapchar-Sets anlegen, anzeigen, ändern und löschen

Sie können mit dem Database Manager GUI Strukturlink Mapchar-Sets anlegen, anzeigen, ändern und löschen.

Voraussetzung

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.

Wählen Sie Instance ® Configuration ® Mapchar Sets.

Sie erhalten die bereits verfügbaren Mapchar-Sets angezeigt.

Mapchar-Set anlegen

1. Wählen Sie Actions ® New.

2. Geben Sie folgende Informationen ein:

Name

Name des Mapchar-Set, seine Länge beträgt maximal 18 Bytes

Code Type

Der dem Mapchar-Set zugrundeliegende Code

ASCII | UNICODE

Mapchar

Definieren Sie die Umsetzung der gewünschten Zeichen. Jedes umzusetzende Zeichen von einem Byte (ASCII) bzw. zwei Bytes (UNICODE) ist zunächst in seiner Ursprungsform und dann in seiner Zielform mit einer Maximallänge von zwei Bytes (ASCII) bzw. vier Bytes (UNICODE) anzugeben.

Intern: Ursprungsform in hexadezimalem Format
Extern Hex: Zielform in hexadezimalem Format
Ext. ASCII: Zielform als druckbares Zeichen (für UNICODE nicht möglich)

3. Sichern Sie Ihre Eingaben.

Mapchar-Set ändern

1. Wählen Sie das gewünschte Mapchar-Set aus.

2. Wählen Sie Actions ® Properties.

3. Nehmen Sie die gewünschten Änderungen vor.

4. Sichern Sie Ihre Eingaben.

Mapchar-Set löschen

1. Wählen Sie das gewünschte Mapchar-Set aus.

2. Wählen Sie Actions ® Delete.

3. Bestätigen Sie Ihren Wunsch, das Mapchar-Set zu löschen.


Statistikinformationen aktualisieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Statistikinformationen aktualisieren

Sie können mit dem Database Manager GUI die Statistiken des SQL-Optimierers aktualisieren. Sie können diese Vorgehensweise auch automatisieren.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Statistikinformationen manuell aktualisieren

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz. Wählen Sie Instance ® Tuning ® Optimizer Statistics.

2. Erstellen Sie eine Liste der Tabellen, für die die Statistiken aktualisiert werden sollen:

○ Um alle Tabellen auszuwählen, für die eine Aktualisierung der Statistiken notwendig ist, übernehmen Sie unter Search den Vorschlagswert *.

○ Um bestimmte Tabellen, für die eine Aktualisierung notwendig ist, auszuwählen, geben Sie unter Search entsprechende Suchargumente ein.

Suchargument | Beschreibung
Owner | Eigentümer
Table Name | Tabellenname
Column Name | Spaltenname

○ Um unabhängig von den Tabellen, für die eine Aktualisierung notwendig ist, alle Tabellen auszuwählen, für die eine Aktualisierung der Statistiken durchgeführt werden kann, wählen Sie unter Advanced die Option Select from tables.

3. Wählen Sie Actions ® Search.

Sie erhalten eine Liste der Tabellen, die Ihren Angaben unter Search und Advanced entspricht. Die Spalten Update Statistics Date und Update Statistics Time zeigen, wann für die jeweilige Tabelle die Statistiken letztmalig aktualisiert wurden.

4. Wählen Sie in der Liste der Tabellen diejenigen Tabellen, für die Sie die Statistiken aktualisieren möchten.

5. Für die Aktualisierung der Statistiken gibt es folgende Optionen:

○ Aktualisieren der Statistiken für alle Zeilen der ausgewählten Tabellen (Systemvorschlag)

○ Aktualisieren der Statistiken für eine Stichprobe

Um die Stichprobe zu definieren, geben Sie unter unter Estimate entsprechende Parameter ein.

Parameter | Beschreibung
Use estimate value | legt fest, ob eine Stichprobe verwendet wird
Percent | Prozentsatz der zu prüfenden Zeilen der Tabellen

Die Aussagefähigkeit einer solchen Stichprobe ist von der Größe der Tabellen und der physischen Lage der Daten abhängig. Wir empfehlen für große Tabellen (mehr als 1 Mio Einträge) einen Prozentsatz von 20% für eine Stichprobe.

Um eine Tabelle vom Aktualisieren der Statistiken auszuschließen, wählen Sie als Stichprobengröße für diese Tabelle den Wert 0.

○ Um zusätzlich zu den Tabellenstatistiken auch die Spaltenstatistiken zu aktualisieren, wählen Sie im Bereich Advanced die Option Include update columns for marked tables, doppelklicken Sie auf die gewünschte Tabelle in der Liste und wählen Sie dann die gewünschten Spalten.

6. Wählen Sie Actions ® Execute.

Automatisches Aktualisieren der Statistikinformationen ein-/ausschalten

Sie können beim Anlegen einer Datenbankinstanz das automatische Aktualisieren der Statistikinformationen ein- oder ausschalten. Verfahren Sie dazu wie in Anlegen einer Datenbankinstanz: Custom beschrieben.

Wenn Sie zu einem späteren Zeitpunkt diese Möglichkeit ein- oder ausschalten wollen, verwenden Sie folgende Funktion des Database Manager GUI:

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz. Wählen Sie Instance ® Automatic Statistics Update.

2. Wählen Sie On (Einschalten) bzw. Off (Ausschalten).

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Statistiken des SQL-Optimierers


Demo-Daten laden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Demo-Daten laden

Sie können mit dem Database Manager GUI die vollständigen Demo-Daten laden.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz. Wählen Sie Instance ® Configuration ® Load Tutorial.

2. Bestätigen Sie Ihren Wunsch, die Demo-Daten zu laden.

Ergebnis

In der Datenbankinstanz werden die Demo-Daten neu angelegt. Eventuell bereits vorhandene Demo-Daten werden überschrieben.

Sie können die Demo-Daten direkt beim Anlegen einer Datenbankinstanz laden. Verfahren Sie dazu z.B. wie in Anlegen einer Datenbankinstanz: Desktop PC/Laptop beschrieben.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank, Strukturlink Objekte im Schema HOTEL


Löschen einer Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen einer Datenbankinstanz

Sie können mit dem Database Manager GUI eine Datenbankinstanz löschen.

Dabei können Sie steuern, ob die Datenbankdateien auf dem DBM-Server ebenfalls gelöscht werden sollen oder nicht.

Voraussetzungen

Die Verbindung zum DBM-Server ist aufgebaut.

Die Datenbankinstanz befindet sich im Betriebszustand OFFLINE.

Vorgehensweise

...

1. Markieren Sie die gewünschte Datenbankinstanz in der Liste der Datenbankinstanzen.

2. Wählen Sie Instance ® Drop.

3. Wenn Sie die Datenbankdateien nicht löschen wollen, entfernen Sie die Markierung im Feld Delete database files.

4. Bestätigen Sie, dass Sie die Datenbankinstanz löschen wollen.


Verwalten des Datenbanksystemadministrators (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Verwalten des Datenbanksystemadministrators

Sie können mit dem Database Manager GUI den Datenbanksystemadministrator (SYSDBA-Benutzer) verwalten.

Aktivitäten

Der Datenbanksystemadministrator (SYSDBA-Benutzer) wird beim Anlegen einer neuen Datenbankinstanz erzeugt.

Folgende Verwaltungsaktionen sind mit dem Database Manager GUI möglich:

· Ändern der DBM-Benutzereigenschaften des Datenbanksystemadministrators

· Ändern des Kennworts des Datenbanksystemadministrators

· Ändern der Serverberechtigungen des Datenbanksystemadministrators

· Ändern der SQL-Benutzereigenschaften des Datenbanksystemadministrators

Siehe auch:

· Konzepte des Datenbanksystems, Strukturlink Datenbanksystemadministrator

· Verwalten der Database Manager-Benutzer

· Verwalten von Datenbankbenutzern


Ändern der DBM-Benutzereigenschaften des Datenbanksystemadministrators

Vorgehensweisen Ändern der DBM-Benutzereigenschaften des Datenbanksystemadministrators

Sie können mit dem Database Manager GUI die DBM-Benutzereigenschaften des Datenbanksystemadministrators (SYSDBA-Benutzer) ändern.

Voraussetzungen

Der Benutzer hat die Serverberechtigung Verwalten der DBM-Benutzer (User management).

Wenn das Kennwort des Datenbanksystemadministrators geändert werden soll, muss sich die Datenbankinstanz im Betriebszustand ONLINE befinden.

Vorgehensweise

...

1. Wählen Sie Instance ® Configuration ® DBM Operator... .

2. Markieren Sie den Datenbanksystemadministrator.

3. Wählen Sie Properties.

4. Wählen Sie die Registerkarte General und ändern Sie die gewünschten DBM-Benutzereigenschaften.

DBM-Benutzereigenschaften

General | Beschreibung
Password | Sie können das Kennwort des Datenbanksystemadministrators ändern.
Disabled | Setzen Sie diese Markierung, wenn der Datenbanksystemadministrator gesperrt werden soll.
Enable Pwd | Setzen Sie diese Markierung, wenn für den Datenbanksystemadministrator ein zweites Kennwort angegeben werden soll.

Ergebnis

Der Datenbanksystemadministrator besitzt die von Ihnen festgelegten DBM-Benutzereigenschaften.

Siehe auch:

Ändern des Kennworts des Datenbanksystemadministrators

Verwalten des Datenbanksystemadministrators


Ändern des Kennworts des Datenbanksystemadministrators (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern des Kennworts des Datenbanksystemadministrators

Sie können mit dem Database Manager GUI das Kennwort des Datenbanksystemadministrators (SYSDBA-Benutzer) ändern.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter.

Das Datenbanksystem wandelt Kennwörter automatisch in Großbuchstaben um.

Entscheiden Sie sich für eine der beiden folgenden Vorgehensweisen:

Vorgehensweise 1

...

1. Wählen Sie Instance ® Configuration ® DBM Operator... .

2. Markieren Sie den Datenbanksystemadministrator.

3. Wählen Sie Properties.

4. Wählen Sie die Registerkarte General und anschließend Password Change.

5. Geben Sie das alte und das neue Kennwort ein und sichern Sie Ihre Eingaben.

Vorgehensweise 2

1. Wählen Sie Instance ® Configuration ® Database User... .

2. Geben Sie den Namen und das Kennwort des Datenbanksystemadministrators ein.

3. Markieren Sie den Datenbanksystemadministrator.

4. Wählen Sie Properties.

5. Wählen Sie die Registerkarte General und anschließend Password Change.

6. Geben Sie das alte und das neue Kennwort ein und sichern Sie Ihre Eingaben.

Ergebnis

Das Kennwort des Datenbanksystemadministrators wurde geändert.

Siehe auch:

Verwalten des Datenbanksystemadministrators


Ändern der Serverberechtigungen des Datenbanksystemadministrators

Vorgehensweisen Ändern der Serverberechtigungen des Datenbanksystemadministrators

Sie können mit dem Database Manager GUI die Serverberechtigungen des Datenbanksystemadministrators (SYSDBA-Benutzer) ändern.

Voraussetzungen

Der Benutzer hat die Serverberechtigung Verwalten der DBM-Benutzer (User management).

Vorgehensweise

...

1. Wählen Sie Instance ® Configuration ® DBM Operator... .

2. Markieren Sie den Datenbanksystemadministrator.

3. Wählen Sie Properties.

4. Auf der Registerkarte Server Rights haben Sie nun die Möglichkeit, die Serverberechtigung des gewählten Benutzers zu erweitern oder zu reduzieren, indem Sie die gewünschten Berechtigungen markieren oder entmarkieren.

Ergebnis

Die Serverberechtigungen des Datenbanksystemadministrators sind Ihren Wünschen entsprechend eingestellt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Serverberechtigungen für den DBM-Server

Verwalten des Datenbanksystemadministrators


Ändern der SQL-Benutzereigenschaften des Datenbanksystemadministrators

Vorgehensweisen Ändern der SQL-Benutzereigenschaften des Datenbanksystemadministrators

Sie können mit dem Database Manager GUI die SQL-Benutzereigenschaften des Datenbanksystemadministrators ändern.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Wählen Sie Instance ® Configuration ® Database User... .

2. Geben Sie den Namen und das Kennwort des Datenbanksystemadministrators ein.

3. Markieren Sie den Datenbanksystemadministrator.

4. Wählen Sie Properties.

5. Wählen Sie die Registerkarte General und ändern Sie die gewünschten SQL-Benutzereigenschaften.

SQL-Benutzereigenschaften

General | Beschreibung
Password Change | Sie können das Kennwort des Datenbanksystemadministrators ändern.
Connection Mode | Sie können folgende Verbindungsarten einstellen: ● der Datenbankbenutzer kann mehrere Datenbanksitzungen gleichzeitig öffnen (NOT EXCLUSIVE) ● der Datenbankbenutzer kann nur jeweils eine Datenbanksitzung öffnen (EXCLUSIVE) ● der Datenbankbenutzer darf keine Datenbanksitzung öffnen (DISABLED)

6. Wählen Sie die Registerkarte Extended und ändern Sie die gewünschten SQL-Benutzereigenschaften.

SQL-Benutzereigenschaften

Extended | Beschreibung
Timeout | Sie können den Timeout-Wert einstellen.
Cost Warning | Sie können den SELECT-Kosten-Schätzwert einstellen, ab dem eine Warnung ausgegeben werden soll.
Cost Limit | Sie können den SELECT-Kosten-Schätzwert einstellen, ab dem eine SQL-Anweisung nicht ausgeführt wird.
Default Code | Sie können einen Vorschlagswert für das Codeattribut einstellen.

Ergebnis

Der Datenbanksystemadministrator besitzt die von Ihnen festgelegten SQL-Benutzereigenschaften.

Siehe auch:

Ändern des Kennworts des Datenbanksystemadministrators

Verwalten des Datenbanksystemadministrators


Verwalten der Database Manager-Benutzer (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Verwalten der Database Manager-Benutzer

Sie können mit dem Database Manager GUI Database Manager-Benutzer (DBM-Benutzer) verwalten.

Aktivitäten

Ein Database Manager-Benutzer mit allen Serverberechtigungen wird beim Anlegen einer neuen Datenbankinstanz erzeugt. Sie können weitere Database Manager-Benutzer anlegen und diese mit den gewünschten Serverberechtigungen ausstatten.

Folgende Verwaltungsaktionen für die Database Manager-Benutzer sind mit dem Database Manager GUI möglich:

· Anlegen/Ändern/Löschen eines Database Manager-Benutzers

· Ändern der DBM-Benutzereigenschaften

· Ändern des Kennworts eines Database Manager-Benutzers

· Ändern der Serverberechtigungen

Siehe auch:

· Konzepte des Datenbanksystems, Strukturlink Database Manager-Benutzer (DBM-Benutzer)

· Verwalten des Datenbanksystemadministrators

· Verwalten von Datenbankbenutzern


Anlegen/Ändern/Löschen eines Database Manager-Benutzers (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen/Ändern/Löschen eines Database Manager-Benutzers

Sie können mit dem Database Manager GUI einen Database Manager-Benutzer (DBM-Benutzer) anlegen, seine Eigenschaften und Serverberechtigungen ändern oder den Database Manager-Benutzer löschen.

Voraussetzungen

Der Benutzer hat die Serverberechtigung Verwalten der DBM-Benutzer (User management).

Anlegen eines Database Manager-Benutzers

...

1. Wählen Sie Instance ® Configuration ® DBM Operator... .

2. Wählen Sie New User.

3. Wählen Sie die Registerkarte General und geben Sie die gewünschten DBM-Benutzereigenschaften an.

DBM-Benutzereigenschaften

General | Beschreibung
Name | Geben Sie den Namen des neuen Database Manager-Benutzers an.
Password | Geben Sie ein Kennwort für diesen Database Manager-Benutzer an.
Confirm Password | Bestätigen Sie das Kennwort.
Comment | Sie können eine Beschreibung des Benutzers eingeben.
Disabled | Setzen Sie diese Markierung, wenn der Database Manager-Benutzer gesperrt werden soll.
Enable Pwd | Setzen Sie diese Markierung, wenn für den Database Manager-Benutzer ein zweites Kennwort angegeben werden soll.

Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter. Das Datenbanksystem wandelt Benutzernamen und Kennwörter automatisch in Großbuchstaben um.

4. Wählen Sie die Registerkarte Server Rights.
Markieren Sie die gewünschten Strukturlink Serverberechtigungen für den DBM-Server.

Ändern eines Database Manager-Benutzers

Sie können die DBM-Benutzereigenschaften und Serverberechtigungen eines Database Manager-Benutzers ändern.

Verfahren Sie zum Ändern der DBM-Benutzereigenschaften und Serverberechtigungen wie in folgenden Abschnitten beschrieben:

● Ändern der DBM-Benutzereigenschaften

● Ändern des Kennworts eines Database Manager-Benutzers

● Ändern der Serverberechtigungen

Löschen eines Database Manager-Benutzers

Sie können einen Database Manager-Benutzer löschen. Ausgenommen davon ist der Database Manager-Benutzer (DBM-Benutzer), der beim Anlegen einer Datenbankinstanz erzeugt wurde.

1. Wählen Sie Instance ® Configuration ® DBM Operator... .

2. Markieren Sie den gewünschten Database Manager-Benutzer.

3. Wählen Sie Delete.

Siehe auch:

Verwalten der Database Manager-Benutzer

Konzepte des Datenbanksystems, Strukturlink Database Manager-Benutzer (DBM-Benutzer)


Ändern der DBM-Benutzereigenschaften (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern der DBM-Benutzereigenschaften

Sie können mit dem Database Manager GUI die DBM-Benutzereigenschaften der Database Manager-Benutzer (DBM-Benutzer) ändern.

Voraussetzungen

Der Benutzer hat die Serverberechtigung Verwalten der DBM-Benutzer (User management).

Vorgehensweise

...

1. Wählen Sie Instance ® Configuration ® DBM Operator... .

2. Markieren Sie den gewünschten Database Manager-Benutzer.

3. Wählen Sie Properties.

4. Wählen Sie die Registerkarte General und ändern Sie die gewünschten DBM-Benutzereigenschaften.

DBM-Benutzereigenschaften

General | Beschreibung
Password | Sie können das Kennwort des Database Manager-Benutzers ändern.
Comment | Sie können die Beschreibung des Database Manager-Benutzers ändern.
Disabled | Setzen Sie diese Markierung, wenn der Database Manager-Benutzer gesperrt werden soll.
Enable Pwd | Setzen Sie diese Markierung, wenn für den Database Manager-Benutzer ein zweites Kennwort angegeben werden soll.

Ergebnis

Der Database Manager-Benutzer besitzt die von Ihnen festgelegten DBM-Benutzereigenschaften.

Siehe auch:

Ändern des Kennworts eines Database Manager-Benutzers

Verwalten der Database Manager-Benutzer


Ändern des Kennworts eines Database Manager-Benutzers (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern des Kennworts eines Database Manager-Benutzers

Sie können mit dem Database Manager GUI die Kennwörter der Database Manager-Benutzer (DBM-Benutzer) ändern.

Voraussetzungen

Der Benutzer hat die Serverberechtigung Verwalten der DBM-Benutzer (User management).

Vorgehensweise

...

1. Wählen Sie Instance ® Configuration ® DBM Operator... .

2. Markieren Sie den gewünschten Database Manager-Benutzer.

3. Wählen Sie Properties.

4. Wählen Sie die Registerkarte General und anschließend Password Change.

5. Geben Sie das alte und das neue Kennwort ein und sichern Sie Ihre Eingaben.

Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter. Das Datenbanksystem wandelt Kennwörter automatisch in Großbuchstaben um.

Ergebnis

Das Kennwort des Database Manager-Benutzers wurde geändert.

Siehe auch:

Verwalten der Database Manager-Benutzer


Ändern der Serverberechtigungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern der Serverberechtigungen

Sie können mit dem Database Manager GUI die Serverberechtigungen von Database Manager-Benutzern (DBM-Benutzern) ändern.

Voraussetzungen

Der Benutzer hat die Serverberechtigung Verwalten der DBM-Benutzer (User management).

Vorgehensweise

1. Wählen Sie Instance ® Configuration ® DBM Operator... .

2. Markieren Sie den gewünschten Database Manager-Benutzer.

3. Wählen Sie Properties.

4. Auf der Registerkarte Server Rights haben Sie nun die Möglichkeit, die Serverberechtigung des gewählten Benutzers zu erweitern oder zu reduzieren, indem Sie die gewünschten Berechtigungen markieren oder entmarkieren.

Ergebnis

Die Serverberechtigungen des Database Manager-Benutzers sind Ihren Wünschen entsprechend eingestellt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Serverberechtigungen für den DBM-Server

Verwalten der Database Manager-Benutzer


Verwalten von Datenbankbenutzern (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Verwalten von Datenbankbenutzern

Sie können mit dem Database Manager GUI Datenbankbenutzer verwalten.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Aktivitäten

Sie können mit dem Database Manager GUI folgende Verwaltungsaktionen für die Datenbankbenutzer durchführen:

● Anlegen/Ändern/Löschen eines Datenbankbenutzers

● Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers

● Ändern des Kennworts eines Datenbankbenutzers

● Anlegen/Ändern/Löschen des Synchronisationsbenutzers

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankbenutzer

Verwalten des Datenbanksystemadministrators

Verwalten der Database Manager-Benutzer


Anlegen/Ändern/Löschen eines Datenbankbenutzers (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen/Ändern/Löschen eines Datenbankbenutzers

Sie können mit dem Database Manager GUI einen Datenbankbenutzer anlegen, die SQL-Benutzereigenschaften eines Datenbankbenutzers ändern oder einen Datenbankbenutzer löschen.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Anlegen eines Datenbankbenutzers

...

1. Wählen Sie Instance ® Configuration ® Database User... .

2. Geben Sie Namen und Kennwort eines Datenbankbenutzers der Datenbankbenutzerklasse DBA, also einen Datenbankadministrator (DBA-Benutzer) an.
Um einen Datenbankadministrator (DBA-Benutzer) anzulegen, müssen Sie den Namen und das Kennwort des Datenbanksystemadministrators (SYSDBA-Benutzer) angeben.
Um einen Datenbankbenutzer der Klasse STANDARD oder RESOURCE anzulegen, können Sie den Namen und das Kennwort des Datenbanksystemadministrators (SYSDBA-Benutzer) oder eines Datenbankadministrators (DBA-Benutzer) angeben.

3. Wählen Sie New User.

4. Wählen Sie die Registerkarte General und geben Sie die gewünschten SQL-Benutzereigenschaften ein.

SQL-Benutzereigenschaften

General | Beschreibung
Name | Geben Sie den Namen des neuen Datenbankbenutzers ein.
Password | Geben Sie das Kennwort des neuen Datenbankbenutzers ein.
Confirm Password | Bestätigen Sie das Kennwort des Datenbankbenutzers.
User Class | Wählen Sie die Datenbankbenutzerklasse (DBA | STANDARD | RESOURCE).
Connection Mode | Sie können folgende Verbindungsarten einstellen: ● der Datenbankbenutzer kann mehrere Datenbanksitzungen gleichzeitig öffnen (NOT EXCLUSIVE) ● der Datenbankbenutzer kann nur jeweils eine Datenbanksitzung öffnen (EXCLUSIVE) ● der Datenbankbenutzer darf keine Datenbanksitzung öffnen (DISABLED)

5. Wählen Sie die Registerkarte Extended und geben Sie die gewünschten SQL-Benutzereigenschaften ein.

SQL-Benutzereigenschaften

Extended | Beschreibung
Timeout | Sie können den Timeout-Wert einstellen.
Cost Warning | Sie können den SELECT-Kosten-Schätzwert einstellen, ab dem eine Warnung ausgegeben werden soll.
Cost Limit | Sie können den SELECT-Kosten-Schätzwert einstellen, ab dem eine SQL-Anweisung nicht ausgeführt wird.
Default Code | Sie können einen Vorschlagswert für das Codeattribut einstellen.
Replication User | zeigt an, ob der Datenbankbenutzer der Synchronisierungsbenutzer ist Siehe Anlegen/Ändern/Löschen des Synchronisationsbenutzers

Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter.

Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers

Sie können die SQL-Benutzereigenschaften eines Datenbankbenutzers ändern. Verfahren Sie dazu wie in folgenden Abschnitten beschrieben:

● Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers

● Ändern des Kennworts eines Datenbankbenutzers

Löschen eines Datenbankbenutzers

Sie können Datenbankbenutzer löschen.

...

1. Wählen Sie Instance ® Configuration ® Database User... .

2. Markieren Sie den gewünschten Datenbankbenutzer.

3. Wählen Sie Delete.

Wählen Sie eine der folgenden Optionen:

○ Default: Mit dem Datenbankbenutzer wird zusätzlich Folgendes gelöscht: alle Synonyme und Tabellen dieses Datenbankbenutzers sowie alle Indizes, Privilegien, View-Tabellen, usw., die auf diesen Synonymen und Tabellen basieren.

○ Restrict: Der Datenbankbenutzer wird nur dann gelöscht, wenn ihm keine Synonyme oder Tabellen gehören.

Siehe auch:

Verwalten von Datenbankbenutzern

Konzepte des Datenbanksystems, Strukturlink Datenbankbenutzer


Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers

Sie können mit dem Database Manager GUI die SQL-Benutzereigenschaften eines Datenbankbenutzers ändern.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Wählen Sie Instance ® Configuration ® Database User... .

2. Geben Sie den Namen und das Kennwort des Datenbankadministrators ein, der der Eigentümer des Datenbankbenutzers ist, dessen SQL-Benutzereigenschaften geändert werden sollen.

3. Markieren Sie den gewünschten Datenbankbenutzer.

4. Wählen Sie Properties.

5. Wählen Sie die Registerkarte General und ändern Sie die gewünschten SQL-Benutzereigenschaften.

SQL-Benutzereigenschaften

General | Beschreibung
Password Change | Sie können das Kennwort des Datenbankbenutzers ändern.
User class | Sie können die Datenbankbenutzerklasse ändern (DBA | RESOURCE | STANDARD).
Connection Mode | Sie können folgende Verbindungsarten einstellen: ● der Datenbankbenutzer kann mehrere Datenbanksitzungen gleichzeitig öffnen (NOT EXCLUSIVE) ● der Datenbankbenutzer kann nur jeweils eine Datenbanksitzung öffnen (EXCLUSIVE) ● der Datenbankbenutzer darf keine Datenbanksitzung öffnen (DISABLED)

6. Wählen Sie die Registerkarte Extended und ändern Sie die gewünschten SQL-Benutzereigenschaften.

SQL-Benutzereigenschaften

Extended | Beschreibung
Timeout | Sie können den Timeout-Wert einstellen
Cost Warning | Sie können den SELECT-Kosten-Schätzwert einstellen, ab dem eine Warnung ausgegeben werden soll.
Cost Limit | Sie können den SELECT-Kosten-Schätzwert einstellen, ab dem eine SQL-Anweisung nicht ausgeführt wird.
Default Code | Sie können einen Vorschlagswert für das Codeattribut einstellen.
Replication User | zeigt an, ob der Datenbankbenutzer der Synchronisationsbenutzer ist Es kann pro Datenbankinstanz nur einen Synchronisationsbenutzer geben (Anlegen/Ändern/Löschen des Synchronisationsbenutzers).

Ergebnis

Der Datenbankbenutzer besitzt die von Ihnen festgelegten SQL-Benutzereigenschaften.

Siehe auch:

Ändern des Kennworts eines Datenbankbenutzers

Verwalten von Datenbankbenutzern


Ändern des Kennworts eines Datenbankbenutzers (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern des Kennworts eines Datenbankbenutzers

Sie können mit dem Database Manager GUI das Kennwort eines Datenbankbenutzers ändern.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Wählen Sie Instance ® Configuration ® Database User... .

2. Geben Sie den Namen und das Kennwort des Datenbankadministrators ein, der der Eigentümer des Datenbankbenutzers ist, dessen Kennwort geändert werden soll.

3. Markieren Sie den gewünschten Datenbankbenutzer.

4. Wählen Sie Properties.

5. Wählen Sie die Registerkarte General und anschließend Password Change .

6. Geben Sie das alte und das neue Kennwort ein und sichern Sie Ihre Eingaben.

Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter.

Ergebnis

Das Kennwort des Datenbankbenutzers wurde geändert.

Siehe auch:

Verwalten von Datenbankbenutzern


Anlegen/Ändern/Löschen des Synchronisationsbenutzers (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen/Ändern/Löschen des Synchronisationsbenutzers

Sie können mit dem Database Manager GUI den Synchronisationsbenutzer anlegen, die SQL-Benutzereigenschaften des Synchronisationsbenutzers ändern oder diesen Benutzer löschen.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Synchronisationsbenutzer löschen

...

1. Wählen Sie Instance ® Configuration ® Database User... .

2. Geben Sie Namen und Kennwort des Datenbanksystemadministrators (SYSDBA-Benutzer) an.

3. Wählen Sie New User.

4. Wählen Sie die Registerkarte General und geben Sie folgende SQL-Benutzereigenschaften ein.

SQL-Benutzereigenschaften

General | Beschreibung
Name | Geben Sie den Namen des Synchronisationsbenutzers ein.
Password | Geben Sie das Kennwort des Synchronisationsbenutzers ein.
Confirm Password | Bestätigen Sie das Kennwort des Synchronisationsbenutzers.
User Class | Wählen Sie die Datenbankbenutzerklasse DBA.
Connection Mode | Stellen Sie die Verbindungsart NOT EXCLUSIVE (der Synchronisationsbenutzer kann mehrere Datenbanksitzungen gleichzeitig öffnen) ein.

5. Wählen Sie die Registerkarte Extended und markieren Sie die SQL-Benutzereigenschaft Replication User.
Eine Beschreibung der weiteren SQL-Benutzereigenschaften finden Sie im Abschnitt Anlegen/Ändern/Löschen eines Datenbankbenutzers.

Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter. Es kann immer nur einen Synchronisationsbenutzer geben.

Synchronisationsbenutzer ändern/löschen

Folgende SQL-Benutzereigenschaften des Synchronisationsbenutzers dürfen Sie nicht ändern:

● User Class

● Connection Mode

● Replication User

Um andere SQL-Benutzereigenschaften des Synchronisationsbenutzers zu ändern oder den Synchronisationsbenutzer zu löschen, gehen Sie vor wie im Abschnitt Anlegen/Ändern/Löschen eines Datenbankbenutzers beschrieben.

Siehe auch:

Dokumentation zum Programm Synchronization Manager

Konzepte des Datenbanksystems, Strukturlink Datenbankbenutzer


Sichern (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Sichern

Verwendung

Sie können mit dem Database Manager GUI die Datenbankinstanz sichern. Die Datenbankinstanz kann sich auf dem lokalen Rechner oder auf einem entfernten Rechner befinden.

Sie können Daten aus dem Datenbereich und Log-Einträge aus dem Log-Bereich auf Datenträger sichern.

Um Sicherungen im Hintergrund durchzuführen, verwenden Sie den Database Manager CLI (siehe Database Manager CLI, Sichern und Wiederherstellen von Datenbankinstanzen).

Wir empfehlen, einen Plan für Strukturlink regelmäßige Verwaltungsaufgaben zu erstellen.

Aktivitäten

Für folgende Aktivitäten können Sie den Database Manager GUI bzw. den Backup Wizard verwenden:

● Sicherungsvorlagen verwalten

● Sicherungen durchführen (siehe Sicherungsverfahren)

● Sicherung prüfen

● Sicherungshistorie anzeigen

Für SAP-Anwendungen können Sie den DBA-Einplanungskalender des Solution Lifecycle Management Systems (CCMS) verwenden, um die Sicherungsfunktionalität des Database Manager und die Verwaltung der Sicherungsvorlagen einzuplanen und zu automatisieren. Weitere Informationen dazu finden Sie in der Dokumentation Datenbankverwaltung im CCMS, Strukturlink DBA-Einplanungskalender.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen


Backup Wizard (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Backup Wizard

Zum Sichern einer Datenbankinstanz können Sie den Backup Wizard verwenden, der Sie durch den gesamten Vorgang leitet.

Vorgehensweise

Wählen Sie im Database Manager GUI Instance ® Backup ® Backup Wizard.

Starten Sie die gewünschten Sicherungsschritte jeweils mit Next.

1. Sie können Daten einer Datenbankinstanz lokal oder auf einem entfernten Rechner sichern.
Wählen Sie die gewünschte Datenbankinstanz aus oder geben Sie direkt folgende Angaben ein:
Database Server: Name des Rechners, auf dem sich die Datenbankinstanz befindet
Database Name: Datenbankname
User Name: Name des Database Manager-Benutzers (DBM-Benutzer)
Password: Kennwort des Database Manager-Benutzers

2. Falls notwendig, überführen Sie die Datenbankinstanz in den gewünschten Betriebszustand.

3. Wählen Sie die gewünschte Sicherungsart:
Complete Data Backup: Vollständige Datensicherung
Incremental Data Backup: Inkrementelle Datensicherung
Log Backup: Log-Sicherung
Activate/deactivate automatic log backup: Automatische Log-Sicherung aktivieren/deaktivieren
Berücksichtigen Sie die Hinweise zu den bereits durchgeführten Sicherungen, die im Backup Wizard angezeigt werden.

4. Wählen Sie eine Sicherungsvorlage aus.
Wenn noch keine Sicherungsvorlage vorhanden ist, können Sie diese anlegen (siehe Verwalten der Sicherungsvorlagen).

5. Starten Sie das gewünschte Sicherungsverfahren.

6. Schließen Sie den Backup Wizard.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen


Verwalten der Sicherungsvorlagen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Verwalten der Sicherungsvorlagen

Verwendung

Bevor Sie Daten und Log-Einträge sichern können, müssen Sie Sicherungsvorlagen definieren. Sicherungsvorlagen können Sie interaktiv mit dem Database Manager GUI oder dem Backup Wizard anlegen und verwalten.

Funktionsumfang

● Sicherungsvorlage für einen einzelnen Datenträger

● Sicherungsvorlage für eine Gruppe paralleler Datenträger

● Ändern von Sicherungsvorlagen

● Löschen von Sicherungsvorlagen

● Sicherung prüfen

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sicherungsvorlagen und Datenträger


Sicherungsvorlage für einen einzelnen Datenträger (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sicherungsvorlage für einen einzelnen Datenträger

Sie können mit dem Database Manager GUI auf einen einzelnen Datenträger sichern. Sie legen dafür eine Sicherungsvorlage für einen einzelnen Datenträger an und verwenden diese beim Sichern.

Voraussetzungen

Die Verbindung der Datenbankinstanz zum DBM-Server ist hergestellt.

Vorgehensweise

Wählen Sie eine der folgenden beiden Vorgehensweisen:

● Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz

Wählen Sie Instance ® Backup ® Backup Medium.

Wählen Sie Actions ® New Medium.

● Backup Wizard
Wählen Sie im Fenster Media for Backup die Funktion New Medium.

...

General

Wählen Sie General und geben Sie folgende Informationen ein:

Name

Name des Datenträgers

Backup Type

Wählen Sie die gewünschte Sicherungsart aus:

Complete Data: Vollständige Datensicherung

Incremental Data: Inkrementelle Datensicherung

Log Backup: Log-Sicherung

Device Type

Wählen Sie den Typ des Datenträgers aus:

File: Datei
Wenn Sie für Log-Sicherungen den Typ File wählen, dann schreibt der Database Manager die Log-Sicherungen in Sicherungsdateien.

Tape: Band
Log-Sicherungen auf Band sind nicht möglich.

Pipe: Pipe
Wenn Sie mit Hilfe eines Sicherungswerkzeugs anderer Anbieter sichern werden, wählen Sie den Typ Pipe.

Backup Tool

Wenn Sie ein Sicherungswerkzeug eines anderen Anbieters verwenden, dann wählen Sie hier die Abkürzung für dieses Sicherungswerkzeug aus.

BACK: Backint for Oracle/Backint for MaxDB

NSR: Networker

TSM: TSM

Device/File

Name des Datenträgers, mit dem er über Betriebssystemfunktionen angesprochen werden kann

Die Versionierung von Log-Sicherungen mit dem Typ File wird vom System vorgenommen.

Extended

Wählen Sie Extended und geben Sie folgende Informationen ein:

Size | Größe des Datenträgers
Overwrite | Markieren Sie Overwrite, wenn Sie den Überschreibemodus für den Datenträger nutzen wollen.
Block Size | Markieren Sie Blocksize, wenn Sie in Blöcken zu 8 Seiten sichern wollen.
Autoloader | Markieren Sie Autoloader, wenn Sie eine Bandstation mit automatischem Bandwechsel verwenden wollen.
OS Command | Sie können Betriebssystemkommandos angeben, die beim Sichern auf Band möglich sind.

Ergebnis

Die von Ihnen definierten Sicherungsvorlagen können Sie nun zum Sichern einsetzen. Ein in einer Sicherungsvorlage definierter Datenträger kann auch als Folgedatenträger verwendet werden.

Sichern auf einen einzelnen Datenträger, Sichern mit manuellem Datenträgerwechsel (Folgedatenträger), Sichern mit automatischem Bandwechsler, Sichern mit Sicherungswerkzeugen anderer Anbieter

Siehe auch:

Verwalten der Sicherungsvorlagen

Konzepte des Datenbanksystems,

● Strukturlink Sichern und Wiederherstellen

● Strukturlink Sicherungsvorlagen und Datenträger

● Strukturlink Sicherungswerkzeuge anderer Anbieter verwenden


Sicherungsvorlage für eine Gruppe paralleler Datenträger (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sicherungsvorlage für eine Gruppe paralleler Datenträger

Um eine höhere Geschwindigkeit beim Sichern zu erreichen, können Sie mit dem Database Manager GUI auf mehrere Datenträger parallel sichern. Sie legen dafür eine Sicherungsvorlage für eine Gruppe paralleler Datenträger an und verwenden diese beim Sichern. Beim Wiederherstellen können Sie die Daten aus einer solchen Sicherung auch wieder parallel einlesen.

Voraussetzungen

Die Verbindung der Datenbankinstanz zum DBM-Server ist hergestellt.

Vorgehensweise

Wählen Sie eine der folgenden beiden Vorgehensweisen:

● Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.

Wählen Sie Instance ® Backup ® Backup Medium.

Wählen Sie Actions ® New Parallel Medium.

● Backup Wizard
Im Fenster Media for Backup wählen Sie New Parallel Medium.

General

Wählen Sie General und geben Sie folgende Informationen ein:

Name | Name für die Sicherungsvorlage einer Gruppe paralleler Datenträger
Backup Type | Wählen Sie die gewünschte Sicherungsart aus: Complete Data Backup: Vollständige Datensicherung Incremental Data Backup: Inkrementelle Datensicherung
Device Type | Wählen Sie den Typ des Datenträgers aus: File: Datei Tape: Band Pipe: Pipe Wenn Sie mit Hilfe eines Sicherungswerkzeugs anderer Anbieter sichern werden, wählen Sie Pipe.
Backup Tool | Wenn Sie ein Sicherungswerkzeug anderer Anbieter verwenden, dann wählen Sie hier die Abkürzung für das externe Sicherungswerkzeug aus. BACK: Backint for Oracle/Backint for MaxDB NSR: Networker TSM: TSM
Name und Device/File | Name und Pfadangaben der Datenträger, die in der Gruppe paralleler Datenträger enthalten sein sollen. Ändern oder ergänzen Sie die Vorschlagswerte, um anzugeben, wohin gesichert werden soll.

Extended

Wählen Sie Extended und geben Sie folgende Informationen ein:

Unit | Maßeinheit für die Angabe der Größen der Datenträger
Overwrite | Markieren Sie Overwrite, wenn Sie den Überschreibemodus für die Datenträger nutzen wollen.
Block Size | Markieren Sie Blocksize, wenn Sie in Blöcken zu 8 Seiten sichern wollen.
Autoloader | Markieren Sie Autoloader, wenn Sie eine Bandstation mit automatischem Bandwechsel verwenden wollen.
Name/Size/OS Command | Für jeden Datenträger der Gruppe können Sie die Größe angeben. Sie können Betriebssystemkommandos angeben, die beim Sichern auf Band möglich sind.

Ergebnis

Die von Ihnen definierte Sicherungsvorlage für parallele Datenträger können Sie nun zum Sichern einsetzen. Die in einer Sicherungsvorlage zusammengefassten Datenträger können auch als Folgedatenträger verwendet werden.

Sichern auf eine Gruppe paralleler Datenträger, Sichern mit manuellem Datenträgerwechsel (Folgedatenträger), Sichern mit automatischem Bandwechsler, Sichern mit Sicherungswerkzeugen anderer Anbieter

Siehe auch:

Verwalten der Sicherungsvorlagen

Konzepte des Datenbanksystems,

● Strukturlink Sichern und Wiederherstellen

● Strukturlink Sicherungsvorlagen und Datenträger

● Strukturlink Sicherungswerkzeuge anderer Anbieter verwenden

...


Ändern von Sicherungsvorlagen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern von Sicherungsvorlagen

Sie können eine Sicherungsvorlage ändern. Danach steht die geänderte Sicherungsvorlage im Database Manager zum Sichern und Wiederherstellen zur Verfügung.

Vorgehensweise

● Database Manager GUI
Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Wählen Sie Instance ® Backup ® Backup Medium.
Wählen Sie die gewünschte Sicherungsvorlage aus.

● Backup Wizard
Im Fenster Media for Backup wählen Sie die gewünschte Sicherungsvorlage aus.

...

Namen der Sicherungsvorlage ändern

1. Wählen Sie Action ® Rename und führen Sie die Änderungen durch.

2. Wählen Sie die Eingabetaste, um Ihre Änderung zu sichern.

Eigenschaften der Sicherungsvorlage ändern

1. Wählen Sie Action ® Properties und führen Sie die Änderungen durch.

2. Informationen zu den Eigenschaften, die in General und Extended geändert werden können, finden Sie in Sicherungsvorlage für einen einzelnen Datenträger und Sicherungsvorlage für eine Gruppe paralleler Datenträger.

Wählen Sie Label, wenn Sie die Sicherungskennung anzeigen lassen wollen.

Siehe auch:

Verwalten der Sicherungsvorlagen

Konzepte des Datenbanksystems, Strukturlink Sicherungsvorlagen und Datenträger


Löschen von Sicherungsvorlagen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen von Sicherungsvorlagen

Sie können eine Sicherungsvorlage löschen. Danach steht der in der Sicherungsvorlage festgelegte Datenträger im Database Manager nicht mehr zum Sichern und Wiederherstellen zur Verfügung.

Vorgehensweise

● Database Manager GUI
Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Wählen Sie Instance ® Backup ® Backup Medium.
Wählen Sie die gewünschte Sicherungsvorlage aus.

● Backup Wizard
Im Fenster Media for Backup wählen Sie die gewünschte Sicherungsvorlage aus.

Wählen Sie Action ® Delete bzw. Delete, um die Sicherungsvorlage zu löschen.

Siehe auch:

Verwalten der Sicherungsvorlagen

Konzepte des Datenbanksystems, Strukturlink Sicherungsvorlagen und Datenträger


Sicherungsverfahren (SAP-Bibliothek - Werkzeuge)

Prozessdokumentation Sicherungsverfahren

Das Sichern von Daten oder Log-Einträgen können Sie interaktiv mit dem Database Manager GUI bzw. dem Backup Wizard durchführen. In Abhängigkeit von den technischen Voraussetzungen sind folgende Sicherungsverfahren möglich:

● Sichern auf einen einzelnen Datenträger

● Sichern auf eine Gruppe paralleler Datenträger

Wenn die Kapazität des gewählten Datenträgers/der Datenträger für die Gesamtmenge der zu sichernden Daten bzw. Log-Einträge ausreicht, ist kein Eingriff eines Datenbankadministrators während des Sicherungsvorganges nötig.

Wenn die Kapazität des gewählten Datenträgers/der Datenträger nicht ausreicht, müssen Folgedatenträger verwendet werden, d. h. dass ein Datenträger, wenn er voll ist, automatisch oder manuell durch einen leeren Datenträger ersetzt werden muss:

● Sichern mit automatischen Bandwechsler

● Sichern mit manuellem Datenträgerwechsel (Folgedatenträger)

Der Backup Wizard fordert weitere Datenträger an, wenn ein Datenträger vollständig beschrieben wurde, die Sicherung aber noch nicht beendet ist. Dafür muss die Datenträgergröße beim Anlegen der Sicherungsvorlage definiert worden sein bzw. die Bandstation das Bandende als solches erkennen.

Sie haben auch die Möglichkeit, Sicherungswerkzeuge anderer Anbieter zu verwenden:

● Sichern mit Sicherungswerkzeugen anderer Anbieter

Für das Sichern der Log-Einträge steht Ihnen die automatische Log-Sicherung zur Verfügung:

● Ein- und Ausschalten der automatischen Log-Sicherung

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen


Sichern auf einen einzelnen Datenträger (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sichern auf einen einzelnen Datenträger

Sie können mit dem Database Manager GUI Daten oder Log-Einträge auf einen einzelnen Datenträger sichern.

Wenn möglich, bevorzugen Sie für Datensicherungen immer das Sichern auf eine Gruppe paralleler Datenträger gegenüber der Sicherung auf einen einzelnen Datenträger mit Folgedatenträger. Für Log-Sicherungen sind keine parallelen Sicherungen möglich.

Wir empfehlen, vor jeder vollständigen Datensicherung die Datenbankstrukturen zu prüfen.

Voraussetzungen

Es steht nur ein Sicherungsgerät zur Verfügung. Sie haben eine Sicherungsvorlage für einen einzelnen Datenträger angelegt.

Wenn Sie mit Hilfe eines automatischen Bandwechslers (Sichern mit automatischem Bandwechsler) oder mit Hilfe von Sicherungswerkzeugen anderer Anbieter (Sichern mit Sicherungswerkzeugen anderer Anbieter) sichern wollen, müssen Sie dies bereits beim Anlegen des Sicherungsvorlage explizit angeben.

Im Normalfall sollten Sie Datenbankinstanzen im Betriebszustand ONLINE sichern.

Das Sichern ist im Notfall auch im Betriebszustand ADMIN möglich.

Vorgehensweise

Verwenden Sie den Backup Wizard.

1. Falls noch keine Sicherungsvorlage angelegt wurde, müssen Sie dies tun wie in Sicherungsvorlage für einen einzelnen Datenträger beschrieben.
Im Fenster Media for Backup wählen Sie die gewünschte Sicherungsvorlage aus.

2. Überprüfen Sie die Angaben. Ändern Sie diese erforderlichenfalls (Ändern von Sicherungsvorlagen).

3. Starten Sie die Sicherung bzw. schalten Sie die automatische Log-Sicherung ein.
Falls die Kapazität des angegebenen Datenträgers für die Sicherung nicht ausreicht und Sie keinen automatischen Bandwechsler verwenden, fordert Sie der Backup Wizard auf, einen neuen Datenträger anzugeben und einzulegen, sobald der vorhergehende Datenträger voll beschrieben ist (Sichern mit manuellem Datenträgerwechsel (Folgedatenträger)).

Ergebnis

Überprüfen Sie das Ergebnis Ihrer Daten- oder Log-Sicherung anhand der Sicherungshistorie.

Siehe auch:

Sicherungsverfahren


Sichern auf eine Gruppe paralleler Datenträger (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sichern auf eine Gruppe paralleler Datenträger

Sie können mit dem Database Manager GUI Daten auf eine Gruppe paralleler Datenträger sichern. Auf diese Weise maximieren Sie den Datendurchsatz. Sie können bis zu 32 Bandgeräte parallel verwenden.

Wenn möglich, bevorzugen Sie für eine Datensicherung immer das Sichern auf eine Gruppe paralleler Datenträger gegenüber der Sichern auf einen einzelnen Datenträger mit Folgedatenträger. Für Log-Sicherungen sind keine parallelen Sicherungen möglich.

Wir empfehlen, vor jeder vollständigen Datensicherung die Datenbankstrukturen zu prüfen.

Voraussetzung

Es stehen mehrere Sicherungsgeräte zur Verfügung. Sie haben die gewünschten Sicherungsvorlagen angelegt.

Wenn Sie mit Hilfe eines automatischen Bandwechslers (Sichern mit automatischem Bandwechsler) oder mit Hilfe von Sicherungswerkzeugen anderer Anbieter (Sichern mit Sicherungswerkzeugen anderer Anbieter) sichern wollen, müssen Sie dies bereits bei der Sicherungsvorlagendefinition explizit angeben.

Im Normalfall sollten Sie Datenbankinstanzen im Betriebszustand ONLINE sichern.

Das Sichern ist im Notfall auch im Betriebszustand ADMIN möglich.

Vorgehensweise

Verwenden Sie den Backup Wizard.

1. Falls Sie noch keine Sicherungsvorlage für eine Gruppe paralleler Datenträger angelegt haben, müssen Sie dies tun wie in Sicherungsvorlage für eine Gruppe paralleler Datenträger beschrieben. Im Fenster Media for Backup wählen Sie die gewünschte Sicherungsvorlage aus.

2. Überprüfen Sie die Angaben. Ändern Sie diese erforderlichenfalls (Ändern von Sicherungsvorlagen).

3. Starten Sie die Sicherung.
Falls die Kapazität der angegebenen parallelen Datenträger für die Sicherung nicht ausreicht und Sie keinen automatischen Bandwechsler verwenden, fordert Sie der Backup Wizard auf, einen neuen Datenträger anzugeben und einzulegen, sobald der vorhergehende Datenträger voll beschrieben ist (Sichern mit manuellem Datenträgerwechsel (Folgedatenträger)).

Ergebnis

Überprüfen Sie das Ergebnis Ihrer Datensicherung anhand der Sicherungshistorie.

Siehe auch:

Sicherungsverfahren


Sichern mit automatischem Bandwechsler (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sichern mit automatischem Bandwechsler

Sie können mit dem Database Manager GUI Daten oder Log-Einträge sichern und dabei automatische Bandwechsler einsetzen. Der Backup Wizard unterstützt automatische Bandwechsler.

Eine alternative Möglichkeit ist das Sichern mit Hilfe eines Sicherungswerkzeugs anderer Anbieter (Sichern mit Sicherungswerkzeugen anderer Anbieter).

Voraussetzungen

Im Normalfall sollten Sie Datenbankinstanzen im Betriebszustand ONLINE sichern.

Das Sichern ist im Notfall auch im Betriebszustand ADMIN möglich.

Stellen Sie eine ausreichende Anzahl von Bändern zur Verfügung.

Prüfen Sie vor dem Sichern unbedingt, dass der Schreibschutz bei allen Bändern deaktiviert ist, da andernfalls der gesamte Sicherungsvorgang abgebrochen wird.

Vorgehensweise

Sicherungsvorlage anlegen

Wenn Sie für das Sichern einen automatischen Bandwechsler verwenden wollen, wählen Sie beim Anlegen der Sicherungsvorlage (Sicherungsvorlage für einen einzelnen Datenträger, Sicherungsvorlage für eine Gruppe paralleler Datenträger oder Ändern von Sicherungsvorlagen) folgende Einstellungen:

● General
Wählen Sie als Typ des Datenträgers (Device Type) Tape.

● Extended
Markieren Sie Autoloader.
Unter dem Betriebssystem Windows ist damit der automatische Bandwechsel definiert.
Wenn Sie ein anderes Betriebssystem verwenden, geben Sie zusätzlich das dem Betriebssystem entsprechende Kommando für den Bandwechsel an. Tragen Sie im Feld OS Command das Betriebssystemkommando ein.

Sicherung durchführen

Verfahren Sie bei der Sicherung wie unter Sichern auf einen einzelnen Datenträger bzw. Sichern auf eine Gruppe paralleler Datenträger beschrieben.

Nach dem Einlegen des Bandmagazins in den automatischen Bandwechsler muss das erste Band im Gerät per Hand ausgewählt werden.

Wenn das Ende des Bandes erreicht ist, nimmt der Bandwechsler das nächste zur Verfügung stehende Band.

Ergebnis

Am Ende des Sicherungsvorganges ist die Anzahl der beschriebenen Bänder am Bandgerät zu erkennen. Die Bänder sollten mit der Sicherungskennung beschriftet werden, die zu Beginn der Sicherung angezeigt und bestätigt wurde.

Überprüfen Sie das Ergebnis Ihrer Daten- oder Log-Sicherung anhand der Sicherungshistorie.

Siehe auch:

Sicherungsverfahren


Sichern mit manuellem Datenträgerwechsel (Folgedatenträger) (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sichern mit manuellem Datenträgerwechsel (Folgedatenträger)

Sie können mit dem Database Manager GUI Daten oder Log-Einträge sichern und dabei Folgedatenträger verwenden. Der Backup Wizard fordert Sie gegebenenfalls zu einem Datenträgerwechsel (Verwenden eines Folgedatenträgers) auf.

Voraussetzungen

Im Normalfall sollten Sie eine Datenbankinstanz im Betriebszustand ONLINE sichern.

Das Sichern ist im Notfall auch im Betriebszustand ADMIN möglich.

Vorgehensweise

Sie haben das Sichern auf einen einzelnen Datenträger oder auf eine Gruppe paralleler Datenträger gestartet.

Die Kapazität des eingelegten Datenträgers bzw. der eingelegten Datenträger ist für die gewählte Sicherung nicht ausreichend. Die Balkenanzeige des Sicherungsfortschritts stoppt, bevor 100 % erreicht sind.

Sie werden vom Backup Wizard aufgefordert, einen weiteren Datenträger zur Verfügung zu stellen.

Folgedatenträger Band

...

1. Legen Sie das nächste Band ein.

2. Vergewissern Sie sich, dass das gerade beschriebene Band in Sicherheit gebracht wurde und das richtige Band eingelegt ist.

3. Setzen Sie die Sicherung fort.

Wir empfehlen, bei der Definition von Sicherungsvorlagen für Bänder die genaue Kapazität des Bandes anzugeben. Wenn der Bandgerätetreiber zuverlässig anzeigt, wann das Ende des Bandes erreicht wird, reagiert der Database Manager GUI auch bei Size = 0 wie beschrieben.
Falls das Bandende nicht richtig erkannt wird, erscheint die Meldung Writing Error. Auch in diesem Fall können Sie wie in den Schritten 1-3 beschrieben fortfahren.

Folgedatenträger Datei

...

1. Geben Sie unter New Location den Namen und vollständigen Pfad einer neuen Datei an, auf die gesichert werden soll.

2. Setzen Sie die Sicherung fort.

Ergebnis

Wiederholen Sie die dem Typ des Datenträgers entsprechende Verfahrensweise so oft, bis der Sicherungsvorgang abgeschlossen ist.

Solange der Sicherungsvorgang läuft, kann keine weitere Sicherung gestartet werden.

Überprüfen Sie das Ergebnis Ihrer Daten- oder Log-Sicherung anhand der Sicherungshistorie.

Siehe auch:

Sicherungsverfahren


Sichern mit Sicherungswerkzeugen anderer Anbieter (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sichern mit Sicherungswerkzeugen anderer Anbieter

Sie können mit dem Database Manager GUI Daten oder Log-Einträge sichern und dabei Sicherungswerkzeuge anderer Anbieter einsetzen. Der Backup Wizard unterstützt das Sichern auf Bänder und Folgebänder mit Hilfe von Sicherungswerkzeugen anderer Anbieter.

Voraussetzungen

Strukturlink Anschluss von Sicherungswerkzeugen anderer Anbieter

Im Normalfall sollten Sie eine Datenbankinstanz im Betriebszustand ONLINE sichern.

Das Sichern ist im Notfall auch im Betriebszustand ADMIN möglich.

Vorgehensweise

Sicherungsvorlagen anlegen

Wenn Sie für das Sichern Sicherungswerkzeuge anderer Anbieter verwenden wollen, achten Sie beim Anlegen der Sicherungsvorlagen (Sicherungsvorlage für einen einzelnen Datenträger, Sicherungsvorlage für eine Gruppe paralleler Datenträger oder Ändern von Sicherungsvorlagen) darauf, dass folgende Einstellungen gewählt werden:

General

● Wählen Sie als Typ des Datenträgers (Device Type) eine Pipe (Pipe).

● Geben Sie für den Datenträger unter Device/File den Betriebssystempfad dieser Pipe an.

Sicherung durchführen

Verfahren Sie bei der Sicherung wie unter Sichern auf einen einzelnen Datenträger bzw. Sichern auf eine Gruppe paralleler Datenträger beschrieben. Verwenden Sie die erforderlichen Sicherungsvorlagen.

Ergebnis

Überprüfen Sie das Ergebnis Ihrer Daten- oder Log-Sicherung anhand der Sicherungshistorie.

Siehe auch:

Sicherungsverfahren


Ein- und Ausschalten der automatischen Log-Sicherung (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ein- und Ausschalten der automatischen Log-Sicherung

Sie können mit dem Database Manager GUI die automatische Log-Sicherung ein- und ausschalten.

Wenn Sie die automatische Log-Sicherung Ihres Systems einschalten, bleibt diese solange eingeschaltet, bis Sie die automatische Log-Sicherung wieder ausschalten. Die automatische Log-Sicherung bleibt auch dann eingeschaltet, wenn die Datenbankinstanz neu gestartet wird.

Voraussetzungen

Bevor Sie die automatische Log-Sicherung einschalten, müssen Sie eine vollständige Datensicherung durchführen.

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

Anlegen einer Datenbankinstanz

Die automatische Log-Sicherung können Sie beim Anlegen einer Datenbankinstanz ein- oder ausschalten.

Verfahren Sie wie in Anlegen einer Datenbankinstanz: Custom beschrieben.

Verwenden des Backup Wizard

Die automatische Log-Sicherung können Sie mit dem Backup Wizard ein- und ausschalten.

...

1. Starten Sie den Backup Wizard .

2. Falls noch keine Sicherungsvorlage angelegt wurde, müssen Sie dies tun wie in Sicherungsvorlage für einen einzelnen Datenträger beschrieben. Im Fenster Media for Backup wählen Sie die gewünschte Sicherungsvorlage aus.

3. Überprüfen Sie die Angaben. Ändern Sie diese erforderlichenfalls ( Ändern von Sicherungsvorlagen ).

4. Wenn sich die Datenbankinstanz im Betriebszustand ONLINE befindet, können Sie die automatische Log-Sicherung ein- oder ausschalten (Activate/deactivate automatic log backup).

Verwenden des Database Manager GUI

Die automatische Log-Sicherung können Sie mit dem Database Manager GUI ein- und ausschalten.

Voraussetzung für das Durchführen von Log-Sicherungen ist das Vorhandensein der erforderlichen Sicherungsvorlagen.

...

1. Starten Sie den Database Manager GUI.

2. Wählen Sie Instance.

3. Wenn sich die Datenbankinstanz im Betriebszustand ONLINE befindet, können Sie die automatische Log-Sicherung ein- oder ausschalten (Set Auto Log ON/OFF).

Ergebnis

In der Liste der Datenbankinstanzen wird neben anderen Informationen auch angezeigt, ob die automatische Log-Sicherung eingeschaltet ist oder nicht (Auto Log On/Off)

Überprüfen Sie das Ergebnis Ihrer Log-Sicherungen anhand der Sicherungshistorie .

Siehe auch:

Sicherungsverfahren

Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern


Wiederherstellen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Wiederherstellen

Verwendung

Um eine Datenbankinstanz nach einem Fehler oder Systemausfall wiederherzustellen, können Sie mit dem Database Manager GUI Daten- und gegebenenfalls Log-Sicherungen einlesen. Sie können die Datenbankinstanz bis zum letzten oder einen früheren Zustand wiederherstellen.

Desweiteren unterstützt der Database Manager GUI das Wiederherstellen von Indizes und von gespiegelten Log-Volumes.

Wenn vor dem Beginn des Wiederherstellens der Datenbankinstanz die automatische Log-Sicherung aktiv war, wird diese nach dem Wiederherstellen nicht automatisch wieder eingeschaltet. Um die Log-Sicherung wieder einzuschalten, verfahren Sie wie in Einschalten der automatischen Log-Sicherung beschrieben.

Aktivitäten

Für interaktive Wiederherstellungsprozesse von Daten können Sie in der Regel den Recovery Wizard verwenden. Der Recovery Wizard schlägt Ihnen die optimale Wiederherstellungsstrategie vor. Es gibt folgende Verfahren:

● Wiederherstellen aus der zuletzt angefertigten Sicherung der Sicherungshistorie

● Wiederherstellen aus einer früheren Sicherung der Sicherungshistorie

● Wiederherstellen ohne Sicherungshistorie

● Fortsetzen einer unterbrochenen Wiederherstellung

● Wiederherstellen mit automatischem Bandwechsler

● Wiederherstellen mit Sicherungswerkzeugen anderer Anbieter

Sollte ein Wiederherstellen mit einem der oben genannten Verfahren nicht möglich sein (z.B. weil die Datenbankinstanz gelöscht wurde), müssen Sie die Datenbankinstanz initialisieren und dann wiederherstellen. Diese Verfahrensweise ist auf Grund des Initialisierungsvorgangs wesentlich zeitaufwändiger und sollte daher nur dann eingesetzt werden, wenn es wirklich erforderlich ist.

● Wiederherstellen nach Initialisieren einer Datenbankinstanz

Mit dem Database Manager GUI können Sie auch Indizes und gespiegelte Volumes wiederherstellen:

● Wiederherstellen der Indizes nach Datenbankwiederherstellung

● Wiederherstellen eines gespiegelten Log-Volume

Siehe auch:

Konzepte des Datenbanksystems, Abschnitt Strukturlink Datenbankinstanz wiederherstellen


Recovery Wizard (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Recovery Wizard

Verwendung

Zum Wiederherstellen einer Datenbankinstanz können Sie den Recovery Wizard verwenden, der Sie durch den gesamten Vorgang leitet.

Der Recovery Wizard kann auf einem windows-basierten Rechner gestartet werden, um auf einem lokalen oder einem entfernten Rechner Daten wiederherzustellen.

Der Recovery Wizard schlägt grundsätzlich das schnellste Verfahren der Wiederherstellung vor. Dabei werden zuerst vollständige Datensicherung(en) und anschließend, soweit notwendig, eine inkrementelle Datensicherung und Log-Sicherungen eingelesen.

Um maximalen Datendurchsatz zu gewährleisten, können Datensicherungen von mehreren Datenträgern gleichzeitig eingelesen werden. Die Anzahl der Datenträger in einer solchen Gruppe paralleler Datenträger ist dabei unabhängig von der Anzahl der beim Anfertigen der Sicherung verwendeten parallelen Datenträgern. Auch eine Sicherung auf einen einzelnen Datenträger mit Folgedatenträgern kann parallel zurückgeladen werden. Durch den Einsatz von bis zu 32 Bandgeräten können Sie so die Wiederherstellungszeiten erheblich reduzieren.

Log-Sicherungen können nicht parallel eingelesen werden.

Vorgehensweise

Wählen Sie im Database Manager GUI Instance ® Recovery ® Recovery... .

Starten Sie die gewünschten Wiederherstellungsschritte jeweils mit Next.

...

1. Sie können Daten einer Datenbankinstanz lokal oder auf einem entfernten Rechner wiederherstellen.
Wählen Sie die gewünschte Datenbankinstanz aus oder geben Sie direkt folgende Angaben ein:
Database Server: Name des Datenbankrechners
Database Name: Datenbanknamen
User Name: Name des Database Manager-Benutzers
Password: Kennwort des Database Manager-Benutzers

2. Sie können die Datenbankinstanz in den gewünschten Betriebszustand bringen. Für Wiederherstellungen ist der Betriebszustand ADMIN erforderlich.

3. Wählen Sie die gewünschte Wiederherstellungsart:
Restore last backup: Wiederherstellen aus der zuletzt angefertigten Sicherung der Sicherungshistorie
Restore a specified backup from history: Wiederherstellen aus einer früheren Sicherung der Sicherungshistorie
Restore a medium: Wiederherstellen ohne Sicherungshistorie
Continue restoring increment/Log: Wenn das Fortsetzen einer unterbrochenen Wiederherstellung erforderlich ist, wird Ihnen diese Einstellung angezeigt.

4. Restore database until a specified time: Wenn Sie eine Wiederherstellung nur bis zu einem bestimmten Zeitpunkt wünschen, markieren Sie diese Einstellung und tragen den gewünschten Zeitpunkt ein.

5. Die Wiederherstellungsstrategie wird Ihnen angezeigt. Sie werden aufgefordert, die erforderlichen Datenträger einzulegen.

6. Starten Sie die Wiederherstellung.

7. Schließen Sie den Recovery Wizard.

Ergebnis

Die Datenbankinstanz ist auf den gewünschten Stand wiederhergestellt.

Wenn die im Recovery Wizard angebotenen Wiederherstellungsverfahren nicht zum gewünschten Erfolg führen, müssen Sie gegebenenfalls eine der Verfahrensweisen zum Wiederherstellen nach Initialisieren einer Datenbankinstanz einsetzen.

Siehe auch:

Konzepte des Datenbanksystems, Abschnitt Strukturlink Datenbankinstanz wiederherstellen


Wiederherstellen aus der zuletzt angefertigten Sicherung der Sicherungshistorie

Vorgehensweisen Wiederherstellen aus der zuletzt angefertigten Sicherung der Sicherungshistorie

Das Wiederherstellen können Sie interaktiv mit dem Recovery Wizard durchführen. Sie können eine Wiederherstellung anhand der zuletzt angefertigten Sicherung durchführen.

Voraussetzungen

Die Strukturlink Protokolldateien dbm.knl und dbm.mdf sind unbeschadet geblieben. Die Strukturlink Sicherungshistorie ist damit vollständig.

Wenn es sich um eine Wiederherstellung mit Sicherungswerkzeugen anderer Anbieter handelt, dann muss zusätzlich das Protokoll dbm.ebf unbeschadet geblieben sein.

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

Verwenden Sie den Recovery Wizard.

...

1. Wählen Sie Restore last backup.
Sie haben die Möglichkeit, einen Zeitpunkt zu bestimmen, bis zu dem wiederhergestellt werden soll. Markieren Sie in diesem Fall Restore database until a specified time und geben Sie den gewünschten Zeitpunkt ein.
Das System schlägt Ihnen den aktuellen Zeitpunkt vor. Wenn Sie diesen Systemvorschlag nicht ändern, wird die Datenbankinstanz vollständig, d. h. mit allen aktuellen Änderungen wiederhergestellt.

2. Die zuletzt angefertigte vollständige Datensicherung und die entsprechend Ihren Einstellungen zugehörige inkrementelle Datensicherung sowie die notwendigen Log-Sicherungen werden angezeigt.
Sie haben die Möglichkeit, die inkrementelle Datensicherung aus dem Vorschlag abzuwählen. Der Recovery Wizard schlägt dann stattdessen die entsprechenden Log-Sicherungen oder falls vorhanden eine alternative inkrementelle Datensicherung vor.

3. Sie werden aufgefordert, den angegebenen Datenträger einzulegen.

4. Starten Sie die Wiederherstellung.
Handelt es sich um eine Wiederherstellung mit Sicherungswerkzeugen anderer Anbieter, werden an dieser Stelle die externen Sicherungskennungen angezeigt.
Die vollständige Datensicherung wird wiederhergestellt.

5. Wenn eine inkrementelle Datensicherung wiederhergestellt wird, fordert Sie der Recovery Wizard auf, diese Aktion zu bestätigen.

6. Wenn Log-Sicherungen wiederhergestellt werden müssen, fordert Sie der Recovery Wizard auf, das Wiederherstellen aller angezeigten Log-Sicherungen insgesamt zu bestätigen. Nach dem Wiederherstellen der Log-Sicherungen befindet sich die Datenbankinstanz im Betriebszustand ONLINE.
Wenn keine Log-Sicherungen wiederhergestellt werden müssen, endet die Wiederherstellung. Gegebenenfalls können Sie einen UNTIL-Zeitpunkt angeben. Wählen Sie Restart, um die Datenbankinstanz zu starten.

Beim Einlesen der aufeinanderfolgenden Sicherungen werden Sie vom Recovery Wizard explizit dazu aufgefordert, den jeweils nächstfolgenden Datenträger einzulegen, sofern Sie nicht den Vorgang des Wiederherstellens mit einem automatischem Bandwechsler durchführen.

Sie haben die Möglichkeit, den Vorgang der Wiederherstellung zu unterbrechen und später fortzusetzen (Fortsetzen einer unterbrochenen Wiederherstellung ).


Wiederherstellen aus einer früheren Sicherung der Sicherungshistorie

Vorgehensweisen Wiederherstellen aus einer früheren Sicherung der Sicherungshistorie

Das Wiederherstellen können Sie interaktiv mit dem Recovery Wizard durchführen. Sie können eine Wiederherstellung anhand einer vollständigen Datensicherung aus der Sicherungshistorie durchführen.

Voraussetzungen

Die Strukturlink Protokolldateien des Database Manager dbm.knl und dbm.mdf sind unbeschadet geblieben. Die Strukturlink Sicherungshistorie ist damit vollständig.

Handelt es sich um eine Wiederherstellung mit Sicherungswerkzeugen anderer Anbieter, muss zusätzlich das Protokoll dbm.ebf unbeschadet geblieben sein.

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

Verwenden Sie den Recovery Wizard.

...

1. Wählen Sie Restore a specified backup from history.
Sie haben die Möglichkeit, einen Zeitpunkt zu bestimmen, bis zu dem wiederhergestellt werden soll. Markieren Sie in diesem Fall Restore database until a specified time und geben Sie den gewünschten Zeitpunkt ein.
Das System schlägt Ihnen den aktuellen Zeitpunkt vor. Wenn Sie diesen Systemvorschlag nicht ändern, wird die Datenbankinstanz vollständig, d. h. mit allen aktuellen Änderungen wiederhergestellt.

2. Die Sicherungshistorie der vollständigen Datensicherungen wird angezeigt.

3. Wählen Sie die gewünschte Datensicherung aus.

4. Die gewählte Datensicherung, die zugehörige inkrementelle Datensicherung und die notwendigen Log-Sicherungen werden angezeigt.
Sie haben die Möglichkeit, die inkrementelle Datensicherung aus dem Vorschlag abzuwählen. Der Recovery Wizard schlägt dann stattdessen die entsprechenden Log-Sicherungen oder falls vorhanden eine alternative inkrementelle Datensicherung vor.

5. Sie werden aufgefordert, den angegebenen Datenträger einzulegen.

6. Starten Sie die Wiederherstellung.
Handelt es sich um eine Wiederherstellung mit Sicherungswerkzeugen anderer Anbieter, werden an dieser Stelle die externen Sicherungskennungen angezeigt.
Die vollständige Datensicherung wird wiederhergestellt.

7. Wenn eine inkrementelle Datensicherung wiederhergestellt wird, fordert Sie der Recovery Wizard auf, diese Aktion zu bestätigen.

8. Wenn Log-Sicherungen wiederhergestellt werden müssen, fordert Sie der Recovery Wizard auf, das Wiederherstellen aller angezeigten Log-Sicherungen insgesamt zu bestätigen. Nach dem Wiederherstellen von Log-Sicherungen befindet sich die Datenbankinstanz im Betriebszustand ONLINE.
Wenn keine Log-Sicherungen wiederhergestellt werden müssen, endet die Wiederherstellung. Gegebenenfalls können Sie einen UNTIL-Zeitpunkt angeben. Wählen Sie Restart, um die Datenbankinstanz zu starten.

Beim Einlesen der aufeinanderfolgenden Sicherungen werden Sie vom Recovery Wizard explizit dazu aufgefordert, den jeweils nächstfolgenden Datenträger einzulegen, sofern Sie nicht den Vorgang des Wiederherstellen mit automatischem Bandwechsler durchführen.

Sie haben die Möglichkeit, den Vorgang der Wiederherstellung zu unterbrechen und später fortzusetzen (Fortsetzen einer unterbrochenen Wiederherstellung ).


Wiederherstellen ohne Sicherungshistorie (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Wiederherstellen ohne Sicherungshistorie

Das Wiederherstellen können Sie interaktiv mit dem Recovery Wizard durchführen. Sie können eine Wiederherstellung auch dann durchführen, wenn die Strukturlink Sicherungshistorie nicht verfügbar ist.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Die Sicherungshistorie ist fehlerhaft oder nicht mehr vollständig.

Vorgehensweise

Verwenden Sie den Recovery Wizard.

...

1. Wählen Sie Restore a medium.
Sie haben die Möglichkeit, einen Zeitpunkt zu bestimmen, bis zu dem die Informationen einer Sicherung wiederhergestellt werden sollen. Markieren Sie in diesem Fall Restore database until a specified time und geben Sie den gewünschten Zeitpunkt ein.
Das System schlägt Ihnen den aktuellen Zeitpunkt vor. Wenn Sie diesen Systemvorschlag nicht ändern, werden die Sicherungen vollständig, d. h. mit allen darin vorhandenen Änderungen wiederhergestellt.

2. Eine Liste aller vorhandenen Sicherungsvorlagen wird angezeigt.

3. Wählen Sie die Sicherungsvorlage aus, deren Daten wiederhergestellt werden sollen.
Wenn es sich um eine Wiederherstellung mit Sicherungswerkzeugen anderer Anbieter handelt, erhalten Sie eine Liste der Sicherungen. Wählen Sie gegebenenfalls die gewünschten externen Sicherungskennungen aus.

4. Sie werden aufgefordert, den angegebenen Datenträger einzulegen. Handelt es sich um eine Wiederherstellung mit Sicherungswerkzeugen anderer Anbieter, werden nochmals die externen Sicherungskennungen angezeigt.

5. Starten Sie den Wiederherstellungsvorgang.
Wenn Sie anschließend weitere Sicherungen ohne Sicherungshistorie wiederherstellen wollen, wiederholen Sie die Vorgehensweise.

6. Wählen Sie Restart, um die Datenbankinstanz neu zu starten.

Sie haben die Möglichkeit, den Vorgang der Wiederherstellung zu unterbrechen und später fortzusetzen (Fortsetzen einer unterbrochenen Wiederherstellung ).


Fortsetzen einer unterbrochenen Wiederherstellung (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Fortsetzen einer unterbrochenen Wiederherstellung

Sie haben die Möglichkeit, nach Abbruch des Wiederherstellens diesen Vorgang mit dem Recovery Wizard später fortzusetzen.

Voraussetzung

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Eines der möglichen Wiederherstellungsverfahren war gestartet und wurde vor dem Abschluss abgebrochen.

● Wiederherstellen aus der zuletzt angefertigten Sicherung der Sicherungshistorie

● Wiederherstellen aus einer früheren Sicherung der Sicherungshistorie

● Wiederherstellen ohne Sicherungshistorie

Vorgehensweise

Verwenden Sie den Recovery Wizard.

...

1. Wählen Sie Continue restoring increment/Log.
Sie haben die Möglichkeit, einen Zeitpunkt zu bestimmen, bis zu dem wiederhergestellt werden soll. Markieren Sie in diesem Fall Restore database until a specified time und geben Sie den gewünschten Zeitpunkt ein.
Das System schlägt Ihnen den aktuellen Zeitpunkt vor. Wenn Sie diesen Systemvorschlag nicht ändern, werden die Sicherungen vollständig, d. h. mit allen darin vorhandenen Änderungen wiederhergestellt.

2. Sie erhalten die Liste aller zu der/den bereits wiederhergestellten Datensicherung/en passenden Log-Sicherungen angezeigt.

3. Setzen Sie den Wiederherstellungsvorgang fort. Sie können den Vorgang des Wiederherstellens sowie seinen Abschluss an der Anzeige auf dem Bildschirm verfolgen.

4. Wählen sie Restart, um die Datenbankinstanz zu starten.

...

Beim Einlesen der aufeinanderfolgenden Sicherungen werden Sie vom Recovery Wizard explizit dazu aufgefordert, den jeweils nächstfolgenden Datenträger einzulegen, sofern Sie nicht den Vorgang des Wiederherstellens mit einem automatischem Bandwechsler durchführen.


Wiederherstellen mit automatischem Bandwechsler (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Wiederherstellen mit automatischem Bandwechsler

Das Wiederherstellen können Sie interaktiv mit dem Recovery Wizard durchführen. Zur Optimierung des Vorgangs können Sie automatische Bandwechsler verwenden.

Voraussetzungen

Damit das Zurückladen erfolgreich verlaufen kann, müssen alle zur Sicherung gehörenden Bänder im Bandwechsler eingelegt sein.

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

Sie verwenden die gleiche Sicherungsvorlage wie beim Sichern (Verwalten der Sicherungsvorlagen).

Führen Sie die einzelnen Schritte gemäss der Beschreibung des entsprechenden Wiederherstellungsvorganges aus:

· Wiederherstellen aus der zuletzt angefertigten Sicherung der Sicherungshistorie

· Wiederherstellen aus einer früheren Sicherung der Sicherungshistorie

· Wiederherstellen ohne Sicherungshistorie


Wiederherstellen mit Sicherungswerkzeugen anderer Anbieter (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Wiederherstellen mit Sicherungswerkzeugen anderer Anbieter

Das Wiederherstellen können Sie interaktiv mit dem Recovery Wizard durchführen. Der Recovery Wizard unterstützt die Verwendung von Sicherungswerkzeugen anderer Anbieter.

Voraussetzungen

Strukturlink Anschluss von Sicherungswerkzeugen anderer Anbieter

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

Sie starten den Vorgang des Wiederherstellens aus dem Recovery Wizard. Der Recovery Wizard zeigt die externen Sicherungskennungen zur Überprüfung durch den Benutzer an und verwendet diese bei der Wiederherstellung. Der Benutzer muss die externen Sicherungskennungen nicht selbst explizit ermitteln oder angeben.

Die Zahl der Datenträger einer Gruppe paralleler Datenträger muss der Anzahl der Datenträger entsprechen, die für das Erstellen der Sicherung verwendet wurde.

Verfahren Sie gemäss der Beschreibung des entsprechenden Wiederherstellungsvorganges:

● Wiederherstellen aus der zuletzt angefertigten Sicherung der Sicherungshistorie

● Wiederherstellen aus einer früheren Sicherung der Sicherungshistorie

● Wiederherstellen ohne Sicherungshistorie


Wiederherstellen nach Initialisieren einer Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Wiederherstellen nach Initialisieren einer Datenbankinstanz

Für das Wiederherstellen kann unter Umständen ein Initialisieren der Datenbankinstanz erforderlich sein, um das Löschen der Log-Einträge im Log-Bereich zu erzwingen. Anschließend können Sie die erforderlichen Sicherungen einspielen, um die Datenbankinstanz bis zum gewünschten Zustand wiederherzustellen.

Für das Wiederherstellen nach Initialisieren einer Datenbankinstanz gibt es zwei Verfahrensweisen. Entscheiden Sie sich für eine dieser Verfahrensweisen, je nachdem, ob Sie vor der Wiederherstellung Einfluß auf die Datenbankparameter- und Volumeeinstellungen nehmen möchten oder nicht.

Sie benötigen das Wiederherstellen nach Initialisieren eine Datenbankinstanz z.B. in folgenden Situationen:

· Sie wollen eine gelöschte Datenbankinstanz aus einer Sicherung wiederherstellen.

· Sie wollen Sicherungen nutzen, die zeitlich vor dem Zeitpunkt liegen, bis zu dem eine Wiederherstellung mit UNTIL-Zeitpunkt durchgeführt wurde (Beispiel: Sie wollen eine Wiederherstellung mit UNTIL-Zeitpunkt wiederholen, um einen anderen Zeitpunkt anzugeben).

Sicherungen, die vor dem Zeitpunkt des Unterbrechens der Sicherungshistorie liegen, können nur mit dem hier beschriebenen Verfahren wiedereingespielt werden.

Bei den hier beschriebenen Verfahren erfolgt ein Initialisieren der Datenbankinstanz. Dieser Vorgang ist sehr zeitaufwändig. Daher sollten Sie diese Verfahren nur dann einsetzen, wenn es wirklich erforderlich ist.

Vorgehensweise

Es gibt folgende Verfahrensweisen, um eine Datenbankinstanz zu initialisieren und anschließend wiederherzustellen:

· Wiederherstellen nach Initialisieren einer Datenbankinstanz ohne die Möglichkeit, die Datenbankparamter und die Konfiguration der Volumes zu ändern

· Wiederherstellen nach Initialisieren einer Datenbankinstanz mit der Möglichkeit, die Datenbankparamter und die Konfiguration der Volumes zu ändern

Wiederherstellen nach Initialisieren einer Datenbankinstanz ohne die Möglichkeit, die Datenbankparamter und die Konfiguration der Volumes zu ändern

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

...

1. Wählen Sie Instance ® Recovery ® Recovery with Initialization.

2. Überführen Sie die Datenbankinstanz gegebenenfalls in den Betriebszustand ADMIN.

3. Der Recovery Wizard schlägt grundsätzlich das schnellste Verfahren der Wiederherstellung vor. Gegebenenfalls müssen Sie ein Ihrer Situation angepaßtes Verfahren auswählen.

4. Sie werden durch den gesamten Vorgang des Wiederherstellens der Datenbankinstanz geleitet. Die weiteren Wiederherstellungschritte sind in den entsprechenden Wiederherstellungsverfahren beschrieben.

Wiederherstellen nach Initialisieren einer Datenbankinstanz mit der Möglichkeit, die Datenbankparamter und die Konfiguration der Volumes zu ändern

Voraussetzungen

Die Strukturlink Protokolldateien dbm.knl und dbm.mdf sind unbeschadet geblieben. Die Strukturlink Sicherungshistorie ist damit vollständig. Die Datenbankinstanz befindet sich im Betriebszustand OFFLINE.

Vorgehensweise

1. Initialisieren Sie die Datenbankinstanz. Alle Daten der alten Version gehen dabei verloren.

2. Wählen Sie im Ablauf des Initialisierens Create Instance for recovery (nicht Create and start instance), denn nur dann können Sie anschließend die Daten wiederherstellen.
Die Datenbankinstanz befindet sich nach Anlegen der Datenbaninstanz im Betriebszustand ADMIN. Der Database Manager öffnet automatisch den Recovery Wizard.

3. Der Recovery Wizard schlägt grundsätzlich das schnellste Verfahren der Wiederherstellung vor. Gegebenenfalls müssen Sie ein Ihrer Situation angepaßtes Verfahren auswählen.

4. Sie werden durch den gesamten Vorgang des Wiederherstellens der Datenbankinstanz geleitet. Die weiteren Wiederherstellungschritte sind in den entsprechenden Wiederherstellungsverfahren beschrieben.


Wiederherstellen der Indizes nach Datenbankwiederherstellung (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Wiederherstellen der Indizes nach Datenbankwiederherstellung

Sie können mit dem Strukturlink speziellen Datenbankparameter AUTO_RECREATE_BAD_INDEXES konfigurieren, ob nach einem Wiederherstellen einer Datenbankinstanz als BAD markierte Indizes automatisch neu erzeugt werden sollen. Wenn Sie diesen Datenbankparameter auf NO gesetzt haben und eine Datenbankwiederherstellung durchgeführt haben, dann können Sie als BAD markierte Indizes auch explizit neu erzeugen.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

1. Wählen Sie Instance ® Recovery ® Index.

2. Sie haben die Möglichkeit auszuwählen, zu welchen Tabellen die als BAD markierten Indizes angezeigt werden sollen. Geben Sie dazu geeignete Suchargumente für folgende Angaben ein:

Owner | Eigentümer
Table Name | Name der Tabelle
Index Name | Name des Index

3. Wählen Sie Actions ® Search. Sie erhalten eine Liste der Indizes, die Ihren Angaben entsprechen.

4. Markieren Sie die Indizes, die Sie neu erzeugen wollen.

5. Wählen Sie Actions ® Recreate, um die Aktion auszuführen.

Wir empfehlen, Indizes in Zeiten geringer Last wiederherzustellen.

Siehe auch:

Indizes de-/aktivieren oder löschen

Datenbankverwaltung im CCMS, Strukturlink Indizes


Wiederherstellen eines gespiegelten Log-Volume (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Wiederherstellen eines gespiegelten Log-Volume

Wenn Sie die Strukturlink Log-Volumes gespiegelt betreiben, kann es zu einem Ausfall eines Volume-Spiegels kommen. Bei Zugriffsproblemen auf den Log-Bereich oder den Spiegel-Log-Bereich wird das betroffene Log-Volume als BAD markiert und die Datenbankinstanz in den Betriebszustand OFFLINE überführt.

Mit dem Database Manager GUI können Sie ein beschädigtes Spiegel-Log-Volume wiederherstellen. Dabei wird der komplette Inhalt des entsprechenden Log-Volumes aus dem anderen Log-Bereich in das defekte Log-Volume kopiert. Damit ist gesichert, dass nach einem Plattenfehler, bei dem der Inhalt eines Log-Volume zerstört wurde, die Datenbankinstanz nicht wiederhergestellt werden muss, da der Inhalt des Log-Volumes gespiegelt war.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

1. Wählen Sie Instance ® Recovery ® Volumes.
Markieren Sie die wiederherzustellenden BADVolumes.

2. Wählen Sie Actions ® Reintegrate, um das Kopieren des Spiegel-Volume zu starten.

Siehe auch:

Strukturlink Log-Modus


Einfrieren des Datenbereichs (Snapshots) (SAP-Bibliothek - Werkzeuge)

Prozessdokumentation Einfrieren des Datenbereichs (Snapshots)

Ein Snapshot friert den aktuellen Zustand des Datenbereichs ein. Sie können danach normal mit den Daten weiterarbeiten und später zum Zustand des Datenbereichs zum Zeitpunkt des Snapshot zurückkehren.

Sie können mit dem Database Manager GUI Snapshots erstellen, verwenden und löschen.

Ein Snapshot ist keine Datensicherung. Um Ihre Daten nach einem Systemausfall wiederherstellen zu können, müssen Sie regelmäßig Daten- und Log-Sicherungen durchführen.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Ablauf

...

1. Sie erstellen einen Snapshot.

2. Sie arbeiten normal mit den Daten weiter.

3. Sie entscheiden sich zwischen folgenden beiden Optionen:

¡ Zurückkehren zum Snapshot (Verwerfen aller Änderungen seit dem Snapshot)

¡ Löschen des Snapshot (endgültiges Übernehmen aller Änderungen seit dem Snapshot)

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbereich einfrieren (Snapshot)


Erstellen eines Snapshot (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Erstellen eines Snapshot

Sie können mit dem Database Manager GUI einen Snapshot erstellen.

Es kann immer nur ein Snapshot existieren. Das Erstellen eines neuen Snapshot überschreibt einen eventuell vorhandenen älteren Snapshot.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

Wir empfehlen, in den Log-Einstellungen den Überschreib-Modus für den Log-Bereich einzuschalten (siehe Log-Einstellungen ändern).

...

1. Wählen Sie Instance ® Snapshot.

2. Wählen Sie Create Snapshot und bestätigen Sie Ihre Eingabe.

Ergebnis

Der Snapshot wird erstellt.

Siehe auch:

Einfrieren des Datenbereichs (Snapshots)


Zurückkehren zum Snapshot (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Zurückkehren zum Snapshot

Sie können mit dem Database Manager GUI zum Zustand des Datenbereichs zum Zeitpunkt des Snapshots zurückkehren. Dadurch verwerfen Sie alle Änderungen seit dem Snapshot.

Wenn Sie zum Snapshot zurückkehren, dann werden auch alle bis zu diesem Zeitpunkt geschriebenen Log-Einträge gelöscht, d. h. die Sicherungshistorie wird unterbrochen. Sie müssen zunächst eine vollständige Datensicherung durchführen, bevor wieder eine Log-Sicherung erfolgen kann.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

...

1. Wählen Sie Instance ® Snapshot.

2. Wählen Sie Revert to Snapshot und bestätigen Sie Ihre Eingabe.

Siehe auch:

Einfrieren des Datenbereichs (Snapshots)


Löschen des Snapshot (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen des Snapshot

Sie können mit dem Database Manager GUI den Snapshot löschen. Dadurch werden alle Änderungen im Datenbereich übernommen, die seit dem Snapshot erfolgt sind.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Vorgehensweise

...

1. Wählen Sie Instance ® Snapshot.

2. Wählen Sie Delete Snapshot und bestätigen Sie Ihre Eingabe.

Siehe auch:

Einfrieren des Datenbereichs (Snapshots)


Anzeigen von Informationen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anzeigen von Informationen

Sie können einen Gesamtüberblick über die im Database Manager GUI vorhandenen Informationen und Statistiken zu wichtigen Datenbankfunktionen erhalten.

Sie können sich alle DBM-Kommandos, die vom Database Manager GUI bei seinen Aktionen zur Verwaltung einer Datenbankinstanz ausgeführt werden, in der Database Manager-Konsole anzeigen lassen.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
 Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information.

3. Wählen Sie den gewünschten Bereich, für den Sie detaillierte Informationen einsehen wollen.

Um die Database Manager-Konsole zu starten, wählen Sie Instance ® Database Manager Console.

Ergebnis

Sie erhalten Informationen zu folgenden Schwerpunkten:

Activity | Datenbankaktivitäten anzeigen
Caches | Cache-Informationen anzeigen
Data Area | Datenbereichs-Informationen anzeigen
Log Area | Log-Bereichs-Informationen anzeigen
Backup History | Sicherungshistorie anzeigen
Parameters | Datenbankparameter anzeigen
Sessions | Datenbanksitzungen anzeigen
System Info Tables | Systemtabellen anzeigen

Wenn Sie die Database Manager-Konsole verwenden, können Sie in der Anzeige der Konsole verfolgen, welche DBM-Kommandos für die jeweilige Verwaltungsaufgabe verwendet werden. Bei Bedarf können Sie die DBM-Kommandos in einer von Ihnen festgelegten Datei speichern oder direkt für das Ausführen von Verwaltungsaktionen mit dem Database Manager CLI verwenden.

Siehe auch:

Diagnosemöglichkeiten

Database Manager CLI, DBM-Kommandos


Sicherungshistorie anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sicherungshistorie anzeigen

Sie können im Database Manager GUI eine chronologische Auflistung aller erfolgten Sicherungs- und Wiederherstellungsaktionen (Sicherungshistorie) erhalten.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz. Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie
Instance ® Information ® Backup History
oder
Instance ® Backup ® Backup History

Ergebnis

Sie erhalten zu jeder Aktion folgende Informationen:

Label | Sicherungskennung
Action | Aktion (Sichern oder Wiederherstellen) und Betriebszustand, in dem die Aktion erfolgte
Start | Beginn der Aktion
Result | Ergebnis
Medium | Name der Sicherungsvorlage
Size (Pages) | Größe (Seiten)
Volumes | Volumes
Next Log Page | I/O-Sequenznummer
From Page | Von I/O-Sequenznummer
To Page | Bis I/O-Sequenznummer

Wenn Sie weitere Informationen zu einer Sicherung erhalten wollen, wählen Sie die gewünschte Sicherungskennung in der Sicherungshistorie. Bei Verwendung von Sicherungswerkzeugen anderer Anbieter wird auch die externe Sicherungskennung und der Status der Sicherung mit dem Sicherungswerkzeugen anderer Anbieter angezeigt. Mittels Action ® Close können Sie diese Anzeige wieder verlassen.

Wählen Sie Action ® Refresh with External Backup Info, um die Sicherungshistorie zu aktualisieren.

Siehe auch:

Sichern

Verwalten der Sicherungsvorlagen

Sichern mit Sicherungswerkzeugen anderer Anbieter


Cache-Informationen anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Cache-Informationen anzeigen

Sie können im Database Manager GUI die Trefferrate der Caches anzeigen lassen. Diese Trefferraten zeigen, ob die Caches ausreichend groß konfiguriert wurden. Besonders wichtig sind die Trefferraten von Data-Cache und Converter.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® Caches.

3. Für die verschiedenen Caches werden folgende Informationen angezeigt:

Accesses | Anzahl der Zugriffe insgesamt
Successful | Anzahl erfolgreicher Zugriffe
Unsuccessful | Anzahl nicht erfolgreicher Zugriffe
Hit Rate (%) | Trefferrate (prozentualer Anteil der Treffer an der Gesamtzahl der Zugriffe)

Außerdem werden die aktuellen Werte einiger Datenbankparameter angezeigt, die Auswirkungen auf die Caches haben.

Ergebnis

Die Trefferrate des Data-Cache sollte bei mindestens 99% und die des Converter bei mindestens 98% liegen.

Kurzzeitig kann es zu niedrigeren Trefferraten kommen, z. B. beim erstmaligen Lesen von Tabellen oder wenn bei wiederholten Tabellendurchsuchungen die Tabelle nicht in 10% des Data-Cache passt. Wenn die Werte dauerhaft unter dem empfohlenen Prozentsatz liegen, dann deutet dies auf eine schlechte Performance hin, und Sie müssen gegebenenfalls den Strukturlink allgemeinen Datenbankparameter CACHE_SIZE anpassen.


Datenbereichs-Informationen anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbereichs-Informationen anzeigen

Sie können im Database Manager GUI Informationen zur Größe und aktuellen Auslastung des Datenbreichs anzeigen lassen.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® Data Area.

Ergebnis

Die Anzeige ist in folgende Bereiche unterteilt:

● Volumes: Angaben zu den Data-Volumes

● Settings: Wert des Datenbankparameters MAXDATAVOLUMES

● Usage: Auslastung des Datenbereichs

● I/O: Lese- und Schreibaktivitäten pro Data-Volume

Volumes

Sie erhalten für jedes Data-Volume unter anderem folgende Informationen: Name, Größe, Typ und Pfadangabe im Arbeitsverzeichnis

Settings

Die maximale Anzahl der Data-Volumes wird durch den Strukturlink allgemeinen Datenbankparameter MAXDATAVOLUMES gesteuert. Der aktuelle Wert dieses Datenbankparameters wird angezeigt.

Usage

Wenn sich die Datenbankinstanz im Betriebszustand ONLINE befindet, können Sie sich die Auslastung des Datenbereichs anzeigen lassen.

Total Size | Gesamtgröße des Datenbereichs
Used Area | Belegter Datenbereich
Permanent Used Area | Mit permanenten Daten belegter Datenbereich
Temporary Used Area | Mit temporären Daten belegter Datenbereich
Free Area | Freier Datenbereich

Desweiteren wird der Füllungsgrad jedes einzelnen Data-Volume angezeigt.

I/O

Wenn sich die Datenbankinstanz im Betriebszustand ONLINE befindet, können Sie sich die Lese- und Schreibaktivität für jedes einzelne Data-Volume anzeigen lassen.

Siehe auch:

Volumes anlegen, anzeigen und löschen

Volume-Eigenschaften ändern

Volume-Datenbankparameter ändern

Automatische Erweiterung des Datenbereichs ein-/ausschalten


Datenbankaktivitäten anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbankaktivitäten anzeigen

Sie können im Database Manager GUI die Datenbankaktivitäten anzeigen lassen.

Voraussetzung

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® Activity.

3. Sie erhalten eine Anzeige der Datenbankaktivitäten, die in folgende Bereiche unterteilt ist:

¡ Commands: Informationen zu den SQL-Anweisungen

¡ I/O Activity: Informationen zu den Lese- und Schreibvorgängen

¡ Lock Activity: Informationen zur Sperraktivität

¡ Log Activity: Informationen zur Log-Aktivität

¡ Scan and Sort Activity: Informationen zu Tabellendurchsuchungen

Commands

Im Bereich Commands erhalten Sie z.B. folgende Informationen zu den SQL-Anweisungen:

Anweisungstyp | Erläuterung
SQL-Kommandos | Anzahl der SQL-Anweisungen, die zur Ausführung an das Datenbanksystem gesendet wurden. Direkter Indikator der Datenbankaktivität.
Prepares | Anzahl der dynamischen SQL-Anweisungen
Executes | Anzahl der ausgeführten dynamischen SQL-Anweisungen
Rollbacks | Bezeichnen nicht erfolgreiche Datenbankoperationen, die in der Regel durch abgebrochene Anwendungen entstehen.
Commits | Bezeichnen erfolgreiche Datenbankoperationen. Das Verhältnis von ROLLBACK- zu COMMIT-Aktionen kann auf logische Inkonsistenzen in einer oder mehreren SQL-Anwendungen hinweisen.
Updates, Selects and Fetches, Creates, Alters, Drops, DB procedure calls, Deletes, Inserts | Anzahl der einzelnen SQL-Anweisungen und gegebenenfalls Zeileninformationen

I/O Activity

Im Bereich I/O Activity erhalten Sie Informationen über die I/O-Aktivitäten, die vom Datenbanksystem ausgelöst wurden. Dazu gehören Einzelheiten über logische und physische Lese- und Schreibvorgänge.

Bei einem physischen Lese- oder Schreibvorgang greift das System direkt auf ein Volume zu. Bei einem logischen Zugriff werden dagegen Daten verwendet, die im Data-Cache oder einem anderen Cache abgelegt sind.

Lock Activity

Im Bereich Lock Activity erhalten Sie Informationen über die maximale Anzahl der verfügbaren Datenbanksperren (Available Entries) sowie die Anzahl der Sperren, die gesetzt wurden. Entspricht die Anzahl der gesetzten Sperren in etwa der Anzahl der verfügbaren Einträge, sollten Sie eventuell den Wert für den Strukturlink allgemeinen Datenbankparameter MAXLOCKS erhöhen.

Escalations zeigt die Gesamtanzahl der Zeilen, die von einer einzigen Datenbanksitzung gesperrt wurden. Wenn die Anzahl der von einer Datenbanksitzung gesperrten Zeilen einen bestimmten Prozentsatz übersteigt, sperrt das Datenbanksystem die ganze Tabelle. Der Schwellenwert für Escalations richtet sich nach dem Wert für MAXLOCKS dieser Datenbankinstanz.

Wird ein gesperrtes Objekt noch einmal angefordert, entsteht ein Sperrkonflikt. Wenn in Ihrem System zahlreiche Sperrkonflikte auftreten, wird eine bestimmte Sperre entweder zu lange gehalten, oder mehrere Benutzer greifen häufig auf die gleiche Datenbankzeile zu.

Die Werte für Lock Owner und Lock Requestor beziehen sich auf die Sperren zum Zeitpunkt der Transaktionsausführung.

Scan and Sort Activity

Im Bereich Scan and Sort Activity erhalten Sie unter anderem Informationen über die Tabellendurchsuchungen (Tabellen-Scans).

Da eine hohe Anzahl von sequentiellen Suchvorgängen in Tabellen die Datenbank-Performance beeinträchtigen kann, sollten Sie dafür sorgen, dass diese Suchvorgänge auf ein Minimum reduziert werden.


Datenbankparameter anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbankparameter anzeigen

Sie können im Database Manager GUI eine Anzeige aller Datenbankparameter und eine chronologische Auflistung aller erfolgten Parameteränderungen erhalten.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® Parameters.

3. Die Datenbankparameteranzeige ist in folgende Bereiche unterteilt:

¡ General: Anzeige der allgemeinen Datenbankparameter

¡ Extended: Anzeige der speziellen Datenbankparameter

¡ Support: Anzeige der Supportparameter

¡ History: Sie können anhand der Historie der Parameter verfolgen, wann die Parametereinstellung geändert wurde, welchen Wert der Parameter hatte und welcher Wert jetzt eingestellt ist. In der Historie werden außerdem benutzerdefinierte Kommentare zu einzelnen Parametern angezeigt.

Siehe auch:

Datenbankparameter anzeigen und ändern

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter


Datenbanksitzungen anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbanksitzungen anzeigen

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® Sessions.

3. Folgende Informationen werden angezeigt:

Name | Name des angemeldeten Datenbankbenutzers
Terminal ID | vom Betriebssystem abhängige Terminal-Identifikation
Task ID | Nummer der User-Task
Session ID | Nummer der Datenbanksitzung
Node | Name des Datenbankrechners
Catalog Cache Size | Größe des für den Datenbankbenutzer verfügbaren Catalog-Cache

Siehe auch:

Datenbanksitzung manuell beenden


Log-Bereichs-Informationen anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Log-Bereichs-Informationen anzeigen

Sie können im Database Manager GUI Informationen zur Größe und aktuellen Auslastung des Log-Bereichs anzeigen lassen.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® Log Area.

Ergebnis

Die Anzeige ist in folgende Bereiche unterteilt:

· Volumes: Angaben zu den Log-Volumes

· Settings: Angaben zu den Log-Einstellungen, Werte der Datenbankparameter MAXLOGVOLUMES und LOG_SEGMENT_SIZE

· Usage: Auslastung des Log-Bereichs

· I/O: Lese- und Schreibaktivitäten pro Log-Volume

· Activity: Zusammenfassung der Log-Aktivitäten

Volumes

Sie erhalten für jedes Log-Volume unter anderem folgende Informationen: Name, Größe, Typ und Pfadangabe im Arbeitsverzeichnis

Settings

Die Redo-Log-Verwaltung kann durch verschiedene Log-Einstellungen gesteuert werden. Diese Einstellungen werden angezeigt.

· Log Mode: siehe dazu Strukturlink Log-Modus
SINGLE: Die Log-Volumes werden nicht gespiegelt.
MIRRORED: Die Log-Volumes werden gespiegelt.

· Overwrite Mode: siehe dazu Strukturlink Überschreibmodus für den Log-Bereich
NORMAL: Der Log-Bereich kann erst nach dem Sichern der Log-Einträge überschrieben werden.
OVERWRITE: Der Log-Bereich wird überschrieben, sofern er voll ist.

· Redo Log Management: siehe dazu Strukturlink Redo-Log-Verwaltung ein- oder ausschalten
ACTIVATED: Die Redo-Log-Verwaltung ist eingeschaltet.
DEACTIVATED: Die Redo-Log-Verwaltung ist ausgeschaltet.

Siehe auch:

Log-Einstellungen ändern

Die maximale Anzahl der Log-Volumes wird durch den Strukturlink allgemeinen Datenbankparameter MAXLOGVOLUMES gesteuert. Der allgemeine Datenbankparameter LOG_SEGMENT_SIZE steuert, wie groß die Segmente bei Log-Sicherungen gewählt werden. Die aktuellen Werte dieser Datenbankparameter werden angezeigt.

Usage

Wenn sich die Datenbankinstanz im Betriebszustand ONLINE befindet, können Sie sich die Auslastung des Log-Bereichs anzeigen lassen.

Total Size | Gesamtgröße des Log-Bereichs
Free Log Area | Freier Log-Bereich
Used Log Area | Belegter Log-Bereich
Unsaved Log Area | Größe des noch nicht gesicherten Log-Bereichs
Log since last data backup | Log-Einträge, die seit der letzten Datensicherung geschrieben wurden

I/O

Wenn sich die Datenbankinstanz im Betriebszustand ONLINE befindet, können Sie sich die Lese- und Schreibaktivität für jedes einzelne Log-Volume anzeigen lassen.

Activity

Log Pages Written | geschriebene Log-Seiten
Wait for Log Writer | gibt an, wie oft darauf gewartet werden musste, dass ein Log-Eintrag geschrieben wurde
Group Commits | gibt an, wie oft mehr als eine Transaktion auf die I/O-Operation einer Log-Seite warten musste
Log I/O Queue Overflow | gibt an, wie oft eine Transaktion mit dem Schreiben eines Log-Eintrags warten musste, weil gerade kein Platz in der Log-Warteschlange war


Systemtabellen anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Systemtabellen anzeigen

Sie können mit dem Database Manager GUI die Systemtabellen anzeigen, die dem Schema SYSINFO zugeordnet sind. Diese Systemtabellen enthalten Informationen zu den Datenbankzuständen.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® System Tables.
Sie erhalten eine Liste von Systemtabellen.

3. Klicken Sie auf die gewünschte Tabelle.

Ergebnis

Sie gelangen in die Anzeige der Zustandsinformationen, die in dieser Systemtabelle abgelegt sind.

Siehe auch:

Referenzhandbuch, Strukturlink Definitionen der Systemtabellen


Diagnosemöglichkeiten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Diagnosemöglichkeiten

Bei Fehlern oder Performance-Problemen bietet Ihnen der Database Manager GUI einige Diagnosemöglichkeiten. Sie können weitere Datenbankwerkzeuge aufrufen und verwenden, um Ihre Performance-Diagnose durchzuführen.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie eine der folgenden Diagnosemöglichkeiten bzw. Datenbankwerkzeuge:

Diagnosemöglichkeiten und Datenbankwerkzeuge

Menübefehl | Bedeutung
Instance ® Check ® Database Structure | Datenbankstrukturen prüfen
Instance ® Check ® Backup | Sicherung prüfen
Instanc ® Check ® Database Server | Datenbankrechner prüfen
Instance ® Check ® Diagnosis Files | Protokolldateien lesen
Instance ® Check ® Database Trace | Datenbank-Trace verwenden
Instance ® Check ® Database Analyzer | Database Analyzer-Informationen anzeigen und löschen
Tools ® SQL Studio | SQL Studio verwenden
Instance ® Command Line | Database Manager CLI verwenden
Instance ® OMS Caches | nur für liveCache-Instanzen; OMS-Caches anzeigen
Instance ® OMS Container | nur für liveCache-Instanzen; OMS-Klassencontainer anzeigen
Instance ® OMS Monitor | nur für liveCache-Instanzen; OMS-Monitor einschalten

Siehe auch:

Anzeigen von Informationen


Sicherung prüfen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Sicherung prüfen

Sie können mit dem Database Manager prüfen, ob eine Sicherung eingelesen werden kann.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Check ® Backup.

3. Starten Sie die gewünschten Schritte jeweils mit Next.

4. Wählen Sie aus, welche Art der Überprüfung Sie durchführen möchten:

○ Check last backup: zuletzt erstellte Sicherung prüfen

○ Check a specified backup from history: bestimmte Sicherung aus der Sicherungshistorie prüfen

○ Check a medium: Sicherung einer bestimmten Sicherungsvorlage prüfen

5. Wählen Sie die zu prüfende Sicherungsvorlage aus.

6. Wählen Sie Start.

Ergebnis

Die Überprüfung der Sicherung wird gestartet.

Wenn die Überprüfung einen Fehler findet, dann wird eine entsprechende Meldung angezeigt.

Siehe auch:

Sichern


Database Analyzer-Informationen anzeigen und löschen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Database Analyzer-Informationen anzeigen und löschen

Sie können mit dem Database Manager GUI Statusangaben zum Database Analyzer anzeigen und Protokolle des Database Analyzer löschen.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die von Ihnen gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Check ® Database Analyzer.

Ergebnis

Sie erhalten Statusangaben des Database Analyzer. Informationen zum Werkzeug Database Analyzer finden Sie in der Dokumentation Database Analyzer.

Wenn Sie die Database Analyzer-Protokolle löschen wollen, wählen Sie Actions ® Delete Protokocls . Geben Sie das Datum ein, ab dem die Protokolldateien des Database Analyzer gelöscht werden sollen.

Siehe auch:

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Database Analyzer

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Database Analyzer


Datenbankrechner prüfen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbankrechner prüfen

Der Database Manager GUI ermöglicht Ihneneinen Überblick über die von der Datenbankinstanz belegten Betriebssystemressourcen, die Aufteilung der Datenbanksitzungen auf die Threads und den Status der aktiven Datenbanksitzungen.

Zusätzlich stehen weitere Funktionen zur Verfügung, die jedoch vornehmlich Supportmitarbeitern und Entwicklern vorbehalten sein sollten

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE oder ADMIN.

Vorgehensweise

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Check ® Database Server.

3. Wählen Sie die gewünschte Informationsart aus.

4. Wählen Sie Actions ® View, um sich die Detailinformationen anzusehen.


Protokolldateien lesen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Protokolldateien lesen

Das Datenbanksystem verfügt über eine Reihe von Protokolldateien. Sie können vom Database Manager GUI aus auf die vorhandenen Protokolldateien zugreifen.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Check ® Diagnosis Files.

3. Wählen Sie die gewünschte Datei aus.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien


Datenbankstrukturen prüfen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbankstrukturen prüfen

Sie können mit dem Database Manager GUI prüfen, ob die Datenbankstrukturen einer Datenbankinstanz konsistent sind. Zusätzlich werden unter anderem die Länge und aufsteigende Reihenfolge der Schlüssel geprüft.

Wir empfehlen, einmal pro Woche eine Datenbankstrukturprüfung durchzuführen.

Eine Datenbankstrukturprüfung ist sehr CPU-intensiv und zeitaufwendig, weil viele I/O-Operationen durchgeführt werden müssen. Planen Sie eine Prüfung im Produktivsystem nur für Zeiten ein, in denen das Datenbanksystem nicht stark ausgelastet ist, oder führen Sie die Prüfung auf einer Datenbankkopie durch (siehe Konzepte des Datenbanksystems, Abschnitt Strukturlink Datenbankkopie).

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE oder ADMIN.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Check ® Database Structure.

3. Wählen Sie die gewünschte Funktion und geben Sie im folgenden Schritt die gewünschten Optionen an.

Funktionen und Optionen zum Prüfen der Datenbankstruktur

Funktion

Betriebszustand

Kommando

Optionen

Prüfen des gesamten Datenbestands

ONLINE

Check database structure in operational state ONLINE

EXCEPT INDEX: Indizes werden nicht überprüft. Mit dieser Option können Sie in der Regel die Prüfung beschleunigen.

Prüfen des gesamten Datenbestands und Bereinigen des Converters

ADMIN

Check database structure and clear converter in operation state ADMIN

Prüfen einer ausgewählten Tabelle

ONLINE

Check database structure for a selected table in operational state ONLINE

WITH LONG CHECK: Wenn die zu überprüfende Basistabelle LONG-Spalten enthält, dann wird geprüft, ob alle dort definierten LONG-Werte existieren. Wegen der Transaktionskonsistenz wird eine SQL-Lesesperre für die Dauer der Prüfung angefordert.

CATALOG: Der Datenbankkatalog für diese Tabelle wird geprüft. Diese Option kann nicht mit den Optionen EXTENDED und WITH LONG CHECK kombiniert werden.

4. Um die Datenbankstrukturprüfung zu starten, wählen Sie Start.

5. Nach dem Ende der Datenbankstrukturprüfung wählen Sie Close.

Ergebnis

Fehler, die bei der Datenbankstrukturprüfung gefunden wurden, werden in die Protokolldatei Database Errors geschrieben. Sie können diese Datei zur weiteren Auswertung öffnen (siehe Protokolldateien lesen).

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankstrukturen prüfen


Datenbank-Trace verwenden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbank-Trace verwenden

Der Database Manager GUI bietet Ihnen die Möglichkeit, in Fehlersituationen den Datenbank-Trace einzuschalten.

Der Datenbank-Trace hat nur bei liveCache-Datenbankinstanzen negative Auswirkungen auf die Performance, bei anderen Datenbankinstanzen können Sie ihn auch im normalen Betrieb verwenden.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die von Ihnen gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Check ® Database Trace.

3. Sie haben die Möglichkeit, die nachfolgend aufgeführten Protokollfunktionen einzeln oder in einer von Ihnen gewählten Kombination auszuführen.

Protokollieren von Datenbankanweisungen allgemein

· Unter der Registerkarte Options markieren Sie in der angebotenen Liste die gewünschten Datenbank-Trace-Optionen. Wenn die Optionen die Auswahl eines Trace-Levels unterstützen, finden Sie in der Spalte Level den Vorschlagswert des Systems.

· Wählen Sie Actions ® Selected Items ON, um den Datenbank-Trace für die gewählten Datenbank-Trace-Optionen einzuschalten.

Wenn Sie das Trace-Level für die gewählten Datenbank-Trace-Optionen ändern möchten, wählen Sie Actions ® Selected Items ON with Level... Sie haben die Möglichkeit ein anderes Trace-Level auszuwählen. Je höher das gewählte Trace-Level ist, um so detaillierter sind die vom Datenbank-Trace gesammelten Informationen.

Mit Actions ® Selected Items OFF schalten Sie den Datenbank-Trace wieder aus.

Protokollieren von Datenbankanweisungen in einer bestimmten Datenbanksitzung

Gemäß Voreinstellung des Systems wird der Datenbank-Trace für alle Datenbanksitzungen geschrieben. Diese Voreinstellung ist änderbar:

1. Wählen Sie die Registerkarte Advanced und markieren Sie die Option Trace session.

2. Wählen Sie aus, ob der Datenbank-Trace für die aktuelle (Current session) oder für eine bestimmte Datenbanksitzung geschrieben werden soll. In diesem Fall geben Sie die Kennung der gewünschten Datenbanksitzung an (Ermitteln der Kennung: Datenbanksitzungen anzeigen).

3. Wählen Sie Actions ® Set Advanced Options.

Protokollieren des Auftretens von bestimmten Fehlern

1. Unter der Registerkarte Advanced markieren Sie die Option Stop on error. Geben Sie den Code des Fehlers ein, bei dessen Auftreten die Erstellung des Datenbank-Trace beendet werden soll.

2. Wählen Sie Actions ® Flush, um die noch im Puffer enthaltenen Informationen in den Trace zu schreiben und damit den Datenbank-Trace vor Erstellung der Protokolldatei zu aktualisieren.

Erstellen und Anzeigen des Datenbank-Trace-Protokolls

1. Unter der Registerkarte Protocol markieren Sie die gewünschten Optionen.

2. Wählen Sie Actions ® Flush, um die noch im Puffer enthaltenen Informationen in den Trace zu schreiben und damit den Datenbank-Trace vor Erstellung der Protokolldatei zu aktualisieren.

3. Wählen Sie Actions ® Make Protocol. Damit wird der Datenbank-Trace in eine lesbare Form umgewandelt.

Um das Protokoll zu öffnen, wählen Sie Instance ® Check ® Diagnosis Files. Markieren Sie die Datei Kernel Trace Protocol und wählen Sie Actions ® View.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Traces


OMS-Caches anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen OMS-Caches anzeigen

Diese Funktion im Database Manager GUI dient dem Support zur Performance-Analyse einer liveCache-Datenbankinstanz.

Voraussetzungen

Die aktuelle Datenbankinstanz ist eine liveCache-Instanz.

Sie befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® OMS Caches.

Ergebnis

Die OMS-Caches werden angezeigt.

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Hauptspeicherbereiche überwachen


OMS-Klassencontainer anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen OMS-Klassencontainer anzeigen

Diese Funktion im Database Manager GUI dient dem Support zur Performance-Analyse einer liveCache-Datenbankinstanz.

Voraussetzungen

Die aktuelle Datenbankinstanz ist eine liveCache-Instanz.

Sie befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® OMS Class Containers

Ergebnis

Informationen zu den Klassencontainern werden angezeigt.

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Klassencontainer


OMS-Monitor einschalten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen OMS-Monitor einschalten

Diese Funktion des Database Manager GUI dient dem Support zur Performance-Analyse einer liveCache-Datenbankinstanz.

Voraussetzungen

Die aktuelle Datenbankinstanz ist eine liveCache-Instanz.

Sie befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Information ® OMS Monitor,

Ergebnis

Der OMS-Monitor wird eingeschaltet.

Siehe auch:

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink OMS-Monitor


Update der Datenbanksoftware (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Update der Datenbanksoftware

Nach einem Update der Datenbanksoftware können Sie mit Hilfe des Database Manager GUI dafür sorgen, dass die neue Softwareversion der Datenbankinstanz bekannt gemacht wird.

Vorgehensweise

1. Führen Sie ein Strukturlink Update der Datenbanksoftware durch.

2. Starten Sie die Datenbankinstanz.
Beim ersten Start des Database Manager GUI nach einem Update der Datenbanksoftware passt der Database Manager GUI die Datenbankparameter automatisch an die mit der neuen Version der Datenbanksoftware ausgelieferten Datenbankparameter an.

3. Wählen Sie Instance ® Configuration ® Upgrade System Tables, um die Systemtabellen zu aktualisieren.

Ergebnis

Der Database Manager legt bei jeder Datenbankparameteränderung eine Kopie der Parameterdatei an.

UNIX: <independent_data_path>/config/<database_name>.<running_number>
Windows: <independent_data_path>\config\<database_name>.<running_number>

<running_number>: Version der Kopie, beginnend bei 01

Falls Fehler bei der Übernahme der Datenbankparamter auftreten, ist es möglich, den Vorgang rückgängig zu machen, indem die Original-Parameterdatei wiederhergestellt wird.

Kopieren Sie dazu mit Hilfe des Programms Database Manager CLI die Datei <database_name>.<running_number> (Kopie der Parameterdatei) wieder nach <database_name> (aktive Parameterdatei) zurück.


Aktualisieren der Systemtabellen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Aktualisieren der Systemtabellen

Bei einem Update der Datenbanksoftware können Sie mit Hilfe des Database Manager GUI die Systemtabellen aktualisieren.

Voraussetzungen

Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Vorgehensweise

...

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.

2. Wählen Sie Instance ® Configuration ® Upgrade System Tables.

3. Starten Sie die Aktualisierung der Systemtabellen. Der Database Manager ermittelt den erforderlichen Datenbankbenutzer. Sollte das nicht möglich sein, werden Sie aufgefordert, die entsprechenden Benutzerangaben vorzunehmen.

Ergebnis

Die Systemtabellen werden geladen und aktualisiert. Am Ende des Vorgangs wird das Protokoll dbm.ins (Installation Protocol) angezeigt.

Wenn ein Fehler auftritt, erscheint der Status ERROR. Öffnen Sie in diesem Fall das Installation Protocol wie in Protokolldateien lesen beschrieben.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien, Strukturlink Benutzer, Authentifizierung und Berechtigungen

Referenzhandbuch, Strukturlink Systemtabellen


SQL Studio verwenden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen SQL Studio verwenden

Sie können aus dem Database Manager GUI heraus das Query Tool SQL Studio aufrufen und über das SQL Studio auf die Daten einer Datenbankinstanz zugreifen.

Voraussetzungen

Sie haben die Berechtigung eines Datenbankbenutzers dieser Datenbankinstanz.

Vorgehensweise

Wählen Sie Tools ® SQL Studio.

Informationen zu diesem Werkzeug finden Sie in der Dokumentation SQL Studio.


Database Manager CLI verwenden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Database Manager CLI verwenden

Sie können vom Database Manager GUI aus die Kommandozeilenversion des Database Manager, den Database Manager CLI, aufrufen.

Vorgehensweise

1. Markieren Sie in der Liste der Datenbankinstanzen die gewünschte Datenbankinstanz.
Stellen Sie gegebenenfalls die Verbindung zum DBM-Server für diese Datenbankinstanz her.

2. Wählen Sie Instance ® Command Line .

3. Geben Sie die gewünschten DBM-Kommandos ein.

4. Wählen Sie Actions ® Execute.

Ergebnis

Das gewünschte DBM-Kommando wird ausgeführt.

Sie können sich alle DBM-Kommandos, die vom Database Manager GUI bei seinen Aktionen zur Verwaltung einer Datenbankinstanz ausgeführt werden, in der Database Manager-Konsole anzeigen lassen.

Siehe auch:

Anzeigen von Informationen


Database Manager CLI (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Database Manager CLI

Einsatzmöglichkeiten

Sie verwenden das Datenbankwerkzeug Database Manager CLI zum Verwalten von Datenbankinstanzen. Sie können damit unter anderem Datenbankinstanzen anlegen, überwachen, sichern und wiederherstellen.

Der Database Manager CLI ist ein Kommandozeilenwerkzeug und kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden. Das Programm ist sowohl für den interaktiven Betrieb als auch für den Batch-Betrieb geeignet.

Einführungshinweise

Der Database Manager CLI ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie in Konzepte des Datenbanksystems, Strukturlink Download und in der Dokumentation Strukturlink Installationshandbuch.

Ausführliche Beispiele für ausgewählte Aufgaben bei der Verwaltung von Datenbankinstanzen mit Hilfe des Database Manager CLI finden Sie im Strukturlink Tutorial Datenbankverwaltung.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Integration

Sie können auf die Funktionen des Database Manager CLI mit verschiedenen Programmiersprachen zugreifen. Auf diese Weise können Sie beispielsweise mit Hilfe eines eigenen Programms die Verwaltung von Datenbankinstanzen mittels DBM-Kommandos automatisieren.

Programmierschnittstellen

Programmiersprache | Modul | Dokumentation
Java | powertoys.DBM | Strukturlink Java-Handbuch
Perl | SAP::DBTech::dbm | Strukturlink Perl-Handbuch
Python | sdb.dbm | Strukturlink Python-Handbuch

Funktionsumfang

Funktionsweise des Database Manager CLI

Kommandoreferenz für das Arbeiten mit dem Database Manager CLI

Übersicht aller DBM-Kommandos

Das Datenbankwerkzeug Database Manager GUI hat einen ähnlichen Funktionsumfang wie der Database Manager CLI, bietet aber eine andere Benutzeroberfläche.


Funktionsweise des Database Manager CLI (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Funktionsweise des Database Manager CLI

Der Database Manager CLI ist das Client-Programm des Database Manager. Mit diesem Programm stellen Sie die Verbindung zum DBM-Server auf dem Rechner her, auf dem eine neue Datenbankinstanz angelegt oder eine bereits existierende Datenbankinstanz verwaltet werden soll.

Beim Anlegen einer Datenbankinstanz definieren Sie den allerersten Benutzer der Datenbankinstanz. Er heißt erster DBM-Benutzer.

Zunächst kann sich nur dieser Benutzer über den Database Manager an die neue Datenbankinstanz anmelden. Während der Konfiguration einer neuen Datenbankinstanz definieren Sie dann den Datenbanksystemadministrator.

Der erste DBM-Benutzer und der Datenbanksystemadministrator können sich an alle Datenbankwerkzeuge anmelden. Sie haben die umfassendsten Rechte für die Arbeit mit der Datenbankinstanz. Mit Hilfe von DBM-Kommandos und DBM-Optionen können Sie Datenbankbenutzer und erforderlichenfalls weitere DBM-Benutzer für diese Datenbankinstanz anlegen.

Nur der Datenbanksystemadministrator und die DBM-Benutzer können sich an den Database Manager anmelden, um mit Hilfe von DBM-Kommandos jene Datenbankinstanzen zu verwalten, für die sie angelegt wurden.

Die Ausführung von DBM-Kommandos setzt voraus, dass der jeweilige Benutzer über die notwendigen Serverberechtigungen verfügt. Der erste DBM-Benutzer und der Datenbanksystemadministrator haben alle Serverberechtigungen.

Für das Ausführen von DBM-Kommandos muss die aktuelle Datenbankinstanz im Betriebszustand ONLINE sein. Ausnahmen hiervon sind in den Voraussetzungen für die Ausführung eines DBM-Kommandos explizit angegeben.

Jeder Aufruf des Database Manager CLI entspricht dem Aufbau einer Sitzung. Wenn das eingegebene DBM-Kommando abgearbeitet ist, wird die Sitzung mit dem Database Manager vom System geschlossen. Wenn Sie eine Folge von mehreren DBM-Kommandos ausführen wollen, rufen Sie den Database Manager CLI im Sitzungsmodus auf.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Betriebsmodi im Database Manager CLI

Konzepte des Datenbanksystems, Strukturlink Benutzer, Authentifizierung und Berechtigungen


Aufrufen des Database Manager CLI (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Aufrufen des Database Manager CLI

Verwendung

Zusammen mit dem Aufruf des Programms Database Manager CLI können Sie DBM-Optionen und jeweils maximal ein DBM-Kommando angeben.

Für DBM-Optionen können Sie zusätzliche Parameter angeben. Welche Parameter möglich sind, ist in der Beschreibung der jeweiligen DBM-Option erläutert.

Wenn Sie DBM-Optionen zusammen mit Parametern verwenden, markieren Sie den Beginn des nachfolgenden DBM-Kommandos mit der Option –c (Kennzeichnen als DBM-Kommando: -c).
Sie vermeiden damit, dass das Programm Database Manager den Beginn des DBM-Kommandos als Parameter der zuvor angegebenen DBM-Option interpretiert.

Für das DBM-Kommando können Sie zusätzliche Kommandooptionen angeben. Erläuterungen zu den möglichen Kommandooptionen finden Sie in der Beschreibung des jeweiligen DBM-Kommandos.

Für lange DBM-Kommandos stehen Ihnen Eingabehilfen zur Verfügung.

Zum Format der Rückgabewerte auf DBM-Kommandos siehe Antwortformat.

Syntax

>dbmcli [<dbm_options>] [<dbm_command> [command_options]]

Beispiele

Angabe von DBM-Optionen mit Parametern sowie eines DBM-Kommandos

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem entfernten Rechner PARMA, Anzeigen des Betriebszustandes der Datenbankinstanz:

>dbmcli –u OLEG,MONDAY –d DEMODB –n PARMA db_state

OK

State

ONLINE

Angabe einer DBM-Option ohne Parameter sowie eines DBM-Kommandos

...

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem lokalen Rechner, Starten des Sicherungsvorganges mit Hilfe der Sicherungsvorlage DemoDataCompl

Die Utility-Sitzung soll mit den Benutzerdaten gemäß Vorschlagswert, d. h. den Daten des ersten DBM-Benutzers, eröffnet werden. Geben Sie deshalb die Option zum Eröffnen der Utility-Sitzung ohne Parameter an. Das DBM-Kommando zum Starten des Sicherungsvorganges müssen Sie mit –c kennzeichnen:

>dbmcli -u OLEG,MONDAY -d DEMODB –uUTL –c backup_start DemoDataCompl

OK

Returncode 0

Date 20060418

Time 00131245

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

...

...


DBM-Optionen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation DBM-Optionen

Verwendung

Beim Aufrufen des Database Manager CLI können Sie mehrere DBM-Optionen und genau ein DBM-Kommando angeben.

Zu vielen der DBM-Optionen können Sie optional Parameter angeben. Wenn Sie diese nicht angeben, werden Vorschlagswerte verwendet.

Wenn Sie DBM-Optionen mit Parametern angeben, müssen Sie den Beginn des nachfolgenden DBM-Kommandos mit der DBM-Option –c kennzeichnen. Auf diese Weise vermeiden Sie, dass der Database Manager das nachfolgende DBM-Kommando als Parameter der zuvor angegebenen DBM-Option interpretiert.

Siehe auch:

Aufrufen des Database Manager CLI

Funktionsumfang

Folgende DBM-Optionen stehen zur Verfügung:

Option | Beschreibung
-c | Kennzeichnen als DBM-Kommando
-d | Name der Datenbankinstanz
-e | Verschlüsselung aktivieren
-i | -ic | -is | -ics | Name des Eingabeskripts
-n | Name des Datenbankrechners
-o | Name der Ausgabedatei
-R | Installationsverzeichnis der Datenbankinstanz
-t | Name der Protokolldatei
-uSQL | Eröffnen einer SQL-Sitzung
-uSRV | Eröffnen einer Servicesitzung
-uUTL | Eröffnen einer Utility-Sitzung
-ud | Löschen von XUSER-Einträgen
-uk | Benutzerschlüssel
-us | Anlegen oder Ändern von XUSER-Einträgen
-ux | Anmelden an das Programm XUSER
-ul | Anzeigen von XUSER-Daten

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen des Inhalts der Datenbank-Systemtabelle users ohne explizite Angabe eines Datenbankbenutzers.

Mit der Option –c markieren Sie den Beginn des DBM-Kommandos. Für den Datenbankbenutzer wird der Vorschlagswert (Datenbanksystemadministrator) verwendet.

dbmcli -u OLEG,MONDAY -d DEMODB -uSQL –c db_execute SELECT * FROM users

OK
END

'OLEG';'';'OLEG';'ADMIN';'MULTIPLE';(null);(null);(null);'DEFAULT';'20050602';'0

0104503';'20050602';'00104503';'20050602';'00104503';'DEMODB';'p59963.dhcp.ber.s

ap.corp';0;'NO';(null)

'DBADMIN';'';'DBSERVICE';'DBA';'MULTIPLE';(null);(null);(null);'DEFAULT';'200506

02';'00104508';'20050602';'00104508';'20050602';'00104508';'DEMODB';'p59963.dhcp

.ber.sap.corp';6;'YES';(null)

'DBADMIN';'';'DBADMIN';'SYSDBA';'MULTIPLE';(null);(null);(null);'DEFAULT';'20050

602';'00104503';'20050602';'00104506';'20050602';'00104503';'DEMODB';'p59963.dhc

p.ber.sap.corp';10;'NO';(null)

'DBADMIN';'';'MONA';'DBA';'MULTIPLE';(null);(null);(null);'DEFAULT';'20050602';'

00104523';'20050602';'00104523';'20050602';'00104523';'DEMODB';'p59963.dhcp.ber.

sap.corp';24;'NO';(null)


-c: Kennzeichnen als DBM-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -c: Kennzeichnen als DBM-Kommando

Verwendung

Wenn Sie eine DBM-Option mit optionalen Parametern verwenden, dann müssen Sie diese logisch von einem nachfolgenden DBM-Kommando abgrenzen. Zu diesem Zweck fügen Sie die DBM-Option –c ein. Der Database Manager CLI interpretiert dann alle nach –c folgenden Angaben als DBM-Kommando.

Syntax

-c <dbm_command>

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Starten des Sicherungsvorganges mit Hilfe der Sicherungsvorlage DemoDataCompl

Die Utility-Sitzung soll mit den Benutzerdaten gemäß Vorschlagswert, d. h. den Daten des ersten DBM-Benutzers, eröffnet werden. Die Option zum Eröffnen der Utility-Sitzung wird deshalb ohne Parameter angegeben.

● Ohne Angabe von -c zwischen den optionalen Parametern der DBM-Option und dem DBM-Kommando wird das DBM-Kommando als Benutzername/Kennwort-Kombination für die DBM-Option –uUTL interpretiert. Sie erhalten eine Fehlermeldung:

>dbmcli -u OLEG,MONDAY -d DEMODB –uUTL backup_start DemoDataCompl

ERR

-24996,ERR_PARAM: Wrong parameters

-24753,ERR_MISSDBUSRPWD: Missing database, user or password

● Mit der Option –c markieren Sie den Beginn des DBM-Kommandos. Das DBM-Kommando wird erfolgreich ausgeführt:

>dbmcli -u OLEG,MONDAY -d DEMODB –uUTL –c backup_start DemoDataCompl

OK

Returncode 0

Date 20060418

Time 00131245

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

...

...


-d: Name der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -d: Name der Datenbankinstanz

Verwendung

Sie geben an, zu welcher Datenbankinstanz der Database Manager die Verbindung herstellen soll.

Der angegebene Name gilt für die gesamte Sitzung. Alle datenbankspezifischen DBM-Kommandos beziehen sich auf diese Datenbankinstanz.

Beim Aufbau der Sitzung prüft das System, ob der angegebene Name der Datenbankinstanz auf dem Datenbankrechner in der Liste der registrierten Datenbankinstanzen registriert ist. Wenn dies nicht der Fall ist, dann wird die Eröffnung der Sitzung abgelehnt.

Voraussetzung

Die angegebene Datenbankinstanz ist vorhanden und im Database Manager registriert.

Syntax

-d <database_name>

<database_name>

Name der Datenbankinstanz

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen des Betriebszustandes der Datenbankinstanz:

>dbmcli –u OLEG,MONDAY –d DEMODB db_state

OK

ONLINE


-e: Verschlüsselung aktivieren (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -e: Verschlüsselung aktivieren

Verwendung

Sie schalten die Verschlüsselungsfunktion ein und wählen die Verschlüsselungsmethode für die Kommunikation.

Sie können diese DBM-Option nur im Zusammenhang mit der DBM-Option –n (Name des Datenbankrechners) verwenden.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenverschlüsselung

Voraussetzungen

Sie haben Ihr System für die Verschlüsselung konfiguriert.

Syntax

-e <encryption>

<encryption>

Verschlüsselungsmethode,

mögliche Werte sind:
SSL (aktuell wird nur die SSL/TLS-Verschlüsselung und diese nur in SAP-Systemen unterstützt)


-i | -ic | -is | -ics: Name des Eingabeskripts (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -i | -ic | -is | -ics: Name des Eingabeskripts

Verwendung

Sie geben den Namen des Eingabeskripts an, das die auszuführenden DBM-Kommandos enthält.

Geben Sie mit Hilfe der geeigneten Option an, ob die Abarbeitung des Skripts bei Auftreten eines Fehlers abgebrochen oder fortgesetzt bzw. ob der Database Manager nach der Abarbeitung des Skripts im Sitzungsmodus stehen bleiben soll.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Skriptdatei verwenden

Syntax

-i <file_name> | -ic <file_name> | -is <file_name> | -ics <file_name>

Optionen

Option | Beschreibung
-i <file_name> | Pfad und Name des Eingabeskripts, bei Auftreten eines Fehlers bricht die Abarbeitung des Skripts ab
-ic <file_name> | Pfad und Name des Eingabeskripts, bei Auftreten eines Fehlers wird die Abarbeitung des Skripts fortgesetzt
-is <file_name> | Pfad und Name des Eingabeskripts, nach erfolgreicher Abarbeitung des Skripts bleibt der Database Manager im Sitzungsmodus, im Falle eines Fehlers werden die Abarbeitung des Skripts und der Sitzungsmodus abgebrochen
-ics <file_name> | Pfad und Name des Eingabeskripts, der Database Manager bleibt nach erfolgreicher Abarbeitung des Skripts aber auch nach Auftreten eines Fehlers im Sitzungsmodus

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ausführen der im Verzeichnis C:\test\scripts im Eingabeskript input.dbm enthaltenen DBM-Kommandos:

>dbmcli -u OLEG,MONDAY –d DEMODB –i C:\test\scripts\input.dbm

OK

<reply_to_first_DBM_command_in_script>

OK

<reply_to_second_DBM_command_in_script>

...


-n: Name des Datenbankrechners (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -n: Name des Datenbankrechners

Verwendung

Sie können mit Hilfe dieser Option auf einen entfernten Rechner zugreifen, um dort eine neue Datenbankinstanz anzulegen oder die Verbindung zu einer vorhandenen Datenbankinstanz herzustellen.

Sie geben mit dieser Option den Namen des entsprechenden Rechners an.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Sichern der Datenbankinstanz auf einem entfernten Rechner

Voraussetzungen

● Auf dem Datenbankrechner ist das Programm Strukturlink X-SERVER aktiv (Status: Started).

● Zum Anlegen einer neuen Datenbankinstanz auf einem entfernten Rechner, benötigen Sie einen Betriebssystembenutzer für diesen Rechner. Dieser muss das Recht "logon as batch job" haben.

Informationen, wie Sie einem Benutzer dieses Recht zuweisen, finden Sie in Ihrer Betriebssystem-Benutzerdokumentation.

Syntax

-n <database_computer>

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem Rechner GENUA, Anzeigen des Betriebszustandes der Datenbankinstanz:

>dbmcli –u OLEG,MONDAY –d DEMODB –n GENUA db_state

OK

ONLINE


-o: Name der Ausgabedatei (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -o: Name der Ausgabedatei

Verwendung

Sie definieren den Pfad und Namen der Datei, in die alle Ausgaben des Database Manager geschrieben werden sollen.

Syntax

-o <file_name>

<file_name>

Pfad und Name der Ausgabedatei

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ausführen der im Verzeichnis C:\test\scripts im Eingabeskript input.dbm enthaltenen DBM-Kommandos und Ausgeben der Antworten auf die DBM-Kommandos in der Datei C:\test\outfiles\output.txt:

>dbmcli –u OLEG,MONDAY –d DEMODB –i C:\test\scripts\input.dbm –o C:\test\outfiles\output.txt


-R: Installationsverzeichnis der Datenbanksoftware (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -R: Installationsverzeichnis der Datenbanksoftware

Verwendung

Auf einem Datenbankrechner können mehrere Versionen der Software des Datenbanksystems vorhanden sein. Wenn Sie eine neue Datenbankinstanz anlegen oder DBM-Kommandos ausführen, die sich nicht auf eine bestimmte Datenbankinstanz und damit eine bestimmte Softwareversion beziehen, dann geben Sie mit dieser Option an, auf welche Softwareversion sich das nachfolgende DBM-Kommando beziehen soll. Beim Aufbau der Sitzung wird geprüft, ob die angegebene Softwareversion auf dem Rechner in der Liste der registrierten Versionen vorhanden ist. Wenn dies nicht der Fall ist, dann wird das Eröffnen der Sitzung abgelehnt.

Beim Aufruf des Database Manager CLI kann mit Hilfe der Option -R nur dann die Verbindung zu einer bestimmten Version der Datenbanksoftware hergestellt werden, wenn diese Version zuvor korrekt registriert wurde. (Siehe: inst_reg).

Wenn Sie zusätzlich zur Option -R die Option -d und den Namen einer Datenbankinstanz angeben, dann wird die Option -R ignoriert. Der Database Manager CLI verwendet in diesem Fall die der Datenbankinstanz zugeordnete Version der Datenbanksoftware.

Um die registrierten Versionen der Datenbanksoftware und die Installationspfade anzuzeigen, verwenden Sie das DBM-Kommando dbm_version INSTROOT (Siehe: dbm_version).

Syntax

-R <dependent_path>

Beispiele

Anlegen einer neuen Datenbankinstanz

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Anlegen der Datenbankinstanz DEMODB mit der unter dem Pfad C:\Program Files\sdb\7600abgelegten Softwareversion auf dem entfernten Rechner GENUA, Identifizierung auf diesem Rechner als Betriebssystembenutzer ANNA mit dem Kennwort MAY:

>dbmcli -R "C:\Program Files\sdb\7600" –n GENUA db_create DEMODB OLEG,MONDAY ANNA,MAY

OK

Anzeigen aller vorhandenen Datenbankinstanzen einer bestimmten Softwareversion

Aufrufen des Database Manager CLI mit der Option –R und dem Installationspfad der Softwareversion 7.6, Ausführen des DBM-Kommandos zum Anzeigen der Liste aller auf dem lokalen Rechner unter der angegebenen Version registrierten Datenbankinstanzen:

>dbmcli -R "C:\Program Files\sdb\DEMODB" db_enum

OK

DEMODB C:\Program Files\SDB\DEMODB 7.6.00.16 slow offline

DEMODB C:\Program Files\SDB\DEMODB 7.6.00.16 fast running


-t: Name der Protokolldatei (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -t: Name der Protokolldatei

Verwendung

Das zusammen mit dieser DBM-Option übergebene DBM-Kommando wird ausgeführt. Die Antwort wird auf der Kommandozeile angezeigt und zusätzlich in der angegebenen Datei protokolliert. Der in der Datei gegebenenfalls bereits vorhandene Inhalt bleibt erhalten.

Syntax

-t <file_name>

<file_name>

Pfad und Name der Protokolldatei

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Speichern der an Database Manager gesandten Kommandozeile mit DBM-Option/en und DBM-Kommando sowie der Antwort des Database Manager in der Protokolldatei log.txt im Verzeichnis <user_home>\logfiles\:

>dbmcli –u OLEG,MONDAY –d DEMODB –t <user_home>\logfiles\log.txt db_state

OK

ONLINE


-uSQL: Eröffnen einer SQL-Sitzung (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -uSQL: Eröffnen einer SQL-Sitzung

Verwendung

Eine Reihe von DBM-Kommandos setzen eine SQL-Sitzung voraus, bevor sie ausgeführt werden dürfen.

Wenn Sie bei der Anmeldung an den Database Manager CLI zusätzlich diese DBM-Option angeben, dann wird implizit das DBM-Kommando zum Eröffnen einer SQL-Sitzung ausgeführt (Siehe: sql_connect).

Wenn Sie zusätzlich die Daten eines Datenbankbenutzers angeben, dann wird die SQL-Sitzung mit diesen Benutzerdaten zu der angegebenen Datenbankinstanz eröffnet. Wenn Sie keinen Benutzer angeben, werden die Daten des ersten DBM-Benutzers (Vorschlagswert des Database Manager) verwendet..

Das Eröffnen einer SQL-Sitzung ist jedoch nur dann erfolgreich, wenn der im Database Manager CLI angemeldete DBM-Benutzer über die erforderliche Serverberechtigung für die Ausführung des DBM-Kommandos zum Eröffnen einer SQL-Sitzung verfügt.

Wenn Sie den Database Manager CLI beenden, dann wird auch die SQL-Sitzung beendet.

Beachten Sie die unterschiedliche Bedeutung des Kommandos bei Groß- und Kleinschreibung.

-uSQL: Angabe des mit Benutzername und Kennwort ausgewiesenen Datenbankbenutzers

-USQL: Anmeldung mit einem in der XUSER-Datei hinterlegten Benutzerschlüssel eines Datenbankbenutzers.

Siehe auch: Utilities, Strukturlink XUSER

Der mit Benutzername und Kennwort oder als Benutzerschlüssel angegebene Datenbankbenutzer muss für die unter der DBM-Option -d angegebene Datenbankinstanz angelegt sein, andernfalls schlägt das DBM-Kommando fehl.

Ein unter einem angegebenen Benutzerschlüssel eventuell gespeicherter Datenbankname wird beim Eröffnen der SQL-Sitzung ignoriert.

Syntax

-uSQL [<database_user>,<database_user_password>] | -USQL <user_key>

Beispiele für -uSQL

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ausführen der SQL-Anweisung zum Anzeigen des Inhalts der Datenbanktabelle columns als Datenbankbenutzer MONA mit dem Kennwort RED:

>dbmcli -u OLEG,MONDAY -d DEMODB -uSQL MONA,RED db_execute SELECT * FROM columns

OK

CONTINUE

'DBADMIN';'DBADMIN';'ALLOCATORSTATISTIC';'ALLOCATOR';'OPT';'CHAR';'ASCII';40;(nu

ll);'YES';'SEL+';(null);(null);(null);(null);1;(null);2;'20060406';'00145007';'2

0060406';'00145007';'SYSTEM';(null)

'DBADMIN';'DBADMIN';'ALLOCATORSTATISTIC';'USED_BYTES';'OPT';'FIXED';'';20;0;'YES

';'SEL+';(null);(null);(null);(null);2;(null);3;'20060406';'00145007';'20060406'

;'00145007';'SYSTEM';(null)

...

...

Beispiel für -USQL

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ausführen der SQL-Anweisung zum Anzeigen des Inhalts der Datenbanktabelle columns für den unter dem Benutzerschlüssel MOKEY registrierten Datenbankbenutzer:

>dbmcli -u OLEG,MONDAY -d DEMODB -USQL MOKEY db_execute SELECT * FROM columns

OK

CONTINUE

'DBADMIN';'DBADMIN';'ALLOCATORSTATISTIC';'ALLOCATOR';'OPT';'CHAR';'ASCII';40;(nu

ll);'YES';'SEL+';(null);(null);(null);(null);1;(null);2;'20060406';'00145007';'2

0060406';'00145007';'SYSTEM';(null)

'DBADMIN';'DBADMIN';'ALLOCATORSTATISTIC';'USED_BYTES';'OPT';'FIXED';'';20;0;'YES

';'SEL+';(null);(null);(null);(null);2;(null);3;'20060406';'00145007';'20060406'

;'00145007';'SYSTEM';(null)

...

...


-uSRV: Eröffnen einer Servicesitzung (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -uSRV: Eröffnen einer Servicesitzung

Verwendung

Bestimmte DBM-Kommandos setzen eine Servicesitzung voraus, bevor sie ausgeführt werden dürfen.

Wenn Sie bei der Anmeldung an den Database Manager CLI zusätzlich diese DBM-Option angeben, dann wird implizit das DBM-Kommando zum Eröffnen einer Servicesitzung ausgeführt (Siehe: service_connect).

Wenn Sie den Database Manager CLI beenden, dann wird auch die Servicesitzung beendet.

Syntax

-uSRV

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Aufbau einer Servicesitzung und Einlesen der Parameterdatei dieser Datenbankinstanz aus der mit der Sicherungsvorlage DemoDataCompl erstellten Sicherung:

>dbmcli –u OLEG,MONDAY –d DEMODB –uSRV recover_config DemoDataCompl

OK


-uUTL: Eröffnen einer Utility-Sitzung (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -uUTL: Eröffnen einer Utility-Sitzung

Verwendung

Eine Reihe von DBM-Kommandos setzen eine Utility-Sitzung zur Datenbankinstanz voraus, bevor sie ausgeführt werden können.

Wenn Sie bei der Anmeldung an den Database Manager CLI zusätzlich diese DBM-Option angeben, dann wird eine Utility-Sitzung zur Datenbankinstanz eröffnet.

Wenn Sie zusätzlich die Daten eines Datenbankbenutzers angeben, dann wird die Utility-Sitzung mit diesen Benutzerdaten zur angegebenen Datenbankinstanz eröffnet. Wenn Sie keinen Benutzer angeben, werden die Daten des ersten DBM-Benutzers (Vorschlagswert des Database Manager) verwendet.

Wenn Sie den Database Manager CLI beenden, dann wird auch die Utility-Sitzung beendet.

Beachten Sie die unterschiedliche Bedeutung des Kommandos bei Groß- und Kleinschreibung.

-uUTL: Angabe des mit Benutzername und Kennwort ausgewiesenen Datenbankbenutzers

-UUTL: Angabe eines in der XUSER-Datei hinterlegten Benutzerschlüssel eines Datenbankbenutzers

Sie übermitteln mit Hilfe dieser DBM-Option die Benutzerdaten des gewünschten Datenbankbenutzers. Die Utility-Sitzung wird daraufhin mit diesen Benutzerdaten zur angegebenen Datenbankinstanz eröffnet. Wenn Sie bei –uUTL keinen Benutzer angeben, verwendet der Database Manager CLI die Daten des ersten DBM-Benutzers.

Wenn Sie bei –UUTL keinen Benutzer angeben, dann versucht der Database Manager, die Benutzerangaben unter dem XUSER-Schlüssel c zu verwenden. Es empfiehlt sich deshalb, einen XUSER-Eintrag mit dem Schlüsselnamen c und den Daten des ersten DBM-Benutzers anzulegen (Siehe: Utilities, Anlegen oder Ändern von XUSER-Einträgen)

Der mit Benutzername und Kennwort oder als Benutzerschlüssel angegebene Datenbankbenutzer muss für die angegebene Datenbankinstanz angelegt sein, andernfalls schlägt das DBM-Kommando fehl.

Ein unter einem angegebenen XUSER-Schlüssel eventuell gespeicherter Datenbankname wird beim Eröffnen der Utility-Sitzung ignoriert.

Siehe auch:

Utilities, XUSER

Tutorial Datenbankverwaltung, Strukturlink Betriebsmodi im Database Manager CLI

Voraussetzungen

● Wenn Sie Administrationskommandos ausführen wollen, benötigen Sie die Serverberechtigung AccessUtility.

● Wenn Sie SQL-Anweisungen ausführen wollen, benötigen Sie die Serverberechtigung AccessSQL.

Syntax

-uUTL [<database_user>,<database_user_password>] | -UUTL [<user_key>]

Optionen

Option | Beschreibung
<database_user> | Name des Datenbankbenutzers
<database_user_password> | Kennwort des Datenbankbenutzers
<user_key> | Benutzerschlüssel

Beispiel für -uUTL

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Eröffnen einer Utility-Sitzung und Starten des Sicherungsvorganges mit Hilfe der Sicherungsvorlage DemoDataCompl

Die Utility-Sitzung soll mit den Benutzerdaten gemäß Vorschlagswert, d. h. den Daten des ersten DBM-Benutzers, eröffnet werden. Die Option zum Eröffnen der Utility-Sitzung wird deshalb ohne Parameter angegeben. Das DBM-Kommando zum Starten des Sicherungsvorganges muss mit –c gekennzeichnet werden:

>dbmcli –u OLEG,MONDAY –d DEMODB –uUTL –c backup_start DemoDataCompl

OK

Returncode 0

Date 20060418

Time 00131245

Server GENUA

Database DEMODB

Kernel Version Kernel 7.6.00 Build 016-123-109-428

...

...

Beispiel für -UUTL

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Eröffnen einer Utility-Sitzung und Ausführen einer SELECT-Anweisung zum Anzeigen des Inhalts der Tabelle users

Die Utility-Sitzung soll mit den Benutzerschlüssel gemäß Vorschlagswert, d. h. den unter dem Benutzerschlüssel c gespeicherten Daten, eröffnet werden. Die Option zum Eröffnen der Utility-Sitzung wird deshalb ohne Parameter angegeben. Das DBM-Kommando zum Ausführen der SELECT-Anweisung muss mit –c gekennzeichnet werden:

>dbmcli –u OLEG,MONDAY –d DEMODB –UUTL –c db_execute SELECT * FROM users

OK

END

'DBM';'';'DBM';'ADMIN';'MULTIPLE';(null);(null);(null);'DEFAULT';'20060406';'001

45004';'20060406';'00145004';'20060406';'00145004';'DEMODB';'GENUA';0;'NO';(null)

'DBADMIN';'';'DBADMIN';'SYSDBA';'MULTIPLE';(null);(null);(null);'DEFAULT';'20060

406';'00145004';'20060406';'00145006';'20060406';'00145004';'DEMODB';'GENUA';10;'NO';(null)

'DBADMIN';'';'MONA';'DBA';'MULTIPLE';(null);(null);(null);'DEFAULT';'20060406';'

00145012';'20060406';'00145012';'20060406';'00145012';'DEMODB';'GENUA';27;'NO';(null)

'DBADMIN';'';'DAVID';'RESOURCE';'MULTIPLE';(null);(null);(null);'DEFAULT';'20060

413';'00133340';'20060413';'00133507';'20060413';'00133340';'DEMODB';'GENUA';29;'NO';(null)


-ud: Löschen von XUSER-Einträgen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -ud: Löschen von XUSER-Einträgen

Verwendung

Sie verwenden die DBM-Option -ud, um die Daten und damit den entsprechenden XUSER-Eintrag eines Datenbankbenutzers im Programm XUSER zu löschen.

Sie müssen sich dazu entweder mit den Daten des zu löschenden Datenbankbenutzers oder mit den unter dem Benutzerschlüssel DEFAULT registrierten Benutzerdaten an XUSER anmelden.

Zur Identifizierung des Benutzers, dessen Daten gelöscht werden sollen, geben Sie eine Kombination aus dem Namen der Datenbankinstanz und des Datenbankrechners oder einen Benutzerschlüssel an.

Verwenden Sie vorzugsweise direkt das Werkzeug XUSER.

Siehe auch: Utilities, Strukturlink XUSER

Anders als bei Benutzernamen und Kennwörtern unterscheidet der Database Manager bei Benutzerschlüsseln zwischen Groß- und Kleinschreibung.

Syntax

-ud

Beispiele

...

1. Aufrufen des Database Manager CLI, Anmelden als der im Programm XUSER zu löschende Benutzer (Beispiel: Benutzer DAVID mit dem Kennwort BLUE),
Zur Identifizierung des zu löschenden Benutzers geben Sie eine Kombination aus Datenbank- und Rechnername an (Beispiel: Datenbankname DEMODB, Datenbankrechner GENUA).

>dbmcli -u <user_name>,<password> -ud -d <database_name> [-n <database_computer>]

>dbmcli -u DAVID,BLUE -ud -d DEMODB -n GENUA

2. Aufrufen des Database Manager CLI, Anmelden mit den unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzerdaten an das Programm XUSER (Beispiel: Benutzer BORIS mit dem Kennwort PINK),
Zur Identifizierung des zu löschenden Benutzers geben Sie eine Kombination aus Datenbank- und Rechnername an (Beispiel: Datenbankname DEMODB, Datenbankrechner GENUA).

>dbmcli –ux <default_user>,<password> -ud -d <database_name> [-n <database_computer>]

>dbmcli -ux BORIS,PINK -ud -d DEMODB -n GENUA

3. Aufrufen des Database Manager CLI, Anmelden als der im Programm XUSER zu löschende Benutzer (Beispiel: Benutzer DAVID mit dem Kennwort BLUE),
Zur Identifizierung des zu löschenden Benutzers geben Sie dessen Benutzerschlüssel (Beispiel: DAKEY) an.

>dbmcli -u <user_name>,<password> -ud -uk <user_key>

>dbmcli -u DAVID,BLUE -ud -uk DAKEY

4. Aufrufen des Database Manager CLI, Anmelden mit den unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzerdaten an das Programm XUSER (Beispiel: Benutzer BORIS mit dem Kennwort PINK),
Zur Identifizierung des zu löschenden Benutzers geben Sie den Benutzerschlüssel des zu löschenden Benutzers an (Beispiel: DAKEY).

>dbmcli -ux <default_user>,<password> -ud -uk <user_key>

>dbmcli -ux BORIS,PINK -ud -uk DAKEY


-uk: Benutzerschlüssel (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -uk: Benutzerschlüssel

Verwendung

Sie verwenden diese Option zur Angabe des Benutzerschlüssels, unter dem der Eintrag im Programm XUSER gespeichert werden soll.

Verwenden Sie vorzugsweise direkt das Werkzeug XUSER.

Siehe auch: Utilities, Strukturlink XUSER

Syntax

-uk <user_key>

Beispiel

Anmelden an den Database Manager CLI (ohne explizite Benutzerangabe, es werden die Daten des ersten DBM-Benutzers verwendet), Anmelden des unter dem Benutzerschlüssel DEFAULT gespeicherten Datenbankbenutzers SAPR3, Kennwort SAP und Eintragen der Daten des Benutzers DAVID Kennwort BLUE unter dem Benutzerschlüssel Newkey

>dbmcli –ux SAPR3,SAP –us DAVID,BLUE –uk Newkey

OK


-us: Anlegen oder Ändern von XUSER-Einträgen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -us: Anlegen oder Ändern von XUSER-Einträgen

Verwendung

Mit der DBM-Option –us legen Sie im Database Manager mit dem Programm XUSER neue XUSER-Einträge für Benutzer an oder überschreiben vorhandene Einträge.

XUSER-Einträge sind Benutzerdatensätze, die durch Benutzerschlüssel definiert sind. Sie erleichtern die Anmeldung an Programme, die XUSER unterstützen. Einen XUSER-Schlüssel können Sie zusammen mit der DBM-Option –U für die Anmeldung an den Database Manager verwenden (Siehe: user_logon). Auf diese Weise können Sie auf die Angabe des Namens und Kennwortes des DBM-Benutzers (DBM-Option –u) verzichten, da der Database Manager CLI die erforderlichen Daten dem entsprechenden XUSER-Eintrag entnimmt.

Verwenden Sie für das Anlegen oder Ändern von XUSER-Einträgen vorzugsweise direkt das Programm XUSER.

Siehe auch: Utilities, Strukturlink XUSER

Zugriff auf die Datenbankinstanz haben Sie mit einem unter einem XUSER-Eintrag gespeicherten Benutzer nur dann, wenn dieser zuvor auch tatsächlich für diese Datenbankinstanz angelegt wurde. DBM-Benutzer müssen mit Hilfe des Database Manager angelegt werden.(Siehe: user_create)
Datenbankbenutzer können mit den Strukturlink Query Tools oder mit Hilfe des Database Manager (Siehe: db_execute) angelegt werden.

Im Unterschied zu Benutzernamen und Kennwörtern unterscheidet der Database Manager bei Benutzerschlüsseln zwischen Groß- und Kleinschreibung. Wenn Sie die Benutzerschlüssel DBMUSR und DEFAULT für die Vorschlagswerte des Database Manager definieren, dann müssen die Benutzerschlüssel mit Großbuchstaben geschrieben werden.

Anlegen von XUSER-Einträgen

Für das Anlegen neuer XUSER-Einträge ist keine Anmeldung an das Programm XUSER erforderlich.

Sie können für einen XUSER-Eintrag einen Benutzerschlüssel definieren, unter dem dieser Eintrag abgelegt werden soll.

Sie können diesen Benutzerschlüssel auch als eine Kombination aus Datenbank- und Rechnername vom Database Manager CLI generieren lassen, indem Sie zusätzlich zum Benutzernamen und Kennwort auch die zugehörige Datenbankinstanz und den Datenbankrechner angeben.

Für die Arbeit im Database Manager empfiehlt es sich, einen XUSER-Eintrag mit dem Benutzerschlüssel DBMUSR und den Benutzerdaten des ersten DBM-Benutzers anzulegen. Der Database Manager CLI versucht bei der Anmeldung an dieses Programm implizit auf diesen Schlüssel zuzugreifen, wenn Sie die DBM-Option –U ohne einen Benutzerschlüssel angeben.

Für andere Funktionen ist die Anmeldung mit den unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzerdaten erforderlich. Es empfiehlt sich daher, auch einen XUSER-Eintrag mit dem Benutzerschlüssel DEFAULT und den Benutzerdaten eines gültigen Datenbankbenutzers anzulegen.

Ändern von XUSER-Einträgen

Für das Ändern von XUSER-Einträgen müssen Sie sich mit den Daten desjenigen Benutzers anmelden, dessen Daten Sie ändern wollen, oder mit den Daten unter dem XUSER-Schlüssel DEFAULT.

Wenn Sie sich mit den Daten unter dem XUSER-Schlüssel DEFAULT anmelden, haben Sie die Berechtigung, jeden XUSER-Eintrag zu ändern. Zur Identifizierung des XUSER-Eintrags, den Sie ändern wollen, verwenden Sie die DBM-Option –uk oder eine Kombination aus dem Datenbank- und dem Rechnernamen (DBM-Optionen -d und –n).

Syntax

-us <new_user_name>,<new_user_password>

Optionen

Option | Beschreibung
<new_user_name> | Name des unter dem Schlüssel neu zu speichernden Benutzers
<new_user_password> | Kennwort des unter dem Schlüssel neu zu speichernden Benutzers

Beispiele

Anlegen eines neues XUSER-Eintrags

...

1. Aufrufen des Database Manager CLI, Anlegen eines neuen XUSER-Eintrags (Beispiel. Benutzer BORIS mit dem Kennwort PINK), Speichern unter einem definierten Benutzerschlüssel (Beispiel: Benutzerschlüssel DEFAULT):

>dbmcli –uk <user_key> –us <new_user_name>,<new_user_password> [options]

>dbmcli –uk DEFAULT –us BORIS,PINK

2. Aufrufen des Database Manager CLI, Anlegen eines neuen XUSER-Eintrags (Beispiel. Benutzer MONA mit dem Kennwort RED), Speichern unter einem definierten Benutzerschlüssel (Beispiel: Benutzerschlüssel MOKEY):

>dbmcli –uk <user_key> –us <new_user_name>,<new_user_password> [options]

>dbmcli –uk MOKEY –us MONA,RED

3. Aufrufen des Database Manager CLI, Anlegen eines neuen XUSER-Eintrags (Beispiel. Benutzer MONA mit dem Kennwort RED), Speichern unter dem Benutzerschlüssel, der aus Datenbank- und Rechnername generiert wird (Beispiel: Datenbankinstanz DEMODB, Rechnername GENUA):

>dbmcli –d <database_name> [-n <database_computer>] –us <new_user_name>,<new_user_password> [options]

>dbmcli –d DEMODB –n GENUA -us MONA,RED

Ändern eines vorhandenen XUSER-Eintrags

...

1. Aufrufen des Database Manager CLI. Anmelden an das Programm XUSER mit den Daten des zu ändernden XUSER-Eintrags mit der DBM-Option -u (Beispiel: Benutzer MONA, Kennwort RED ändern auf Benutzer DAVID, Kennwort BLUE)

a. Spezifizieren des zu ändernden XUSER-Eintrags über Benutzerschlüssel (Beispiel: Benutzerschlüssel MOKEY):

>dbmcli -u <user_name>,<user_password> -uk <user_key> –us <new_user_name>,<new_user_password> [options]

>dbmcli –u DAVID,BLUE –uk DAKEY –us BORIS,PINK

b. Spezifizieren des zu ändernden XUSER-Eintrags über Kombination aus Datenbankname und –rechnername (Beispiel: Datenbankinstanz DEMODB, Rechnername GENUA):

>dbmcli -u <user_name>,<user_password> –d <database_name> [-n <database_computer>] –us <new_user_name>,<new_user_password> [options]

>dbmcli –u DAVID,BLUE –d DEMODB –n GENUA –us BORIS,PINK

2. Aufrufen des Database Manager CLI, Anmelden an das Programm XUSER mit den unter dem XUSER-Schlüssel DEFAULT gespeicherten Daten mit Hilfe der DBM-Option -ux (Beispiel: Benutzer BORIS, Kennwort PINK), und

a. Spezifizieren des zu ändernden XUSER-Eintrags mit Hilfe der DBM-Option –uk (Beispiel: Benutzerschlüssel: DAKEY),
Angabe der neuen Daten mit Hilfe der DBM-Option –us (Beispiel: Benutzer BORIS, Kennwort PINK):

>dbmcli -ux <default_user_name>,<default_user_password> -uk <user_key> –us <new_user_name>,<new_user_password> [options]

>dbmcli –ux BORIS,PINK –uk DAKEY –us BORIS,PINK

b. Spezifizieren des zu ändernden XUSER-Eintrags mit Hilfe der Kombination aus Datenbankname und –rechnername (Beispiel: Datenbankinstanz DEMODB, Rechnername GENUA),
Angabe der neuen Daten mit Hilfe der DBM-Option –us (Beispiel: Benutzer BORIS, Kennwort PINK):

>dbmcli -ux <default_user_name>,<default_user_password> –d <database_name> [-n <database_computer>] –us <new_user_name>,<new_user_password> [options]

>dbmcli –ux MONA,RED –d DEMODB –n GENUA –us BORIS,PINK


-ux: Anmelden an das Programm XUSER (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -ux: Anmelden an das Programm XUSER

Verwendung

Sie verwenden die DBM-Option -ux, um sich aus dem Database Manager CLI heraus mit den Daten unter dem Benutzerschlüssel DEFAULT an das Programm XUSER anzumelden.

Sie können diese DBM-Option zusammen mit den DBM-Optionen zum Ändern (–us) oder Löschen (–ud) von XUSER-Einträgen verwenden.

Verwenden Sie vorzugsweise direkt das Werkzeug XUSER.

Siehe auch: Utilities, Strukturlink XUSER

Voraussetzungen

Sie haben den Benutzernamen und das Kennwort eines gültigen Datenbankbenutzers unter dem Benutzerschlüssel DEFAULT gespeichert.

Syntax

-ux <default_user_name>,<default_user_password>

Optionen

Option | Beschreibung
<default_user_name> | Name des unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzers
<default_user_password> | Kennwort des unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzers

Beispiele

Ändern eines vorhandenen XUSER-Eintrags

>dbmcli -ux <default_user_name>,<default_user_password> -uk <user_key> –us <new_user_name>,<new_user_password> [options]

Aufrufen des Database Manager CLI, Anmelden mit dem unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzer BORIS, Kennwort PINK, Angabe des zu ändernden XUSER-Eintrags mit dem Benutzerschlüssel DAKEY, Angabe des neuen Benutzernamens und –kennworts MONA und RED:

>dbmcli –ux BORIS,PINK –uk DAKEY –us MONA,RED

Löschen eines vorhandenen XUSER-Eintrags

>dbmcli -ux <default_user_name>,<default_user_password> -uk <user_key> -ud

Aufrufen des Database Manager CLI, Anmelden mit dem unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzer BORIS, Kennwort PINK, Angabe des zu löschenden XUSER-Eintrags mit dem Benutzerschlüssel DAKEY, Angabe der DBM-Option –ud zum Löschen dieses Eintrags:

>dbmcli –ux BORIS,PINK –uk DAKEY –ud


-ul: Anzeigen von XUSER-Daten (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation -ul: Anzeigen von XUSER-Daten

Verwendung

Mit Hilfe der DBM-Option –ul lassen Sie sich aus dem Database Manager CLI heraus die im Programm XUSER gespeicherten Benutzerdaten anzeigen. Sie melden sich dazu als der unter dem Benutzerschlüssel DEFAULT gespeicherte Benutzer an das Programm XUSER an (DBM-Option -ux).

Sie erhalten eine Liste der vorhandenen Benutzerschlüssel mit den zugeordneten Benutzernamen.

Siehe auch: Utilities, Strukturlink XUSER

Anders als bei Benutzernamen und Kennwörtern unterscheidet der Database Manager bei Benutzerschlüsseln zwischen Groß- und Kleinschreibung.

Voraussetzungen

Sie haben den Benutzernamen und das Kennwort eines gültigen Datenbankbenutzers unter dem Benutzerschlüssel DEFAULT gespeichert.

Syntax

-ul

Beispiel

Aufrufen des Database Manager CLI, Anmelden an das Programm XUSER mit den unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzer BORIS, Kennwort PINK, Anzeigen einer Liste aller im Programm XUSER gespeicherten XUSER-Einträge:

>dbmcli -ux BORIS,PINK -ul

OK

DEFAULT BORIS

DAKEY DAVID

DBMUSR DBM


DBM-Kommandos (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation DBM-Kommandos

Verwendung

DBM-Kommandos sind Kommandos im Database Manager CLI für das Verwalten von Datenbankinstanzen.

Alle DBM-Kommandos während einer Sitzung mit dem Database Manager beziehen sich auf die Datenbankinstanz, deren Name beim Anmelden an den Database Manager CLI mit Hilfe der Option -d angegeben wurde.

Siehe auch:

Aufrufen des Database Manager CLI

help

Übersicht aller DBM-Kommandos

Voraussetzungen

Das Recht ein DBM-Kommando auszuführen, kann an drei Voraussetzungen gebunden sein:

● die Anmeldungen an den Database Manager (Siehe:user_logon)

● Serverberechtigungen

● die Anmeldung an das Betriebssystem (Siehe: user_system)

Welche dieser Voraussetzungen für die Ausführung eines bestimmten DBM-Kommandos erfüllt sein müssen, entnehmen Sie der Beschreibung für das jeweilige DBM-Kommando.

Syntax

<dbm_command> [<dbm_option_list>]

<dbm_command> :: = <command_name> [<cmd_option_list>]

<cmd_option_list> :: = <command_option> | <command_option> <command_option> ...

<dbm_option_list> :: = <dbm_option> | <dbm_option> <dbm_option> ...

Option | Beschreibung
<command_name> | DBM-Kommandoname
<command_option> | Kommandooption (siehe Beschreibung des jeweiligen DBM-Kommandos)
<dbm_option> | DBM-Option


Betriebsmodi im Database Manager (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Betriebsmodi im Database Manager

Verwendung

Im Programm Database Manager CLI haben Sie die Möglichkeit, die aufgeführten DBM-Kommandos einzeln nacheinander in der angegebenen Reihenfolge auszuführen und dazu für jedes Kommando den Database Manager CLI aufzurufen, der nach Ausführung dieses Kommandos wieder geschlossen wird (Kommandomodus).

Ebenso ist es möglich, den Database Manager CLI im Sitzungsmodus aufzurufen und die DBM-Kommandos nacheinander auszuführen, ohne dass Sie sich mehrfach an den Database Manager anmelden (Sitzungsmodus).

Eine dritte Möglichkeit ist die Erstellung eines Skripts, das anschließend im Database Manager CLI aufgerufen und abgearbeitet wird (Skriptmodus).

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Kommandomodus verwenden, Strukturlink Sitzungsmodus verwenden, Strukturlink Skriptmodus verwenden


Eingabehilfen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Eingabehilfen

Verwendung

Für die Eingabe von DBM-Kommandos auf der Kommandozeile stehen Ihnen die Eingabehilfen des Database Manager zur Verfügung.

Sie können damit mehrzeilige Eingaben im Database Manager verknüpfen, Zeilen als Kommentar kennzeichnen und damit ihre Ausführung unterbinden, oder Kommandos an das lokale Betriebssystem übergeben, ohne das Eingabefenster des Database Manager verlassen zu müssen.

Voraussetzungen

Sie befinden sich im Skriptmodus oder Sitzungsmodus.

Funktionsumfang

Folgende Eingabehilfen stehen zur Verfügung:

Syntax | Beschreibung
# | Kommentar
! | Lokaler Systemaufruf
/ | Zeilenverknüpfung
< | Zeilenverknüpfung


Kommentar: # (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Kommentar: #

Verwendung

Wenn Sie ein Kommando mit einem Nummernzeichen beginnen, dann wird es vom Database Manager ignoriert und nicht ausgeführt.

Voraussetzung

Sie haben den Database Manager CLI im Sitzungsmodus oder im Skriptmodus aufgerufen.

Syntax

#<dbm_command>


Lokaler Systemaufruf: ! (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Lokaler Systemaufruf: !

Verwendung

Sie sind an den Database Manager angemeldet und wollen ein Kommando im Betriebssystem des lokalen Rechners ausführen. Sie müssen dazu nicht das Eingabefenster das Database Manager verlassen. Wenn Sie dem Kommando ein Ausrufungszeichen voranstellen, dann wird es nicht an den Database Manager übergeben, sondern im lokalen Kommandointerpreter des Betriebssystems ausgeführt.

Voraussetzungen

Sie haben den Database Manager CLI im Skriptmodus oder im Sitzungsmodus aufgerufen.

Syntax

!<os_command>

Beispiel

dbmcli>!dir


Zeilenverknüpfung: / (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Zeilenverknüpfung: /

Verwendung

Wenn Sie ein mehrzeiligen DBM-Kommando eingeben wollen, schließen Sie jede Zeile mit einem Schrägstrich ab. Dies ist für das System das Zeichen, dass das Kommando noch nicht vollständig ist. Wenn Sie am Ende einer mit einem Schrägstrich abgeschlossenen Zeile Enter wählen, wird das Kommando noch nicht ausgeführt.

Erst wenn Sie Enter wählen, ohne dass Sie in der aktuellen Zeile einen Schrägstrich eingegeben haben, wird das gesamte Kommando an den Database Manager übermittelt und ausgeführt.

Voraussetzung

Sie haben den Database Manager CLI im Sitzungsmodus oder Skriptmodus aufgerufen.

Syntax

<command_line_beginning>/

<command_line_continued>/

<command_line_continued>/

<command_line_end>

Beispiel

>dbm_version/

BUILD

OK

DBMServer 7.6.00 Build 009-103-092-650


Zeilenverknüpfung: < (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Zeilenverknüpfung: <

Verwendung

Mit dem Zeichen „kleiner als“ (<) können Sie mehrzeilige Kommandos an den Database Manager übermitteln. Die Zeichenkette <command_line_beginning> wird solange mit den Folgezeilen verknüpft, bis eine Zeile gefunden wird, die mit <stop_token> beginnt.

Die Zeile mit <stop_token> fließt nicht in das Kommando ein.

Voraussetzung

Sie haben den Database Manager CLI im Skriptmodus oder Sitzungsmodus aufgerufen.

Alle Zeilen sind durch Zeilenvorschub voneinander getrennt.

Syntax

'<'<stop_token> <command_line_beginning>

Beispiel

><stop dbm_version

BUILD

stop

OK

DBMServer 7.6.00 Build 009-103-092-650


Antwortformat (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Antwortformat

Wenn ein DBM-Kommando oder ein Skript mit DBM-Kommandos im Database Manager ausgeführt wurde, erhalten Sie eine Antwort des Database Manager.

Die Kommunikation erfolgt dabei in ASCII-Darstellung. Nur in einigen Spezialfällen, wie dem binären Dateizugriff, enthalten Anfrage und Antwort auch binäre Daten. Damit sind die Antworten auf der Client-Seite gut lesbar. Außerdem werden Abhängigkeiten von der Hardwarearchitektur weitgehend vermieden.

Erfolgreiche Antwort

Wenn ein DBM-Kommando erfolgreich ausgeführt wurde, wird eine OK-Meldung im folgenden Format gegeben:

OK[,<description>]

[<answer>]

Die Zeichenkette OK ist das erste Token der Antwort. Auf der gleichen Zeile folgt optional ein Erläuterungstext.

Die Antwortdaten werden in der folgenden Zeile ausgegeben. Die Struktur der Antwortdaten hängt vom konkreten DBM-Kommando ab.

Fehlermeldung

ERR[,<description>]

[<err_code>,<err_description>

[<sub_code>,<sub_description>]

[<extended_description>]]

Ein Fehler beginnt immer mit der Zeichenkette ERR. Auf der gleichen Zeile folgt optional eine Beschreibung.

Auf der ersten Folgezeile können die Nummer des Fehlers (<err_code>) und ein zugehöriger Text (<err_description>) ausgegeben werden.

Siehe auch: Strukturlink Meldungen

Wenn dem System die Fehlernummer und der zugehörige Text einer Subkomponente (z.B. Laufzeitumgebung oder Betriebssystem) vorliegen, dann werden diese als <sub_code> und <sub_description> ausgegeben.

Eventuelle weitere Informationen folgen in der <extended_description>. Spezialfälle, in denen diese ein strukturiertes Format hat, werden bei den jeweiligen DBM-Kommandos beschrieben. Sie finden dort eine Erläuterung der einzelnen Antwortfelder.

Beispiele

Interner Fehler des Database Manager:

ERR

-24979,ERR_XPNOTFOUND_CN00 : parameter not found

Fehler der Laufzeitumgebung:

ERR

-24994,ERR_RTE_CN00 : runtime environment error

3,cannot access PARAM file [32]

Fehler bei der Analyse der Vorschlagsparameterdatei:

ERR

-24978,ERR_XPSYNTAX_CN00 : xparam syntax error

16,XPERR_IVSEQ_CN21 : error in IF-ELSIF-ELSE sequence

D:\d628\usr\env\cserv.pcf(60) : ELSE


Kommandoreferenz für das Arbeiten mit dem Database Manager CLI (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Kommandoreferenz für das Arbeiten mit dem Database Manager CLI

Verwendung

Sie verwalten Datenbankinstanzen mit Hilfe von DBM-Kommandos, die Sie auf der Kommandozeile eingeben.

Für weitere Informationen zur Kommandostruktur siehe auch: Aufrufen des Database Manager CLI

Die in diesem Dokument beschriebenen DBM-Kommandos sind in Standardkommandos und weiterführende Kommandos eingeteilt. Diese Unterteilung soll es Ihnen ermöglichen, leicht die einfach und sicher zu verwendenden Administrationskommandos von jenen zu unterscheiden, die genaueste Kenntnis datenbankinterner Abläufe verlangen.

Standardkommandos sind jene Kommandos, die vom Administrator für den gewöhnlichen Datenbankbetrieb verwendet werden.

Die Verwendung der weiterführenden Kommandos sollte ausschließlich erfahrenen Datenbankspezialisten vorbehalten sein, da sie die Möglichkeit zu tiefgreifenden Eingriffen in das Datenbanksystem bieten.
Die weiterführenden Kommandos sind wiederum in folgende Gruppen unterteilt:

● Kommandos für Experten

Sie bieten umfangreiche Eingriffsmöglichkeiten bei der Administration, die nur mit sehr detailliertem Fachwissen vorgenommen werden sollten.

● Kommandos für den Support

Diese Kommandos wurden für ausgesprochene Spezialisten implementiert, die an der Behebung von Problemen arbeiten.

● Kommandos zur Verwendung in Programmen

Diese Kommandos wurden vor allem für die Verwendung in Skripten oder Programmen implementiert.

● Systeminterne Kommandos

Diese Kommandos finden nur systemintern bei der Kommunikation von MaxDB-Komponenten mit dem Database Manager Verwendung.

Um das Auffinden der DBM-Kommandos zu erleichtern, sind diese für jeden Aufgabenbereich in der Datenbankadministration nach diesen Kategorien sortiert.

Aufgabenbereiche in der Datenbankadministration

Softwareinstallation

Anlegen und Löschen der Datenbankinstanz

Konfigurieren der Datenbankinstanz

Steuern der Datenbankinstanz

Sichern und Wiederherstellen der Datenbankinstanz

Verwalten der Database Manager-Benutzer

Analysieren der Datenbankinstanz

SQL-Zugriffe auf die Datenbankinstanz

Optimieren von SQL-Zugriffen auf die Datenbankinstanz

Nutzen von Events der Datenbankinstanz

Verwenden des Scheduler

Verwalten von Hot-Standby-Systemen

Einstellungen des Database Manager

Der Abschnitt Hilfe zum Database Manager enthält eine Übersicht der Hilfekommandos im Database Manager, die es Ihnen ermöglichen, Kurzreferenzen zu DBM-Kommandos online anzuzeigen.

Siehe auch:

Glossar, Strukturlink Syntaxnotation, Strukturlink Variablen in der Dokumentation

Strukturlink Tutorial Datenbankverwaltung


Hilfe zum Database Manager (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Hilfe zum Database Manager

Standardkommandos

DBM-Kommando | Beschreibung
apropos | Suche nach DBM-Kommando
explain | Anzeigen des Erläuterungstexts zu einem DBM-Kommando
help | Liste der DBM-Kommandos anzeigen

Weitere Kommandos für die Hilfe zum Database Manager


Weitere Kommandos für die Hilfe zum Database Manager (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos für die Hilfe zum Database Manager

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
get_default | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando


Softwareinstallation (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Softwareinstallation

Standardkommandos

DBM-Kommando | Beschreibung
inst_enum | Liste aller registrierten Versionen der Datenbanksoftware anzeigen

Weitere Kommandos zur Softwareinstallation


Weitere Kommandos zur Softwareinstallation (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos zur Softwareinstallation

Kommandos für Experten

DBM-Kommando | Beschreibung
dbm_getpath | Anzeigen der versionsunabhängigen Verzeichnisse
dbm_setpath | Ausschließlich vom Softwareinstallationsprogramm verwendetes DBM-Kommando
inst_info | Ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
inst_reg | Registrieren einer Version der Datenbanksoftware
inst_unreg | Löschen der Registrierung einer Version der Datenbanksoftware
package_info | Ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando

Kommandos für den Support

DBM-Kommando | Beschreibung
exec_nipingsrv | Ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
exec_sdbinfo | Ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando


Anlegen und Löschen der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Anlegen und Löschen der Datenbankinstanz

Standardkommandos

DBM-Kommando | Beschreibung
db_drop | Löschen der aktuellen Datenbankinstanz
db_enum | Liste aller registrierten Datenbankinstanzen anzeigen
db_reinstall | Neuaufbau der Datenbankinstanz
load_systab | Laden der Systemtabellen
load_tutorial | Laden der Daten des SQL-Tutorials

Weitere Kommandos für das Anlegen und Löschen der Datenbankinstanz


Weitere Kommandos für das Anlegen und Löschen der Datenbankinstanz

Syntaxdokumentation Weitere Kommandos für das Anlegen und Löschen der Datenbankinstanz

Kommandos für Experten

DBM-Kommando | Beschreibung
db_activate | Initialisieren einer Datenbankinstanz
db_create | Anlegen einer Datenbankinstanz
db_migratecatalog | Ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
db_reg | Aktualisieren der Registrierung einer Datenbankinstanz

Kommandos für den Support

DBM-Kommando | Beschreibung
load_lcapps | Laden der Bibliotheken der Anwendung


Konfigurieren der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Konfigurieren der Datenbankinstanz

Standardkommandos für das Konfigurieren der Volumes

DBM-Kommando | Beschreibung
auto_extend | automatisches Erweitern des Datenbereichs
db_addvolume | Hinzufügen von Volumes
db_deletevolume | Löschen eines Data-Volume

Weitere Kommandos für das Konfigurieren der Volumes

Kommandos für das Ändern der Datenbankparameter

Das Ändern der Datenbankparameter gehört nicht zu den Standardaufgaben eines Datenbankadministrators. Jede Datenbankinstanz ist mit der beim Anlegen der Datenbankinstanz definierten Konfiguration grundsätzlich lauffähig. Nachträgliche Änderungen einzelner Datenbankparameter erfordern äußerst genaue Kenntnis der internen Vorgänge und Zusammenhänge in einer Datenbankinstanz. Um die Lauffähigkeit des Datenbanksystems und die Sicherheit der Daten zu gewährleisten, sollten Änderungen an den Datenbankparametern ausschließlich von ausgebildeten und erfahrenen Experten vorgenommen werden.

Kommandos für das Ändern der Datenbankparameter


Weitere Kommandos für das Konfigurieren der Volumes (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos für das Konfigurieren der Volumes

Kommandos für Experten

DBM-Kommando | Beschreibung
param_addvolume | Ändern von Volume-Parametern
param_delvolume | Löschen von Volume-Parametern
param_getvolsall | Anzeigen der Daten aller Volume-Parameter
param_getvolume | Anzeigen der Daten eines einzelnen Volume-Parameters


Kommandos für das Ändern der Datenbankparameter (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Kommandos für das Ändern der Datenbankparameter

Kommandos für Experten

DBM-Kommando | Beschreibung
param_abortsession | Abbrechen einer Parametersitzung
param_checkall | Prüfen aller Datenbankparameter
param_commitsession | Bestätigen von Änderungen der Datenbank-Parameterdatei
param_copy | Kopieren einer Datenbank-Parameterdatei
param_directdel | Löschen eines Datenbankparameters
param_directget | Anzeigen des Wertes eines Parameters aus der Datenbank-Parameterdatei
param_directgetall | Anzeigen der Werte aller Parameter der Datenbank-Parameterdatei
param_directput | Ändern eines Parameterwertes direkt in der Datenbank-Parameterdatei
param_extget | Anzeigen einzelner Daten eines Datenbankparameters
param_extgetall | Anzeigen der Daten aller Datenbankparameter
param_getdefault | Anzeigen des Systemvorschlags (Default-Value)
param_getexplain | Anzeigen des hinterlegten Erläuterungstextes
param_getfull | Anzeigen aller Daten eines Datenbankparameters
param_gethelp | Anzeigen des hinterlegten Hilfetextes
param_gethistory | Öffnen der Datenbankparameter-Historie
param_getproperties | Anzeigen aller Eigenschaften eines Datenbankparameters
param_gettype | Anzeigen des Datentyps eines Datenbankparameters
param_getvalue | Anzeigen des aktuellen Wertes eines Datenbankparameters
param_init | Initialisieren der Datenbankparameter für eine neue Datenbankinstanz
param_put | Ändern des Wertes eines Datenbankparameters
param_restore | Zurücksetzen der Parameterdatei auf eine vorherige Version
param_rmfile | Löschen der Datenbank-Parameterdatei
param_startsession | Eröffnen einer Parametersitzung
param_versions | Liste der Parameterdateien anzeigen

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
param_directgetallnext | Blättern in den Parameterwerten der Datenbank-Parameterdatei
param_extgetallnext | Blättern in den Daten aller Datenbankparameter
param_gethistorynext | Blättern in der Datenbankparameter-Historie


Steuern der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Steuern der Datenbankinstanz

Standardkommandos

DBM-Kommando | Beschreibung
db_admin | Überführen in den Betriebszustand ADMIN
db_offline | Überführen in den Betriebszustand OFFLINE
db_online | Überführen in den Betriebszustand ONLINE
db_restart | Restart der Datenbankinstanz
db_state | Anzeigen des Betriebszustands der Datenbankinstanz
db_stop | Beenden des Prozesses der Datenbankinstanz
info | Anzeigen von Zustandsinformationen der Datenbankinstanz

Weitere Kommandos für das Steuern der Datenbankinstanz


Weitere Kommandos für das Steuern der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos für das Steuern der Datenbankinstanz

Kommandos für Experten

DBM-Kommando | Beschreibung
db_clear | Löschen von Laufzeitinformationen nach einem Datenbankfehler
db_cons | Benutzen des Werkzeugs XCONS (Datenbankkonsole)
db_restartinfo | Anzeigen der Restart-Informationen nach dem Einlesen einer Sicherung
db_speed | Anzeigen der Variante des Datenbankkerns
exec_lcinit | Ausführen des liveCache-Initialisierungsskripts
show | Anzeigen von Informationen zur Datenbankinstanz
show_list | Anzeigen der Schlüsselwörter für Informationen zur Datenbankinstanz
show_next | Blättern in den Informationen zur Datenbankinstanz

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
info_next | Blättern in den Zustandsinformationen der Datenbankinstanz


Sichern und Wiederherstellen der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Sichern und Wiederherstellen der Datenbankinstanz

Standardkommandos für Sicherungsvorlagen

DBM-Kommando | Beschreibung
medium_delete | Löschen einer Sicherungsvorlage
medium_get | Daten der Sicherungsvorlage anzeigen
medium_getall | Liste aller definierten Sicherungsvorlagen anzeigen
medium_put | Definieren oder Ändern der Daten einer Sicherungsvorlage

Weitere Kommandos für Sicherungsvorlagen

Standardkommandos für das Sichern

DBM-Kommando | Beschreibung
autolog_off | Ausschalten der automatischen Log-Sicherung
autolog_on | Einschalten der automatischen Log-Sicherung
autolog_show | Anzeigen der Funktion zur automatischen Log-Sicherung
backup_start | Sichern der Datenbankinstanz
backup_state | Anzeigen des aktuellen Standes der Sicherung

Weitere Kommandos zum Sichern

Standardkommandos zu Informationen über Sicherungen

DBM-Kommando | Beschreibung
backup_ext_ids_forget | Freigeben des von externen Sicherungskennungen belegten Arbeitsspeichers
backup_ext_ids_get | Holen der externen Sicherungskennungen
backup_ext_ids_getfromtool | Holen der im Sicherungswerkzeug gespeicherten Sicherungsinformationen
backup_ext_ids_list | Anzeigen der vom Sicherungswerkzeug erzeugten Information
backup_history_list | Anzeigen der Sicherungshistorie
medium_label | Anzeigen der Sicherungsinformationen im Betriebszustand ONLINE oder ADMIN
medium_labeloffline | Anzeigen der Sicherungsinformationen im Betriebszustand OFFLINE
recover_check | Prüfen einer Sicherung
recover_state_check | Anzeigen des aktuellen Standes der Prüfung einer Sicherung

Weitere Kommandos zu Informationen über Sicherungen

Standardkommandos zum Wiederherstellen

DBM-Kommando | Beschreibung
autorecover | Automatisches Wiederherstellen der Datenbankinstanz
recover_config | Wiederherstellen der Parameterdatei aus einer Sicherung
recover_start | Wiederherstellen der Datenbankinstanz
recover_state | Anzeigen des aktuellen Standes der Wiederherstellung
sql_recreateindex | Wiederherstellen eines beschädigten Indexes

Weitere Kommandos zum Wiederherstellen


Weitere Kommandos für Sicherungsvorlagen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos für Sicherungsvorlagen

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
medium_date | Anzeigen des Änderungsdatums der Vorlagendefinitionsdatei

Systeminterne Kommandos

DBM-Kommando | Beschreibung
medium_delete_nodistribute | Systeminternes Kommando im Zusammenhang mit Hot-Standby-Konfigurationen
medium_migrate | Eigenschaften einer Sicherungsvorlage übernehmen
medium_put_nodistribute | Systeminternes Kommando im Zusammenhang mit Hot-Standby-Konfigurationen


Weitere Kommandos zum Sichern (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos zum Sichern

Kommandos für Experten

DBM-Kommando | Beschreibung
archive_stage | Einfaches Archivieren der Sicherungsdateien (nur für Log-Sicherungen)
archive_stage_repeat | Mehrfaches Archivieren der Sicherungsdateien (nur für Log-Sicherungen)
backup_cancel | Beenden einer unterbrochenen Sicherung
backup_ignore | Fortsetzen einer Sicherung ohne den angeforderten Folgedatenträger
backup_replace | Angeben des Folgedatenträgers für eine Sicherungsaktion

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
autolog_cancel | Abbrechen der automatischen Log-Sicherung
backup_cancel_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_ignore_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_replace_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_reply_available | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_reply_receive | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando


Weitere Kommandos zu Informationen über Sicherungen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos zu Informationen über Sicherungen

Kommandos für Experten

DBM-Kommando | Beschreibung
backup_history_close | Schließen der Sicherungshistorie
backup_history_open | Holen der Sicherungshistorie

Kommandos für den Support

DBM-Kommando | Beschreibung
load_r3tab | Laden SAP-spezifischer Tabellen

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
backup_ext_ids_listnext | Blättern in den externen Sicherungskennungen
backup_history_date | Änderungsdatum der Sicherungshistorie
backup_history_listnext | Blättern in der Sicherungshistorie
recover_check_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando

Systeminterne Kommandos

DBK-Kommando | Beschreibung
backup_history_append | internes Systemkommando


Weitere Kommandos zum Wiederherstellen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos zum Wiederherstellen

Kommandos für Experten

DBM-Kommando | Beschreibung
recover_cancel | Beenden der unterbrochenen Wiederherstellung oder der Prüfung einer Sicherung
recover_ignore | Fortsetzen der parallelen Wiederherstellung oder der Prüfung einer Sicherung
recover_replace | Angeben des Folgedatenträgers für eine Wiederherstellungsaktion oder das Prüfen einer Sicherung
recover_volume | Wiederherstellen eines beschädigten Volume
service_connect | Eröffnen einer Servicesitzung
service_release | Beenden einer Servicesitzung

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
db_activate_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_cancel_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_ignore_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_replace_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando


Verwalten der Database Manager-Benutzer (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Verwalten der Database Manager-Benutzer

Standardkommandos

DBM-Kommando | Beschreibung
user_create | Anlegen von Database Manager-Benutzern
user_delete | Löschen von Database Manager-Benutzern
user_get | Anzeigen der DBM-Benutzereigenschaften
user_getall | Liste der Database Manager-Benutzer anzeigen
user_getrights | Anzeigen der Serverberechtigungen
user_logon | Anmelden an den Database Manager
user_put | Ändern der DBM-Benutzereigenschaften
user_rename | Ändern des Namens eines DBM-Benutzers

Weitere Kommandos zum Verwalten der Database Manager-Benutzer


Weitere Kommandos zum Verwalten der Database Manager-Benutzer (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos zum Verwalten der Database Manager-Benutzer

Kommandos für Experten

DBM-Kommando | Beschreibung
user_sysdba | Übermitteln der Daten des Datenbanksystemadministrators an den Database Manager
user_system | Anmelden an das Betriebssystem

Kommandos für den Support

DBM-Kommando | Beschreibung
user_sap | Hinterlegen von speziellen Benutzern


Analysieren der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Analysieren der Datenbankinstanz

Mit Hilfe von DBM-Kommandos lassen sich einzelne Funktionen der Datenbankinstanz analysieren. Diese Analysen sind jedoch für den normalen Datenbankbetrieb nicht erforderlich. Nutzen Sie diese Möglichkeit deshalb nur, wenn Sie durch den Support dazu aufgefordert werden.

Kommandos für die Datenbank-Trace-Funktion

Kommandos für den Zugriff auf Datenbankdateien

Kommandos für die Verwendung des Database Analyzer


Kommandos für die Datenbank-Trace-Funktion (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Kommandos für die Datenbank-Trace-Funktion

Kommandos für den Support

DBM-Kommando | Beschreibung
trace_clear | Löschen des Inhalts des Datenbank-Trace
trace_flush | Erzeugen der Binärdatei des Datenbank-Trace
trace_off | Ausschalten des Datenbank-Trace
trace_on | Einschalten des Datenbank-Trace
trace_prot | Erstellen der Textversion des Datenbank-Trace
trace_show | Anzeigen der protokollierten Aktivitäten des Datenbank-Trace

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
trace_protopt | Anzeigen der Kommandoptionen für das Erstellen der Textversion des Datenbank-Trace


Kommandos für den Zugriff auf Datenbankdateien (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Kommandos für den Zugriff auf Datenbankdateien

Kommandos für Experten

DBM-Kommando | Beschreibung
diag_histlist | Anzeigen der Diagnosehistorie
file_getfirst | Öffnen einer Datenbankdatei
file_getlist | Liste der Datenbankdateien anzeigen
file_operation | Bearbeiten von Protokolldateien der Datenbankinstanz

Kommandos für den Support

DBM-Kommando | Beschreibung
diag_pack | Packen von Datenbankdateien
file_restore | Wiederherstellen einer Datenbankdatei

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
file_getnext | Blättern im Inhalt einer Datenbankdatei

Systeminterne Kommandos

DBM-Kommando | Beschreibung
file_backup | Sichern einer Datenbankdatei


Kommandos für die Verwendung des Database Analyzer (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Kommandos für die Verwendung des Database Analyzer

Kommandos für Experten

DBM-Kommando | Beschreibung
dban_delete | Löschen der Protokolldateien des Database Analyzer
dban_start | Aufrufen des Database Analyzer
dban_state | Anzeigen der Funktion des Database Analyzer
dban_stop | Beenden des Database Analyzer


SQL-Zugriffe auf die Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation SQL-Zugriffe auf die Datenbankinstanz

Standardkommandos

DBM-Kommando | Beschreibung
db_connect | Eröffnen einer Datenbanksitzung
db_release | Beenden einer Datenbanksitzung

Weitere Kommandos für SQL-Zugriffe auf die Datenbankinstanz


Weitere Kommandos für SQL-Zugriffe auf die Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos für SQL-Zugriffe auf die Datenbankinstanz

Kommandos für Experten

DBM-Kommando | Beschreibung
db_execute | Ausführen eines Administrationskommandos oder einer SQL-Anweisung (Anzeigen einer Ergebnisliste)
db_executenice | Ausführen eines Administrationskommandos oder einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
db_fetch | Blättern in den Ergebnisdaten eines Administrationskommandos oder einer SQL-Anweisung (Anzeigen einer Ergebnisliste)
db_fetchnice | Blättern in den Ergebnisdaten eines Administrationskommandos oder einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
sql_connect | Eröffnen einer SQL-Sitzung
sql_execute | Ausführen einer SQL-Anweisung (Anzeigen einer Ergebnisliste)
sql_executenice | Ausführen einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
sql_fetch | Blättern in den Ergebnisdaten einer SQL-Anweisung (Anzeigen einer Ergebnisliste)
sql_fetchnice | Blättern in den Ergebnisdaten einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
sql_info | Anzeigen der Struktur einer Ergebnismenge
sql_release | Beenden einer SQL-Sitzung


Optimieren von SQL-Zugriffen auf die Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Optimieren von SQL-Zugriffen auf die Datenbankinstanz

Standardkommandos

DBM-Kommando | Beschreibung
auto_update_statistics | Automatisches Aktualisieren der Optimiererstatistiken
sql_updatestat | Aktualisieren der Optimiererstatistiken
sql_updatestat_per_systemtable | Aktualisieren der Optimiererstatistiken gemäß Systemtabelle SYSUPDSTATWANTED


Nutzen von Events der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Nutzen von Events der Datenbankinstanz

Standardkommandos

DBM-Kommando | Beschreibung
event_delete | Deaktivieren eines Events
event_list | Liste der Events und ihres Status anzeugen
event_list_categories | Liste der Event-Kategorien anzeigen
event_set | Aktivieren eines Events

Siehe auch:

Utilities, Event-Dispatcher

Weitere Kommandos für das Nutzen von Events der Datenbankinstanz


Weitere Kommandos für das Nutzen von Events der Datenbankinstanz

Syntaxdokumentation Weitere Kommandos für das Nutzen von Events der Datenbankinstanz

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
event_available | Anzeigen, ob Events ausgelöst wurden
event_receive | Anzeigen eines ausgelösten Events
event_release | Beenden einer Event-Sitzung
event_wait | Warten auf ein Event

Systeminterne Kommandos

DBM-Kommando | Beschreibung
dbmevtdisp_internal_add | internes Systemkommando
dbmevtdisp_internal_communication | internes Systemkommando
dbmevtdisp_internal_delete | internes Systemkommando


Verwenden des Scheduler (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Verwenden des Scheduler

Standardkommandos

DBM-Kommando | Beschreibung
scheduler_create_job | Anlegen eines Scheduler-Jobs
scheduler_delete_job | Löschen eines Scheduler-Jobs
scheduler_list_jobs | Liste aller Scheduler-Jobs anzeigen
scheduler_start | Starten des Scheduler
scheduler_state | Anzeigen der Funktion des Scheduler
scheduler_stop | Stoppen des Scheduler

Weitere Kommandos für das Verwenden des Scheduler


Weitere Kommandos für das Verwenden des Scheduler (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos für das Verwenden des Scheduler

Kommandos für Experten

DBM-Kommando | Beschreibung
scheduler_activate_job | Anlegen eines Scheduler-Jobs
scheduler_deactivate_job | Deaktivieren eines Scheduler-Jobs


Verwalten von Hot-Standby-Systemen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Verwalten von Hot-Standby-Systemen

Das Einrichten und Verwalten von Hot-Standby-Systemen erfordert ein sehr fundiertes Wissen über die systeminternen Abläufe und das Verwalten eines Datenbanksystems. Zusätzlich müssen besondere Anforderungen im Zusammenhang mit der Hard- und Software Ihres Systems erfüllt sein.

Aus diesen Gründen sollten nur erfahrene Datenbankadministratoren mit den notwendigen Kenntnissen ein Hot-Standby-System einrichten.

Expertenkommandos für das Verwalten von Hot-Standby-Systemen


Kommandos für das Verwalten von Hot-Standby-Systemen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Kommandos für das Verwalten von Hot-Standby-Systemen

Kommandos für Experten

DBM-Kommando | Beschreibung
hss_addstandby | Definieren einer Standby-Instanz
hss_copyfile | Kopieren von Datenbankdateien im Cluster
hss_enable | Definieren der Datenbankinstanz als Master-Instanz
hss_execute | Ausführen von DBM-Kommandos in einer Standby-Instanz
hss_getnodes | Anzeigen der Hot-Standby-Parameter
hss_removestandby | Löschen einer Standby-Instanz


Einstellungen des Database Manager (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Einstellungen des Database Manager

Verwendung

Die Parametereinstellungen des Database Manager sind in der Konfigurationsdatei dbm.cfg des Database Manager sind gespeichert. Die Datei ist im Arbeitsverzeichnis der Datenbankinstanz abgelegt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien

Standardkommandos

DBM-Kommando | Beschreibung
dbm_version | Anzeigen der Softwareversion
bye | exit | quit | release | Beenden des Database Manager

Weitere Kommandos zu den Einstellungen des Database Manager


Weitere Kommandos zu den Einstellungen des Database Manager (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Weitere Kommandos zu den Einstellungen des Database Manager

Kommandos für Experten

DBM-Kommando | Beschreibung
dbm_configget | Anzeigen eines Konfigurationsparameters des Database Manager
dbm_configset | Ändern eines Konfigurationsparameters des Database Manager

Kommandos für den Support

DBM-Kommando | Beschreibung
dbm_listmemoryerror | internes Systemkommando
dbm_shm_info | Anzeigen von Informationen über das Shared-Memory
dbm_shm_reset | Zurücksetzen des Shared-Memory
dbm_shm_unlock | Entsperren des Shared-Memory

Kommandos zur Verwendung in Programmen

DBM-Kommando | Beschreibung
dbm_next | internes Systemkommando

Systeminterne Kommandos

DBM-Kommando | Beschreibung
dbm_getpid | internes Systemkommando
dbm_execute_serverprocess | internes Systemkommando


Übersicht aller DBM-Kommandos (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Übersicht aller DBM-Kommandos

DBM-Kommando | Beschreibung
apropos | Suche nach DBM-Kommando
archive_stage | Einfaches Archivieren der Sicherungsdateien (nur für Log-Sicherungen)
archive_stage_repeat | Mehrfaches Archivieren der Sicherungsdateien (nur für Log-Sicherungen)
auto_extend | Automatisches Erweitern des Datenbereichs
auto_update_statistics | Automatisches Aktualisieren der Optimiererstatistiken
autolog_cancel | Abbrechen der automatischen Log-Sicherung
autolog_off | Ausschalten der automatischen Log-Sicherung
autolog_on | Einschalten der automatischen Log-Sicherung
autolog_show | Anzeigen der Funktion zur automatischen Log-Sicherung
autorecover | Automatisches Wiederherstellen der Datenbankinstanz
backup_cancel | Beenden einer unterbrochenen Sicherung
backup_cancel_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_ext_ids_forget | Freigeben des von externen Sicherungskennungen belegten Arbeitsspeichers
backup_ext_ids_get | Holen der externen Sicherungskennungen
backup_ext_ids_getfromtool | Holen der im Sicherungswerkzeug gespeicherten Sicherungsinformationen
backup_ext_ids_list | Anzeigen der externen Sicherungskennungen
backup_ext_ids_listnext | Blättern in den externen Sicherungskennungen
backup_history_append | internes Systemkommando
backup_history_close | Schließen der Sicherungshistorie
backup_history_date | Änderungsdatum der Sicherungshistorie
backup_history_list | Anzeigen der Sicherungshistorie
backup_history_listnext | Blättern in der Sicherungshistorie
backup_history_open | Holen der Sicherungshistorie
backup_ignore | Fortsetzen der Sicherung ohne den zuletzt als voll gemeldeten Datenträger
backup_ignore_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_replace | Angeben des Folgedatenträgers für eine Sicherungsaktion
backup_replace_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_reply_available | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_reply_receive | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_start | Sichern der Datenbankinstanz
backup_state | Anzeigen des aktuellen Standes der Sicherung
bye | exit | quit | release | Beenden des Database Manager CLI
db_activate | Initialisieren einer Datenbankinstanz
db_activate RECOVER | Wiederherstellen einer Datenbankinstanz mit Initialisierung
db_activate_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
db_addvolume | Hinzufügen von Volumes
db_admin | Überführen in den Betriebszustand ADMIN
db_clear | Löschen von Laufzeitinformationen nach einem Datenbankfehler
db_connect | Eröffnen einer Datenbanksitzung
db_cons | Benutzen des Werkzeugs XCONS (Datenbankkonsole)
db_create | Anlegen einer Datenbankinstanz
db_deletevolume | Löschen eines Data-Volume
db_drop | Löschen der aktuellen Datenbankinstanz
db_enum | Liste aller registrierten Datenbankinstanzen anzeigen
db_execute | Ausführen eines Administrationskommandos oder einer SQL-Anweisung (Anzeigen einer Ergebnisliste)
db_executenice | Ausführen eines Administrationskommandos oder einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
db_fetch | Blättern in den Ergebnisdaten eines Administrationskommandos oder einer SQL-Anweisung (Anzeigen einer Ergebnisliste)
db_fetchnice | Blättern in den Ergebnisdaten eines Administrationskommandos oder einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
db_migratecatalog | ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
db_offline | Überführen in den Betriebszustand OFFLINE
db_online | Überführen in den Betriebszustand ONLINE
db_reg | Aktualisieren der Registrierung einer Datenbankinstanz
db_reinstall | Neuaufbau der Datenbankinstanz
db_release | Beenden einer Datenbanksitzung
db_restart | Restart der Datenbankinstanz
db_restartinfo | Anzeigen der Restart-Informationen nach dem Einlesen einer Sicherung
db_speed | Anzeigen der Variante des Datenbankkerns
db_standby | Überführen in den Betriebszustand STANDBY
db_state | Anzeigen des Betriebszustands der Datenbankinstanz
db_stop | Beenden des Prozesses der Datenbankinstanz
dban_delete | Löschen der Protokolldateien des Database Analyzer
dban_start | Aufrufen des Database Analyzer
dban_state | Anzeigen der Funktion des Database Analyzer
dban_stop | Beenden des Database Analyzer
dbm_configget | Anzeigen eines Konfigurationsparameters des Database Manager
dbm_configset | Ändern eines Konfigurationsparameters des Database Manager
dbm_execute_serverprocess | internes Systemkommando
dbm_getpath | Anzeigen der versionsunabhängigen Verzeichnisse
dbm_getpid | internes Systemkommando
dbm_listmemoryerror | internes Systemkommando
dbm_next | internes Systemkommando
dbm_setpath | ausschließlich vom Softwareinstallationsprogramm verwendetes DBM-Kommando
dbm_shm_info | Anzeigen von Informationen über das Shared-Memory
dbm_shm_reset | Zurücksetzen des Shared-Memory
dbm_shm_unlock | Entsperren des Shared-Memory
dbm_version | Anzeigen der Softwareversion
dbmevtdisp_internal_add | internes Systemkommando
dbmevtdisp_internal_communication | internes Systemkommando
dbmevtdisp_internal_delete | internes Systemkommando
diag_histlist | Anzeigen der Diagnosehistorie
diag_pack | Packen von Datenbankdateien
event_available | Anzeigen, ob Events ausgelöst wurden
event_delete | Deaktivieren eines Events
event_list | Liste der Events und ihres Status anzeigen
event_list_categories | Liste der Event-Kategorien anzeigen
event_receive | Anzeigen eines ausgelösten Events
event_release | Beenden einer Event-Sitzung
event_set | Aktivieren eines Events
event_wait | Warten auf ein Event
exec_lcinit | Ausführen des liveCache-Initialisierungsskripts
exec_nipingsrv | ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
exec_sdbinfo | ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
exit | Beenden des Database Manager CLI
explain | Anzeigen des Erläuterungstexts zu einem DBM-Kommando
file_backup | Sichern einer Datenbankdatei
file_getfirst | Öffnen einer Datenbankdatei
file_getlist | Liste der Datenbankdateien anzeigen
file_getnext | Blättern im Inhalt einer Datenbankdatei
file_operation | Bearbeiten von Protokolldateien der Datenbankinstanz
file_restore | Wiederherstellen einer Datenbankdatei
get_default | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
help | Liste der DBM-Kommandos anzeigen
hss_addstandby | Definieren einer Standby-Instanz
hss_copyfile | Kopieren von Datenbankdateien im Cluster
hss_enable | Definieren der Datenbankinstanz als Master-Instanz
hss_execute | Ausführen von DBM-Kommandos in einer Standby-Instanz
hss_getnodes | Anzeigen der Hot-Standby-Parameter
hss_removestandby | Löschen einer Standby-Instanz
info | Anzeigen von Zustandsinformationen der Datenbankinstanz
info_next | Blättern in den Zustandsinformationen der Datenbankinstanz
inst_enum | Liste aller registrierten Versionen der Datenbanksoftware anzeigen
inst_info | ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
inst_reg | Registrieren einer Version der Datenbanksoftware
inst_unreg | Löschen der Registrierung einer Version der Datenbanksoftware
load_lcapps | Laden der Bibliotheken der Anwendung
load_r3tab | Laden SAP-spezifischer Tabellen
load_systab | Laden der Systemtabellen
load_tutorial | Laden der Daten des SQL-Tutorial
medium_date | Anzeigen des Änderungsdatums der Vorlagendefinitionsdatei
medium_delete | Löschen einer Sicherungsvorlage
medium_delete_nodistribute | systeminternes Kommando im Zusammenhang mit Hot-Standby-Konfigurationen
medium_get | Daten der Sicherungsvorlage anzeigen
medium_getall | Liste aller definierten Sicherungsvorlagen anzeigen
medium_label | Anzeigen der Sicherungsinformationen im Betriebszustand ONLINE oder ADMIN
medium_labeloffline | Anzeigen der Sicherungsinformationen im Betriebszustand OFFLINE
medium_migrate | Übernehmen einer vorhandenen Vorlagendefinition
medium_put | Definieren oder Ändern der Eigenschaften einer Sicherungsvorlage
medium_put_nodistribute | systeminternes Kommando im Zusammenhang mit Hot-Standby-Konfigurationen
package_info | ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
param_abortsession | Abbrechen einer Parametersitzung
param_addvolume | Ändern von Volume-Parametern
param_checkall | Prüfen aller Datenbankparameter
param_commitsession | Bestätigen von Änderungen der Datenbank-Parameterdatei
param_copy | Kopieren einer Datenbank-Parameterdatei
param_delvolume | Löschen von Volume-Parametern
param_directdel | Löschen eines Datenbankparameters
param_directget | Anzeigen des Wertes eines Parameters der Datenbank-Parameterdatei
param_directgetall | Anzeigen der Werte aller Parameter der Datenbank-Parameterdatei
param_directgetallnext | Blättern in den Parameterwerten der Datenbank-Parameterdatei
param_directput | Ändern eines Parameterwertes direkt in der Datenbank-Parameterdatei
param_extget | Anzeigen einzelner Daten eines Datenbankparameters
param_extgetall | Anzeigen der Daten aller Datenbankparameter
param_extgetallnext | Blättern in den Daten aller Datenbankparameter
param_getdefault | Anzeigen des Systemvorschlags (Defaultwert)
param_getexplain | Anzeigen des hinterlegten Erläuterungstextes
param_getfull | Anzeigen aller Daten eines Datenbankparameters
param_gethelp | Anzeigen des hinterlegten Hilfetextes
param_gethistory | Öffnen der Datenbankparameter-Historie
param_gethistorynext | Blättern in der Datenbankparameter-Historie
param_getproperties | Anzeigen aller Eigenschaften eines Datenbankparameters
param_gettype | Anzeigen des Datentyps eines Datenbankparameters
param_getvalue | Anzeigen des aktuellen Wertes eines Datenbankparameters
param_getvolsall | Anzeigen der Daten aller Volume-Parameter
param_getvolume | Anzeigen der Daten eines einzelnen Volume
param_init | Initialisieren der Datenbankparameter für eine neue Datenbankinstanz
param_put | Ändern der Werte von Datenbankparametern
param_restore | Zurücksetzen der Parameterdatei auf eine vorherige Version
param_rmfile | Löschen der Datenbank-Parameterdatei
param_startsession | Eröffnen einer Parametersitzung
param_versions | Liste der Parameterdateien anzeigen
quit | Beenden des Database Manager CLI
recover_cancel | Beenden der unterbrochenen Wiederherstellung oder der Prüfung einer Sicherung
recover_cancel_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_check | Prüfen einer Sicherung
recover_check_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_config | Wiederherstellen der Parameterdatei aus einer Datensicherung
recover_ignore | Fortsetzen der parallelen Wiederherstellung oder der Prüfung einer Sicherung
recover_ignore_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_replace | Angeben des Folgedatenträgers für eine Wiederherstellungsaktion oder das Prüfen einer Sicherung
recover_replace_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_start | Wiederherstellen der Datenbankinstanz
recover_state | Anzeigen des aktuellen Standes der Wiederherstellung
recover_state_check | Anzeigen des aktuellen Standes der Prüfung einer Sicherung
recover_volume | Wiederherstellen eines beschädigten Volume
release | Beenden des Database Manager CLI
scheduler_activate_job | Aktivieren eines Scheduler-Jobs
scheduler_create_job | Anlegen eines Scheduler-Jobs
scheduler_deactivate_job | Deaktivieren eines Scheduler-Jobs
scheduler_delete_job | Löschen eines Scheduler-Jobs
scheduler_list_jobs | Liste aller Scheduler-Jobs anzeigen
scheduler_start | Starten des Scheduler
scheduler_state | Anzeigen der Funktion des Scheduler
scheduler_stop | Stoppen des Scheduler
service_connect | Eröffnen einer Servicesitzung
service_release | Beenden einer Servicesitzung
show | Anzeigen von Informationen zur Datenbankinstanz
show_list | Anzeigen der Schlüsselwörter für Informationen zur Datenbankinstanz
show_next | Blättern in den Informationen zur Datenbankinstanz
sql_connect | Eröffnen einer SQL-Sitzung
sql_execute | Ausführen einer SQL-Anweisung (Anzeigen einer Ergebnisliste)
sql_executenice | Ausführen einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
sql_fetch | Blättern in den Ergebnisdaten einer SQL-Anweisung (Anzeigen einer Ergebnisliste)
sql_fetchnice | Blättern in den Ergebnisdaten einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
sql_info | Anzeigen der Struktur einer Ergebnismenge
sql_recreateindex | Wiederherstellen eines beschädigten Indexes
sql_release | Beenden einer SQL-Sitzung
sql_updatestat | Aktualisieren der Optimiererstatistiken
sql_updatestat_per_systemtable | Aktualisieren der Optimiererstatistiken gemäß Systemtabelle SYSUPDSTATWANTED
trace_clear | Löschen des Inhalts des Datenbank-Trace
trace_flush | Erzeugen der Binärdatei des Datenbank-Trace
trace_off | Ausschalten des Datenbank-Trace
trace_on | Einschalten des Datenbank-Trace
trace_prot | Erstellen der Textversion des Datenbank-Trace
trace_protopt | Anzeigen der Kommandooptionen für das Erstellen der Textversion des Datenbank-Trace
trace_show | Anzeigen der protokollierten Aktivitäten des Datenbank-Trace
user_create | Anlegen von Database Manager-Benutzern
user_delete | Löschen von Database Manager-Benutzern
user_get | Anzeigen der DBM-Benutzereigenschaften
user_getall | Liste der Database Manager-Benutzer anzeigen
user_getrights | Anzeigen der Serverberechtigungen
user_logon | Anmelden an den Database Manager
user_put | Ändern der DBM-Benutzereigenschaften
user_rename | Ändern des Namens eines DBM-Benutzers
user_sap | Hinterlegen von speziellen Benutzern
user_sysdba | Übermitteln der Daten des Datenbanksystemadministrators an den Database Manager
user_system | Anmelden an das Betriebssystem


apropos (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen apropos

Verwendung

Sie lassen sich alle DBM-Kommandos und deren Beschreibungen anzeigen, die die angegebene Zeichenkette oder eine ähnliche Zeichenkette enthalten.

Wenn die Ausgabe für ein DBM-Kommando und seine Beschreibung länger als 80 Zeichen ist, dann werden vom System Zeilenumbrüche eingefügt.

Voraussetzungen

Für die Ausführung dieses DBM-Kommandos ist keine Benutzeranmeldung an den Database Manager erforderlich.

Syntax

apropos <character_string>

<character_string>

Zeichenkette

Antwort

OK

<dbm_command> <description>

Werte für die Felder der Antwort

Wert | Beschreibung
<dbm_command> | DBM-Kommando
<description> | Beschreibung

Beispiel

Aufrufen des Database Manager CLI, Anzeigen alle DBM-Kommandos, die die Zeichenkette auto enthalten:

>dbmcli apropos auto

OK

auto_extend <mode> [<percentage>]

autolog_cancel

autolog_off

autolog_on [<medium>]

autolog_show

autorecover [LOG] [UNTIL <date> <time>] [ ( KEY <key> LABEL

<label> ) | ( IBID <internal_backup_ID> ) ]

auto_update_statistics <mode>


archive_stage (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen archive_stage

Verwendung

Sie kopieren Sicherungsdateien von Log-Sicherungen einfach oder mehrfach mit Hilfe von Sicherungswerkzeugen, um die Sicherheit Ihrer Daten zu erhöhen. Dabei wird vom System geprüft, ob der Kopiervorgang erfolgreich war. Mit Hilfe von Optionen können Sie steuern, ob die kopierten Dateien aus Sicherheitsgründen mit den Originaldateien verglichen werden sollen und ob die Originaldateien nach dem Kopieren gelöscht werden sollen.

Log-Sicherungen, die mit Hilfe der automatischen Log-Sicherung erstellt werden, können nur in Dateien geschrieben werden. Zum Archivieren können Sie diese Sicherungsdateien mit Hilfe von Betriebssystemkommandos auf andere Datenträger kopieren.

Das DBM-Kommando archive_stage ermöglicht Ihnen hingegen, den Inhalt der Sicherungsdateien in Pipes zu übertragen, und so von Sicherungswerkzeugen anderer Anbieter auslesen und archivieren zu lassen. Die aus den Pipes gelesenen Daten können dann einfach, oder aus Sicherheitsgründen auch mehrfach, von Sicherungswerkzeugen archiviert werden. Dies können auch Sicherungswerkzeuge verschiedenen Anbieter sein. Dabei ist sichergestellt, dass alle so erzeugten Kopien der Sicherungsdateien identisch sind, auch dann, wenn durch die eingeschaltete automatische Log-Sicherung in der Zwischenzeit weiter neue Sicherungsdateien geschrieben werden.

Wenn Sie die gleichen Sicherungsdateien mehrfach auf verschiedenen Datenträgern archivieren wollen, rufen Sie den Database Manager CLI im Sitzungsmodus auf. Sie verwenden dann zunächst das hier beschriebene Kommando archive_stage mit der Option KEEP und geben einen Datenträger (1) an, auf den die Sicherungsdateien kopiert werden sollen. Anschließend führen Sie das DBM-Kommando archive_stage_repeat aus und geben dabei einen weiteren Datenträger (2) an. Damit wird die gleiche Gruppe von Sicherungsdateien noch einmal kopiert.

Die archivierten Sicherungsdateien erhalten eigene externe Sicherungskennungen und werden in die Sicherungshistorie eingetragen.

Nach Ausführung des DBM-Kommandos erhalten Sie Informationen über die archivierten Sicherungsdateien angezeigt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sicherungsdateien archivieren

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben den Log-Bereich in Dateien gesichert.

● Die Sicherungsvorlage für den Datenträger ist für die Sicherungsart LOG definiert (Siehe: medium_put).

Syntax

archive_stage <ext_backup_medium> <log_medium> [NOVERIFY] [KEEP] [FNL <list>]

Optionen

Option

Beschreibung

<ext_backup_medium>

Name der Sicherungsvorlage

<log_medium>

Name der Sicherungsvorlage, mit der die Log-Sicherung erstellt wurde

NOVERIFY

Vom System werden nur die üblichen Prüfungen durchgeführt, um festzustellen, ob die Sicherung erfolgreich war. Sie erhalten gegebenenfalls Fehlermeldungen und Ausgaben der Sicherungswerkzeuge.

Wenn Sie diese Angabe nicht machen, dann vergleicht das System zusätzlich der Inhalt der archivierten Dateien mit dem Inhalt der Originaldateien (Systemvorschlag).

KEEP

Die Originaldateien werden archiviert, anschließend aber nicht gelöscht.

Wenn Sie diese Angabe nicht machen, dann werden die Originaldateien gelöscht, nachdem sie erfolgreich auf dem Datenträger archiviert wurden (Systemvorschlag).

FNL

File Number List: Schlüsselwort für die Liste der zu archivierenden Dateien

Geben Sie dieses Schlüsselwort und die Dateinummernliste nur dann an, wenn Sicherungsdateien aufgrund eines Fehlers nicht in der Sicherungshistorie stehen, Sie aber sicher sind, dass diese erstellt wurden. Dies wäre beispielsweise der Fall, wenn die Sicherungsdateien mit den Nummern 10 und 12 in der Sicherungshistorie stehen, aber die Nummer 11 fehlt.

<list>

Dateiname oder Bereich von Dateinamen,

führende Nullen können weggelassen werden, mehrere Angaben sind durch Komma zu trennen

Wenn Sie keine Dateiliste angeben, werden alle zum Beginn des Archivierungsvorgangs vorhandenen Sicherungsdateien kopiert, die mit Hilfe der angegebenen Sicherungsvorlage erstellt wurden und auch in der Sicherungshistorie enthalten sind.

Antwort

OK

Processed Stage Files <number>

Bytes Processed <number>

Deleted Stage Files <number>

Remaining Stage Files <number>

Werte für die Felder der Antwort

Wert | Beschreibung
Processed Stage Files | Bearbeitete Sicherungsdateien
Bytes Processed | Bearbeitete Bytes
Deleted Stage Files | Gelöschte Sicherungsdateien
Remaining Stage Files | Verbleibende Sicherungsdateien
<number> | Anzahl

Beispiel

Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, einfaches Archivieren der originalen Sicherungsdateien 1 und 3-10, diese wurden mit Hilfe der Sicherungsvorlage DemoAutoLog gesichert, sie sollen nun für Archivierungszwecke mit Hilfe der Sicherungsvorlage EXTDATACARRIER_1 nochmals gesichert werden, die originalen Sicherungsdateien sollen anschließend nicht gelöscht werden:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>archive_stage EXTDATACARRIER_1 DemoAutoLog NOVERIFY KEEP FNL 1,3-10

OK
Processed Stage Files   9
Bytes Processed         12845056
Deleted Stage Files     0
Remaining Stage Files   2


archive_stage_repeat (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen archive_stage_repeat

Verwendung

Sie kopieren die Originale der Sicherungsdateien von Log-Sicherungen mehrfach auf verschiedene Datenträger. Dabei wird vom System geprüft, ob der Kopiervorgang erfolgreich war. Mit Hilfe von Optionen können Sie steuern, ob die kopierten Dateien aus Sicherheitsgründen mit den Originaldateien verglichen werden sollen und ob die Originaldateien nach dem Kopieren gelöscht werden sollen.

Sie können dieses DBM-Kommando nur unmittelbar nach dem DBM-Kommando zum einfachen Archivieren der Sicherungsdateien und in derselben Database Manager-Sitzung ausführen. Dabei werden dann genau jene Sicherungsdateien erneut kopiert, die mit dem zuvor ausgeführten DBM-Kommando archive_stage auf den ersten Datenträger kopiert wurden.

Solange Sie in diesem DBM-Kommando die Option KEEP angeben, können Sie es beliebig oft wiederholen und dabei auch Sicherungsvorlagen für verschiedene Sicherungswerkzeuge angeben.

Erst wenn Sie diese Option nicht mehr angeben, werden nach dem Ausführen dem Kopieren die Originaldateien gelöscht und Sie erhalten Informationen über die archivierten Sicherungsdateien angezeigt.

Die archivierten Sicherungsdateien erhalten eigene externe Sicherungskennungen und werden in die Sicherungshistorie eingetragen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sicherungsdateien archivieren

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben zunächst das DBM-Kommando zum einfachen Archivieren der Sicherungsdateien mit Angabe der Option KEEP ausgeführt und befinden sich noch innerhalb derselben Sitzung mit dem DBM-Server (Siehe: archive_stage).

● Die Sicherungsvorlagen für die Datenträger sind für die Sicherungsart LOG definiert (Siehe: medium_put).

Syntax

archive_stage_repeat <ext_backup_medium> [NOVERIFY] [KEEP]

Optionen

Option

Beschreibung

<ext_backup_medium>

Name der Sicherungsvorlage

NOVERIFY

Vom System werden nur die üblichen Prüfungen durchgeführt, um festzustellen, ob die Sicherung erfolgreich war. Sie erhalten gegebenenfalls Fehlermeldungen und Ausgaben der Sicherungswerkzeuge.

Wenn Sie diese Angabe nicht machen, dann vergleicht das System zusätzlich den Inhalt der archivierten Dateien mit dem Inhalt der Originaldateien (Systemvorschlag).

KEEP

Die Originaldateien werden archiviert, anschließend aber nicht gelöscht.

Wenn Sie diese Angabe nicht machen, dann werden die Originaldateien gelöscht, nachdem sie erfolgreich auf dem Datenträger archiviert wurden (Systemvorschlag).

Antwort

OK

Processed Stage Files   <number>

Bytes Processed         <number>

Deleted Stage Files     <number>

Remaining Stage Files   <number>

Werte für die Felder Antwort

Wert | Beschreibung
Processed Stage Files | Bearbeitete Sicherungsdateien
Bytes Processed | Bearbeitete Bytes
Deleted Stage Files | Gelöschte Sicherungsdateien
Remaining Stage Files | Verbleibende Sicherungsdateien
<number> | Anzahl

Beispiel

...

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als DBM-Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>

2. Die Sicherungsdateien wurden mit Hilfe der Sicherungsvorlage DemoFileLog erstellt. Sie sollen zunächst auf dem Datenträger LOCATION_1 archiviert werden. Vom System sollen die üblichen Prüfungen durchgeführt werden, um festzustellen ob die Sicherung erfolgreich war. Außerdem soll der Inhalt der archivierten Dateien mit dem Inhalt der Originaldateien verglichen werden (Systemvorschlag). Die Originaldateien sollen danach nicht gelöscht werden:

dbmcli on DEMODB>archive_stage LOCATION_1 DemoFileLog KEEP

OK

Processed Stage Files 9

Bytes Processed 12845056

Deleted Stage Files 0

Remaining Stage Files 2

3. Anschließend sollen die Sicherungsdateien auf dem Datenträger LOCATION_2 archiviert werden. Dabei sollen nur die üblichen Systemprüfungen durchgeführt werden. Die Originaldateien sollen anschließend gelöscht werden (Systemvorschlag):

dbmcli on DEMODB>archive_stage_repeat LOCATION_2 NOVERIFY

OK

Processed Stage Files 9

Bytes Processed 12845056

Deleted Stage Files 9

Remaining Stage Files 0


auto_extend (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen auto_extend

Verwendung

Sie können Ihr Datenbanksystem so konfigurieren, dass das System jeweils ein neues Data-Volume hinzufügt, sobald der Datenbereich zu einem bestimmten Prozentsatz gefüllt ist. Sie nutzen dafür die Funktion zum automatischen Erweitern des Datenbereichs.

Die Anzahl der Data-Volumes, die während des laufenden Datenbankbetriebs hinzugefügt werden können, ist durch den Wert des Datenbankparameters MAXDATAVOLUMES begrenzt. Der Name des neuen Data-Volume wird vom System auf der Basis der vorhandenen Volume-Definitionen ermittelt.

Sie haben die Möglichkeit, über den Database Manager-Parameter AutoExtDir das Verzeichnis zu definieren, in dem das neue Data-Volume angelegt werden soll (Siehe: dbm_configset). Wenn dieser Parameter nicht definiert ist, legt der Database Manager das neue Data-Volume im Arbeitsverzeichnis der Datenbankinstanz an.

Sie können die Funktion für das automatische Erweitern des Datenbereichs ein- und ausschalten. Gemäß Systemvorschlag ist sie eingeschaltet und das System fügt ein neues Data-Volume zum Datenbereich hinzu, sobald ein Füllungsgrad von 90 % erreicht wird.

Sie können den gültigen Prozentwert überschreiben, indem Sie das DBM-Kommando auto_extend ausführen und einen neuen Wert angeben. Dieser bleibt solange gültig, bis Sie ihn erneut überschreiben.

Wenn Sie die Funktion zum automatischen Erweitern des Datenbereichs einschalten und keinen Prozentwert angeben, dann wird die Funktion mit dem zuletzt definierten Prozentwert eingeschaltet.

Dieses DBM-Kommando benötigt wie andere DBM-Kommandos eine eigene Event-Task. Stellen Sie deshalb sicher, dass der Datenbankparameter _MAXEVENTTASKS groß genug eingestellt ist, wenn Sie dieses DBM-Kommando ausführen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Vergrößern einer Datenbankinstanz

Konzepte des Datenbanksystems, Strukturlink Volumes (permanenter Speicher)

Voraussetzungen

● Sie haben die Serverberechtigung ParamFull oder AccessUtility.

● Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

● Das letzte Data-Volume, das Sie hinzugefügt haben, ist vom Typ Datei.

Syntax

auto_extend <mode> [<number>]

Optionen

Option | Beschreibung
<mode> | Funktion zur automatischen Erweiterung des Datenbereichs, mögliche Werte sind: ON: Funktion einschalten OFF: Funktion ausschalten SHOW: Funktion anzeigen
<number> | Prozentwert, bei dessen Erreichen das System ein neues Data-Volume hinzufügen soll Es gilt: 1 <= <number> <= 100 Vorschlagswert ist 90

Antwort

OK

[ON [<number>] | OFF [, <reason> | UNKNOWN]

Werte für die Felder der Antwort

Wert | Beschreibung
ON | Funktion zur automatischen Erweiterung des Datenbereichs ist eingeschaltet
<number> | definierter Prozentsatz, bei dessen Erreichen vom System ein Data-Volume hinzugefügt wird
OFF | Funktion zur automatischen Erweiterung des Datenbereichs ist ausgeschaltet
<reason> | Ursache für die Deaktivierung der Funktion
UNKNOWN | Status der Funktion zur automatischen Erweiterung des Datenbereichs kann nicht ermittelt werden

Beispiele

Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB,

● Einschalten der Funktion zur automatischen Erweiterung des Datenbereichs, das System soll ein Data-Volume hinzufügen, sobald der Datenbereich zu 66 % gefüllt ist:

>dbmcli -d DEMODB -u OLEG,MONDAY

dbmcli on DEMODB>auto_extend ON 66

OK

● Anzeigen des Status der Funktion zur automatischen Erweiterung des Datenbereichs:

dbmcli on DEMODB>auto_extend SHOW

OK

ON 66


auto_update_statistics (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen auto_update_statistics

Verwendung

Sie können die Statistiken des SQL-Optimierers automatisch aktualisieren lassen.

Sie können diese Funktion im Database Manager ein- oder ausschalten. Gemäß Systemvorschlag ist sie ausgeschaltet.

Sie verwenden dieses DBM-Kommando auch, um sich den Zustand dieser Funktion anzeigen zu lassen.

Wenn die Funktion eingeschaltet ist, aktualisiert das System die Statistiken des SQL-Optimierers Event-gesteuert auf der Grundlage der Systemeinträge in der Systemtabelle SYSUPDSTATWANTED.

Dieses DBM-Kommando benötigt wie andere DBM-Kommandos, eine eigene Event-Task. Stellen Sie deshalb sicher, dass der Datenbankparameter _MAXEVENTTASKS groß genug eingestellt ist, wenn Sie dieses DBM-Kommando ausführen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Performance

Voraussetzungen

· Sie haben die Serverberechtigung AccessSQL.

· Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

Syntax

auto_update_statistics <mode>

<mode> :: = ON | OFF | SHOW

<mode>

Funktion für das automatische Aktualisieren der Statistiken des SQL-Optimierers, mögliche Werte sind:

ON: Funktion einschalten

OFF: Funktion ausschalten

SHOW: Funktion anzeigen

Antwort

OK

[ON | OFF | UNKNOWN]

Werte für die Felder der Antwort

Wert

Beschreibung

ON | OFF | UNKNOWN

Ausgabe bei Verwendung des Modus SHOW, mögliche Werte sind:

ON: Die Funktion zum automatischen Aktualisieren der Statistiken des SQL-Optimierers ist eingeschaltet.

OFF: Die Funktion zum automatischen Aktualisieren der Statistiken des SQL-Optimierers ist ausgeschaltet.

UNKNOWN: Der Zustand der Funktion zum automatischen Aktualisieren der Statistiken des SQL-Optimierers konnte nicht ermittelt werden..

Im Fehlerfall siehe Antwortformat.


autolog_cancel (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen autolog_cancel

Verwendung

Sie brechen eine laufende automatische Log-Sicherung ab. Die Funktion automatische Log-Sicherung wird dadurch deaktiviert.

Sie können dieses Kommando verwenden, um beispielsweise technischen Problemen des Datenträgers zuvorzukommen.

Wenn Sie zu einem späteren Zeitpunkt den Log-Bereich wieder automatisch sichern wollen, müssen Sie die automatische Log-Sicherung explizit wieder einschalten (Siehe: autolog_on).

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern

Voraussetzungen

Sie haben die Serverberechtigung Backup.

Syntax

autolog_cancel

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Abbrechen der automatischen Log-Sicherung für diese Datenbankinstanz:

>dbmcli -u OLEG,MONDAY -d DEMODB autolog_cancel

OK


autolog_off (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen autolog_off

Verwendung

Sie schalten die Funktion für die automatische Log-Sicherung der Datenbankinstanz aus.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern

Voraussetzungen

Sie haben die Serverberechtigung Backup.

Syntax

autolog_off

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ausschalten der automatischen Log-Sicherung:

>dbmcli –u OLEG,MONDAY -d DEMODB autolog_off

OK


autolog_on (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen autolog_on

Verwendung

Sie schalten die Funktion für das automatische Sichern des Log-Bereichs ein.

Wenn Sie die automatische Log-Sicherung erstmalig einschalten, dann müssen Sie den Namen einer Sicherungsvorlage angeben, mit deren Hilfe der Log-Bereich automatisch gesichert werden soll.

Die Sicherungsvorlage kann für die Sicherungsart LOG oder AUTO definiert worden sein. Wenn Sie eine Sicherungsvorlage angeben, die für die Sicherungsart LOGangelegt wurde, dann wird diese Eigenschaft vom System auf AUTO umgestellt.

Wenn die automatische Log-Sicherung schon einmal eingeschaltet war und Sie keine Sicherungsvorlage angeben, dann verwendet das System die zuletzt für die automatische Log-Sicherung verwendete Sicherungsvorlage.

Kopieren Sie die durch die automatische Log-Sicherung erstellten Sicherungsdateien zur Sicherheit auf einen weiteren Datenträger außerhalb des Datenbankrechners.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Automatische Log-Sicherung einschalten

Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern, Strukturlink Sicherungsdateien archivieren

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben für die Datenbankinstanz bereits mindestens einmal eine vollständige Datensicherung durchgeführt (Siehe: backup_start).

● Sie haben eine Sicherungsvorlage für die Sicherungsrat Log-Sicherung definiert (Siehe: medium_put)

Syntax

autolog_on [<medium_name>]

<medium_name>

Name der Sicherungsvorlage

Systemvorschlag ist die zuletzt für die automatische Log-Sicherung der Datenbankinstanz verwendete Sicherungsvorlage

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Einschalten der Funktion zur automatischen Log-Sicherung mit Hilfe der Sicherungsvorlage DemoAutoLog:

>dbmcli -u OLEG,MONDAY -d DEMODB autolog_on DemoAutoLog

OK


autolog_show (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen autolog_show

Verwendung

Sie lassen sich anzeigen, ob die Funktion für die automatische Log-Sicherung ein- oder ausgeschaltet ist.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Log-Einträge sichern

Voraussetzungen

Sie haben die Serverberechtigung DBFileRead oder DBInfoRead.

Syntax

autolog_show

Antwort

OK

AUTOLOG IS OFF | AUTOLOG IS ON

Werte für die Felder der Antwort

Wert | Beschreibung
AUTOLOG IS ON | die automatische Log-Sicherung ist eingeschaltet
AUTOLOG IS OFF | die automatische Log-Sicherung ist ausgeschaltet

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, anzeigen der Funktion zur automatischen Log-Sicherung:

>dbmcli -u OLEG,MONDAY –d DEMODB autolog_show

OK

AUTOLOG IS OFF


autorecover (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen autorecover

Verwendung

Sie starten das automatische Wiederherstellen der Datenbankinstanz.

Auf der Basis der Sicherungshistorie ermittelt das System, welche Sicherungen für das Wiederherstellen benötigt werden. Wenn es sich dabei um Sicherungen handelt, die vom Typ Datei sind oder mit Sicherungswerkzeugen anderer Anbieter erstellt wurden, prüft das System auch, ob ihm die entsprechenden Sicherungen zur Verfügung stehen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen

Voraussetzungen

● Sie haben die Serverberechtigung Recovery.

● Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

Syntax

autorecover [LOG] [UNTIL <date> <time>] [<backup_spec>]

<backup_spec> :: = <key_label_spec> | IBID <backup_ID>

<key_label_spec> :: = KEY <key> LABEL <label>

Optionen

Option

Beschreibung

LOG

Es werden nur die Log-Sicherungen für das Wiederherstellen der Datenbankinstanz verwendet.

Vorschlagswert des Database Manager ist die Verwendung der Daten- und Log-Sicherungen

UNTIL <date> <time>

<date> ::= <yyyymmdd>

<time> ::= <hhmmss>

Zeitpunkt, bis zu dem der Inhalt des Datenbanksystems wiederhergestellt werden soll

<date>: Datum (Jahr, Monat, Tag)

<time>: Uhrzeit (Stunde, Minuten, Sekunden)

Wenn Sie diese Option nicht angeben, stellt der Database Manager das Datenbanksystem bis zum aktuellsten möglichen Zustand auf der Basis aller vorhandenen Daten- und Log-Sicherungen und des Inhalts des Log-Volume wieder her.

KEY <key>

Schlüssel der als erste einzulesenden Sicherung

Sie finden diesen Wert in der Sicherungshistorie.

LABEL <label>

Sicherungskennung der als erste einzulesenden Sicherung

Sie finden diesen Wert in der Sicherungshistorie.

IBID <backup_ID>

Sicherungskennung bestehend aus <key> und <label>, die durch einen senkrechten Strich (|) voneinander getrennt sind

Diese Schreibweise entspricht der Ausgabe in der Sicherungshistorie und ermöglicht ein einfaches Kopieren dieser Angabe aus der Sicherungshistorie in das DBM-Kommando.

Antwort

OK

Returncode              <value>

Date                    [<value>]

Time                    [<value>]

Server                  [<value>]

Database                [<value>]

Kernel Version          [<value>]

Pages Transferred       [<value>]

Pages Left              [<value>]

Volume Count            [<value>]

Medianame               [<value>]

Location                [<value>]

Errortext               [<value>]

Label                   [<value>]

Is Consistent           [<value>]

First LOG Page          [<value>]

Last LOG Page           [<value>]

DB Stamp 1 Date         [<value>]

DB Stamp 1 Time         [<value>]

DB Stamp 2 Date         [<value>]

DB Stamp 2 Time         [<value>]

Page Count              [<value>]

Devices Used            [<value>]

Werte für die Felder der Antwort

Wert

Beschreibung

Date

Datum

Time

Anfangszeitpunkt des Erstellens der Sicherung

Server

Name des Datenbankrechners

Database

Name der Datenbankinstanz

Kernel Version

Version des Datenbankkerns

Pages Transferred

Anzahl der übertragenen Seiten

Pages Left

Anzahl noch zu übertragender Seiten

Volumes

Anzahl der verwendeten Datenträger

Medianame

Name der Sicherungsvorlage

Location

Datei- oder Gerätename

Errortext

Text der Fehlermeldung

Label

Sicherungskennung

Is Consistent

nur für Datensicherung: Sicherung ist in sich konsistent

First LOG Page

bei Datensicherung: erste einzulesende Seite der Log-Sicherung

bei Log-Sicherung: erste gesicherte Seite im Log

Last LOG Page

nur für Log-Sicherung: letzte gesicherte Seite im Log

DB Stamp 1 Date
DB Stamp 1 Time

Zeitstempel der ersten Seite der Log-Sicherung

DB Stamp 2 Date
DB Stamp 2 Time

Zeitstempel der letzten Seite der Log-Sicherung

Page Count

Gesamtzahl der gesicherten Seiten

Devices Used

Anzahl der verwendeten Sicherungsgeräte

Database ID

Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)

Im Fehlerfall siehe Antwortformat.


backup_cancel (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_cancel

Verwendung

Sie beenden einen unterbrochenen Sicherungsvorgang endgültig.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Daten sichern, Strukturlink Log-Einträge sichern

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben mit dem Sichern der Datenbankinstanz begonnen. Der Sicherungsvorgang wurde unterbrochen. Sie befinden sich noch in derselben Datenbanksitzung.

Syntax

backup_cancel

Antwort

OK

Returncode 0

Im Fehlerfall siehe Antwortformat.


backup_cancel_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_cancel_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


backup_ext_ids_forget (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_ext_ids_forget

Verwendung

Die von einem Sicherungswerkzeug abgefragten Sicherungskennungen werden im Arbeitsspeicher gehalten. Mit Hilfe dieses DBM-Kommandos geben Sie diesen Bereich des Arbeitsspeichers wieder frei und vergrößern damit den freien Speicherplatz.

Siehe auch:

Glossar, Strukturlink Sicherungskennung

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead.

Syntax

backup_ext_ids_forget

Antwort

OK

Im Fehlerfall siehe Antwortformat.


backup_ext_ids_get (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_ext_ids_get

Verwendung

Wenn Sie dieses DBM-Kommando ausführen, greift das System auf die Informationen zu, die im Sicherungswerkzeug gespeichert sind, und schreibt diese in eine Datei. Zu diesen Informationen gehören die externe Sicherungskennung, der Verfügbarkeitsstatus, die Sicherungsart und der Erstellungszeitpunkt der Sicherungen einer Datenbankinstanz. Im Unterschied zu backup_ext_ids_getfromtool geben Sie hier den Namen der Sicherungsvorlage an.

Um sich den Inhalt der Datei anzeigen zu lassen, verwenden Sie anschließend das DBM-Kommando zum Anzeigen von externen Sicherungskennungen (Siehe: backup_ext_ids_list).

Siehe auch:

Glossar, Strukturlink Sicherungskennung

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead.

Syntax

backup_ext_ids_get <medium_name> [<database_name>] [<database_computer>]

Optionen

Option | Beschreibung
<medium_name> | Name der Sicherungsvorlage
<database_name> | Name der Datenbankinstanz, von der die Sicherungen erstellt wurden
<database_computer> | Name des Datenbankrechners

Antwort

OK

Im Fehlerfall siehe Antwortformat.


backup_ext_ids_getfromtool (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_ext_ids_getfromtool

Verwendung

Wenn Sie dieses DBM-Kommando ausführen, greift das System auf die Informationen zu, die im Sicherungswerkzeug gespeichert sind, und schreibt diese in eine Datei. Zu diesen Informationen gehören die externe Sicherungskennung, der Verfügbarkeitsstatus, die Sicherungsart und der Erstellungszeitpunkt der Sicherungen einer Datenbankinstanz. Im Unterschied zu backup_ext_ids_get geben Sie hier den Namen des Sicherungswerkzeugs an.

Um sich den Inhalt der Datei anzeigen zu lassen, verwenden Sie anschließend das DBM-Kommando zum Anzeigen von externen Sicherungskennungen (Siehe: backup_ext_ids_list).

Siehe auch:

Glossar, Strukturlink Sicherungskennung

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead.

Syntax

backup_ext_ids_getfromtool <tool_type> [<database_name>] [<database_computer>]

Optionen

Option | Beschreibung
<tool_type> | Sicherungswerkzeug, mögliche Werte sind: BACK: (Backint for MaxDB/ Backint for Oracle) NSR: NetWorker TSM: TSM von IBM/Tivoli
<database_name> | Name der Datenbankinstanz
<database_computer> | Name des Datenbankrechners

Antwort

OK

Im Fehlerfall siehe Antwortformat.


backup_ext_ids_list (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_ext_ids_list

Verwendung

Sie lassen sich die von einem Sicherungswerkzeug abgefragten Informationen anzeigen. Dazu gehören für jede Sicherung die externen Sicherungskennung, der Verfügbarkeitsstatus, die Sicherungsart und der Zeitpunkt, an dem die Sicherung erstellt wurde.

Siehe auch:

Glossar, Strukturlink Sicherungskennung

Voraussetzungen

● Sie haben die Serverberechtigung Backup oder DBInfoRead.

● Sie haben die externe Sicherungskennungen eines Sicherungswerkzeuges geholt (Siehe: backup_ext_ids_get).

Syntax

backup_ext_ids_list

Antwort

OK

END|CONTINUE

[<external_backup_id_line>]

[<external_backup_id_line>]

....

Werte für die Felder der Antwort

Wert | Beschreibung
END | Alle vom Sicherungswerkzeug abgefragten Informationen wurden vollständig übertragen.
CONTINUE | Es sind noch Informationen zu weiteren Sicherungen vorhanden, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden. Sie können darin blättern (Siehe: backup_ext_ids_listnext).
<external_backup_id_line> | Eine Zeile enthält Angaben zu jeweils einer dem Sicherungswerkzeug bekannten Sicherung. Die einzelnen Spalten sind durch einen vertikalen Strich (|) voneinander getrennt.

Im Fehlerfall siehe Antwortformat.


backup_ext_ids_listnext (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_ext_ids_listnext

Verwendung

Sie zeigen die externen Sicherungskennungen der einzelnen Datenträger einer Sicherung an.

Zusätzlich erhalten Sie pro Datenträger auch den Verfügbarkeitsstatus, die Sicherungsart und den Zeitpunkt des Erstellens der Sicherung angezeigt.

Siehe auch:

Glossar, Strukturlink Sicherungskennung

Voraussetzungen

● Sie haben die Serverberechtigung Backup oder DBInfoRead.

● Sie haben die externen Sicherungskennungen eines Sicherungswerkzeuges geholt (Siehe: backup_ext_ids_get)

● Sie haben das DBM-Kommando zum Anzeigen der externen Sicherungskennungen ausgeführt (Siehe: backup_ext_ids_list). Das Schlüsselwort CONTINUE in der Antwort zeigt an, dass die Datei noch nicht vollständig übertragen wurde.

Syntax

backup_ext_ids_listnext

Antwort

OK

END|CONTINUE

[<external_backup_id_line>]

[<external_backup_id_line>]

....

Werte für die Felder der Antwort

Feld | Beschreibung
END | Alle vom Sicherungswerkzeug abgefragten Informationen wurden vollständig übertragen.
CONTINUE | Es sind noch Informationen zu weiteren Sicherungen vorhanden, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden. Sie können diese anzeigen, indem Sie das o. a. DBM-Kommando wiederholen.
<external_backup_id_line> | Eine Zeile enthält Angaben zu jeweils einer dem Sicherungswerkzeug bekannten Sicherung. Die einzelnen Spalten sind durch einen vertikalen Strich (|) voneinander getrennt.

Im Fehlerfall siehe Antwortformat.


backup_history_append (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_history_append

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando.

Es ist gegenwärtig nicht dokumentiert.


backup_history_close (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_history_close

Verwendung

Sie schließen die Sicherungshistorie. Die im Database Manager zwischengespeicherten Informationen der Sicherungshistorie werden gelöscht.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

● Sie haben die Serverberechtigung Backup oder DBInfoRead .

● Sie haben das DBM-Kommando zum Holen der Sicherungshistorie (backup_history_open) oder zum Anzeigen der Sicherungshistorie (backup_history_list) ausgeführt.

Syntax

backup_history_close

Antwort

OK

Im Fehlerfall siehe Antwortformat.


backup_history_date (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_history_date

Verwendung

Sie lassen sich das Datum und die Uhrzeit anzeigen, an dem die aktuelle Sicherungshistorie zuletzt geändert wurde.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead .

Syntax

backup_history_date

Antwort

OK

<yyyymmddHHMMSS>

<yyyymmddHHMMSS>

letztes Änderungsdatum der Sicherungshistorie

Zeitformat: Jahr Monat Tag Stunden Minuten Sekunden

Im Fehlerfall siehe Antwortformat.


backup_history_list (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_history_list

Verwendung

Sie lassen sich den Inhalt der Sicherungshistorie anzeigen. Sie haben die Möglichkeit, die Anzeige durch die Angabe von Optionen einzuschränken oder zu erweitern.

Aus Gründen der Zeitersparnis empfiehlt es sich, zuvor das DBM-Kommando zum Holen der Sicherungshistorie auszuführen (Siehe: backup_history_open). Wenn Sie dies nicht tun, wird es implizit bei dem hier beschriebenen DBM-Kommando zum Anzeigen der Sicherungshistorie ausgeführt.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead .

Syntax

backup_history_list [<option_list>]

<option_list>:: = <option> | <option>,<option>, ...

<option>:: = -c <columns> | -k <key> | -l <label> | -a <action> | -r <restore_flag> | –u <yyyymmddHHMMSS> | –m | -e | -Inverted

Optionen

Option

Beschreibung

-c <columns>

Sie legen fest, welche Spalten ausgegeben werden sollen. Wenn Sie mehrere Spalten angeben, sind diese durch Komma voneinander zu trennen. Die Schlüsselwörter für die einzelnen Spalten sind:
KEY Schlüsselwert der Sicherung

LABEL Label der Sicherung

ACTION Sicherungsaktion

STAMP1 Erster Zeitstempel der Sicherung

STAMP2 Zweiter Zeitstempel der Sicherung

START Beginn der Sicherung

STOP Ende der Sicherung

FIRSTLOG Erste Log-IO-Sequenznummer der Sicherung

LASTLOG Letzte Log-IO-Sequenznummer der Sicherung

LOG Angabe ob nach dem Einlesen der Datensicherung noch Log-Sicherungen eingelesen werden müssen.

MEDIA Name der verwendeten Sicherungsvorlage

PAGES Größe der Sicherung in Seiten

VOLUMES Anzahl der Teile aus denen die Sicherung besteht

RC Rückgabewert der Datenbankinstanz für die Sicherung

ERROR Fehlertext der Sicherung

-k <key>

Es wird nur die Zeile der Sicherungshistorie ausgegeben, die den unter <key> angegebenen Schlüsselwert enthält.

Diese Option darf nicht mit der Option -r verwendet werden.

-l <label>

Es werden nur die Zeilen der Sicherungshistorie ausgegeben, die die angegebene Sicherungskennung enthalten.

Diese Option darf nicht mit der Option -r verwendet werden.

-a <action>

Es werden nur die Zeilen der Sicherungshistorie ausgegeben, die der angegebenen Sicherungsart entsprechen.

Diese Option darf nicht mit der Option -r verwendet werden.

-r <restore_flag>

Es werden nur Sicherungen ausgegeben, die zum Wiederherstellen der Datenbankinstanz benötigt werden. Mögliche Werte für <restore_flag> sind:

* | LAST | <key>

*: Es werden alle Datensicherungen ausgegeben, die für das Wiederherstellen der Datenbankinsztanz erforderlich sind. Wenn das Log-Volume noch intakt ist, dann werden nur jene Datensicherungen ausgegeben, die zu den vorhandenen Log-Einträgen im Log-Volume passen.

LAST: Einschließlich der letzten vollständigen Datensicherung werden alle Sicherungen ausgegeben, die zum Wiederherstellen der Datenbankinstanz benötigt werden.

<key>: Schlüsselwert der vollständigen Datensicherung
Es werden alle Sicherungen ausgegeben, die zum Wiederherstellen der Datenbankinstanz benötigt werden. Den Schlüsselwert der vollständigen Datensicherung finden Sie in der 1. Spalte des Eintrags dieser Sicherung in der Sicherungshistorie.

-u <yyyymmddHHMMSS>

Es werden nur jene Zeilen der Sicherungshistorie ausgegeben, die Daten enthalten, welche vor dem angegebenen Zeitpunkt in der Datenbankinstanz gespeichert wurden. Zeitformat: Jahr Monat Tag Stunden Minuten Sekunden

-m

Zu jeder Zeile, die eine Sicherung betrifft, werden Informationen über die verwendete Sicherungsvorlage ausgegeben.

-e

Zu jeder Zeile, die eine Sicherung betrifft, werden Informationen über die zugehörige externe Sicherungskennung ausgegeben.

-Inverted

Die Sicherungshistorie wird in umgekehrter Reihenfolge ausgegeben, d. h. die jüngste Sicherung zuerst.

Antwort

OK

END|CONTINUE

<history_line>

[<media_line>

[<external_backup_id-line>]

<history_line>

[<media_line>]

[<external_backup_id-line>]

....

Werte für die Felder der Antwort

Wert

Beschreibung

END

Der Inhalt der Sicherungshistorie wurde vollständig übertragen. Die Datei wird automatisch geschlossen.

CONTINUE

Die Sicherungshistorie hat noch weitere Einträge, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden. Sie können diese durch erneutes Eingeben des DBM-Kommandos anzeigen oder die Sicherungshistorie schließen (Siehe: backup_history_close).

<history_line>

Angaben zu den angefertigten Sicherungen
Die Spalten, sind durch einen vertikalen Strich (|) voneinander getrennt. Pro Sicherung wird eine Zeile ausgegeben.

<media_line>

Informationen über die beim Sichern verwendete Sicherungsvorlage
Der Zeile ist ein M: vorangestellt, dem die durch einen vertikalen Strich (|) voneinander getrennten Spalten folgen.

<external_backup_id_line>

Wenn die Sicherung mit Hilfe eines Sicherungswerkzeuges erstellt wurde, sind hier die Informationen zur externen Sicherungskennung zu finden.

Der Zeile ist ein E: vorangestellt, dem die durch einen vertikalen Strich (|) voneinander getrennten Spalten folgen.

Im Fehlerfall siehe Antwortformat.


backup_history_listnext (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_history_listnext

Verwendung

Sie lesen die weitere Sicherungshistorie. Die beim Kommando zum Anzeigen der Sicherungshistorie (backup_history_list) angegebenen Optionen bleiben aktiv.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

● Sie haben die Serverberechtigung Backup oder DBInfoRead .

● Sie haben die DBM-Kommandos zum Holen der Sicherungshistorie (backup_history_open) und zum Anzeigen der Sicherungshistorie (backup_history_list) ausgeführt. Das Schlüsselwort CONTINUE in der Antwort zeigt an, dass die Datei noch nicht vollständig angezeigt wurde.

Syntax

backup_history_listnext

Antwort

OK

[END|CONTINUE]

<history_line>

[<media_line>]

[<external_backup_id-line>]

<history_line>

[<media_line>]

[<external_backup_id-line>]

....

Werte für die Felder der Antwort

Wert | Beschreibung
END | Der Inhalt der Sicherungshistorie wurde vollständig an den Database Manager übertragen.
CONTINUE | Die Sicherungshistorie hat noch weitere Einträge, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden. Sie können diese durch erneutes Eingeben des o. a. Kommandos anzeigen oder die Sicherungshistorie schließen (Siehe: backup_history_close).
<history_line> | Angaben zu den angefertigten Sicherungen, die einzelnen Spalten, sind durch einen Vertikalen Strich (|) getrennt Pro Sicherung wird eine Zeile ausgegeben.
<media_line> | Die Informationen über die beim Sichern verwendete Sicherungsvorlage Der Zeile ist ein M: vorangestellt, dem die jeweils durch einen vertikalen Strich (|) voneinander getrennten Spalten folgen.
<external_backup_id_line> | Wenn die Sicherung mit Hilfe eines Sicherungswerkzeuges eines anderen Anbieters erstellt wurde, finden Sie hier die externe Sicherungskennung. Der Zeile ist ein E: vorangestellt, dem die jeweils durch einen vertikalen Strich (|) voneinander getrennten Spalten folgen.

Im Fehlerfall siehe Antwortformat.


backup_history_open (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_history_open

Verwendung

Sie holen die aktuelle Sicherungshistorie in den Hauptspeicher. Wenn Sie die Option –e angeben, wird die Sicherungshistorie mit den aktuellen Informationen über die verwendeten Sicherungswerkzeuge ergänzt.

Um sich den Inhalt anzusehen, führen Sie anschließend das DBM-Kommando zum Anzeigen der Sicherungshistorie backup_history_list aus.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead .

Syntax

backup_history_open [-e]

-e

Der Verfügbarkeitsstatus der jeweiligen Sicherungen im Sicherungswerkzeug wird bestimmt.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


backup_ignore (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_ignore

Verwendung

Eine laufende Sicherung mit Hilfe einer Sicherungsvorlage für eine Gruppe paralleler Datenträger wurde unterbrochen, weil das System gemeldet hat, dass ein Datenträger der Gruppe voll ist. Da noch weitere Daten gesichert werden müssen, werden Sie vom System aufgefordert, diesen Datenträger zu ersetzen.

Sie verwenden das DBM-Kommando backup_ignore, um den Sicherungsvorgang fortzusetzen ohne diesen Datenträger zu ersetzen. Die übrigen noch zu sichernden Daten werden dann nur noch auf die anderen Datenträger der Gruppe gesichert.

Nachdem das System dieses DBM-Kommando ausgeführt hat, werden die Informationen über die Sicherung ausgegeben. Dies erfolgt erst dann, wenn der Sicherungsvorgang beendet ist oder erneut unterbrochen wurde. Die Antwort auf dieses DBM-Kommando kann deshalb sehr lange dauern.

Werten Sie insbesondere das Antwortfeld Returncode aus, das einen numerischen Wert für eine Meldung enthält.

Siehe auch: Dokumentation Strukturlink Meldungen

Wenn sich aus der Meldungsnummer ergibt, dass der Sicherungsvorgang erneut unterbrochen wurde, müssen Sie die Sitzung mit einem Folgekommando fortsetzen (backup_replace , backup_ignore) oder beenden (backup_cancel).

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben das Sichern der Datenbankinstanz auf eine Gruppe paralleler Datenträger gestartet. Der Sicherungsvorgang wurde unterbrochen, weil ein Datenträger der Gruppe als voll gemeldet wurde. Sie befinden sich noch in derselben Datenbanksitzung.

Syntax

backup_ignore

Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Medianame [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Werte für die Felder der Antwort

Wert | Beschreibung
Date | Datum
Time | Anfangszeitpunkt des Erstellens der Sicherung
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version des Datenbankkerns
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Datenträger
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)

Im Fehlerfall siehe Antwortformat.


backup_ignore_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_ignore_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


backup_replace (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_replace

Verwendung

Ein laufender Sicherungsvorgang wurde unterbrochen, weil das System gemeldet hat, dass ein Datenträger voll ist.

Sie ersetzen den vollen Datenträger. Der Sicherungsvorgang wird fortgesetzt.

Nachdem das System dieses DBM-Kommando ausgeführt hat, werden die Informationen über die Sicherung ausgegeben. Dies erfolgt erst dann, wenn der Sicherungsvorgang beendet ist oder erneut unterbrochen wurde. Die Antwort auf dieses DBM-Kommando kann deshalb sehr lange dauern.

Werten Sie insbesondere das Antwortfeld Returncode aus, das einen numerischen Wert für eine Meldung enthält.

Siehe auch: Strukturlink Meldungen

Wenn sich aus der Meldungsnummer ergibt, dass der Sicherungsvorgang erneut unterbrochen wurde, müssen Sie die Sitzung mit einem Folgekommando fortsetzen (backup_replace, backup_ignore) oder beenden (backup_cancel).

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Sichern

Konzepte des Datenbanksystems, Strukturlink Daten sichern, Strukturlink Log-Einträge sichern

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben das Sichern der Datenbankinstanz gestartet. Der Sicherungsvorgang wurde unterbrochen, weil ein Datenträger als voll gemeldet wurde. Sie befinden sich noch in derselben Datenbanksitzung.

Syntax

backup_replace <location>

<location>

Vollständiger Datei- oder Gerätename des Datenträgers

Antwort

OK

Returncode              <value>

Date                    [<value>]

Time                    [<value>]

Server                  [<value>]

Database                [<value>]

Kernel Version          [<value>]

Pages Transferred       [<value>]

Pages Left              [<value>]

Volume Count            [<value>]

Medianame               [<value>]

Location                [<value>]

Errortext               [<value>]

Label                   [<value>]

Is Consistent           [<value>]

First LOG Page          [<value>]

Last LOG Page           [<value>]

DB Stamp 1 Date         [<value>]

DB Stamp 1 Time         [<value>]

DB Stamp 2 Date         [<value>]

DB Stamp 2 Time         [<value>]

Page Count              [<value>]

Devices Used            [<value>]

Werte für die Felder der Antwort

Wert

Beschreibung

Date

Datum

Time

Anfangszeitpunkt des Erstellens der Sicherung

Server

Name des Datenbankrechners

Database

Name der Datenbankinstanz

Kernel Version

Version des Datenbankkerns

Pages Transferred

Anzahl der übertragenen Seiten

Pages Left

Anzahl noch zu übertragender Seiten

Volumes

Anzahl der verwendeten Datenträger

Medianame

Name der Sicherungsvorlage

Location

Datei- oder Gerätename

Errortext

Text der Fehlermeldung

Label

Sicherungskennung

Is Consistent

nur für Datensicherung: Sicherung ist in sich konsistent

First LOG Page

bei Datensicherung: erste einzulesende Seite der Log-Sicherung

bei Log-Sicherung: erste gesicherte Seite im Log

Last LOG Page

nur für Log-Sicherung: letzte gesicherte Seite im Log

DB Stamp 1 Date
DB Stamp 1 Time

Zeitstempel der ersten Seite der Log-Sicherung

DB Stamp 2 Date
DB Stamp 2 Time

Zeitstempel der letzten Seite der Log-Sicherung

Page Count

Gesamtzahl der gesicherten Seiten

Devices Used

Anzahl der verwendeten Sicherungsgeräte

Database ID

Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)

Im Fehlerfall siehe Antwortformat.


backup_replace_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_replace_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


backup_reply_available (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_reply_available

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


backup_reply_receive (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_reply_receive

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


backup_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


backup_start (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_start

Verwendung

Sie sichern den Daten- oder den Log-Bereich der Datenbankinstanz.

Nachdem das System dieses DBM-Kommando ausgeführt hat, werden die Informationen über die Sicherung ausgegeben. Dies erfolgt erst dann, wenn der Sicherungsvorgang beendet ist oder unterbrochen wurde. Die Antwort auf dieses DBM-Kommando kann deshalb sehr lange dauern. Den Fortschritt des Sicherungsvorganges können Sie sich währenddessen mit Hilfe des DBM-Kommandos backup_state anzeigen lassen.

Wenn sich aus der Meldungsnummer ergibt, dass der Sicherungsvorgang nur unterbrochen wurde, müssen Sie ihn innerhalb derselben Datenbanksitzung mit einem Folgekommando fortsetzen (backup_replace, backup_ignore) oder beenden (backup_cancel).

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Sichern

Konzepte des Datenbanksystems, Strukturlink Daten sichern, Strukturlink Log-Einträge sichern

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

● Wenn Sie eine interaktive Log-Sicherung durchführen wollen, müssen Sie zuvor mindestens einmal eine Datensicherung der entsprechenden Datenbankinstanz durchgeführt haben.

Syntax

backup_start <medium_name> [<backup_type>] [AUTOIGNORE]

Optionen

Option | Beschreibung
<medium_name> | Name der Sicherungsvorlage Beim Sichern auf eine Gruppe paralleler Datenträger ist hier der Name der Gruppe anzugeben.
<backup_type> | Art der Sicherung Diese Angabe müssen Sie nur dann machen, wenn Sie bei der Definition der verwendeten Sicherungsvorlage die Sicherungsart nicht angegeben haben (Vorlagendefinitionen in früheren Versionen). Mögliche Werte sind: DATA: vollständige Datensicherung PAGES: inkrementelle Datensicherung LOG: interaktive Log-Sicherung Andernfalls verwendet das System den Wert der bei der Definition der Sicherungsvorlage angegebenen Sicherungsart.
AUTOIGNORE | Die Sicherung soll automatisch ohne den zuletzt als voll gemeldeten Datenträger fortgesetzt werden (Siehe: backup_ignore)

Antwort

OK

Returncode              <value>

Date                    [<value>]

Time                    [<value>]

Server                  [<value>]

Database                [<value>]

Kernel Version          [<value>]

Pages Transferred       [<value>]

Pages Left              [<value>]

Volume Count            [<value>]

Medianame               [<value>]

Location                [<value>]

Errortext               [<value>]

Label                   [<value>]

Is Consistent           [<value>]

First LOG Page          [<value>]

Last LOG Page           [<value>]

DB Stamp 1 Date         [<value>]

DB Stamp 1 Time         [<value>]

DB Stamp 2 Date         [<value>]

DB Stamp 2 Time         [<value>]

Page Count              [<value>]

Devices Used            [<value>]

Werte für die Felder der Antwort

Wert

Beschreibung

Date

Datum

Time

Anfangszeitpunkt des Erstellens der Sicherung

Server

Name des Datenbankrechners

Database

Name der Datenbankinstanz

Kernel Version

Version des Datenbankkerns

Pages Transferred

Anzahl der übertragenen Seiten

Pages Left

Anzahl noch zu übertragender Seiten

Volumes

Anzahl der verwendeten Datenträger

Medianame

Name der Sicherungsvorlage

Location

Datei- oder Gerätename

Errortext

Text der Fehlermeldung

Label

Sicherungskennung

Is Consistent

nur für Datensicherung: Sicherung ist in sich konsistent

First LOG Page

bei Datensicherung: erste einzulesende Seite der Log-Sicherung

bei Log-Sicherung: erste gesicherte Seite im Log

Last LOG Page

nur für Log-Sicherung: letzte gesicherte Seite im Log

DB Stamp 1 Date
DB Stamp 1 Time

Zeitstempel der ersten Seite der Log-Sicherung

DB Stamp 2 Date
DB Stamp 2 Time

Zeitstempel der letzten Seite der Log-Sicherung

Page Count

Gesamtzahl der gesicherten Seiten

Devices Used

Anzahl der verwendeten Sicherungsgeräte

Database ID

Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)

Antwort im Fehlerfall

Wenn bei der Verwendung eines Sicherungswerkzeugs eines anderen Anbieters ein Fehler auftritt, erhalten Sie eine Antwort in folgender Form:

ERR

<errcode>, <err_description>

[<extended_description>]

Werte für die Felder der Antwort

Wert | Beschreibung
<errcode> | Nummer der Fehlermeldung Siehe: Dokumentation Strukturlink Meldungen
<err_description> | Beschreibung des Fehlers
<extended_description> | Fehlerursache

Es können folgende Fehler auftreten:

Nummer der Fehlermeldung | Text der Fehlermeldung | Erläuterung
-24927 | ERR_TOOLCHK: the external backup tool was not found | Das Sicherungswerkzeug wurde nicht gefunden oder ist nicht korrekt installiert.
-24926 | ERR_MEDIUMCHK: the medium cannot be used with this external backup tool | Die angegebene Sicherungsvorlage kann mit diesem Sicherungswerkzeug nicht verwendet werden.
-24925 | ERR_PREPARE: prepare of the backup operation failed | Die für die Verwendung des Sicherungswerkzeugs notwendigen Vorbereitungen konnten nicht erfolgreich abgeschlossen werden.
-24924 | ERR_DBREQ: cannot start database kernel request | Die Datenbankinstanz konnte den Sicherungsvorgang nicht starten.
-24923 | ERR_TOOLREQ: cannot start external backup tool correctly | Das Sicherungswerkzeug konnte nicht korrekt gestartet werden.
-24922 | ERR_OPCHK: cannot check state of backup operation | Es war nicht möglich, die Zustände der Datenbankinstanz oder des Sicherungswerkzeugs zu überprüfen.
-24921 | ERR_POSTOP: cannot finish backup operation correctly | Obwohl die Sicherung erfolgreich war, konnten die notwendigen Nachbearbeitungsschritte nicht durchgeführt werden.
-24920 | ERR_BACKUPOP: backup operation was unsuccessful | Die Sicherung ist wegen eines Datenbankproblems oder eines Problemes des Sicherungswerkzeuges fehlgeschlagen.
-24919 | ERR_CLEANUP: cannot clean up correctly after backup operation | Obwohl die Sicherung erfolgreich war, konnten die in Anspruch genommenen temporären Systemressourcen nicht wieder freigegeben werden.


backup_state (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen backup_state

Verwendung

Sie lassen sich den aktuellen Stand des Sicherungsvorganges anzeigen.

Dieses DBM-Kommando können Sie auch während eines laufenden Sicherungsvorganges ausführen. Sie öffnen dazu ein zweites Command Prompt und melden sich auch darin an die Datenbankinstanz an, auf der der Sicherungsvorgang läuft.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Anzeigen des Sicherungsfortschritts

Konzepte des Datenbanksystems, Strukturlink Daten sichern, Strukturlink Log-Einträge sichern

Voraussetzungen

● Sie haben die Serverberechtigung Backup.

● Sie haben eine Sicherung gestartet (Siehe: backup_start).

Syntax

backup_state

Antwort

OK

Returncode              <value>

Date                    [<value>]

Time                    [<value>]

Server                  [<value>]

Database                [<value>]

Kernel Version          [<value>]

Pages Transferred       [<value>]

Pages Left              [<value>]

Volume Count            [<value>]

Medianame               [<value>]

Location                [<value>]

Errortext               [<value>]

Label                   [<value>]

Is Consistent           [<value>]

First LOG Page          [<value>]

Last LOG Page           [<value>]

DB Stamp 1 Date         [<value>]

DB Stamp 1 Time         [<value>]

DB Stamp 2 Date         [<value>]

DB Stamp 2 Time         [<value>]

Page Count              [<value>]

Devices Used            [<value>]

Werte für die Felder der Antwort

Wert

Beschreibung

Date

Datum

Time

Anfangszeitpunkt des Erstellens der Sicherung

Server

Name des Datenbankrechners

Database

Name der Datenbankinstanz

Kernel Version

Version des Datenbankkerns

Pages Transferred

Anzahl der übertragenen Seiten

Pages Left

Anzahl noch zu übertragender Seiten

Volumes

Anzahl der verwendeten Datenträger

Medianame

Name der Sicherungsvorlage

Location

Datei- oder Gerätename

Errortext

Text der Fehlermeldung

Label

Sicherungskennung

Is Consistent

nur für Datensicherung: Sicherung ist in sich konsistent

First LOG Page

bei Datensicherung: erste einzulesende Seite der Log-Sicherung

bei Log-Sicherung: erste gesicherte Seite im Log

Last LOG Page

nur für Log-Sicherung: letzte gesicherte Seite im Log

DB Stamp 1 Date
DB Stamp 1 Time

Zeitstempel der ersten Seite der Log-Sicherung

DB Stamp 2 Date
DB Stamp 2 Time

Zeitstempel der letzten Seite der Log-Sicherung

Page Count

Gesamtzahl der gesicherten Seiten

Devices Used

Anzahl der verwendeten Sicherungsgeräte

Database ID

Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)

Im Fehlerfall siehe Antwortformat.


bye | exit | quit | release (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen bye | exit | quit | release

Verwendung

Sie beenden das Programm Database Manager CLI.

Syntax

bye | exit | quit | release

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_activate (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_activate

Verwendung

Sie verwenden dieses DBM-Kommando beim erstmaligen Starten einer neuen Datenbankinstanz und legen damit den Datenbanksystemadministrator an.

Wir empfehlen, für den Benutzernamen und das Kennwort Großbuchstaben zu verwenden.

Geben Sie als Benutzernamen nicht die Zeichenfolge SYSDBA an, weil dies ein reserviertes SQL-Schlüsselwort ist.

Siehe: Strukturlink Konventionen für Benutzernamen und Kennwörter.

Sie verwenden dieses Kommando auch, um eine Datenbankinstanz zu initialisieren. Dabei werden die Kataloginformationen und Anwendungdaten in der Datenbankinstanz gelöscht. Die Datenbankparameter bleiben davon unberührt.

Siehe auch:

Tutorial Datenbankverwaltung,

Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Strukturlink Parameterdatei aus einer anderen Datenbankinstanz kopieren

Strukturlink Parameterdatei aus einer Datensicherung kopieren

Konzepte des Datenbanksystems, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Voraussetzungen

● Sie haben die Serverberechtigung AccessUtility.

● Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

Syntax

db_activate <sysdba_user>,<sysdba_user_password>

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_activate RECOVER (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_activate RECOVER

Verwendung

Sie initialisieren die Data- und Log-Volumes der aktuellen Datenbankinstanz und lesen die in einer vollständigen Datensicherung gespeicherten Daten in die Datenbankinstanz ein. Alle zuvor in der aktuellen Datenbankinstanz vorhandenen Daten werden überschrieben.

Sie verwenden dieses Kommando auch, um die Kopie einer Datenbankinstanz zu erstellen, wie es beispielsweise für den Aufbau einer Schattendatenbankinstanz erforderlich ist.

Im Gegensatz zum DBM-Kommando zum Wiederherstellen der Datenbankinstanz (Siehe: recover_start) werden bei der Ausführung von db_activate RECOVER zunächst alle Kataloginformationen und Anwendungsdaten sowie die Einträge im Log-Bereich der aktuellen Datenbankinstanz gelöscht. Anschließend wird die vollständige Datensicherung eingelesen und der darin enthaltene Datenbankzustand hergestellt.

Nach dem Wiederherstellen mit Initialisierung müssen Sie noch die Systemtabellen laden. (Siehe: load_systab).

Mit dem Einlesen der Sicherung überschreiben Sie alle ursprünglichen Datenbank-Benutzerdaten der Zielinstanz mit den Daten der Quellinstanz. Dies ist von besonderer Bedeutung, wenn die Quelldatenbank, von der die Sicherung erzeugt wurde, von der Zieldatenbank, in die die Sicherung eingelesen wird, verschieden ist. Sie benötigen dann für die weitere Arbeit mit der Zieldatenbankinstanz, insbesondere für das Laden der Systemtabellen nach dem Einlesen der Sicherung, die Benutzerdaten des Datenbanksystemadministrators der Quelldatenbankinstanz. Nur mit diesen Benutzerdaten ist ein vollständiges Wiederherstellen der Daten in der Zieldatenbankinstanz möglich. Die DBM-Benutzerdaten der Zieldatenbankinstanz bleiben erhalten.

Wenn die einzulesende Datensicherung mit Hilfe des Sicherungswerkzeugs eines anderen Anbieters erstellt wurde, müssen Sie dieses Sicherungswerkzeug auch für das Wiederherstellen mit Initialisierung verwenden.

Nach der Ausführung von db_activate RECOVER werden die Informationen über die Wiederherstellung ausgegeben. Dies erfolgt erst dann, wenn die Sicherung vollständig eingelesen wurde oder der Vorgang unterbrochen wurde. Die Antwort auf dieses DBM-Kommando kann deshalb sehr lange dauern.

Wenn vor dem Beginn des Wiederherstellens die automatische Log-Sicherung aktiv war, wird diese nach dem Wiederherstellen nicht automatisch wieder eingeschaltet. Um die automatische Log-Sicherung wieder einzuschalten, führen Sie das DBM-Kommando zum Einschalten der automatischen Log-Sicherung aus (Siehe: autolog_on).

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Wiederherstellen der Datenbankinstanz, Strukturlink Datenbankkopie erstellen, Strukturlink Schatteninstanz einrichten und aktualisieren

Konzepte des Datenbanksystems, Strukturlink Datenbankinstanz wiederherstellen, Strukturlink Datenbankkopie, Strukturlink Schattendatenbank

Voraussetzungen

● Sie haben die Serverberechtigung Recovery.

● Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

● Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

Syntax

db_activate RECOVER <medium_name> DATA [ExternalBackupID <external_backup_ID>] [AUTOIGNORE]

Optionen

Option | Beschreibung
<medium_name> | Name der Sicherungsvorlage, die auf denjenigen Datenträger oder die Gruppe paralleler Datenträger verweist, von der/denen die Sicherung eingelesen werden soll.
DATA | Art der einzulesenden Sicherung ist DATA (vollständige Datensicherung) Diese Angabe müssen Sie nur dann machen, wenn Sie einen Datenträger einlesen wollen, in dessen Sicherungsvorlage die Sicherungsart nicht definiert wurde.
ExternalBackupID <external_backup_ID> | Um eine Sicherung wiederherzustellen, die mit einem Sicherungswerkzeug erstellt wurde, geben Sie hier den Namen an, unter dem die Sicherung diesem Sicherungswerkzeug bekannt ist.
AUTOIGNORE | Beim Wiederherstellen von mehreren parallelen Datenträgern wird der Vorgang vom System automatisch fortgesetzt, wenn das Einlesen der Daten von einem einzelnen Datenträger beendet ist.

Antwort

OK

Returncode              <value>

Date                    [<value>]

Time                    [<value>]

Server                  [<value>]

Database                [<value>]

Kernel Version          [<value>]

Pages Transferred       [<value>]

Pages Left              [<value>]

Volume Count            [<value>]

Medianame               [<value>]

Location                [<value>]

Errortext               [<value>]

Label                   [<value>]

Is Consistent           [<value>]

First LOG Page          [<value>]

Last LOG Page           [<value>]

DB Stamp 1 Date         [<value>]

DB Stamp 1 Time         [<value>]

DB Stamp 2 Date         [<value>]

DB Stamp 2 Time         [<value>]

Page Count              [<value>]

Devices Used            [<value>]

Werte für die Felder der Antwort

Wert

Beschreibung

Date

Datum

Time

Anfangszeitpunkt des Erstellens der eingelesenen Datensicherung

Server

Name des Datenbankrechners

Database

Name der Datenbankinstanz

Kernel Version

Version des Datenbankkerns

Pages Transferred

Anzahl der übertragenen Seiten

Pages Left

Anzahl noch zu übertragender Seiten

Volumes

Anzahl der verwendeten Datenträger

Medianame

Name der Sicherungsvorlage

Location

Datei- oder Gerätename

Errortext

Text der Fehlermeldung

Label

Sicherungskennung

Is Consistent

nur für Datensicherung: Sicherung ist in sich konsistent

First LOG Page

bei Datensicherung: erste einzulesende Seite der Log-Sicherung

bei Log-Sicherung: erste gesicherte Seite im Log

Last LOG Page

nur für Log-Sicherung: letzte gesicherte Seite im Log

DB Stamp 1 Date
DB Stamp 1 Time

Zeitstempel der ersten Seite der Log-Sicherung

DB Stamp 2 Date
DB Stamp 2 Time

Zeitstempel der letzten Seite der Log-Sicherung

Page Count

Gesamtzahl der gesicherten Seiten

Devices Used

Anzahl der verwendeten Sicherungsgeräte

Database ID

Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)

Antwort im Fehlerfall

Wenn bei der Verwendung eines Sicherungswerkzeugs ein Fehler auftritt, erhalten Sie eine Antwort in folgender Form:

ERR<NL>
<errcode>, <err_description><NL>
[<extended_description><NL>]

Werte für die Felder der Antwort

Feld | Beschreibung
<errcode> | Nummer der Fehlermeldung Siehe: Dokumentation Strukturlink Meldungen
<err_description> | Text der Fehlermeldung
<extended_description> | Fehlerursache

Es können folgende Fehler auftreten:

Nummer der Fehlermeldung | Text der Fehlermeldung | Fehlerursache
-24927 | ERR_TOOLCHK: the external backup tool was not found | Das Sicherungswerkzeug wurde nicht gefunden oder ist nicht korrekt installiert.
-24926 | ERR_MEDIUMCHK: the medium cannot be used with an external backup tool | Die angegebene Sicherungsvorlage kann nicht mit dem Sicherungswerkzeug verwendet werden, auf das der Name der Sicherungsvorlage hinweist.
-24925 | ERR_PREPARE: prepare of the backup operation failed | Die für die Verwendung des Sicherungswerkzeugs notwendigen Vorbereitungen konnten nicht erfolgreich abgeschlossen werden.
-24924 | ERR_DBREQ: cannot start database kernel request | Die Datenbankinstanz konnte den Wiederherstellungsvorgang nicht starten.
-24923 | ERR_TOOLREQ: cannot start external backup tool correctly | Das Sicherungswerkzeug konnte nicht korrekt gestartet werden.
-24922 | ERR_OPCHK: cannot check state of backup operation | Es war nicht möglich, die Zustände der Datenbankinstanz oder des Sicherungswerkzeugs zu überprüfen.
-24921 | ERR_POSTOP: cannot finish backup operation correctly | Obwohl die Wiederherstellung erfolgreich war, konnten die notwendigen Nachbearbeitungsschritte nicht durchgeführt werden.
-24920 | ERR_BACKUPOP: backup operation was unsuccessful | Die Wiederherstellung ist wegen eines Datenbankproblems oder eines Problems des Sicherungswerkzeuges fehlgeschlagen.
-24919 | ERR_CLEANUP: cannot clean up correctly after backup operation | Obwohl die Wiederherstellung erfolgreich war, konnten die in Anspruch genommenen temporären Systemressourcen nicht wieder freigegeben werden.


db_activate_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_activate_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


db_addvolume (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_addvolume

1. Hinzufügen von Data-Volumes

Verwendung

Sie definieren zusätzliche Data-Volumes, um den Datenbereich der Datenbankinstanz zu erweitern.

Dabei haben Sie die Möglichkeit, entweder die Größe des anzulegenden Data-Volumes oder einen angestrebten Füllungsgrad des Datenbereiches zu definieren. Wenn dieser angestrebte Füllungsgrad niedriger als der aktuelle Füllungsgrad ist, dann wird das DBM-Kommando ausgeführt und es werden so viele Data-Volumes hinzugefügt, bis der angestrebte Füllungsgrad erreicht ist. Wenn der aktuelle Füllungsgrad unter dem angestrebten liegt, wird das DBM-Kommando nicht ausgeführt.

Ohne Angabe einer Volume-Spezifikation wird auf der Basis der vorhandenen Volume-Definitionen ein Systemvorschlag für ein Volume vom Typ Datei ermittelt und verwendet.

Sie haben die Möglichkeit, über den Database Manager-Parameter AutoExtDir das Verzeichnis und über den Database Manager-Parameter AutoExtSize die Größe für diesen Systemvorschlag zu definieren (Siehe: dbm_configset).

Beachten Sie, dass unter Microsoft Windows Volumes in Form von Dateien nicht komprimiert und nicht in einem komprimierten Verzeichnis des Betriebssystems abgelegt werden dürfen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Vergrößern einer Datenbankinstanz, Abschnitte "Szenario 2" und "Szenario 3"

Konzepte des Datenbanksystems, Strukturlink Volumes (permanenter Speicher), Strukturlink Datenbankdesign

Voraussetzungen

Sie haben die Serverberechtigung ParamFull oder AccessUtility.

Syntax

db_addvolume DATA [<definition>]

<definition> :: = -fd <filling_level> | <vol_specification>

<vol_specification> :: = <device_name> <vol_type> <size>

Optionen

Option | Beschreibung
-fd <filling_level> | angestrebter Füllungsgrad des Datenbereichs in Prozent Das Volume wird nur dann angelegt, wenn der definierte Füllungsgrad bereits erreicht oder überschritten ist.
<device_name> | Name des Gerätes / der Datei
<vol_type> | Typ des Gerätes/der Datei, das/die hinzugefügt werden soll mögliche Werte sind: F | L | R F: Datei L: Link R: Raw Device
<size> | Größe des hinzuzufügenden Data-Volume in Seiten

Antwort

OK

<number>

<number>

nur nach Verwendung der Option -fd <filling_level>:

Anzahl der hinzugefügten Volumes zum Erreichen des angestrebten Füllungsgrades

Im Fehlerfall siehe Antwortformat.

2. Hinzufügen von Log-Volumes

Verwendung

Sie definieren zusätzliche Log-Volumes, um den Log-Bereich der Datenbankinstanz zu erweitern.

Wenn Sie das DBM-Kommando ausführen ohne eine Volume-Spezifikation anzugeben, dann wird auf der Basis der vorhandenen Volume-Definitionen ein Systemvorschlag für ein Volume vom Typ Datei ermittelt und verwendet.

Sie haben die Möglichkeit, über den Database Manager-Parameter AutoExtDirLog das Verzeichnis und über den Database Manager-Parameter AutoExtSizeLog die Größe für diesen Systemvorschlag zu definieren (Siehe: dbm_configset).

Sie verwenden dieses DBM-Kommando auch für das Anlegen von Log-Volumes mit Spiegel-Volumes.

Wenn Ihre Datenbankinstanz bereits gespiegelt betrieben wird, haben Sie die Möglichkeit, über den Database Manager-Parameter AutoExtDirLogMirror das Verzeichnis für den Systemvorschlag des Spiegel-Volume zu definieren.

Wenn die Datenbankinstanz noch nicht gespiegelt betrieben wird, verwenden Sie das DBM-Kommando zum Ändern von Volume-Parametern (Siehe: param_addvolume) für das Anlegen des ersten Spiegel-Volume.

Beachten Sie, dass unter Microsoft Windows Volumes in Form von Dateien nicht komprimiert und nicht in einem komprimierten Verzeichnis des Betriebssystems abgelegt werden dürfen.

Voraussetzungen

Sie haben die Serverberechtigung ParamFull oder AccessUtility.

Syntax

db_addvolume LOG [<vol_specification> | <mvol_specification>]

<vol_specification> :: = <device_name> <vol_type> <size>

<mvol_specification> :: = <device_name> <vol_type> <size> <mdevice_name> <mvol_type>

Optionen

Option | Beschreibung
<device_name> | Name des Gerätes/der Datei
<vol_type> | Typ des Gerätes/der Datei, das/die hinzugefügt werden soll mögliche Werte sind: F | L | R F: Datei L: Link R: Raw Device
<size> | Größe des hinzuzufügenden Log-Volume in Seiten
<mdevice_name> | Name des Gerätes/der Datei des Spiegelvolume
<mvol_type> | Typ des Gerätes/der Datei, das/die als Spiegel-Volume hinzugefügt werden soll mögliche Werte sind: F | L | R F: Datei L: Link R: Raw Device

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankinstanz planen


db_admin (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_admin

Verwendung

Sie überführen die Datenbankinstanz in den Betriebszustand ADMIN.

Wenn sich die Datenbankinstanz im Betriebszustand ONLINE befindet, wird sie zunächst in den Betriebszustand OFFLINE überführt und dann erst in den Betriebszustand ADMIN.

Siehe auch:

Glossar, Strukturlink Betriebszustand

Voraussetzungen

Sie haben die Serverberechtigung DBStop.

Syntax

db_admin [<option>]

<option> :: = -f | -s | -t

Optionen

Option | Beschreibung
-f | -fast | Beim Übergang vom Betriebszustand OFFLINE zu ADMIN wird die Kernvariante fast gestartet.
-s | -slow | Beim Übergang vom Betriebszustand OFFLINE zu ADMIN wird die Kernvariante slow gestartet.
-t | -test | Beim Übergang vom Betriebszustand OFFLINE zu ADMIN wird die Kernvariante test gestartet.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_clear (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_clear

Verwendung

Wenn nach einem Datenbankfehler noch Laufzeitinformationen im Betriebssystem vorhanden sind, ist es nicht möglich, die Datenbankinstanz neu zu starten.

Verwenden Sie dieses DBM-Kommando, um die Laufzeitinformationen aus dem Betriebssystem zu löschen und damit das erneute Starten der Datenbankinstanz zu ermöglichen.

Voraussetzungen

Sie haben die Serverberechtigung DBStop.

Syntax

db_clear

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_connect (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_connect

Verwendung

Sie eröffnen eine Datenbanksitzung, in der Sie sowohl DBM-Kommandos ausführen als auch SQL-Anweisungen an die Datenbankinstanz übergeben können.

Sie haben die Möglichkeit, sich mit dem Benutzernamen und -kennwort eines Datenbankbenutzers oder mit dem Benutzertyp anzumelden. Wenn Sie keinen Datenbankbenutzer angeben, erfolgt die Anmeldung mit den Daten des auf dem Datenbankrechner hinterlegten ersten DBM-Benutzers.

Die Datenbanksitzung ist mit einer User-Task der Datenbankinstanz verknüpft. Die Anzahl der maximal gleichzeitig möglichen Datenbanksitzungen konfigurieren Sie mit dem Wert des allgemeinen Datenbankparameters MAXUSERTASKS.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Sichern, Strukturlink Wiederherstellen der Datenbankinstanz, Strukturlink Folge von Datenbankanweisungen ausführen

Glossar, Strukturlink Datenbanksitzung

Voraussetzungen

● Sie verfügen über die Serverberechtigung AccesSQL oder AccessUtility.

● Sie verfügen über die für die Ausführung der SQL-Anweisungen in der Datenbankinstanz notwendigen Benutzerberechtigungen.

● Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

● Sie arbeiten im Skriptmodus oder im Sitzungsmodus des Database Manager CLI.

Syntax

db_connect <user_identification>

<user_identification> ::= <user_spec> | <user_type>

<user_spec> ::= <database_user>,<database_user_password>

<user_type> ::= user-type=<value>

Optionen

Option | Beschreibung
<database_user> | Name des Datenbankbenutzers
<database_user_password> | Kennwort des Datenbankbenutzers
user-type=<value> | Benutzertyp, mögliche Werte für <value> sind: DBM: DBM-Benutzer DBA: Datenbanksystemadministrator SAP: Datenbankbenutzer der SAP-Anwendung

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_cons (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_cons

Verwendung

Sie nutzen das Datenbankwerkzeug XCONS (Datenbankkonsole), um das Laufzeitverhalten der Datenbankinstanz zu analysieren und zu beeinflussen.

Verwenden Sie XCONS nur, wenn Sie durch den Support dazu aufgefordert werden.

Siehe auch:

Utilities, XCONS

Voraussetzungen

● Sie haben die Serverberechtigung DBStop.

● Die Datenbankinstanz befindet sich im Betriebszustand ADMIN oder ONLINE.

Syntax

db_cons <cons_cmd> [<cons_param>]

Optionen

Option | Beschreibung
<cons_cmd> | XCONS-Kommando
<cons_param> | XCONS-Parameter

Antwort

OK

<cons_output>

<cons_output>

Antwort des Programms XCONS.

Im Fehlerfall siehe Antwortformat.


db_create (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_create

Verwendung

Sie legen auf einem lokalen oder entfernten Rechner eine neue Datenbankinstanz an und den ersten Database Manager-Benutzer mit umfassenden Berechtigungen zur Verwaltung dieser Datenbankinstanz an. Er kann Verwaltungsaufgaben für die Datenbankinstanz ausführen und u. a. auch weitere Database Manager-Benutzer sowie Datenbankbenutzer anlegen.

Gleichzeitig definieren Sie den Datenbanksystemadministrator.

Durch die Angabe von Optionen können Sie definieren, mit welcher der auf dem Datenbankrechner vorhandenen Versionen der Datenbanksoftware diese Datenbankinstanz angelegt werden soll sowie weitere Eigenschaften dieser Datenbankinstanz festlegen.

Direkt nach dem Anlagen der neuen Datenbankinstanz können nur der beim Anlegen definierte erste Database Manager-Benutzer und der Datenbanksystemadministrator auf die Datenbankinstanz zugreifen.

Bevor Sie mit der neu angelegten Datenbankinstanz arbeiten können, müssen Sie noch weitere Schritte ausführen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Konzepte des Datenbanksystems, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Voraussetzungen

  • Sie sind als Betriebssystembenutzers auf dem Rechner angemeldet, auf dem die Datenbankinstanz angelegt werden soll (Siehe: user_system).
  • Für das Anlegen einer Datenbankinstanz unter UNIX/Linux müssen Sie als Betriebssystembenutzer root oder als ein Mitglied der Betriebssystembenutzergruppe sdba angemeldet sein (Siehe: Strukturlink Spezielle Betriebssystembenutzer und -benutzergruppen (UNIX/Linux)).
  • Für das Anlegen einer Datenbankinstanz auf einem entfernten Rechner unter Microsoft Windows müssen Sie zusätzlich Administrationsrechte für den Datenbankrechner haben sowie das Recht log on as batch job. Hinweise zur Verwaltung von Betriebssystembenutzern finden Sie in Ihrer Betriebssystemdokumentation.
  • Der X-Server ist gestartet.
    Bei der Installation der Datenbanksoftware unter Microsoft Windows wird der Startup Type für den X-Server vom System auf Automatic gesetzt und damit beim Starten des Rechners vom System gestartet. Unter UNIX müssen Sie den X-Server des entfernten Datenbankrechners explizit starten, um eine Datenbankinstanz auf diesem Rechner verwalten zu können (Siehe: Dokumentation Utilities: Starten des X-Server).

Syntax

db_create [-a|-auto] [-g <group>] [-u] <database_name> <dbm_user>,<dbm_user_password> [<os_user>,<os_user_password>]

Optionen

Option | Beschreibung
-a | -auto | Unter Microsoft Windows wird der Service-Eintrag Start-up-type für den Datenbank-Service im Control-Panel auf automatic gesetzt. Unter dem Betriebssystem UNIX wird dieser Parameter ignoriert.
-g <group> | Nur für UNIX: Sie ordnen ihre Datenbankdateien einer von der Standardgruppe abweichenden Betriebssystembenutzergruppe zu und können Sie damit vor unberechtigten Zugriffen schützen.
-u | Betriebssystembenutzerspezifikation mit Angabe der Option –u (nur für Microsoft Windows): Der Service zum Starten des Datenbankkerns soll unter dem am Schluss des DBM-Kommandos angegebenen Betriebssystembenutzer laufen.
<os_user> | Name des Betriebssystembenutzers des entfernten Rechners Wenn Sie die Datenbankinstanz auf einem entfernten Rechner (remote) anlegen wollen, ist es erforderlich, auch den Betriebssystembenutzer dieses Rechners anzugeben. Wenn die Anmeldung an das Betriebssystem scheitert, dann ist auch das Anlegen der Datenbankinstanz nicht möglich.
<os_user_password> | Kennwort des Betriebssystembenutzers
<database_name> | Name der Datenbankinstanz Beachten Sie die Strukturlink Konventionen für Datenbanknamen. Das Datenbanksystem wandelt den Datenbanknamen automatisch in Großbuchstaben um.
<dbm_operator> | Database-Manager-Benutzer (DBM-Benutzer) Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter. Das Datenbanksystem wandelt den Benutzernamen automatisch in Großbuchstaben um.
<dbm_operator_password> | Kennwort des Database Manager-Benutzers. Das Datenbanksystem wandelt das Kennwort automatisch in Großbuchstaben um.

Antwort

OK

Im Fehlerfall siehe Antwortformat

Beispiele

Aufrufen des Database Manager CLI, Anlegen einer lokalen Datenbankinstanz mit dem Namen DEMODB, Definieren des ersten Database Manager-Benutzers mit dem Benutzernamen DBM und dem Kennwort DBM:
>dbmcli db_create DEMODB DBM,DBM

OK

>

Aufrufen des Database Manager CLI, Anlegen einer lokalen Datenbankinstanz mit dem Namen DEMODB mit der unter dem Pfad C:\Program Files\SDB\7600 abgelegten Software, Definieren des Database Manager-Benutzers DBM mit dem Kennwort DBM:

>dbmcli -R "C:\Program Files\SDB\7600" db_create DEMODB DBM,DBM

OK

>

Aufrufen des Database Manager CLI, Anlegen einer Datenbankinstanz mit dem Namen DEMODB auf dem entfernten Rechner GENUA, Definieren des Database Manager-Benutzers DBM mit dem Kennwort DBM, Anmelden als Betriebssystembenutzer ANNA mit dem Kennwort BLACK an den entfernten Rechner:
>dbmcli –n GENUA db_create DEMODB  DBM,DBM ANNA,BLACK

OK

>


db_deletevolume (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_deletevolume

Verwendung

Die Daten des angegebenen Data-Volume werden auf die übrigen Data-Volumes verteilt. Das Data-Volume wird gelöscht und die ursprünglich davon belegten Ressourcen werden wieder freigegeben.

Data-Volumes vom Typ Datei (FILE) werden aus dem Dateisystem gelöscht.

Das letzte Data-Volume kann nicht gelöscht werden.

Das Löschen von Log-Volumes wird nicht unterstützt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Volumes (permanenter Speicher)

Voraussetzungen

● Sie haben die Serverberechtigung ParamFull oder AccessUtility.

● Die Datenbankinstanz befindet sich im Betriebszustand ONLINE.

Syntax

db_deletevolume [DATA] [<vol_description>]

<vol_description>:: = NAME <device_name> | [ID] <vol_no>

Optionen

Option | Beschreibung
DATA | das Data-Volume mit der höchsten vom System vergebenen Nummer wird gelöscht
NAME <device_name> | Geräte- oder Dateiname
[ID] <vol_no> | vom System vergebene fortlaufende Nummer des Volume, die Angabe des Schlüsselwortes ID ist optional

Ergebnis

OK

Im Fehlerfall siehe Antwortformat.


db_drop (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_drop

Verwendung

Sie löschen die aktuelle Datenbankinstanz. Dabei können Sie angeben, dass die Datenbankdateien im Database Manager erhalten bleiben sollen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Löschen einer Datenbankinstanz

Voraussetzungen

● Die Datenbankinstanz befindet sich im Betriebszustand OFFLINE.

● Sie haben die Serverberechtigung InstallMgm.

Syntax

db_drop [WITHOUTFILES]

WITHOUTFILES

Die Datenbankdateien werden nicht gelöscht.

Wenn Sie diese Angabe nicht machen, werden auch alle Datenbankdateien gelöscht.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_enum (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_enum

Verwendung

Sie lassen sich die Liste aller auf dem Datenbankrechner registrierten Datenbankinstanzen anzeigen.

Die Anzeige erfolgt in Form einer Tabelle. Die einzelnen Spalten sind durch Tabulatoren voneinander getrennt.

Voraussetzungen

Für die Ausführung dieses DBM-Kommandos ist keine Anmeldung an den Database Manager erforderlich.

Es ist auch keine Serverberechtigung erforderlich.

Syntax

db_enum [-s]

-s

Sie erhalten auch die Service-Datenbankinstanzen angezeigt.

Antwort

OK

<database_name><TAB><dependent_path><TAB><database_version><TAB><kernel_version><TAB><operational_state>

<database_name><TAB><dependent_path><TAB><database_version><TAB><kernel_version><TAB><operational_state>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<database_name> | Name der Datenbankinstanz
<dependent_path> | Verzeichnis, das die von der Datenbankversion abhängige Server-Software enthält
<database_version> | Version der Datenbanksoftware
<kernel_version> | Kernvariante
<operational_state> | Betriebszustand der Datenbankinstanz

Beispiel

Aufrufen des Database Manager CLI, Anzeigen der Liste aller auf dem Rechner GENUA registrierten Datenbankinstanzen.:

dbmcli –n GENUA db_enum

OK

DEMODB C:\Program Files\sdb\DEMODB 7.6.00.10 fast running

DEMODB C:\Program Files\sdb\DEMODB 7.6.00.10 slow offline


db_execute (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_execute

Verwendung

Mit diesem DBM-Kommando übermitteln Sie ein Administrationskommando oder eine SQL-Anweisung an die Datenbankinstanz. Insbesondere bei SQL-Anweisungen ist es jedoch für die Verwendung über eine Programmierschnittstelle gedacht.

Anders als bei Verwendung des DBM-Kommandos db_executenicewollen Sie mit der Antwort so viele Datensätze wie möglich übertragen. Die Menge der übertragenen Daten ist begrenzt durch die Größe des vom DBM-Server übertragenen Antwortpakets.

Wenn es sich um eine SELECT-Anweisung handelt, dann werden vom System die Datensätze der Antwort angezeigt. Wenn aufgrund der begrenzten Größe des Antwortpakets noch nicht alle Daten übertragen wurden, dann verwenden Sie anschließend das DBM-Kommando db_fetch, um ein weiteres Antwortpaket mit Datensätzen zu übertragen. Dies ist jedoch nur dann möglich, wenn Sie sich noch in derselben Datenbanksitzung befinden.

Wenn Sie andere SQL-Anweisungen eingeben, wird die Ausführung der Anweisung mit einer OK-Meldung bestätigt.

Bei der Ausführung von db_execute wird implizit eine Sitzung mit der Datenbankinstanz eröffnet und nach Ausführung des Kommandos wieder beendet. Diese Datenbanksitzung wird im AUTOCOMMIT-Modus eröffnet, d. h. jede eingegebene SQL-Anweisung wird automatisch mit einer COMMIT-Anweisung abgeschlossen.

Wenn eine Folge von SQL-Anweisungen ausgeführt werden soll und diese nur von einem bestimmten Datenbankbenutzer ausgeführt werden können, dann empfiehlt es sich, zunächst eine SQL-Sitzung mit den Daten dieses Datenbankbenutzers zu eröffnen (Siehe: db_connect), dann alle SQL-Anweisungen nacheinander auszuführen und anschließend entweder die Datenbanksitzung (Siehe: db_release) oder den Database Manager CLI zu beenden.

Weitere Informationen zu SQL-Anweisungen finden Sie in den Dokumentationen Strukturlink SQL-Referenzhandbuch und Strukturlink SQL-Tutorial.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Betriebsmodi im Database Manager CLI, Strukturlink Ausführen von Datenbankanweisungen

Konzepte des Datenbanksystems, Strukturlink SQL

Voraussetzungen

● Wenn Sie Administrationskommandos ausführen wollen, benötigen Sie die Serverberechtigung AccessUtility.

● Wenn Sie SQL-Anweisungen ausführen wollen, benötigen Sie die Serverberechtigung AccessSQL.

Syntax

db_execute [<user_type>] <statement>

Optionen

Option | Beschreibung
<user_type> | Benutzertyp, mögliche Werte sind: DBM: erster DBM-Benutzer DBA: Datenbanksystemadministrator SAP: spezieller Datenbankbenutzer im Zusammenhang mit SAP-Anwendungen
<statement> | Administrationskommando oder SQL-Anweisung

Antwort

OK

[END|CONTINUE]

[<record>

<record>

...]

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Antwort wurde vollständig ausgegeben
CONTINUE | Es liegen noch weitere Datensätze vor, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden.
<record> | Ergebnisdaten der SQL-Anweisung Die Felder in einem Datensatz sind durch Semikolon voneinander getrennt. Die Ausgabe von Zeichenketten erfolgt in einfachen Anführungszeichen.

Im Fehlerfall siehe Antwortformat.

Beispiel

...

db_execute im Kommandomodus verwenden

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB,

Anzeigen der Spaltennamen und Kommentare der Tabelle users in der Systemtablelle COLUMNS im Schema DOMAIN:

>dbmcli -u OLEG,MONDAY -d DEMODB db_execute SELECT columnname, comment FROM domain.columns WHERE tablename = 'USERS'

OK

END

'OWNER';(long)

'GROUPNAME';(long)

'USERNAME';(long)

'USERMODE';(long)

'CONNECTMODE';(long)

'MAXTIMEOUT';(long)

'COSTWARNING';(long)

'COSTLIMIT';(long)

'DEFAULTCODE';(long)

'CREATEDATE';(long)

'CREATETIME';(long)

'ALTERDATE';(long)

'ALTERTIME';(long)

'PWCREADATE';(long)

'PWCREATIME';(long)

'SERVERDB';(long)

'SERVERNODE';(long)

'USER_ID';(long)

'ISREPLICATIONUSER';(long)

'COMMENT';(long)

db_execute im Sitzungsmodus verwenden

1. Anmelden an den Database Manager CLI im Sitzungsmodus als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

2. Eröffnen einer Datenbanksitzung:

dbmcli on DEMODB>db_connect

OK

3. Anzeigen des Inhalts der Systemtabelle columns des Schemas domain:

dbmcli on DEMODB>db_execute SELECT * FROM domain.columns

OK

CONTINUE

'DBADMIN';'DBADMIN';'ALLOCATORSTATISTIC';'ALLOCATOR';'OPT';'CHAR';'ASCII';40;(nu

ll);'YES';'SEL+';(null);(null);(null);(null);1;(null);2;'20060406';'00145007';'2

0060406';'00145007';'SYSTEM';(null)

'DBADMIN';'DBADMIN';'ALLOCATORSTATISTIC';'USED_BYTES';'OPT';'FIXED';'';20;0;'YES

';'SEL+';(null);(null);(null);(null);2;(null);3;'20060406';'00145007';'20060406'

;'00145007';'SYSTEM';(null)

'DBADMIN';'DBADMIN';'ALLOCATORSTATISTIC';'MAXUSED_BYTES';'OPT';'FIXED';'';20;0;'

YES';'SEL+';(null);(null);(null);(null);3;(null);4;'20060406';'00145007';'200604

06';'00145007';'SYSTEM';(null)

'DBADMIN';'DBADMIN';'ALLOCATORSTATISTIC';'ALLOCATED_BYTES';'OPT';'FIXED';'';20;0

;'YES';'SEL+';(null);(null);(null);(null);4;(null);5;'20060406';'00145007';'2006

0406';'00145007';'SYSTEM';(null)

...

...

4. Übertragen des nächsten Antwortpakets:

dbmcli on DEMODB>db_fetch

OK

CONTINUE

'DBADMIN';'DBADMIN';'LOCKSTATISTICS';'REQTIMEOUT';'OPT';'CHAR';'UNICODE';10;(nul

l);'YES';'SEL+';(null);(null);(null);(null);10;(null);11;'20060406';'00145007';'

20060406';'00145007';'SYSTEM';(null)

'DBADMIN';'DBADMIN';'LOCKSTATISTICS';'LASTWRITE';'OPT';'CHAR';'UNICODE';10;(null

);'YES';'SEL+';(null);(null);(null);(null);11;(null);12;'20060406';'00145007';'2

0060406';'00145007';'SYSTEM';(null)

...

...

5. Übertragen des nächsten Antwortpakets:

dbmcli on DEMODB>db_fetch

OK

CONTINUE

…

…

…

6. Übertragen des nächsten Antwortpakets:

dbmcli on DEMODB>db_fetch

OK

END

…

…

'HOTEL';'MONA';'ROOM';'FREE';'OPT';'FIXED';'';3;0;'YES';'SEL+UPD+';(null);(null)

;(null);(null);3;(null);3;'20060406';'00145012';'20060406';'00145012';'TABLE';(n

ull)

'HOTEL';'MONA';'ROOM';'PRICE';'OPT';'FIXED';'';6;2;'YES';'SEL+UPD+';(null);(null

);(null);(null);4;(null);4;'20060406';'00145012';'20060406';'00145012';'TABLE';(null)

7. Beenden der Datenbanksitzung

dbmcli on DEMODB>db_release

OK

dbmcli on DEMODB>


db_executenice (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_executenice

Verwendung

Mit diesem DBM-Kommando übermitteln Sie ein Administrationskommando oder eine SQL-Anweisung an die Datenbankinstanz. Insbesondere bei SQL-Anweisungen ist es jedoch für die Verwendung über eine Programmierschnittstelle gedacht.

Anders als bei Verwendung des DBM-Kommandos db_execute wollen Sie sich in der Antwort einen Datensatz nach dem anderen anzeigen lassen.

Bei der Ausführung dieses DBM-Kommandos wird implizit eine Sitzung mit der Datenbankinstanz eröffnet und nach Ausführung des Kommandos wieder beendet. Diese Datenbanksitzung wird im AUTOCOMMIT-Modus eröffnet. Wenn Sie eine SQL-Anweisung eingeben, wird diese automatisch mit einer COMMIT-Anweisung abgeschlossen.

Nachdem das Administrationskommandos oder die SQL-Anweisung ausgeführt wurde, erhalten Sie eine OK-Meldung oder den ersten Datensatz der Antwort angezeigt. Um den jeweils nächsten Datensatz anzuzeigen, verwenden Sie das DBM-Kommando db_fetchnice.

Weitere Informationen zu SQL-Anweisungen finden Sie in den Dokumentationen Strukturlink SQL-Referenzhandbuch und Strukturlink SQL-Tutorial.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Betriebsmodi im Database Manager CLI, Strukturlink Folge von Datenbankanweisungen ausführen

Konzepte des Datenbanksystems, Strukturlink SQL

Voraussetzungen

● Sie arbeiten im Sitzungsmodus des Database Manager CLI.

● Wenn Sie Administrationskommandos ausführen wollen, benötigen Sie die Serverberechtigung AccessUtility.

● Wenn Sie SQL-Anweisungen ausführen wollen, benötigen Sie die Serverberechtigung AccessSQL.

Syntax

db_executenice [<user_type>] <statement>

Optionen

Option | Beschreibung
<user_type> | Benutzertyp, mögliche Werte sind: DBM: erster DBM-Benutzer DBA: Datenbankadministrator SAP: spezieller Datenbankbenutzer im Zusammenhang mit SAP-Anwendungen
<statement> | Administrationskommando oder SQL-Anweisung

Antwort

OK

[END | CONTINUE]

[<record>]

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Antwort wurde vollständig ausgegeben
CONTINUE | Es liegen noch weitere Datensätze vor, die aufgrund der begrenzten Größe des Antwortpakted nicht übertragen wurden.
<record> | Ein Datensatz des Ergebnisses der SQL-Anweisung Die Felder in einem Datensatz sind durch Semikolon voneinander getrennt. Die Ausgabe von Zeichenketten erfolgt in einfachen Anführungszeichen.

Im Fehlerfall siehe Antwortformat.

Beispiel

...

Anmelden an den Database Manager CLI im Sitzungsmodus als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, datensatzweises Anzeigen der Spalten der Tabelle USERS mit den dazugehörigen Kommentaren:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>db_executenice SELECT columnname, comment FROM domain.columns WHERE tablename = 'USERS'

OK

CONTINUE

COLUMNNAME = 'OWNER'

COMMENT = (long)

---

dbmcli on DEMODB>db_fetchnice

OK

CONTINUE

COLUMNNAME = 'GROUPNAME'

COMMENT = (long)

---

dbmcli on DEMODB>db_fetchnice

...

...


db_fetch (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_fetch

Verwendung

Sie verwenden dieses DBM-Kommando nachdem Sie das DBM-Kommando db_execute ausgeführt haben und lassen sich damit innerhalb derselben Datenbanksitzung die weiteren Ergebnisdaten anzeigen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Folge von Datenbankanweisungen ausführen

Voraussetzungen

● Sie haben die Serverberechtigung AccessSQL.

● Sie haben ein Administrationskommando oder eine SQL-Anweisung ausgeführt (Siehe: db_execute). Das Schlüsselwort CONTINUE in der Antwort zeigt an, dass die Daten noch nicht vollständig ausgegeben wurden.

Syntax

db_fetch

Antwort

OK

[END|CONTINUE]

[<record>

<record>

...]

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Antwort wurde vollständig übertragen.
CONTINUE | Es liegen noch weitere Datensätze vor, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden.
<record> | Ergebnisdaten der SQL-Anweisung Die Felder in einem Datensatz sind durch Semikolon voneinander getrennt. Die Ausgabe von Zeichenketten erfolgt in einfachen Anführungszeichen.

Im Fehlerfall siehe Antwortformat.


db_fetchnice (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_fetchnice

Verwendung

Sie verwenden dieses DBM-Kommando nachdem Sie db_executenice ausgeführt haben und lassen sich damit innerhalb derselben Datenbanksitzung den jeweils nächsten Datensatz des Ergebnisses anzeigen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Folge von Datenbankanweisungen ausführen

Voraussetzungen

● Sie haben die Serverberechtigung AccessSQL.

● Sie haben eine SQL-Anweisung ausgeführt (Siehe: db_executenice). Das Schlüsselwort CONTINUE in der Antwort zeigt an, dass die Daten noch nicht vollständig ausgegeben wurden.

Syntax

db_fetchnice

Antwort

OK

[END | CONTINUE]

[<column>=<value>]

[<column>=<value>]

[...]

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Antwort wurde vollständig übertragen.
CONTINUE | Es liegen noch weitere Datensätze vor, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden.
<column> | Spaltenname
<value> | Spaltenwert

Beispiel

Anmelden an den Database Manager CLI im Sitzungsmodus als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Eröffnen einer Datenbanksitzung, Datensatzweises Anzeigen der Spalten der Tabelle USERS mit den dazugehörigen Kommentaren:

>dbmcli -u OLEG,MONDAY -d DEMODB

>dbmcli on DEMODB>db_connect

OK

dbmcli on DEMODB>db_executenice SELECT columnname, comment FROM domain.columns WHERE tablename = 'USERS'

OK

CONTINUE

COLUMNNAME = 'OWNER'

COMMENT = (long)

---

dbmcli on demodb>db_fetchnice

OK

CONTINUE

COLUMNNAME = 'GROUPNAME'

COMMENT = (long)

---

dbmcli on demodb>db_fetchnice

...

...


db_migratecatalog (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_migratecatalog

Verwendung

Dieses DBM-Kommando wird ausschließlich von SAP-Anwendungen verwendet.

Es ist gegenwärtig nicht dokumentiert.


db_offline (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_offline

Verwendung

Sie überführen die Datenbankinstanz in den Betriebszustand OFFLINE.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Starten und Stoppen einer Datenbankinstanz

Voraussetzungen

Sie haben die Serverberechtigung DBStop.

Syntax

db_offline [<option>]

<option> :: = -d | -dump

-d | -dump

Beim Übergang vom Betriebszustand ONLINE oder ADMIN zu OFFLINE wird ein Dump erzeugt.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_online (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_online

Verwendung

Sie überführen die Datenbankinstanz in den Betriebszustand ONLINE.

Sie verwenden dieses DBM-Kommando auch dann, wenn die Datenbank nicht korrekt gestoppt wurde, weil der Computer durch einen Stromausfall abgeschaltet wurde. Wenn die Volumes der Datenbankinstanz unbeschädigt sind, nutzt das System die intern noch vorhandenen Informationen, um abgeschlossene Transaktionen zu wiederholen und nicht abgeschlossene Transaktionen rückgängig zu machen.

Wenn Sie im DBM-Kommando einen Zeitpunkt angeben, dann werden nur die bis zu diesem Zeitpunkt abgeschlossenen Transaktionen wiederholt.

Sie haben die Möglichkeit, eine Datenbankinstanz so zu konfigurieren, dass sie beim Starten des Datenbankrechners automatisch gestartet wird.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Starten und Stoppen einer Datenbankinstanz

Glossar, Strukturlink Restart.

Konzepte des Datenbanksystems, Strukturlink Automatischer Start

Voraussetzungen

Sie haben die Serverberechtigung DBStart.

Syntax

db_online [<option>]

<option> :: = -f | -s | -t | -u

Optionen

Option

Beschreibung

-f | -fast

Es wird die Kernvariante fast gestartet.

-s | -slow

Es wird die Kernvariante slow gestartet.

-t | -test

Es wird die Kernvariante test gestartet.

[-u | -until] <date> <time>
<date> ::= <yyyymmdd>
<time> ::= <hhmmss>

Zeitpunkt (Jahr, Monat, Tag, Stunde, Minuten, Sekunden), bis zu dem die noch in der Datenbankinstanz vorhandenen Log-Einträge wieder eingelesen werden sollen.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_reg (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_reg

Verwendung

Sie aktualisieren die Registrierungsinformationen einer Datenbankinstanz. Durch die Angabe einer Option können Sie eine bestimmte Registrierungsinformation aktualisieren.

Unter Microsoft Windows wird der entsprechende Eintrag in der Registry und unter UNIX die Datei databases.ini im Verzeichnis <independent_data_path>/config aktualisiert.

Jede Datenbankinstanz wird implizit beim Anlegen registriert. Eine Aktualisierung der Registrierungsinformation könnte nur nach einem Datenbankfehler erforderlich werden.

Verwenden Sie dieses DBM-Kommando deshalb nur nach einem Upgrade der Datenbankinstanz in Verbindung mit der Angabe zum Installationspfad der neuen Version der Datenbanksoftware.

Da Sie damit auch die Version des Database Manager CLI ändern, ist es notwendig, vor dem Ausführen des Kommandos alle übrigen Sitzungen mit dem Database Manager (insbesondere auch mit dem Database Manager GUI) zu schließen.

Wenn Sie das Kommando im Sitzungsmodus ausführen, müssen Sie anschließend auch explizit den Database Manager CLI beenden. Auf diese Weise wird dann beim nächsten Zugriff auf die aktuelle Datenbankinstanz die neue Version der Datenbanksoftware und des Database Manager CLI verwendet.

Sie können mit diesem Kommando nur zwischen Versionen der Datenbanksoftware wechseln, die keine Migration der Datenbankinstanz erfordern.

Voraussetzungen

● Sie haben die Serverberechtigung InstallMgm.

● Die Datenbankinstanz befindet sich im Betriebszustand OFFLINE.

● Sie haben alle anderen Sitzungen mit dem Database Manager (auch im Database Manager GUI) beendet.

Syntax

db_reg [-R <dependent_path> | -a [OFF] | –g <group> | -u <os_user>,<os_user_password>]

Optionen

Option | Beschreibung
-R <dependent_path> | Ablageort der von der Datenbankversion abhängigen Server-Software
-a [OFF] | Nur für Microsoft Windows: Sie definieren den Service-Eintrag Start-up-type im Control-Panel. Mögliche Optionen sind –a | -a OFF. -a: Der Start-up-type wird auf automatic gesetzt. -a OFF: Der Start-up-type wird auf manual gesetzt. Unter dem Betriebssystem UNIX wird dieser Parameter ignoriert.
-g <group> | Nur für UNIX: Sie ordnen ihre Datenbankdateien einer von der Standardgruppe abweichenden Betriebssystembenutzergruppe zu und können Sie damit vor unberechtigten Zugriffen schützen.
-u <os_user>,<os_user_password> | Nur für Microsoft Windows: Betriebssystembenutzerspezifikation Der Service zum Starten des Datenbankkerns soll unter dem angegebenen Betriebssystembenutzer laufen. <os_user>: Name des Betriebssystembenutzers <os_user_password>: Kennwort des Betriebssystembenutzers

Beispiel

Ändern der Softwareversion im Kommandomodus

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ändern der aktuellen Softwareversion auf die Version 7.6, die unter dem Installationspfad C:\Program Files\sdb\76 abgelegt ist:

>dbmcli -u OLEG,MONDAY -d DEMODB db_reg -R "C:\Program Files\sdb\76"

OK

Ändern der Softwareversion im Sitzungsmodus

...

Aufrufen des Database Manager CLI, Anmelden als Benutzer DBM mit dem Kennwort DBM, Herstellen der Verbindung zur Datenbankinstanz DEMODB

Ändern der Softwareversion auf die Version 7.6 unter dem Installationspfad C:\Program Files\sdb\76,

Beenden des Database Manager CLI:

>dbmcli -u DBM,DBM -d DEMODB

dbmcli on DEMODB>db_reg -R "C:\Program Files\sdb\76"

dbmcli on DEMODB>exit

OK


db_reinstall (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_reinstall

Verwendung

Sie bauen die Datenbankinstanz auf der Basis ihrer aktuellen Konfiguration neu auf. Die in der Datenbank gespeicherten Daten werden vollständig gelöscht.

Sie könnten so beispielsweise eine Testdatenbank wieder in ihren leeren Ursprungszustand versetzen, um auf der Basis der gleichen Datenbankkonfiguration verschiedene Szenarios zu testen.

Das System durchläuft bei der Ausführung des DBM-Kommandos folgende Schritte:

...

1. Überführen in den Betriebeszustand ADMIN

2. Initialisieren der Datenbankinstanz

3. Laden der Systemtabellen

Wenn Sie die Daten noch benötigen, vergewissern Sie sich, dass Sie über aktuelle Sicherungen des Datenbestandes verfügen. Sobald Sie dieses DBM-Kommando ausführen, sind alle in der Datenbank gespeicherten Daten unwiederbringlich verloren. Verwenden Sie es deshalb mit äußerster Sorgfalt.

Voraussetzungen

Sie haben die Serverberechtigung AccessUtility.

Syntax

db_reinstall

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_release (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_release

Verwendung

Sie beenden die aktive Datenbanksitzung. Alle dieser Datenbanksitzung zugeordneten Ressourcen werden freigegeben.

Siehe auch:

Glossar, Strukturlink Datenbanksitzung

Voraussetzungen

Sie haben die Serverberechtigung AccessUtility, AccessSQL oder DBInfoRead.

Syntax

db_release

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_restart (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_restart

Verwendung

Sie überführen die Datenbankinstanz aus dem Betriebszustand ADMIN oder ONLINE zunächst in den Betriebszustand OFFLINE und dann in den Betriebszustand ONLINE.

Siehe auch:

Glossar, Strukturlink Restart

Voraussetzungen

Sie haben die Serverberechtigung DBStop.

Syntax

db_restart [-f | -s | -t | -d | -u <until>]

Optionen

Option

Beschreibung

-f | -fast

Es wird die Kernvariante fast gestartet.

-s | -slow

Es wird die Kernvariante slow gestartet.

-t | -test

Es wird die Kernvariante test gestartet.

-d | -dump

Beim Übergang von ADMIN oder ONLINE zu OFFLINE wird ein Dump erzeugt.

[-u | -until] <date> <time>
<date> ::= <yyyymmdd>
<time> ::= <hhmmss>

Zeitpunkt (Jahr, Monat, Tag, Stunde, Minuten, Sekunden), bis zu dem die noch in der Datenbankinstanz vorhandenen Log-Einträge wieder eingelesen werden sollen.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_restartinfo (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_restartinfo

Verwendung

Sie lassen sich die Restart-Information der Datenbankinstanz anzeigen.

Sie können so ermitteln, welche Datenseiten im Log-Bereich stehen und ob ein Restart der Datenbankinstanz möglich ist. Die Restart-Information benötigen Sie u. a. wenn Sie eine Datenbankinstanz wiederherstellen wollen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Restart-Information und Sicherungshistorie für das Einlesen von Sicherungen auswerten

Konzepte des Datenbanksystems, Strukturlink Beispiel: Restart

Voraussetzungen

● Sie haben die Serverberechtigung Recovery.

● Die Datenbankinstanz befindet sich im Betriebszustand ONLINE oder ADMIN.

Syntax

db_restartinfo

Antwort

OK

Used LOG Page <page_no>

First LOG Page <page_no>

Restartable (1|0)

Id Restart Record <database_ID>

Id LOG Info <database_ID>

Consistent (1|0)

Log Volume Enabled (1|0)

Log Auto Overwrite (1|0)

Master Servernode <computer_name>

Converter Version <converter_version_no>

Oldest Compatible Version <software_version_no>

Queue Count <log_queue_no>

Werte für die Felder der Antwort

Wert | Beschreibung
Used LOG Page | nach dem Restart vom System zu verwendende nächste Log-Seite
First LOG Page | älteste vorhandene Log-Seite
Restartable | Restartfähigkeit 1: Die Datenbankinstanz ist restartfähig. 0: Die Datenbankinstanz ist nicht restartfähig.
Id Restart Record | Datenbank-ID des Datenbereichs der Datenbankinstanz (gespeichert in der Restart-Information)
Id LOG Info | Datenbank-ID des Log-Bereichs der Datenbankinstanz
Consistent | Konsistenz der Datenbankinstanz, d.h. Restartfähigkeit ohne Einlesen von Log-Einträgen 1: restartfähig ohne Einlesen von Log-Einträgen 0: nicht restartfähig ohne Einlesen von Log-Einträgen
Log Volume Enabled | 1: Das Datenbanksystem schreibt Redo-Log-Einträge (Vorschlagswert) 0: Das Datenbanksystem schreibt keine Redo-Log-Einträge.
Log Auto Overwrite | Überschreibmodus für den Log-Bereich 1: eingeschaltet 0: ausgeschaltet
Master Servernode | Nur für Hot-Standby-Systeme relevant: Name des Rechners, auf dem die Master-Instanz läuft
Converter Version | Converter-Version
Oldest Compatible Version | älteste kompatible Version der Datenbanksoftware
Queue Count | Anzahl der Log-Warteschlangen

Im Fehlerfall siehe Antwortformat.

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem Rechner PARMA, Anzeigen der Restart-Information:

>dbmcli -u OLEG,MONDAY -d DEMODB db_restartinfo

OK

Used LOG Page 710

First LOG Page 2147483647

Restartable 1

Id Restart Record PARMA:DEMODB_20060202_141737

Id LOG Info PARMA:DEMODB_20060202_141737

Consistent 1

Log Volume Enabled 1

Log Auto Overwrite 1

Master Servernode PARMA

Converter Version 13

Oldest Compatible Version 7.6.00.22

Queue Count 1


db_speed (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_speed

Verwendung

Sie lassen sich die Variante des Datenbankkerns der aktuellen Datenbankinstanz anzeigen.

Die Datenbankinstanz darf sich nicht im Betriebszustand OFFLINE befinden. Andernfalls erhalten Sie als Antwort auf dieses Kommando eine Fehlermeldung.

Siehe auch:

Glossar, Strukturlink Variante des Datenbankkerns

Voraussetzungen

● Sie haben die Serverberechtigung DBInfoRead.

● Die Datenbankinstanz befindet sich im Betriebszustand ONLINE oder ADMIN.

Syntax

db_speed

Antwort

OK

Speed

(FAST | SLOW | TEST | UNKNOWN)

Werte für die Felder der Antwort

Wert | Beschreibung
FAST | Schnellste Variante des Datenbankkerns, es werden nur minimale Protokollierungen und Laufzeitprüfungen durchgeführt
SLOW | Variante des Datenbankkerns, bei der umfangreiche Protokollierungen und Laufzeitprüfungen erfolgen
TEST | Die Kernvariante TEST für zusätzliche Tests ist aktiv.
UNKNOWN | Die Kernvariante konnte nicht ermittelt werden.

Im Fehlerfall siehe Antwortformat.


db_standby (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_standby

Verwendung

Eine Standby-Instanz wird in den Betriebszustand STANDBY überführt und dem Hot Standby-System hinzugefügt. Hierbei erhält die Standby-Instanz eine exakte Kopie der Konfiguration der Master-Instanz.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Hot-Standby-System einrichten

Konzepte des Datenbanksystems, Strukturlink Hot-Standby

Voraussetzungen

● Das Hot Standby-System ist im Betriebszustand ONLINE.

● Alle Datenpfade und Dateien (Arbeitsverzeichnis, Volumes, Trace-Dateien etc.) von Master- und Standby-Instanz stimmen überein.

● Sie haben die Serverberechtigung DBStart.

Syntax

db_standby <hs_node_nnn>

hs_node_nnn

Rechnername/Adresse der Standby-Instanz nnn.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


db_state (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_state

Verwendung

Sie lassen sich den aktuellen Betriebszustand der Datenbankinstanz anzeigen.

Siehe auch:

Glossar, Strukturlink Betriebszustand

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

db_state [-v]

-v

Anzeigen der Füllungsgrade des Log- und Datenbereichs der Datenbankinstanz

Antwort

OK

<operational_state>

Log Full = <value>

Database Full = <value>

Werte für die Felder der Antwort

Wert | Beschreibung
<operational_state> | Betriebszustand der Datenbankinstanz, mögliche Werte sind u.a.: ONLINE: Die Datenbankinstanz ist betriebsbereit. ADMIN: Die Datenbankinstanz ist im Zustand der Betriebsruhe. Nur spezielle administrative Tätigkeiten sind möglich. OFFLINE: Die Datenbankinstanz ist nicht betriebsbereit. STOPPED INCORRECTLY: Nur bei Betriebssystem UNIX, die Datenbankinstanz steht nach einem Fehler. UNKNOWN: Der Betriebszustand konnte vom System nicht ermittelt werden.
Log Full = <value> | Füllungsgrad des Log-Bereichs, mögliche Werte sind: YES: Der Log-Bereich ist voll. NO: Der Log-Bereich ist nicht voll.
Database Full = <value> | Füllungsgrad des Datenbereichs, mögliche Werte sind: YES: Der Datenbereich ist voll. NO: Der Datenbereich ist nicht voll.


db_stop (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen db_stop

Verwendung

Sie überführen die Datenbankinstanz in den Betriebszustand OFFLINE. Im Gegensatz zum DBM-Kommando db_offline wird dabei unmittelbar der Prozess der Datenbankinstanz beendet. Verwenden Sie das DBM-Kommando db_stop deshalb nur dann, wenn das DBM-Kommando db_offline nicht zum Erfolg geführt hat.

Siehe auch:

Glossar, Strukturlink Betriebszustand

Voraussetzungen

Sie haben die Serverberechtigung DBStop.

Syntax

db_stop [<option>]

<option> :: = -d | -dump

-d | -dump

Beim Übergang vom Betriebszustand ONLINE oder ADMIN zu OFFLINE wird ein Dump erzeugt.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


dban_delete (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dban_delete

Verwendung

Sie löschen alte Protokollverzeichnisse des Programms Database Analyzer.

Siehe auch:

Dokumentation Database Analyzer

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

dban_delete <date>

<date>

Datum

Es werden alle Protokolldateien gelöscht, die dieses oder ein älteres Datum haben.

Zeitformat: <yyyymmdd> (Jahr,Monat,Tag)

Antwort

Sie erhalten die Ausgabe des Database Analyzer.

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Löschen aller Protokolldateien des Database Analyzer, die vom 12.12.2005 oder älter sind:

>dbmcli –u OLEG,MONDAY –d DEMODB dban_delete 20051212

OK

0,OK: everything works fine

0,"c:\program files\sdb\programs\bin\dbanalyzer" -d DEMODB -u *,* -delete 20051212

MaxDB Database Analyzer, The Performance Analysis Tool, Version 7.6.00.16

Copyright 2000-2005 by SAP AG

Used protocol directory: c:\documents and settings\all users\application data\sd

b\data\wrk\DEMODB\analyzer

Used configuration file: c:\program files\sdb\programs\env\dbanalyzer76.cfg


dban_start (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dban_start

Verwendung

Sie rufen im Database Manager das Programm Database Analyzer auf. Der Database Manager übergibt dabei implizit die Daten des Datenbanksystemadministrators an den Database Analyzer.

Zusammen mit dem Aufrufkommando können Sie auch Optionen für den Database Analyzer angeben.

Wenn der Database Analyzer bereits aktiv ist, wird nur sein Status angezeigt.

Siehe auch:

Dokumentation Database Analyzer

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

dban_start [<option_list>]

<option_list> : = <option> | <option> <option> …

<option>

Option für den Aufruf des Database Analyzer (Siehe: Database Analyzer, Optionen)

Antwort

Sie erhalten die Ausgabe des Database Analyzer.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Aufrufen des Database Analyzer,

Ändern des Zeitintervalls zwischen zwei Analysen auf 300 Sekunden und Begrenzen der Anzahl der Analysen auf 4:

>dbmcli -u OLEG,MONDAY -d DEMODB dban_start –t 300,4

OK

0,OK: everything works fine

0,"c:\program files\sdb\programs\bin\dbanalyzer" -d DEMODB -u *,* -state

MaxDB Database Analyzer, The Performance Analysis Tool, Version 7.6.00.16

Copyright 2000-2005 by SAP AG

Used protocol directory: c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB\analyzer

INFO 13: Database Analyzer active in directory "c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB\analyzer".

Database = DEMODB

Node =

Rundirectory = c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB

Configfile = c:\program files\sdb\programs\env\dbanalyzer76.cfg

Protocoldirectory = c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB\analyzer

Interval = 300

Reconnect = false

ProcessID = 4180

SessionID = 404

Driver = MaxDB

Started = 2006-03-30 09:54:50


dban_state (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dban_state

Verwendung

Sie lassen sich den Status des Programms Database Analyzer anzeigen.

Siehe auch:

Dokumentation Database Analyzer

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

dban_state

Antwort

Sie erhalten die Ausgabe des Database Analyzer über den aktuellen Status.

Beispiel

Aufrufen des Database Manager, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY an die Datenbankinstanz DEMODB, Anzeigen des Status des Database Analyzer

>dbmcli -u OLEG,MONDAY -d DEMODB dban_state

OK

0,OK: everything works fine

0,"c:\program files\sdb\programs\bin\dbanalyzer" -d DEMODB -u *,* -state

MaxDB Database Analyzer, The Performance Analysis Tool, Version 7.6.00.16

Copyright 2000-2005 by SAP AG

Used protocol directory: c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB\analyzer

INFO 20: Database Analyzer not active in directory "c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB\analyzer".

Database = DEMODB

Node =

Rundirectory = c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB

Configfile = c:\program files\sdb\programs\env\dbanalyzer76.cfg

Protocoldirectory = c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB\analyzer

Interval = 5

Reconnect = false

ProcessID = 5340

SessionID = 1631

Driver = MaxDB

Started = 2006-04-06 09:59:17

Stopped = 2006-04-06 09:59:44


dban_stop (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dban_stop

Verwendung

Sie beenden aus dem Database Manager heraus das Programm Database Analyzer.

Wenn der Database Analyzer nicht aktiv ist, wird nur sein Status ausgegeben.

Siehe auch:

Dokumentation Database Analyzer

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

dban_stop

Antwort

Sie erhalten die Ausgabe des Database Analyzer.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Beenden des Database Analyzer:

>dbmcli -u OLEG,MONDAY -d DEMODB dban_stop

OK

0,OK: everything works fine

0,"c:\program files\sdb\programs\bin\dbanalyzer" -d DEMODB -u *,* -stop

MaxDB Database Analyzer, The Performance Analysis Tool, Version 7.6.00.16

Copyright 2000-2005 by SAP AG

Used protocol directory: c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB\analyzer


dbm_configget (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_configget

Verwendung

Sie lassen sich den Wert eines oder mehrerer Konfigurationsparameter des Database Manager anzeigen. Mit Hilfe von Optionen können Sie die Anzeige einschränken.

Die Werte der Konfigurationsparameter stehen in drei verschiedenen Konfigurationsdateien:

● einer datenbankspezifischen Konfigurationsdatei

● einer für die Softwareversion spezifischen Konfigurationsdatei

● einer für den Datenbankrechner spezifischen Konfigurationsdatei

Die Werte der Parameter in der datenbankspezifischen Konfigurationsdatei übersteuern die Werte in der für die Softwareversion spezifischen Konfigurationsdatei, welche wiederum die Werte in der für den Datenbankrechner spezifischen Konfigurationsdatei übersteuern.

Beachten Sie deshalb, dass angezeigte Werte für Konfigurationsparameter im Database Manager von anderen Werten übersteuert sein können und damit nicht die aktuell verwendeten Werte repräsentieren.

Voraussetzungen

Sie haben die Serverberechtigung InstallMgm.

Syntax

dbm_configget [<file_range>] [<parameter_name>]

<file_range>:: = ALL|INSTANCE|INSTALLATION|GLOBAL

Optionen

Option | Beschreibung
<file_range> | zu durchsuchende Konfigurationsdatei/en, mögliche Werte sind: ALL|INSTANCE|INSTALLATION|GLOBAL ALL: Vorschlagswert, Suche in allen drei Konfigurationsdateien des Database Manager INSTANCE: Suche in der datenbankspezifischen Konfigurationsdatei INSTALLATION: Suche in der für die Softwareversion spezifischen Konfigurationsdatei GLOBAL: Suche in der für den Datenbankrechner spezifischen Konfigurationsdatei
<parameter_name> | Name des Konfigurationsparameters des Database Manager, wenn Sie diese Option nicht angeben, werden alle Konfigurationsparameter angezeigt

Antwort

OK

<parameter_value>

oder

<parameter_name> = <parameter_value>

<parameter_name> = <parameter_value>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<parameter_value> | Wert des Konfigurationsparameters
<parameter_name> | Name des Konfigurationsparameters

Im Fehlerfall siehe Antwortformat.

Beispiele

Anzeigen des Parameterwertes ohne Angabe einer Konfigurationsdatei

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen des Wertes des Konfigurationsparameters für die Funktion der automatischen Log-Sicherung (Die Funktion der automatischen Log-Sicherung kann nur den Wert 0 oder 1 haben):

>dbmcli -u OLEG,MONDAY -d DEMODB dbm_configget AUTOSAVE

OK

0

Ergebnis

Das System sucht in allen Konfigurationsdateien. Sie erhalten den gemäß obiger Regel (Abschnitt "Verwendung") ermittelten und aktuell verwendeten Wert.

Anzeigen des Parameterwertes mit Angabe einer Konfigurationsdatei

Wenn Sie hingegen zusätzlich angeben, dass nur in der für die Softwareversion spezifischen Konfigurationsdatei gesucht werden soll, können Sie für den gleichen Parameter einen anderen Wert erhalten. Dies ist der in diese Datei eingetragene Wert.

Das bedeutet: Wenn dieser Parameter auch in der datenbankspezifischen Konfigurationsdatei enthalten ist und dort einen anderen Wert hat, übersteuert er den hier angezeigten:

>dbmcli -u OLEG,MONDAY -d DEMODB dbm_configget INSTALLATION AUTOSAVE

OK

1

Ergebnis

Das System sucht nur in der für die Softwareversion spezifischen Konfigurationsdatei. Darin ist dieser Parameter mit dem Wert 1 eingetragen.


dbm_configset (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_configset

Verwendung

Sie definieren oder löschen einen Konfigurationsparameter des Database Manager in der angegebenen Konfigurationsdatei.

In folgenden drei Konfigurationsdateien sind Parameter für den Database Manager definiert:

· datenbankspezifische Konfigurationsdatei

· für die Softwareversion spezifische Konfigurationsdatei

· für den Datenbankrechner spezifische Konfigurationsdatei

Die Werte der Parameter in der datenbankspezifischen Konfigurationsdatei übersteuern die Werte in der für die Softwareversion spezifischen Konfigurationsdatei, welche wiederum die Werte in der für den Datenbankrechner spezifischen Konfigurationsdatei übersteuern.

Voraussetzungen

Sie haben die Serverberechtigung InstallMgm.

Syntax

dbm_configset [<config_file>] <parameter_name> [<value>]

Optionen

Option | Beschreibung
<config_file> | Konfigurationsdatei, in die der Parameterwert eingetragen oder aus der er gelöscht werden soll, mögliche Werte sind: INSTANCE | INSTALLATION | GLOBAL INSTANCE: datenbankspezifische Konfigurationsdatei, Vorschlagswert INSTALLATION: für die Softwareversion spezifische Konfigurationsdatei GLOBAL: für den Datenbankrechner spezifische Konfigurationsdatei
<paramater_name> | Name des Konfigurationsparameters
<value> | Wert des Konfigurationsparameters Wenn Sie keinen Wert angeben, wir der Parameter in der angegebenen Konfigurationsdatei gelöscht.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


dbm_execute_serverprocess (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_execute_serverprocess

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando.

Es ist gegenwärtig nicht dokumentiert.


dbm_getpath (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_getpath

Verwendung

Sie lassen sich die auf dem Datenbankrechner konfigurierten versionsunabhängigen Verzeichnisse anzeigen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Informationen über installierte Software und Datenbankinstanzen anzeigen, Abschnitt "Installationsverzeichnisse der versionsunabhängigen Datenbanksoftware anzeigen"

Installationshandbuch, Strukturlink Verzeichnisse

Voraussetzungen

Für die Ausführung dieses DBM-Kommandos ist keine Anmeldung an den Database Manager erforderlich. Sie benötigen auch keine Serverberechtigung.

Syntax

dbm_getpath <path_ID>

<path_ID>:: = IndepDataPath | IndepProgPath

Optionen

Option

Beschreibung

<path_ID>

Pfad für die Datenablage auf dem Datenbankrechner, mögliche Werte sind:

IndepDataPath | IndepProgPath

IndepDataPath: Pfad, unter dem die Daten, Konfiguration und Arbeitsverzeichnisse von Datenbankinstanzen und Anwendungen abgelegt sind

IndepProgPath: Pfad, unter dem die von allen Datenbankinstanzen und Anwendungen gemeinsam genutzten Programme und Bibliotheken abgelegt sind

Antwort

OK

<path>

Beispiel

Aufrufen des Database Manager CLI, Anzeigen des Pfades, unter dem die Daten, Konfiguration und Arbeitsverzeichnisse von Datenbankinstanzen und Anwendungen abgelegt sind:

>dbmcli dbm_getpath indepdatapath

OK

c:\documents and settings\all users\application data\sdb\data


dbm_getpid (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_getpid

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando.

Es ist gegenwärtig nicht dokumentiert.


dbm_listmemoryerror (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_listmemoryerror

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando.

Es ist gegenwärtig nicht dokumentiert.


dbm_next (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_next

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando.

Es ist gegenwärtig nicht dokumentiert.


dbm_setpath (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_setpath

Verwendung

Dieses DBM-Kommando wird nur vom Softwareinstallationsprogramm verwendet.

Es ist gegenwärtig nicht dokumentiert.


dbm_shm_info (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_shm_info

Verwendung

Sie lassen sich Informationen über das Shared-Memory des Database Manager anzeigen.

Siehe auch:

Glossar, Strukturlink Shared-Memory

Voraussetzungen

Sie haben die Serverberechtigung SharedMemoryAdmin.

Syntax

dbm_shm_info

Antwort

OK

VERSION

Required <version_no>

Found <version_no>

LOCKING

Lock <status>

Reserve lock <status>

Locking process <pid>

PROCESSES

<pid> <state>

<pid> <state>

<pid> <state>

...

[PERSISTENCE

<error_message>]

Werte für die Felder der Antwort

Wert | Beschreibung
Required <version_no> | Vom System erwartete Version des Shared-Memory
Found <version_no | Tatsächliche Version des Shared-Memory
Lock <status> Reserve lock <status> | Sperrstatus, mögliche Werte sind: LOCKED: gesperrt UNLOCKED: nicht gesperrt
Locking process <pid> | ID des sperrenden Prozesses
<state> | Zustand des Prozesses, mögliche Werte sind: ALIVE: der Prozess arbeitet DEAD: der Prozess ist nicht in der Prozessliste des Betriebssystems UNKNOWN: konnte nicht ermittelt werden
<error_message> | Meldungstext


dbm_shm_reset (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_shm_reset

Verwendung

Sie setzen den Inhalt des Shared-Memory zurück, indem Sie im Dateisystem die Datei löschen, die den Inhalt des Shared-Memory widerspiegelt. Dieses DBM-Kommando ist nur für das Beheben von Fehlersituationen gedacht.

Verwenden Sie dieses DBM-Kommando nur nach Aufforderung durch den Support, da es zu Inkonsistenzen im Datenbanksystem führen kann.

Siehe auch:

Glossar, Strukturlink Shared-Memory

Voraussetzungen

Sie haben die Serverberechtigung SharedMemoryAdmin.

Syntax

dbm_shm_reset

Antwort

OK

Im Fehlerfall siehe Antwortformat.


dbm_shm_unlock (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_shm_unlock

Verwendung

Sie entsperren das Shared-Memory. Dieses DBM-Kommando ist nur für das Beheben von Fehlersituationen gedacht.

Verwenden Sie dieses DBM-Kommando nur nach Aufforderung durch den Support, da es zu Inkonsistenzen im Datenbanksystem führen kann.

Siehe auch:

Glossar, Strukturlink Shared-Memory

Voraussetzungen

Sie haben die Serverberechtigung SharedMemoryAdmin.

Syntax

dbm_shm_unlock

Antwort

OK

Im Fehlerfall siehe Antwortformat.


dbm_version (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbm_version

Verwendung

Sie lassen sich die Versionsinformationen des Database Manager anzeigen. Durch die Angabe von Optionen können Sie die Anzeige der Versionsinformationen einschränken.

Da die Version des DBM-Server und damit des Programms Database Manager immer mit der Version der Datenbanksoftware identisch ist, können Sie auf diese Weise auch die Version der Datenbanksoftware ermitteln.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Informationen über installierte Software und Datenbankinstanzen anzeigen

Konzepte des Datenbanksystems, Strukturlink Versionsnotierung

Voraussetzungen

Für die Ausführung dieses DBM-Kommandos ist keine Anmeldung an den Database Manager erforderlich.

Sie benötigen auch keine Serverberechtigung.

Syntax

dbm_version [<detail>]>

Option

Option | Beschreibung
<detail> | Teil der Versionsinformation, mögliche Werte sind: version: Versionsnummer des Database Manager build: Identifikationsnummer des Database Manager os: Name des Betriebssystems instroot: Installationsverzeichnis der versionsabhängigen Komponenten logon: Anzeige ob eine Anmeldung an das Betriebssystem erfolgt ist code: im Database Manager verwendeten Zeichensatzes swap: im Database Manager verwendeter Swap-Typ Unicode: vom Datenbankkatalog verwendeter Zeichensatz instance: Typ des Datenbanksystems sysname: Name des Betriebssystems

Antwort

OK

VERSION    = <version>

BUILD      = <build_number>

OS         = <os>

INSTROOT   = <dependent_path>

LOGON      = <logon_state>

CODE = <code>

SWAP = <swap>

UNICODE = (YES|NO)

INSTANCE = (OLTP|LVC|unknown)

SYSNAME = <os>

Werte für die Felder der Antwort

Wert | Beschreibung
VERSION | Versionsnummer des Database Manager
BUILD | Identifikationsnummer des Database Manager
OS | Name des Betriebssystems
INSTROOT | Installationsverzeichnis der versionsabhängigen Komponenten
LOGON | Anzeige ob eine Anmeldung an das Betriebssystem erfolgt ist: True angemeldet False nicht angemeldet
CODE | Ausgabe des im Database Manager verwendeten Zeichensatzes, mögliche Werte sind ASCII oder UTF8
SWAP | Ausgabe des im Database Manager verwendeten Swap-Typs (interne Darstellung numerischer Werte): no hihi-hilo-lohi-lolo full lolo-lohi-hilo-hihi half lohi-lolo-hihi-hilo
UNICODE | vom Datenbankkatalog verwendeter Zeichensatz, mögliche Werte sind: yes: UNICODE no: ASCII
INSTANCE | Typ des Datenbanksystems, mögliche Werte sind: OLTP: MaxDB-Instanz LVC: liveCache-Instanz unknown: Der Instanztyp konnte nicht ermittelt werden.
SYSNAME | Name des Betriebssystems

Im Fehlerfall siehe Antwortformat.


dbmevtdisp_internal_add (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbmevtdisp_internal_add

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando.

Es ist gegenwärtig nicht dokumentiert.


dbmevtdisp_internal_communication (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbmevtdisp_internal_communication

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando.

Es ist gegenwärtig nicht dokumentiert.


dbmevtdisp_internal_delete (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen dbmevtdisp_internal_delete

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando.

Es ist gegenwärtig nicht dokumentiert.


diag_histlist (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen diag_histlist

Verwendung

Sie lassen sich die verfügbaren Protokolldateien anzeigen.

Wenn Sie das DBM-Kommando ohne Angabe eines Zeitstempels ausführen, erhalten Sie eine Liste aller verfügbaren Protokolldateien, das Verzeichnis, in dem sie abgelegt sind, und den jeweiligen Zeitstempel angezeigt.

Wenn Sie zusätzlich zum DBM-Kommando einen Zeitstempel angeben, erhalten Sie die Datei-IDs der Protokolldateien angezeigt. Mit Hilfe der Datei-ID können Sie sich den Inhalt einer solchen Datei anzeigen lassen (Siehe: file_getfirst).

Mit der Information über das Verzeichnis haben Sie jedoch auch die Möglichkeit, mit Mitteln des Betriebssystems auf Protokolldateien zuzugreifen. Der Pfad des Verzeichnisses, das die Protokolldateien enthält, ist durch den Wert des speziellen Datenbankparameter DIAG_HISTORY_PATH definiert.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

Sie haben die Serverberechtigung DBFileRead.

Syntax

diag_histlist [<YYYYMMDDHHMMSS>]

<YYYYMMDDHHMMSS>

Änderungsdatum der Sicherungshistorie

Zeitformat: Jahr Monat Tag Stunden Minuten Sekunden

Antwort nach Kommandoeingabe ohne Zeitstempel

Sie erhalten eine Liste aller verfügbaren Protokolldateien angezeigt.

OK

<timestamp> <directory>

<timestamp> <directory>

...

Antwort nach Kommandoeingabe mit Zeitstempel

Sie erhalten die Datei-IDs der verfügbaren Protokolldateien angezeigt.

OK

<file_ID>

<file_ID>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<timestamp> | Zeitstempel
<directory> | Verzeichnis
<file_ID> | Datei-ID Siehe auch: Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Im Fehlerfall siehe Antwortformat.

Beispiele

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Liste der zu dieser Instanz verfügbaren Protokolldateien:

>dbmcli -u OLEG,MONDAY –d DEMODB diag_histlist

OK

20050324150815 C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\DIAGHISTORY\DEMODB_20050324_15-08-15

20050324150845 C:\Documents and Settings\All Users\Application Data\sdb\data\wrk\DEMODB\\DIAGHISTORY\DEMODB_20050324_15-08-45

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Datei-IDs der Protokolldateien:

>dbmcli -u OLEG,MONDAY –d DEMODB diag_histlist 20050324150815

OK

DIAGHIST#20050324_15-08-15\knldiag

DIAGHIST#20050324_15-08-15\knldiag.run

DIAGHIST#20050324_15-08-15\knldiag.start

DIAGHIST#20050324_15-08-15\knltrace


diag_pack (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen diag_pack

Verwendung

Für die umfassende Diagnose eines Datenbankproblems benötigt der Support zahlreiche Protokolldateien der Datenbankinstanz. Sie fassen mit diesem Kommando alle notwendigen Protokolldateien zu einer komprimierten Archivdatei zusammen.

Vorschlagswerte des Database Manager für diese Archivdatei

Dateiname | diagpack.tgz
Verzeichnis | Arbeitsverzeichnis der Datenbankinstanz
Datei-ID | DIAGTGZ

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

Sie haben die Serverberechtigung DBFileRead.

Syntax

diag_pack [file=<archive>] [class=<spec_list> | class=hist[,<spec_list>] date=<timestamp>]

<spec_list>:: = <class_spec> | <class_spec>,...

Optionen

Option | Beschreibung
<archive> | Name und Pfad der zu erstellenden Archivdatei, Vorschlagswert: siehe oben
<class_spec> | Dateiklasse, die in das Paket aufgenommen werden soll Für die möglichen Werte siehe: Glossar, Strukturlink Dateiklasse Vorschlagswert ist protocol Mehrere Klassenangaben sind durch Komma voneinander zu trennen.
<timestamp> | Zeitstempel der Diagnosedatei, zusätzlicher Parameter für die Klasse hist Sie ermitteln den Zeitstempel durch das Anzeigen der Liste der verfügbaren Diagnosedateien (Siehe: diag_histlist)

Antwort

OK

Im Fehlerfall siehe Antwortformat.


event_available (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen event_available

Verwendung

Mit Hilfe dieses DBM-Kommandos lassen Sie sich anzeigen, ob Events ausgelöst wurden und mittels event_receive oder event_wait abgeholt werden können.

Bei der ersten Ausführung eines der DBM-Kommandos event_wait, event_receive oder event_available wird eine Event-Sitzung innerhalb der Database Manager-Sitzung erzeugt. Events, die von diesem Zeitpunkt an ausgelöst werden, werden gesammelt und können innerhalb der Event-Sitzung behandelt werden.

Wenn Events ausgelöst wurden, erhalten Sie eine OK-Meldung.

Siehe auch:

Utilities, Event-Dispatcher

Voraussetzungen

● Sie haben die Serverberechtigung DBInfoRead.

● Der Datenbankparameter _MAXEVENTTASK ist ausreichend groß konfiguriert (Siehe: Konzepte des Datenbanksystems, Strukturlink Support-Datenbankparameter).

Syntax

event_available

Antwort

OK

Im Fehlerfall siehe Antwortformat.


event_delete (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen event_delete

Verwendung

Sie legen fest, dass ein Event nicht mehr aktiv sein soll, so dass es vom Datenbanksystem nicht mehr ausgelöst wird.

Sie können dieses DBM-Kommando in jedem Betriebszustand der Datenbankinstanz ausführen.

Für eine Übersicht der aktivierbaren und deaktivierbaren Event-Kategorien
siehe: Konzepte des Datenbanksystems, Strukturlink Übersicht der Datenbank-Event-Kategorien

Siehe auch:

Utilities, Event-Dispatcher

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

event_delete <event_category> [<value>]

Optionen

Option | Beschreibung
<event_category> | Event-Kategorie
<value> | numerischer Wert, dessen Bedeutung vom Event abhängt

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Deaktivieren des Events DBFILLINGABOVELIMIT mit dem Wert 50:

>dbmcli -u OLEG,MONDAY -d DEMODB event_delete DBFILLINGABOVELIMIT 50

OK


event_list (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen event_list

Verwendung

Sie lassen sich eine Liste aller aktiven Events anzeigen.

Siehe auch:

Utilities, Event-Dispatcher

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

event_list

Antwort

OK

Name Priority Value Description

<event_category> <priority> <value> <description>

<event_category> <priority> <value> <description>

<event_category> <priority> <value> <description>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<event_category> | Event-Kategorie
<priority> | auswertbare Eigenschaft des Events mögliche Werte sind: LOW | MEDIUM | HIGH
<value> | zusätzlicher Wert, dessen Bedeutung vom Event abhängt
<description> | Beschreibung des Events

Im Fehlerfall siehe Antwortformat.

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Liste aller aktiven Events:

>dbmcli -u OLEG,MONDAY -d DEMODB event_list

OK

Name Priority Value Description

DBFILLINGABOVELIMIT LOW 70 Filling of the database exceeds the given percentage

DBFILLINGABOVELIMIT MEDIUM 80 Filling of the database exceeds the given percentage

DBFILLINGABOVELIMIT MEDIUM 85 Filling of the database exceeds the given percentage

DBFILLINGABOVELIMIT HIGH 90 Filling of the database exceeds the given percentage

DBFILLINGABOVELIMIT HIGH 95 Filling of the database exceeds the given percentage

DBFILLINGABOVELIMIT HIGH 96 Filling of the database exceeds the given percentage

DBFILLINGABOVELIMIT HIGH 97 Filling of the database exceeds the given percentage

DBFILLINGABOVELIMIT HIGH 98 Filling of the database exceeds the given percentage

DBFILLINGABOVELIMIT HIGH 99 Filling of the database exceeds the given percentage

DBFILLINGBELOWLIMIT LOW 70 Filling of the database has fallen short of the given percentage

DBFILLINGBELOWLIMIT LOW 80 Filling of the database has fallen short of the given percentage

DBFILLINGBELOWLIMIT LOW 85 Filling of the database has fallen short of the given percentage

...

...


event_list_categories (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen event_list_categories

Verwendung

Sie lassen sich die Liste aller Event-Kategorien anzeigen, für die Events gesetzt werden können. Zu jeder Event-Kategorie wird ein Erläuterungstext angezeigt.

Siehe auch:

Konzepte des Datenbank-Systems, Strukturlink Übersicht der Datenbank-Event-Kategorien

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

event_list_categories

Antwort

OK

<event_category>

<description>

<event_category>

<description>

<event_category>

<description>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<event_category> | Event-Kategorie
<description> | Erläuterungstext

Im Fehlerfall siehe Antwortformat.


event_receive (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen event_receive

Verwendung

Wenn ein Event ausgelöst wurde, können Sie es mit diesem DBM-Kommando abholen.

Um weitere Events abzuholen, wiederholen Sie dieses DBM-Kommando. Die Events werden in der zeitlichen Reihenfolge ihres Auslösens abgeholt, die älteren Events zuerst.

Bei der ersten Ausführung eines der DBM-Kommandos event_wait, event_receive oder event_available wird eine Event-Sitzung innerhalb der Database Manager-Sitzung erzeugt. Events, die von diesem Zeitpunkt an ausgelöst werden, werden gesammelt und können innerhalb der Event-Sitzung behandelt werden.

Wenn kein Event ausgelöst wurde, erhalten Sie auf das DBM-Kommando event_receive eine Fehlermeldung.

Siehe auch:

Utilities, Event-Dispatcher

Voraussetzungen

● Sie haben die Serverberechtigung DBInfoRead.

● Der Datenbankparameter _MAXEVENTTASK ist ausreichend groß konfiguriert (Siehe: Konzepte des Datenbanksystems, Strukturlink Support-Datenbankparameter).

Syntax

event_receive

Antwort

OK

NAME=<event_category>

PRIORITY=<priority>

VALUE1=<value1>

VALUE2=<value2>

DATE=<yyyymmdd>

TIME=<HHmmss>

COUNT=<count>

TEXT=[<text>]

Werte für die Felder der Antwort

Wert | Beschreibung
<event_category> | Event-Kategorie
<priority> | auswertbare Eigenschaft des Events, mögliche Werte sind: LOW | MEDIUM | HIGH
<value1> | numerischer Wert 1, dessen Bedeutung vom Event abhängt, bei den Events der Kategorien DBFILLINGABOVELIMIT, DBFILLINGBELOWLIMIT und LOGABOVELIMIT: Anzahl der belegten Seiten
<value2> | numerischer Wert 2, dessen Bedeutung vom Event abhängt, bei den Events der Kategorien DBFILLINGABOVELIMIT, DBFILLINGBELOWLIMIT und LOGABOVELIMIT: Prozentsatz der belegten Seiten
<date> | Tag, an dem das Event ausgelöst wurde Zeitformat: <yyyymmdd> (Jahr Monat Tag)
<time> | Zeit, zu der das Event ausgelöst wurde Zeitformat: <HHMMSS> (Stunden Minuten Sekunden)
<count> | laufende Nummer des Events Das System beginnt die Nummerierung mit dem Überführen der Datenbankinstanz in den Betriebszustand ONLINE.
<text> | Text, dessen Bedeutung vom Event abhängt

Im Fehlerfall siehe Antwortformat.


event_release (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen event_release

Verwendung

Beim Warten auf ein Event wird implizit eine Event-Sitzung aufgebaut (Siehe: event_wait).

Mit diesem DBM-Kommando beenden Sie die Event-Sitzung.

Siehe auch:

Utilities, Event-Dispatcher

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

event_release

Antwort

OK

Im Fehlerfall siehe Antwortformat.


event_set (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen event_set

Verwendung

Sie legen fest, dass vom Datenbanksystem ein Event ausgelöst werden soll, sobald eine definierte Situation eintritt. Sie können dieses DBM-Kommando in jedem Betriebszustand der Datenbankinstanz ausführen, und das Event ist sofort aktiv.

Für eine Übersicht der aktivierbaren und deaktivierbaren Events siehe: Konzepte des Datenbanksystems, Strukturlink Übersicht der Datenbank-Event-Kategorien

Mit Hilfe des Event-Dispatchers können Sie die vom Datenbanksystem ausgelösten Events behandeln und damit beispielsweise nutzen, um periodische Verwaltungsaufgaben zu automatisieren. Dazu legen Sie im Event-Dispatcher eine Event-Definition an, in der Sie festlegen, dass und wie ein vom Datenbanksystem ausgelöstes Event behandelt werden soll.

Siehe auch:

Nutzen von Events der Datenbankinstanz

Tutorial Datenbankverwaltung, Strukturlink Log automatisch sichern nach Event LOGABOVELIMIT

Utilities, Event-Dispatcher

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

event_set <event_category> <priority> <value>

<priority> :: = LOW | MEDIUM | HIGH

Optionen

Option

Beschreibung

<event_category>

Event-Kategorie, mögliche Werte sind:

DBFILLINGABOVELIMIT | DBFILLINGBELOWLIMIT | LOGABOVELIMIT

DBFILLINGABOVELIMIT:

Das System löst Events dieser Event-Kategorie aus, wenn der Füllungsgrad des Datenbereichs die vordefinierten Werte überschreitet.

Vorschlagswerte des Systems sind Events bei den Füllungsgraden 90%, 95%, 96%, 97%, 98%, 99% (mit Priorität HIGH), bei den Füllungsgraden 80%, 85% (mit Priorität MEDIUM) und beim Füllungsgrad 70% (mit Priorität LOW)

DBFILLINGBELOWLIMIT:

Das System löst Events dieser Event-Kategorie aus, wenn der Füllungsgrad des Datenbereichs die vordefinierten Werte unterschreitet.

Vorschlagswerte des Systems sind Events bei den Füllungsgraden 70%, 80%, 85%, 90%, 95% (mit Priorität LOW)

LOGABOVELIMIT:

Das System löst Events dieser Event-Kategorie aus, wenn der Füllungsgrad des Log-Bereichs die vordefinierten Werte überschreitet.

Vorschlagswerte des Systems sind Events bei den Füllungsgraden 96%, 97%, 98%, 99% (mit Priorität HIGH ), bei den Füllungsgraden 90%, 95% (mit Priorität MEDIUM) und bei den Füllungsgraden 50%, 75% (mit Priorität LOW)

<priority>

auswertbare Eigenschaft des Events

mögliche Werte sind: LOW | MEDIUM | HIGH

Bei den Events die zu einer änderbaren Event-Kategorie gehören, können Sie die als Vorschlagswerte im Datenbanksystem definierten Werte übersteuern.

<value>

numerischer Wert, dessen Bedeutung vom Event abhängt

DBFILLINGABOVELIMIT:

Sie können für jedes Überschreiten eines Füllungsgrads zwischen 0% und 99% ein eigenes Event mit einer bestimmten Priorität definieren (Wertebereich 0 ≤ n ≤ 99).

DBFILLINGBELOWLIMIT:

Sie können für jedes Unterschreiten des Füllungsgrads zwischen 1% und 100% ein eigenes Event mit einer bestimmten Priorität definieren (Wertebereich 1 ≤ n ≤ 100).

LOGABOVELIMIT

Sie können für jedes Überschreiten des Füllungsgrads zwischen 0% und 100% ein eigenes Event mit einer eigenen Priorität definieren (Wertebereich 0 < n < 100).

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Aktivieren des Events DBFILLINGABOVELIMIT mit der Priorität LOW und dem Wert 50.

>dbmcli -u OLEG,MONDAY -d DEMODB event_set DBFILLINGABOVELIMIT LOW 50

OK


event_wait (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen event_wait

Verwendung

Sie arbeiten im Sitzungsmodus des Database Manager und holen sich die Mitteilungen über das Eintreten eines Events und die dazugehörigen Daten ab. Diese werden anschließend gelöscht.

Bei der ersten Ausführung eines der DBM-Kommandos event_wait, event_receive oder event_available wird eine Event-Sitzung innerhalb dieser Database Manager-Sitzung erzeugt. Events, die von diesem Zeitpunkt an ausgelöst werden, werden gesammelt und können innerhalb dieser Sitzung behandelt werden.

Die Events werden in der zeitlichen Reihenfolge ihres Auslösens abgeholt, die älteren Events zuerst.

Wenn die Daten über das eingetretene Event abgeholt wurden, werten Sie sie aus und warten durch die erneute Eingabe des DBM-Kommandos auf die nächste Mitteilung des Database Manager über das Eintreten eines Events.

Sie erhalten auf dieses DBM-Kommando erst dann eine Antwort, wenn ein Event eintritt.

Wenn Sie das Abholen der Mitteilungen beenden wollen, müssen Sie die Event-Sitzung explizit beenden (Siehe: event_release)

Verwenden Sie dieses DBM-Kommando vorzugsweise über eine Programmierschnittstelle des Database Manager.

Siehe auch:

Utilities, Event-Dispatcher

Voraussetzungen

● Sie haben die Serverberechtigung DBInfoRead.

● Der Datenbankparameter _MAXEVENTTASK ist ausreichend groß konfiguriert (Siehe: Konzepte des Datenbanksystems, Strukturlink Support-Datenbankparameter).

Syntax

event_wait

Antwort

OK

NAME=<event_category>

PRIORITY=<priority>

VALUE1=<value1>

VALUE2=<value2>

DATE=<yyyymmdd>

TIME=<HHmmss>

COUNT=<count>

TEXT=[<text>]

Werte für die Felder der Antwort

Wert | Beschreibung
<event_category> | Event-Kategorie
<priority> | auswertbare Eigenschaft des Events mögliche Werte sind: LOW | MEDIUM | HIGH
<value1> | numerischer Wert 1, dessen Bedeutung vom Event abhängt, bei den Events der Kategorien DBFILLINGABOVELIMIT, DBFILLINGBELOWLIMIT und LOGABOVELIMIT: Anzahl der belegten Seiten
<value2> | numerischer Wert 2, dessen Bedeutung vom Event abhängt, bei den Events der Kategorien DBFILLINGABOVELIMIT, DBFILLINGBELOWLIMIT und LOGABOVELIMIT: Prozentsatz der belegten Seiten
<date> | Tag, an dem das Event ausgelöst wurde Zeitformat: <yyyymmdd> (Jahr Monat Tag)
<time> | Zeit, zu der das Event ausgelöst wurde Zeitformat: <HHMMSS> (Stunden Minuten Sekunden)
<count> | laufende Nummer des Events Das System beginnt de Nummerierung mit dem Überführen der Datenbankinstanz in den Betriebszustand ONLINE.
<text> | Text, dessen Bedeutung vom Event abhängt

Im Fehlerfall siehe Antwortformat.

Beispiel

1. Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>

2. Ausführen des DBM-Kommandos zum Warten auf ein Event:

dbmcli on DEMODB>event_wait

OK

NAME=DBFILLINGABOVELIMIT

PRIORITY=LOW

DATE=20050615

TIME=150344

VALUE1=6998

VALUE2=70

COUNT=8

TEXT=


exec_lcinit (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen exec_lcinit

Dieses Kommando ist nur im Zusammenhang mit SAP-Anwendungen relevant.

Verwendung

Sie starten aus dem Database Manager heraus das auf dem Datenbankrechner abgelegte liveCache-Initialisierungsskript. Zusammen mit diesem DBM-Kommando können Sie eine Option angeben, die vom Database Manager an das liveCache-Initialisierungsskript übergeben wird.

Die Ausgaben des liveCache-Initialisierungsskripts werden vom Database Manager CLI angezeigt.

Siehe auch:

Glossar, Strukturlink liveCache (SAP liveCache-Technologie)

Voraussetzungen

Sie haben die Serverberechtigung SystemCmd.

Syntax

exec_lcinit [<option>]

<option>:: = init | register | restart | slow | stop | shutdown

Optionen

Option | Beschreibung
init | Die liveCache-Instanz wird initialisiert.
register | Die liveCache-Bibliotheken werden neu geladen. Dazu wird die liveCache-Instanz – falls notwendig - zuerst in den Betriebszustand ONLINE überführt.
restart | Vorschlagswert des Systems, wenn Sie keine Option angeben Ein Restart der liveCache-Instanz wird durchgeführt.
slow | Die Kernvariante slow wird gestartet.
stop | Das DBM-Kommando db_stop wird ausgeführt.
shutdown | Das DBM-Kommando db_offline wird ausgeführt.

Antwort

OK

<return_code>,<description>)

<pgm_code>,<command>

<command_output_lines>

Werte für die Felder der Antwort

Wert | Beschreibung
<return_code> | Rückgabewert des Database Manager Wenn der Wert 0 ist, dann wurde das DBM-Kommando erfolgreich ausgeführt. Für jeden anderen Wert siehe Strukturlink Meldungen.
<description> | Kurztext der Meldung
<pgm_code> | Rückgabewert des liveCache-Initialisierungsskripts
<command> | ausgeführte Kommandozeile
<command_output_lines> | Ausgabetext des Programms


exec_nipingsrv (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen exec_nipingsrv

Verwendung

Dieses DBM-Kommando wird ausschließlich von SAP-Anwendungen verwendet.

Es ist gegenwärtig nicht dokumentiert.


exec_sdbinfo (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen exec_sdbinfo

Verwendung

Dieses DBM-Kommando wird ausschließlich von SAP-Anwendungen verwendet.

Es ist gegenwärtig nicht dokumentiert.


explain (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen explain

Verwendung

Für eine Reihe von DBM-Kommandos können Sie sich mit Hilfe dieses DBM-Kommandos einen Erläuterungstext anzeigen lassen.

Durch die Angabe von Optionen können Sie die Anzeige dieses Erläuterungstexts modifizieren.

Siehe auch:

DBM-Kommandos

Voraussetzungen

Für die Ausführung dieses DBM-Kommandos ist keine Benutzeranmeldung an den Database Manager erforderlich.

Syntax

explain <dbm_command> <display_spec>

<display_spec> :: = <command_option> [-nolinewrap | -longinfo]

Optionen

Option | Beschreibung
<dbm_command> | DBM-Kommando
<command_option> | Kommandooption für dieses DBM-Kommando, deren Erläuterungstext angezeigt werden soll
-nolinewrap | Zeilenumbruch im Erläuterungstext unterdrücken
-longinfo | nur relevant für die Programmierung von DBM-Client-Programmen: Anzeige eines Langtextes über die zulässigen Werte

Antwort

OK

<explain_text>

<explain_text>

Erläuterungstext

Beispiele

Aufrufen des Database Manager CLI, Anzeigen des vollständigen Erläuterungstexts zum DBM-Kommando auto_extend:

>dbmcli explain auto_extend

OK

With this command, the database instance can be configured to automatically

create new data volumes, when the degree of filling reaches a certain limit.

Size and location of the new data volume are determined as explained in

DBMServer command db_addvolume.

Preconditions:

You have the server authorization ParamFull or AccessUtility.

Syntax:

auto_extend <mode> [<percentage>]

Options:

<mode>

New mode for the database. Possible values are:

ON activate automatic database extension

OFF deactivate automatic database extension

SHOW show current status of automatic database extension

<percentage>

Limit of degree of filling of the database instance, at which a new

data volume should be added. 1 <= <percentage> <= 100 must be true.

Default is 90. Use only with <mode> ON.

Reply:

OK

[ON <percentage>|OFF[, <reason>]|UNKNOWN]

Meaning of the individual fields of the reply:

ON

Automatic database extension is activated (only if <mode> is SHOW).

<percentage> is the actual degree of filling of the database

instance, at which a new data volume is added in the current

configuration.

OFF

Automatic database extension is deactivated (only if <mode> is

SHOW)

UNKNOWN

Status of automatic database extension is unknown (only if <mode>

is SHOW)

Aufrufen des Database Manager CLI, Anzeigen des Erläuterungstexts zur Kommandooption percentage für das DBM-Kommando auto_extend:

>dbmcli explain auto_extend percentage

OK

Limit of degree of filling of the database instance, at which a new data volume should be added. 1 <= <percentage> <= 100 must be true. Default is 90. Use only with <mode> ON.


file_backup (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen file_backup

Verwendung

Sie legen eine Sicherheitskopie der angegebenen Datenbankdatei an.

Im Normalfall ist es nicht erforderlich, Sicherheitskopien von internen Dateien des Database Manager anzulegen, da das Programm bei allen Schreibzugriffen auf Konfigurationsdateien selbst Sicherheitskopien anlegt.

Voraussetzungen

● Sie haben die Serverberechtigung DBFileRead.

● Sie haben die Datei-ID der gewünschten Datenbankdatei ermittelt (Siehe: file_getlist).

Syntax

file_backup <file_ID>

Antwort

OK

Im Fehlerfall siehe Antwortformat.


file_getfirst (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen file_getfirst

Verwendung

Sie öffnen die angegebene Datenbankdatei. Es wird der erste Block des Dateiinhalts angezeigt.

Auf der Kommandozeile können Sie mit diesem DBM-Kommando nur den Inhalt von Klartext-Dateien anzeigen. Programme können auf den Inhalt von Binärdateien über die DBM-Schnittstelle zugreifen.

Bei Dateien im Klartext werden die Daten aus der Datei zeilenweise gelesen. Jede Zeile wird im Ausgabebereich wieder um einen Zeilenvorschub (0x0D,0x0A) erweitert.

Bei einem UNIX-Rechner besteht ein Zeilenvorschub nur aus einem Zeichen. Deshalb kann es sein, dass der anfänglich für die Dateilänge ausgegebene Wert kleiner ist als die Datenlänge.

Da Sie mit diesem DBM-Kommando ausschließlich auf Datenbankdateien zugreifen können, ist keine Anmeldung an das Betriebssystem erforderlich.

Siehe auch:

Glossar, Strukturlink Datenbankdatei

Voraussetzungen

● Sie haben die Serverberechtigung DBFileRead.

● Sie haben die Datei-ID der gewünschten Datenbankdatei ermittelt (Siehe: file_getlist).

Syntax

file_getfirst <file_ID> [<file_spec>]

<file_spec> :: = DATE=<timestamp> | LINE=<nnn>

Optionen

Option | Beschreibung
<file_ID> | Datei-ID, für die möglichen Werte siehe: Konzepte des Datenbanksystems, Strukturlink Protokolldateien oder Strukturlink Konfigurationsdateien
DATE=<timestamp> | Es wird der Inhalt ab der Zeile mit dem angegeben Zeitstempel ausgegeben.
LINE=<nnn> | Es wird der Inhalt von Textdateien ab Zeile nnn ausgegeben.

Antwort

OK

<file_handle>

CONTINUE|END

<file_length><data_length>

<data_line>

<data_line>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<file_handle> | numerischer Wert, der für nachfolgende Zugriffe auf diese Datei verwendet werden kann
END | Der Inhalt der Datei wurde vollständig übertragen. Die Datei wird automatisch geschlossen.
CONTINUE | Die Datei hat noch weitere Einträge, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden. Sie können diese durch erneutes Eingeben des DBM-Kommandos anzeigen oder die Datei schließen.
<file_length> | Dateilänge, Länge dieser Angabe: max. 20 Zeichen
<data_length> | Länge des angezeigten Datenblocks, Länge dieser Angabe: max. 20 Zeichen
<data_line> | Datenzeile

Im Fehlerfall siehe Antwortformat.


file_getlist (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen file_getlist

Verwendung

Sie lassen sich die Liste der Datenbankdateien der aktuellen Datenbankinstanz anzeigen. Sie haben die Möglichkeit, den Umfang der ausgegebenen Dateiliste zu spezifizieren.

Es werden jedoch nur jene Dateien angezeigt, auf die das System zum Zeitpunkt der Ausführung des DBM-Kommandos tatsächlich zugreifen kann. Daher kann die Liste in Abhängigkeit vom Zustand der Datenbankinstanz variieren.

Siehe auch:

Glossar, Strukturlink Datenbankdatei

Voraussetzungen

Sie haben die Serverberechtigung DBFileRead.

Syntax

file_getlist <list_level>

<list_level>

Umfang der anzuzeigenden Dateiliste, mögliche Werte sind

0: die wichtigsten Dateien, Vorschlagswert

1: alle Dateien

Antwort

OK

key_name,mode,size,date,time,comment,file_name

<file_ID> <mode> <file_length> <date> <time> <comment> <file_name>

<file_ID> <mode> <file_length> <date> <time> <comment> <file_name>

...

Werte für die Felder der Antwort

Feld | Beschreibung
<file_ID> | Datei-ID der Datenbankdatei
<mode> | Angabe, ob es sich um eine Klartext- oder Binärdatei handelt, mögliche Werte sind: ASCII|BINARY ASCII: Klartextdatei (auch UNICODE) BINARY: Binärdatei
<file_length> | Größe der Datenbankdatei
<date> | Datum der letzten Änderung
<time> | Zeitpunkt der letzten Änderung
<comment> | Zusätzliche Informationen
<file_name> | Dateiname

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Liste der wichtigsten Datenbankdateien:

>dbmcli -u OLEG,MONDAY -d DEMODB file_getlist 1

OK

keyname,mode,size,date,time,comment,filename

KNLDIAG ASCII 50608 20050421 133815 Database Messages knldiag.classic

KNLDIAGERR ASCII 1447 20050421 133815 Database Errors knldiag.err.classic

KNLDIAGOLD ASCII 56767 20050421 133816 Database Messages (OLD) knldiag.old.classic

KNLTRC BINARY 5595136 20050418 141944 Database Trace knltrace

UTLPRT ASCII 102400 20050418 141927 Utility Statements dbm.utl

BACKHIST ASCII 1424 20050418 131056 Backup History dbm.knl

...


file_getnext (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen file_getnext

Verwendung

Sie fordern die Ausgabe des weiteren Inhalts einer geöffneten Datenbankdatei an.

Sie verwenden dazu das beim Öffnen der Datenbankdatei ausgegebene Datei-Handle (Siehe: file_getfirst).

Siehe auch:

Glossar, Strukturlink Datenbankdatei

Voraussetzungen

● Sie haben eine Datenbankdatei geöffnet. Das Schlüsselwort CONTINUE in der Antwort zeigt an, dass die Datei noch nicht vollständig übertragen wurde.

● Sie haben die Serverberechtigung DBFileRead.

● Sie haben die Datei-ID für die Datei ermittelt (Siehe: file_getlist).

Syntax

file_getnext <file_ID> <file_handle>

Antwort

OK

<file_handle>

CONTINUE|END

<file_length><data_length>

<data_line>

<data_line>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<file_handle> | numerischer Wert, der für nachfolgende Zugriffe auf diese Datei verwendet werden kann
END | Der Inhalt der Datei wurde vollständig übertragen. Die Datei wird automatisch geschlossen.
CONTINUE | Die Datei hat noch weitere Einträge, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden. Sie können diese durch erneutes Eingeben des DBM-Kommandos anzeigen oder die Datei schließen.
<file_length> | Dateilänge Die Gesamtlänge der Datei wird nicht noch einmal ermittelt und ist daher mit 0 ausgewiesen.
<data_length> | Länge des angezeigten Datenblocks, Länge dieser Angabe: max. 20 Zeichen
<data_line> | Datenzeile

Im Fehlerfall siehe Antwortformat.


file_operation (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen file_operation

Verwendung

Sie löschen Teile des Inhalts oder ganze Datenbankdateien.

Wenn Sie das Kommando auf eine nicht zulässige Datei anwenden, erhalten Sie den Fehler
-24996 ERR_PARAM - wrong parameters.

Siehe auch:

Glossar, Strukturlink Datenbankdatei

Voraussetzungen

● Sie haben dieServerberechtigung DBFileRead.

● Sie haben die Datei-ID der zu bearbeitenden Datei ermittelt (Siehe:file_getfirst) .

Syntax

file_operation <file_ID> <action>

<action> :: = <delete_action> | <shrink_action>

<delete_action>:: = OP=DELETE [DATE=<yyyymmddhhmmss>]

<shrink_action>:: = OP=SHRINK <option>

<option> :: = DATE=<yyyymmddhhmmss> | LINE=<n>

Optionen

Option | Beschreibung
<file_ID> | Protokolldatei/en der Datenbankinstanz
OP=DELETE [DATE=<yyyymmddhhmmss>] | Die Datei/en wird/werden gelöscht. Mit der Option DATE=<yyyymmddhhmmss> können Sie eingrenzen, dass nur jene Dateien zu löschen sind, die nach dem angegebenen Zeitpunkt nicht mehr geändert wurden.
OP=SHRINK <option> | Teile des Inhalts der Datei werden gelöscht. Über Optionen können Sie eingrenzen, welche Teile gelöscht werden sollen: Wenn Sie die Option DATE=<yyyymmddhhmmss> angeben, dann werden alle Zeilen gelöscht, die vor dem angegebenen Zeitpunkt geschrieben wurden. Wenn Sie die Option LINE=<n> angeben, wird der Inhalt der Datei auf die Zeilenzahl <n> reduziert. Die zuletzt geschriebenen <n> Zeilen bleiben erhalten.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


file_restore (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen file_restore

Verwendung

Sie kopieren die vom System angefertigte Sicherheitskopie der angegebenen Datenbankdatei zurück an die Originalposition. Die dort eventuell vorhandene Datei wird überschrieben.

Im Normalfall ist es nicht erforderlich, Sicherheitskopien der Datenbankdateien manuell an ihre Originalposition zu kopieren, da das System selbständig die Sicherheitskopie einer Datenbankdatei verwendet, wenn der Zugriff auf die Originaldatei fehlschlägt.

Siehe auch:

Glossar, Strukturlink Datenbankdatei

Voraussetzungen

● Sie haben die Serverberechtigung DBFileRead.

● Sie haben die Datei-ID der zu kopierenden Datei ermittelt (Siehe: file_getlist).

Syntax

file_restore <file_ID>

Antwort

OK

Im Fehlerfall siehe Antwortformat


get_default (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen get_default

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


help (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen help

Verwendung

Sie lassen sich die Liste aller DBM-Kommandos anzeigen. Durch die Angabe von Optionen können Sie die Anzeige dieser Liste einschränken.

Sie einhalten eine Beschreibung der Syntax für die Eingabe von DBM- Kommandos, Angaben zu den möglichen und/oder notwendigen DBM-Optionen sowie Informationen darüber, ob die Ausführung des DBM-Kommandos eine Datenbank- oder eine Servicesitzung voraussetzt.

Veraltete Kommandos sind mit einem Hinweis auf den neuen Namen des Kommandos versehen.

Antwortzeilen mit mehr als 80 Zeichen werden umgebrochen.

Voraussetzungen

Für die Ausführung dieses DBM-Kommandos ist keine Benutzeranmeldung an den Database Manager erforderlich.

Syntax

help [<option>]

<option>::= <string> | <fuzzy_option> | <obsolete_option>

<fuzzy_option>:: = –k <string>

<obsolete_option>:: = -obsolete [<string>]

Optionen

Option

Beschreibung

<string>

Zeichenkette

Es werden nur jene aktuellen DBM-Kommandos angezeigt, die mit der angegebenen Zeichenkette beginnen.

-k <string>

fehlertolerante Suche nach eine Zeichenkette im DBM-Kommando

-obsolete [<string>]

Es werden ausschließlich die veralteten DBM-Kommandos angezeigt. Zu jedem dieser Kommandos erhalten Sie einen Hinweis auf die aktuelle Bezeichnung.

Wenn Sie eine Zeichenkette angeben, wird die Anzeige auf jene veralteten DBM-Kommandos eingegrenzt, die diese Zeichenkette enthielten.

Wenn Sie keine Zeichenkette angeben, werden alle veralteten DBM-Kommandos angezeigt.

Antwort

OK

<dbm_command> <description>

<dbm_command> <description>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<dbm_command> | DBM-Kommando
<description> | Beschreibung des DBM-Kommandos, der möglichen Optionen und ihrer Verwendung für veraltete DBM-Kommandos wird das aktuell gültige ausgewiesen

Im Fehlerfall siehe Antwortformat.

Beispiele

Aufrufen des Database Manager CLI, Anzeigen aller gültigen DBM-Kommandos:

dbmcli help

OK

apropos <command_name_part>

archive_stage <medium> <stage> [verify|noverify] [remove|keep]

[FileNumberList <list>]

archive_stage_repeat <medium> [verify|noverify] [remove|keep]

auto_extend <mode> [<percentage>]

autolog_cancel

autolog_off

autolog_on [<medium>]

autolog_show

autorecover [LOG] [UNTIL <date> <time>] [ ( KEY <key> LABEL

<label> ) | ( IBID <internal_backup_ID> ) ]

auto_update_statistics <mode>

backup_cancel (needs backup session)

backup_ext_ids_forget

...

...

Aufrufen des Database Manager CLI, Anzeigen aller DBM-Kommandos, die die Zeichenkette shm enthalten:

>dbmcli help –k shm

OK

dbm_shm_info

dbm_shm_reset

dbm_shm_unlock

Aufrufen des Database Manager CLI, Anzeigen aller veralteten DBM-Kommandos, die die Zeichenkette recover enthalten :

>dbmcli help –obsolete recover

OK

recover_devspace (obsolete version of recover_volume)


hss_addstandby (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen hss_addstandby

Verwendung

Sie fügen eine Standby-Instanz zu einem Hot-Standby-System hinzu.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Hot-Standby-System einrichten

Konzepte des Datenbanksystems, Strukturlink Hot-Standby

Voraussetzungen

● Sie sind an die Datenbankinstanz des Hot-Standby-Systems auf dem Virtual Server angemeldet.

● Die Datenbankinstanz, die Sie hinzufügen möchten, hat denselben Namen wie die Master-Instanz.

● Die Datenbankinstanz, die Sie hinzufügen möchten, ist im Betriebszustand ONLINE.

● Sie haben die Serverberechtigung ParamFull.

Syntax

hss_addstandby <hs_node> login=<os_user>,<os_user_password> [path=<dependent_path>] [delay=<hs_delay_time>]

Optionen

Option | Beschreibung
<hs_node> | Rechnername oder IP-Adresse der Standby-Instanz
<os_user> | Betriebssystembenutzer auf dem Standby-Rechner, muss Administrationsrechte auf dem Rechner haben.
<os_user_password> | Kennwort des Betriebssystembenutzers
<dependent_path> | Installationspfad der von der Datenbankversion abhängigen Server-Software auf dem Standby-Rechner Wenn Sie keinen Pfad angeben, dann verwendet das System die Datenbanksoftware derselben Version wie die der Master-Instanz.
<hs_delay_time> | Zeitverzögerung (in Sekunden), mit der die Standby-Instanz aktualisiert werden soll

Antwort

OK

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY an die Datenbankinstanz DEMODB auf dem Virtual Server HOTEL_VIRTUAL, Anmelden an den Rechner PARMA als Betriebssystembenutzer ANNA mit Kennwort MAY und Hinzufügen der Datenbankinstanz auf dem Rechner PARMA als Standby-Instanz:

>dbmcli –u OLEG,MONDAY –d DEMODB –n HOTEL_VIRTUAL hss_addstandby PARMA login=ANNA,MAY

OK


hss_copyfile (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen hss_copyfile

Verwendung

Sie können Datenbankdateien innerhalb des Cluster-Systems von einer Instanz auf eine andere kopieren. Sie können damit beispielsweise die Konfigurationsdateien der Master-Instanz nach Änderungen an der Datenbankkonfiguration auf alle Standby-Instanzen eines Hot-Standby-Systems duplizieren. Verwenden Sie dazu grundsätzlich das DBM-Kommando hss_execute.

Für Supportzwecke ist es jedoch auch möglich, eine Datenbankdatei mit Hilfe des DBM-Kommandos hss_copyfile auf eine andere Instanz zu kopieren, unabhängig davon, ob die Quellinstanz oder die Zielinstanz aktuell als Master- oder Standby-Instanz fungieren.

Sie haben auch die Möglichkeit, eine Datenbankdatei explizit auf die aktuelle Master-Instanz zu kopieren, ohne dass Sie zuvor ermitteln müssen, welche aktuell die Master-Instanz ist.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Hot-Standby

Voraussetzungen

● Sie sind an das Cluster-System angemeldet.

● Sie haben die Serverberechtigung InstallMgm.

Syntax

hss_copyfile node=<source_component> name=<file_ID>

Optionen

Option | Beschreibung
<source_component> | Instanz, in der sich die zu kopierende Datei befindet
<file_ID> | Datei-ID der zu kopierenden Datei (siehe: Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien bzw. Strukturlink Protokolldateien)

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiele

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem Virtual Server HOTEL_VIRTUAL, Kopieren der Sicherungshistorie mit der Datei-ID BACKHIST von der Instanz PARMA über den Virtual Server, der sie an die Zielinstanz GENUA weiterleitet:

>dbmcli -u OLEG,MONDAY -d DEMODB -n HOTEL_VIRTUAL hss_execute GENUA hss_copyfile node=PARMA name=BACKHIST

OK


hss_enable (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen hss_enable

Verwendung

Sie definieren eine Datenbankinstanz als Master-Instanz eines Hot-Standby-Systems.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Hot-Standby-System einrichten

Konzepte des Datenbanksystems, Strukturlink Hot-Standby

Voraussetzungen

● Die Datenbankinstanz befindet sich auf dem Rechner, dem Sie mit Hilfe der Cluster-Software den Virtual Server Name zugewiesen haben.

● Die Datenbankinstanz befindet sich im Betriebszustand OFFLINE.

● Sie haben sich an die Datenbankinstanz auf dem Virtual Server angemeldet.

● Sie haben die Serverberechtigung ParamFull.

Syntax

hss_enable lib=<hs_storage_dll> node=<virtual_server_name>

Optionen

Option | Beschreibung
<hs_storage_dll> | Name der Bibliothek, die zum Ansteuern des Speicherverwaltungssystems benötigt wird
<virtual_server_name> | Name des Virtual Server

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem Virtual Server HOTEL_VIRTUAL, Definieren der Master-Instanz unter Angabe der Bibliothek libhsscopy zum Ansteuern des Speicherverwaltungssystems:

>dbmcli –u OLEG,MONDAY –d DEMODB –n HOTEL_VIRTUAL hss_enable lib=libhsscopy node=HOTEL_VIRTUAL

OK


hss_execute (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen hss_execute

Verwendung

Sie übermitteln ein DBM-Kommando direkt an eine Standby-Instanz.

Verwenden Sie dieses DBM-Kommando nicht für Änderungsoperationen, sondern ausschließlich, um Informationen über die Standby-Instanz zu gewinnen.

Ändernde DBM-Kommandos müssen an den Cluster und nicht an einzelne Standby-Instanzen übermittelt werden. Die Cluster-Software gibt die DBM-Kommandos an die Master-Instanz weiter. Die Master-Instanz führt die DBM-Kommandos aus und synchronisiert gegebenenfalls die Standby-Instanzen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Hot-Standby

Voraussetzungen

● Sie haben die notwendigen Serverberechtigungen.

● Sie sind an die Datenbankinstanz des Hot-Standby-Systems auf dem Virtual Server angemeldet.

Syntax

hss_execute <hs_node> <dbm_command>

Optionen

Option | Beschreibung
<hs_node> | Rechnername oder IP-Adresse der Standby-Instanz
<dbm_command> | DBM-Kommando

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem Virtual Server HOTEL_VIRTUAL, Anzeigen des Betriebszustandes der Standby-Instanz PARMA:

>dbmcli -u OLEG,MONDAY –d DEMODB –n HOTEL_VIRTUAL hss_execute PARMA db_state

OK

State

ONLINE


hss_getnodes (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen hss_getnodes

Verwendung

Sie lassen sich die Hot-Standby-Datenbankparameter des Hot-Standby-Systems anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Hot-Standby

Voraussetzungen

● Sie haben die Serverberechtigung ParamRead, ParamCheckWrite oder ParamFull.

● Sie sind an die Datenbankinstanz des Hot-Standby-Systems auf dem Virtual Server angemeldet.

Syntax

hss_getnodes

Antwort

OK

HS_STORAGE_DLL <file_name>

OFFICIAL_NODE <virtual_server_name>

HS_DELAY_TIME_<nnn> <delay_time>

HS_SYNC_INTERVAL <sync_interval>

HS_NODE_<nnn> <master_database_computer>_<nnn>

HS_NODE_<nnn> <standby_database_computer>_<nnn>

HS_NODE_<nnn> <standby_database_computer>_<nnn>

...

Werte für die Felder der Antwort

Feld | Beschreibung
<file_name> | Name der Bibliothek, über die auf das Speicherverwaltungssystem zugegriffen wird
<virtual_server_name> | Name des Virtual Server
<delay_time> | Zeitverzögerung (in s), mit der die Standby-Instanz nnn Datenänderungen der Master-Instanz nachvollzieht
<sync_interval> | minimale Zeitspanne (in s) zwischen zwei Befehlen der Master-Instanz zum Synchronisieren der Standby-Instanzen
<master_database_computer> | Rechner der Master-Instanz
<standby_database_computer> | Rechner der Standby-Instanz
<nnn> | laufende Nummer der Standby-Instanz (nnn > 1)

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem Virtual Server HOTEL_VIRTUAL, Anzeigen aller Hot-Standby-Parameter des Hot-Standby-Systems:

>dbmcli -u OLEG,MONDAY -d DEMODB –n HOTEL_VIRTUAL hss_getnodes

OK

HS_STORAGE_DLL libhsscopy

OFFICIAL_NODE HOTEL_VIRTUAL

HS_NODE_001 GENUA

HS_NODE_002 PARMA

Ergebnis

Das Speicherverwaltungssystem des Hot-Standby-Systems verwendet die Bibliothek libhsscopy. Der Virtual Server Name des Systems lautet HOTEL_VIRTUAL. Die aktuelle Master-Instanz befindet sich auf dem Rechner GENUA. Das Hot-Standby-System umfasst die Rechner GENUA und PARMA.


hss_removestandby (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen hss_removestandby

Verwendung

Sie löschen eine Standby-Instanz aus einem Hot-Standby-System.

Alle Dateien dieser Datenbankinstanz werden gelöscht.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Hot-Standby

Voraussetzungen

● Sie sind an die Datenbankinstanz des Hot-Standby-Systems auf dem Virtual Server angemeldet.

● Sie haben die Serverberechtigung ParamFull.

Syntax

hss_removestandby <hs_node>

<hs_node>

Rechnername oder IP-Adresse der Standby-Instanz

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB auf dem Virtual Server HOTEL_VIRTUAL, Löschen der Standby-Instanz auf dem Rechner PARMA:

>dbmcli -u OLEG,MONDAY -d DEMODB –n HOTEL_VIRTUAL hss_removestandby PARMA

OK


info (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen info

Verwendung

Sie lassen Information zu einer Datenbankinstanz anzeigen.

Mit Hilfe einer Info-ID geben Sie an, welche Information angezeigt werden soll. Nachfolgend sind die wichtigsten Info-IDs beschrieben. Eine Liste aller verfügbaren Info-IDs können Sie durch Angabe der Info-ID INFOS anzeigen.

Voraussetzungen

● Sie haben die Serverberechtigung DBInfoRead.

● Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect)

Syntax

info <info_ID>

Optionen

Option | Beschreibung
<info_ID> | ID der anzuzeigenden Information, die wichtigsten Info-IDs sind: CACHES: Zugriffe auf die Caches und Trefferquoten DATA: Pfad, Größe und Auslastung der Data-Volumes LOG: umfassende Informationen über den Log-Bereich STATE: Informationen über den aktuellen Zustand der Datenbankinstanz VERSIONS: Version der Datenbanksoftware INFOS: alle verfügbaren Info-IDs

Antwort

OK

END|CONTINUE

<description_record>

<info_record>

<info_record>

Werte für die Felder der Antwort

Feld | Beschreibung
END | Die Ergebnismenge wurde vollständig ausgegeben
Continue | Es liegen noch Ergebnisdaten bereit
<description_record> | Namen der Felder der nachfolgenden Informationszeilen
<info_record> | Information

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Version der Datenbanksoftware:

>dbmcli –u OLEG,MONDAY –d DEMODB info VERSIONS

OK

END

Name | Value

Kernel = Kernel 7.6.00 Build 016-123-109-428

Runtime Environment = W32/INTEL 7.6.00 Build 016-123-109-428


info_next (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen info_next

Verwendung

Nach Ausführen des DBM-Kommandos zum Anzeigen von Zustandsinformationen der Datenbankinstanz wurde in der Antwort durch das Schlüsselwort CONTINUE angezeigt, dass noch weitere Ergebnisdaten vorhanden sind. Sie lassen sich innerhalb derselben Datenbanksitzung die weiteren Ergebnisdaten anzeigen.

Voraussetzungen

· Sie haben die Serverberechtigung DBInfoRead.

· Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

· Sie haben das DBM-Kommando zum Anzeigen von Zustandsinformationen der Datenbankinstanz ausgeführt (Siehe: info).

Syntax

info_next

Antwort

OK

END|CONTINUE

<description_record>

<info_record>

<info_record>

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Ergebnismenge wurde vollständig ausgegeben.
Continue | Es liegen noch Ergebnisdaten bereit.
<description_record> | Namen der Felder der nachfolgenden Informationszeilen
<info_record> | Information


inst_enum (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen inst_enum

Verwendung

Sie lassen sich die Liste aller auf dem Datenbankrechner registrierten Versionen der Datenbanksoftware anzeigen.

Siehe auch:

Glossar, Strukturlink Version

Installationshandbuch, Strukturlink Verzeichnisse

Voraussetzungen

Für die Ausführung dieses DBM-Kommandos ist keine Anmeldung an den Database Manager erforderlich.

Es ist auch keine Serverberechtigung erforderlich.

Syntax

inst_enum

Antwort

OK

<version><TAB><dependent_path>

<version><TAB><dependent_path>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<version> | registrierte Version der Datenbanksoftware
<dependent_path> | Installationspfad der von der Datenbankversion abhängigen Server-Software

Beispiel

Aufrufen des Database Manager CLI, Anzeigen der Liste aller registrierten Versionen der Datenbanksoftware:

>dbmcli inst_enum

OK

7.4.0.3 "C:\Program Files\SAPDB\depend"

7.5.0.3                    "C:\Program Files\SDB\7500"

7.6.00.09 "C:\Program Files\sdb\DEMODB"


inst_info (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen inst_info

Verwendung

Dieses DBM-Kommando wird ausschließlich von SAP-Anwendungen verwendet.

Es ist gegenwärtig nicht dokumentiert.


inst_reg (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen inst_reg

Verwendung

Mit diesem DBM-Kommando trägt das System bei der Installation der Datenbanksoftware die Version der Software einmalig in die Registry ein. Dies ist die Voraussetzung für das korrekte Funktionieren der Software.

Im Normalfall wird dieses DBM-Kommando vom System ausgeführt. Verwenden Sie es nur nach Aufforderung durch den Support.

Voraussetzungen

· Sie sind an das Betriebssystem angemeldet (Siehe: user_system).

· Sie haben den Database Manager jener Softwareversion aufgerufen, die sie erneut registrieren wollen (Siehe: Option –R).

Für die Ausführung dieses DBM-Kommandos ist keine Anmeldung an den Database Manager erforderlich.

Es ist auch keine Serverberechtigung erforderlich.

Syntax

inst_reg [-c]

-c

registrieren des Client, wenn auf einem Rechner nur die Client-Programme der Datenbanksoftware installiert wurden

Antwort

OK

Im Fehlerfall siehe Antwortformat.


inst_unreg (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen inst_unreg

Verwendung

Sie löschen den Versionseintrag und die Pfadangabe für die von der Datenbankversion abhängige Server-Software aus der Liste der registrierten Versionen der Datenbanksoftware.

Die Datenbanksoftware ist danach nicht mehr uneingeschränkt lauffähig.

Voraussetzung

● Sie haben den Database Manager CLI mit der Option -R aufgerufen.

● Sie sind an das Betriebssystem angemeldet (Siehe: user_system).

Sie benötigen keine Serverberechtigung.

Syntax

inst_unreg <dependent_path>

<dependent_path>

Installationspfad der von der Datenbankversion abhängigen Server-Software

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB,

Löschen der Registrierung der Softwareversion 7.5 (hier: Vorschlagswert des Installationsprogramms)

>dbmcli –u OLEG,MONDAY –d DEMODB instunreg C:\Program Files\sdb\7500


load_lcapps (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen load_lcapps

Verwendung

Sie laden die Bibliotheken der Anwendung in eine liveCache-Datenbank.

Im Normalfall wird dieses DBM-Kommando regelmäßig von der SAP-Anwendung ausgeführt. Benutzen Sie es deshalb nur nach Aufforderung durch den Support.

Siehe auch:

Glossar, Strukturlink liveCache (SAP liveCache-Technologie)

Voraussetzungen

Sie haben die Serverberechtigung ExecLoad oder LoadSysTab.

Syntax

load_lcapps

Anwort

OK

<return_code>,<description>

<loader_code>,<command>

<loader_output_lines>

<loader_log_lines>

Werte für die Felder der Antwort

Feld | Beschreibung
<return_code> | Rückgabewert des Database Manager Wenn der Wert 0 ist, wurde das DBM-Kommando erfolgreich ausgeführt. Für jeden anderen Wert siehe Strukturlink Meldungen.
<description> | Kurztext der Meldung
<loader_code> | Rückgabewert des Loader
<dbm_command> | ausgeführte Kommandozeile
<loader_output_lines> | Ausgabetext des Loader
<loader_log_lines> | Zusammenfassung des Inhalts des Loader-Protokolls


load_r3tab (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen load_r3tab

Verwendung

Die SAP-spezifischen Tabellen sind systeminterne Tabellen, die nicht vom Benutzer gepflegt werden. Sie enthalten Informationen für die SAP-Anwendung über den Zustand der Datenbankinstanz.

Im Normalfall wird dieses DBM-Kommando regelmäßig von der SAP-Anwendung ausgeführt. Benutzen Sie es deshalb nur nach Aufforderung durch den Support.

Voraussetzungen

Sie haben die Serverberechtigung ExecLoad oder LoadSysTab.

Syntax

load_r3tab

Antwort

OK

<return_code>,<description>

<loader_code>,<command>

<loader_output_lines>

<loader_log_lines>

Werte für die Felder der Antwort

Wert | Beschreibung
<return_code> | Rückgabewert des Database Manager, wenn der Wert 0 ist, wurde das DBM-Kommando erfolgreich ausgeführt, für jeden anderen Wert siehe: Dokumentation Strukturlink Meldungen
<description> | Kurztext der Meldung
<loader_code> | Rückgabewert des Loader
<command> | ausgeführte Kommandozeile
<loader_output_lines> | Meldungstext des Loader
<loader_log_lines> | Zusammenfassung des Inhalts des Loader-Protokolls


load_systab (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen load_systab

Verwendung

Die Systemtabellen sind systeminterne Tabellen, die nicht vom Benutzer gepflegt werden.

Zum Laden der Systemtabellen müssen dem Database Manager der Name und das Kennwort des Datenbanksystemadministrator bekannt sein. Wenn dies noch nicht der Fall ist, machen Sie diese Angaben zusammen mit dem DBM-Kommandos zum Laden der Systemtabellen.

Die Systemtabellen müssen neu geladen werden, nachdem Sie eine neue Version der Datenbanksoftware installiert und die Datenbankinstanz in diese Version überführt haben (Upgrade).

Beim normalen Wiederherstellen einer Datenbankinstanz ist es nicht erforderlich, die Systemtabellen erneut zu laden. Wenn Sie jedoch eine Datenbankkopie angefertigt, also die Datensicherung einer Datenbankinstanz A in einer Datenbankinstanz B wiederhergestellt haben, dann müssen zum Abschluss auch die Systemtabellen geladen werden. Sie benötigen dazu die Daten des in der eingelesenen Datensicherung gespeicherten Datenbanksystemadministrators.

Siehe auch:

Glossar, Strukturlink Systemtabelle

Voraussetzungen

● Sie haben die Serverberechtigung ExecLoad oder LoadSysTab.

● Die Datenbankinstanz befindet sich im Betriebszustand ONLINE:

Syntax

load_systab [-u <sysdba_user>,<sysdba_user_password>]

Option | Beschreibung
<sysdba_user> | Name des Datenbanksystemadministrators jener Datenbankinstanz, von der die eingelesene Datensicherung stammt
<sysdba_user_password> | Kennwort des Datenbanksystemadministrators

Antwort

OK

0,<err_description>

<loader_code>,<dbm_command>

<loader_output_lines>

<loader_log_lines>

Werte für die Felder der Antwort

Feld | Beschreibung
<err_description> | Meldungstext
<loader_code> | Rückgabewert des Loader
<dbm_command> | ausgeführtes DBM-Kommando
<loader_output_lines> | Meldungstext des Loader
<loader_log_lines> | Zusammenfassung des Inhalts des Loader-Protokolls

Beispiel

...

Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –d DEMODB –u OLEG,MONDAY

dbmcli on DEMODB>

Laden der Systemtabellen, für dieses DBM-Kommando Autorisierung als Datenbanksystemadministrator DBADMIN mit dem Kennwort SECRET:

dbmcli on DEMODB>load_systab –u DBADMIN,SECRET

OK

0,OK: everything works fine

0,""c:\program files\sdb\demodb\bin\x_python" "c:\program files\sdb\demodb\env

\lsystab.py" -R "c:\program files\sdb\demodb" -d DEMODB -u OLEG,*"

Removing obsolete objects

Installing Loader tables

Installing messages and help

Installing SYSDBA tables

Installing comments for SYSDBA tables

Installing precompiler tables

Installing system tables for R3 backup information

Installing ODBC tables

...

...


load_tutorial (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen load_tutorial

Verwendung

Sie laden die für die Beispiele in der MaxDB-Dokumentation verwendeten Demo-Daten.

Sie können diese Demo-Daten in jede vorhandene Datenbankinstanz und zu jedem beliebigen Zeitpunkt laden. Sie verfügen damit über alle notwendigen Daten, um die in den verschiedenen Dokumentationen aufgeführten Beispiele nachvollziehen zu können.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Demo-Daten in eine Datenbankinstanz laden

Konzepte des Datenbanksystems, Strukturlink Demo-Datenbank, Strukturlink Objekte im Schema HOTEL

Voraussetzungen

Sie haben die Serverberechtigung ExecLoad oder LoadSysTab.

Syntax

load_tutorial

Anwort

OK

<return_code>,<description>

<loader_code>,<command>

<loader_output_lines>

<loader_log_lines>

Werte für die Felder der Antwort

Wert | Beschreibung
<return_code> | Rückgabewert des Database Manager Wenn der Wert 0 ist, wurde das DBM-Kommando erfolgreich ausgeführt. Für jeden anderen Wert siehe Strukturlink Meldungen.
<description> | Kurztext der Meldung
<loader_code> | Rückgabewert des Loader
<command> | ausgeführte Kommandozeile
<loader_output_lines> | Meldungstext des Loader
<loader_log_lines> | Zusammenfassung des Inhalts des Loader-Protokolls


medium_date (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_date

Verwendung

Sie lassen sich das Datum und die Uhrzeit anzeigen, an dem die aktuelle Definitionsdatei für Sicherungsvorlagen letztmalig geändert wurde.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien, Strukturlink Sicherungsvorlagen und Datenträger

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead.

Syntax

medium_date

Antwort

OK

<yyyymmdd><HHMMSS>

<yyyymmdd><HHMMSS>

letztes Änderungsdatum der Definitionsdatei für die Sicherungsvorlagen

Zeitformat: Jahr Monat Tag Stunden Minuten Sekunden

Im Fehlerfall siehe Antwortformat.

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen des letzten Änderungsdatums der Definitionsdatei für Sicherungsvorlagen:

>dbmcli -u OLEG,MONDAY -d DEMODB medium_date

OK

20041210160344


medium_delete (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_delete

Verwendung

Sie löschen die angegebene Sicherungsvorlage.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sicherungsvorlagen und Datenträger

Voraussetzungen

Sie haben die Serverberechtigung Backup.

Syntax

medium_delete <medium_name>

<medium_name>

Name der Sicherungsvorlage

Antwort

OK

Im Fehlerfall siehe Antwortformat.


medium_delete_nodistribute (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_delete_nodistribute

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando im Zusammenhang mit Hot-Standby-Konfigurationen.

Es ist gegenwärtig nicht dokumentiert.


medium_get (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_get

Verwendung

Sie lassen sich die Eigenschaften der angegebenen Sicherungsvorlage anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sicherungsvorlagen und Datenträger

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead.

Syntax

medium_get <medium_name>

Antwort

OK

<medium_name> <location> <type> <backup_type> <size> <block_size> <overwrite> <autoldr> <oscmd> <date_created> <date_modified> <tool_type>

Werte für die Felder der Antwort

Wert

Beschreibung

<medium_name>

Name der Sicherungsvorlage, kann aus einem Gruppennamen und einem Member-Namen bestehen. Diese sind dann durch einen Schrägstrich voneinander getrennt.

<location>

Name des Gerätes/der Datei, mit dem es über Betriebssystemfunktionen angesprochen werden kann

<type>

Typ der Sicherungsvorlage, mögliche Werte sind:

TAPE | FILE | NO-REWIND | PIPE | AUTOLOADER | UNKNOWN

<backup_type>

Sicherungsart, für die die Sicherungsvorlage benutzt werden soll. Mögliche Werte sind:

DATA | PAGES | LOG

<size>

Anzahl der Seiten, die maximal auf den Datenträger geschrieben werden können

<block_size>

Anzahl der Seiten, die bei einem Zugriff auf den Datenträger übertragen werden

<overwrite>

Überschreiben des Datenträgers erlaubt (wird nur beim Vorlagentyp FILE ausgewertet), mögliche Werte sind:

NO | YES

<autoldr>

Angabe, ob das Gerät den Datenträger automatisch wechselt. Mögliche Werte sind:
YES | NO

<oscmd>

Betriebssystemkommando, das vor dem Sichern auf einen Folgedatenträger (backup_replace) oder dem Wiederherstellen von einem Folgedatenträger (recover_replace) ausgeführt werden soll.

<date_created>

Datum, an dem die Sicherungsvorlage angelegt wurde

<date_modified>

Datum, an dem die Sicherungsvorlage geändert wurde

<tool_type>

Typ des Sicherungswerkzeugs, mögliche Werte sind:

NONE | BACK | NSR | TSM

NONE: Es wird kein automatisches Sicherungswerkzeug verwendet
BACK: Backint for Oracle
NSR: NetWorker
TSM: TSM von IBM/Tivoli

Im Fehlerfall siehe Antwortformat.


medium_getall (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_getall

Verwendung

Sie lassen sich die Liste aller definierten Sicherungsvorlagen anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sicherungsvorlagen und Datenträger

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead.

Syntax

medium_getall

Antwort

OK

<medium_name> <location> <type> <backup_type> <size> <block_size> <overwrite> <autoldr> <oscmd> <date_created> <date_modified> <tool_type>

<medium_name> <location> <type> <backup_type> <size> <block_size> <overwrite> <autoldr> <oscmd> <date_created> <date_modified> <tool_type>

...

Werte für die Felder der Antwort

Wert

Beschreibung

<medium_name>

Name der Sicherungsvorlage,
kann aus einem Gruppennamen und einem Member-Namen bestehen, die durch einen Schrägstrich voneinander getrennt sind.

<location>

Name des Gerätes/der Datei, mit dem es über Betriebssystemfunktionen angesprochen werden kann

<type>

Typ der Sicherungsvorlage, mögliche Werte sind:

TAPE | FILE | NO-REWIND | PIPE | AUTOLOADER | UNKNOWN

<backup_type>

Sicherungsart, für die die Sicherungsvorlage benutzt werden soll. Mögliche Werte sind:

DATA | PAGES | LOG

<size>

Anzahl der Seiten, die maximal auf den Datenträger geschrieben werden können

<block_size>

Anzahl der Seiten, die bei einem Zugriff auf den Datenträger übertragen werden

<overwrite>

Überschreiben des Datenträgers erlaubt (wird nur beim Vorlagentyp FILE ausgewertet), mögliche Werte sind:

NO | YES

<autoldr>

Angabe, ob das Gerät den Datenträger automatisch wechselt, mögliche Werte sind:

YES | NO

<oscmd>

Betriebssystemkommando, das vor dem backup_replace oder dem recover_replace ausgeführt werden soll

<date_created>

Datum und Zeit, an dem die Sicherungsvorlage angelegt wurde

<date_modified>

Datum und Zeit, an dem die Sicherungsvorlage letztmalig geändert wurde

<tool_type>

Typ des Sicherungswerkzeugs, mögliche Werte sind:

NONE | BACK | NSR | TSM

NONE: Es wird kein automatisches Sicherungswerkzeug verwendet
BACK: Backint for Oracle
NSR: NetWorker
TSM: TSM von IBM/Tivoli

Im Fehlerfall siehe Antwortformat


medium_label (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_label

Verwendung

Sie lassen sich die auf einem Datenträger gespeicherten Informationen über die Sicherung anzeigen.

Siehe auch:

Glossar, Strukturlink Sicherungskennung

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect)

● Die Datenbankinstanz befindet sich im Betriebszustand ONLINE oder ADMIN.

Syntax

medium_label <medium_name>

<medium_name>

Name der Sicherungsvorlage, von der die Informationen gelesen werden sollen
Bei Sicherungsvorlagen für eine Gruppe paralleler Datenträger ist der Name der Gruppe anzugeben.

Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volumes [<value>]

Medianame [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Hinweis Werten Sie insbesondere das Antwortfeld Returncode aus, das einen vom Kern gelieferten numerischen Wert enthält.

Siehe auch: Strukturlink Meldungen

Werte für die Felder der Antwort

Feld | Beschreibung
Returncode | Rückgabewert des Database Manager Wenn der Wert 0 ist, dann wurde das DBM-Kommando erfolgreich ausgeführt. Für jeden anderen Wert siehe Strukturlink Meldungen.
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version des Datenbankkerns
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Sicherungsvorlagen
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße beim Einlesen der Sicherung)

Im Fehlerfall siehe Antwortformat.


medium_labeloffline (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_labeloffline

Verwendung

Sie lassen sich die Informationen anzeigen, die Sie zur Identifizierung einer Sicherung benötigen, wenn Sie sie z. B. beim Wiederherstellen der Datenbankinstanz verwenden wollen.

Sie können entweder über den Namen der Sicherungsvorlage oder über die Angabe des Datenträgers spezifizieren, von welcher Sicherung die Informationen angezeigt werden sollen.

Wenn Sie mit diesem Kommando den Namen der Sicherungsvorlage angeben wollen, dann müssen Sie eine Verbindung zur entsprechenden Datenbankinstanz haben (angemeldet mit –d ). Dabei ist der Betriebszustand der Datenbankinstanz irrelevant.

Wenn Sie den Datenträger angeben, können Sie sich das Label jeder Sicherung anzeigen lassen, unabhängig vom Vorhandensein einer Datenbankinstanz.

Siehe auch:

Glossar, Strukturlink Sicherungskennung

Voraussetzungen

Sie haben die Serverberechtigung Backup .

Syntax

medium_labeloffline <name> | <location_spec>

<name> :: = <medium_name> [<nnn>]

<location_spec> :: = <device | file> <media_spec>

<media_spec> :: = <type_spec> [<blocksize_spec>] | <blocksize_spec>

<type_spec> :: = [DEVICETYPE] <device_type>

<device_type> : = FILE | TAPE | PIPE

<blocksize_spec> :: = BLOCKSIZE <block_size>

Optionen

Option | Beschreibung
<medium_name> | Name der Sicherungsvorlage
<nnn> | nur für Log-Sicherung und nur für Sicherungsvorlagen vom Typ Datei: Versionsnummer der Log-Sicherung auf dem Datenträger
<device | file> | Datenträger
<block_size> | Anzahl der Seiten, die bei einem Zugriff auf den Datenträger übertragen werden Geben Sie hier die Blockungsgröße an, die beim Erstellen der Sicherung verwendet wurde. Wenn Sie keine Angabe machen, wird der Systemvorschlag (8) verwendet.
<device_type> | Typ des Datenträgers, mögliche Werte sind: FILE | TAPE | PIPE FILE: Datei TAPE: Band PIPE: Pipe Vorschlagswert des Systems ist FILE.

Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Medianame [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Werte für die Felder der Antwort

Feld | Beschreibung
Returncode | Rückgabewert des Database Manager Wenn der Wert 0 ist, dann wurde das DBM-Kommando erfolgreich ausgeführt. Für jeden anderen Wert siehe Strukturlink Meldungen.
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version der Datenbanksoftware
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Sicherungsvorlagen
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße beim Einlesen der Sicherung)

Im Fehlerfall siehe Antwortformat.


medium_migrate (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_migrate

Verwendung

Sie können vorhandene Definitionen für Sicherungsvorlagen (früher "Sicherungsmedien") aus der Mediendefinitionsdatei control.med (Datenbankversion 6.2) in die neue Vorlagendefinitionsdatei dbm.mmm (ab Datenbankversion 7.2.4.2) übernehmen.

Bei identischen Namen in der alten und neuen Definitionsdatei wird die Definition der alten Datei nicht übernommen.

Die alten Definitionen für Sicherungsvorlagen enthalten keine Angaben darüber, für welche Sicherungsart die Vorlage bestimmt ist. Aus diesem Grunde empfehlen wir Ihnen, für eine solche Vorlage unmittelbar nach der Übernahme mit Hilfe des DBM-Kommandos medium_put die Sicherungsart zu definieren. Andernfalls müssen Sie später die Sicherungsart explizit angeben, wenn Sie eine Sicherung unter Verwendung dieser Vorlage starten wollen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien

Voraussetzungen

Sie haben die Serverberechtigung Backup oder DBInfoRead.

Syntax

medium_migrate

Antwort

OK

Im Fehlerfall siehe Antwortformat.


medium_put (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_put

Verwendung

Sie legen eine neue Sicherungsvorlage an oder ändern die Daten einer bereits vorhandenen Sicherungsvorlage.

Die so definierten Eigenschaften der Sicherungsvorlage werden in der Konfigurationsdatei dbm.mmm des Database Manager abgelegt.

Das mit der Eigenschaft location/device definierte Verzeichnis, in dem die Sicherungsvorlage angelegt werden soll, muss bereits vorhanden sein. Die Sicherungsvorlage wird physisch erst dann angelegt, wenn sie erstmals für eine Sicherung verwendet wird.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Sicherungsvorlagen definieren

Konzepte des Datenbanksystems, Strukturlink Sicherungsvorlagen und Datenträger, Strukturlink Konfigurationsdateien

Voraussetzungen

Sie haben die Serverberechtigung Backup.

Syntax

medium_put <medium_name> <location> <type> <backup_type> [<size> [<block_size> [<overwrite> [<autoloader> [<os_command> [<tool_type>]]]]]]

Optionen

Option

Beschreibung

<medium_name>

Name der Sicherungsvorlage, kann aus einem Gruppennamen und einem Member-Namen bestehen

Diese sind dann durch einen inversen Schrägstrich (\) voneinander zu trennen:

<medium_name> ::= [<group_name>\]<member_name>

Um eine Sicherungsvorlage für eine Gruppe paralleler Datenträger anzulegen, führen Sie das DBM-Kommando mehrfach nacheinander aus. Geben Sie dabei für <group_name> immer den gleichen Namen und für <member_name> jeweils einen anderen Namen an, um die Sicherungsvorlagen derselben Gruppe zuzuordnen.

<location>

Name des Gerätes/der Datei, mit dem es über Betriebssystemfunktionen angesprochen werden kann

Die Zuordnung von Versionsnummern für die Sicherungsdateien bei Log-Sicherungen wird vom System vorgenommen.

Beachten Sie die Vorgaben für verschiedene Typen von Sicherungsvorlagen (<type>) unter verschiedenen Betriebssystemen:

Für eine Sicherungsvorlage vom Typ PIPE gilt

auf UNIX:

Die Pfadangabe ist frei wählbar. Wenn Sie einen relativen Pfad angeben, wird die Sicherungsvorlage im Arbeitsverzeichnis der Datenbankinstanz abgelegt ([<path>/]<file_name>).

auf Microsoft Windows:

Die Pfadangabe muss folgender Konvention entsprechen: \\.\pipe\<pipe_name>.

Für eine Sicherungsvorlage vom Typ FILE gilt

auf UNIX:

Sie können einen absoluten oder einen relativen Pfad angeben. Eine absolute Pfadangabe muss mit einem Schrägstrich (/) eingeleitet werden. Wenn Sie einen relativen Pfad angeben, dann wird dieser relativ zum Arbeitsverzeichnis der Datenbankinstanz interpretiert.

auf Microsoft Windows:

Ein absoluter Pfad ist wie folgt anzugeben:

\\<computer_name>\<share>\[<path>\]<file_name>

oder mit Laufwerksnotation:

<drive>:\[<path>]\<file_name>

Wenn Sie einen relativen Pfad angeben, dann wird dieser relativ zum Arbeitsverzeichnis der Datenbankinstanz interpretiert.

Für eine Sicherungsvorlage vom Typ TAPE gilt

auf UNIX:

Sie müssen einen absoluten Pfad angeben.

auf Microsoft Windows:

Die Pfadangabe muss folgender Konvention entsprechen: \\.\tape<running_number>.

Für das Sicherungswerkzeug NSR gilt:

Geben Sie einen absoluten Pfadnamen an. Dieser muss für den Sicherungs- und Wiederherstellungsvorgang gleich sein. Beachten Sie, dass Teile des Pfadnamens, die nur Links repräsentieren, von Networker durch die tatsächlichen Verzeichnis- oder Dateinamen ersetzt werden.

<type>

Typ der Sicherungsvorlage

Mögliche Werte für Datensicherungen sind:

TAPE | FILE | PIPE | UNKNOWN

Mögliche Werte für Log-Sicherungen sind:

FILE | PIPE | UNKNOWN

Geben Sie TAPE für das Sichern auf ein nicht rückspulbares Band, FILE für das Sichern in eine Datei und PIPE für das Sichern in eine Pipe an. Wenn Sie einen dieser Vorlagentypen angeben, wird die Richtigkeit der Angabe vom System geprüft.

Wenn Sie diese Prüfung umgehen wollen, geben Sie den Typ UNKNOWN an. Beachten Sie jedoch, dass Log-Sicherungen nur in Dateien und Pipes möglich sind. Andernfalls erhalten Sie beim Sichern eine Fehlermeldung.

Vorschlagswert des Systems ist UNKNOWN.

<backup_type>

Sicherungsart, für die die Sicherungsvorlage benutzt werden soll,

mögliche Werte sind:

DATA | PAGES | LOG | AUTO

Geben Sie DATA für eine vollständige Datensicherung, PAGES für eine inkrementelle Datensicherung, LOG für eine interaktive Log-Sicherung und AUTO für die automatische Log-Sicherung an.

Beachten Sie:

Es kann nur eine Sicherungsvorlage des Sicherungstyps AUTO geben. Wenn bereits eine Sicherungsvorlage für diesen Sicherungstyp vorhanden ist und Sie ein weiteres vom Typ AUTO definieren, dann ändert das System den Sicherungstyp des bereits vorhandenen auf den Sicherungstyp LOG.

<size>

Anzahl der Seiten, die maximal auf den Datenträger geschrieben werden können.

Vorschlagswert des Systems ist 0, d. h. die Größe des Datenträgers ist nicht begrenzt. Das System schreibt auf diesen Datenträger bis entweder die Sicherung beendet ist oder das Betriebssystem kein weiteres Schreiben auf diesen Datenträger zulässt, weil er voll ist. In diesem Fall erhalten Sie eine Fehlermeldung und können anschließend die Sicherung mit einem weiteren Datenträger fortsetzen.

<block_size>

Anzahl der Seiten, die bei einem Zugriff auf den Datenträger übertragen werden. Diese Angabe wird nur für Datenträger des Typs TAPE ausgewertet.
Vorschlagswert des Systems ist 8.

<overwrite>

Angabe ist nur für den Vorlagentyp FILE (Datei) und nur für Datensicherungen obligatorisch. Sie definiert das Verhalten für den Fall, dass die Datei bereits vorhanden ist.
Mögliche Werte sind:

YES | NO

Wenn Sie YES angeben und die Datei bereits existiert, wird sie mit der neuen Sicherung überschrieben. Wenn Sie NO angeben und die Datei bereits existiert, schlägt die Sicherung fehl.
Vorschlagswert des Systems ist NO.

Für Log-Sicherungen wird diese Angabe nicht ausgewertet.

<autoloader>

Angabe, ob das Gerät den Datenträger automatisch wechselt,

ist nur unter Microsoft Windows relevant

Mögliche Werte sind:

YES | NO

Vorschlagswert des Systems ist NO.

<os_command>

Betriebssystemkommando, das vor dem Sichern auf einen Folgedatenträger (backup_replace) oder dem Wiederherstellen von einem Folgedatenträger (recover_replace) ausgeführt werden soll.

<tool_type>

zu verwendendes Sicherungswerkzeug,

mögliche Werte sind:

NONE: Es wird kein Sicherungswerkzeug verwendet.
BACK: Backint for MaxDB/ Backint for Oracle
NSR: NetWorker
TSM: TSM von IBM/Tivoli

Wenn Sie den Wert NONE und als <type> PIPE angeben, muss unter UNIX die Pipe vor dem Beginn der Sicherung bereits angelegt sein, auf Microsoft Windows darf sie noch nicht existieren.

Wenn Sie einen anderen Wert als NONE angeben, müssen Sie für <type> PIPE und für <size> 0 angeben. Die Pipe darf weder unter UNIX noch unter Microsoft Windows vor dem Beginn der Sicherung existieren.

Für den Wert NSR beachten Sie außerdem die speziellen Angaben unter <location>.

Vorschlagswert des Systems ist NONE.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


medium_put_nodistribute (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen medium_put_nodistribute

Verwendung

Dieses DBM-Kommando ist ein internes Systemkommando im Zusammenhang mit Hot-Standby-Konfigurationen.

Es ist gegenwärtig nicht dokumentiert.


package_info (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen package_info

Verwendung

Dieses DBM-Kommando wird ausschließlich von SAP-Anwendungen verwendet.

Es ist gegenwärtig nicht dokumentiert.


param_abortsession (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_abortsession

Verwendung

Sie brechen die Parametersitzung ab.

Alle in dieser Sitzung durchgeführten Änderungen von Datenbankparametern werden verworfen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Werte mehrerer Datenbankparameter ändern

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

● Sie haben eine Parametersitzung eröffnet (Siehe: param_startsession).

● Sie haben die Serverberechtigung ParamRead.

Syntax

param_abortsession

Antwort

OK

Im Fehlerfall siehe Antwortformat


param_addvolume (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_addvolume

Verwendung

Verwenden Sie das hier beschriebene DBM-Kommando param_addvolume nur beim Anlegen einer Datenbankinstanz, beim Anlegen eines ersten Spiegel-Volume für eine Datenbankinstanz oder nach Aufforderung durch den Support.

Erweitern Sie hingegen eine bestehende Datenbankinstanz mit dem DBM-Kommando für das Hinzufügen von Volumes (Siehe: db_addvolume). Für das Anlegen von Spiegel-Volumes verwenden Sie das DBM-Kommando nur dann, wenn die Datenbankinstanz bereits gespiegelt wird, also bereits Spiegel-Volumes vorhanden sind.

Inkonsistenzen in den Volume-Einstellungen können zur Beschädigung der Datenbankinstanz führen.

Mit diesem DBM-Kommando ändern Sie Volume-Parameter in der Parameterdatei der Datenbankinstanz. Der neue Wert des Parameters wird vom System registriert und beim nächsten Restart der Datenbankinstanz als gültiger Wert übernommen.

Das Ändern von Volume-Parametern erfolgt in zwei Schritten:

...

1. Änderung der Einträge zu den Parametern in der Parameterdatei

2. Übermittlung der entsprechenden Informationen an den Datenbankkern mit einem administrativen Kommando (Siehe: db_execute)

Wenn dieses Kommando fehlschlägt, müssen Sie auch die Einträge in der Parameterdatei der Datenbankinstanz wieder entfernen.

Es wird nicht geprüft, ob für das Hinzufügen des Volume noch eine ausreichende Plattenkapazität vorhanden ist.

Wenn Sie mit diesem DBM-Kommando ein Spiegel-Volume anlegen, dann müssen Sie anschließend noch den allgemeinen Datenbankparameter LOG_MIRRORED auf den Wert YES ändern (Siehe: param_put).

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Konzepte des Datenbanksystems, Strukturlink Volumes (permanenter Speicher)

Voraussetzungen

Sie haben die Serverberechtigung ParamFull.

Syntax

param_addvolume <vol_no> <vol_mode> <vol_name> <vol_type> <size>

Optionen

Option

Beschreibung

<vol_no>

Nummer des Volume

<vol_mode>

Art des Volume, mögliche Werte sind:

DATA: Data-Volume,
die Nummer des Data-Volume wird beim Anlegen des Volume als vierstellige Zahl mit vorangestellten Nullen vom System vergeben

LOG: Log-Volume,
die Nummer des Log-Volume wird beim Anlegen des Volume als dreistellige Zahl mit vorangestellten Nullen vom System vergeben

MLOG: Gespiegeltes Log-Volume

<vol_name>

Name des Gerätes / der Datei

Beachten Sie, dass unter Microsoft Windows Volumes in Form von Dateien nicht komprimiert werden oder in einem komprimierten Verzeichnis des Betriebssystems abgelegt werden dürfen.

<vol_type>

Typ des Gerätes/der Datei, das/die hinzugefügt werden soll,

mögliche Werte sind:

F: Datei

L: Link

R: Raw Device

<size>

Größe des Volume in Seiten

Antwort

OK

Im Fehlerfall siehe Antwortformat.


param_checkall (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_checkall

Verwendung

Sie führen eine Prüfung der Datenbankparameter anhand der in der Vorschlagsparameterdatei hinterlegten Eigenschaften, Berechnungsvorschriften und Bedingungen durch. Der weitere Ablauf ist davon abhängig, ob Sie vor der Ausführung des DBM-Kommandos eine Parametersitzung eröffnet haben oder nicht.

Wenn Sie zuvor eine Parametersitzung eröffnet haben (Siehe: param_startsession) und während der Prüfung ein Fehler festgestellt wird, dann wird diese abgebrochen und es werden das Prüfergebnis und eine Fehlermeldung ausgegeben. Korrigieren Sie den beanstandeten Datenbankparameter (Siehe: param_put) und starten Sie die Prüfung anschließend noch einmal. Wiederholen Sie diese Vorgehensweise bis die Prüfung der Datenbankparameter keine Fehler mehr ergibt. Alle Änderungen der Datenbankparameter werden zunächst vom System zwischengespeichert. Sie werden erst dann in die Parameterdatei eingetragen, wenn Sie die gemachten Änderungen explizit bestätigen (Siehe: param_commitsession).

Wenn Sie die Prüfung durchführen ohne zuvor eine Parametersitzung eröffnet zu haben, und die Prüfung Fehler ergibt, dann passt das System die Werte der geänderten Parameter den gültigen Vorschriften an und trägt diese in die Parameterdatei ein. Alle Änderungen werden erst nach einem Restart der Datenbankinstanz wirksam.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Werte mehrerer Datenbankparameter ändern

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamCheckWrite.

Syntax

param_checkall

Erfolgreiche Antwort

OK

Antwort im Fehlerfall (mit Parametersitzung)

ERR

-24986,ERR_XPCHECK: param check failure/request

<parameter_name> <check_status>

<user_value>

<computed_value>

Werte für die Felder der Antwort

Feld | Beschreibung
<parameter_name> | Name des Datenbankparameters
<check_status> | Prüfergebnis, folgende Werte sind möglich: mandatory | constraint mandatory: Ein obligatorischer Datenbankparameter wurde mit einem leeren Wert belegt. constraint: Eine in der Vorschlagsparameterdatei definierte Bedingung konnte nicht erfüllt werden.
<user_value> | Wert, der vom Benutzer für den Datenbankparameter definiert wurde
<computed_value> | vom System errechneter Vorschlagswert


param_commitsession (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_commitsession

Verwendung

Sie verwenden dieses DBM-Kommando, um zuvor durchgeführte Änderungen der Datenbankparameter zu bestätigen und in die Datenbankparameterdatei einzutragen. Führen Sie dieses DBM-Kommando erst dann aus, wenn Sie das DBM-Kommando zum Prüfen aller Datenbankparameter erfolgreich ausgeführt haben.

Durch die Angabe einer Option können Sie definieren, ob die Parametersitzung nach dem Bestätigen der Änderungen erhalten bleiben oder geschlossen werden soll.

Die geänderten Werte in der Datenbank-Parameterdatei werden erst mit einem Restart der Datenbankinstanz wirksam.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Werte mehrerer Datenbankparameter ändern

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

● Sie haben während einer param_startsession Parameterwerte geändert.

● Die Prüfung der geänderten Parameter war erfolgreich (Siehe: param_checkall).

● Sie haben die Serverberechtigung ParamCheckWrite.

Syntax

param_commitsession [NOCLOSE]

NOCLOSE

Die Parametersitzung bleibt nach dem Speichern der Datenbankparameter erhalten.

Erfolgreiche Antwort

OK

Fehlermeldung

ERR
14,ERR_XPCHECK_CN00 : param check failure/request
<parameter_name> <check_status>
<user_value>
<computed_value>

Werte für die Felder der Antwort

Wert | Beschreibung
<parameter_name> | Name des Datenbankparameters
<check_status> | Prüfergebnis, folgende Werte sind möglich: mandatory | constraint mandatory: Ein obligatorischer Datenbankparameter wurde mit einem leeren Wert belegt. constraint: Eine in der Vorschlagsparameterdatei definierte Bedingung konnte nicht erfüllt werden.
<user_value> | Wert, der vom Benutzer für den Datenbankparameter definiert wurde
<computed_value> | vom System errechneter Vorschlagswert


param_copy (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_copy

Verwendung

Sie kopieren die Parameterdatei einer existierenden Datenbankinstanz und verwenden diese Kopie als Initialkonfiguration für eine Datenbankinstanz. Alle bis zu diesem Zeitpunkt durchgeführten Änderungen der Datenbankarameterdatei werden von der Kopie überschrieben.

Eine Ausnahme hiervon bilden die Parameter RUNDIRECTORY und KERNELVERSION sowie alle Volume-Parameter, die aufgrund ihrer Eigenschaften nicht kopiert werden können. Für diese Parameter bleiben die aus der Vorschlagsparameterdatei übernommenen Werte erhalten.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Parameterdatei aus einer anderen Datenbankinstanz kopieren

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

● Sie haben eine Parametersitzung eröffnet (Siehe: param_startsession).

● Sie haben die Serverberechtigung InstallMgm.

Syntax

param_copy <source_database>

<source_database>

Name der Datenbankinstanz, deren Parameterdatei kopiert werden soll

Antwort

OK

Im Fehlerfall siehe Antwortformat


param_delvolume (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_delvolume

Verwendung

Sie löschen die Parameter des angegebenen Volume aus der Datenbankparameterdatei. Dieses DBM-Kommando löscht nur die Parameter des Volume.

Verwenden Sie dieses DBM-Kommando mit großer Sorgfalt. Inkonsistenzen in den Volume-Einstellungen können zur Beschädigung der Datenbankinstanz führen.

Für das physische Löschen von Data-Volumes und die anschließende Wiederfreigabe der entsprechenden Ressourcen verwenden Sie das DBM-Kommando db_deletevolume.

Voraussetzungen

Sie haben die Serverberechtigung ParamCheckWrite.

Syntax

param_delvolume <vol_no> <vol_mode>

Optionen

Option | Beschreibung
<vol_no> | Nummer des Volume
<vol_mode> | Art des Volume, mögliche Werte sind: DATA | LOG | MLOG DATA: Data-Volume LOG: Log-Volume MLOG: gespiegeltes Log-Volume

Antwort

OK

Im Fehlerfall siehe Antwortformat


param_directdel (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_directdel

Verwendung

Der angegebene Parameter wird aus der Datenbankparameterdatei gelöscht.

Diese Änderung wird erst beim nächsten Restart der Datenbankinstanz wirksam.

Verwenden Sie dieses DBM-Kommando mit großer Sorgfalt, da es direkt auf die Parameterdatei der Datenbankinstanz zugreift. Zwar prüft das System, ob die gemachten Änderungen den Vorschriften entsprechen und überschreibt ungültige Werte beim nächsten Restart der Datenbankinstanz gegebenenfalls mit den Werten aus der Vorschlagsparameterdatei. Dies gilt jedoch nicht für die Parameter RUNDIRECTORY und KERNELVERSION sowie alle Volume-Parameter. Wenn Sie diese Parameter löschen, kann dies zu schweren Inkonsistenzen im Datenbankbetrieb führen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamFull.

Syntax

param_directdel <parameter_name> [<comment>]

Optionen

Option | Beschreibung
<parameter_name> | Name des Datenbankparameters
<comment> | zum Datenbankparameter gespeicherter Kommentar Wenn die Kommentarzeile Leerzeichen enthält, müssen Sie die Zeile in doppelte Anführungszeichen setzen.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


param_directget (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_directget

Verwendung

Sie lassen sich Wert des angegebenen Datenbankparameters anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_directget <parameter_name>

Antwort

OK

<parameter_name> <value>

Werte für die Felder der Antwort

Wert | Beschreibung
<parameter_name> | Name des Datenbankparameters
<value> | Wert des Datenbankparameters

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen des Wertes des Parameters RUNDIRECTORY (Arbeitsverzeichnis der Datenbankinstanz):

>dbmcli – u OLEG,MONDAY –d DEMODB param_directget RUNDIRECTORY

OK

RUNDIRECTORY c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB


param_directgetall (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_directgetall

Verwendung

Sie lassen sich alle Datenbankparameter der aktuellen Datenbankinstanz mit ihren Werten anzeigen.

Wenn aufgrund der begrenzten Größe des Antwortpakets noch nicht alle Parameter angezeigt werden können, verwenden Sie anschließend param_directgetallnext, um sich den weiteren Inhalt der Parameterdatei anzeigen zu lassen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_directgetall

Antwort

OK

<parameter_name> <value>

<parameter_name> <value>

...

Im Fehlerfall siehe Antwortformat.


param_directgetallnext (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_directgetallnext

Verwendung

Sie lassen sich den weiteren Inhalt der aktuellen Datenbank-Parameterdatei anzeigen. Pro Zeile wird je ein Parameter mit Namen und Wert angezeigt.

Voraussetzungen

● Sie haben das DBM-Kommando zum Anzeigen aller Parameter der aktuellen Datenbank-Parameterdatei ausgeführt (Siehe: param_directgetall). Wegen der begrenzten Größe des Antwortpakets sind noch nicht alle Werte angezeigt worden.

● Sie haben die Serverberechtigung ParamRead.

Syntax

param_directgetallnext

Antwort

OK

<parameter_name> <value>

<parameter_name> <value>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<parameter_name> | Name des Parameters
<value> | Wert des Parameters

Im Fehlerfall siehe Antwortformat.


param_directput (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_directput

Verwendung

Mit diesem DBM-Kommando ändern Sie die Parameter der Datenbankinstanz.

Im Unterschied zum DBM-Kommando für das Ändern der Werte von Datenbankparametern (Siehe: param_put) wird der Wert für den angegebenen Parameter direkt in die Datenbankparameterdatei eingetragen. Der Eintrag erfolgt jedoch nur, wenn der Parameter in der Vorschlagsparameterdatei enthalten ist.

Verwenden Sie dieses DBM-Kommando mit großer Sorgfalt, da es direkt auf die Parameterdatei der Datenbankinstanz zugreift. Zwar prüft das System, ob die gemachten Änderungen den Vorschriften entsprechen und überschreibt ungültige Werte beim nächsten Restart der Datenbankinstanz gegebenenfalls mit den Werten aus der Vorschlagsparameterdatei. Dies gilt jedoch nicht für die Parameter RUNDIRECTORY und KERNELVERSION sowie alle Volume-Parameter. Wenn Sie diese Parameter ändern, kann dies zu schweren Inkonsistenzen im Datenbankbetrieb führen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamFull.

Syntax

param_directput <parameter_name> <value> [<comment>]

Optionen

Option | Beschreibung
<parameter_name> | Name des Datenbankparameters
<value> | Wert des Datenbankparameters
<comment> | zum Datenpankparameter zu speichernder Kommentar Wenn die Kommentarzeile Leerzeichen enthält, müssen Sie die Zeile in doppelte Anführungszeichen setzen.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


param_extget (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_extget

Verwendung

Sie lassen sich den Namen, Datentyp und aktuellen Wert des angegebenen Datenbankparameters anzeigen.

Die Suche erfolgt in der Parameterdatei der aktuellen Datenbankinstanz. Wenn der Parameter darin nicht vorhanden ist, dann wird der Vorschlagswert für diesen Parameter aus der Vorschlagsparameterdatei ausgegeben.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_extget <parameter_name>

<parameter_name>

Name des Parameters

Antwort

OK

<parameter_name> <type> <value>

Werte für die Felder der Antwort

Wert | Beschreibung
<parameter_name> | Name des Datenbankparameters
<type> | Datentyp des Datenbankparameters
<value> | aktueller Wert Dies ist der Wert, der zum Zeitpunkt des Starts der Sitzung aus der Datenbank-Parameterdatei übernommen wird. Wenn der Parameter darin nicht enthalten ist, wird der entsprechende Wert aus der Vorschlagsparameterdatei ausgegeben.

Im Fehlerfall siehe Antwortformat.


param_extgetall (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_extgetall

Verwendung

Sie lassen sich die Daten aller Datenbankparameter aus der Datenbank-Parameterdatei und der Vorschlagsparameterdatei anzeigen.

Es werden der Name jedes Datenbankparameters, sein Datentyp und sein aktueller Wert angezeigt. Dies ist der Wert, der zum Zeitpunkt des Beginns der Sitzung aus der Parameterdatei übernommen wird. Wenn der Parameter darin nicht vorhanden ist, wird der Wert aus der Vorschlagsparameterdatei angezeigt.

Durch die Angabe von Eigenschaften können Sie die Anzeige einschränken.

Wenn aufgrund der begrenzten Größe des Antwortpakets noch nicht alle Parameter angezeigt werden können, verwenden Sie anschließend param_extgetallnext, um sich den weiteren Inhalt der Parameterdatei anzeigen zu lassen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_extgetall [<property_list>]

<property_list>:: = <property_definition> <property_definition> ...

<property_definition>:: = <property>=<value> | <property>=<value,value,...>

Optionen

Option | Beschreibung
<property> | Eigenschaft des Parameters, muss in Großbuchstaben angegeben werden Wenn Sie mehrere Eigenschaften angeben, dann werden nur jene Parameter angezeigt, die allen Kriterien entsprechen (UND-Verknüpfung). Jede Eigenschaft kann nur einmal spezifiziert werden. Bei mehrfacher Eingabe derselben Eigenschaft wird der Wert der letzten Eingabe für die Suche verwendet.
<value> | Wert der Eigenschaft, muss in Großbuchstaben angegeben werden Sie können für jede Eigenschaft einen oder mehrere Werte angeben (ODER-Verknüpfung). Diese sind durch Komma voneinander zu trennen. Siehe auch: Konzepte des Datenbanksystems, Strukturlink Eigenschaften von Datenbankparametern

Antwort

OK

<parameter_name> <type> <value>

<parameter_name> <type> <value>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<parameter_name> | Name des Parameters
<type> | Datentyp des Parameters
<value> | Wert des Parameters

Im Fehlerfall siehe Antwortformat.

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen alle Parameter, die nicht änderbar und der Gruppe General - Allgemeine Datenbankparameter zugeordnet sind

>dbmcli –u OLEG,MONDAY –d DEMODB param_extgetall CHANGE=NO GROUP=GENERAL

OK

KERNELVERSION string KERNEL 7.6.00 BUILD 009-103-092-650

INSTANCE_TYPE string OLTP


param_extgetallnext (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_extgetallnext

Verwendung

Sie lassen sich nun die weiteren Daten der Parameter aus der Datenbankparameterdatei und der Vorschlagsparameterdatei anzeigen.

Es werden der Name jedes Datenbankparameters, sein Datentyp und sein aktueller Wert angezeigt. Dies ist der Wert, der zum Zeitpunkt des Beginns der Sitzung aus der Parameterdatei übernommen wird. Wenn der Parameter darin nicht vorhanden ist, wird der Wert aus der Vorschlagsparameterdatei angezeigt.

Um die weitere Ausgabe des zuvor ausgeführten DBM-Kommandos param_extgetall anzuzeigen, müssen Sie die Anzeige erneut mit den gleichen Eigenschaften und Werten einschränken. Wenn Sie jedoch keine oder andere Eigenschaften definieren, dann erfolgt die weitere Anzeige ab der ersten Zeile gemäß der neuen Definition.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

● Sie haben das DBM-Kommando zum Anzeigen der Daten aller Parameter aus der Datenbankparameterdatei und der Vorschlagsparameterdatei ausgeführt (Siehe: param_extgetall). Wegen der begrenzten Größe des Antwortpakets sind noch nicht alle Ergebnisse angezeigt worden.

● Sie haben die Serverberechtigung ParamRead.

Syntax

param_extgetall [<property_list>]

<property_list>:: = <property_definition> <property_definition> ...

<property_definition>:: = <property>=<value> | <property>=<value,value,...>

Optionen

Option | Beschreibung
<property> | Eigenschaft des Parameters, muss in Großbuchstaben angegeben werden Wenn Sie mehrere Eigenschaften angeben, dann werden nur jene Parameter angezeigt, die allen Kriterien entsprechen (UND-Verknüpfung). Jede Eigenschaft kann nur einmal spezifiziert werden. Bei mehrfacher Eingabe derselben Eigenschaft wird der Wert der letzten Eingabe für die Suche verwendet.
<value> | Wert der Eigenschaft, muss in Großbuchstaben angegeben werden Sie können für jede Eigenschaft einen oder mehrere Werte angeben (ODER-Verknüpfung). Diese sind durch Komma voneinander zu trennen. Siehe auch: Konzepte des Datenbanksystems, Strukturlink Eigenschaften von Datenbankparametern

Antwort

OK

<parameter_name> <data_type> <value>

<parameter_name> <data_type> <value>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<parameter_name> | Name des Parameters
<data_type> | Datentyp des Parameters
<value> | Wert des Parameters

Im Fehlerfall siehe Antwortformat.


param_getdefault (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_getdefault

Verwendung

Sie lassen sich den Vorschlagswert des Systems für den angegebenen Datenbankparameter anzeigen.

Sie erhalten eine OK-Meldung und eine Zeile mit dem Vorschlagswert des Systems. Die Zeile ist leer, wenn kein Vorschlagswert für den Datenbankparameter existiert.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_getdefault <parameter_name>

<parameter_name>

Name des Parameters

Antwort

OK

<default>

<default>

Vorschlagswert des Systems

Im Fehlerfall siehe Antwortformat.


param_getexplain (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_getexplain

Verwendung

Sie lassen sich den für den Datenbankparameter hinterlegten Erläuterungstext anzeigen.

Sie erhalten eine OK-Meldung und nachfolgend den Erläuterungstext. Die Zeile ist leer, wenn kein Erläuterungstext hinterlegt ist.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_getexplain <parameter_name>

<parameter_name>

Name des Parameters

Antwort

OK

<explanation_line>

<explanation_line>

...

<explanation_line>

Erläuterungstext

Im Fehlerfall siehe Antwortformat.


param_getfull (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_getfull

Verwendung

Sie lassen sich alle für den angegebenen Datenbankparameter hinterlegten Daten anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_getfull <parameter_name>

<parameter_name>

Name des Datenbankparameters

Antwort

OK

<type>

<default> <value>

<property> <value>

<property> <value>

...
HELP
<help_line>

<help_line>

...
EXPLAIN
<explain_line>

<explain_line>

...

Werte für die Felder der Antwort

Feld | Beschreibung
<type> | Datentyp des Parameters
<default> | Vorschlagswert des Systems
<value> | Aktueller Wert, wird zum Zeitpunkt des Starts der Sitzung aus der Parameterdatei übernommen
<property> | Eigenschaft des Parameters Siehe auch: Konzepte des Datenbanksystems, Strukturlink Eigenschaften von Datenbankparametern)
<help_line> | Hilfetext
<explain_line> | Erläuterungstext

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen aller Daten des Datenbankparameters RUNDIRECTORY:

>dbmcli -u OLEG,MONDAY -d DEMODB param_getfull RUNDIRECTORY

OK

string

c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB

CHANGE OFFLINE

INTERN NO

MANDATORY YES

CLEAR YES

DYNAMIC NO

CASESENSITIVE YES

DEVSPACE NO

MODIFY YES

GROUP GENERAL

DISPLAYNAME

VALUESET

MAX

MIN

INSTANCES

SYSDBAONLY YES

CLASS GENERAL

LASTKNOWNGOOD c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB

ACTIVEVALUE c:\documents and settings\all users\application data\sdb\data\wrk\DEMODB

HELP

Path where context and diagnosis information is stored

EXPLAIN

Path where context and diagnosis information is stored

for this database instance.

(char(256))


param_gethelp (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_gethelp

Verwendung

Sie lassen sich den für den angegebenen Datenbankparameter hinterlegten Hilfetext anzeigen.

Sie erhalten eine OK-Meldung und nachfolgend die Zeile mit dem hinterlegten Hilfetext. Die Zeile ist leer, wenn kein Hilfetext vorhanden ist.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_gethelp <parameter_name>

<parameter_name>

Name des Datenbankparameters

Antwort

OK

<help_line>

<help_line>

...

Im Fehlerfall siehe Antwortformat.


param_gethistory (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_gethistory

Verwendung

Sie öffnen die Historie der Datenbankparameter und übertragen den ersten Block des Inhalts. Dabei werden die Einträge in umgekehrter zeitlicher Reihenfolge angezeigt, d.h. die jüngsten Einträge zuerst und die ältesten zuletzt.

Durch die Angabe von Optionen haben Sie die Möglichkeit, die Ausgabe der Parameter einzuschränken. Wenn Sie mehrere Selektionskriterien angeben, dann werden nur die Daten jener Parameter ausgegeben, die allen Kriterien entsprechen. Zusätzlich können Sie definieren, welche Angaben zu den selektierten Parametern angezeigt werden sollen.

Jeder Parameter wird in einer gesonderten Zeile mit den Angaben zu allen definierten Feldern angezeigt.

Wenn die Einträge der Parameterhistorie aufgrund der begrenzten Größe des Antwortpakets nicht vollständig übertragen wurden, zeigen Sie den weiteren Inhalt mit param_gethistorynext an.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_gethistory [NAME=<parameter_name>] [DATE=<yyyymmdd>] [GROUP=<group_list>] [STATE=<status_list>] [FIELDS=<field_list>]

<group_list>:: = <parameter_group>,<parameter_group>,...

<status_list>:: = <status>,<status>...

<field_list>:: = <field>,<field>,...

<field>:: = DATE | TIME | NAME | OLDVALUE | NEWVALUE | STATE | GROUP | COMMENT

Optionen

Option | Beschreibung
<parameter_name> | Name des Datenbankparameters Wenn Sie keinen Parameternamen angeben, werden die Einträge für alle Parameter in der Historie angezeigt.
<yyyymmdd> | Datumsformat (Jahr Monat Tag) Es werden nur jene Parameteränderungen angezeigt, die seit diesem Datum erfolgten. Wenn Sie kein Datum angeben, werden alle Einträge in der Historie angezeigt.
<parameter_group> | Parametergruppe Es werden die Änderungen an den zu dieser Gruppe gehörenden Datenbankparametern angezeigt. Mögliche Werte sind: GENERAL: Allgemeine Datenbankparameter EXTENDED: Spezielle Datenbankparameter SUPPORT: Support-Datenbankparameter Wenn Sie keine Parametergruppe angeben, werden die Parameteränderungen aller Gruppen ausgegeben. Siehe auch: Konzepte des Datenbanksystems, Strukturlink Datenbankparameter
<status> | Datenbankparameter-Status MöglicheWerte sind: a | c | c a: aktive Datenbankparameter c: geänderte Datenbankparameter d: gelöschte Datenbankparameter Wenn Sie keinen Status angeben, werden alle Parameteränderungen ausgegeben.
<field> | Name des anzuzeigenden Feldes der Parameterhistorie Folgende Felder können angezeigt werden: DATE Datum der Parameteränderung TIME Uhrzeit der Parameteränderung NAME Name des Parameters NEWVALUE Neuer Wert des Parameters OLDVALUE Alter Wert des Parameters STATE Änderungsstatus des Parameters GROUP Gruppenzuordnung des Parameters COMMENT Kommentar, den Sie beim Ändern eines Parameters angeben können oder der vom System erzeugt wird Wenn Sie kein Feld angeben, werden alle Felder angezeigt.
<hhmmss> | Zeitformat (Stunden Minuten Sekunden) Es werden nur jene Parameteränderungen angezeigt, die seit dem angegebenen Zeitpunkt erfolgten. Wenn Sie keinen Zeitpunkt angeben, werden alle Einträge in der Historie angezeigt.

Antwort

OK

<header_line>

<param_line>

<param_line>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<header_line> | enthält die Namen der ausgegebenen Felder S steht für STATUS des Datenbankparameters
<param_line> | enthält die Werte für die in <header_line> angezeigten Felder, dabei hat der Wert die gleiche Spaltenposition wie der dazugehörige Feldname in der <header_line> Mögliche Status sind: a: aktiver Datenbankparameter c: geänderter Datenbankparameter d: gelöschter Datenbankparameter

Beispiel

Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli –u OLEG,MONDAY –d DEMODB

dbmcli on DEMODB>

● Anzeigen der Parameterhistorie für den Parameter MAXDATAVOLUMES:

>param_gethistory NAME=MAXDATAVOLUMES

OK

DATE TIME NAME NEWVALUE

OLDVALUE S GROUP

20050503 00134126 MAXDATAVOLUMES 32

64 A GENERAL

20050317 00141019 MAXDATAVOLUMES 64

1 C GENERAL

20050317 00141013 MAXDATAVOLUMES 1

C GENERAL

● Anzeigen aller Änderungen des Datenbankparameters MAXUSERTASKS mit Datum, Zeit und Status:

param_gethistory NAME=MAXUSERTASK FIELDS=DATE,TIME,STATE

OK

DATE TIME S

20050503 00105843 A

20050317 00141019 C

20050317 00141013 C


param_gethistorynext (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_gethistorynext

Verwendung

Sie lassen sich den weiteren Inhalt der Datenbankparameter-Historie anzeigen.

Wenn Sie beim Öffnen der Datenbankparameter-Historie mit Hilfe von Optionen Selektionskriterien angegeben haben, dann werden diese vom System auch für das anschließend ausgeführte DBM-Kommando param_gethistorynext verwendet.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Voraussetzungen

● Sie haben die Datenbankparameter-Historie geöffnet (Siehe: param_gethistory).

● Sie haben die Serverberechtigung ParamRead.

Syntax

param_gethistorynext

Antwort

OK

<header_line>

<param_line>

<param_line>

...

Wenn Sie nur die Antwort

OK

<header_line>

erhalten, dann sind alle spezifizierten Einträge bereits ausgegeben worden.

Werte für die Felder der Antwort

Wert | Beschreibung
<header_line> | enthält die Namen der ausgegebenen Felder S steht für STATE und beschreibt des Änderungszustand des Datenbankparameters
<param_line> | enthält die Werte für die in <header_line> angezeigten Felder, dabei hat der Wert die gleiche Spaltenposition wie der dazugehörige Feldname in der <header_line> Mögliche Status sind: a: aktiver Datenbankparameter c: geänderter Datenbankparameter d: gelöschter Datenbankparameter


param_getproperties (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_getproperties

Verwendung

Sie lassen sich alle Eigenschaften des angegebenen Datenbankparameters mit den dazugehörigen Werten anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Eigenschaften von Datenbankparametern

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_getproperties <parameter_name>

<parameter_name>

Name des Datenbankparameters

Antwort

OK

<property> <value>

<property> <value>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<property> | Eigenschaft des Datenbankparameters
<value> | Wert der Eigenschaft

Im Fehlerfall siehe Antwortformat.


param_gettype (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_gettype

Verwendung

Sie lassen sich den Datentyp des angegebenen Parameters anzeigen.

Sie erhalten eine OK-Meldung und anschließend den Datentyp des angegebenen Parameters angezeigt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_gettype <parameter_name>

<parameter_name>

Name des Datenbankparameters

Antwort

OK

<type>

<type>

Datentyp des Datenbankparameters,

Folgenden Werte sind möglich:

int2 | int4 | c8 | c18 | c24 | c40 | c64

Im Fehlerfall siehe Antwortformat


param_getvalue (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_getvalue

Verwendung

Sie lassen sich den aktuellen Wert des angegebenen Datenbankparameters anzeigen.

Sie erhalten eine OK-Meldung und den Wert des Parameters angezeigt, der beim letzten Starten der Datenbankinstanz in der Datenbank-Parameterdatei gesichert war.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_getvalue <parameter_name>

<parameter_name>

Name des Datenbankparameters

Antwort

OK

<value>

Im Fehlerfall siehe Antwortformat.


param_getvolsall (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_getvolsall

Verwendung

Sie lassen sich die Daten der Volumes einer Datenbankinstanz anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Volumes (permanenter Speicher)

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_getvolsall [<vol_mode>]

<vol_mode>

Art des Volume,

mögliche Werte sind: DATA | LOG | MLOG

DATA: Data-Volume

LOG: Log-Volume

MLOG: Gespiegeltes Log-Volume

Antwort

Sie erhalten alle Daten der angegebenen Volume-Art angezeigt.

OK

<parameter_name> <value>

<parameter_name> <value>

...

<vol_name> <vol_size> <vol_type> <file_name>

<vol_name> <vol_size> <vol_type> <file_name>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<parameter_name> | Name des für die angegebene Volume-Art relevanten Datenbankparameters
<value> | Wert des Parameters
<vol_name> | Name des Volume
<vol_size> | Größe des Volume
<vol_type> | Typ des Volume (z. B. Datei, Raw Device)
<file_name> | Name des Gerätes/der Datei des Volume

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Daten aller Volumes der Art DATA

>dbmcli –u OLEG,MONDAY –d DEMODB param_getvolsall DATA

OK

MAXDATAVOLUMES 64

DATA_VOLUME_NAME_0001 32768 F C:\Documents and Settings\All Users\Application Data\sdb\data\DEMODB\data\DISKD0001

DATA_VOLUME_NAME_0002 32768 F C:\Documents and Settings\All Users\Application Data\sdb\data\DEMODB\data\DISKD0002

...


param_getvolume (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_getvolume

Verwendung

Sie lassen sich die Daten eines einzelnen Volume der aktuellen Datenbankinstanz anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Volumes (permanenter Speicher)

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_getvolume <vol_no> <vol_mode>

Optionen

Option | Beschreibung
<vol_no> | Nummer des Volume
<vol_mode> | Art des Volume, mögliche Werte sind: DATA | LOG | MLOG DATA: Data-Volume LOG: Log-Volume MLOG: Gespiegeltes Log-Volume

Antwort

OK

<file_name>

<vol_type>

<vol_size>

Werte für die Felder der Antwort

Wert | Beschreibung
<file_name> | Name des Gerätes/der Datei
<vol_type> | Typ des Volume (z. B. Datei, Raw Device)
<vol_size> | Größe des Volume

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Daten des Volume Nr. 0001 vom Typ DATA:

>dbmcli –u OLEG,MONDAY –d DEMODB param_getvolume 0001 DATA

OK

C:\Documents and Settings\All Users\Application Data\sdb\data\DEMODB\data\DISKD0001

F

32768


param_init (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_init

Verwendung

Sie initialisieren alle Datenbankparameter, die für das Anlegen einer neuen Datenbankinstanz erforderlich sind. Bei diesem Vorgang wird der Name der Datenbankinstanz aus der Sitzung mit dem Database Manager benutzt. Für diese Datenbankinstanz darf noch keine Datenbankparameterdatei existieren.

Sämtliche Datenbankparameter werden zunächst mit ihren Werten aus der Vorschlagsparameterdatei belegt.

Die Initialisierung erfolgt nur innerhalb des Programms Database Manager. Um die Parameter in der Datenbankparameterdatei zu sichern, müssen Sie anschließend alle Parameter prüfen (Siehe: param_checkall) und bestätigen (Siehe: param_commitsession).

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Konzepte des Datenbanksystems, Strukturlink Anlegen und Konfigurieren einer Datenbankinstanz

Voraussetzungen

● Sie haben eine Parametersitzung eröffnet (Siehe: param_startsession).

● Sie haben die Serverberechtigung InstallMgm.

Syntax

param_init [<database_type>]

<database_type>

Datenbanktyp, mögliche Werte sind: OLTP | LVC

OLTP: MaxDB-Datenbankinstanz

LVC: liveCache-Datenbankinstanz

Vorschlagswert des Systems ist OLTP.

Antwort

OK

Im Fehlerfall siehe Antwortformat


param_put (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_put

Verwendung

Sie ändern den Wert eines Datenbankparameters. Wenn Sie dieses DBM-Kommando ausführen, dann wird vom System implizit eine Parametersitzung geöffnet. Der Parameterwert wird geändert und anhand der in der Vorschlagsparameterdatei hinterlegten Eigenschaften, Berechnungsvorschriften und Bedingungen geprüft. Anschließend wird die Änderung des Parameters bestätigt und in die Parameterdatei eingetragen.

Die Änderung des Parameters wird vom System abgelehnt, wenn der eingegebene Wert oder die Änderung aufgrund der Eigenschaften des Parameters nicht zulässig ist.

Sie haben die Möglichkeit zu definieren, wie lange die Änderung wirksam ist:

● nur bis zum nächsten Restart

● erst nach dem nächsten Restart

● sofort und dauerhaft

Nur bis zum nächsten Restart wirksame Änderungen können jedoch nur für Datenbankparameter mit der Eigenschaft CHANGE=RUNNING definiert werden.

Siehe auch:

param_getproperties (Anzeigen aller Eigenschaften eines Datenbankparameters)

Tutorial Datenbankverwaltung, Strukturlink Wert eines einzelnen Datenbankparameters ändern, Strukturlink Werte mehrerer Datenbankparameter ändern

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter, Strukturlink Eigenschaften von Datenbankparametern

Voraussetzungen

Sie haben die Serverberechtigung ParamCheckWrite.

Syntax

param_put [<durability>] <parameter_name> <new_value> [<comment>]

<durability>::= [-running] [-permanent]

Optionen

Option

Beschreibung

<durability>

Dauerhaftigkeit der Änderung, mögliche Werte sind:

-running: Die Änderung gilt ab sofort, jedoch nur, solange die Datenbankinstanz nicht in den Betriebszustand OFFLINE gebracht wird, d. h. bis zum nächsten Restart oder Überführen in den Betriebszustand ADMIN. Danach gilt für den Parameter wieder der ursprüngliche Wert.

-permanent: Die Änderung erfolgt nur in der Datenbankparameterdatei. Sie wird nicht aktuell sondern erst beim nächsten Restart der Datenbankinstanz wirksam.

-running –permanent: Die Änderung gilt ab sofort und bleibt auch nach einem Restart erhalten.

Vorschlagswert des Systems ist -permanent.

<parameter_name>

Name des Datenbankparameters

<new_value>

Neuer Wert des Parameters

<comment>

zum Datenbankparameter gespeicherter Kommentar

Wenn die Kommentarzeile Leerzeichen enthält, müssen Sie die Zeile in doppelte Anführungszeichen setzen.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


param_restore (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_restore

Verwendung

Sie setzen die Datenbankparameterdatei auf die angegebene frühere Version dieser Datei zurück. Beim nächsten Restart der Datenbankinstanz wird diese als Datenbankparameterdatei verwendet.

Sie ermitteln den Namen der gewünschten Datei mit Hilfe des DBM-Kommandos param_versions.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien

Voraussetzungen

Sie haben die Serverberechtigung ParamCheckWrite.

Syntax

param_restore <file_name>

<file_name>

Name jener Parameterdatei, auf die die aktuelle Datenbankparameterdatei zurückgesetzt werden soll (Siehe: param_versions)

Antwort

OK

Im Fehlerfall siehe Antwortformat.


param_rmfile (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_rmfile

Verwendung

Sie löschen die Datenbankparameterdatei der aktuellen Datenbankinstanz.

Mit dem DBM-Kommando param_restore können Sie die vor dem Löschen gültige Version der Parameterdatei wiederherstellen.

Verwenden Sie dieses DBM-Kommando mit großer Sorgfalt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien

Voraussetzung

Sie haben die Serverberechtigung InstallMgm.

Syntax

param_rmfile

Antwort

OK

Im Fehlerfall siehe Antwortformat.


param_startsession (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_startsession

Verwendung

Sie eröffnen eine Parametersitzung, um Parameter einer Datenbankinstanz prüfen zu lassen oder zu ändern.

Das Programm Database Manager liest die Vorschlagsparameterdatei und die Datenbankparameterdatei ein und legt deren Inhalt in internen Datenstrukturen ab. Innerhalb einer Parametersitzung erfolgen alle Zugriffe auf diese internen Daten.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Werte mehrerer Datenbankparameter ändern

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_startsession

Antwort

OK

Im Fehlerfall siehe Antwortformat.


param_versions (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen param_versions

Verwendung

Sie lassen sich die Liste aller vorhandenen Versionen der Datenbankparameterdatei anzeigen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien

Voraussetzungen

Sie haben die Serverberechtigung ParamRead.

Syntax

param_versions

Antwort

OK

<file_name>

<file_name>

...

<file_name>

Name der Version der Datenbankparameterdatei

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen aller Versionen der Datenbankparameterdatei:

>dbmcli -u OLEG,MONDAY -d DEMODB param_versions

OK

c:\documents and settings\all users\application data\sdb\data\config\DEMODB

c:\documents and settings\all users\application data\sdb\data\config\DEMODB.01

c:\documents and settings\all users\application data\sdb\data\config\DEMODB.02

c:\documents and settings\all users\application data\sdb\data\config\DEMODB.03


recover_cancel (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_cancel

Verwendung

Sie brechen eine unterbrochene Wiederherstellung oder Prüfung einer Sicherung endgültig ab. Die Datenbankinstanz wird in den Betriebszustand OFFLINE überführt.

Bei der Antwort auf dieses DBM-Kommando ist nur das Feld Returncode mit einem Wert belegt.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Schatteninstanz als aktive Instanz in Betrieb nehmen

Konzepte des Datenbanksystems, Strukturlink Datenbankinstanz wiederherstellen

Voraussetzungen

● Sie haben die Serverberechtigung Backup.

● Sie haben das DBM-Kommando zum Wiederherstellen der Datenbankinstanz (Siehe: recover_start) oder zum Prüfen einer Sicherung (Siehe: recover_check) ausgeführt. Der Vorgang wurde unterbrochen. Sie befinden sich noch in derselben Datenbanksitzung.

Syntax

recover_cancel

Antwort

OK
Returncode <value>

Im Fehlerfall siehe Antwortformat.


recover_cancel_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_cancel_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


recover_check (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_check

Verwendung

Sie prüfen, ob der Database Manager ordnungsgemäß auf den angegebenen Datenträger zugreifen und die Daten darauf lesen kann. Sie können mit diesem DBM-Kommando beispielsweise prüfen, ob der Zugriff auf ein Sicherungswerkzeug funktioniert.

Die Ausführung dieses DBM-Kommandos erfolgt unabhängig von den laufenden Funktionen der Datenbankinstanz. Sie kann jedoch mit zeitweiligen Performance-Einbußen für die Datenbankinstanz verbunden sein.

Die angegebene Sicherung wird nur geprüft, nicht wiederhergestellt.

Voraussetzungen

● Sie haben die Serverberechtigung Backup .

● Sie haben eine Servicesitzung eröffnet (Siehe: service_connect).

Syntax

recover_check <medium_name> <type> [EBID <ebid_list>] [<nnn>] [UNTIL <date> <time>]

<ebid_list> :: = <external_backup_ID> | <external_backup_ID>,<external_backup_ID>,...

Optionen

Option

Beschreibung

<medium_name>

Name der Sicherungsvorlage

<type>

Art der Sicherung, mögliche Werte sind:

DATA: vollständige Datensicherung

PAGES: inkrementelle Datensicherung

LOG: Log-Sicherung

<nnn>

nur bei Log-Sicherung: Version der Sicherung auf dem Datenträger, nur bei einem Datenträger vom Typ FILE relevant

UNTIL <date> <time>

<date> ::= <yyyymmdd>

<time> ::= <hhmmss>

nur bei Log-Sicherung: genauer Zeitpunkt (Jahr, Monat, Tag, Stunde, Minuten, Sekunden), bis zu dem geprüft werden soll

<ebid_list>

Liste der externen Sicherungskennungen,

Wenn die Liste mehrere Sicherungskennungen enthält, dann sind diese durch Kommas voneinander zu trennen.

Wenn Sicherungskennungen Leerzeichenhalten, muss die Liste in doppelte Anführungszeichen eingeschlossen werden.

<external_backup_ID>

nur für das Prüfen einer Sicherung, die mit dem Sicherungswerkzeug eines anderen Anbieters erstellt wurde: Name, unter dem die Sicherung dem Sicherungswerkzeug bekannt ist

Erfolgreiche Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Mediumname [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Werte für die Felder der Antwort

Wert | Beschreibung
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version des Datenbanksoftware
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Datenträger
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße bei Einlesen der Sicherung)

Antwort im Fehlerfall

ERR

<err_code>, <err_description>

[<extended_description>

Werte für die Felder der Antwort

Wert | Beschreibung
<err_code> | Nummer der Fehlermeldung Siehe auch: Dokumentation Strukturlink Meldungen
<err_description> | Beschreibung des Fehlers
<extended_description> | Fehlerursache

Es können folgende Fehler auftreten:

<err_code> | <err_description> | Erläuterung
-24927 | ERR_TOOLCHK: the external backup tool was not found | Das Sicherungswerkzeug wurde nicht gefunden oder ist nicht korrekt installiert.
-24926 | ERR_MEDIUMCHK: the medium cannot be used with an external backup tool | Die angegebene Sicherungsvorlage kann nicht mit einem Sicherungswerkzeug verwendet werden.
-24925 | ERR_PREPARE: prepare of the backup operation failed | Die für die Verwendung des Sicherungswerkzeugs notwendigen Vorbereitungen konnten nicht erfolgreich abgeschlossen werden.
-24924 | ERR_DBREQ: cannot start database kernel request | Die Datenbankinstanz konnte die Prüfung nicht starten.
-24923 | ERR_TOOLREQ: cannot start external backup tool correctly | Das Sicherungswerkzeug konnte nicht korrekt gestartet werden.
-24922 | ERR_OPCHK: cannot check state of backup operation | Es war nicht möglich, die Zustände der Datenbankinstanz oder des Sicherungswerkzeugs zu prüfen.
-24921 | ERR_POSTOP: cannot finish backup operation correctly | Obwohl die Sicherung erfolgreich war, konnten die notwendigen Nachbearbeitungsschritte nicht durchgeführt werden.
-24920 | ERR_BACKUPOP: backup operation was unsuccessful | Die Prüfung ist wegen eines Datenbankproblems oder eines Problems des Sicherungswerkzeuges fehlgeschlagen.
-24919 | ERR_CLEANUP: cannot clean up correctly after backup operation | Obwohl die Prüfung erfolgreich war, konnten die in Anspruch genommenen temporären Systemressourcen nicht wieder freigegeben werden.


recover_check_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_check_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


recover_config (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_config

Verwendung

Sie verwenden dieses DBM-Kommando beim Anlegen einer Datenbankinstanz. Es ermöglicht Ihnen, eine neue Datenbankinstanz mit den gleichen Parameterwerten wie eine vorhandene Datenbankinstanz anzulegen. Sie benötigen dazu eine vollständige Datensicherung der vorhandenen Datenbankinstanz und lesen daraus die Parameterdatei in die neue Datenbankinstanz ein.

Die Kopie der Parameterdatei wird anschließend im <dependent_path> unter dem Namen der aktuellen Datenbankinstanz abgelegt.

Wenn Sie das Kommando beim Anlegen einer Datenbankkopie oder einer Schatteninstanz verwenden, sollten Sie immer die Notwendigkeit prüfen, diese Datenbankinstanzen aus Sicherheitsgründen auf einem anderen Datenbankrechner als die Originalinstanz anzulegen. Wenn Sie sie jedoch auf dem gleichen Rechner wie die Originalinstanz anlegen, müssen Sie in jedem Fall die von der Originalinstanz importierten Parameterwerte für das Arbeitsverzeichnis und die Diagnosehistorie sowie die Pfade der Data- und Log-Volumes ändern, da es sonst zu Kollisionen kommt.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Parameterdatei aus einer Datensicherung kopieren

Konzepte des Datenbanksystems, Strukturlink Datenbankparameter

Voraussetzungen

  • Sie haben die Serverberechtigung Recovery.
  • Sie haben eine Service-Sitzung eröffnet (Siehe: service_connect).

Syntax

recover_config <medium_name>

<medium_name>

Name der Sicherungsvorlage

Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Mediumname [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Werte für die Felder der Antwort

Wert | Beschreibung
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version des Datenbanksoftware
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Datenträger
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung Siehe auch: Dokumentation Strukturlink Meldungen
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße bei Einlesen der Sicherung)

Im Fehlerfall siehe Antwortformat.


recover_ignore (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_ignore

Verwendung

Beim Wiederherstellen einer Sicherung, die mit Hilfe einer Sicherungsvorlage für mehrere parallele Datenträger erstellt wurde, wurden die Daten von einem der beteiligten Datenträger vollständig eingelesen. Das System fordert Sie auf, für diesen einen Folgedatenträger anzugeben. Wenn Sie stattdessen das DBM-Kommando recover_ignore ausführen, arbeitet das System nur noch mit den übrigen Plätzen der parallelen Datenträger.

Sie würden dieses DBM-Kommando beispielsweise in folgender Situation verwenden: Sie wollen eine Sicherung einlesen, die mit Hilfe von 3 Bandlaufwerken parallel erstellt wurde und insgesamt 5 Bänder umfasst. Sie starten das Einlesen der Daten mit Hilfe von 3 Bandlaufwerken und somit von den Bändern 1-3 parallel. Nach einiger Zeit wurden die Daten des Bandes im Bandlaufwerk 1 bereits vollständig eingelesen. Das Einlesen der Daten der Bandlaufwerke 2 und 3 dauert noch an. Das System fordert Sie auf, ein Folgeband in das Bandlaufwerk 1 einzulegen. Wenn Sie nun recover_ignore eingeben, wird das Einlesen der Sicherungen nur noch mit den Bandlaufwerken 2 und 3 fortgesetzt. Sobald das nächste Bandlaufwerk (beispielsweise Bandlaufwerk 3) Sie auffordert, einen weiteren Datenträger einzulegen, geben Sie mit recover_replace einen Folgedatenträger an und lesen somit Band 4 ein. Wenn Sie vom Bandlaufwerk 2 die entsprechende Aufforderung erhalten, geben Sie mit recover_replace ebenfalls eine Folgedatenträger an und lesen somit Band 5 ein. Danach sind alle 5 Bänder der Sicherung eingelesen.

Als Antwort auf dieses DBM-Kommando erhalten Sie die Informationen über das Einlesen der Sicherung angezeigt. Werten Sie insbesondere die im Feld Returncode angezeigte Meldungsnummer aus.

Die Antwort erhalten Sie jedoch erst dann, wenn die Sicherung vollständig eingelesen ist oder das Einlesen unterbrochen wurde. Die Ausführung dieses Kommandos kann deshalb sehr lange dauern.

Voraussetzungen

● Sie haben die Serverberechtigung Backup.

● Sie haben das Wiederherstellen der Datenbankinstanz durch das Einlesen der Daten von mehreren Datenträgern parallel begonnen (Siehe: recover_start) und befinden sich noch in derselben Datenbanksitzung. Der Vorgang wurde unterbrochen, weil das System für einen der parallelen Datenträger einen Folgedatenträger anfordert.
Sie wollen hier keinen Folgedatenträger mehr angeben und nur noch die übrigen Datenträger weiter einlesen.

Syntax

recover_ignore

Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Mediumname [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Werte für die Felder der Antwort

Wert | Beschreibung
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version des Datenbanksoftware
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Datenträger
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung Siehe auch: Dokumentation Strukturlink Meldungen
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße bei Einlesen der Sicherung)

Im Fehlerfall siehe Antwortformat.


recover_ignore_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_ignore_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


recover_replace (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_replace

Verwendung

Sie geben den Folgedatenträger an, von dem die Sicherung weiter gelesen werden soll.

Als Antwort auf dieses DBM-Kommando erhalten Sie die Informationen über das Einlesen der Sicherung angezeigt. Werten Sie insbesondere die im Feld Returncode angezeigte Meldungsnummer aus.

Die Antwort erhalten Sie jedoch erst dann, wenn die Sicherung vollständig eingelesen ist oder das Einlesen unterbrochen wurde. Die Ausführung dieses Kommandos kann deshalb sehr lange dauern.

Wenn Sie das DBM-Kommando ausgeführt haben und das Wiederherstellen anschließend erneut unterbrochen wird (Meldungsnummer -8020), dann geben Sie mit recover_replace den nächsten Folgedatenträger an.

Sie wiederholen diesen Vorgang bis die Daten von allen zu dieser Sicherung gehörenden Datenträgern eingelesen wurden.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Wiederherstellen der Datenbankinstanz

Konzepte des Datenbanksystems, Strukturlink Datenbankinstanz wiederherstellen

Voraussetzungen

● Sie haben die Serverberechtigung Backup.

● Sie haben das DBM-Kommando zum Wiederherstellen der Datenbankinstanz ausgeführt (Siehe: recover_start. Der Vorgang wurde unterbrochen, weil die auf dem Datenträger gespeicherten Daten vollständig eingelesen wurden. Sie befinden sich noch in derselben Datenbanksitzung.

Syntax

recover_replace <medium_name> [ExternalBackupID <ext_backup_ID>] [<loc> [<nnn>]]

Optionen

Option | Beschreibung
<medium_name> | Datenträger von dem die Sicherung eingelesen werden soll Beim Wiederherstellen einer Sicherung, die mit Hilfe einer Sicherungsvorlage für mehrere parallele Datenträger erstellt wurde, ist hier der Name der Gruppe paralleler Datenträger anzugeben.
ExternalBackupID <external_backup_ID> | nur für das Wiederherstellen einer Sicherung, die mit einem Sicherungswerkzeug erstellt wurde: Name, unter dem die Sicherung dem Sicherungswerkzeug bekannt ist
<loc> | Name des Gerätes/der Datei in dem sich die wiederherzustellende Sicherung befindet. Das Gerät/die Datei muss über <loc> durch Betriebssystemfunktionen angesprochen werden können.
<nnn> | nur für einzulesende Log-Sicherung und nur für Datenträger vom Typ FILE: Versionsnummer der Log-Sicherung auf dem einzulesenden Datenträger

Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Mediumname [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Werte für die Felder der Antwort

Wert | Beschreibung
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version des Datenbanksoftware
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Datenträger
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung Siehe auch: Dokumentation Strukturlink Meldungen
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße bei Einlesen der Sicherung)

Im Fehlerfall siehe Antwortformat.


recover_replace_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_replace_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


recover_req (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_req

Verwendung

Dieses DBM-Kommando wird nur von DBM-Client-Programmen verwendet.

Es ist gegenwärtig nicht dokumentiert.


recover_start (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_start

Verwendung

Sie lesen die Sicherungen der Datenbankinstanz ein und stellen den darin enthaltenen Datenbankzustand wieder her.

Um die Datenbankinstanz komplett wiederherzustellen, lesen Sie zunächst die aktuellste vollständige Datensicherung ein. Wenn Sie nach der vollständigen Datensicherung eine oder mehrere inkrementelle Datensicherungen erstellt haben, dann müssen Sie auch diese einlesen. Die Informationen darüber, welches die aktuellste vollständige Datensicherung ist und welche inkrementellen Datensicherungen danach angefertigt wurden, finden Sie in der Sicherungshistorie (Siehe backup_history_open).

Nach dem Einlesen der Datensicherung/en erhalten Sie angezeigt, mit welcher Log-Seite begonnen werden muss, die Log-Sicherungen einzulesen. Sie können diese Information auch in der Sicherungshistorie finden. Auf der Basis dieser Information wählen Sie die erste einzulesende Log-Sicherung aus. Anschließend lesen Sie die weiteren Log-Sicherungen in chronologischer Reihenfolge ein.

Der Restartinformation können Sie entnehmen, bis zu welcher Log-Seite Sie Log-Sicherungen einlesen müssen. Sie erhalten angezeigt, ab welcher Nummer sich die Log-Seiten noch im Log-Bereich befinden und vom System daraus wiederhergestellt werden können (Siehe db_restartinfo).

Die Gesamtheit der einzulesenden Sicherungen muss lückenlos den wiederherzustellenden Datenbankinhalt enthalten. Nur die letzten, noch im Log-Bereich vorhandenen Log-Einträge können vom Datenbanksystem selbsttätig wiederhergestellt werden, wenn die Log-Volumes noch intakt sind.

Wenn die Log-Volumes noch alle Log-Einträge enthalten, die nach jener Datensicherung geschrieben wurden, die als letzte eingelesen wurde, dann genügt es, nach dem Einlesen der Datensicherung die Datenbankinstanz neu zu starten (Siehedb_restart). Das System liest dann den Inhalt des Log-Bereichs ein.

Wenn Sie nach der letzten Datensicherung noch Log-Sicherungen einlesen müssen, dann erkennt das Datenbanksystem, ab welcher Seite der noch fehlende Inhalt aus dem Log-Bereich eingelesen werden kann. Es bricht das Einlesen der Log-Sicherung an dieser Stelle ab, stellt die übrigen Log-Seiten aus dem Log-Bereich wieder her und überführt die Datenbankinstanz selbsttätig in den Betriebszustand ONLINE.

Sie können sowohl sequentiell erstellte Datensicherungen als auch Datensicherungen, die auf mehrere Datenträger parallel erstellt wurden, in das Datenbanksystem einlesen.
Datensicherungen lesen Sie mit dem DBM-Kommando recover_start ein, ebenso die erste einzulesende Log-Sicherung.

Beim Wiederherstellen müssen alle weiteren Log-Sicherungen mit dem Folgekommando recover_replace eingelesen werden (nach Rückgabewert -8020).
Siehe Tutorial Datenbankverwaltung, Strukturlink Wiederherstellen der Datenbankinstanz

Beim Einrichten einer Schatteninstanz müssen auch alle weiteren Log-Sicherungen mit recover_start eingelesen werden (nach Rückgabewert -7075).
Siehe Tutorial Datenbankverwaltung, Strukturlink Schatteninstanz einrichten und aktualisieren

Sie haben die Möglichkeit, die Datenbankinstanz nur bis zu einem bestimmten konsistenten Zustand vor einem Datenbank- oder Festplattenfehler wiederherzustellen. Mit Hilfe einer Option können Sie beim Einlesen der Log-Sicherungen angeben, bis zu welchem Zeitpunkt die Einträge aus den Log-Sicherungen oder gegebenenfalls aus dem Log-Bereich eingelesen werden sollen.

Wenn die Sicherungen mit Hilfe eines Sicherungswerkzeugs eines anderen Anbieters erstellt wurden, verwenden Sie dieses Werkzeug auch für das Einlesen der Sicherungen. Ermitteln Sie dafür zunächst die externe Sicherungskennung der erforderlichen Sicherung (Siehe: backup_ext_ids_get und backup_ext_ids_list). Anhand dieser Kennung identifiziert der Database Manager die einzulesende Sicherung.

Beim parallelen Einlesen der Sicherungen mit Hilfe eines Sicherungswerkzeugs muss die Zahl der Datenträger einer Gruppe paralleler Datenträger exakt der Anzahl der Datenträger entsprechen, die für das Erstellen der Sicherung verwendet wurden. Es ist in diesem Falle nicht möglich, mit einer geringeren Zahl von Datenträgern zu beginnen und die anderen als weitere Folgedatenträger einzulesen. Sie können auch alle Datenträger einer solchen Sicherung sequentiell einlesen.

Als Antwort auf das DBM-Kommando recover_start erhalten Sie die Informationen über das Einlesen der Sicherung angezeigt. Die Ausgabe erfolgt jedoch erst dann, wenn die Sicherung vollständig eingelesen ist oder unterbrochen wurde. Die Ausführung dieses Kommandos kann deshalb sehr lange dauern.

Wenn vor dem Beginn des Wiederherstellens die automatische Log-Sicherung aktiv war, wird diese nach dem Wiederherstellen nicht automatisch wieder eingeschaltet. Um die automatische Log-Sicherung wieder einzuschalten, führen Sie das DBM-Kommando autolog_on aus.

Wenn Sie nach dem durch das Wiederherstellen erreichten Datenbankzustand die Software aktualisiert haben, müssen Sie die Systemtabellen neu laden, um diese der neuen Softwareversion anzupassen.

Wenn es während des parallelen Wiederherstellens der Datenbankinstanz mit einem Sicherungswerkzeug zu einem Deadlock kommen sollte, müssen Sie alle Datenträger der Gruppe mit Hilfe des Database Manager einzeln nacheinander einlesen.

Siehe auch:

Tutorial Datenbankverwaltung

● Strukturlink Wiederherstellen der Datenbankinstanz,

● Strukturlink Datenbankkopie erstellen (Datensicherung in eine andere Datenbankinstanz einlesen)

Konzepte des Datenbanksystems, Strukturlink Datenbankinstanz wiederherstellen

Voraussetzungen

● Sie haben die Serverberechtigung Recovery.

● Die Datenbankinstanz befindet sich im Betriebszustand ADMIN.

● Sie haben eine Datenbanksitzung eröffnet (Siehe db_connect).

Wenn Sie die Datenbankinstanz mit Hilfe eines Sicherungswerkzeugs eines anderen Anbieters wiederherstellen wollen, müssen auch folgende Voraussetzungen erfüllt sein:

● Sie haben Ihre MaxDB-Softwareinstallation für das entsprechende Sicherungswerkzeug konfiguriert (Siehe: Installationshandbuch, Strukturlink Anschluss von Sicherungswerkzeugen anderer Anbieter).

● Sie verfügen über die erforderlichen Daten- und Log-Sicherungen zum Wiederherstellen der Datenbankinstanz.

Syntax

Einlesen einer Datensicherung

recover_start <medium_name> <backup_type> [LABEL <label>] [EBID <ebid_list>] [AUTOIGNORE]

<ebid_list> :: = <external_backup_ID> | <external_backup_ID>,<external_backup_ID>,...

Einlesen einer Log-Sicherung

recover_start <medium_name> <backup_type> [LABEL <label>] [<nnn> | EBID <ebid_list>] [UNTIL <date> <time>] [AUTOIGNORE]

<ebid_list> :: = <external_backup_ID> | <external_backup_ID>,<external_backup_ID>,...

Optionen

Option

Beschreibung

<medium_name>

Sicherungsvorlage von dem die Sicherung eingelesen werden soll
Beim Einlesen einer Sicherung, die auf mehrere Datenträger parallel erstellt wurde, ist hier der Name der Gruppe paralleler Datenträger anzugeben.

<backup_type>

Art der einzulesenden Sicherung, mögliche Werte sind:

DATA: vollständige Datensicherung

PAGES: inkrementelle Datensicherung

LOG: Log-Sicherung

LABEL <label>

Sicherungskennung des einzulesenden Datenträgers

<ebid_list>

Liste der externen Sicherungskennungen,

Wenn die Liste mehrere Sicherungskennungen enthält, dann sind diese durch Kommas voneinander zu trennen.

Wenn Sicherungskennungen Leerzeichenhalten, muss die Liste in doppelte Anführungszeichen eingeschlossen werden.

<external_backup_ID>

nur für das Einlesen einer Sicherung, die mit einem Sicherungswerkzeug erstellt wurde: Name, unter dem die Sicherung dem Sicherungswerkzeug bekannt ist

<nnn>

nur für einzulesende Log-Sicherung und nur für Datenträger vom Typ FILE: Versionsnummer der Log-Sicherung auf dem einzulesenden Datenträger

UNTIL <date> <time>
<date> ::= <yyyymmdd>
<time> ::= <hhmmss>

genauer Zeitpunkt (Jahr, Monat, Tag, Stunde, Minuten, Sekunden), bis zu dem wiederhergestellt werden soll

AUTOIGNORE

Im Falle des parallelen Wiederherstellens soll der Vorgang vom System automatisch fortgesetzt werden.

Erfolgreiche Antwort

OK

Returncode 0

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Mediumname [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Werte für die Felder der Antwort

Wert | Beschreibung
Returncode | Der Rückgabewert 0 bestätigt das erfolgreiche Einlesen der Sicherung.
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version der Datenbanksoftware
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Datenträger
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße bei Einlesen der Sicherung)

Antwort im Fehlerfall

ERR

<err_code>, <err_description>

[<extended_description>]

Werte für die Felder der Antwort

Wert | Beschreibung
<err_code> | Nummer der Fehlermeldung Siehe auch: Dokumentation Strukturlink Meldungen
<err_description> | Beschreibung des Fehlers
<extended_description> | Fehlerursache

Es können unter anderem folgende Fehler auftreten:

Nummer der Fehlermeldung | Text der Fehlermeldung | Erläuterung
-24927 | ERR_TOOLCHK: the external backup tool was not found | Das externe Sicherungswerkzeug wurde nicht gefunden oder ist nicht korrekt installiert.
-24926 | ERR_MEDIUMCHK: the medium cannot be used with an external backup tool | Die angegebene Sicherungsvorlage kann nicht mit dem Sicherungswerkzeug verwendet werden, auf das der Name hinweist.
-24925 | ERR_PREPARE: prepare of the backup operation failed | Die für die Verwendung des Sicherungswerkzeugs notwendigen Vorbereitungen konnten nicht erfolgreich abgeschlossen werden.
-24924 | ERR_DBREQ: cannot start database kernel request | Die Datenbankinstanz konnte den Wiederherstellungsvorgang nicht starten.
-24923 | ERR_TOOLREQ: cannot start external backup tool correctly | Das Sicherungswerkzeug konnte nicht korrekt gestartet werden.
-24922 | ERR_OPCHK: cannot check state of backup operation | Es war nicht möglich, die Zustände der Datenbankinstanz oder des Sicherungswerkzeugs zu überprüfen.
-24921 | ERR_POSTOP: cannot finish backup operation correctly | Obwohl die Wiederherstellung erfolgreich war, konnten die notwendigen Nachbearbeitungsschritte nicht durchgeführt werden.
-24920 | ERR_BACKUPOP: backup operation was unsuccessful | Die Wiederherstellung ist wegen eines Datenbankproblems oder eines Problems des Sicherungswerkzeuges fehlgeschlagen.
-24919 | ERR_CLEANUP: cannot clean up correctly after backup operation | Obwohl die Wiederherstellung erfolgreich war, konnten die in Anspruch genommenen temporären Systemressourcen nicht wieder freigegeben werden.


recover_state (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_state

Verwendung

Sie lassen sich Informationen über den aktuellen Stand des Wiederherstellens der Datenbankinstanz anzeigen.

Sie können dieses DBM-Kommando auch während der laufenden Wiederherstellung einer Datenbankinstanz ausführen.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenbankinstanz wiederherstellen

Voraussetzungen

● Sie haben die Serverberechtigung Recovery.

● Sie haben das DBM-Kommandos zum Wiederherstellen der Datenbankinstanz ausgeführt (Siehe: recover_start).

Syntax

recover_state

Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Mediumname [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Werte für die Felder der Antwort

Wert | Beschreibung
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version des Datenbanksoftware
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Datenträger
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung Siehe auch: Dokumentation Strukturlink Meldungen
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße bei Einlesen der Sicherung)

Im Fehlerfall siehe Antwortformat.


recover_state_check (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_state_check

Verwendung

Sie lassen sich Informationen über den aktuellen Stand des Prüfens einer Sicherung anzeigen (Siehe: recover_check).

Sie können dieses DBM-Kommando auch während der laufenden Prüfung einer Sicherung ausführen.

Voraussetzungen

● Sie haben die Serverberechtigung Backup.

● Sie haben eine Servicesitzung eröffnet (Siehe: service_connect).

Syntax

recover_state_check

Antwort

OK

Returncode <value>

Date [<value>]

Time [<value>]

Server [<value>]

Database [<value>]

Kernel Version [<value>]

Pages Transferred [<value>]

Pages Left [<value>]

Volume Count [<value>]

Mediumname [<value>]

Location [<value>]

Errortext [<value>]

Label [<value>]

Is Consistent [<value>]

First LOG Page [<value>]

Last LOG Page [<value>]

DB Stamp 1 Date [<value>]

DB Stamp 1 Time [<value>]

DB Stamp 2 Date [<value>]

DB Stamp 2 Time [<value>]

Page Count [<value>]

Devices Used [<value>]

Database ID [<value>]

Max Used Data Page [<value>]

Werte für die Felder der Antwort

Wert | Beschreibung
Date | Datum
Time | Zeit
Server | Name des Datenbankrechners
Database | Name der Datenbankinstanz
Kernel Version | Version des Datenbanksoftware
Pages Transferred | Anzahl der übertragenen Seiten
Pages Left | Anzahl noch zu übertragender Seiten
Volumes | Anzahl der verwendeten Datenträger
Medianame | Name der Sicherungsvorlage
Location | Datei- oder Gerätename
Errortext | Text der Fehlermeldung Siehe auch: Dokumentation Strukturlink Meldungen
Label | Sicherungskennung
Is Consistent | nur für Datensicherung: Sicherung ist in sich konsistent
First LOG Page | bei Datensicherung: erste einzulesende Seite der Log-Sicherung bei Log-Sicherung: erste gesicherte Seite im Log
Last LOG Page | nur für Log-Sicherung: letzte gesicherte Seite im Log
DB Stamp 1 Date DB Stamp 1 Time | Zeitstempel der ersten Seite der Log-Sicherung
DB Stamp 2 Date DB Stamp 2 Time | Zeitstempel der letzten Seite der Log-Sicherung
Page Count | Gesamtzahl der gesicherten Seiten
Devices Used | Anzahl der verwendeten Sicherungsgeräte
Database ID | Datenbankkennung (zur Identifikation zueinandergehöriger Daten- und Log-Sicherungen)
Max Used Data Page | höchste vergebene Seitenzahl (Hinweis für minimale Datenbankgröße bei Einlesen der Sicherung)

Im Fehlerfall siehe Antwortformat.


recover_volume (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen recover_volume

Verwendung

Mit diesem DBM-Kommando nehmen Sie ein beschädigtes Volume eines Volume-Paares wieder in Betrieb.

Wenn Sie die Log-Volumes einer Datenbankinstanz gespiegelt betreiben und während des laufenden Datenbankbetriebs ein einzelnes Log-Volume ausfällt, dann haben Sie die Möglichkeit, die Funktion dieses ausgefallenen Volume wiederherzustellen.

Einträge, die nur auf das intakte Volume geschrieben wurden, während das beschädigte Volume außer Betrieb war, werden dabei nicht kopiert.

Die Sicherheit des gespiegelten Log-Volume ist erst wieder ab der Inbetriebnahme des wiederhergestellten Volume gegeben. Sichern Sie deshalb die nur einmal vorhandenen Log-Einträge mit Hilfe einer Log-Sicherung (Siehe: backup_start ).

Voraussetzungen

● Sie haben die Serverberechtigung Recovery.

● Sie betreiben die Datenbankinstanz mit gespiegelten Log-Volumes (LOG_MODE: DUAL).

● Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

Syntax

recover_volume <vol_name>

Optionen

<vol_name>

Name des Volume

Antwort

OK

Im Fehlerfall siehe Antwortformat.


scheduler_activate_job (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen scheduler_activate_job

Verwendung

Sie aktivieren einen Scheduler-Job.

Für das Aktivieren eines Jobs ist es irrelevant, welchen Betriebszustand die betreffende Datenbankinstanz hat und ob der Scheduler ein- oder ausgeschaltet ist.

Der aktivierte Job wird jedoch nur dann tatsächlich ausgeführt, wenn der Scheduler eingeschaltet ist und Sie die Serverberechtigung haben, das im Job definierte DBM-Kommando auszuführen (Siehe: scheduler_start)

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Voraussetzungen

● Der zu aktivierende Scheduler-Job wurde angelegt (siehe: scheduler_create_job).

● Sie haben die Serverberechtigung SchedulerMgm oder Sie sind Eigentümer des Jobs und haben die Serverberechtigung Scheduling.

Syntax

scheduler_activate_job <job_ID>

<job_ID>

Job-ID des zu aktivierenden Scheduler-Jobs

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer DBM mit dem Kennwort OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Aktivieren des Scheduler-Jobs mit der Job-ID 1:

>dbmcli -u OLEG,MONDAY -d DEMODB scheduler_activate_job 1

OK


scheduler_create_job (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen scheduler_create_job

Verwendung

In einem Scheduler-Job definieren Sie, welches DBM-Kommando wann und wie oft vom Database Manager in der aktuellen Datenbankinstanz ausgeführt werden soll.

Sie können festlegen, wie oft und zu welchem Zeitpunkt oder nach welchem anderen Job der neue Job eingeplant werden soll. Wenn Sie keine Angabe dazu machen, wie oft der neue Job eingeplant werden soll, dann wird er täglich für den definierten Zeitpunkt eingeplant oder immer, wenn der definierte vorangehende Job ausgeführt wurde.

Derjenige DBM-Benutzer, der einen Job anlegt, ist der Eigentümer dieses Jobs. Das System vergibt pro Datenbankinstanz für jeden angelegten Job eine laufende Nummer.

Für das Anlegen eines Jobs ist es irrelevant, welchen Betriebszustand die betreffende Datenbankinstanz hat und ob der Scheduler ein- oder ausgeschaltet ist.

Der neu angelegte Job ist aktiv, er wird jedoch nur dann tatsächlich ausgeführt, wenn der Scheduler eingeschaltet ist und Sie die Serverberechtigung haben, um das im Job definierte DBM-Kommando auszuführen (Siehe:scheduler_start)

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Voraussetzungen

Sie haben die Serverberechtigung SchedulerMgm oder Scheduling.

Syntax

scheduler_create_job <condition> <dbm_command> [-o | -once]

<condition> :: = <time> | <previous_job_ID>

Optionen

Option | Beschreibung
<dbm_command> | DBM-Kommando, das eingeplant werden soll Wenn es Leerzeichen enthält, dann muss das gesamte DBM-Kommando in doppelte Anführungszeichen gesetzt werden.
<time> | Zeitpunkt, zu dem es ausgeführt werden soll Zeitformat: <hh:mm:ss> (Stunden:Minuten:Sekunden)
<previous_job_ID> | Job-ID des vorhergehenden Jobs
-o | -once | Angabe, dass das DBM-Kommando nur einmalig ausgeführt werden soll Anschließend wird der Job gelöscht.

Antwort

OK

<job_ID>

<job_ID>

Vom System vergebene ID für den Scheduler-Job

Im Fehlerfall siehe Antwortformat.

Beispiele

Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB,

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>

● Anlegen eines Scheduler-Jobs für das Stoppen der Datenbankinstanz heute abend um 18:00 Uhr:

dbmcli on DEMODB>scheduler_create_job 18:00:00 db_offline -o

OK
0

● Anlegen eines zweiten Scheduler-Jobs für das Starten der Datenbankinstanz heute abend um 19:00 Uhr:

dbmcli on DEMODB>scheduler_create_job 19:00:00 db_online -o

OK
1

● Anlegen eines dritten Scheduler-Jobs für das Anzeigen des Betriebszustandes der Datenbankinstanz immer nach dem Starten der Datenbankinstanz, also immer nach Job 1:

dbmcli on DEMODB>scheduler_create_job 1 db_state

OK
2

● Anlegen eines vierten Scheduler-Jobs für das Anlegen eines DBM-Benutzers mit dem Benutzernamen ELENA, dem Kennwort SUNDAY und den Benutzereigenschaften wie der Benutzer OLEG. Dieser Job soll einmalig heute um 8:00 Uhr ausgeführt werden.

dbmcli on DEMODB>scheduler_create_job 08:00:00 "user_create ELENA,SUNDAY OLEG" -once

OK

3


scheduler_deactivate_job (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen scheduler_deactivate_job

Verwendung

Sie deaktivieren einen Scheduler-Job.

Er verbleibt anschließend in der Liste der angelegten Scheduler-Jobs, wird jedoch nicht mehr ausgeführt. Auch jene Scheduler-Jobs, die als Nachfolger eines deaktivierten Jobs definiert wurden, werden nicht mehr ausgeführt.

Für das Deaktivieren eines Jobs ist es irrelevant, welchen Betriebszustand die betreffende Datenbankinstanz hat und ob der Scheduler ein- oder ausgeschaltet ist.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Voraussetzungen

Sie haben die Serverberechtigung SchedulerMgm oder Sie sind Eigentümer des Jobs und haben die Serverberechtigung Scheduling.

Syntax

scheduler_deactivate_job <job_ID>

<job_ID>

Job-ID des zu deaktivierenden Scheduler-Jobs

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Deaktivieren des Scheduler-Jobs mit der Job-ID 1:

>dbmcli -u OLEG,MONDAY -d DEMODB scheduler_deactivate_job 1

OK


scheduler_delete_job (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen scheduler_delete_job

Verwendung

Sie verwenden dieses DBM-Kommando, um einen Scheduler-Job zu löschen. Sie können sowohl aktive als auch inaktive Jobs löschen. Zuvor müssen Sie jedoch sicherstellen, dass der zu löschende Job keine Nachfolger mehr hat. Andernfalls wird das DBM-Kommando mit einer Fehlermeldung abgebrochen.

Für das Löschen eines Jobs ist es irrelevant, welchen Betriebszustand die betreffende Datenbankinstanz hat und ob der Scheduler ein- oder ausgeschaltet ist.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Voraussetzungen

● Der zu löschende Job hat keine Nachfolger

● Sie haben die Serverberechtigung SchedulerMgm oder Sie sind Eigentümer des Jobs und haben die Serverberechtigung Scheduling.

Syntax

scheduler_delete_job <job_ID>

<job_ID>

Job-ID des zu löschenden Scheduler-Jobs

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Löschen des Scheduler-Jobs mit der Job-ID 1:

>dbmcli -u OLEG,MONDAY -d DEMODB scheduler_delete_job 1

OK


scheduler_list_jobs (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen scheduler_list_jobs

Verwendung

Sie verwenden dieses DBM-Kommando, um die Liste aller Scheduler-Jobs anzuzeigen. Zu jedem angelegten Job werden die Job-ID, Eigentümer, Status, Zeitpunkt, zu dem der Job ausgeführt werden soll, Zeitpunkt, zu dem er das letzte Mal ausgeführt wurde, und das auszuführende DBM-Kommando angezeigt.

DBM-Benutzer mit der Serverberechtigung SchedulerMgm sehen alle aktiven und inaktiven Jobs. DBM-Benutzer mit der Serverberechtigung Scheduling sehen nur jene aktiven und inaktiven Jobs, deren Eigentümer sie sind.

Wenn bei der Ausführung eines Jobs ein Fehler aufgetreten ist, finden Sie in der Protokolldatei dbm.prt nähere Informationen dazu. Suchen Sie nach dem entsprechenden Eintrag anhand der geplanten Uhrzeit, der Job-ID und der in der Liste aller Scheduler-Jobs ausgewiesenen DBM-Server-PID.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Voraussetzungen

Sie haben die Serverberechtigung SchedulerMgm oder Scheduling.

Syntax

scheduler_list_jobs

Anwort

OK

ID <job_ID>

owner: <dbm_user>

status: <job_status>

runs: at: <job_time>|after: <job_id> [(once)]>

last run: <date_run> <time_run>

DBM Server PID <process_ID>

return code <message_number>

dbm_command: <dbm_command>

ID <job_ID>

owner: <dbm_user>

status: <job_status>

runs: at: <job_time>|after: <job_id> [(once)]>

last run: <date_run> <time_run>

DBM Server PID <process_ID>

return code <message_number>

dbm_command: <dbm_command>

...

Werte für die Felder der Antwort

Wert | Beschreibung
<job_ID> | Job-ID
<job_status> | Job-Status, mögliche Werte sind: active: Der Job ist aktiv. inactive: Der Job ist inaktiv.
<job_time> | definierter Zeitpunkt zu dem der Job ausgeführt werden soll
(once) | einmalige Ausführung
<date_run> | Tag, an dem der Job zuletzt ausgeführt wurde
<time_run> | Zeitpunkt, zu dem der Job zuletzt ausgeführt wurde
<process_ID> | Prozess-ID
<message_number> | Meldungsnummer Siehe auch: Dokumentation Strukturlink Meldungen

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Liste aller aktiven und inaktiven Scheduler-Jobs:

>dbmcli -u OLEG,MONDAY -d DEMODB scheduler_list_jobs

OK

ID 0

owner: OLEG

status: active

runs: at 18:00:00

last run: 2005-05-02 18:00:02

DBM Server PID 2632

return code OK (0)

dbm_command: db_offline

ID 1

owner: OLEG

status: active

runs: at 19:00:00

last run: 2005-05-02 19:00:01

DBM Server PID 1652

return code ERR (-24977)

dbm_command: db_onnnline

ID 2

owner: OLEG

status: active

runs: after 1

dbm_command: db_state


scheduler_start (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen scheduler_start

Verwendung

Sie starten den Scheduler. Dies ist die Voraussetzung dafür, dass eingeplante DBM-Kommandos ausgeführt werden können.

Der Scheduler läuft solange, bis Sie ihn mit dem Kommando scheduler_stop wieder ausschalten.

Das Überführen der Datenbankinstanz in den Betriebszustand OFFLINE stoppt den Scheduler nicht.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Voraussetzungen

Sie haben die Serverberechtigung SchedulerMgm.

Syntax

scheduler_start

Antwort

OK

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Starten des Scheduler für diese Datenbankinstanz:

>dbmcli -u OLEG,MONDAY -d DEMODB scheduler_start

OK


scheduler_state (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen scheduler_state

Verwendung

Sie lassen sich anzeigen, ob die Scheduler-Funktion ein- oder ausgeschaltet ist.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Voraussetzungen

Sie haben die Serverberechtigung SchedulerMgm oder Scheduling.

Syntax

scheduler_state

Antwort

OK

<state>

<state>

Scheduler-Funktion, mögliche Werte sind

ON: Der Scheduler ist eingeschaltet, aktive Scheduler-Jobs werden ausgeführt.

OFF: Der Scheduler ist ausgeschaltet.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Scheduler-Funktion:

>dbmcli -u OLEG,MONDAY -d DEMODB scheduler_state

OK

ON


scheduler_stop (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen scheduler_stop

Verwendung

Sie stoppen den Scheduler. Nachdem der Scheduler gestoppt wurde, werden eingeplante DBM-Kommandos nicht mehr ausgeführt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Voraussetzungen

Sie haben die Serverberechtigung SchedulerMgm.

Syntax

scheduler_stop

Beispiel

Aufrufen des Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Stoppen des Scheduler für die Datenbankinstanz:

>dbmcli -u OLEG,MONDAY -d DEMODB scheduler_stop

OK


service_connect (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen service_connect

Verwendung

Sie starten den zur Version der Datenbanksoftware passenden Servicekern und eröffnen eine Datenbanksitzung.

Der Servicekern ist eine speziell konfigurierte Datenbankinstanz ohne eigenen Datenbestand. Mit ihm können aber Dienste für andere Datenbankinstanzen durchgeführt werden, wie z.B. das Prüfen einer Sicherung (Siehe: recover_check oder das Wiederherstellen der Parameterdatei aus einer Datensicherung (Siehe: recover_config).

Voraussetzungen

· Sie haben die Serverberechtigung Backup.

· Sie arbeiten im Skriptmodus oder Sitzungsmodus.

Syntax

service_connect

Antwort

OK

Im Fehlerfall siehe Antwortformat


service_release (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen service_release

Verwendung

Sie beenden die aktive Servicesitzung. Alle zugeordneten Ressourcen werden freigegeben.

Beim Beenden des Database Manager wird dieses DBM-Kommando implizit ausgeführt.

Voraussetzungen

· Sie haben die Serverberechtigung Backup.

· Sie haben eine Service-Sitzung gestartet (Siehe: service_connect).

Syntax

service_release

Antwort

OK

Im Fehlerfall siehe Antwortformat.


show (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen show

Verwendung

Sie lassen sich Informationen über die Datenbankinstanz zu Statistiken, dem Betriebszustand, Tasks usw. anzeigen. Dazu greift das DBM-Kommando auf das Programm XCONS zurück und liefert dessen Ausgaben.

Siehe auch:

Utilities, Anzeigen von Informationen zur Datenbankinstanz.

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

show <command>

<command>

auszuführendes XCONS-Kommando

Sie können alle XCONS-Kommandos verwenden, die mit dem Schlüsselwort show beginnen (Siehe: show_list).

Antwort

OK

[CONTINUE]

<info_record>

<info_record>

Werte für die Felder der Antwort

Wert | Beschreibung
Continue | Es liegen noch Ergebnisdaten bereit, Sie können diese mit dem DBM-Kommando show_next anzeigen.
<info_record> | Information

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen von Statistiken zum Zugriff auf die Volumes der Datenbankinstanz:

>dbmcli –u OLEG,MONDAY –d DEMODB show io

OK

SERVERDB: DEMODB

Volume Devs. Read(s) Write(s) Total

Name No. Count Count Count

knltrace 0 0 1 1

C:\Documents and Set...DEMODB\data\DISKD0001 1 54 59 113

C:\Documents and Set....DEMODB\log\DISKL0001 3 14 14 28

C:\Documents and Set....DEMODB\data\DISKD0003 4 1 9 10

total I/O: 69 83 152


show_list (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen show_list

Verwendung

Sie lassen sich die Liste aller Schlüsselwörter für Informationen zur Datenbankinstanz anzeigen.

Anschließend führen Sie mit dem entsprechenden Schlüsselwort das DBM-Kommando zum Anzeigen der gewünschten Information aus (Siehe: show).

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

show_list

Antwort

OK

<keyword>

<keyword>

...

<keyword>

Schlüsselwort für eine Information zur Datenbankinstanz


show_next (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen show_next

Verwendung

Sie lassen sich die weiteren Informationen zur Datenbankinstanz anzeigen.

Voraussetzungen

● Sie haben die Serverberechtigung DBInfoRead.

● Sie haben das DBM-Kommando zum Anzeigen von Informationen zur Datenbankinstanz ausgeführt (Siehe: show). Das Schlüsselwort CONTINUE in der Antwort zeigt, dass weitere Informationen vorliegen, die wegen der begrenzten Größe des Antwortpakets noch nicht angezeigt wurden.

Syntax

show_next

Antwort

OK

[CONTINUE | END]

<info_record>

<info_record>

...

Werte für die Felder der Antwort

Wert | Beschreibung
END | Der Inhalt der Datei wurde vollständig übertragen. Die Datei wird automatisch geschlossen.
Continue | Die Datei hat noch weitere Einträge, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden. Sie können diese durch erneutes Eingeben des DBM-Kommandos anzeigen.
<info_record> | Information


sql_connect (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_connect

Verwendung

Sie erzeugen für den angegebenen Datenbankbenutzer eine SQL-Sitzung mit der Datenbankinstanz.

Wenn Sie keinen Benutzer angeben, verwendet das System die Daten des ersten DBM-Benutzers. Deshalb können in diesem Fall anschließend nur Datenbankanweisungen ausgeführt werden, zu denen der erste DBM-Benutzer berechtigt ist.

Bei der Ausführung der meisten DBM-Kommandos, die eine SQL-Sitzung verlangen, wird diese implizit eröffnet und wieder geschlossen. Das explizite Eröffnen einer SQL-Sitzung ist in diesem Falle nicht erforderlich.

Die Verwendung des DBM-Kommandos zum Eröffnen einer SQL-Sitzung empfiehlt sich nur dann, wenn es sich um SQL-Anweisungen handelt, die nur von einem bestimmten Datenbankbenutzer ausgeführt werden können, oder aus Performancegründen, wenn Sie eine größere Anzahl von SQL-Anweisungen übermitteln wollen.

Eröffnen Sie in diesem Fall die SQL-Sitzung unter Angabe des gewünschten Datenbankbenutzers, führen Sie die gewünschten SQL-Anweisungen aus (Siehe: sql_execute) und schließen Sie die SQL-Sitzung anschließend wieder (Siehe: sql_release).

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink SQL

Voraussetzungen

● Sie haben die Serverberechtigung DBInfoRead oder AccessSQL.

● Sie arbeiten im Skriptmodus oder Sitzungsmodus.

Syntax

sql_connect <user_identification>

<user_identification> :: = <user_spec> | <user_type>

<user_spec> :: = <database_user_name>,<database_user_password>

<user_type> :: = user-type=<value>

Optionen

Option | Beschreibung
<database_user_name> | Name des Datenbankbenutzers
<database_user_password> | Kennwort des Datenbankbenutzers
user-type=<value> | Benutzertyp, mögliche Werte sind: DBM: DBM-Benutzer DBA: Datenbanksystemadministrator SAP: Datenbankbenutzer der SAP-Anwendung

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

...

1. Anmelden an den Database Manager CLI im Sitzungsmodus als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>

2. Eröffnen einer SQL-Sitzung für den Datenbankbenutzer MONA mit dem Kennwort RED:

dbmcli on DEMODB>sql_connect MONA,RED

OK


sql_execute (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_execute

Verwendung

Sie verwenden ein DBM-Kommando, um eine SQL-Anweisung an die Datenbankinstanz zu übermitteln.

Anders als bei Verwendung des DBM-Kommandos sql_executenicewollen Sie sich in der Antwort so viele Datensätze wie möglich anzeigen lassen. Die Menge der übertragenen Daten ist begrenzt durch die Größe des vom DBM-Server übertragenen Antwortpakets.

Wenn es sich um eine SELECT-Anweisung handelt, dann werden vom System die Datensätze der Antwort angezeigt. Wenn aufgrund der begrenzten Größe des Antwortpakets noch nicht alle Daten angezeigt werden können, dann verwenden Sie anschließend das DBM-Kommando sql_fetch, um ein weiteres Antwortpaket mit Datensätzen zu übertragen. Dies ist jedoch nur dann möglich, wenn Sie sich noch in derselben Datenbanksitzung befinden.

Wenn Sie andere SQL-Anweisungen eingeben, wird die Ausführung der Anweisung mit einer OK-Meldung bestätigt.

Bei der Ausführung dieses DBM-Kommandos wird implizit eine Sitzung mit der Datenbankinstanz eröffnet und nach Ausführung des Kommandos wieder beendet. Diese Datenbanksitzung wird im AUTOCOMMIT-Modus eröffnet, d. h. jede eingegebene SQL-Anweisung wird automatisch mit einer COMMIT-Anweisung abgeschlossen.

Wenn eine Folge von SQL-Anweisungen ausgeführt werden soll und diese nur von einem bestimmten Datenbankbenutzer ausgeführt werden können, dann empfiehlt es sich, zunächst eine SQL-Sitzung mit den Daten dieses Datenbankbenutzers zu eröffnen (Siehe: sql_connect), alle SQL-Anweisungen auszuführen und anschließend entweder die SQL-Sitzung (Siehe: sql_release) oder den Database Manager CLI zu beenden.

Weitere Informationen zu SQL-Anweisungen finden Sie in den Dokumentationen Strukturlink SQL-Referenzhandbuch und Strukturlink SQL-Tutorial.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Betriebsmodi im Database Manager CLI, Strukturlink Ausführen von Datenbankanweisungen

Konzepte des Datenbanksystems, Strukturlink SQL

Voraussetzungen

● Sie arbeiten im Sitzungsmodus des Database Manager CLI.

● Sie haben die Serverberechtigung AccessSQL.

Syntax

sql_execute [<user_type>] <statement>

<user_type> : = user-type=<value>

Optionen

Option | Beschreibung
<statement> | SQL-Anweisung
<dabase_user> | Name des Datenbankbenutzers
<database_user_password> | Kennwort des Datenbankbenutzers
user-type=<value> | Benutzertyp, mögliche Werte sind: DBM: erster DBM-Benutzer DBA: Datenbanksystemadministrator SAP: spezieller Datenbankbenutzer im Zusammenhang mit SAP-Anwendungen

Antwort

OK

[END|CONTINUE]

[<record>

<record>

...]

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Antwort wurde vollständig ausgegeben.
CONTINUE | Es liegen noch weitere Datensätze vor, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden.
<record> | Ergebnisdaten der SQL-Anweisung Die Felder in einem Datensatz sind durch Semikolon voneinander getrennt. Die Ausgabe von Zeichenketten erfolgt in einfachen Anführungszeichen.

Im Fehlerfall siehe Antwortformat.

Beispiel

...

Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Spalten der Tabelle USERS mit den dazugehörigen Kommentaren:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>sql_execute SELECT columnname, comment FROM domain.columns WHERE tablename = 'USERS'

OK

END

'OWNER';(long)

'GROUPNAME';(long)

'USERNAME';(long)

'USERMODE';(long)

'CONNECTMODE';(long)

'MAXTIMEOUT';(long)

'COSTWARNING';(long)

'COSTLIMIT';(long)

'DEFAULTCODE';(long)

'CREATEDATE';(long)

'CREATETIME';(long)

'ALTERDATE';(long)

'ALTERTIME';(long)

'PWCREADATE';(long)

'PWCREATIME';(long)

'SERVERDB';(long)

'SERVERNODE';(long)

'USER_ID';(long)

'ISREPLICATIONUSER';(long)

'COMMENT';(long)


sql_executenice (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_executenice

Verwendung

Sie übermitteln eine SQL-Anweisung an die Datenbankinstanz.

Anders als bei Verwendung des DBM-Kommandos sql_execute wollen Sie sich in der Antwort einen Datensatz nach dem anderen anzeigen lassen.

Bei der Ausführung dieses DBM-Kommandos wird implizit eine Sitzung mit der Datenbankinstanz eröffnet und nach Ausführung des Kommandos wieder beendet. Diese Datenbanksitzung wird im AUTOCOMMIT-Modus eröffnet, d. h. jede eingegebene SQL-Anweisung wird automatisch mit einer COMMIT-Anweisung abgeschlossen.

Nach dem Ausführen der SQL-Anweisung erhalten Sie eine OK-Meldung oder den ersten Datensatz der Antwort angezeigt. Für das Anzeigen jedes weiteren Datensatzes verwenden Sie das DBM-Kommando sql_fetchnice.

Weitere Informationen zu SQL-Anweisungen finden Sie in den Dokumentationen Strukturlink SQL-Referenzhandbuch und Strukturlink SQL-Tutorial.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Betriebsmodi im Database Manager CLI, Strukturlink Folge von Datenbankanweisungen ausführen

Konzepte des Datenbanksystems, Strukturlink SQL

Voraussetzungen

● Sie arbeiten im Sitzungsmodus des Database Manager CLI.

● Sie haben die Serverberechtigung AccessSQL.

Syntax

sql_executenice <statement>

<statement>

SQL-Anweisung

Antwort

OK

[END | CONTINUE]

[<record>]

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Antwort wurde vollständig ausgegeben.
CONTINUE | Es liegen noch weitere Datensätze vor, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden.
<record> | Ein Datensatz des Ergebnisses der SQL-Anweisung Die Felder in einem Datensatz sind durch Semikolon voneinander getrennt. Die Ausgabe von Zeichenketten erfolgt in einfachen Anführungszeichen.

Beispiel

Aufrufen des Database Manager CLI im Sitzungsmodus, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, datensatzweises Anzeigen der Spalten der Tabelle USERS mit den dazugehörigen Kommentaren:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>sql_executenice SELECT columnname, comment FROM domain.columns WHERE tablename = 'USERS'

OK

CONTINUE

COLUMNNAME = 'OWNER'

COMMENT = (long)

---

dbmcli on demodb>sql_fetchnice

OK

CONTINUE

COLUMNNAME = 'GROUPNAME'

COMMENT = (long)

---

dbmcli on demodb>sql_fetchnice

...

...


sql_fetch (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_fetch

Verwendung

Sie verwenden dieses DBM-Kommando nachdem Sie sql_execute ausgeführt haben und lassen sich damit innerhalb derselben Datenbanksitzung die weiteren Ergebnisdaten anzeigen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Folge von Datenbankanweisungen ausführen

Voraussetzungen

● Sie haben die Serverberechtigung AccessSQL.

● Sie haben eine SQL-Anweisung ausgeführt (Siehe: sql_execute). Das Schlüsselwort CONTINUE in der Antwort zeigt, dass die Ergebnisdaten noch nicht vollständig angezeigt wurden.

Syntax

sql_fetch

Antwort

OK

[END|CONTINUE]

[<record>

<record>

...]

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Antwort wurde vollständig übertragen.
CONTINUE | Es liegen noch weitere Datensätze vor, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden.
<record> | Ergebnisdaten der SQL-Anweisung Die Felder in einem Datensatz sind durch Semikolon voneinander getrennt. Die Ausgabe von Zeichenketten erfolgt in einfachen Anführungszeichen.


sql_fetchnice (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_fetchnice

Verwendung

Sie verwenden dieses DBM-Kommando nachdem Sie sql_executenice ausgeführt haben und lassen sich damit innerhalb derselben Datenbanksitzung den jeweils nächsten Datensatz des Ergebnisses anzeigen.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink Folge von Datenbankanweisungen ausführen

Voraussetzungen

● Sie haben die Serverberechtigung AccessSQL.

● Sie haben eine SQL-Anweisung ausgeführt (Siehe: sql_executenice). Das Schlüsselwort CONTINUE in der Antwort zeigt an, dass die Daten noch nicht vollständig ausgegeben wurden.

Syntax

sql_fetchnice

Antwort

OK

[END | CONTINUE]

[<column>=<value>]

[<column>=<value>]

[...]

Werte für die Felder der Antwort

Wert | Beschreibung
END | Die Antwort wurde vollständig übertragen.
CONTINUE | Es liegen noch weitere Datensätze vor, die aufgrund der begrenzten Größe des Antwortpakets nicht übertragen wurden.
<column> | Spaltenname
<value> | Spaltenwert

Beispiel

Anmelden an den Database Manager CLI im Sitzungsmodus als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Datensatzweises Anzeigen der Spalten der Tabelle USERS mit den dazugehörigen Kommentaren:

>dbmcli -u OLEG,MONDAY -d DEMODB

dbmcli on DEMODB>sql_executenice SELECT columnname, comment FROM domain.columns WHERE tablename = 'USERS'

OK

CONTINUE

COLUMNNAME = 'OWNER'

COMMENT = (long)

---

dbmcli on demodb>sql_fetchnice

OK

CONTINUE

COLUMNNAME = 'GROUPNAME'

COMMENT = (long)

---

dbmcli on demodb>sql_fetchnice

...

...


sql_info (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_info

Verwendung

Sie lassen sich die Struktur der Ergebnismenge einer SQL-Anweisung anzeigen.

Sie erhalten die Namen aller Spalten angezeigt. Diese sind durch Semikolon voneinander getrennt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink SQL

Voraussetzungen

Sie haben die Serverberechtigung AccessSQL.

Syntax

sql_info <statement>

<statement>

SQL-Anweisung

Antwort

OK

<col_name>;<col_name>;...;<col_name>

<col_name>

Spaltenname

Beispiel

Anmelden an den Database Manager CLI als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Struktur der Ergebnismenge für die SELECT-Anweisung zum Anzeigen des Inhalts der Tabelle users:

>dbmcli -u OLEG,MONDAY - d DEMODB sql_info SELECT * FROM users

OK

OWNER;GROUPNAME;USERNAME;USERMODE;CONNECTMODE;MAXTIMEOUT;COSTWARNING;
COSTLIMIT;DEFAULTCODE;CREATEDATE;CREATETIME;ALTERDATE;ALTERTIME;PWCREADATE;PWCREATIME;SERVERDB;SERVERNODE;USER_ID;ISREPLICATIONUSER;COMMENT


sql_recreateindex (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_recreateindex

Verwendung

Sie stellen die als Indizes des Datenbanksystems wieder her.

Voraussetzungen

· Sie haben die Serverberechtigung AccessSQL.

· Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

Syntax

sql_recreateindex [<index_specification>]

<index_specification> :: = <schema>.<table>.<index>

Optionen

Option | Beschreibung
<index_specification> | Indexspezifikation <schema>: Schema <table>: Tabellenname <index>: Indexname oder Feldname Vorschlagswert sind alle Indizes, die als "bad" markiert sind.

Antwort

OK

Im Fehlerfall siehe Antwortformat.


sql_release (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_release

Verwendung

Sie beenden eine SQL-Sitzung. Alle dieser Sitzung zugeordneten Ressourcen werden freigegeben.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink SQL

Voraussetzungen

Sie haben die Serverberechtigung AccessSQL oder DBInfoRead.

Syntax

sql_release

Antwort

OK


sql_updatestat (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_updatestat

Verwendung

Sie aktualisieren die Statistiken des SQL-Optimierers.

Sie können alle Statistiken aktualisieren oder die Menge der zu aktualisierenden Statistiken über eine Tabellen- oder Spaltenspezifikation einschränken.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink SQL-Optimierer

Voraussetzungen

● Sie haben die Serverberechtigung AccessSQL.

● Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

Syntax

sql_updatestat [<table_or_column_spec>]

<table_or_column_spec>

Tabellen- oder Spaltenspezifikation,

für mögliche Argumente und Schlüsselwörter siehe: SQL-Referenzhandbuch, Strukturlink UPDATE STATISTICS-Anweisung (update_statistics_statement)

Antwort

OK

Im Fehlerfall siehe Antwortformat.


sql_updatestat_per_systemtable (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen sql_updatestat_per_systemtable

Verwendung

Sie aktualisieren die Optimiererstatistiken jener Tabellen, für die das System die Notwendigkeit festgestellt und einen Eintrag in die Systemtabelle SYSUPDSTATWANTED vorgenommen hat.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink SQL-Optimierer

Voraussetzungen

· Sie haben die Serverberechtigung AccessSQL.

· Sie haben eine Datenbanksitzung eröffnet (Siehe: db_connect).

Syntax

sql_updatestat_per_systemtable

Antwort

OK

Im Fehlerfall siehe Antwortformat.


trace_clear (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen trace_clear

Verwendung

Sie löschen den aktuellen Inhalt des Datenbank-Trace.

Sie verwenden dieses DBM-Kommando, um nicht mehr benötigte Daten aus dem Datenbank-Trace zu löschen. Es empfiehlt sich, dieses DBM-Kommando auszuführen, bevor Sie durch das Einschalten des Datenbank-Trace gezielt Aktivitäten der Datenbankinstanz protokollieren (Siehe: trace_on).

Siehe auch:

Glossar, Strukturlink Datenbank-Trace

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead oder DBFileRead.

Syntax

trace_clear

Antwort

OK

Im Fehlerfall siehe Antwortformat.


trace_flush (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen trace_flush

Verwendung

Sie schreiben den Inhalt des aktuellen Datenbank-Trace als Binärdatei unter dem Dateinamen knltrace in das Arbeitsverzeichnis der Datenbankinstanz.

Um den Inhalt der Datei auswerten zu können, müssen Sie sie anschließend in eine Klartextdatei konvertieren (Siehe: trace_prot) und mit Hilfe des DBM-Kommandos file_getfirst öffnen.

Siehe auch:

Glossar, Strukturlink Datenbank-Trace

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead oder DBFileRead.

Syntax

trace_flush

Antwort

OK

Im Fehlerfall siehe Antwortformat.


trace_off (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen trace_off

Verwendung

Sie legen fest, welche Aktivitäten der Datenbankinstanz nicht mehr protokolliert werden sollen oder schalten den Datenbank-Trace insgesamt aus.

Durch die Angabe einer Kommandooption definieren Sie, welche Aktivitäten nicht mehr protokolliert werden sollen.

Siehe auch:

Glossar, Strukturlink Datenbank-Trace

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead oder DBFileRead.

Syntax

trace_off <command_option>

<command_option> :: = <activity_list> | ALL

<activity_list> :: = <activity> | <activity> <activity> ...

Optionen

Option | Beschreibung
ALL | es werden keine Aktivitäten der Datenbankinstanz mehr protokolliert, der Datenbank-Trace wird insgesamt ausgeschaltet
<activity> | Aktivität, deren Protokollierung ausgeschaltet werden soll Für das Anzeigen der aktuell protokollierten Aktivitäten und der entsprechenden Kommandooptionen siehe: trace_show.

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ausschalten des Datenbank-Trace für die Bereiche CHECK_IOMAN und CHECK_LOGPAGE:

>dbmcli -u OLEG,MONDAY –d DEMODB trace_off CHECK_IOMAN CHECK_LOGPAGE

OK


trace_on (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen trace_on

Verwendung

Sie schalten den Datenbank-Trace ein und protokollieren Aktivitäten des Datenbankkerns.

Durch die Angabe einer Kommandooption definieren Sie, welche Aktivitäten protokolliert werden sollen. Einige Aktivitäten erlauben die Angabe eines Protokollierungslevels. Wenn Sie Ihre Analyse beendet haben, schalten Sie den Datenbank-Trace wieder aus.

Um die Ergebnisse der Trace-Funktion auswerten zu können, erstellen Sie zunächst eine Binärdatei des Datenbank-Trace (Siehe: trace_flush) und konvertieren diese in eine Klartextdatei (Siehe: trace_prot). Die Datei-ID der Klartextdatei des Datenbank-Trace ist KNLTRC. Sie öffnen diese Klartextdatei mit Hilfe des DBM-Kommando file_getfirst.

Das Einschalten des Datenbank-Trace wirkt sich bei liveCache-Datenbankinstanzen negativ auf die Performance aus, bei MaxDB-Datenbankinstanzen ist dies nicht der Fall.

Siehe auch:

Glossar, Strukturlink Datenbank-Trace

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead oder DBFileRead.

Syntax

trace_on <command_option>

<command_option> :: = <activity_list> | ALL [<level>]

<activity_list> :: = <activity> <activity> ...

<activity> :: = <activity_name> [<level>]

Optionen

Option | Beschreibung
ALL | Es werden alle Aktivitäten der Datenbankinstanz protokolliert
<activity> | Aktivität, deren Protokollierung eingeschaltet werden soll
<level> | Protokollierungslevel, kann für einige Aktivitäten angegeben werden, mögliche Werte sind 1 bis 9, Vorschlagswert ist 5 Für das Anzeigen der protokollierbaren Aktivitäten und der entsprechenden Kommandooptionen siehe: trace_show.

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Einschalten des Datenbank-Trace für die Bereiche CHECK_IOMAN und CHECK_LOGPAGE:

>dbmcli -u OLEG,MONDAY –d DEMODB trace_on CHECK_IOMAN CHECK_LOGPAGE

OK


trace_prot (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen trace_prot

Verwendung

Sie überführen die Binärdatei des Datenbank-Trace in eine Klartextdatei. Mit Hilfe von Kommandooptionen können Sie die Art und Weise der Konvertierung definieren.

Die Binärdatei des Datenbank-Trace ist unter dem Dateinamen knltrace im Arbeitsverzeichnis der Datenbankinstanz abgelegt. Die erzeugte Klartextdatei hat die Datei-ID KNLTRCPROT.

Siehe auch:

Glossar, Strukturlink Datenbank-Trace

Voraussetzungen

● Sie haben die Serverberechtigung DBInfoRead oder DBFileRead.

● Sie haben den Datenbank-Trace erzeugt (Siehe: trace_on).

● Sie haben die Binärdatei des Datenbank-Trace erzeugt (Siehe: trace_flush).

Syntax

trace_prot <option> | <option_list>

<option_list> :: = <option><option>...

<option>

Kommandoption, steuert Art und Weise der Konvertierung

Für das Anzeigen der möglichen Kommandooptionen siehe: trace_protopt.

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Erstellen der Textversion des Datenbank-Trace für die Bereiche a (Order Interface) und b ( Record Interface):

>dbmcli -u OLEG;MONDAY -d DEMODB trace_prot ab

OK


trace_protopt (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen trace_protopt

Verwendung

Sie lassen sich anzeigen, welche Kommandooptionen zulässig sind, um die Trace-Ausgaben der datenbankinternen Komponenten beim Erstellen der Textversion des Datenbank-Trace einzuschränken (Siehe: trace_prot).

Sie erhalten eine Liste mit Namen und Beschreibung dieser Kommandooptionen.

Siehe auch:

Glossar, Strukturlink Datenbank-Trace

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead oder DBFileRead.

Syntax

trace_protopt

Antwort

OK

name,option

<name>,<option>

<name>,<option>

...

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der möglichen Optionen für die Texterstellung des Datenbank-Trace:

>dbmcli -d DB -u dbm,dbm trace_protopt

OK
name,option
a Order Interface (AK)
b Record Interface (BD)
k Show Message Block (KB)
m Message Block
e No Entrypos Output
s Strategy
t Time
x Switch Output (Slow Kernel)

Werte für die Felder der Antwort

Wert | Beschreibung
a | Die Trace-Ausgaben der datenbankinternen Komponente Auftragsschnittstelle werden in die Textdatei übertragen.
b | Die Trace-Ausgaben der datenbankinternen Komponente Datensatz-Schnittstelle werden in die Textdatei übertragen.
k | Die Trace-Ausgaben der datenbankinternen Komponente Tabellen-Schnittstelle werden in die Textdatei übertragen.
m | Die Nachrichtenpuffer genannte interne Datenstruktur wird in die Textdatei übertragen.
e | Für die Auftragsschnittstelle und den Nachrichtenpuffer werden die Nummer der Trace-Seite und die Position des Puffers innerhalb der Seite in die Textdatei übertragen.
s | Informationen über die Abarbeitungsstrategie werden in die Textdatei übertragen.
t | Die Ergebnisse interner Zeitmessungen werden in die Textdatei übertragen.
x | Zusätzliche Trace-Ausgaben werden in die Textdatei übertragen.


trace_show (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen trace_show

Verwendung

Sie lassen sich anzeigen, welche Aktivitäten der Datenbankinstanz zur Zeit mit Hilfe des Datenbank-Trace protokolliert werden.

Siehe auch:

Glossar, Strukturlink Datenbank-Trace

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead oder DBFileRead.

Syntax

trace_show [verbose]

verbose

erweiterte Beschreibung zu den mit Hilfe des Datenbank-Trace protokollierbaren Aktivitäten des Datenbankkerns

Antwort

OK

<name> <state> <level> <short description>[,<long description>]

<value> <value> <value> <value>

...

...

Werte für die Felder der Antwort

Wert | Beschreibung
<name> | Name der Aktivität
<state> | Zustand der Protokollierungsfunktion, mögliche Werte sind ON | OFF ON: Aktivität wird protokolliert OFF: Aktivität wird nicht protokolliert
<level> | Protokollierungslevel, kann für einige Aktivitäten angegeben werden, mögliche Werte sind 1 bis 9, Vorschlagswert ist 5
<short_description> | Kurzbeschreibung der Aktivität
<long_description> | erweiterte Beschreibung der Aktivität
<value> | Wert

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der aktuell protokollierten Aktivitäten des Datenbankkerns mit der erweiterten Beschreibung:

>dbmcli -u OLEG,MONDAY -d DEMODB trace_show verbose

OK

Name State Level Description

TRACE_AK OFF - Defines whether tracing

of all order packets is switched on (YES/NO)

TRACE_DEFAULT OFF - Defines whether default

tracing is switched on (YES/NO)

TRACE_DELETE OFF - Defines whether tracing

of complete message buffer of DELETE is switched on (YES/NO)

TRACE_INDEX OFF - Defines whether tracing

...

...


user_create (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_create

Verwendung

Unmittelbar nach dem Anlegen einer Datenbankinstanz gibt es nur einen DBM-Benutzer (den ersten DBM-Benutzer) und den Datenbanksystemadministrator. Wenn Sie für diese Datenbankinstanz weitere DBM-Benutzer anlegen wollen, verwenden Sie zunächst das nachfolgend beschriebene DBM-Kommando zum Anlegen des Benutzers. Sie definieren damit den Benutzernamen und das Kennwort. Der so angelegte neue Benutzer hat jedoch noch keine Serverberechtigungen. Sie müssen ihm diese explizit zuweisen (siehe: user_put).

Alternativ dazu können Sie beim Anlegen des Benutzers auch einen vorhandenen DBM-Benutzer angeben, von dem dann alle DBM-Benutzereigenschaften mit Ausnahme von Name und Kennwort kopiert werden.

Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter. Das Datenbanksystem wandelt Benutzernamen und Kennwörter automatisch in Großbuchstaben um.

Siehe auch:

Tutorial Datenbankverwaltung, Strukturlink DBM-Benutzer anlegen

Konzepte des Datenbanksystems, Strukturlink Database Manager-Benutzer (DBM-Benutzer)

Voraussetzungen

Sie haben die Serverberechtigung UserMgm.

Syntax

user_create <dbm_operator>,<dbm_operator_password> [<template_user>]

Optionen

Option | Beschreibung
<dbm_operator> | Name des anzulegenden DBM-Benutzers
<dbm_operator_password> | Kennwort des anzulegenden DBM-Benutzers
<template_user> | DBM-Benutzer, dessen Benutzereigenschaften übernommen werden sollen

Antwort

OK

Im Fehlerfall siehe Antwortformat

Beispiel

Aufrufen des Database Manager CLI, Anmelden als DBM-Benutzer mit dem Namen OLEG und dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anlegen des DBM-Benutzers ELENA mit dem Kennwort SUNDAY und den Berechtigungen des DBM-Benutzers OLEG:

>dbmcli –u OLEG,MONDAY –d DEMODB user_create ELENA,SUNDAY OLEG

OK


user_delete (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_delete

Verwendung

Sie löschen den angegebenen DBM-Benutzer.

Der aktuell angemeldete DBM-Benutzer und der DBM-Benutzer, der beim Anlegen der Datenbankinstanz definierte erste DBM-Benutzer und der Datenbanksystemadministrator können nicht gelöscht werden.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Benutzer, Authentifizierung und Berechtigungen

Voraussetzungen

Sie haben die Serverberechtigung UserMgm.

Syntax

user_delete <dbm_operator>

<dbm_operator>

Name des zu löschenden DBM-Benutzers

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Löschen des für diese Datenbankinstanz angelegten DBM-Benutzers ELENA:

>dbmcli -u OLEG,MONDAY -d DEMODB user_delete ELENA

OK


user_get (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_get

Verwendung

Sie lassen sich die DBM-Benutzereigenschaften und Serverberechtigungen des angegebenen DBM-Benutzers oder Datenbanksystemadministrators anzeigen.

Der Database Manager gibt unter anderem eine Liste der dem Benutzer zugeordneten Serverberechtigungen aus.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Benutzer, Authentifizierung und Berechtigungen

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

user_get <dbm_operator>

<dbm_operator>

Name des DBM-Benutzers oder des Datenbanksystemadministrators

Antwort

OK

SERVERRIGHTS=<right_list>

SECONDPASSWORD=[YES|NO]

DISABLED=[YES|NO]

COMMENT=<comment>

USERTYPE=[DBM|DBA]

Werte für die Felder der Antwort

Wert | Beschreibung
SERVERRIGHTS | alle Serverberechtigungen des DBM-Benutzers, durch Kommas voneinander getrennt
SECONDPASSWORD | Angabe, ob ein zweites Kennwort für den DBM-Benutzer aktiviert wurde, mögliche Werte sind: YES | NO
DISABLED | Angabe, ob der DBM-Benutzer gesperrt ist, mögliche Werte sind: YES | NO
COMMENT | Beschreibung
USERTYPE | Benutzertyp, mögliche Werte sind: DBA: Datenbanksystemadministrator DBM: DBM-Benutzer

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen der Serverberechtigungen und DBM-Benutzereigenschaften des Database Manager-Benutzers mit dem Namen ELENA

>dbmcli -u OLEG,MONDAY -d DEMODB user_get ELENA

OK

SERVERRIGHTS=DBInfoRead,ExecLoad,SystemCmd,UserMgm,DBFileRead,Backup,...

SECONDPASSWORD=NO

DISABLED=NO

COMMENT=

USERTYPE=DBM


user_getall (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_getall

Verwendung

Sie lassen sich die Namen aller DBM-Benutzer, einschließlich des Datenbanksystemadministrators anzeigen, die für die aktuelle Datenbankinstanz angelegt wurden.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Benutzer, Authentifizierung und Berechtigungen

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

user_getall

Antwort

OK

<dbm_operator_1>

<sysdba_user>

<dbm_operator_2>

...

Im Fehlerfall siehe Antwortformat

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Database Manager-Benutzer mit dem Namen OLEG und dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Anzeigen aller DBM-Benutzer der Datenbankinstanz:

>dbmcli -u OLEG,MONDAY -d DEMODB user_getall

OK

DBM

DBADMIN

oleg

elena


user_getrights (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_getrights

Verwendung

Sie lassen sich die Liste der Serverberechtigungen des angegebenen DBM-Benutzers anzeigen.

Siehe auch:

Serverberechtigungen

Konzepte des Datenbanksystems, Strukturlink Database Manager-Benutzer (DBM-Benutzer)

Voraussetzungen

Sie haben die Serverberechtigung DBInfoRead.

Syntax

user_getrights <dbm_operator> SERVERRIGHTS

<dbm_operator>

Name des DBM-Benutzers

Antwort

OK

UserMgm                 <flag>  User management

InstallMgm              <flag>  Install management

SystemCmd               <flag>  System commands

FileFull                <flag>  File full access

FileRead                <flag>  File read access

DBFileRead              <flag>  Database file read access

AccessUtility           <flag>  Utility session access

BackupRestore           <flag>  Backup restore actions

BackupSave              <flag>  Backup save actions

ParamFull               <flag>  Parameter full access

ParamCheckWrite         <flag>  Parameter check-write access

ParamRead               <flag>  Parameter read access

AccessSQL               <flag>  SQL session access

ExecLoad                <flag>  Can execute load

LoadSysTab              <flag>  Can load system tables

DBStop                  <flag>  Can stop database

DBStart                 <flag>  Can start database

DBInfoRead              <flag>  Info functions access

Werte für die Felder der Antwort

Wert | Beschreibung
<flag> | Angabe, ob der DBM-Benutzer die betreffende Serverberechtigung hat, mögliche Werte sind: +: Der Benutzer hat diese Serverberechtigung -: Der Benutzer hat diese Serverberechtigung nicht.

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Aufbau der Verbindung zur Datenbankinstanz DEMODB und Anzeigen der Serverberechtigungen des für diese Datenbankinstanz angelegten DBM-Benutzers mit dem NamenELENA:

>dbmcli -u OLEG,MONDAY -d DEMODB user_getrights ELENA SERVERRIGHTS

OK

DBInfoRead + Request status data

SystemCmd + Execute operating system commands

ExecLoad + Execute the LOAD program

UserMgm + User management

DBFileRead + Database file access (read only)

Backup + Saving backups

InstallMgm + Installation management

LoadSysTab + Load the system tables

ParamCheckWrite + Parameter access (checked write)

ParamFull + Parameter access (read and write)

ParamRead + Parameter access (read only)

DBStart + Start database instance

DBStop + Stop database instance

Recovery + Restoring backups

AccessSQL + Access to SQL session

AccessUtility + Access to utility session

SharedMemoryMgm + Shared memory management

SchedulerMgm + Scheduler management

Scheduling + Scheduler use

EvtDispMgm + Event Dispatcher management

EvtDisp + Event Dispatcher use


user_logon (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_logon

Verwendung

Der angegebene DBM-Benutzer meldet sich an das Programm Database Manager an.

Die Anmeldung an den Database Manager erfordert eine Sitzung mit dem DBM-Server der zu verwaltenden Datenbankinstanz. Sie können diese Sitzung eröffnen und sich gleichzeitig anmelden (einstufige Anmeldung) oder zunächst nur die Sitzung eröffnen und sich in einem zweiten Schritt an den Database Manager anmelden (zweistufige Anmeldung).

Die Verbindung muss immer zum DBM-Server auf dem Rechner der zu verwaltenden Datenbankinstanz hergestellt werden. Wenn sich die Datenbankinstanz auf einem entfernten Rechner befindet, müssen Sie deshalb bei der Anmeldung an den Database Manager zusätzlich den Namen des Datenbankrechners angeben.

Siehe auch:

Serverberechtigungen

Konzepte des Datenbanksystems, Strukturlink Database Manager-Benutzer (DBM-Benutzer)

Zweistufige Anmeldung

Sie können zunächst die Sitzung mit dem DBM-Server eröffnen und sich in einem zweiten Schritt an den Database Manager anmelden.

...

1. Eröffnen einer DBM-Server-Sitzung:

>dbmcli –d <database_name> [-n <database_computer>]

dbmcli on DEMODB>

2. Anmelden an den Database Manager:

dbmcli on DEMODB>user_logon <dbm_operator>,<dbm_operator_password>

OK

dbmcli on DEMODB>

Einstufige Anmeldung

Mit Hilfe der DBM-Option –u | -U können Sie auch beide Schritte der Anmeldung gleichzeitig ausführen. Dabei führt der Database Manager implizit das DBM-Kommando user_logon aus.

Beachten Sie die verschiedene Bedeutung der Option bei Groß- und Kleinschreibung.

Verwendung der DBM-Option -u

>dbmcli -u [<dbm_operator>,<dbm_operator_password>] –d <database_name> [-n <database_computer>]

· -u: explizite Angabe des mit <dbm_user_name> und <dbm_user_password> ausgewiesenen Database Manager-Benutzers

Verwendung der DBM-Option –U (Anmeldung mit XUSER)

>dbmcli -U [<user_key>] –d <database_name> [-n <database_computer>]

· -U: Anmeldung mit einem in der XUSER-Datei hinterlegten Benutzer

Mit Hilfe des Programms XUSER können Sie Sets von Benutzerangaben als Benutzerschlüssel speichern und diese zur Anmeldung verwenden. Benutzerschlüssel für Database Manager-Benutzer können jedoch nur dann erfolgreich verwendet werden, wenn die darin gespeicherten Benutzer für die entsprechende Datenbankinstanz auch tatsächlich angelegt wurden (Siehe: user_create).

Wenn Sie bei –U keinen <user_key> angeben, versucht der Database Manager die Daten unter dem Benutzerschlüssel DBMUSR zu verwenden. Es empfiehlt sich deshalb, einen XUSER-Eintrag mit dem Benutzerschlüssel DBMUSR und den Daten des Database Manager-Benutzers mit den umfassendsten Berechtigungen anzulegen (Siehe: Anlegen oder Ändern von XUSER-Einträgen).

Antwort

dbmcli on [<database_computer>] : <database_name>

Im Fehlerfall siehe Antwortformat

Beispiele

Zweistufige Anmeldung

...

1. Aufrufen des Database Manager im Sitzungsmodus und Herstellen der Verbindung mit der lokalen Datenbankinstanz DEMODB:

>dbmcli -d DEMODB

dbmcli on DEMODB>

2. Anmelden als Benutzer OLEG mit dem Kennwort MONDAY:

dbmcli on DEMODB>user_logon OLEG,MONDAY

OK

dbmcli on DEMODB>

oder:

...

1. Aufrufen des Database Manager im Sitzungsmodus und Herstellen der Verbindung mit der Datenbankinstanz MAXDB auf dem entfernten Rechner GENUA:

>dbmcli -d MAXDB – n GENUA

dbmcli on GENUA : MAXDB>

2. Anmelden als Benutzer OLEG mit dem Kennwort MONDAY:

dbmcli on GENUA : MAXDB>user_logon OLEG,MONDAY

OK

dbmcli on GENUA : MAXDB>

Einstufige Anmeldung mit Benutzerschlüssel und Ausführen eines DBM-Kommandos

Aufrufen des Database Manager CLI, Anmelden als Benutzer unter dem Benutzerschlüssel OLKEY, Herstellen der Verbindung zur lokalen Datenbankinstanz DEMODB, Anzeigen des Betriebszustandes der Datenbankinstanz:

>dbmcli –U OLKEY –d DEMODB db_state

OK

State

OFFLINE

Einstufige Anmeldung mit Name und Kennwort eines DBM-Benutzers und Ausführen eines DBM-Kommandos

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur lokalen Datenbankinstanz DEMODB, Anzeigen des Betriebszustandes der Datenbankinstanz:

>dbmcli –u OLEG,MONDAY –d DEMODB db_state

OK

State

OFFLINE


user_put (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_put

Verwendung

Sie können die DBM-Benutzereigenschaften und die Serverberechtigungen von DBM-Benutzern und des Datenbanksystemadministrators ändern.

Beachten Sie die Strukturlink Konventionen für Benutzernamen und Kennwörter.
Das Datenbanksystem wandelt Kennwörter von DBM-Benutzern automatisch in Großbuchstaben um.

Siehe auch:

Serverberechtigungen

Tutorial Datenbankverwaltung, Strukturlink DBM-Benutzer anlegen

Konzepte des Datenbanksystems, Strukturlink Database Manager-Benutzer (DBM-Benutzer), Strukturlink Datenbankbenutzer

Voraussetzungen

● Sie haben die Serverberechtigung UserMgm.

● Wenn Sie das Kennwort des Datenbanksystemadministrators ändern wollen, muss sich die Datenbankinstanz im Betriebszustand ONLINE befinden.

Syntax

user_put <dbm_operator> <property_definition>

<property_definition> :: = <property_spec> | <property_spec_list>

<property_spec> :: = <property>=<value>

<property_spec_list> :: = <property>=<value_list>

<value_list> :: = <property>=<value,value,...>

Optionen

Option

Beschreibung

<dbm_operator>

Name eines Database Manager-Benutzers oder des Datenbanksystemadministrators, dessen Eigenschaften geändert werden sollen

<property>

Eigenschaft des Benutzers, folgende Werte sind möglich:

PASSWORD: Benutzerkennwort

COMMENT: Beschreibung

SECONDPASSWORD: zweites Benutzerkennwort

DISABLED: Sperren des Benutzers

SERVERRIGHTS: Serverberechtigung,

<value>

Wert der zugewiesenen Eigenschaft,

mögliche Werte für die DBM-Benutzereigenschaften PASSWORD, COMMENT und SECONDPASSWORD: Werte sind frei wählbar

mögliche Werte für DISABLED: YES | NO
YES: der Benutzer ist gesperrt
NO: der Benutzer ist nicht gesperrt

mögliche Werte für SERVERRIGHTS: siehe Serverberechtigungen
Setzen Sie ein Pluszeichen vor die Serverberechtigung, um sie zuzuordnen und ein Minuszeichen um sie zu entziehen. Bei der Angabe von mehreren Serverberechtigungen sind die Werte durch Kommas voneinander zu trennen.

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als DBM-Benutzer mit dem Namen OLEG und dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB,

Ändern des Benutzerkennworts für den DBM-Benutzer mit dem Benutzernamen ELENA auf den Wert SATURDAY, Zuweisen der Serverberechtigung zum Starten von Datenbankinstanzen und Entziehen der Serverberechtigung zum Stoppen von Datenbankinstanzen:

>dbmcli –u OLEG,MONDAY –d DEMODB user_put ELENA PASSWORD=SATURDAY SERVERRIGHTS=+DBStart,-DBStop

OK


Serverberechtigungen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Serverberechtigungen

Übersicht, welche Serverberechtigung für welche Aktion im Database Manager vorausgesetzt wird

Serverberechtigung | Aktion
AccessSQL | Zugriff auf SQL-Sitzung
AccessUtility | Zugriff auf Utility-Sitzung
Backup | Durchführen von Sicherungen
DBFileRead | Zugriff auf Datenbankdateien (nur lesend)
DBInfoRead | Anzeigen von Zustandsinformationen
DBStart | Starten der Datenbankinstanz
DBStop | Stoppen der Datenbankinstanz
ExecLoad | Ausführen des Programms Loader
InstallMgm | Installationsverwaltung
LoadSysTab | Laden der Systemtabellen
ParamCheckWrite | Zugriff auf Datenbankparameter (geprüftes Schreiben)
ParamFull | Zugriff auf Datenbankparameter (lesend und schreibend)
ParamRead | Zugriff auf Datenbankparameter (nur lesend)
Recovery | Wiederherstellen von Sicherungen
SchedulerMgm | Verwalten des Scheduler
Scheduling | Einplanen von DBM-Kommandos
SharedMemoryAdmin | Verwalten des Shared-Memory
SystemCmd | Ausführen von Betriebssystemkommandos
UserMgm | Verwalten der DBM-Benutzer

Siehe auch:

user_getrights

Dokumentation Konzepte des Datenbanksystems, Abschnitt Strukturlink Serverberechtigungen für den DBM-Server


AccessSQL: Zugriff auf SQL-Sitzung (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation AccessSQL: Zugriff auf SQL-Sitzung

Benutzer, denen die Serverberechtigung AccessSQL zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
auto_update_statistics | Automatisches Aktualisieren der Optimiererstatistiken
db_connect | Eröffnen einer Datenbanksitzung
db_execute | Ausführen eines Administrationskommandos oder einer SQL-Anweisung (Anzeige der Ergebnisliste)
db_executenice | Ausführen eines Administrationskommandos oder einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
db_fetch | Blättern in den Ergebnisdaten eines Administrationskommandos oder einer Datenbankanweisung (Anzeige der Ergebnisliste)
db_fetchnice | Blättern in den Ergebnisdaten eines Administrationskommandos oder einer Datenbankanweisung (datensatzweise Anzeige des Ergebnisses)
db_release | Beenden einer Datenbanksitzung
sql_connect | Eröffnen einer SQL-Sitzung
sql_execute | Ausführen einer SQL-Anweisung (Anzeige der Ergebnisliste)
sql_executenice | Ausführen einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
sql_fetch | Blättern in den Ergebnisdaten einer SQL-Anweisung (Anzeige der Ergebnisliste)
sql_fetchnice | Blättern in den Ergebnisdaten einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
sql_info | Anzeigen der Struktur einer Ergebnismenge
sql_recreateindex | Wiederherstellen eines beschädigten Indexes
sql_release | Beenden einer SQL-Sitzung
sql_updatestat | Aktualisieren der Optimiererstatistiken
sql_updatestat_per_systemtable | Aktualisieren der Optimiererstatistiken gemäß Systemtabelle SYSUPDSTATWANTED


AccessUtility: Zugriff auf Utility-Sitzung (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation AccessUtility: Zugriff auf Utility-Sitzung

Benutzer, denen die Serverberechtigung AccessUtility zugewiesen wurde, dürfen folgendes DBM-Kommando ausführen:

DBM-Kommando | Beschreibung
auto_extend | Automatisches Erweitern des Datenbereichs
db_activate | Initialisieren einer Datenbankinstanz
db_activate_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
db_addvolume | Hinzufügen von Volumes
db_connect | Eröffnen einer Datenbanksitzung
db_deletevolume | Löschen eines Data-Volume
db_execute | Ausführen eines Administrationskommandos oder einer SQL-Anweisung (Anzeige der Ergebnisliste)
db_executenice | Ausführen eines Administrationskommandos oder einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
db_fetch | Blättern in den Ergebnisdaten eines Administrationskommandos oder einer SQL-Anweisung (Anzeige der Ergebnisliste)
db_fetchnice | Blättern in den Ergebnisdaten eines Administrationskommandos oder einer SQL-Anweisung (datensatzweise Anzeige des Ergebnisses)
db_migratecatalog | ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando
db_reinstall | Neuaufbau der Datenbankinstanz
db_release | Beenden einer Datenbanksitzung
scheduler_deactivate_job | Deaktivieren eines Scheduler-Jobs


Backup: Durchführen von Sicherungen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Backup: Durchführen von Sicherungen

Benutzer, denen die Serverberechtigung Backup zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
archive_stage | Einfaches Archivieren der Sicherungsdateien (nur für Log-Sicherungen)
archive_stage_repeat | Mehrfaches Archivieren der Sicherungsdateien (nur für Log-Sicherungen)
autolog_cancel | Beenden einer unterbrochenen automatischen Log-Sicherung
autolog_off | Abbrechen der automatischen Log-Sicherung
autolog_on | Einschalten der automatischen Log-Sicherung
autolog_show | Anzeigen der Funktion zur automatischen Log-Sicherung
backup_cancel | Beenden einer unterbrochenen Sicherung
backup_cancel_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_ext_ids_forget | Freigeben des von externen Sicherungskennungen belegten Arbeitsspeichers
backup_ext_ids_get | Holen der externen Sicherungskennungen
backup_ext_ids_getfromtool | Holen der im Sicherungswerkzeug gespeicherten Sicherungsinformationen
backup_ext_ids_list | Anzeigen der externen Sicherungskennungen
backup_ext_ids_listnext | Blättern in den externen Sicherungskennungen
backup_history_append | internes Systemkommando
backup_history_close | Schließen der Sicherungshistorie
backup_history_date | Anzeigen des Änderungsdatums der Sicherungshistorie
backup_history_list | Anzeigen der Sicherungshistorie
backup_history_listnext | Blättern in der Sicherungshistorie
backup_history_open | Holen der Sicherungshistorie
backup_ignore | Fortsetzen der Sicherung ohne den zuletzt als voll gemeldeten Datenträger
backup_ignore_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_replace | Angeben des Folgedatenträgers für eine Sicherungsaktion
backup_replace_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_reply_available | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_reply_receive | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
backup_start | Sichern der Datenbankinstanz
backup_state | Anzeigen des aktuellen Standes der Sicherung
db_connect | Eröffnen einer Datenbanksitzung
db_release | Beenden einer Datenbanksitzung
medium_date | Anzeigen des Änderungsdatums der Vorlagendefinitionsdatei
medium_delete | Löschen einer Sicherungsvorlage
medium_delete_nodistribute | systeminternes Kommando im Zusammenhang mit Hot-Standby-Konfigurationen
medium_get | Daten der Sicherungsvorlage anzeigen
medium_getall | Liste aller definierten Sicherungsvorlagen anzeigen
medium_label | Anzeigen der Sicherungsinformationen im Betriebszustand ONLINE oder ADMIN
medium_labeloffline | Anzeigen der Sicherungsinformationen im Betriebszustand OFFLINE
medium_migrate | Übernehmen einer vorhandenen Vorlagendefinition
medium_put | Definieren oder Ändern einer Sicherungsvorlage
medium_put_nodistribute | systeminternes Kommando im Zusammenhang mit Hot-Standby-Konfigurationen
recover_check | Prüfen einer Sicherung
recover_check_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_ignore | Fortsetzen der parallelen Wiederherstellung oder der Prüfung einer Sicherung
recover_ignore_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_replace | Angeben des Folgedatenträgers für eine Wiederherstellungsaktion oder das Prüfen einer Sicherung
recover_replace_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_state_check | Anzeigen des aktuellen Standes des Prüfens einer Sicherung
service_connect | Eröffnen einer Servicesitzung
service_release | Beenden einer Servicesitzung


DBFileRead: Zugriff auf Datenbankdateien (nur lesend) (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation DBFileRead: Zugriff auf Datenbankdateien (nur lesend)

Benutzer, denen die Serverberechtigung DBFileRead zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
diag_histlist | Anzeigen der Diagnosehistorie
diag_pack | Packen von Datenbankdateien
file_backup | Sichern einer Datenbankdatei
file_getfirst | Öffnen einer Datenbankdatei
file_getlist | Liste der Datenbankdateien anzeigen
file_getnext | Blättern im Inhalt einer Datenbankdatei
file_operation | Bearbeiten von Protokolldateien der Datenbankinstanz
file_restore | Wiederherstellen einer Datenbankdatei
trace_clear | Löschen des Inhalts eines Datenbank-Trace
trace_flush | Erzeugen der Binärdatei des Datenbank-Trace
trace_off | Ausschalten des Datenbank-Trace
trace_on | Einschalten des Datenbank-Trace
trace_prot | Erstellen der Textversion des Datenbank-Trace
trace_protopt | Anzeigen der Kommandooptionen für das Erstellen der Textversion des Datenbank-Trace
trace_show | Anzeigen des protokollierten Aktivitäten des Datenbank-Trace


DBInfoRead: Anzeigen von Zustandsinformationen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation DBInfoRead: Anzeigen von Zustandsinformationen

Benutzer, denen die Serverberechtigung DBInfoRead zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
autolog_show | Anzeigen der Funktion zur automatischen Log-Sicherung
backup_ext_ids_forget | Freigeben des von externen Sicherungskennungen belegten Arbeitsspeichers
backup_ext_ids_get | Holen der externen Sicherungskennungen
backup_ext_ids_getfromtool | Holen der im Sicherungswerkzeug gespeicherten Sicherungsinformationen
backup_ext_ids_list | Anzeigen der externen Sicherungskennungen
backup_ext_ids_listnext | Blättern in den externen Sicherungskennungen
backup_history_close | Schließen der Sicherungshistorie
backup_history_date | Anzeigen des Änderungsdatums der Sicherungshistorie
backup_history_list | Anzeigen der Sicherungshistorie
backup_history_listnext | Blättern in der Sicherungshistorie
backup_history_open | Holen der Sicherungshistorie
db_speed | Anzeigen der Variante des Datenbankkerns
db_state | Anzeigen des Betriebszustands der Datenbankinstanz
dban_delete | Löschen der Protokolldateien des Database Analyzer
dban_start | Aufrufen des Database Analyzer
dban_state | Anzeigen der Funktion des Database Analyzer
dban_stop | Beenden des Database Analyzer
event_available | Anzeigen, ob Events ausgelöst wurden
event_delete | Deaktivieren eines Events
event_list | Liste der Events und ihres Status anzeigen
event_list_categories | Liste der Event-Kategorien anzeigen
event_receive | Anzeigen eines ausgelösten Events
event_release | Beenden einer Event-Sitzung
event_set | Aktivieren eines Events
event_wait | Warten auf ein Event
hss_getnodes | Anzeigen der Hot-Standby-Parameter
info | Anzeigen von Zustandsinformationen der Datenbankinstanz
info_next | Blättern in den Zustandsinformationen der Datenbankinstanz
medium_date | Anzeigen des Änderungsdatums der Vorlagendefinitionsdatei
medium_get | Daten der Sicherungsvorlage anzeigen
medium_getall | Liste aller definierten Sicherungsvorlagen anzeigen
medium_migrate | Übernehmen einer vorhandenen Vorlagendefinition
show | Anzeigen von Informationen zur Datenbankinstanz
show_list | Anzeigen der Schlüsselwörter für Informationen zur Datenbankinstanz
show_next | Blättern in den Informationen zur Datenbankinstanz
sql_connect | Eröffnen einer SQL-Sitzung
sql_release | Beenden einer SQL-Sitzung
trace_clear | Löschen des Inhalts des Datenbank-Trace
trace_flush | Erzeugen der Binärdatei des Datenbank-Trace
trace_off | Ausschalten des Datenbank-Trace
trace_on | Einschalten des Datenbank-Trace
trace_prot | Erstellen der Textversion des Datenbank-Trace
trace_protopt | Anzeigen der Kommandooptionen für das Erstellen der Textversion des Datenbank-Trace
trace_show | Anzeigen der protokollierten Aktivitäten des Datenbank-Trace
user_get | Anzeigen der DBM-Benutzereigenschaften
user_getall | Liste der Database Manager-Benutzer anzeigen
user_getrights | Anzeigen der Serverberechtigungen


DBStart: Starten der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation DBStart: Starten der Datenbankinstanz

Benutzer, denen die Serverberechtigung DBStart zugewiesen wurde, dürfen folgendes DBM-Kommando ausführen:

DBM-Kommando | Beschreibung
db_online | Überführen in den Betriebszustand ONLINE
db_standby | Überführen in den Betriebszustand STANDBY


DBStop: Stoppen der Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation DBStop: Stoppen der Datenbankinstanz

Benutzer, denen die Serverberechtigung DBStop zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
db_admin | Überführen in den Betriebszustand ADMIN
db_clear | Löschen von Laufzeitinformationen nach einem Datenbankfehler
db_cons | Benutzen des Werkzeugs XCONS (Datenbankkonsole)
db_offline | Überführen in den Betriebszustand OFFLINE
db_restart | Restart der Datenbankinstanz
db_stop | Beenden des Prozesses der Datenbank


ExecLoad: Ausführen des Programms Loader: (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation ExecLoad: Ausführen des Programms Loader:

Benutzer, denen die Serverberechtigung ExecLoad zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
load_lcapps | Laden der Bibliotheken der Anwendung
load_r3tab | Laden SAP-spezifischer Tabellen
load_systab | Laden der Systemtabellen
load_tutorial | Laden der Daten des SQL-Tutorial


InstallMgm: Installationsverwaltung (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation InstallMgm: Installationsverwaltung

Benutzer, denen die Serverberechtigung InstallMgm zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
db_drop | Löschen der aktuellen Datenbankinstanz
db_reg | Aktualisieren der Registrierung einer Datenbankinstanz
dbm_configget | Anzeigen eines Konfigurationsparameters des Database Manager
dbm_configset | Ändern eines Konfigurationsparameters des Database Manager
hss_addstandby | Definieren einer Standby-Instanz
hss_copyfile | Kopieren von Datenbankdateien im Cluster
hss_enable | Definieren der Datenbankinstanz als Master-Instanz
hss_removestandby | Löschen einer Standby-Instanz
param_copy | Kopieren einer Datenbank-Parameterdatei
param_init | Initialisieren der Datenbankparameter für eine neue Datenbankinstanz
param_rmfile | Löschen der Datenbank-Parameterdatei


LoadSysTab: Laden der Systemtabellen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation LoadSysTab: Laden der Systemtabellen

Benutzer, denen die Serverberechtigung LoadSysTab zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
load_lcapps | Laden der Bibliotheken der Anwendung
load_r3tab | Laden SAP-spezifischer Tabellen
load_systab | Laden der Systemtabellen
load_tutorial | Laden der Daten des SQL-Tutorial


ParamCheckWrite: Zugriff auf Datenbankparameter (geprüftes Schreiben)

Funktionsdokumentation ParamCheckWrite: Zugriff auf Datenbankparameter (geprüftes Schreiben)

Benutzer, denen die Serverberechtigung ParamCheckWrite zugewiesen wurde, dürfen alle unter der Serverberechtigung ParamRead aufgeführten Kommandos ausführen.

Zusätzlich dürfen sie folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
param_abortsession | Abbrechen einer Parametersitzung
param_addvolume | Ändern von Volume-Parametern
param_checkall | Prüfen aller Datenbankparameter
param_commitsession | Bestätigen von Änderungen der Datenbank-Parameterdatei
param_delvolume | Löschen von Volume-Parametern
param_extget | Anzeigen einzelner Daten eines Datenbankparameters
param_extgetall | Anzeigen der Daten aller Datenbankparameter
param_extgetallnext | Blättern in den Daten aller Datenbankparameter
param_getdefault | Anzeigen des Systemvorschlags (Defaultwert)
param_getexplain | Anzeigen des hinterlegten Erläuterungstexts
param_getfull | Anzeigen aller Daten eines Datenbankparameters
param_gethelp | Anzeigen des Hinterlegten Hilfetexts
param_gethistory | Öffnen der Datenbankparameter-Historie
param_gethistorynext | Blättern in der Datenbankparameter-Historie
param_getproperties | Anzeigen aller Eigenschaften eines Datenbankparameters
param_gettype | Anzeigen des Datentyps eines Datenbankparameters
param_getvalue | Anzeigen des aktuellen Wertes eines Datenbankparameters
param_getvolsall | Anzeigen der Daten aller Volume-Parameter
param_getvolume | Anzeigen der Daten eines einzelnen Volume
param_put | Ändern der Werte von Datenbankparametern
param_restore | Zurücksetzen der Parameterdatei auf eine vorherige Version
param_startsession | Eröffnen einer Parametersitzung
param_versions | Liste der Parameterdateien anzeigen


ParamFull: Zugriff auf Datenbankparameter (lesend und schreibend)

Funktionsdokumentation ParamFull: Zugriff auf Datenbankparameter (lesend und schreibend)

Benutzer, denen die Serverberechtigung ParamFull zugewiesen wurde, dürfen alle unter den Serverberechtigungen ParamRead und ParamCheckWrite aufgeführten Kommandos ausführen.

Zusätzlich dürfen sie folgende DBM-Kommandos ausführen:

DBM-Kommandos | Beschreibung
auto_extend | Automatisches Erweitern des Datenbereichs
db_addvolume | Hinzufügen von Volumes
db_deletevolume | Löschen eines Data-Volume
param_abortsession | Abbrechen einer Parametersitzung
param_addvolume | Ändern von Volume-Parametern
param_checkall | Prüfen aller Datenbankparameter
param_commitsession | Bestätigen von Änderungen der Datenbank-Parameterdatei
param_delvolume | Löschen von Volume-Parametern
param_directdel | Löschen eines Datenbankparameters
param_directget | Anzeigen eines Wertes aus der Datenbank-Parameterdatei
param_directgetall | Anzeigen aller Parameter der aktuellen Datenbank-Parameterdatei
param_directgetallnext | Blättern in den Parametern der aktuellen Datenbank-Parameterdatei
param_directput | Ändern eines Parameterwertes direkt in der Datenbank-Parameterdatei
param_extget | Anzeigen einzelner Daten eines Datenbankparameters
param_extgetall | Anzeigen der Daten aller Datenbankparameter
param_extgetallnext | Blättern in den Daten aller Datenbankparameter
param_getdefault | Anzeigen des Systemvorschlags (Defaultwert)
param_getexplain | Anzeigen des hinterlegten Erläuterungstextes
param_getfull | Anzeigen aller Daten eines Datenbankparameters
param_gethelp | Anzeigen des hinterlegten Hilfetextes
param_gethistory | Öffnen der Datenbankparameter-Historie
param_gethistorynext | Blättern in der Datenbankparameter-Historie
param_getproperties | Anzeigen aller Eigenschaften eines Datenbankparameters
param_gettype | Anzeigen des Datentyps eines Datenbankparameters
param_getvalue | Anzeigen des aktuellen Wertes eines Datenbankparameters
param_getvolsall | Anzeigen der Daten aller Volume-Parameter
param_getvolume | Anzeigen der Daten eines einzelnen Volume
param_put | Ändern der Werte von Datenbankparametern
param_restore | Zurücksetzen der Parameterdatei auf eine vorherige Version
param_startsession | Eröffnen einer Parametersitzung
param_versions | Liste der Parameterdateien anzeigen


ParamRead: Zugriff auf Datenbankparameter (nur lesend) (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation ParamRead: Zugriff auf Datenbankparameter (nur lesend)

Benutzer, denen die Serverberechtigung ParamRead zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
param_abortsession | Abbrechen einer Parametersitzung
param_directget | Anzeigen des Wertes eines Parameters der Datenbank-Parameterdatei
param_directgetall | Anzeigen der Werte aller Parameter der Datenbank-Parameterdatei
param_directgetallnext | Blättern in den Parameterwerten der Datenbank-Parameterdatei
param_extget | Anzeigen einzelner Daten eines Datenbankparameters
param_extgetall | Anzeigen der Daten aller Datenbankparameter
param_extgetallnext | Blättern in den Daten aller Datenbankparameter
param_getdefault | Anzeigen des Systemvorschlags (Default-Value)
param_getexplain | Anzeigen des hinterlegten Erläuterungstextes
param_getfull | Anzeigen aller Daten eines Datenbankparameters
param_gethelp | Anzeigen des hinterlegten Hilfetextes
param_gethistory | Öffnen der Datenbankparameter-Historie
param_gethistorynext | Blättern in der Datenbankparameter-Historie
param_getproperties | Anzeigen aller Eigenschaften eines Datenbankparameters
param_gettype | Anzeigen des Datentyps eines Datenbankparameters
param_getvalue | Anzeigen des aktuellen Wertes eines Datenbankparameters
param_getvolsall | Anzeigen der Daten aller Volume-Parameter
param_getvolume | Anzeigen der Daten eines einzelnen Volume
param_startsession | Eröffnen einer Parametersitzung
param_versions | Liste der Parameterdateien anzeigen


Recovery: Wiederherstellen von Sicherungen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Recovery: Wiederherstellen von Sicherungen

Benutzer, denen die Serverberechtigung Recovery zugewiesen wurde, dürfen alle unter der Serverberechtigung Backup aufgeführten Kommandos ausführen.

Zusätzlich dürfen sie folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
autorecover | Automatisches Wiederherstellen der Datenbankinstanz
db_restartinfo | Anzeigen der Restart-Informationen nach dem Einlesen einer Sicherung
recover_cancel | Beenden der unterbrochenen Wiederherstellung oder der Prüfung einer Sicherung
recover_cancel_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_config | Wiederherstellen der Parameterdatei aus einer Datensicherung
recover_req | ausschließlich von DBM-Client-Programmen verwendetes DBM-Kommando
recover_start | Wiederherstellen der Datenbankinstanz
recover_state | Anzeigen des aktuellen Standes der Wiederherstellung
recover_volume | Wiederherstellen eines beschädigten Volume


SchedulerMgm: Verwalten des Scheduler (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation SchedulerMgm: Verwalten des Scheduler

Benutzer, denen die Serverberechtigung SchedulerMgm zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
scheduler_activate_job | Aktivieren eines Scheduler-Jobs
scheduler_create_job | Anlegen eines Scheduler-Jobs
scheduler_deactivate_job | Deaktivieren eines Scheduler-Jobs
scheduler_delete_job | Löschen eines Scheduler-Jobs
scheduler_list_jobs | Liste aller Scheduler-Jobs anzeigen
scheduler_start | Starten des Scheduler
scheduler_state | Anzeigen der Funktion des Scheduler
scheduler_stop | Stoppen des Scheduler


Scheduling: Einplanen von DBM-Kommandos (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Scheduling: Einplanen von DBM-Kommandos

Benutzer, denen die Serverberechtigung Scheduling zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
scheduler_activate_job | Aktivieren eines Scheduler-Jobs
scheduler_create_job | Anlegen eines Scheduler-Jobs
scheduler_deactivate_job | Deaktivieren eines Scheduler-Jobs
scheduler_delete_job | Löschen eines Scheduler-Jobs
scheduler_list_jobs | Liste aller Scheduler-Jobs anzeigen
scheduler_state | Anzeigen der Funktion des Scheduler


SharedMemoryAdmin: Verwalten des Shared-Memory (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation SharedMemoryAdmin: Verwalten des Shared-Memory

Benutzer, denen die Serverberechtigung SharedMemoryAdmin zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommandos | Beschreibung
dbm_shm_info | Anzeigen von Shared-Memory-Informationen
dbm_shm_reset | Zurücksetzen des Shared-Memory
dbm_shm_unlock | Entsperren des Shared-Memory


SystemCmd: Ausführen von Betriebssystemkommandos (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation SystemCmd: Ausführen von Betriebssystemkommandos

Benutzer, denen die Serverberechtigung SystemCmd zugewiesen wurde, dürfen folgendes DBM-Kommando ausführen:

DBM-Kommando | Beschreibung
exec_lcinit | Ausführen des liveCache-Initialisierungsskripts
exec_nipingsrv | ausschließlich von SAP-Anwendungen verwendetes DBM-Kommando


UserMgm: Verwalten der Database Manager-Benutzer (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation UserMgm: Verwalten der Database Manager-Benutzer

Benutzer, denen die Serverberechtigung UserMgm zugewiesen wurde, dürfen folgende DBM-Kommandos ausführen:

DBM-Kommando | Beschreibung
user_create | Anlegen von Database Manager-Benutzern
user_delete | Löschen von Database Manager-Benutzern
user_put | Ändern der DBM-Benutzereigenschaften
user_rename | Ändern des Namens eines DBM-Benutzers
user_sap | Hinterlegen von speziellen Benutzern
user_sysdba | Übermitteln der Daten des Datenbanksystemadministrators an den Database Manager


user_rename (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_rename

Verwendung

Sie ändern den Namen des angegebenen DBM-Benutzers.

Sie können die Namen beliebiger DBM-Benutzer ändern, einschließlich des Namens des aktuell angemeldeten DBM-Benutzers, des ersten DBM-Benutzers und des Datenbanksystemadministrators.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Benutzer, Authentifizierung und Berechtigungen

Voraussetzungen

· Sie haben die Serverberechtigung UserMgm.

· Den Namen des Datenbanksystemadministrators können Sie nur im Betriebszustand ONLINE ändern.
Die Namen aller anderen DBM-Benutzer können Sie auch im Betriebszustand ADMIN oder OFFLINE ändern.

Syntax

user_rename <dbm_operator> <new_name>

<dbm_operator> | Name des DBM-Benutzers, den Sie ändern möchten
<new_name> | neuer Name des DBM-Benutzers

Antwort

OK

Im Fehlerfall siehe Antwortformat.

Beispiel

Aufrufen des Database Manager CLI, Anmelden als Benutzer OLEG mit dem Kennwort MONDAY, Herstellen der Verbindung zur Datenbankinstanz DEMODB, Ändern des Namens des DBM-Benutzers ELENA in JULIE:

>dbmcli -u OLEG,MONDAY -d DEMODB user_rename ELENA JULIE

OK


user_sap (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_sap

Verwendung

In Ausnahmefällen kann es dazu kommen, dass der Database Manager den Benutzer einer SAP-Anwendung nicht mehr erkennt. Sie können diesen Benutzer im Database Manager neu hinterlegen.

Verwenden Sie dieses Kommando nur, wenn Sie durch den Support dazu aufgefordert werden.

Sie legen mit diesem Kommando keine neuen Benutzer an.

Voraussetzungen

Sie haben die Serverberechtigung UserMgm.

Syntax

user_sap = <dbm_operator>,<dbm_operator_password>

Optionen

Option | Beschreibung
<dbm_operator> | Name des Benutzers
<dbm_operator_password> | Kennwort des Benutzers

Antwort

OK

Im Fehlerfall siehe Antwortformat.


user_sysdba (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_sysdba

Verwendung

Sie geben dem Database Manager den Datenbanksystemadministrator bekannt. Die Verwendung dieses DBM-Kommandos ist nur in dem Fall erforderlich, dass der Datenbanksystemadministrator dem Database Manager nicht oder nicht korrekt bekannt ist.

Voraussetzungen

Sie haben die Serverberechtigung UserMgm.

Syntax

user_sysdba <sysdba_user>,<sysdba_user_password>

Optionen

Option | Beschreibung
<sysdba_user> | Name des Datenbanksystemadministrators
<sysdba_user_password> | Kennwort des Datenbanksystemadministrators

Antwort

OK

Im Fehlerfall siehe Antwortformat.


user_system (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen user_system

Verwendung

Wenn der Database Manager mit Betriebssystemrechten auf einen entfernten Rechner zugreifen soll, dann melden Sie sich mit Hilfe dieses DBM-Kommandos im Sitzungsmodus oder Skriptmodus an das Betriebssystem an.

Die angegebenen Benutzerdaten werden nur einmalig für die Anmeldung genutzt. Sie werden auf dem entfernten Rechner nicht gespeichert.

Diese Anmeldung ist Voraussetzung für die Ausführung folgender DBM-Kommandos:

DBM-Kommando | Beschreibung
db_create | Anlegen einer Datenbankinstanz
inst_unreg | Löschen der Registrierung einer Version der Datenbanksoftware
inst_reg | Registrieren einer Version der Datenbanksoftware

Voraussetzungen

Für dieses DBM-Kommando ist keine Serverberechtigung erforderlich.

Syntax

user_system <dbm_operator>,<dbm_operator_password>

Optionen

Option | Beschreibung
<dbm_operator> | Name des DBM-Benutzers
<dbm_operator_password> | Kennwort des DBM-Benutzers

Antwort

OK

Im Fehlerfall siehe Antwortformat.


Database Analyzer (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Database Analyzer

Einsatzmöglichkeiten

Das Datenbankwerkzeug Database Analyzer dient dazu, die Performance von Datenbankinstanzen zu analysieren. Sie können hiermit Probleme in den folgenden Bereichen identifizieren:

  • Datenbankkonfiguration (Caches, Parameter)
  • Synchronisation (Sperren, kritische Abschnitte, Heap-Bereich)
  • Bearbeitung von SQL-Anweisungen (z. B. Suchstrategie, Indizes, Optimiererstatistiken)
  • Hardwarekonfiguration

Der Database Analyzer kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden. Sie können alle Datenbankinstanztypen und -versionen mit dem Database Analyzer analysieren und auch auf Datenbankinstanzen auf einem entfernten Computer zugreifen.

Einführungshinweise

Der Database Analyzer ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Integration

Der Database Analyzer ist in das Datenbankwerkzeug Database Manager GUI und in das SAP Solution Lifecycle Management (CCMS) integriert. Sie können den Database Analyzer aber auch direkt von der Kommandozeile aus oder über den Database Manager CLI aufrufen: Aufruf des Database Analyzer.

Unter Microsoft Windows verwendet der Database Analyzer MDAC (Microsoft Data Access Components). Sie benötigen MDAC in der Version 2.7 oder höher.

Funktionsumfang

Der Database Analyzer analysiert in regelmäßigen Zeitabständen die Performance der Datenbankinstanz. Die Regeln und Kommandos für das Ermitteln der performancerelevanten Daten durch den Database Analyzer werden in der Konfigurationsdatei festgelegt.

Die Ergebnisse seiner Analyse schreibt der Database Analyzer in Protokolldateien .

Dabei verwendet er eine Reihe von vordefinierten Meldungen.

Einschränkungen

Die DBM-Kommandos für den Zugriff auf den Database Analyzer stehen ab Version 7.5 uneingeschränkt zur Verfügung, siehe Database Manager CLI, Kommandos für die Verwendung des Database Analyzer. Um den Database Analyzer für Datenbankinstanzen früherer Versionen zu verwenden, rufen Sie ihn direkt auf, siehe Aufruf des Database Analyzer.


Aufruf des Database Analyzer (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Aufruf des Database Analyzer

Um den Database Analyzer aufzurufen, wählen Sie eine der folgenden Varianten.

Aufruf im CCMS (nur für SAP-Systeme)

Siehe :

Datenbankverwaltung im CCMS: MaxDB, Strukturlink Database Analyzer

Datenbankverwaltung im CCMS: SAP liveCache-Technologie, Strukturlink Database Analyzer

Aufruf im Database Manager

Siehe:

Database Manager GUI, Database Analyzer-Informationen anzeigen und löschen

Database Manager CLI, Analysieren der Datenbankinstanz

Direkter Aufruf von der Kommandozeile

Geben Sie in einem Kommandofenster folgendes Kommando ein:

dbanalyzer [<options>]

Eine Übersicht der Aufrufoptionen <options> finden Sie im Abschnitt Optionen.

Siehe auch:

Glossar, Strukturlink Syntaxnotation


Optionen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Optionen

Verwendung

Sie können beim Aufrufen des Database Analyzer Optionen angeben:

dbanalyzer [<option_list>]

<option_list> : = <option> | <option> <option> ...

Option

Beschreibung

-c <level>

Anzeigen von Debugging-Informationen

Sie können einen Wert zwischen 1 (wenig) und 4 (viel) angeben. Wenn Sie -c nicht angeben, dann erfolgt werden keine Debugging-Informationen angezeigt

-d <database_name>

Name der Datenbankinstanz

-delete <date>

löscht alle Analysedaten und Protokolle des Database Analyzer bis inklusive des Datums <date>

Geben Sie <date> im Format YYYYMMDD an.

-f <configfile>

Name der Konfigurationsdatei

Wenn Sie keine Konfigurationsdatei angeben, dann verwendet der Database Analyzer die Datei dbanalyzer<version>.cfg im Datenbankverzeichnis <dependent_path>/env.

Siehe

● Konzepte des Datenbanksystems, Strukturlink Konfigurationsdateien

● Installationshandbuch, Strukturlink Verzeichnisse

-i

Löschen bereits vorhandener Protokolldateien desselben Tags

-n <database_computer>

Name des Rechners, auf dem die Datenbankinstanz läuft

Wenn Sie den Rechnernamen angeben, dann müssen Sie mit der Option –o auch das Verzeichnis für die Protokolldateien angeben.

Siehe Konzepte des Datenbanksystems, Strukturlink Protokolldateien

-noenv

Unterdrücken der Protokollierung und der Ausgabe der Umgebungsvariablen aus der Konfigurationsdatei

-nologo

Unterdrücken der Logo-Ausgabe

-o <outputdir>

Verzeichnis für die Protokolldateien

Wenn Sie den Database Analyzer auf dem Rechner starten, auf dem die Datenbankinstanz installiert ist, müssen Sie –o nicht angeben.

Wenn Sie -o nicht angeben, dann verwendet der Database Analyzer das Unterverzeichnis analyzer im Strukturlink Arbeitsverzeichnis der Datenbankinstanz.

-state

Anzeigen von Informationen zum laufenden Database Analyzer

-stop

Stoppen des Database Analyzer

-t <interval>[,<number>]

Zeitintervall <interval> zwischen zwei Analysen (in Sekunden) und Zahl <number> der gewünschten Analysen

Vorschlagswert des Systems für <interval> ist 900 sec.

Wenn Sie für <number> einen Wert angeben, dann beendet sich das Programm Database Analyzer nach der entsprechenden Anzahl von Analysen.

-u <database_user>,<database_user_password>

Name und Kennwort des Datenbankbenutzers

-V

Anzeigen der Version des Database Analyzer

-?

Anzeigen der Hilfe zum Database Analyzer


Konfigurationsdatei (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Konfigurationsdatei

Die Konfigurationsdatei dbanalyzer<version>.cfg definiert die Regeln und Kommandos für das Ermitteln der performancerelevanten Daten durch den Database Analyzer.

Diese performancerelevanten Daten werden entweder direkt den Systemtabellen der Datenbank entnommen oder aus entnommenen Werten berechnet.

Die Konfigurationsdatei beschreibt auch die fünf Klassen (Information, drei Warnstufen, Fehlermeldung), nach denen der Database Analyzer die Parameter bewertet und in der Protokolldatei DBAN.prt protokolliert. Für diese Klassen lassen sich in der Konfigurationsdatei konkrete Handlungsanweisungen für den Nutzer hinterlegen.

Änderungen der Regeln und Kommandos wirken sich nur auf die Konfigurationsdatei aus, während das Programm Database Analyzer selbst unverändert bleibt.


Protokolldateien (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Protokolldateien

Definition

Die während eines Tages gesammelten Analysedaten des Database Analyzer und weitere Protokolle des Database Analyzer werden im Protokolldateiverzeichnis in einer Reihe von Protokolldateien gespeichert.

Das Protokolldateiverzeichnis kann wie folgt festgelegt werden:

● Bei Aufruf des Database Analyzer können Sie mittels der Option –o das Protokolldateiverzeichnis festlegen. Die Protokolldateien werden in den Unterverzeichnissen /YYYYMMDD gespeichert.

● Wenn Sie den Database Analyzer auf dem Rechner starten, auf dem die Datenbankinstanz installiert ist, können Sie auf die Angabe von –o verzichten. Die Protokolldateien werden im Unterverzeichnis analyzer im Strukturlink Arbeitsverzeichnis der Datenbankinstanz gespeichert.

Erläuterung einiger Protokolldateien

DBAN.prt

Diese Datei enthält folgende Informationen:

· einmalige Informationen über die Konfiguration und performance-relevante Daten der Datenbankinstanz

· für jede durchgeführte Messung die vom Database Analyzer erkannten Engpässe

Die Informationen und Engpässe werden vom Database Analyzer gewichtet:

I | Information | Allgemeine Informationen, z.B. Anzahl ausgeführter Kommandos
W1 bis W3 | Warnstufe 1 bis 3 | Warnungen zu Engpässen von niedriger, mittlerer und hoher Priorität
E | Emergency | Schwerwiegende Probleme, z. B. drohender Datenbankstillstand

Siehe auch:

Meldungen

DBAN_<Monitorklasse>.csv

Diese Dateien enthalten die gesamten Analysedaten. Sie dienen der nachträglichen Kontrolle des Laufzeitverhaltens.

Pro Monitorklasse, also Analysebereich, existiert eine Datei, die Sie mit Microsoft Excel öffnen und lesen können, sobald sie vom Database Analyzer nicht mehr beschrieben wird.

Protokolldateien des Database Analyzer

Der Database Analyzer verfügt über eine Reihe von Protokollen, die bei Auftreten von Problemen mit dem Werkzeug Database Analyzer geschrieben werden.

● DBAN.err: Fehlerdatei des Database Analyzer

● DBAN.inf: Laufzeitinformationen über den zuletzt gestarteten Database Analyzer
Diese Datei beinhaltet auch Informationen zur Identifikation der Datenbanksitzung (Datei DBAN.sid) und zur Identifikation der Prozesse (Datei DBAN.pid).

Liste aller Protokolldateien

Die Tabellen zeigen, welche Informationen Sie in den Protokolldateien des Database Analyzer finden.

Protokolldateien für alle Datenbankinstanztypen

DBAN.err | Fehlerdatei des Database Analyzer
DBAN.inf | Laufzeitinformationen über den zuletzt gestarteten Database Analyzer
DBAN.prt | Protokollierung der Meldungen inklusive der Analyseregeln und aktuellen Werte, die zu der Meldung geführt haben
DBAN_BACKUP.csv | Anzahl und Dauer physischer Schreib- und Leseaktivitäten während Daten- und/ Log-Sicherungen
DBAN_CACHES.csv | erfolgreiche und nicht erfolgreiche Zugriffe auf die Caches sowie Trefferraten
DBAN_CPU_UTILIZATION.csv | Informationen über die Systemauslastung: CPU-Verbrauch im User- und im System-Modus, aufgeschlüsselt nach System und Instanz, Zeit im Zustand Idle.
DBAN_FILLING.csv | Füllungsgrad der Datenbankinstanz (z. B. Größe der Data-Volumes, Anzahl der benutzten permanenten und temporären Seiten)
DBAN_IO.csv | Lese- und Schreibzugriffe auf Cache- und Datenseiten
DBAN_IOTHREADS.csv | Anzahl und Dauer physischer Schreib- und Leseaktivitäten (I/O-Threads)
DBAN_LOAD.csv | Zugriffe und Selektivität von SELECT-, FETCH-, INSERT-, UPDATE- und DELETE-Anweisungen
DBAN_LOGGING.csv | Anzahl geschriebener Log-Seiten, Füllungsgrad der Log-Warteschlangen usw.
DBAN_OVERVIEW.csv | Überblick der wichtigsten Informationen aus den Protokolldateien des Database Analyzer.
DBAN_REGIONS.csv | Informationen über Zugriffe auf kritische Abschnitte
DBAN_RW_LOCKS.csv | Informationen über Zugriffe auf kritische Abschnitte (Reader-Writer-Locks)
DBAN_SHARED_SQL.csv | Statistiken zu Shared SQL (Trefferraten des Prepare-Cache, Command-Cache, Cleanup, Unload)
DBAN_SPINLOCKS.csv | Informationen über Zugriffe auf kritische Abschnitte (Spinlocks)
DBAN_STRATEGY_INDEX.csv | Zugriffe und Selektivität bei Suche über Indizes
DBAN_STRATEGY_PRIMKEY.csv | Zugriffe und Selektivität bei Suche über PRIMARY KEY
DBAN_STRATEGY_SCANS.csv | Zugriffe und Selektivität bei Suche über INDEX SCAN und TABLE SCAN
DBAN_TASK_ACTIVITIES.csv | Informationen über Task-Aktivitäten (z. B. Anzahl von SQL-Anweisungen, Anzahl laufender User-Tasks, Anzahl der Task-Wechsel)
DBAN_TASK_IO.csv | Anzahl und Dauer physischer Schreib- und Leseaktivitäten aus Sicht der Log-Writer, der User-Task und des Pager
DBAN_TASK_STATES.csv | Anzahl und Ausführungsdauer der abgearbeiteten Anweisungen Anzahl und Wartedauer der Task-Zustände Vsuspend, Vwait, sleep
DBAN_TRANSACTIONS.csv | Anzahl von SQL-Anweisungen und Prozedur-Aufrufen, PREPARE-, EXECUTE-, COMMIT- und ROLLBACK-Anweisungen, Subtransaktionen, TIMEOUTS durch Sperren sowie Umwandlungen von Zeilen- in Tabellensperren (Lock List Escalations)

liveCache-spezifische Protokolldateien

DBAN_CACHES_OCCUPANCY.csv | Cache-Auslastung und -belegung (Anteil an OMS-, SQL- und History-Seiten im Data-Cache)
DBAN_GC.csv | Informationen zu den Aktivitäten der Garbage-Collector-Tasks: wie oft waren sie aktiv, Anzahl gelöschter Objekte und History-Objekte, Anzahl physischer I/O-Operationen.
DBAN_OMS.csv | Anzahl von Aufrufen durch DB-Prozeduren, Dereferenzierungen, gelöschte Objekte, History-Zugriffe
DBAN_OMS_CONTAINER.csv | Informationen über Strukturlink Klassencontainer (z. B. Anzahl der Klassen, Belegung, Anzahl der freien Seiten)
DBAN_OMS_HEAP.csv | Informationen über den OMS-Heap (z. B. Belegung, aktuelle Größe, Kollisionen)
DBAN_OMS_VERSIONS.csv | Informationen über Strukturlink OMS-Versionen (z. B. Anzahl und Alter verwendeter Versionen)


Meldungen (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Meldungen

Der Database Analyzer kann unter anderem die folgenden Meldungen in der Protokolldatei DBAN.prt ausgeben:

Avg user cmd exec time for task

Avg user suspend time for task

Avg user wait time for task

Catalog cache hitrate

Collision rate

Data cache hitrate

Data volume filling level

Deletes

Free user tasks

Index accesses

Index range accesses

Isolated index accesses

Isolated index range accesses

Isolated index scans

Log area filling level

Lock list escalations

Log queue overflows

Log write time

Max log queue filling

Number of cached history pages

Number of physical reads

Number of physical writes

Number of physical writes of temporary pages

OMS cache hitrate

OMS heap collisions

OMS heap utilization

OMS history cache hitrate

OMS terminates

OMS version is old

OMS version is unloaded

Out of memory exceptions

Parse activities

Physical reads for user task

Primary key accesses

Primary key range accesses

Selects and Fetches

Table scans

Updates

User task blocked in state

User task physical writes


Avg user cmd exec time for task (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Avg user cmd exec time for task

Avg user cmd exec time for task <task_ID>: <duration> ms,
<number_of> commands, application pid <pid>

Erläuterung

Die von der angegebenen User-Tasks benötigte Zeit für die Ausführung von Anweisungen ist sehr hoch. Es werden die durchschnittliche Ausführungszeit einer Anweisung, die Zahl aller geprüften Anweisungen und die Prozess-ID des betreffenden Applikationsprozesses angezeigt.

Ob dies wirklich ein Engpass ist, hängt von der Anwendungsstruktur ab.

So führen Massenanweisungen bei Hintergrundverarbeitungen häufig zu hohen Laufzeiten. Daneben führen z. B. Sperrsituationen auf SQL-Objekten, physische Lese- und Schreibaktivitäten oder Dispatching infolge Priorisierung anderer Tasks etc. zu kerninternen Wartesituationen, die ebenfalls die Bearbeitungsdauer verlängern.

Wenn bei liveCache-Instanzen die lange Ausführungszeit bei der Bearbeitung einer DB-Prozedur benötigt wurde, ist die Wahrscheinlichkeit sehr hoch, andere Benutzer im selben liveCache-Thread zu blockieren. Das kann zu unerwartet hohen Laufzeiten von anderen Transaktionen oder DB-Prozeduren führen.


Avg user suspend time for task (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Avg user suspend time for task

Avg user suspend time for task <task_ID>: <duration> ms,
<number_of> suspends, application pid <pid>

Erläuterung

Die Ausführung der angezeigten Strukturlink User-Task wurde durch Wartezeiten unterbrochen. Sie erhalten den Durchschnittswert aller festgestellten Wartezeiten angezeigt. Im Normalfall liegt dieser Wert unter 100 Millisekunden.

Sie erhalten außerdem angezeigt, wie oft Wartezeiten auftraten.

Benutzerreaktion

Überprüfen Sie den Zustand der User-Task regelmäßig.


Avg user wait time for task (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Avg user wait time for task

Avg user wait time for task <task_ID>: <duration> ms, <number_of> waits, application pid <pid>

Erläuterung

Bei einer Sperrkollision ist die Wartezeit auf die Freigabe einer Strukturlink Sperre sehr groß.

Die Ursache kann eine zu lange Transaktion sein. Lange Wartezeiten ( Strukturlink Task-Zustand vwait) treten aber auch dann auf, wenn viele Anwendungen dasselbe Objekt sperren wollen.

Das Datenbanksystem versucht, sperrende Tasks innerhalb des Datenbankkerns mit höherer Priorität auszuführen, wenn deren Sperren von anderen Sitzungen angefordert werden.

Informationen zu den aktuellen Sperren finden Sie in den Systemtabellen Strukturlink TRANSACTIONS und Strukturlink LOCKS der Datenbankinstanz.

Benutzerreaktion

Überprüfen Sie die Anwendung unter folgenden Gesichtspunkten:

  • Eignet sie sich für den Strukturlink Isolation-Level 0 (uncommitted)?
  • Kann der Zeitraum zwischen dem Anfordern der Sperre und der COMMIT-Anweisung verringert werden?
  • Lassen sich durch Teilung von Tabellen gleichzeitige Sperren auf dieselbe Zeile vermeiden?


Catalog cache hitrate (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Catalog cache hitrate

Catalog cache hitrate <percentage>%, <number> of <number> accesses failed

Erläuterung

Die Trefferrate beim Zugriff auf den Strukturlink Catalog-Cache, in dem die geparsten SQL-Anweisungen verwaltet werden, ist zu niedrig. Bei einer eingeschwungenen Datenbankanwendung sollte die Catalog-Cache-Trefferrate bei rund 90 Prozent liegen. Werden neue Programmteile oder Programme gestartet, kann die Trefferrate kurzfristig auf sehr kleine Werte sinken. Sie sollte im Viertelstundenmittel jedoch nicht unter 85 Prozent liegen.

Benutzerreaktion

Die Größe des Catalog-Cache sollte rund 100 Seiten pro Datenbanksitzung betragen. Dies können Sie anhand des Strukturlink allgemeinen Datenbankparameters MAXUSERTASKS und des Strukturlink speziellen Datenbankparameters CAT_CACHE_SUPPLY überprüfen.

Der Catalog-Cache wird von den aktiven Datenbanksitzungen dynamisch vergrößert und bei einer RELEASE-Anweisung wieder freigegeben. Die aktuell belegten Cache-Größen können Sie mittels der SQL-Anweisung SELECT * FROM CONNECTEDUSERS ermitteln.

Sollten Sitzungen erheblich mehr als 100 Seiten benötigen, so empfiehlt sich mittelfristig eine entsprechende Vergrößerung des Catalog-Cache, falls der Speicher des Rechners dies zulässt.


Collision rate (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Collision rate

<region_name>: collision rate (<percentage>%), <number_of> collisions, <number_of> accesses on region <region_ID>

Erläuterung

Die Rate der Sperrkollisionen ist hoch.

In unterschiedlichen Threads laufende Tasks versuchen parallel auf einen globalen Speicherbereich zuzugreifen. Bei der dafür notwendigen Synchronisation treten gehäuft Kollisionen auf.

Eine Ausnahme hiervon sind bei Strukturlink liveCache-Instanzen hohe Kollisionsraten in den Bereichen (<region_id>) OMSVDIR und CNSTVIEW. Diese sind bei bestimmten Aktionen, z.B. gleichzeitigem CIF-Queue-Transfer, normal.

Benutzerreaktion

Handlungsbedarf besteht bei Kollisionsraten von mehr als 10 Prozent. Generell steigt die Kollisionswahrscheinlichkeit mit wachsender Anzahl genutzter Prozessoren ( Strukturlink allgemeiner Datenbankparameter MAXCPU). Sie sollten daher prüfen, ob bei Multiprozessorsystemen das Datenbanksystem die Anwendungsanforderungen auch mit weniger CPUs erfüllen kann.

Treten in Multiprozessor-Zentralsystemen (Datenbanksystem und Anwendung laufen auf dem gleichen Rechner) hohe Kollisionsraten auf, sollten Sie überprüfen, ob der Rechner CPU-seitig überlastet ist und die Datenbank-Threads durch andere Anwendungen blockiert werden. In diesem Fall sollten diejenigen Datenbank-Threads, die Strukturlink User-Tasks enthalten, vom Betriebssystem REAL TIME PRIORITY erhalten. Dabei muss jedoch der Wert von MAXCPU um mindestens eins kleiner sein als die Anzahl realer CPU, um Betriebssystemblockaden zu vermeiden.

Zusätzliche Maßnahmen

· Wenn die hohen Kollisionsraten in den Bereichen DATAn, SPLITnoder TREEn auftreten, dann erhöhen Sie die Werte des allgemeinen Datenbankparameters CACHE_SIZE sowie der speziellen Strukturlink Datenbankparameter _DATA_CACHE_RGNS und _TREE_RGNS.

· Wenn die hohen Kollisionsraten in den Bereichen TRACE oder BUFWRTRauftreten, dann schalten Sie den Strukturlink Datenbank-Trace immer nur vorübergehend zur Problemlokalisierung ein.


Data cache hitrate (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Data cache hitrate

Data cache hitrate <percentage>%, <number> of <number> accesses failed

Erläuterung

Die Trefferrate beim Zugriff auf den Data-Cache ist zu niedrig. Bei einer eingeschwungenen Strukturlink liveCache-Anwendung sollte die Trefferrate nicht unter 100 Prozent liegen.

Kurzzeitig kann es zu niedrigeren Trefferraten kommen, z. B. beim erstmaligen Zugriff auf Objekte oder wenn bei wiederholten Tabellendurchsuchungen (TABLE SCAN) die Tabelle größer ist als 10 Prozent des Data-Cache (nur wenn der Strukturlink spezielle Datenbankparameter LRU_FOR_SCAN den Wert yes hat). Im Viertelstundenmittel sind Data-Cache-Trefferraten unter 99 Prozent zu vermeiden.

Benutzerreaktion

Überprüfen Sie folgende Punkte:

· die Auslastung des Data-Cache

· die Konfiguration der Datenbankinstanz und der Hardware

· bei liveCache-Instanzen auch die Größe von Planversionen sowie lang existierende Strukturlink OMS-Versionen

Häufig verursachen einzelne SQL-Anweisungen einen hohen Anteil an der gesamten logischen und physischen Leseaktivität. Eine Vergrößerung des Cache verlagert die Last lediglich von der Festplatte auf die CPU, obwohl z. B. durch einen zusätzlichen Index aus einem leseintensiven Durchsuchen der Tabelle ein schneller Direktzugriff werden könnte. Informationen zur Erstellung optimaler SQL-Anweisungen finden Sie im Abschnitt Strukturlink SQL-Optimierer.


Data volume filling level (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Data volume filling level

Data volume filling level <percentage>%, <number_of> pages configured, perm used <perm_used>, temp used <temp_used>

Erläuterung

Der Füllungsgrad der Strukturlink Data-Volumes ist hoch. Erreicht der Füllungsgrad 100 Prozent, wird es zum Stillstand der Datenbankinstanz kommen.

Benutzerreaktion

Wenn sich die in der Datenbankinstanz zu verwaltende Datenmenge erhöht hat, dann müssen Sie gegebenenfalls ein neues Data-Volume hinzufügen.

Ein hoher Anteil von temporären Datenseiten (temp used) deutet auf große (Zwischen-)
Ergebnismengen hin. Versuchen Sie die Anweisung zu finden, die zu dem Aufbau der großen (Zwischen-)Ergebnismengen führt, und überprüfen Sie die Zugriffsstrategien für diese Anweisung.

Informationen zur Erstellung optimaler SQL-Anweisungen finden Sie in der Dokumentation Strukturlink SQL-Optimierer.


Deletes/Updates (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Deletes/Updates

Delete selectivity <percentage>%: <number_of> deletes, <number_of> rows read, <number_of> rows qualified

Update selectivity <percentage>%: <number_of> updates, <number_of> rows read, <number_of> rows qualified

Erläuterung

Bei UPDATE- oder DELETE-Anweisungen ist das Verhältnis zwischen gelesenen und geänderten Zeilen schlecht.

Bevor mit UPDATE- und DELETE-Anweisungen Zeilen geändert oder gelöscht werden können, müssen diese zuvor in der entsprechenden Tabelle lokalisiert werden. Dabei werden die gleichen Zugriffsstrategien wie bei einer SELECT-Anweisung verwendet.

Benutzerreaktion

Versuchen Sie die Anweisung zu finden, die zu dem schlechten Verhältnis zwischen gelesenen und gefundenen Zeilen führt, und überprüfen Sie die Zugriffsstrategien für diese Anweisung.

Informationen zur Erstellung optimaler SQL-Anweisungen finden Sie in der Dokumentation Strukturlink SQL-Optimierer.


Free user tasks (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Free user tasks

Free user tasks: <count>, connected users: <count>

Erläuterung

Die Anzahl freier Strukturlink User-Tasks ist gering. Wenn ihre Anzahl auf null zurückgeht, können sich keine weiteren Anwendungen mehr mit der Datenbankinstanz verbinden.

Benutzerreaktion

Überprüfen Sie die bestehenden Datenbankverbindungen. Überprüfen Sie, ob sich einige Anwendungen mehrfach an der Datenbankinstanz angemeldet haben. Wenn sich die Anzahl der Anwendungen, die mit der Datenbankinstanz arbeiten sollen, erhöht, dann müssen Sie eventuell den Wert des Strukturlink allgemeinen Datenbankparameters MAXUSERTASKS erhöhen.


Lock list escalations (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Lock list escalations

Lock list escalations: <count>

Erläuterung

Die Anzahl von Strukturlink Zeilensperren in einer Tabelle ist zu hoch. Das Datenbanksystem versucht die Zeilensperren deshalb in eine Tabellensperre umzuwandeln.

Benutzerreaktion

Sie können die maximale Anzahl möglicher Zeilensperren in der Sperrliste (Lock-Liste) über den Strukturlink allgemeinen Datenbankparameter MAXLOCKS angeben. Die Umwandlung in eine Tabellensperre wird versucht, wenn eine Task mehr als 0,1*MAXLOCKS Zeilensperren auf einer Tabelle hält. Bei häufigerem Auftreten unerwünschter Eskalationen sollte der Parameterwert erhöht werden.

Ob Eskalationen zum Problem werden, hängt stark von der jeweiligen Anwendung ab. Wenn Eskalationen auftreten, dann untersuchen Sie die Anwendung daraufhin, ob Änderungstransaktionen, die sehr viele Zeilen sperren, in mehrere einzelne Transaktionen aufgeteilt werden können.


Log area filling level (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Log area filling level

Log area filling level <percentage>%, <number_of> pages configured, <number> used

Erläuterung

Der Füllungsgrad des Strukturlink Log-Bereichs ist hoch. Wenn der Füllungsgrad 100 Prozent erreicht, wird es zum Stillstand der Datenbankinstanz kommen.

Benutzerreaktion

Sichern Sie den Log-Bereich. Aktivieren Sie gegebenenfalls die Strukturlink automatische Log-Sicherung. Wenn die automatische Log-Sicherung bereits eingeschaltet ist, dann überprüfen Sie, ob die letzte durchgeführte Log-Sicherung erfolgreich war.


Log queue overflows (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Log queue overflows

Log queue overflows: <count>

Log queue overflows: <count>, configured log queue pages: <count>

Erläuterung

Die Strukturlink Log-Warteschlange ist voll, bevor die Log-Seiten in den Log-Bereich geschrieben wurden.

Benutzerreaktion

Überprüfen Sie die Größe der Log-Warteschlange anhand des Strukturlink speziellen Datenbankparameters LOG_IO_QUEUE und erhöhen Sie den Wert, wenn möglich.

Überprüfen Sie die Performance der Festplatte, auf der die Log-Volumes liegen.


Log write time (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Log write time

Avg log write time (log_writer_task) <duration> ms, <number_of> writes, <number_of> pages

Avg log write time (dev_thread) <duration> ms, <number_of> writes, <number_of> pages

Erläuterung

Das physische Schreiben von Log-Einträgen dauert zu lange. Es besteht die Gefahr, dass das physische Schreiben der Log-Einträge zum Engpass wird.

Benutzerreaktion

Überprüfen Sie die Lese- und Schreibvorgänge auf dem Plattenbereich oder Device, auf dem die Strukturlink Log-Volumes liegen. Neben dem Schreiben der Log-Einträge sollten dort möglichst keine weiteren Lese- oder Schreibvorgänge stattfinden. Unter Umständen ist eine Verlagerung der Log-Volumes auf ein schnelleres Device notwendig.

Siehe auch:

Dokumentation Konzepte des Datenbanksystems, Strukturlink Protokollierung von Datenänderungen (Logging)


Max log queue filling (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Max log queue filling

Max log queue filling: <percentage>%

Erläuterung

Der Füllungsgrad der Strukturlink Log-Warteschlange ist hoch. Erreicht der Füllungsgrad 100 Prozent, besteht die Gefahr eines Log queue overflows.

Benutzerreaktion

Überprüfen Sie den Wert des Strukturlink speziellen Datenbankparameters LOG_IO_QUEUE und erhöhen Sie ihn, wenn möglich.

Überprüfen Sie die Performance der Festplatte, auf der die Log-Volumes liegen.


Number of cached history pages (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Number of cached history pages

Number of cached history pages (<number>) exceeds number of cached OMS pages (<number>)

Erläuterung

Diese Meldung kann nur bei liveCache-Instanzen auftreten.

Im Data-Cache ist die Anzahl der History-Seiten höher als die Anzahl der OMS-Datenseiten.

Benutzerreaktion

Suchen Sie nach alten Strukturlink OMS-Versionen und Transaktionen, die das Löschen der History-Seiten im Data-Cache verhindern.

Überprüfen Sie, ob die Reports /SAPAPO/OM_REORG_DAILY und /SAPAPO/OM_DELETE_OLD_SIMSESS regelmäßig ausgeführt werden (siehe auch: Strukturlink OMS-Versionen überwachen).


Number of physical reads (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Number of physical reads

Number of physical reads: <count>

Erläuterung

Es erfolgen sehr viele physische Lesezugriffe auf die Strukturlink Volumes der Datenbankinstanz, da die von den Anwendungen angeforderten Daten nicht im Strukturlink Data-Cache gefunden wurden.

Benutzerreaktion

Wird auf Tabellen zum ersten Mal zugegriffen oder wurden sie längere Zeit nicht verwendet und daher aus dem Data-Cache verdrängt, ist dieses Verhalten unproblematisch.

Lässt sich die Leseaktivität jedoch nicht aus dem erstmaligen Zugriff auf Tabellen erklären, sollten Sie die Trefferrate für den Data-Cache überprüfen und den Data-Cache gegebenenfalls vergrößern.

Schließen Sie außerdem aus, dass die von der Anwendung gegebenen SQL-Anweisungen erheblich mehr Daten lesen als zur Abarbeitung benötigt werden, z. B. durch ungünstige Strukturlink Suchstrategien.

Wenn der Wert des Strukturlink speziellen Datenbankparameters LRU_FOR_SCAN yes ist, dann werden bei Tabellendurchsuchungen ( Strukturlink TABLE SCAN) nur 10 Prozent des Data-Cache für die Zwischenspeicherung der Tabelle genutzt, so dass die Tabelle eventuell nicht komplett im Data-Cache gehalten werden kann und beim nächsten Durchsuchen erneut physisch gelesen werden muss.


Number of physical writes (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Number of physical writes

Number of physical writes: <count>

Erläuterung

Die von den Anwendungen verwendeten Daten können nicht vollständig im Strukturlink Data-Cache gehalten werden. Deshalb findet eine Verdrängung von Seiten vom Data-Cache in den Datenbereich statt, d.h. es erfolgen sehr viele physische Schreibzugriffe auf die Strukturlink Data-Volumes.

Bei längeren Ladeläufen (Datenimport) kommt es fast zwangsläufig zu solchen Verdrängungserscheinungen, da das importierte Datenvolumen in der Regel die Größe des Data-Cache weit übersteigt.

In regelmäßigen Abständen werden außerdem beim Strukturlink Savepoint alle geänderten Seiten aus dem Data-Cache in den Datenbereich geschrieben. Zu diesem Zeitpunkt steigt die Lese- und Schreibaktivität stark an, ohne dass es sich dabei um einen echten Engpass handelt. Im Normalbetrieb sollten Sie jedoch außerhalb der Savepoints keine nennenswerten Schreibaktivitäten messen können.

Benutzerreaktion

Werden im Normalbetrieb hohe Schreibaktivitäten beobachtet, sollten Sie zunächst ausschließen, dass während des (gegebenenfalls zu kurzen) Messintervalls ein Savepoint aktiv war.

Wenn dies nicht der Fall ist, dann vergrößern Sie den Data-Cache.


Number of physical writes of temporary pages (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Number of physical writes of temporary pages

Number of physical writes of temporary pages: <count>

Erläuterung

Beim Erzeugen temporärer Strukturlink Datenseiten zum Aufbau von (Zwischen-) Ergebnismengen, z.B. bei JOINS oder ORDER BY-Anweisungen, reicht der Strukturlink Data-Cache zur Aufnahme der temporären Seiten nicht aus, so dass eine Auslagerung in den Strukturlink Datenbereich erfolgen muss. Diese Seiten müssen im Rahmen der weiteren Verarbeitung der SQL-Anweisung jedoch wieder vom Datenbereich eingelesen werden.

Benutzerreaktion

Versuchen Sie die Anweisung zu finden, die zu dem Aufbau der großen (Zwischen-) Ergebnismengen führt und überprüfen Sie die Zugriffsstrategien für diese Anweisung.

Informationen zur Erstellung optimaler SQL-Anweisungen finden Sie in der Dokumentation Strukturlink SQL-Optimierer.


OMS cache hitrate (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation OMS cache hitrate

OMS cache hitrate <percentage>%, <number> of <number of> accesses failed

Erläuterung

Diese Meldung kann nur bei liveCache-Instanzen auftreten.

Die Trefferrate beim Zugriff auf die Strukturlink OMS-Daten im Strukturlink Data-Cache ist zu niedrig. Bei einer eingeschwungenen liveCache-Anwendung sollte die Trefferrate nicht unter 100 Prozent liegen, da ansonsten Daten physisch gelesen werden müssen.

Kurzzeitig kann es zu niedrigeren Trefferraten kommen, z. B. beim erstmaligen Zugriff auf Objekte.

Benutzerreaktion

Überprüfen Sie die folgenden Punkte:

· die Auslastung des Data-Cache

· die Größe der Planversion

· lang laufende Strukturlink OMS-Versionen

· die Konfiguration der liveCache-Instanz und der Hardware


OMS heap collisions (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation OMS heap collisions

OMS heap collision rate <percentage>%, <number of> collisions during <number of> heap allocations/deallocations

Erläuterung

Diese Meldung kann nur bei Strukturlink liveCache-Instanzen auftreten.

In unterschiedlichen Threads laufende Tasks versuchen parallel Speicher vom Strukturlink OMS-Heap anzufordern oder freizugeben. Dabei kommt es gehäuft zu Kollisionen.

Benutzerreaktion

Überprüfen Sie, ob der liveCache-Datenbankparameter OMS_HEAP_COUNT, der die Anzahl der OMS-Heap-Segmente bestimmt, optimal eingestellt ist. Siehe Konzepte des Datenbanksystems, Strukturlink liveCache-Datenbankparameter.

Die Kollisionswahrscheinlichkeit steigt generell mit wachsender Anzahl genutzter Prozessoren ( Strukturlink allgemeiner Datenbankparameter MAXCPU). Prüfen Sie, ob die liveCache-Instanz die Anwendungsanforderungen auch mit weniger Prozessoren erfüllen kann. Wenn das nicht der Fall ist, dann prüfen Sie, ob der Rechner CPU-seitig überlastet ist und die liveCache-Threads durch andere auf dem Rechner laufende Anwendungen blockiert werden. In diesem Fall sollten diejenigen liveCache-Threads, die Strukturlink User-Tasks enthalten, vom Betriebssystem REAL TIME PRIORITY erhalten. Dabei muss jedoch der Wert von MAXCPU um mindestens eins kleiner sein als die Anzahl realer CPU, um Betriebssystemblockaden zu vermeiden.


OMS heap utilization (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation OMS heap utilization

OMS heap utilization <percentage>%, used/max: <used_size>/<heap_limit_size> MB

Erläuterung

Diese Meldung kann nur bei liveCache-Instanzen auftreten.

Für die laufenden DB-Prozeduren ist der Speicherplatzbedarf im Strukturlink OMS-Heap sehr hoch.

Erreicht die Speicherplatzbelegung im OMS-Heap 100 Prozent, besteht die Gefahr, dass Fehler in den DB-Prozeduren auftreten (Out Of Memory Exceptions) oder dass Strukturlink OMS-Versionsdaten vom OMS-Heap in den globalen Strukturlink Data-Cache ausgelagert werden (OMS version is unloaded).

Benutzerreaktion

Vergrößern Sie gegebenenfalls den OMS-Heap.

Überprüfen Sie, ob die Konfiguration Ihrer Datenbankinstanz und der Hardware den Anforderungen der liveCache-Anwendung entspricht.


OMS history cache hitrate (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation OMS history cache hitrate

OMS history cache hitrate <percentage>%, <number> of <number of> accesses failed

Erläuterung

Diese Meldung kann nur bei liveCache-Instanzen auftreten.

Die Trefferrate beim Zugriff auf die History-Daten (Verweise auf die Undo-Log-Einträge der Objekte) im Strukturlink Data-Cache ist zu niedrig. Bei einer eingeschwungenen liveCache-Anwendung sollte die Trefferrate nicht unter 100 Prozent liegen, da ansonsten Daten physisch gelesen werden müssen.

Kurzzeitig kann es zu niedrigeren Trefferraten kommen, z. B. beim erstmaligen Zugriff auf Objekte.

Benutzerreaktion

Überprüfen Sie die folgenden Punkte:

  • die Auslastung des Data-Cache
  • die Größe der Planversion
  • lang laufende Strukturlink OMS-Versionen
  • die Konfiguration der liveCache-Instanz und der Hardware

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink History-Verwaltung


OMS terminates (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation OMS terminates

<number of> terminates of DB procedure '<DB_procedure_name>' due to errors

Erläuterung

Diese Meldung kann nur bei liveCache-Instanzen auftreten.

Während der Ausführung der angegeben DB-Prozedur ist ein Fehler aufgetreten.

Benutzerreaktion

Versuchen Sie anhand der Strukturlink Protokolldateien (z. B. knldiag und lcapo_com_trace_<xy>.txt) die Ursache des Fehlers zu ermitteln.


OMS version is old (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation OMS version is old

OMS version <OMS_version_ID> is <hours> hours old, uses <number> KB

Erläuterung

Diese Meldung kann nur bei liveCache-Instanzen auftreten.

Strukturlink OMS-Versionen sind lange offen und belegen Speicherplatz im Strukturlink OMS-Heap. Die Anzahl der History-Seiten (Verweise auf die Undo-Log-Einträge der Objekte) kann so im Data-Cache und auf der Festplatte anwachsen.

Benutzerreaktion

Ermitteln Sie die OMS-Version und den Füllungsgrad des Data-Cache.

Wenn der Füllungsgrad des Data-Cache und der Prozentsatz der History-Seiten hoch ist, versuchen Sie den Verursacher zu identifizieren.

Überprüfen Sie, ob die Reports /SAPAPO/OM_REORG_DAILY und /SAPAPO/OM_DELETE_OLD_SIMSESS regelmäßig ausgeführt werden (siehe auch: Strukturlink OMS-Versionen überwachen).

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink History-Verwaltung


OMS version is unloaded (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation OMS version is unloaded

OMS version <OMS_version_ID> is unloaded, uses <number> KB

Erläuterung

Diese Meldung kann nur bei liveCache-Instanzen auftreten.

Daten der Strukturlink OMS-Versionen wurden vom Strukturlink OMS-Heap in den Strukturlink Data-Cache geladen, weil der Wert einer der beiden liveCache-Parameter OMS_HEAP_THRESHOLD oder OMS_VERS_THRESHOLD überschritten wurde.

Die Performance beim Zugriff auf die betreffenden OMS-Versionen verschlechtert sich, weil der Zugriff auf den Data-Cache zeitintensiver ist als der auf den OMS-Heap.

Benutzerreaktion:

Überprüfen Sie die Parameter OMS_HEAP_THRESHOLD und OMS_VERS_THRESHOLD.

Vergrößern Sie gegebenenfalls den OMS-Heap.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink liveCache-Datenbankparameter


Optimizer strategies (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Optimizer strategies

<number of> <optimizer_strategy_executes>, selectivity <percentage>%: <number of> rows read, <number of> rows qualified

Erläuterung

Bei der Anwendung einer bestimmten Zugriffsstrategie (<optimizer_strategy_executes>) ist das Verhältnis zwischen gelesenen und gefundenen Tabellenzeilen schlecht.

Bei der Zugriffsstrategie kann es sich um eine der folgenden Strategien handeln:

· Primary key accesses
( Strukturlink EQUAL CONDITION FOR KEY,
Strukturlink SUBQ CONDITION FOR KEY,
Strukturlink IN CONDITION FOR KEY)

· Primary key range accesses
( Strukturlink RANGE CONDITION FOR KEY,
SUBQ CONDITION FOR KEY,
IN CONDITION FOR KEY)

· Index accesses
( Strukturlink EQUAL CONDITION FOR INDEX,
Strukturlink SUBQ CONDITION FOR INDEX,
Strukturlink IN CONDITION FOR INDEX)

· Index range accesses
( Strukturlink RANGE CONDITION FOR INDEX,
SUBQ CONDITION FOR INDEX,
IN CONDITION FOR INDEX)

· Isolated index accesses
siehe: Strukturlink EXPLAIN-Anweisung: Spalten O,D,T,M, Spalte O (Only Index)
sowie Index accesses

· Isolated index range accesses
siehe: EXPLAIN-Anweisung: Spalten O,D,T,M, Spalte O (Only Index)
sowie Index range accesses

· Isolated index scans
( Strukturlink INDEX SCAN)

Benutzerreaktion

Versuchen Sie die Anweisung zu finden, die zu dem schlechten Verhältnis zwischen gelesenen und gefundenen Zeilen führt, und überprüfen Sie die Zugriffsstrategien für diese Anweisung.

Informationen zur Erstellung optimaler SQL-Anweisungen finden Sie in der Dokumentation Strukturlink SQL-Optimierer.

Siehe auch: Table scans


Out of memory exceptions (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Out of memory exceptions

Out of memory exceptions: <count>

Erläuterung

Diese Meldung kann nur bei liveCache-Instanzen auftreten.

DB-Prozeduren scheiterten wegen mangelnden Speicherplatzes im Strukturlink OMS-Heap.

Benutzerreaktion

· Suchen Sie in der Strukturlink Protokolldatei knldiag nach näheren Angaben.

· Überprüfen Sie die Strukturlink OMS-Versionen und überprüfen Sie, wieviel Platz sie im OMS-Heap belegen, z. B. anhand der Protokolldateien DBAN_OMS_VERSIONS.csv und DBAN_OMS_HEAP.csv.

· Überprüfen Sie den OMS-Heap und erhöhen Sie, wenn möglich, die Heap-Größe.


Parse activities (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Parse activities

Parse activities <percentage>%, <number of> prepares, <number of> commands

Erläuterung

Die Anzahl von Parse-Vorgängen ist bezogen auf die Gesamtzahl der ausgeführten Anweisungen sehr hoch.

Vor der erstmaligen Ausführung einer SQL-Anweisung muss diese zunächst analysiert (geparst) werden, wobei das Datenbanksystem u. a. die möglichen Zugriffsstrategien ermittelt und die Anweisung in kompakter Form in der Datenbankinstanz ablegt. Bei jeder weiteren Ausführung wird nur noch auf diese internen Informationen zugegriffen und die Anweisung direkt ausgeführt.

Bei Anwendungen, die auf ODBC basieren und die PREPARE-Anweisung verwenden, ist der Entwickler für die Anzahl der Parse- bzw. EXECUTE-Aufträge verantwortlich.

Bei Verwendung der SQLDBC- oder JDBC-Schnittstelle sorgt bei aktiviertem Parse-Info-Cache die jeweilige Schnittstelle für die Optimierung der Parse-Aufträge.

Hohe Parse-Aktivitäten im laufenden Betrieb können auf die fehlende Implementierung eines Statement-Cache in Ihrer Anwendung oder den deaktivierten Parse-Info-Cache der JDBC-Schnittstelle hindeuten.

Beim erstmaligen Start von Programmen oder Programmteilen ist eine hohe Parse-Aktivität normal.


Physical reads for user task (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Physical reads for user task

<number of> physical reads for user task <task_ID>, <number of> commands, application pid <pid>

Erläuterung

Es erfolgen durch die Strukturlink User-Task <task_id> sehr viele physische Lesezugriffe auf die Strukturlink Volumes der Datenbankinstanz, da die von den Anwendungen angeforderten Daten nicht im Strukturlink Data-Cache gefunden wurden.

Benutzerreaktion

Wird auf Tabellen zum ersten Mal zugegriffen oder wurden sie längere Zeit nicht verwendet und daher aus dem Data-Cache verdrängt, ist dieses Verhalten unproblematisch.

Lässt sich die Leseaktivität jedoch nicht aus dem erstmaligen Zugriff auf Tabellen erklären, sollten Sie die Trefferrate für den Data-Cache überprüfen und den Data-Cache gegebenenfalls vergrößern.

Schließen Sie außerdem aus, dass die von der Anwendung gegebenen SQL-Anweisungen erheblich mehr Daten lesen als zur Abarbeitung benötigt werden, z. B. durch ungünstige Strukturlink Suchstrategien.

Wenn der Wert des Strukturlink speziellen Datenbankparameters LRU_FOR_SCAN yes ist, dann werden bei Tabellendurchsuchungen ( Strukturlink TABLE SCAN) nur 10 Prozent des Data-Cache für die Zwischenspeicherung der Tabelle genutzt, so dass die Tabelle eventuell nicht komplett im Data-Cache gehalten werden kann und beim nächsten Durchsuchen erneut physisch gelesen werden muss.


Selects and Fetches (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Selects and Fetches

<number of> selects and fetches, selectivity <percentage>%: <number of> rows read, <number of> rows qualified

Erläuterung

Bei SELECT- oder FETCH-Anweisungen sind die Strategien für den Zugriff auf Tabellendaten schlecht. Es müssen viele Tabellenzeilen gelesen werden, um die wenigen Zeilen zu finden, die eine WHERE-Bedingung erfüllen.

Benutzerreaktion

Versuchen Sie die Anweisung zu finden, die zu dem schlechten Verhältnis zwischen gelesenen und gefundenen Zeilen führt, und überprüfen Sie die Zugriffsstrategien für diese Anweisung.

Informationen zur Erstellung optimaler SQL-Anweisungen finden Sie in der Dokumentation Strukturlink SQL-Optimierer.


Table scans (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Table scans

<number of> table scans, selectivity <percentage>%: <number of> rows read, <number of> rows qualified

Erläuterung

Bei Tabellendurchsuchungen ( Strukturlink TABLE SCAN) ist das Verhältnis zwischen gelesenen und gefundenen Zeilen schlecht. Dies deutet oft auf eine schlechte Strukturlink Suchstrategie hin, die entweder durch die Anwendung (fehlende oder unzureichende Indizes etc.) oder durch ein Problem bei der SELECT-Optimierung des Datenbankkerns verursacht wird.

Das Durchsuchen von großen Tabellen kann die Performance des Gesamtsystems gravierend vermindern.

Benutzerreaktion

Versuchen Sie die Anweisung zu finden, die zu dem schlechten Verhältnis zwischen gelesenen und gefundenen Zeilen führt, und überprüfen Sie die Zugriffsstrategien für diese Anweisung.

Informationen zur Erstellung optimaler SQL-Anweisungen finden Sie in der Dokumentation Strukturlink SQL-Optimierer.


User task blocked in state (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation User task blocked in state

User task <task_ID> blocked in state '<state_description>'

User task <task_ID> blocked in state '<state description>', DB procedure: <DB_procedure_name>

Erläuterung

Die angegebene Strukturlink User-Task ist aktiv, ändert jedoch ihren Strukturlink Task-Zustand nicht. Dadurch werden auch alle anderen Tasks, die sich im selben Strukturlink User-Kernel-Thread befinden, blockiert. Im Extremfall befindet sich die blockierende Task in einer Endlosschleife.


User task physical writes (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation User task physical writes

User task physical writes: <count>

Erläuterung

Es findet eine Verdrängung geänderter Seiten aus dem Strukturlink Data-Cache in den Strukturlink Datenbereich statt, da die von den Anwendungen verwendeten Daten nicht vollständig im Data-Cache gehalten werden können.

Bei ausreichendem Data-Cache würde das physische Schreiben bis zum nächsten Strukturlink Savepoint verzögert werden und dann asynchron erfolgen. Cache-Verdrängungen führen dagegen zu synchronen Schreib- und Lesevorgängen und sollten möglichst vermieden werden.

Bei längeren Ladeläufen (Datenimport) kommt es fast zwangsläufig zu Verdrängungserscheinungen, da das importierte Datenvolumen in der Regel die Größe des Data-Cache weit übersteigt.

Benutzerreaktion

Vergrößern Sie den Data-Cache.


Loader (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Loader

Einsatzmöglichkeiten

Der Loader ermöglicht den Export aus einer MaxDB-Datenbankinstanz in das Dateisystem oder den Import von Anwendungsdaten aus dem Dateisystem in eine MaxDB-Datenbankinstanz.

Da der Loader eine große Anzahl von Dateiformaten unterstützt, kann er häufig anstelle von speziellen Anwendungsprogrammen zum Exportieren und Importieren von Daten verwendet werden. Der Loader bietet hierbei wegen seiner Spezialisierung auf MaxDB-Datenbankinstanzen maximale Performance.

Darüber hinaus unterstützt der Loader den direkten Transport von Daten einer Datenbankinstanz in eine andere, die auf einer unterschiedlichen Hardware-Architektur oder einem unterschiedlichen Betriebssystem läuft.

Optional können die gesamten Daten einer Datenbankinstanz, die eines speziellen Datenbankbenutzers, die eines speziellen Datenbankschemas, einzelne Tabellen oder auch nur einer Menge qualifizierter Spalten transportiert werden. Als Transportmedien werden neben Dateien Pipes und Sicherungswerkzeuge anderer Anbieter unterstützt.

Der Loader ist ein Kommandozeilenwerkzeug und kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden.

Einführungshinweise

Der Loader ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

...

● Aufrufen des Loader

● Kommandos und SQL-Anweisungen

● Protokollfunktionen

Übersichten

● Syntaxregeln: alphabetisch sortiert

● Syntaxregeln: semantisch sortiert

● Begriffe: Übersicht

● Schlüsselwörter: Übersicht

● Strukturlink Objekte im Schema HOTEL

Siehe auch:

Installationshandbuch, Strukturlink Verzeichnisse


Aufrufen des Loader (SAP-Bibliothek - Werkzeuge)

Prozessdokumentation Aufrufen des Loader

Das Datenbankwerkzeug Loader besteht aus einem Client-Teil und einem Server-Teil. Der Loader-Client übermittelt die zu verarbeitenden Kommandos. Der Loader-Server stellt die Verbindung zur Datenbankinstanz her und verarbeitet die Kommandos.

Siehe auch: Konzepte des Datenbanksystems, Strukturlink Architektur der Datenbankwerkzeuge

Die erforderlichen Softwarekompenenten des Loader können Sie durch Angabe folgender Installationsprofile installieren: Loader oder All.

Siehe auch: Installationshandbuch, Strukturlink Installationsprofile

Ablauf

In Abhängigkeit davon, welchen Client des Loader Sie verwenden, unterscheidet sich der Aufruf des Loader-Server.

● Aufrufoptionen des Loader CLI

● Perl-Handbuch, Strukturlink Modul SAP::DBTech::loader

● Python-Handbuch, Strukturlink Modul sdb.loader

● Java-Handbuch, Strukturlink Loader-Java-Klassen

Syntaxregeln bei Aufruf des Loader

Beachten Sie die folgenden allgemeinen Syntaxregeln bei Aufruf des Loader.

● Groß- und Kleinschreibung
Es erfolgt keine Unterscheidung zwischen Groß- und Kleinschreibung. Der Loader wandelt alle Namen intern in Großbuchstaben um, es sei denn, Sie setzen Zeichenketten in doppelte Anführungszeichen.

● Schlüsselwörter
Sowohl die Schlüsselwörter des Loader als auch die SQL-Schlüsselwörter können als Bezeichnungen für Datenbankobjekte verwendet werden, wenn sie in einfache oder doppelte Anführungszeichen gesetzt werden.

Diese Dokumentation enthält nur einen kurzen Abriss über jene Funktionen der Skriptsprachen, die im Loader Verwendung finden. Für darüber hinausgehende Informationen verwenden Sie bitte die Herstellerdokumentation zu Perl, Python oder Java.

Siehe auch:

Schlüsselwörter: Übersicht

SQL-Referenzhandbuch, Strukturlink Schlüsselwort (key_word)


Aufrufoptionen des Loader CLI (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Aufrufoptionen des Loader CLI

Der Aufruf des Loader kann mittels des Clients Loader CLI (LOADERCLI) erfolgen. Durch Angabe entsprechender Optionen können Sie die Einstellung des Betriebsmodus steuern, Verbindungsinformationen usw. übergeben.

Vorgehensweise

Sie können beim Aufruf des Loader CLI Optionen angeben.

loadercli [<options>]

Eine Übersicht über alle Optionen erhalten Sie durch Aufruf der Hilfe.

loadercli -h

Erläuterung

Die Eingabe an den Loader kann über drei Betriebsmodi erfolgen: den interaktiven Transportmodus, den Kommandodateimodus und den Sitzungsmodus.

● Im Transportmodus werden vom Benutzer interaktiv Eingaben abgefragt, um Anwendungsdaten aus einer Datenbankinstanz zu exportieren und in eine andere Datenbankinstanz zu importieren. Anhand der Eingabeparameter und der Loader-Konfigurationsdatei wird die Syntax der Loader-Kommandos generiert und ausgeführt.

Die generierten Loader-Kommandos werden optional an der Konsole ausgegeben und können dem Benutzer als Vorlage für selbst verfasste Loader-Kommandos dienen. Im Transportmodus selbst ist kein Wissen über die Loader-Syntax erforderlich.

● Im Kommandodateimodus wird eine vom Benutzer selbst verfasste Kommandodatei sequentiell abgearbeitet. Die Kommandodatei kann im Gegensatz zum Transportmodus eine beliebige Sequenz aus Loader-Kommandos und SQL-Anweisungen enthalten. In den meisten Anwendungsfällen ist eine leichte Modifikation der im Transportmodus generierten Loader-Kommandos ausreichend, um eine Kommandodatei zu erstellen.

● Im Sitzungsmodus kann der Benutzer die Loader-Kommandos und SQL-Anweisungen über die Konsole direkt an den Loader übermitteln.

Optionen, um den Betriebsmodus einzustellen

Die Option, die zur Bestimmung des gewünschten Betriebsmodus erforderlich ist, muss immer angegeben werden.

options

-p [<package_name>]

Der Loader CLI wird in den Transportmodus überführt, wenn Sie die Option –p angeben.

siehe auch: Transportmodus

-b <command_file>
[<connect_options>]
[<in_output_options>]
[<version_options>]

Der Loader CLI wird in den Kommandodateimodus überführt, wenn Sie die Option –b angeben.

siehe auch: Kommandodateimodus

<command_file>

Kommandodatei

[<connect_options>]
[<in_output_options>]
[<version_options>]

Der Loader CLI wird in den Sitzungsmodus überführt, wenn Sie weder die Option –p noch die Option –b angeben.

Siehe auch: Sitzungsmodus

Optionen zum Übergeben von Verbindungsinformationen

Sie können Verbindungsinformationen übergeben.

connect_options

-d <database_name> | Name der Datenbankinstanz
-u <database_user>[,<password>] | Name des Datenbankbenutzers und sein Kennwort
-n <database_computer>[:<port>] | Name des Datenbankrechners
-s <database_schema> | Name des Schemas
-e <encryption> | Verschlüsselungsmethode

Siehe auch:

Optionen für Verbindungsaufbau

Optionen zum Steuern der Ein- und Ausgabe

Sie können die Ein- und Ausgabe steuern.

in_output_options

-o[w|a] <file_name> | Name der Ausgabedatei
-cs <separator> | Angabe eines Kommandotrenners
-ps <number><string> | Angabe eines Ersetzungsparameters
-E <number> | Anzahl der maximal zulässigen Fehler

Siehe auch:

Optionen für Ein- und Ausgabe

Optionen zum Ermitteln von Versionsinformationen

Sie können Versionsinformationen ermitteln.

version_options

-V | Version des Loader-Server
-v | Version des Loader CLI
-R <dependent_path> | Verzeichnis, das die von der Version der Datenbanksoftware abhängigen Programme enthält

Siehe auch:

Optionen zum Ermitteln von Versionsinformationen

Beispiele

Loader-Tutorial, Strukturlink Transportmodus, Strukturlink Kommandodateimodus, Strukturlink Sitzungsmodus

Ergebnis

Zum Aufbau der Verbindung zur Datenbankinstanz wertet der Loader CLI zunächst die entsprechenden Optionen aus. Anschließend führt der Loader die interaktiv eingegebenen oder in der Kommandodatei vorhandenen Kommandos und SQL-Anweisungen aus.

Der Loader schreibt in allen drei Betriebsmodi eine Protokolldatei und gegebenenfalls weitere Informationen.

Siehe auch:

Protokolldatei

Protokollfunktionen

Fehler

Treten bei der Bearbeitung von Kommandos oder SQL-Anweisungen Fehler auf, ist das Verhalten des Loader abhängig davon, in welchem Betriebsmodus er verwendet wurde.

● Transportmodus: Der Loader bricht bei Auftreten eines Fehlers die Verarbeitung der Kommandos und SQL-Anweisungen ab. Für Detailinformationen werden Protokolldateien geschrieben. Für den Export und Import werden die Fehler in der Protokolldatei geschrieben. Im Falle eines Transports gibt es für den Export und den Import je eine separate Protokolldatei.

● Kommandodateimodus: Der Loader bricht bei Auftreten einer definierten Anzahl von Fehlern die Verarbeitung der Kommandos und SQL-Anweisungen ab und beendet sich. Mit der Option –E legen Sie die Anzahl der Fehler fest, die der Loader ignorieren soll, bevor er die Verarbeitung weiterer Kommandos abbricht. Wird die Option –E nicht angegeben, wird nach dem ersten fehlerhaften Kommando die Bearbeitung abgebrochen. Eine Reaktion auf die Fehler ist bei Verwenden des Loader CLI nicht möglich.

● Sitzungsmodus: Der Loader meldet den aufgetretenen Fehler und erwartet danach weitere Eingaben zur Bearbeitung.

Um auf Fehler reagieren zu können, wird die Funktionalität des Loader als Bibliothek für die Skriptsprachen Perl und Python zur Verfügung gestellt.

Siehe auch:

Perl-Handbuch, Strukturlink Modul SAP::DBTech::loader

Python-Handbuch, Strukturlink Modul sdb.loader


Transportmodus (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Transportmodus

Im Transportmodus werden vom Benutzer interaktiv Eingaben abgefragt, um Anwendungsdaten aus einer Datenbankinstanz zu exportieren und in eine andere Datenbankinstanz zu importieren. Anhand der Eingabeparameter und der Loader-Konfigurationsdatei wird die Syntax der Loader-Kommandos generiert (Phase Generate) und ausgeführt (Phase Execute).

Die generierten Loader-Kommandos werden optional an der Konsole ausgegeben und können dem Benutzer als Vorlage für selbst verfasste Loader-Kommandos dienen. Im Transportmodus selbst ist kein Wissen über die Loader-Syntax erforderlich.

Verwendung

Im Transportmodus entwirft der Benutzer in einem interaktiven Menü ein Transformationspaket, indem er die Richtung des Transports (Export aus einer Datenbankinstanz, Import in eine Datenbankinstanz oder Transport zwischen Datenbankinstanzen), die Datenbankverbindungsparameter und den zu transportierenden Datenbankteil eingibt. Damit ist der Inhalt des Pakets festgelegt, das transportiert werden soll. Optional kann der Benutzer beim Entwurf des Pakets den Datenträgertyp und das Format wählen, in das die Anwendungsdaten während des Transports transformiert werden sollen.

Syntax

Sie können den Loader CLI im interaktiven Transportmodus starten. Geben Sie dazu folgendes Kommando ein:

loadercli –p [<package_timestamp>]

<package_timestamp>

Name eines generierten Pakets (Phase Generate), für das ein Export oder Transport ausgeführt werden kann (Phase Execute)
oder
Name eines beim Export entstandenen Paketes (Phase Execute), das importiert werden kann

Vorschlagswert: Zeitstempel, der angibt, wann das Paket erzeugt wurde

Beispiele

Loader-Tutorial, Strukturlink Transportmodus

Funktionsumfang

Bei einem Export im Transportmodus wird ein Transformationspaket entworfen. Dieses Paket besteht zusätzlich zu den Entwurfsdaten aus den entsprechenden Datenbankkatalog- und Anwendungsdaten und den dazugehörigen Laufzeitdaten der Transformation, wie z.B. der Transport-Protokolldatei.

Dieses Paket können Sie zur Ausführung bringen, d.h. der Loader arbeitet die durch das Paket festgelegte Folge von Loader-Kommandos, den Transformationen, Schritt für Schritt ab (Phase Execute).

Sie müssen ein einmal entworfenes Paket nicht sofort zur Ausführung bringen, sondern Sie können sich auf das Generieren der Folge der Loader-Kommandos beschränken (Phase Generate). Dieses generierte Paket können Sie zu einem späteren Zeitpunkt unverändert oder mit geringfügigen Modifikationen ausführen (Phase Execute). Sie können ein generiertes Transformationspaket interaktiv oder mit Hilfe der entsprechenden Transportmodusoptionen zur Ausführung bringen.

Der Benutzer hat nach einem Export die Möglichkeit den Import des Pakets in eine andere Datenbankinstanz durch die Angabe des Paketnamens zu starten (interaktiv oder Angabe des Paketnamens nach der Option -p). Auch in diesem Fall können Sie das Importpaket entweder generieren oder sofort ausführen lassen.

Sie können ein Export- und das entsprechende Importpaket gemeinsam entwerfen und generieren oder sogar zur Ausführung bringen, wenn Sie die Transformationsart Transport wählen.

Generierte Entwurfsdaten

Die generierten Entwurfsdaten eines Pakets umfassen folgende Dateien:

● Kommandodatei: <timestamp>.EXPORT bzw. <timestamp>.IMPORT
Diese Datei enthält die aus den Entwurfsdaten generierte Sequenz von Loader-Kommandos. Die Datei kann vom Benutzer modifiziert und im Kommandodateimodus des Loader zur Ausführung gebracht werden.

● Interne Dateien: <timestamp>.xml, <timestamp>.pkg, <timestamp>.par, <timestamp>.cfg
Diese Dateien beinhalten interne Daten und dürfen nicht verändert werden.

Datenbankkatalogdaten

Die Datenbankkatalogdaten eines Pakets umfassen eine oder mehrere CATALOG-Dateien, je nachdem, welche Granularität des Datenbankkatalogs beim Export ausgewählt wurde.

● <database_name>.CATALOG: Alle Metadaten der angegebenen Datenbank wurden transformiert.

● <database_user>.CATALOG: Die Metadaten, deren Eigentümer der angegebene Benutzer ist, wurden transformiert.

● <schema_name>.CATALOG: Die Metadaten des angegebenen Schemas wurden transformiert.

● <table_name>.CATALOG: Die Metadaten der angegebenen Tabelle wurden transformiert.

Anwendungsdaten

Die Anwendungsdaten eines Pakets umfassen eine oder mehrere Datendateien, je nachdem, welche Granularität für die Daten beim Export ausgewählt wurde.

● Mappingdatei:
<database_name>.DATA0000
| <database_user>.DATA0000
| <schema_name>.DATA0000
Die Anwendungsdaten der angegebenen Datenbank, des Benutzers oder des Schemas wurden transformiert.

● Datendatei:
<database_name>.DATA000[<FILENO>]
| <database_user>.DATA000[<FILENO>]
| <schema_name>.DATA000[<FILENO>]
FILENO ist eine mit 1 beginnende, fortlaufende Nummerierung der Dateien für die Anwendungsdaten, falls die Datenmenge einer Datei 2 GB übersteigt.
Die Anwendungsdaten der angegebenen Datenbank, des Benutzers oder des Schemas wurden transformiert.

● Anwendungsdaten der Tabellen außer den Werten der LONG-Spalten: <table_name>.DATA
Die Anwendungsdaten der angegebenen Tabelle wurden transformiert.

● Anwendungsdaten der LONG-Spalten: <table_name>_<column_name>.DATA[<ROWNO>]
ROWNO ist eine mit 1 beginnende, fortlaufende Nummerierung der Datendateien, falls die LONG-Werte pro Spaltenwert in eine separate Datei exportiert wird.
Die Anwendungsdaten der angegebenen LONG-Spalte der Tabelle wurden transformiert.

Laufzeitdaten

Die Laufzeitdaten eines Pakets sind in der PACKAGE-Datei <timestamp>.PACKAGE enthalten.

Ergebnis

Die gewünschten Kommandos werden entworfen und generiert und gegebenenfalls ausgeführt.

Jedes Paket erhält einen Zeitstempel package_timestamp, der angibt, wann das Paket erstmalig generiert oder ausgeführt wurde. Wenn die Vorschlagswerte nicht geändert werden, ist dieser Zeitstempel auch der Name des Paketes.

Die Export- und Importpakete werden im Paketverzeichnis <loader_user_data>\packages in folgenden Unterverzeichnissen abgelegt:

  • EXPORT-Verzeichnis:
    export\<database_computer>\<database_name>\<package_timestamp>
  • IMPORT-Verzeichnis:
    import\<database_computer>\<database_name>\<package_timestamp>
  • Transport: EXPORT- und IMPORT-Verzeichnis werden genutzt

Protokollierung

Der Loader schreibt im Transportmodus folgende Protokolle:

● Protokolldatei loader_<timestamp>.log

● Transformationshistorie transport.log

Konfiguration

Die Konfiguration der Pakete über die Konfigurationsdatei loader.cfg bietet dem Benutzer die Möglichkeit, seine spezifischen Einstellungen vorzunehmen. Die Konfigurationsdatei loader.cfg befindet sich im Verzeichnis <loader_application_data>\config.

Sie können z.B. im Abschnitt [PACKAGE] Einstellungen für die Erstellung des Paketes (wie soll der Name gewählt werden, wo sollen die Pakete abgelegt werden usw.) konfigurieren. Beachten Sie bei Einträgen in die Konfigurationsdatei die Groß- und Kleinschreibung.

Siehe auch:

Aufrufoptionen des Loader CLI

Konzepte des Datenbanksystems, Strukturlink Protokolldateien, Strukturlink Konfigurationsdateien

Installationshandbuch, Strukturlink Verzeichnisse


Kommandodateimodus (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Kommandodateimodus

Im Kommandodateimodus wird eine vom Benutzer selbst verfasste Kommandodatei sequentiell abgearbeitet. Die Kommandodatei kann eine beliebige Sequenz aus Loader-Kommandos und SQL-Anweisungen enthalten.

Verwendung

Sie können den Loader CLI im Kommandodateimodus starten. Geben Sie dazu folgendes Kommando ein:

loadercli –b <command_file>

Wenn Sie z.B. Verbindungsinformationen bereits bei Aufruf des Loader CLI übergeben möchten, verwenden Sie zusätzlich die entsprechenden Optionen.

loadercli –b
<command_file>
[<connect_options>]
[<in_output_options]
[<version_options>]

Funktionsumfang

Geben Sie nach der Option –b den Namen der Kommandodatei und optional die gewünschten Optionen zum Verbindungsaufbau, zur Ein- und Ausgabesteuerung und zu Versionsabfragen an.

command_file

<command_file>

Kommandodatei

siehe auch: Kommandodatei

connect_options

-d <database_name> | Name der Datenbankinstanz
-u <database_user>[,<password>] | Name des Datenbankbenutzers und sein Kennwort
-n <database_computer>[:<port>] | Name des Datenbankrechners Vorschlagswert: lokaler Rechner
-s <schema_name> | Name des Datenbankschemas Vorschlagswert: Schema des aktuellen Datenbankbenutzers
-e <encryption> | Verschlüsselungsmethode Möglicher Wert: SSL (momentan wird nur die SSL/TLS-Verschlüsselung in SAP-Systemen unterstützt)

siehe auch: Optionen für Verbindungsaufbau

in_output_options

-o[w|a] <file_name> | Name der Ausgabedatei
-cs <separator> | Angabe eines Kommandotrenners
-ps <number><string> | Angabe eines Ersetzungsparameters
-E <number> | Anzahl der maximal zulässigen Fehler

siehe auch: Optionen für Ein- und Ausgabe

version_options

-V | Version des Loader-Server
-v | Version des Loader CLI
-R <dependent_path> | Verzeichnis, das die von der Version der Datenbanksoftware abhängigen Programme enthält

siehe auch: Optionen zum Ermitteln von Versionsinformationen

Beispiele

loadercli -b command.dat -d demodb -u mona,red –E 20

Der Loader stellt eine Verbindung zur Datenbankinstanz DEMODB für den Benutzer MONA her. Der Loader arbeitet die in der Kommandodatei command.dat enthaltenen Kommandos und SQL-Anweisungen ab.

Wenn dabei Fehler (Returncode <> 0) auftreten, wird die Abarbeitung abgebrochen, sobald 20 Fehlermeldungen aufgetreten sind.

Weitere Beispiele finden Sie im Loader-Tutorial, Strukturlink Kommandodateimodus.

Erläuterung

Der Loader liest die Kommandos und SQL-Anweisungen aus der angegebenen Kommandodatei <command_file> und übermittelt diese an den Loader-Server.

Eine Kommandodatei kann auch durch Generieren der Entwurfsdaten im Transportmodus erzeugt werden.

Siehe auch:

Aufrufoptionen des Loader CLI

Protokolldatei


Kommandodatei (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Kommandodatei

Definition

Beim Aufrufen des Loader mit dem Loader CLI können Sie die Kommandos und SQL-Anweisungen, die ausgewertet werden sollen, in einer speziellen Datei, der Kommandodatei, an den Loader übergeben.

Verwendung

Wenn Sie den Loader im Kommandodateimodus aufrufen wollen, müssen Sie den Namen der Kommandodatei durch Angabe der Option –b <command_file> übergeben. Gegebenenfalls können Sie weitere Optionen übergeben (Optionen für Verbindungsaufbau, Optionen für Ein- und Ausgabe, Optionen zum Ermitteln von Versionsinformationen).

Beispiele

loadercli -d demodb -u mona,red -n genua -b command.dat

Name der Datenbankinstanz, Datenbankbenutzerangaben und Rechnername werden über entsprechende Optionen übergeben. Die Kommandos und SQL-Anweisungen befinden sich in der Datei command.dat.

Die in der Kommandodatei von Ihnen angegebenen Kommandos und SQL-Anweisungen werden vom Loader einzeln in der angegebenen Reihenfolge abgearbeitet.

Weitere Beispiele finden Sie im Loader-Tutorial, Strukturlink Kommandodateimodus.

Struktur

Beachten Sie die folgenden Syntaxregeln für Kommandodateien:

● Allgemeine Syntaxregeln

Es gelten die Syntaxregeln wie bei Aufrufen des Loader.

● Trennzeile zwischen Kommandos

Einzelne Kommandos in einer Kommandodatei werden durch eine Zeile, an deren Zeilenanfang ein doppelter Schrägstrich // steht, voneinander getrennt.

Ein von den Schrägstrichen abweichender Kommandotrenner kann mit der Option –cs beim Aufruf des Loader CLI definiert werden (Optionen für Ein- und Ausgabe).

● Kommentare

Nach einem doppelten Schrägstrich // am Zeilenanfang können Kommentare eingegeben werden. Die Kommentare werden bei der Bearbeitung der Kommandodatei vom Loader ignoriert.

Integration

Eine Kommandodatei kann auch durch Generieren der Entwurfsdaten im Transportmodus erzeugt werden.


Sitzungsmodus (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Sitzungsmodus

Im Sitzungsmodus kann der Benutzer die Loader-Kommandos und SQL-Anweisungen über die Konsole direkt an den Loader übermitteln.

Verwendung

Sie können den Loader CLI im Sitzungsmodus starten. Geben Sie dazu folgendes Kommando ein:

loadercli

Wenn Sie z.B. Verbindungsinformationen bereits bei Aufruf des Loader CLI übergeben möchten, verwenden Sie zusätzlich die entsprechenden Optionen.

loadercli
[<connect_options>]
[<in_output_options]
[<version_options>]

Funktionsumfang

Geben Sie die gewünschten Optionen zum Verbindungsaufbau, zur Ein- und Ausgabesteuerung und zu Versionsabfragen an.

connect_options

-d <database_name> | Name der Datenbankinstanz
-u <database_user>[,<password>] | Name des Datenbankbenutzers und sein Kennwort
-n <database_computer>[:<port>] | Name des Datenbankrechners Vorschlagswert: lokaler Rechner
-s <schema_name> | Name des Datenbankschemas Vorschlagswert: Schema des aktuellen Datenbankbenutzers
-e <encryption> | Verschlüsselungsmethode Möglicher Wert: SSL (momentan wird nur die SSL/TLS-Verschlüsselung in SAP-Systemen unterstützt)

siehe auch: Optionen für Verbindungsaufbau

in_output_options

-o[w|a] <file_name> | Name der Ausgabedatei
-cs <command_separator> | Angabe eines Kommandotrenners Vorschlagswert: ENTER
-ps <number><string> | Angabe eines Ersetzungsparameters
-E <number> | Anzahl der maximal zulässigen Fehler

siehe auch: Optionen für Ein- und Ausgabe

version_options

-V | Version des Loader-Server
-v | Version des Loader CLI
-R <dependent_path> | Verzeichnis, das die von der Version der Datenbanksoftware abhängigen Programme enthält

siehe auch: Optionen zum Ermitteln von Versionsinformationen

Beispiele

loadercli -d demodb -u mona,red -s hotel

Der Loader stellt eine Verbindung zur Datenbankinstanz DEMODB für den Benutzer MONA im Schema HOTEL her. Danach erwartet der Loader die Kommandos und SQL-Anweisungen auf der Kommandozeile. Diese müssen jeweils mit einem ENTER abgeschlossen werden, damit der Loader sie verarbeitet.

loadercli -d demodb -u mona,red -cs ;

Der Loader stellt eine Verbindung zur Datenbankinstanz DEMODB für den Benutzer MONA her. Der Loader erwartet die Kommandos und SQL-Anweisungen auf der Kommandozeile. Diese müssen jeweils mit einem Semikolon abgeschlossen werden, damit der Loader sie verarbeitet.

Weitere Beispiele finden Sie im Loader-Tutorial, Strukturlink Sitzungsmodus.

Erläuterung

Nach dem Start des Loader CLI im Sitzungsmodus können Sie interaktiv mehrere Kommandos und SQL-Anweisungen eingeben.

Kommandotrenner

Vorschlagswert für einen Kommandotrenner ist ein ENTER. Wenn Sie eine Zeile innerhalb eines mehrere Zeilen umfassenden Loader-Kommandos mit einem Schrägstrich („/“) abschließen, erkennt der Loader CLI, dass das Kommando noch nicht vollständig ist. Es wird deshalb bei Eingabe des Kommandotrenners ENTER noch nicht ausgeführt. Erst die Eingabe des Kommandotrenners ENTER ohne vorhergehenden Schrägstrich zeigt dem Loader CLI an, dass das Kommando vollständig eingegeben wurde.

Dieses Verhalten können Sie durch Definition eines anderen Kommandotrenners mittels der Option –cs <command_separator> ändern. Wenn Sie z.B. ein Semikolon als Kommandotrenner wählen, können Sie jedes Kommando ohne besonderen Abschluss über mehrere Zeilen schreiben. Erst die Eingabe des Kommandotrenners Semikolon zeigt dem Loader CLI, dass das Kommando vollständig eingegeben wurde.

Nach Erreichen des Kommandotrenners wird das Kommando an den Loader-Server übermittelt und von diesem ausgeführt. Nach der Bearbeitung der einzelnen Kommandos und SQL-Anweisungen gibt der Loader CLI eine Meldung aus.

Um den Sitzungsmodus zu beenden, geben Sie release oder exit und den Kommandotrenner ein.

Siehe auch:

Aufrufoptionen des Loader CLI

Protokolldatei


Optionen für Verbindungsaufbau (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Optionen für Verbindungsaufbau

Verwendung

Im Kommandodatei- oder Sitzungsmodus können Sie Optionen für den Verbindungsaufbau angeben.

connect_options

-d <database_name> | Name der Datenbankinstanz
-u [<database_user>,<password>] | Name des Datenbankbenutzers und sein Kennwort
-n <database_computer>[:<port>] | Name des Datenbankrechners Vorschlagswert: lokaler Rechner
-s <schema_name> | Name des Datenbankschemas Vorschlagswert: Schema des aktuellen Datenbankbenutzers
-e <encryption> | Verschlüsselungsmethode Möglicher Wert: SSL (momentan wird nur die SSL/TLS-Verschlüsselung in SAP-Systemen unterstützt)

Beispiele

Loader-Tutorial, Strukturlink Kommandodateimodus, Strukturlink Sitzungsmodus

Erläuterung

-d <database_name>

Der Loader baut eine Verbindung zur angegebenen Datenbankinstanz database_name auf. Dabei führt der Loader implizit das Loader-Kommando USE DB oder bei gleichzeitiger Angaben von Datenbankinstanzname und Benutzerdaten das Loader-Kommando USE USER aus.

Der Name der Datenbankinstanz kann auch mit Hilfe der Kommandos USE DB oder USE USER übermittelt werden und damit während der Loader-Sitzung gewechselt werden.

-u [<database_user>,<password>]

Voraussetzung für die Verwendung dieser Option ist, dass Sie gleichzeitig die Option –d zur Angabe einer Datenbankinstanz verwenden.

Wenn Sie die Option –u ohne die Angabe der Benutzerdaten <database_user>,<password> verwenden, werden Sie vom Loader nach der Benutzername-/Kennwort-Kombination gefragt. Auf diese Weise vermeiden Sie, dass das Benutzerkennwort in der Kommandozeile, Kommandohistorie sowie in der Prozessliste des Betriebssystems sichtbar wird.

Für den angegebenen Benutzer wird eine Datenbanksitzung aufgebaut. Dabei führt der Loader implizit das Loader-Kommando USE USER aus. Benutzername und Kennwort werden vom Datenbanksystem automatisch in Großbuchstaben umgewandelt.

Benutzerdaten können auch mit Hilfe des Kommandos USE USER übermittelt werden. Dadurch ist ein Benutzerwechsel während einer Loader-Sitzung möglich.

-n <database_computer>[:<port>]

Voraussetzung für die Verwendung dieser Option ist, dass Sie gleichzeitig die Option –d oder die Optionen –d und –u verwenden.

Der Loader baut eine Verbindung zur Datenbankinstanz auf dem angegebenen Rechner database_computer auf. Dabei führt der Loader implizit das Loader-Kommando USE DB oder bei gleichzeitiger Angaben von Datenbankinstanzname und Benutzerdaten das Loader-Kommando USE USER aus.

Der Name des Datenbankrechners kann auch mit Hilfe der Kommandos USE DB oder USE USER übermittelt werden.

-s <schema_name>

Voraussetzung für die Verwendung dieser Option ist, dass Sie gleichzeitig die Optionen –d und –u verwenden.

Der Loader baut eine Verbindung zum angegebenen Schema auf.

Der Name des Schemas kann auch mit Hilfe der Kommandos USE SCHEMA, USE USER oder SET CURRENT SCHEMA übermittelt werden.

-e <encryption>

Voraussetzung für die Verwendung dieser Option ist, dass Sie Ihr SAP-System für die Verschlüsselung konfiguriert haben.

Sie schalten die Verschlüsselungsfunktion ein und wählen die Verschlüsselungsmethode für die Kommunikation.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Datenverschlüsselung


Optionen für Ein- und Ausgabe (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Optionen für Ein- und Ausgabe

Verwendung

Im Kommandodatei- oder im Sitzungsmodus können Sie Optionen zum Ermitteln von Versionsinformationen angeben.

in_output_options

-o[w|a] <file_name> | Name der Ausgabedatei
-cs <separator> | Angabe eines Kommandotrenners
-ps <number><string> | Angabe eines Ersetzungsparameters
-E <number> | Anzahl der maximal zulässigen Fehler

Beispiele

Loader-Tutorial, Strukturlink Kommandodateimodus, Strukturlink Sitzungsmodus

Erläuterung

-o[w|a] <file_name>

Wenn Sie im Kommandodateimodus arbeiten, können Sie mit dieser Option steuern, dass die Ausgaben des Loader in die angegebene Datei file_name geschrieben werden. Im Sitzungsmodus wird diese Option vom Loader nicht ausgewertet.

Vorschlagswert: Wenn Sie die Option nicht angeben, erfolgen die Ausgaben des Loader auf dem Bildschirm.

● Option –ow <file_name>
Die Datei wird zum Schreiben geöffnet und eventuell vorhandene Einträge werden gelöscht.

● Option –oa <file_name>
Die Datei wird zum Schreiben geöffnet und die Ausgaben werden an das Dateiende angehangen, ohne dass vorherige Einträge gelöscht werden.

Die Option bezieht sich ausschließlich auf die Ausgaben des Loader. Unabhängig davon schreibt der Loader noch eine Protokolldatei.

-cs <command_separator>

Mit dieser Option können Sie bestimmen, welche Zeichen vom Loader CLI als Kommandotrenner command_separator erkannt werden sollen. Durch einen Kommandotrenner wird ein Loader-Kommando abgeschlossen und kann vom Loader bearbeitet werden.

Ein Kommandotrenner darf mindestens ein, maximal zwei Zeichen enthalten.

● Kommandodateimodus
Vorschlagswert: Ein Kommando wird durch eine Zeile, an deren Zeilenanfang ein doppelter Schrägstrich // steht, abgeschlossen.

Wenn Sie mit der Option –cs einen Kommandotrenner festlegen, wird ein Kommando durch diesen Kommandotrenner abgeschlossen.

siehe auch: Syntaxregeln für Kommandodatei

● Sitzungsmodus
Vorschlagswert: Ein Kommando wird durch die Eingabe von ENTER abgeschlossen.
Um ein Kommando auf der Folgezeile fortzusetzen, erwartet der Loader CLI in diesem Fall am Ende der Zeile einen einfachen Schrägstrich (/).

Wenn Sie mit der Option –cs einen Kommandotrenner festlegen, wird ein Kommando durch diesen Kommandotrenner abgeschlossen.
Um ein Kommando auf der Folgezeile fortzusetzen, erwartet der Loader CLI in diesem Fall am Ende der Zeile ein ENTER.

Aufruf des Loader im Kommandodateimodus

loadercli -b command.dat -d demodb -u mona,red –cs ;

-ps <number> <substitution_value>

Mit dieser Option bestimmen Sie Werte für Platzhalter in der Kommandodatei. Der Wert number definiert die Nummern des zu ersetzenden Platzhalters in der Kommandodatei (1<=n<=9). Mittels substitution_value geben Sie den Wert an, der den Platzhalter ersetzen soll. Diese Werte können beliebige Zeichenketten sein.

Sie können 9 verschiedene Parameter (und damit Platzhalter) pro Kommandodatei festlegen. In der Kommandodatei geben Sie die Platzhalter in der Form &<number> ein.

-E <number>

Sie legen mit dieser Option fest, nach welcher Anzahl fehlerhaft ausgeführter Kommandos <number> der Loader die weitere Abarbeitung der Kommandodatei abbricht.

Aufruf des Loader im Kommandodateimodus

loadercli -b command.dat -d demodb -u mona,red –E 20

Der Loader stellt eine Verbindung zur Datenbankinstanz DEMODB für den Benutzer MONA her. Der Loader arbeitet die in der Kommandodatei command.dat enthaltenen Kommandos und SQL-Anweisungen ab. Wenn dabei Fehler (Returncode <> 0) auftreten, wird die Abarbeitung abgebrochen, sobald 20 Fehlermeldungen aufgetreten sind.


Optionen zum Ermitteln von Versionsinformationen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Optionen zum Ermitteln von Versionsinformationen

Verwendung

Im Kommandodatei- oder im Sitzungsmodus können Sie Optionen zum Ermitteln von Versionsinformationen angeben.

version_options

-V | Version des Loader-Server
-v | Version des Loader CLI
-R <dependent_path> | Verzeichnis, das die von der Version der Datenbanksoftware abhängigen Programme enthält

Erläuterung

-R <dependent_path>

Wenn mehrere Loader-Versionen auf dem Rechner installiert sind, haben Sie die Möglichkeit, den Loader einer bestimmten Version zu starten. Geben Sie dazu den Namen des Verzeichnisses <dependent_path> auf dem Rechner des Loader an, das die von der Version der Datenbanksoftware abhängigen Programme enthält. Wenn Sie keinen Verzeichnisnamen angeben, wird immer der Loader der aktuellsten Version der Datenbanksoftware gestartet.

Siehe auch:

Installationshandbuch, Strukturlink Verzeichnisse


Kommandos und SQL-Anweisungen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Kommandos und SQL-Anweisungen

Verwendung

Der Loader kann Kommandos und SQL-Anweisungen ausführen.

Funktionsumfang

Aufbau einer Datenbanksitzung

Die Kommandos und SQL-Anweisungen zum Exportieren und Importieren können nur nach einem erfolgreichen Aufbau einer Datenbanksitzung ausgeführt werden. Somit ist sichergestellt, dass nur entsprechend autorisierte Eigentümer exportieren und importieren können.

Siehe dazu:

Aufbau einer Datenbanksitzung: Kommandos

Exportieren und Importieren

Eine wesentliche Funktionalität des Loader ist das Exportieren und Importieren des Datenbankkatalogs, von Teilen des Datenbankkatalogs und von Anwendungsdaten. Für diese Zwecke stehen eine Reihe von Kommandos mit ihren Syntaxelementen zur Verfügung.

Siehe dazu:

Exportieren: Kommandos

Importieren: Kommandos

Siehe können Spaltenwerte ändern.

Siehe dazu:

UPDATE COLUMNS-Kommando

SQL-Anweisungen

Der Loader ist in der Lage, die für das Exportieren und Importieren erforderlichen SQL-Anweisungen durchzuführen. Insbesondere die DDL-Anweisungen sind beim Importieren von Daten unentbehrlich (SQL-Referenzhandbuch, Strukturlink SQL-Anweisungen: Überblick).

Datenbankabfragen liefern lediglich Statusmeldungen.

COMMIT und ROLLBACK-Anweisungen wirken nur im Modus AUTOCOMMIT OFF (AUTOCOMMIT-Kommando).

Siehe auch:

Glossar, Strukturlink Variablen in der Dokumentation


Aufbau einer Datenbanksitzung: Kommandos (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Aufbau einer Datenbanksitzung: Kommandos

Verwendung

Der Loader kann eine Reihe von Kommandos und SQL-Anweisungen verarbeiten, unter anderem Kommandos, die beim Aufbau einer Loader-Sitzung verwendet werden können.

Funktionsumfang

● AUTOCOMMIT-Kommando

● SET-Kommando

● SQLMODE-Kommando

● USE DB-Kommando

● USE SCHEMA-Kommando

● USE SCHEMAMAP-Kommando

● USE USER-Kommando

Siehe auch:

Optionen für Verbindungsaufbau

Syntaxregeln: alphabetisch sortiert

Syntaxregeln: semantisch sortiert


AUTOCOMMIT-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation AUTOCOMMIT-Kommando

Mit dem AUTOCOMMIT-Kommando zum Aufbau einer Datenbanksitzung schalten Sie den AUTOCOMMIT-Modus für eine Datenbanksitzung ein und aus.

Syntax

<autocommit_command> :: = AUTOCOMMIT ON | AUTOCOMMIT OFF

Erläuterung

Wenn dieses Kommando nicht verwendet wird, arbeitet der Loader implizit mit eingeschaltetem AUTOCOMMIT-Modus.

AUTOCOMMIT ON

Der AUTOCOMMIT-Modus wird eingeschaltet (Vorschlagswert des Loader).

Bei Kommandos zum Importieren wird das Einfügen einer bestimmten Anzahl von Datensätzen mit einem COMMIT abgeschlossen. Diese Anzahl von Datensätzen kann vom Benutzer durch das Kommando SET TRANSACTION SIZE festgelegt werden. Beim Exportieren von Daten hat dieser Modus keine Bedeutung, da die Tabelleninhalte in der Datenbank nicht verändert werden.

Wenn bei eingeschaltetem AUTOCOMMIT-Modus COMMIT- und ROLLBACK-Anweisungen ausgeführt werden, werden diese vom Loader ignoriert.

Jede SQL-Anweisung wird vom Loader implizit mit einem COMMIT abgeschlossen.

AUTOCOMMIT OFF

Der AUTOCOMMIT-Modus wird ausgeschaltet.

Alle Transaktionen, müssen explizit durch ein COMMIT beendet werden.

Sie haben die Möglichkeit, Kommandos zu Einheiten zusammenfassen, um sie insgesamt abzuschließen oder zurückzusetzen.

Für Kommandos, die außerhalb des Transaktionskonzeptes der Datenbank ablaufen und daher vom Loader stets implizit mit einem commit abgeschlossen werden, gilt dieser Modus nicht.

Bei großen Transaktionen (z.B. viele zu ladende Datensätze) muss der Log-Bereich entsprechend groß sein.

Siehe auch:

Aufbau einer Datenbanksitzung: Kommandos


SET-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation SET-Kommando

Mit diesem Kommando des Loader können Sie viele Eigenschaften einer Loader-Sitzung festlegen. Sie haben die Möglichkeit, voreingestellte Werte der Steuerparameter des Loader Ihren eigenen Anforderungen anzupassen.

Die neu eingestellten Werte gelten nur für die jeweilige Loader-Sitzung und müssen für die nachfolgenden Loader-Sitzungen bei Bedarf wieder neu eingestellt werden. Die Werte können durch ein erneutes SET-Kommando oder gegebenenfalls durch Loader-Kommandos geändert werden.

Syntax

<set_commando> ::= SET
| SET <bool_spec>
| SET <code_page_spec>
| SET <isolation_level_spec>
| SET <null_spec>
| SET <number_spec>
| SET BACKUPTOOL <backup_tool_spec>
| SET CODETYPE <standard_code_spec>
| SET CONFIGURATION <exclude_include>
| SET CSV '/<separator>/<delimiter>/'
| SET CURRENT_SCHEMA = <schema_name>
| SET DATE <standard_date_mask>
| SET FORMAT <standard_date_mask>
| SET MAXERRORCOUNT <unigned_integer>
| SET TIME <standard_time_mask>
| SET TIMESTAMP <standard_timestamp_mask>
| SET TRANSACTION SIZE <unsigned_integer>

<bool_spec> ::= BOOLEAN '<true_value>/<false_value>'
<code_page_spec> ::= CODEPAGE [<literal>]
<isolation_level_spec> ::= ISOLATION LEVEL <unsigned_integer>
<null_spec> ::= NULL-Wert-Darstellung
<number_spec> ::= DECIMAL '/[<digit_grouping_symbol>]/<decimal_symbol>/'

<backup_tool_spec>        ::=
BACKINT | NETWORKER | TSM
<standard_code_spec>      ::= Code-Spezifikation
<exclude_include>         ::=
EXCLUDE | INCLUDE
<separator>               ::=
<character>
<delimiter>               ::=
<character>
<schema_name>             ::=
<identifier>
<standard_date_mask>      ::= Datumsangaben
<standard_time_mask>      ::= Zeitangaben
<standard_timestamp_mask> ::= Zeitstempelangaben

SET-Kommando ohne weitere Angaben

Anzeige folgender Protokollinformationen:

- Name und vollständiger Pfad des Loader-Protokolls

- Vollständiger Pfad zu dem Verzeichnis, in dem der Loader die Pakete speichert, die im Transportmodus angelegt werden

BOOLEAN '<true_value>/<false_value>'

true_value: Definiert die Zeichenkette für Werte, die wahr sind, Vorschlagswert: TRUE

false_value: Definiert die Zeichenkette für Werte, die falsch sind, Vorschlagswert: FALSE

Die Zeichenketten dürfen höchstens 10 Zeichen lang sein.

siehe auch: SQL-Referenzhandbuch, Strukturlink Zeichenkette

CODEPAGE [<literal>]

literal: Name der Code-Page
Vorschlagswert: ISO-8859-1

Die Angabe eines leeren Wertes setzt eine einmal gesetzte Code-Page auf den Vorschlagswert zurück.

siehe auch: SQL-Referenzhandbuch, Strukturlink Literal (literal)

ISOLATION LEVEL <unsigned_integer>

unsigned_integer: Wert des einzustellenden Isolation-Levels, Vorschlagswert: 3

siehe auch: SQL-Referenzhandbuch, Strukturlink CONNECT-Anweisung (connect_statement), Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

DECIMAL '/[<digit_grouping_symbol>]
/<decimal_symbol>/'

digit_grouping_symbol: Definiert ein Zeichen oder kein Zeichen für die Gliederung von Tausendern
Vorschlagswert: kein Zeichen

decimal_symbol: Definiert das Zeichen zum Trennen der Dezimalstellen
Vorschlagswert: Punkt

Als Zeichen sind Zahlen nicht zugelassen.

siehe auch: SQL-Referenzhandbuch, Strukturlink Zeichen (character)

BACKUPTOOL <backup_tool_spec>
<backup_tool_spec> ::= BACKINT | NETWORKER | TSM

Sie können festlegen, welches Sicherungswerkzeug für das Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter verwendet werden soll.

BACKINT: Sicherungswerkzeuge anderer Anbieter, die
Backint for MaxDB und Backint for Oracle unterstützen
NETWORKER: Sicherungswerkzeug NetWorker (Legato)
TSM: Sicherungswerkzeug TSM (IBM/Tivoli)

CONFIGURATION <exclude_include>
<exclude_include> ::= EXCLUDE | INCLUDE

EXCLUDE: Negativliste
Die in der Konfigurationsdatei aufgeführten Tabellen sollen nicht bearbeitet werden.

INCLUDE: Positivliste
Die in der Konfigurationsdatei aufgeführten Tabellen sollen bearbeitet werden.

CSV '/<separator>/<delimiter>/'
<separator> ::= <character>
<delimiter> ::= <character>

separator: Zeichen, mit dem Datenfelder bei Verwenden des CSV-Formats voneinander getrennt werden (Separator-Darstellung), Vorschlagswert: Komma (,)

Es muss genau ein Zeichen angegeben werden, das aus dem 7-Bit-ASCII-Zeichensatz stammt (nur 1 Byte lang).

delimiter: Zeichen, mit dem Daten bei Verwenden des CSV-Formats in Markierungen eingeschlossen werden (Delimiter-Darstellung), Vorschlagswert: doppeltes Anführungszeichen (")

Es kann genau ein Zeichen, das aus dem 7-Bit-ASCII-Zeichensatz stammt (nur 1 Byte lang) oder kein Zeichen (kein Delimiter) angegeben werden.

siehe auch: SQL-Referenzhandbuch, Strukturlink Zeichen (character)

CURRENT_SCHEMA = <schema_name>
<schema_name> ::= <identifier>

Das Schema schema_name wird als aktuelles Schema festgelegt
Vorschlagswert: Schema, das dem angemeldeten Datenbankbenutzer zugeordnet ist

siehe auch: SQL-Referenzhandbuch, Strukturlink Schemaname (schema_name), Strukturlink Bezeichner (identifier)

MAXERRORCOUNT <unigned_integer>

unsigned_integer: Anzahl der Fehler, die der Loader akzeptiert

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

TRANSACTION SIZE <unsigned_integer>

unsigned_integer: Anzahl der Datensätze, nach denen ein COMMIT durchgeführt wird

Erläuterung

Einige der Möglichkeiten des SET-Kommandos werden im Folgenden detaillierter erläutert.

SET <bool_spec>

Sie legen mit der Syntaxregel SET <bool_spec> die Zeichenkette fest, mit der aus der Datenbankinstanz exportierte bzw. in eine Datenbankinstanz zu importierende BOOLEAN-Werte in Datenströmen repräsentiert werden. Diese Einstellung gilt für die gesamte Loader-Sitzung, sofern die Zeichenketten nicht durch ein erneutes SET BOOLEAN-Kommando geändert wird.

Sie haben die Möglichkeit, für einzelne Kommandos den aktuellen Wert durch Verwenden des Syntaxelements bool_spec zur Definition des Datenformats (field_format_spec) zu ändern.

SET <code_page_spec>

Soll bei der Konvertierung von CHAR-Daten von ASCII nach UCS2 eine bestimmte Code-Page verwendet werden, dann kann diese mit dem SET-Kommando SET <code_page_spec> angegeben werden.

SET CODEPAGE "8859-14"
SET CODEPAGE WINDOS-1252

Fall 1: Die für die Konvertierung zu verwendende Code-Page ist eine benutzerdefinierte Code-Page und noch nicht in der Systemtabelle CODEPAGE enthalten.

Um benutzerdefinierte Code-Pages dem Loader für Konvertierungen zugänglich zu machen, müssen Sie diese Code-Pages zuerst in die Systemtabelle CODEPAGE laden. Verfahren Sie dazu wie folgt:

...

1. Legen Sie im benutzerspezifischen Konfigurationsverzeichnis des Loader (Microsoft Windows: <drive>:\Documents and Settings\<user_id>\Application Data\sdb\loader\config, UNIX: $HOME/sdb/loader/config) eine Datei <literal>.txt an. Diese Datei muss wie die Dateien formatiert sein, die vom UNICODE-Konsortium unter ftp://ftp.unicode.org/Public/MAPPINGS/ zur Verfügung gestellt werden.

...
# Format: Three ab-separated columns
# Column #1 is the ISO/IEC 8859-8 code (in hex as 0xXX)
# Column #2 is the Unicode (in hex as 0xXXXX)
# Column #3 the Unicode name (follows a comment sign, '#')
...
0x00 0x0000 # NULL
0x01 0x0001 # START OF HEADING
0x02 0x0002 # START OF TEXT
0x03 0x0003 # END OF TEXT
0x04 0x0004 # END OF TRANSMISSION
0x05 0x0005 # ENQUIRY
0x06 0x0006 # ACKNOWLEDGE
0x07 0x0007 # BELL
0x08 0x0008 # BACKSPACE
0x09 0x0009 # HORIZONTAL TABULATION
0x0A 0x000A # LINE FEED

2. Melden Sie sich als Datenbanksystemadministrator an die Datenbankinstanz an.

3. Laden Sie die Code-Page in die Systemtabelle CODEPAGE.
Verwenden Sie dazu das SET-Kommando. Der Loader versucht bei der Bearbeitung des SET-Kommandos SET CODEPAGE <literal> zuerst, die angegebene Code-Page in der Systemtabelle CODEPAGE zu finden. Wenn sie dort nicht enthalten ist, versucht er die zugehörige Datei <literal>.txt zu finden. Wenn diese Datei vorhanden ist, wird die Datei gelesen und die Konvertierungstabelle in die Systemtabelle CODEPAGE eingetragen.

Wenn die Datei nicht gefunden wird und die Code-Page auch nicht in der Systemtabelle enthalten ist, bricht der Loader die Bearbeitung des SET-Kommandos mit einem Fehler ab.

Die benutzerdefinierte Code-Page steht bei erfolgreicher Abarbeitung des SET-Kommandos in der Systemtabelle CODEPAGE zur Verfügung.

Fall 2: Die für die Konvertierung zu verwendende Code-Page ist bereits in der Systemtabelle CODEPAGE enthalten.

Der Loader liest die gewünschte Konvertierungstabelle aus der Systemtabelle CODEPAGE. Alle nachfolgenden Konvertierungen der CHAR-Daten von ASCII nach UCS2 werden mit Hilfe dieser Konvertierungstabelle durchgeführt.

SET <isolation_level_spec>

Sie legen mit der Syntaxregel SET ISOLATION LEVEL <unsigned_integer> den Wert des Isolation-Levels (zulässige Werte: 0, 1, 10, 15, 2, 20, 3, 30) fest. Wenn Sie keinen Isolation-Level einstellen, wird der Isolation-Level 3 angenommen. Diese Einstellung gilt für die gesamte Loader-Sitzung, sofern der Isolation-Level nicht durch ein erneutes SET ISOLATION LEVEL-Kommando geändert wird.

Für einen Benutzer können Sie den Isolation-Level durch das USE USER-Kommando einstellen und damit den durch das SET-Kommando eingestellten Wert übersteuern.

SET <number_spec>

Sie legen mit der Syntaxregel SET <number_spec> fest, welche Zeichen bei Dezimalzahlen zu verwenden sind, um Tausender zu gliedern und die Dezimalstellen zu trennen. Werden keine Zeichen vorgeschlagen, verwendet der Loader den jeweiligen Vorschlagswert. Diese Einstellung gilt für die gesamte Loader-Sitzung, sofern das Nummernformat nicht durch ein erneutes SET DECIMAL-Kommando geändert wird.

SET DECIMAL '/ /,/'
Ergibt folgendes Nummernformat: 1 999 987,98

SET DECIMAL '///'
Ergibt folgendes Nummernformat (Vorschlagswert des Loader): 1999987.98

Sie haben die Möglichkeit, für einzelne Kommandos den aktuellen Wert durch Verwenden des Syntaxelements number_spec zur Definition des Datenformats (field_format_spec) zu ändern.

SET CSV '/<separator>/<delimiter>/'

Sie legen mit der Syntaxregel SET CSV '/<separator>/<delimiter>/' die Zeichen fest, die im Format CSV als Separator und Delimiter verwendet werden sollen. Diese Einstellung gilt für die gesamte Loader-Sitzung, sofern der Separator und der Delimiter nicht durch ein erneutes SET CSV-Kommando geändert wird.

Sie haben die Möglichkeit, für einzelne Kommandos den aktuellen Wert durch Verwenden des Syntaxelements separator_spec bzw. delimitor_spec zur Definition des Datenformats (csv_format_spec) zu ändern.

SET CURRENT SCHEMA = <schema_name>

Das angegebene Schema wird als aktuelles Schema festgelegt. Diese Einstellung gilt für die gesamte Loader-Sitzung, sofern das Schema nicht durch ein erneutes SET CURRENT SCHEMA-Kommando geändert wird. Für einen Benutzer können Sie diesen Wert durch ein USE USER-Kommando oder USE SCHEMA-Kommando einstellen und damit den durch das SET-Kommando eingestellten Wert übersteuern.

SET FORMAT <standard_date_mask>

Sie legen mit dem Kommando fest, in welchem Format der Loader Datums- und Zeitwerte in SQL-Anweisungen an die Datenbank übermittelt. Der Loader übermittelt bei der Bearbeitung von Loader-Kommandos Datums- und Zeitwerte grundsätzlich im Format INTERNAL. Sollen in SQL-Anweisungen eingebettete Datums- und Zeitwerte in einem anderen Format übermittelt werden, muss dieses mit diesem Kommando explizit eingestellt werden. Diese Einstellung gilt für die gesamte Loader-Sitzung, sofern das Format nicht durch ein erneutes SET FORMAT-Kommando geändert wird.

INSERT INTO <table_name> values ('2005-01-01', 1)

Da hier das Datum im Format ISO übermittelt werden soll, muss das Format mit SET FORMAT ISO gesetzt werden.

SET MAXERRORCOUNT <unsigned_integer>

Sie legen mit der Syntaxregel SET MAXERRORCOUNT <unsigned_integer> fest, wie viele Fehler der Loader bei der Ausführung eines einzelnen Kommandos akzeptiert, bevor er die Bearbeitung des Kommandos abbricht. Diese Einstellung gilt für die gesamte Loader-Sitzung, sofern die Fehleranzahl nicht durch ein erneutes SET MAXERRORCOUNT-Kommando geändert wird.

Siehe auch:

Aufbau einer Datenbanksitzung: Kommandos


SQLMODE-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation SQLMODE-Kommando

Mit dem SQLMODE-Kommando des Loader können Sie beim Aufbau einer Datenbanksitzung den SQL-Modus der Datenbankinstanz angeben.

Syntax

<sql_mode_command> ::= SQLMODE <sql_mode>

<sql_mode> ::= INTERNAL | ANSI | DB2 | ORACLE

INTERNAL | Datenbanksysteminterner SQL-Modus (Vorschlagswert des Systems))
ANSI | SQL-Dialekt entsprechend des ANSI-Standards (ANSI X3.135-1992, Entry SQL)
DB2 | SQL-Dialekt entsprechend der Definition für DB2 Version 4
ORACLE | SQL-Dialekt entsprechend der Definition für ORACLE7

Erläuterung

Die vom Loader auszuführenden Kommandos zum Exportieren und Importieren und die SQL-Anweisungen werden entsprechend des eingestellten SQL-Modus interpretiert, wenn der Datenstrom nicht das Format PAGES hat.

Der festgelegte SQL-Modus gilt solange, bis er mit Hilfe des SET SQLMODE-Kommandos wieder geändert wird.

● Ohne Angabe eines SQL-Modus wird der SQL-Modus INTERNAL verwendet.

● Den SQL-Modus können Sie innerhalb einer Kommandodatei oder eines Skriptes mit Hilfe des SQLMODE-Kommandos wechseln.

Siehe auch:

Aufbau einer Datenbanksitzung: Kommandos


USE DB-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation USE DB-Kommando

Mit dem USE DB-Kommando des Loader zum Aufbau einer Datenbanksitzung können Sie die Verbindung zu einer anderen Datenbankinstanz aufbauen.

Syntax

<use_database_command> ::= USE DB <database_spec>

<database_spec> ::= <database_name>
[ON <database_computer> [ENCRYPTION <protocol_name>]]

<database_name>

Name der Datenbankinstanz

Gilt für die gesamte Loader-Sitzung mit dieser Datenbankinstanz

Wenn der Name der Datenbankinstanz mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden.

siehe dazu: Konzepte des Datenbanksystems, Strukturlink Konventionen für Datenbanknamen

<database_computer>

Name des Rechners, auf dem die Datenbankinstanz installiert ist, für die eine Loader-Sitzung eröffnet werden soll

Wird diese Angabe nicht gemacht, geht der Loader davon aus, dass die angegebene Datenbankinstanz auf dem Rechner angelegt wurde, auf dem der Benutzer an den Loader angemeldet ist.

<protocol_name>

Name des Verschlüsselungsprotokolls

Zusätzlich kann nach dem Schlüsselwort ENCRYPTION der Name des gewünschten Verschlüsselungsprotokolls protocol_name angegeben werden, um eine verschlüsselte Datenübertragung zu gewährleisten. Zur Zeit wird diese Möglichkeit nur für SAP-Systeme und SSL unterstützt.

Beispiele

USE USER mona red DB demodb ON genua

//

USE DB demodb ON parma

Der Benutzer MONA ist an der Datenbankinstanz DEMODB auf dem Rechner GENUA angemeldet. Sie wechseln mit dem USE DB-Kommando zur Datenbankinstanz DEMODB auf dem Rechner PARMA.

Erläuterung

Sie wechseln mit dem USE DB-Kommando zu einer anderen Datenbankinstanz, ohne dass der Loader verlassen werden muss. Die Verbindung zur bisherigen Datenbankinstanz wird beendet und die neue Verbindung zu der angegebenen Datenbankinstanz aufgebaut. Auf der neuen Datenbankinstanz muss ein Datenbankbenutzer mit dem gleichen Namen und Kennwort existieren. Alle nachfolgenden Kommandos werden vom Loader auf diese Datenbankinstanz bezogen.

Diese Einstellung gilt, solange keine andere Datenbankinstanz durch ein USE DB-Kommando angegeben wird.

Siehe auch:

Aufbau einer Datenbanksitzung: Kommandos

Optionen für Verbindungsaufbau


USE SCHEMA-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation USE SCHEMA-Kommando

Mit dem USE SCHEMA-Kommando des Loader zum Aufbau einer Datenbanksitzung können Sie festgelegen, welches Schema der angemeldete Datenbankbenutzer verwenden soll.

Syntax

<use_schema_command> ::= USE SCHEMA <schema_name>

<schema_name> ::= <identifier>

<schema_name>

Name des Schemas, das der Datenbankbenutzer verwenden soll

Wenn der Name des Schemas mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden.

siehe auch: SQL-Referenzhandbuch, Strukturlink Schemaname (schema_name), Strukturlink Bezeichner (identifier)

Beispiele

USE SCHEMA hotel

Der angemeldete Datenbankbenutzer soll das Schema HOTEL verwenden.

Erläuterung

Sie können mit dem USE SCHEMA-Kommando festlegen, welches Schema der angemeldete Datenbankbenutzer verwenden soll. Diese Einstellung gilt, solange kein anderes Schema durch ein USE SCHEMA-, USE USER- oder SET CURRENT SCHEMA-Kommando angegeben wird.

Siehe auch:

Aufbau einer Datenbanksitzung: Kommandos

Optionen für Verbindungsaufbau


USE SCHEMAMAP-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation USE SCHEMAMAP-Kommando

Mit dem USE SCHEMAMAP-Kommando des Loader zum Aufbau einer Datenbanksitzung können Sie festgelegen, welches Schema-Map der angemeldete Datenbankbenutzer verwenden soll.

Voraussetzungen

Sie haben Schema-Maps mit der CREATE SCHEMAMAP-Anweisung erzeugt. Dadurch befinden sich in der Systemtabelle MAPSCHEMANAMES die erforderlichen Einträge.

Siehe auch:

CREATE/DROP SCHEMAMAP-Anweisung

MAPSCHEMANAMES

Syntax

<use_schema_map_command> ::= USE SCHEMAMAP <schema_map_name>

<schema_map_name> ::= <identifier>

<schema_map_name>

Name des Schema-Map, das der Datenbankbenutzer verwenden soll

Wenn der Name des Schema-Map mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden.

siehe auch: SQL-Referenzhandbuch, Strukturlink Bezeichner (identifier)

Beispiele

USE SCHEMAMAP hotel_to_mona

Der angemeldete Datenbankbenutzer soll das Schema-Map HOTEL_TO_MONA verwenden.

Erläuterung

Sie können mit dem USE SCHEMAMAP-Kommando festlegen, welches Schema-Map der angemeldete Datenbankbenutzer verwenden soll. Diese Einstellung für die Loader-Sitzung gilt, solange kein anderes Schema-Map durch ein USE SCHEMAMAP-Kommando oder IMPORT SCHEMA-Kommando angegeben wird.

Siehe auch:

Aufbau einer Datenbanksitzung: Kommandos

IMPORT SCHEMA-Kommando


CREATE/DROP SCHEMAMAP-Anweisung (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation CREATE/DROP SCHEMAMAP-Anweisung

Ein Schema-Map ist eine Abbildung der Daten eines Schemas auf ein anderes Schema.

Mit Hilfe der CREATE SCHEMAMAP-Anweisung können Sie ein Schema-Map anlegen. Mit Hilfe der DROP SCHEMAMAP-Anweisung können Sie ein Schema-Map löschen.

Syntax

<create_schema_map_statement> ::=
CREATE SCHEMAMAP <schema_map_name> MAP SCHEMA <schema_to_schema>,...

<drop_schema_map_statement> ::= DROP SCHEMAMAP <schema_map_name>

<schema_map_name> ::= <identifier>
<schema_to_schema> ::= <schema_name> TO <schema_name>
<schema_name> ::= <identifier>

<schema_map_name> | Name des Schema-Map Wenn der Name des Schema-Map mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden. siehe auch: SQL-Referenzhandbuch, Strukturlink Bezeichner (identifier)
<schema_name> | Name des Schemas Wenn der Name des Schemas mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden. siehe auch: SQL-Referenzhandbuch, Strukturlink Schemaname (schema_name)

Beispiele

CREATE SCHEMAMAP myschemamap MAP SCHEMA a1 TO b1, a2 TO b2
//
USE SCHEMAMAP myschemamap
//
IMPORT SCHEMA a1 ...
//

Die Daten des Schemas a1 werden auf das Schema b1 abgebildet. Diese Einstellung gilt für die gesamte Loader-Sitzung (USE SCHEMAMAP), sofern Sie nicht ein neues USE SCHEMAMAP-Kommando eingeben oder im IMPORT SCHEMA-Kommando eine andere Schema-Abbildung festlegen. Das IMPORT SCHEMA-Kommando geben Sie mit der üblichen Syntax an, d.h. der Schemaname der exportierten Daten wird im Import-Kommando angegeben.

IMPORT SCHEMA a1 ...
 MAP SCHEMA a1 TO b1, a2 TO b2
 CATALOG INSTREAM 'a1_csv.catalog'

Die Schema-Abbildung a1 TO b1, a2 TO b2 gilt nur für dieses IMPORT SCHEMA-Kommando. Das Schema-Map wird implizit angelegt und nach Ausführung des Kommandos sofort wieder gelöscht. Eine CREATE SCHEMAMAP-Anweisung ist nicht erforderlich.

IMPORT SCHEMA a1 ...
 MAP SCHEMA myschemamap
 CATALOG INSTREAM 'a1_csv.catalog'

Die Schema-Abbildung gilt nur für dieses IMPORT SCHEMA-Kommando. Dabei wird ein mit CREATE SCHEMAMAP vordefiniertes Schema-Map myschemamap verwendet.

Erläuterung

Wenn Sie mit der CREATE SCHEMAMAP-Anweisung ein Schema-Map anlegen, werden in der Systemtabelle MAPSCHEMANAMES der Schema-Map-Name und die beteiligten Schemanamen abgelegt. Die beteiligten Schemas müssen existieren.

Für jedes Schema einer Datenbankinstanz existiert ein DEFAULT-Schema-Map mit dem Namen ID, das dieses Schema auf sich selbst abbildet.

Die DROP SCHEMAMAP-Anweisung löscht die Einträge des in der Anweisung angegebenen Schema-Map aus der Tabelle MAPSCHEMANAMES.

Mit Hilfe des USE SCHEMAMAP-Kommandos oder des IMPORT SCHEMA-Kommandos können Sie das gewünschte Schema-Map verwenden.

Siehe auch:

MAPSCHEMANAMES

USE SCHEMAMAP-Kommando

IMPORT SCHEMA-Kommando


USE USER-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation USE USER-Kommando

Mit dem USE USER-Kommando des Loader zum Aufbau einer Datenbanksitzung können Sie eine Verbindung mit den angegebenen Informationen aufbauen.

Syntax

<use_user_command> ::= USE USER <user_spec> [SCHEMA <schema_name>]
[DB <database_spec>] [<isolation_level_spec>]

<user_spec> ::= <database_user> <password>
<schema_name> ::= <identifier>
<database_spec> ::= <database_name>
[ON <database_computer> [ENCRYPTION <protocol_name>]]
<isolation_level_spec> ::= ISOLATION LEVEL <unsigned_integer>

<database_user>

Name des Datenbankbenutzers

Der Datenbankbenutzername wird vom Datenbanksystem automatisch in Großbuchstaben umgewandelt. Wenn die Umwandlung nicht gewünscht ist, muss der Name in Anführungszeichen eingeschlossen werden.

siehe auch: SQL-Referenzhandbuch, Strukturlink Benutzername (user_name)

<password>

Kennwort

Das Datenbankbenutzerkennwort wird vom Datenbanksystem automatisch in Großbuchstaben umgewandelt. Wenn die Umwandlung nicht gewünscht ist, muss der Name in Anführungszeichen eingeschlossen werden.

siehe auch: SQL-Referenzhandbuch, Strukturlink Kennwort (password)

Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter

<schema_name>

Schema für den Datenbankbenutzer

Wenn der Name des Schemas mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden.

siehe auch: SQL-Referenzhandbuch, Strukturlink Schemaname (schema_name)

<database_name>

Name der Datenbankinstanz

Gilt für die gesamte Datenbanksitzung mit dieser Datenbankinstanz

Wenn der Name der Datenbankinstanz mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden.

siehe auch: Konzepte des Datenbanksystems, Strukturlink Konventionen für Datenbanknamen

<database_computer>

Name des Rechners, auf dem die Datenbankinstanz installiert ist, für die eine Datenbanksitzung eröffnet werden soll

Wird diese Angabe nicht gemacht, geht der Loader davon aus, dass die angegebene Datenbankinstanz auf dem Rechner angelegt wurde, auf dem der Benutzer an den Loader angemeldet ist.

<protocol_name>

Name des Verschlüsselungsprotokolls

Zusätzlich kann nach dem Schlüsselwort ENCRYPTION der Name des gewünschten Verschlüsselungsprotokolls valPROTOCOL_NAME angegeben werden, um eine verschlüsselte Datenübertragung zu gewährleisten. Zur Zeit wird diese Möglichkeit nur für SAP-Systeme und SSL unterstützt.

ISOLATION LEVEL <unsigned_integer>

unsigned_integer: Wert des einzustellenden Isolation-Levels

Vorschlagswert: 3

siehe auch: SQL-Referenzhandbuch, Strukturlink CONNECT-Anweisung (connect_statement)

Konzepte des Datenbanksystems, Strukturlink Isolation-Level

Beispiele

USE USER mona red DB demodb ON genua

Anmeldung als Benutzer MONA an der Datenbankinstanz DEMODB auf dem Rechner GENUA

USE USER mona red SCHEMA hotel DB demodb ON genua

Anmeldung als Benutzer MONA an der Datenbankinstanz DEMODB im Schema HOTEL auf dem Rechner GENUA

USE USER mona red DB demodb ON genua ISOLATION LEVEL 0

Festlegung des Isolation-Levels 0

Erläuterung

Die bestehende Verbindung des Loader zur Datenbankinstanz wird unterbrochen und eine neue Verbindung mit den angegebenen Parametern aufgebaut. Diese Einstellung gilt, solange keine neuen Parameter durch USE-Kommandos angegeben werden.

<schema_spec>

Sie können festlegen, in welchem Schema der Benutzer angemeldet werden soll. Wenn Sie kein Schema angeben, verwendete der Benutzer das Schema, das ihm zugeordnet ist. Diese Einstellung gilt, solange kein anderes Schema durch ein USE USER-, USE SCHEMA- oder SET CURRENT-SCHEMA-Kommando angegeben wird.

<database_spec>

Wenn Sie im USE USER-Kommando keinen Datenbankinstanznamen angeben, wird die neue Verbindung zu derjenigen Datenbankinstanz hergestellt, mit der vor dem USE USER-Kommando gearbeitet bzw. die durch die Option –u eingestellt wurde. Sie können mit dem USE DB-Kommando die Verbindung zu einer anderen Datenbankinstanz aufbauen.

<isolation_level_spec>

Für einen Benutzer können Sie den Isolation-Level durch das USE USER-Kommando einstellen und damit den durch das SET ISOLATION LEVEL-Kommando eingestellten Wert übersteuern. Wenn Sie keinen Isolation-Level angeben, wird der für die Datenbanksitzung gesetzte Wert verwendet.

Der aktuelle Isolation-Level-Wert kann auch in einem EXPORT COLUMNS-Kommando durch Angabe der entsprechenden Strukturlink LOCK-Option in der SELECT-Anweisung geändert werden.

Siehe auch:

Aufbau einer Datenbanksitzung: Kommandos

Optionen für Verbindungsaufbau


Exportieren: Kommandos (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Exportieren: Kommandos

Verwendung

Der Loader kann eine Reihe von Kommandos und SQL-Anweisungen verarbeiten, unter anderem loaderspezifische Kommandos zum Exportieren von Daten.

Voraussetzungen

Aufrufen des Loader

Aufbau einer Datenbanksitzung: Kommandos

Syntax

<export_command> ::=
< export_db_command >
| < export_user_command >
| < export_schema_command >
| < export_table_command >
| < export_columns_command >

Funktionsumfang

Der Sprachumfang des Loader ermöglicht es, bei zunehmender Granularität eine vollständige Datenbank, die Objekte eines Benutzers, die Objekte eines Schemas, die Daten einer Tabelle oder eine Menge von Spaltenwerten einer Tabelle zu exportieren.

Beispiele

Loader-Tutorial, Strukturlink Exportieren

Importieren

Importieren: Kommandos

Siehe auch:

UPDATE COLUMNS-Kommando

Syntaxregeln: alphabetisch sortiert

Syntaxregeln: semantisch sortiert


EXPORT DB-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation EXPORT DB-Kommando

Mit den EXPORT DB-Kommando des Loader können Sie die Daten, die zur Anwendung einer Datenbank gehören, exportieren.

Voraussetzungen

Das EXPORT DB-Kommando kann nur vom Datenbanksystemadministrator (SYSDBA-Benutzer) ausgeführt werden.

Syntax

<export_db_command> ::= EXPORT DB [<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>] [<restart_spec>]

<catalog_data_outstream_part_spec> ::= <catalog_outstream_spec>
| <data_outstream_part_spec>
| <catalog_outstream_spec> <data_outstream_part_spec>

EXPORT DB
[<configuration_spec>]
<catalog_outstream_spec>
<data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

Export der Daten der Anwendung der Datenbank (Datenbankkatalog und Anwendungsdaten)

EXPORT DB
<catalog_outstream_spec>
[<package_spec>]
[<restart_spec>]

Export der Datenbankkataloginformationen aller Datenbankbenutzer, die zur Anwendung der Datenbank gehören

EXPORT DB
[<configuration_spec>]
<data_outstream_part_spec>
[<package_spec>]
[<restart>]

Export der Anwendungsdaten aller Datenbankbenutzer

<configuration_spec>

CONFIGURATION <instream_csv_spec>

<catalog_outstream_spec>

CATALOG <outstream_ddl_spec>

<data_outstream_part_spec>

DATA <outstream_tableformat_spec>

<package_spec>

PACKAGE <outstream_csv_spec>

<instream_csv_spec>
<oustream_csv_spec>
<outstream_ddl_spec>
<outstream_tableformat_spec>

Datenstrom

<restart_spec>

RESTART <package_guid>
<package_guid> ::= <unsigned_integer>

unsigned_integer: ID, die zur Laufzeit vom Loader für jedes Kommando erzeugt wird. Diese ganze Zahl ist immer 24 Bytes lang.

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

Loader-Tutorial, Strukturlink EXPORT DB

Erläuterung

<catalog_outstream_spec>, <data_outstream_part_spec>

Beim Export werden je nachdem, ob Datenbankkatalog- und/oder Anwendungsdaten exportiert werden, folgende Datenströme erzeugt:

● Datenstrom für die Datenbankkatalogdefinitionen CATALOG <outstream_ddl_spec>

● Datenstrom für die Anwendungsdaten DATA <outstream_tableformat_spec>

Die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL und weitere Systemtabellen werden gefüllt.

Für den Datenstrom der Anwendungsdaten outstream_tableformat_spec ist nur eines der Formate PAGES oder RECORDS möglich.

Siehe auch:

Datenstrom

<configuration_spec>

Sie können Tabellen vom Export ausschließen.

● Ohne Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> werden die gesamten Anwendungsdaten exportiert.

● Durch die Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> können aus den Anwendungsdaten outstream_tableformat_spec die Anwendungsdaten ausgewählter Tabellen vom Export ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.
Die Angabe, welche Tabellen nicht exportiert werden sollen, wird in den Systemtabellen abgelegt. Eine Möglichkeit der Anzeige dieser Informationen ist die Anzeige der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL. Die vom Export der Anwendungsdaten ausgeschlossenen Tabellen besitzen in der Spalte EXCLUDE den Wert TRUE.

Die Datenbankkatalogeinträge CATALOG <outstream_ddl_spec> aller Tabellen werden unabhängig von den mittels CONFIGURATION <instream_csv_spec> gemachten Einschränkungen immer exportiert.

<package_spec>

Sie können die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL exportieren.

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert. Sie sollten diese Möglichkeit nutzen, um den Exportvorgang gut zu protokollieren.

● Ohne Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> wird die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL nicht exportiert.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

<restart_spec>

Sie können den Export wiederaufsetzen.

Der Benutzer kann die package_guid des entsprechenden Export-Kommandos aus der Tabelle SYSLOADER.TRANSFORMATIONMODEL oder der Protokolldatei ermitteln. Unter Verwendung des Syntaxelements restart_spec können Sie das Kommando mit der entsprechenden package_guid wiederaufsetzen.

Siehe auch:

Wiederaufsetzen

Verwenden von Sicherungswerkzeugen anderer Anbieter

Wenn das Exportieren von Daten mit den Loader-Kommandos zum Exportieren der gesamten Anwendungs- und/oder Datenbankkatalogdaten erfolgt (EXPORT DB), ist der Einsatz von Sicherungswerkzeugen anderer Anbieter möglich.

Siehe auch:

Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter

Ergebnis

Die Anwendungsdaten und/oder der Datenbankkatalog werden in die Datenströme data_outstream_part_spec und catalog_outstream_spec exportiert.

Gegebenenfalls werden alle Einträge der Tabelle TRANSFORMATIONMODEL in den Datenstrom package_spec exportiert.

Mit dem korrespondierenden IMPORT-Kommando können der Datenbankkatalog und/oder die Anwendungsdaten wiederaufgebaut werden.

Fehlerfall

Der Export kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Die Werte PACKAGEGUID und CLIENTNODE werden ebenfalls in die Protokolldatei geschrieben. Die PACKAGEGUID ist für ein eventuelles Wiederaufsetzen des Exports erforderlich.

Siehe auch:

Exportieren: Kommandos

IMPORT DB-Kommando

Protokolldatei

Systemtabellen


EXPORT USER-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation EXPORT USER-Kommando

Mit dem EXPORT USER-Kommando des Loader können Sie die Daten, die zur Anwendung des an die Datenbank angemeldeten Datenbankbenutzers gehören, exportieren.

Voraussetzungen

Mit dem EXPORT USER-Kommando können die Objekte exportiert werden, dessen Eigentümer der an die Datenbankinstanz angemeldete Datenbankbenutzer ist.

Syntax

<export_user_command> ::= EXPORT USER [<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>] [<restart>]

<catalog_data_outstream_part_spec> ::= <catalog_outstream_spec>
| <data_outstream_part_spec>
| <catalog_outstream_spec> <data_outstream_part_spec>

EXPORT USER
[<configuration_spec>]
<catalog_outstream_spec>
<data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

Export der Daten, die zur Anwendung des an die Datenbank angemeldeten Datenbankbenutzers gehören

EXPORT USER
<catalog_outstream_spec>
[<package_spec>]
[<restart_spec>]

Export der Datenbankkataloginformationen des angemeldeten Datenbankbenutzers, die zur Anwendung gehören

EXPORT USER
[<configuration_spec>]
<data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

Export der Anwendungsdaten des angemeldeten Datenbankbenutzers

<configuration_spec>

CONFIGURATION <instream_csv_spec>

<catalog_outstream_spec>

CATALOG <outstream_ddl_spec>

<data_outstream_part_spec>

DATA <outstream_tableformat_spec>

<package_spec>

PACKAGE <outstream_csv_spec>

<instream_csv_spec>
<outstream_csv_spec>
<outstream_ddl_spec>
<outstream_tableformat_spec>

Datenstrom

<restart_spec>

RESTART <package_guid>
<package_guid> ::= <unsigned_integer>

unsigned_integer: ID, die zur Laufzeit vom Loader für jedes Kommando erzeugt wird. Diese ganze Zahl ist immer 24 Bytes lang.

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

Loader-Tutorial, Strukturlink EXPORT USER

Erläuterung

<catalog_outstream_spec>, <data_outstream_part_spec>

Beim Export werden je nachdem, ob Datenbankkatalog- und/oder Anwendungsdaten exportiert werden, folgende Datenströme erzeugt:

● Datenstrom für die Datenbankkatalogdefinitionen CATALOG <outstream_ddl_spec>

● Datenstrom für die Anwendungsdaten DATA <outstream_tableformat_spec>

Die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL und weitere Systemtabellen werden gefüllt.

Für den Datenstrom der Anwendungsdaten outstream_tableformat_spec ist nur eines der Formate PAGES oder RECORDS möglich.

Siehe auch:

Datenstrom

<configuration_spec>

Sie können Tabellen vom Export ausschließen.

● Ohne Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> werden die gesamten Anwendungsdaten exportiert.

● Durch die Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> können aus den Anwendungsdaten outstream_tableformat_spec die Anwendungsdaten ausgewählter Tabellen vom Export ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.
Die Angabe, welche Tabellen nicht exportiert werden sollen, wird in den Systemtabellen abgelegt. Eine Möglichkeit der Anzeige dieser Informationen ist die Anzeige der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL. Die vom Export der Anwendungsdaten ausgeschlossenen Tabellen besitzen in der Spalte EXCLUDE den Wert TRUE.

Die Datenbankkatalogeinträge CATALOG <outstream_ddl_spec> aller Tabellen werden unabhängig von den mittels CONFIGURATION <instream_csv_spec> gemachten Einschränkungen immer exportiert.

<package_spec>

Sie können die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL exportieren.

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert. Sie sollten diese Möglichkeit nutzen, um den Exportvorgang gut zu protokollieren.

● Ohne Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> wird die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL nicht exportiert.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

<restart_spec>

Sie können den Export wiederaufsetzen.

Der Benutzer kann die package_guid des entsprechenden Export-Kommandos aus der Tabelle SYSLOADER.TRANSFORMATIONMODEL oder der Protokolldatei ermitteln. Unter Verwendung des Syntaxelements restart_spec können Sie das Kommando mit der entsprechenden package_guidwiederaufsetzen.

Siehe auch:

Wiederaufsetzen

Ergebnis

Die Anwendungsdaten und/oder der Datenbankkatalog werden in die Datenströme data_outstream_part_spec und catalog_outstream_spec exportiert.

Gegebenenfalls werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den Datenstrom package_spec exportiert.

Mit dem korrespondierenden IMPORT-Kommando können der Datenbankkatalog und/oder die Anwendungsdaten wiederaufgebaut werden.

Fehlerfall

Der Export kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Die Werte PACKAGEGUID und CLIENTNODE werden ebenfalls in die Protokolldatei geschrieben. Die PACKAGEGUID ist für ein eventuelles Wiederaufsetzen des Exports erforderlich.

Siehe auch:

Exportieren: Kommandos

IMPORT USER-Kommando

Protokolldatei

Systemtabellen


EXPORT SCHEMA-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation EXPORT SCHEMA-Kommando

Mit dem EXPORT SCHEMA-Kommando des Loader können Sie die Daten, die zur Anwendung des angegebenen Schemas gehören, exportieren.

Voraussetzungen

Das EXPORT SCHEMA-Kommando kann nur vom Eigentümer des Schemas ausgeführt werden.

Syntax

<export_schema_command> ::= EXPORT SCHEMA <schema_name>
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>] [<restart_spec>]

<catalog_data_outstream_part_spec> ::= <catalog_outstream_spec>
| <data_outstream_part_spec>
| <catalog_outstream_spec> <data_outstream_part_spec>

EXPORT SCHEMA <schema_name>
[<configuration_spec>]
<catalog_outstream_spec>
<data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

Export der Daten, die zur Anwendung des angegebenen Schemas gehören

EXPORT SCHEMA <schema_name>
<catalog_outstream_spec>
[<package_spec>]
[<restart_spec>]

Export der Datenbankkataloginformationen, die zur Anwendung des Schemas gehören

EXPORT SCHEMA <schema_name>
[<configuration_spec>]
<data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

Export der Anwendungsdaten des angegebenen Schemas

<schema_name>

Schemaname

Wenn der Name des Schemas mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden.

<schema_name> ::= <identifier>

siehe auch: SQL-Referenzhandbuch, Strukturlink Schemaname (schema_name)

<configuration_spec>

CONFIGURATION <instream_csv_spec>

<catalog_outstream_spec>

CATALOG <outstream_ddl_spec>

<data_outstream_part_spec>

DATA <outstream_tableformat_spec>

<package_spec>

PACKAGE <outstream_csv_spec>

<instream_csv_spec>
<outstream_csv_spec>
<outstream_ddl_spec>
<outstream_tableformat_spec>

Datenstrom

<restart_spec>

RESTART <package_guid>
<package_guid> ::= <unsigned_integer>

unsigned_integer: ID, die zur Laufzeit vom Loader für jedes Kommando erzeugt wird. Diese ganze Zahl ist immer 24 Bytes lang.

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

Loader-Tutorial, Strukturlink EXPORT SCHEMA

Erläuterung

<catalog_outstream_spec>, <data_outstream_part_spec>

Beim Export werden je nachdem, ob Datenbankkatalog- und/oder Anwendungsdaten exportiert werden, folgende Datenströme erzeugt:

● Datenstrom für die Datenbankkatalogdefinitionen CATALOG <outstream_ddl_spec>

● Datenstrom für die Anwendungsdaten DATA <outstream_tableformat_spec>

Die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL und weitere Systemtabellen werden gefüllt.

Für den Datenstrom der Anwendungsdaten outstream_tableformat_spec ist nur eines der Formate PAGES oder RECORDS möglich.

Siehe auch:

Datenstrom

<configuration_spec>

Sie können Tabellen vom Export ausschließen.

● Ohne Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> werden die gesamten Anwendungsdaten exportiert.

● Durch die Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> können aus den Anwendungsdaten outstream_tableformat_spec die Anwendungsdaten ausgewählter Tabellen vom Export ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.
Die Angabe, welche Tabellen nicht exportiert werden sollen, wird in den Systemtabellen abgelegt. Eine Möglichkeit der Anzeige dieser Informationen ist die Anzeige der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL. Die vom Export der Anwendungsdaten ausgeschlossenen Tabellen besitzen in der Spalte EXCLUDE den Wert TRUE.

Die Datenbankkatalogeinträge CATALOG <outstream_ddl_spec> aller Tabellen werden unabhängig von den mittels CONFIGURATION <instream_csv_spec> gemachten Einschränkungen immer exportiert.

<package_spec>

Sie können die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL exportieren.

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert. Sie sollten diese Möglichkeit nutzen, um den Exportvorgang gut zu protokollieren.

● Ohne Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> wird die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL nicht exportiert.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

<restart_spec>

Sie können den Export wiederaufsetzen.

Der Benutzer kann die package_guid des entsprechenden Export-Kommandos aus der Tabelle SYSLOADER.TRANSFORMATIONMODEL oder der Protokolldatei ermitteln. Unter Verwendung des Syntaxelements restart_spec können Sie das Kommando mit der entsprechenden package_guidwiederaufsetzen.

Siehe auch:

Wiederaufsetzen

Ergebnis

Die Anwendungsdaten und/oder der Datenbankkatalog werden in die Datenströme data_outstream_part_spec und catalog_outstream_spec exportiert.

Gegebenenfalls werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den Datenstrom package_spec exportiert.

Mit dem korrespondierenden IMPORT-Kommando können der Datenbankkatalog und/oder die Anwendungsdaten wiederaufgebaut werden.

Fehlerfall

Der Export kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Die Werte PACKAGEGUID und CLIENTNODE werden ebenfalls in die Protokolldatei geschrieben. Die PACKAGEGUID ist für ein eventuelles Wiederaufsetzen des Exports erforderlich.

Siehe auch:

Exportieren: Kommandos

Import SCHEMA-Kommando

Protokolldatei

Systemtabellen


EXPORT TABLE-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation EXPORT TABLE-Kommando

Mit diesem Kommando des Loader können Sie die gesamten Daten einer angegebenen Tabelle exportieren.

Voraussetzungen

Die angegebene Tabelle muss in der Datenbankinstanz vorhanden sein.

Das Kommando EXPORT TABLE...PAGES kann nur vom Eigentümer der Tabelle ausgeführt werden. In allen anderen Fällen müssen Sie die Zugriffsberechtigung für die zu exportierende Tabelle haben.

Syntax

<export_table_command> ::= EXPORT TABLE <table_name>
                                       [<order_clause>]
                                        <catalog_data_outstream_table_spec>
[<package_spec>]

<catalog_data_outstream_table_spec> ::= <catalog_outstream_spec>
| <data_outstream_table_spec>
| <catalog_outstream_spec> <data_outstream_table_spec>

EXPORT TABLE <table_name> [<order_clause>] <catalog_outstream_spec> <data_outstream_table_spec> [<package_spec>] | Export der Daten der angegebenen Tabelle (Datenbankkatalog und Anwendungsdaten)
EXPORT TABLE <table_name> <catalog_outstream_spec> [<package_spec>] | Export der Datenbankkataloginformationen der angegebenen Tabelle
EXPORT TABLE <table_name> [<order_clause>] <data_outstream_table_spec> [<package_spec>] | Export der Anwendungsdaten der angegebenen Tabelle

<table_name> | Tabellenname
<order_clause> | ORDER BY <column_name>,...
<column_name> | Spaltenname <column_name> ::= <identifier> siehe auch: SQL-Referenzhandbuch, Strukturlink Spaltenname (column_name)
<catalog_outstream_spec> | CATALOG <outstream_ddl_spec>
<data_outstream_table_spec> | <data_outstream_part_spec> | <data_outstream_column_spec>
<data_outstream_part_spec> | DATA <outstream_tableformat_spec>
<data_outstream_column_spec> | DATA <outstream_columnformat_spec> [<export_lobcolumn_spec>...]
<package_spec> | PACKAGE <outstream_csv_spec>
<outstream_ddl_spec> <outstream_tableformat_spec> <outstream_columnformat_spec> <outstream_csv_spec> | Datenstrom
<export_lobcolumn_spec> | Exportieren und Importieren von LONG-Werten

Beispiele

Loader-Tutorial, Strukturlink EXPORT TABLE

Erläuterung

Mit dem EXPORT TABLE-Kommando können Sie die gesamten Daten einer angegebenen Tabelle exportieren. Eine Auswahl bestimmter Spaltenwerte ist mit dem EXPORT TABLE-Kommando nicht möglich, sondern nur mit dem EXPORT COLUMNS-Kommando.

<order_clause>

Mit Hilfe des Syntaxelements order_clause können Sie die Sortierreihenfolge für die Tabellenzeilen im Datenstrom festlegen. Die in der ORDER-Klausel angegebenen Spalten legen die Sortierreihenfolge fest.

<catalog_outstream_spec>, <data_outstream_table_spec>

Beim Export werden je nachdem, ob Datenbankkatalog- und/oder Anwendungsdaten exportiert werden, folgende Datenströme erzeugt:

● Datenstrom für die Datenbankkatalogdefinitionen CATALOG <outstream_ddl_spec>

● Datenstrom für die Anwendungsdaten <data_outstream_table_spec>

Die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL und weitere Systemtabellen werden gefüllt.

<data_outstream_part_spec> ::= DATA <outstream_tableformat_spec>

Wenn die Daten im Format PAGES oder RECORDS exportiert werden sollen, verwenden Sie die Syntaxvariante DATA <outstream_tableformat_spec>. Diese Möglichkeit ist empfehlenswert, wenn Sie die Daten nicht in einem lesbaren Format benötigen und zwischen MaxDB-Datenbankinstanzen austauschen wollen. Alle Daten werden in den Datenstrom exportiert, insbesondere auch die LONG-Daten.

Nach dem Export können Sie die Daten im Datenstrom nicht mehr ändern.

Eine Tabelle ist während des Exportierens im Format PAGES schreibgeschützt.

<data_outstream_column_spec> ::= DATA <outstream_columnformat_spec> [<export_lobcolumn_spec>...]

Wenn die Daten im Format CSV oder FWV [BINARY] exportiert werden sollen, verwenden Sie die Syntaxvariante DATA <outstream_columnformat_spec>. Diese Möglichkeit ist empfehlenswert, wenn Sie die Daten in einem lesbaren Format benötigen, z.B. für Werkzeuge anderer Anbieter. Ein Austausch der Daten zwischen MaxDB-Datenbankinstanzen ist möglich, jedoch wesentlich zeitintensiver als im Fall des Verwendens der Formate RECORDS oder PAGES.

Nach dem Export können Sie die Daten in den Datenströmen noch ändern.

Wenn Sie LONG-Werte exportieren wollen, müssen Sie für diese Spaltenwerte einen eigenen Datenstrom mittels des Syntaxelements export_lobcolumn_spec angeben.

Siehe auch:

Datenstrom

Exportieren und Importieren von LONG-Werten

<package_spec>

Sie können die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL exportieren.

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert. Sie sollten diese Möglichkeit nutzen, um den Export zu protokollieren.

● Ohne Angabe des Datenstroms mittels PACKAGE <outstream_csv_spec> wird die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL nicht exportiert.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

Ergebnis

Die Anwendungsdaten und/oder der Datenbankkatalog der Tabelle werden in die Datenströme data_outstream_table_spec und catalog_outstream_spec exportiert.

Gegebenenfalls werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den Datenstrom package_spec exportiert.

Mit dem korrespondierenden IMPORT TABLE-Kommando können der Datenbankkatalog und/oder die Anwendungsdaten wiederaufgebaut werden.

Fehlerfall

Der Export kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Die Werte PACKAGEGUID und CLIENTNODE werden ebenfalls in die Protokolldatei geschrieben. Die PACKAGEGUID ist für ein eventuelles Wiederaufsetzen des Exports erforderlich.

Siehe auch:

Exportieren: Kommandos

IMPORT TABLE-Kommando

Protokolldatei

Systemtabellen


EXPORT COLUMNS-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation EXPORT COLUMNS-Kommando

Mit diesem Kommando des Loader können Sie einzelne Spaltenwerte einer Tabelle exportieren.

Voraussetzungen

Sie müssen die Zugriffsberechtigung für die zu exportierende Tabelle haben.

Syntax

<export_columns_command> ::= EXPORT COLUMNS <select_expression>
[MAP COLUMNS <export_column_spec> ...]
<data_oustream_column_spec>

<export_column_spec> ::= Ausgabespalte

<data_outstream_column_spec> ::= DATA <outstream_columnformat_spec>
[<export_lobcolumn_spec> ...]
<oustream_columnformat_spec> ::= Datenstrom
<export_lobcolumn_spec> ::= Exportieren von LONG-Werten

<select_expression>

SELECT-Anweisung ohne Angabe des Schlüsselwortes SELECT

Referenzhandbuch, Strukturlink SELECT-Anweisung

Beispiele

Loader-Tutorial, Strukturlink EXPORT COLUMNS

Erläuterung

Sie können mit dem EXPORT COLUMNS-Kommando die Spalten der Tabelle festlegen, deren Anwendungsdaten (DATA) exportiert werden sollen. Dabei können mehrere Tabellen miteinander verknüpft werden und eine Sortierreihenfolge für die exportierten Daten festgelegt werden.

<select_expression>

Mit der Syntaxregel select_expression legen Sie fest, welche Spalten einer Tabelle exportiert werden sollen. Diese Datenbankabfrage wird genauso formuliert wie eine SELECT-Anweisung, jedoch wird das Schlüsselwort SELECT nicht verwendet. Alle Möglichkeiten einer SELECT-Anweisung sind dabei zulässig:

● Auswahl der Ergebnisspalten und Bestimmung ihrer Reihenfolge in der Ergebnistabelle

● Verknüpfung mehrerer Tabellen (Joins)

● Auswahl von Ergebniszeilen über Qualifikationen

● Festlegung einer bestimmten Sortierfolge

● Festlegen von Sperren und Isolation-Level

<export_column_spec>

Wenn Sie das Syntaxelement export_column_spec angeben, beschreiben Sie die zu exportierenden Spalten (Ausgabespalten) einer Quelltabelle und die Darstellung der Datensätze im Datenstrom.

● Die Reihenfolge der auszugebenden Spalten in der Spaltenbeschreibung ist beliebig.

● Die Spaltenliste kann nur Spalten der SELECT-Anweisung oder einen Teil dieser enthalten.

● Es werden nur Werte für Spalten ausgegeben, die in der Spaltenliste enthalten sind. Wenn die Spaltenliste mehr Spalten enthält als die SELECT-Anweisung, dann generiert der Loader einen Fehler und beendet die Bearbeitung des Kommandos.

● Wenn Sie die Spalten der Quelltabelle Feldern des Datenstroms zuordnen möchten, müssen Sie das Schlüsselwort MAP COLUMNS angeben.

● Wenn Sie für den Datenstrom das Format CSV definieren, werden die Werte der zu exportierenden Spalten in der Reihenfolge der Angabe in der SELECT-Anweisung ausgegeben und durch Separatoren voneinander getrennt.

● Wenn Sie für den Datenstrom das Format FWV definieren, werden die Werte der zu exportiernden Spalten formatiert und in der Reihenfolge der Angabe in der SELECT-Anweisung ausgegeben. Die Länge der einzelnen Ausgabewerte richtet sich nach den Definitionsgrößen der einzelnen Spalten in der Quelltabelle.

● Wenn auch die SELECT-Anweisung keine Spaltennamen (EXPORT COLUMNS * FROM ...) enthält, werden die Spalten entsprechend dem Format des Datenstroms formatiert und in der Reihenfolge ausgegeben, die von der Datenbank für die Abarbeitung des Kommandos festgelegt wurde.

Ergebnis

Die Anwendungsdaten werden in den Datenstrom outstream_columnformat_spec gegebenenfalls unter Angabe der Long-Spezifikation export_lobcolumn_spec exportiert.

Mit dem korrespondierenden IMPORT-Kommando können die Anwendungsdaten wiederaufgebaut werden.

Fehlerfall

Der Export kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Siehe auch:

Exportieren: Kommandos

IMPORT TABLE-Kommando

IMPORT COLUMN-Kommando

Protokolldatei


Importieren: Kommandos (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Importieren: Kommandos

Verwendung

Der Loader kann eine Reihe von Kommandos und SQL-Anweisungen verarbeiten, unter anderem loaderspezifische Kommandos zum Importieren von Daten.

Voraussetzungen

Aufrufen des Loader

Aufbau einer Datenbanksitzung: Kommandos

Exportieren: Kommandos

Syntax

<import_command> ::=
< import_db_command >
| < import_user_command >
| < import_schema_command >
| < import_table_command >
| < import_columns_command >

Funktionsumfang

Der Sprachumfang des Loader ermöglicht es, bei zunehmender Granularität eine vollständige Datenbank, die Objekte eines Datenbankbenutzers, die Objekte eines Schemas, die Daten einer Tabelle oder eine Menge von Spaltenwerten einer Tabelle zu importieren.

Beispiele

Loader-Tutorial, Strukturlink Importieren

Siehe auch:

UPDATE COLUMNS-Kommando

Syntaxregeln: alphabetisch sortiert

Syntaxregeln: semantisch sortiert


IMPORT DB-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation IMPORT DB-Kommando

Mit den IMPORT DB-Kommando des Loader können Sie die Daten, die zur Anwendung einer Datenbank gehören, importieren.

Voraussetzungen

Das IMPORT DB-Kommando kann nur vom Datenbanksystemadministrator (SYSDBA-Benutzer) ausgeführt werden.

Sie haben die erforderlichen Daten mit dem korrespondierenden EXPORT-Kommando exportiert.

Syntax

<import_db_command> ::= IMPORT DB
[<duplicates_clause>] [<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>] [<restart_spec>]

<catalog_data_instream_part_spec> ::= <catalog_instream_spec>
| <data_instream_part_spec>
| <catalog_instream_spec> <data_instream_part_spec>

IMPORT DB
[<duplicates_clause>]
[<configuration_spec>]
<catalog_instream_spec>
<data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

Import der Daten der Anwendung der Datenbank (Datenbankkatalog und Anwendungsdaten)

IMPORT DB
<catalog_instream_spec>
[<package_spec>]
[<restart_spec>]

Import der Datenbankkataloginformationen aller Datenbankbenutzer, die zur Anwendung der Datenbank gehören

IMPORT DB
[<duplicates_clause>]
[<configuration_spec>]
<data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

Import der Anwendungsdaten aller Datenbankbenutzer

<duplicates_clause>

REJECT DUPLICATES
| IGNORE DUPLICATES
| UPDATE DUPLICATES

Vorschlagswert: REJECT DUPLICATES

<configuration_spec>

CONFIGURATION <instream_csv_spec>

<catalog_instream_spec>

CATALOG <instream_ddl_spec>

<data_instream_part_spec>

DATA <instream_tableformat_spec>

<package_spec>

PACKAGE <outstream_csv_spec>

<instream_csv_spec>
<instream_ddl_spec>
<instream_tableformat_spec>
<outstream_csv_spec>

Datenstrom

<restart_spec>

RESTART <package_guid>
<package_guid> ::= <unsigned_integer>

unsigned_integer: ID, die zur Laufzeit vom Loader für jedes Kommando erzeugt wird. Diese ganze Zahl ist immer 24 Bytes lang.

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

Loader-Tutorial, Strukturlink IMPORT DB

Erläuterung

<duplicates_clause>

Mit der DUPLICATES-Regel legen Sie fest, wie beim Importieren von Daten aus einem Datenstrom verfahren werden soll, wenn eine Zeile mit dem Schlüssel der einzufügenden Zeile in der Tabelle bereits existiert. Diese Regel wird nicht ausgewertet, wenn die Daten im Format PAGES in die Datenbank importiert werden.

REJECT DUPLICATES | Die einzufügende Zeile wird mit einer Fehlermeldung abgelehnt.
IGNORE DUPLICATES | Die neue Zeile wird nicht eingefügt.
UPDATE DUPLICATES | Die existierende Zeile wird mit der neuen Zeile überschrieben.

<catalog_instream_spec>, <data_instream_part_spec>

Beim Import sind je nachdem, ob Datenbankkatalog- und/oder Anwendungsdaten importiert werden, folgende Datenströme erforderlich:

● Datenstrom mit den Datenbankkatalogdefinitionen CATALOG <instream_ddl_spec>

● Datenstrom mit den Anwendungsdaten DATA <instream_tableformat_spec>

Für den Datenstrom der Anwendungsdaten instream_tableformat_spec ist nur eines der Formate PAGES oder RECORDS möglich.

Siehe auch:

Datenstrom

<configuration_spec>

Sie können Tabellen vom Import ausschließen.

● Ohne Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> werden die gesamten Anwendungsdaten importiert.

● Durch die Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> können aus den Anwendungsdaten instream_tableformat_spec> die Anwendungsdaten ausgewählter Tabellen vom Import ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.
Die Angabe, welche Tabellen nicht importiert werden sollen, wird in den Systemtabellen abgelegt. Eine Möglichkeit der Anzeige dieser Informationen ist die Anzeige der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL. Die vom Import der Anwendungsdaten ausgeschlossenen Tabellen besitzen in der Spalte EXCLUDE den Wert TRUE.

Die Datenbankkatalogeinträge CATALOG <instream_ddl_spec> aller Tabellen werden unabhängig von den mittels CONFIGURATION <instream_csv_spec> gemachten Einschränkungen immer importiert.

<package_spec>

Sie können die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL exportieren.

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert. Sie sollten diese Möglichkeit nutzen, um den Importvorgang gut zu protokollieren.

● Ohne Angabe des Datenstroms mittels PACKAGE <outstream_csv_spec> wird die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL nicht exportiert.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

<restart_spec>

Sie können den Import wiederaufsetzen.

Der Benutzer kann die package_guid des entsprechenden Import-Kommandos aus der Tabelle SYSLOADER.TRANSFORMATIONMODEL oder der Protokolldatei ermitteln. Unter Verwendung des Syntaxelements restart_spec können Sie das Kommando mit der entsprechenden package_guidwiederaufsetzen.

Siehe auch:

Wiederaufsetzen

Verwenden von Sicherungswerkzeugen anderer Anbieter

Wenn das Importieren von Daten mit den Loader-Kommandos zum Importieren der gesamten Anwendungs- und/oder Datenbankkatalogdaten erfolgt (IMPORT DB), ist der Einsatz von Sicherungswerkzeugen anderer Anbieter möglich.

Siehe auch:

Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter

Ergebnis

Die Anwendungsdaten und/oder der Datenbankkatalog werden in die Datenströme data_instream_part_spec und catalog_instream_spec importiert.

Gegebenenfalls werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den Datenstrom package_spec exportiert.

Fehlerfall

Der Import kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Die Werte PACKAGEGUID und CLIENTNODE werden ebenfalls in die Protokolldatei geschrieben. Die PACKAGEGUID ist für ein eventuelles Wiederaufsetzen des Imports erforderlich.

Siehe auch:

Importieren: Kommandos

EXPORT DB-Kommando

Protokolldatei

Systemtabellen


IMPORT USER-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation IMPORT USER-Kommando

Mit den IMPORT USER-Kommando des Loader können Sie Daten importieren, die benutzerspezifisch exportiert wurden. Diese importierten Daten gehören dann dem Datenbankbenutzer, der zum Zeitpunkt des Imports an die Datenbank angemeldet ist.

Voraussetzungen

Sie haben die erforderlichen Daten mit dem korrespondieren EXPORT-Kommando exportiert.

Syntax

<import_user_command> ::= IMPORT USER
[<duplicates_clause>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>] [<restart_spec>]

<catalog_data_instream_part_spec> ::= <catalog_instream_spec>
| <data_instream_part_spec>
| <catalog_instream_spec> <data_instream_part_spec>

IMPORT USER
[<duplicates_clause>]
[<configuration_spec>]
<catalog_instream_spec>
<data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

Import der Daten, die benutzerspezifisch exportiert wurden (Datenbankkatalog und Anwendungsdaten)

IMPORT USER
<catalog_instream_spec>
[<package_spec>]
[<restart_spec>]

Import der benutzerspezifischen Datenbankkataloginformationen, die zur Anwendung gehören

IMPORT USER [<duplicates_clause>]
[<configuration_spec>]
<data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

Import der benutzerspezifischen Anwendungsdaten

<duplicates_clause>

REJECT DUPLICATES
| IGNORE DUPLICATES
| UPDATE DUPLICATES

Vorschlagswert: REJECT DUPLICATES

<configuration_spec>

CONFIGURATION <instream_csv_spec>

<catalog_instream_spec>

CATALOG <instream_ddl_spec>

<data_instream_part_spec>

DATA <instream_tableformat_spec>

<package_spec>

PACKAGE <outstream_csv_spec>

<instream_csv_spec>
<instream_ddl_spec>
<instream_tableformat_spec>
<outstream_csv_spec>

Datenstrom

<restart_spec>

RESTART <package_guid>
<package_guid> ::= <unsigned_integer>

unsigned_integer: ID, die zur Laufzeit vom Loader für jedes Kommando erzeugt wird. Diese ganze Zahl ist immer 24 Bytes lang.

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

Loader-Tutorial, Strukturlink IMPORT USER

Erläuterung

<duplicates_clause>

Mit der DUPLICATES-Regel legen Sie fest, wie beim Importieren von Daten aus einem Datenstrom verfahren werden soll, wenn eine Zeile mit dem Schlüssel der einzufügenden Zeile in der Tabelle bereits existiert. Diese Regel wird nicht ausgewertet, wenn die Daten im Format PAGES in die Datenbank importiert werden.

REJECT DUPLICATES | Die einzufügende Zeile wird mit einer Fehlermeldung abgelehnt.
IGNORE DUPLICATES | Die neue Zeile wird nicht eingefügt.
UPDATE DUPLICATES | Die existierende Zeile wird mit der neuen Zeile überschrieben.

<catalog_instream_spec>, <data_instream_part_spec>

Beim Import sind je nachdem, ob Datenbankkatalog- und/oder Anwendungsdaten importiert werden, folgende Datenströme erforderlich:

● Datenstrom mit den Datenbankkatalogdefinitionen CATALOG <instream_ddl_spec>

● Datenstrom mit den Anwendungsdaten DATA <instream_tableformat_spec>

Für den Datenstrom der Anwendungsdaten instream_tableformat_spec ist nur eines der Formate PAGES oder RECORDS möglich.

Siehe auch:

Datenstrom

<configuration_instream_spec>

Sie können Tabellen vom Import ausschließen.

● Ohne Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> werden die gesamten Anwendungsdaten importiert.

● Durch die Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> können aus den Anwendungsdaten <instream_tableformat_spec> die Anwendungsdaten ausgewählter Tabellen vom Import ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.
Die Angabe, welche Tabellen nicht importiert werden sollen, wird in den Systemtabellen abgelegt. Eine Möglichkeit der Anzeige dieser Informationen ist die Anzeige der Systemtabelle SYSLOADERTRANSFORMATIONMODEL. Die vom Import der Anwendungsdaten ausgeschlossenen Tabellen besitzen in der Spalte EXCLUDE den Wert TRUE.

Die Datenbankkatalogeinträge CATALOG <instream_spec> aller Tabellen werden unabhängig von den mittels CONFIGURATION <instream_spec> gemachten Einschränkungen immer importiert.

<package_spec>

Sie können die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL exportieren.

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert. Sie sollten diese Möglichkeit nutzen, um den Importvorgang gut zu protokollieren.

● Ohne Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> wird die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL nicht exportiert.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

<restart_spec>

Sie können den Import wiederaufsetzen.

Der Benutzer kann die package_guid des entsprechenden Import-Kommandos aus der Tabelle SYSLOADER.TRANSFORMATIONMODEL oder der Protokolldatei ermitteln. Unter Verwendung des Syntaxelements restart_spec können Sie das Kommando mit der entsprechenden package_guidwiederaufsetzen.

Siehe auch:

Wiederaufsetzen

Ergebnis

Die Anwendungsdaten und/oder der Datenbankkatalog werden in die Datenströme data_instream_part_spec und catalog_instream_spec importiert.

Gegebenenfalls werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den Datenstrom package_spec exportiert.

Fehlerfall

Der Import kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Die Werte PACKAGEGUID und CLIENTNODE werden ebenfalls in die Protokolldatei geschrieben. Die PACKAGEGUID ist für ein eventuelles Wiederaufsetzen des Imports erforderlich.

Siehe auch:

Importieren: Kommandos

EXPORT USER-Kommando

Protokolldatei

Systemtabellen


IMPORT SCHEMA-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation IMPORT SCHEMA-Kommando

Mit den IMPORT SCHEMA-Kommando des Loader können Sie die Daten, die zur Anwendung des angegebenen Schemas gehören, importieren.

Voraussetzungen

Das IMPORT SCHEMA-Kommando kann nur vom Eigentümer des Schemas ausgeführt werden.

Sie haben die erforderlichen Daten mit dem korrespondieren EXPORT-Kommando exportiert.

Syntax

<import_schema_command>           ::=
IMPORT SCHEMA
<schema_name>
[<duplicates_clause>]
[<map_schema_spec>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

<catalog_data_instream_part_spec> ::= <catalog_instream_spec>
| <data_instream_part_spec>
| <catalog_instream_spec> <data_instream_part_spec>

IMPORT SCHEMA <schema_name>
[<duplicates_clause>]
  [<map_schema_spec>]
  [<configuration_spec>]
  <catalog_instream_spec>
  <data_instream_part_spec>
  [<package_spec>]
  [<restart_spec>]

Import der Daten, die zur Anwendung des angegebenen Schemas gehören (Datenbankkatalog und Anwendungsdaten)

IMPORT SCHEMA <schema_name>
[<map_schema_spec>]
  <catalog_instream_spec>
  [<package_spec>]
  [<restart_spec>]

Import der Datenbankkataloginformationen, die zur Anwendung des angegebenen Schemas gehören

IMPORT SCHEMA <schema_name>
[<duplicates_clause>]
  [<map_schema_spec>]
  [<configuration_spec>]
  <data_instream_part_spec>
  [<package_spec>]
  [<restart_spec>]

Import der Anwendungsdaten des angegebenen Schemas

<schema_name>

Schemaname

Wenn der Name des Schemas mit einem Schlüsselwort identisch oder die Groß- und Kleinschreibung von Bedeutung ist, muss der Name in Anführungszeichen eingeschlossen werden.

<schema_name> ::= <identifier>

siehe auch: SQL-Referenzhandbuch, Strukturlink Schemaname (schema_name)

<duplicates_clause>

REJECT DUPLICATES
| IGNORE DUPLICATES
| UPDATE DUPLICATES

Vorschlagwert: REJECT DUPLICATES

<map_schema_spec>

MAP SCHEMA [<schema_map_name> | <schema_to_schema>,...]

<schema_map_name> ::= <identifier>
<schema_to_schema> ::= <schema_name> TO <schema_name>

siehe auch: USE SCHEMAMAP-Kommando

<configuration_spec>

CONFIGURATION <instream_csv_spec>

<catalog_instream_spec>

CATALOG <instream_ddl_spec>

<data_instream_part_spec>

DATA <instream_tableformat_spec>

<package_spec>

PACKAGE <outstream_csv_spec>

<instream_csv_spec>
<instream_ddl_spec>
<instream_tableformat_spec>
<outstream_spec>

Datenstrom

<restart_spec>

RESTART <package_guid>
<package_guid> ::= <unsigned_integer>

unsigned_integer: ID, die zur Laufzeit vom Loader für jedes Kommando erzeugt wird. Diese ganze Zahl ist immer 24 Bytes lang.

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

Loader-Tutorial, Strukturlink IMPORT SCHEMA

Erläuterung

<duplicates_clause>

Mit der DUPLICATES-Regel legen Sie fest, wie beim Importieren von Daten aus einem Datenstrom verfahren werden soll, wenn eine Zeile mit dem Schlüssel der einzufügenden Zeile in der Tabelle bereits existiert. Diese Regel wird nicht ausgewertet, wenn die Daten im Format PAGES in die Datenbank importiert werden.

REJECT DUPLICATES | Die einzufügende Zeile wird mit einer Fehlermeldung abgelehnt.
IGNORE DUPLICATES | Die neue Zeile wird nicht eingefügt.
UPDATE DUPLICATES | Die existierende Zeile wird mit der neuen Zeile überschrieben.

<catalog_instream_spec>, <data_instream_part_spec>

Beim Import sind je nachdem, ob Datenbankkatalog- und/oder Anwendungsdaten importiert werden, folgende Datenströme erforderlich:

● Datenstrom mit den Datenbankkatalogdefinitionen CATALOG <instream_ddl_spec>

● Datenstrom mit den Anwendungsdaten DATA <instream_tableformat_spec>

Für den Datenstrom der Anwendungsdaten instream_tableformat_spec ist nur eines der Formate PAGES oder RECORDS möglich.

Siehe auch:

Datenstrom

<configuration_spec>

Sie können Tabellen vom Import ausschließen.

● Ohne Angabe eines Datenstroms mittels CONFIGURATION <instream_csv_spec> werden die gesamten Anwendungsdaten importiert.

● Durch die Angabe eines Datenstroms mittels CONFIGURATION <instream_spec> können aus den Anwendungsdaten <instream_tableformat_spec> die Anwendungsdaten ausgewählter Tabellen vom Import ausgeschlossen werden. Die Tabellen müssen durch die Angabe ihres Schemas und des Tabellennamens im Datenstrom spezifiziert sein.
Die Angabe, welche Tabellen nicht importiert werden sollen, wird in den Systemtabellen abgelegt. Eine Möglichkeit der Anzeige dieser Informationen ist die Anzeige der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL. Die vom Import der Anwendungsdaten ausgeschlossenen Tabellen besitzen in der Spalte EXCLUDE den Wert TRUE.

Die Datenbankkatalogeinträge CATALOG <instream_ddl_spec> aller Tabellen werden unabhängig von den mittels CONFIGURATION <instream_csv_spec> gemachten Einschränkungen immer importiert.

<map_schema_spec>

Sie können Daten, die in einem Schema exportiert wurden, in ein anderes Schema importieren. Dazu können Sie für eine Loader-Sitzung ein Schema-Map mit dem USE SCHEMAMAP-Kommando festlegen. Sie können aber auch im IMPORT SCHEMA-Kommando das Syntaxelement map_schema_spec verwenden, um entweder ein vorhandenes Schema-Map schema_map_name anzugeben, das die gewünschte Schema-Abbildung enthält oder die gewünschte Schema-Abbildung mittels <schema_name> TO <schema_name> direkt festzulegen.

Siehe auch:

CREATE/DROP SCHEMAMAP-Anweisung

<package_spec>

Sie können die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL exportieren.

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert. Sie sollten diese Möglichkeit nutzen, um den Importvorgang gut zu protokollieren.

● Ohne Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> wird die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL nicht exportiert.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

<restart_spec>

Sie können den Import wiederaufsetzen.

Der Benutzer kann die package_guid des entsprechenden Import-Kommandos aus der Tabelle SYSLOADER.TRANSFORMATIONMODEL oder der Protokolldatei ermitteln. Unter Verwendung des Syntaxelements restart_spec können Sie das Kommando mit der entsprechenden package_guidwiederaufsetzen.

Siehe auch:

Wiederaufsetzen

Ergebnis

Die Anwendungsdaten und/oder der Datenbankkatalog werden in die Datenströme data_instream_part_spec und catalog_instream_spec importiert.

Gegebenenfalls werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den Datenstrom package_spec exportiert.

Fehlerfall

Der Import kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Die Werte PACKAGEGUID und CLIENTNODE werden ebenfalls in die Protokolldatei geschrieben. Die PACKAGEGUID ist für ein eventuelles Wiederaufsetzen des Imports erforderlich.

Siehe auch:

Importieren: Kommandos

EXPORT SCHEMA-Kommando

Protokolldatei

Systemtabellen


IMPORT TABLE-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation IMPORT TABLE-Kommando

Mit dem IMPORT TABLE-Kommando des Loader können Sie den Import von Anwendungsdaten und/oder der dazugehörigen Datenbankkataloginformationen der Objekte eines Benutzers steuern.

Voraussetzungen

Die mit einem IMPORT TABLE-Kommando importierten Objekte gehören dem Benutzer, der zum Zeitpunkt des Imports an die Datenbankinstanz angemeldet ist.

Sie haben die erforderlichen Daten entweder mit dem korrespondieren EXPORT-Kommando exportiert oder die Daten liegen im angegebenen Datenformat vor.

Syntax

<import_table_command> ::= IMPORT TABLE <table_name>
[<if_condition>] [<duplicates_clause>]
<catalog_data_instream_table_spec>
[<package_spec>]

<catalog_data_instream_table_spec> ::= <catalog_instream_spec>
| <data_instream_table_spec>
| <catalog_instream_spec> <data_instream_table_spec>

IMPORT TABLE <table_name>
[<if_condition>]
 [<duplicates_clause>]
<catalog_instream_spec>
<data_instream_table_spec>
[<package_spec>]

Import der Daten einer Tabelle (Datenbankkatalog und Anwendungsdaten)

IMPORT TABLE <table_name>
<catalog_instream_spec>
[<package_spec>]

Import der Datenbankkataloginformationen einer Tabelle, die zur Anwendung gehören

IMPORT TABLE <table_spec>
[<if_condition>]
 [<duplicates_clause>]
<data_instream_table_spec>
[<package_spec>]

Import der Anwendungsdaten einer Tabelle

<table_name> | Tabellenname
<if_condition> | Selektieren von Datensätzen
<duplicates_clause> | REJECT DUPLICATES | IGNORE DUPLICATES | UPDATE DUPLICATES Vorschlagswert: REJECT DUPLICATES
<catalog_instream_spec> | CATALOG <instream_ddl_spec>
<data_instream_table_spec> | <data_instream_part_spec> | <data_instream_columns_spec>
<data_instream_part_spec> | DATA <instream_tableformat_spec>
<data_instream_columns_spec> | DATA <instream_columnformat_spec> [<import_column_spec> ... <import_lobcolumn_spec> ...] [<usage_spec>]
<package_spec> | PACKAGE <outstream_csv_spec>
<instream_ddl_spec> <instream_tableformat_spec> <instream_column_format_spec> <outstream_csv_spec> | Datenstrom

<import_column_spec> ::= Spaltenbeschreibung

<import_lobcolumn_spec> ::= Exportieren und Importieren von LONG-Werten

<usage_spec> ::= Performance-Steigerung beim IMPORT TABLE

Beispiele

Loader-Tutorial, Strukturlink IMPORT TABLE

Erläuterung

<if_condition>

Sie können einzelne Datensätze aus einem DATA-Datenstrom des Formats CSV, FWV oder RECORDS selektieren und nur diese in die angegebene Tabelle importieren.

Siehe auch:

Selektieren von Datensätzen

<duplicates_clause>

Mit der DUPLICATES-Klausel legen Sie fest, wie beim Importieren von Daten aus einem Datenstrom verfahren werden soll, wenn eine Zeile mit dem Schlüssel der einzufügenden Zeile in der Tabelle bereits existiert. Diese Syntaxregel wird nicht ausgewertet, wenn die Daten im Format PAGES in die Datenbank importiert werden.

REJECT DUPLICATES | Die einzufügende Zeile wird mit einer Fehlermeldung abgelehnt.
IGNORE DUPLICATES | Die neue Zeile wird nicht eingefügt.
UPDATE DUPLICATES | Die existierende Zeile wird mit der neuen Zeile überschrieben.

<catalog_instream_spec>, <data_instream_table_spec>

Beim Import sind je nachdem, ob Datenbankkatalog- und/oder Anwendungsdaten importiert werden, folgende Datenströme erforderlich:

● Datenstrom mit den Datenbankkatalogdefinitionen CATALOG <instream_ddl_spec>

● Datenstrom mit den Anwendungsdaten data_instream_table_spec

Die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL und weitere Systemtabellen werden gefüllt.

<data_instream_part_spec> ::= DATA <instream_tableformat_spec>

Wenn die Daten im Format PAGES oder RECORDS importiert werden sollen, verwenden Sie die Syntaxvariante DATA <instream_tableformat_spec>. Diese Möglichkeit ist empfehlenswert, wenn Sie die Daten nicht in einem lesbaren Format benötigen und zwischen MaxDB-Datenbankinstanzen austauschen wollen. Alle Daten befinden sich im angegebenen Datenstrom, insbesondere auch die LONG-Daten.

<data_instream_columns_spec> ::= DATA <instream_columnformat_spec>
[<import_column_spec>... <import_lobcolumn_spec>...] [<usage_spec>]

Wenn die Daten im Format CSV oder FWV [BINARY] importiert werden sollen, verwenden Sie die Syntaxvariante DATA <instream_columnformat_spec>. Diese Möglichkeit ist empfehlenswert, wenn Sie die Daten in einem lesbaren Format benötigen, z.B. für Werkzeuge anderer Anbieter. Ein Austausch der Daten zwischen MaxDB-Datenbankinstanzen ist möglich, jedoch wesentlich zeitintensiver als im Fall des Verwendens der Formate RECORDS oder PAGES.

Wenn Sie die Formate CSV und FWV [BINARY] verwenden, werden für die LONG-Daten beim Export extra Datenströme angelegt.

Wenn Sie LONG-Werte exportieren wollen, müssen Sie für diese Spaltenwerte einen eigenen Datenstrom mittels des Syntaxelements import_lobcolumn_spec angeben.

Siehe auch:

Datenstrom

Spaltenspezifikation

Exportieren und Importieren von LONG-Werten

<usage_spec>

Mit Hilfe der Syntaxregel usage_spec können Sie angeben, ob Daten, die im Format CSV oder FWV [BINARY] vorliegen über ein Massen-INSERT (RECORDS USAGE) oder über Seiten (PAGE WITH ...) importiert werden sollen.

Die Performance des Imports von sortierten Anwendungsdaten in eine Tabelle kann durch usage_spec gesteuert werden. Die Möglichkeit des seitenweisen Import (PAGE WITH ...) kann genutzt werden, falls die Tabellendefinition der Zieltabelle bestimmten Voraussetzungen genügt. Bei Auswahl von PAGE WITH ... werden die Daten direkt in die Seiten der Datenbank eingetragen und es werden keine Log-Einträge geschrieben. Das ermöglicht einen zusätzlichen Performance-Gewinn gegenüber der Wahl von RECORDS USAGE. Allerdings bleibt die entsprechende Tabelle schreibgeschützt, so lange Sie die neuen Anwendungsdaten nicht gesichert haben.

Siehe auch:

Performance-Steigerung beim IMPORT TABLE

<package_spec>

Sie können die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL exportieren.

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert. Sie sollten diese Möglichkeit nutzen, um den Importvorgang gut zu protokollieren.

● Ohne Angabe des Datenstroms mittels PACKAGE <outstream_csv_spec> wird die Systemtabelle SYLOADER.TRANSFORMATIONMODEL nicht exportiert.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

Ergebnis

Die Anwendungsdaten und/oder der Datenbankkatalog werden in die Datenströme data_instream_table_spec und catalog_instream_spec importiert.

Gegebenenfalls werden alle Einträge der Tabelle SYSLOADER.TRANSFORMATIONMODEL in den Datenstrom package_spec exportiert.

Fehlerfall

Der Import kann nicht erfolgreich beendet werden. In diesem Fall protokolliert der Loader die Fehlerursache in der Protokolldatei.

Die Werte PACKAGEGUID und CLIENTNODE werden ebenfalls in die Protokolldatei geschrieben. Die PACKAGEGUID ist für ein eventuelles Wiederaufsetzen des Imports erforderlich.

Siehe auch:

Importieren: Kommandos

EXPORT TABLE-Kommando

Protokolldatei

Systemtabellen


Performance-Steigerung beim IMPORT TABLE (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Performance-Steigerung beim IMPORT TABLE

Mit der Syntaxregel usage_spec im DATA-Datenstrom können Sie steuern, ob Daten einer Tabelle im Datenformat CSV oder FWV über ein Massen-INSERT (RECORDS USAGE) oder über Seiten (PAGE WITH ...) importiert werden sollen.

Syntax

<usage_spec> ::= RECORDS USAGE
| PAGE WITH <unsigned_integer> % USAGE
| PAGE WITH <unsigned_integer> RECORDS USAGE

Vorschlagswert: RECORDS USAGE

<unsigned_integer>

Ganze Zahl ohne Vorzeichen

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Bei Angabe eines Prozentsatzes muss diese Zahl zwischen 50 und 100 liegen.
Vorschlagswert: 80

Bei Angabe der Anzahl der Zeilen spielt die Länge eines einzelnen Tabellensatzes eine Rolle.

Beispiele

Loader-Tutorial, Strukturlink IMPORT TABLE

Erläuterung

Ein Import von Tabellen (IMPORT TABLE-Kommando) kann durch Angabe von PAGE WITH ... (Import als Seiten) im Vergleich zur Verwendung von RECORDS USAGE (Import über ein Massen-INSERT) wesentlich beschleunigt werden.

Beim Import von Anwendungsdaten unter Angabe der Syntaxregel PAGE WITH ... werden die Daten direkt in die Seiten der Datenbank eingetragen und es werden keine Log-Einträge geschrieben.

Bei Angabe der Regel RECORDS USAGE werden die Daten als Massen-INSERT in die Datenbank eintragen und es werden Log-Einträge geschrieben, so dass im Fehlerfall die eingefügten Einträge rückgängig gemacht werden können.

Die Syntaxregel PAGE WITH ...können Sie nur verwenden, wenn die folgenden Voraussetzungen erfüllt sind:

● Die Zieltabelle ist in der Datenbankinstanz vorhanden.

● Sie haben sich mit dem Datenbankbenutzer am Loader angemeldet, der Eigentümer der Zieltabelle ist.

● Für die Zieltabelle existiert kein Index.

● In der Zieltabelle existiert keine LONG Spalte.

● Die Anwendungsdaten im einzulesenden Datenstrom sind in der Reihenfolge des Primärschlüssels der Zieltabelle aufsteigend sortiert.

● Wenn die Zieltabelle bereits Anwendungsdaten enthält, können nur solche Datensätze eingefügt werden, deren Schlüsselwerte größer sind als der größte Schlüsselwert der Zieltabelle.

Mit der Syntaxregel PAGE WITH ... können Sie zudem festlegen, wie weit eine Seite mit Datensätzen gefüllt werden soll. Sie können dazu einen Prozentsatz zwischen 50 und 100 festlegen oder definieren, wie viele Zeilen (Datensätze, Records) in jede Seite importiert werden sollen. Wenn Sie eine Zeilenanzahl angeben, die über die tatsächlich mögliche hinausgeht, liefert der Loader beim Importvorgang eine Fehlermeldung und weist die pro Seite maximal mögliche Zeilenzahl aus.

Wenn es sich um eine Tabelle handelt, die wenig oder gar nicht mehr verändert wird, ist es sinnvoll, den belegten Speicher zu mehr als 80% auszunutzen.

Wenn es sich um eine Tabelle handelt, für die ein starkes dynamisches Wachstum erwartet wird, ist es sinnvoll, den belegten Speicher zu weniger als 80% auszunutzen.

Beachten Sie bei Verwenden der Syntaxregel PAGE WITH ...:

● Da bei Angabe der PAGE WITH ... keine Log-Einträge geschrieben werden, müssen Sie die neuen Tabellendaten nach Abschluss des Importvorgangs sichern. Dabei können entweder die entsprechenden Seiten (inkrementelle Datensicherung) oder die gesamten Daten (vollständige Datensicherung) gesichert werden.

● Solange Sie die neuen Anwendungsdaten nicht gesichert haben, bleibt die entsprechende Tabelle schreibgeschützt.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Daten sichern

Sie können Daten einer Tabelle auch im Format PAGES exportieren und importieren, um die Informationen im Datenstrom seitenweise abzulegen. In diesem Fall ist keine usage_spec-Syntaxregel möglich und nötig.

EXPORT TABLE-Kommando, IMPORT TABLE-Kommando


IMPORT COLUMNS-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation IMPORT COLUMNS-Kommando

Mit dem IMPORT COLUMNS-Kommando des Loader können Sie den Import von Anwendungsdaten in eine Tabelle steuern.

Voraussetzungen

Die Tabelle ist in der Datenbank vorhanden. Andernfalls müssen Sie diese vor dem IMPORT COLUMNS-Kommando anlegen.

Sie haben die erforderlichen Daten entweder mit dem korrespondieren EXPORT-Kommando exportiert oder die Daten liegen im angegebenen Datenformat vor.

Syntax

<import_columns_command > ::= IMPORT COLUMNS TABLE <table_name>
[<if_condition>] [<duplicates_clause>]
<import_column_spec> ...
<data_instream_column_spec>

<table_name> ::= Tabellenname

<if_condition> ::= Selektieren von Datensätzen
<duplicates_clause> ::= REJECT DUPLICATES
| IGNORE DUPLICATES
| UPDATE DUPLICATES

<import_column_spec> ::= Spaltenbeschreibung

<data_instream_column_spec> ::= DATA <instream_columnformat_spec>
[<import_lobcolumn_spec> ...]
<instream_columnformat_spec> ::= Datenstrom
<import_lobcolumn_spec> ::= Exportieren und Importieren von LONG-Werten

Beispiele

Loader-Tutorial, Strukturlink IMPORT COLUMNS

Erläuterung

Der Loader erzeugt aus einem IMPORT COLUMNS-Kommando intern eine Massen-INSERT-Anweisung und führt diese aus.

Während des Importvorganges können alle von diesem IMPORT COLUMNS-Kommando geänderten Tabellen auch von anderen Datenbankbenutzern gelesen und geändert werden.

<duplicates_clause>

Mit der DUPLICATES-Regel legen Sie fest, wie beim Importieren von Daten aus einem Datenstrom verfahren werden soll, wenn eine Zeile mit dem Schlüssel der einzufügenden Zeile in der Tabelle bereits existiert. Diese Regel wird nur ausgewertet, falls die Daten nicht im Datenformat PAGES in die Datenbank importiert werden.

REJECT DUPLICATES | Die einzufügende Zeile wird mit einer Fehlermeldung abgelehnt. Vorschlagswert: REJECT DUPLICATES
IGNORE DUPLICATES | Die neue Zeile wird nicht eingefügt.
UPDATE DUPLICATES | Die existierende Zeile wird mit der neuen Zeile überschrieben.

Ergebnis

Die Daten des Datenstroms wurden in die Zieltabelle/n importiert. Alle dadurch in der/den Zieltabelle/n verursachten Änderungen wurden auch in den Log-Bereich der Datenbankinstanz geschrieben.

Sie können das Kommando IMPORT COLUMNS TABLE * ... DATA ... oder auch das Kommando IMPORT TABLE ... DATA ... verwenden, um alle Anwendungsdaten einer Tabelle zu importieren. Zu allen Spalten der Tabelle müssen Daten in dem entsprechenden Datenstrom vorhanden sein. Andernfalls meldet der Loader einen Fehler.

Fehlerfall

Wenn der Importvorgang nicht erfolgreich beendet werden kann, protokolliert der Loader die letzte erfolgreich in die Tabelle eingefügte Zeile, die Anzahl eingefügter und die Anzahl abgelehnter Zeilen in der Protokolldatei.

Siehe auch:

Importieren: Kommandos

EXPORT COLUMNS-Kommando

Protokolldatei


UPDATE COLUMNS-Kommando (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation UPDATE COLUMNS-Kommando

Mit diesem Kommando des Loader können Sie einzelne Spaltenwerte von Tabellen aktualisieren.

Voraussetzungen

Die Tabelle, deren Spaltenwerte aktualisiert werden sollen, muss in der Datenbankinstanz vorhanden sein.

Syntax

<update_columns_command> ::= UPDATE COLUMNS TABLE <table_name>
[<if_condition>]
<update_column_spec> ... <set_column_spec> ...
<data_instream_column_spec>

<table_name> ::= Tabellenname

<if_condition> ::= Selektieren von Datensätzen

<update_column_spec> ::= <map_field_column>
| <column_assignment>
<map_field_column> ::= Spaltenbeschreibung
<column_assignement> ::= Spaltenbeschreibung

<set_column_spec> ::= SET <import_column_spec>
<import_column_spec> ::= Spaltenbeschreibung

<data_instream_column_spec> ::= DATA <instream_columnformat_spec>
[<import_lobcolumn_spec> ...]
<instream_column_format_spec> ::= Datenstrom
<import_lobcolumn_spec> ::= Importieren von LONG-Werten

Beispiele

Loader-Tutorial, Strukturlink UPDATE COLUMNS

Erläuterung

Der Loader erzeugt aus einem UPDATE COLUMNS-Kommando intern eine UPDATE-Anweisung und führt diese aus.

<update_column_spec>, <set_column_spec>

Sie definieren mit der Syntaxregel update_column_spec die Qualifikationsspalten.

Die Qualifikationsspalten müssen im UPDATE COLUMNS-Kommando vor den Zielspalten set_column_spec aufgeführt werden.

Wenn Sie Qualifikationsspalten map_field_column verwenden, dann wird für jeden Datensatz des Datenstroms jede Zeile der Zieltabelle aktualisiert, die mit dem Wert/ den Werten der Qualifikationsspalte/n dieses Datensatzes identifiziert wird. Sie ordnen also mit der Syntaxregel map_field_column die Datenfelder der Qualifikationspalten im Datenstrom den Spalten der Zieltabelle zu und können die externen Datentypen angeben.

Ergebnis

Die einzelnen Zeilenwerte der angegebenen Spalten der Tabelle wurden aktualisiert. Alle dadurch in der/den Zieltabelle/n verursachten Änderungen wurden auch in den Log-Bereich der Datenbankinstanz geschrieben.

Fehlerfall

Wenn während der Ausführung des UPDATE COLUMNS-Kommandos ein Fehler auftritt, bricht der Loader den Vorgang ab und gibt eine Fehlermeldung aus. Es wird eine Protokolldatei geschrieben.

Siehe auch:

Protokolldatei


Daten (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Daten

Definition

Der Loader bietet Funktionalität zum Exportieren, Importieren, Transportieren und Formatieren von Daten zwischen unterschiedlichen Datenquellen und Datenzielen in verschiedener Granularität an.

Struktur

Der Loader unterscheidet Anwendungsdaten und Metadaten.

● Anwendungsdaten

Anwendungsdaten sind die Daten, die in den Datenbanktabellen abgelegt sind.
Der Loader schreibt die Anwendungsdaten beim Exportieren aus dem Datenbanksystem in einen Datenstrom und beim Importieren vom Datenstrom in das Datenbanksystem.

● Metadaten

Das Datenbanksystem selbst verwaltet seine Metadaten im Datenbankkatalog.
Für den Loader sind Metadaten die Metadaten des Datenbanksystems und zusätzlich die Daten, die Anwendungsdaten, Datenbankkataloginformationen und Transformationen den Anforderungen des Loader entsprechend beschreiben.

Metadaten des Loader

Der Loader unterscheidet Metadaten der Anwendungsdaten, des Datenbankkatalogs und der Transformation.

Metadaten der Anwendungsdaten

Die Metadaten der Anwendungsdaten (Schlüsselwort DATA) werden in den Datenströmen durch Kommandos und SQL-Anweisungen festgelegt.

Der Loader speichert diese Informationen in den Systemtabellen ab, falls sich die Transformation über mehrere Tabellen erstreckt.

Die entsprechenden Daten liegen in der Datenbankinstanz in Form von Seiten bzw. Zeilen und in einem Datenstrom in den nicht lesbaren Formaten PAGES und RECORDS oder in den lesbaren Formaten CSV, FWV, FWV BINARY vor.

Werden die Daten in Form von Zeilen transformiert, so können Spalten des externen Datentyps CHAR mit dem Codeattribut ASCII in Werte von Datenfeldern mit dem Codeattribut ASCII, UCS-2 oder UTF-8 transformiert werden.

Metadaten des Datenbankkatalogs

Die Metadaten des Datenbankkatalogs (Schlüsselwort CATALOG) beschreiben die Struktur der Daten im Datenbankkatalog.

Der Loader speichert diese Informationen in seinen Systemtabllen ab, falls sich die Transformation über mehrere Tabellen erstreckt.

Die entsprechenden Daten liegen in der Datenbankinstanz in Form von Zeilen in den Systemtabellen und in einem Datenstrom in Form von SQL-Anweisungen zur Datendefinition vor.

Metadaten der Transformation

Die Metadaten der Transformationen (Schlüsselwort CONFIGURATION und PACKAGE) werden in Form von Kommandos oder in Form von Loader-spezifischen Systemtabellen deklariert.

Diese Metadaten beschreiben die Konfiguration und das Laufzeitverhalten der Transformationen.

Die entsprechenden Daten, wie Benutzer- und Tabellennamen, werden nach referentiellen Contraint-Bedingungen sortiert abgelegt.

In der Datenbankinstanz werden die Daten in Form von Zeilen in den Systemtabellen in einem Datenstrom im lesbaren Format CSV gespeichert.

Siehe auch:

Datenstrom

Datentypen

Datenformat

Code-Spezifikation

Transformation

Exportieren: Kommandos

Importieren: Kommandos


Datenstrom (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Datenstrom

Der Loader exportiert Daten aus Datenbanken in Datenströme exportiert bzw. importiert Daten aus Datenströmen in Datenbanken. Dabei können die Daten transformiert werden.

Es gibt eine Reihe von Syntaxelementen zur Beschreibung des Datenstroms, die in den Kommandos zum Exportieren und Importieren verwendet werden.

Syntax

Zusätzlich zum Namen des Datenstroms können Sie den Datenträgertyp festlegen, Formatangaben übergeben und gegebenenfalls weitere Angaben machen, um den Datenstrom näher zu beschreiben.

· Durch das Schlüsselwort OUTSTREAM geben Sie an, dass die Daten aus einer MaxDB-Datenbankinstanz in einen Datenstrom exportiert werden.

· Durch das Schlüsselwort INSTREAM geben Sie an, dass die Daten aus einem Datenstrom in eine MaxDB-Datenbankinstanz importiert werden.

In der Loader-Syntax werden folgende Syntaxelemente verwendet:

<outstream_columnformat_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>' [<column_dataformat_spec>] [<start_spec>]
<instream_columnformat_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>' [<column_dataformat_spec>] [<start_spec>]

<outstream_tableformat_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>' [<table_dataformat_spec>]
<instream_tableformat_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>' [<table_dataformat_spec>]

Gegebenenfalls kann es erforderlich sein, das Format des Datenstroms (CSV, DDL, FWV [BINARY], PAGES, RECORDS) anzugeben.

<outstream_csv_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>' [CSV [<csv_format_spec> ...]] [<start_spec>]
<instream_csv_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>' [CSV [<csv_format_spec> ...]] [<start_spec>]

<outstream_ddl_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>' [DDL]
<instream_ddl_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>' [DDL]

<outstream_fwv_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>' FWV [<fwv_format_spec> ...] [<start_spec>]
<instream_fwv_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>' FWV [<fwv_format_spec> ...] [<start_spec>]

<outstream_pages_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>' [PAGES]
<instream_pages_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>' [PAGES]

<outstream_records_spec>
::= OUTSTREAM [<mediumtype_spec>] '<stream_name>' RECORDS
[<records_format_spec>]
<instream_records_spec>  ::=  INSTREAM
[<mediumtype_spec>] '<stream_name>' RECORDS
[<records_format_spec>]

Siehe auch:

CSV, FWV, FWV BINARY, PAGES, RECORDS

Für den Fall der Behandlung von LONG-Werten, sind eigene Syntaxregeln zu beachten.

<outstream_lob_spec> ::= Exportieren von LONG-Werten
<instream_lob_spec> ::= Importieren von LONG-Werten

<mediumtype_spec>

Datenträgertyp

<stream_name>

Name und Pfad des Datenstroms

CSV

CSV (Comma Separated Values) ist ein Format für CHAR-Daten, bei dem eine Datenzeile genau so lang ist, wie für die Abbildung der Daten minimal erforderlich ist. Die Zuordnung eines Datenfeldes des Datenstroms zu einer Spalte in der Tabelle erfolgt gemäß der Positionsangabe.

FWV

FWV (Fixed Width Values) ist ein Format für Klarextwerte, bei dem eine Datenzeile im Datenstrom einem Datensatz entspricht. Die Zuordnung zwischen Datenfeldern des Datenstroms und Tabellenspalten erfolgt gemäß der Positionsangabe.

FWV BINARY

FWV BINARY (Fixed Width Values BINARY) ist ein Format für Binärwerte, bei dem die Datenfelder alle die gleiche feste Länge haben. Die Zuordnung zwischen Datenfeldern des Datenstroms und Tabellenspalten erfolgt gemäß der Positionsangabe. Im Unterschied zu FWV wird ein Datensatz nicht zusätzlich durch einen Zeilenumbruch abgeschlossen.

PAGES

Format, das angibt, dass die Anwendungsdaten in Seiten abgelegt werden

RECORDS

datenbankeigenes Format

DDL

DDL (Data Definition Language) ist ein Format, das für einen Datenstrom mit Datenbankkatalogdaten angegeben werden kann

<column_dataformat_spec>
<table_dataformat_spec>

<csv_format_spec>
<fwv_format_spec>
<records_format_spec>

Datenformat

<start_spec>

START <unsigned_integer> [MAXROWS]
| START <unsigned_integer> [MAXRECORDS]
| START <unsigned_integer> <unsigned_integer>

Import: Es wird der mit start_spec festgelegt Bereich aus dem Datenstrom importiert.

Export: Es wird der mit start_spec festgelegt Bereich einer Tabelle exportiert.

unsigned_integer: Sie können den Startpunkt des Bereichs angegeben (START <unsigned_integer> [MAXROWS] bzw. START <unsigned_integer> [MAXRECORDS]) oder die Bereichsobergrenze und Bereichsuntergrenze festlegen (<unsigned_integer> <unsigned_integer>).

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data'

Die im Datenstrom room_csv.data abgelegten Anwendungsdaten (DATA) werden in (INSTREAM) die Tabelle ROOM des Schemas HOTEL importiert (IMPORT). Der Datenträgertyp des Datenstroms room_csv.data ist eine Datei (FILE, Vorschlagswert). Das Format des Datenstroms ist CSV (Vorschlagswert).

Loader-Tutorial, Strukturlink Exportieren, Strukturlink Importieren

Erläuterung

Durch die Schlüsselwörter CATALOG, DATA, CONFIGURATION und PACKAGE erfolgt in den Kommandos zum Exportieren und Importieren die Unterscheidung nach Art der Daten, die exportiert oder importiert werden sollen.

<catalog_outstream_spec> | CATALOG <outstream_ddl_spec>
<catalog_instream_spec> | CATALOG <instream_ddl_spec> Datenströme für die Datenbankkataloginformationen der Anwendungsdaten
<data_outstream_column_spec> | DATA <outstream_columnformat_spec> [<export_lobcolumn_spec> ...]
<data_outstream_part_spec> | DATA <outstream_tableformat_spec>
<data_outstream_table_spec> | <data_outstream_part_spec> | <data_oustream_column_spec>
<data_instream_column_spec> | DATA <instream_tableformat_spec>
<data_instream_columns_spec> | DATA <instream_columnformat_spec> [<import_column_spec> ... <import_lobcolumn_spec> ...] [<usage_spec>] <usage_spec> ::= Performance-Steigerung beim IMPORT TABLE
<data_instream_part_spec> | DATA <instream_tableformat_spec>
<data_instream_table_spec> | <data_instream_part_spec> | <data_instream_columns_spec>
 | Datenströme für die Anwendungsdaten
<configuration_spec> | CONFIGURATION <instream_csv_spec> Die Anwendungsdaten ausgewählter Tabellen können vom Export bzw. Import ausgeschlossen werden
<package_spec> | PACKAGE <outstream_csv_spec> Datenstrom mit Einträgen der Systemtabelle TRANSFORMATIONMODEL (siehe auch: Zusätzliche Protokollfunktionalität (package_spec))

Siehe auch:

Exportieren: Kommandos

Importieren: Kommandos

Daten

Datenformat

Datentypen

Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter


Positionsbeschreibung (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Positionsbeschreibung

Sie beschreiben mit der Syntaxregel field_spec zur Positionsbeschreibung:

● die Position eines Eingabefeldes im Datenstrom beim Importieren von Anwendungsdaten (Spaltenbeschreibung)

● die Position einer Ausgabespalte im Datenstrom beim Exportieren von Anwendungsdaten (Ausgabespalte)

● die Position eines Vergleichswertes für das selektive Importieren von Anwendungsdaten (Selektieren von Datensätzen).

Siehe auch:

Datenstrom

Syntax

<field_spec> ::= <unsigned_integer>
| <unsigned_integer> - <unsigned_integer>

<unsigned_integer> | Anfangsposition eines Datenfeldes siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)
<unsigned_integer> - <unsigned_integer> | Anfangsposition - Endposition eines Datenfeldes

Erläuterung

Geben Sie in Ihrer Spaltenbeschreibung für jede Spalte eine Positionsbeschreibung field_spec an. Die Positionsbeschreibung ist abhängig vom Format des Datenstroms.

Siehe auch:

CSV, FWV, FWV BINARY

Format CSV

Die Datenfelder sind nicht einheitlich formatiert, sie sind durch Komma voneinander getrennt und durch Zeilenumbruch abgeschlossen.

Geben Sie Positionsbeschreibungen field_spec ausschließlich als relative Positionsangaben ein.

Wenn Sie für einzelne oder alle Spalten Positionsbeschreibungen mit Anfangs- und Endposition eingeben, dann generiert der Loader einen Fehler und beendet die Ausführung des Kommandos.

EXPORT COLUMNS * FROM hotel.reservation
MAP COLUMNS
rno 1
cno 2
hno 3
type 4
arrival 5
departure 6-15 ERROR
DATA OUTSTREAM 'reservation_csv.data' CSV

Ordnen Sie der ersten Spalte Ihrer Liste die Position 1 zu. Die nachfolgenden Spaltenangaben erhalten aufsteigende, jeweils um die Zahl 1 erhöhte Positionsnummern. Das bedeutet auch, dass jede Positionsnummer nur einmal vergeben werden kann.

Wenn Sie diese Regeln nicht einhalten, generiert der Loader einen Fehler und beendet die Ausführung des Kommandos.

EXPORT COLUMNS * FROM hotel.reservation
MAP COLUMNS
rno 1
cno 2
hno 3
type 4
arrival 5
departure 6
 type 7
DATA OUTSTREAM 'reservation_csv.data' CSV

Sie können eine Spalte mehreren verschiedenen Positionen zuordnen.

Datenstrom customer_csv.data

Pos.-Nr. | 1 2 3 4 ....
 | "3000","Mrs","Jenny","Porter",... "3100","Mr","Peter","Brown",... "3200","Company","?","Datasoft",...

IMPORT-Kommando

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'
 cno 1
title 2
firstname 3
name 4
zip 5
address 6
PAGE WITH 80% USAGE

Format FWV

Die Datenfelder sind einheitlich formatiert und durch einen Zeilenumbruch abgeschlossen.

Geben Sie alle Positionsbeschreibungen field_spec mit exakten Anfangs- und Endpositionen an.

Geben Sie grundsätzlich aufsteigende Werte für Positionsbeschreibungen an, die sich nicht überlappen. Wenn die Positionsangaben nicht aufeinander folgen, dann werden die so entstehenden Lücken vom Loader mit Leerzeichen aufgefüllt. Das gilt auch für binäre Daten.

EXPORT COLUMNS * FROM hotel.reservation
MAP COLUMNS
rno 01-05
cno 06-10
hno 11-15
 type 16-21
arrival 25-34
depature 36-45
DATA OUTSTREAM 'reservation_fwv.data' FWV

Datenstrom customer_fwv.data

Pos.-Nr. | 1 2 3 4 5 6 7 8 9 ....
 | - 3 0 0 0 M r s - - - - J e n n y - - - - - P o r t e r - 3 1 0 0 M r - - - - - P e t e r - - - - - B r o w n - - 3 2 0 0 C o m p a n y ? - - - - - - - - - D a t a s o

IMPORT-Kommando

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_fwv.data' FWV
cno 01-05
title 06-12
firstname 13-22
name 23-32
zip 33-37
address 38-62
PAGE WITH 80% USAGE

Definieren Sie die Positionen für den Datenstrom mindestens so groß wie die Länge der Werte in der Datenbank.

Wenn Sie für den Datenstrom eine Position definieren, die größer ist als die Länge des Wertes in der Datenbank, dann werden

● Zeichenketten linksbündig eingetragen und mit Leerzeichen auf die erforderliche Länge aufgefüllt

● numerische Werte rechtsbündig eingetragen und mit Leerzeichen auf die erforderliche Länge aufgefüllt

Wenn Sie für den Datenstrom eine Position definieren, die kleiner ist als die Länge des Wertes in der Datenbank, dann generiert der Loader einen Fehler und beendet die Ausführung des Kommandos.

Format FWV BINARY

Die Datenfelder sind einheitlich formatiert, werden jedoch nicht durch einen Zeilenumbruch abgeschlossen.

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_fwv_binary.data' FWV BINARY
cno 01-05
title 06-12
firstname 13-22
name 23-32
zip 33-37
address 38-62
PAGE WITH 80% USAGE


Datenformat (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Datenformat

Bei der Mehrzahl der Loader-Kommandos zum Exportieren und Importieren können Sie angeben, welchen externen Datentyp und welches Datenformat die jeweiligen Feldwerte im Datenstrom haben bzw. haben sollen. Das angegebene Datenformat bezieht sich auf die Spalten, die den entsprechenden datenbankinternen Datentyp haben.

Außerdem können Sie z. B. festlegen, welche Separatoren und Delimiter verwendet werden sollen.

Das Datenformat kann in Kommandos zum Exportieren und Importieren für den Datenstrom angegeben werden. Dieses Datenformat übersteuert dann den entsprechenden Vorschlagswert oder den Wert, der mit Hilfe des SET-Kommandos gesetzt wurde.

Syntax

<column_dataformat_spec> ::= CSV <csv_format_spec> ...
| FWV [BINARY] <fwv_format_spec> ...
| FWV BINARY <fwv_format_spec> ... <noheader_spec>

<table_dataformat_spec> ::= PAGES
| RECORDS <records_format_spec>

<csv_format_spec> ::= <separator_spec>
| <delimiter_spec>
| <null_spec>
| <field_format_spec>

<fwv_format_spec> ::= <null_spec>
| <int_spec>
| <field_format_spec>

<records_format_spec> ::= <field_format_spec> ...

<field_format_spec ::= <bool_spec>
| <code_spec>
| <date_spec>
| <int_spec>
| <number_spec>
| <time_spec>
| <timestamp_spec>

<noheader_spec> ::= NOHEADER <unsigned_integer>
<separator_spec> ::= SEPARATOR '<separator>'
<delimiter_spec> ::= DELIMITER '<delimiter>'
<null_spec> ::= NULL-Wert-Darstellung
<bool_spec> ::= BOOLEAN '<true_value>/<false_value>'
<code_spec> ::= Code-Spezifikation
<date_spec> ::= Datumsangaben
<int_spec> ::= INTEGER HILO | INTEGER LOHI
<number_spec> ::= DECIMAL '/[<digit_grouping_symbol>]/<decimal_symbol>/'
<time_spec> ::= Zeitangaben
<timestamp_spec> ::= Zeitstempelangaben

CSV

CSV (Comma Separated Values) ist ein Format für CHAR-Daten, bei dem eine Datenzeile genau so lang ist, wie für die Abbildung der Daten minimal erforderlich ist. Die Zuordnung eines Datenfeldes des Datenstroms zu einer Spalte in der Tabelle erfolgt gemäß der Positionsangabe.

FWV

FWV (Fixed Width Values) ist ein Format für Klarextwerte, bei dem eine Datenzeile im Datenstrom einem Datensatz entspricht. Die Zuordnung zwischen Datenfeldern des Datenstroms und Tabellenspalten erfolgt gemäß der Positionsangabe.

FWV BINARY

FWV BINARY (Fixed Width Values BINARY) ist ein Format für Binärwerte, bei dem die Datenfelder alle die gleiche feste Länge haben. Die Zuordnung zwischen Datenfeldern des Datenstroms und Tabellenspalten erfolgt gemäß der Positionsangabe. Im Unterschied zu FWV wird ein Datensatz nicht zusätzlich durch einen Zeilenumbruch abgeschlossen.

PAGES

Format, das angibt, dass die Anwendungsdaten in Seiten abgelegt werden

RECORDS

datenbankeigenes Format

NOHEADER <unsigned_integer>

unsigned_integer: Länge eines einzelnen Datensatzes im Datenstrom

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

SEPARATOR '<separator>'
<separator> ::= <character>

separator: Zeichen, mit dem Datenfelder bei Verwenden des CSV-Formats voneinander getrennt werden (Separator-Darstellung), Vorschlagwert: Komma (,)

Es muss genau ein Zeichen angegeben werden, das aus dem 7-Bit-ASCII-Zeichensatz stammt (nur 1 Byte lang).

siehe auch: SQL-Referenzhandbuch, Strukturlink Zeichen (character)

DELIMITER '<delimiter>'
< delimiter > ::= <character>

delimiter: Zeichen, mit dem Daten bei Verwenden des CSV-Formats in Markierungen eingeschlossen werden (Delimiter-Darstellung), Vorschlagswert: doppeltes Anführungszeichen (″)

Es kann genau ein Zeichen, das aus dem 7-Bit-ASCII-Zeichensatz stammt (nur 1 Byte lang) oder kein Zeichen (kein Delimiter) angegeben werden.

BOOLEAN '<true_value>/<false_value>'

true_value: Definiert die Zeichenkette für Werte, die wahr sind, Vorschlagwert TRUE

false_value: Definiert die Zeichenkette für Werte, die falsch sind, Vorschlagwert FALSE

Die Zeichenketten dürfen höchstens 10 Zeichen lang sein.

siehe auch: SQL-Referenzhandbuch, Strukturlink Zeichenkette

INTEGER HILO

Im aktuellen Datenstrom sind ganze Zahlen so dargestellt, dass das Byte mit der niedrigsten Wertigkeit zuerst gespeichert ist, d.h. in der binären Zahl am weitesten rechts steht (Big Endian).

INTEGER LOHI

Im aktuellen Datenstrom sind ganze Zahlen so dargestellt, dass das Byte mit der höchsten Wertigkeit zuerst gespeichert ist, d.h. in der binären Zahl am weitesten rechts steht (Little Endian, Byte Swap).

DECIMAL '/[<digit_grouping_symbol>]
/<decimal_symbol>/'

digit_grouping_symbol: Definiert ein Zeichen oder kein Zeichen für die Gliederung von Tausendern
Vorschlagswert: kein Zeichen

decimal_symbol: Definiert das Zeichen zum Trennen der Dezimalstellen
Vorschlagswert: Punkt

Als Zeichen sind Zahlen nicht zugelassen.

siehe auch: SQL-Referenzhandbuch, Strukturlink Zeichen (character)

Beispiele

EXPORT TABLE hotel.room
CATALOG OUTSTREAM 'room_ddl.catalog'
DATA OUTSTREAM 'room_csv.data'
SEPARATOR ','
 DELIMITER '"'
 NULL '? '
 DECIMAL '/./,/'
 BOOLEAN 'TRUE/FALSE'
 TIMESTAMP ISO
DATE ISO
 TIME ISO
PACKAGE OUTSTREAM 'room_csv.package'

Die erzeugte Datendatei hat folgenden Inhalt (Ausschnitt):

"10","double","45","200.00"
"10","single","20","135.00"
"20","double","13","100.00"

Loader-Tutorial, Strukturlink Exportieren, Strukturlink Importieren

Erläuterung

Mit diesen Syntaxregeln innerhalb eines Kommandos zum Exportieren und Importieren können Sie eine Reihe von Datenformaten festlegen. Einige dieser Formate sollen an dieser Stelle näher erläutert werden. Werden die Formate nicht festgelegt, verwendet der Loader die jeweiligen Vorschlagswerte, die in der Tabelle weiter oben angegeben sind.

CSV, FWV, FWV BINARY, PAGES, RECORDS

Es handelt sich um Formate des Datenstroms.

● CSV, FWV und FWV BINARY

● PAGES und RECORDS

siehe auch: Datenstrom

<noheader_spec>

Die Syntaxregel noheader_spec wird nur für IMPORT TABLE-Kommandos ausgewertet, wenn das Datenformat FWV BINARY ist. Mit noheader_spec können Sie angeben, dass der Datenstrom keinen speziellen Header mit der Länge eines einzelnen Datensatzes enthält. Gleichzeitig geben Sie die Länge eines einzelnen Datensatzes im Datenstrom an.

Wenn der Datenstrom mit dem EXPORT TABLE-Kommando erzeugt wurde, enthält er einen speziellen Header mit der Länge eines einzelnen Datensatzes im Datenstrom. Wenn dieser Header fehlt, kann dem Loader mit noheader_spec die Länge eines einzelnen Datensatzes mitgeteilt werden. Wenn diese Regel fehlt, berechnet der Loader die Länge eines einzelnen Datensatzes aus den Angaben zu den Spaltenpositionen im Ladekommando.

<bool_spec>

Sie legen mit der Syntaxregel bool_spec die Zeichenketten fest, mit der aus der Datenbankinstanz exportierte bzw. in eine Datenbankinstanz zu importierende BOOLEAN-Werte in Datenströmen repräsentiert werden. Diese Einstellung gilt für dieses Loader-Kommando. Wenn Sie die Zeichenketten nicht festlegen, wird der mit dem SET BOOLEAN-Kommando gesetzte Wert verwendet oder der Vorschlagswert des Loader.

<int_spec>

Sie legen mit der Syntaxregel int_spec die binäre Darstellung von ganzen Zahlen in den Datenströmen fest. Dies ist jedoch nur für Datenströme mit dem Format FWV BINARY möglich. Beim Exportieren in Datenströme oder beim Importieren aus Datenströmen in einem anderen Format wird diese Angabe ignoriert.

Wenn die für einen Datenstrom angegebene Darstellung nicht mit der des aktuellen Rechners übereinstimmt, werden die Werte vor dem Exportieren in den Datenstrom bzw. vor dem Importieren in die Datenbank angepasst.

<number_spec>

Sie legen mit der Syntaxregel number_spec fest, welche Zeichen bei Dezimalzahlen zu verwenden sind, um Tausender zu gliedern und ganze Zahlen von Dezimalstellen zu trennen. Diese Einstellung gilt für dieses Loader-Kommando. Wenn Sie keine Zeichen festlegen, wird der mit dem SET DECIMAL-Kommando gesetzte Wert verwendet oder der Vorschlagswert des Loader.

Siehe auch:

SET-Kommando

Datenstrom

Exportieren: Kommandos

Importieren: Kommandos


Code-Spezifikation (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Code-Spezifikation

Sie können in der Code-Spezifikation den Standard-Code-Typ für die Interpretation von Datenströmen, die Klartextwerte beinhalten, festlegen. Code-Spezifikationen können Sie mit dem SET-Kommando für eine Loader-Sitzung festlegen oder für ein Loader-Kommando durch die Definition des Datenformats angeben.

Syntax

<set_codetype_command> ::= SET CODETYPE <standard_code_spec>

<code_spec> ::= <standard_code_spec>
| CODESET <literal>

<standard_code_spec> ::= ASCII | UCS2 | UTF8

ASCII | Code-Typ für die Interpretation von Datenströmen ist ASCII Vorschlagswert des Loader: ASCII
UCS2 | Code-Typ für die Interpretation von Datenströmen ist UCS2
UTF8 | Code-Typ für die Interpretation von Datenströmen ist UTF8
CODESET <literal> | literal: Bezeichnung des Code-Typs siehe auch: SQL-Referenzhandbuch, Strukturlink Literal (literal)

Code-Spezifikation bei Verwendung von LONG-Daten

<lob_code_spec> ::= <code_spec> | BINARY

BINARY

Daten werden ohne Konvertierung exportiert/importiert

Die Angabe von BINARY ist nur für Spalten vom Datentyp LONG BYTE sinnvoll.

Beispiele

EXPORT TABLE hotel.room
CATALOG OUTSTREAM 'room_ddl.catalog'
DATA OUTSTREAM 'room_csv.data' ASCII

Code-Spezifikation bei Verwendung von LONG-Daten:
Exportieren und Importieren von LONG-Werten

Erläuterung

Wenn die Angabe der Code-Spezifikation code_spec im Kommando fehlt, verwendet der Loader den mittels des SET CODETYPE-Kommandos gesetzten oder einen Vorschlagswert für den Code-Typ.

● SET CODETYPE-Kommando:
Diese Einstellung gilt für die gesamte Loader-Sitzung, sofern die Zeichenketten nicht durch ein erneutes SET CODETYPE-Kommando geändert wird.
Sie haben die Möglichkeit, für einzelne Kommandos den aktuellen Wert durch Verwenden des Syntaxelements code_spec zur Definition des Datenformats (field_format_spec) zu ändern.

● Vorschlagswert: Der Vorschlagswert wird aus dem datenbankinternen Datentyp der zu importierenden Spalte abgeleitet. Wenn der datenbankinterne Datentyp und die Code-Spezifikation der Datenströme unterschiedlich sind, konvertiert der Loader die Daten. Bei Inkompatibilität des Datenbanktyps mit der Code-Spezifikation erzeugt der Loader eine Fehlermeldung und beendet die Bearbeitung des Kommandos.

<code_spec>

Sie haben die Möglichkeit, beim Exportieren oder Importieren von Daten diese zwischen verschiedenen Code-Typen zu transformieren. Beim Exportieren/Importieren von ASCII-Daten in eine ASCII-Datenbank oder von UCS2-Daten in eine UNICODE-Datenbank ist keine Konvertierung notwendig.

Mögliche Kombinationen (datenbankinterner und externer Datentyp) sind:

Datenbankinterner Datentyp | Mögliche Code-Spezifikationen für Datenströme mit Klartextwerten beim Exportieren
(VAR)CHAR ASCII | ASCII, UCS2, UTF8
(VAR)CHAR UNICODE | UCS2, UTF8
(VAR)CHAR BYTE | BINARY, ASCII (HEX), UCS2 (HEX), UTF8 (HEX)
Numerische Datentypen | ASCII, UCS2, UTF8

Datenbankinterner Datentyp | Mögliche Code-Spezifikationen für Datenströme mit Klartextwerten beim Importieren
(VAR)CHAR ASCII | ASCII
(VAR)CHAR UNICODE | ASCII, UCS2, UTF8
(VAR)CHAR BYTE | BINARY, ASCII, UCS2 (HEX), UTF8 (HEX)
Numerische Datentypen | ASCII, UCS2, UTF8

<lob_code_spec>

Beim Export/Import von LONG-Daten legen Sie die Standard-Code-Typen mit Hilfe der Syntaxregel lob_code_spec fest. So haben Sie die Möglichkeit, die LONG-Daten zwischen verschiedenen Code-Typen zu konvertieren.

Beim Export/Import von ASCII-LONG-Daten in eine ASCII-Datenbank oder von UCS2-LONG-Daten in eine UNICODE-Datenbank ist keine Konvertierung notwendig.

Mögliche Kombinationen (datenbankinterner und externer Datentyp) sind:

Datenbankinterner Datentyp | Mögliche Code-Spezifikationen des LONG-Datenstroms beim Exportieren
LONG ASCII | ASCII, UCS2, UTF8
LONG UNICODE | UCS2, UTF8
LONG BYTE | BINARY, ASCII (HEX), UCS2 (HEX), UTF8 (HEX)

Datenbankinterner Datentyp | Mögliche Code-Spezifikationen des LONG-Datenstroms beim Importieren
LONG ASCII | ASCII
LONG UNICODE | ASCII, UCS2, UTF8
LONG BYTE | BINARY, ASCII, UCS2 (HEX), UTF8 (HEX)

Siehe auch:

Exportieren und Importieren von LONG-Werten

Datentypen

SQL-Referenzhandbuch, Strukturlink Datentyp (data_type)


CSV, FWV, FWV BINARY (SAP-Bibliothek - Werkzeuge)

Objektdokumentation CSV, FWV, FWV BINARY

Definition

CSV (auch COMPRESSED), FWV (auch FORMATTED) und FWV BINARY (auch FORMATTED BINARY) sind mögliche Formate eines Datenstroms und werden im Folgenden näher erläutert.

Verwendung

Der Loader setzt voraus, dass Datenströme mit Klartextwerten das Format CSV haben. Eine explizite Angabe des Formates CSV ist daher nicht erforderlich. Wenn das Format CSV nicht gewünscht ist, müssen Sie in einem Kommando zum Exportieren oder Importieren das Format FWV bzw. bei binär codierten Datenströmen das Format FWV BINARY explizit angeben.

Das gewünschte Format kann in Kommandos zum Exportieren und Importieren mit den Syntaxregeln zum Datenformat column_dataformat_spec und Datenstrom outstream_csv_spec, instream_csv_spec, outstream_fwv_spec, instream_fwv_spec angegeben werden.

Siehe auch:

Datenformat, Datenstrom

CSV (COMPRESSED)

CSV (Comma Separated Values) bezeichnet ein mögliches Format eines Datenstroms, das nur für Quelldatenströme mit Klartextwerten möglich ist. Wenn Sie in einem Kommando zum Exportieren oder Importieren kein Format angeben und die Daten nicht in Klarschrift sind, erzeugt der Loader eine Fehlermeldung.

customer.data

Pos.-Nr. | 1 2 3 4 ....
 | "3000","Mrs","Jenny","Porter",... "3100","Mr","Peter","Brown",... "3200","Company","?","Datasoft",...

Die Datenfelder sind nicht einheitlich formatiert, sie sind durch Komma voneinander getrennt.

IMPORT TABLE-Kommando:

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'
 cno 1
title 2
firstname 3
name 4
zip 5
address 6
PAGE WITH 80% USAGE

Datenzeilen

Im Format CSV ist eine Datenzeile genau so lang, wie für die Abbildung der Daten minimal erforderlich ist. Die Länge der einzelnen Datenfelder und die Gesamtlänge der Datenzeilen können variieren. Jede Datenzeile ist durch einen Zeilenumbruch abgeschlossen.

Beim Export von Daten entspricht eine Datenzeile in einer Quelltabelle dieses Formats genau einem Datensatz im Zieldatenstrom.

Beim Import von Daten entspricht eine Datenzeile in einem Quelldatenstrom dieses Formats genau einem Datensatz in der Zieltabelle.

Datenfelder

Datenfelder in den Datenströmen müssen grundsätzlich vom externen Datentyp CHAR sein.

Die einzelnen Datenfelder sind durch ein frei wählbares Zeichen voneinander getrennt (Vorschlagswert des Loader für Separator: Komma). Sie können zusätzlich in frei wählbare Zeichen eingeschlossen sein (Vorschlagswert des Loader für Delimiter: doppelte Anführungszeichen).

Wenn in einer Datenzeile Trennzeichen unmittelbar aufeinanderfolgen, dann ist der Wert die leere Zeichenkette. Wenn die relative Position größer ist, als die Anzahl von Werten in der Zeile, dann ist der Wert ebenfalls die leere Zeichenkette.

Positionsangabe

Die Zuordnung eines Datenfeldes des Datenstroms zu einer Spalte in der Tabelle erfolgt gemäß der Positionsangabe in einem Kommando zum Exportieren oder Importieren von Daten. Diese beschreibt eine relative Position innerhalb des Datensatzes. Sie gibt also an, der wievielte Wert eines Datensatzes aus einer bestimmten Spalte exportiert bzw. in eine bestimmte Spalte importiert werden soll.

Beim Export von Daten aus der Datenbank in einen Datenstrom ordnen Sie der ersten Spalte Ihrer Liste die Position 1 zu. Die nachfolgenden Spalten erhalten aufsteigende, jeweils um die Zahl 1 erhöhte Positionsnummern. Das bedeutet auch, dass jede Positionsnummer nur einmal vergeben werden kann.

Beim Import von Daten aus einer Quelltabelle müssen die Datenfelder der Zieltabelle in der Datenbank in aufsteigender Reihenfolge sortiert sein. Es ist möglich, verschiedene Spalten mit den gleichen Eingabewerten zu belegen oder auch Positionen auszulassen. Wenn Trennzeichen unmittelbar aufeinanderfolgen oder die relative Position größer ist als die Anzahl von Werten in der Zeile, dann ist die leere Zeichenkette der Wert.

FWV (FORMATTED)

FWV (Fixed Width Values) bezeichnet ein mögliches Format eines Datenstroms, das nur für Quelldatenströme mit Klartextwerten möglich ist. Da dieses Format nicht der Vorschlagswert des Loader ist, muss es in einem Kommando zum Export oder Import explizit angegeben werden.

customer.data

Pos.-Nr. | 1 2 3 4 5 6 7 8 9 ....
 | - 3 0 0 0 M r s - - - - J e n n y - - - - - P o r t e r - 3 1 0 0 M r - - - - - P e t e r - - - - - B r o w n - - 3 2 0 0 C o m p a n y ? - - - - - - - - - D a t a s o

Die Datenfelder sind einheitlich formatiert.

IMPORT TABLE-Kommando:

IMPORT TABLE hotel.customer
DATA INSTREAM FILE 'customer.data' FWV
 cno 01-05
title 06-12
firstname 13-22
name 23-32
zip 33-37
address 38-62
PAGE WITH 80% USAGE

Datenzeilen

Eine Datenzeile im Datenstrom entspricht einem Datensatz, der exportiert oder importiert werden soll.

Alle Datenzeilen haben die gleiche feste Länge. In jeder Zeile im Datenstrom sind die einzelnen Datenfelder an gleicher Position mit gleicher Länge zu finden. Jede Datenzeile ist mit einem Zeilenumbruch abgeschlossen.

Datenfelder

Die Zuordnung zwischen Datenfeldern des Datenstroms und Tabellenspalten erfolgt anhand der Positionsangabe in einem Kommando zum Exportieren oder Importieren von Daten.

Positionsangabe

Die Datenfelder des Datenstroms werden durch ihre Byte-Anfangs- und -Endposition beschrieben. Die erste mögliche Byte-Anfangsposition ist 1. Die Angabe einer Endposition ist optional. Wenn für ein Datenfeld keine Endposition angegeben wird, hat dieses Datenfeld die Länge 1.

Die Zuordnung zwischen Datenfeldern des Datenstroms und Tabellenspalten kann in beliebiger Reihenfolge erfolgen. Die Reihenfolge hat auch keine Auswirkungen auf die Verarbeitungsgeschwindigkeit.

FWV BINARY (FORMATTED BINARY)

FWV BINARY (Fixed Width Values BINARY) bezeichnet ein mögliches Format eines Datenstroms, das den Export und Import von Binärwerten ermöglicht. Da dieses Format nicht der Vorschlagswert des Loader ist, muss es in einem Kommando zum Exportieren und Importieren explizit angegeben werden.

Datenzeilen

Das Format FWV BINARY entspricht im Wesentlichen dem Format FWV. Es unterscheidet sich jedoch dadurch, dass die Länge eines Datensatzes nur durch die Summe der Längen der einzelnen Datenfelder bestimmt ist.

Im Unterschied zu FWV wird ein Datensatz nicht zusätzlich durch einen Zeilenumbruch abgeschlossen.

Datenfelder

Die Datenfelder können Sonderzeichen enthalten und haben alle die gleiche feste Länge. Dies trifft damit auch auf die einzelnen Datensätze zu.

Die Zuordnung zwischen Datenfeldern des Datenstroms und Tabellenspalten erfolgt gemäß der Positionsangabe im Kommando zum Exportieren oder Importieren.

Positionsangaben

Datenfelder werden durch ihre Byte-Anfangs- und -Endposition beschrieben. Die erste mögliche Byte-Anfangsposition eines Datensatzes ist 1. Die Angabe einer Endposition ist optional. Wenn sie fehlt, hat das entsprechende Datenfeld die Länge 1.

Die Datenfelder des Datenstroms können den Tabellenspalten in beliebiger Reihenfolge zugeordnet werden. Die Reihenfolge hat auch keine Auswirkungen auf die Verarbeitungsgeschwindigkeit.

Sowohl beim Exportieren als auch Importieren von Daten müssen die Positionsangaben nicht lückenlos aufeinanderfolgen. Beim Exportieren füllt der Loader die Lücken mit Leerzeichen auf.

Siehe auch:

PAGES, RECORDS


PAGES, RECORDS (SAP-Bibliothek - Werkzeuge)

Objektdokumentation PAGES, RECORDS

Definition

PAGES und RECORDS sind mögliche Formate eines Datenstroms und werden im Folgenden näher erläutert.

Verwendung

In den Kommandos EXPORT DB, EXPORT USER und EXPORT SCHEMA bzw. IMPORT DB, IMPORT USER und IMPORT SCHEMA müssen Sie eines der beiden Formate verwenden.

Der Loader setzt bei diesen Kommandos voraus, dass Datenströme das Format PAGES haben. Eine explizite Angabe des Formates PAGES ist daher nicht erforderlich. Wenn das Format PAGES nicht gewünscht ist, müssen Sie in einem Kommando zum Exportieren bzw. Importieren das Format RECORDS explizit angeben.

In den Kommandos EXPORT TABLE bzw. IMPORT TABLE können Sie die Formate PAGES und RECORDS ebenfalls verwenden. Allerdings müssen Sie in einem EXPORT TABLE bzw. IMPORT TABLE-Kommando das Format PAGES bzw. RECORDS immer explizit angeben, da der Vorschlagswert CSV ist.

Die Formate PAGES und RECORDS sind Loader-eigene Binärformate. Die Datenströme sollten vom Benutzer nicht manuell verändert werden. Die Daten liegen nicht lesbar in diesen Formaten vor.

Das gewünschte Format kann in Kommandos zum Exportieren und Importieren mit den Syntaxregeln zum Datenformat table_dataformat_spec und Datenstrom outstream_pages_spec, instream_pages_spec, outstream_records_spec, import_records_spec angegeben werden.

Siehe auch:

Datenformat, Datenstrom

PAGES

Die Daten werden als Seiten im Datenstrom abgelegt.

● EXPORT TABLE: Der Loader erzeugt einen einzelnen Datenstrom.

● EXPORT DB, EXPORT USER, EXPORT SCHEMA: Der Loader erzeugt mindestens zwei Datenströme. In Abhängigkeit vom zu exportierenden Datenvolumen werden mehr als zwei Datenströme erzeugt.

Die Namen der Datenströme werden wie folgt gebildet: an die Namen werden jeweils 4 Ziffern angehängt beginnend bei 0000. Die maximale Anzahl von Datenströmen ist damit auf 9999 festgelegt.

Der Datenstrom mit der Ziffernfolge 0000 ist die so genannte Mapping-Datei, in der der Loader Angaben zur Verwaltung der Datenströme beim Import speichert. Diese Datei ist lesbar sollte aber nicht verändert werden.

Der Datenstrom mit der Ziffernfolge 0001 und größer enthält die eigentlichen Daten, d.h. die Anwendungsdaten der Tabellen werden in Seiten gespeichert.

Der bzw. die Datenströme mit den Anwendungsdaten enthält alle Anwendungsdaten einer Tabelle, gegebenenfalls auch die LONG-Werte.

Das Format PAGES ermöglicht einen sehr schnellen Export bzw. Import über spezielle, nur dem Loader verfügbare Kommandos. Beim Import werden keine Log-Einträge geschrieben und die Tabelle ist anschließend schreibgeschützt. Wenn Tabellendaten im Format PAGES importiert wurden, können diese daher anschließend nur geändert werden, wenn eine inkrementelle oder vollständige Datensicherung durchgeführt wurde.

Konzepte des Datenbanksystems, Strukturlink Daten sichern

EXPORT/IMPORT TABLE

Beim Export bzw. Import einer Tabelle im Format PAGES können Sie keine weiteren Angaben zu den Spalten machen. Alle relevanten Informationen sind bereits in den Datenströmen enthalten.

Sie können die Daten nicht in eine Tabelle importieren, wenn eine der folgenden Situationen eintritt:

● die binäre Struktur der Tabelle unterscheidet sich von der Struktur der Quelltabelle

● die Tabelle, in die die Daten importiert werden sollen, enthält bereits Daten

In beiden Fällen bricht der Loader den IMPORT mit einem Fehler ab.

Beispiele

EXPORT USER DATA OUTSTREAM 'mona_pages.data'

Export der Anwendungsdaten des Datenbankbenutzers MONA in den Datenstrom mona_pages.data im Format PAGES (Vorschlagswert)

Mapping-Datei mona_pages.data0000

"HOTEL","CITY","1","?","?","?","?","mona.pages0001","FILE","?","PAGES","ASCII","0","1024","0","66560","0","0"

"HOTEL","CUSTOMER","2","?","?","?","?","mona.pages0001","FILE","?","PAGES","ASCII","0","66560","0","132096","0","0"

"HOTEL","HOTEL","3","?","?","?","?","mona.pages0001","FILE","?","PAGES","ASCII","0","132096","0","214016","0","0"

"HOTEL","ROOM","4","?","?","?","?","mona.pages0001","FILE","?","PAGES","ASCII","0","214016","0","279552","0","0"

"HOTEL","EMPLOYEE","5","?","?","?","?","mona.pages0001","FILE","?","PAGES","ASCII","0","279552","0","345088","0","0"

"HOTEL","RESERVATION","6","?","?","?","?","mona.pages0001","FILE","?","PAGES","ASCII","0","345088","0","410624","0","0"

Loader-Tutorial, Strukturlink Exportieren, Strukturlink Importieren

RECORDS

Die Daten werden in einem loader-eigenen Binärformat ähnlich wie ein Datenbank-Record im Datenstrom abgelegt.

● EXPORT TABLE: Der Loader erzeugt einen einzelnen Datenstrom.

● EXPORT DB, EXPORT USER, EXPORT SCHEMA: Der Loader erzeugt zwei Datenströme.

Die Namen der Datenströme werden wie folgt gebildet: an die Namen werden jeweils 4 Ziffern angehängt, entweder 0000 oder 0001.

Der Datenstrom mit der Ziffernfolge 0000 ist die so genannte Mapping-Datei, in der der Loader Angaben zur Verwaltung der Datenströme beim Import speichert. Diese Datei ist lesbar sollte aber nicht verändert werden.

Der Datenstrom mit der Ziffernfolge 0001 enthält die eigentlichen Daten, d.h. die Anwendungsdaten der Tabellen werden hintereinander gespeichert.

Der Datenstrom mit den Anwendungsdaten enthält alle Anwendungsdaten einer Tabelle, gegebenenfalls auch die LONG-Werte.

Bei Einsatz des Formats RECORDS verwendet der Loader von ihm erzeugte übliche Massen-SELECT- und Massen-INSERT-Anweisungen.

Beispiele

EXPORT USER DATA OUTSTREAM 'mona_records.data' RECORDS

Export der Anwendungsdaten des Datenbankbenutzers MONA in den Datenstrom mona_records.data im Format RECORDS

Mapping-Datei mona_records.data0000

"HOTEL","CITY","1","?","?","?","?","mona.records0001","FILE","?","RECORDS","ASCII","0","0","0","2610","0","1586"

"HOTEL","CUSTOMER","2","?","?","?","?","mona.records0001","FILE","?","RECORDS","ASCII","0","2610","0","5463","0","4439"

"HOTEL","HOTEL","3","?","?","?","?","mona.records0001","FILE","?","RECORDS","ASCII","0","5463","0","10240","0","9216"

"HOTEL","ROOM","4","?","?","?","?","mona.records0001","FILE","?","RECORDS","ASCII","0","10240","0","13199","0","12175"

"HOTEL","EMPLOYEE","5","?","?","?","?","mona.records0001","FILE","?","RECORDS","ASCII","0","13199","0","15552","0","14528"

"HOTEL","RESERVATION","6","?","?","?","?","mona.records0001","FILE","?","RECORDS","ASCII","0","15552","0","18033","0","17009"

Siehe auch:

CSV, FWV, FWV BINARY


Datenträgertyp (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Datenträgertyp

Der Loader verwendet für die physische Ablage des Datenstroms beim Export/Import außerhalb der Datenbankinstanz einen Datenträger.

Der Typ des Datenträgers kann in Kommandos zum Exportieren und Importieren im Syntaxelement mediumtype_spec für den Datenstrom angegeben werden.

Siehe auch:

Datenstrom

Syntax

<mediumtype_spec> ::= FILE | PIPE | TAPE [<ebid_spec>]

FILE | Datenträger für den Datenstrom ist das Dateisystem Vorschlagswert: FILE
PIPE | Datenträger für den Datenstrom ist eine Pipe
TAPE | (nur für EXPORT DB relevant): Datenträger für den Datenstrom ist ein Band, das über ein Sicherungswerkzeug anderer Anbieter angesprochen wird
TAPE <ebid_spec> | (nur für IMPORT DB relevant): Datenträger für den Datenstrom ist ein Band, das über ein Sicherungswerkzeug anderer Anbieter angesprochen wird
<ebid_spec> | EBID '<literal>' Sie müssen die externe Sicherungskennung literal des zu importierenden Datenstroms angeben. siehe auch: SQL-Referenzhandbuch, Strukturlink Literal (literal)

Erläuterung

Sie können mit der Syntaxregel mediumtype_spec dem Datenstrom einen Datenträgertyp zuordnen. Der Loader unterscheidet die in mediumtype_spec angegebenen Datenträgertypen. Wenn Sie keinen Datenträgertyp angegeben, verwendet der Loader Dateien des Dateisystem (FILE) als Datenträger für den Datenstrom.

Verwenden von Sicherungswerkzeugen anderer Anbieter

Der Datenträgertyp TAPE wird für das Exportieren/Importieren der gesamten Datenbank und/oder des gesamten Datenbankkatalogs (EXPORT/IMPORT DB) unterstützt. In diesem Fall wird das für die Loader-Sitzung festgelegte Sicherungswerkzeug anderer Anbieter für das Exportieren/Importieren verwendet.

Siehe auch:

Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter

EXPORT DB-Kommando

IMPORT DB-Kommando


Spaltenbeschreibung (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Spaltenbeschreibung

Die hier aufgeführten Syntaxregelen sind Bestandteile der Spaltenbeschreibung in den Kommandos zum Exportieren, Importieren und Aktualisieren von Anwendungsdaten.

Wenn Sie Schlüsselwörter als Spaltennamen verwenden wollen, müssen diese in doppelte Anführungszeichen eingeschlossen werden.

Syntax

<export_column_spec> ::= <map_column_field>
| <field_assignment>

<import_column_spec> ::= <map_field_column> [<null_condition>]
| <column_assignment>

<update_column_spec> ::= <map_field_column>
| <column_assignment>

<map_column_field> ::= Ausgabespalte
<field_assignment> ::= Ausgabespalte

<map_field_column> ::= <column_name> <field_spec> <field_function>
<column_name> ::= <identifier>
<field_spec> ::= Positionsbeschreibung
<field_function> ::= <field_type> [HEX]
| <numerical_functions>
| <field_type> [HEX] <numerical_functions>

<field_type> ::= Datentypen
<numerical_functions> ::= <scale_spec>
| <round_or_trunc_spec>
| <scale_spec> <round_or_trunc_spec>

<scale_spec> ::= SCALE <unsigned_integer>
<round_or_trunc_spec> ::= ROUND <unsigned_integer>
| TRUNC <unsigned_integer>

<null_condition> ::= NULL-Wert-Darstellung

<column_assignment> ::= <column_name> '<literal>'
| <column_name> <column_function>
<column_name> ::= <identifier>
<column_function> ::= Importieren von beliebigen und speziellen Konstanten

<column_name> | Spaltenname siehe auch: SQL-Referenzhandbuch, Strukturlink Spaltenname (column_name)
HEX | Sie können HEX-Werte definieren.
SCALE <unsigned_integer> | Der Skalierungsfaktor unsigned_integer, kann positiv oder negativ sein Der Wert, auf den sich die Syntaxregel bezieht, wird mit der entsprechenden Zehnerpotenz multipliziert. siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)
ROUND <unsigned_integer> | TRUNC <unsigned_integer> | Anzahl der Stellen unsigned_integer nach dem Komma Der Wert muss zwischen 0 und 18 liegen. Wenn die Zahl keine Nachkommastellen hat, hat die Funktion keinen Effekt.
<column_name> '<literal>' | Angabe eines Literals als Spaltenwert siehe auch: SQL-Referenzhandbuch, Strukturlink Literal (literal)

Beispiele

Im Abschnitt Loader-Tutorial, Strukturlink IMPORT TABLE, Strukturlink IMPORT COLUMNS, Strukturlink UPDATE COLUMNS und in den folgenden Abschnitten

Erläuterung

Sie beschreiben mit der Syntaxregel import_column_spec in einem Kommando zum Importieren oder Aktualisieren von Anwendungsdaten (IMPORT TABLE, IMPORT COLUMNS, UPDATE COLUMNS) die zu importierenden Datensätze eines Datenstroms. Sie ordnen die Datenfelder des Datenstroms den Spalten der Zieltabelle zu und geben die externen Datentypen sowie die Bedingungen für das Importieren der Daten an. Angaben wie Spaltenname und Positionsbeschreibung finden auch in Beschreibungen der Ausgabespalten Verwendung.

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'
cno 1
title 2
firstname 3
name 4
zip 5
address 6

IMPORT TABLE hotel.reservation
DATA INSTREAM 'reservation_fwv_binary.data' FWV BINARY
rno 01-04 INTEGER
cno 05-08 INTEGER
hno 09-12 INTEGER
type 13-18 CHAR
arrival 19-28 CHAR
departure 29-38 CHAR

Für jede Spalte, die Sie im Import-Kommando angeben, müssen Daten im Datenstrom vorhanden sein.

Wenn Sie im Kommando Spalten der Zieltabelle nicht angeben, wird beim Import die gesamte Spalte mit dem definierten Vorschlagswert für diese Spalte belegt. Wenn kein spezieller Vorschlagswert für die Spalte festgelegt ist, wird der NULL-Wert importiert.

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'
cno 1
name 4
address 6

Die Werte der Spalten TITLE, FIRSTNAME und ZIP werden beim Import mit dem Vorschlagswert belegt.

Schlüsselspalten und Pflichtspalten (Spalten, die NOT NULL ohne Vorschlagswert definiert sind) müssen im Import-Kommando angegeben werden. Ansonsten wird die Verarbeitung mit einem SQL-Fehler abgebrochen.

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'
name 4
zip 5
address 6

Das Kommando wird mit SQL-Fehler abgebrochen, da die Spalte CNO fehlt.

Wenn Sie im Import-Kommando keine Spalten für die Zieltabelle angeben, dann wird die Tabelle so importiert, als wären alle Spalten der Zieltabelle im Kommando angegeben worden. In diesem Fall müssen für alle Spalten der Zieltabelle Daten im Datenstrom vorhanden sein.

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'

Für alle Spalten der Zieltabelle müssen Daten im Datenstrom vorhanden sein.

<map_field_column>

In einem Kommando zum Importieren oder Aktualisieren von Anwendungsdaten ordnen Sie mit der Syntaxregel map_field_column ein Datenfeld des Datenstroms einer Spalte der Zieltabelle zu.

Sie geben dazu den Spaltennamen, die Position und den externen Datentyp der Daten im Datenstrom an.

IMPORT TABLE hotel.reservation
DATA INSTREAM FILE 'reservation.data' FORMATTED BINARY
 rno 01-04 INTEGER
 cno 05-08 INTEGER
hno 09-12 INTEGER
type 13-18 INTEGER
arrival 19-28 CHAR
departure 29-38 CHAR

<field_function>

In einem Kommando zum Exportieren oder Importieren von Anwendungsdaten spezifizieren Sie mit der Syntaxregel field_function die Datenfelder im Datenstrom (externer Datentyp, Position etc.).

Sie können mit der Syntaxregel numerical_function numerische Datenwerte beim Importieren aus dem Datenstrom in die Zieltabelle sowie beim Exportieren aus der Quelltabelle in den Datenstrom skalieren (scale_spec), runden und/oder kürzen (round_or_trunc_spec).

Beachten Sie, dass Sie scale_spec immer vor round_or_trunc_spec angeben müssen.

EXPORT COLUMNS * FROM hotel.room
MAP COLUMNS
hno 1
 type 2
free 3
price 4 SCALE -1 TRUNC 2
DATA OUTSTREAM 'room_csv.data'

Sie legen mit der Syntaxregel round_or_trunc_spec für eine Zahl die Anzahl der Stellen nach dem Komma fest.

● ROUND <unsigned_integer>
Der Wert wird ausgehend von der (<unsigned_integer>+1). Stelle nach dem Komma gerundet. Wenn diese Ziffer >= 5 ist, wird aufgerundet. Wenn sie < 5 ist, wird abgerundet. Das Ergebnis ist eine Zahl, bei der die (<unsigned_integer>+1). Stelle und alle folgenden Stellen 0 sind. Die vorderen Ziffern der Zahl können aber durch Aufrunden verändert worden sein.

● TRUNC <unsigned_integer>
Die (<unsigned_integer>+1). und alle folgenden Nachkommastellen des Wertes werden auf 0 gesetzt. Die ersten <unsigned_integer> Stellen nach dem Komma bleiben unverändert.

<column_assignment>

Sie können mit der Syntaxregel column_assignment festlegen, dass für die spezifizierte Spalte die angegebene beliebige oder spezielle Konstante als Wert importiert oder aktualisiert wird und nicht der entsprechende Wert aus dem Datenstrom.

Weitere Informationen dazu finden Sie im Abschnitt Importieren von beliebigen und speziellen Konstanten.

Wenn der Datenstrom leer ist, werden die im Kommando angegebenen Konstanten nicht importiert.

Siehe auch:

Ausgabespalte

EXPORT COLUMNS-Kommando

IMPORT COLUMNS-Kommando

IMPORT TABLE-Kommando

UPDATE COLUMNS-Kommando


Datentypen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Datentypen

Bei der Mehrzahl der Loader-Kommandos zum Exportieren und Importieren können Sie angeben, welchen Datentyp die jeweiligen Feldwerte im Datenstrom haben bzw. haben sollen.

Es werden datenbankinterne und externe Datentypen unterschieden.

● Datenbankinterne Datentypen

Datenbankinterne Datentypen sind die für die Spalten der Datenbanktabelle definierten Datentypen.
Eine Erläuterung aller datenbankinternen Datentypen finden Sie im SQL-Referenzhandbuch, Strukturlink Datentyp (data_type).

● Externe Datentypen

Externe Datentypen sind die Datentypen, in die der Loader die datenbankinternen Datentypen beim Exportieren von Anwendungsdaten umwandeln kann bzw. die der Loader beim Importieren in datenbankinterne Datentypen umwandeln kann.
Der externe Datentyp kann für jeden zu exportierenden oder importierenden Feldwert in den Kommandos zum Exportieren oder Importieren mit dem Syntaxelement field_type angegeben werden.

Die Spezifikation der Datentypen gibt dem Loader an, wie die Daten des Datenstroms zu interpretieren sind.

● Beim Exportieren von Anwendungsdaten aus einer Tabelle werden die datenbankinternen Datentypen in die angegebenen externen Datentypen konvertiert und die entsprechenden Spaltenwerte exportiert.

● Beim Importieren von Anwendungsdaten in eine Tabelle werden die angegebenen externen Datentypen in datenbankinterne Datentypen konvertiert und die entsprechenden Spaltenwerte einer Tabelle importiert.

Der externe Datentyp und der entsprechende datenbankinterne Datentyp des Spaltenwerts in der Zieltabelle müssen nicht notwendigerweise übereinstimmen.

Siehe auch:

Spaltenbeschreibung

Ausgabespalte

Selektieren von Datensätzen

Syntax

<field_type> ::= /* empty */ | CHAR | DECIMAL [(<unsigned_integer>)]
| INTEGER | REAL | ZONED [(<unsigned_integer>)]

/* empty */ | Das Datenfeld wird als Datentyp CHAR gelesen oder ausgegeben. Das Lesen bzw. die Ausgabe im CHAR-Datentyp ist für jedes datenbankinterne Spaltenformat möglich.
CHAR (Klartextwert) | Je nach Rechner ASCII-, UCS2- oder UTF8-codiert, max. 254 Bytes lang
DECIMAL (Binärwert) | Gepackt dezimal: eine Ziffer pro Halbbyte, Vorzeichen im am weitesten rechts stehenden Halbbyte, 1 bis 10 Bytes lang, max. 18 Ziffern, die Stellung des gedachten Dezimalpunktes wird vom Typ der Tabellenspalte abgeleitet
DECIMAL(<unsigned_integer>) (Binärwert) | unsigend_integer: Anzahl der Stellen rechts vom gedachten Dezimalpunkt
INTEGER (Binärwert) | Binär codiert (rechnerspezifisch), 1, 2 oder 4 Bytes lang, Vorzeichen in Bit 0, negative Werte in Zweierkomplementform
REAL (Binärwert) | Gleitkommadarstellung mit Mantisse und Exponent, 4 oder 8 Bytes lang, in der rechnerspezifischen Darstellung
ZONED (Binärwert) | Gezont dezimal: zulässig ist das /370 Zoned Data Format, die Stellung des gedachten Dezimalpunktes wird vom Typ der Tabellenspalte abgeleitet
ZONED(<unsigned_integer>) (Binärwert) | unsigend_integer: Anzahl der Stellen rechts vom gedachten Dezimalpunkt

Beispiele

IMPORT TABLE hotel.reservation
DATA INSTREAM 'reservation_fwv.data' FWV BINARY
rno 01-04 INTEGER
cno 05-08 INTEGER
hno 09-12 INTEGER
type 13-18 CHAR
arrival 19-28 CHAR
departure 29-38 CHAR

Die Datenbanktabelle RESERVATION fordert für die Werte in den Spalten RNO, CNO und HNOden datenbankinternen Datentyp FIXED.

Das IMPORT TABLE-Kommando definiert für diese Spalten den externen Datentyp INTEGER. Die Daten der Spalten RNO, CNO und HNO werden beim Import in den datenbankinternen Datentyp FIXED konvertiert.

IMPORT TABLE room
DATA INSTREAM 'room_fwv_binary.data' FWV BINARY
  hno     01-05
  type    06-11
  free    12-19  INTEGER  HEX
price 20-27 INTEGER HEX

Das IMPORT TABLE-Kommando definiert für die Spalten FREE und PRICE als externen Datentyp hexadezimale Werte. Das wird durch die zusätzlichen Spezifikation HEX erreicht.

Erläuterung

Wenn für einen Feldwert kein externer Datentyp angegeben ist, wählt der Loader als Vorschlagswert den Datentyp CHAR für diesen Feldwert aus. Für den Fall, dass der Feldwert nicht den Datentyp CHAR hat bzw. der Datentyp CHAR nicht gewünscht ist, ist die Angabe des Datentyps daher zwingend erforderlich.

Binärwerte

Alle numerischen externen Datentypen (INTEGER, REAL, DECIMAL, ZONED) werden als Binärwerte interpretiert. Sie sind in die datenbankinternen Datentypen (FIXED, SMALLINT, INTEGER, FLOAT) beliebig konvertierbar.

● Daten des Datentyps INTEGER werden vom Loader grundsätzlich als vorzeichenbehaftete Werte interpretiert. Ihre Darstellung in einem Datenstrom kann mit Hilfe des Syntaxelements int_spec angepasst werden.

● Daten des Datentyps REAL sind in der rechnerspezifischen Form codiert und können nicht ohne zusätzliche Konvertierung zwischen verschiedenen Betriebssystemen und Rechnerplattformen transportiert werden.

Klartextwerte

Feldwerte mit dem externen Datentyp CHAR sind Klartextwerte, d.h. diese Werte bestehen aus lesbaren Zeichen.

● Klartextwerte können in unterschiedlichen Ausprägungen vorliegen: ASCII, UCS2 oder UTF8 (Code-Spezifikation).

● Für Klartextwerte, die Datum, Zeit oder einen Zeitstempel darstellen, können deren Datenformate (Datums-, Zeit-, Zeitstempelangabe) angegeben werden.

Diese Datenformate können in Kommandos zum Exportieren und Importieren als Verarbeitungsspezifikation für den Datenstrom angegeben werden.

Klartextwerte können für Spalten jedes beliebigen datenbankinternen Datentyps als Eingabe verwendet und in diesen konvertiert werden. Wenn Klartextwerte in numerische Spalten importiert werden sollen, müssen die Werte auch als Zahl interpretierbar sein.

HEX-Werte

Sie können einen externen Datentyp mit der zusätzlichen Spezifikation HEX (siehe dazu: Spaltenbeschreibung, Ausgabespalte) als hexadezimalen Wert beschreiben.

Damit haben Sie die Möglichkeit, alle Datentypen auch hexadezimal codiert zu exportieren oder zu importieren. Im Ergebnis wird jedes Byte der Daten durch zwei Hexadezimalziffern repräsentiert. Jeder Wert im Datenstrom belegt dann doppelt soviel Platz wie der Wert des gleichen Datentyps ohne die Spezifikation als HEX-Wert.

Umwandlung der Datentypen

Der Loader kann numerische Datentypen ineinander umwandeln, falls erforderlich. Das Lesen bzw. die Ausgabe im externen Datentyp CHAR ist für jeden datenbankinternen Datentyp möglich.

● Beim Exportieren von Daten aus einer Tabelle werden die datenbankinternen Datentypen in die angegebenen externen Datentypen konvertiert und die entsprechenden Spaltenwerte exportiert.
Die datenbankinternen Datentypen INT[EGER], FIXED und SMALLINT können in die externen Datentypen DECIMAL, INTEGER, REAL oder ZONED überführt werden.
Der datenbankinternen Datentyp FLOAT kann in die externen Datentypen CHAR[ACTER] oder REAL überführt werden.

● Beim Importieren von Daten in eine Tabelle werden die angegebenen externen Datentyp in datenbankinterne Datentypen konvertiert und die entsprechenden Spaltenwerte einer Tabelle importiert.
Die externen Datentypen DECIMAL, INTEGER, REAL und ZONED können in die datenbankinternen Datentypen INTEGER, FIXED, FLOAT oder SMALLINT überführt werden.

Siehe auch:

Datenstrom

Datenformat


Importieren von beliebigen und speziellen Konstanten (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Importieren von beliebigen und speziellen Konstanten

Sie können mit der Syntaxregel column_assignment bei einer Spaltenbeschreibung festlegen, dass für jeden importierten Datensatz in die spezifizierte Spalte eine beliebige oder spezielle Konstante importiert werden soll, und nicht der Wert aus dem Datenstrom.

Syntax

<column_assignment> ::= <column_name> '<literal>'
| <column_name> <column_function>

<column_name> ::= <identifier>

<column_function> ::= DATE | FALSE | STAMP | TIME | TIMESTAMP
| TRUE | USER | USERGROUP | <sequence_number>

<sequence_number> ::= SEQNO
| SEQNO <integer>
| SEQNO <integer> <integer>

<column_name> | Spaltenname siehe auch: SQL-Referenzhandbuch, Strukturlink Spaltenname (column_name)
<literal> | Literal siehe auch: SQL-Referenzhandbuch, Strukturlink Literal (literal)
DATE | Aktuelles Datum Die Spalte, in die einer dieser Werte importiert werden soll, muss vom Typ DATE sein.
FALSE | Boolescher Wert FALSE
STAMP | Ein vom Datenbanksystem erzeugter eindeutiger Wert, der nur in Spalten des Typs CHAR(n) BYTE mit n >= 8 importiert werden kann
TIME | Aktuelle Zeit Die Spalte, in die einer dieser Werte importiert werden soll, muss vom Typ TIME sein.
TIMESTAMP | Aktueller Zeitstempel Die Spalte, in die einer dieser Werte importiert werden soll, muss vom Typ TIMESTAMP sein.
TRUE | Boolescher Wert TRUE
USER | Name des aktuellen Benutzers wird importiert.
USERGROUP | Name der Gruppe des aktuellen Benutzers wird importiert. Wenn dieser Benutzer keiner Benutzergruppe zugeordnet ist, wird der Name des aktuellen Benutzers importiert. Die Spalte, in die einer dieser Werte importiert werden soll, muss vom Typ CHAR(n) mit n >= 32 sein.
SEQNO | Sequenzwerte Startwert ist 0 und der Abstand zwischen den darauf folgenden Zahlen ist jeweils 1
SEQNO <integer> | Sequenzwerte Startwert und damit erster zu importierender Wert ist die ganze Zahl integer. Der Abstand zwischen den darauf folgenden Zahlen ist jeweils 1
SEQNO <integer> <integer> | Sequenzwerte Unmittelbar nach dem Schlüsselwort SEQNO wird der Startwert integer und damit der erste zu importierende Wert angegeben. Die folgende ganze Zahl gibt den Abstand zwischen den zu importierenden Werten an. siehe auch: SQL-Referenzhandbuch, Strukturlink CREATE SEQUENCE-Anweisung (create_sequence_statement)

Beispiele

IMPORT TABLE hotel.reservation
DATA INSTREAM 'reservation_csv.data'
rno 1
cno 2
hno 3
type 4
 arrival '20040207'
departure '20040220'

Die Konstanten 20040207 und 20040220 (Datum im Format INTERNAL) werden importiert.

IMPORT TABLE hotel.reservation
DATA INSTREAM 'reservation_csv.data'
rno 1
cno 2
hno 3
type 4
 arrival DATE
 departure 5

Die spezielle Konstante DATE wird importiert.

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'
cno SEQNO 3000 100
title 2
firstname 3
name 4
zip 5
address 6

Die Angaben zur Sequenz (Startposition 3000, Abstand 100) werden importiert.

Erläuterung

Geben Sie die beliebige Konstante literal bzw. spezielle Konstante column_function anstelle einer Positionsangabe im Kommando an. Für die entsprechende Spalte werden dann keine Daten aus dem Datenstrom importiert.

Wenn der Datenstrom leer ist, werden die im Kommando angegebenen Konstanten nicht importiert.

<column_name> '<literal>'

Um eine beliebige Konstante literal zu importieren, geben Sie anstelle einer Position die gewünschte Konstante an. Schließen Sie den Wert in einfache Anführungszeichen ein.

Der Loader behandelt die Konstante wie einen Klartextwert und wandelt ihn in den Datentyp der Zielspalte um.

Wenn die Konstante in eine numerische Spalte importiert werden soll, muss sie ein gültiges Zahlenformat haben.

<column_name> <column_function>

Sie können spezielle Konstanten column_function importieren. Folgende Wert sind möglich: DATE, FALSE, STAMP, TIME, TIMESTAMP, TRUE, USER, USERGROUP und sequence_number.

<sequence_number>

Sie können bei Verwendung der Syntaxregel sequence_number selbst erzeugte Nummerngeneratoren mit frei wählbarem Startwert und Abstand importieren.

Der berechenbare Zahlenbereich wird als zyklisch betrachtet, d. h. der Nachfolgewert des größten darstellbaren Wertes ist der neue kleinste darstellbare Wert. Auf diese Weise können beliebig viele und gegebenenfalls mehrfach wiederkehrende Folgenummern generiert werden.

Wenn Sie die Syntaxregel sequence_number verwenden, sollen Folgenummern entsprechend einer der drei Möglichkeiten generiert werden. Sowohl der Startwert als auch der Abstand können negativ sein. Für die Speicherung der Folgenummern ist eine Spalte des Typs FIXED(10) ausreichend.

Siehe auch:

IMPORT COLUMNS-Kommando

IMPORT TABLE-Kommando

UPDATE COLUMNS-Kommando


Selektieren von Datensätzen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Selektieren von Datensätzen

Beim Importieren von Anwendungsdaten ist es möglich, die zu importierenden Datensätze inhaltlich zu selektieren.

Die dabei definierten Bedingungen können durch die Angabe von NOT negiert, mit AND und OR verbunden und beliebig geklammert werden. Der Loader wichtet die Operatoren dementsprechend.

Syntax

<if_condition> ::= IF <condition>

<condition> ::= (<condition>)
| <condition> AND <condition>
| <condition> OR <condition>
| NOT <condition>
| <simple_condition>

<simple_condition> ::= POS <field_spec> <field_type> [HEX] <compare_operator> '<literal>'

<compare_operator> ::= < | > | = | <= | >= | !=

field_spec | Positionsbeschreibung
field_type | Datentypen
HEX | Sie können HEX-Werte definieren.
literal | Literal, das als Vergleichswert dient siehe auch: SQL-Referenzhandbuch, Strukturlink Literal (literal)

Beispiele

IMPORT TABLE hotel.room
IF POS 06-11 = 'double'
DATA INSTREAM 'room_fwv.data' FWV
hno 01-05
type 06-11
free 12-15
price 16-22

Sie importieren nur jene Datensätze aus dem Quelldatenstrom room_fwv.data in die Zieltabelle ROOM, in denen als Zimmertyp double angegeben ist.

Erläuterung

Der Loader unterscheidet zusammengesetzte Bedingungen und einfache Bedingungen (simple_condition). Es werden nur jene Sätze importiert, für die die zusammengesetzte oder einfache Bedingung zutrifft.

Zusammengesetzte Bedingungen

Bedingungen können mit NOT negiert oder mit AND und OR zu zusammengesetzten Bedingungen kombiniert und beliebig geklammert werden.

Operatoren in Klammern werden vor nicht geklammerten Operatoren ausgewertet.

Wenn keine Operatoren geklammert wurden, wichtet der Loader die Operatoren wie folgt:

● NOT bindet stärker als AND und OR

● AND bindet stärker als OR

● Bei gleicher Wichtung erfolgt die Auswertung von links nach rechts

Einfache Bedingungen

Sie definieren mit der einfachen Bedingung simple_condition das Selektionskriterium, mit dem festgelegt wird, welche Sätze des Datenstroms in welche Zieltabelle importiert werden. Die Selektion der zu importierenden Datensätze erfolgt durch den Vergleich mit einer Konstanten.

<field_spec>

Einen zu vergleichenden Wert im Datensatz beschreiben Sie wie die übrigen Felder eines Datensatzes durch seine Position.

<field_type>

Die Angabe des Datentyps ist nur dann erforderlich, wenn das betreffende Datenfeld mit einem anderen Datentyp als CHAR gelesen oder ausgegeben werden soll. Das Lesen bzw. die Ausgabe im CHAR-Datentyp ist für jedes datenbankinterne Spaltenformat möglich.

<literal>

Das angegebene Literal ist eine Konstante, die als Vergleichswert dienen soll. Geben Sie das Literal als Klartextwert an und schließen es in einfache Anführungszeichen ein. Dieser Wert wird in den Datentyp des zu vergleichenden Wertes im Datensatz umgewandelt.

Wenn das als Vergleichswert dienende Literal eine Zahl ist, muss sie ein gültiges Zahlenformat haben, also entweder eine Gleitkommazahl in Mantisse-/Exponent-Darstellung oder eine Festkommazahl mit der aktuell definierten oder im Loader voreingestellten Dezimaldarstellung sein.

Siehe auch:

IMPORT TABLE-Kommandos

IMPORT COLUMNS-Kommandos

UPDATE COLUMNS-Kommandos


Ausgabespalte (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Ausgabespalte

Die für die Ausgabespalten verwendeten Syntaxelemente in Loader-Kommandos werden im Folgenden beschrieben.

Syntax

<export_column_spec> := <map_column_field>
| <field_assignment>

<map_column_field> ::= <column_spec> <field_spec> <field_function> <null_assign>

<column_spec> ::= <column_name>
| <column_id>
<column_name> ::= <identifier>
<column_id> ::= <unsigned_integer>

<field_spec> ::= Positionsbeschreibung
<field_function> ::= <field_type> [HEX]
| <numerical_functions>
| <field_type> [HEX] <numerical_functions>
<null_assign> ::= NULL-Wert-Darstellung

<field_assignment> ::= '<literal>' <field_spec>

<column_name> | Spaltenname siehe auch: SQL-Referenzhandbuch, Strukturlink Spaltenname (column_name)
<column_id> | Spalten-ID siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)
<field_type> | Spezifikation des Datentyps eines Datenfeldes im Datenstrom
HEX | Sie können das Datenfeld als HEX-Wert definieren.
<numerical_functions> | Sie können numerische Datenwerte beim Importieren oder Exportieren skalieren (scale_spec), runden und/oder kürzen (round_or_trunc_spec). <scale_spec> | <round_or_trunc_spec> | <scale_spec> <round_or_trunc_spec> Siehe auch: Spaltenbeschreibung
<literal> | Literal siehe auch: SQL-Referenzhandbuch, Strukturlink Literal (literal)

Beispiele

Im Abschnitt EXPORT COLUMNS-Kommando und in den folgenden Abschnitten

Erläuterung

Das Syntaxelement export_column_spec wird im EXPORT COLUMNS-Kommando verwendet. Angaben wie Spaltenname, Positionsbeschreibung finden auch in Spaltenbeschreibungen anderer Loader-Kommandos Verwendung.

<map_column_field>

In Kommandos zum Exportieren ordnen Sie mit dem Syntaxelement map_column_field den Spalten der Quelltabelle die Datenfelder des Datenstroms zu. Sie geben die externen Datentypen und die Bedingungen für das Exportieren der Anwendungsdaten an.

Mit Hilfe der Syntaxregel column_spec können Sie Spaltenname oder Spalten-ID angegeben.

EXPORT COLUMNS cno, name, zip, address FROM hotel.customer
MAP COLUMNS
cno 01-05
name 06-15
zip 16-20
address 21-45
DATA OUTSTREAM 'customer_fwv.data' FWV

Der Spaltenname column_name bezeichnet die Spalte im SELECT-Ausdruck.

EXPORT COLUMNS cno, name, zip, address FROM hotel.customer
MAP COLUMNS
1 01-05
2 06-15
3 16-20
4 21-45
DATA OUTSTREAM 'customer_fwv.data' FWV

Die Spalten-ID column_id bezeichnet die Position der Spalte im SELECT-Ausdruck.

<field_assignment>

Sie haben mit dem Syntaxelemen field_assignment die Möglichkeit, zusätzlich zu den Ausgabewerten im Exportkommando auszugebende Literale zu definieren.

Anstelle des Spaltennamens bzw. der Spalten-ID wird das Literal in einfachen Anführungszeichen angegeben.

EXPORT COLUMNS * FROM hotel.customer
MAP COLUMNS
 'customer number:' 01-16
 cno 17-21
title 22-28
firstname 29-38
name 39-48
zip 49-53
address 54-78
DATA OUTSTREAM 'customer_fwv.data' FWV

Siehe auch:

EXPORT COLUMNS-Kommandos


Tabellenname (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Tabellenname

Die Syntaxregel table_name gibt den Tabellennamen in den Kommandos zum Exportieren und Importieren von Daten an.

Wenn Sie Schlüsselwörter als Tabellennamen verwenden wollen, müssen diese in doppelte Anführungszeichen eingeschlossen werden.

Syntax

<table_name> ::= [<schema_name>.]<identifier>

<schema_name> ::= <identifier>

<table_name> | Name der Tabelle siehe auch: SQL-Referenzhandbuch, Strukturlink Tabellenname (table_name)
<schema_name> | Name des Schemas siehe auch: SQL-Referenzhandbuch, Strukturlink Schemaname (schema_name)

Beispiele

EXPORT TABLE hotel.room
DATA OUTSTREAM 'room_csv.data'

Die Anwendungsdaten der Tabelle ROOM sollen exportiert werden.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data'
hno 1
type 2
free 3
price 4

Die Anwendungsdaten aus der Datei room_csv.data sollen in die Tabelle ROOM in die angegebenen Spalten importiert werden.

IMPORT TABLE hotel.room
 IF POS 06-11 = 'double'
DATA INSTREAM 'room_csv.data'
hno 01-05
type 06-11
free 12-15
price 16-22

Sie wollen nur jene Datensätze aus dem Datenstrom room_csv.data in die Zieltabelle ROOM importieren, in denen als Zimmertyp double angegeben ist.

Erläuterung

Sie legen mit der Syntaxregel table_name in Kommandos zum Exportieren oder Importieren den/die Namen der Tabelle/n fest.

Siehe auch:

EXPORT TABLE-Kommandos

IMPORT TABLE-Kommandos

EXPORT COLUMNS-Kommando

IMPORT COLUMNS-Kommandos

UPDATE COLUMNS-Kommandos

Selektieren von Datensätzen


Datumsangaben (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Datumsangaben

Sie legen mit dieser Syntaxregel das Datenformat der Klartextwerte fest, in dem DATE-Spalten ein- und ausgegeben werden.

Dieses Format gilt nur für das Kommando zum Exportieren oder Importieren von Daten, in dem es angegeben wird. Ist in einem Kommando kein Datumsformat angegeben, wird entweder der Vorschlagswert des Loader oder ein mit dem SET DATE-Kommando festgelegter Wert verwendet. Mit dem SET DATE-Kommando legen Sie das Datumsformat für alle nachfolgenden Kommandos fest. Dieses gilt in einer Loader-Sitzung so lange, bis es durch ein neues SET-Kommando aufgehoben wird.

Syntax

<set_date_command> ::= SET DATE <standard_date_mask>

<date_spec> ::= DATE <standard_date_mask>
| DATE '<free_mask_date>'

<standard_date_mask> ::= EUR | INTERNAL | ISO | JIS | USA

SET DATE <standard_date_mask>

Diese Einstellung einer standardisierten Datumsmaske gilt für die gesamte Loader-Sitzung, sofern die Datumsmaske nicht durch ein erneutes SET DATE-Kommando geändert wird.

<date_spec>

Sie haben die Möglichkeit, für einzelne Kommandos die aktuelle Datumsmaske durch Verwenden des Syntaxelements date_spec zur Definition des Datenformats (field_format_spec) zu ändern.

DATE <standard_date_mask>

Sie legen mit der Standarddatumsmaske standard_date_mask das Format der Klartextwerte fest, in dem DATE-Spalten ein- und ausgegeben werden.

Vorschlagswert: INTERNAL

DATE '<free_mask_date>'

Sie legen mit der frei definierbaren Datumsmaske free_mask_date das Format der Klartextwerte fest, in dem DATE-Spalten ein- und ausgegeben werden.

Verwenden Sie Y für das Jahr, M für den Monat, D für den Tag.
Die Jahresbezeichnung muss zwei- oder vierstellig, Tagesbezeichnungen müssen zweistellig, Monatsbezeichnungen müssen zwei- oder dreistellig sein. Wenn Sie für den Monat drei Stellen, also MMM angeben, wird die Bezeichnung des Monatsnamens in der üblichen englischen Abkürzung ausgegeben, z. B. Oct für Oktober.

Beispiele

EXPORT TABLE hotel.reservation
DATA OUTSTREAM 'reservation_csv.data'
DATE ISO

Die Standarddatumsmaske ISO wird angegeben.

IMPORT TABLE hotel.reservation
DATA INSTREAM 'reservation_csv.data'
DATE 'YYYY-MMM-DD'

Beispiel für Inhalt des Datenstroms
"100","3000","80","single","2005-Nov-13","2005-Nov-15"

Die Maske YYYY-MMM-DD wird für die Datumsangaben angegeben.

Standarddatumsmaske <standard_date_mask>

'YYYY' | Vierstellige Jahresbezeichnung
'MM' | Zweistellige Monatsbezeichnung (01-12)
'DD' | Zweistellige Tagesbezeichnung (01-31)

Format | Allgemeine Form | Beispiel
EUR | 'DD.MM.YYYY' | '23.01.2005'
INTERNAL | 'YYYYMMDD' | '20050123'
ISO/JIS | 'YYYY-MM-DD' | '2005-01-23'
USA | 'MM/DD/YYYY' | '01/23/2005'

Tages- und Monatsangaben müssen zweistellig sein. Bei allen Formaten außer INTERNAL müssen die Jahresangaben zwei- oder vierstellig sein. Beim Format INTERNAL muss die Jahresangabe vierstellig sein.

Siehe auch:

Zeitangaben

Zeitstempelangaben


Zeitangaben (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Zeitangaben

Sie legen mit dieser Syntaxregel das Datenformat der Klartextwerte fest, in dem TIME-Spalten ein- und ausgegeben werden.

Dieses Format gilt nur für das Kommando zum Exportieren oder Importieren von Daten, in dem es angegeben wird. Ist in einem Kommando kein Zeitformat angegeben, wird entweder der Vorschlagswert des Loader oder ein mit dem SET TIME-Kommando festgelegter Wert verwendet. Mit dem SET TIME-Kommando legen Sie das Zeitformat für alle nachfolgenden Kommandos fest. Dieses gilt in einer Loader-Sitzung so lange, bis es durch ein neues SET-Kommando aufgehoben wird.

Syntax

<set_time_command> ::= SET TIME <standard_time_mask>

<time_spec> ::= TIME <standard_time_mask>
| TIME '<free_mask_time>'

<standard_time_mask> ::= EUR | INTERNAL | ISO | JIS | USA

SET TIME <standard_time_mask>

Diese Einstellung einer standardisierten Zeitmaske gilt für die gesamte Loader-Sitzung, sofern die Zeitmaske nicht durch ein erneutes SET TIME-Kommando geändert wird.

<time_spec>

Sie haben die Möglichkeit, für einzelne Kommandos die aktuelle Zeitmaske durch Verwenden des Syntaxelements time_spec zur Definition des Datenformats (field_format_spec) zu ändern

TIME <standard_time_mask>

Sie legen mit der Standardzeitsmaske standard_time_mask das Format der Klartextwerte fest, in dem TIME-Spalten ein- und ausgegeben werden.

Vorschlagswert: INTERNAL

TIME '<free_mask_time>'

Sie legen mit der frei definierbaren Zeitmaske free_mask_time das Format der Klartextwerte fest, in dem TIME-Spalten ein- und ausgegeben werden.

Verwenden Sie H für Stunden, M für Minuten und S für Sekunden. Die Minuten und Sekunden müssen zweistellig angegeben werden. Die Stunden müssen zwei- oder vierstellig angegeben werden.

Beispiele

EXPORT COLUMNS * FROM hotel.reservation
OUTSTREAM 'reservation_csv.data'
TIME ISO

Die Standardzeitmaske ISO wird angegeben.

EXPORT COLUMNS * from hotel.reservation
OUTSTREAM 'reservation_csv.data'
TIME 'HH:MM:SS'

Beispiel für Inhalt des Datenstroms
"14:30:08"

Die Maske HH:MM:SS wird für die Zeitangaben angegeben.

Standardzeitmaske <standard_time_mask>

'HHHH' | Vierstellige Stundenbezeichnung
'HH' | Zweistellige Stundenbezeichnung
'MM' | Zweistellige Minutenbezeichnung (00-59)
'SS' | Zweistellige Sekundenbezeichnung (00-59)

Format | Allgemeine Form | Beispiel
EUR | 'HH.MM.SS' | '14.30.08'
INTERNAL | 'HHHHMMSS' | '00143008'
ISO/JIS | 'HH:MM:SS' | '14:30:08'
USA | 'HH:MM AM (PM)' | '2:30 PM'

Minuten- und Sekundenangaben müssen zweistellig sein. Die Stundenangaben müssen außer im Format INTERNAL zweistellig sein. Im Format INTERNAL müssen die Stundenangaben zwei- oder vierstellig sein.

Beim Importieren von Daten führen in allen Formaten außer INTERNAL Stundenangaben größer 24 zu einem Fehler. Beim Exportieren von Daten werden in allen Formaten außer INTERNAL die Stunden modulo 24 ausgegeben. Im Format INTERNAL können Stundenangaben bis 9999 verwendet werden.

Siehe auch:

Datumsangaben

Zeitstempelangaben


Zeitstempelangaben (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Zeitstempelangaben

Sie legen mit dieser Syntaxregel das Datenformat der Klartextwerte fest, in dem TIMESTAMP-Spalten ein- und ausgegeben werden. Ein Zeitstempel setzt sich aus einem Datums- und einem Zeitwert und der Angabe von Mikrosekunden zusammen.

Dieses Format gilt nur für das Kommando zum Exportieren oder Importieren von Daten, in dem es angegeben wird. Ist in einem Kommando kein Zeitstempelformat angegeben, wird entweder der Vorschlagswert des Loader oder ein mit dem SET TIMESTAMP-Kommando festgelegter Wert verwendet. Mit dem SET TIMESTAMP-Kommando legen Sie das Zeitstempelformat für alle nachfolgenden Kommandos fest. Dieses gilt in einer Loader-Sitzung so lange, bis es durch ein neues SET-Kommando aufgehoben wird.

Syntax

<set_timestamp_command> ::= SET TIMESTAMP <standard_timestamp_mask>

<timestamp_spec> ::= TIMESTAMP <standard_timestamp_mask>
| TIMESTAMP '<free_mask_timestamp>'

<standard_timestamp_mask> ::= EUR | INTERNAL | ISO | JIS | USA

SET TIMESTAMP <standard_timestamp_mask>

Diese Einstellung einer standardisierten Zeitstempelmaske gilt für die gesamte Loader-Sitzung, sofern die Zeitstempelmaske nicht durch ein erneutes SET TIMESTAMP-Kommando geändert wird.

<timestamp_spec>

Sie haben die Möglichkeit, für einzelne Kommandos die aktuelle Zeitstempelmaske durch Verwenden des Syntaxelements timestamp_spec zur Definition des Datenformats (field_format_spec) zu ändern.

TIMESTAMP <standard_timestamp_mask>

Sie legen mit der Standardzeitstempelmaske standard_timestamp_mask das Format der Klartextwerte fest, in dem TIMESTAMP-Spalten ein- und ausgegeben werden.

Vorschlagswert: INTERNAL

TIMESTAMP '<free_mask_timestamp>'

Sie legen mit der frei definierbaren Zeitstempelmaske free_mask_timestamp das Format der Klartextwerte fest, in dem TIMESTAMP-Spalten ein- und ausgegeben werden.

Verwenden Sie Y für das Jahr, M für den Monat, D für den Tag, H für die Stunden, M für die Minuten, S für die Sekunden und N für die Mikrosekunden.

Die Jahresbezeichnung muss zwei- oder vierstellig, Tagesbezeichnungen müssen zweistellig, Monatsbezeichnungen müssen zwei- oder dreistellig sein. Wenn Sie für den Monat drei Stellen, also MMM angeben, wird die Bezeichnung des Monatsnamens in der üblichen englischen Abkürzung ausgegeben, z. B. Oct für Oktober.

Die Minuten und Sekunden müssen zweistellig angegeben werden. Die Stunden müssen zwei- oder vierstellig angegeben werden. Die Stellenanzahl bei der Angabe der Mikrosekunden ist zwischen 0 und 6 frei wählbar.

Beispiele

EXPORT COLUMNS * FROM hotel.reservation
OUTSTREAM ′reservation_csv.data′
TIMESTAMP ISO

Die Standardzeitstempelmaske ISO wird angegeben.

EXPORT COLUMNS * FROM hotel.reservation
OUTSTREAM ′reservation_csv.data′
TIMESTAMP ′YYYY-MM-DD-HH-MM-SS-NNNNNN′

Beispiel für Inhalt des Datenstroms: "2005-11-15-13-14-12-987654"

Die Maske YYYY-MM-DD-HH-MM-SS-NNNNNN wird für die Zeitstempelangaben angegeben.

Standardzeitstempelmaske <standard_timestamp_mask>

'YYYY' | Vierstellige Jahresbezeichnung
'MM' | Zweistellige Monatsbezeichnung (01-12)
'DD' | Zweistellige Tagesbezeichnung (01-31)
'HH' | Zweistellige Stundenbezeichnung (0-24)
'MM' | Zweistellige Minutenbezeichnung (00-59)
'SS' | Zweistellige Sekundenbezeichnung (00-59)
'NNNNNN' | Sechstellige Mikrosekundenbezeichnung

Format | Allgemeine Form | Beispiel
EUR/JIS/USA | 'YYYY-MM-DD-HH.MM.SS.NNNNNN' | '2005-01-23-14.30.08.456234'
INTERNAL | 'YYYYMMDDHHMMSSNNNNNN' | '20050123143008456234'
ISO | 'YYYY-MM-DD HH:MM:SS.NNNNNN' | '2005-01-23 14:30:08.456234'

Jahresangaben müssen vierstellig sein. Die Monats- und Tagesangaben müssen zweistellig sein.

Die Stunden-, Minuten- und Sekundenangaben müssen zweistellig sein.

Die Stellenanzahl bei der Angabe der Mikrosekunden ist zwischen 0 und 6 frei wählbar.

Siehe auch:

Datumsangaben

Zeitangaben


NULL-Wert-Darstellung (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation NULL-Wert-Darstellung

Der Loader ist in der Lage verschiedene NULL-Wert-Darstellungen in den Datenströmen zu verarbeiten.

Sie können die voreingestellte NULL-Wert-Darstellung verwenden oder diese für eine Loader-Sitzung oder für einzelne Loader-Kommandos festlegen.

NULL-Wert-Darstellung für eine Loader-Sitzung festlegen

Sie können für die aktuelle Loader-Sitzung die NULL-Wert-Darstellung mit dem SET-Kommando festlegen. Diese gilt dann so lange für diese Loader-Sitzung, bis sie durch ein erneutes SET-Kommando überschrieben wird. Wenn Sie über das SET-Kommando keine NULL-Wert-Darstellung festgelegen, wird der Vorschlagswert des Loader (Fragezeichen ?) verwendet.

<SET_null_spec_command> ::= SET <null_spec>

<null_spec> ::= NULL '<literal>'

Sie können mit dem SET-Kommando die Zeichenkette literal festlegen, mit der NULL-Werte in Datenströmen repräsentiert werden. Eine NULL-Wert-Darstellung kann maximal eine Länge von 20 Zeichen haben und ist vom Datentyp CHAR.

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Literal (literal), Strukturlink NULL-Wert

NULL-Wert-Darstellung für den Datenstrom festlegen

Sie haben die Möglichkeit, für einzelne Loader-Kommandos den aktuellen Wert für die NULL-Wert-Darstellung in Datenströmen festzulegen. Verwenden Sie für diese Zwecke das Syntaxelement null_spec zur Definition des Datenformats eines Datenstroms. Wenn Sie über das Syntaxelement null_spec keine NULL-Wert-Darstellung für den Datenstrom festlegen, wird der mit dem SET-Kommando für die Loader-Sitzung gesetzte Wert verwendet. Wenn Sie über das SET-Kommando keine NULL-Wert-Darstellung festgelegt haben, wird der Vorschlagswert des Loader (Fragezeichen ?) verwendet.

Die NULL-Wert-Darstellungen können Sie nur für Datenströme der Formate CSV und FWV vornehmen, für die Formate RECORDS und PAGES ist eine NULL-Wert-Darstellung nicht nötig und möglich.

<csv_or_fwv_format_null_spec> ::= <null_spec>

<null_spec> ::= NULL '<literal>'

Sie legen mit der Syntaxregel null_spec die Zeichenkette literal fest, mit der NULL-Werte in Datenströmen repräsentiert werden. Eine NULL-Wert-Darstellung kann maximal eine Länge von 20 Zeichen haben und ist vom Datentyp CHAR.

Siehe auch:

Datenformat

Sie möchten die Daten des Datenstroms room_cvs.data in die Datenbank importieren, wobei in die Spalten der Zieltabelle der NULL-Wert in eigener Darstellung importiert werden soll. Ein SET-Kommando wurde nicht verwendet.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data' NULL 'NULL'

Für die Darstellung des NULL-Wertes im Datenstrom room_csv.data wurde das Literal NULL gewählt.

Sie möchten die Daten des Datenstroms room_cvs.data in die Datenbank importieren, wobei in die Spalten der Zieltabelle der Vorschlagswert für den NULL-Wert importiert werden soll. Ein SET-Kommando wurde nicht verwendet.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data'

Für die Darstellung des NULL-Wertes im Datenstrom room_csv.data wurde das Literal ? gewählt.

NULL-Wert-Darstellung für ein Datenfeld festlegen

Die NULL-Wert-Darstellung für Datenströme im Format RECORDS oder PAGES wird vom Loader intern verwaltet. Daher sind die folgenden Erläuterungen für die Kommandos EXPORT DB|USER|SCHEMA bzw. IMPORT DB|USER|SCHEMA nicht relevant.

Ausgabespalten in EXPORT-Kommandos

Sie können in EXPORT TABLE oder EXPORT COLUMNS-Kommandos die NULL-Wert-Darstellung für einzelne Datenfelder festlegen. Sie geben durch das Syntaxelement null_assign an, welcher Wert für das Datenfeld der Quelltabelle in den Datenstrom geschrieben werden soll, wenn der Wert in der Quelltabelle der NULL-Wert ist. Wenn Sie über das Syntaxelement null_assign keine NULL-Wert-Darstellung festlegen, wird der über das Syntaxelement null_spec gesetzte Wert für den Datenstrom auch für das Datenfeld verwendet. Wenn Sie über das Syntaxelement null_spec keine NULL-Wert-Darstellung für den Datenstrom festgelegt haben, wird der mit dem SET-Kommando für die Loader-Sitzung gesetzte Wert verwendet. Wenn Sie über das SET-Kommando keine NULL-Wert-Darstellung festgelegt haben, wird der Vorschlagswert des Loader (Fragezeichen ?) verwendet.

<null_assign> ::= [IF] NULL SET '<literal>'

Sie können mit dem Syntaxelement null_assign die Zeichenkette literal festlegen, mit der NULL-Werte in Datenströmen repräsentiert werden. Eine NULL-Wert-Darstellung kann maximal eine Länge von 20 Zeichen haben und ist vom Datentyp CHAR.

Wenn die NULL-Wert-Darstellung in einem der externen Datentypen für Binärwerte ausgegeben werden soll, muss sie ein gültiges Zahlenformat haben, d. h. entweder eine Gleitkommazahl in Mantisse-/Exponent-Darstellung oder eine Festkommazahl mit der aktuell vereinbarten oder der Standarddezimaleinstellung sein.

Die erzeugte NULL-Wert-Darstellung wird an die gleiche Stelle im Datenstrom geschrieben, an die der eigentliche Spaltenwert geschrieben werden würde.

● Wenn die NULL-Wert-Darstellung kürzer ist als die durch die Positionsangabe spezifizierte Länge des Wertes (für Datenströme im Format FWV), dann wird der Wert mit Leerzeichen aufgefüllt. Wenn die NULL-Wert-Darstellung länger ist, dann wird sie beim Schreiben auf die angegebene Länge gekürzt. Der Loader gibt dazu eine Warnung in die Protokolldatei aus.

● Wenn Sie für den Export von NOT-NULL-Spalten eine NULL-Wert-Darstellung definieren, führt dies nicht zu einem Fehler. Der Loader ignoriert die Angaben in diesen Fällen.

Siehe auch:

Ausgabespalte

EXPORT TABLE-Kommando

EXPORT COLUMNS-Kommando

Sie möchten die Tabelle ROOM aus der Datenbankinstanz in den Datenstrom room_csv.data exportieren, wobei einige Spalten der Tabelle NULL-Werte enthalten. Ein SET-Kommando wurde nicht verwendet.

EXPORT COLUMNS * FROM hotel.room
MAP COLUMNS
hno 1
type 2
 free 3 IF NULL SET '0'
price 4 IF NULL SET 'X'
 DATA OUTSTREAM 'room_csv.data'

Sie verwenden für die Spalten FREE und PRICE das Syntaxelement null_assign. Wenn in der Spalte ein NULL-Wert gefunden wird, wird die jeweilige NULL-Wert-Darstellung in den Datenstrom eingetragen. Für die anderen Spalten wird die als Vorschlagswert des Loader definierte NULL-Wert-Darstellung '?' verwendet.

Sie möchten die Tabelle ROOM aus der Datenbankinstanz in den Datenstrom room_csv.data exportieren, wobei einige Spalten der Tabelle NULL-Werte enthalten. Ein SET-Kommando wurde nicht verwendet.

EXPORT COLUMNS * FROM hotel.room
MAP COLUMNS
hno 1
type 2
free 3
price 4
DATA OUTSTREAM 'room_csv.data'

oder

EXPORT TABLE hotel.room
DATA OUTSTREAM 'room_csv.data'

Da Sie für keine im EXPORT-Kommando aufgeführte Spalte eine NULL-Wert-Darstellung definiert haben, aber alle Werte den externen Datentyp CHAR haben, wird die als Vorschlagswert des Loader definierte NULL-Wert-Darstellung ? verwendet.

Sie möchten die Tabelle ROOM aus der Datenbankinstanz in den Datenstrom room_fwv_binary.data exportieren, wobei einige Spalten der Tabelle NULL-Werte enthalten. Ein SET-Kommando wurde nicht verwendet.

EXPORT COLUMNS * FROM hotel.room
MAP COLUMNS
hno 01-05
type 06-11
free 12-15 INTEGER
price 16-19 INTEGER
DATA OUTSTREAM 'room_fwv_binary.data' FWV BINARY

Da Sie für keine der im EXPORT-Kommando aufgeführten Spalten eine NULL-Wert-Darstellung definiert haben, versucht der Loader, die als Voreinstellung definierte NULL-Wert-Darstellung (Datentyp CHAR) zu nutzen. Dies führt in jenen Fällen zum Fehler, in denen für die Spalten ein numerischer externer Datentyp definiert wurde. Die Bearbeitung des Kommandos wird mit einer Fehlermeldung abgebrochen.

Spaltenbeschreibung in IMPORT- und UPDATE-Kommandos

Sie können in IMPORT TABLE-, IMPORT COLUMNS- und UPDATE COLUMNS-Kommandos mit dem Syntaxelement null_condition festlegen, unter welchen Bedingungen ein NULL-Wert in eine Spalte der Zieltabelle importiert werden soll.

Wenn Sie alle Spalten beim IMPORT oder UPDATE angeben, jedoch keine null_conditionspezifizieren, werden die Werte aus dem Datenstrom in die Zieltabelle so importiert, wie sie im Datenstrom stehen, d.h. der Loader versucht nicht, einzelne Werte als NULL-Wert zu interpretieren.

<null_condition> ::= NULL [IF] <condition>
| DEFAULT NULL

● NULL [IF] <condition>: Vor dem Importieren bzw. Ändern jeder Zeile des Datenstroms in die Tabelle wird geprüft, ob die für die Spalten formulierte Bedingung condition zutrifft. Wenn ja, wird der NULL-Wert in diese Tabellenspalte eingefügt, andernfalls der Wert aus dem zugeordneten Feld des Datenstroms. Bei der Auswertung der Bedingung (condition) wird der kürzere der jeweiligen Vergleichswerte (Wert im Datenstrom oder NULL-Wert-Darstellung) mit Leerzeichen aufgefüllt, um den Vergleich zu ermöglichen.

● DEFAULT NULL: Vor dem Importieren bzw. Ändern jeder Zeile des Datenstroms wird geprüft, ob der Wert im Datenstrom für die Spalte mit dem Vorschlagswert des Loader für den NULL-Wert übereinstimmt. Wenn ja, wird der NULL-Wert in diese Spalte eingefügt, andernfalls der Wert aus dem zugeordneten Feld des Datenstroms. Beim Vergleich wird der kürzere der jeweiligen Vergleichswerte (Wert im Datenstrom oder NULL-Wert-Darstellung) mit Leerzeichen aufgefüllt, um den Vergleich zu ermöglichen.

Wenn Sie DEFAULT NULL verwenden, wird der Vorschlagswert des Loader für den NULL-Wert wie folgt bestimmt: Der über das Syntaxelement null_spec für den Datenstrom gesetzte Wert wird als NULL-Wert verwendet. Wenn Sie über das Syntaxelement null_spec keine NULL-Wert-Darstellung für den Datenstrom festgelegt haben, wird der mit dem SET-Kommando für die Loader-Sitzung gesetzte Wert verwendet. Wenn Sie über das SET-Kommando keine NULL-Wert-Darstellung festgelegt haben, wird der Vorschlagswert des Loader (Fragezeichen ?) verwendet.

Für Spalten, die Sie als Schlüsselspalten (KEY) oder als NOT NULL definiert haben, können Sie keinen NULL-Wert setzen. Das Importieren bzw. Ändern der Tabelle wird mit einer entsprechenden Fehlermeldung abgebrochen.

Für Spalten, die Sie als NOT NULL DEFAULT <value> definiert haben, fügt der Loader anstelle eines NULL-Wertes den DEFAULT-Wert ein.

Siehe auch:

Spaltenbeschreibung

IMPORT TABLE-Kommando

IMPORT COLUMNS-Kommando

UPDATE COLUMNS-Kommando

Sie möchten die Daten des Datenstroms room_cvs.data in die Datenbank importieren, wobei in einige Spalten der Zieltabelle der NULL-Wert importiert werden soll, wenn eine explizit angegebene Bedingung erfüllt ist.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data'
hno 1
type 2
free 3 NULL IF POS 3 = '0'
price 4 NULL IF POS 4 <> 'XXXX'

Für jede der Spalten FREE und PRICE definieren Sie eine eigene Bedingung für das angegebene Datenfeld. Wenn diese erfüllt ist, wird der NULL-Wert in die entsprechende Tabellenspalte eingetragen.

Sie möchten die Daten des Datenstroms customer_csv.data in die Datenbank importieren. In einige Spalten der Zieltabelle soll der NULL-Wert importiert werden, wenn eine explizit angegebene Bedingung erfüllt ist. In andere Spalten soll der NULL-Wert importiert werden, wenn der Vorschlagswert des Loader für die NULL-Wert-Darstellung gefunden wird. Ein SET-Kommando wurde nicht verwendet.

IMPORT TABLE hotel.customer
DATA INSTREAM 'customer_csv.data'
cno 1
title 2 DEFAULT NULL
firstname 3 NULL IF POS 3 = 'XXXX'
name 4
zip 5 DEFAULT NULL
address 6

Für die Spalten TITLE und ZIP gilt als Bedingung, dass der NULL-Wert in die entsprechende Tabellenspalte eingetragen wird, wenn die Default-NULL-Darstellung des Loader ? im Datenstrom gefunden wird. Für die Spalte FIRSTNAME wurde eine eigene Bedingung für die Werte im Datenstrom definiert, bei deren Erfüllung der NULL-Wert in die entsprechende Tabellenspalte eingetragen wird.

Sie möchten die Daten des Datenstroms room_cvs.data in die Datenbank importieren, wobei in einige Spalten der Zieltabelle der NULL-Wert importiert werden soll. Ein SET-Kommando wurde nicht verwendet.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data'
hno 1
type 2
free 3 DEFAULT NULL
price 4 DEFAULT NULL

Für alle im IMPORT-Kommando aufgeführten Spalten, für die DEFAULT NULL angegeben ist, gilt die gleiche Darstellung des NULL-Wertes im Datenstrom ?. Das ist in diesem Fall der Vorschlagswert für die NULL-Wert-Darstellung. Für die Spalten FREE und PRICE gilt als Bedingung, dass der NULL-Wert in die entsprechende Tabellenspalte eingetragen wird, wenn die NULL-Darstellung des Loader ? im Datenstrom gefunden wird.

Sie möchten die Daten des Datenstroms room_cvs.data in die Datenbank importieren, wobei in einige Spalten der Zieltabelle der NULL-Wert in eigener Darstellung importiert werden soll.

IMPORT TABLE hotel.room
DATA INSTREAM 'room_csv.data' NULL 'NULL'
hno 1
type 2
free 3 DEFAULT NULL
price 4 DEFAULT NULL

Für alle im IMPORT-Kommando aufgeführten Spalten, für die DEFAULT NULL angegeben ist, gilt die gleiche Darstellung des NULL-Wertes im Datenstrom: das Literal NULL. Für die Spalten FREE und PRICE gilt als Bedingung, dass der NULL-Wert in die entsprechende Tabellenspalte eingetragen wird, wenn die NULL-Darstellung des Loader NULL im Datenstrom gefunden wird.


Transformation (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Transformation

Definition

Die mit dem Exportieren/Importieren/Transportieren verbundene Aktion wird als Transformation bezeichnet und durch die Syntax des Loader oder durch Einträge in die Loader-spezifischen Systemtabellen beschrieben.

Verwendung

Eine Transformation ist durch Angaben zum Loader und zur Datenbankinstanz (Verbindungsinformationen), einen Transformationstyp (Export, Import, Transport), ein Transformationspaket (Angabe, welche Daten transportiert werden sollen) und die Spezifizierung der Datenströme (verwendete Datenträger, Datenformate) gekennzeichnet.

Zur logischen Beschreibung der Daten und deren Transformation nutzt der Loader Metadaten, die in unterschiedlichen Formaten vorliegen können. Wenn die Systemtabellen des Loader gefüllt werden, können diese unter anderem für das Wiederaufsetzen einer Transformation verwendet werden.

Der Sprachumfang des Loader ermöglicht die Transformation von Daten der gesamten Datenbank, eines Benutzers, eines Schemas, einer Tabelle oder einer Menge qualifizierter Spalten einer Tabelle oder mehrerer Tabellen, d.h. die Daten werden in Transformationspakete zusammengefasst. Mit entsprechenden Loader-Kommandos können Sie die Transformationspakete bearbeiten.

Siehe auch:

Exportieren: Kommandos

Importieren: Kommandos

Weitere Informationen

Eine Transformation der gesamten Anwendungsdaten oder des gesamten Datenbankkatalogs kann auch über Sicherungswerkzeuge anderer Anbieter erfolgen.

Siehe auch:

Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter


Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter

Vorgehensweisen Exportieren und Importieren mit Sicherungswerkzeugen anderer Anbieter

Wenn das Exportieren/Importieren von Daten mit den Loader-Kommandos zum Exportieren/Importieren der gesamten Anwendungs- und/oder Datenbankkatalogdaten erfolgt (EXPORT/IMPORT DB), ist der Einsatz von Sicherungswerkzeugen anderer Anbieter möglich.

Voraussetzungen

...

1. Strukturlink Anschluss von Sicherungswerkzeugen anderer Anbieter

2. Festlegen des Sicherungswerkzeuges
Verwenden Sie dazu das Loader-Kommando SET BACKUPTOOL.

Vorgehensweise

Sie starten den Export bzw. den Import direkt mit dem Loader. Bei der Angabe der Datenströme müssen Sie den Datenträgertyp TAPE bzw. TAPE <ebid_spec> wählen, da der Datenträger ein Band ist, das über ein Sicherungswerkzeug eines anderen Anbieters angesprochen wird.

● Export: Geben Sie als Datenträgertyp TAPE an.
Die Pipes zur Übertragung der Sicherungsdaten werden vom Loader beim Export implizit angelegt. Sie dürfen vorher nicht vorhanden sein.

● Import: Geben Sie als Datenträgertyp TAPE <ebid_spec> (<ebid_spec> ::= EBID '<literal>') an.
Die externe Sicherungskennung literal muss beim Importieren mit einem Sicherungswerkzeug eines anderen Anbieters nach dem Schlüsselwörten TAPE EBID angegeben werden.
Anhand der externen Sicherungskennung kann der gewünschte Datenstrom identifiziert werden.

Ergebnis

Die externe Sicherungskennung wird nach Beenden des Exportierens mit einem Sicherungswerkzeug eines anderen Anbieters in die Protokolldatei und in die Transformationstabelle des Loader geschrieben. Falls erforderlich, müssen Sie die externe Sicherungskennung anhand dieser Protokollinformationen ermitteln.

Siehe auch:

Datenstrom

EXPORT DB-Kommando

IMPORT DB-Kommando

Protokollfunktionen


Exportieren und Importieren von LONG-Werten (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Exportieren und Importieren von LONG-Werten

Mit den Kommandos EXPORT/IMPORT TABLE und EXPORT/IMPORT/UPDATE COLUMNS können LONG-Werte in Datenströme exportiert, in eine Zieltabelle importiert oder die LONG-Werte einer Tabelle geändert werden.

Sie definieren mit Hilfe der entsprechenden Syntaxregeln, in welche Datenströme die LONG-Werte exportiert bzw. in welche Spalten einer Zieltabelle die LONG-Werte importiert werden sollen.

Im Falle der Verwendung der Formate RECORDS oder PAGES sind besondere Syntaxregeln zur Behandlung der LONG-Werte nicht erforderlich.

Syntax

<export_lobcolumn_spec> ::= LOB <outstream_lob_spec>
<outstream_lob_spec> ::= OUTSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>]

<import_lobcolumn_spec> ::= LOB <instream_lob_spec>
<instream_lob_spec> ::= INSTREAM [FILE] <column_spec> <lob_code_spec>
| INSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>]

<column_spec> ::= <column_name> | <column_id>
<column_name> ::= <identifier>
<column_id> ::= <unsigned_integer>

<lob_code_spec> ::= <code_spec> | BINARY

<stream_name> | Name und Pfad des Datenstroms Es handelt sich um einen Datenstrom vom Datenträgertyp FILE. siehe auch: Datenstrom
<column_name> | Spaltenname siehe auch: SQL-Referenzhandbuch, Strukturlink Spaltenname (column_name)
<column_id> | Spalten-ID siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

EXPORT TABLE hotel.hotel
  DATA OUTSTREAM 'hotel_csv.data'
  LOB OUTSTREAM info 'hotel_info.data'

Die Werte der LONG-Spalte INFO werden in den Datenstrom hotel_info.data exportiert.

EXPORT TABLE hotel.hotel
  DATA INSTREAM 'hotel_csv.data'
  LOB INSTREAM info 'hotel_info.data'

Die Werte aus dem einen Datenstrom hotel_info.data werden in die LONG-Spalte INFO importiert.

Erläuterung

Die Daten für LONG-Werte werden von den anderen Daten getrennt in LONG-Datenströmen gespeichert. Diese Datenströme stream_name sind immer vom Datenträgertyp FILE.

Exportieren von LONG-Werten

Sie verwenden die Syntaxregel LOB OUTSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>], um den Export der LONG-Werte zu steuern.

● Jeder LONG-Wert einer Spalte kann in einen separaten LONG-Datenstrom exportiert werden.

● Alle LONG-Werte einer Spalte können in einen LONG-Datenstrom exportiert werden.

Wenn Sie beim Exportieren von LONG-Werten mehr LONG-Datenströme angeben als es LONG-Ausgabespalten in der Spaltenliste gibt, dann werden die überzähligen LONG-Datenströme vom Loader ignoriert.

Eine Erläuterung zur Spaltenspezifikation column_spec und zum Datenstrom stream_name finden Sie im Abschnitt Exportieren von LONG-Werten.

Importieren von LONG-Werten

Sie können die Syntaxregel LOB INSTREAM [FILE] <column_spec> <lob_code_spec> oder LOB INSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>] verwenden, um den Import der LONG-Werte zu steuern.

● Die LONG-Werte können aus mehreren LONG-Datenströmen importiert werden.

● Alle LONG-Werte können aus einem LONG-Datenstrom importiert werden.

Eine Erläuterung der beiden Syntaxregeln, zur Spaltenspezifikation column_spec und zum Datenstrom stream_name finden Sie im Abschnitt Importieren von LONG-Werten.

<lob_code_spec>

Die Angabe des Codeattributs für alle Datenströme, die LONG-Werte enthalten, die in eine Spalte exportiert/importiert werden sollen, ist durch Angabe der Syntaxregel lob_code_spec möglich. Es kann nur ein Codeattibut für alle Datenströme einer Spalte angegeben werden, da das Codeattribut im Kommando angegeben werden muss.

Die LONG-Werte der Spalte INFO werden aus mehreren LONG-Datenströmen importiert.

Angabe des Codeattributs ASCII

IMPORT TABLE hotel.hotel
  DATA INSTREAM 'hotel_csv.data'
    hno      1
    name     2
    zip      3
    address  4
    info     5 DEFAULT NULL
 LOB INSTREAM info ASCII

Inhalt des Datenstroms hotel_csv.data:

"10","Congress","20005","155 Beechwood St.","'hotel_info.data001'"
"20","Long Island","11788","1499 Grove Street","?"
"30","Regency","20037","477 17th Avenue","'hotel_info.data002'"

Die LONG-Werte der Spalte INFO werden aus einem LONG-Datenstrom importiert.

Angabe des Codeattributs ASCII

IMPORT TABLE hotel.hotel
  DATA INSTREAM 'hotel_csv.data'
    hno      1
    name     2
    zip      3
    address  4
    info     5 DEFAULT NULL
 LOB INSTREAM info 'hotel_info.data' ASCII

Inhalt des Datenstroms:

"10","Congress","20005","155 Beechwood St.","1-915"
"20","Long Island","11788","1499 Grove Street","?"
"30","Regency","20037","477 17th Avenue","916-1074"

Siehe auch:

Code-Spezifikation


Exportieren von LONG-Werten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Exportieren von LONG-Werten

Mit den Kommandos EXPORT TABLE und EXPORT COLUMNS können LONG-Werte in Datenströme exportiert werden.

Sie definieren mit Hilfe der entsprechenden Syntaxregeln, in welche Datenströme die LONG-Werte exportiert werden sollen.

Im Falle der Verwendung der Formate RECORDS oder PAGES sind besondere Syntaxregeln zur Behandlung der LONG-Werte nicht erforderlich.

Syntax

<export_lobcolumn_spec> ::= LOB <outstream_lob_spec>
<outstream_lob_spec> ::= OUTSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>]

<column_spec> ::= <column_name> | <column_id>
<column_name> ::= <identifier>
<column_id> ::= <unsigned_integer>

<lob_code_spec> ::= <code_spec> | BINARY

<stream_name> | Name des Datenstroms Es handelt sich um einen Datenstrom vom Datenträgertyp FILE. Auf Besonderheiten bei der Vergabe des Namens wird in den Erläuterungen hingewiesen. siehe auch: Datenstrom
<column_name> | Spaltenname siehe auch: SQL-Referenzhandbuch, Strukturlink Spaltenname (column_name)
<column_id> | Spalten-ID siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

Im Abschnitt Exportieren und Importieren von LONG-Werten und in den folgenden Abschnitten

Erläuterung

<column_spec>

Sie können für eine zu exportierende LONG-Spalte den Spaltennamen column_name oder die Spalten-ID column_id verwenden. Die Spalten-ID widerspiegelt die Stellung der Spalte in der Spaltenliste.

Angaben des LONG-Spaltennamens INFO

EXPORT TABLE hotel.hotel
  DATA OUTSTREAM 'hotel_csv.data'
  LOB OUTSTREAM info 'hotel_info.data'

Angaben der Spalten-ID der LONG-Spalte INFO

EXPORT TABLE hotel.hotel
  DATA OUTSTREAM 'hotel_csv.data'
  LOB OUTSTREAM 5 'hotel_info.data'

<lob_code_spec>

Die Angabe des Code-Typs für alle Datenströme, die LONG-Werte enthalten, die in eine Spalte exportiert werden sollen, ist durch Angabe der Syntaxregel lob_code_spec möglich. Es kann nur ein Code-Typ für alle Datenströme einer Spalte angegeben werden, da der Code-Typ im Kommando angegeben werden muss.

Angaben des Code-Typs ASCII

EXPORT TABLE hotel.hotel
  DATA OUTSTREAM 'hotel_csv.data'
  LOB OUTSTREAM info 'hotel_info.data' ASCII

Siehe auch:

Code-Spezifikation

Angabe des LONG-Datenstroms <stream_name>

Beim Exportieren von LONG-Werten müssen folgende Fälle unterschieden werden:

...

● Jeder zu exportierende LONG-Wert einer Spalte wird in einen separaten LONG-Datenstrom exportiert.

● Alle zu exportierenden LONG-Werte einer Spalte werden in einen LONG-Datenstrom exportiert.

Jeder zu exportierende LONG-Wert wird in einen separaten LONG-Datenstrom exportiert

Sie vergeben durch das Export-Kommando für jeden zu exportierenden LONG-Wert einen Namen eines LONG-Datenstroms. Dazu geben Sie nach Angabe der LONG-Spalte im Export-Kommando den Namen des LONG-Datenstroms mit einer Anzahl von Platzhaltern für eine fortlaufende Nummerierung der erzeugten LONG-Datenströme an.

Wenn die zu exportierende LONG-Spalte in einem Datensatz keinen Wert enthält (Wert ist die leere Zeichenkette), dann wird für diesen LONG-Wert ein leerer LONG-Datenstrom erzeugt.

Mit Hilfe der so erzeugten eindeutigen Namen können die einzelnen LONG-Datenströme dem entsprechenden Datensatz in der Zieltabelle zugeordnet werden.

Verwenden Sie als Platzhalter eine ausreichende Anzahl von Nummernzeichen am Ende des Namens des LONG-Datenstroms. Wenn während des Exportierens die Obergrenze der Nummerierung erreicht wird aber noch weitere Werte zu exportieren sind, erzeugt der Loader eine Fehlermeldung und bricht die Bearbeitung des Export-Kommandos ab.

EXPORT TABLE hotel.hotel
  DATA OUTSTREAM 'hotel_csv.data'
  LOB OUTSTREAM info 'hotel_info.data###'

Der Loader erzeugt für den ersten zu exportierenden LONG-Wert den LONG-Datenstrom mit dem Namen hotel_info.data.001, für den zweiten den LONG-Datenstrom hotel_info.data.002 usw.
Inhalt des Datenstroms hotel_csv.data (Auszug)

"10","Congress","20005","155 Beechwood St.","hotel_info.data001"
"20","Long Island","11788","1499 Grove Street","?"
"30","Regency","20037","477 17th Avenue","hotel_info.data002"

Siehe auch:

Importieren von LONG-Werten, Jeder zu importierende LONG-Wert steht in einem separaten LONG-Datenstrom

Alle zu exportierenden LONG-Werte werden in einen LONG-Datenstrom exportiert

Sie geben im Kommando zum Exportieren von Daten pro LONG-Spalte den Namen eines LONG-Datenstroms an, in den jeweils die LONG-Werte dieser zu exportierenden LONG-Spalte eingetragen werden.

Wenn die zu exportierende LONG-Spalte in einem Datensatz keinen Wert enthält (Wert ist die leere Zeichenkette), dann wird die Positionsangabe für diesen LONG-Wert wie folgt erzeugt: Anfangsposition ist die Endposition des vorhergehenden LONG-Wertes der Spalte plus 1; Endposition ist die Endposition des vorhergehenden LONG-Wertes der Spalte. Daraus ergibt sich, dass im Fall des leeren Wertes die Anfangsposition immer genau einen Wert größer ist als die Endposition.

Die Zuordnung von LONG-Werten zu den Datensätzen erfolgt mit Hilfe der Anfangs- und Endposition des erzeugten LONG-Wertes im LONG-Datenstrom.

EXPORT TABLE hotel.hotel
  DATA OUTSTREAM 'hotel_csv.data'
  LOB OUTSTREAM info 'hotel_info.data'

Inhalt des Datenstroms hotel_csv.data (Auszug)

"10","Congress","20005","155 Beechwood St.","1-994"
"20","Long Island","11788","1499 Grove Street","?"
"30","Regency","20037","477 17th Avenue","995-1157"

Siehe auch:

Importieren von LONG-Werten, Alle zu importierenden LONG-Werte einer Spalte stehen in einem LONG-Datenstrom


Importieren von LONG-Werten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Importieren von LONG-Werten

Mit den Kommandos IMPORT TABLE und IMPORT/UPDATE COLUMNS können LONG-Werte in eine Zieltabelle importiert bzw. aktualisiert werden.

Sie definieren mit Hilfe der entsprechenden Syntaxregeln, in welche Spalten einer Zieltabelle die LONG-Werte importiert bzw. welche Spalten aktualisiert werden sollen.

Im Falle der Verwendung der Formate RECORDS oder PAGES sind besondere Syntaxregeln zur Behandlung der LONG-Werte nicht erforderlich.

Voraussetzungen

Wenn Sie einen Import durchführen möchte, müssen Sie die Daten exportiert bzw. in entsprechendem Format vorliegen haben. Die erforderlichen LONG-Werte befinden sich in LONG-Datenströmen.

Siehe auch:

Exportieren von LONG-Werten

Syntax

<import_lobcolumn_spec> ::= LOB <instream_lob_spec>
<instream_lob_spec> ::= INSTREAM [FILE] <column_spec> <lob_code_spec>
| INSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>]

<column_spec> ::= <column_name> | <column_id>
<column_name> ::= <identifier>
<column_id> ::= <unsigned_integer>

<lob_code_spec> ::= <code_spec> | BINARY

<stream_name> | Name des Datenstroms Es handelt sich um einen Datenstrom vom Datenträgertyp FILE. Auf Besonderheiten des Namens wird in den Erläuterungen hingewiesen. siehe auch: Datenstrom
<column_name> | Spaltenname siehe auch: SQL-Referenzhandbuch, Strukturlink Spaltenname (column_name)
<column_id> | Spalten-ID siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Beispiele

Im Abschnitt Exportieren und Importieren von LONG-Werten und in den folgenden Abschnitten

Erläuterung

<column_spec>

Sie können für eine zu importierende LONG-Spalte den Spaltennamen column_name oder die Spalten-ID column_id verwenden. Die Spalten-ID widerspiegelt die Stellung der Spalte in der Spaltenliste.

Angaben des LONG-Spaltennamens INFO

IMPORT TABLE hotel.hotel
  DATA INSTREAM 'hotel_csv.data'
  LOB INSTREAM info 'hotel_info.data'

Angaben der Spalten-ID der LONG-Spalte INFO

IMPORT TABLE hotel.hotel
  DATA INSTREAM 'hotel_csv.data'
  LOB INSTREAM 5 'hotel_info.data'

<lob_code_spec>

Die Angabe des Code-Typs für alle Datenströme, die LONG-Werte enthalten, die in eine Spalte importiert werden sollen, ist durch Angabe der Syntaxregel lob_code_spec möglich. Es kann nur ein Code-Typ für alle Datenströme einer Spalte angegeben werden, da der Code-Typ im Kommando angegeben werden muss.

Angaben des Code-Typs ASCII

IMPORT TABLE hotel.hotel
DATA INSTREAM 'hotel_csv.data'
LOB INSTREAM info 'hotel_info.data' ASCII

Siehe auch:

Code-Spezifikation

Angabe des LONG-Datenstroms <stream_name>

Beim Importieren von LONG-Werten müssen folgende Fälle unterschieden werden:

● Jeder zu importierende LONG-Wert steht in einem separaten LONG-Datenstrom.

● Alle zu importierenden LONG-Werte einer Spalte stehen in einem LONG-Datenstrom.

Jeder zu importierende LONG-Wert steht in einem separaten LONG-Datenstrom

Sie müssen keine der LOB-Syntaxregeln im IMPORT-Kommando verwenden, da der Loader den DATA-Datenstrom auswertet. Im DATA-Datenstrom stehen nach entsprechendem Export (Exportieren von LONG-Werten, Jeder zu exportierende LONG-Wert wird in einen separaten LONG-Datenstrom exportiert) anstelle der Spaltenwerte die Namen der zu importierenden LONG-Datenströme (gegebenenfalls ergänzt die fortlaufende Nummerierung). Die kompletten LONG-Datenströme werden als LONG-Werte importiert.

Die kompletten LONG-Datenströme werden als LONG-Werte importiert

IMPORT TABLE hotel.hotel
  DATA INSTREAM 'hotel_csv.data'
    hno      1
    name     2
    zip      3
    address  4
    info     5 DEFAULT NULL

Inhalt des DATA-Datenstroms hotel_csv.data (Auszug)

10","Congress","20005","155 Beechwood St.","hotel_info.data001"
"20","Long Island","11788","1499 Grove Street","?"
"30","Regency","20037","477 17th Avenue","hotel_info.data002"

Sie können zusätzlich die Syntaxregel LOB INSTREAM [FILE] <column_spec> <lob_code_spec> im IMPORT-Kommando verwenden, wenn Sie erreichen wollen, dass die Werte in den LONG-Datenströmen entsprechend des angegebenen Code-Typs importiert werden. Auch in diesem Fall stehen im DATA-Datenstrom anstelle der Spaltenwerte die Namen der zu importierenden LONG-Datenströme (gegebenenfalls ergänzt die fortlaufende Nummerierung) an. Die kompletten LONG-Datenströme werden als LONG-Werte importiert.

Die kompletten LONG-Datenströme werden als LONG-Werte importiert und binär eingelesen

IMPORT TABLE hotel.hotel
  DATA INSTREAM 'hotel_csv.data'
    hno      1
    name     2
    zip      3
    address  4
 info 5 DEFAULT NULL
  LOB INSTREAM info BINARY

Inhalt des DATA-Datenstroms hotel_csv.data (Auszug)

10","Congress","20005","155 Beechwood St.","hotel_info.data001"
"20","Long Island","11788","1499 Grove Street","?"
"30","Regency","20037","477 17th Avenue","hotel_info.data002"

Alle zu importierenden LONG-Werte einer Spalte stehen in einem LONG-Datenstrom

Sie verwenden die Syntaxregel LOB INSTREAM [FILE] <column_spec> '<stream_name>', um den LONG-Datenstrom anzugeben. Im DATA-Datenstrom stehen nach entsprechendem Export (Exportieren von LONG-Werten, Alle zu exportierenden LONG-Werte werden in einen LONG-Datenstrom exportiert) anstelle der Spaltenwerte nur die Positionen der LONG-Werte im LONG-Datenstrom.

IMPORT TABLE hotel.hotel
DATA INSTREAM 'hotel_csv.data'
hno 1
name 2
zip 3
address 4
info 5 DEFAULT NULL
LOB INSTREAM info 'hotel_info.data'

Inhalt des DATA-Datenstroms hotel_csv.data (Auszug)

"10","Congress","20005","155 Beechwood St.","1-915"
"20","Long Island","11788","1499 Grove Street","?"
"30","Regency","20037","477 17th Avenue","916-1074"

Sie können die Syntaxregel LOB INSTREAM [FILE] <column_spec> '<stream_name>' <lob_code_spec> im IMPORT-Kommando verwenden, wenn Sie erreichen wollen, dass die Werte in den LONG-Datenströmen entsprechend des angegebenen Code-Typs importiert werden. Auch in diesem Fall sind im DATA-Datenstrom nur die Positionen der LONG-Werte im LONG-Datenstrom angegeben.

IMPORT TABLE hotel.hotel
DATA INSTREAM 'hotel_csv.data'
hno 1
name 2
zip 3
address 4
 info 5 DEFAULT NULL
LOB INSTREAM info 'hotel_info.data' ASCII

Inhalt des DATA-Datenstroms hotel_csv.data (Auszug)

"10","Congress","20005","155 Beechwood St.","1-915"
"20","Long Island","11788","1499 Grove Street","?"
"30","Regency","20037","477 17th Avenue","916-1074"


Wiederaufsetzen (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Wiederaufsetzen

Mit der Syntaxregel restart_spec können Sie die Voraussetzung dafür schaffen, dass Sie den Export bzw. den Import wiederaufsetzen können.

Syntax

<restart_spec> ::= RESTART <package_guid>

<package_guid> ::= <unsigned_integer>

<package_guid>

ID, die zur Laufzeit vom Loader für jedes Kommando erzeugt wird

Die package_guid ist eine ganze Zahl, die immer 24 Bytes lang ist.

siehe auch: SQL-Referenzhandbuch, Strukturlink Ganze Zahl ohne Vorzeichen (unsigned_integer)

Erläuterung

Die package_guid und der Rechnername des Loader-Clients werden in die Systemtabelle SYSLOADER.TRANSFORMATIONMODEL eingetragen und in der Protokolldatei protokolliert.

Der Benutzer kann die package_guid eines Kommandos aus der Tabelle SYSLOADER.TRANSFORMATIONMODEL oder der Protokolldatei ermitteln. Durch Ausführung dieses Kommandos mit dem Syntaxelement RESTART <package_guid> kann das Kommando wiederaufgesetzt werden.

Siehe auch:

TRANSFORMATIONMODEL

Protokolldatei

EXPORT DB-Kommando

EXPORT USER-Kommando

EXPORT SCHEMA-Kommando

IMPORT DB-Kommando

IMPORT USER-Kommando

IMPORT SCHEMA-Kommando


Protokollfunktionen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Protokollfunktionen

Verwendung

Der Loader protokolliert seine Aktionen in Dateien und Systemtabellen.

Funktionsumfang

● Protokolldatei
Der Loader protokolliert seine Export- und Importaktionen in der Protokolldatei loader_<timestamp>.log bzw. loader.log.

● Transformationshistorie
Der Loader erzeugt bei der Arbeit im Transportmodus zusätzlich zur Protokolldatei eine Transformationshistorie transport.log.

● Zusätzliche Protokollfunktionalität (package_spec)
Eine detaillierte Protokollierung eines einzelnen Loader-Kommandos können Sie durch Verwenden des Syntaxelements package_spec erreichen.

● Systemtabellen
Ein Transportieren von Daten nimmt je nach Datenvolumen einige Zeit in Anspruch. Der Loader ist in der Lage, im Fall einer Unterbrechung die Aktion wiederaufzusetzen. Dazu werden die Informationen der Systemtabellen ausgewertet.


Protokolldatei (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Protokolldatei

Definition

Eine wesentliche Protokollfunktion des Loader ist das Anlegen und Verwalten einer Protokolldatei. Die Protokollierung des Laufzeitverhaltens beim Export oder Import (d.h. die Ausführung der Kommandos) erfolgt jeweils in der Protokolldatei loader_<timestamp>.log bzw. loader.log.

Verwendung

Beim Starten des Loader wird die Protokolldatei angelegt bzw. fortgeschrieben.

● Transportmodus: Die Protokollierung des Laufzeitverhaltens des Pakets (d.h. die Ausführung der Kommandos) erfolgt in der Protokolldatei loader_<timestamp>.log. Anhand des Zeitstempels können Sie ablesen, wann das Paket ausgeführt wurde. Der Zeitstempel der ersten Protokolldatei ist mit dem Namen des Pakets package_timestamp (Voreinstellung ist der Zeitstempel als Name) identisch. Wenn Sie das Paket für erneute Transformationen verwenden, werden Protokolldateien erzeugt, deren Zeitstempel den Beginn dieser Transformation widerspiegeln und daher nicht mehr mit dem Namen des Pakets identisch sind.

● Kommandodatei- und Sitzungsmodus: Die Protokollierung des Laufzeitverhaltens innerhalb einer Loader-Sitzung erfolgt in der Protokolldatei loader.log, die fortlaufend gefüllt wird. Wenn gleichzeitig eine weitere Loader-Sitzung eröffnet wird, wird die Protokolldatei loader_<timestamp>.log erzeugt und für diese Loader-Sitzung fortgeschrieben. Anhand des Zeitstempels können Sie ablesen, wann die zusätzliche Loader-Sitzung eröffnet wurde.

Ablage der Protokolldateien

Betriebsmodus

Protokolldateiverzeichnis

Transportmodus

EXPORT-Verzeichnis: <loader_user_data>\packages\export\<database_computer>\<database_name>\<package_timestamp>

IMPORT-Verzeichnis: <loader_user_data>\packages\import\<database_computer>\<database_name>\<package_timestamp>

Beispiel für EXPORT-Verzeichnis

C:\transport\sdb\loader\packages\export\GENUA\DEMODB\20060330101010

Kommandodatei- und Sitzungsmodus

Server-Profil: <independent_data_path>\wrk

Client-Profil: <loader_application_data>\log

Beispiel für Client-Profil

C:\Documents and Settings\anna\My Documents\sdb\loader\log

Struktur

In der Protokolldatei finden sie alle Loader-Kommandos, die für den Verbindungsaufbau und das Durchführen der gewünschten Transformation (Export, Import oder Transport) erforderlich sind.

Kommentare beginnen in einer neuen Zeile mit // * oder // <Buchstabe>.

Besondere Kommentarzeilen:

// M | Zeile mit Meldungen Es handelt sich um informative Systemmeldungen, wie Anzahl eingefügter und abgelehnter Zeilen, letzte abgeschlossene Transaktion usw.
// E | Zeile mit Fehlermeldungen Damit werden z. B. die beiden Zeilen mit Tabellen- und Positionsangabe sowie Fehlernummer oder Fehlertext bei abgelehnten Zeilen eingeleitet.
// R | Zeile mit REMARK-Kommentar Es handelt sich um die Kommentare, die der Benutzer mit Hilfe des REMARK-Kommandos angegeben hat.

Integration

Die Protokolldatei ist so aufgebaut, dass Teile daraus ohne großen Aufwand zum Erzeugen einer Kommandodatei verwendet werden können.

In der Protokolldatei wird jedes Kommando gespeichert mit Informationen zur Ausführungszeit, für wie viele Objekte Aktionen durchgeführt wurden und welche Fehler aufgetreten sind. Allerdings wird in der Protokolldatei nicht wiedergegeben, welche einzelnen Aktionen erforderlich waren, um das Kommando durchzuführen. Möchten Sie diese detaillierten Informationen haben, können Sie das Syntaxelement package_spec verwenden, um die Vorgänge detaillierter zu protokollieren.

Siehe auch:

Zusätzliche Protokollfunktionalität (package_spec)

REMARK-Kommando

Mit diesem Kommando des Loader können Sie Kommentare in die Protokolldatei schreiben.

<remark_command> ::= REMARK "<literal>"

<literal>

literal: Kommentar

siehe auch: SQL-Referenzhandbuch, Strukturlink Literal (literal)

Siehe auch:

Transportmodus

Kommandodateimodus

Sitzungsmodus

Konzepte des Datenbanksystems, Strukturlink Protokolldateien

Installationshandbuch, Strukturlink Verzeichnisse


Transformationshistorie (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Transformationshistorie

Definition

Der Loader erzeugt bei der Arbeit im Transportmodus zusätzlich zur Protokolldatei eine Transformationshistorie transport.log, in der verzeichnet ist, welches Paket generiert und welches ausgeführt wurde.

Ablage der Transformationshistorie

Verzeichnis | <loader_application_data>\packages
Beispiel | C:\Documents and Settings\anna\My Documents\sdb\loader\log

Siehe auch:

Transportmodus

Protokolldatei

Protokollfunktionen


Zusätzliche Protokollfunktionalität (package_spec) (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Zusätzliche Protokollfunktionalität (package_spec)

Zusätzlich zu Einträgen in der Protokolldatei des Loader (loader.prt) finden Sie detaillierte Informationen zu den Aktionen, die während der Ausführung eines Kommandos ablaufen, in der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL.

Sie können für viele Loader-Kommandos die Werte der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL, die zu einem Kommando gehören, mit Hilfe des Syntaxelements package_spec in einen Datenstrom exportieren. In diesem Datenstrom finden Sie alle Angaben, die das durchgeführte Loader-Kommando vollständig beschreiben, sowohl Angaben zum Entwurf des Kommandos als auch die Laufzeitdaten des ausgeführten Kommandos.

Syntax

<package_spec> ::= PACKAGE <outstream_csv_spec>

<outstream_csv_spec> ::= Datenstrom

Verwendung

Das Syntaxelement package_spec kann in folgenden Kommandos verwendet werden:

EXPORT DB | IMPORT DB
EXPORT USER | IMPORT USER
EXPORT SCHEMA | IMPORT SCHEMA
EXPORT TABLE | IMPORT TABLE

Erläuterung

● Durch die Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden die dem Kommando zugehörigen Einträge in der Tabelle SYSLOADER.TRANSFORMATIONMODEL in diesen Datenstrom exportiert.

● Ohne Angabe eines Datenstroms mittels PACKAGE <outstream_csv_spec> werden die Einträge der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL nicht exportiert.

Der PACKAGE-Datenstrom outstream_csv_spec wird im Format CSV erzeugt.

Die Spaltenwerte der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL sind in der folgenden Reihenfolge im PACKAGE-Datenstrom outstream_csv_spec abgelegt:

OWNER
SCHEMANAME
TABLENAME
DATASTREAMNAME
DATASTREAMHEADERBLOCK
DATASTREAMHEADERPOS
DATASTREAMTRAILERBLOCK
DATASTREAMTRAILERPOS
DATASTREAMDATABLOCK
DATASTREAMDATAPOS
EXCLUDE
PACKAGEGUID
TASKID
STEPID
SERVERNODE
SERVERDB
USERNAME
CODETYPE
CODEPAGEID
STORAGEDEVICE
TRANSACTIONSIZE
TRANSFORMATION
PART
TABLETYPE
CATALOGSTREAMNAME
CATALOGSTREAMTYPE
CATALOGSTREAMEBID
CATALOGSTREAMFORMAT
DATASTREAMTYPE
DATASTREAMEBID
DATASTREAMFORMAT
RESTART
RESTORE
PAGECOUNT
ROWCOUNT
STARTTIME
ENDTIME
REQUESTTIME
RECEIVETIME
IOTIME
LOGTIME

Die dem Kommando zugehörigen Werte werden aus der Systemtabelle SYSLOADER.TRANSFORMATIONMODEL gelöscht, wenn sich alle Werte im gewünschten Datenstrom befinden.

Beispiel

EXPORT USER
DATA OUTSTREAM 'mona_pages.data' PAGES
PACKAGE OUTSTREAM 'mona_csv.package'

Die Anwendungsdaten des Datenbankbenutzers MONA werden exportiert. Im Datenstrom mona_csv.package finden Sie alle Angaben, die das durchgeführte Loader-Kommando vollständig beschreiben

Inhalt des PACKAGE-Datenstroms mona_csv.package

"MONA","HOTEL","CITY","mona.data0001","0","1024","0","0","0","66560","FALSE","010000003A29DCF9200F0000B0450000A6B717DE7CE1BF84","1","1","GENUA","TESTDB","MONA","ASCII","?","NONE","0","EXPORT","USER","TABLE","?","?","?","?","FILE","?","PAGES","FALSE","FALSE","0","0","20060116135730309000","20060116135730339000","0.000","0.000","0.000","0.000"

"MONA","HOTEL","CUSTOMER","mona.data0001","0","66560","0","0","0","132096","FALSE","010000003A29DCF9200F0000B0450000A6B717DE7CE1BF84","1","2","GENUA","TESTDB","MONA","ASCII","?","NONE","0","EXPORT","USER","TABLE","?","?","?","?","FILE","?","PAGES","FALSE","FALSE","0","0","20060116135730349000","20060116135730359000","0.000","0.000","0.000","0.000"

"MONA","HOTEL","HOTEL","mona.data0001","0","132096","0","0","0","214016","FALSE","010000003A29DCF9200F0000B0450000A6B717DE7CE1BF84","1","3","GENUA","TESTDB","MONA","ASCII","?","NONE","0","EXPORT","USER","TABLE","?","?","?","?","FILE","?","PAGES","FALSE","FALSE","0","0","20060116135730359000","20060116135730389000","0.000","0.000","0.000","0.000"

"MONA","HOTEL","ROOM","mona.data0001","0","214016","0","0","0","279552","FALSE","010000003A29DCF9200F0000B0450000A6B717DE7CE1BF84","1","4","GENUA","TESTDB","MONA","ASCII","?","NONE","0","EXPORT","USER","TABLE","?","?","?","?","FILE","?","PAGES","FALSE","FALSE","0","0","20060116135730389000","20060116135730399000","0.000","0.000","0.000","0.000"

"MONA","HOTEL","EMPLOYEE","mona.data0001","0","279552","0","0","0","345088","FALSE","010000003A29DCF9200F0000B0450000A6B717DE7CE1BF84","1","5","GENUA","TESTDB","MONA","ASCII","?","NONE","0","EXPORT","USER","TABLE","?","?","?","?","FILE","?","PAGES","FALSE","FALSE","0","0","20060116135730409000","20060116135730419000","0.000","0.000","0.000","0.000"

"MONA","HOTEL","RESERVATION","mona.data0001","0","345088","0","0","0","410624","FALSE","010000003A29DCF9200F0000B0450000A6B717DE7CE1BF84","1","6","GENUA","TESTDB","MONA","ASCII","?","NONE","0","EXPORT","USER","TABLE","?","?","?","?","FILE","?","PAGES","FALSE","FALSE","0","0","20060116135730429000","20060116135730439000","0.000","0.000","0.000","0.000"


Systemtabellen (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Systemtabellen

Definition

Eine wesentliche Protokollfunktion des Loader ist das Ablegen Loader-relevanter Informationen in Systemtabellen.

Verwendung

Bei der Installation des Datenbanksystems werden für den Loader folgende Systemtabellen angelegt:

● CODEPAGE

● MAPSCHEMANAMES

● TRANSFORMATIONMODEL

● TRANSFORMATIONMONITOR

● TRANSFORMATIONPACKAGES

● TRANSFORMATIONRESOURCES

● TRANSFORMATIONSTATISTICS

● TRANSFORMATIONSTEPS

Struktur

Eigentümer dieser Systemtabellen ist der Datenbanksystemadministrator. Die Tabellen werden im Schema SYSLOADER erzeugt. Die Angabe des Schemas ist beim Zugriff auf diese Tabellen erforderlich.

SELECT * FROM sysloader.transformationmodel
WHERE PACKAGEGUID = <package_guid>

In den TRANSFORMATION-Systemtabellen protokolliert der Loader Informationen zum Laufzeitverhalten beim Export und Import. Über die Systemtabellen kann eine Transformation zusätzlich konfiguriert werden.

Der Loader nutzt die Einträge in den Systemtabellen für die Wiederaufsetzbarkeit von Kommandos. Die Wiederaufsetzbarkeit wird über die RESTART-Option eines Kommandos erreicht.

Siehe auch:

Wiederaufsetzen

Zusätzliche Protokollfunktionalität (package_spec)


MAPSCHEMANAMES (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation MAPSCHEMANAMES

Definition

Die Systemtabelle MAPSCHEMANAMES enthält Informationen zu den Schema-Maps, die der Loader verwenden kann.

Wenn ein Schema-Map angelegt wurde, werden die entsprechenden Einträge in die Systemtabelle MAPSCHEMANAMES eingefügt. Wenn Sie ein Schema-Map löschen, werden die entsprechenden Einträge aus dieser Systemtabelle gelöscht.

Siehe auch:

CREATE/DROP SCHEMAMAP-Anweisung

USE SCHEMAMAP-Kommando

Struktur

MAPSCHEMANAMES

PACKAGEGUID | CHAR(24) BYTE | Eindeutige Kennung des Schema-Map
MAPPINGNAME | CHAR(32) | Name des Schema-Map
SOURCESCHEMANAME | CHAR(32) | Name des Schemas, das auf das Ziel-Schema abgebildet wird
TARGETSCHEMANAME | CHAR(32) | Name des Schemas, auf das das ursprüngliche Schema abgebildet wird

Siehe auch:

IMPORT SCHEMA-Kommando


Syntaxregeln: alphabetisch sortiert (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Syntaxregeln: alphabetisch sortiert

Die für die Loader-Kommandos erforderlichen Syntaxregeln werden in der folgenden Übersicht alphabetisch sortiert aufgelistet.

Ein Kommando des Loader setzt sich aus einem oder mehreren Schlüsselwörtern sowie Argumenten und Syntaxregeln zusammen. Die für die Kommandos des Loader verwendete Syntaxform ist die Backus-Naur-Form (BNF) mit folgenden Konventionen:

Erläuterung

SCHLÜSSELWÖRTER

Schlüsselwörter sind zur Verdeutlichung in Großbuchstaben geschrieben. Sie können in Groß- und in Kleinbuchstaben angegeben werden.

Wenn Sie Schlüsselwörter als Namen von Spalten, Tabellen oder Datenbankbenutzern verwenden, müssen diese in doppelte Anführungszeichen eingeschlossen werden.

<xyz>

In spitze Klammern eingefasste Begriffe sind Platzhalter für Endsymbole, die erläutert werden. Verwenden Sie die spitzen Klammern bei der Angabe eines Loader-Kommandos nicht mit.

Es handelt sich um Benutzereingaben. Beachten Sie, dass diese Eingaben gegebenenfalls in einfache Anführungszeichen zu setzen sind, wenn es die Syntaxregel verlangt. Endsymbole sind Zahlen, Zeichen, Literale oder Schlüsselwörter und werden nicht weiter aufgelöst.

<! Text !>

In spitze Klammern und Ausrufezeichen eingefasste Texte geben an, dass die syntaktische Einheit durch einen Text erläutert wird. Geben Sie die spitzen Klammern und Ausrufezeichen bei der Angabe eines Loader-Kommandos nicht an.

Regel ::= Regelteil

Regeln sind die Bausteine der Loader-Kommandos. Die Regelteile beschreiben die Bildung zusammengesetzter Bausteine aus einfacheren Bausteinen und ihre Notation.

Ein Regelteil ist eine beliebige Kombination von Regeln und Endsymbolen.

Regel1 Regel2

Die beiden Regeln werden hintereinander notiert und durch wenigstens ein Leerzeichen voneinander getrennt.

[Regel]

Optionale Regel. Diese Regel kann ersatzlos entfallen. Geben Sie die eckigen Klammern bei der Angabe eines Loader-Kommandos nicht an.

Regel1 | Regel2 | ... | Regel<n>

Alternative Regeln. Sie können jeweils genau eine der Regeln verwenden.

Regel,...

Die Regel kann beliebig oft wiederholt werden. Die einzelnen Wiederholungen sind hintereinander zu notieren und durch ein Komma und beliebig viele Leerzeichen voneinander zu trennen.

Regel ...

Die Regel kann beliebig oft wiederholt werden. Die einzelnen Wiederholungen sind hintereinander zu notieren und durch Leerzeichen voneinander zu trennen.

Leerzeichen in Kommandos sind erlaubt. Sie werden vom Loader nicht interpretiert.

Die Syntaxregeln können auch in semantischer Sortierung angezeigt werden: Syntaxregeln: semantisch sortiert.

<autocommit_command> ::=
AUTOCOMMIT ON
| AUTOCOMMIT OFF

<backup_tool_spec> ::=
BACKINT
| NETWORKER
| TSM

<bool_spec> ::=
BOOLEAN '<true_value>/<false_value>'

<catalog_data_instream_part_spec> ::=
<catalog_instream_spec>
| <data_instream_part_spec>
| <catalog_instream_spec> <data_instream_part_spec>

<catalog_data_instream_table_spec> ::=
<catalog_instream_spec>
| <data_instream_table_spec>
| <catalog_instream_spec> <data_instream_table_spec>

<catalog_data_outstream_part_spec> ::=
<catalog_outstream_spec>
| <data_outstream_part_spec>
| <catalog_outstream_spec> <data_outstream_part_spec>

<catalog_data_outstream_table_spec> ::=
<catalog_outstream_spec>
| <data_outstream_table_spec>
| <catalog_outstream_spec> <data_outstream_table_spec>

<catalog_instream_spec> ::=
CATALOG <instream_ddl_spec>

<catalog_outstream_spec> ::=
CATALOG <outstream_ddl_spec>

< Strukturlink character> ::=
<! SQL-Referenzhandbuch !>

<code_page_spec> ::=
CODEPAGE [<literal>]

<code_spec> ::=
<standard_code_spec>
| CODESET <literal>

<column_assignment> ::=
<column_name> '<literal>'
| <column_name> <column_function>

<column_dataformat_spec> ::=
CSV <csv_format_spec> ...
| FWV [BINARY] <fwv_format_spec> ...
| FWV BINARY <fwv_format_spec> ... <noheader_spec>

<column_function> ::=
DATE
| FALSE
| STAMP
| TIME
| TIMESTAMP
| TRUE
| USER
| USERGROUP
| <sequence_number>

<column_id> ::=
<unsigned_integer>

<column_name> ::=
<identifier>

<column_spec> ::=
<column_name>
| <column_id>

<compare_operator> ::=
<
| >
| =
| <=
| >=
| !=

<condition> ::=
(<condition>)
| <condition> AND <condition>
| <condition> OR <condition>
| NOT <condition>
| <simple_condition>

<configuration_spec> ::=
CONFIGURATION <instream_csv_spec>

<csv_format_spec> ::=
<separator_spec>
| <delimiter_spec>
| <null_spec>
| <field_format_spec>

<data_instream_column_spec> ::=
DATA <instream_columnformat_spec> [<import_lobcolumn_spec> ...]

<data_instream_columns_spec> ::=
DATA <instream_columnformat_spec>
[<import_column_spec> ... <import_lobcolumn_spec> ...] [<usage_spec>]

<data_instream_part_spec> ::=
DATA <instream_tableformat_spec>

<data_instream_table_spec> ::=
<data_instream_part_spec>
| <data_instream_columns_spec>

<data_outstream_column_spec> ::=
DATA <outstream_columnformat_spec> [<export_lobcolumn_spec> ...]

<data_outstream_part_spec>::=
DATA <outstream_tableformat_spec>

<data_outstream_table_spec> ::=
<data_outstream_part_spec>
| <data_outstream_column_spec>

<database_computer> ::=
<! USE DB-Kommando !>

<database_name> ::=
<! USE DB-Kommando !>

<database_spec> ::=
<database_name> [ON <database_computer> [ENCRYPTION <protocol_name>]]

< Strukturlink database_user> ::=
 <! SQL-Referenzhandbuch !>

<date_spec> ::=
DATE <standard_date_mask>
| DATE '<free_mask_date>'

<decimal_symbol> ::=
<! SET-Kommando !>

<delimter> ::=
<character>

<delimiter_spec> ::=
DELIMITER '<delimiter>'

<digit_grouping_symbol> ::=
<! SET-Kommando !>

<duplicates_clause> ::=
REJECT DUPLICATES
| IGNORE DUPLICATES
| UPDATE DUPLICATES

<ebid_spec> ::=
EBID '<literal>'

<exclude_include> ::=
EXCLUDE
| INCLUDE

<export_column_spec> ::=
<map_column_field>
| <field_assignment>

<export_columns_command> ::=
EXPORT COLUMNS <select_expression>
[MAP COLUMNS <export_column_spec> ...]
<data_outstream_column_spec>

<export_command> ::=
<export_db_command>
| <export_user_command>
| <export_schema_command>
| <export_table_command>
| <export_columns_command>

<export_db_command> ::=
EXPORT DB
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

<export_lobcolumn_spec> ::=
LOB <outstream_lob_spec>

<export_schema_command> ::=
EXPORT SCHEMA <schema_name>
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

<export_table_command> ::=
EXPORT TABLE <table_name>
[<restore_spec>]
[<order_clause>]
<catalog_data_outstream_table_spec>
[<package_spec>]

<export_user_command> ::=
EXPORT USER
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

<false_value> ::=
<! SET-Kommando !>

<field_assignment> ::=
'<literal>' <field_spec>

<field_format_spec> ::=
<bool_spec>
| <code_spec>
| <date_spec>
| <number_spec>
| <time_spec>
| <timestamp_spec>

<field_function> ::=
<field_type> [HEX]
| <numerical_functions>
| <field_type> [HEX] <numerical_functions>

<field_spec> ::=
<unsigned_integer>
| <unsigned_integer> - <unsigned_integer>

<field_type> ::=
/* empty */
| CHAR
| DECIMAL [<unsigned_integer>]
| INTEGER
| REAL
| ZONED [<unsigned_integer>]

<free_mask_date> ::=
<! Datumsangaben !>

<free_mask_time> ::=
<! Zeitangaben !>

<free_mask_timestamp> ::=
<! Zeitstempelangaben !>

<fwv_format_spec> ::=
<null_spec>
| <int_spec>
| <field_format_spec>

< Strukturlink identifier> ::=
<! SQL-Referenzhandbuch !>

<if_condition> ::=
IF <condition>

<import_column_spec> ::=
<map_field_column> [<null_condition>]
| <column_assignment>

<import_columns_command> ::=
IMPORT COLUMNS TABLE <table_name>
[<if_condition>]
[<duplicates_clause>]
<import_column_spec> ...
<data_instream_column_spec>

<import_command> ::=
<import_db_command>
| <import_user_command>
| <import_schema_command>
| <import_table_command>
| <import_columns_command>

<import_db_command> ::=
IMPORT DB
[<duplicates_clause>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

<import_lobcolumn_spec> ::=
LOB <instream_lob_spec>

<import_schema_command>
::=
IMPORT SCHEMA <schema_name>
[<duplicates_clause>]
[<map_schema_spec>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

<import_table_command> ::=
IMPORT TABLE <table_name>
[<if_condition>]
[<duplicates_clause>]
<catalog_data_instream_table_spec>
[<package_spec>]

<import_user_command> ::=
IMPORT USER
[<duplicates_clause>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

<instream_columnformat_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>'
[<column_dataformat_spec>] [<start_spec>]

<instream_csv_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>'
[CSV [<csv_format_spec> ...]] [<start_spec>]

<instream_ddl_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>' [DDL]

<instream_fwv_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>'
FWV [<fwv_format_spec> ...] [<start_spec>]

<instream_lob_spec> ::=
INSTREAM [FILE] <column_spec> <lob_code_spec>
| INSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>]

<instream_pages_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>' [PAGES]

<instream_records_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>' RECORDS [<records_format_spec>]

<instream_tableformat_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>' [<table_dataformat_spec>]

<int_spec> ::=
INTEGER HILO
| INTEGER LOHI

<isolation_level_spec> ::=
ISOLATION LEVEL <unsigned_integer>

< Strukturlink literal> ::=
<! SQL-Referenzhandbuch !>

<lob_code_spec> ::=
<code_spec>
| BINARY

<map_column_field> ::=
<column_name> <field_spec> <field_function> <null_assign>

<map_field_column> ::=
<column_name> <field_spec> <field_function>

<map_schema_spec> ::=
MAP SCHEMA [<schema_map_name> | <schema_to_schema>,...]

<mediumtype_spec> ::=
FILE
| PIPE
| TAPE [<ebid_spec>]

<noheader_spec> ::=
NOHEADER <unsigned_integer>

<null_assign> ::=
[IF] NULL SET '<literal>'

<null_condition> ::=
NULL [IF] <condition>
| DEFAULT NULL

<null_spec> ::=
NULL '<literal>'

<number_spec> ::=
DECIMAL '/[<digit_grouping_symbol>]/<decimal_symbol>/'

<numerical_functions> ::=
<scale_spec>
| <round_or_trunc_spec>
| <scale_spec> <round_or_trunc_spec>

<order_clause> ::=
ORDER BY <column_name>,...

<outstream_columnformat_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>'
[<column_dataformat_spec>] [<start_spec>]

<outstream_csv_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>'
[CSV [<csv_format_spec> ...]] [<start_spec>]

<outstream_ddl_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>' [DDL]

<outstream_fwv_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>'
FWV [<fwv_format_spec> ...] [<start_spec>]

<outstream_lob_spec> ::=
OUTSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>]

<outstream_pages_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>' [PAGES]

<outstream_records_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>' RECORDS [<records_format_spec>]

<outstream_tableformat_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>' [<table_dataformat_spec>]

<package_guid> ::=
<! Wiederaufsetzen !>

<package_spec> ::=
PACKAGE <outstream_csv_spec>

< Strukturlink password> ::=
<! SQL-Referenzhandbuch !>

<protocol_name> ::=
<! USE DB-Kommando !>

<records_format_spec> ::=
<field_format_spec> ...

<remark_command> ::=
REMARK "<literal>"

<restart_spec> ::=
RESTART <package_guid>

<round_or_trunc_spec> ::=
ROUND <unsigned_integer>
| TRUNC <unsigned_integer>

<scale_spec> ::=
SCALE <unsigned_integer>

<schema_name> ::=
<identifier>

<schema_map_name> ::=
<identifier>

<schema_to_schema> ::=
<schema_name> TO <schema_name>

<select_expression> ::=
<! <select_statement> ohne Angabe des Schlüsselwortes SELECT> !>

<separator> ::=
<character>

<separator_spec> ::=
SEPARATOR '<separator>'

<sequence_number> ::=
SEQNO
| SEQNO <integer>
| SEQNO <integer> <integer>

<set_column_spec> ::=
SET <load_column_spec>

<set_command> ::=
SET
| SET <bool_spec>
| SET <code_page_spec>
| SET <isolation_level_spec>
| SET <null_spec>
| SET <number_spec>
| SET BACKUPTOOL <backup_tool_spec>
| SET CODETYPE <standard_code_spec>
| SET CONFIGURATION <exclude_include>
| SET CSV '/<separator>/<delimiter>/'
| SET CURRENT_SCHEMA = <schema_name>
| SET DATE <standard_date_mask>
| SET FORMAT <standard_date_mask>
| SET MAXERRORCOUNT <unsigned_integer>
| SET TIME <standard_time_mask>
| SET TIMESTAMP <standard_timestamp_mask>
| SET TRANSACTION SIZE <unsigned_integer>

<simple_condition> ::=
POS <field_spec> <field_type> [HEX] <compare_operator> '<literal>'

<sql_mode> ::=
INTERNAL
| ANSI
| DB2
| ORACLE

<sql_mode_command> ::=
SQLMODE <sql_mode>

<standard_code_spec> ::=
ASCII
| UCS2
| UTF8

<standard_date_mask> ::=
EUR
| INTERNAL
| ISO
| JIS
| USA

<standard_time_mask> ::=
EUR
| INTERNAL
| ISO
| JIS
| USA

<standard_timestamp_mask> ::=
EUR
| INTERNAL
| ISO
| JIS
| USA

<start_spec> ::=
START <unsigned_integer> [MAXROWS]
| START <unsigned_integer> [MAXRECORDS]
| START <unsigned_integer> <unsigned_integer>

<stream_name> ::=
<! Datenstrom !>

<table_dataformat_spec> ::=
PAGES
| RECORDS <records_format_spec>

<table_name> ::=
[<schema_name>.]<identifier>

<time_spec> ::=
TIME <standard_time_mask>
| TIME '<free_mask_time>'

<timestamp_spec> ::=
TIMESTAMP <standard_timestamp_mask>
| TIMESTAMP '<free_mask_timestamp>'

<true_value> ::=
<! SET-Kommando !>

< Strukturlink unsigned_integer> ::=
<! SQL-Referenzhandbuch !>

<update_column_spec> ::=
<map_field_column>
| <column_assignment>

<update_columns_command> ::=
UPDATE COLUMNS TABLE <table_name>
[<if_condition>]
<update_column_spec> ... <set_column_spec> ...
<data_instream_column_spec>

<usage_spec> ::=
RECORDS USAGE
| PAGE WITH <unsigned_integer> % USAGE
| PAGE WITH <unsigned_integer> RECORDS USAGE

<use_database_command> ::=
USE DB <database_spec>

<use_schema_command> ::=
USE SCHEMA <schema_name>

<use_schema_map_command> ::=
USE SCHEMAMAP <schema_map_name>

<use_user_command> ::=
USE USER <user_spec> [SCHEMA <schema_name>] [DB <database_spec>] [<isolation_level_spec>]

<user_spec> ::=
<database_user> <password>


autocommit_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation autocommit_command

<autocommit_command> ::=
AUTOCOMMIT ON
| AUTOCOMMIT OFF


backup_tool_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation backup_tool_spec

<backup_tool_spec> ::=
BACKINT
| NETWORKER
| TSM


bool_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation bool_spec

<bool_spec> ::=
BOOLEAN '<true_value>/<false_value>'


catalog_data_instream_part_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation catalog_data_instream_part_spec

<catalog_data_instream_part_spec> ::=
<catalog_instream_spec>
| <data_instream_part_spec>
| <catalog_instream_spec> <data_instream_part_spec>


catalog_data_outstream_part_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation catalog_data_outstream_part_spec

<catalog_data_outstream_part_spec> ::=
<catalog_outstream_spec>
| <data_outstream_part_spec>
| <catalog_outstream_spec> <data_outstream_part_spec>


catalog_data_instream_table_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation catalog_data_instream_table_spec

<catalog_data_instream_table_spec> ::=
<catalog_instream_spec>
| <data_instream_table_spec>
| <catalog_instream_spec> <data_instream_table_spec>


catalog_data_outstream_table_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation catalog_data_outstream_table_spec

<catalog_data_outstream_table_spec> ::=
<catalog_outstream_spec>
| <data_outstream_table_spec>
| <catalog_outstream_spec> <data_outstream_table_spec>


catalog_instream_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation catalog_instream_spec

<catalog_instream_spec> ::=
CATALOG <instream_ddl_spec>


catalog_outstream_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation catalog_outstream_spec

<catalog_outstream_spec> ::=
CATALOG <outstream_ddl_spec>


code_page_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation code_page_spec

<code_page_spec> ::=
CODEPAGE [< Strukturlink literal>]


code_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation code_spec

<code_spec> ::=
<standard_code_spec>
| CODESET < Strukturlink literal>


column_assignment (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation column_assignment

<column_assignment> ::=
<column_name> '< Strukturlink literal>'
| <column_name> <column_function>


column_dataformat_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation column_dataformat_spec

<column_dataformat_spec> ::=
CSV <csv_format_spec> ...
| FWV [BINARY] <fwv_format_spec> ...
| FWV BINARY <fwv_format_spec> ... <noheader_spec>


column_function (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation column_function

<column_function> ::=
DATE
| FALSE
| STAMP
| TIME
| TIMESTAMP
| TRUE
| USER
| USERGROUP
| <sequence_number>


column_id (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation column_id

<column_id> ::=
< Strukturlink unsigned_integer>


column_name (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation column_name

<column_name> ::=
< Strukturlink identifier>


column_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation column_spec

<column_spec> ::=
<column_name>
| <column_id>


compare_operator (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation compare_operator

<compare_operator> ::=
<
| >
| =
| <=
| >=
| !=


condition (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation condition

<condition> ::=
(<condition>)
| <condition> AND <condition>
| <condition> OR <condition>
| NOT <condition>
| <simple_condition>


configuration_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation configuration_spec

<configuration_spec> ::=
CONFIGURATION <instream_csv_spec>


csv_format_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation csv_format_spec

<csv_format_spec> ::=
<separator_spec>
| <delimiter_spec>
| <null_spec>
| <field_format_spec>


data_instream_column_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation data_instream_column_spec

<data_instream_column_spec> ::=
DATA <instream_columnformat_spec> [<import_lobcolumn_spec> ...]


data_instream_columns_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation data_instream_columns_spec

<data_instream_columns_spec> ::=
DATA <instream_columnformat_spec>
[<import_column_spec> ... <import_lobcolumn_spec> ...] [<usage_spec>]


data_instream_part_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation data_instream_part_spec

<data_instream_part_spec> ::=
DATA <instream_tableformat_spec>


data_instream_table_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation data_instream_table_spec

<data_instream_table_spec> ::=
<data_instream_part_spec>
| <data_instream_columns_spec>


data_outstream_column_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation data_outstream_column_spec

<data_outstream_column_spec> ::=
DATA <outstream_columnformat_spec> [<export_lobcolumn_spec> ...]


data_outstream_part_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation data_outstream_part_spec

<data_outstream_part_spec> ::=
DATA <outstream_tableformat_spec>


data_outstream_table_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation data_outstream_table_spec

<data_outstream_table_spec> ::=
<data_outstream_part_spec>
| <data_oustream_column_spec>


database_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation database_spec

<database_spec> ::=
<database_name> [ON <database_computer> [ENCRYPTION <protocol_name>]]


date_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation date_spec

<date_spec> ::=
DATE <standard_date_mask>
| DATE '<free_mask_date>'


delimiter (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation delimiter

<delimiter> ::=
< Strukturlink character>


delimiter_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation delimiter_spec

<delimiter_spec> ::=
DELIMITER '<delimiter>'


duplicates_clause (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation duplicates_clause

<duplicates_clause> ::=
REJECT DUPLICATES
| IGNORE DUPLICATES
| UPDATE DUPLICATES


ebid_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation ebid_spec

<ebid_spec> ::=
EBID '< Strukturlink literal>'


exclude_include (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation exclude_include

<exclude_include> ::=
EXCLUDE
| INCLUDE


export_column_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation export_column_spec

<export_column_spec> ::=
<map_column_field>
| <field_assignment>


export_columns_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation export_columns_command

<export_columns_command> ::=
EXPORT COLUMNS <select_expression>
[MAP COLUMNS <export_column_spec> ...]
<data_outstream_column_spec>


export_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation export_command

<export_command> ::=
<export_db_command>
| <export_user_command>
| <export_schema_command>
| <export_table_command>
| <export_columns_command>


export_db_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation export_db_command

<export_db_command> ::=
EXPORT DB
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]


export_lobcolumn_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation export_lobcolumn_spec

<export_lobcolumn_spec> ::=
LOB <outstream_lob_spec>


export_schema_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation export_schema_command

<export_schema_command> ::=
EXPORT SCHEMA <schema_name>
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]


export_table_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation export_table_command

<export_table_command> ::=
EXPORT <table_name>
[<restore_spec>]
[<order_clause>]
<catalog_data_outstream_table_spec>
[<package_spec>]


export_user_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation export_user_command

<export_user_command> ::=
EXPORT USER
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]


field_assignment (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation field_assignment

<field_assignment> ::=
'< Strukturlink literal>' <field_spec>


field_format_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation field_format_spec

<field_format_spec> ::=
<bool_spec>
| <code_spec>
| <date_spec>
| <number_spec>
| <time_spec>
| <timestamp_spec>


field_function (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation field_function

<field_function> ::=
<field_type> [HEX]
| <numerical_functions>
| <field_type> [HEX] <numerical_functions>


field_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation field_spec

<field_spec> ::=
< Strukturlink unsigned_integer>
| <unsigned_integer> - <unsigned_integer>


field_type (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation field_type

<field_type> ::=
/* empty */
| CHAR
| DECIMAL [< Strukturlink unsigned_integer>]
| INTEGER
| REAL
| ZONED [<unsigned_integer>]


fwv_format_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation fwv_format_spec

<fwv_format_spec> ::=
<null_spec>
| <int_spec>
| <field_format_spec>


if_condition (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation if_condition

<if_condition> ::=
IF <condition>


import_column_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation import_column_spec

<import_column_spec> ::=
<map_field_column> [<null_condition>]
| <column_assignment>


import_columns_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation import_columns_command

<import_columns_command> ::=
IMPORT COLUMNS TABLE <table_name>
[<if_condition>]
[<duplicates_clause>]
<import_column_spec> ...
<data_instream_column_spec>


import_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation import_command

<import_command> ::=
<import_db_command>
| <import_user_command>
| <import_schema_command>
| <import_table_command>
| <import_columns_command>


import_db_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation import_db_command

<import_db_command> ::=
IMPORT DB
[<duplicates_clause>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]


import_lobcolumn_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation import_lobcolumn_spec

<import_lobcolumn_spec> ::=
LOB <instream_lob_spec>


import_schema_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation import_schema_command

<import_schema_command>
::=
IMPORT SCHEMA <schema_name>
[<duplicates_clause>]
[<map_schema_spec>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]


import_table_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation import_table_command

<import_table_command> ::=
IMPORT TABLE <table_name>
[<if_condition>]
[<duplicates_clause>]
<catalog_data_instream_table_spec>
[<package_spec>]


import_user_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation import_user_command

<import_user_command> ::=
IMPORT USER
[<duplicates_clause>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]


instream_columnformat_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation instream_columnformat_spec

<instream_columnformat_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>'
[<column_dataformat_spec>] [<start_spec>]


instream_csv_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation instream_csv_spec

<instream_csv_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>'
[CSV [<csv_format_spec> ...]] [<start_spec>]


instream_ddl_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation instream_ddl_spec

<instream_ddl_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>' [DDL]


instream_fwv_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation instream_fwv_spec

<instream_fwv_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>'
FWV [<fwv_format_spec> ...] [<start_spec>]


instream_lob_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation instream_lob_spec

<instream_lob_spec> ::=
INSTREAM [FILE] <column_spec> <lob_code_spec>
| INSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>]


instream_pages_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation instream_pages_spec

<instream_pages_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>' [PAGES]


instream_records_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation instream_records_spec

<instream_records_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>'
RECORDS [<records_format_spec>]


instream_tableformat_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation instream_tableformat_spec

<instream_tableformat_spec> ::=
INSTREAM [<mediumtype_spec>] '<stream_name>' [<table_dataformat_spec>]


int_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation int_spec

<int_spec> ::=
INTEGER HILO
| INTEGER LOHI


isolation_level_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation isolation_level_spec

<isolation_level_spec> ::=
ISOLATION LEVEL < Strukturlink unsigned_integer>


lob_code_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation lob_code_spec

<lob_code_spec> ::=
<code_spec>
| BINARY


map_column_field (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation map_column_field

<map_column_field> ::=
<column_spec> <field_spec> <field_function> <null_assign>


map_field_column (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation map_field_column

<map_field_column> ::=
<column_name> <field_spec> <field_function>


map_schema_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation map_schema_spec

<map_schema_spec> ::=
MAP SCHEMA [<schema_map_name> | <schema_to_schema>,...]


mediumtype_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation mediumtype_spec

<mediumtype_spec> ::=
FILE
| PIPE
| TAPE [<ebid_spec>]


noheader_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation noheader_spec

<noheader_spec> ::=
NOHEADER < Strukturlink unsigned_integer>


null_assign (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation null_assign

<null_assign> ::=
[IF] NULL SET '< Strukturlink literal>'


null_condition (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation null_condition

<null_condition> ::=
NULL [IF] <condition>
| DEFAULT NULL


null_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation null_spec

<null_spec> ::=
NULL '< Strukturlink literal>'


number_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation number_spec

<number_spec> ::=
DECIMAL '/[<digit_grouping_symbol>]/<decimal_symbol>/'


numerical_functions (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation numerical_functions

<numerical_functions> ::=
<scale_spec>
| <round_or_trunc_spec>
| <scale_spec> <round_or_trunc_spec>


order_clause (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation order_clause

<order_clause> ::=
ORDER BY <column_name>,...


outstream_columnformat_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation outstream_columnformat_spec

<outstream_columnformat_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>'
[<column_dataformat_spec>] [<start_spec>]


outstream_csv_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation outstream_csv_spec

<outstream_csv_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>'
[CSV [<csv_format_spec> ...]] [<start_spec>]


outstream_ddl_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation outstream_ddl_spec

<outstream_ddl_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>' [DDL]


outstream_fwv_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation outstream_fwv_spec

<outstream_fwv_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>'
FWV [<fwv_format_spec> ...] [<start_spec>]


outstream_lob_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation outstream_lob_spec

<outstream_lob_spec> ::=
OUTSTREAM [FILE] <column_spec> '<stream_name>' [<lob_code_spec>]


outstream_pages_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation outstream_pages_spec

<outstream_pages_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>' [PAGES]


outstream_records_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation outstream_records_spec

<outstream_records_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>' RECORDS [<records_format_spec>]


outstream_tableformat_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation outstream_tableformat_spec

<outstream_tableformat_spec> ::=
OUTSTREAM [<mediumtype_spec>] '<stream_name>' [<table_dataformat_spec>]


package_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation package_spec

<package_spec> ::=
PACKAGE <outstream_csv_spec>


records_format_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation records_format_spec

<records_format_spec> ::=
<field_format_spec> ...


remark_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation remark_command

<remark_command> ::=
REMARK "< Strukturlink literal>"


restart_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation restart_spec

<restart_spec> ::=
RESTART <package_guid>


restore_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation restore_spec

<restore_spec> ::=
FOR IMPORT TABLE


round_or_trunc_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation round_or_trunc_spec

<round_or_trunc_spec> ::=
ROUND < Strukturlink unsigned_integer>
| TRUNC <unsigned_integer>


scale_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation scale_spec

<scale_spec> ::=
SCALE < Strukturlink unsigned_integer>


schema_name (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation schema_name

<schema_name> ::=
< Strukturlink identifier>


schema_map_name (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation schema_map_name

<schema_map_name> ::=
< Strukturlink identifier>


schema_to_schema (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation schema_to_schema

<schema_to_schema> ::=
<schema_name> TO <schema_name>


select_expression (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation select_expression

<select_expression> ::=
<! <select_statement ohne Angabe des Schlüsselwortes SELECT> !>


separator (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation separator

<separator> ::=
< Strukturlink character>


separator_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation separator_spec

<separator_spec> ::=
SEPARATOR '<separator>'


sequence_number (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation sequence_number

<sequence_number> ::=
SEQNO
| SEQNO < Strukturlink integer>
| SEQNO <integer> <integer>


set_column_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation set_column_spec

<set_column_spec> ::=
SET <import_column_spec>


set_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation set_command

<set_command> ::=
SET
| SET <bool_spec>
| SET <code_page_spec>
| SET <isolation_level_spec>
| SET <null_spec>
| SET <number_spec>
| SET BACKUPTOOL <backup_tool_spec>
| SET CODETYPE <standard_code_spec>
| SET CONFIGURATION <exclude_include>
| SET CSV '/<separator>/<delimiter>/'
| SET CURRENT_SCHEMA = <schema_name>
| SET DATE <standard_date_mask>
| SET FORMAT <standard_date_mask>
| SET MAXERRORCOUNT < Strukturlink unsigned_integer>
| SET TIME <standard_time_mask>
| SET TIMESTAMP <standard_timestamp_mask>
| SET TRANSACTION SIZE <unsigned_integer>


simple_condition (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation simple_condition

<simple_condition> ::=
POS <field_spec> <field_type> [HEX] <compare_operator> '< Strukturlink literal>'


sql_mode (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation sql_mode

<sql_mode> ::=
INTERNAL
| ANSI
| DB2
| ORACLE


sql_mode_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation sql_mode_command

<sql_mode_command> ::=
SQLMODE <sql_mode>


standard_code_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation standard_code_spec

<standard_code_spec> ::=
ASCII
| UCS2
| UTF8


standard_date_mask (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation standard_date_mask

<standard_date_mask> ::=
 EUR
| INTERNAL
| ISO
| JIS
| USA


standard_time_mask (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation standard_time_mask

<standard_time_mask> ::=
 EUR
| INTERNAL
| ISO
| JIS
| USA


standard_timestamp_mask (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation standard_timestamp_mask

<standard_timestamp_mask> ::=
EUR
| INTERNAL
| ISO
| JIS
| USA


start_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation start_spec

<start_spec> ::=
START < Strukturlink unsigned_integer> [MAXROWS]
| START <unsigned_integer> [MAXRECORDS]
| START <unsigned_integer> <unsigned_integer>


table_dataformat_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation table_dataformat_spec

<table_dataformat_spec> ::=
PAGES
| RECORDS <records_format_spec>


table_name (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation table_name

<table_name> ::=
[<schema_name>.]< Strukturlink identifier>


time_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation time_spec

<time_spec> ::=
TIME <standard_time_mask>
| TIME '<free_mask_time>'


timestamp_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation timestamp_spec

<timestamp_spec> ::=
TIMESTAMP <standard_timestamp_mask>
| TIMESTAMP '<free_mask_timestamp>'


update_column_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation update_column_spec

<update_column_spec> ::=
<map_field_column>
| <column_assignment>


update_columns_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation update_columns_command

<update_columns_command> ::=
UPDATE COLUMNS TABLE <table_name>
[<if_condition>]
<update_column_spec> ... <set_column_spec> ...
<data_instream_column_spec>


usage_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation usage_spec

<usage_spec> ::=
RECORDS USAGE
| PAGE WITH < Strukturlink unsigned_integer> % USAGE
| PAGE WITH <unsigned_integer> RECORDS USAGE


use_database_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation use_database_command

<use_database_command> ::=
USE DB <database_spec>


use_schema_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation use_schema_command

<use_schema_command> ::=
USE SCHEMA <schema_name>


use_schema_map_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation use_schema_map_command

<use_schema_map_command> ::=
 USE SCHEMAMAP <schema_map_name>


use_user_command (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation use_user_command

<use_user_command>
::=
USE USER <user_spec>
[SCHEMA <schema_name>]
[DB <database_spec>]
[<isolation_level_spec>]


user_spec (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation user_spec

<user_spec> ::=
< Strukturlink database_user> < Strukturlink password>


Syntaxregeln: semantisch sortiert (SAP-Bibliothek - Werkzeuge)

Syntaxdokumentation Syntaxregeln: semantisch sortiert

Die für die Loader-Kommandos erforderlichen Syntaxregeln werden in der folgenden Übersicht semantisch sortiert aufgelistet.

Die Syntaxregeln können auch in alphabetischer Sortierung angezeigt werden: Syntaxregeln: alphabetisch sortiert. An dieser Stelle finden Sie auch die Beschreibung der verwendeten Syntaxnotation.

<set_command> ::= SET
| SET CSV '/<separator>/<delimiter>/'
| SET <null_spec>
| SET <bool_spec>
| SET <number_spec>
| SET FORMAT <standard_date_mask>
| SET DATE <standard_date_mask>
| SET TIME <standard_time_mask>
| SET TIMESTAMP <standard_timestamp_mask>
| SET CODETYPE <standard_code_spec>
| SET <code_page_spec>
| SET <isolation_level_spec>
| SET TRANSACTION SIZE <unsigned_integer>
| SET CURRENT_SCHEMA = <schema_name>
| SET MAXERRORCOUNT <unsigned_integer>
| SET CONFIGURATION <exclude_include>
| SET BACKUPTOOL <backup_tool_spec>

<separator_spec>
::= SEPARATOR '<separator>'
<separator>      ::= <character>
<delimiter_spec> ::= DELIMITER '<delimiter>'
<delimiter>      ::= <character>
<null_spec>      ::= NULL
'<literal>'
<bool_spec>      ::= BOOLEAN
'<true_value>/<false_value>'
<true_value>     ::= <!  SET-Kommando  !>
<false_value>    ::= <!  SET-Kommando  !>

<date_spec> ::= DATE <standard_date_mask> | DATE '<free_mask_date>'
<time_spec> ::= TIME <standard_time_mask> | TIME '<free_mask_time>'
<timestamp_spec> ::= TIMESTAMP <standard_timestamp_mask> | TIMESTAMP '<free_mask_timestamp>'
<standard_date_mask> ::= EUR | INTERNAL | ISO | JIS | USA
<standard_time_mask> ::= EUR | INTERNAL | ISO | JIS | USA
<standard_timestamp_mask> ::= EUR | INTERNAL | ISO | JIS | USA
<free_mask_date> ::= <! Datumsangaben !>
<free_mask_time> ::= <! Zeitangaben !>
<free_mask_timestamp> ::= <! Zeitstempelangaben !>

<number_spec> ::= DECIMAL '/[<digit_grouping_symbol>]/<decimal_symbol>/'
<digit_grouping_symbol> ::= <! SET-Kommando !>
<decimal_symbol> ::= <! SET-Kommando !>

<int_spec> ::= INTEGER HILO | INTEGER LOHI

<lob_code_spec> ::= <code_spec> | BINARY
<code_spec> ::= <standard_code_spec> | CODESET <literal>
<standard_code_spec> ::= ASCII | UCS2 | UTF8
<code_page_spec> ::= CODEPAGE [<literal>]

<exclude_include> ::= EXCLUDE | INCLUDE
<backup_tool_spec> ::= BACKINT | NETWORKER | TSM

<sql_mode_command> ::= SQLMODE <sql_mode>
<sql_mode> ::= INTERNAL | ANSI | DB2 | ORACLE
<isolation_level_spec> ::= ISOLATION LEVEL <unsigned_integer>
<autocommit_command> ::= AUTOCOMMIT ON | AUTOCOMMIT OFF

<remark_command> ::= REMARK "<literal>"

<use_database_command> ::= USE DB <database_spec>
<use_user_command> ::= USE USER <user_spec> [SCHEMA <schema_name>]
[DB <database_spec>] [<isolation_level_spec>]
<use_schema_command> ::= USE SCHEMA <schema_name>
<use_schema_map_command> ::= USE SCHEMAMAP <schema_map_name>
<database_spec> ::= <database_name> [ON <database_computer>
[ENCRYPTION <protocol_name>]]
<user_spec> ::= <database_user> <password>
<database_computer> ::= <! USE DB-Kommando !>
<database_name> ::= <! USE DB-Kommando !>
<protocol_name> ::= <! USE DB-Kommando !>
<database_user> ::= <! SQL-Referenzhandbuch !>
<password> ::= <! SQL-Referenzhandbuch !>

<schema_name> ::= <identifier>
<schema_map_name> ::= <identifier>
<table_name> ::= [<schema_name>.]<identifier>

<column_spec> ::= <column_name> | <column_id>
<column_name> ::= <identifier>
<column_id> ::= <unsigned_integer>
<column_function> ::= TRUE | FALSE | DATE | TIME | TIMESTAMP | STAMP
| USER | USERGROUP | <sequence_number>
<sequence_number> ::= SEQNO | SEQNO <integer> | SEQNO <integer> <integer>

<field_spec> ::= <unsigned_integer> | <unsigned_integer> - <unsigned_integer>
<field_type> ::= /* empty */ | CHAR | DECIMAL [<unsigned_integer>]
| INTEGER | REAL | ZONED [<unsigned_integer>]
<field_function> ::= <field_type> [HEX] | <numerical_functions>
| <field_type> [HEX] <numerical_functions>
<numerical_functions> ::= <scale_spec> | <round_or_trunc_spec>
| <scale_spec> <round_or_trunc_spec>
<round_or_trunc_spec> ::= ROUND <unsigned_integer> | TRUNC <unsigned_integer>
<scale_spec> ::= SCALE <unsigned_integer>

<map_column_field> ::= <column_name> <field_spec> <field_function> <null_assign>
<map_field_column> ::= <column_name> <field_spec> <field_function>
<map_schema_spec> ::= MAP SCHEMA [<schema_map_name> | <schema_to_schema>,...]
<schema_to_schema> ::= <schema_name> TO <schema_name>

<null_assign> ::= [IF] NULL SET '<literal>'
<null_condition> ::= NULL [IF] <condition> | DEFAULT NULL
<if_condition> ::= IF <condition>
<condition> ::= (<condition>) | <condition> AND <condition>
| <condition> OR <condition> | NOT <condition>
| <simple_condition>
<simple_condition> ::= POS <field_spec> <field_type> [HEX] <compare_operator> '<literal>'
<compare_operator> ::= < | > | = | <= | >= | !=

<export_command> ::= <export_db_command>
| <export_user_command>
| <export_schema_command>
| <export_table_command>
| <export_columns_command>

<import_command> ::= <import_db_command>
| <import_user_command>
| <import_schema_command>
| <import_table_command>
| <import_columns_command>

<export_db_command> ::= EXPORT DB
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

<import_db_command> ::= IMPORT DB
[<duplicates_clause>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

<export_user_command> ::= EXPORT USER
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

<import_user_command> ::= IMPORT USER
[<duplicates_clause>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

<export_schema_command> ::= EXPORT SCHEMA <schema_name>
[<configuration_spec>]
<catalog_data_outstream_part_spec>
[<package_spec>]
[<restart_spec>]

<import_schema_command>  ::=
IMPORT SCHEMA <schema_name>
[<duplicates_clause>]
[<map_schema_spec>]
[<configuration_spec>]
<catalog_data_instream_part_spec>
[<package_spec>]
[<restart_spec>]

<export_table_command> ::= EXPORT TABLE <table_name>
[<restore_spec>]
[<order_clause>]
<catalog_data_outstream_table_spec>
[<package_spec>]

<import_table_command> ::= IMPORT TABLE <table_name>
[<if_condition>]
[<duplicates_clause>]
<catalog_data_instream_table_spec>
[<package_spec>]

<export_columns_command> ::= EXPORT COLUMNS <select_expression>
[MAP COLUMNS <export_column_spec> ...]
<data_outstream_column_spec>
<select_expression> ::= <! <select_statement>
ohne Angabe des Schlüsselwortes SELECT> !>
<export_column_spec> ::= <map_column_field> | <field_assignment>
<field_assignment> ::= '<literal>' <field_spec>

<import_columns_command> ::= IMPORT COLUMNS TABLE <table_name>
[<if_condition>]
[<duplicates_clause>]
<import_column_spec> ...
<data_instream_column_spec>
<import_column_spec> ::= <map_field_column> [<null_condition>] | <column_assignment>
<column_assignment> ::= <column_name> '<literal>' | <column_name> <column_function>

<update_columns_command> ::= UPDATE COLUMNS TABLE <table_name>
[<if_condition>]
<update_column_spec> ... <set_column_spec> ...
<data_instream_column_spec>
<update_column_spec> ::= <map_field_column> | <column_assignment>
<set_column_spec> ::= SET <load_column_spec>

<order_clause> ::= ORDER BY <column_name>,...
<duplicates_clause> ::= REJECT DUPLICATES | IGNORE DUPLICATES
| UPDATE DUPLICATES
<start_spec> ::= START <unsigned_integer> [MAXROWS]
| START <unsigned_integer> [MAXRECORDS]
| START <unsigned_integer> <unsigned_integer>
<restart_spec> ::= RESTART <package_guid>
<package_guid> ::= <unsigned_integer>

<catalog_data_outstream_part_spec> ::= <catalog_outstream_spec>
| <data_outstream_part_spec>
| <catalog_outstream_spec> <data_outstream_part_spec>
<catalog_data_instream_part_spec> ::= <catalog_instream_spec>
| <data_instream_part_spec>
| <catalog_instream_spec> <data_instream_part_spec>
<catalog_data_outstream_table_spec> ::= <catalog_outstream_spec>
| <data_outstream_table_spec>
| <catalog_outstream_spec> <data_outstream_table_spec>
<catalog_data_instream_table_spec> ::= <catalog_instream_spec>
| <data_instream_table_spec>
| <catalog_instream_spec> <data_instream_table_spec>

<data_outstream_table_spec> ::= <data_outstream_part_spec>
| <data_outstream_column_spec>
<data_instream_table_spec> ::= <data_instream_part_spec>
| <data_instream_columns_spec>

<configuration_spec> ::= CONFIGURATION <instream_csv_spec>
<catalog_outstream_spec> ::= CATALOG <outstream_ddl_spec>
<catalog_instream_spec> ::= CATALOG <instream_ddl_spec>
<data_outstream_part_spec> ::= DATA <outstream_tableformat_spec>
<data_instream_part_spec> ::= DATA <instream_tableformat_spec>
<data_instream_columns_spec> ::= DATA <instream_columnformat_spec>
[<import_column_spec> ... <import_lobcolumn_spec> ...]
[<usage_spec>]
<data_outstream_column_spec> ::= DATA <outstream_columnformat_spec>
[<export_lobcolumn_spec> ...]

<data_instream_column_spec> ::= DATA <instream_columnformat_spec>
[<import_lobcolumn_spec> ...]
<export_lobcolumn_spec> ::= LOB <outstream_lob_spec>
<import_lobcolumn_spec> ::= LOB <instream_lob_spec>
<package_spec> ::= PACKAGE <outstream_csv_spec>

<outstream_ddl_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>' [DDL]
<instream_ddl_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>' [DDL]

<outstream_tableformat_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>'
[<table_dataformat_spec>]
<instream_tableformat_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>'
[<table_dataformat_spec>]

<outstream_columnformat_spec>
::= OUTSTREAM [<mediumtype_spec>] '<stream_name>'
[<column_dataformat_spec>]
[<start_spec>]
<instream_columnformat_spec>  ::= INSTREAM
[<mediumtype_spec>] '<stream_name>'
[<column_dataformat_spec>]
[<start_spec>]

<outstream_csv_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>'
[CSV [<csv_format_spec> ...]] [<start_spec>]
<instream_csv_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>'
[CSV [<csv_format_spec> ...]] [<start_spec>]

<outstream_fwv_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>'
FWV [<fwv_format_spec> ...] [<start_spec>]
<instream_fwv_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>'
FWV [<fwv_format_spec> ...] [<start_spec>]

<outstream_lob_spec> ::= OUTSTREAM [FILE] <column_spec> '<stream_name>'
[<lob_code_spec>]
<instream_lob_spec> ::= INSTREAM [FILE] <column_spec> <lob_code_spec>
| INSTREAM [FILE] <column_spec> '<stream_name>'
[<lob_code_spec>]

<outstream_records_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>'
RECORDS [<records_format_spec>]
<instream_records_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>'
RECORDS [<records_format_spec>]

<outstream_pages_spec> ::= OUTSTREAM [<mediumtype_spec>] '<stream_name>'
[PAGES]
<instream_pages_spec> ::= INSTREAM [<mediumtype_spec>] '<stream_name>'
[PAGES]

<mediumtype_spec> ::= FILE | PIPE | TAPE [<ebid_spec>]
<ebid_spec> ::= EBID '<literal>'

<stream_name> ::= <! Datenstrom !>

<usage_spec> ::= RECORDS USAGE
| PAGE WITH <unsigned_integer> % USAGE
| PAGE WITH <unsigned_integer> RECORDS USAGE

<table_dataformat_spec> ::= PAGES | RECORDS <records_format_spec>
<column_dataformat_spec> ::= CSV <csv_format_spec> ...
| FWV [BINARY] <fwv_format_spec> ...
| FWV BINARY <fwv_format_spec> ... <noheader_spec>

<csv_format_spec> ::= <separator_spec> | <delimiter_spec>
| <null_spec> | <field_format_spec>
<fwv_format_spec> ::= <null_spec> | <int_spec> | <field_format_spec>
<records_format_spec> ::= <field_format_spec> ...
<field_format_spec> ::= <bool_spec> | <code_spec> | <date_spec>
| <number_spec> | <time_spec> | <timestamp_spec>

<noheader_spec> ::= NOHEADER <unsigned_integer>

<character> ::= <! SQL-Referenzhandbuch !>
<identifier> ::= <! SQL-Referenzhandbuch !>
<literal> ::= <! SQL-Referenzhandbuch !>
<unsigned_integer> ::= <! SQL-Referenzhandbuch !>


Begriffe: Übersicht (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Begriffe: Übersicht

Definition

Die folgende Begriffsübersicht soll dazu dienen, schnell die im Loader verwendeten Begriffe nachschlagen zu können.

Aufruf des Loader

AUTOCOMMIT

Betriebsmodus

Binärwert

COMPRESSED

CSV

Daten

Datenbankinterner Datentyp

Datenformat

Datenstrom

Datenträgertyp

Datentyp

DDL

EXPORT

EXPORT COLUMNS

EXPORT DB

EXPORT SCHEMA

EXPORT TABLE

EXPORT USER

Externer Datentyp

FORMATTED

FORMATTED BINARY

FWV

FWV BINARY

HEX-Wert

IMPORT

IMPORT COLUMNS

IMPORT DB

IMPORT SCHEMA

IMPORT TABLE

IMPORT USER

INSTREAM

Klartextwert

Kommandodatei

Kommandodateimodus

Kommandos

Kommandotrenner

Loader CLI

LONG-Werte (Exportieren und Importieren)

Metadaten

NULL-Wert

Optionen

OUTSTREAM

PACKAGE

PAGES

Protokolldatei

RECORDS

REMARK

Selektieren von Datensätzen

SET

Sitzungsmodus

SQL-Anweisung

SQLMODE

Systemtabelle

Transformation

Transportieren

Transportmodus

UPDATE COLUMNS

USE DB

USE SCHEMA

USE SCHEMAMAP

USE USER

Siehe auch:

Schlüsselwörter: Übersicht

Syntaxregeln: alphabetisch sortiert

Syntaxregeln: semantisch sortiert


Schlüsselwörter: Übersicht (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Schlüsselwörter: Übersicht

Schlüsselwörter sind Bestandteile der Loader-Kommandos. Sie legen die Funktionalität des Kommandos durch die entsprechenden Schlüsselwörter fest, die durch Argumente und Optionen ergänzt werden.

Der Loader kennt die nachfolgend aufgeführten Schlüsselwörter. Sie haben in einigen Fällen die Möglichkeit, auch die angegebenen alternativen Schlüsselwörter zu verwenden.

Schlüsselwörter | Alternative Schlüsselwörter
AND |
ANSI |
APPEND |
ASCII |
AUTOCOMMIT |
BINARY |
BOOLEAN |
BY |
CATALOG |
CHAR |
CODESET |
CODETYPE |
COLUMNS |
CONFIGURATION |
COUNT |
CSV | COMPRESSED
CURRENT |
DATA |
DATE |
DB |
DB2 |
DDL |
DEC |
DECIMAL |
DEFAULT |
DELIMITER |
DUPLICATES |
EBCDIC |
EUR |
EXPORT |
FILE |
FOR |
FWV | FORMATTED
FWV BINARY | FORMATTED BINARY
HEX |
HILO |
IF |
IGNORE |
IMPORT |
INSTALLTION |
INSTREAM |
INSTREAM FILE | INFILE
INTERNAL |
INTEGER |
ISO |
ISOLATION |
JIS |
KEY |
LANGUAGE |
LOB INSTREAM FILE | LONGFILE
LOB OUTSTREAM FILE | LONGFILE
LOHI |
MAP COLUMNS | OUTFIELDS
MAP SCHEMA |
MAXRECORDS |
MAROWS |
MESSAGE |
NOT |
NULL |
NUMBER |
OFF |
ON |
OR |
ORACLE |
ORDER |
OTHERWISE |
OUTSTREAM |
OUTSTREAM FILE | OUTFILE
PACKAGE |
PAGE |
PAGES |
PIPE |
POS |
REAL |
RECORDS |
REJECT |
RELEASE |
RESTART |
ROUND |
ROW |
ROWS |
SCALE |
SCHEMA |
SEPARATOR |
SEQNO |
SERVERDB |
SET |
SQLMODE |
STAMP |
START |
SQLID |
SYSDATE |
SYSTEM |
TABLE |
TAPE |
TIME |
TIMESTAMP |
TO |
TRUNC |
UID |
UPDATE |
USA |
USAGE |
USE |
USER |
USERKEY |
USERGROUP |
VERSION |
WITH |
ZONED |

Siehe auch:

Begriffe: Übersicht

Aufrufen des Loader

Syntaxregeln: alphabetisch sortiert

Syntaxregeln: semantisch sortiert

SQL-Referenzhandbuch, Strukturlink Schlüsselwort (key_word)


SQL Studio (GUI) (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation SQL Studio (GUI)

Einsatzmöglichkeiten

Das Strukturlink Datenbankwerkzeug SQL Studio dient dazu, mit Hilfe von SQL-Anweisungen auf die Daten von Datenbankinstanzen zuzugreifen.

Das SQL Studio hat eine grafische Benutzeroberfläche und kann nur unter Microsoft Windows eingesetzt werden. Sie können mit dem SQL Studio aber auch auf Datenbankinstanzen zugreifen, die auf einem entfernten Computer mit einem anderen Betriebssystem laufen.

Einführungshinweise

Das SQL Studio ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems, zur SQL-Syntax im Strukturlink SQL-Tutorial und im Strukturlink SQL-Referenzhandbuch. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

Das SQL Studio bietet unter anderem die folgenden Funktionen:

● Anlegen und Verwalten von Datenbanktabellen, Indizes und Zahlenreihen sowie Verwalten von gespeicherten SQL-Anweisungen, Datenbankbenutzern und Datenbankprozeduren mit dem Catalog Manager

● Erstellen und Ausführen von SQL-Anweisungen im SQL-Dialog

● Auswählen und Bearbeiten von Datensätzen in einer Maskendarstellung mit dem Form-Dialog

● Formulieren von Datenbankanfragen mit Hilfe visueller Unterstützung im Visual-Query-Dialog

Die Datenbankwerkzeuge SQLCLI und Web SQL Studio haben einen ähnlichen Funktionsumfang wie das SQL Studio, bieten aber eine andere Benutzeroberfläche.


Starten von SQL Studio (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Starten von SQL Studio

Vorgehensweise

Um SQL Studio zu starten, wählen Sie Start ® Programs ® MaxDB ® SQL Studio.

Starten von der Kommandozeile

Sie können SQL Studio auch von der Kommandozeile aus starten. In diesem Fall können Sie Optionen angeben.

...

1. Wechseln Sie in das Verzeichnis, in dem sich das Programm sqlsto.exe befindet.

2. Geben Sie folgenden Befehl ein:

sqlsto [<options>]

Folgende Optionen stehen zur Verfügung:

-? | Anzeige aller Kommandozeilenoptionen
-version | Anzeige von Informationen zur Softwareversion
-n <database_computer> | Name des Datenbankrechners
-d <database_name> | Name der Datenbankinstanz
-u <database_user>[,<database_user_password>] | Name und Kennwort des Datenbankbenutzers Siehe Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter
-c <sql_mode> | Strukturlink SQL-Modus Mögliche Werte: INTERNAL | ORACLE | ANSI | DB2 Wenn Sie sich mit SQL Studio an eine Datenbankinstanz der Version 7.6 oder höher anmelden, dann können Sie nur noch den SQL-Modus INTERNAL oder ORACLE wählen. Die SQL-Modi DB2 und ANSI werden nicht mehr unterstützt. Nach dem Starten von SQL Studio können Sie den SQL-Modus auch in den Benutzereinstellungen ändern.
-t <trace_file> | Aktivieren des ODBC-Trace (siehe ODBC-Handbuch, Strukturlink Eigenschaften von Datenquellen)

Siehe auch:

Eröffnen einer Datenbanksitzung


Eröffnen einer Datenbanksitzung (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Eröffnen einer Datenbanksitzung

Verwendung

Um SQL-Anweisungen in einer Datenbankinstanz ausführen zu können, müssen Sie eine Datenbanksitzung eröffnen.

Vorgehensweise

...

1. Wenn Sie möchten, dass es für die zu eröffnende Datenbanksitzung keinen Timeout gibt, dann wählen Sie No Timeout.

2. Wählen Sie Session ® Connect.

3. Geben Sie den Namen des Datenbankrechners und der Datenbankinstanz an.

4. Geben Sie Namen und Kennwort des Datenbankbenutzers an

Das Datenbanksystem wandelt alle Buchstaben in Großbuchstaben um. Um Groß- und Kleinbuchstaben oder Sonderzeichen zu verwenden, schließen Sie den Benutzernamen/das Kennwort in Anführungszeichen ein.

Siehe Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter

5. Wählen Sie OK.

Ergebnis

Das Datenbanksystem eröffnet eine Datenbanksitzung.

Um eine weitere Datenbanksitzung in einem neuen Fenster zu eröffnen, wählen Sie Session ® New SQL Studio.

Siehe auch:

Liste der zuletzt geöffneten Sitzungen

Beenden der Datenbanksitzung


Liste der zuletzt geöffneten Sitzungen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Liste der zuletzt geöffneten Sitzungen

Verwendung

Die Liste der zuletzt geöffneten Sitzungen zeigt die zuletzt geöffneten Datenbanksitzungen an. Die Liste kann bis zu 10 Einträge haben.

Aktivitäten

● Sie können Benutzername und Kennwort für Datenbanksitzungen speichern, siehe Benutzereinstellung.

● Um die Liste der zuletzt geöffneten Sitzungen zu löschen, wählen Sie Session ® Clear Recent Sessions.

Diese Funktion steht nur zur Verfügung, solange Sie in SQL Studio keine Datenbanksitzung eröffnet haben.


Bildschirmbereiche von SQL Studio (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Bildschirmbereiche von SQL Studio

Der Bildschirm von SQL Studio gliedert sich in fünf Bereiche. Sie können die Größe der einzelnen Bildschirmbereiche ändern.

Diese Grafik wird im zugehörigen Text erklärt

Inhalt der Bildschirmbereiche

Nr. | Name des Bereichs | Beschreibung
1 | Menüzeile | Kommandos für die aktuelle Datenbanksitzung
2 | Symbolleiste | Symbole für die wichtigsten Kommandos
3 | Catalog Manager | verfügbare Datenbankobjekte
4 | Arbeitsbereich | Der Arbeitsbereich kann folgende Fenster enthalten: · SQL-Dialog · Form-Dialog · Visual-Query-Dialog · Ergebnistabellen
5 | Statusfenster | Informationen und Fehlermeldungen


Benutzereinstellungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Benutzereinstellungen

Verwendung

Sie können in SQL Studio während des laufenden Betriebs Ihre persönlichen Einstellungen vornehmen. Beim Beenden des SQL Studio werden diese Einstellungen gesichert.

Vorgehensweise

Um Ihre Einstellungen zu ändern, wählen Sie Session ® Settings.

Sie können folgende Einstellungen vornehmen:

General

Store Password | Das System speichert das Kennwort, das Sie beim Anmelden benutzt haben, für die nächste Anmeldung.
Confirmation for saving SQL Studio Objects | Das System fragt beim Schließen des Dialogfensters, ob das neu erstellte SQL-Studio-Objekt gesichert werden soll.
Open Form Dialog read only | Form-Dialoge werden zunächst im Nur-Lese-Modus geöffnet.
Remove failed connection attempts from Recent Sessions list | Das System löscht fehlgeschlagene Anmeldungsversuche aus der Liste der zuletzt geöffneten Sitzungen.
Identifiers in Create Dialogs uppercase | Beim Erstellen neuer SQL-Studio-Objekte wandelt das System die Eingaben automatisch in Großbuchstaben um.

Result Window

Limit for long columns (Bytes) | Maximale Anzahl der Bytes, die für eine LONG-Spalte aus der Datenbank geladen werden sollen.
Limit for binary zoom (Bytes) | Maximale Anzahl der Bytes, die beim Zoomen in der LONG-Spalte einer Ergebnistabelle angezeigt werden sollen.
Representation of null value | Darstellung des NULL-Werts
Clipped result view (Internal Mode) | Abschnittsweise Anzeige der Ergebnisse
Replace non chars in long columns | ASCII-Codes < 32 werden bei der Anzeige von LONG-Spalten durch ein Leerzeichen ersetzt.
Copy columns tab separated to Clipboard | Beim Zwischenspeichern von Ergebnissen trennt das System die Spalten durch Tabulatoren.
Copy Result with Column Header | Beim Kopieren von Ergebnissen kopiert das System auch die Spaltennamen.
Append Exported Data to File | Beim Exportieren einer Ergebnistabelle in eine Datei werden die Inhalte dieser Ergebnistabelle an den bestehenden Dateiinhalt angehängt.
Display Char Byte Column as Hex Values | Daten vom Datentyp Strukturlink CHAR BYTE werden als Hexadezimalzahlen dargestellt. Wenn Sie diese Option nicht wählen, dann werden diese Daten binär dargestellt.

Catalog Manager

Selected table types | Angabe, welche Tabellentypen im Catalog Manager angezeigt werden
Path for local folder | Pfadangabe für das Speichern der SQL-Studio-Objekte im Local Folder
Restore catalog state | Bei Neuanmeldung an der Datenbank wird die letzte Ansicht des Catalog Managers wiederhergestellt.
Convert input for catalog filter to uppercase | Eingaben im Filter des Catalog Managers wandelt das System automatisch in Großbuchstaben um

Query Dialog

Isolation Level

Isolation-Level für die Erstellung von SQL-Anweisungen

SQL Mode

SQL-Modus für die Erstellung von SQL-Anweisungen im SQL-Dialog. Für den Form-Dialog und den Visual-Query-Dialog gilt immer der SQL-Modus INTERNAL.

Wenn Sie sich mit SQL Studio an eine Datenbankinstanz der Version 7.6 oder höher anmelden, dann können Sie nur noch den SQL-Modus INTERNAL oder ORACLE wählen. Die SQL-Modi DB2 und ANSI werden nicht mehr unterstützt.

Execute Statements Asynchronously

SQL-Anweisungen werden asynchron ausgeführt. Sie können einen Zeitraum (in Millisekunden) angeben, über den SQL Studio während der Ausführung der SQL-Anweisungen inaktiv sein soll.

AutoCommit Mode

Vorschlagswert für den Autocommit-Modus

Fonts

SQL Studio Font | Schriftart und -größe für alle Textfelder, Beschriftungen und Baumansichten
SQL Dialog Font | Schriftart und -größe für den SQL-Dialog
Result Window Font | Schriftart und -größe für die Ergebnisansicht
Status Window Font | Schriftart und -größe für das Statusfenster

Siehe auch Unicode-Unterstützung.

Wenn Sie die Benutzereigenschaft EXCLUSIVE haben, können Sie die Standardeinstellungen für den Isolation-Level und den SQL-Modus nicht ändern. SQL Studio arbeitet in diesem Fall automatisch mit dem Isolation-Level COMMITTED und im SQL-Modus INTERNAL.

Eine Erläuterung zu Benutzereigenschaften finden Sie im SQL-Referenzhandbuch unter Strukturlink Autorisierung .


Unicode-Unterstützung (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Unicode-Unterstützung

Verwendung

SQL Studio unterstützt Unicode nur eingeschränkt.

Voraussetzungen

Sie haben in der Systemsteuerung Ihres Betriebssystems in den regionalen Einstellungen die gewünschte Sprache für Nicht-Unicode-Programme konfiguriert und alle benötigten Codepage-Konvertierungstabellen ausgewählt.

Vorgehensweise

Konfigurieren Sie in den Benutzereinstellungen unter Fonts die gewünschte Schriftart.


Catalog Manager (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Catalog Manager

Der Catalog Manager befindet sich im linken Bereich des SQL-Studio-Fensters. Er zeigt Ihnen alle Verzeichnisse und Datenbankobjekte an, auf die Sie mindestens lesend Zugriff haben:

SQL-Studio-Objekte | Gespeicherte SQL-Anweisungen und Entwürfe von Datenbanktabellen
Tabellen | Datenbank- und Systemtabellen, Viewtabellen und Synonyme nach Besitzern geordnet
Indizes | Indizes, die für Tabellen angelegt wurden, nach Tabellen und deren Besitzern geordnet
Zahlenreihen | generierte Zahlenreihen, nach Eigentümern geordnet
Benutzer | alle Benutzer, für die der an der Datenbank angemeldete Benutzer die Eigentümerrechte besitzt
Datenbankprozeduren | Datenbankprozeduren, die der Benutzer in der Datenbank angelegt hat
Trigger | Trigger, die der Benutzer in der Datenbank angelegt hat

Wenn der Catalog Manager Ihnen nur bestimmte Objekte anzeigen soll, dann geben Sie einen Filter für die Objektnamen an. Geben Sie die Anfangsbuchstaben ein, nach denen Sie filtern wollen, und wählen Sie Catalog Manager ® Refresh. Der Filter bezieht sich jedoch nicht auf Ihre gespeicherten SQL-Anweisungen und Entwürfe.

Mit View ® Catalog Manager können Sie den Catalog Manager anzeigen oder ausblenden.


SQL-Studio-Objekte (SAP-Bibliothek - Werkzeuge)

Objektdokumentation SQL-Studio-Objekte

Sie können SQL-Anweisungen und Entwürfe von Datenbanktabellen als SQL-Studio-Objekte in der Datenbank oder lokal im Unterverzeichnis Local Folder speichern. Dadurch können Sie die Objekte später wieder verwenden.

Anlegen von SQL-Studio-Objekten

· Um mit dem Catalog Manager einen neuen Ordner für SQL-Studio-Objekte in der Datenbank anzulegen, wählen Sie Catalog Manager ® New ® Folder.

· Um SQL-Anweisungen zu erstellen und als SQL-Studio-Objekte zu speichern, verwenden Sie den SQL-Dialog, den Form-Dialog oder den Visual-Query-Dialog.

· Um Entwürfe von Datenbanktabellen als SQL-Studio-Objekte zu speichern, erstellen Sie die Tabellendefinition mit dem Catalog Manager.

Den Pfad für den Local Folder können Sie in den Benutzereinstellungen angeben.

Bearbeiten und Ausführen von SQL-Studio-Objekten

· Um ein gespeichertes SQL-Studio-Objekt zu bearbeiten, markieren Sie das Objekt und wählen Sie Catalog Manager ® Open Object Definition.

· Um ein gespeichertes SQL-Studio-Objekt in Dialogen oder einer Tabellendefinition zu verwenden, markieren Sie das Objekt. Wählen Sie Catalog Manager ® Send Object To und dann die gewünschte Dialogart.

· Um die SQL-Anweisungen eines gespeicherten SQL-Studio-Objekts direkt auszuführen, markieren Sie das Objekt und wählen Sie Catalog Manager ® Execute. Die Ergebnistabelle erscheint in einem weiteren Fenster. Falls ein Fehler aufgetreten ist, sehen Sie eine Fehlermeldung im Statusfenster des SQL Studio. Dort werden Ihnen je nach Ihren Einstellungen auch weitere Informationen wie z.B. die Ausführungsdauer Ihrer SQL-Anweisungen angezeigt.

Umbenennen und Löschen von SQL-Studio-Objekten

· Um ein gespeichertes SQL-Studio-Objekt umzubenennen, markieren Sie das Objekt und wählen Sie Catalog Manager ® Rename Object.

· Um ein gespeichertes SQL-Studio-Objekt zu löschen, markieren Sie das Objekt und wählen Sie Catalog Manager ® Drop Object.


Exportieren der Definition eines Datenbankobjekts (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Exportieren der Definition eines Datenbankobjekts

Verwendung

Sie exportieren die Definition eines Datenbankobjekts, z. B. die Definition einer Tabelle oder eines Index.

Vorgehensweise

...

1. Markieren Sie im Catalog Manager das Datenbankobjekt, dessen Definition Sie exportieren möchten.

2. Wählen Sie Catalog Manager ® Open Object Definition.

3. Wählen Sie Table Definition ® Export to SQL Dialog.

4. Wählen Sie im Kontextmenü des SQL-Dialogs Export File und geben Sie Name und Pfad der Datei an, in die die Definition exportiert werden soll.

Ergebnis

Die Definition des Datenbankobjekts wird in Form einer SQL-Anweisung exportiert.

Beispiel

Exportieren der Definition für die Tabelle CUSTOMER als Benutzer MONA liefert folgende SQL-Anweisung:

CREATE TABLE "MONA"."CUSTOMER"

(

"CNO" Fixed (4,0) NOT NULL,

"TITLE" Char (7) ASCII,

"FIRSTNAME" Char (10) ASCII,

"NAME" Char (10) ASCII NOT NULL,

"ZIP" Char (5) ASCII,

"ADDRESS" Char (25) ASCII NOT NULL,

PRIMARY KEY ("CNO"),

CONSTRAINT "CNO_CONS" CHECK "CNO " > 0,

CONSTRAINT "TITLE_CONS" CHECK "TITLE " IN ('Mr', 'Mrs', 'Company'),

CONSTRAINT "ZIP_CONS" CHECK "SUBSTR(ZIP,1,1)" BETWEEN '0' AND '9' AND

"SUBSTR(ZIP,2,1)" BETWEEN '0' AND '9' AND

"SUBSTR(ZIP,3,1)" BETWEEN '0' AND '9' AND

"SUBSTR(ZIP,4,1)" BETWEEN '0' AND '9' AND

"SUBSTR(ZIP,5,1)" BETWEEN '0' AND '9',

FOREIGN KEY "CUSTOMER_ZIP_IN_CITY" ("ZIP") REFERENCES "MONA"."CITY" ("ZIP") ON DELETE RESTRICT

)


Tabellen (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Tabellen

Der Catalog Manager zeigt Ihnen unter Tables entsprechend Ihren Benutzereinstellungen die Datenbanktabellen, Viewtabellen und Synonyme an, auf die Sie Zugriff haben. Die Einträge sind nach Besitzern geordnet.

Datenbanktabellen können Sie neu anlegen und bearbeiten. Viewtabellen und Synonyme können Sie anlegen, umbenennen oder löschen.

· Anlegen einer Datenbanktabelle

· Anlegen einer Viewtabelle

· Anlegen eines Synonyms

· Anzeigen der Definition einer Tabelle

· Ändern der Definition einer Datenbanktabelle

· Anzeigen des Inhalts einer Tabelle

· Verwenden einer Tabellen in Dialogen oder Definitionen

· Umbenennen einer Tabelle

· Löschen aller Zeilen einer Tabelle

· Löschen einer Tabelle


Anlegen einer Datenbanktabelle (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen einer Datenbanktabelle

Verwendung

Mit SQL Studio können Sie neue Datenbanktabellen in der Datenbank anlegen, an der Sie angemeldet sind. Sie können dabei bestehende Datenbanktabellen oder gespeicherte SQL-Studio-Objekte als Vorlage für die neue Datenbanktabelle nutzen.

Voraussetzung

Sie besitzen die erforderlichen Benutzerberechtigungen und haben die Benutzereigenschaft NOT EXCLUSIVE.

Eine Erläuterung zu Benutzerberechtigungen und Benutzereigenschaften finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer und im SQL-Referenzhandbuch unter Strukturlink Autorisierung .

Vorgehensweise

...

1. Wählen Sie Catalog Manager ® New ® Table Definition.
Ein Fenster für die Tabellendefinition öffnet sich.

2. Um eine bestehende Datenbanktabelle oder ein gespeichertes SQL-Studio-Objekt als Vorlage für Ihre neue Datenbanktabelle zu nutzen, wählen Sie Table Definition ® Get Table. Wählen Sie die gewünschte Tabelle oder das SQL-Studio-Objekt, und bestätigen Sie mit OK.

3. Geben Sie einen Tabellennamen ein.

4. Führen Sie folgende Schritte durch:

· Definieren von Spalten (Columns)

· Definieren von Einschränkungen für Spalten (Constraints)

· Definieren von Fremdschlüsselbeziehungen (Foreign Keys)

· Definieren von zusätzlichen Angaben (Misc)

5. Um Ihren Tabellenentwurf später wieder zu verwenden oder weiter zu bearbeiten, sichern Sie ihn mit Table Definition ® Save As als SQL-Studio-Objekt.

6. Wählen Sie Table Definition ® Create Table. Das System legt die neue Tabelle in der Datenbank an.

7. Mit Table Definition ® Export to SQL Dialog können Sie die entsprechende SQL-Anweisung zum Anlegen der Datenbanktabelle in den SQL-Dialog exportieren.

Informationen zur Syntax von CREATE TABLE-Anweisungen finden Sie im SQL-Referenzhandbuch unter Strukturlink CREATE TABLE-Anweisung.


Definieren von Spalten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Definieren von Spalten

Verwendung

Sie wollen beim Anlegen einer Datenbanktabelle oder beim Ändern einer Tabellendefinition eine Tabellenspalte (Column) definieren.

Vorgehensweise

1. Geben Sie unter Name einen Namen für die Spalte ein, und bestätigen Sie mit Enter.

2. Wählen Sie unter Datatype den gewünschten Datentyp.

3. In Abhängigkeit vom Datentyp können Sie folgende weiteren Eigenschaften angeben:

· Dimension (Dim)

· Code-Typ (Code)

· Spalte ist Schlüsselspalte

· Spaltenwerte dürfen keine NULL-Werte sein (Not NULL)

· Vorschlagswert für Spaltenwerte (Default)

· Eindeutigkeit der Spaltenwerte (Unique)

· Kommentar (Comment)

1. Um eine neue Spalte hinzuzufügen, wählen Sie New Column. Die neue Spalte wird am Ende der Tabelle eingefügt.

2. Um neue Spalten hinzuzufügen und dabei die Definitionen bestehender Spalten aus derselben Tabelle zu übernehmen, markieren Sie die gewünschten Spalten, und wählen Sie Clone Column. Die neuen Spalten werden am Ende der Tabelle eingefügt.

3. Um neue Spalten hinzuzufügen und dabei die Definitionen bestehender Spalten aus bestehenden Tabellen zu übernehmen, wählen Sie Import Column. Ein Fenster mit allen vom aktuellen Benutzer definierten Spalten öffnet sich. Markieren Sie eine oder mehrere Spalten, und wählen Sie OK. Die neuen Spalten werden am Ende der Tabelle eingefügt.

4. Um eine Spalte aus der Tabelle zu löschen, markieren Sie die Spalte, und wählen Sie Remove Column.

Sie können die Reihenfolge der Spalten ändern, indem Sie eine oder mehrere Spalten markieren und Sie mit den Pfeilen Ý ß nach unten oder oben verschieben.


Definieren von Einschränkungen für Spalten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Definieren von Einschränkungen für Spalten

Verwendung

Sie möchten beim Anlegen einer Datenbanktabelle oder beim Ändern einer Tabellendefinition Einschränkungen (Constraints) für Tabellenspalten angeben. Eine Einschränkung für die Werte einer Spalte setzt sich aus einer oder mehreren Bedingungen zusammen, die Sie zeilenweise formulieren und miteinander verknüpfen können.

Voraussetzung

Sie haben zuvor die Tabellenspalten definiert.

Die Formulierung von Einschränkungen ist nur für Spalten mit gültigen Spaltendefinitionen möglich.

Vorgehensweise

1. Geben Sie unter Name, falls gewünscht, einen Namen für die Einschränkung an.

2. Wählen Sie unter Column die Spalte, für die Sie eine Bedingung formulieren möchten.

3. Wählen Sie unter Predicate ein Prädikat für die Bedingung. Um die Bedingung zu negieren, benutzen Sie den NOT-Operator !. Bei Vergleichsoperatoren ist das Negieren nicht möglich.

4. Geben Sie unter Expression den Vergleichsausdruck für die Bedingung an, und bestätigen Sie mit Enter.
Sie können beim Angeben des Vergleichsausdrucks aus folgenden Optionen wählen:

Option | Bedeutung
Single Value | Der Ausdruck besteht aus einem einzelnen Wert.
ALL | Die Bedingung muss mit allen Ausdrücken der Liste (Expression List) erfüllt sein.
ANY | Die Bedingung muss mit mindestens einem Ausdruck der Liste (Expression List) erfüllt sein.
DEFAULT | Der Ausdruck besteht aus dem Vorschlagswert der Spalte.

5. Geben Sie an, wie die formulierte Bedingung mit der nächsten Bedingung verknüpft werden soll (AND/OR).

Wenn Sie die Art der Verknüpfung nachträglich auf <none> zurücksetzen, dann werden alle nachfolgend formulierten Bedingungen sofort gelöscht.

6. Um eine neue Einschränkung hinzuzufügen, wählen Sie New Constraint.

7. Um neue Einschränkungen hinzuzufügen und dabei die Definitionen bestehender Einschränkungen aus derselben Tabelle zu übernehmen, markieren Sie die gewünschten Einschränkungen, und wählen Sie Copy Constraint.

8. Um neue Einschränkungen hinzuzufügen und dabei die Definitionen bestehender Einschränkungen aus bestehenden Tabellen zu übernehmen, wählen Sie Import Constraint. Ein Fenster mit allen vom aktuellen Benutzer definierten Einschränkungen öffnet sich. Markieren Sie eine oder mehrere Einschränkungen, und bestätigen Sie mit OK.

9. Um eine Einschränkung zu löschen, markieren Sie die Einschränkung, und wählen Sie Remove Constraint.


Definieren von Fremdschlüsselbeziehungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Definieren von Fremdschlüsselbeziehungen

Verwendung

Sie wollen beim Anlegen einer Datenbanktabelle oder beim Ändern der Tabellendefinition Fremschlüsselbeziehungen (Foreign Keys, referentielle CONSTRAINT-Definitionen) zu Spalten anderer Datenbanktabellen definieren. Fremdschlüsselbeziehungen beschreiben Existenzabhängigkeiten zwischen zwei Tabellen.

Voraussetzung

Sie haben zuvor die Tabellenspalten definiert.

Vorgehensweise

1. Geben Sie, falls gewünscht, unter Foreign Key Name einen Namen für den Fremdschlüssel an.

2. Wählen Sie in Referencing Columns die referenzierende Spalte, und bestätigen Sie mit Enter.

3. Übernehmen Sie in Reference mit Drag&Drop die referenzierte Datenbanktabelle aus dem Catalog Manager. Wählen Sie die Spalte, auf die verwiesen wird, und bestätigen Sie mit Enter.

4. Wählen Sie unter On Delete das gewünschte Verhalten der referenzierten Tabelle beim Löschen eines Datensatzes in der referenzierenden Tabelle (DELETE-Regel).

5. Geben Sie unter Comment, falls gewünscht, einen Kommentar an.

6. Um einen neuen Verweis hinzuzufügen, wählen Sie New Foreign Key.

7. Um neue Verweise hinzuzufügen und dabei die Definitionen bestehender Verweise derselben Tabelle zu übernehmen, markieren Sie die gewünschten Verweise, und wählen Sie Copy Foreign Key.

8. Um neue Verweise hinzuzufügen und dabei die Definitionen bestehender Verweise aus bestehenden Tabellen zu übernehmen, wählen Sie Import Foreign Key. Ein Fenster mit allen vom aktuellen Benutzer definierten Verweisen öffnet sich. Markieren Sie einen oder mehrere Verweise, und wählen Sie OK.

9. Um einen Verweis zu löschen, markieren Sie den Verweis, und wählen Sie Remove Foreign Key.

Informationen zur Syntax von referentiellen CONSTRAINT-Definitionen finden Sie im SQL-Referenzhandbuch unter Strukturlink referentielle CONSTRAINT-Definition.


Definieren von zusätzlichen Angaben (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Definieren von zusätzlichen Angaben

Unter Misc können Sie beim Anlegen von Datenbanktabellen oder beim Ändern von Tabellendefinitionen folgende zusätzlichen Angaben zu Ihrer Tabelle machen:

Angabe | Bedeutung
Comment | Kommentar
Duplicates | Durch die DUPLICATES-Klausel kann das Verhalten beim Auftreten von Schlüsselkollisionen gesteuert werden.
Statistics | Der Sample Value gibt an, wie groß der Anteil der Daten ist, der für die Optimierung der Datenbankstrategie einbezogen wird.
Temporary Table Ignore Rollback | Die Tabelle ist eine temporäre Tabelle und wird unter Temp lokal abgelegt. Für temporäre Tabellen können Sie die Option Ignore Rollback angeben.
Identifiers Uppercase | Automatische Umwandlung der Tabellen-, Spalten- und weiteren Namen in Großbuchstaben. Eine Änderung der Einstellung wirkt sich sofort auf die gesamte Tabellendefinition aus. Beim Anlegen einer Datenbanktabelle mit einer anderen Datenbanktabelle als Vorlage wird die Benutzereinstellung der Vorlage übernommen.

Informationen zur Syntax von CREATE TABLE-Anweisungen finden Sie im SQL-Referenzhandbuch unter Strukturlink CREATE TABLE-Anweisung.


Anlegen einer View-Tabelle (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen einer View-Tabelle

Verwendung

Mit SQL Studio können Sie View-Tabellen anlegen.

Voraussetzungen

● Wenn die View-Tabelle auf einer Datenbankanfrage basieren soll, dann haben Sie diese Anfrage zuvor als SQL-Studio-Objekt gespeichert.

● Sie besitzen die erforderlichen Benutzerberechtigungen und haben die Benutzereigenschaft NOT EXCLUSIVE.

Eine Erläuterung zu Benutzerberechtigungen und Benutzereigenschaften finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer und im SQL-Referenzhandbuch unter Strukturlink Autorisierung .

Vorgehensweise

...

1. Wählen Sie Catalog Manager ® New ® View Definition.
Ein Fenster für die Definition der View-Tabelle öffnet sich.

2. Um eine Datenbanktabelle als Grundlage für die View-Tabelle zu verwenden, wählen Sie View Definition ® Get Table. Wählen Sie die gewünschte Datenbanktabelle, und bestätigen Sie mit OK.

3. Um die Struktur der Ergebnismenge einer gespeicherten Datenbankanfrage als Grundlage für die View-Tabelle zu verwenden, wählen Sie View Definition ® Get Stored Query. Wählen Sie die gewünschte Datenbankanfrage, und bestätigen Sie mit OK.

4. Geben Sie einen Namen für die View-Tabelle ein.

5. Wenn Sie die Spalten Ihrer View-Tabelle umbenennen möchten, geben Sie unter Alias in View neue Spaltennamen ein.

6. Wählen Sie die gewünschten Optionen aus:

Replace Existing View | Ersetzen der vorhandenen View-Tabelle
Check on Insert or Update | Überprüfen der View-Bedingungen beim Ändern von Werten
Identifiers Uppercase | Automatische Umwandlung der Tabellen- und Spaltennamen in Großbuchstaben

7. Wählen Sie View Definition ® Create View.

Mit View Definition ® Export to SQL Dialog können Sie die entsprechende SQL-Anweisung zum Anlegen der View-Tabelle in den SQL-Dialog exportieren.

Informationen zur Syntax von CREATE VIEW-Anweisungen finden Sie im SQL-Referenzhandbuch unter Strukturlink CREATE VIEW-Anweisung.


Anlegen eines Synonyms (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen eines Synonyms

Verwendung

Mit SQL Studio können Sie Synonyme für Datenbanktabellen anlegen.

Voraussetzung

Sie besitzen die erforderlichen Benutzerberechtigungen und haben die Benutzereigenschaft NOT EXCLUSIVE.

Eine Erläuterung zu Benutzerberechtigungen und Benutzereigenschaften finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer und im SQL-Referenzhandbuch unter Strukturlink Autorisierung .

Vorgehensweise

1. Markieren Sie im Catalog Manager die Datenbanktabelle, für die Sie ein Synonym anlegen möchten, und wählen Sie Catalog Manager ® New ® Synonym Definition.
Ein Fenster für die Definition des Synonyms öffnet sich.

2. Geben Sie einen Synonymnamen ein, und wählen Sie, ob das Synonym privat oder Public sein soll.

3. Wählen Sie Synonym Definition ® Create Synonym.

Mit Synonym Definition ® Export to SQL Dialog können Sie die entsprechende SQL-Anweisung zum Anlegen des Synonyms in den SQL-Dialog exportieren.

Informationen zur Syntax von CREATE SYNONYM-Anweisungen finden Sie im SQL-Referenzhandbuch Strukturlink CREATE SYNONYM-Anweisung.


Anzeigen der Definition einer Tabelle (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anzeigen der Definition einer Tabelle

Verwendung

Mit SQL Studio können Sie sich die Definition einer Datenbanktabelle, einer Viewtabelle oder eines Synonyms anzeigen lassen.

Voraussetzung

Sie besitzen die erforderlichen Benutzerberechtigungen.

Vorgehensweise

1. Markieren Sie im Catalog Manager die Tabelle, deren Definition Sie sehen möchten.

2. Wählen Sie Catalog Manager ® Open Object Definition.


Ändern der Definition einer Datenbanktabelle (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern der Definition einer Datenbanktabelle

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen und haben die Benutzereigenschaft NOT EXCLUSIVE.

Eine Erläuterung zu Benutzerberechtigungen und Benutzereigenschaften finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer und im SQL-Referenzhandbuch unter Strukturlink Autorisierung.

Vorgehensweise

...

1. Markieren Sie die Tabelle, und wählen Sie Catalog Manager ® Alter Table.
Ein Fenster mit der Tabellendefinition öffnet sich.

2. Nehmen Sie die gewünschten Änderungen vor:

· Definieren von Spalten (Columns)

· Definieren von Einschränkungen für Spalten (Constraints)

· Definieren von Fremdschlüsselbeziehungen (Foreign Keys)

· Definieren von zusätzlichen Angaben (Misc)

3. Wählen Sie Table Definition ® Alter Table.

Mit Table Definition ® Export to SQL Dialog können Sie die entsprechende SQL-Anweisung zum Ändern der Datenbanktabelle in den SQL-Dialog exportieren.

Informationen zur Syntax von ALTER TABLE-Anweisungen finden Sie im SQL-Referenzhandbuch unter Strukturlink ALTER TABLE-Anweisung .


Anzeigen des Inhalts einer Tabelle (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anzeigen des Inhalts einer Tabelle

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Vorgehensweise

1. Markieren Sie im Catalog Manager die Tabelle, deren Inhalt Sie sehen möchten.

2. Wählen Sie Catalog Manager ® Show Content.


Verwenden einer Tabelle in Dialogen oder Definitionen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Verwenden einer Tabelle in Dialogen oder Definitionen

Verwendung

Sie können Tabellen direkt aus dem Catalog Manager in einen SQL-Dialog, Form-Dialog oder Visual-Query-Dialog übernehmen oder sie als Grundlage für eine Tabellen- oder Viewdefinition verwenden.

Vorgehensweise

Markieren Sie die Tabelle im Catalog Manager. Wählen Sie Catalog Manager ® Send Object To und dann die gewünschte Dialogart.


Umbenennen einer Tabelle (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Umbenennen einer Tabelle

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

1. Markieren Sie im Catalog Manager die Tabelle, die Sie umbenennen möchten.

2. Wählen Sie Catalog Manager ® Rename Object und geben Sie den neuen Namen ein.


Löschen aller Zeilen einer Tabelle (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen aller Zeilen einer Tabelle

Voraussetzung

Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

1. Markieren Sie im Catalog Manager die Tabelle, deren Zeilen Sie löschen möchten.

2. Wählen Sie Catalog Manager ® Delete All Rows.

Wenn Sie die Zeilen eines Synonyms löschen, löschen Sie damit die Zeilen der zugrundeliegenden Datenbanktabelle.


Löschen einer Tabelle (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen einer Tabelle

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

1. Markieren Sie im Catalog Manager die Tabelle, die Sie aus der Datenbank löschen möchten.

2. Wählen Sie Catalog Manager ® Drop Object.


Indizes (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Indizes

Der Catalog Manager zeigt Ihnen unter Indexes die Tabellen an, für die Indizes angelegt wurden. Sie haben folgende Möglichkeiten:

  • Anlegen eines Index
  • Anzeigen der Definition eines Index
  • Löschen eines Index


Anlegen eines Index (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen eines Index

Verwendung

Mit SQL Studio können Sie neue Indizes für Datenbanktabellen anlegen.

Voraussetzung

Sie besitzen die erforderlichen Benutzerberechtigungen und haben die Benutzereigenschaft NOT EXCLUSIVE.

Eine Erläuterung zu Benutzerberechtigungen und Benutzereigenschaften finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer und im SQL-Referenzhandbuch unter Strukturlink Autorisierung .

Vorgehensweise

...

1. Markieren Sie im Catalog Manager die Datenbanktabelle, für die Sie einen Index anlegen möchten, und wählen Sie Catalog Manager ® New ® Index Definition.

2. Geben Sie unter Index Name einen Namen für den Index ein.

3. Wählen Sie im Feld In Index für die Spalten, deren Werte indiziert werden sollen, Yes.

4. Um die Indexwerte aufsteigend oder absteigend zu sortieren, wählen Sie im Feld Sort die Option ASC oder DESC.

5. Um die Reihenfolge der Tabellenspalten zu ändern, markieren Sie eine Tabellenspalte und verwenden Sie die Pfeile Ý ß, um sie nach oben oder unten zu verschieben.

6. Wählen Sie die gewünschten Optionen:

Unique | Stellt die Eindeutigkeit der indizierten Spalten sicher
Index Name Upper Case | Automatische Umwandlung der Tabellen- und Spaltennamen in Großbuchstaben

7. Wählen Sie Index Definition ® Create Index.

8. Mit Index Definition ® Export to SQL Dialog können Sie die ensprechende SQL-Anweisung zum Anlegen des Index in den SQL-Dialog exportieren.

Informationen zur Syntax von CREATE INDEX-Anweisungen finden Sie im SQL-Referenzhandbuch unter Strukturlink CREATE INDEX-Anweisung.


Anzeigen der Definition eines Index (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anzeigen der Definition eines Index

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Vorgehensweise

1. Markieren Sie im Catalog Manager den Index, dessen Definition Sie sehen möchten.

2. Wählen Sie Catalog Manager ® Open Object Definition.


Löschen eines Index (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen eines Index

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

1. Markieren Sie im Catalog Manager den Index, den Sie löschen möchten.

2. Wählen Sie Catalog Manager ® Drop Object.


Zahlenreihen (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Zahlenreihen

Der Catalog Manager zeigt Ihnen unter Sequences die Zahlenreihen an, die in der Datenbank angelegt wurden. Sie haben folgende Möglichkeiten:

  • Anlegen einer Zahlenreihe
  • Anzeigen der Definition einer Zahlenreihe
  • Löschen einer Zahlenreihe


Anlegen einer Zahlenreihe (Sequenz) (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen einer Zahlenreihe (Sequenz)

Verwendung

Mit SQL Studio können Sie neue Zahlenreihen (Sequenzen) in der Datenbank anlegen.

Voraussetzung

Sie besitzen die erforderlichen Benutzerberechtigungen und haben die Benutzereigenschaft NOT EXCLUSIVE.

Eine Erläuterung zu Benutzerberechtigungen und Benutzereigenschaften finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer und im SQL-Referenzhandbuch unter Strukturlink Autorisierung .

Vorgehensweise

...

1. Wählen Sie Catalog Manager ® New ® Sequence Definition.

2. Geben Sie einen Namen für die Sequenz ein und definieren Sie die gewünschten Werte.

3. Wählen Sie Sequence Definition ® Create Sequence.

4. Mit Sequence Definition ® Export to SQL Dialog können Sie die entsprechende SQL-Anweisung zum Anlegen der Sequenz in den SQL-Dialog exportieren.

Informationen zur Syntax von CREATE SEQUENCE-Anweisungen finden Sie im SQL-Referenzhandbuch unter Strukturlink CREATE SEQUENCE-Anweisung .


Anzeigen der Definition einer Zahlenreihe (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anzeigen der Definition einer Zahlenreihe

Verwendung

Mit SQL Studio können Sie sich die Definition einer Zahlenreihe (Sequence) sowie den zuletzt erzeugten Wert dieser Zahlenreihe anzeigen lassen.

Voraussetzung

Sie besitzen die erforderlichen Benutzerberechtigungen.

Vorgehensweise

1. Markieren Sie im Catalog Manager die Zahlenreihe, deren Definition Sie sehen möchten.

2. Wählen Sie Catalog Manager ® Open Object Definition.


Löschen einer Zahlenreihe (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen einer Zahlenreihe

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

1. Markieren Sie im Catalog Manager die Zahlenreihe, die Sie löschen möchten.

2. Wählen Sie Catalog Manager ® Drop Object.


Benutzer (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Benutzer

Definition

Der Catalog Manager zeigt Ihnen unter Owned Users die Benutzer an, für die Sie die Eigentümerrechte besitzt. Mit SQL Studio können Sie Informationen zu diesen Benutzern ansehen, Benutzer umbenennen und löschen.

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer .

Vorgehensweise

· Um die Informationen zu einem Benutzer anzuzeigen, markieren Sie den Benutzernamen, und wählen Sie Catalog Manager ® Open Object Definition.

· Um einen Benutzernamen zu ändern, markieren Sie ihn und wählen Sie Catalog Manager ® Rename Object.

· Um einen Benutzer zu löschen, markieren Sie den Benutzernamen und wählen Sie Catalog Manager ® Drop Object.


Datenbankprozeduren (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Datenbankprozeduren

Definition

Der Catalog Manager zeigt Ihnen unter Procedures die Datenbankprozeduren an, die in der Datenbank angelegt sind. Mit SQL Studio können Sie die Definitionen dieser Datenbankprozeduren ansehen und die Datenbankprozeduren löschen.

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen und Benutzereigenschaften finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

· Um sich eine Datenbankprozedur anzeigen zu lassen, markieren Sie sie und wählen Sie Catalog Manager ® Open Object Definition.

· Um eine Datenbankprozedur zu löschen, markieren Sie sie und wählen Sie Catalog Manager ® Drop Object.

Informationen zur Syntax von CREATE DBPROC-Anweisungen finden Sie im SQL-Referenzhandbuch unter Strukturlink CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement).


Trigger (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Trigger

Definition

Der Catalog Manager zeigt Ihnen unter Triggers die Trigger an, die in der Datenbank angelegt sind. Mit SQL Studio können Sie die Definitionen dieser Trigger ansehen und die Trigger löschen.

Voraussetzungen

Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen und Benutzereigenschaften finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

● Um sich die Definition eines Triggers anzeigen zu lassen, markieren Sie ihn und wählen Sie Catalog Manager ® Open Object Definition.

● Um einen Trigger zu löschen, markieren Sie ihn und wählen Sie Catalog Manager ® Drop Object.

Informationen zur Syntax von CREATE TRIGGER-Anweisungen finden Sie im SQL-Referenzhandbuch unter Strukturlink CREATE TRIGGER-Anweisung.


SQL-Dialog (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation SQL-Dialog

Wenn Sie SQL-Anweisungen unmittelbar in SQL erstellen möchten, dann verwenden Sie den SQL-Dialog.

Der SQL-Dialog bietet Ihnen folgende Möglichkeiten:

● Erstellen und Ausführen von SQL-Anweisungen

● Parametrisieren von SQL-Anweisungen

● Importieren und Exportieren von SQL-Anweisungen

Informationen zur Syntax und Semantik der SQL-Anweisungen des Datenbanksystems finden Sie im Strukturlink SQL-Referenzhandbuch.


Erstellen und Ausführen von SQL-Anweisungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Erstellen und Ausführen von SQL-Anweisungen

Verwendung

Im SQL-Dialog können Sie SQL-Anweisungen in unterschiedlichen Modi erstellen und speichern.

Vorgehensweise

1. Wählen Sie View ® SQL Dialog. Ein Fenster für den SQL-Dialog öffnet sich.

2. Für den SQL-Modus und den Isolation-Level sind die Vorschlagswerte eingestellt, die Sie in den Benutzereinstellungen festgelegt haben. Wenn Sie mit anderen Werten arbeiten möchten, dann wählen Sie den gewünschten SQL-Modus und Isolation-Level im unteren Bereich des Dialogfensters.

Wenn Sie sich mit SQL Studio an eine Datenbankinstanz der Version 7.6 oder höher anmelden, dann können Sie nur noch den SQL-Modus INTERNAL oder ORACLE wählen. Die SQL-Modi DB2 und ANSI werden nicht mehr unterstützt.

3. Sie können den Commit-Modus ebenfalls im unteren Bereich des Dialogfensters ändern.

Wenn Sie die Benutzereigenschaft EXCLUSIVE haben, können Sie nur den Modus Auto Commit: ON wählen. Eine Erläuterung zu Benutzereigenschaften finden Sie im SQL-Referenzhandbuch unter Strukturlink Autorisierung .

4. Geben Sie Ihre SQL-Anweisungen ein.

Sie können SQL-Anweisungen einfügen, die während der aktuellen Datenbanksitzung bereits ausgeführt wurden. Wählen Sie SQL Dialog ® Recent Statements. Markieren Sie die gewünschte Anweisung, und wählen Sie Get.

Die Liste der Schlüsselbegriffe bietet Ihnen ebenfalls Unterstützung bei der Erstellung von SQL-Anweisungen.

5. Um eine Zeile auszukommentieren, verwenden Sie // oder -- am Anfang der Zeile.

6. Um zwei SQL-Anweisungen voneinander zu trennen, geben Sie eine auskommentierte Trennzeile ein.

7. Um durch die Anweisungshistorie der Datenbanksitzung zu blättern, wählen Sie SQL Dialog ® Previous Statement bzw.SQL Dialog ® Next Statement

8. Sie können SQL-Anweisungen parametrisieren.

9. Um Ihre SQL-Anweisungen später wieder zu verwenden oder weiter zu bearbeiten, speichern Sie diese mit SQL Dialog ® Save As als SQL-Studio-Objekt.

10. Um die SQL-Anweisungen auszuführen, wählen Sie SQL Dialog ® Execute. Wenn Sie nur einen Teil der angezeigten SQL-Anweisungen ausführen möchten, markieren Sie diesen Teil, und wählen Sie dann SQL Dialog ® Execute.

Ergebnis

Die Statuszeile des Anweisungsfensters zeigt Ihnen an, ob die Ausführung Ihrer SQL-Anweisungen erfolgreich war. Falls ein Fehler aufgetreten ist, dann sehen Sie eine Fehlermeldung im Statusfenster des SQL Studio. Dort werden Ihnen je nach Ihren Einstellungen auch weitere Informationen wie z.B. die Ausführungsdauer Ihrer SQL-Anweisungen angezeigt.

Wenn Ihre SQL-Anweisung eine Ergebnistabelle liefert, erscheint diese Ergebnistabelle in einem weiteren Fenster.


Liste der Schlüsselbegriffe (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Liste der Schlüsselbegriffe

Definition

Die Liste der Schlüsselbegriffe (Keyword List) enthält reservierte Begriffe.

Verwendung

Die Liste steht im SQL-Dialog zur Verfügung und bietet Ihnen Liste Unterstützung beim Erstellen von SQL-Anweisungen.

Um die Liste der Schlüsselbegriffe aufzurufen, wählen Sie SQL Dialog ® Show Keyword List.


Parametrisieren von SQL-Anweisungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Parametrisieren von SQL-Anweisungen

Verwendung

Im SQL-Dialog können Sie SQL-Anweisungen parametrisieren. Beim Ausführen der parametrisierten SQL-Anweisung erscheint dann ein Dialogfenster, in das Sie einen Wert für den Parameter eingeben müssen.

Vorgehensweise

1. Fügen Sie beim Erstellen der SQL-Anweisung überall dort, wo eine variable Eingabe möglich sein soll, eckige Klammern ein.

2. Wenn Sie eine Eingabeaufforderung für das Dialogfenster formulieren möchten, geben Sie diese Eingabeaufforderung innerhalb der eckigen Klammern ein.

Wenn Sie die die Abfrage für die Spalten Artikel-Nr und Einzelpreis in der Tabelle Artikel parametrisieren wollen, können Sie bei den Auswahlkriterien folgende Parameter setzen:

SELECT  "Artikel-Nr", "Einzelpreis" FROM "Artikel"
WHERE  "Artikel-Nr" > [Artikelnummer (von)]
AND  "Artikel-Nr" < [Artikelnummer (bis)]
AND  "Einzelpreis" <= [Preisobergrenze]

Mit der Parametrisierung können Sie auch ganze Teile einer SQL-Anweisung ersetzen.

Sie können eine SELECT-Anweisung formulieren und über einen Parameter eine WHERE-Bedingung hinzufügen:

SELECT * FROM USERS [Ihre WHERE-Bedingung]

Wenn Sie einen Vergleichswert für den Datentyp CHAR, VARCHAR, DATE oder TIME angeben, müssen Sie den Vergleichswert in einfache Anführungszeichen einschließen.


Importieren und Exportieren von SQL-Anweisungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Importieren und Exportieren von SQL-Anweisungen

Verwendung

Im SQL-Dialog können Sie SQL-Anweisungen als Textdatei im ASCII-Format importieren und exportieren.

Vorgehensweise

Wählen Sie im Kontextmenü des SQL-Dialogs Import Filebzw. Export File.


Form-Dialog (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Form-Dialog

Wenn Sie Datensätze von Tabellen in einer Maskendarstellung ansehen, auswählen und bearbeiten möchten, dann verwenden Sie den Form Dialog.

Der Form Dialog bietet Ihnen folgende Möglichkeiten:

· Ausführen eines Form-Dialogs

· Auswählen von Datensätzen mit Hilfe von Suchbedingungen

· Ändern von Datensätzen

· Einfügen von Datensätzen

· Löschen eines Datensatzes

· Importieren und Exportieren von Longspalten

Wenn Sie Anweisungen unmittelbar in SQL erstellen oder außer dem Bearbeiten von Datensätzen weitere Möglichkeiten der Datenbank nutzen möchten, dann verwenden Sie den SQL-Dialog.


Ausführen eines Form-Dialogs (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ausführen eines Form-Dialogs

Verwendung

Mit dem Form-Dialog können Sie Anweisungen zum Bearbeiten von Datensätzen in unterschiedlichen Strukturlink Isolation-Levels ausführen.

Vorgehensweise

...

1. Wählen Sie View ®Form Dialog. Ein Fenster für den Form-Dialog öffnet sich.

2. Je nach Ihren Benutzereinstellungen befinden Sie sich zunächst im Nur-Lese-Modus (Read Only) oder im Änderungsmodus. Wenn Sie den Dialogmodus ändern möchten, dann setzen oder entfernen Sie die Markierung Read Only im unteren Bereich des Dialogfensters.

3. Für den Isolation-Level gilt zunächst der Vorschlagswert, den Sie in den Benutzereinstellungen festgelegt haben. Wenn Sie mit einem anderen Isolation-Level arbeiten möchten, dann wählen Sie den gewünschten Isolation-Level im unteren Bereich des Dialogfensters.

4. Wählen Sie Form Dialog ® Get Table. Wählen Sie die Tabelle, die Sie bearbeiten möchten, und bestätigen Sie mit OK.
In der linken Hälfte des Fensters erscheint der erste Datensatz. Sie können mit den Pfeilen < > durch die Datensätze blättern. Im Änderungsmodus können Sie Datensätze ändern, einfügen oder löschen. In der rechten Hälfte des Fensters können Sie Suchbedingungen zur Auswahl bestimmter Datensätze eingeben.

Um den Fensterbereich für die Eingabe der Suchbedingungen auszublenden, entfernen Sie die Markierung Filter.

5. Um die Datensätze als Liste zu sehen, wählen Sie Report. Um zurück zur Maskendarstellung zu wechseln, wählen Sie Record.

6. Um den Dialog später wieder zu verwenden oder weiter zu bearbeiten, sichern Sie ihn mit Form Dialog ® Save As als SQL-Studio-Objekt.

7. Mit Form Dialog ® Export to SQL Dialog können Sie die entsprechende SQL-Anweisung Ihres Form-Dialogs in den SQL-Dialog exportieren.


Auswählen von Datensätzen mit Hilfe von Suchbedingungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Auswählen von Datensätzen mit Hilfe von Suchbedingungen

Verwendung

Um sich nur bestimmte Datensätze einer Tabelle anzeigen zu lassen, können Sie im Form-Dialog Suchbedingungen angeben.

Vorgehensweise

1. Um den Fensterbereich für die Eingabe der Suchbedingungen einzublenden, markieren Sie Filter.

2. Formulieren Sie Ihre Suchbedingungen für die entsprechenden Tabellenspalten. Wählen Sie das gewünschte Prädikat, und geben Sie die Vergleichswerte bzw. Vergleichsausdrücke an.

3. Geben Sie an, wie die formulierte Suchbedingung mit der nächsten Suchbedingung verknüpft werden soll.

4. Wählen Sie Refresh. SQL Studio lädt die Datensätze aus der Datenbank.

Informationen zur Syntax von Prädikaten finden Sie im SQL-Referenzhandbuch unter Strukturlink Prädikat.


Ändern von Datensätzen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ändern von Datensätzen

Voraussetzungen

· Sie haben zum Ausführen des Form-Dialogs den Änderungsmodus gewählt.

· Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

1. Blättern Sie in der Maskendarstellung zu dem Datensatz, den Sie ändern möchten.

2. Geben Sie Ihre Änderungen ein.

Die Namen von Schlüsselspalten sind fett dargestellt.

Inhalte von LONG-Spalten können Sie importieren und exportieren.

3. Bestätigen Sie mit Update. SQL Studio übernimmt die Änderungen in die Datenbank.


Einfügen von Datensätzen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Einfügen von Datensätzen

Verwendung

Mit dem Form-Dialog können Sie in einer Maskendarstellung neue Datensätze in Tabellen einfügen.

Voraussetzungen

· Sie haben zum Ausführen des Form-Dialogs den Änderungsmodus gewählt.

· Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

...

1. Wählen Sie in der Maskendarstellung Form Dialog ® New. Eine leere Eingabemaske öffnet sich.

2. Geben Sie die Daten ein. Beachten Sie dabei folgende Punkte:

¡ Die Namen von Schlüsselspalten sind fett dargestellt.

¡ Für einen NULL-Wert geben Sie die Darstellung des NULL-Werts entsprechend Ihren Benutzereinstellungen ein, z.B. ?.

¡ Wenn Sie beim Einfügen eines Datensatzes ein Feld leer lassen, interpretiert das System dies folgendermaßen:

§ Wenn für die entsprechende Spalte ein DEFAULT-Wert definiert ist, dann wird dieser Wert in die Datenbanktabelle übernommen.

§ Wenn für die entsprechende Spalte kein DEFAULT-Wert definiert ist, dann wird der NULL-Wert in die Datenbanktabelle übernommen

¡ Inhalte von LONG-Spalten können Sie importieren und exportieren.

3. Wählen Sie Insert. SQL Studio speichert den neuen Datensatz in der Tabelle.
Eine weitere Eingabemaske öffnet sich. Sie können direkt weitere Daten eingeben und als Datensätze einfügen.

4. Wenn Sie keine weiteren Datensätze einfügen möchten, entmarkieren Sie Form Dialog ® New.

5. Um die neuen Datensätze in der Listendarstellung zu sehen, wählen Sie Refresh und anschließend Report.

Sie können beim Einfügen von Datensätzen auch einen bestehenden Datensatz derselben Tabelle als Vorlage nutzen. Blättern Sie zu diesem Datensatz, geben Sie Ihre Änderungen ein, und wählen Sie Insert. Der Datensatz wird als neuer Datensatz in die Tabelle eingefügt.


Löschen eines Datensatzes (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen eines Datensatzes

Voraussetzungen

· Sie haben zum Ausführen des Form-Dialogs den Änderungsmodus gewählt.

· Sie besitzen die erforderlichen Benutzerberechtigungen.

Eine Erläuterung zu Benutzerberechtigungen finden Sie in der Dokumentation Konzepte des Datenbanksystems unter Strukturlink Datenbankbenutzer.

Vorgehensweise

1. Blättern Sie in der Maskendarstellung zu dem Datensatz, den Sie löschen möchten.

2. Wählen Sie Delete.

SQL Studio löscht den Datensatz sofort aus der Datenbank.


Importieren und Exportieren von LONG-Spalten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Importieren und Exportieren von LONG-Spalten

Verwendung

Mit dem Form-Dialog können Sie Inhalte von LONG-Spalten aus einer Datei oder aus der Zwischenablage importieren und in eine Datei oder in die Zwischenablage exportieren.

Vorgehensweise

1. Um den Inhalt einer LONG-Spalte aus einer Datei zu importieren, klicken Sie in der Maskendarstellung in das Eingabefeld dieser Spalte, und wählen Sie
Form Dialog ® Import Long ®Import from File.

2. Um den Inhalt einer LONG-Spalte aus der Zwischenablage zu importieren, klicken Sie in der Maskendarstellung in das Eingabefeld dieser Spalte, und wählen Sie
Form Dialog ® Import Long ® Import Text from Clipboard.

3. Um den Inhalt einer LONG-Spalte in eine Datei zu exportieren, klicken Sie in der Maskendarstellung in das Eingabefeld dieser Spalte, und wählen Sie
Form Dialog ® Export Long ®Export to File.

4. Um den Inhalt einer LONG-Spalte aus der Zwischenablage zu importieren, klicken Sie in der Maskendarstellung in das Eingabefeld dieser Spalte, und wählen Sie
Form Dialog ® Export Long ®Export to Clipboard as Text.


Visual-Query-Dialog (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Visual-Query-Dialog

Wenn Sie beim Formulieren von Datenbankanfragen visuelle Unterstützung haben möchten, dann verwenden Sie den Visual-Query-Dialog.

Der Visual-Query-Dialog bietet Ihnen folgende Möglichkeiten:

· Erstellen und Ausführen einer Visual Query

· Verknüpfen von Tabellenspalten mit JOINS

· Angeben von Suchbedingungen

· Parametrisieren von Suchbedingungen

· Definieren der Ergebnisansicht

Wenn Sie Anweisungen unmittelbar in SQL erstellen möchten oder außer Datenbankanfragen auch weitere Möglichkeiten der Datenbank nutzen wollen, dann verwenden Sie den SQL-Dialog.


Erstellen und Ausführen einer Visual Query (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Erstellen und Ausführen einer Visual Query

Verwendung

Mit dem Visual-Query-Dialog können Sie SQL-Anweisungen in unterschiedlichen Strukturlink Isolation-Levels erstellen und speichern.

Vorgehensweise

...

1. Wählen Sie View ®Visual Query. Ein Fenster für den Visual-Query-Dialog öffnet sich. Das Fenster besteht aus folgenden Bereichen:

¡ Die obere Fensterhälfte ist der Bereich für die Tabellenauswahl.

¡ Die untere Fensterhälfte ist der Bereich für die Ergebnisdefinition.

2. Für den Isolation-Level gilt zunächst der Vorschlagswert, den Sie in den Benutzereinstellungen festgelegt haben. Wenn Sie mit einem anderen Isolation-Level arbeiten möchten, dann wählen Sie den gewünschten Isolation-Level im unteren Bereich des Dialogfensters.

3. Wählen Sie Visual Query ® Get Table. Wählen Sie die Tabelle, die Sie in Ihrer Datenbankanfrage verwenden möchten, und bestätigen Sie mit OK. Sie können auf diese Weise bis zu 16 Tabellen in die Tabellenauswahl übernehmen. Zu jeder übernommenen Tabelle öffnet sich ein Fenster, in dem die Namen der Tabellenspalten angezeigt werden.

¡ Um die Tabellen neu anzuordnen, wählen Sie Visual Query ® Arrange Tables bzw. Visual Query ® Cascade Tables.

¡ Um eine Tabelle wieder aus der Tabellenauswahl zu entfernen, schließen Sie das dazugehörige Fenster.

¡ Um alle Tabellen aus der Tabellenauswahl zu entfernen, wählen Sie Visual Query ® Clear Window.

4. Markieren Sie die Namen der Tabellenspalten, auf die sich Ihre Datenbankanfrage bezieht, und übernehmen Sie sie mit Drag&Drop in den Bereich für die Ergebnisdefinition.

Mit * übernehmen Sie alle Tabellenspalten einer Tabelle in die Ergebnisdefinition. Um eine Tabellenspalte wieder aus der Ergebnisdefinition zu entfernen, markieren Sie die Spalte und wählen Sie Visual Query ® Delete Column.

5. Sie können Tabellenspalten mit JOINS verknüpfen, für die Datensätze Suchbedingungen angeben und die Ergebnisansicht definieren.

6. Um Ihre Visual Query später wieder zu verwenden oder weiter zu bearbeiten, sichern Sie sie mit Visual Query ® Save As als SQL-Studio-Objekt.

7. Um die mit Visual Query erstellte Datenbankanfrage auszuführen, wählen Sie Visual Query ® Execute.

8. Mit Visual Query ® Export to SQL Dialog können Sie die Ihrer Visual Query entsprechenden SQL-Anweisungen in den SQL-Dialog exportieren.

Ergebnis beim Ausführen einer Visual Query

Die Statuszeile des Anweisungsfensters zeigt Ihnen an, ob die Ausführung Ihrer SQL-Anweisungen erfolgreich war. Falls ein Fehler aufgetreten ist, dann sehen Sie eine Fehlermeldung im Statusfenster des SQL Studio. Dort werden Ihnen je nach Ihren Einstellungen auch weitere Informationen wie z.B. die Ausführungsdauer Ihrer SQL-Anweisungen angezeigt.

Wenn Ihre Datenbankanfrage eine Ergebnistabelle liefert, erscheint diese Ergebnistabelle in einem weiteren Fenster.


Verknüpfen von Tabellenspalten mit Joins (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Verknüpfen von Tabellenspalten mit Joins

Verwendung

Mit dem Visual-Query-Dialog können Sie in Datenbankanfragen Tabellenspalten durch Joins verknüpfen.

Informationen zur Syntax von Joins finden Sie im SQL-Referenzhandbuch unter Strukturlink JOIN-Prädikat.

Voraussetzung

Sie haben die Tabellen, deren Spalten Sie verknüpfen möchten, beim Erstellen der Visual Query in die Tabellenauswahl übernommen.

Vorgehensweise

1. Markieren Sie in der Tabellenauswahl die Tabellenspalte, die Sie verknüpfen möchten, und verbinden Sie diese durch Drag&Drop mit der gewünschten Tabellenspalte der anderen Tabelle. Eine Verbindungslinie erscheint zwischen den beiden Tabellenspalten.

2. Um den Join genauer zu spezifizieren, markieren Sie ihn und wählen Sie Show Join Definition im Kontextmenü. Ein Fenster für die Join-Definition öffnet sich. Wählen Sie den Join-Typ und den Vergleichsoperator, und wählen Sie OK.

3. Um einen Join zu löschen, markieren Sie ihn und wählen Sie Delete Join im Kontextmenü.

Wenn Sie dieselbe Tabelle zweimal in die Tabellenauswahl übernehmen, vergibt SQL Studio einen Aliasnamen. Auf diese Weise können Sie SELF JOINS erstellen.


Angeben von Suchbedingungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Angeben von Suchbedingungen

Verwendung

Im Visual-Query-Dialog können Sie bei der Formulierung Ihrer Datenbankanfrage Suchbedingungen angeben.

Voraussetzung

Sie haben beim Erstellen der Visual Query die Tabellenspalten, auf die sich Ihre Datenbankanfrage bezieht, in den Fensterbereich für die Ergebnisdefinition übernommen.

Vorgehensweise

1. Geben Sie Ihre Suchbedingung in das Feld Predicate der entsprechenden Tabellenspalte ein.
Sie können die Suchbedingung parametrisieren.

Wenn Sie eine Suchbedingung für eine Spalte des Datentyps CHAR, VARCHAR, DATE oder TIME angeben, dann setzen Sie den Vergleichsausdruck in einfache Anführungszeichen.

2. Sie können mehrere Suchbedingungen mit UND-Verknüpfungen bzw. ODER-Verknüpfungen formulieren. Wenn Sie eine Spalte zur Formulierung von Suchbedingungen mehrfach verwenden, aber nicht mehrfach anzeigen wollen, dann blenden Sie diese in der Ergebnisansicht aus.

· Um mehrere Suchbedingungen mit UND-Verknüpfungen zu formulieren, geben Sie diese Bedingungen in derselben Zeile ein.

· Um mehrere Suchbedingungen mit ODER-Verknüpfungen zu formulieren, geben Sie jede dieser Bedingungen in einer neuen Zeile ein.

Informationen zur Syntax von Suchbedingungen und Prädikaten finden Sie im SQL-Referenzhandbuch unter Strukturlink Suchbedingung bzw. Strukturlink Prädikat .


Parametrisieren von Suchbedingungen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Parametrisieren von Suchbedingungen

Verwendung

Im Visual-Query-Dialog können Sie Suchbedingungen für Datenbankanfragen parametrisieren. Beim Ausführen der Datenbankanfrage erscheint dann ein Dialogfenster, in das Sie einen Wert für den Parameter eingeben müssen.

Vorgehensweise

1. Fügen Sie beim Angeben der Suchbedingungen überall dort, wo eine variable Eingabe möglich sein soll, eckige Klammern ein.

2. Wenn Sie eine Eingabeaufforderung für das Dialogfenster formulieren möchten, geben Sie diese Eingabeaufforderung innerhalb der eckigen Klammern ein.

Für die Spalte Bestell_Nr der Tabelle Bestellungen können Sie die Suchbedingung folgendermaßen parametrisieren:
=[Bestellnummer:]


Definieren der Ergebnisansicht (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Definieren der Ergebnisansicht

Verwendung

Im Visual-Query-Dialog können Sie angeben, wie SQL Studio das Ergebnis Ihrer Datenbankanfrage anzeigen soll.

Voraussetzung

Sie haben beim Erstellen der Visual Query die Tabellenspalten, auf die sich Ihre Datenbankanfrage bezieht, in den Fensterbereich für die Ergebnisdefinition übernommen.

Vorgehensweise

1. Um ein Synonym für einen Spaltennamen zu vergeben, tragen Sie den gewünschten Synonymnamen in die Zeile Synonym ein.

2. Um eine Spalte in der Ergebnisansicht auszublenden, wählen Sie in der Zeile Visible der entsprechenden Spalte No.

Dies ist vor allem dann nützlich, wenn Sie die Spalte nur zur Formulierung von Suchbedingungen benötigen.

3. Um das Ergebnis nach den Spaltenwerten einer Spalte zu gruppieren, wählen Sie in der Zeile Group der entsprechenden Spalte Yes.

Mit Hilfe einer Gruppierung können Sie in der Ergebnisansicht Durchschnittswerte, Maximalwerte, Minimalwerte, Summen und die Anzahl der gefundenen Datensätze bestimmen.

4. Um die Datensätze aufsteigend oder absteigend zu sortieren, wählen Sie im Feld Order der Spalte, die Sie zur Sortierung heranziehen möchten, Ascending bzw. Descending.


Ergebnistabellen (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Ergebnistabellen

SQL Studio zeigt Ergebnisse von Datenbankanfragen jeweils in separaten Fensterbereichen an. Mit den Navigationsfunktionen im Kontextmenü eines Ergebnisses können Sie durch die Ergebnistabelle blättern.

Außerdem haben Sie folgende Möglichkeiten:

  • Anpassen der Ergebnisansicht
  • Speichern eines Ergebnisses

Wenn Sie im SQL-Dialog mehrere SQL-Anweisungen auf einmal ausführen, werden mehrere einzelne Ergebnistabellen erzeugt. Sie können anhand der Auswahlliste in der Statuszeile des Ergebnisfensters zwischen diesen Ergebnistabellen hin und her wechseln.


Anpassen der Ergebnisansicht (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anpassen der Ergebnisansicht

Verwendung

Sie können sich Ergebnistabellen abschnittsweise oder fortlaufend anzeigen lassen. Sie können Spalten umbennen, ausblenden oder zum besseren Blättern in der Ergebnistabelle fixieren, und Sie können die Schriftart der Ergebnistabelle ändern.

Vorgehensweise

1. Um sich die Ergebnistabelle grundsätzlich abschnittsweise anzeigen zu lassen, wählen Sie Clipped Result View in den Benutzereinstellungen.
Im SQL-Dialog und im Visual-Query-Dialog können Sie diese Einstellung für das aktuelle Dialogfenster ändern. Wählen Sie dazu SQL Dialog ® Clipped Result View bzw. Visual Query ® Clipped Result View.

2. Um Spalten umzubenennen, auszublenden oder zu fixieren, wählen Sie Customize im Kontextmenü des Ergebnisses. Nehmen Sie folgende Einstellungen vor:

¡ Ändern Sie, falls gewünscht, die Spaltennamen.

¡ Ändern Sie, falls gewünscht, die Angabe Visible für die einzelnen Spalten.

¡ Geben Sie in Fixed Columns die Anzahl der Spalten ein, die Sie von links beginnend fixieren möchten.

Bestätigen Sie Ihre Einstellungen mit OK.

3. Um die Schriftart der Ergebnistabelle zu ändern, wählen Sie Font im Kontextmenü des Ergebnisses. Wählen Sie die gewünschte Schriftart, und bestätigen Sie mit OK.


Speichern eines Ergebnisses (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Speichern eines Ergebnisses

Verwendung

Im Strukturlink SQL-Modus INTERNAL können Sie das gesamte Ergebnis einer Datenbankanfrage als Textdatei speichern oder nach Microsoft Excel exportieren. Sie können einzelne Zellen als Textdatei speichern oder in einem separaten Zoom-Fenster anzeigen lassen.

Vorgehensweise

· Um die gesamte Ergebnistabelle als Textdatei zu speichern, wählen Sie
Export Result to ® File im Kontextmenü des Ergebnisses.
Je nach Ihren Benutzereinstellungen werden die Inhalte der Ergebnistabelle an den bestehenden Dateiinhalt angehängt oder der Dateiinhalt neu erzeugt.
SQL Studio trennt die Spalten beim Speichern durch Tabulatoren und die Zeilen durch einen Zeilenumbruch. Spalteninhalte vom Datentyp CHARACTER oder LONG werden nach 16 Zeichen abgeschnitten. Nicht darstellbare Zeichen werden durch Leerzeichen ersetzt.

· Um die gesamte Ergebnistabelle nach Microsoft Excel zu exportieren, wählen Sie
Export Result to ® Excel im Kontextmenü des Ergebnisses.
Microsoft Excel öffnet sich automatisch und überträgt pro Zelle maximal 1024 Byte. Daten vom Typ CHARACTER werden nach 1021 Bytes abgeschnitten.

· Um eine Zelle als Textdatei zu speichern, wählen Sie Export Cell to ® File.
Je nach Ihren Benutzereinstellungen werden die Inhalte der Ergebnistabelle an den bestehenden Dateiinhalt angehängt oder der Dateiinhalt neu erzeugt.

· Um eine Zelle in einem separaten Zoom-Fenster anzeigen zu lassen, wählen Sie
Export Cell to ® Zoom Window. In den Benutzereinstellungen können Sie wählen, wie viele Bytes im Zoom-Fenster angezeigt werden.

Das Exportieren bzw. Anzeigen von Zelleninhalten ist vor allem bei Spalteninhalten vom Datentyp LONG hilfreich.


Statusfenster (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Statusfenster

Im Statusfenster im unteren Bildschirmbereich des SQL Studio sehen Sie Informationen wie Fehlermeldungen oder die Ausführungsdauer von SQL-Anweisungen.

Sie können nach Wörtern und Begriffen suchen, den Text im Statusfenster kopieren oder als Textdatei exportieren.

Sie haben außerdem folgende Optionen:

· Wenn Sie außer Fehlermeldungen auch weitere Informationen zu Ihren Aktionen im SQL Studio anzeigen lassen wollen, dann wählen Sie
Status Window ® Trace All.

· Wenn Sie den gesamten Inhalt des Statusfensters markieren wollen, dann wählen Sie
Status Window ® Select All.

· Wenn Sie den Inhalt des Statusfensters löschen wollen, dann wählen Sie
Status Window ® Clear.

· Wenn Sie das Statusfenster anzeigen oder ausblenden wollen, dann wählen Sie
View ® Status Window.


Beenden der Datenbanksitzung (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Beenden der Datenbanksitzung

Um die aktuelle Datenbanksitzung zu beenden, wählen Sie Session ® Disconnect.

In folgenden Fällen beendet das Datenbanksystem die Datenbanksitzung automatisch:

● Sie schließen SQL Studio.

● Sie melden sich als ein anderer Datenbankbenutzer an die Datenbankinstanz an.

● Der Timeout-Wert wurde überschritten.


Web SQL Studio (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Web SQL Studio

Einsatzmöglichkeiten

Sie verwenden das Strukturlink Datenbankwerkzeug Web SQL Studio (Web SQL), um mit SQL-Anweisungen Daten in einer Datenbankinstanz anzuzeigen und zu ändern. Sie können mit Web SQL Studio auf Datenbankinstanzen auf dem lokalen Rechner und auf entfernten Rechnern zugreifen.

Web SQL Studio ist eine Webanwendung und kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden.

Einführungshinweise

Web SQL Studio ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie diese installieren, finden Sie im Abschnitt Strukturlink Download und im Installationshandbuch im Abschnitt Strukturlink Web SQL / WebDAV konfigurieren.

Integration

Mit Web SQL Studio können Sie auf WebDAV-Repositories zugreifen. Siehe Dokumentation zu Strukturlink WebDAV.

Funktionsumfang

Informationen zur Benutzungsoberfläche finden Sie unter Bildschirmbereiche von Web SQL Studio.

Die Datenbankwerkzeuge SQL Studio (GUI) und SQLCLI haben einen ähnlichen Funktionsumfang wie Web SQL Studio, bieten aber eine andere Benutzungsoberfläche.

Web SQL Studio bietet unter anderem die folgenden Funktionen:

● Web SQL Studio aufrufen

● An eine Datenbankinstanz anmelden

● SQL-Anweisungen ausführen

● WebDAV-Repository öffnen

● SQL-Anweisungen speichern

● Gespeicherte SQL-Anweisung bearbeiten

● Softwareversion von Web SQL Studio anzeigen

● Web SQL Studio beenden

Siehe auch:

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Informationen zur SQL-Syntax finden Sie im Strukturlink SQL-Tutorial und im Strukturlink SQL-Referenzhandbuch. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe empfehlen wir das alphabetisch sortierte Strukturlink Glossar.


Web SQL Studio aufrufen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Web SQL Studio aufrufen

Voraussetzungen

● Sie haben Web SQL Studio installiert. Siehe Installationshandbuch, Strukturlink Web SQL / WebDAV konfigurieren.

Wenn Sie bei der Installation die Vorschlagswerte verwendet haben, dann wurde Web SQL unter dem Kontextpfad /websql installiert

● Sie haben Ihren Servlet-Container gestartet. Informationen hierzu finden Sie in der Dokumentation zu Ihrem Servlet-Container.

Vorgehensweise

Geben Sie in Ihrem Webbrowser folgende Adresse ein:

http://<servlet_container_computer>:<servlet_container_port>/<context_path>

<servlet_container_computer> | Rechner, auf dem der Servlet-Container installiert ist
<servlet_container_port> | Port des Servlet-Containers
<context_path> | Kontextpfad von Web SQL

Beispiel

Sie haben den Servlet-Container Apache Tomcat auf dem Rechner PARMA installiert und verwenden für den Port den Vorschlagswert 8080.

http://PARMA:8080/websql

Siehe auch:

An eine Datenbankinstanz anmelden


An eine Datenbankinstanz anmelden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen An eine Datenbankinstanz anmelden

Verwendung

Sie melden sich an eine Datenbankinstanz an. Hiermit eröffnen Sie eine Datenbanksitzung.

Voraussetzungen

● Sie haben Web SQL Studio aufgerufen.

● Die Datenbankinstanz ist im Betriebszustand ONLINE.

Wenn die Datenbankinstanz nicht im Betriebszustand ONLINE ist, dann starten Sie sie mit dem Database Manager. Siehe

○ Database Manager CLI, db_online

○ Database Manager GUI, Betriebszustand überwachen

Vorgehensweise

...

1. Geben Sie folgende Daten ein.

Daten für die Anmeldung an die Datenbankinstanz

Name | Beschreibung
Server Name | Name des Datenbankrechners Wenn die Datenbankinstanz auf dem lokalen Rechner installiert ist, dann können Sie dieses Feld leer lassen.
Database Name | Name der Datenbankinstanz
User Name | Name des Datenbankbenutzers
Password | Kennwort des Datenbankbenutzers Das Datenbanksystem wandelt in Kennwörtern alle Buchstaben in Großbuchstaben um. Um Kleinbuchstaben und Sonderzeichen einzugeben, schließen Sie Ihre Eingabe in Anführungszeichen ein. Siehe Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter.

2. Optional: Um die Eigenschaften der Datenbanksitzung zu ändern, wählen Sie Extended. Ändern Sie dann die gewünschten Eigenschaften

Eigenschaften der Verbindung zur Datenbankinstanz

Name | Vorschlagswert | Beschreibung
Database Type | MaxDB | Datenbankinstanztyp
Auto Commit | On | AUTOCOMMIT-Modus
SQL Mode | Internal | SQL-Modus
Isolation Level | Read Committed | Isolation-Level

Weitere Informationen finden Sie im Strukturlink Glossar.

3. Wählen Sie Logon.

Ergebnis

Sie haben eine Datenbanksitzung eröffnet. Die Hauptseite von Web SQL Studio wird angezeigt (siehe Bildschirmbereiche von Web SQL Studio).


Bildschirmbereiche von Web SQL Studio (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Bildschirmbereiche von Web SQL Studio

Hauptbildschirm

Sie gelangen auf den Hauptbildschirm, nachdem Sie sich an Web SQL Studio angemeldet haben.

Diese Grafik wird im zugehörigen Text erklärt

Bildschirmbereiche des Hauptbildschirms

Nr.

Name des Bereichs

Beschreibung

1

Kopfzeile

● Informationen zur aktuellen Datenbanksitzung: Name der Datenbankinstanz, Name des angemeldeten Datenbankbenutzers

● Logoff-Button

2

Repositories

WebDAV-Repositories (wenn verfügbar)

siehe WebDAV-Repository öffnen

3

Result

Ergebnisfenster

● Ergebnisliste (enthält mehrere Einträge, wenn Sie mehrere SQL-Anweisungen gleichzeitig ausgeführt haben)

● Blättern in der Ergebnistabelle

● Anzahl der angezeigten Ergebniszeilen

● Ergebnistabelle der SQL-Anweisung

Um Werte in LONG-Spalten vollständig anzuzeigen, klicken Sie auf den entsprechenden Wert. Sie gelangen auf den Zoom-Bildschirm (siehe unten).

4

Fußzeile

● Version der Datenbankinstanz

● weitere Informationen zur aktuellen Datenbanksitzung: AUTOCOMMIT-Modus, SQL-Modus, Isolation-Level

5

Stored Statements

gespeicherte SQL-Anweisungen

siehe SQL-Anweisungen speichern

6

SQL Entry

Eingabebereich für SQL-Anweisungen

Buttons:

● Execute (SQL-Anweisung ausführen)

● Clear (Eingaben löschen)

● History Back (in der Historie der ausgeführten SQL-Anweisungen rückwärts blättern)

● History Forward (in der Historie der ausgeführten SQL-Anweisungen vorwärts blättern)

● Save (SQL-Anweisung speichern)

siehe SQL-Anweisungen ausführen

Zoom-Bildschirm

Sie gelangen auf den Zoom-Bildschirm, nachdem Sie auf einen Wert in einer LONG-Spalte geklickt haben.

Diese Grafik wird im zugehörigen Text erklärt

Bildschirmbereiche des Zoom-Bildschirms

Nr. | Name | Beschreibung
1 | Zoom | Zoom-Bildschirm ● Buttons und Felder: ○ Back to Result (zurück zum Hauptbildschirm) ○ Offset (Position, ab der der LONG-Wert angezeigt wird) ○ Refresh (Offset anwenden) ○ Representation (Art der Anzeige des LONG-Werts): Text, Decimal, Hex ○ Truncation (Trunkierung des Werts auf eine Größe in kB)


SQL-Anweisungen ausführen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen SQL-Anweisungen ausführen

Voraussetzungen

Sie haben sich an die Datenbankinstanz angemeldet.

Vorgehensweise

...

1. Geben Sie im Feld SQL Entry eine oder mehrere SQL-Anweisungen ein.

Um zwei SQL-Anweisungen voneinander zu trennen, fügen Sie eine auskommentierte Trennzeile zwischen den SQL-Anweisungen ein. Als Kommentarzeichen können Sie // oder -- am Anfang der Zeile verwenden.

CREATE SCHEMA hotel
//
SET CURRENT_SCHEMA = hotel

2. Wählen Sie Execute.

Ergebnis

Wenn die SQL-Anweisung eine Ergebnistabelle liefert, dann wird diese im Ergebnisfenster angezeigt. Wenn sie keine Ergebnistabelle liefert, dann wird im Ergebnisfenster eine Meldung angezeigt.

Wenn Sie mehrere SQL-Anweisungen gleichzeitig ausgeführt haben, dann können Sie mit dem Drop-Down-Menü zwischen den einzelnen Ergebnistabellen hin- und herwechseln.

Siehe auch:

SQL-Anweisungen speichern

Bildschirmbereiche von Web SQL Studio

Eine kurze Einführung in SQL finden Sie im Strukturlink SQL-Tutorial, eine ausführliche Beschreibung der MaxDB SQL-Syntax finden Sie im Strukturlink SQL-Referenzhandbuch.


WebDAV-Repository öffnen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen WebDAV-Repository öffnen

Verwendung

Sie öffnen ein WebDAV-Repository und zeigen die darin gespeicherten Objekte an, wie z. B. gespeicherte SQL-Anweisungen.

Voraussetzungen

● Sie haben die Berechtigung, auf ein WebDAV-Repository zuzugreifen.

Weitere Informationen zu WebDAV finden Sie in der Dokumentation Strukturlink WebDAV.

● Sie haben sich an eine Datenbankinstanz angemeldet.

Vorgehensweise

...

1. Wählen Sie im Feld Repository den Typ des WebDAV-Repository:

Typen von WebDAV-Repositories

Typ | Beschreibung
Private | Ihr privates WebDAV-Repository in der Datenbankinstanz, an die Sie angemeldet sind
Public | öffentliches WebDAV-Repository der Datenbankinstanz, an die Sie angemeldet sind
Remote | Wählen Sie diesen Typ für folgende WebDAV-Repositories: ● WebDAV-Repository in einer anderen MaxDB-Datenbankinstanz auf dem lokalen Rechner oder auf einem entfernten Rechner ● beliebiges anderes WebDAV-Repository auf dem lokalen Rechner oder auf einem entfernten Rechner

2. Wenn Sie den Typ Remote gewählt haben, dann geben Sie die Adresse des WebDAV-Repository an. Verwenden Sie folgende Syntax:

http://<servlet_container_computer>:<servlet_container_port>/<context_path>[/<internal_path>]

<servlet_container_computer> | Rechner, auf dem der Servlet-Container für das WebDAV-Repository installiert ist
<servlet_container_path> | Port des Servlet-Containers
<context_path> | Kontextpfad des WebDAV-Repository
<internal_path> | Pfad innerhalb des WebDAV-Repository

http://PARMA:8080/sdbwebdav/test/

3. Wählen Sie Refresh.

Ergebnis

Die Verzeichnisse und Objekte des ausgewählten WebDAV-Repository werden im Feld Stored Statements angezeigt.


SQL-Anweisungen speichern (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen SQL-Anweisungen speichern

Verwendung

Sie können SQL-Anweisungen speichern und später erneut ausführen oder bearbeiten. Web SQL Studio speichert SQL-Anweisungen in einem WebDAV-Repository.

Vorgehensweise

...

1. Öffnen Sie das WebDAV-Repository, in dem Sie die SQL-Anweisung speichern möchten.

2. Geben Sie im Feld SQL Entry die SQL-Anweisung ein.

3. Wählen Sie Save.

4. Geben Sie einen Namen für zu speichernde SQL-Anweisung ein und bestätigen Sie Ihre Eingabe.

Siehe auch:

Gespeicherte SQL-Anweisung bearbeiten

SQL-Anweisungen ausführen

Bildschirmbereiche von Web SQL Studio

Eine kurze Einführung in SQL finden Sie im Strukturlink SQL-Tutorial, eine ausführliche Beschreibung der MaxDB SQL-Syntax finden Sie im Strukturlink SQL-Referenzhandbuch.


Gespeicherte SQL-Anweisung bearbeiten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Gespeicherte SQL-Anweisung bearbeiten

Voraussetzungen

Sie haben sich an die Datenbankinstanz angemeldet.

Vorgehensweise

...

1. Öffnen Sie das WebDAV-Repository, in dem die SQL-Anweisung gespeichert wurde.

2. Wählen Sie im Feld Repository die SQL-Anweisung aus, die Sie bearbeiten möchten.

Die gespeicherte SQL-Anweisung wird im Feld SQL Entry angezeigt.

3. Bearbeiten Sie die SQL-Anweisung.

4. Um die Änderungen zu speichern, wählen Sie Save.

Siehe auch:

SQL-Anweisungen speichern


Softwareversion von Web SQL Studio anzeigen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Softwareversion von Web SQL Studio anzeigen

Voraussetzungen

Sie haben Ihren Servlet-Container gestartet. Informationen hierzu finden Sie in der Dokumentation zu Ihrem Servlet-Container.

Vorgehensweise

Rufen Sie mit Ihrem Webbrowser folgende Adresse auf:

http://<servlet_container_computer>:<servlet_container_port>/<context_path>/version.jsp

<servlet_container_computer> | Rechner, auf dem der Servlet-Container installiert ist
<servlet_container_port> | Port des Servlet-Containers
<context_path> | Kontextpfad von Web SQL

Beispiel

http://PARMA:8080/websql/version.jsp


Web SQL Studio beenden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Web SQL Studio beenden

...

1. Um die Datenbanksitzung zu beenden, wählen Sie Logoff.

2. Schließen Sie den Webbrowser.


SQLCLI (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation SQLCLI

Einsatzmöglichkeiten

Mit dem Strukturlink Datenbankwerkzeug SQLCLI können Sie SQL-Anweisungen eingeben und ausführen, Datenbankprozeduren ausführen und Informationen zur Datenbankinstanz abfragen. Sie können den SQLCLI interaktiv verwenden oder Kommandos aus einer Datei einlesen und im Hintergrund ausführen lassen.

Der SQLCLI ist ein Kommandozeilenwerkzeug und kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden. Sie können auf Datenbankinstanzen auf dem lokalen Rechner und auf entfernten Rechnern zugreifen.

Die Datenbankwerkzeuge SQL Studio und Web SQL Studio haben einen ähnlichen Funktionsumfang wie der SQLCLI, bieten aber eine andere Benutzungsoberfläche.

Einführungshinweise

Der SQLCLI ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

● SQL-Anweisungen ausführen

● Datenbankprozeduren ausführen

● Informationen zum Datenbankkatalog abfragen

● Shell-Kommandos ausführen

Im Abschnitt Kommando ausführen finden Sie eine Beschreibung der Kommandosyntax und der Optionen, die Ihnen beim Arbeiten mit dem SQLCLI zur Verfügung stehen.

Siehe auch:

Übersicht der Aufrufoptionen

Übersicht der SQLCLI-Kommandos

Glossar, Strukturlink Syntaxnotation


An eine Datenbankinstanz anmelden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen An eine Datenbankinstanz anmelden

Verwendung

Um den SQLCLI interaktiv (im Sitzungsmodus) zu verwenden, melden Sie sich als Datenbankbenutzer an eine Datenbankinstanz an. Hiermit eröffnen Sie eine Datenbanksitzung.

Voraussetzungen

Der angegebene Benutzer ist ein Strukturlink Datenbankbenutzer.

Einstufige Anmeldung

Anmelden an die Datenbankinstanz:

sqlcli [<options>] -d <database_name> -u <database_user>,<database_user_password>

<options> | Aufrufoptionen für das Programm SQLCLI
<database_name> | Name der Datenbankinstanz
<database_user> | Name des Datenbankbenutzers Siehe Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter
<database_user_password> | Kennwort des Datenbankbenutzers

Einstufige Anmeldung an die Datenbankinstanz DEMODB auf dem Rechner PARMA als Datenbankbenutzer MONA mit dem Passwort RED:

sqlcli -n PARMA -d DEMODB -u MONA,RED

Um sich mit einem Strukturlink Benutzerschlüssel <user_key> anzumelden, geben Sie folgendes Kommando ein:

sqlcli [<options>] -U <user_key>

Zweistufige Anmeldung

Starten des SQLCLI:

sqlcli [<options>]

Anmelden an die Datenbankinstanz:

\c [<options>] -d <database_name> -u <database_user>,<database_user_password>

Ergebnis

Sie haben eine Datenbanksitzung eröffnet und können nun interaktiv Kommandos ausführen.

Siehe auch:

Übersicht der SQLCLI-Kommandos


Kommando ausführen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Kommando ausführen

Verwendung

Sie führen im SQLCLI eine SQL-Anweisung, eine Datenbankprozedur oder ein spezielles SQLCLI-Kommando (siehe Übersicht der SQLCLI-Kommandos) aus.

Voraussetzungen

Einige Kommandos setzen voraus, dass Sie an die Datenbankinstanz angemeldet sind.

Einzelnes Kommando im interaktiven Modus (Sitzungsmodus) ausführen

...

1. Starten Sie das Programm SQLCLI. Sie können dabei Aufrufoptionen <options> verwenden.

sqlcli [<options>]

2. Geben Sie das Kommando ein.

<command>

Sie können Kommandos auch im Mehrzeilenmodus eingeben oder in einer externen Datei bearbeiten.

Starten des Programms SQLCLI und Anmelden an die Datenbankinstanz DEMODB als Benutzer MONA mit dem Kennwort RED:

sqlcli -d DEMODB -u MONA,RED

Anzeigen von allgemeinen Informationen zur Datenbankinstanz:

\s

host : localhost
database : demodb
xuserkey :
user : MONA
kernel version: KERNEL 7.6.00 BUILD 009-103-092-269
sapdbc version: libSQLDBC 7.6.0 BUILD 009-103-092-248
unicode : NO
default code : ASCII
sql mode : INTERNAL
autocommit : ON

Weitere Informationen finden Sie in folgenden Abschnitten:

SQL-Anweisung ausführen

Datenbankprozedur ausführen

Informationen zum Datenbankkatalog abfragen

Shell-Kommando ausführen

Einzelnes Kommando im Kommandomodus ausführen

...

1. Rufen Sie den SQLCLI auf und geben Sie direkt das Kommando ein.

sqlcli [<options>] <command>

sqlcli -d DEMODB -u MONA,RED \s

Wenn Sie als Kommando eine SQL-Anweisung oder eine Datenbankprozedur eingeben, dann setzen Sie die SQL-Anweisung/die Datenbankprozedur in doppelte Hochkommas.

sqlcli –d DEMODB –u MONA,RED ″select CNO,TITLE,FIRSTNAME,NAME,ZIP from HOTEL.CUSTOMER″

SQLCLI führt das Kommando aus und beendet sich danach.

Mehrere Kommandos aus einer Batch-Datei ausführen

● Wenn Sie sich im interaktiven Modus befinden, dann geben Sie den Pfad und den Namen der Batch-Datei <file>, aus der SQLCLI das Kommando auslesen soll, folgendermaßen an:

\i <file>

● Wenn Sie im Kommandomodus arbeiten, dann geben Sie beim Anmelden an die Datenbankinstanz den Pfad und den Namen der Batch-Datei <file> folgendermaßen an:

sqlcli [<options>] -i <file>

Siehe auch:

Ergebnis in eine Datei umleiten


Mehrzeilenmodus (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Mehrzeilenmodus

Verwendung

Im Mehrzeilenmodus können Sie lange Kommandos auf mehreren Zeilen eingeben. SQLCLI legt mehrzeilige Kommandos in einem internen Befehlspuffer ab.

Voraussetzungen

Sie betreiben das Programm SQLCLI im Mehrzeilenmodus. Um den Mehrzeilenmodus zu aktivieren, haben Sie folgende Möglichkeiten:

· Aufrufoption: sqlcli [<options>] -m

· SQLCLI-Kommando: \mu ON

Aktivitäten

Um im Mehrzeilenmodus eine neue Zeile zu beginnen, wählen Sie Enter.

Um das Kommando auszuführen, schließen Sie die letzte Zeile entweder mit einem Semikolon ab und wählen dann Enter oder Sie geben das Kommando \g ein.

Beispiel

Anmelden an die Datenbankinstanz DEMODB als Benutzer MONA mit Kennwort RED im Mehrzeilen-Modus:

sqlcli -d DEMODB -u MONA,RED

Eingeben einer mehrzeiligen SQL-Anweisung:

select
*
from
HOTEL.CUSTOMER

Ausführen der SQL-Anweisung:

\g

Siehe auch:

Kommando in einer externen Datei bearbeiten

Kommando ausführen


Befehlspuffer (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Befehlspuffer

Verwendung

Wenn Sie das Programm SQLCLI im Mehrzeilenmodus aufgerufen haben, dann legt SQLCLI alle Kommandos in einem internen Befehlspuffer ab.

Aktivitäten

· Inhalt des Befehlspuffers anzeigen: \p

· Inhalt des Befehlspuffers löschen: \r

· Kommando in einer externen Datei bearbeiten

· Befehlspuffer ausführen: \g


Kommando in einer externen Datei bearbeiten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Kommando in einer externen Datei bearbeiten

Verwendung

Wenn Sie ein langes Kommando eingeben haben, können Sie nachträglich Änderungen an diesem Kommando vornehmen, indem Sie den Befehlspuffer in einer externen Datei bearbeiten.

Voraussetzungen

Sie haben bereits ein Kommando ausgeführt.

Vorgehensweise

...

1. Um den Inhalt des Befehlspuffers in eine externe Datei zu laden, geben Sie folgendes Kommando ein:

\e [<file>]

¡ Geben Sie den vollständigen Pfad und Namen der Datei <file> an.

¡ Wenn Sie keine Datei angeben, dann erzeugt SQLCLI eine temporäre Datei.

Die Datei wird in einem Editor geöffnet. Um zu bestimmen, welcher Editor verwendet wird, wertet SQLCLI nacheinander die Umgebungsvariablen SQLCLI_EDITOR, EDITOR und VISUAL aus. Wenn Sie keine dieser Umgebungsvariablen gesetzt haben, dann wird auf Microsoft Windows der Notepad-Editor und auf Linux/Unix der vi-Editor verwendet. Hinweise dazu, wie Sie Umgebungsvariablen setzen können, finden Sie in der Dokumentation Ihres Betriebssystems.

2. Nehmen Sie die gewünschten Änderungen in der Datei vor.

3. Speichern Sie die Datei im Editor und schließen Sie die Datei bzw. den Editor.

Ergebnis

Sie haben den Inhalt des Befehlspuffers geändert und können nun das geänderte Kommando mit dem Befehl \g ausführen.

Siehe auch:

Mehrzeilenmodus

Batch-Datei


Batch-Datei (SAP-Bibliothek - Werkzeuge)

Objektdokumentation Batch-Datei

Definition

SQLCLI kann Kommandos aus einer Batch-Datei einlesen und im Hintergrund abarbeiten, siehe Kommando ausführen.

Struktur

Die einzelnen Kommandos stehen auf einzelnen Zeilen und sind durch ein Trennzeichen getrennt.

Sie können das in der Batch-Datei verwendete Trennzeichen zwischen zwei Kommandos mit der Aufrufoption -c <separator> festlegen. Der Vorschlagswert ist //

Geben Sie in der Batch-Datei keine zusätzlichen Leerzeichen ein. Für das Datenbanksystem sind z. B. die folgenden beiden Trennzeichen nicht identisch:

//

<blank>//

Beispiel

CREATE TABLE city
(zip CHAR (5) KEY CONSTRAINT zip BETWEEN '10000' AND '99999',
name CHAR(20) NOT NULL,
state CHAR(2) NOT NULL)
//
CREATE TABLE customer
(cno FIXED (4) KEY CONSTRAINT cno BETWEEN 1 AND 9999,
title CHAR (7) CONSTRAINT title IN ('Mr', 'Mrs', 'Company'),
firstname CHAR (10) ,
name CHAR (10) NOT NULL,
zip CHAR (5) CONSTRAINT zip BETWEEN '10000' AND '99999',
address CHAR (25) NOT NULL,
FOREIGN KEY (zip) REFERENCES city ON DELETE RESTRICT)
//
\dt customer
//
COMMIT

Der AUTOCOMMIT-Modus ist in diesem Beispiel ausgeschaltet. Damit SQLCLI SQL-Anweisungen sofort nach dem Einlesen der Batch-Datei ausführt, muss die Batch-Datei ein explizites COMMIT enthalten.

Vorschlagswert des Datenbanksystems: eingeschalteter AUTOCOMMIT-Modus


Ergebnis in eine Datei umleiten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Ergebnis in eine Datei umleiten

Verwendung

Sie leiten das Ergebnis von Kommandos in eine Datei <file> um.

Voraussetzungen

Sie haben sich an eine Datenbankinstanz angemeldet.

Vorgehensweise

...

1. \o <file>

Geben Sie den vollständigen Pfad der Datei an.

2. Geben Sie das Kommando ein, dessen Ergebnis in die Datei <file> umgeleitet werden soll.

<command>

Um mehrere Kommandos hintereinander einzugeben, wählen Sie nach jedem Kommando Enter.

3. Um die Umleitung in die Datei zu beenden, geben Sie \o ein.

Beispiel

Sie melden sich an die Datenbankinstanz DEMODB als Benutzer MONA mit dem Kennwort RED an:

sqlcli -d DEMODB -u MONA,RED

Sie erzeugen die Datei c:\tmp\redirected.txt, in die SQLCLI das Ergebnis umleiten soll:

\o c:\tmp\redirected.txt

Sie geben ein Kommando ein:

\ds

Sie geben ein weiteres Kommando ein (SQL-Anweisung):

select * from HOTEL.CUSTOMER

Sie beenden die Umleitung in die Datei:

\o

Die Datei redirected.txt hat nun folgenden Inhalt:

| Schema name | Owner name |

| ----------- | -------------------------------- |

| DBADMIN | DBADMIN |

| DBM | DBM |

| DOMAIN | DBADMIN |

| HOTEL | MONA |

| MONA | MONA |

| OMS | DBADMIN |

| SYSINFO | DBADMIN |

| CNO | TITLE | FIRSTNAME | NAME | ZIP | ADDRESS|
| ------ | ------- | ---------- | ---------- | ----- | -------|
| 3200 | Company | ? | Datasoft | 90018 | 486 Maple Str.|
| 3400 | Mrs | Mary | Griffith | 20005 | 3401 Elder Lane|
| 3500 | Mr | Martin | Randolph | 60615 | 340 MAIN STREET, #7|
| 3600 | Mrs | Sally | Smith | 75243 | 250 Curtis Street|
| 3700 | Mr | Mike | Jackson | 45211 | 133 BROADWAY APT. 1|
| 3900 | Mr | George | Howe | 75243 | 111 B Parkway, #23|
| 4000 | Mr | Frank | Miller | 95054 | 27 5th Str., 76|
| 4400 | Mr | Antony | Jenkins | 20903 | 55 A Parkway, #15|

...

Siehe auch:

Kommando ausführen


SQL-Anweisung ausführen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen SQL-Anweisung ausführen

Verwendung

Sie führen eine SQL-Anweisung im interaktiven Modus (Sitzungsmodus) aus.

Informationen zu den anderen Möglichkeiten, SQL-Anweisungen im SQLCLI auszuführen, finden Sie im Abschnitt Kommando ausführen.

Voraussetzung

Sie haben sich an eine Datenbankinstanz angemeldet.

Vorgehensweise

Geben Sie die SQL-Anweisung <sql_statement> ein.

<sql_statement>

Beispiel

Anmelden an die Datenbankinstanz DEMODB als Benutzer MONA mit dem Kennwort RED und Festlegen des SQL-Modus INTERNAL:

sqlcli -d DEMODB -u MONA,RED -S INTERNAL

Anzeigen der Spalten CNO, TITLE, FIRSTNAME, NAME und ZIP der Tabelle HOTEL.CUSTOMER:

select CNO,TITLE,FIRSTNAME,NAME,ZIP from HOTEL.CUSTOMER

CNO | TITLE | FIRSTNAME | NAME | ZIP
-------+---------+------------+------------+------
3000 | Mrs | Jenny | Porter | 10580
3100 | Mr | Peter | Brown | 48226
3200 | Company | ? | Datasoft | 90018
3300 | Mrs | Rose | Brian | 75243
3400 | Mrs | Mary | Griffith | 20005
3500 | Mr | Martin | Randolph | 60615
3600 | Mrs | Sally | Smith | 75243
3700 | Mr | Mike | Jackson | 45211
3800 | Mrs | Rita | Doe | 97213
3900 | Mr | George | Howe | 75243
4000 | Mr | Frank | Miller | 95054
4100 | Mrs | Susan | Baker | 90018
4200 | Mr | Joseph | Peters | 92714
4300 | Company | ? | TOOLware | 20019
 4400 | Mr | Antony | Jenkins | 20903
(15 rows selected)
* Ok

Siehe auch:

Datenbankprozedur ausführen

Eine Einführung zu den verfügbaren SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial, eine detaillierte Übersicht über Semantik und Syntax der SQL-Anweisungen gibt das Strukturlink SQL-Referenzhandbuch.


Datenbankprozedur ausführen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbankprozedur ausführen

Verwendung

Sie führen die Datenbankprozedur <dbproc_name> im interaktiven Modus (Sitzungsmodus) aus.

Informationen zu den anderen Möglichkeiten, Datenbankprozeduren im SQLCLI auszuführen, finden Sie im Abschnitt Kommando ausführen.

Voraussetzungen

Sie sind mit SQLCLI an eine Datenbankinstanz angemeldet.

Vorgehensweise

call <dbproc_name> (<parameter_value_1>,<parameter_value_2>,..., <parameter_value_n)

Geben Sie die Parameterwerte <parameter_value_n> folgendermaßen an:

● Für Input-Parameter geben Sie den Wert in einfachen Hochkommas ein.

● Für Output-Parameter geben Sie einen Platzhalter ein. Als Platzhalter können Sie entweder ein Fragezeichen ? oder den Namen des Platzhalters in folgender Notation verwenden: :<placeholder_name>

Weitere Informationen finden Sie im Abschnitt SQLCLI-Kommando ausführen.

Beispiel

siehe SQL-Tutorial, Strukturlink Datenbankprozeduren

Siehe auch:

SQL-Referenzhandbuch, Strukturlink Name einer Datenbankprozedur (dbproc_name)


Informationen zum Datenbankkatalog abfragen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Informationen zum Datenbankkatalog abfragen

Verwendung

Sie fragen mit einem SQLCLI-Kommando Informationen zum Datenbankkatalog einer Datenbankinstanz im interaktiven Modus ab.

Informationen zu den anderen Möglichkeiten, SQLCLI-Kommandos auszuführen, finden Sie im Abschnitt Kommando ausführen.

Voraussetzungen

Sie haben sich an eine Datenbankinstanz angemeldet.

Vorgehensweise

...

Geben Sie eines der unten aufgeführten SQLCLI-Kommandos ein.

Der SQLCLI liefert Informationen zu denjenigen Datenbankobjekten, die dem angegebenen Muster [PATTERN] oder [NAME] entsprechen und auf die Sie Zugriff haben. Wenn Sie kein Muster angeben, dann werden Informationen zu allen Datenbankobjekten angezeigt, auf die Sie Zugriff haben.

SQLCLI-Kommandos zum Abfragen von Informationen zum Datenbankkatalog

Datenbankobjekt | SQLCLI-Kommando | Ergebnis
Spalte | \dc [PATTERN] | · Spaltenname · Datentyp · Spaltenlänge · Nullwerte erlaubt oder nicht · Position der Spalte im Primärschlüssel der Tabelle (falls anwendbar)
Index | \de [PATTERN] | · Indexname · im Index enthaltene Spalten · Position der Spalten im Index · Angabe, ob der Index UNIQUE ist · Sortierung
Datenbankprozedur | \dp [PATTERN] | · Schemaname · Name der Datenbankprozedur · Paket, dem die Datenbankprozedur zugeordnet ist
Schema | \ds [NAME] | · Schemaname · Eigentümer
Tabelle | \dt [PATTERN] | · Schemaname · Tabellenname · Tabellentyp
Datenbankbenutzer | \du [NAME] | · Name des Datenbankbenutzers · Benutzereigenschaften
View | \dv [PATTERN] | · Schemaname · Viewname · Viewtyp

Für das Muster [PATTERN] gilt folgende Syntax:

PATTERN | [OWNER.][OBJECT_NAME] oder [SCHEMA.][OBJECT_NAME]
OWNER | Eigentümer des Datenbankobjekts, zu dem Sie Informationen abfragen möchten.
SCHEMA | Schema des Datenbankobjekts, zu dem Sie Informationen abfragen möchten.
OBJECT_NAME | Name des Datenbankobjekts

Sie können folgende Platzhalter verwenden:

· für 1 Zeichen: _

· für beliebig viele Zeichen: %

Beispiel

Abfragen von Informationen zu den Spalten der Tabelle HOTEL.CUSTOMER:

\dc HOTEL.CUSTOMER

Table "HOTEL.CUSTOMER"
Column Name | Type | Length | Nullable | KEYPOS
------------+------------+--------+----------+-------
ADDRESS | CHAR ASCII | 25 | NO |
CNO | FIXED | 4 | NO | 1
FIRSTNAME | CHAR ASCII | 10 | YES |
NAME | CHAR ASCII | 10 | NO |
TITLE | CHAR ASCII | 7 | YES |
ZIP | CHAR ASCII | 5 | YES |
(6 rows selected)


Shell-Kommando ausführen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Shell-Kommando ausführen

Verwendung

Sie führen aus dem Programm SQLCLI heraus ein Shell-Kommando aus. Auf diese Weise können Sie z. B. mit dem Database Manager CLI die Datenbankinstanz in den Betriebszustand ONLINE bringen, ohne SQLCLI zu beenden.

Voraussetzungen

Sie haben das Programm SQLCLI aufgerufen.

Vorgehensweise

\! <shell_command>

Beispiel

Sie haben SQLCLI bereits aufgerufen, stellen nun aber fest, dass die Datenbankinstanz DEMODB sich noch im Betriebszustand ADMIN befindet.

Um die Datenbankinstanz mit dem Database Manager CLI als Benutzer OLEG mit Kennwort MONDAY in den Betriebszustand ONLINE zu bringen, geben Sie im SQLCLI folgendes Kommando ein:

\! dbmcli -d DEMODB -u OLEG,MONDAY db_online


SQLCLI beenden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen SQLCLI beenden

Verwendung

Sie beenden den interaktiven Betriebsmodus des SQLCLI.

Vorgehensweise

exit | quit | \q


Übersicht der Aufrufoptionen (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Übersicht der Aufrufoptionen

Sie können das Programm SQLCLI mit Optionen aufrufen:

sqlcli [<options>]

Datenbanksitzung

Aufrufoption | Beschreibung
-d <database_name> | Name der Datenbankinstanz
-e | verschlüsselte Datenübertragung
-n <database_computer>[:<port>] | Name des Rechners, auf dem die Datenbankinstanz installiert ist Wenn Sie nicht den Standard-Port des X-Servers verwenden, dann geben Sie hier Ihren Port an. Siehe X-Server, Ports und Protokolle des X-Servers.
-r | erzwingt, dass SQL-Anweisungen als Statements und nicht als Prepared Statements ausgeführt werden
-S <SQLMODE> | Strukturlink SQL-Modus
-u <database_user,database_user_password> | Benutzername und Kennwort für die Anmeldung an der Datenbankinstanz
-U <user_key> | Anmeldung mit Strukturlink Benutzerschlüssel
-y <timeout> | Timeoutwert (in Sekunden) für die Datenbanksitzung Wenn Sie diese Option nicht angeben, dann verwendet SQLCLI den Vorschlagswert der Datenbankinstanz.
-z | schaltet den AUTOCOMMIT-Modus aus

Ein- und Ausgabe

Aufrufoption | Beschreibung
-c <separator> | Beim Einlesen von Kommandos aus einer Datei verwendet SQLCLI <separator> als Trennzeichen für die einzelnen Befehle. Der Vorschlagswert ist //
-i <file> | liest Kommandos aus der Batch-Datei <file> ein
-j | Ergebnisse werden fortlaufend ausgegeben (keine seitenweise Ausgabe)
-m | aktiviert des Mehrzeilenmodus für die Eingabe von SQLCLI-Befehlen
-o <file> | schreibt die Ergebnisse in die Datei <file>
-x | unterdrückt zusätzliche Ausgaben, wie z. B. die Anzahl der selektierten Zeilen einer Ergebnismenge

Formatierung der Ausgabe

Aufrufoption | Beschreibung
-A | gibt die Ergebnismenge unformatiert aus (ohne Auffüllen mit Leerzeichen) SQLCLI trennt dabei Spalten durch Kommas und Zeilen durch Zeilenumbrüche. Dieses Ausgabeformat eignet sich besonders für das Erzeugen von kommaseparierten Dateien (.csf).
-a | unterdrückt die Ausgabe der Spaltennamen der Ergebnismenge
-b <MAXLENGTH> | legt die maximale Anzahl von Zeichen für die Ausgabe von Strukturlink LONG-Werten fest Vorschlagswert: 10 Zeichen
-f | SQLCLI gibt alle SQL-Anweisungen aus, bevor er sie an die Datenbankinstanz schickt.
-F <separator> | legt die Zeichenkette fest, die SQLCLI als Trennzeichen zwischen den einzelnen Spalten der Ergebnismenge verwendet Vorschlagswert:|
-g <null_value> | legt das Zeichen für Nullwerte in der Ergebnismenge fest Vorschlagswert: ?
-p <prefix> | legt die Zeichenkette fest, die vor jeder Zeile der Ergebnismenge ausgegeben wird Vorschlagswert:|
-P <suffix> | legt die Zeichenkette fest, die nach jeder Zeile der Ergebnismenge ausgegeben wird Vorschlagswert: |
-Q | gibt jede Spalte der Ergebnismenge auf einer neuen Zeile aus

Sonstiges

Aufrufoption | Beschreibung
-E <exit_code> | Wenn ein Fehler auftritt, beendet sich SQLCLI und gibt die Fehlermeldung <exit_code> zurück.
-h | zeigt die Hilfe an
-t | gibt Debug-Informationen aus
-T <file> | schaltet den SQLDBC-Trace ein SQLDBC schreibt die Trace-Daten in die Datei <file>
-v | zeigt Versionsinformationen zum Programm SQLCLI an


Übersicht der SQLCLI-Kommandos (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Übersicht der SQLCLI-Kommandos

Die folgende Tabelle zeigt alle SQLCLI-Kommandos, die Sie im interaktiven Betrieb eingeben können.

Statt eines SQLCLI-Kommandos können Sie auch eine SQL-Anweisung oder eine Datenbankprozedur eingeben. Eine Einführung zu den verfügbaren SQL-Anweisungen finden Sie im Strukturlink SQL-Tutorial, eine detaillierte Übersicht über Semantik und Syntax der SQL-Anweisungen gibt das Strukturlink SQL-Referenzhandbuch.

Kommando | Bedeutung
\! <shell_command> | führt ein Shell-Kommando aus
\? \h[elp] | zeigt alle SQLCLI-Kommandos an
\a[utocommit] [ON|OFF] | schaltet den AUTOCOMMIT-Modus an oder aus
\al[ign] [ON|OFF] | schaltet die formatierte Ausgabe der Ergebnisse von SQL-Anweisungen an oder aus
\c[onnect] | an die Datenbankinstanz anmelden
\dc [PATTERN] | listet alle Tabellenspalten auf, die dem Muster PATTERN entsprechen SQLCLI listet nur diejenigen Tabellen auf, auf die der aktuelle Benutzer zugreifen darf. siehe Informationen zu Datenbankobjekten abfragen
\de [PATTERN] | listet alle Indizes der Datenbankobjekte auf, die dem Muster PATTERN entsprechen
\di[sconnect] | meldet den Benutzer von der Datenbankinstanz ab
\dp [PATTERN] | listet alle Datenbankprozeduren auf, die dem Muster PATTERN entsprechen
\ds [NAME] | listet alle Schemas auf, die dem Muster NAME entsprechen
\dt [PATTERN] | listet alle Tabellen auf, die dem Muster PATTERN entsprechen
\du [NAME] | listet alle Datenbankbenutzer auf, die dem Muster NAME entsprechen
\dv [PATTERN] | listet alle Views auf, die dem Muster PATTERN entsprechen
\e[dit] [<file>] | schreibt den Befehlspuffer in die Datei <file>, wo Sie ihn mit einem Editor bearbeiten können
\f[ieldsep] <separator> | verwendet das Zeichen <separator> als Trennzeichen zwischen den einzelnen Feldern des Ergebnisses
\g | führt die Befehle im Befehlspuffers aus und gibt die Ergebnisse aus
\i[nput] <file> | liest Befehlen aus der Batch-Datei <file> ein
\m[ode] <INTERNAL|ORACLE|ANSI|DB2> | ändert den SQL-Modus
\mu[ltiline] ON | OFF | schaltet den Mehrzeilenmodus an | aus
\o[utput] <file> | leitet das Ergebnis in eine Datei um
\pa[ger] | Ergebnisse werden fortlaufend ausgegeben (keine seitenweise Ausgabe)
\p[rint] | zeigt den aktuellen Befehlspuffer an
\q[uit] | beendet SQLCLI
\r[eset] | löscht den aktuellen Befehlspuffer
\ro[wsep] <separator> | verwendet das Zeichen <separator> als Trennzeichen zwischen den einzelnen Zeilen des Ergebnisses
\s[tatus] | zeigt allgemeine Informationen zur Datenbankinstanz an


Synchronization Manager (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Synchronization Manager

Einsatzmöglichkeiten

Der Synchronization Manager ist eine Sammlung mehrerer Programme und Skripte, mit denen Sie die Daten einer Master-Datenbankinstanz mit den Daten einer oder mehrerer Client-Datenbankinstanzen synchronisieren können. Die Daten der Client-Datenbankinstanzen sind in der Regel eine Teilmenge der Daten der Master-Datenbankinstanz. Alle an der Synchronisation beteiligten Datenbankinstanzen können gleichzeitig Daten lesen, aktualisieren und ändern.

Weil die Daten bei der Synchronisation asynchron übertragen werden, müssen die Datenbankinstanzen, deren Daten synchronisiert werden, nicht gleichzeitig online sein. Das hat den Vorteil, dass auch mobile Anwendungen das Verfahren nutzen können.

Der Synchronization Manager kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen verwendet werden.

Einführungshinweise

Der Synchronization Manager ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Installationshandbuch im Abschnitt Strukturlink Synchronization Manager installieren.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

Technische Systemlandschaft

Datenmodell

Konfiguration

Synchronisation

Beispiel

Beispiel: Datenmodell


Technische Systemlandschaft (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Technische Systemlandschaft

Der Synchronization Manager umfasst folgende Software:

· Synchronization Manager GUI zum Konfigurieren und Überwachen der Synchronisation

· Message-Server mit einer Message-Datenbankinstanz

· Synchronisierungsdienste auf jedem Rechner, auf dem sich eine der beteiligten Datenbankinstanzen befindet

Synchronization Manager GUI, Message-Server und Synchronisierungsdienste kommunizieren über verschiedene Ports miteinander, siehe Synchronisierungs-Ports.

Die Datenbankinstanzen, deren Daten synchronisiert werden, befinden sich in der Regel auf unterschiedlichen Rechnern.

Beispiel

Die Abbildung zeigt folgendes Beispiel:

· Master-Instanz DBMASTER mit Synchronisierungsdienst auf dem Rechner GENUA

· Client-Instanz DBCLIENT mit Synchronisierungsdienst auf dem Rechner COMO

· weitere Client-Instanzen mit Synchronisierungsdiensten auf weiteren Rechnern

· Message-Datenbankinstanz MSGDB auf dem Rechner PARMA

· Synchronization Manager GUI auf dem Rechner ROME

Zwei Client-Instanzen synchronisieren ihre Daten mit einer Master-Instanz

Diese Grafik wird im zugehörigen Text erklärt

Siehe auch:

Datenmodell

Konfiguration


Message-Server (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Message-Server

Einsatzmöglichkeiten

Der Message-Server überträgt die Synchronisierungsmeldungen, die zwischen den an der Synchronisation beteiligten Datenbankinstanzen ausgetauscht werden.

Der Message-Server kommuniziert mit den an der Synchronisation beteiligten Datenbankinstanzen über deren Synchronisierungsdienste.

Integration

Der Message-Server ist Bestandteil des Synchronization Manager.

Funktionsumfang

Message-Server konfigurieren

Message-Server starten und stoppen

An den Message-Server anmelden

Siehe auch:

Technische Systemlandschaft


Synchronization Manager GUI (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Synchronization Manager GUI

Einsatzmöglichkeiten

Synchronization Manager GUI ist ein Werkzeug, mit dem Sie die Synchronisation mehrerer Datenbankinstanzen konfigurieren, verwalten und überwachen können.

Integration

Synchronization Manager GUI ist Teil des Synchronization Manager.

Funktionsumfang

Synchronization Manager GUI konfigurieren

Synchronization Manager GUI starten

Siehe auch:

Technische Systemlandschaft


Synchronisierungsdienst (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Synchronisierungsdienst

Einsatzmöglichkeiten

Für jede Datenbankinstanz, die an der Synchronisation teilnimmt, starten Sie einen Synchronisierungsdienst.

Die Synchronisierungsdienste haben folgende Aufgaben:

· Senden von Datenänderungen der Datenbankinstanz als Synchronisationsmeldungen an den Message-Server

· Empfangen der Sychronisationsmeldungen anderer Datenbankinstanzen vom Message-Server

· Ändern der entsprechenden Daten in der Datenbankinstanz

Integration

Die Synchronisierungsdienste sind Bestandteil des Synchronization Manager.

Funktionsumfang

Synchronization Services konfigurieren

Synchronization Services starten und stoppen

Siehe auch:

Technische Systemlandschaft


Synchronisierungs-Ports (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Synchronisierungs-Ports

Synchronization Manager GUI, Message-Server und Synchronisierungsdienste verwenden für die Kommunikation mehrere Ports.

Synchronisierungs-Ports

Diese Grafik wird im zugehörigen Text erklärt

Synchronisierungs-Ports

Port | Vorschlagswert
Verwaltungs-Port des Message-Servers | 7220
JNDI-Port des Message-Servers | 7221
JMS-Port des Message-Servers | 7222
Verwaltungs-Port des Synchronisierungsdienstes | 7223 Wenn Sie mehrere Synchronisierungsdienste auf dem gleichen Rechner starten, geben Sie für jeden Synchronisierungsdienst einen eigenen Port an, also z. B. 7223 für den Synchronisierungsdienst der Master-Instanz und 7224 für den Synchronisierungsdienst der Client-Instanz

Siehe auch:

Technische Systemlandschaft


Datenmodell (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Datenmodell

Bevor Sie eine Synchronisation implementieren, planen Sie die technische Systemlandschaft und entwerfen Sie das Datenmodell.

Wir empfehlen, dass Sie das Datenmodell zunächst „auf Papier“ entwerfen, bevor Sie es mit dem Synchronization Manager in den Datenbankinstanzen definieren.

Das Datenmodell umfasst die an der Synchronisation beteiligten Tabellen in der Master-Instanz (Master-Tabellen) und die Tabellen der Client-Instanzen (Client-Tabellen).

Die Definitionen der Client-Tabellen können sich von der Definition der Master-Tabellen unterscheiden. Client-Tabellen können z. B. einem anderen Schema zugeordnet sein, einen anderen Tabellennamen oder andere Spaltennamen haben. Sie können alle oder ausgewählte Spalten von Tabellen synchronisieren. Zusätzlich können Sie Filter definieren.

Alle zu synchronisierenden Tabellen müssen Primärschlüssel haben.

Sie dürfen in den Tabellen, die an der Synchronisation teilnehmen, keine UPDATES für Daten in den Primärschlüsselspalten durchführen.

Um die Beziehungen zwischen den Master- und Client-Tabellen und die Synchronisationseigenschafen festzulegen, definieren Sie Replikationstabellen und Replikationseinheiten.

Replikationstabellen

Für jede Master-Tabelle, deren Daten mit den Daten der Client-Tabellen synchronisiert werden sollen, definieren Sie eine Replikationstabelle. Die Definition einer Replikationstabelle enthält folgende Angaben:

· zu replizierende Spalten der Master-Tabelle

· Spaltengruppen (optional)

Spaltengruppen können Sie verwenden, um Filter für die Synchronisierung zu definieren. Außerdem können Sie mit Spaltengruppen verhindern, dass unterschiedliche Client-Instanzen gleichzeitig unterschiedliche Spalten desselben Datensatzes in der Master-Instanz ändern.

· eine versionierte Spaltengruppe (optional)

Wenn eine Tabelle LONG-Spalten enthält, legt der Synchronization Manager automatisch eine versionierte Spaltengruppe für die Tabelle an.

Beispiel für eine Master-Instanz mit einer Master- und Replikationstabelle und eine Client-Instanz mit einer Client-Tabelle

Diese Grafik wird im zugehörigen Text erklärt

Replikationseinheiten

In den Replikationseinheiten definieren Sie die Synchronisationseigenschaften:

· Art der Synchronisation (Typ der Replikationseinheit)

· Filter

· weitere Synchronisationseigenschaften

Sie können Replikationseinheiten aktivieren und deaktivieren.

Für jede Master-Instanz gibt es mindestens eine Master-Replikationseinheit, für jede Client-Instanz mindestens eine Client-Replikationseinheit. Jeder Master-Replikationseinheit ist mindestens eine Client-Replikationseinheit zugeordnet. Alle Replikationseinheiten definieren Sie in der Master-Instanz.

Eine Master-Replikationseinheit umfasst eine oder mehrere Replikationstabellen. Eine Replikationstabelle kann zu mehreren Replikationseinheiten gehören.

Eine Client-Replikationseinheit umfasst eine oder mehrere Client-Tabellen. Eine Client-Tabelle darf nur genau einer Client-Replikationseinheit zugeordnet sein (und keiner anderen Master- oder Client-Replikationseinheit).

Beispiel für eine Master-Replikationseinheit mit zwei Client-Replikationseinheiten

Diese Grafik wird im zugehörigen Text erklärt

Der Typ einer Replikationseinheit legt fest, in welche Richtung Datenänderungen übertragen werden. Der Typ der Master-Replikationseinheit bestimmt den Typ der zugehörigen Client-Replikationseinheiten.

Typen von Replikationseinheiten

Typ der Master-Replikationseinheit | Typ der Client-Replikationseinheiten | Beschreibung
OUT | IN | Die Inhalte der Client-Tabellen werden so aktualisiert, dass sie mit den geänderten Inhalten der Master-Tabellen übereinstimmen.
IN/OUT | IN/OUT oder IN | Die Inhalte der Client- und der Master-Tabellen werden abgeglichen. Die Client-Instanzen schicken ihre Änderungen zunächst an die Master-Instanz. Dort findet eine Kollisionsauflösung statt. Danach schickt die Master-Instanz die Änderungen an alle Client-Instanzen. Diese Änderungen überschreiben dann gegebenenfalls widersprechende Änderungen in den Client-Instanzen.

Typen von Replikationseinheiten

Diese Grafik wird im zugehörigen Text erklärt

Kollisionsauflösung

Wenn mehrere an der Synchronisation beteiligte Datenbankinstanzen gleichzeitig den gleichen Datensatz ändern, dann entsteht eine Kollision. Unter gleichzeitig wird die Zeitspanne zwischen zwei Synchronisationen durch die Synchronisierungsdienste der beteiligten Datenbankinstanzen verstanden. Kollisionen können nur entstehen, wenn die Master-Replikationseinheit den Typ IN/OUT hat. Um zu entscheiden, welche Änderung des Datensatzes Vorrang hat (Kollisionsauflösung), verwendet der Synchronization Manager feste Regeln.

Einschränkungen

Wir empfehlen, dass die Definitionen der Client-Tabellen mit der Definition der Replikationstabellen übereinstimmen, die Client-Tabellen also z. B. keine zusätzlichen Spalten enthalten. Die Definition der Master-Tabellen kann sich von der Definition der Replikationstabellen unterscheiden.

Für Replikations- und Client-Tabellen gelten folgende Einschränkungen:

· Sie dürfen keine Fremdschlüsselbeziehungen enthalten.

· Bestimmte Massen-Updates für Spalten mit Spaltenattribut UNIQUE dürfen nicht durchgeführt werden, siehe das folgende Beispiel.

In der Tabelle EXAMPLE gibt die UNIQUE-Spalte ORDER die Reihenfolge der Zeilen an. Sie geben folgende SQL-Anweisung an:

UPDATE EXAMPLE SET ORDER + 1

Das Datenbanksystem führt diese SQL-Anweisung als Massen-UPDATE durch: zunächst erhöht es alle Werte in der Spalte ORDER um 1 und prüft erst dann, ob alle Werte in der Spalte ORDER eindeutig sind.

Im Gegensatz dazu führt der Synchronization Manager diese SQL-Anweisung in Einzelschritten aus und überprüft nach jedem Einzelschritt, ob die Werte in der Spalte ORDER eindeutig sind. Dies führt schon nach dem ersten UPDATE zu einer Verletzung der UNIQUE-Bedingung in der Spalte ORDER.

Ergebnis

Nachdem Sie Ihre technische Systemlandschaft und Ihr Datenmodell entworfen haben, können Sie mit der Konfiguration beginnen.

Beispiel

Beispiel: Datenmodell

Siehe auch:

Technische Systemlandschaft


Beispiel: Datenmodell (SAP-Bibliothek - Werkzeuge)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Datenmodell

Das folgende Beispiel stützt sich auf die Tabellen des SQL-Tutorials, siehe SQL-Tutorial, Strukturlink SQL-Anweisungen für das Schema HOTEL.

Nachdem Sie die Software des Synchronization Manager installiert haben, finden Sie die Beschreibung eines ausführlichen Beispiels im Verzeichnis <independent_program_path>\app\syncman\example\doc.

Siehe auch Installationshandbuch, Strukturlink Verzeichnisse.

An der Synchronisation sind die Master-Instanz DBMASTER und die Client-Instanz DBCLIENT beteiligt.

Definition der Synchronisation

Datenbankinstanz | DBMASTER | DBCLIENT
Replikationseinheit | masterunit1 Typ: IN/OUT | clientunit1 Typ: IN/OUT
Schema.Tabelle | HOTEL.CITY (Master-Tabelle) | MONA.TOWN (Client-Tabelle)
Spalten der Tabelle | ZIP NAME STATE | ZIP TNAME TSTATE
Primärschlüsselspalte | ZIP | ZIP
zu synchronisierende Spalten | NAME STATE | TNAME TSTATE

Siehe auch:

Technische Systemlandschaft


Konfiguration (SAP-Bibliothek - Werkzeuge)

Prozessdokumentation Konfiguration

Einsatzmöglichkeiten

Sie konfigurieren auf den an der Synchronisation beteiligten Rechnern alle für die Synchronisation benötigten Programme, Datenbankinstanzen und Dienste.

Voraussetzungen

● Sie haben ein Datenmodell entworfen.

● Sie haben auf allen Rechnern die Software für den Synchronization Manager installiert. Siehe Installationshandbuch, Strukturlink Sychronization Manager installieren.

Die Software des Synchronization Managers befindet sich im Verzeichnis <independent_program_path>\app\syncman. Dieses Verzeichnis wird im Folgenden als <syncman> bezeichnet.

Microsoft Windows: <syncman>=C:\Program Files\sdb\app\syncman

UNIX/Linux: <syncman>=/opt/sdb/programs/app/syncman

Siehe auch Installationshandbuch, Strukturlink Verzeichnisse.

● Sie haben auf allen Rechnern die folgende Software installiert:

○ Java Runtime Environment ≥ 1.4, siehe java.sun.com/jre

○ j2ee.jar aus dem Java 2 Enterprise SDK ≥ 1.4, siehe java.sun.com/j2ee

● Sie haben auf den Rechnern, auf denen Sie das Synchronization Manager GUI verwenden möchten, zusätzlich die folgende Software installiert:

○ Eclipse SDK oder Eclipse Platform Runtime-Binärpaket, siehe www.eclipse.org

Ablauf

Wir empfehlen, bei der Konfiguration immer Rechnernamen anzugeben. Verwenden Sie nicht localhost oder IP-Adressen. IP-Adressen (außer 127.0.0.1) werden unter Umständen dynamisch im Netzwerk vergeben.

...

1. Java-Pfade konfigurieren

2. Synchronization Manager GUI konfigurieren

3. Datenbankinstanzen konfigurieren

4. Message-Server konfigurieren

5. Synchronisation konfigurieren

Ergebnis

Nach Abschluss der Konfiguration können Sie die Synchronisation starten.


Java-Pfade konfigurieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Java-Pfade konfigurieren

Verwendung

Sie konfigurieren für den Synchronization Manager die Pfade Ihrer Java-Installation und der Datei j2ee.jar.

Vorgehensweise

Führen Sie die folgenden Aktionen auf allen Rechnern durch, auf denen Sie den Synchronization Manager GUI, den Message-Server oder Synchronisierungsdienste verwenden möchten.

...

1. Geben Sie folgendes Kommando ein:

<independent_program_path>\bin\syncmanjconf

2. Geben Sie den Pfad Ihrer Java-Installation ein.

3. Geben Sie den Pfad der Datei j2ee.jar ein.

Siehe auch:

Konfiguration

Installationshandbuch, Strukturlink Verzeichnisse


Synchronization Manager GUI konfigurieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Synchronization Manager GUI konfigurieren

Verwendung

Um das Synchronization Manager GUI verwenden zu können, benötigen Sie mehrere Eclipse-Dateien im Verzeichnis <independent_data_path>\app\syncman\extern.

UNIX/Linux: /var/opt/sdb/data/app/syncman/extern

Microsoft Windows: c:\Documents and Settings\All Users\Application Data\sdb\data\app\syncman\extern

Siehe Installationshandbuch, Strukturlink Verzeichnisse.

Dateien im Verzeichnis <independent_data_path>\app\syncman\extern übersteuern gleichnamige Dateien im Verzeichnis <syncman> und dessen Unterverzeichnissen. Beide Verzeichnisse werden bei der Installation des Synchronization Manager angelegt.

Voraussetzungen

Nur für UNIX/Linux: Sie sind als Betriebssystembenutzer der speziellen Betriebssystemgruppe <sdba_group> an das Betriebssystem angemeldet. Siehe Konzepte des Datenbanksystems, Strukturlink <sdba_group> (spezielle Betriebssystemgruppe).

Vorgehensweise

Führen Sie die folgenden Aktionen auf allen Rechnern durch, auf denen Sie das Synchronization Manager GUI verwenden möchten.

Kopieren Sie die folgenden Eclipse-Dateien aus dem Eclipse SDK oder dem Eclipse Platform Runtime-Binärpaket für Ihr Betriebssystem in das Verzeichnis <independent_data_path>\app\syncman\extern.

Die folgende Tabelle listet die für den Synchronization Manager GUI benötigten Dateien von Eclipse 3.1 auf. Wenn Sie eine andere Eclipse-Version verwenden, dann benötigten Sie unter Umständen andere oder zusätzliche Dateien.

Benötigte Eclipse-Dateien

UNIX/Linux | Microsoft Windows
org.eclipse.core.runtime_<version>.jar org.eclipse.jface.text_<version>.jar org.eclipse.jface_<version>.jar org.eclipse.osgi_<version>.jar org.eclipse.swt_<version>.jar org.eclipse.text_<version>.jar org.eclipse.swt.gtk.linux.<architecture>_<version>.jar Extrahieren Sie aus dem Paket org.eclipse.swt.gtk.linux.<architecture>_<version>.jar die folgenden Dateien: ● libswt-atk-gtk-*.so ● libswt-awt-gtk-*.so ● libswt-cairo-gtk-*.so ● libswt-gnome-gtk-*.so ● libswt-gtk-*.so ● libswt-mozilla-gtk-*.so ● libswt-pi-gtk-*.so | org.eclipse.core.runtime_<version>.jar org.eclipse.jface.text_<version>.jar org.eclipse.jface_<version>.jar org.eclipse.osgi_<version>.jar org.eclipse.swt_<version>.jar org.eclipse.text_<version>.jar org.eclipse.swt.win32.win32.<architecture>_<version>.jar Extrahieren Sie aus dem Paket org.eclipse.swt.win32.win32.<architecture>_<version>.jar die folgende Datei: ● swt-win32-*.dll

Ergebnis

Sie können das Synchronization Manager GUI starten.

Siehe auch:

Konfiguration


Datenbankinstanzen konfigurieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Datenbankinstanzen konfigurieren

Verwendung

Sie konfigurieren die Datenbankinstanzen, die synchronisiert werden sollen.

Voraussetzungen

● Sie verwenden MaxDB-Software der Version 7.6 oder höher.

● Sie haben die Datenbankinstanz angelegt, die später die Rolle der Master-Instanz übernehmen soll. Siehe

○ Database Manager GUI, Anlegen einer Datenbankinstanz

○ Database Manager CLI, db_create

● Sie haben die Datenbankinstanzen angelegt, die später die Rolle der Client-Instanzen übernehmen sollen.

● Sie haben in allen Datenbankinstanzen den Synchronisationsbenutzer angelegt.

Siehe Database Manager GUI, Anlegen/Ändern/Löschen des Synchronisationsbenutzers

● Sie haben ein Datenmodell entworfen.

Siehe Datenmodell.

Alle zu synchronisierenden Tabellen müssen Primärschlüssel haben. Sie dürfen in den Tabellen, die an der Synchronisation teilnehmen, keine UPDATES für Daten in den Primärschlüsselspalten durchführen.

Vorgehensweise

...

1. Definieren Sie in der Master-Instanz Ihrem Datenmodell gemäß die Master-Tabellen, Datenbankbenutzer usw.

Siehe

○ SQL-Referenzhandbuch, Strukturlink Datendefinition

○ SQL-Tutorial, Strukturlink Datendefinition

2. Fügen Sie Daten in die Master-Tabellen ein.

Siehe

○ SQL-Referenzhandbuch, Strukturlink Datenmanipulation

○ SQL-Tutorial, Strukturlink Datenmanipulation

○ Loader, Importieren: Kommandos

3. Definieren Sie in den Client-Instanzen Ihrem Datenmodell gemäß die Client-Tabellen, Datenbankbenutzer usw.

Füllen Sie die Client-Tabellen nicht mit Daten. Bevor Sie die Synchronisation beginnen, initialisieren Sie die Client-Tabellen; dabei kopiert der Synchronization Manager alle notwendigen Daten von den Master- in die Client-Tabellen.

4. Der Synchronisationsbenutzer muss auf alle Tabellen, die an der Synchronisation beteiligt sind, zugreifen können. Die Datenbankbenutzer, die diese Tabellen angelegt haben, müssen deswegen dem Synchronisationsbenutzer mit der GRANT-Anweisung alle Privilegien für diese Tabellen zuweisen. Siehe SQL-Referenzhandbuch, Strukturlink GRANT-Anweisung (grant_statement).

Siehe auch:

Technische Systemlandschaft


Message-Server konfigurieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Message-Server konfigurieren

Vorgehensweise

...

1. Legen Sie auf dem Rechner <msg_database_computer> eine Datenbankinstanz <msg_database> an, siehe

○ Database Manager GUI, Anlegen einer Datenbankinstanz

○ Database Manager CLI, db_create

Diese Datenbankinstanz muss sich nicht auf demselben Rechner wie der Message-Server befinden.

Der Synchronization Manager verwendet die Datenbankinstanz <msg_database> als Message-Datenbankinstanz für den Message-Server.

Wie groß Sie den Datenbereich dieser Datenbankinstanz konfigurieren, hängt unter anderem von folgenden Faktoren ab: Umfang der Datenänderungen, Anzahl der beteiligten Datenbankinstanzen, Verweildauer der Synchronisierungsnachrichten auf dem Message-Server (bis alle Datenbankinstanzen die Änderungen abgeholt haben).

Wir empfehlen, für den Strukturlink allgemeinen Datenbankparameter MAXUSERTASKS einen Wert > 50 zu konfigurieren.

Beim Anlegen der Datenbankinstanz definieren Sie den Datenbanksystemadministrator <sysdba_user>.

2. Legen Sie in der Message-Datenbankinstanz den Synchronisationsbenutzer an.

Siehe Database Manager GUI, Anlegen/Ändern/Löschen des Synchronisationsbenutzers.

3. Um den Message-Server zu konfigurieren, geben Sie auf dem Rechner, auf dem der Message-Server laufen soll, folgendes Kommando ein:

<independent_program_path>\bin\msgserver config

Sie gelangen in das interaktive Konfigurationsprogramm des Message-Servers.

4. Abhängig von Ihrer Systemumgebung fragt das Konfigurationsprogramm folgende Informationen ab:

○ Verzeichnis, in dem sich Ihre Java-Installation befindet

○ Verzeichnis, in dem sich die Datei j2ee.jar befindet

○ Rechner <msg_database_computer>, auf dem sich die Message-Datenbankinstanz befindet

○ Name der Message-Datenbankinstanz <msg_database>

○ Name und Kennwort des Synchronisationsbenutzers

○ Administrationskennwort für den Message-Server

Sie können dieses Kennwort frei wählen.

○ Administrationsport <msgsrv_admin_port> für den Message-Server (Vorschlagswert: 7220), JNDI-Port <jndi_port> (Vorschlagswert: 7221), JMS-Port <jms_port> (Vorschlagswert: 7222).

Wenn diese Ports auf Ihrem Rechner bereits belegt sind, dann wählen Sie andere Ports. Um herauszufinden, welche Ports bereits belegt sind, geben Sie folgendes Kommando ein: netstat -a

Siehe auch:

Message-Server starten


Synchronisation konfigurieren (SAP-Bibliothek - Werkzeuge)

Prozessdokumentation Synchronisation konfigurieren

Einsatzmöglichkeiten

Bei der Synchronisation protokollieren die Synchronization Services die Änderungen in an der Synchronisation beteiligten Tabellen und replizieren diese Änderungen. Um festzulegen, welche Tabellen in welcher Art und Weise repliziert werden, definieren Sie Replikationseinheiten.

Voraussetzungen

Datenbankinstanzen konfigurieren

Ablauf

...

1. Replikationstabellen definieren (in der Master-Instanz)

2. Replikationseinheiten definieren

3. Replikationseinheiten aktivieren (siehe Replikationseinheiten aktivieren und deaktivieren)

4. Client-Tabellen initialisieren

5. Synchronization Services konfigurieren

Ergebnis

Sie haben die Konfiguration abgeschlossen und können nun die Synchronisation starten.


Replikationstabellen definieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Replikationstabellen definieren

Verwendung

Sie wählen in der Master-Instanz die Tabellen aus, die synchronisiert werden sollen (Replikationstabellen). Optional können Sie Spaltengruppen für Replikationstabellen definieren.

Voraussetzungen

· Sie haben ein Datenmodell entworfen.

· Sie haben den Synchronization Manager GUI konfiguriert.

· Sie haben die Datenbankinstanzen konfiguriert.

· Sie sind mit dem Synchronization Manager GUI als Synchronisationsbenutzer an die Master-Instanz angemeldet.

· Der Synchronisationsbenutzer hat für die Tabellen, die synchronisiert werden sollen, die SELECT-, INSERT-, UPDATE- und DELETE-Privilegien.

Vorgehensweise

...

1. Sie befinden sich auf der Registerkarte Replication Tables.

Wählen Sie Replication Tables ® Add Table...

2. Wählen Sie das Schema aus, zu dem die zu synchronisierenden Tabellen gehören.

3. Wählen Sie die zu synchronisierenden Tabellen aus.

4. Optional können Sie Spaltengruppen für Tabellen definieren.

a. Um eine neue Spaltengruppe für eine Tabelle zu definieren, wählen Sie die Tabelle aus.

b. Wählen Sie New Column Group.

c. Geben Sie einen Namen für die Spaltengruppe ein.

d. Fügen Sie die gewünschten Spalten zum Feld Columns of Columns Group hinzu.

e. Um eine Spaltengruppe zu versionieren, wählen Sie Versioned.

Ergebnis

Nun können Sie für die Replikationstabellen Replikationseinheiten definieren.


Replikationseinheiten definieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Replikationseinheiten definieren

Verwendung

Sie gruppieren die zu synchronisierenden Tabellen in logischen Replikationseinheiten. Sie müssen mindestens eine Master-Replikationseinheit für die Master-Datenbankinstanz und eine Client-Replikationseinheit pro Client-Datenbankinstanz definieren.

Voraussetzungen

● Sie haben ein Datenmodell entworfen.

● Sie haben in der Master-Instanz Replikationstabellen definiert.

● Sie haben das Synchronization Manager GUI gestartet.

● Sie sind als Synchronisierungsbenutzer an die Master-Datenbankinstanz angemeldet.

Master-Replikationseinheit definieren

...

1. Sie befinden sich auf der Registerkarte Replication Units.

Um eine Master-Replikationseinheit zu definieren, wählen Sie Replication Units ® Add Master Unit..

Geben Sie folgende Daten ein:

Feld | Wert
Unit Name | Name der Master-Replikationseinheit
Unit Type | Typ der Master-Replikationseinheit

2. Um Replikationstabellen hinzuzufügen, wählen Sie die Replikationseinheit aus.

Wählen Sie Replication Units ® Add Table...

Wählen Sie das Schema, zu dem die Replikationstabellen gehören.

Wählen Sie die gewünschten Tabellen aus.

3. Optional können Sie Spalten und Spaltengruppen von der Synchronisation ausschließen.

Um eine Spalte oder Spaltengruppe auszuschließen, wählen Sie unter dem Knoten Tables die Replikationstabelle aus.

Entfernen Sie im Bereich Column Filter for Replication die Markierung für die Spalte oder Spaltengruppe.

Client-Replikationseinheit definieren

Führen Sie die folgenden Schritte für alle Client-Datenbankinstanzen durch, die an der Synchronisation teilnehmen sollen.

...

1. Sie befinden sich auf der Registerkarte Replication Units.

Um eine Client-Replikationseinheit zu definieren, wählen Sie die Master-Replikationseinheit aus, zu der die Client-Replikationseinheit gehören soll.

Wählen Sie Replication Units ® Add Client Unit...

Geben Sie folgende Daten ein:

Feld | Wert
Unit Name | Name der Client-Replikationseinheit
Host | Rechner, auf dem sich die Client-Datenbankinstanz befindet
Database | Name der Client-Datenbankinstanz
User | Name des Synchronisierungsbenutzers der Client-Datenbankinstanz
Password | Kennwort des Synchronisierungsbenutzers
Save Password | gibt an, ob der Synchronization Manager das Kennwort sichern soll Der Synchronization Manager sichert das Kennwort im Klartext.
Unit Type | Typ der Client-Replikationseinheit

2. Optional können Sie die Synchronisierungseigenschaften der Client-Tabellen bearbeiten. Dies ist beispielsweise dann notwendig, wenn eine Tabelle in der Client-Instanz einen anderen Namen als in der Master-Instanz hat oder wenn Sie Filter definieren möchten.

Um die Synchronisierungseigenschaften einer einzelnen Client-Tabelle zu bearbeiten, wählen Sie im Bereich Participant Tables die Client-Tabelle.

a. Wählen Sie im Bereich Participant Tables die gewünschte Client-Tabelle.

b. Wählen Sie Edit Table.

c. Bearbeiten Sie die Synchronisierungseigenschaften der Client-Tabelle.

Feld | Wert
Table Schema | Schema, zu dem die Client-Tabelle in der Client-Instanz gehört
Table Name | Name der Client-Tabelle in der Client-Instanz
Master Column | Name der Spalte der Replikationstabelle in der Master-Instanz
Column Name | Name der Spalte der Client-Tabellen in der Client-Instanz
Constraint Typ | Typ der Filterbedingung
Constraint Value1 Constraint Value2 | Werte der Filterbedingung

Um in den Synchronisierungseigenschaften mehrerer Client-Tabellen gleichzeitig das Schema zu ändern, wählen Sie im Bereich Participant Tables die Client-Tabellen.

...

a. Wählen Sie Set Schema.

b. Geben Sie das Schema an, zu dem die Client-Tabellen in der Client-Instanz gehören.

Ergebnis

Sie haben Replikationseinheiten definiert.

Um die Replikationseinheiten für die Synchronisation zu verwenden, müssen Sie diese Replikationseinheiten aktivieren (siehe Replikationseinheiten aktivieren und deaktivieren).


Replikationseinheiten aktivieren und deaktivieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Replikationseinheiten aktivieren und deaktivieren

Verwendung

Damit der Synchronization Manager Änderungen in den Tabellen einer Replikationseinheit protokolliert, müssen Sie die Replikationseinheit aktivieren. Die Protokollierung ist Voraussetzung dafür, dass die Tabellen mehrerer Instanzen synchronisiert werden können.

Voraussetzungen

· Sie haben Replikationseinheiten definiert.

· Sie haben sich mit dem Synchronization Manager GUI an den Message-Server angemeldet.

· Sie haben sich mit dem Synchronization Manager GUI an die Master-Instanz angemeldet, siehe An eine Datenbankinstanz anmelden.

· Sie haben den MaxDB X-Server gestartet.

Replikationseinheiten aktivieren

...

1. Sie befinden sich auf der Registerkarte Replication Units.

Wählen Sie die zu aktivierende Replikationseinheit.

Wählen Sie eines der folgenden Kommandos:

Kommando | Beschreibung
Replication Units ® Activate Master Unit | Master-Replikationseinheit aktivieren
Replication Units ® Activate Client Unit | Client-Replikationseinheit aktivieren
Replication Units ® Activate All Units | alle Replikationseinheiten aktivieren

2. Wenn notwendig, geben Sie das Kennwort des Synchronisierungsbenutzers der entsprechenden Datenbankinstanz ein.

Der Synchronization Manager legt für die Synchronisation in den beteiligten Datenbankinstanzen Schattentabellen und weitere Datenbankobjekte an. Diese Datenbankobjekte sind dem Schema SYNCHRONIZATIONSSERVICE zugeordnet.

Diese Datenbankobjekte dürfen Sie nicht ändern oder löschen.

Wenn das Synchronization Manager GUI keine Verbindung zum Message-Server aufbauen konnte, wird eine entsprechende Fehlermeldung angezeigt. Überprüfen Sie in diesem Fall, ob Sie den Message-Server gestartet haben und ob der Message-Server erreichbar ist. Führen Sie dann folgendes Kommando aus: Replication Units ® Initialize Message Server

Als nächsten Schritt initialisieren Sie die Client-Tabellen.

Replikationseinheiten deaktivieren

...

1. Sie befinden sich auf der Registerkarte Replication Units.

2. Wählen Sie die zu deaktivierende Replikationseinheit.

Wählen Sie eines der folgenden Kommandos:

Kommando | Beschreibung
Replication Units ® Deactivate Master Unit | Master-Replikationseinheit deaktivieren
Replication Units ® Deactivate Client Unit | Client-Replikationseinheit deaktivieren
Replication Units ® Deactivate All Units | alle Replikationseinheiten deaktivieren


Client-Tabellen initialisieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Client-Tabellen initialisieren

Verwendung

Sie initialisieren die Client-Tabellen einer Client-Instanz. Dabei sendet der Synchronization Manager die Daten aus den entsprechenden Master-Tabellen zum Message-Server. Wenn Sie den Synchronisierungsdienst einer Client-Instanz starten, kopiert dieser Synchronisierungsdienst diese Daten in die Client-Tabellen.

Voraussetzungen

· Die Client-Tabellen enthalten keine Datensätze.

Wenn die Client-Tabellen bereits Daten enthalten, dann werden diese Daten bei der Synchronisation nicht berücksichtigt. Beim Initialisieren kopiert der Synchronization Manager auch Datensätze in die Client-Tabellen, die dort bereits vorhanden sind.

· Die Master-Datenbankinstanz und die Client-Datenbankinstanz sind im Betriebszustand ONLINE.

· Sie haben sich mit dem Synchronization Manager GUI an den Message-Server angemeldet.

· Sie haben sich mit dem Synchronization Manager GUI an die Master-Instanz angemeldet, siehe An eine Datenbankinstanz anmelden.

· Sie haben die Replikationseinheiten aktiviert, die an der Synchronisation teilnehmen sollen.

Vorgehensweise

...

1. Sie befinden sich auf der Registerkarte Replication Units.

Wählen Sie die Client-Replikationseinheit, deren Client-Tabellen Sie initialisieren möchten.

2. Wählen Sie Replication Units ® Send Content to Client.

Ergebnis

Die Client-Tabellen enthalten nun alle Daten der Master-Tabellen mit Ausnahme derjenigen Daten, die in den Definitionen der Replikationseinheiten von der Synchronisation ausgeschlossen wurden.

Nun können Sie die Synchronisierungsdienste konfigurieren.


Synchronisierungsdienste konfigurieren (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Synchronisierungsdienste konfigurieren

Verwendung

Sie benötigen je einen Synchronisierungsdienst für jede Master-Instanz und jede Client-Instanz, die an der Synchronisation teilnimmt.

Voraussetzungen

Sie sind auf dem Rechner angemeldet, auf dem sich die Datenbankinstanz <database_name> befindet, für die Sie den Synchronisierungsdienst konfigurieren möchten.

Vorgehensweise

Führen Sie die folgenden Schritte für die Master-Instanz und jede an der Synchronisation beteiligte Client-Instanz durch.

...

1. Führen Sie folgendes Kommando aus:

<independent_program_path>\bin\syncservice config –d <database_name>

2. Geben Sie folgende Daten ein:

Eigenschaft | Wert
synchronization user | Name des Synchronisierungsbenutzers
synchronization user password | Kennwort des Synchronisierungsbenutzers
message server host | Rechner, auf dem der Message-Server läuft
synchronization service admin port | Verwaltungs-Port des Synchronisierungsdienstes (Vorschlagswert ist 7223) Wenn mehrere Synchronisierungsdienste auf dem gleichen Rechner gestartet werden, wählen Sie für jeden dieser Dienste einen eigenen Verwaltungs-Port, wie z. B. 7223 und 7224
JNDI port of message server | JNDI-Port des Message-Servers (Vorschlagswert 7221) Wenn Sie bei der Konfiguration des Messages-Servers einen anderen Port als den Vorschlagswert gewählt haben, dann tragen Sie diesen Port hier ein.
service port of message server | JMS-Port des Message-Servers (Vorschlagswert 7222) Wenn Sie bei der Konfiguration des Messages-Servers einen anderen Port als den Vorschlagswert gewählt haben, dann tragen Sie diesen Port hier ein.

Siehe auch:

Synchronisierungsdienste starten und stoppen


Synchronization Manager GUI starten (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Synchronization Manager GUI starten

Voraussetzungen

Synchronization Manager GUI konfigurieren

Vorgehensweise

...

1. Geben Sie auf dem Rechner, auf dem Sie das Synchronization Manager GUI konfiguriert haben, folgendes Kommando ein:

<independent_program_path>\bin\syncmangui

2. Wenn Sie das Synchronization Manager GUI zum ersten Mal starten und zuvor noch nie den Message-Server oder einen Synchronisierungsdienst gestartet haben, dann fragt das System Sie nach dem Pfad Ihrer Java-Installation und dem Pfad der Datei j2ee.jar aus Ihrer J2EE-Installation.

Das System speichert diese Angaben in der Datei syncman.cfg. Diese Datei befindet sich auf Microsoft Windows im Verzeichznis <user_home>\sdb, auf UNIX/Linux im Verzeichnis <user_home>/.sdb.

Siehe auch:

Installationshandbuch, Strukturlink Verzeichnisse


An eine Datenbankinstanz anmelden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen An eine Datenbankinstanz anmelden

Voraussetzungen

● Die Datenbankinstanz ist im Betriebszustand ONLINE, siehe

○ Database Manager GUI, Betriebszustand überwachen

○ Database Manager CLI, db_online

● Sie haben das Synchronization Manager GUI gestartet.

Vorgehensweise

...

1. Wählen Sie Session ® Connect to Database...

2. Geben Sie folgende Daten ein:

Feld | Wert
Host | Name des Rechners, auf dem die Datenbankinstanz läuft
Database | Datenbankname
Service User | Name des Synchronisationsbenutzers der Datenbankinstanz
Password | Kennwort des Synchronisationsbenutzers
SSL Connection | nur in SAP-Systemen gibt an, ob die Verbindung zwischen Synchronization Manager GUI und der Datenbankinstanz verschlüsselt werden soll


Message-Server starten und stoppen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Message-Server starten und stoppen

Voraussetzungen

● Message-Server konfigurieren

● Die Message-Datenbankinstanz ist im Betriebszustand ONLINE. Siehe

○ Database Manager GUI, Starten der Datenbankinstanz (Restart)

○ Database Manager CLI, db_online

Message-Server starten

Geben Sie folgendes Kommando ein:

<independent_program_path>\bin\msgserver start

Message-Server stoppen

Geben Sie folgendes Kommando ein:

<independent_program_path>\bin\msgserver stop

Siehe auch:

Installationshandbuch, Strukturlink Verzeichnisse


An den Message-Server anmelden (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen An den Message-Server anmelden

Voraussetzungen

· Sie haben den Message-Server gestartet.

· Sie haben Synchronization Manager GUI gestartet.

Vorgehensweise

...

1. Wählen Sie Session ® Connect to Message Server

2. Geben Sie folgende Daten ein:

Feld | Wert
Host | Rechner, auf dem der Message-Server läuft
Port | Port des Message-Servers
Password | Administrationskennwort für den Message-Server Beachten Sie die Hinweise in Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter.
SSL Connection | nur in SAP-Systemen gibt an, ob die Verbindung zwischen dem Synchronization Manager GUI und dem Message-Server verschlüsselt wird


Synchronisation (SAP-Bibliothek - Werkzeuge)

Prozessdokumentation Synchronisation

Einsatzmöglichkeiten

Eine Master-Datenbankinstanz und eine oder mehrerer Client-Datenbankinstanzen synchronisieren ihre Daten.

Sie können eine Datenbankinstanz zwischenzeitlich vom Netzwerk trennen. Wenn Sie die Datenbankinstanz wieder an das Netzwerk anschließen, müssen Sie den Synchronisierungsdienst für diese Datenbankinstanz starten. Der Synchronisierungsdienst sorgt dann dafür, dass alle Daten der Datenbankinstanz aktualisiert werden und schickt gegebenenfalls Datenänderungen an die anderen Datenbankinstanzen.

Voraussetzungen

· Sie haben die Konfiguration abgeschlossen.

· Sie haben den Message-Server gestartet.

Ablauf

...

1. Synchronisierungsdienste starten

2. Sie können nun Daten in einer oder mehreren der Datenbankinstanzen ändern.

Der Synchronisierungsdienst, der zur jeweiligen Datenbankinstanz gehört, überträgt die Änderungen an den Message-Server und holt sich vom Message-Server die Änderungen der anderen Datenbankinstanzen ab. Der Synchronisierungsdienst löst Änderungskollisionen auf.


Synchronisierungsdienste starten und stoppen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Synchronisierungsdienste starten und stoppen

Verwendung

Die Synchronisierungsdienste haben folgende Aufgaben:

● Protokollieren aller Datenänderungen in Tabellen, die an der Synchronisation teilnehmen

● Senden dieser Datenänderungen an den Message-Server

● Empfangen von Datenänderungen anderer an der Synchronisation beteiligter Datenbankinstanzen

Voraussetzungen

● Sie haben die Synchronisierungsdienste konfiguriert.

● Sie haben den Message-Server gestartet.

● Sie sind auf dem Rechner mit der Datenbankinstanz <database_name>, die an der Synchronisation teilnehmen soll, angemeldet.

Synchronisierungsdienst starten

Geben Sie folgendes Kommando für jede Datenbankinstanz ein, die an der Synchronisation teilnehmen soll:

<independent_program_path>\bin\syncservice start –d <database_name>

Synchronisierungsdienst stoppen

Geben Sie folgendes Kommando ein

<independent_program_path>\bin\syncservice stop –d <database_name>

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter

Installationshandbuch, Strukturlink Verzeichnisse


Utilities (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Utilities

Einsatzmöglichkeiten

In dieser Dokumentation werden die folgenden Strukturlink Datenbankwerkzeuge beschrieben:

● Event-Dispatcher: Der Event-Dispatcher nimmt die von der Datenbankinstanz ausgegebenen Events entgegen und reagiert darauf.

● XCONS: Abfragen von Informationen zu Datenbankinstanzen

● XUSER: Anlegen und Verwalten von XUSER-Einträgen für eine vereinfachte Anmeldung an Datenbankwerkzeuge und Schnittstellen mit Benutzerschlüsseln

Außerdem wird folgendes Programm beschrieben:

● X-Server: Kommunikationsserver des Datenbanksystems

Einführungshinweise

Die Programme sind Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.


Event-Dispatcher (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation Event-Dispatcher

Einsatzmöglichkeiten

Event-Dispatcher überwachen Datenbankinstanzen. Wenn in einer von einem Event-Dispatcher überwachten Datenbankinstanz eine definierte Situation eintritt und das Datenbanksystem ein Event auslöst, dann führt der Event-Dispatcher eine definierte Aktion aus.

Event-Dispatcher können Sie verwenden, um Verwaltungsaufgaben zu automatisieren.

Der Event-Dispatcher ist ein Kommandozeilenwerkzeug und kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden.

Einführungshinweise

Der Event-Dispatcher ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Integration

Um Events zu aktivieren und zu deaktivieren, verwenden Sie das Datenbankwerkzeug Database Manager CLI (Siehe Database Manager CLI, Nutzen von Events der Datenbankinstanz).

Das Datenbanksystem nutzt den Event-Dispatcher implizit für die automatische Erweiterung des Datenbereichs (DBM-Kommando auto_extend) und das automatische Aktualisieren der Statistiken des SQL-Optimierers (DBM-Kommando auto_update_statistics).

Funktionsumfang

Event-Dispatcher können folgende Arten von Events behandeln:

● Events zum Automatisieren von Verwaltungsaufgaben der Datenbankinstanz
(Siehe: Konzepte des Datenbanksystems, Strukturlink Übersicht der Datenbank-Event-Kategorien)

● Events, die Auskunft über den Zustand des Event-Dispatchers geben
(Siehe: Spezielle Events des Event-Dispatchers)

Event-Dispatcher in Betrieb nehmen

Übersicht der Event-Dispatcher-Kommandos

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Glossar, Strukturlink Syntaxnotation

Tutorial Datenbankverwaltung, Strukturlink Log-Bereich automatisch sichern nach Event LOGABOVELIMIT


Event-Dispatcher in Betrieb nehmen (SAP-Bibliothek - Werkzeuge)

Prozessdokumentation Event-Dispatcher in Betrieb nehmen

Verwendung

Sie starten den Event-Dispatcher und automatisieren damit die Reaktionen des Datenbanksystems auf bestimmte Events. Auf welche Events und wie das Datenbanksystem reagieren soll, definieren Sie in der Konfigurationsdatei des Event-Dispatchers.

Voraussetzungen

● Sie haben die Konfigurationsdatei für diesen Event-Dispatcher angelegt (Siehe: Konfiguration für den Event-Dispatcher)

● Die Events, deren Behandlung in der Konfigurationsdatei beschrieben ist, sind aktiv.

Zum Aktivieren eines Events siehe Database Manager, event_set.

Eine Übersicht der Events, die Sie aktivieren und deaktivieren können, finden Sie in Konzepte des Datenbanksystems, Strukturlink Übersicht der Datenbank-Eventkategorien.

Die speziellen Events des Event-Dispatchers müssen Sie nicht aktivieren.

Ablauf

...

1. Sie fügen mit dem Kommando add eine neue Definition in die Konfigurationsdatei des Event-Dispatchers ein.

Wenn noch keine Konfigurationsdatei existiert, dann legt der Event-Dispatcher beim Ausführen des add-Kommandos eine Konfigurationsdatei an.

2. Wenn der Event-Dispatcher noch nicht gestartet wurde, dann starten Sie mit dem Kommando start den Event-Dispatcher mit dieser Konfigurationsdatei.

Ergebnis

Der Event-Dispatcher überwacht die Datenbankinstanz.

Wenn die überwachte Datenbankinstanz ein Event auslöst, dann analysiert der Event-Dispatcher das Event. Wenn er in seiner Konfigurationsdatei einen entsprechenden Eintrag findet, dann ruft er das dort festgelegte Programm auf und übergibt ihm gegebenenfalls Parameter.

Siehe auch:

Übersicht der Event-Dispatcher-Kommandos

Konzepte des Datenbanksystems, Strukturlink Verwaltungsaufgaben automatisieren

Tutorial Datenbankverwaltung, Strukturlink Log-Bereich automatisch sichern nach Event LOGABOVELIMIT


Konfiguration für den Event-Dispatcher (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Konfiguration für den Event-Dispatcher

Verwendung

Bevor Sie einen Event-Dispatcher starten können, müssen Sie die Konfigurationsdatei des Event-Dispatchers anlegen. Darin definieren Sie, in welcher Weise ein vom Datenbanksystem geschicktes Event behandelt werden soll.

Es können nur solche Events vom Datenbanksystem geschickt werden, die immer aktiv sind oder die Sie im Database Manager gesetzt und damit aktiviert haben (Siehe: Database Manager CLI, event_set).

Sie müssen außerdem sicherstellen, dass der Datenbankparameter für die maximale Anzahl der Event-Tasks ausreichend groß konfiguriert ist, da jeder Event-Dispatcher eine eigene Event-Task benötigt.

Die DBM-Kommandos auto_extend und auto_update_statistics verwenden implizit einen Event-Dispatcher und benötigen jeweils eine eigene Event-Task.

Aktivitäten

● Um einen Event-Dispatcher zu konfigurieren, tragen Sie Event-Definitionen in die Konfigurationsdatei ein.

Siehe add-Kommando.

● Um die maximale Anzahl der Event-Dispatcher für eine Datenbankinstanz festzulegen, konfigurieren Sie den Datenbankparameter _MAXEVENTTASKS.

Siehe Konzepte des Datenbanksystems, Strukturlink Support-Datenbankparameter

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Übersicht der Datenbank-Eventkategorien


Spezielle Events des Event-Dispatchers (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Spezielle Events des Event-Dispatchers

Verwendung

Die speziellen Events des Event-Dispatchers geben Auskunft über den Zustand des Event-Dispatchers.

Sie sind immer aktiv und müssen deshalb nicht mit Hilfe des Database Manager CLI aktiviert werden.

Siehe auch:

Event-Dispatcher

Übersicht der speziellen Events des Event-Dispatchers

Name | Wann wird es von der Datenbankinstanz ausgelöst?
DISPINFO:DISPSTART | Ein Benutzer hat den Event-Dispatcher gestartet.
DISPINFO:DISPSTOP | Ein Benutzer hat den Event-Dispatcher gestoppt.
DISPWARN:SHUTDOWN | Die Datenbankinstanz wurde in den Betriebszustand OFFLINE überführt.
DISPERR:DBCRASH | Das Datenbanksystem ist abgestürzt (Systemausfall).
DISPERR:CONNLOST | Der Event-Dispatcher hat die Verbindung zum DBM-Server verloren. Wenn Sie den Event-Dispatcher auf demselben Rechner wie die Datenbankanwendung gestartet haben, dann können Sie dieses Event z. B. dazu verwenden, um über den Ausfall der Netzwerkverbindung zwischen Datenbankanwendung und Datenbankinstanz informiert zu werden.
DISPWARN:MISSEDEVT | Das Datenbanksystem hat ein Event ausgelöst, auf das der Event-Dispatcher jedoch nicht reagiert hat.
DISPERR:NOEVENTTASK | Der Event-Dispatcher konnte nicht gestartet werden, weil keine Event-Task mehr frei war. Um die Anzahl der Event-Tasks zu konfigurieren, verwenden Sie den Datenbankparameter _MAXEVENTTASKS, siehe Konzepte des Datenbanksystems, Strukturlink Support-Datenbankparameter.

Siehe auch:

Übersicht der Event-Dispatcher-Kommandos


Übersicht der Event-Dispatcher-Kommandos (SAP-Bibliothek - Werkzeuge)

Hintergrunddokumentation Übersicht der Event-Dispatcher-Kommandos

Event-Dispatcher-Kommandos

Kommando | Beschreibung
add | neuen Eintrag zu einer Event-Dispatcher-Konfigurationsdatei hinzufügen
delete | Eintrag aus einer Event-Dispatcher-Konfigurationsdatei löschen
list | Inhalt einer Event-Dispatcher-Konfigurationsdatei anzeigen
start | Event-Dispatcher starten
state | Zustand aller Event-Dispatcher der Datenbankinstanz anzeigen
stop | Event-Dispatcher beenden
version | Informationen zur Softwareversion der Event-Dispatcher anzeigen

Siehe auch:

Database Manager CLI, Nutzen von Events der Datenbankinstanz


add (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen add

Verwendung

Sie fügen einen neuen Eintrag zu einer Event-Dispatcher-Konfigurationsdatei hinzu.

Ein Eintrag in einer Konfigurationsdatei ordnet Bedingungen (Event-Kategorie und weitere Eigenschaften des Events) einem Kommando des Database Manager CLI oder eines anderen Programms zu.

Wenn der Event-Dispatcher, der die Konfigurationsdatei verwendet, bereits gestartet wurde, dann berücksichtigt er sofort den neuen Eintrag.

Voraussetzungen

Das Event, deren Behandlung in der Konfigurationsdatei definiert werden soll, ist aktiv.

Eine Übersicht jener Events, die immer aktiv sind, sowie jener, die Sie aktivieren und deaktivieren können, finden Sie in Konzepte des Datenbanksystems, Strukturlink Übersicht der Datenbank-Event-Kategorien.

Die speziellen Events des Event-Dispatchers sind immer aktiv.

Vorgehensweise

dbmevtdisp add <configuration_file> <condition> <command>

<condition> :: = Name == <event_category> [Priority == HIGH|MEDIUM|LOW] [Value1 ==|>=|<=|>|< <NumVal>] [Value2 ==|>=|<=|>|< <NumVal>]

<command> :: = Command == <program> [<parameter_list>]

<parameter_list> :: = <parameter> | <parameter> <parameter> …

Option | Beschreibung
<configuration_file> | Konfigurationsdatei mit vollständigem Pfad Wenn diese Datei noch nicht existiert, dann legt der Event-Dispatcher sie beim Ausführen des add-Kommandos im aktuellen Verzeichnis an.
<condition> | Bedingung, die erfüllt sein muss, damit der Event-Dispatcher das Kommando <command> ausführt. Syntax:
<command> | Kommando, das beim Eintreten der Bedingung <condition> ausgeführt werden soll
<event_category> | Eventkategorie Sie können das *-Zeichen als Platzhalter verwenden.
<NumVal> | Werte, die der Event-Dispatcher mit den Werten VALUE1 und VALUE2 vergleicht, die das Datenbanksystem beim Eintreten eines Events liefert (weitere Informationen zum Datenbankzustand, abhängig von der Event-Kategorie)
<program> | Programm (und gegebenenfalls Kommando dieses Programms), das beim Eintreten des Events aufgerufen werden soll
<parameter> | Parameter, die der Event-Dispatcher beim Eintreten des Events an das Programm <program> übergeben soll Sie können beliebige Parameter angeben. Eine Liste spezieller vordefinierter Platzhalter, die Sie anstelle der Parameter verwenden können, finden Sie in der folgenden Tabelle.

Die folgende Tabelle enthält definierte Platzhalter, die Sie in der Konfigurationsdatei eines Event-Dispatchers verwenden können:

Platzhalter | Beschreibung
$DBNAME$ | Name der überwachten Datenbankinstanz
$DBMUSERPW$ | Name und Kennwort des DBM-Benutzers, mit denen sich der Event-Dispatcher an der Datenbankinstanz anmeldet.
$EVTNAME$ | Eventkategorie
$EVTVAL1$ | erster Wert VALUE1, den das Datenbanksystem beim Eintreten des Events liefert (weitere Informationen zum Datenbankzustand, abhängig von der Event-Kategorie)
$EVTVAL2$ | zweiter Wert VALUE2, den das Datenbanksystem beim Eintreten des Events liefert (weitere Informationen zum Datenbankzustand, abhängig von der Event-Kategorie)
$EVTDATE$ | Datum, an dem das Event ausgelöst wurde
$EVTTIME$ | Zeit, zu der das Event ausgelöst wurde
$EVTTEXT$ | Beschreibungstext des Events
$EVTCOUNT$ | Anzahl, wie oft das Event bereits ausgelöst wurde
$EVTPRIO$ | Priorität des Events
$SERVERNAME$ | Datenbankrechner

Ergebnis

OK
<entry_ID>

Sie erhalten eine numerische ID angezeigt, die den neu angelegten Eintrag in der Konfigurationsdatei identifiziert. Sie verwenden diese ID, um den Eintrag wieder aus der Konfigurationsdatei zu löschen.

Beispiel

Sie erzeugen in der Konfigurationsdatei C:\test\testconfig.cfg einen neuen Eintrag. Wenn ein Event-Dispatcher mit dieser Konfigurationsdatei gestartet wird, dann bewirkt dieser Eintrag Folgendes: wenn der Event-Dispatcher ein LOGFULL-Event empfängt, ruft er das Programm alarmapp auf und übergibt diesem Programm als Parameter den Namen der Datenbankinstanz, die das Event ausgelöst hat.

dbmevtdisp add C:\test\testconfig.cfg Name == LOGFULL Command == "alarmapp $DBNAME$"

OK
2

Der Event-Dispatcher hat dem neu erzeugten Eintrag in der Konfigurationsdatei die ID 2 zugewiesen.

Siehe auch:

Konfiguration für den Event-Dispatcher

Tutorial Datenbankverwaltung, Strukturlink Log-Bereich automatisch sichern nach Event LOGABOVELIMIT


delete (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen delete

Verwendung

Sie löschen einen Eintrag aus einer Event-Dispatcher-Konfigurationsdatei. Das Löschen des Eintrags wird sofort wirksam.

Voraussetzungen

Sie haben eine Event-Dispatcher-Konfigurationsdatei angelegt und mit dem Kommando add Einträge zu dieser Konfigurationsdatei hinzugefügt.

Vorgehensweise

dbmevtdisp delete <entry_ID> <configuration_file>

Option | Beschreibung
<entry_ID> | numerische ID, die den zu löschenden Eintrag in der Konfigurationsdatei identifiziert Diese ID erzeugt der Event-Dispatcher beim Hinzufügen von Einträgen. Um die Einträge einer Konfigurationsdatei anzuzeigen, verwenden Sie das list-Kommando.
<configuration_file> | Pfad und Name der Konfigurationsdatei, aus der Eintrag gelöscht werden soll

Ergebnis

OK

Beispiel

Sie löschen den Eintrag mit der ID 2 aus der Konfigurationsdatei C:\test\testconfig.cfg.

dbmevtdisp delete 2 C:\test\testconfig.cfg

OK


list (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen list

Verwendung

Sie zeigen den Inhalt einer Event-Dispatcher-Konfigurationsdatei an.

Voraussetzungen

Sie haben eine Konfigurationsdatei <configuration_file> für einen Event-Dispatcher angelegt und mit dem Kommando add Event-Definitionen in dieser Konfigurationsdatei gespeichert.

Vorgehensweise

dbmevtdisp list <configuration_file>

<configuration_file>

Name und Pfad der Konfigurationsdatei des Event-Dispatchers

Ergebnis

OK
ID <entry_ID_1>
condition: <condition_1>
command: <command_1>
.
.
.
ID <entry_ID_n>
condition: <condition_n>
command: <command_n>

Feld | Beschreibung
<entry_ID_n> | numerische ID, die die Event-Definition in der Konfigurationsdatei identifiziert
<condition_n> | Bedingung, die erfüllt sein muss, damit der Event-Dispatcher das Kommando <command_n> ausführt.
<command_n> | Kommando, das beim Eintreten der Bedingung <condition_n> ausgeführt werden soll

Beispiel

Sie zeigen den Inhalt der Konfigurationsdatei C:\test\testconfig.cfg an.

dbmevtdisp list C:\test\testconfig.cfg

OK
ID 0
condition: ((Name == "DBFILL*") && (Value1 < 10))
command: alarmapp $DBNAME$
ID 1
condition: ((Name == "UPDSTATWANTED"))
command: dbmcli -d $DBNAME$ -u $DBMUSERPW$ sql_updatestat_per_systemtable

Die Konfigurationsdatei enthält folgende Einträge:

● Eintrag mit der ID 0

Wenn der Event-Dispatcher ein Event empfängt, dessen Name mit der Zeichenkette DBFILL beginnt und dessen Value1-Feld einen Wert kleiner als 10 enthält, dann startet er das Programm alarmapp und übergibt dem Programm als Parameter den Namen der Datenbankinstanz, die das Event ausgelöst hat.

● Eintrag mit der ID 1

Wenn der Event-Dispatcher ein Event mit dem Namen UPDSTATWANTED empfängt, dann meldet er sich mit dem Datenbankwerkzeug Database Manager CLI an die Datenbankinstanz an, die das Event ausgelöst hat. Hierbei verwendet er Namen und Kennwort des DBM-Benutzers, der den Event-Dispatcher gestartet hat. Dann führt er das DBM-Kommando sql_updatestat_per_systemtable aus.

Siehe auch:

Übersicht der Event-Dispatcher-Kommandos


start (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen start

Verwendung

Sie starten einen Event-Dispatcher, der eine Datenbankinstanz überwacht.

Voraussetzungen

● Sie haben mit dem add-Kommando Einträge zu einer Event-Dispatcher-Konfigurationsdatei hinzugefügt.

● Damit der Event-Dispatcher sich an die Datenbankinstanz anmelden kann, benötigen Sie Name und Kennwort eines DBM-Benutzers, der die Serverberechtigung DBInfoRead und mindestens eine der Serverberechtigungen EvtDispAdmin | EvtDispUse hat.

Vorgehensweise

dbmevtdisp start [-remoteaccess] <configuration_file> -l <log_file> <database_authentication>

<database_authentication> :: = -d <database_name> <user_authentication> [-n <database_computer>] [-e SSL]

<user_authentication> :: = -u <user_data> |-U <user_key>

<user_data> :: = <dbm_operator>,<dbm_operator_password>

Option

Beschreibung

-remoteaccess

Wenn Sie diese Option nicht angeben, dann können Sie den Event-Dispatcher nur vom Datenbankrechner und von dem Rechner aus wieder stoppen, von dem aus Sie ihn auch gestartet haben.

Wenn Sie diese Option angeben, dann können Sie den Event-Dispatcher von einem beliebigen Rechner aus stoppen.

<configuration_file>

Konfigurationsdatei, die der Event-Dispatcher verwenden soll.

Wir empfehlen, die Konfigurationsdatei auf dem Rechner anzulegen, auf dem Sie den Event-Dispatcher starten werden.

<log_file>

Protokolldatei des Event-Dispatchers

Wenn die Datei noch nicht existiert, wird sie unter dem angegebenen Namen vom Event-Dispatcher angelegt.

<database_name>

Name der zu überwachenden Datenbankinstanz

<database_computer>

Name des Datenbankrechners

SSL

Verschlüsselungsmethode

Siehe Database Manager CLI, -e: Verschlüsselung aktivieren

<user_key>

XUSER-Schlüssel

Siehe Utilities, XUSER

<dbm_operator>,<dbm_operator_password>

DBM-Benutzerdaten, mit denen sich der Event-Dispatcher an die zu überwachende Datenbankinstanz anmeldet

Siehe Database Manager CLI, user_logon

Ergebnis

Event Dispatcher instance <instance_ID> running
using configuration file <configuration_file>

Das Datenbanksystem weist dem Event-Dispatcher eine numerische ID <instance_ID> zu. Diese ID ist eindeutig für die Datenbankinstanz, die der Event-Dispatcher überwacht. Sie benötigen die ID, um den Event-Dispatcher zu stoppen.

Beispiel

Sie starten einen Event-Dispatcher, der die Konfigurationsdatei C:\test\testconfig.cfg und die Protokolldatei C:\test\mylog.log verwendet und sich mit den Authentifizierungsdaten des DBM-Benutzers OLEG mit Kennwort MONDAY an die Datenbankinstanz DEMODB auf dem Datenbankrechner PARMA anmeldet.

dbmevtdisp start C:\test\testconfig.cfg –l C:\test\mylog.log –d DEMODB -u OLEG,MONDAY –n PARMA

Siehe auch:

Übersicht der Event-Dispatcher-Kommandos


state (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen state

Verwendung

Sie zeigen den Zustand aller Event-Dispatcher an, die zu einer Datenbankinstanz gehören.

Voraussetzungen

DBM-Benutzer mit folgenden Eigenschaften können das Kommando state verwenden:

● DBM-Benutzer mit der Serverberechtigung EvtDispAdmin erhalten eine Liste aller Event-Dispatcher der Datenbankinstanz.

● DBM-Benutzer mit der Serverberechtigung EvtDispUse erhalten eine Liste derjenigen Event-Dispatcher, die unter ihrem Benutzernamen gestartet wurden.

Vorgehensweise

dbmevtdisp state <database_authentication>

<database_authentication> :: = -d <database_name> <user_authentication> [-n <database_computer> [-e SSL]]

<user_authentication> :: = -u <user_data> | -U <user_key>

<user_data> :: = <dbm_operator>,<dbm_operator_password>

Option | Beschreibung
<database_name> | Name der überwachten Datenbankinstanz
<database_computer> | Name des Datenbankrechners
SSL | Verschlüsselungsmethode Siehe Database Manager CLI, -e: Verschlüsselung aktivieren
<user_key> | XUSER-Schlüssel Siehe Utilities, XUSER
<dbm_operator>,<dbm_operator_password> | DBM-Benutzerdaten, mit denen sich der Event-Dispatcher an die zu überwachende Datenbankinstanz anmeldet Siehe Database Manager CLI, user_logon

Ergebnis

OK
Instance ID <instance_ID_1>
user: <dbm_user_name_1>
host: <database_computer_1>
configuration file: <configuration_file_1>
log file: <log_file_1>
.
.
.
Instance ID <instance_ID_n>
user: <dbm_user_name_n>
host: <database_computer_n>
configuration file: <configuration_file_n>
log file: <log_file_n>

Feld | Beschreibung
<instance_ID_n> | ID des Event-Dispatchers n
<dbm_user_name_n> | DBM-Benutzer, der den Event-Dispatcher n gestartet hat
<database_computer_name_n> | Datenbankrechner, auf dem der Event-Dispatcher n läuft
<configuration_file_n> | Konfigurationsdatei, die der Event-Dispatcher n verwendet
<log_file_n> | Protokolldatei, die der Event-Dispatcher n verwendet

Beispiel

Der DBM-Benutzer OLEG mit Kennwort MONDAY zeigt die Event-Dispatcher der Datenbankinstanz DEMODB auf dem lokalen Rechner an:

>dbmevtdisp state -d DEMODB -u OLEG,MONDAY

OK
Instance ID 1
user: OLEG
host: PARMA
configuration file: testconfig.cfg
log file: mylog.log
Instance ID 0
user: DBADMIN
host: GENUA
configuration file: ed.cfg
log file: ed.log

Folgende Event-Dispatcher der Datenbankinstanz DEMODB laufen zur Zeit:

● Event-Dispatcher mit der ID 1

○ gestartet vom DBM-Benutzer OLEG auf dem Rechner PARMA

○ Konfigurationsdatei testconfig.cfg

○ Protokolldatei mylog.log

● Event-Dispatcher mit der ID 0

○ gestartet vom DBM-Benutzer DBADMIN auf dem Rechner GENUA

○ Konfigurationsdatei ed.cfg

○ Protokolldatei ed.log

Siehe auch:

Übersicht der Event-Dispatcher-Kommandos


stop (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen stop

Verwendung

Sie stoppen einen Event-Dispatcher.

Voraussetzungen

● Der Event-Dispatcher wurde gestartet und hat dabei vom Datenbanksystem eine numerische ID <instance_ID> erhalten (siehe start).

● Wenn beim Starten des Event-Dispatchers die Option –remoteaccess nicht angegeben wurde, dann können Sie den Event-Dispatcher nur vom Datenbankrechner oder von dem Rechner aus stoppen, von dem aus er auch gestartet wurde.

● Damit der Event-Dispatcher sich an die Datenbankinstanz anmelden kann, benötigen Sie Name und Kennwort eines DBM-Benutzers mit folgenden Eigenschaften:

○ DBM-Benutzer mit der Serverberechtigung EvtDispAdmin können alle Event-Dispatcher stoppen

○ DBM-Benutzer mit der Server-Berechtigung EvtDispUse können nur diejenigen Event-Dispatcher stoppen, die unter ihrem Benutzernamen gestartet wurden.

Vorgehensweise

dbmevtdisp stop <instance_ID> <database_authentication>

<database_authentication> :: = -d <database_name> <user_authentication> [-n <database_computer>] [-e SSL]

<user_authentication> :: = -u <user_data> |-U <user_key>

<user_data> :: = <dbm_operator>,<dbm_operator_password>

Option | Beschreibung
<instance_ID> | ID des Event-Dispatchers, den Sie stoppen möchten
<database_name> | Name der zu überwachenden Datenbankinstanz
<database_computer> | Name des Datenbankrechners
SSL | Verschlüsselungsmethode Siehe Database Manager CLI, -e: Verschlüsselung aktivieren
<user_key> | XUSER-Schlüssel Siehe Utilities, XUSER
<dbm_operator>,<dbm_operator_password> | DBM-Benutzerdaten, mit denen sich der Event-Dispatcher an die zu überwachende Datenbankinstanz anmeldet Siehe Database Manager CLI, user_logon

Ergebnis

OK

Siehe auch:

Übersicht der Event-Dispatcher-Kommandos


version (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen version

Verwendung

Sie zeigen Informationen zur Softwareversion des Event-Dispatchers an.

Vorgehensweise

dbmevtdisp version

Ergebnis

MaxDB Event Dispatcher, Version <version>
<copyright>

Feld | Beschreibung
<version> | Softwareversion des Event-Dispatchers
<copyright> | Copyright

Siehe auch:

Übersicht der Event-Dispatcher-Kommandos


XCONS (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation XCONS

Einsatzmöglichkeiten

Das Strukturlink Datenbankwerkzeug XCONS (Datenbankkonsole) dient dazu, die vom Datenbanksystem belegten Betriebssystemressourcen, die Aufteilung der Datenbanksitzungen auf Threads sowie den Status der aktiven Datenbanksitzungen anzuzeigen.

Wir empfehlen, XCONS in produktiven Systemen nur dann zu verwenden, wenn Sie über ein fundiertes Datenbank- und Betriebssystemwissen verfügen.

XCONS ist ein Kommandozeilenwerkzeug und kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden.

Einführungshinweise

XCONS ist Bestandteil der MaxDB-Software, die Sie über die MaxDB-Website herunterladen können (siehe Strukturlink Download und Strukturlink Installationsprofile).

Weiterführende Informationen zum Datenbanksystem finden Sie in den Dokumentationen Strukturlink Konzepte des Datenbanksystems und Strukturlink Glossar.

Integration

Sie können XCONS auch über den Database Manager CLI und über die Datenbankkonsole des CCMS (in SAP-Systemen) aufrufen.

Funktionsumfang

Sie können XCONS für Anzeigen von Informationen zur Datenbankinstanz einsetzen.

Das Datenbankwerkzeug Database Analyzer verwendet XCONS.


Anzeigen von Informationen zur Datenbankinstanz (SAP-Bibliothek - Werkzeuge)

Diese Grafik wird im zugehörigen Text erklärt Anzeigen von Informationen zur Datenbankinstanz

Vorgehensweise

Die folgenden Abschnitte beschreiben, wie Sie XCONS direkt auf der Kommandozeile aufrufen können. Wir empfehlen jedoch, XCONS nicht direkt auf der Kommandozeile, sondern immer über den Database Manager CLI oder das CCMS aufzurufen. Auf diese Weise vermeiden Sie unter anderem Probleme mit Zugriffsrechten auf Unix/Linux.

Siehe:

○ Database Manager CLI, show

○ Datenbankverwaltung im CCMS, Strukturlink Datenbankkonsole (nur in SAP-Systemen)

Syntax

x_cons <database_name> <command> [<interval> [<repeat>]]

<command> | XCONS-Kommando
<interval> | Zeit zwischen zwei Wiederholungen desselben Kommandos. Wenn Sie <interval> nicht angeben, dann wird das Kommando einmal ausgeführt.
<repeat> | Anzahl der Wiederholungen des Kommandos. Wenn Sie <interval> angeben, <repeat> jedoch nicht, dann wird das Kommando unendlich oft wiederholt.

XCONS-Kommandos

affinity <uktindex>

Beachten Sie, dass dieses Kommando für Entwicklungsaufgaben konzipiert wurde und deswegen nicht im Produktivbetrieb verwendet werden sollte. Setzen Sie dieses Kommando nur nach Aufforderung durch den Support ein.

Mit diesem Kommando erlauben Sie, dass der User-Kernel-Thread mit dem Index uktindex an einen Prozessor gebunden werden darf.

cancel <taskindex>

Abbrechen des Kommandos, das von der Task mit dem Index <taskindex> gerade ausgeführt wird

diagnose_pagecache

Analyse des Page-Cache. Die Ergebnisse werden in die Kernprotokolldatei geschrieben (siehe Konzepte des Datenbanksystems, Strukturlink Protokolldateien).

kill <taskindex>

Beenden der Sitzung der Task mit dem Index <taskindex>

pagecache_release

Freigeben des Page-Cache

procmask <procmask>

Beachten Sie, dass dieses Kommando für Entwicklungsaufgaben konzipiert wurde und deswegen nicht im Produktivbetrieb verwendet werden sollte. Setzen Sie dieses Kommando nur nach Aufforderung durch den Support ein.

Nur unter Microsoft Windows. Festes Binden von User-Kernel-Threads an einzelne Prozessoren

show active [dw | sv | us | gc]

Anzeigen von Statistiken zu den aktiven Tasks.

Optional können Sie nur Statistiken bestimmter Task-Gruppen anzeigen: DW (Data-Writer=Pager), SV (Server-Task), US (User-Task), GC (Garbage-Collector).

show aio

Nur für Backups; Anzeigen von Statistiken zum Zugriff auf die Volumes

show all

Anzeigen aller verfügbaren Informationen und Statistiken

show io

Anzeigen von Statistiken zum Zugriff auf die Volumes

show moveinfo

Nur für Load-Balancing; Historie und aktuelle Bewegungen von Tasks zwischen User-Kernel-Threads

show queues

Anzeigen der Warteschlangen

show regions

Anzeigen von Informationen zu den kritischen Abschnitten

show rte

Anzeigen von Informationen zur Laufzeitumgebung (Threads etc.)

show runnable [dw | sv | us | gc]

Anzeigen von Informationen zu den lauffähigen Tasks; optional nur für einzelne Task-Gruppen

show sleep

Anzeigen von Statistiken, wie lange die einzelnen User-Kernel-Threads suspendiert waren

show state

Anzeigen des Betriebszustands der Datenbankinstanz

Zusätzlich zu den Betriebszuständen werden hier auch Zwischenzustände angezeigt, in denen sich die Datenbankinstanz kurzfristig beim Übergang zwischen zwei Betriebszuständen befinden kann: STARTING, SHUTDOWN, SHUTDOWNREINIT, SHUTDOWNKILL, STOP, KILL, ABORT, UNKNOWN

show storage

Anzeigen des Speicherverbrauchs. Unter Microsoft Windows wird zusätzlich der Task-Stack angezeigt.

show suspends

Anzeigen der Gründe, warum aktuell suspendierte Tasks suspendiert wurden

show t_cnt [dw | sv | us | gc | <taskindex>]

Anzeigen von Detailinformationen zu allen Tasks einer bestimmten Task-Gruppe oder zur Task mit dem Index <taskindex>

show t_move

Nur für Load-Balancing; Anzeigen, ob Tasks aktuell von einem User-Kernel-Thread in einen anderen wechseln dürfen

show t_queue

Anzeigen der Task-Warteschlangen

show t_reg

Anzeigen der Semaphoren (Benutzung der kritischen Regionen durch die Tasks)

show t_stat

Anzeigen von Task-Statistiken

show tasks

Anzeigen von Statistiken zu allen Tasks

show thrd_times

Nur für Microsoft Windows. Anzeigen, wieviel Prozessorzeit die Threads verbraucht haben

show tstack

nur auf UNIX/Linux

Übersicht über den aktuellen Taskstack-Verbrauch und die Lage der Taskstacks im virtuellen Adressraum des Kernprozesses.

show versions

Anzeigen der Version des Datenbankkerns und der Laufzeitumgebung

time <enable | disable>

Einschalten der internen Zeitmessung. Beachten Sie, dass die Performance Ihres Systems hierdurch sinken kann.

trace_flush

Flushen der Trace-Datei

Beispiel

Auf Microsoft Windows zeigen Sie alle aktiven Tasks der Datenbankinstanz DEMODB an und wiederholen das Kommando 10 Mal im Abstand von 1 Sekunde:

x_cons DEMODB show active 1 10

Anzeigen der Hilfe zu allen XCONS-Kommandos:

x_cons DEMODB help

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Übersicht der Tasks


XUSER (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation XUSER

Einsatzmöglichkeiten

Das Datenbankwerkzeug XUSER dient dazu, Anmeldedaten für Benutzer zu speichern und zur vereinfachten Anmeldung an Datenbankinstanzen zur Verfügung zu stellen. Sie können mit dem Programm XUSER Anmeldedaten für den Datenbanksystemadministrator (SYSDBA-Benutzer), für Database Manager-Benutzer (DBM-Benutzer) und auch für Datenbankbenutzer speichern.

XUSER ist ein Kommandozeilenwerkzeug und kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden. XUSER kann in SAP-Systemen verwendet werden.

Einführungshinweise

XUSER ist Bestandteil der MaxDB-Software, die Sie über die MaxDB-Website herunterladen können (siehe Strukturlink Download und Strukturlink Installationshandbuch).

Weiterführende Informationen zum Datenbanksystem finden Sie in den Dokumentationen Strukturlink Konzepte des Datenbanksystems und Strukturlink Glossar.

Integration

Das Programm XUSER können Sie auch aus dem Database Manager CLI heraus aufrufen. Dort stehen jedoch nicht alle Funktionen von XUSER zur Verfügung. Siehe Database Manager CLI, Anmelden an das Programm XUSER: -ux

Funktionsumfang

Anmeldedaten für die Anmeldung an Datenbankinstanzen werden als XUSER-Einträge definiert und unter einem Benutzerschlüssel gespeichert. Beim Anmelden an eine Datenbankinstanz geben Sie nur den Benutzerschlüssel an.

Die XUSER-Einträge werden pro Betriebssystembenutzer separat gespeichert. Unter Microsoft Windows werden die XUSER-Einträge in der Registry, unter UNIX/Linux im Dateisystem gespeichert.

Ein Betriebssystembenutzer kann bis zu 32 Benutzerschlüssel für sich definieren. Wenn mehrere Benutzer den gleichen Rechner benutzen, aber unter verschiedenen Benutzernamen mit einer Datenbankinstanz arbeiten, dann können auf diese Weise individuelle Benutzerangaben verwaltet werden.

Verwenden eines Benutzerschlüssels beim Anmelden an eine Datenbankinstanz

Anlegen oder Ändern von XUSER-Einträgen

Anzeigen der Daten von XUSER-Einträgen

Löschen von XUSER-Einträgen

XUSER-Optionen

Einschränkungen

● Einige Datenbankwerkzeuge (Loader und Database Manager GUI) und Anwendungen, die die ODBC-Schnittstelle verwenden (z. B. SQL Studio), können nicht auf XUSER-Daten zugreifen.

● XUSER dient nicht dazu, die Benutzer zu verwalten. XUSER verwaltet nur die XUSER-Einträge zu diesen Benutzern. Sie können nur dann mit einem unter einem XUSER-Eintrag gespeicherten Benutzer auf eine Datenbankinstanz zugreifen, wenn dieser auch tatsächlich für diese Datenbankinstanz angelegt wurde. Ebenso können Sie mit einem unter einem XUSER-Eintrag gespeicherten Database Manager-Benutzer nur dann eine Datenbankinstanz verwalten, wenn Sie diesen Database Manager-Benutzer zuvor angelegt haben.

● Nur für Unicode-fähige Datenbankinstanzen: Sie können Benutzernamen und Kennwörter in Unicode nur mit der XUSER-Option -b aus einer Datei in XUSER einlesen, aber nicht direkt auf der Kommandozeile angeben.


Verwenden eines Benutzerschlüssels beim Anmelden an eine Datenbankinstanz

Vorgehensweisen Verwenden eines Benutzerschlüssels beim Anmelden an eine Datenbankinstanz

Verwendung

Mehrere Datenbankwerkzeuge und Schnittstellen unterstützen das Programm XUSER und die Anmeldung an eine Datenbankinstanz mit einem Benutzerschlüssel.

Vorgehensweise

Um sich mit Hilfe eines Benutzerschlüssels an eine Datenbankinstanz anzumelden, geben Sie bei der Anmeldung die Option –U <user_key> [<options>] an. <user_key> ist der im Programm XUSER gespeichert Benutzerschlüssel.

Achten Sie bei der Angabe des Benutzerschlüssels auf die Groß- und Kleinschreibung.

Beachten Sie außerdem, dass die Anmeldung nur dann erfolgreich sein kann, wenn der unter dem angegebenen Benutzerschlüssel gespeicherte Benutzer tatsächlich auch zuvor angelegt wurde.

Wenn Sie zusätzliche Anmeldeoptionen angeben, dann übersteuern diese die entsprechenden Angaben im XUSER-Eintrag.

Wenn Sie sich über SQL-Anwendungen an XUSER anmelden und keinen Benutzerschlüssel angeben, dann erfolgt die Anmeldung mit den unter dem Benutzerschlüssel DEFAULT gespeicherten Benutzerdaten.

Wenn Sie sich über den Database Manager an XUSER anmelden und keinen Benutzerschlüssel angeben, dann erfolgt die Anmeldung mit den unter dem Benutzerschlüssel DBMUSR gespeicherten Benutzerdaten.

Beispiel

Sie melden sich an den Database Manager CLI mit dem Benutzerschlüssel ag an.

dbmcli -U ag

Im Benutzerschlüssel ag ist der DBM-Benutzername anna_ghobadi mit dem Kennwort may für die Datenbankinstanz DEMODB gespeichert.


Anlegen oder Ändern von XUSER-Einträgen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anlegen oder Ändern von XUSER-Einträgen

Neue XUSER-Einträge anlegen

Neue XUSER-Einträge können Sie entweder interaktiv anlegen oder aus einer XUSER-Datei einlesen.

Es gibt bereits einen vordefinierten Benutzerschlüssel DEFAULT. Dieser Benutzerschlüssel ist nicht änderbar. Wenn unter diesem Benutzerschlüssel noch keine Angaben gespeichert sind, dann wird der erste Eintrag, den Sie definieren, unter dem Benutzerschlüssel DEFAULT gespeichert, unabhängig von einem eventuell angegebenen Benutzerschlüssel.

Wenn Sie beim Anlegen eines XUSER-Eintrags keinen Benutzerschlüssel angeben, dann werden alle Angaben unter dem Benutzerschlüssel DEFAULT gespeichert. Bereits vorhandene Angaben werden also überschrieben.

XUSER-Einträge ändern

Sie ändern einen vorhandenen XUSER-Eintrag, indem Sie dessen Daten vollständig überschreiben.

In der Regel kann ein Betriebssystembenutzer nur die eigenen XUSER-Einträge ändern.

Ausnahmen:

· Der Betriebssystembenutzer, der den Benutzerschlüssel DEFAULT definiert hat, kann diesen XUSER-Eintrag ändern.

· Unter Microsoft Windows kann ein Betriebssystembenutzer, der Mitglied der Gruppe Administrators ist, die XUSER-Einträge anderer Betriebssystembenutzer ändern. Dies ist notwendig, wenn ein Betriebssystembenutzer, für den ein XUSER-Eintrag existiert, sich nicht interaktiv am Betriebssystem anmelden darf.

Syntax

xuser [<options>] set

Für Informationen zu den Optionen <options> siehe XUSER-Optionen.

Beispiel

Als Betriebssystembenutzer ANNA legen Sie einen XUSER-Eintrag mit dem Benutzerschlüssel ag an. Unter diesem XUSER-Benutzerschlüssel speichern Sie Ihre Anmeldedaten für die Datenbankinstanz DEMODB: den Database Manager-Benutzernamen anna_ghobadi und das Kennwort may.

xuser –U ag –d DEMODB –u anna_ghobadi,may


Anzeigen der Daten von XUSER-Einträgen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Anzeigen der Daten von XUSER-Einträgen

xuser [-U <user_key>] [-c <os_user>\<domain>] list

Um die Daten aller gespeicherten XUSER-Einträge für Ihren Betriebssystembenutzer anzuzeigen, verwenden Sie das Kommando ohne Optionen.

Siehe auch:

XUSER-Optionen


Löschen von XUSER-Einträgen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Löschen von XUSER-Einträgen

xuser [-U <user_key>] [-c <os_user>\<domain>] clear

Um alle XUSER-Einträge zu löschen, die Ihrem Betriebssystembenutzer zugeordnet sind, geben Sie keine Optionen an.

XUSER ist kein Werkzeug zur Verwaltung von Datenbankbenutzern oder Database Manager-Benutzern. Es verwaltet nur die XUSER-Einträge zu diesen Benutzern im Programm XUSER. Das Löschen eines XUSER-Eintrags bewirkt kein Löschen des entsprechenden Benutzers. Um Benutzer zu löschen, verwenden Sie das Datenbankwerkzeug Database Manager.

Siehe auch:

XUSER-Optionen


XUSER-Optionen (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation XUSER-Optionen

Verwendung

Sie können XUSER mit Optionen aufrufen:

xuser [<options>] [set|clear|list]

XUSER-Optionen

<option> | Beschreibung
-A | Das Programm XUSER interpretiert die Angaben als ASCII8. Der Vorschlagswert für den Zeichensatz ist UTF-8.
-b <file_name> | XUSER liest die XUSER-Einträge aus der XUSER-Datei <file_name> ein. Siehe: XUSER-Einträge aus einer Datei einlesen
-c <domain>\<os_user> | nur auf Microsoft Windows Betriebssystembenutzer <os_user> in der Domäne <domain>, dessen XUSER-Eintrag geändert wird Um diese Option zu verwenden, benötigen Sie Administrationsrechte.
-d <database_name> | Name der Datenbankinstanz Wenn Sie keinen Datenbanknamen angeben, dann wird dem XUSER-Eintrag keine Datenbankinstanz zugeordnet.
-e <encryption> | nur in SAP-Systemen Art <encryption> der für die Verbindung mit der Datenbankinstanz verwendeten Verschlüsselung Zur Zeit können Sie nur den Wert SSL für <encryption> wählen. Wenn Sie keine Verschlüsselung verwenden, dann lassen Sie die Option weg.
-h | Anzeigen der Hilfe
-l <isolation_level> | Isolation-Level nur für Anwendungsprogramme Wenn Sie <isolation_level> nicht angeben, dann verwendet das Programm XUSER den Wert –1.
-n <database_computer> | Name des Rechners, auf dem die Datenbankinstanz läuft Zeichenkette mit maximal 64 Zeichen Beachten Sie die Groß- und Kleinschreibung. Wenn Sie <database_computer> nicht angeben, dann verwendet das Programm XUSER den lokalen Rechner.
-S <SQL_mode> | SQL-Modus Zeichenkette mit maximal 8 Zeichen Wenn Sie <SQL_mode> nicht angeben, dann verwendet das Programm XUSER den SQL-Modus INTERNAL.
-t <timeout> | Timeout-Wert in Sekunden Mögliche Werte: -1, <seconds>, 0 -1: Das Programm XUSER übernimmt den Vorschlagswert der Datenbankinstanz. 0: kein Timeout Wenn Sie <timeout> nicht angeben, dann verwendet das Programm XUSER den Wert –1.
-U <user_key> | Benutzerschlüssel des XUSER-Eintrags Zeichenkette mit maximal 18 Zeichen (UNICODE: 9 Zeichen) Beachten Sie die Groß- und Kleinschreibung.
-u <user_name>,<password> | Benutzername (Datenbankbenutzer oder DBM-Benutzer) und Kennwort Zeichenketten mit je maximal 18 Zeichen (UNICODE: 9 Zeichen) Wenn der Benutzername oder das Kennwort Kleinbuchstaben oder Sonderzeichen enthalten, dann schließen Sie diese in doppelte Hochkommas ein. Andernfalls wandelt das Programm XUSER Kleinbuchstaben automatisch in Großbuchstaben um.
-V | Anzeigen der Version des XUSER-Programms


XUSER-Einträge aus einer Datei einlesen (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen XUSER-Einträge aus einer Datei einlesen

Verwendung

Sie können XUSER-Einträge anlegen, ändern und löschen, indem Sie Informationen aus einer Datei einlesen.

Vorgehensweise

...

1. Legen Sie mit einem Texteditor die Datei an, aus der die XUSER-Einträge eingelesen werden sollen.

Jede Zeile der Datei enthält die Optionen für einen XUSER-Eintrag und das Kommando set oder clear.

Sie dürfen die Option –b nicht in der Datei verwenden.

Den Namen der Datei können Sie frei wählen.

2. Um die Datei <file> in XUSER einzulesen, geben Sie folgendes Kommando an:

xuser -b <file>

Beispiel

Sie lesen eine Datei mit dem folgenden Inhalt in XUSER ein:

-U MK –u MONA,RED –d DEMODB –n GENUA –t 90 –l 1 set

-U DK –u DAVID,BLUE –d DEMODB set

Hierdurch werden folgende XUSER-Einträge angelegt:

  • Benutzerschlüssel MK, Benutzer MONA, Kennwort RED, Datenbankname DEMODB, Rechner GENUA, Timeout 90 Sekunden, Isolation-Level 1.
  • Benutzerschlüssel DK, Benutzer DAVID, Kennwort BLUE, Datenbankname DEMODB


X-Server (SAP-Bibliothek - Werkzeuge)

Komponentendokumentation X-Server

Einsatzmöglichkeiten

Der MaxDB X-Server ist der Kommunikations-Server des Datenbanksystems. Der X-Server lauscht auf Verbindungswünsche von Clients, beispielsweise Datenbankanwendungen und Datenbankwerkzeugen.

Der X-Server wird benötigt, wenn ein Client eine Verbindung zu einer Datenbankinstanz aufbaut, die sich auf einem entfernten Computer befindet. Die JDBC-Schnittstelle benötigt den X-Server auch bei der lokalen Kommunikation. Die Kommunikation zwischen Clients und X-Server kann in SAP-Systemen mit SSL/TLS verschlüsselt werden.

Der X-Server kann auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden.

Einführungshinweise

Der X-Server ist Bestandteil der MaxDB-Software, die Sie über die MaxDB-Website herunterladen können (siehe Strukturlink Download und Strukturlink Installationsprofile).

Weiterführende Informationen zum Datenbanksystem finden Sie in den Dokumentationen Strukturlink Konzepte des Datenbanksystems und Strukturlink Glossar.

Funktionsumfang

· Starten des X-Servers

· Stoppen des X-Servers

· Ports und Protokolle des X-Servers.

Siehe auch:

Konzepte des Datenbanksystems,

· Strukturlink Netzwerkkommunikation

· Strukturlink Datenverschlüsselung

· Strukturlink Übersicht der Prozesse

MaxDB Sicherheitsleitfaden, Strukturlink MaxDB X-Server hinter einer Firewall verwenden


Starten des X-Servers (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Starten des X-Servers

Verwendung

Auf Windows registriert das MaxDB-Installationsprogramm den X-Server als Dienst XServer, setzt den Startup Type für diesen Dienst auf Automatic und startet ihn. Sie müssen ihn nicht manuell starten.

Auf UNIX/Linux wird der X-Server nicht automatisch als Dienst installiert. Sie können den X-Server entweder in die entsprechenden Startskripten des Betriebssystems eintragen oder ihn bei Bedarf manuell starten. Nach dem Start läuft der X-Server als Prozess vserver im Hintergrund. Beim Starten des X-Servers wird automatisch ein spezieller Prozess für die Unterstützung des SAP-eigenen NI-Netzwerkprotokolls gestartet.

Vorgehensweise

x_server [<options>] [start]

Optionen für den Aufruf des X-Servers

<option>

Erläuterung

-D <debugging_level>

Legt den Debugging-Level fest. Sie können Werte zwischen 0 (kein Schreiben von Debugging-Informationen) bis 9 (maximale Debugging-Informationen) angeben. Der Vorschlagswert ist 0.

-F

Wenn Sie diese Option setzen, dann ermittelt der X-Server den Rechnernamen der sich anmeldenden Anwendung nicht beim DNS-Server (kein reverse DNS lookup).

Wenn der Verbindungsaufbau mit einer entfernten Datenbankinstanz ungewöhnlich lange dauert, dann starten Sie den X-Server mit dieser Option neu. Auf diese Weise können Sie herausfinden, ob Ihr DNS-Server die Ursache für den langsamen Verbindungsaufbau ist.

-S <port>

Nur für UNIX/Linux: weist dem X-Server einen anderen Port <port> zu. Als Vorschlagswert verwendet der X-Server Port 7210. Siehe Ports und Protokolle des X-Servers

-V

Zeigt die Version des X-Servers an.

-w

nur auf UNIX/Linux, nur in SAP-Systemen

schränkt das Kommando auf die SAP NISSL-Verbindung ein

-W

nur auf UNIX/Linux, nur in SAP-Systemen

unterdrückt die automatische Verwendung von SAP NISSL

-y

nur auf UNIX/Linux, nur in SAP-Systemen

schränkt das Kommando auf die SAP NI-Verbindung ein

-Y

nur auf UNIX/Linux, nur in SAP-Systemen

unterdrückt die automatische Verwendung von SAP NI und SSL

-Z <file_size>

Legt die Größe der Strukturlink Protokolldatei xserver_<computer_name>.prt in KB fest. computer_name ist der Name des Rechners, auf dem der X-Server läuft.


Stoppen des X-Servers (SAP-Bibliothek - Werkzeuge)

Vorgehensweisen Stoppen des X-Servers

Verwendung

Sie stoppen den X-Server.

Nachdem der X-Server gestoppt wurde, ist keine Kommunikation zwischen Datenbankwerkzeugen und -anwendungen mit einer Datenbankinstanz auf einem entfernten Computer mehr möglich.

die JDBC-Schnittstelle benötigT den X-Server auch für die lokale Kommunikation.

Voraussetzungen

Auf UNIX/Linux: Sie sind als Betriebssystembenutzer der Gruppe Strukturlink <sdba_group> angemeldet.

Vorgehensweise

x_server stop


Ports und Protokolle des X-Servers (SAP-Bibliothek - Werkzeuge)

Funktionsdokumentation Ports und Protokolle des X-Servers

Verwendung

Clients können über verschiedene Protokolle mit dem X-Server Daten austauschen.

Funktionsumfang

Der MaxDB X-Server verwendet die folgenden Ports.

Ports und Protokolle des X-Servers

Portnummer | Protokoll | Protokoll-Identifier | Bemerkungen
7210 | TCP/IP | remote:// |
7269 | NI | sapni:// | nur in SAP-Systemen, verwendet SAP-eigenes Netzwerkprotokoll NI
7270 | SSL/TLS NISSL | remotes:// sapnis:// | nur in SAP-Systemen, verwendet SAP-Verschlüsselungsbibliothek und SAP-eigenes Netzwerkprotokoll NI

Ports und Protokolle des X-Servers

Diese Grafik wird im zugehörigen Text erklärt

Die Ports sind in der Datei services eingetragen:

· UNIX/Linux: /etc/services

· Microsoft Windows: <windows_directory>\system32\drivers\etc\services

Siehe auch:

· MaxDB Sicherheitsleitfaden, Strukturlink MaxDB X-Server hinter einer Firewall verwenden

· Konzepte des Datenbanksystems, Strukturlink Datenverschlüsselung


Schnittstellen (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation Schnittstellen

Titel der Dokumentation | Inhalt
ODBC-Handbuch | Grundlagen und Besonderheiten des MaxDB-ODBC-Treibers
SQLDBC-Handbuch | SQL Database Connectivity für die Entwicklung von Anwendungen und Schnittstellen für MaxDB
Java-Handbuch | Beschreibung des MaxDB JDBC-Treibers und der Programmierschnittstellen für Database Manager und Loader für die Entwicklung von Datenbankanwendungen mit Java
Perl-Handbuch | Beschreibung der Programmierschnittstellen für SQL, Database Manager und Loader für die Entwicklung von Datenbankanwendungen mit Perl
Python-Handbuch | Beschreibung der Programmierschnittstellen für SQL, Database Manager und Loader für die Entwicklung von Datenbankanwendungen mit Python
PHP-Handbuch | Beschreibung der MaxDB-PHP-Softwareerweiterung für die Entwicklung von Datenbankanwendungen mit PHP
WebDAV | Beschreibung des Zugriffs auf eine Dokumentenablage in einer MaxDB-Datenbankinstanz mit dem MaxDB-WebDAV-Servlet
Backint for MaxDB | Beschreibung der Backint for MaxDB-Schnittstelle für externe Sicherungswerkzeuge


ODBC-Handbuch (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation ODBC-Handbuch

Einsatzmöglichkeiten

Mit dem MaxDB-ODBC-Treiber können Sie über die ODBC-Schnittstelle auf MaxDB-Datenbankinstanzen zugreifen. Den MaxDB-ODBC-Treiber können Sie auf allen Strukturlink vom Datenbanksystem unterstützten Betriebssystemen verwenden.

MaxDB-ODBC-Treiber

Betriebssystem | ODBC-Treiber/ASCII | ODBC-Treiber/UNICODE
Microsoft Windows | sqlod32.dll | sqlod32w.dll
UNIX/Linux | libsqlod.a|so | libsqlodw.a|so

Weitere Informationen zu den verschiedenen Treiber-Varianten finden Sie unter UNICODE-Unterstützung.

Einführungshinweise

Der MaxDB-ODBC-Treiber ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Ausführliche Informationen zu ODBC finden Sie im Microsoft Developer Network unter msdn.microsoft.com. Weiterführende Informationen zum MaxDB-Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

● Eigenschaften des MaxDB-ODBC-Treibers

● MaxDB-ODBC-Treiber verwenden

● Datenquelle anlegen/ändern

Siehe auch:

Konzepte des Datenbanksystems,

● Strukturlink Entwicklung von Datenbankanwendungen

● Strukturlink Schnittstellen


Eigenschaften des MaxDB-ODBC-Treibers (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Eigenschaften des MaxDB-ODBC-Treibers

Der MaxDB-ODBC-Treiber unterstützt die vollständige ODBC-SQL-Syntax. Detaillierte Informationen zu den ODBC-Funktionsaufrufen finden Sie unter msdn.microsoft.com in der Dokumentation ODBC Programmer‘s Reference.

Der MaxDB-ODBC-Treiber erweitert die ODBC-SQL-Syntax in folgenden Bereichen:

● Datenbankprozeduren können als SQL-Anweisungen verarbeitet werden.

Die ODBC-Syntax für Prozeduren erlaubt keine Rückgabewerte für Funktionen.

Siehe SQL-Referenzhandbuch, Strukturlink Name einer Datenbankprozedur (dbproc_name).

● Der MaxDB-ODBC-Treiber unterstützt folgende Arten von positionierbaren Cursors: statische, dynamische und Keyset-gesteuerte. Mit der Funktion SQLSetPos kann eine Anwendung positionierende INSERT-, UPDATE- und DELETE-Anweisungen ausführen.

Siehe SQL-Referenzhandbuch, Strukturlink DECLARE CURSOR-Anweisung (declare_cursor_statement).

Funktionsumfang

● ODBC-API-Kompatibilität

● Unterstützte Datentypen

● Unicode-Unterstützung

Siehe auch:

MaxDB-ODBC-Treiber verwenden


ODBC-API-Kompatibilität (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation ODBC-API-Kompatibilität

Der MaxDB-ODBC-Treiber erfüllt die Schnittstellenspezifikation von ODBC 3.51.

Beachten Sie bei der Entwicklung eigener Anwendungen, dass sich die Versionen ODBC 2.x und ODBC 3.x unterscheiden. Definieren Sie deshalb mit der Funktion SQLSetEnvAttr das Attribut SQL_ATTR_ODBC_VERSION, bevor Sie mit SQLAllocHandle ein Connection-Handle anfordern.

Übersicht der Funktionen, die im MaxDB-ODBC-Treiber definiert sind

Kern-API

Level-1-API

Level-2-API


Kern-API (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Kern-API

Übersicht der Funktionen, die im MaxDB-ODBC-Treiber für das Kern-API definiert sind

Funktion

Anmerkungen

SQLAllocConnect

-

SQLAllocEnv

-

SQLAllocStmt

-

SQLBindCol

Wenn die Längenangabe pcbValueMax kleiner als die Länge einer gebundenen LONG-Spalte ist, liefert der MaxDB-ODBC-Treiber für pcbValue den Wert SQL_NO_TOTAL. In allen anderen Fällen zeigt pcbValue die Länge der kopierten Bytes an.

Weitere Teile dieser LONG-Spalte können Sie dann mit der Funktion SQLGetData holen.

SQLCancel

-

SQLColAttributes

-

SQLConnect

-

SQLDescribeCol

-

SQLDisconnect

-

SQLError

-

SQLExecDirect

-

SQLExecute

-

SQLFetch

-

SQLFreeConnect

-

SQLFreeEnv

-

SQLFreeStmt

-

SQLGetCursorName

Unterscheidung nach Groß- und Kleinbuchstaben, maximale Länge 18 Zeichen
Beachten Sie dies z. B. bei der Anweisung SELECT FOR UPDATE, da Bezeichner, die nicht in Hochkommas eingeschlossen sind, automatisch in Großbuchstaben umgewandelt werden.

Der MaxDB-ODBC-Treiber bildet für Cursor-Namen Vorschlagswerte nach folgendem Schema:
SQL_CURSOR_nnnn, wobei nnnn einem internen Zähler entspricht.
SQL_CUR_nnnnnnn, wenn n >= 10000

SQLNumResultCols

-

SQLPrepare

-

SQLRowCount

Zeigt Anzahl der betroffenen Zeilen für alle SELECT-, INSERT-, DELETE-, usw. -Anweisungen an

Falls keine Ergebnismenge aufgebaut wurde, wird für die nicht bestimmbare Anzahl von betroffenen Zeilen der Wert -1 angezeigt.

SQLSetCursorName

-

SQLTransact

-


Level-1-API (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Level-1-API

Übersicht der Funktionen, die im MaxDB-ODBC-Treiber für das Level-1-API definiert sind

Funktion

Anmerkung

SQLBindParameter

-

SQLColumns

-

SQLDriverConnect

Schlüsselwort für den Namen des Datenbankrechners: SERVERNODE
Schlüsselwort für den Namen der Datenbankinstanz: SERVERDB

SQLGetConnectAttr

Anmerkung

SQLGetData

-

SQLGetFunctions

Anmerkung

SQLGetInfo

Anmerkung

SQLGetStmtAttr

-

SQLGetTypeInfo

Die vom Datenbanksystem MaxDB unterstützten Datentypen können Sie mit Hilfe der Funktion SQLGetTypeInfo ermitteln.

Folgende Datentypen werden unterstützt:
CHAR, VARCHAR, DECIMAL, FIXED, INTEGER, SMALLINT, FLOAT, REAL, DOUBLE PRECISION, DATE, TIME, TIMESTAMP, LONG, CHAR BYTE, VARCHAR BYTE, LONG BYTE, BOOLEAN

Wenn die Datenbank so konfiguriert ist, dass UNICODE-Zeichen verarbeitet werden können, unterstützt MaxDB auch folgende Datentypen:
CHAR UNICODE, VARCHAR UNICODE, LONG UNICODE

SQLParamData

-

SQLPutData

-

SQLSetConnectAttr

Siehe SQLGetConnectAttr

SQLSetParam

-

SQLSetStmtAttr

-

SQLSpecialColumns

-

SQLStatistics

-

SQLTables

Der MaxDB-ODBC-Treiber unterstützt folgende Tabellentypen (szTableType):
ALIAS, RESULT, SNAPSHOT, SYSTEM, SYSTEM TABLE, TABLE, UNLOADED, VIEW


Anmerkung zu SQLGetConnectAttr (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Anmerkung zu SQLGetConnectAttr

Liste aller unterstützten Attribute und Rückgabewerte des MaxDB-ODBC-Treibers

Attribute | Rückgabewerte
SQL_ ATTR_ACCESS_MODE | pvParam = SQL_MODE_READ_WRITE
SQL_ ATTR_AUTOCOMMIT | pvParam = SQL_AUTOCOMMIT_ON
SQL_ATTR_CONNECTION_DEAD |
SQL_ATTR_CURRENT_CATALOG |
SQL_ ATTR_LOGIN_TIMEOUT | pvParam = 15
SQL_ATTR_ODBC_CURSORS |
SQL_ATTR_QUIET_MODE |
SQL_ ATTR_OPT_TRACE | pvParam = SQL_OPT_TRACE_OFF =0
SQL_ ATTR_OPT_TRACEFILE | (Der mit SQLSetConnectAttr gesetzte Dateiname, Vorschlagswert: \SQL.LOG)
SQL_ ATTR_TRANSLATE_LIB |
SQL_ ATTR_TRANSLATE_OPTION | pvParam = 0
SQL_ ATTR_TXN_ISOLATION | pvParam = SQL_TXN_REPEATABLE_READ
SQL_ MODE = SQL_CONNECT_OPT_START + 2 | pvParam = (1 = INTERNAL, 2 = DB2, 3 = ANSI, 4 = ORACLE)


Anmerkung zu SQLGetFunctions (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Anmerkung zu SQLGetFunctions

Bei Angabe der Function-ID SQL_API_ODBC3_ALL_FUNCTION gibt das Makro SQL_FUNC_EXISTS für folgende Werte das Ergebnis TRUE aus:

SQL_API_SQLALLOCCONNECT

SQL_API_SQLALLOCENV

SQL_API_SQLALLOCHANDLE

SQL_API_SQLALLOCHANDLESTD

SQL_API_SQLALLOCSTMT

SQL_API_SQLBINDCOL

SQL_API_SQLBINDPARAM

SQL_API_SQLBINDPARAMETER

SQL_API_SQLBROWSECONNECT

SQL_API_SQLBULKOPERATIONS

SQL_API_SQLCANCEL

SQL_API_SQLCLOSECURSOR

SQL_API_SQLCOLATTRIBUTES

SQL_API_SQLCOLUMNPRIVILEGES

SQL_API_SQLCOLUMNS

SQL_API_SQLCONNECT

SQL_API_SQLCOPYDESC

SQL_API_SQLDATASOURCES

SQL_API_SQLDESCRIBECOL

SQL_API_SQLDESCRIBEPARAM

SQL_API_SQLDISCONNECT

SQL_API_SQLDRIVERCONNECT

SQL_API_SQLDRIVERS

SQL_API_SQLENDTRAN

SQL_API_SQLERROR

SQL_API_SQLEXECDIRECT

SQL_API_SQLEXECUTE

SQL_API_SQLEXTENDEDFETCH

SQL_API_SQLFETCH

SQL_API_SQLFETCHSCROLL

SQL_API_SQLFOREIGNKEYS

SQL_API_SQLFREECONNECT

SQL_API_SQLFREEENV

SQL_API_SQLFREEHANDLE

SQL_API_SQLFREESTMT

SQL_API_SQLGETCONNECTATTR

SQL_API_SQLGETCONNECTOPTION

SQL_API_SQLGETCURSORNAME

SQL_API_SQLGETDATA

SQL_API_SQLGETDESCFIELD

SQL_API_SQLGETDESCREC

SQL_API_SQLGETDIAGFIELD

SQL_API_SQLGETDIAGREC

SQL_API_SQLGETENVATTR

SQL_API_SQLGETFUNCTIONS

SQL_API_SQLGETINFO

SQL_API_SQLGETSTMTATTR

SQL_API_SQLGETSTMTOPTION

SQL_API_SQLGETTYPEINFO

SQL_API_SQLMORERESULTS

SQL_API_SQLNATIVESQL

SQL_API_SQLNUMPARAMS

SQL_API_SQLNUMRESULTCOLS

SQL_API_SQLPARAMDATA

SQL_API_SQLPARAMOPTIONS

SQL_API_SQLPREPARE

SQL_API_SQLPRIMARYKEYS

SQL_API_SQLPROCEDURECOLUMNS

SQL_API_SQLPROCEDURES

SQL_API_SQLPUTDATA

SQL_API_SQLROWCOUNT

SQL_API_SQLSETCONNECTATTR

SQL_API_SQLSETCONNECTOPTION

SQL_API_SQLSETCURSORNAME

SQL_API_SQLSETDESCFIELD

SQL_API_SQLSETDESCREC

SQL_API_SQLSETENVATTR

SQL_API_SQLSETPARAM

SQL_API_SQLSETPOS

SQL_API_SQLSETSCROLLOPTIONS

SQL_API_SQLSETSTMTATTR

SQL_API_SQLSETSTMTOPTION

SQL_API_SQLSPECIALCOLUMNS

SQL_API_SQLSTATISTICS

SQL_API_SQLTABLEPRIVILEGES

SQL_API_SQLTABLES

SQL_API_SQLTRANSACT


Anmerkung zu SQLGetInfo (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Anmerkung zu SQLGetInfo

Liste aller vom MaxDB-ODBC-Treiber unterstützen Attribute und Rückgabewerte

Attribute

Rückgabewerte

SQL_ACCESSIBLE_PROCEDURES

rgbInfoValue = "N"

SQL_ACCESSIBLE_TABLES

rgbInfoValue = "N"

SQL_ACTIVE_CONNECTIONS

rgbInfoValue = 0

SQL_ACTIVE_STATEMENTS

rgbInfoValue = 32767

SQL_ALTER_TABLE

rgbInfoValue =
  SQL_AT_ADD_COLUMN
| SQL_AT_DROP_COLUMN
| SQL_AT_ADD_COLUMN_DEFAULT
| SQL_AT_ADD_CONSTRAINT
| SQL_AT_ADD_TABLE_CONSTRAINT
| SQL_AT_DROP_COLUMN_CASCADE
| SQL_AT_DROP_COLUMN_DEAFAULT
| SQL_AT_SET_COLUMN_DEFAULT

SQL_BOOKMARK_PERSISTENCE

rgbInfoValue =
  SQL_BP_SCROLL
| SQL_BP_UPDATE

SQL_CATALOG_LOCATION

rgbInfoValue = 1 (SQL_CL_START)

SQL_CATALOG_NAME_SEPARATOR

rgbInfoValue = "."

SQL_CATALOG_TERM

rgbInfoValue = "Qualifier"

SQL_CATALOG_USAGE

rgbInfoValue = 0x00000000

SQL_COLUMN_ALIAS

rgbInfoValue = "Y"

SQL_CONCAT_NULL_BEHAVIOR

rgbInfoValue = 0 (SQL_CB_NULL)

SQL_CONVERT_BIGINT

SQL_CONVERT_BINARY

SQL_CONVERT_BIT

SQL_CONVERT_CHAR

SQL_CONVERT_DATE

SQL_CONVERT_DECIMAL

SQL_CONVERT_DOUBLE

SQL_CONVERT_FLOAT

SQL_CONVERT_FUNCTIONS

rgbInfoValue = 0x00000000L

SQL_CONVERT_INTEGER

SQL_CONVERT_LONGVARBINARY

rgbInfoValue = 0x00000000L

SQL_CONVERT_LONGVARCHAR

SQL_CONVERT_NUMERIC

SQL_CONVERT_REAL

SQL_CONVERT_SMALLINT

SQL_CONVERT_TIME

SQL_CONVERT_TIMESTAMP

SQL_CONVERT_TINYINT

SQL_CONVERT_VARBINARY

SQL_CONVERT_VARCHAR

SQL_CORRELATION_NAME

rgbInfoValue = 2 (SQL_CN_ANY)

SQL_CURSOR_COMMIT_BEHAVIOR

rgbInfoValue =
SQL_CB_PRESERVE
| SQL_CB_DELETED (SQLMode = ANSI)

SQL_CURSOR_ROLLBACK_BEHAVIOR

rgbInfoValue =
SQL_CB_PRESERVE
| SQL_CB_DELETED (SQLMode = ANSI)

SQL_DATA_SOURCE_NAME

rgbInfoValue = (Name der geöffneten Datenquelle)

SQL_DATA_SOURCE_READ_ONLY

rgbInfoValue = "N"

SQL_DBMS_NAME

rgbInfoValue = "MaxDB"

SQL_DBMS_VER

rgbInfoValue = "07.06.nnn"

SQL_DEFAULT_TXN_ISOLATION

rgbInfoValue = SQL_TXN_READ_COMMITTED

SQL_DRIVER_HDBC

rgbInfoValue = (Handle der Treiberanmeldung)

SQL_DRIVER_HENV

rgbInfoValue = (Handle der Treiberumgebung)

SQL_DRIVER_HLIB

rgbInfoValue = (Handle der Library)

SQL_DRIVER_HSTMT

rgbInfoValue = (Handle der Treiberanweisung)

SQL_DRIVER_NAME

rgbInfoValue = "sqlod32.dll", "libsqlod.so" (UNIX)

SQL_DRIVER_ODBC_VER

rgbInfoValue = "03.51"

SQL_DRIVER_ODBC_VER

rgbInfoValue = (Version des Driver Manager > 3.51)

SQL_DRIVER_VER

rgbInfoValue = "7.<minor_version>.<correction_level>b<build_number>"

SQL_EXPRESSIONS_IN_ORDERBY

rgbInfoValue = "N"

SQL_FETCH_DIRECTION

rgbInfoValue =
  SQL_FD_FETCH_NEXT
| SQL_FD_FETCH_FIRST
| SQL_FD_FETCH_LAST
| SQL_FD_FETCH_PRIOR
| SQL_FD_FETCH_ABSOLUTE
| SQL_FD_FETCH_RELATIVE
| SQL_FD_FETCH_BOOKMARK

SQL_FILE_USAGE

rgbInfoValue = 0 (SQL_FILE_NOT_SUPPORTED)

SQL_GETDATA_EXTENSIONS

rgbInfoValue =
  SQL_GD_ANY_COLUMN
| SQL_GD_ANY_ORDER
| SQL_GD_ANY_BOUND
| SQL_GD_ANY_BLOCK

SQL_GROUP_BY

rgbInfoValue = SQL_GB_GROUP_BY_CONTAINS_SELECT

SQL_IDENTIFIER_CASE

rgbInfoValue = 1 (SQL_IC_UPPER)

SQL_IDENTIFIER_QUOTE_CHAR

rgbInfoValue = "\""

SQL_INTEGRITY

rgbInfoValue = "N"

SQL_KEYWORDS

rgbInfoValue = (Liste von Schlüsselwörtern, abhängig vom SQLMode)

SQL_LIKE_ESCAPE_CLAUSE

rgbInfoValue = "Y"

SQL_LOCK_TYPES

rgbInfoValue = 1 SQL_LCK_NO_CHANGE

SQL_MAX_BINARY_LITERAL_LEN

rgbInfoValue = 0

SQL_MAX_CATALOG_NAME_LEN

rgbInfoValue = 0

SQL_MAX_CHAR_LITERAL_LEN

rgbInfoValue = 0

SQL_MAX_COLUMN_NAME_LEN

rgbInfoValue = 32

SQL_MAX_COLUMNS_IN_GROUP_BY

rgbInfoValue = 128

SQL_MAX_COLUMNS_IN_INDEX

rgbInfoValue = 16

SQL_MAX_COLUMNS_IN_ORDER_BY

rgbInfoValue = 128

SQL_MAX_COLUMNS_IN_SELECT

rgbInfoValue = 1023

SQL_MAX_COLUMNS_IN_TABLE

rgbInfoValue = 1023

SQL_MAX_CONCURRENT_ACTIVITIES

rgbInfoValue = 32767

SQL_MAX_CURSOR_NAME_LEN

rgbInfoValue = 32

SQL_MAX_DRIVER_CONNECTIONS

rgbInfoValue = 0

SQL_MAX_INDEX_SIZE

rgbInfoValue = 1024

SQL_MAX_OWNER_NAME_LEN

rgbInfoValue = 32

SQL_MAX_PROCEDURE_NAME_LEN

rgbInfoValue = 32

SQL_MAX_QUALIFIER_NAME_LEN

rgbInfoValue = 0

SQL_MAX_ROW_SIZE

rgbInfoValue = 0

SQL_MAX_ROW_SIZE_INCLUDES_LONG

rgbInfoValue = "N"

SQL_MAX_SCHEMA_NAME_LEN

rgbInfoValue = 32

SQL_MAX_STATEMENT_LEN

rgbInfoValue = 0

SQL_MAX_TABLE_NAME_LEN

rgbInfoValue = 32

SQL_MAX_TABLES_IN_SELECT

rgbInfoValue = 64

SQL_MAX_USER_NAME_LEN

rgbInfoValue = 32

SQL_MULT_RESULT_SETS

rgbInfoValue = "N"

SQL_MULTIPLE_ACTIVE_TXN

rgbInfoValue = "Y"

SQL_NEED_LONG_DATA_LEN

rgbInfoValue = "N"

SQL_NON_NULLABLE_COLUMN

rgbInfoValue = 1 (SQL_NNC_NON_NULL)

SQL_NULL_COLLATION

rgbInfoValue = 1 (SQL_NC_LOW)

SQL_NUMERIC_FUNCTIONS

rgbInfoValue =
  SQL_FN_NUM_ABS
| SQL_FN_NUM_ACOS
| SQL_FN_NUM_ASIN
| SQL_FN_NUM_ATAN
| SQL_FN_NUM_ATAN2
| SQL_FN_NUM_CEILING
| SQL_FN_NUM_COS
| SQL_FN_NUM_COT
| SQL_FN_NUM_EXP
| SQL_FN_NUM_FLOOR
| SQL_FN_NUM_LOG
| SQL_FN_NUM_MOD
| SQL_FN_NUM_SIGN
| SQL_FN_NUM_SIN
| SQL_FN_NUM_SQRT
| SQL_FN_NUM_TAN
| SQL_FN_NUM_PI
| SQL_FN_NUM_DEGREES
| SQL_FN_NUM_RADIANS
| SQL_FN_NUM_ROUND

SQL_ODBC_API_CONFORMANCE

rgbInfoValue = 2 (SQL_OAC_LEVEL2)

SQL_ODBC_SAG_CLI_CONFORMANCE

rgbInfoValue = 1 (SQL_OSCC_COMPLIANT)

SQL_ODBC_SQL_CONFORMANCE

rgbInfoValue = 2 (SQL_OSC_EXTENDED)

SQL_ODBC_SQL_OPT_IEF

rgbInfoValue = "N"

SQL_ODBC_VER

rgbInfoValue = "03.520000"

SQL_ORDER_BY_COLUMNS_IN_SELECT

rgbInfoValue = "N"

SQL_OUTER_JOINS

rgbInfoValue = "Y"

SQL_OWNER_TERM

rgbInfoValue = "Schema"

SQL_OWNER_USAGE

rgbInfoValue =
  SQL_OU_DML_STATEMENTS
| SQL_OU_PROCEDURE_INVOCATION
| SQL_OU_TABLE_DEFINITION
| SQL_OU_INDEX_DEFINITION
| SQL_OU_PRIVILEGE_DEFINITION

SQL_POS_OPERATIONS

rgbInfoValue =
  SQL_POS_UPDATE
| SQL_POS_DELETE
| SQL_POS_ADD (nur mit dynamischen Cursors erlaubt)
| SQL_POS_POSITION
| SQL_POS_REFRESH

SQL_POSITIONED_STATEMENTS

rgbInfoValue =
  SQL_PS_POSITIONED_DELETE
| SQL_PS_POSITIONED_UPDATE
| SQL_PS_SELECT_FOR_UPDATE

SQL_PROCEDURE_TERM

rgbInfoValue = "stored procedure"

SQL_PROCEDURES

rgbInfoValue = "Y"

SQL_QUALIFIER_LOCATION

rgbInfoValue = 1 (SQL_CL_START)

SQL_QUALIFIER_NAME_SEPARATOR

rgbInfoValue = "."

SQL_QUALIFIER_TERM

rgbInfoValue = "Qualifier"

SQL_QUALIFIER_USAGE

rgbInfoValue = 0x00000000

SQL_QUOTED_IDENTIFIER_CASE

rgbInfoValue = 3 (SQL_IC_SENSITIVE)

SQL_ROW_UPDATES

rgbInfoValue = "Y"

SQL_SCHEMA_TERM

rgbInfoValue = "Schema"

SQL_SCHEMA_USAGE

rgbInfoValue =
  SQL_OU_DML_STATEMENTS
| SQL_OU_PROCEDURE_INVOCATION
| SQL_OU_TABLE_DEFINITION
| SQL_OU_INDEX_DEFINITION
| SQL_OU_PRIVILEGE_DEFINITION

SQL_SCROLL_CONCURRENCY

rgbInfoValue =
  SQL_SCCO_READ_ONLY
| SQL_SCCO_LOCK
| SQL_SCCO_OPT_ROWVER
| SQL_SCCO_OPT_VALUES

SQL_SCROLL_OPTIONS

rgbInfoValue =
  SQL_SO_FORWARD_ONLY
| SQL_SO_KEYSET_DRIVEN
| SQL_SO_DYNAMIC
| SQL_SO_STATIC

SQL_SEARCH_PATTERN_ESCAPE

rgbInfoValue = "\"

SQL_SERVER_NAME

rgbInfoValue = (Name des Datenbankrechners)

SQL_SPECIAL_CHARACTERS

rgbInfoValue = "#@$"

SQL_STATIC_SENSITIVITY

rgbInfoValue = 0x00000000

SQL_STRING_FUNCTIONS

rgbInfoValue =
  SQL_FN_STR_LEFT
| SQL_FN_STR_LTRIM
| SQL_FN_STR_LENGTH
| SQL_FN_STR_LCASE
| SQL_FN_STR_REPLACE
| SQL_FN_STR_RIGHT
| SQL_FN_STR_RTRIM
| SQL_FN_STR_SUBSTRING
| SQL_FN_STR_UCASE
| SQL_FN_STR_SOUNDEX

SQL_SUBQUERIES

rgbInfoValue =
  SQL_SQ_COMPARISON
| SQL_SQ_EXISTS
| SQL_SQ_IN
| SQL_SQ_CORRELATED_SUBQUERIES

SQL_SYSTEM_FUNCTIONS

rgbInfoValue =
  SQL_FN_SYS_USERNAME
| SQL_FN_SYS_DBNAME
| SQL_FN_SYS_IFNULL

SQL_TABLE_TERM

rgbInfoValue = "Table"

SQL_TIMEDATE_ADD_INTERVALS

rgbInfoValue = 0x00000000

SQL_TIMEDATE_DIFF_INTERVALS

rgbInfoValue = 0x00000000

SQL_TIMEDATE_FUNCTIONS

rgbInfoValue =
  SQL_FN_TD_NOW
| SQL_FN_TD_CURDATE
| SQL_FN_TD_DAYOFMONTH
| SQL_FN_TD_DAYOFWEEK
| SQL_FN_TD_DAYOFYEAR
| SQL_FN_TD_MONTH
| SQL_FN_TD_WEEK
| SQL_FN_TD_YEAR
| SQL_FN_TD_CURTIME
| SQL_FN_TD_HOUR
| SQL_FN_TD_MINUTE
| SQL_FN_TD_SECOND
| SQL_FN_TD_DAYNAME
| SQL_FN_TD_MONTHNAME

SQL_TXN_CAPABLE

rgbInfoValue = 2 (SQL_TC_ALL)

SQL_TXN_ISOLATION_OPTION

rgbInfoValue =
  SQL_TXN_READ_UNCOMMITTED
| SQL_TXN_READ_COMMITTED
| SQL_TXN_REPEATABLE_READ
| SQL_TXN_SERIALIZABLE

SQL_UNION

rgbInfoValue =
  SQL_U_UNION
| SQL_U_UNION_ALL

SQL_USER_NAME

rgbInfoValue = (Name des aktiven Benutzers)


Level-2-API (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Level-2-API

Übersicht der Funktionen, die im MaxDB-ODBC-Treiber für das Level-2-API definiert sind

Funktion

Anmerkung

SQLBrowseConnect

SQLColumnPrivileges

SQLDataSources (*)

SQLDescribeParam

SQLExtendedFetch

Nur beim dynamischen Corsor-Modell (SQL_CURSOR_DYNAMIC) können Sie mit Hilfe der Funktion SQLSetPos Zeilen einfügen. Bei allen anderen Cursor-Modellen ist dies nicht möglich.

UPDATE- und DELETE-Anweisungen sind sowohl beim statischen (SQL_CURSOR_STATIC) als auch beim Keyset-gesteuerten Cursor-Modell (SQL_CURSOR_KEYSETDRIVEN) möglich.

SQLFetchScroll

SQLForeignKeys

SQLMoreResults

Die Funktion ruft SQLFreeStmt mit dem Attribut SQL_CLOSE auf, um die vorhergehende Ergebnismenge zu schließen und liefert dann SQL_NO_DATA_FOUND.

SQLNativeSql

SQLNumParams

SQLParamOptions

SQLPrimaryKeys

SQLProcedureColumns

SQLProcedures

SQLSetPos

Alle Attribute sind zulässig.
Das Attribut SQL_ADD ist nur im dynamischen Cursor-Modell (SQL_CURSOR_DYNAMIC) möglich.
Für das fLock-Argument ist nur das Attribut SQL_LOCK_NO_CHANGE zulässig.

SQLSetScrollOptions

SQLTablePrivileges


Unterstützte Datentypen (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Unterstützte Datentypen

Die ODBC-Schnittstelle unterscheidet zwischen folgenden Datentypen:

● SQL-Datentypen (vom Datenbanksystem zur Verfügung gestellte Datentypen)

● C-Datentypen (in der Anwendung verwendete Datentypen)

Der MaxDB-ODBC-Treiber ermöglicht die Konvertierung aller von ODBC unterstützten Datentypen.

Vom MaxDB-ODBC-Treiber unterstützte MaxDB-Datentypen (SQL-Datentypen)

Gruppe | Datentyp
Character | CHAR, VARCHAR, LONG, CHAR BYTE, VARCHAR BYTE, LONG BYTE
numerisch | DECIMAL, FIXED, INTEGER, SMALLINT, FLOAT, REAL, DOUBLE PRECISION
Zeit/Datum | DATE, TIME, TIMESTAMP
Sonstige | BOOLEAN, CHAR EBCDIC, VARCHAR EBCDIC

Ausführliche Informationen zu den MaxDB-Datentypen finden Sie unter SQL-Referenzhandbuch, Strukturlink Datentyp (data_type).


Unicode-Unterstützung (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Unicode-Unterstützung

Der MaxDB ODBC-Treiber unterstützt Unicode. Ab den Versionen 7.4.03.32 / 7.5.00.11 stehen jeweils zwei ODBC-Treiber zur Verfügung.

MaxDB-ODBC-Treiber

Betriebssystem | ODBC-Treiber/ASCII | ODBC-Treiber/Unicode
Microsoft Windows | sqlod32.dll | sqlod32w.dll
UNIX/Linux | libsqlod.a|so | libsqlodw.a|so

Die ASCII-Version des ODBC-Treibers verbindet sich immer über ASCII mit dem Datenbankkern.

Die Unicode-Version des ODBC-Treibers verbindet sich mit ASCII-Datenbankkernen über ASCII und mit Unicode-Datenbankkernen über UCS2.

Um Unicode-Daten zu verarbeiten, verwendet der MaxDB-ODBC-Treiber intern UCS-2 (also 2 Bytes). Auf Plattformen, die für WCHAR_T-Daten 4 Bytes verwenden, können Sie beim Kompilieren mit dem GNU-C-Compiler mit einer Option erzwingen, dass WCHAR_T-Daten mit 2 Bytes verarbeitet werden.

Beispiel:

gcc -fshort-wchar [...]

Anwendungen, die die Funktionalität eines Treiber-Managers nicht benötigen, können Sie statisch mit dem ODBC-Treiber linken.

Folgende Funktionen sind im MaxDB-ODBC-Treiber für den Zugriff auf Unicode-Daten definiert:

SQLBrowseConnectW

SQLColAttributesW

SQLColAttributeW

SQLColumnPrivilegesW

SQLColumnsW

SQLConnectW

SQLDataSourcesW

SQLDescribeColW

SQLDriverConnectW

SQLDriversW

SQLErrorW

SQLExecDirectW

SQLForeignKeysW

SQLGetConnectAttrW

SQLGetConnectOptionW

SQLGetCursorNameW

SQLGetDescFieldW

SQLGetDescRecW

SQLGetDiagFieldW

SQLGetDiagRecW

SQLGetInfoW

SQLGetStmtAttrW

SQLGetTypeInfoW

SQLNativeSqlW

SQLPrepareW

SQLPrimaryKeysW

SQLProcedureColumnsW

SQLProceduresW

SQLSetConnectAttrW

SQLSetConnectOptionW

SQLSetCursorNameW

SQLSetDescFieldW

SQLSetStmtAttrW

SQLSpecialColumnsW

SQLStatisticsW

SQLTablePrivilegesW

SQLTablesW


MaxDB-ODBC-Treiber verwenden (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation MaxDB-ODBC-Treiber verwenden

Verwendung

Um den MaxDB-ODBC-Treiber zu verwenden, haben Sie folgende Möglichkeiten:

● MaxDB-ODBC-Treiber in einem Treiber-Manager registrieren. Sie können folgende Treiber-Manager verwenden:

○ Microsoft Windows: Microsoft ODBC Driver Manager 3.52 oder höher

○ UNIX/Linux: unixODBC 2.0.9 oder höher, iODBC 3.0.5 oder höher

● MaxDB-ODBC-Treiber direkt mit der Anwendung linken (nur auf UNIX/Linux)

Voraussetzungen

● Auf Microsoft Windows benötigen Sie Microsoft Data Access Components (MDAC) Version 2.7 oder höher.

● Sie haben den MaxDB-ODBC-Treiber installiert.

Der ODBC-Treiber ist in den Installationsprofilen Server, Web Tools und DB Analyzer und in der Softwarekomponente ODBC enthalten. Weitere Informationen finden Sie im Strukturlink Installationshandbuch.

Installation des ODBC-Treibers

Betriebssystem | Installationsverfahren | Verzeichnis | Anmerkungen
Microsoft Windows | Standardinstallation | <independent_program_path>\pgm Beispiel: C:\Program Files\sdb\programs\pgm Siehe auch Installationshandbuch, Strukturlink Verzeichnisse | Das System speichert die Informationen über alle installierten ODBC-Treiber in der Registry im Schlüssel HKEY_LOCAL_MACHINE/SOFTWARE/ODBC/ODBCINST.INI und legt außerdem für jeden ODBC-Treiber einen treiberspezifischer Schlüssel an.
UNIX/Linux | Standardinstallation | <independent_program_path>/pgm Beispiel: /opt/sdb/programs/pgm |
Linux | rpm-Installation | /opt/sdb/interfaces/odbc |

Dateien des MaxDB-ODBC-Treibers

Betriebssystem | Dateiname | Beschreibung
Microsoft Windows | sqlod32.dll sqlod32w.dll | Bibliothek des MaxDB-ODBC-Treibers (ASCII) Bibliothek des MaxDB-ODBC-Treibers (Unicode)
 | odbcreg.exe | Programm für das Eintragen der Treiberinformationen in die Registry
UNIX/Linux | libsqlod.a, libsqlod.so libsqlodw.a, libsqlodw.so | Bibliothek des MaxDB-ODBC-Treibers (ASCII, statisch/dynamisch) Bibliothek des MaxDB-ODBC-Treibers (Unicode, statisch/dynamisch)
 | incl/sql.h | ODBC-Treiber-Kopfdatei (Kern-API)
 | incl/sqlext.h | ODBC-Treiber-Kopfdatei (Level-1-API und Level-2-API)
 | incl/sqltypes.h | ODBC-Treiber-Kopfdatei (Datentypen)
 | incl/sqlucode.h | ODBC-Treiber-Kopfdatei (Unicode)
 | incl/WINDOWS.H | Kopfdatei für die Unix/Linux -Plattformen

Aktivitäten

ODBC-Treiber im Treiber-Manager registrieren

Informationen zum Registrieren eines ODBC-Treibers im Treiber-Manager finden Sie in der Dokumentation des Herstellers des Treiber-Managers.

ODBC-Treiber mit der Anwendung linken (nur auf UNIX/Linux)

Sie können den MaxDB-ODBC-Treiber entweder statisch (Bibliothek libsqlod.a) oder dynamisch (Bibliothek libsqlod.so) mit der Anwendung linken.

Stellen Sie beim dynamischen Linken sicher, dass das System die dynamische Bibliothek libsqlod.so beim Ausführen der Anwendung findet, z. B. indem Sie den Pfad von libsqlod.so zur Umgebungsvariable LD_LIBRARY_PATH hinzufügen.

Sie kompilieren die Anwendung myapp.c mit den passenden ODBC-Header-Dateien:

cc –c myapp.c –I<ODBC_include>

Sie linken den ODBC-Treiber statisch mit der Anwendung:

cc –o myapp myapp.o <ODBC_lib>/libsqlod.a

Sie linken den ODBC-Treiber dynamisch mit der Anwendung:

cc –o myapp myapp.o –L<ODBC_lib> -lsqlod

Siehe auch:

Datenquelle anlegen/ändern


Datenquelle anlegen/ändern (SAP-Bibliothek - Schnittstellen)

Vorgehensweisen Datenquelle anlegen/ändern

Verwendung

Um über die ODBC-Schnittstelle auf eine MaxDB-Datenbankinstanz zugreifen zu können, müssen Sie eine Datenquelle für die MaxDB-Datenbankinstanz anlegen.

Um eine Datenquelle anzulegen oder zu ändern, können Sie einen Treiber-Manager verwenden. Auf UNIX/Linux können Sie Datenquellen auch ohne Treiber-Manager anlegen oder ändern. Die Definition der Datenquellen werden auf Microsoft Windows in der Registry, auf UNIX/Linux in Konfigurationsdateien im Dateisystem gespeichert.

Datenquelle im Treiber-Manager anlegen

...

1. Wählen Sie den MaxDB-ODBC-Treiber aus.

2. Geben Sie die Eigenschaften der MaxDB-Datenquelle an.

Weitere Informationen finden Sie in der Dokumentation des Herstellers des Treiber-Managers.

Datenquelle ohne Treiber-Manager anlegen (nur auf UNIX/Linux)

Auf UNIX/Linux werden die Angaben zu ODBC-Datenquellen entweder global in der Konfigurationsdatei /etc/odbc.ini oder benutzerspezifisch in der Datei <user_home>/.odbc.ini gespeichert. Das System sucht Datenquellen zuerst in der benutzerspezifischen Konfigurationsdatei, dann in der globalen Konfigurationsdatei.

...

1. Öffnen Sie die gewünschte Konfigurationsdatei in einem Editor.

2. Geben Sie die Eigenschaften der Datenquelle folgendermaßen an:

[<data_source_name>]

ServerDB=<database_name>

ServerNode=<database_computer_name>

SQLMode=<INTERNAL|DB2|ANSI|ORACLE>

IsolationLevel=<Uncommitted|Committed|Repeatable|Serializable>

TraceFileName=<trace_file_path_and_name>

Wenn sich die Anwendung, mit der Sie über den ODBC-Treiber auf die Datenbankinstanz zugreifen möchten, auf einem anderen Rechner befindet als die Datenbankinstanz, dann muss auf dem Datenbankrechner der MaxDB X-Server laufen. Siehe Konzepte des Datenbanksystems, Strukturlink Architektur der Schnittstellen und X-Server, Strukturlink Ports und Protokolle des X-Servers.

Ergebnis

Wenn Sie Angaben zu einer Datenquelle geändert haben, dann werden diese Änderungen wirksam, wenn Sie sich das nächste Mal über die ODBC-Schnittstelle an die Datenbankinstanz anmelden.

Siehe auch:

MaxDB-ODBC-Treiber verwenden


Eigenschaften von Datenquellen (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Eigenschaften von Datenquellen

Eigenschaften von Datenquellen

Eigenschaft
(Microsoft Windows)

Eigenschaft
(UNIX/Linux)

Beschreibung

Data Source Name

<data_source_name>

Name der Datenquelle

Sie können den Namen frei wählen.

Der Name darf keine Sonderzeichen enthalten.

Description

-

Beschreibung der Datenquelle

Database

ServerDB

Datenbankname

Server

ServerNode

Name des Datenbankrechners

Wenn sich die MaxDB-Datenbankinstanz auf demselben Rechner wie die ODBC-Anwendung befindet, können Sie diese Angabe weglassen

SQLMode

SQLMode

Strukturlink SQL-Modus

Isolation Level

IsolationLevel

Sperrverhalten

siehe Konzepte des Datenbanksystems, Strukturlink Isolation-Level

Trace On

TraceFileName

Um den ODBC-Trace für die Datenbankinstanz zu aktivieren, wählen Sie diese Eigenschaft und geben Sie den Pfad und Namen der Datei an, in der das Datenbanksystem die SQL-Anweisungen protokollieren soll.

Dieser ODBC-Trace ist nicht identisch mit dem Treiber-Manager-Protokoll (Tracing) des Microsoft ODBC Data Source Administrator.

Wenn Sie sich das nächste Mal an die Datenbankinstanz anmelden, protokolliert das Datenbanksystem alle SQL-Anweisungen, die die Anwendung an die Datenbankinstanz übermittelt, einschließlich der folgenden Informationen:

· Ausführungszeit

· CONNECT-Parameter

· Ein- und Ausgabeparameter

· Anfang und Ende der Datenbanksitzung

Bei eingeschaltetem ODBC-Trace führt das System viele Dateioperationen aus. Darunter kann die Ausführungsgeschwindigkeit der Anwendung leiden. Schalten Sie deswegen den ODBC-Trace wieder aus, sobald die Aktionen ausgeführt wurden, die Sie mit dem ODBC-Trace analysieren möchten.


SQLDBC-Handbuch (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation SQLDBC-Handbuch

Einsatzmöglichkeiten

SQL Database Connectivity (SQLDBC) ist eine Laufzeitbibliothek für die Entwicklung von Datenbankanwendungen und Datenbankschnittstellen für MaxDB. Über SQLDBC können Anwendungen auf MaxDB-Datenbankinstanzen zugreifen, SQL-Anweisungen ausführen und Daten bearbeiten. Es besteht aus der Laufzeitbibliothek libSQLDBC, dem Software Development Kit SQLDBC SDK und dem Werkzeug sqldbc_cons.

SQLDBC können Sie auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen einsetzen.

Einführungshinweise

SQLDBC ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Wenn Sie SQLDBC in Open-Source-Projekten verwenden möchten, dann beachten Sie die Lizenzbedingungen. Weitere Informationen finden Sie unter dev.mysql.com/doc/maxdb/FLOSS.html

Eine detaillierte Programmierreferenz können Sie von der MaxDB-Website herunterladen, siehe Abschnitt Download.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Konzepte des Datenbanksystems Strukturlink Konzepte des Datenbanksystems, zur SQL-Syntax im Strukturlink SQL-Referenzhandbuch und im Strukturlink SQL-Tutorial. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

SQLDBC bietet unter anderem die folgenden Funktionen:

● unbegrenzte Anzahl von Datenbankverbindungen und SQL-Anweisungen

● vollständige Unicode-Unterstützung (UCS2 und UTF-8)

● flexible Ergebnismengen (Navigieren innerhalb der Ergebnismenge, Ändern der Ergebnismenge)

● stückweises Schreiben von Character- und Binärdaten (LOB-Schnittstelle)

● Unterstützung der folgenden SQL- und C-Datentypen:

○ CHAR, VARCHAR, SHORT, INT, LONG, FIXED, FLOAT, DOUBLE

○ BLOB, CLOB

○ ODBC (NUMERIC, DATE, TIME)

○ STREAMS (BLOB, CLOB, ABAP und liveCache)

● interne Zwischenspeicherung von SQL-Anweisungen im Parse-Info-Cache

● Optimierung von SELECT- und FETCH-Anweisungen

● Optimierung der Pakete (Verwendung mehrerer Segmente, Nutzung des nicht belegten Platzes in Paketen für Verwaltungsaufgaben, Verwendung eines gemischten Unicode-/ASCII-Modus, Wechselpuffertechnik für INSERT-Anweisungen)

● umfangreiche Trace-Möglichkeiten

● Multi-Threading (parallele Ausführung von SQL-Anweisungen, Beenden langlaufender SQL-Anweisungen, Sychronisation in einer Multi-Threading-Umgebung, Unabhängigkeit paralleler Datenbankverbindungen)

SQLDBC wurde in Analogie zur ODBC- und zur JDBC-Schnittstelle entwickelt und hat wie diese eine objektorientierte Architektur.

Siehe:

Aufbau von SQLDBC

SQLDBC-Klassen

SQLDBC-Traces

sqldbc_cons


Aufbau von SQLDBC (SAP-Bibliothek - Schnittstellen)

Objektdokumentation Aufbau von SQLDBC

Definition

SQLDBC besteht aus der Laufzeitbibliothek libSQLDBC zum Ausführen von Programmen, die auf eine MaxDB-Datenbankinstanz zugreifen, dem Software Development Kit SQLDBC SDK zum Enwickeln von Datenbankanwendungen und Datenbankschnittstellen für MaxDB und dem Werkzeug sqldbc_cons zum Schreiben von Traces.

Struktur

libSQLDBC

libSQLDBC enthält die folgenden Bibliotheken:

· versionsunabhängige Laufzeitbibliothek libSQLDBC.dll bzw. libSQLDBC.so (UNIX/Linux)

· versionsabhängige Laufzeitbibliothek libSQLDBC<version>.dll bzw. libSQLDBC<version>.so (UNIX/Linux)

libSQLDBC76.dll für MaxDB 7.6

· Laufzeitbibliothek libSQLDBC_C.dll zur Unterstützung nativer C-Anwendungen

Alle Bibliotheken sind voneinander unabhängig und weisen keine Abhängigkeiten zu anderen MaxDB-Bibliotheken auf. Sie werden im Verzeichnis <independent_program_path>/pgm installiert.

SQLDBC SDK

SQLDBC SDK enthält die folgenden Dateien:

· Header-Datei SQLDBC.h für C++

· Header-Datei SQLDBC_C.h für C

· statische und dynamisch gebundene Bibliotheken für C und C++

Die Dateien werden im Verzeichnis <independent_program_path>/sdk/sqldbc installiert.

sqldbc_cons

siehe sqldbc_cons


SQLDBC-Klassen (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation SQLDBC-Klassen

Verwendung

Die folgende Tabelle gibt einen Überblick über die SQLDBC-Klassen.

Eine detaillierte Programmierreferenz können Sie von der MaxDB-Website herunterladen, siehe Konzepte des Datenbanksystems, Strukturlink Download.

SQLDBC-Klassen

Name

Beschreibung

SQLDBC::SQLDBC_Environment

Basisklasse der SQLDBC-Bibliothek

Mit den Methoden dieser Klasse können Sie:

● SQLDBC_Connection-Objekte anlegen und freigeben

● SQLDBC-Traces steuern

● das Laufzeitverhalten steuern (Single- und Multi-Threading, Speicherverwaltung)

● SQLDBC-Eigenschaften abfragen, wie z. B. die SQLDBC-Version

SQLDBC::SQLDBC_Connection

Verwaltung von Datenbankverbindungen

Mit den Methoden dieser Klasse können Sie:

● Datenbanksitzungen eröffnen

● Transaktionen steuern

● Datums- und Zeitformate von Datenbanksitzungen ändern

● Informationen zur Datenbanksitzung ermitteln, wie z. B. die Datenbankversion

● Objekte erzeugen, mit denen SQL-Anweisungen ausgeführt werden können

SQLDBC::SQLDBC_ConnectProperties

Mit den Methoden dieser Klasse in Verbindung mit einem SQLDBC_Connection-Objekt können Sie einer Datenbanksitzung unter anderem folgende speziellen Eigenschaften zuweisen oder diese Eigenschaften abfragen:

● Sitzung: SQL-Modus, Timeout, Isolation-Level

● Performance: Select-Fetch-Optimierung, SQL-Statement-Cache

● Kompatibilität: Cursorpräfix, Auffüllverfahren für Spalten mit alphanumerischen Werten (Blank Padding)

SQLDBC::SQLDBC_Statement

Mit den Methoden dieser Klasse können Sie SQL-Anweisungen ohne Parameter ausführen, wie z. B. DDL-Anweisungen.

Wir empfehlen, alle SQL-Anweisungen ohne Parameter mit den Methoden dieser Klasse auszuführen.

Mit den Methoden dieser Klasse können Sie:

● Ergebnismengen erzeugen (schreibgeschützt oder änderbar)

● SQL-Anweisungen zu Sammelaufträgen zusammenfassen

● Informationen zu Ergebnismengen abfragen, wie z. B. die Anzahl geänderter Tabellenzeilen

● laufende Nummern (Serials) von INSERT-Anweisungen abfragen

SQLDBC::SQLDBC_PreparedStatement

Diese Klasse ist von der Klasse SQLDBC_Statement abgeleitet. Mit den Methoden dieser Klasse können Sie SQL-Anweisungen mit Parametern ausführen. Parameter in SQL-Anweisungen geben Sie mit ? oder :<identifier> an (siehe SQL-Referenzhandbuch, Strukturlink Parametername (parameter_name)).

Mit den Methoden dieser Klasse können Sie:

● Parameter an Programmvariablen binden (notwendig vor dem Ausführen von SQL-Anweisungen mit Parametern)

● SQL-Anweisungen vorbereiten (parsen)

● Informationen zu Parametern abfragen

● Massenaufträge (Batch- oder Array-Anweisungen) ausführen

SQLDBC::SQLDBC_ParameterMetaData

Mit den Methoden dieser Klasse können Sie Datentyp- und Längeninformationen von Parametern in SQL-Anweisungen abfragen.

SQLDBC::SQLDBC_ResultSetMetaData

Mit den Methoden dieser Klasse können Sie Datentyp- und Längeninformationen zu Spalten von Ergebnismengen von SQL-Anweisungen abfragen.

SQLDBC::SQLDBC_ResultSet

Verarbeiten von Ergebnismengen, die durch das Ausführen von SQL-Anweisungen mit den Methoden der Klasse SQLDBC_Statement oder der Klasse SQLDBC_PreparedStatement erzeugt wurden

Mit den Methoden dieser Klasse können Sie:

● in Ergebnismengen navigieren

● Ausschnitte (Row-Sets) aus Ergebnismengen erzeugen

● Programmvariablen zum Auslesen von Spaltenwerten von Ergebnismengen binden

● Blockoperationen zum Auslesen von Teilen (siehe Klasse SQLDBC_RowSet) oder der gesamten Ergebnismenge durchführen

SQLDBC::SQLDBC_RowSet

Auslesen von Daten aus Ergebnismengen

Row-Sets sind Ausschnitte aus Ergebnismengen, die mit Methoden der SQLDBC_ResultSet-Klasse erzeugt wurden.

Mit den Methoden dieser Klasse können Sie:

● einzelne Zeilen innerhalb des Ausschnittes (Row-Set) ansprechen

● einzelne Spalteninhalte in Programmvariablen übertragen

● mit Blockoperationen Spalteninhalte in Arrays von Programmvariablen übertragen

SQLDBC::SQLDBC_UpdatableRowSet

Diese Klasse ist von der Klasse SQLDBC_RowSet abgeleitet und enthält Methoden für änderbare Ergebnismengen.

Mit den Methoden dieser Klasse können Sie:

● Inhalte von Spalten ändern (UPDATE)

● Tabellenzeilen löschen (DELETE)

● neue Tabellenzeilen einfügen (INSERT)

SQLDBC::SQLDBC_LOB

Verarbeiten von Spaltenwerten aus Long-Spalten

Mit den Methoden dieser Klassen können Sie Long-Werte stückweise lesen und schreiben.

SQLDBC::SQLDBC_ErrorHndl

Mit den Methoden dieser Klasse können Sie Fehlermeldungen vorangegangener Operationen abfragen.

SQLDBC::SQLDBC_SQLWarning

Mit den Methoden dieser Klasse können Sie Warnungen vorangegangener Operationen abfragen.

Siehe auch:

Strukturlink SQL-Referenzhandbuch

Strukturlink SQL-Tutorial


SQLDBC-Traces (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation SQLDBC-Traces

Verwendung

Für die Fehlersuche und Problemanalyse stehen Ihnen mehrere SQLDBC-Traces zur Verfügung.

Traces beeinträchtigen die Performance. Schalten Sie Traces nur für die Fehlersuche und Problemanalyse ein.

SQLDBC-Traces

Trace | Inhalt
SQL | SQL-Anweisungen (einfachster Trace, ist für die meisten Analysen ausreichend)
PACKET | Kommunikationspakete
SHORT | Methodenaufrufe
LONG | Methodenaufrufe mit Aufrufparametern (umfangreichster Trace)

Um die SQLDBC-Traces zu konfigurieren, zu starten und zu stoppen, verwenden Sie das Werkzeug sqldbc_cons.

Alle SQLDBC-Traces enthalten unter anderem Profil- und Zeitstempelinformationen.

Die Trace-Dateien werden im Verzeichnis <user_home>\Application Data\sdb (Microsoft Windows) bzw. <user_home>/.sdb (UNIX/Linux) als Dateien sqldbctrace-<pid>.prt abgelegt, wobei <pid> die Prozess-ID ist. Die Trace-Dateien werden zyklisch überschrieben.

Siehe auch Installationshandbuch, Strukturlink Verzeichnisse.

Beispiel

Um den SQL-Trace einzuschalten, geben Sie folgendes Kommando ein:

sqldbc_cons TRACE SQL ON

Betriebssystembenutzerin anna verwendet das Datenbankwerkzeug SQLCLI. Sie meldet sich mit dem Datenbankwerkzeug SQLCLI als MONA an die Datenbankinstanz DEMODB an und fragt Daten der Tabelle CUSTOMER ab.

Der SQL-Trace wird in die Datei /home/anna/.sdb/sqldbctrace-19714.prt geschrieben:

<html><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body><PRE><PLAINTEXT>SQLDBC 7.6.0 BUILD 004-101-084-288 Nov 15 2004 23:56:34

--- THREAD 4D02 --- 2004-11-19 09:42:27.223840 ---

2004-11-19 09:42:27.224027 [0x8217CC8]

SERVERNODE: ''

SERVERDB : 'DEMODB'

USER : 'MONA'

CONNECT PROPERTIES: (1 entry)

KEY: 'SQLMODE' VALUE: 'INTERNAL'

CONNECT COMMAND: 'CONNECT "MONA" IDENTIFIED BY ? SQLMODE INTERNAL'

SESSION ID: 1

OK

::SET AUTOCOMMIT ON 2004-11-19 09:42:27.279370 [0x8217CC8]

::EXECUTE DBS 'SQLCURS_2' 2004-11-19 09:42:27.279581 [0x8219730]

SQL COMMAND: 'SELECT * FROM CUSTOMER'

RESULT COUNT: -1

CURSOR NAME: 'SQLCURS_2'

::GET RESULT SET [0x8219730]

CURSOR NAME: 'SQLCURS_2' [0x8219E08]

::FETCH NEXT 'SQLCURS_2' 2004-11-19 09:42:27.282629

...


sqldbc_cons (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation sqldbc_cons

Einsatzmöglichkeiten

sqldbc_cons können Sie verwenden, um Traces für die MaxDB SQLDBC-Schnittstelle zu konfigurieren und zu steuern.

Integration

sqldbc_cons ist Bestandteil von MaxDB SQLDBC.

Funktionsumfang

Syntax

sqldbc_cons [<command>] [<option>]

Optionen können Sie nur einzeln angeben. Sie können nicht kombiniert werden.

Kommandos

<command> | Beschreibung
TRACE SQL ON|OFF | schaltet den SQL-Trace ein/aus siehe SQLDBC-Traces
TRACE PACKET ON|OFF | schaltet den PACKET-Trace ein/aus
TRACE SHORT ON|OFF | schaltet den SHORT-Trace ein/aus
TRACE LONG ON|OFF | schaltet den ausführlichen LONG-Trace ein/aus
TRACE OFF | schaltet alle SQLDBC-Traces aus
TRACE FILENAME <file_name> | legt den Namen <file_name> der Trace-Datei fest Ein %p im Namen wird durch die Prozess-ID der Anwendung ersetzt, für die der Trace geschrieben wird.
TRACE SIZE <size> | legt die Größe <size> der Trace-Datei fest ( in Bytes)
SHOW ALL | zeigt die Konfiguration der Traces und aktuelle Informationen zu den Traces an
SHOW CONFIG | zeigt die Konfiguration der Traces an
SHOW TRACESETTINGS | zeigt aktuelle Informationen zu den Traces an

Optionen

<option> | Beschreibung
-f | erzwingt das Ausführen des Kommandos
-h | zeigt die Hilfe an
-p <pid> | führt das Kommando nur für den Prozess mit der Prozess-ID <pid> aus
-v | zeigt ausführliche Informationen an (verbose)


Java-Handbuch (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation Java-Handbuch

Einsatzmöglichkeiten

Diese Dokumentation beschreibt den MaxDB JDBC-Treiber und die MaxDB Java-Klassen.

Diese Dokumentation beschreibt nicht die Sun Java-Plattform. Informationen zu Java finden Sie unter java.sun.com.

Mit dem MaxDB JDBC-Treiber und den MaxDB Java-Klassen können Sie MaxDB-Datenbankinstanzen in Java-Anwendungen einbinden. Der MaxDB JDBC-Treiber und die MaxDB Java-Klassen können auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen eingesetzt werden.

Einführungshinweise

Der MaxDB JDBC-Treiber und die MaxDB Java-Klassen sind in der Softwarekomponente JDBC enthalten (siehe Installationshandbuch, Strukturlink Softwarekomponenten). Informationen dazu, wo Sie die MaxDB-Software erhalten, finden Sie im Abschnitt Strukturlink Download.

Sie installieren die Softwarekomponente JDBC auf dem Rechner, auf dem sich Ihre Java-Anwendung befindet. Nach der Installation finden Sie den JDBC-Treiber und die MaxDB Java-Klassen in der Datei sapdbc.jar im Verzeichnis <independent_program_path>\runtime\jar\

C:\Program Files\sdb\programs\runtime\jar\sapdbc.jar

Für das Verständnis dieser Dokumentation werden Grundkenntnisse der Programmiersprache Java sowie der JDBC-Spezifikation (siehe java.sun.com/products/jdbc) vorausgesetzt.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Integration

Sie benötigen eine Java-Plattform (siehe java.sun.com). Damit die Java-Plattform den MaxDB JDBC-Treiber und die MaxDB Java-Klassen findet, fügen Sie den Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzu.

Funktionsumfang

MaxDB Java-Klassen

Name | Funktionen | Java-Klassen
JDBC-Treiber | SQL-Anweisungen ausführen | com.sap.dbtech.jdbc.DriverSapDB com.sap.dbtech.jdbc.exceptions.* com.sap.dbtech.jdbcext.*
Database Manager-Java-Klassen | Datenbankinstanzen verwalten (DBM-Kommandos ausführen) | com.sap.dbtech.powertoys.DBM com.sap.dbtech.powertoys.DBMException
Loader-Java-Klassen | Daten importieren und exportieren (Loader-Kommandos und SQL-Anweisungen ausführen) | com.sap.dbtech.powertoys.Loader com.sap.dbtech.powertoys.LoaderException

Siehe auch:

Konzepte des Datenbanksystems,

● Strukturlink Schnittstellen

● Strukturlink Architektur der Schnittstellen


Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzufügen (SAP-Bibliothek - Schnittstellen)

Vorgehensweisen Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzufügen

Verwendung

Damit die Sun Java-Plattform den MaxDB JDBC-Treiber und die MaxDB Java-Klassen findet, fügen Sie den Pfad der Datei sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzu.

Voraussetzungen

Sie haben die Softwarekomponente JDBC installiert (siehe Installationshandbuch, Strukturlink Softwarekomponenten).

Vorgehensweise

...

1. Um den Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzuzufügen, geben Sie folgendes Kommando ein:

Microsoft Windows

set CLASSPATH=%CLASSPATH%;<independent_program_path>\runtime\jar\sapdbc.jar

UNIX (sh)

export CLASSPATH=$CLASSPATH:<independent_program_path>/runtime/jar/sapdbc.jar

Wenn Sie den Pfad von sapdbc.jar nicht in die Umgebungsvariable CLASSPATH aufnehmen möchten, dann können Sie beim Aufrufen von Java den vollständigen Pfad von sapdbc.jar folgendermaßen angeben:

Microsoft Windows

java -cp <independent_program_path>\runtime\jar\sapdbc.jar

UNIX (sh)

java -cp <independent_program_path>/runtime/jar/sapdbc.jar

2. Wenn notwendig, fügen Sie die Umgebungsvariable CLASSPATH zum Login-Profil des aktuellen Betriebssystembenutzers hinzu.

Siehe auch:

Installationshandbuch, Strukturlink Verzeichnisse


JDBC-Treiber (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation JDBC-Treiber

Verwendung

Um in einer Java-Anwendung SQL-Anweisungen in einer MaxDB-Datenbankinstanz auszuführen, verwenden Sie den MaxDB JDBC-Treiber.

Wichtige Eigenschaften des MaxDB JDBC-Treibers:

● "100 percent pure Java"

● unterstützt JDBC 2.0 Standard Extension API (DataSource, XADataSource und ConnectionPoolDataSource)

● Treiber des Typs 4 (Verbindung zur Datenbankinstanz wird über das MaxDB-spezifische Netzwerkprotokoll hergestellt)

Voraussetzungen

● Sie haben eine Java-Plattform installiert:

○ Sun Java JRE 1.2 bzw. für die Anwendungsentwicklung Sun Java JDK 1.2 (für JDBC 2.0)

○ Sun Java 2 Standard Edition 1.4 oder 1.5 bzw. für die Anwendungsentwicklung Sun Java JDK 1.4 oder 1.5 (für JDBC 3.0)

● Sie haben die Softwarekomponente JDBC installiert (siehe Installationshandbuch, Strukturlink Softwarekomponenten).

Funktionsumfang

● JDBC-Treiber laden

● Mit der Datenbankinstanz verbinden

● SQL-Anweisungen ausführen

● Fehlerbehandlung (JDBC-Treiber)

Die Java-Klassen des MaxDB JDBC-Treibers sind in der Datei <independent_program_path>\runtime\jar\sapdbc.jar enthalten.

C:\Program Files\sdb\programs\runtime\jar\sapdbc.jar

Java-Klassen des MaxDB JDBC-Treibers

Java-Klasse | Beschreibung
com.sap.dbtech.jdbc.DriverSapDB | JDBC-Treiber
com.sap.dbtech.powertoys.jdbc.exception.* | Fehlerbehandlung
com.sap.dbtech.jdbcext.DataSourceSapDB | Klasse für die JDBC 2.0 Standard Extension

Beispiel

Beispiel: SQL-Anweisung ausführen


JDBC-Treiber laden (SAP-Bibliothek - Schnittstellen)

Vorgehensweisen JDBC-Treiber laden

Verwendung

Sie verwenden die Methode forName der Klasse Class der Java-Plattform.

Voraussetzungen

· Sie haben eine Java-Plattform installiert:

¡ Sun Java JRE 1.2 bzw. für die Anwendungsentwicklung Sun Java JDK 1.2 (für JDBC 2.0)

¡ Sun Java 2 Standard Edition 1.4 oder 1.5 bzw. für die Anwendungsentwicklung Sun Java JDK 1.4 oder 1.5 (für JDBC 3.0)

· Sie haben den Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzugefügt.

Vorgehensweise

Class.forName("com.sap.dbtech.jdbc.DriverSapDB");

Ausführliche Informationen zur Methode forName finden Sie in der Dokumentation zur Java-Plattform, siehe java.sun.com.

Ergebnis

Beim Ausführen der Java-Anwendung lädt die Java-Plattform den MaxDB JDBC-Treiber und registriert ihn automatisch im JDBC-Treiber-Manager.

Wenn eine Ausnahme der Klasse java.lang.ClassNotFoundException ausgelöst wird, dann konnte die Java-Plattform den MaxDB JDBC-Treiber nicht finden.


Mit der Datenbankinstanz verbinden (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Mit der Datenbankinstanz verbinden

Verwendung

Um eine Java-Anwendung über JDBC mit einer MaxDB-Datenbankinstanz zu verbinden, haben Sie zwei Möglichkeiten:

● Sie verwenden die Methode java.sql.DriverManager.getConnection (Bestandteil der Java-Plattform).

● Sie verwenden die Klasse com.sap.dbtech.jdbcext.DataSourceSapDB (enthalten in sapdbc.jar).

SAP-Kunden können eine SSL-Verbindung zwischen Datenbankanwendung und Datenbankinstanz einrichten.

Voraussetzungen

● Sie haben den JDBC-Treiber geladen.

● Sie haben den X-Server gestartet (siehe X-Server, Strukturlink Starten des X-Servers)

Sie müssen den X-Server auch dann starten, wenn sich die Java-Anwendung und die Datenbankinstanz auf demselben Rechner befinden.

Beispiel

Beispiele: Mit der Datenbankinstanz verbinden


Methode java.sql.DriverManager.getConnection (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode java.sql.DriverManager.getConnection

Verwendung

Um eine Verbindung zwischen der Java-Anwendung und der Datenbankinstanz herzustellen und eine Datenbanksitzung zu eröffnen, können Sie die Methodejava.sql.DriverManager.getConnection der Java-Plattform verwenden. Diese Methode liefert ein Connection-Objekt, das mit der Datenbankinstanz verbunden ist.

Alternativ können Sie die Klasse com.sap.dbtech.jdbcext.DataSourceSapDB verwenden.

Ausführliche Informationen finden Sie in der Dokumentation zur Java-Plattform, siehe sun.java.com.

Voraussetzungen

● Sie haben den X-Server gestartet (siehe X-Server, Strukturlink Starten des X-Servers)

Sie müssen den X-Server auch dann starten, wenn sich die Java-Anwendung und die Datenbankinstanz auf demselben Rechner befinden.

● Sie haben den JDBC-Treiber geladen.

Funktionsumfang

Die Methode java.sql.DriverManager.getConnection hat den Pflichtparameter url (Verbindungs-URL), der folgende Verbindungsoptionen enthalten kann.

Verbindungsoptionen

Option

Vorschlagswert

Beschreibung

acceptServerCertificateAlways

off

nur für SSL-Verbindungen

legt fest, ob das das Datenbanksystem überprüft, ob das SSL-Zertifikat des Datenbankrechners in der Liste der vertrauenswürdigen Zertifikate enthalten ist und ob es noch gültig ist

Mögliche Werte:

off: Das Datenbanksystem überprüft das SSL-Zertifikat.

on: Das Datenbanksystem überprüft das SSL-Zertifikat nicht.

autocommit

on

AUTOCOMMIT-Modus

on: Das Datenbanksystem beendet jede SQL-Anweisung automatisch mit einem COMMIT.

off: Sie müssen Transaktionen explizit mit den Methoden commit () und rollback () beenden.

cache

-

gibt an, für welche SQL-Anweisungen in Prepared Statements der JDBC-Treiber Informationen (z. B. zu den verwendeten Parametern) in einem eigenen Cache speichert

Mögliche Werte:

all: alle SQL-Anweisungen

Kombination aus den folgenden Buchstaben

s (SELECT-Anweisungen)

i (INSERT-Anweisungen)

u (UPDATE-Anweisungen)

d (DELETE-Anweisungen)

cache=iud

Das Datenbanksystem speichert Informationen zu INSERT-, UPDATE- und DELETE-Anweisungen im Cache.

connectiontimeout

0

Timeout für die Verbindung (in Millisekunden)

Der Wert 0 bedeutet, dass es keinen Timeout gibt.

ignoreHostNameInServerCert

off

nur für SSL-Verbindungen

legt fest, ob das Datenbanksystem den Namen des Datenbankrechners mit dem im SSL-Zertifikat angegebenen Namen vergleicht

Mögliche Werte:

off: Das Datenbanksystem vergleicht die Namen.

on: Das Datenbanksystem vergleicht die Namen nicht.

isolation

-

Isolation-Level der Verbindung

Sie können den Isolation-Level entweder als Zeichenkette oder als ganzzahligen Wert angeben werden (je nachdem, wie Sie ihn in der Klasse java.sql.Connection deklariert haben).

Folgende Zeichenketten können Sie angeben:

TRANSACTION_READ_UNCOMMITTED | TRANSACTION_READ_COMMITTED | TRANSACTION_REPEATABLE_READ | TRANSACTION_SERIALIZABLE

Folgende ganzzahlige Werte können Sie angeben: siehe Konzepte des Datenbanksystems, Strukturlink Isolation-Level.

password

-

Kennwort des Datenbankbenutzers

Beachten Sie die Groß- und Kleinschreibung, siehe Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter.

reconnect

on

RECONNECT-Modus

Mögliche Werte:

on: Nach einem Kommando-Timeout wird vom System automatisch eine neue Verbindung aufgebaut.

off: Die Verbindung wird nicht automatisch wieder aufgebaut.

sqlmode

INTERNAL

SQL-Modus

ORACLE | INTERNAL

timeout

Timeout für die Datenbanksitzung (in Sekunden)

Wenn Sie diese Verbindungsoption angeben, übersteuern Sie den Timeout, der für die Datenbankinstanz mit dem speziellen Datenbankparameter SESSION_TIMEOUT konfiguriert wurde (siehe Konzepte des Datenbanksystems, Strukturlink Spezielle Datenbankparameter).

trace

-

<directory>/<jdbc_trace_file>

Wenn Sie diese Verbindungsoption angeben, dann schreibt das Datenbanksystem einen JDBC-Trace in die Datei <jdbc_trace_file> im Verzeichnis <directory>.

tracesize

-

maximale Anzahl der Zeilen in der JDBC-Trace-Datei

Wenn diese Anzahl von Zeilen überschritten wird, dann beginnt das Datenbanksystem, den Inhalt der JDBC-Trace-Datei zu überschreiben.

transport

socket

Kommunikationsmethode für die Kommunikation mit dem DBM-Server

Mögliche Werte:

socket: TCP/IP-Verbindung

secure: SSL-Verbindung, siehe SSL-Verbindung einrichten

unicode

false

Wenn Sie diese Verbindungsoption angeben, dann sendet der JDBC-Treiber Benutzername, Kennwort und SQL-Anweisungen in Unicode an die Datenbankinstanz.

user

-

Name des Datenbankbenutzers

Beispiel

Beispiele: Mit der Datenbankinstanz verbinden


Klasse com.sap.dbtech.jdbcext.DataSourceSapDB (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse com.sap.dbtech.jdbcext.DataSourceSapDB

Verwendung

Um eine Verbindung zwischen der Java-Anwendung und der Datenbankinstanz herzustellen und eine Datenbanksitzung zu eröffnen, können Sie die Klasse com.sap.dbtech.jdbcext.DataSourceSapDB verwenden (Bestandteil von sapdbc.jar). Diese Klasse implementiert die Schnittstelle javax.sql.DataSource der Sun Java-Plattform. Weitere Informationen finden Sie unter java.sun.com.

Alternativ können Sie die Methode java.sql.DriverManager.getConnection der Java-Plattform verwenden.

Voraussetzungen

● Sie haben den X-Server gestartet (siehe X-Server, Strukturlink Starten des X-Servers)

Sie müssen den X-Server auch dann starten, wenn sich die Java-Anwendung und die Datenbankinstanz auf demselben Rechner befinden.

● Sie haben den JDBC-Treiber geladen.

Funktionsumfang

Methoden der Klasse com.sap.dbtech.jdbcext.DataSourceSapDB

Methode | Aufgabe
<type> get<property_name>() | Wert der Eigenschaft abfragen
void set<property_name>(<type> <value>) | Wert für die Eigenschaft setzen

<property_name> = Name der Eigenschaft (siehe unten), der erste Buchstabe des Namens wird groß geschrieben

String getCache()

String getDatabaseName()

Eigenschaften von DataSourceSapDB-Objekten

<property_name> | Vorschlagswert | Beschreibung
cache | - | gibt an, für welche SQL-Anweisungen in Prepared Statements der JDBC-Treiber Informationen (z. B. zu den verwendeten Parametern) in einem eigenen Cache speichert Mögliche Werte: ● all: alle SQL-Anweisungen ● Kombination aus den folgenden Buchstaben s (SELECT-Anweisungen) i (INSERT-Anweisungen) u (UPDATE-Anweisungen) d (DELETE-Anweisungen) cache=iud Das Datenbanksystem speichert Informationen zu INSERT-, UPDATE- und DELETE-Anweisungen im Cache.
databaseName | - | Datenbankname
description | - | frei wählbare Beschreibung
loginTimeout | 30 | Timeout für die Anmeldung (in Sekunden)
password | - | Kennwort
port | 7210 | Port des X-Servers auf dem Datenbankrechner siehe X-Server, Strukturlink Ports und Protokolle des X-Servers
reconnect | on | RECONNECT-Modus Mögliche Werte: on: Nach einem Kommando-Time-out wird vom System automatisch eine neue Verbindung aufgebaut. off: Die Verbindung wird nicht automatisch wieder aufgebaut.
serverName | localhost | Datenbankrechner
sqlMode | INTERNAL | SQL-Modus ORACLE | INTERNAL
timeout | - | Timeout für die Datenbanksitzung (in Sekunden) Wenn Sie diese Verbindungsoption angeben, übersteuern Sie den Timeout, der für die Datenbankinstanz mit dem speziellen Datenbankparameter SESSION_TIMEOUT konfiguriert wurde (siehe Konzepte des Datenbanksystems, Strukturlink Spezielle Datenbankparameter).
trace | - | <directory>/<jdbc_trace_file> Wenn Sie diese Verbindungsoption angeben, dann schreibt das Datenbanksystem einen JDBC-Trace in die Datei <jdbc_trace_file> im Verzeichnis <directory>.
traceSize | - | maximale Anzahl der Zeilen in der JDBC-Trace-Datei Wenn diese Anzahl von Zeilen überschritten wird, dann beginnt das Datenbanksystem, den Inhalt der JDBC-Trace-Datei zu überschreiben.
transport | socket | Kommunikationsmethode für die Kommunikation mit dem DBM-Server Mögliche Werte: socket: TCP/IP-Verbindung secure: SSL-Verbindung, siehe SSL-Verbindung einrichten
unicode | false | Unicode-Unterstützung true: der JDBC-Treiber sendet Benutzername, Kennwort und SQL-Anweisungen in Unicode an die Datenbankinstanz false: der JDBC-Treiber verwendet ASCII
url | - | Verbindungs-URL
user | - | Name des Datenbankbenutzers

Sie können die meisten Eigenschaften auch als Verbindungsoptionen innerhalb der Verbindungs-URL url übergeben. Ausnahmen sind die folgenden Eigenschaften: description, databasename, servername, url, port, loginTimeout.

Beispiel

Beispiele: Mit der Datenbankinstanz verbinden


Verbindungs-URL (SAP-Bibliothek - Schnittstellen)

Objektdokumentation Verbindungs-URL

Definition

In der Verbindungs-URL url definieren Sie Eigenschaften der Verbindung zur Datenbankinstanz. Ausführliche Informationen finden Sie in der Dokumentation zur Java-Plattform, siehe sun.java.com.

Sytax

jdbc:sapdb://<database_computer>[:<port>]/<database_name>[?<option1>[&<option2>]...]

<database_computer> | Name des Datenbankrechners
<port> | Port des X-Servers auf dem Datenbankrechner Wenn Sie den Vorschlagswert für den Port des X-Servers nicht geändert haben, dann müssen Sie den Port in der Verbindungs-URL nicht angeben. Siehe X-Server, Strukturlink Ports und Protokolle des X-Servers
<database_name> | Datenbankname
<option1>,<option2>,... | Eigenschaften der Verbindung Siehe ● Methode java.sql.DriverManager.getConnection ● Klasse com.sap.dbtech.jdbcext.DataSourceSapDB

Beispiel

jdbc:sapdb://PARMA:9876/DEMODB?sqlmode=ORACLE&timeout=120

Mit dieser Verbindungs-URL stellen Sie eine Verbindung zur Datenbankinstanz DEMODB auf dem entfernten Rechner PARMA her. Der X-Server auf dem Rechner PARMA verwendet den Port 9876. Als Verbindungsoptionen haben Sie den SQL-Modus ORACLE und einen Timeout für die Datenbanksitzung von 120 Sekunden gewählt.

Siehe auch:

Beispiele: Mit der Datenbankinstanz verbinden


SSL-Verbindung einrichten (SAP-Bibliothek - Schnittstellen)

Vorgehensweisen SSL-Verbindung einrichten

Verwendung

Um die Kommunikation zwischen der Java-Anwendung und der Datenbankinstanz zu verschlüsseln, können Sie SSL verwenden.

Voraussetzungen

● Sie verwenden MaxDB in einem SAP-System.

● Sie haben MaxDB 7.6 oder höher installiert.

● Sie haben die MaxDB-Installation für SSL konfiguriert. Weitere Informationen finden Sie im Installationsleitfaden (siehe Konzepte des Datenbanksystems, Strukturlink Download).

● Sie haben Sun Java JDK 1.4.0 oder höher installiert (siehe java.sun.com).

Vorgehensweise

Wenn Sie das Server-Zertifikat von einer Zertifizierungsstelle erhalten haben, die in der Liste der vertrauenswürdigen Zertifizierungsstellen der Java-Plattform enthalten ist, dann beginnen Sie mit Schritt 2.

...

1. Um das Server-Zertifikat zur Liste der vertrauenswürdigen Zertifikate hinzuzufügen, importieren Sie es mit dem Programm keytool der Java-Plattform in eine Truststore-Datei. Sie benötigen hierfür folgende Informationen:

○ Name der Truststore-Datei

○ Kennwort der Truststore-Datei

○ Name der Datei, in der das Zertifikat für MaxDB gespeichert ist

Weitere Informationen finden Sie in der Dokumentation zum Programm keytool (siehe java.sun.com).

2. Wählen Sie folgende Eigenschaft für die Verbindung:

transport=secure

Siehe

○ Methode java.sql.DriverManager.getConnection

○ Klasse com.sap.dbtech.jdbcext.DataSourceSapDB

Ergebnis

Die Java-Anwendung verwendet SSL für die Verbindung zur Datenbankinstanz.

Sie können die Verbindungsoptionen so wählen, dass das Datenbanksystem beim Herstellen einer SSL-Verbindung nicht alle Sicherheitsüberprüfungen durchführt.

Schalten Sie Überprüfungen nur zu Entwicklungs- oder Testzwecken ab, weil sonst die Sicherheit der Verbindung zur Datenbankinstanz nicht oder nur teilweise gewährleistet ist.

Siehe auch:

Mit der Datenbankinstanz verbinden


Beispiele: Mit der Datenbankinstanz verbinden (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiele: Mit der Datenbankinstanz verbinden

Die folgenden Beispiele zeigen verschiedene Möglichkeiten, wie Sie Ihre Java-Anwendung mit der Datenbankinstanz verbinden können.

Es werden die folgenden Beispieldaten verwendet:

Beschreibung | Eigenschaft | Beispiel
Name des Datenbankbenutzers | user | MONA
Kennwort des Datenbankbenutzers | password | RED
Name der Datenbankinstanz | - | DEMODB
Name des Rechners, auf dem die Datenbankinstanz läuft | server | PARMA
SQL-Modus | sqlmode | ORACLE

Verbindung mit der Methode java.sql.DriverManager.getConnection herstellen

Um die Verbindungsoptionen zu übergeben, haben Sie folgende Möglichkeiten:

● Sie übergeben die Verbindungsoptionen als Teil der Verbindungs-URL.

Die Verbindungs-URL url hat folgenden Inhalt: "jdbc:sapdb://PARMA/DEMODB?sqlmode=ORACLE"

Um die Verbindung mit der Datenbankinstanz herzustellen, rufen Sie die Methode jgetConnection folgendermaßen auf:

java.sql.Connection conn = java.sql.DriverManager.getConnection(url, "MONA", "RED");

● Sie übergeben sowohl die Verbindungsoptionen als auch Name und Kennwort des Datenbankbenutzers als Teil der Verbindungs-URL.

Die Verbindungs-URL url hat folgenden Inhalt:
"jdbc:sapdb://PARMA/DEMODB?sqlmode=ORACLE&user=MONA&password=RED"

Um die Verbindung mit der Datenbankinstanz herzustellen, rufen Sie die Methode getConnection folgendermaßen auf:

java.sql.Connection conn = java.sql.DriverManager.getConnection(url);

● Sie übergeben Verbindungsoptionen, Name und Kennwort des Datenbankbenutzers in einem Objekt der Klasse java.util.Properties.

Die Verbindungs-URL url hat folgenden Inhalt:

"jdbc:sapdb://PARMA/DEMODB"

...

                            a.      Sie erzeugen ein Objekt der Klasse java.util.Properties:

java.util.Properties properties = new java.util.Properties();

b. Sie definieren die Verbindungsoptionen:

properties.setProperty ("user", "MONA");

properties.setProperty ("password", "RED");

properties.setProperty ("sqlmode", "ORACLE");

c. Um die Verbindung zur Datenbankinstanz herzustellen, rufen Sie die Methode getConnection folgendermaßen auf:

java.sql.Connection conn = java.sql.DriverManager.getConnection(url, properties);

Weitere Informationen finden Sie unter Methode java.sql.DriverManager.getConnection.

Verbindung mit der Klasse com.sap.dbtech.jdbcext.DataSourceSapDB herstellen

import java.sql.Connection;

import java.sql.Statement;

import java.sql.SQLException;

import javax.sql.DataSource;

import java.sql.ResultSet;

import com.sap.dbtech.jdbcext.DataSourceSapDB;

public final class HelloDataSource

{

public static void main (String[] args) throws SQLException

{

String dbUser = "MONA";

String password = "RED";

String dbName = "DEMODB";

String dbServer = "PARMA";

DataSourceSapDB ds = null;

ds = new DataSourceSapDB();

ds.setUser(dbUser);

ds.setPassword(password);

ds.setDatabaseName(dbName);

ds.setServer(dbServer);

Connection c = ds.getConnection();

Statement s = c.createStatement();

ResultSet rs = s.executeQuery("SELECT * FROM

HOTEL.CITY");

rs.next();

System.out.println(rs.getString(1));

return;

}

}

Weitere Informationen finden Sie unter Klasse com.sap.dbtech.jdbcext.DataSourceSapDB.


SQL-Anweisungen ausführen (SAP-Bibliothek - Schnittstellen)

Vorgehensweisen SQL-Anweisungen ausführen

Voraussetzungen

Sie haben eine Verbindung zur Datenbankinstanz hergestellt.

Vorgehensweise

Sie gehen vor wie in der JDBC-Spezifikation beschrieben. Weitere Informationen finden Sie unter java.sun.com/products/jdbc.

Beispiel

Beispiel: SQL-Anweisungen ausführen


Fehlerbehandlung (JDBC-Treiber) (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Fehlerbehandlung (JDBC-Treiber)

Verwendung

Wenn Fehler auftreten, löst der JDBC-Treiber Ausnahmen (Exceptions) der folgenden Klassen aus. Alle Klassen sind Unterklassen der Klasse java.sql.SQLException der Java-Plattform.

Ausnahmen

Klasse | Beschreibung
com.sap.dbtech.jdbc.exceptions.DatabaseException | Fehler beim Ausführen einer SQL-Anweisung
com.sap.dbtech.jdbc.exceptions.InternalJDBCError | interner Fehler des JDBC-Treibers
com.sap.dbtech.jdbc.exceptions.InvalidArgumentValue | ein ungültiger Parameterwert wurde an eine Methode übergeben
com.sap.dbtech.jdbc.exceptions.InvalidColumnException | es wurde auf eine ungültige Spalte eines Objektes der Klasse ResultSet zugegriffen
com.sap.dbtech.jdbc.exceptions.JDBCDriverException | interner Fehler des JDBC-Treibers
com.sap.dbtech.jdbc.exceptions.NotSupportedException | es wurde eine Eigenschaft verwendet, die der JDBC-Treiber nicht unterstützt
com.sap.dbtech.jdbc.exceptions.ObjectIsClosedException | es wurde auf ein Objekt der Klasse Connection, Statement oder ResultSet zugegriffen, nachdem die Methode close für dieses Objekt aufgerufen wurde
com.sap.dbtech.jdbc.exceptions.PrepareExecution | Fehler beim Vorbereiten einer SQL-Anweisung
com.sap.dbtech.jdbc.translators.ConversionExceptionSapDB | Fehler beim Konvertieren zwischen Java- und SQL-Datentypen

Um eine Java-Anwendung zu schreiben, die vom Datenbankprodukt unabhängig ist, fragen Sie in catch-Anweisungen nicht explizit die oben genannten Ausnahmen, sondern nur Ausnahmen der Klasse java.sql.SQLException ab.


Beispiel: HelloMaxDB (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: HelloMaxDB

Das folgende Beispiel zeigt den Quelltext der Java-Klasse HelloMaxDB.

Die einzelnen Schritte sind in den Kommentaren des Beispiels erklärt.

HelloMaxDB.java

import java.sql.*;

public class HelloMaxDB

{

public static void main (String [] args)

throws ClassNotFoundException, SQLException

{

String username = "MONA";

String password = "RED";

String host = "";

String dbname = "DEMODB";

/*

* JDBC-Treiber laden

*/

Class.forName ("com.sap.dbtech.jdbc.DriverSapDB");

/*

* Verbindungs-URL definieren

*/

String url = "jdbc:sapdb://" + host + "/" + dbname;

/*

* Mit der Datenbankinstanz verbinden

*/

Connection connection = DriverManager.getConnection (url, username, password);

/*

* SQL-Anweisungen ausführen

*/

Statement stmt = connection.createStatement ();

ResultSet resultSet = stmt.executeQuery ("SELECT * FROM HOTEL.CUSTOMER");

resultSet.next ();

String hello = resultSet.getString (1);

System.out.println (hello);

/*

* alle Objekte schließen

*/

resultSet.close ();

stmt.close ();

connection.close ();

}

}


Database Manager-Java-Klassen (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Database Manager-Java-Klassen

Verwendung

Um eine MaxDB-Datenbankinstanz in einer Java-Anwendung zu verwalten, verwenden Sie Database Manager-Java-Klassen.

Voraussetzungen

● Sie haben die Softwarekomponente JDBC installiert (siehe Installationshandbuch, Strukturlink Softwarekomponenten).

● Sie haben den Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzugefügt.

Funktionsumfang

Die Database Manager-Java-Klassen sind in der Datei <independent_program_path>\runtime\jar\sapdbc.jar enthalten.

C:\Program Files\sdb\programs\runtime\jar\sapdbc.jar

Database Manager-Java-Klassen

Klasse | Aufgabe
com.sap.dbtech.powertoys.DBM | Verbindung zur Datenbankinstanz herstellen und beenden DBM-Kommandos (Kommandos des Administrationswerkzeugs Database Manager) ausführen
com.sap.dbtech.powertoys.DBMException | Fehlerbehandlung

Methoden der Klasse com.sap.dbtech.powertoys.DBM

Methode | Aufgabe
dbrootDBM | Java-Anwendung mit dem DBM-Server einer bestimmten Softwareversion verbinden Sie benötigen diese Methode, um eine neue Datenbankinstanz anzulegen.
dbDBM | Java-Anwendung über den Database Manager mit einer Datenbankinstanz verbinden
cmd | DBM-Kommandos ausführen
cancel | DBM-Kommando abbrechen
release | Verbindung zum Database Manager beenden

Methoden der Klasse com.sap.dbtech.powertoys.DBMException

siehe Fehlerbehandlung (Database Manager)

Beispiel

Beispiel: Betriebszustand der Datenbankinstanz anzeigen

Siehe auch:

Database Manager CLI, Strukturlink Übersicht aller DBM-Kommandos

Dokumentation zum Strukturlink Database Manager CLI

Dokumentation zum Strukturlink Database Manager GUI


Methode com.sap.dbtech.powertoys.DBM.dbrootDBM (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.DBM.dbrootDBM

Verwendung

Um eine Java-Anwendung mit dem DBM-Server einer bestimmten Softwareversion zu verbinden, verwenden Sie die Methode com.sap.dbtech.powertoys.DBM.dbrootDBM.

Verwenden Sie diese Methode nur dann, wenn Sie mit Ihrer Java-Anwendung eine neue Datenbankinstanz anlegen möchten.

Um andere DBM-Kommandos auszuführen, verwenden Sie die Methode com.sap.dbtech.powertoys.DBM.dbDBM, um die Verbindung zur Datenbankinstanz herzustellen.

Voraussetzungen

· Sie haben als Betriebssystembenutzer Zugriff auf den Rechner, auf dem Sie die neue Datenbankinstanz anlegen.

· Auf Microsoft Windows benötigen Sie auf diesem Rechner außerdem Administrationsrechte und das Recht Log on as batch job.

Funktionsumfang

public static DBM dbrootDBM(String database_computer, String dependent_path)

throws

com.sap.dbtech.rte.comm.RTEException

Parameter

Name

Beschreibung

database_computer

Name des Datenbankrechners, auf dem die Datenbankinstanz läuft

Um die Verbindung zu einem DBM-Server auf dem lokalen Rechner herzustellen, geben Sie den Wert null an.

dependent_path

Pfad der Datenbanksoftware in der gewünschten Version

Um die Verbindung zum DBM-Server mit der höchsten Softwareversion herzustellen, geben Sie den Wert null an.

Um die Pfade und Versionen der auf Ihrem Rechner installierten Datenbanksoftware anzuzeigen, geben Sie auf der Kommandozeile folgendes Kommando ein:

dbmcli db_enum

Ausnahmen

Klasse | Beschreibung
com.sap.dbtech.rte.comm.RTEException | siehe Fehlerbehandlung (Database Manager)

Siehe auch:

Database Manager-Java-Klassen


Methode com.sap.dbtech.powertoys.DBM.dbDBM (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.DBM.dbDBM

Verwendung

Um in einer Java-Anwendung DBM-Kommandos ausführen zu können, verbinden Sie die Java-Anwendung zunächst über den Database Manager mit einer Datenbankinstanz. Hierzu verwenden Sie die Methode com.sap.dbtech.powertoys.DBM.dbDBM.

Um eine neue Datenbankinstanz anzulegen, stellen Sie die Verbindung zur Datenbankinstanz mit der Methode com.sap.dbtech.powertoys.DBM.dbrootDBM her.

Funktionsumfang

public static DBM dbDBM(String database_computer, String database_name)

throws

com.sap.dbtech.rte.comm.RTEException

Parameter

Name | Beschreibung
database_computer | Name des Datenbankrechners Um die Verbindung zu einer Datenbankinstanz auf dem lokalen Rechner herzustellen, geben Sie den Wert null an.
database_name | Datenbankname

Ausnahmen

Klasse | Beschreibung
com.sap.dbtech.rte.comm.RTEException | siehe Fehlerbehandlung (Database Manager)

Siehe auch:

Database Manager-Java-Klassen


Methode com.sap.dbtech.powertoys.DBM.cmd (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.DBM.cmd

Verwendung

Um in Ihrer Java-Anwendung DBM-Kommandos auszuführen, verwenden Sie die Methode com.sap.dbtech.powertoys.DBM.cmd.

Voraussetzungen

· Sie sind mit der Datenbankinstanz verbunden, siehe Methode com.sap.dbtech.powertoys.DBM.dbDBM.

· Die meisten DBM-Kommandos können Sie nur ausführen, wenn Sie an der Datenbankinstanz angemeldet sind. Um sich an die Datenbankinstanz anzumelden, verwenden Sie das DBM-Kommando user_logon (siehe Database Manager CLI, Strukturlink user_logon).

Funktionsumfang

public String cmd(String dbm_command)

throws

com.sap.dbtech.rte.comm.RTEException,

com.sap.dbtech.powertoys.DBMException;

Parameter

Parameter | Beschreibung
dbm_command | DBM-Kommando siehe Database Manager CLI, Strukturlink Übersicht aller DBM-Kommandos

Rückgabewert

Der Rückgabewert der Methode enthält den Rückgabewert des DBM-Kommandos.

Ausnahmen

Klassen | Beschreibung
com.sap.dbtech.rte.comm.RTEException com.sap.dbtech.powertoys.DBMException | siehe Fehlerbehandlung (Database Manager)

Der Rückgabewert der Methode enthält den Rückgabewert des DBM-Kommandos.

Beispiel

Sie verwenden in der Methode cmd das DBM-Kommando user_logon, mit dem Sie den DBM-Benutzer OLEG mit dem Kennwort MONDAY an die Datenbankinstanz anmelden:

String result = session.cmd ("user_logon OLEG,MONDAY");

Siehe auch:

Beispiel: Betriebszustand der Datenbankinstanz anzeigen

Fehlerbehandlung (Database Manager)


Methode com.sap.dbtech.powertoys.DBM.cancel (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.DBM.cancel

Verwendung

Um das DBM-Kommando abzubrechen, das gerade ausgeführt wird, verwenden Sie in Ihrer Java-Anwendung die Methode com.sap.dbtech.powertoys.DBM.cancel.

Funktionsumfang

public void cancel()

throws

java.sql.SQLException

Siehe auch:

Database Manager-Java-Klassen


Methode com.sap.dbtech.powertoys.DBM.release (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.DBM.release

Verwendung

Um die Verbindung zwischen Database Manager und Datenbankinstanz zu beenden, verwenden Sie die Methode com.sap.dbtech.powertoys.release.

Der JDBC-Treiber ruft diese Methode implizit auf, wenn der Garbage-Collector ein Objekt der Klasse DBM löscht.

Funktionsumfang

public void release()

throws

com.sap.dbtech.rte.comm.RTEException

Ausnahmen

Klasse | Beschreibung
com.sap.dbtech.rte.comm.RTEException | siehe Fehlerbehandlung (Database Manager)

Beispiel

session.release();

Siehe auch:

Beispiel: Betriebszustand der Datenbankinstanz anzeigen

Database Manager-Java-Klassen


Fehlerbehandlung (Database Manager) (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Fehlerbehandlung (Database Manager)

Verwendung

Wenn Fehler bei der Verwendung der Database Manager-Java-Klassen auftreten, löst das System folgende Ausnahmen aus:

Ausnahmen

Klasse | Wann wird diese Ausnahme ausgelöst?
com.sap.dbtech.powertoys.DBMException | Wenn der Database Manager einen Fehler meldet.
com.sap.dbtech.rte.comm.RTEException | Wenn die Java-Plattform keine Verbindung zum Database Manager herstellen kann. Wenn eine bestehende Verbindung unterbrochen wird.

Funktionsumfang

Methoden der Klasse com.sap.dbtech.powertoys.DBMException

Methode | Beschreibung
public int getErrorCode() | Das System gibt den Fehlercode des Database Manager aus.
public String getErrorID() | Das System gibt die Fehlernummer des Database Manager aus.
public String toString() | Das System gibt die Exception als String-Objekt aus.

Siehe auch:

Beispiel: Betriebszustand der Datenbankinstanz anzeigen


Beispiel: Betriebszustand der Datenbankinstanz anzeigen (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Betriebszustand der Datenbankinstanz anzeigen

Dieses Beispiel zeigt, wie Sie in Ihrer Java-Anwendung den Betriebszustand der Datenbankinstanz anzeigen.

Die einzelnen Schritte sind in den Kommentaren des Beispiels erklärt.

import com.sap.dbtech.powertoys.*;

import com.sap.dbtech.rte.comm.RTEException;

public class DBMDemo

{

public

DBMDemo()

{

}

public static void main(String [] args)

{

DBM session;

try {

// Sie stellen die Verbindung zur Datenbankinstanz DEMODB her.

// siehe Methode com.sap.dbtech.powertoys.DBM.dbDBM

session = DBM.dbDBM(null, "DEMODB");

}

catch (RTEException rteExc) {

System.out.println("connect failed: " + rteExc.toString());

return;

}

try {

// Sie melden sich als DBM-Benutzer OLEG mit Kennwort MONDAY an.

// siehe Methode com.sap.dbtech.powertoys.DBM.cmd

session.cmd("user_logon OLEG,MONDAY");

// Sie zeigen den Betriebszustand der Datenbankinstanz an.

String result = session.cmd("db_state");

System.out.println(result);

}

catch(RTEException rteExc) {

System.out.println("connection broken: " + rteExc.toString());

}

catch(DBMException dbmExc) {

System.out.println("command failed: " + dbmExc.toString ());

}

finally {

try {

// Sie beenden die Verbindung zum Database Manager.

// siehe Methode com.sap.dbtech.powertoys.DBM.release

session.release();

}

catch(RTEException rteExc) {

// ignore

}

}

}

}

Siehe auch:

Database Manager-Java-Klassen


Loader-Java-Klassen (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Loader-Java-Klassen

Verwendung

Um Daten aus Datenbankinstanzen in eine Java-Anwendung zu importieren oder aus einer Java-Anwendung zu exportieren, verwenden Sie die Loader-Java-Klassen.

Voraussetzungen

● Sie haben die Softwarekomponente JDBC installiert (siehe Installationshandbuch, Strukturlink Softwarekomponenten).

● Sie haben den Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzugefügt.

Funktionsumfang

Die Loader-Java-Klassen sind in der Datei <independent_program_path>\runtime\jar\sapdbc.jar enthalten.

C:\Program Files\sdb\programs\runtime\jar\sapdbc.jar

Loader-Java-Klassen

Klasse | Aufgabe
com.sap.dbtech.powertoys.Loader | Verbindung zur Datenbankinstanz herstellen und beenden Loader-Kommandos (Kommandos des Werkzeugs Loader) und SQL-Anweisnungen ausführen
com.sap.dbtech.powertoys.LoaderException | Fehlerbehandlung

Methoden der Klasse com.sap.dbtech.powertoys.Loader

Methode | Aufgabe
dbLoader | Java-Anwendung mit dem Loader verbinden
cmd | Loader-Kommando oder SQL-Anweisung ausführen
cancel | Loader-Kommando oder SQL-Anweisung abbrechen
finalize | Diese Methode überschreibt die Methode finalize() der Klasse java.lang.Object.
release | Verbindung zum Loader beenden

Methoden den Klasse com.sap.dbtech.powertoys.LoaderException

siehe Fehlerbehandlung (Loader)

Beispiel

Beispiel: Tabelle exportieren

Siehe auch:

Loader, Strukturlink Kommandos und SQL-Anweisungen

Dokumentation zum Strukturlink Loader


Methode com.sap.dbtech.powertoys.Loader.dbLoader (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.Loader.dbLoader

Verwendung

Um in einer Java-Anwendung Loader-Kommandos ausführen zu können, verbinden Sie die Java-Anwendung zunächst über den Loader mit einer Datenbankinstanz. Hierzu verwenden Sie die Methode com.sap.dbtech.powertoys.Loader.dbLoader.

Das System verwendet automatisch die neueste Loader-Version, die auf dem Rechner verfügbar ist, auf dem der Loader läuft. Der Loader läuft in der Regel auf dem gleichen Rechner wie die Java-Anwendung.

Funktionsumfang

public static Loader dbLoader(String database_computer, String database_name)

throws

com.sap.dbtech.rte.comm.RTEException

Parameter

Name | Beschreibung
database_computer | Name des Rechners, auf dem die Datenbankinstanz läuft
database_name | Datenbankname

Ausnahmen

Klasse | Beschreibung
com.sap.dbtech.rte.comm.RTEException | siehe Fehlerbehandlung (Loader)

Um sich an die Datenbankinstanz anzumelden, führen Sie das Loader-Kommando USE USER aus, siehe Methode com.sap.dbtech.powertoys.Loader.cmd.

Siehe auch:

Beispiel: Tabelle exportieren

Loader-Java-Klassen


Methode com.sap.dbtech.powertoys.Loader.cmd (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.Loader.cmd

Verwendung

Um Loader-Kommandos und SQL-Anweisungen auszuführen, verwenden Sie die Methode com.sap.dbtech.powertoys.Loader.cmd.

Voraussetzungen

● Sie haben die Verbindung zum Loader hergestellt, siehe Methode com.sap.dbtech.powertoys.Loader.dbLoader.

● Für einige Loader-Kommandos und SQL-Anweisungen gelten zusätzliche Voraussetzungen. Weitere Informationen finden Sie unter Loader, Strukturlink Kommandos und SQL-Anweisungen.

Funktionsumfang

public String cmd(String loader_command)

throws

com.sap.dbtech.rte.comm.RTEException,

com.sap.dbtech.powertoys.LoaderException

Parameter

Name | Beschreibung
loader_command | Loader-Kommando oder SQL-Anweisung

Rückgabewert

Der Rückgabewert der Methode enthält den Rückgabewert des Loader-Kommandos oder der SQL-Anweisung.

Ausnahmen

Klasse | Beschreibung
com.sap.dbtech.rte.comm.RTEException com.sap.dbtech.powertoys.LoaderException | siehe Fehlerbehandlung (Loader)

Siehe auch:

Beispiel: Tabelle exportieren

Loader-Java-Klassen


Methode com.sap.dbtech.powertoys.Loader.cancel (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.Loader.cancel

Verwendung

Um das Loader-Kommando/die SQL-Anweisung abzubrechen, das/die gerade ausgeführt wird, verwenden Sie in Ihrer Java-Anwendung die Methode com.sap.dbtech.powertoys.Loader.cancel.

Funktionsumfang

public void cancel()

throws

java.sql.SQLException

Siehe auch:

Loader-Java-Klassen


Methode com.sap.dbtech.powertoys.Loader.release (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode com.sap.dbtech.powertoys.Loader.release

Verwendung

Um die Verbindung zum Loader zu beenden, verwenden Sie die in Ihrer Java-Anwendung die Methode com.sap.dbtech.powertoys.release.

Das System ruft diese Methode implizit auf, wenn der Garbage-Collector ein Objekt der Klasse Loader löscht.

Funktionsumfang

public void release()

throws

com.sap.dbtech.rte.comm.RTEException

Ausnahmen

Klasse | Beschreibung
com.sap.dbtech.rte.comm.RTEException | siehe Fehlerbehandlung (Loader)

Beispiel

session.release();

Siehe auch:

Beispiel: Tabelle exportieren

Loader-Java-Klassen


Fehlerbehandlung (Loader) (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Fehlerbehandlung (Loader)

Verwendung

Wenn Fehler bei der Verwendung der Loader-Java-Klassen auftreten, löst das System folgende Ausnahmen aus:

Ausnahmen

Klasse | Wann wird diese Ausnahme ausgelöst?
com.sap.dbtech.powertoys.LoaderException | Wenn der Loader einen Fehler meldet.
com.sap.dbtech.rte.comm.RTEException | Wenn die Java-Plattform keine Verbindung zum Loader kann. Wenn eine bestehende Verbindung unterbrochen wird.

Funktionsumfang

Methoden der Klasse com.sap.dbtech.powertoys.DBMException

Methode | Beschreibung
public int getErrorCode() | Das System gibt den Fehlercode des Loader aus.
public String getErrorID() | Das System gibt die Fehlernummer des Loader aus.
public String toString() | Das System gibt die Exception als String-Objekt aus.

Siehe auch:

Beispiel: Tabelle exportieren


Beispiel: Tabelle exportieren (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Tabelle exportieren

Dieses Beispiel zeigt, wie Sie in Ihrer Java-Anwendung mit Loader-Kommandos eine Tabelle exportieren.

Sie gehen folgendermaßen vor:

...

1. Sie rufen von Ihrer Java-Anwendung aus den Loader auf.

2. Sie verbinden sich mit dem Loader.

3. Sie melden sich an die Datenbankinstanz an.

4. Sie exportieren die Tabelle mit einem Loader-Kommando.

5. Sie beenden die Verbindung zum Loader.

Die einzelnen Schritte sind in den Kommentaren des Beispiels erklärt.

import com.sap.dbtech.powertoys.*;

import com.sap.dbtech.rte.comm.RTEException;

import java.util.Properties;

public class LoaderDemo

{

public

LoaderDemo ()

{

}

public static void main (String [] args)

{

// Loader mLoaderSession = null;

Loader mLoaderSession;

try {

// Sie stellen eine Verbindung zum Loader her.

mLoaderSession = Loader.dbLoader(null,null);

}

catch (RTEException rteExc) {

System.out.println ("connect failed: " + rteExc.toString ());

return;

}

try {

// Sie melden sich als Datenbankbenutzer MONA

// mit Kennwort RED

// an die Datenbankinstanz DEMODB an.

// siehe Methode com.sap.dbtech.powertoys.Loader.cmd

mLoaderSession.cmd ("use serverdb DEMODB");

mLoaderSession.cmd ("use user MONA RED");

// Sie exportieren mit der Methode cmd

// und dem Loader-Kommando EXPORT TABLE

// die Tabelle LOADERTEST

// siehe Loader, Strukturlink EXPORT TABLE-Kommandos

String result = mLoaderSession.cmd ("EXPORT TABLE HOTEL.CITY DATA OUTSTREAM FILE 'CITY.data'");

System.out.println (result);

}

catch (RTEException rteExc) {

System.out.println ("connection broken: " + rteExc.toString ());

}

catch (LoaderException LoaderExc) {

System.out.println ("command failed: " + LoaderExc.toString ());

}

finally {

try {

// Sie beenden die Verbindung zum Loader.

// siehe Methode com.sap.dbtech.powertoys.Loader.release

mLoaderSession.release ();

}

catch (RTEException rteExc) {

// ignore

}

}

}

}

Siehe auch:

Loader-Java-Klassen


Perl-Handbuch (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation Perl-Handbuch

Einsatzmöglichkeiten

Über die Module SAP::DBTech::dbm und SAP::DBTech::loader können Sie mit Hilfe von Perl-Skripten auf die Datenbankwerkzeuge Database Manager und Loader zuzugreifen. Sie können auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen verwendet werden.

Über das Modul DBD::MaxDB können Sie mit Hilfe von Perl-Skripten SQL-Anweisungen im Datenbanksystem ausführen.

Einführungshinweise

Die Module SAP::DBTech::dbm und SAP::DBTech::loader sind Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Das Modul DBD::MaxDB können Sie unter der Adresse search.cpan.org/~maxdb/ herunterladen.

Für das Verständnis werden Grundkenntnisse der Programmiersprache Perl vorausgesetzt. Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

Konfiguration der Perl-Module

Perl-Module

Name | Programmierschnittstelle | Verwendung
SAP::DBTech::dbm | Database Manager | DBM-Kommandos zum Verwalten von Datenbankinstanzen ausführen
SAP::DBTech::loader | Loader | Loader-Kommandos zum Importieren und Exportieren von Daten ausführen
DBD::MaxDB | SQL | SQL-Anfragen ausführen und die Ergebnisse verarbeiten

Siehe auch:

Glossar, Strukturlink Syntaxnotation


Konfiguration der Perl-Module (SAP-Bibliothek - Schnittstellen)

Vorgehensweisen Konfiguration der Perl-Module

Voraussetzungen

Sie haben die Perl-Module im Verzeichnis <perl_dir> installiert.

Wenn Sie die Perl-Module mit dem Installationsprogramm (siehe Strukturlink Installationshandbuch) installiert haben, dann wurden die Perl-Module im Verzeichnis <perl_dir>=<dependent_path>/runtime/perl angelegt.

Vorgehensweise

Erweitern Sie die Umgebungsvariable PERL5LIB um <perl_dir>:

· Windows:

set PERL5LIB=%PERL5LIB%;<perl_dir>

· Unix/Linux (sh/bash):

PERL5LIB=$PERL5LIB:<perl_dir>
export PERL5LIB


Modul SAP::DBTech::dbm (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Modul SAP::DBTech::dbm

Syntax

use SAP::DBTech::dbm;

Verwendung

SAP::DBTech::dbm ist ein für das MaxDB-Datenbanksystem entwickeltes Modul in der Programmiersprache Perl. Sie können es in Perl-Skripten verwenden, um neue Datenbankinstanzen anzulegen und bestehende Datenbankinstanzen zu verwalten.

Das Modul SAP::DBTech::dbm ermöglicht die Ausführung aller Strukturlink DBM-Kommandos. Anders als bei der Ausführung dieser Kommandos mit Hilfe des Datenbankverwaltungswerkzeugs Strukturlink Database Manager CLI können Sie auftretende Fehler behandeln und die DBM-Kommandos dynamisch zur Laufzeit erzeugen.

Inhalt des Moduls

Klasse DBM

Siehe auch:

Beispiele für das Modul SAP::DBTech::dbm

Fehlerbehandlung für das Modul SAP::DBTech::dbm


Klasse DBM (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Klasse DBM

Verwendung

DBM ist eine Klasse des Moduls SAP::DBTech::dbm. Eine Instanz dieser Klasse entspricht einer Verbindung zu einem Strukturlink DBM-Server.

Inhalt der Klasse

Die Klasse DBM enthält folgende Methoden:

cmd (cmd_string)

rawCmd (cmd_string)

release ()

Verwendung des Constructors

$session = new DBM ($computer_server, $database_name, $dependent_path, $user_info);

Parameter | Beschreibung
$database_computer | Name des Rechners, mit dem die Verbindung aufgebaut werden soll, Vorschlagswert des Systems ist der lokale Rechner
$database_name | Name der Datenbankinstanz, zu der eine Verbindung hergestellt werden soll, Die Angabe ist optional.
$dependent_path | Installationspfad der Datenbanksoftware (Siehe auch: Installationshandbuch, Strukturlink Verzeichnisse) Die Angabe ist optional.
$user_info | ein String der Form <dbm_operator>,<dbm_operator_password> Der angegebene DBM-Benutzer meldet sich an das Programm DBM-Server an. Die Angabe ist optional.

Wenn es auf Ihrem Rechner mehrere Installationen der Datenbanksoftware gibt, können Sie über die Angaben $database_name und $dependent_path steuern, welche Version des Programms DBM-Server gestartet wird:

Fall 1 – Sie wollen eine neue Datenbankinstanz mit der neuesten Softwareinstallation anlegen oder sich Informationen über die bestehenden Datenbankinstanzen und Softwareversionen anzeigen lassen:

Geben Sie weder $database_name und $dependent_path an.

Das System startet so den DBM-Server der Softwareinstallation mit der höchsten Versionsnummer.

Fall 2 – Sie wollen eine bestimmte Datenbankinstanz verwalten.

Geben Sie den $database_namean, jedoch nicht den $dependent_path.

Das System startet so den zur angegebenen Datenbankinstanz gehörigen DBM-Server.

Fall 3 – Sie wollen eine neue Datenbankinstanz einer bestimmten Softwareversion anlegen

Geben Sie den $dependent_pathan, jedoch keinen $database_name.

Das System startet so den DBM-Server der angegebenen Softwareinstallation.

Erzeugen eines Verbindungsobjekts $session zur Datenbank DEMODB auf dem aktuellen Rechner:

$session = new DBM ('', 'DEMODB', '', 'OLEG,MONDAY');


Methode cmd (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Methode cmd

Verwendung

$result = $session->cmd ($cmd_string);

cmd ist eine Methode der Klasse DBM. Sie senden damit das unter $cmd_string angegebene Strukturlink DBM-Kommando an das Programm Strukturlink DBM-Server.

Ergebnis

Es wird das Ergebnis des DBM-Kommandos zurückgegeben.

Wenn das Programm DBM-Server einen Fehler zurückgibt, dann wird eine Ausnahme der Klasse DBMServError ausgelöst.

Angabe eines gültigen DBM-Kommandos

$result = session->cmd ('db_state');
print "$result\n";

Ausgabe:

State

OFFLINE

Angabe eines ungültigen DBM-Kommandos

$result = $session->cmd ('invalid command');
print "$result\n";

Ausgabe:

Error DBM Server: -24977 ERR_COMMAND: unknown command "invalid" at /opt/sapdb/misc/SAP/DBTech/dbm.pm line 89.

(Siehe auch: Methode rawCmd)


Methode rawCmd (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Methode rawCmd

Verwendung

$result = $session->rawCmd ($cmd_string);

rawCmd ist eine Methode der Klasse DBM. Sie senden damit das unter $cmd_string angegebene Strukturlink DBM-Kommando an das Programm Strukturlink DBM-Server.

Fehler des DBM-Server lösen keine Ausnahme aus. Der Rückgabewert beginnt mit OK, wenn die Ausführung des Kommandos erfolgreich war, und mit ERR, wenn das Kommando fehlgeschlagen ist.

(Siehe auch: Methode cmd)

Ergebnis

Es wird das Ergebnis des DBM-Kommandos zurückgegeben.

Angabe eines gültigen DBM-Kommandos

$result = session->rawCmd ('db_state');
print "$result\n";

Ausgabe:

OK

State

OFFLINE

Angabe eines ungültigen DBM-Kommandos

$result = $session->rawCmd ('invalid command');
print "result\n";)

Ausgabe:

ERR

-24977,ERR_COMMAND: unknown command "invalid"


Methode release (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Methode release

Verwendung

$session->release ();

release ist eine Methode der Klasse DBM. Sie beendet die Verbindung zum Programm Strukturlink DBM-Server.


Fehlerbehandlung für das Modul SAP::DBTech::dbm (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Fehlerbehandlung für das Modul SAP::DBTech::dbm

In Fehlersituationen lösen die Methoden des Moduls SAP::DBTech::dbm eine der folgenden Ausnahmen aus:

Ausnahme CommunicationError

Ausnahme DBMServError


Ausnahme CommunicationError (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Ausnahme CommunicationError

Ausnahmen vom Typ CommunicationError werden ausgelöst, wenn keine Verbindung zum Strukturlink DBM-Server hergestellt werden kann oder eine bestehende Verbindung abgebrochen wird.

Sie haben das folgende Format:

Communication Error: $message

$message

Text der Fehlermeldung

Der Typ CommunicationError einer Ausnahme kann durch den Vergleich mit dem regulären Ausdruck Communication Error: (.*) ermittelt werden.

Der DBM-Server, zu dem die Verbindung aufgebaut werden soll, existiert nicht:

eval { $session = new DBM ('unknownhost', '');}
if ($@) {
    print "$@\n";
}

Ausgabe:

Communication Error: unknown host name


Ausnahme DBMServError (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Ausnahme DBMServError

Ausnahmen vom Typ DBMServError werden ausgelöst, wenn der Strukturlink DBM-Server einen Fehler meldet.

Sie haben das folgende Format:

Error DBM Server: $errorCode $errorSymbol: $message

$errorCode | Nummer der Fehlermeldung (Siehe auch: Dokumentation Strukturlink Meldungen)
$errorSymbol | Kurztext der Fehlermeldung
$message | Langtext der Fehlermeldung

Der Typ DBMServError einer Ausnahme kann durch den Vergleich mit dem regulären Ausdruck Error DBM Server: (-?[0-9]+) ([A-Z_]+): (.*)ermittelt werden.


Beispiele für das Modul SAP::DBTech::dbm (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiele für das Modul SAP::DBTech::dbm

Um eine Verbindung aufzubauen, übergeben Sie in den folgenden Beispielen die Argumente jeweils auf der Kommandozeile.

Mit folgendem Kommando rufen Sie das Perl-Skript sample.pl auf und melden sich als DBM-Benutzer OLEG mit Kennwort MONDAY an die Datenbankinstanz DEMODB an.

perl sample.pl OLEG MONDAY DEMODB

Aufbau einer Verbindung

# Verweis auf die Perl-Libraries

# ------------------------------

use SAP::DBTech::dbm;

# Parsen der Aufrufargumente

# --------------------------

my $user_name = $ARGV [0];

my $password = $ARGV [1];

my $database_name = $ARGV [2];

# Aufbau einer Database Manager-Sitzung

# ---------------------------------------

my $session = new DBM ('', $database_name, '', "$user_name,$password");

# Abmelden

# -------------------------------------

$session->release ();

In den folgenden Beispielen wird die Anmeldung jeweils verkürzt angegeben:

session = sapdb.dbm.DBM (’’, $ARGV [2], $ARGV [0] . ’,’ . $ARGV [1])

Auflisten aller Datenbanken

Mit der Methode cmd können Sie DBM-Kommandos ausführen. Das Ergebnis ist eine Zeichenkette, die mit Perl weiterverarbeitet werden kann.

# Verweis auf die Perl-Libraries

# ------------------------------

use SAP::DBTech::dbm;

# Aufbau einer Database Manager-Sitzung

# ------------------------------------------------------

my $session = new DBM ('', $ARGV [2], '', $ARGV [0] . ',' . $ARGV [1]);

# Ausführen des DBM-Kommandos, mit dem alle Datenbankinstanzen

# aufgelistet werden. Das Ergebnis ist eine Zeichenkette.

output = session.cmd ('db_enum')

my $dbstate = 'offline';

my $lastdb = '';

# Einzelne Datenbankinstanzen sind durch Zeilenumbrüche getrennt.

foreach my $line (split /\n/, $output){

# Datenfelder sind durch Tabulatorzeichen getrennt.

my ($name, $instroot, $release, $kind, $state) = split /\t/, $line;

if ($name ne $lastdb) {

# Es existieren mehrere Zeilen pro Datenbankinstanz,

# maximal je eine für die Kernvarianten

# fast und slow.

if ($lastdb ne '') {

print "$lastdb\t$dbstate\n";

}

$lastdb = $name;

$dbstate = 'offline';

}

# Die Datenbank ist aktiv, wenn eine der Kernvarianten

# als 'running' angezeigt wird.

if ($state eq 'running') {

$dbstate = $state;

}

}

print "$lastdb\t$dbstate\n";

$session->release ();

Behandeln von Fehlersituationen

Wenn innerhalb der Methode cmd ein Fehler auftritt, dann wird eine Ausnahme erzeugt. Diese Ausnahme können Sie durch eval abfangen und mit der Systemvariablen $@ abfragen.

# Verweis auf die Perl-Libraries

# ------------------------------

use SAP::DBTech::dbm;

# Aufbau einer Database Manager-Sitzung

# -----------------------------------------

my $session = new DBM ('', $ARGV [2], '', $ARGV [0] . ',' . $ARGV [1]);

foreach my $cmd (('db_state', 'invalid command')) {

eval {

my $result = $session->cmd ($cmd);

# Ausgabe des Ergebnisses

print "$cmd: OK $result\n";

};

if ($@) {

# Ausgabe der Fehlermeldung

print "$CMD: ERR $@\n";

}

}

$session->release ();


Modul SAP::DBTech::loader (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Modul SAP::DBTech::loader

Syntax

use SAP::DBTech::dbm;

Verwendung

SAP::DBTech::loader ist ein für das MaxDB-Datenbanksystem entwickeltes Modul in der Programmiersprache Perl. Sie können es in Perl-Skripten verwenden, um Daten über den Loader zu importieren.

Das Modul SAP::DBTech::loader ermöglicht die Ausführung aller Loader-Kommandos, die Sie auch mit Hilfe des Werkzeugs Loader ausführen können. Zusätzlich können Sie aber auch flexibel auf Fehlersituationen reagieren und die Befehle dynamisch zur Laufzeit erzeugen.

Inhalt des Moduls

Klasse Loader

Siehe auch:

Fehlerbehandlung für das Modul SAP::DBTech::loader

Beispiele für das Modul SAP::DBTech::loader


Klasse Loader (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Klasse Loader

Verwendung

Loader ist eine Klasse des Moduls SAP::DBTech::loader. Alle Dateinamen in den Loader-Kommandos müssen für den Rechner angegeben werden, auf dem der Loader-Server gestartet wurde.

Eine Instanz der Klasse Loader entspricht einer Verbindung zu einem Loader-Server.

Damit wird jedoch noch keine Verbindung zwischen Loader-Server und Datenbankinstanz aufgebaut.

Um eine Verbindung zwischen Loader-Server und Datenbankinstanz aufzubauen, führen Sie die Loader-Kommandos Strukturlink USE DB und Strukturlink USE USER aus.

Inhalt der Klasse

Die Klasse Loaderenthält folgende Methoden:

cmd (cmd_string)

rawCmd (cmd_string)

sql (cmd_string)

release ()

Verwendung des Constructors

$session = new Loader ($database_computer);

Parameter | Beschreibung
database_computer | Netzwerkname des Rechners, mit dem die Verbindung aufgebaut werden soll Wenn Sie für database_computer keine Angabe machen, wird eine Verbindung zum lokalen Rechner hergestellt.

Erzeugen einer Verbindung session zum Programm Loader-Server auf dem aktuellen Rechner:

$session = new Loader ();

Erzeugen einer Verbindung session zum Programm Loader-Server auf dem Rechner remote_computer:

$session =new Loader ('remote_computer');


Methode cmd (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Methode cmd

Verwendung

$result = $session->cmd ($cmd_string);

cmd ist eine Methode der Klasse Loader. Sie senden damit das unter $cmd_string angegebene Loader-Kommando an das Programm Loader-Server.

Ergebnis

Es wird das Ergebnis des Loader-Kommandos zurückgegeben.

Wenn das Programm Loader-Server einen Fehler zurückgibt, dann wird eine Ausnahme vom Typ LoaderError ausgelöst.

Angabe eines gültigen Loader-Kommandos

$result = $session->cmd ('CREATE TABLE testtable1 (colname INTEGER)')
print "result: '$result'\n";

Ausgabe:

result: ''

Angabe eines ungültigen Loader-Kommandos

$result = $session->cmd ('invalid command')
 print "result: '$result'\n";

Ausgabe:

Error Loader Server: SQL error -3005 = Invalid SQL statement error position: 1) at /opt/sdb/misc/SAP/DBTech/loader.pm line 89.

(Siehe auch: Methode rawCmd)


Methode rawCmd (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Methode rawCmd

Verwendung

$result = $session->rawCmd ($cmd_string);

rawCmd ist eine Methode der Klasse Loader. Sie senden damit das unter $cmd_string angegebene Loader-Kommando an das Programm Loader-Server.

Fehler des Loader-Server lösen keine Ausnahme aus. Der Rückgabewert beginnt mit OK, wenn die Ausführung des Kommandos erfolgreich war, und mit ERR, wenn das Kommando fehlgeschlagen ist.

(Siehe auch: Methode cmd)

Ergebnis

Es wird das Ergebnis des Loader-Kommandos zurückgegeben.

Angabe eines gültigen Loader-Kommandos

$result = $session->cmd ('CREATE TABLE testtable2 (colname INTEGER)')
print "result: '$result'\n";

Ausgabe:

result: 'OK

'

Angabe eines ungültigen Loader-Kommandos

$result = $session->cmd ('invalid command')
print "result: '$result'\n";

Ausgabe:

result: 'ERR
-25010
SQL error -3005 = Invalid SQL statement (error position: 1)'


Methode sql (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Methode sql

Verwendung

$sqlrc = $session->sql ($cmd_string);

sql ist eine Methode der Klasse Loader. Sie senden damit die unter $cmd_string angegebene SQL-Anweisung an den Strukturlink Loader-Server.

Sie können SQL-Anweisungen auch mit Hilfe der Methoden cmd oder rawCmd ausführen. Wenn dabei Ausnahmen auftreten, müssen Sie diese jedoch selbst erkennen und den Fehlercode aus dem Text der Ausnahme ermitteln.

Ergebnis

Wenn die Anweisung erfolgreich ausgeführt wurde, ist der Ergebniswert 0

Wenn die Ausführung der Anweisung zu einem SQL-Fehler führt, dann wird die Nummer der Fehlermeldung der SQL-Anweisung zurückgegeben.

Wenn die Ausführung der Anweisung zu einem Loader-Fehler führt, dann wird eine Ausnahme des Typs LoaderError ausgelöst.

Ausführen einer gültigen SQL-Anweisung

print $session->cmd ('CREATE TABLE testtable3 (a integer)');

Ausgabe:

0

Ausführen einer ungültigen SQL-Anweisung

print $session->cmd ('invalid command');

Ausgabe ist der Fehlercode der SQL-Anweisung:

3005

Ausführen eines ungültigen Loader-Kommandos

print $session->cmd ('dataload invalid spec')

Ausgabe ist die Ausnahme des Loader-Server:

Error Loader Server: Syntax error at position 10 (Unexpected token: invalid). at /opt/sdb/programs/misc/SAP/DBTech/loader.pm line 89.


Methode release (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Methode release

Verwendung

$session->release ();

release ist eine Methode der Klasse Loader. Sie beendet die aktuelle Verbindung zum Programm Strukturlink Loader-Server.


Fehlerbehandlung für das Modul SAP::DBTech::loader (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Fehlerbehandlung für das Modul SAP::DBTech::loader

In Fehlersituationen lösen die Methoden des Moduls SAP::DBTech::loader eine der folgenden Ausnahmen aus:

Ausnahme CommunicationError

Ausnahme LoaderError


Ausnahme CommunicationError (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Ausnahme CommunicationError

Ausnahmen vom Typ CommunicationError werden ausgelöst, wenn keine Verbindung zum Strukturlink Loader-Server hergestellt werden kann oder eine bestehende Verbindung abgebrochen wird.

Sie haben das folgende Format:

Communication Error: $message

message

Text der Fehlermeldung

Der Typ CommunicationError einer Ausnahme kann durch den Vergleich mit dem regulären Ausdruck Communication Error: (.*) ermittelt werden.

Der Loader-Server, zu dem die Verbindung aufgebaut werden soll, existiert nicht:

eval
{ $session = new Loader ('unknownhost', '');}
if ($@) {
print "$@\n";
}

Ausgabe:

Communication Error: unknown host name


Ausnahme LoaderError (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Ausnahme LoaderError

Ausnahmen vom Typ LoaderError werden ausgelöst, wenn das Programm Strukturlink Loader-Server einen Fehler meldet.

Sie haben das folgende Format:

Error Loader Server: $message

message

Langtext der Fehlermeldung

Der Typ LoaderError einer Ausnahme kann durch den Vergleich mit dem regulären Ausdruck Error Loader Server: (.*) ermittelt werden.


Beispiele für das Modul SAP::DBTech::loader (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiele für das Modul SAP::DBTech::loader

Um das Perl-Skript sample.pl aufzurufen und sich am Loader als Datenbankbenutzer MONA mit dem Kennwort RED an die Datenbankinstanz DEMODB anzumelden, geben Sie folgendes Kommando auf der Kommandozeile ein:

perl sample.pl MONA RED DEMODB

Aufbau einer Verbindung

# Verweis auf Perl-Libraries

# ----------------------------

use SAP::DBTech::loader;

# Parsen der Aufrufargumente

# --------------------------

my $user_name = $ARGV [0];

my $password = $ARGV [1];

my $database_name = $ARGV [2];

# Aufbau einer Loadersitzung; es wird noch keine

# Verbindung zur Datenbankinstanz aufgebaut

# ------------------------------------------------------

my $session = new Loader ();

# Anmelden an die Datenbankinstanz

# -------------------------------------

$session->cmd ("use user $user_name $password serverdb $database_name");

# Abmelden

# -------------------------------------

$session->release ();

Variante

Um zu vermeiden, dass das System Benutzername und Kennwort in Großbuchstaben umwandelt, schließen Sie Benutzername und Kennwort im Kommando use user in doppelte Anführungszeichen ein:

$session->cmd ("use user \”$user\”_name \”$password\” serverdb $database_name");

In den folgenden Beispielen wird die Anmeldung verkürzt angegeben:

my $session = new Loader ()

$session->cmd ("use user ${ARGV [0]} ${ARGV [1]} serverdb ${ARGV [2]}");

Ausführen von Loader-Kommandos

Mit der Methode cmd können Sie sowohl Loader-Kommandos als auch SQL-Anweisungen ausführen.

use SAP::DBTech::loader;

# Aufbau einer Loadersitzung

my $session = new Loader ();

$session->cmd ("use user ${ARGV [0]} ${ARGV [1]} serverdb ${ARGV [2]}");

# Ausführen einer SQL-Anweisung

$session->cmd("

CREATE TABLE customer2

(

cno FIXED(4,0) PRIMARY KEY,

title CHAR(7),

firstname CHAR(10),

name CHAR(10) NOT NULL,

zip CHAR(5),

address CHAR(25) NOT NULL)");

# Ausführen eines DATALOAD-Kommandos

$session->cmd ("

DATALOAD TABLE customer

cno 1

title 2

firstname 3

name 4

zip 5

address 6

INFILE 'customer.dat'");

Behandeln von Fehlersituationen

Wenn innerhalb der Methode cmd ein Fehler auftritt, dann wird ein Ausnahmeobjekt der Klasse LoaderError erzeugt. Dieses Ausnahmeobjekt können Sie innerhalb eines try-except-Kommandos erkennen und behandeln.

Die Methode sql bietet einen vereinfachten Zugriff auf Fehler innerhalb von SQL-Anweisungen. Wenn innerhalb der Methode sql ein SQL-Fehler auftritt, dann wird keine Ausnahme erzeugt, sondern die Fehlernummer an den Aufrufer zurückgegeben. Diese Fehlernummer können Sie im Programm abfragen.

use SAP::DBTech::loader;

# Aufbau einer Loadersitzung

my $session = new Loader ();

$session->cmd ("use user ${ARGV [0]} ${ARGV [1]} serverdb ${ARGV [2]}");

# Abfrage, ob eine Tabelle existiert

my $sqlrc = $session->sql ("EXISTS TABLE customer2");

# die Tabelle wird nur angelegt, wenn sie

# nicht bereits existiert

if ($sqlrc == -4004) {

$session->cmd("

CREATE TABLE customer2

(

cno FIXED(4,0) PRIMARY KEY,

title CHAR(7),

firstname CHAR(10),

name CHAR(10) NOT NULL,

zip CHAR(5),

address CHAR(25) NOT NULL)");

}

# Ausführen eines DATALOAD-Kommandos

my $filename = 'customer.dat';

eval {

$session->cmd ("

DATALOAD TABLE customer2

cno 1

title 2

firstname 3

name 4

zip 5

address 6

INFILE '$filename'");

};

# Ausgabe der Fehlermeldung

if ($@) {

print "DATALOAD der Datei $filename ist gescheitert: $@\n";

}

Beispieldaten

Die in den Beispielen verwendete Datei customer.dat hat folgenden Inhalt:

"3000","Mrs","Jenny","Porter","10580","1340 N.Ash Street, #3"

"3100","Mr","Peter","Brown","48226","1001 34th Str., APT.3"

"3200","Company","?","Datasoft","90018","486 Maple Str."

"3300","Mrs","Rose","Brian","75243","500 Yellowstone Drive, #2"

"3400","Mrs","Mary","Griffith","20005","3401 Elder Lane"

"3500","Mr","Martin","Randolph","60615","340 MAIN STREET, #7"

"3600","Mrs","Sally","Smith","75243","250 Curtis Street"

"3700","Mr","Mike","Jackson","45211","133 BROADWAY APT. 1"

"3800","Mrs","Rita","Doe","97213","2000 Humboldt Str., #6"

"3900","Mr","George","Howe","75243","111 B Parkway, #23"

"4000","Mr","Frank","Miller","95054","27 5th Str., 76"

"4100","Mrs","Susan","Baker","90018","200 MAIN STREET, #94"

"4200","Mr","Joseph","Peters","92714","700 S. Ash Str., APT.12"

"4300","Company","?","TOOLware","20019","410 Mariposa Str., # 10"

"4400","Mr","Antony","Jenkins","20903","55 A Parkway, #15"


Python-Handbuch (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation Python-Handbuch

Einsatzmöglichkeiten

Über die MaxDB-Python-Module können Sie mit Python-Skripten auf MaxDB-Datenbankinstanzen und die Datenbankwerkzeuge Database Manager und Loader zugreifen.

Die MaxDB-Python-Module können auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen verwendet werden.

Einführungshinweise

Die MaxDB-Python-Module sind Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Strukturlink Installationshandbuch.

Funktionsumfang

Konfiguration der Python-Module

Python-Module

Name | Programmierschnittstelle | Verwendung
sdb.dbapi | SQL | SQL-Anweisungen ausführen (implementiert die Python Database API Specification v2.0)
sdb.sql | SQL | SQL-Anweisungen ausführen (MaxDB-spezifisch)
sdb.dbm | Database Manager | Datenbankinstanzen verwalten (DBM-Kommandos ausführen)
sdb.loader | Loader | Daten importieren und exportieren (Loader-Kommandos und SQL-Anweisungen ausführen)

Einschränkungen

Nur für Unicode-fähige Datenbankinstanzen: Sie können in SQL-Anweisungen nur in Input-/Output-Parametern Unicode-Werte verwenden.

Siehe auch:

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe empfehlen wir das alphabetisch sortierte Strukturlink Glossar.


Konfiguration der Python-Module (SAP-Bibliothek - Schnittstellen)

Vorgehensweisen Konfiguration der Python-Module

Voraussetzungen

Sie haben Python auf Ihrem Rechner installiert.

Vorgehensweise

...

1. Laden Sie das Paket maxdb-python-* für Ihre Plattform von der MaxDB-Website herunter:

Siehe Konzepte des Datenbanksystems, Strukturlink Download.

maxdb-python-win-32bit-i386-7_6_00_16.zip

2. Entpacken Sie dieses Paket in ein beliebiges Verzeichnis <module_path> auf Ihrem Rechner.

C:\tmp\maxdb-python-win-32bit-i386-7_6_00_16

3. Fügen Sie das Verzeichnis <module_path> zur Umgebungsvariablen PYTHONPATH hinzu:

● Microsoft Windows:

set PYTHONPATH=%PYTHONPATH%;<module_path>

set PYTHONPATH=%PYTHONPATH%;"C:\tmp\maxdb-python-win-32bit-i386-7_6_00_16"

● UNIX/Linux (sh/bash):

PYTHONPATH=$PYTHONPATH:<module_path>

export PYTHONPATH

Siehe auch:

Python-Handbuch


Modul sdb.dbapi (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Modul sdb.dbapi

Verwendung

Sie verwenden das Python-Modul sdb.dbapi, um in Python-Skripten SQL-Anweisungen in einer MaxDB-Datenbankinstanz auszuführen.

Voraussetzungen

Sie haben die Python-Module konfiguriert.

Funktionsumfang

sdb.dbapi implementiert die Python Database API Specification v2.0. Diese Dokumentation beschreibt nur die Unterschiede zu dieser Spezifikation. Weitere Informationen finden Sie unter www.python.org.

● Methode connect

● Konvertierung von Datums- und Zeitwerten

● Konvertierung von LOB-Werten

Um in Python-Skripten MaxDB-spezifische Funktionen zu nutzen, verwenden Sie das Modul sdb.sql.

Siehe auch:

Python-Handbuch


Methode connect (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode connect

Verwendung

connect ist eine Methode des Moduls sdb.dbapi.

Mit dieser Methode eröffnen Sie eine Datenbanksitzung.

Voraussetzungen

Die Datenbankinstanz ist im Betriebszustand ONLINE.

Funktionsumfang

connect (user, password, database, host ='', **config)

user | Name des Datenbankbenutzers
password | Kennwort des Datenbankbenutzers Beachten Sie die Groß- und Kleinschreibung. Siehe Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter
config | ● autocommit on | off AUTOCOMMIT-Modus ● sqlmode internal | oracle SQL-Modus ● isolation 0 | 1 | 2 | 3 | 10 | 15 | 20 | 30 Isolation-Level ● timeout <integer> Kommando-Timeout in Sekunden

Ergebnis

● bei erfolgreicher Ausführung: Objekt der Klasse sdb.dbapi.Connection.

● bei einem Fehler: Ausnahme der Klasse sdb.dbapi.Error.

Weitere Informationen finden Sie in der Python Database API Specification v2.0, siehe www.python.org.

Beispiel

session = sdb.dbapi.connect ('MONA', 'RED', 'DEMODB', '', autocommit = 'off', sqlmode= 'oracle', isolation = 1, timeout = 90)


Konvertierung von Datums- und Zeitwerten (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Konvertierung von Datums- und Zeitwerten

Verwendung

Das Modul sdb.dbapi implementiert die Funktionen, die in der Python Database API Specification v2.0 für die Konvertierung von Datumswerten und -Zeitwerten empfohlen werden.

Funktionsumfang

Konvertierung Python-Werte -> MaxDB-Werte

Funktion | Rückgabewert
Date (year, month, day) | String, der überall dort verwendet werden kann, wo das Datenbanksystem einen Inputwert für einen SQL-Datentyp DATE erwartet
Time (hour, minute, second) | String, der überall dort verwendet werden kann, wo das Datenbanksystem einen Inputwert für einen SQL-Datentyp TIME erwartet
Timestamp (year, month, day, hour, minute, second, micros = 0) | String, der überall dort verwendet werden kann, wo das Datenbanksystem einen Inputwert für einen SQL-Datentyp TIMESTAMP erwartet
DateFromTicks (ticks) | String, der überall dort verwendet werden kann, wo das Datenbanksystem einen Inputwert für einen SQL-Datentyp DATE erwartet
TimeFromTicks (ticks) | String, der überall dort verwendet werden kann, wo das Datenbanksystem einen Inputwert für einen SQL-Datentyp TIME erwartet
TimestampFromTicks (ticks) | String, der überall dort verwendet werden kann, wo das Datenbanksystem einen Inputwert für einen SQL-Datentyp TIMESTAMP erwartet

Konvertierung MaxDB-Werte -> Python-Werte

Funktion | Rückgabewert
dateTuple | (year, month, day)
timeTuple | (hour, minute, second)
timestampTuple | Tupel im selben Format wie der Rückgabewert von time.localtime ()
dateVal | Anzahl Sekunden seit epoch
timeVal | Anzahl Sekunden seit epoch
timestampVal | Anzahl Sekunden seit epoch
DateFormat (formatString) | Datum formatiert gemäß time.strftime
TimeFormat (formatString) | Zeit formatiert gemäß time.strftime
TimestampFormat (formatString) | Zeitstempel formatiert gemäß time.strftime

Weitere Informationen finden Sie in der Dokumentation zu Python, siehe www.python.org.

Registrierung von Konvertierungsfunktionen mit einem Cursor- oder Connection-Objekt

aufrufbares Objekt

Beschreibung

cursor.setTranslation ([

None,

sdb.dbapi.dateTuple,

sdb.dbapi.DateFormat('%Y-%m-%d')])

Sie übergeben eine Liste, in der Sie für jede Spalte eine Funktion zur Datenumwandlung angeben. Wenn für eine Spalte kein Datenumwandlung stattfinden soll, dann übergeben Sie an der Position dieser Spalte das None-Objekt.

cursor.setTypeTranslation ({

'Date': sdb.dbapi.dateTuple,

'Time': sdb.dbapi.timeTuple,

'Fixed':str})

Sie übergeben ein Dictionary. Als Schlüssel geben Sie die gleichen Typnamen an, wie sie die Methode sdb.sql.SapDB_ResultSet.getDescription ausgibt.

Als Werte geben Sie Funktionen zur Datenumwandlung an. Diese Funktionen wendet das System auf alle Spalten eines bestimmten SQL-Datentyps an.

connection.setTypeTranslation ({

Date': sdb.dbapi.dateTuple,

'Time': sdb.dbapi.timeTuple,

'Fixed':str})

Sie übergeben ein Dictionary, das so aufgebaut ist wie der Parameter für cursor.setTypeTranslation. Für jedes neu erzeugte Cursor-Objekt rufen Sie die Methode setTypeTranslation mit dem Dictionary als Parameter auf.

Weitere Informationen finden Sie unter www.python.org.


Konvertierung von LOB-Werten (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Konvertierung von LOB-Werten

Verwendung

Das Modul sdb.dbapi konvertiert LOB-Werte (LONG-Werte).

Funktionsumfang

Python-Werte -> MaxDB-Werte

Sie können LOB-Werte folgendermaßen als Input-Parameter übergeben:

● als String

● als aufrufbares Objekt, das analog zur Methode read von Dateiobjekten definiert ist (Ein ganzzahliger Parameter gibt an, wie viele Zeichen das System lesen soll, und das Ende des Eingabestroms wird durch eine leere Zeichenkette gekennzeichnet).

MaxDB-Werte -> Python-Werte

MaxDB-LONG-Werte (LOBs) werden als Instanzen der Klasse SapDB_LongReader ausgegeben. Diese Klasse implementiert die Methode read.

Siehe auch:

Weitere Informationen finden Sie unter www.python.org.


Modul sdb.sql (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Modul sdb.sql

Verwendung

Sie verwenden das Python-Modul sdb.sql, um in Python-Skripten SQL-Anweisungen in einer MaxDB-Datenbankinstanz auszuführen.

Voraussetzungen

Sie haben die Python-Module konfiguriert.

Funktionsumfang

Methode connect

Klasse SapDB_Session

Klasse SapDB_ResultSet

Klasse SapDB_Prepared

Klasse SapDB_Result

Fehlerbehandlung für das Modul sql

Um gemäß der Python Database API Specification v2.0 auf eine MaxDB-Datenbankinstanz zuzugreifen, verwenden Sie das Modul sdb.dbapi.

Beispiel

Beispiele für das Modul sdb.sql

Siehe auch:

Python-Handbuch

Informationen zur MaxDB-SQL-Syntax finden Sie im Strukturlink SQL-Referenzhandbuch.


Methode connect (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode connect

Verwendung

connect ist eine Methode des Moduls sdb.sql.

Mit dieser Methode eröffnen Sie eine Datenbanksitzung.

Voraussetzungen

Die Datenbankinstanz ist im Betriebszustand ONLINE.

Funktionsumfang

connect (database_user, password, database_name , host = '' config = '')

database_user | Name des Datenbankbenutzers
password | Kennwort des Datenbankbenutzers Beachten Sie die Groß- und Kleinschreibung. Siehe Konzepte des Datenbanksystems, Strukturlink Konventionen für Benutzernamen und Kennwörter
database_name | Name der Datenbankinstanz
host | Name oder IP-Adresse des Datenbankrechners
config | Verbindungsoptionen (siehe unten) Format: keyword=value[&keyword=value]...

Verbindungsoptionen

Schlüsselwort | mögliche Werte | Vorschlagswert | Beschreibung
autocommit | on | off | off | AUTOCOMMIT-Modus on: Das System beendet nach jeder SQL-Anweisung die Transaktion mit einem COMMIT. off: Sie steuern die Transaktion mit den Methoden commit und rollback selbst.
cachelimit | <value in kB> | Vorschlagswert der Datenbankinstanz | Cache-Limit der Datenbanksitzung in KB
component | odbc | cpc | cpc | odbc: die Datenbank wählt die für ODBC gültige SQL-Variante für die Bearbeitung cpc: die Datenbank wählt die für den C++-Precompiler gültige SQL-Variante für die Bearbeitung
genericResults | on | off | off | on: Die Methoden sql und sqlX der Klasse SapDB_Session und die Methode execute der Klasse SapDB_Prepared liefern als Ergebnis ein Objekt der Klasse SapDB_Result. Das ist z. B. sinnvoll für Anwendungen, bei denen der SQL-Modus nicht bekannt ist. off: In Abhängigkeit von der ausgeführten SQL-Anweisung sind verschiedene SQL-Ergebnisse möglich.
isolation | 0 | 1 | 2 | 3 | 10 | 15 | 20 | 30 | Vorschlagswert der Datenbankinstanz | Isolation-Level
sqlmode | internal | oracle | internal | SQL-Modus
timeout | 0 | <value in seconds> | Vorschlagswert der Datenbankinstanz | maximale Inaktivitätsdauer einer Datenbanksitzung (in Sekunden)

Ergebnis:

● bei erfolgreicher Ausführung: Objekt der Klasse SapDB_Session

● bei einem Fehler: Ausnahme der Klasse CommunicationError

Beispiel

● Der Datenbankbenutzer MONA mit dem Kennwort RED stellt eine Verbindung zur Datenbankinstanz DEMODB auf dem lokalen Rechner her:

session=sdb.sql.connect ('MONA', 'RED', 'DEMODB')

● Der Datenbankbenutzer MONA mit dem Kennwort RED stellt eine Verbindung zur Datenbankinstanz DEMODB auf dem Rechner PARMA her:

session=sdb.sql.connect ('MONA', 'RED', 'DEMODB','PARMA')

● Der Datenbankbenutzer MONA mit dem Kennwort RED stellt eine Verbindung zur Datenbankinstanz DEMODB auf dem lokalen Rechner mit den Verbindungsoptionen SQL-Modus=ORACLE und Kommando-Timeout = 60 Sekunden her:

session=sdb.sql.connect ('MONA', 'RED', 'DEMODB','', 'sqlmode=oracle&timeout=60')

● Verbindung zur Datenbankinstanz herstellen und beenden


Klasse SapDB_Session (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse SapDB_Session

Verwendung

SapDB_Session ist eine Klasse des Moduls sdb.sql.

Mit den Methoden dieser Klasse können Sie SQL-Anweisungen ausführen.

Ein Objekt dieser Klasse entspricht einer Datenbanksitzung. Um ein Objekt dieser Klasse zu erzeugen, rufen Sie die Methode connect des Moduls sdb.sql auf. Nachdem die letzte Referenz zu einem Objekt dieser Klasse gelöscht wurde, beendet das System die Datenbanksitzung mit einem ROLLBACK der Transaktion.

Funktionsumfang

Die Klasse SapDB_Session enthält folgende Methoden:

sql

sqlX

prepare

release

commit

rollback

Einschränkungen

Für die Methoden sql, sqlX und prepare gilt:

In SQL-Anweisungen können Sie keine Unicode-Zeichenketten verwenden.


Methode sql (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode sql

Verwendung

sql ist eine Methode der Klasse SapDB_Session.

Mit dieser Methode führen Sie eine SQL-Anweisung aus.

Funktionsumfang

sql (cmd)

cmd

SQL-Anweisung

Ergebnis:

● bei erfolgreicher Ausführung: siehe Mögliche SQL-Ergebnisse

● bei einem Fehler: Ausnahme der Klasse SQLError

Beispiel

● Sie führen eine SELECT-Anweisung aus:

cursor = session.sql ('SELECT * FROM hotel.room')

Die Variable cursor enthält ein Objekt der Klasse SapDB_ResultSet. Mit diesem Objekt können Sie auf die Datensätze der Ergebnismenge zugreifen.

● Sie führen eine DELETE-Anweisung aus:

rowsDeleted = session.sql ('DELETE FROM hotel.person WHERE name='NY'')

Die Variable rowsDeleted enthält die Anzahl der Zeilen, die von der DELETE-Anweisung gelöscht wurden.

● SQL-Anweisung ausführen und Ergebnismenge auslesen

● SQL-Anweisung ausführen und Ergebnismenge mit einer for-Schleife auslesen

● SQL-Anweisung ausführen und Informationen zur Ergebnismenge abfragen

● SQL-Anweisung mehrfach mit verschiedenen Werten ausführen


Methode sqlX (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode sqlX

Verwendung

sqlX ist eine Methode der Klasse SapDB_Session.

Mit dieser Methode führen Sie SQL-Anweisungen mit Parametern aus, ohne dass Sie zunächst ein Objekt der Klasse SapDB_Prepared anlegen müssen.

Funktionsumfang

sqlX (cmd, parms = [])

cmd | SQL-Anweisung, kann folgende Platzhalter für Parameter enthalten: ? | :<varname>
parms | Parameterliste, aus der das System die Platzhalter für Parameter ersetzt

Ergebnis:

● bei erfolgreicher Ausführung: siehe Mögliche SQL-Ergebnisse

● bei einem Fehler: Ausnahme der Klasse SQLError

Beispiel

● Sie führen eine SELECT-Anweisung aus, die einen Parameter enthält:

cursor = session.sqlX ('SELECT firstname, name, cno FROM hotel.customer WHERE cno>?',[3000])

Die Variable cursor enthält ein Objekt der Klasse SapDB_ResultSet. Mit diesem Objekt können Sie auf die Datensätze der Ergebnismenge zugreifen.

● Sie führen eine DELETE-Anweisung aus, die einen Parameter enthält:

rowsDeleted = session.sqlX ('DELETE FROM hotel.person WHERE name = ?',['NY'])

Die Variable rowsDeleted enthält die Anzahl der Zeilen, die von der DELETE-Anweisung gelöscht wurden.


Methode prepare (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode prepare

Verwendung

prepare ist eine Methode der Klasse SapDB_Session.

Mit dieser Methode senden Sie eine SQL-Anweisung cmd zur Prüfung an die Datenbankinstanz.

Funktionsumfang

prepare (cmd)

cmd

SQL-Anweisung

Ergebnis:

● bei erfolgreicher Ausführung: Objekt der Klasse SapDB_Prepared

Sie können dieses Objekt verwenden, um die gleiche SQL-Anweisung mehrfach und mit unterschiedlichen Parametern auszuführen (Methode execute). Auf diese Weise muss die Datenbankinstanz nicht jedes Mal die Syntax und die Privilegien neu überprüfen.

● bei einem Fehler: Ausnahme der Klasse SQLError

Beispiel

● Sie senden eine INSERT-Anweisung an die Datenbankinstanz:

insert = session.prepare ('INSERT INTO hotel.city VALUES (?,?,?)')

Die Variable insert enthält ein Objekt der Klasse SapDB_Prepared. Mit diesem Objekt können Sie die INSERT-Anweisung mit unterschiedlichen Parametern ausführen.

● SQL-Anweisung mehrfach mit verschiedenen Werten ausführen


Methode release (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode release

Verwendung

release ist eine Methode der Klasse SapDB_Session.

Mit dieser Methode beenden Sie die aktuelle Verbindung zur Datenbankinstanz. Danach können Sie nicht mehr auf das Objekt der Klasse SapDB_Session zugreifen.

Funktionsumfang

release (with_commit = False)

with_commit

optional

True: Transaktion wird mit COMMIT beendet

False: Transaktion wird mit ROLLBACK beendet (Vorschlagswert)

Beispiel

Verbindung zur Datenbankinstanz herstellen und beenden


Methode commit (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode commit

Verwendung

commit ist eine Methode der Klasse SapDB_Session.

Mit dieser Methode beenden Sie die aktuelle Transaktion mit einem COMMIT und starten eine neue Transaktion.

Funktionsumfang

commit ()


Methode rollback (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode rollback

Verwendung

rollback ist eine Methode der Klasse SapDB_Session.

Mit dieser Methode beenden Sie die aktuelle Transaktion mit einem ROLLBACK und starten eine neue Transaktion.

Funktionsumfang

rollback ()


Klasse SapDB_ResultSet (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse SapDB_ResultSet

Verwendung

SapDB_ResultSet ist eine Klasse des Moduls sdb.sql.

Mit den Methoden dieser Klasse können Sie den Cursor innerhalb der Ergebnismenge positionieren und Daten aus der der Ergebnismenge auslesen.

Funktionsumfang

Die Klasse SapDB_ResultSet enthält folgende Methoden:

next

previous

relative

absolute

first

last

current

__getitem__

getDescription

Einschränkungen

Für die Methoden next, previous, relative, absolute, first, last und current gilt:

● Python 2.x: Unicode-Spalten können gelesen und geschrieben werden.

● Python 1.5.2: Unicode-Ausgabewerte werden nach ASCII konvertiert. Wenn diese Umwandlung fehlschlägt, dann wird ein Fehler gemeldet.

Beispiel

SQL-Anweisung ausführen und in der Ergebnismenge navigieren


Methode next (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode next

Verwendung

next ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode positionieren Sie den Cursor innerhalb der Ergebnismenge auf dem nächsten Datensatz.

Funktionsumfang

next ()

Ergebnis:

● nächster Datensatz der Ergebnismenge

● bei leerer Ergebnismenge/wenn das Ende der Ergebnismenge erreicht ist: None

Beispiel

● row = cursor.next ()

Die Variable row enthält den nächsten Ergebnissatz.

● SQL-Anweisung ausführen und Ergebnismenge auslesen


Methode previous (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode previous

Verwendung

previous ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode positionieren Sie den Cursor innerhalb einer Ergebnismenge auf dem vorhergehenden Datensatz.

Funktionsumfang

previous ()

Ergebnis:

● vorhergehender Datensatz

● bei leerer Ergebnismenge/wenn der Anfang der Ergebnismenge erreicht ist: None

Beispiel

● row = cursor.previous ()

Die Variable row enthält den vorhergehenden Datensatz.

● SQL-Anweisung ausführen und in der Ergebnismenge navigieren


Methode relative (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode relative

Verwendung

relative ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode positionieren Sie den Cursor auf einem Datensatz, der sich eine bestimmte Anzahl von Datensätzen weiter hinten/weiter vorne in der Ergebnismenge befindet.

Funktionsumfang

relative (offset)

offset

Anzahl von Datensätzen, die der Cursor vorwärts oder rückwärts bewegt werden soll

offset > 0: Sie bewegen den Cursor vorwärts in der Ergebnismenge

offset < 0: Sie bewegen den Cursor rückwärts in der Ergebnismenge

Ergebnis:

● Datensatz an der angegebenen Position der Ergebnismenge

● bei leerer Ergebnismenge/wenn offset größer als die Anzahl der Datensätze nach/vor der aktuellen Cursorposition ist: None

Beispiel

● Sie bewegen den Cursor 5 Datensätze nach vorne:

row = cursor.relative (5)

● Sie bewegen den Cursor 1 Datensatz nach hinten:

row = cursor.relative (-1)

Dieser Ausdruck ist äquivalent zu row = cursor.previous ().

● SQL-Anweisung ausführen und in der Ergebnismenge navigieren


Methode absolute (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode absolute

Verwendung

absolute ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode positionieren Sie den Cursor innerhalb der Ergebnismenge auf dem Satz an Position pos.

Funktionsumfang

absolute (pos)

pos

Position des auszulesenden Datensatzes in der Ergebnismenge

pos ≥ 1: Position wird vom Beginn der Ergebnismenge aus berechnet

pos = 1: erster Satz der Ergebnismenge

pos ≤ -1: Position wird vom Ende der Ergebnismenge aus berechnet

pos = -1: letzter Satz der Ergebnismenge

Ergebnis:

● Datensatz an der angegebenen Position der Ergebnismenge

● bei leerer Ergebnismenge/wenn pos die Anzahl der Datensätze in der Ergebnismenge überschreitet: None

Beispiel

● Sie positionieren den Cursor auf dem dritten Satz der Ergebnismenge:

row = cursor.absolute (3)

● Sie positionieren den Cursor auf dem vorletzten Satz der Ergebnismenge:

row = cursor.absolute (-2)

● SQL-Anweisung ausführen und in der Ergebnismenge navigieren


Methode first (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode first

Verwendung

first ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode positionieren Sie den Cursor auf dem ersten Datensatz der Ergebnismenge.

Funktionsumfang

first ()

Ergebnis:

● erster Datensatz der Ergebnismenge

● bei leerer Ergebnismenge: None

Beispiel

● row = cursor.first ()

● SQL-Anweisung ausführen und in der Ergebnismenge navigieren


Methode last (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode last

Verwendung

last ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode positionieren Sie den Cursor auf dem letzten Satz der Ergebnismenge.

Funktionsumfang

last ()

Ergebnis:

● letzter Datensatz der Ergebnismenge

● bei leerer Ergebnismenge: None

Beispiel

● row = cursor.last ()

● SQL-Anweisung ausführen und in der Ergebnismenge navigieren


Methode current (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode current

Verwendung

current ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode lesen Sie den Datensatz aus, auf dem sich der Cursor in der Ergebnismenge momentan befindet.

Funktionsumfang

current ()

Ergebnis:

● aktueller Datensatz

● bei leerer Ergebnismenge/wenn der Cursor vor dem ersten oder hinter dem letzten Datensatz steht: None

Beispiel

● row = cursor.current ()

● SQL-Anweisung ausführen und in der Ergebnismenge navigieren


Methode __getitem__ (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode __getitem__

Verwendung

__getitem__ ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode positionieren Sie den Cursor auf einem Datensatz in der Ergebnismenge. Sie verwenden diese Methode, um in einer for-Schleife durch alle Datensätze der Ergebnismenge zu iterieren.

Funktionsumfang

__getitem__ (pos)

pos

Position des Datensatzes

pos=0: erster Datensatz in der Ergebnismenge

Ergebnis:

● Datensatz an der angegebenen Position der Ergebnismenge

● bei leerer Ergebnismenge/wenn pos die Anzahl der Datensätze in der Ergebnismenge überschreitet: None

Beispiel

Sie iterieren mit for über die gesamte Ergebnismenge. Dabei ruft das System implizit die __getitem__-Methode auf und erhöht den Wert des Parameters pos immer um 1, bis die Methode eine Ausnahme auslöst.

for zip, name, state in session.sql ('SELECT * FROM hotel.city'):

print zip, name, state


Methode getDescription (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode getDescription

Verwendung

getDescription ist eine Methode der Klasse SapDB_ResultSet.

Mit dieser Methode zeigen Sie Informationen über die Spalten in der Ergebnismenge an.

Funktionsumfang

getDescription ()

Ergebnis:

● Name der Spalte

● Typ der Spalte (als String)

● Typ der Spalte (als ganze Zahl gemäß ODBC-Spezifikation)

Die Bedeutung dieser Zahlen entspricht ihrer Bedeutung in der ODBC-Spezifikation.

● logische Größe der Spalte (maximale Anzahl der Zeichen bei String-Spalten, maximale Anzahl der Ziffern bei numerischen Spalten)

● Anzahl der Nachkommastellen

● Angabe, ob die Spalte NULL enthalten kann

● Der Wert in der Spalte in/out ist für diese Methode immer OUT (Ergebnismenge).

Beispiel

● Sie führen mit der Methode sql eine SQL-Anweisung aus, die eine Ergebnismenge liefert. Mit der Methode getDescription zeigen Sie Informationen zu den Spalten dieser Ergebnismenge an.

cursor = session.sql ("SELECT * FROM hotel.customer")

print "colname type code length frac null? in/out"

print "===================================================="

for columnDescription in cursor.getDescription ():

print "%-10s %-10s %4d %6d %2d %5s %s" %

columnDescription

colname type code length frac null? in/out

=========================================================

CNO Fixed 3 4 0 None OUT

TITLE Char 1 7 0 1 OUT

FIRSTNAME Char 1 20 0 1 OUT

NAME Char 1 20 0 None OUT

ZIP Char 1 5 0 1 OUT

ADDRESS Char 1 40 0 None OUT

● SQL-Anweisung ausführen und Informationen zur Ergebnismenge abfragen


Klasse SapDB_Prepared (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse SapDB_Prepared

Verwendung

SapDB_Prepared ist eine Klasse des Moduls sdb.sql.

Mit den Methoden dieser Klasse können Sie eine SQL-Anweisung mehrmals mit unterschiedlichen Parametern ausführen. Dies hat folgende Vorteile:

● Das Datenbanksystem muss die Syntax und die Privilegien nur einmal überprüfen.

● Die Python-Anwendung muss Parameter nicht in ein der SQL-Syntax entsprechendes Format umwandeln, Sonderzeichen müssen also nicht speziell behandelt werden.

Um ein Objekt dieser Klasse zu erzeugen, verwenden Sie die Methode prepare der Klasse SapDB_Session.

Funktionsumfang

Die Klasse SapDB_Prepared enthält folgende Methoden:

execute

getDescription


Methode execute (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode execute

Verwendung

execute ist eine Methode der Klasse SapDB_Prepared.

Mit dieser Methode führen Sie eine SQL-Anweisung mit Parametern aus (z. B. eine Datenbankprozedur).

Funktionsumfang

execute (sqlParms = [])

sqlParms

Parameterliste mit den Eingabeparameter

Ergebnis:

● bei erfolgreicher Ausführung: siehe Mögliche SQL-Ergebnisse

gegebenenfalls Ausgabeparameter

● bei einem Fehler: Ausnahme der Klasse SQLError

Beispiel

SELECT-Anweisung ausführen

select = session.prepare ('SELECT * FROM hotel.customer WHERE cno = ?')
select.execute ([3000])

<SapDB_ResultSet object at …>

Datenbankprozedur aufrufen (Stored Procedure)

Sie erzeugen die Datenbankprozedur avg_price:

session.sql ("""CREATE DBPROCEDURE avg_price (IN zip CHAR(5), OUT avg_price FIXED(6,2)) AS

VAR sum FIXED(10,2); price FIXED(6,2); hotels INTEGER;

TRY

SET sum = 0; SET hotels = 0;

DECLARE dbproccursor CURSOR FOR

SELECT price FROM hotel.room,hotel.hotel WHERE zip = :zip AND

room.hno = hotel.hno AND type = 'single';

WHILE $rc = 0 DO BEGIN

FETCH dbproccursor INTO :price;

SET sum = sum + price;

SET hotels = hotels + 1;

END;

CATCH

IF $rc <> 100 THEN STOP ($rc, 'unexpected error');

CLOSE dbproccursor;

IF hotels > 0 THEN SET avg_price = sum / hotels

ELSE STOP (100, 'no hotel found');""")

Sie erzeugen mit der Methode prepare ein Objekt der Klasse SapDB_Prepared:

call = session.prepare ('call hotel.avg_price (?, ?)')

Sie geben einen Wert für den Inputparameter an:

in1 = 20005 # sets zip

Sie rufen die Datenbankprozedur mit der Methode execute auf.

out1 = call.execute ([in1])

Sie zeigen den Wert des Ausgabeparameters an:

print 'value avg_price:', out1

value avg_price: (135,0)


Methode getDescription (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode getDescription

Verwendung

getDescription ist eine Methode der Klasse SapDB_Prepared.

Mit dieser Methode zeigen Sie Informationen zu den Parametern einer SQL-Anweisung an.

Funktionsumfang

getDescription ()

Ergebnis:

● leerer String als Platzhalter für den Namen des Parameters

● Typ des Parameters (als String)

● Typ des Parameters (als ganze Zahl)

Die Bedeutung dieser Zahlen entspricht ihrer Bedeutung in der ODBC-Spezifikation.

● logische Größe des Parameters (maximale Anzahl der Zeichen bei einem String-Parameter, maximale Anzahl der Ziffern bei einem numerischen Parameter)

● Anzahl der Nachkommastellen

● Angabe, ob der Parameter NULL enthalten kann

● Typ des Parameters: 'IN' |'OUT' | 'IN/OUT'

Beispiel

Sie erzeugen die Datenbankprozedur avg_price:

session.sql ("""CREATE DBPROCEDURE avg_price (IN zip CHAR(5), OUT avg_price FIXED(6,2)) AS

VAR sum FIXED(10,2); price FIXED(6,2); hotels INTEGER;

TRY

SET sum = 0; SET hotels = 0;

DECLARE dbproccursor CURSOR FOR

SELECT price FROM hotel.room,hotel.hotel WHERE zip = :zip AND

room.hno = hotel.hno AND type = 'single';

WHILE $rc = 0 DO BEGIN

FETCH dbproccursor INTO :price;

SET sum = sum + price;

SET hotels = hotels + 1;

END;

CATCH

IF $rc <> 100 THEN STOP ($rc, 'unexpected error');

CLOSE dbproccursor;

IF hotels > 0 THEN SET avg_price = sum / hotels

ELSE STOP (100, 'no hotel found');""")

Sie erzeugen mit der Methode prepare ein Objekt der Klasse SapDB_Prepared:

call = session.prepare ('call avg_price (?, ?)')

Sie zeigen die Informationen zu den Parametern in formatierter Form an:

print "colname type code length frac null? in/out"
print "===================================================="
for parameterDescription in call.getDescription ():
print "%-10s %-10s %4d %6d %2d %5s %s" % parameterDescription

colname type code length frac null? in/out

====================================================

Unicode 1 5 0 1 IN

Fixed 3 6 2 1 OUT


Klasse SapDB_Result (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse SapDB_Result

Verwendung

SapDB_Result ist eine Klasse des Moduls sdb.sql.

SQL-Anweisungen können unterschiedliche Ergebnisse liefern (siehe Mögliche SQL-Ergebnisse). Mit den Methoden dieser Klasse können Sie gezielt abfragen, welcher Art die Ergebnisse sind.

Funktionsumfang

Die Klasse SapDB_Result enthält folgende Methoden:

getResultSet

getOutputParameters

getRowsAffected

getLastSerial

getFirstSerial


Methode getResultSet (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode getResultSet

Verwendung

getResultSet ist eine Methode der Klasse SapDB_Result.

Mit dieser Methode lesen Sie die Ergebnismenge einer SQL-Anweisung aus.

Funktionsumfang

getResultSet ()

Ergebnis:

● Objekt der Klasse SapDB_ResultSet

● bei leerer Ergebnismenge: None


Methode getOutputParameters (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode getOutputParameters

Verwendung

getOutputParameters ist eine Methode der Klasse SapDB_Result.

Mit dieser Methode lesen Sie die Ausgabeparameter einer SQL-Anweisung aus.

Funktionsumfang

getOutputParameters ()

Ergebnis:

● Ausgabeparameter der SQL-Anweisung

● Wenn die SQL-Anweisung keine Ausgabeparameter hat: None


Methode getRowsAffected (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode getRowsAffected

Verwendung

getRowsAffected ist eine Methode der KlasseSapDB_Result.

Mit dieser Methode fragen Sie ab, wie viele Datensätze (Zeilen) von einer SQL-Anweisung geändert wurden.

Funktionsumfang

getRowsAffected ()

Ergebnis: Anzahl der geänderten Datensätze


Methode getLastSerial (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode getLastSerial

Verwendung

getLastSerial ist eine Methode der Klasse SapDB_Result.

Wenn das System bei einer INSERT-Anweisung für eine Schlüsselspalte vom Typ SERIAL einen Wert oder mehrere Werte automatisch generiert hat, dann können Sie mit dieser Methode den letzten dieser generierten Werte auslesen. Das ist z. B. dann nützlich, um in weiteren SQL-Anweisungen FOREIGN KEY-Beziehungen zu pflegen.

Funktionsumfang

getLastSerial ()

Ergebnis:

● letzter Wert vom Typ SERIAL der Ergebnismenge

● Wenn die SQL-Anweisung keine Werte vom Typ SERIAL geliefert hat: None.


Methode getFirstSerial (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode getFirstSerial

Verwendung

getFirstSerial ist eine Methode der Klasse SapDB_Result.

Wenn das System bei einer INSERT-Anweisung für eine Schlüsselspalte vom Typ SERIAL einen Wert oder mehrere Werte automatisch generiert hat, dann können Sie mit dieser Methode den ersten dieser generierten Werte auslesen. Das ist z. B. dann nützlich, um in weiteren SQL-Anweisungen FOREIGN KEY-Beziehungen zu pflegen.

Funktionsumfang

getFirstSerial ()

Ergebnis:

● erster Wert vom Typ SERIAL der Ergebnismenge

● Wenn die SQL-Anweisung keine Werte vom Typ SERIAL geliefert hat: None


Klasse SapDB_LongReader (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse SapDB_LongReader

Verwendung

SapDB_LongReader ist eine Klasse des Moduls sdb.sql.

Mit der Methode read dieser Klasse können Sie den Inhalt einer LONG-Spalte (LOB-Werte) sequentiell lesen.

Objekte der Klasse SapDB_LongReader werden von Ergebnismengen erzeugt, die eine oder mehrere LONG-Spalten enthalten.

Funktionsumfang

Die Klasse SapDB_LongReader enthält folgende Methode:

read


Methode read (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode read

Verwendung

read ist eine Methode der Klasse SapDB_LongReader.

Mit dieser Methode lesen Sie einen LONG-Wert (LOB) aus.

Funktionsumfang

read (count = -1)

count

Anzahl Zeichen, die ausgelesen werden sollen

Ergebnis:

● Wenn Sie die Methode ohne Parameter aufgerufen haben: Rest des LONG-Werts

● Wenn das Ende des LONG-Werts erreicht ist: leerer String

Auf diese Weise können Sie Objekte der Klasse SapDB_LongReader wie Objekte der Klasse file verwenden.


Fehlerbehandlung für das Modul sdb.sql (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Fehlerbehandlung für das Modul sdb.sql

Verwendung

Bei Fehlern lösen die Methoden des Moduls sdb.sql Ausnahmen der folgenden Klassen aus:

Klasse CommunicationError

Klasse SQLError

Beispiel

SQL-Anweisung ausführen und Fehler behandeln


Klasse CommunicationError (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse CommunicationError

Verwendung

CommunicationError ist eine Klasse des Moduls sdb.sql.

Die Methoden des Moduls sdb.sql lösen Ausnahmen dieser Klasse aus, wenn keine Verbindung zur Datenbankinstanz hergestellt werden kann oder eine bestehende Verbindung abgebrochen wird.

Attribute der Objekte der Klasse CommunicationError

Name | Beschreibung
errorCode | Fehlercode
message | Text der Fehlermeldung


Klasse SQLError (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse SQLError

Verwendung

SQLError ist eine Klasse des Moduls sdb.sql.

Die Methoden des Moduls sdb.sql lösen Ausnahmen dieser Klasse aus, wenn eine SQL-Anweisung einen Fehler enthält oder beim Ausführen einer SQL-Anweisung ein Fehler auftritt.

Attribute der Objekte der Klasse SQLError

Name | Beschreibung
errorCode | Meldungsnummer siehe Dokumentation Strukturlink Meldungen
sqlState | normierter Fehlercode
message | Text der Fehlermeldung
errorPos | Fehler in der SQL-Anweisung: Position des Fehlers in der SQL-Anweisung Fehler beim Ausführen der SQL-Anweisung: Positionsnummer des fehlerhaften Parameters (erster Parameter = 0)


Mögliche SQL-Ergebnisse (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Mögliche SQL-Ergebnisse

Wenn Sie mit den Methoden des Moduls sdb.sql SQL-Anweisungen ausführen, erhalten Sie unterschiedliche Ergebnisse, abhängig von der Art der SQL-Anweisung.

SQL-Anweisung

Ergebnis

SELECT

Objekt der Klasse SapDB_ResultSet

UPDATE, DELETE

Anzahl der geänderten oder gelöschten Datensätze

INSERT

● Objekt der Klasse SapDB_Result, wenn die Tabelle, in die Datensätze eingefügt werden, eine Spalte vom Typ SERIAL enthält

● Anzahl der eingefügten Sätze, wenn die Tabelle, in die die Datensätze eingefügt werden, keine Spalte vom Typ SERIAL enthält

CALL

● Ausgabeparameter,
wenn die Datenbankprozedur (Stored Procedure) Ausgabeparameter zurückgibt

● Objekt der Klasse SapDB_ResultSet,
wenn die Datenbankprozedur eine Ergebnismenge zurückgibt

● Objekt der Klasse SapDB_Result,
wenn die Datenbankprozedur sowohl Ausgabeparameter als auch eine Ergebnismenge zurückgibt

DDL (Data Definition Language)

None


Beispiele für das Modul sdb.sql (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiele für das Modul sdb.sql

Die Beispiele zeigen, wie Sie in einem Python-Skript mit dem Modul sdb.sql SQL-Anweisungen in einer MaxDB-Datenbankinstanz ausführen können.

● Verbindung zur Datenbankinstanz herstellen und beenden

● SQL-Anweisung ausführen und Ergebnismenge auslesen

● SQL-Anweisung ausführen und in der Ergebnismenge navigieren

● SQL-Anweisung ausführen und Ergebnismenge mit einer for-Schleife auslesen

● SQL-Anweisung ausführen und Informationen zur Ergebnismenge abfragen

● SQL-Anweisung mehrfach mit verschiedenen Werten ausführen

● SQL-Anweisung ausführen und Fehler behandeln

Die Beispiele verwenden die folgenden Demo-Daten:

Demo-Daten | Beschreibung
DBADMIN | Datenbanksystemadministrator (SYSDBA-Benutzer) als Beispiel für einen DBM-Benutzer
SECRET | Kennwort des Datenbanksystemadministrators
DEMODB | Demo-Datenbank


Verbindung zur Datenbankinstanz herstellen und beenden (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Verbindung zur Datenbankinstanz herstellen und beenden

In diesem Beispiel verwenden Sie die Methoden connect und release des Moduls sdb.sql. Sie stellen eine Verbindung zur MaxDB-Datenbankinstanz her und beenden sie wieder.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

#

# Python-Module importieren

# -------------------------------------------

import sys

import sdb.sql

#

# Aufrufargumente parsen

# -------------------------------------------

database_user = sys.argv [1]

database_user_password = sys.argv [2]

database_name = sys.argv [3]

#

# Verbindung zur Datenbankinstanz herstellen

# -------------------------------------------

session = sdb.sql.connect (database_user, database_user_password, database_name)

#

# Verbindung zur Datenbankinstanz beenden

# --------------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py MONA RED DEMODB

Siehe auch:

Beispiele für das Modul sdb.sql


SQL-Anweisung ausführen und Ergebnismenge auslesen (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt SQL-Anweisung ausführen und Ergebnismenge auslesen

In diesem Beispiel verwenden Sie die Methoden sql und next des Moduls sdb.sql. Sie führen eine SELECT-Anweisung aus, die als Ergebnis ein Objekt der Klasse SapDB_ResultSet liefert (Ergebnismenge), lesen die Datensätze dieser Ergebnismenge nacheinander aus.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

#

# Python-Module importieren

# -------------------------------------------

import sys

import sdb.sql

# Verbindung zur Datenbankinstanz herstellen

# -------------------------------------------

database_user = sys.argv [1]

database_user_password = sys.argv [2]

database_name = sys.argv [3]

session = sdb.sql.connect (database_user, database_user_password, database_name)

select = """

SELECT title, name, cno FROM hotel.customer

WHERE cno BETWEEN 3000 AND 8000"""

#

# SELECT-Anweisung ausführen

# Ergebnis: Objekt der Klasse SAPDB_ResultSet

# -----------------------------------------------

cursor = session.sql (select)

#

# Die Methode next liest den nächsten Datensatz

# der Ergebnismenge aus.

# Wenn das Ende der Ergebnismenge erreicht wurde,

# dann gibt die Methode next den Wert None aus.

# -----------------------------------------------

row = cursor.next ()

while row:

title, name, cno = row

print "%s %s %d" % (title, name, cno)

row = cursor.next ()

#

# Verbindung zur Datenbankinstanz beenden

# ---------------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py MONA RED DEMODB

Ergebnis

Mrs Porter 3000

Mr Brown 3100

Company Datasoft 3200

Mrs Brian 3300

Mrs Griffith 3400

Mr Randolph 3500

Mrs Smith 3600

Mr Jackson 3700

Mrs Doe 3800

Mr Howe 3900

Mr Miller 4000

Mrs Baker 4100

Mr Peters 4200

Company TOOLware 4300

Mr Jenkins 4400

Siehe auch:

Beispiele für das Modul sdb.sql


SQL-Anweisung ausführen und in der Ergebnismenge navigieren (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt SQL-Anweisung ausführen und in der Ergebnismenge navigieren

In diesem Beispiel verwenden Sie Methoden der Klasse SAPDB_ResultSet des Moduls sdb.sql. Sie legen eine Tabelle an, füllen Sie mit Werten, führen eine SQL-Anweisung aus und positionieren den Cursor an verschiedenen Stellen in der Ergebnismenge.

Vorgehensweise

...

1. Legen Sie eine neue Tabelle customer1 an und füllen Sie sie mit Daten:

session.sql ('CREATE TABLE customer1 (cno FIXED(4) PRIMARY KEY)')

insert = session.prepare ('INSERT INTO customer1 (cno) VALUES (?)')

for i in xrange (1, 11):

insert.execute ([i])

2. Führen Sie folgende SQL-Anweisung aus:

cursor = session.sql ('SELECT cno FROM customer1 ORDER BY cno')

Die SQL-Anweisung liefert eine Ergebnismenge. Der Cursor steht vor dem ersten Datensatz der Ergebnismenge.

3. Positionieren Sie den Cursor an verschiedenen Stellen der Ergebnismenge und zeigen Sie den jeweiligen Datensatz an:

a. nächster Datensatz (erster Datensatz der Ergebnismenge):

print cursor.next ()

(1,)

b. nächster Datensatz:

print cursor.next ()

(2,)

c. vorheriger Datensatz:

print cursor.previous ()

(1,)

d. fünf Datensätze vorwärts:

print cursor.relative (5)

(6,)

e. ein Datensatz rückwärts:

print cursor.relative (-1)

(5,)

f. dritter Datensatz:

print cursor.absolute (3)

(3,)

g. drittletzter Datensatz:

print cursor.absolute (-3)

(8,)

h. erster Datensatz:

print cursor.first ()

(1,)

i. letzter Datensatz:

print cursor.last ()

(10,)

j. aktueller Datensatz:

print cursor.current ()

(10,)

4. Iterieren Sie über die gesamte Ergebnismenge und zeigen Sie alle Datensätze an:

for row in cursor: print row

(1,)

(2,)

(3,)

(4,)

(5,)

(6,)

(7,)

(8,)

(9,)

(10,)

Siehe auch:

Beispiele für das Modul sdb.sql


SQL-Anweisung ausführen und Ergebnismenge mit einer for-Schleife auslesen

Diese Grafik wird im zugehörigen Text erklärt SQL-Anweisung ausführen und Ergebnismenge mit einer for-Schleife auslesen

In diesem Beispiel verwenden Sie die Methode sql. Sie führen eine SELECT-Anweisung aus, die als Ergebnis ein Objekt der Klasse SapDB_ResultSet liefert (Ergebnismenge), und lesen die Datensätze dieser Ergebnismenge in einer for-Schleife aus.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

#

# Python-Module importieren

# -------------------------------------------

import sys

import sdb.sql

#

# Verbindung zur Datenbankinstanz herstellen

# -------------------------------------------

database_user = sys.argv [1]

database_user_password = sys.argv [2]

database_name = sys.argv [3]

session = sdb.sql.connect (database_user, database_user_password, database_name)

select = """

SELECT * FROM hotel.room"""

#

# SELECT-Anweisung ausführen

# Ergebnis: Objekt der Klasse SAPDB_ResultSet

# -----------------------------------------------

cursor = session.sql (select)

#

# Ein Objekt der Klasse SapDB_ResultSet kann in einer for-Schleife

# wie jeder andere Iterator verwendet werden.

# -----------------------------------------------

for row in cursor:

hno, type, free, price = row

print "%6d %s %d %6d" % (hno, type, free, price)

#

# Mit einer for-Anweisung können Sie sowohl

# eine SQL-Anweisung ausführen als auch die Ergebniszeilen

# in Spalten gliedern.

# -------------------------------------------------

for hno, type, free, price in session.sql (select):

print "%6d %s %d %6d" % (hno, type, free, price)

#

# Verbindung zur Datenbankinstanz beenden

# --------------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py MONA RED DEMODB

Ergebnis

10 double 45 200

10 single 20 135

20 double 13 100

20 single 10 70

30 double 15 80

30 single 12 45

[...]

Siehe auch:

Beispiele für das Modul sdb.sql


SQL-Anweisung ausführen und Informationen zur Ergebnismenge abfragen

Diese Grafik wird im zugehörigen Text erklärt SQL-Anweisung ausführen und Informationen zur Ergebnismenge abfragen

In diesem Beispiel verwenden Sie die Methoden sql und getDescription des Moduls sdb.sql. Sie führen eine SELECT-Anweisung aus, die als Ergebnis ein Objekt der Klasse SapDB_ResultSet liefert (Ergebnismenge), und fragen Informationen zur Struktur der Ergebnismenge ab.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

#

# Python-Module importieren

# -------------------------------------------

import sys

import sdb.sql

#

# Verbindung zur Datenbankinstanz herstellen

# -------------------------------------------

database_user = sys.argv [1]

database_user_password = sys.argv [2]

database_name = sys.argv [3]

session = sdb.sql.connect (database_user, database_user_password, database_name)

select = """

SELECT title, name, cno FROM hotel.customer

WHERE cno BETWEEN 3000 AND 8000"""

#

# SELECT-Anweisung ausführen

# Ergebnis: Objekt der Klasse SAPDB_ResultSet

# ----------------------------------------------

cursor = session.sql (select)

#

# Die Methode getDescription gibt

# eine Liste der Spaltenbeschreibungen aus.

# ----------------------------------------------

descriptions = cursor.getDescription ()

for description in descriptions:

print '======================='

# Name der Spalte

print 'Name:', description [0]

# Typ der Spalte als String

print 'Type:', description [1]

# Typ der Spalte als ganze Zahl

print 'Type:', description [2]

# Länge der Spalte

print 'Len:', description [3]

# Anzahl der Nachkommastellen

print 'Frac:', description [4]

# Spalten von Ergebnismengen sind immer Pflichtspalten.

print 'Mandatory:', description [5]

# Spalten von Ergebnismengen sind immer Output.

print 'in/out:', description [6]

#

# Beenden der Sitzung mit der Datenbankinstanz

# --------------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py MONA RED DEMODB

Ergebnis

=======================

Name: TITLE

Type: Char

Type: 1

Len: 7

Frac: 0

Mandatory: 1

in/out: OUT

=======================

Name: NAME

Type: Char

Type: 1

Len: 20

Frac: 0

Mandatory: None

in/out: OUT

=======================

Name: CNO

Type: Fixed

Type: 3

Len: 4

Frac: 0

Mandatory: None

in/out: OUT


SQL-Anweisung mehrfach mit verschiedenen Werten ausführen (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt SQL-Anweisung mehrfach mit verschiedenen Werten ausführen

In diesem Beispiel verwenden Sie die Methoden sql und prepare des Moduls sdb.sql. Sie führen eine SQL-Anweisung mehrfach mit verschiedenen Werten aus, ohne dass das Datenbanksystem Python-Werte konvertieren muss.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

#

# Python-Module importieren

# -------------------------------------------

import sys

import sdb.sql

#

# Verbindung zur Datenbankinstanz herstellen

# -------------------------------------------

database_user = sys.argv [1]

database_user_password = sys.argv [2]

database_name = sys.argv [3]

session = sdb.sql.connect (database_user, database_user_password, database_name)

#

# Testtabelle customer anlegen

# (um sicherzustellen, dass diese Tabelle noch nicht vorhanden ist,

# wird zunächst die SQL-Anweisung zum Löschen der Tabelle

# ausgeführt)

# ----------------------------------------------

try:

session.sql ('DROP TABLE hotel.customer')

except sdb.sql.SQLError:

pass

session.sql ("""CREATE TABLE customer (cno FIXED(4) PRIMARY KEY)""")

#

# Objekt der Klasse SapDB_Prepared erzeugen

# ------------------------------------------------

insert = session.prepare ('INSERT INTO customer (cno) VALUES (?)')

for i in xrange (1,11):

# die Methode execute führt die vorbereitete

# SQL-Anweisung mit allen Parametern der Liste aus

insert.execute ([i])

cursor = session.sql ('SELECT cno FROM customer')

for row in cursor: print row

#

# Verbindung zur Datenbankinstanz beenden

# -----------------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py MONA RED DEMODB

Ergebnis

(1,)

(2,)

(3,)

(4,)

(5,)

(6,)

(7,)

(8,)

(9,)

(10,)


SQL-Anweisung ausführen und Fehler behandeln (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt SQL-Anweisung ausführen und Fehler behandeln

In diesem Beispiel verwenden Sie die die Klasse SQLError des Moduls sdb.sql. Um Ausnahmen dieser Klasse zu erzeugen, führen Sie folgende Fehlersituationen herbei: Sie führen eine SELECT-Anweisung mit einem falschen Spaltennamen aus und Sie führen eine SQL-Anweisung mit einem falschen Parameter aus.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

#

# Python-Module importieren

# ---------------------------------------------------

import sys

import sdb.sql

#

# Verbindung zur Datenbankinstanz herstellen

# ---------------------------------------------------

database_user = sys.argv [1]

database_user_password = sys.argv [2]

database_name = sys.argv [3]

session = sdb.sql.connect (database_user, database_user_password, database_name)

#

# SELECT-Anweisung mit einem falschen Spaltennamen

# unknown ausführen (Fehler in der SQL-Anweisung)

#----------------------------------------------------

select = "SELECT unknown FROM hotel.customer"

try:

cursor = session.sql (select)

except sdb.sql.SQLError, err:

print "ERR [%d] %s" % (err.errorCode, err.message)

print select

print ("=" * (err.errorPos - 1)) + '^'

#

# SQL-Anweisung mit einem falschen Parameter ausführen

# (Fehler während der Ausführung der SQL-Anweisung)

#-----------------------------------------------------

try:

count = session.sqlX ("""INSERT INTO hotel.customer

VALUES (?,?,?,?,?,?)""", ['wrong_data_type', 'Mrs', 'Jennifer', 'Parker', '10590', '0 N.Ash Street, #6'])

except sdb.sql.SQLError, err:

print "ERR [%d] %s" % (err.errorCode, err.message)

#

# Verbindung zur Datenbankinstanz beenden

# ----------------------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample_6.py MONA RED DEMODB

ERR [-4005] Unknown column name:UNKNOWN

SELECT unknown FROM hotel.customer

=======^

ERR [-817] Incompatible data types

Siehe auch:

Beispiele für das Modul sdb.sql


Modul sdb.dbm (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Modul sdb.dbm

Verwendung

Sie verwenden das Python-Modul sdb.dbm, um in Python-Skripten DBM-Kommandos auszuführen. Mit DBM-Kommandos können Sie Datenbankinstanzen anlegen und verwalten.

Funktionsumfang

Klasse DBM

Fehlerbehandlung für das Modul sdb.dbm

Beispiel

Beispiele für das Modul sdb.dbm

Siehe auch:

Python-Handbuch

Database Manager CLI, Strukturlink Übersicht aller DBM-Kommandos

Konzepte des Datenbanksystems, Strukturlink Architektur der Schnittstellen


Klasse DBM (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse DBM

Verwendung

DBM ist eine Klasse des Moduls sdb.dbm.

Mit den Methoden dieser Klasse können Sie DBM-Kommandos ausführen. Ein Objekt dieser Klasse entspricht einer Verbindung zu einem Strukturlink DBM-Server.

Funktionsumfang

Die Klasse DBM enthält folgende Methoden:

cmd

rawCmd

release

Definition des Constructors

DBM (database_computer = '', database_name = '', dependent_path = '', user_info = '')

Parameter | Beschreibung
database_computer | Name des Rechners, zu dem Sie eine Verbindung herstellen möchten Vorschlagswert ist der lokale Rechner
database_name | Name der Datenbankinstanz, zu der Sie eine Verbindung herstellen möchten Diese Angabe ist optional.
dependent_path | Verzeichnis, das die von der Datenbankversion abhängige Server-Software enthält (siehe Installationshandbuch, Strukturlink Verzeichnisse) Diese Angabe ist optional.
user_info | Name und Kennwort des DBM-Benutzers Format: <dbm_operator>,<dbm_operator_password>

Aktivitäten

Wenn es auf Ihrem Rechner mehrere Installationen der Datenbanksoftware gibt, dann können Sie mit database_name und dependent_path festlegen, welche Version des Programms Database Manager gestartet wird.

● Um eine neue Datenbankinstanz mit der neuesten Softwareinstallation anzulegen oder Informationen zu den bestehenden Datenbankinstanzen und Softwareversionen anzuzeigen, geben Sie weder database_name noch dependent_path an.

Das System startet den Database Manager der Softwareinstallation mit der höchsten Versionsnummer.

● Um eine bestimmte Datenbankinstanz zu verwalten, geben Sie database_name an, aber nicht dependent_path.

Das System startet die zur angegebenen Datenbankinstanz gehörige Version des Database Manager.

● Um eine neue Datenbankinstanz einer bestimmten Softwareversion anzulegen, geben Sie dependent_path an, aber nicht database_name.

Das System startet den Database Manager der angegebenen Softwareinstallation.

Beispiel

Um als DBM-Benutzer DBADMIN mit Kennwort SECRET über den DBM-Server eine Verbindung zur Datenbankinstanz DEMODB auf dem lokalen Rechner herzustellen, erzeugen Sie folgendermaßen ein Objekt session:

session = sdb.dbm.DBM ('', 'DEMODB', '', 'DBADMIN,SECRET')

Um eine Verbindung zum Database Manager der aktuellsten Softwareinstallation auf dem lokalen Rechner herzustellen, erzeugen Sie folgendermaßen ein Objekt session:

session = sdb.dbm.DBM ('', '')

Um eine Verbindung zum entfernten Rechner PARMA herzustellen und den Database Manager aus der Softwareinstallation /usr/local/sdb/7600 auszuwählen, erzeugen Sie folgendermaßen ein Objekt session:

session = sdb.dbm.DBM ('PARMA', '', '/usr/local/sdb/7500')


Methode cmd (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode cmd

Verwendung

cmd ist eine Methode der Klasse DBM.

Mit dieser Methode senden Sie ein DBM-Kommando an den DBM-Server (siehe Database Manager CLI, Strukturlink Übersicht aller DBM-Kommandos).

Funktionsumfang

cmd (cmd_string)

cmd_string

DBM-Kommando

Ergebnis:

● bei erfolgreicher Ausführung: Ergebnis des DBM-Kommandos

● bei einem Fehler: Ausnahme der Klasse DBMServError

Beispiel

● Sie fragen mit dem DBM-Kommando db_state den Betriebszustand der Datenbankinstanz ab:

result = session.cmd ('db_state')

print repr (result)

'State\nOFFLINE\n'

● Sie geben ein falsches DBM-Kommando ein:

result = session.cmd ('invalid command')

print repr (result)

Traceback (most recent call last):

[...]

dbm.DBMServError: [-24977] Unknown DBM command "invalid"

● DBM-Kommando ausführen


Methode rawCmd (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode rawCmd

Verwendung

rawCmd ist eine Methode der Klasse DBM.

Mit dieser Methode senden Sie ein Strukturlink DBM-Kommando an den DBM-Server. Fehler des DBM-Server lösen keine Ausnahme aus.

Im Gegensatz dazu lösen Fehler beim Ausführen der Methode cmd Ausnahmen aus.

Funktionsumfang

rawCmd (cmd_string)

cmd_string

DBM-Kommando

Ergebnis:

● bei erfolgreicher Ausführung:

OK

Ergebnis des DBM-Kommandos

● bei einem Fehler:

ERR

Fehlermeldung

Beispiel

● Sie fragen mit dem DBM-Kommando db_state den Betriebszustand der Datenbankinstanz ab:

result = session.rawCmd ('db_state')

print repr (result)

'OK\nState\nOFFLINE\n'

● Sie geben ein falsches DBM-Kommando ein:

result = session.rawCmd ('invalid command')

print repr (result)

'ERR\n-24977,ERR_COMMAND: unknown command "invalid"\n'


Methode release (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode release

Verwendung

release ist eine Methode der Klasse DBM.

Mit dieser Methode beenden Sie die Verbindung zum Database Manager.

Funktionsumfang

release ()

Beispiel

Database Manager aufrufen und beenden


Fehlerbehandlung für das Modul sdb.dbm (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Fehlerbehandlung für das Modul sdb.dbm

Verwendung

In Fehlersituationen lösen die Methoden des Moduls sdb.dbm Ausnahmen der folgenden Klassen aus:

Klasse CommunicationError

Klasse DBMServError

Beispiel

DBM-Kommando ausführen und Fehler behandeln


Klasse CommunicationError (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse CommunicationError

Verwendung

CommunicationError ist eine Klasse des Moduls sdb.dbm.

Die Methoden des Moduls sdb.dbm lösen Ausnahmen dieser Klasse aus, wenn keine Verbindung zum DBM-Server hergestellt werden kann oder eine bestehende Verbindung abgebrochen wird.

Attribute der Objekte der Klasse CommunicationError

Name | Beschreibung
errorCode | Fehlercode
message | Text der Fehlermeldung

Beispiel

Sie haben einen falschen Rechnernamen angegeben (PRAMA statt PARMA):

try:

session = sdb.dbm.DBM ('PRAMA', '')

except sdb.dbm.CommunicationError, err:

print err

print err.message

dbm.CommunicationError: [-4] unknown host name

unknown host name


Klasse DBMServError (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse DBMServError

Verwendung

DBMServError ist eine Klasse des Moduls sdb.dbm.

Die Methoden des Moduls sdb.dbm lösen Ausnahmen dieser Klasse aus, wenn der DBM-Server einen Fehler meldet.

Attribute der Objekte der Klasse DBMServError

Name | Beschreibung
errorCode | Meldungsnummer siehe Dokumentation Strukturlink Meldungen
errorSymbol | Kurztext
message | Langtext
additionalInfo | Zusatzinformationen
cmd | Strukturlink DBM-Kommando, das den Fehler ausgelöst hat

Siehe auch:

Beispiele für das Modul sdb.dbm


Beispiele für das Modul sdb.dbm (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiele für das Modul sdb.dbm

Die Beispiele zeigen, wie Sie in einem Python-Skript mit dem Modul sdb.dbm DBM-Kommandos in einer MaxDB-Datenbankinstanz ausführen können.

● Database Manager aufrufen und beenden

● DBM-Kommando ausführen

● Fehler behandeln

Die Beispiele verwenden die folgenden Demo-Daten:

Demo-Daten | Beschreibung
DBADMIN | Datenbanksystemadministrator (SYSDBA-Benutzer) als Beispiel für einen DBM-Benutzer
SECRET | Kennwort des Datenbanksystemadministrators
DEMODB | Demo-Datenbank


Database Manager aufrufen und beenden (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Database Manager aufrufen und beenden

In diesem Beispiel verwenden Sie die Klasse DBM und die Methode release des Moduls sdb.dbm. Sie rufen den Database Manager auf und beenden ihn wieder.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt

#

# Python-Module importieren

# ----------------------------

import sys

import sdb.dbm

#

# Aufrufargumente parsen

# --------------------------

dbm_operator = sys.argv [1]

dbm_operator_password = sys.argv [2]

database_name = sys.argv [3]

#

# Database Manager aufrufen und an eine Datenbankinstanz anmelden

# ------------------------------------------------------

session = sdb.dbm.DBM ('', database_name, '', dbm_operator + ',' + dbm_operator_password)

#

# Verbindung zum Database Manager beenden

# -------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py DBADMIN SECRET DEMODB


DBM-Kommando ausführen (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt DBM-Kommando ausführen

In diesem Beispiel verwenden Sie die Methode cmd des Moduls sdb.sql. Sie führen das DBM-Kommando db_enum aus (Liste aller registrierten Datenbankinstanzen anzeigen) und formatieren die Ausgabe.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

# Python-Module importieren

# ----------------------------

import sys

import sdb.dbm

#

# Database Manager aufrufen und an die Datenbankinstanz anmelden

# ------------------------------------------------------

session = sdb.dbm.DBM ()

# DBM-Kommando db_enum ausführen (Liste aller registrierten

# Datenbankinstanzen anzeigen.

# Ergebnis: Zeichenkette

output = session.cmd ('db_enum')

dbstate = 'offline'

lastdb = ''

# Ergebnis durch Zeilenumbrüche trennen.

for line in output.split ('\n'):

if not line:

continue

# Datenfelder sind durch Tabulatorzeichen getrennt.

database_name, installation_path, version, kernel_variant, operational_state = line.split ('\t')

if database_name != lastdb:

# Es existieren mehrere Zeilen pro Datenbankinstanz,

# je eine für die Kernvarianten

# fast, slow und test

if lastdb != '':

print lastdb, '\t', dbstate

lastdb = database_name

dbstate = 'offline'

# Die Datenbankinstanz ist in Betrieb, wenn eine der

# Kernvarianten als 'running' angezeigt wird.

if operational_state == 'running':

dbstate = operational_state

print lastdb, '\t', dbstate

2. Rufen Sie das Python-Skript auf:

python sample.py

DEMODB running

TESTDB offline

Siehe auch:

Beispiele für das Modul sdb.dbm


DBM-Kommando ausführen und Fehler behandeln (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt DBM-Kommando ausführen und Fehler behandeln

In diesem Beispiel verwenden Sie die Methode cmd und die Klasse DBMServError des Moduls sdb.dbm. Sie führen ein falsches DBM-Kommando aus und behandeln den Fehler.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

# Python-Module importieren

# ----------------------------

import sys

import sdb.dbm

#

# Aufrufargumente parsen

# --------------------------

dbm_operator = sys.argv [1]

dbm_operator_password = sys.argv [2]

database_name = sys.argv [3]

#

# Den Database Manager aufrufen und an eine Datenbankinstanz anmelden

# ------------------------------------------------------

session = sdb.dbm.DBM ('', database_name, '', dbm_operator + ',' + dbm_operator_password)

# Falsches DBM-Kommando ausführen

for cmd in ['db_state', 'invalid_command']:

try:

result = session.cmd (cmd)

# Ergebnis anzeigen

print cmd + ': OK ', repr (result)

except sdb.dbm.DBMServError, err:

# Fehlermeldung anzeigen

print cmd + ': ERR', err.errorCode, err.message

2. Rufen Sie das Python-Skript auf:

python sample.py DBADMIN SECRET DEMODB

db_state: OK 'State\nONLINE\n'

my_invalid_command: ERR -24977 Unknown DBM command "inval

Siehe auch:

Beispiele für das Modul sdb.dbm


Modul sdb.loader (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Modul sdb.loader

Verwendung

Sie verwenden das Python-Modul sdb.loader, um in Python-Skripten Loader-Kommandos und SQL-Anweisungen in einer MaxDB-Datenbankinstanz auszuführen.

Funktionsumfang

Klasse Loader

Fehlerbehandlung für das Modul sdb.loader

Beispiel

Beispiele für das Modul sdb.loader

Siehe auch:

Python-Handbuch

Loader, Strukturlink Kommandos und SQL-Anweisungen

Konzepte des Datenbanksystems, Strukturlink Architektur der Schnittstellen


Klasse Loader (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse Loader

Verwendung

Loader ist eine Klasse des Moduls sdb.loader.

Mit den Methoden dieser Klasse können Sie Loader-Kommandos und SQL-Anweisungen ausführen.

Funktionsumfang

Die Klasse Loader enthält folgende Methoden:

cmd

rawCmd

sql

release

Definition des Constructors

Loader ()

Wenn Sie den Constructor aufrufen, wird der Loader auf dem lokalen Rechner gestartet, es wird aber noch keine Verbindung zu einer Datenbankinstanz hergestellt.

Beispiel

...

1. Sie starten den Loader auf dem lokalen Rechner,:

session = sdb.loader.Loader ()

2. Sie haben nun unter anderem folgende Möglichkeiten:

○ Sie eröffnen eine Datenbanksitzung (Datenbankinstanz DEMODB) auf dem lokalen Rechner:

session.cmd('USE DB DEMODB')

○ Sie eröffnen eine Datenbanksitzung (Datenbankinstanz DEMODB) auf dem entfernten Rechner PARMA:

session.cmd('USE DB DEMODB ON PARMA')

○ Sie eröffnen als Datenbankbenutzer MONA mit Kennwort RED eine Datenbanksitzung (Datenbankinstanz DEMODB)auf dem entfernten Rechner PARMA:

session.cmd('USE USER MONA RED DB DEMODB ON PARMA')

3. Sie beenden die Verbindung zum Loader und beenden die Datenbanksitzung:

session.release ()


Methode cmd (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode cmd

Verwendung

cmd ist eine Methode der Klasse Loader.

Mit dieser Methode senden Sie ein Loader-Kommando oder eine SQL-Anweisung an den Loader-Server (siehe Loader, Strukturlink Kommandos und SQL-Anweisungen)

Funktionsumfang

cmd (cmd_string)

cmd_string

Loader-Kommando oder SQL-Anweisung

Ergebnis:

● bei erfolgreicher Ausführung: Ergebnis des Loader-Kommandos oder der SQL-Anweisung

● bei einem Fehler: Ausnahme der Klasse LoaderError

Beispiel

Tabelle exportieren


Methode rawCmd (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode rawCmd

Verwendung

rawCmd ist eine Methode der Klasse Loader.

Mit dieser Methode senden Sie ein Loader-Kommando oder eine SQL-Anweisung an den Loader-Server. Fehler des Loader-Servers lösen keine Ausnahmen aus.

Im Gegensatz dazu lösen Fehler beim Ausführen der Methode cmd Ausnahmen aus.

Funktionsumfang

rawCmd (cmd_string)

cmd_string

Loader-Kommando

Ergebnis:

● bei erfolgreicher Ausführung:

OK

Ergebnis des Loader-Kommandos

● bei einem Fehler:

ERR

Fehlermeldung

Beispiel

● Sie senden eine gültige SQL-Anweisung:

result = session.rawCmd ('CREATE TABLE testtable2 (colname INTEGER)')
print repr (result)

'OK \n'

● Sie senden ein ungültiges Loader-Kommando:

result = session.rawCmd ('invalid command')
print repr (result)

'ERR\n-25010\nSQL error -3005 = Invalid SQL statement (error position: 1)'


Methode sql (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode sql

Verwendung

sql ist eine Methode der Klasse Loader.

Mit dieser Methode senden Sie ein Loader-Kommando oder eine SQL-Anweisung an den Loader-Server.

Funktionsumfang

sql (cmd_string)

cmd_string

Loader-Kommando oder SQL-Anweisung

Ergebnis:

● bei erfolgreicher Ausführung: 0

● bei einem SQL-Fehler: Meldungsnummer der Fehlermeldung

● bei einem Loader-Fehler: Ausnahme der Klasse LoaderError

Beispiel

Abfrage, ob eine Tabelle existiert


Methode release (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Methode release

Verwendung

release ist eine Methode der Klasse Loader.

Mit dieser Methode beenden Sie die Verbindung zum Loader-Server.

Funktionsumfang

release ()


Fehlerbehandlung für das Modul sdb.loader (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Fehlerbehandlung für das Modul sdb.loader

Verwendung

In Fehlersituationen lösen die Methoden des Moduls sdb.loader Ausnahmen der folgenden Klassen aus:

Klasse CommunicationError

Klasse LoaderError


Klasse CommunicationError (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse CommunicationError

Verwendung

CommunicationError ist eine Klasse des Moduls sdb.loader.

Die Methoden des Moduls sdb.loader lösen Ausnahmen dieser Klasse aus, wenn keine Verbindung zum Loader-Server hergestellt werden kann oder eine bestehende Verbindung abgebrochen wird.

Attribute der Objekte der Klasse CommunicationError

Name | Beschreibung
errorCode | Fehlercode
message | Text der Fehlermeldung

Beispiel

Sie haben einen falschen Rechnernamen angegeben (PRAMA statt PARMA):

try:

session = sdb.loader.Loader ('PRAMA', '')

except sdb.loader.CommunicationError, err:

print err

print err.message

loader.CommunicationError: [-4] unknown host name

unknown host name


Klasse LoaderError (SAP-Bibliothek - Schnittstellen)

Funktionsdokumentation Klasse LoaderError

Verwendung

LoaderError ist eine Klasse des Moduls sdb.loader.

Die Methoden des Moduls sdb.loader lösen Ausnahmen dieser Klasse aus, wenn der Loader-Server einen Fehler meldet.

Mögliche Ursachen:

● Fehler beim Ausführen einer SQL-Anweisung mit der Methode sql

● Fehler beim Ausführen eines Loader-Kommandos mit der Methode cmd

Attribute der Objekte der Klasse LoaderError

Name | Beschreibung
errorCode | Meldungsnummer siehe Dokumentation Strukturlink Meldungen
message | Langtext
sqlCode | ● Nummer der Fehlermeldung der SQL-Anweisung (bei einem SQL-Fehler) ● 0 (bei einem Loader-Fehler)
sqlMessage | Text der SQL-Fehlermeldung


Beispiele für das Modul sdb.loader (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Beispiele für das Modul sdb.loader

Die Beispiele zeigen, wie Sie in einem Python-Skript mit dem Modul sdb.loader Loader-Kommandos in einer MaxDB-Datenbankinstanz ausführen können.

● An eine Datenbankinstanz anmelden

● Abfrage, ob eine Tabelle existiert

● Tabelle exportieren

Die Beispiele verwenden die folgenden Demo-Daten:

Demo-Daten | Beschreibung
MONA | Name des Datenbankbenutzers
RED | Kennwort des Datenbankbenutzers
DEMODB | Demo-Datenbank


An eine Datenbankinstanz anmelden (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt An eine Datenbankinstanz anmelden

In diesem Beispiel verwenden Sie die Klasse Loader und die Methode cmd des Moduls sdb.loader. Sie rufen den Loader auf und melden sich an eine Datenbankinstanz an.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

# Python-Module importieren

# -------------------------------------------

import sys

import sdb.loader

# Loader aufrufen

# -------------------------------------------

session = sdb.loader.Loader ()

# An die Datenbankinstanz anmelden

# -------------------------------------------

session.cmd ("USE USER MONA RED DB DEMODB")

# Verbindung zur Datenbankinstanz beenden

# -------------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py

Siehe auch:

Beispiele für das Modul sdb.loader


Abfrage, ob eine Tabelle existiert (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Abfrage, ob eine Tabelle existiert

In diesem Beispiel verwenden Sie die Klasse Loader und die Methode sql des Moduls sdb.loader. Sie rufen den Loader auf, melden sich an eine Datenbankinstanz an und fragen ab, ob eine bestimmte Tabelle existiert.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

# Python-Module importieren

# -------------------------------------------

import sys

import sdb.loader

# Loader aufrufen

# -------------------------------------------

session = sdb.loader.Loader ()

# An die Datenbankinstanz anmelden

# -------------------------------------------

session.cmd ("USE USER MONA RED DB DEMODB")

# Abfrage, ob die Tabelle HOTEL.CUSTOMER existiert.

# Wenn die Tabelle nicht existiert, gibt der Loader

# einen Fehler zurück.
# -------------------------------------

sqlrc = session.sql("EXISTS TABLE HOTEL.CUSTOMER")

if (sqlrc == 0):

print 'Table HOTEL.CUSTOMER exists.'

elif (sqlrc == -4004):

print 'Error -4004: Table HOTEL.CUSTOMER does not exist.'

# Verbindung zur Datenbankinstanz beenden
# -------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py

Siehe auch:

Beispiele für das Modul sdb.loader


Tabelle exportieren (SAP-Bibliothek - Schnittstellen)

Diese Grafik wird im zugehörigen Text erklärt Tabelle exportieren

In diesem Beispiel verwenden Sie die Klasse Loader und die Methode cmd des Moduls sdb.loader. Sie rufen den Loader auf, melden sich an eine Datenbankinstanz an und exportieren eine Tabelle.

Vorgehensweise

...

1. Erstellen Sie ein Python-Skript sample.py mit folgendem Inhalt:

# Python-Module importieren

# -------------------------------------------

import os

import sys

import sdb.loader

# Home-Verzeichnis ermitteln

# -------------------------------------------

homedir = None

if sys.platform[:3] in ['win']:

homedir= os.path.join(os.getenv ('HOMEDRIVE'), os.getenv ('HOMEPATH' ))

else:

homedir = os.getenv ('HOME')

# Loader aufrufen

# -------------------------------------------

session = sdb.loader.Loader ()

# An die Datenbankinstanz anmelden

# -------------------------------------------

session.cmd ("USE USER MONA RED DB DEMODB")

# Loader-Kommando ausführen (Export)

# -------------------------------------------

catalogstream = "CATALOG OUTSTREAM '%s' " % os.path.join(homedir, 'room_ddl.catalog')

datastream = "DATA OUTSTREAM '%s' " % os.path.join(homedir, 'room_csv.data')

cmd = "EXPORT TABLE HOTEL.ROOM %s %s " % (catalogstream,datastream)

session.cmd (cmd)

# Verbindung zur Datenbankinstanz beenden

# -------------------------------------------

session.release ()

2. Rufen Sie das Python-Skript auf:

python sample.py

Ergebnis

Die Datenbankkatalogdaten und die Anwendungsdaten der Tabelle HOTEL.ROOM wurden in die Ausgabedateien room_ddl.catalog und room_csv.data im Home-Verzeichnis des angemeldeten Betriebssystembenutzers exportiert

Siehe auch:

Beispiele für das Modul sdb.loader


PHP-Handbuch (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation PHP-Handbuch

Einsatzmöglichkeiten

Mit der MaxDB PHP-Erweiterung können Sie können Sie mit PHP auf MaxDB-Datenbankinstanzen zugreifen. Die MaxDB-PHP-Erweiterung ist eine Schnittstelle zwischen PHP und der MaxDB SQLDBC-Schnittstelle.

Einführungshinweise

Die Programmierschnittstelle kann auf Linux (32bit), Microsoft Windows 2000 und Microsoft Windows XP verwendet werden. Sie benötigen PHP Version 4.3.6 oder höher.

Die MaxDB-PHP-Erweiterung ist nicht Bestandteil des MaxDB-Standard-Installationspakets. Sie können die MaxDB-PHP-Erweiterung aus dem PECL-Repository für PHP-Erweiterungen herunterladen, siehe pecl.php.net.

Die Dokumentation zur MaxDB-PHP-Erweiterung finden Sie unter www.php.net/manual/en/ref.maxdb.php.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

Die MaxDB PHP-Erweiterung bietet unter anderem die folgenden Funktionen:

● Datenbanksitzung eröffnen

● Mit SQL-Anweisungen auf Daten in der Datenbankinstanz zugreifen

Siehe auch:

Installationshandbuch, Strukturlink MaxDB-PHP-Erweiterung installieren


WebDAV (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation WebDAV

Einsatzmöglichkeiten

MaxDB stellt ein WebDAV-Servlet zur Verfügung, das das WebDAV-Protokoll gemäß RFC2518 (siehe www.w3.org) implementiert. Sie können eine MaxDB-Datenbankinstanz als Dokumentenablage nutzen und über das WebDAV-Servlet mit einem WebDAV-Client, wie z. B. dem Microsoft Windows Explorer, direkt auf die Dokumente in der MaxDB-Datenbankinstanz zugreifen.

Sie können das WebDAV-Servlet auf allen vom Datenbanksystem unterstützten Betriebssystemen verwenden

Einführungshinweise

Das WebDAV-Servlet ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten und wie Sie sie installieren, finden Sie im Abschnitt Strukturlink Download und im Installationshandbuch im Abschnitt Strukturlink Web SQL / WebDAV konfigurieren.

Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Integration

Sie benötigen einen Servlet-Container, wie z. B. Apache Tomcat, SAP NetWeaver AS oder JBoss, als Laufzeitumgebung für das MaxDB-WebDAV-Servlet.

Mit dem Datenbankwerkzeug Web SQL Studio können Sie auf die Dokumentenablagen der Datenbankinstanz zugreifen, mit der Sie gerade verbunden sind. Siehe Web SQL Studio, Strukturlink WebDAV-Repository öffnen.

Funktionsumfang

WebDAV-Servlet aufrufen

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Architektur der Schnittstellen


WebDAV-Servlet aufrufen (SAP-Bibliothek - Schnittstellen)

Vorgehensweisen WebDAV-Servlet aufrufen

Voraussetzungen

● Sie haben das WebDAV-Servlet installiert. Siehe Installationshandbuch, Strukturlink Web SQL / WebDAV konfigurieren.

Wenn Sie bei der Installation die Vorschlagswerte verwendet haben, dann wurde das WebDAV-Servlet unter dem Kontextpfad /sdbwebdav installiert

● Sie haben Ihren Servlet-Container gestartet. Informationen hierzu finden Sie in der Dokumentation zu Ihrem Servlet-Container.

Vorgehensweise

Geben Sie in Ihrem Web-Browser folgende Adresse ein:

http://<servlet_container_computer>:<servlet_container_port>/<context_path>

<servlet_container_computer> | Rechner, auf dem der Servlet-Container installiert ist.
<servlet_container_port> | Port des Servlet-Containers
<context_path> | Kontextpfad des WebDav-Servlets

Beispiel

Sie haben den Servlet-Container Apache Tomcat auf dem Rechner PARMA installiert und verwenden für den Port den Vorschlagswert 8080. Als Kontextpfad für das WebDAV-Servlet haben Sie /mywebdav konfiguriert.

http://PARMA:8080/mywebdav


Backint for MaxDB (SAP-Bibliothek - Schnittstellen)

Komponentendokumentation Backint for MaxDB

Einsatzmöglichkeiten

Diese Dokumentation spezifiziert die Schnittstelle Backint for MaxDB, über die externe Sicherungswerkzeuge an das MaxDB- Strukturlink Datenbankwerkzeug Database Manager angeschlossen werden können.

Einführungshinweise

Sie können die MaxDB-Software über die MaxDB-Website herunterladen (siehe Strukturlink Download und Strukturlink Installationsprofile). Die MaxDB-Software enthält eine spezielle Implementation der Backint for MaxDB-Spezifikation. Über diese spezielle Implementation können Sie externe Sicherungswerkzeuge, die eine Backint for Oracle-Schnittstelle haben, an den Database Manager anschließen (siehe Strukturlink Anschluss an eine Backint for Oracle-Schnittstelle).

Weiterführende Informationen zum Datenbanksystem finden Sie in den Dokumentationen Strukturlink Konzepte des Datenbanksystems und Strukturlink Glossar.

Funktionsumfang

Jede Implementation einer Backint for MaxDB-Schnittstelle muss die folgenden Funktionen aufweisen:

· Sicherungsfunktion (backup)

· Wiederherstellungsfunktion (restore)

· Auskunftsfunktion (inquire)

· Löschfunktion (delete)

Die Programmdefinition für Backint for MaxDB beschreibt, welche formellen Anforderungen eine Backint for MaxDB-Implementation erfüllen muss.

Einschränkungen

Unterstützte Betriebssysteme und Plattformen der Datenbankversion 7.4

Unterstützte Betriebssysteme und Plattformen der Datenbankversion 7.3


Sichern und Wiederherstellen mit MaxDB-Programmen (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Sichern und Wiederherstellen mit MaxDB-Programmen

MaxDB-Datenbankinstanzen können mit Hilfe von MaxDB-Programmen gesichert und wiederhergestellt werden.

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Sichern und Wiederherstellen


Sichern und Wiederherstellen mit externen Sicherungsprogrammen (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Sichern und Wiederherstellen mit externen Sicherungsprogrammen

Verwendung

Sie können Strukturlink externe Sicherungswerkzeuge anschließen, um ein MaxDB-Datenbanksystem zu sichern und wiederherzustellen. Der Datentransfer erfolgt dabei mit Hilfe des Strukturlink Database Manager über benannte Pipes.

Dabei gibt es zwei Möglichkeiten:

· Das externe Sicherungswerkzeug wird vom Strukturlink DBM-Server gesteuert.

Beim Strukturlink Sichern initiiert der DBM-Server den Datentransfer von der Strukturlink Datenbankinstanz zu einer oder mehreren Pipes und ruft zum Sichern der in den Pipes gelieferten Daten das externe Sicherungswerkzeug auf. Wenn das Datenbanksystem oder das externe Sicherungswerkzeug einen Fehler verursachen, beendet der DBM-Server den Datentransfer und informiert den Datentransferpartner.

Beim Strukturlink Wiederherstellen fordert der Client die verfügbaren Sicherungen über den DBM-Server vom externen Sicherungswerkzeug an. Dann zeigt er das Ergebnis dieser Abfrage dem Benutzer an und initiiert und steuert den Transfer der gewünschten Sicherungen mit Hilfe einer oder mehrerer Pipes vom externen Sicherungswerkzeug zur Datenbankinstanz.

Siehe auch: Dokumentation Anschluss Externer Sicherungswerkzeuge, Abschnitt Strukturlink Blockdiagramm Sichern und Wiederherstellen

· Das externe Sicherungswerkzeug verwendet die Client-Anwendung Strukturlink Database Manager CLI zur Steuerung der Datenbank.


Funktionsbeschreibung für Backint for MaxDB (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Funktionsbeschreibung für Backint for MaxDB

Backint for MaxDB führt das Strukturlink Sichern und Strukturlink Wiederherstellen mit dem entsprechenden MaxDB-Datenbankwerkzeug durch und sucht nach früheren Sicherungen. Das Programm ist die Verbindung zwischen dem Strukturlink DBM-Server und dem Strukturlink externen Sicherungswerkzeug.

Wenn das externe Sicherungswerkzeug eine Client-/Server-Architektur hat, kommuniziert Backint for MaxDB mit dem Client. Andernfalls implementiert es den Client, der auf dem Datenbankserver läuft. Auf diese Weise kann das MaxDB-Datenbankwerkzeug unterschiedliche externe Sicherungswerkzeuge standardisiert einsetzen.

Siehe auch: Installationshandbuch, Abschnitt Strukturlink Blockdiagramm Sichern und Wiederherstellen

Backint for MaxDB unterstützt folgende Funktionen:

· Sichern (backup)

· Wiederherstellen (restore)

· Auskunft (inquire)

· Löschen (delete)

Für alle Funktionen wird die Benutzerkennung (UID) zur Kennzeichnung der MaxDB-Datenbank verwendet. Nachdem die Funktion ausgeführt wurde, gibt Backint for MaxDB einen Rückgabewert aus, aus dem hervorgeht, ob der Aufruf erfolgreich war.


Sicherungsfunktion (backup) (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Sicherungsfunktion (backup)

Allgemeine Funktionsbeschreibung

Mit Hilfe der Sicherungsfunktion wird eine Sicherungsanfrage für die in einer Liste angegebenen Dateien oder Pipes definiert und an Backint for MaxDB übermittelt. Backint for MaxDB sichert diese Dateien oder Pipes und erzeugt als Antwort eine Sicherungskennung für die gesicherten Dateien oder Pipes, welche die Sicherung eindeutig kennzeichnet.

Backint for MaxDB informiert den Benutzer, welche Dateien oder Pipes erfolgreich gesichert wurden und welche nicht, welche Sicherungskennung den einzelnen Dateien und Pipes zugeordnet wurde, und wie viele Bytes für jede Pipe gesichert wurden.

Die Reihenfolge, in der die Dateien und/oder Pipes in der Liste gesichert werden, wird vom externen Sicherungswerkzeug frei bestimmt.

Art der zu sichernden Objekte

In der Eingabeliste für die Sicherungsfunktion ist gekennzeichnet, ob ein zu sicherndes Objekt eine Datei oder eine Pipe ist. Sie können in der Eingabeliste gemischt angegeben sein.

Backint for MaxDB und BACKINT (für Oracle) unterscheiden sich in den zulässigen Objekten für die Sicherung:

BACKINT (für Oracle) lässt Dateien, Verzeichnisse und Raw Devices zu.

Backint for MaxDB lässt nur Dateien und Pipes zu.

Datentransfer

Wenn die Eingabeliste Dateien enthält, werden diese so gesichert, wie sie im Dateisystem abgelegt sind.

Für das Wiederherstellen von Pipes gelten folgende Regeln:

Die Software (DBM-Server) oder der Benutzer, die/der Backint for MaxDB aufgerufen hat, stellen sicher, dass jede Pipe in der Liste mindestens einmal geöffnet und geschlossen wird. Backint for MaxDB gibt für jede Pipe, die nicht geöffnet wurde, einen Fehler zurück. Für einen Datentransfer müssen beide Seiten einer Pipe geöffnet werden; die eine Seite durch die Datenbanksoftware oder den Benutzer und die andere Seite durch Backint for MaxDB. Wenn Pipes, die in der Eingabedatei aufgeführt sind, nicht existieren, legt Backint for MaxDB sie entweder an oder prüft periodisch, ob sie vorhanden sind.

Pipes werden nur zum Lesen geöffnet. Der Datentransfer durch eine Pipe endet, sobald eine Seite der Pipe geschlossen wird.

Wenn eine Datenbankversion kleiner als 7.4.03 verwendet wird und mehrere Pipes in der Eingabedatei angegeben sind, müssen die Pipes parallel und in Echtzeit verarbeitet werden, um gegenseitiges Sperren (Deadlocks) zu vermeiden. Backint for MaxDB muss also alle Pipes gleichzeitig, dabei aber unabhängig voneinander verarbeiten.

Das Öffnen oder Lesen einer Pipe darf nicht das Öffnen und die Datentransfers der anderen in der Eingabedatei aufgeführten Pipes sperren. Zu diesem Zweck prüft Backint for MaxDB jede Pipe periodisch, um sicherzustellen, dass sie geöffnet werden kann oder dass Daten aus der Pipe gelesen werden können. Dies kann dadurch erreicht werden, dass für jede einzelne Pipe ein untergeordneter Prozess oder Thread gestartet wird und jede Synchronisation zwischen diesen Prozessen und/oder Threads vermieden wird. So können die Prozesse oder Threads die Pipes mit normalen blockierenden Operationen öffnen und lesen, da das Betriebssystem periodisch zwischen den Prozessen oder Threads aller Pipes hin- und herschaltet.

Wenn eine Datenbankversion ab 7.4.03 verwendet wird und mehrere Pipes in der Eingabedatei angegeben sind, verarbeitet Backint for MaxDB diese Pipes zumindest teilweise parallel. Andernfalls würde die Möglichkeit, parallel sichern zu können, keine Vorteile bieten. Abhängigkeiten zwischen den Pipes oder den Prozessen/Threads, die diese Pipes verarbeiten, müssen während des Sicherungsvorganges nicht vermieden werden, da die Datenbank selbst die Pipes unabhängig voneinander verarbeitet.

MaxDB kann, muss aber nicht das parallele Sichern von Pipes unterstützen. Ebenso ist es möglich, Backint for MaxDB nur für Datenbankversionen 7.4.03 oder für alle Datenbankversionen zu konzipieren, für die diese Dokumentation gilt.


Wiederherstellungsfunktion (restore) (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Wiederherstellungsfunktion (restore)

Mit Hilfe der Wiederherstellungsfunktion wird eine Anfrage zur Wiederherstellung von Sicherungen an Backint for MaxDB übergeben. Diese Anfrage besteht aus der Benutzerkennung (Siehe auch: Variablen) und einer Liste der wiederherzustellenden Dateien und/oder Pipes.

Für Dateien werden die Strukturlink Sicherungskennung, ihr Name und ein Verzeichnis angegeben, in dem die Datei wiederhergestellt werden soll. Für Pipes werden die Sicherungskennung, ihr Name und der Name der aktuellen Pipe angegeben, in der der Inhalt der gesicherten Pipe wiederhergestellt werden soll. Der Name des Verzeichnisses, in der die Datei angelegt werden soll, und der Name der aktuellen Pipe sind optional. Wenn keine Sicherungskennung angegeben ist, wird die letzte Strukturlink Sicherung der Datei oder Pipe wiederhergestellt. Die zurückgegebenen Informationen geben an, welche Dateien oder Pipes wiederhergestellt wurden und welche Sicherungen verwendet wurden.

Die Reihenfolge, in der die Dateien in der Liste wiederhergestellt werden, wird von Backint for MaxDB frei bestimmt.

Art des Datenträgers

Für die Wiederherstellungsfunktion verwendet Backint for MaxDB eigene Informationen oder Informationen des Sicherungswerkzeugs um zu ermitteln, ob es sich bei einem wiederherzustellenden Objekt um eine Datei oder eine Pipe handelt. In der Eingabeliste können sie gemischt angegeben sein.

Datentransfer

Wenn die Eingabeliste Dateien enthält, dann werden diese im Dateisystem wiederhergestellt.

Die Software (DBM-Server) oder der Benutzer, die/der Backint for MaxDB aufgerufen hat, stellen sicher, dass jede Pipe in der Liste mindestens einmal geöffnet und geschlossen wird. Backint for MaxDB gibt für jede Pipe, die nicht geöffnet wurde, einen Fehler zurück. Es stellt die Daten in einer Pipe in der Reihenfolge wieder her, in der sie aus der originalen, gesicherten Pipe gelesen wurden. Für einen Datentransfer müssen beide Seiten einer Pipe geöffnet werden; die eine Seite durch die Datenbanksoftware oder den Benutzer und die andere Seite durch Backint for MaxDB. Wenn Pipes, die in der Eingabedatei aufgeführt sind, nicht existieren, legt Backint for MaxDB sie entweder an oder prüft periodisch, ob sie vorhanden sind.

Pipes werden nur zum Schreiben geöffnet. Der Datentransfer durch eine Pipe endet, sobald eine Seite der Pipe geschlossen wird.

Wenn eine Datenbankversion kleiner als 7.4.03 verwendet wird und mehrere Pipes in der Eingabedatei angegeben sind, müssen die Pipes parallel und in Echtzeit verarbeitet werden, um gegenseitiges Sperren (Deadlocks) zu vermeiden. Backint for MaxDB muss also alle Pipes gleichzeitig, dabei aber unabhängig voneinander verarbeiten.

Das Öffnen oder Schreiben einer Pipe darf nicht das Öffnen und die Datentransfers der anderen in der Eingabedatei aufgeführten Pipes sperren. Zu diesem Zweck prüft Backint for MaxDB jede Pipe periodisch, um sicherzustellen, dass sie geöffnet werden kann oder dass Daten in die Pipe geschrieben werden können. Dies kann dadurch erreicht werden, dass für jede einzelne Pipe ein untergeordneter Prozess oder Thread gestartet wird und jede Synchronisation zwischen diesen Prozessen und/oder Threads vermieden wird, einschließlich der Synchronisation, die aus gemeinsam genutzten Ressourcen wie Bändern resultiert. Dann können die Prozesse oder Threads die Pipes mit normalen blockierenden Operationen öffnen und beschreiben, da das Betriebssystem periodisch zwischen den Prozessen oder Threads aller Pipes hin- und herschaltet.

Wenn eine Datenbankversion ab 7.4.03 verwendet wird und mehrere Pipes in der Eingabedatei angegeben sind, verarbeitet Backint for MaxDB ein Maximum dieser Pipes parallel. Dadurch werden minimale Wiederherstellungszeiten erreicht. Abhängigkeiten zwischen den Pipes oder den Prozessen/Threads, die diese Pipes verarbeiten, müssen während der Wiederherstellung nicht vermieden werden, da die Datenbank selbst die Pipes unabhängig voneinander verarbeitet.

MaxDB kann, muss aber nicht das parallele Wiederherstellen von Pipes unterstützen. Ebenso ist es möglich, Backint for MaxDB nur für Datenbankversionen 7.4.03 oder für alle Datenbankversionen zu konzipieren, für die diese Dokumentation gilt. Allerdings muss der unterstützte Typ der parallelen Wiederherstellung dem Typ der parallelen Sicherung entsprechen.


Auskunftsfunktion (inquire) (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Auskunftsfunktion (inquire)

Mit Hilfe der Auskunftsfunktion können Informationen über die vom Strukturlink externen Sicherungswerkzeug verwalteten Strukturlink Sicherungen abgefragt werden.

Diese Funktion wird mit der Benutzerkennung, der Sicherungskennung und dem Datei- oder Pipe-Namen aufgerufen. Die Benutzerkennung muss angegeben werden. Die Angabe der Sicherungskennung und des Datei- oder Pipe-Namens ist optional. Der Inhalt der Ausgabedatei für diese Funktion ist abhängig von den Angaben in der Abfrage.

Wenn die Eingabeliste mehrere Einträge enthält, dann generiert Backint for MaxDB die Ausgaben für die einzelnen Einträge und gibt sie in der Reihenfolge der Eingaben aus.

Es ergeben sich vier mögliche Fälle:

Einträge in der Eingabedatei

Einträge in der Ausgabedatei

Weder Sicherungskennung noch Datei- oder Pipe-Name angegeben:
#NULL

Liste der Sicherungskennungen für eine Benutzerkennung, sortiert nach Erzeugungsdatum (letzte Sicherung zuerst)
Ein Listeneintrag besteht aus einer Sicherungskennung.
 #BACKUP <backup_id>

Wenn keine Sicherungskennungen zur angegebenen Benutzerkennung vorhanden sind, erzeugt Backint for MaxDB keine Ausgabe.

Sicherungskennung angegeben,
Datei- oder Pipe-Name nicht angegeben:
<backup_id>

Liste der zur Sicherungskennung gehörigen Dateien oder Pipes
Jeder Listeneintrag besteht aus der angegebenen Sicherungskennung und einem Datei- oder Pipe-Namen.
 #BACKUP <backup_id> <file_name>
|#BACKUP <backup_id> <pipe_name>

Wenn keine Dateien und/oder Pipes zur angegebenen Sicherungskennung vorhanden sind, erzeugt Backint for MaxDB keine Ausgabe.

Datei- oder Pipe-Name angegeben,
Sicherungskennung nicht angegeben:
#NULL <file_name> |#NULL <pipe_name>

Liste der zu der angegebenen Datei oder Pipe gehörigen Sicherungskennungen, sortiert nach Erzeugungsdatum (letzte Sicherung zuerst)
Jeder Listeneintrag besteht aus einer Sicherungskennung und dem angegebenen Datei- oder Pipe-Namen.

( #BACKUP <backup_id> <file_name>
|#BACKUP <backup_id> <pipe_name>)

Wenn es keine Sicherung der angegebenen Datei oder Pipe gibt, generiert MaxDB eine Ausgabe, die das Schlüsselwort #NOTFOUND enthält.

(#NOTFOUND <file_name>)
(#NOTFOUND <pipe_name>)

Sowohl Sicherungskennung als auch Datei- oder Pipe-Name angegeben:
<backup_id> <file_name>
|<backup_id> <pipe_name>

Die durch die Sicherungskennung und den Datei- oder Pipe-Namen spezifizierte Sicherung:
#BACKUP <backup_id> <file_name>
|#BACKUP <backup_id> <pipe_name>

Wenn es keine Sicherung der angegebenen Datei oder Pipe mit der angegebenen Sicherungskennung gibt, generiert MaxDB eine Ausgabe, die das Schlüsselwort #NOTFOUND enthält.

(#NOTFOUND <file_name>)
(#NOTFOUND <pipe_name>)


Löschfunktion (delete) (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Löschfunktion (delete)

Mit Hilfe der Löschfunktion wird Backint for MaxDB darüber informiert, welche zuvor gesicherten Dateien oder Pipes nicht länger benötigt werden. Backint for MaxDB darf eine Löschanfrage ignorieren.

Wenn z.B. eine Strukturlink Sicherungsaktion nur teilweise erfolgreich war, wird Backint for MaxDB darüber durch die Löschfunktion informiert. Die Dateien oder Pipes, die nicht länger benötigt werden, werden mit Benutzerkennung, Sicherungskennung und Namen angegeben.


Programmdefinition für Backint for MaxDB (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Programmdefinition für Backint for MaxDB

Variablen

Aufruf von Backint for MaxDB

Optionen

Inhalt der Eingabedatei

Inhalt der Ausgabedatei

Rückgabewerte


Aufruf von Backint for MaxDB (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Aufruf von Backint for MaxDB

Backint for MaxDB muss auf Kommandozeilenebene mit folgender Syntax aufgerufen werden können:

backint -u <user_id> [-f <function>] [-t <type>] [-c] [-p <par_file>] [-i <in_file>] [-o <out_file>]

Für die Beschreibung der Optionen siehe Abschnitt Optionen

Für die Beschreibung der Variablen siehe Abschnitt Variablen

Zusätzlich zu den Optionen unterstützt die Schnittstelle einige Umgebungsvariablen, die vom Strukturlink DBM-Server gesetzt werden, bevor Backint for MaxDB aufgerufen wird:

Umgebungsvariable | Wert | Beschreibung
BI_CALLER | DBMSRV | Backint for MaxDB wird vom DBM-Server aufgerufen
BI_BACKUP | FULL | PARTIAL | ARCHIVE | vollständige oder inkrementelle Strukturlink Datensicherung oder Strukturlink Log-Sicherung
BI_REQUEST | NEW | OLD | erster oder nachfolgender Aufruf von Backint for MaxDB während einer laufenden Sicherung

Da der DBM-Server die Umgebung dynamisch setzt (putenv), kann Backint for MaxDB als ein vom DBM-Server gestarteter Prozess diese Variablen erben (getenv) und anhand ihrer Werte die weitere Verarbeitung steuern.


Optionen (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Optionen

Folgende Optionen müssen für Backint for MaxDB gesetzt werden können:

Option | Beschreibung | Vorschlagswert
-u <user_id> | Benutzerkennung (UID), Benutzer des Sicherungswerkzeugs (z. B. Name der Datenbankinstanz) | Keiner
-f <function> | <function>::= backup | restore | inquire | delete Art der Operation | backup
-t <type> | <type>::= file Sicherungstyp, file ist der einzig mögliche Typ für die Handhabung von Dateien oder Pipes Er ist equivalent zum Sicherungstyp file von BACKINT (für Oracle). | file
-c | Unbetreute Sicherung (keine Aktion durch Operator möglich) | Betreute Sicherung
-p <par_file> | Name der Parameterdatei, Textdatei für das Strukturlink externe Sicherungswerkzeug mit Parametern, die die Sicherungsprozedur festlegen ist spezifisch für das Sicherungswerkzeug Die MaxDB-Datenbankwerkzeuge entnehmen den Speicherort dieser Datei ihrer eigenen Parameterdatei, werten aber ihren Inhalt nicht aus. | Keiner
-i <in_file> | Name der Eingabedatei Textdatei mit den Objekten der Funktion (backup, restore, inquire oder delete). Siehe auch: Inhalt der Eingabedatei | Wenn diese Option nicht gesetzt ist, werden die Daten aus der Standardeingabe gelesen.
-o <out_file> | Name der Ausgabedatei Textdatei, in der Meldungen über die Verarbeitung und die Ergebnisse der ausgeführten Funktion gespeichert werden Siehe auch: Inhalt der Ausgabedatei | Wenn diese Option nicht gesetzt ist, werden die Meldungen in die Standardausgabe geschrieben.

Siehe auch: Variablen


Variablen (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Variablen

Variablen

In den Abschnitten dieses Dokuments werden alle Variablen mit folgenden Bedeutungen und Definitionen verwendet:

Variable | Beschreibung | Typ (max. Länge)
<backup_id> | Sicherungskennung (BID) | CHAR(16)
<backup_vol> | Sicherungsabschnitt (z.B. Bandetikett) | CHAR(10)
<dest_dir> | absolutes Verzeichnis und Name, unter dem eine gesicherte Datei wiederhergestellt werden soll | CHAR(255)
<dest_name> | absoluter Name der aktuellen Pipe, in der der Inhalt einer gesicherten Pipe wiederhergestellt werden soll | CHAR(255)
<file_name> | absolutes Verzeichnis und Name der Datei | CHAR(255)
<in_file> | Name der Eingabedatei | CHAR(255)
<out_file> | Name der Ausgabedatei | CHAR(255)
<par_file> | Name der Parameterdatei | CHAR(255)
<pipe_name> | absoluter Name der Pipe | CHAR(255)
<size> | Datei- oder Pipe-Größe | CHAR(16)
<user_id> | Benutzerkennung (UID) | CHAR(16)


Sicherungskennung (BID) (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Sicherungskennung (BID)

Die Implementierung von Backint for MaxDB erzeugt beim Strukturlink Sichern einer Datei oder Pipe eine Sicherungskennung (BID) und schreibt sie in die Ausgabedatei. Diese wird dann für die Funktionen Strukturlink Wiederherstellung, Auskunft und Löschung verwendet.

Eine Sicherungskennung muss nicht unbedingt eindeutig sein, da sie sowohl der Sicherung einer einzelnen Datei oder Pipe als auch den Sicherungen mehrerer Dateien und/oder Pipes zugeordnet werden kann. Jedoch wird jede Sicherung immer durch eine eindeutige Kombination von Benutzerkennung, Sicherungskennung und Datei- oder Pipe-Namen gekennzeichnet.


Inhalt der Eingabedatei (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Inhalt der Eingabedatei

Die Eingabedatei besteht aus einer Liste von zu sichernden Objekten. Die Angaben müssen den unten angegebenen Syntaxregeln entsprechen.

Welche Angaben Backint for MaxDB verarbeiten muss, hängt von der verwendeten Funktion ab.

Siehe auch: Funktionsbeschreibung für Backint for MaxDB

Funktion | Inhalt der Eingabedatei | Syntax
Sichern | Namen der zu sichernden Dateien oder Pipes Pipes sind mit dem Schlüsselwort #PIPE markiert | <file_name> | <pipe_name> #PIPE
Wiederherstellen | Sicherungskennung/en und/oder Namen der wiederherzustellenden Dateien oder Pipes Wenn die letzte Version von Dateien oder Pipes wiederhergestellt werden soll, können die Sicherungskennungen teilweise oder ganz durch das Schlüsselwort #NULL ersetzt sein. Eine Kombination aus Sicherungskennung und Name einer Datei kann um den absoluten Namen eines Zielverzeichnisses erweitert sein, wenn die Datei in einem anderen Verzeichnis wiederhergestellt werden sollen, als sie gesichert wurde. Eine Kombination aus Sicherungskennung und Name einer Pipe kann um den absoluten Namen der Ziel-Pipe erweitert sein, wenn der Inhalt der Pipe in einer anderen Pipe wiederhergestellt werden soll, als er gesichert wurde. | <backup_id> <file_name> [<dest_dir>] | #NULL <file_name> [<dest_dir>] | <backup_id> <pipe_name> [<dest_name>] | #NULL <pipe_name> [<dest_name>]
Auskunft | Sicherungskennung/en und/oder Namen der Dateien oder Pipes, zu denen Informationen abgefragt werden | #NULL | <backup_id> | #NULL <file_name> | #NULL <pipe_name> | <backup_id> <file_name> | <backup_id> <pipe_name>
Löschung | Sicherungskennungen und Namen der Dateien oder Pipes, die gelöscht werden können. | <backup_id> <file_name> | <backup_id> <pipe_name>

Siehe auch: Variablen


Inhalt der Ausgabedatei (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Inhalt der Ausgabedatei

Die Ausgabedatei enthält die Meldungen über die Verarbeitung sowie die Ergebnisse der ausgeführten Funktion. Neben den Erfolgs- und Fehlermeldungen im definierten Format kann die Datei noch weitere Meldungen enthalten.

Der Meldungsinhalt ist von der ausgeführten Funktion abhängig.

Siehe auch: Funktionsbeschreibung für Backint for MaxDB

Funktion

Erfolgsmeldung

Fehlermeldung

Sichern

#SAVED <backup_id> <file_name> [<backup_vol>]

| #SAVED <backup_id> <pipe_name> <size> [<backup_vol>]

#ERROR <file_name>
| #ERROR <pipe_name>

Wiederherstellen

#RESTORED <backup_id> <file_name>
| #RESTORED <backup_id> <pipe_name>

#NOTFOUND <file_name>
| #NOTFOUND <pipe_name>
| #ERROR <file_name>
| #ERROR <pipe_name>

Auskunft

#BACKUP <backup_id>
| #BACKUP <backup_id> <file_name>
| #BACKUP <backup_id> <pipe_name>

#NOTFOUND <file_name>
| #NOTFOUND <pipe_name>
| #ERROR <file_name>
| #ERROR <pipe_name>

Löschung

#DELETED <backup_id> <file_name>
| #DELETED <backup_id> <pipe_name>

#NOTFOUND <file_name>
| #NOTFOUND <pipe_name>
| #ERROR <file_name>
| #ERROR <pipe_name>
| #NOTDELETED <file_name>
| #NOTDELETED <pipe_name>

Siehe auch: Variablen


Rückgabewerte (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Rückgabewerte

Backint for MaxDB wird von der Software (d. h. dem Strukturlink DBM-Server) oder einem Benutzer aufgerufen. Software und Benutzer erwarten, dass Backint for MaxDB einen der im folgenden beschriebenen Werte zurückliefert.

Rückgabewert | Beschreibung
0 | OK – Alle Dateien und Pipes wurden erfolgreich und ohne Warnungen verarbeitet.
1 | WARNUNG – Alle Dateien und Pipes wurden jedoch erfolgreich verarbeitet.
2 | FEHLER – Einige oder alle Dateien oder Pipes wurden nicht erfolgreich verarbeitet.


Unterstützte Betriebssysteme und Plattformen (Version 7.4) (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Unterstützte Betriebssysteme und Plattformen (Version 7.4)

Die Version 7.4 des Datenbanksystems unterstützt folgende Betriebssysteme und Plattformen:

· Compaq Tru64 Unix (Alpha)

· HP-UX (HP-PA)

· IBM AIX (PowerPC)

· Linux (i386, ia64)

· SUN Solaris (SPARC)

· Microsoft Windows 2000 (i386)

· Microsoft Windows XP (i386)

· Microsoft Windows Server 2003 (i386, ia64)


Unterstützte Betriebssysteme und Plattformen (Version 7.3) (SAP-Bibliothek - Schnittstellen)

Hintergrunddokumentation Unterstützte Betriebssysteme und Plattformen (Version 7.3)

Die Version 7.3 des Datenbanksystems unterstützt folgende Betriebssysteme und Plattformen:

· Compaq True64 Unix / Alpha

· IBM AIX / PowerPC

· SUN Solaris / SPARC

· HP-UX / HP-PA

· Linux / Intel

· Siemens Reliant Unix / MIPS

· Windows NT / Intel


Entwicklung (SAP-Bibliothek - Entwicklung)

Komponentendokumentation Entwicklung

Titel der Dokumentation | Inhalt
SAP Developer Guide, Strukturlink Developing on Database MaxDB | Entwickeln von Datenbankanwendungen für MaxDB
Entwicklungsumgebung | Verwendung der Entwicklungsumgebung zum Erstellen von MaxDB-Software aus dem Quelltext
Web Based Problem Tracking System | Web-Interface zum MaxDB-internen Programm PTS (Problem Tracking System) für die Dokumentation von Problemmeldungen zur MaxDB-Software


Entwicklungsumgebung (SAP-Bibliothek - Entwicklung)

Komponentendokumentation Entwicklungsumgebung

Einsatzmöglichkeiten

Die Entwicklungsumgebung dient dazu, den Quelltext einzelner MaxDB-Programme zu ändern und diese MaxDB-Programme neu zu erstellen.

Sie können die Entwicklungsumgebung auf allen vom Datenbanksystem Strukturlink unterstützten Betriebssystemen einsetzen, Installation und einige Funktionen unterscheiden sich jedoch unter den verschiedenen Betriebssystemen geringfügig.

Einführungshinweise

Die Entwicklungsumgebung ist Bestandteil der MaxDB-Software. Informationen dazu, wo Sie die MaxDB-Software erhalten, finden Sie im Abschnitt Strukturlink Download. Weiterführende Informationen zum Datenbanksystem finden Sie in der Dokumentation Strukturlink Konzepte des Datenbanksystems. Für einen schnellen Zugriff auf die gesamte Dokumentation und eine Erklärung der wichtigsten Begriffe verwenden Sie das alphabetisch sortierte Strukturlink Glossar.

Funktionsumfang

Ihnen stehen unter anderem die folgenden Werkzeuge zur Verfügung:

● Skripte zum Initialisieren der Entwicklungsumgebung

● Skripte zum Bearbeiten von Quelltext und Vergleichen unterschiedlicher Versionen von Dateien

● Skripte zum Aufrufen von VMAKE

● VMAKE zum Übersetzen und Linken des geänderten Quelltexts

Einschränkungen

Die Datenbankwerkzeuge Database Manager GUI und SQL Studio werden nicht mit der hier beschriebenen Entwicklungsumgebung erstellt.

Beispiel

● Beispiel: Übersetzen der Datei HelloWorld.c

● Beispiel: Erstellen des Programms Database Manager CLI

Siehe auch:

Konzepte des Datenbanksystems, Strukturlink Open-Source-Entwicklung der Datenbanksoftware

Glossar, Strukturlink Syntaxnotation


Installieren der Entwicklungsumgebung (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Installieren der Entwicklungsumgebung

Voraussetzungen

· Perl 5.005 (ActivePerl) oder höher

· Python 1.5.2 oder höher

Wir empfehlen, Perl und Python unter Microsoft Windows in Verzeichnissen zu installieren, deren Pfade keine Leerzeichen enthalten.

· Visual C++ 6.0 oder Visual C++ 7.0 (Microsoft Windows) bzw. C/C++-Compiler gcc (UNIX/Linux)

· bison, flex (nur UNIX/Linux)

Vorgehensweise

...

1. Laden Sie das zip-Archiv (Microsoft Windows) oder das tgz-Archiv (UNIX/Linux) herunter, das die Entwicklungsumgebung enthält. Siehe Strukturlink Download und Strukturlink Installationsprofile.

2. Nur unter UNIX/Linux:

Überprüfen Sie, ob Ihr Browser die Dateierweiterung von .tgz nach .tar geändert hat. Wenn ja, dann benennen Sie das Archiv wieder in .tgz um.

3. Entpacken Sie das Archiv in ein Verzeichnis, das keine Leerzeichen im Pfad enthält.

Das Verzeichnis DevTool wird angelegt.

4. Führen Sie im Verzeichnis DevTool das Skript installtools.pl aus.

¡ Das Skript sucht in der Umgebungsvariablen %PATH% bzw. $PATH nach Ihrer Perl- und Python-Installation.

¡ Sie werden aufgefordert, Ihren bevorzugten Text-Editor anzugeben.

¡ Die Datei iprofile.tmp wird erzeugt.

Ergebnis

Die Entwicklungsumgebung wurde installiert.

Um MaxDB-Programme zu ändern und neu zu erstellen, installieren Sie nun den Quelltext und initialisieren Sie die Entwicklungsumgebung.


Installieren des Quelltexts (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Installieren des Quelltexts

Voraussetzungen

Sie haben die Entwicklungsumgebung installiert.

Vorgehensweise

...

1. Laden Sie das Archiv mit dem Quelltext herunter. Siehe Strukturlink Download.

2. Entpacken Sie das Archiv in ein beliebiges Verzeichnis

Das Verzeichnis V<version> wird angelegt, wobei <version> die Versionsnummer der MaxDB-Software ist.

3. Führen Sie im Verzeichnis V<version> das Perl-Skript installsources.pl aus.

Die Datei initDev_SAPDB(.bat) und die Verzeichnisse MaxDB_ORG und MaxDB_DEV werden erzeugt (siehe Verzeichnisstruktur der Entwicklungsumgebung).

Ergebnis

Der Quelltext wurde installiert. Bevor Sie MaxDB-Programme ändern und neu erstellen können, initialisieren Sie zunächst die Entwicklungsumgebung.

Beispiel

Bei der Installation der Entwicklungsumgebung und des Quelltexts der MaxDB-Softwareversion 7.5.00.12 im Verzeichnis <MyDevelopmentDirectory> werden folgende Unterverzeichnisse angelegt:

<myDevelopmentDirectory>

/DevTool

/V75_00_12

/MaxDB_ORG

/MaxDB_DEV


Initialisieren der Entwicklungsumgebung (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Initialisieren der Entwicklungsumgebung

Verwendung

Sie rufen das Skript initDev_MaxDB(.bat) auf, das die vom Programm VMAKE benötigten Umgebungsvariablen mit Werten belegt.

Rufen Sie dieses Skript jedes Mal auf, nachdem Sie eine neue Shell oder ein neues Kommandofenster geöffnet haben.

Voraussetzungen

· Sie haben die Entwicklungsumgebung installiert.

· Sie haben den Quelltext installiert.

Vorgehensweise

...

1. Wechseln Sie in das Verzeichnis, in dem Sie die Entwicklungsumgebung installiert haben, und dann in das Verzeichnis V<version>. <version> ist die Version des installierten Quelltexts.

<myDevelopmentDirectory>/V75_00_12/

2. Falls erforderlich, ändern Sie im Skript initDev_MaxDB(.bat) die Werte der Umgebungsvariablen.

3. Führen Sie das Skript initDev_MaxDB(.bat) aus.

Ergebnis

Die Umgebungsvariablen der Entwicklungsumgebung wurden mit Werten belegt. Das System wechselt außerdem in das Verzeichnis MaxDB_DEV.

Sie können nun ein MaxDB-Programm ändern.


Umgebungsvariablen (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Umgebungsvariablen

Verwendung

In der Regel werden alle Umgebungsvariablen beim Initialisieren der Entwicklungsumgebung vom Skript initDEV_MaxDB(.bat) gesetzt. Sie können die Umgebungsvariablen jedoch auch von Hand konfigurieren. Hinweise zum Ändern von Umgebungsvariablen finden Sie in der Dokumentation Ihres Betriebssystems.

Unter Microsoft Windows ist der Name von Umgebungsvariablen in Prozentzeichen (%env_variable%) eingeschlossen. Unter UNIX beginnt der Name von Umgebungsvariablen mit einem Dollarzeichen ($env_variable). In dieser Dokumentation wird die UNIX-Schreibweise für Umgebungsvariablen verwendet.

Sie können folgende Umgebungsvariablen konfigurieren:

$ARC_TYPE

$BUILD_PRAEFIX

$CORRECTION_LEVEL

$DBROOT

$DLL_TYPE

$EDITOR

%INCLUDE% (nur unter Microsoft Windows)

$INSTROOT

$NOQUIET

$OWN

$PATH

$PERL5LIB

$PYTHONPATH

$RELVER

$SHELL

$TOOL

$TOOLEXT

$TOOLOPT

$TOOLSHELL

$TOOLVARS

$VMAKE_DEFAULT

$VMAKE_OPTION

$VMAKE_PATH

$VMAKE_VERSION

$WRK


$ARC_TYPE (SAP-Bibliothek - Entwicklung)

Objektdokumentation $ARC_TYPE

Definition

Diese Umgebungsvariable ist optional. Sie legt die Dateiendung von statischen Bibliotheken fest.

Systemvorschlag

Betriebssystem | Dateiendung
Microsoft Windows | .lib
UNIX/Linux | .a


$BUILD_PRAEFIX (SAP-Bibliothek - Entwicklung)

Objektdokumentation $BUILD_PRAEFIX

Definition

Diese Umgebungsvariable legt die Nummer des Patch-Levels des zu erstellenden MaxDB-Programms fest.

Systemvorschlag ist das Patch-Level des installierten Quelltexts.

Beispiel

Der Patch-Level des Quelltexts der MaxDB-Softwareversion 7.5.00.12 ist 12.


$CORRECTION_LEVEL (SAP-Bibliothek - Entwicklung)

Objektdokumentation $CORRECTION_LEVEL

Definition

Diese Umgebungsvariable legt die Nummer des Korrektur-Levels für die zu erstellende Software-Komponente fest.

Systemvorschlag ist der Korrektur-Level des installierten Quelltexts der MaxDB-Software.

Beispiel

Der Korrektur-Level des Quelltexts der MaxDB-Softwareversion 7.5.00.12 ist 00.


$DBROOT (SAP-Bibliothek - Entwicklung)

Objektdokumentation $DBROOT

Definition

$DBROOT ist eine veraltete Bezeichnung für die Umgebungsvariable $INSTROOT.

Wenn Sie $INSTROOT ändern, dann setzen Sie $DBROOT auf den gleichen Wert.


$DLL_TYPE (SAP-Bibliothek - Entwicklung)

Objektdokumentation $DLL_TYPE

Definition

Diese Umgebungsvariable ist optional. Sie legt die Dateiendung von dynamischen Bibliotheken fest.

Systemvorschlag

Betriebssystem | Dateiendung
Microsoft Windows | .dll
UNIX/Linux | keine Dateiendung


$EDITOR (SAP-Bibliothek - Entwicklung)

Objektdokumentation $EDITOR

Definition

Diese Umgebungsvariable legt den Editor fest, den das Perl-Skript iview.pl zum Anzeigen und Bearbeiten von Quelltextdateien verwendet.


%INCLUDE% (SAP-Bibliothek - Entwicklung)

Objektdokumentation %INCLUDE%

Definition

Diese Umgebungsvariable gibt es nur unter Microsoft Windows. Sie legt fest, in welchen Verzeichnissen die Werkzeuge der Entwicklungsumgebung nach Include-Dateien suchen.

Folgende Verzeichnisse müssen enthalten sein:

%INSTROOT%\incl

%TOOL%\incl

%OWN%\sys\wrk\incl

%OWN%\sys\wrk\incl\SAPDB


$INSTROOT (SAP-Bibliothek - Entwicklung)

Objektdokumentation $INSTROOT

Definition

Diese Umgebungsvariable legt fest, wo das Programm VMAKE die erstellten MaxDB-Programme ablegen soll. Der relative Pfad unterhalb von $INSTROOT ist abhängig vom erstellten MaxDB-Programm.

$INSTROOT enthält einen absoluten Pfad.

Beispiel

C:\test\V75_00_12\MaxDB_DEV\usr


$NOQUIET (SAP-Bibliothek - Entwicklung)

Objektdokumentation $NOQUIET

Definition

Diese Umgebungsvariable ist optional. Sie legt fest, ob beim MAKE-Vorgang jeder Compiler- und Linker-Aufruf angezeigt wird.

Sie können das gleiche Verhalten erreichen, indem Sie den MAKE-Vorgang folgendermaßen starten (siehe ims.pl, imf.pl: Starten des MAKE-Vorgangs):

imf --noquiet


$OWN (SAP-Bibliothek - Entwicklung)

Objektdokumentation $OWN

Definition

Diese Umgebungsvariable legt den absoluten Pfad für den Entwicklungsbereich MaxDB_DEV fest.

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


$PATH (SAP-Bibliothek - Entwicklung)

Objektdokumentation $PATH

Definition

Diese Umgebungsvariable erweitert die Betriebssystemvariable PATH um diejenigen Verzeichnisse, die von der Entwicklungsumgebung benötigt werden.

Folgende Pfade müssen enthalten sein:

$INSTROOT\bin

$INSTROOT\pgm (nur Microsoft Windows)

$TOOL\Posix

$TOOL\bin

$TOOL\pgm (nur Microsoft Windows)


$PERL5LIB (SAP-Bibliothek - Entwicklung)

Objektdokumentation $PERL5LIB

Definition

Diese Umgebungsvariable legt fest, in welchen Verzeichnissen die Entwicklungsumgebung nach Perl-Bibliotheken suchen. Diese Umgebungsvariable muss gesetzt werden, damit die in den Werkzeugen enthaltenen Perl-Skripte ablaufen können.

Folgende Verzeichnisse müssen enthalten sein:

$INSTROOT\misc

$TOOL\bin

$TOOL\Lib\Perl

$TOOL\Lib\perl5


$PYTHONPATH (SAP-Bibliothek - Entwicklung)

Objektdokumentation $PYTHONPATH

Definition

Diese Umgebungsvariable legt fest, in welchen Verzeichnissen die Entwicklungsumgebung nach Python-Bibliotheken sucht. Diese Umgebungsvariable muss gesetzt werden, damit die in den Werkzeugen enthaltenen Python-Skripte ablaufen können.

Folgenden Verzeichnisse müssen enthalten sein:

$TOOL\Lib\Python

$INSTROOT\lib


$RELVER (SAP-Bibliothek - Entwicklung)

Objektdokumentation $RELVER

Definition

Diese Umgebungsvariable legt die Versionsbezeichnung der zu erstellenden MaxDB-Programme fest. Die Werkzeuge der Entwicklungsumgebung verwenden diese Umgebungsvariable beim Linken.

Systemvorschlag ist die Versionsbezeichnung des installierten Quelltexts der MaxDB-Software.

Beispiel

Die Versionsbezeichnung des Quelltexts der MaxDB-Softwareversion 7.5.00.12 ist V75.


$SHELL (SAP-Bibliothek - Entwicklung)

Objektdokumentation $SHELL

Definition

Diese Umgebungsvariable ist optional. Sie legt fest, welche Kommando-Shell die Werkzeuge der Entwicklungsumgebung verwenden, um Betriebssystemkommandos in Beschreibungsdateien abzuarbeiten.

Wenn Sie diese Umgebungsvariable nicht setzen, dann werden folgende Kommando-Shells verwendet:

· Windows: cmd /c

· UNIX/Linux: sh

Folgende Kommando-Shells können Sie nicht verwenden: csh, tcsh

Wir empfehlen unter UNIX/Linux, sh oder bash zu verwenden.

Beispiel

/usr/local/bin/bash


$TOOL (SAP-Bibliothek - Entwicklung)

Objektdokumentation $TOOL

Definition

Diese Umgebungsvariable legt den absoluten Pfad fest, unter dem die Skripte und Programme gespeichert sind, die das Programm VMAKE verwendet.

Beispiel

C:\MyProject\DevTool


$TOOLEXT (SAP-Bibliothek - Entwicklung)

Objektdokumentation $TOOLEXT

Definition

Diese Umgebungsvariable legt die Dateiendung der Skripte (VMAKE-Werkzeuge) fest. Das Programm VMAKE kennt nur den ersten Teil der Dateinamen der zu verwendenden Skripte und benutzt diese Umgebungsvariable, um die Dateiendung zu ermitteln.

Beispiel

.pl


$TOOLOPT (SAP-Bibliothek - Entwicklung)

Objektdokumentation $TOOLOPT

Definition

Diese Umgebungsvariable übermittelt zusätzliche Optionen an die Shell, die mit $TOOLSHELL festgelegt wurde. Die Umgebungsvariable wird nur für interne Testzwecke verwendet.


$TOOLSHELL (SAP-Bibliothek - Entwicklung)

Objektdokumentation $TOOLSHELL

Definition

Diese Umgebungsvariable legt fest, welche Shell das Programm VMAKE verwenden soll, um Skripte auszuführen (VMAKE-Werkzeuge).

Beispiel

C:\Perl\bin\perl.exe


$TOOLVARS (SAP-Bibliothek - Entwicklung)

Objektdokumentation $TOOLVARS

Definition

Diese Umgebungsvariable legt den Pfad für die Initialisierungsdatei toolvars.pl fest, mit der die Perl-Skripte der Entwicklungsumgebung initialisiert werden. Der Systemvorschlag ist $TOOL/bin.

toolvars.pl enthält plattformspezifische Anpassungen, z. B. die plattformspezifischen Kompilier-, Link- und anderen Programme und deren zugehörige Optionen. Außderm werden mit dieser Initialisierungsdatei einige zusätzliche, für den Erstellungsprozess notwendige, Umgebungsvariablen initialisiert.

Beispiel

C:\develop\DevTool\bin\toolvars.pl


$VMAKE_DEFAULT (SAP-Bibliothek - Entwicklung)

Objektdokumentation $VMAKE_DEFAULT

Definition

Diese Umgebungsvariable ist optional. Sie legt den Systemvorschlag für die Übersetzung von Moduldateien fest, die in Beschreibungsdateien aufgeführt sind.

Verwendung

· Wenn Sie diese Umgebungsvariable nicht gesetzt haben, dann verwendet VMAKE den Wert von $VMAKE_VERSION.

· Wenn Sie für $VMAKE_VERSION den Wert slow angegeben haben und $VMAKE_DEFAULT auf fast gesetzt haben, dann werden von den in einer Beschreibungsdatei aufgeführten Dateien nur die Moduldateien mit der VMAKE-Version fast, alle anderen Dateien jedoch mit der VMAKE-Version slow übersetzt.


$VMAKE_OPTION (SAP-Bibliothek - Entwicklung)

Objektdokumentation $VMAKE_OPTION

Definition

Die Parameter dieser Umgebungsvariablen legen die Arbeitsweise von VMAKE fest:

· Allgemeine Parameter für $VMAKE_OPTION

· $VMAKE_OPTION-Parameter für die Suche nach Quelltext

· $VMAKE_OPTION-Parameter für die Suche nach Objektdateien

Wenn Sie mehrere Parameter angeben, dann setzen Sie keine Leerzeichen zwischen die einzelnen Parameter. Jeder Buchstabe steht für einen Parameter, wobei zwischen Klein- und Großbuchstaben unterschieden wird.

Einige dieser Parameter können Sie übersteuern, indem Sie beim Starten des MAKE-Vorgangs VMAKE-Optionen angeben.

Beispiel

aDISOhvWMLRgbX


Allgemeine Parameter für $VMAKE_OPTION (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Allgemeine Parameter für $VMAKE_OPTION

Verwendung

Für die Umgebungsvariable $VMAKE_OPTION können Parameter gesetzt werden. Wenn Sie mehrere Parameter angeben, dann setzen Sie keine Leerzeichen zwischen die einzelnen Parameter.

Allgemeine Parameter für $VMAKE_OPTION

Parameter | Beschreibung
A | Objektdateien werden auch dann auf die oberste in $VMAKE_PATH angegebene Verzeichnisebene kopiert, wenn sie im Entwicklungsbereich MaxDB_DEV bereits vorhanden sind.
a | Anstelle einer Fehlermeldung wegen unterschiedlicher Groß-/Kleinschreibung eines Ziels wird nur eine Warnung ausgegeben. Wenn sich Ziele in der Hierarchie in der Groß-/Kleinschreibung unterscheiden, gilt das normalerweise als Fehler.
b | Normalerweise dürfen C-Moduldateien keine PASCAL-Include-Dateien nutzen. Wenn diese Option gesetzt ist, dann ist dies erlaubt, und die aus der PASCAL-Include-Datei erzeugten C-Header-Dateien werden genutzt.
C | c | C-Level. Es gelten dieselben Regeln wie beim PASCAL-Level mit der Ausnahme, dass hier keine PASCAL-Moduldateien existieren dürfen. Wenn PASCAL- und C-Level verwendet wird, werden beim Übersetzungsvorgang Nicht-PASCAL_Dateien vom PASCAL-Level auf das C-Level kopiert. C | c impliziert also, dass PASCAL-Dateien in C-Dateien übersetzt werden. C verlangt, dass Quelltext auf diesem Level verwaltet wird. Wenn Sie c verwenden, dann ist dies optional, d. h. der Quelltext von diesem Level wird genutzt, wenn er vorhanden ist.
D | Datumsdateien werden genutzt, um das Datum einer Moduldatei zu protokollieren, an dem ein Programm erzeugt wurde.
e | Alle Objektdateien werden mit Debug-Informationen versehen.
g | Wenn Objekte in der Suchhierarchie gefunden werden, die jünger als die der 1. Hierarchie sind, so werden diese auf die 1. Hierarchie kopiert (standardmäßiges Verhalten).
h | Wenn Sie auf der Kommandozeile eine Beschreibungsdatei ohne Endung angeben, dann versucht VMAKE eine Beschreibungsdatei zu finden, die als Dateinamen den auf der Kommandozeile angegebenen Namen trägt. Mit der Option h wird die Suchreihenfolge folgendermaßen festgelegt: ... 1. Dateiendung mac 2. Dateiendung shm 3. Dateiendung lnk 4. Dateiendung dld 5. Dateiendung shr 6. Dateiendung rel
H | PASCAL-Include-Dateien werden nicht automatisch in C-Header-Dateien umwandelt.
I | i | Include-Dateien sind mit einem Rahmen versehen. Dieser muss entfernt werden, und die Include-Datei ist in das Include Verzeichnis zu stellen. Wenn weder die Option i noch I gesetzt ist, dann sind Include-Dateien untereinander unabhängig. Wenn i spezifiziert ist, dann gelten für Include-Dateien die normalen Abhängigkeitsregeln. Wenn I spezifiziert ist, dann werden für PASCAL-Include-Dateien Größeninformationen erzeugt. Include-Dateien werden nur dann berücksichtigt, wenn eine der Optionen S | s gesetzt ist.
l | Objektdateien, deren Moduldateien sich innerhalb des Entwicklungsbereiches MaxDB_ORG befinden, werden als aktuell betrachtet. Die Suchhierarchie wird also nicht angewendet.
L | Der Inhalt von Bibliotheken wird nicht analysiert. Das Datum einer Bibliothek wird gegen die Datumsstempel der Objektdateien geprüft. Beim Neuerstellen von Bibliotheken werden alle beteiligten Objektdateien gelinkt.
M | Objektdateien werden im Dateisystem gespeichert, weil auf sie sonst nicht zugegriffen werden kann. Im anderen Fall können Objektdateien aus schon gelinkten Programmen genutzt werden.
O | o | Dieses Level enthält Objektdateien, die zur Programmerzeugung gelinkt werden können. Wenn O gesetzt ist, dann werden diese Dateien entsprechend genutzt. Wenn o gesetzt ist, dann endet die Programmerzeugung, nachdem alle Objektdateien hergestellt sind.
P | p | Wenn P spezifiziert ist, dann verbleiben PASCAL-Level-Dateien im PASCAL-Level-Verzeichnis. P verlangt, dass Quelltext auf diesem Level verwaltet wird. Mit p ist dies optional, d. h. der Quelltext von diesem Level wird genutzt, wenn er vorhanden ist.
R | Die Optionen für Beschreibungsdateien shrglob und noshrglob werden ignoriert.
S | s | Viele Moduldateien sind mit einem Rahmen versehen, der vor dem Übersetzen entfernt werden muss. Wenn S spezifiziert ist, dann müssen alle Moduldateien vorhanden sein. Wenn s spezifiziert ist, dann werden diese Dateien nur genutzt, wenn sie vorhanden sind. Abhängige Dateien werden nur verarbeitet, wenn der Quelltext vorhanden ist.
t | Wenn Beschreibungsdateien übersetzt werden, dann wird ein Datumsstempel ausgegeben.
T | Bevor die Übersetzung einer Moduldatei beginnt, wird immer ein Zeitstempel ausgegeben.
X | Wenn auf schreibgeschützte Quelltexte (z. B. auf einer CDROM) zugegriffen werden soll, dann müssen Sie diese Option angeben.
Z | Moduldateidateien, in deren Namen keine Schicht kodiert ist und die auf .rc, .ico, .def, .mc, .dlg, .idl, .ycc, .lex oder .rgs enden, werden in der Schicht Resource gesucht.


$VMAKE_OPTION-Parameter für die Suche nach Quelltext (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation $VMAKE_OPTION-Parameter für die Suche nach Quelltext

Verwendung

Für die Umgebungsvariable $VMAKE_OPTION können Parameter gesetzt werden. Wenn Sie mehrere Parameter angeben, dann setzen Sie keine Leerzeichen zwischen die einzelnen Parameter.

Parameter für die Suche nach Quelltext

Parameter | Beschreibung
(kein Parameter gesetzt) | Der zuerst gefundene Quelltext wird genutzt.
v | Der zuerst gefundene Quelltext wird genutzt. Wenn eine jüngere Datei in der weiteren Suchhierarchie gefunden wird, dann wird eine Warnung ausgegeben.
V | Der jüngste Quelltext aus der Hierarchie wird genutzt und wenn nötig in den lokalen Sourcebereich kopiert.
vV | Der jüngste Quelltext aus der Hierarchie wird genutzt und es wird eine Warnung ausgegeben.


$VMAKE_OPTION-Parameter für die Suche nach Objektdateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation $VMAKE_OPTION-Parameter für die Suche nach Objektdateien

Verwendung

Für die Umgebungsvariable $VMAKE_OPTION können Parameter gesetzt werden. Wenn Sie mehrere Parameter angeben, dann setzen Sie keine Leerzeichen zwischen die einzelnen Parameter.

Parameter für die Suche nach Objektdateien

Parameter | Beschreibung
(kein Parameter gesetzt) | Die zuerst gefundene Objektdatei wird genutzt.
w | Die zuerst gefundene Objektdatei wird genutzt. Wenn eine jüngere Objektdatei in der weiteren Suchhierarchie gefunden wird, dann wird eine Warnung ausgegeben.
W | Die jüngste Objektdatei aus der Suchhierarchie wird genutzt.
wW | Die jüngste Objektdatei aus der Suchhierarchie wird genutzt und es wird eine Warnung ausgegeben.


$VMAKE_PATH (SAP-Bibliothek - Entwicklung)

Objektdokumentation $VMAKE_PATH

Definition

Diese Umgebungsvariable legt fest, in welchen Verzeichnissen das Programm VMAKE nach Dateien suchen soll. Trennen Sie die einzelnen Verzeichnisse durch Kommas.

Wenn ein Verzeichnis mit doppelten Schrägstrichen endet, dann wird dieses Verzeichnis nicht nach aktuellen Objektdateien durchsucht.

Beispiel

/home/test/MAXDB_DEV,/maxdbmount/hpux1/src/MAXDB_ORG//


$VMAKE_VERSION (SAP-Bibliothek - Entwicklung)

Objektdokumentation $VMAKE_VERSION

Definition

Diese Umgebungsvariable ist optional. Sie legt den Systemvorschlag für die VMAKE-Version fest und kann folgende Werte haben: fast oder slow.


$WRK (SAP-Bibliothek - Entwicklung)

Objektdokumentation $WRK

Definition

Diese Umgebungsvariable verweist auf das Verzeichnis sys/wrk im Entwicklungsbereich MaxDB_DEV. Sie wird von verschiedenen Beschreibungsdateien genutzt.

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


Suchhierarchie (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Suchhierarchie

Verwendung

Die Suchhierarchie ist die Reihenfolge der Verzeichnisse, in der die Werkzeuge der Entwicklungsumgebung nach Dateien suchen.

Die Werkzeuge suchen Dateien in der folgenden Reihenfolge:

...

1. im Verzeichnis MaxDB_DEV und dessen Unterverzeichnissen

2. im Verzeichnis MaxDB_ORG und dessen Unterverzeichnissen

Um eine andere Suchhierarchie zu konfigurieren, ändern Sie den Wert der Umgebungsvariable $VMAKE_PATH.

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


Verzeichnisstruktur der Entwicklungsumgebung (SAP-Bibliothek - Entwicklung)

Objektdokumentation Verzeichnisstruktur der Entwicklungsumgebung

Definition

Die Entwicklungsumgebung hat eine fest definierte Verzeichnisstruktur.

Verwendung

Im Verzeichnis MaxDB_ORG und seinen Unterverzeichnissen befinden sich die Originalversionen der Beschreibungs- und Moduldateien, die von den Werkzeugen der Entwicklungsumgebung nicht verändert werden.

Im Verzeichnis MaxDB_DEV („Entwicklungsbereich“) ändern Sie Dateien. Alle Dateien, die Sie ändern möchten, müssen Sie zunächst mit dem Skript icp.pl in den Entwicklungsbereich kopieren.

Bei der Installation des Quelltexts werden die beiden Verzeichnisse MaxDB_ORG und MaxDB_DEV angelegt. Wenn Sie VMAKE zum ersten Mal aufrufen, legt VMAKE die entsprechenden Unterverzeichnisse an.

Mit der Umgebungsvariablen $OWN konfigurieren Sie den Pfad und, wenn gewünscht, einen anderen Namen für das Verzeichnis MaxDB_DEV. Wenn Sie Moduldateien und Beschreibungsdateien nicht im Verzeichnis MaxDB_DEV, sondern an einem anderen Ort ablegen, dann passen Sie die Umgebungsvariable $VMAKE_PATH (Suchhierarchie) entsprechend an.

Struktur

MaxDB_DEV hat die Unterverzeichisse sys, tmp und usr.

Das Verzeichnis sys ist der Arbeitsbereich. Es enthält die folgenden Unterverzeichnisse:

● src: Moduldateien, optional auch Beschreibungsdateien

● desc: Beschreibungsdateien

● wrk : Verzeichnis, in dem der MAKE-Vorgang stattfindet. Hier werden auch sämtliche Zwischenprodukte (Objektdateien, Include-Dateien) und Protokolle abgelegt.

○ Für jede VMAKE-Version gibt es ein separates Verzeichnis (fast, slow) mit analoger Struktur. Weil Include-Dateien unabhängig von der VMAKE-Version sind, werden sie direkt unterhalb des Verzeichnisses wrk im Verzeichnis incl abgelegt. Die dazugehörigen Datumsdateien werden entsprechend direkt unterhalb des Verzeichnisses wrk im Verzeichnis dates abgelegt.

○ Im Unterverzeichnis obj werden alle Objektdateien und statischen Bibliotheken, die erzeugt werden, abgelegt. Im Unterverzeichnis dates liegen die Datumsdateien. Die Verzeichnisse psrc und csrc können als Zwischenspeicher für Moduldateien genutzt werden, nachdem die Parameter für $VMAKE_OPTION entsprechend gesetzt wurden. Im Verzeichnis debug werden jene Moduldateien abgelegt, die im Debug-Modus übersetzt wurden (siehe Aktivieren des Debug-Modus).

Das Verzeichnis tmp enthält temporäre Dateien des Perl-Skripts iview.pl zum Anzeigen und Bearbeiten von Quelltextdateien.

Das Verzeichnis usr enthält die MaxDB-Programme, die mit Hilfe der Entwicklungsumgebung erstellt wurden. Dieses Verzeichnis ist das zukünftige $INSTROOT-Verzeichnis der MaxDB-Software (<dependent_path>, siehe Installationshandbuch, Strukturlink Verzeichnisse).

Beispiel

<myDevelopmentDirectory>
MaxDB_DEV
sys
desc
src
ak
vak54
tmp

MaxDB_ORG
sys
desc
src
ContentStorage
Globals
Interfaces
Resource
SAPDB
ak
gak00
...
vak54
...
bd
...


Ändern eines MaxDB-Programms (SAP-Bibliothek - Entwicklung)

Prozessdokumentation Ändern eines MaxDB-Programms

Einsatzmöglichkeiten

Sie ändern den Quelltext eines MaxDB-Programms. Der Quelltext eines MaxDB-Programms besteht aus Moduldateien.

Voraussetzungen

Sie haben die Entwicklungsumgebung initialisiert.

Ablauf

...

1. Sie kopieren die Moduldateien, die Sie ändern möchten, mit dem Perl-Skript icp.pl vom Verzeichnis MaxDB_ORG in den Entwicklungsbereich MaxDB_DEV.

2. Sie ändern die Moduldateien (Quelltext).

3. Sie bereiten den MAKE-Vorgang vor.

Ergebnis

Sie können im nächsten Schritt VMAKE aufrufen und den geänderten Quelltext neu übersetzen (siehe MAKE-Vorgang).

Beispiel

· Beispiel: Übersetzen der Datei HelloWorld.c

· Beispiel: Erstellen des Programms Database Manager CLI


Ändern einer Moduldatei (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Ändern einer Moduldatei

Verwendung

Sie ändern eine Moduldatei.

Voraussetzungen

Sie haben die Datei mit dem Skript icp.pl in den Entwicklungsbereich kopiert.

Vorgehensweise

...

1. Rufen Sie die Datei mit dem Werkzeug iview.pl auf.

Die Datei wird in Ihrem Editor geöffnet.

2. Ändern Sie die Datei in Ihrem Editor.

3. Speichern Sie die Datei.


Moduldatei (SAP-Bibliothek - Entwicklung)

Objektdokumentation Moduldatei

Definition

Der Quelltext eines MaxDB-Programms besteht aus mehreren Moduldateien.

Verwendung

Moduldateien können in beliebigen Programmiersprachen verfasst sein. Für jede von MaxDB verwendete Programmiersprache gibt es spezielle VMAKE-Werkzeuge zum Entpacken und Übersetzen der Moduldateien.

Moduldateien können Include-Dateien enthalten.

Beachten Sie die Namenskonventionen für Moduldateien.


Include-Datei (SAP-Bibliothek - Entwicklung)

Objektdokumentation Include-Datei

Definition

Eine Include-Datei ist eine Moduldatei, die in eine andere Moduldatei eingebunden ist. Include-Dateien sind unabhängig von VMAKE-Versionen.

Verwendung

Beim MAKE-Vorgang muss für jede Include-Datei, die Sie geändert haben, auch die Moduldatei, in die diese Include-Datei eingebunden ist, neu übersetzt werden (siehe Übersetzungsvorgang).


Schicht (Layer) (SAP-Bibliothek - Entwicklung)

Objektdokumentation Schicht (Layer)

Definition

Unterverzeichnisse im Verzeichnis für Moduldateien werden auch als Schichten oder Layer bezeichnet.

Beispiel

Schicht ak:

<myDevelopmentdirectory>\V75_00_15\MaxDB_ORG\sys\src\ak

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


Vorbereiten des MAKE-Vorgangs (SAP-Bibliothek - Entwicklung)

Prozessdokumentation Vorbereiten des MAKE-Vorgangs

Einsatzmöglichkeiten

Nachdem Sie Moduldateien geändert haben, sind vor dem Starten des MAKE-Vorgangs noch einige Vorbereitungen notwendig.

Ablauf

...

1. Erstellen oder Ändern der zugehörigen Beschreibungsdateien

2. Anpassen der Initialisierungsdateien

3. Angeben nicht zu übersetzender Dateien


Erstellen/Ändern von Beschreibungsdateien (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Erstellen/Ändern von Beschreibungsdateien

Verwendung

Falls notwendig, erstellen oder ändern Sie die Beschreibungsdateien. In den Beschreibungsdateien sind die Informationen enthalten, wie und mit welchen Moduldateien das MaxDB-Programm (Ziel) erstellt wird.

Wenn Sie beispielsweise eine neue Moduldatei mit zusätzlichen Funktionen für ein MaxDB-Programm erstellt haben, dann müssen Sie diese Moduldatei in die Linkbeschreibung des MaxDB-Programms eintragen und die Abhängigkeiten für diese Moduldatei in der entsprechenden Kompilierbeschreibung ergänzen.

Voraussetzungen

· Sie haben die Entwicklungsumgebung initialisiert.

· Sie haben Moduldateien geändert.

Vorgehensweise

...

1. Kopieren Sie die benötigten Beschreibungsdateien in den Entwicklungsbereich.

2. Verwenden Sie das Skript iview.pl, um die Beschreibungsdateien zu ändern.

Halten Sie sich dabei an die allgemeine Grammatik für Beschreibungsdateien.

Beispiel

Erstellen des DBMCLI


Beschreibungsdatei (SAP-Bibliothek - Entwicklung)

Objektdokumentation Beschreibungsdatei

Definition

Eine Beschreibungsdatei legt fest, wie und mit welchen Moduldateien ein MaxDB-Programm (Ziel) erstellt wird.

Es gibt folgende Arten von Beschreibungsdateien:

· Linkbeschreibungen

· Kompilierbeschreibungen

· Abarbeitungslisten

Beachten Sie die Namenskonventionen für Beschreibungsdateien.


Linkbeschreibung (SAP-Bibliothek - Entwicklung)

Objektdokumentation Linkbeschreibung

Definition

Eine Linkbeschreibung legt fest, auf welche Art und Weise die Moduldateien zu einem MaxDB-Programm (Ziel) gelinkt werden.

Verwendung

Eine Linkbeschreibung listet die Verweise auf Moduldateien und weitere Beschreibungsdateien auf, die von VMAKE seriell abgearbeitet werden sollen. Sie können Optionen angeben, die beim Linkvorgang verwendet werden.

Die Dateiendung der Linkbeschreibung legt fest, welche Softwarekomponente erstellt wird.

Namenskonventionen für Dateiendungen von Linkbeschreibungen

Dateiendung | Ziel
lnk | Programm
shm | Programm, das einen Shared-Memory-Zugriff ermöglicht
lib | statische Bibliothek
dld | dynamische Bibliothek
rel | Programm, das mit anderen Programmen gelinkt werden kann (relocatable)
shr | Programm, das mit anderen Programmen gelinkt werden kann (relocatable) und einen Shared-Memory-Zugriff ermöglicht


Kompilierbeschreibung (SAP-Bibliothek - Entwicklung)

Objektdokumentation Kompilierbeschreibung

Definition

Eine Kompilierbeschreibung legt fest, wie VMAKE die Moduldateien übersetzt.

Verwendung

Eine Kompilierbeschreibung listet die Moduldateien mit ihren Abhängigkeiten und übersetzungsspezifische Optionen auf.

Es kann folgende Abhängigkeiten zwischen Moduldateien geben:

· Include-Abhängigkeiten (Include-Datei)

· Abhängigkeiten, wonach bestimmte Hilfsdateien beim Übersetzungsvorgang im gleichen Verzeichnis stehen müssen wie die zu übersetzende Moduldatei (demand=<list>)

· Logische Abhängigkeiten, wenn beispielsweise die Moduldatei X eine Datei Z linkt, die als Nebenprodukt der Übersetzung von Moduldatei Y entsteht (extdep=<list>)

Kompilierbeschreibungen werden nicht für jede einzelne Moduldatei, sondern immer für Gruppen von Moduldateien erstellt. Der Name der Kompilierbeschreibung entspricht dem Namen der Gruppe. Kompilierbeschreibungen haben die Dateiendung .com

Wenn im Verzeichnis der Moduldateien (src) eine Schicht ak existiert, dann muss im Verzeichnis der Beschreibungsdateien (desc) eine Kompilierbeschreibung ak.com vorhanden sein.

Wenn eine Schicht unter dem Verzeichnis der Moduldateien (src) noch weitere Unterschichten aufweist, dann muss die Hierarchie bis auf die vorletzte Ebene im Verzeichnis der Beschreibungsdateien (desc) nachgebildet sein. Der Name einer solchen Kompilierbeschreibung ergibt sich aus der letzten Unterschicht und der Dateiendung .com

Für Moduldateien in der Schicht SAPDB/DBM/Cli hat die zugehörige Kompilierbeschreibung den Namen Cli.com und befindet sich im Verzeichnis der Beschreibungsdateien (desc) unter SAPDB/DBM.

Die Abarbeitungspunkte einer Kompilierbeschreibung werden gezielt angesprungen und nicht seriell abgearbeitet.

Variante

Sie können Kompilierbeschreibungen auch direkt im zugehörigen Verzeichnis der Moduldateien (src) mit dem gleichen Namen und der Dateiendung .com anlegen.

Für Moduldateien in der Schicht SAPDB/DBM/Cli heißt die zugehörige Kompilierbeschreibung Cli.com. Sie befindet sich im Verzeichnis src/SAPDB/DBM/Cli

VMAKE sucht Kompilierbeschreibungen immer zuerst im Verzeichnis der Beschreibungsdateien (desc).

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


Abarbeitungsliste (SAP-Bibliothek - Entwicklung)

Objektdokumentation Abarbeitungsliste

Definition

Eine Abarbeitungsliste listet die abzuarbeitenden Beschreibungsdateien, die zu behandelnden Moduldateien und die auszuführenden Betriebssystemkommandos auf. Sie kann außerdem weitere Abarbeitungslisten und Optionen enthalten.

Abarbeitungslisten haben die Dateiendung .mac.

Verwendung

VMAKE arbeitet die Einträge in einer Abarbeitungsliste von oben nach unten ab.

Dabei prüft es zunächst alle aufgeführten Dateien und die in diesen Dateien als Links enthaltenen Dateien bis in die unterste Ebene daraufhin, ob es im Vergleich zu einem früher erzeugten Ziel Änderungen gab. Wenn es Änderungen gab, dann erstellt VMAKE die Ziele neu.


Allgemeine Grammatik für Beschreibungsdateien (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Allgemeine Grammatik für Beschreibungsdateien

Eine ausführliche Beschreibung finden Sie in Grammatik für Linkbeschreibungen, Grammatik für Kompilierbeschreibungen und Grammatik für Abarbeitungslisten.

Syntax

<debug_opt> = debug | d

<digit> = 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9

<letter> = A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | r | u | v | w | x | y | z

<new_line> = expliziter Zeilenumbruch

<profile_opt> = profile | p

<sign> = + | -

<tabulator> =Tabulator

<vmake_default> = f | q | s

<vmake_version> = f | q | s

<extended_letter> = alle weiteren druckbaren Zeichen

<character> = <digit> | <letter> | <extended_ letter>

<identifier> = <token>

<space> = [<space>] | [<space>]<tabulator>

<token_sep> = {<token_sep>}<space>

<token> = <character>{<character>}

<list> = [<list>,],{<character>}<token_sep>

<ext_list> = [<ext_list>,],[<sign>]{<character>}<token_sep>

<comment> = [<comment><token_sep>]<token>

<compile_option> = <extended_letter><token>

<demand_spec> = demand[{<layer>{<layer>}}]

<dep_list> = (obj | inc | dep | <demand spec>)=(<list> | <ext_list> | EMPTY)

<expr> = <character>{<character>} | (<expr>) | not<space><expr> | ![<space>]<expr> | <expr><space>[(not | !)<space> ]in<space>[[<space>]<expr>{[<space>] ,[<space>]<expr>}[<space>]] | <expr>=[=]<expr> | <expr>!=<expr> | <expr>&&<expr> | <expr>||<expr>

<layer> = <letter><letter>{<letter>}

<mf_option> = <token>[=<value>]

<option> = [<option><token_sep>](<dep_list> | <mf_option> | <compile_option> | <target_option>)

<option_block> = ([f | [q | [s) <option> {<option>} (f] | q] | s])

<ext_option> = <option_block> | <option> | EMPTY

<target_option> = uncond | remake | <debug opt> | binary | ascii | exec | definition | interface | <profile opt> | shrglob | noshrglob | noobjcopy | (<vmake_version>[<vmake_default>]) | -><token> | <ext_target_option> | <ext_target_option_list> | nobind | noversion | nocomfile

<ext_target_option> = ?<token_sep>(default_layer | default_version | require | -><token> | propagate | parentlinkoption)<token_sep>(: | ([<character>]))<token_sep><token>

<ext_target_option_list> = ?<token_sep>(output | link_with | link_option | tool_option)<token_sep>(: | ([<character>]))<token_sep><token>{<token_sep>,<token_sep><token>}

<ext_target_option_line> = (<ext_target_option> | <ext_target_option_list>) <new_line>

<value> = <character>{<character>}

<def line> = &define | &undef <identifier> [<value>]<new_line>

<comment_line> = #<comment><new_line>

<block> = <instance_block> | <sub_block>

<instance_block> = (<instance_block_start>{<sub_block>}<instance_block_end>) | EMPTY

<instance_block_start> = (&fast | &slow) <comment><new_line>

<instance_block_end> = (&endfast | &endslow) <comment><new_line>

<sub_block> = {<line>} | <sub_block_start>{<line>}<sub_block_end>

<sub_block_start> = &if <expr>{<space>}<new_line> | &ifdef | &ifndef | &ifvar | &ifnvar) <identifier>{<space>}<new_line>

<sub_block_end> = &endif <comment><new_line> | &else <comment><new_line> | &elif <comment><new_line>

<line> = Zeile

Allgemeine Regeln

· <token> darf maximal 512 Zeichen enthalten

· <token> darf kein <space> enthalten

· Wenn <instance_block_start> die Zeichenfolge &xxx beinhaltet, dann muss <instance_block_stop> die Zeichenfolge &endxxx enthalten.

· Wenn der Ausdruck <option_block> mit [x startet, dann muss er mit x] enden.

· In <mf_option>muss <token> mit <letter> oder <character> beginnen.


Grammatik für Linkbeschreibungen (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Grammatik für Linkbeschreibungen

Grundlage für Linkbeschreibungen sind die allgemeine Grammatik für Beschreibungsdateien, die Namenskonventionen für Moduldateien und die Namenskonventionen für Beschreibungsdateien.

Syntax

<link_description> = {<block>} | EMPTY

<line> = <link_desc_line>

<link_desc_line> = <comment_line> | <link_line> | <def_line> | <ext_target_option_line> | <tool_option_line> | <file> | EMPTY

<tool_option_line> = <extended_letter><token><new_line>

<file> = (/ | $)<token>

<link_line> = [<source_spec>|<desc_spec>]<new_line>

Allgemeine Regel

In <tool_option_line> darf <ext_character> nicht mit / | $ | ! beginnen.


Grammatik für Kompilierbeschreibungen (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Grammatik für Kompilierbeschreibungen

Grundlage für Kompilierbeschreibungen sind die allgemeine Grammatik für Beschreibungsdateien und die Namenskonventionen für Moduldateien.

<compile_description> = {<block>} | EMPTY

<line> = <comp_desc_line>

<comp_desc_line> = <comment_line> | <comp_line> | <def_line> | <option_line> | EMPTY

<comp_line> = (<source_spec> | <reg_source>)<token_sep>{<option>}<new_line>

<reg_source> = regex(<regex>) | ([<source_id>]*[<lang_id>][<variant>])

<source_id> = g | h | i | v

<regex> = regulärer Ausdruck (nach GNU-Standard)


Grammatik für Abarbeitungslisten (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Grammatik für Abarbeitungslisten

Grundlage für Abarbeitungslisten sind die allgemeine Grammatik für Beschreibungsdateien, die Namenskonventionen für Moduldateien und die Namenskonventionen für Beschreibungsdateien.

Syntax

<macro_description> = {<block>} | EMPTY

<line> = <macro_desc_line>

<macro_desc_line> = <comment_line> | <macro_line> | <def_line> | <ext_target_option_line>

| <command_line> | EMPTY

<command_line> = ![! | ?]<command>

<command> = {<character>}

<macro_line> = [<source_spec>|<desc_spec>]<new_line>

Allgemeine Regel

In <tool_option_line> darf <ext_character> nicht mit / | $ | ! beginnen.


Optionen für Beschreibungsdateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Optionen für Beschreibungsdateien

Verwendung

Um den Übersetzungsvorgang und Linkvorgang zu spezifizieren und den Systemvorschlag von VMAKE für bestimmte Prozesse zu übersteuern, können Sie in Beschreibungsdateien Optionen angeben.

Einige Optionen stehen für alle Arten von Beschreibungsdateien zur Verfügung, andere können nur in bestimmten Beschreibungsdateien verwendet werden.

Siehe

· Optionen für Linkbeschreibungen

· Optionen für Kompilierbeschreibungen

· Optionen für Abarbeitungslisten


Optionen für Linkbeschreibungen (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Optionen für Linkbeschreibungen

Verwendung

Für Linkbeschreibungen stehen Ihnen folgende Optionen zur Verfügung:

? defaultlayer : <layer>

? defaultlayer :

? defaultversion : <vmake_version>

? defaultversion :

? distribute : <list>

? error: <error_message>

? link with : <list>

? linkoption : <list>

? output : <list>

? parentlinkoption : <link_option>

? propagate : <variable>[=<value>]

? require : <target>

? tooloption : <list>

-><output>

ascii

binary

debug|d

definition

demand

demand{<relative_path>}

demand=<list>

demand{<relative_path>}=<list>

dep=<list>

distrib

extdep=<list>

inc=<list>

interface

nobind

nocomfile

nodistrib

noobjcopy

noshrglob

obj=<list>

output=<list>

profile|p

remake

shrglob

uncond


Optionen für Kompilierbeschreibungen (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Optionen für Kompilierbeschreibungen

Verwendung

Für Kompilierbeschreibungen stehen Ihnen folgende Optionen zur Verfügung:

? defaultlayer : <layer>

? defaultlayer :

ascii

binary

debug|d

definition

demand=<list>

demand{<relative_path>}=<list>

dep=<list>

exec

extdep=<list>

inc=<list>

interface

noobjcopy

noshrglob

noversion

obj=<list>

output=<list>

parentlinkoption=<link_option>

profile|p

remake

shrglob

uncond


Optionen für Abarbeitungslisten (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Optionen für Abarbeitungslisten

Verwendung

Für Abarbeitungslisten stehen Ihnen folgende Optionen zur Verfügung:

!! <command>

!? <command>

! <command>

? defaultlayer : <layer>

? defaultlayer :

? defaultversion : <vmake_version>

? defaultversion :

? distribute : <list>

? error: <error_message>

? propagate : <variable>[=<value>]

? require : <target>

ascii

binary

debug|d

distrib

nocomfile

nodistrib

remake

shrglob

uncond


! <command> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ! <command>

Diese Option kann nur in Abarbeitungslisten verwendet werden.

VMAKE arbeitet eine Abarbeitungsliste von oben nach unten ab. Wenn VMAKE den Eintrag dieser Option erreicht und bis dahin bereits Ziele durch VMAKE aktualisiert wurden, dann wird das Betriebssystemkommando <command> ausgeführt.

Wenn bis dahin keine Ziele aktualisiert wurden, dann wird das Kommando ignoriert.


!! <command> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation !! <command>

Diese Option kann nur in Abarbeitungslisten verwendet werden.

VMAKE arbeitet eine Abarbeitungsliste von oben nach unten ab. Wenn VMAKE den Eintrag dieser Option erreicht, dann wird das Betriebssystemkommando <command> ausgeführt.

Im Gegensatz zur Option ! <command> erfolgt dies unabhängig davon, ob bis dahin bereits Ziele aktualisiert wurden.


!? <command> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation !? <command>

Diese Option kann nur in Abarbeitungslisten verwendet werden.

VMAKE arbeitet eine Abarbeitungsliste von oben nach unten ab. Wenn alle vorherigen Ziele erfolgreich aktualisiert wurden, dann wird das Betriebssystemkommando <command> ausgeführt, sobald VMAKE diese Option erreicht.


? defaultlayer : <layer> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? defaultlayer : <layer>

Diese Option kann in Abarbeitungslisten, Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Wenn der Name einer Moduldatei nicht den Namenskonventionen entspricht und aus diesem Grund die entsprechende Schicht vom System nicht ermittelt werden kann, dann wird auf die in <layer> spezifizierte Schicht zurückgegriffen.

Diese Option kann sich innerhalb einer Beschreibungsdatei mehrfach wiederholen.


? defaultlayer : (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? defaultlayer :

Diese Option kann in Abarbeitungslisten, Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Wenn der Name einer Moduldatei nicht den Namenskonventionen entspricht und aus diesem Grund die entsprechende Schicht vom System nicht ermittelt werden kann, dann wird auf die Schicht zurückgegriffen, die mit Hilfe der Option ? defaultlayer : <layer> spezifiziert wurde.

Um diesen Vorschlagswert für eine Schicht zu löschen, verwenden Sie die Option ? defaultlayer :


? defaultversion : <vmake_version> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? defaultversion : <vmake_version>

Diese Option kann in Abarbeitungslisten und Linkbeschreibungen verwendet werden.

Sie legen damit fest, welche VMAKE-Version für die Abarbeitung der nachfolgend aufgeführten Dateien genutzt werden soll.

Um später eine andere Version zu spezifizieren, verwenden Sie wiederum die Option ? defaultversion : <vmake_version>. Damit kann sich diese Option also mehrfach in einer Beschreibungsdatei wiederholen.

Um VMAKE auf die beim Aufruf spezifizierte VMAKE-Version zurückzusetzen, verwenden Sie die Option ? defaultversion :


? defaultversion : (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? defaultversion :

Diese Option kann in Abarbeitungslisten und Linkbeschreibungen verwendet werden.

Sie verwenden diese Option, um eine mittels ? defaultversion : <vmake_version>VMAKE-Version zu löschen.

Danach wird vom System wieder die VMAKE-Version verwendet, die beim Aufruf von VMAKE angegeben wurde.


? distribute : <list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? distribute : <list>

Diese Option kann in Abarbeitungslisten und Linkbeschreibungen verwendet werden.

Sie können diese Option beim Erstellen von Auslieferungslisten (Option -F für den Aufruf von VMAKE) verwenden. Geben Sie in <list> die Liste der Dateien an, die mit in die Auslieferungsliste aufgenommen werden soll.

Geben Sie die Pfade der Dateien in <list> relativ zum $INSTROOT-Verzeichnis an (z. B. pgm/kernel) .

Wir empfehlen, die Option distrib zu verwenden.


? error : <error_message> (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation ? error : <error_message>

Diese Option kann nur in Linkbeschreibungen und Abarbeitungslisten verwendet werden.

Es wird ein Fehler ausgegeben und der MAKE-Vorgang wird beendet.


? link with : <list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? link with : <list>

Diese Option kann nur in Linkbeschreibungen verwendet werden.

Wenn ein Ziel zusätzliche Bibliotheken benötigt, können diese mit der Option ? link with : <list> in die Linkbeschreibung aufgenommen werden.


? linkoption : <list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? linkoption : <list>

Diese Option kann nur in Linkbeschreibungen verwendet werden.

Verwenden Sie diese Option, um die in <list> angegebene Liste von Optionen an das Werkzeug zu übergeben, das für den Linkvorgang genutzt wird.


? output : <list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? output : <list>

Diese Option kann nur in Linkbeschreibungen verwendet werden.

Ziele von Linkbeschreibungen erhalten den Namen der Linkbeschreibung und werden unter einem von VMAKE vorgegebenen Pfad abgelegt.

Mit der Option ? output : <list> können Sie den Namen und/oder Pfad für mehrere Ausgabedateien ändern oder auch Kopien von Dateien anlegen. Sie erstellen dazu eine Liste <list>, in der Sie einem oder mehreren Zielen mehrere Pfadangaben zuordnen. Damit ändert VMAKE die vom System vorgegebene Namens- und Pfaddefinition für dieses Ziel.

Wenn Sie in einer solchen Liste ein Verzeichnis angegeben oder einen Eintrag mit einem Schrägstrich beenden, dann behält die Datei den vom System vergebenen Namen und wird in das angegebene Verzeichnis kopiert.

Um den Namen und/oder Pfad für eine einzelne Ausgabedatei zu ändern, verwenden Sie die Option -><output>.

Eine Ausgabedatei kann auf verschiedenen Plattformen unterschiedliche Dateiendungen haben. In einem solchen Fall geben Sie für das Ziel die Dateiendung * an. Sie vermeiden damit, für dieses Ziel einzelne plattformbezogene Ausgabedateien definieren zu müssen.

Dynamische Bibliotheken haben unter Microsoft Windows die Dateiendung dll und unter UNIX die Dateiendung so oder sl (HP-UX).

Angeben der Liste libtest.* mit Pfadangaben für Ziele:

? output : $DBROOT/misc/libtest.*


? parentlinkoption : <link_option> (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation ? parentlinkoption : <link_option>

Sie können diese Option in Linkbeschreibungen verwenden. Sie definieren damit eine Linkoption für alle Linkbeschreibungen, die diese Linkbeschreibung einbinden.

Die angegebene Linkoption wird auch an alle weiteren (übergeordneten) Linkbeschreibungen weitergegeben.


? propagate : <variable>[=<value>] (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? propagate : <variable>[=<value>]

Sie verwenden diese Option in Abarbeitungslisten und Linkbeschreibungen, um eine Umgebungsvariable zu setzen.

Nach Abarbeitung der betreffenden Liste oder Linkbeschreibung wird diese Variable vom System wieder gelöscht.


? require : <target> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? require : <target>

Diese Option kann in Abarbeitungslisten und Linkbeschreibungen verwendet werden. Sie wirkt nur in Verbindung mit der Option -R für den Aufruf von VMAKE.

Sie spezifizieren mit dieser Option, ob eine Linkbeschreibung die Erstellung bestimmter Ziele zur Voraussetzung hat.


? tooloption : <list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ? tooloption : <list>

Diese Option kann nur in Linkbeschreibungen verwendet werden.

Die in der Liste <list> aufgeführten Optionen werden an das Werkzeug weitergereicht, das für den Linkvorgang zuständig ist.


-><output> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation -><output>

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Ziele von Linkbeschreibungen erhalten den Namen der Linkbeschreibung und werden unter einem von VMAKE vorgegebenen Pfad abgelegt.

Mit der Option -><output> ändern Sie den Namen und/oder Pfad für eine einzelne Ausgabedatei.

Wenn Sie den Namen und/oder Pfad für mehrere Ausgabedateien ändern oder Kopien von Dateien anlegen möchten, dann verwenden Sie die Option ? output: <list> (in Linkbeschreibungen) oder die Option output=<list> (in Kompilierbeschreibungen).


ascii (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation ascii

Diese Option kann in Abarbeitungslisten, Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Wenn diese Option angegeben ist, dann wird die Moduldatei nicht übersetzt und VMAKE erstellt das entsprechende Ziel, indem die Moduldatei nur in das Objektverzeichnis kopiert wird. Anders als bei der Option binary wird die Datei dabei als Textdatei behandelt.

Um die Datei an einem anderen Ort abzulegen, verwenden Sie die Option -><output>.


binary (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation binary

Diese Option kann in Abarbeitungslisten, Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Wenn diese Option angegeben ist, dann wird die Moduldatei nicht ausgepackt und übersetzt. VMAKE erstellt das entsprechende Ziel, indem die Moduldatei nur in das Objektverzeichnis kopiert wird. Anders als bei der Option ascii wird die Datei dabei als Binärdatei behandelt.

Um die Datei an einem anderen Ort abzulegen, verwenden Sie die Option ->output.


debug|d (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation debug|d

Diese Option kann in Abarbeitungslisten, Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Die Option bewirkt, dass eine Moduldatei im Debug-Modus übersetzt wird. Sie geben die Option debug oder d hinter der Moduldatei an.

Beispiel

vak10 debug

ven70.c d

Siehe auch:

Aktivieren des Debug-Modus


definition (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation definition

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Sie kennzeichnet eine Moduldatei als Definitionsdatei für dynamische Bibliotheken unter Microsoft Windows. Semantisch entspricht diese Option der Kombination aus den Optionen binary und demand.

Wenn eine Moduldatei mit dieser Option versehen wird, dann wird sie vor dem Linkvorgang binär in das aktuelle Arbeitsverzeichnis tmp kopiert


demand (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation demand

Diese Option kann nur in Linkbeschreibungen verwendet werden.

Eine Objektdatei wird vor dem Linkvorgang in das Verzeichnis tmp kopiert.

Wenn Sie eine Moduldatei mit dieser Option versehen, dann wird die daraus resultierende Objektdatei für den Linkvorgang angefordert, d. h. sie wird in das entsprechende von VMAKE vorgegebene Arbeitsverzeichnis kopiert.


demand{<relative path>} (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation demand{<relative path>}

Diese Option kann nur in Linkbeschreibungen verwendet werden.

Es wird die Objektdatei der so gekennzeichnete Moduldatei zum Linkvorgang in einen bestimmten Pfad angefordert, d. h. sie wird in den angegeben relativen Pfad zum Arbeitsverzeichnis kopiert.


demand=<list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation demand=<list>

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Es werden die Objekt-Dateien der in der Liste <list> aufgeführten Dateien zum Übersetzungszeitpunkt angefordert, d. h. sie werden ins entsprechende Arbeitsverzeichnis kopiert.


demand{<relative path>}=<list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation demand{<relative path>}=<list>

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Es werden die Objekt-Dateien der in der Liste <list> aufgeführten Dateien zum Übersetzungszeitpunkt in einen bestimmten Pfad angefordert, d. h. sie werden in den relativen Pfad zum Arbeitsverzeichnis kopiert.


dep=<list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation dep=<list>

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Die Liste <list> enthält die Moduldateien, von der die angegebene Moduldatei abhängig ist.

Beispiel

vco01.idl dep=vco03.idl


distrib (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation distrib

Diese Option kann in Abarbeitungslisten und Linkbeschreibungen verwendet werden.

Sie wird zum Erstellen von Auslieferungslisten (Option -F für den Aufruf von VMAKE) benötigt. Die aus dem unmittelbar vor dieser Option aufgeführten Ziel resultierenden Dateien werden in die Auslieferungsliste aufgenommen, wenn sie sich im $INSTROOT-Verzeichnis befinden.


exec (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation exec

Diese Option kann nur in Kompilierbeschreibungen verwendet werden. Sie wird nur unter UNIX und im Zusammenhang mit den Optionen ascii oder binary ausgewertet.

Wenn Sie diese Option angeben, dann wird das entsprechende Ziel mit dem Zugriffsrecht execute versehen.


extdep=<list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation extdep=<list>

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Mit dieser Option definieren Sie eine logische Abhängigkeit zwischen Zielen und/oder Dateien.

Beispiel

Bei der Übersetzung der Moduldatei X entsteht ein Nebenprodukt Y. Mit der Option können Sie spezifizieren, dass X neu übersetzt werden soll, sobald Y nicht mehr existiert oder veraltet ist und damit neu erstellt werden muss.

vco01.idl extdep=$WRK/incl/livecache.h


inc=<list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation inc=<list>

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden. Sie können mit dieser Option die Include-Dateien auflisten, die von der Moduldatei genutzt werden sollen.

Die in <list> aufgeführten Dateien müssen als Include-Dateien identifizierbar sein. Wenn eine solche Datei nicht durch ihre Dateiendung .h oder 00 bzw. durch ein h als ersten Buchstaben des Dateinamens als Include-Datei identifizierbar ist, dann können Sie die Datei durch ein nachgestelltes (i) als Include-Datei kennzeichnen.

inc=vma18(i)


interface (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation interface

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Durch die Angabe dieser Option stellen Sie sicher, dass eine Moduldatei nach der erstmaligen Übersetzung nicht mehr aktualisiert werden kann (z. B. eine definierte Schnittstelle). Dazu wird auf dem Rechner, auf dem eine mit dieser Option versehene Moduldatei übersetzt wird, eine Datei dieses Namens mit der Dateiendung .i erzeugt.

Eine Übersetzung der Moduldatei ist erst dann wieder möglich, wenn VMAKE in der Pfadhierarchie (VMAKE_PATH) keine Datei dieses Namens mit der Dateiendung .i mehr findet.


nobind (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation nobind

Diese Option kann nur in Linkbeschreibungen verwendet werden.

Das mit dieser Option versehene Ziel wird zwar erstellt, aber beim Linkvorgang nicht gelinkt.


nocomfile (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation nocomfile

Diese Option kann in Linkbeschreibungen und Abarbeitungslisten verwendet werden.

Zum Modul, hinter dem diese Option angegeben wird, wertet VMAKE keine Kompilierbeschreibung aus.

Alle Optionen, die sonst in der Kompilierbeschreibung aufgeführt sind, müssen für dieses Modul in der Auflistung der Linkbeschreibung oder in der Abarbeitungsliste einzeln definiert werden.


nodistrib (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation nodistrib

Diese Option kann in Abarbeitungslisten und Linkbeschreibungen verwendet werden.

Die Option wird hinter dem Ziel nodistrib bzw. direkt hinter der Ausgabedatei in Klammern (nodistrib) angegeben. So können einzelne Komponenten oder Dateien, die im Normalfall beim MAKE-Vorgang erstellt werden, von der Auslieferungsliste ausgeschlossen werden.


noobjcopy (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation noobjcopy

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Objektdateien, die aus mit dieser Option versehenen Moduldateien entstehen, werden nicht kopiert. Sie verwenden diese Option beispielsweise, wenn das Objekt rechnerspezifische oder abteilungsweit eindeutige Informationen enthält.


noshrglob (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation noshrglob

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Durch die Angabe dieser Option unterdrücken Sie explizit die Berechnung der Größenangaben für globale Variablen im Quelltext. Diese Größenangaben sind für die Nutzung des Shared Memory erforderlich.


noversion (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation noversion

Diese Option kann in Kompilierbeschreibungen verwendet werden.

Wenn Module, die von Headerdateien verwendet werden, unabhängig von der VMAKE-Version erstellt werden sollen, dann müssen Sie die Option noversion für dieses Modul angeben. Die Objektdateien und die Datumsdateien werden dann direkt unterhalb des $WRK-Verzeichnisses in das obj- bzw. date-Verzeichnis kopiert. Damit werden diese Dateien für alle Kernvarianten (Versionen) (fast, slow) nur einmal erstellt.


obj=<list> (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation obj=<list>

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Im Normalfall wird beim Übersetzungsvorgang genau eine Objektdatei erzeugt, die den Namen der Moduldatei und die Dateiendung .o erhält. Verwenden Sie die Option obj=<list> dann, wenn andere Objektdateien entstehen als im Normalfall. Wenn gar keine Objektdatei entsteht, dann kann <list> leer sein.


output=<list> (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation output=<list>

Diese Option kann in Kompilierbeschreibungen verwendet werden.

Mit dieser Option wird die Ausgabedatei an denjenigen Stellen gespeichert, die in der Liste <list> angegeben sind.


parentlinkoption=<link_option> (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation parentlinkoption=<link_option>

Sie verwenden diese Option in Kompilierbeschreibungen, um eine Linkoption für alle Linkbeschreibungen zu definieren, die dieses Modul einbinden.

Die angegebene Linkoption wird auch in Linkbeschreibungen weitergegeben, die Linkbeschreibungen enthalten, die das betreffende Modul (mit der Linkoption) einbinden.


profile|p (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation profile|p

Diese Option kann in Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Sie können mit dieser Option Quelltext zur Performance-Messung (Profiling) in eine Moduldatei einfügen.

Beispiel

vak10 profile

ven70.c p


remake (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation remake

Diese Option kann in Abarbeitungslisten, Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Wenn Objektdateien nicht mehr aktuell sind und das Ziel neu erstellt werden soll, dann erzwingen Sie mit dieser Option, dass die entsprechenden Moduldateien neu übersetzt werden.


shrglob (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation shrglob

Diese Option kann in Abarbeitungslisten, Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Mit dieser Option legen Sie fest, dass eine Datei mit Größenangaben zu den Variablen erstellt wird, die im Quelltext global verwendet werden. Diese Größenangaben sind für die Nutzung des Shared Memory erforderlich.


uncond (SAP-Bibliothek - Entwicklung)

Syntaxdokumentation uncond

Diese Option kann in Abarbeitungslisten, Linkbeschreibungen und Kompilierbeschreibungen verwendet werden.

Sie verwenden diese Option, wenn eine Moduldatei bei jedem MAKE-Vorgang neu übersetzt werden soll.


Anpassen des Initialisierungsdateien (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Anpassen des Initialisierungsdateien

Verwendung

Die Initialisierungsdateien bestimmen, wie das Programm VMAKE initialisiert wird.

Initialisierungsdateien von VMAKE

Name | Verwendung
Langextinfo | Zuordnung der Moduldateien zu den Übersetzungswerkzeugen; die Zuordnung erfolgt anhand der Dateiendung oder des letzten Zeichens des Dateinamens
Langinfo | Zuordnung von Programmiersprachen zu bestimmten Werkzeugen zum Entpacken und Übersetzen von Moduldateien
Extra | Zuordnung nicht zu übersetzender Dateien zu ihren Speicherorten
Globals.com | Globale Kompilierbeschreibung für alle Beschreibungsdateien
DirectoryMapping | Zuordnung von Moduldateien zu einer Schicht; die Zuordnung erfolgt anhand des ersten Teils des Dateinamens

Die Initialisierungsdateien sind im Verzeichnis desc abgelegt (siehe Verzeichnisstruktur der Entwicklungsumgebung).

Vorgehensweise

Ändern Sie die Initialisierungsdateien mit dem Skript iview.pl.


Langextinfo (SAP-Bibliothek - Entwicklung)

Objektdokumentation Langextinfo

Definition

Langextinfo ist eine Initialisierungsdatei von VMAKE. Sie ordnet Dateiendungen einer Programmiersprache zu. Jede Programmiersprache wird durch einen Buchstaben repräsentiert (siehe unten).

Verwendung

Wenn VMAKE eine Datei Langextinfo findet, dann übersteuern die darin enthaltenen Informationen den Systemvorschlag von VMAKE für die Zuordnung von Programmiersprachen.

Um den Systemvorschlag zu übersteuern, legen Sie eine Datei mit dem Namen Langextinfo im Verzeichnis desc an.

Syntax

<langextinfo_line> = <comment_line> | (<lang_id><lang_descr><token_sep><token>{<token_sep>,<token_sep><token>}<new_line>)

Verwenden Sie als Kommentarzeichen das Zeichen #

Parameter

Name | Beschreibung
<lang_id> | Buchstabe, der die Sprache identifiziert
<lang_descr> | Beschreibung der Sprache; darf nicht <token_sep> enthalten
<token> | Dateiendung

Wenn Sie Zuordnungen zwischen neuen Buchstaben, Programmen und Dateiendungen vornehmen, dann müssen Sie auch die Datei Langinfo entsprechend pflegen.

Systemvorschlag

zugeordneter Buchstabe (Programm) | Dateiendung/en
x(C++) | cpp, hpp
c(C) | c, h
t(PASCAL) | t
a(Assembler) | s
r(Resources) | rc, ico, def, mc, dlg, idl, ycc, lex, rgs

Beispiel

w(WinResources) rc


Langinfo (SAP-Bibliothek - Entwicklung)

Objektdokumentation Langinfo

Definition

Langinfo ist eine Initialisierungsdatei von VMAKE. In dieser Datei ordnen Sie den einzelnen Programmiersprachen die Werkzeuge zu, die beim Entpacken und Übersetzen von Moduldateien verwendet werden sollen.

Verwendung

Wenn VMAKE eine Datei Langinfo findet, dann übersteuern die darin enthaltenen Informationen den Systemvorschlag von VMAKE. Um die vorhandenen Zuordnungen zu ändern oder zu erweitern, legen Sie eine Datei mit dem Namen Langinfo im Verzeichnis desc an. Alle weiteren Änderungen nehmen Sie in dieser Datei vor.

Jede Programmiersprache wird in der Datei Langinfo durch einen Buchstaben spezifiziert. Dieser Buchstabe wird in der Datei Langextinfo festgelegt.

Syntax

<langinfo_line> = <comment_line> | (<lang_id><token_sep><unpack_inc_tool><token_sep><unpack exp tool><tokensep><unpack mod tool><tokensep><extension><tokensep><option prefix><tokensep>
<compiler tool>)

<unpack inc tool> = <token>

<unpack exp tool> = <token>

<unpack mod tool> = <token>

<extension> = .<token>

<option prefix> = <ext character><letter>

<compiler tool> = <token>

Verwenden Sie als Kommentarzeichen das Zeichen #

Systemvorschlag

last char | unpack include | unpack exports | unpack module | extension | option prefix | compiler | comment
t | mfpinc | mfpexp | mfp | .p | %T | comppc | # PASCAL
p | mfpinc | mfpexp | mfp | .p | %P | compp | # PASCAL
c | mfcinc | mfcexp | mfc | .c | %C | compc | # C
x | mfcinc | mfcexp | mfc | .cpp | %X | compc | # C++
a | mfainc | mfaexp | mfa | .s | %A | compa | # Assembler
r | mfcinc | mfcexp | mfrc | .rc | %R | comprc | # Resources

Die Skripte zum Entpacken einer Moduldatei verwenden den Tabelleneintrag unter extension als Dateiendung.

Beispiel

w mfcinc mfcexp mfrc .rc .res %W comprc2res


Extra (SAP-Bibliothek - Entwicklung)

Objektdokumentation Extra

Definition

Extra ist eine Initialisierungsdatei von VMAKE. Sie legt fest, wie VMAKE Moduldateien behandelt, die eine spezielle Dateiendung haben und die nicht übersetzt werden sollen.

Verwendung

<extra_line> = <comment_line> | (<extension><token_sep><layer><token_sep><dest_dir><token_sep><option><new_line>)

Verwenden Sie als Kommentarzeichen das Zeichen #

Parameter

Name | Beschreibung
<extension> | Dateierweiterung
<token_sep> | Trennzeichen (beliebig viele Leerzeichen oder Tabulatoren)
<layer> | Schicht
<dest_dir> | Verzeichnis, in das die Dateien kopiert werden sollen
<option> | Optionen

Optionen

Name | Beschreibung
ascii | siehe ascii
binary | siehe binary
concom | Conditional Compiling
exec | siehe exec
unpack=yes|no|no dot | Entpacken (ja | nein | Entfernen der letzten Dateierweiterung)

Beispiel

.ino xx usr/env unpack=no
.mp px usr/bin unpack=no dot
.dm px tmp exec

Moduldateien mit der Dateiendung .ino gehören zur Schicht xx. Sie sind in das Verzeichnis usr/env zu kopieren, das sich in $INSTROOT befindet. Die Moduldatei enthält keinen textuellen Rahmen (Option unpack=no).

Moduldateien mit der Dateiendung .mp gehören zur Schicht px. Sie sind in das Verzeichnis usr/bin (relativ zu $INSTROOT) zu kopieren. Die Moduldatei enthält keinen textuellen Rahmen. Nach dem Kopieren ist die Dateiendung .mp zu entfernen (Option unpack=no dot).

Moduldateien mit der Dateiendung .dm gehören zur Schicht px. Sie sind in das Verzeichnis tmp (relativ zu $INSTROOT) zu kopieren. Die Moduldatei enthält einen textuellen Rahmen, der zu entfernen ist. Nachdem der Rahmen entfernt wurde, wird die Datei als ausführbar gekennzeichnet (Option exec, nur unter UNIX/Linux relevant).


Globals.com (SAP-Bibliothek - Entwicklung)

Objektdokumentation Globals.com

Definition

Globals.com ist eine Kompilierbeschreibung, in der Optionen und Abhängigkeiten für alle Moduldateien angegeben werden. Sie kann entweder in $INSTROOT/sys/desc oder $INSTROOT/sys/src/Globals abgelegt werden.

Verwendung

VMAKE interpretiert für jedes Modul die zugehörige Kompilierbeschreibung, um für diese Abhängigkeiten und Optionen zu bestimmen. Wenn es Optionen oder Abhängigkeiten gibt, die für alle Moduldateien gelten, dann müssen diese nicht in jeder Kompilierbeschreibung aufgeführt werden, sondern können global in Globals.com festgelegt werden. Die Syntax ist die gleiche wie für alle anderen Kompilierbeschreibungen.

Beispiel

Die Datei $INSTROOT/sys/src/Globals/Globals.com hat folgende Einträge:

*.cpp -OPT=-O2

Für alle C++-Dateien wird die Optimierung bei der Kompilierung auf -O2 gesetzt.

*p dep=:ptoc/ptoc_h

Alle Pascal-Dateien sind abhängig von der Moduldatei src/ptoc/ptoc_h


DirectoryMapping (SAP-Bibliothek - Entwicklung)

Objektdokumentation DirectoryMapping

Definition

DirectoryMapping ist eine Initialisierungsdatei von VMAKE. Sie dient dazu, Moduldateien Schichten zuzuordnen. DirectoryMapping ist im Verzeichnis $INSTROOT/sys/desc abgelegt.

Verwendung

VMAKE ordnet Moduldateien anhand des zweiten und dritten Buchstabens des Dateinamens einer Schicht zu. Eine weitere Möglichkeit, Moduldateien einer Schicht zuzuordnen, ist die DirectoryMapping-Funktion. Damit können Sie auch längere und sprechendere Dateinamen verwenden. Ein mit der DirectoryMapping-Funktion spezifizierter Dateiname besteht aus zwei Namensteilen, die durch einen Unterstrich miteinander verbunden sind. Der erste Teil spezifiziert in Kurzform die Schicht, der zweite Teil den Namen der Moduldatei:
<file_name> = <short_layer>_<modular_file>

In der Datei DirectoryMapping wird die Kurzform auf die entsprechende Schicht abgebildet:
<dm_line> = <comment_line> | (<short_layer>, <full_layer><new_line>)

<short_layer> | Kurzform der Schicht
<full_layer> | Schichten unterhalb von $INSTROOT/sys/src/SAPDB

Sie können als Kommentarzeichen das Zeichen # verwenden.

Für ein Verzeichnis, in dem Moduldateien enthalten sind, ist eine Kompilierbeschreibung erforderlich. Diese wird entsprechend der Konventionen für Kompilierbeschreibungen abgelegt.

Beispiel

Die Datei $INSTROOT/sys/desc/DirectoryMapping hat folgende Einträge:

# <short_layer>, <directory>
# Component SQLStudio
StudioTD, SQLStudio/TableDefinition # Table Definition

Wenn die Dateien StudioTD_TableDef.cpp und StudioTD_Wrapper.cpp erstellt werden sollen, dann muss die Kompilierbeschreibung TableDefinition.com unter dem Pfad $INSTROOT/sys/desc/SAPDB/SQLStudio/ oder $INSTROOT/sys/src/SAPDB/SQLStudio/TableDefinition abgelegt sein.

VMAKE sucht die Dateien StudioTD_TableDef.cpp und StudioTD_Wrapper.cpp in der Schicht $INSTROOT/sys/src/SAPDB/SQLStudio/TableDefinition.


Angeben nicht zu übersetzender Dateien (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Angeben nicht zu übersetzender Dateien

Verwendung

Es gibt Dateien, die im Quelltext bereits in dem später benötigten Textformat oder binär vorliegen. Diese Dateien müssen nicht übersetzt werden, sondern werden von VMAKE nur in das Objektverzeichnis kopiert.

Sie können diese Dateien mit Hilfe des Werkzeugs mfextra (siehe VMAKE-Werkzeuge) bearbeiten.

Vorgehensweise

Um das Übersetzen einer Datei zu verhindern, haben Sie folgende Möglichkeiten:

· Setzen Sie die Option ascii oder binary.

· Tragen Sie die Datei in die Initialisierungsdatei Extra ein.


icp.pl: Kopieren von Dateien in den Entwicklungsbereich (SAP-Bibliothek - Entwicklung)

Vorgehensweisen icp.pl: Kopieren von Dateien in den Entwicklungsbereich

Verwendung

Sie ändern Quelltextdateien immer im Entwicklungsbereich MaxDB_DEV, und nicht im Bereich MaxDB_ORG (Originaldateien). Mit dem Perl-Skript icp.pl kopieren Sie Quelltextdateien aus dem Bereich MaxDB_ORG in den Entwicklungsbereich MaxDB_DEV. Beim Kopieren legt icp.pl im Entwicklungsbereich alle notwendigen Unterverzeichnisse an.

Voraussetzungen

Sie haben die Entwicklungsumgebung initialisiert.

Vorgehensweise

icp.pl [-o] <file1> [<file2>]

Parameter

Name | Beschreibung
<file1> | Datei, die in den Entwicklungsbereich kopiert werden soll Geben Sie nicht den vollständigen Pfad, sondern nur den Dateinamen an. Die Namenskonventionen für Dateien stellen sicher, dass der Dateiname eindeutig ist.
<file2> | Name, unter dem die Datei im Entwicklungsbereich abgelegt werden soll
-o | kopiert die Datei in das gleiche Verzeichnis in der obersten Ebene der Suchhierarchie

Ergebnis

Die Moduldatei kann nun geändert werden.

Beispiel

Kopieren der Moduldatei vak54:

icp.pl vak54

Das Perl-Skript icp.pl kopiert die Datei vak54 in den Entwicklungsbereich MaxDB_DEV und legt dabei die notwendigen Verzeichnisse an:

<myDevelopmentDirectory>\V75_00_12\MaxDB_DEV\sys\src\ak\vak54

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


iview.pl: Anzeigen und Bearbeiten von Dateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation iview.pl: Anzeigen und Bearbeiten von Dateien

Verwendung

iview.pl ist ein Perl-Skript, mit dem Sie Modul- und Beschreibungsdateien anzeigen und bearbeiten. Als Editor wird das Programm verwendet, das in der Umgebungsvariable $EDITOR angegeben ist.

iview.pl [-l <level>] <file>

Parameter

Name | Beschreibung
<file> | Datei, die geöffnet werden soll Geben Sie nicht den vollständigen Pfad, sondern nur den Dateinamen an. Die Namenskonventionen für Dateien stellen sicher, dass der Dateiname eindeutig ist.
-l <level> | Zugriff auf diejenige Version der Datei, die sich in der Suchhierarchie an der Stelle <level> befindet

Das Skript geht folgendermaßen vor:

· Wenn sich die Datei <file> im Unterverzeichnis src oder desc im Entwicklungsbereich MaxDB_DEV befindet, dann wird sie direkt von dort geöffnet und kann bearbeitet werden.

· Wenn sich die Datei nicht im Entwicklungsbereich befindet, dann sucht das Skript sie anhand der Suchhierarchie und kopiert die Datei zum Anzeigen in das Unterverzeichnis tmp im Entwicklungsbereich MaxDB_DEV.

Änderungen an einer Datei können nur dann übersetzt werden, wenn die Datei zuvor mit dem Skript icp.pl in den Entwicklungsbereich kopiert und dort geändert wurde.

Beispiel

iview.pl dbmcli.lnk

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


idiff.pl: Vergleichen von Dateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation idiff.pl: Vergleichen von Dateien

Verwendung

idiff.pl ist ein Perl-Skript, das eine Datei im Entwicklungsbereich MaxDB_DEV mit einer älteren Version derselben Datei in der Suchhierarchie vergleicht.

idiff.pl [-l <level1>,<level2>] <file>

Parameter

Name

Beschreibung

-l <level1>,<level2>

Ebenen <level1>,<level2> der Suchhierarchie, in denen das Skript nach zu vergleichenden Versionen der Datei suchen soll

Wenn Sie diese Option weglassen, dann wird die Datei mit der nächstfolgenden in der Suchhierarchie verglichen.

<file>

Datei im Entwicklungsbereich, die mit einer älteren Version verglichen werden soll

Geben Sie nicht den vollständigen Pfad, sondern nur den Dateinamen an. Die Namenskonventionen für Dateien stellen sicher, dass der Dateiname eindeutig ist.

Beispiel

idiff.pl -l 2,3 vak54

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


ils.pl: Anzeigen der Versionen einer Datei (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation ils.pl: Anzeigen der Versionen einer Datei

ils.pl ist ein Perl-Skript, das die Versionen einer Datei innerhalb der Suchhierarchie anzeigt.

ils.pl [-l <level>] <file>

Parameter

Name | Beschreibung
<file> | Datei, deren Versionen in der Suchhierarchie angezeigt werden sollen Geben Sie nicht den vollständigen Pfad, sondern nur den Dateinamen an. Die Namenskonventionen für Dateien stellen sicher, dass der Dateiname eindeutig ist.
-l <level> | Ebene der Suchhierarchie, ab der das Skript nach Versionen der Datei suchen soll

Beispiel

ils.pl vak54

------------------------------------------------

level 0 - C:\test\V75_00_15\MaxDB_DEV :

190144 Thu Jul 22 09:41:03 2004 sys/src/ak/vak54

level 1 - C:\test\V75_00_15\MaxDB_ORG :

190144 Tue Jun 22 20:33:46 2004 sys/src/ak/vak54

------------------------------------------------

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


Namenskonventionen für Dateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Namenskonventionen für Dateien

Verwendung

Beachten Sie folgende Namenskonventionen, wenn Sie Moduldateien und Beschreibungsdateien benennen.

<filename> = <digit> | <letter> | <extended letter>

Erlaubte Zeichen in Dateinamen

<digit> | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
<letter> | A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | | u | v | w | x | y | z
<extended> | alle weiteren druckbaren Zeichen außer Bindestrich und Punkt

Außerdem gelten folgende Konventionen:

· Namenskonventionen für Moduldateien

· Namenskonventionen für Beschreibungsdateien


Namenskonventionen für Moduldateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Namenskonventionen für Moduldateien

Verwendung

<source_spec> = <qual_source> | <std_source> | <ext_std_source> | <map_source>

<source_spec> darf maximal 512 Zeichen lang sein.

Namenskonventionen für Moduldateien

<qual_source> | :<ext_layer><source>
<std_source> | <source_id><layer><digit><digit>{<digit>}[{<letter>}<lang_id>][<variant>]
<ext_std_source> | <std_source>[<primary_lang_id>]
<map_source> | <shortform>_<specification>
<source> | <token>[<variant>]<primary_lang_id>
<source_id> | g | h | i | v
<ext_layer> | [<ext_layer>]<character><character>{< character >}/ maximal 256 Zeichen
<shortform> | <letter>{<letter>}
<specification> | <letter>{<letter>}[<variant>][<primary_lang_id>]
<lang_id> | <letter>
<layer> | <letter><letter>{<letter>} maximal 256 Zeichen
<primary_lang_id> | .<token>
<variant> | -<token>

Beispiel

<qual_source> | :Demo/Test/demo.cpp
<std_source> | hak33c | vbd23x | vkb00
<ext_std_source> | hak33.h | vbd23x.cpp | vkb00.hxx
<map_source> | StudioTD_TableDef.hpp | StudioTD_Wrapper.cpp


Namenskonventionen für Beschreibungsdateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Namenskonventionen für Beschreibungsdateien

Verwendung

<desc_spec> = <qual_desc> | <std_desc>

<desc_spec> darf maximal 512 Zeichen lang sein.

Namenskonventionen für Beschreibungsdateien

<qual_desc> | ::[<ext_layer>]<std_desc>
<std_desc> | <character>{<character>}<desc_ext>
<desc_ext> | .(mac | prj | shm | lnk | dld | shr | rel | lib | com)

Beispiel

<qual_desc> | ::Kern/diagnose.lnk
<std_desc> | ak1.lib | kernel.shm | ak.com


MAKE-Vorgang (SAP-Bibliothek - Entwicklung)

Prozessdokumentation MAKE-Vorgang

Einsatzmöglichkeiten

Sie erstellen mit dem Programm VMAKE aus geänderten Quelltext-Dateien eine Softwarekomponente.

Voraussetzungen

Sie haben den MAKE-Vorgang vorbereitet.

Ablauf

Der MAKE-Vorgang gliedert sich grundsätzlich in die zwei Phasen, die Sammelphase und die Make-Phase.

Sammelphase

...

1. ims.pl, imf.pl: Starten des MAKE-Vorgangs

2. Ermitteln der zu übersetzenden Dateien

Make-Phase

In der Make-Phase werden die Moduldateien nach den in den Beschreibungsdateien festgelegten Abhängigkeiten erstellt. Wenn beim Erstellen einer Moduldatei ein Fehler auftritt, dann werden auch all jene Ziele nicht erstellt, die von dieser Moduldatei abhängig sind. Dies gilt über alle Abhängigkeitsstufen hinweg.

3. Übersetzungsvorgang

4. Linkvorgang

5. Nach der erfolgreichen Erstellung der Ziele werden die Dateien im temporären Arbeitsverzeichnis wieder gelöscht. Wenn bei der Erstellung ein Fehler aufgetreten ist, dann bleiben sie erhalten. Der gesamte Prozess der Software-Erstellung wird von VMAKE protokolliert.

Beispiel

Wenn eine Moduldatei vak10 von der Moduldatei vak00 abhängig ist (vak10 inc=vak00), dann wird zunächst die Moduldatei vak00 behandelt. Erst wenn diese erfolgreich erstellt wurde, kann vak10 erstellt werden.

Wenn beim Erstellen von vak00 ein Fehler auftritt, dann wird neben anderen abhängigen Dateien auch vak10 nicht behandelt. Weil vak10 in der ak1lib.lib enthalten ist, wird ak1lib.lib nicht gelinkt. Weil ak1lib.lib im Kern kernel.shm enthalten ist, wird auch der Kern nicht gelinkt.

Siehe auch:

Vergleich MaxDB-VMAKE - herkömmliches make-Programm


ims.pl, imf.pl: Starten des MAKE-Vorgangs (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation ims.pl, imf.pl: Starten des MAKE-Vorgangs

Verwendung

Sie rufen VMAKE nie direkt auf, sondern immer mit einem der folgenden Perl-Skripte:

· imf.pl (VMAKE-Version fast)

· ims.pl (slow)

Das gewählte Skript initialisiert eine definierte Umgebung und startet dann das Programm VMAKE und damit den eigentlichen MAKE-Vorgang.

Vorgehensweise

<script_name> [<option_list>][<vmake_option_list>] <target1>[//<ext_option1>] <target2>[//<ext_option2>]

Parameter

Name | Beschreibung
<script_name> | Name des Skripts
<option_list> | Folgende Optionen können in der Optionsliste <option_list> angegeben werden: · --mail=<email_address> Nach dem Ende des MAKE-Vorgangs wird eine E-Mail an die Adresse <email_address> verschickt. · --force_run Erzwingt einen MAKE-Vorgang auch außerhalb des Entwicklungsbereichs MaxDB_DEV. · --noquiet Beim MAKE-Vorgang werden sämtliche Compiler- und Linkeraufrufe ausgegeben. Um diese Option standardmäßig zu aktivieren, definieren Sie die Umgebungsvariable $NOQUIET.
<vmake_option_list> | [-<vmake_opt1>] [-<vmake_opt2>] [+e] Optionen für den Aufruf von VMAKE
<target> | Ziel (zu erstellendes Softwaremodul): <source_spec> | <desc_spec> Als Ziel können Sie alle Arten von Ausgabedateien angeben, die während des gesamten Software-Erstellungsprozesses entstehen können. Dies können sowohl einzelne Objektdateien Linkbeschreibungen als auch Ausgabedateien von nicht zu übersetzenden Dateien sein.
<source_spec> | Moduldatei
<desc_spec> | Beschreibungsdatei (Linkbeschreibung und Abarbeitungslisten) Sie können die Dateierweiterung weglassen. VMAKE sucht in folgender Reihenfolge nach Dateien: .mac, .shm, .lnk, .dld, .shr, .rel, .lib, .jpr
<ext_option> | Diese Optionen entsprechen den Optionen für Beschreibungsdateien. Verwenden Sie als Separator einen Slash /

Beispiel

Erstellen der Softwarekomponente Database Manager CLI mit der VMAKE-Version slow:

ims.pl dbmcli.lnk

Erstellen aller Softwarekomponenten mit der VMAKE-Version fast:

imf.pl all


Direkter VMAKE-Aufruf (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Direkter VMAKE-Aufruf

Verwendung

VMAKE übersetzt und linkt geänderten Quelltext.

Rufen Sie VMAKE nie direkt auf, sondern verwenden Sie immer eines der drei Skripte zum Starten des MAKE-Vorgangs, siehe ims.pl, imf.pl: Starten des MAKE-Vorgangs.

Syntax

vmake [<vmake_opt_list>] <target1>[//<ext_option1>] <target2>[//<ext_option2>] ...

Informationen zur Bedeutung der Parameter finden Sie im Abschnitt ims.pl, imf.pl: Starten des MAKE-Vorgangs.

Beispiel

vmake -D4 -i vzz34x//debug/profile

vmake -l -p demo.mac


Optionen für den Aufruf von VMAKE (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Optionen für den Aufruf von VMAKE

Verwendung

Option | Beschreibung
-b | Elternprozess wird beendet, nachdem der Kindprozess erfolgreich erzeugt wurde. Der Kindprozess wird erzeugt, nachdem alle Beschreibungen gesammelt wurden. Normalerweise lautet die erste Meldung des Kindprozesses <date> start of <target>. Vor dieser Nachricht wird VMAKE interaktiv ausgeführt, d. h. die standardmäßigen Signalhandler werden genutzt.
-c | Nachdem alle Beschreibungsdateien gesammelt wurden, wird die gesamte Beschreibungsinformation angezeigt und VMAKE beendet. Dies kann zur Überprüfung der Beschreibungsdateien (oder des Werkzeugs VMAKE) genutzt werden.
-d | Nur die in der Kommandozeile aufgeführten Ziele werden erstellt, falls sie nicht aktuell sind. Bei abhängigen Moduldateien wird davon ausgegangen, dass sie aktuell sind. So kann für einen Test eine Aktualisierung aller abhängigen Moduldateien vermieden werden.
-D<digit> | Ausgabe von Informationen über interne Daten und Programmabläufe; je größer die Zahl <digit> ist, um so mehr Informationen werden ausgegeben.
+e | Wenn Sie mit Hilfe der Umgebungsvariablen $VMAKE_OPTION die Erstellung der Software im Debug-Mode spezifiziert haben, dann können Sie mit der Option +e den Debug-Modus deaktivieren.
-F | Erstellen einer Auslieferungsliste, wobei eventuell veraltete Ziele nicht aktualisiert werden. Von dem aufgerufenen Ziel werden alle Dateien, die mit der Option distrib oder distribute für Beschreibungsdateien versehen wurden, in eine Liste eingetragen. Diese Liste wird im Verzeichnis $INSTROOT/etc in eine Datei gesichert. Der Name der Datei ist der Name des aufgerufenen Zieles. Sie bekommt die Dateiendung .lst. Bei der Eingabe von imf -F all wird die Datei all.lst erzeugt.
-g | Nutzung der kompletten Pfadhierarchie aus $VMAKE_PATH zur Suche nach Objektdateien; übersteuert den Parameter I der Umgebungsvariablen $VMAKE_OPTION.
-i | interaktiver Modus; Benutzer muss einen Abbruch von VMAKE nicht bestätigen.
-I | zusammen mit der Option -U; Include-Dateien werden neu erzeugt
-k | temporäre Dateien werden nicht gelöscht (z. B. entpackte Moduldateien, Objektdateien)
-K | temporäre Dateien werden nicht gelöscht; zusätzlich erhalten alle Skripte die Option -k. Damit löschen auch die Skripte ihre temporären Dateien nicht.
-L | C-Moduldateien werden mit Hilfe von LINT analysiert. Weitere Operationen werden nicht ausgeführt.
-l | verhindert die Benutzung von Objektdateien aus kleineren Pfadhierarchien. VMAKE übersetzt nur Moduldateien, die von der untersten Pfadhierarchie stammen. Diese Option übersteuert den Parameter g der Umgebungsvariablen $VMAKE_OPTION.
-m | Nachdem alle Beschreibungsinformationen gesammelt wurden, werden sämtliche Moduldateien ausgegeben, die benötigt werden.
-n | Überprüfendes MAKE-Vorgangs. VMAKE arbeitet wie gewöhnlich, aber alle Dateisystem- und Betriebssystemkommandos werden nicht ausgeführt. VMAKE nimmt an, dass alle diese Operationen erfolgreich durchgeführt wurden.
-p | Profiling für alle Moduldateien
-r | Normalerweise werden Moduldateien von ihrem Rahmen befreit und dann übersetzt. Die Verwendung dieser Option unterbindet das Übersetzen und Linken. Die ausgepackten Moduldateien verbleiben im Arbeitsverzeichnis. Weitere Operationen werden nicht ausgeführt.
-R | Um den Erstellungsprozess zu beschleunigen, wird gemäß Voreinstellung von VMAKE die Option ? require : <source> in Beschreibungsdateien nicht ausgewertet. Mit der Option R wird die Option ? require : <source> berücksichtigt.
-S | Aus PASCAL-Moduldateien werden Größeninformationen von Typen und Variablen extrahiert. Weitere Operationen werden nicht ausgeführt.
-u | Alle genannten Moduldateien werden explizit neu übersetzt und gelinkt. Alle abhängigen Moduldateien werden wie gewöhnlich entsprechend ihrer Aktualität übersetzt und gelinkt. Alle genannten Beschreibungsdateien werden explizit neu gelinkt. Wenn Sie als Ziel eine Abarbeitungsliste angeben, dann werden alle Module, die direkt in dieser Abarbeitungsliste aufgeführt sind, neu übersetzt.
-U | Alle genannten Moduldateien sowie davon abhängige Dateien werden übersetzt und gelinkt (Ausnahme: Include-Dateien).
-x | Alle Dateisystem-Kommandos, die VMAKE ausführt, werden vorher angezeigt.


Aktivieren des Debug-Modus (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Aktivieren des Debug-Modus

Verwendung

Sie können für einzelne Moduldateien den Debug-Modus aktivieren.

Vorgehensweise

Sie haben folgende Möglichkeiten, den Debug-Modus für Moduldateien zu aktivieren:

· Option -e für den Aufruf von VMAKE

· VMAKE_OPTION-Parameter e

· debug|d-Option für Beschreibungsdateien

Ergebnis

· Die Objektdateien, die aus diesen Moduldateien erstellt werden, enthalten zusätzliche Debug-Informationen.

· Die Moduldateien werden in das versionsspezifische Debug-Verzeichnis $WRK/<version>/debug kopiert, wo sie zur späteren Fehlersuche genutzt werden können.


VMAKE-Versionen (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation VMAKE-Versionen

Verwendung

VMAKE kann in verschiedenen Versionen ausgeführt werden. Die VMAKE-Versionen unterscheiden sich darin, welche Trace- und Prüfungsstufen beim Erstellen in die Software eingebaut werden (siehe Strukturlink Kernvarianten).

Skripten zum Aufrufen von VMAKE

VMAKE-Version | Beschreibung | Aufrufendes Skript
fast | Die erstellte Software führt keine zusätzlichen internen Fehlerprüfungen durch und protokolliert auch keine über die normale Trace-Ausgabe der Datenbank hinausgehenden Informationen. | imf.pl
slow | Die erstellte Software führt zusätzliche interne Fehlerprüfungen durch und protokolliert über die normale Trace-Ausgabe der Datenbank hinausgehende Informationen. | ims.pl

Siehe ims.pl, imf.pl: Starten des MAKE-Vorgangs.

Wenn in Beschreibungsdateien zu den Modulgruppen eine andere VMAKE-Version spezifiziert ist, als Sie durch den VMAKE-Aufruf festgelegt haben, dann wird die Aufrufversion durch die in der Beschreibungsdatei spezifizierte Version im Geltungsbereich dieser Beschreibungsdatei übersteuert.


Ermitteln der zu übersetzenden Dateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Ermitteln der zu übersetzenden Dateien

Verwendung

VMAKE ermittelt anhand der Datumsdateien, welche Ziele neu erstellt werden müssen.

VMAKE sammelt die Beschreibungsdateien eines Ziels und untersucht die gegenseitigen Abhängigkeiten der Dateien. Die Moduldateien selbst werden noch nicht innerhalb der Hierarchie gesucht.

Wenn in dieser Phase Fehler auftreten, dann beendet sich VMAKE.


Übersetzungsvorgang (SAP-Bibliothek - Entwicklung)

Prozessdokumentation Übersetzungsvorgang

Einsatzmöglichkeiten

VMAKE und seine Werkzeuge übersetzen Moduldateien mit Hilfe von Beschreibungsdateien. Die daraus entstehenden Dateien heißen Objektdateien.

Ablauf

...

1. VMAKE kopiert die Moduldateien in das temporäre Arbeitsverzeichnis tmp.

2. Auswahl der Übersetzungswerkzeuge

3. Entpacken der Moduldateien

4. Übersetzen der Moduldateien

5. VMAKE legt die Ausgabedateien (Objektdateien und Include-Dateien) zunächst ebenfalls im temporären Arbeitsverzeichnis ab.

6. VMAKE kopiert die Objektdateien in das jeweilige obj-Verzeichnis, die Include-Dateien entsprechend ihrer Schicht in das incl-Verzeichnis. Wenn VMAKE im Debug-Modus arbeitet (siehe Aktivieren des Debug-Modus), dann kopiert VMAKE die Moduldateien zusätzlich in das entsprechende Debug-Verzeichnis. Für jede Moduldatei, aus der ein Ziel erstellt wurde, legt VMAKE eine Datumsdatei an.

In den verschiedenen Phasen des MAKE-Vorgangs einer Datei <file_name>.<ext> bleibt der Dateiname <file_name> erhalten, die Dateiendung <ext> hingegen ändert sich.


Auswahl der Übersetzungswerkzeuge (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Auswahl der Übersetzungswerkzeuge

Verwendung

Moduldateien können in verschiedenen Programmiersprachen verfasst sein. Für die Übersetzung der Sprachen PASCAL, C/C++ und Assembler gibt es spezielle VMAKE-Werkzeuge; zusätzlich gibt es ein Werkzeug für die Übersetzung einer Gruppe von Beschreibungssprachen (IDL, Resource, Yak, Lex etc.).

Verfügbare Werkzeuge

 |  | Assembler | PASCAL | C / C++ | Beschreibungs-sprachgruppe
1. Phase | importierte Schnittstelle auspacken | mfainc | mfpinc | mfcinc | mfcinc
 | exportierte Schnittstelle auspacken | mfaexp | mfpexp | mfcexp | mfcexp
 | Modul auspacken | mfa | mfp | mfc | mfrc
2. Phase | übersetzen | compa | comppc | compc | comprc

VMAKE ordnet eine Moduldatei auf der Basis der Dateiendung einem bestimmten Werkzeug zu. Wenn keine Dateiendung vorhanden ist, dann erfolgt die Zuordnung auf der Basis des letzten Zeichens des Dateinamens.

 | Assembler | PASCAL | C / C++ | Beschreibungs-sprachklasse
Dateiendung | s | p, t | c, h / cpp, hpp | rc, ico, def, mc, dlg, idl, ycc, lex, rgs
letztes Zeichen | a | p, t oder eine Ziffer | c / x | r

Sie können die Zuordnung der Übersetzungswerkzeuge auf der Basis der Dateieindung bzw. des letzten Zeichens des Dateinamens in der Initialisierungsdatei Langextinfo ändern.


Entpacken der Moduldateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Entpacken der Moduldateien

Verwendung

VMAKE entscheidet anhand der Optionen in den Kompilierbeschreibungen, ob die Moduldateien entpackt werden müssen.

Zusätzlich können folgende Schritte ablaufen:

· Entfernen nicht übersetzungsrelevanter Teile des Rahmens: Moduldateien, die entpackt werden müssen, haben einen textuellen Rahmen, der unter anderem folgende Informationen enthält:

¡ Name des Moduls

¡ Modul-Spezifikation

¡ Autor, Version, Release

¡ exportierte Schnittstelle

¡ importierte Schnittstelle

¡ Quellcode

¡ Steuerzeichen

Da nicht alle Teile des textuellen Rahmens übersetzt werden müssen, werden beim Entpacken die nicht übersetzungsrelevanten Teile des Rahmens entfernt.

· Bedingte Kompilierung: VMAKE blendet die Teile des Quelltexts aus, die unter den aktuellen Bedingungen nicht benötigt werden, z. B. nicht notwendige Netzwerkanbindungen. Die zu verwendenden Include-Dateien werden vom System an den Anfang der zu übersetzenden Moduldatei kopiert.


Übersetzen der Moduldateien (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Übersetzen der Moduldateien

Verwendung

VMAKE übersetzt die Moduldateien im temporären Verzeichnis tmp. Die dabei erzeugten Objektdateien werden vom System in einem Objektverzeichnis abgelegt und anschließend im temporären Verzeichnis wieder gelöscht.

Siehe auch:

Verzeichnisstruktur der Entwicklungsumgebung


Objektdateien (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Objektdateien

Die Dateien, die beim Entpacken und Übersetzen von Moduldateien entstehen, werden Objektdateien genannt. Objektdateien haben die Dateiendung .o

Objektdateien werden standardmäßig in den Verzeichnissen, die der verwendeten VMAKE-Version (Aufrufversionen für VMAKE) entsprechen, abgelegt, also unter fast oder slow (siehe Verzeichnisstruktur der Entwicklungsumgebung). Wenn in der Kompilierbeschreibung für eine Moduldatei die Option noversion angegeben ist, dann wird die Objektdatei direkt im Verzeichnis wrk/obj abgelegt.


Datumsdatei (SAP-Bibliothek - Entwicklung)

Objektdokumentation Datumsdatei

Definition

Für jedes zu erzeugende Ziel legt VMAKE eine Datumsdatei an. Der Name einer Datumsdatei setzt sich aus dem Namen der bearbeiteten Datei und der Dateiendung .dat zusammen: <file_name>.dat. Ihr Zeitstempel entspricht dem der jeweiligen Moduldatei oder Linkbeschreibung.

Verwendung

VMAKE verwendet die Datumsdatei beim MAKE-Vorgang zum Vergleich, ob die lokal vorhandenen Ziele den aktuell genutzten Moduldateien/Linkbeschreibungen entsprechen. Wenn beide Dateien einen unterschiedlichen Zeitstempel haben, dann erkennt VMAKE das Ziel als nicht aktuell und erstellt es neu.

VMAKE legt Datumsdateien folgendermaßen ab:

· Datumsdateien von Include-Dateien werden unabhängig von der VMAKE-Version des MAKE-Vorgangs im Verzeichnis $WRK/dates innerhalb ihrer Schicht abgelegt, da Include-Dateien versionsunabhängig sind.

· Datumsdateien für alle anderen Moduldateien werden in dem versionsspezifischen Verzeichnis $WRK/<version>/dates in den jeweiligen Unterverzeichnissen, die der Schicht entsprechen, abgelegt.

· Datumsdateien für Linkbeschreibungen werden direkt im versionsspezifischen Verzeichnis $WRK/<version>/dates abgelegt.


Linkvorgang (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Linkvorgang

Verwendung

Beim Linken werden Objektdateien im Verzeichnis tmp zu einer Softwarekomponente zusammengefügt.

VMAKE verwendet zum Linken verschiedene Werkzeuge für die unterschiedlichen Objektdateien, die beim Übersetzungsvorgang entstehen können. Die Entscheidung darüber, welches Werkzeug zum Linken der jeweiligen Objektdatei verwendet werden soll, trifft VMAKE auf der Basis der Dateiendung der Beschreibungsdatei. Das Werkzeug entnimmt der Linkbeschreibung die Verweise auf die zu linkenden Objektdateien und die dabei zu verwendenden Optionen.

VMAKE legt die beim Linken erstellte Softwarekomponente in einem vordefinierten oder einem in der Linkbeschreibung spezifizierten Zielverzeichnis ab und löscht sie danach im Verzeichnis tmp.

zu erstellende Softwarekomponente | verwendetes Werkzeug | Zielverzeichnis
Programm | linklnk | $DBROOT/pgm
Programm, das Shared-Memory-Zugriff ermöglicht | linkshm | $DBROOT/pgm
statische Bibliothek | archive | $WRK/fast/obj oder $WRK/slow/obj
dynamische Bibliothek | linkdll | $DBROOT/lib (32 bit) $DBROOT/lib/lib64 (64 bit)
Programm, das mit anderen Programmen gelinkt werden kann | linkrel | $WRK/fast/obj oder $WRK/slow/obj
Programm, das mit anderen Programmen gelinkt werden kann und Shared-Memory-Zugriff ermöglicht | linkshr | $WRK/fast/obj oder $WRK/slow/obj


VMAKE-Werkzeuge (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation VMAKE-Werkzeuge

Verwendung

Das Programm VMAKE verwendet mehrere Werkzeuge (Skripte). Diese Werkzeuge können in einer beliebigen Skript- oder Prototypingsprache vorliegen. Mit der Umgebungsvariablen $TOOLSHELL konfigurieren Sie, welche Shell die Skripte ausführt.

Die Namen der Skripte werden von VMAKE mit Hilfe der Variable $TOOLEXT vervollständigt (sofern vorhanden), die die Dateiendung der Skripte definiert. Wenn zusätzliche Parameter an $TOOLSHELL übergeben werden sollen, sind diese in der Umgebungsvariable $TOOLOPT zu definieren.

Die Werkzeuge akzeptieren sowohl absolute als auch relative Pfadangaben für Moduldateien und Beschreibungsdateien. Die Ziele werden in dem von VMAKE vorgegebenen aktuellen Arbeitsverzeichnis erzeugt und anschließend im vorgegebenen Zielverzeichnis abgelegt.

VMAKE geht zunächst davon aus, dass die VMAKE-Werkzeuge im Verzeichnis $TOOL/bin gespeichert sind. Wenn sie sich nicht dort befinden, dann sucht VMAKE für jeden lokalen Pfad <path> entlang des Pfades <path>/sys/tool/bin.

Funktionsumfang

VMAKE-Werkzeuge

Aufruf

Beschreibung

archive [<ar-flags>] <library> <objects>

schreibt die Objektdateien <objects> in die Bibliothek <library>

compa [<as-flags>] <source>

übersetzt eine Assembler-Moduldatei und erstellt die Datei <file_name>.o

compc [<cc-flags>] <source>

übersetzt eine C/C++-Moduldatei und erstellt die Datei <file_name>.o

complint [<cc-flags>] <source>

prüft eine C-Moduldatei mit LINT

compp [<pc-flags>] <source>

übersetzt eine PASCAL-Moduldatei und erstellt die Datei <file_name>.o

comppc [<pc-flags>] <source>

übersetzt eine PASCAL-Moduldatei in eine C-Moduldatei

linkdll [<ld-flags>] <dll> <archive> <objects>

linkt die Objektdateien <objects> zu einer dynamischen Bibliothek <dll> und erstellt die statische Bibliothek <archive>

linklnk [<ld-flags>] [-o program] <objects>

linkt ein Programm mit dem Namen program

linkrel [<ld-flags>] relocatable <objects>

schreibt die Objektdateien <objects> in ein Relocatable-Objekt mit dem Namen relocatable

linkshm [<ld-flags>] [-o program] <objects>

linkt ein Programm mit dem Namen program, dessen globale Variablen im Shared Memory abzulegen sind

linkshr [<ld-flags>] relocatable <objects>

schreibt die Objektdateien <objects> in ein Relocatable-Objekt mit dem Namen relocatable, dessen globale Variablen im Shared Memory abzulegen sind

mfa [-trace=<procedure>] [-check=no] [-<token>=<value>] <source> [<includes>]

extrahiert die Code Section einer Assembler-Moduldatei und schreibt diese in die Datei <file_name>.s

Wenn Include-Dateien benötigt werden, dann sind diese in korrekter Reihenfolge anzugeben. Die Optionen -trace und -check sind aus Gründen der Kompatibilität mit mfp-Skripten eingefügt und werden vom mfa-Skript ignoriert.

mfainc [-<token>=<value>] <source>

extrahiert den Include-Code einer Assembler-Include-Datei und schreibt ihn in die Datei <file_name>.h

mfc [-trace=<procedure>] [-check=no] [-<token>=<value>] <source> [includes]

extrahiert die Code Section einer C/C++-Moduldatei und schreibt diese in <file_name>(.c |.cpp)

Wenn Include-Dateien benötigt werden, dann sind diese in korrekter Reihenfolge anzugeben. Wenn $VMAKE_VERSION mit slow definiert ist, dann wird der Datei #define DEBUG vorangestellt. Die Optionen -trace und -check sind aus Gründen der Kompatibilität mit mfp-Skripten eingefügt und werden vom mfc-Skripten ignoriert.

mfcexp [-<token>=<value>] <source>

schreibt die exportierte Schnittstelle (Define Section des textuellen Rahmens) in die Datei <file_name>.h

mfcinc [-<token>=<value>] <source>

extrahiert den Include-Code einer C/C++-Include-Datei und schreibt ihn in die Datei <file_name>.h

mfextra [-<token>=<value>] <source> <destination> [<includes>]

erzeugt nicht zu übersetzende Dateien

mfp [-trace=<procedure>] [-check=no] [-<token>=<value>] <source> [>includes>]

extrahiert die Define Section, Use Section und Code Section einer PASCAL-Moduldatei und schreibt diese in die Datei <file_name>.p

Wenn Include-Dateien benötigt werden, dann sind diese in korrekter Reihenfolge anzugeben. Die Option -trace=<procedure> spezifiziert den Namen der Trace-Prozedur, deren Aufruf am Anfang jeder Funktion und Prozedur eingefügt wird. Die Option -check=no definiert, ob die Namenspräfixe exportierter Prozeduren geprüft werden sollen.

mfpinc [-<token>=<value>] <source>

extrahiert den Include-Code einer C/C++- Include-Datei.

Extrahierte CONST-Definitionen werden in die Datei <file_name>.con, extrahierte TYPE-Definitionen in die Datei <file_name>.typ geschrieben.

mfsize [<include-list>] <module>

erzeugt eine Datei <file_name>.siz, die Größeninformationen über verwendete Typen der Moduldatei enthält

Wenn Include-Dateien benötigt werden, dann sind diese in korrekter Reihenfolge anzugeben.

Für einige Werkzeuge können Sie zusätzliche Optionen angeben.


Optionen für VMAKE-Werkzeuge (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Optionen für VMAKE-Werkzeuge

Verwendung

Die folgenden Optionen können von VMAKE an die VMAKE-Werkzeuge übergeben werden. Manche Werkzeuge ignorieren diese Optionen.

Optionen

-g | Debug-Modus eingeschaltet (für mindestens eine Moduldatei)
-k | Zwischendateien werden nicht gelöscht
-language=<lang id> | wird von allen Werkzeugen verwendet; Kürzel für die dem Quelltext zugrundeliegende Programmiersprache
-p | Profiling eingeschaltet (für mindestens eine Moduldatei)
-unpack=no | Quelltext enthält keinen Rahmen (nur bei mf*-Skripten)
-Y | Shared Global Data, PTOC-Zeiger-Konvertierung

Zusätzlich wirken die Optionen für den Aufruf von VMAKE und Optionen für Beschreibungsdateien.


VMAKE-Protokolle (SAP-Bibliothek - Entwicklung)

Objektdokumentation VMAKE-Protokolle

Definition

VMAKE protokolliert den gesamten MAKE-Vorgang. Es erzeugt für jede übersetzte Moduldatei Protokolle im Verzeichnis prot (siehe Allgemeine Verzeichnisstruktur).

Verwendung

Die Namen der Protokolle entsprechen den Dateinamen, die beim Aufruf der VMAKE-Version als Parameter angegeben wurden. Sie haben die Dateiendung .e0, .p0 oder .x0.

Inhalte der Protokolle

Dateiendung | Protokoll
.e0 | enthält nur Fehlermeldungen und eine Auflistung der Ziele, die nicht erfolgreich erstellt werden konnten
.p0 | normales Protokoll, entspricht den Bildschirmausgaben während des Erstellungsprozesses
.x0 | enthält genaue Informationen über die einzelnen Dateien sowie die beim Aufruf der VMAKE-Werkzeuge verwendeten Optionen

Beim Anlegen der Protokolle werden ältere Protokolle mit dem gleichen Namen so umbenannt, dass die Ziffer am Ende des Namens um 1 erhöht wird. Damit ist eine Historie von bis zu 10 Protokollen möglich (.p0 bis .p9).

Die jeweils aktuellen Protokolle können Sie mit Hilfe der Skripte ips.pl, ipf.pl: Anzeigen von Protokollen anzeigen.


ips.pl, ipf.pl: Anzeigen von Protokollen (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation ips.pl, ipf.pl: Anzeigen von Protokollen

Verwendung

ips.pl und ipf.pl sind Perl-Skripte, mit denen Sie die VMAKE-Protokolle eines Übersetzungsvorgangs anzeigen.

<script_name> <file>

<script_name> | Name des Skripts · ips.pl: VMAKE-Version slow · ipf.pl: VMAKE-Version fast
<file> | Datei, für deren Übersetzungsvorgang die Protokolle angezeigt werden sollen

Beispiel

Aufrufen der VMAKE-Version fast und Übersetzen der Datei dmbcli:

imf dbmcli

Anzeigen der Protokolle für den Übersetzungsvorgang:

ipf dbmcli


Vergleich MaxDB-VMAKE - herkömmliches make-Programm (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Vergleich MaxDB-VMAKE - herkömmliches make-Programm

Verwendung

VMAKE verhält sich in einigen Punkten anders als make unter UNIX oder nmake von Microsoft:

· Da VMAKE alle Include-Dateien nach sys/wrk/incl und alle Quelldateien vor der Übersetzung in ein temporäres Verzeichnis kopiert, zeigen Dateinamen in Fehlermeldungen des Kompilierers nie auf die eigentlichen Quelldateien.

· VMAKE erzeugt immer so viel wie möglich und stoppt nicht beim ersten Fehler. Dies entspricht der Option -k in make.

· Zu jeder Objektdatei existiert eine Datumsdatei. Eine Objektdatei wird in den folgenden Fällen neu erzeugt:

¡ Die bestehende Objektdatei ist älter als die Quelldatei (wie in make).

¡ Der Zeitstempel der Datumsdatei unterscheidet sich vom Zeitstempel der Quelldatei.


Beispiel: Übersetzen der Datei HelloWorld.c (SAP-Bibliothek - Entwicklung)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Übersetzen der Datei HelloWorld.c

Einsatzmöglichkeiten

Sie übersetzen und linken die Datei sys/src/SAPDB/HelloWorld.c zu einem ausführbaren Programm usr/pgm/hello (bzw. usr\pgm\hello.exe unter Microsoft Windows).

Voraussetzungen

· Sie haben die Datei sys/src/SAPDB/HelloWorld.c erstellt.

· Sie haben die Include-Datei sys/src/SAPDB/HelloWorld.h erstellt.

Ablauf

...

1. Sie starten den MAKE-Vorgang (VMAKE-Version fast):

imf.pl hello.lnk

2. VMAKE ermittelt die benötigten Dateien:

¡ VMAKE erkennt die Beschreibungsdatei sys/desc/hello.lnk anhand ihrer Dateiendung .lnk als die Beschreibung eines ausführbaren Programms. Die Beschreibung enthält nur die Datei :SAPDB/HelloWorld.c; der Doppelpunkt steht für das Verzeichnis mit den Moduldateien sys/src.

¡ VMAKE erkennt die Moduldatei sys/src/SAPDB/HelloWorld.c anhand ihrer Dateiendung .c als eine Moduldatei, die mit dem C-Kompilierer übersetzt werden muss. Die von dieser Moduldatei benötigten Include-Dateien werden in der Beschreibungsdatei sys/desc/SAPDB.com aufgeführt:
HelloWorld.c inc=:SAPDB/HelloWorld.h
In dieser Zeile können weitere Optionen für den Kompilierer stehen.

¡ Die Include-Datei sys/src/SAPDB/HelloWorld.h benötigt keine weiteren Dateien, ansonsten müssten diese Abhängigkeiten ebenfalls in SAPDB.com eingetragen werden.

3. VMAKE aktualisiert die benötigten Dateien:

¡ Include-Dateien:
HelloWorld.h, HelloWorld.c fast, hello.lnk fast
Diese kopiert VMAKE aus dem Entwicklungsbereich in ein entsprechendes Unterverzeichnis sys/wrk/incl, in diesem Fall nach sys/wrk/inl/SAPDB/HelloWorld.h. Dateinamen in #include-Anweisungen sind deshalb immer relativ zu sys/wrk/incl anzugeben.

¡ C-Quellen:
HelloWorld.h, HelloWorld.c fast, hello.lnk fast
Diese werden mit Hilfe des C-Kompilierers in Objektdateien übersetzt. Objektdateien können in drei Versionen (VMAKE-Versionen) erzeugt werden: fast (mit Optimierung) oder slow (mit Assertions und Traceausgaben). In diesem Fall wird die erzeugte Datei nach sys/wrk/fast/obj/SAPDB/HelloWorld.o geschrieben. Auch unter Microsoft Windows erhalten Objektdateien die Dateiendung .o. Zum Übersetzen wird die Quelldatei in das Verzeichnis sys/wrk/fast/tmp kopiert. Alle Zwischenergebnisse (diese fallen insbesondere bei PASCAL-Quellen an) werden in diesem Verzeichnis erzeugt und können beim Auftreten eines Fehlers dort überprüft werden.

¡ Ausführbare Programme:
HelloWorld.h, HelloWorld.c fast, hello.lnk fast
Diese werden gelinkt und nach usr/pgm kopiert. Unter UNIX wird dabei usr/pgm/hello.f erzeugt und darauf ein Link im Dateisystem unter usr/pgm/hello eingetragen. Unter Microsoft Windows wird die Datei usr\pgm\hello.exe.ferzeugt und nach usr\pgm\hello.exe kopiert.

4. Sie zeigen die VMAKE-Protokolle hello.lnk.p0 (Kopie der Bildschirmausgabe) und hello.lnk.x0 (Auflistung aller relevanten Zeitstempel sowie der ausgeführten Aktionen) an:

ipf.pl hello.lnk

Varianten

· Erzwungene Übersetzung: Damit wird das angegeben Ziel neu erzeugt. Ein ausführbares Programm wird neu gelinkt.

imf.pl -u hello.lnk

hello.lnk fast

· Option -U: Damit werden das angegebene Ziel und alle dafür benötigten Moduldateien neu erzeugt.

imf.pl -U hello.lnk

HelloWorld.c fast
hello.lnk fast

· Option -U -I: Damit werden das angegebene Ziel, alle dafür benötigten Module und alle benötigten Include-Dateien neu erzeugt.

imf.pl -U -I hello.lnk

HelloWorld.h
HelloWorld.c fast
hello.lnk fast

· Option -e: Sie weisen VMAKE an, alle Ziele mit Debuginformationen zu erzeugen (siehe Aktivieren des Debug-Modus).

imf.pl -U -e hello.lnk

HelloWorld.c fast debug
hello.lnk fast debug

Danach kann usr/pgm/hello im Debugger gestartet werden. Die Quelldateien werden nach dem Übersetzungsvorgang nach sys/wrk/fast/debug kopiert. Dies ist vor allem für PASCAL-Moduldateien wichtig, da diese nicht im Quelltext debugt werden können, sondern nur anhand der generierten C-Datei.

5. Anzeigen der neu zu erzeugenden Ziele:

imf.pl -u -n hello.lnk

6. Anzeigen der benutzten Modul- und Beschreibungsdateien:

imf.pl -m hello.lnk

7. Anzeigen der benutzten Modul- und Beschreibungsdateien sowie der Abhängigkeiten:

imf.pl -C hello.lnk


Beispiel: Erstellen des Programms Database Manager CLI 7.4.03 (SAP-Bibliothek - Entwicklung)

Diese Grafik wird im zugehörigen Text erklärt Beispiel: Erstellen des Programms Database Manager CLI 7.4.03

Einsatzmöglichkeiten

Sie erstellen das MaxDB-Programm Database Manager CLI 7.4.03.

Das Programm Database Manager CLI (DBMCLI) besteht aus den folgenden Komponenten:

· Hauptkomponenten:

¡ Entgegennahme und Auswertung der Aufrufparameter und Nutzereingaben

¡ Übergabe der DBM-Kommandos an die Kommunikationskomponenten

¡ Entgegennahme der Antworten des DBM-Server von den Kommunikationskomponenten

¡ Auswerten und Ausgabe der Antworten des DBM-Server

· Kommunikationskomponenten:

¡ Kommunikation mit dem lokalen DBM-Server

¡ Kommunikation zu einem DBM-Server auf einem entfernten Rechner

¡ Die Kommunikationskomponenten sind Bestandteile der Laufzeitumgebung (LZU) des Datenbanksystems.

· DBM-Server: Auf Anforderung des Benutzers kann dieser integrierte DBM-Server verwendet werden. In diesem Fall werden die Komponenten, die für die Verbindung zu einem eigenständigen DBM-Server erforderlich sind, nicht verwendet.

Ablauf

...

1. Verfahren Sie wie in Erstellen des DBMCLI beschrieben.

2. Führen Sie anschließend eine Funktionsprüfung durch.

Siehe auch:

Bestandteile des DBMCLI

Dokumentation zum Strukturlink Database Manager CLI


Bestandteile des DBMCLI (SAP-Bibliothek - Entwicklung)

Objektdokumentation Bestandteile des DBMCLI

Definition

Der Quelltext des Programms DBMCLI besteht aus den folgenden Dateien:

· Moduldatei dbmcli.rc

· Moduldatei vcn12.cpp

· Moduldatei vcn13.cpp

· Moduldatei vcn14.c

· Linkbeschreibung cservlib

· Linkbeschreibung splib

· Linkbeschreibung eoxlib

· Linkbeschreibung sqlusr

· Linkbeschreibung enalib

· Linkbeschreibung enblib

· Weitere Abhängigkeiten

Siehe auch:

Linkbeschreibung dbmcli.lnk


dbmcli.rc (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation dbmcli.rc

Verwendung

Diese Moduldatei ist eine Ressourcendatei und befindet sich im Unterverzeichnis $OWN\sys\src\Resource. Beim Angeben der Moduldatei in der Linkbeschreibung müssen Sie das Verzeichnis Resource explizit aufführen:

:Resource/dbmcli.rc

Wenn Sie diese Moduldatei in der Linkbeschreibung angeben, dann werden die entsprechenden Ressourcen in das Programm DBMCLI eingebunden.

In der Moduldatei ist ein Microsoft Windows-spezifischer Quelltext enthalten. Die Moduldatei dbmcli.rc ist nur unter Microsoft Windows in der Linkbeschreibung dbmcli.lnk relevant und ist aus diesem Grund in der Linkbeschreibung mit einer Bedingung versehen.

Siehe auch:

Bestandteile des DBMCLI


vcn12.cpp, vcn13.cpp, vcn14.c (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation vcn12.cpp, vcn13.cpp, vcn14.c

Verwendung

Die Moduldateien vcn12.cpp, vcn13.cpp und vcn14.c der Linkbeschreibung dbmcli.lnk sind im Verzeichnis $OWN/sys/src/cn abgelegt. Der Verzeichnisname cn wird implizit anhand des Namens der Moduldateien ermittelt.

Diese Moduldateien sind die Hauptkomponenten des Programms DBMCLI und enthalten C- bzw. C++-Quellcode:

· In der Moduldatei vcn12.cpp ist die main-Funktion enthalten.

· In der Moduldatei vcn13.cpp sind einige Funktionen zum Dateizugriff und zur Zeichensatzkonvertierung enthalten.

· Die Moduldatei vcn14.c dient als Verbindung zwischen Hauptkomponenten und Kommunikationskomponenten.

Die Moduldateien vcn12.cpp, vcn13.cpp und vcn14.c binden über #include-Anweisungen Include-Dateien ein.

In der Kompilierbeschreibung ist beschrieben, wie die Moduldateien von den Include-Dateien abhängen.

Siehe auch:

Bestandteile des DBMCLI


Kompilierbeschreibungen (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation Kompilierbeschreibungen

Verwendung

Eine Kompilierbeschreibung spezifiziert, wie die Moduldateien vcn12.cpp, vcn13.cpp und vcn14.c von den Include-Dateien abhängen.

In einer Kompilierbeschreibung sind neben den Abhängigkeiten einer Moduldatei von Include-Dateien noch weitere Eigenschaften der Moduldateien angegeben, die die Übersetzung der Moduldateien durch die Entwicklungsumgebung steuern.

Die für eine Moduldatei passende Kompilierbeschreibung wird implizit anhand des Verzeichnisses, in dem die zu übersetzende Moduldatei abgelegt ist, ermittelt und ausgewertet.


Beispiel für eine Include-Datei (SAP-Bibliothek - Entwicklung)

Diese Grafik wird im zugehörigen Text erklärt Beispiel für eine Include-Datei

Verwendung

Das folgende Beispiel zeigt, wie eine Moduldatei vcn12.cpp aus dem Verzeichnis $OWN/sys/src/cn von Include-Dateien abhängt.

Die Abhängigkeiten für die Moduldatei sind in der Kompilierbeschreibung $OWN/sys/desc/cn.com enthalten:

vcn12.cpp inc=gsp09.h,heo02.h,hcn13.h,hcn14.h,hcn90.h,...

Im Beispiel ist nur das Schlüsselwort inc enthalten. Das Schlüsselwort inc verweist auf die notwendigen Include-Dateien. Die nach dem Schlüsselwort inc genannten Include-Dateien werden von der Entwicklungsumgebung vor der Übersetzung der Moduldatei in das Include-Verzeichnis $OWN/wrk/incl generiert. Dabei behandelt die Entwicklungsumgebung die Include-Dateien je nach ihrem Dateityp.

Im Beispiel gibt es nur Include-Dateien vom Typ h. Include-Dateien vom Typ h werden aus dem jeweiligen Unterverzeichnis des Verzeichnisses $OWN/sys/src in ein Unterverzeichnis des Include-Verzeichnisses kopiert. Der Name dieses Unterverzeichnisses wird von dedr Entwicklungsumgebung implizit aus dem Namen der Include-Datei ermittelt.


cservlib (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation cservlib

Verwendung

cservlib ($OWN/sys/desc/cservlib.lib) ist eine Linkbeschreibung vom Typ lib. Der Linkbeschreibungstyp lib beschreibt das Erstellen einer statischen Bibliothek.

Eine Linkbeschreibung vom Typ lib besteht aus mehreren Moduldateien, die nach der Übersetzung zu der entsprechenden Bibliothek zusammengefasst werden. Die Abhängigkeiten und Eigenschaften für die einzelnen Moduldateien sind in den verzeichnisspezifischen Kompilierbeschreibungen hinterlegt.

Um die Bibliothek cservlib in das Programm Database Manager CLI einzubinden, tragen Sie sie in die Linkbeschreibung dbmcli.lnk ein.

In der Bibliothek cservlib ist die Funktionalität des in das Programm DBMCLI integrierten DBM-Server enthalten.

Siehe auch:

Bestandteile des DBMCLI


splib (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation splib

Verwendung

Die Linkbeschreibung splib ($OWN/sys/desc/splib.lib) in der Linkbeschreibung dbmcli.lnk hat den Typ lib und spezifiziert das Erstellen einer statischen Bibliothek.

Die Bibliothek splib enthält Module mit allgemein benutzbaren Funktionen.

Siehe auch:

Bestandteile des DBMCLI


eoxlib (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation eoxlib

Verwendung

Die Linkbeschreibung eoxlib ($OWN/sys/desc/eoxlib.lib) in der Linkbeschreibung dbmcli.lnk hat den Typ lib und spezifiziert das Erstellen einer statischen Bibliothek.

Die Bibliothek eoxlib enthält Kommunikationskomponenten der Laufzeitumgebung des Datenbanksystems.

Siehe auch:

Bestandteile des DBMCLI


sqlusr, enalib, enblib (SAP-Bibliothek - Entwicklung)

Funktionsdokumentation sqlusr, enalib, enblib

Verwendung

Die Linkbeschreibungen sqlusr, enalib, enblib ($OWN/sys/desc/sqlusr.lib, $OWN/sys/desc/enalib.lib, $OWN/sys/desc/enblib.lib) sind vom Typ lib und spezifieren das Erstellen von statischen Bibliotheken.

Die Bibliotheken sqlusr, enalib, enblib enthalten Kommunikationskomponenten der MaxDB-Laufzeitumgebung. Weil die MaxDB-Laufzeitumgebung plattformspezifisch ist, werden für UNIX andere Bibliotheken verwendet als für Microsoft Windows. Daher erfolgt in der Linkbeschreibung dbmcli.lnk eine Klammerung der Linkbeschreibungen durch eine Bedingung.

Siehe auch:

Bestandteile des DBMCLI


Weitere Abhängigkeiten (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Weitere Abhängigkeiten

Wenn Sie das Betriebssystem Microsoft Windows verwenden, dann benötigt das Programm DBMCLI die dynamische Bibliothek sqltcp.dll. Sie müssen diese Bibliothek explizit erstellen.

Geben Sie dazu folgendes Kommando ein:

imf sqltcp

Weitere Informationen zum Skript imf finden Sie im Abschnitt ims.pl, imf.pl: Starten des MAKE-Vorgangs.


Erstellen des DBMCLI (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Erstellen des DBMCLI

Verwendung

Um das ausführbare Programm DBMCLI zu erstellen, verwenden Sie die Linkbeschreibung dbmcli.lnk. Sie befindet sich im Verzeichnis $OWN/sys/desc/dbmcli.lnk (siehe Verzeichnisstruktur der Entwicklungsumgebung).

Vorgehensweise

Um die Linkbeschreibung dbmcli.lnk mit VMAKE abzuarbeiten und so das Programm DBMCLI zu erstellen, geben Sie folgendes Kommando ein:

imf dbmcli

Sie können den Typ (lnk) der Linkbeschreibung weglassen, weil der Name der Datei (dbmcli) eindeutig ist.

Weitere Informationen zum Skrit imf finden Sie im Abschnitt ims.pl, imf.pl: Starten des MAKE-Vorgangs.

Ergebnis

Das Programm DBMCLI wird erstellt. In der Linkbeschreibung ist festgelegt, wo das Programm DBMCLI abgelegt wird:

· Microsoft Windows: $OWN\usr\pgm

· UNIX: Die Zeile ->$INSTROOT/bin/dbmcli bewirkt, dass das Programm im Verzeichnis $OWN/usr/bin abgelegt wird.

Wir empfehlen, nach dem Erstellen des Programms DBMCLI eine Funktionsprüfung durchzuführen.


Linkbeschreibung dbmcli.lnk (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Linkbeschreibung dbmcli.lnk

Der folgende Auszug aus der Linkbeschreibung dbmcli.lnk enthält die wesentlichen Kommandos, die für das Erstellen des Programms DBMCLI notwendig sind. Spezielle Befehle und Schalter, die für den Linkvorgang auf den verschiedenen Plattformen notwendig sein können, sind hier nicht aufgeführt.

Um das Programm Database Manager CLI zu erstellen, verwenden Sie die vollständige Linkbeschreibung dbmcli.lnk (siehe Verzeichnisstruktur der Entwicklungsumgebung).

Auszug aus der Linkbeschreibung dbmcli.lnk

&if $OS in [ WIN32 ]
:Resource/dbmcli.rc remake
&endif

vcn12.cpp
vcn13.cpp
vcn14.c

cservlib

splib
eoxlib

&if $OS in [ WIN32 ]
sqlusr
&else

enalib
enblib

&endif

Anmerkungen

Die Linkbeschreibung verweist auf Moduldateien und weitere Linkbeschreibungen:

· Verweise auf Moduldateien führen dazu, dass diese Moduldateien auch übersetzt werden. Die Zuordnung der Übersetzungswerkzeuge erfolgt über die Dateiendung der Moduldateien.

Moduldateien in der Beispiel-Linkbeschreibung: dbmcli.rc, vcn12.cpp, vcn13.cpp, vcn14.c

· Verweise auf Linkbeschreibungen führen dazu, dass diese Linkbeschreibungen abgearbeitet werden.

Linkbeschreibungen in der Beispiel-Linkbeschreibung: cservlib, splib, eoxlib, sqlusr, enalib, enblib

Siehe auch:

Bestandteile des DBMCLI


Funktionsprüfung (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Funktionsprüfung

Verwendung

Sie können die Funktionsfähigkeit des Programms DBMCLI überprüfen, indem Sie ein DBM-Kommando ausführen (siehe Database Manager CLI, Strukturlink Übersicht aller DBM-Kommandos).

Voraussetzung

· Erstellen des DBMCLI

· Sie haben, beispielsweise mit der unveränderten Version der MaxDB-Software, bereits eine Datenbankinstanz angelegt.

Vorgehensweise

...

1. Überprüfen Sie, ob Sie wirklich auf die gerade erstellte Softwarekomponente, das Programm DBMCLI,($OWN/usr/bin/dbmcli, Microsoft Windows: $OWN\usr\pgm\dbmcli.exe) zugreifen.

2. Geben Sie das DBM-Kommando zum Anzeigen der Version des Database Manager ein:

dbmcli [-n <server_node>] -d <database_name> -u <dbm_userid>,<dbm_password> dbm_version

dbmcli -d DEMODB -u dbm,dbm dbm_version

OK

VERSION = 7.3.4

BUILD = DBMServer 7.3.4 Build 009-000-220-192

OS = UNIX

INSTROOT = /usr/sapdb-srv

LOGON = False

CODE = ASCII

SWAP = full


Web Based Problem Tracking System (SAP-Bibliothek - Entwicklung)

Komponentendokumentation Web Based Problem Tracking System

Einsatzmöglichkeiten

Das Web Based Problem Tracking System (Web PTS) ist eine Web-Schnittstelle zum MaxDB-internen Programm PTS, in dem Problemmeldungen zur MaxDB-Datenbanksoftware dokumentiert sind. Sie greifen mit einem Web-Browser auf Web PTS zu (siehe Systemanforderungen).

Einführungshinweise

Web PTS steht unter folgender Adresse zur Verfügung: www.sapdb.org/webpts

Funktionsumfang

Funktionsweise des Web PTS

Begriffe

Einschränkungen

Über Web PTS können Sie ausschließlich lesend auf die im MaxDB-internen Programm PTS erfassten Problemmeldungen zugreifen.

Beispiel

Ein externer Entwickler, beispielsweise ein Mitglied der Open-Source-Community, schickt eine Problemmeldung an das MaxDB-Entwicklungsteam. Diese wird intern im Programm PTS erfasst. Anschließend wird dem externen Entwickler die URL dieser Problemmeldung geschickt. Damit erhält er die Möglichkeit, jederzeit den Bearbeitungsstand zu verfolgen und sich über die Planung zu informieren, welche Änderung in welche Datenbankversion eingehen soll.


Systemanforderungen (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Systemanforderungen

Die günstigste Voraussetzung für die Verwendung des Programms Web Based Problem Tracking System ist ein Browser, der Frames, JavaScript und Cascading-Style-Sheets (CSS) unterstützt.

Wenn Ihr Browser CSS nicht unterstützt, wird die Darstellung des Programms beeinträchtigt sein. Bei einzelnen Browsers kann es aber auch dazu führen, dass das Programm nicht benutzbar ist (z. B. Konqueror 2.9.2 mit aktiviertem Accessibility-Style-Sheet).

Tests mit Microsoft Internet Explorer 6, Netscape 4.74, Mozilla 1.1, Netscape 6.1, Netscape 7 (alle auf Windows 2000) sowie Konqueror 3.0.3 (alle auf Linux SuSE 8.0) zeigten gute Ergebnisse.


Funktionsweise des Web PTS (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Funktionsweise des Web PTS

Verwendung

Das Programm Web Based Problem Tracking System (Web PTS) bietet Ihnen die Möglichkeit, nach den in diesem Programm erfassten Problemmeldungen zu suchen. Dazu stehen Ihnen verschiedene Suchmasken mit Auswahllisten und Suchfunktionen zu den Meldungsdaten und Meldungstexten zur Verfügung.

Verfügbare Suchmasken

Einfache Suche: Simple Search | Einschränkung des Suchergebnisses mit Hilfe freier Eingaben
Erweiterte Suche: Advanced Search | Einschränkung des Suchergebnisses mit Hilfe von Eingaben, die Sie aus den Vorschlägen des Systems auswählen
Versionsvergleich: My Release Notes | Einschränkung des Suchergebnisses auf ausschließlich jene Meldungen, die für den Endkunden relevante Informationen enthalten Wenn Sie die Version Ihrer installierten Software und eine neuere Version angeben, begrenzen Sie die Ergebnisliste auf die für Ihre Softwareinstallation relevanten Informationen, die bis zur angegebenen neueren Version ausgegeben wurden.


Einfache Suche (Simple Search) (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Einfache Suche (Simple Search)

Verwendung

Mit der Einfachen Suche zeigen Sie die im MaxDB-internen Programm PTS erfassten Problemmeldungen mit den dazu vorhandenen Informationen an. Das Suchergebnis schränken Sie durch die Angabe geeigneter freier Suchbegriffe ein.

Die Suche erfolgt in den Meldungstexten und Keywords aber nicht in den Meldungsdaten.

Es werden maximal 25 Ergebnisse ausgegeben.

Eingaberegeln

Sie können beliebige Buchstaben- und/oder Zahlenkombinationen angeben. Folgende Eingaberegeln müssen dabei beachtet werden:

· Such-Strings, die aus mehreren Wörtern bestehen, sind in Anführungszeichen zu setzen (z. B.: "backup history“)

· Such-Strings, die mit einem Minuszeichen beginnen, sind ebenfalls in Anführungszeichen zu setzen (z. B.: "-8000“)

· Um Problemmeldungen aus der Ergebnisliste auszuschließen, leiten Sie den Such-String mit einem Minuszeichen als Negationsoperator ein (z. B.: -logging, -"-8000", -"backup history")

Vorgehensweise

Wählen Sie Simple Search.

...

1. Geben Sie Such-Strings unter Einhaltung der oben genannten Eingaberegeln an.

2. Wählen Sie, nach welchen Regeln die Suche erfolgen soll:

All Words | Jede Meldung in der Ergebnisliste soll alle aufgeführten Suchstrings enthalten.
Any Word | Jede Meldung in der Ergebnisliste soll mindestens einen der aufgeführten Such-Strings enthalten.
Exact Phrase | Jede Meldung in der Ergebnisliste soll exakt den aufgeführten Such-String enthalten.

3. Wenn Sie Ihre Eingaben zurücksetzen wollen, wählen Sie Clear.

Wenn Sie die Suche starten wollen, wählen Sie Search.

Ein Negationsoperator vor einem Such-String ist am sinnvollsten in der Kombination mit der Suchregel All Words, da Sie damit die Ergebnistabelle eingrenzen.

Dagegen kann der Negationsoperator vor einem Such-String in der Kombination mit der Suchregel Any Words die Ergebnisliste bedeutend vergrößern.

Ergebnisliste der Einfachen Suche


Ergebnisliste der Einfachen Suche (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Ergebnisliste der Einfachen Suche

Verwendung

Sie zeigen die bei der Suche verwendeten Suchkriterien an, darunter die Anzahl der Gesamttreffer der Suche und die Ergebnisliste. In der Liste werden maximal 25 Treffer angezeigt. Wenn die Trefferzahl 25 übersteigt, empfiehlt es sich, die Suche weiter einzugrenzen.

Zu jedem Ergebnis zeigen sie die wichtigsten Meldungsdaten sowie die ersten 160 Zeichen der zur Problemmeldung erfassten Beschreibung an.

Vorgehensweise

Wenn Sie sich zu einem Eintrag in der Ergebnisliste eine Detailansicht anzeigen lassen wollen, klicken Sie dazu auf die laufende Nummer (Number) der jeweiligen Meldung. Sie zeigen damit alle zu einer ausgewählten Meldung vorhandenen Informationen an, d. h. alle verfügbaren Meldungsdaten und Meldungstexte.
Sie können die Detailansicht als URL speichern. Klicken Sie dazu mit der rechten Maustaste auf den angebotenen Link.

Wenn Sie die Suche ändern wollen, ändern Sie die angezeigten Suchkriterien. Anschließend wählen Sie Search.

Wenn Sie eine neue Suche starten wollen, wählen Sie Clear und verfahren wie unter Einfache Suche beschrieben.


Erweiterte Suche (Advanced Search) (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Erweiterte Suche (Advanced Search)

Verwendung

Mit der Erweiterten Suche zeigen Sie die im MaxDB-internen Programm PTS erfassten Problemmeldungen mit den dazu vorhandenen Informationen an. Durch die Auswahl von Werten für die Eingabefelder können Sie das Suchergebnis eingrenzen.

Sie erhalten eine Information, wie viele Problemmeldungen gefunden wurden.

Sie können definieren, wie viele Problemmeldungen in der Ergebnisliste angezeigt werden.

Die Ergebnisliste können Sie als URL speichern.

Vorgehensweise

...

1. Wählen Sie Advanced Search.

Grenzen Sie das Suchergebnis ein, indem sie Werte aus den angebotenen Listen und Optionen auswählen oder freie Eingaben für die Suche in den zu den Meldungen erfassten Texten machen:
Header-Daten

¡ Klicken Sie auf Keywords, um eine eine Liste aller verfügbaren Schlüsselwörter zu erhalten. Durch einen einfachen Mausklick auf das gewünschte Schlüsselwort fügen Sie es zur Liste der Schlüsselwörter hinzu. Sie können bis zu 25 Schlüsselwörter angeben. Wählen Sie Apply, um die gewählten Schlüsselwörter in die Suchmaske zu kopieren.

Bearbeitungsstand
Meldungstexte

2. Definieren Sie die Anzeige der Ergebnisliste. Sie können zwischen verschiedenen Spaltenkombinationen wählen und angeben, wie viele Problemmeldungen angezeigt werden sollen.

¡ Wählen Sie, ob eine maximale Zeilenzahl (Max Rows) oder alle Zeilen der Ergebnisliste (All Rows) angezeigt werden sollen. Wenn Sie die Zeilenzahl begrenzen wollen, geben Sie die gewünschte Zahl an. Die Anzahl der Zeilen entspricht der Anzahl der angezeigten Problemmeldungen.

¡ Wählen Sie unter Result Column Set welche Spalten in der Ergebnisliste angezeigt werden sollen. Sie können zwischen 3 vordefinierten Spaltenkombinationen wählen:

Minimum | Nummer der Meldung (Number), Meldungsart (Message Type), Komponente (Component), Erstellt (Reported), Erfassungsdatum (Created)
Standard | wie Minimal sowie die Spalten Bearbeitungsstand (Settlement), Geplant/Ausgeliefert (Planned/Delivered)
Maximum | wie Standard sowie die Spalten Bearbeitungsdatum (Processed), Beendigungsdatum (Completed), Betroffene Betriebssysteme (Affected OS)

3. Wenn Sie Ihre Eingaben zurücksetzen wollen, wählen Sie Clear

Wenn Sie die Suche starten wollen, wählen Sie Search.

Ergebnisliste der Erweiterten Suche


Ergebnisliste der Erweiterten Suche (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Ergebnisliste der Erweiterten Suche

Verwendung

Sie zeigen alle zu den definierten Suchkriterien passenden Problemmeldungen an. Zu jeder Problemmeldung können Sie eine Detailansicht aufrufen.

Sowohl die Ergebnisliste als auch die Detailansicht einer Problemmeldung können Sie als URL speichern.

Vorgehensweise

Wenn Sie die ausgegebene Ergebnisliste als URL speichern wollen, wählen Sie dazu den oben auf der Seite angebotenen Link mit der rechten Maustaste.
Wenn Sie diese URL zu einem späteren Zeitpunkt aufrufen, erhalten Sie genau diese Ergebnisliste angezeigt. Wählen Sie dann Refresh, um die Ausgabe zu aktualisieren.

Wenn Sie sich zu einem Eintrag in der Ergebnisliste die Detailansicht anzeigen lassen wollen, klicken Sie dazu auf die laufende Nummer (Number) der jeweiligen Meldung. Sie zeigen damit alle zu einer ausgewählten Meldung vorhandenen Informationen an, d. h. alle verfügbaren Meldungsdaten und Meldungstexte.
Sie können auch die Detailansicht als URL speichern. Klicken Sie dazu mit der rechten Maustaste auf den oben auf der Seite angebotenen Link.

Wenn Sie für die angezeigte Ergebnisliste die Suche modifizieren wollen, wählen Sie Modify Search.

Wenn Sie eine neue Suchabfrage definieren wollen, wählen Sie New Search und verfahren wie unter Erweiterte Suche beschrieben.


Versionsvergleich (My Release Notes) (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Versionsvergleich (My Release Notes)

Verwendung

Mit dem Versionsvergleich ermitteln Sie, welche zu einer Version erfassten Fehler/ Änderungsanforderungen in einer bestimmten nachfolgend ausgelieferten Version behoben/umgesetzt sind.

In der Ergebnisliste werden die zu den abgearbeiteten Problemmeldungen verfassten Release-Notes angezeigt. Release-Notes für behobene Fehler heißen Patch Information. Release-Notes für umgesetzte Änderungsanforderungen heißen Feature.

Sie erhalten eine Information, wie viele Release-Notes gefunden wurden. Die Anzeige ist sortiert.

Vorgehensweise

...

1. Wählen Sie My Release Notes.

2. Grenzen Sie die Suche ein, indem sie Werte aus den angebotenen Listen auswählen:

My Version | Version ab der gesucht werden soll
Newer Version | Version bis zu der gesucht werden soll
Component | MaxDB-Komponente

3. Wenn Sie Ihre Eingaben zurücksetzen wollen, wählen Sie Clear.

Wenn Sie die Suche starten wollen, wählen Sie Search.

Ergebnisliste des Versionsvergleichs


Ergebnisliste des Versionsvergleichs (SAP-Bibliothek - Entwicklung)

Vorgehensweisen Ergebnisliste des Versionsvergleichs

Verwendung

In dieser Liste erhalten Sie alle zu den definierten Suchkriterien passenden Release-Notes angezeigt.

Zu jeder Release-Note erhalten Sie die wichtigsten Meldungsdaten. Diesen können Sie unter anderem entnehmen, ob das Problem in der angegebenen Newer Version in Planung (Planned) oder ausgeliefert (Delivered) ist.

Alle gefundenen Release-Notes werden in der Ergebnisliste nach Komponenten sortiert angezeigt. Dabei wird für jede Komponente zwischen Patch Information und Feature unterschieden.

Für eine bestimmte Komponente werden zunächst die Release-Notes für ausgelieferte Versionen (zuerst Features und dann Patch Informations) und dann die Release-Notes für geplante Versionen (zuerst Features und dann Patch Informations) angezeigt.

Vorgehensweise

Wenn Sie für die angezeigte Ergebnisliste die Suche modifizieren wollen, wählen Sie Modify Search.

Wenn Sie eine neue Suche definieren wollen, wählen Sie New Search und verfahren wie unter Versionsvergleich beschrieben.


Begriffe (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Begriffe

Affected OS

Change Request

Completed

Component

Created

Delivered

Description

Error

Evaluate

Feature

Header Data

Keywords

Message Data

Message Texts

Message Type

Modules

Number

Patch Information

Planned/Delivered

Processed

Rejected

Release Note

Reported

Settlement

Solution

To be done

Waiting


Meldungsdaten (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Meldungsdaten

Zu jeder Problemmeldung sind folgende Meldungsdaten erfasst:

Header-Daten (Header Data)

Bearbeitungsstand(Settlement)

Der Inhalt der Problemmeldung steht im Meldungstext.


Header-Daten (Header Data) (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Header-Daten (Header Data)

Header-Daten sind Teil der Meldungsdaten.

Zu jeder Problemmeldung sind folgende Header-Daten erfasst:

Number | Laufende Nummer der Problemmeldung
Message Type | Art der Problemmeldung Error: Meldungsart Fehler, die Software funktioniert nicht, wie vorgesehen Change Request: Meldungsart Änderungsanforderung, der gemeldete Mangel erschwert den vorgesehenen Gebrauch der Software
Component | MaxDB-Komponente
Reported | Datenbankversion, auf die sich die Problemmeldung bezieht
Settlement | Bearbeitungsstand
Planned/Delivered | Datenbankversion, in der das Problem behoben sein wird/ ist
Created | Erfassungsdatum
Processed | Bearbeitungsdatum
Completed | Datum, an dem die Bearbeitung abgeschlossen wurde
Affected OS | Betroffene Betriebssysteme
Keywords | Schlüsselwörter Sie entsprechen den Indizes, die einer Problemmeldung beim Erfassen zugeordnet werden können.


Bearbeitungsstand (Settlement) (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Bearbeitungsstand (Settlement)

Angaben zum Bearbeitungsstand einer Problemmeldung sind Teil der Meldungsdaten.

Folgende Bearbeitungsstände sind möglich:

Waiting | Die Problemmeldung wurde erfasst, wird jedoch noch nicht bearbeitet
Evaluate | Der zuständige Entwickler bewertet die Problemmeldung hinsichtlich Relevanz, Arbeits- und Zeitaufwand
To be done | Die Problemmeldung wird bearbeitet
Delivered | Das Arbeitsergebnis ist in eine Datenbankversion eingeflossen, die ausgeliefert wurde
Rejected | Die Problemmeldung wird nicht bearbeitet


Meldungstexte (Message Texts) (SAP-Bibliothek - Entwicklung)

Hintergrunddokumentation Meldungstexte (Message Texts)

Meldungstexte sind die in den einzelnen Phasen der Bearbeitung einer Problemmeldung erfassten Texte.
Folgende Textarten können erfasst sein:

Description | Beschreibung des Problems
Solution | Beschreibung des Lösungsweges für das Problem
Patch Information | Beschreibung des neuen Standes nach Behebung eines Fehlers (Release-Note bei Meldungsart Fehler)
Modules | Von der Problemlösung betroffene Softwaremodule
Feature | Beschreibung des neuen Feature (Release-Note bei Meldungsart Änderungsanforderung)


LIESMICH
========

Dieses Paket enthält die html-Versionen der folgenden Dokumente:

Installation:
- Installationshandbuch

Grundwissen:
- Konzepte des Datenbanksystems
- Glossar
- SQL-Referenzhandbuch
- Meldungen
- MaxDB-Sicherheitsleitfaden

Tutorials
- Tutorial Datenbankverwaltung
- SQL-Tutorial
- Loader-Tutorial

Werkzeuge:
- Database Manager GUI
- Database Manager CLI
- Database Analyzer
- Loader
- SQL Studio
- Web SQL Studio
- SQLCLI
- Synchronization Manager
- Utilities

Schnittstellen:
- ODBC-Handbuch
- SQLDBC-Handbuch
- Java-Handbuch
- Perl-Handbuch
- Python-Handbuch
- PHP-Handbuch
- WebDAV
- Backint for MaxDB

Entwicklung:
- Entwicklungsumgebung
- Web Based Problem Tracking System

Zum Lesen der Dokumentation im Offline-Modus extrahieren Sie die Dateien
in ein lokales Verzeichnis. Anschließend öffnen Sie die Datei 'default.htm'.


SAP-Bibliothek - Grundwissen

 Anfang des Navigationsbaums
Anfang Ebene 1 Knoten Grundwissen Grundwissen Ende Ebene 1 Knoten Grundwissen
Anfang Ebene 2 Knoten Konzepte des Datenbanksystems Konzepte des Datenbanksystems Ende Ebene 2 Knoten Konzepte des Datenbanksystems
Anfang Ebene 3 Knoten Informationen zur Software Informationen zur Software Ende Ebene 3 Knoten Informationen zur Software
Anfang Ebene 4 Knoten SAP DB und MaxDB SAP DB und MaxDB Ende Ebene 4 Knoten SAP DB und MaxDB
Anfang Ebene 4 Knoten Dokumentation Dokumentation Ende Ebene 4 Knoten Dokumentation
Anfang Ebene 4 Knoten Demo-Datenbank Demo-Datenbank Ende Ebene 4 Knoten Demo-Datenbank
Anfang Ebene 5 Knoten Objekte im Schema HOTEL Objekte im Schema HOTEL Ende Ebene 5 Knoten Objekte im Schema HOTEL
Anfang Ebene 4 Knoten Download Download Ende Ebene 4 Knoten Download
Anfang Ebene 4 Knoten Versionsnotierung Versionsnotierung Ende Ebene 4 Knoten Versionsnotierung
Anfang Ebene 4 Knoten Unterstützte Betriebssysteme und Architekturen Unterstützte Betriebssysteme und Architekturen Ende Ebene 4 Knoten Unterstützte Betriebssysteme und Architekturen
Anfang Ebene 4 Knoten Open-Source-Entwicklung der Datenbanksoftware Open-Source-Entwicklung der Datenbanksoftware Ende Ebene 4 Knoten Open-Source-Entwicklung der Datenbanksoftware
Anfang Ebene 4 Knoten Support Support Ende Ebene 4 Knoten Support
Anfang Ebene 4 Knoten Problemmeldungen mit Web PTS verfolgen Problemmeldungen mit Web PTS verfolgen Ende Ebene 4 Knoten Problemmeldungen mit Web PTS verfolgen
Anfang Ebene 3 Knoten Das Datenbanksystem im Überblick Das Datenbanksystem im Überblick Ende Ebene 3 Knoten Das Datenbanksystem im Überblick
Anfang Ebene 4 Knoten SQL SQL Ende Ebene 4 Knoten SQL
Anfang Ebene 4 Knoten Transaktionen Transaktionen Ende Ebene 4 Knoten Transaktionen
Anfang Ebene 5 Knoten Protokollierung von Datenänderungen (Logging) Protokollierung von Datenänderungen (Logging) Ende Ebene 5 Knoten Protokollierung von Datenänderungen (Logging)
Anfang Ebene 6 Knoten History-Verwaltung History-Verwaltung Ende Ebene 6 Knoten History-Verwaltung
Anfang Ebene 6 Knoten Beispiel: Restart Beispiel: Restart Ende Ebene 6 Knoten Beispiel: Restart
Anfang Ebene 6 Knoten Beispiel: Konsistente Sicht Beispiel: Konsistente Sicht Ende Ebene 6 Knoten Beispiel: Konsistente Sicht
Anfang Ebene 5 Knoten Sperren für Datenbankobjekte Sperren für Datenbankobjekte Ende Ebene 5 Knoten Sperren für Datenbankobjekte
Anfang Ebene 6 Knoten Lesesperre Lesesperre Ende Ebene 6 Knoten Lesesperre
Anfang Ebene 6 Knoten Schreibsperre Schreibsperre Ende Ebene 6 Knoten Schreibsperre
Anfang Ebene 6 Knoten Optimistische Sperre Optimistische Sperre Ende Ebene 6 Knoten Optimistische Sperre
Anfang Ebene 6 Knoten Phänomene Phänomene Ende Ebene 6 Knoten Phänomene
Anfang Ebene 6 Knoten Parallelität von Sperren Parallelität von Sperren Ende Ebene 6 Knoten Parallelität von Sperren
Anfang Ebene 6 Knoten Isolation-Level Isolation-Level Ende Ebene 6 Knoten Isolation-Level
Anfang Ebene 4 Knoten Datenspeicherung Datenspeicherung Ende Ebene 4 Knoten Datenspeicherung
Anfang Ebene 5 Knoten Arbeitsspeicherbereiche Arbeitsspeicherbereiche Ende Ebene 5 Knoten Arbeitsspeicherbereiche
Anfang Ebene 5 Knoten Volumes (permanenter Speicher) Volumes (permanenter Speicher) Ende Ebene 5 Knoten Volumes (permanenter Speicher)
Anfang Ebene 5 Knoten Savepoint Savepoint Ende Ebene 5 Knoten Savepoint
Anfang Ebene 5 Knoten Logische Zugriffsstrukturen Logische Zugriffsstrukturen Ende Ebene 5 Knoten Logische Zugriffsstrukturen
Anfang Ebene 6 Knoten B*-Bäume für Tabellen mit LONG-Spalten B*-Bäume für Tabellen mit LONG-Spalten Ende Ebene 6 Knoten B*-Bäume für Tabellen mit LONG-Spalten
Anfang Ebene 6 Knoten B*-Bäume für Tabellen mit Indizes B*-Bäume für Tabellen mit Indizes Ende Ebene 6 Knoten B*-Bäume für Tabellen mit Indizes
Anfang Ebene 6 Knoten Belegungsausgleich Belegungsausgleich Ende Ebene 6 Knoten Belegungsausgleich
Anfang Ebene 6 Knoten Beispiel: SELECT-Anweisung Beispiel: SELECT-Anweisung Ende Ebene 6 Knoten Beispiel: SELECT-Anweisung
Anfang Ebene 6 Knoten Beispiel: INSERT-Anweisung Beispiel: INSERT-Anweisung Ende Ebene 6 Knoten Beispiel: INSERT-Anweisung
Anfang Ebene 6 Knoten Beispiel: DELETE-Anweisung Beispiel: DELETE-Anweisung Ende Ebene 6 Knoten Beispiel: DELETE-Anweisung
Anfang Ebene 6 Knoten Beispiel: UPDATE-Anweisung Beispiel: UPDATE-Anweisung Ende Ebene 6 Knoten Beispiel: UPDATE-Anweisung
Anfang Ebene 5 Knoten Converter Converter Ende Ebene 5 Knoten Converter
Anfang Ebene 3 Knoten Datenbankwerkzeuge Datenbankwerkzeuge Ende Ebene 3 Knoten Datenbankwerkzeuge
Anfang Ebene 3 Knoten Schnittstellen Schnittstellen Ende Ebene 3 Knoten Schnittstellen
Anfang Ebene 3 Knoten Technische Systemlandschaft Technische Systemlandschaft Ende Ebene 3 Knoten Technische Systemlandschaft
Anfang Ebene 4 Knoten Netzwerkkommunikation Netzwerkkommunikation Ende Ebene 4 Knoten Netzwerkkommunikation
Anfang Ebene 4 Knoten Architektur der Datenbankwerkzeuge Architektur der Datenbankwerkzeuge Ende Ebene 4 Knoten Architektur der Datenbankwerkzeuge
Anfang Ebene 4 Knoten Architektur der Schnittstellen Architektur der Schnittstellen Ende Ebene 4 Knoten Architektur der Schnittstellen
Anfang Ebene 4 Knoten Datenverschlüsselung Datenverschlüsselung Ende Ebene 4 Knoten Datenverschlüsselung
Anfang Ebene 4 Knoten Beispiel: Systemlandschaft mit MaxDB-Datenbankinstanz Beispiel: Systemlandschaft mit MaxDB-Datenbankinstanz Ende Ebene 4 Knoten Beispiel: Systemlandschaft mit MaxDB-Datenbankinstanz
Anfang Ebene 4 Knoten Beispiel: SAP-Systemlandschaft mit zwei MaxDB-Datenbankinstanzen Beispiel: SAP-Systemlandschaft mit zwei MaxDB-Datenbankinstanzen Ende Ebene 4 Knoten Beispiel: SAP-Systemlandschaft mit zwei MaxDB-Datenbankinstanzen
Anfang Ebene 4 Knoten Prozessstruktur Prozessstruktur Ende Ebene 4 Knoten Prozessstruktur
Anfang Ebene 5 Knoten Übersicht der Prozesse Übersicht der Prozesse Ende Ebene 5 Knoten Übersicht der Prozesse
Anfang Ebene 5 Knoten Übersicht der Dienste Übersicht der Dienste Ende Ebene 5 Knoten Übersicht der Dienste
Anfang Ebene 5 Knoten Übersicht der Tasks Übersicht der Tasks Ende Ebene 5 Knoten Übersicht der Tasks
Anfang Ebene 5 Knoten Übersicht der Task-Zustände Übersicht der Task-Zustände Ende Ebene 5 Knoten Übersicht der Task-Zustände
Anfang Ebene 5 Knoten Task-Wechsel Task-Wechsel Ende Ebene 5 Knoten Task-Wechsel
Anfang Ebene 5 Knoten Load-Balancing Load-Balancing Ende Ebene 5 Knoten Load-Balancing
Anfang Ebene 5 Knoten Übersicht der Spezial-Threads Übersicht der Spezial-Threads Ende Ebene 5 Knoten Übersicht der Spezial-Threads
Anfang Ebene 3 Knoten Anlegen und Konfigurieren einer Datenbankinstanz Anlegen und Konfigurieren einer Datenbankinstanz Ende Ebene 3 Knoten Anlegen und Konfigurieren einer Datenbankinstanz
Anfang Ebene 4 Knoten Datenbankinstanz planen Datenbankinstanz planen Ende Ebene 4 Knoten Datenbankinstanz planen
Anfang Ebene 4 Knoten Technische Restriktionen Technische Restriktionen Ende Ebene 4 Knoten Technische Restriktionen
Anfang Ebene 4 Knoten Vorlagen für Datenbankinstanzen Vorlagen für Datenbankinstanzen Ende Ebene 4 Knoten Vorlagen für Datenbankinstanzen
Anfang Ebene 4 Knoten Konventionen für Datenbanknamen Konventionen für Datenbanknamen Ende Ebene 4 Knoten Konventionen für Datenbanknamen
Anfang Ebene 4 Knoten Datenbankparameter Datenbankparameter Ende Ebene 4 Knoten Datenbankparameter
Anfang Ebene 5 Knoten Allgemeine Datenbankparameter Allgemeine Datenbankparameter Ende Ebene 5 Knoten Allgemeine Datenbankparameter
Anfang Ebene 5 Knoten Spezielle Datenbankparameter Spezielle Datenbankparameter Ende Ebene 5 Knoten Spezielle Datenbankparameter
Anfang Ebene 5 Knoten Support-Datenbankparameter Support-Datenbankparameter Ende Ebene 5 Knoten Support-Datenbankparameter
Anfang Ebene 5 Knoten liveCache-Datenbankparameter liveCache-Datenbankparameter Ende Ebene 5 Knoten liveCache-Datenbankparameter
Anfang Ebene 5 Knoten Eigenschaften von Datenbankparametern Eigenschaften von Datenbankparametern Ende Ebene 5 Knoten Eigenschaften von Datenbankparametern
Anfang Ebene 4 Knoten Automatischer Start Automatischer Start Ende Ebene 4 Knoten Automatischer Start
Anfang Ebene 5 Knoten Beispiel: Startskript für eine Datenbankinstanz (Linux) Beispiel: Startskript für eine Datenbankinstanz (Linux) Ende Ebene 5 Knoten Beispiel: Startskript für eine Datenbankinstanz (Linux)
Anfang Ebene 4 Knoten Log-Einstellungen Log-Einstellungen Ende Ebene 4 Knoten Log-Einstellungen
Anfang Ebene 4 Knoten Konfigurationsdateien Konfigurationsdateien Ende Ebene 4 Knoten Konfigurationsdateien
Anfang Ebene 4 Knoten Datenbankdesign Datenbankdesign Ende Ebene 4 Knoten Datenbankdesign
Anfang Ebene 5 Knoten Tipps zum Datenbank-Design Tipps zum Datenbank-Design Ende Ebene 5 Knoten Tipps zum Datenbank-Design
Anfang Ebene 3 Knoten Verwaltung Verwaltung Ende Ebene 3 Knoten Verwaltung
Anfang Ebene 4 Knoten Regelmäßige Verwaltungsaufgaben Regelmäßige Verwaltungsaufgaben Ende Ebene 4 Knoten Regelmäßige Verwaltungsaufgaben
Anfang Ebene 4 Knoten Verwaltungsaufgaben automatisieren Verwaltungsaufgaben automatisieren Ende Ebene 4 Knoten Verwaltungsaufgaben automatisieren
Anfang Ebene 5 Knoten Übersicht der Datenbank-Event-Kategorien Übersicht der Datenbank-Event-Kategorien Ende Ebene 5 Knoten Übersicht der Datenbank-Event-Kategorien
Anfang Ebene 4 Knoten Benutzer, Authentifizierung und Berechtigungen Benutzer, Authentifizierung und Berechtigungen Ende Ebene 4 Knoten Benutzer, Authentifizierung und Berechtigungen
Anfang Ebene 5 Knoten Datenbanksystemadministrator (SYSDBA-Benutzer) Datenbanksystemadministrator (SYSDBA-Benutzer) Ende Ebene 5 Knoten Datenbanksystemadministrator (SYSDBA-Benutzer)
Anfang Ebene 5 Knoten Database Manager-Benutzer (DBM-Benutzer) Database Manager-Benutzer (DBM-Benutzer) Ende Ebene 5 Knoten Database Manager-Benutzer (DBM-Benutzer)
Anfang Ebene 5 Knoten Datenbankbenutzer Datenbankbenutzer Ende Ebene 5 Knoten Datenbankbenutzer
Anfang Ebene 5 Knoten Serverberechtigungen für den DBM-Server Serverberechtigungen für den DBM-Server Ende Ebene 5 Knoten Serverberechtigungen für den DBM-Server
Anfang Ebene 5 Knoten Konventionen für Benutzernamen und Kennwörter Konventionen für Benutzernamen und Kennwörter Ende Ebene 5 Knoten Konventionen für Benutzernamen und Kennwörter
Anfang Ebene 5 Knoten Authentifizierung Authentifizierung Ende Ebene 5 Knoten Authentifizierung
Anfang Ebene 5 Knoten Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux) Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux) Ende Ebene 5 Knoten Spezielle Betriebssystembenutzer und -gruppen (UNIX/Linux)
Anfang Ebene 6 Knoten <sdb_user> (spezieller Betriebssystembenutzer) <sdb_user> (spezieller Betriebssystembenutzer) Ende Ebene 6 Knoten <sdb_user> (spezieller Betriebssystembenutzer)
Anfang Ebene 6 Knoten <sdba_group> (spezielle Betriebssystemgruppe) <sdba_group> (spezielle Betriebssystemgruppe) Ende Ebene 6 Knoten <sdba_group> (spezielle Betriebssystemgruppe)
Anfang Ebene 6 Knoten Supportgruppe (spezielle Betriebssystemgruppe) Supportgruppe (spezielle Betriebssystemgruppe) Ende Ebene 6 Knoten Supportgruppe (spezielle Betriebssystemgruppe)
Anfang Ebene 4 Knoten Sichern und Wiederherstellen Sichern und Wiederherstellen Ende Ebene 4 Knoten Sichern und Wiederherstellen
Anfang Ebene 5 Knoten Sicherungsvorlagen und Datenträger Sicherungsvorlagen und Datenträger Ende Ebene 5 Knoten Sicherungsvorlagen und Datenträger
Anfang Ebene 6 Knoten Hinweise zu den verschiedenen Typen von Datenträgern Hinweise zu den verschiedenen Typen von Datenträgern Ende Ebene 6 Knoten Hinweise zu den verschiedenen Typen von Datenträgern
Anfang Ebene 5 Knoten Daten sichern Daten sichern Ende Ebene 5 Knoten Daten sichern
Anfang Ebene 5 Knoten Log-Einträge sichern Log-Einträge sichern Ende Ebene 5 Knoten Log-Einträge sichern
Anfang Ebene 6 Knoten Sicherungsdateien archivieren Sicherungsdateien archivieren Ende Ebene 6 Knoten Sicherungsdateien archivieren
Anfang Ebene 5 Knoten Datenbankinstanz wiederherstellen Datenbankinstanz wiederherstellen Ende Ebene 5 Knoten Datenbankinstanz wiederherstellen
Anfang Ebene 5 Knoten Beispiel: Sichern und Wiederherstellen Beispiel: Sichern und Wiederherstellen Ende Ebene 5 Knoten Beispiel: Sichern und Wiederherstellen
Anfang Ebene 5 Knoten Sichern/Wiederherstellen mit entfernten Rechnern Sichern/Wiederherstellen mit entfernten Rechnern Ende Ebene 5 Knoten Sichern/Wiederherstellen mit entfernten Rechnern
Anfang Ebene 5 Knoten Sicherungswerkzeuge anderer Anbieter verwenden Sicherungswerkzeuge anderer Anbieter verwenden Ende Ebene 5 Knoten Sicherungswerkzeuge anderer Anbieter verwenden
Anfang Ebene 5 Knoten Datenbereich einfrieren (Snapshot) Datenbereich einfrieren (Snapshot) Ende Ebene 5 Knoten Datenbereich einfrieren (Snapshot)
Anfang Ebene 4 Knoten Exportieren und Importieren Exportieren und Importieren Ende Ebene 4 Knoten Exportieren und Importieren
Anfang Ebene 4 Knoten Replikation und High-Availability Replikation und High-Availability Ende Ebene 4 Knoten Replikation und High-Availability
Anfang Ebene 5 Knoten Datenbankkopie Datenbankkopie Ende Ebene 5 Knoten Datenbankkopie
Anfang Ebene 6 Knoten Kompatible Prozessorarchitekturen für Datenbankkopien Kompatible Prozessorarchitekturen für Datenbankkopien Ende Ebene 6 Knoten Kompatible Prozessorarchitekturen für Datenbankkopien
Anfang Ebene 5 Knoten Schattendatenbank Schattendatenbank Ende Ebene 5 Knoten Schattendatenbank
Anfang Ebene 6 Knoten Einrichten einer Schatteninstanz Einrichten einer Schatteninstanz Ende Ebene 6 Knoten Einrichten einer Schatteninstanz
Anfang Ebene 6 Knoten Aktualisieren der Schatteninstanz Aktualisieren der Schatteninstanz Ende Ebene 6 Knoten Aktualisieren der Schatteninstanz
Anfang Ebene 6 Knoten Inbetriebnahme der Schatteninstanz als aktive Instanz Inbetriebnahme der Schatteninstanz als aktive Instanz Ende Ebene 6 Knoten Inbetriebnahme der Schatteninstanz als aktive Instanz
Anfang Ebene 5 Knoten Hot-Standby Hot-Standby Ende Ebene 5 Knoten Hot-Standby
Anfang Ebene 6 Knoten Systemanforderungen für ein Hot-Standby-System Systemanforderungen für ein Hot-Standby-System Ende Ebene 6 Knoten Systemanforderungen für ein Hot-Standby-System
Anfang Ebene 6 Knoten Architektur eines Hot-Standby-Systems Architektur eines Hot-Standby-Systems Ende Ebene 6 Knoten Architektur eines Hot-Standby-Systems
Anfang Ebene 6 Knoten Synchronisation von Master- und Standby-Instanzen Synchronisation von Master- und Standby-Instanzen Ende Ebene 6 Knoten Synchronisation von Master- und Standby-Instanzen
Anfang Ebene 6 Knoten Verhalten des Hot-Standby-Systems im Fehlerfall Verhalten des Hot-Standby-Systems im Fehlerfall Ende Ebene 6 Knoten Verhalten des Hot-Standby-Systems im Fehlerfall
Anfang Ebene 5 Knoten Synchronisation Synchronisation Ende Ebene 5 Knoten Synchronisation
Anfang Ebene 3 Knoten Überwachung Überwachung Ende Ebene 3 Knoten Überwachung
Anfang Ebene 3 Knoten Performance Performance Ende Ebene 3 Knoten Performance
Anfang Ebene 4 Knoten Performance-Engpässe analysieren Performance-Engpässe analysieren Ende Ebene 4 Knoten Performance-Engpässe analysieren
Anfang Ebene 4 Knoten Automatisches Umformen von SQL-Anweisungen Automatisches Umformen von SQL-Anweisungen Ende Ebene 4 Knoten Automatisches Umformen von SQL-Anweisungen
Anfang Ebene 4 Knoten SQL-Optimierer SQL-Optimierer Ende Ebene 4 Knoten SQL-Optimierer
Anfang Ebene 5 Knoten Arbeitsweise des SQL-Optimierers Arbeitsweise des SQL-Optimierers Ende Ebene 5 Knoten Arbeitsweise des SQL-Optimierers
Anfang Ebene 6 Knoten Suchbedingungen Suchbedingungen Ende Ebene 6 Knoten Suchbedingungen
Anfang Ebene 7 Knoten Gleichheitsbedingung Gleichheitsbedingung Ende Ebene 7 Knoten Gleichheitsbedingung
Anfang Ebene 7 Knoten Bereichsbedingung Bereichsbedingung Ende Ebene 7 Knoten Bereichsbedingung
Anfang Ebene 7 Knoten IN-Bedingung IN-Bedingung Ende Ebene 7 Knoten IN-Bedingung
Anfang Ebene 7 Knoten LIKE-Bedingung LIKE-Bedingung Ende Ebene 7 Knoten LIKE-Bedingung
Anfang Ebene 7 Knoten Einschränkungen für UPDATE-Anweisungen Einschränkungen für UPDATE-Anweisungen Ende Ebene 7 Knoten Einschränkungen für UPDATE-Anweisungen
Anfang Ebene 6 Knoten Kostenermittlung Kostenermittlung Ende Ebene 6 Knoten Kostenermittlung
Anfang Ebene 6 Knoten Statistiken des SQL-Optimierers Statistiken des SQL-Optimierers Ende Ebene 6 Knoten Statistiken des SQL-Optimierers
Anfang Ebene 6 Knoten Suchstrategien Suchstrategien Ende Ebene 6 Knoten Suchstrategien
Anfang Ebene 7 Knoten Sequentielle Suche Sequentielle Suche Ende Ebene 7 Knoten Sequentielle Suche
Anfang Ebene 7 Knoten Suchbedingungen für Schlüsselspalten Suchbedingungen für Schlüsselspalten Ende Ebene 7 Knoten Suchbedingungen für Schlüsselspalten
Anfang Ebene 7 Knoten Suchbedingungen für indizierte Spalten Suchbedingungen für indizierte Spalten Ende Ebene 7 Knoten Suchbedingungen für indizierte Spalten
Anfang Ebene 7 Knoten Mit OR verknüpfte Suchbedingungen Mit OR verknüpfte Suchbedingungen Ende Ebene 7 Knoten Mit OR verknüpfte Suchbedingungen
Anfang Ebene 7 Knoten Verlagerung der Suche auf den FETCH-Zeitpunkt Verlagerung der Suche auf den FETCH-Zeitpunkt Ende Ebene 7 Knoten Verlagerung der Suche auf den FETCH-Zeitpunkt
Anfang Ebene 7 Knoten Joins Joins Ende Ebene 7 Knoten Joins
Anfang Ebene 8 Knoten Datenbankparameter JOIN_SEARCH_LEVEL Datenbankparameter JOIN_SEARCH_LEVEL Ende Ebene 8 Knoten Datenbankparameter JOIN_SEARCH_LEVEL
Anfang Ebene 7 Knoten Liste aller Suchstrategien Liste aller Suchstrategien Ende Ebene 7 Knoten Liste aller Suchstrategien
Anfang Ebene 8 Knoten CATALOG KEY ACCESS CATALOG KEY ACCESS Ende Ebene 8 Knoten CATALOG KEY ACCESS
Anfang Ebene 8 Knoten CATALOG SCAN CATALOG SCAN Ende Ebene 8 Knoten CATALOG SCAN
Anfang Ebene 8 Knoten CATALOG SCAN USING USER EQUAL CONDITION CATALOG SCAN USING USER EQUAL CONDITION Ende Ebene 8 Knoten CATALOG SCAN USING USER EQUAL CONDITION
Anfang Ebene 8 Knoten DIFFERENT STRATEGIES FOR OR-TERMS DIFFERENT STRATEGIES FOR OR-TERMS Ende Ebene 8 Knoten DIFFERENT STRATEGIES FOR OR-TERMS
Anfang Ebene 8 Knoten EQUAL CONDITION FOR INDEX EQUAL CONDITION FOR INDEX Ende Ebene 8 Knoten EQUAL CONDITION FOR INDEX
Anfang Ebene 8 Knoten EQUAL CONDITION FOR KEY EQUAL CONDITION FOR KEY Ende Ebene 8 Knoten EQUAL CONDITION FOR KEY
Anfang Ebene 8 Knoten IN CONDITION FOR INDEX IN CONDITION FOR INDEX Ende Ebene 8 Knoten IN CONDITION FOR INDEX
Anfang Ebene 8 Knoten IN CONDITION FOR KEY IN CONDITION FOR KEY Ende Ebene 8 Knoten IN CONDITION FOR KEY
Anfang Ebene 8 Knoten INDEX SCAN INDEX SCAN Ende Ebene 8 Knoten INDEX SCAN
Anfang Ebene 8 Knoten JOIN VIA INDEXED COLUMN JOIN VIA INDEXED COLUMN Ende Ebene 8 Knoten JOIN VIA INDEXED COLUMN
Anfang Ebene 8 Knoten JOIN VIA KEY COLUMN JOIN VIA KEY COLUMN Ende Ebene 8 Knoten JOIN VIA KEY COLUMN
Anfang Ebene 8 Knoten JOIN VIA KEY RANGE JOIN VIA KEY RANGE Ende Ebene 8 Knoten JOIN VIA KEY RANGE
Anfang Ebene 8 Knoten JOIN VIA MULTIPLE INDEXED COLUMNS JOIN VIA MULTIPLE INDEXED COLUMNS Ende Ebene 8 Knoten JOIN VIA MULTIPLE INDEXED COLUMNS
Anfang Ebene 8 Knoten JOIN VIA MULTIPLE KEY COLUMNS JOIN VIA MULTIPLE KEY COLUMNS Ende Ebene 8 Knoten JOIN VIA MULTIPLE KEY COLUMNS
Anfang Ebene 8 Knoten JOIN VIA RANGE OF MULTIPLE INDEXED COL. JOIN VIA RANGE OF MULTIPLE INDEXED COL. Ende Ebene 8 Knoten JOIN VIA RANGE OF MULTIPLE INDEXED COL.
Anfang Ebene 8 Knoten JOIN VIA RANGE OF MULTIPLE KEY COLUMNS JOIN VIA RANGE OF MULTIPLE KEY COLUMNS Ende Ebene 8 Knoten JOIN VIA RANGE OF MULTIPLE KEY COLUMNS
Anfang Ebene 8 Knoten NO RESULT SET POSSIBLE NO RESULT SET POSSIBLE Ende Ebene 8 Knoten NO RESULT SET POSSIBLE
Anfang Ebene 8 Knoten NO STRATEGY NOW (ONLY AT EXECUTION TIME) NO STRATEGY NOW (ONLY AT EXECUTION TIME) Ende Ebene 8 Knoten NO STRATEGY NOW (ONLY AT EXECUTION TIME)
Anfang Ebene 8 Knoten RANGE CONDITION FOR INDEX RANGE CONDITION FOR INDEX Ende Ebene 8 Knoten RANGE CONDITION FOR INDEX
Anfang Ebene 8 Knoten RANGE CONDITION FOR KEY RANGE CONDITION FOR KEY Ende Ebene 8 Knoten RANGE CONDITION FOR KEY
Anfang Ebene 8 Knoten SUBQ CONDITION FOR INDEX SUBQ CONDITION FOR INDEX Ende Ebene 8 Knoten SUBQ CONDITION FOR INDEX
Anfang Ebene 8 Knoten SUBQ CONDITION FOR KEY SUBQ CONDITION FOR KEY Ende Ebene 8 Knoten SUBQ CONDITION FOR KEY
Anfang Ebene 8 Knoten TABLE SCAN TABLE SCAN Ende Ebene 8 Knoten TABLE SCAN
Anfang Ebene 5 Knoten Problemanalyse Problemanalyse Ende Ebene 5 Knoten Problemanalyse
Anfang Ebene 6 Knoten EXPLAIN-Anweisung EXPLAIN-Anweisung Ende Ebene 6 Knoten EXPLAIN-Anweisung
Anfang Ebene 7 Knoten EXPLAIN-Anweisung für Joins EXPLAIN-Anweisung für Joins Ende Ebene 7 Knoten EXPLAIN-Anweisung für Joins
Anfang Ebene 7 Knoten EXPLAIN-Anweisung für komplizierte SELECT-Anweisungen EXPLAIN-Anweisung für komplizierte SELECT-Anweisungen Ende Ebene 7 Knoten EXPLAIN-Anweisung für komplizierte SELECT-Anweisungen
Anfang Ebene 7 Knoten EXPLAIN-Anweisung für SELECT-Anweisungen mit Unterabfragen EXPLAIN-Anweisung für SELECT-Anweisungen mit Unterabfragen Ende Ebene 7 Knoten EXPLAIN-Anweisung für SELECT-Anweisungen mit Unterabfragen
Anfang Ebene 7 Knoten Spalte STRATEGY Spalte STRATEGY Ende Ebene 7 Knoten Spalte STRATEGY
Anfang Ebene 3 Knoten Fehlersuche Fehlersuche Ende Ebene 3 Knoten Fehlersuche
Anfang Ebene 4 Knoten Typische Fehlersituationen Typische Fehlersituationen Ende Ebene 4 Knoten Typische Fehlersituationen
Anfang Ebene 4 Knoten Protokolldateien Protokolldateien Ende Ebene 4 Knoten Protokolldateien
Anfang Ebene 4 Knoten Traces Traces Ende Ebene 4 Knoten Traces
Anfang Ebene 4 Knoten Datenbankstrukturen prüfen Datenbankstrukturen prüfen Ende Ebene 4 Knoten Datenbankstrukturen prüfen
Anfang Ebene 5 Knoten Fehler in der Datenstruktur beheben Fehler in der Datenstruktur beheben Ende Ebene 5 Knoten Fehler in der Datenstruktur beheben
Anfang Ebene 5 Knoten Beispiel: Fehler in der Datenstruktur Beispiel: Fehler in der Datenstruktur Ende Ebene 5 Knoten Beispiel: Fehler in der Datenstruktur
Anfang Ebene 3 Knoten Entwicklung von Datenbankanwendungen Entwicklung von Datenbankanwendungen Ende Ebene 3 Knoten Entwicklung von Datenbankanwendungen
Anfang Ebene 2 Knoten Glossar Glossar Ende Ebene 2 Knoten Glossar
Anfang Ebene 3 Knoten A A Ende Ebene 3 Knoten A
Anfang Ebene 3 Knoten Verwaltung Verwaltung Ende Ebene 3 Knoten Verwaltung
Anfang Ebene 3 Knoten After-Image After-Image Ende Ebene 3 Knoten After-Image
Anfang Ebene 3 Knoten Anwendungsdaten Anwendungsdaten Ende Ebene 3 Knoten Anwendungsdaten
Anfang Ebene 3 Knoten Architektur Architektur Ende Ebene 3 Knoten Architektur
Anfang Ebene 3 Knoten ASCII ASCII Ende Ebene 3 Knoten ASCII
Anfang Ebene 3 Knoten Authentifizierung Authentifizierung Ende Ebene 3 Knoten Authentifizierung
Anfang Ebene 3 Knoten Berechtigung Berechtigung Ende Ebene 3 Knoten Berechtigung
Anfang Ebene 3 Knoten AUTOCOMMIT-Modus AUTOCOMMIT-Modus Ende Ebene 3 Knoten AUTOCOMMIT-Modus
Anfang Ebene 3 Knoten Automatische Log-Sicherung Automatische Log-Sicherung Ende Ebene 3 Knoten Automatische Log-Sicherung
Anfang Ebene 3 Knoten Automatischer Start Automatischer Start Ende Ebene 3 Knoten Automatischer Start
Anfang Ebene 3 Knoten Automatisierung Automatisierung Ende Ebene 3 Knoten Automatisierung
Anfang Ebene 3 Knoten B B Ende Ebene 3 Knoten B
Anfang Ebene 3 Knoten B*-Baum B*-Baum Ende Ebene 3 Knoten B*-Baum
Anfang Ebene 3 Knoten Backint for MaxDB Backint for MaxDB Ende Ebene 3 Knoten Backint for MaxDB
Anfang Ebene 3 Knoten Sichern Sichern Ende Ebene 3 Knoten Sichern
Anfang Ebene 3 Knoten Sicherungsdatei Sicherungsdatei Ende Ebene 3 Knoten Sicherungsdatei
Anfang Ebene 3 Knoten Sicherungshistorie Sicherungshistorie Ende Ebene 3 Knoten Sicherungshistorie
Anfang Ebene 3 Knoten Sicherungskennung Sicherungskennung Ende Ebene 3 Knoten Sicherungskennung
Anfang Ebene 3 Knoten Sicherungsmedium Sicherungsmedium Ende Ebene 3 Knoten Sicherungsmedium
Anfang Ebene 3 Knoten Sicherungsvorlage Sicherungsvorlage Ende Ebene 3 Knoten Sicherungsvorlage
Anfang Ebene 3 Knoten Sicherungswerkzeug Sicherungswerkzeug Ende Ebene 3 Knoten Sicherungswerkzeug
Anfang Ebene 3 Knoten Sicherungsart Sicherungsart Ende Ebene 3 Knoten Sicherungsart
Anfang Ebene 3 Knoten Before-Image Before-Image Ende Ebene 3 Knoten Before-Image
Anfang Ebene 3 Knoten BLOB BLOB Ende Ebene 3 Knoten BLOB
Anfang Ebene 3 Knoten C C Ende Ebene 3 Knoten C
Anfang Ebene 3 Knoten Cache Cache Ende Ebene 3 Knoten Cache
Anfang Ebene 3 Knoten Catalog-Cache Catalog-Cache Ende Ebene 3 Knoten Catalog-Cache
Anfang Ebene 3 Knoten Checkpoint Checkpoint Ende Ebene 3 Knoten Checkpoint
Anfang Ebene 3 Knoten CLOB CLOB Ende Ebene 3 Knoten CLOB
Anfang Ebene 3 Knoten Codeattribut Codeattribut Ende Ebene 3 Knoten Codeattribut
Anfang Ebene 3 Knoten Spalte Spalte Ende Ebene 3 Knoten Spalte
Anfang Ebene 3 Knoten Kommandomodus Kommandomodus Ende Ebene 3 Knoten Kommandomodus
Anfang Ebene 3 Knoten Kommandomonitor Kommandomonitor Ende Ebene 3 Knoten Kommandomonitor
Anfang Ebene 3 Knoten COMMIT COMMIT Ende Ebene 3 Knoten COMMIT
Anfang Ebene 3 Knoten Kommunikationsserver Kommunikationsserver Ende Ebene 3 Knoten Kommunikationsserver
Anfang Ebene 3 Knoten Vollständige Datensicherung Vollständige Datensicherung Ende Ebene 3 Knoten Vollständige Datensicherung
Anfang Ebene 3 Knoten Komponentengruppe Komponentengruppe Ende Ebene 3 Knoten Komponentengruppe
Anfang Ebene 3 Knoten Konfiguration Konfiguration Ende Ebene 3 Knoten Konfiguration
Anfang Ebene 3 Knoten Konfigurationsverzeichnis Konfigurationsverzeichnis Ende Ebene 3 Knoten Konfigurationsverzeichnis
Anfang Ebene 3 Knoten Konfigurationsdatei Konfigurationsdatei Ende Ebene 3 Knoten Konfigurationsdatei
Anfang Ebene 3 Knoten Konsistente Sicht Konsistente Sicht Ende Ebene 3 Knoten Konsistente Sicht
Anfang Ebene 3 Knoten Constraint Constraint Ende Ebene 3 Knoten Constraint
Anfang Ebene 3 Knoten Kontrollstruktur Kontrollstruktur Ende Ebene 3 Knoten Kontrollstruktur
Anfang Ebene 3 Knoten Converter Converter Ende Ebene 3 Knoten Converter
Anfang Ebene 3 Knoten Kosten Kosten Ende Ebene 3 Knoten Kosten
Anfang Ebene 3 Knoten Kritischer Abschnitt Kritischer Abschnitt Ende Ebene 3 Knoten Kritischer Abschnitt
Anfang Ebene 3 Knoten Cursor Cursor Ende Ebene 3 Knoten Cursor
Anfang Ebene 3 Knoten D D Ende Ebene 3 Knoten D
Anfang Ebene 3 Knoten Datenzugriff Datenzugriff Ende Ebene 3 Knoten Datenzugriff
Anfang Ebene 3 Knoten Datenbereich Datenbereich Ende Ebene 3 Knoten Datenbereich
Anfang Ebene 3 Knoten Datensicherung Datensicherung Ende Ebene 3 Knoten Datensicherung
Anfang Ebene 3 Knoten Data-Cache Data-Cache Ende Ebene 3 Knoten Data-Cache
Anfang Ebene 3 Knoten Datenträger Datenträger Ende Ebene 3 Knoten Datenträger
Anfang Ebene 3 Knoten Datenintegrität Datenintegrität Ende Ebene 3 Knoten Datenintegrität
Anfang Ebene 3 Knoten Datensatz Datensatz Ende Ebene 3 Knoten Datensatz
Anfang Ebene 3 Knoten Datentyp Datentyp Ende Ebene 3 Knoten Datentyp
Anfang Ebene 3 Knoten Data-Volume Data-Volume Ende Ebene 3 Knoten Data-Volume
Anfang Ebene 3 Knoten Data-Writer Data-Writer Ende Ebene 3 Knoten Data-Writer
Anfang Ebene 3 Knoten Datenbank Datenbank Ende Ebene 3 Knoten Datenbank
Anfang Ebene 3 Knoten Datenbankadministrator (DBA-Benutzer) Datenbankadministrator (DBA-Benutzer) Ende Ebene 3 Knoten Datenbankadministrator (DBA-Benutzer)
Anfang Ebene 3 Knoten Database Analyzer Database Analyzer Ende Ebene 3 Knoten Database Analyzer
Anfang Ebene 3 Knoten Datenbankanwendung Datenbankanwendung Ende Ebene 3 Knoten Datenbankanwendung
Anfang Ebene 3 Knoten Datenbankkatalog Datenbankkatalog Ende Ebene 3 Knoten Datenbankkatalog
Anfang Ebene 3 Knoten Datenbankverbindung Datenbankverbindung Ende Ebene 3 Knoten Datenbankverbindung
Anfang Ebene 3 Knoten Datenbankkopie Datenbankkopie Ende Ebene 3 Knoten Datenbankkopie
Anfang Ebene 3 Knoten Datenbankdesign Datenbankdesign Ende Ebene 3 Knoten Datenbankdesign
Anfang Ebene 3 Knoten Datenbankdatei Datenbankdatei Ende Ebene 3 Knoten Datenbankdatei
Anfang Ebene 3 Knoten Datenbankfunktion Datenbankfunktion Ende Ebene 3 Knoten Datenbankfunktion
Anfang Ebene 3 Knoten Datenbank-ID Datenbank-ID Ende Ebene 3 Knoten Datenbank-ID
Anfang Ebene 3 Knoten Datenbankinstanz Datenbankinstanz Ende Ebene 3 Knoten Datenbankinstanz
Anfang Ebene 3 Knoten Database Manager Database Manager Ende Ebene 3 Knoten Database Manager
Anfang Ebene 3 Knoten Database Manager-Benutzer (DBM-Benutzer) Database Manager-Benutzer (DBM-Benutzer) Ende Ebene 3 Knoten Database Manager-Benutzer (DBM-Benutzer)
Anfang Ebene 3 Knoten Datenbankname Datenbankname Ende Ebene 3 Knoten Datenbankname
Anfang Ebene 3 Knoten Datenbankobjekt Datenbankobjekt Ende Ebene 3 Knoten Datenbankobjekt
Anfang Ebene 3 Knoten Datenbankparameter Datenbankparameter Ende Ebene 3 Knoten Datenbankparameter
Anfang Ebene 3 Knoten Datenbankprozedur Datenbankprozedur Ende Ebene 3 Knoten Datenbankprozedur
Anfang Ebene 3 Knoten Datenbanksitzung Datenbanksitzung Ende Ebene 3 Knoten Datenbanksitzung
Anfang Ebene 3 Knoten Datenbankstruktur Datenbankstruktur Ende Ebene 3 Knoten Datenbankstruktur
Anfang Ebene 3 Knoten Datenbanksystem Datenbanksystem Ende Ebene 3 Knoten Datenbanksystem
Anfang Ebene 3 Knoten Datenbanksystemadministrator (SYSDBA-Benutzer) Datenbanksystemadministrator (SYSDBA-Benutzer) Ende Ebene 3 Knoten Datenbanksystemadministrator (SYSDBA-Benutzer)
Anfang Ebene 3 Knoten Datenbankwerkzeug Datenbankwerkzeug Ende Ebene 3 Knoten Datenbankwerkzeug
Anfang Ebene 3 Knoten Datenbank-Trace Datenbank-Trace Ende Ebene 3 Knoten Datenbank-Trace
Anfang Ebene 3 Knoten Datenbankbenutzer Datenbankbenutzer Ende Ebene 3 Knoten Datenbankbenutzer
Anfang Ebene 3 Knoten DBA DBA Ende Ebene 3 Knoten DBA
Anfang Ebene 3 Knoten DBA-Einplanungskalender DBA-Einplanungskalender Ende Ebene 3 Knoten DBA-Einplanungskalender
Anfang Ebene 3 Knoten DBADMIN DBADMIN Ende Ebene 3 Knoten DBADMIN
Anfang Ebene 3 Knoten DBM-Kommando DBM-Kommando Ende Ebene 3 Knoten DBM-Kommando
Anfang Ebene 3 Knoten DBM-Benutzer DBM-Benutzer Ende Ebene 3 Knoten DBM-Benutzer
Anfang Ebene 3 Knoten DBM-Benutzereigenschaften DBM-Benutzereigenschaften Ende Ebene 3 Knoten DBM-Benutzereigenschaften
Anfang Ebene 3 Knoten DBM-Option DBM-Option Ende Ebene 3 Knoten DBM-Option
Anfang Ebene 3 Knoten DBM-Server DBM-Server Ende Ebene 3 Knoten DBM-Server
Anfang Ebene 3 Knoten DBMCLI DBMCLI Ende Ebene 3 Knoten DBMCLI
Anfang Ebene 3 Knoten DBMGUI DBMGUI Ende Ebene 3 Knoten DBMGUI
Anfang Ebene 3 Knoten DDL-Anweisung DDL-Anweisung Ende Ebene 3 Knoten DDL-Anweisung
Anfang Ebene 3 Knoten Vorschlagsparameterdatei Vorschlagsparameterdatei Ende Ebene 3 Knoten Vorschlagsparameterdatei
Anfang Ebene 3 Knoten Demo-Datenbank Demo-Datenbank Ende Ebene 3 Knoten Demo-Datenbank
Anfang Ebene 3 Knoten Entwicklung Entwicklung Ende Ebene 3 Knoten Entwicklung
Anfang Ebene 3 Knoten Verzeichnisstruktur Verzeichnisstruktur Ende Ebene 3 Knoten Verzeichnisstruktur
Anfang Ebene 3 Knoten Dokumentation Dokumentation Ende Ebene 3 Knoten Dokumentation
Anfang Ebene 3 Knoten Variablen in der Dokumentation Variablen in der Dokumentation Ende Ebene 3 Knoten Variablen in der Dokumentation
Anfang Ebene 3 Knoten Wertebereich Wertebereich Ende Ebene 3 Knoten Wertebereich
Anfang Ebene 3 Knoten Download Download Ende Ebene 3 Knoten Download
Anfang Ebene 3 Knoten E E Ende Ebene 3 Knoten E
Anfang Ebene 3 Knoten Verschlüsselung Verschlüsselung Ende Ebene 3 Knoten Verschlüsselung
Anfang Ebene 3 Knoten Umgebungsvariable Umgebungsvariable Ende Ebene 3 Knoten Umgebungsvariable
Anfang Ebene 3 Knoten Fehlermeldung Fehlermeldung Ende Ebene 3 Knoten Fehlermeldung
Anfang Ebene 3 Knoten Event Event Ende Ebene 3 Knoten Event
Anfang Ebene 3 Knoten Event-Dispatcher Event-Dispatcher Ende Ebene 3 Knoten Event-Dispatcher
Anfang Ebene 3 Knoten Beispiel Beispiel Ende Ebene 3 Knoten Beispiel
Anfang Ebene 3 Knoten Schreibsperre Schreibsperre Ende Ebene 3 Knoten Schreibsperre
Anfang Ebene 3 Knoten Ausführungsplan Ausführungsplan Ende Ebene 3 Knoten Ausführungsplan
Anfang Ebene 3 Knoten EXPLAIN-Anweisung EXPLAIN-Anweisung Ende Ebene 3 Knoten EXPLAIN-Anweisung
Anfang Ebene 3 Knoten Exportieren Exportieren Ende Ebene 3 Knoten Exportieren
Anfang Ebene 3 Knoten Externes Sicherungswerkzeug Externes Sicherungswerkzeug Ende Ebene 3 Knoten Externes Sicherungswerkzeug
Anfang Ebene 3 Knoten F F Ende Ebene 3 Knoten F
Anfang Ebene 3 Knoten FBM (Free Block Management) FBM (Free Block Management) Ende Ebene 3 Knoten FBM (Free Block Management)
Anfang Ebene 3 Knoten Dateiklasse Dateiklasse Ende Ebene 3 Knoten Dateiklasse
Anfang Ebene 3 Knoten Dateiverzeichnis Dateiverzeichnis Ende Ebene 3 Knoten Dateiverzeichnis
Anfang Ebene 3 Knoten Datei-ID Datei-ID Ende Ebene 3 Knoten Datei-ID
Anfang Ebene 3 Knoten Fremdschlüssel Fremdschlüssel Ende Ebene 3 Knoten Fremdschlüssel
Anfang Ebene 3 Knoten G G Ende Ebene 3 Knoten G
Anfang Ebene 3 Knoten Garbage-Collector Garbage-Collector Ende Ebene 3 Knoten Garbage-Collector
Anfang Ebene 3 Knoten H H Ende Ebene 3 Knoten H
Anfang Ebene 3 Knoten High-Availability High-Availability Ende Ebene 3 Knoten High-Availability
Anfang Ebene 3 Knoten History-Datei History-Datei Ende Ebene 3 Knoten History-Datei
Anfang Ebene 3 Knoten Trefferquote Trefferquote Ende Ebene 3 Knoten Trefferquote
Anfang Ebene 3 Knoten Homogene Systemkopie Homogene Systemkopie Ende Ebene 3 Knoten Homogene Systemkopie
Anfang Ebene 3 Knoten Hot-Standby Hot-Standby Ende Ebene 3 Knoten Hot-Standby
Anfang Ebene 3 Knoten I I Ende Ebene 3 Knoten I
Anfang Ebene 3 Knoten I/O-Buffer-Cache I/O-Buffer-Cache Ende Ebene 3 Knoten I/O-Buffer-Cache
Anfang Ebene 3 Knoten Importieren Importieren Ende Ebene 3 Knoten Importieren
Anfang Ebene 3 Knoten Inkrementelle Datensicherung Inkrementelle Datensicherung Ende Ebene 3 Knoten Inkrementelle Datensicherung
Anfang Ebene 3 Knoten Index Index Ende Ebene 3 Knoten Index
Anfang Ebene 3 Knoten Indizierte Spalte Indizierte Spalte Ende Ebene 3 Knoten Indizierte Spalte
Anfang Ebene 3 Knoten Initialisieren Initialisieren Ende Ebene 3 Knoten Initialisieren
Anfang Ebene 3 Knoten Installation Installation Ende Ebene 3 Knoten Installation
Anfang Ebene 3 Knoten Installation Manager Installation Manager Ende Ebene 3 Knoten Installation Manager
Anfang Ebene 3 Knoten Installationsprofil Installationsprofil Ende Ebene 3 Knoten Installationsprofil
Anfang Ebene 3 Knoten Interaktive Log-Sicherung Interaktive Log-Sicherung Ende Ebene 3 Knoten Interaktive Log-Sicherung
Anfang Ebene 3 Knoten Schnittstelle Schnittstelle Ende Ebene 3 Knoten Schnittstelle
Anfang Ebene 3 Knoten Datenbankinterne Datei Datenbankinterne Datei Ende Ebene 3 Knoten Datenbankinterne Datei
Anfang Ebene 3 Knoten Invertierungsliste Invertierungsliste Ende Ebene 3 Knoten Invertierungsliste
Anfang Ebene 3 Knoten Invertierte Spalte Invertierte Spalte Ende Ebene 3 Knoten Invertierte Spalte
Anfang Ebene 3 Knoten Isolation-Level Isolation-Level Ende Ebene 3 Knoten Isolation-Level
Anfang Ebene 3 Knoten J J Ende Ebene 3 Knoten J
Anfang Ebene 3 Knoten Java Java Ende Ebene 3 Knoten Java
Anfang Ebene 3 Knoten JDBC JDBC Ende Ebene 3 Knoten JDBC
Anfang Ebene 3 Knoten Join Join Ende Ebene 3 Knoten Join
Anfang Ebene 3 Knoten K K Ende Ebene 3 Knoten K
Anfang Ebene 3 Knoten Kern Kern Ende Ebene 3 Knoten Kern
Anfang Ebene 3 Knoten Kernprotokoll Kernprotokoll Ende Ebene 3 Knoten Kernprotokoll
Anfang Ebene 3 Knoten Kernvariante Kernvariante Ende Ebene 3 Knoten Kernvariante
Anfang Ebene 3 Knoten Schlüsselwort Schlüsselwort Ende Ebene 3 Knoten Schlüsselwort
Anfang Ebene 3 Knoten KNLDIAG KNLDIAG Ende Ebene 3 Knoten KNLDIAG
Anfang Ebene 3 Knoten L L Ende Ebene 3 Knoten L
Anfang Ebene 3 Knoten Sprachunterstützung (Mapchar-Sets) Sprachunterstützung (Mapchar-Sets) Ende Ebene 3 Knoten Sprachunterstützung (Mapchar-Sets)
Anfang Ebene 3 Knoten Blattseite Blattseite Ende Ebene 3 Knoten Blattseite
Anfang Ebene 3 Knoten liveCache (SAP liveCache-Technologie) liveCache (SAP liveCache-Technologie) Ende Ebene 3 Knoten liveCache (SAP liveCache-Technologie)
Anfang Ebene 3 Knoten Load-Balancing Load-Balancing Ende Ebene 3 Knoten Load-Balancing
Anfang Ebene 3 Knoten Loader Loader Ende Ebene 3 Knoten Loader
Anfang Ebene 3 Knoten Loader-Server Loader-Server Ende Ebene 3 Knoten Loader-Server
Anfang Ebene 3 Knoten Laden Laden Ende Ebene 3 Knoten Laden
Anfang Ebene 3 Knoten LOB LOB Ende Ebene 3 Knoten LOB
Anfang Ebene 3 Knoten Sperre Sperre Ende Ebene 3 Knoten Sperre
Anfang Ebene 3 Knoten Sperrliste Sperrliste Ende Ebene 3 Knoten Sperrliste
Anfang Ebene 3 Knoten Log-Bereich Log-Bereich Ende Ebene 3 Knoten Log-Bereich
Anfang Ebene 3 Knoten Log-Sicherung Log-Sicherung Ende Ebene 3 Knoten Log-Sicherung
Anfang Ebene 3 Knoten Log-Eintrag Log-Eintrag Ende Ebene 3 Knoten Log-Eintrag
Anfang Ebene 3 Knoten Protokolldatei Protokolldatei Ende Ebene 3 Knoten Protokolldatei
Anfang Ebene 3 Knoten Log-Modus Log-Modus Ende Ebene 3 Knoten Log-Modus
Anfang Ebene 3 Knoten Log-Seite Log-Seite Ende Ebene 3 Knoten Log-Seite
Anfang Ebene 3 Knoten Log-Warteschlange Log-Warteschlange Ende Ebene 3 Knoten Log-Warteschlange
Anfang Ebene 3 Knoten Log-Leser Log-Leser Ende Ebene 3 Knoten Log-Leser
Anfang Ebene 3 Knoten Log-Segment Log-Segment Ende Ebene 3 Knoten Log-Segment
Anfang Ebene 3 Knoten Log-Einstellung Log-Einstellung Ende Ebene 3 Knoten Log-Einstellung
Anfang Ebene 3 Knoten Log-Volume Log-Volume Ende Ebene 3 Knoten Log-Volume
Anfang Ebene 3 Knoten Log-Writer Log-Writer Ende Ebene 3 Knoten Log-Writer
Anfang Ebene 3 Knoten Logging Logging Ende Ebene 3 Knoten Logging
Anfang Ebene 3 Knoten LONG-Wert LONG-Wert Ende Ebene 3 Knoten LONG-Wert
Anfang Ebene 3 Knoten M M Ende Ebene 3 Knoten M
Anfang Ebene 3 Knoten Mailing-Liste Mailing-Liste Ende Ebene 3 Knoten Mailing-Liste
Anfang Ebene 3 Knoten Mapchar-Set Mapchar-Set Ende Ebene 3 Knoten Mapchar-Set
Anfang Ebene 3 Knoten Master-Instanz Master-Instanz Ende Ebene 3 Knoten Master-Instanz
Anfang Ebene 3 Knoten MaxDB MaxDB Ende Ebene 3 Knoten MaxDB
Anfang Ebene 3 Knoten Merge Merge Ende Ebene 3 Knoten Merge
Anfang Ebene 3 Knoten Message-Server Message-Server Ende Ebene 3 Knoten Message-Server
Anfang Ebene 3 Knoten Migration Migration Ende Ebene 3 Knoten Migration
Anfang Ebene 3 Knoten Überwachung Überwachung Ende Ebene 3 Knoten Überwachung
Anfang Ebene 3 Knoten Multi-Prozessor-Konfiguration Multi-Prozessor-Konfiguration Ende Ebene 3 Knoten Multi-Prozessor-Konfiguration
Anfang Ebene 3 Knoten N N Ende Ebene 3 Knoten N
Anfang Ebene 3 Knoten Namenskonventionen Namenskonventionen Ende Ebene 3 Knoten Namenskonventionen
Anfang Ebene 3 Knoten Netzwerk Netzwerk Ende Ebene 3 Knoten Netzwerk
Anfang Ebene 3 Knoten O O Ende Ebene 3 Knoten O
Anfang Ebene 3 Knoten ODBC ODBC Ende Ebene 3 Knoten ODBC
Anfang Ebene 3 Knoten OLTP (MaxDB) OLTP (MaxDB) Ende Ebene 3 Knoten OLTP (MaxDB)
Anfang Ebene 3 Knoten OMS OMS Ende Ebene 3 Knoten OMS
Anfang Ebene 3 Knoten OMS-Heap OMS-Heap Ende Ebene 3 Knoten OMS-Heap
Anfang Ebene 3 Knoten OMS-Version OMS-Version Ende Ebene 3 Knoten OMS-Version
Anfang Ebene 3 Knoten Open-Source-Entwicklung Open-Source-Entwicklung Ende Ebene 3 Knoten Open-Source-Entwicklung
Anfang Ebene 3 Knoten Betriebssystembenutzer Betriebssystembenutzer Ende Ebene 3 Knoten Betriebssystembenutzer
Anfang Ebene 3 Knoten Betriebsmodus Betriebsmodus Ende Ebene 3 Knoten Betriebsmodus
Anfang Ebene 3 Knoten Betriebszustand Betriebszustand Ende Ebene 3 Knoten Betriebszustand
Anfang Ebene 3 Knoten Optimistische Sperre Optimistische Sperre Ende Ebene 3 Knoten Optimistische Sperre
Anfang Ebene 3 Knoten Optimierer Optimierer Ende Ebene 3 Knoten Optimierer
Anfang Ebene 3 Knoten Überschreibmodus für den Log-Bereich Überschreibmodus für den Log-Bereich Ende Ebene 3 Knoten Überschreibmodus für den Log-Bereich
Anfang Ebene 3 Knoten Eigentümer Eigentümer Ende Ebene 3 Knoten Eigentümer
Anfang Ebene 3 Knoten P P Ende Ebene 3 Knoten P
Anfang Ebene 3 Knoten Seite Seite Ende Ebene 3 Knoten Seite
Anfang Ebene 3 Knoten Seitenkette Seitenkette Ende Ebene 3 Knoten Seitenkette
Anfang Ebene 3 Knoten Pager Pager Ende Ebene 3 Knoten Pager
Anfang Ebene 3 Knoten Parallele Sicherung Parallele Sicherung Ende Ebene 3 Knoten Parallele Sicherung
Anfang Ebene 3 Knoten Parameter Parameter Ende Ebene 3 Knoten Parameter
Anfang Ebene 3 Knoten Parameterdatei Parameterdatei Ende Ebene 3 Knoten Parameterdatei
Anfang Ebene 3 Knoten Parameter in SQL-Anweisungen Parameter in SQL-Anweisungen Ende Ebene 3 Knoten Parameter in SQL-Anweisungen
Anfang Ebene 3 Knoten Performance Performance Ende Ebene 3 Knoten Performance
Anfang Ebene 3 Knoten Perl Perl Ende Ebene 3 Knoten Perl
Anfang Ebene 3 Knoten PHP PHP Ende Ebene 3 Knoten PHP
Anfang Ebene 3 Knoten Port Port Ende Ebene 3 Knoten Port
Anfang Ebene 3 Knoten Precompiler Precompiler Ende Ebene 3 Knoten Precompiler
Anfang Ebene 3 Knoten Prädikat Prädikat Ende Ebene 3 Knoten Prädikat
Anfang Ebene 3 Knoten Prepared Statement Prepared Statement Ende Ebene 3 Knoten Prepared Statement
Anfang Ebene 3 Knoten Primärschlüssel Primärschlüssel Ende Ebene 3 Knoten Primärschlüssel
Anfang Ebene 3 Knoten Privileg Privileg Ende Ebene 3 Knoten Privileg
Anfang Ebene 3 Knoten Prozess Prozess Ende Ebene 3 Knoten Prozess
Anfang Ebene 3 Knoten Programmierschnittstelle Programmierschnittstelle Ende Ebene 3 Knoten Programmierschnittstelle
Anfang Ebene 3 Knoten PTS (Problem Tracking System) PTS (Problem Tracking System) Ende Ebene 3 Knoten PTS (Problem Tracking System)
Anfang Ebene 3 Knoten Python Python Ende Ebene 3 Knoten Python
Anfang Ebene 3 Knoten Q Q Ende Ebene 3 Knoten Q
Anfang Ebene 3 Knoten Query Tool Query Tool Ende Ebene 3 Knoten Query Tool
Anfang Ebene 3 Knoten R R Ende Ebene 3 Knoten R
Anfang Ebene 3 Knoten Raw-Device Raw-Device Ende Ebene 3 Knoten Raw-Device
Anfang Ebene 3 Knoten Reader-Writer-Lock Reader-Writer-Lock Ende Ebene 3 Knoten Reader-Writer-Lock
Anfang Ebene 3 Knoten Redo-Liste Redo-Liste Ende Ebene 3 Knoten Redo-Liste
Anfang Ebene 3 Knoten Redo-Log-Eintrag Redo-Log-Eintrag Ende Ebene 3 Knoten Redo-Log-Eintrag
Anfang Ebene 3 Knoten Redo-Log-Datei Redo-Log-Datei Ende Ebene 3 Knoten Redo-Log-Datei
Anfang Ebene 3 Knoten Redo-Log-Verwaltung Redo-Log-Verwaltung Ende Ebene 3 Knoten Redo-Log-Verwaltung
Anfang Ebene 3 Knoten Redo-Log-Manager Redo-Log-Manager Ende Ebene 3 Knoten Redo-Log-Manager
Anfang Ebene 3 Knoten Redo-Task Redo-Task Ende Ebene 3 Knoten Redo-Task
Anfang Ebene 3 Knoten Region Region Ende Ebene 3 Knoten Region
Anfang Ebene 3 Knoten Reorganisation Reorganisation Ende Ebene 3 Knoten Reorganisation
Anfang Ebene 3 Knoten Replikation Replikation Ende Ebene 3 Knoten Replikation
Anfang Ebene 3 Knoten Replikationstabelle Replikationstabelle Ende Ebene 3 Knoten Replikationstabelle
Anfang Ebene 3 Knoten Replikationseinheit Replikationseinheit Ende Ebene 3 Knoten Replikationseinheit
Anfang Ebene 3 Knoten Reserviertes Wort Reserviertes Wort Ende Ebene 3 Knoten Reserviertes Wort
Anfang Ebene 3 Knoten RESOURCE-Benutzer RESOURCE-Benutzer Ende Ebene 3 Knoten RESOURCE-Benutzer
Anfang Ebene 3 Knoten Ressourcenmonitor Ressourcenmonitor Ende Ebene 3 Knoten Ressourcenmonitor
Anfang Ebene 3 Knoten Restart Restart Ende Ebene 3 Knoten Restart
Anfang Ebene 3 Knoten Restart-Information Restart-Information Ende Ebene 3 Knoten Restart-Information
Anfang Ebene 3 Knoten Wiederherstellen Wiederherstellen Ende Ebene 3 Knoten Wiederherstellen
Anfang Ebene 3 Knoten Restriktion Restriktion Ende Ebene 3 Knoten Restriktion
Anfang Ebene 3 Knoten Rolle Rolle Ende Ebene 3 Knoten Rolle
Anfang Ebene 3 Knoten ROLL FORWARD ROLL FORWARD Ende Ebene 3 Knoten ROLL FORWARD
Anfang Ebene 3 Knoten ROLLBACK ROLLBACK Ende Ebene 3 Knoten ROLLBACK
Anfang Ebene 3 Knoten Zeile Zeile Ende Ebene 3 Knoten Zeile
Anfang Ebene 3 Knoten Arbeitsverzeichnis Arbeitsverzeichnis Ende Ebene 3 Knoten Arbeitsverzeichnis
Anfang Ebene 3 Knoten S S Ende Ebene 3 Knoten S
Anfang Ebene 3 Knoten SAP DB SAP DB Ende Ebene 3 Knoten SAP DB
Anfang Ebene 3 Knoten Savepoint Savepoint Ende Ebene 3 Knoten Savepoint
Anfang Ebene 3 Knoten Scheduler Scheduler Ende Ebene 3 Knoten Scheduler
Anfang Ebene 3 Knoten Schema Schema Ende Ebene 3 Knoten Schema
Anfang Ebene 3 Knoten Skriptmodus Skriptmodus Ende Ebene 3 Knoten Skriptmodus
Anfang Ebene 3 Knoten sdb sdb Ende Ebene 3 Knoten sdb
Anfang Ebene 3 Knoten sdba sdba Ende Ebene 3 Knoten sdba
Anfang Ebene 3 Knoten Suchstrategie Suchstrategie Ende Ebene 3 Knoten Suchstrategie
Anfang Ebene 3 Knoten Sekundärschlüssel Sekundärschlüssel Ende Ebene 3 Knoten Sekundärschlüssel
Anfang Ebene 3 Knoten Selektivität Selektivität Ende Ebene 3 Knoten Selektivität
Anfang Ebene 3 Knoten Separator Separator Ende Ebene 3 Knoten Separator
Anfang Ebene 3 Knoten Sequenz Sequenz Ende Ebene 3 Knoten Sequenz
Anfang Ebene 3 Knoten Sequence-Cache Sequence-Cache Ende Ebene 3 Knoten Sequence-Cache
Anfang Ebene 3 Knoten Serverberechtigung Serverberechtigung Ende Ebene 3 Knoten Serverberechtigung
Anfang Ebene 3 Knoten Server-Task Server-Task Ende Ebene 3 Knoten Server-Task
Anfang Ebene 3 Knoten Dienst Dienst Ende Ebene 3 Knoten Dienst
Anfang Ebene 3 Knoten Service-Datenbankinstanz Service-Datenbankinstanz Ende Ebene 3 Knoten Service-Datenbankinstanz
Anfang Ebene 3 Knoten Service-Sitzung Service-Sitzung Ende Ebene 3 Knoten Service-Sitzung
Anfang Ebene 3 Knoten Sitzungsmodus Sitzungsmodus Ende Ebene 3 Knoten Sitzungsmodus
Anfang Ebene 3 Knoten Lesesperre Lesesperre Ende Ebene 3 Knoten Lesesperre
Anfang Ebene 3 Knoten Shared-Memory Shared-Memory Ende Ebene 3 Knoten Shared-Memory
Anfang Ebene 3 Knoten Shared-SQL Shared-SQL Ende Ebene 3 Knoten Shared-SQL
Anfang Ebene 3 Knoten Snapshot Snapshot Ende Ebene 3 Knoten Snapshot
Anfang Ebene 3 Knoten Softwarekomponente Softwarekomponente Ende Ebene 3 Knoten Softwarekomponente
Anfang Ebene 3 Knoten Spezial-Thread Spezial-Thread Ende Ebene 3 Knoten Spezial-Thread
Anfang Ebene 3 Knoten SQL SQL Ende Ebene 3 Knoten SQL
Anfang Ebene 3 Knoten SQL-Modus SQL-Modus Ende Ebene 3 Knoten SQL-Modus
Anfang Ebene 3 Knoten SQL-Optimierer SQL-Optimierer Ende Ebene 3 Knoten SQL-Optimierer
Anfang Ebene 3 Knoten SQL-Sitzung SQL-Sitzung Ende Ebene 3 Knoten SQL-Sitzung
Anfang Ebene 3 Knoten SQL-Anweisung SQL-Anweisung Ende Ebene 3 Knoten SQL-Anweisung
Anfang Ebene 3 Knoten SQL Studio SQL Studio Ende Ebene 3 Knoten SQL Studio
Anfang Ebene 3 Knoten SQL-Tutorial SQL-Tutorial Ende Ebene 3 Knoten SQL-Tutorial
Anfang Ebene 3 Knoten SQLCLI SQLCLI Ende Ebene 3 Knoten SQLCLI
Anfang Ebene 3 Knoten SQLDBC SQLDBC Ende Ebene 3 Knoten SQLDBC
Anfang Ebene 3 Knoten SSL/TLS SSL/TLS Ende Ebene 3 Knoten SSL/TLS
Anfang Ebene 3 Knoten STANDARD-Benutzer STANDARD-Benutzer Ende Ebene 3 Knoten STANDARD-Benutzer
Anfang Ebene 3 Knoten Schattendatenbank Schattendatenbank Ende Ebene 3 Knoten Schattendatenbank
Anfang Ebene 3 Knoten Standby-Instanz Standby-Instanz Ende Ebene 3 Knoten Standby-Instanz
Anfang Ebene 3 Knoten Starten Starten Ende Ebene 3 Knoten Starten
Anfang Ebene 3 Knoten Statistiken Statistiken Ende Ebene 3 Knoten Statistiken
Anfang Ebene 3 Knoten Stored Procedure Stored Procedure Ende Ebene 3 Knoten Stored Procedure
Anfang Ebene 3 Knoten Strategie Strategie Ende Ebene 3 Knoten Strategie
Anfang Ebene 3 Knoten Subtransaktion Subtransaktion Ende Ebene 3 Knoten Subtransaktion
Anfang Ebene 3 Knoten Support Support Ende Ebene 3 Knoten Support
Anfang Ebene 3 Knoten Synchronisation Synchronisation Ende Ebene 3 Knoten Synchronisation
Anfang Ebene 3 Knoten Synchronization Manager Synchronization Manager Ende Ebene 3 Knoten Synchronization Manager
Anfang Ebene 3 Knoten Synchronisationsbenutzer Synchronisationsbenutzer Ende Ebene 3 Knoten Synchronisationsbenutzer
Anfang Ebene 3 Knoten Synonym Synonym Ende Ebene 3 Knoten Synonym
Anfang Ebene 3 Knoten Syntaxnotation Syntaxnotation Ende Ebene 3 Knoten Syntaxnotation
Anfang Ebene 3 Knoten SYSDBA-Benutzer SYSDBA-Benutzer Ende Ebene 3 Knoten SYSDBA-Benutzer
Anfang Ebene 3 Knoten Systemausfall Systemausfall Ende Ebene 3 Knoten Systemausfall
Anfang Ebene 3 Knoten Systemkopie Systemkopie Ende Ebene 3 Knoten Systemkopie
Anfang Ebene 3 Knoten Systemvoraussetzungen Systemvoraussetzungen Ende Ebene 3 Knoten Systemvoraussetzungen
Anfang Ebene 3 Knoten Systemtabelle Systemtabelle Ende Ebene 3 Knoten Systemtabelle
Anfang Ebene 3 Knoten System-Trigger System-Trigger Ende Ebene 3 Knoten System-Trigger
Anfang Ebene 3 Knoten T T Ende Ebene 3 Knoten T
Anfang Ebene 3 Knoten Tabelle Tabelle Ende Ebene 3 Knoten Tabelle
Anfang Ebene 3 Knoten Tabellen-ID Tabellen-ID Ende Ebene 3 Knoten Tabellen-ID
Anfang Ebene 3 Knoten Tabellenname Tabellenname Ende Ebene 3 Knoten Tabellenname
Anfang Ebene 3 Knoten Task Task Ende Ebene 3 Knoten Task
Anfang Ebene 3 Knoten Task-Zustand Task-Zustand Ende Ebene 3 Knoten Task-Zustand
Anfang Ebene 3 Knoten Vorlage für eine Datenbankinstanz Vorlage für eine Datenbankinstanz Ende Ebene 3 Knoten Vorlage für eine Datenbankinstanz
Anfang Ebene 3 Knoten Thread Thread Ende Ebene 3 Knoten Thread
Anfang Ebene 3 Knoten Timeout Timeout Ende Ebene 3 Knoten Timeout
Anfang Ebene 3 Knoten Timer-Task Timer-Task Ende Ebene 3 Knoten Timer-Task
Anfang Ebene 3 Knoten Werkzeug Werkzeug Ende Ebene 3 Knoten Werkzeug
Anfang Ebene 3 Knoten Trace Trace Ende Ebene 3 Knoten Trace
Anfang Ebene 3 Knoten Trace-Writer-Task Trace-Writer-Task Ende Ebene 3 Knoten Trace-Writer-Task
Anfang Ebene 3 Knoten Transaktion Transaktion Ende Ebene 3 Knoten Transaktion
Anfang Ebene 3 Knoten Transaktionsdatei Transaktionsdatei Ende Ebene 3 Knoten Transaktionsdatei
Anfang Ebene 3 Knoten Transaktionsliste Transaktionsliste Ende Ebene 3 Knoten Transaktionsliste
Anfang Ebene 3 Knoten Trigger Trigger Ende Ebene 3 Knoten Trigger
Anfang Ebene 3 Knoten Fehlersuche Fehlersuche Ende Ebene 3 Knoten Fehlersuche
Anfang Ebene 3 Knoten Tutorial Tutorial Ende Ebene 3 Knoten Tutorial
Anfang Ebene 3 Knoten U U Ende Ebene 3 Knoten U
Anfang Ebene 3 Knoten Undo-Log-Eintrag Undo-Log-Eintrag Ende Ebene 3 Knoten Undo-Log-Eintrag
Anfang Ebene 3 Knoten Undo-Log-Datei Undo-Log-Datei Ende Ebene 3 Knoten Undo-Log-Datei
Anfang Ebene 3 Knoten Unicode Unicode Ende Ebene 3 Knoten Unicode
Anfang Ebene 3 Knoten Entladen Entladen Ende Ebene 3 Knoten Entladen
Anfang Ebene 3 Knoten Update Update Ende Ebene 3 Knoten Update
Anfang Ebene 3 Knoten Upgrade Upgrade Ende Ebene 3 Knoten Upgrade
Anfang Ebene 3 Knoten Benutzer Benutzer Ende Ebene 3 Knoten Benutzer
Anfang Ebene 3 Knoten Benutzergruppe Benutzergruppe Ende Ebene 3 Knoten Benutzergruppe
Anfang Ebene 3 Knoten User-Kernel-Thread User-Kernel-Thread Ende Ebene 3 Knoten User-Kernel-Thread
Anfang Ebene 3 Knoten Benutzerschlüssel Benutzerschlüssel Ende Ebene 3 Knoten Benutzerschlüssel
Anfang Ebene 3 Knoten User-Task User-Task Ende Ebene 3 Knoten User-Task
Anfang Ebene 3 Knoten Benutzerdefinierte Funktion Benutzerdefinierte Funktion Ende Ebene 3 Knoten Benutzerdefinierte Funktion
Anfang Ebene 3 Knoten Utility-Task Utility-Task Ende Ebene 3 Knoten Utility-Task
Anfang Ebene 3 Knoten V V Ende Ebene 3 Knoten V
Anfang Ebene 3 Knoten Variable Variable Ende Ebene 3 Knoten Variable
Anfang Ebene 3 Knoten Version Version Ende Ebene 3 Knoten Version
Anfang Ebene 3 Knoten View View Ende Ebene 3 Knoten View
Anfang Ebene 3 Knoten View-Tabelle View-Tabelle Ende Ebene 3 Knoten View-Tabelle
Anfang Ebene 3 Knoten Virtueller Rechner Virtueller Rechner Ende Ebene 3 Knoten Virtueller Rechner
Anfang Ebene 3 Knoten VMAKE VMAKE Ende Ebene 3 Knoten VMAKE
Anfang Ebene 3 Knoten Volume Volume Ende Ebene 3 Knoten Volume
Anfang Ebene 3 Knoten vserver vserver Ende Ebene 3 Knoten vserver
Anfang Ebene 3 Knoten vtrace vtrace Ende Ebene 3 Knoten vtrace
Anfang Ebene 3 Knoten W W Ende Ebene 3 Knoten W
Anfang Ebene 3 Knoten Web DBM Web DBM Ende Ebene 3 Knoten Web DBM
Anfang Ebene 3 Knoten Web Server Web Server Ende Ebene 3 Knoten Web Server
Anfang Ebene 3 Knoten Web Server Manager Web Server Manager Ende Ebene 3 Knoten Web Server Manager
Anfang Ebene 3 Knoten Web SQL Web SQL Ende Ebene 3 Knoten Web SQL
Anfang Ebene 3 Knoten Web Tool Web Tool Ende Ebene 3 Knoten Web Tool
Anfang Ebene 3 Knoten WebDAV WebDAV Ende Ebene 3 Knoten WebDAV
Anfang Ebene 3 Knoten Arbeitsspeicher Arbeitsspeicher Ende Ebene 3 Knoten Arbeitsspeicher
Anfang Ebene 3 Knoten X X Ende Ebene 3 Knoten X
Anfang Ebene 3 Knoten X-Server X-Server Ende Ebene 3 Knoten X-Server
Anfang Ebene 3 Knoten XCONS (Datenbankkonsole) XCONS (Datenbankkonsole) Ende Ebene 3 Knoten XCONS (Datenbankkonsole)
Anfang Ebene 3 Knoten XUSER XUSER Ende Ebene 3 Knoten XUSER
Anfang Ebene 3 Knoten Y Y Ende Ebene 3 Knoten Y
Anfang Ebene 3 Knoten Z Z Ende Ebene 3 Knoten Z
Anfang Ebene 3 Knoten Deutsche Sortierung - Glossar
Anfang Ebene 2 Knoten SQL-Referenzhandbuch SQL-Referenzhandbuch Ende Ebene 2 Knoten SQL-Referenzhandbuch
Anfang Ebene 3 Knoten Datendefinition Datendefinition Ende Ebene 3 Knoten Datendefinition
Anfang Ebene 4 Knoten Datenintegrität absichern Datenintegrität absichern Ende Ebene 4 Knoten Datenintegrität absichern
Anfang Ebene 4 Knoten CREATE TABLE-Anweisung (create_table_statement) CREATE TABLE-Anweisung (create_table_statement) Ende Ebene 4 Knoten CREATE TABLE-Anweisung (create_table_statement)
Anfang Ebene 5 Knoten Spaltendefinition (column_definition) Spaltendefinition (column_definition) Ende Ebene 5 Knoten Spaltendefinition (column_definition)
Anfang Ebene 6 Knoten Datentyp (data_type) Datentyp (data_type) Ende Ebene 6 Knoten Datentyp (data_type)
Anfang Ebene 7 Knoten CHAR[ACTER] CHAR[ACTER] Ende Ebene 7 Knoten CHAR[ACTER]
Anfang Ebene 7 Knoten VARCHAR VARCHAR Ende Ebene 7 Knoten VARCHAR
Anfang Ebene 7 Knoten LONG [VARCHAR] LONG [VARCHAR] Ende Ebene 7 Knoten LONG [VARCHAR]
Anfang Ebene 7 Knoten Codeattribut Codeattribut Ende Ebene 7 Knoten Codeattribut
Anfang Ebene 7 Knoten BOOLEAN BOOLEAN Ende Ebene 7 Knoten BOOLEAN
Anfang Ebene 7 Knoten FIXED FIXED Ende Ebene 7 Knoten FIXED
Anfang Ebene 7 Knoten FLOAT FLOAT Ende Ebene 7 Knoten FLOAT
Anfang Ebene 7 Knoten INT[EGER] INT[EGER] Ende Ebene 7 Knoten INT[EGER]
Anfang Ebene 7 Knoten SMALLINT SMALLINT Ende Ebene 7 Knoten SMALLINT
Anfang Ebene 7 Knoten DATE (Datumswert) DATE (Datumswert) Ende Ebene 7 Knoten DATE (Datumswert)
Anfang Ebene 7 Knoten TIME (Zeitwert) TIME (Zeitwert) Ende Ebene 7 Knoten TIME (Zeitwert)
Anfang Ebene 7 Knoten TIMESTAMP (Zeitstempelwert) TIMESTAMP (Zeitstempelwert) Ende Ebene 7 Knoten TIMESTAMP (Zeitstempelwert)
Anfang Ebene 7 Knoten NULL-Wert NULL-Wert Ende Ebene 7 Knoten NULL-Wert
Anfang Ebene 7 Knoten Spezial-NULL-Wert Spezial-NULL-Wert Ende Ebene 7 Knoten Spezial-NULL-Wert
Anfang Ebene 7 Knoten Zahl Zahl Ende Ebene 7 Knoten Zahl
Anfang Ebene 7 Knoten Zeichenkette Zeichenkette Ende Ebene 7 Knoten Zeichenkette
Anfang Ebene 6 Knoten Spaltenattribute (column_attributes) Spaltenattribute (column_attributes) Ende Ebene 6 Knoten Spaltenattribute (column_attributes)
Anfang Ebene 6 Knoten Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp Ende Ebene 6 Knoten Platzbedarf eines Spaltenwertes in Abhängigkeit vom Datentyp
Anfang Ebene 5 Knoten CONSTRAINT-Definition (constraint_definition) CONSTRAINT-Definition (constraint_definition) Ende Ebene 5 Knoten CONSTRAINT-Definition (constraint_definition)
Anfang Ebene 5 Knoten Referentielle CONSTRAINT-Definition (referential_constraint_defi Referentielle CONSTRAINT-Definition (referential_constraint_defi Ende Ebene 5 Knoten Referentielle CONSTRAINT-Definition (referential_constraint_defi
Anfang Ebene 5 Knoten Schlüsseldefinition (key_definition) Schlüsseldefinition (key_definition) Ende Ebene 5 Knoten Schlüsseldefinition (key_definition)
Anfang Ebene 5 Knoten UNIQUE-Definition (unique_definition) UNIQUE-Definition (unique_definition) Ende Ebene 5 Knoten UNIQUE-Definition (unique_definition)
Anfang Ebene 4 Knoten DROP TABLE-Anweisung (drop_table_statement) DROP TABLE-Anweisung (drop_table_statement) Ende Ebene 4 Knoten DROP TABLE-Anweisung (drop_table_statement)
Anfang Ebene 4 Knoten ALTER TABLE-Anweisung (alter_table_statement) ALTER TABLE-Anweisung (alter_table_statement) Ende Ebene 4 Knoten ALTER TABLE-Anweisung (alter_table_statement)
Anfang Ebene 5 Knoten ADD-Definition (add_definition) ADD-Definition (add_definition) Ende Ebene 5 Knoten ADD-Definition (add_definition)
Anfang Ebene 5 Knoten ALTER-Definition (alter_definition) ALTER-Definition (alter_definition) Ende Ebene 5 Knoten ALTER-Definition (alter_definition)
Anfang Ebene 5 Knoten COLUMN-Change-Definition (column_change_definition) COLUMN-Change-Definition (column_change_definition) Ende Ebene 5 Knoten COLUMN-Change-Definition (column_change_definition)
Anfang Ebene 5 Knoten DROP-Definition (drop_definition) DROP-Definition (drop_definition) Ende Ebene 5 Knoten DROP-Definition (drop_definition)
Anfang Ebene 5 Knoten MODIFY-Definition (modify_definition) MODIFY-Definition (modify_definition) Ende Ebene 5 Knoten MODIFY-Definition (modify_definition)
Anfang Ebene 4 Knoten RENAME TABLE-Anweisung (rename_table_statement) RENAME TABLE-Anweisung (rename_table_statement) Ende Ebene 4 Knoten RENAME TABLE-Anweisung (rename_table_statement)
Anfang Ebene 4 Knoten RENAME COLUMN-Anweisung (rename_column_statement) RENAME COLUMN-Anweisung (rename_column_statement) Ende Ebene 4 Knoten RENAME COLUMN-Anweisung (rename_column_statement)
Anfang Ebene 4 Knoten EXISTS TABLE-Anweisung (exists_table_statement) EXISTS TABLE-Anweisung (exists_table_statement) Ende Ebene 4 Knoten EXISTS TABLE-Anweisung (exists_table_statement)
Anfang Ebene 4 Knoten CREATE SCHEMA-Anweisung (create_schema_statement) CREATE SCHEMA-Anweisung (create_schema_statement) Ende Ebene 4 Knoten CREATE SCHEMA-Anweisung (create_schema_statement)
Anfang Ebene 4 Knoten RENAME SCHEMA-Anweisung (rename_schema_statement) RENAME SCHEMA-Anweisung (rename_schema_statement) Ende Ebene 4 Knoten RENAME SCHEMA-Anweisung (rename_schema_statement)
Anfang Ebene 4 Knoten DROP SCHEMA-Anweisung (drop_schema_statement) DROP SCHEMA-Anweisung (drop_schema_statement) Ende Ebene 4 Knoten DROP SCHEMA-Anweisung (drop_schema_statement)
Anfang Ebene 4 Knoten CREATE DOMAIN-Anweisung (create_domain_statement) CREATE DOMAIN-Anweisung (create_domain_statement) Ende Ebene 4 Knoten CREATE DOMAIN-Anweisung (create_domain_statement)
Anfang Ebene 4 Knoten DROP DOMAIN-Anweisung (drop_domain_statement) DROP DOMAIN-Anweisung (drop_domain_statement) Ende Ebene 4 Knoten DROP DOMAIN-Anweisung (drop_domain_statement)
Anfang Ebene 4 Knoten CREATE SEQUENCE-Anweisung (create_sequence_statement) CREATE SEQUENCE-Anweisung (create_sequence_statement) Ende Ebene 4 Knoten CREATE SEQUENCE-Anweisung (create_sequence_statement)
Anfang Ebene 4 Knoten DROP SEQUENCE-Anweisung (drop_sequence_statement) DROP SEQUENCE-Anweisung (drop_sequence_statement) Ende Ebene 4 Knoten DROP SEQUENCE-Anweisung (drop_sequence_statement)
Anfang Ebene 4 Knoten CREATE SYNONYM-Anweisung (create_synonym_statement) CREATE SYNONYM-Anweisung (create_synonym_statement) Ende Ebene 4 Knoten CREATE SYNONYM-Anweisung (create_synonym_statement)
Anfang Ebene 4 Knoten DROP SYNONYM-Anweisung (drop_synonym_statement) DROP SYNONYM-Anweisung (drop_synonym_statement) Ende Ebene 4 Knoten DROP SYNONYM-Anweisung (drop_synonym_statement)
Anfang Ebene 4 Knoten RENAME SYNONYM-Anweisung (rename_synonym_statement) RENAME SYNONYM-Anweisung (rename_synonym_statement) Ende Ebene 4 Knoten RENAME SYNONYM-Anweisung (rename_synonym_statement)
Anfang Ebene 4 Knoten CREATE VIEW-Anweisung (create_view_statement) CREATE VIEW-Anweisung (create_view_statement) Ende Ebene 4 Knoten CREATE VIEW-Anweisung (create_view_statement)
Anfang Ebene 5 Knoten INSERT-/UPDATE-/DELETE-Privileg für Eigentümer der View-Tabelle INSERT-/UPDATE-/DELETE-Privileg für Eigentümer der View-Tabelle Ende Ebene 5 Knoten INSERT-/UPDATE-/DELETE-Privileg für Eigentümer der View-Tabelle
Anfang Ebene 5 Knoten Änderbare Join-View-Tabelle Änderbare Join-View-Tabelle Ende Ebene 5 Knoten Änderbare Join-View-Tabelle
Anfang Ebene 4 Knoten DROP VIEW-Anweisung (drop_view_statement) DROP VIEW-Anweisung (drop_view_statement) Ende Ebene 4 Knoten DROP VIEW-Anweisung (drop_view_statement)
Anfang Ebene 4 Knoten RENAME VIEW-Anweisung (rename_view_statement) RENAME VIEW-Anweisung (rename_view_statement) Ende Ebene 4 Knoten RENAME VIEW-Anweisung (rename_view_statement)
Anfang Ebene 4 Knoten CREATE INDEX-Anweisung (create_index_statement) CREATE INDEX-Anweisung (create_index_statement) Ende Ebene 4 Knoten CREATE INDEX-Anweisung (create_index_statement)
Anfang Ebene 4 Knoten DROP INDEX-Anweisung (drop_index_statement) DROP INDEX-Anweisung (drop_index_statement) Ende Ebene 4 Knoten DROP INDEX-Anweisung (drop_index_statement)
Anfang Ebene 4 Knoten ALTER INDEX-Anweisung (alter_index_statement) ALTER INDEX-Anweisung (alter_index_statement) Ende Ebene 4 Knoten ALTER INDEX-Anweisung (alter_index_statement)
Anfang Ebene 4 Knoten RENAME INDEX-Anweisung (rename_index_statement) RENAME INDEX-Anweisung (rename_index_statement) Ende Ebene 4 Knoten RENAME INDEX-Anweisung (rename_index_statement)
Anfang Ebene 4 Knoten CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement) CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement) Ende Ebene 4 Knoten CREATE DBPROC[EDURE]-Anweisung (create_dbproc_statement)
Anfang Ebene 5 Knoten Routine (routine) Routine (routine) Ende Ebene 5 Knoten Routine (routine)
Anfang Ebene 5 Knoten Allgemeine CASE-Anweisung (searched_case_statement) Allgemeine CASE-Anweisung (searched_case_statement) Ende Ebene 5 Knoten Allgemeine CASE-Anweisung (searched_case_statement)
Anfang Ebene 5 Knoten Einfache CASE-Anweisung (simple_case_statement) Einfache CASE-Anweisung (simple_case_statement) Ende Ebene 5 Knoten Einfache CASE-Anweisung (simple_case_statement)
Anfang Ebene 4 Knoten DROP DBPROC[EDURE]-Anweisung (drop_dbproc_statement) DROP DBPROC[EDURE]-Anweisung (drop_dbproc_statement) Ende Ebene 4 Knoten DROP DBPROC[EDURE]-Anweisung (drop_dbproc_statement)
Anfang Ebene 4 Knoten CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement Ende Ebene 4 Knoten CREATE SYSTEM TRIGGER-Anweisung (create_system_trigger_statement
Anfang Ebene 4 Knoten DROP SYSTEM TRIGGER-Anweisung (drop_system_trigger_statement) DROP SYSTEM TRIGGER-Anweisung (drop_system_trigger_statement) Ende Ebene 4 Knoten DROP SYSTEM TRIGGER-Anweisung (drop_system_trigger_statement)
Anfang Ebene 4 Knoten CREATE FUNCTION-Anweisung (create_function_statement) CREATE FUNCTION-Anweisung (create_function_statement) Ende Ebene 4 Knoten CREATE FUNCTION-Anweisung (create_function_statement)
Anfang Ebene 4 Knoten DROP FUNCTION-Anweisung (drop_function_statement) DROP FUNCTION-Anweisung (drop_function_statement) Ende Ebene 4 Knoten DROP FUNCTION-Anweisung (drop_function_statement)
Anfang Ebene 4 Knoten CREATE TRIGGER-Anweisung (create_trigger_statement) CREATE TRIGGER-Anweisung (create_trigger_statement) Ende Ebene 4 Knoten CREATE TRIGGER-Anweisung (create_trigger_statement)
Anfang Ebene 4 Knoten DROP TRIGGER-Anweisung (drop_trigger_statement) DROP TRIGGER-Anweisung (drop_trigger_statement) Ende Ebene 4 Knoten DROP TRIGGER-Anweisung (drop_trigger_statement)
Anfang Ebene 4 Knoten COMMENT ON-Anweisung (comment_on_statement) COMMENT ON-Anweisung (comment_on_statement) Ende Ebene 4 Knoten COMMENT ON-Anweisung (comment_on_statement)
Anfang Ebene 3 Knoten Autorisierung Autorisierung Ende Ebene 3 Knoten Autorisierung
Anfang Ebene 4 Knoten CREATE USER-Anweisung (create_user_statement) CREATE USER-Anweisung (create_user_statement) Ende Ebene 4 Knoten CREATE USER-Anweisung (create_user_statement)
Anfang Ebene 4 Knoten CREATE USERGROUP-Anweisung (create_usergroup_statement) CREATE USERGROUP-Anweisung (create_usergroup_statement) Ende Ebene 4 Knoten CREATE USERGROUP-Anweisung (create_usergroup_statement)
Anfang Ebene 4 Knoten DROP USER-Anweisung (drop_user_statement) DROP USER-Anweisung (drop_user_statement) Ende Ebene 4 Knoten DROP USER-Anweisung (drop_user_statement)
Anfang Ebene 4 Knoten DROP USERGROUP-Anweisung (drop_usergroup_statement) DROP USERGROUP-Anweisung (drop_usergroup_statement) Ende Ebene 4 Knoten DROP USERGROUP-Anweisung (drop_usergroup_statement)
Anfang Ebene 4 Knoten ALTER USER-Anweisung (alter_user_statement) ALTER USER-Anweisung (alter_user_statement) Ende Ebene 4 Knoten ALTER USER-Anweisung (alter_user_statement)
Anfang Ebene 4 Knoten ALTER USERGROUP-Anweisung (alter_usergroup_statement) ALTER USERGROUP-Anweisung (alter_usergroup_statement) Ende Ebene 4 Knoten ALTER USERGROUP-Anweisung (alter_usergroup_statement)
Anfang Ebene 4 Knoten RENAME USER-Anweisung (rename_user_statement) RENAME USER-Anweisung (rename_user_statement) Ende Ebene 4 Knoten RENAME USER-Anweisung (rename_user_statement)
Anfang Ebene 4 Knoten RENAME USERGROUP-Anweisung (rename_usergroup_statement) RENAME USERGROUP-Anweisung (rename_usergroup_statement) Ende Ebene 4 Knoten RENAME USERGROUP-Anweisung (rename_usergroup_statement)
Anfang Ebene 4 Knoten GRANT USER-Anweisung (grant_user_statement) GRANT USER-Anweisung (grant_user_statement) Ende Ebene 4 Knoten GRANT USER-Anweisung (grant_user_statement)
Anfang Ebene 4 Knoten GRANT USERGROUP-Anweisung (grant_usergroup_statement) GRANT USERGROUP-Anweisung (grant_usergroup_statement) Ende Ebene 4 Knoten GRANT USERGROUP-Anweisung (grant_usergroup_statement)
Anfang Ebene 4 Knoten ALTER PASSWORD-Anweisung (alter_password_statement) ALTER PASSWORD-Anweisung (alter_password_statement) Ende Ebene 4 Knoten ALTER PASSWORD-Anweisung (alter_password_statement)
Anfang Ebene 4 Knoten CREATE ROLE-Anweisung (create_role_statement) CREATE ROLE-Anweisung (create_role_statement) Ende Ebene 4 Knoten CREATE ROLE-Anweisung (create_role_statement)
Anfang Ebene 4 Knoten DROP ROLE-Anweisung (drop_role_statement) DROP ROLE-Anweisung (drop_role_statement) Ende Ebene 4 Knoten DROP ROLE-Anweisung (drop_role_statement)
Anfang Ebene 4 Knoten GRANT-Anweisung (grant_statement) GRANT-Anweisung (grant_statement) Ende Ebene 4 Knoten GRANT-Anweisung (grant_statement)
Anfang Ebene 4 Knoten REVOKE-Anweisung (revoke_statement) REVOKE-Anweisung (revoke_statement) Ende Ebene 4 Knoten REVOKE-Anweisung (revoke_statement)
Anfang Ebene 3 Knoten Datenmanipulation Datenmanipulation Ende Ebene 3 Knoten Datenmanipulation
Anfang Ebene 4 Knoten INSERT-Anweisung (insert_statement) INSERT-Anweisung (insert_statement) Ende Ebene 4 Knoten INSERT-Anweisung (insert_statement)
Anfang Ebene 5 Knoten Datentyp der Zielspalte und Datentyp des einzufügenden Wertes Datentyp der Zielspalte und Datentyp des einzufügenden Wertes Ende Ebene 5 Knoten Datentyp der Zielspalte und Datentyp des einzufügenden Wertes
Anfang Ebene 5 Knoten Join-View-Tabelle, QUERY-Ausdruck, CONSTRAINT-Definition, Trigge Join-View-Tabelle, QUERY-Ausdruck, CONSTRAINT-Definition, Trigge Ende Ebene 5 Knoten Join-View-Tabelle, QUERY-Ausdruck, CONSTRAINT-Definition, Trigge
Anfang Ebene 4 Knoten UPDATE-Anweisung (update_statement) UPDATE-Anweisung (update_statement) Ende Ebene 4 Knoten UPDATE-Anweisung (update_statement)
Anfang Ebene 4 Knoten DELETE-Anweisung (delete_statement) DELETE-Anweisung (delete_statement) Ende Ebene 4 Knoten DELETE-Anweisung (delete_statement)
Anfang Ebene 4 Knoten NEXT STAMP-Anweisung (next_stamp_statement) NEXT STAMP-Anweisung (next_stamp_statement) Ende Ebene 4 Knoten NEXT STAMP-Anweisung (next_stamp_statement)
Anfang Ebene 4 Knoten CALL-Anweisung (call_statement) CALL-Anweisung (call_statement) Ende Ebene 4 Knoten CALL-Anweisung (call_statement)
Anfang Ebene 3 Knoten Datenanfrage Datenanfrage Ende Ebene 3 Knoten Datenanfrage
Anfang Ebene 4 Knoten QUERY-Anweisung (query_statement) QUERY-Anweisung (query_statement) Ende Ebene 4 Knoten QUERY-Anweisung (query_statement)
Anfang Ebene 5 Knoten DECLARE CURSOR-Anweisung (declare_cursor_statement) DECLARE CURSOR-Anweisung (declare_cursor_statement) Ende Ebene 5 Knoten DECLARE CURSOR-Anweisung (declare_cursor_statement)
Anfang Ebene 5 Knoten Rekursive DECLARE CURSOR-Anweisung (recursive_declare_cursor_sta Rekursive DECLARE CURSOR-Anweisung (recursive_declare_cursor_sta Ende Ebene 5 Knoten Rekursive DECLARE CURSOR-Anweisung (recursive_declare_cursor_sta
Anfang Ebene 5 Knoten SELECT-Anweisung (select_statement) SELECT-Anweisung (select_statement) Ende Ebene 5 Knoten SELECT-Anweisung (select_statement)
Anfang Ebene 5 Knoten QUERY-Ausdruck (query_expression) QUERY-Ausdruck (query_expression) Ende Ebene 5 Knoten QUERY-Ausdruck (query_expression)
Anfang Ebene 5 Knoten Tabellenausdruck (table_expression) Tabellenausdruck (table_expression) Ende Ebene 5 Knoten Tabellenausdruck (table_expression)
Anfang Ebene 5 Knoten Subquery (subquery) Subquery (subquery) Ende Ebene 5 Knoten Subquery (subquery)
Anfang Ebene 5 Knoten ORDER-Klausel (order_clause) ORDER-Klausel (order_clause) Ende Ebene 5 Knoten ORDER-Klausel (order_clause)
Anfang Ebene 5 Knoten UPDATE-Klausel (update_clause) UPDATE-Klausel (update_clause) Ende Ebene 5 Knoten UPDATE-Klausel (update_clause)
Anfang Ebene 5 Knoten LOCK-Option (lock_option) LOCK-Option (lock_option) Ende Ebene 5 Knoten LOCK-Option (lock_option)
Anfang Ebene 4 Knoten FETCH-Anweisung (fetch_statement) FETCH-Anweisung (fetch_statement) Ende Ebene 4 Knoten FETCH-Anweisung (fetch_statement)
Anfang Ebene 4 Knoten CLOSE-Anweisung (close_statement) CLOSE-Anweisung (close_statement) Ende Ebene 4 Knoten CLOSE-Anweisung (close_statement)
Anfang Ebene 4 Knoten SINGLE SELECT-Anweisung (single_select_statement) SINGLE SELECT-Anweisung (single_select_statement) Ende Ebene 4 Knoten SINGLE SELECT-Anweisung (single_select_statement)
Anfang Ebene 4 Knoten EXPLAIN-Anweisung (explain_statement) EXPLAIN-Anweisung (explain_statement) Ende Ebene 4 Knoten EXPLAIN-Anweisung (explain_statement)
Anfang Ebene 3 Knoten Transaktionen Transaktionen Ende Ebene 3 Knoten Transaktionen
Anfang Ebene 4 Knoten CONNECT-Anweisung (connect_statement) CONNECT-Anweisung (connect_statement) Ende Ebene 4 Knoten CONNECT-Anweisung (connect_statement)
Anfang Ebene 4 Knoten SET-Anweisung (set_statement) SET-Anweisung (set_statement) Ende Ebene 4 Knoten SET-Anweisung (set_statement)
Anfang Ebene 4 Knoten COMMIT-Anweisung (commit_statement) COMMIT-Anweisung (commit_statement) Ende Ebene 4 Knoten COMMIT-Anweisung (commit_statement)
Anfang Ebene 4 Knoten ROLLBACK-Anweisung (rollback_statement) ROLLBACK-Anweisung (rollback_statement) Ende Ebene 4 Knoten ROLLBACK-Anweisung (rollback_statement)
Anfang Ebene 4 Knoten SUBTRANS-Anweisung (subtrans_statement) SUBTRANS-Anweisung (subtrans_statement) Ende Ebene 4 Knoten SUBTRANS-Anweisung (subtrans_statement)
Anfang Ebene 4 Knoten INNER TRANSACTION-Anweisung (inner_transaction_statement) INNER TRANSACTION-Anweisung (inner_transaction_statement) Ende Ebene 4 Knoten INNER TRANSACTION-Anweisung (inner_transaction_statement)
Anfang Ebene 4 Knoten SQL SAVEPOINT-Anweisungen (savepoint/rollback_to_/release_savepo SQL SAVEPOINT-Anweisungen (savepoint/rollback_to_/release_savepo Ende Ebene 4 Knoten SQL SAVEPOINT-Anweisungen (savepoint/rollback_to_/release_savepo
Anfang Ebene 4 Knoten LOCK-Anweisung (lock_statement) LOCK-Anweisung (lock_statement) Ende Ebene 4 Knoten LOCK-Anweisung (lock_statement)
Anfang Ebene 4 Knoten UNLOCK-Anweisung (unlock_statement) UNLOCK-Anweisung (unlock_statement) Ende Ebene 4 Knoten UNLOCK-Anweisung (unlock_statement)
Anfang Ebene 4 Knoten RELEASE-Anweisung (release_statement) RELEASE-Anweisung (release_statement) Ende Ebene 4 Knoten RELEASE-Anweisung (release_statement)
Anfang Ebene 3 Knoten Statistiken Statistiken Ende Ebene 3 Knoten Statistiken
Anfang Ebene 4 Knoten UPDATE STATISTICS-Anweisung (update_statistics_statement) UPDATE STATISTICS-Anweisung (update_statistics_statement) Ende Ebene 4 Knoten UPDATE STATISTICS-Anweisung (update_statistics_statement)
Anfang Ebene 4 Knoten MONITOR-Anweisung (monitor_statement) MONITOR-Anweisung (monitor_statement) Ende Ebene 4 Knoten MONITOR-Anweisung (monitor_statement)
Anfang Ebene 3 Knoten SQL-Anweisungen: Überblick SQL-Anweisungen: Überblick Ende Ebene 3 Knoten SQL-Anweisungen: Überblick
Anfang Ebene 4 Knoten Kommentar (sql_comment) Kommentar (sql_comment) Ende Ebene 4 Knoten Kommentar (sql_comment)
Anfang Ebene 3 Knoten Häufig verwendete Syntaxelemente: Überblick Häufig verwendete Syntaxelemente: Überblick Ende Ebene 3 Knoten Häufig verwendete Syntaxelemente: Überblick
Anfang Ebene 4 Knoten CASCADE-Option (cascade_option) CASCADE-Option (cascade_option) Ende Ebene 4 Knoten CASCADE-Option (cascade_option)
Anfang Ebene 4 Knoten Zeichen (character) Zeichen (character) Ende Ebene 4 Knoten Zeichen (character)
Anfang Ebene 4 Knoten Spaltenspezifikation (column_spec) Spaltenspezifikation (column_spec) Ende Ebene 4 Knoten Spaltenspezifikation (column_spec)
Anfang Ebene 4 Knoten DEFAULT-Spezifikation (default_spec) DEFAULT-Spezifikation (default_spec) Ende Ebene 4 Knoten DEFAULT-Spezifikation (default_spec)
Anfang Ebene 4 Knoten DELETE-Regel (delete_rule) DELETE-Regel (delete_rule) Ende Ebene 4 Knoten DELETE-Regel (delete_rule)
Anfang Ebene 4 Knoten DISTINCT-Spezifikation (distinct_spec) DISTINCT-Spezifikation (distinct_spec) Ende Ebene 4 Knoten DISTINCT-Spezifikation (distinct_spec)
Anfang Ebene 4 Knoten DUPLICATES-Klausel (duplicates_clause) DUPLICATES-Klausel (duplicates_clause) Ende Ebene 4 Knoten DUPLICATES-Klausel (duplicates_clause)
Anfang Ebene 4 Knoten Ausdruck (expression) Ausdruck (expression) Ende Ebene 4 Knoten Ausdruck (expression)
Anfang Ebene 4 Knoten Spezifikation von Werten (extended_value_spec) Spezifikation von Werten (extended_value_spec) Ende Ebene 4 Knoten Spezifikation von Werten (extended_value_spec)
Anfang Ebene 4 Knoten Funktion (function_spec) Funktion (function_spec) Ende Ebene 4 Knoten Funktion (function_spec)
Anfang Ebene 5 Knoten Arithmetische Funktion (arithmetic_function) Arithmetische Funktion (arithmetic_function) Ende Ebene 5 Knoten Arithmetische Funktion (arithmetic_function)
Anfang Ebene 6 Knoten ABS(a) ABS(a) Ende Ebene 6 Knoten ABS(a)
Anfang Ebene 6 Knoten CEIL(a) CEIL(a) Ende Ebene 6 Knoten CEIL(a)
Anfang Ebene 6 Knoten EXP(a) EXP(a) Ende Ebene 6 Knoten EXP(a)
Anfang Ebene 6 Knoten FIXED(a,p,s) FIXED(a,p,s) Ende Ebene 6 Knoten FIXED(a,p,s)
Anfang Ebene 6 Knoten FLOAT(a,s) FLOAT(a,s) Ende Ebene 6 Knoten FLOAT(a,s)
Anfang Ebene 6 Knoten FLOOR(a) FLOOR(a) Ende Ebene 6 Knoten FLOOR(a)
Anfang Ebene 6 Knoten INDEX(a,b,p,s) INDEX(a,b,p,s) Ende Ebene 6 Knoten INDEX(a,b,p,s)
Anfang Ebene 6 Knoten LENGTH(a) LENGTH(a) Ende Ebene 6 Knoten LENGTH(a)
Anfang Ebene 6 Knoten LN(a) LN(a) Ende Ebene 6 Knoten LN(a)
Anfang Ebene 6 Knoten LOG(a,b) LOG(a,b) Ende Ebene 6 Knoten LOG(a,b)
Anfang Ebene 6 Knoten NOROUND(a) NOROUND(a) Ende Ebene 6 Knoten NOROUND(a)
Anfang Ebene 6 Knoten PI PI Ende Ebene 6 Knoten PI
Anfang Ebene 6 Knoten POWER(a,n) POWER(a,n) Ende Ebene 6 Knoten POWER(a,n)
Anfang Ebene 6 Knoten ROUND(a,n) ROUND(a,n) Ende Ebene 6 Knoten ROUND(a,n)
Anfang Ebene 6 Knoten SIGN(a) SIGN(a) Ende Ebene 6 Knoten SIGN(a)
Anfang Ebene 6 Knoten SQRT(a) SQRT(a) Ende Ebene 6 Knoten SQRT(a)
Anfang Ebene 6 Knoten TRUNC(a,n) TRUNC(a,n) Ende Ebene 6 Knoten TRUNC(a,n)
Anfang Ebene 5 Knoten Konversionsfunktion (conversion_function) Konversionsfunktion (conversion_function) Ende Ebene 5 Knoten Konversionsfunktion (conversion_function)
Anfang Ebene 6 Knoten CHAR(a,t) CHAR(a,t) Ende Ebene 6 Knoten CHAR(a,t)
Anfang Ebene 6 Knoten CHR(a,n) CHR(a,n) Ende Ebene 6 Knoten CHR(a,n)
Anfang Ebene 6 Knoten HEX(a) HEX(a) Ende Ebene 6 Knoten HEX(a)
Anfang Ebene 6 Knoten HEXTORAW(a) HEXTORAW(a) Ende Ebene 6 Knoten HEXTORAW(a)
Anfang Ebene 6 Knoten NUM(a) NUM(a) Ende Ebene 6 Knoten NUM(a)
Anfang Ebene 6 Knoten Datums- und Zeitformat (datetimeformat) Datums- und Zeitformat (datetimeformat) Ende Ebene 6 Knoten Datums- und Zeitformat (datetimeformat)
Anfang Ebene 5 Knoten Datumsfunktion (date_function) Datumsfunktion (date_function) Ende Ebene 5 Knoten Datumsfunktion (date_function)
Anfang Ebene 6 Knoten ADDDATE/SUBDATE(t,a) ADDDATE/SUBDATE(t,a) Ende Ebene 6 Knoten ADDDATE/SUBDATE(t,a)
Anfang Ebene 6 Knoten DATEDIFF(t,s) DATEDIFF(t,s) Ende Ebene 6 Knoten DATEDIFF(t,s)
Anfang Ebene 6 Knoten DAYNAME/MONTHNAME(t) DAYNAME/MONTHNAME(t) Ende Ebene 6 Knoten DAYNAME/MONTHNAME(t)
Anfang Ebene 6 Knoten DAYOFWEEK/WEEKOFYEAR/DAYOFMONTH/DAYOFYEAR(t) DAYOFWEEK/WEEKOFYEAR/DAYOFMONTH/DAYOFYEAR(t) Ende Ebene 6 Knoten DAYOFWEEK/WEEKOFYEAR/DAYOFMONTH/DAYOFYEAR(t)
Anfang Ebene 6 Knoten MAKEDATE(a,b) MAKEDATE(a,b) Ende Ebene 6 Knoten MAKEDATE(a,b)
Anfang Ebene 5 Knoten Datenbankfunktionsaufruf (dbfunction_call) Datenbankfunktionsaufruf (dbfunction_call) Ende Ebene 5 Knoten Datenbankfunktionsaufruf (dbfunction_call)
Anfang Ebene 5 Knoten Extraktion (extraction_function) Extraktion (extraction_function) Ende Ebene 5 Knoten Extraktion (extraction_function)
Anfang Ebene 6 Knoten DATE(a) DATE(a) Ende Ebene 6 Knoten DATE(a)
Anfang Ebene 6 Knoten HOUR/MINUTE/SECOND(t) HOUR/MINUTE/SECOND(t) Ende Ebene 6 Knoten HOUR/MINUTE/SECOND(t)
Anfang Ebene 6 Knoten MICROSECOND(a) MICROSECOND(a) Ende Ebene 6 Knoten MICROSECOND(a)
Anfang Ebene 6 Knoten TIME(a) TIME(a) Ende Ebene 6 Knoten TIME(a)
Anfang Ebene 6 Knoten TIMESTAMP(a,b) TIMESTAMP(a,b) Ende Ebene 6 Knoten TIMESTAMP(a,b)
Anfang Ebene 6 Knoten YEAR/MONTH/DAY(t) YEAR/MONTH/DAY(t) Ende Ebene 6 Knoten YEAR/MONTH/DAY(t)
Anfang Ebene 5 Knoten Spezialfunktion (special_function) Spezialfunktion (special_function) Ende Ebene 5 Knoten Spezialfunktion (special_function)
Anfang Ebene 6 Knoten DECODE(x,y(i),...,z) DECODE(x,y(i),...,z) Ende Ebene 6 Knoten DECODE(x,y(i),...,z)
Anfang Ebene 6 Knoten GREATEST/LEAST(x,y,...) GREATEST/LEAST(x,y,...) Ende Ebene 6 Knoten GREATEST/LEAST(x,y,...)
Anfang Ebene 6 Knoten VALUE(x,y,...) VALUE(x,y,...) Ende Ebene 6 Knoten VALUE(x,y,...)
Anfang Ebene 6 Knoten Allgemeine CASE-Funktion (searched_case_function) Allgemeine CASE-Funktion (searched_case_function) Ende Ebene 6 Knoten Allgemeine CASE-Funktion (searched_case_function)
Anfang Ebene 6 Knoten Einfache CASE-Funktion (simple_case_function) Einfache CASE-Funktion (simple_case_function) Ende Ebene 6 Knoten Einfache CASE-Funktion (simple_case_function)
Anfang Ebene 5 Knoten Stringfunktion (string_function) Stringfunktion (string_function) Ende Ebene 5 Knoten Stringfunktion (string_function)
Anfang Ebene 6 Knoten ALPHA(x,n) ALPHA(x,n) Ende Ebene 6 Knoten ALPHA(x,n)
Anfang Ebene 6 Knoten ASCII(x) ASCII(x) Ende Ebene 6 Knoten ASCII(x)
Anfang Ebene 6 Knoten EXPAND(x,n) EXPAND(x,n) Ende Ebene 6 Knoten EXPAND(x,n)
Anfang Ebene 6 Knoten GET_OBJECTNAME(x,o) GET_OBJECTNAME(x,o) Ende Ebene 6 Knoten GET_OBJECTNAME(x,o)
Anfang Ebene 6 Knoten GET_SCHEMA(x,o) GET_SCHEMA(x,o) Ende Ebene 6 Knoten GET_SCHEMA(x,o)
Anfang Ebene 6 Knoten INITCAP(x) INITCAP(x) Ende Ebene 6 Knoten INITCAP(x)
Anfang Ebene 6 Knoten LFILL(x,a,n) LFILL(x,a,n) Ende Ebene 6 Knoten LFILL(x,a,n)
Anfang Ebene 6 Knoten LPAD(x,a,y,n) LPAD(x,a,y,n) Ende Ebene 6 Knoten LPAD(x,a,y,n)
Anfang Ebene 6 Knoten LTRIM(x,y) LTRIM(x,y) Ende Ebene 6 Knoten LTRIM(x,y)
Anfang Ebene 6 Knoten MAPCHAR(x,n,i) MAPCHAR(x,n,i) Ende Ebene 6 Knoten MAPCHAR(x,n,i)
Anfang Ebene 6 Knoten REPLACE(x,y,z) REPLACE(x,y,z) Ende Ebene 6 Knoten REPLACE(x,y,z)
Anfang Ebene 6 Knoten RFILL(x,a,n) RFILL(x,a,n) Ende Ebene 6 Knoten RFILL(x,a,n)
Anfang Ebene 6 Knoten RPAD(x,a,y,n) RPAD(x,a,y,n) Ende Ebene 6 Knoten RPAD(x,a,y,n)
Anfang Ebene 6 Knoten RTRIM(x,y) RTRIM(x,y) Ende Ebene 6 Knoten RTRIM(x,y)
Anfang Ebene 6 Knoten SOUNDEX(x) SOUNDEX(x) Ende Ebene 6 Knoten SOUNDEX(x)
Anfang Ebene 6 Knoten SUBSTR(x,a,b) SUBSTR(x,a,b) Ende Ebene 6 Knoten SUBSTR(x,a,b)
Anfang Ebene 6 Knoten TRANSLATE(x,y,z) TRANSLATE(x,y,z) Ende Ebene 6 Knoten TRANSLATE(x,y,z)
Anfang Ebene 6 Knoten TRIM(x,y) TRIM(x,y) Ende Ebene 6 Knoten TRIM(x,y)
Anfang Ebene 6 Knoten UPPER/LOWER(x) UPPER/LOWER(x) Ende Ebene 6 Knoten UPPER/LOWER(x)
Anfang Ebene 6 Knoten Verkettung (concatenation) Verkettung (concatenation) Ende Ebene 6 Knoten Verkettung (concatenation)
Anfang Ebene 5 Knoten Zeitfunktion (time_function) Zeitfunktion (time_function) Ende Ebene 5 Knoten Zeitfunktion (time_function)
Anfang Ebene 6 Knoten ADDTIME/SUBTIME(t,a) ADDTIME/SUBTIME(t,a) Ende Ebene 6 Knoten ADDTIME/SUBTIME(t,a)
Anfang Ebene 6 Knoten MAKETIME(h,m,s) MAKETIME(h,m,s) Ende Ebene 6 Knoten MAKETIME(h,m,s)
Anfang Ebene 6 Knoten TIMEDIFF(t,s) TIMEDIFF(t,s) Ende Ebene 6 Knoten TIMEDIFF(t,s)
Anfang Ebene 5 Knoten Trigonometrische Funktion (trigonometric_function) Trigonometrische Funktion (trigonometric_function) Ende Ebene 5 Knoten Trigonometrische Funktion (trigonometric_function)
Anfang Ebene 4 Knoten Join-Tabelle (joined_table) Join-Tabelle (joined_table) Ende Ebene 4 Knoten Join-Tabelle (joined_table)
Anfang Ebene 4 Knoten Schlüsselspezifikation (key_spec) Schlüsselspezifikation (key_spec) Ende Ebene 4 Knoten Schlüsselspezifikation (key_spec)
Anfang Ebene 4 Knoten Literal (literal) Literal (literal) Ende Ebene 4 Knoten Literal (literal)
Anfang Ebene 5 Knoten Festkommazahl (fixed_point_literal) Festkommazahl (fixed_point_literal) Ende Ebene 5 Knoten Festkommazahl (fixed_point_literal)
Anfang Ebene 5 Knoten Gleitkommazahl (floating_point_literal) Gleitkommazahl (floating_point_literal) Ende Ebene 5 Knoten Gleitkommazahl (floating_point_literal)
Anfang Ebene 5 Knoten Ganze Zahl ohne Vorzeichen (unsigned_integer) Ganze Zahl ohne Vorzeichen (unsigned_integer) Ende Ebene 5 Knoten Ganze Zahl ohne Vorzeichen (unsigned_integer)
Anfang Ebene 5 Knoten Ganze Zahl (integer) Ganze Zahl (integer) Ende Ebene 5 Knoten Ganze Zahl (integer)
Anfang Ebene 4 Knoten Parameterspezifikation (parameter_spec) Parameterspezifikation (parameter_spec) Ende Ebene 4 Knoten Parameterspezifikation (parameter_spec)
Anfang Ebene 4 Knoten Prädikat (predicate) Prädikat (predicate) Ende Ebene 4 Knoten Prädikat (predicate)
Anfang Ebene 5 Knoten BETWEEN-Prädikat (between_predicate) BETWEEN-Prädikat (between_predicate) Ende Ebene 5 Knoten BETWEEN-Prädikat (between_predicate)
Anfang Ebene 5 Knoten Boolesches Prädikat (bool_predicate) Boolesches Prädikat (bool_predicate) Ende Ebene 5 Knoten Boolesches Prädikat (bool_predicate)
Anfang Ebene 5 Knoten Vergleichsprädikat (comparison_predicate) Vergleichsprädikat (comparison_predicate) Ende Ebene 5 Knoten Vergleichsprädikat (comparison_predicate)
Anfang Ebene 5 Knoten DEFAULT-Prädikat (default_predicate) DEFAULT-Prädikat (default_predicate) Ende Ebene 5 Knoten DEFAULT-Prädikat (default_predicate)
Anfang Ebene 5 Knoten EXISTS-Prädikat (exists_predicate) EXISTS-Prädikat (exists_predicate) Ende Ebene 5 Knoten EXISTS-Prädikat (exists_predicate)
Anfang Ebene 5 Knoten IN-Prädikat (in_predicate) IN-Prädikat (in_predicate) Ende Ebene 5 Knoten IN-Prädikat (in_predicate)
Anfang Ebene 5 Knoten JOIN-Prädikat (join_predicate) JOIN-Prädikat (join_predicate) Ende Ebene 5 Knoten JOIN-Prädikat (join_predicate)
Anfang Ebene 5 Knoten LIKE-Prädikat (like_predicate) LIKE-Prädikat (like_predicate) Ende Ebene 5 Knoten LIKE-Prädikat (like_predicate)
Anfang Ebene 5 Knoten NULL-Prädikat (null_predicate) NULL-Prädikat (null_predicate) Ende Ebene 5 Knoten NULL-Prädikat (null_predicate)
Anfang Ebene 5 Knoten Mengenvergleichsprädikat (quantified_predicate) Mengenvergleichsprädikat (quantified_predicate) Ende Ebene 5 Knoten Mengenvergleichsprädikat (quantified_predicate)
Anfang Ebene 5 Knoten ROWNO-Prädikat (rowno_predicate) ROWNO-Prädikat (rowno_predicate) Ende Ebene 5 Knoten ROWNO-Prädikat (rowno_predicate)
Anfang Ebene 5 Knoten SOUNDS-Prädikat (sounds_predicate) SOUNDS-Prädikat (sounds_predicate) Ende Ebene 5 Knoten SOUNDS-Prädikat (sounds_predicate)
Anfang Ebene 4 Knoten SAMPLE-Definition (sample_definition) SAMPLE-Definition (sample_definition) Ende Ebene 4 Knoten SAMPLE-Definition (sample_definition)
Anfang Ebene 4 Knoten Suchbedingung (search_condition) Suchbedingung (search_condition) Ende Ebene 4 Knoten Suchbedingung (search_condition)
Anfang Ebene 4 Knoten Selektierte Spalte (select_column) Selektierte Spalte (select_column) Ende Ebene 4 Knoten Selektierte Spalte (select_column)
Anfang Ebene 4 Knoten Set-Funktion (set_function_spec) Set-Funktion (set_function_spec) Ende Ebene 4 Knoten Set-Funktion (set_function_spec)
Anfang Ebene 4 Knoten Zeichensatz (token) Zeichensatz (token) Ende Ebene 4 Knoten Zeichensatz (token)
Anfang Ebene 5 Knoten Bezeichner (identifier) Bezeichner (identifier) Ende Ebene 5 Knoten Bezeichner (identifier)
Anfang Ebene 5 Knoten Schlüsselwort (key_word) Schlüsselwort (key_word) Ende Ebene 5 Knoten Schlüsselwort (key_word)
Anfang Ebene 3 Knoten Funktionen: Überblick Funktionen: Überblick Ende Ebene 3 Knoten Funktionen: Überblick
Anfang Ebene 3 Knoten Namen: Überblick Namen: Überblick Ende Ebene 3 Knoten Namen: Überblick
Anfang Ebene 4 Knoten Alias-Name (alias_name) Alias-Name (alias_name) Ende Ebene 4 Knoten Alias-Name (alias_name)
Anfang Ebene 4 Knoten Spaltenname (column_name) Spaltenname (column_name) Ende Ebene 4 Knoten Spaltenname (column_name)
Anfang Ebene 4 Knoten Constraint-Name (constraint_name) Constraint-Name (constraint_name) Ende Ebene 4 Knoten Constraint-Name (constraint_name)
Anfang Ebene 4 Knoten Name einer Datenbankfunktion (dbfunction_name) Name einer Datenbankfunktion (dbfunction_name) Ende Ebene 4 Knoten Name einer Datenbankfunktion (dbfunction_name)
Anfang Ebene 4 Knoten Name einer Datenbankprozedur (dbproc_name) Name einer Datenbankprozedur (dbproc_name) Ende Ebene 4 Knoten Name einer Datenbankprozedur (dbproc_name)
Anfang Ebene 4 Knoten Domänenname (domain_name) Domänenname (domain_name) Ende Ebene 4 Knoten Domänenname (domain_name)
Anfang Ebene 4 Knoten Indexname (index_name) Indexname (index_name) Ende Ebene 4 Knoten Indexname (index_name)
Anfang Ebene 4 Knoten Indikatorname (indicator_name) Indikatorname (indicator_name) Ende Ebene 4 Knoten Indikatorname (indicator_name)
Anfang Ebene 4 Knoten Mapchar-Set-Name (mapchar_set_name) Mapchar-Set-Name (mapchar_set_name) Ende Ebene 4 Knoten Mapchar-Set-Name (mapchar_set_name)
Anfang Ebene 4 Knoten Kennwort (password) Kennwort (password) Ende Ebene 4 Knoten Kennwort (password)
Anfang Ebene 4 Knoten Parametername (parameter_name) Parametername (parameter_name) Ende Ebene 4 Knoten Parametername (parameter_name)
Anfang Ebene 4 Knoten Referenzname (reference_name) Referenzname (reference_name) Ende Ebene 4 Knoten Referenzname (reference_name)
Anfang Ebene 4 Knoten Name eines Referentiellen Constraints (referential_constraint_na Name eines Referentiellen Constraints (referential_constraint_na Ende Ebene 4 Knoten Name eines Referentiellen Constraints (referential_constraint_na
Anfang Ebene 4 Knoten Ergebnistabellenname (result_table_name) Ergebnistabellenname (result_table_name) Ende Ebene 4 Knoten Ergebnistabellenname (result_table_name)
Anfang Ebene 4 Knoten Rollenname (role_name) Rollenname (role_name) Ende Ebene 4 Knoten Rollenname (role_name)
Anfang Ebene 4 Knoten Schemaname (schema_name) Schemaname (schema_name) Ende Ebene 4 Knoten Schemaname (schema_name)
Anfang Ebene 4 Knoten Sequenzname (sequence_name) Sequenzname (sequence_name) Ende Ebene 4 Knoten Sequenzname (sequence_name)
Anfang Ebene 4 Knoten Synonymname (synonym_name) Synonymname (synonym_name) Ende Ebene 4 Knoten Synonymname (synonym_name)
Anfang Ebene 4 Knoten Tabellenname (table_name) Tabellenname (table_name) Ende Ebene 4 Knoten Tabellenname (table_name)
Anfang Ebene 4 Knoten Triggername (trigger_name) Triggername (trigger_name) Ende Ebene 4 Knoten Triggername (trigger_name)
Anfang Ebene 4 Knoten Benutzergruppenname (usergroup_name) Benutzergruppenname (usergroup_name) Ende Ebene 4 Knoten Benutzergruppenname (usergroup_name)
Anfang Ebene 4 Knoten Benutzername (user_name) Benutzername (user_name) Ende Ebene 4 Knoten Benutzername (user_name)
Anfang Ebene 3 Knoten Privilegien: Überblick Privilegien: Überblick Ende Ebene 3 Knoten Privilegien: Überblick
Anfang Ebene 4 Knoten Privilegienspezifikation (priv_spec) Privilegienspezifikation (priv_spec) Ende Ebene 4 Knoten Privilegienspezifikation (priv_spec)
Anfang Ebene 4 Knoten Privilegienspezifikation für ein Schema (schema_priv_spec) Privilegienspezifikation für ein Schema (schema_priv_spec) Ende Ebene 4 Knoten Privilegienspezifikation für ein Schema (schema_priv_spec)
Anfang Ebene 3 Knoten Syntaxverzeichnis Syntaxverzeichnis Ende Ebene 3 Knoten Syntaxverzeichnis
Anfang Ebene 4 Knoten add_definition add_definition Ende Ebene 4 Knoten add_definition
Anfang Ebene 4 Knoten alias_name alias_name Ende Ebene 4 Knoten alias_name
Anfang Ebene 4 Knoten all_function all_function Ende Ebene 4 Knoten all_function
Anfang Ebene 4 Knoten alter_definition alter_definition Ende Ebene 4 Knoten alter_definition
Anfang Ebene 4 Knoten alter_index_statement alter_index_statement Ende Ebene 4 Knoten alter_index_statement
Anfang Ebene 4 Knoten alter_password_statement alter_password_statement Ende Ebene 4 Knoten alter_password_statement
Anfang Ebene 4 Knoten alter_table_statement alter_table_statement Ende Ebene 4 Knoten alter_table_statement
Anfang Ebene 4 Knoten alter_user_statement alter_user_statement Ende Ebene 4 Knoten alter_user_statement
Anfang Ebene 4 Knoten alter_usergroup_statement alter_usergroup_statement Ende Ebene 4 Knoten alter_usergroup_statement
Anfang Ebene 4 Knoten argument argument Ende Ebene 4 Knoten argument
Anfang Ebene 4 Knoten argument1 argument1 Ende Ebene 4 Knoten argument1
Anfang Ebene 4 Knoten arithmetic_function arithmetic_function Ende Ebene 4 Knoten arithmetic_function
Anfang Ebene 4 Knoten ASCII_or_UNICODE ASCII_or_UNICODE Ende Ebene 4 Knoten ASCII_or_UNICODE
Anfang Ebene 4 Knoten assignment_statement assignment_statement Ende Ebene 4 Knoten assignment_statement
Anfang Ebene 4 Knoten between_predicate between_predicate Ende Ebene 4 Knoten between_predicate
Anfang Ebene 4 Knoten bool_predicate bool_predicate Ende Ebene 4 Knoten bool_predicate
Anfang Ebene 4 Knoten boolean_factor boolean_factor Ende Ebene 4 Knoten boolean_factor
Anfang Ebene 4 Knoten boolean_term boolean_term Ende Ebene 4 Knoten boolean_term
Anfang Ebene 4 Knoten call_statement call_statement Ende Ebene 4 Knoten call_statement
Anfang Ebene 4 Knoten cascade_option cascade_option Ende Ebene 4 Knoten cascade_option
Anfang Ebene 4 Knoten case_else_clause case_else_clause Ende Ebene 4 Knoten case_else_clause
Anfang Ebene 4 Knoten case_function case_function Ende Ebene 4 Knoten case_function
Anfang Ebene 4 Knoten case_statement case_statement Ende Ebene 4 Knoten case_statement
Anfang Ebene 4 Knoten character character Ende Ebene 4 Knoten character
Anfang Ebene 4 Knoten check_expression check_expression Ende Ebene 4 Knoten check_expression
Anfang Ebene 4 Knoten close_statement close_statement Ende Ebene 4 Knoten close_statement
Anfang Ebene 4 Knoten column_attributes column_attributes Ende Ebene 4 Knoten column_attributes
Anfang Ebene 4 Knoten column_change_definition column_change_definition Ende Ebene 4 Knoten column_change_definition
Anfang Ebene 4 Knoten column_definition column_definition Ende Ebene 4 Knoten column_definition
Anfang Ebene 4 Knoten column_list column_list Ende Ebene 4 Knoten column_list
Anfang Ebene 4 Knoten column_name column_name Ende Ebene 4 Knoten column_name
Anfang Ebene 4 Knoten column_spec column_spec Ende Ebene 4 Knoten column_spec
Anfang Ebene 4 Knoten comment comment Ende Ebene 4 Knoten comment
Anfang Ebene 4 Knoten comment_on_statement comment_on_statement Ende Ebene 4 Knoten comment_on_statement
Anfang Ebene 4 Knoten commit_statement commit_statement Ende Ebene 4 Knoten commit_statement
Anfang Ebene 4 Knoten comp_op comp_op Ende Ebene 4 Knoten comp_op
Anfang Ebene 4 Knoten comparison_predicate comparison_predicate Ende Ebene 4 Knoten comparison_predicate
Anfang Ebene 4 Knoten connect_mode connect_mode Ende Ebene 4 Knoten connect_mode
Anfang Ebene 4 Knoten connect_option connect_option Ende Ebene 4 Knoten connect_option
Anfang Ebene 4 Knoten connect_statement connect_statement Ende Ebene 4 Knoten connect_statement
Anfang Ebene 4 Knoten constraint_definition constraint_definition Ende Ebene 4 Knoten constraint_definition
Anfang Ebene 4 Knoten constraint_name constraint_name Ende Ebene 4 Knoten constraint_name
Anfang Ebene 4 Knoten conversion_function conversion_function Ende Ebene 4 Knoten conversion_function
Anfang Ebene 4 Knoten create_dbproc_statement create_dbproc_statement Ende Ebene 4 Knoten create_dbproc_statement
Anfang Ebene 4 Knoten create_domain_statement create_domain_statement Ende Ebene 4 Knoten create_domain_statement
Anfang Ebene 4 Knoten create_function_statement create_function_statement Ende Ebene 4 Knoten create_function_statement
Anfang Ebene 4 Knoten create_index_statement create_index_statement Ende Ebene 4 Knoten create_index_statement
Anfang Ebene 4 Knoten create_role_statement create_role_statement Ende Ebene 4 Knoten create_role_statement
Anfang Ebene 4 Knoten create_schema_statement create_schema_statement Ende Ebene 4 Knoten create_schema_statement
Anfang Ebene 4 Knoten create_sequence_statement create_sequence_statement Ende Ebene 4 Knoten create_sequence_statement
Anfang Ebene 4 Knoten create_synonym_statement create_synonym_statement Ende Ebene 4 Knoten create_synonym_statement
Anfang Ebene 4 Knoten create_system_trigger_statement create_system_trigger_statement Ende Ebene 4 Knoten create_system_trigger_statement
Anfang Ebene 4 Knoten create_table_statement create_table_statement Ende Ebene 4 Knoten create_table_statement
Anfang Ebene 4 Knoten create_table_temp create_table_temp Ende Ebene 4 Knoten create_table_temp
Anfang Ebene 4 Knoten create_trigger_statement create_trigger_statement Ende Ebene 4 Knoten create_trigger_statement
Anfang Ebene 4 Knoten create_user_statement create_user_statement Ende Ebene 4 Knoten create_user_statement
Anfang Ebene 4 Knoten create_usergroup_statement create_usergroup_statement Ende Ebene 4 Knoten create_usergroup_statement
Anfang Ebene 4 Knoten create_view_statement create_view_statement Ende Ebene 4 Knoten create_view_statement
Anfang Ebene 4 Knoten data_type data_type Ende Ebene 4 Knoten data_type
Anfang Ebene 4 Knoten date_function date_function Ende Ebene 4 Knoten date_function
Anfang Ebene 4 Knoten date_or_timestamp_expression date_or_timestamp_expression Ende Ebene 4 Knoten date_or_timestamp_expression
Anfang Ebene 4 Knoten datetimeformat datetimeformat Ende Ebene 4 Knoten datetimeformat
Anfang Ebene 4 Knoten dbfunction_call dbfunction_call Ende Ebene 4 Knoten dbfunction_call
Anfang Ebene 4 Knoten dbfunction_name dbfunction_name Ende Ebene 4 Knoten dbfunction_name
Anfang Ebene 4 Knoten dbproc_name dbproc_name Ende Ebene 4 Knoten dbproc_name
Anfang Ebene 4 Knoten declare_cursor_statement declare_cursor_statement Ende Ebene 4 Knoten declare_cursor_statement
Anfang Ebene 4 Knoten default_expression default_expression Ende Ebene 4 Knoten default_expression
Anfang Ebene 4 Knoten default_predicate default_predicate Ende Ebene 4 Knoten default_predicate
Anfang Ebene 4 Knoten default_spec default_spec Ende Ebene 4 Knoten default_spec
Anfang Ebene 4 Knoten delete_rule delete_rule Ende Ebene 4 Knoten delete_rule
Anfang Ebene 4 Knoten delete_statement delete_statement Ende Ebene 4 Knoten delete_statement
Anfang Ebene 4 Knoten delimiter_token delimiter_token Ende Ebene 4 Knoten delimiter_token
Anfang Ebene 4 Knoten derived_column derived_column Ende Ebene 4 Knoten derived_column
Anfang Ebene 4 Knoten digit digit Ende Ebene 4 Knoten digit
Anfang Ebene 4 Knoten digit_sequence digit_sequence Ende Ebene 4 Knoten digit_sequence
Anfang Ebene 4 Knoten distinct_function distinct_function Ende Ebene 4 Knoten distinct_function
Anfang Ebene 4 Knoten distinct_spec distinct_spec Ende Ebene 4 Knoten distinct_spec
Anfang Ebene 4 Knoten domain_name domain_name Ende Ebene 4 Knoten domain_name
Anfang Ebene 4 Knoten double_quotes double_quotes Ende Ebene 4 Knoten double_quotes
Anfang Ebene 4 Knoten drop_dbproc_statement drop_dbproc_statement Ende Ebene 4 Knoten drop_dbproc_statement
Anfang Ebene 4 Knoten drop_definition drop_definition Ende Ebene 4 Knoten drop_definition
Anfang Ebene 4 Knoten drop_domain_statement drop_domain_statement Ende Ebene 4 Knoten drop_domain_statement
Anfang Ebene 4 Knoten drop_function_statement drop_function_statement Ende Ebene 4 Knoten drop_function_statement
Anfang Ebene 4 Knoten drop_index_statement drop_index_statement Ende Ebene 4 Knoten drop_index_statement
Anfang Ebene 4 Knoten drop_role_statement drop_role_statement Ende Ebene 4 Knoten drop_role_statement
Anfang Ebene 4 Knoten drop_schema_statement drop_schema_statement Ende Ebene 4 Knoten drop_schema_statement
Anfang Ebene 4 Knoten drop_sequence_statement drop_sequence_statement Ende Ebene 4 Knoten drop_sequence_statement
Anfang Ebene 4 Knoten drop_synonym_statement drop_synonym_statement Ende Ebene 4 Knoten drop_synonym_statement
Anfang Ebene 4 Knoten drop_system_trigger_statement drop_system_trigger_statement Ende Ebene 4 Knoten drop_system_trigger_statement
Anfang Ebene 4 Knoten drop_table_statement drop_table_statement Ende Ebene 4 Knoten drop_table_statement
Anfang Ebene 4 Knoten drop_table_temp drop_table_temp Ende Ebene 4 Knoten drop_table_temp
Anfang Ebene 4 Knoten drop_trigger_statement drop_trigger_statement Ende Ebene 4 Knoten drop_trigger_statement
Anfang Ebene 4 Knoten drop_user_statement drop_user_statement Ende Ebene 4 Knoten drop_user_statement
Anfang Ebene 4 Knoten drop_usergroup_statement drop_usergroup_statement Ende Ebene 4 Knoten drop_usergroup_statement
Anfang Ebene 4 Knoten drop_view_statement drop_view_statement Ende Ebene 4 Knoten drop_view_statement
Anfang Ebene 4 Knoten duplicates_clause duplicates_clause Ende Ebene 4 Knoten duplicates_clause
Anfang Ebene 4 Knoten equal_or_not equal_or_not Ende Ebene 4 Knoten equal_or_not
Anfang Ebene 4 Knoten exists_predicate exists_predicate Ende Ebene 4 Knoten exists_predicate
Anfang Ebene 4 Knoten exists_table_statement exists_table_statement Ende Ebene 4 Knoten exists_table_statement
Anfang Ebene 4 Knoten explain_statement explain_statement Ende Ebene 4 Knoten explain_statement
Anfang Ebene 4 Knoten exponent exponent Ende Ebene 4 Knoten exponent
Anfang Ebene 4 Knoten expression expression Ende Ebene 4 Knoten expression
Anfang Ebene 4 Knoten expression_list expression_list Ende Ebene 4 Knoten expression_list
Anfang Ebene 4 Knoten extended_expression extended_expression Ende Ebene 4 Knoten extended_expression
Anfang Ebene 4 Knoten extended_letter extended_letter Ende Ebene 4 Knoten extended_letter
Anfang Ebene 4 Knoten extended_value_spec extended_value_spec Ende Ebene 4 Knoten extended_value_spec
Anfang Ebene 4 Knoten extraction_function extraction_function Ende Ebene 4 Knoten extraction_function
Anfang Ebene 4 Knoten factor factor Ende Ebene 4 Knoten factor
Anfang Ebene 4 Knoten fetch_statement fetch_statement Ende Ebene 4 Knoten fetch_statement
Anfang Ebene 4 Knoten final_select final_select Ende Ebene 4 Knoten final_select
Anfang Ebene 4 Knoten first_character first_character Ende Ebene 4 Knoten first_character
Anfang Ebene 4 Knoten first_password_character first_password_character Ende Ebene 4 Knoten first_password_character
Anfang Ebene 4 Knoten fixed_point_literal fixed_point_literal Ende Ebene 4 Knoten fixed_point_literal
Anfang Ebene 4 Knoten floating_point_literal floating_point_literal Ende Ebene 4 Knoten floating_point_literal
Anfang Ebene 4 Knoten formal_parameter formal_parameter Ende Ebene 4 Knoten formal_parameter
Anfang Ebene 4 Knoten formal_parameter1 formal_parameter1 Ende Ebene 4 Knoten formal_parameter1
Anfang Ebene 4 Knoten from_clause from_clause Ende Ebene 4 Knoten from_clause
Anfang Ebene 4 Knoten from_table_spec from_table_spec Ende Ebene 4 Knoten from_table_spec
Anfang Ebene 4 Knoten function_spec function_spec Ende Ebene 4 Knoten function_spec
Anfang Ebene 4 Knoten grant_statement grant_statement Ende Ebene 4 Knoten grant_statement
Anfang Ebene 4 Knoten grant_user_statement grant_user_statement Ende Ebene 4 Knoten grant_user_statement
Anfang Ebene 4 Knoten grant_usergroup_statement grant_usergroup_statement Ende Ebene 4 Knoten grant_usergroup_statement
Anfang Ebene 4 Knoten granted_usergroups granted_usergroups Ende Ebene 4 Knoten granted_usergroups
Anfang Ebene 4 Knoten granted_users granted_users Ende Ebene 4 Knoten granted_users
Anfang Ebene 4 Knoten grantee grantee Ende Ebene 4 Knoten grantee
Anfang Ebene 4 Knoten group_clause group_clause Ende Ebene 4 Knoten group_clause
Anfang Ebene 4 Knoten having_clause having_clause Ende Ebene 4 Knoten having_clause
Anfang Ebene 4 Knoten hex_digit hex_digit Ende Ebene 4 Knoten hex_digit
Anfang Ebene 4 Knoten hex_digit_seq hex_digit_seq Ende Ebene 4 Knoten hex_digit_seq
Anfang Ebene 4 Knoten hex_literal hex_literal Ende Ebene 4 Knoten hex_literal
Anfang Ebene 4 Knoten hours hours Ende Ebene 4 Knoten hours
Anfang Ebene 4 Knoten identifier identifier Ende Ebene 4 Knoten identifier
Anfang Ebene 4 Knoten identifier_tail_character identifier_tail_character Ende Ebene 4 Knoten identifier_tail_character
Anfang Ebene 4 Knoten if_statement if_statement Ende Ebene 4 Knoten if_statement
Anfang Ebene 4 Knoten in_predicate in_predicate Ende Ebene 4 Knoten in_predicate
Anfang Ebene 4 Knoten index_column_name index_column_name Ende Ebene 4 Knoten index_column_name
Anfang Ebene 4 Knoten index_name index_name Ende Ebene 4 Knoten index_name
Anfang Ebene 4 Knoten index_spec index_spec Ende Ebene 4 Knoten index_spec
Anfang Ebene 4 Knoten indicator_name indicator_name Ende Ebene 4 Knoten indicator_name
Anfang Ebene 4 Knoten initial_select initial_select Ende Ebene 4 Knoten initial_select
Anfang Ebene 4 Knoten inner_transaction_statement inner_transaction_statement Ende Ebene 4 Knoten inner_transaction_statement
Anfang Ebene 4 Knoten insert_expression insert_expression Ende Ebene 4 Knoten insert_expression
Anfang Ebene 4 Knoten insert_statement insert_statement Ende Ebene 4 Knoten insert_statement
Anfang Ebene 4 Knoten integer integer Ende Ebene 4 Knoten integer
Anfang Ebene 4 Knoten INTERNAL_ANSI_DB2_ORACLE INTERNAL_ANSI_DB2_ORACLE Ende Ebene 4 Knoten INTERNAL_ANSI_DB2_ORACLE
Anfang Ebene 4 Knoten join_predicate join_predicate Ende Ebene 4 Knoten join_predicate
Anfang Ebene 4 Knoten join_spec join_spec Ende Ebene 4 Knoten join_spec
Anfang Ebene 4 Knoten joined_table joined_table Ende Ebene 4 Knoten joined_table
Anfang Ebene 4 Knoten key_definition key_definition Ende Ebene 4 Knoten key_definition
Anfang Ebene 4 Knoten key_or_not_null_spec key_or_not_null_spec Ende Ebene 4 Knoten key_or_not_null_spec
Anfang Ebene 4 Knoten key_spec key_spec Ende Ebene 4 Knoten key_spec
Anfang Ebene 4 Knoten key_word key_word Ende Ebene 4 Knoten key_word
Anfang Ebene 4 Knoten language_specific_character language_specific_character Ende Ebene 4 Knoten language_specific_character
Anfang Ebene 4 Knoten letter letter Ende Ebene 4 Knoten letter
Anfang Ebene 4 Knoten like_expression like_expression Ende Ebene 4 Knoten like_expression
Anfang Ebene 4 Knoten like_predicate like_predicate Ende Ebene 4 Knoten like_predicate
Anfang Ebene 4 Knoten limit_clause limit_clause Ende Ebene 4 Knoten limit_clause
Anfang Ebene 4 Knoten literal literal Ende Ebene 4 Knoten literal
Anfang Ebene 4 Knoten local_variable local_variable Ende Ebene 4 Knoten local_variable
Anfang Ebene 4 Knoten local_variable_list local_variable_list Ende Ebene 4 Knoten local_variable_list
Anfang Ebene 4 Knoten local_variables local_variables Ende Ebene 4 Knoten local_variables
Anfang Ebene 4 Knoten lock_option lock_option Ende Ebene 4 Knoten lock_option
Anfang Ebene 4 Knoten lock_spec lock_spec Ende Ebene 4 Knoten lock_spec
Anfang Ebene 4 Knoten lock_statement lock_statement Ende Ebene 4 Knoten lock_statement
Anfang Ebene 4 Knoten mantissa mantissa Ende Ebene 4 Knoten mantissa
Anfang Ebene 4 Knoten mapchar_set_name mapchar_set_name Ende Ebene 4 Knoten mapchar_set_name
Anfang Ebene 4 Knoten match_char match_char Ende Ebene 4 Knoten match_char
Anfang Ebene 4 Knoten match_set match_set Ende Ebene 4 Knoten match_set
Anfang Ebene 4 Knoten match_string match_string Ende Ebene 4 Knoten match_string
Anfang Ebene 4 Knoten minutes minutes Ende Ebene 4 Knoten minutes
Anfang Ebene 4 Knoten modify_column_definition modify_column_definition Ende Ebene 4 Knoten modify_column_definition
Anfang Ebene 4 Knoten modify_definition modify_definition Ende Ebene 4 Knoten modify_definition
Anfang Ebene 4 Knoten monitor_statement monitor_statement Ende Ebene 4 Knoten monitor_statement
Anfang Ebene 4 Knoten new_index_name new_index_name Ende Ebene 4 Knoten new_index_name
Anfang Ebene 4 Knoten new_password new_password Ende Ebene 4 Knoten new_password
Anfang Ebene 4 Knoten new_schema_name new_schema_name Ende Ebene 4 Knoten new_schema_name
Anfang Ebene 4 Knoten new_synonym_name new_synonym_name Ende Ebene 4 Knoten new_synonym_name
Anfang Ebene 4 Knoten new_table_name new_table_name Ende Ebene 4 Knoten new_table_name
Anfang Ebene 4 Knoten new_user_name new_user_name Ende Ebene 4 Knoten new_user_name
Anfang Ebene 4 Knoten new_usergroup_name new_usergroup_name Ende Ebene 4 Knoten new_usergroup_name
Anfang Ebene 4 Knoten next_stamp_statement next_stamp_statement Ende Ebene 4 Knoten next_stamp_statement
Anfang Ebene 4 Knoten not_reserved_key_word not_reserved_key_word Ende Ebene 4 Knoten not_reserved_key_word
Anfang Ebene 4 Knoten null_predicate null_predicate Ende Ebene 4 Knoten null_predicate
Anfang Ebene 4 Knoten numeric_literal numeric_literal Ende Ebene 4 Knoten numeric_literal
Anfang Ebene 4 Knoten object_spec object_spec Ende Ebene 4 Knoten object_spec
Anfang Ebene 4 Knoten offset offset Ende Ebene 4 Knoten offset
Anfang Ebene 4 Knoten old_index_name old_index_name Ende Ebene 4 Knoten old_index_name
Anfang Ebene 4 Knoten old_password old_password Ende Ebene 4 Knoten old_password
Anfang Ebene 4 Knoten old_synonym_name old_synonym_name Ende Ebene 4 Knoten old_synonym_name
Anfang Ebene 4 Knoten old_table_name old_table_name Ende Ebene 4 Knoten old_table_name
Anfang Ebene 4 Knoten order_clause order_clause Ende Ebene 4 Knoten order_clause
Anfang Ebene 4 Knoten outer_join_indicator outer_join_indicator Ende Ebene 4 Knoten outer_join_indicator
Anfang Ebene 4 Knoten parameter_name parameter_name Ende Ebene 4 Knoten parameter_name
Anfang Ebene 4 Knoten parameter_spec parameter_spec Ende Ebene 4 Knoten parameter_spec
Anfang Ebene 4 Knoten password password Ende Ebene 4 Knoten password
Anfang Ebene 4 Knoten pattern_element pattern_element Ende Ebene 4 Knoten pattern_element
Anfang Ebene 4 Knoten position position Ende Ebene 4 Knoten position
Anfang Ebene 4 Knoten predicate predicate Ende Ebene 4 Knoten predicate
Anfang Ebene 4 Knoten priv_spec priv_spec Ende Ebene 4 Knoten priv_spec
Anfang Ebene 4 Knoten privilege privilege Ende Ebene 4 Knoten privilege
Anfang Ebene 4 Knoten quantified_predicate quantified_predicate Ende Ebene 4 Knoten quantified_predicate
Anfang Ebene 4 Knoten quantifier quantifier Ende Ebene 4 Knoten quantifier
Anfang Ebene 4 Knoten query_expression query_expression Ende Ebene 4 Knoten query_expression
Anfang Ebene 4 Knoten query_primary query_primary Ende Ebene 4 Knoten query_primary
Anfang Ebene 4 Knoten query_spec query_spec Ende Ebene 4 Knoten query_spec
Anfang Ebene 4 Knoten query_statement query_statement Ende Ebene 4 Knoten query_statement
Anfang Ebene 4 Knoten query_term query_term Ende Ebene 4 Knoten query_term
Anfang Ebene 4 Knoten recursive_declare_cursor_statement recursive_declare_cursor_statement Ende Ebene 4 Knoten recursive_declare_cursor_statement
Anfang Ebene 4 Knoten recursive_select recursive_select Ende Ebene 4 Knoten recursive_select
Anfang Ebene 4 Knoten reference_name reference_name Ende Ebene 4 Knoten reference_name
Anfang Ebene 4 Knoten referenced_column referenced_column Ende Ebene 4 Knoten referenced_column
Anfang Ebene 4 Knoten referenced_table referenced_table Ende Ebene 4 Knoten referenced_table
Anfang Ebene 4 Knoten referencing_column referencing_column Ende Ebene 4 Knoten referencing_column
Anfang Ebene 4 Knoten referential_constraint_definition referential_constraint_definition Ende Ebene 4 Knoten referential_constraint_definition
Anfang Ebene 4 Knoten referential_constraint_name referential_constraint_name Ende Ebene 4 Knoten referential_constraint_name
Anfang Ebene 4 Knoten regular_token regular_token Ende Ebene 4 Knoten regular_token
Anfang Ebene 4 Knoten release_savepoint_statement release_savepoint_statement Ende Ebene 4 Knoten release_savepoint_statement
Anfang Ebene 4 Knoten release_statement release_statement Ende Ebene 4 Knoten release_statement
Anfang Ebene 4 Knoten rename_column_statement rename_column_statement Ende Ebene 4 Knoten rename_column_statement
Anfang Ebene 4 Knoten rename_index_statement rename_index_statement Ende Ebene 4 Knoten rename_index_statement
Anfang Ebene 4 Knoten rename_schema_statement rename_schema_statement Ende Ebene 4 Knoten rename_schema_statement
Anfang Ebene 4 Knoten rename_synonym_statement rename_synonym_statement Ende Ebene 4 Knoten rename_synonym_statement
Anfang Ebene 4 Knoten rename_table_statement rename_table_statement Ende Ebene 4 Knoten rename_table_statement
Anfang Ebene 4 Knoten rename_user_statement rename_user_statement Ende Ebene 4 Knoten rename_user_statement
Anfang Ebene 4 Knoten rename_usergroup_statement rename_usergroup_statement Ende Ebene 4 Knoten rename_usergroup_statement
Anfang Ebene 4 Knoten rename_view_statement rename_view_statement Ende Ebene 4 Knoten rename_view_statement
Anfang Ebene 4 Knoten reserved_key_word reserved_key_word Ende Ebene 4 Knoten reserved_key_word
Anfang Ebene 4 Knoten result_column_name result_column_name Ende Ebene 4 Knoten result_column_name
Anfang Ebene 4 Knoten result_expression result_expression Ende Ebene 4 Knoten result_expression
Anfang Ebene 4 Knoten result_table_name result_table_name Ende Ebene 4 Knoten result_table_name
Anfang Ebene 4 Knoten revoke_statement revoke_statement Ende Ebene 4 Knoten revoke_statement
Anfang Ebene 4 Knoten role_name role_name Ende Ebene 4 Knoten role_name
Anfang Ebene 4 Knoten rollback_statement rollback_statement Ende Ebene 4 Knoten rollback_statement
Anfang Ebene 4 Knoten rollback_to_statement rollback_to_statement Ende Ebene 4 Knoten rollback_to_statement
Anfang Ebene 4 Knoten routine routine Ende Ebene 4 Knoten routine
Anfang Ebene 4 Knoten routine_sql_statement routine_sql_statement Ende Ebene 4 Knoten routine_sql_statement
Anfang Ebene 4 Knoten row_count row_count Ende Ebene 4 Knoten row_count
Anfang Ebene 4 Knoten row_spec row_spec Ende Ebene 4 Knoten row_spec
Anfang Ebene 4 Knoten rowno_column rowno_column Ende Ebene 4 Knoten rowno_column
Anfang Ebene 4 Knoten rowno_predicate rowno_predicate Ende Ebene 4 Knoten rowno_predicate
Anfang Ebene 4 Knoten sample_definition sample_definition Ende Ebene 4 Knoten sample_definition
Anfang Ebene 4 Knoten savepoint_statement savepoint_statement Ende Ebene 4 Knoten savepoint_statement
Anfang Ebene 4 Knoten scalar_subquery scalar_subquery Ende Ebene 4 Knoten scalar_subquery
Anfang Ebene 4 Knoten schema_authorization_identifier schema_authorization_identifier Ende Ebene 4 Knoten schema_authorization_identifier
Anfang Ebene 4 Knoten schema_element schema_element Ende Ebene 4 Knoten schema_element
Anfang Ebene 4 Knoten schema_name schema_name Ende Ebene 4 Knoten schema_name
Anfang Ebene 4 Knoten schema_name_clause schema_name_clause Ende Ebene 4 Knoten schema_name_clause
Anfang Ebene 4 Knoten schema_priv_spec schema_priv_spec Ende Ebene 4 Knoten schema_priv_spec
Anfang Ebene 4 Knoten schema_privilege schema_privilege Ende Ebene 4 Knoten schema_privilege
Anfang Ebene 4 Knoten search_and_result_spec search_and_result_spec Ende Ebene 4 Knoten search_and_result_spec
Anfang Ebene 4 Knoten search_condition search_condition Ende Ebene 4 Knoten search_condition
Anfang Ebene 4 Knoten search_expression search_expression Ende Ebene 4 Knoten search_expression
Anfang Ebene 4 Knoten searched_case_function searched_case_function Ende Ebene 4 Knoten searched_case_function
Anfang Ebene 4 Knoten searched_case_statement searched_case_statement Ende Ebene 4 Knoten searched_case_statement
Anfang Ebene 4 Knoten searched_case_when_clause searched_case_when_clause Ende Ebene 4 Knoten searched_case_when_clause
Anfang Ebene 4 Knoten seconds seconds Ende Ebene 4 Knoten seconds
Anfang Ebene 4 Knoten select_column select_column Ende Ebene 4 Knoten select_column
Anfang Ebene 4 Knoten select_statement select_statement Ende Ebene 4 Knoten select_statement
Anfang Ebene 4 Knoten sequence_name sequence_name Ende Ebene 4 Knoten sequence_name
Anfang Ebene 4 Knoten set_function_name set_function_name Ende Ebene 4 Knoten set_function_name
Anfang Ebene 4 Knoten set_function_spec set_function_spec Ende Ebene 4 Knoten set_function_spec
Anfang Ebene 4 Knoten set_insert_clause set_insert_clause Ende Ebene 4 Knoten set_insert_clause
Anfang Ebene 4 Knoten set_statement set_statement Ende Ebene 4 Knoten set_statement
Anfang Ebene 4 Knoten set_update_clause set_update_clause Ende Ebene 4 Knoten set_update_clause
Anfang Ebene 4 Knoten sign sign Ende Ebene 4 Knoten sign
Anfang Ebene 4 Knoten simple_case_function simple_case_function Ende Ebene 4 Knoten simple_case_function
Anfang Ebene 4 Knoten simple_case_statement simple_case_statement Ende Ebene 4 Knoten simple_case_statement
Anfang Ebene 4 Knoten simple_case_when_clause simple_case_when_clause Ende Ebene 4 Knoten simple_case_when_clause
Anfang Ebene 4 Knoten simple_identifier simple_identifier Ende Ebene 4 Knoten simple_identifier
Anfang Ebene 4 Knoten single_select_statement single_select_statement Ende Ebene 4 Knoten single_select_statement
Anfang Ebene 4 Knoten sort_spec sort_spec Ende Ebene 4 Knoten sort_spec
Anfang Ebene 4 Knoten sound_predicate sound_predicate Ende Ebene 4 Knoten sound_predicate
Anfang Ebene 4 Knoten source_user source_user Ende Ebene 4 Knoten source_user
Anfang Ebene 4 Knoten special_character special_character Ende Ebene 4 Knoten special_character
Anfang Ebene 4 Knoten special_function special_function Ende Ebene 4 Knoten special_function
Anfang Ebene 4 Knoten special_identifier special_identifier Ende Ebene 4 Knoten special_identifier
Anfang Ebene 4 Knoten special_identifier_character special_identifier_character Ende Ebene 4 Knoten special_identifier_character
Anfang Ebene 4 Knoten sql_comment sql_comment Ende Ebene 4 Knoten sql_comment
Anfang Ebene 4 Knoten sql_comment_text sql_comment_text Ende Ebene 4 Knoten sql_comment_text
Anfang Ebene 4 Knoten sql_savepoint_name sql_savepoint_name Ende Ebene 4 Knoten sql_savepoint_name
Anfang Ebene 4 Knoten sql_statement sql_statement Ende Ebene 4 Knoten sql_statement
Anfang Ebene 4 Knoten stamp_column stamp_column Ende Ebene 4 Knoten stamp_column
Anfang Ebene 4 Knoten statement statement Ende Ebene 4 Knoten statement
Anfang Ebene 4 Knoten statement_list statement_list Ende Ebene 4 Knoten statement_list
Anfang Ebene 4 Knoten string_function string_function Ende Ebene 4 Knoten string_function
Anfang Ebene 4 Knoten string_literal string_literal Ende Ebene 4 Knoten string_literal
Anfang Ebene 4 Knoten string_spec string_spec Ende Ebene 4 Knoten string_spec
Anfang Ebene 4 Knoten subquery subquery Ende Ebene 4 Knoten subquery
Anfang Ebene 4 Knoten subtrans_statement subtrans_statement Ende Ebene 4 Knoten subtrans_statement
Anfang Ebene 4 Knoten synonym_name synonym_name Ende Ebene 4 Knoten synonym_name
Anfang Ebene 4 Knoten table_columns table_columns Ende Ebene 4 Knoten table_columns
Anfang Ebene 4 Knoten table_description_element table_description_element Ende Ebene 4 Knoten table_description_element
Anfang Ebene 4 Knoten table_expression table_expression Ende Ebene 4 Knoten table_expression
Anfang Ebene 4 Knoten table_name table_name Ende Ebene 4 Knoten table_name
Anfang Ebene 4 Knoten term term Ende Ebene 4 Knoten term
Anfang Ebene 4 Knoten time_expression time_expression Ende Ebene 4 Knoten time_expression
Anfang Ebene 4 Knoten time_or_timestamp_expression time_or_timestamp_expression Ende Ebene 4 Knoten time_or_timestamp_expression
Anfang Ebene 4 Knoten time_function time_function Ende Ebene 4 Knoten time_function
Anfang Ebene 4 Knoten token token Ende Ebene 4 Knoten token
Anfang Ebene 4 Knoten top_spec top_spec Ende Ebene 4 Knoten top_spec
Anfang Ebene 4 Knoten trigger_event trigger_event Ende Ebene 4 Knoten trigger_event
Anfang Ebene 4 Knoten trigger_name trigger_name Ende Ebene 4 Knoten trigger_name
Anfang Ebene 4 Knoten trigonometric_function trigonometric_function Ende Ebene 4 Knoten trigonometric_function
Anfang Ebene 4 Knoten underscore underscore Ende Ebene 4 Knoten underscore
Anfang Ebene 4 Knoten unique_definition unique_definition Ende Ebene 4 Knoten unique_definition
Anfang Ebene 4 Knoten unlock_statement unlock_statement Ende Ebene 4 Knoten unlock_statement
Anfang Ebene 4 Knoten unsigned_integer unsigned_integer Ende Ebene 4 Knoten unsigned_integer
Anfang Ebene 4 Knoten update_clause update_clause Ende Ebene 4 Knoten update_clause
Anfang Ebene 4 Knoten update_statement update_statement Ende Ebene 4 Knoten update_statement
Anfang Ebene 4 Knoten update_statistics_statement update_statistics_statement Ende Ebene 4 Knoten update_statistics_statement
Anfang Ebene 4 Knoten user_mode user_mode Ende Ebene 4 Knoten user_mode
Anfang Ebene 4 Knoten user_name user_name Ende Ebene 4 Knoten user_name
Anfang Ebene 4 Knoten usergroup_mode usergroup_mode Ende Ebene 4 Knoten usergroup_mode
Anfang Ebene 4 Knoten usergroup_name usergroup_name Ende Ebene 4 Knoten usergroup_name
Anfang Ebene 4 Knoten value_spec value_spec Ende Ebene 4 Knoten value_spec
Anfang Ebene 4 Knoten variable_name variable_name Ende Ebene 4 Knoten variable_name
Anfang Ebene 4 Knoten vertical_slash vertical_slash Ende Ebene 4 Knoten vertical_slash
Anfang Ebene 4 Knoten where_clause where_clause Ende Ebene 4 Knoten where_clause
Anfang Ebene 4 Knoten while_statement while_statement Ende Ebene 4 Knoten while_statement
Anfang Ebene 4 Knoten Syntaxnotation Syntaxnotation Ende Ebene 4 Knoten Syntaxnotation
Anfang Ebene 4 Knoten Syntaxänderungen Syntaxänderungen Ende Ebene 4 Knoten Syntaxänderungen
Anfang Ebene 3 Knoten Systemtabellen Systemtabellen Ende Ebene 3 Knoten Systemtabellen
Anfang Ebene 4 Knoten Allgemeine Hinweise Allgemeine Hinweise Ende Ebene 4 Knoten Allgemeine Hinweise
Anfang Ebene 4 Knoten Datenbankbegriffe Datenbankbegriffe Ende Ebene 4 Knoten Datenbankbegriffe
Anfang Ebene 4 Knoten Systemtabellen auswerten (Beispiele) Systemtabellen auswerten (Beispiele) Ende Ebene 4 Knoten Systemtabellen auswerten (Beispiele)
Anfang Ebene 5 Knoten ACTIVECONFIGURATION ACTIVECONFIGURATION Ende Ebene 5 Knoten ACTIVECONFIGURATION
Anfang Ebene 5 Knoten CACHESTATISTICS CACHESTATISTICS Ende Ebene 5 Knoten CACHESTATISTICS
Anfang Ebene 5 Knoten COLUMNS COLUMNS Ende Ebene 5 Knoten COLUMNS
Anfang Ebene 5 Knoten CONSTRAINTS CONSTRAINTS Ende Ebene 5 Knoten CONSTRAINTS
Anfang Ebene 5 Knoten DATASTATISTICS DATASTATISTICS Ende Ebene 5 Knoten DATASTATISTICS
Anfang Ebene 5 Knoten DATAVOLUMES DATAVOLUMES Ende Ebene 5 Knoten DATAVOLUMES
Anfang Ebene 5 Knoten DBPROCEDURES DBPROCEDURES Ende Ebene 5 Knoten DBPROCEDURES
Anfang Ebene 5 Knoten DBPROCPARAMS DBPROCPARAMS Ende Ebene 5 Knoten DBPROCPARAMS
Anfang Ebene 5 Knoten DOMAINCONSTRAINTS DOMAINCONSTRAINTS Ende Ebene 5 Knoten DOMAINCONSTRAINTS
Anfang Ebene 5 Knoten DOMAINS DOMAINS Ende Ebene 5 Knoten DOMAINS
Anfang Ebene 5 Knoten FOREIGNKEYCOLUMNS FOREIGNKEYCOLUMNS Ende Ebene 5 Knoten FOREIGNKEYCOLUMNS
Anfang Ebene 5 Knoten FOREIGNKEYS FOREIGNKEYS Ende Ebene 5 Knoten FOREIGNKEYS
Anfang Ebene 5 Knoten FUNCTIONS FUNCTIONS Ende Ebene 5 Knoten FUNCTIONS
Anfang Ebene 5 Knoten INDEXCOLUMNS INDEXCOLUMNS Ende Ebene 5 Knoten INDEXCOLUMNS
Anfang Ebene 5 Knoten INDEXES INDEXES Ende Ebene 5 Knoten INDEXES
Anfang Ebene 5 Knoten INSTANCE INSTANCE Ende Ebene 5 Knoten INSTANCE
Anfang Ebene 5 Knoten LOCKS LOCKS Ende Ebene 5 Knoten LOCKS
Anfang Ebene 5 Knoten LOGQUEUESTATISTICS LOGQUEUESTATISTICS Ende Ebene 5 Knoten LOGQUEUESTATISTICS
Anfang Ebene 5 Knoten LOGSTATISTICS LOGSTATISTICS Ende Ebene 5 Knoten LOGSTATISTICS
Anfang Ebene 5 Knoten MAPCHARSETS MAPCHARSETS Ende Ebene 5 Knoten MAPCHARSETS
Anfang Ebene 5 Knoten ROLEPRIVILEGES ROLEPRIVILEGES Ende Ebene 5 Knoten ROLEPRIVILEGES
Anfang Ebene 5 Knoten ROLES ROLES Ende Ebene 5 Knoten ROLES
Anfang Ebene 5 Knoten SEQUENCES SEQUENCES Ende Ebene 5 Knoten SEQUENCES
Anfang Ebene 5 Knoten SESSION_ROLES SESSION_ROLES Ende Ebene 5 Knoten SESSION_ROLES
Anfang Ebene 5 Knoten SESSIONS SESSIONS Ende Ebene 5 Knoten SESSIONS
Anfang Ebene 5 Knoten SYNONYMS SYNONYMS Ende Ebene 5 Knoten SYNONYMS
Anfang Ebene 5 Knoten TABLEPRIVILEGES TABLEPRIVILEGES Ende Ebene 5 Knoten TABLEPRIVILEGES
Anfang Ebene 5 Knoten TABLES TABLES Ende Ebene 5 Knoten TABLES
Anfang Ebene 5 Knoten TRIGGERS TRIGGERS Ende Ebene 5 Knoten TRIGGERS
Anfang Ebene 5 Knoten USERS USERS Ende Ebene 5 Knoten USERS
Anfang Ebene 5 Knoten VERSION VERSION Ende Ebene 5 Knoten VERSION
Anfang Ebene 5 Knoten VIEWCOLUMNS VIEWCOLUMNS Ende Ebene 5 Knoten VIEWCOLUMNS
Anfang Ebene 5 Knoten VIEWDEFS VIEWDEFS Ende Ebene 5 Knoten VIEWDEFS
Anfang Ebene 5 Knoten VIEWS VIEWS Ende Ebene 5 Knoten VIEWS
Anfang Ebene 4 Knoten Definitionen der Systemtabellen Definitionen der Systemtabellen Ende Ebene 4 Knoten Definitionen der Systemtabellen
Anfang Ebene 5 Knoten ACTIVECONFIGURATION ACTIVECONFIGURATION Ende Ebene 5 Knoten ACTIVECONFIGURATION
Anfang Ebene 5 Knoten BACKUPTHREADS BACKUPTHREADS Ende Ebene 5 Knoten BACKUPTHREADS
Anfang Ebene 5 Knoten CACHESTATISTICS CACHESTATISTICS Ende Ebene 5 Knoten CACHESTATISTICS
Anfang Ebene 5 Knoten CATALOGCACHESTATISTICS CATALOGCACHESTATISTICS Ende Ebene 5 Knoten CATALOGCACHESTATISTICS
Anfang Ebene 5 Knoten CLASSCONTAINER_CHAINS CLASSCONTAINER_CHAINS Ende Ebene 5 Knoten CLASSCONTAINER_CHAINS
Anfang Ebene 5 Knoten CLASSCONTAINER_KEYS CLASSCONTAINER_KEYS Ende Ebene 5 Knoten CLASSCONTAINER_KEYS
Anfang Ebene 5 Knoten CLASSCONTAINER_ROOTS CLASSCONTAINER_ROOTS Ende Ebene 5 Knoten CLASSCONTAINER_ROOTS
Anfang Ebene 5 Knoten CLASSCONTAINERS CLASSCONTAINERS Ende Ebene 5 Knoten CLASSCONTAINERS
Anfang Ebene 5 Knoten CODEPAGE CODEPAGE Ende Ebene 5 Knoten CODEPAGE
Anfang Ebene 5 Knoten COLUMNS COLUMNS Ende Ebene 5 Knoten COLUMNS
Anfang Ebene 5 Knoten COMMANDCACHESTATISTICS COMMANDCACHESTATISTICS Ende Ebene 5 Knoten COMMANDCACHESTATISTICS
Anfang Ebene 5 Knoten COMMANDCACHESTATISTICSRESET COMMANDCACHESTATISTICSRESET Ende Ebene 5 Knoten COMMANDCACHESTATISTICSRESET
Anfang Ebene 5 Knoten COMMANDSTATISTICS COMMANDSTATISTICS Ende Ebene 5 Knoten COMMANDSTATISTICS
Anfang Ebene 5 Knoten COMMANDSTATISTICSRESET COMMANDSTATISTICSRESET Ende Ebene 5 Knoten COMMANDSTATISTICSRESET
Anfang Ebene 5 Knoten CONNECTEDUSERS CONNECTEDUSERS Ende Ebene 5 Knoten CONNECTEDUSERS
Anfang Ebene 5 Knoten CONNECTPARAMETERS CONNECTPARAMETERS Ende Ebene 5 Knoten CONNECTPARAMETERS
Anfang Ebene 5 Knoten CONSISTENTVIEWS CONSISTENTVIEWS Ende Ebene 5 Knoten CONSISTENTVIEWS
Anfang Ebene 5 Knoten CONSTRAINTCOLUMNS CONSTRAINTCOLUMNS Ende Ebene 5 Knoten CONSTRAINTCOLUMNS
Anfang Ebene 5 Knoten CONSTRAINTS CONSTRAINTS Ende Ebene 5 Knoten CONSTRAINTS
Anfang Ebene 5 Knoten DATACACHE DATACACHE Ende Ebene 5 Knoten DATACACHE
Anfang Ebene 5 Knoten DATASTATISTICS DATASTATISTICS Ende Ebene 5 Knoten DATASTATISTICS
Anfang Ebene 5 Knoten DATASTATISTICSRESET DATASTATISTICSRESET Ende Ebene 5 Knoten DATASTATISTICSRESET
Anfang Ebene 5 Knoten DATAVOLUMES DATAVOLUMES Ende Ebene 5 Knoten DATAVOLUMES
Anfang Ebene 5 Knoten DBPARAMETERS DBPARAMETERS Ende Ebene 5 Knoten DBPARAMETERS
Anfang Ebene 5 Knoten DBPROCEDURES DBPROCEDURES Ende Ebene 5 Knoten DBPROCEDURES
Anfang Ebene 5 Knoten DBPROCPARAMS DBPROCPARAMS Ende Ebene 5 Knoten DBPROCPARAMS
Anfang Ebene 5 Knoten DOMAINCONSTRAINTS DOMAINCONSTRAINTS Ende Ebene 5 Knoten DOMAINCONSTRAINTS
Anfang Ebene 5 Knoten DOMAINS DOMAINS Ende Ebene 5 Knoten DOMAINS
Anfang Ebene 5 Knoten FILEDIRECTORIES FILEDIRECTORIES Ende Ebene 5 Knoten FILEDIRECTORIES
Anfang Ebene 5 Knoten FILES FILES Ende Ebene 5 Knoten FILES
Anfang Ebene 5 Knoten FOREIGNKEYCOLUMNS FOREIGNKEYCOLUMNS Ende Ebene 5 Knoten FOREIGNKEYCOLUMNS
Anfang Ebene 5 Knoten FOREIGNKEYS FOREIGNKEYS Ende Ebene 5 Knoten FOREIGNKEYS
Anfang Ebene 5 Knoten FUNCTIONS FUNCTIONS Ende Ebene 5 Knoten FUNCTIONS
Anfang Ebene 5 Knoten GARBAGECOLLECTOR_STATISTICS GARBAGECOLLECTOR_STATISTICS Ende Ebene 5 Knoten GARBAGECOLLECTOR_STATISTICS
Anfang Ebene 5 Knoten HISTORYINFO HISTORYINFO Ende Ebene 5 Knoten HISTORYINFO
Anfang Ebene 5 Knoten HOTSTANDBYCOMPONENT HOTSTANDBYCOMPONENT Ende Ebene 5 Knoten HOTSTANDBYCOMPONENT
Anfang Ebene 5 Knoten HOTSTANDBYGROUP HOTSTANDBYGROUP Ende Ebene 5 Knoten HOTSTANDBYGROUP
Anfang Ebene 5 Knoten INDEXCOLUMNS INDEXCOLUMNS Ende Ebene 5 Knoten INDEXCOLUMNS
Anfang Ebene 5 Knoten INDEXES INDEXES Ende Ebene 5 Knoten INDEXES
Anfang Ebene 5 Knoten INDEXSIZE INDEXSIZE Ende Ebene 5 Knoten INDEXSIZE
Anfang Ebene 5 Knoten INDEXSTATISTICS INDEXSTATISTICS Ende Ebene 5 Knoten INDEXSTATISTICS
Anfang Ebene 5 Knoten INDEXSTORAGEDETAILS INDEXSTORAGEDETAILS Ende Ebene 5 Knoten INDEXSTORAGEDETAILS
Anfang Ebene 5 Knoten INSTANCE INSTANCE Ende Ebene 5 Knoten INSTANCE
Anfang Ebene 5 Knoten IOBUFFERCACHES IOBUFFERCACHES Ende Ebene 5 Knoten IOBUFFERCACHES
Anfang Ebene 5 Knoten IOTHREADSTATISTICS IOTHREADSTATISTICS Ende Ebene 5 Knoten IOTHREADSTATISTICS
Anfang Ebene 5 Knoten IOTHREADSTATISTICSRESET IOTHREADSTATISTICSRESET Ende Ebene 5 Knoten IOTHREADSTATISTICSRESET
Anfang Ebene 5 Knoten LOCKLISTSTATISTICS LOCKLISTSTATISTICS Ende Ebene 5 Knoten LOCKLISTSTATISTICS
Anfang Ebene 5 Knoten LOCKS LOCKS Ende Ebene 5 Knoten LOCKS
Anfang Ebene 5 Knoten LOCK_WAITS LOCK_WAITS Ende Ebene 5 Knoten LOCK_WAITS
Anfang Ebene 5 Knoten LOGINFORMATION LOGINFORMATION Ende Ebene 5 Knoten LOGINFORMATION
Anfang Ebene 5 Knoten LOGQUEUESTATISTICS LOGQUEUESTATISTICS Ende Ebene 5 Knoten LOGQUEUESTATISTICS
Anfang Ebene 5 Knoten LOGQUEUESTATISTICSRESET LOGQUEUESTATISTICSRESET Ende Ebene 5 Knoten LOGQUEUESTATISTICSRESET
Anfang Ebene 5 Knoten LOGSTATISTICS LOGSTATISTICS Ende Ebene 5 Knoten LOGSTATISTICS
Anfang Ebene 5 Knoten LOGSTATISTICSRESET LOGSTATISTICSRESET Ende Ebene 5 Knoten LOGSTATISTICSRESET
Anfang Ebene 5 Knoten LOGVOLUMES LOGVOLUMES Ende Ebene 5 Knoten LOGVOLUMES
Anfang Ebene 5 Knoten MACHINECONFIGURATION MACHINECONFIGURATION Ende Ebene 5 Knoten MACHINECONFIGURATION
Anfang Ebene 5 Knoten MACHINEUTILIZATION MACHINEUTILIZATION Ende Ebene 5 Knoten MACHINEUTILIZATION
Anfang Ebene 5 Knoten MAPCHARSETS MAPCHARSETS Ende Ebene 5 Knoten MAPCHARSETS
Anfang Ebene 5 Knoten MEMORYALLOCATORSTATISTICS MEMORYALLOCATORSTATISTICS Ende Ebene 5 Knoten MEMORYALLOCATORSTATISTICS
Anfang Ebene 5 Knoten MONITOR MONITOR Ende Ebene 5 Knoten MONITOR
Anfang Ebene 5 Knoten MONITOR_CACHES MONITOR_CACHES Ende Ebene 5 Knoten MONITOR_CACHES
Anfang Ebene 5 Knoten MONITOR_LOAD MONITOR_LOAD Ende Ebene 5 Knoten MONITOR_LOAD
Anfang Ebene 5 Knoten MONITOR_LOCK MONITOR_LOCK Ende Ebene 5 Knoten MONITOR_LOCK
Anfang Ebene 5 Knoten MONITOR_LOG MONITOR_LOG Ende Ebene 5 Knoten MONITOR_LOG
Anfang Ebene 5 Knoten MONITOR_LONG MONITOR_LONG Ende Ebene 5 Knoten MONITOR_LONG
Anfang Ebene 5 Knoten MONITOR_OMS MONITOR_OMS Ende Ebene 5 Knoten MONITOR_OMS
Anfang Ebene 5 Knoten MONITOR_PAGES MONITOR_PAGES Ende Ebene 5 Knoten MONITOR_PAGES
Anfang Ebene 5 Knoten MONITOR_REWRITE MONITOR_REWRITE Ende Ebene 5 Knoten MONITOR_REWRITE
Anfang Ebene 5 Knoten MONITOR_ROW MONITOR_ROW Ende Ebene 5 Knoten MONITOR_ROW
Anfang Ebene 5 Knoten MONITOR_TRANS MONITOR_TRANS Ende Ebene 5 Knoten MONITOR_TRANS
Anfang Ebene 5 Knoten OBJECTLOCKS OBJECTLOCKS Ende Ebene 5 Knoten OBJECTLOCKS
Anfang Ebene 5 Knoten OMS_HEAP_STATISTICS OMS_HEAP_STATISTICS Ende Ebene 5 Knoten OMS_HEAP_STATISTICS
Anfang Ebene 5 Knoten OMS_LOCKOBJ_INFO OMS_LOCKOBJ_INFO Ende Ebene 5 Knoten OMS_LOCKOBJ_INFO
Anfang Ebene 5 Knoten OMSLOCKS OMSLOCKS Ende Ebene 5 Knoten OMSLOCKS
Anfang Ebene 5 Knoten OMS_VERSIONS OMS_VERSIONS Ende Ebene 5 Knoten OMS_VERSIONS
Anfang Ebene 5 Knoten OPTIMIZERINFORMATION OPTIMIZERINFORMATION Ende Ebene 5 Knoten OPTIMIZERINFORMATION
Anfang Ebene 5 Knoten OPTIMIZERSTATISTICS OPTIMIZERSTATISTICS Ende Ebene 5 Knoten OPTIMIZERSTATISTICS
Anfang Ebene 5 Knoten PACKAGES PACKAGES Ende Ebene 5 Knoten PACKAGES
Anfang Ebene 5 Knoten POSTUPGRADECHECKLIST POSTUPGRADECHECKLIST Ende Ebene 5 Knoten POSTUPGRADECHECKLIST
Anfang Ebene 5 Knoten READERWRITERLOCKINFORMATION READERWRITERLOCKINFORMATION Ende Ebene 5 Knoten READERWRITERLOCKINFORMATION
Anfang Ebene 5 Knoten READERWRITERLOCKSTATISTICS READERWRITERLOCKSTATISTICS Ende Ebene 5 Knoten READERWRITERLOCKSTATISTICS
Anfang Ebene 5 Knoten READERWRITERLOCKSTATISTICSRESET READERWRITERLOCKSTATISTICSRESET Ende Ebene 5 Knoten READERWRITERLOCKSTATISTICSRESET
Anfang Ebene 5 Knoten READERWRITERLOCKWAITINGTASKS READERWRITERLOCKWAITINGTASKS Ende Ebene 5 Knoten READERWRITERLOCKWAITINGTASKS
Anfang Ebene 5 Knoten REGIONINFORMATION REGIONINFORMATION Ende Ebene 5 Knoten REGIONINFORMATION
Anfang Ebene 5 Knoten REGIONSTATISTICS REGIONSTATISTICS Ende Ebene 5 Knoten REGIONSTATISTICS
Anfang Ebene 5 Knoten REGIONSTATISTICSRESET REGIONSTATISTICSRESET Ende Ebene 5 Knoten REGIONSTATISTICSRESET
Anfang Ebene 5 Knoten RESTARTINFORMATION RESTARTINFORMATION Ende Ebene 5 Knoten RESTARTINFORMATION
Anfang Ebene 5 Knoten ROLEPRIVILEGES ROLEPRIVILEGES Ende Ebene 5 Knoten ROLEPRIVILEGES
Anfang Ebene 5 Knoten ROLES ROLES Ende Ebene 5 Knoten ROLES
Anfang Ebene 5 Knoten SCHEMAPRIVILEGES SCHEMAPRIVILEGES Ende Ebene 5 Knoten SCHEMAPRIVILEGES
Anfang Ebene 5 Knoten SCHEMAS SCHEMAS Ende Ebene 5 Knoten SCHEMAS
Anfang Ebene 5 Knoten SCHEMASIZE SCHEMASIZE Ende Ebene 5 Knoten SCHEMASIZE
Anfang Ebene 5 Knoten SEQUENCEPRIVILEGES SEQUENCEPRIVILEGES Ende Ebene 5 Knoten SEQUENCEPRIVILEGES
Anfang Ebene 5 Knoten SEQUENCES SEQUENCES Ende Ebene 5 Knoten SEQUENCES
Anfang Ebene 5 Knoten SERVERDBSTATISTICS SERVERDBSTATISTICS Ende Ebene 5 Knoten SERVERDBSTATISTICS
Anfang Ebene 5 Knoten SERVERTASKS SERVERTASKS Ende Ebene 5 Knoten SERVERTASKS
Anfang Ebene 5 Knoten SESSION_ROLES SESSION_ROLES Ende Ebene 5 Knoten SESSION_ROLES
Anfang Ebene 5 Knoten SESSIONS SESSIONS Ende Ebene 5 Knoten SESSIONS
Anfang Ebene 5 Knoten SNAPSHOTS SNAPSHOTS Ende Ebene 5 Knoten SNAPSHOTS
Anfang Ebene 5 Knoten SPINLOCKPOOLSTATISTICS SPINLOCKPOOLSTATISTICS Ende Ebene 5 Knoten SPINLOCKPOOLSTATISTICS
Anfang Ebene 5 Knoten SPINLOCKPOOLSTATISTICSRESET SPINLOCKPOOLSTATISTICSRESET Ende Ebene 5 Knoten SPINLOCKPOOLSTATISTICSRESET
Anfang Ebene 5 Knoten SPINLOCKSTATISTICS SPINLOCKSTATISTICS Ende Ebene 5 Knoten SPINLOCKSTATISTICS
Anfang Ebene 5 Knoten SPINLOCKSTATISTICSRESET SPINLOCKSTATISTICSRESET Ende Ebene 5 Knoten SPINLOCKSTATISTICSRESET
Anfang Ebene 5 Knoten SYNONYMS SYNONYMS Ende Ebene 5 Knoten SYNONYMS
Anfang Ebene 5 Knoten SYSTEMTRIGGERS SYSTEMTRIGGERS Ende Ebene 5 Knoten SYSTEMTRIGGERS
Anfang Ebene 5 Knoten SYSUPDATECOUNTERWANTED SYSUPDATECOUNTERWANTED Ende Ebene 5 Knoten SYSUPDATECOUNTERWANTED
Anfang Ebene 5 Knoten SYSUPDSTATWANTED SYSUPDSTATWANTED Ende Ebene 5 Knoten SYSUPDSTATWANTED
Anfang Ebene 5 Knoten SYSUPGRADEHISTORY SYSUPGRADEHISTORY Ende Ebene 5 Knoten SYSUPGRADEHISTORY
Anfang Ebene 5 Knoten TABLEPRIVILEGES TABLEPRIVILEGES Ende Ebene 5 Knoten TABLEPRIVILEGES
Anfang Ebene 5 Knoten TABLES TABLES Ende Ebene 5 Knoten TABLES
Anfang Ebene 5 Knoten TABLESIZE TABLESIZE Ende Ebene 5 Knoten TABLESIZE
Anfang Ebene 5 Knoten TABLESTATISTICS TABLESTATISTICS Ende Ebene 5 Knoten TABLESTATISTICS
Anfang Ebene 5 Knoten TABLESTORAGEDETAILS TABLESTORAGEDETAILS Ende Ebene 5 Knoten TABLESTORAGEDETAILS
Anfang Ebene 5 Knoten TASKGROUPSTATISTICS TASKGROUPSTATISTICS Ende Ebene 5 Knoten TASKGROUPSTATISTICS
Anfang Ebene 5 Knoten TASKGROUPSTATISTICSRESET TASKGROUPSTATISTICSRESET Ende Ebene 5 Knoten TASKGROUPSTATISTICSRESET
Anfang Ebene 5 Knoten TASKLOADBALANCINGINFORMATION TASKLOADBALANCINGINFORMATION Ende Ebene 5 Knoten TASKLOADBALANCINGINFORMATION
Anfang Ebene 5 Knoten TASKLOADBALANCINGTASKGROUPSTATES TASKLOADBALANCINGTASKGROUPSTATES Ende Ebene 5 Knoten TASKLOADBALANCINGTASKGROUPSTATES
Anfang Ebene 5 Knoten TASKLOADBALANCINGTASKMOVES TASKLOADBALANCINGTASKMOVES Ende Ebene 5 Knoten TASKLOADBALANCINGTASKMOVES
Anfang Ebene 5 Knoten TRANSACTIONHISTORY TRANSACTIONHISTORY Ende Ebene 5 Knoten TRANSACTIONHISTORY
Anfang Ebene 5 Knoten TRANSACTIONS TRANSACTIONS Ende Ebene 5 Knoten TRANSACTIONS
Anfang Ebene 5 Knoten TRANSACTIONS TRANSACTIONS Ende Ebene 5 Knoten TRANSACTIONS
Anfang Ebene 5 Knoten TRANSFORMATIONMODEL TRANSFORMATIONMODEL Ende Ebene 5 Knoten TRANSFORMATIONMODEL
Anfang Ebene 5 Knoten TRANSFORMATIONMONITOR TRANSFORMATIONMONITOR Ende Ebene 5 Knoten TRANSFORMATIONMONITOR
Anfang Ebene 5 Knoten TRANSFORMATIONPACKAGES TRANSFORMATIONPACKAGES Ende Ebene 5 Knoten TRANSFORMATIONPACKAGES
Anfang Ebene 5 Knoten TRANSFORMATIONRESOURCES TRANSFORMATIONRESOURCES Ende Ebene 5 Knoten TRANSFORMATIONRESOURCES
Anfang Ebene 5 Knoten TRANSFORMATIONSTATISTICS TRANSFORMATIONSTATISTICS Ende Ebene 5 Knoten TRANSFORMATIONSTATISTICS
Anfang Ebene 5 Knoten TRANSFORMATIONSTEPS TRANSFORMATIONSTEPS Ende Ebene 5 Knoten TRANSFORMATIONSTEPS
Anfang Ebene 5 Knoten TRIGGERS TRIGGERS Ende Ebene 5 Knoten TRIGGERS
Anfang Ebene 5 Knoten UNLOADEDSTATEMENTS UNLOADEDSTATEMENTS Ende Ebene 5 Knoten UNLOADEDSTATEMENTS
Anfang Ebene 5 Knoten USERS USERS Ende Ebene 5 Knoten USERS
Anfang Ebene 5 Knoten USERSTATISTICS USERSTATISTICS Ende Ebene 5 Knoten USERSTATISTICS
Anfang Ebene 5 Knoten VERSION VERSION Ende Ebene 5 Knoten VERSION
Anfang Ebene 5 Knoten VERSIONS VERSIONS Ende Ebene 5 Knoten VERSIONS
Anfang Ebene 5 Knoten VIEWCOLUMNS VIEWCOLUMNS Ende Ebene 5 Knoten VIEWCOLUMNS
Anfang Ebene 5 Knoten VIEWDEFS VIEWDEFS Ende Ebene 5 Knoten VIEWDEFS
Anfang Ebene 5 Knoten VIEWS VIEWS Ende Ebene 5 Knoten VIEWS
Anfang Ebene 5 Knoten VIEWTABLES VIEWTABLES Ende Ebene 5 Knoten VIEWTABLES
Anfang Ebene 3 Knoten Restriktionen für SQL-Anweisungen Restriktionen für SQL-Anweisungen Ende Ebene 3 Knoten Restriktionen für SQL-Anweisungen
Anfang Ebene 3 Knoten SQL-Modus ORACLE SQL-Modus ORACLE Ende Ebene 3 Knoten SQL-Modus ORACLE
Anfang Ebene 4 Knoten SQL-Syntaxelemente SQL-Syntaxelemente Ende Ebene 4 Knoten SQL-Syntaxelemente
Anfang Ebene 5 Knoten Datenbankobjekt Datenbankobjekt Ende Ebene 5 Knoten Datenbankobjekt
Anfang Ebene 5 Knoten Name Name Ende Ebene 5 Knoten Name
Anfang Ebene 5 Knoten Namensraum Namensraum Ende Ebene 5 Knoten Namensraum
Anfang Ebene 5 Knoten Zugriff auf Objekte Zugriff auf Objekte Ende Ebene 5 Knoten Zugriff auf Objekte
Anfang Ebene 5 Knoten Ganze Zahl Ganze Zahl Ende Ebene 5 Knoten Ganze Zahl
Anfang Ebene 5 Knoten Zahl Zahl Ende Ebene 5 Knoten Zahl
Anfang Ebene 5 Knoten Datentyp Datentyp Ende Ebene 5 Knoten Datentyp
Anfang Ebene 5 Knoten Pseudospalte Pseudospalte Ende Ebene 5 Knoten Pseudospalte
Anfang Ebene 5 Knoten Operator Operator Ende Ebene 5 Knoten Operator
Anfang Ebene 5 Knoten Funktion Funktion Ende Ebene 5 Knoten Funktion
Anfang Ebene 5 Knoten Format Format Ende Ebene 5 Knoten Format
Anfang Ebene 4 Knoten SQL-Anweisungen SQL-Anweisungen Ende Ebene 4 Knoten SQL-Anweisungen
Anfang Ebene 5 Knoten alter_cluster_statement alter_cluster_statement Ende Ebene 5 Knoten alter_cluster_statement
Anfang Ebene 5 Knoten alter_database_statement alter_database_statement Ende Ebene 5 Knoten alter_database_statement
Anfang Ebene 5 Knoten alter_function_statement alter_function_statement Ende Ebene 5 Knoten alter_function_statement
Anfang Ebene 5 Knoten alter_index_statement alter_index_statement Ende Ebene 5 Knoten alter_index_statement
Anfang Ebene 5 Knoten alter_package_statement alter_package_statement Ende Ebene 5 Knoten alter_package_statement
Anfang Ebene 5 Knoten alter_procedure_statement alter_procedure_statement Ende Ebene 5 Knoten alter_procedure_statement
Anfang Ebene 5 Knoten alter_profile_statement alter_profile_statement Ende Ebene 5 Knoten alter_profile_statement
Anfang Ebene 5 Knoten alter_resource_cost_statement alter_resource_cost_statement Ende Ebene 5 Knoten alter_resource_cost_statement
Anfang Ebene 5 Knoten alter_role_statement alter_role_statement Ende Ebene 5 Knoten alter_role_statement
Anfang Ebene 5 Knoten alter_rollback_segment_statement alter_rollback_segment_statement Ende Ebene 5 Knoten alter_rollback_segment_statement
Anfang Ebene 5 Knoten alter_sequence_statement alter_sequence_statement Ende Ebene 5 Knoten alter_sequence_statement
Anfang Ebene 5 Knoten alter_snapshot_statement alter_snapshot_statement Ende Ebene 5 Knoten alter_snapshot_statement
Anfang Ebene 5 Knoten alter_snapshot_log_statement alter_snapshot_log_statement Ende Ebene 5 Knoten alter_snapshot_log_statement
Anfang Ebene 5 Knoten alter_system_statement alter_system_statement Ende Ebene 5 Knoten alter_system_statement
Anfang Ebene 5 Knoten alter_table_statement alter_table_statement Ende Ebene 5 Knoten alter_table_statement
Anfang Ebene 5 Knoten alter_tablespace_statement alter_tablespace_statement Ende Ebene 5 Knoten alter_tablespace_statement
Anfang Ebene 5 Knoten alter_trigger_statement alter_trigger_statement Ende Ebene 5 Knoten alter_trigger_statement
Anfang Ebene 5 Knoten alter_user_statement alter_user_statement Ende Ebene 5 Knoten alter_user_statement
Anfang Ebene 5 Knoten alter_view_statement alter_view_statement Ende Ebene 5 Knoten alter_view_statement
Anfang Ebene 5 Knoten analyze_statement analyze_statement Ende Ebene 5 Knoten analyze_statement
Anfang Ebene 5 Knoten audit_statement audit_statement Ende Ebene 5 Knoten audit_statement
Anfang Ebene 5 Knoten commit_statement commit_statement Ende Ebene 5 Knoten commit_statement
Anfang Ebene 5 Knoten constraint_clause constraint_clause Ende Ebene 5 Knoten constraint_clause
Anfang Ebene 5 Knoten create_cluster_statement create_cluster_statement Ende Ebene 5 Knoten create_cluster_statement
Anfang Ebene 5 Knoten create_controlfile_statement create_controlfile_statement Ende Ebene 5 Knoten create_controlfile_statement
Anfang Ebene 5 Knoten create_database_statement create_database_statement Ende Ebene 5 Knoten create_database_statement
Anfang Ebene 5 Knoten create_database_link_statement create_database_link_statement Ende Ebene 5 Knoten create_database_link_statement
Anfang Ebene 5 Knoten create_index_statement create_index_statement Ende Ebene 5 Knoten create_index_statement
Anfang Ebene 5 Knoten create_package_statement create_package_statement Ende Ebene 5 Knoten create_package_statement
Anfang Ebene 5 Knoten create_package_body_statement create_package_body_statement Ende Ebene 5 Knoten create_package_body_statement
Anfang Ebene 5 Knoten create_procedure_statement create_procedure_statement Ende Ebene 5 Knoten create_procedure_statement
Anfang Ebene 5 Knoten create_profile_statement create_profile_statement Ende Ebene 5 Knoten create_profile_statement
Anfang Ebene 5 Knoten create_rollback_segment_statement create_rollback_segment_statement Ende Ebene 5 Knoten create_rollback_segment_statement
Anfang Ebene 5 Knoten create_sequence_statement create_sequence_statement Ende Ebene 5 Knoten create_sequence_statement
Anfang Ebene 5 Knoten create_snapshot_statement create_snapshot_statement Ende Ebene 5 Knoten create_snapshot_statement
Anfang Ebene 5 Knoten create_snapshot_log_statement create_snapshot_log_statement Ende Ebene 5 Knoten create_snapshot_log_statement
Anfang Ebene 5 Knoten create_synonym_statement create_synonym_statement Ende Ebene 5 Knoten create_synonym_statement
Anfang Ebene 5 Knoten create_table_statement create_table_statement Ende Ebene 5 Knoten create_table_statement
Anfang Ebene 5 Knoten create_tablespace_statement create_tablespace_statement Ende Ebene 5 Knoten create_tablespace_statement
Anfang Ebene 5 Knoten create_trigger_statement create_trigger_statement Ende Ebene 5 Knoten create_trigger_statement
Anfang Ebene 5 Knoten create_user_statement create_user_statement Ende Ebene 5 Knoten create_user_statement
Anfang Ebene 5 Knoten create_view_statement create_view_statement Ende Ebene 5 Knoten create_view_statement
Anfang Ebene 5 Knoten declare_statement declare_statement Ende Ebene 5 Knoten declare_statement
Anfang Ebene 5 Knoten declare_table_statement declare_table_statement Ende Ebene 5 Knoten declare_table_statement
Anfang Ebene 5 Knoten delete_statement delete_statement Ende Ebene 5 Knoten delete_statement
Anfang Ebene 5 Knoten describe_statement describe_statement Ende Ebene 5 Knoten describe_statement
Anfang Ebene 5 Knoten drop_cluster_statement drop_cluster_statement Ende Ebene 5 Knoten drop_cluster_statement
Anfang Ebene 5 Knoten drop_database_link_statement drop_database_link_statement Ende Ebene 5 Knoten drop_database_link_statement
Anfang Ebene 5 Knoten drop_index_statement drop_index_statement Ende Ebene 5 Knoten drop_index_statement
Anfang Ebene 5 Knoten drop_procedure_statement drop_procedure_statement Ende Ebene 5 Knoten drop_procedure_statement
Anfang Ebene 5 Knoten drop_profile_statement drop_profile_statement Ende Ebene 5 Knoten drop_profile_statement
Anfang Ebene 5 Knoten drop_rollback_segment_statement drop_rollback_segment_statement Ende Ebene 5 Knoten drop_rollback_segment_statement
Anfang Ebene 5 Knoten drop_snapshot_statement drop_snapshot_statement Ende Ebene 5 Knoten drop_snapshot_statement
Anfang Ebene 5 Knoten drop_snapshot_log_statement drop_snapshot_log_statement Ende Ebene 5 Knoten drop_snapshot_log_statement
Anfang Ebene 5 Knoten drop_table_statement drop_table_statement Ende Ebene 5 Knoten drop_table_statement
Anfang Ebene 5 Knoten drop_tablespace_statement drop_tablespace_statement Ende Ebene 5 Knoten drop_tablespace_statement
Anfang Ebene 5 Knoten drop_trigger_statement drop_trigger_statement Ende Ebene 5 Knoten drop_trigger_statement
Anfang Ebene 5 Knoten drop_view_statement drop_view_statement Ende Ebene 5 Knoten drop_view_statement
Anfang Ebene 5 Knoten execute_statement execute_statement Ende Ebene 5 Knoten execute_statement
Anfang Ebene 5 Knoten explain_plan_statement explain_plan_statement Ende Ebene 5 Knoten explain_plan_statement
Anfang Ebene 5 Knoten grant_statement grant_statement Ende Ebene 5 Knoten grant_statement
Anfang Ebene 5 Knoten insert_statement (embedded SQL) insert_statement (embedded SQL) Ende Ebene 5 Knoten insert_statement (embedded SQL)
Anfang Ebene 5 Knoten lock_table_statement lock_table_statement Ende Ebene 5 Knoten lock_table_statement
Anfang Ebene 5 Knoten noaudit_statement noaudit_statement Ende Ebene 5 Knoten noaudit_statement
Anfang Ebene 5 Knoten rename_statement rename_statement Ende Ebene 5 Knoten rename_statement
Anfang Ebene 5 Knoten revoke_statement revoke_statement Ende Ebene 5 Knoten revoke_statement
Anfang Ebene 5 Knoten rollback_statement rollback_statement Ende Ebene 5 Knoten rollback_statement
Anfang Ebene 5 Knoten select_statement select_statement Ende Ebene 5 Knoten select_statement
Anfang Ebene 5 Knoten set_transaction_statement set_transaction_statement Ende Ebene 5 Knoten set_transaction_statement
Anfang Ebene 5 Knoten truncate_statement truncate_statement Ende Ebene 5 Knoten truncate_statement
Anfang Ebene 5 Knoten update_statement update_statement Ende Ebene 5 Knoten update_statement
Anfang Ebene 4 Knoten Systemtabellen Systemtabellen Ende Ebene 4 Knoten Systemtabellen
Anfang Ebene 4 Knoten Fehlermeldungen Fehlermeldungen Ende Ebene 4 Knoten Fehlermeldungen
Anfang Ebene 2 Knoten Meldungen Meldungen Ende Ebene 2 Knoten Meldungen
Anfang Ebene 3 Knoten Nummernkreise Nummernkreise Ende Ebene 3 Knoten Nummernkreise
Anfang Ebene 3 Knoten Von -1 bis -699 Von -1 bis -699 Ende Ebene 3 Knoten Von -1 bis -699
Anfang Ebene 4 Knoten -1: Duplicate key in index -1: Duplicate key in index Ende Ebene 4 Knoten -1: Duplicate key in index
Anfang Ebene 4 Knoten -8: Execution failed, parse again -8: Execution failed, parse again Ende Ebene 4 Knoten -8: Execution failed, parse again
Anfang Ebene 4 Knoten -20: Duplicate key -20: Duplicate key Ende Ebene 4 Knoten -20: Duplicate key
Anfang Ebene 4 Knoten -25: Duplicate secondary key -25: Duplicate secondary key Ende Ebene 4 Knoten -25: Duplicate secondary key
Anfang Ebene 4 Knoten -30: Integrity violation -30: Integrity violation Ende Ebene 4 Knoten -30: Integrity violation
Anfang Ebene 4 Knoten -32: View violation -32: View violation Ende Ebene 4 Knoten -32: View violation
Anfang Ebene 4 Knoten -35: Referential integrity violated -35: Referential integrity violated Ende Ebene 4 Knoten -35: Referential integrity violated
Anfang Ebene 4 Knoten -36: Foreign key integrity violation -36: Foreign key integrity violation Ende Ebene 4 Knoten -36: Foreign key integrity violation
Anfang Ebene 4 Knoten -40: Lock collision -40: Lock collision Ende Ebene 4 Knoten -40: Lock collision
Anfang Ebene 4 Knoten -50: Lock request timeout -50: Lock request timeout Ende Ebene 4 Knoten -50: Lock request timeout
Anfang Ebene 4 Knoten -51: Lock request timeout -51: Lock request timeout Ende Ebene 4 Knoten -51: Lock request timeout
Anfang Ebene 4 Knoten -54: Lock collision -54: Lock collision Ende Ebene 4 Knoten -54: Lock collision
Anfang Ebene 4 Knoten -60: Work rolled back -60: Work rolled back Ende Ebene 4 Knoten -60: Work rolled back
Anfang Ebene 4 Knoten -65: Work rolled back -65: Work rolled back Ende Ebene 4 Knoten -65: Work rolled back
Anfang Ebene 4 Knoten -70: Session inactivity timeout (Work rolled back) -70: Session inactivity timeout (Work rolled back) Ende Ebene 4 Knoten -70: Session inactivity timeout (Work rolled back)
Anfang Ebene 4 Knoten -71: Session terminated by shutdown (Work rolled back) -71: Session terminated by shutdown (Work rolled back) Ende Ebene 4 Knoten -71: Session terminated by shutdown (Work rolled back)
Anfang Ebene 4 Knoten -75: Too many SQL statements (Work rolled back) -75: Too many SQL statements (Work rolled back) Ende Ebene 4 Knoten -75: Too many SQL statements (Work rolled back)
Anfang Ebene 4 Knoten -101: SQL statement not available in this DB mode -101: SQL statement not available in this DB mode Ende Ebene 4 Knoten -101: SQL statement not available in this DB mode
Anfang Ebene 4 Knoten -102: SQL statement canceled -102: SQL statement canceled Ende Ebene 4 Knoten -102: SQL statement canceled
Anfang Ebene 4 Knoten -103: SQL statement not available for this application -103: SQL statement not available for this application Ende Ebene 4 Knoten -103: SQL statement not available for this application
Anfang Ebene 4 Knoten -104: DBM command impossible at this time -104: DBM command impossible at this time Ende Ebene 4 Knoten -104: DBM command impossible at this time
Anfang Ebene 4 Knoten -106: Table unloaded or content deleted -106: Table unloaded or content deleted Ende Ebene 4 Knoten -106: Table unloaded or content deleted
Anfang Ebene 4 Knoten -107: SQL statement not allowed for this instance -107: SQL statement not allowed for this instance Ende Ebene 4 Knoten -107: SQL statement not allowed for this instance
Anfang Ebene 4 Knoten -108: Table or index dropped or content deleted -108: Table or index dropped or content deleted Ende Ebene 4 Knoten -108: Table or index dropped or content deleted
Anfang Ebene 4 Knoten -111: Incompatible incremental backup -111: Incompatible incremental backup Ende Ebene 4 Knoten -111: Incompatible incremental backup
Anfang Ebene 4 Knoten -115: Table is read only -115: Table is read only Ende Ebene 4 Knoten -115: Table is read only
Anfang Ebene 4 Knoten -123: No more log to save -123: No more log to save Ende Ebene 4 Knoten -123: No more log to save
Anfang Ebene 4 Knoten -126: Data backup missing (backup history lost) -126: Data backup missing (backup history lost) Ende Ebene 4 Knoten -126: Data backup missing (backup history lost)
Anfang Ebene 4 Knoten -127: Log backup is not possible because log writing has been sw -127: Log backup is not possible because log writing has been sw Ende Ebene 4 Knoten -127: Log backup is not possible because log writing has been sw
Anfang Ebene 4 Knoten -128: Log backup is not possible because the log overwrite mode -128: Log backup is not possible because the log overwrite mode Ende Ebene 4 Knoten -128: Log backup is not possible because the log overwrite mode
Anfang Ebene 4 Knoten -530: Referential integrity violated -530: Referential integrity violated Ende Ebene 4 Knoten -530: Referential integrity violated
Anfang Ebene 4 Knoten -602: System error -602: System error Ende Ebene 4 Knoten -602: System error
Anfang Ebene 3 Knoten Von -900 bis -999 Von -900 bis -999 Ende Ebene 3 Knoten Von -900 bis -999
Anfang Ebene 4 Knoten -900: Data area full -900: Data area full Ende Ebene 4 Knoten -900: Data area full
Anfang Ebene 4 Knoten -901: Log full -901: Log full Ende Ebene 4 Knoten -901: Log full
Anfang Ebene 4 Knoten -902: I/O error -902: I/O error Ende Ebene 4 Knoten -902: I/O error
Anfang Ebene 4 Knoten -903: Hostfile I/O error -903: Hostfile I/O error Ende Ebene 4 Knoten -903: Hostfile I/O error
Anfang Ebene 4 Knoten -904: Space for result tables exhausted -904: Space for result tables exhausted Ende Ebene 4 Knoten -904: Space for result tables exhausted
Anfang Ebene 4 Knoten -907: Space for user session exhausted -907: Space for user session exhausted Ende Ebene 4 Knoten -907: Space for user session exhausted
Anfang Ebene 4 Knoten -910: COSTLIMIT for this user exhausted -910: COSTLIMIT for this user exhausted Ende Ebene 4 Knoten -910: COSTLIMIT for this user exhausted
Anfang Ebene 4 Knoten -911: Work rolled back -911: Work rolled back Ende Ebene 4 Knoten -911: Work rolled back
Anfang Ebene 4 Knoten -913: Lock request timeout -913: Lock request timeout Ende Ebene 4 Knoten -913: Lock request timeout
Anfang Ebene 4 Knoten -914: New volume not accessible -914: New volume not accessible Ende Ebene 4 Knoten -914: New volume not accessible
Anfang Ebene 4 Knoten -915: No more memory -915: No more memory Ende Ebene 4 Knoten -915: No more memory
Anfang Ebene 4 Knoten -917: Save/restore write process crash - I/O error -917: Save/restore write process crash - I/O error Ende Ebene 4 Knoten -917: Save/restore write process crash - I/O error
Anfang Ebene 4 Knoten -918: Stack overflow -918: Stack overflow Ende Ebene 4 Knoten -918: Stack overflow
Anfang Ebene 4 Knoten -942: Unknown table name -942: Unknown table name Ende Ebene 4 Knoten -942: Unknown table name
Anfang Ebene 4 Knoten -955: Duplicate name -955: Duplicate name Ende Ebene 4 Knoten -955: Duplicate name
Anfang Ebene 3 Knoten Von -1000 bis -1999 Von -1000 bis -1999 Ende Ebene 3 Knoten Von -1000 bis -1999
Anfang Ebene 4 Knoten -1000: Too many lock requests -1000: Too many lock requests Ende Ebene 4 Knoten -1000: Too many lock requests
Anfang Ebene 4 Knoten -1001: Too many lock objects specified -1001: Too many lock objects specified Ende Ebene 4 Knoten -1001: Too many lock objects specified
Anfang Ebene 4 Knoten -1002: Too many columns -1002: Too many columns Ende Ebene 4 Knoten -1002: Too many columns
Anfang Ebene 4 Knoten -1003: Too many buffers requested -1003: Too many buffers requested Ende Ebene 4 Knoten -1003: Too many buffers requested
Anfang Ebene 4 Knoten -1004: Too many correlated columns -1004: Too many correlated columns Ende Ebene 4 Knoten -1004: Too many correlated columns
Anfang Ebene 4 Knoten -1005: Too many monadic operators -1005: Too many monadic operators Ende Ebene 4 Knoten -1005: Too many monadic operators
Anfang Ebene 4 Knoten -1006: Too many variables -1006: Too many variables Ende Ebene 4 Knoten -1006: Too many variables
Anfang Ebene 4 Knoten -1007: Parameter list too long -1007: Parameter list too long Ende Ebene 4 Knoten -1007: Parameter list too long
Anfang Ebene 4 Knoten -1008: Too many or too few host variables for output -1008: Too many or too few host variables for output Ende Ebene 4 Knoten -1008: Too many or too few host variables for output
Anfang Ebene 4 Knoten -1009: Too many named indexes for this table -1009: Too many named indexes for this table Ende Ebene 4 Knoten -1009: Too many named indexes for this table
Anfang Ebene 4 Knoten -1010: Too many volumes -1010: Too many volumes Ende Ebene 4 Knoten -1010: Too many volumes
Anfang Ebene 4 Knoten -1011: Too many correlated tables -1011: Too many correlated tables Ende Ebene 4 Knoten -1011: Too many correlated tables
Anfang Ebene 4 Knoten -1012: Too many referential constraint definitions for this tabl -1012: Too many referential constraint definitions for this tabl Ende Ebene 4 Knoten -1012: Too many referential constraint definitions for this tabl
Anfang Ebene 4 Knoten -1013: Too many order columns -1013: Too many order columns Ende Ebene 4 Knoten -1013: Too many order columns
Anfang Ebene 4 Knoten -1014: Too many source tables -1014: Too many source tables Ende Ebene 4 Knoten -1014: Too many source tables
Anfang Ebene 4 Knoten -1015: Too many values -1015: Too many values Ende Ebene 4 Knoten -1015: Too many values
Anfang Ebene 4 Knoten -1017: Too many joins -1017: Too many joins Ende Ebene 4 Knoten -1017: Too many joins
Anfang Ebene 4 Knoten -1023: Too many nested subtransactions -1023: Too many nested subtransactions Ende Ebene 4 Knoten -1023: Too many nested subtransactions
Anfang Ebene 4 Knoten -1025: Too many asynchron requests -1025: Too many asynchron requests Ende Ebene 4 Knoten -1025: Too many asynchron requests
Anfang Ebene 4 Knoten -1026: Too many differences between old and new view definition -1026: Too many differences between old and new view definition Ende Ebene 4 Knoten -1026: Too many differences between old and new view definition
Anfang Ebene 4 Knoten -1102: Too complicated SQL statement (Too many subqueries) -1102: Too complicated SQL statement (Too many subqueries) Ende Ebene 4 Knoten -1102: Too complicated SQL statement (Too many subqueries)
Anfang Ebene 4 Knoten -1103: Too complicated SQL statement -1103: Too complicated SQL statement Ende Ebene 4 Knoten -1103: Too complicated SQL statement
Anfang Ebene 4 Knoten -1104: Too complicated SQL statement (KB-stack overflow) -1104: Too complicated SQL statement (KB-stack overflow) Ende Ebene 4 Knoten -1104: Too complicated SQL statement (KB-stack overflow)
Anfang Ebene 4 Knoten -1105: Too complicated SQL statement (Too much data) -1105: Too complicated SQL statement (Too much data) Ende Ebene 4 Knoten -1105: Too complicated SQL statement (Too much data)
Anfang Ebene 4 Knoten -1106: Too complicated SQL statement (Too much strategy data) -1106: Too complicated SQL statement (Too much strategy data) Ende Ebene 4 Knoten -1106: Too complicated SQL statement (Too much strategy data)
Anfang Ebene 4 Knoten -1107: Too complicated SQL statement (Too many internal commands -1107: Too complicated SQL statement (Too many internal commands Ende Ebene 4 Knoten -1107: Too complicated SQL statement (Too many internal commands
Anfang Ebene 4 Knoten -1108: Too complicated SQL statement (correlated row too long) -1108: Too complicated SQL statement (correlated row too long) Ende Ebene 4 Knoten -1108: Too complicated SQL statement (correlated row too long)
Anfang Ebene 4 Knoten -1110: View definition too long -1110: View definition too long Ende Ebene 4 Knoten -1110: View definition too long
Anfang Ebene 4 Knoten -1111: Too many savepoints -1111: Too many savepoints Ende Ebene 4 Knoten -1111: Too many savepoints
Anfang Ebene 4 Knoten -1112: Constraint too complicated -1112: Constraint too complicated Ende Ebene 4 Knoten -1112: Constraint too complicated
Anfang Ebene 4 Knoten -1113: Too many nested function calls -1113: Too many nested function calls Ende Ebene 4 Knoten -1113: Too many nested function calls
Anfang Ebene 4 Knoten -1114: Communication packet too small -1114: Communication packet too small Ende Ebene 4 Knoten -1114: Communication packet too small
Anfang Ebene 4 Knoten -1115: Too many intern columns -1115: Too many intern columns Ende Ebene 4 Knoten -1115: Too many intern columns
Anfang Ebene 4 Knoten -1116: Too long trigger parameters -1116: Too long trigger parameters Ende Ebene 4 Knoten -1116: Too long trigger parameters
Anfang Ebene 4 Knoten -1117: Too complicated trigger qualification -1117: Too complicated trigger qualification Ende Ebene 4 Knoten -1117: Too complicated trigger qualification
Anfang Ebene 4 Knoten -1119: Too many constraints for this table -1119: Too many constraints for this table Ende Ebene 4 Knoten -1119: Too many constraints for this table
Anfang Ebene 4 Knoten -1120: Too many statements in definition -1120: Too many statements in definition Ende Ebene 4 Knoten -1120: Too many statements in definition
Anfang Ebene 4 Knoten -1200: Too few values -1200: Too few values Ende Ebene 4 Knoten -1200: Too few values
Anfang Ebene 4 Knoten -1201: Too few columns -1201: Too few columns Ende Ebene 4 Knoten -1201: Too few columns
Anfang Ebene 4 Knoten -1400: Input parameter cannot be NULL value -1400: Input parameter cannot be NULL value Ende Ebene 4 Knoten -1400: Input parameter cannot be NULL value
Anfang Ebene 4 Knoten -1402: Integrity violation -1402: Integrity violation Ende Ebene 4 Knoten -1402: Integrity violation
Anfang Ebene 4 Knoten -1403: Row not found -1403: Row not found Ende Ebene 4 Knoten -1403: Row not found
Anfang Ebene 4 Knoten -1405: Missing indicator variable, output parameter with NULL va -1405: Missing indicator variable, output parameter with NULL va Ende Ebene 4 Knoten -1405: Missing indicator variable, output parameter with NULL va
Anfang Ebene 4 Knoten -1406: Output value truncated -1406: Output value truncated Ende Ebene 4 Knoten -1406: Output value truncated
Anfang Ebene 4 Knoten -1452: Duplicate secondary key -1452: Duplicate secondary key Ende Ebene 4 Knoten -1452: Duplicate secondary key
Anfang Ebene 4 Knoten -1556: Data space full -1556: Data space full Ende Ebene 4 Knoten -1556: Data space full
Anfang Ebene 4 Knoten -1755: SQL statement will drop further objects (use CASCADE) -1755: SQL statement will drop further objects (use CASCADE) Ende Ebene 4 Knoten -1755: SQL statement will drop further objects (use CASCADE)
Anfang Ebene 3 Knoten Von -2000 bis -2999 Von -2000 bis -2999 Ende Ebene 3 Knoten Von -2000 bis -2999
Anfang Ebene 4 Knoten -2000: Row too long -2000: Row too long Ende Ebene 4 Knoten -2000: Row too long
Anfang Ebene 4 Knoten -2001: Key too long -2001: Key too long Ende Ebene 4 Knoten -2001: Key too long
Anfang Ebene 4 Knoten -2002: One output column too long -2002: One output column too long Ende Ebene 4 Knoten -2002: One output column too long
Anfang Ebene 4 Knoten -2003: Output columns too long -2003: Output columns too long Ende Ebene 4 Knoten -2003: Output columns too long
Anfang Ebene 4 Knoten -2004: Numeric constant too long -2004: Numeric constant too long Ende Ebene 4 Knoten -2004: Numeric constant too long
Anfang Ebene 4 Knoten -2008: Data area too small -2008: Data area too small Ende Ebene 4 Knoten -2008: Data area too small
Anfang Ebene 4 Knoten -2009: Join columns too long -2009: Join columns too long Ende Ebene 4 Knoten -2009: Join columns too long
Anfang Ebene 4 Knoten -2010: Assignment impossible, char value too long -2010: Assignment impossible, char value too long Ende Ebene 4 Knoten -2010: Assignment impossible, char value too long
Anfang Ebene 4 Knoten -2012: View column list too long -2012: View column list too long Ende Ebene 4 Knoten -2012: View column list too long
Anfang Ebene 4 Knoten -2013: Select column list too long -2013: Select column list too long Ende Ebene 4 Knoten -2013: Select column list too long
Anfang Ebene 4 Knoten -2014: Identifier too long -2014: Identifier too long Ende Ebene 4 Knoten -2014: Identifier too long
Anfang Ebene 4 Knoten -2020: Data buffer too small -2020: Data buffer too small Ende Ebene 4 Knoten -2020: Data buffer too small
Anfang Ebene 4 Knoten -2025: Invalid number of backup devices -2025: Invalid number of backup devices Ende Ebene 4 Knoten -2025: Invalid number of backup devices
Anfang Ebene 4 Knoten -2027: Space for converted value too small -2027: Space for converted value too small Ende Ebene 4 Knoten -2027: Space for converted value too small
Anfang Ebene 4 Knoten -2028: Sequence <sequence name> exhausted -2028: Sequence <sequence name> exhausted Ende Ebene 4 Knoten -2028: Sequence <sequence name> exhausted
Anfang Ebene 4 Knoten -2029: <sequence_name>.CURRVAL is not yet defined in this sessio -2029: <sequence_name>.CURRVAL is not yet defined in this sessio Ende Ebene 4 Knoten -2029: <sequence_name>.CURRVAL is not yet defined in this sessio
Anfang Ebene 3 Knoten Von -3000 bis -3999 Von -3000 bis -3999 Ende Ebene 3 Knoten Von -3000 bis -3999
Anfang Ebene 4 Knoten -3000: Invalid host file content -3000: Invalid host file content Ende Ebene 4 Knoten -3000: Invalid host file content
Anfang Ebene 4 Knoten -3002: Invalid datatype -3002: Invalid datatype Ende Ebene 4 Knoten -3002: Invalid datatype
Anfang Ebene 4 Knoten -3003: Invalid user name -3003: Invalid user name Ende Ebene 4 Knoten -3003: Invalid user name
Anfang Ebene 4 Knoten -3004: Invalid host file sequence -3004: Invalid host file sequence Ende Ebene 4 Knoten -3004: Invalid host file sequence
Anfang Ebene 4 Knoten -3005: Invalid SQL statement -3005: Invalid SQL statement Ende Ebene 4 Knoten -3005: Invalid SQL statement
Anfang Ebene 4 Knoten -3007: Invalid sequence for DML and DDL statements -3007: Invalid sequence for DML and DDL statements Ende Ebene 4 Knoten -3007: Invalid sequence for DML and DDL statements
Anfang Ebene 4 Knoten -3008: Invalid keyword or missing delimiter -3008: Invalid keyword or missing delimiter Ende Ebene 4 Knoten -3008: Invalid keyword or missing delimiter
Anfang Ebene 4 Knoten -3009: Invalid table name -3009: Invalid table name Ende Ebene 4 Knoten -3009: Invalid table name
Anfang Ebene 4 Knoten -3011: Invalid column name -3011: Invalid column name Ende Ebene 4 Knoten -3011: Invalid column name
Anfang Ebene 4 Knoten -3014: Invalid end of SQL statement -3014: Invalid end of SQL statement Ende Ebene 4 Knoten -3014: Invalid end of SQL statement
Anfang Ebene 4 Knoten -3016: Invalid numeric constant -3016: Invalid numeric constant Ende Ebene 4 Knoten -3016: Invalid numeric constant
Anfang Ebene 4 Knoten -3017: Invalid unsigned integer -3017: Invalid unsigned integer Ende Ebene 4 Knoten -3017: Invalid unsigned integer
Anfang Ebene 4 Knoten -3018: Invalid numeric parameter -3018: Invalid numeric parameter Ende Ebene 4 Knoten -3018: Invalid numeric parameter
Anfang Ebene 4 Knoten -3019: Invalid exponent -3019: Invalid exponent Ende Ebene 4 Knoten -3019: Invalid exponent
Anfang Ebene 4 Knoten -3020: Invalid length for this data type -3020: Invalid length for this data type Ende Ebene 4 Knoten -3020: Invalid length for this data type
Anfang Ebene 4 Knoten -3021: Invalid mixture of functions and columns -3021: Invalid mixture of functions and columns Ende Ebene 4 Knoten -3021: Invalid mixture of functions and columns
Anfang Ebene 4 Knoten -3022: Invalid number of tables for outer join -3022: Invalid number of tables for outer join Ende Ebene 4 Knoten -3022: Invalid number of tables for outer join
Anfang Ebene 4 Knoten -3024: Invalid numeric expression -3024: Invalid numeric expression Ende Ebene 4 Knoten -3024: Invalid numeric expression
Anfang Ebene 4 Knoten -3030: Invalid SESSION TIMEOUT -3030: Invalid SESSION TIMEOUT Ende Ebene 4 Knoten -3030: Invalid SESSION TIMEOUT
Anfang Ebene 4 Knoten -3035: Invalid date time format -3035: Invalid date time format Ende Ebene 4 Knoten -3035: Invalid date time format
Anfang Ebene 4 Knoten -3037: Invalid volume name -3037: Invalid volume name Ende Ebene 4 Knoten -3037: Invalid volume name
Anfang Ebene 4 Knoten -3038: Invalid volume size -3038: Invalid volume size Ende Ebene 4 Knoten -3038: Invalid volume size
Anfang Ebene 4 Knoten -3046: Invalid char position in string function -3046: Invalid char position in string function Ende Ebene 4 Knoten -3046: Invalid char position in string function
Anfang Ebene 4 Knoten -3047: Invalid table for RESTORE CATALOG -3047: Invalid table for RESTORE CATALOG Ende Ebene 4 Knoten -3047: Invalid table for RESTORE CATALOG
Anfang Ebene 4 Knoten -3048: Invalid date format -3048: Invalid date format Ende Ebene 4 Knoten -3048: Invalid date format
Anfang Ebene 4 Knoten -3049: Invalid time format -3049: Invalid time format Ende Ebene 4 Knoten -3049: Invalid time format
Anfang Ebene 4 Knoten -3050: Invalid timestamp format -3050: Invalid timestamp format Ende Ebene 4 Knoten -3050: Invalid timestamp format
Anfang Ebene 4 Knoten -3054: Invalid block size -3054: Invalid block size Ende Ebene 4 Knoten -3054: Invalid block size
Anfang Ebene 4 Knoten -3059: Invalid day of week -3059: Invalid day of week Ende Ebene 4 Knoten -3059: Invalid day of week
Anfang Ebene 4 Knoten -3060: Invalid escape sequence -3060: Invalid escape sequence Ende Ebene 4 Knoten -3060: Invalid escape sequence
Anfang Ebene 4 Knoten -3061: Invalid escape value -3061: Invalid escape value Ende Ebene 4 Knoten -3061: Invalid escape value
Anfang Ebene 4 Knoten -3062: Invalid month -3062: Invalid month Ende Ebene 4 Knoten -3062: Invalid month
Anfang Ebene 4 Knoten -3063: Invalid format code -3063: Invalid format code Ende Ebene 4 Knoten -3063: Invalid format code
Anfang Ebene 4 Knoten -3064: Date input value out of range -3064: Date input value out of range Ende Ebene 4 Knoten -3064: Date input value out of range
Anfang Ebene 4 Knoten -3065: Invalid date input value -3065: Invalid date input value Ende Ebene 4 Knoten -3065: Invalid date input value
Anfang Ebene 4 Knoten -3066: Date input value inconsistent -3066: Date input value inconsistent Ende Ebene 4 Knoten -3066: Date input value inconsistent
Anfang Ebene 4 Knoten -3067: Invalid timezone -3067: Invalid timezone Ende Ebene 4 Knoten -3067: Invalid timezone
Anfang Ebene 4 Knoten -3068: Mismatch of parameter configuration between backup and in -3068: Mismatch of parameter configuration between backup and in Ende Ebene 4 Knoten -3068: Mismatch of parameter configuration between backup and in
Anfang Ebene 4 Knoten -3069: Bad xparam page in backup -3069: Bad xparam page in backup Ende Ebene 4 Knoten -3069: Bad xparam page in backup
Anfang Ebene 4 Knoten -3102: Invalid subtrans structure -3102: Invalid subtrans structure Ende Ebene 4 Knoten -3102: Invalid subtrans structure
Anfang Ebene 4 Knoten -3103: Invalid sequence definition -3103: Invalid sequence definition Ende Ebene 4 Knoten -3103: Invalid sequence definition
Anfang Ebene 4 Knoten -3995: Invalid pattern -3995: Invalid pattern Ende Ebene 4 Knoten -3995: Invalid pattern
Anfang Ebene 4 Knoten -3998: Wrong password -3998: Wrong password Ende Ebene 4 Knoten -3998: Wrong password
Anfang Ebene 4 Knoten -3999: Invalid parameter -3999: Invalid parameter Ende Ebene 4 Knoten -3999: Invalid parameter
Anfang Ebene 3 Knoten Von -4000 bis -4999 Von -4000 bis -4999 Ende Ebene 3 Knoten Von -4000 bis -4999
Anfang Ebene 4 Knoten -4000: Unknown result table -4000: Unknown result table Ende Ebene 4 Knoten -4000: Unknown result table
Anfang Ebene 4 Knoten -4001: Unknown user name/password combination in operational sta -4001: Unknown user name/password combination in operational sta Ende Ebene 4 Knoten -4001: Unknown user name/password combination in operational sta
Anfang Ebene 4 Knoten -4002: Unknown password -4002: Unknown password Ende Ebene 4 Knoten -4002: Unknown password
Anfang Ebene 4 Knoten -4003: Unknown user name -4003: Unknown user name Ende Ebene 4 Knoten -4003: Unknown user name
Anfang Ebene 4 Knoten -4004: Unknown table name -4004: Unknown table name Ende Ebene 4 Knoten -4004: Unknown table name
Anfang Ebene 4 Knoten -4005: Unknown column name -4005: Unknown column name Ende Ebene 4 Knoten -4005: Unknown column name
Anfang Ebene 4 Knoten -4006: Unknown domain name -4006: Unknown domain name Ende Ebene 4 Knoten -4006: Unknown domain name
Anfang Ebene 4 Knoten -4007: Unknown synonym name -4007: Unknown synonym name Ende Ebene 4 Knoten -4007: Unknown synonym name
Anfang Ebene 4 Knoten -4008: Unknown user name/password combination -4008: Unknown user name/password combination Ende Ebene 4 Knoten -4008: Unknown user name/password combination
Anfang Ebene 4 Knoten -4009: Unknown referential constraint name -4009: Unknown referential constraint name Ende Ebene 4 Knoten -4009: Unknown referential constraint name
Anfang Ebene 4 Knoten -4010: Unknown MAPCHAR SET name -4010: Unknown MAPCHAR SET name Ende Ebene 4 Knoten -4010: Unknown MAPCHAR SET name
Anfang Ebene 4 Knoten -4011: Unknown index name -4011: Unknown index name Ende Ebene 4 Knoten -4011: Unknown index name
Anfang Ebene 4 Knoten -4013: Unknown usergroup name -4013: Unknown usergroup name Ende Ebene 4 Knoten -4013: Unknown usergroup name
Anfang Ebene 4 Knoten -4014: Unknown SERVERDB name -4014: Unknown SERVERDB name Ende Ebene 4 Knoten -4014: Unknown SERVERDB name
Anfang Ebene 4 Knoten -4016: Unknown procedure name -4016: Unknown procedure name Ende Ebene 4 Knoten -4016: Unknown procedure name
Anfang Ebene 4 Knoten -4017: Unknown constraint -4017: Unknown constraint Ende Ebene 4 Knoten -4017: Unknown constraint
Anfang Ebene 4 Knoten -4018: Unknown default -4018: Unknown default Ende Ebene 4 Knoten -4018: Unknown default
Anfang Ebene 4 Knoten -4019: Unknown trigger name -4019: Unknown trigger name Ende Ebene 4 Knoten -4019: Unknown trigger name
Anfang Ebene 4 Knoten -4020: Unknown sequence name -4020: Unknown sequence name Ende Ebene 4 Knoten -4020: Unknown sequence name
Anfang Ebene 4 Knoten -4023: Unknown function name -4023: Unknown function name Ende Ebene 4 Knoten -4023: Unknown function name
Anfang Ebene 4 Knoten -4024: Unknown name -4024: Unknown name Ende Ebene 4 Knoten -4024: Unknown name
Anfang Ebene 4 Knoten -4025: Unknown or not loaded character set -4025: Unknown or not loaded character set Ende Ebene 4 Knoten -4025: Unknown or not loaded character set
Anfang Ebene 4 Knoten -4027: Unknown session -4027: Unknown session Ende Ebene 4 Knoten -4027: Unknown session
Anfang Ebene 4 Knoten -4030: Unknown schema -4030: Unknown schema Ende Ebene 4 Knoten -4030: Unknown schema
Anfang Ebene 3 Knoten Von -5000 bis -5999 Von -5000 bis -5999 Ende Ebene 3 Knoten Von -5000 bis -5999
Anfang Ebene 4 Knoten -5001: Missing privilege -5001: Missing privilege Ende Ebene 4 Knoten -5001: Missing privilege
Anfang Ebene 4 Knoten -5003: Missing key specification -5003: Missing key specification Ende Ebene 4 Knoten -5003: Missing key specification
Anfang Ebene 4 Knoten -5004: Missing constant -5004: Missing constant Ende Ebene 4 Knoten -5004: Missing constant
Anfang Ebene 4 Knoten -5005: Missing non-NULL value -5005: Missing non-NULL value Ende Ebene 4 Knoten -5005: Missing non-NULL value
Anfang Ebene 4 Knoten -5006: Missing identifier -5006: Missing identifier Ende Ebene 4 Knoten -5006: Missing identifier
Anfang Ebene 4 Knoten -5007: Missing numeric constant -5007: Missing numeric constant Ende Ebene 4 Knoten -5007: Missing numeric constant
Anfang Ebene 4 Knoten -5008: Missing string constant -5008: Missing string constant Ende Ebene 4 Knoten -5008: Missing string constant
Anfang Ebene 4 Knoten -5009: Missing integer -5009: Missing integer Ende Ebene 4 Knoten -5009: Missing integer
Anfang Ebene 4 Knoten -5010: Missing value specification -5010: Missing value specification Ende Ebene 4 Knoten -5010: Missing value specification
Anfang Ebene 4 Knoten -5012: Missing definite table name -5012: Missing definite table name Ende Ebene 4 Knoten -5012: Missing definite table name
Anfang Ebene 4 Knoten -5013: Missing update column -5013: Missing update column Ende Ebene 4 Knoten -5013: Missing update column
Anfang Ebene 4 Knoten -5014: Missing definite column name -5014: Missing definite column name Ende Ebene 4 Knoten -5014: Missing definite column name
Anfang Ebene 4 Knoten -5015: Missing keyword -5015: Missing keyword Ende Ebene 4 Knoten -5015: Missing keyword
Anfang Ebene 4 Knoten -5016: Missing delimiter -5016: Missing delimiter Ende Ebene 4 Knoten -5016: Missing delimiter
Anfang Ebene 3 Knoten Von -6000 bis -6999 Von -6000 bis -6999 Ende Ebene 3 Knoten Von -6000 bis -6999
Anfang Ebene 4 Knoten -6000: Duplicate table name -6000: Duplicate table name Ende Ebene 4 Knoten -6000: Duplicate table name
Anfang Ebene 4 Knoten -6001: Duplicate column name -6001: Duplicate column name Ende Ebene 4 Knoten -6001: Duplicate column name
Anfang Ebene 4 Knoten -6002: Duplicate privilege -6002: Duplicate privilege Ende Ebene 4 Knoten -6002: Duplicate privilege
Anfang Ebene 4 Knoten -6003: Duplicate result table name -6003: Duplicate result table name Ende Ebene 4 Knoten -6003: Duplicate result table name
Anfang Ebene 4 Knoten -6006: Duplicate name -6006: Duplicate name Ende Ebene 4 Knoten -6006: Duplicate name
Anfang Ebene 4 Knoten -6008: Duplicate index name -6008: Duplicate index name Ende Ebene 4 Knoten -6008: Duplicate index name
Anfang Ebene 4 Knoten -6009: Duplicate reference name -6009: Duplicate reference name Ende Ebene 4 Knoten -6009: Duplicate reference name
Anfang Ebene 4 Knoten -6011: Duplicate constraint -6011: Duplicate constraint Ende Ebene 4 Knoten -6011: Duplicate constraint
Anfang Ebene 4 Knoten -6012: Duplicate default -6012: Duplicate default Ende Ebene 4 Knoten -6012: Duplicate default
Anfang Ebene 4 Knoten -6013: Duplicate trigger definition -6013: Duplicate trigger definition Ende Ebene 4 Knoten -6013: Duplicate trigger definition
Anfang Ebene 4 Knoten -6014: Duplicate value -6014: Duplicate value Ende Ebene 4 Knoten -6014: Duplicate value
Anfang Ebene 4 Knoten -6016: Duplicate format code -6016: Duplicate format code Ende Ebene 4 Knoten -6016: Duplicate format code
Anfang Ebene 3 Knoten Von -7000 bis -7999 Von -7000 bis -7999 Ende Ebene 3 Knoten Von -7000 bis -7999
Anfang Ebene 4 Knoten -7002: KEY not allowed -7002: KEY not allowed Ende Ebene 4 Knoten -7002: KEY not allowed
Anfang Ebene 4 Knoten -7003: NOT NULL not allowed -7003: NOT NULL not allowed Ende Ebene 4 Knoten -7003: NOT NULL not allowed
Anfang Ebene 4 Knoten -7004: DEFAULT not allowed -7004: DEFAULT not allowed Ende Ebene 4 Knoten -7004: DEFAULT not allowed
Anfang Ebene 4 Knoten -7005: Lower bound greater than upper bound not allowed -7005: Lower bound greater than upper bound not allowed Ende Ebene 4 Knoten -7005: Lower bound greater than upper bound not allowed
Anfang Ebene 4 Knoten -7006: Reserved identifier not allowed -7006: Reserved identifier not allowed Ende Ebene 4 Knoten -7006: Reserved identifier not allowed
Anfang Ebene 4 Knoten -7007: Key column not allowed -7007: Key column not allowed Ende Ebene 4 Knoten -7007: Key column not allowed
Anfang Ebene 4 Knoten -7008: Updates of this table not allowed -7008: Updates of this table not allowed Ende Ebene 4 Knoten -7008: Updates of this table not allowed
Anfang Ebene 4 Knoten -7009: NULL value in key column not allowed -7009: NULL value in key column not allowed Ende Ebene 4 Knoten -7009: NULL value in key column not allowed
Anfang Ebene 4 Knoten -7011: Correlated subquery not allowed -7011: Correlated subquery not allowed Ende Ebene 4 Knoten -7011: Correlated subquery not allowed
Anfang Ebene 4 Knoten -7012: More than one update row not allowed -7012: More than one update row not allowed Ende Ebene 4 Knoten -7012: More than one update row not allowed
Anfang Ebene 4 Knoten -7015: More than one result row not allowed -7015: More than one result row not allowed Ende Ebene 4 Knoten -7015: More than one result row not allowed
Anfang Ebene 4 Knoten -7016: Parameter spec not allowed in this context -7016: Parameter spec not allowed in this context Ende Ebene 4 Knoten -7016: Parameter spec not allowed in this context
Anfang Ebene 4 Knoten -7017: User not allowed -7017: User not allowed Ende Ebene 4 Knoten -7017: User not allowed
Anfang Ebene 4 Knoten -7018: Variable not allowed in view definition -7018: Variable not allowed in view definition Ende Ebene 4 Knoten -7018: Variable not allowed in view definition
Anfang Ebene 4 Knoten -7019: Feature not allowed in view definition -7019: Feature not allowed in view definition Ende Ebene 4 Knoten -7019: Feature not allowed in view definition
Anfang Ebene 4 Knoten -7021: View column derived from function not allowed -7021: View column derived from function not allowed Ende Ebene 4 Knoten -7021: View column derived from function not allowed
Anfang Ebene 4 Knoten -7022: Columns from more than one table not allowed -7022: Columns from more than one table not allowed Ende Ebene 4 Knoten -7022: Columns from more than one table not allowed
Anfang Ebene 4 Knoten -7023: Dropping of all columns not allowed -7023: Dropping of all columns not allowed Ende Ebene 4 Knoten -7023: Dropping of all columns not allowed
Anfang Ebene 4 Knoten -7024: Alter column not allowed, constraint violation -7024: Alter column not allowed, constraint violation Ende Ebene 4 Knoten -7024: Alter column not allowed, constraint violation
Anfang Ebene 4 Knoten -7026: SQL statement not allowed without previous FETCH -7026: SQL statement not allowed without previous FETCH Ende Ebene 4 Knoten -7026: SQL statement not allowed without previous FETCH
Anfang Ebene 4 Knoten -7029: Function not allowed for this data type -7029: Function not allowed for this data type Ende Ebene 4 Knoten -7029: Function not allowed for this data type
Anfang Ebene 4 Knoten -7032: SQL statement not allowed for column of data type LONG -7032: SQL statement not allowed for column of data type LONG Ende Ebene 4 Knoten -7032: SQL statement not allowed for column of data type LONG
Anfang Ebene 4 Knoten -7035: DEFAULT specification not allowed for this column -7035: DEFAULT specification not allowed for this column Ende Ebene 4 Knoten -7035: DEFAULT specification not allowed for this column
Anfang Ebene 4 Knoten -7036: ROWNO- specification not allowed in this context -7036: ROWNO- specification not allowed in this context Ende Ebene 4 Knoten -7036: ROWNO- specification not allowed in this context
Anfang Ebene 4 Knoten -7037: NULL value for NOT NULL column not allowed -7037: NULL value for NOT NULL column not allowed Ende Ebene 4 Knoten -7037: NULL value for NOT NULL column not allowed
Anfang Ebene 4 Knoten -7038: Foreign key column not allowed -7038: Foreign key column not allowed Ende Ebene 4 Knoten -7038: Foreign key column not allowed
Anfang Ebene 4 Knoten -7039: Cycle in referential constraint definition not allowed -7039: Cycle in referential constraint definition not allowed Ende Ebene 4 Knoten -7039: Cycle in referential constraint definition not allowed
Anfang Ebene 4 Knoten -7040: Referential constraint not allowed -7040: Referential constraint not allowed Ende Ebene 4 Knoten -7040: Referential constraint not allowed
Anfang Ebene 4 Knoten -7041: Result table name not allowed -7041: Result table name not allowed Ende Ebene 4 Knoten -7041: Result table name not allowed
Anfang Ebene 4 Knoten -7042: Key update not allowed -7042: Key update not allowed Ende Ebene 4 Knoten -7042: Key update not allowed
Anfang Ebene 4 Knoten -7043: Group member not allowed -7043: Group member not allowed Ende Ebene 4 Knoten -7043: Group member not allowed
Anfang Ebene 4 Knoten -7045: Parameter spec not allowed -7045: Parameter spec not allowed Ende Ebene 4 Knoten -7045: Parameter spec not allowed
Anfang Ebene 4 Knoten -7046: Column with length greater than 254 not allowed -7046: Column with length greater than 254 not allowed Ende Ebene 4 Knoten -7046: Column with length greater than 254 not allowed
Anfang Ebene 4 Knoten -7048: DROP/ALTER USER not allowed while user is connected -7048: DROP/ALTER USER not allowed while user is connected Ende Ebene 4 Knoten -7048: DROP/ALTER USER not allowed while user is connected
Anfang Ebene 4 Knoten -7050: Fastload with indexed table not allowed -7050: Fastload with indexed table not allowed Ende Ebene 4 Knoten -7050: Fastload with indexed table not allowed
Anfang Ebene 4 Knoten -7051: Read only view WITH CHECK OPTION not allowed -7051: Read only view WITH CHECK OPTION not allowed Ende Ebene 4 Knoten -7051: Read only view WITH CHECK OPTION not allowed
Anfang Ebene 4 Knoten -7055: Column(s) already indexed -7055: Column(s) already indexed Ende Ebene 4 Knoten -7055: Column(s) already indexed
Anfang Ebene 4 Knoten -7056: Subquery not allowed -7056: Subquery not allowed Ende Ebene 4 Knoten -7056: Subquery not allowed
Anfang Ebene 4 Knoten -7057: View definition contradicts new table definition -7057: View definition contradicts new table definition Ende Ebene 4 Knoten -7057: View definition contradicts new table definition
Anfang Ebene 4 Knoten -7058: Correlated subquery with select in from clause not allowe -7058: Correlated subquery with select in from clause not allowe Ende Ebene 4 Knoten -7058: Correlated subquery with select in from clause not allowe
Anfang Ebene 4 Knoten -7061: LOCK ROW for this table not allowed -7061: LOCK ROW for this table not allowed Ende Ebene 4 Knoten -7061: LOCK ROW for this table not allowed
Anfang Ebene 4 Knoten -7063: Temp table not allowed -7063: Temp table not allowed Ende Ebene 4 Knoten -7063: Temp table not allowed
Anfang Ebene 4 Knoten -7064: Feature not allowed in temp table definition -7064: Feature not allowed in temp table definition Ende Ebene 4 Knoten -7064: Feature not allowed in temp table definition
Anfang Ebene 4 Knoten -7065: SUBTRANS COMMIT/ROLLBACK not allowed without SUBTRANS BEG -7065: SUBTRANS COMMIT/ROLLBACK not allowed without SUBTRANS BEG Ende Ebene 4 Knoten -7065: SUBTRANS COMMIT/ROLLBACK not allowed without SUBTRANS BEG
Anfang Ebene 4 Knoten -7066: Unique index referenced by foreign key not allowed -7066: Unique index referenced by foreign key not allowed Ende Ebene 4 Knoten -7066: Unique index referenced by foreign key not allowed
Anfang Ebene 4 Knoten -7067: Update without repeated read not allowed -7067: Update without repeated read not allowed Ende Ebene 4 Knoten -7067: Update without repeated read not allowed
Anfang Ebene 4 Knoten -7068: Outer Join not allowed in this context -7068: Outer Join not allowed in this context Ende Ebene 4 Knoten -7068: Outer Join not allowed in this context
Anfang Ebene 4 Knoten -7071: AUTOSAVE LOG must be stopped -7071: AUTOSAVE LOG must be stopped Ende Ebene 4 Knoten -7071: AUTOSAVE LOG must be stopped
Anfang Ebene 4 Knoten -7072: More than one column with default SERIAL not allowed -7072: More than one column with default SERIAL not allowed Ende Ebene 4 Knoten -7072: More than one column with default SERIAL not allowed
Anfang Ebene 4 Knoten -7074: Cycle in granted roles not allowed -7074: Cycle in granted roles not allowed Ende Ebene 4 Knoten -7074: Cycle in granted roles not allowed
Anfang Ebene 4 Knoten -7075: Current save skipped, next is ready to take on this tape -7075: Current save skipped, next is ready to take on this tape Ende Ebene 4 Knoten -7075: Current save skipped, next is ready to take on this tape
Anfang Ebene 4 Knoten -7076: No more data to read from tape -7076: No more data to read from tape Ende Ebene 4 Knoten -7076: No more data to read from tape
Anfang Ebene 4 Knoten -7077: Synonym not allowed -7077: Synonym not allowed Ende Ebene 4 Knoten -7077: Synonym not allowed
Anfang Ebene 4 Knoten -7078: No backup is running -7078: No backup is running Ende Ebene 4 Knoten -7078: No backup is running
Anfang Ebene 4 Knoten -7079: A backup is already running -7079: A backup is already running Ende Ebene 4 Knoten -7079: A backup is already running
Anfang Ebene 4 Knoten -7080: Query in statement not allowed -7080: Query in statement not allowed Ende Ebene 4 Knoten -7080: Query in statement not allowed
Anfang Ebene 4 Knoten -7082: SQL statement not allowed for this table type -7082: SQL statement not allowed for this table type Ende Ebene 4 Knoten -7082: SQL statement not allowed for this table type
Anfang Ebene 4 Knoten -7084: Parameter change not allowed -7084: Parameter change not allowed Ende Ebene 4 Knoten -7084: Parameter change not allowed
Anfang Ebene 4 Knoten -7085: Function not allowed for this cursor -7085: Function not allowed for this cursor Ende Ebene 4 Knoten -7085: Function not allowed for this cursor
Anfang Ebene 4 Knoten -7086: Schema not allowed -7086: Schema not allowed Ende Ebene 4 Knoten -7086: Schema not allowed
Anfang Ebene 4 Knoten -7500: DCOM HRESULT -7500: DCOM HRESULT Ende Ebene 4 Knoten -7500: DCOM HRESULT
Anfang Ebene 4 Knoten -7900: Different block sizes -7900: Different block sizes Ende Ebene 4 Knoten -7900: Different block sizes
Anfang Ebene 3 Knoten Von -8000 bis -9799 Von -8000 bis -9799 Ende Ebene 3 Knoten Von -8000 bis -9799
Anfang Ebene 4 Knoten -8000: SERVERDB must be restarted -8000: SERVERDB must be restarted Ende Ebene 4 Knoten -8000: SERVERDB must be restarted
Anfang Ebene 4 Knoten -8001: User must be connected -8001: User must be connected Ende Ebene 4 Knoten -8001: User must be connected
Anfang Ebene 4 Knoten -8002: User already connected to this user task -8002: User already connected to this user task Ende Ebene 4 Knoten -8002: User already connected to this user task
Anfang Ebene 4 Knoten -8003: Log and data must be compatible -8003: Log and data must be compatible Ende Ebene 4 Knoten -8003: Log and data must be compatible
Anfang Ebene 4 Knoten -8004: Constant must be compatible with column type and length -8004: Constant must be compatible with column type and length Ende Ebene 4 Knoten -8004: Constant must be compatible with column type and length
Anfang Ebene 4 Knoten -8005: Value expression must be parameter name -8005: Value expression must be parameter name Ende Ebene 4 Knoten -8005: Value expression must be parameter name
Anfang Ebene 4 Knoten -8006: Data types must be compatible -8006: Data types must be compatible Ende Ebene 4 Knoten -8006: Data types must be compatible
Anfang Ebene 4 Knoten -8007: Column must be key column -8007: Column must be key column Ende Ebene 4 Knoten -8007: Column must be key column
Anfang Ebene 4 Knoten -8009: DEFAULT value must be in constraint specification -8009: DEFAULT value must be in constraint specification Ende Ebene 4 Knoten -8009: DEFAULT value must be in constraint specification
Anfang Ebene 4 Knoten -8010: Table name must be in from list -8010: Table name must be in from list Ende Ebene 4 Knoten -8010: Table name must be in from list
Anfang Ebene 4 Knoten -8013: Order column must be output column -8013: Order column must be output column Ende Ebene 4 Knoten -8013: Order column must be output column
Anfang Ebene 4 Knoten -8014: Result table must be FOR REUSE -8014: Result table must be FOR REUSE Ende Ebene 4 Knoten -8014: Result table must be FOR REUSE
Anfang Ebene 4 Knoten -8015: Table must be a base table -8015: Table must be a base table Ende Ebene 4 Knoten -8015: Table must be a base table
Anfang Ebene 4 Knoten -8016: Table must be a view table -8016: Table must be a view table Ende Ebene 4 Knoten -8016: Table must be a view table
Anfang Ebene 4 Knoten -8017: Column must be group column -8017: Column must be group column Ende Ebene 4 Knoten -8017: Column must be group column
Anfang Ebene 4 Knoten -8018: Index name must be unique -8018: Index name must be unique Ende Ebene 4 Knoten -8018: Index name must be unique
Anfang Ebene 4 Knoten -8020: Next volume required -8020: Next volume required Ende Ebene 4 Knoten -8020: Next volume required
Anfang Ebene 4 Knoten -8021: Column must have DEFAULT specification -8021: Column must have DEFAULT specification Ende Ebene 4 Knoten -8021: Column must have DEFAULT specification
Anfang Ebene 4 Knoten -8022: User already connected -8022: User already connected Ende Ebene 4 Knoten -8022: User already connected
Anfang Ebene 4 Knoten -8023: COSTLIMIT must be greater than COSTWARNING -8023: COSTLIMIT must be greater than COSTWARNING Ende Ebene 4 Knoten -8023: COSTLIMIT must be greater than COSTWARNING
Anfang Ebene 4 Knoten -8024: RESTORE CATALOG failed -8024: RESTORE CATALOG failed Ende Ebene 4 Knoten -8024: RESTORE CATALOG failed
Anfang Ebene 4 Knoten -8025: Table must be temp table -8025: Table must be temp table Ende Ebene 4 Knoten -8025: Table must be temp table
Anfang Ebene 4 Knoten -8026: Connect disabled for this user -8026: Connect disabled for this user Ende Ebene 4 Knoten -8026: Connect disabled for this user
Anfang Ebene 4 Knoten -8028: UNION columns must be compatible -8028: UNION columns must be compatible Ende Ebene 4 Knoten -8028: UNION columns must be compatible
Anfang Ebene 4 Knoten -8030: Column must be indexed -8030: Column must be indexed Ende Ebene 4 Knoten -8030: Column must be indexed
Anfang Ebene 4 Knoten -8031: Schema must be specified -8031: Schema must be specified Ende Ebene 4 Knoten -8031: Schema must be specified
Anfang Ebene 4 Knoten -8033: Incomplete log segment -8033: Incomplete log segment Ende Ebene 4 Knoten -8033: Incomplete log segment
Anfang Ebene 4 Knoten -8034: Order column must be number -8034: Order column must be number Ende Ebene 4 Knoten -8034: Order column must be number
Anfang Ebene 4 Knoten -8035: Foreign key must exist -8035: Foreign key must exist Ende Ebene 4 Knoten -8035: Foreign key must exist
Anfang Ebene 4 Knoten -8037: DB procedure must be recompiled -8037: DB procedure must be recompiled Ende Ebene 4 Knoten -8037: DB procedure must be recompiled
Anfang Ebene 4 Knoten -8040: Key does not exist -8040: Key does not exist Ende Ebene 4 Knoten -8040: Key does not exist
Anfang Ebene 4 Knoten -8044: Conversion for character set value impossible -8044: Conversion for character set value impossible Ende Ebene 4 Knoten -8044: Conversion for character set value impossible
Anfang Ebene 4 Knoten -8045: Conversion to UNICODE impossible -8045: Conversion to UNICODE impossible Ende Ebene 4 Knoten -8045: Conversion to UNICODE impossible
Anfang Ebene 4 Knoten -8046: Conversion from UNICODE impossible -8046: Conversion from UNICODE impossible Ende Ebene 4 Knoten -8046: Conversion from UNICODE impossible
Anfang Ebene 4 Knoten -8047: Password required -8047: Password required Ende Ebene 4 Knoten -8047: Password required
Anfang Ebene 4 Knoten -8048: Version of component must be compatible with kernel versi -8048: Version of component must be compatible with kernel versi Ende Ebene 4 Knoten -8048: Version of component must be compatible with kernel versi
Anfang Ebene 4 Knoten -8049: Prepare migration required -8049: Prepare migration required Ende Ebene 4 Knoten -8049: Prepare migration required
Anfang Ebene 4 Knoten -8050: Migration error -8050: Migration error Ende Ebene 4 Knoten -8050: Migration error
Anfang Ebene 4 Knoten -8051: No snapshot available -8051: No snapshot available Ende Ebene 4 Knoten -8051: No snapshot available
Anfang Ebene 4 Knoten -8052: Trigger dropped during migration; check view migrationerr -8052: Trigger dropped during migration; check view migrationerr Ende Ebene 4 Knoten -8052: Trigger dropped during migration; check view migrationerr
Anfang Ebene 4 Knoten -8053: Software version is too old for version of persistent dat -8053: Software version is too old for version of persistent dat Ende Ebene 4 Knoten -8053: Software version is too old for version of persistent dat
Anfang Ebene 4 Knoten -8888: SERVERDB not accessible -8888: SERVERDB not accessible Ende Ebene 4 Knoten -8888: SERVERDB not accessible
Anfang Ebene 4 Knoten -9000: System error: Not yet implemented -9000: System error: Not yet implemented Ende Ebene 4 Knoten -9000: System error: Not yet implemented
Anfang Ebene 4 Knoten -9001 bis -9799: System error -9001 bis -9799: System error Ende Ebene 4 Knoten -9001 bis -9799: System error
Anfang Ebene 3 Knoten Von -10000 bis -10999 Von -10000 bis -10999 Ende Ebene 3 Knoten Von -10000 bis -10999
Anfang Ebene 4 Knoten -10001: System error: <description> -10001: System error: <description> Ende Ebene 4 Knoten -10001: System error: <description>
Anfang Ebene 4 Knoten -10003: Feature not supported for kernel version <version> -10003: Feature not supported for kernel version <version> Ende Ebene 4 Knoten -10003: Feature not supported for kernel version <version>
Anfang Ebene 4 Knoten -10100: Invalid value for option <option> of SQLDBC_ConnectPrope -10100: Invalid value for option <option> of SQLDBC_ConnectPrope Ende Ebene 4 Knoten -10100: Invalid value for option <option> of SQLDBC_ConnectPrope
Anfang Ebene 4 Knoten -10101: Invalid value for ISOLATIONLEVEL (<description>) -10101: Invalid value for ISOLATIONLEVEL (<description>) Ende Ebene 4 Knoten -10101: Invalid value for ISOLATIONLEVEL (<description>)
Anfang Ebene 4 Knoten -10102: Invalid value for PACKETCOUNT (<description>) -10102: Invalid value for PACKETCOUNT (<description>) Ende Ebene 4 Knoten -10102: Invalid value for PACKETCOUNT (<description>)
Anfang Ebene 4 Knoten -10103: Invalid value for STATEMENTCACHESIZE (<description>) -10103: Invalid value for STATEMENTCACHESIZE (<description>) Ende Ebene 4 Knoten -10103: Invalid value for STATEMENTCACHESIZE (<description>)
Anfang Ebene 4 Knoten -10104: Invalid value for KEY -10104: Invalid value for KEY Ende Ebene 4 Knoten -10104: Invalid value for KEY
Anfang Ebene 4 Knoten -10200: Function sequence error (data for execution expected) -10200: Function sequence error (data for execution expected) Ende Ebene 4 Knoten -10200: Function sequence error (data for execution expected)
Anfang Ebene 4 Knoten -10201: Function sequence error (no data for execution expected) -10201: Function sequence error (no data for execution expected) Ende Ebene 4 Knoten -10201: Function sequence error (no data for execution expected)
Anfang Ebene 4 Knoten -10202: Function sequence error (operation was aborted by discon -10202: Function sequence error (operation was aborted by discon Ende Ebene 4 Knoten -10202: Function sequence error (operation was aborted by discon
Anfang Ebene 4 Knoten -10210: Invalid command state (no prepared SQL command) -10210: Invalid command state (no prepared SQL command) Ende Ebene 4 Knoten -10210: Invalid command state (no prepared SQL command)
Anfang Ebene 4 Knoten -10220: Calling addBatch is not allowed for PreparedStatement / -10220: Calling addBatch is not allowed for PreparedStatement / Ende Ebene 4 Knoten -10220: Calling addBatch is not allowed for PreparedStatement /
Anfang Ebene 4 Knoten -10221: Command info too long -10221: Command info too long Ende Ebene 4 Knoten -10221: Command info too long
Anfang Ebene 4 Knoten -10300: Invalid parameter index [<number>] -10300: Invalid parameter index [<number>] Ende Ebene 4 Knoten -10300: Invalid parameter index [<number>]
Anfang Ebene 4 Knoten -10301: Invalid host type (<name>) for parameter (<number>) -10301: Invalid host type (<name>) for parameter (<number>) Ende Ebene 4 Knoten -10301: Invalid host type (<name>) for parameter (<number>)
Anfang Ebene 4 Knoten -10304: Parameter/Column (<number>) not bound -10304: Parameter/Column (<number>) not bound Ende Ebene 4 Knoten -10304: Parameter/Column (<number>) not bound
Anfang Ebene 4 Knoten -10305: Parameter <number> contains null pointer -10305: Parameter <number> contains null pointer Ende Ebene 4 Knoten -10305: Parameter <number> contains null pointer
Anfang Ebene 4 Knoten -10306: Negative buffer length for parameter (<number>) used -10306: Negative buffer length for parameter (<number>) used Ende Ebene 4 Knoten -10306: Negative buffer length for parameter (<number>) used
Anfang Ebene 4 Knoten -10307: Invalid length or indicator value for parameter (<number -10307: Invalid length or indicator value for parameter (<number Ende Ebene 4 Knoten -10307: Invalid length or indicator value for parameter (<number
Anfang Ebene 4 Knoten -10308: Non-character and non-binary data for parameter (<number -10308: Non-character and non-binary data for parameter (<number Ende Ebene 4 Knoten -10308: Non-character and non-binary data for parameter (<number
Anfang Ebene 4 Knoten -10310: Invalid column index (<number>) -10310: Invalid column index (<number>) Ende Ebene 4 Knoten -10310: Invalid column index (<number>)
Anfang Ebene 4 Knoten -10312: Attempt to concatenate to a NULL or DEFAULT value for pa -10312: Attempt to concatenate to a NULL or DEFAULT value for pa Ende Ebene 4 Knoten -10312: Attempt to concatenate to a NULL or DEFAULT value for pa
Anfang Ebene 4 Knoten -10313: Requested parameter (<number>) was already processed -10313: Requested parameter (<number>) was already processed Ende Ebene 4 Knoten -10313: Requested parameter (<number>) was already processed
Anfang Ebene 4 Knoten -10314: Invalid parameter processing sequence, process non-LONG -10314: Invalid parameter processing sequence, process non-LONG Ende Ebene 4 Knoten -10314: Invalid parameter processing sequence, process non-LONG
Anfang Ebene 4 Knoten -10315: Invalid start position (<number>) -10315: Invalid start position (<number>) Ende Ebene 4 Knoten -10315: Invalid start position (<number>)
Anfang Ebene 4 Knoten -10316: DATA AT EXECUTE for parameter (<number>) not allowed (co -10316: DATA AT EXECUTE for parameter (<number>) not allowed (co Ende Ebene 4 Knoten -10316: DATA AT EXECUTE for parameter (<number>) not allowed (co
Anfang Ebene 4 Knoten -10317: LOB type for parameter (<number>) not allowed (conflicts -10317: LOB type for parameter (<number>) not allowed (conflicts Ende Ebene 4 Knoten -10317: LOB type for parameter (<number>) not allowed (conflicts
Anfang Ebene 4 Knoten -10318: Invalid LOB object -10318: Invalid LOB object Ende Ebene 4 Knoten -10318: Invalid LOB object
Anfang Ebene 4 Knoten -10319: Could not read/write LOB for parameter/column (<number>) -10319: Could not read/write LOB for parameter/column (<number>) Ende Ebene 4 Knoten -10319: Could not read/write LOB for parameter/column (<number>)
Anfang Ebene 4 Knoten -10320: LOB already closed for parameter/column (<number>) -10320: LOB already closed for parameter/column (<number>) Ende Ebene 4 Knoten -10320: LOB already closed for parameter/column (<number>)
Anfang Ebene 4 Knoten -10321: LOB invalidated by a previous error for parameter/column -10321: LOB invalidated by a previous error for parameter/column Ende Ebene 4 Knoten -10321: LOB invalidated by a previous error for parameter/column
Anfang Ebene 4 Knoten -10322: Could not insert LOB. Parameter/column (<number>) has a -10322: Could not insert LOB. Parameter/column (<number>) has a Ende Ebene 4 Knoten -10322: Could not insert LOB. Parameter/column (<number>) has a
Anfang Ebene 4 Knoten -10323: Non-character and non-binary data for parameter/column ( -10323: Non-character and non-binary data for parameter/column ( Ende Ebene 4 Knoten -10323: Non-character and non-binary data for parameter/column (
Anfang Ebene 4 Knoten -10324: Stream with id (<number>) not found -10324: Stream with id (<number>) not found Ende Ebene 4 Knoten -10324: Stream with id (<number>) not found
Anfang Ebene 4 Knoten -10325: Stream parameter (<number>) is not an input|output param -10325: Stream parameter (<number>) is not an input|output param Ende Ebene 4 Knoten -10325: Stream parameter (<number>) is not an input|output param
Anfang Ebene 4 Knoten -10326: No data found for stream (<number>) -10326: No data found for stream (<number>) Ende Ebene 4 Knoten -10326: No data found for stream (<number>)
Anfang Ebene 4 Knoten -10327: Invalid use of null pointer in stream parameter field of -10327: Invalid use of null pointer in stream parameter field of Ende Ebene 4 Knoten -10327: Invalid use of null pointer in stream parameter field of
Anfang Ebene 4 Knoten -10328: Mismatch of number of stream members for parameter (<num -10328: Mismatch of number of stream members for parameter (<num Ende Ebene 4 Knoten -10328: Mismatch of number of stream members for parameter (<num
Anfang Ebene 4 Knoten -10329: Invalid serial value requested, must be first or last va -10329: Invalid serial value requested, must be first or last va Ende Ebene 4 Knoten -10329: Invalid serial value requested, must be first or last va
Anfang Ebene 4 Knoten -10330: Multiple stream output sequence error -10330: Multiple stream output sequence error Ende Ebene 4 Knoten -10330: Multiple stream output sequence error
Anfang Ebene 4 Knoten -10331: Input stream callback buffer overflow for table id (<num -10331: Input stream callback buffer overflow for table id (<num Ende Ebene 4 Knoten -10331: Input stream callback buffer overflow for table id (<num
Anfang Ebene 4 Knoten -10332: No callback function supplied for stream parameter (<num -10332: No callback function supplied for stream parameter (<num Ende Ebene 4 Knoten -10332: No callback function supplied for stream parameter (<num
Anfang Ebene 4 Knoten -10400: Conversion looses significant digits for parameter/colum -10400: Conversion looses significant digits for parameter/colum Ende Ebene 4 Knoten -10400: Conversion looses significant digits for parameter/colum
Anfang Ebene 4 Knoten -10401: Conversion of parameter/column (<number>) would truncate -10401: Conversion of parameter/column (<number>) would truncate Ende Ebene 4 Knoten -10401: Conversion of parameter/column (<number>) would truncate
Anfang Ebene 4 Knoten -10404: Conversion not supported for parameter/column (<number>) -10404: Conversion not supported for parameter/column (<number>) Ende Ebene 4 Knoten -10404: Conversion not supported for parameter/column (<number>)
Anfang Ebene 4 Knoten -10405: Cannot convert UCS2 data to ASCII -10405: Cannot convert UCS2 data to ASCII Ende Ebene 4 Knoten -10405: Cannot convert UCS2 data to ASCII
Anfang Ebene 4 Knoten -10406: Invalid data length for UCS2 data for parameter/column ( -10406: Invalid data length for UCS2 data for parameter/column ( Ende Ebene 4 Knoten -10406: Invalid data length for UCS2 data for parameter/column (
Anfang Ebene 4 Knoten -10407: Corrupted UTF8 data for parameter/column (<number>) -10407: Corrupted UTF8 data for parameter/column (<number>) Ende Ebene 4 Knoten -10407: Corrupted UTF8 data for parameter/column (<number>)
Anfang Ebene 4 Knoten -10408: Character conversion failed -10408: Character conversion failed Ende Ebene 4 Knoten -10408: Character conversion failed
Anfang Ebene 4 Knoten -10410: Date/time format is not supported for parameter/column ( -10410: Date/time format is not supported for parameter/column ( Ende Ebene 4 Knoten -10410: Date/time format is not supported for parameter/column (
Anfang Ebene 4 Knoten -10411: Illegal DATE value for parameter/column (<number>) -10411: Illegal DATE value for parameter/column (<number>) Ende Ebene 4 Knoten -10411: Illegal DATE value for parameter/column (<number>)
Anfang Ebene 4 Knoten -10412: Illegal TIME value for parameter/column (<number>) -10412: Illegal TIME value for parameter/column (<number>) Ende Ebene 4 Knoten -10412: Illegal TIME value for parameter/column (<number>)
Anfang Ebene 4 Knoten -10413: Illegal TIMESTAMP value for parameter/column (<number>) -10413: Illegal TIMESTAMP value for parameter/column (<number>) Ende Ebene 4 Knoten -10413: Illegal TIMESTAMP value for parameter/column (<number>)
Anfang Ebene 4 Knoten -10414: Conversion from binary value to string is not supported -10414: Conversion from binary value to string is not supported Ende Ebene 4 Knoten -10414: Conversion from binary value to string is not supported
Anfang Ebene 4 Knoten -10500: Result set is closed -10500: Result set is closed Ende Ebene 4 Knoten -10500: Result set is closed
Anfang Ebene 4 Knoten -10501: Invalid position in result set: before first row -10501: Invalid position in result set: before first row Ende Ebene 4 Knoten -10501: Invalid position in result set: before first row
Anfang Ebene 4 Knoten -10502: Invalid position in result set: after last row -10502: Invalid position in result set: after last row Ende Ebene 4 Knoten -10502: Invalid position in result set: after last row
Anfang Ebene 4 Knoten -10503: The operation is not allowed for result set type FORWARD -10503: The operation is not allowed for result set type FORWARD Ende Ebene 4 Knoten -10503: The operation is not allowed for result set type FORWARD
Anfang Ebene 4 Knoten -10504: Invalid position (<row_number>) for row set -10504: Invalid position (<row_number>) for row set Ende Ebene 4 Knoten -10504: Invalid position (<row_number>) for row set
Anfang Ebene 4 Knoten -10505: Result set type is UPDATABLE but row set type is READ_ON -10505: Result set type is UPDATABLE but row set type is READ_ON Ende Ebene 4 Knoten -10505: Result set type is UPDATABLE but row set type is READ_ON
Anfang Ebene 4 Knoten -10506: Result set type is READ_ONLY but row set type is UPDATAB -10506: Result set type is READ_ONLY but row set type is UPDATAB Ende Ebene 4 Knoten -10506: Result set type is READ_ONLY but row set type is UPDATAB
Anfang Ebene 4 Knoten -10507: Internal error: No metadata available for row set operat -10507: Internal error: No metadata available for row set operat Ende Ebene 4 Knoten -10507: Internal error: No metadata available for row set operat
Anfang Ebene 4 Knoten -10508: Invalid encoding of column name for column (<number>) fo -10508: Invalid encoding of column name for column (<number>) fo Ende Ebene 4 Knoten -10508: Invalid encoding of column name for column (<number>) fo
Anfang Ebene 4 Knoten -10509: The statement was not executed with updatable cursor con -10509: The statement was not executed with updatable cursor con Ende Ebene 4 Knoten -10509: The statement was not executed with updatable cursor con
Anfang Ebene 4 Knoten -10601: SQL command is the empty string -10601: SQL command is the empty string Ende Ebene 4 Knoten -10601: SQL command is the empty string
Anfang Ebene 4 Knoten -10602: SQL command contains UNICODE character -10602: SQL command contains UNICODE character Ende Ebene 4 Knoten -10602: SQL command contains UNICODE character
Anfang Ebene 4 Knoten -10603: SQL command would generate a result set -10603: SQL command would generate a result set Ende Ebene 4 Knoten -10603: SQL command would generate a result set
Anfang Ebene 4 Knoten -10604: SQL command contains output parameters -10604: SQL command contains output parameters Ende Ebene 4 Knoten -10604: SQL command contains output parameters
Anfang Ebene 4 Knoten -10605: Illegal schema modification, parameters/columns have cha -10605: Illegal schema modification, parameters/columns have cha Ende Ebene 4 Knoten -10605: Illegal schema modification, parameters/columns have cha
Anfang Ebene 4 Knoten -10706: Statement too long -10706: Statement too long Ende Ebene 4 Knoten -10706: Statement too long
Anfang Ebene 4 Knoten -10709: Connection failed (<description>) -10709: Connection failed (<description>) Ende Ebene 4 Knoten -10709: Connection failed (<description>)
Anfang Ebene 4 Knoten -10715: Missing user name for connection | Missing password for -10715: Missing user name for connection | Missing password for Ende Ebene 4 Knoten -10715: Missing user name for connection | Missing password for
Anfang Ebene 4 Knoten -10757: XUSER error (<description>) -10757: XUSER error (<description>) Ende Ebene 4 Knoten -10757: XUSER error (<description>)
Anfang Ebene 4 Knoten -10802: Invalid numeric value for parameter/column (<number>) -10802: Invalid numeric value for parameter/column (<number>) Ende Ebene 4 Knoten -10802: Invalid numeric value for parameter/column (<number>)
Anfang Ebene 4 Knoten -10803: Allocation of shared memory failed (<description>) -10803: Allocation of shared memory failed (<description>) Ende Ebene 4 Knoten -10803: Allocation of shared memory failed (<description>)
Anfang Ebene 4 Knoten -10807: Connection down: [<description>] -10807: Connection down: [<description>] Ende Ebene 4 Knoten -10807: Connection down: [<description>]
Anfang Ebene 4 Knoten -10808: Feature <feature> not implemented yet in module: <module -10808: Feature <feature> not implemented yet in module: <module Ende Ebene 4 Knoten -10808: Feature <feature> not implemented yet in module: <module
Anfang Ebene 4 Knoten -10810: Session already in use -10810: Session already in use Ende Ebene 4 Knoten -10810: Session already in use
Anfang Ebene 4 Knoten -10811: Numeric overflow for parameter/column (<number>) -10811: Numeric overflow for parameter/column (<number>) Ende Ebene 4 Knoten -10811: Numeric overflow for parameter/column (<number>)
Anfang Ebene 4 Knoten -10821: Session not connected -10821: Session not connected Ende Ebene 4 Knoten -10821: Session not connected
Anfang Ebene 4 Knoten -10856: Invalid row array size 0 -10856: Invalid row array size 0 Ende Ebene 4 Knoten -10856: Invalid row array size 0
Anfang Ebene 4 Knoten -10857: Missing database name for connection -10857: Missing database name for connection Ende Ebene 4 Knoten -10857: Missing database name for connection
Anfang Ebene 4 Knoten -10861: Invalid use of null pointer for stream handle in paramet -10861: Invalid use of null pointer for stream handle in paramet Ende Ebene 4 Knoten -10861: Invalid use of null pointer for stream handle in paramet
Anfang Ebene 4 Knoten -10862: Stream parameter (<number>) error in read|write procedur -10862: Stream parameter (<number>) error in read|write procedur Ende Ebene 4 Knoten -10862: Stream parameter (<number>) error in read|write procedur
Anfang Ebene 4 Knoten -10899: Unknown error -10899: Unknown error Ende Ebene 4 Knoten -10899: Unknown error
Anfang Ebene 4 Knoten -10901: No space left in request packet -10901: No space left in request packet Ende Ebene 4 Knoten -10901: No space left in request packet
Anfang Ebene 4 Knoten -10902: Invalid request packet structure -10902: Invalid request packet structure Ende Ebene 4 Knoten -10902: Invalid request packet structure
Anfang Ebene 4 Knoten -10903: Internal Error: LONGDATA part expected -10903: Internal Error: LONGDATA part expected Ende Ebene 4 Knoten -10903: Internal Error: LONGDATA part expected
Anfang Ebene 4 Knoten -10904: Internal error: Expected result count -10904: Internal error: Expected result count Ende Ebene 4 Knoten -10904: Internal error: Expected result count
Anfang Ebene 4 Knoten -10905: Invalid reply packet structure -10905: Invalid reply packet structure Ende Ebene 4 Knoten -10905: Invalid reply packet structure
Anfang Ebene 4 Knoten -10906: Internal Error: Entry for valindex (<number>) not found -10906: Internal Error: Entry for valindex (<number>) not found Ende Ebene 4 Knoten -10906: Internal Error: Entry for valindex (<number>) not found
Anfang Ebene 4 Knoten -10907: Internal Error: Long descriptor has error flag set -10907: Internal Error: Long descriptor has error flag set Ende Ebene 4 Knoten -10907: Internal Error: Long descriptor has error flag set
Anfang Ebene 3 Knoten Von -11000 bis -11099 Von -11000 bis -11099 Ende Ebene 3 Knoten Von -11000 bis -11099
Anfang Ebene 3 Knoten Von -11100 bis -11199 Von -11100 bis -11199 Ende Ebene 3 Knoten Von -11100 bis -11199
Anfang Ebene 4 Knoten -11100: Unknown error -11100: Unknown error Ende Ebene 4 Knoten -11100: Unknown error
Anfang Ebene 4 Knoten -11101: Initialization failed [<description>]. -11101: Initialization failed [<description>]. Ende Ebene 4 Knoten -11101: Initialization failed [<description>].
Anfang Ebene 4 Knoten -11104: Session not connected. -11104: Session not connected. Ende Ebene 4 Knoten -11104: Session not connected.
Anfang Ebene 4 Knoten -11105: Cannot get column name for column <number>. -11105: Cannot get column name for column <number>. Ende Ebene 4 Knoten -11105: Cannot get column name for column <number>.
Anfang Ebene 4 Knoten -11106: No result set found. -11106: No result set found. Ende Ebene 4 Knoten -11106: No result set found.
Anfang Ebene 4 Knoten -11107: Statement not prepared. -11107: Statement not prepared. Ende Ebene 4 Knoten -11107: Statement not prepared.
Anfang Ebene 4 Knoten -11108: Invalid parameter index <number>. -11108: Invalid parameter index <number>. Ende Ebene 4 Knoten -11108: Invalid parameter index <number>.
Anfang Ebene 4 Knoten -11109: Column/Parameter <number> truncated. -11109: Column/Parameter <number> truncated. Ende Ebene 4 Knoten -11109: Column/Parameter <number> truncated.
Anfang Ebene 4 Knoten -11111: Parameter/Column (<number>) not bound. -11111: Parameter/Column (<number>) not bound. Ende Ebene 4 Knoten -11111: Parameter/Column (<number>) not bound.
Anfang Ebene 4 Knoten -11113: Number of parameters does not match number of result col -11113: Number of parameters does not match number of result col Ende Ebene 4 Knoten -11113: Number of parameters does not match number of result col
Anfang Ebene 4 Knoten -11115: Syntax error. Expected: <description>. -11115: Syntax error. Expected: <description>. Ende Ebene 4 Knoten -11115: Syntax error. Expected: <description>.
Anfang Ebene 4 Knoten -11116: Wrong parameter type. Expected: <description>. -11116: Wrong parameter type. Expected: <description>. Ende Ebene 4 Knoten -11116: Wrong parameter type. Expected: <description>.
Anfang Ebene 3 Knoten Von -22000 bis -22999 Von -22000 bis -22999 Ende Ebene 3 Knoten Von -22000 bis -22999
Anfang Ebene 4 Knoten -22000: Null values not allowed on more than one long column -22000: Null values not allowed on more than one long column Ende Ebene 4 Knoten -22000: Null values not allowed on more than one long column
Anfang Ebene 4 Knoten -22005: Connection timeout occurred. Session reconnected -22005: Connection timeout occurred. Session reconnected Ende Ebene 4 Knoten -22005: Connection timeout occurred. Session reconnected
Anfang Ebene 3 Knoten Von -23000 bis -23999 Von -23000 bis -23999 Ende Ebene 3 Knoten Von -23000 bis -23999
Anfang Ebene 4 Knoten -23050: Unknown error -23050: Unknown error Ende Ebene 4 Knoten -23050: Unknown error
Anfang Ebene 4 Knoten -23051: Could not load system tables for SQL Studio -23051: Could not load system tables for SQL Studio Ende Ebene 4 Knoten -23051: Could not load system tables for SQL Studio
Anfang Ebene 4 Knoten -23052: Could not save object data -23052: Could not save object data Ende Ebene 4 Knoten -23052: Could not save object data
Anfang Ebene 4 Knoten -23053: Cannot load suppose list -23053: Cannot load suppose list Ende Ebene 4 Knoten -23053: Cannot load suppose list
Anfang Ebene 4 Knoten -23054: Maximum numbers of windows reached -23054: Maximum numbers of windows reached Ende Ebene 4 Knoten -23054: Maximum numbers of windows reached
Anfang Ebene 4 Knoten -23055: Connection failed -23055: Connection failed Ende Ebene 4 Knoten -23055: Connection failed
Anfang Ebene 4 Knoten -23056: User is exclusive -23056: User is exclusive Ende Ebene 4 Knoten -23056: User is exclusive
Anfang Ebene 4 Knoten -23057: Reconnect failed -23057: Reconnect failed Ende Ebene 4 Knoten -23057: Reconnect failed
Anfang Ebene 4 Knoten -23058: No database connection -23058: No database connection Ende Ebene 4 Knoten -23058: No database connection
Anfang Ebene 4 Knoten -23059: You do not have the permission to modify this object -23059: You do not have the permission to modify this object Ende Ebene 4 Knoten -23059: You do not have the permission to modify this object
Anfang Ebene 4 Knoten -23060: You do not have the permission to delete this object -23060: You do not have the permission to delete this object Ende Ebene 4 Knoten -23060: You do not have the permission to delete this object
Anfang Ebene 4 Knoten -23061: Cannot analyze error -23061: Cannot analyze error Ende Ebene 4 Knoten -23061: Cannot analyze error
Anfang Ebene 4 Knoten -23062: Could not open connection -23062: Could not open connection Ende Ebene 4 Knoten -23062: Could not open connection
Anfang Ebene 4 Knoten -23063: Could not create Global Com Object -23063: Could not create Global Com Object Ende Ebene 4 Knoten -23063: Could not create Global Com Object
Anfang Ebene 4 Knoten -23064: Import failed -23064: Import failed Ende Ebene 4 Knoten -23064: Import failed
Anfang Ebene 4 Knoten -23070: Cannot open object created by newer SQL Studio Version -23070: Cannot open object created by newer SQL Studio Version Ende Ebene 4 Knoten -23070: Cannot open object created by newer SQL Studio Version
Anfang Ebene 4 Knoten -23071: Convert object created by older SQL Studio Version -23071: Convert object created by older SQL Studio Version Ende Ebene 4 Knoten -23071: Convert object created by older SQL Studio Version
Anfang Ebene 4 Knoten -23072: Representation of null value too long -23072: Representation of null value too long Ende Ebene 4 Knoten -23072: Representation of null value too long
Anfang Ebene 4 Knoten -23100: OLE Error! Please restart SQL Studio -23100: OLE Error! Please restart SQL Studio Ende Ebene 4 Knoten -23100: OLE Error! Please restart SQL Studio
Anfang Ebene 4 Knoten -23101: Data in clipboard truncated -23101: Data in clipboard truncated Ende Ebene 4 Knoten -23101: Data in clipboard truncated
Anfang Ebene 4 Knoten -23102: Failed to create DBC Pool -23102: Failed to create DBC Pool Ende Ebene 4 Knoten -23102: Failed to create DBC Pool
Anfang Ebene 4 Knoten -23103: Failed to create DBC Handle -23103: Failed to create DBC Handle Ende Ebene 4 Knoten -23103: Failed to create DBC Handle
Anfang Ebene 4 Knoten -23104: Could not load table definition -23104: Could not load table definition Ende Ebene 4 Knoten -23104: Could not load table definition
Anfang Ebene 4 Knoten -23200: No data sources -23200: No data sources Ende Ebene 4 Knoten -23200: No data sources
Anfang Ebene 4 Knoten -23201: No ODBC driver -23201: No ODBC driver Ende Ebene 4 Knoten -23201: No ODBC driver
Anfang Ebene 4 Knoten -23202: Could not load object description -23202: Could not load object description Ende Ebene 4 Knoten -23202: Could not load object description
Anfang Ebene 4 Knoten -23203: Cannot show tables of users, wrong database version -23203: Cannot show tables of users, wrong database version Ende Ebene 4 Knoten -23203: Cannot show tables of users, wrong database version
Anfang Ebene 3 Knoten Von -24000 bis -24999 Von -24000 bis -24999 Ende Ebene 3 Knoten Von -24000 bis -24999
Anfang Ebene 4 Knoten -24905: ERR_NOEBIDLIST: no information on external backup IDs av -24905: ERR_NOEBIDLIST: no information on external backup IDs av Ende Ebene 4 Knoten -24905: ERR_NOEBIDLIST: no information on external backup IDs av
Anfang Ebene 4 Knoten -24906: ERR_EBFDIRTY: invalid format of external backup history -24906: ERR_EBFDIRTY: invalid format of external backup history Ende Ebene 4 Knoten -24906: ERR_EBFDIRTY: invalid format of external backup history
Anfang Ebene 4 Knoten -24907: ERR_DBAWRONG - wrong SYSDBA -24907: ERR_DBAWRONG - wrong SYSDBA Ende Ebene 4 Knoten -24907: ERR_DBAWRONG - wrong SYSDBA
Anfang Ebene 4 Knoten -24909: ERR_DBAUNKNOWN - SYSDBA unknown -24909: ERR_DBAUNKNOWN - SYSDBA unknown Ende Ebene 4 Knoten -24909: ERR_DBAUNKNOWN - SYSDBA unknown
Anfang Ebene 4 Knoten -24910: ERR_PARAMVER - wrong version of param help file (cserv.p -24910: ERR_PARAMVER - wrong version of param help file (cserv.p Ende Ebene 4 Knoten -24910: ERR_PARAMVER - wrong version of param help file (cserv.p
Anfang Ebene 4 Knoten -24911: ERR_INVDBNAME - database name <database_name> is reserve -24911: ERR_INVDBNAME - database name <database_name> is reserve Ende Ebene 4 Knoten -24911: ERR_INVDBNAME - database name <database_name> is reserve
Anfang Ebene 4 Knoten -24912: ERR_WRONGINST – DBM server instroot is <inst_path> -24912: ERR_WRONGINST – DBM server instroot is <inst_path> Ende Ebene 4 Knoten -24912: ERR_WRONGINST – DBM server instroot is <inst_path>
Anfang Ebene 4 Knoten -24913: ERR_SERVICEDB - can not register service kernel for <ins -24913: ERR_SERVICEDB - can not register service kernel for <ins Ende Ebene 4 Knoten -24913: ERR_SERVICEDB - can not register service kernel for <ins
Anfang Ebene 4 Knoten -24914: ERR_KEYEXISTS - installation key <key> exists -24914: ERR_KEYEXISTS - installation key <key> exists Ende Ebene 4 Knoten -24914: ERR_KEYEXISTS - installation key <key> exists
Anfang Ebene 4 Knoten -24915: ERR_NOADDD - configuration update not allowed (param fil -24915: ERR_NOADDD - configuration update not allowed (param fil Ende Ebene 4 Knoten -24915: ERR_NOADDD - configuration update not allowed (param fil
Anfang Ebene 4 Knoten -24916: ERR_MAXVOLCNT - max volume count exceeded -24916: ERR_MAXVOLCNT - max volume count exceeded Ende Ebene 4 Knoten -24916: ERR_MAXVOLCNT - max volume count exceeded
Anfang Ebene 4 Knoten -24917: ERR_MAXDATA - max data size exceeded -24917: ERR_MAXDATA - max data size exceeded Ende Ebene 4 Knoten -24917: ERR_MAXDATA - max data size exceeded
Anfang Ebene 4 Knoten -24918: ERR_MISSMIRR - missing data for mirror volume -24918: ERR_MISSMIRR - missing data for mirror volume Ende Ebene 4 Knoten -24918: ERR_MISSMIRR - missing data for mirror volume
Anfang Ebene 4 Knoten -24919: ERR_CLEANUP: cannot free all operational ressources afte -24919: ERR_CLEANUP: cannot free all operational ressources afte Ende Ebene 4 Knoten -24919: ERR_CLEANUP: cannot free all operational ressources afte
Anfang Ebene 4 Knoten -24920: ERR_BACKUPOP: backup operation was unsuccessful -24920: ERR_BACKUPOP: backup operation was unsuccessful Ende Ebene 4 Knoten -24920: ERR_BACKUPOP: backup operation was unsuccessful
Anfang Ebene 4 Knoten -24921: ERR_POSTOP: error while finishing backup operation -24921: ERR_POSTOP: error while finishing backup operation Ende Ebene 4 Knoten -24921: ERR_POSTOP: error while finishing backup operation
Anfang Ebene 4 Knoten -24922: ERR_OPCHK: cannot check state of backup operation -24922: ERR_OPCHK: cannot check state of backup operation Ende Ebene 4 Knoten -24922: ERR_OPCHK: cannot check state of backup operation
Anfang Ebene 4 Knoten -24923: ERR_TOOLREQ: error while starting external backup tool -24923: ERR_TOOLREQ: error while starting external backup tool Ende Ebene 4 Knoten -24923: ERR_TOOLREQ: error while starting external backup tool
Anfang Ebene 4 Knoten -24924: ERR_DBREQ: cannot start database kernel request -24924: ERR_DBREQ: cannot start database kernel request Ende Ebene 4 Knoten -24924: ERR_DBREQ: cannot start database kernel request
Anfang Ebene 4 Knoten -24925: ERR_PREPARE: preparation of backup operation failed -24925: ERR_PREPARE: preparation of backup operation failed Ende Ebene 4 Knoten -24925: ERR_PREPARE: preparation of backup operation failed
Anfang Ebene 4 Knoten -24926: ERR_MEDIUMCHK: medium cannot be used with this external -24926: ERR_MEDIUMCHK: medium cannot be used with this external Ende Ebene 4 Knoten -24926: ERR_MEDIUMCHK: medium cannot be used with this external
Anfang Ebene 4 Knoten -24927: ERR_TOOLCHK: external backup tool not found -24927: ERR_TOOLCHK: external backup tool not found Ende Ebene 4 Knoten -24927: ERR_TOOLCHK: external backup tool not found
Anfang Ebene 4 Knoten -24928: ERR_NOREPLY - no reply available -24928: ERR_NOREPLY - no reply available Ende Ebene 4 Knoten -24928: ERR_NOREPLY - no reply available
Anfang Ebene 4 Knoten -24929: ERR_USRFRM - invalid user record format -24929: ERR_USRFRM - invalid user record format Ende Ebene 4 Knoten -24929: ERR_USRFRM - invalid user record format
Anfang Ebene 4 Knoten -24930: ERR_XPVALUESET - parameter value not in value set -24930: ERR_XPVALUESET - parameter value not in value set Ende Ebene 4 Knoten -24930: ERR_XPVALUESET - parameter value not in value set
Anfang Ebene 4 Knoten -24931: ERR_XPMAX - parameter value higher than maximum allowed -24931: ERR_XPMAX - parameter value higher than maximum allowed Ende Ebene 4 Knoten -24931: ERR_XPMAX - parameter value higher than maximum allowed
Anfang Ebene 4 Knoten -24932: ERR_XPMIN - parameter value smaller than minimum allowed -24932: ERR_XPMIN - parameter value smaller than minimum allowed Ende Ebene 4 Knoten -24932: ERR_XPMIN - parameter value smaller than minimum allowed
Anfang Ebene 4 Knoten -24933: ERR_NOSERVICESESSION - no service kernel available -24933: ERR_NOSERVICESESSION - no service kernel available Ende Ebene 4 Knoten -24933: ERR_NOSERVICESESSION - no service kernel available
Anfang Ebene 4 Knoten -24934: ERR_VERSION - incompatible versions (param and kernel) -24934: ERR_VERSION - incompatible versions (param and kernel) Ende Ebene 4 Knoten -24934: ERR_VERSION - incompatible versions (param and kernel)
Anfang Ebene 4 Knoten -24935: ERR_NOUSERS - no users found -24935: ERR_NOUSERS - no users found Ende Ebene 4 Knoten -24935: ERR_NOUSERS - no users found
Anfang Ebene 4 Knoten -24936: ERR_DBNORUN - database is not running -24936: ERR_DBNORUN - database is not running Ende Ebene 4 Knoten -24936: ERR_DBNORUN - database is not running
Anfang Ebene 4 Knoten -24937: ERR_MISSRIGHT - no server rights for this command -24937: ERR_MISSRIGHT - no server rights for this command Ende Ebene 4 Knoten -24937: ERR_MISSRIGHT - no server rights for this command
Anfang Ebene 4 Knoten -24938: ERR_NOENTRY - no entry found -24938: ERR_NOENTRY - no entry found Ende Ebene 4 Knoten -24938: ERR_NOENTRY - no entry found
Anfang Ebene 4 Knoten -24939: ERR_LASTREG - cannot delete last registration of instanc -24939: ERR_LASTREG - cannot delete last registration of instanc Ende Ebene 4 Knoten -24939: ERR_LASTREG - cannot delete last registration of instanc
Anfang Ebene 4 Knoten -24940: ERR_NEEDSYSLOGON - system logon required -24940: ERR_NEEDSYSLOGON - system logon required Ende Ebene 4 Knoten -24940: ERR_NEEDSYSLOGON - system logon required
Anfang Ebene 4 Knoten -24941: ERR_NEEDLOGON - DBM server logon required -24941: ERR_NEEDLOGON - DBM server logon required Ende Ebene 4 Knoten -24941: ERR_NEEDLOGON - DBM server logon required
Anfang Ebene 4 Knoten -24942: ERR_USRDELSDBA - cannot delete sysdba -24942: ERR_USRDELSDBA - cannot delete sysdba Ende Ebene 4 Knoten -24942: ERR_USRDELSDBA - cannot delete sysdba
Anfang Ebene 4 Knoten -24943: ERR_USRDELDBM - cannot delete DBM operator -24943: ERR_USRDELDBM - cannot delete DBM operator Ende Ebene 4 Knoten -24943: ERR_USRDELDBM - cannot delete DBM operator
Anfang Ebene 4 Knoten -24944: ERR_USRDELSELF - cannot delete current user -24944: ERR_USRDELSELF - cannot delete current user Ende Ebene 4 Knoten -24944: ERR_USRDELSELF - cannot delete current user
Anfang Ebene 4 Knoten -24945: ERR_TOFEWPARAM - to few parameters -24945: ERR_TOFEWPARAM - to few parameters Ende Ebene 4 Knoten -24945: ERR_TOFEWPARAM - to few parameters
Anfang Ebene 4 Knoten -24946: ERR_TOMANYPARAM - to many parameters -24946: ERR_TOMANYPARAM - to many parameters Ende Ebene 4 Knoten -24946: ERR_TOMANYPARAM - to many parameters
Anfang Ebene 4 Knoten -24947: ERR_DBNAME - do not use dbname -24947: ERR_DBNAME - do not use dbname Ende Ebene 4 Knoten -24947: ERR_DBNAME - do not use dbname
Anfang Ebene 4 Knoten -24948: ERR_NODBNAME - database name required -24948: ERR_NODBNAME - database name required Ende Ebene 4 Knoten -24948: ERR_NODBNAME - database name required
Anfang Ebene 4 Knoten -24949: ERR_USREXISTS - user entry already exists -24949: ERR_USREXISTS - user entry already exists Ende Ebene 4 Knoten -24949: ERR_USREXISTS - user entry already exists
Anfang Ebene 4 Knoten -24950: ERR_USRFAIL - user authorization failed -24950: ERR_USRFAIL - user authorization failed Ende Ebene 4 Knoten -24950: ERR_USRFAIL - user authorization failed
Anfang Ebene 4 Knoten -24951: ERR_USRREAD - could not read user data -24951: ERR_USRREAD - could not read user data Ende Ebene 4 Knoten -24951: ERR_USRREAD - could not read user data
Anfang Ebene 4 Knoten -24952: ERR_USRSAVE - could not save user data -24952: ERR_USRSAVE - could not save user data Ende Ebene 4 Knoten -24952: ERR_USRSAVE - could not save user data
Anfang Ebene 4 Knoten -24953: ERR_DBEXIST - database instance already exists -24953: ERR_DBEXIST - database instance already exists Ende Ebene 4 Knoten -24953: ERR_DBEXIST - database instance already exists
Anfang Ebene 4 Knoten -24954: ERR_BANOAUTOMED - no autolog medium found in media list -24954: ERR_BANOAUTOMED - no autolog medium found in media list Ende Ebene 4 Knoten -24954: ERR_BANOAUTOMED - no autolog medium found in media list
Anfang Ebene 4 Knoten -24955: ERR_BANOSAVETYPE - backup type not defined -24955: ERR_BANOSAVETYPE - backup type not defined Ende Ebene 4 Knoten -24955: ERR_BANOSAVETYPE - backup type not defined
Anfang Ebene 4 Knoten -24956: ERR_BASAVETYPECON - backup type conflicts with medium de -24956: ERR_BASAVETYPECON - backup type conflicts with medium de Ende Ebene 4 Knoten -24956: ERR_BASAVETYPECON - backup type conflicts with medium de
Anfang Ebene 4 Knoten -24957: ERR_NOUSER - required user not set -24957: ERR_NOUSER - required user not set Ende Ebene 4 Knoten -24957: ERR_NOUSER - required user not set
Anfang Ebene 4 Knoten -24958: ERR_BAOVERWRITE - file already exists, cannot overwrite -24958: ERR_BAOVERWRITE - file already exists, cannot overwrite Ende Ebene 4 Knoten -24958: ERR_BAOVERWRITE - file already exists, cannot overwrite
Anfang Ebene 4 Knoten -24959: ERR_XPOVERFLOW - value out of margin -24959: ERR_XPOVERFLOW - value out of margin Ende Ebene 4 Knoten -24959: ERR_XPOVERFLOW - value out of margin
Anfang Ebene 4 Knoten -24960: ERR_DBRUN - database is running -24960: ERR_DBRUN - database is running Ende Ebene 4 Knoten -24960: ERR_DBRUN - database is running
Anfang Ebene 4 Knoten -24961: ERR_STATE - cannot determine current db state -24961: ERR_STATE - cannot determine current db state Ende Ebene 4 Knoten -24961: ERR_STATE - cannot determine current db state
Anfang Ebene 4 Knoten -24962: ERR_VOLTYPE - wrong volume type -24962: ERR_VOLTYPE - wrong volume type Ende Ebene 4 Knoten -24962: ERR_VOLTYPE - wrong volume type
Anfang Ebene 4 Knoten -24963: ERR_VOLCHECK - error while checking volume -24963: ERR_VOLCHECK - error while checking volume Ende Ebene 4 Knoten -24963: ERR_VOLCHECK - error while checking volume
Anfang Ebene 4 Knoten -24964: ERR_EXECUTE - error in program execution -24964: ERR_EXECUTE - error in program execution Ende Ebene 4 Knoten -24964: ERR_EXECUTE - error in program execution
Anfang Ebene 4 Knoten -24965: ERR_SYSLOGON - logon to system failed -24965: ERR_SYSLOGON - logon to system failed Ende Ebene 4 Knoten -24965: ERR_SYSLOGON - logon to system failed
Anfang Ebene 4 Knoten -24966: ERR_LOGON - logon to DBM server failed -24966: ERR_LOGON - logon to DBM server failed Ende Ebene 4 Knoten -24966: ERR_LOGON - logon to DBM server failed
Anfang Ebene 4 Knoten -24967: ERR_SYSTEM - system call error -24967: ERR_SYSTEM - system call error Ende Ebene 4 Knoten -24967: ERR_SYSTEM - system call error
Anfang Ebene 4 Knoten -24968: ERR_XPREADONLY - parameter is read only -24968: ERR_XPREADONLY - parameter is read only Ende Ebene 4 Knoten -24968: ERR_XPREADONLY - parameter is read only
Anfang Ebene 4 Knoten -24969: ERR_XPDIRTY - param file is dirty -24969: ERR_XPDIRTY - param file is dirty Ende Ebene 4 Knoten -24969: ERR_XPDIRTY - param file is dirty
Anfang Ebene 4 Knoten -24970: ERR_XPNOMODIFY - parameter must not be modified -24970: ERR_XPNOMODIFY - parameter must not be modified Ende Ebene 4 Knoten -24970: ERR_XPNOMODIFY - parameter must not be modified
Anfang Ebene 4 Knoten -24971: ERR_XPNOCHECK - no running parameter check -24971: ERR_XPNOCHECK - no running parameter check Ende Ebene 4 Knoten -24971: ERR_XPNOCHECK - no running parameter check
Anfang Ebene 4 Knoten -24972: ERR_XPINVCONF - invalid value -24972: ERR_XPINVCONF - invalid value Ende Ebene 4 Knoten -24972: ERR_XPINVCONF - invalid value
Anfang Ebene 4 Knoten -24973: ERR_XPCHECK - param check failure/request -24973: ERR_XPCHECK - param check failure/request Ende Ebene 4 Knoten -24973: ERR_XPCHECK - param check failure/request
Anfang Ebene 4 Knoten -24974: ERR_XPSESSION - param session active -24974: ERR_XPSESSION - param session active Ende Ebene 4 Knoten -24974: ERR_XPSESSION - param session active
Anfang Ebene 4 Knoten -24975: ERR_NOXPSESSION - param session inactive -24975: ERR_NOXPSESSION - param session inactive Ende Ebene 4 Knoten -24975: ERR_NOXPSESSION - param session inactive
Anfang Ebene 4 Knoten -24976: ERR_PARAMEXIST - param file of database already exists -24976: ERR_PARAMEXIST - param file of database already exists Ende Ebene 4 Knoten -24976: ERR_PARAMEXIST - param file of database already exists
Anfang Ebene 4 Knoten -24977: ERR_COMMAND - unknown command <command> -24977: ERR_COMMAND - unknown command <command> Ende Ebene 4 Knoten -24977: ERR_COMMAND - unknown command <command>
Anfang Ebene 4 Knoten -24978: ERR_XPSYNTAX - xparam syntax error -24978: ERR_XPSYNTAX - xparam syntax error Ende Ebene 4 Knoten -24978: ERR_XPSYNTAX - xparam syntax error
Anfang Ebene 4 Knoten -24979: ERR_XPNOTFOUND - parameter not found -24979: ERR_XPNOTFOUND - parameter not found Ende Ebene 4 Knoten -24979: ERR_XPNOTFOUND - parameter not found
Anfang Ebene 4 Knoten -24980: ERR_NOHELP - xparam help file not found -24980: ERR_NOHELP - xparam help file not found Ende Ebene 4 Knoten -24980: ERR_NOHELP - xparam help file not found
Anfang Ebene 4 Knoten -24981: ERR_HIENTRYNOTFOUND - backup history entry not found -24981: ERR_HIENTRYNOTFOUND - backup history entry not found Ende Ebene 4 Knoten -24981: ERR_HIENTRYNOTFOUND - backup history entry not found
Anfang Ebene 4 Knoten -24982: ERR_ERR_NOHISTORY - backup history file not found -24982: ERR_ERR_NOHISTORY - backup history file not found Ende Ebene 4 Knoten -24982: ERR_ERR_NOHISTORY - backup history file not found
Anfang Ebene 4 Knoten -24983: ERR_BANOVALIDTYPE - invalid backup type -24983: ERR_BANOVALIDTYPE - invalid backup type Ende Ebene 4 Knoten -24983: ERR_BANOVALIDTYPE - invalid backup type
Anfang Ebene 4 Knoten -24984: ERR_MENOVALID - invalid medium definition -24984: ERR_MENOVALID - invalid medium definition Ende Ebene 4 Knoten -24984: ERR_MENOVALID - invalid medium definition
Anfang Ebene 4 Knoten -24985: ERR_MENOTFOUND - medium not found -24985: ERR_MENOTFOUND - medium not found Ende Ebene 4 Knoten -24985: ERR_MENOTFOUND - medium not found
Anfang Ebene 4 Knoten -24986: ERR_NOMEDIA - media file not found -24986: ERR_NOMEDIA - media file not found Ende Ebene 4 Knoten -24986: ERR_NOMEDIA - media file not found
Anfang Ebene 4 Knoten -24987: ERR_TOSMALL - packet size too small for answer -24987: ERR_TOSMALL - packet size too small for answer Ende Ebene 4 Knoten -24987: ERR_TOSMALL - packet size too small for answer
Anfang Ebene 4 Knoten -24988: ERR_SQL - sql error -24988: ERR_SQL - sql error Ende Ebene 4 Knoten -24988: ERR_SQL - sql error
Anfang Ebene 4 Knoten -24989: ERR_NOHISTORYSESSION - no backup history session availab -24989: ERR_NOHISTORYSESSION - no backup history session availab Ende Ebene 4 Knoten -24989: ERR_NOHISTORYSESSION - no backup history session availab
Anfang Ebene 4 Knoten -24990: ERR_ NOBACKUPSESSION - no backup session available -24990: ERR_ NOBACKUPSESSION - no backup session available Ende Ebene 4 Knoten -24990: ERR_ NOBACKUPSESSION - no backup session available
Anfang Ebene 4 Knoten -24993: ERR_RTEEXT - runtime environment error -24993: ERR_RTEEXT - runtime environment error Ende Ebene 4 Knoten -24993: ERR_RTEEXT - runtime environment error
Anfang Ebene 4 Knoten -24994: ERR_RTE - runtime environment error -24994: ERR_RTE - runtime environment error Ende Ebene 4 Knoten -24994: ERR_RTE - runtime environment error
Anfang Ebene 4 Knoten -24995: ERR_MEM - memory allocation error -24995: ERR_MEM - memory allocation error Ende Ebene 4 Knoten -24995: ERR_MEM - memory allocation error
Anfang Ebene 4 Knoten -24996: ERR_PARAM - wrong parameters -24996: ERR_PARAM - wrong parameters Ende Ebene 4 Knoten -24996: ERR_PARAM - wrong parameters
Anfang Ebene 4 Knoten -24997: ERR_FILE - file handling error -24997: ERR_FILE - file handling error Ende Ebene 4 Knoten -24997: ERR_FILE - file handling error
Anfang Ebene 4 Knoten -24998: ERR_NOTIMPL - sorry, command not yet implemented -24998: ERR_NOTIMPL - sorry, command not yet implemented Ende Ebene 4 Knoten -24998: ERR_NOTIMPL - sorry, command not yet implemented
Anfang Ebene 4 Knoten -24999: ERR - common error -24999: ERR - common error Ende Ebene 4 Knoten -24999: ERR - common error
Anfang Ebene 3 Knoten Von -25000 bis -25999 Von -25000 bis -25999 Ende Ebene 3 Knoten Von -25000 bis -25999
Anfang Ebene 4 Knoten -25002: No database connection possible - missing database name; -25002: No database connection possible - missing database name; Ende Ebene 4 Knoten -25002: No database connection possible - missing database name;
Anfang Ebene 4 Knoten -25003: Getting hostname of database host failed: <error_code> = -25003: Getting hostname of database host failed: <error_code> = Ende Ebene 4 Knoten -25003: Getting hostname of database host failed: <error_code> =
Anfang Ebene 4 Knoten -25004: A connection to the database could not be established: < -25004: A connection to the database could not be established: < Ende Ebene 4 Knoten -25004: A connection to the database could not be established: <
Anfang Ebene 4 Knoten -25005: User (<user_name>) logon to database failed: <error_text -25005: User (<user_name>) logon to database failed: <error_text Ende Ebene 4 Knoten -25005: User (<user_name>) logon to database failed: <error_text
Anfang Ebene 4 Knoten -25006: Connect with userkey '<user_key>' failed: <error_text> -25006: Connect with userkey '<user_key>' failed: <error_text> Ende Ebene 4 Knoten -25006: Connect with userkey '<user_key>' failed: <error_text>
Anfang Ebene 4 Knoten -25007: No connection to server db '<database_name>' established -25007: No connection to server db '<database_name>' established Ende Ebene 4 Knoten -25007: No connection to server db '<database_name>' established
Anfang Ebene 4 Knoten -25008: Logon failure; previous user's (<user_name>) connection -25008: Logon failure; previous user's (<user_name>) connection Ende Ebene 4 Knoten -25008: Logon failure; previous user's (<user_name>) connection
Anfang Ebene 4 Knoten -25009: Failure in db communication (<type>): <return_code> = <e -25009: Failure in db communication (<type>): <return_code> = <e Ende Ebene 4 Knoten -25009: Failure in db communication (<type>): <return_code> = <e
Anfang Ebene 4 Knoten -25010: <SQL_error_text> -25010: <SQL_error_text> Ende Ebene 4 Knoten -25010: <SQL_error_text>
Anfang Ebene 4 Knoten -25011: Error executing internal SQL statement '<statement>' : ' -25011: Error executing internal SQL statement '<statement>' : ' Ende Ebene 4 Knoten -25011: Error executing internal SQL statement '<statement>' : '
Anfang Ebene 4 Knoten -25012: No user connection to server db established -25012: No user connection to server db established Ende Ebene 4 Knoten -25012: No user connection to server db established
Anfang Ebene 4 Knoten -25018: Error changing log file owner to current user '<user_nam -25018: Error changing log file owner to current user '<user_nam Ende Ebene 4 Knoten -25018: Error changing log file owner to current user '<user_nam
Anfang Ebene 4 Knoten -25019: Error opening server log file '<log_file_name>' (<error_ -25019: Error opening server log file '<log_file_name>' (<error_ Ende Ebene 4 Knoten -25019: Error opening server log file '<log_file_name>' (<error_
Anfang Ebene 4 Knoten -25020: No more memory available -25020: No more memory available Ende Ebene 4 Knoten -25020: No more memory available
Anfang Ebene 4 Knoten -25021: Error switching connected user to <user_name> : <error_t -25021: Error switching connected user to <user_name> : <error_t Ende Ebene 4 Knoten -25021: Error switching connected user to <user_name> : <error_t
Anfang Ebene 4 Knoten -25022: Received cancel request; stopping execution -25022: Received cancel request; stopping execution Ende Ebene 4 Knoten -25022: Received cancel request; stopping execution
Anfang Ebene 4 Knoten -25024: Error switching current schema to <schema_name> ; <error -25024: Error switching current schema to <schema_name> ; <error Ende Ebene 4 Knoten -25024: Error switching current schema to <schema_name> ; <error
Anfang Ebene 4 Knoten -25109: Command not implemented -25109: Command not implemented Ende Ebene 4 Knoten -25109: Command not implemented
Anfang Ebene 4 Knoten -25201: Column '<column_name>' - INTEGER field: 1, 2 or 4 bytes -25201: Column '<column_name>' - INTEGER field: 1, 2 or 4 bytes Ende Ebene 4 Knoten -25201: Column '<column_name>' - INTEGER field: 1, 2 or 4 bytes
Anfang Ebene 4 Knoten -25202: Column '<column_name>' - REAL field: 4 or 8 bytes long ( -25202: Column '<column_name>' - REAL field: 4 or 8 bytes long ( Ende Ebene 4 Knoten -25202: Column '<column_name>' - REAL field: 4 or 8 bytes long (
Anfang Ebene 4 Knoten -25203: Column '<column_name>' - DECIMAL field: 20 bytes maximum -25203: Column '<column_name>' - DECIMAL field: 20 bytes maximum Ende Ebene 4 Knoten -25203: Column '<column_name>' - DECIMAL field: 20 bytes maximum
Anfang Ebene 4 Knoten -25204: Column '<column_name>' - ZONED field: 20 bytes maximum ( -25204: Column '<column_name>' - ZONED field: 20 bytes maximum ( Ende Ebene 4 Knoten -25204: Column '<column_name>' - ZONED field: 20 bytes maximum (
Anfang Ebene 4 Knoten -25205: Declare USAGE between 50% and 100% -25205: Declare USAGE between 50% and 100% Ende Ebene 4 Knoten -25205: Declare USAGE between 50% and 100%
Anfang Ebene 4 Knoten -25206: USAGE value of '0 rows' not allowed -25206: USAGE value of '0 rows' not allowed Ende Ebene 4 Knoten -25206: USAGE value of '0 rows' not allowed
Anfang Ebene 4 Knoten -25207: USAGE value of row(s) too high; maximum number of record -25207: USAGE value of row(s) too high; maximum number of record Ende Ebene 4 Knoten -25207: USAGE value of row(s) too high; maximum number of record
Anfang Ebene 4 Knoten -25208: Invalid position specification (negative values not allo -25208: Invalid position specification (negative values not allo Ende Ebene 4 Knoten -25208: Invalid position specification (negative values not allo
Anfang Ebene 4 Knoten -25209: Invalid FRACTION specification (negative values not allo -25209: Invalid FRACTION specification (negative values not allo Ende Ebene 4 Knoten -25209: Invalid FRACTION specification (negative values not allo
Anfang Ebene 4 Knoten -25210: Invalid SCALE specification. Scale range: -127 <= SCALE -25210: Invalid SCALE specification. Scale range: -127 <= SCALE Ende Ebene 4 Knoten -25210: Invalid SCALE specification. Scale range: -127 <= SCALE
Anfang Ebene 4 Knoten -25211: Invalid ROUND specification (0 <= ROUND_value <= 18) -25211: Invalid ROUND specification (0 <= ROUND_value <= 18) Ende Ebene 4 Knoten -25211: Invalid ROUND specification (0 <= ROUND_value <= 18)
Anfang Ebene 4 Knoten -25212: Invalid TRUNC specification (0 <= TRUNC_value <= 18) -25212: Invalid TRUNC specification (0 <= TRUNC_value <= 18) Ende Ebene 4 Knoten -25212: Invalid TRUNC specification (0 <= TRUNC_value <= 18)
Anfang Ebene 4 Knoten -25213: Invalid file format specification: given formats rule ea -25213: Invalid file format specification: given formats rule ea Ende Ebene 4 Knoten -25213: Invalid file format specification: given formats rule ea
Anfang Ebene 4 Knoten -25214: The specification of a separator/delimiter is not allowe -25214: The specification of a separator/delimiter is not allowe Ende Ebene 4 Knoten -25214: The specification of a separator/delimiter is not allowe
Anfang Ebene 4 Knoten -25216: File option FWV required -25216: File option FWV required Ende Ebene 4 Knoten -25216: File option FWV required
Anfang Ebene 4 Knoten -25217: End position for column <column_name> lower than start p -25217: End position for column <column_name> lower than start p Ende Ebene 4 Knoten -25217: End position for column <column_name> lower than start p
Anfang Ebene 4 Knoten -25218: No column specified but file format is FWV -25218: No column specified but file format is FWV Ende Ebene 4 Knoten -25218: No column specified but file format is FWV
Anfang Ebene 4 Knoten -25219: Columns have to be specified in left-to-right order (pos -25219: Columns have to be specified in left-to-right order (pos Ende Ebene 4 Knoten -25219: Columns have to be specified in left-to-right order (pos
Anfang Ebene 4 Knoten -25220: Wrong separator/delimiter specification -25220: Wrong separator/delimiter specification Ende Ebene 4 Knoten -25220: Wrong separator/delimiter specification
Anfang Ebene 4 Knoten -25221: Wrong decimal specification -25221: Wrong decimal specification Ende Ebene 4 Knoten -25221: Wrong decimal specification
Anfang Ebene 4 Knoten -25222: Wrong Boolean specification -25222: Wrong Boolean specification Ende Ebene 4 Knoten -25222: Wrong Boolean specification
Anfang Ebene 4 Knoten -25223: Wrong null specification -25223: Wrong null specification Ende Ebene 4 Knoten -25223: Wrong null specification
Anfang Ebene 4 Knoten -25225: Wrong number specification -25225: Wrong number specification Ende Ebene 4 Knoten -25225: Wrong number specification
Anfang Ebene 4 Knoten -25226: A maximum of 1024 columns can be specified for one table -25226: A maximum of 1024 columns can be specified for one table Ende Ebene 4 Knoten -25226: A maximum of 1024 columns can be specified for one table
Anfang Ebene 4 Knoten -25227: Specification of conditions exceeds allowed count of con -25227: Specification of conditions exceeds allowed count of con Ende Ebene 4 Knoten -25227: Specification of conditions exceeds allowed count of con
Anfang Ebene 4 Knoten -25228: Incorrect date-time format, all patterns accepted in the -25228: Incorrect date-time format, all patterns accepted in the Ende Ebene 4 Knoten -25228: Incorrect date-time format, all patterns accepted in the
Anfang Ebene 4 Knoten -25229: Incorrect comparison operator in condition -25229: Incorrect comparison operator in condition Ende Ebene 4 Knoten -25229: Incorrect comparison operator in condition
Anfang Ebene 4 Knoten -25230: Cannot execute command DATAEXTRACT FOR <load_type>; spec -25230: Cannot execute command DATAEXTRACT FOR <load_type>; spec Ende Ebene 4 Knoten -25230: Cannot execute command DATAEXTRACT FOR <load_type>; spec
Anfang Ebene 4 Knoten -25231: ROUND or TRUNC specification not allowed for this column -25231: ROUND or TRUNC specification not allowed for this column Ende Ebene 4 Knoten -25231: ROUND or TRUNC specification not allowed for this column
Anfang Ebene 4 Knoten -25232: Wrong keyword -25232: Wrong keyword Ende Ebene 4 Knoten -25232: Wrong keyword
Anfang Ebene 4 Knoten -25233: Some column descriptions with end position but file form -25233: Some column descriptions with end position but file form Ende Ebene 4 Knoten -25233: Some column descriptions with end position but file form
Anfang Ebene 4 Knoten -25234: Some column descriptions without end position but file f -25234: Some column descriptions without end position but file f Ende Ebene 4 Knoten -25234: Some column descriptions without end position but file f
Anfang Ebene 4 Knoten -25235: Some positions specified more than once -25235: Some positions specified more than once Ende Ebene 4 Knoten -25235: Some positions specified more than once
Anfang Ebene 4 Knoten -25236: Some positions overlap -25236: Some positions overlap Ende Ebene 4 Knoten -25236: Some positions overlap
Anfang Ebene 4 Knoten -25237: Cannot execute DATAUPDATE command; specify set columns -25237: Cannot execute DATAUPDATE command; specify set columns Ende Ebene 4 Knoten -25237: Cannot execute DATAUPDATE command; specify set columns
Anfang Ebene 4 Knoten -25238: Cannot execute DATAUPDATE command; specify access column -25238: Cannot execute DATAUPDATE command; specify access column Ende Ebene 4 Knoten -25238: Cannot execute DATAUPDATE command; specify access column
Anfang Ebene 4 Knoten -25239: Specified value '<value>' is not a valid integer -25239: Specified value '<value>' is not a valid integer Ende Ebene 4 Knoten -25239: Specified value '<value>' is not a valid integer
Anfang Ebene 4 Knoten -25240: Incomplete logon parameters; password missing -25240: Incomplete logon parameters; password missing Ende Ebene 4 Knoten -25240: Incomplete logon parameters; password missing
Anfang Ebene 4 Knoten -25242: Database identifier too long -25242: Database identifier too long Ende Ebene 4 Knoten -25242: Database identifier too long
Anfang Ebene 4 Knoten -25243: Error parsing <time> mask: <error_text> -25243: Error parsing <time> mask: <error_text> Ende Ebene 4 Knoten -25243: Error parsing <time> mask: <error_text>
Anfang Ebene 4 Knoten -25244: Loader CONSTRAINT violation: <error_text> -25244: Loader CONSTRAINT violation: <error_text> Ende Ebene 4 Knoten -25244: Loader CONSTRAINT violation: <error_text>
Anfang Ebene 4 Knoten -25245: Error: specify CATALOG, DATA, and PACKAGE stream -25245: Error: specify CATALOG, DATA, and PACKAGE stream Ende Ebene 4 Knoten -25245: Error: specify CATALOG, DATA, and PACKAGE stream
Anfang Ebene 4 Knoten -25247: Error: specify CATALOG or DATA stream -25247: Error: specify CATALOG or DATA stream Ende Ebene 4 Knoten -25247: Error: specify CATALOG or DATA stream
Anfang Ebene 4 Knoten -25249: Invalid Isolation Level specification: possible values a -25249: Invalid Isolation Level specification: possible values a Ende Ebene 4 Knoten -25249: Invalid Isolation Level specification: possible values a
Anfang Ebene 4 Knoten -25250: Error building URI for encrypted connection: <error_text -25250: Error building URI for encrypted connection: <error_text Ende Ebene 4 Knoten -25250: Error building URI for encrypted connection: <error_text
Anfang Ebene 4 Knoten -25251: Code page to set (<code_page_name>) not found in system -25251: Code page to set (<code_page_name>) not found in system Ende Ebene 4 Knoten -25251: Code page to set (<code_page_name>) not found in system
Anfang Ebene 4 Knoten -25281: Syntax error at position <position> (<error_text>). Chec -25281: Syntax error at position <position> (<error_text>). Chec Ende Ebene 4 Knoten -25281: Syntax error at position <position> (<error_text>). Chec
Anfang Ebene 4 Knoten -25301: Invalid input for date or time column: <input_value> -25301: Invalid input for date or time column: <input_value> Ende Ebene 4 Knoten -25301: Invalid input for date or time column: <input_value>
Anfang Ebene 4 Knoten -25302: This value is not a valid number: '<input_value>' -25302: This value is not a valid number: '<input_value>' Ende Ebene 4 Knoten -25302: This value is not a valid number: '<input_value>'
Anfang Ebene 4 Knoten -25303: Input value does not match key order or range specificat -25303: Input value does not match key order or range specificat Ende Ebene 4 Knoten -25303: Input value does not match key order or range specificat
Anfang Ebene 4 Knoten -25304: Columns for key (KEY) or search condition missing -25304: Columns for key (KEY) or search condition missing Ende Ebene 4 Knoten -25304: Columns for key (KEY) or search condition missing
Anfang Ebene 4 Knoten -25305: Data for key columns exceeds allowed key length -25305: Data for key columns exceeds allowed key length Ende Ebene 4 Knoten -25305: Data for key columns exceeds allowed key length
Anfang Ebene 4 Knoten -25306: The value is not a valid HEX constant: <input_value> -25306: The value is not a valid HEX constant: <input_value> Ende Ebene 4 Knoten -25306: The value is not a valid HEX constant: <input_value>
Anfang Ebene 4 Knoten -25308: CONSTRAINT condition violated -25308: CONSTRAINT condition violated Ende Ebene 4 Knoten -25308: CONSTRAINT condition violated
Anfang Ebene 4 Knoten -25309: Invalid input for BOOLEAN column: <input_value> -25309: Invalid input for BOOLEAN column: <input_value> Ende Ebene 4 Knoten -25309: Invalid input for BOOLEAN column: <input_value>
Anfang Ebene 4 Knoten -25310: Column '<column_name>' must not contain NULL values -25310: Column '<column_name>' must not contain NULL values Ende Ebene 4 Knoten -25310: Column '<column_name>' must not contain NULL values
Anfang Ebene 4 Knoten -25311: No Data for NOT NULL - column without default (<column_n -25311: No Data for NOT NULL - column without default (<column_n Ende Ebene 4 Knoten -25311: No Data for NOT NULL - column without default (<column_n
Anfang Ebene 4 Knoten -25313: Overflow occurred, execution aborted -25313: Overflow occurred, execution aborted Ende Ebene 4 Knoten -25313: Overflow occurred, execution aborted
Anfang Ebene 4 Knoten -25314: Fractional part too small for column '<column_name>', mi -25314: Fractional part too small for column '<column_name>', mi Ende Ebene 4 Knoten -25314: Fractional part too small for column '<column_name>', mi
Anfang Ebene 4 Knoten -25315: Column data type of column '<column_name>' and external -25315: Column data type of column '<column_name>' and external Ende Ebene 4 Knoten -25315: Column data type of column '<column_name>' and external
Anfang Ebene 4 Knoten -25316: Table contains at least one column defined as LONG; IMPO -25316: Table contains at least one column defined as LONG; IMPO Ende Ebene 4 Knoten -25316: Table contains at least one column defined as LONG; IMPO
Anfang Ebene 4 Knoten -25317: Constant must be compatible with column type and length -25317: Constant must be compatible with column type and length Ende Ebene 4 Knoten -25317: Constant must be compatible with column type and length
Anfang Ebene 4 Knoten -25318: Syskey violation (the computed value exceeds the highest -25318: Syskey violation (the computed value exceeds the highest Ende Ebene 4 Knoten -25318: Syskey violation (the computed value exceeds the highest
Anfang Ebene 4 Knoten -25319: Missing data for specified column '<column_name>' -25319: Missing data for specified column '<column_name>' Ende Ebene 4 Knoten -25319: Missing data for specified column '<column_name>'
Anfang Ebene 4 Knoten -25320: The LONG value could not be loaded into column -25320: The LONG value could not be loaded into column Ende Ebene 4 Knoten -25320: The LONG value could not be loaded into column
Anfang Ebene 4 Knoten -25321: This condition value is not a valid number: '<value>' -25321: This condition value is not a valid number: '<value>' Ende Ebene 4 Knoten -25321: This condition value is not a valid number: '<value>'
Anfang Ebene 4 Knoten -25322: This condition value was truncated and cannot be used: ' -25322: This condition value was truncated and cannot be used: ' Ende Ebene 4 Knoten -25322: This condition value was truncated and cannot be used: '
Anfang Ebene 4 Knoten -25323: Data type of null value representation for column '<colu -25323: Data type of null value representation for column '<colu Ende Ebene 4 Knoten -25323: Data type of null value representation for column '<colu
Anfang Ebene 4 Knoten -25324: Errors checking length of column specifications. See loa -25324: Errors checking length of column specifications. See loa Ende Ebene 4 Knoten -25324: Errors checking length of column specifications. See loa
Anfang Ebene 4 Knoten -25325: Errors checking compatibility of external and db data ty -25325: Errors checking compatibility of external and db data ty Ende Ebene 4 Knoten -25325: Errors checking compatibility of external and db data ty
Anfang Ebene 4 Knoten -25326: The exported number (column '<column_name>') was truncat -25326: The exported number (column '<column_name>') was truncat Ende Ebene 4 Knoten -25326: The exported number (column '<column_name>') was truncat
Anfang Ebene 4 Knoten -25327: Error(s) exporting record <record_no>; start position of -25327: Error(s) exporting record <record_no>; start position of Ende Ebene 4 Knoten -25327: Error(s) exporting record <record_no>; start position of
Anfang Ebene 4 Knoten -25328: Some error(s) while extracting data. See loader server l -25328: Some error(s) while extracting data. See loader server l Ende Ebene 4 Knoten -25328: Some error(s) while extracting data. See loader server l
Anfang Ebene 4 Knoten -25329: The given data file '<file_name>' was not generated usin -25329: The given data file '<file_name>' was not generated usin Ende Ebene 4 Knoten -25329: The given data file '<file_name>' was not generated usin
Anfang Ebene 4 Knoten -25330: The page sizes of the source system and the target syste -25330: The page sizes of the source system and the target syste Ende Ebene 4 Knoten -25330: The page sizes of the source system and the target syste
Anfang Ebene 4 Knoten -25331: This is a restricted statement, user must be SYSDBA -25331: This is a restricted statement, user must be SYSDBA Ende Ebene 4 Knoten -25331: This is a restricted statement, user must be SYSDBA
Anfang Ebene 4 Knoten -25332: Error getting schema definition of table <table_name> (< -25332: Error getting schema definition of table <table_name> (< Ende Ebene 4 Knoten -25332: Error getting schema definition of table <table_name> (<
Anfang Ebene 4 Knoten -25333: Error getting index definitions for table <table_name> ( -25333: Error getting index definitions for table <table_name> ( Ende Ebene 4 Knoten -25333: Error getting index definitions for table <table_name> (
Anfang Ebene 4 Knoten -25334: File counter for data file exceeded maximum value of 999 -25334: File counter for data file exceeded maximum value of 999 Ende Ebene 4 Knoten -25334: File counter for data file exceeded maximum value of 999
Anfang Ebene 4 Knoten -25335: Error restoring single table using data file with multip -25335: Error restoring single table using data file with multip Ende Ebene 4 Knoten -25335: Error restoring single table using data file with multip
Anfang Ebene 4 Knoten -25336: Error restoring multiple tables using data file with sin -25336: Error restoring multiple tables using data file with sin Ende Ebene 4 Knoten -25336: Error restoring multiple tables using data file with sin
Anfang Ebene 4 Knoten -25337: Error restoring table <table_name>; no table data found -25337: Error restoring table <table_name>; no table data found Ende Ebene 4 Knoten -25337: Error restoring table <table_name>; no table data found
Anfang Ebene 4 Knoten -25338: Error during restart IMPORT; restart entry <position> no -25338: Error during restart IMPORT; restart entry <position> no Ende Ebene 4 Knoten -25338: Error during restart IMPORT; restart entry <position> no
Anfang Ebene 4 Knoten -25339: Error during restart IMPORT; file <file_name> could not -25339: Error during restart IMPORT; file <file_name> could not Ende Ebene 4 Knoten -25339: Error during restart IMPORT; file <file_name> could not
Anfang Ebene 4 Knoten -25340: UCS2 conversion error; character string contains invalid -25340: UCS2 conversion error; character string contains invalid Ende Ebene 4 Knoten -25340: UCS2 conversion error; character string contains invalid
Anfang Ebene 4 Knoten -25341: Error generating 'create table/index statements': <error -25341: Error generating 'create table/index statements': <error Ende Ebene 4 Knoten -25341: Error generating 'create table/index statements': <error
Anfang Ebene 4 Knoten -25342: Error restoring table <table_name>; table exists but sou -25342: Error restoring table <table_name>; table exists but sou Ende Ebene 4 Knoten -25342: Error restoring table <table_name>; table exists but sou
Anfang Ebene 4 Knoten -25343: Column name(s) or number(s) do not match column names/nu -25343: Column name(s) or number(s) do not match column names/nu Ende Ebene 4 Knoten -25343: Column name(s) or number(s) do not match column names/nu
Anfang Ebene 4 Knoten -25344: Incorrect field length for column '<column_name>', minim -25344: Incorrect field length for column '<column_name>', minim Ende Ebene 4 Knoten -25344: Incorrect field length for column '<column_name>', minim
Anfang Ebene 4 Knoten -25345: Definition of source and target table <table_name> do no -25345: Definition of source and target table <table_name> do no Ende Ebene 4 Knoten -25345: Definition of source and target table <table_name> do no
Anfang Ebene 4 Knoten -25346: Communication packet size too small to run IMPORT for PA -25346: Communication packet size too small to run IMPORT for PA Ende Ebene 4 Knoten -25346: Communication packet size too small to run IMPORT for PA
Anfang Ebene 4 Knoten -25347: Encoding type of source and target database do not match -25347: Encoding type of source and target database do not match Ende Ebene 4 Knoten -25347: Encoding type of source and target database do not match
Anfang Ebene 4 Knoten -25348: Different byte swap of source and target computer. The L -25348: Different byte swap of source and target computer. The L Ende Ebene 4 Knoten -25348: Different byte swap of source and target computer. The L
Anfang Ebene 4 Knoten -25349: Error exporting <type> data of table <table_name>. See l -25349: Error exporting <type> data of table <table_name>. See l Ende Ebene 4 Knoten -25349: Error exporting <type> data of table <table_name>. See l
Anfang Ebene 4 Knoten -25350: Conversion from UNICODE data to ASCII data is not suppor -25350: Conversion from UNICODE data to ASCII data is not suppor Ende Ebene 4 Knoten -25350: Conversion from UNICODE data to ASCII data is not suppor
Anfang Ebene 4 Knoten -25351: No long file info given for LONG column '<column_name>' -25351: No long file info given for LONG column '<column_name>' Ende Ebene 4 Knoten -25351: No long file info given for LONG column '<column_name>'
Anfang Ebene 4 Knoten -25352: Errors analyzing long file information. See loader serve -25352: Errors analyzing long file information. See loader serve Ende Ebene 4 Knoten -25352: Errors analyzing long file information. See loader serve
Anfang Ebene 4 Knoten -25353: Specified maximum number of LONG data files for column ' -25353: Specified maximum number of LONG data files for column ' Ende Ebene 4 Knoten -25353: Specified maximum number of LONG data files for column '
Anfang Ebene 4 Knoten -25354: LONGFILE specification missing or incorrect -25354: LONGFILE specification missing or incorrect Ende Ebene 4 Knoten -25354: LONGFILE specification missing or incorrect
Anfang Ebene 4 Knoten -25355: Error processing LONG value (column '<column_name>'): <e -25355: Error processing LONG value (column '<column_name>'): <e Ende Ebene 4 Knoten -25355: Error processing LONG value (column '<column_name>'): <e
Anfang Ebene 4 Knoten -25356: Error processing LONG value(s): <error_text> -25356: Error processing LONG value(s): <error_text> Ende Ebene 4 Knoten -25356: Error processing LONG value(s): <error_text>
Anfang Ebene 4 Knoten -25364: Name of table to import <table_name> and the table curre -25364: Name of table to import <table_name> and the table curre Ende Ebene 4 Knoten -25364: Name of table to import <table_name> and the table curre
Anfang Ebene 4 Knoten -25365: Data file corrupted: trailer not found -25365: Data file corrupted: trailer not found Ende Ebene 4 Knoten -25365: Data file corrupted: trailer not found
Anfang Ebene 4 Knoten -25366: Data file corrupted: header not found -25366: Data file corrupted: header not found Ende Ebene 4 Knoten -25366: Data file corrupted: header not found
Anfang Ebene 4 Knoten -25371: Error converting data from <source_encoding> to <target_ -25371: Error converting data from <source_encoding> to <target_ Ende Ebene 4 Knoten -25371: Error converting data from <source_encoding> to <target_
Anfang Ebene 4 Knoten -25390: Error generating CREATE TABLE/INDEX statements. Table na -25390: Error generating CREATE TABLE/INDEX statements. Table na Ende Ebene 4 Knoten -25390: Error generating CREATE TABLE/INDEX statements. Table na
Anfang Ebene 4 Knoten -25391: SQL statement is too long -25391: SQL statement is too long Ende Ebene 4 Knoten -25391: SQL statement is too long
Anfang Ebene 4 Knoten -25392: [SAP AG][SQLOD32 DLL][MaxDB] <error_text> -25392: [SAP AG][SQLOD32 DLL][MaxDB] <error_text> Ende Ebene 4 Knoten -25392: [SAP AG][SQLOD32 DLL][MaxDB] <error_text>
Anfang Ebene 4 Knoten -25393: Error during check if table <table_name> exists <error_t -25393: Error during check if table <table_name> exists <error_t Ende Ebene 4 Knoten -25393: Error during check if table <table_name> exists <error_t
Anfang Ebene 4 Knoten -25394: Catalog of table <table_name> changed while processing < -25394: Catalog of table <table_name> changed while processing < Ende Ebene 4 Knoten -25394: Catalog of table <table_name> changed while processing <
Anfang Ebene 4 Knoten -25401: Error reading system table SYSLOADER.CODEPAGE -25401: Error reading system table SYSLOADER.CODEPAGE Ende Ebene 4 Knoten -25401: Error reading system table SYSLOADER.CODEPAGE
Anfang Ebene 4 Knoten -25402: Error creating/granting system table SYSLOADER.CODEPAGE -25402: Error creating/granting system table SYSLOADER.CODEPAGE Ende Ebene 4 Knoten -25402: Error creating/granting system table SYSLOADER.CODEPAGE
Anfang Ebene 4 Knoten -25403: Error opening/reading code page file <code_page>. Can't -25403: Error opening/reading code page file <code_page>. Can't Ende Ebene 4 Knoten -25403: Error opening/reading code page file <code_page>. Can't
Anfang Ebene 4 Knoten -25404: Invalid HEX constant <hex_value> found in code page file -25404: Invalid HEX constant <hex_value> found in code page file Ende Ebene 4 Knoten -25404: Invalid HEX constant <hex_value> found in code page file
Anfang Ebene 4 Knoten -25405: Invalid ASCII values read or values not sorted in ascend -25405: Invalid ASCII values read or values not sorted in ascend Ende Ebene 4 Knoten -25405: Invalid ASCII values read or values not sorted in ascend
Anfang Ebene 4 Knoten -25451: Integrity violation (SQL_Error) -25451: Integrity violation (SQL_Error) Ende Ebene 4 Knoten -25451: Integrity violation (SQL_Error)
Anfang Ebene 4 Knoten -25498: Errors processing data for table <table_name>; No data i -25498: Errors processing data for table <table_name>; No data i Ende Ebene 4 Knoten -25498: Errors processing data for table <table_name>; No data i
Anfang Ebene 4 Knoten -25499: Errors processing data for table <table_name>. Data not -25499: Errors processing data for table <table_name>. Data not Ende Ebene 4 Knoten -25499: Errors processing data for table <table_name>. Data not
Anfang Ebene 4 Knoten -25500: Errors processing command exceed maximum number of error -25500: Errors processing command exceed maximum number of error Ende Ebene 4 Knoten -25500: Errors processing command exceed maximum number of error
Anfang Ebene 4 Knoten -25501: Error opening file <file_name> : <error_text> -25501: Error opening file <file_name> : <error_text> Ende Ebene 4 Knoten -25501: Error opening file <file_name> : <error_text>
Anfang Ebene 4 Knoten -25502: Error closing file <file_name> : <error_text> -25502: Error closing file <file_name> : <error_text> Ende Ebene 4 Knoten -25502: Error closing file <file_name> : <error_text>
Anfang Ebene 4 Knoten -25503: Error reading file <file_name> : <error_text> -25503: Error reading file <file_name> : <error_text> Ende Ebene 4 Knoten -25503: Error reading file <file_name> : <error_text>
Anfang Ebene 4 Knoten -25504: Error writing file <file_name> : <error_text> -25504: Error writing file <file_name> : <error_text> Ende Ebene 4 Knoten -25504: Error writing file <file_name> : <error_text>
Anfang Ebene 4 Knoten -25505: Error erasing file <file_name> : <error_text> -25505: Error erasing file <file_name> : <error_text> Ende Ebene 4 Knoten -25505: Error erasing file <file_name> : <error_text>
Anfang Ebene 4 Knoten -25507: Error truncating file <file_name> : <error_text> -25507: Error truncating file <file_name> : <error_text> Ende Ebene 4 Knoten -25507: Error truncating file <file_name> : <error_text>
Anfang Ebene 4 Knoten -25508: File <file_name> is not encoded as <encoding> -25508: File <file_name> is not encoded as <encoding> Ende Ebene 4 Knoten -25508: File <file_name> is not encoded as <encoding>
Anfang Ebene 4 Knoten -25551: Error importing statistics: <error_text> -25551: Error importing statistics: <error_text> Ende Ebene 4 Knoten -25551: Error importing statistics: <error_text>
Anfang Ebene 4 Knoten -25552: Error exporting statistics: <error_text> -25552: Error exporting statistics: <error_text> Ende Ebene 4 Knoten -25552: Error exporting statistics: <error_text>
Anfang Ebene 4 Knoten -25601: Error restoring table <table_name>. Table does not exist -25601: Error restoring table <table_name>. Table does not exist Ende Ebene 4 Knoten -25601: Error restoring table <table_name>. Table does not exist
Anfang Ebene 4 Knoten -25602: Error restoring table <table_name>. Table is not empty. -25602: Error restoring table <table_name>. Table is not empty. Ende Ebene 4 Knoten -25602: Error restoring table <table_name>. Table is not empty.
Anfang Ebene 4 Knoten -25603: Error processing IMPORT in PAGE Format. Loader versions -25603: Error processing IMPORT in PAGE Format. Loader versions Ende Ebene 4 Knoten -25603: Error processing IMPORT in PAGE Format. Loader versions
Anfang Ebene 4 Knoten -25801: Internal error [<file_name>,<line_no>,<error_code>]. Con -25801: Internal error [<file_name>,<line_no>,<error_code>]. Con Ende Ebene 4 Knoten -25801: Internal error [<file_name>,<line_no>,<error_code>]. Con
Anfang Ebene 3 Knoten Von -27000 bis -28999 Von -27000 bis -28999 Ende Ebene 3 Knoten Von -27000 bis -28999
Anfang Ebene 4 Knoten -27000: Unknown error -27000: Unknown error Ende Ebene 4 Knoten -27000: Unknown error
Anfang Ebene 4 Knoten -27003: Numeric input parameter overflow -27003: Numeric input parameter overflow Ende Ebene 4 Knoten -27003: Numeric input parameter overflow
Anfang Ebene 4 Knoten -27006: Incompatible data types -27006: Incompatible data types Ende Ebene 4 Knoten -27006: Incompatible data types
Anfang Ebene 4 Knoten -27009: Command too long -27009: Command too long Ende Ebene 4 Knoten -27009: Command too long
Anfang Ebene 4 Knoten -27014: Connect not ok -27014: Connect not ok Ende Ebene 4 Knoten -27014: Connect not ok
Anfang Ebene 4 Knoten -27015: Connection down -27015: Connection down Ende Ebene 4 Knoten -27015: Connection down
Anfang Ebene 4 Knoten -27016: DB shut down -27016: DB shut down Ende Ebene 4 Knoten -27016: DB shut down
Anfang Ebene 4 Knoten -27017: Too many users -27017: Too many users Ende Ebene 4 Knoten -27017: Too many users
Anfang Ebene 4 Knoten -27018: Connection error -27018: Connection error Ende Ebene 4 Knoten -27018: Connection error
Anfang Ebene 4 Knoten -27019: Conversion UNICODE to ASCII not possible -27019: Conversion UNICODE to ASCII not possible Ende Ebene 4 Knoten -27019: Conversion UNICODE to ASCII not possible
Anfang Ebene 4 Knoten -28001: Access via NIL OID -28001: Access via NIL OID Ende Ebene 4 Knoten -28001: Access via NIL OID
Anfang Ebene 4 Knoten -28002: Invalid OID -28002: Invalid OID Ende Ebene 4 Knoten -28002: Invalid OID
Anfang Ebene 4 Knoten -28003: Unknown GUID -28003: Unknown GUID Ende Ebene 4 Knoten -28003: Unknown GUID
Anfang Ebene 4 Knoten -28005: Duplicate object -28005: Duplicate object Ende Ebene 4 Knoten -28005: Duplicate object
Anfang Ebene 4 Knoten -28006: Object not locked -28006: Object not locked Ende Ebene 4 Knoten -28006: Object not locked
Anfang Ebene 4 Knoten -28007: OID not compatible with given class -28007: OID not compatible with given class Ende Ebene 4 Knoten -28007: OID not compatible with given class
Anfang Ebene 4 Knoten -28501: Error reading OMS input stream -28501: Error reading OMS input stream Ende Ebene 4 Knoten -28501: Error reading OMS input stream
Anfang Ebene 4 Knoten -28502: Error writing OMS output stream -28502: Error writing OMS output stream Ende Ebene 4 Knoten -28502: Error writing OMS output stream
Anfang Ebene 4 Knoten -28503: Crash in DB-Procedure -28503: Crash in DB-Procedure Ende Ebene 4 Knoten -28503: Crash in DB-Procedure
Anfang Ebene 4 Knoten -28505: No Component Object found -28505: No Component Object found Ende Ebene 4 Knoten -28505: No Component Object found
Anfang Ebene 4 Knoten -28508: Unsupported parameter type -28508: Unsupported parameter type Ende Ebene 4 Knoten -28508: Unsupported parameter type
Anfang Ebene 4 Knoten -28514: Unknown OMS Version -28514: Unknown OMS Version Ende Ebene 4 Knoten -28514: Unknown OMS Version
Anfang Ebene 4 Knoten -28515: OMS Version already open -28515: OMS Version already open Ende Ebene 4 Knoten -28515: OMS Version already open
Anfang Ebene 4 Knoten -28516: Commit or Rollback required -28516: Commit or Rollback required Ende Ebene 4 Knoten -28516: Commit or Rollback required
Anfang Ebene 4 Knoten -28517: Already in Critical Section -28517: Already in Critical Section Ende Ebene 4 Knoten -28517: Already in Critical Section
Anfang Ebene 4 Knoten -28518: Not in Critical Section -28518: Not in Critical Section Ende Ebene 4 Knoten -28518: Not in Critical Section
Anfang Ebene 4 Knoten -28521: Already in version -28521: Already in version Ende Ebene 4 Knoten -28521: Already in version
Anfang Ebene 4 Knoten -28522: Missing before image -28522: Missing before image Ende Ebene 4 Knoten -28522: Missing before image
Anfang Ebene 4 Knoten -28523: Unknown schema -28523: Unknown schema Ende Ebene 4 Knoten -28523: Unknown schema
Anfang Ebene 4 Knoten -28524: Duplicate schema -28524: Duplicate schema Ende Ebene 4 Knoten -28524: Duplicate schema
Anfang Ebene 4 Knoten -28525: Procedure Address not found -28525: Procedure Address not found Ende Ebene 4 Knoten -28525: Procedure Address not found
Anfang Ebene 4 Knoten -28527: Directory not found -28527: Directory not found Ende Ebene 4 Knoten -28527: Directory not found
Anfang Ebene 4 Knoten -28529: Too small name buffer -28529: Too small name buffer Ende Ebene 4 Knoten -28529: Too small name buffer
Anfang Ebene 4 Knoten -28530: omsTerminate called -28530: omsTerminate called Ende Ebene 4 Knoten -28530: omsTerminate called
Anfang Ebene 4 Knoten -28531: OMS read only -28531: OMS read only Ende Ebene 4 Knoten -28531: OMS read only
Anfang Ebene 4 Knoten -28532: Version bound by transaction -28532: Version bound by transaction Ende Ebene 4 Knoten -28532: Version bound by transaction
Anfang Ebene 4 Knoten -28533: Integer out of packed range -28533: Integer out of packed range Ende Ebene 4 Knoten -28533: Integer out of packed range
Anfang Ebene 4 Knoten -28534: Package must be recreated -28534: Package must be recreated Ende Ebene 4 Knoten -28534: Package must be recreated
Anfang Ebene 4 Knoten -28600: Invalid request code in packet -28600: Invalid request code in packet Ende Ebene 4 Knoten -28600: Invalid request code in packet
Anfang Ebene 4 Knoten -28601: Object data packet for read missing -28601: Object data packet for read missing Ende Ebene 4 Knoten -28601: Object data packet for read missing
Anfang Ebene 4 Knoten -28602: Packet size does not match object size -28602: Packet size does not match object size Ende Ebene 4 Knoten -28602: Packet size does not match object size
Anfang Ebene 4 Knoten -28603: Requested packet size to transfer an object is too big -28603: Requested packet size to transfer an object is too big Ende Ebene 4 Knoten -28603: Requested packet size to transfer an object is too big
Anfang Ebene 4 Knoten -28604: Trying to queue too many data packets when sending objec -28604: Trying to queue too many data packets when sending objec Ende Ebene 4 Knoten -28604: Trying to queue too many data packets when sending objec
Anfang Ebene 4 Knoten -28605: Invalid operation in UDE Server-Kernel communication -28605: Invalid operation in UDE Server-Kernel communication Ende Ebene 4 Knoten -28605: Invalid operation in UDE Server-Kernel communication
Anfang Ebene 4 Knoten -28606: Communication error -28606: Communication error Ende Ebene 4 Knoten -28606: Communication error
Anfang Ebene 4 Knoten -28607: Missing object data packet -28607: Missing object data packet Ende Ebene 4 Knoten -28607: Missing object data packet
Anfang Ebene 4 Knoten -28608: Invalid reply for stored procedure -28608: Invalid reply for stored procedure Ende Ebene 4 Knoten -28608: Invalid reply for stored procedure
Anfang Ebene 4 Knoten -28609: Stored procedure not found -28609: Stored procedure not found Ende Ebene 4 Knoten -28609: Stored procedure not found
Anfang Ebene 4 Knoten -28801: Wrong class id -28801: Wrong class id Ende Ebene 4 Knoten -28801: Wrong class id
Anfang Ebene 4 Knoten -28802: Wrong object version -28802: Wrong object version Ende Ebene 4 Knoten -28802: Wrong object version
Anfang Ebene 4 Knoten -28803: Wrong object version -28803: Wrong object version Ende Ebene 4 Knoten -28803: Wrong object version
Anfang Ebene 4 Knoten -28804: Too old OID -28804: Too old OID Ende Ebene 4 Knoten -28804: Too old OID
Anfang Ebene 4 Knoten -28806: Nil page pointer -28806: Nil page pointer Ende Ebene 4 Knoten -28806: Nil page pointer
Anfang Ebene 4 Knoten -28808: Hash not found -28808: Hash not found Ende Ebene 4 Knoten -28808: Hash not found
Anfang Ebene 4 Knoten -28810: Duplicate hash key -28810: Duplicate hash key Ende Ebene 4 Knoten -28810: Duplicate hash key
Anfang Ebene 4 Knoten -28813: Unknown consistent version -28813: Unknown consistent version Ende Ebene 4 Knoten -28813: Unknown consistent version
Anfang Ebene 4 Knoten -28814: Object not found -28814: Object not found Ende Ebene 4 Knoten -28814: Object not found
Anfang Ebene 4 Knoten -28815: Object history not found -28815: Object history not found Ende Ebene 4 Knoten -28815: Object history not found
Anfang Ebene 4 Knoten -28817: Wrong object length -28817: Wrong object length Ende Ebene 4 Knoten -28817: Wrong object length
Anfang Ebene 4 Knoten -28818: Wrong object position -28818: Wrong object position Ende Ebene 4 Knoten -28818: Wrong object position
Anfang Ebene 4 Knoten -28819: Object has been updated by other transactions -28819: Object has been updated by other transactions Ende Ebene 4 Knoten -28819: Object has been updated by other transactions
Anfang Ebene 4 Knoten -28823: Page already in use -28823: Page already in use Ende Ebene 4 Knoten -28823: Page already in use
Anfang Ebene 4 Knoten -28826: Pagecounter inconsistent -28826: Pagecounter inconsistent Ende Ebene 4 Knoten -28826: Pagecounter inconsistent
Anfang Ebene 4 Knoten -28828: Inconsistent information concerning “is container droppe -28828: Inconsistent information concerning “is container droppe Ende Ebene 4 Knoten -28828: Inconsistent information concerning “is container droppe
Anfang Ebene 4 Knoten -28902: Too many nested try/catch statements -28902: Too many nested try/catch statements Ende Ebene 4 Knoten -28902: Too many nested try/catch statements
Anfang Ebene 4 Knoten -28903: DBFunction$1 must return a value -28903: DBFunction$1 must return a value Ende Ebene 4 Knoten -28903: DBFunction$1 must return a value
Anfang Ebene 4 Knoten -28822 bis -28999: Internal Error -28822 bis -28999: Internal Error Ende Ebene 4 Knoten -28822 bis -28999: Internal Error
Anfang Ebene 3 Knoten Von 0 bis 1999 Von 0 bis 1999 Ende Ebene 3 Knoten Von 0 bis 1999
Anfang Ebene 4 Knoten 0: Success 0: Success Ende Ebene 4 Knoten 0: Success
Anfang Ebene 4 Knoten 100: Row not found 100: Row not found Ende Ebene 4 Knoten 100: Row not found
Anfang Ebene 4 Knoten 200: Duplicate key 200: Duplicate key Ende Ebene 4 Knoten 200: Duplicate key
Anfang Ebene 4 Knoten 250: Duplicate secondary key 250: Duplicate secondary key Ende Ebene 4 Knoten 250: Duplicate secondary key
Anfang Ebene 4 Knoten 300: Integrity violation 300: Integrity violation Ende Ebene 4 Knoten 300: Integrity violation
Anfang Ebene 4 Knoten 320: View violation 320: View violation Ende Ebene 4 Knoten 320: View violation
Anfang Ebene 4 Knoten 350: Referential integrity violated 350: Referential integrity violated Ende Ebene 4 Knoten 350: Referential integrity violated
Anfang Ebene 4 Knoten 360: Foreign key integrity violation 360: Foreign key integrity violation Ende Ebene 4 Knoten 360: Foreign key integrity violation
Anfang Ebene 4 Knoten 400: Lock collision 400: Lock collision Ende Ebene 4 Knoten 400: Lock collision
Anfang Ebene 4 Knoten 500: Lock request timeout 500: Lock request timeout Ende Ebene 4 Knoten 500: Lock request timeout
Anfang Ebene 4 Knoten 600: Work rolled back 600: Work rolled back Ende Ebene 4 Knoten 600: Work rolled back
Anfang Ebene 4 Knoten 650: Work rolled back 650: Work rolled back Ende Ebene 4 Knoten 650: Work rolled back
Anfang Ebene 4 Knoten 700: Session inactivity timeout (work rolled back) 700: Session inactivity timeout (work rolled back) Ende Ebene 4 Knoten 700: Session inactivity timeout (work rolled back)
Anfang Ebene 4 Knoten 710: Session terminated by shutdown (work rolled back) 710: Session terminated by shutdown (work rolled back) Ende Ebene 4 Knoten 710: Session terminated by shutdown (work rolled back)
Anfang Ebene 4 Knoten 750: Too many SQL statements (work rolled back) 750: Too many SQL statements (work rolled back) Ende Ebene 4 Knoten 750: Too many SQL statements (work rolled back)
Anfang Ebene 4 Knoten 1403: Row not found 1403: Row not found Ende Ebene 4 Knoten 1403: Row not found
Anfang Ebene 3 Knoten Von 25000 bis 25999 Von 25000 bis 25999 Ende Ebene 3 Knoten Von 25000 bis 25999
Anfang Ebene 4 Knoten 25599: Value for usage <number> rows too high to fit into one da 25599: Value for usage <number> rows too high to fit into one da Ende Ebene 4 Knoten 25599: Value for usage <number> rows too high to fit into one da
Anfang Ebene 4 Knoten 25600: CONFIGURATION stream is not supported for this Loader com 25600: CONFIGURATION stream is not supported for this Loader com Ende Ebene 4 Knoten 25600: CONFIGURATION stream is not supported for this Loader com
Anfang Ebene 4 Knoten 25601: Output of NULL values for column <column_name> will be tr 25601: Output of NULL values for column <column_name> will be tr Ende Ebene 4 Knoten 25601: Output of NULL values for column <column_name> will be tr
Anfang Ebene 4 Knoten 25602: Possible overflow of integer values for column '<column_n 25602: Possible overflow of integer values for column '<column_n Ende Ebene 4 Knoten 25602: Possible overflow of integer values for column '<column_n
Anfang Ebene 4 Knoten 25603: Output of literal '<literal>' will be truncated 25603: Output of literal '<literal>' will be truncated Ende Ebene 4 Knoten 25603: Output of literal '<literal>' will be truncated
Anfang Ebene 4 Knoten 25604: Surplus long file info (column name/id '<column_name>') i 25604: Surplus long file info (column name/id '<column_name>') i Ende Ebene 4 Knoten 25604: Surplus long file info (column name/id '<column_name>') i
Anfang Ebene 4 Knoten 25605: No header in binary data file and no record length in com 25605: No header in binary data file and no record length in com Ende Ebene 4 Knoten 25605: No header in binary data file and no record length in com
Anfang Ebene 4 Knoten 25606: Different byte swap of source and target machine; long va 25606: Different byte swap of source and target machine; long va Ende Ebene 4 Knoten 25606: Different byte swap of source and target machine; long va
Anfang Ebene 4 Knoten 25607: Value for usage <value>% too less to fit one row into one 25607: Value for usage <value>% too less to fit one row into one Ende Ebene 4 Knoten 25607: Value for usage <value>% too less to fit one row into one
Anfang Ebene 4 Knoten 25608: Restart file <file_name> not found; starting import from 25608: Restart file <file_name> not found; starting import from Ende Ebene 4 Knoten 25608: Restart file <file_name> not found; starting import from
Anfang Ebene 4 Knoten 25913: Table <schema_name>. <table_name> not imported 25913: Table <schema_name>. <table_name> not imported Ende Ebene 4 Knoten 25913: Table <schema_name>. <table_name> not imported
Anfang Ebene 4 Knoten 25921: Range of SEQUENCE is exhausted 25921: Range of SEQUENCE is exhausted Ende Ebene 4 Knoten 25921: Range of SEQUENCE is exhausted
Anfang Ebene 4 Knoten 25940: Error at record <record_count> in input file for table <t 25940: Error at record <record_count> in input file for table <t Ende Ebene 4 Knoten 25940: Error at record <record_count> in input file for table <t
Anfang Ebene 4 Knoten 25965: No data to import in datastream <file_name>; either the s 25965: No data to import in datastream <file_name>; either the s Ende Ebene 4 Knoten 25965: No data to import in datastream <file_name>; either the s
Anfang Ebene 4 Knoten 25966: Error at record <record_count> in input file <file_name> 25966: Error at record <record_count> in input file <file_name> Ende Ebene 4 Knoten 25966: Error at record <record_count> in input file <file_name>
Anfang Ebene 4 Knoten 25967: Error at position <file_position> in input file <file_nam 25967: Error at position <file_position> in input file <file_nam Ende Ebene 4 Knoten 25967: Error at position <file_position> in input file <file_nam
Anfang Ebene 4 Knoten 25968: Number of NULL values inserted: <null_count> (NULL repres 25968: Number of NULL values inserted: <null_count> (NULL repres Ende Ebene 4 Knoten 25968: Number of NULL values inserted: <null_count> (NULL repres
Anfang Ebene 2 Knoten MaxDB-Sicherheitsleitfaden MaxDB-Sicherheitsleitfaden Ende Ebene 2 Knoten MaxDB-Sicherheitsleitfaden
Anfang Ebene 3 Knoten Einführung Einführung Ende Ebene 3 Knoten Einführung
Anfang Ebene 3 Knoten Bevor Sie anfangen Bevor Sie anfangen Ende Ebene 3 Knoten Bevor Sie anfangen
Anfang Ebene 3 Knoten Technische Systemlandschaft Technische Systemlandschaft Ende Ebene 3 Knoten Technische Systemlandschaft
Anfang Ebene 3 Knoten Benutzerverwaltung und -authentifizierung Benutzerverwaltung und -authentifizierung Ende Ebene 3 Knoten Benutzerverwaltung und -authentifizierung
Anfang Ebene 4 Knoten Kennwörter von Standardbenutzern ändern Kennwörter von Standardbenutzern ändern Ende Ebene 4 Knoten Kennwörter von Standardbenutzern ändern
Anfang Ebene 4 Knoten Protokolldateien auf fehlgeschlagene Anmeldeversuche überprüfen Protokolldateien auf fehlgeschlagene Anmeldeversuche überprüfen Ende Ebene 4 Knoten Protokolldateien auf fehlgeschlagene Anmeldeversuche überprüfen
Anfang Ebene 3 Knoten Berechtigungen Berechtigungen Ende Ebene 3 Knoten Berechtigungen
Anfang Ebene 4 Knoten Klare Berechtigungen für Benutzer definieren Klare Berechtigungen für Benutzer definieren Ende Ebene 4 Knoten Klare Berechtigungen für Benutzer definieren
Anfang Ebene 3 Knoten Netzwerk- und Kommunikationssicherheit Netzwerk- und Kommunikationssicherheit Ende Ebene 3 Knoten Netzwerk- und Kommunikationssicherheit
Anfang Ebene 4 Knoten Kommunikationskanäle absichern Kommunikationskanäle absichern Ende Ebene 4 Knoten Kommunikationskanäle absichern
Anfang Ebene 4 Knoten MaxDB X-Server hinter einer Firewall verwenden MaxDB X-Server hinter einer Firewall verwenden Ende Ebene 4 Knoten MaxDB X-Server hinter einer Firewall verwenden
Anfang Ebene 4 Knoten Web Tools hinter einer Firewall verwenden Web Tools hinter einer Firewall verwenden Ende Ebene 4 Knoten Web Tools hinter einer Firewall verwenden
Anfang Ebene 3 Knoten Sicherheit der Datenablage Sicherheit der Datenablage Ende Ebene 3 Knoten Sicherheit der Datenablage
Anfang Ebene 4 Knoten Zugriffsrechte auf Datenbankressourcen einschränken (UNIX/Linux Zugriffsrechte auf Datenbankressourcen einschränken (UNIX/Linux Ende Ebene 4 Knoten Zugriffsrechte auf Datenbankressourcen einschränken (UNIX/Linux
Anfang Ebene 4 Knoten Zugriff auf Datenbankressourcen einschränken (Microsoft Windows) Zugriff auf Datenbankressourcen einschränken (Microsoft Windows) Ende Ebene 4 Knoten Zugriff auf Datenbankressourcen einschränken (Microsoft Windows)
Anfang Ebene 4 Knoten Kennwörter von SAP Standard-Betriebssystembenutzern ändern Kennwörter von SAP Standard-Betriebssystembenutzern ändern Ende Ebene 4 Knoten Kennwörter von SAP Standard-Betriebssystembenutzern ändern
Anfang Ebene 3 Knoten Überflüssige Funktionen mit Auswirkungen auf die Sicherheit Überflüssige Funktionen mit Auswirkungen auf die Sicherheit Ende Ebene 3 Knoten Überflüssige Funktionen mit Auswirkungen auf die Sicherheit
Anfang Ebene 4 Knoten MaxDB X-Server bei lokaler Kommunikation ausschalten MaxDB X-Server bei lokaler Kommunikation ausschalten Ende Ebene 4 Knoten MaxDB X-Server bei lokaler Kommunikation ausschalten
Anfang Ebene 4 Knoten MaxDB X-Server ohne NI-Unterstützung starten (UNIX/Linux) MaxDB X-Server ohne NI-Unterstützung starten (UNIX/Linux) Ende Ebene 4 Knoten MaxDB X-Server ohne NI-Unterstützung starten (UNIX/Linux)
Anfang Ebene 4 Knoten Demo-Daten entfernen Demo-Daten entfernen Ende Ebene 4 Knoten Demo-Daten entfernen
Anfang Ebene 3 Knoten Weitere sicherheitsrelevante Informationen Weitere sicherheitsrelevante Informationen Ende Ebene 3 Knoten Weitere sicherheitsrelevante Informationen
Anfang Ebene 4 Knoten Benutzereingaben in SQL-Anweisungen überprüfen Benutzereingaben in SQL-Anweisungen überprüfen Ende Ebene 4 Knoten Benutzereingaben in SQL-Anweisungen überprüfen
Anfang Ebene 3 Knoten Trace- und Protokolldateien Trace- und Protokolldateien Ende Ebene 3 Knoten Trace- und Protokolldateien
Anfang Ebene 4 Knoten Zugriff auf Protokolldateien einschränken Zugriff auf Protokolldateien einschränken Ende Ebene 4 Knoten Zugriff auf Protokolldateien einschränken
Anfang Ebene 3 Knoten Anhang Anhang Ende Ebene 3 Knoten Anhang


SAP Navigator

 Anfang des Navigationstastenbereichs
Anfang Klicken Sie hier, um das gesamte Inhaltsverzeichnis aufzuklappen Navigationtaste Alle öffnen Ende Klicken Sie hier, um das gesamte Inhaltsverzeichnis aufzuklappen Navigationtaste Anfang Klicken Sie hier, um das gesamte Inhaltsverzeichnis zuzuklappen Navigationtaste Alle schliessen Ende Klicken Sie hier, um das gesamte Inhaltsverzeichnis zuzuklappen Navigationtaste
Anfang Klicken Sie hier, um das vorhergehende Topic im Inhaltsverzeichnis anzuzeigen Navigationtaste Zurück Ende Klicken Sie hier, um das vorhergehende Topic im Inhaltsverzeichnis anzuzeigen Navigationtaste Anfang Klicken Sie hier, um das nächstes Topic im Inhaltsverzeichnis anzuzeigen Navigationtaste Vorwärts Ende Klicken Sie hier, um das nächstes Topic im Inhaltsverzeichnis anzuzeigen Navigationtaste Anfang Klicken Sie hier, um das Inhaltsverzeichnis mit dem angezeigten Topic zu synchronisieren Navigationtaste Synchronisieren Ende Klicken Sie hier, um das Inhaltsverzeichnis mit dem angezeigten Topic zu synchronisieren Navigationtaste
Ende des Navigationstastenbereichs


SAP-Bibliothek - Tutorials

 Anfang des Navigationsbaums
Anfang Ebene 1 Knoten Tutorials Tutorials Ende Ebene 1 Knoten Tutorials
Anfang Ebene 2 Knoten Tutorial Datenbankverwaltung Tutorial Datenbankverwaltung Ende Ebene 2 Knoten Tutorial Datenbankverwaltung
Anfang Ebene 3 Knoten Anlegen und Konfigurieren einer Datenbankinstanz Anlegen und Konfigurieren einer Datenbankinstanz Ende Ebene 3 Knoten Anlegen und Konfigurieren einer Datenbankinstanz
Anfang Ebene 4 Knoten Skriptdatei verwenden Skriptdatei verwenden Ende Ebene 4 Knoten Skriptdatei verwenden
Anfang Ebene 4 Knoten Parameterdatei einer anderen Datenbankinstanz verwenden Parameterdatei einer anderen Datenbankinstanz verwenden Ende Ebene 4 Knoten Parameterdatei einer anderen Datenbankinstanz verwenden
Anfang Ebene 5 Knoten Parameterdatei aus einer anderen Datenbankinstanz kopieren Parameterdatei aus einer anderen Datenbankinstanz kopieren Ende Ebene 5 Knoten Parameterdatei aus einer anderen Datenbankinstanz kopieren
Anfang Ebene 5 Knoten Parameterdatei aus einer Datensicherung kopieren Parameterdatei aus einer Datensicherung kopieren Ende Ebene 5 Knoten Parameterdatei aus einer Datensicherung kopieren
Anfang Ebene 3 Knoten Informationen über installierte Software und Datenbankinstanzen Informationen über installierte Software und Datenbankinstanzen Ende Ebene 3 Knoten Informationen über installierte Software und Datenbankinstanzen
Anfang Ebene 3 Knoten Starten und Stoppen einer Datenbankinstanz Starten und Stoppen einer Datenbankinstanz Ende Ebene 3 Knoten Starten und Stoppen einer Datenbankinstanz
Anfang Ebene 3 Knoten Löschen einer Datenbankinstanz Löschen einer Datenbankinstanz Ende Ebene 3 Knoten Löschen einer Datenbankinstanz
Anfang Ebene 3 Knoten Demo-Daten in eine Datenbankinstanz laden Demo-Daten in eine Datenbankinstanz laden Ende Ebene 3 Knoten Demo-Daten in eine Datenbankinstanz laden
Anfang Ebene 3 Knoten DBM-Benutzer anlegen DBM-Benutzer anlegen Ende Ebene 3 Knoten DBM-Benutzer anlegen
Anfang Ebene 3 Knoten Werte von Datenbankparametern ändern Werte von Datenbankparametern ändern Ende Ebene 3 Knoten Werte von Datenbankparametern ändern
Anfang Ebene 4 Knoten Wert eines einzelnen Datenbankparameters ändern Wert eines einzelnen Datenbankparameters ändern Ende Ebene 4 Knoten Wert eines einzelnen Datenbankparameters ändern
Anfang Ebene 4 Knoten Werte mehrerer Datenbankparameter ändern Werte mehrerer Datenbankparameter ändern Ende Ebene 4 Knoten Werte mehrerer Datenbankparameter ändern
Anfang Ebene 3 Knoten Vergrößern einer Datenbankinstanz Vergrößern einer Datenbankinstanz Ende Ebene 3 Knoten Vergrößern einer Datenbankinstanz
Anfang Ebene 3 Knoten Ausführen von Datenbankanweisungen Ausführen von Datenbankanweisungen Ende Ebene 3 Knoten Ausführen von Datenbankanweisungen
Anfang Ebene 4 Knoten Einzelne Datenbankanweisung ausführen Einzelne Datenbankanweisung ausführen Ende Ebene 4 Knoten Einzelne Datenbankanweisung ausführen
Anfang Ebene 4 Knoten Folge von Datenbankanweisungen ausführen Folge von Datenbankanweisungen ausführen Ende Ebene 4 Knoten Folge von Datenbankanweisungen ausführen
Anfang Ebene 3 Knoten Sicherungsvorlagen definieren Sicherungsvorlagen definieren Ende Ebene 3 Knoten Sicherungsvorlagen definieren
Anfang Ebene 4 Knoten Sicherungsvorlage für die vollständige Datensicherung in eine Da Sicherungsvorlage für die vollständige Datensicherung in eine Da Ende Ebene 4 Knoten Sicherungsvorlage für die vollständige Datensicherung in eine Da
Anfang Ebene 4 Knoten Sicherungsvorlage für die inkrementelle Datensicherung in eine D Sicherungsvorlage für die inkrementelle Datensicherung in eine D Ende Ebene 4 Knoten Sicherungsvorlage für die inkrementelle Datensicherung in eine D
Anfang Ebene 4 Knoten Sicherungsvorlage für die Log-Sicherung in eine Datei definieren Sicherungsvorlage für die Log-Sicherung in eine Datei definieren Ende Ebene 4 Knoten Sicherungsvorlage für die Log-Sicherung in eine Datei definieren
Anfang Ebene 4 Knoten Sicherungsvorlage für die Log-Sicherung in eine Pipe definieren Sicherungsvorlage für die Log-Sicherung in eine Pipe definieren Ende Ebene 4 Knoten Sicherungsvorlage für die Log-Sicherung in eine Pipe definieren
Anfang Ebene 4 Knoten Sicherungsvorlage für die vollständige Datensicherung auf ein Ba Sicherungsvorlage für die vollständige Datensicherung auf ein Ba Ende Ebene 4 Knoten Sicherungsvorlage für die vollständige Datensicherung auf ein Ba
Anfang Ebene 3 Knoten Sichern Sichern Ende Ebene 3 Knoten Sichern
Anfang Ebene 4 Knoten Vollständige Datensicherung in eine Datei durchführen Vollständige Datensicherung in eine Datei durchführen Ende Ebene 4 Knoten Vollständige Datensicherung in eine Datei durchführen
Anfang Ebene 4 Knoten Vollständige Datensicherung auf ein Band durchführen Vollständige Datensicherung auf ein Band durchführen Ende Ebene 4 Knoten Vollständige Datensicherung auf ein Band durchführen
Anfang Ebene 5 Knoten Anzeigen des Sicherungsfortschritts Anzeigen des Sicherungsfortschritts Ende Ebene 5 Knoten Anzeigen des Sicherungsfortschritts
Anfang Ebene 4 Knoten Inkrementelle Datensicherung in eine Datei durchführen Inkrementelle Datensicherung in eine Datei durchführen Ende Ebene 4 Knoten Inkrementelle Datensicherung in eine Datei durchführen
Anfang Ebene 4 Knoten Log-Sicherung in eine Pipe durchführen Log-Sicherung in eine Pipe durchführen Ende Ebene 4 Knoten Log-Sicherung in eine Pipe durchführen
Anfang Ebene 4 Knoten Automatische Log-Sicherung einschalten Automatische Log-Sicherung einschalten Ende Ebene 4 Knoten Automatische Log-Sicherung einschalten
Anfang Ebene 4 Knoten Sichern mit Sicherungswerkzeugen anderer Anbieter Sichern mit Sicherungswerkzeugen anderer Anbieter Ende Ebene 4 Knoten Sichern mit Sicherungswerkzeugen anderer Anbieter
Anfang Ebene 4 Knoten Sichern der Datenbankinstanz auf einem entfernten Rechner Sichern der Datenbankinstanz auf einem entfernten Rechner Ende Ebene 4 Knoten Sichern der Datenbankinstanz auf einem entfernten Rechner
Anfang Ebene 3 Knoten Log automatisch sichern nach Event LOGABOVELIMIT Log automatisch sichern nach Event LOGABOVELIMIT Ende Ebene 3 Knoten Log automatisch sichern nach Event LOGABOVELIMIT
Anfang Ebene 3 Knoten Event DATABASEFULL über Microsoft Windows Event Viewer anzeigen Event DATABASEFULL über Microsoft Windows Event Viewer anzeigen Ende Ebene 3 Knoten Event DATABASEFULL über Microsoft Windows Event Viewer anzeigen
Anfang Ebene 3 Knoten Restart-Information und Sicherungshistorie für das Einlesen von Restart-Information und Sicherungshistorie für das Einlesen von Ende Ebene 3 Knoten Restart-Information und Sicherungshistorie für das Einlesen von
Anfang Ebene 3 Knoten Wiederherstellen der Datenbankinstanz Wiederherstellen der Datenbankinstanz Ende Ebene 3 Knoten Wiederherstellen der Datenbankinstanz
Anfang Ebene 4 Knoten Einlesen der Log-Sicherungen bis zu einem bestimmten Zeitpunkt ( Einlesen der Log-Sicherungen bis zu einem bestimmten Zeitpunkt ( Ende Ebene 4 Knoten Einlesen der Log-Sicherungen bis zu einem bestimmten Zeitpunkt (
Anfang Ebene 3 Knoten Datenbankkopie erstellen (Datensicherung in eine andere Datenban Datenbankkopie erstellen (Datensicherung in eine andere Datenban Ende Ebene 3 Knoten Datenbankkopie erstellen (Datensicherung in eine andere Datenban
Anfang Ebene 3 Knoten Schatteninstanz einrichten und aktualisieren Schatteninstanz einrichten und aktualisieren Ende Ebene 3 Knoten Schatteninstanz einrichten und aktualisieren
Anfang Ebene 4 Knoten Schatteninstanz als aktive Instanz in Betrieb nehmen Schatteninstanz als aktive Instanz in Betrieb nehmen Ende Ebene 4 Knoten Schatteninstanz als aktive Instanz in Betrieb nehmen
Anfang Ebene 4 Knoten Log-Volumes mit Betriebssystemmitteln kopieren und Schatteninsta Log-Volumes mit Betriebssystemmitteln kopieren und Schatteninsta Ende Ebene 4 Knoten Log-Volumes mit Betriebssystemmitteln kopieren und Schatteninsta
Anfang Ebene 3 Knoten Hot-Standby-System einrichten Hot-Standby-System einrichten Ende Ebene 3 Knoten Hot-Standby-System einrichten
Anfang Ebene 3 Knoten Betriebsmodi im Database Manager CLI Betriebsmodi im Database Manager CLI Ende Ebene 3 Knoten Betriebsmodi im Database Manager CLI
Anfang Ebene 4 Knoten Kommandomodus verwenden Kommandomodus verwenden Ende Ebene 4 Knoten Kommandomodus verwenden
Anfang Ebene 4 Knoten Sitzungsmodus verwenden Sitzungsmodus verwenden Ende Ebene 4 Knoten Sitzungsmodus verwenden
Anfang Ebene 4 Knoten Skriptmodus verwenden Skriptmodus verwenden Ende Ebene 4 Knoten Skriptmodus verwenden
Anfang Ebene 2 Knoten SQL-Tutorial SQL-Tutorial Ende Ebene 2 Knoten SQL-Tutorial
Anfang Ebene 3 Knoten Demo-Daten für das SQL-Tutorial Demo-Daten für das SQL-Tutorial Ende Ebene 3 Knoten Demo-Daten für das SQL-Tutorial
Anfang Ebene 4 Knoten SQL-Anweisungen für das Demo-Schema HOTEL SQL-Anweisungen für das Demo-Schema HOTEL Ende Ebene 4 Knoten SQL-Anweisungen für das Demo-Schema HOTEL
Anfang Ebene 4 Knoten Erläuterung der Tabellen im Demo-Schema HOTEL Erläuterung der Tabellen im Demo-Schema HOTEL Ende Ebene 4 Knoten Erläuterung der Tabellen im Demo-Schema HOTEL
Anfang Ebene 3 Knoten Datenanfrage Datenanfrage Ende Ebene 3 Knoten Datenanfrage
Anfang Ebene 4 Knoten Auswählen, Anordnen und Umbenennen von Spalten Auswählen, Anordnen und Umbenennen von Spalten Ende Ebene 4 Knoten Auswählen, Anordnen und Umbenennen von Spalten
Anfang Ebene 4 Knoten Auswählen und Anordnen von Zeilen Auswählen und Anordnen von Zeilen Ende Ebene 4 Knoten Auswählen und Anordnen von Zeilen
Anfang Ebene 4 Knoten Bedingungen: Vergleich, AND, OR, BETWEEN, IN Bedingungen: Vergleich, AND, OR, BETWEEN, IN Ende Ebene 4 Knoten Bedingungen: Vergleich, AND, OR, BETWEEN, IN
Anfang Ebene 4 Knoten Suchen nach Zeichenketten: LIKE Suchen nach Zeichenketten: LIKE Ende Ebene 4 Knoten Suchen nach Zeichenketten: LIKE
Anfang Ebene 4 Knoten Negative Bedingungen: NOT Negative Bedingungen: NOT Ende Ebene 4 Knoten Negative Bedingungen: NOT
Anfang Ebene 4 Knoten Bilden von Gruppen: GROUP BY, HAVING Bilden von Gruppen: GROUP BY, HAVING Ende Ebene 4 Knoten Bilden von Gruppen: GROUP BY, HAVING
Anfang Ebene 4 Knoten Arithmetische Operationen Arithmetische Operationen Ende Ebene 4 Knoten Arithmetische Operationen
Anfang Ebene 4 Knoten Funktionen Funktionen Ende Ebene 4 Knoten Funktionen
Anfang Ebene 4 Knoten Set-Funktionen Set-Funktionen Ende Ebene 4 Knoten Set-Funktionen
Anfang Ebene 4 Knoten Datums- und Zeitberechnungen Datums- und Zeitberechnungen Ende Ebene 4 Knoten Datums- und Zeitberechnungen
Anfang Ebene 4 Knoten Umwandeln von Werten Umwandeln von Werten Ende Ebene 4 Knoten Umwandeln von Werten
Anfang Ebene 4 Knoten Verändern von Zeichenketten Verändern von Zeichenketten Ende Ebene 4 Knoten Verändern von Zeichenketten
Anfang Ebene 4 Knoten Informationen über Zeichenketten Informationen über Zeichenketten Ende Ebene 4 Knoten Informationen über Zeichenketten
Anfang Ebene 4 Knoten Subquery: Innere Abfragen Subquery: Innere Abfragen Ende Ebene 4 Knoten Subquery: Innere Abfragen
Anfang Ebene 4 Knoten Joins: Informationen aus mehreren Tabellen Joins: Informationen aus mehreren Tabellen Ende Ebene 4 Knoten Joins: Informationen aus mehreren Tabellen
Anfang Ebene 4 Knoten Mengenoperationen: UNION, INTERSECT, EXCEPT Mengenoperationen: UNION, INTERSECT, EXCEPT Ende Ebene 4 Knoten Mengenoperationen: UNION, INTERSECT, EXCEPT
Anfang Ebene 3 Knoten Datendefinition Datendefinition Ende Ebene 3 Knoten Datendefinition
Anfang Ebene 4 Knoten Tabellen Tabellen Ende Ebene 4 Knoten Tabellen
Anfang Ebene 4 Knoten Constraints Constraints Ende Ebene 4 Knoten Constraints
Anfang Ebene 4 Knoten Primärschlüssel Primärschlüssel Ende Ebene 4 Knoten Primärschlüssel
Anfang Ebene 4 Knoten Fremdschlüsselbeziehungen zwischen Tabellen Fremdschlüsselbeziehungen zwischen Tabellen Ende Ebene 4 Knoten Fremdschlüsselbeziehungen zwischen Tabellen
Anfang Ebene 4 Knoten View-Tabellen View-Tabellen Ende Ebene 4 Knoten View-Tabellen
Anfang Ebene 4 Knoten Indizes Indizes Ende Ebene 4 Knoten Indizes
Anfang Ebene 4 Knoten Wertebereiche Wertebereiche Ende Ebene 4 Knoten Wertebereiche
Anfang Ebene 4 Knoten Datenbankprozeduren Datenbankprozeduren Ende Ebene 4 Knoten Datenbankprozeduren
Anfang Ebene 4 Knoten Datenbankfunktionen Datenbankfunktionen Ende Ebene 4 Knoten Datenbankfunktionen
Anfang Ebene 4 Knoten Datenbanktrigger Datenbanktrigger Ende Ebene 4 Knoten Datenbanktrigger
Anfang Ebene 4 Knoten Nummerngeneratoren für Tabellen Nummerngeneratoren für Tabellen Ende Ebene 4 Knoten Nummerngeneratoren für Tabellen
Anfang Ebene 4 Knoten Nummerngenerator für eine einzelne Spalte einer Tabelle Nummerngenerator für eine einzelne Spalte einer Tabelle Ende Ebene 4 Knoten Nummerngenerator für eine einzelne Spalte einer Tabelle
Anfang Ebene 3 Knoten Datenmanipulation Datenmanipulation Ende Ebene 3 Knoten Datenmanipulation
Anfang Ebene 4 Knoten Einfügen, Ändern, Löschen von Zeilen Einfügen, Ändern, Löschen von Zeilen Ende Ebene 4 Knoten Einfügen, Ändern, Löschen von Zeilen
Anfang Ebene 3 Knoten Autorisierung Autorisierung Ende Ebene 3 Knoten Autorisierung
Anfang Ebene 4 Knoten Datenbankbenutzer und ihre Privilegien Datenbankbenutzer und ihre Privilegien Ende Ebene 4 Knoten Datenbankbenutzer und ihre Privilegien
Anfang Ebene 4 Knoten Rollen Rollen Ende Ebene 4 Knoten Rollen
Anfang Ebene 3 Knoten Systemtabellen auswerten (Beispiele) Systemtabellen auswerten (Beispiele) Ende Ebene 3 Knoten Systemtabellen auswerten (Beispiele)
Anfang Ebene 2 Knoten Loader-Tutorial Loader-Tutorial Ende Ebene 2 Knoten Loader-Tutorial
Anfang Ebene 3 Knoten Demo-Datenbanken DEMODB und TESTDB Demo-Datenbanken DEMODB und TESTDB Ende Ebene 3 Knoten Demo-Datenbanken DEMODB und TESTDB
Anfang Ebene 3 Knoten Exportieren Exportieren Ende Ebene 3 Knoten Exportieren
Anfang Ebene 4 Knoten EXPORT DB EXPORT DB Ende Ebene 4 Knoten EXPORT DB
Anfang Ebene 4 Knoten EXPORT USER EXPORT USER Ende Ebene 4 Knoten EXPORT USER
Anfang Ebene 4 Knoten EXPORT SCHEMA EXPORT SCHEMA Ende Ebene 4 Knoten EXPORT SCHEMA
Anfang Ebene 4 Knoten EXPORT TABLE EXPORT TABLE Ende Ebene 4 Knoten EXPORT TABLE
Anfang Ebene 4 Knoten EXPORT COLUMNS EXPORT COLUMNS Ende Ebene 4 Knoten EXPORT COLUMNS
Anfang Ebene 3 Knoten Importieren Importieren Ende Ebene 3 Knoten Importieren
Anfang Ebene 4 Knoten IMPORT DB IMPORT DB Ende Ebene 4 Knoten IMPORT DB
Anfang Ebene 4 Knoten IMPORT USER IMPORT USER Ende Ebene 4 Knoten IMPORT USER
Anfang Ebene 4 Knoten IMPORT SCHEMA IMPORT SCHEMA Ende Ebene 4 Knoten IMPORT SCHEMA
Anfang Ebene 4 Knoten IMPORT TABLE IMPORT TABLE Ende Ebene 4 Knoten IMPORT TABLE
Anfang Ebene 4 Knoten IMPORT COLUMNS IMPORT COLUMNS Ende Ebene 4 Knoten IMPORT COLUMNS
Anfang Ebene 3 Knoten UPDATE COLUMNS UPDATE COLUMNS Ende Ebene 3 Knoten UPDATE COLUMNS
Anfang Ebene 3 Knoten Transportmodus Transportmodus Ende Ebene 3 Knoten Transportmodus
Anfang Ebene 4 Knoten Transport Transport Ende Ebene 4 Knoten Transport
Anfang Ebene 4 Knoten Export Export Ende Ebene 4 Knoten Export
Anfang Ebene 4 Knoten Import Import Ende Ebene 4 Knoten Import
Anfang Ebene 3 Knoten Kommandodateimodus Kommandodateimodus Ende Ebene 3 Knoten Kommandodateimodus
Anfang Ebene 3 Knoten Sitzungsmodus Sitzungsmodus Ende Ebene 3 Knoten Sitzungsmodus


SAP-Bibliothek - Schnittstellen

 Anfang des Navigationsbaums
Anfang Ebene 1 Knoten Schnittstellen Schnittstellen Ende Ebene 1 Knoten Schnittstellen
Anfang Ebene 2 Knoten ODBC-Handbuch ODBC-Handbuch Ende Ebene 2 Knoten ODBC-Handbuch
Anfang Ebene 3 Knoten Eigenschaften des MaxDB-ODBC-Treibers Eigenschaften des MaxDB-ODBC-Treibers Ende Ebene 3 Knoten Eigenschaften des MaxDB-ODBC-Treibers
Anfang Ebene 4 Knoten ODBC-API-Kompatibilität ODBC-API-Kompatibilität Ende Ebene 4 Knoten ODBC-API-Kompatibilität
Anfang Ebene 5 Knoten Kern-API Kern-API Ende Ebene 5 Knoten Kern-API
Anfang Ebene 5 Knoten Level-1-API Level-1-API Ende Ebene 5 Knoten Level-1-API
Anfang Ebene 6 Knoten Anmerkung zu SQLGetConnectAttr Anmerkung zu SQLGetConnectAttr Ende Ebene 6 Knoten Anmerkung zu SQLGetConnectAttr
Anfang Ebene 6 Knoten Anmerkung zu SQLGetFunctions Anmerkung zu SQLGetFunctions Ende Ebene 6 Knoten Anmerkung zu SQLGetFunctions
Anfang Ebene 6 Knoten Anmerkung zu SQLGetInfo Anmerkung zu SQLGetInfo Ende Ebene 6 Knoten Anmerkung zu SQLGetInfo
Anfang Ebene 5 Knoten Level-2-API Level-2-API Ende Ebene 5 Knoten Level-2-API
Anfang Ebene 4 Knoten Unterstützte Datentypen Unterstützte Datentypen Ende Ebene 4 Knoten Unterstützte Datentypen
Anfang Ebene 4 Knoten Unicode-Unterstützung Unicode-Unterstützung Ende Ebene 4 Knoten Unicode-Unterstützung
Anfang Ebene 3 Knoten MaxDB-ODBC-Treiber verwenden MaxDB-ODBC-Treiber verwenden Ende Ebene 3 Knoten MaxDB-ODBC-Treiber verwenden
Anfang Ebene 3 Knoten Datenquelle anlegen/ändern Datenquelle anlegen/ändern Ende Ebene 3 Knoten Datenquelle anlegen/ändern
Anfang Ebene 4 Knoten Eigenschaften von Datenquellen Eigenschaften von Datenquellen Ende Ebene 4 Knoten Eigenschaften von Datenquellen
Anfang Ebene 2 Knoten SQLDBC-Handbuch SQLDBC-Handbuch Ende Ebene 2 Knoten SQLDBC-Handbuch
Anfang Ebene 3 Knoten Aufbau von SQLDBC Aufbau von SQLDBC Ende Ebene 3 Knoten Aufbau von SQLDBC
Anfang Ebene 3 Knoten SQLDBC-Klassen SQLDBC-Klassen Ende Ebene 3 Knoten SQLDBC-Klassen
Anfang Ebene 3 Knoten SQLDBC-Traces SQLDBC-Traces Ende Ebene 3 Knoten SQLDBC-Traces
Anfang Ebene 3 Knoten sqldbc_cons sqldbc_cons Ende Ebene 3 Knoten sqldbc_cons
Anfang Ebene 2 Knoten Java-Handbuch Java-Handbuch Ende Ebene 2 Knoten Java-Handbuch
Anfang Ebene 3 Knoten Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzufügen Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzufügen Ende Ebene 3 Knoten Pfad von sapdbc.jar zur Umgebungsvariablen CLASSPATH hinzufügen
Anfang Ebene 3 Knoten JDBC-Treiber JDBC-Treiber Ende Ebene 3 Knoten JDBC-Treiber
Anfang Ebene 4 Knoten JDBC-Treiber laden JDBC-Treiber laden Ende Ebene 4 Knoten JDBC-Treiber laden
Anfang Ebene 4 Knoten Mit der Datenbankinstanz verbinden Mit der Datenbankinstanz verbinden Ende Ebene 4 Knoten Mit der Datenbankinstanz verbinden
Anfang Ebene 5 Knoten Methode java.sql.DriverManager.getConnection Methode java.sql.DriverManager.getConnection Ende Ebene 5 Knoten Methode java.sql.DriverManager.getConnection
Anfang Ebene 5 Knoten Klasse com.sap.dbtech.jdbcext.DataSourceSapDB Klasse com.sap.dbtech.jdbcext.DataSourceSapDB Ende Ebene 5 Knoten Klasse com.sap.dbtech.jdbcext.DataSourceSapDB
Anfang Ebene 5 Knoten Verbindungs-URL Verbindungs-URL Ende Ebene 5 Knoten Verbindungs-URL
Anfang Ebene 5 Knoten SSL-Verbindung einrichten SSL-Verbindung einrichten Ende Ebene 5 Knoten SSL-Verbindung einrichten
Anfang Ebene 5 Knoten Beispiele: Mit der Datenbankinstanz verbinden Beispiele: Mit der Datenbankinstanz verbinden Ende Ebene 5 Knoten Beispiele: Mit der Datenbankinstanz verbinden
Anfang Ebene 4 Knoten SQL-Anweisungen ausführen SQL-Anweisungen ausführen Ende Ebene 4 Knoten SQL-Anweisungen ausführen
Anfang Ebene 4 Knoten Fehlerbehandlung (JDBC-Treiber) Fehlerbehandlung (JDBC-Treiber) Ende Ebene 4 Knoten Fehlerbehandlung (JDBC-Treiber)
Anfang Ebene 4 Knoten Beispiel: HelloMaxDB Beispiel: HelloMaxDB Ende Ebene 4 Knoten Beispiel: HelloMaxDB
Anfang Ebene 3 Knoten Database Manager-Java-Klassen Database Manager-Java-Klassen Ende Ebene 3 Knoten Database Manager-Java-Klassen
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.dbrootDBM Methode com.sap.dbtech.powertoys.DBM.dbrootDBM Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.dbrootDBM
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.dbDBM Methode com.sap.dbtech.powertoys.DBM.dbDBM Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.dbDBM
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.cmd Methode com.sap.dbtech.powertoys.DBM.cmd Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.cmd
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.cancel Methode com.sap.dbtech.powertoys.DBM.cancel Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.cancel
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.release Methode com.sap.dbtech.powertoys.DBM.release Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.DBM.release
Anfang Ebene 4 Knoten Fehlerbehandlung (Database Manager) Fehlerbehandlung (Database Manager) Ende Ebene 4 Knoten Fehlerbehandlung (Database Manager)
Anfang Ebene 4 Knoten Beispiel: Betriebszustand der Datenbankinstanz anzeigen Beispiel: Betriebszustand der Datenbankinstanz anzeigen Ende Ebene 4 Knoten Beispiel: Betriebszustand der Datenbankinstanz anzeigen
Anfang Ebene 3 Knoten Loader-Java-Klassen Loader-Java-Klassen Ende Ebene 3 Knoten Loader-Java-Klassen
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.Loader.dbLoader Methode com.sap.dbtech.powertoys.Loader.dbLoader Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.Loader.dbLoader
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.Loader.cmd Methode com.sap.dbtech.powertoys.Loader.cmd Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.Loader.cmd
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.Loader.cancel Methode com.sap.dbtech.powertoys.Loader.cancel Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.Loader.cancel
Anfang Ebene 4 Knoten Methode com.sap.dbtech.powertoys.Loader.release Methode com.sap.dbtech.powertoys.Loader.release Ende Ebene 4 Knoten Methode com.sap.dbtech.powertoys.Loader.release
Anfang Ebene 4 Knoten Fehlerbehandlung (Loader) Fehlerbehandlung (Loader) Ende Ebene 4 Knoten Fehlerbehandlung (Loader)
Anfang Ebene 4 Knoten Beispiel: Tabelle exportieren Beispiel: Tabelle exportieren Ende Ebene 4 Knoten Beispiel: Tabelle exportieren
Anfang Ebene 2 Knoten Perl-Handbuch Perl-Handbuch Ende Ebene 2 Knoten Perl-Handbuch
Anfang Ebene 3 Knoten Konfiguration der Perl-Module Konfiguration der Perl-Module Ende Ebene 3 Knoten Konfiguration der Perl-Module
Anfang Ebene 3 Knoten Modul SAP::DBTech::dbm Modul SAP::DBTech::dbm Ende Ebene 3 Knoten Modul SAP::DBTech::dbm
Anfang Ebene 4 Knoten Klasse DBM Klasse DBM Ende Ebene 4 Knoten Klasse DBM
Anfang Ebene 5 Knoten Methode cmd Methode cmd Ende Ebene 5 Knoten Methode cmd
Anfang Ebene 5 Knoten Methode rawCmd Methode rawCmd Ende Ebene 5 Knoten Methode rawCmd
Anfang Ebene 5 Knoten Methode release Methode release Ende Ebene 5 Knoten Methode release
Anfang Ebene 4 Knoten Fehlerbehandlung für das Modul SAP::DBTech::dbm Fehlerbehandlung für das Modul SAP::DBTech::dbm Ende Ebene 4 Knoten Fehlerbehandlung für das Modul SAP::DBTech::dbm
Anfang Ebene 5 Knoten Ausnahme CommunicationError Ausnahme CommunicationError Ende Ebene 5 Knoten Ausnahme CommunicationError
Anfang Ebene 5 Knoten Ausnahme DBMServError Ausnahme DBMServError Ende Ebene 5 Knoten Ausnahme DBMServError
Anfang Ebene 4 Knoten Beispiele für das Modul SAP::DBTech::dbm Beispiele für das Modul SAP::DBTech::dbm Ende Ebene 4 Knoten Beispiele für das Modul SAP::DBTech::dbm
Anfang Ebene 3 Knoten Modul SAP::DBTech::loader Modul SAP::DBTech::loader Ende Ebene 3 Knoten Modul SAP::DBTech::loader
Anfang Ebene 4 Knoten Klasse Loader Klasse Loader Ende Ebene 4 Knoten Klasse Loader
Anfang Ebene 5 Knoten Methode cmd Methode cmd Ende Ebene 5 Knoten Methode cmd
Anfang Ebene 5 Knoten Methode rawCmd Methode rawCmd Ende Ebene 5 Knoten Methode rawCmd
Anfang Ebene 5 Knoten Methode sql Methode sql Ende Ebene 5 Knoten Methode sql
Anfang Ebene 5 Knoten Methode release Methode release Ende Ebene 5 Knoten Methode release
Anfang Ebene 4 Knoten Fehlerbehandlung für das Modul SAP::DBTech::loader Fehlerbehandlung für das Modul SAP::DBTech::loader Ende Ebene 4 Knoten Fehlerbehandlung für das Modul SAP::DBTech::loader
Anfang Ebene 5 Knoten Ausnahme CommunicationError Ausnahme CommunicationError Ende Ebene 5 Knoten Ausnahme CommunicationError
Anfang Ebene 5 Knoten Ausnahme LoaderError Ausnahme LoaderError Ende Ebene 5 Knoten Ausnahme LoaderError
Anfang Ebene 4 Knoten Beispiele für das Modul SAP::DBTech::loader Beispiele für das Modul SAP::DBTech::loader Ende Ebene 4 Knoten Beispiele für das Modul SAP::DBTech::loader
Anfang Ebene 2 Knoten Python-Handbuch Python-Handbuch Ende Ebene 2 Knoten Python-Handbuch
Anfang Ebene 3 Knoten Konfiguration der Python-Module Konfiguration der Python-Module Ende Ebene 3 Knoten Konfiguration der Python-Module
Anfang Ebene 3 Knoten Modul sdb.dbapi Modul sdb.dbapi Ende Ebene 3 Knoten Modul sdb.dbapi
Anfang Ebene 4 Knoten Methode connect Methode connect Ende Ebene 4 Knoten Methode connect
Anfang Ebene 4 Knoten Konvertierung von Datums- und Zeitwerten Konvertierung von Datums- und Zeitwerten Ende Ebene 4 Knoten Konvertierung von Datums- und Zeitwerten
Anfang Ebene 4 Knoten Konvertierung von LOB-Werten Konvertierung von LOB-Werten Ende Ebene 4 Knoten Konvertierung von LOB-Werten
Anfang Ebene 3 Knoten Modul sdb.sql Modul sdb.sql Ende Ebene 3 Knoten Modul sdb.sql
Anfang Ebene 4 Knoten Methode connect Methode connect Ende Ebene 4 Knoten Methode connect
Anfang Ebene 4 Knoten Klasse SapDB_Session Klasse SapDB_Session Ende Ebene 4 Knoten Klasse SapDB_Session
Anfang Ebene 5 Knoten Methode sql Methode sql Ende Ebene 5 Knoten Methode sql
Anfang Ebene 5 Knoten Methode sqlX Methode sqlX Ende Ebene 5 Knoten Methode sqlX
Anfang Ebene 5 Knoten Methode prepare Methode prepare Ende Ebene 5 Knoten Methode prepare
Anfang Ebene 5 Knoten Methode release Methode release Ende Ebene 5 Knoten Methode release
Anfang Ebene 5 Knoten Methode commit Methode commit Ende Ebene 5 Knoten Methode commit
Anfang Ebene 5 Knoten Methode rollback Methode rollback Ende Ebene 5 Knoten Methode rollback
Anfang Ebene 4 Knoten Klasse SapDB_ResultSet Klasse SapDB_ResultSet Ende Ebene 4 Knoten Klasse SapDB_ResultSet
Anfang Ebene 5 Knoten Methode next Methode next Ende Ebene 5 Knoten Methode next
Anfang Ebene 5 Knoten Methode previous Methode previous Ende Ebene 5 Knoten Methode previous
Anfang Ebene 5 Knoten Methode relative Methode relative Ende Ebene 5 Knoten Methode relative
Anfang Ebene 5 Knoten Methode absolute Methode absolute Ende Ebene 5 Knoten Methode absolute
Anfang Ebene 5 Knoten Methode first Methode first Ende Ebene 5 Knoten Methode first
Anfang Ebene 5 Knoten Methode last Methode last Ende Ebene 5 Knoten Methode last
Anfang Ebene 5 Knoten Methode current Methode current Ende Ebene 5 Knoten Methode current
Anfang Ebene 5 Knoten Methode __getitem__ Methode __getitem__ Ende Ebene 5 Knoten Methode __getitem__
Anfang Ebene 5 Knoten Methode getDescription Methode getDescription Ende Ebene 5 Knoten Methode getDescription
Anfang Ebene 4 Knoten Klasse SapDB_Prepared Klasse SapDB_Prepared Ende Ebene 4 Knoten Klasse SapDB_Prepared
Anfang Ebene 5 Knoten Methode execute Methode execute Ende Ebene 5 Knoten Methode execute
Anfang Ebene 5 Knoten Methode getDescription Methode getDescription Ende Ebene 5 Knoten Methode getDescription
Anfang Ebene 4 Knoten Klasse SapDB_Result Klasse SapDB_Result Ende Ebene 4 Knoten Klasse SapDB_Result
Anfang Ebene 5 Knoten Methode getResultSet Methode getResultSet Ende Ebene 5 Knoten Methode getResultSet
Anfang Ebene 5 Knoten Methode getOutputParameters Methode getOutputParameters Ende Ebene 5 Knoten Methode getOutputParameters
Anfang Ebene 5 Knoten Methode getRowsAffected Methode getRowsAffected Ende Ebene 5 Knoten Methode getRowsAffected
Anfang Ebene 5 Knoten Methode getLastSerial Methode getLastSerial Ende Ebene 5 Knoten Methode getLastSerial
Anfang Ebene 5 Knoten Methode getFirstSerial Methode getFirstSerial Ende Ebene 5 Knoten Methode getFirstSerial
Anfang Ebene 4 Knoten Klasse SapDB_LongReader Klasse SapDB_LongReader Ende Ebene 4 Knoten Klasse SapDB_LongReader
Anfang Ebene 5 Knoten Methode read Methode read Ende Ebene 5 Knoten Methode read
Anfang Ebene 4 Knoten Fehlerbehandlung für das Modul sdb.sql Fehlerbehandlung für das Modul sdb.sql Ende Ebene 4 Knoten Fehlerbehandlung für das Modul sdb.sql
Anfang Ebene 5 Knoten Klasse CommunicationError Klasse CommunicationError Ende Ebene 5 Knoten Klasse CommunicationError
Anfang Ebene 5 Knoten Klasse SQLError Klasse SQLError Ende Ebene 5 Knoten Klasse SQLError
Anfang Ebene 4 Knoten Mögliche SQL-Ergebnisse Mögliche SQL-Ergebnisse Ende Ebene 4 Knoten Mögliche SQL-Ergebnisse
Anfang Ebene 4 Knoten Beispiele für das Modul sdb.sql Beispiele für das Modul sdb.sql Ende Ebene 4 Knoten Beispiele für das Modul sdb.sql
Anfang Ebene 5 Knoten Verbindung zur Datenbankinstanz herstellen und beenden Verbindung zur Datenbankinstanz herstellen und beenden Ende Ebene 5 Knoten Verbindung zur Datenbankinstanz herstellen und beenden
Anfang Ebene 5 Knoten SQL-Anweisung ausführen und Ergebnismenge auslesen SQL-Anweisung ausführen und Ergebnismenge auslesen Ende Ebene 5 Knoten SQL-Anweisung ausführen und Ergebnismenge auslesen
Anfang Ebene 5 Knoten SQL-Anweisung ausführen und in der Ergebnismenge navigieren SQL-Anweisung ausführen und in der Ergebnismenge navigieren Ende Ebene 5 Knoten SQL-Anweisung ausführen und in der Ergebnismenge navigieren
Anfang Ebene 5 Knoten SQL-Anweisung ausführen und Ergebnismenge mit einer for-Schleife SQL-Anweisung ausführen und Ergebnismenge mit einer for-Schleife Ende Ebene 5 Knoten SQL-Anweisung ausführen und Ergebnismenge mit einer for-Schleife
Anfang Ebene 5 Knoten SQL-Anweisung ausführen und Informationen zur Ergebnismenge abfr SQL-Anweisung ausführen und Informationen zur Ergebnismenge abfr Ende Ebene 5 Knoten SQL-Anweisung ausführen und Informationen zur Ergebnismenge abfr
Anfang Ebene 5 Knoten SQL-Anweisung mehrfach mit verschiedenen Werten ausführen SQL-Anweisung mehrfach mit verschiedenen Werten ausführen Ende Ebene 5 Knoten SQL-Anweisung mehrfach mit verschiedenen Werten ausführen
Anfang Ebene 5 Knoten SQL-Anweisung ausführen und Fehler behandeln SQL-Anweisung ausführen und Fehler behandeln Ende Ebene 5 Knoten SQL-Anweisung ausführen und Fehler behandeln
Anfang Ebene 3 Knoten Modul sdb.dbm Modul sdb.dbm Ende Ebene 3 Knoten Modul sdb.dbm
Anfang Ebene 4 Knoten Klasse DBM Klasse DBM Ende Ebene 4 Knoten Klasse DBM
Anfang Ebene 5 Knoten Methode cmd Methode cmd Ende Ebene 5 Knoten Methode cmd
Anfang Ebene 5 Knoten Methode rawCmd Methode rawCmd Ende Ebene 5 Knoten Methode rawCmd
Anfang Ebene 5 Knoten Methode release Methode release Ende Ebene 5 Knoten Methode release
Anfang Ebene 4 Knoten Fehlerbehandlung für das Modul sdb.dbm Fehlerbehandlung für das Modul sdb.dbm Ende Ebene 4 Knoten Fehlerbehandlung für das Modul sdb.dbm
Anfang Ebene 5 Knoten Klasse CommunicationError Klasse CommunicationError Ende Ebene 5 Knoten Klasse CommunicationError
Anfang Ebene 5 Knoten Klasse DBMServError Klasse DBMServError Ende Ebene 5 Knoten Klasse DBMServError
Anfang Ebene 4 Knoten Beispiele für das Modul sdb.dbm Beispiele für das Modul sdb.dbm Ende Ebene 4 Knoten Beispiele für das Modul sdb.dbm
Anfang Ebene 5 Knoten Database Manager aufrufen und beenden Database Manager aufrufen und beenden Ende Ebene 5 Knoten Database Manager aufrufen und beenden
Anfang Ebene 5 Knoten DBM-Kommando ausführen DBM-Kommando ausführen Ende Ebene 5 Knoten DBM-Kommando ausführen
Anfang Ebene 5 Knoten DBM-Kommando ausführen und Fehler behandeln DBM-Kommando ausführen und Fehler behandeln Ende Ebene 5 Knoten DBM-Kommando ausführen und Fehler behandeln
Anfang Ebene 3 Knoten Modul sdb.loader Modul sdb.loader Ende Ebene 3 Knoten Modul sdb.loader
Anfang Ebene 4 Knoten Klasse Loader Klasse Loader Ende Ebene 4 Knoten Klasse Loader
Anfang Ebene 5 Knoten Methode cmd Methode cmd Ende Ebene 5 Knoten Methode cmd
Anfang Ebene 5 Knoten Methode rawCmd Methode rawCmd Ende Ebene 5 Knoten Methode rawCmd
Anfang Ebene 5 Knoten Methode sql Methode sql Ende Ebene 5 Knoten Methode sql
Anfang Ebene 5 Knoten Methode release Methode release Ende Ebene 5 Knoten Methode release
Anfang Ebene 4 Knoten Fehlerbehandlung für das Modul sdb.loader Fehlerbehandlung für das Modul sdb.loader Ende Ebene 4 Knoten Fehlerbehandlung für das Modul sdb.loader
Anfang Ebene 5 Knoten Klasse CommunicationError Klasse CommunicationError Ende Ebene 5 Knoten Klasse CommunicationError
Anfang Ebene 5 Knoten Klasse LoaderError Klasse LoaderError Ende Ebene 5 Knoten Klasse LoaderError
Anfang Ebene 4 Knoten Beispiele für das Modul sdb.loader Beispiele für das Modul sdb.loader Ende Ebene 4 Knoten Beispiele für das Modul sdb.loader
Anfang Ebene 5 Knoten An eine Datenbankinstanz anmelden An eine Datenbankinstanz anmelden Ende Ebene 5 Knoten An eine Datenbankinstanz anmelden
Anfang Ebene 5 Knoten Abfrage, ob eine Tabelle existiert Abfrage, ob eine Tabelle existiert Ende Ebene 5 Knoten Abfrage, ob eine Tabelle existiert
Anfang Ebene 5 Knoten Tabelle exportieren Tabelle exportieren Ende Ebene 5 Knoten Tabelle exportieren
Anfang Ebene 2 Knoten PHP-Handbuch PHP-Handbuch Ende Ebene 2 Knoten PHP-Handbuch
Anfang Ebene 2 Knoten WebDAV WebDAV Ende Ebene 2 Knoten WebDAV
Anfang Ebene 3 Knoten WebDAV-Servlet aufrufen WebDAV-Servlet aufrufen Ende Ebene 3 Knoten WebDAV-Servlet aufrufen
Anfang Ebene 2 Knoten Backint for MaxDB Backint for MaxDB Ende Ebene 2 Knoten Backint for MaxDB
Anfang Ebene 3 Knoten Sichern und Wiederherstellen mit MaxDB-Programmen Sichern und Wiederherstellen mit MaxDB-Programmen Ende Ebene 3 Knoten Sichern und Wiederherstellen mit MaxDB-Programmen
Anfang Ebene 3 Knoten Sichern und Wiederherstellen mit externen Sicherungsprogrammen Sichern und Wiederherstellen mit externen Sicherungsprogrammen Ende Ebene 3 Knoten Sichern und Wiederherstellen mit externen Sicherungsprogrammen
Anfang Ebene 3 Knoten Funktionsbeschreibung für Backint for MaxDB Funktionsbeschreibung für Backint for MaxDB Ende Ebene 3 Knoten Funktionsbeschreibung für Backint for MaxDB
Anfang Ebene 4 Knoten Sicherungsfunktion (backup) Sicherungsfunktion (backup) Ende Ebene 4 Knoten Sicherungsfunktion (backup)
Anfang Ebene 4 Knoten Wiederherstellungsfunktion (restore) Wiederherstellungsfunktion (restore) Ende Ebene 4 Knoten Wiederherstellungsfunktion (restore)
Anfang Ebene 4 Knoten Auskunftsfunktion (inquire) Auskunftsfunktion (inquire) Ende Ebene 4 Knoten Auskunftsfunktion (inquire)
Anfang Ebene 4 Knoten Löschfunktion (delete) Löschfunktion (delete) Ende Ebene 4 Knoten Löschfunktion (delete)
Anfang Ebene 3 Knoten Programmdefinition für Backint for MaxDB Programmdefinition für Backint for MaxDB Ende Ebene 3 Knoten Programmdefinition für Backint for MaxDB
Anfang Ebene 4 Knoten Aufruf von Backint for MaxDB Aufruf von Backint for MaxDB Ende Ebene 4 Knoten Aufruf von Backint for MaxDB
Anfang Ebene 5 Knoten Optionen Optionen Ende Ebene 5 Knoten Optionen
Anfang Ebene 5 Knoten Variablen Variablen Ende Ebene 5 Knoten Variablen
Anfang Ebene 5 Knoten Sicherungskennung (BID) Sicherungskennung (BID) Ende Ebene 5 Knoten Sicherungskennung (BID)
Anfang Ebene 4 Knoten Inhalt der Eingabedatei Inhalt der Eingabedatei Ende Ebene 4 Knoten Inhalt der Eingabedatei
Anfang Ebene 4 Knoten Inhalt der Ausgabedatei Inhalt der Ausgabedatei Ende Ebene 4 Knoten Inhalt der Ausgabedatei
Anfang Ebene 4 Knoten Rückgabewerte Rückgabewerte Ende Ebene 4 Knoten Rückgabewerte
Anfang Ebene 3 Knoten Unterstützte Betriebssysteme und Plattformen (Version 7.4) Unterstützte Betriebssysteme und Plattformen (Version 7.4) Ende Ebene 3 Knoten Unterstützte Betriebssysteme und Plattformen (Version 7.4)
Anfang Ebene 3 Knoten Unterstützte Betriebssysteme und Plattformen (Version 7.3) Unterstützte Betriebssysteme und Plattformen (Version 7.3) Ende Ebene 3 Knoten Unterstützte Betriebssysteme und Plattformen (Version 7.3)


SAP-Bibliothek - MaxDB

 Anfang des Navigationsbaums
Anfang Ebene 1 Knoten MaxDB MaxDB Ende Ebene 1 Knoten MaxDB
Anfang Ebene 2 Knoten Installation
Anfang Ebene 2 Knoten Grundwissen Grundwissen Ende Ebene 2 Knoten Grundwissen
Anfang Ebene 2 Knoten Tutorials Tutorials Ende Ebene 2 Knoten Tutorials
Anfang Ebene 2 Knoten Werkzeuge Werkzeuge Ende Ebene 2 Knoten Werkzeuge
Anfang Ebene 2 Knoten Schnittstellen Schnittstellen Ende Ebene 2 Knoten Schnittstellen
Anfang Ebene 2 Knoten Entwicklung Entwicklung Ende Ebene 2 Knoten Entwicklung
Anfang Ebene 2 Knoten Datenbankverwaltung im CCMS: MaxDB Datenbankverwaltung im CCMS: MaxDB Ende Ebene 2 Knoten Datenbankverwaltung im CCMS: MaxDB


SAP-Bibliothek - Entwicklung

 Anfang des Navigationsbaums
Anfang Ebene 1 Knoten Entwicklung Entwicklung Ende Ebene 1 Knoten Entwicklung
Anfang Ebene 2 Knoten Entwicklungsumgebung Entwicklungsumgebung Ende Ebene 2 Knoten Entwicklungsumgebung
Anfang Ebene 3 Knoten Installieren der Entwicklungsumgebung Installieren der Entwicklungsumgebung Ende Ebene 3 Knoten Installieren der Entwicklungsumgebung
Anfang Ebene 3 Knoten Installieren des Quelltexts Installieren des Quelltexts Ende Ebene 3 Knoten Installieren des Quelltexts
Anfang Ebene 3 Knoten Initialisieren der Entwicklungsumgebung Initialisieren der Entwicklungsumgebung Ende Ebene 3 Knoten Initialisieren der Entwicklungsumgebung
Anfang Ebene 4 Knoten Umgebungsvariablen Umgebungsvariablen Ende Ebene 4 Knoten Umgebungsvariablen
Anfang Ebene 5 Knoten $ARC_TYPE $ARC_TYPE Ende Ebene 5 Knoten $ARC_TYPE
Anfang Ebene 5 Knoten $BUILD_PRAEFIX $BUILD_PRAEFIX Ende Ebene 5 Knoten $BUILD_PRAEFIX
Anfang Ebene 5 Knoten $CORRECTION_LEVEL $CORRECTION_LEVEL Ende Ebene 5 Knoten $CORRECTION_LEVEL
Anfang Ebene 5 Knoten $DBROOT $DBROOT Ende Ebene 5 Knoten $DBROOT
Anfang Ebene 5 Knoten $DLL_TYPE $DLL_TYPE Ende Ebene 5 Knoten $DLL_TYPE
Anfang Ebene 5 Knoten $EDITOR $EDITOR Ende Ebene 5 Knoten $EDITOR
Anfang Ebene 5 Knoten %INCLUDE% %INCLUDE% Ende Ebene 5 Knoten %INCLUDE%
Anfang Ebene 5 Knoten $INSTROOT $INSTROOT Ende Ebene 5 Knoten $INSTROOT
Anfang Ebene 5 Knoten $NOQUIET $NOQUIET Ende Ebene 5 Knoten $NOQUIET
Anfang Ebene 5 Knoten $OWN $OWN Ende Ebene 5 Knoten $OWN
Anfang Ebene 5 Knoten $PATH $PATH Ende Ebene 5 Knoten $PATH
Anfang Ebene 5 Knoten $PERL5LIB $PERL5LIB Ende Ebene 5 Knoten $PERL5LIB
Anfang Ebene 5 Knoten $PYTHONPATH $PYTHONPATH Ende Ebene 5 Knoten $PYTHONPATH
Anfang Ebene 5 Knoten $RELVER $RELVER Ende Ebene 5 Knoten $RELVER
Anfang Ebene 5 Knoten $SHELL $SHELL Ende Ebene 5 Knoten $SHELL
Anfang Ebene 5 Knoten $TOOL $TOOL Ende Ebene 5 Knoten $TOOL
Anfang Ebene 5 Knoten $TOOLEXT $TOOLEXT Ende Ebene 5 Knoten $TOOLEXT
Anfang Ebene 5 Knoten $TOOLOPT $TOOLOPT Ende Ebene 5 Knoten $TOOLOPT
Anfang Ebene 5 Knoten $TOOLSHELL $TOOLSHELL Ende Ebene 5 Knoten $TOOLSHELL
Anfang Ebene 5 Knoten $TOOLVARS $TOOLVARS Ende Ebene 5 Knoten $TOOLVARS
Anfang Ebene 5 Knoten $VMAKE_DEFAULT $VMAKE_DEFAULT Ende Ebene 5 Knoten $VMAKE_DEFAULT
Anfang Ebene 5 Knoten $VMAKE_OPTION $VMAKE_OPTION Ende Ebene 5 Knoten $VMAKE_OPTION
Anfang Ebene 6 Knoten Allgemeine Parameter für $VMAKE_OPTION Allgemeine Parameter für $VMAKE_OPTION Ende Ebene 6 Knoten Allgemeine Parameter für $VMAKE_OPTION
Anfang Ebene 6 Knoten $VMAKE_OPTION-Parameter für die Suche nach Quelltext $VMAKE_OPTION-Parameter für die Suche nach Quelltext Ende Ebene 6 Knoten $VMAKE_OPTION-Parameter für die Suche nach Quelltext
Anfang Ebene 6 Knoten $VMAKE_OPTION-Parameter für die Suche nach Objektdateien $VMAKE_OPTION-Parameter für die Suche nach Objektdateien Ende Ebene 6 Knoten $VMAKE_OPTION-Parameter für die Suche nach Objektdateien
Anfang Ebene 5 Knoten $VMAKE_PATH $VMAKE_PATH Ende Ebene 5 Knoten $VMAKE_PATH
Anfang Ebene 5 Knoten $VMAKE_VERSION $VMAKE_VERSION Ende Ebene 5 Knoten $VMAKE_VERSION
Anfang Ebene 5 Knoten $WRK $WRK Ende Ebene 5 Knoten $WRK
Anfang Ebene 4 Knoten Suchhierarchie Suchhierarchie Ende Ebene 4 Knoten Suchhierarchie
Anfang Ebene 4 Knoten Verzeichnisstruktur der Entwicklungsumgebung Verzeichnisstruktur der Entwicklungsumgebung Ende Ebene 4 Knoten Verzeichnisstruktur der Entwicklungsumgebung
Anfang Ebene 3 Knoten Ändern eines MaxDB-Programms Ändern eines MaxDB-Programms Ende Ebene 3 Knoten Ändern eines MaxDB-Programms
Anfang Ebene 4 Knoten Ändern einer Moduldatei Ändern einer Moduldatei Ende Ebene 4 Knoten Ändern einer Moduldatei
Anfang Ebene 5 Knoten Moduldatei Moduldatei Ende Ebene 5 Knoten Moduldatei
Anfang Ebene 5 Knoten Include-Datei Include-Datei Ende Ebene 5 Knoten Include-Datei
Anfang Ebene 5 Knoten Schicht (Layer) Schicht (Layer) Ende Ebene 5 Knoten Schicht (Layer)
Anfang Ebene 4 Knoten Vorbereiten des MAKE-Vorgangs Vorbereiten des MAKE-Vorgangs Ende Ebene 4 Knoten Vorbereiten des MAKE-Vorgangs
Anfang Ebene 5 Knoten Erstellen/Ändern von Beschreibungsdateien Erstellen/Ändern von Beschreibungsdateien Ende Ebene 5 Knoten Erstellen/Ändern von Beschreibungsdateien
Anfang Ebene 6 Knoten Beschreibungsdatei Beschreibungsdatei Ende Ebene 6 Knoten Beschreibungsdatei
Anfang Ebene 7 Knoten Linkbeschreibung Linkbeschreibung Ende Ebene 7 Knoten Linkbeschreibung
Anfang Ebene 7 Knoten Kompilierbeschreibung Kompilierbeschreibung Ende Ebene 7 Knoten Kompilierbeschreibung
Anfang Ebene 7 Knoten Abarbeitungsliste Abarbeitungsliste Ende Ebene 7 Knoten Abarbeitungsliste
Anfang Ebene 6 Knoten Allgemeine Grammatik für Beschreibungsdateien Allgemeine Grammatik für Beschreibungsdateien Ende Ebene 6 Knoten Allgemeine Grammatik für Beschreibungsdateien
Anfang Ebene 7 Knoten Grammatik für Linkbeschreibungen Grammatik für Linkbeschreibungen Ende Ebene 7 Knoten Grammatik für Linkbeschreibungen
Anfang Ebene 7 Knoten Grammatik für Kompilierbeschreibungen Grammatik für Kompilierbeschreibungen Ende Ebene 7 Knoten Grammatik für Kompilierbeschreibungen
Anfang Ebene 7 Knoten Grammatik für Abarbeitungslisten Grammatik für Abarbeitungslisten Ende Ebene 7 Knoten Grammatik für Abarbeitungslisten
Anfang Ebene 6 Knoten Optionen für Beschreibungsdateien Optionen für Beschreibungsdateien Ende Ebene 6 Knoten Optionen für Beschreibungsdateien
Anfang Ebene 7 Knoten Optionen für Linkbeschreibungen Optionen für Linkbeschreibungen Ende Ebene 7 Knoten Optionen für Linkbeschreibungen
Anfang Ebene 7 Knoten Optionen für Kompilierbeschreibungen Optionen für Kompilierbeschreibungen Ende Ebene 7 Knoten Optionen für Kompilierbeschreibungen
Anfang Ebene 7 Knoten Optionen für Abarbeitungslisten Optionen für Abarbeitungslisten Ende Ebene 7 Knoten Optionen für Abarbeitungslisten
Anfang Ebene 7 Knoten ! <command> ! <command> Ende Ebene 7 Knoten ! <command>
Anfang Ebene 7 Knoten !! <command> !! <command> Ende Ebene 7 Knoten !! <command>
Anfang Ebene 7 Knoten !? <command> !? <command> Ende Ebene 7 Knoten !? <command>
Anfang Ebene 7 Knoten ? defaultlayer : <layer> ? defaultlayer : <layer> Ende Ebene 7 Knoten ? defaultlayer : <layer>
Anfang Ebene 7 Knoten ? defaultlayer : ? defaultlayer : Ende Ebene 7 Knoten ? defaultlayer :
Anfang Ebene 7 Knoten ? defaultversion : <vmake_version> ? defaultversion : <vmake_version> Ende Ebene 7 Knoten ? defaultversion : <vmake_version>
Anfang Ebene 7 Knoten ? defaultversion : ? defaultversion : Ende Ebene 7 Knoten ? defaultversion :
Anfang Ebene 7 Knoten ? distribute : <list> ? distribute : <list> Ende Ebene 7 Knoten ? distribute : <list>
Anfang Ebene 7 Knoten ? error : <error_message> ? error : <error_message> Ende Ebene 7 Knoten ? error : <error_message>
Anfang Ebene 7 Knoten ? link with : <list> ? link with : <list> Ende Ebene 7 Knoten ? link with : <list>
Anfang Ebene 7 Knoten ? linkoption : <list> ? linkoption : <list> Ende Ebene 7 Knoten ? linkoption : <list>
Anfang Ebene 7 Knoten ? output : <list> ? output : <list> Ende Ebene 7 Knoten ? output : <list>
Anfang Ebene 7 Knoten ? parentlinkoption : <link_option> ? parentlinkoption : <link_option> Ende Ebene 7 Knoten ? parentlinkoption : <link_option>
Anfang Ebene 7 Knoten ? propagate : <variable>[=<value>] ? propagate : <variable>[=<value>] Ende Ebene 7 Knoten ? propagate : <variable>[=<value>]
Anfang Ebene 7 Knoten ? require : <target> ? require : <target> Ende Ebene 7 Knoten ? require : <target>
Anfang Ebene 7 Knoten ? tooloption : <list> ? tooloption : <list> Ende Ebene 7 Knoten ? tooloption : <list>
Anfang Ebene 7 Knoten -><output> -><output> Ende Ebene 7 Knoten -><output>
Anfang Ebene 7 Knoten ascii ascii Ende Ebene 7 Knoten ascii
Anfang Ebene 7 Knoten binary binary Ende Ebene 7 Knoten binary
Anfang Ebene 7 Knoten debug|d debug|d Ende Ebene 7 Knoten debug|d
Anfang Ebene 7 Knoten definition definition Ende Ebene 7 Knoten definition
Anfang Ebene 7 Knoten demand demand Ende Ebene 7 Knoten demand
Anfang Ebene 7 Knoten demand{<relative path>} demand{<relative path>} Ende Ebene 7 Knoten demand{<relative path>}
Anfang Ebene 7 Knoten demand=<list> demand=<list> Ende Ebene 7 Knoten demand=<list>
Anfang Ebene 7 Knoten demand{<relative path>}=<list> demand{<relative path>}=<list> Ende Ebene 7 Knoten demand{<relative path>}=<list>
Anfang Ebene 7 Knoten dep=<list> dep=<list> Ende Ebene 7 Knoten dep=<list>
Anfang Ebene 7 Knoten distrib distrib Ende Ebene 7 Knoten distrib
Anfang Ebene 7 Knoten exec exec Ende Ebene 7 Knoten exec
Anfang Ebene 7 Knoten extdep=<list> extdep=<list> Ende Ebene 7 Knoten extdep=<list>
Anfang Ebene 7 Knoten inc=<list> inc=<list> Ende Ebene 7 Knoten inc=<list>
Anfang Ebene 7 Knoten interface interface Ende Ebene 7 Knoten interface
Anfang Ebene 7 Knoten nobind nobind Ende Ebene 7 Knoten nobind
Anfang Ebene 7 Knoten nocomfile nocomfile Ende Ebene 7 Knoten nocomfile
Anfang Ebene 7 Knoten nodistrib nodistrib Ende Ebene 7 Knoten nodistrib
Anfang Ebene 7 Knoten noobjcopy noobjcopy Ende Ebene 7 Knoten noobjcopy
Anfang Ebene 7 Knoten noshrglob noshrglob Ende Ebene 7 Knoten noshrglob
Anfang Ebene 7 Knoten noversion noversion Ende Ebene 7 Knoten noversion
Anfang Ebene 7 Knoten obj=<list> obj=<list> Ende Ebene 7 Knoten obj=<list>
Anfang Ebene 7 Knoten output=<list> output=<list> Ende Ebene 7 Knoten output=<list>
Anfang Ebene 7 Knoten parentlinkoption=<link_option> parentlinkoption=<link_option> Ende Ebene 7 Knoten parentlinkoption=<link_option>
Anfang Ebene 7 Knoten profile|p profile|p Ende Ebene 7 Knoten profile|p
Anfang Ebene 7 Knoten remake remake Ende Ebene 7 Knoten remake
Anfang Ebene 7 Knoten shrglob shrglob Ende Ebene 7 Knoten shrglob
Anfang Ebene 7 Knoten uncond uncond Ende Ebene 7 Knoten uncond
Anfang Ebene 5 Knoten Anpassen des Initialisierungsdateien Anpassen des Initialisierungsdateien Ende Ebene 5 Knoten Anpassen des Initialisierungsdateien
Anfang Ebene 6 Knoten Langextinfo Langextinfo Ende Ebene 6 Knoten Langextinfo
Anfang Ebene 6 Knoten Langinfo Langinfo Ende Ebene 6 Knoten Langinfo
Anfang Ebene 6 Knoten Extra Extra Ende Ebene 6 Knoten Extra
Anfang Ebene 6 Knoten Globals.com Globals.com Ende Ebene 6 Knoten Globals.com
Anfang Ebene 6 Knoten DirectoryMapping DirectoryMapping Ende Ebene 6 Knoten DirectoryMapping
Anfang Ebene 5 Knoten Angeben nicht zu übersetzender Dateien Angeben nicht zu übersetzender Dateien Ende Ebene 5 Knoten Angeben nicht zu übersetzender Dateien
Anfang Ebene 4 Knoten icp.pl: Kopieren von Dateien in den Entwicklungsbereich icp.pl: Kopieren von Dateien in den Entwicklungsbereich Ende Ebene 4 Knoten icp.pl: Kopieren von Dateien in den Entwicklungsbereich
Anfang Ebene 4 Knoten iview.pl: Anzeigen und Bearbeiten von Dateien iview.pl: Anzeigen und Bearbeiten von Dateien Ende Ebene 4 Knoten iview.pl: Anzeigen und Bearbeiten von Dateien
Anfang Ebene 4 Knoten idiff.pl: Vergleichen von Dateien idiff.pl: Vergleichen von Dateien Ende Ebene 4 Knoten idiff.pl: Vergleichen von Dateien
Anfang Ebene 4 Knoten ils.pl: Anzeigen der Versionen einer Datei ils.pl: Anzeigen der Versionen einer Datei Ende Ebene 4 Knoten ils.pl: Anzeigen der Versionen einer Datei
Anfang Ebene 4 Knoten Namenskonventionen für Dateien Namenskonventionen für Dateien Ende Ebene 4 Knoten Namenskonventionen für Dateien
Anfang Ebene 5 Knoten Namenskonventionen für Moduldateien Namenskonventionen für Moduldateien Ende Ebene 5 Knoten Namenskonventionen für Moduldateien
Anfang Ebene 5 Knoten Namenskonventionen für Beschreibungsdateien Namenskonventionen für Beschreibungsdateien Ende Ebene 5 Knoten Namenskonventionen für Beschreibungsdateien
Anfang Ebene 3 Knoten MAKE-Vorgang MAKE-Vorgang Ende Ebene 3 Knoten MAKE-Vorgang
Anfang Ebene 4 Knoten ims.pl, imf.pl: Starten des MAKE-Vorgangs ims.pl, imf.pl: Starten des MAKE-Vorgangs Ende Ebene 4 Knoten ims.pl, imf.pl: Starten des MAKE-Vorgangs
Anfang Ebene 5 Knoten Direkter VMAKE-Aufruf Direkter VMAKE-Aufruf Ende Ebene 5 Knoten Direkter VMAKE-Aufruf
Anfang Ebene 5 Knoten Optionen für den Aufruf von VMAKE Optionen für den Aufruf von VMAKE Ende Ebene 5 Knoten Optionen für den Aufruf von VMAKE
Anfang Ebene 5 Knoten Aktivieren des Debug-Modus Aktivieren des Debug-Modus Ende Ebene 5 Knoten Aktivieren des Debug-Modus
Anfang Ebene 5 Knoten VMAKE-Versionen VMAKE-Versionen Ende Ebene 5 Knoten VMAKE-Versionen
Anfang Ebene 4 Knoten Ermitteln der zu übersetzenden Dateien Ermitteln der zu übersetzenden Dateien Ende Ebene 4 Knoten Ermitteln der zu übersetzenden Dateien
Anfang Ebene 4 Knoten Übersetzungsvorgang Übersetzungsvorgang Ende Ebene 4 Knoten Übersetzungsvorgang
Anfang Ebene 5 Knoten Auswahl der Übersetzungswerkzeuge Auswahl der Übersetzungswerkzeuge Ende Ebene 5 Knoten Auswahl der Übersetzungswerkzeuge
Anfang Ebene 5 Knoten Entpacken der Moduldateien Entpacken der Moduldateien Ende Ebene 5 Knoten Entpacken der Moduldateien
Anfang Ebene 5 Knoten Übersetzen der Moduldateien Übersetzen der Moduldateien Ende Ebene 5 Knoten Übersetzen der Moduldateien
Anfang Ebene 5 Knoten Objektdateien Objektdateien Ende Ebene 5 Knoten Objektdateien
Anfang Ebene 5 Knoten Datumsdatei Datumsdatei Ende Ebene 5 Knoten Datumsdatei
Anfang Ebene 4 Knoten Linkvorgang Linkvorgang Ende Ebene 4 Knoten Linkvorgang
Anfang Ebene 4 Knoten VMAKE-Werkzeuge VMAKE-Werkzeuge Ende Ebene 4 Knoten VMAKE-Werkzeuge
Anfang Ebene 5 Knoten Optionen für VMAKE-Werkzeuge Optionen für VMAKE-Werkzeuge Ende Ebene 5 Knoten Optionen für VMAKE-Werkzeuge
Anfang Ebene 4 Knoten VMAKE-Protokolle VMAKE-Protokolle Ende Ebene 4 Knoten VMAKE-Protokolle
Anfang Ebene 5 Knoten ips.pl, ipf.pl: Anzeigen von Protokollen ips.pl, ipf.pl: Anzeigen von Protokollen Ende Ebene 5 Knoten ips.pl, ipf.pl: Anzeigen von Protokollen
Anfang Ebene 4 Knoten Vergleich MaxDB-VMAKE - herkömmliches make-Programm Vergleich MaxDB-VMAKE - herkömmliches make-Programm Ende Ebene 4 Knoten Vergleich MaxDB-VMAKE - herkömmliches make-Programm
Anfang Ebene 3 Knoten Beispiel: Übersetzen der Datei HelloWorld.c Beispiel: Übersetzen der Datei HelloWorld.c Ende Ebene 3 Knoten Beispiel: Übersetzen der Datei HelloWorld.c
Anfang Ebene 3 Knoten Beispiel: Erstellen des Programms Database Manager CLI 7.4.03 Beispiel: Erstellen des Programms Database Manager CLI 7.4.03 Ende Ebene 3 Knoten Beispiel: Erstellen des Programms Database Manager CLI 7.4.03
Anfang Ebene 4 Knoten Bestandteile des DBMCLI Bestandteile des DBMCLI Ende Ebene 4 Knoten Bestandteile des DBMCLI
Anfang Ebene 5 Knoten dbmcli.rc dbmcli.rc Ende Ebene 5 Knoten dbmcli.rc
Anfang Ebene 5 Knoten vcn12.cpp, vcn13.cpp, vcn14.c vcn12.cpp, vcn13.cpp, vcn14.c Ende Ebene 5 Knoten vcn12.cpp, vcn13.cpp, vcn14.c
Anfang Ebene 6 Knoten Kompilierbeschreibungen Kompilierbeschreibungen Ende Ebene 6 Knoten Kompilierbeschreibungen
Anfang Ebene 6 Knoten Beispiel für eine Include-Datei Beispiel für eine Include-Datei Ende Ebene 6 Knoten Beispiel für eine Include-Datei
Anfang Ebene 5 Knoten cservlib cservlib Ende Ebene 5 Knoten cservlib
Anfang Ebene 5 Knoten splib splib Ende Ebene 5 Knoten splib
Anfang Ebene 5 Knoten eoxlib eoxlib Ende Ebene 5 Knoten eoxlib
Anfang Ebene 5 Knoten sqlusr, enalib, enblib sqlusr, enalib, enblib Ende Ebene 5 Knoten sqlusr, enalib, enblib
Anfang Ebene 5 Knoten Weitere Abhängigkeiten Weitere Abhängigkeiten Ende Ebene 5 Knoten Weitere Abhängigkeiten
Anfang Ebene 4 Knoten Erstellen des DBMCLI Erstellen des DBMCLI Ende Ebene 4 Knoten Erstellen des DBMCLI
Anfang Ebene 5 Knoten Linkbeschreibung dbmcli.lnk Linkbeschreibung dbmcli.lnk Ende Ebene 5 Knoten Linkbeschreibung dbmcli.lnk
Anfang Ebene 4 Knoten Funktionsprüfung Funktionsprüfung Ende Ebene 4 Knoten Funktionsprüfung
Anfang Ebene 2 Knoten Web Based Problem Tracking System Web Based Problem Tracking System Ende Ebene 2 Knoten Web Based Problem Tracking System
Anfang Ebene 3 Knoten Systemanforderungen Systemanforderungen Ende Ebene 3 Knoten Systemanforderungen
Anfang Ebene 3 Knoten Funktionsweise des Web PTS Funktionsweise des Web PTS Ende Ebene 3 Knoten Funktionsweise des Web PTS
Anfang Ebene 4 Knoten Einfache Suche (Simple Search) Einfache Suche (Simple Search) Ende Ebene 4 Knoten Einfache Suche (Simple Search)
Anfang Ebene 5 Knoten Ergebnisliste der Einfachen Suche Ergebnisliste der Einfachen Suche Ende Ebene 5 Knoten Ergebnisliste der Einfachen Suche
Anfang Ebene 4 Knoten Erweiterte Suche (Advanced Search) Erweiterte Suche (Advanced Search) Ende Ebene 4 Knoten Erweiterte Suche (Advanced Search)
Anfang Ebene 5 Knoten Ergebnisliste der Erweiterten Suche Ergebnisliste der Erweiterten Suche Ende Ebene 5 Knoten Ergebnisliste der Erweiterten Suche
Anfang Ebene 4 Knoten Versionsvergleich (My Release Notes) Versionsvergleich (My Release Notes) Ende Ebene 4 Knoten Versionsvergleich (My Release Notes)
Anfang Ebene 5 Knoten Ergebnisliste des Versionsvergleichs Ergebnisliste des Versionsvergleichs Ende Ebene 5 Knoten Ergebnisliste des Versionsvergleichs
Anfang Ebene 3 Knoten Begriffe Begriffe Ende Ebene 3 Knoten Begriffe
Anfang Ebene 4 Knoten Meldungsdaten Meldungsdaten Ende Ebene 4 Knoten Meldungsdaten
Anfang Ebene 5 Knoten Header-Daten (Header Data) Header-Daten (Header Data) Ende Ebene 5 Knoten Header-Daten (Header Data)
Anfang Ebene 5 Knoten Bearbeitungsstand (Settlement) Bearbeitungsstand (Settlement) Ende Ebene 5 Knoten Bearbeitungsstand (Settlement)
Anfang Ebene 4 Knoten Meldungstexte (Message Texts) Meldungstexte (Message Texts) Ende Ebene 4 Knoten Meldungstexte (Message Texts)


SAP-Bibliothek - Installation

 Anfang des Navigationsbaums
Anfang Ebene 1 Knoten Installation Installation Ende Ebene 1 Knoten Installation
Anfang Ebene 2 Knoten Installationshandbuch Installationshandbuch Ende Ebene 2 Knoten Installationshandbuch
Anfang Ebene 3 Knoten Verwenden des Installation Manager Verwenden des Installation Manager Ende Ebene 3 Knoten Verwenden des Installation Manager
Anfang Ebene 4 Knoten Installation/Upgrade auf UNIX/Linux Installation/Upgrade auf UNIX/Linux Ende Ebene 4 Knoten Installation/Upgrade auf UNIX/Linux
Anfang Ebene 4 Knoten Installation/Upgrade auf Microsoft Windows Installation/Upgrade auf Microsoft Windows Ende Ebene 4 Knoten Installation/Upgrade auf Microsoft Windows
Anfang Ebene 4 Knoten Datenbankinstanz nachträglich anlegen Datenbankinstanz nachträglich anlegen Ende Ebene 4 Knoten Datenbankinstanz nachträglich anlegen
Anfang Ebene 4 Knoten Demo-Datenbankinstanz DEMODB anlegen Demo-Datenbankinstanz DEMODB anlegen Ende Ebene 4 Knoten Demo-Datenbankinstanz DEMODB anlegen
Anfang Ebene 4 Knoten Deinstallation Deinstallation Ende Ebene 4 Knoten Deinstallation
Anfang Ebene 4 Knoten Datenbankinstanz löschen Datenbankinstanz löschen Ende Ebene 4 Knoten Datenbankinstanz löschen
Anfang Ebene 3 Knoten Installation, Upgrade und Deinstallation auf der Kommandozeile Installation, Upgrade und Deinstallation auf der Kommandozeile Ende Ebene 3 Knoten Installation, Upgrade und Deinstallation auf der Kommandozeile
Anfang Ebene 4 Knoten Installation und Update der Datenbanksoftware Installation und Update der Datenbanksoftware Ende Ebene 4 Knoten Installation und Update der Datenbanksoftware
Anfang Ebene 5 Knoten Installation/Update der Software auf UNIX Installation/Update der Software auf UNIX Ende Ebene 5 Knoten Installation/Update der Software auf UNIX
Anfang Ebene 6 Knoten Entpacken der Software auf UNIX Entpacken der Software auf UNIX Ende Ebene 6 Knoten Entpacken der Software auf UNIX
Anfang Ebene 6 Knoten Interaktive Installation/Update auf UNIX Interaktive Installation/Update auf UNIX Ende Ebene 6 Knoten Interaktive Installation/Update auf UNIX
Anfang Ebene 6 Knoten Installation/Update im Hintergrund auf UNIX Installation/Update im Hintergrund auf UNIX Ende Ebene 6 Knoten Installation/Update im Hintergrund auf UNIX
Anfang Ebene 5 Knoten Installation/Update der Software auf Linux Installation/Update der Software auf Linux Ende Ebene 5 Knoten Installation/Update der Software auf Linux
Anfang Ebene 6 Knoten Installation/Update mit dem Programm SDBINST Installation/Update mit dem Programm SDBINST Ende Ebene 6 Knoten Installation/Update mit dem Programm SDBINST
Anfang Ebene 6 Knoten Installation/Update mit dem Red Hat Package Manager Installation/Update mit dem Red Hat Package Manager Ende Ebene 6 Knoten Installation/Update mit dem Red Hat Package Manager
Anfang Ebene 5 Knoten Installation/Update der Software auf Microsoft Windows Installation/Update der Software auf Microsoft Windows Ende Ebene 5 Knoten Installation/Update der Software auf Microsoft Windows
Anfang Ebene 6 Knoten Entpacken der Software auf Microsoft Windows Entpacken der Software auf Microsoft Windows Ende Ebene 6 Knoten Entpacken der Software auf Microsoft Windows
Anfang Ebene 6 Knoten Interaktive Installation/Update auf Microsoft Windows Interaktive Installation/Update auf Microsoft Windows Ende Ebene 6 Knoten Interaktive Installation/Update auf Microsoft Windows
Anfang Ebene 6 Knoten Installation/Update im Hintergrund auf Microsoft Windows Installation/Update im Hintergrund auf Microsoft Windows Ende Ebene 6 Knoten Installation/Update im Hintergrund auf Microsoft Windows
Anfang Ebene 4 Knoten Deinstallation der Datenbanksoftware Deinstallation der Datenbanksoftware Ende Ebene 4 Knoten Deinstallation der Datenbanksoftware
Anfang Ebene 5 Knoten Deinstallation mit SDBUNINST auf UNIX, Linux und Microsoft Windo Deinstallation mit SDBUNINST auf UNIX, Linux und Microsoft Windo Ende Ebene 5 Knoten Deinstallation mit SDBUNINST auf UNIX, Linux und Microsoft Windo
Anfang Ebene 5 Knoten Deinstallation mit dem Red Hat Package Manager Deinstallation mit dem Red Hat Package Manager Ende Ebene 5 Knoten Deinstallation mit dem Red Hat Package Manager
Anfang Ebene 4 Knoten Aktualisierung von Datenbankinstanzen inklusive Server-Software Aktualisierung von Datenbankinstanzen inklusive Server-Software Ende Ebene 4 Knoten Aktualisierung von Datenbankinstanzen inklusive Server-Software
Anfang Ebene 5 Knoten Auswahl der Upgrade-Strategie Auswahl der Upgrade-Strategie Ende Ebene 5 Knoten Auswahl der Upgrade-Strategie
Anfang Ebene 6 Knoten Patch-Installation mit SDBUPD Patch-Installation mit SDBUPD Ende Ebene 6 Knoten Patch-Installation mit SDBUPD
Anfang Ebene 6 Knoten Patch-Installation mit SDBINST und Nachbereitung Patch-Installation mit SDBINST und Nachbereitung Ende Ebene 6 Knoten Patch-Installation mit SDBINST und Nachbereitung
Anfang Ebene 6 Knoten In-Place-Migration mit SDBUPD In-Place-Migration mit SDBUPD Ende Ebene 6 Knoten In-Place-Migration mit SDBUPD
Anfang Ebene 6 Knoten In-Place-Migration mit SDBINST und Nachbereitung In-Place-Migration mit SDBINST und Nachbereitung Ende Ebene 6 Knoten In-Place-Migration mit SDBINST und Nachbereitung
Anfang Ebene 6 Knoten Upgrade mittels APO Extract/Load Upgrade mittels APO Extract/Load Ende Ebene 6 Knoten Upgrade mittels APO Extract/Load
Anfang Ebene 3 Knoten Anschluss von Sicherungswerkzeugen anderer Anbieter Anschluss von Sicherungswerkzeugen anderer Anbieter Ende Ebene 3 Knoten Anschluss von Sicherungswerkzeugen anderer Anbieter
Anfang Ebene 4 Knoten Blockdiagramm Sichern und Wiederherstellen Blockdiagramm Sichern und Wiederherstellen Ende Ebene 4 Knoten Blockdiagramm Sichern und Wiederherstellen
Anfang Ebene 4 Knoten Blockdiagramm Importieren und Exportieren von Daten Blockdiagramm Importieren und Exportieren von Daten Ende Ebene 4 Knoten Blockdiagramm Importieren und Exportieren von Daten
Anfang Ebene 4 Knoten Anschluss an eine Backint for Oracle-Schnittstelle Anschluss an eine Backint for Oracle-Schnittstelle Ende Ebene 4 Knoten Anschluss an eine Backint for Oracle-Schnittstelle
Anfang Ebene 5 Knoten Einschränkungen für die Verwendung von Backint for Oracle für Ve Einschränkungen für die Verwendung von Backint for Oracle für Ve Ende Ebene 5 Knoten Einschränkungen für die Verwendung von Backint for Oracle für Ve
Anfang Ebene 5 Knoten Funktionsweise des MaxDB-Adapterprogramms Funktionsweise des MaxDB-Adapterprogramms Ende Ebene 5 Knoten Funktionsweise des MaxDB-Adapterprogramms
Anfang Ebene 5 Knoten Konfiguration des Backint for Oracle-Anschlusses Konfiguration des Backint for Oracle-Anschlusses Ende Ebene 5 Knoten Konfiguration des Backint for Oracle-Anschlusses
Anfang Ebene 6 Knoten Erstellen der Parameterdatei für das MaxDB-Adapterprogramm Erstellen der Parameterdatei für das MaxDB-Adapterprogramm Ende Ebene 6 Knoten Erstellen der Parameterdatei für das MaxDB-Adapterprogramm
Anfang Ebene 7 Knoten Beispiel einer Parameterdatei für das MaxDB-Adapterprogramm Beispiel einer Parameterdatei für das MaxDB-Adapterprogramm Ende Ebene 7 Knoten Beispiel einer Parameterdatei für das MaxDB-Adapterprogramm
Anfang Ebene 6 Knoten Erstellen der Konfigurationsdatei für Backint for MaxDB Erstellen der Konfigurationsdatei für Backint for MaxDB Ende Ebene 6 Knoten Erstellen der Konfigurationsdatei für Backint for MaxDB
Anfang Ebene 7 Knoten Beispiel einer Konfigurationsdatei für Backint for MaxDB Beispiel einer Konfigurationsdatei für Backint for MaxDB Ende Ebene 7 Knoten Beispiel einer Konfigurationsdatei für Backint for MaxDB
Anfang Ebene 6 Knoten Exportieren von Umgebungsvariablen für das externe Sicherungswer Exportieren von Umgebungsvariablen für das externe Sicherungswer Ende Ebene 6 Knoten Exportieren von Umgebungsvariablen für das externe Sicherungswer
Anfang Ebene 6 Knoten Setzen der Umgebungsvariablen BSI_ENV Setzen der Umgebungsvariablen BSI_ENV Ende Ebene 6 Knoten Setzen der Umgebungsvariablen BSI_ENV
Anfang Ebene 6 Knoten Setzen werkzeugunabhängiger Umgebungsvariablen für den Database Setzen werkzeugunabhängiger Umgebungsvariablen für den Database Ende Ebene 6 Knoten Setzen werkzeugunabhängiger Umgebungsvariablen für den Database
Anfang Ebene 7 Knoten Setzen von TEMP oder TMP Setzen von TEMP oder TMP Ende Ebene 7 Knoten Setzen von TEMP oder TMP
Anfang Ebene 7 Knoten Setzen von DBM_TTO_SUCCESS und DBM_TTO_FAILURE Setzen von DBM_TTO_SUCCESS und DBM_TTO_FAILURE Ende Ebene 7 Knoten Setzen von DBM_TTO_SUCCESS und DBM_TTO_FAILURE
Anfang Ebene 4 Knoten Anschluss an eine Backint for MaxDB-Schnittstelle Anschluss an eine Backint for MaxDB-Schnittstelle Ende Ebene 4 Knoten Anschluss an eine Backint for MaxDB-Schnittstelle
Anfang Ebene 5 Knoten Einschränkungen für die Verwendung von Backint for MaxDB für Ver Einschränkungen für die Verwendung von Backint for MaxDB für Ver Ende Ebene 5 Knoten Einschränkungen für die Verwendung von Backint for MaxDB für Ver
Anfang Ebene 4 Knoten Anschluss an TSM Anschluss an TSM Ende Ebene 4 Knoten Anschluss an TSM
Anfang Ebene 5 Knoten Einschränkungen für die Verwendung von TSM für Versionen kleiner Einschränkungen für die Verwendung von TSM für Versionen kleiner Ende Ebene 5 Knoten Einschränkungen für die Verwendung von TSM für Versionen kleiner
Anfang Ebene 5 Knoten Einschränkungen für das Parallele Sichern und Wiederherstellen m Einschränkungen für das Parallele Sichern und Wiederherstellen m Ende Ebene 5 Knoten Einschränkungen für das Parallele Sichern und Wiederherstellen m
Anfang Ebene 5 Knoten Konfiguration des TSM-Anschlusses Konfiguration des TSM-Anschlusses Ende Ebene 5 Knoten Konfiguration des TSM-Anschlusses
Anfang Ebene 6 Knoten Setzen der Umgebungsvariablen ADINT und ADA_OPT Setzen der Umgebungsvariablen ADINT und ADA_OPT Ende Ebene 6 Knoten Setzen der Umgebungsvariablen ADINT und ADA_OPT
Anfang Ebene 4 Knoten Anschluss an NetWorker Anschluss an NetWorker Ende Ebene 4 Knoten Anschluss an NetWorker
Anfang Ebene 5 Knoten Einschränkungen für die Verwendung von NetWorker für Versionen k Einschränkungen für die Verwendung von NetWorker für Versionen k Ende Ebene 5 Knoten Einschränkungen für die Verwendung von NetWorker für Versionen k
Anfang Ebene 5 Knoten Einschränkungen für das Parallele Sichern und Wiederherstellen m Einschränkungen für das Parallele Sichern und Wiederherstellen m Ende Ebene 5 Knoten Einschränkungen für das Parallele Sichern und Wiederherstellen m
Anfang Ebene 5 Knoten Konfiguration des NetWorker-Anschlusses Konfiguration des NetWorker-Anschlusses Ende Ebene 5 Knoten Konfiguration des NetWorker-Anschlusses
Anfang Ebene 6 Knoten Setzen der Umgebungsvariablen NSR_ENV Setzen der Umgebungsvariablen NSR_ENV Ende Ebene 6 Knoten Setzen der Umgebungsvariablen NSR_ENV
Anfang Ebene 6 Knoten Erstellen der Konfigurationsdatei für NetWorker Erstellen der Konfigurationsdatei für NetWorker Ende Ebene 6 Knoten Erstellen der Konfigurationsdatei für NetWorker
Anfang Ebene 7 Knoten Beispiel einer Konfigurationsdatei für NetWorker Beispiel einer Konfigurationsdatei für NetWorker Ende Ebene 7 Knoten Beispiel einer Konfigurationsdatei für NetWorker
Anfang Ebene 4 Knoten Anschluss an VERITAS NetBackup Anschluss an VERITAS NetBackup Ende Ebene 4 Knoten Anschluss an VERITAS NetBackup
Anfang Ebene 3 Knoten Synchronization Manager installieren Synchronization Manager installieren Ende Ebene 3 Knoten Synchronization Manager installieren
Anfang Ebene 3 Knoten MaxDB-PHP-Erweiterung installieren MaxDB-PHP-Erweiterung installieren Ende Ebene 3 Knoten MaxDB-PHP-Erweiterung installieren
Anfang Ebene 4 Knoten Erstellen und Installieren der MaxDB-PHP-Erweiterung auf Linux Erstellen und Installieren der MaxDB-PHP-Erweiterung auf Linux Ende Ebene 4 Knoten Erstellen und Installieren der MaxDB-PHP-Erweiterung auf Linux
Anfang Ebene 5 Knoten Testen der MaxDB-PHP-Erweiterung (Linux) Testen der MaxDB-PHP-Erweiterung (Linux) Ende Ebene 5 Knoten Testen der MaxDB-PHP-Erweiterung (Linux)
Anfang Ebene 4 Knoten Installieren der MaxDB-PHP-Bibliothek (Microsoft Windows) Installieren der MaxDB-PHP-Bibliothek (Microsoft Windows) Ende Ebene 4 Knoten Installieren der MaxDB-PHP-Bibliothek (Microsoft Windows)
Anfang Ebene 5 Knoten Testen der PHP-Bibliothek (Microsoft Windows) Testen der PHP-Bibliothek (Microsoft Windows) Ende Ebene 5 Knoten Testen der PHP-Bibliothek (Microsoft Windows)
Anfang Ebene 3 Knoten Web SQL / WebDAV konfigurieren Web SQL / WebDAV konfigurieren Ende Ebene 3 Knoten Web SQL / WebDAV konfigurieren
Anfang Ebene 3 Knoten Fehlerbehandlung Fehlerbehandlung Ende Ebene 3 Knoten Fehlerbehandlung
Anfang Ebene 4 Knoten Fehler bei der Ausführung des Programms SDBINST Fehler bei der Ausführung des Programms SDBINST Ende Ebene 4 Knoten Fehler bei der Ausführung des Programms SDBINST
Anfang Ebene 4 Knoten Fehler bei der Ausführung des Programms SDBUPD Fehler bei der Ausführung des Programms SDBUPD Ende Ebene 4 Knoten Fehler bei der Ausführung des Programms SDBUPD
Anfang Ebene 5 Knoten Fall 1: Es gibt noch keine Datenbankinstanzen Fall 1: Es gibt noch keine Datenbankinstanzen Ende Ebene 5 Knoten Fall 1: Es gibt noch keine Datenbankinstanzen
Anfang Ebene 5 Knoten Fall 2: Downgrade für Dependent Software Fall 2: Downgrade für Dependent Software Ende Ebene 5 Knoten Fall 2: Downgrade für Dependent Software
Anfang Ebene 5 Knoten Fall 3: Downgrade für Independent Software Fall 3: Downgrade für Independent Software Ende Ebene 5 Knoten Fall 3: Downgrade für Independent Software
Anfang Ebene 3 Knoten Detailinformationen Detailinformationen Ende Ebene 3 Knoten Detailinformationen
Anfang Ebene 4 Knoten Verzeichnisse Verzeichnisse Ende Ebene 4 Knoten Verzeichnisse
Anfang Ebene 5 Knoten Verzeichnisstruktur innerhalb von SAP-Systemen Verzeichnisstruktur innerhalb von SAP-Systemen Ende Ebene 5 Knoten Verzeichnisstruktur innerhalb von SAP-Systemen
Anfang Ebene 5 Knoten Verzeichnisstruktur außerhalb von SAP-Systemen Verzeichnisstruktur außerhalb von SAP-Systemen Ende Ebene 5 Knoten Verzeichnisstruktur außerhalb von SAP-Systemen
Anfang Ebene 4 Knoten Komponentengruppen Komponentengruppen Ende Ebene 4 Knoten Komponentengruppen
Anfang Ebene 4 Knoten Installationsprofile Installationsprofile Ende Ebene 4 Knoten Installationsprofile
Anfang Ebene 4 Knoten Softwarekomponenten Softwarekomponenten Ende Ebene 4 Knoten Softwarekomponenten
Anfang Ebene 4 Knoten Protokollierung Protokollierung Ende Ebene 4 Knoten Protokollierung
Anfang Ebene 4 Knoten Anzeigen der installierten Softwarekomponenten Anzeigen der installierten Softwarekomponenten Ende Ebene 4 Knoten Anzeigen der installierten Softwarekomponenten
Anfang Ebene 4 Knoten Übersicht der Optionen für das Programm SDBINST Übersicht der Optionen für das Programm SDBINST Ende Ebene 4 Knoten Übersicht der Optionen für das Programm SDBINST
Anfang Ebene 4 Knoten Übersicht der Optionen für das Programm SDBUNINST Übersicht der Optionen für das Programm SDBUNINST Ende Ebene 4 Knoten Übersicht der Optionen für das Programm SDBUNINST
Anfang Ebene 4 Knoten Übersicht der Optionen für das Programm SDBUPD Übersicht der Optionen für das Programm SDBUPD Ende Ebene 4 Knoten Übersicht der Optionen für das Programm SDBUPD


SAP-Bibliothek - Werkzeuge

 Anfang des Navigationsbaums
Anfang Ebene 1 Knoten Werkzeuge Werkzeuge Ende Ebene 1 Knoten Werkzeuge
Anfang Ebene 2 Knoten Database Manager GUI Database Manager GUI Ende Ebene 2 Knoten Database Manager GUI
Anfang Ebene 3 Knoten Aufrufen des Database Manager GUI Aufrufen des Database Manager GUI Ende Ebene 3 Knoten Aufrufen des Database Manager GUI
Anfang Ebene 3 Knoten Bildschirmbereiche des Database Manager GUI Bildschirmbereiche des Database Manager GUI Ende Ebene 3 Knoten Bildschirmbereiche des Database Manager GUI
Anfang Ebene 3 Knoten Anlegen einer Datenbankinstanz Anlegen einer Datenbankinstanz Ende Ebene 3 Knoten Anlegen einer Datenbankinstanz
Anfang Ebene 4 Knoten Anlegen einer Datenbankinstanz: Desktop PC/Laptop Anlegen einer Datenbankinstanz: Desktop PC/Laptop Ende Ebene 4 Knoten Anlegen einer Datenbankinstanz: Desktop PC/Laptop
Anfang Ebene 4 Knoten Anlegen einer Datenbankinstanz: Custom Anlegen einer Datenbankinstanz: Custom Ende Ebene 4 Knoten Anlegen einer Datenbankinstanz: Custom
Anfang Ebene 4 Knoten Anlegen einer Datenbankinstanz: My Templates Anlegen einer Datenbankinstanz: My Templates Ende Ebene 4 Knoten Anlegen einer Datenbankinstanz: My Templates
Anfang Ebene 3 Knoten Initialisieren einer vorhandenen Datenbankinstanz Initialisieren einer vorhandenen Datenbankinstanz Ende Ebene 3 Knoten Initialisieren einer vorhandenen Datenbankinstanz
Anfang Ebene 3 Knoten Verwalten von Datenbankinstanzen Verwalten von Datenbankinstanzen Ende Ebene 3 Knoten Verwalten von Datenbankinstanzen
Anfang Ebene 4 Knoten Liste der Datenbankinstanzen verwalten Liste der Datenbankinstanzen verwalten Ende Ebene 4 Knoten Liste der Datenbankinstanzen verwalten
Anfang Ebene 4 Knoten Verbindung zum DBM-Server Verbindung zum DBM-Server Ende Ebene 4 Knoten Verbindung zum DBM-Server
Anfang Ebene 4 Knoten Starten der Datenbankinstanz (Restart) Starten der Datenbankinstanz (Restart) Ende Ebene 4 Knoten Starten der Datenbankinstanz (Restart)
Anfang Ebene 4 Knoten Stoppen der Datenbankinstanz (Shutdown) Stoppen der Datenbankinstanz (Shutdown) Ende Ebene 4 Knoten Stoppen der Datenbankinstanz (Shutdown)
Anfang Ebene 4 Knoten Betriebszustand überwachen Betriebszustand überwachen Ende Ebene 4 Knoten Betriebszustand überwachen
Anfang Ebene 4 Knoten Datenbanksitzung manuell beenden Datenbanksitzung manuell beenden Ende Ebene 4 Knoten Datenbanksitzung manuell beenden
Anfang Ebene 4 Knoten Volumes anlegen, anzeigen und löschen Volumes anlegen, anzeigen und löschen Ende Ebene 4 Knoten Volumes anlegen, anzeigen und löschen
Anfang Ebene 4 Knoten Volume-Eigenschaften ändern Volume-Eigenschaften ändern Ende Ebene 4 Knoten Volume-Eigenschaften ändern
Anfang Ebene 4 Knoten Datenbankparameter anzeigen und ändern Datenbankparameter anzeigen und ändern Ende Ebene 4 Knoten Datenbankparameter anzeigen und ändern
Anfang Ebene 4 Knoten Volume-Datenbankparameter ändern Volume-Datenbankparameter ändern Ende Ebene 4 Knoten Volume-Datenbankparameter ändern
Anfang Ebene 4 Knoten Automatische Erweiterung des Datenbereichs ein-/ausschalten Automatische Erweiterung des Datenbereichs ein-/ausschalten Ende Ebene 4 Knoten Automatische Erweiterung des Datenbereichs ein-/ausschalten
Anfang Ebene 4 Knoten Log-Einstellungen ändern Log-Einstellungen ändern Ende Ebene 4 Knoten Log-Einstellungen ändern
Anfang Ebene 4 Knoten Master-Instanz einrichten (Hot-Standby) Master-Instanz einrichten (Hot-Standby) Ende Ebene 4 Knoten Master-Instanz einrichten (Hot-Standby)
Anfang Ebene 4 Knoten Standby-Instanz hinzufügen (Hot-Standby) Standby-Instanz hinzufügen (Hot-Standby) Ende Ebene 4 Knoten Standby-Instanz hinzufügen (Hot-Standby)
Anfang Ebene 4 Knoten Indizes de-/aktivieren oder löschen Indizes de-/aktivieren oder löschen Ende Ebene 4 Knoten Indizes de-/aktivieren oder löschen
Anfang Ebene 4 Knoten Mapchar-Sets anlegen, anzeigen, ändern und löschen Mapchar-Sets anlegen, anzeigen, ändern und löschen Ende Ebene 4 Knoten Mapchar-Sets anlegen, anzeigen, ändern und löschen
Anfang Ebene 4 Knoten Statistikinformationen aktualisieren Statistikinformationen aktualisieren Ende Ebene 4 Knoten Statistikinformationen aktualisieren
Anfang Ebene 4 Knoten Demo-Daten laden Demo-Daten laden Ende Ebene 4 Knoten Demo-Daten laden
Anfang Ebene 3 Knoten Löschen einer Datenbankinstanz Löschen einer Datenbankinstanz Ende Ebene 3 Knoten Löschen einer Datenbankinstanz
Anfang Ebene 3 Knoten Verwalten des Datenbanksystemadministrators Verwalten des Datenbanksystemadministrators Ende Ebene 3 Knoten Verwalten des Datenbanksystemadministrators
Anfang Ebene 4 Knoten Ändern der DBM-Benutzereigenschaften des Datenbanksystemadminist Ändern der DBM-Benutzereigenschaften des Datenbanksystemadminist Ende Ebene 4 Knoten Ändern der DBM-Benutzereigenschaften des Datenbanksystemadminist
Anfang Ebene 4 Knoten Ändern des Kennworts des Datenbanksystemadministrators Ändern des Kennworts des Datenbanksystemadministrators Ende Ebene 4 Knoten Ändern des Kennworts des Datenbanksystemadministrators
Anfang Ebene 4 Knoten Ändern der Serverberechtigungen des Datenbanksystemadministrator Ändern der Serverberechtigungen des Datenbanksystemadministrator Ende Ebene 4 Knoten Ändern der Serverberechtigungen des Datenbanksystemadministrator
Anfang Ebene 4 Knoten Ändern der SQL-Benutzereigenschaften des Datenbanksystemadminist Ändern der SQL-Benutzereigenschaften des Datenbanksystemadminist Ende Ebene 4 Knoten Ändern der SQL-Benutzereigenschaften des Datenbanksystemadminist
Anfang Ebene 3 Knoten Verwalten der Database Manager-Benutzer Verwalten der Database Manager-Benutzer Ende Ebene 3 Knoten Verwalten der Database Manager-Benutzer
Anfang Ebene 4 Knoten Anlegen/Ändern/Löschen eines Database Manager-Benutzers Anlegen/Ändern/Löschen eines Database Manager-Benutzers Ende Ebene 4 Knoten Anlegen/Ändern/Löschen eines Database Manager-Benutzers
Anfang Ebene 4 Knoten Ändern der DBM-Benutzereigenschaften Ändern der DBM-Benutzereigenschaften Ende Ebene 4 Knoten Ändern der DBM-Benutzereigenschaften
Anfang Ebene 4 Knoten Ändern des Kennworts eines Database Manager-Benutzers Ändern des Kennworts eines Database Manager-Benutzers Ende Ebene 4 Knoten Ändern des Kennworts eines Database Manager-Benutzers
Anfang Ebene 4 Knoten Ändern der Serverberechtigungen Ändern der Serverberechtigungen Ende Ebene 4 Knoten Ändern der Serverberechtigungen
Anfang Ebene 3 Knoten Verwalten von Datenbankbenutzern Verwalten von Datenbankbenutzern Ende Ebene 3 Knoten Verwalten von Datenbankbenutzern
Anfang Ebene 4 Knoten Anlegen/Ändern/Löschen eines Datenbankbenutzers Anlegen/Ändern/Löschen eines Datenbankbenutzers Ende Ebene 4 Knoten Anlegen/Ändern/Löschen eines Datenbankbenutzers
Anfang Ebene 4 Knoten Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers Ende Ebene 4 Knoten Ändern der SQL-Benutzereigenschaften eines Datenbankbenutzers
Anfang Ebene 4 Knoten Ändern des Kennworts eines Datenbankbenutzers Ändern des Kennworts eines Datenbankbenutzers Ende Ebene 4 Knoten Ändern des Kennworts eines Datenbankbenutzers
Anfang Ebene 4 Knoten Anlegen/Ändern/Löschen des Synchronisationsbenutzers Anlegen/Ändern/Löschen des Synchronisationsbenutzers Ende Ebene 4 Knoten Anlegen/Ändern/Löschen des Synchronisationsbenutzers
Anfang Ebene 3 Knoten Sichern Sichern Ende Ebene 3 Knoten Sichern
Anfang Ebene 4 Knoten Backup Wizard Backup Wizard Ende Ebene 4 Knoten Backup Wizard
Anfang Ebene 4 Knoten Verwalten der Sicherungsvorlagen Verwalten der Sicherungsvorlagen Ende Ebene 4 Knoten Verwalten der Sicherungsvorlagen
Anfang Ebene 5 Knoten Sicherungsvorlage für einen einzelnen Datenträger Sicherungsvorlage für einen einzelnen Datenträger Ende Ebene 5 Knoten Sicherungsvorlage für einen einzelnen Datenträger
Anfang Ebene 5 Knoten Sicherungsvorlage für eine Gruppe paralleler Datenträger Sicherungsvorlage für eine Gruppe paralleler Datenträger Ende Ebene 5 Knoten Sicherungsvorlage für eine Gruppe paralleler Datenträger
Anfang Ebene 5 Knoten Ändern von Sicherungsvorlagen Ändern von Sicherungsvorlagen Ende Ebene 5 Knoten Ändern von Sicherungsvorlagen
Anfang Ebene 5 Knoten Löschen von Sicherungsvorlagen Löschen von Sicherungsvorlagen Ende Ebene 5 Knoten Löschen von Sicherungsvorlagen
Anfang Ebene 4 Knoten Sicherungsverfahren Sicherungsverfahren Ende Ebene 4 Knoten Sicherungsverfahren
Anfang Ebene 5 Knoten Sichern auf einen einzelnen Datenträger Sichern auf einen einzelnen Datenträger Ende Ebene 5 Knoten Sichern auf einen einzelnen Datenträger
Anfang Ebene 5 Knoten Sichern auf eine Gruppe paralleler Datenträger Sichern auf eine Gruppe paralleler Datenträger Ende Ebene 5 Knoten Sichern auf eine Gruppe paralleler Datenträger
Anfang Ebene 5 Knoten Sichern mit automatischem Bandwechsler Sichern mit automatischem Bandwechsler Ende Ebene 5 Knoten Sichern mit automatischem Bandwechsler
Anfang Ebene 5 Knoten Sichern mit manuellem Datenträgerwechsel (Folgedatenträger) Sichern mit manuellem Datenträgerwechsel (Folgedatenträger) Ende Ebene 5 Knoten Sichern mit manuellem Datenträgerwechsel (Folgedatenträger)
Anfang Ebene 5 Knoten Sichern mit Sicherungswerkzeugen anderer Anbieter Sichern mit Sicherungswerkzeugen anderer Anbieter Ende Ebene 5 Knoten Sichern mit Sicherungswerkzeugen anderer Anbieter
Anfang Ebene 5 Knoten Ein- und Ausschalten der automatischen Log-Sicherung Ein- und Ausschalten der automatischen Log-Sicherung Ende Ebene 5 Knoten Ein- und Ausschalten der automatischen Log-Sicherung
Anfang Ebene 3 Knoten Wiederherstellen Wiederherstellen Ende Ebene 3 Knoten Wiederherstellen
Anfang Ebene 4 Knoten Recovery Wizard Recovery Wizard Ende Ebene 4 Knoten Recovery Wizard
Anfang Ebene 4 Knoten Wiederherstellen aus der zuletzt angefertigten Sicherung der Sic Wiederherstellen aus der zuletzt angefertigten Sicherung der Sic Ende Ebene 4 Knoten Wiederherstellen aus der zuletzt angefertigten Sicherung der Sic
Anfang Ebene 4 Knoten Wiederherstellen aus einer früheren Sicherung der Sicherungshist Wiederherstellen aus einer früheren Sicherung der Sicherungshist Ende Ebene 4 Knoten Wiederherstellen aus einer früheren Sicherung der Sicherungshist
Anfang Ebene 4 Knoten Wiederherstellen ohne Sicherungshistorie Wiederherstellen ohne Sicherungshistorie Ende Ebene 4 Knoten Wiederherstellen ohne Sicherungshistorie
Anfang Ebene 4 Knoten Fortsetzen einer unterbrochenen Wiederherstellung Fortsetzen einer unterbrochenen Wiederherstellung Ende Ebene 4 Knoten Fortsetzen einer unterbrochenen Wiederherstellung
Anfang Ebene 4 Knoten Wiederherstellen mit automatischem Bandwechsler Wiederherstellen mit automatischem Bandwechsler Ende Ebene 4 Knoten Wiederherstellen mit automatischem Bandwechsler
Anfang Ebene 4 Knoten Wiederherstellen mit Sicherungswerkzeugen anderer Anbieter Wiederherstellen mit Sicherungswerkzeugen anderer Anbieter Ende Ebene 4 Knoten Wiederherstellen mit Sicherungswerkzeugen anderer Anbieter
Anfang Ebene 4 Knoten Wiederherstellen nach Initialisieren einer Datenbankinstanz Wiederherstellen nach Initialisieren einer Datenbankinstanz Ende Ebene 4 Knoten Wiederherstellen nach Initialisieren einer Datenbankinstanz
Anfang Ebene 4 Knoten Wiederherstellen der Indizes nach Datenbankwiederherstellung Wiederherstellen der Indizes nach Datenbankwiederherstellung Ende Ebene 4 Knoten Wiederherstellen der Indizes nach Datenbankwiederherstellung
Anfang Ebene 4 Knoten Wiederherstellen eines gespiegelten Log-Volume Wiederherstellen eines gespiegelten Log-Volume Ende Ebene 4 Knoten Wiederherstellen eines gespiegelten Log-Volume
Anfang Ebene 3 Knoten Einfrieren des Datenbereichs (Snapshots) Einfrieren des Datenbereichs (Snapshots) Ende Ebene 3 Knoten Einfrieren des Datenbereichs (Snapshots)
Anfang Ebene 4 Knoten Erstellen eines Snapshot Erstellen eines Snapshot Ende Ebene 4 Knoten Erstellen eines Snapshot
Anfang Ebene 4 Knoten Zurückkehren zum Snapshot Zurückkehren zum Snapshot Ende Ebene 4 Knoten Zurückkehren zum Snapshot
Anfang Ebene 4 Knoten Löschen des Snapshot Löschen des Snapshot Ende Ebene 4 Knoten Löschen des Snapshot
Anfang Ebene 3 Knoten Anzeigen von Informationen Anzeigen von Informationen Ende Ebene 3 Knoten Anzeigen von Informationen
Anfang Ebene 4 Knoten Sicherungshistorie anzeigen Sicherungshistorie anzeigen Ende Ebene 4 Knoten Sicherungshistorie anzeigen
Anfang Ebene 4 Knoten Cache-Informationen anzeigen Cache-Informationen anzeigen Ende Ebene 4 Knoten Cache-Informationen anzeigen
Anfang Ebene 4 Knoten Datenbereichs-Informationen anzeigen Datenbereichs-Informationen anzeigen Ende Ebene 4 Knoten Datenbereichs-Informationen anzeigen
Anfang Ebene 4 Knoten Datenbankaktivitäten anzeigen Datenbankaktivitäten anzeigen Ende Ebene 4 Knoten Datenbankaktivitäten anzeigen
Anfang Ebene 4 Knoten Datenbankparameter anzeigen Datenbankparameter anzeigen Ende Ebene 4 Knoten Datenbankparameter anzeigen
Anfang Ebene 4 Knoten Datenbanksitzungen anzeigen Datenbanksitzungen anzeigen Ende Ebene 4 Knoten Datenbanksitzungen anzeigen
Anfang Ebene 4 Knoten Log-Bereichs-Informationen anzeigen Log-Bereichs-Informationen anzeigen Ende Ebene 4 Knoten Log-Bereichs-Informationen anzeigen
Anfang Ebene 4 Knoten Systemtabellen anzeigen Systemtabellen anzeigen Ende Ebene 4 Knoten Systemtabellen anzeigen
Anfang Ebene 3 Knoten Diagnosemöglichkeiten Diagnosemöglichkeiten Ende Ebene 3 Knoten Diagnosemöglichkeiten
Anfang Ebene 4 Knoten Sicherung prüfen Sicherung prüfen Ende Ebene 4 Knoten Sicherung prüfen
Anfang Ebene 4 Knoten Database Analyzer-Informationen anzeigen und löschen Database Analyzer-Informationen anzeigen und löschen Ende Ebene 4 Knoten Database Analyzer-Informationen anzeigen und löschen
Anfang Ebene 4 Knoten Datenbankrechner prüfen Datenbankrechner prüfen Ende Ebene 4 Knoten Datenbankrechner prüfen
Anfang Ebene 4 Knoten Protokolldateien lesen Protokolldateien lesen Ende Ebene 4 Knoten Protokolldateien lesen
Anfang Ebene 4 Knoten Datenbankstrukturen prüfen Datenbankstrukturen prüfen Ende Ebene 4 Knoten Datenbankstrukturen prüfen
Anfang Ebene 4 Knoten Datenbank-Trace verwenden Datenbank-Trace verwenden Ende Ebene 4 Knoten Datenbank-Trace verwenden
Anfang Ebene 4 Knoten OMS-Caches anzeigen OMS-Caches anzeigen Ende Ebene 4 Knoten OMS-Caches anzeigen
Anfang Ebene 4 Knoten OMS-Klassencontainer anzeigen OMS-Klassencontainer anzeigen Ende Ebene 4 Knoten OMS-Klassencontainer anzeigen
Anfang Ebene 4 Knoten OMS-Monitor einschalten OMS-Monitor einschalten Ende Ebene 4 Knoten OMS-Monitor einschalten
Anfang Ebene 3 Knoten Update der Datenbanksoftware Update der Datenbanksoftware Ende Ebene 3 Knoten Update der Datenbanksoftware
Anfang Ebene 4 Knoten Aktualisieren der Systemtabellen Aktualisieren der Systemtabellen Ende Ebene 4 Knoten Aktualisieren der Systemtabellen
Anfang Ebene 3 Knoten SQL Studio verwenden SQL Studio verwenden Ende Ebene 3 Knoten SQL Studio verwenden
Anfang Ebene 3 Knoten Database Manager CLI verwenden Database Manager CLI verwenden Ende Ebene 3 Knoten Database Manager CLI verwenden
Anfang Ebene 2 Knoten Database Manager CLI Database Manager CLI Ende Ebene 2 Knoten Database Manager CLI
Anfang Ebene 3 Knoten Funktionsweise des Database Manager CLI Funktionsweise des Database Manager CLI Ende Ebene 3 Knoten Funktionsweise des Database Manager CLI
Anfang Ebene 4 Knoten Aufrufen des Database Manager CLI Aufrufen des Database Manager CLI Ende Ebene 4 Knoten Aufrufen des Database Manager CLI
Anfang Ebene 5 Knoten DBM-Optionen DBM-Optionen Ende Ebene 5 Knoten DBM-Optionen
Anfang Ebene 6 Knoten -c: Kennzeichnen als DBM-Kommando -c: Kennzeichnen als DBM-Kommando Ende Ebene 6 Knoten -c: Kennzeichnen als DBM-Kommando
Anfang Ebene 6 Knoten -d: Name der Datenbankinstanz -d: Name der Datenbankinstanz Ende Ebene 6 Knoten -d: Name der Datenbankinstanz
Anfang Ebene 6 Knoten -e: Verschlüsselung aktivieren -e: Verschlüsselung aktivieren Ende Ebene 6 Knoten -e: Verschlüsselung aktivieren
Anfang Ebene 6 Knoten -i | -ic | -is | -ics: Name des Eingabeskripts -i | -ic | -is | -ics: Name des Eingabeskripts Ende Ebene 6 Knoten -i | -ic | -is | -ics: Name des Eingabeskripts
Anfang Ebene 6 Knoten -n: Name des Datenbankrechners -n: Name des Datenbankrechners Ende Ebene 6 Knoten -n: Name des Datenbankrechners
Anfang Ebene 6 Knoten -o: Name der Ausgabedatei -o: Name der Ausgabedatei Ende Ebene 6 Knoten -o: Name der Ausgabedatei
Anfang Ebene 6 Knoten -R: Installationsverzeichnis der Datenbanksoftware -R: Installationsverzeichnis der Datenbanksoftware Ende Ebene 6 Knoten -R: Installationsverzeichnis der Datenbanksoftware
Anfang Ebene 6 Knoten -t: Name der Protokolldatei -t: Name der Protokolldatei Ende Ebene 6 Knoten -t: Name der Protokolldatei
Anfang Ebene 6 Knoten -uSQL: Eröffnen einer SQL-Sitzung -uSQL: Eröffnen einer SQL-Sitzung Ende Ebene 6 Knoten -uSQL: Eröffnen einer SQL-Sitzung
Anfang Ebene 6 Knoten -uSRV: Eröffnen einer Servicesitzung -uSRV: Eröffnen einer Servicesitzung Ende Ebene 6 Knoten -uSRV: Eröffnen einer Servicesitzung
Anfang Ebene 6 Knoten -uUTL: Eröffnen einer Utility-Sitzung -uUTL: Eröffnen einer Utility-Sitzung Ende Ebene 6 Knoten -uUTL: Eröffnen einer Utility-Sitzung
Anfang Ebene 6 Knoten -ud: Löschen von XUSER-Einträgen -ud: Löschen von XUSER-Einträgen Ende Ebene 6 Knoten -ud: Löschen von XUSER-Einträgen
Anfang Ebene 6 Knoten -uk: Benutzerschlüssel -uk: Benutzerschlüssel Ende Ebene 6 Knoten -uk: Benutzerschlüssel
Anfang Ebene 6 Knoten -us: Anlegen oder Ändern von XUSER-Einträgen -us: Anlegen oder Ändern von XUSER-Einträgen Ende Ebene 6 Knoten -us: Anlegen oder Ändern von XUSER-Einträgen
Anfang Ebene 6 Knoten -ux: Anmelden an das Programm XUSER -ux: Anmelden an das Programm XUSER Ende Ebene 6 Knoten -ux: Anmelden an das Programm XUSER
Anfang Ebene 6 Knoten -ul: Anzeigen von XUSER-Daten -ul: Anzeigen von XUSER-Daten Ende Ebene 6 Knoten -ul: Anzeigen von XUSER-Daten
Anfang Ebene 5 Knoten DBM-Kommandos DBM-Kommandos Ende Ebene 5 Knoten DBM-Kommandos
Anfang Ebene 5 Knoten Betriebsmodi im Database Manager Betriebsmodi im Database Manager Ende Ebene 5 Knoten Betriebsmodi im Database Manager
Anfang Ebene 5 Knoten Eingabehilfen Eingabehilfen Ende Ebene 5 Knoten Eingabehilfen
Anfang Ebene 6 Knoten Kommentar: # Kommentar: # Ende Ebene 6 Knoten Kommentar: #
Anfang Ebene 6 Knoten Lokaler Systemaufruf: ! Lokaler Systemaufruf: ! Ende Ebene 6 Knoten Lokaler Systemaufruf: !
Anfang Ebene 6 Knoten Zeilenverknüpfung: / Zeilenverknüpfung: / Ende Ebene 6 Knoten Zeilenverknüpfung: /
Anfang Ebene 6 Knoten Zeilenverknüpfung: < Zeilenverknüpfung: < Ende Ebene 6 Knoten Zeilenverknüpfung: <
Anfang Ebene 4 Knoten Antwortformat Antwortformat Ende Ebene 4 Knoten Antwortformat
Anfang Ebene 3 Knoten Kommandoreferenz für das Arbeiten mit dem Database Manager CLI Kommandoreferenz für das Arbeiten mit dem Database Manager CLI Ende Ebene 3 Knoten Kommandoreferenz für das Arbeiten mit dem Database Manager CLI
Anfang Ebene 4 Knoten Hilfe zum Database Manager Hilfe zum Database Manager Ende Ebene 4 Knoten Hilfe zum Database Manager
Anfang Ebene 5 Knoten Weitere Kommandos für die Hilfe zum Database Manager Weitere Kommandos für die Hilfe zum Database Manager Ende Ebene 5 Knoten Weitere Kommandos für die Hilfe zum Database Manager
Anfang Ebene 4 Knoten Softwareinstallation Softwareinstallation Ende Ebene 4 Knoten Softwareinstallation
Anfang Ebene 5 Knoten Weitere Kommandos zur Softwareinstallation Weitere Kommandos zur Softwareinstallation Ende Ebene 5 Knoten Weitere Kommandos zur Softwareinstallation
Anfang Ebene 4 Knoten Anlegen und Löschen der Datenbankinstanz Anlegen und Löschen der Datenbankinstanz Ende Ebene 4 Knoten Anlegen und Löschen der Datenbankinstanz
Anfang Ebene 5 Knoten Weitere Kommandos für das Anlegen und Löschen der Datenbankinsta Weitere Kommandos für das Anlegen und Löschen der Datenbankinsta Ende Ebene 5 Knoten Weitere Kommandos für das Anlegen und Löschen der Datenbankinsta
Anfang Ebene 4 Knoten Konfigurieren der Datenbankinstanz Konfigurieren der Datenbankinstanz Ende Ebene 4 Knoten Konfigurieren der Datenbankinstanz
Anfang Ebene 5 Knoten Weitere Kommandos für das Konfigurieren der Volumes Weitere Kommandos für das Konfigurieren der Volumes Ende Ebene 5 Knoten Weitere Kommandos für das Konfigurieren der Volumes
Anfang Ebene 5 Knoten Kommandos für das Ändern der Datenbankparameter Kommandos für das Ändern der Datenbankparameter Ende Ebene 5 Knoten Kommandos für das Ändern der Datenbankparameter
Anfang Ebene 4 Knoten Steuern der Datenbankinstanz Steuern der Datenbankinstanz Ende Ebene 4 Knoten Steuern der Datenbankinstanz
Anfang Ebene 5 Knoten Weitere Kommandos für das Steuern der Datenbankinstanz Weitere Kommandos für das Steuern der Datenbankinstanz Ende Ebene 5 Knoten Weitere Kommandos für das Steuern der Datenbankinstanz
Anfang Ebene 4 Knoten Sichern und Wiederherstellen der Datenbankinstanz Sichern und Wiederherstellen der Datenbankinstanz Ende Ebene 4 Knoten Sichern und Wiederherstellen der Datenbankinstanz
Anfang Ebene 5 Knoten Weitere Kommandos für Sicherungsvorlagen Weitere Kommandos für Sicherungsvorlagen Ende Ebene 5 Knoten Weitere Kommandos für Sicherungsvorlagen
Anfang Ebene 5 Knoten Weitere Kommandos zum Sichern Weitere Kommandos zum Sichern Ende Ebene 5 Knoten Weitere Kommandos zum Sichern
Anfang Ebene 5 Knoten Weitere Kommandos zu Informationen über Sicherungen Weitere Kommandos zu Informationen über Sicherungen Ende Ebene 5 Knoten Weitere Kommandos zu Informationen über Sicherungen
Anfang Ebene 5 Knoten Weitere Kommandos zum Wiederherstellen Weitere Kommandos zum Wiederherstellen Ende Ebene 5 Knoten Weitere Kommandos zum Wiederherstellen
Anfang Ebene 4 Knoten Verwalten der Database Manager-Benutzer Verwalten der Database Manager-Benutzer Ende Ebene 4 Knoten Verwalten der Database Manager-Benutzer
Anfang Ebene 5 Knoten Weitere Kommandos zum Verwalten der Database Manager-Benutzer Weitere Kommandos zum Verwalten der Database Manager-Benutzer Ende Ebene 5 Knoten Weitere Kommandos zum Verwalten der Database Manager-Benutzer
Anfang Ebene 4 Knoten Analysieren der Datenbankinstanz Analysieren der Datenbankinstanz Ende Ebene 4 Knoten Analysieren der Datenbankinstanz
Anfang Ebene 5 Knoten Kommandos für die Datenbank-Trace-Funktion Kommandos für die Datenbank-Trace-Funktion Ende Ebene 5 Knoten Kommandos für die Datenbank-Trace-Funktion
Anfang Ebene 5 Knoten Kommandos für den Zugriff auf Datenbankdateien Kommandos für den Zugriff auf Datenbankdateien Ende Ebene 5 Knoten Kommandos für den Zugriff auf Datenbankdateien
Anfang Ebene 5 Knoten Kommandos für die Verwendung des Database Analyzer Kommandos für die Verwendung des Database Analyzer Ende Ebene 5 Knoten Kommandos für die Verwendung des Database Analyzer
Anfang Ebene 4 Knoten SQL-Zugriffe auf die Datenbankinstanz SQL-Zugriffe auf die Datenbankinstanz Ende Ebene 4 Knoten SQL-Zugriffe auf die Datenbankinstanz
Anfang Ebene 5 Knoten Weitere Kommandos für SQL-Zugriffe auf die Datenbankinstanz Weitere Kommandos für SQL-Zugriffe auf die Datenbankinstanz Ende Ebene 5 Knoten Weitere Kommandos für SQL-Zugriffe auf die Datenbankinstanz
Anfang Ebene 4 Knoten Optimieren von SQL-Zugriffen auf die Datenbankinstanz Optimieren von SQL-Zugriffen auf die Datenbankinstanz Ende Ebene 4 Knoten Optimieren von SQL-Zugriffen auf die Datenbankinstanz
Anfang Ebene 4 Knoten Nutzen von Events der Datenbankinstanz Nutzen von Events der Datenbankinstanz Ende Ebene 4 Knoten Nutzen von Events der Datenbankinstanz
Anfang Ebene 5 Knoten Weitere Kommandos für das Nutzen von Events der Datenbankinstanz Weitere Kommandos für das Nutzen von Events der Datenbankinstanz Ende Ebene 5 Knoten Weitere Kommandos für das Nutzen von Events der Datenbankinstanz
Anfang Ebene 4 Knoten Verwenden des Scheduler Verwenden des Scheduler Ende Ebene 4 Knoten Verwenden des Scheduler
Anfang Ebene 5 Knoten Weitere Kommandos für das Verwenden des Scheduler Weitere Kommandos für das Verwenden des Scheduler Ende Ebene 5 Knoten Weitere Kommandos für das Verwenden des Scheduler
Anfang Ebene 4 Knoten Verwalten von Hot-Standby-Systemen Verwalten von Hot-Standby-Systemen Ende Ebene 4 Knoten Verwalten von Hot-Standby-Systemen
Anfang Ebene 5 Knoten Kommandos für das Verwalten von Hot-Standby-Systemen Kommandos für das Verwalten von Hot-Standby-Systemen Ende Ebene 5 Knoten Kommandos für das Verwalten von Hot-Standby-Systemen
Anfang Ebene 4 Knoten Einstellungen des Database Manager Einstellungen des Database Manager Ende Ebene 4 Knoten Einstellungen des Database Manager
Anfang Ebene 5 Knoten Weitere Kommandos zu den Einstellungen des Database Manager Weitere Kommandos zu den Einstellungen des Database Manager Ende Ebene 5 Knoten Weitere Kommandos zu den Einstellungen des Database Manager
Anfang Ebene 3 Knoten Übersicht aller DBM-Kommandos Übersicht aller DBM-Kommandos Ende Ebene 3 Knoten Übersicht aller DBM-Kommandos
Anfang Ebene 4 Knoten apropos apropos Ende Ebene 4 Knoten apropos
Anfang Ebene 4 Knoten archive_stage archive_stage Ende Ebene 4 Knoten archive_stage
Anfang Ebene 4 Knoten archive_stage_repeat archive_stage_repeat Ende Ebene 4 Knoten archive_stage_repeat
Anfang Ebene 4 Knoten auto_extend auto_extend Ende Ebene 4 Knoten auto_extend
Anfang Ebene 4 Knoten auto_update_statistics auto_update_statistics Ende Ebene 4 Knoten auto_update_statistics
Anfang Ebene 4 Knoten autolog_cancel autolog_cancel Ende Ebene 4 Knoten autolog_cancel
Anfang Ebene 4 Knoten autolog_off autolog_off Ende Ebene 4 Knoten autolog_off
Anfang Ebene 4 Knoten autolog_on autolog_on Ende Ebene 4 Knoten autolog_on
Anfang Ebene 4 Knoten autolog_show autolog_show Ende Ebene 4 Knoten autolog_show
Anfang Ebene 4 Knoten autorecover autorecover Ende Ebene 4 Knoten autorecover
Anfang Ebene 4 Knoten backup_cancel backup_cancel Ende Ebene 4 Knoten backup_cancel
Anfang Ebene 4 Knoten backup_cancel_req backup_cancel_req Ende Ebene 4 Knoten backup_cancel_req
Anfang Ebene 4 Knoten backup_ext_ids_forget backup_ext_ids_forget Ende Ebene 4 Knoten backup_ext_ids_forget
Anfang Ebene 4 Knoten backup_ext_ids_get backup_ext_ids_get Ende Ebene 4 Knoten backup_ext_ids_get
Anfang Ebene 4 Knoten backup_ext_ids_getfromtool backup_ext_ids_getfromtool Ende Ebene 4 Knoten backup_ext_ids_getfromtool
Anfang Ebene 4 Knoten backup_ext_ids_list backup_ext_ids_list Ende Ebene 4 Knoten backup_ext_ids_list
Anfang Ebene 4 Knoten backup_ext_ids_listnext backup_ext_ids_listnext Ende Ebene 4 Knoten backup_ext_ids_listnext
Anfang Ebene 4 Knoten backup_history_append backup_history_append Ende Ebene 4 Knoten backup_history_append
Anfang Ebene 4 Knoten backup_history_close backup_history_close Ende Ebene 4 Knoten backup_history_close
Anfang Ebene 4 Knoten backup_history_date backup_history_date Ende Ebene 4 Knoten backup_history_date
Anfang Ebene 4 Knoten backup_history_list backup_history_list Ende Ebene 4 Knoten backup_history_list
Anfang Ebene 4 Knoten backup_history_listnext backup_history_listnext Ende Ebene 4 Knoten backup_history_listnext
Anfang Ebene 4 Knoten backup_history_open backup_history_open Ende Ebene 4 Knoten backup_history_open
Anfang Ebene 4 Knoten backup_ignore backup_ignore Ende Ebene 4 Knoten backup_ignore
Anfang Ebene 4 Knoten backup_ignore_req backup_ignore_req Ende Ebene 4 Knoten backup_ignore_req
Anfang Ebene 4 Knoten backup_replace backup_replace Ende Ebene 4 Knoten backup_replace
Anfang Ebene 4 Knoten backup_replace_req backup_replace_req Ende Ebene 4 Knoten backup_replace_req
Anfang Ebene 4 Knoten backup_reply_available backup_reply_available Ende Ebene 4 Knoten backup_reply_available
Anfang Ebene 4 Knoten backup_reply_receive backup_reply_receive Ende Ebene 4 Knoten backup_reply_receive
Anfang Ebene 4 Knoten backup_req backup_req Ende Ebene 4 Knoten backup_req
Anfang Ebene 4 Knoten backup_start backup_start Ende Ebene 4 Knoten backup_start
Anfang Ebene 4 Knoten backup_state backup_state Ende Ebene 4 Knoten backup_state
Anfang Ebene 4 Knoten bye | exit | quit | release bye | exit | quit | release Ende Ebene 4 Knoten bye | exit | quit | release
Anfang Ebene 4 Knoten db_activate db_activate Ende Ebene 4 Knoten db_activate
Anfang Ebene 4 Knoten db_activate RECOVER db_activate RECOVER Ende Ebene 4 Knoten db_activate RECOVER
Anfang Ebene 4 Knoten db_activate_req db_activate_req Ende Ebene 4 Knoten db_activate_req
Anfang Ebene 4 Knoten db_addvolume db_addvolume Ende Ebene 4 Knoten db_addvolume
Anfang Ebene 4 Knoten db_admin db_admin Ende Ebene 4 Knoten db_admin
Anfang Ebene 4 Knoten db_clear db_clear Ende Ebene 4 Knoten db_clear
Anfang Ebene 4 Knoten db_connect db_connect Ende Ebene 4 Knoten db_connect
Anfang Ebene 4 Knoten db_cons db_cons Ende Ebene 4 Knoten db_cons
Anfang Ebene 4 Knoten db_create db_create Ende Ebene 4 Knoten db_create
Anfang Ebene 4 Knoten db_deletevolume db_deletevolume Ende Ebene 4 Knoten db_deletevolume
Anfang Ebene 4 Knoten db_drop db_drop Ende Ebene 4 Knoten db_drop
Anfang Ebene 4 Knoten db_enum db_enum Ende Ebene 4 Knoten db_enum
Anfang Ebene 4 Knoten db_execute db_execute Ende Ebene 4 Knoten db_execute
Anfang Ebene 4 Knoten db_executenice db_executenice Ende Ebene 4 Knoten db_executenice
Anfang Ebene 4 Knoten db_fetch db_fetch Ende Ebene 4 Knoten db_fetch
Anfang Ebene 4 Knoten db_fetchnice db_fetchnice Ende Ebene 4 Knoten db_fetchnice
Anfang Ebene 4 Knoten db_migratecatalog db_migratecatalog Ende Ebene 4 Knoten db_migratecatalog
Anfang Ebene 4 Knoten db_offline db_offline Ende Ebene 4 Knoten db_offline
Anfang Ebene 4 Knoten db_online db_online Ende Ebene 4 Knoten db_online
Anfang Ebene 4 Knoten db_reg db_reg Ende Ebene 4 Knoten db_reg
Anfang Ebene 4 Knoten db_reinstall db_reinstall Ende Ebene 4 Knoten db_reinstall
Anfang Ebene 4 Knoten db_release db_release Ende Ebene 4 Knoten db_release
Anfang Ebene 4 Knoten db_restart db_restart Ende Ebene 4 Knoten db_restart
Anfang Ebene 4 Knoten db_restartinfo db_restartinfo Ende Ebene 4 Knoten db_restartinfo
Anfang Ebene 4 Knoten db_speed db_speed Ende Ebene 4 Knoten db_speed
Anfang Ebene 4 Knoten db_standby db_standby Ende Ebene 4 Knoten db_standby
Anfang Ebene 4 Knoten db_state db_state Ende Ebene 4 Knoten db_state
Anfang Ebene 4 Knoten db_stop db_stop Ende Ebene 4 Knoten db_stop
Anfang Ebene 4 Knoten dban_delete dban_delete Ende Ebene 4 Knoten dban_delete
Anfang Ebene 4 Knoten dban_start dban_start Ende Ebene 4 Knoten dban_start
Anfang Ebene 4 Knoten dban_state dban_state Ende Ebene 4 Knoten dban_state
Anfang Ebene 4 Knoten dban_stop dban_stop Ende Ebene 4 Knoten dban_stop
Anfang Ebene 4 Knoten dbm_configget dbm_configget Ende Ebene 4 Knoten dbm_configget
Anfang Ebene 4 Knoten dbm_configset dbm_configset Ende Ebene 4 Knoten dbm_configset
Anfang Ebene 4 Knoten dbm_execute_serverprocess dbm_execute_serverprocess Ende Ebene 4 Knoten dbm_execute_serverprocess
Anfang Ebene 4 Knoten dbm_getpath dbm_getpath Ende Ebene 4 Knoten dbm_getpath
Anfang Ebene 4 Knoten dbm_getpid dbm_getpid Ende Ebene 4 Knoten dbm_getpid
Anfang Ebene 4 Knoten dbm_listmemoryerror dbm_listmemoryerror Ende Ebene 4 Knoten dbm_listmemoryerror
Anfang Ebene 4 Knoten dbm_next dbm_next Ende Ebene 4 Knoten dbm_next
Anfang Ebene 4 Knoten dbm_setpath dbm_setpath Ende Ebene 4 Knoten dbm_setpath
Anfang Ebene 4 Knoten dbm_shm_info dbm_shm_info Ende Ebene 4 Knoten dbm_shm_info
Anfang Ebene 4 Knoten dbm_shm_reset dbm_shm_reset Ende Ebene 4 Knoten dbm_shm_reset
Anfang Ebene 4 Knoten dbm_shm_unlock dbm_shm_unlock Ende Ebene 4 Knoten dbm_shm_unlock
Anfang Ebene 4 Knoten dbm_version dbm_version Ende Ebene 4 Knoten dbm_version
Anfang Ebene 4 Knoten dbmevtdisp_internal_add dbmevtdisp_internal_add Ende Ebene 4 Knoten dbmevtdisp_internal_add
Anfang Ebene 4 Knoten dbmevtdisp_internal_communication dbmevtdisp_internal_communication Ende Ebene 4 Knoten dbmevtdisp_internal_communication
Anfang Ebene 4 Knoten dbmevtdisp_internal_delete dbmevtdisp_internal_delete Ende Ebene 4 Knoten dbmevtdisp_internal_delete
Anfang Ebene 4 Knoten diag_histlist diag_histlist Ende Ebene 4 Knoten diag_histlist
Anfang Ebene 4 Knoten diag_pack diag_pack Ende Ebene 4 Knoten diag_pack
Anfang Ebene 4 Knoten event_available event_available Ende Ebene 4 Knoten event_available
Anfang Ebene 4 Knoten event_delete event_delete Ende Ebene 4 Knoten event_delete
Anfang Ebene 4 Knoten event_list event_list Ende Ebene 4 Knoten event_list
Anfang Ebene 4 Knoten event_list_categories event_list_categories Ende Ebene 4 Knoten event_list_categories
Anfang Ebene 4 Knoten event_receive event_receive Ende Ebene 4 Knoten event_receive
Anfang Ebene 4 Knoten event_release event_release Ende Ebene 4 Knoten event_release
Anfang Ebene 4 Knoten event_set event_set Ende Ebene 4 Knoten event_set
Anfang Ebene 4 Knoten event_wait event_wait Ende Ebene 4 Knoten event_wait
Anfang Ebene 4 Knoten exec_lcinit exec_lcinit Ende Ebene 4 Knoten exec_lcinit
Anfang Ebene 4 Knoten exec_nipingsrv exec_nipingsrv Ende Ebene 4 Knoten exec_nipingsrv
Anfang Ebene 4 Knoten exec_sdbinfo exec_sdbinfo Ende Ebene 4 Knoten exec_sdbinfo
Anfang Ebene 4 Knoten explain explain Ende Ebene 4 Knoten explain
Anfang Ebene 4 Knoten file_backup file_backup Ende Ebene 4 Knoten file_backup
Anfang Ebene 4 Knoten file_getfirst file_getfirst Ende Ebene 4 Knoten file_getfirst
Anfang Ebene 4 Knoten file_getlist file_getlist Ende Ebene 4 Knoten file_getlist
Anfang Ebene 4 Knoten file_getnext file_getnext Ende Ebene 4 Knoten file_getnext
Anfang Ebene 4 Knoten file_operation file_operation Ende Ebene 4 Knoten file_operation
Anfang Ebene 4 Knoten file_restore file_restore Ende Ebene 4 Knoten file_restore
Anfang Ebene 4 Knoten get_default get_default Ende Ebene 4 Knoten get_default
Anfang Ebene 4 Knoten help help Ende Ebene 4 Knoten help
Anfang Ebene 4 Knoten hss_addstandby hss_addstandby Ende Ebene 4 Knoten hss_addstandby
Anfang Ebene 4 Knoten hss_copyfile hss_copyfile Ende Ebene 4 Knoten hss_copyfile
Anfang Ebene 4 Knoten hss_enable hss_enable Ende Ebene 4 Knoten hss_enable
Anfang Ebene 4 Knoten hss_execute hss_execute Ende Ebene 4 Knoten hss_execute
Anfang Ebene 4 Knoten hss_getnodes hss_getnodes Ende Ebene 4 Knoten hss_getnodes
Anfang Ebene 4 Knoten hss_removestandby hss_removestandby Ende Ebene 4 Knoten hss_removestandby
Anfang Ebene 4 Knoten info info Ende Ebene 4 Knoten info
Anfang Ebene 4 Knoten info_next info_next Ende Ebene 4 Knoten info_next
Anfang Ebene 4 Knoten inst_enum inst_enum Ende Ebene 4 Knoten inst_enum
Anfang Ebene 4 Knoten inst_info inst_info Ende Ebene 4 Knoten inst_info
Anfang Ebene 4 Knoten inst_reg inst_reg Ende Ebene 4 Knoten inst_reg
Anfang Ebene 4 Knoten inst_unreg inst_unreg Ende Ebene 4 Knoten inst_unreg
Anfang Ebene 4 Knoten load_lcapps load_lcapps Ende Ebene 4 Knoten load_lcapps
Anfang Ebene 4 Knoten load_r3tab load_r3tab Ende Ebene 4 Knoten load_r3tab
Anfang Ebene 4 Knoten load_systab load_systab Ende Ebene 4 Knoten load_systab
Anfang Ebene 4 Knoten load_tutorial load_tutorial Ende Ebene 4 Knoten load_tutorial
Anfang Ebene 4 Knoten medium_date medium_date Ende Ebene 4 Knoten medium_date
Anfang Ebene 4 Knoten medium_delete medium_delete Ende Ebene 4 Knoten medium_delete
Anfang Ebene 4 Knoten medium_delete_nodistribute medium_delete_nodistribute Ende Ebene 4 Knoten medium_delete_nodistribute
Anfang Ebene 4 Knoten medium_get medium_get Ende Ebene 4 Knoten medium_get
Anfang Ebene 4 Knoten medium_getall medium_getall Ende Ebene 4 Knoten medium_getall
Anfang Ebene 4 Knoten medium_label medium_label Ende Ebene 4 Knoten medium_label
Anfang Ebene 4 Knoten medium_labeloffline medium_labeloffline Ende Ebene 4 Knoten medium_labeloffline
Anfang Ebene 4 Knoten medium_migrate medium_migrate Ende Ebene 4 Knoten medium_migrate
Anfang Ebene 4 Knoten medium_put medium_put Ende Ebene 4 Knoten medium_put
Anfang Ebene 4 Knoten medium_put_nodistribute medium_put_nodistribute Ende Ebene 4 Knoten medium_put_nodistribute
Anfang Ebene 4 Knoten package_info package_info Ende Ebene 4 Knoten package_info
Anfang Ebene 4 Knoten param_abortsession param_abortsession Ende Ebene 4 Knoten param_abortsession
Anfang Ebene 4 Knoten param_addvolume param_addvolume Ende Ebene 4 Knoten param_addvolume
Anfang Ebene 4 Knoten param_checkall param_checkall Ende Ebene 4 Knoten param_checkall
Anfang Ebene 4 Knoten param_commitsession param_commitsession Ende Ebene 4 Knoten param_commitsession
Anfang Ebene 4 Knoten param_copy param_copy Ende Ebene 4 Knoten param_copy
Anfang Ebene 4 Knoten param_delvolume param_delvolume Ende Ebene 4 Knoten param_delvolume
Anfang Ebene 4 Knoten param_directdel param_directdel Ende Ebene 4 Knoten param_directdel
Anfang Ebene 4 Knoten param_directget param_directget Ende Ebene 4 Knoten param_directget
Anfang Ebene 4 Knoten param_directgetall param_directgetall Ende Ebene 4 Knoten param_directgetall
Anfang Ebene 4 Knoten param_directgetallnext param_directgetallnext Ende Ebene 4 Knoten param_directgetallnext
Anfang Ebene 4 Knoten param_directput param_directput Ende Ebene 4 Knoten param_directput
Anfang Ebene 4 Knoten param_extget param_extget Ende Ebene 4 Knoten param_extget
Anfang Ebene 4 Knoten param_extgetall param_extgetall Ende Ebene 4 Knoten param_extgetall
Anfang Ebene 4 Knoten param_extgetallnext param_extgetallnext Ende Ebene 4 Knoten param_extgetallnext
Anfang Ebene 4 Knoten param_getdefault param_getdefault Ende Ebene 4 Knoten param_getdefault
Anfang Ebene 4 Knoten param_getexplain param_getexplain Ende Ebene 4 Knoten param_getexplain
Anfang Ebene 4 Knoten param_getfull param_getfull Ende Ebene 4 Knoten param_getfull
Anfang Ebene 4 Knoten param_gethelp param_gethelp Ende Ebene 4 Knoten param_gethelp
Anfang Ebene 4 Knoten param_gethistory param_gethistory Ende Ebene 4 Knoten param_gethistory
Anfang Ebene 4 Knoten param_gethistorynext param_gethistorynext Ende Ebene 4 Knoten param_gethistorynext
Anfang Ebene 4 Knoten param_getproperties param_getproperties Ende Ebene 4 Knoten param_getproperties
Anfang Ebene 4 Knoten param_gettype param_gettype Ende Ebene 4 Knoten param_gettype
Anfang Ebene 4 Knoten param_getvalue param_getvalue Ende Ebene 4 Knoten param_getvalue
Anfang Ebene 4 Knoten param_getvolsall param_getvolsall Ende Ebene 4 Knoten param_getvolsall
Anfang Ebene 4 Knoten param_getvolume param_getvolume Ende Ebene 4 Knoten param_getvolume
Anfang Ebene 4 Knoten param_init param_init Ende Ebene 4 Knoten param_init
Anfang Ebene 4 Knoten param_put param_put Ende Ebene 4 Knoten param_put
Anfang Ebene 4 Knoten param_restore param_restore Ende Ebene 4 Knoten param_restore
Anfang Ebene 4 Knoten param_rmfile param_rmfile Ende Ebene 4 Knoten param_rmfile
Anfang Ebene 4 Knoten param_startsession param_startsession Ende Ebene 4 Knoten param_startsession
Anfang Ebene 4 Knoten param_versions param_versions Ende Ebene 4 Knoten param_versions
Anfang Ebene 4 Knoten recover_cancel recover_cancel Ende Ebene 4 Knoten recover_cancel
Anfang Ebene 4 Knoten recover_cancel_req recover_cancel_req Ende Ebene 4 Knoten recover_cancel_req
Anfang Ebene 4 Knoten recover_check recover_check Ende Ebene 4 Knoten recover_check
Anfang Ebene 4 Knoten recover_check_req recover_check_req Ende Ebene 4 Knoten recover_check_req
Anfang Ebene 4 Knoten recover_config recover_config Ende Ebene 4 Knoten recover_config
Anfang Ebene 4 Knoten recover_ignore recover_ignore Ende Ebene 4 Knoten recover_ignore
Anfang Ebene 4 Knoten recover_ignore_req recover_ignore_req Ende Ebene 4 Knoten recover_ignore_req
Anfang Ebene 4 Knoten recover_replace recover_replace Ende Ebene 4 Knoten recover_replace
Anfang Ebene 4 Knoten recover_replace_req recover_replace_req Ende Ebene 4 Knoten recover_replace_req
Anfang Ebene 4 Knoten recover_req recover_req Ende Ebene 4 Knoten recover_req
Anfang Ebene 4 Knoten recover_start recover_start Ende Ebene 4 Knoten recover_start
Anfang Ebene 4 Knoten recover_state recover_state Ende Ebene 4 Knoten recover_state
Anfang Ebene 4 Knoten recover_state_check recover_state_check Ende Ebene 4 Knoten recover_state_check
Anfang Ebene 4 Knoten recover_volume recover_volume Ende Ebene 4 Knoten recover_volume
Anfang Ebene 4 Knoten scheduler_activate_job scheduler_activate_job Ende Ebene 4 Knoten scheduler_activate_job
Anfang Ebene 4 Knoten scheduler_create_job scheduler_create_job Ende Ebene 4 Knoten scheduler_create_job
Anfang Ebene 4 Knoten scheduler_deactivate_job scheduler_deactivate_job Ende Ebene 4 Knoten scheduler_deactivate_job
Anfang Ebene 4 Knoten scheduler_delete_job scheduler_delete_job Ende Ebene 4 Knoten scheduler_delete_job
Anfang Ebene 4 Knoten scheduler_list_jobs scheduler_list_jobs Ende Ebene 4 Knoten scheduler_list_jobs
Anfang Ebene 4 Knoten scheduler_start scheduler_start Ende Ebene 4 Knoten scheduler_start
Anfang Ebene 4 Knoten scheduler_state scheduler_state Ende Ebene 4 Knoten scheduler_state
Anfang Ebene 4 Knoten scheduler_stop scheduler_stop Ende Ebene 4 Knoten scheduler_stop
Anfang Ebene 4 Knoten service_connect service_connect Ende Ebene 4 Knoten service_connect
Anfang Ebene 4 Knoten service_release service_release Ende Ebene 4 Knoten service_release
Anfang Ebene 4 Knoten show show Ende Ebene 4 Knoten show
Anfang Ebene 4 Knoten show_list show_list Ende Ebene 4 Knoten show_list
Anfang Ebene 4 Knoten show_next show_next Ende Ebene 4 Knoten show_next
Anfang Ebene 4 Knoten sql_connect sql_connect Ende Ebene 4 Knoten sql_connect
Anfang Ebene 4 Knoten sql_execute sql_execute Ende Ebene 4 Knoten sql_execute
Anfang Ebene 4 Knoten sql_executenice sql_executenice Ende Ebene 4 Knoten sql_executenice
Anfang Ebene 4 Knoten sql_fetch sql_fetch Ende Ebene 4 Knoten sql_fetch
Anfang Ebene 4 Knoten sql_fetchnice sql_fetchnice Ende Ebene 4 Knoten sql_fetchnice
Anfang Ebene 4 Knoten sql_info sql_info Ende Ebene 4 Knoten sql_info
Anfang Ebene 4 Knoten sql_recreateindex sql_recreateindex Ende Ebene 4 Knoten sql_recreateindex
Anfang Ebene 4 Knoten sql_release sql_release Ende Ebene 4 Knoten sql_release
Anfang Ebene 4 Knoten sql_updatestat sql_updatestat Ende Ebene 4 Knoten sql_updatestat
Anfang Ebene 4 Knoten sql_updatestat_per_systemtable sql_updatestat_per_systemtable Ende Ebene 4 Knoten sql_updatestat_per_systemtable
Anfang Ebene 4 Knoten trace_clear trace_clear Ende Ebene 4 Knoten trace_clear
Anfang Ebene 4 Knoten trace_flush trace_flush Ende Ebene 4 Knoten trace_flush
Anfang Ebene 4 Knoten trace_off trace_off Ende Ebene 4 Knoten trace_off
Anfang Ebene 4 Knoten trace_on trace_on Ende Ebene 4 Knoten trace_on
Anfang Ebene 4 Knoten trace_prot trace_prot Ende Ebene 4 Knoten trace_prot
Anfang Ebene 4 Knoten trace_protopt trace_protopt Ende Ebene 4 Knoten trace_protopt
Anfang Ebene 4 Knoten trace_show trace_show Ende Ebene 4 Knoten trace_show
Anfang Ebene 4 Knoten user_create user_create Ende Ebene 4 Knoten user_create
Anfang Ebene 4 Knoten user_delete user_delete Ende Ebene 4 Knoten user_delete
Anfang Ebene 4 Knoten user_get user_get Ende Ebene 4 Knoten user_get
Anfang Ebene 4 Knoten user_getall user_getall Ende Ebene 4 Knoten user_getall
Anfang Ebene 4 Knoten user_getrights user_getrights Ende Ebene 4 Knoten user_getrights
Anfang Ebene 4 Knoten user_logon user_logon Ende Ebene 4 Knoten user_logon
Anfang Ebene 4 Knoten user_put user_put Ende Ebene 4 Knoten user_put
Anfang Ebene 5 Knoten Serverberechtigungen Serverberechtigungen Ende Ebene 5 Knoten Serverberechtigungen
Anfang Ebene 6 Knoten AccessSQL: Zugriff auf SQL-Sitzung AccessSQL: Zugriff auf SQL-Sitzung Ende Ebene 6 Knoten AccessSQL: Zugriff auf SQL-Sitzung
Anfang Ebene 6 Knoten AccessUtility: Zugriff auf Utility-Sitzung AccessUtility: Zugriff auf Utility-Sitzung Ende Ebene 6 Knoten AccessUtility: Zugriff auf Utility-Sitzung
Anfang Ebene 6 Knoten Backup: Durchführen von Sicherungen Backup: Durchführen von Sicherungen Ende Ebene 6 Knoten Backup: Durchführen von Sicherungen
Anfang Ebene 6 Knoten DBFileRead: Zugriff auf Datenbankdateien (nur lesend) DBFileRead: Zugriff auf Datenbankdateien (nur lesend) Ende Ebene 6 Knoten DBFileRead: Zugriff auf Datenbankdateien (nur lesend)
Anfang Ebene 6 Knoten DBInfoRead: Anzeigen von Zustandsinformationen DBInfoRead: Anzeigen von Zustandsinformationen Ende Ebene 6 Knoten DBInfoRead: Anzeigen von Zustandsinformationen
Anfang Ebene 6 Knoten DBStart: Starten der Datenbankinstanz DBStart: Starten der Datenbankinstanz Ende Ebene 6 Knoten DBStart: Starten der Datenbankinstanz
Anfang Ebene 6 Knoten DBStop: Stoppen der Datenbankinstanz DBStop: Stoppen der Datenbankinstanz Ende Ebene 6 Knoten DBStop: Stoppen der Datenbankinstanz
Anfang Ebene 6 Knoten ExecLoad: Ausführen des Programms Loader: ExecLoad: Ausführen des Programms Loader: Ende Ebene 6 Knoten ExecLoad: Ausführen des Programms Loader:
Anfang Ebene 6 Knoten InstallMgm: Installationsverwaltung InstallMgm: Installationsverwaltung Ende Ebene 6 Knoten InstallMgm: Installationsverwaltung
Anfang Ebene 6 Knoten LoadSysTab: Laden der Systemtabellen LoadSysTab: Laden der Systemtabellen Ende Ebene 6 Knoten LoadSysTab: Laden der Systemtabellen
Anfang Ebene 6 Knoten ParamCheckWrite: Zugriff auf Datenbankparameter (geprüftes Schre ParamCheckWrite: Zugriff auf Datenbankparameter (geprüftes Schre Ende Ebene 6 Knoten ParamCheckWrite: Zugriff auf Datenbankparameter (geprüftes Schre
Anfang Ebene 6 Knoten ParamFull: Zugriff auf Datenbankparameter (lesend und schreibend ParamFull: Zugriff auf Datenbankparameter (lesend und schreibend Ende Ebene 6 Knoten ParamFull: Zugriff auf Datenbankparameter (lesend und schreibend
Anfang Ebene 6 Knoten ParamRead: Zugriff auf Datenbankparameter (nur lesend) ParamRead: Zugriff auf Datenbankparameter (nur lesend) Ende Ebene 6 Knoten ParamRead: Zugriff auf Datenbankparameter (nur lesend)
Anfang Ebene 6 Knoten Recovery: Wiederherstellen von Sicherungen Recovery: Wiederherstellen von Sicherungen Ende Ebene 6 Knoten Recovery: Wiederherstellen von Sicherungen
Anfang Ebene 6 Knoten SchedulerMgm: Verwalten des Scheduler SchedulerMgm: Verwalten des Scheduler Ende Ebene 6 Knoten SchedulerMgm: Verwalten des Scheduler
Anfang Ebene 6 Knoten Scheduling: Einplanen von DBM-Kommandos Scheduling: Einplanen von DBM-Kommandos Ende Ebene 6 Knoten Scheduling: Einplanen von DBM-Kommandos
Anfang Ebene 6 Knoten SharedMemoryAdmin: Verwalten des Shared-Memory SharedMemoryAdmin: Verwalten des Shared-Memory Ende Ebene 6 Knoten SharedMemoryAdmin: Verwalten des Shared-Memory
Anfang Ebene 6 Knoten SystemCmd: Ausführen von Betriebssystemkommandos SystemCmd: Ausführen von Betriebssystemkommandos Ende Ebene 6 Knoten SystemCmd: Ausführen von Betriebssystemkommandos
Anfang Ebene 6 Knoten UserMgm: Verwalten der Database Manager-Benutzer UserMgm: Verwalten der Database Manager-Benutzer Ende Ebene 6 Knoten UserMgm: Verwalten der Database Manager-Benutzer
Anfang Ebene 4 Knoten user_rename user_rename Ende Ebene 4 Knoten user_rename
Anfang Ebene 4 Knoten user_sap user_sap Ende Ebene 4 Knoten user_sap
Anfang Ebene 4 Knoten user_sysdba user_sysdba Ende Ebene 4 Knoten user_sysdba
Anfang Ebene 4 Knoten user_system user_system Ende Ebene 4 Knoten user_system
Anfang Ebene 2 Knoten Database Analyzer Database Analyzer Ende Ebene 2 Knoten Database Analyzer
Anfang Ebene 3 Knoten Aufruf des Database Analyzer Aufruf des Database Analyzer Ende Ebene 3 Knoten Aufruf des Database Analyzer
Anfang Ebene 4 Knoten Optionen Optionen Ende Ebene 4 Knoten Optionen
Anfang Ebene 3 Knoten Konfigurationsdatei Konfigurationsdatei Ende Ebene 3 Knoten Konfigurationsdatei
Anfang Ebene 3 Knoten Protokolldateien Protokolldateien Ende Ebene 3 Knoten Protokolldateien
Anfang Ebene 3 Knoten Meldungen Meldungen Ende Ebene 3 Knoten Meldungen
Anfang Ebene 4 Knoten Avg user cmd exec time for task Avg user cmd exec time for task Ende Ebene 4 Knoten Avg user cmd exec time for task
Anfang Ebene 4 Knoten Avg user suspend time for task Avg user suspend time for task Ende Ebene 4 Knoten Avg user suspend time for task
Anfang Ebene 4 Knoten Avg user wait time for task Avg user wait time for task Ende Ebene 4 Knoten Avg user wait time for task
Anfang Ebene 4 Knoten Catalog cache hitrate Catalog cache hitrate Ende Ebene 4 Knoten Catalog cache hitrate
Anfang Ebene 4 Knoten Collision rate Collision rate Ende Ebene 4 Knoten Collision rate
Anfang Ebene 4 Knoten Data cache hitrate Data cache hitrate Ende Ebene 4 Knoten Data cache hitrate
Anfang Ebene 4 Knoten Data volume filling level Data volume filling level Ende Ebene 4 Knoten Data volume filling level
Anfang Ebene 4 Knoten Deletes/Updates Deletes/Updates Ende Ebene 4 Knoten Deletes/Updates
Anfang Ebene 4 Knoten Free user tasks Free user tasks Ende Ebene 4 Knoten Free user tasks
Anfang Ebene 4 Knoten Lock list escalations Lock list escalations Ende Ebene 4 Knoten Lock list escalations
Anfang Ebene 4 Knoten Log area filling level Log area filling level Ende Ebene 4 Knoten Log area filling level
Anfang Ebene 4 Knoten Log queue overflows Log queue overflows Ende Ebene 4 Knoten Log queue overflows
Anfang Ebene 4 Knoten Log write time Log write time Ende Ebene 4 Knoten Log write time
Anfang Ebene 4 Knoten Max log queue filling Max log queue filling Ende Ebene 4 Knoten Max log queue filling
Anfang Ebene 4 Knoten Number of cached history pages Number of cached history pages Ende Ebene 4 Knoten Number of cached history pages
Anfang Ebene 4 Knoten Number of physical reads Number of physical reads Ende Ebene 4 Knoten Number of physical reads
Anfang Ebene 4 Knoten Number of physical writes Number of physical writes Ende Ebene 4 Knoten Number of physical writes
Anfang Ebene 4 Knoten Number of physical writes of temporary pages Number of physical writes of temporary pages Ende Ebene 4 Knoten Number of physical writes of temporary pages
Anfang Ebene 4 Knoten OMS cache hitrate OMS cache hitrate Ende Ebene 4 Knoten OMS cache hitrate
Anfang Ebene 4 Knoten OMS heap collisions OMS heap collisions Ende Ebene 4 Knoten OMS heap collisions
Anfang Ebene 4 Knoten OMS heap utilization OMS heap utilization Ende Ebene 4 Knoten OMS heap utilization
Anfang Ebene 4 Knoten OMS history cache hitrate OMS history cache hitrate Ende Ebene 4 Knoten OMS history cache hitrate
Anfang Ebene 4 Knoten OMS terminates OMS terminates Ende Ebene 4 Knoten OMS terminates
Anfang Ebene 4 Knoten OMS version is old OMS version is old Ende Ebene 4 Knoten OMS version is old
Anfang Ebene 4 Knoten OMS version is unloaded OMS version is unloaded Ende Ebene 4 Knoten OMS version is unloaded
Anfang Ebene 4 Knoten Optimizer strategies Optimizer strategies Ende Ebene 4 Knoten Optimizer strategies
Anfang Ebene 4 Knoten Out of memory exceptions Out of memory exceptions Ende Ebene 4 Knoten Out of memory exceptions
Anfang Ebene 4 Knoten Parse activities Parse activities Ende Ebene 4 Knoten Parse activities
Anfang Ebene 4 Knoten Physical reads for user task Physical reads for user task Ende Ebene 4 Knoten Physical reads for user task
Anfang Ebene 4 Knoten Selects and Fetches Selects and Fetches Ende Ebene 4 Knoten Selects and Fetches
Anfang Ebene 4 Knoten Table scans Table scans Ende Ebene 4 Knoten Table scans
Anfang Ebene 4 Knoten User task blocked in state User task blocked in state Ende Ebene 4 Knoten User task blocked in state
Anfang Ebene 4 Knoten User task physical writes User task physical writes Ende Ebene 4 Knoten User task physical writes
Anfang Ebene 2 Knoten Loader Loader Ende Ebene 2 Knoten Loader
Anfang Ebene 3 Knoten Aufrufen des Loader Aufrufen des Loader Ende Ebene 3 Knoten Aufrufen des Loader
Anfang Ebene 4 Knoten Aufrufoptionen des Loader CLI Aufrufoptionen des Loader CLI Ende Ebene 4 Knoten Aufrufoptionen des Loader CLI
Anfang Ebene 5 Knoten Transportmodus Transportmodus Ende Ebene 5 Knoten Transportmodus
Anfang Ebene 5 Knoten Kommandodateimodus Kommandodateimodus Ende Ebene 5 Knoten Kommandodateimodus
Anfang Ebene 6 Knoten Kommandodatei Kommandodatei Ende Ebene 6 Knoten Kommandodatei
Anfang Ebene 5 Knoten Sitzungsmodus Sitzungsmodus Ende Ebene 5 Knoten Sitzungsmodus
Anfang Ebene 5 Knoten Optionen für Verbindungsaufbau Optionen für Verbindungsaufbau Ende Ebene 5 Knoten Optionen für Verbindungsaufbau
Anfang Ebene 5 Knoten Optionen für Ein- und Ausgabe Optionen für Ein- und Ausgabe Ende Ebene 5 Knoten Optionen für Ein- und Ausgabe
Anfang Ebene 5 Knoten Optionen zum Ermitteln von Versionsinformationen Optionen zum Ermitteln von Versionsinformationen Ende Ebene 5 Knoten Optionen zum Ermitteln von Versionsinformationen
Anfang Ebene 3 Knoten Kommandos und SQL-Anweisungen Kommandos und SQL-Anweisungen Ende Ebene 3 Knoten Kommandos und SQL-Anweisungen
Anfang Ebene 4 Knoten Aufbau einer Datenbanksitzung: Kommandos Aufbau einer Datenbanksitzung: Kommandos Ende Ebene 4 Knoten Aufbau einer Datenbanksitzung: Kommandos
Anfang Ebene 5 Knoten AUTOCOMMIT-Kommando AUTOCOMMIT-Kommando Ende Ebene 5 Knoten AUTOCOMMIT-Kommando
Anfang Ebene 5 Knoten SET-Kommando SET-Kommando Ende Ebene 5 Knoten SET-Kommando
Anfang Ebene 5 Knoten SQLMODE-Kommando SQLMODE-Kommando Ende Ebene 5 Knoten SQLMODE-Kommando
Anfang Ebene 5 Knoten USE DB-Kommando USE DB-Kommando Ende Ebene 5 Knoten USE DB-Kommando
Anfang Ebene 5 Knoten USE SCHEMA-Kommando USE SCHEMA-Kommando Ende Ebene 5 Knoten USE SCHEMA-Kommando
Anfang Ebene 5 Knoten USE SCHEMAMAP-Kommando USE SCHEMAMAP-Kommando Ende Ebene 5 Knoten USE SCHEMAMAP-Kommando
Anfang Ebene 6 Knoten CREATE/DROP SCHEMAMAP-Anweisung CREATE/DROP SCHEMAMAP-Anweisung Ende Ebene 6 Knoten CREATE/DROP SCHEMAMAP-Anweisung
Anfang Ebene 5 Knoten USE USER-Kommando USE USER-Kommando Ende Ebene 5 Knoten USE USER-Kommando
Anfang Ebene 4 Knoten Exportieren: Kommandos Exportieren: Kommandos Ende Ebene 4 Knoten Exportieren: Kommandos
Anfang Ebene 5 Knoten EXPORT DB-Kommando EXPORT DB-Kommando Ende Ebene 5 Knoten EXPORT DB-Kommando
Anfang Ebene 5 Knoten EXPORT USER-Kommando EXPORT USER-Kommando Ende Ebene 5 Knoten EXPORT USER-Kommando
Anfang Ebene 5 Knoten EXPORT SCHEMA-Kommando EXPORT SCHEMA-Kommando Ende Ebene 5 Knoten EXPORT SCHEMA-Kommando
Anfang Ebene 5 Knoten EXPORT TABLE-Kommando EXPORT TABLE-Kommando Ende Ebene 5 Knoten EXPORT TABLE-Kommando
Anfang Ebene 5 Knoten EXPORT COLUMNS-Kommando EXPORT COLUMNS-Kommando Ende Ebene 5 Knoten EXPORT COLUMNS-Kommando
Anfang Ebene 4 Knoten Importieren: Kommandos Importieren: Kommandos Ende Ebene 4 Knoten Importieren: Kommandos
Anfang Ebene 5 Knoten IMPORT DB-Kommando IMPORT DB-Kommando Ende Ebene 5 Knoten IMPORT DB-Kommando
Anfang Ebene 5 Knoten IMPORT USER-Kommando IMPORT USER-Kommando Ende Ebene 5 Knoten IMPORT USER-Kommando
Anfang Ebene 5 Knoten IMPORT SCHEMA-Kommando IMPORT SCHEMA-Kommando Ende Ebene 5 Knoten IMPORT SCHEMA-Kommando
Anfang Ebene 5 Knoten IMPORT TABLE-Kommando IMPORT TABLE-Kommando Ende Ebene 5 Knoten IMPORT TABLE-Kommando
Anfang Ebene 6 Knoten Performance-Steigerung beim IMPORT TABLE Performance-Steigerung beim IMPORT TABLE Ende Ebene 6 Knoten Performance-Steigerung beim IMPORT TABLE
Anfang Ebene 5 Knoten IMPORT COLUMNS-Kommando IMPORT COLUMNS-Kommando Ende Ebene 5 Knoten IMPORT COLUMNS-Kommando
Anfang Ebene 4 Knoten UPDATE COLUMNS-Kommando UPDATE COLUMNS-Kommando Ende Ebene 4 Knoten UPDATE COLUMNS-Kommando
Anfang Ebene 4 Knoten Daten Daten Ende Ebene 4 Knoten Daten
Anfang Ebene 5 Knoten Datenstrom Datenstrom Ende Ebene 5 Knoten Datenstrom
Anfang Ebene 5 Knoten Positionsbeschreibung Positionsbeschreibung Ende Ebene 5 Knoten Positionsbeschreibung
Anfang Ebene 5 Knoten Datenformat Datenformat Ende Ebene 5 Knoten Datenformat
Anfang Ebene 5 Knoten Code-Spezifikation Code-Spezifikation Ende Ebene 5 Knoten Code-Spezifikation
Anfang Ebene 5 Knoten CSV, FWV, FWV BINARY CSV, FWV, FWV BINARY Ende Ebene 5 Knoten CSV, FWV, FWV BINARY
Anfang Ebene 5 Knoten PAGES, RECORDS PAGES, RECORDS Ende Ebene 5 Knoten PAGES, RECORDS
Anfang Ebene 5 Knoten Datenträgertyp Datenträgertyp Ende Ebene 5 Knoten Datenträgertyp
Anfang Ebene 4 Knoten Spaltenbeschreibung Spaltenbeschreibung Ende Ebene 4 Knoten Spaltenbeschreibung
Anfang Ebene 5 Knoten Datentypen Datentypen Ende Ebene 5 Knoten Datentypen
Anfang Ebene 5 Knoten Importieren von beliebigen und speziellen Konstanten Importieren von beliebigen und speziellen Konstanten Ende Ebene 5 Knoten Importieren von beliebigen und speziellen Konstanten
Anfang Ebene 5 Knoten Selektieren von Datensätzen Selektieren von Datensätzen Ende Ebene 5 Knoten Selektieren von Datensätzen
Anfang Ebene 5 Knoten Ausgabespalte Ausgabespalte Ende Ebene 5 Knoten Ausgabespalte
Anfang Ebene 4 Knoten Tabellenname Tabellenname Ende Ebene 4 Knoten Tabellenname
Anfang Ebene 4 Knoten Datumsangaben Datumsangaben Ende Ebene 4 Knoten Datumsangaben
Anfang Ebene 4 Knoten Zeitangaben Zeitangaben Ende Ebene 4 Knoten Zeitangaben
Anfang Ebene 4 Knoten Zeitstempelangaben Zeitstempelangaben Ende Ebene 4 Knoten Zeitstempelangaben
Anfang Ebene 4 Knoten NULL-Wert-Darstellung NULL-Wert-Darstellung Ende Ebene 4 Knoten NULL-Wert-Darstellung
Anfang Ebene 4 Knoten Transformation Transformation Ende Ebene 4 Knoten Transformation
Anfang Ebene 4 Knoten Exportieren und Importieren mit Sicherungswerkzeugen anderer Anb Exportieren und Importieren mit Sicherungswerkzeugen anderer Anb Ende Ebene 4 Knoten Exportieren und Importieren mit Sicherungswerkzeugen anderer Anb
Anfang Ebene 4 Knoten Exportieren und Importieren von LONG-Werten Exportieren und Importieren von LONG-Werten Ende Ebene 4 Knoten Exportieren und Importieren von LONG-Werten
Anfang Ebene 5 Knoten Exportieren von LONG-Werten Exportieren von LONG-Werten Ende Ebene 5 Knoten Exportieren von LONG-Werten
Anfang Ebene 5 Knoten Importieren von LONG-Werten Importieren von LONG-Werten Ende Ebene 5 Knoten Importieren von LONG-Werten
Anfang Ebene 4 Knoten Wiederaufsetzen Wiederaufsetzen Ende Ebene 4 Knoten Wiederaufsetzen
Anfang Ebene 3 Knoten Protokollfunktionen Protokollfunktionen Ende Ebene 3 Knoten Protokollfunktionen
Anfang Ebene 4 Knoten Protokolldatei Protokolldatei Ende Ebene 4 Knoten Protokolldatei
Anfang Ebene 4 Knoten Transformationshistorie Transformationshistorie Ende Ebene 4 Knoten Transformationshistorie
Anfang Ebene 4 Knoten Zusätzliche Protokollfunktionalität (package_spec) Zusätzliche Protokollfunktionalität (package_spec) Ende Ebene 4 Knoten Zusätzliche Protokollfunktionalität (package_spec)
Anfang Ebene 4 Knoten Systemtabellen Systemtabellen Ende Ebene 4 Knoten Systemtabellen
Anfang Ebene 5 Knoten CODEPAGE CODEPAGE Ende Ebene 5 Knoten CODEPAGE
Anfang Ebene 5 Knoten MAPSCHEMANAMES MAPSCHEMANAMES Ende Ebene 5 Knoten MAPSCHEMANAMES
Anfang Ebene 5 Knoten TRANSFORMATIONMODEL TRANSFORMATIONMODEL Ende Ebene 5 Knoten TRANSFORMATIONMODEL
Anfang Ebene 5 Knoten TRANSFORMATIONMONITOR TRANSFORMATIONMONITOR Ende Ebene 5 Knoten TRANSFORMATIONMONITOR
Anfang Ebene 5 Knoten TRANSFORMATIONPACKAGES TRANSFORMATIONPACKAGES Ende Ebene 5 Knoten TRANSFORMATIONPACKAGES
Anfang Ebene 5 Knoten TRANSFORMATIONRESOURCES TRANSFORMATIONRESOURCES Ende Ebene 5 Knoten TRANSFORMATIONRESOURCES
Anfang Ebene 5 Knoten TRANSFORMATIONSTATISTICS TRANSFORMATIONSTATISTICS Ende Ebene 5 Knoten TRANSFORMATIONSTATISTICS
Anfang Ebene 5 Knoten TRANSFORMATIONSTEPS TRANSFORMATIONSTEPS Ende Ebene 5 Knoten TRANSFORMATIONSTEPS
Anfang Ebene 3 Knoten Syntaxregeln: alphabetisch sortiert Syntaxregeln: alphabetisch sortiert Ende Ebene 3 Knoten Syntaxregeln: alphabetisch sortiert
Anfang Ebene 4 Knoten autocommit_command autocommit_command Ende Ebene 4 Knoten autocommit_command
Anfang Ebene 4 Knoten backup_tool_spec backup_tool_spec Ende Ebene 4 Knoten backup_tool_spec
Anfang Ebene 4 Knoten bool_spec bool_spec Ende Ebene 4 Knoten bool_spec
Anfang Ebene 4 Knoten catalog_data_instream_part_spec catalog_data_instream_part_spec Ende Ebene 4 Knoten catalog_data_instream_part_spec
Anfang Ebene 4 Knoten catalog_data_outstream_part_spec catalog_data_outstream_part_spec Ende Ebene 4 Knoten catalog_data_outstream_part_spec
Anfang Ebene 4 Knoten catalog_data_instream_table_spec catalog_data_instream_table_spec Ende Ebene 4 Knoten catalog_data_instream_table_spec
Anfang Ebene 4 Knoten catalog_data_outstream_table_spec catalog_data_outstream_table_spec Ende Ebene 4 Knoten catalog_data_outstream_table_spec
Anfang Ebene 4 Knoten catalog_instream_spec catalog_instream_spec Ende Ebene 4 Knoten catalog_instream_spec
Anfang Ebene 4 Knoten catalog_outstream_spec catalog_outstream_spec Ende Ebene 4 Knoten catalog_outstream_spec
Anfang Ebene 4 Knoten code_page_spec code_page_spec Ende Ebene 4 Knoten code_page_spec
Anfang Ebene 4 Knoten code_spec code_spec Ende Ebene 4 Knoten code_spec
Anfang Ebene 4 Knoten column_assignment column_assignment Ende Ebene 4 Knoten column_assignment
Anfang Ebene 4 Knoten column_dataformat_spec column_dataformat_spec Ende Ebene 4 Knoten column_dataformat_spec
Anfang Ebene 4 Knoten column_function column_function Ende Ebene 4 Knoten column_function
Anfang Ebene 4 Knoten column_id column_id Ende Ebene 4 Knoten column_id
Anfang Ebene 4 Knoten column_name column_name Ende Ebene 4 Knoten column_name
Anfang Ebene 4 Knoten column_spec column_spec Ende Ebene 4 Knoten column_spec
Anfang Ebene 4 Knoten compare_operator compare_operator Ende Ebene 4 Knoten compare_operator
Anfang Ebene 4 Knoten condition condition Ende Ebene 4 Knoten condition
Anfang Ebene 4 Knoten configuration_spec configuration_spec Ende Ebene 4 Knoten configuration_spec
Anfang Ebene 4 Knoten csv_format_spec csv_format_spec Ende Ebene 4 Knoten csv_format_spec
Anfang Ebene 4 Knoten data_instream_column_spec data_instream_column_spec Ende Ebene 4 Knoten data_instream_column_spec
Anfang Ebene 4 Knoten data_instream_columns_spec data_instream_columns_spec Ende Ebene 4 Knoten data_instream_columns_spec
Anfang Ebene 4 Knoten data_instream_part_spec data_instream_part_spec Ende Ebene 4 Knoten data_instream_part_spec
Anfang Ebene 4 Knoten data_instream_table_spec data_instream_table_spec Ende Ebene 4 Knoten data_instream_table_spec
Anfang Ebene 4 Knoten data_outstream_column_spec data_outstream_column_spec Ende Ebene 4 Knoten data_outstream_column_spec
Anfang Ebene 4 Knoten data_outstream_part_spec data_outstream_part_spec Ende Ebene 4 Knoten data_outstream_part_spec
Anfang Ebene 4 Knoten data_outstream_table_spec data_outstream_table_spec Ende Ebene 4 Knoten data_outstream_table_spec
Anfang Ebene 4 Knoten database_spec database_spec Ende Ebene 4 Knoten database_spec
Anfang Ebene 4 Knoten date_spec date_spec Ende Ebene 4 Knoten date_spec
Anfang Ebene 4 Knoten delimiter delimiter Ende Ebene 4 Knoten delimiter
Anfang Ebene 4 Knoten delimiter_spec delimiter_spec Ende Ebene 4 Knoten delimiter_spec
Anfang Ebene 4 Knoten duplicates_clause duplicates_clause Ende Ebene 4 Knoten duplicates_clause
Anfang Ebene 4 Knoten ebid_spec ebid_spec Ende Ebene 4 Knoten ebid_spec
Anfang Ebene 4 Knoten exclude_include exclude_include Ende Ebene 4 Knoten exclude_include
Anfang Ebene 4 Knoten export_column_spec export_column_spec Ende Ebene 4 Knoten export_column_spec
Anfang Ebene 4 Knoten export_columns_command export_columns_command Ende Ebene 4 Knoten export_columns_command
Anfang Ebene 4 Knoten export_command export_command Ende Ebene 4 Knoten export_command
Anfang Ebene 4 Knoten export_db_command export_db_command Ende Ebene 4 Knoten export_db_command
Anfang Ebene 4 Knoten export_lobcolumn_spec export_lobcolumn_spec Ende Ebene 4 Knoten export_lobcolumn_spec
Anfang Ebene 4 Knoten export_schema_command export_schema_command Ende Ebene 4 Knoten export_schema_command
Anfang Ebene 4 Knoten export_table_command export_table_command Ende Ebene 4 Knoten export_table_command
Anfang Ebene 4 Knoten export_user_command export_user_command Ende Ebene 4 Knoten export_user_command
Anfang Ebene 4 Knoten field_assignment field_assignment Ende Ebene 4 Knoten field_assignment
Anfang Ebene 4 Knoten field_format_spec field_format_spec Ende Ebene 4 Knoten field_format_spec
Anfang Ebene 4 Knoten field_function field_function Ende Ebene 4 Knoten field_function
Anfang Ebene 4 Knoten field_spec field_spec Ende Ebene 4 Knoten field_spec
Anfang Ebene 4 Knoten field_type field_type Ende Ebene 4 Knoten field_type
Anfang Ebene 4 Knoten fwv_format_spec fwv_format_spec Ende Ebene 4 Knoten fwv_format_spec
Anfang Ebene 4 Knoten if_condition if_condition Ende Ebene 4 Knoten if_condition
Anfang Ebene 4 Knoten import_column_spec import_column_spec Ende Ebene 4 Knoten import_column_spec
Anfang Ebene 4 Knoten import_columns_command import_columns_command Ende Ebene 4 Knoten import_columns_command
Anfang Ebene 4 Knoten import_command import_command Ende Ebene 4 Knoten import_command
Anfang Ebene 4 Knoten import_db_command import_db_command Ende Ebene 4 Knoten import_db_command
Anfang Ebene 4 Knoten import_lobcolumn_spec import_lobcolumn_spec Ende Ebene 4 Knoten import_lobcolumn_spec
Anfang Ebene 4 Knoten import_schema_command import_schema_command Ende Ebene 4 Knoten import_schema_command
Anfang Ebene 4 Knoten import_table_command import_table_command Ende Ebene 4 Knoten import_table_command
Anfang Ebene 4 Knoten import_user_command import_user_command Ende Ebene 4 Knoten import_user_command
Anfang Ebene 4 Knoten instream_columnformat_spec instream_columnformat_spec Ende Ebene 4 Knoten instream_columnformat_spec
Anfang Ebene 4 Knoten instream_csv_spec instream_csv_spec Ende Ebene 4 Knoten instream_csv_spec
Anfang Ebene 4 Knoten instream_ddl_spec instream_ddl_spec Ende Ebene 4 Knoten instream_ddl_spec
Anfang Ebene 4 Knoten instream_fwv_spec instream_fwv_spec Ende Ebene 4 Knoten instream_fwv_spec
Anfang Ebene 4 Knoten instream_lob_spec instream_lob_spec Ende Ebene 4 Knoten instream_lob_spec
Anfang Ebene 4 Knoten instream_pages_spec instream_pages_spec Ende Ebene 4 Knoten instream_pages_spec
Anfang Ebene 4 Knoten instream_records_spec instream_records_spec Ende Ebene 4 Knoten instream_records_spec
Anfang Ebene 4 Knoten instream_tableformat_spec instream_tableformat_spec Ende Ebene 4 Knoten instream_tableformat_spec
Anfang Ebene 4 Knoten int_spec int_spec Ende Ebene 4 Knoten int_spec
Anfang Ebene 4 Knoten isolation_level_spec isolation_level_spec Ende Ebene 4 Knoten isolation_level_spec
Anfang Ebene 4 Knoten lob_code_spec lob_code_spec Ende Ebene 4 Knoten lob_code_spec
Anfang Ebene 4 Knoten map_column_field map_column_field Ende Ebene 4 Knoten map_column_field
Anfang Ebene 4 Knoten map_field_column map_field_column Ende Ebene 4 Knoten map_field_column
Anfang Ebene 4 Knoten map_schema_spec map_schema_spec Ende Ebene 4 Knoten map_schema_spec
Anfang Ebene 4 Knoten mediumtype_spec mediumtype_spec Ende Ebene 4 Knoten mediumtype_spec
Anfang Ebene 4 Knoten noheader_spec noheader_spec Ende Ebene 4 Knoten noheader_spec
Anfang Ebene 4 Knoten null_assign null_assign Ende Ebene 4 Knoten null_assign
Anfang Ebene 4 Knoten null_condition null_condition Ende Ebene 4 Knoten null_condition
Anfang Ebene 4 Knoten null_spec null_spec Ende Ebene 4 Knoten null_spec
Anfang Ebene 4 Knoten number_spec number_spec Ende Ebene 4 Knoten number_spec
Anfang Ebene 4 Knoten numerical_functions numerical_functions Ende Ebene 4 Knoten numerical_functions
Anfang Ebene 4 Knoten order_clause order_clause Ende Ebene 4 Knoten order_clause
Anfang Ebene 4 Knoten outstream_columnformat_spec outstream_columnformat_spec Ende Ebene 4 Knoten outstream_columnformat_spec
Anfang Ebene 4 Knoten outstream_csv_spec outstream_csv_spec Ende Ebene 4 Knoten outstream_csv_spec
Anfang Ebene 4 Knoten outstream_ddl_spec outstream_ddl_spec Ende Ebene 4 Knoten outstream_ddl_spec
Anfang Ebene 4 Knoten outstream_fwv_spec outstream_fwv_spec Ende Ebene 4 Knoten outstream_fwv_spec
Anfang Ebene 4 Knoten outstream_lob_spec outstream_lob_spec Ende Ebene 4 Knoten outstream_lob_spec
Anfang Ebene 4 Knoten outstream_pages_spec outstream_pages_spec Ende Ebene 4 Knoten outstream_pages_spec
Anfang Ebene 4 Knoten outstream_records_spec outstream_records_spec Ende Ebene 4 Knoten outstream_records_spec
Anfang Ebene 4 Knoten outstream_tableformat_spec outstream_tableformat_spec Ende Ebene 4 Knoten outstream_tableformat_spec
Anfang Ebene 4 Knoten package_spec package_spec Ende Ebene 4 Knoten package_spec
Anfang Ebene 4 Knoten records_format_spec records_format_spec Ende Ebene 4 Knoten records_format_spec
Anfang Ebene 4 Knoten remark_command remark_command Ende Ebene 4 Knoten remark_command
Anfang Ebene 4 Knoten restart_spec restart_spec Ende Ebene 4 Knoten restart_spec
Anfang Ebene 4 Knoten restore_spec restore_spec Ende Ebene 4 Knoten restore_spec
Anfang Ebene 4 Knoten round_or_trunc_spec round_or_trunc_spec Ende Ebene 4 Knoten round_or_trunc_spec
Anfang Ebene 4 Knoten scale_spec scale_spec Ende Ebene 4 Knoten scale_spec
Anfang Ebene 4 Knoten schema_name schema_name Ende Ebene 4 Knoten schema_name
Anfang Ebene 4 Knoten schema_map_name schema_map_name Ende Ebene 4 Knoten schema_map_name
Anfang Ebene 4 Knoten schema_to_schema schema_to_schema Ende Ebene 4 Knoten schema_to_schema
Anfang Ebene 4 Knoten select_expression select_expression Ende Ebene 4 Knoten select_expression
Anfang Ebene 4 Knoten separator separator Ende Ebene 4 Knoten separator
Anfang Ebene 4 Knoten separator_spec separator_spec Ende Ebene 4 Knoten separator_spec
Anfang Ebene 4 Knoten sequence_number sequence_number Ende Ebene 4 Knoten sequence_number
Anfang Ebene 4 Knoten set_column_spec set_column_spec Ende Ebene 4 Knoten set_column_spec
Anfang Ebene 4 Knoten set_command set_command Ende Ebene 4 Knoten set_command
Anfang Ebene 4 Knoten simple_condition simple_condition Ende Ebene 4 Knoten simple_condition
Anfang Ebene 4 Knoten sql_mode sql_mode Ende Ebene 4 Knoten sql_mode
Anfang Ebene 4 Knoten sql_mode_command sql_mode_command Ende Ebene 4 Knoten sql_mode_command
Anfang Ebene 4 Knoten standard_code_spec standard_code_spec Ende Ebene 4 Knoten standard_code_spec
Anfang Ebene 4 Knoten standard_date_mask standard_date_mask Ende Ebene 4 Knoten standard_date_mask
Anfang Ebene 4 Knoten standard_time_mask standard_time_mask Ende Ebene 4 Knoten standard_time_mask
Anfang Ebene 4 Knoten standard_timestamp_mask standard_timestamp_mask Ende Ebene 4 Knoten standard_timestamp_mask
Anfang Ebene 4 Knoten start_spec start_spec Ende Ebene 4 Knoten start_spec
Anfang Ebene 4 Knoten table_dataformat_spec table_dataformat_spec Ende Ebene 4 Knoten table_dataformat_spec
Anfang Ebene 4 Knoten table_name table_name Ende Ebene 4 Knoten table_name
Anfang Ebene 4 Knoten time_spec time_spec Ende Ebene 4 Knoten time_spec
Anfang Ebene 4 Knoten timestamp_spec timestamp_spec Ende Ebene 4 Knoten timestamp_spec
Anfang Ebene 4 Knoten update_column_spec update_column_spec Ende Ebene 4 Knoten update_column_spec
Anfang Ebene 4 Knoten update_columns_command update_columns_command Ende Ebene 4 Knoten update_columns_command
Anfang Ebene 4 Knoten usage_spec usage_spec Ende Ebene 4 Knoten usage_spec
Anfang Ebene 4 Knoten use_database_command use_database_command Ende Ebene 4 Knoten use_database_command
Anfang Ebene 4 Knoten use_schema_command use_schema_command Ende Ebene 4 Knoten use_schema_command
Anfang Ebene 4 Knoten use_schema_map_command use_schema_map_command Ende Ebene 4 Knoten use_schema_map_command
Anfang Ebene 4 Knoten use_user_command use_user_command Ende Ebene 4 Knoten use_user_command
Anfang Ebene 4 Knoten user_spec user_spec Ende Ebene 4 Knoten user_spec
Anfang Ebene 4 Knoten Syntaxregeln: semantisch sortiert Syntaxregeln: semantisch sortiert Ende Ebene 4 Knoten Syntaxregeln: semantisch sortiert
Anfang Ebene 3 Knoten Begriffe: Übersicht Begriffe: Übersicht Ende Ebene 3 Knoten Begriffe: Übersicht
Anfang Ebene 3 Knoten Schlüsselwörter: Übersicht Schlüsselwörter: Übersicht Ende Ebene 3 Knoten Schlüsselwörter: Übersicht
Anfang Ebene 2 Knoten SQL Studio (GUI) SQL Studio (GUI) Ende Ebene 2 Knoten SQL Studio (GUI)
Anfang Ebene 3 Knoten Starten von SQL Studio Starten von SQL Studio Ende Ebene 3 Knoten Starten von SQL Studio
Anfang Ebene 3 Knoten Eröffnen einer Datenbanksitzung Eröffnen einer Datenbanksitzung Ende Ebene 3 Knoten Eröffnen einer Datenbanksitzung
Anfang Ebene 4 Knoten Liste der zuletzt geöffneten Sitzungen Liste der zuletzt geöffneten Sitzungen Ende Ebene 4 Knoten Liste der zuletzt geöffneten Sitzungen
Anfang Ebene 3 Knoten Bildschirmbereiche von SQL Studio Bildschirmbereiche von SQL Studio Ende Ebene 3 Knoten Bildschirmbereiche von SQL Studio
Anfang Ebene 3 Knoten Benutzereinstellungen Benutzereinstellungen Ende Ebene 3 Knoten Benutzereinstellungen
Anfang Ebene 4 Knoten Unicode-Unterstützung Unicode-Unterstützung Ende Ebene 4 Knoten Unicode-Unterstützung
Anfang Ebene 3 Knoten Catalog Manager Catalog Manager Ende Ebene 3 Knoten Catalog Manager
Anfang Ebene 4 Knoten SQL-Studio-Objekte SQL-Studio-Objekte Ende Ebene 4 Knoten SQL-Studio-Objekte
Anfang Ebene 4 Knoten Exportieren der Definition eines Datenbankobjekts Exportieren der Definition eines Datenbankobjekts Ende Ebene 4 Knoten Exportieren der Definition eines Datenbankobjekts
Anfang Ebene 4 Knoten Tabellen Tabellen Ende Ebene 4 Knoten Tabellen
Anfang Ebene 5 Knoten Anlegen einer Datenbanktabelle Anlegen einer Datenbanktabelle Ende Ebene 5 Knoten Anlegen einer Datenbanktabelle
Anfang Ebene 6 Knoten Definieren von Spalten Definieren von Spalten Ende Ebene 6 Knoten Definieren von Spalten
Anfang Ebene 6 Knoten Definieren von Einschränkungen für Spalten Definieren von Einschränkungen für Spalten Ende Ebene 6 Knoten Definieren von Einschränkungen für Spalten
Anfang Ebene 6 Knoten Definieren von Fremdschlüsselbeziehungen Definieren von Fremdschlüsselbeziehungen Ende Ebene 6 Knoten Definieren von Fremdschlüsselbeziehungen
Anfang Ebene 6 Knoten Definieren von zusätzlichen Angaben Definieren von zusätzlichen Angaben Ende Ebene 6 Knoten Definieren von zusätzlichen Angaben
Anfang Ebene 5 Knoten Anlegen einer View-Tabelle Anlegen einer View-Tabelle Ende Ebene 5 Knoten Anlegen einer View-Tabelle
Anfang Ebene 5 Knoten Anlegen eines Synonyms Anlegen eines Synonyms Ende Ebene 5 Knoten Anlegen eines Synonyms
Anfang Ebene 5 Knoten Anzeigen der Definition einer Tabelle Anzeigen der Definition einer Tabelle Ende Ebene 5 Knoten Anzeigen der Definition einer Tabelle
Anfang Ebene 5 Knoten Ändern der Definition einer Datenbanktabelle Ändern der Definition einer Datenbanktabelle Ende Ebene 5 Knoten Ändern der Definition einer Datenbanktabelle
Anfang Ebene 5 Knoten Anzeigen des Inhalts einer Tabelle Anzeigen des Inhalts einer Tabelle Ende Ebene 5 Knoten Anzeigen des Inhalts einer Tabelle
Anfang Ebene 5 Knoten Verwenden einer Tabelle in Dialogen oder Definitionen Verwenden einer Tabelle in Dialogen oder Definitionen Ende Ebene 5 Knoten Verwenden einer Tabelle in Dialogen oder Definitionen
Anfang Ebene 5 Knoten Umbenennen einer Tabelle Umbenennen einer Tabelle Ende Ebene 5 Knoten Umbenennen einer Tabelle
Anfang Ebene 5 Knoten Löschen aller Zeilen einer Tabelle Löschen aller Zeilen einer Tabelle Ende Ebene 5 Knoten Löschen aller Zeilen einer Tabelle
Anfang Ebene 5 Knoten Löschen einer Tabelle Löschen einer Tabelle Ende Ebene 5 Knoten Löschen einer Tabelle
Anfang Ebene 4 Knoten Indizes Indizes Ende Ebene 4 Knoten Indizes
Anfang Ebene 5 Knoten Anlegen eines Index Anlegen eines Index Ende Ebene 5 Knoten Anlegen eines Index
Anfang Ebene 5 Knoten Anzeigen der Definition eines Index Anzeigen der Definition eines Index Ende Ebene 5 Knoten Anzeigen der Definition eines Index
Anfang Ebene 5 Knoten Löschen eines Index Löschen eines Index Ende Ebene 5 Knoten Löschen eines Index
Anfang Ebene 4 Knoten Zahlenreihen Zahlenreihen Ende Ebene 4 Knoten Zahlenreihen
Anfang Ebene 5 Knoten Anlegen einer Zahlenreihe (Sequenz) Anlegen einer Zahlenreihe (Sequenz) Ende Ebene 5 Knoten Anlegen einer Zahlenreihe (Sequenz)
Anfang Ebene 5 Knoten Anzeigen der Definition einer Zahlenreihe Anzeigen der Definition einer Zahlenreihe Ende Ebene 5 Knoten Anzeigen der Definition einer Zahlenreihe
Anfang Ebene 5 Knoten Löschen einer Zahlenreihe Löschen einer Zahlenreihe Ende Ebene 5 Knoten Löschen einer Zahlenreihe
Anfang Ebene 4 Knoten Benutzer Benutzer Ende Ebene 4 Knoten Benutzer
Anfang Ebene 4 Knoten Datenbankprozeduren Datenbankprozeduren Ende Ebene 4 Knoten Datenbankprozeduren
Anfang Ebene 4 Knoten Trigger Trigger Ende Ebene 4 Knoten Trigger
Anfang Ebene 3 Knoten SQL-Dialog SQL-Dialog Ende Ebene 3 Knoten SQL-Dialog
Anfang Ebene 4 Knoten Erstellen und Ausführen von SQL-Anweisungen Erstellen und Ausführen von SQL-Anweisungen Ende Ebene 4 Knoten Erstellen und Ausführen von SQL-Anweisungen
Anfang Ebene 5 Knoten Liste der Schlüsselbegriffe Liste der Schlüsselbegriffe Ende Ebene 5 Knoten Liste der Schlüsselbegriffe
Anfang Ebene 5 Knoten Parametrisieren von SQL-Anweisungen Parametrisieren von SQL-Anweisungen Ende Ebene 5 Knoten Parametrisieren von SQL-Anweisungen
Anfang Ebene 4 Knoten Importieren und Exportieren von SQL-Anweisungen Importieren und Exportieren von SQL-Anweisungen Ende Ebene 4 Knoten Importieren und Exportieren von SQL-Anweisungen
Anfang Ebene 3 Knoten Form-Dialog Form-Dialog Ende Ebene 3 Knoten Form-Dialog
Anfang Ebene 4 Knoten Ausführen eines Form-Dialogs Ausführen eines Form-Dialogs Ende Ebene 4 Knoten Ausführen eines Form-Dialogs
Anfang Ebene 5 Knoten Auswählen von Datensätzen mit Hilfe von Suchbedingungen Auswählen von Datensätzen mit Hilfe von Suchbedingungen Ende Ebene 5 Knoten Auswählen von Datensätzen mit Hilfe von Suchbedingungen
Anfang Ebene 5 Knoten Ändern von Datensätzen Ändern von Datensätzen Ende Ebene 5 Knoten Ändern von Datensätzen
Anfang Ebene 5 Knoten Einfügen von Datensätzen Einfügen von Datensätzen Ende Ebene 5 Knoten Einfügen von Datensätzen
Anfang Ebene 5 Knoten Löschen eines Datensatzes Löschen eines Datensatzes Ende Ebene 5 Knoten Löschen eines Datensatzes
Anfang Ebene 5 Knoten Importieren und Exportieren von LONG-Spalten Importieren und Exportieren von LONG-Spalten Ende Ebene 5 Knoten Importieren und Exportieren von LONG-Spalten
Anfang Ebene 3 Knoten Visual-Query-Dialog Visual-Query-Dialog Ende Ebene 3 Knoten Visual-Query-Dialog
Anfang Ebene 4 Knoten Erstellen und Ausführen einer Visual Query Erstellen und Ausführen einer Visual Query Ende Ebene 4 Knoten Erstellen und Ausführen einer Visual Query
Anfang Ebene 5 Knoten Verknüpfen von Tabellenspalten mit Joins Verknüpfen von Tabellenspalten mit Joins Ende Ebene 5 Knoten Verknüpfen von Tabellenspalten mit Joins
Anfang Ebene 5 Knoten Angeben von Suchbedingungen Angeben von Suchbedingungen Ende Ebene 5 Knoten Angeben von Suchbedingungen
Anfang Ebene 6 Knoten Parametrisieren von Suchbedingungen Parametrisieren von Suchbedingungen Ende Ebene 6 Knoten Parametrisieren von Suchbedingungen
Anfang Ebene 5 Knoten Definieren der Ergebnisansicht Definieren der Ergebnisansicht Ende Ebene 5 Knoten Definieren der Ergebnisansicht
Anfang Ebene 3 Knoten Ergebnistabellen Ergebnistabellen Ende Ebene 3 Knoten Ergebnistabellen
Anfang Ebene 4 Knoten Anpassen der Ergebnisansicht Anpassen der Ergebnisansicht Ende Ebene 4 Knoten Anpassen der Ergebnisansicht
Anfang Ebene 4 Knoten Speichern eines Ergebnisses Speichern eines Ergebnisses Ende Ebene 4 Knoten Speichern eines Ergebnisses
Anfang Ebene 3 Knoten Statusfenster Statusfenster Ende Ebene 3 Knoten Statusfenster
Anfang Ebene 3 Knoten Beenden der Datenbanksitzung Beenden der Datenbanksitzung Ende Ebene 3 Knoten Beenden der Datenbanksitzung
Anfang Ebene 2 Knoten Web SQL Studio Web SQL Studio Ende Ebene 2 Knoten Web SQL Studio
Anfang Ebene 3 Knoten Web SQL Studio aufrufen Web SQL Studio aufrufen Ende Ebene 3 Knoten Web SQL Studio aufrufen
Anfang Ebene 3 Knoten An eine Datenbankinstanz anmelden An eine Datenbankinstanz anmelden Ende Ebene 3 Knoten An eine Datenbankinstanz anmelden
Anfang Ebene 3 Knoten Bildschirmbereiche von Web SQL Studio Bildschirmbereiche von Web SQL Studio Ende Ebene 3 Knoten Bildschirmbereiche von Web SQL Studio
Anfang Ebene 3 Knoten SQL-Anweisungen ausführen SQL-Anweisungen ausführen Ende Ebene 3 Knoten SQL-Anweisungen ausführen
Anfang Ebene 3 Knoten WebDAV-Repository öffnen WebDAV-Repository öffnen Ende Ebene 3 Knoten WebDAV-Repository öffnen
Anfang Ebene 3 Knoten SQL-Anweisungen speichern SQL-Anweisungen speichern Ende Ebene 3 Knoten SQL-Anweisungen speichern
Anfang Ebene 3 Knoten Gespeicherte SQL-Anweisung bearbeiten Gespeicherte SQL-Anweisung bearbeiten Ende Ebene 3 Knoten Gespeicherte SQL-Anweisung bearbeiten
Anfang Ebene 3 Knoten Softwareversion von Web SQL Studio anzeigen Softwareversion von Web SQL Studio anzeigen Ende Ebene 3 Knoten Softwareversion von Web SQL Studio anzeigen
Anfang Ebene 3 Knoten Web SQL Studio beenden Web SQL Studio beenden Ende Ebene 3 Knoten Web SQL Studio beenden
Anfang Ebene 2 Knoten SQLCLI SQLCLI Ende Ebene 2 Knoten SQLCLI
Anfang Ebene 3 Knoten An eine Datenbankinstanz anmelden An eine Datenbankinstanz anmelden Ende Ebene 3 Knoten An eine Datenbankinstanz anmelden
Anfang Ebene 3 Knoten Kommando ausführen Kommando ausführen Ende Ebene 3 Knoten Kommando ausführen
Anfang Ebene 4 Knoten Mehrzeilenmodus Mehrzeilenmodus Ende Ebene 4 Knoten Mehrzeilenmodus
Anfang Ebene 4 Knoten Befehlspuffer Befehlspuffer Ende Ebene 4 Knoten Befehlspuffer
Anfang Ebene 4 Knoten Kommando in einer externen Datei bearbeiten Kommando in einer externen Datei bearbeiten Ende Ebene 4 Knoten Kommando in einer externen Datei bearbeiten
Anfang Ebene 4 Knoten Batch-Datei Batch-Datei Ende Ebene 4 Knoten Batch-Datei
Anfang Ebene 4 Knoten Ergebnis in eine Datei umleiten Ergebnis in eine Datei umleiten Ende Ebene 4 Knoten Ergebnis in eine Datei umleiten
Anfang Ebene 3 Knoten SQL-Anweisung ausführen SQL-Anweisung ausführen Ende Ebene 3 Knoten SQL-Anweisung ausführen
Anfang Ebene 3 Knoten Datenbankprozedur ausführen Datenbankprozedur ausführen Ende Ebene 3 Knoten Datenbankprozedur ausführen
Anfang Ebene 3 Knoten Informationen zum Datenbankkatalog abfragen Informationen zum Datenbankkatalog abfragen Ende Ebene 3 Knoten Informationen zum Datenbankkatalog abfragen
Anfang Ebene 3 Knoten Shell-Kommando ausführen Shell-Kommando ausführen Ende Ebene 3 Knoten Shell-Kommando ausführen
Anfang Ebene 3 Knoten SQLCLI beenden SQLCLI beenden Ende Ebene 3 Knoten SQLCLI beenden
Anfang Ebene 3 Knoten Übersicht der Aufrufoptionen Übersicht der Aufrufoptionen Ende Ebene 3 Knoten Übersicht der Aufrufoptionen
Anfang Ebene 3 Knoten Übersicht der SQLCLI-Kommandos Übersicht der SQLCLI-Kommandos Ende Ebene 3 Knoten Übersicht der SQLCLI-Kommandos
Anfang Ebene 2 Knoten Synchronization Manager Synchronization Manager Ende Ebene 2 Knoten Synchronization Manager
Anfang Ebene 3 Knoten Technische Systemlandschaft Technische Systemlandschaft Ende Ebene 3 Knoten Technische Systemlandschaft
Anfang Ebene 4 Knoten Message-Server Message-Server Ende Ebene 4 Knoten Message-Server
Anfang Ebene 4 Knoten Synchronization Manager GUI Synchronization Manager GUI Ende Ebene 4 Knoten Synchronization Manager GUI
Anfang Ebene 4 Knoten Synchronisierungsdienst Synchronisierungsdienst Ende Ebene 4 Knoten Synchronisierungsdienst
Anfang Ebene 4 Knoten Synchronisierungs-Ports Synchronisierungs-Ports Ende Ebene 4 Knoten Synchronisierungs-Ports
Anfang Ebene 3 Knoten Datenmodell Datenmodell Ende Ebene 3 Knoten Datenmodell
Anfang Ebene 4 Knoten Beispiel: Datenmodell Beispiel: Datenmodell Ende Ebene 4 Knoten Beispiel: Datenmodell
Anfang Ebene 3 Knoten Konfiguration Konfiguration Ende Ebene 3 Knoten Konfiguration
Anfang Ebene 4 Knoten Java-Pfade konfigurieren Java-Pfade konfigurieren Ende Ebene 4 Knoten Java-Pfade konfigurieren
Anfang Ebene 4 Knoten Synchronization Manager GUI konfigurieren Synchronization Manager GUI konfigurieren Ende Ebene 4 Knoten Synchronization Manager GUI konfigurieren
Anfang Ebene 4 Knoten Datenbankinstanzen konfigurieren Datenbankinstanzen konfigurieren Ende Ebene 4 Knoten Datenbankinstanzen konfigurieren
Anfang Ebene 4 Knoten Message-Server konfigurieren Message-Server konfigurieren Ende Ebene 4 Knoten Message-Server konfigurieren
Anfang Ebene 4 Knoten Synchronisation konfigurieren Synchronisation konfigurieren Ende Ebene 4 Knoten Synchronisation konfigurieren
Anfang Ebene 5 Knoten Replikationstabellen definieren Replikationstabellen definieren Ende Ebene 5 Knoten Replikationstabellen definieren
Anfang Ebene 5 Knoten Replikationseinheiten definieren Replikationseinheiten definieren Ende Ebene 5 Knoten Replikationseinheiten definieren
Anfang Ebene 5 Knoten Replikationseinheiten aktivieren und deaktivieren Replikationseinheiten aktivieren und deaktivieren Ende Ebene 5 Knoten Replikationseinheiten aktivieren und deaktivieren
Anfang Ebene 5 Knoten Client-Tabellen initialisieren Client-Tabellen initialisieren Ende Ebene 5 Knoten Client-Tabellen initialisieren
Anfang Ebene 5 Knoten Synchronisierungsdienste konfigurieren Synchronisierungsdienste konfigurieren Ende Ebene 5 Knoten Synchronisierungsdienste konfigurieren
Anfang Ebene 3 Knoten Synchronization Manager GUI starten Synchronization Manager GUI starten Ende Ebene 3 Knoten Synchronization Manager GUI starten
Anfang Ebene 3 Knoten An eine Datenbankinstanz anmelden An eine Datenbankinstanz anmelden Ende Ebene 3 Knoten An eine Datenbankinstanz anmelden
Anfang Ebene 3 Knoten Message-Server starten und stoppen Message-Server starten und stoppen Ende Ebene 3 Knoten Message-Server starten und stoppen
Anfang Ebene 3 Knoten An den Message-Server anmelden An den Message-Server anmelden Ende Ebene 3 Knoten An den Message-Server anmelden
Anfang Ebene 3 Knoten Synchronisation Synchronisation Ende Ebene 3 Knoten Synchronisation
Anfang Ebene 4 Knoten Synchronisierungsdienste starten und stoppen Synchronisierungsdienste starten und stoppen Ende Ebene 4 Knoten Synchronisierungsdienste starten und stoppen
Anfang Ebene 2 Knoten Utilities Utilities Ende Ebene 2 Knoten Utilities
Anfang Ebene 3 Knoten Event-Dispatcher Event-Dispatcher Ende Ebene 3 Knoten Event-Dispatcher
Anfang Ebene 4 Knoten Event-Dispatcher in Betrieb nehmen Event-Dispatcher in Betrieb nehmen Ende Ebene 4 Knoten Event-Dispatcher in Betrieb nehmen
Anfang Ebene 5 Knoten Konfiguration für den Event-Dispatcher Konfiguration für den Event-Dispatcher Ende Ebene 5 Knoten Konfiguration für den Event-Dispatcher
Anfang Ebene 4 Knoten Spezielle Events des Event-Dispatchers Spezielle Events des Event-Dispatchers Ende Ebene 4 Knoten Spezielle Events des Event-Dispatchers
Anfang Ebene 4 Knoten Übersicht der Event-Dispatcher-Kommandos Übersicht der Event-Dispatcher-Kommandos Ende Ebene 4 Knoten Übersicht der Event-Dispatcher-Kommandos
Anfang Ebene 5 Knoten add add Ende Ebene 5 Knoten add
Anfang Ebene 5 Knoten delete delete Ende Ebene 5 Knoten delete
Anfang Ebene 5 Knoten list list Ende Ebene 5 Knoten list
Anfang Ebene 5 Knoten start start Ende Ebene 5 Knoten start
Anfang Ebene 5 Knoten state state Ende Ebene 5 Knoten state
Anfang Ebene 5 Knoten stop stop Ende Ebene 5 Knoten stop
Anfang Ebene 5 Knoten version version Ende Ebene 5 Knoten version
Anfang Ebene 3 Knoten XCONS XCONS Ende Ebene 3 Knoten XCONS
Anfang Ebene 4 Knoten Anzeigen von Informationen zur Datenbankinstanz Anzeigen von Informationen zur Datenbankinstanz Ende Ebene 4 Knoten Anzeigen von Informationen zur Datenbankinstanz
Anfang Ebene 3 Knoten XUSER XUSER Ende Ebene 3 Knoten XUSER
Anfang Ebene 4 Knoten Verwenden eines Benutzerschlüssels beim Anmelden an eine Datenba Verwenden eines Benutzerschlüssels beim Anmelden an eine Datenba Ende Ebene 4 Knoten Verwenden eines Benutzerschlüssels beim Anmelden an eine Datenba
Anfang Ebene 4 Knoten Anlegen oder Ändern von XUSER-Einträgen Anlegen oder Ändern von XUSER-Einträgen Ende Ebene 4 Knoten Anlegen oder Ändern von XUSER-Einträgen
Anfang Ebene 4 Knoten Anzeigen der Daten von XUSER-Einträgen Anzeigen der Daten von XUSER-Einträgen Ende Ebene 4 Knoten Anzeigen der Daten von XUSER-Einträgen
Anfang Ebene 4 Knoten Löschen von XUSER-Einträgen Löschen von XUSER-Einträgen Ende Ebene 4 Knoten Löschen von XUSER-Einträgen
Anfang Ebene 4 Knoten XUSER-Optionen XUSER-Optionen Ende Ebene 4 Knoten XUSER-Optionen
Anfang Ebene 4 Knoten XUSER-Einträge aus einer Datei einlesen XUSER-Einträge aus einer Datei einlesen Ende Ebene 4 Knoten XUSER-Einträge aus einer Datei einlesen
Anfang Ebene 3 Knoten X-Server X-Server Ende Ebene 3 Knoten X-Server
Anfang Ebene 4 Knoten Starten des X-Servers Starten des X-Servers Ende Ebene 4 Knoten Starten des X-Servers
Anfang Ebene 4 Knoten Stoppen des X-Servers Stoppen des X-Servers Ende Ebene 4 Knoten Stoppen des X-Servers
Anfang Ebene 4 Knoten Ports und Protokolle des X-Servers Ports und Protokolle des X-Servers Ende Ebene 4 Knoten Ports und Protokolle des X-Servers


SAP liveCache und CCMS Dokumentation

 Entering content frame

Component documentation SAP liveCache und CCMS Dokumentation

Die Dokumentation zum SAP liveCache und der Verwaltung von MaxDB-Datenbanksystemen (früher SAP DB) im Computing Center Management System CCMS ist nur für SAP-Kunden relevant. Sie finden diese Dokumentation deshalb nur im SAP Help Portal unter der Adresse http://help.sap.com.

Leaving content frame


SAP Banner

Entering navigation banner
Entering MaxDB Library Button MaxDB Library Leaving SAP Library Button
SAP Knowledge Warehouse
Leaving navigation banner


SAP Banner

Anfang der Navigationsleiste
Anfang SAP Bibliothek Navigationtaste SAP Bibliothek Ende SAP Bibliothek Navigationtaste Anfang Getting Started Navigationtaste Getting Started Ende Getting Started Navigationtaste Anfang Release-Infos Navigationtaste Release-Infos Ende Release-Infos Navigationtaste Anfang IMG Navigationtaste IMG Ende IMG Navigationtaste Anfang Glossar Navigationtaste Glossar Ende Glossar Navigationtaste Anfang Suchen Navigationtaste Suchen Ende Suchen Navigationtaste Anfang Hilfe zur Hilfe Navigationtaste Hilfe zur Hilfe Ende Hilfe zur Hilfe Navigationtaste
SAP Knowledge Warehouse
Anfang Anwendungsübergreifende Komponenten Navigationtaste Anwendungsübergreifende Komponenten Ende Anwendungsübergreifende Komponenten Navigationtaste Anfang Rechnungswesen Navigationtaste Rechnungswesen Ende Rechnungswesen Navigationtaste Anfang Logistik Navigationtaste Logistik Ende Logistik Navigationtaste Anfang Personalwirtschaft Navigationtaste Personalwirtschaft Ende Personalwirtschaft Navigationtaste Anfang Basis Navigationtaste Basis Ende Basis Navigationtaste Anfang Service Navigationtaste Service Ende Service Navigationtaste
Ende der Navigationsleiste


SAP Banner

Anfang der Navigationsleiste
SAP Training
SAP Knowledge Warehouse
Ende der Navigationsleiste


SAP

 Anfang der Alphabetleiste A B C D E F G H I J K L M N O P Q R S T U V W X Y Z Sonderzeichen Ende der Alphabetleiste


SAP-Bibliothek
SAP NetWeaver 04, März 2004
SAP-Bibliotehk

Glossar

Einführung in das SAP-System
© Copyright 2004 SAP AG
Alle Rechte vorbehalten.


Kaputter Link

Das Ziel des ausgewählten Links ist nicht vorhanden.

 Ende des Inhaltsbereichs