Subject: SDR core dump?

From: Dave Hayes <[email-masked]>
Date: Mon, 06 May 1996 02:55:03 -0700

Subject says it all. Is it just me, or everyone else?
------
Dave Hayes - Altadena CA, USA - [email-masked] 
Freedom Knight of Usenet - http://www.jetcafe.org/~dave/usenet

People sell talking parrots for huge sums.  They never pause to compare the 
possible value of a thinking parrot.                        -Mulla Nasrudin

---

From: Robert Elz <[email-masked]>
Date: Mon, 06 May 1996 20:24:57 +1000

My sdr went away too, and dropped a turd, at 09:53 UTC.

kre

---

From: Yozo Toda (TELEPHONE +81-43-290-3539) <[email-masked]>
Date: Mon, 06 May 1996 19:35:52 +0900

> Subject says it all. Is it just me, or everyone else?

my sdr core-dumped just now.  here is gdb output.

-- yozo.

%%%%%%%%%%%%%%%%%%%%
Script started on Mon May 06 19:25:27 1996
aohakobe:yozo% l core
-rw-r--r--   1 yozo     staff    1402976 May  6 19:22 core
aohakobe:yozo% file core
core:		ELF 32-bit MSB core file SPARC Version 1, from 'sdr.sunOS5.V2.'
aohakobe:yozo% gdb `which sdr` core
GDB is free software and you are welcome to distribute copies of it
 under certain conditions; type "show copying" to see the conditions.
There is absolutely no warranty for GDB; type "show warranty" for details.
GDB 4.14 (sparc-sun-solaris2.4), 
Copyright 1995 Free Software Foundation, Inc...

warning: core file may not match specified executable file.
Core was generated by `sdr'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libX11.so.4...done.
Reading symbols from /usr/lib/libnsl.so.1...done.
Reading symbols from /usr/lib/libdl.so.1...done.
Reading symbols from /usr/lib/libsocket.so.1...done.
Reading symbols from /usr/lib/libc.so.1...done.
Reading symbols from /usr/openwin/lib/libXext.so.0...done.
Reading symbols from /usr/lib/libw.so.1...done.
Reading symbols from /usr/lib/libintl.so.1...done.
Reading symbols from /usr/lib/nss_files.so.1...done.
#0  0xef5d750c in strlen ()
(gdb) where
#0  0xef5d750c in strlen ()
#1  0xef61ecdc in sscanf ()
#2  0x1e46c in parse_entry (advertid=0x0, data=0x1448d0 "v=0", length=0, 
    src=2148548621, hfrom=2148548621, sd_addr=0x15b7d8 "224.2.127.254", 
    sd_port=9875, t=831378131) at ../src/sd_listen.c:818
#3  0x1d5b0 in recv_packets (ix=0x0) at ../src/sd_listen.c:470
#4  0x8a390 in FileHandlerEventProc () at ../src/sip.c:39
#5  0x9b6cc in ServiceEvent () at ../src/sip.c:39
#6  0x9b920 in Tcl_DoOneEvent () at ../src/sip.c:39
#7  0x243ec in Tk_MainLoop () at ../src/sip.c:39
#8  0x1cd84 in main (argc=1, argv=0xeffffa84) at ../src/sd_listen.c:376
(gdb) quit
aohakobe:yozo% exit
script done on Mon May 06 19:26:21 1996
%%%%%%%%%%%%%%%%%%%%