Subject: Promiscous mode ethernet & performance

From: Don McGregor <[email-masked]>
Date: Fri, 15 May 1998 13:10:23 -0700 (PDT)

BTW, I've got some data on how cards going into multicast-
promiscuous mode affects CPU performance. The short story
is that modern CPUs can handle largish amounts of traffic
surprisingly well; a card in promiscous mode can handle
two or three thousand packets/sec and devote about 10-20% of
CPU to the task (166 MHz Pentium, 3Com 10 mb/s card.) The
number of multicast groups the host is subscribed to has
some effect, but it is second order compared to traffic.

See http://www.stl.nps.navy.mil/~mcgredo/projectNotebook/ethernet.html

Comments and criticism welcome.

---

From: Bill Fenner <[email-masked]>
Date: Sat, 16 May 1998 11:06:03 PDT

Don,

  Just to be clear, do you mean promiscuous or multicast-promiscuous?

  Bill

---

From: Don McGregor <[email-masked]>
Date: Sun, 17 May 1998 21:41:53 -0700 (PDT)

>   Just to be clear, do you mean promiscuous or multicast-promiscuous?

Multicast-promiscuous.

The URL I posted earlier was botched.

http://www.stl.nps.navy.mil/~mcgredo/projectNotebook/mcast/ethernet.html