Subject: Re[2]: Creating a DVMRP tunnel

From: "Siraj Shoeb Z."<[email-masked]>
Date: Mon, 15 Dec 97 17:56:04 -0500

Hello:
     
       I looked at the documentation at ftp-eng.cisco.com/ipmulticast.html 
     and configured the routers the following way.  I was wondering if 
     someone would take a look at the configurations and let me know what I 
     am doing wrong.  I would really appreciate it if someone could help. 
     -- Thanks 
     
     P.S. Is 11.2(9) the right version to run.  Do all the routers have to 
     run the same version?
     
     solaris------router1------router2------router3------solaris 
     w/wb         dvmrp        unicast       dvmrp        w/wb

     ---------------------------------------- 
     Configuration for 'router1' running DVMRP 
     ---------------------------------------- 
     version 11.2
     no service udp-small-servers
     no service tcp-small-servers
     
     enable secret 
     enable password 
     !
     ip subnet-zero
     no ip domain-lookup
     ip host bottom 199.242.73.1 199.57.127.6 
     ip host middle 199.57.127.2 199.57.127.5 
     ip multicast-routing
     ip dvmrp route-limit 7000
     !
     interface Loopback0
      no ip address
     !
     interface Tunnel1
      description ip dvmrp tunnel
      ip address 199.57.113.1 255.255.255.0 
      ip pim dense-mode
      ip sdr listen
      tunnel source 199.57.127.1
      tunnel destination 199.57.127.6
      tunnel mode dvmrp
      interface Ethernet0
      description mbone hai side
      ip address 199.55.251.8 255.255.255.0 
      ip pim dense-mode
      ip sdr listen
      load-interval 30
      no mop enabled
     
      interface Ethernet1
      description link to internet
      ip address 199.57.127.1 255.255.255.252 
      ip pim dense-mode
      load-interval 30
      no mop enabled
      !
      interface Ethernet2
      no ip address
      load-interval 30
      shutdown
      no mop enabled
      !
     router ospf 1
      network 199.57.124.0 0.0.0.255 area 199.57.124.0 
      network 199.57.127.0 0.0.0.3 area 0
      network 199.55.251.0 0.0.0.255 area 199.55.251.0 
      network 199.57.113.0 0.0.0.255 area 199.57.113.0
     !
     ip classless
     ip mroute 0.0.0.0 0.0.0.0 Tunnel1
     access-list 10 permit any
     !
     line con 0
     line aux 0
     line vty 0 4
     !
     end

     -------------------------------------------- 
     Configuration for 'router2' "unicast router" 
     --------------------------------------------
     
     version 11.2
     no service udp-small-servers
     no service tcp-small-servers
     !
     ip subnet-zero
     no ip domain-lookup
     !
     interface Ethernet0
      description backbone .2
      ip address 199.57.127.2 255.255.255.252
     !
     interface Ethernet1
      description backbone .5
      ip address 199.57.127.5 255.255.255.252
     
     router ospf 1
      network 199.57.127.0 0.0.0.3 area 0
      network 199.57.127.4 0.0.0.3 area 0
     !
     ip classless
     !
     !
     line con 0
     line aux 0
     line vty 0 4
     
     end
     
     ---------------------------
     Configoration for 'router3'
     ---------------------------
     
     version 11.2
     no service udp-small-servers
     no service tcp-small-servers
     !
     enable secret 
     enable password 
     !
     ip subnet-zero
     no ip source-route
     ip host top 199.57.124.2 199.57.127.1
     ip host middle 199.57.124.2 199.57.127.5 
     ip multicast-routing
     ip dvmrp route-limit 7000
     !
     interface Loopback0
      no ip address
     !
     interface Tunnel1
      ip address 199.57.112.1 255.255.255.0 
      ip pim dense-mode
      ip sdr listen
      tunnel source 199.57.127.6
      tunnel destination 199.57.127.1
      tunnel mode dvmrp
     !
     interface Ethernet0
      description 199.55.252.1
      ip address 199.55.252.1 255.255.255.252 
      ip pim dense-mode
     !
     interface Ethernet1
      description link to backbone
      ip address 199.57.127.6 255.255.255.252 
      ip pim dense-mode
     !
     interface Ethernet2
      no ip address
      shutdown
     !
     interface Ethernet3
      shutdown
     !
     interface Ethernet4
      no ip address
      shutdown
     !
     interface Ethernet5
      no ip address
      shutdown
     !
     router ospf 1
      network 199.57.127.4 0.0.0.3 area 0
      network 199.55.252.0 0.0.0.255 area 199.55.252.0 
      network 199.57.112.0 0.0.0.3 area 199.57.112.0
     !
     ip classless
     access-list 10 permit any
     access-list 100 permit ip any any
     !
     snmp-server community public RO
     !
     line con 0
     line vty 0 4
     !
     end

______________________________ Reply Separator _________________________________
Subject: Re: Creating a DVMRP tunnel  
Author:  "John M. Zwiebel" <[email-masked]>  at internet 
Date:    12/12/97 2:29 PM

ftp://ftp-eng.cisco.com/ipmulticast.html

     
         I was wondering if anybody out there knows where I can find 
         configuration to set up a DVMRP tunnel between two Cisco 4500 routers 
         running IOS 11.2
     
         This is what I am trying to do:
     
         hostX--------router1--------router2-------router3-------hostY 
         w/sdr       multicast      unicast      multicast       w/sdr
     
         I am trying to get configuration information on how to set up 
         'router1' and 'router3' with DVMRP tunnel so that hostX and hostY can 
         exchange multicast packets (vic, vat, wb etc.)
     
         Thanks in advance..

------------------------------------------------------------------------------
        John Zwiebel                       Phone: 408-526-5303 
        Cisco Systems Inc.                 
        Multimedia Group

---

From: Liming Wei <[email-masked]>
Date: Mon, 15 Dec 1997 15:34:36 -0800 (PST)

Siraj,

You want to replace the command "tunnel mode dvmrp" on tunnel1 with
"ip dvmrp unicast-routing", on both end of the tunnel.

-Liming

> Date: Mon, 15 Dec 97 17:56:04 -0500
> From: "Siraj Shoeb Z."<[email-masked]>
> 
>      Hello:
>