Subject: multicast path problem.

From: Dwight Spencer <[email-masked]>
Date: Thu, 13 Nov 1997 12:00:35 -0400

Can someone check this out ... the owner of flashman.cisco.com
was mtracing to my host with no problems (only a couple of mrouted's
in the path even, he said), by my mtrace back to him was this:

teleeducation:/etc# mtrace 171.70.242.10
Mtrace from 171.70.242.10 to 198.164.125.5 via group 224.2.0.1
Querying full reverse path... * switching to hop-by-hop:
  0  teleeducation.nb.ca (198.164.125.5)
 -1  teleeducation.nb.ca (198.164.125.5)  DVMRP  thresh^ 1
 -2  mbone2.onet.on.ca (130.185.89.225)  Unknown protocol code 5  thresh^ 32
 -3  * dec3800-1-fddi-0.NorthRoyalton.mci.net (204.70.98.29)  DVMRP  thresh^ 64 

 -4  * dec3800-1-fddi-0.WestOrange.mci.net (204.70.64.29)  DVMRP  thresh^ 1
 -5  ? (192.36.137.1)  DVMRP  thresh^ 32
 -6  stockholm.mbone.ebone.net (192.36.148.206)  DVMRP  thresh^ 64
 -7  * * * broodjeham.surfnet.nl (192.87.106.102) [mrouted 3.255] didn't respond
 -8  flash.cisco.com (171.70.242.10)
Round trip time 210 ms

Results after 10 seconds:

  Source        Response Dest    Packet Statistics For     Only For Traffic
171.70.242.10   198.164.125.5    All Multicast Traffic     From 171.70.242.10
     v       __/  rtt  211 ms    Lost/Sent = Pct  Rate       To 224.2.0.1
192.36.148.206  stockholm.mbone.ebone.net 
     v     ^      ttl   64        0/1188 =  0% 108 pps     0/0    = --%   0 pps
192.36.137.1    ?
     v     ^      ttl   65       17/1201 =  1% 120 pps     0/0    = --%   0 pps
204.70.64.29    dec3800-1-fddi-0.WestOrange.mci.net
     v     ^      ttl   66       -3/1935 =  0%   0 pps     0/0    = --%   0 pps
204.70.98.45
204.70.98.29    dec3800-1-fddi-0.NorthRoyalton.mci.net
     v     ^      ttl   67       37/3299 =  1%   0 pps     0/0    = --%   0 pps
130.185.89.225  mbone2.onet.on.ca
     v     ^      ttl   68       -1/334  =  0%  33 pps     0/0    = --%   0 pps
198.164.125.5   teleeducation.nb.ca
     v      \__   ttl   69          492         49 pps       0            0 pps
198.164.125.5   198.164.125.5
  Receiver      Query Source

teleeducation:/etc#

He could hear and see me listed (in rat) in the session we were in, but
I could not see him.  Can someone take a look?  The problem looked
to be at 192.36.137.1 and 204.70.64.29

mtracing the Milwaukee Parking Lot Cam,  I get:

teleeducation:/etc# mtrace 129.89.143.30
Mtrace from 129.89.143.30 to 198.164.125.5 via group 224.2.0.1
Querying full reverse path...
  0  teleeducation.nb.ca (198.164.125.5)
 -1  teleeducation.nb.ca (198.164.125.5)  DVMRP  thresh^ 1
 -2  mbone2.onet.on.ca (130.185.89.225)  Unknown protocol code 5  thresh^ 32
 -3  dec3800-1-fddi-0.NorthRoyalton.mci.net (204.70.98.29)  DVMRP  thresh^ 64
 -4  dec3800-2-fddi-1.Atlanta.mci.net (204.70.86.77)  DVMRP  thresh^ 1
 -5  dec3800-1-fddi-1.Dallas.mci.net (204.70.114.45)  DVMRP  thresh^ 1
 -6  dec3800-2-fddi-1.SanFrancisco.mci.net (204.70.158.77)  DVMRP  thresh^ 1
 -7  MCI-WEST.mbone.alter.net (208.205.11.6)  Unknown protocol code 5  thresh^ 6
4
 -8  maew-mbone.nsn.nasa.gov (198.32.136.99)  Unknown protocol code 5  thresh^ 6
4
 -9  mbone1.nap.net (206.54.224.150)  DVMRP  thresh^ 64
-10  alumni.cs.uwm.edu (129.89.143.30)  DVMRP  thresh^ 32
-11  alumni.cs.uwm.edu (129.89.143.30)
Round trip time 208 ms

....

thanks,
dwight s.

______________________________________________________________
dwight spencer				phone:  506 444 5389
internet services manager			fax:    506 444 4232
[email-masked]

TeleEducation NB, 500 Beaverbrook Court, Fredericton, NB, Canada, E3B 5H1

---

From: Bill Fenner <[email-masked]>
Date: Thu, 13 Nov 1997 08:56:36 PST

Dwight,

  You should use mtrace 5.1; there are several bugs in the mtrace 3.8 that
you were using that can give confusing results like the ones you posted.

  mtrace 5.1 points out the problem:

Mtrace from 171.70.242.10 to 198.164.125.5 via group 224.2.0.1
Querying full reverse path... * switching to hop-by-hop:
  0  ? (198.164.125.5)
 -1  teleeducation.nb.ca (198.164.125.5)  DVMRP  thresh^ 1  -17 s    [default]
 -2  mbone2.onet.on.ca (130.185.89.225)  PIM/Special  thresh^ 32  15 s    [default]
 -3  dec3800-1-fddi-0.NorthRoyalton.mci.net (204.70.98.29)  DVMRP  thresh^ 64  -157 s    [default]
 -4  dec3800-1-fddi-0.WestOrange.mci.net (204.70.64.29)  DVMRP  thresh^ 1  162 s    [default]
[...etc]

There's no route for your friend, so it's following the bogus default
route that someone in Europe is advertising.  So, your friend needs to
get a route for his network advertised into the MBone.  It's
notoriously difficult to configure certain routers correctly, but
perhaps your friend has some local expertise that he can consult.

  Bill