Subject: Re: need some help with my 1st mrouted

From: [email-masked] (David PATE)
Date: Wed, 10 Dec 1997 12:00:30 +0100

> Hello,
> I'm trying to run mrouted 3.81 under Linux. I compiled my kernel with
> the multicast option.
> When I try to run mrouted I get the following (mrouted -d 2)
> can't enable Multicast routing in kernel: Protocol not available
> 
> Any idea why?.
> 
> Currently my mrouted.conf only contains this (194.38.160.137 my local
> IP):
> 
> tunnel 194.38.160.137 192.65.185.100  metric 1 threshold 16 rate_limit
> 500
> 

If you look at the result of the dmesg command, you should have a line like :
IP Protocols: IGMP, ICMP, UDP, TCP, IPIP
Linux IP multicast router 0.07
to get it, you have to compile your kernel whith options :
CONFIG_EXPERIMENTAL=y
CONFIG_IP_FORWARD=y
CONFIG_IP_MULTICAST=y
CONFIG_NET_IPIP=y
CONFIG_IP_MROUTE=y           (you must have CONFIG_EXPERIMENTAL=y to do this)

BTW : if someone passed to run mrouted and multicast applications on the same station,
please help me. I still have an unidirectional tunnel. I receive everything, but I don't
sent anything. I've got a 2.0.32 kernel, with a multicast route and mrouted 3.8.1.

	DAVID
	-----

---

From: Christian Burger <[email-masked]>
Date: Wed, 10 Dec 1997 12:09:31 +0100

Hello David

there is a kernelpatch available at:

ftp://ftp.parker.boston.ma.us/pub/mbone/

it's for the 2.0.27. perhaps it works on 2.0.32.
i tried it out, but after patching i wasn't able to recompile the kernel.
chris