Subject: Re: windows / win95 / nt MBONE applications

From: Frank-Uwe Andersen <[email-masked]>
Date: Tue, 26 Nov 1996 21:31:14 +0100

thanks for your answers. they were all correct.

*humor off*

i was confused because in a recent mail in this list
the conclusion was that there is no MROUTED for the
microsoft range of OS yet because the kernels don't
feature the necessary "hooks". but i wrongly concluded
that win 95 etc. wouldn't support multicast at all.

frank

-- 

Frank-Uwe Andersen
[email-masked]

---------------------------------------

---

From: [email-masked]
Date: Tue, 26 Nov 1996 14:11:17 -0800 (PST)

> that win 95 etc. wouldn't support multicast at all.

Just for the sake of completeness, for those who are 
interested there is an experimental *client* program
for the Apple PowerMac available on the Apple developer's
site.  (Thus proving that Apple also supports multicast.)  
The last time I looked, this version was receive-only.  
[And, of course, there is no *mrouted* for the Mac.]  
To run the program, you will need very recent releases 
of System 7.whatever, OpenTransport, etc., but, it does 
work if you put the pieces together correctly.

-Hugh LaMaster

  Hugh LaMaster, M/S 258-5,     Email:       Please send ASCII documents to:
  NASA Ames Research Center     Internet:    [email-masked]
  Moffett Field, CA 94035-1000  Or:          [email-masked] 
  Phone:  415/604-1056          Disclaimer:  Unofficial, personal *opinion*.

---

From: Ross Finlayson <[email-masked]>
Date: Tue, 26 Nov 1996 19:39:22 -0800 (PST)

>minimal mbone tunnel/stub routing for a windows 95/3 system would sure
>be useful right now

Unfortunately Windows 95 (with the default Microsoft TCP/IP stack, at least)
doesn't appear to support IP-in-IP encapsulation, nor raw sockets (which
could otherwise be used to implement IP-in-IP).  This would seem to make it
impossible to implement MBone tunneling for Windows 95 - at least, tunneling
that could connect to a mrouted or other multicast-tunnel-capable router at
the other end.

One way around this would be to implement IP-in-*UDP* tunneling, but then of
course the node at the other end would also have to understand IP-in-UDP.

But as others have mentioned, the 'right' solution here is for the node at
the other end of the user's PPP connection understand multicast routing, so
you wouldn't need a tunnel at all.

        Ross.