Subject: Re: IP mcast per-source pruning

From: [email-masked] (Tim Dorcey)
Date: Thu, 18 Apr 1996 14:22:12 -0500

At 1:47 PM 4/17/96, Ajit Thyagarajan wrote:
>        "Matthew G. Harrigan" wrote:
>>Is anyone developing apps with IGMP v3 in mind yet (with filtereque
>>features), or are all applications being developed specifically  <= v2?
>
>I am not aware of any as yet.  I think it has been the general
>practice for the support to be present in the underlying protocol
>before adding it to the tools.  For example, Vat can shut off audio

We took the opposite approach while developing CU-SeeMe.  Because multicast
was not available on the desktop platforms we were interested in, we built
"reflectors" as a temporary stand-in.  We figured we could begin
experimenting immediately with the user experience, and then tear out the
reflectors as soon as IP multicast with source specific pruning became
widely available on the Internet.  That was over 3 years ago.  I'm glad we
didn't wait.

Tim Dorcey
BoxTop Interactive

---

From: Van Jacobson <[email-masked]>
Date: Thu, 18 Apr 96 18:46:44 PDT

> Is anyone developing apps with IGMP v3 in mind yet (with
> filtereque features), or are all applications being developed
> specifically  <= v2?

We were the ones who started the campaign for source-based
pruning in igmp & have written our apps (vat, vic, wb, etc.)
assuming that it would one day exist.  As soon as it is
available, our apps will use it.  (As Ajit noted, the user
interface is already there.)

Unfortunately, the effect of source-based prunes may not be as
large as one would desire.  An increasing number of PCs running
that slime pit Microsoft calls an OS are appearing on the
MBone.  Despite a great deal of explaining & cajoling on my
part, Microsloth still hasn't incorporated the "bind" fixes that
we got into every Unix system way back in 1991.  (Under win95,
join two vat sessions with different multicast addresses but
the same port & notice that all the members of both sessions
appear in each.)  If they can't get a 3 line fix into "bind" in
5 years, I can't imagine how many centuries it will take for
something significant like upgrading to igmp v3.  And while
there are v2 hosts on a subnet, the v3 source based prunes will
be a nop.

 - Van

---

From: "Myjak, Michael" <[email-masked]>
Date: Mon, 22 Apr 96 10:46:00 EDT

Although we haven't developed an app. specifically for v3, I can see (rather 
easily) how I could use source filtering in distributed interactive 
simulations.

 -- Michael Myjak
   Senior Research Scientist
   Institute for Simulation and Training
 ----------
From: majordom
To: ajit
Cc: mbone
Subject: Re: IP mcast per-source pruning
Date: Wednesday, April 17, 1996 11:15AM

>Per-source joining and leaving is not yet supported in IGMP
>(versions 1 and 2).  Version 3 of IGMP has support for specifying an
>explicit set of sources within a group as well as pruning specific
>sources within a group.

 -Matt

Matthew G. Harrigan             cisco Systems
Internet Systems Engineer       [email-masked]
                                408-527-3852 (x63582)