Subject: Re: Reproducable panic: Digital Unix 4.0B, mrouted.

From: Takashi Ichihara <[email-masked]>
Date: Fri, 27 Jun 1997 14:20:54 JST

>> In message <[email-masked]>, 
>> 	Takashi Ichihara <[email-masked]> writes:
>> 
>> >    The question is how to run the "mrouted" under Digital UNIX
>> > V4.0B without crash.   Did anyone succeed ?
>> 

   "[email-masked]"  "Christopher Samuel" writes:
> I've received the following patch details from DEC (many thanks Ajay).
>[munch]
>
>More news:
>
>It would appear that this patch has been incorporated into the latest
>jumbo patch containing all published fixes from Digital which I'm now
>pulling. It's at:
>
>  ftp://ftp.service.digital.com/public/osf/v4.0b/duv40bas00004-19970609.tar
>
>Be warned though, it's about 34Mb in size!

   Christopher, thank you for the information.   I also received 
a patch from local DEC support just before (No official patchID 
yet, new image of /sys/BINARY/inet.mod (keyword for this patch is 
something like "HPAQ6076M").

     After installing this image and rebuilding kernel, mrouted run 
successfully in my Digital Unix 4.0B (Rev. 564).  Following is an 
summary for this patch information. 

  mrouted patch for  Digital Unix 4.0B (Rev. 564)

(new patch image, [mrouted run normally] )

   %ls -l /sys/BINARY/inet.mod
   -rw-r--r--   1 bin   bin    288882 May 31 00:52 /sys/BINARY/inet.mod
   % strings  /sys/BINARY/inet.mod 
   @(#)$RCSfile: inet_cfg.c,v $ $Revision: 1.1.10.2 $ (DEC) $Date: 1997/04/25 19:59:31 $
   :

(original image, [mrouted does not run (panic, kernel memory fault)
    %ls -l /sys/BINARY/inet.mod.org0
    -rw-r--r--   1 bin   bin    277532 Mar 19 09:09 /sys/BINARY/inet.mod.org0

    % strings  /sys/BINARY/inet.mod.org0 
    @(#)$RCSfile: inet_cfg.c,v $ $Revision: 1.1.2.2 $ (DEC) $Date: 1995/12/15 18:10:01 $
    :

(I'm not sure whether this new image /sys/BINARY/inet.mod is included 
 in the duv40bas00004-19970609.tar of DEC ftpserver or not .)

   Takashi Ichihara
   Radiation lab/Accelerator Research Facility
   RIKEN (The Institute of Physical and Chemical Research)

---

From: Christopher Samuel <[email-masked]>
Date: Fri, 27 Jun 1997 11:35:16 +0100

/*
 * I've set Reply-To back to just myself, but this will be of interest
 * to people running Digital Unix 4.0B.
 */

In message <[email-masked]>, 

>  mrouted patch for  Digital Unix 4.0B (Rev. 564)

This is not the patch that is in the latest jumbo patch, your patch works
and is of a different size and later modification date. :-(

The version of the ip_mroute object in the inet.mod in the latest patch
is:

# strings inet.mod | grep ip_mroute.c
@(#)$RCSfile: ip_mroute.c,v $ $Revision: 1.1.24.2 $ (DEC) $Date: 1997/03/10 21:45:39 $

I'm chasing our DEC people to try and get the right version of the patch.

Chris
-- 
 Christopher Samuel,   IT Vulnerabilities Group,   [email-masked]
 N-115, Defence Research Agency, St Andrews Road, Great Malvern, England, UK
 DISCLAIMER: I write only for myself, not for DRA.    Phone: +44 1684 894644
 +MIME+                           +QMAIL+                              +PGP+