Subject: Re: WEB Front End to SDR

From: Ross Finlayson <[email-masked]>
Date: Mon, 3 Mar 1997 20:57:18 -0800 (PST)

At 05:07 PM 3/3/97 -0800, Bill Nowicki wrote:
>The Silicon Graphics "WebForce Internet Gateway" product
>includes a program that listens to sdr announcements and
>builds a web page dynamically. The SGI version of Netscape
>browser has had a little-known feature since the 2.01S
>release that can launch tools like vat and vic from an
>sdr entry web link

Bill,

Out of curiosity: What kinds of URLs are used for these links; i.e., what is
the HTML?  Are they just regular "http:" URLs that retrieve the session's
SDP description (from the gateway) as a MIME component?  Or do you use your
own "sdp:" (or whatever) URL that encodes the SDP description directly?  Or
do use a "data:" URL that encodes the SDP description (with an associated
MIME type) directly, as 'immediate data' (as described in I-D
draft-masinter-url-data-02.txt).

Personally, I like the third of these options.  It allows the SDP
description to be embedded directly in the HTML (i.e., without requiring a
round-trip to a server), but it doesn't require defining a special URL form
just for SDP.  (Unfortunately, though, I don't think the "data:" URL form is
recognized by most browsers yet.)

        Ross.

---

From: "Bill Nowicki" <[email-masked]>
Date: Tue, 4 Mar 1997 09:40:24 -0800

On Mar 3,  8:57pm, Ross Finlayson wrote:
> SDP description (from the gateway) as a MIME component?

Yes. I did not do it myself, but have set up pages for our recent
multicast events. A mime-types entry was put on the server and the
client, associating extention ".sdr" with "type=application/x-sdr".
The client runs a perl script called "sdr-launch" which reads a file
called mbone-fmt.txt that maps the formats into applications (e.g.
vic, vat, wb etc.). Netscape comes this way standard pre-installed
when you buy any SGI machine.

To create a link, just use http:<whatever>.sdr and put the sdr entry
on the server at that location ending in ".sdr". The SDR listener
builds the page dynamically by listening to sdr announcements.
I wish I could point you to one as an example, but the ones I do
are all inside our firewall.

> just for SDP.

Sure this can be improved; it was meant to be something quick to get
some experience. I do not think our scheme is deployed heavily,
so if you want to write up an internet-draft for a proposed
"best standard practice" or whatever the right name is we can
come up something that inter-operates between browsers and servers
from various vendors (new concept?).

The manager for the SGI Internet Gateway product is Anurag Narula,
email <[email-masked]>.  I think it was Scott Hotes who did
the integration, <[email-masked]>.  I suspect other
implementations were done like this -- is there already a
discussion group or draft proposal?

---

From: Dave Kristol <[email-masked]>
Date: Tue, 04 Mar 1997 13:59:17 -0500

Bill Nowicki wrote:
> [...]

I would dearly love to have the Perl script and mbone-fmt.txt.  Would it
be possible to post them here (if they're *real* short) or on a web or
FTP site somewhere?

Many thanks.
Dave Kristol

---

From: Dave Kristol <[email-masked]>
Date: Tue, 04 Mar 1997 15:11:16 -0500

Carl Malamud [IMS] wrote:
> 
> Hi -
> 
> Bill Fenner's original sd_launch code used to live on my system.  It appears
> that there is a copy at the following URL:
> 
> http://archive.thepoint.net/Software/Internet/Interactive media/MBONE/Session Directory
> 
> This was c code, but PERL works fine.  Its basically a matter
> of parsing the sd format, then putting the parameters into a
> call to the appropriate app.

I used to use sd_launch, and I tried to hack it up for sdr but failed.  I
figured if someone already has something working, I would be more than happy to
use their efforts.

Dave Kristol

---

From: "Carl Malamud [IMS]" <[email-masked]>
Date: Tue, 4 Mar 1997 15:01:41 -0500 (EST)

Hi -

Carl