Subject: The Cisco PIM-DVMRP question

From: HERSENT Olivier CNET/DSE/CAE <[email-masked]>
Date: Fri, 19 Dec 1997 18:21:43 +0100

>  Hello & Happy New Year !
> 
> Before you all leave for vacation, I have an enigma that you might
> have
> encountered previously, and it would be a -BIG- relief if you had an
> answer (please reply to [email-masked]) !
> Thanks in advance (and sorry for the trouble) :
> 
> We have been trying to attach a CISCO with IOS 11.2 to the mbone for
> almost 2 weeks, and it is still not working.
> 
> The configuration is the following :
> 
> tunnel from mBone to a Sun running mrouted 3.8, with TTL threshold 32
> tunnel from the Sun (if 192.190.236.6) to the Cisco at interface
> 192.168.2.53 (eth 1/0), with TTL threshold 16
> and the cisco has an interface 194.199.139.233 running PIM-DM
> 
> the following commands have been used to configure the router :
> ------------------------------
> ip subnet-zero
> ip multicast-routing
> ip multicast cache-headers
> ip sdr cache-timeout 30
> ip dvmrp route-limit 7000
> -----------------------------------------
> interface Tunnel1
>  ip unnumbered Ethernet1/0
>  ip pim dense-mode
>  ip multicast ttl-threshold 16
>  ip dvmrp accept-filter 2
>  ip sdr listen
>  tunnel source Ethernet1/0
>  tunnel destination 192.190.236.6
>  tunnel mode dvmrp 
> ------------------------------------------------
> interface Ethernet1/0
>  ip address 192.168.2.53 255.255.255.0
> !
> interface Ethernet1/1
>  description multicast interface caen
>  ip address 194.199.139.233 255.255.255.248
>  ip pim query-interval 20
>  ip pim dense-mode
>  ip multicast rate-limit out 500000
>  ip igmp version 1
>  ip dvmrp metric 1 list 1
>  ip dvmrp metric 0 list 2
>  ip dvmrp unicast-routing
>  ip sdr listen  
> --------------------------------------------------
> ip classless
> ip route 0.0.0.0 0.0.0.0 192.168.2.1
> ip route 192.168.3.0 255.255.255.0 192.168.4.1
> ip route 194.199.139.0 255.255.255.224 192.168.2.173
> ip route 194.199.139.224 255.255.255.252 192.168.4.1
> ip route 194.199.139.228 255.255.255.252 10.0.0.2
> access-list 1 permit 194.199.139.232 0.0.0.7
> access-list 1 deny   any
> access-list 2 permit any 
> ----------------------------------------------------------------------
> --
> ---------------------------
> 
> I have checked the following : - IGMPv1 is working on
> 194.199.139.232/29
> (the sh ip igmp command shows that the right groups have been
> subscribed).
> 			- The route 194.199.139.232/29 is advertised
> correctly on the mbone
> 			- the multicast packets generated from
> 194.199.139.232/29 are forwarded correctly to the mbone.
> 
> HOWEVER, we don't receive anything from the mbone on the eth1/1
> interface (for instance the listen sdr on tunnel1 works correcly, but
> listen sdr on eth1/1 doesn't receive any session advertisement).
> Actually, when subscribing a group from the 194.199.139.232/29 segment
> we receive sometimes 1 packet, sometimes 0 or a couple right after the
> subscription, and then
> nothing.
> The routes seem to be pruned as in :
> 
> (130.149.226.72/32, 224.2.2.1), 00:02:00/00:00:59, flags: PCT
>   Incoming interface: Tunnel1, RPF nbr 192.190.236.6, Dvmrp
>   Outgoing interface list: Null      
> 
> even though the group 224.2.2.1 has subscribers on eth1/1.
> 
> 
> at first I thought this was an RPF issue, but the mroutes and unicast
> routes seem congruent to me. So I'm beginning to wonder if PIM is
> correctly able to pass group membership information to DVMRP ?
> 
> 		Any hint on this from CISCO gurus ?
> 
> 			Olivier Hersent
> 
>

---

From: "John M. Zwiebel" <[email-masked]>
Date: Fri, 19 Dec 1997 14:41:38 -0800

Which 11.2?  Hopefully not 11.2(8), there was a problem with densemode PIM
forwarding in that version.

Why do you have "dvmrp" configured on ethernet1/1?  Are there other
DVMRP routers on that interface or do you have more ciscos and know that you
need to use this command because your multicast and unicast routing 
topologies are incongurent.

    > the following commands have been used to configure the router :

Why did you change the query-interval?  Theoretically, one should be able to
change these values, but realistically, unless you have a very good reason
for changing them, it isn't a good idea.

    >  ip multicast rate-limit out 500000

this means all RPF lookups will be made using DVMRP.  Perchance have you
received a default DVMRP route?  Where does that point?

    >  ip sdr listen  

Are there other routers on this network forwarding the multicast packets?

    > correctly able to pass group membership information to DVMRP ?

Since there are quite a few other folks that are successful with this
set up, it isn't a PIM/DVMRP problem, but it could be a IOS version problem.
 
    > 		Any hint on this from CISCO gurus ?

You could turn on "deb ip pim <group>" and/or "deb ip mr <group>" and
look for some prunes to come in on the ethernet interface from an
unexpected source.

What does "sh ip pim int" say?
"sh ip igmp int"
"sh ip pim neighbor"

    > 			Olivier Hersent

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 
	Multimedia Group