Subject: multicast Media-On-Demand (mMOD)

From: Peter Parnes <[email-masked]>
Date: Wed, 05 Feb 1997 20:40:20 +0100

Announcing the multicast Media-On-Demand system (mMOD)

As Kevin announced his IMJ today I have to announce my media-on-demand system called mMOD - multicast Media-On-Demand. 

mMOD is  a system for requesting playback of general multicast-sessions, including media as audio and video (of course) but also WB, NTE and other media that aren't RTP-based. The system also allows for random-access within the recording during playback using a VCR-applet.  A major difference from the IMJ-system is that mMOD doesn't adopt the strict channel-paradigm and several playbacks can go on simultaneously. 

The system and more information can be found at
 <URL:http://www.cdt.luth.se/~peppar/progs/mMOD/>. 
That page also includes a short paper describing the system and its features. 

<WARNING>: There is currently no bandwidth limit on the playbacks and no TTL limit but I guess that everybody on the mbone list understands the implication of starting a 1 Mbit/s playback with TTL 127 !!!!! ;-)  </WARNING>

Other features included are:
 
* user-indexing of the recording which allows for the content provider to provide indexes into their recording. These indexes are displayed to the user using a tree-widget in the VCR-applet. 

* Selection of media to play back

* Information about other currently running sessions and their current playout-time

* Automatic launch of corresponding tools if the mLaunch program is installed locally 
<URL:http://www.cdt.luth.se/~peppar/progs/mlaunch/>

* Alternative to play back the session in either unicast or multicast

* Alternative to set the TTL for the playback

* and much more .....

Content: 
The system currently contains a couple of full-length movies, some episodes of "the X-files", lectures from a local under-graduate course in distributed multimedia (in Swedish :-), electronic meetings (from the MATES-project) and some random recordings of sessions from the MBone the last month (such as Usenix, a public PIM meeting, the last NASA launch and MIR-docking, Severe-Tire-Damage etc). 

Background:
mMOD was developed due to a direct need in the Education Direct project which needed a system for recording and playing back general MBone-sessions on demand by the viewers. mMOD is daily being used for viewing recent lectures and meeting-recordings. 

Implementation:  
The system is implemented using Java (100%, no C !!) 

			I love feedback and comments!!!!!! :-)

/P

---

From: Dermot Tynan <[email-masked]>
Date: Thu, 6 Feb 1997 10:48:21 +0000 (GMT)

Peter Parnes wrote:
> 
> [...] my media-on-demand system called multicast Media-On-Demand. 
> 
> The system currently contains a couple of full-length movies, some
> episodes of "the X-files", lectures from a local under-graduate
> course in distributed multimedia (in Swedish :-), [... etc]

I think now is as good a time as any to point out the serious
ramifications of broadcasting copyrighted material without permission.
Unless you have permission from the producers and copyright owners of
those "full-length movies" and X-files episodes, you're in breach of
copyright.  To put this into context, the copyright agencies (such as
MCPS - mechanical copyright protection society) consider the Internet
to be a worldwide audience.  To give just one example, if you use a
piece of library production music in a film or television programme,
you must license that music from MCPS or their equivalent for each
market in which you intend to broadcast the programme.  Regional radio
markets can cost on the order of $15 per 30-second clip.  Worldwide
rights can cost upwards of $600 per clip.  That's just for library
music!

The MCPS are running a pilot scheme at the moment (valid until
September) for people wishing to put music on their web pages.  You can
bet that after september, they'll be chasing down all those people who
use audio clips to enhance their web sites without permission.  No
doubt they'll be looking at MBone broadcasts as well.

The Internet is a new market for most of these copyright protection
organizations, but don't think you've escaped their notice, and don't
think their lawyers will be nice to you because you didn't realise you
had usurped "worldwide broadcasting rights" to those particular
programmes.  Check out "http://www.mcps.co.uk/" for more info...
						- Der
-- 
Dermot Tynan						+353 91 754608
[email-masked]					 DTN: 822-4608

AltaVista Internet Software, Galway, Ireland

---

From: Peter Parnes <[email-masked]>
Date: Thu, 06 Feb 1997 12:24:53 +0100

Well, the reason for putting it online was I thought that the quality was to low
for anyone to care but I stand corrected and the movies have now been removed!!

/P