Subject: VIC and Solaris 2.5 with patches

From: Chris Robson ATDNet Admin <[email-masked]>
Date: Wed, 30 Oct 1996 14:04:28 -0500 (EST)

I have 2 Sparc (a Ultra 1 and a Sparc20) both are running Solaris 2.5 
with patches (august).  If I bring up a session with more than 5 videos 
the vic session crashes.  This doesnt happen on my Sparc 20 4.1.4 box nor 
an SGI.  Any ideas. The Ultra has 64Mb ram and 300Mb swap and the solaris 
2.5 sparc 20 has 1Gb of swap.

thanks chris

---

From: Mark Handley <[email-masked]>
Date: Thu, 31 Oct 1996 10:13:21 +0000

>2.5 sparc 20 has 1Gb of swap.

Sounds like your Solaris boxes are running out of shared memory segments.
Try adding the following to /etc/system:

        set shmsys:shminfo_shmseg=50
        set shmsys:shminfo_shmmax=2097152

Mark

---

From: Koji OKAMURA <[email-masked]>
Date: Thu, 31 Oct 1996 20:10:04 +0900

>         set shmsys:shminfo_shmmax=2097152

I use your sdr's Excellent function :-)

1. make symbolic link of vic.

# cd /usr/local/bin
# ln -s vic vic-noshm

2. make plugin file, in which "vic-noshm" will be executed with "-s" option.
   and cp it into your .sdr/plugins

3. Then, you can choose "vic" or "vic-noshm" on sdr ! :-)

--
Koji

 --- sdr2.plugin.S14.video.rtp.*.vic-noshme ---

media:video
proto:RTP/AVP
protoname:RTP
tool:vic-noshm
fmt:31
{
  fmtname:H.261
  flags:-f h261
}
fmt:28
{
  fmtname:nv
  flags:-f nv
}
fmt:26
{
  fmtname:M-JPEG
  flags:-f jpeg
}
fmt:25
{
  fmtname:Cell B
  flags:-f celb
}
flags:-s
flags:-t $(TTL)
flags:-I $(CHAN)
flags:-C $(SESSNAME)
flags:$(ADDRESS)/$(PORT)

---

From: Graeme Wood <[email-masked]>
Date: Thu, 31 Oct 1996 11:48:05 +0000 (GMT)

>    and cp it into your .sdr/plugins

Yes but this then means you get a performance hit because you are not
using shared memory. The solution that Mark gave I think must be the
preferred one.

=============================================================================
Graeme Wood                                 Email: [email-masked]
Unix Systems Support                        Phone: +44 131 650 5003
The University of Edinburgh                 Fax:   +44 131 650 6552
-----------------------------------------------------------------------------
Scottish MICE National Support Centre       Email: [email-masked]
for your multimedia conferencing support    WWW:   http://mice.ed.ac.uk/mice/
=============================================================================

---

From: Koji OKAMURA <[email-masked]>
Date: Thu, 31 Oct 1996 21:01:16 +0900

Date: Thu, 31 Oct 1996 11:48:05 +0000 (GMT)
From: Graeme Wood <[email-masked]>

> using shared memory. The solution that Mark gave I think must be the

Yes, really I will get a performance hit. But I am using very small PC
which has only 20MB main memory, but its weight is only 850g.
I can send video by vic with PCMCIA Video Capture Card.

--
Koji