Subject: Duplicate packets on CERN - LHCC

From: Gorm Haug Eriksen <[email-masked]>
Date: Thu, 01 Feb 1996 10:52:11 +0100

There is something strange on the CERN - LHCC broadcast @ MBONE:

<tcpdump id 6502 is duplicate>
(tcpdump -v ether multicast and dst 224.2.244.210)
11:28:18.191589 sunmed.cern.ch.1293 > 224.2.244.210.63658: udp 328 (ttl 120, 
id 6502)
11:28:18.197613 sunmed.cern.ch.1293 > 224.2.244.210.63658: udp 328 (ttl 120, 
id 6502)
11:28:18.199629 sunmed.cern.ch.1293 > 224.2.244.210.63658: udp 328 (ttl 120, 
id 6503)
11:28:18.208573 sunmed.cern.ch.1293 > 224.2.244.210.63658: udp 328 (ttl 120, 
id 6505)
</tcpdump>

Also, a program that looks in the headers of the vat packets :

Collecting duplicate information for 224.2.244.210, port 63658

Estimating # of samples pr. pkt : - - - - - -> 320

Sender           Packets:   received   duplicates   lost       10:27 1/2/96
-----------------------------------------------------------------------------
137.138.31.200              1814       82           171  

Sender           Packets:   received   duplicates   lost       10:28 1/2/96
-----------------------------------------------------------------------------
137.138.31.200              1509       60           49   

Sender           Packets:   received   duplicates   lost       10:29 1/2/96
-----------------------------------------------------------------------------
137.138.31.200              1437       62           123  

Sender           Packets:   received   duplicates   lost       10:30 1/2/96
-----------------------------------------------------------------------------
137.138.31.200              1530       86           58   

Sender           Packets:   received   duplicates   lost       10:31 1/2/96
-----------------------------------------------------------------------------
137.138.31.200              1543       105          60   

<mtrace>
  Source        Response Dest    Packet Statistics For     Only For Traffic
137.138.31.200  129.240.140.21   All Multicast Traffic     From 137.138.31.200
     |       __/  rtt  162 ms    Lost/Sent = Pct  Rate       To 224.2.244.210
     v      /     hop -557 ms    ---------------------     --------------------
137.138.31.193 
128.141.211.65  r31-s-rci25-2-gb0.cern.ch 
     |     ^      ttl    0   
     v     |      hop  105 ms     0/381  =  0%  38 pps     0/370  =  0%  37 pps
128.141.211.1   b513-b-rsuix-2.cern.ch 
     |     ^      ttl    8   
     v     |      hop 2012 ms     2/381  =  1%  38 pps     2/370  =  1%  37 pps
192.65.185.20   mbone.cern.ch  
     |     ^      ttl   48   
     v     |      hop -119 s    -58/392  =-14%  39 pps   -58/368  =-15%  36 pps
192.87.106.102 
192.87.4.25     broodjeham.surfnet.nl 
     |     ^      ttl   49   
     v     |      hop  138 s      6/478  =  1%  47 pps     6/426  =  1%  42 pps
194.68.128.50  
192.36.148.206  stockholm.mbone.ebone.net 
     |     ^      ttl   50   
     v     |      hop  -20 s     -2/1021 =  0% 102 pps     0/420  =  0%  42 pps
</mtrace>

--

From mtrace, it looks like the problem is from 128.141/16.

I have seen up to one duplicate for every two packets.

Can someone check this out at CERN?

- Gorm Haug Eriksen
  Mice-Nsc Norway / +47 22852731

---

From: "Christian Isnard - CERN/CN/CS" <[email-masked]>
Date: Thu, 1 Feb 1996 14:20:43 +0100 (MET)

Thanks for informing us. The explanation for these duplicate packets
is still unclear. We are investigating.
FYI, the broadcast stopped at 11:30 (MET).

Best regards,
--------------------------------------------------------------------
Christian Isnard                                     CERN - CN/CS/EN
[email-masked]       European Laboratory for Particle Physics
Tel: +41 22 767 23 94                Computers and Networks division
Fax: +41 22 767 71 55                CH-1211 Geneva 23 - Switzerland

---- Text sent by Gorm Haug Eriksen follows: ----
> Return-Path: <[email-masked]>
> Received: from aun.uninett.no by goggins.uio.no with SMTP (PP) 
>           id <[email-masked]>; Thu, 1 Feb 1996 10:59:40 +0100
> Received: from sics.se by aun.uninett.no with SMTP (PP);
>           Thu, 1 Feb 1996 10:56:08 +0100
> Received: by sics.se (5.65+bind 1.7+ida 1.4.2/SICS-1.4) id AA01611;
>           Thu, 1 Feb 96 10:53:21 +0100
> Received: from venera.isi.edu by sics.se (5.65+bind 1.7+ida 1.4.2/SICS-1.4) 
>           with SMTP id AA01593; Thu, 1 Feb 96 10:53:15 +0100
> Received: by venera.isi.edu (5.65c/5.61+local-22) id <AA23607>;
>           Thu, 1 Feb 1996 01:53:12 -0800
> Received: from pat.uio.no by venera.isi.edu (5.65c/5.61+local-22) id <AA23598>;
>           Thu, 1 Feb 1996 01:53:08 -0800
> Received: from ulrik.uio.no by pat.uio.no with local-SMTP (PP) 
>           id <[email-masked]>; Thu, 1 Feb 1996 10:52:18 +0100
> Received: from marion by marion.uio.no ; Thu, 1 Feb 1996 09:52:14 GMT
> Message-Id: <[email-masked]>
> X-Mailer: exmh version 1.6.2 7/18/95
> To: [email-masked]
> 
> Cc: [email-masked]
> Subject: Duplicate packets on CERN - LHCC
> Mime-Version: 1.0
> Content-Type: text/plain; charset=us-ascii
> Date: Thu, 01 Feb 1996 10:52:11 +0100
> From: Gorm Haug Eriksen <[email-masked]>
> 
>