Subject: Re: automated launch

From: [email-masked] (Jan-Peter Richter)
Date: Wed, 12 Jun 1996 09:31:24 +0200 (MET DST)

> A question or two...
> 
> We would like to have a machine broadcasting an in-house video channel 
> all the time.  Thus, I would like to be able have the mbone utilities 
> launch on boot (in case the transmitting machine crashes).  Is this 
> possible?  I can't seem to get the tools to automatically transmit on 
> startup.
[...]
> ----
> Jim Bogard  JHU/APL BIX Group             "This is my banjo.  There are many
> Backbone Network Engineer                   like it, but this one is mine."

After you automatically launch vic you can start a wish script, that
"presses" the transmit button by tk-'send'-ing an invokation:

	send vic { .menu.cb.frame.buttons.send invoke }

This is a hack but it will probably work.

enjoy

	Jan-Peter Richter

------------------------------------------------------------------------------
Jan-Peter Richter				Vogt-Koelln-Str.30
Universitaet Hamburg				D-22527 Hamburg
Fachbereich Informatik				Tel: +49 40 54715-344
Arbeitsbereich Rechnerorganisation		Fax: +49 40 54715-345

e-mail:	[email-masked]

NEW TELEPHONE NUMBER IN JUNE: from 6-28-96 the telephone number will be:

	Tel.:	+49 40 5494-2344
	Fax.:	+49 40 5494-2328
------------------------------------------------------------------------------

---

From: Bob Olson <[email-masked]>
Date: Wed, 12 Jun 1996 07:31:06 -0500

this is what the user_hook is for in vic; I use the following to set
it up for high bandwidth/framerate and to start transmission. 

option add Vic.maxbw 8000 startupFile
option add Vic.bandwidth 5000 startupFile
option add Vic.defaultFormat jpeg startupFile
option add Vic.mtu 4096 startupFile
#option add Vic.framerate 1 startupFile
option add Vic.framerate 20 startupFile

#
# Invoked after everything else is set up.
#

proc user_hook {} {
    global transmitButton
    build.menu
    $transmitButton invoke
}