Subject: Configuring MBone on 3Com router

From: Toerless Eckert <[email-masked]>
Date: Mon, 28 Oct 1996 13:20:05 +0100 (MET)

Hi

I've to configure multicast routing on 3Com routers.
I am totally unused to 3Com routers and would appreciate help
from people who know.

Basically i need to know:
- What software release should i run (or avoid or will work).
- What is the basic minimum configuration to get
  a) a DVMRP tunnel set up
  b) some intra-area multicast routing running (any multicast routing
     protocol, i.e.: MOSPF or DVMRP or PIM ?)

Thanks
	
-- 
Toerless Eckert
Universitaet Erlangen Nuernberg
Lehrstuhl fuer Betriebsysteme 
Martensstrasse 1
D-91058 Erlangen, Germany
Tel.: +49 9131 85 7278
FAX: +49 9131 85 8732
[email-masked]
/C=De/A=D400/P=Uni-Erlangen/OU=Informatik/S=Eckert/G=Toerless/

---

From: "Cyndi M. Jung" <[email-masked]>
Date: Mon, 28 Oct 1996 09:13:27 -0800 (PST)

I've copied the list, sorry if it's too long.

Cyndi

>      protocol, i.e.: MOSPF or DVMRP or PIM ?)

Toerless,

	It's easy, but if you are unfamiliar with the product,
I'm sure it isn't obvious.

	The command set is divided into groups called "services" -
if you use the command "menu" it presents all the configuration
parameters to you in a menuing system, with the top level listing the
different services, then within each service are listed the various
parameters.  Most people start with the "menu" command until they are
familiar with the system and then use the command line commands - but
still the "menu" system is good for even people familiar with the system
but have perhaps forgotten exactly how to spell some parameter name or
the syntax of the value.

	You should be running at least version 8.3 (we are up to 9.1 released,
and 9.2 is in beta test).  We have different packages of software, and
multicast IP support is only on the "Full Feature" package.  This means
you need the Flash Drive installed so that you can hold the binary and
config files (the chassis always has a diskette, but it is quickly running
out of room for all the software).  You also need the 20MB CPU card, CEC20.
Hopefully that's already been taken care of.

	There are 3 services involved with multicast - MIP, which is common
to both routing protocols, DVMRP, and MOSPF, which requires OSPF configured
to be used.  The DVMRP can be used even when IP routing is disabled, so it
is convenient to a firewalled site.

Configure the DVMRP interfaces:
	Configure a tunnel in DVMRP - pick a tunnel index 1-32, I picked 1 here
		setd !T1 -dvmrp tunnel = <local-IP> <peer-IP> 
	Configure a second tunnel if you need to
		setd !T2 -dvmrp tunnel = <local-IP> <peer-IP> 
	Enable each tunnel/physical interface.
		setd !t1 -dvmrp cont = enable
		setd !t2 -dvmrp cont = enable
		setd !1 -dvmrp cont = enable
		setd !4 -dvmrp cont = enable
Enable Multicast IP.
		setd -mip cont = e
--------------------------------------------------------------------------------	
Check for the tunnels to be established
	Display the DVMRP neighbor routers:
		show -dvmrp neighborrouter
E.G.
[4]NETBuilder # sh -dv nr
Port IPAddress       GenerationID  Version TTL   Status                        
===============================================================================
!T1  131.119.244.11  845076085      3.8    140   ~Leaf, Prune, GenID, MTrace
!T2  129.213.32.117  844311745      3.38   135   ~Leaf, Prune, GenID, MTrace

Check to see if the routes are arriving from the peer:
	Display the DVMRP routing table
		show -dvmrp routetable
[6]NETBuilder # sh -dv rt
------------------------------DVMRP Routing Table------------------------------
Number of route entries = 3241
SourceSubnet    SubnetMask      FromGateway     Metric Status  TTL  Type  InPort
================================================================================
4.0.0.0         255.0.0.0       131.119.244.11  4      Up      170  DVMRP T1
9.0.0.0         255.0.0.0       131.119.244.11  8      Up      170  DVMRP T1
10.0.0.0        255.0.0.0       131.119.244.11  6      Up      170  DVMRP T1
13.0.32.0       255.255.252.0   131.119.244.11  12     Up      175  DVMRP T1
13.1.100.0      255.255.252.0   131.119.244.11  10     Up      175  DVMRP T1
13.1.136.0      255.255.252.0   131.119.244.11  11     Up      175  DVMRP T1
13.1.140.0      255.255.252.0   131.119.244.11  13     Up      175  DVMRP T1
--<CR> to continue, Q to quit--

Check the forwarding status of various sessions
	Display the DVMRP forwarding table
		show -dvmrp forwardingtable
[5]NETBuilder # sh -dv ft
----------------------------DVMRP Forwarding Table-----------------------------
Number of forwarding entries = 193
SourceSubnet    MulticastGroup  TTL   InPort   OutPorts
=======================================================
13.1.100.0      224.2.175.209   295   T1        T2p MOSPF
13.2.116.0      224.2.0.1       290   T1        T2p MOSPF
                224.2.5.153     10    T1  Pr    T2p MOSPFp 
                224.2.100.100   110   T1  Pr    T2p MOSPFp 
                224.2.120.235   265   T1  Pr    T2p MOSPFp 
                224.2.129.197   175   T1  Pr    T2p MOSPFp 
                224.2.134.176   250   T1  Pr    T2p MOSPFp 
                224.2.142.37    265   T1  Pr    T2p MOSPFp 
                224.2.154.45    50    T1  Pr    T2p MOSPFp 
                224.2.162.174   240   T1  Pr    T2p MOSPFp 
                224.2.162.222   20    T1  Pr    T2p MOSPFp 
                224.2.165.1     10    T1  Pr    T2p MOSPFp 
                224.2.167.31    50    T1  Pr    T2p MOSPFp 
                224.2.175.209   280   T1        T2p MOSPF

Here are some more parameters of DVMRP.  The menu command can take a
service name as an argument and drop into the service level menu.

[3]NETBuilder # menu -dvmrp

========================= DVMRP service menu (Level 2)=========================
   1  - AggregateExcept ( Add Delete )     2  - AggregateRange  ( Add Delete )
   3  - BoundaryAddr    ( Add Delete )     4  - CacheTime       ( SetD )
   5  - CONFiguration                      6  - CONTrol         ( SetD )
   7  - DestGroup       ( Add Delete )     8  - ForwardTable    
   9  - MEtric          ( SetD )           10 - MOspf           ( Add Delete )
   11 - NEighbor        ( Add Delete )     12 - NeighborRouter  
   13 - PolicyControl   ( SetD )           14 - Prune           ( SetD )
   15 - RateLimit       ( SetD )           16 - RouteTable      ( Flush )
   17 - TUnnel          ( SetD )           18 - UpdateTime      ( SetD )
Select (1-18) ... <CR> to Exit ===> 17

============================= SHow -DVMRP TUnnel ==============================
Port LocalIP         RemoteIP         Metric  Threshold  Init-TTL
=================================================================
!T1  129.213.128.9   131.119.244.11   1       32         64 
!T2  129.213.128.9   129.213.32.117   1       1          64 
!T3  129.213.128.9   129.213.48.27    1       1          64 
!T4  129.213.128.9   129.213.200.38   1       1          16 
==================== -DVMRP TUnnel parameter menu (Level 3)====================
   1  - SetD 
Select (1-1) ... <CR> to Exit ====> 1
Enter !<tunnel ID> (mandatory) => t5
   SetD       !<tunnel ID> TUnnel         = {<local-end IP> <remote-end IP> [<ttl> (1-255)] | None}
   SetD       !T5          TUnnel         = 

Here, we use DVMRP for the MBONE tunnel, then that router interfaces to an
OSPF domain where some of the routers are also multicast enabled.  That
same router has another tunnel to a second router running both DVMRP and
MOSPF in a separate OSPF system.  We set a high threshold on the MBONE tunnel
to keep local traffic from escaping.

To configure MOSPF, first get the OSPF set-up, then enable MOSPF on
the interfaces involved in multicast (it might be all of them):

Enable MOSPF on each port in the OSPF system:
	setd !3 -mospf control = enable
	setd !4 -mospf control = enable
		... etc ...

To configure interworking between MOSPF and DVMRP there is a parameter in both 
the DVMRP and MOSPF services called "PolicyControl" - in DVMRP there is a 
choice of MOSPF | NoMOSPF - and in MOSPF there is a choice DVMRP | NoDVMRP.

Enable interworking between DVMRP and MOSPF:
	setd -dvmrp policycontrol = mospf
	setd -mospf policycontrol = dvmrp

You probably don't want all the OSPF routes injected into DVMRP, so you
can aggregate them using the MOSPF parameter in DVMRP as follows:
	add -dvmrp mospf <subnet>/<mask> Aggregate
(here <mask> is the number of bits in the <subnet> to advertise)
You may need this multiple times for different subnet prefixes.

You also don't want the DVMRP routes in your MOSPF system, but
you need to inject them if MOSPF is going to be able to do the
Reverse Path lookup - we have injected all of them, and they are
imported as Externals into OSPF which is really kind of cheap,
but it should be straightforward to aggregate many of them - just
tedious and we haven't done it.

Import all DVMRP routes into MOSPF system:
	add -mospf dvmrp 0.0.0.0/0 individual inf t1

Filter out all subnets of 13 when importing from DVMRP into MOSPF
	add -mospf dvmrp 13.0.0.0/8 reject

[20]NETBuilder # menu -mospf dvmrp

============================== SHow -MOSPF Dvmrp ==============================
Subnet/Mask            Status     Metric     Type
0.0.0.0 / 0            Individual INFinity   Type1
==================== -MOSPF Dvmrp parameter menu (Level 3)=====================
   1  - Add 
   2  - Delete 
Select (1-2) ... <CR> to Exit ====> 1
   Add        Dvmrp          <subnet>/<mask> [Aggregate|Individual|Reject] [<metric>] [Type1|Type2]
   Add        Dvmrp          

This is what the DVMRP updates look like in your link state database:
-------------------------------------------------------------------------------
LS Type  Link State ID   Router ID   LS Seq      LS Age    Opt. Flag/Mask
External 13.1.100.0      0x8B570CF3* 0x8000026C   430      0x26 255.255.252.0 

Forwarding Address   Metric   TOS  Metric Type  Route Tag
0.0.0.0              16777215 0    Type1        0
-------------------------------------------------------------------------------
LS Type  Link State ID   Router ID   LS Seq      LS Age    Opt. Flag/Mask
External 13.1.136.0      0x8B570CF3* 0x8000026C   430      0x26 255.255.252.0 

Forwarding Address   Metric   TOS  Metric Type  Route Tag
0.0.0.0              16777215 0    Type1        0

This is what the group membership LSAs look like in your link state database:
[21]NETBuilder # sh -ospf lsd g
-----------Area 139.87.172.0   CksumSum 0073927C   LSA (12R 6N 214S)-----------
LS Type  Link State ID   Router ID   LS Seq      LS Age    Opt. Flag/Mask
Group    224.0.1.24      0x8B570CFE  0x800002E4   1021     0x06 
Group    224.2.0.1       0x8B57AC01  0x8000014D   992      0x06 
Group    224.2.127.254   0x8B57AC01  0x8000014D   992      0x06 
Group    224.2.175.209   0x8B57AC01  0x8000014D   992      0x06 
Group    239.239.239.10  0x8B570CF4  0x8000049C   91       0x06 

This is what the MOSPF forwarding table looks like:

[22]NETBuilder # sh -mospf ft
Total Routes = 30
Destination     Source          Upstream        Downstream      TTL
224.2.0.1       140.185.50.3    External        !4              2
224.2.0.1       206.246.160.2   External        !4              2
224.2.127.254   140.173.8.3     External        !4              2
224.2.127.254   199.94.220.184  External        !4              2
224.2.175.209   13.2.116.11     External        !4              2
224.2.175.209   128.84.247.157  External        !4              2
224.2.175.209   171.69.57.11    External        !4              2
239.239.239.10  129.213.208.136 !4              Dvmrp           -

To get statistics for DVMRP:
[23]NETBuilder # sh stat -dvmrp
ACCUMULATED VALUES
============================== DVMRP statistics ===============================
 Rcvd from MOSPF                              435229 
 Sent to MOSPF                              26677844 
 Pruned by MOSPF                              217279 
 Graft from MOSPF                                 27 
== DVMRP statistics ======== 1===== 2===== 3===== 4==== T1==== T2==== T3==== T4
 DVMRP Statistics : 
  Pkts Received(total)       0 232237      0      0 584404  2133K      0      0
     Reports                 0 103105      0      0 481413  1527K      0      0
     Prunes                  0 109847      0      0      0 504660      0      0
     Grafts                  0      0      0      0      0      0      0      0
     Graft Acks              0      0      0      0   1100      0      0      0
  Pkts Transmitted 
     Reports             1426K  1426K  1426K      0  1426K  1426K  1426K  1426K
     Prunes                  0      0      0      0 474276      0      0      0
     Grafts                  0      0      0      0   1144      0      0      0
     Graft Acks              0      0      0      0      0      0      0      0
  Pkts Forwarded             0 213540      0      0  12445  8171K      0      0
  Pkts Discarded 
     No Route                0      0      0      0  11879      0      0      0
     Wrong Port              0      0      0      0      0      0      0      0
     Unknown Type            0      0      0      0      0      0      0      0
     Misc. Err               0      0      0 415184  68710      0      0      0
 IP over IP Statistics  
  Pkts Received            322      0      0      0 30019K   5418      0      0
  Pkts Discarded           322      0      0      0      0      0      0      0

To get statistics for MOSPF:
[24]NETBuilder # sh stat -mospf
ACCUMULATED VALUES
============================== MOSPF statistics ===============================
 SPF calculations                             372961 
 Cache flushed                                 10934 
 Rcvd from DVMRP                            26678060 
 Sent to DVMRP                                435247 
 Prune back DVMRP                             217299 
 Resource error                                    0 
 Internal Client Transmit                          0 
 Internal Client Receive                           0 
 Internal Client Errors                            0 
== MOSPF statistics ============== 1========= 2========= 3========= 4==========
 Receive   
  Good                             0          0          0     435247 
  No Route                         0          0          0          0 
  Bad MAC Address                  0          0          0          0 
  Wrong Source                     0          0          0          0 
  TTL exceeded                     0          0          0          0 
  Recv Disabled                    0          0          0          0 
 Transmit  
  Good                             0          0          0   26457987 
  TTL too small                    0          0          0          0 
  Xmit Disabled                    0          0          0          0 
  failure                          0          0          0          0