Subject: IP multicasting with CISCO

From: "Toma Belichki" <[email-masked]>
Date: Thu, 30 Oct 1997 11:15:41 +0200

Dear All,
Excuse me for the stupid question. I'm absolutely novice with multicasting.
We have CISCO AGS (IOS v.11.0(10)), the task is to enable multicasting between 
it's two Ethernet interfaces.
The commands I type are:
ip multicast-routing  
interface Ethernet0  ip pim dense-mode þ
ip igmp query-interval 5
interface Ethernet1  ip pim dense-mode 
ip igmp query-interval 5

Obviosly that's not enough. What else do I need?
Thanks
Toma

---

From: "John M. Zwiebel" <[email-masked]>
Date: Thu, 30 Oct 1997 05:56:04 -0800

Actually, this is enough.  Please remove the "ip igmp query-interval 5" and
let that run at its default rate.  Changing it invites trouble unless you have
some good reasons for doing so and you understand the consequences.

What makes you think it wasn't enough?

This is a very old image.  11.0 included fastswitching for multicast packets.
It is possible that the mcache doesn't work correctly, so if you know you
are sending mpackets and that they aren't being forwarded, you should
look at "sh ip mc" and if it is empty or corrupted, then on the interface
"no ip mroute-c".  

Another "favorite" problem is the source sends mpackets with a ttl that by
default is 1.  Such a packet will not be forwarded.

Please look at ftp://ftp-eng.cisco.com/ipmulticast.html

    Dear All,
    Excuse me for the stupid question. I'm absolutely novice with multicastin=
    g.
    We have CISCO AGS (IOS v.11.0(10)), the task is to enable multicasting be=
    tween=20
    it's two Ethernet interfaces.
    The commands I type are:
    ip multicast-routing =20
    interface Ethernet0  ip pim dense-mode =FE
    ip igmp query-interval 5
    interface Ethernet1  ip pim dense-mode=20
    ip igmp query-interval 5

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 
	Multimedia Group                   

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

     Paranoids are people, too;  they have their own problems.  It's
     easy to criticize, but if everybody hated you, you'd be paranoid, too.

                                  --UNKNOWN

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

---

From: [email-masked]
Date: Thu, 30 Oct 1997 15:14:52 +0100

> This is a very old image.  11.0 included fastswitching for
> multicast packets.  It is possible that the mcache doesn't work
> correctly, so if you know you are sending mpackets and that
> they aren't being forwarded, you should look at "sh ip mc" and
> if it is empty or corrupted, then on the interface "no ip
> mroute-c".

Right.  If I remember correctly (I think I do...), the most
severe IP multicast fastswitching bug on the AGS was cured in
11.0(13).

Regards,

- Håvard