Subject: Re: multiple sdr -- found the problem

From: Mark Tinguely <[email-masked]>
Date: Tue, 28 Apr 1998 15:38:20 -0500 (CDT)

ps to earlier note:
udp_input() in udp_usrreq.c should take care of distributing to ALL
sockets once you have bind working. see comment starting around line 182. 

--mark.

---

From: Mark Tinguely <[email-masked]>
Date: Tue, 28 Apr 1998 16:10:34 -0500 (CDT)

Bill says:

>  If you set SO_REUSEADDR (or SO_REUSEPORT on 4.4BSD), multiple sockets
>  may be bound to the same address/port, and multicast packets are delivered
>  to each matching socket.

that is what SUPPOSE to happen, but I sent the code snip to Luigi that
show that in function in_pcbbind() in file /sys/inet/in_pcb.c about line 197
that this is done wrong. I don't know if I did a group reply...if I did
not Luigi could you send it to Bill for him to look at it.

--mark.