Subject: Mbone over ISDN

From: [email-masked] (Dan Rose)
Date: Thu, 3 Apr 1997 13:11:55 -0500

Has anyone try to run an mbone session
over ISDN line?  I would be very interested
in trying to make this work.

		Dan
		
-----------------------------------------------------
Daniel L. Rose  (908)957-2073  [email-masked]

---

From: "John M. Zwiebel" <[email-masked]>
Date: Thu, 03 Apr 1997 10:48:06 -0800

I think I heard you say....

Yes.  Cisco's support this.

Here is the configuration I use on my home router (a c1004) which requires
the "bnsy" image.  Of course, we do PIM inside of cisco.  If you need
DVMRP information it can also be disseminated across the ISDN link.

Most people forget the "broadcast" keyword in the dialer map.

Look at ftp://ftp-eng.cisco.com/ipmulticast.html
	or in http://www.cisco.com

for information on the commands.

!
version 11.2
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname ***
!
boot system flash 
enable password 7 072A2F48411B090D461C
!
username tgv-eng-pri1 password 7 070371185713
ip subnet-zero
ip rcmd rsh-enable
ip rcmd remote-username jzwiebel
!***
ip domain-name cisco.com
ip name-server ***
ip name-server ***
ip name-server ***
ip multicast-routing
ip dvmrp route-limit 7000
appletalk routing
isdn switch-type basic-5ess
clock timezone PST -8
clock summer-time PDT recurring
!
interface Ethernet0
 ip address <address> 255.255.255.248
 ip pim sparse-mode
 appletalk cable-range ***
 appletalk zone ***
!
interface BRI0
 ip unnumbered Ethernet0
 ip pim sparse-mode
 no ip mroute-cache
 encapsulation ppp
 load-interval 30
 appletalk cable-range ***
 appletalk zone ***
 dialer idle-timeout 300
 dialer map ip <address> name tgv-eng-pri1 broadcast <number>
 dialer hold-queue 10
 dialer load-threshold 10 either
 dialer-group 1
 isdn spid1 ***
 priority-group 1
 compress stac
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 0.0.0.0 0.0.0.0 ***
ip route ***
ip route ***
ip pim rp-address ***
access-list 101 deny   icmp any any
access-list 101 deny   igmp any any
access-list 101 deny   udp any any eq ntp
access-list 101 deny   udp any any eq snmp
access-list 101 deny   udp any any eq snmptrap
access-list 101 deny   udp any any eq netbios-ns
access-list 101 deny   ip any 224.0.0.0 15.255.255.255
access-list 101 permit ip any any
access-list 601 deny other-access
tacacs-server host ***
tacacs-server host ***
dialer-list 1 protocol ip list 101
dialer-list 1 protocol appletalk list 601
banner motd ^C
Welcome to Santa Cruz
John Zwiebel 
^C
!
line con 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 login tacacs
!
end

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 Fax:   
	Multimedia Group                   Email: [email-masked]

---

From: Magnus Danielson <[email-masked]>
Date: Thu, 03 Apr 1997 20:59:40 +0200

>>>>> "DR" == Dan Rose <[email-masked]> writes:

 DR> Has anyone try to run an mbone session
 DR> over ISDN line?  I would be very interested
 DR> in trying to make this work.

Oh yes, I have done that. I ran an DVMRP tunnel over a 2B ISDN line to
a workstation. It worked great except for the obvious bandwidth
limit. I did make exlicit bandwidth limit in both ends.
The irony was that the session I was tuned to lost 30 % of it's
packets in one of the first hops and not on my ISDN line.

Once you have IP up it should not be very diffrent from any other tunneling
with limited bandwidth.

I don't know for sure about ISDN/IP routers and/or bridges which
properly deals with multicast thougth there should be such around, at least
the bridges should be able to do it.

Cheers,
Magnus

---

From: Bill Fenner <[email-masked]>
Date: Thu, 3 Apr 1997 11:21:21 PST

I run a tunnel over my ISDN line to home.  I set the rate limit to 100kbps
so I still have a little bandwidth left over, and with the limited priority
queueing in the UNIX kernel it works extremely well.

  Bill

---

From: "Dorian R. Kim" <[email-masked]>
Date: Thu, 3 Apr 1997 15:25:03 -0500 (EST)

We've tried it once. We basically had two Cisco 2500s on each side of ISDN
line and tunneled PIM Sparse-dense mode across it. (we couldn't figure out how
to make this work with bitsurfers) So it was an ugly hack but it worked fine
for most groups. There are some groups that weren't meant for ISDN though.

This is fine for a hack to get mbone at home with ISDN, but for anything else,
I wouldn't recommend it.

-dorian

---

From: Larry Rowe <[email-masked]>
Date: Thu, 03 Apr 1997 14:32:24 -0800

Hi -

Several people at Berkeley have done this using the rtpgw (a.k.a. vgw) process 
developed by Elan Amir (see http://www.cs.berkeley.edu/~elan/vgw/README.html). 
 Works well.
	Larry

---

From: Mobasshar Ahmed <[email-masked]>
Date: Thu, 3 Apr 1997 22:48:12 +0000 (GMT)

> in trying to make this work.

I have ISDN to my home with MBONE across it. I needed to replace the 3COm
Acces builder for a Cisco 2503 and that worked.

----------------------<i-Exchange   The Internet Peering Point>--------------
i-Exchange	http://www.i-exchange.co.uk
MBONE		http://www.i-exchange.co.uk/mbone
Tel:		++44-181-256-9990	Fax:	++44-181-288-0222

---

From: Amancio Hasty <[email-masked]>
Date: Fri, 04 Apr 1997 18:47:52 -0800

Not sure what you are asking...

Here is my setup:
Ascend Pipeline 50 --- 2bri channels connected to my PCs via ethernet.
PPro 200Mhz - OS FreeBSD

I run mrouted in my FreeBSD box with a maximum bandwith set to 100kilobits/sec.

	Hope this helps,
	Amancio