Subject: Re: Multicast for switches ?

From: Peter Eriksson <[email-masked]>
Date: Tue, 13 Aug 1996 10:35:52 +0200

Bill Fenner <[email-masked]> writes:

> In message <[email-masked]> you write:
> >1. Spoof for IGMP Query messages. Broadcast them on all segments and
> >   call segments from which IGMP Query messages are received "uplink".
> >   Call the other segments "downlink" or "leaf". Do some senseful timeout
> >   on the uplink/downlink state of a segment (5 minutes).
> 
> All multicast routers on a subnet must be able to hear IGMP Report
> messages, and all multicast traffic must be passed between all
> multicast routers.  So you really need manual configuration to tell
> the switches what segments routers are on; they can't guess.

It seems like the LanPlex 2500's _can_ guess. I don't know how they
do it though... I've setup my LP2500's to do IGMP snooping&querying:

	Select menu option (ip/multicast): igmp
	Enter IGMP snooping mode (disabled,enabled) [enabled]: 
	Enter IGMP query mode (disabled,enabled) [enabled]: 

And it correctly discovers nodes wanting multicast traffic and 
the multicast routers on the network. From one of my "internal" switches
that only does IGMP snooping/querying:

	Select menu option (ip/multicast/interface): display
                                                                                
	DVMRP is disabled, IGMP snooping is enabled
	                                    
	Index Local Address     Metric Threshold RateLimit  State
	                      
	  1   130.236.160.145   1      1         0          one-way                     
	                        pkts in: 0  pkts out: 0
	                        port  1  peers: 130.236.160.1 (3.6) (0x8e)
	                                        130.236.160.159 (3.6) (0x8e)
	                        port  1 groups: 224.0.2.2      
	                                        224.0.1.24     
	                        port 10 groups: 224.2.127.254  
	                                        224.1.127.255  
	                                        224.2.127.253      
	                        port 14 groups: 224.0.1.2      
	                                        224.0.2.2                               

Port 1 is FDDI, and it correctly discovers the peers 130.236.160.1
(the main router to the outside world) and 130.236.160.159 (another
router I mainly use for testing purposes...).                                                                           
Port 10 and 14 are ethernet ports which have machines wanting multicast
traffic. (My workstation running "sdr" is located on port 10 I think).

And the Lanplex is a acting as a pure FDDI/ethernet switch here. No 
routing going on (I have another Lanplex which is a combined router/switch).

- Peter

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 13 Aug 1996 13:20:13 +0200 (MET DST)

> that only does IGMP snooping/querying:

It's good to knwo that the LanPlex can do this. I just wonder how fast
it will be. Given that the accumulated bandwith the LanPlex 2500 can
handle is about 300 Mbps, there shouldn't be much of a problem though,
even if all the multicast traffic is passed through a CPU without
much hardware help.

Toerless