Subject: Re: Cisco Memory

From: Matt Crawford <[email-masked]>
Date: Thu, 17 Oct 1996 09:29:03 -0500

> We recently turned on a tunnel from MCI for multicasting to the
> Mbone.  Unfortunately, our cisco routers, both with 16 MB of RAM,
> didn't particularly care for all the multicast routes.  They ran
> out of memory.

That's interesting.  I've been running both DVMRP and PIM (as well as
IGRP, OSPF, DECNET phase IV and Appletalk) routing in 16MB for a very
long time and never had an out-of-memory problem.  Are you also doing
something else memory-intensive, such as ip accounting?

Maybe this should move to a cisco-specific mailing list.
_________________________________________________________
Matt Crawford          [email-masked]          Fermilab
  PGP: D5 27 83 7A 25 25 7D FB  09 3C BA 33 71 C4 DA 6A

---

From: Fred Roeling <[email-masked]>
Date: Thu, 17 Oct 1996 16:55:13 +0200

> Maybe this should move to a cisco-specific mailing list.
What version are you running, and which Cisco

We are running 11.1(5) enterprise on a 16 Mb Cisco 7000 (RP1 processor)
and 1 AIP controller. now and then, it seemes that memory is running
out. It is better then the version 11.1(4).

We use Dvmrp, rip and ospf on this router.

Any suggestions?

What is the profit by using a central router (Cisco 7000) instead of a
Unix workstation. in Multicast routing

Fred.
-----------------------------
Fred Roeling
Computing Centre
Delft University of Technology
The Netherlands

---

From: dave pratt <[email-masked]>
Date: Fri, 18 Oct 1996 09:29:15 +0100 (BST)

On Thu, 17 Oct 1996, Fred Roeling wrote:

->Date: Thu, 17 Oct 1996 16:55:13 +0200
->From: Fred Roeling <[email-masked]>
->To: Matt Crawford <[email-masked]>
->Cc: Ken Vescovi <[email-masked]>, [email-masked]
->Subject: Re: Cisco Memory
->
->Matt Crawford wrote:
->> 
->We are running 11.1(5) enterprise on a 16 Mb Cisco 7000 (RP1 processor)
->and 1 AIP controller. now and then, it seemes that memory is running
->out. It is better then the version 11.1(4).
->

If you've got sdr turned on then there is a memory leak in 11.1(5). Every few
days the router will run out of memory.

Remove all "ip sdr listen", reboot and the problem goes away.

"sh proc mem" tracks the memory usage.

This has been fixed in later versions (11.1-6.3) but I've seen reports of
other bugs (in LANE) and so we're still using 11.1(5) without SDR.

Cheers
--------
The views expressed here may or may not be anybodies.
WWW - doesn't that stand for "Wait a Week Word" ?
BEER - so much more than just a breakfast drink.
Dave Pratt      (tel: +44 1473 643840 )
[email-masked]

---

From: Petri Helenius <[email-masked]>
Date: Fri, 18 Oct 1996 19:42:59 +0300 (EET DST)

> other bugs (in LANE) and so we're still using 11.1(5) without SDR.
It's still there on 11.1(6.3):
(and yes, this has been taken care of, or at least I'm being told so)
swallow# sh proc mem
Total: 60994880, Used: 24429888, Free: 36564992
 PID  TTY  Allocated      Freed    Holding    Getbufs    Retbufs Process
  31    0   29320280   25211460    4158476          0    1858440 SDP Process

IOS (tm) 4500 Software (C4500-I-M), Version 11.1(6.3), MAINTENANCE INTERIM SOFTWARE
Copyright (c) 1986-1996 by cisco Systems, Inc.
Compiled Mon 07-Oct-96 22:09 by tej
Image text-base: 0x600088A0, data-base: 0x60436000

Pete