Subject: DVMRP tunnel between 2 ciscos

From: Kostas Strakadounas <[email-masked]>
Date: Fri, 28 Nov 1997 12:41:15 +0200

Hello,

Our cisco backbone is running PIM-DM.
I tried to test a DVMRP tunnel between routerA which is connected
to the PIM cloud and routerB which is not, with no success.
RouterB doesn't get any routes throught the tunnel.

The configuration of the 2 routers is the following:

routerA
---------
ip multicast-routing
ip dvmrp route-limit 7000

interface Tunnel1
 ip unnumbered Loopback0
 ip pim dense-mode
 tunnel source Loopback0
 tunnel destination 194.219.239.145    ! routerB loopback interface
 tunnel mode dvmrp

routerB
---------
ip multicast-routing
ip dvmrp route-limit 7000

 interface Tunnel0
 ip unnumbered Loopback0
 ip pim dense-mode
 tunnel source Loopback0
 tunnel destination 194.219.235.70   ! routerA loopback interface
 tunnel mode dvmrp

Do you have any suggestion that would make the above configuration work?
Is the problem in the tunnel itself or in the PIM - DVMRP interaction?

Thanks in advance

Strakadounas Costas
FORTHnet S.A.

---

From: John Meylor <[email-masked]>
Date: Fri, 28 Nov 1997 06:07:21 -0800

Kostas,
 If you are trying to tunnel multicast between two ciscos
you should remove the command "tunnel mode dvmrp", since
cisco<->cisco tunnels use the default GRE encapsulation mode.
 Also, from what you have provided, both routerA and routerB
are connected to the PIM cloud since they are both running
pim dense-mode.  If you are also connected somewhere to a
dvmrp cloud you will need to utilize several commands
to pass routes between your pim environment and dvmrp.
I can't tell where you interface with dvmrp, but you
may need to use "ip dvmrp unicast routing" on some
of your interfaces in order to carry dvmrp routes into
your pim cloud, and "ip dvmrp metric" to inject select
pim cloud routes back into the dvmrp routing table.

For more information on how to do this, please see:

ftp://ftpeng.cisco.com/ipmulticast/html/ipmulticast.html
ftp://ftpeng.cisco.com/ipmulticast/Quickstart-dvmrp

or check out the "Beginner's Guide to connecting to the MBone" 
Networkers97 presentation at:

"ftp://ftp-eng.cisco.com/ipmulticast/networkers97/index.html". 

- John Meylor