Subject: Re: What is IGMPv2

From: Cyndi Jung <[email-masked]>
Date: Mon, 28 Jul 1997 14:27:56 -0700

OK - I'll bite.  What is CGMP?

Cyndi

At 03:22 PM 7/28/97 +0200, Toerless Eckert wrote:
>> 	It is compatible with IGMPv1. On a cisco router the versions
>> 	are detected dynamically and if a IGMPv1 system is present, we 
>> 	switch automaticaly to verison 1 in the queries.
>
>As of today, the biggest improvement in performance by using igmp-v2 instead
>of igmp-v1 can be gained in local area networks with switches that do
>run CGMP. (My 2cent).
>
>Toerless
>
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 29 Jul 1997 00:23:45 +0200 (MET DST)

> OK - I'll bite.  What is CGMP?

Something in the way of "cisco's gory messy protocol" ;-))
(i think the official term is "cisco group management protocol").

In short it's IGMP snooping done by the router who then instructs the switches
to prune multicast groups appropriately. Avoids the switches to promisciously
listen on all active multicast groups, which would otherwise easily overload
low-end switches CPU's. I'm not sure how secretive cisco still is
about the actual protocol operation, but this general principle of operation
is outlined on their web.

I think CGMP is a very good short term solution for the multicast problem
in switched LANs. 802.1p may be nicer when it's there, but that will 
take at least 2 years, if you ask me.  Especially in all the end system
operating systems (if you happen to consider workstation OSs).

Toerless

---

From: Doug Dillon <[email-masked]>
Date: Tue, 29 Jul 97 08:32:53 EDT

What's CGMP? Do you have an RFC number handy?

	Doug Dillon..............