Subject: mrouted3.9-beta3 & SGI

From: Don McGregor <[email-masked]>
Date: Wed, 18 Mar 1998 14:04:00 -0800 (PST)

I'm attempting to get mrouted 3.9-beta3 running on SGI, without
much success. When I attempt to fire up mrouted, I get this
error:

mrouted: 13:45:43.684 can't enable Multicast routing in kernel: Operation not su
pported on transport endpoint      

The ec0 interface appears to be configured for multicast:

ec0  1500  131.120.7   131.120.7.35       27207     0    15989     0    70
                        224.0.0.1
                        08:00:69:07:3d:c4         

And I've got a tunnel entry in the /etc/mrouted.conf file:

#      Our end      dren end     one hop  limits packets  limits bandwidth
tunnel 131.120.7.35 138.18.5.224 metric 1 threshold 32 rate_limit 4000  

The SGI is running IRIX 6.2, with the networking rollup patch #4 installed.

The code seems to be failing in a setsockopt kern.c:

void k_init_dvmrp()
{
#ifdef OLD_KERNEL
    if (setsockopt(igmp_socket, IPPROTO_IP, MRT_INIT,
                   (char *)NULL, 0) < 0)
#else
    int v=1;

    if (setsockopt(igmp_socket, IPPROTO_IP, MRT_INIT,
                   (char *)&v, sizeof(int)) < 0)
#endif
        log(LOG_ERR, errno, "can't enable Multicast routing in kernel");
}                                

Anyone have insight?

---

From: Bill Fenner <[email-masked]>
Date: Wed, 18 Mar 1998 15:58:46 PST

That sounds like you haven't installed eoe.sw.ipgate and build a new kernel
with "autoconfig".  Did you have previous versions of mrouted running on
this machine, or is this a new installation?

  Bill

---

From: Don McGregor <[email-masked]>
Date: Wed, 18 Mar 1998 21:12:53 -0800 (PST)

> this machine, or is this a new installation?

Nope, first time. I'll give that a go.