Subject: no mrouted on multi-homed SGI O2

From: "Craig M. Votava" <[email-masked]>
Date: Thu, 08 Oct 1998 16:26:12 -0500

Folks-

I continue to be frustrated at trying to get
any version of mrouted to run correctly on a
multi-homed SGI O2.

Has anyone successfully done this at any time?

Please respond to my email address, as I'll be
on vacation until the end of October, and won't
be getting any MBONE mailing list email.

Attached are the current details. Please take
a look at them and help if you can.

Thanks

-Craig Votava
Lucent Technologies

SETUP:
======
NETWORK A    |    NETWORK B

A1 -------- AB -------- B1

A1 - A client on the A network, sourcing multicast audio and video
AB - The multi-homed SGI O2, running mrouted 3.9b3
B1 - A client on the B network trying to receive the source from A1

-All routers on both networks have mutlicasting turned off.
-AB has all of the lines in /etc/mrouted.conf commented out.
-AB is setup for the primary interface on network A

SYMPTOMS:
=========

-When A1 announces an sdr session with audio and video,
	the session shows up in the sdr windows on A1,
	AB, and B1.

-When B1 joins the session, it gets no multicast packets.

-When AB joins the session, AB receives video and audio,
	and suddenly B1 starts getting audio and video too.

-When AB quits out of the video and/or audio tool B1 stops
	getting the video and/or audio at the same time.

-When using mtrace to try and trace between A1 and B1, in
	either direction, sometimes mtrace has to go to
	point-to-point mode, other times it doesn't. This
	seems to vary over time.

-In the "netstat -M" output, the multicast forwarding cache
	has an entry for B1 on the audio and video multicast
	group addresses. When B1 doesn't receive media, the
	count numbers don't increase, when B1 does get media
	the count numbers do increase.

-Running "netsnoop" on the A interface of AB shows continuous
	multicast media packets at all times when A1 is
	transmitting. This was verified by an independent PC
	snooping on that same segment as well.

-Running "netsnoop" on the B interface of AB when B1 is not getting
	media shows only the person ID packets (or whatever they're
	called) on the media sessions. When I have B1 send continuous
	audio packets, netsnoop on AB picks them up fine.

---

From: Angel Mateo <[email-masked]>
Date: Fri, 09 Oct 1998 09:12:52 +0200

I think your problem is not you have a multi-homed SGI O2. I have one in just 
one network and I have the same problem.

	My machine has some tunnels with other networks and that works right, but in 
my network, the other computers can only receive the sessions that receive the 
O2 (the mrouter). If the O2 joins to a session, then the other computers can 
receive media from this session, but otherway they can´t.

	(Please, if you fix the problem, advice me what can I do to fix it)

>         audio packets, netsnoop on AB picks them up fine.

-----------------------------------------
Angel L. Mateo Martinez
RedIRIS/CSIC
C/ Serrano, 142
28006  Madrid (Spain)
Tlfo: +34-91-5855145
Fax:  +34-91-5855146

---

From: "Thomas M. Kendall <tkendall>" <[email-masked]>
Date: Fri, 9 Oct 1998 09:37:45 -0400 (EDT)

FYI-

I filed a bug report with SGI on this issue in March.  I worked with 
them for 3 months before they admitted that there is a problem in the O2
kernel multicasting code. They have now stated that their Engineering
Department has no interest in fixing it.

The SGI case number is 0917087.

-------------------------------------------------------------------------------
Thomas M. Kendall		U. S. Army Research Laboratory
410-278-9195			Corporate Information and Computing Center
410-278-9199 (FAX)		Attn: AMSRL-CI-HC
[email-masked]		Aberdeen Proving Ground, MD  21005-5067
-------------------------------------------------------------------------------

---

From: Ignatios Souvatzis <[email-masked]>
Date: Fri, 9 Oct 1998 16:34:43 +0200

> The SGI case number is 0917087.

Ah, that explains much....

A colleague in the neighbour department complained that he couldn't start 
MBONE tools on his machine because it would instantly panic.

	-is