Subject: PIM-DM

From: Sushma Anantharam <[email-masked]>
Date: Thu, 05 Sep 1996 14:27:42 -0700

I am starting work on the PIM-DM and I had a couple of questions that I
need clarification on. 

I have the following questions:
 
 1. Do only leaf routers initiate prune messages.
 2. Is a join message sent in response to a prune
 or is join/prune messages sent periodically.

 Thank You
 Sushma Anantharam

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 6 Sep 1996 08:55:58 -0700

>>  1. Do only leaf routers initiate prune messages.

    Yes, intermediate routers may also if packets come down non-RPF 
    point-to-point interfaces.

>>  2. Is a join message sent in response to a prune

    Yes, on a multicast capable media where one router prunes and another
    wants to override it because it has downstream members.

    Join/Prune messages are send periodically only for sparse-mode groups.

Dino