Subject: Problem with ROJ-alpha1 packet

From: Markus Kaas <[email-masked]>
Date: Tue, 25 Jun 1996 12:38:10 +0200 (MET DST)

I'm having some problems with the ROJ-alpha1 packet for java.
We want to develop a client-server application using CORBA, but it seems 
to be impossible to run client and server application on different machines.

I'm using the following scenario.

I start my local web-browser on a PC or a unix machine and load an URL 
that starts my client applet on www-server X. The client applet invokes a 
CORBA-function that is handled by the server application.

This works fine, as long as the client and the server applications are on 
the same machine. It also works fine, when I start the client applet on 
my local machine and the server is on an other machine.
But when the client aplication is not on my local machine and the server 
is on a different machine than the client, the client won't connect to the 
server.

Does anybody have a clue why it won't work? 
I read something that java can't "create a network connection to any 
other computer than the one from which the applet was itself loaded" 
(Java in a nutshell, p.198)

But why is there a  remote object packet from SUN when I can't access remote 
objects on remote servers?

Thanks a lot for any ideas...

------------------------------------------------------------------------------

Markus Kaas                 	  E-mail: [email-masked]
University of Mannheim           
Praktische Informatik IV        
68131 Mannheim, Germany

---

From: Peter Parnes <[email-masked]>
Date: Tue, 25 Jun 1996 13:02:11 +0200

[email-masked] said:
> Does anybody have a clue why it won't work?  I read something that 
> java can't "create a network connection to any  other computer than 
> the one from which the applet was itself loaded"  (Java in a 
> nutshell, p.198)

This all depends on the security-manager in the specific Java-implementation. Netscape has chosen to supply a very "hard" s-manager that only allows applets to connect to there original site. HotJava has a more "soft" s-manager where the user can choose how the security should be enforced.

> But why is there a  remote object packet from SUN when I can't access 
> remote  objects on remote servers?

Java _can_ be used to other things than applets!!! (Heard of real Java-applications? ;-)

/P