Subject: Miro/Pinnacle DC30+ + Windows 95 + vic

From: keryell <[email-masked]>
Date: Wed, 24 Jun 1998 15:20:23 +0200

We've just receive our DC30+ v1.23a card but it does not work with vic2.7b2,
vic2.7b3 or vic2.8s4 (SHRIMP).
It does broadcast a black image...
The capture is correct with the Miro tool.

It works well (except for the quality... :-) ) if we install a color
QuickCam on the same machine and the same software.

AltaVista with "+dc30+ +vic" gives some information close to our
problem and I've added the message at the end of this mail.

May be the correct video entry is not selected, or the luminosity is
off, or...

Does anybody have a quick and dirty patch, kludge or hack for that ?
I need to broadcast a PhD defense on next tuesday... :-(

I am quite illetterate on Windows 95... :-(

    Ronan KERYELL
    Centre de Recherche en Informatique
    de l'École Nationale Supérieure des Mines de Paris (CRI-ENSMP)
    35, Rue Saint-Honoré
    77305 FONTAINEBLEAU CEDEX
    FRANCE                               Tel:    (+33|0) 1.64.69.48.44
                                         Fax:    (+33|0) 1.64.69.47.09
                                         E-mail: [email-masked]
                                         http://www.cri.ensmp.fr/~keryell

http://sauce.mmlab.uninett.no/maill/mbone/mbone-1997/Mbone-December/0109.html

Re: vic with Miro DC30+ ?

Jong Kuk Lee ([email-masked])
Tue, 30 Dec 97 16:01:20 -0500 

      Messages sorted by: [ date ][ thread ][ subject ][ author ] 
      Previous message: Bill Fenner: "Top 50 unstable DVMRP routes" 

Hello. Isidor Kouvelas..
this is Raphael Lee(Jong Kuk Lee).

> From: Isidor Kouvelas \ Internet: ([email-masked])
> To: Jong Kuk Lee \ Internet: ([email-masked].
kr)
> Subject: Re: vic with Miro DC30+ ?
> > Where is vic 5.0?
> vic5 is part of mash:
> http://www-mash.cs.berkeley.edu/mash/
> > Miro20+ works on vic. but Miro 30+ doesn't works on vic.
> I do not think vic5 will solve your problem as it probably has my code
> unmodified for windows grabbing.

- No.. this problem is not solved.... 
Port of Vic's sub-menu (for frame grabber) has only External-In.
It has to get 'S-Video, Composite'.

So.. This problem is not solved...

Thank you.

---

From: Peter Tebault <[email-masked]>
Date: Wed, 24 Jun 1998 08:53:06 -0700

The Miro DC-30/+ does not work with anything that doesn't understand how to hook
into it's M-JPEG datastream.  That is why you get a black screen.  Look at:

http://www.miro.com/support/generalfaq/videocon.html

That explains about which of their cards does and does not support the proper
video formats (size, color space, compression/no compression).

-Pete-

---

From: keryell <[email-masked]>
Date: Thu, 25 Jun 1998 15:24:02 +0200

>>>>> On Wed, 24 Jun 1998 08:53:06 -0700, Peter Tebault <[email-masked]> said:

    Saskia> The Miro DC-30/+ does not work with anything that doesn't
    Saskia> understand how to hook into it's M-JPEG datastream.  That
    Saskia> is why you get a black screen.  Look at:

    Saskia> http://www.miro.com/support/generalfaq/videocon.html

    Saskia> That explains about which of their cards does and does not
    Saskia> support the proper video formats (size, color space,
    Saskia> compression/no compression).

But in fact, according to the vic documentation, vic *is* Motion JPEG
capable. The "jpeg" button (allowing the Motion JPEG format) on the
Sun Solaris2 vic2.8 is selectable but not on Windows95 vic 2.7 or
2.8...

I've downloaded the MASH vic v5.0a10 and the "jpeg" button is
selectable but I get an error window when clicking on it with a
content begining with:

todo: move to base class .vw1,.vw1
class Module/VideoEncoder/Pixel/JPEG: constructor failed (invalid command name "Module/VideoEncoder/Pixel/JPEG"): invalid command name "Module/VideoEncoder/Pixel/JPEG"
[...]

If there was something to disable MJPEG compression in the DC30+
driver... Since the card is able to do incrustation through the PCI
bus, a device driver with this kind of plain output should be writed...

-- 
    Ronan KERYELL