Subject: No DVMRP routes [ARS1412/SSC1388]

From: Willem van der Scheun <[email-masked]>
Date: Fri, 04 Jul 1997 15:07:25 DST

Hi,

I am setting up a tunnel from broodjeham.surfnet.nl (SPARC20 running 
Solaris 2.4 / Mrouted 3.255) to a cisco 7000 router 
(MR1.Eindhoven.surf.net). I copied a working configuration for a tunnel 
from broodjeham to a Cisco 7507 (Amsterdam6.router.surfnet.nl), but alas, 
the tunnel does not function. Both cisco's run 11.1(9). We are lost! Any 
clues?

Here are the configurations:

broodjeham:

# Amsterdam6
tunnel 192.87.106.102 145.41.1.6 metric 1 threshold 32 boundary mcastrp 
rate_limit 0
# MR1.Eindhoven
tunnel 192.87.106.102 145.41.4.114 metric 1 threshold 32 boundary mcastrp 
rate_limit 0

MR1.Eindhoven:

ip multicast-routing
ip dvmrp route-limit 7000

interface Tunnel0
 description MBone tunnel naar broodjeham.surfnet.nl
 ip unnumbered ATM4/0.1
 ip pim dense-mode
 ip multicast ttl-threshold 32
 no ip mroute-cache
 no ip route-cache
 load-interval 30
 tunnel source ATM4/0.1
 tunnel destination 192.87.106.102
 tunnel mode dvmrp

interface ATM4/0
 description SURFnet IP/ATM (conn. panel ST-3B))
 no ip address
 no ip redirects
 ip route-cache cbus
 atm rxbuff 512
 atm txbuff 512
 atm sonet stm-1
!
interface ATM4/0.1 point-to-point
 description Eindhoven2 (5 Mbit/s, EHV/ATM)
 ip address 145.41.4.114 255.255.255.252
 bandwidth 5000
 atm pvc 1 0 129 aal5snap 5000 5000 1

ip mroute 0.0.0.0 0.0.0.0 Tunnel0 1

Amsterdam6:

ip multicast-routing
ip dvmrp route-limit 7000

interface Tunnel0
 description MBone tunnel naar broodjeham.surfnet.nl
 ip unnumbered FastEthernet2/0
 ip pim dense-mode
 ip multicast ttl-threshold 32
 no ip mroute-cache
 no ip route-cache
 load-interval 30
 transmit-buffers backing-store
 tunnel source FastEthernet2/0
 tunnel destination 192.87.106.102
 tunnel mode dvmrp

interface FastEthernet2/0
 description SW1.AMSTERDAM.SURF.NET (3/6)
 ip address 145.41.1.6 255.255.255.192
 no ip route-cache optimum
 ip route-cache flow
 full-duplex

ip mroute 0.0.0.0 0.0.0.0 Tunnel0 1

On broodjeham I see:

# mrinfo

  192.87.106.102 -> 145.41.1.6 (Amsterdam6.router.surfnet.nl) 
[1/32/tunnel/leaf]
  192.87.106.102 -> 145.41.4.114 (MR1.Eindhoven.surf.net) 
[1/32/tunnel/down/leaf

on MR1.eindhoven:

MR1.Eindhoven#sh int tunnel 0
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel
  Description: MBone tunnel naar broodjeham.surfnet.nl
  Interface is unnumbered.  Using address of ATM4/0.1 (145.41.4.114)
  MTU 1500 bytes, BW 9 Kbit, DLY 500000 usec, rely 255/255, load 1/255
  Encapsulation TUNNEL, loopback not set, keepalive set (10 sec)
  Tunnel source 145.41.4.114 (ATM4/0.1), destination 192.87.106.102
  Tunnel protocol/transport IP/IP (DVMRP), key disabled, sequencing 
disabled
  Checksumming of packets disabled
  Last input 00:00:11, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/0, 0 drops; input queue 0/75, 0 drops
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
     170 packets input, 9748 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     174 packets output, 11136 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out

MR1.Eindhoven#sh ip igmp int tunnel 0 
Tunnel0 is up, line protocol is up
  Interface is unnumbered.  Using address of ATM4/0.1 (145.41.4.114)
  IGMP is enabled on interface
  CGMP is disabled on interface
  Current IGMP version is 2
  IGMP query interval is 60 seconds
  IGMP querier timeout is 120 seconds
  IGMP max query response time is 10 seconds
  Inbound IGMP access group is not set
  Multicast routing is enabled on interface
  Multicast TTL threshold is 32
  DVMRP/mrouted neighbors present for 00:29:11
     [version mrouted 3.255] [flags: GPM]
  0 DVMRP routes received in last 00:01:01
  0/0 Unicast/DVMRP routes last advertised by DVMRP
  Multicast groups joined: 224.0.1.40

MR1.Eindhoven#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode

(*, 224.0.1.40), 00:30:51/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel0, Forward/Dvmrp, 00:29:26/00:00:00

--
Willem van der Scheun
SARA / NCC                            [email-masked]
Stichting Academisch Rekencentrum Amsterdam / Network Control Centre
Kruislaan 415; 1098 SJ Amsterdam     Telefoon +31 (0)20 592 8000
Postbus 94613; 1090 GP Amsterdam     Telefax  +31 (0)20 668 3167

---

From: Bill Fenner <[email-masked]>
Date: Sat, 5 Jul 1997 00:05:31 PDT

Looks like the Cisco can hear broodjeham but broodjeham can't hear the
Cisco (see "down" in broodjeham mrinfo output).  Can mr1.eindhoven ping
broodjeham?  Can you mrinfo broodjeham from mr1.eindhoven?

  Bill

---

From: Niels den Otter <[email-masked]>
Date: Mon, 07 Jul 1997 11:34:33 +0200

Bill,

> broodjeham?  Can you mrinfo broodjeham from mr1.eindhoven?

Yes to both questions:
  MR1.Eindhoven>ping broodjeham.surfnet.nl
 
  Type escape sequence to abort.
  Sending 5, 100-byte ICMP Echoes to 193.148.15.2, timeout is 2 seconds:
  !!!!!
  Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/44 ms

  MR1.Eindhoven>mrinfo broodjeham.surfnet.nl
  193.148.15.2 (broodjeham.surfnet.nl) [version mrouted 3.255] [flags: GPM]:
    193.148.15.2 -> 0.0.0.0 [1/1/disabled]
    192.87.106.102 -> 0.0.0.0 [1/1/disabled]
    192.87.106.102 -> 192.36.148.206 (stockholm.mbone.ebone.net)
      [1/48/tunnel/leaf]
    192.87.106.102 -> 193.174.226.254 (mr-stu1.win-ip.dfn.de)
      [6/48/tunnel/leaf]
    193.148.15.2 -> 192.65.185.20 (mbone.cern.ch) [1/48/tunnel/leaf]
    193.148.15.2 -> 193.148.15.68 (Amsterdam1.ripe.net) [1/32/tunnel/leaf]
    193.148.15.2 -> 193.190.196.253 (mbone.belnet.be) [1/48/tunnel/down/leaf]
    192.87.106.102 -> 193.144.0.39 (mbone.rediris.es) [1/48/tunnel/leaf]
    192.87.106.102 -> 145.41.1.6 (Amsterdam6.router.surfnet.nl)
      [1/32/tunnel/leaf]
    192.87.106.102 -> 145.41.4.114 (MR1.Eindhoven.surf.net)
      [1/32/tunnel/down/leaf]
    192.87.106.102 -> 192.87.30.6 (vivaldi.terena.nl) [1/32/tunnel/leaf]
    [etc.]

The following is debug output on mr1.eindhoven:
  DVMRP: Received Probe on Tunnel0 from 192.87.106.102
  DVMRP: Received Probe on Tunnel0 from 192.87.106.102
  DVMRP: Building Report for Tunnel0 224.0.0.4
  DVMRP: 0 unicast, 0 DVMRP routes advertised

It seems that it does not send a neighbor probe back to broodjeham. I
verified this by turning on the "peers,neighbors,interface,vif" debug flags
on broodjeham. It does send a neighbor probe to mr1.eindhoven:
10:42:47.123 SENT neighbor probe     from 192.87.106.102  to 145.41.4.114

But it never receives one back.

It seems that mr1.eindhoven has a kind of bootstrap problem. If a tunnel to
another Cisco with MBone connectivity (amsterdam6.router.surfnet.nl) is
added and ip dvmrp unicast-routing is enabled on this tunnel, mr1.eindhoven
does get all DVMRP routes from amsterdam6.router AND from broodjeham. If
this new tunnel is removed then, mr1.eindhoven keeps receiving DVMRP routes
from broodjeham and broodjeham finds that the tunnel is up.

--
Niels