Subject: Any Ideas?

From: "Jung, Michael" <[email-masked]>
Date: Fri, 6 Sep 1996 12:35:42 -0400

Following is a mtrace.  It is querying hosts along its unicast route. 
I would expect the trace to follow:
	
	206.246.160.131 	The Host itself
	206.246.160.129	Local end of tunnel (c7000 11.0.(10))
				(same ethernet as host)
	198.6.9.1		End of Tunnel (c7000 11.0.(10))
	137.39.43.34		mbone1.uu.net
	.......

Instead it is querying the router (ascend 400 4.6bi18) which is the
first hop from 
our tunnel endpoint. Here is the rpf output from 206.246.160.129

bacchus.finall.com#show ip rpf 129.89.9.63 
RPF information for homestead.cs.uwm.edu (129.89.9.63)
  RPF interface: Ethernet1/0
  RPF neighbor: pipeline400.finall.com (206.246.160.130)
  RPF route/mask: 129.89.0.0/255.255.0.0
  RPF type: unicast
bacchus.finall.com#
 
Internet
     |
198.6.9.1 (c7000 11.0(10)) - 
     |
Ethernet
     |
198.6.9.40 (ascend max 4.6bi3)
     |                      |
ISDN (384k)  GRE Tunnel - PIM Dense Mode
     |                      |
206.246.160.130 (ascend p400 4.6bi18)
     |
ethernet
 |      | 
 |    206.246.160.129 (c7000 11.0(10))
 |    
206.246.160.131 (FreeBSD - no mrouted running)

/tmp # mtrace  -t 127 129.89.9.63 224.2.100.102
Mtrace from 129.89.9.63 to 206.246.160.131 via group 224.2.100.102
Querying full reverse path... * switching to hop-by-hop:
  0  charon.finall.com (206.246.160.131)
 -1  e1/0.c7000.finall.com (206.246.160.129)  PIM  thresh^ 0  
[129.89/16]
 -2  * * * * * pipeline400.finall.com (206.246.160.130) didn't respond
 -3  * * * 
 -4  * * * 
 -5  * * * ...giving up
Round trip time 4 ms

Results after 42 seconds:

  Source        Response Dest    Packet Statistics For     Only For
Traffic
   * * *        206.246.160.131  All Multicast Traffic     From
129.89.9.63
     v       __/  rtt    4 ms    Lost/Sent = Pct  Rate       To
224.2.100.102
206.246.160.129 e1/0.c7000.finall.com 
     v      \__   ttl    0          0            0 pps       0          
 0 pps
206.246.160.131 206.246.160.131
  Receiver      Query Source

/tmp # 

Here is a trace from 206.246.160.129

bacchus.finall.com#mtrace 129.89.9.63 224.2.100.102
Type escape sequence to abort.
Mtrace from 129.89.9.63 to 206.246.160.129 via group 224.2.100.102
From source (homestead.cs.uwm.edu) to destination
(e1/0.c7000.finall.com)
Querying full reverse path... * switching to hop-by-hop:
 0  e1/0.c7000.finall.com (206.246.160.129)
-1  e1/0.c7000.finall.com (206.246.160.129) PIM  thresh^ 0  3 ms  
-2  * * * pipeline400.finall.com (206.246.160.130)
bacchus.finall.com#

As always - thanks in advance..

--mikej

Michael Jung
Financial Alliance Processing Services, Inc.
Sr. Systems/Network Administrator
[email-masked]

---

From: "John M. Zwiebel" <[email-masked]>
Date: Fri, 06 Sep 1996 10:09:05 -0700

The "sh ip rpf" shows that the route on your 7000 to the source you are trying 
to trace to is out the ethernet interface.  You have to get your
unicast and/or DVMRP routing to be congruent and point out the tunnel for
those multicast routes.

One way is to get the mrouter on the other end of your DVMRP tunnel to send
you default.  Another way is to use static mroutes.

ip mroute 0.0.0.0 0.0.0.0 tunnel0.
ip mroute <***> ethernet0

Where <***> is the internal routes inside your network.  _OR_ you could
use:
	ip mroute <***> null0 255

so that any routes that match your internal network will see the static 
mroute with a 255 administrative distance and instead use the lower 
administrative distance of your unicast route.

See ftp://ftpeng.cisco.com/ftp/ipmulticast/Mroutes

z