Subject: setting up a Cisco - I want to avoid the traps!

From: Carl Brewer <[email-masked]>
Date: Wed, 7 Feb 1996 08:53:47 +0800 (WST)

G'day,

I'm about to take delivery of a nice new Cisco 4500, running 11.0(4),
as part of a network upgrade, and we'll be going from a tunnel to
my machine running mrouted to using the Cisco as a multicast router.

Given all the problems that have shown up that I've seen on this list
concerning mis-configured routers causing all sorts of nasty problems,
can anyone give me a quick run-down on what not to do?  I've done a
couple of Cisco courses, but they didn't address setting things up for
the mbone, and the instructor didn't know much about it, and I don't
want to break anything that might affect the rest of the mbone.

Thanks for any tips

Carl

[email-masked]
#include <generic_disclaimer.h>

finger [email-masked] for my pgp public key

---

From: "David M. Meyer 503/346-1747" <[email-masked]>
Date: Wed, 7 Feb 1996 06:47:33 -0800 (PST)

Carl,

	The main configuration-oriented way things have gone badly 
	in the past is with the command

		ip dvmrp metric <metric> <list>

	The way this works is 

	(i).	If you don't specify an "ip dvmrp metric", then
		the router advertises only directly connected networks
		to the DVMRP cloud. This would be ok if you had only
		one router connecting all of your multicast enabled
		networks.

	(ii).	If you say something like

		ip dvmrp metric 1

		Then the router will inject all of your unicast
		routes (yes, *all*) into the DVMRP cloud.

		This is what goes badly wrong (at least when
		we've seen the number of DVMRP routes in the 
		global routing system grow wildly).

		The lesson is: don't configure this.

	(iii).	If you say 

		ip dvmrp metric <metric> <access-list>

		Then the router will advertise the networks
		described by <access-list> to the DVMRP cloud.

	So, the thing to watch out for is (ii). above. This is 
	part of what can go badly...

	Dave

	David M. Meyer                  Voice:    +1 541.346.1747
	Senior Network Engineer         SkyPager: +1 800.580.7929
	Office of University Computing  Cellular: +1 541.954.1103
	Computing Center                FAX:      +1 541.346.4397
	University of Oregon            Internet: [email-masked]
	1225 Kincaid			URL:	  http://ns.uoregon.edu/~meyer
	Eugene, OR 97403