Subject: SDR error

From: Mark Leber <[email-masked]>
Date: Tue, 5 Aug 1997 17:25:37 -0500 (CDT)

Hi,

I have a Sun Ultra 1 that will not run sdr.  It's Solaris 2.5.1 Server 
OS.  I have the exact system and it runs fine.  We've tried 
reinstalling Solaris and received the same error as stated below:

--------------------------------------------
Error: font

"-*-helvetica-medium-r-normal--10-*-iso
8859-1" doesn't exist

--------------------------------------------

Any pointers would be helpful and very much appreciated ;) !!

thanks,
--mark
---------------------------------
Mark D. Leber                    
USAE Waterway Experiment Station 
e-mail: [email-masked]

---

From: Yozo Toda <[email-masked]>
Date: Wed, 06 Aug 1997 17:21:13 +0900

> "-*-helvetica-medium-r-normal--10-*-iso

maybe your X server doesn't have this font.
use "xlsfonts" command to get the list of fonts you can use.

grep'ing the source code of sdr2.3a1,
I find the font name above in src/sdr.tcl.
so, you have to do one of the following:
  o make font alias, or
  o patch sdr source code to use other font available.
    (or define some X resource?)

-- yozo.

---

From: Mark Handley <[email-masked]>
Date: Thu, 07 Aug 1997 04:56:03 -0400

>maybe your X server doesn't have this font.

Your should be able to set the following Xresources to fonts that do exist:

sdr.infoFont:  -*-helvetica-medium-r-normal--10-*-iso8859-1
sdr.headerFont:  -*-helvetica-bold-r-normal--14-*-iso8859-1
sdr.mediumFont:  -*-helvetica-medium-r-normal--12-*-iso8859-1
sdr.font:  -*-helvetica-bold-r-normal--12*-*-iso8859-1
sdr.italfont:  -*-helvetica-bold-o-normal--12*-*-iso8859-1

Mark