Subject: inter-subnet woes

From: <[email-masked]>
Date: Wed, 23 Apr 1997 16:12:44 -0500 (CDT)

Hi all,

I am a newbie to mbone, so bear with me :)

I am trying to deploy mbone at my university. I have 2 subnets 128.252.98
and 128.252.120 that are directly connected to a multicast capable cisco,
and both use it as a gateway. The cisco appears to be properly configured.
I can run sdr on any machine on my subnets and see the conferences going
on. I can also set up conferences on machines withing the same subnet.
However, if I set up a conference on the 120 subnet, the machines in the
98 subnet cannot see it - and vice versa.

Can you give me a lead as to what could be happening?

Thanks very much,
naeem

-------------------------------------------------------------
Naeem Bari			Tel: (314) 935-4865
Software/Network Engineer	Fax: (314) 935-7142
Office of the N/W Coordinator	[email-masked]
Washington U. in St. Louis	http://rusty.wustl.edu/~naeem/
--------------------------------------------------------------

---

From: "John M. Zwiebel" <[email-masked]>
Date: Wed, 23 Apr 1997 14:59:09 -0700

Nareem:

--What is your configuration?
--What does "sho ip mr" say?
--What does "sh ip igmp gr" say?
--Are you using sparse mode or dense mode (or sparse-dense)?

There are _lots_ of possibilities.

Please read the info at ftp://ftp-eng.cisco.com/ipmulticast.html 
for additional information.
    
    Hi all,

    
    
    Thanks very much,
    naeem

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 Fax:   
	Multimedia Group                   Email: [email-masked]

---

From: [email-masked]
Date: Thu, 24 Apr 1997 10:19:50 -0500 (CDT)

John et al,

Thanks for all the replies. It makes me hopeful :). Here is a complete
description of my setup... 

=>--What is your configuration?

 o Machine 'A' is a sparc5/solaris2.5.1 sitting on the 128.252.120 subnet.
   It's IP addr is 128.252.120.70
 o Machine 'B' is a sparc5/solaris2.5.1 sitting on the same subnet.
   It's IP addr is 128.252.120.25
 o Machine 'C' is a sparc5/sol2.5 sitting on the 128.252.98 subnet.
   It's IP addr is 128.252.98.3
 o Router 'D' is a cisco 7000/IOS 11.1 directly connected to both subnets.
   It's interfaces are addressed as 128.252.120.254 and 128.252.98.254

 o All machines have 224.0.0.0 routes set to point to D (128.252.x.254)
 o All machines have sdr, vat, wb, vic and nv.
 o All machines see all conferences using sdr, and can join in anything
   outside 128.252

Here is the situation:

I set up a conference at A using sdr with the following parameters:

Session name: onc aud/wb
Description: test
Type of session: Test
Security: public
Scope: Site (ttl 15)
Media: Audio/PCM, proto=RTP, Addr=224.2.255.127, port=28636
       Whiteboard/wb, proto=udp, Addr=224.2.166.76, port=48192

(of the above, proto, Addr and port were selected by sdr)

Now both A and B can see the conference and participate in it
successfully. But C can't even see it, let alone join.

=>--What does "sho ip mr" say?

A LOT of routes. The first few lines look like:

+++++++++++++++++++++++
ncrc-onc#sho ip mr
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
 
(*, 239.111.111.239), 1d09h/00:02:57, RP 0.0.0.0, flags: DJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel1, Forward/Dvmrp, 1d09h/00:02:42
    Fddi1/0, Forward/Dense, 1d09h/00:02:06
 
(131.107.1.109/32, 239.111.111.239), 1d09h/00:02:54, flags: CT
  Incoming interface: Tunnel1, RPF nbr 204.70.98.45, Dvmrp
  Outgoing interface list:
    Fddi1/0, Forward/Dense, 1d09h/00:00:58
 
(*, 224.2.198.37), 2d16h/00:02:56, RP 0.0.0.0, flags: DJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel1, Forward/Dvmrp, 2d16h/00:00:44
    Fddi1/0, Forward/Dense, 2d16h/00:02:02
+++++++++++++++++++++++++++

=>--What does "sh ip igmp gr" say?

+++++++++++++++++++++++++++
ncrc-onc#sh ip igmp gr
IGMP Connected Group Membership
Group Address    Interface            Uptime    Expires   Last Reporter
224.2.166.76     Ethernet0/1          00:19:08  00:02:42  128.252.120.70
224.2.127.253    Ethernet0/5          00:44:15  00:02:34  128.252.98.3
224.2.127.253    Ethernet0/1          18:49:12  00:02:41  128.252.120.70
224.1.127.255    Ethernet0/5          00:44:15  00:02:27  128.252.98.3
224.1.127.255    Ethernet0/1          18:49:12  00:02:41  128.252.120.25
224.2.255.127    Ethernet0/1          00:19:06  00:02:46  128.252.120.25
224.2.127.255    Tunnel1              584942417ynever     130.221.192.50
224.2.127.254    Ethernet0/5          00:44:15  00:02:34  128.252.98.3
224.2.127.254    Ethernet0/1          18:49:12  00:02:41  128.252.120.70
224.0.1.40       Fddi1/0              3w1d      00:02:45  128.252.5.173
+++++++++++++++++++++++++++

=>--Are you using sparse mode or dense mode (or sparse-dense)?

dense mode.

=>There are _lots_ of possibilities.

Hopefully you can help me eliminate some of them with the above info :)

=>Please read the info at ftp://ftp-eng.cisco.com/ipmulticast.html 
=>for additional information.

Did that already. From what I understood, the router seems to be properly
configured. Didn't understand a lot of it...

Many, many thanks for all your help,
naeem

=>    Hi all,
=>    
=>    I am a newbie to mbone, so bear with me :)
=>    
=>    I am trying to deploy mbone at my university. I have 2 subnets 128.252.98
=>    and 128.252.120 that are directly connected to a multicast capable cisco,
=>    and both use it as a gateway. The cisco appears to be properly configured.
=>    I can run sdr on any machine on my subnets and see the conferences going
=>    on. I can also set up conferences on machines withing the same subnet.
=>    However, if I set up a conference on the 120 subnet, the machines in the
=>    98 subnet cannot see it - and vice versa.
=>    
=>    Can you give me a lead as to what could be happening?
=>    
=>    Thanks very much,
=>    naeem
=>    
=>    -------------------------------------------------------------
=>    Naeem Bari			Tel: (314) 935-4865
=>    Software/Network Engineer	Fax: (314) 935-7142
=>    Office of the N/W Coordinator	[email-masked]
=>    Washington U. in St. Louis	http://rusty.wustl.edu/~naeem/
=>    --------------------------------------------------------------
=>    
=>    
=>
=>------------------------------------------------------------------------------
=>	John Zwiebel                       Phone: 408-526-5303
=>	Cisco Systems Inc..                 Fax:   
=>	Multimedia Group                   Email: [email-masked]
=>

---

From: "John M. Zwiebel" <[email-masked]>
Date: Thu, 24 Apr 1997 10:27:22 -0700

Naeem:

You went to the trouble of setting up the conference and partly describing
how the systems are connected and then you don't show me the 
configuration of the router and you don't show me the mroute entries
for the conference you are trying to get A, B and C to join.

The only thing that is useful in all the information you provided is
the "sh ip igmp gr" which shows that A is reporting joined to the
224.2.166.76 group and B is joined to ghe 224.2.255.127 group both
on ethernet1/0.  That means there should be entries in the multicast 
routing table for these systems.

The question is where is C?  Why isn't it trying to join the group?
Is it even responding to the IGMP queries being sent out from the router?
Is the router even sending those queries?

	"sh ip igmp int"
	"sh ip pim int"

Should both show the router interfaces over which you want to forward traffic.
These interfaces also have to show up in the multicast routing table somewhere.

Next, which 11.1 are you running on the router.  
It should be at least 11.1(8.1) or better.
The current release is 11.1(10.5) or 11.2(5.2).

    John et al,

    

    Here is the situation:

    Session name: onc aud/wb
    Description: test
    Type of session: Test
    Security: public
    Scope: Site (ttl 15)

    

    +++++++++++++++++++++++
    ncrc-onc#sho ip mr

     

    
    dense mode.

    

    
    =>    Hi all,
    =>    
    =>    I am a newbie to mbone, so bear with me :)
    =>    
    =>    I am trying to deploy mbone at my university. I have 2 subnets 128.25
	2.98
    =>    and 128.252.120 that are directly connected to a multicast capable ci
	sco,
    =>    and both use it as a gateway. The cisco appears to be properly config
	ured.
    =>    I can run sdr on any machine on my subnets and see the conferences go
	ing
    =>    on. I can also set up conferences on machines withing the same subnet
	.
    =>    However, if I set up a conference on the 120 subnet, the machines in 
	the
    =>    98 subnet cannot see it - and vice versa.
    =>    
    =>    Can you give me a lead as to what could be happening?
    =>    
    =>    Thanks very much,
    =>    naeem
    =>    
    =>    -------------------------------------------------------------
    =>    Naeem Bari			Tel: (314) 935-4865
    =>    Software/Network Engineer	Fax: (314) 935-7142
    =>    Office of the N/W Coordinator	[email-masked]
    =>    Washington U. in St. Louis	http://rusty.wustl.edu/~naeem/
    =>    --------------------------------------------------------------
    =>    
    =>    
    =>
    =>-------------------------------------------------------------------------
	-----
    =>	John Zwiebel                       Phone: 408-526-5303
    =>	Cisco Systems Inc..                 Fax:   
    =>	Multimedia Group                   Email: [email-masked]
    =>

---

From: Bill Fenner <[email-masked]>
Date: Thu, 24 Apr 1997 12:22:03 PDT

>A LOT of routes. The first few lines look like:

The interesting one is "show ip mr 224.2.127.254" (the sdr group), and
specifically, the entry for the machine on which you created the session
("show ip mr 224.2.127.254 ip.ad.dr.ess").

It should look something like

(128.252.120.xxx 224.2.127.254), ...
  Incoming interface: Ethernet0/1...
  Outgoing interface list:
    Tunnel1, Forward/Dvmrp, ...
    Ethernet0/5, Forward/Dense, ...

"show ip mr ... count" is also interesting, to see how many packets
actually got heard.

  Bill

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 24 Apr 1997 16:54:29 -0700

>> "show ip mr ... count" is also interesting, to see how many packets

    Got forwarded.

Dino