Subject: shmat error message on "Places all over the world"

From: Beau Williamson <[email-masked]>
Date: Thu, 21 May 1998 16:00:03 -0500

I'm getting a strange error message on my Sparc 5 (running Solaris 2.5.1)
when I try to join the video stream for "Places all over the world".  Vic
will start up and start to display the current 5-6 active video session and
then bomb off with a console error message of: "shmat: Too many open files".

I realize that this isn't a multicast problem but I'll bet someone out
there knows what this means and can tell me what system resource I need to
increase and how to fix this. I have searched my Solaris docs and don't
find anything regarding this error message.

TIA.

Beau

---

From: [email-masked] (Jeremy Hall)
Date: Thu, 21 May 1998 18:45:19 -0400 (EDT)

haven't seen the places announcement in 15 or so minutes.

However, some of them are repeating quite frequently, under a minute.

_J

---

From: [email-masked] (Jeremy Hall)
Date: Thu, 21 May 1998 18:47:00 -0400 (EDT)

The ``arts

---

From: [email-masked] (Jeremy Hall)
Date: Thu, 21 May 1998 18:59:50 -0400 (EDT)

SAP: 596 bytes
version: 0
message type: 0
encrypt: 0
compress: 0
auth length: 0
msgid: 8192
address: 130.240.64.20
v=0
o=demo 3066564173 3066564269 IN IP4 130.240.64.67
s=Places all over the world
i=Low bandwidth video (10 kb/s) with views from all over the world. It is
probably wise to limit the overall bandwidth to 100 kb/s (that is, a
maximum of ten 10 kb/s streams).  Audio is primarily for feedback for the
senders of video.
e=Hakan Lennestal <[email-masked]>
c=IN IP4 224.2.172.238/127
t=0 0
a=tool:mStar 1.0beta1
a=type:broadcast
m=video 51482 RTP/AVP 31
c=IN IP4 224.2.172.238/127
m=audio 20154 RTP/AVP 0
c=IN IP4 224.2.213.113/127
a=rtpred1:5
a=ptime:40
a=rtpred2:5
a=rtpmap:121 red/8000

looks fine to me. Not sure what rtpmap:121 and rtpred are. (I know what an
rtpmap is, just not sure what 121 is.)

_J

---

From: Hugh LaMaster <[email-masked]>
Date: Thu, 21 May 1998 16:08:39 -0700 (PDT)

> find anything regarding this error message.

Do you have the following variables set in /etc/system?
If not, you should do so; I don't recall why the message
says "shmat", but, the general problem is usually lack
of enough shared memory segments.  The defaults are set
too low on many (most?) OS's.  In this case, set these
in /etc/system and then reboot.  I use the following,
which specify the maximum size of any shared memory 
segment, and, the maximum number of such segments.

                set shmsys:shminfo_shmmax=2097152
                set shmsys:shminfo_shmseg=50

--
 Hugh LaMaster, M/S 233-21,    ASCII Email: [email-masked]
 NASA Ames Research Center     Or:          [email-masked]
 Moffett Field, CA 94035-1000  No Junkmail: USC 18 section 2701
 Phone: 650/604-1056           Disclaimer:  Unofficial, personal *opinion*.