Subject: Tunnel is sending packets - although other end is inactive

From: Klaus Mueller <[email-masked]>
Date: Tue, 28 Apr 1998 18:22:42 +0200

Hi,

hoping the information I can give on the problem we experience is
enough,
I would like you to think about this:

We have a setup which looks something like this:

 SGI A
(transmitter)                                        (tunnel)
  |
--------------------------------------
  |
|                                      |
CISCO A(M) -------> (34 MBit) Internet --> CISCO B(M) --> CISCO C(NM)
(2 MBit)--> SGI C

|
(receiver)
  |
 SGI B
(receiver)

SGI A is transmitting to the mbone. CISCO A (multicasting enabled) is
connecting the subnets
of SGI A and SGI B.
It has another interface that, let's us connect to the internet.

On the other side there is CISCO B (multicasting enabled) which connects
CISCO C (multicasting
disabled) to the internet. Finally, CISCO C has a connection to SGI C.
We have a tunnel between CISCO B and SGI C, which allows us to receive
MBone-sessions.
The tunnel is set to a max output rate of 500 kB on the CISCO side.
The transmission rate is set to 128 kBits/s. The reception rate on
SGI B is roughly as high as that.
Whereas the reception rate on SGI C is somewhere around 70 kBit/s.
Looking at the tunnel
on the CISCO, it says: output at 500 kBit/s. There is definitely no
second receiver on the side of
SGI C and even when the mrouted on SGI C is stopped, the tunnels says,
it outputs at
500 kBit/s.

The Config file for mrouted on SGI C has only one line:
tunnel <IP of SGI C> <IP of CISCO B>

I suppose, the problem has something to do with the tunnel, as users
from somewhere else on the net
(outside of our campus - but not connected through our tunnel...) report
much higher rates.
Does anyone have a clue, on what the problem could be, or where we could
start searching...

Thanks in advance,

K. Mueller.

--

 Klaus Mueller
 Labor Medieninformatik
 Fachhochschule Offenburg

 eMail: [email-masked]
 Tel: +49-781-205135
 Fax: +49-781-205242

---

From: ORLHAC Christophe <[email-masked]>
Date: Wed, 29 Apr 1998 09:43:40 +0200

Hello,

In the /etc/mrouted.conf of SGI C :

--->here are the mrouted commands :

       Command formats:
#
# name <boundname> <scoped-addr>/<mask-len>
# cache_lifetime 3600  # seconds
# pruning on
#
# phyint <local-addr> [disable] [metric <m>] [threshold <t>] [rate_limit
<b>]
#                         [boundary
(<boundname>|<scoped-addr>/<mask-len>)]
#     [altnet (<subnet>/<mask-len>|<subnet>)]
# tunnel <local-addr> <remote-addr> [srcrt] [metric <m>]
#                                      [threshold <t>] [rate_limit <b>]
#                         [boundary
(<boundname>|<scoped-addr>/<mask-len>)]
#
#   NOTE: any phyint commands MUST precede any tunnel commands
#   NOTE: the mask-len is the no. of leading 1's in the mask
#   NOTE: rate_limit is in kilobits, and defaults to 500 for tunnels
#

--->have you cheked all physical interfaces of SGI C ?

--->you must perhaps check the max rate of the tunnel : tunnel <@IP of
SGI C> <@IP of Cisco B> metric <x> threshold <y> rate-limit <500>
        Rate-limit is in Kbps and defaults to 500 for tunnels.

In the CISCO B configuration, try the ip multicast rate-limit command in
the tunnel interface configuration mode.

A+.
Christophe.

Klaus Mueller wrote:

> On the other side there is CISCO B (multicasting enabled) which
> connects CISCO C (multicasting
> The transmission rate is set to 128 kBits/s. The reception rate on SGI
> B is roughly as high as that.
> (outside of our campus - but not connected through our tunnel...)
> report much higher rates.
> Does anyone have a clue, on what the problem could be, or where we
> could start searching...
>
> Thanks in advance,
>
> K. Mueller.
>
>
> --
>
>  Klaus Mueller
>  Labor Medieninformatik
>  Fachhochschule Offenburg
>

---

From: Klaus Mueller <[email-masked]>
Date: Wed, 29 Apr 1998 12:18:29 +0200

> --->have you cheked all physical interfaces of SGI C ?

SGI C has one physical interface only (eth0)

>         Rate-limit is in Kbps and defaults to 500 for tunnels.

a reception rate of 500 kbit would be fine... (actually: even 200 kbit/s
would be fine)

> In the CISCO B configuration, try the ip multicast rate-limit command
> in the tunnel interface configuration mode.

the command in the cisco-config (CISCO B) looks like this:ip multicast
rate-limit out 500
so, this should be fine, too.

thanks for your help...

K. Mueller.

--

 Klaus Mueller
 Labor Medieninformatik
 Fachhochschule Offenburg

---

From: Bill Fenner <[email-masked]>
Date: Wed, 29 Apr 1998 10:29:11 PDT

The problem is likely that pruning is not working correctly, causing your
router to attempt to stuff all of the traffic on the MBone down your link
with the 500kbps limit.

Make sure that:

a) SGI C is sending prunes.  kill -USR2 `cat /etc/mrouted.pid` and look
at /var/tmp/mrouted.cache; it should have a capital "P" next to the
incoming interface for the groups that you're not a member of, e.g.

 Origin             Mcast-group         CTmr     Age      Ptmr Rx IVif Forwvifs
 135.16.13/24       224.0.1.10       0:01:46  0:02:10  0:04:48  2  4P  0p 1p

b) Cisco B is accepting the prunes.  "show ip mroute" should show the
tunnel towards SGI C in the state "Prune/Dvmrp" for all the same sources
and groups, e.g.

    Tunnel4, Prune/Dvmrp, 2d03h/00:55:10

  Bill