Subject: Multicasting without tunneling.

From: Vivek Vaidya <[email-masked]>
Date: Mon, 9 Jun 1997 14:27:33 -0400 (EDT)

Hi 
Hi all,
  I need to do the following:

From a multihomed Sun Sparc station that serves as a router and has one
multicast interface, I want to perform multicast routing to all subnetworks
that have hosts that are part of the multicast group for which the sparc
station receives multicast packets.

Please help..

Vivek.
([email-masked]).

---

From: Bill Fenner <[email-masked]>
Date: Mon, 9 Jun 1997 16:13:26 PDT

Vivek,

  I'm not sure what you mean by saying that your multihomed sun
has one multicast interface.  How is that one interface different
from your other interfaces?

  In any case, the multi-homed sun can just run mrouted (apply
the kernel patches from ftp://ftp.parc.xerox.com/pub/net-research/
ipmulti/, and get mrouted from the same place) and it will forward
traffic from one subnet to another if there are group members.

  If you want to forward multicast from elsewhere (e.g. from the
MBone), then the sun running mrouted needs to receive a DVMRP
routing table.  If the other router providing multicast to the
common link is running mrouted, then you don't need to do
anything; if it's a Cisco then you can use "ip dvmrp unicast-routing"
or "ip dvmrp default-information originate" on the shared link.
Please don't use "ip dvmrp default-information" if there's any
chance (e.g. via redundant topology) that the default route advertised
will make it back to the MBone.

  Bill

---

From: Vivek Vaidya <[email-masked]>
Date: Wed, 11 Jun 1997 15:23:51 -0400 (EDT)

Thanks a lot, Bill.

> traffic from one subnet to another if there are group members.
I have done that and installed mrouted and the kernel patches. However, when I
run a multicast source and sink on 2 Win 95 machines, which are on different
subnets, the sink does not get the multicast packets. When I run the source
and sink on m/c's on the same subnet, it works.

What am I missing out ?

Vivek.

---

From: Bill Fenner <[email-masked]>
Date: Wed, 11 Jun 1997 12:46:09 PDT

Vivek Vaidya <[email-masked]> wrote:
>However, when I

If you kill -USR1 `cat /etc/mrouted.pid`, mrouted will put
an "mrouted.dump" file in /usr/tmp.  Check it and make sure
it has routes for each of the interfaces on the multi-homed
host.  Also check and be sure that the group memberships on
the other interface(s) are listed.

If you kill -USR2 `cat /etc/mrouted.pid`, mrouted will put
an "mrouted.cache" file in /usr/tmp.  Find the entry in it
for the multicast source, and see if it has a parent route
and parent vif, or if the parent vif says -1 (meaning there
is no route for this source).  Also check the list of
outgoing interfaces and see if the subnets on which the
multicast sink(s) sit are listed as outgoing.

  Bill

---

From: "John M. Zwiebel" <[email-masked]>
Date: Wed, 11 Jun 1997 12:57:14 -0700

Thanks a lot, Bill.
    
    > traffic from one subnet to another if there are group members.
    I have done that and installed mrouted and the kernel patches. However, whe
	n I
    run a multicast source and sink on 2 Win 95 machines, which are on differen
	t
    subnets, the sink does not get the multicast packets. When I run the source
    and sink on m/c's on the same subnet, it works.
    
    What am I missing out ?

TTL?

Check that the default for your application isn't 1.  If it is, the packet
won't be forwarded across the router.

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 Fax:   
	Multimedia Group                   Email: [email-masked]

---

From: Vivek Vaidya <[email-masked]>
Date: Wed, 11 Jun 1997 16:44:52 -0400 (EDT)

TTL it was; I tried that after sending the mail and it worked. Thanks a lot
for all the help.

Vivek.