Subject: MBone loops ?

From: Joao Carlos Mendes Luis <[email-masked]>
Date: Fri, 26 Sep 1997 03:01:32 -0300 (EST)

Hi,

  I'm just thinking, is it possible to create loops to the MBone,
in order to get redundancy ?

  For example:

 +--------------------------------------------------------+
 |                      MBone cloud                       |
 +-------+---------------------------------+--------------+
         |                                 |
     +---+---+                         +---+---+
     | Rout1 |                         | Rout2 |
     +---+---+                         +---+---+
         |                                 |
     +---+---+                         +---+---+
     | Rout3 |                         | Rout4 |
     +---+---+                         +---+---+
         |                                 |
         +---------------------------------+

  Would it work efficiently, or would all traffic come from
both interfaces ?  It seems to me that pruning only is not
designed to work this way, but I don't know other features
of DVMRP.

					Jonny

--
Joao Carlos Mendes Luis			[email-masked]
+55 21 290-4698				[email-masked]
Universidade Federal do Rio de Janeiro	UFRJ/COPPE/CISI
PGP fingerprint: 29 C0 50 B9 B6 3E 58 F2  83 5F E3 26 BF 0F EA 67

---

From: [email-masked] (Ravi Shekhar)
Date: Fri, 26 Sep 1997 10:33:44 -0400 (EDT)

>in order to get redundancy ?
    
    Exchange of routes between Rout3 and Rout4 will make it clear who 
    would forward the data from a particular source.
    The router(among 3 and 4 in this case) with the minimum distance to 
    the source forwards it to the common subnet. In case of tie, the one 
    with the lower IP address takes precedence.

    - Ravi Shekhar.

---

From: "Matt Crawford" <[email-masked]>
Date: Fri, 26 Sep 1997 09:37:26 -0500

Bom dia, Jonny.

> in order to get redundancy ?   For example:  ...

Yes, you can do this.  In my experience, you might get transient
loops when links come back up, but that's based on some very old
versions of mrouted.  It might be better now.  One guideline that
used to apply was to set the metric of one link in the loop to be
larger than the sum of the metrics of all the other links in the
loop.  For example, if you have a loop of 5 mrouters A, B, C, D, E,
you might set the metric of four links to 1 and the remaining link
to 5.
				Ate logo,
				  Matt

---

From: Andre Uratsuka Manoel <[email-masked]>
Date: Fri, 26 Sep 1997 18:14:18 -0300 (GMT-0300)

Hi, Johnny

On Fri, 26 Sep 1997, Joao Carlos Mendes Luis wrote:
->Hi,
->
->  I'm just thinking, is it possible to create loops to the MBone,
->in order to get redundancy ?
->
->  For example:
->
-> +--------------------------------------------------------+
-> |                      MBone cloud                       |
-> +-------+---------------------------------+--------------+
->         |                                 |
->     +---+---+                         +---+---+
->     | Rout1 |                         | Rout2 |
->     +---+---+                         +---+---+
->         |                                 |
->     +---+---+                         +---+---+
->     | Rout3 |                         | Rout4 |
->     +---+---+                         +---+---+
->         |                                 |
->         +---------------------------------+
->
->  Would it work efficiently, or would all traffic come from
->both interfaces ?  It seems to me that pruning only is not
->designed to work this way, but I don't know other features
->of DVMRP.
->

	Please, if anyone can correct me where I'm wrong, I would be very
thankful.

	AFAIK, yes it is possible, but care must be taken. The first thing
I see is that the MBONE cloud must have the shortest route between the
routers to which rout1 and rout2 are connected. If the shortest route
between them is through your network, unwanted traffic will start to flow 
through you. So, increase metrics where necessary.

	There is also a bug in older mrouteds that cause prunes not to be
sent for the network of Rout3 and rout4. That, I think, is corrected in
the 3.9 beta.

	Regards,
	Andre