Subject: Start shrimp with sdr, ...

From: Christoph Fleck <[email-masked]>
Date: Thu, 3 Sep 1998 11:48:37 +0200 (MET DST)

Dear all,

To start the Intergrated User Interface Shrimp from sdr (windows) I wrote a 
sdr.tcl file that creates a shrimp-Button in the session description window.
If pushed it creates a shrimp.ini and start shrimp.
ftp://ftp-mm.urz.tu-dresden.de/pub/mbone/shrimp/mmrz/sdr.tcl

If you would use sdr2.5a5 you have to set %HOME% and %HOMEDIR% to
the same directory. Otherwise you will get 2 different shrimp.ini files.
Sdr2.4a6s3 need only %HOMEDIR% .

If you have already a sdr.tcl you could merge the files :-(
or rename both and use sdr.tcl_master as sdr.tcl to source all 
renamed sdr.tcl files. (e.g. sdr-shrimp.tcl, sdr-scopes.tcl, ...)
ftp://ftp-mm.urz.tu-dresden.de/pub/mbone/shrimp/mmrz/sdr.tcl_master

Do you use sdr2.5a5 on windows and your "New -> Create advertised session" window
is not complete diplayed? Yor Desktop is to small or some plugins for sdr probably 
the reason.
The sdr on windows would only accept and start *.exe files (why?). 
You could delete the plugins or change it.
If you would use a *.bat file you could change the tool-line to 

tool:cmd               (on NT)
tool:start             (on W95) 

and give a new flags-line  

flags:/C toolname      (on NT cmd)
flags:/m toolname      (on W95 start)

Examples for webconf and mtalk you can find at 
ftp://ftp-mm.urz.tu-dresden.de/pub/mbone/webcanal/mmrz/

Rgds,
Christoph Fleck

,------------------------------------------------------------------.
| Referenzzentrum fuer multimediale Teledienste (MMRZ), TU Dresden |
|         Dr. Klaus Koehler, Christoph Fleck, Rainer Kranz         |
| e-mail: [email-masked]             Tel.: 0351 / 463 5653  |
|    WWW: http://www-mm.urz.tu-dresden.de               (GERMANY)  |
`------------------------------------------------------------------'

---

From: "Christopher J. Tengi" <[email-masked]>
Date: Thu, 03 Sep 1998 16:21:32 -0400

In the file:

which has been installed in %HOMEDIR%\sdr\sdr.tcl.  There is a line:

	exec start shrimp

which causes an error on the NT system we are trying to use this on.  It 
appears that 'start' cannot be found.  Do we need to have anything other than 
the SHRIMP UI and sdr/rat/vic/nte/wb installed?  Where would the 'start' 
command be found?  I was not able to find it on this system (and I know very 
little about NT at this point).

					Thanks,
						/Chris

---

From: Christoph Fleck <[email-masked]>
Date: Fri, 4 Sep 1998 10:21:38 +0200 (MET DST)

> little about NT at this point).

The start.exe comes from win95. I have both NT4.0 and win95 on my machine.
Copy the start.exe from any win95 to your NT and it should work.
I need the funktion to run shrimp in background. Otherwise sdr will stay 
until you exit shrimp.
On unix a "&" will do this. Win95 has start. And NT?

Rgds,
Christoph

---

From: Christoph Fleck <[email-masked]>
Date: Fri, 4 Sep 1998 11:38:47 +0200 (MET DST)

> On unix a "&" will do this. Win95 has start. And NT?

Tcl can start shrimp in the background with "exec shrimp &" but shrimp 
will fail to come up on my box.
With "exec start shrimp" it works.

Rgds,
Christoph

---

From: Hugh LaMaster <[email-masked]>
Date: Tue, 15 Sep 1998 12:54:18 -0700 (PDT)

I notice a lot of people are converting to native PIM from
their previous tunneled arrangements.  That is great.

I also notice that quite often there are no outgoing TTL thresholds
set.  So, low-TTL traffic that was not forwarded in the previous
configuration, and that I have noticed is clearly not supposed
to be going out to "The World", is now going out.  While TTL is
a poor way to get administrative scoping, the fact is that there
is a lot of traffic going out for sessions set with, e.g., 
TTL=15, =31, =63, where users expected these to stop when they hit 
the appropriate TTL boundaries.

So, I am requesting that people set these thresholds appropriately
so that traffic from their "enterprise", (or region for certain
regional networks), be filtered using a threshold of 64.  Cisco
has the same option as mrouted for this, via the following command:

On the outbound interface (that is, to "the rest of the world"),

  ip multicast ttl-threshold 64

This will prevent TTL 63 or less traffic from being forwarded
from another interface out that interface.  Notice that "sdr"
uses TTL <= 15 as the "site" TTL by default and TTL <= 63 as
the "region" TTL default.  Many people also assume a third
level, TTL <= 31, as an intermediate limit.  So, in the
above statement, it could use 16 or 32 as well, depending
on how the internal limits are set up.  I suggest that 
corporations and universities use 64 unless they know it should
be less, and use 32 and 16 for different campuses/departments/etc.
Some regional networks connecting universities seem to use 64
for the entire network, 32 for the different campuses, and 16
for individual departments/schools/sites etc.

To forestall criticism: I agree that this is mostly obsolete,
but, it is better than nothing, given some of the purely local
traffic I am seeing leaking out of folks LANs.

Comments/corrections/criticism welcome.

--
 Hugh LaMaster, M/S 233-21,    ASCII Email: [email-masked]
 NASA Ames Research Center     Or:          [email-masked]
 Moffett Field, CA 94035-1000  No Junkmail: USC 18 section 2701
 Phone: 650/604-1056           Disclaimer:  Unofficial, personal *opinion*.