Subject: MBone: US-EU connectivity

From: "Peter Feil" <[email-masked]>
Date: Tue, 27 Aug 1996 22:39:20 +0200

Dear All,

The actual MBone connectivity from Europe (at least to/from Germany)
to/from the US is really a catastrophe:
- we are watching very high loss rates at or near Stockholm
- information received over the MBone "looks" like an
  ON-OFF-source (period about 2 seconds)
- multicast routes from Stockholm/SURFNET to the US are changing
(- I couldn't find any dups)

Included you will find some mtrace and tcpdump outputs
from today describing this situation (due to the high
loss rates mtrace most of the times just timed out...)

Please, please, let's work together to improve this situation!!!

Thanks
  Peter
---------------------------------------------------------------
Peter Feil
University of Stuttgart
National Supercomputing Center (RUS)
Communication Systems    phone : ++49-711-685 5735
Allmandring 30           fax   : ++49-711-678 7626
70550 Stuttgart          e-mail: [email-masked]
Germany
---------------------------------------------------------------

feil@kssun9:/usr/multicast$ mtrace -l 131.136.234.103 224.2.179.106
Mtrace from 131.136.234.103 to 129.69.30.19 via group 224.2.179.106
Querying full reverse path... * switching to hop-by-hop:
  0  kssun9 (129.69.30.19)
 -1  suntrec (129.69.30.12)  DVMRP  thresh^ 1
 -2  mbone-atm (129.69.200.36)  DVMRP  thresh^ 1
 -3  * broodjeham.surfnet.nl (192.87.106.102)  DVMRP  thresh^ 48
 -4  * mbone.cern.ch (192.65.185.20)  DVMRP  thresh^ 48
 -5  * fmroute1-1.exp.edf.fr (192.70.92.133)  DVMRP  thresh^ 64
 -6  * mae-bone.psi.net (192.41.177.247)  DVMRP  thresh^ 64
 -7  * * * * MBONE1.UU.NET (137.39.43.34) didn't respond
 -8
Resuming...
 -7  MBONE1.UU.NET (137.39.43.34)  DVMRP  thresh^ 64
 -8  collegepk-mbone1.bbnplanet.net (128.167.252.196)  DVMRP  thresh^ 32
 -9  * * * * cdrn.bbnplanet.net (192.221.34.22) didn't respond
-10  * * *

tcpdump output:
12:14:41.701350 8:0:20:74:ef:9 1:0:5e:2:b3:6a ip 370:
spiff.crc-mcast.drenet.dnd.ca.50122 > 224.2.179.106.26206: udp 328 (ttl 117, id
59661)
12:14:41.730724 8:0:20:74:ef:9 1:0:5e:2:b3:6a ip 370:
spiff.crc-mcast.drenet.dnd.ca.50122 > 224.2.179.106.26206: udp 328 (ttl 117, id
59662)
---------------------------------------------------------------

tcpdump output:
12:17:43.375078 8:0:20:74:ef:9 1:0:5e:2:b3:6a ip 370:
spiff.crc-mcast.drenet.dnd.ca.50122 > 224.2.179.106.26206: udp 328 (ttl 118, id
64241)
12:17:43.429450 8:0:20:74:ef:9 1:0:5e:2:b3:6a ip 370:
spiff.crc-mcast.drenet.dnd.ca.50122 > 224.2.179.106.26206: udp 328 (ttl 118, id
64242)

feil@kssun9:/usr/multicast$ mtrace -l 131.136.234.103 224.2.179.106
Mtrace from 131.136.234.103 to 129.69.30.19 via group 224.2.179.106
Querying full reverse path... * switching to hop-by-hop:
  0  kssun9 (129.69.30.19)
 -1  suntrec (129.69.30.12)  DVMRP  thresh^ 1
 -2  mbone-atm (129.69.200.36)  DVMRP  thresh^ 1
 -3  broodjeham.surfnet.nl (192.87.106.102)  DVMRP  thresh^ 48
 -4  * stockholm.mbone.ebone.net (194.68.128.50)  DVMRP  thresh^ 48
 -5  * * * * mae-bone.psi.net (192.41.177.247) didn't respond
 -6  * * *
 -7
Resuming...
 -5  mae-bone.psi.net (192.41.177.247)  DVMRP  thresh^ 64
 -6  MBONE1.UU.NET (137.39.43.34)  DVMRP  thresh^ 64
 -7  collegepk-mbone1.bbnplanet.net (128.167.252.196)  DVMRP  thresh^ 32
 -8  * * * * cdrn.bbnplanet.net (192.221.34.22) didn't respond
 -9  * * *
-10  * * *
-11  * * * ...giving up
Round trip time 360 ms

Results after 39 seconds:

  Source        Response Dest    Packet Statistics For     Only For Traffic
   * * *        129.69.30.19     All Multicast Traffic     From 131.136.234.103
     v       __/  rtt  364 ms    Lost/Sent = Pct  Rate       To 224.2.179.106
128.167.252.196 collegepk-mbone1.bbnplanet.net
     v     ^      ttl   32     1233/2849 = 43%  73 pps     0/993  =  0%  25 pps
137.39.43.34    MBONE1.UU.NET
     v     ^      ttl   64       16/1624 =  1%  41 pps     9/993  =  1%  25 pps
192.41.177.247  mae-bone.psi.net
     v     ^      ttl   65     1621/1962 = 83%  50 pps   810/984  = 82%  25 pps
192.36.148.206
194.68.128.50   stockholm.mbone.ebone.net
     v     ^      ttl   66        1/667  =  0%  17 pps     0/174  =  0%   4 pps
193.148.15.2
192.87.106.102  broodjeham.surfnet.nl
     v     ^      ttl   67       33/864  =  4%  22 pps     5/174  =  3%   4 pps
193.196.152.10
129.69.200.36   mbone-atm
     v     ^      ttl   68       -1/922  =  0%  23 pps     0/169  =  0%   4 pps
129.69.200.31
129.69.30.12    suntrec
     v      \__   ttl   69          798         20 pps       169          4 pps
129.69.30.19    129.69.30.19
  Receiver      Query Source

Waiting to accumulate statistics... * Results after 52 seconds:

  Source        Response Dest    Packet Statistics For     Only For Traffic
   * * *        129.69.30.19     All Multicast Traffic     From 131.136.234.103
     |       __/  rtt  715 ms    Lost/Sent = Pct  Rate       To 224.2.179.106
     v      /     hop -240 s     ---------------------     --------------------
128.167.252.196 collegepk-mbone1.bbnplanet.net
     |     ^      ttl   32   1910350181/1402968604= -1%25150
pps301989873/-1943153971= --%-34833 pps
     v     |      hop -155 s -1516705022/-1871457792= --%-30568
pps50331648/973406208=  1%15899 pps
Route changed:
 -1  suntrec (129.69.30.12)  DVMRP  thresh^ 1
 -2  mbone-atm (129.69.200.36)  DVMRP  thresh^ 1
 -3  broodjeham.surfnet.nl (192.87.106.102)  DVMRP  thresh^ 48
 -4  stockholm.mbone.ebone.net (194.68.128.50)  DVMRP  thresh^ 48
 -5  icm-pen-2-F2/0.icp.net (198.67.134.250)  DVMRP  thresh^ 64
 -6  cambridge1-mbone1.bbnplanet.net (199.94.207.2)  DVMRP  thresh^ 32
 -7  collegepk-mbone1.bbnplanet.net (128.167.252.196)  DVMRP  thresh^ 32
Restarting.

Querying full reverse path... * switching to hop-by-hop:
  0  kssun9 (129.69.30.19)
 -1  suntrec (129.69.30.12)  DVMRP  thresh^ 1
 -2  mbone-atm (129.69.200.36)  DVMRP  thresh^ 1
 -3  broodjeham.surfnet.nl (192.87.106.102)  DVMRP  thresh^ 48
 -4  stockholm.mbone.ebone.net (194.68.128.50)  DVMRP  thresh^ 48
 -5  icm-pen-2-F2/0.icp.net (198.67.134.250)  DVMRP  thresh^ 64
 -6  ^Cfeil@kssun9:/usr/multicast$

---------------------------------------------------------------
---------------------------------------------------------------
tcpdump output:
13:33:59.205210 canine.pica.army.mil.32797 > 224.52.0.24.28028: udp 339 (ttl
191, id 44156)
13:33:59.242191 canine.pica.army.mil.32797 > 224.52.0.24.28028: udp 339 (ttl
191, id 44159)
...
13:35:10.849507 canine.pica.army.mil.32797 > 224.52.0.24.28028: udp 339 (ttl
190, id 48221)
13:35:10.852870 canine.pica.army.mil.32797 > 224.52.0.24.28028: udp 339 (ttl
190, id 48224)
feil@kssun9:/home/feil$ mtrace -l canine.pica.army.mil 224.52.0.24
Mtrace from 129.139.68.19 to 129.69.30.19 via group 224.52.0.24
Querying full reverse path...
  0  kssun9 (129.69.30.19)
 -1  suntrec (129.69.30.12)  DVMRP  thresh^ 1
 -2  mbone-atm (129.69.200.36)  DVMRP  thresh^ 1
 -3  broodjeham.surfnet.nl (192.87.106.102)  DVMRP  thresh^ 48
 -4  stockholm.mbone.ebone.net (194.68.128.50)  DVMRP  thresh^ 48
 -5  mae-bone.psi.net (192.41.177.247)  DVMRP  thresh^ 64
 -6  wtn-ms1.bbnplanet.net (192.41.177.197)  DVMRP  thresh^ 32
 -7  iguana.nrl.navy.mil (132.250.1.6)  DVMRP  thresh^ 64
 -8  arl-mbone.dren.net (138.18.4.224)  DVMRP  thresh^ 48
 -9  bpsouth.pica.army.mil (129.139.68.165)  DVMRP  thresh^ 32
-10  canine.pica.army.mil (129.139.68.19)
Round trip time 497 ms

Waiting to accumulate statistics... Results after 10 seconds:

  Source        Response Dest    Packet Statistics For     Only For Traffic
129.139.68.19   129.69.30.19     All Multicast Traffic     From 129.139.68.19
     v       __/  rtt  361 ms    Lost/Sent = Pct  Rate       To 224.52.0.24
Route changed:
 -1  suntrec (129.69.30.12)  DVMRP  thresh^ 1
 -2  mbone-atm (129.69.200.36)  DVMRP  thresh^ 1
 -3  broodjeham.surfnet.nl (192.87.106.102)  DVMRP  thresh^ 48
 -4  stockholm.mbone.ebone.net (194.68.128.50)  DVMRP  thresh^ 48
 -5  icm-pen-2-F2/0.icp.net (198.67.134.250)  DVMRP  thresh^ 64
 -6  mae-bone.psi.net (192.41.177.247)  DVMRP  thresh^ 64
 -7  wtn-ms1.bbnplanet.net (192.41.177.197)  DVMRP  thresh^ 32
 -8  iguana.nrl.navy.mil (132.250.1.6)  DVMRP  thresh^ 64
 -9  arl-mbone.dren.net (138.18.4.224)  DVMRP  thresh^ 48
Restarting.

Querying full reverse path...
  0  kssun9 (129.69.30.19)
 -1  suntrec (129.69.30.12)  DVMRP  thresh^ 1
 -2  mbone-atm (129.69.200.36)  DVMRP  thresh^ 1
 -3  broodjeham.surfnet.nl (192.87.106.102)  DVMRP  thresh^ 48
 -4  stockholm.mbone.ebone.net (194.68.128.50)  DVMRP  thresh^ 48
 -5  icm-pen-2-F2/0.icp.net (198.67.134.250)  DVMRP  thresh^ 64
 -6  mae-bone.psi.net (192.41.177.247)  DVMRP  thresh^ 64
 -7  wtn-ms1.bbnplanet.net (192.41.177.197)  DVMRP  thresh^ 32
 -8  iguana.nrl.navy.mil (132.250.1.6)  DVMRP  thresh^ 64
 -9  arl-mbone.dren.net (138.18.4.224)  DVMRP  thresh^ 48
-10  bpsouth.pica.army.mil (129.139.68.165)  DVMRP  thresh^ 32
-11  canine.pica.army.mil (129.139.68.19)

---

From: Bjorn Carlsson <[email-masked]>
Date: Wed, 28 Aug 96 00:10:34 +0200

Any improvement now? I think I've fixed the loss betwean schnell.ebone.net
(icm-pen-2 in your traces) and stockholm.mbone.ebone.net. This probably
caused the 2 seconds ON-OFF source problem below. 

(It was caused by both ethernet-interfaces of the stockholm mbone box
 being connected to two "partitions" of the same FDDI-switch with the
 same mac-address).

--BC

---

From: "Peter Feil" <[email-masked]>
Date: Wed, 28 Aug 1996 10:01:18 +0200

On Aug 28, 12:10am, Bjorn Carlsson wrote:
> Subject: Re: MBone: US-EU connectivity
Thanks for fixing this. Yes, the ON-OFF behaviour disappeared
and I am no longer wathing this high loss rate on the way
to stockholm.mbone.ebone.net.

Thanks
  Peter