Subject: mbone on an 02

From: Dave Wright <[email-masked]>
Date: Mon, 25 Nov 1996 10:44:17 -0800 (PST)

Does anyone know if the vino card on the new 02 is the same as
the one on the Indys? Just curious if anyone has tried broadcasting
from an 02 yet.

	thanks

 ________  o      Dave Wright 
 _______ _/\_>    [email-masked]
 _______O=>// O   91CBR600F2 AFM# 316
 --------------   Mathematical Sciences Research Institute

---

From: "Bill Nowicki" <[email-masked]>
Date: Wed, 27 Nov 1996 14:51:46 -0800

> Does anyone know if the vino card on the new 02 is the
> same as the one on the Indys? Just curious if anyone has
> tried broadcasting from an 02 yet.

Not sure if this what you mean, but Silicon Graphics
Computer Systems has a product called an O2. It is
a totally new workstation, with a new Audio-Video
module. It is spelled with the letter "Oh" not
the numeral zero. We did multicast the announcement.

Device differences are supposed to be covered
up by the Video Library (VL) layer, which is
dynamically linked at run time. So the old binary
of the vic program just works. It queries for the
available ports when it starts up: you get
Analog Composite, S-Video, included Camera (controllable
focus and shutter, so better than the IndyCam,
but you still want a professional camera for anything
but conferencing), or Digital Video in.

I have been using an O2 to source some video for
internal SGI multicasts.  Currently the encoding
and decoding are still done in software on the MIPS
R5000. It should be possible to accelerate these
by putting the inner loops into firmware on the
video processing chip.  There is also some kind of
bug that causes the input buffers to be lost
every now and then. I don't think any customers
have seen this, but we are trying to track that
down and fix. Just turning transmit off and on
brings it back to life. The bug might be in the
VL calls within vic, which would require a new
vic, or in the video driver, which can be fixed
with a new Irix release or patch.

Let me know if you need more details.

Bill Nowicki
Silicon Graphics