Subject: cisco 2500 and mbone

From: Amancio Hasty <[email-masked]>
Date: Mon, 17 Aug 1998 22:20:14 -0700

Does anyone know which IOS version for a Cisco 2500 works with pim sparse
and DVMRP ?

The network  topology is

above.net
  	native ip multicast

    v-site.net (2500 )
	tunnel to rah

It appears that the cisco 2500 is not accepting ip multicast traffic from 
the above.net side;however, if I establish a tunnel directly to above.net's
network everything seems to work.

	Tnks!
	Amancio

P.S:. This is the  2500's config file .

gateway#show ver
Cisco Internetwork Operating System Software 
IOS (tm) 3000 Software (IGS-I-L), Version 11.1(15), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1997 by cisco Systems, Inc.
Compiled Mon 20-Oct-97 20:29 by richv
Image text-base: 0x03020570, data-base: 0x00001000
 
ROM: System Bootstrap, Version 4.14(9.1), SOFTWARE
 
gateway uptime is 2 days, 15 hours, 34 minutes
System restarted by power-on
System image file is "igs-i-l.111-15.bin", booted via flash
 
cisco 2500 (68030) processor (revision A) with 16384K/2048K bytes of
memory.
Processor board ID 01512855, with hardware revision 00000000
Bridging software.
X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
1 Ethernet/IEEE 802.3 interface.
2 Serial network interfaces.
32K bytes of non-volatile configuration memory.
4096K bytes of processor board System flash (Read ONLY)
 
Configuration register is 0x102

gateway#show config
Using 1761 out of 32762 bytes
!
version 11.1
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname gateway
!
ip subnet-zero
no ip source-route
ip multicast-routing
ip dvmrp route-limit 7000
!
interface Tunnel0
 ip unnumbered Ethernet0
 ip pim dense-mode
 tunnel source Ethernet0
 tunnel destination 209.133.7.234
 tunnel mode dvmrp

interface Ethernet0
 ip address 209.66.64.10 255.255.255.192
 no ip directed-broadcast
 ip pim sparse-mode
 ip dvmrp unicast-routing
 no ip mroute-cache
 ip sdr listen
 no ip route-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
!
interface Serial0.4 point-to-point
 ip unnumbered Ethernet0
 bandwidth 128
 frame-relay interface-dlci 17 IETF   
!
interface Serial0.5 point-to-point
 ip unnumbered Ethernet0
 bandwidth 384
 frame-relay interface-dlci 18 IETF   
!         
interface Serial0.6 point-to-point
 ip unnumbered Ethernet0
 no ip directed-broadcast
 bandwidth 256
 frame-relay interface-dlci 16 IETF   
!
interface Serial0.8 point-to-point
 ip unnumbered Ethernet0
 bandwidth 56
 frame-relay interface-dlci 19 IETF   
!
interface Serial0.9 point-to-point
 ip unnumbered Ethernet0
 bandwidth 384
 frame-relay interface-dlci 20 IETF   
!
interface Serial1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
!
ip classless
ip route 0.0.0.0 0.0.0.0 209.66.64.1
ip route 209.66.64.64 255.255.255.192 Serial0.9
ip route 209.66.64.128 255.255.255.192 Serial0.8
ip route 209.66.64.192 255.255.255.192 Serial0.4
ip route 209.133.7.0 255.255.255.0 Serial0.6
ip route 209.133.95.128 255.255.255.128 Serial0.5
snmp-server community public RO
!
line con 0
line aux 0
line vty 0 4

end

---

From: Petri Helenius <[email-masked]>
Date: Tue, 18 Aug 1998 08:49:19 +0300 (EEST)

> Does anyone know which IOS version for a Cisco 2500 works with pim sparse

Most of the bugs were never fixed for 11.1 so a late 11.2 or 11.3 version
is preferable for PIM and DVMRP operation.

Pete

---

From: Beau Williamson <[email-masked]>
Date: Tue, 18 Aug 1998 08:28:50 -0500

Amancio,

Be sure that you are not trying to tunnel to another Cisco using DVMRP
tunnels.  This is not supported and may be why things work when you tunnel
directly to the above.net network and not in the other case.  However, I'm
laboring under a severe lack of information here so this is only a wild
guess. (I didn't see anything wrong with your configs)

Also, upgrading to 11.2 would be a good idea.  Many bug-fixes are in 11.2
that are not in 11.1.

Beau Williamson

---

From: Richard Irving <[email-masked]>
Date: Tue, 18 Aug 1998 10:53:33 -0500

I am adjacent to above.net as well.... They are working with the
new MBGP... have patience  ;)

I am receiving *zip* for routes from them, and usually my multicast
is stable..... *knock* on wood... You say up there it is OK ?

I don't know about that..... In 24 hours I have not received
one SDR announcement on our mutual tunnel.....

---

From: Bill Fenner <[email-masked]>
Date: Tue, 18 Aug 1998 09:10:38 PDT

>	tunnel to rah

Does this router know about the RP's inside above.net?  I assume
it's using the "member-is-sender" hack for doing PIM-SM<>DVMRP
interoperability; are you sending traffic with a high enough TTL
to get to this router so that it knows that you're a group member?

  Bill

---

From: Amancio Hasty <[email-masked]>
Date: Tue, 18 Aug 1998 09:18:14 -0700

Hi, 

I am listening to CyberTheatre right now however this is with a
temporary tunnel to above.net and I am supposed to use my ISP's
Cisco 2500 . When I tunnel to v-site.net's 209.66.64.10 I get 
zero ip multicast traffic.  Guess we will have to wait for Cisco to respond
or for my ISP to upgrade his Cisco 2500 from IOS Version 11.1(15) to
the latest . According to private email 11.2 and 11.3 have many
of the bug fixes for this kind of scenario:

native ip multicast <----> Cisco 2500 <----- tunnel ----> FreeBSD Mrouted 3.8

mtrace from 195.138.192.92 to 209.133.7.234 via group 224.2.249.48
Querying full reverse path... * switching to hop-by-hop:
  0  rah.star-gate.com (209.133.7.234)
 -1  rah.star-gate.com (209.133.7.234)  DVMRP  thresh^ 1  
 -2  main-loop.sjc.above.net (207.126.96.6)  Unknown protocol code 8  thresh^ 
32
 -3  * * core2-main.sjc.above.net (207.126.96.133)  PIM/Special  thresh^ 0  
 -4  * * mbone-west.internex.net (205.158.0.60)  DVMRP  thresh^ 1  
 -5  * * * * dec3800-2-fddi-0.SanFrancisco.mci.net (204.70.158.61) didn't 
respond
 -6  * * 
Resuming...
 -5  dec3800-2-fddi-0.SanFrancisco.mci.net (204.70.158.61)  DVMRP  thresh^ 64  
 -6  stk-mbone-1.sprintlink.net (207.12.55.99)  DVMRP  thresh^ 64  
 -7  * * pen-mbone-1.sprintlink.net (207.41.200.99)  DVMRP  thresh^ 32  
 -8  * * schnell.ebone.net (192.36.137.1)  PIM/Special  thresh^ 32  
 -9  * * stockholm.mbone.ebone.net (192.36.148.206)  DVMRP  thresh^ 64  
-10  * * ams-mr.att-unisource.net (195.206.64.170)  PIM/Special  thresh^ 48  
-11  * * router.nirvanet.net (195.138.192.254)  PIM  thresh^ 48  
-12  sgi002.nirvanet.net (195.138.192.92)
Round trip time 432 ms; total ttl of 71 required.

Waiting to accumulate statistics... Results after 10 seconds:

  Source        Response Dest    Overall     Packet Statistics For Traffic From
195.138.192.92  209.133.7.234    Packet      195.138.192.92 To 224.2.249.48
     v       __/  rtt  405 ms     Rate       Lost/Sent = Pct  Rate
195.138.192.254 router.nirvanet.net 
     v     ^      ttl   49        52 pps       12/516  =  2%  51 pps
195.206.64.170  ams-mr.att-unisource.net 
     v     ^      ttl   50        51 pps        0/504  =  0%  50 pps
194.68.128.50  
192.36.148.206  stockholm.mbone.ebone.net 
     v     ^      ttl   67        73 pps        0/504  =  0%  50 pps
192.36.137.1    schnell.ebone.net 
     v     ^      ttl   67        72 pps        2/504  =  0%  50 pps
207.41.200.99   pen-mbone-1.sprintlink.net 
     v     ^      ttl   67        61 pps        0/502  =  0%  50 pps
207.12.55.99    stk-mbone-1.sprintlink.net 
     v     ^      ttl   70        55 pps       -1/502  =  0%  50 pps
204.70.158.77  
204.70.158.61   dec3800-2-fddi-0.SanFrancisco.mci.net 
     v     ^      ttl   71       292 pps       -2/503  =  0%  50 pps
205.158.0.60    mbone-west.internex.net 
     v     ^      ttl   71       108 pps        1/505  =  0%  50 pps
207.126.96.17  
207.126.96.133  core2-main.sjc.above.net 
     v     ^      ttl   71        54 pps        0/504  =  0%  50 pps
207.126.96.134 
207.126.96.6    main-loop.sjc.above.net 
     v     ^      ttl   71        54 pps        1/504  =  0%  50 pps
209.133.7.234   rah.star-gate.com 
     v      \__   ttl   71        50 pps        ?/503         50 pps
209.133.7.234   209.133.7.234
  Receiver      Query Source

---

From: Amancio Hasty <[email-masked]>
Date: Tue, 18 Aug 1998 09:22:54 -0700

This is my current mrouted entry:

tunnel  209.133.7.234    207.126.96.6   metric 1  rate_limit 100

Which is the same entry which I use to tunnel to the Cisco 2500 ip
address 209.66.64.10.

>From the application side , I use ttl 127 still no go thru the 2500.

	Tnks!
	Amancio

---

From: Bill Fenner <[email-masked]>
Date: Tue, 18 Aug 1998 09:55:31 PDT

The question remains about whether or not the router you're talking to
knows about the PIM RP's inside its domain.

If you're sending to a group and you say "show ip mr <group>" on
the cisco, you should see an entry with an RP listed, and flags:
F for your source (meaning that the router is registering your
traffic to the RP).

Via SNMP, I see, as an example:

gateway> showipmr 224.2.172.238

(*, 224.2.172.238), 0:28:11/0:02:59, flags: PD
  Incoming interface: None, RPF nbr 0.0.0.0, PIMv1
  Outgoing interface list:
[empty table]

(209.133.7.234/32, 224.2.172.238), 0:01:18/0:01:41, flags: PD
  Incoming interface: Ethernet0, RPF nbr 209.66.64.4, DVMRP
  Outgoing interface list:
[empty table]

and

PIM RP Table
Group           RP              State STimer LastChange
[empty table]

(i.e. it sees your traffic but doesn't have anywhere to forward it,
and isn't registering it, and has an empty PIM RP table.)

  Bill

---

From: Amancio Hasty <[email-masked]>
Date: Tue, 18 Aug 1998 10:01:46 -0700

Hi Bill, 

I already forwarded your message to Steve as well as this one.

	Regards,
	Amancio