Subject: Ever growing MBUFS

From: Dave Hayes <[email-masked]>
Date: Tue, 05 Nov 1996 11:10:18 -0800

SunOS 4.1.3 sun4c, mrouted 3.8. Two bogons with mrouted are beginning
to bother me.

On a reboot, I get loads of "ip_mforward: ip_mrouter socket queue
full" messages. An annoyance to be sure.

This is more serious. 

# netstat -m
408/672 mbufs in use:
...
        38 mbufs allocated to multicast options

This number grows until my machine runs out of mbufs. 

Am I loopy, or is there a new version of mrouted that fixes these
behaviors?
------
Dave Hayes - Altadena CA, USA - [email-masked] 
Freedom Knight of Usenet - http://www.jetcafe.org/~dave/usenet

  "No man is a failure who is enjoying life."             - William Feather

---

From: Bill Fenner <[email-masked]>
Date: Fri, 15 Nov 1996 14:41:47 PST

>full" messages. An annoyance to be sure.

That's more or less a debugging message, which you can feel free to comment 
out (you have the source to /sys/netinet/ip_mroute.c .

>This number grows until my machine runs out of mbufs. 

Remove the rate_limit on the phyint.  If you absolutely require that rate limit, I have a patch available which I haven't distributed because the problem is rare.

  Bill