Subject: Re: ISDN, Mbone gateway

From: [email-masked] (Gilles Dauphin)
Date: Mon, 10 Feb 1997 12:48:42 +0100

> From [email-masked] Mon Feb 10 11:44:41 1997
> 
> 
> I think dauphin's reply was probably the most accurate one, but I am
> still not sure how we can translate the input to the isdn card in a sun 
> box to mbone application output on the ethernet card or even if such a 
> thing is possible. 

It's possible:
	Configure both computer with SunISDN 1.0.3.
	when it's done you have a PPP link beetween the two computer.
	Depending of your configuration this link can go up to 128kbit/s.

Here is my config for multicast:
	A SS10M512 with DBRI interface is connect to ethernet and a ISDN line.
	This SS10 is at E.N.S.T. and is called
		- on the ethernet side : sig.enst.fr
		- on the ISDN side : sig-ppp.enst.fr
	This SS10 is runing mrouted with this conf:

------------------------------/etc/mrouted.conf---------------------------
# $Id: mrouted.conf,v 1.5 1994/08/24 23:54:21 thyagara Exp $
cache_lifetime 3600
pruning on

# juste remove ptp multicast (sig-ppp)
phyint 137.194.234.1 disable

# tunnel vers panoramix-bbone.enst.fr (the firewall to internet)
#
tunnel 137.194.224.8 137.194.24.2 metric 1 threshold 8
-----------------------------end /etc/mrouted.conf-----------------------

	you notice that the ppp multicast interface is down.
	On sig.enst.fr I add a file: /etc/gateways
	with one line:
		norip isptp0
	This line nullify the traffic over ISDN line. Avoid the server
	to call every X minutes the host 'flipper'. This is because
	sig.enst.fr is running in.routed

	At home , I have a SS5 whith a ISDN card and a ISDN line called
	flipper.enst.fr. (of course my name is Dauphin ;-) )
	When I want the mbone on 'flipper' , i run a 'rsh' to sig-ppp
	that just comment the 'phyint' line and kill -HUP mrouted.pid.
	Now the multicast traffic go on the ppp (ISDN) interface.
	When flipper boot, a special route command is issue:
		route add net 224.0.0.0 sig-ppp 1
	So, 'flipper' never run mrouted.

I send you later the exact config of flipper. Please wait end of this day.

Best regards,

Gilles

PS:
	The default of this config is, you need to have root access
	on both side.

---

From: [email-masked] (Gilles Dauphin)
Date: Tue, 11 Feb 1997 13:28:30 +0100

> From [email-masked] Tue Feb 11 13:09:35 1997
> 
> a) how to connect two Sun boxes over ISDN (Gilles Dauphin, Peter Parnes)

Just a fun complement information for this config.
	A SS5 with a ISDN card have 4 audio chanels:
	- 2 stereo chanels on board.
	- 2 stereo chanels on ISDN card with a speaker box.
That does not fit with your video problem, but some body who want
quadriphonique music (like old pickup) can start a project ;-)

Regards,

Gilles

---

From: caristan alain <[email-masked]>
Date: Wed, 12 Feb 1997 20:49:42 GMT

> From [email-masked] Wed Feb 12 19:26 WET 1997
> From: Craig Tenney <[email-masked]>
> X-Authentication-Warning: sodor.es.net: Host LOCALHOST [127.0.0.1] didn't use 
HELO protocol
> To: Soghra Zamani <[email-masked]>
> Cc: [email-masked], [email-masked]
> Subject: Re: ISDN, Mbone gateway
> Mime-Version: 1.0
> Date: Wed, 12 Feb 97 10:18:29 -0800
> X-Mts: smtp
> 
> 
> Soghra,
> 
> > This sounds quite straight forward, thanks. This is the answer I was
> > looking for. Am I correct to assume that video and audio out of the codec
> > to the workstation is in the analog domain and therefore, no conversion
> > between different video and audio standards is necessary? Sorry if this 
> > sounds a very simple question. We don't have any videoconferencing 
> > devices yet as we are in the process of purchasing one.
> 
> First, I will admit that I am not an audio expert, but the codec we
> are using has a audio line out which I plug into the audio line in on my
> DEC AlphaStation.  You could have troubles if the codec only has 
> a speaker out, and the workstation only has a mic in, then I think you  
> would need something to do the conversion.
I'm not also a big audio expert, but we are a little bit experimented in audio 
coupling with workstations.
You have to check with your codec provider the impedance of the analog audio 
output. The low impedance 4, 8 or 16 ohms is for speakers and is some time also 
compliant with the line-in plug of the workstation.
The microphone input requires many times a high impedance (you must check it for 
you computer or audio devices) which cannot fit with low impedance signal.
But, i think that you will not have any problem to connect the audio out of your 
codec, excepted some too low signal if it is not enough amplified by the coded. 
You can enhance it using the internal audio level tunning or passing by a small 
amplifier.
The impedance problem was more offently encountered three or four years ago when 
we just started to do audiovideoconferencing with not very well multimedia 
featured workstations.
But if you get a high impedance signal, you wil need to path through an audio 
mixer (with mic entry a low impedance output)
 or to find the right impedance adaptor(contact people who are working in audio 
for music, concert, radio television and so on).
> For video, I just plug the video out on the codec to the video in on the 
> AV321 card on the DEC AlphaStation.
> 
> Craig Tenney
> [email-masked]
> 
> 
> 
PS: if you want to grab audio, the best result come with omnidirectional  
(cardioide) microphone (like thus used for interviews ar talk shows)
characteristics: (example) output impedance 200 ohms
frequency range 20 to 18000 cps
we use the DO21b model from LEM (French company).
Of course it's a professional component and we have to use an adapter for canon 
socket to the mini-jack 3"5 conversion.

Alain Caristan

Telesia
[email-masked]

---

From: jgrant <[email-masked]>
Date: Fri, 14 Feb 97 16:49:45+010

At 12:08 11/02/97 +0000, Soghra Zamani wrote:
>
>Am I correct to assume that video and audio out of the codec
>between different video and audio standards is necessary?

Although analogue audio is reasonably straightforward 
(mostly you just need to worry about the impedance and 
the voltage level, though there can be other things 
such as the companding used in Dolby noise suppression),
an analogue video signal isn't that simple, particularly 
if it's in colour.

However, as your address ends ".ac.uk" I'm sure you can 
(and indeed should) get advice from UKERNA.

John Grant                    ______________________
Director                     /                      |
K-NET R&D Ltd               /      K  -  N  E  T    |
+44 1223 862125            /________________________|
http://www.k-net.co.uk     Leaders in ATM technology

---

From: "Bill Nowicki" <[email-masked]>
Date: Tue, 18 Feb 1997 14:41:20 -0800

> Apparently, vic supports the  video out on one of the SGI frame
> capture cards, but from what I've heard,  the performance on
> the card is not very good.

Time to prevent false rumors.

For some time SGI workstations have included video input
as standard, so there is no "capture card" to buy on
the Indy or O2. The O2 also includes video out, while
Indy requires a card for output. It is true that
going directly out on the Indy card (or some of the other
output options that do not have DMA color mapping) is
not practical. But there is another easy way to do what you
want. Just run the standard "videoout" program to
take an NTSC sized area of the screen out from the frame
buffer in hardware, select NTSC size in vic, and position
the window in the right place.

Other options like Octane ProVideo and Onyx2 video
should not require going through the framebuffer, but
I have not tried them.

As for the other discussion going on: there are about
15 "radio" stations and one "TV" station within SGI at
any given time, using Internet mbone technology with
thousands of users.

As an example, Maya Angelou is giving a talk tomorrow
which we would like to send outside as well.