Subject: BLT-1.9 help

From: Chris Robson ATDNet Admin <[email-masked]>
Date: Mon, 18 Mar 1996 12:25:22 -0500 (EST)

All

I'm trying to rebuild VIC and to do this you have to have BLT built.  
Thus my problem I get the following:

andy# set path=($path /usr/local/bin)
andy# make
making all in ./src
gcc -fwritable-strings -Wall -c -O 
-DBLT_LIBRARY=\"/usr/local/blt/lib/blt\" -I. -I/usr/local/include 
-I/usr/local/include  bltGraph.c
In file included from bltGraph.c:49:
bltGraph.h:400: parse error before `Tk_Cursor'
bltGraph.h:400: warning: no semicolon at end of struct or union
bltGraph.h:440: parse error before `}'
bltGraph.h:564: parse error before `TCL_VARARGS'
bltGraph.h:564: parse error before `specs'
bltGraph.h:564: warning: data definition has no type or storage class
bltGraph.c:96: dereferencing pointer to incomplete type
bltGraph.c:96: initializer element for `configSpecs.offset' is not constant
bltGraph.c:99: dereferencing pointer to incomplete type
bltGraph.c:99: initializer element for `configSpecs.offset' is not constant
bltGraph.c:102: dereferencing pointer to incomplete type

Any ideas to what I'm doing wrong?  Ran configure -with-gcc and get the 
following:

andy# configure -with-gcc
checking for install
checking for ranlib
checking how to run the C preprocessor
checking for ANSI C header files
checking for stdlib.h
checking for string.h
checking for float.h
checking for malloc.h
checking for errno.h
checking for unistd.h
checking for memory.h
checking for limits.h
checking for sys/time.h
checking for sys/wait.h
checking for whether time.h and sys/time.h may both be included
checking for strerror
checking for strdup
checking for strcasecmp
checking for size_t in sys/types.h
checking for union wait
checking if postscript prolog can be inlined
checking for X include and library files with xmkmf
checking for X include and library files directly
checking for -lXt
checking for tcl.h
checking for libtcl.a
checking for tk.h
checking for libtk.a
checking for -lXbsd
checking for -lsocket
checking for -lnsl
checking for -lieee
checking for -lm
checking for -ldl
checking how to make shared libraries
checking for uname
creating config.status
creating Makefile
creating src/Makefile
creating src/shared/Makefile
creating man/Makefile
creating library/Makefile
creating src/bltConfig.h
src/bltConfig.h is unchanged
 
Configuration results (edit and run ./config.status to modify):
 
directory containing "tcl.h"      => /usr/local/include
directory containing "tk.h"       => /usr/local/include
directory containing "X11/Xlib.h" => default
directory containing "libtcl.a"   => /usr/local/lib
directory containing "libtk.a"    => /usr/local/lib
directory containing "libX11.a"   => /usr/openwin/lib
directory to install "blt_wish"   => /usr/local/blt/bin
directory to install "libBLT.a"   => /usr/local/blt/lib
directory to install BLT library files => /usr/local/blt/lib/blt

Not sure what above is telling me since all the files are in the 
locations indicated.
The config.status output is:

andy# config.status
creating Makefile
creating src/Makefile
creating src/shared/Makefile
creating man/Makefile
creating library/Makefile
creating src/bltConfig.h
src/bltConfig.h is unchanged

I have built blt-1.7 and is installed on the same machine.  Is there a 
comflict such that I need to delete all the old blt stuff?

thanks for the help ...chris

---

From: Van Jacobson <[email-masked]>
Date: Mon, 18 Mar 96 16:41:58 PST

From the error messages, it looks like you have the wrong
version of tk installed.  The blt-1.9 readme says:

    This version of BLT works with the following tcl/tk versions ONLY:
	tcl 7.4 / tk 4.0 (any patchlevel)
	tcl 7.5a2 / tk4.1a2

All tk4.x versions put their version number on the library
(e.g., libtk4.0.a) so if configure found libtk.a, it &
the stuff in /usr/local/include/tk.h is probably tk3.x
vintage.  You need to upgrade tcl/tk or at least put the
4.x versions in your source tree and point configure at
them when doing the blt & vic builds.

 - Van