Subject: PIM over ATM

From: "Weiping Li" <[email-masked]>
Date: Tue, 16 Dec 1997 19:52:21 +0100

Hi,

we're managing to test the cisco PIM over ATM p-t-mp VCs in our pilot
ATM WAN. The network infrastructure as follows,

	          sdr
		   |
                |------|
		|cisco | <--- PIM peer
		|7000  |
		|------¦
		   |
                |------|
		|cisco |
		|LS1010|
		|------¦
		   |
           -----------------
	   | ATM Cloud	   |
	   | (PNNI)	   | --- other PIM peers
	   |---------------|
            |
         |------|
         |cisco |
	 |LS1010|
	 |------¦
	   |
         |------|
	 |cisco | <--- PIM peer
	 |7000  |
	 |------¦
            |
         receiver

The cisco7000 have IOS 11.2(9) installed. All of the participating ATM
interfaces are UNI or PNNI enabled.

Could you advise me a reference configuration? Should we etablish PIM
sparse tunnels between the cisco 7000s for PIM messages?

Thanks for any pointer.

Weiping Li

---

From: "John M. Zwiebel" <[email-masked]>
Date: Tue, 16 Dec 1997 10:55:09 -0800

Note the map-list includes the NSAP address of this system.  The
ATM switch has to have atm routes configured.

See more in ftp://ftp-eng.cisco.com/ipmulticast.html

interface ATM2/0
 ip address 171.69.214.43 255.255.255.248
 no ip redirects
 no ip proxy-arp
 ip pim sparse-dense-mode
 ip pim multipoint-signalling
 ip ospf network broadcast
 atm nsap-address 47.00918100000000410B0A1981.333333333333.00
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 atm multipoint-signalling
 map-group mpvc
 no shut

map-list mpvc
 ip 171.69.214.41 atm-nsap 47.00918100000000410B0A1981.111111111111.00 broadcast
 ip 171.69.214.42 atm-nsap 47.00918100000000410B0A1981.222222222222.00 broadcast
 ip 171.69.214.43 atm-nsap 47.00918100000000410B0A1981.333333333333.00 broadcast
 ip 171.69.214.44 atm-nsap 47.00918100000000410B0A1981.444444444444.00 broadcast
 ip 171.69.214.45 atm-nsap 47.00918100000000410B0A1981.555555555555.00 broadcast

    Hi,

    	          sdr
    		   |
                    |------|
    		|cisco | <--- PIM peer
    		|7000  |
    		|------=A6
    		   |
                    |------|
    		|cisco |
    		|LS1010|
    		|------=A6
    		   |
               -----------------
    	   | ATM Cloud	   |
    	 |------=A6
    	   |
             |------|
    	 |cisco | <--- PIM peer
    	 |7000  |
    	 |------=A6
                |
             receiver

    
    Thanks for any pointer.

    Weiping Li

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 
	Multimedia Group

---

From: Petri Helenius <[email-masked]>
Date: Tue, 16 Dec 1997 22:31:30 +0200 (EET)

> ATM switch has to have atm routes configured.

It does not if you have only one switch and use ILMI. Additionally
putting the box itself to the map list makes OSPF feel bad (it starts
spitting out syslog messages about hearing itself)

Pete