Subject: Re: [mbone-be] SDR core dump?

From: [email-masked] (Robert Jansen [VUBnet])
Date: Mon, 6 May 1996 12:44:46 +0200

>>Subject says it all. Is it just me, or everyone else?
>>------
>
>Yep,... same here to. the sdr on vnet2.vub.ac.be choked.
>version 2.2a6
>Robert

SDR just dumped core  again !! What's going on here ?
Running SunOS 4.1.3U1b multicast 3.5 kernel from parcftp and mrouted 3.8.2

Robert

--------------------------
Brussels University
Pleinlaan 2
Computer Center VUB/ULB (VUBnet)
Ing. Robert Jansen
B-1050 Brussels
Belgium (Europe)

email: [email-masked]
Tel:  +32-2-650.37.29
Secr: +32-2-650.37.38
Fax:  +32-2-650.37.40
--------------------------

---

From: Michel Colin <[email-masked]>
Date: Mon, 6 May 1996 13:27:46 +0200

> SDR just dumped core  again !! What's going on here ?

SDR has probably received a badly formatted announcement and can't handle
it even into the 'error' branch of the sd_listen function

Michel
===============================================================================
 Michel Colin                                           Tel. +32-2-650 57 03
                                                        Fax: +32-2-629 38 16
 Universite Libre de Bruxelles
 Faculte des Sciences                            
 Service Telematique et Communication	       
 CP 230, Boulevard du triomphe
 B-1050 Bruxelles          	        
 BELGIUM                              

RFC822: [email-masked]
X.400 : C=be;ADMD=rtt;PRMD=iihe;O=helios;S=colin;
X.500 : @c=be@o=Universite Libre de Bruxelles@ou=Faculte des Sciences@ou=Service        Telematique et Communication@cn=Michel Colin

-------------------------------------------------------------------------------

---

From: Graeme Wood <[email-masked]>
Date: Mon, 6 May 1996 11:55:16 +0100 (BST)

> Running SunOS 4.1.3U1b multicast 3.5 kernel from parcftp and mrouted 3.8.2

It is happening repeatedly because there is something somewhere sending
out a session announcement which sdr cannot parse.  I haven't yet figured
out where it is coming from.

=============================================================================
Graeme Wood                                 Email: [email-masked]
Unix Systems Support                        Phone: +44 131 650 5003
The University of Edinburgh                 Fax:   +44 131 650 6552
-----------------------------------------------------------------------------
Scottish MICE National Support Centre       Email: [email-masked]
for your multimedia conferencing support    WWW:   http://mice.ed.ac.uk/mice/
=============================================================================

---

From: Mark Handley <[email-masked]>
Date: Mon, 06 May 96 14:58:36 +0100

>it even into the 'error' branch of the sd_listen function

There's an sdr 2.2a7 now on ftp://cs.ucl.ac.uk/mice/sdr/

As the offending announcement has now stopped I can't be certain this
will cure the problem, but I have fixed a broken bit of the parser
which is the likely culprit.  Thanks to Michel Colin, Graeme Wood and
Yozo Toda for sending me trace information to help diagnose the
problem.

Mark

Recent changes are:

2.2a7 4-6 May 96 mhandley
        Some parser checks that were missing added.
          - should prevent crashes with broken MCM sd announcements.
        Calendar interface redesigned to use pop-up fewer windows.
        Calendar now handles repeat times properly.
        Incoming invitations now force the popup of the invitation window
          on window managers like twm which nornally delay window placement.
        Minor changes to prevent sdr exiting in certain error conditions.
        long phone numbers bug fixed.
2.2a6 27 Apr 96 mhandley
        TkPlatformInit redefined to fix tk4.1b3 stupidity trying to
          explicitly load $TK_LIBRARY/tk.tcl
2.2a5 15-26 Apr 96 mhandley
        Basic SIP implementation added.
          allows users to invite other users to join advertised sessons
        Tcl SDP parser added for SIP messages.
        Sensible error message now produced when DISPLAY is incorrect.
        better support for monochrome displays added
        plugin parser made more robust to odd spaces
        new session window made shorter and fatter
        moved cache files from .sdr dir to .sdr/cache dir.
        youremail variable added to plugin mechanism
        bug in plugin attr parser fixed (was preventing wb session launch)
        check added so sdr ignores announcements with later versions than 0
        repeat times now displayed properly in session display window
        window placement code improved - windows should get moved less
        added code to parse mailto URLs (but not to handle them yet)
        bug displaying sessions with no media fixed.
        bugs in recording startup fixed by Bill Fenner

---

From: "Amancio Hasty Jr." <[email-masked]>
Date: Mon, 06 May 1996 13:32:07 -0700

Any clues as to when are the sources for sdr going to be released?

	Amancio