Subject: Multicast routes

From: Dimitris Zisiadis <[email-masked]>
Date: Mon, 01 Dec 1997 18:19:08 +0200

Hello all,

we would like to have the following configuration:

                                              ___________
                                             /           |
  Mbone                         Cisco       /            |
  SUN server  <--- tunnel -->   7507  <-->  | PIM cloud  |   
  mrouted                       router      \            |
                                  _          \___________|
                                  |
                             PIM  |--- Real Audio Server
                         enabled  |
                                  -

 The Mbone server sends all the mutlicast routes to the Cisco via the
DVMRP tunnel, which will be used for outgoing traffic only (Cisco->SUN).
 The Cisco filters out the content from the SUN (accept filter IN)
and redistributes the information only to the Real Audio server 
(access filter OUT)
in order for the server to determine which addresses to use (it is
necessary as far as i understood in order not to use some already used 
multicast address for emission).
The multicast server will broadcasts all the channels into the PIM
cloud and to the tunnel also.
 How will the multicast address space will be configured at the server?

 Is this scheme right, i.e. does it achieve the required
functionality?

---

From: Joseph Porrovecchio <[email-masked]>
Date: Mon, 1 Dec 1997 15:47:17 -0500

tekanis Dimitris,

> we would like to have the following configuration:

This not the case. You do not need to assign multicast addresses.

A DVMRP tunnel from the MBONE to your SUN then your config will look 
soemthinglike this:

interface Tunnel1
 description tunnel {whatever}
 ip unnumbered loopback
 ip pim dense-mode
 ip multicast ttl-threshold 32 
 ip dvmrp metric 1
 ip dvmrp unicast-routing
 tunnel source  {mbone feed source}
 tunnel destination {SUN SEVER}
 tunnel mode dvmrp

My questions to you Dimitris are the following:

1. Where are you getting your mbone feed from?
2. What kind of tunnel are you setting  from the CISCO to the real-audio 
server (DVMRP?)
3. Do you want to limit bandwith on mbone traffic?

ciao,

-- 
Joseph Porrovecchio 
Network Support Specialist
------
External Networking Facilities Management  	
4 Bancroft Ave. Rm. 101			         
Toronto, Ontario M5S 1C1		   
Voice: 416.978.0188  Fax: 416.978.6620	   
http://enfm.utcc.utoronto.ca/~joseph / N.O.C.: 1.800.268.6324

---

From: Dimitris Zisiadis <[email-masked]>
Date: Tue, 02 Dec 1997 11:19:15 +0200

In message <[email-masked]>, 
>tekanis Dimitris,

 Hi,

>This not the case. You do not need to assign multicast addresses.

 The Real audio server needs to know the multicast address range
to use when emitting channels. 

>A DVMRP tunnel from the MBONE to your SUN then your config will look 

 The MBONE server is the SUN server and our server is the
Cisco 7xxx.

>1. Where are you getting your mbone feed from?

 We want to enable it on our link to MCI, so the SUN server mentioned above
is MCI's closest MBone server.

>2. What kind of tunnel are you setting  from the CISCO to the real-audio 

 Isn't it ok if we use pim on that ethernet?
Do we need to have a tunnel?
If this is the case we can built a DVMRP tunnel..

>3. Do you want to limit bandwith on mbone traffic?

 YES, ABSOLUTELY,

we want to filter ALL the incoming traffic
(but i think we still want to know the mroute
announcements in order to know what addresses are 
free for our RealAudio server, right?).

Thanks

Dimitris

---

From: "John M. Zwiebel" <[email-masked]>
Date: Tue, 02 Dec 1997 01:42:14 -0800

yes, pick one that isn't being used.  All MBONE groups should be announced
using sdr.  You should also announce any group that you plan to send to
via sdr.

You may also configure "ip sdr listen" on one interface on the cisco router.

    [no] ip sdr listen 
        Enables/disables Session Directory Protocol V2 (sdr) from accepting 
        packets on the interface. The router joins group 224.2.127.254 on the 
        interface. [11.1]