Subject: problem with mbone sessions

From: [email-masked] (miguel cruz)
Date: Mon, 09 Jun 1997 16:21:49 -0500

Hello all,
Im currently connected to the MBONE by an 8 Mbps (4xE1)link using MCI.
Im just a viewer of MBONE sessions and I have precept software for
evaluation. The question is how can I do to increase the performace of
the sessions ? because in the most af that the audio goes faster than
the video (there are no sychrinization between them). Do I need to
increase the bandwith? I have a DVMRP tunnel and cisco routers.
All your suggestions are wellcome...

-- 
Miguel A. Cruz Reyes
Avantel S.A.
Data Services Engineering
Vnet       273 5832
Ph     (8) 153 5832
Fax    (8) 153 5808

---

From: "Jeff Young" <[email-masked]>
Date: Tue, 10 Jun 1997 16:13:28 -0400

synch of audio and video takes place at the application layer.
i can check to see if there are any rate-limits on your tunnel
if you'll tell me the tunnel endpoint, but other than that there
is no way for me to alter the performance of multicast.

if you are having performance problems, especially in the area
of video decode, my first suggestion would be to try receiving the
multicast on a faster machine.  video decode is hard to do and
you probably need to throw all of the cpu speed and memory you
can muster at the application.

Jeff Young
[email-masked]

> Return-Path: [email-masked] 
> Received: from zephyr.isi.edu (zephyr.isi.edu [128.9.160.160])
> 	by postoffice.Reston.mci.net (8.8.5/8.8.5) with SMTP id RAA10911;
> 	Mon, 9 Jun 1997 17:33:24 -0400 (EDT)
> Received: by zephyr.isi.edu (5.65c/5.61+local-26)
> 	id <AA29826>; Mon, 9 Jun 1997 14:24:06 -0700
> Received: from venera.isi.edu by zephyr.isi.edu (5.65c/5.61+local-26)
> 	id <AA29820>; Mon, 9 Jun 1997 14:24:04 -0700
> Received: from zephyr.isi.edu by venera.isi.edu (5.65c/5.61+local-29)
> 	id <AA04674>; Mon, 9 Jun 1997 14:24:03 -0700
> Received: by zephyr.isi.edu (5.65c/5.61+local-26)
> 	id <AA29808>; Mon, 9 Jun 1997 14:23:39 -0700
> Received: from venera.isi.edu by zephyr.isi.edu (5.65c/5.61+local-26)
> 	id <AA29802>; Mon, 9 Jun 1997 14:23:35 -0700
> Received: from web1.avantel.net.mx by venera.isi.edu (5.65c/5.61+local-29)
> 	id <AA04659>; Mon, 9 Jun 1997 14:23:33 -0700
> Received: from mcruz.avantel.net.mx ([200.33.231.30])
>           by web1.avantel.net.mx (Netscape Mail Server v2.0) with ESMTP
>           id AAA24860 for <[email-masked]>; Mon, 9 Jun 1997 16:23:16 -0500
> Message-Id: <[email-masked]>
> Date: Mon, 09 Jun 1997 16:21:49 -0500
> From: [email-masked] (miguel cruz)
> Organization: Avantel S.A.
> X-Mailer: Mozilla 4.0b4 [en] (Win95; I)
> Mime-Version: 1.0
> To: mbone_questions <[email-masked]>
> Subject: problem with mbone sessions
> X-Priority: 3 (Normal)
> Content-Transfer-Encoding: 7bit
> Sender: [email-masked]
> Precedence: bulk
> Content-Type: text/plain; charset=us-ascii
> Content-Length: 583
> 
> Hello all,

---

From: Mark Handley <[email-masked]>
Date: Tue, 10 Jun 1997 18:01:19 -0400

> All your suggestions are wellcome...

It seems there are several possible causes for this:

- synchronisation turned off in your software
- problems with the Precept software's synchronisation code
- problems with packet loss causing delayed decoding of some frames
  (seems unlikely)
- audio and video sent from different machines
- audio and video sent from software with incompatible RTP CNAMEs

I don't know Precept's software well enough to know what the cause is
likely to be, but a network problem is the least likely cause.  It's
quite likely that the problem is with the site making the
transmission.

Mark

---

From: Stephen Casner <[email-masked]>
Date: Tue, 10 Jun 1997 16:44:58 -0700 ()

Miguel Cruz asked:

> > The question is how can I do to increase the performace of
> > the video (there are no sychrinization between them).

I had already responded privately that this question would be more
appropriately asked of Precept's support team.  However, I have a

> - synchronisation turned off in your software

Yes, this is a switch setting, but the default is "on".

> - audio and video sent from software with incompatible RTP CNAMEs

These factors will not prevent synchronization so long as the NTP
timestamps in the audio and video streams come from synchronized
clocks.  The CNAME is used as a hint in matching up audio and video
streams, but is not required to be the same when there is only one of
each being received (as is the case in many MBone transmissions).

One other possible cause we have seen is broken timestamps when using
vat older than 4.0a9 or vic older than 2.7a39 as the transmitter.

							-- Steve

---

From: Amancio Hasty <[email-masked]>
Date: Tue, 10 Jun 1997 18:26:59 -0700

Try to get a unix box or run unix on your PC. video and audio decoding is
kind of hard right now on Win95 and Windows NT. The situation 
should get better with the next release of Win95 and Windows NT.

You probably will need a P166 and a decent graphics card such as a
Matrox Millenium . Find out if the author of the software
provides MMX support because if they do and you can get your
hands on a Pentium or Pentium II that can significantly increase
your performance . Also I would shop around for other mbone 
clients mostly  to see what features or performance
other clients may have. 

	Regards,
	Amancio