Subject: mrouted 3.8 for solaris 2.4 x86

From: "Mahesh Ramachandran" <[email-masked]>
Date: Sun, 18 Feb 1996 21:28:17 -0500 (EST)

I thought I had seen this mentioned on this list before, but I couldn't find
it ... certainly not on playground.sun.com. anyone know where i can get
mrouted 3.8 binaries for sol x86 from? are there any other patches
needed to get it running?

thx
-rr

---

From: Yozo Toda (TELEPHONE +81-43-290-3539) <[email-masked]>
Date: Mon, 19 Feb 1996 11:46:57 +0900

> needed to get it running?

digging my mail box, I found the following two:

%%%% message 1 %%%%

From: "Jonathan Knight"  <[email-masked]>
Message-Id: <[email-masked]>
Subject: Re: Solaris x86 and multicasting...
To: [email-masked] (Mark Abene)
Date: Thu, 4 Jan 1996 13:24:26 +0000 (GMT)
Cc: [email-masked]
In-Reply-To: <[email-masked]> from "Mark Abene" at Jan 4, 96 07:38:37 am
X-Mailer: ELM [version 2.4 PL21]
Content-Type: text
Content-Length: 675

> In other words, does anyone know when Sun plans on adding MODERN multicasting 
> support for Solaris x86?

The ftp area for the latest multicast that the Sun engineers are
playing with is

 ftp://playground.sun.com/pub/multicast

It's mrouted 3.8 for Solaris 2.4 at the moment.

They give an email address of [email-masked] for questions
and comments.

-- 
  ______    Internet  :[email-masked]   Jonathan Knight,
    /       UUCP      :...!uknet!kl-cs!jonathan  Department of Computer Science
   / _   __ Telephone : +44 1782 583437          University of Keele, Keele,
(_/ (_) / / Fax       : +44 1782 713082          Staffordshire.  ST5 5BG.  U.K.

%%%% message 2 %%%%

From: Mark Abene <[email-masked]>
Message-Id: <[email-masked]>
Subject: Re: Solaris x86 and multicasting...
To: [email-masked] (Jonathan Knight)
Date: Thu, 4 Jan 1996 08:30:30 -0500 (EST)
Cc: [email-masked]
In-Reply-To: <[email-masked]> from "Jonathan Knight" at Jan 4, 96 01:24:26 pm
X-Mailer: ELM [version 2.4 PL23]
Mime-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Type: text/plain; charset=US-ASCII
Content-Length: 298

> 
> The ftp area for the latest multicast that the Sun engineers are
> playing with is
> 
>  ftp://playground.sun.com/pub/multicast
> 
> It's mrouted 3.8 for Solaris 2.4 at the moment.
> 
...

Thanks, I was already aware.  But you won't find anything in there for
Solaris x86, only SPARC.

-Mark

%%%% messages %%%%

-- yozo.

---

From: Mark Abene <[email-masked]>
Date: Mon, 19 Feb 1996 04:48:16 -0500 (EST)

> needed to get it running?

Yes, and yes.  It was temporarily pulled due to some minor problems, 
potentially with the kernel drivers, which I'm working with Sun to resolve.
I did the necessary patches to mrouted (and related tools) myself, which
were incorporated into the distribution.  The changes were minor, and 
consisted of host to network byte-ordering fixes.
After we resolve the driver problem, it will likely reappear in /pub/multicast
on playground.sun.com.

-Mark