Subject: Connected sites?

From: [email-masked] (Kevin C. Almeroth)
Date: Mon, 12 Feb 1996 10:40:12 -0500 (EST)

Does anyone have any idea approximately how many sites around the world
are part of the MBone?

-Kevin Almeroth

---

From: Piete Brooks <[email-masked]>
Date: Mon, 12 Feb 1996 16:44:37 +0000

> Does anyone have any idea approximately how many sites around the world

Define a "site" ...

You can get a list of the routers reachable from my site by looking at stuff 
near
http://www.cl.cam.ac.uk/mbone/#Mrouted or you can HACK is using something like

	lynx -dump http://www.cl.cam.ac.uk/cgi-bin/mrinfo?map+-h | wc

to get the number or routers (1728). Given a definition of a "site", you could 
then use perl / awk / sed / ... to do more selective counting.

---

From: "Charles Stephens" <[email-masked]>
Date: Mon, 12 Feb 1996 12:44:07 -0500

On Feb 12,  4:44pm, Piete Brooks ([email-masked]) wrote:
> Subject: Re: Connected sites?
>-- End of excerpt from Piete Brooks

Under solaris 2.x, you can examine this type of information with 'netstat -M'.

cfs

-- 
Charles F. Stephens   + <URL:http://www.mathcs.emory.edu/~cfs>
Emory University      + [email-masked]
Dept. of Math & CS    + Copyright (c) 1996 Charles Fredrick Stephens
Atlanta, Georgia, USA + All rights reserved.

It is nearly year 00, do you know what your computers are doing?
"Now with the D4-dopamine Receptor Personality Gene!"

---

From: "Amancio Hasty Jr." <[email-masked]>
Date: Mon, 12 Feb 1996 10:54:35 -0800

>>> "Charles Stephens" said:

On freebsd we can do  "netstat -g", I just count 99 is that right?

	Tnks
	Amancio

---

From: Magnus <[email-masked]>
Date: Mon, 12 Feb 1996 20:05:34 +0100

> On freebsd we can do  "netstat -g", I just count 99 is that right?

Well, Piete's tool knows about well over 1600 routers in the world, more then
400 of them in Europe. I use his tool a lot.

Magnus

---

From: Naohiro Shichijo <[email-masked]>
Date: Tue, 13 Feb 1996 04:05:42 +0900

From: "Charles Stephens" <[email-masked]>
Subject: Re: Connected sites?
Date: Mon, 12 Feb 1996 12:44:07 -0500
Message-ID: <[email-masked]>

cfs> > to get the number or routers (1728). Given a definition of a "site", you
cfs> could
cfs> > then use perl / awk / sed / ... to do more selective counting.
cfs> >
cfs> Under solaris 2.x, you can examine this type of information with 'netstat -M'.

netstat dumps only the entries on multicast routing table.
in order to count all mrouters ( possibly there are routers' which
never generated packets, so do not appear on the routing table ),
you could do map-mbone. the information on the web suggested by Piete
is essentially same as the output of map-mbone. ( more comprehensive!)

maybe... we can count mrouters, but cannot count MBONE-connect hosts. :(

Naohiro Shichijo
Univ. of Tokyo

---

From: Bill Fenner <[email-masked]>
Date: Mon, 12 Feb 1996 11:56:13 PST

>On freebsd we can do  "netstat -g", I just count 99 is that right?

Under 3.x based kernels, netstat -M (or netstat -g for 4.4) gives you only the 
active sources.  Under 2.x based kernels, netstat -M gives you the full 
routing table (the same info you can get from kill -USR1 `cat 
/etc/mrouted.pid` and reading /usr/tmp/mrouted.dump).  I suppose Charles meant 
"Under solaris 2.x without the 3.x multicast patches".

  Bill

---

From: Magnus <[email-masked]>
Date: Mon, 12 Feb 1996 21:11:50 +0100

> "Under solaris 2.x without the 3.x multicast patches".

Recall that the number of entires in the routing table just gives you a hunch
of how many networks that is connected to Mbone where as Piete's tool gives a
fairly good view of the routers... many routers do have multiple interfaces
(almost by definition :)

Magnus

---

From: "Charles Stephens" <[email-masked]>
Date: Mon, 12 Feb 1996 15:39:58 -0500

On Feb 12, 11:56am, Bill Fenner ([email-masked]) wrote:
> > > Under solaris 2.x, you can examine this type of information with 'netstat
-M
> >     '.
>-- End of excerpt from Bill Fenner

That is what I was aiming for Bill.  2.5 doesn't have the magic "patches" yet.
 Sun is slow to get that off the ground.

cfs

---

From: [email-masked] (Andrew Patrick)
Date: Fri, 14 Jun 96 17:30:52 EDT

On Jun 14,  4:54pm, Bill Fenner wrote:
} Subject: Re: bbnplanet and mci, big packet loss rate...
| The left-hand column of numbers is not always accurate, mostly due to
| what appear to be implementation bugs.  The right-hand numbers are
| usually more believable.  Try sourcing some data and try the mtrace
| again.
| 
|   Bill
| 
}-- End of excerpt from Bill Fenner

I am seeing a similar pattern of loss today.  Here is a trace of some
audio data from CBC in Toronto:

  Source        Response Dest    Packet Statistics For     Only For Traffic
159.33.1.50     131.136.234.172  All Multicast Traffic     From 159.33.1.50
     |       __/  rtt  175 ms    Lost/Sent = Pct  Rate       To 224.2.66.45
     v      /     hop  235 s     ---------------------     --------------------
159.33.1.50     www.radio.cbc.ca 
     |     ^      ttl   32        0/1    = --%   0 pps     0/1    = --%   0 pps
     v     |      hop  154 s    414/4404 =  9%  41 pps   414/4404 =  9%  41 pps
205.207.90.6    TorConc6.ftn.net 
     |     ^      ttl   33        0/3    = --%   0 pps     0/1    = --%   0 pps
     v     |      hop  199 s     -2/4003 =  0%  38 pps    -2/3990 =  0%  38 pps
204.70.98.45    dec3800-1-fddi-1.NorthRoyalton.mci.net 
     |     ^      ttl   34       -1/22   = -4%   0 pps     0/1    = --%   0 pps
     v     |      hop -148 s      0/4284 =  0%   0 pps     0/3992 =  0%   0 pps
204.70.64.29    dec3800-1-fddi-0.WestOrange.mci.net 
     |     ^      ttl   35        6/26   = 23%   0 pps     0/1    = --%   0 pps
     v     |      hop -179 s    671/4319 = 16%   1 pps   610/3992 = 15%   1 pps
198.67.134.250  ?              
     |     ^      ttl   36       -1/65   = -1%   6 pps     0/1    = --%   0 pps
     v     |      hop  -26 s     -4/4098 =  0%  39 pps    -3/3382 =  0%  32 pps
199.94.207.2    cambridge1-mbone1.bbnplanet.net 
     |     ^      ttl   37        0/80   =  0%   8 pps     0/1    = --%   0 pps
     v     |      hop   10 ms    -1/4256 =  0%  40 pps    -1/3385 =  0%  32 pps
     ...
     ...
     ...
     
As far as I can tell, the 198.67.134.250 machine is something owned
by Sprint.  This 15% loss has persisted for 2 days now.  The 9% loss
closer to cbc.ca is transient, but also a local concern.

-- 
           Andrew Patrick, Ph.D. <[email-masked]>
               Networks Services & Interfaces Laboratory
                     Communications Research Centre
                       http://debra.dgbt.doc.ca/

---

From: "Juan A. Garcia. CSIC RedIRIS" <[email-masked]>
Date: Thu, 12 Mar 1998 18:17:54 +0100

Hi all,

 We've a SGI O2 (IP32, IRIX 6.3) running as a boundary mrouter (mrouted3.9b3)
for our network.

127.0.0.1 (localhost) [DVMRPv3 compliant]:
  130.206.1.45 -> 0.0.0.0 (local) [1/1/querier/leaf]
  130.206.1.45 -> 195.206.64.170 (ams-mr.att-unisource.net) [1/48/tunnel]
  130.206.1.45 -> 193.146.0.2 (indy.rediris.es) [1/16/tunnel]
  .... other internal tunnels.

 When we joined any multicast group in the mrouter (130.206.1.45), it
constructs the apropiate forwarding table, and we see the multicast
traffic flow through this network (130.206.1.0/24). Although, when
we leave this multicast group on the mrouter, the primary interface
is removed from the multicast forwarding table, and no multicast 
datagrams are sent to the 130.206.1.0 network, regardless of the
presence of other members in this multicast group.

Could anybody help us?

Many thanks in advance.
Regards,

-- 
Juan A. Garcia                [email-masked]
RedIRIS/CSIC SPAIN            Voice: (+34 1) 585.5145
Infosystems Management

---

From: Bill Fenner <[email-masked]>
Date: Thu, 12 Mar 1998 11:12:35 PST

Are the other group members on the local 130.206.1.0/24 subnet?  If
so, could you run "mrouted -d igmp,members" to see if you can tell why
the O2 isn't noticing the other group members?

If the other group members are elsewhere, you should
kill -USR2 `cat /etc/mrouted.pid` and look at the /usr/tmp/mrouted.cache
files and see if the main mrouter thinks that the other mrouter sent a
prune when it didn't.

  Bill

---

From: "Juan A. Garcia. CSIC RedIRIS" <[email-masked]>
Date: Thu, 12 Mar 1998 21:50:22 +0100

Bill Fenner ([email-masked]) decia hace un rato:
> Subject: Re: mutlicast forwarding problems on IRIX ??
> Are the other group members on the local 130.206.1.0/24 subnet? 

Yes they are.

> If so, could you run "mrouted -d igmp,members" to see if you can tell why

Only membership (IGMPv2) reports from these hosts reach the O2, if
any other program, that joins this group, is running in the O2 (a 
simple tcpdump, or a rtpqual to the same group and port)

However the leave messages are reaching the O2 :-/ If I run a tcpdump
in any host in that subnet (130.206.1/24), I see the query messages from
the O2 (the mrouter), and the reply from other hosts (IGMPv2 nreport)
that joins that multicast group. But from the O2 point of view, only
leave messages are received.

This is an example of our internal network topology:

    MBone
  _____|_____________________________________________
 |   __|__               ______                      |
 |  | O2  |             |host A|                     |
 |  |_____|             |______|   130.206.1/24 VLAN |
 |____|____________________|_________________________|
      |                    |
      | FastETH            | FastETH
      |                    |
    __|____________________|________________
   | CISCO Catalyst 5000 ETH/fastETH switch |
   |________________________________________|

In this situation:

  - O2 queries reach the host A
  - Host A leave messages reach the O2
 But:
  - Host A nreports DO NOT reach the O2

Do you (or does anybody) know if there is any bug in the CISCO switch
that could cause filtering upstream IGMP membership reports? 
We've a Catalyst 5000 whith software release 2.3, and the CISCO CGMP 
(Cisco Group Management Protocol) is disabled. 

Thanks for your reply anyway.
Regards,

---

From: "Craig M. Votava" <[email-masked]>
Date: Thu, 12 Mar 1998 15:42:03 -0600

Juan-

This is exactly the same problem that I asked
for help on a while ago. I also have an O2 with
IRIX 6.3, but was running an older version of
mrouted. It was suggested to me to upgrade to
mrouted3.9b3, which I did, but still see the
same problem. I haven't looked into this further
since then.

I'm suspicious of our upstream router, which is
a CISCO router. Is that what your upstream router
is too?

If you figure this out, please let me know. I'll
keep you posted about anything I uncover.

Thanks

-Craig

-- 

	()_()	Craig Votava
	 (_)	Lucent Technologies
		[email-masked]

---

From: "Juan A. Garcia. CSIC RedIRIS" <[email-masked]>
Date: Thu, 12 Mar 1998 23:11:59 +0100

> a CISCO router. Is that what your upstream router
Yes, but we send all (except internal) multicast traffic through
DVMRP tunnels, so the presence of CISCO unicast router has no 
effect on this.

In a later mail, I've send a simplified picture of our internal 
network topology. I receive a reply by Bill Fenner, that pointed
us about a posible problem in our internal CISCO Catalyst switch.
Definitevely, I think that it's the problem, because our 
software version maybe don't understand IGMPv2 messages. In this
case, the CISCO-switch could forward any IGMPv2 query (it was the
same message type that IGMPv1), but fails to forward IGMPv2 membership
reports because they have a new version type (0x16).

Regards,

---

From: "Thomas M. Kendall <tkendall>" <[email-masked]>
Date: Thu, 12 Mar 1998 20:13:58 -0500 (EST)

Craig,

We at the Army Research Laboratory also had this difficulty with
and O2 running mrouted.  We moved the tunnel endpoint to
an Indy running IRIX 6.2 and the problem disappeared.  I opened
a case with SGI support, but have no resolution to date.

Our upstream multicast router is a SPARC 20 running mrouted 3.9.

Tom

>keep you posted about anything I uncover.
-------------------------------------------------------------------------------
Thomas M. Kendall		U. S. Army Research Laboratory
410-278-9195			Corporate Information and Computing Center
410-278-9199 (FAX)		Attn: AMSRL-CI-HC
[email-masked]		Aberdeen Proving Ground, MD  21005-5067
-------------------------------------------------------------------------------

---

From: "Juan A. Garcia. CSIC RedIRIS" <[email-masked]>
Date: Fri, 13 Mar 1998 20:50:30 +0100

> Our upstream multicast router is a SPARC 20 running mrouted 3.9.

 Yes, maybe I must move the tunnels to another (non SGI) 
workstation. :-/ If you receive some input form SGI about this,
please send me a e-mail. Thanks in advance.

 In a previous message I was talking about the posibility of CISCO 
Catalyst problems. Finally the problem was NOT de Catalyst. I made 
the following experience:

  To the CISCO switch
       ____|_____
      | Eth. HUB |
      |__________|
         |    |________________
        _|__               ____|___
       | O2 |             | Host A |
       |____|             |________|

 And the problem remains :-( The membership reports,sent by Host A, are 
not seen in the O2. Well, if I run a tcpdump in O2, I see the reports, 
but the mrouted (running in debug mode) don't see them. I've checked 
this with mrouted versions 3.8, 3.9b2 and 3.9b3.

Regards,