Subject: Re: packet loss between mbone2.UU.Net & SanFrancisco.mci.net

From: Dave Hayes <[email-masked]>
Date: Sun, 16 Feb 1997 13:45:35 -0800

Peter Berger writes:
> At NANOG, at least one Large Provider Who Shall Remain Nameless
> indicated in conversation that they had tried using native multicast
> on Cisco IOS (I believe version 11.2, though I wouldn't swear to it)
> and encountered performance degradation in (unicast) packet forwarding
> sufficient to convince them to immediately revert to tunneling.

Gee, I'd like to hear from people who do NOT work for Cisco (sorry
guys), who are using Cisco's version of mrouting (PIM?), AND who are
getting a tunnel to the MBONE through a UNIX mrouted daemon. If any of
these people exist, that's a datapoint. Their collective opinions are
another. I'd sure like to see both these points.

> That's all I meant.  And I am -certainly- not implying that there is
> any other router vendor that I am aware of that does native multicast
> better. 

Er...Is there another vendor who even does native multicast?
------
Dave Hayes - Altadena CA, USA - [email-masked] 
Freedom Knight of Usenet - http://www.jetcafe.org/~dave/usenet

    "They that can give up essential liberty to obtain a little temporary 
    safety deserve neither liberty nor safety."        -Benjamin Franklin

---

From: Tom Maufer <[email-masked]>
Date: Sun, 16 Feb 1997 15:52:58 -0700

>Er...Is there another vendor who even does native multicast?

Dave--

3Com NETBuilder family routers can run DVMRP over
LAN, WAN, and tunnel interfaces.  Also, MOSPF is
supported.  3Com LANPlex switch/routers can route
over LAN (FDDI, ATM, Ethernet, Fast Ethernet) using
DVMRP.  Plus they do IGMP snooping.

I know that Bay Networks routers can route using
DVMRP over tunnels and over LANs.  I believe that
Alantec/Fore switches can do multicast (DVMRP) as
well.  I am pretty sure that Ipsilon also does
multicast.  I bet there are others.

Cheers,
Tom

---

From: [email-masked] (Bill Manning)
Date: Sun, 16 Feb 1997 17:35:25 -0800 (PST)

> another. I'd sure like to see both these points.

Hi Dave,
	I don't work for cisco, I run PIM and DVMRP.  Do you really want
	my "collective" opinions? :)

-- 
--bill

---

From: "Dorian R. Kim" <[email-masked]>
Date: Sun, 16 Feb 1997 22:29:26 -0500 (EST)

> another. I'd sure like to see both these points.

Sure, we exist alright. We have 2 DVMRP tunnels from MCI, and internally run
PIM sparse-dense mode native. We are also doing PIM with DIGEX native on our
private interconnect. 

-dorian

---

From: Mark Boolootian <[email-masked]>
Date: Sun, 16 Feb 1997 21:03:52 -0800 (PST)

UCSC is fed via a DVMRP tunnel and we run PIM dense-mode internal to the
campus.  We did have a bad experience which sounds similar to what
Peter Berger mentioned in his note.

What we saw was cpu utilization ramping up to near 100% for brief periods
of time, making the router fairly useless for anything other than warming
the room.  We weren't seeing anything unusual in terms of the amount of
unicast or multicast traffic.  We found that everything got better when we
disabled the multicast routing.

This was in an early version of 11.0 or 11.1 (sorry, can't recall which).
We moved mrouting into a dedicated router and haven't seen a problem since.

mb

---

From: Petri Helenius <[email-masked]>
Date: Mon, 17 Feb 1997 08:51:06 +0200 (EET)

> another. I'd sure like to see both these points.

Seen that, done that at various occasions (from single router configs
to interconnecting clouds up to 50 routers). I can't say that the road
has been without bumps along the way but with the current software
(both 11.1 and 11.2 releases) it runs smoothly, taking into account
the limitations in the router architechture itself.
Pete

---

From: [email-masked] (Charles Spurgeon)
Date: Mon, 17 Feb 1997 09:20:05 -0600 (CST)

>another. I'd sure like to see both these points.

UT Austin has been connected to the Mbone via an mrouted tunnel (Sun)
into a Cisco for a while now.  So far we've been using PIM dense mode
on campus, planning to go to sparse mode.

It has been pretty stable, though one needs to run recent code in the
routers with mcast enabled.  

-Charles

Charles E. Spurgeon
[email-masked]
512.475.9265
--------------------------
Everything has a boolean value, if you stand far enough away from it.
-- Galena Alyson Canada 
--------------------------

---

From: Jim Bogard <[email-masked]>
Date: Mon, 17 Feb 1997 13:32:03 -0500 (EST)

Ditto.  Some of the earlier releases had some problems, but things seem 
pretty ok now.  

J-.
----
Jim Bogard  JHU/APL BIX Group             "This is my banjo.  There are many
Backbone Network Engineer                   like it, but this one is mine."

---

From: "John F. McGowan, Ph.D." <[email-masked]>
Date: Mon, 17 Feb 1997 10:03:20 -0800

>PIM sparse-dense mode native. We are also doing PIM with DIGEX native on our

Dear Dorian R. Kim,

     Are you able to run successfully with PIM *sparse* mode as well as
dense mode at your site?  If so, were there any startup problems, odd
quirks?

                                 Sincerely,

                                 John McGowan

----------------------------------------------------------------------------
John F. McGowan, Ph.D.
Software Engineer
Desktop Video/Advanced Applications
Sterling Software/NASA Ames Research Center

E-Mail: [email-masked]
Voice: (415) 604-0143

Desktop Video Expert Center: http://zeus.arc.nasa.gov/
Advanced Applications: http://zeus.arc.nasa.gov/adv_apps.html
----------------------------------------------------------------------------

---

From: "Dorian R. Kim" <[email-masked]>
Date: Mon, 17 Feb 1997 14:21:26 -0500 (EST)

> dense mode at your site?  If so, were there any startup problems, odd

Well, actually, I'm running a new thing sparse-dense mode, not sparse mode and
dense mode. This effectively makes most groups into sparse mode groups, and
then there are some dense mode clouds we touch on. The set up seems to work.
RP selection is bootstrapped by RP mapping agents and auto-RP on the end
station/gateways.

-dorian

---

From: Amancio Hasty <[email-masked]>
Date: Mon, 17 Feb 1997 11:44:41 -0800

> routers with mcast enabled.  

What is recent code ? 8)

It will be nice if this information was readily available for instance
if a major ISP is going to provide a tunnel to a cisco router it can 
require that the targetted router to have the  proper rev level of the 
cisco software . Simple things like that can make life a lot easier
in  the mbone.

	Regards,
	Amancio

---

From: Petri Helenius <[email-masked]>
Date: Mon, 17 Feb 1997 22:01:54 +0200 (EET)

> > routers with mcast enabled.  

Depending on the phase of the moon and other scientific data, anything
from a couple of hours to a couple of months old. I'd also recommend
to use 11.1 release since it currently provides the best functionality
/ stability equation (at least for the issues I care about).

The word _CURRENT_ should be emphasized. The above paragraph does not
mean that you should run 11.1 until year 2003.
 > cisco software . Simple things like that can make life a lot easier
I think it should be reasonable to require whatever is the current
(or close) at the time of the tunnel activation.

Pete

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 17 Feb 1997 17:23:06 -0800

>> / stability equation (at least for the issues I care about).

    Please don't forget your an EFT site so you have decided to go with
    the pain :-)

    The latest 11.1 is fairly stable. That is 11.1(9).

Dino

---

From: Petri Helenius <[email-masked]>
Date: Mon, 17 Feb 1997 22:01:54 +0200 (EET)

Pete

---

From: Petri Helenius <[email-masked]>
Date: Tue, 18 Feb 1997 07:41:51 +0200 (EET)

>     Please don't forget your an EFT site so you have decided to go with
I'm not complaining, I'm just trying to communicate the reality of
released code out to people that are not playing with it before release.

 >     The latest 11.1 is fairly stable. That is 11.1(9).
Yes, and 11.1(8) was not, that's what I'm saying. It takes precision
to be successful.

Pete

---

From: Phil Pishioneri <[email-masked]>
Date: Mon, 03 Mar 1997 15:25:05 -0500

On Sun, 16 Feb 1997 15:52:58 -0700  Tom Maufer wrote:
> I believe that
> well.

I've heard that the PowerHubs from Fore (formerly Alantec) do not
support pruning.  Can anyone confirm/deny this?

-Phil			Cornell Theory Center

---

From: Anh Vu <[email-masked]>
Date: Mon, 3 Mar 97 13:49:24 PST

Phil,

You're right.  Pruning is not supported in the PowerHubs with the
current version.  However, it'll be supported in our next release.

Anh

> Date: Mon, 03 Mar 1997 15:25:05 -0500
> From: Phil Pishioneri <[email-masked]>
> Sender: [email-masked]
> Precedence: bulk
>