Subject: mrouter problems

From: Don McGregor <[email-masked]>
Date: Tue, 14 Jan 1997 09:57:54 -0800 (PST)

I dunno if this is the right place to ask, but I've
got some problems with my mrouted 3.8. Correction 
and pointers to a better place to ask welcome.

I've got a dual-homed SGI with fiber on one interface
and ethernet on the other. The fiber is getting multicast
packets--I can subscribe to various mcast groups. But
the mrouter doesn't forward to ethernet.

The routing tables (from sending mrouted a -USR1 signal)
are as follows:

----------------------------------
vifs_with_neighbors = 0

Virtual Interface Table
Vif  Name  Local-Address                               M  Thr  Rate   Flags
 0   xpi0  131.120.64.17   subnet: 131.120.64/24       1   1      0   querier leaf
                           groups: 224.2.244.141  
                         pkts in : 6757
                         pkts out: 15708

 1    ec0  131.120.63.17   subnet: 131.120.63/24       1   1      0   querier leaf
                           groups: 224.0.1.24     
                         pkts in : 6757
                         pkts out: 15708

Multicast Routing Table (2 entries)
 Origin-Subnet      From-Gateway    Metric Tmr In-Vif  Out-Vifs
 131.120.64/24                         1   105   0    1*
 131.120.63/24                         1   105   1    0*

---------------------------------

If I'm reading this correctly, it's telling me that this mrouter isn't
seeing any neighboring mrouters (vifs_with_neighbors = 0). There's
a cisco router providing mcast to the fiber.

Am I correct in assuming that this is a problem with not seeing
mrouters, and does anyone have a possible cause? Are there any
good diagnostic tools out there for something like this?

---

From: Bill Fenner <[email-masked]>
Date: Tue, 14 Jan 1997 11:37:46 PST

The Cisco is not providing DVMRP routing information, so the
mrouted has no information about other sources and won't forward
packets from sources it has no information about.  Check your
mrouted.cache (from kill -USR2) and you will probably see lots
of entries with in-vif 32 and no out-vifs.

The mrouted is not seeing the Cisco at all as a DVMRP neighbor,
so you'll have to configure it to perform DVMRP on the shared
interface.  (I thought that Cisco did DVMRP automatically, so
I can't tell you what to enable to make this happen).  Once they
see each other as DVMRP neighbors, the easiest way to make
things work, assuming that this is a stub and not transit, is
to configure the Cisco to inject a default route towards the
mrouted ("ip dvmrp default-information originate").

  Bill

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 14 Jan 1997 12:20:08 -0800

>> mrouted ("ip dvmrp default-information originate").

    To inject a default route only, you need to use the command "ip dvmrp 
    default-information only".

Dino

---

From: Jining Tian <[email-masked]>
Date: Tue, 14 Jan 1997 15:52:41 UTC-0800

My solution to this problem is to modify the mrouted since you might not have
access to the router. 
Here is a modified version of mrouted3.8:

ftp://ftp.cs.ubc.ca/pub/local/dsg/mrouted/

It allows to add a line in the mrouted.conf to specify the default route:

default a.b.c.d(your cisco router)

It worked on my machine.

-- Jining

>MIME-Version: 1.0
>Content-Type:  text

---

From: "John M. Zwiebel" <[email-masked]>
Date: Tue, 14 Jan 1997 16:49:46 -0800

>I can't tell you what to enable to make this happen).  Once they

The cisco doesn't do DVMRP automatically on a physical interface.

When it detects a DVMRP neighbor it will act as if it is a host for
all the groups it knows about and will send IGMP host reports to the 
DVMRP router.

If you want the cisco to pass DVMRP routing information over a physical
interface use the interface command:

	ip dvmrp unicast-routing

Check out the files in ftp://ftpeng.cisco.com/ipmulticast.html

z