Subject: MCI & FreeBSD

From: Amancio Hasty <[email-masked]>
Date: Thu, 08 Aug 1996 16:24:44 -0700

Any ideas when MCI is going to fix this problem:

{hasty} mtrace  -t 127 129.89.9.63 224.2.100.102
Mtrace from 129.89.9.63 to 204.188.121.18 via group 224.2.100.102
Querying full reverse path... 
  0  rah.star-gate.com (204.188.121.18)
 -1  rah.star-gate.com (204.188.121.18)  DVMRP  thresh^ 1  
 -2  toad.com (140.174.2.1)  DVMRP  thresh^ 1  
 -3  dec3800-2-fddi-1.SanFrancisco.mci.net (204.70.158.77)  DVMRP  thresh^ 64  
 -4  dec3800-2-fddi-0.Denver.mci.net (204.70.152.61)  DVMRP  thresh^ 1  
 -5  dec3800-1-fddi-0.WillowSprings.mci.net (204.70.104.29)  DVMRP  thresh^ 1  
 -6  dgx-fddi6-0-0.chicago.cic.net (131.103.1.21)  DVMRP  thresh^ 32  
 -7  alumni.cs.uwm.edu (129.89.9.30)  DVMRP  thresh^ 32  
 -8  homestead.cs.uwm.edu (129.89.9.63)
Round trip time 231 ms

Waiting to accumulate statistics... Results after 10 seconds:

  Source        Response Dest    Packet Statistics For     Only For Traffic
129.89.9.63     204.188.121.18   All Multicast Traffic     From 129.89.9.63
     v       __/  rtt  190 ms    Lost/Sent = Pct  Rate       To 224.2.100.102
129.89.9.30     alumni.cs.uwm.edu 
     v     ^      ttl   32        0/31   =  0%   0 pps     0/29   =  0%   0 pps
131.103.1.21    dgx-fddi6-0-0.chicago.cic.net 
     v     ^      ttl   33        0/31   =  0%   3 pps     0/29   =  0%   2 pps
204.70.104.45  
204.70.104.29   dec3800-1-fddi-0.WillowSprings.mci.net 
     v     ^      ttl   34        0/39   =  0%   0 pps     0/29   =  0%   0 pps
204.70.152.77  
204.70.152.61   dec3800-2-fddi-0.Denver.mci.net 
     v     ^      ttl   35       30/298  = 10%   0 pps    29/29   =100%   0 pps
204.70.158.77   dec3800-2-fddi-1.SanFrancisco.mci.net 
     v     ^      ttl   64        1/815  =  0%   0 pps     0/0    = --%   0 pps
140.174.2.1     toad.com       
     v     ^      ttl   65        0/8    = --%   0 pps     0/0    = --%   0 pps
204.188.121.18  rah.star-gate.com 
     v      \__   ttl   66          5            0 pps       0            0 pps
204.188.121.18  204.188.121.18
  Receiver      Query Source

 dec3800-2-fddi-0.Denver.mci.net is blocking the video stream from
 FreeBSD Lounge. This is a problem that has been with us for at least
 a couple of months now.

	 Thank you,
	 Amancio

---

From: Petri Helenius <[email-masked]>
Date: Fri, 9 Aug 1996 15:07:57 +0300 (EET DST)

> Any ideas when MCI is going to fix this problem:
I guess they might have some bigger problems of theirs, I'm not sure
but my suspect for the 40 Mbps fall every working day at 10:00 EST at
MAE-E might give some clue who's falling off the cliff.

For your reference:
http://www.mfsdatanet.com/MAE/east.giga.overlay.html

Pete

---

From: "Danny McPherson" <[email-masked]>
Date: Fri, 09 Aug 1996 12:05:22 -0400

How 'bout we ask MCI?   

-danny

>      v     ^      ttl   33        0/31   =  0%   3 pps     0/29   =  0%   2 pps

[snip]

Date: Fri, 9 Aug 1996 15:34:53 +0300 (EET DST)
From: Petri Helenius <[email-masked]>
To: [email-masked]
Subject: MCI & FreeBSD

Just to confirm, all my routes that usually go trough MAE-E --> MCI
path just got rerouted to ICM --> BBNplanet path and the time seems to
be quite accurate to the 09:00-10:30 EST, guess we got little more
load today to push them off the cliff a little sooner.

Pete

[snip]

Date: Fri, 9 Aug 1996 15:07:57 +0300 (EET DST)
From: Petri Helenius <[email-masked]>
To: Amancio Hasty <[email-masked]>
Cc: [email-masked]
Subject: MCI & FreeBSD

For your reference:

Pete

---

From: Amancio Hasty <[email-masked]>
Date: Fri, 09 Aug 1996 14:15:52 -0700

> How 'bout we ask MCI?   

I have and trust me is been a couple of months and I rather have the people
who  actually have fixed the mbone between rah.star-gate.com and 
uwm.edu talk about it when we are done 8)

	Regards,
	Amancio

---

From: Amancio Hasty <[email-masked]>
Date: Fri, 09 Aug 1996 15:03:29 -0700

> -danny

Well , I am going to give a try to your kind offer 8)

Specifically, I would like to know if anything has changed or the system
reboot at: dec3800-2-fddi-0.Denver.mci.net 

If dec3800-1-fddi-1.WillowSprings.mci.net is a cisco router, which version
is it running.

Till last nite pretty much all the time, dec3800-2-fddi-0.Denver.mci.net 
was blocking the video traffic from FreeBSD Lounge;however, as of this
morning around 5:00 am, I noticed that I was able to get the FreeBSD video 
stream. A few hours later the video is gone and  this is what the
mtrace is showing:

 -6  dgx-fddi6-0-0.chicago.cic.net (131.103.1.21)  DVMRP  thresh^ 32  Output pruned
Round trip time 162 ms

  Source        Response Dest    Packet Statistics For     Only For Traffic
   * * *        204.188.121.18   All Multicast Traffic     From 129.89.9.63
     v       __/  rtt  635 ms    Lost/Sent = Pct  Rate       To 224.2.100.102
131.103.1.21    dgx-fddi6-0-0.chicago.cic.net Output pruned
     v     ^      ttl   32        0/2    = --%   0 pps    20/20   =100%   2 pps
204.70.104.45  
204.70.104.29   dec3800-1-fddi-0.WillowSprings.mci.net 
     v     ^      ttl   33        0/7    = --%   0 pps     0/0    = --%   0 pps
204.70.152.77  
204.70.152.61   dec3800-2-fddi-0.Denver.mci.net 
     v     ^      ttl   34       11/274  =  4%   0 pps     0/0    = --%   0 pps
204.70.158.77   dec3800-2-fddi-1.SanFrancisco.mci.net 
     v     ^      ttl   64        0/632  =  0%   0 pps     0/0    = --%   0 pps
140.174.2.1     toad.com       
     v     ^      ttl   65        1/11   =  9%   1 pps     0/0    = --%   0 pps
204.188.121.18  rah.star-gate.com 
     v      \__   ttl   66          12           0 pps       0            0 pps
204.188.121.18  204.188.121.18
  Receiver      Query Source

I am assuming that dgx-fddi6-0-0.chicago.cic.net is a cisco router so 
the most natural question to ask is which version or snapshot is that
router running?

	Tnks,
	Amancio

---

From: "Dorian R. Kim" <[email-masked]>
Date: Fri, 9 Aug 1996 21:31:52 -0400 (EDT)

> If dec3800-1-fddi-1.WillowSprings.mci.net is a cisco router, which version

This is, as the name indicate, a DEC alpha.

>      v     ^      ttl   32        0/2    = --%   0 pps    20/20   =100%   2 pps

It's based on 11.1(4.1) as far as I know.

From dgx's sh ip sdr det:

Session Name: FreeBSD Lounge
  Description: Channel to discuss FreeBSD related issues.  Please keep video
               bandwidth below 64kbps.
  Group: 224.2.100.100, ttl: 127, Contiguous allocation: 1
  Uptime: 6d02h, Last Heard: 00:00:34
  Announcement source: 129.89.9.110
  Created by: james 3036925017 3036925272 IN IP4 129.89.9.110
  Phone number: Jim Lowe (414) 229-6634
  Email: Jim Lowe <[email-masked]>
  URL:
  Media: audio 16400 rtp gsm
    Media group: 224.2.100.100, ttl: 127
    Attribute: id:0
  Media: video 49200 rtp h261
    Media group: 224.2.100.102, ttl: 127
    Attribute: id:0
  Media: whiteboard 32800 udp wb
    Media group: 224.2.100.101, ttl: 127
    Attribute: orient:portrait

sh ip mroute act

Group: 224.2.100.102, FreeBSD Lounge
   Source: 129.89.9.63 (homestead.cs.uwm.edu)
     Rate: 4 pps/9 kbps(1sec), 9 kbps(last 0 secs), 10 kbps(life avg)

dgx#sh ip mroute 224.2.100.102 count
IP Multicast Statistics - Group count: 32, Average sources per group: 2.43
Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second

Group: 224.2.100.102, Source count: 6, Group pkt count: 79135
  Source: 13.2.116.11/32, 6118/1/103/0
  Source: 129.89.9.63/32, 51952/3/461/8
  Source: 129.89.9.110/32, 13843/0/164/0
  Source: 132.197.248.20/32, 4933/0/88/0
  Source: 193.84.49.32/32, 2234/0/84/0
  Source: 193.166.227.2/32, 55/0/98/0

dgx#sh ip mroute 224.2.100.102 sum
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode

(*, 224.2.100.102), 6d03h/00:02:56, RP 0.0.0.0, flags: DJC
  (13.2.116.11/32, 224.2.100.102), 09:07:35/00:05:33, flags: CT
  (129.89.9.63/32, 224.2.100.102), 05:06:27/00:02:54, flags: CT
  (129.89.9.110/32, 224.2.100.102), 19:21:24/00:02:53, flags: CT
  (132.197.248.20/32, 224.2.100.102), 06:57:10/00:04:50, flags: CT
  (193.84.49.32/32, 224.2.100.102), 06:04:47/00:02:53, flags: CT
  (193.166.227.2/32, 224.2.100.102), 00:17:51/00:04:45, flags: CT

Things look ok from here....

-dorian

---

From: "Danny McPherson" <[email-masked]>
Date: Fri, 09 Aug 1996 22:00:51 -0400

> Specifically, I would like to know if anything has changed

nope.

> or the system reboot at: dec3800-2-fddi-0.Denver.mci.net 
  
nope.

> If dec3800-1-fddi-1.WillowSprings.mci.net is a cisco router, which version

As Dorian pointed out, a DEC alpha, running mrouted...

>      v     ^      ttl   32        0/2    = --%   0 pps    20/20   =100%   2 pps

once again...  Dorian answered.  Let me know if you anymore question  ;-)

-danny