Subject: MBone default route

From: Petri Helenius <[email-masked]>
Date: Sun, 19 May 1996 10:59:06 +0300 (EET DST)

-----BEGIN PGP SIGNED MESSAGE-----

  Somebody at or near barrnet is injecting default route to the global
MBone, not that it actually hurts anybody but it might be a good idea
to fix the config anyhow:

silver:/usr/local/src/mview/bin(256)% mtrace 0.0.0.1 224.2.129.168
Mtrace from 0.0.0.1 to 194.111.122.1 via group 224.2.129.168
Querying full reverse path... * switching to hop-by-hop:
  0  silver.sms.fi (194.111.122.1)
 -1  hideout-e0.sms.fi (194.111.122.254)  PIM  thresh^ 1   [0/8]
 -2  swallow-s2.sms.fi (192.194.252.177)  PIM  thresh^ 4   [default]
 -3  kiwi-gw.funet.fi (193.166.255.73)  DVMRP  thresh^ 12   [default]
 -4  rip.funet.fi (193.166.1.1)  DVMRP  thresh^ 16   [default]
 -5  directory.funet.fi (128.214.1.252)  DVMRP  thresh^ 12   [default]
 -6  stockholm.mbone.ebone.net (192.36.148.206)  DVMRP  thresh^ 40   [default]
 -7  ? (198.67.134.250)  DVMRP  thresh^ 64   [default]
 -8  cambridge1-mbone1.bbnplanet.net (199.94.207.2)  DVMRP  thresh^ 32   [default]
 -9  cpk-mc1.sura.net (128.167.252.196)  DVMRP  thresh^ 32   [default]
- -10  paloalto-mbone1.bbnplanet.net (131.119.0.197)  DVMRP  thresh^ 64   [default]
- -11  utumno.barrnet.net (131.119.244.11)  DVMRP  thresh^ 32   [default]
- -12  * * * * ? (129.213.128.9) didn't respond
- -13  * * ^C

Pete

---

From: John Hawkinson <[email-masked]>
Date: Sun, 19 May 1996 10:56:58 -0400 (EDT)

> From: Petri Helenius <[email-masked]>

> to fix the config anyhow:

Yes, it seems to be 3com (129.213.128.9). I'll talk to them.  In the
meantime, it's filtered out at the hop past utumno.

Lately folks haven't sent mail to mbone everytime there was default, given
the frequency with which that happens. Perhaps it's good to change that?
(lots o' mail)

Anyhow, we're still counting to infinity on my default, so it's
not clear who the next guilty person is :-)

--jhawk

---

From: Petri Helenius <[email-masked]>
Date: Sun, 19 May 1996 22:09:46 +0300 (EET DST)

> the frequency with which that happens. Perhaps it's good to change that?
I'm not sure but input is appreciated. We're still counting at 11
metric hops from Finland so it moved but did not disappear.

 > not clear who the next guilty person is :-)
I give almost full score for wonderful hostname:
 -8  dec3800-1-fddi-0.WestOrange.mci.net (204.70.64.29)  DVMRP  thresh^ 32   [default]
 -9  dec3800-1-fddi-1.NorthRoyalton.mci.net (204.70.98.45)  DVMRP  thresh^ 1   [default]
-10  dec3800-1-fddi-1.WillowSprings.mci.net (204.70.104.45)  DVMRP  thresh^ 1   [default]
-11  tibia.cic.net (131.103.1.100)  DVMRP  thresh^ 32   [default]
-12  fibula.cic.net (131.103.1.101)  DVMRP  thresh^ 1  Next router no mtrace [default]
-13  UP-TelecommunicationsBldg1-Ethernet3.gw.psu.edu (192.5.159.2) [cisco 10.2] doesn't support mtrace
Round trip time 316 ms

Not to mention that it's criminal to run pre-11.0(3.1) Cisco code
running DVMRP.

Pete

---

From: Dave Barr <[email-masked]>
Date: Sun, 19 May 1996 20:01:27 -0400

>Not to mention that it's criminal to run pre-11.0(3.1) Cisco code

I know the admin who runs this Cisco.  We run PIM on the backbone, but
this one is set up to do a dvmrp broadcast default so my mrouted can talk
to it.  I thought it was set up to only broadcast the route on my interface,
but perhaps not.  Unfortunately I know nothing about Ciscos in general
or details of how this one is set up in particular.  Can someone send
me info privately that I can send to my contact on how to track this
down and correct it?  I'd love to get him to upgrade the code as well.
I know he has big concerns about stability because this is a production
router.  Suggestions welcome, especially since I seem to be the one
leading the charge to get PSU MBONE-capable.  I could use some
more ammo, or at least some battle plans.  :-)

--Dave

---

From: Dorian Kim <[email-masked]>
Date: Sun, 19 May 1996 20:11:16 -0400 (EDT)

> -13  UP-TelecommunicationsBldg1-Ethernet3.gw.psu.edu (192.5.159.2) [cisco 10.2] doesn't support mtrace

From where I'm sitting (fibula.cic.net that is) the default is still heading
to BARRnet. Am I missing something or has something changed since this?

I've contacted PSU to and they should be checking into their DVMRP config.

> Not to mention that it's criminal to run pre-11.0(3.1) Cisco code

Not something I can do much about, unfortunately...

-dorian

---

From: Petri Helenius <[email-masked]>
Date: Mon, 20 May 1996 08:23:44 +0300 (EET DST)

-----BEGIN PGP SIGNED MESSAGE-----

 > but perhaps not.  Unfortunately I know nothing about Ciscos in
general

If one initiates a default route on an interface that is into a DVMRP
cloud that is connected to the MBone at some point using DVMRP the
default will be propagated. Since the default you get from your
neighbor is likely to be the best default that actually might look
like that it 'fixes' the problem since their traffic originated is
accepted by the mrouted. The Cisco code will automatically announce
all networks connected to the router using DVMRP and which are
multicast enabled. If you want more than that you can do unicast to
DVMRP redistribution but be extremely careful NOT TO redistribute huge
routing tables into the DVMRP cloud since you'll break it.

If however your DVMRP is stub in a config like this:

MBONE <----> PIM border router <-----> PIM cloud <---> Router <---> mrouted

You should be announcing default route to the mrouted but then there
should be no possibility of it leaking out to the MBone.

 > more ammo, or at least some battle plans.  :-)
Take anything saying 'ip dvmrp default-information XXX' out on the
interfaces connected to MBone but you can use them on interfaces
connected to mrouteds not connected directly to the MBone.

Pete