Subject: RE: some misconfigured cisco trashing the mbone again

From: Arlie Davis <[email-masked]>
Date: Sat, 27 Apr 1996 12:58:31 -0400

Yes, dozens of people have accidentally triggered this
problem with an innocent-looking configuration command.
This is definitely obnoxious; it should have a big, scary
name like "ip dvmrp unicast-redistribute" rather than just "metric".

However, that doesn't mean it's a bug.  Many, many routers run
with very small unicast routing tables, and in order to get multicast
to work exactly right on them, it is sometimes necessary to
redistribute unicast routes.

Also, it demonstrates the fragility of DVMRP, and the need
to replace it with something better.  When I first learned about 
multicast routing, I could hardly believe that the entire 
infrastructure ran as a single routing domain.  The fact that 
one miscreant router can bring down the entire MBONE
shows the weakness of the protocol, not the irresponsibility
of the network administrator.  The unicast routing
protocols, on the other hand, have a strong emphasis on
robustness, and on preventing madness in one section
of the network from affecting the proper operation of
other parts of the network.  (I can mangle my router
all day, and the effects only manifest within my domain,
not my neighbors'.)

This is one of the biggest reasons why I use PIM inside
my network, instead of UNIX workstations masquerading 
as routers.  PIM doesn't solve all the problems in the world, 
but it is definitely an improvement.

Since there is no multicast routing border protocol, it
is very difficult to implement any other multicast routing
protocol; everything has to pretend that it is DVMRP
on one side.  Until there is a border protocol, or there
is some way to break the MBONE into multiple
routing domains, the MBONE will continue to be a
fragile research toy.  Multicast-aware application
development is hitting the knee of the curve; soon,
every network administrator on the planet will want
to turn up multicast IP on his/her network.  They will
want to use real routers, existing routers to do this;
they won't be satisfied with mrouted.  It had better
be easy to install and robust, or we'll be seeing
messages about misconfigured routers trashing
the MBONE every week.

Don't get me wrong -- I'm very thankful that everyone
has worked hard to bring the MBONE to where it is
today.  But it still has a long way to go.

-- arlie

----------
From: 	Magnus Danielson[SMTP:[email-masked]]
Sent: 	Saturday, April 27, 1996 12:34 PM
To: 	Van Jacobson
Cc: 	[email-masked]; [email-masked]
Subject: 	Re: some misconfigured cisco trashing the mbone again 

> A misconfigured cisco router somewhere in the world is injecting
> massive numbers of unicast routes into the mbone again.  Our local
> mrouted's are currently seeing 32579 routes advertised (and spending
> 40% of an SS-2 processing routing updates).  Anyone have any idea
> how we can find this router and stop it?  Anyone have any idea how,
> after 3 years of putting up with this crap, we can get cisco to
> fix their goddamn software so that cisco customers and the mbone
> aren't continually hosed by innocent customers making a very-easy-
> to-make configuration mistake?

You should be able to mtrace to bogus mbone networks, that is network you know
is not on the Mbone and see where they show up... this of course assumes that
you have any Mbone routers alive along the path.

Everyone should look into their routing tables and see where the most entries
came from. If everyone had SNMP access to their routers I would even be able to
make a routing entry trace tool... it would be a bit clumpsy but would do the
trick.

I dont understand why Cisco still think they should allow people to include
the unicast table into the DVMRP routing table since this will never survive
it. Cisco should view this as a bug and not as a feature. When useing a 
diffrent
routing table scheme (I hope, I surely hope) it just migth be a good idea 
again,
but until then it is a bug.

Magnus Danielson
Mbone coordinator in Europe and Chairman of the RIPE Mbone WG

---

From: Jon Crowcroft <[email-masked]>
Date: Sun, 28 Apr 1996 13:47:09 +0100

>but it is definitely an improvement.

yes, but you can run gated with other multicast routing protocls than
dvmrp - unix is irrelevant, please don't bash it, you'd have precious
little internet or mbone without it as the proof of concept platform:-)
 
 >protocol; 

yes - IDMR is working on this (its why we started it:-)
we are correctly being harassed that we havn't made fast enuff
progress...

any suggestions on ways to disseminate receiver group existence in a
scalable, inter-domain fashion are very very welcome!

cheers
jon