Subject: Multicast interaction with Mac G3, System 8.1, etc ????

From: Hugh LaMaster <[email-masked]>
Date: Tue, 16 Jun 1998 13:45:30 -0700 (PDT)

This is grasping at straws, but, I have a faint hope that someone
on this list may have heard of this.  We have a user on a very
busy subnet with multicast enabled who is experiencing TCP problems.
Circumstantial evidence shows a slight possibility of a multicast
interaction.

The system in question is a PowerMac G3, 266 MHz, 160 MB, 
builtin ethernet, running System 8.1, Finder 8.1, 
OpenTransport 1.3.

The symptom is that the system drops off the net, and has
to be rebooted to get back on the net.  Eudora, if it happens
to be running, reports that all the sockets are busy.

The association with multicast is that it seems that this
happens when the ethernet is very busy and a significant
part of the traffic is multicast (around 1 Mbits/sec).

Does this sound like anything anyone has heard of?  No other
system on the network is apparently experiencing the problem,
at least not this severely.

--
 Hugh LaMaster, M/S 233-21,    ASCII Email: [email-masked]
 NASA Ames Research Center     Or:          [email-masked]
 Moffett Field, CA 94035-1000  No Junkmail: USC 18 section 2701
 Phone: 650/604-1056           Disclaimer:  Unofficial, personal *opinion*.

---

From: Matthew Flanagan <[email-masked]>
Date: Wed, 17 Jun 1998 13:14:09 +1000 (EST)

Hugh,

This is a known problem with the ethernet drivers for the G3 and there is a fix available from apple. You can grab it at:

ftp://ftp.info.apple.com/Apple_Support_Area/Apple_Software_Updates/US/Macintosh/System/CPU_Specific_Updates/Power_Mac_G3/G3_Ethernet_2.0.4.smi.bin

Here is an excerpt from the readme:

"This driver is used by the Power Macintosh G3 built-in Ethernet
interface. The 2.0.4 driver fixes a problem present in the 2.0, 2.0.1,
2.0.2, and 2.0.3 drivers, where there is a possibility that the system
could lose network services when using the built-in Ethernet interface
with the machines listed above."

matthew

--
Matthew Flanagan	[email-masked]
University of Technology, Sydney
Australia

---

From: Hugh LaMaster <[email-masked]>
Date: Tue, 16 Jun 1998 22:25:54 -0700 (PDT)

> interface. The 2.0.4 driver fixes a problem present in the 2.0, 2.0.1,

You are a gentleman and a scholar.  It is unlikely I would ever
have found that patch, but, it appears to be exactly what is
needed.  Thanks again.

Regards,
Hugh LaMaster