Subject: Re: wrong email-adr in session-advertisement

From: Mark Allard <[email-masked]>
Date: Tue, 22 Jul 1997 10:36:31 -0700

This seems to be a bug, flaw, or "feature" in the sdr software and I do not
know where it is pulling the information from.
Whenever the session is edited, this information is getting defaulted in by
the application.
I will attempt again to isolate and correct the source of the problem but
am open to suggestions from anyone intimately familiar with sdr.
Thanks,
M

At 09:05 AM 7/22/97 +0200, Christoph Fleck wrote:
>Hi,
>
>To [email-masked] and [email-masked]: 
>Please check your session-advertisement, becourse it contains my
email-adress.
>Your sessions have wrong e= and p= fields !?
>Which session-annoncer do you use?
> In the case of "itv Carleton University" it say you use "sdr v2.3a1", is it 
> true? 
>Have you other advertisements with the same error?
>
>To Brian Tonner:
>Do you know the reason, that our email-adress carryed in someone else's 
>session-advertisement, or is it in your case o.k.?
>
>To all other:
>Any solutions, explanations?
>Is the session-advertisement of "itv Carleton University" and 
>"NASA Space Shuttle STS-94" the same around the world?
>
>Please see enclosed session-advertisements. I have it taken twice with:
> $ rtpdump -f payload 224.2.127.254/9875
>
>
>rgds Christoph
>
>,------------------------------------------------------------------.
>| Referenzzentrum fuer multimediale Teledienste (MMRZ), TU Dresden |
>|         Dr. Klaus Koehler, Christoph Fleck, Rainer Kranz         |
>| e-mail: [email-masked]             Tel.: 0351 / 463 5653  |
>|    WWW: http://www-mm.urz.tu-dresden.de               (GERMANY)  |
>`------------------------------------------------------------------'
>
>
>-----------------------------------------------------------
>o=mbone 3078153544 3078409207 IN IP4 134.117.4.93
>s=itv Carleton University
>i=This is the multicast itv courses from Carleton University. The
schedules of the courses are: Introduction to Astronomy at 9:05am for
Mon.,Wed., and Fri. Introduction to Linguistics at 2:35pm for mon.,Wed.,and
Fri. Wood Engineering at 9:05am for Tues. a
>nd Thurs. Introduction to Social Psychology at 2:35pm for Tues. and Thurs.
Please use MPOLL(Control) for your feedback. Mpoll is available on
http://debra.dgbt.doc.ca/mbone/mpoll/ .
>u=http://www.sce.carleton.ca/
>e=IN IP4 224.2.212.30/75Referenzzentrum __ <[email-masked]>
Brian Tonner (UWM) <[email-masked]>IN IP4
224.2.212.30/75Referenzzentrum __ <[email-masked]>       Brian
Tonner (UWM) <[email-masked]>Shuyang Shi - Carleton University
> <[email-masked]>
>p=Brian Tonner (at UWM) 414-229-4626Brian Tonner (at LBL)
510-486-5590Brian Tonner (at UWM) 414-229-4626Brian Tonner (at LBL)
510-486-5590Shuyang Shi - Carleton University 613-520-2600 ext. 5725
>c=IN IP4 224.2.209.91/127
>t=3078133200 3080584800
>r=604800 32400 0
>a=tool:sdr v2.3a1
>a=type:test
>m=audio 19368 RTP/AVP 0
>c=IN IP4 224.2.209.91/127
>a=ptime:40
>m=video 63652 RTP/AVP 31
>c=IN IP4 224.2.203.119/127
>m=control 50354 udp mpoll
>c=IN IP4 224.2.142.124/127
>-----------------------------------------------------------
>o=mbone 3078153544 3078409207 IN IP4 134.117.4.93
>s=itv Carleton University
>i=This is the multicast itv courses from Carleton University. The
schedules of the courses are: Introduction to Astronomy at 9:05am for
Mon.,Wed., and Fri. Introduction to Linguistics at 2:35pm for mon.,Wed.,and
Fri. Wood Engineering at 9:05am for Tues. a
>nd Thurs. Introduction to Social Psychology at 2:35pm for Tues. and Thurs.
Please use MPOLL(Control) for your feedback. Mpoll is available on
http://debra.dgbt.doc.ca/mbone/mpoll/ .
>u=http://www.sce.carleton.ca/
>e=IN IP4 224.2.212.30/75Referenzzentrum __ <[email-masked]>
Brian Tonner (UWM) <[email-masked]>IN IP4
224.2.212.30/75Referenzzentrum __ <[email-masked]>       Brian
Tonner (UWM) <[email-masked]>Shuyang Shi - Carleton University
> <[email-masked]>
>p=Brian Tonner (at UWM) 414-229-4626Brian Tonner (at LBL)
510-486-5590Brian Tonner (at UWM) 414-229-4626Brian Tonner (at LBL)
510-486-5590Shuyang Shi - Carleton University 613-520-2600 ext. 5725
>c=IN IP4 224.2.209.91/127
>t=3078133200 3080584800
>r=604800 32400 0
>a=tool:sdr v2.3a1
>a=type:test
>m=audio 19368 RTP/AVP 0
>c=IN IP4 224.2.209.91/127
>a=ptime:40
>m=video 63652 RTP/AVP 31
>c=IN IP4 224.2.203.119/127
>m=control 50354 udp mpoll
>c=IN IP4 224.2.142.124/127
>===========================================================
>o=shuttle 3075630923 3075633526 IN IP4 128.102.84.134
>s=NASA Space Shuttle STS-94
>i=Video/Audio broadcast of NASA space shuttle mission STS-94, Microgravity
Science Laboratory-1.  This session is being broadcast as a service to the
MBONE community by NASA-Ames Reseach Center.
>u=http://www-pao.ksc.nasa.gov/kscpao/kscpao.htm
>e=NASA - ARC Digital Video Lab <[email-masked]
>e=Brian Tonner (UWM) <[email-masked]>
>e=Referenzzentrum __ <[email-masked]>       
>e=IN IP4 224.2.212.30/75
>p=NASA - ARC Digital Video Lab (415) 604-6145
>p=Brian Tonner (at LBL) 510-486-5590
>p=Brian Tonner (at UWM) 414-229-4626
>c=IN IP4 224.2.210.20/127
>t=3076354800 3078774000
>m=audio 24680 RTP/AVP 0
>c=IN IP4 224.2.210.20/127
>m=video 56062 RTP/AVP 31
>c=IN IP4 224.2.210.20/127
>-----------------------------------------------------------
>o=shuttle 3075630923 3075633526 IN IP4 128.102.84.134
>s=NASA Space Shuttle STS-94
>i=Video/Audio broadcast of NASA space shuttle mission STS-94, Microgravity
Science Laboratory-1.  This session is being broadcast as a service to the
MBONE community by NASA-Ames Reseach Center.
>u=http://www-pao.ksc.nasa.gov/kscpao/kscpao.htm
>e=NASA - ARC Digital Video Lab <[email-masked]
>e=Brian Tonner (UWM) <[email-masked]>
>e=Referenzzentrum __ <[email-masked]>       
>e=IN IP4 224.2.212.30/75
>p=NASA - ARC Digital Video Lab (415) 604-6145
>p=Brian Tonner (at LBL) 510-486-5590
>p=Brian Tonner (at UWM) 414-229-4626
>c=IN IP4 224.2.210.20/127
>t=3076354800 3078774000
>m=audio 24680 RTP/AVP 0
>c=IN IP4 224.2.210.20/127
>m=video 56062 RTP/AVP 31
>c=IN IP4 224.2.210.20/127
>
>

---

From: [email-masked] (Deborah Agarwal)
Date: Tue, 22 Jul 97 12:12:20 PDT

Hi Mark,

This is a bug in the sdr create session interface.  You need to
quit sdr and then find your advertisement in your .sdr/cache
directory and edit out the bad information there and then restart
sdr and you should be rid of the bad information.

Thanks,
Deb Agarwal
----------------------------------