Subject: rtptools multicast problem?

From: Christian Isnard - CERN CN/CS/EN <[email-masked]>
Date: Wed, 23 Oct 1996 14:33:45 +0200 (MET DST)

Hi,

We try to set up unicast<->multicast gateways using rtptrans program, distributed in
ftp://ftp.cs.columbia.edu/pub/schulzrinne/rtptools .

We discovered that SGI Indys do not "see" the multicast stream produced by
rtptrans, whereas SUN SparcStations connected to the same segment do play
the multicast data without problem.
The Indys run Irix 5.3 for R5000, and the SUNs run SunOS 4.1.4 patched
with IP multicast v3.5. The applications are vat (-r), vic, rat.

We observe the same behaviour whether rtptrans runs on a SUN or an SGI Indy.

We dumped the multicast packets sent by rtptrans using rtpdump and tcpdump
(running on a SUN), which showed that the these packets have an IP *source*
address equal to the destination *multicast* address!

Everything works fine if rtpgw is used instead of rtptrans.

Have other people noticed the same odd behaviour?  Is this an rtptrans
bug, or could we do something at the operating system level to fix the
problem?

Example:  Host 128.141.211.1 sends in unicast to a station running
``rtptrans 128.141.211.1/5656 225.6.6.6/7878'' thus relaying to 225.6.6.6 :

 tcpdump -e ip multicast

 18:11:08.600597 8:0:69:9:a9:bf 1:0:5e:6:6:6 ip 374: 225.6.6.6.7878 > 225.6.6.6.7878: udp 332
 18:11:08.643380 8:0:69:9:a9:bf 1:0:5e:6:6:6 ip 374: 225.6.6.6.7878 > 225.6.6.6.7878: udp 332
 18:11:08.682233 8:0:69:9:a9:bf 1:0:5e:6:6:6 ip 374: 225.6.6.6.7878 > 225.6.6.6.7878: udp 332
 18:11:08.720149 8:0:69:9:a9:bf 1:0:5e:6:6:6 ip 374: 225.6.6.6.7878 > 225.6.6.6.7878: udp 332
 18:11:08.760073 8:0:69:9:a9:bf 1:0:5e:6:6:6 ip 374: 225.6.6.6.7878 > 225.6.6.6.7878: udp 332

 rtpdump -F rtcp 225.6.6.6/7878

 845647741.139400 RTCP len=64 from=225.6.6.6:7879         <==========
   (RR ssrc=0xbbf5f224 p=0 count=0 len=1
   )
   (SDES p=0 count=1 len=13
    (src=0xbbf5f224 CNAME="[email-masked]" NAME="C.Isnard - CERN - hbone" )
   )
  845647748.561975 RTCP len=64 from=225.6.6.6:7879
   (RR ssrc=0xbbf5f224 p=0 count=0 len=1
   )

Thanks in advance,
--------------------------------------------------------------------
Christian Isnard                                     CERN - CN/CS/EN
[email-masked]       European Laboratory for Particle Physics
Tel: +41 22 767 23 94                Computers and Networks division
Fax: +41 22 767 71 55                CH-1211 Geneva 23 - Switzerland

---

From: "Bill Nowicki" <[email-masked]>
Date: Wed, 23 Oct 1996 14:12:48 -0700

The Silicon Graphics IP stack does not accept packets with the
source address being multicast (or broadcast). There are very good
security and administrative reasons for this (see the host
requirements RFC for details). Please use a valid IP source.