Subject: Problems running SDR on NT3.51

From: David Esarey <[email-masked]>
Date: Tue, 10 Dec 1996 11:22:22 -0800

I am trying to run the MBONE tools on my NT3.51 workstation.  I am using a
dual pentium 90MHz w/64MB RAM, and service pack4.  I downloaded winsdr22.zip
(1767231 Bytes) and tried to run sdr.  I did as they suggest, in regards to
setting up the correct path and home directory.  But when I run sdr, I get
an error message: "socket fd too large (92)".
I was able to run the same sdr program on a Win95 machine, so I know the
downloaded file is intact.
I would appreciate any information that will point me in the right direction.

Thanx..

David Esarey
NRaD Code 4121
x.5790

---

From: D E PRICE <[email-masked]>
Date: Tue, 10 Dec 1996 22:15:15 +0000

Dear David (and Friends),

	It appears that the early version of sdr contained
in the packages you collected has problems on NT4.
UCL have another `test' version in 

ftp://cs.ucl.ac.uk/mice/sdrtest/sdrwin.exe

which overcomes the bug you mention. However, at least
on my attempts, it fails to launch the support tools
as it attempts to access an environment variable called
PATH whereas it appears this is called Path
====                                   ==== 

on NT4.   I have patched the binary (how horrid) using a binary file
editor to replace the PATH references with Path and I now
have it sort-of working. I have however been experiencing
problems with it only spotting a subset of the sessions
I know are being announced on the subnet to which it
is attached.   It also sometimes gripes if one clicks
in certain places it seems not to like.....

I suspect Mark Handley may join in with more helpfull
comments.

Dave Price. MICE NSC, Wales