Subject: multicast extensions for SS5

From: David W Lloyd <[email-masked]>
Date: Tue, 16 Apr 1996 15:52:01 +0100

I've been trying to install mulitcast release 3.5 on a Sun Sparc 5 (sun4m
architecture).  The install works fine (using mcast_install) but when I attempt
to use the kernel the console reports the errors:

le1: TINT but buffer owned by LANCE
le1: RINT but buffer owned by LANCE

This machine has two ethernet interfaces le0 and le1 (there are no errors
reported for le0).

I've tried installing mcast in a patched sys directory and a generic version
copied straight from the CD, but the above errors always appear.  I've also
tried using the patched version of if_le.o included in the mcast release but
that didn't help either.

Can anyone provide me with help on what to try next?

Dave.

===============================================================================
David Lloyd                              | email: [email-masked]
Computer Science, Strathclyde University |
26 Richmond Street, Glasgow              | Phone: +44 (0)141 552 4400 ext 3592
Scotland  G1 1XH                         | FAX:   +44 (0)141 552 5330
===============================================================================

---

From: Graeme Wood <[email-masked]>
Date: Tue, 16 Apr 1996 16:13:49 +0100 (BST)

> This machine has two ethernet interfaces le0 and le1 (there are no errors

The problem is with the type of ethernet card you have installed.  Here 
is a message from Syngen Brown who managed to get this working:

From [email-masked] Apr 16 16:12:16 1996
Date: Tue, 09 Jan 96 18:48:16 GMT
From: Syngen Brown <[email-masked]>
Reply to: [email-masked]
To: "Jeffrey S. Curtis" <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: more RINT/TINT error messages!

>
> }I just tried putting the patches onto a SS5 (sun4m) with a 4-port (qe) 
> }card.  The kernel recompiled just peachy, but no unicast traffic passes 
> }in/out of any of the qe{0-3} interfaces. [...]
> 
> Drat.  In other words, if you have a SPARC 5 and want multicasting
> on ethernet interfaces, your only options are the builtin ethernet
> port and any SCSI+10baseT sBus NICs you have in the machine (which
> I've gotten to work with ipmulti-3.5).
 
Not quite, since my last posting I have successfully configured a
multicast router comprising a SPARC 4, SunOS 4.1.3_U1B, ipmulti 3.5,
mrouted 3.8 and the Sbus Ethernet Card (X453A).  I mentioned that
replacing the if_le.o driver with that from the ipmulti 3.3 had been
known to work, although I had tried this unsuccessfully at that time.
It now appears that there are at least two versions of this driver for
the Sun4m architecture.  The first one I tried reports the Sbus
Ethernet Card to be unsupported, this is 19389 bytes in length and has
the checksum 40268 (calculated by SunOS4 sum).  The good one is 21237
bytes length and has the checksum 23695.  Unfortunately I could not
get even the good one to work under SunOS4.1.4, although there is no
indication of anything untoward until one attempts to start mrouted. 

I'm afraid I cannot account for the two different versions of this
driver, but if anyone has difficulty locating the good if_le.o I'll
make a copy available to them.

Syngen

=============================================================================
Graeme Wood                                 Email: [email-masked]
Unix Systems Support                        Phone: +44 131 650 5003
The University of Edinburgh                 Fax:   +44 131 650 6552
-----------------------------------------------------------------------------
Scottish MICE National Support Centre       Email: [email-masked]
for your multimedia conferencing support    WWW:   http://mice.ed.ac.uk/mice/
=============================================================================