Subject: mtrace question

From: "Craig M. Votava" <[email-masked]>
Date: Wed, 30 Sep 1998 17:15:49 -0500

Folks-

I have a simple tunnel setup from A to B (both A and B
are workstations are running mrouted3.9b3).

Multicasting seems to work great in the A->B direction
but not in the B->A direction.

Running mtrace doesn't show any pruning going on. When
I say I run mtrace from A->B, what I really mean is that
I run mtrace from machine X (on the A side of the tunnel)
to machine Y (on the B side of the tunnel)

Running mtrace in the A->B direction works great. It
Queries in the full reverse path, returns very quickly,
and shows what you would expect.

Running mtrace in the B->A direction takes more time. It
tries Querying full reverse path, then goes to hop-by-hop.
Everything else looks normal. Why would this be?

I suspect that the network infrastructure between Y and B
may include ethernet switches. I further believe that these
switches either don't know how to handle multicast packets,
or are not correctly setup to do so. Any experiences with
ethernet switches would be appreciated and any help in
understanding the above scenario would be appreciated too.

Thanks!

-Craig Votava

Lucent Technologies

---

From: Bill Fenner <[email-masked]>
Date: Thu, 1 Oct 1998 11:50:30 PDT

Craig,

  The "full path trace" from B to A relies on getting a multicast packet
from A to Y.  Try "mtrace -U" and see if you get the full path trace -
that way you'll know whether the problem is with getting multicast to Y.
This is consistent with your suspicion of the ethernet switches on the
B/Y network, especially if the switches need to set up state but the
multicast packet arrives before the state is set up.  (The mtrace client
assumes that the multicast join latency is not larger than the RTT.)

  Bill