Subject: Re: linux and mrouted problem

From: [email-masked] (Rodrigo Costa Colossi - ITI - Prof. Wanderley)
Date: Fri, 22 Aug 1997 17:57:29 -0300

Hello George!
 
        What kernel version are you using? I'm using linux with routed
without problems, but I'd used kernel version 2.0.30 with some parameters
on the kernel. I tried to use mrouted with 2.0.0 but I had many problems.
        You can use this command line: dmesg | more    and see what's the
multicast version. In 2.0.30 is 0.06 instead 0.05 of 2.0.0.
        If you'll have more questions, please send me!
 
On Fri, 22 Aug 1997, George Eleftheriou wrote:

> Hello,
> we are trying to connect a pc running linux with our multicast capable
> router through a tunnel.
> I have recompiled the kernel with multicast support,
> and I have also done: route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0
> The programs sdr,vic,vat,wb run fine.
> I can't run mrouted. I have added a phyint and a tunnel interface in
> mrouted.conf but when i try to run it writing mrouted -d it says:
> debug level 2
> 15:55:33.923 mrouted version 3.8
> 15:55:34.258 can't enable Multicast routing in kernel: Protocol not
> available

[]'s

Rodrigo Costa Colossi
---------------------
Federal University of Sao Carlos
mailto: [email-masked]
http://www.dc.ufscar.br/~rodrigo

---

From: Koji OKAMURA <[email-masked]>
Date: Sat, 23 Aug 1997 10:19:32 +0900

Hi,

> without problems, but I'd used kernel version 2.0.30 with some parameters

How did you solve the memory leak with multicasting in Linux kernel ?
I hear that it will be not solved in 2.0.31.

I have experienced that receiving is no problem and memory leak occurs
on sending.

--
Koji
[email-masked]