Subject: Tunnel positioning

From: "Janne Olsson" <[email-masked]>
Date: Tue, 08 Apr 1997 01:36:01 PDT

On which level in a network is it best to place a tunnel endpoint. What problems 
can be caused by choosing different tunnel endpoint positions relative to the 
RP-point if we use PIM Sparse-mode.

// Janne Olsson
// Mattias Hjelmir

---------------------------------------------------------
Get Your *Web-Based* Free Email at http://www.hotmail.com
---------------------------------------------------------

---

From: Magnus Danielson <[email-masked]>
Date: Tue, 08 Apr 1997 13:06:22 +0200

>>>>> "JO" == Janne Olsson <[email-masked]> writes:

Hej Janne!

 JO> On which level in a network is it best to place a tunnel endpoint. What problems 
 JO> can be caused by choosing different tunnel endpoint positions relative to the 
 JO> RP-point if we use PIM Sparse-mode.

You should get your Mbone connectivity at the same point as you get
your unicast connectivity, that is from your favorite ISP. If they
can't give it, you may need to tunnel througth them, but that is not
recommended.

Regards,
Magnus

---

From: Pat Trainor <[email-masked]>
Date: Tue, 8 Apr 1997 07:12:31 -0400 (EDT)

-----BEGIN PGP SIGNED MESSAGE-----

	I have no idea how this came to me or why. If it's spam, it's
cleverly disguised. If you really need our help, please write to us
directly.

On Tue, 8 Apr 1997, Janne Olsson wrote:

> Return-Path: [email-masked]
> Received: from zephyr.isi.edu (zephyr.isi.edu [128.9.160.160]) by aura.title14.com (8.8.5/8.6.9) with SMTP id GAA00239 for <[email-masked]>; Tue, 8 Apr 1997 06:42:30 -0400
> Received: by zephyr.isi.edu (5.65c/5.61+local-23)
> 	id <AA23157>; Tue, 8 Apr 1997 01:39:51 -0700
> Received: from venera.isi.edu by zephyr.isi.edu (5.65c/5.61+local-23)
> 	id <AA23151>; Tue, 8 Apr 1997 01:39:50 -0700
> Received: from zephyr.isi.edu by venera.isi.edu (5.65c/5.61+local-26)
> 	id <AA06574>; Tue, 8 Apr 1997 01:39:50 -0700
> Received: by zephyr.isi.edu (5.65c/5.61+local-23)
> 	id <AA23089>; Tue, 8 Apr 1997 01:36:21 -0700
> Received: from venera.isi.edu by zephyr.isi.edu (5.65c/5.61+local-23)
> 	id <AA23083>; Tue, 8 Apr 1997 01:36:20 -0700
> Received: from F26.hotmail.com by venera.isi.edu (5.65c/5.61+local-26)
> 	id <AA06418>; Tue, 8 Apr 1997 01:36:20 -0700
> Received: (from root@localhost) by f26.hotmail.com (8.8.3/8.8.3) id BAA18722; Tue, 8 Apr 1997 01:36:02 -0700 (PDT)
> Message-Id: <[email-masked]>
> Received: from 131.115.149.162 by www.hotmail.com with HTTP;
> 	Tue, 08 Apr 1997 01:36:01 PDT
> X-Originating-Ip: [131.115.149.162]
> From: "Janne Olsson" <[email-masked]>
> To: [email-masked]
> Subject: Tunnel positioning
> Content-Type: text/plain
> Date: Tue, 08 Apr 1997 01:36:01 PDT
> Sender: [email-masked]
> Precedence: bulk
> 

pat 	
:)  	
           [email-masked] http://www.title14.com
      www.rimact.com -+- The New England Firefighter's Network

---

From: "John M. Zwiebel" <[email-masked]>
Date: Tue, 08 Apr 1997 08:21:45 -0700

I think I heard you say....

    On which level in a network is it best to place a tunnel endpoint. What pro
	blems 
    can be caused by choosing different tunnel endpoint positions relative to t
	he 
    RP-point if we use PIM Sparse-mode.

Please check out the IOS documentation and for additional information
ftp://ftp-eng.cisco.com/ipmulticast.html has several papers.  

The biggest problem with selecting a tunnel end point is that if you dump
a DVMRP tunnel into the middle of a PIM cloud you'll have trouble with RPF 
checks.  Select the tunnel endpoint so that the multicast and unicast 
topologies are congruent.  PIM uses the unicast routing protocol on your
router to make the RPF check.  

You may want to _consider_ (not necessarily use) the "ip dvmrp unicast-routing"
interface configuration command, if you can not make the unicast and
multicast routing topologies congruent.

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 Fax:   
	Multimedia Group                   Email: [email-masked]