Subject: How is this possible?

From: Yves Lepage <[email-masked]>
Date: Fri, 17 Jan 97 15:45:48 -0500

Hello all,

Here are two tunnels I have:

  206.167.175.6 -> 205.189.33.254 (205.189.33.254) [1/32/tunnel]
  206.167.175.6 -> 206.172.195.1 (cpu257.adsl.sympatico.ca) [1/32/tunnel/leaf]

traceroute to 205.189.33.254 (205.189.33.254), 30 hops max, 40 byte packets
 1  206.167.175.5 (206.167.175.5)  2.026 ms  1.917 ms  3.224 ms
 2  mcgill3-gw.risq.net (132.202.1.111)  9.444 ms  3.379 ms  1.379 ms
 3  mcgill-gw.risq.net (132.202.105.250)  1.938 ms  1.327 ms  1.275 ms
 4  mtl-gw.risq.net (132.202.190.38)  1.958 ms  1.951 ms  1.916 ms
 5  qc-gw.risq.net (132.202.190.9)  2.115 ms  2.119 ms  3.220 ms
 6  205.189.33.49 (205.189.33.49)  9.343 ms *  6.685 ms

The other machine is  probably behind a firewall and ICMP seems to be blocked:

--- cpu257.adsl.sympatico.ca ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 36.007/39.372/45.482 ms

But I have illustrated that I have proper unicast connectivity to these two machines.

Now:

tempest# mtrace 205.189.33.254
Mtrace from 205.189.33.254 to 132.216.30.10 via group 224.2.0.1
Querying full reverse path... * switching to hop-by-hop:
  0  tempest.CC.McGill.CA (132.216.30.10)
 -1  * * * Timed out receiving responses
Perhaps no local router has a route for source 205.189.33.254

tempest# mtrace cpu257.adsl.sympatico.ca
Mtrace from 206.172.195.1 to 132.216.30.10 via group 224.2.0.1
Querying full reverse path... * switching to hop-by-hop:
  0  tempest.CC.McGill.CA (132.216.30.10)
 -1  * * * Timed out receiving responses
Perhaps no local router has a route for source 206.172.195.1

Since both tunnels are up and running (mcast traffic actually makes it to there) and that
I have proper connectivity, why isn't mtrace working to these two places?

Is it because they are cisco routers running PIM?

205.189.33.254 (205.189.33.254) [version 11.2,prune,mtrace]:
206.172.195.1 (cpu257.adsl.sympatico.ca) [version 11.2,prune,mtrace]:

The mrinfo output indicates they both support mtrace.

I need insights.

Thanks,
Yves Lepage

---

From: Bill Fenner <[email-masked]>
Date: Fri, 17 Jan 1997 13:33:13 PST

mtrace doesn't trace to routers; it traces to subnets.  None of the
multicast routers on your subnet have a route for either 205.189.33.254
or 206.172.195.1.  If the routers are supposed to be injecting those
routes, then they are misconfigured.  If they are injecting other
routes, then you should try mtracing to them.

(use kill -USR1 `cat /etc/mrouted.pid` and look at /usr/tmp/mrouted.dump
to verify that you don't have the routes).

  Bill

---

From: Bob Ollerton <[email-masked]>
Date: Fri, 17 Jan 1997 18:48:43 -0500

science.

>----------
>From: 	Yves Lepage[SMTP:[email-masked]]
>Sent: 	Friday, January 17, 1997 3:45 PM
>To: 	[email-masked]
>Subject: 	How is this possible?
>
>Hello all,
>