Subject: Re: Announcing: Interactive Multimedia Jukebox (IMJ)

From: [email-masked] (Kevin C. Almeroth)
Date: Wed, 5 Feb 1997 16:55:17 -0500 (EST)

>>I find it amusing that Turner Broadcasting would be concerned about
>>their content being broadcast on the MBone.  At this point the technology
>>is so much more a limitation than intellectual property that their
>>concern seems a bit quaint.

I agree, but you must realize that from Turner's point of view, their
content is their business.  Without it, they have very little.  A
common belief is that content is the next king and I'm sure many are
aware of the current race to snap up the little content providers.

>>Naturally you are aware that if even
>>3-4 projects (possibly even 1?) like IMJ start broadcasting
>>audio/video on the MBone, the MBone virtual network will not be
>>able to handle it.

I am aware.  However, my personal belief (and even based on some
statistics collected using Mlisten  [self plug :-)]) is that the
MBone is floundering.  Great, everyone loves to watch the shuttle.
Great, everyone wants to put their college radio station on the MBone.
But what next?  Without some new and exciting applications, there
isn't much left to do.

Furthermore, the last couple of MBone BOFs have produced lots of 
interest in "upgrading" the MBone (bandwdith, reliability, etc.) but 
not much progress.  I think one reason is that there isn't anyone
(paying customers that is) screaming for these improvements.  Why?
Back to the no interesting applications problems.

>>I think a larger concern is getting the MBone community to accept such
>>transmissions.  Related to this is the question of what decision process
>>will be used to choose which such transmissions are used for continued
>>testing/development of IP multicast.

I've made my suggestion...  debate as you will.

-Kevin Almeroth

---

From: "James E. [Jed] Donnelley" <[email-masked]>
Date: Wed, 5 Feb 1997 15:13:59 -0800 (PST)

Jed>I find it amusing that Turner Broadcasting would be concerned about
>>>concern seems a bit quaint.
Kevin>I agree, but you must realize that from Turner's point of view, their
>aware of the current race to snap up the little content providers.

Accepting all that completely, putting such content on the
MBone would have absolutely no cost to Turner.  Do you agree?
Have they seen and heard the quality of the multimedia delivery
on the MBone?  The MBone is a toy.  Putting multimedia content
from television "ON" the MBone is somewhat of a misnomer.
What would be there is a drastically reduced "toy" facsimile.
No threat to Turner.  Perhaps someday, but not now.  Now it
seems to me it could only act to their benefit.  Do you talk
to anyone there enough to communicate this concept?

>... my personal belief (and even based on some

Are you kidding?  How many college radio stations are on the MBone?
Everyone may want to, but how many can?  If even two could really
be delivered on the MBone and that capacity could be sold I believe
a market would develop for that delivery.  It wouldn't be college
radio stations buying it ;-)

>But what next?  Without some new and exciting applications, there

Without new carrier technology (higher bandwidth at least and perhaps
some protocol enhancements - e.g. quality of service [though I
am not an ATM fan: http://www.webstart.com/gif/atm.gif
]) new applications are not going to help.  Just more toys.
The MBone will continue to flounder - and for good reason.
I actually think there might be a market for multicast delivery
of some sorts of content - e.g. Web database updates.  However,
for real time multimedia delivery (even audio for which there
is a clear market, even just as a radio replacement),
is beyond the capacity of the MBone to carry in any reasonable
quantity.  Even if a market mechanism were in place for selling
the existing capacity I don't think there is adequate capacity
to allow the market to flourish.

>Back to the no interesting applications problems.

I don't agree.  I don't believe anyone can say that "Internet Phone"
is not an "interesting" application of the Internet (there is clear
demand for POTS), but the demand is pretty minimal at this point.
Nobody can say that radio isn't an "interesting" application
of the airwaves.  Both of these interesting applications can
be put on the Internet today (and are to an extent) - except
for the problem of capacity and the nonexistant market for selling
it.  I am not sure how much of this problem is simply the
cost of the transmission lines.  Certainly that is an important
issue.  Also an issue is the inability to effectively
sell and trade the capacity that is there.

Jed>I think a larger concern is getting the MBone community to accept such
>I've made my suggestion...  debate as you will.

Hmmm.  I think perhaps I didn't communicate my intended point.
Let me clarify by example.

Suppose (by some technical and market miracle) a rock solid
56 kb/sec multicast "channel" on the Internet could be sold
that could reach everyone connected to an ISP (X2).  Do you think
some companies would be willing to bid on access to that
channel?  You know they would.  56kb/s isn't much, but it
is enough for a start if it was solid and could be purchased.
On the day two such channels are available you can start
talking about how important "interesting" applications are
(for all I know the most "interesting" application from a
market viewpoint might be delivering soap operas).

Until then it seems to me that developing more "interesting"
applications is an academic exercise - not devoid
of academic interest, but devoid of commercial interest.
Namely "floundering."  The same delightful floundering that
the ARPAnet/Internet has been doing for years, but which is
quite distinct from the real market developing around todays
Internet/Web.

Jed Donnelley    [email-masked]   Phone: (510) 422-4309
http://www.webstart.com/jed/    FAX: (510) 423-1355

---

From: Jon Crowcroft <[email-masked]>
Date: Thu, 06 Feb 1997 00:00:20 +0000

>>>testing/development of IP multicast.
 
users are never interested, per se, in optimisations - multicast is an
optimisation not an application - internet phone or RMP/IP based
t120/h261 conferencing are applications...as is wb/nte .....

until internet  users are directly or indirectly charged SIGNIFICANT amounts,
they 
a) wont use the mbone
b) wont use web proxy caching servers.....

charging can take the form of unacceptable service - unfortunately,
all the service is commercially unacceptable, but recreationally
accepatable i.e. its a hobbyists paradise.....)

same song, different version....
 jon

---

From: "Carl Malamud [IMS]" <[email-masked]>
Date: Wed, 5 Feb 1997 19:11:54 -0500 (EST)

> MBone would have absolutely no cost to Turner.  Do you agree?

Absolutely not!  If you have a fancy car, would you let somebody
drive it?  Let me give you just one example of objections we had
to get over with HarperCollins to put their Caedmon collection
on-line.  They understood that 8khz audio wouldn't threaten
their tape sales, but they were *very* worried that people would
hear "bad" versions of their material and that would reduce
the overall quality of their brand name.

> radio stations buying it ;-)

Lots of college stations would love to do this, but they are
very worried that they would be violating the ethics of the
mbone.  Look at the flack the North Carolina station ran into
when they went on the air.  Even more importantly, the college
radio station can't do it until their subnet is multicast
enabled and the network czars at most campuses are even more
scared of being politically incorrect.

> quantity.  Even if a market mechanism were in place for selling

Bah ... I don't believe it.  Proper ttls and bandwidth limits
can go a long way.  If we stop thinking in term of a single
global mbone and start treating multicast as part of the 
infrastructure, we'll start seeing services flourish on regional
levels.  Perhaps the answer is to get rid of the mbone and
start looking at many multicast backbones.  Not as pretty, but
it sure scales better and is a good step towards moving this
out of the research project arena and into the general-purpose
infrastructure.

Carl

---

From: Jon Crowcroft <[email-masked]>
Date: Thu, 06 Feb 1997 00:27:23 +0000

>mbone.  

ethics yes (of fair sharing a scrace common resource network); 
copyright no, at least not round here:-) - so long as we admin scope it, uk
universities can _freely_ rebroadcast national tv and radio.....its
part of an educational agreement....and having a well run national
mbone helps just a bit....

 >can go a long way.  

or having a 155 mbps national infrastructure:-)

of course the commercial isps squeal, becuase then they don't get such
a high bandwidth resell factor, and they have to compete on a level (ish) 
playing field with telcos....and their main edge (knowing how to do router
config, web server config and firewalls) is becoming a commodity
item....c.f. ISPs for Dummies, in a bookstore near you, and coming
soon "Mbone for Dummies" and "Internet Phone for Dummies"

again, as infrastructure, though, the mbone oughta be thoroughly
entcing to just those same isps, since it gives you back the bandwith
multiplier again.....e.g. for mirror site loading...

cheers

 jon

---

From: George Michaelson <[email-masked]>
Date: Thu, 06 Feb 1997 11:50:18 +1000

Pricing for data services down here is already  adjusting to reflect web-cache
as a niche price. The economics of cost-saving on offshore link dictates this
and in some cases, boundary routers have port 80 blocks.

Its not impossible to say one of the instances you cite Jon is already being
observed to come into play. 

I would expect that a viable price for MBONE would be a computed rate for
the clear-channel minimum requirements for reticulation, plus the single-point
input from expensive external, divided by the stakeholders who will commit or
something close given viable business constraints, or hole-digging (as in
digging a hole for oneself because you priced it wrong :-)

If we take news as a model, news is increadibly good bytes to sell people 
because the local resale cost assuming regional feeders is way better than
the import costs for those nasty gigs. Its like a 30:1 ratio or better.

If MBONE can be computed into the same region, its a snap. The problem is
that it doesn't seem to be formalized. I'd expect 10:1 to fly.

Anybody doing basic econometrics of mbone dispersion? Any real economists
able to help us do pricing of utility-dispersion issues where the cost is
a function of the ability to prevent others from using the bandwidth for
1:1 usage, which is definately simpler to bill...

Damn. Another fine PhD topic given away.

-George
--
George Michaelson         |  connect.com.au pty/ltd
Email: [email-masked] |  c/o AAPT,
Phone: +61 7 3834 9976    |  level 8, the Riverside Centre,
  Fax: +61 7 3834 9908    |  123 Eagle St, Brisbane QLD 4000

---

From: Petri Helenius <[email-masked]>
Date: Thu, 6 Feb 1997 08:19:30 +0200 (EET)

> radio stations buying it ;-)
Who made you the guy who defines the bandwidth and quality of 'the
mbone'?

My 112kbps, MPEG layer-2 44kHz 16 bit STEREO radio reception is
comparable to FM radio and I wouldn't consider that 'bad'.

Pete

---

From: Petri Helenius <[email-masked]>
Date: Thu, 6 Feb 1997 08:59:59 +0200 (EET)

> out of the research project arena and into the general-purpose
I think with proper engineering you can do both at the same time.
That is, have MBone and regional multicast infrastructure.

Pete

---

From: "Louis A. Mamakos" <[email-masked]>
Date: Thu, 06 Feb 1997 15:50:58 -0500

Oh come now, if this is the perception of how Internet backbone operators
view this technolgy, then it's no surprise that we haven't seen
widespread multicast capability deployed on the Internet.

> soon "Mbone for Dummies" and "Internet Phone for Dummies"

The problem, of course, is that "you" have given the ISP's nothing in
the way of technology which can be deployed in a production network
as a service.  

Would anyone seriously expect to use just RIP as world-wide unicast
routing protocol?  That's what you've effectively asked Internet
operators to do with the currently available technology.  There are
no policy tools by which you can protect your routing domain (and
customers) from misconfigurations which happen on the other side of
the planet and causing service disruptions.  This happen now with
disturbing frequency.

There are no management tools to speak of available.  Sure, there are
wonderful diagnostic tools available which are quite handy if you're
a protocol designer or involved in the IETF, but nothing that a normal
network operations staff is going to be able to effectively use.

> multiplier again.....e.g. for mirror site loading...

Sure, the technology is very interesting.  We have a substantial multicast
IP infrastructure in place with 50 multicast routers dedicated to the task - 
but it's got to work for production applications and for customers, so 
it's not connected to the global MBONE.

All the added hype in the industry recently has shedded mostly heat, and 
only a little light on the real problems which are a barrier to 
universal deployment of multicast IP capability.  To attribute the lack
of interest by "commercial ISPs" to some sort of malice is just plain
unfair and ignores the very real problems that we face trying to turn
this technology into a product that can be supported.   

-- 
Louis A. Mamakos,  Manager, Strategic Technologies  [email-masked],  uunet!louie
UUNET Technologies, Inc.                            Voice: +1 703 206 5823
3060 Williams Drive                                 Fax:   +1 703 208 5390
Fairfax, VA 22031

---

From: "James E. [Jed] Donnelley" <[email-masked]>
Date: Thu, 6 Feb 1997 14:03:19 -0800 (PST)

>Who made you the guy who defines the bandwidth and quality of 'the

I am expressing my opinion.  My opinion is that the delivered
reliability and quality of the multimedia (audio and video) over
the MBone is inadequate for commercialization.  For that matter
I think it is inadequate for most "serious" uses - i.e. uses
where it is important if something is missed.  I don't think it
would be appropriate to use the current MBone for multicasting distance
learning, for example.  How many such multicasts could we get
on with a 512kb/sec aggregate max (still current?)?  How would
it be decided who's multicast would be delivered?  How could
an instructor depend on delivery when a new load (e.g. induced
by some "Internet Phone" calls ;-) may at any time break up
their transmission?  I believe these are fundamental problems
that go to the core of the reason why the Web has "taken off"
commercially and multidestination delivery of real time multimedia
over IP multicast (e.g. MBone) has not.

>comparable to FM radio and I wouldn't consider that 'bad'.

I agree.  As I indicated previously, if somebody could reliably
get a 112kbps multicast channel that people could receive, that
would be a marketable facility.  I even suggested 56k (e.g. X2)
would be adequate if it could be sold and reliably delivered
from a multicaster to thousands or millions of receivers.

While I agree with Jon Crowcroft when he says:

>optimisation not an application.

I believe the scale of the multicast "optimization" (a factor
of N with N recipients) is such that multicast/broadcast
over Internet will be impractical without it.

My point is that something fundamental has to change with the
Internet MBone to realize its potential.  I do not believe
new applications, ttl or bandwidth tinkering, etc. will
suffice to make realtime multimedia delivery over MBone (or
possibly over the Internet in general - e.g. "Internet
Phone" - though I am not as sure about that) a commercially
important service (e.g. the way Web content delivery over
TCP has become commercially important).  I believe
it will require some combination of more bandwidth and
some sort of resource reservation mechanism along with a
mechanism to market (charge for) such reserved bandwidth.

I agree with Kevin Almeroth's observation that the MBone
seems to be floundering - certainly commercially where

>Back to the no interesting applications problems.

my reaction was that the focus on "upgrading" was appropriate
and is the most likely road to transiting IP multicast to economic
significance.

Regarding the comment by Ken Vescovi <[email-masked]>:

>There is a discussion group for these little conversations you
>folks were having.

Though I bridle a bit at the "little" characterization,
I would be happy to switch to such a discussion group.  If there
is such a list, I think perhaps mentioning it early on when
such little discussions as these get started (mea culpa)
would be appropriate.  I am sorry, but I am not aware of such
a list.

>The main mailing list is usually reserved for sending
>technical information.

If that is the case then I won't send such messages to the
list any longer.  However, I share Jon Crowcroft's understanding:

>um, que? i thought this list was for exactly this......
>is there some other list that focusses on this area, or should we
>start an mbone session for discussing this?

While this list is perhaps most useful for detailed technical
discussions, I was not aware of any other place to address related
higher level issues.  It would seem to me useful to have such a place
(e.g. a netnews group?) to refer such discussions to, so if you
know of one, please let me (and the list?) know of it.

---

From: Petri Helenius <[email-masked]>
Date: Fri, 7 Feb 1997 08:15:55 +0200 (EET)

> from a multicaster to thousands or millions of receivers.

What is the target QoS here? The problem with all this technology we
currently are using is that frame loss is built into the system as a
part of it's survival skills. That's what makes it so successful.

Would sub 5% frame loss be adequate QoS or do you require zero loss reception?
 > mechanism to market (charge for) such reserved bandwidth.

I think we need content and the technology will come along to support
the content. Despite the quality concerns you rise above, I used to
keep CBC newsworld open with low volume when I was working. It does
not matter that much for informational content. When we go to movies
and entertainment, they require higher resolution and framerates than
news and learning.
 > and is the most likely road to transiting IP multicast to economic

No content --> no revenue --> no upgrades.

And we need the policy control Louis has been repeatedly beating for.

Pete

---

From: "James E. [Jed] Donnelley" <[email-masked]>
Date: Fri, 7 Feb 1997 09:36:28 -0800 (PST)

[Preamble...  In responce to a request to move this discussion
(with no destination) I dropped my part of this thread to
a private discussion.  However, parts of it keep showing up
on the list.  This seems to me the worst of both worlds -
getting lots of messages to deal with, but not being able
to follow the discussion.  Consequently I am submitting at
least this message (of somewhat more general interest I think?)
back to the list ([email-masked]).  I would be interested
to hear privately from anyone who would like this discussion
moved about how I can help in doing so - even in keeping
what I was trying to keep private off the list (if that
is indeed appropriate).  Thanks.]

>Jed writes:
Petri:>What is the target QoS here? The problem with all this technology we
>Would sub 5% frame loss be adequate QoS or do you require zero loss reception?

I think part of our divergence may be resulting on our focus
on different aspects of "multimedia."  Me on audio and you on
video?  To me the audio is by far the more important aspect
of the communication.  I agree with you that video is
very tolerant of packet losses.  For video signals even much
more than 5% frame loss is generally fine.  The only problems
would likely occur in high motion situations.  For something
like distance learning or even "picture phone" applications,
I expect such losses would not be serious.

However, for the audio even small losses at the wrong time
can completely destroy the value of a communication.  Don't
we share this experience?  I have tried and tried to participate
in MBone presentations of conference sessions, only to have
some packet loss sequence ruin my ability to understand what
was being said.  Granted many of these efforts were in Germany
during the '94-95 time frame when Internet communication there
during the day was terrible.  Still, my limited experience
since has not made me think things are substantively better.
It seems clear to me that Internet (excluding "private"
multicast networks like the UUNet system) packet multicast can't
be a viable commercial enterprise at least until the allocation
of available resources is managed by something other than
peer communication on this list.

>and entertainment, they require higher resolution and framerates than

It seems we strongly disagree on this.  Perhaps I am just looking
at things differently.  I see content everywhere I look.  There
are people talking on the telephone, television, radio, etc.,
etc.  This is all existing content that could be carried
over computer networks - if they were able to carry it.

Just stick with simple telephone communication for example.
This is a huge source of "content" that is currently being
carried by POTS that is a terrific source of relatively
low bandwidth communication that could be carried by
computer networks.  Forget multicast for the moment (though
it is important to the discussion).  Why aren't people
communicating this valued content over computer networks
(e.g. the Internet)?  The main reason is that the available
bandwidth is completely, pitifully, inadequate.  Add to
that the fact that there is no effective mechanism to allocate
the available resources and market them and you have a system
that is "floundering" (to continue the theme...).

>No content --> no revenue --> no upgrades.

I guess I would agree if there literally was no content -
e.g. no ability to produce, transmit, receive, and reproduce
audio/video.  However, we are VERY far past that stage.  The
world is awash with multimedia content that people can
generate and receive, they just can't communicate it
for a price they can afford.  Perhaps it is the price part
of the equation that we are missing and is sending us down
separate paths?

I will accept that if one had some content that was so
compelling that people couldn't do without it (I won't
speculate on what that might be) AND we had no alternative
communication channels (clearly not a valid assumption)
then we could develop a market for packet network multimedia
communication.

The problem is that it has to displace existing nonpacket
communication channels for existing content - first.
That seems clear to me.  Not to you?

>And we need the policy control Louis has been repeatedly beating for.

Sorry, I don't follow this reference.

Also, I would be happy to take this thread private again...

---

From: Colin Perkins <[email-masked]>
Date: Fri, 07 Feb 1997 18:05:03 +0000

>>Would sub 5% frame loss be adequate QoS or do you require zero loss reception?
[...]
>since has not made me think things are substantively better.

It still amazes me how few people have tried tools which use audio
redundancy to _vastly_ improve the perceived quality of an mbone session!
The use of DVI/DVI encoding, instead of a single PCM stream will produce
audio which is understandable with much higher rates of loss, and will use
roughly the same amount of bandwidth as the PCM.

See http://www-mice.cs.ucl.ac.uk/mice/rat/
    http://zenon.inria.fr/rodeo/fphone/
    http://www.precept.com/
for information and tools which support this format.

Colin

---

From: Piete Brooks <[email-masked]>
Date: Fri, 07 Feb 1997 18:32:00 +0000

> redundancy to _vastly_ improve the perceived quality of an mbone session!

Is it compatible with the de facto standard, vat ?          [ rhetorical ! ]

If you could arrange that a rat transmitter could use redundant streams and
vat clients could receive them (and, say, just discard the second), then I
think rat would take off, but until then, I'm not going to use it.
I realise the work has to be done in vat rather than rat (assuming rat can't
use two separate channels for the two streams), and it'll take a while before
the majority of vat users are running the "forwards compatible" code,
but I suspect that that's where you need to get the changes made ...

[[ I'd *love* to use rat -- vat is usually unbearable -- please help me ! ]]

---

From: Colin Perkins <[email-masked]>
Date: Fri, 07 Feb 1997 18:47:05 +0000

>Is it compatible with the de facto standard, vat ?          [ rhetorical ! ]

As you are clearly aware, rat is compatible with vat, unless you turn
on redundancy. The relative advantages/disadvantages of the two tools 
if redundancy is not used is not something I'm about to discuss!  :-)

>[[ I'd *love* to use rat -- vat is usually unbearable -- please help me ! ]]

One area we are working on is a transcoder, which will convert between
multiple audio formats, including adding/removing redundancy. Once this 
is complete, it will be easy to "simulcast" sessions both with and without
redundancy.

Of course, the real solution is to get support for redundancy into vat....

Colin

---

From: Hakan Lennestal <[email-masked]>
Date: Fri, 07 Feb 1997 19:59:25 +0100

> Is it compatible with the de facto standard, vat ?          [ rhetorical ! ]

There is still another approach to the problem that cold (easily ?) be included
into rat, fphone, etc. And that is when handling an ordinary vat stream to
repeat the last received frame when packet loss occur, and to lower the
volume when the frame has to be repeated more then once until it is silent
after ~ 0.5 sec.
This approach is used in the GSM mobile phone system and it is normally not
possible to hear the handoffs even though the phone does not receive
any voice frames for up to about 0.5 secs.

Regards.

/Håkan

---

From: Colin Perkins <[email-masked]>
Date: Fri, 07 Feb 1997 19:12:22 +0000

--> Hakan Lennestal writes:
>> > redundancy to _vastly_ improve the perceived quality of an mbone sess=
>ion!
>>=20

Recent versions of RAT already do something very similar to this.

Colin

---

From: Hakan Lennestal <[email-masked]>
Date: Fri, 07 Feb 1997 20:17:16 +0100

> Recent versions of RAT already do something very similar to this.

Great !

Then there is already quite something to be gained by using rat also
on ordinary vat streams !

Regards.

/Håkan

---

From: Piete Brooks <[email-masked]>
Date: Fri, 07 Feb 1997 20:58:08 +0000

> on redundancy.

Hah -- the raison d'etre of rat is redundancy !!

> multiple audio formats, including adding/removing redundancy.

IMHO that may be of use (in some cases), but not the way to get rat into use.
A compatible vat/rat is the way to move the community over to rat.

> Once this is complete, it will be easy to "simulcast" sessions both with
> and without redundancy.

... doubling the MBone usage .... :-(

> Of course, the real solution is to get support for redundancy into vat....

... at which point there isn't enough reasom to move to rat !
I'd say "merge rat into vat" if that's what you want ...

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 7 Feb 1997 22:17:07 +0100 (MET)

> I'd say "merge rat into vat" if that's what you want ...

What's the advantage of vat over rat ?
Can rat do the internal bus protocol with vic ?

---

From: Petri Helenius <[email-masked]>
Date: Sat, 8 Feb 1997 01:29:13 +0200 (EET)

> over computer networks - if they were able to carry it.

The problem here that you and other people saying the same things are
scaring the people that _OWN_ the rights to transmit the content away
from using the technology of IP multicast. You are scaring them to the
unicast replication way of dealing things since "it's ready today".
 > that is "floundering" (to continue the theme...).

This is untrue. There is bandwidth there. If it does not cross your
whereabouts, too bad :-)
 > of the equation that we are missing and is sending us down

Yes, you are missing the point of who owns the content.
 > Also, I would be happy to take this thread private again...
You just cannot make up your mind?

Pete