Subject: mcast routing question

From: Yves Lepage <[email-masked]>
Date: Tue, 28 May 96 11:01:20 -0400

Hi all,

I am somewhat unfamiliar with routing protocols interaction and I was wondering:

If we have a machine that sends A/V out to a tunnel to MCI (DVMRP all the way) and to
a second tunnel to another machine and there would be a tunnel to JvNC (PIM) from
this second machine. What would happen?

Would MCI or JvNC refuse the packets from one of the tunnels?

if no, how would the collison be handled? Would an area within and around JvNC get the
packets from the second machine while MCI would get the packets from the first tunnel
and some gray area between the two be burdened with duplicate packets?

Thanks in advance,
Yves Lepage

---

From: Bill Fenner <[email-masked]>
Date: Tue, 28 May 1996 14:15:25 PDT

In message <[email-masked]> you write:
>If we have a machine that sends A/V out to a tunnel to MCI (DVMRP all
>the way) and to a second tunnel to another machine and there would be a
>tunnel to JvNC (PIM) from this second machine. What would happen?
>

No.

>if no, how would the collison be handled? Would an area within and
>around JvNC get the packets from the second machine while MCI would get
>the packets from the first tunnel

Yes.

>and some gray area between the two be burdened with duplicate packets?

No.  Multicast routing algorithms try to prevent duplicate packets.

DVMRP does this by using the metrics along the paths to find the
shortest reverse path from a source.  It then uses that path to
receive packets, and ignores any other possible paths it might
have.  It tie-breaks between equal length paths.

  Bill