Subject: Re: Multicast routing on Linux ?

From: Carles Mateu <[email-masked]>
Date: Wed, 2 Jul 1997 11:36:31 +0200

>
> Has anyone got multicast tunnelling to work on Linux 2.0.30 ?
>
        In the University of Lleida, the multicast router was
        a Linux 2.0.30 (it's now down due to network reorganizations).

> Current setup:
>
> Linux box:  2.0.30 with necessary experimental kernel options turned on
>             mrouted 3.9beta2 (or the pre-built for linux mrouted 3.8)
>             sdr 2.4a6
>             wb 1.59
>
> tunnels with ttl 1 threshold 1 rate_limit 0 to/from
>
> Alpha box:  DU4.0B (+patches) or DU4.0A
>             mrouted 3.9beta2
>             sdr 2.4a6
>             wb 1.59
>
> tunnels with ttl 1 threshold 1 rate_limit 0 to/from
>
> Alpha box:  DU4.0A
>             mrouted 3.9beta2
>             sdr 2.4a6
>             wb 1.59
>
> A session created on the same network as either of the two alphas appears
> on the network of the other alpha with no problem. Very occasionally it
> appears on the network of the Linux machine as well.
>
> If a user on the linux network joins such a session they see things as
> they should, but the alpha users never see them.
>
> A linux user can join a session that doesn't appear in his sdr window by
> giving the correct options to wb, but you get the same behaviour as above.
>
> A session created on the linux network never seems to appear on the networks
> the alphas are routing for.
>
> I've followed the FAQs, dug around in mailing list archives, and I still
> can't see if it's something I'm doing wrong, a linux bug, an alpha bug or
> an interoperability bug.  At the moment I guess I'm tending to think of it
> more as a linux bug.

        It can be a Linux "bug". With some network cards we weren't able
        to set up a mrouted cause such network drivers didn't worked
        properly in MULTICAST mode. At the end the problem was solved
        bye using very standard network cards (NE2000/ISA).

        The other thing is that you must install ipip module and add
        the multicast route by hand:

        route add -net 224.0.0.0 netmask 240.0.0.0 dev ethx

             salut,

       :-CARLES-:
   [email-masked]

-----------------------------------------------------------------
      ___           ___           ___           ___
     /\  \         /\  \         /\  \         /\__\
    /::\  \       /::\  \       /::\  \       /:/  /
   /:/\:\  \     /:/\:\  \     /:/\:\  \     /:/__/
  /::\~\:\__\   /:/  \:\  \   /::\~\:\  \   /::\  \ ___
 /:/\:\ \:|__| /:/__/ \:\__\ /:/\:\ \:\__\ /:/\:\  /\__\
 \:\~\:\/:/  / \:\  \ /:/  / \/__\:\ \/__/ \/__\:\/:/  /
  \:\ \::/  /   \:\  /:/  /       \:\__\        \::/  /
   \:\/:/  /     \:\/:/  /         \/__/        /:/  /
    \::/__/       \::/  /                      /:/  /
     ~~            \/__/                       \/__/

---

From: Brad Parker <[email-masked]>
Date: Thu, 03 Jul 1997 22:19:56 -0400

>> Has anyone got multicast tunnelling to work on Linux 2.0.30 ?

I found several bugs in the 2.0.27-2.0.30 linux kernels with mbone
routing.  My opinion is that these kernels may work "ok" as the
destination of an mbone tunnel but none can source a tunnel.

There were several bugs in the route socket code which were agravated
by some poor choices of constants in the code.  Not fatal but certainly
bugs which could cause lost prune resquests.

The outbound tunnel bugs were more severe and would cause outbound packets
(when encapsulated or 'tunneled') to be sent to the wrong ip destination.

I put fixes for these up on my web site and submitted them - they may
be in 2.0.31 or .32...

-brad

---

From: [email-masked] (pae jung hee)
Date: Fri, 04 Jul 1997 14:57:00 +0900